Social Security Benefit Calculator

Collapse All Collapse All Expand All Expand All
Anypia Programmer's Documentation
Close
Social Security Benefit Calculator

The Social Security Benefit Calculator.

Collapse Expand Description

The code used to compute Social Security benefits in the Social Security Benefit Calculator and other programs is comprised of two libraries, named Misc Library and PiaData Library. The code in the Misc Library provides some basic functions independent of benefit calculations. The code in the PiaData Library is used to calculate benefits.

All of the code for both libraries is in subdirectories of the oactobjs32 directory. Generally, the header files for both libraries are in the include subdirectory, while the source files are in the misc and piadata subdirectories. A few header and source files are in the windows subdirectory, where the code is specific to the Windows platform.

All of the code for output from the Social Security Benefit Calculator is in the PiaOut Library, stored in the piaout subdirectory of the oactobjs32 directory.

The primary calculation class is PiaCal (in the PiaData Library), which is the parent of classes that actually control the calculation of a Social Security benefit.

Contents | Index | Home
What do you think about this topic? Send feedback!


PiaData Library

PiaData Library
Legend Topics

The piadata library part of the oactobjs library.

Collapse Expand Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Variables | The following table lists variables in this documentation.
Files | The following table lists files in this documentation.
Collapse Expand Classes
Name | Description
Assumptions | Parent of classes that manage the average wage and benefit increase assumptions.
AssumptionsFile | Reads the average wage and benefit increase parameters from disk storage.
AssumptionsNonFile | Contains the average wage and benefit increase assumptions (it does not read from disk).
AssumptionType | The assumption types (about future average wage and benefit increases) allowed in the piadata library.
AverageWage | Manages an array of average wage indexing amounts, or any other earnings series.
AwbiData | Manages the historical Social Security parameters.
AwbiDataFile | Manages the historical Social Security parameters stored in a file.
AwbiDataNonFile | Manages the historical Social Security parameters stored in arrays in the code.
Awinc | Manages a vector of projected average wage increases.
AwincDoc | Abstract parent of classes that manage the file of projected average wage increases.
AwincFile | Manages the file of projected average wage increases stored on disk.
AwincNonFile | Manages the file of projected average wage increases stored in static arrays.
BaseChangeType | The wage base change types allowed in the piadata library.
BaseYear | Parent of classes that manage the computation year for a pia program.
BaseYearFile | Manages the computation year for a pia program where it is gotten from disk.
BaseYearNonFile | Manages the computation year for a pia program where it is stored with the code.
BendPia | Manages the array of bend points used in the PIA formula.
BendMfb | Manages the array of bend points used in the MFB formula.
BenefitAmount | Represents a benefit amount for one year.
BenefitAmountArray | Manages an array of BenefitAmount's.
Bic | Represents one 2-character bic (Beneficiary Identification code) code.
Biproj | Abstract parent of classes that manage the file of projected benefit increases.
BiprojFile | Manages the file of projected benefit increases stored on disk.
BiprojNonFile | Manages the file of projected benefit increases stored in arrays.
BpMfbOut | Manages the array of mfb formula bend points.
BpPiaOut | Manages the array of pia formula bend points.
Catchup | Manages the catch-up benefit increases required to calculate a Social Security benefit.
CatchupDoc | Abstract parent of classes that manage a file of catch-up benefit increases.
CatchupFile | Manages a file of catch-up benefit increases stored on disk.
CatchupIncreases | Manages the catch-up benefit increases for one year of eligibility.
CatchupNonFile | Manages a file of catch-up benefit increases stored in arrays.
ChildCareCalc | Manages the functions required for calculation of a wage indexed Social Security benefit using childcare dropout years.
ChildCareCalcLC | Manages the functions required for calculation of a wage indexed Social Security benefit using childcare dropout years, with law changes.
CompPeriod | Manages the number of elapsed years, dropout years, and computation years.
Config | Parent of classes that manage the configuration information used by the PIA calculation program.
ConfigFile | Manages the configuration information used by the PIA calculation program, stored in a file.
ConfigNonFile | Manages the configuration information used by the PIA calculation program, stored with the code.
DibGuar | Manages the functions required for calculation of a disability guarantee Social Security benefit.
DibGuarLC | Manages the functions required for calculation of a disability guarantee Social Security benefit with law changes.
DisabPeriod | Manages a period of disability.
DisInsCode | Represents one disability insured status code.
DisInsCodeArray | Manages an array of annual DisInsCode's.
EarnProject | Manages an array of earnings, with forward and backward projections and specified levels of earnings.
FieldOfficeInfo | Parent of classes that manage the name and address of the field office.
FieldOfficeInfoFile | Reads and writes field office information from and to a file.
FieldOfficeInfoNonFile | Manages field office information not stored in a file (but its data may be saved in an .ini file).
FreezeYears | Manages the years in a freeze period. The years may be wholly or partially within a freeze period.
FrozMin | Manages the functions required for calculation of a frozen minimum Social Security benefit.
InsCode | Represents one insured status code.
InsCodeArray | Manages an array of annual insured status codes.
LawChange | The basic class that manages all of the extra data and functions required for one change in law concerning benefit calculations.
LawChangeAGE65COMP | Parameters for a proposal to increase the number of elapsed years in a pia calculation.
LawChangeALLEARN | Parameters for a proposal to use all years of earnings in an AIME calculation.
LawChangeArray | Manages an array of LawChange's.
LawChangeBPFRACWAGE | Parameters for a proposal to increase the bend points in the benefit formula by a fraction of average wage growth.
LawChangeBPMINCONST | Parameters for a proposal to increase the bend points in the benefit formula by the growth in wages minus a specified rate.
LawChangeBPSPECRATE | Parameters for a proposal to increase the bend points in the benefit formula by a specified growth rate.
LawChangeCHILDCARECREDIT | Parameters for a proposal to provide child care credits.
LawChangeCHILDCAREDROPOUT | Parameters for a proposal to provide child care dropout years.
LawChangeCOLACHANGE | Parameters for a proposal to change the cost-of-living benefit increases.
LawChangeDECLINEPERC | Parameters for a proposal to decrease the benefit formula percentages by a constant rate.
LawChangeDROPOUTCHG | Parameters for a proposal to reduce the number of dropout years in a pia calculation.
LawChangeMARRLENGTH | Parameters for a proposal to change the length of marriage requirement for divorced spouse benefits.
LawChangeNEWFORMULA | Parameters for a proposal to change the pia formula bend points and/or percentages.
LawChangeNEWSPECMIN | Parameters for a proposal to change the special minimum pia calculation.
LawChangeNRACHANGE | Parameters for a proposal to change the full retirement age.
LawChangeOut | Manages the output file of law change descriptions.
LawChangePSAACCT | Parameters for a proposal to introduce individual accounts.
LawChangeRead | Reads law changes stored in a file.
LawChangeTAXBENCHG | Parameters for a proposal to change the taxation of benefits.
LawChangeTAXRATECHG | Parameters for a proposal to change the OASDI tax rates.
LawChangeWAGEBASECHG | Parameters for a proposal to change the OASDI and/or old-law wage bases.
LawChangeWIDFACTOR | Parameters for a proposal to change the factor for an aged widow(er) benefit.
LawChangeWIFEFACTOR | Parameters for a proposal to change the factor for an aged spouse benefit.
LawChangeWrite | Writes a set of law changes to a file.
MilServDates | Manages one period of military service dates.
MilServDatesVec | Manages all the military service dates records for one ssn.
OldPia | Parent of all methods using pia tables in the calculation of a Social Security benefit.
OldStart | Manages the functions required for calculation of an old start Social Security benefit.
OldStartLC | Manages the functions required for calculation of an old start Social Security benefit with law changes.
Pebs | Manages most of the data required to prepare and print out the results of a Statement calculation.
PercMfb | Manages the array of percentages used in the MFB formula.
PercPia | Manages the array of percentages used in the PIA formula.
PercPiaOut | Manages the array of pia formula percentages, projected for all years.
PiaCal | Parent of all classes that manage the functions required for calculation of a Social Security benefit.
PiaCalAny | Manages the additional functions required for calculation of a Social Security benefit in the Anypia program.
PiaCalLC | Manages all of the law-change functions required for calculation of a Social Security benefit.
PiaCalPL | Manages all of the present law functions required for calculation of a Social Security benefit.
PiaData | Manages all of the worker-specific amounts calculated in preparation for and during the calculation of a Social Security benefit.
PiaDataArray | Manages an array of PiaData's, representing one family.
PiaMethod | Parent of the various methods required for calculation of a Social Security benefit.
PiaParams | Abstract parent of classes to manage the Social Security parameters required to calculate a Social Security benefit.
PiaParamsAny | Manages the additional Social Security parameters required to calculate Social Security benefits in the Anypia program.
PiaParamsLC | Manages the changed law Social Security parameters required to calculate Social Security benefits.
PiaParamsLCTR | Manages the changed law Social Security parameters, already projected based on a Trustees Report assumption.
PiaParamsPL | Manages the present law Social Security parameters required to calculate Social Security benefits.
PiaParamsTR | Manages the present law Social Security parameters required to calculate Social Security benefits, with projected values set to Trustees Report assumptions.
PiaRead | Reads the basic data required to calculate a Social Security benefit.
PiaReadAny | Reads the data required to calculate a Social Security benefit for the Anypia program.
PiaTable | Manages the functions required for calculation of a Pia Table Social Security benefit.
PiaTableLC | Manages the functions required for calculation of a Pia Table Social Security benefit, including changes from present law.
PiaWrite | Writes out the basic data required to calculate a Social Security benefit.
PiaWriteAny | Writes out the data required to calculate a Social Security benefit for the Anypia program.
Pib50Mfb | Manages the 1950 pib-mfb conversion figures.
Pib50Pib | Manages the 1950 pib-pia conversion figures.
Pib52Ame | Manages the 1952 pib-ame conversion figures.
Pib52Mfb | Manages the 1952 pib-mfb conversion figures.
Pib54Ame | Manages the 1954 pib-ame conversion figures.
Pib54Mfb | Manages the 1954 pib-mfb conversion figures.
Pib54Pia | Manages the 1954 pib-pia conversion figures.
Pib58Ame | Manages the 1958 pib-ame conversion figures.
Pib58Pib | Manages the 1958 pib-pia conversion figures.
Pifc | Represents a pia factor code (type of Social Security pia).
PortionAime | Manages the array of portions of AIME in the PIA formula.
PresValFacs | Manages an array of present value factors.
Psa | Manages the (theoretical) PSA accounts.
Qc | Handles calculations with quarters of coverage for one year.
Qcamt | Manages an array of quarter of coverage amounts.
QcArray | Manages an array of annual quarters of coverage.
QcPacked | Holds 8 annual quarters of coverage amounts in one word (4 bytes). Each value is in 4 bits, and can take values from 0 to 4.
RailRoadData | Manages the railroad data for one worker.
ReindWid | Manages the functions required for calculation of a reindexed widow(er) Social Security benefit.
ReindWidLC | Manages the functions required for calculation of a reindexed widow(er) Social Security benefit with law changes.
RetireTest | Contains all of the retirement test exempt amounts and functions to use them.
Rtea62 | Manages the annual retirement test exempt amount projections under full retirement age.
Rtea62m | Manages the monthly retirement test exempt amount projections under full retirement age.
Rtea65 | Manages the annual retirement test exempt amount projections over full retirement age.
Rtea65m | Manages the monthly retirement test exempt amount projections over full retirement age.
RteaHigh | Manages the upper annual retirement test exempt amounts when there were two tiers.
RtGeneral | Parent of classes to manage the retirement test exempt amount projections.
ScaledEarnFactors | Manages scaled earner amounts.
Secondary | Contains the information about a secondary benefit.
SecondaryArray | Manages an array of Secondary's.
Sga | Contains all of the SGA amounts and functions to use them.
SgaBlindA | Manages the annual SGA amounts (historical and projected) for blind beneficiaries.
SgaBlindM | Manages the monthly SGA amounts (historical and projected) for blind beneficiaries (as of December).
SgaGeneral | Parent of classes to manage the SGA (Substantial Gainful Activity) amounts (historical and projected).
SgaMaxA | Manages the annual SGA maximum amounts(historical and projected) for non-blind beneficiaries.
SgaMaxM | Manages the monthly SGA maximum amounts (historical and projected) for non-blind beneficiaries (as of December).
SgaMinA | Manages the annual SGA minimum amounts (historical and projected) for non-blind beneficiaries.
SgaMinM | Manages the monthly SGA minimum amounts (historical and projected) for non-blind beneficiaries (as of December).
SpecMin | Manages the functions required for calculation of a special minimum Social Security benefit.
SpecMinLC | Manages the functions required for calculation of a special minimum Social Security benefit, including changes from present law.
TaxBenefits | Contains the functions required to calculate the tax on a Social Security benefit.
TaxBenefitsLC | Contains the functions required to calculate the tax on a Social Security benefit with law changes.
TaxData | Manages the Social Security payroll and self-employed taxes paid by a worker.
TaxRates | Abstract parent of classes that manage the Social Security payroll and self-employed tax rates.
TaxRatesLC | Manages the Social Security payroll and self-employed tax rates, with changes from present law.
TaxRatesPL | Manages the present law Social Security payroll and self-employed tax rates.
TransGuar | Manages the functions required for calculation of a transitional guarantee Social Security benefit.
TransGuarLC | Manages the functions required for calculation of a transitional guarantee Social Security benefit, with changes from present law.
UserAssumptions | Manages all the assumptions about future average wage increases, wage bases, benefit increases, and catch-up benefit increases that a user might specify.
WageBase | Manages the OASDI wage base projections.
WageBaseGeneral | Ancestor of the classes that manage the wage base projections.
WageBaseHI | Manages the HI wage base projections.
WageBaseLC | Manages the OASDI wage base projection with law changes.
WageBaseOldLaw | Manages the old-law OASDI wage base projections.
WageBaseOldLawLC | Manages the old-law OASDI wage base projection with law changes.
WageInd | Manages the functions required for calculation of a wage indexed Social Security benefit.
WageIndGeneral | Parent of all classes that manage the functions required for calculation of a wage indexed Social Security benefit.
WageIndLC | Manages the functions required for calculation of a wage indexed Social Security benefit, with changes from present law.
WageIndNonFreeze | Manages the functions required for calculation of a wage indexed non-freeze Social Security benefit.
WorkerData | Manages the basic data required to calculate a Social Security benefit.
WorkerDataArray | Manages an array of WorkerData's, representing one family.
WorkerDataGeneral | The abstract parent of all classes that manage the basic data required to calculate a Social Security benefit.
Collapse Expand Files
Name | Description
Assumptions.cpp | Functions for the Assumptions class - parent of classes that manage the average wage and benefit increase assumptions.
Assumptions.h | Declarations for the Assumptions class - parent of classes that manage the average wage and benefit increase assumptions.
AssumptionsFile.cpp | Functions for the AssumptionsFile class that reads the average wage and benefit increase parameters from disk storage.
AssumptionsFile.h | Declarations for the AssumptionsFile class that reads the average wage and benefit increase parameters from disk storage.
AssumptionsNonFile.cpp | Functions for the AssumptionsNonFile class that contains the average wage and benefit increase parameters (it does not read from disk).
AssumptionsNonFile.h | Declarations for the AssumptionsNonFile class that contains the average wage and benefit increase parameters (it does not read from disk).
AssumptionType.cpp | Functions of the AssumptionType class containing the assumption types allowed in the piadata library.
AssumptionType.h | Declaration of the AssumptionType class containing the assumption types allowed in the piadata library.
avgwg.cpp | Functions needed for AverageWage class to manage array of average wages.
avgwg.h | Declarations needed for AverageWage class to manage array of average wages.
awbidat.cpp | Functions of the AwbiData class to manage historical Social Security parameters.
awbidat.h | Declaration of the AwbiData class to manage historical Social Security parameters.
AwbiDataFile.h | Declaration of the AwbiDataFile class to manage historical Social Security parameters stored in a file.
AwbiDataNonFile.h | Declaration of the AwbiDataNonFile class to manage historical Social Security parameters stored with the code.
awbidtfl.cpp | Functions of the AwbiDataFile class to manage historical Social Security parameters stored in a file.
awbidtnf.cpp | Functions of the AwbiDataNonFile class to manage historical Social Security parameters stored with the code.
awinc.cpp | Functions for the Awinc class to manage a vector of average wage increases.
awinc.h | Declarations for the Awinc class to manage a vector of average wage increases.
AwincDoc.cpp | Functions for the AwincDoc class to manage average wage increases.
AwincDoc.h | Declarations for the AwincDoc class to manage average wage increases.
AwincFile.h | Declarations needed for AwincFile class to manage average wage increases stored on disk.
awincfl.cpp | Functions needed for AwincFile class to manage average wage increases stored on disk.
awincnf.cpp | Functions for the AwincNonFile class to manage average wage increases stored in static arrays.
AwincNonFile.h | Declarations for the AwincNonFile class to manage average wage increases stored in static arrays.
BaseChangeType.cpp | Functions of the BaseChangeType class with the wage base change types allowed in the piadata library.
BaseChangeType.h | Declaration of the BaseChangeType class with the wage base change types allowed in the piadata library.
baseyear.cpp | Functions for the BaseYear class - parent of classes that manage the computation year for a pia program.
baseyear.h | Declarations for the BaseYear class - parent of classes that manage the computation year for a pia program.
BaseYearFile.h | Declarations for the BaseYearFile class to manage the computation year on disk.
BaseYearNonFile.h | Declarations for the BaseYearNonFile class to manage the computation year stored internally.
baseyrfl.cpp | Functions for the BaseYearFile class to manage the computation year on disk.
baseyrnf.cpp | Functions for the BaseYearNonFile class to manage the computation year stored internally.
BendPoints.h | Includes for the class that handles PIA and MFB formula bend points.
BenefitAmount.cpp | Functions for the BenefitAmount class to handle Social Security benefit amount.
BenefitAmount.h | Declarations for the BenefitAmount class to handle Social Security benefit amount.
BenefitAmountArray.cpp | Functions for the BenefitAmountArray class of an array of Social Security benefit amounts.
BenefitAmountArray.h | Declarations for the BenefitAmountArray class of an array of Social Security benefit amounts.
Bic.cpp | Functions for the Bic class to manage bic (Beneficiary Identification code) code.
bic.h | Declarations for the Bic class to manage bic (Beneficiary Identification code) code.
biproj.cpp | Functions for the Biproj class to manage projected benefit increases.
biproj.h | Declarations for the Biproj class to manage projected benefit increases.
BiprojFile.h | Declarations for the BiprojFile class to manage projected benefit increases stored on disk.
biprojfl.cpp | Declarations for the BiprojFile class to manage projected benefit increases stored on disk.
biprojnf.cpp | Functions for the BiprojNonFile class to manage projected benefit increases stored in arrays.
BiprojNonFile.h | Declarations for the BiprojNonFile class to manage projected benefit increases stored in arrays.
bpmfbout.cpp | Functions for the BpMfbOut class to manage array of mfb formula bend points.
bpmfbout.h | Declarations for the BpMfbOut class to manage array of mfb formula bend points.
bppiaout.cpp | Functions for the BpPiaOut class to manage array of pia formula bend points.
bppiaout.h | Declarations for the BpPiaOut class to manage array of pia formula bend points.
cachpdoc.cpp | Functions for the CatchupDoc class to manage a set of catch-up benefit increases.
cachup.cpp | Functions for the CatchupIncreases and Catchup classes to manage catch-up benefit increases.
cachup.h | Declarations for the CatchupIncreases and Catchup classes to manage catch-up benefit increases.
cachupf.h | Declarations for the CatchupDoc class to manage a set of catch-up benefit increases.
cachupfl.cpp | Functions for the CatchupFile class to manage file of catch-up benefit increases.
cachupnf.cpp | Functions for the CatchupNonFile class to manage a set of catch-up benefit increases stored in arrays.
CatchupFile.h | Declarations for the CatchupFile class to manage file of catch-up benefit increases.
CatchupNonFile.h | Declarations for the CatchupNonFile class to manage a set of catch-up benefit increases stored in arrays.
ChildCareCalc.cpp | Functions for the ChildCareCalc class to manage childcare dropout year pia calculations.
ChildCareCalc.h | Declarations for the ChildCareCalc class to manage childcare dropout year pia calculations.
ChildCareCalcLC.cpp | Functions for the ChildCareCalcLC class to manage childcare dropout year pia calculations, with law changes.
ChildCareCalcLC.h | Declarations for the ChildCareCalcLC class to manage childcare dropout year pia calculations, with law changes.
comppd.h | Declarations for the CompPeriod class to manage computation period variables.
CompPeriod.cpp | Functions for the CompPeriod class to manage computation period variables.
config.cpp | Functions for the Config class to manage configuration information used by the PIA calculation program.
config.h | Declarations for the Config class to manage configuration information used by the PIA calculation program.
configFile.cpp | Functions for the ConfigFile class to manage configuration information used by the PIA calculation program stored on disk.
ConfigFile.h | Declarations for the ConfigFile class to manage configuration information used by the PIA calculation program stored on disk.
configNonFile.cpp | Functions for the ConfigNonFile class to manage configuration information used by the PIA calculation program stored internally.
ConfigNonFile.h | Declarations for the ConfigNonFile class to manage configuration information used by the PIA calculation program stored internally.
DebugCase.cpp |
DebugCase.h |
DibGuar.cpp | Functions for the DibGuar class to manage disability guarantee pia calculations.
DibGuar.h | Declarations for the DibGuar class to manage disability guarantee pia calculations.
DibGuarLC.cpp | Functions for the DibGuarLC class to manage disability guarantee pia calculations with law changes.
DibGuarLC.h | Declarations for the DibGuarLC class to manage disability guarantee pia calculations with law changes.
dinscode.cpp | Functions for the DisInsCode class representing a disability insured status code.
dinscode.h | Declarations for the DisInsCode class representing a disability insured status code.
DisabPeriod.cpp | Functions for the DisabPeriod class to manage a period of disability.
DisabPeriod.h | Declarations for the DisabPeriod class to manage a period of disability.
DisInsCodeArray.cpp | Functions for the DisInsCodeArray class to manage an array of disability insured status codes.
DisInsCodeArray.h | Declarations for the DisInsCodeArray class to manage an array of disability insured status codes.
EarnProject.cpp | Functions for the EarnProject class to handle an array of earnings, with forward and backward projections and specified levels of earnings.
EarnProject.h | Declarations for the EarnProject class to handle an array of earnings, with forward and backward projections and specified levels of earnings.
FieldOfficeInfoFile.h | Declarations for the FieldOfficeInfoFile class to manage field office information stored on disk.
FieldOfficeInfoNonFile.h | Declarations for the FieldOfficeInfoNonFile class to manage field office information stored in memory.
foinfo.cpp | Functions for the FieldOfficeInfo class to manage field office information.
foinfo.h | Declarations for the FieldOfficeInfo class to manage field office information.
foinfofl.cpp | Functions for the FieldOfficeInfoFile class to manage field office information stored on disk.
foinfonf.cpp | Functions for the FieldOfficeInfoNonFile class to manage field office information stored in memory.
FrozMin.cpp | Functions for the FrozMin class to manage frozen minimum pia calculations.
FrozMin.h | Declarations for the FrozMin class to manage frozen minimum pia calculations.
frzyrs.cpp | Functions for the FreezeYears class to manage freeze period variables.
frzyrs.h | Declarations for the FreezeYears class to manage freeze period variables.
inscode.cpp | Functions for the InsCode class to manage an insured status code.
inscode.h | Declarations for the InsCode class to manage an insured status code.
InsCodeArray.cpp | Functions for the InsCodeArray class to manage an array of insured status codes.
InsCodeArray.h | Declarations for the InsCodeArray class to manage an array of insured status codes.
LawChange.cpp | Functions for the LawChange class to manage law-change parameters.
LawChange.h | Declarations for the LawChange class to manage law-change parameters.
LawChangeAGE65COMP.cpp | Functions for the LawChangeAGE65COMP class to manage parameters for a proposal to increase the number of elapsed years in a pia calculation.
LawChangeAGE65COMP.h | Declarations for the LawChangeAGE65COMP class to manage parameters for a proposal to increase the number of elapsed years in a pia calculation.
LawChangeALLEARN.cpp | Functions for the LawChangeALLEARN class to manage parameters for a proposal to use all years of earnings in an AIME calculation.
LawChangeALLEARN.h | Declarations for the LawChangeALLEARN class to manage parameters for a proposal to use all years of earnings in an AIME calculation.
LawChangeArray.cpp | Functions for the LawChangeArray class to manage an array of LawChange parameters.
LawChangeArray.h | Declarations for the LawChangeArray class to manage an array of LawChange parameters.
LawChangeBPFRACWAGE.cpp | Functions for the LawChangeBPFRACWAGE class to manage parameters for a proposal to increase the bend points in the benefit formula by a fraction of average wage growth.
LawChangeBPFRACWAGE.h | Declarations for the LawChangeBPFRACWAGE class to manage parameters for a proposal to increase the bend points in the benefit formula by a fraction of average wage growth.
LawChangeBPMINCONST.cpp | Functions for the LawChangeBPMINCONST class to manage parameters for a proposal to increase the bend points in the benefit formula by the growth in wages minus a specified rate.
LawChangeBPMINCONST.h | Declarations for the LawChangeBPMINCONST class to manage parameters for a proposal to increase the bend points in the benefit formula by the growth in wages minus a specified rate.
LawChangeBPSPECRATE.cpp | Functions for the LawChangeBPSPECRATE class to manage parameters for a proposal to increase the bend points in the benefit formula by a specified growth rate.
LawChangeBPSPECRATE.h | Declarations for the LawChangeBPSPECRATE class to manage parameters for a proposal to increase the bend points in the benefit formula by a specified growth rate.
LawChangeCHILDCARECREDIT.cpp | Functions for the LawChangeCHILDCARECREDIT class to manage parameters for a proposal to provide child care credits.
LawChangeCHILDCARECREDIT.h | Declarations for the LawChangeCHILDCARECREDIT class to manage parameters for a proposal to provide child care credits.
LawChangeCHILDCAREDROPOUT.cpp | Functions for the LawChangeCHILDCAREDROPOUT class to manage parameters for a proposal to provide child care dropout years.
LawChangeCHILDCAREDROPOUT.h | Declarations for the LawChangeCHILDCAREDROPOUT class to manage parameters for a proposal to provide child care dropout years.
LawChangeCOLACHANGE.cpp | Functions for the LawChangeCOLACHANGE class to manage parameters for a proposal to change the cost-of-living benefit increases.
LawChangeCOLACHANGE.h | Declarations for the LawChangeCOLACHANGE class to manage parameters for a proposal to change the cost-of-living benefit increases.
LawChangeDECLINEPERC.cpp | Functions for the LawChangeDECLINEPERC class to manage parameters for a proposal to decrease the benefit formula percentages by various rates.
LawChangeDECLINEPERC.h | Declarations for the LawChangeDECLINEPERC class to manage parameters for a proposal to decrease the benefit formula percentages by various rates.
LawChangeDROPOUTCHG.cpp | Functions for the LawChangeDROPOUTCHG class to manage parameters for a proposal to reduce the number of dropout years in a pia calculation.
LawChangeDROPOUTCHG.h | Declarations for the LawChangeDROPOUTCHG class to manage parameters for a proposal to reduce the number of dropout years in a pia calculation.
LawChangeMARRLENGTH.cpp | Functions for the LawChangeMARRLENGTH class to manage parameters for a proposal to change the length of marriage requirement for divorced spouse benefits.
LawChangeMARRLENGTH.h | Declarations for the LawChangeMARRLENGTH class to manage parameters for a proposal to change the length of marriage requirement for divorced spouse benefits.
LawChangeNEWFORMULA.cpp | Functions for the LawChangeNEWFORMULA class to manage parameters for a proposal to change the pia formula bend points and/or percentages.
LawChangeNEWFORMULA.h | Declarations for the LawChangeNEWFORMULA class to manage parameters for a proposal to change the pia formula bend points and/or percentages.
LawChangeNEWSPECMIN.cpp | Functions for the LawChangeNEWSPECMIN class to manage parameters for a proposal to change the special minimum pia calculation.
LawChangeNEWSPECMIN.h | Declarations for the LawChangeNEWSPECMIN class to manage parameters for a proposal to change the special minimum pia calculation.
LawChangeNRACHANGE.cpp | Functions for the LawChangeNRACHANGE class to manage parameters for a proposal to change the full retirement age.
LawChangeNRACHANGE.h | Declarations for the LawChangeNRACHANGE class to manage parameters for a proposal to change the full retirement age.
LawChangeOut.cpp | Functions for the LawChangeOut class to manage the output file of law change descriptions.
LawChangeOut.h | Declarations for the LawChangeOut class to manage the output file of law change descriptions.
LawChangePSAACCT.cpp | Functions for the LawChangePSAACCT class to manage parameters for a proposal to introduce individual accounts.
LawChangePSAACCT.h | Declarations for the LawChangePSAACCT class to manage parameters for a proposal to introduce individual accounts.
LawChangeRead.cpp | Functions for the LawChangeRead class to read law changes from a file.
LawChangeRead.h | Declarations for the LawChangeRead class to read law changes from a file.
LawChangeTAXBENCHG.cpp | Functions for the LawChangeTAXBENCHG class to manage parameters for a proposal to change the taxation of benefits.
LawChangeTAXBENCHG.h | Declarations for the LawChangeTAXBENCHG class to manage parameters for a proposal to change the taxation of benefits.
LawChangeTAXRATECHG.cpp | Functions for the LawChangeTAXRATECHG class to manage parameters for a proposal to change the OASDHI tax rates.
LawChangeTAXRATECHG.h | Declarations for the LawChangeTAXRATECHG class to manage parameters for a proposal to change the OASDHI tax rates.
LawChangeWAGEBASECHG.cpp | Functions for the LawChangeWAGEBASECHG class to manage parameters for a proposal to change the OASDI and/or old-law wage bases.
LawChangeWAGEBASECHG.h | Declarations for the LawChangeWAGEBASECHG class to manage parameters for a proposal to change the OASDI and/or old-law wage bases.
LawChangeWIDFACTOR.cpp | Functions for the LawChangeWIDFACTOR class to manage parameters for a proposal to change the factor for an aged widow(er) benefit.
LawChangeWIDFACTOR.h | Declarations for the LawChangeWIDFACTOR class to manage parameters for a proposal to change the factor for an aged widow(er) benefit.
LawChangeWIFEFACTOR.cpp | Functions for the LawChangeWIFEFACTOR class to manage parameters for a proposal to change the factor for an aged spouse benefit.
LawChangeWIFEFACTOR.h | Declarations for the LawChangeWIFEFACTOR class to manage parameters for a proposal to change the factor for an aged spouse benefit.
LawChangeWrite.cpp | Functions for the LawChangeWrite class to write law changes to a file.
LawChangeWrite.h | Declarations for the LawChangeWrite class to write law changes to a file.
MilServDatesVec.h | Declarations for the MilServDatesVec class to manage an array of military service dates records.
msdates.cpp | Functions for the MilServDates class to manage one military service dates record.
msdates.h | Declarations for the MilServDates class to manage one military service dates record.
msdatesvec.cpp | Functions for the MilServDatesVec class to manage an array of military service dates records.
oactcnst.h | Constants used in the various Oact C++ programs and utilities.
oldpia.cpp | Functions for the OldPia class - parent of all methods using pia tables in the calculation of a Social Security benefit.
OldPia.h | Declarations for the OldPia class - parent of all methods using pia tables in the calculation of a Social Security benefit.
oldstart.cpp | Functions for the OldStart class to manage old-start pia calculations.
OldStart.h | Declarations for the OldStart class to manage old-start pia calculations.
OldStartLC.cpp | Functions for the OldStartLC class to manage old-start pia calculations, with changes from present law.
OldStartLC.h | Declarations for the OldStartLC class to manage old-start pia calculations, with changes from present law.
pebs.cpp | Functions for the Pebs class to handle Social Security Statement data.
pebs.h | Declarations for the Pebs class to handle Social Security Statement data.
percmfb.cpp | Functions to handle MFB formula percentages.
percmfb.h | Declarations needed for class to manage array of MFB formula percentages.
percpia.cpp | Functions to handle PIA formula percentages.
percpia.h | Declarations needed for class to manage array of PIA formula percentages.
PercPiaOut.cpp | Functions for the PercPiaOut class to manage array of pia formula percentages.
PercPiaOut.h | Declarations for the PercPiaOut class to manage array of pia formula percentages.
piacal.cpp | Functions for the PiaCal class - parent of all classes that manage the calculation of a Social Security benefit.
piacal.h | Declarations for the PiaCal class - parent of all classes that manage the calculation of a Social Security benefit.
piacalany.cpp | Functions for the PiaCalAny class to manage pia calculation functions used in Anypia.
PiaCalAny.h | Declarations for the PiaCalAny class to manage pia calculation functions used in Anypia.
piacallc.cpp | Functions for the PiaCalLC class to manage law-change pia calculation functions.
PiaCalLC.h | Declarations for the PiaCalLC class to manage law-change pia calculation functions.
PiaCalPL.cpp | Functions for the PiaCalPL class to manage present law pia calculation functions.
PiaCalPL.h | Declarations for the PiaCalPL class to manage present law pia calculation functions.
piadata.cpp | Functions for the PiaData class to set up data to calculate and print out a PIA.
piadata.h | Declarations for the PiaData class to set up data to calculate and print out a PIA.
PiadataArray.cpp | Functions for the PiaDataArray class to manage an array of PiaData's, representing one family.
PiadataArray.h | Declarations for the PiaDataArray class to manage an array of PiaData's, representing one family.
PiaMethod.cpp | Functions for the PiaMethod class - parent of the various methods required for calculation of a Social Security benefit.
PiaMethod.h | Declarations for the PiaMethod class - parent of the various methods required for calculation of a Social Security benefit.
PiaParamsLCTR.cpp | Functions for the PiaParamsLCTR class to manage the changed law Social Security parameters, already projected based on a Trustees Report assumption.
PiaParamsLCTR.h | Declarations for the PiaParamsLCTR class to manage the changed law Social Security parameters, already projected based on a Trustees Report assumption.
PiaParamsTR.cpp | Functions for the PiaParamsTR class of pia calculation parameters using present law only, with projected values set to Trustees Report assumptions.
PiaParamsTR.h | Declarations for the PiaParamsTR class of pia calculation parameters using present law only, with projected values set to Trustees Report assumptions.
piaparms.cpp | Functions for the PiaParams class - parent of classes to manage the Social Security parameters required to calculate a Social Security benefit.
piaparms.h | Declarations for the PiaParams class - parent of classes to manage the Social Security parameters required to calculate a Social Security benefit.
piaparmsAny.cpp | Functions for the PiaParamsAny class to manage the Social Security parameters required to calculate Social Security benefits in the Anypia program.
piaparmsAny.h | Declarations for the PiaParamsAny class to manage the Social Security parameters required to calculate Social Security benefits in the Anypia program.
piaparmsLC.cpp | Functions for the PiaParamsLC class to handle changed law PIA parameters.
piaparmsLC.h | Declarations for the PiaParamsLC class to handle changed law PIA parameters.
piaparmsPL.cpp | Functions for the PiaParamsPL class of pia calculation parameters using present law only.
piaparmsPL.h | Declarations for the PiaParamsPL class of pia calculation parameters using present law only.
piaread.cpp | Functions for the PiaRead class to read a file of worker data from disk.
piaread.h | Declarations for the PiaRead class to read a file of worker data from disk.
piareadAny.cpp | Functions for the PiaReadAny class to read worker data for Anypia.
piareadAny.h | Declarations for the PiaReadAny class to read worker data for Anypia.
PiaTable.cpp | Functions for the PiaTable class to manage Pia Table pia calculations.
PiaTable.h | Declarations for the PiaTable class to manage Pia Table pia calculations.
PiaTableLC.cpp | Functions for the PiaTableLC class to manage Pia Table pia calculations, with changes from present law.
PiaTableLC.h | Declarations for the PiaTableLC class to manage Pia Table pia calculations, with changes from present law.
piawrite.cpp | Functions for the PiaWrite class to write out worker data.
piawrite.h | Declarations for the PiaWrite class to write out worker data.
piawriteAny.cpp | Functions for the PiaWriteAny class to write out worker data for Anypia program.
piawriteAny.h | Declarations for the PiaWriteAny class to write out worker data for Anypia program.
pib50mfb.cpp | Functions for the Pib50Mfb class to handle 1950 pib-mfb conversion table.
pib50pib.cpp | Functions for the Pib50Pib class to handle 1950 pib-pia conversion table.
pib52ame.cpp | Functions for the class to handle 1952 pib-ame conversion table.
bendmfb.cpp | Functions to handle MFB formula bend points.
pib52mfb.cpp | Functions for the class to handle 1952 pib-mfb conversion table.
bendpia.cpp | Functions for the BendPia class to handle PIA formula bend points.
pib54ame.cpp | Functions for the class to handle 1954 pib-ame conversion table.
pib54mfb.cpp | Functions for the class to handle 1954 pib-mfb conversion table.
pib54pia.cpp | Functions for the class to handle 1954 pib-pia conversion table.
pib58ame.cpp | Functions for the class to handle 1958 pib-ame conversion table.
pib58pib.cpp | Functions for the class to handle 1958 pib-pia conversion table.
pibtable.h | Declarations for the Pib50Mfb, Pib50Pib, Pib52Ame, Pib52Mfb, Pib54Ame, Pib54Mfb, Pib54Pia, Pib58Ame, and Pib58Pib classes to manage pib-pia conversion tables.
Pifc.cpp | Functions for the Pifc class representing a type of Social Security pia.
Pifc.h | Declarations for the Pifc class representing a type of Social Security pia.
PresValFacs.cpp | Functions for the PresValFacs class to handle present value factors.
PresValFacs.h | Declarations for the PresValFacs class to handle present value factors.
Psa.cpp | Functions for Psa class to manage PSA accounts.
Psa.h | Declarations for Psa class to manage PSA accounts.
qc.cpp | Functions for the Qc class to manage one annual quarters of coverage number.
qc.h | Declarations for the Qc class to manage one annual quarters of coverage number.
qcamt.cpp | Functions for the Qcamt class to manage array of amounts required for quarter of coverage.
qcamt.h | Declarations for the Qcamt class to manage array of amounts required for quarter of coverage.
QcArray.cpp | Functions for the QcArray class to handle an array of annual number of quarters of coverage.
QcArray.h | Declarations for the QcArray class to handle an array of annual number of quarters of coverage.
QcPacked.cpp | Functions for the QcPacked class to hold 8 quarters of coverage amounts in one word.
QcPacked.h | Declaration of the QcPacked class to hold 8 quarters of coverage amounts in one word.
railroad.cpp | Functions for the RailRoadData class to manage edited railroad record.
railroad.h | Declarations for the RailRoadData class to manage edited railroad record.
ReindWid.cpp | Functions for the ReindWid class to manage reindexed widow(er) pia calculations.
ReindWid.h | Declarations for the ReindWid class to manage reindexed widow(er) pia calculations.
ReindWidLC.cpp | Functions for the ReindWidLC class to manage reindexed widow(er) pia calculation with law changes.
ReindWidLC.h | Declarations for the ReindWidLC class to manage reindexed widow(er) pia calculation with law changes.
RetireTest.cpp | Functions for the RetireTest class to manage retirement test calculations.
RetireTest.h | Declarations for the RetireTest class to manage retirement test calculations.
rtgenrl.cpp | Functions for the RtGeneral class - parent of classes to manage one retirement test projection.
rtgenrl.h | Declarations for the RtGeneral class - parent of classes to manage one retirement test projection.
ScaledEarnFactors.cpp | Functions for the ScaledEarnFactors class of scaled earnings factors.
ScaledEarnFactors.h | Declarations for the ScaledEarnFactors class of scaled earnings factors.
Secondary.cpp | Functions for the Secondary class containing the information about a secondary benefit.
Secondary.h | Declarations for the Secondary class containing the information about a secondary benefit.
SecondaryArray.cpp | Functions for the SecondaryArray class to manage a vector of secondary benefit data.
SecondaryArray.h | Declarations for the SecondaryArray class to manage a vector of secondary benefit data.
Sga.cpp | Functions for the Sga class to manage SGA amounts.
Sga.h | Declarations for the Sga class to manage SGA amounts.
SgaDerived.cpp | Functions for the SgaBlindA, SgaBlindM, SgaMinA, SgaMinM, SgaMaxA, and SgaMaxM classes (derived classes of the SgaGeneral class).
SgaDerived.h | Declarations for the SgaBlindA, SgaBlindM, SgaMinA, SgaMinM, SgaMaxA, and SgaMaxM classes (derived classes of the SgaGeneral class).
SgaGeneral.cpp | Functions for the SgaGeneral class - parent of classes to handle historical and projected SGA (Substantial Gainful Activity) amounts, stored in arrays.
SgaGeneral.h | Declarations for the SgaGeneral class - parent of classes to handle historical and projected SGA (Substantial Gainful Activity) amounts, stored in arrays.
SpecMin.cpp | Functions for the SpecMin class to manage special minimum pia calculations.
SpecMin.h | Declarations for the SpecMin class to manage special minimum pia calculations.
SpecMinLC.cpp | Functions for the SpecMinLC class to manage special minimum pia calculations, including changes from present law.
SpecMinLC.h | Declarations for the SpecMinLC class to manage special minimum pia calculations, including changes from present law.
TaxBenefits.cpp | Functions for the TaxBenefits class to manage tax on benefits functions.
TaxBenefits.h | Declarations for the TaxBenefits class to manage tax on benefits functions.
TaxBenefitsLC.cpp | Functions for the TaxBenefitsLC class to manage tax on benefits functions with law changes.
TaxBenefitsLC.h | Declarations for the TaxBenefitsLC class to manage tax on benefits functions with law changes.
TaxData.cpp | Functions for the TaxData class to manage taxes paid by a worker.
TaxData.h | Declarations for the TaxData class to manage taxes paid by a worker.
TaxRates.cpp | Functions for the TaxRates class - parent of classes to manage OASDHI tax rates.
TaxRates.h | Declarations for the TaxRates class - parent of classes to manage OASDHI tax rates.
TaxRatesLC.cpp | Functions for the TaxRatesLC class to manage the Social Security payroll and self-employed tax rates, with changes from present law.
TaxRatesLC.h | Declarations for the TaxRatesLC class to manage the Social Security payroll and self-employed tax rates, with changes from present law.
TaxRatesPL.cpp | Functions for the TaxRatesPL class to manage the Social Security payroll and self-employed tax rates.
TaxRatesPL.h | Declarations for the TaxRatesPL class to manage the Social Security payroll and self-employed tax rates.
TransGuar.cpp | Functions for the TransGuar class to manage transitional guarantee pia calculations.
TransGuar.h | Declarations for the TransGuar class to manage transitional guarantee pia calculations.
TransGuarLC.cpp | Functions for the TransGuarLC class to manage transitional guarantee pia calculations, with changes from present law.
TransGuarLC.h | Declarations for the TransGuarLC class to manage transitional guarantee pia calculations, with changes from present law.
UserAssumptions.cpp | Functions for the UserAssumptions class to manage user-specified assumptions.
UserAssumptions.h | Declarations for the UserAssumptions class to manage user-specified assumptions.
WageBase.cpp | Functions for the WageBase, WageBaseHI, and WageBaseOldLaw classes to manage wage base projections.
WageBase.h | Declarations for the WageBase, WageBaseHI, and WageBaseOldLaw classes to manage wage base projections.
WageInd.cpp | Functions for the WageInd class to calculate a wage-indexed PIA.
WageInd.h | Declarations for the WageInd class to manage wage-indexed pia calculation functions.
WageIndGeneral.cpp | Functions for the WageIndGeneral class - parent of classes to manage wage-indexed pia calculations.
WageIndGeneral.h | Declarations for the WageIndGeneral class - parent of classes to manage wage-indexed pia calculations.
WageIndLC.cpp | Functions for the WageIndLC class to manage wage-indexed pia calculation, with law change parameters.
WageIndLC.h | Declarations for the WageIndLC class to manage wage-indexed pia calculation, with law change parameters.
WageIndNonFreeze.cpp | Functions for the WageIndNonFreeze class to calculate a wage-indexed non-freeze PIA.
WageIndNonFreeze.h | Declarations for the WageIndNonFreeze class to manage wage-indexed non-freeze pia calculation functions.
wbgenrl.cpp | Functions for the WageBaseGeneral class - parent of classes that manage wage base projections.
wbgenrl.h | Declarations for the WageBaseGeneral class - parent of classes that manage wage base projections.
wbgenrlLC.cpp | Functions for the WageBaseLC and WageBaseOldLawLC classes to manage wage base projections with law changes.
wbgenrlLC.h | Declarations for the WageBaseLC and WageBaseOldLawLC classes to manage wage base projections with law changes.
WorkerDataArray.cpp | Functions for the WorkerDataArray class to manage array of WorkerData's.
WorkerDataArray.h | Declarations for the WorkerDataArray class to manage array of WorkerData's.
WorkerDataGeneral.cpp | Functions for the WorkerDataGeneral class - parent of classes to manage worker data.
WorkerDataGeneral.h | Declarations for the WorkerDataGeneral class - parent of classes to manage worker data.
wrkrdata.cpp | Functions for the WorkerData class to manage worker data.
wrkrdata.h | Declarations for the WorkerData class to manage worker data.
bendmfb.h | Declarations needed for class to manage array of MFB formula bend points.
bendpia.h | Declarations for the BendPia class to manage array of PIA formula bend points.
PortionAime.cpp | Functions to handle PIA formula AIME portions.
PortionAime.h | Declarations needed for class to manage array of portions of AIME in the PIA formula.
Collapse Expand Functions
Name | Description
isDebugPid | Returns true if argument person id is the debug pid.
Collapse Expand Variables
Name | Description
BASEYR | Base year for trust fund projection arrays on January 1 basis.
BASEYR1 | Base year for trust fund projection arrays on during-year basis.
DEBUGPID | Value of 999999 is reserved. It means print out for all pid's.
LASTYEARLR | Last year of long-range projection arrays.
LASTYRSR | Last year of short-range projection arrays.
MAXEARN | Maximum annual earnings allowed.
MAXYRS | Maximum number of years of earnings for one individual.
MAXYRSR | Number of years of data in trust fund projections, January 1 basis.
MAXYRSR1 | Number of years of data in trust fund projections, during-year basis.
ORSYR | Base year for ORS trust fund projection data.
YEAR2075 | Last possible year of projection.
YEAR2080 | Last possible year of projection.
YEAR2085 | Last possible year of projection.
YEAR2090 | Last possible year of projection.
YEAR2095 | Last possible year of projection.
YEAR2100 | Last possible year of projection.
YEAR2105 | Last possible year of projection.
YEAR2200 | Last possible year for dates.
YEAR36 | Year before first year of Social Security.
YEAR37 | Base year for many data arrays.
YEAR50 | Year before first year of major revisions to Social Security.
YEAR51 | First year of major revisions to Social Security.
YEAR69 | First year of many OACT projection arrays.
YEAR70 | First year of many OACT projection arrays.
YEAR74 | First year of many OACT projection arrays.
YEAR75 | First year of many OACT projection arrays.
YEAR79 | First year of bend points.
Collapse Expand Links
Legend, Topics


Classes

Classes
Classes Legend PiaData Library

The following table lists classes in this documentation.

Collapse Expand Classes
Name | Description
Assumptions | Parent of classes that manage the average wage and benefit increase assumptions.
AssumptionsFile | Reads the average wage and benefit increase parameters from disk storage.
AssumptionsNonFile | Contains the average wage and benefit increase assumptions (it does not read from disk).
AssumptionType | The assumption types (about future average wage and benefit increases) allowed in the piadata library.
AverageWage | Manages an array of average wage indexing amounts, or any other earnings series.
AwbiData | Manages the historical Social Security parameters.
AwbiDataFile | Manages the historical Social Security parameters stored in a file.
AwbiDataNonFile | Manages the historical Social Security parameters stored in arrays in the code.
Awinc | Manages a vector of projected average wage increases.
AwincDoc | Abstract parent of classes that manage the file of projected average wage increases.
AwincFile | Manages the file of projected average wage increases stored on disk.
AwincNonFile | Manages the file of projected average wage increases stored in static arrays.
BaseChangeType | The wage base change types allowed in the piadata library.
BaseYear | Parent of classes that manage the computation year for a pia program.
BaseYearFile | Manages the computation year for a pia program where it is gotten from disk.
BaseYearNonFile | Manages the computation year for a pia program where it is stored with the code.
BendPia | Manages the array of bend points used in the PIA formula.
BendMfb | Manages the array of bend points used in the MFB formula.
BenefitAmount | Represents a benefit amount for one year.
BenefitAmountArray | Manages an array of BenefitAmount's.
Bic | Represents one 2-character bic (Beneficiary Identification code) code.
Biproj | Abstract parent of classes that manage the file of projected benefit increases.
BiprojFile | Manages the file of projected benefit increases stored on disk.
BiprojNonFile | Manages the file of projected benefit increases stored in arrays.
BpMfbOut | Manages the array of mfb formula bend points.
BpPiaOut | Manages the array of pia formula bend points.
Catchup | Manages the catch-up benefit increases required to calculate a Social Security benefit.
CatchupDoc | Abstract parent of classes that manage a file of catch-up benefit increases.
CatchupFile | Manages a file of catch-up benefit increases stored on disk.
CatchupIncreases | Manages the catch-up benefit increases for one year of eligibility.
CatchupNonFile | Manages a file of catch-up benefit increases stored in arrays.
ChildCareCalc | Manages the functions required for calculation of a wage indexed Social Security benefit using childcare dropout years.
ChildCareCalcLC | Manages the functions required for calculation of a wage indexed Social Security benefit using childcare dropout years, with law changes.
CompPeriod | Manages the number of elapsed years, dropout years, and computation years.
Config | Parent of classes that manage the configuration information used by the PIA calculation program.
ConfigFile | Manages the configuration information used by the PIA calculation program, stored in a file.
ConfigNonFile | Manages the configuration information used by the PIA calculation program, stored with the code.
DibGuar | Manages the functions required for calculation of a disability guarantee Social Security benefit.
DibGuarLC | Manages the functions required for calculation of a disability guarantee Social Security benefit with law changes.
DisabPeriod | Manages a period of disability.
DisInsCode | Represents one disability insured status code.
DisInsCodeArray | Manages an array of annual DisInsCode's.
EarnProject | Manages an array of earnings, with forward and backward projections and specified levels of earnings.
FieldOfficeInfo | Parent of classes that manage the name and address of the field office.
FieldOfficeInfoFile | Reads and writes field office information from and to a file.
FieldOfficeInfoNonFile | Manages field office information not stored in a file (but its data may be saved in an .ini file).
FreezeYears | Manages the years in a freeze period. The years may be wholly or partially within a freeze period.
FrozMin | Manages the functions required for calculation of a frozen minimum Social Security benefit.
InsCode | Represents one insured status code.
InsCodeArray | Manages an array of annual insured status codes.
LawChange | The basic class that manages all of the extra data and functions required for one change in law concerning benefit calculations.
LawChangeAGE65COMP | Parameters for a proposal to increase the number of elapsed years in a pia calculation.
LawChangeALLEARN | Parameters for a proposal to use all years of earnings in an AIME calculation.
LawChangeArray | Manages an array of LawChange's.
LawChangeBPFRACWAGE | Parameters for a proposal to increase the bend points in the benefit formula by a fraction of average wage growth.
LawChangeBPMINCONST | Parameters for a proposal to increase the bend points in the benefit formula by the growth in wages minus a specified rate.
LawChangeBPSPECRATE | Parameters for a proposal to increase the bend points in the benefit formula by a specified growth rate.
LawChangeCHILDCARECREDIT | Parameters for a proposal to provide child care credits.
LawChangeCHILDCAREDROPOUT | Parameters for a proposal to provide child care dropout years.
LawChangeCOLACHANGE | Parameters for a proposal to change the cost-of-living benefit increases.
LawChangeDECLINEPERC | Parameters for a proposal to decrease the benefit formula percentages by a constant rate.
LawChangeDROPOUTCHG | Parameters for a proposal to reduce the number of dropout years in a pia calculation.
LawChangeMARRLENGTH | Parameters for a proposal to change the length of marriage requirement for divorced spouse benefits.
LawChangeNEWFORMULA | Parameters for a proposal to change the pia formula bend points and/or percentages.
LawChangeNEWSPECMIN | Parameters for a proposal to change the special minimum pia calculation.
LawChangeNRACHANGE | Parameters for a proposal to change the full retirement age.
LawChangeOut | Manages the output file of law change descriptions.
LawChangePSAACCT | Parameters for a proposal to introduce individual accounts.
LawChangeRead | Reads law changes stored in a file.
LawChangeTAXBENCHG | Parameters for a proposal to change the taxation of benefits.
LawChangeTAXRATECHG | Parameters for a proposal to change the OASDI tax rates.
LawChangeWAGEBASECHG | Parameters for a proposal to change the OASDI and/or old-law wage bases.
LawChangeWIDFACTOR | Parameters for a proposal to change the factor for an aged widow(er) benefit.
LawChangeWIFEFACTOR | Parameters for a proposal to change the factor for an aged spouse benefit.
LawChangeWrite | Writes a set of law changes to a file.
MilServDates | Manages one period of military service dates.
MilServDatesVec | Manages all the military service dates records for one ssn.
OldPia | Parent of all methods using pia tables in the calculation of a Social Security benefit.
OldStart | Manages the functions required for calculation of an old start Social Security benefit.
OldStartLC | Manages the functions required for calculation of an old start Social Security benefit with law changes.
Pebs | Manages most of the data required to prepare and print out the results of a Statement calculation.
PercMfb | Manages the array of percentages used in the MFB formula.
PercPia | Manages the array of percentages used in the PIA formula.
PercPiaOut | Manages the array of pia formula percentages, projected for all years.
PiaCal | Parent of all classes that manage the functions required for calculation of a Social Security benefit.
PiaCalAny | Manages the additional functions required for calculation of a Social Security benefit in the Anypia program.
PiaCalLC | Manages all of the law-change functions required for calculation of a Social Security benefit.
PiaCalPL | Manages all of the present law functions required for calculation of a Social Security benefit.
PiaData | Manages all of the worker-specific amounts calculated in preparation for and during the calculation of a Social Security benefit.
PiaDataArray | Manages an array of PiaData's, representing one family.
PiaMethod | Parent of the various methods required for calculation of a Social Security benefit.
PiaParams | Abstract parent of classes to manage the Social Security parameters required to calculate a Social Security benefit.
PiaParamsAny | Manages the additional Social Security parameters required to calculate Social Security benefits in the Anypia program.
PiaParamsLC | Manages the changed law Social Security parameters required to calculate Social Security benefits.
PiaParamsLCTR | Manages the changed law Social Security parameters, already projected based on a Trustees Report assumption.
PiaParamsPL | Manages the present law Social Security parameters required to calculate Social Security benefits.
PiaParamsTR | Manages the present law Social Security parameters required to calculate Social Security benefits, with projected values set to Trustees Report assumptions.
PiaRead | Reads the basic data required to calculate a Social Security benefit.
PiaReadAny | Reads the data required to calculate a Social Security benefit for the Anypia program.
PiaTable | Manages the functions required for calculation of a Pia Table Social Security benefit.
PiaTableLC | Manages the functions required for calculation of a Pia Table Social Security benefit, including changes from present law.
PiaWrite | Writes out the basic data required to calculate a Social Security benefit.
PiaWriteAny | Writes out the data required to calculate a Social Security benefit for the Anypia program.
Pib50Mfb | Manages the 1950 pib-mfb conversion figures.
Pib50Pib | Manages the 1950 pib-pia conversion figures.
Pib52Ame | Manages the 1952 pib-ame conversion figures.
Pib52Mfb | Manages the 1952 pib-mfb conversion figures.
Pib54Ame | Manages the 1954 pib-ame conversion figures.
Pib54Mfb | Manages the 1954 pib-mfb conversion figures.
Pib54Pia | Manages the 1954 pib-pia conversion figures.
Pib58Ame | Manages the 1958 pib-ame conversion figures.
Pib58Pib | Manages the 1958 pib-pia conversion figures.
Pifc | Represents a pia factor code (type of Social Security pia).
PortionAime | Manages the array of portions of AIME in the PIA formula.
PresValFacs | Manages an array of present value factors.
Psa | Manages the (theoretical) PSA accounts.
Qc | Handles calculations with quarters of coverage for one year.
Qcamt | Manages an array of quarter of coverage amounts.
QcArray | Manages an array of annual quarters of coverage.
QcPacked | Holds 8 annual quarters of coverage amounts in one word (4 bytes). Each value is in 4 bits, and can take values from 0 to 4.
RailRoadData | Manages the railroad data for one worker.
ReindWid | Manages the functions required for calculation of a reindexed widow(er) Social Security benefit.
ReindWidLC | Manages the functions required for calculation of a reindexed widow(er) Social Security benefit with law changes.
RetireTest | Contains all of the retirement test exempt amounts and functions to use them.
Rtea62 | Manages the annual retirement test exempt amount projections under full retirement age.
Rtea62m | Manages the monthly retirement test exempt amount projections under full retirement age.
Rtea65 | Manages the annual retirement test exempt amount projections over full retirement age.
Rtea65m | Manages the monthly retirement test exempt amount projections over full retirement age.
RteaHigh | Manages the upper annual retirement test exempt amounts when there were two tiers.
RtGeneral | Parent of classes to manage the retirement test exempt amount projections.
ScaledEarnFactors | Manages scaled earner amounts.
Secondary | Contains the information about a secondary benefit.
SecondaryArray | Manages an array of Secondary's.
Sga | Contains all of the SGA amounts and functions to use them.
SgaBlindA | Manages the annual SGA amounts (historical and projected) for blind beneficiaries.
SgaBlindM | Manages the monthly SGA amounts (historical and projected) for blind beneficiaries (as of December).
SgaGeneral | Parent of classes to manage the SGA (Substantial Gainful Activity) amounts (historical and projected).
SgaMaxA | Manages the annual SGA maximum amounts(historical and projected) for non-blind beneficiaries.
SgaMaxM | Manages the monthly SGA maximum amounts (historical and projected) for non-blind beneficiaries (as of December).
SgaMinA | Manages the annual SGA minimum amounts (historical and projected) for non-blind beneficiaries.
SgaMinM | Manages the monthly SGA minimum amounts (historical and projected) for non-blind beneficiaries (as of December).
SpecMin | Manages the functions required for calculation of a special minimum Social Security benefit.
SpecMinLC | Manages the functions required for calculation of a special minimum Social Security benefit, including changes from present law.
TaxBenefits | Contains the functions required to calculate the tax on a Social Security benefit.
TaxBenefitsLC | Contains the functions required to calculate the tax on a Social Security benefit with law changes.
TaxData | Manages the Social Security payroll and self-employed taxes paid by a worker.
TaxRates | Abstract parent of classes that manage the Social Security payroll and self-employed tax rates.
TaxRatesLC | Manages the Social Security payroll and self-employed tax rates, with changes from present law.
TaxRatesPL | Manages the present law Social Security payroll and self-employed tax rates.
TransGuar | Manages the functions required for calculation of a transitional guarantee Social Security benefit.
TransGuarLC | Manages the functions required for calculation of a transitional guarantee Social Security benefit, with changes from present law.
UserAssumptions | Manages all the assumptions about future average wage increases, wage bases, benefit increases, and catch-up benefit increases that a user might specify.
WageBase | Manages the OASDI wage base projections.
WageBaseGeneral | Ancestor of the classes that manage the wage base projections.
WageBaseHI | Manages the HI wage base projections.
WageBaseLC | Manages the OASDI wage base projection with law changes.
WageBaseOldLaw | Manages the old-law OASDI wage base projections.
WageBaseOldLawLC | Manages the old-law OASDI wage base projection with law changes.
WageInd | Manages the functions required for calculation of a wage indexed Social Security benefit.
WageIndGeneral | Parent of all classes that manage the functions required for calculation of a wage indexed Social Security benefit.
WageIndLC | Manages the functions required for calculation of a wage indexed Social Security benefit, with changes from present law.
WageIndNonFreeze | Manages the functions required for calculation of a wage indexed non-freeze Social Security benefit.
WorkerData | Manages the basic data required to calculate a Social Security benefit.
WorkerDataArray | Manages an array of WorkerData's, representing one family.
WorkerDataGeneral | The abstract parent of all classes that manage the basic data required to calculate a Social Security benefit.
Collapse Expand Module

PiaData Library

Collapse Expand Links
Classes, Legend, PiaData Library


Assumptions Class

Assumptions Class
Assumptions Constructor Assumptions Methods Assumptions Members Assumptions.h Classes

Parent of classes that manage the average wage and benefit increase assumptions.

Collapse Expand Class Hierarchy
  Assumptions
C++
class Assumptions;
Collapse Expand File

File: Assumptions.h

Module: PiaData Library

Collapse Expand Remarks

One of its subclasses should be instantiated: AssumptionsFile if it is to be read from disk, AssumptionsNonFile otherwise.

Collapse Expand Group

Classes

Collapse Expand Links
Assumptions Constructor, Assumptions Methods, Assumptions Members, Assumptions.h, Classes


Assumptions Members

Assumptions Members
Assumptions Class Legend Public Methods

The following tables list the members exposed by Assumptions.

Collapse Expand Class

Assumptions Class

Collapse Expand Public Methods
Name | Description
Assumptions | Initializes an Assumptions, with or without a specified first year.
averageWageMenu | Set average wage increases from stored values.
benefitIncMenu | Set benefit increases from stored values.
getAverageWage | Returns an average wage increase assumption title.
getAwincProj | Returns projected average wage increases.
getBenefitInc | Returns a benefit increase assumption title.
getBiProj | Returns projected benefit increases.
getCatchupDoc | Returns catch-up benefit increases.
getIstart | Returns current year.
getMaxyear | Returns maximum projected year.
setAwincProjTitle | Set title of projected average wage increases.
setBiProjTitle | Set title of projected benefit increases.
setIstart | Sets the current year, including for the members.
~Assumptions | Destructor.
Collapse Expand Links
Assumptions Class, Legend, Public Methods


Assumptions Constructor

Assumptions Constructor
Assumptions Class

Initializes an Assumptions, with or without a specified first year.

Collapse Expand Description

There are two versions of the Assumptions constructor. The last year of assumptions is always specified, but the first year can be specified or gotten from BaseYearNonFile.

Collapse Expand Overload List
Name | Description
Assumptions::Assumptions (int) | Initializes years, where the year after last known benefit increase is taken from BaseYearNonFile.
Assumptions::Assumptions (int, int) | Initializes years, where the year after last known benefit increase is specified.
Collapse Expand Class

Assumptions Class

Collapse Expand Links
Assumptions Class


Assumptions::Assumptions Constructor (int)

Assumptions::Assumptions Constructor (int)
Assumptions Class Assumptions Members Assumptions Constructor

Initializes years, where the year after last known benefit increase is taken from BaseYearNonFile.

C++
Assumptions(
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
int newMaxyear | Maximum projected year
Collapse Expand Group

Assumptions Constructor

Collapse Expand Links
Assumptions Class, Assumptions Members, Assumptions Constructor


Assumptions::Assumptions Constructor (int, int)

Assumptions::Assumptions Constructor (int, int)
Assumptions Class Assumptions Members Assumptions Constructor

Initializes years, where the year after last known benefit increase is specified.

C++
Assumptions(
    int newIstart,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
int newIstart | Year after last known benefit increase.
int newMaxyear | Maximum projected year
Collapse Expand Group

Assumptions Constructor

Collapse Expand Links
Assumptions Class, Assumptions Members, Assumptions Constructor


Assumptions::~Assumptions Destructor

Assumptions::~Assumptions Destructor
Assumptions Class Assumptions Members Assumptions Class

Destructor.

C++
virtual ~Assumptions();
Collapse Expand Class

Assumptions Class

Collapse Expand Links
Assumptions Class, Assumptions Members, Assumptions Class


Assumptions Methods

Assumptions Methods
Assumptions Class Legend Public Methods

The methods of the Assumptions class are listed here.

Collapse Expand Class

Assumptions Class

Collapse Expand Public Methods
Name | Description
averageWageMenu | Set average wage increases from stored values.
benefitIncMenu | Set benefit increases from stored values.
getAverageWage | Returns an average wage increase assumption title.
getAwincProj | Returns projected average wage increases.
getBenefitInc | Returns a benefit increase assumption title.
getBiProj | Returns projected benefit increases.
getCatchupDoc | Returns catch-up benefit increases.
getIstart | Returns current year.
getMaxyear | Returns maximum projected year.
setAwincProjTitle | Set title of projected average wage increases.
setBiProjTitle | Set title of projected benefit increases.
setIstart | Sets the current year, including for the members.
Collapse Expand Links
Assumptions Class, Legend, Public Methods


Assumptions::averageWageMenu Method

Assumptions::averageWageMenu Method
Assumptions Class Assumptions Members Assumptions Methods

Set average wage increases from stored values.

C++
virtual void averageWageMenu(
    int
) = 0;
Collapse Expand Group

Assumptions Methods

Collapse Expand Links
Assumptions Class, Assumptions Members, Assumptions Methods


Assumptions::benefitIncMenu Method

Assumptions::benefitIncMenu Method
Assumptions Class Assumptions Members Assumptions Methods

Set benefit increases from stored values.

C++
virtual void benefitIncMenu(
    int
) = 0;
Collapse Expand Group

Assumptions Methods

Collapse Expand Links
Assumptions Class, Assumptions Members, Assumptions Methods


Assumptions::getAverageWage Method

Assumptions::getAverageWage Method
Assumptions Class Assumptions Members Assumptions Methods

Returns an average wage increase assumption title.

C++
const std::string& getAverageWage(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Number of assumption (1 to AssumptionType::assum_type::PEBS_ASSUM).
Collapse Expand Returns

An average wage increase assumption title.

Collapse Expand Group

Assumptions Methods

Collapse Expand Links
Assumptions Class, Assumptions Members, Assumptions Methods


Assumptions::getAwincProj Method

Assumptions::getAwincProj Method
Assumptions Class Assumptions Members Assumptions Methods

Returns projected average wage increases.

C++
virtual const AwincDoc& getAwincProj() const = 0;
Collapse Expand Returns

Projected average wage increases.

Collapse Expand Group

Assumptions Methods

Collapse Expand Links
Assumptions Class, Assumptions Members, Assumptions Methods


Assumptions::getBenefitInc Method

Assumptions::getBenefitInc Method
Assumptions Class Assumptions Members Assumptions Methods

Returns a benefit increase assumption title.

C++
const std::string& getBenefitInc(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Number of assumption (1 to AssumptionType::assum_type::PEBS_ASSUM).
Collapse Expand Returns

A benefit increase assumption title.

Collapse Expand Group

Assumptions Methods

Collapse Expand Links
Assumptions Class, Assumptions Members, Assumptions Methods


Assumptions::getBiProj Method

Assumptions::getBiProj Method
Assumptions Class Assumptions Members Assumptions Methods

Returns projected benefit increases.

C++
virtual const Biproj& getBiProj() const = 0;
Collapse Expand Returns

Projected benefit increases.

Collapse Expand Group

Assumptions Methods

Collapse Expand Links
Assumptions Class, Assumptions Members, Assumptions Methods


Assumptions::getCatchupDoc Method

Assumptions::getCatchupDoc Method
Assumptions Class Assumptions Members Assumptions Methods

Returns catch-up benefit increases.

C++
virtual const CatchupDoc& getCatchupDoc() const = 0;
Collapse Expand Returns

Catch-up benefit increases.

Collapse Expand Group

Assumptions Methods

Collapse Expand Links
Assumptions Class, Assumptions Members, Assumptions Methods


Assumptions::getIstart Method

Assumptions::getIstart Method
Assumptions Class Assumptions Members Assumptions Methods

Returns current year.

C++
int getIstart() const;
Collapse Expand Returns

Current year.

Collapse Expand Group

Assumptions Methods

Collapse Expand Links
Assumptions Class, Assumptions Members, Assumptions Methods


Assumptions::getMaxyear Method

Assumptions::getMaxyear Method
Assumptions Class Assumptions Members Assumptions Methods

Returns maximum projected year.

C++
int getMaxyear() const;
Collapse Expand Returns

Maximum projected year.

Collapse Expand Group

Assumptions Methods

Collapse Expand Links
Assumptions Class, Assumptions Members, Assumptions Methods


Assumptions::setAwincProjTitle Method

Assumptions::setAwincProjTitle Method
Assumptions Class Assumptions Members Assumptions Methods

Set title of projected average wage increases.

C++
virtual void setAwincProjTitle(
    int
) = 0;
Collapse Expand Group

Assumptions Methods

Collapse Expand Links
Assumptions Class, Assumptions Members, Assumptions Methods


Assumptions::setBiProjTitle Method

Assumptions::setBiProjTitle Method
Assumptions Class Assumptions Members Assumptions Methods

Set title of projected benefit increases.

C++
virtual void setBiProjTitle(
    int
) = 0;
Collapse Expand Group

Assumptions Methods

Collapse Expand Links
Assumptions Class, Assumptions Members, Assumptions Methods


Assumptions::setIstart Method

Assumptions::setIstart Method
Assumptions Class Assumptions Members Assumptions Methods

Sets the current year, including for the members.

C++
virtual void setIstart(
    int newIstart
);
Collapse Expand Parameters
Parameters | Description
int newIstart | The new current year.
Collapse Expand Group

Assumptions Methods

Collapse Expand Links
Assumptions Class, Assumptions Members, Assumptions Methods


AssumptionsFile Class

AssumptionsFile Class
AssumptionsFile Data Members AssumptionsFile Methods AssumptionsFile Members AssumptionsFile.h Classes

Reads the average wage and benefit increase parameters from disk storage.

Collapse Expand Class Hierarchy
  AssumptionsFileAssumptionsFile
C++
class AssumptionsFile : public Assumptions;
Collapse Expand File

File: AssumptionsFile.h

Module: PiaData Library

Collapse Expand Remarks

Reads the average wage and benefit increase parameters from disk storage.

Collapse Expand Group

Classes

Collapse Expand Links
AssumptionsFile Data Members, AssumptionsFile Methods, AssumptionsFile Members, AssumptionsFile.h, Classes


AssumptionsFile Members

AssumptionsFile Members
AssumptionsFile Class Legend Public Data Members Public Methods

The following tables list the members exposed by AssumptionsFile.

Collapse Expand Class

AssumptionsFile Class

Collapse Expand Public Data Members
Name | Description
awincProj | Projected average wage increases.
biProj | Projected benefit increases.
catchupDoc | Catch-up benefit increases.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
Assumptions | Initializes an Assumptions, with or without a specified first year.
AssumptionsFile | Initializes arrays.
averageWageMenu | Reads stored average wage increases from disk.
benefitIncMenu | Reads stored benefit increases from disk.
getAverageWage | Returns an average wage increase assumption title.
getAwincProj | Returns projected average wage increases.
getBenefitInc | Returns a benefit increase assumption title.
getBiProj | Returns projected benefit increases.
getCatchupDoc | Returns catch-up benefit increases.
getIstart | Returns current year.
getMaxyear | Returns maximum projected year.
setAwincProjTitle | Set title of projected average wage increases.
setBiProjTitle | Set title of projected benefit increases.
setIstart | Sets the current year, including for the members.
~AssumptionsFile | Destructor.
Collapse Expand Links
AssumptionsFile Class, Legend, Public Data Members, Public Methods


AssumptionsFile::AssumptionsFile Constructor

AssumptionsFile::AssumptionsFile Constructor
AssumptionsFile Class AssumptionsFile Members AssumptionsFile Class

Initializes arrays.

C++
AssumptionsFile(
    int newIstart,
    int newMaxyear,
    const std::string& newDirectory
);
Collapse Expand Parameters
Parameters | Description
int newIstart | Year after last known benefit increase.
int newMaxyear | Maximum projected year.
const std::string& newDirectory | Directory with conversion table file.
Collapse Expand Class

AssumptionsFile Class

Collapse Expand Links
AssumptionsFile Class, AssumptionsFile Members, AssumptionsFile Class


AssumptionsFile::~AssumptionsFile Destructor

AssumptionsFile::~AssumptionsFile Destructor
AssumptionsFile Class AssumptionsFile Members AssumptionsFile Class

Destructor.

C++
~AssumptionsFile();
Collapse Expand Class

AssumptionsFile Class

Collapse Expand Links
AssumptionsFile Class, AssumptionsFile Members, AssumptionsFile Class


AssumptionsFile Data Members

AssumptionsFile Data Members
AssumptionsFile Class Legend Public Data Members

The data members of the AssumptionsFile class are listed here.

Collapse Expand Class

AssumptionsFile Class

Collapse Expand Public Data Members
Name | Description
awincProj | Projected average wage increases.
biProj | Projected benefit increases.
catchupDoc | Catch-up benefit increases.
Collapse Expand Links
AssumptionsFile Class, Legend, Public Data Members


AssumptionsFile::awincProj Data Member

AssumptionsFile::awincProj Data Member
AssumptionsFile Class AssumptionsFile Members AssumptionsFile Data Members

Projected average wage increases.

C++
AwincFile awincProj;
Collapse Expand Group

AssumptionsFile Data Members

Collapse Expand Links
AssumptionsFile Class, AssumptionsFile Members, AssumptionsFile Data Members


AssumptionsFile::biProj Data Member

AssumptionsFile::biProj Data Member
AssumptionsFile Class AssumptionsFile Members AssumptionsFile Data Members

Projected benefit increases.

C++
BiprojFile biProj;
Collapse Expand Group

AssumptionsFile Data Members

Collapse Expand Links
AssumptionsFile Class, AssumptionsFile Members, AssumptionsFile Data Members


AssumptionsFile::catchupDoc Data Member

AssumptionsFile::catchupDoc Data Member
AssumptionsFile Class AssumptionsFile Members AssumptionsFile Data Members

Catch-up benefit increases.

C++
CatchupFile catchupDoc;
Collapse Expand Group

AssumptionsFile Data Members

Collapse Expand Links
AssumptionsFile Class, AssumptionsFile Members, AssumptionsFile Data Members


AssumptionsFile Methods

AssumptionsFile Methods
AssumptionsFile Class Legend Public Methods

The methods of the AssumptionsFile class are listed here.

Collapse Expand Class

AssumptionsFile Class

Collapse Expand Public Methods
Name | Description
averageWageMenu | Reads stored average wage increases from disk.
benefitIncMenu | Reads stored benefit increases from disk.
getAwincProj | Returns projected average wage increases.
getBiProj | Returns projected benefit increases.
getCatchupDoc | Returns catch-up benefit increases.
setAwincProjTitle | Set title of projected average wage increases.
setBiProjTitle | Set title of projected benefit increases.
setIstart | Sets the current year, including for the members.
Collapse Expand Links
AssumptionsFile Class, Legend, Public Methods


AssumptionsFile::averageWageMenu Method

AssumptionsFile::averageWageMenu Method
AssumptionsFile Class AssumptionsFile Members AssumptionsFile Methods

Reads stored average wage increases from disk.

C++
void averageWageMenu(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative (1-4).
Collapse Expand Group

AssumptionsFile Methods

Collapse Expand Links
AssumptionsFile Class, AssumptionsFile Members, AssumptionsFile Methods


AssumptionsFile::benefitIncMenu Method

AssumptionsFile::benefitIncMenu Method
AssumptionsFile Class AssumptionsFile Members AssumptionsFile Methods

Reads stored benefit increases from disk.

C++
void benefitIncMenu(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative (1-4).
Collapse Expand Group

AssumptionsFile Methods

Collapse Expand Links
AssumptionsFile Class, AssumptionsFile Members, AssumptionsFile Methods


AssumptionsFile::getAwincProj Method

AssumptionsFile::getAwincProj Method
AssumptionsFile Class AssumptionsFile Members AssumptionsFile Methods

Returns projected average wage increases.

C++
const AwincDoc& getAwincProj() const;
Collapse Expand Returns

Projected average wage increases.

Collapse Expand Group

AssumptionsFile Methods

Collapse Expand Links
AssumptionsFile Class, AssumptionsFile Members, AssumptionsFile Methods


AssumptionsFile::getBiProj Method

AssumptionsFile::getBiProj Method
AssumptionsFile Class AssumptionsFile Members AssumptionsFile Methods

Returns projected benefit increases.

C++
const Biproj& getBiProj() const;
Collapse Expand Returns

Projected benefit increases.

Collapse Expand Group

AssumptionsFile Methods

Collapse Expand Links
AssumptionsFile Class, AssumptionsFile Members, AssumptionsFile Methods


AssumptionsFile::getCatchupDoc Method

AssumptionsFile::getCatchupDoc Method
AssumptionsFile Class AssumptionsFile Members AssumptionsFile Methods

Returns catch-up benefit increases.

C++
const CatchupDoc& getCatchupDoc() const;
Collapse Expand Returns

Catch-up benefit increases.

Collapse Expand Group

AssumptionsFile Methods

Collapse Expand Links
AssumptionsFile Class, AssumptionsFile Members, AssumptionsFile Methods


AssumptionsFile::setAwincProjTitle Method

AssumptionsFile::setAwincProjTitle Method
AssumptionsFile Class AssumptionsFile Members AssumptionsFile Methods

Set title of projected average wage increases.

C++
void setAwincProjTitle(
    int number
);
Collapse Expand Parameters
Parameters | Description
int number | Trustees Report assumption.
Collapse Expand Group

AssumptionsFile Methods

Collapse Expand Links
AssumptionsFile Class, AssumptionsFile Members, AssumptionsFile Methods


AssumptionsFile::setBiProjTitle Method

AssumptionsFile::setBiProjTitle Method
AssumptionsFile Class AssumptionsFile Members AssumptionsFile Methods

Set title of projected benefit increases.

C++
void setBiProjTitle(
    int number
);
Collapse Expand Parameters
Parameters | Description
int number | Trustees Report assumption.
Collapse Expand Group

AssumptionsFile Methods

Collapse Expand Links
AssumptionsFile Class, AssumptionsFile Members, AssumptionsFile Methods


AssumptionsFile::setIstart Method

AssumptionsFile::setIstart Method
AssumptionsFile Class AssumptionsFile Members AssumptionsFile Methods

Sets the current year, including for the members.

C++
void setIstart(
    int newIstart
);
Collapse Expand Parameters
Parameters | Description
int newIstart | New current year.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if year is out of range (only in debug mode).
Collapse Expand Group

AssumptionsFile Methods

Collapse Expand Links
AssumptionsFile Class, AssumptionsFile Members, AssumptionsFile Methods


AssumptionsNonFile Class

AssumptionsNonFile Class
AssumptionsNonFile Constructor AssumptionsNonFile Data Members AssumptionsNonFile Methods AssumptionsNonFile Members AssumptionsNonFile.h Classes

Contains the average wage and benefit increase assumptions (it does not read from disk).

Collapse Expand Class Hierarchy
  AssumptionsNonFileAssumptionsNonFile
C++
class AssumptionsNonFile : public Assumptions;
Collapse Expand File

File: AssumptionsNonFile.h

Module: PiaData Library

Collapse Expand Remarks

Contains the average wage and benefit increase assumptions (it does not read from disk).

Collapse Expand Group

Classes

Collapse Expand Links
AssumptionsNonFile Constructor, AssumptionsNonFile Data Members, AssumptionsNonFile Methods, AssumptionsNonFile Members, AssumptionsNonFile.h, Classes


AssumptionsNonFile Members

AssumptionsNonFile Members
AssumptionsNonFile Class Legend Public Data Members Public Methods

The following tables list the members exposed by AssumptionsNonFile.

Collapse Expand Class

AssumptionsNonFile Class

Collapse Expand Public Data Members
Name | Description
awincProj | Projected average wage increases.
biProj | Projected benefit increases.
catchupDoc | Catch-up benefit increases.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
Assumptions | Initializes an Assumptions, with or without a specified first year.
AssumptionsNonFile | Initializes an AssumptionsNonFile, either with or without a specified first year.
averageWageMenu | Reads stored average wage increases from a static array.
benefitIncMenu | Reads stored benefit increases from a static array.
getAverageWage | Returns an average wage increase assumption title.
getAwincProj | Returns projected average wage increases.
getBenefitInc | Returns a benefit increase assumption title.
getBiProj | Returns projected benefit increases.
getCatchupDoc | Returns catch-up benefit increases.
getIstart | Returns current year.
getMaxyear | Returns maximum projected year.
setAwincProjTitle | Set title of projected average wage increases.
setBiProjTitle | Set title of projected benefit increases.
setIstart | Sets the current year, including for the members.
~AssumptionsNonFile | Destructor.
Collapse Expand Links
AssumptionsNonFile Class, Legend, Public Data Members, Public Methods


AssumptionsNonFile Constructor

AssumptionsNonFile Constructor
AssumptionsNonFile Class

Initializes an AssumptionsNonFile, either with or without a specified first year.

Collapse Expand Description

There are two versions of the AssumptionsNonFile constructor. The last year of assumptions is always specified, but the first year can be specified or gotten from BaseYearNonFile.

Collapse Expand Overload List
Name | Description
AssumptionsNonFile::AssumptionsNonFile (int) | Initializes years, where the year after last known benefit increase is taken from BaseYearNonFile.
AssumptionsNonFile::AssumptionsNonFile (int, int) | Initializes years, where the year after last known benefit increase is specified.
Collapse Expand Class

AssumptionsNonFile Class

Collapse Expand Links
AssumptionsNonFile Class


AssumptionsNonFile::AssumptionsNonFile Constructor (int)

AssumptionsNonFile::AssumptionsNonFile Constructor (int)
AssumptionsNonFile Class AssumptionsNonFile Members AssumptionsNonFile Constructor

Initializes years, where the year after last known benefit increase is taken from BaseYearNonFile.

C++
AssumptionsNonFile(
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
int newMaxyear | Maximum projected year
Collapse Expand Group

AssumptionsNonFile Constructor

Collapse Expand Links
AssumptionsNonFile Class, AssumptionsNonFile Members, AssumptionsNonFile Constructor


AssumptionsNonFile::AssumptionsNonFile Constructor (int, int)

AssumptionsNonFile::AssumptionsNonFile Constructor (int, int)
AssumptionsNonFile Class AssumptionsNonFile Members AssumptionsNonFile Constructor

Initializes years, where the year after last known benefit increase is specified.

C++
AssumptionsNonFile(
    int newIstart,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
int newIstart | Year after last known benefit increase.
int newMaxyear | Maximum projected year
Collapse Expand Group

AssumptionsNonFile Constructor

Collapse Expand Links
AssumptionsNonFile Class, AssumptionsNonFile Members, AssumptionsNonFile Constructor


AssumptionsNonFile::~AssumptionsNonFile Destructor

AssumptionsNonFile::~AssumptionsNonFile Destructor
AssumptionsNonFile Class AssumptionsNonFile Members AssumptionsNonFile Class

Destructor.

C++
~AssumptionsNonFile();
Collapse Expand Class

AssumptionsNonFile Class

Collapse Expand Links
AssumptionsNonFile Class, AssumptionsNonFile Members, AssumptionsNonFile Class


AssumptionsNonFile Data Members

AssumptionsNonFile Data Members
AssumptionsNonFile Class Legend Public Data Members

The data members of the AssumptionsNonFile class are listed here.

Collapse Expand Class

AssumptionsNonFile Class

Collapse Expand Public Data Members
Name | Description
awincProj | Projected average wage increases.
biProj | Projected benefit increases.
catchupDoc | Catch-up benefit increases.
Collapse Expand Links
AssumptionsNonFile Class, Legend, Public Data Members


AssumptionsNonFile::awincProj Data Member

AssumptionsNonFile::awincProj Data Member
AssumptionsNonFile Class AssumptionsNonFile Members AssumptionsNonFile Data Members

Projected average wage increases.

C++
AwincNonFile awincProj;
Collapse Expand Group

AssumptionsNonFile Data Members

Collapse Expand Links
AssumptionsNonFile Class, AssumptionsNonFile Members, AssumptionsNonFile Data Members


AssumptionsNonFile::biProj Data Member

AssumptionsNonFile::biProj Data Member
AssumptionsNonFile Class AssumptionsNonFile Members AssumptionsNonFile Data Members

Projected benefit increases.

C++
BiprojNonFile biProj;
Collapse Expand Group

AssumptionsNonFile Data Members

Collapse Expand Links
AssumptionsNonFile Class, AssumptionsNonFile Members, AssumptionsNonFile Data Members


AssumptionsNonFile::catchupDoc Data Member

AssumptionsNonFile::catchupDoc Data Member
AssumptionsNonFile Class AssumptionsNonFile Members AssumptionsNonFile Data Members

Catch-up benefit increases.

C++
CatchupNonFile catchupDoc;
Collapse Expand Group

AssumptionsNonFile Data Members

Collapse Expand Links
AssumptionsNonFile Class, AssumptionsNonFile Members, AssumptionsNonFile Data Members


AssumptionsNonFile Methods

AssumptionsNonFile Methods
AssumptionsNonFile Class Legend Public Methods

The methods of the AssumptionsNonFile class are listed here.

Collapse Expand Class

AssumptionsNonFile Class

Collapse Expand Public Methods
Name | Description
averageWageMenu | Reads stored average wage increases from a static array.
benefitIncMenu | Reads stored benefit increases from a static array.
getAwincProj | Returns projected average wage increases.
getBiProj | Returns projected benefit increases.
getCatchupDoc | Returns catch-up benefit increases.
setAwincProjTitle | Set title of projected average wage increases.
setBiProjTitle | Set title of projected benefit increases.
setIstart | Sets the current year, including for the members.
Collapse Expand Links
AssumptionsNonFile Class, Legend, Public Methods


AssumptionsNonFile::averageWageMenu Method

AssumptionsNonFile::averageWageMenu Method
AssumptionsNonFile Class AssumptionsNonFile Members AssumptionsNonFile Methods

Reads stored average wage increases from a static array.

C++
void averageWageMenu(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative (1-4).
Collapse Expand Group

AssumptionsNonFile Methods

Collapse Expand Links
AssumptionsNonFile Class, AssumptionsNonFile Members, AssumptionsNonFile Methods


AssumptionsNonFile::benefitIncMenu Method

AssumptionsNonFile::benefitIncMenu Method
AssumptionsNonFile Class AssumptionsNonFile Members AssumptionsNonFile Methods

Reads stored benefit increases from a static array.

C++
void benefitIncMenu(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative (1-4).
Collapse Expand Group

AssumptionsNonFile Methods

Collapse Expand Links
AssumptionsNonFile Class, AssumptionsNonFile Members, AssumptionsNonFile Methods


AssumptionsNonFile::getAwincProj Method

AssumptionsNonFile::getAwincProj Method
AssumptionsNonFile Class AssumptionsNonFile Members AssumptionsNonFile Methods

Returns projected average wage increases.

C++
const AwincDoc& getAwincProj() const;
Collapse Expand Returns

Projected average wage increases.

Collapse Expand Group

AssumptionsNonFile Methods

Collapse Expand Links
AssumptionsNonFile Class, AssumptionsNonFile Members, AssumptionsNonFile Methods


AssumptionsNonFile::getBiProj Method

AssumptionsNonFile::getBiProj Method
AssumptionsNonFile Class AssumptionsNonFile Members AssumptionsNonFile Methods

Returns projected benefit increases.

C++
const Biproj& getBiProj() const;
Collapse Expand Returns

Projected benefit increases.

Collapse Expand Group

AssumptionsNonFile Methods

Collapse Expand Links
AssumptionsNonFile Class, AssumptionsNonFile Members, AssumptionsNonFile Methods


AssumptionsNonFile::getCatchupDoc Method

AssumptionsNonFile::getCatchupDoc Method
AssumptionsNonFile Class AssumptionsNonFile Members AssumptionsNonFile Methods

Returns catch-up benefit increases.

C++
const CatchupDoc& getCatchupDoc() const;
Collapse Expand Returns

Catch-up benefit increases.

Collapse Expand Group

AssumptionsNonFile Methods

Collapse Expand Links
AssumptionsNonFile Class, AssumptionsNonFile Members, AssumptionsNonFile Methods


AssumptionsNonFile::setAwincProjTitle Method

AssumptionsNonFile::setAwincProjTitle Method
AssumptionsNonFile Class AssumptionsNonFile Members AssumptionsNonFile Methods

Set title of projected average wage increases.

C++
void setAwincProjTitle(
    int number
);
Collapse Expand Parameters
Parameters | Description
int number | Trustees Report assumption.
Collapse Expand Group

AssumptionsNonFile Methods

Collapse Expand Links
AssumptionsNonFile Class, AssumptionsNonFile Members, AssumptionsNonFile Methods


AssumptionsNonFile::setBiProjTitle Method

AssumptionsNonFile::setBiProjTitle Method
AssumptionsNonFile Class AssumptionsNonFile Members AssumptionsNonFile Methods

Set title of projected benefit increases.

C++
void setBiProjTitle(
    int number
);
Collapse Expand Parameters
Parameters | Description
int number | Trustees Report assumption.
Collapse Expand Group

AssumptionsNonFile Methods

Collapse Expand Links
AssumptionsNonFile Class, AssumptionsNonFile Members, AssumptionsNonFile Methods


AssumptionsNonFile::setIstart Method

AssumptionsNonFile::setIstart Method
AssumptionsNonFile Class AssumptionsNonFile Members AssumptionsNonFile Methods

Sets the current year, including for the members.

C++
void setIstart(
    int newIstart
);
Collapse Expand Parameters
Parameters | Description
int newIstart | New current year.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if year is out of range (only in debug mode).
Collapse Expand Group

AssumptionsNonFile Methods

Collapse Expand Links
AssumptionsNonFile Class, AssumptionsNonFile Members, AssumptionsNonFile Methods


AssumptionType Class

AssumptionType Class
AssumptionType Enumerations AssumptionType Data Members AssumptionType Methods AssumptionType Members AssumptionType.h Classes

The assumption types (about future average wage and benefit increases) allowed in the piadata library.

Collapse Expand Class Hierarchy
  AssumptionType
C++
class AssumptionType;
Collapse Expand File

File: AssumptionType.h

Module: PiaData Library

Collapse Expand Remarks

There is an enum and some static functions, but no member variables, so there are no instances of this class.

Collapse Expand Group

Classes

Collapse Expand Links
AssumptionType Enumerations, AssumptionType Data Members, AssumptionType Methods, AssumptionType Members, AssumptionType.h, Classes


AssumptionType Members

AssumptionType Members
Enumerations AssumptionType Class Legend Public Data Members Public Methods

The following tables list the members exposed by AssumptionType.

Collapse Expand Enumerations
Name | Description
assum_type | Type of assumptions.
Collapse Expand Class

AssumptionType Class

Collapse Expand Public Data Members
Name | Description
EXPANDED_PEBES | True to use a wider range of possible assumptions for Statement calculations.
Collapse Expand Public Methods
Name | Description
ialtawCheck1 | Checks average wage increase indicator in general case.
ialtawCheck2 | Checks average wage increase indicator in Statement case.
ialtbiCheck1 | Checks benefit increase indicator in general case.
ialtbiCheck2 | Checks benefit increase indicator in Statement case.
isFlatOrPebs | Returns true if argument is a statement-type constant-dollar assumption.
isNotTR | Returns true if argument is not a Trustees Report assumption.
isTR | Returns true if argument is a Trustees Report assumption.
Collapse Expand Links
Enumerations, AssumptionType Class, Legend, Public Data Members, Public Methods


AssumptionType Enumerations

AssumptionType Enumerations
Enumerations AssumptionType Class Legend

The enumerations of the AssumptionType class are listed here.

Collapse Expand Enumerations
Name | Description
assum_type | Type of assumptions.
Collapse Expand Class

AssumptionType Class

Collapse Expand Links
Enumerations, AssumptionType Class, Legend


AssumptionType::assum_type Enumeration

AssumptionType::assum_type Enumeration
AssumptionType.h AssumptionType Enumerations

Type of assumptions.

C++
enum assum_type {
  NONE,
  ALTERN_I,
  ALTERN_IIB,
  ALTERN_III,
  ALTERN_IIA,
  FLAT,
  PEBS_ASSUM,
  OTHER_ASSUM
};
Collapse Expand File

File: AssumptionType.h

Module: PiaData Library

Collapse Expand Members
Members | Description
NONE | No assumptions chosen.
ALTERN_I | Alternative 1 from Trustees Report.
ALTERN_IIB | Alternative 2 from Trustees Report.
ALTERN_III | Alternative 3 from Trustees Report.
ALTERN_IIA | Flat assumptions (same as FLAT).
FLAT | Flat assumptions.
PEBS_ASSUM | Old PEBES assumptions.
OTHER_ASSUM | User-specified assumptions.
Collapse Expand Group

AssumptionType Enumerations

Collapse Expand Links
AssumptionType.h, AssumptionType Enumerations


AssumptionType Data Members

AssumptionType Data Members
AssumptionType Class Legend Public Data Members

The data members of the AssumptionType class are listed here.

Collapse Expand Class

AssumptionType Class

Collapse Expand Public Data Members
Name | Description
EXPANDED_PEBES | True to use a wider range of possible assumptions for Statement calculations.
Collapse Expand Links
AssumptionType Class, Legend, Public Data Members


AssumptionType::EXPANDED_PEBES Data Member

AssumptionType::EXPANDED_PEBES Data Member
AssumptionType Class AssumptionType Members AssumptionType Data Members

True to use a wider range of possible assumptions for Statement calculations.

C++
const bool EXPANDED_PEBES = false;
Collapse Expand Group

AssumptionType Data Members

Collapse Expand Links
AssumptionType Class, AssumptionType Members, AssumptionType Data Members


AssumptionType Methods

AssumptionType Methods
AssumptionType Class Legend Public Methods

The methods of the AssumptionType class are listed here.

Collapse Expand Class

AssumptionType Class

Collapse Expand Public Methods
Name | Description
ialtawCheck1 | Checks average wage increase indicator in general case.
ialtawCheck2 | Checks average wage increase indicator in Statement case.
ialtbiCheck1 | Checks benefit increase indicator in general case.
ialtbiCheck2 | Checks benefit increase indicator in Statement case.
isFlatOrPebs | Returns true if argument is a statement-type constant-dollar assumption.
isNotTR | Returns true if argument is not a Trustees Report assumption.
isTR | Returns true if argument is a Trustees Report assumption.
Collapse Expand Links
AssumptionType Class, Legend, Public Methods


AssumptionType::ialtawCheck1 Method

AssumptionType::ialtawCheck1 Method
AssumptionType Class AssumptionType Members AssumptionType Methods

Checks average wage increase indicator in general case.

C++
static void ialtawCheck1(
    int ialtawt
);
Collapse Expand Parameters
Parameters | Description
int ialtawt | Assumption type to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_IALTAW1 if average wage increase indicator is out of range in general case.
Collapse Expand Group

AssumptionType Methods

Collapse Expand Links
AssumptionType Class, AssumptionType Members, AssumptionType Methods


AssumptionType::ialtawCheck2 Method

AssumptionType::ialtawCheck2 Method
AssumptionType Class AssumptionType Members AssumptionType Methods

Checks average wage increase indicator in Statement case.

C++
static void ialtawCheck2(
    int ialtawt
);
Collapse Expand Parameters
Parameters | Description
int ialtawt | Assumption type to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_IALTAW2 if average wage increase indicator is out of range in Statement case.
Collapse Expand Group

AssumptionType Methods

Collapse Expand Links
AssumptionType Class, AssumptionType Members, AssumptionType Methods


AssumptionType::ialtbiCheck1 Method

AssumptionType::ialtbiCheck1 Method
AssumptionType Class AssumptionType Members AssumptionType Methods

Checks benefit increase indicator in general case.

C++
static void ialtbiCheck1(
    int ialtbit
);
Collapse Expand Parameters
Parameters | Description
int ialtbit | Assumption type to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_IALTBI1 if benefit increase indicator is out of range in general case.
Collapse Expand Group

AssumptionType Methods

Collapse Expand Links
AssumptionType Class, AssumptionType Members, AssumptionType Methods


AssumptionType::ialtbiCheck2 Method

AssumptionType::ialtbiCheck2 Method
AssumptionType Class AssumptionType Members AssumptionType Methods

Checks benefit increase indicator in Statement case.

C++
static void ialtbiCheck2(
    int ialtbit
);
Collapse Expand Parameters
Parameters | Description
int ialtbit | Assumption type to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_IALTBI2 if benefit increase indicator is out of range in Statement case.
Collapse Expand Group

AssumptionType Methods

Collapse Expand Links
AssumptionType Class, AssumptionType Members, AssumptionType Methods


AssumptionType::isFlatOrPebs Method

AssumptionType::isFlatOrPebs Method
AssumptionType Class AssumptionType Members AssumptionType Methods

Returns true if argument is a statement-type constant-dollar assumption.

C++
static bool isFlatOrPebs(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Assumption type to check.
Collapse Expand Returns

True if argument is a statement-type assumption (assum_type::FLAT or assum_type::PEBS_ASSUM).

Collapse Expand Group

AssumptionType Methods

Collapse Expand Links
AssumptionType Class, AssumptionType Members, AssumptionType Methods


AssumptionType::isNotTR Method

AssumptionType::isNotTR Method
AssumptionType Class AssumptionType Members AssumptionType Methods

Returns true if argument is not a Trustees Report assumption.

C++
static bool isNotTR(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Assumption type to check.
Collapse Expand Returns

True if argument is not a Trustees Report assumption (assum_type::FLAT, assum_type::PEBS_ASSUM, or assum_type::OTHER_ASSUM).

Collapse Expand Group

AssumptionType Methods

Collapse Expand Links
AssumptionType Class, AssumptionType Members, AssumptionType Methods


AssumptionType::isTR Method

AssumptionType::isTR Method
AssumptionType Class AssumptionType Members AssumptionType Methods

Returns true if argument is a Trustees Report assumption.

C++
static bool isTR(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Assumption type to check.
Collapse Expand Returns

True if argument is a Trustees Report assumption (assum_type::ALTERN_I, assum_type::ALTERN_IIB, assum_type::ALTERN_III, or assum_type::ALTERN_IIA).

Collapse Expand Group

AssumptionType Methods

Collapse Expand Links
AssumptionType Class, AssumptionType Members, AssumptionType Methods


AverageWage Class

AverageWage Class
AverageWage Methods AverageWage Operators AverageWage Friends AverageWage Members avgwg.h Classes

Manages an array of average wage indexing amounts, or any other earnings series.

Collapse Expand Class Hierarchy
  AverageWageAverageWage
C++
class AverageWage : public DoubleAnnual;
Collapse Expand File

File: avgwg.h

Module: PiaData Library

Collapse Expand Remarks

Manages an array of average wage indexing amounts, or any other earnings series.

Collapse Expand Group

Classes

Collapse Expand Links
AverageWage Methods, AverageWage Operators, AverageWage Friends, AverageWage Members, avgwg.h, Classes


AverageWage Members

AverageWage Members
AverageWage Class Legend Public Data Members Public Friends Public Methods

The following tables list the members exposed by AverageWage.

Collapse Expand Class

AverageWage Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Allows serialization of this class.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
AverageWage | Initializes the first and last years.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
endYear | Returns the last year that data > 4.5, or returns 0.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects average wage amounts.
projectBackward | Projects the earnings amount backward for the specified year.
projectBackwardStatic | Projects an earnings amount back for one year.
projectForward | Projects the earnings amount forward for the specified year.
projectForwardStatic | Projects an earnings amount forward for one year.
round | Rounds an earnings amount to 2 decimal places.
startYear | Returns the first year that data > 4.5, or returns 0.
~AverageWage | Destroys average wage array.
Collapse Expand Public Operators
Name | Description
= | Sets this instance equal to another instance.
[] | Functions to access an element of the array.
Collapse Expand Links
AverageWage Class, Legend, Public Data Members, Public Friends, Public Methods


AverageWage::AverageWage Constructor

AverageWage::AverageWage Constructor
AverageWage Class AverageWage Members AverageWage Class

Initializes the first and last years.

C++
AverageWage(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | Year that array starts in.
int newLastYear | Maximum year of projection.
Collapse Expand Class

AverageWage Class

Collapse Expand Links
AverageWage Class, AverageWage Members, AverageWage Class


AverageWage::~AverageWage Destructor

AverageWage::~AverageWage Destructor
AverageWage Class AverageWage Members AverageWage Class

Destroys average wage array.

C++
~AverageWage();
Collapse Expand Class

AverageWage Class

Collapse Expand Links
AverageWage Class, AverageWage Members, AverageWage Class


AverageWage Methods

AverageWage Methods
AverageWage Class Legend Public Methods

The methods of the AverageWage class are listed here.

Collapse Expand Class

AverageWage Class

Collapse Expand Public Methods
Name | Description
endYear | Returns the last year that data > 4.5, or returns 0.
project | Projects average wage amounts.
projectBackward | Projects the earnings amount backward for the specified year.
projectBackwardStatic | Projects an earnings amount back for one year.
projectForward | Projects the earnings amount forward for the specified year.
projectForwardStatic | Projects an earnings amount forward for one year.
round | Rounds an earnings amount to 2 decimal places.
startYear | Returns the first year that data > 4.5, or returns 0.
Collapse Expand Links
AverageWage Class, Legend, Public Methods


AverageWage::endYear Method

AverageWage::endYear Method
AverageWage Class AverageWage Members AverageWage Methods

Returns the last year that data > 4.5, or returns 0.

C++
int endYear() const;
Collapse Expand Returns

The last year that data > 4.5, or returns 0.

Collapse Expand Group

AverageWage Methods

Collapse Expand Links
AverageWage Class, AverageWage Members, AverageWage Methods


project Method

project Method
AverageWage Methods

Projects average wage amounts.

Collapse Expand Description

There are two versions of the project function. If the last year is not specified, the projection goes to the last year of the stored data array. There can be an array of multipliers, or one constant that is used for all years.

Collapse Expand Overload List
Name | Description
AverageWage::project (const Awinc&, int) | Projects average wage amounts to the last year of the vector of average wage amounts.
AverageWage::project (double, int, int) | Projects average wage amounts to a specified last year.
Collapse Expand Group

AverageWage Methods

Collapse Expand Links
AverageWage Methods


AverageWage::project Method (const Awinc&, int)

AverageWage::project Method (const Awinc&, int)
AverageWage Class AverageWage Members project Method

Projects average wage amounts to the last year of the vector of average wage amounts.

C++
void project(
    const Awinc& averageWageInc,
    int firstYeart
);
Collapse Expand Parameters
Parameters | Description
const Awinc& averageWageInc | Average wage percentage increases (e.g. 5.0 for 5 percent increase).
int firstYeart | First year to project.
Collapse Expand Group

project Method

Collapse Expand Links
AverageWage Class, AverageWage Members, project Method


AverageWage::project Method (double, int, int)

AverageWage::project Method (double, int, int)
AverageWage Class AverageWage Members project Method

Projects average wage amounts to a specified last year.

C++
void project(
    double factor,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
double factor | Multiplicative factor used to increase each year (e.g. 1.05).
int firstYeart | First year to project.
int lastYeart | Last year to project to.
Collapse Expand Group

project Method

Collapse Expand Links
AverageWage Class, AverageWage Members, project Method


AverageWage::projectBackward Method

AverageWage::projectBackward Method
AverageWage Class AverageWage Members AverageWage Methods

Projects the earnings amount backward for the specified year.

C++
void projectBackward(
    int year,
    double factor
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which average wage is desired.
double factor | Multiplicative factor used to decrease from following year.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_AVGWG if year is out of range (only in debug mode).
Collapse Expand Group

AverageWage Methods

Collapse Expand Links
AverageWage Class, AverageWage Members, AverageWage Methods


AverageWage::projectBackwardStatic Method

AverageWage::projectBackwardStatic Method
AverageWage Class AverageWage Members AverageWage Methods

Projects an earnings amount back for one year.

C++
static double projectBackwardStatic(
    double amount,
    double factor
);
Collapse Expand Parameters
Parameters | Description
double amount | The earnings to be projected.
double factor | Multiplicative factor used to decrease earnings from following year.
Collapse Expand Returns

The backward-projected earnings.

Collapse Expand Group

AverageWage Methods

Collapse Expand Links
AverageWage Class, AverageWage Members, AverageWage Methods


AverageWage::projectForward Method

AverageWage::projectForward Method
AverageWage Class AverageWage Members AverageWage Methods

Projects the earnings amount forward for the specified year.

C++
void projectForward(
    int year,
    double factor
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which average wage is desired.
double factor | Multiplicative factor used to increase previous year.
Collapse Expand Remarks

Calls projectForwardStatic with an amount and a factor.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_AVGWG if year is out of range (only in debug mode).
Collapse Expand Group

AverageWage Methods

Collapse Expand Links
AverageWage Class, AverageWage Members, AverageWage Methods


AverageWage::projectForwardStatic Method

AverageWage::projectForwardStatic Method
AverageWage Class AverageWage Members AverageWage Methods

Projects an earnings amount forward for one year.

C++
static double projectForwardStatic(
    double amount,
    double factor
);
Collapse Expand Parameters
Parameters | Description
double amount | The earnings to be projected.
double factor | Multiplicative factor used to increase earnings from previous year.
Collapse Expand Returns

The projected earnings.

Collapse Expand Group

AverageWage Methods

Collapse Expand Links
AverageWage Class, AverageWage Members, AverageWage Methods


AverageWage::round Method

AverageWage::round Method
AverageWage Class AverageWage Members AverageWage Methods

Rounds an earnings amount to 2 decimal places.

C++
static double round(
    double wage
);
Collapse Expand Parameters
Parameters | Description
double wage | The earnings to be rounded.
Collapse Expand Returns

Rounded earnings.

Collapse Expand Group

AverageWage Methods

Collapse Expand Links
AverageWage Class, AverageWage Members, AverageWage Methods


AverageWage::startYear Method

AverageWage::startYear Method
AverageWage Class AverageWage Members AverageWage Methods

Returns the first year that data > 4.5, or returns 0.

C++
int startYear() const;
Collapse Expand Returns

The first year that data > 4.5, or returns 0.

Collapse Expand Group

AverageWage Methods

Collapse Expand Links
AverageWage Class, AverageWage Members, AverageWage Methods


AverageWage Operators

AverageWage Operators
AverageWage Class Legend

The operators of the AverageWage class are listed here.

Collapse Expand Class

AverageWage Class

Collapse Expand Public Operators
Name | Description
= | Sets this instance equal to another instance.
Collapse Expand Links
AverageWage Class, Legend


AverageWage::= Operator

AverageWage::= Operator
AverageWage Class AverageWage Members AverageWage Operators

Sets this instance equal to another instance.

C++
AverageWage& operator =(
    const AverageWage& newData
);
Collapse Expand Parameters
Parameters | Description
const AverageWage& newData | The instance to copy from.
Collapse Expand Returns

A reference to this AverageWage.

Collapse Expand Group

AverageWage Operators

Collapse Expand Links
AverageWage Class, AverageWage Members, AverageWage Operators


AverageWage Friends

AverageWage Friends
AverageWage Class Public Friends

The friends of the AverageWage class are listed here.

Collapse Expand Class

AverageWage Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Allows serialization of this class.
Collapse Expand Links
AverageWage Class, Public Friends


friend class boost::serialization::access Friend

friend class boost::serialization::access Friend
AverageWage Class AverageWage Members AverageWage Friends

Allows serialization of this class.

C++
friend class boost::serialization::access;
Collapse Expand Group

AverageWage Friends

Collapse Expand Links
AverageWage Class, AverageWage Members, AverageWage Friends


AwbiData Class

AwbiData Class
AwbiData Constructor AwbiData Data Members AwbiData Methods AwbiData Members awbidat.h Classes

Manages the historical Social Security parameters.

Collapse Expand Class Hierarchy
  AwbiData
C++
class AwbiData;
Collapse Expand File

File: awbidat.h

Module: PiaData Library

Collapse Expand Remarks

Manages the historical Social Security parameters: historical benefit increases, average wages, OASDI wage bases, old-law wage bases, and HI wage bases. This class cannot be instantiated; use one of its subclasses: AwbiDataFile or AwbiDataNonFile.

Collapse Expand Group

Classes

Collapse Expand Links
AwbiData Constructor, AwbiData Data Members, AwbiData Methods, AwbiData Members, awbidat.h, Classes


AwbiData Members

AwbiData Members
AwbiData Class Legend Public Data Members Public Methods

The following tables list the members exposed by AwbiData.

Collapse Expand Class

AwbiData Class

Collapse Expand Public Data Members
Name | Description
HI_BASE_YEAR | Year when HI wage base first differs from OASDI base.
base77 | Historical old-law wage bases.
baseHi | Historical HI wage bases.
baseOasdi | Historical OASDI wage bases.
cpiinc | Historical benefit increases.
fq | Historical average wages.
Collapse Expand Public Methods
Name | Description
AwbiData | Initializes an AwbiData, with or without specifying the last year of historical wage bases.
getLastYear | Gets last year of historical wage bases.
read | Dummy function (descendant class may use it).
setData | Set data values.
setLastYear | Sets last year of historical wage bases.
write | Dummy function (descendant class may use it).
~AwbiData | Destructor.
Collapse Expand Links
AwbiData Class, Legend, Public Data Members, Public Methods


AwbiData Constructor

AwbiData Constructor
AwbiData Class

Initializes an AwbiData, with or without specifying the last year of historical wage bases.

Collapse Expand Description

There are two versions of the AwbiData constructor. Both specify the last year of projection. The last year of historical wage bases can be specified; otherwise, it is set equal to the last year of historical wage bases stored in the code.

Collapse Expand Overload List
Name | Description
AwbiData::AwbiData (int) | Initializes historical parameters info, where the last year of historical wage bases is set to BaseYearNonFile::YEAR.
AwbiData::AwbiData (int, int) | Initializes historical parameters info, where the last year of historical wage bases is specified.
Collapse Expand Class

AwbiData Class

Collapse Expand Links
AwbiData Class


AwbiData::AwbiData Constructor (int)

AwbiData::AwbiData Constructor (int)
AwbiData Class AwbiData Members AwbiData Constructor

Initializes historical parameters info, where the last year of historical wage bases is set to BaseYearNonFile::YEAR.

C++
explicit AwbiData(
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
int newMaxyear | Maximum projected year.
Collapse Expand Group

AwbiData Constructor

Collapse Expand Links
AwbiData Class, AwbiData Members, AwbiData Constructor


AwbiData::AwbiData Constructor (int, int)

AwbiData::AwbiData Constructor (int, int)
AwbiData Class AwbiData Members AwbiData Constructor

Initializes historical parameters info, where the last year of historical wage bases is specified.

C++
AwbiData(
    int newLastYear,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Last year of wage bases.
int newMaxyear | Maximum projected year.
Collapse Expand Group

AwbiData Constructor

Collapse Expand Links
AwbiData Class, AwbiData Members, AwbiData Constructor


AwbiData::~AwbiData Destructor

AwbiData::~AwbiData Destructor
AwbiData Class AwbiData Members AwbiData Class

Destructor.

C++
virtual ~AwbiData();
Collapse Expand Class

AwbiData Class

Collapse Expand Links
AwbiData Class, AwbiData Members, AwbiData Class


AwbiData Data Members

AwbiData Data Members
AwbiData Class Legend Public Data Members

The data members of the AwbiData class are listed here.

Collapse Expand Class

AwbiData Class

Collapse Expand Public Data Members
Name | Description
HI_BASE_YEAR | Year when HI wage base first differs from OASDI base.
base77 | Historical old-law wage bases.
baseHi | Historical HI wage bases.
baseOasdi | Historical OASDI wage bases.
cpiinc | Historical benefit increases.
fq | Historical average wages.
Collapse Expand Links
AwbiData Class, Legend, Public Data Members


AwbiData::HI_BASE_YEAR Data Member

AwbiData::HI_BASE_YEAR Data Member
AwbiData Class AwbiData Members AwbiData Data Members

Year when HI wage base first differs from OASDI base.

C++
const int HI_BASE_YEAR = 1991;
Collapse Expand Group

AwbiData Data Members

Collapse Expand Links
AwbiData Class, AwbiData Members, AwbiData Data Members


AwbiData::base77 Data Member

AwbiData::base77 Data Member
AwbiData Class AwbiData Members AwbiData Data Members

Historical old-law wage bases.

C++
DoubleAnnual base77;
Collapse Expand Group

AwbiData Data Members

Collapse Expand Links
AwbiData Class, AwbiData Members, AwbiData Data Members


AwbiData::baseHi Data Member

AwbiData::baseHi Data Member
AwbiData Class AwbiData Members AwbiData Data Members

Historical HI wage bases.

C++
DoubleAnnual baseHi;
Collapse Expand Group

AwbiData Data Members

Collapse Expand Links
AwbiData Class, AwbiData Members, AwbiData Data Members


AwbiData::baseOasdi Data Member

AwbiData::baseOasdi Data Member
AwbiData Class AwbiData Members AwbiData Data Members

Historical OASDI wage bases.

C++
DoubleAnnual baseOasdi;
Collapse Expand Group

AwbiData Data Members

Collapse Expand Links
AwbiData Class, AwbiData Members, AwbiData Data Members


AwbiData::cpiinc Data Member

AwbiData::cpiinc Data Member
AwbiData Class AwbiData Members AwbiData Data Members

Historical benefit increases.

C++
DoubleAnnual cpiinc;
Collapse Expand Group

AwbiData Data Members

Collapse Expand Links
AwbiData Class, AwbiData Members, AwbiData Data Members


AwbiData::fq Data Member

AwbiData::fq Data Member
AwbiData Class AwbiData Members AwbiData Data Members

Historical average wages.

C++
DoubleAnnual fq;
Collapse Expand Group

AwbiData Data Members

Collapse Expand Links
AwbiData Class, AwbiData Members, AwbiData Data Members


AwbiData Methods

AwbiData Methods
AwbiData Class Legend Public Methods

The methods of the AwbiData class are listed here.

Collapse Expand Class

AwbiData Class

Collapse Expand Public Methods
Name | Description
getLastYear | Gets last year of historical wage bases.
read | Dummy function (descendant class may use it).
setData | Set data values.
setLastYear | Sets last year of historical wage bases.
write | Dummy function (descendant class may use it).
Collapse Expand Links
AwbiData Class, Legend, Public Methods


AwbiData::getLastYear Method

AwbiData::getLastYear Method
AwbiData Class AwbiData Members AwbiData Methods

Gets last year of historical wage bases.

C++
int getLastYear() const;
Collapse Expand Returns

Last year of historical wage bases.

Collapse Expand Group

AwbiData Methods

Collapse Expand Links
AwbiData Class, AwbiData Members, AwbiData Methods


AwbiData::read Method

AwbiData::read Method
AwbiData Class AwbiData Members AwbiData Methods

Dummy function (descendant class may use it).

C++
virtual void read();
Collapse Expand Group

AwbiData Methods

Collapse Expand Links
AwbiData Class, AwbiData Members, AwbiData Methods


AwbiData::setData Method

AwbiData::setData Method
AwbiData Class AwbiData Members AwbiData Methods

Set data values.

C++
virtual void setData() = 0;
Collapse Expand Group

AwbiData Methods

Collapse Expand Links
AwbiData Class, AwbiData Members, AwbiData Methods


AwbiData::setLastYear Method

AwbiData::setLastYear Method
AwbiData Class AwbiData Members AwbiData Methods

Sets last year of historical wage bases.

C++
void setLastYear(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Last year of historical wage bases.
Collapse Expand Group

AwbiData Methods

Collapse Expand Links
AwbiData Class, AwbiData Members, AwbiData Methods


AwbiData::write Method

AwbiData::write Method
AwbiData Class AwbiData Members AwbiData Methods

Dummy function (descendant class may use it).

C++
virtual void write();
Collapse Expand Group

AwbiData Methods

Collapse Expand Links
AwbiData Class, AwbiData Members, AwbiData Methods


AwbiDataFile Class

AwbiDataFile Class
AwbiDataFile Methods AwbiDataFile Members AwbiDataFile.h Classes

Manages the historical Social Security parameters stored in a file.

Collapse Expand Class Hierarchy
  AwbiDataFileAwbiDataFile
C++
class AwbiDataFile : public AwbiData;
Collapse Expand File

File: AwbiDataFile.h

Module: PiaData Library

Collapse Expand Remarks

See AwbiDataNonFile for a version of this class that stores the parameters internally.

Collapse Expand See Also

AwbiDataNonFile

Collapse Expand Group

Classes

Collapse Expand Links
AwbiDataFile Methods, AwbiDataFile Members, AwbiDataFile.h, Classes


AwbiDataFile Members

AwbiDataFile Members
AwbiDataFile Class Legend Public Data Members Public Methods

The following tables list the members exposed by AwbiDataFile.

Collapse Expand Class

AwbiDataFile Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
HI_BASE_YEAR | Year when HI wage base first differs from OASDI base.
base77 | Historical old-law wage bases.
baseHi | Historical HI wage bases.
baseOasdi | Historical OASDI wage bases.
cpiinc | Historical benefit increases.
fq | Historical average wages.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
AwbiData | Initializes an AwbiData, with or without specifying the last year of historical wage bases.
AwbiDataFile | Initializes historical parameters info.
getLastYear | Gets last year of historical wage bases.
read | Reads historical parameters.
setAwbiFile | Forms a file name for historical parameters file.
setData | Dummy function (descendant class may use it).
setLastYear | Sets last year of historical wage bases.
write | Writes historical parameters.
Collapse Expand Links
AwbiDataFile Class, Legend, Public Data Members, Public Methods


AwbiDataFile::AwbiDataFile Constructor

AwbiDataFile::AwbiDataFile Constructor
AwbiDataFile Class AwbiDataFile Members AwbiDataFile Class

Initializes historical parameters info.

C++
AwbiDataFile(
    int newLastYear,
    int newMaxyear,
    const std::string& newDirectory
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Last year of wage bases.
int newMaxyear | Maximum projected year.
const std::string& newDirectory | Directory with historical parameters file.
Collapse Expand Class

AwbiDataFile Class

Collapse Expand Links
AwbiDataFile Class, AwbiDataFile Members, AwbiDataFile Class


AwbiDataFile Methods

AwbiDataFile Methods
AwbiDataFile Class Legend Public Methods

The methods of the AwbiDataFile class are listed here.

Collapse Expand Class

AwbiDataFile Class

Collapse Expand Public Methods
Name | Description
read | Reads historical parameters.
setAwbiFile | Forms a file name for historical parameters file.
setData | Dummy function (descendant class may use it).
write | Writes historical parameters.
Collapse Expand Links
AwbiDataFile Class, Legend, Public Methods


read Method

read Method
AwbiDataFile Methods

Reads historical parameters.

Collapse Expand Description

There are two versions of the read function. The version without an argument opens an input and passes it to the version with a stream argument.

Collapse Expand Overload List
Name | Description
AwbiDataFile::read () | Reads historical parameters.
AwbiDataFile::read (std::istream&) | Reads historical parameters from an open file.
Collapse Expand Group

AwbiDataFile Methods

Collapse Expand Links
AwbiDataFile Methods


AwbiDataFile::read Method ()

AwbiDataFile::read Method ()
AwbiDataFile Class AwbiDataFile Members read Method

Reads historical parameters.

C++
void read();
Collapse Expand Remarks

This version opens an input file and passes that file as an argument to the version with one argument.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_AWBI1 if unable to open input file. PiaException of type PIA_IDS_AWBI3 if unable to read all required data.
Collapse Expand Group

read Method

Collapse Expand Links
AwbiDataFile Class, AwbiDataFile Members, read Method


AwbiDataFile::read Method (std::istream&)

AwbiDataFile::read Method (std::istream&)
AwbiDataFile Class AwbiDataFile Members read Method

Reads historical parameters from an open file.

C++
void read(
    std::istream& in
);
Collapse Expand Parameters
Parameters | Description
std::istream& in | An open input stream to read from.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_AWBI3 if unable to read all required data.
Collapse Expand Group

read Method

Collapse Expand Links
AwbiDataFile Class, AwbiDataFile Members, read Method


AwbiDataFile::setAwbiFile Method

AwbiDataFile::setAwbiFile Method
AwbiDataFile Class AwbiDataFile Members AwbiDataFile Methods

Forms a file name for historical parameters file.

C++
void setAwbiFile();
Collapse Expand Group

AwbiDataFile Methods

Collapse Expand Links
AwbiDataFile Class, AwbiDataFile Members, AwbiDataFile Methods


AwbiDataFile::setData Method

AwbiDataFile::setData Method
AwbiDataFile Class AwbiDataFile Members AwbiDataFile Methods

Dummy function (descendant class may use it).

C++
void setData();
Collapse Expand Group

AwbiDataFile Methods

Collapse Expand Links
AwbiDataFile Class, AwbiDataFile Members, AwbiDataFile Methods


write Method

write Method
AwbiDataFile Methods

Writes historical parameters.

Collapse Expand Description

There are two versions of the write function. The version without an argument opens an input and passes it to the version with a stream argument.

Collapse Expand Overload List
Name | Description
AwbiDataFile::write () | Saves historical parameters.
AwbiDataFile::write (std::ostream&) | Saves historical parameters to an open file.
Collapse Expand Group

AwbiDataFile Methods

Collapse Expand Links
AwbiDataFile Methods


AwbiDataFile::write Method ()

AwbiDataFile::write Method ()
AwbiDataFile Class AwbiDataFile Members write Method

Saves historical parameters.

C++
void write();
Collapse Expand Remarks

This version opens an output file and passes that file as an argument to the version with one argument.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_AWBI2 if unable to open output file.
Collapse Expand Group

write Method

Collapse Expand Links
AwbiDataFile Class, AwbiDataFile Members, write Method


AwbiDataFile::write Method (std::ostream&)

AwbiDataFile::write Method (std::ostream&)
AwbiDataFile Class AwbiDataFile Members write Method

Saves historical parameters to an open file.

C++
void write(
    std::ostream& out
);
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream to write to.
Collapse Expand Group

write Method

Collapse Expand Links
AwbiDataFile Class, AwbiDataFile Members, write Method


AwbiDataNonFile Class

AwbiDataNonFile Class
AwbiDataNonFile Constructor AwbiDataNonFile Methods AwbiDataNonFile Members AwbiDataNonFile.h Classes

Manages the historical Social Security parameters stored in arrays in the code.

Collapse Expand Class Hierarchy
  AwbiDataNonFileAwbiDataNonFile
C++
class AwbiDataNonFile : public AwbiData;
Collapse Expand File

File: AwbiDataNonFile.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is used in the Anypia program. See AwbiDataFile for a version of this class that stores the parameters in a file.

Collapse Expand See Also

AwbiDataFile

Collapse Expand Group

Classes

Collapse Expand Links
AwbiDataNonFile Constructor, AwbiDataNonFile Methods, AwbiDataNonFile Members, AwbiDataNonFile.h, Classes


AwbiDataNonFile Members

AwbiDataNonFile Members
AwbiDataNonFile Class Legend Public Data Members Public Methods

The following tables list the members exposed by AwbiDataNonFile.

Collapse Expand Class

AwbiDataNonFile Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
HI_BASE_YEAR | Year when HI wage base first differs from OASDI base.
base77 | Historical old-law wage bases.
baseHi | Historical HI wage bases.
baseOasdi | Historical OASDI wage bases.
cpiinc | Historical benefit increases.
fq | Historical average wages.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
AwbiData | Initializes an AwbiData, with or without specifying the last year of historical wage bases.
AwbiDataNonFile | Initializes an AwbiDataNonFile, with or without specifying the last year of historical wage bases.
getBase77Data | Returns a historical old-law wage base.
getBaseHiData | Returns a historical HI wage base.
getBaseOasdiData | Returns a historical OASDI wage base.
getCpiincData | Returns a historical benefit increase.
getFqData | Returns a historical average indexing wage.
getLastYear | Gets last year of historical wage bases.
read | Dummy function (descendant class may use it).
setData | Sets values for historical parameters through the last year of historical wage bases (to avoid reading from disk).
setLastYear | Sets last year of historical wage bases.
write | Dummy function (descendant class may use it).
Collapse Expand Links
AwbiDataNonFile Class, Legend, Public Data Members, Public Methods


AwbiDataNonFile Constructor

AwbiDataNonFile Constructor
AwbiDataNonFile Class

Initializes an AwbiDataNonFile, with or without specifying the last year of historical wage bases.

Collapse Expand Description

There are two versions of the AwbiDataNonFile constructor. Both specify the last year of projection. The last year of historical wage bases can be specified; otherwise, it is set equal to the last year of historical wage bases stored in the code.

Collapse Expand Overload List
Name | Description
AwbiDataNonFile::AwbiDataNonFile (int) | Initializes historical parameters info, where the last year of wage bases is set to BaseYearNonFile::YEAR.
AwbiDataNonFile::AwbiDataNonFile (int, int) | Initializes historical parameters info, where the last year of wage bases is specified.
Collapse Expand Class

AwbiDataNonFile Class

Collapse Expand Links
AwbiDataNonFile Class


AwbiDataNonFile::AwbiDataNonFile Constructor (int)

AwbiDataNonFile::AwbiDataNonFile Constructor (int)
AwbiDataNonFile Class AwbiDataNonFile Members AwbiDataNonFile Constructor

Initializes historical parameters info, where the last year of wage bases is set to BaseYearNonFile::YEAR.

C++
explicit AwbiDataNonFile(
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
int newMaxyear | Maximum projected year.
Collapse Expand Remarks

Calls setData after setting the last year of wage bases and the maximum year of projection.

Collapse Expand Group

AwbiDataNonFile Constructor

Collapse Expand Links
AwbiDataNonFile Class, AwbiDataNonFile Members, AwbiDataNonFile Constructor


AwbiDataNonFile::AwbiDataNonFile Constructor (int, int)

AwbiDataNonFile::AwbiDataNonFile Constructor (int, int)
AwbiDataNonFile Class AwbiDataNonFile Members AwbiDataNonFile Constructor

Initializes historical parameters info, where the last year of wage bases is specified.

C++
AwbiDataNonFile(
    int newLastYear,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Last year of wage bases.
int newMaxyear | Maximum projected year.
Collapse Expand Remarks

Calls setData after setting the last year of wage bases and the maximum year of projection.

Collapse Expand Group

AwbiDataNonFile Constructor

Collapse Expand Links
AwbiDataNonFile Class, AwbiDataNonFile Members, AwbiDataNonFile Constructor


AwbiDataNonFile Methods

AwbiDataNonFile Methods
AwbiDataNonFile Class Legend Public Methods

The methods of the AwbiDataNonFile class are listed here.

Collapse Expand Class

AwbiDataNonFile Class

Collapse Expand Public Methods
Name | Description
getBase77Data | Returns a historical old-law wage base.
getBaseHiData | Returns a historical HI wage base.
getBaseOasdiData | Returns a historical OASDI wage base.
getCpiincData | Returns a historical benefit increase.
getFqData | Returns a historical average indexing wage.
setData | Sets values for historical parameters through the last year of historical wage bases (to avoid reading from disk).
Collapse Expand Links
AwbiDataNonFile Class, Legend, Public Methods


AwbiDataNonFile::getBase77Data Method

AwbiDataNonFile::getBase77Data Method
AwbiDataNonFile Class AwbiDataNonFile Members AwbiDataNonFile Methods

Returns a historical old-law wage base.

C++
static double getBase77Data(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which old-law wage base is desired.
Collapse Expand Returns

The old-law wage base for the specified year.

Collapse Expand Group

AwbiDataNonFile Methods

Collapse Expand Links
AwbiDataNonFile Class, AwbiDataNonFile Members, AwbiDataNonFile Methods


AwbiDataNonFile::getBaseHiData Method

AwbiDataNonFile::getBaseHiData Method
AwbiDataNonFile Class AwbiDataNonFile Members AwbiDataNonFile Methods

Returns a historical HI wage base.

C++
static double getBaseHiData(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which HI wage base is desired.
Collapse Expand Returns

The HI wage base for the specified year.

Collapse Expand Group

AwbiDataNonFile Methods

Collapse Expand Links
AwbiDataNonFile Class, AwbiDataNonFile Members, AwbiDataNonFile Methods


AwbiDataNonFile::getBaseOasdiData Method

AwbiDataNonFile::getBaseOasdiData Method
AwbiDataNonFile Class AwbiDataNonFile Members AwbiDataNonFile Methods

Returns a historical OASDI wage base.

C++
static double getBaseOasdiData(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which OASDI wage base is desired.
Collapse Expand Returns

The OASDI wage base for the specified year.

Collapse Expand Group

AwbiDataNonFile Methods

Collapse Expand Links
AwbiDataNonFile Class, AwbiDataNonFile Members, AwbiDataNonFile Methods


AwbiDataNonFile::getCpiincData Method

AwbiDataNonFile::getCpiincData Method
AwbiDataNonFile Class AwbiDataNonFile Members AwbiDataNonFile Methods

Returns a historical benefit increase.

C++
static double getCpiincData(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which benefit increase is desired.
Collapse Expand Returns

The benefit increase for the specified year.

Collapse Expand Group

AwbiDataNonFile Methods

Collapse Expand Links
AwbiDataNonFile Class, AwbiDataNonFile Members, AwbiDataNonFile Methods


AwbiDataNonFile::getFqData Method

AwbiDataNonFile::getFqData Method
AwbiDataNonFile Class AwbiDataNonFile Members AwbiDataNonFile Methods

Returns a historical average indexing wage.

C++
static double getFqData(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which average indexing wage is desired.
Collapse Expand Returns

The average indexing wage for the specified year.

Collapse Expand Group

AwbiDataNonFile Methods

Collapse Expand Links
AwbiDataNonFile Class, AwbiDataNonFile Members, AwbiDataNonFile Methods


AwbiDataNonFile::setData Method

AwbiDataNonFile::setData Method
AwbiDataNonFile Class AwbiDataNonFile Members AwbiDataNonFile Methods

Sets values for historical parameters through the last year of historical wage bases (to avoid reading from disk).

C++
void setData();
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_AWBIDAT1 if last year of historical data is greater than BaseYearNonFile::YEAR (only in debug mode).
Collapse Expand Group

AwbiDataNonFile Methods

Collapse Expand Links
AwbiDataNonFile Class, AwbiDataNonFile Members, AwbiDataNonFile Methods


Awinc Class

Awinc Class
Awinc Constructor Awinc Methods Awinc Members awinc.h Classes

Manages a vector of projected average wage increases.

Collapse Expand Class Hierarchy
  AwincAwinc
C++
class Awinc : public DoubleAnnual;
Collapse Expand File

File: awinc.h

Module: PiaData Library

Collapse Expand Remarks

Manages a vector of projected average wage increases.

Collapse Expand Group

Classes

Collapse Expand Links
Awinc Constructor, Awinc Methods, Awinc Members, awinc.h, Classes


Awinc Members

Awinc Members
Awinc Class Legend Public Data Members Public Friends Public Methods

The following tables list the members exposed by Awinc.

Collapse Expand Class

Awinc Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
Awinc | Initializes an Awinc, with or without specifying the first year of data.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
fqincCheck | Checks an average wage increase.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Calculates average wage increases.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
Awinc Class, Legend, Public Data Members, Public Friends, Public Methods


Awinc Constructor

Awinc Constructor
Awinc Class

Initializes an Awinc, with or without specifying the first year of data.

Collapse Expand Description

There are two versions of the Awinc constructor. Both specify the last year of projection. The first year of data can be specified; otherwise, it is set equal to 1937.

Collapse Expand Overload List
Name | Description
Awinc::Awinc (int) | Initializes the first year of data array to 1937.
Awinc::Awinc (int, int) | Initializes the first year of data array to the specified year.
Collapse Expand Class

Awinc Class

Collapse Expand Links
Awinc Class


Awinc::Awinc Constructor (int)

Awinc::Awinc Constructor (int)
Awinc Class Awinc Members Awinc Constructor

Initializes the first year of data array to 1937.

C++
Awinc(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Last year of array.
Collapse Expand Group

Awinc Constructor

Collapse Expand Links
Awinc Class, Awinc Members, Awinc Constructor


Awinc::Awinc Constructor (int, int)

Awinc::Awinc Constructor (int, int)
Awinc Class Awinc Members Awinc Constructor

Initializes the first year of data array to the specified year.

C++
Awinc(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | First year of array.
int newLastYear | Last year of array.
Collapse Expand Group

Awinc Constructor

Collapse Expand Links
Awinc Class, Awinc Members, Awinc Constructor


Awinc Methods

Awinc Methods
Awinc Class Legend Public Methods

The methods of the Awinc class are listed here.

Collapse Expand Class

Awinc Class

Collapse Expand Public Methods
Name | Description
fqincCheck | Checks an average wage increase.
project | Calculates average wage increases.
Collapse Expand Links
Awinc Class, Legend, Public Methods


Awinc::fqincCheck Method

Awinc::fqincCheck Method
Awinc Class Awinc Members Awinc Methods

Checks an average wage increase.

C++
static void fqincCheck(
    double fqinct
);
Collapse Expand Parameters
Parameters | Description
double fqinct | Value to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FQINC1 if average wage increase is out of range.
Collapse Expand Group

Awinc Methods

Collapse Expand Links
Awinc Class, Awinc Members, Awinc Methods


project Method

project Method
Awinc Methods

Calculates average wage increases.

Collapse Expand Description

There are two versions of the project function. If the last year is not specified, the projection goes to the last year of the stored data array. There can be an array of multipliers, or one constant that is used for all years.

Collapse Expand Overload List
Name | Description
Awinc::project (const AverageWage&, int, int) | Calculates average wage increases from the AverageWage argument and assigns each one to the corresponding slot in this array.
Awinc::project (double, int) | Calculates average wage increases by assigning all years the same percent increase.
Collapse Expand Group

Awinc Methods

Collapse Expand Links
Awinc Methods


Awinc::project Method (const AverageWage&, int, int)

Awinc::project Method (const AverageWage&, int, int)
Awinc Class Awinc Members project Method

Calculates average wage increases from the AverageWage argument and assigns each one to the corresponding slot in this array.

C++
void project(
    const AverageWage& averageWages,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const AverageWage& averageWages | Series of average wages from which to calculate increase percentages.
int firstYeart | First year of calculation.
int lastYeart | Last year of calculation.
Collapse Expand Group

project Method

Collapse Expand Links
Awinc Class, Awinc Members, project Method


Awinc::project Method (double, int)

Awinc::project Method (double, int)
Awinc Class Awinc Members project Method

Calculates average wage increases by assigning all years the same percent increase.

C++
void project(
    double factor,
    int firstYeart
);
Collapse Expand Parameters
Parameters | Description
double factor | Multiplicative increase factor.
int firstYeart | First year of calculation.
Collapse Expand Group

project Method

Collapse Expand Links
Awinc Class, Awinc Members, project Method


AwincDoc Class

AwincDoc Class
AwincDoc Data Members AwincDoc Methods AwincDoc Members AwincDoc.h Classes

Abstract parent of classes that manage the file of projected average wage increases.

Collapse Expand Class Hierarchy
  AwincDoc
C++
class AwincDoc;
Collapse Expand File

File: AwincDoc.h

Module: PiaData Library

Collapse Expand Remarks

One of its subclasses should be instantiated: AwincFile if it is to be retrieved from disk, AwincNonFile otherwise.

Collapse Expand See Also

AwincFile, AwincNonFile

Collapse Expand Group

Classes

Collapse Expand Links
AwincDoc Data Members, AwincDoc Methods, AwincDoc Members, AwincDoc.h, Classes


AwincDoc Members

AwincDoc Members
AwincDoc Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by AwincDoc.

Collapse Expand Class

AwincDoc Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
avgwage | Titles of projected average wage increase assumptions, other than the four TR assumptions.
awincTitle | Title of projected average wage increases.
Collapse Expand Public Data Members
Name | Description
awinc | Array of average wage increases.
Collapse Expand Public Methods
Name | Description
AwincDoc | Initializes projected average wage increase info.
getFirstYear | Returns first year of data.
getTitle | Returns title of assumptions.
read | Read data.
setData | Sets data for one alternative.
setFirstYear | Sets first year of data.
setFqinc | Sets average wage increase for specified year.
setTitle | Sets title for one alternative.
write | Write data.
~AwincDoc | Destructor.
Collapse Expand Links
AwincDoc Class, Legend, Protected Data Members, Public Data Members, Public Methods


AwincDoc::AwincDoc Constructor

AwincDoc::AwincDoc Constructor
AwincDoc Class AwincDoc Members AwincDoc Class

Initializes projected average wage increase info.

C++
AwincDoc(
    int newIstart,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
int newIstart | Starting year of average wage increases.
int newMaxyear | Maximum projected year.
Collapse Expand Class

AwincDoc Class

Collapse Expand Links
AwincDoc Class, AwincDoc Members, AwincDoc Class


AwincDoc::~AwincDoc Destructor

AwincDoc::~AwincDoc Destructor
AwincDoc Class AwincDoc Members AwincDoc Class

Destructor.

C++
virtual ~AwincDoc();
Collapse Expand Class

AwincDoc Class

Collapse Expand Links
AwincDoc Class, AwincDoc Members, AwincDoc Class


AwincDoc Data Members

AwincDoc Data Members
AwincDoc Class Legend Protected Data Members Public Data Members

The data members of the AwincDoc class are listed here.

Collapse Expand Class

AwincDoc Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
avgwage | Titles of projected average wage increase assumptions, other than the four TR assumptions.
awincTitle | Title of projected average wage increases.
Collapse Expand Public Data Members
Name | Description
awinc | Array of average wage increases.
Collapse Expand Links
AwincDoc Class, Legend, Protected Data Members, Public Data Members


AwincDoc::avgwage Data Member

AwincDoc::avgwage Data Member
AwincDoc Class AwincDoc Members AwincDoc Data Members

Titles of projected average wage increase assumptions, other than the four TR assumptions.

C++
std::string avgwage[3];
Collapse Expand Group

AwincDoc Data Members

Collapse Expand Links
AwincDoc Class, AwincDoc Members, AwincDoc Data Members


AwincDoc::awinc Data Member

AwincDoc::awinc Data Member
AwincDoc Class AwincDoc Members AwincDoc Data Members

Array of average wage increases.

C++
Awinc awinc;
Collapse Expand Group

AwincDoc Data Members

Collapse Expand Links
AwincDoc Class, AwincDoc Members, AwincDoc Data Members


AwincDoc::awincTitle Data Member

AwincDoc::awincTitle Data Member
AwincDoc Class AwincDoc Members AwincDoc Data Members

Title of projected average wage increases.

C++
std::string awincTitle;
Collapse Expand Group

AwincDoc Data Members

Collapse Expand Links
AwincDoc Class, AwincDoc Members, AwincDoc Data Members


AwincDoc Methods

AwincDoc Methods
AwincDoc Class Legend Public Methods

The methods of the AwincDoc class are listed here.

Collapse Expand Class

AwincDoc Class

Collapse Expand Public Methods
Name | Description
getFirstYear | Returns first year of data.
getTitle | Returns title of assumptions.
read | Read data.
setData | Sets data for one alternative.
setFirstYear | Sets first year of data.
setFqinc | Sets average wage increase for specified year.
setTitle | Sets title for one alternative.
write | Write data.
Collapse Expand Links
AwincDoc Class, Legend, Public Methods


AwincDoc::getFirstYear Method

AwincDoc::getFirstYear Method
AwincDoc Class AwincDoc Members AwincDoc Methods

Returns first year of data.

C++
int getFirstYear() const;
Collapse Expand Returns

First year of data.

Collapse Expand Group

AwincDoc Methods

Collapse Expand Links
AwincDoc Class, AwincDoc Members, AwincDoc Methods


AwincDoc::getTitle Method

AwincDoc::getTitle Method
AwincDoc Class AwincDoc Members AwincDoc Methods

Returns title of assumptions.

C++
const std::string& getTitle() const;
Collapse Expand Returns

Title of assumptions.

Collapse Expand Group

AwincDoc Methods

Collapse Expand Links
AwincDoc Class, AwincDoc Members, AwincDoc Methods


AwincDoc::read Method

AwincDoc::read Method
AwincDoc Class AwincDoc Members AwincDoc Methods

Read data.

C++
virtual void read(
    int
) = 0;
Collapse Expand Group

AwincDoc Methods

Collapse Expand Links
AwincDoc Class, AwincDoc Members, AwincDoc Methods


setData Method

setData Method
AwincDoc Methods

Sets data for one alternative.

Collapse Expand Description

There are two versions of the setData method; however, both are placeholder functions for child classes.

Collapse Expand Overload List
Name | Description
AwincDoc::setData (int) | Set data for one alternative.
AwincDoc::setData (int, const DoubleAnnual&) | Set data for one alternative.
Collapse Expand Group

AwincDoc Methods

Collapse Expand Links
AwincDoc Methods


AwincDoc::setData Method (int)

AwincDoc::setData Method (int)
AwincDoc Class AwincDoc Members setData Method

Set data for one alternative.

C++
virtual void setData(
    int
) = 0;
Collapse Expand Group

setData Method

Collapse Expand Links
AwincDoc Class, AwincDoc Members, setData Method


AwincDoc::setData Method (int, const DoubleAnnual&)

AwincDoc::setData Method (int, const DoubleAnnual&)
AwincDoc Class AwincDoc Members setData Method

Set data for one alternative.

C++
virtual void setData(
    int,
    const DoubleAnnual&
) = 0;
Collapse Expand Group

setData Method

Collapse Expand Links
AwincDoc Class, AwincDoc Members, setData Method


AwincDoc::setFirstYear Method

AwincDoc::setFirstYear Method
AwincDoc Class AwincDoc Members AwincDoc Methods

Sets first year of data.

C++
void setFirstYear(
    int newFirstYear
);
Collapse Expand Parameters
Parameters | Description
int newFirstYear | New first year of data.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if year is out of range (only in debug mode).
Collapse Expand Group

AwincDoc Methods

Collapse Expand Links
AwincDoc Class, AwincDoc Members, AwincDoc Methods


AwincDoc::setFqinc Method

AwincDoc::setFqinc Method
AwincDoc Class AwincDoc Members AwincDoc Methods

Sets average wage increase for specified year.

C++
void setFqinc(
    int year,
    double newFqinc
);
Collapse Expand Parameters
Parameters | Description
int year | Year of average wage increase to set.
double newFqinc | New average wage increase.
Collapse Expand Group

AwincDoc Methods

Collapse Expand Links
AwincDoc Class, AwincDoc Members, AwincDoc Methods


setTitle Method

setTitle Method
AwincDoc Methods

Sets title for one alternative.

Collapse Expand Description

There are two versions of the setTitle method; however, both are placeholder functions for child classes.

Collapse Expand Overload List
Name | Description
AwincDoc::setTitle (int) | Sets title for one alternative.
AwincDoc::setTitle (int, const std::string&) | Sets title for one alternative.
Collapse Expand Group

AwincDoc Methods

Collapse Expand Links
AwincDoc Methods


AwincDoc::setTitle Method (int)

AwincDoc::setTitle Method (int)
AwincDoc Class AwincDoc Members setTitle Method

Sets title for one alternative.

C++
virtual void setTitle(
    int
) = 0;
Collapse Expand Group

setTitle Method

Collapse Expand Links
AwincDoc Class, AwincDoc Members, setTitle Method


AwincDoc::setTitle Method (int, const std::string&)

AwincDoc::setTitle Method (int, const std::string&)
AwincDoc Class AwincDoc Members setTitle Method

Sets title for one alternative.

C++
virtual void setTitle(
    int,
    const std::string&
) = 0;
Collapse Expand Group

setTitle Method

Collapse Expand Links
AwincDoc Class, AwincDoc Members, setTitle Method


AwincDoc::write Method

AwincDoc::write Method
AwincDoc Class AwincDoc Members AwincDoc Methods

Write data.

C++
virtual void write(
    int
) = 0;
Collapse Expand Group

AwincDoc Methods

Collapse Expand Links
AwincDoc Class, AwincDoc Members, AwincDoc Methods


AwincFile Class

AwincFile Class
AwincFile Methods AwincFile Members AwincFile.h Classes

Manages the file of projected average wage increases stored on disk.

Collapse Expand Class Hierarchy
  AwincFileAwincFile
C++
class AwincFile : public AwincDoc;
Collapse Expand File

File: AwincFile.h

Module: PiaData Library

Collapse Expand Remarks

Manages the file of projected average wage increases stored on disk.

Collapse Expand Group

Classes

Collapse Expand Links
AwincFile Methods, AwincFile Members, AwincFile.h, Classes


AwincFile Members

AwincFile Members
AwincFile Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by AwincFile.

Collapse Expand Class

AwincFile Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
avgwage | Titles of projected average wage increase assumptions, other than the four TR assumptions.
awincTitle | Title of projected average wage increases.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
setAwFile | Forms a file name for projected average wage increase file.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
awinc | Array of average wage increases.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
AwincFile | Initializes projected average wage increase info.
getFirstYear | Returns first year of data.
getTitle | Returns title of assumptions.
read | Reads projected average wage increases.
setData | Sets data for one alternative.
setData | Sets data for one alternative.
setFirstYear | Sets first year of data.
setFqinc | Sets average wage increase for specified year.
setTitle | Sets title for one alternative.
setTitle | Sets title for one alternative.
write | Saves projected average wage increases.
Collapse Expand Links
AwincFile Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


AwincFile::AwincFile Constructor

AwincFile::AwincFile Constructor
AwincFile Class AwincFile Members AwincFile Class

Initializes projected average wage increase info.

C++
AwincFile(
    int newIstart,
    int newMaxyear,
    const std::string& newDirectory
);
Collapse Expand Parameters
Parameters | Description
int newIstart | Starting year of average wage increases.
int newMaxyear | Maximum projected year.
const std::string& newDirectory | Directory with average wage increase file.
Collapse Expand Class

AwincFile Class

Collapse Expand Links
AwincFile Class, AwincFile Members, AwincFile Class


AwincFile Methods

AwincFile Methods
AwincFile Class Legend Protected Methods Public Methods

The methods of the AwincFile class are listed here.

Collapse Expand Class

AwincFile Class

Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
setAwFile | Forms a file name for projected average wage increase file.
Collapse Expand Public Methods
Name | Description
read | Reads projected average wage increases.
setData | Sets data for one alternative.
setTitle | Sets title for one alternative.
write | Saves projected average wage increases.
Collapse Expand Links
AwincFile Class, Legend, Protected Methods, Public Methods


AwincFile::read Method

AwincFile::read Method
AwincFile Class AwincFile Members AwincFile Methods

Reads projected average wage increases.

C++
void read(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-4).
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FQINC4 if unable to open input file. PiaException of type PIA_IDS_FQINC3 if unable to read all required data.
Collapse Expand Group

AwincFile Methods

Collapse Expand Links
AwincFile Class, AwincFile Members, AwincFile Methods


AwincFile::setAwFile Method

AwincFile::setAwFile Method
AwincFile Class AwincFile Members AwincFile Methods

Forms a file name for projected average wage increase file.

C++
void setAwFile(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-4).
Collapse Expand Group

AwincFile Methods

Collapse Expand Links
AwincFile Class, AwincFile Members, AwincFile Methods


setData Method

setData Method
AwincFile Methods

Sets data for one alternative.

Collapse Expand Description

There are two versions of the setData method; however, both are dummy (unused) functions.

Collapse Expand Overload List
Name | Description
AwincFile::setData (int) | Dummy function.
AwincFile::setData (int, const DoubleAnnual&) | Dummy function.
Collapse Expand Group

AwincFile Methods

Collapse Expand Links
AwincFile Methods


AwincFile::setData Method (int)

AwincFile::setData Method (int)
AwincFile Class AwincFile Members setData Method

Dummy function.

C++
void setData(
    int
);
Collapse Expand Group

setData Method

Collapse Expand Links
AwincFile Class, AwincFile Members, setData Method


AwincFile::setData Method (int, const DoubleAnnual&)

AwincFile::setData Method (int, const DoubleAnnual&)
AwincFile Class AwincFile Members setData Method

Dummy function.

C++
virtual void setData(
    int,
    const DoubleAnnual&
);
Collapse Expand Group

setData Method

Collapse Expand Links
AwincFile Class, AwincFile Members, setData Method


setTitle Method

setTitle Method
AwincFile Methods

Sets title for one alternative.

Collapse Expand Description

There are two versions of the setTitle method. However, the second argument in one version (providing a new title) is ignored, so that both functions do the same thing.

Collapse Expand Overload List
Name | Description
AwincFile::setTitle (int) | Sets title of assumptions.
AwincFile::setTitle (int, const std::string&) | Sets title of assumptions.
Collapse Expand Group

AwincFile Methods

Collapse Expand Links
AwincFile Methods


AwincFile::setTitle Method (int)

AwincFile::setTitle Method (int)
AwincFile Class AwincFile Members setTitle Method

Sets title of assumptions.

C++
void setTitle(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Which set of assumptions.
Collapse Expand Group

setTitle Method

Collapse Expand Links
AwincFile Class, AwincFile Members, setTitle Method


AwincFile::setTitle Method (int, const std::string&)

AwincFile::setTitle Method (int, const std::string&)
AwincFile Class AwincFile Members setTitle Method

Sets title of assumptions.

C++
void setTitle(
    int altNum,
    const std::string&
);
Collapse Expand Parameters
Parameters | Description
int altNum | Which set of assumptions.
Collapse Expand Group

setTitle Method

Collapse Expand Links
AwincFile Class, AwincFile Members, setTitle Method


AwincFile::write Method

AwincFile::write Method
AwincFile Class AwincFile Members AwincFile Methods

Saves projected average wage increases.

C++
void write(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-4).
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FQINC2 if unable to open output file.
Collapse Expand Group

AwincFile Methods

Collapse Expand Links
AwincFile Class, AwincFile Members, AwincFile Methods


AwincNonFile Class

AwincNonFile Class
AwincNonFile Enumerations AwincNonFile Methods AwincNonFile Members AwincNonFile.h Classes

Manages the file of projected average wage increases stored in static arrays.

Collapse Expand Class Hierarchy
  AwincNonFileAwincNonFile
C++
class AwincNonFile : public AwincDoc;
Collapse Expand File

File: AwincNonFile.h

Module: PiaData Library

Collapse Expand Remarks

See AwincFile for a version of this class that stores the average wage increases on disk.

Collapse Expand See Also

AwincFile

Collapse Expand Group

Classes

Collapse Expand Links
AwincNonFile Enumerations, AwincNonFile Methods, AwincNonFile Members, AwincNonFile.h, Classes


AwincNonFile Members

AwincNonFile Members
Enumerations AwincNonFile Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by AwincNonFile.

Collapse Expand Enumerations
Name | Description
DimLimits | Dimension limits.
Collapse Expand Class

AwincNonFile Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
avgwage | Titles of projected average wage increase assumptions, other than the four TR assumptions.
awincTitle | Title of projected average wage increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
awinc | Array of average wage increases.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
AwincNonFile | Initializes projected average wage increase info with latest Trustees Report assumptions.
getFirstYear | Returns first year of data.
getTitle | Returns title of assumptions.
read | Restore values to original values.
setData | Sets data for one alternative.
setData | Sets data for one alternative.
setFirstYear | Sets first year of data.
setFqinc | Sets average wage increase for specified year.
setTitle | Sets title for one alternative.
setTitle | Sets title for one alternative.
write | Dummy function.
~AwincNonFile | Destructor.
Collapse Expand Links
Enumerations, AwincNonFile Class, Legend, Protected Data Members, Public Data Members, Public Methods


AwincNonFile::AwincNonFile Constructor

AwincNonFile::AwincNonFile Constructor
AwincNonFile Class AwincNonFile Members AwincNonFile Class

Initializes projected average wage increase info with latest Trustees Report assumptions.

C++
AwincNonFile(
    int newIstart,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
int newIstart | Starting year of average wage increases.
int newMaxyear | Maximum projected year.
Collapse Expand Class

AwincNonFile Class

Collapse Expand Links
AwincNonFile Class, AwincNonFile Members, AwincNonFile Class


AwincNonFile::~AwincNonFile Destructor

AwincNonFile::~AwincNonFile Destructor
AwincNonFile Class AwincNonFile Members AwincNonFile Class

Destructor.

C++
~AwincNonFile();
Collapse Expand Remarks

Deletes the vectors of stored Trustees Report assumptions.

Collapse Expand Class

AwincNonFile Class

Collapse Expand Links
AwincNonFile Class, AwincNonFile Members, AwincNonFile Class


AwincNonFile Enumerations

AwincNonFile Enumerations
Enumerations AwincNonFile Class Legend

The enumerations of the AwincNonFile class are listed here.

Collapse Expand Enumerations
Name | Description
DimLimits | Dimension limits.
Collapse Expand Class

AwincNonFile Class

Collapse Expand Links
Enumerations, AwincNonFile Class, Legend


AwincNonFile::DimLimits Enumeration

AwincNonFile::DimLimits Enumeration
AwincNonFile.h AwincNonFile Enumerations

Dimension limits.

C++
enum DimLimits {
  NUMASSUMSETS = 4,
  NUMPROJYEARS = 16
};
Collapse Expand File

File: AwincNonFile.h

Module: PiaData Library

Collapse Expand Members
Members | Description
NUMASSUMSETS = 4 | Number of sets of assumptions (4 for 1, 2, 3, and 2b).
NUMPROJYEARS = 16 | Number of annual average wage increases. This should not normally be changed because it is the number of blanks on a form in the detailed calculator.
Collapse Expand Group

AwincNonFile Enumerations

Collapse Expand Links
AwincNonFile.h, AwincNonFile Enumerations


AwincNonFile Methods

AwincNonFile Methods
AwincNonFile Class Legend Public Methods

The methods of the AwincNonFile class are listed here.

Collapse Expand Class

AwincNonFile Class

Collapse Expand Public Methods
Name | Description
read | Restore values to original values.
setData | Sets data for one alternative.
setTitle | Sets title for one alternative.
write | Dummy function.
Collapse Expand Links
AwincNonFile Class, Legend, Public Methods


AwincNonFile::read Method

AwincNonFile::read Method
AwincNonFile Class AwincNonFile Members AwincNonFile Methods

Restore values to original values.

C++
void read(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-4).
Collapse Expand Exceptions
Exceptions | Description
PiaException | Thrown if there is any error restoring values to original values.
Collapse Expand Group

AwincNonFile Methods

Collapse Expand Links
AwincNonFile Class, AwincNonFile Members, AwincNonFile Methods


setData Method

setData Method
AwincNonFile Methods

Sets data for one alternative.

Collapse Expand Description

There are two versions of the setData method. The data to be used can be passed as an argument; if it is not, the stored data is used.

Collapse Expand Overload List
Name | Description
AwincNonFile::setData (int) | Sets data for one alternative, using the stored data for the specified alternative.
AwincNonFile::setData (int, const DoubleAnnual&) | Sets data for one alternative, storing the data for the specified alternative, then setting the current data to that data.
Collapse Expand Group

AwincNonFile Methods

Collapse Expand Links
AwincNonFile Methods


AwincNonFile::setData Method (int)

AwincNonFile::setData Method (int)
AwincNonFile Class AwincNonFile Members setData Method

Sets data for one alternative, using the stored data for the specified alternative.

C++
void setData(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-7).
Collapse Expand Group

setData Method

Collapse Expand Links
AwincNonFile Class, AwincNonFile Members, setData Method


AwincNonFile::setData Method (int, const DoubleAnnual&)

AwincNonFile::setData Method (int, const DoubleAnnual&)
AwincNonFile Class AwincNonFile Members setData Method

Sets data for one alternative, storing the data for the specified alternative, then setting the current data to that data.

C++
virtual void setData(
    int altNum,
    const DoubleAnnual& newData
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-7).
const DoubleAnnual& newData | Data to use.
Collapse Expand Group

setData Method

Collapse Expand Links
AwincNonFile Class, AwincNonFile Members, setData Method


setTitle Method

setTitle Method
AwincNonFile Methods

Sets title for one alternative.

Collapse Expand Description

There are two versions of the setTitle method. The title to be used can be passed as an argument; if it is not, the stored title is used.

Collapse Expand Overload List
Name | Description
AwincNonFile::setTitle (int) | Sets the current title, using the title stored for the specified alternative.
AwincNonFile::setTitle (int, const std::string&) | Sets the current title, storing the title for the specified alternative, then setting the current title to that title.
Collapse Expand Group

AwincNonFile Methods

Collapse Expand Links
AwincNonFile Methods


AwincNonFile::setTitle Method (int)

AwincNonFile::setTitle Method (int)
AwincNonFile Class AwincNonFile Members setTitle Method

Sets the current title, using the title stored for the specified alternative.

C++
void setTitle(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-7).
Collapse Expand Group

setTitle Method

Collapse Expand Links
AwincNonFile Class, AwincNonFile Members, setTitle Method


AwincNonFile::setTitle Method (int, const std::string&)

AwincNonFile::setTitle Method (int, const std::string&)
AwincNonFile Class AwincNonFile Members setTitle Method

Sets the current title, storing the title for the specified alternative, then setting the current title to that title.

C++
void setTitle(
    int altNum,
    const std::string& newTitle
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-7).
const std::string& newTitle | Title to use.
Collapse Expand Group

setTitle Method

Collapse Expand Links
AwincNonFile Class, AwincNonFile Members, setTitle Method


AwincNonFile::write Method

AwincNonFile::write Method
AwincNonFile Class AwincNonFile Members AwincNonFile Methods

Dummy function.

C++
void write(
    int
);
Collapse Expand Group

AwincNonFile Methods

Collapse Expand Links
AwincNonFile Class, AwincNonFile Members, AwincNonFile Methods


BaseChangeType Class

BaseChangeType Class
BaseChangeType Enumerations BaseChangeType Methods BaseChangeType Members BaseChangeType.h Classes

The wage base change types allowed in the piadata library.

Collapse Expand Class Hierarchy
  BaseChangeType
C++
class BaseChangeType;
Collapse Expand File

File: BaseChangeType.h

Module: PiaData Library

Collapse Expand Remarks

There is an enum and some static functions, but no member variables, so there are no instances of this class.

Collapse Expand Group

Classes

Collapse Expand Links
BaseChangeType Enumerations, BaseChangeType Methods, BaseChangeType Members, BaseChangeType.h, Classes


BaseChangeType Members

BaseChangeType Members
Enumerations BaseChangeType Class Legend Public Methods

The following tables list the members exposed by BaseChangeType.

Collapse Expand Enumerations
Name | Description
change_type | Type of wage base changes.
Collapse Expand Class

BaseChangeType Class

Collapse Expand Public Methods
Name | Description
check | Checks wage base indicator.
toString | Returns description of wage base projection method.
Collapse Expand Links
Enumerations, BaseChangeType Class, Legend, Public Methods


BaseChangeType Enumerations

BaseChangeType Enumerations
Enumerations BaseChangeType Class Legend

The enumerations of the BaseChangeType class are listed here.

Collapse Expand Enumerations
Name | Description
change_type | Type of wage base changes.
Collapse Expand Class

BaseChangeType Class

Collapse Expand Links
Enumerations, BaseChangeType Class, Legend


BaseChangeType::change_type Enumeration

BaseChangeType::change_type Enumeration
BaseChangeType.h BaseChangeType Enumerations

Type of wage base changes.

C++
enum change_type {
  NONE = 0,
  AUTOMATIC,
  ADHOC,
  NUM_CHANGE_TYPES
};
Collapse Expand File

File: BaseChangeType.h

Module: PiaData Library

Collapse Expand Members
Members | Description
NONE = 0 | No type of change chosen.
AUTOMATIC | Automatic provisions apply.
ADHOC | Ad hoc wage bases.
NUM_CHANGE_TYPES | Number of wage base change types.
Collapse Expand Group

BaseChangeType Enumerations

Collapse Expand Links
BaseChangeType.h, BaseChangeType Enumerations


BaseChangeType Methods

BaseChangeType Methods
BaseChangeType Class Legend Public Methods

The methods of the BaseChangeType class are listed here.

Collapse Expand Class

BaseChangeType Class

Collapse Expand Public Methods
Name | Description
check | Checks wage base indicator.
toString | Returns description of wage base projection method.
Collapse Expand Links
BaseChangeType Class, Legend, Public Methods


BaseChangeType::check Method

BaseChangeType::check Method
BaseChangeType Class BaseChangeType Members BaseChangeType Methods

Checks wage base indicator.

C++
static void check(
    int ibascht
);
Collapse Expand Parameters
Parameters | Description
int ibascht | Value to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BASECH if wage base indicator is not change_type::AUTOMATIC or change_type::ADHOC.
Collapse Expand Group

BaseChangeType Methods

Collapse Expand Links
BaseChangeType Class, BaseChangeType Members, BaseChangeType Methods


BaseChangeType::toString Method

BaseChangeType::toString Method
BaseChangeType Class BaseChangeType Members BaseChangeType Methods

Returns description of wage base projection method.

C++
static std::string toString(
    change_type ibascht
);
Collapse Expand Parameters
Parameters | Description
change_type ibascht | The type of wage base change.
Collapse Expand Returns

Description of wage base projection method.

Collapse Expand Group

BaseChangeType Methods

Collapse Expand Links
BaseChangeType Class, BaseChangeType Members, BaseChangeType Methods


BaseYear Class

BaseYear Class
BaseYear Data Members BaseYear Methods BaseYear Members baseyear.h Classes

Parent of classes that manage the computation year for a pia program.

Collapse Expand Class Hierarchy
  BaseYear
C++
class BaseYear;
Collapse Expand File

File: baseyear.h

Module: PiaData Library

Collapse Expand Remarks

One of its subclasses should be instantiated: BaseYearFile if it is to be gotten from disk, BaseYearNonFile otherwise.

Collapse Expand See Also

BaseYearFile, BaseYearNonFile

Collapse Expand Group

Classes

Collapse Expand Links
BaseYear Data Members, BaseYear Methods, BaseYear Members, baseyear.h, Classes


BaseYear Members

BaseYear Members
BaseYear Class Legend Protected Data Members Public Methods

The following tables list the members exposed by BaseYear.

Collapse Expand Class

BaseYear Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
theYear | Computation year.
Collapse Expand Public Methods
Name | Description
BaseYear | Initializes base year to zero.
getYear | Returns computation year.
read | Read base year.
setYear | Sets computation year.
write | Save base year.
yearCheck | Checks base year.
~BaseYear | Destroys base year info.
Collapse Expand Links
BaseYear Class, Legend, Protected Data Members, Public Methods


BaseYear::BaseYear Constructor

BaseYear::BaseYear Constructor
BaseYear Class BaseYear Members BaseYear Class

Initializes base year to zero.

C++
BaseYear();
Collapse Expand Class

BaseYear Class

Collapse Expand Links
BaseYear Class, BaseYear Members, BaseYear Class


BaseYear::~BaseYear Destructor

BaseYear::~BaseYear Destructor
BaseYear Class BaseYear Members BaseYear Class

Destroys base year info.

C++
virtual ~BaseYear();
Collapse Expand Class

BaseYear Class

Collapse Expand Links
BaseYear Class, BaseYear Members, BaseYear Class


BaseYear Data Members

BaseYear Data Members
BaseYear Class Legend Protected Data Members

The data members of the BaseYear class are listed here.

Collapse Expand Class

BaseYear Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
theYear | Computation year.
Collapse Expand Links
BaseYear Class, Legend, Protected Data Members


BaseYear::theYear Data Member

BaseYear::theYear Data Member
BaseYear Class BaseYear Members BaseYear Data Members

Computation year.

C++
int theYear;
Collapse Expand Group

BaseYear Data Members

Collapse Expand Links
BaseYear Class, BaseYear Members, BaseYear Data Members


BaseYear Methods

BaseYear Methods
BaseYear Class Legend Public Methods

The methods of the BaseYear class are listed here.

Collapse Expand Class

BaseYear Class

Collapse Expand Public Methods
Name | Description
getYear | Returns computation year.
read | Read base year.
setYear | Sets computation year.
write | Save base year.
yearCheck | Checks base year.
Collapse Expand Links
BaseYear Class, Legend, Public Methods


BaseYear::getYear Method

BaseYear::getYear Method
BaseYear Class BaseYear Members BaseYear Methods

Returns computation year.

C++
int getYear() const;
Collapse Expand Returns

Computation year.

Collapse Expand Group

BaseYear Methods

Collapse Expand Links
BaseYear Class, BaseYear Members, BaseYear Methods


BaseYear::read Method

BaseYear::read Method
BaseYear Class BaseYear Members BaseYear Methods

Read base year.

C++
virtual void read() = 0;
Collapse Expand Group

BaseYear Methods

Collapse Expand Links
BaseYear Class, BaseYear Members, BaseYear Methods


BaseYear::setYear Method

BaseYear::setYear Method
BaseYear Class BaseYear Members BaseYear Methods

Sets computation year.

C++
void setYear(
    int newYear
);
Collapse Expand Parameters
Parameters | Description
int newYear | New computation year to use.
Collapse Expand Group

BaseYear Methods

Collapse Expand Links
BaseYear Class, BaseYear Members, BaseYear Methods


BaseYear::write Method

BaseYear::write Method
BaseYear Class BaseYear Members BaseYear Methods

Save base year.

C++
virtual void write() = 0;
Collapse Expand Group

BaseYear Methods

Collapse Expand Links
BaseYear Class, BaseYear Members, BaseYear Methods


BaseYear::yearCheck Method

BaseYear::yearCheck Method
BaseYear Class BaseYear Members BaseYear Methods

Checks base year.

C++
static void yearCheck(
    int newYear
);
Collapse Expand Parameters
Parameters | Description
int newYear | New value of base year.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BASEYR1 if base year is out of range (1979-2025). When the last short-range year is updated, the string tables for anypia need to be changed to reflect the new maximum year.
Collapse Expand Group

BaseYear Methods

Collapse Expand Links
BaseYear Class, BaseYear Members, BaseYear Methods


BaseYearFile Class

BaseYearFile Class
BaseYearFile Methods BaseYearFile Members BaseYearFile.h Classes

Manages the computation year for a pia program where it is gotten from disk.

Collapse Expand Class Hierarchy
  BaseYearFileBaseYearFile
C++
class BaseYearFile : public BaseYear;
Collapse Expand File

File: BaseYearFile.h

Module: PiaData Library

Collapse Expand Remarks

See BaseYearNonFile for a class where the computation year is stored internally.

Collapse Expand See Also

BaseYearNonFile

Collapse Expand Group

Classes

Collapse Expand Links
BaseYearFile Methods, BaseYearFile Members, BaseYearFile.h, Classes


BaseYearFile Members

BaseYearFile Members
BaseYearFile Class Legend Protected Data Members Public Methods

The following tables list the members exposed by BaseYearFile.

Collapse Expand Class

BaseYearFile Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
theYear | Computation year.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
BaseYearFile | Initializes base year info.
getYear | Returns computation year.
read | Reads base year from disk.
setYear | Sets computation year.
write | Saves base year to disk.
yearCheck | Checks base year.
Collapse Expand Links
BaseYearFile Class, Legend, Protected Data Members, Public Methods


BaseYearFile::BaseYearFile Constructor

BaseYearFile::BaseYearFile Constructor
BaseYearFile Class BaseYearFile Members BaseYearFile Class

Initializes base year info.

C++
BaseYearFile(
    const std::string& newDirectory
);
Collapse Expand Parameters
Parameters | Description
const std::string& newDirectory | Directory with base year file.
Collapse Expand Class

BaseYearFile Class

Collapse Expand Links
BaseYearFile Class, BaseYearFile Members, BaseYearFile Class


BaseYearFile Methods

BaseYearFile Methods
BaseYearFile Class Legend Public Methods

The methods of the BaseYearFile class are listed here.

Collapse Expand Class

BaseYearFile Class

Collapse Expand Public Methods
Name | Description
read | Reads base year from disk.
write | Saves base year to disk.
Collapse Expand Links
BaseYearFile Class, Legend, Public Methods


BaseYearFile::read Method

BaseYearFile::read Method
BaseYearFile Class BaseYearFile Members BaseYearFile Methods

Reads base year from disk.

C++
void read();
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BASEYR4 if unable to open input file. PiaException of type PIA_IDS_BASEYR3 if unable to read base year.
Collapse Expand Group

BaseYearFile Methods

Collapse Expand Links
BaseYearFile Class, BaseYearFile Members, BaseYearFile Methods


BaseYearFile::write Method

BaseYearFile::write Method
BaseYearFile Class BaseYearFile Members BaseYearFile Methods

Saves base year to disk.

C++
void write();
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BASEYR2 if unable to open output file.
Collapse Expand Group

BaseYearFile Methods

Collapse Expand Links
BaseYearFile Class, BaseYearFile Members, BaseYearFile Methods


BaseYearNonFile Class

BaseYearNonFile Class
BaseYearNonFile Data Members BaseYearNonFile Methods BaseYearNonFile Members BaseYearNonFile.h Classes

Manages the computation year for a pia program where it is stored with the code.

Collapse Expand Class Hierarchy
  BaseYearNonFileBaseYearNonFile
C++
class BaseYearNonFile : public BaseYear;
Collapse Expand File

File: BaseYearNonFile.h

Module: PiaData Library

Collapse Expand Remarks

Currently YEAR is 2026 and TR_YEAR is 2025. See BaseYearFile for a class where the computation year is stored on disk.

Collapse Expand See Also

BaseYearFile

Collapse Expand Group

Classes

Collapse Expand Links
BaseYearNonFile Data Members, BaseYearNonFile Methods, BaseYearNonFile Members, BaseYearNonFile.h, Classes


BaseYearNonFile Members

BaseYearNonFile Members
BaseYearNonFile Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by BaseYearNonFile.

Collapse Expand Class

BaseYearNonFile Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
theYear | Computation year.
Collapse Expand Public Data Members
Name | Description
TR_YEAR | Year of Trustees Report assumptions.
YEAR | Year for which data has been stored.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
BaseYearNonFile | Initializes base year.
getYear | Returns computation year.
read | Reads stored base year.
setYear | Sets computation year.
write | Saves base year (dummy function).
yearCheck | Checks base year.
Collapse Expand Links
BaseYearNonFile Class, Legend, Protected Data Members, Public Data Members, Public Methods


BaseYearNonFile::BaseYearNonFile Constructor

BaseYearNonFile::BaseYearNonFile Constructor
BaseYearNonFile Class BaseYearNonFile Members BaseYearNonFile Class

Initializes base year.

C++
BaseYearNonFile();
Collapse Expand Class

BaseYearNonFile Class

Collapse Expand Links
BaseYearNonFile Class, BaseYearNonFile Members, BaseYearNonFile Class


BaseYearNonFile Data Members

BaseYearNonFile Data Members
BaseYearNonFile Class Legend Public Data Members

The data members of the BaseYearNonFile class are listed here.

Collapse Expand Class

BaseYearNonFile Class

Collapse Expand Public Data Members
Name | Description
TR_YEAR | Year of Trustees Report assumptions.
YEAR | Year for which data has been stored.
Collapse Expand Links
BaseYearNonFile Class, Legend, Public Data Members


BaseYearNonFile::TR_YEAR Data Member

BaseYearNonFile::TR_YEAR Data Member
BaseYearNonFile Class BaseYearNonFile Members BaseYearNonFile Data Members

Year of Trustees Report assumptions.

C++
const int TR_YEAR = 2025;
Collapse Expand Remarks

This is updated when the TR is released, so it is equal to YEAR from the TR date to the COLA update, and 1 less than YEAR from the COLA update to the TR date.

Collapse Expand Group

BaseYearNonFile Data Members

Collapse Expand Links
BaseYearNonFile Class, BaseYearNonFile Members, BaseYearNonFile Data Members


BaseYearNonFile::YEAR Data Member

BaseYearNonFile::YEAR Data Member
BaseYearNonFile Class BaseYearNonFile Members BaseYearNonFile Data Members

Year for which data has been stored.

C++
const int YEAR = 2026;
Collapse Expand Remarks

The value of 2026 means that the December 2025 benefit increase, 2024 average wage, and 2026 wage base are available. This is updated in October after the annual automatic adjustment announcement.

Collapse Expand Group

BaseYearNonFile Data Members

Collapse Expand Links
BaseYearNonFile Class, BaseYearNonFile Members, BaseYearNonFile Data Members


BaseYearNonFile Methods

BaseYearNonFile Methods
BaseYearNonFile Class Legend Public Methods

The methods of the BaseYearNonFile class are listed here.

Collapse Expand Class

BaseYearNonFile Class

Collapse Expand Public Methods
Name | Description
read | Reads stored base year.
write | Saves base year (dummy function).
Collapse Expand Links
BaseYearNonFile Class, Legend, Public Methods


BaseYearNonFile::read Method

BaseYearNonFile::read Method
BaseYearNonFile Class BaseYearNonFile Members BaseYearNonFile Methods

Reads stored base year.

C++
void read();
Collapse Expand Group

BaseYearNonFile Methods

Collapse Expand Links
BaseYearNonFile Class, BaseYearNonFile Members, BaseYearNonFile Methods


BaseYearNonFile::write Method

BaseYearNonFile::write Method
BaseYearNonFile Class BaseYearNonFile Members BaseYearNonFile Methods

Saves base year (dummy function).

C++
void write();
Collapse Expand Group

BaseYearNonFile Methods

Collapse Expand Links
BaseYearNonFile Class, BaseYearNonFile Members, BaseYearNonFile Methods


BendPia Class

BendPia Class
BendPia Data Members BendPia Methods BendPia Operators BendPia Nested Types BendPia Members bendpia.h Classes

Manages the array of bend points used in the PIA formula.

Collapse Expand Class Hierarchy
  BendPia
C++
class BendPia;
Collapse Expand File

File: bendpia.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is used in WageIndGeneral. There is an array with 5 slots for bend points.

Collapse Expand Group

Classes

Collapse Expand Links
BendPia Data Members, BendPia Methods, BendPia Operators, BendPia Nested Types, BendPia Members, bendpia.h, Classes


BendPia Members

BendPia Members
BendPia Class Legend Public Data Members Public Methods Public Nested Types

The following tables list the members exposed by BendPia.

Collapse Expand Class

BendPia Class

Collapse Expand Public Data Members
Name | Description
BP1979 | Three bend points from 1979.
Collapse Expand Public Methods
Name | Description
BendPia | Constructor.
as_array | Returns bend points as a simple array.
begin | This is the overview for the begin method overload.
deleteContents | Zeroes out all values.
end | This is the overview for the end method overload.
getNumBend | Returns the number of bendpoints.
max_size | Returns maximum number of bend points.
project | Projects bend points, using 1979 bend points as a base.
setNumBend | Sets the number of bendpoints. Sets number of bend points.
size | Returns number of bend points.
~BendPia | Destroys bend point array.
Collapse Expand Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of size in this array.
value_type | The type of data in this array.
Collapse Expand Public Operators
Name | Description
[] | This is the overview for the [] operator overload.
Collapse Expand Links
BendPia Class, Legend, Public Data Members, Public Methods, Public Nested Types


BendPia::BendPia Constructor

BendPia::BendPia Constructor
BendPia Class BendPia Members BendPia Class

Constructor.

C++
BendPia(
    int newNumBend
);
Collapse Expand Parameters
Parameters | Description
int newNumBend | Number of bend points in formula.
Collapse Expand Remarks

Sets first bend point to 0.0.

Collapse Expand Class

BendPia Class

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Class


BendPia::~BendPia Destructor

BendPia::~BendPia Destructor
BendPia Class BendPia Members BendPia Class

Destroys bend point array.

C++
~BendPia();
Collapse Expand Class

BendPia Class

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Class


BendPia Data Members

BendPia Data Members
BendPia Class Legend Public Data Members

The data members of the BendPia class are listed here.

Collapse Expand Class

BendPia Class

Collapse Expand Public Data Members
Name | Description
BP1979 | Three bend points from 1979.
Collapse Expand Links
BendPia Class, Legend, Public Data Members


BendPia::BP1979 Data Member

BendPia::BP1979 Data Member
BendPia Class BendPia Members BendPia Data Members

Three bend points from 1979.

C++
const double BP1979[3];
Collapse Expand Group

BendPia Data Members

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Data Members


BendPia Methods

BendPia Methods
BendPia Class Legend Public Methods

The methods of the BendPia class are listed here.

Collapse Expand Class

BendPia Class

Collapse Expand Public Methods
Name | Description
as_array | Returns bend points as a simple array.
begin | This is the overview for the begin method overload.
deleteContents | Zeroes out all values.
end | This is the overview for the end method overload.
getNumBend | Returns the number of bendpoints.
max_size | Returns maximum number of bend points.
project | Projects bend points, using 1979 bend points as a base.
setNumBend | Sets the number of bendpoints. Sets number of bend points.
size | Returns number of bend points.
Collapse Expand Links
BendPia Class, Legend, Public Methods


BendPia::as_array Method

BendPia::as_array Method
BendPia Class BendPia Members BendPia Methods

Returns bend points as a simple array.

C++
double* as_array();
Collapse Expand Returns

Percentages as a simple array.

Collapse Expand Group

BendPia Methods

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Methods


begin Method

begin Method
BendPia Methods

This is the overview for the begin method overload.

Collapse Expand Overload List
Name | Description
BendPia::begin () | Returns beginning of array, non-const version.
BendPia::begin () | Returns beginning of array, non-const version.
Collapse Expand Group

BendPia Methods

Collapse Expand Links
BendPia Methods


BendPia::begin Method ()

BendPia::begin Method ()
BendPia Class BendPia Members begin Method

Returns beginning of array, non-const version.

C++
iterator begin();
Collapse Expand Returns

Beginning of array.

Collapse Expand Group

begin Method

Collapse Expand Links
BendPia Class, BendPia Members, begin Method


BendPia::begin Method ()

BendPia::begin Method ()
BendPia Class BendPia Members begin Method

Returns beginning of array, non-const version.

C++
const_iterator begin() const;
Collapse Expand Returns

Beginning of array.

Collapse Expand Group

begin Method

Collapse Expand Links
BendPia Class, BendPia Members, begin Method


BendPia::deleteContents Method

BendPia::deleteContents Method
BendPia Class BendPia Members BendPia Methods

Zeroes out all values.

C++
void deleteContents();
Collapse Expand Group

BendPia Methods

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Methods


end Method

end Method
BendPia Methods

This is the overview for the end method overload.

Collapse Expand Overload List
Name | Description
BendPia::end () | Returns one past end of array, non-const version.
BendPia::end () | Returns one past end of array, const version.
Collapse Expand Group

BendPia Methods

Collapse Expand Links
BendPia Methods


BendPia::end Method ()

BendPia::end Method ()
BendPia Class BendPia Members end Method

Returns one past end of array, non-const version.

C++
iterator end();
Collapse Expand Returns

One past end of array.

Collapse Expand Group

end Method

Collapse Expand Links
BendPia Class, BendPia Members, end Method


BendPia::end Method ()

BendPia::end Method ()
BendPia Class BendPia Members end Method

Returns one past end of array, const version.

C++
const_iterator end() const;
Collapse Expand Returns

One past end of array.

Collapse Expand Group

end Method

Collapse Expand Links
BendPia Class, BendPia Members, end Method


BendPia::getNumBend Method

BendPia::getNumBend Method
BendPia Class BendPia Members BendPia Methods

Returns the number of bendpoints.

C++
size_type getNumBend() const;
Collapse Expand Returns

Number of bend points.

Collapse Expand Group

BendPia Methods

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Methods


BendPia::max_size Method

BendPia::max_size Method
BendPia Class BendPia Members BendPia Methods

Returns maximum number of bend points.

C++
size_type max_size() const;
Collapse Expand Returns

Number of bend points.

Collapse Expand Group

BendPia Methods

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Methods


BendPia::project Method

BendPia::project Method
BendPia Class BendPia Members BendPia Methods

Projects bend points, using 1979 bend points as a base.

C++
void project(
    int eligYear,
    const AverageWage& fq
);
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
const AverageWage& fq | Average wage series.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if average wages are not initialized (only in debug mode).
Collapse Expand Group

BendPia Methods

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Methods


BendPia::setNumBend Method

BendPia::setNumBend Method
BendPia Class BendPia Members BendPia Methods

Sets the number of bendpoints.

Sets number of bend points.

C++
void setNumBend(
    int newNumBend
);
Collapse Expand Parameters
Parameters | Description
int newNumBend | Number of bend points in formula.
Collapse Expand Returns

Number of bend points.

Collapse Expand Group

BendPia Methods

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Methods


BendPia::size Method

BendPia::size Method
BendPia Class BendPia Members BendPia Methods

Returns number of bend points.

C++
size_type size() const;
Collapse Expand Returns

Number of bend points.

Collapse Expand Group

BendPia Methods

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Methods


BendPia Operators

BendPia Operators
BendPia Class Legend

The operators of the BendPia class are listed here.

Collapse Expand Class

BendPia Class

Collapse Expand Public Operators
Name | Description
[] | This is the overview for the [] operator overload.
Collapse Expand Links
BendPia Class, Legend


[] Operator

[] Operator
BendPia Operators

This is the overview for the [] operator overload.

Collapse Expand Overload List
Name | Description
BendPia::[] (std::size_t) | Returns a pia formula bend point, non-const version.
BendPia::[] (std::size_t) | Returns a pia formula bend point, const version.
Collapse Expand Group

BendPia Operators

Collapse Expand Links
BendPia Operators


BendPia::[] Operator (std::size_t)

BendPia::[] Operator (std::size_t)
BendPia Class BendPia Members [] Operator

Returns a pia formula bend point, non-const version.

C++
reference operator [](
    std::size_t index
);
Collapse Expand Parameters
Parameters | Description
std::size_t index | Index of bend point desired (0-2).
Collapse Expand Returns

A pia formula bend point.

Collapse Expand Group

[] Operator

Collapse Expand Links
BendPia Class, BendPia Members, [] Operator


BendPia::[] Operator (std::size_t)

BendPia::[] Operator (std::size_t)
BendPia Class BendPia Members [] Operator

Returns a pia formula bend point, const version.

C++
const_reference operator [](
    std::size_t index
) const;
Collapse Expand Parameters
Parameters | Description
std::size_t index | Index of bend point desired (0-2).
Collapse Expand Returns

A pia formula bend point.

Collapse Expand Group

[] Operator

Collapse Expand Links
BendPia Class, BendPia Members, [] Operator


BendPia Nested Types

BendPia Nested Types
BendPia Class Public Nested Types

The nested types of the BendPia class are listed here.

Collapse Expand Class

BendPia Class

Collapse Expand Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of size in this array.
value_type | The type of data in this array.
Collapse Expand Links
BendPia Class, Public Nested Types


BendPia::const_iterator Nested Type

BendPia::const_iterator Nested Type
BendPia Class BendPia Members BendPia Nested Types

A const iterator for this array.

C++
typedef const double* const_iterator;
Collapse Expand Group

BendPia Nested Types

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Nested Types


BendPia::const_reference Nested Type

BendPia::const_reference Nested Type
BendPia Class BendPia Members BendPia Nested Types

A const reference for this array.

C++
typedef const double& const_reference;
Collapse Expand Group

BendPia Nested Types

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Nested Types


BendPia::difference_type Nested Type

BendPia::difference_type Nested Type
BendPia Class BendPia Members BendPia Nested Types

The type of difference in this array.

C++
typedef ptrdiff_t difference_type;
Collapse Expand Group

BendPia Nested Types

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Nested Types


BendPia::iterator Nested Type

BendPia::iterator Nested Type
BendPia Class BendPia Members BendPia Nested Types

An iterator for this array.

C++
typedef double* iterator;
Collapse Expand Group

BendPia Nested Types

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Nested Types


BendPia::reference Nested Type

BendPia::reference Nested Type
BendPia Class BendPia Members BendPia Nested Types

A reference for this array.

C++
typedef double& reference;
Collapse Expand Group

BendPia Nested Types

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Nested Types


BendPia::size_type Nested Type

BendPia::size_type Nested Type
BendPia Class BendPia Members BendPia Nested Types

The type of size in this array.

C++
typedef std::size_t size_type;
Collapse Expand Group

BendPia Nested Types

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Nested Types


BendPia::value_type Nested Type

BendPia::value_type Nested Type
BendPia Class BendPia Members BendPia Nested Types

The type of data in this array.

C++
typedef double value_type;
Collapse Expand Group

BendPia Nested Types

Collapse Expand Links
BendPia Class, BendPia Members, BendPia Nested Types


BendMfb Class

BendMfb Class
BendMfb Data Members BendMfb Methods BendMfb Operators BendMfb Nested Types BendMfb Members bendmfb.h Classes

Manages the array of bend points used in the MFB formula.

Collapse Expand Class Hierarchy
  BendMfb
C++
class BendMfb;
Collapse Expand File

File: bendmfb.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is used in most of the PiaMethod classes. There is an array with 4 slots for bend points.

Collapse Expand Group

Classes

Collapse Expand Links
BendMfb Data Members, BendMfb Methods, BendMfb Operators, BendMfb Nested Types, BendMfb Members, bendmfb.h, Classes


BendMfb Members

BendMfb Members
BendMfb Class Legend Public Data Members Public Methods Public Nested Types

The following tables list the members exposed by BendMfb.

Collapse Expand Class

BendMfb Class

Collapse Expand Public Data Members
Name | Description
BP1979 | Four bend points from 1979.
Collapse Expand Public Methods
Name | Description
BendMfb | Constructor.
as_array | Returns bend points as a simple array.
begin | This is the overview for the begin method overload.
deleteContents | Zeroes out all values.
end | This is the overview for the end method overload.
max_size | Returns maximum number of bend points.
project | Projects bend points, using 1979 bend points as a base.
size | Returns number of bend points.
~BendMfb | Destroys bend point array.
Collapse Expand Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of number of bend points in this array.
value_type | The type of data in this array.
Collapse Expand Public Operators
Name | Description
[] | This is the overview for the [] operator overload.
Collapse Expand Links
BendMfb Class, Legend, Public Data Members, Public Methods, Public Nested Types


BendMfb::BendMfb Constructor

BendMfb::BendMfb Constructor
BendMfb Class BendMfb Members BendMfb Class

Constructor.

C++
BendMfb();
Collapse Expand Remarks

Sets first bend point to 0.0.

Collapse Expand Class

BendMfb Class

Collapse Expand Links
BendMfb Class, BendMfb Members, BendMfb Class


BendMfb::~BendMfb Destructor

BendMfb::~BendMfb Destructor
BendMfb Class BendMfb Members BendMfb Class

Destroys bend point array.

C++
~BendMfb();
Collapse Expand Class

BendMfb Class

Collapse Expand Links
BendMfb Class, BendMfb Members, BendMfb Class


BendMfb Data Members

BendMfb Data Members
BendMfb Class Legend Public Data Members

The data members of the BendMfb class are listed here.

Collapse Expand Class

BendMfb Class

Collapse Expand Public Data Members
Name | Description
BP1979 | Four bend points from 1979.
Collapse Expand Links
BendMfb Class, Legend, Public Data Members


BendMfb::BP1979 Data Member

BendMfb::BP1979 Data Member
BendMfb Class BendMfb Members BendMfb Data Members

Four bend points from 1979.

C++
const double BP1979[MAXBP];
Collapse Expand Group

BendMfb Data Members

Collapse Expand Links
BendMfb Class, BendMfb Members, BendMfb Data Members


BendMfb Methods

BendMfb Methods
BendMfb Class Legend Public Methods

The methods of the BendMfb class are listed here.

Collapse Expand Class

BendMfb Class

Collapse Expand Public Methods
Name | Description
as_array | Returns bend points as a simple array.
begin | This is the overview for the begin method overload.
deleteContents | Zeroes out all values.
end | This is the overview for the end method overload.
max_size | Returns maximum number of bend points.
project | Projects bend points, using 1979 bend points as a base.
size | Returns number of bend points.
Collapse Expand Links
BendMfb Class, Legend, Public Methods


BendMfb::as_array Method

BendMfb::as_array Method
BendMfb Class BendMfb Members BendMfb Methods

Returns bend points as a simple array.

C++
double* as_array();
Collapse Expand Returns

Percentages as a simple array.

Collapse Expand Group

BendMfb Methods

Collapse Expand Links
BendMfb Class, BendMfb Members, BendMfb Methods


begin Method

begin Method
BendMfb Methods

This is the overview for the begin method overload.

Collapse Expand Overload List
Name | Description
BendMfb::begin () | Returns beginning of array, non-const version.
BendMfb::begin () | Returns beginning of array, const version.
Collapse Expand Group

BendMfb Methods

Collapse Expand Links
BendMfb Methods


BendMfb::begin Method ()

BendMfb::begin Method ()
BendMfb Class BendMfb Members begin Method

Returns beginning of array, non-const version.

C++
iterator begin();
Collapse Expand Returns

Beginning of array.

Collapse Expand Group

begin Method

Collapse Expand Links
BendMfb Class, BendMfb Members, begin Method


BendMfb::begin Method ()

BendMfb::begin Method ()
BendMfb Class BendMfb Members begin Method

Returns beginning of array, const version.

C++
const_iterator begin() const;
Collapse Expand Returns

Beginning of array.

Collapse Expand Group

begin Method

Collapse Expand Links
BendMfb Class, BendMfb Members, begin Method


BendMfb::deleteContents Method

BendMfb::deleteContents Method
BendMfb Class BendMfb Members BendMfb Methods

Zeroes out all values.

C++
void deleteContents();
Collapse Expand Group

BendMfb Methods

Collapse Expand Links
BendMfb Class, BendMfb Members, BendMfb Methods


end Method

end Method
BendMfb Methods

This is the overview for the end method overload.

Collapse Expand Overload List
Name | Description
BendMfb::end () | Returns one past end of array, non-const version.
BendMfb::end () | Returns one past end of array, const version.
Collapse Expand Group

BendMfb Methods

Collapse Expand Links
BendMfb Methods


BendMfb::end Method ()

BendMfb::end Method ()
BendMfb Class BendMfb Members end Method

Returns one past end of array, non-const version.

C++
iterator end();
Collapse Expand Returns

One past end of array.

Collapse Expand Group

end Method

Collapse Expand Links
BendMfb Class, BendMfb Members, end Method


BendMfb::end Method ()

BendMfb::end Method ()
BendMfb Class BendMfb Members end Method

Returns one past end of array, const version.

C++
const_iterator end() const;
Collapse Expand Returns

One past end of array.

Collapse Expand Group

end Method

Collapse Expand Links
BendMfb Class, BendMfb Members, end Method


BendMfb::max_size Method

BendMfb::max_size Method
BendMfb Class BendMfb Members BendMfb Methods

Returns maximum number of bend points.

C++
size_type max_size() const;
Collapse Expand Returns

Number of bend points.

Collapse Expand Group

BendMfb Methods

Collapse Expand Links
BendMfb Class, BendMfb Members, BendMfb Methods


BendMfb::project Method

BendMfb::project Method
BendMfb Class BendMfb Members BendMfb Methods

Projects bend points, using 1979 bend points as a base.

C++
void project(
    int eligYear,
    const AverageWage& fq
);
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
const AverageWage& fq | Average wage series.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if average wages are not initialized (only in debug mode).
Collapse Expand Group

BendMfb Methods

Collapse Expand Links
BendMfb Class, BendMfb Members, BendMfb Methods


BendMfb::size Method

BendMfb::size Method
BendMfb Class BendMfb Members BendMfb Methods

Returns number of bend points.

C++
size_type size() const;
Collapse Expand Returns

Number of bend points.

Collapse Expand Group

BendMfb Methods

Collapse Expand Links
BendMfb Class, BendMfb Members, BendMfb Methods


BendMfb Operators

BendMfb Operators
BendMfb Class Legend

The operators of the BendMfb class are listed here.

Collapse Expand Class

BendMfb Class

Collapse Expand Public Operators
Name | Description
[] | This is the overview for the [] operator overload.
Collapse Expand Links
BendMfb Class, Legend


[] Operator

[] Operator
BendMfb Operators

This is the overview for the [] operator overload.

Collapse Expand Overload List
Name | Description
BendMfb::[] (std::size_t) | Returns an mfb formula bend point, non-const version.
BendMfb::[] (std::size_t) | Returns an mfb formula bend point, const version.
Collapse Expand Group

BendMfb Operators

Collapse Expand Links
BendMfb Operators


BendMfb::[] Operator (std::size_t)

BendMfb::[] Operator (std::size_t)
BendMfb Class BendMfb Members [] Operator

Returns an mfb formula bend point, non-const version.

C++
reference operator [](
    std::size_t index
);
Collapse Expand Parameters
Parameters | Description
std::size_t index | Index of bend point desired (0-3).
Collapse Expand Returns

An mfb formula bend point.

Collapse Expand Group

[] Operator

Collapse Expand Links
BendMfb Class, BendMfb Members, [] Operator


BendMfb::[] Operator (std::size_t)

BendMfb::[] Operator (std::size_t)
BendMfb Class BendMfb Members [] Operator

Returns an mfb formula bend point, const version.

C++
const_reference operator [](
    std::size_t index
) const;
Collapse Expand Parameters
Parameters | Description
std::size_t index | Index of bend point desired (0-3).
Collapse Expand Returns

An mfb formula bend point.

Collapse Expand Group

[] Operator

Collapse Expand Links
BendMfb Class, BendMfb Members, [] Operator


BendMfb Nested Types

BendMfb Nested Types
BendMfb Class Public Nested Types

The nested types of the BendMfb class are listed here.

Collapse Expand Class

BendMfb Class

Collapse Expand Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of number of bend points in this array.
value_type | The type of data in this array.
Collapse Expand Links
BendMfb Class, Public Nested Types


BendMfb::const_iterator Nested Type

BendMfb::const_iterator Nested Type
BendMfb Class BendMfb Members BendMfb Nested Types

A const iterator for this array.

C++
typedef const double* const_iterator;
Collapse Expand Group

BendMfb Nested Types

Collapse Expand Links
BendMfb Class, BendMfb Members, BendMfb Nested Types


BendMfb::const_reference Nested Type

BendMfb::const_reference Nested Type
BendMfb Class BendMfb Members BendMfb Nested Types

A const reference for this array.

C++
typedef const double& const_reference;
Collapse Expand Group

BendMfb Nested Types

Collapse Expand Links
BendMfb Class, BendMfb Members, BendMfb Nested Types


BendMfb::difference_type Nested Type

BendMfb::difference_type Nested Type
BendMfb Class BendMfb Members BendMfb Nested Types

The type of difference in this array.

C++
typedef ptrdiff_t difference_type;
Collapse Expand Group

BendMfb Nested Types

Collapse Expand Links
BendMfb Class, BendMfb Members, BendMfb Nested Types


BendMfb::iterator Nested Type

BendMfb::iterator Nested Type
BendMfb Class BendMfb Members BendMfb Nested Types

An iterator for this array.

C++
typedef double* iterator;
Collapse Expand Group

BendMfb Nested Types

Collapse Expand Links
BendMfb Class, BendMfb Members, BendMfb Nested Types


BendMfb::reference Nested Type

BendMfb::reference Nested Type
BendMfb Class BendMfb Members BendMfb Nested Types

A reference for this array.

C++
typedef double& reference;
Collapse Expand Group

BendMfb Nested Types

Collapse Expand Links
BendMfb Class, BendMfb Members, BendMfb Nested Types


BendMfb::size_type Nested Type

BendMfb::size_type Nested Type
BendMfb Class BendMfb Members BendMfb Nested Types

The type of number of bend points in this array.

C++
typedef std::size_t size_type;
Collapse Expand Group

BendMfb Nested Types

Collapse Expand Links
BendMfb Class, BendMfb Members, BendMfb Nested Types


BendMfb::value_type Nested Type

BendMfb::value_type Nested Type
BendMfb Class BendMfb Members BendMfb Nested Types

The type of data in this array.

C++
typedef double value_type;
Collapse Expand Group

BendMfb Nested Types

Collapse Expand Links
BendMfb Class, BendMfb Members, BendMfb Nested Types


BenefitAmount Class

BenefitAmount Class
BenefitAmount Methods BenefitAmount Operators BenefitAmount Members BenefitAmount.h Classes

Represents a benefit amount for one year.

Collapse Expand Class Hierarchy
  BenefitAmount
C++
class BenefitAmount;
Collapse Expand File

File: BenefitAmount.h

Module: PiaData Library

Collapse Expand Remarks

There are instances of this class in PiaData and the various PiaMethod classes.

Collapse Expand Group

Classes

Collapse Expand Links
BenefitAmount Methods, BenefitAmount Operators, BenefitAmount Members, BenefitAmount.h, Classes


BenefitAmount Members

BenefitAmount Members
BenefitAmount Class Legend Public Methods

The following tables list the members exposed by BenefitAmount.

Collapse Expand Class

BenefitAmount Class

Collapse Expand Public Methods
Name | Description
BenefitAmount | Initializes amount.
applyCola | Applies cola percent to a benefit.
get | Returns the benefit amount.
round | Rounds a PIA or MFB to the appropriate multiple of $0.10.
round1 | Rounds a specified PIA or MFB down to a whole dollar for June 1982 and later.
round5 | Rounds a benefit down to $5 multiple.
set | Sets the benefit amount.
toString | Returns benefit amount as a string with 2 decimal places.
unApplyCola | Removes cola percent from a quantity.
unround | Unrounds a PIA or MFB to the appropriate multiple of $0.10.
Collapse Expand Public Operators
Name | Description
< | Compares benefit with benefit from another instance.
Collapse Expand Links
BenefitAmount Class, Legend, Public Methods


BenefitAmount::BenefitAmount Constructor

BenefitAmount::BenefitAmount Constructor
BenefitAmount Class BenefitAmount Members BenefitAmount Class

Initializes amount.

C++
BenefitAmount(
    double newAmount = 0.0
);
Collapse Expand Parameters
Parameters | Description
double newAmount = 0.0 | New amount to use.
Collapse Expand Remarks

If argument is omitted, sets amount to 0.0.

Collapse Expand Class

BenefitAmount Class

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, BenefitAmount Class


BenefitAmount Methods

BenefitAmount Methods
BenefitAmount Class Legend Public Methods

The methods of the BenefitAmount class are listed here.

Collapse Expand Class

BenefitAmount Class

Collapse Expand Public Methods
Name | Description
applyCola | Applies cola percent to a benefit.
get | Returns the benefit amount.
round | Rounds a PIA or MFB to the appropriate multiple of $0.10.
round1 | Rounds a specified PIA or MFB down to a whole dollar for June 1982 and later.
round5 | Rounds a benefit down to $5 multiple.
set | Sets the benefit amount.
toString | Returns benefit amount as a string with 2 decimal places.
unApplyCola | Removes cola percent from a quantity.
unround | Unrounds a PIA or MFB to the appropriate multiple of $0.10.
Collapse Expand Links
BenefitAmount Class, Legend, Public Methods


applyCola Method

applyCola Method
BenefitAmount Methods

Applies cola percent to a benefit.

Collapse Expand Description

There are two versions of the applyCola function. The version with two arguments calls the static version with three arguments, passing it the stored benefit amount.

Collapse Expand Overload List
Name | Description
BenefitAmount::applyCola (double, double, int) | Applies cola percent to specified benefit.
BenefitAmount::applyCola (double, int) | Applies cola percent to stored benefit.
Collapse Expand Group

BenefitAmount Methods

Collapse Expand Links
BenefitAmount Methods


BenefitAmount::applyCola Method (double, double, int)

BenefitAmount::applyCola Method (double, double, int)
BenefitAmount Class BenefitAmount Members applyCola Method

Applies cola percent to specified benefit.

C++
static double applyCola(
    double theAmount,
    double percent,
    int year
);
Collapse Expand Parameters
Parameters | Description
double theAmount | Amount to increase.
double percent | Percentage increase.
int year | Year of increase.
Collapse Expand Returns

The increased amount.

Collapse Expand Group

applyCola Method

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, applyCola Method


BenefitAmount::applyCola Method (double, int)

BenefitAmount::applyCola Method (double, int)
BenefitAmount Class BenefitAmount Members applyCola Method

Applies cola percent to stored benefit.

C++
void applyCola(
    double percent,
    int year
);
Collapse Expand Parameters
Parameters | Description
double percent | Percentage increase.
int year | Year of increase.
Collapse Expand Remarks

Uses the stored amount to call the static version with 3 arguments.

Collapse Expand Group

applyCola Method

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, applyCola Method


BenefitAmount::get Method

BenefitAmount::get Method
BenefitAmount Class BenefitAmount Members BenefitAmount Methods

Returns the benefit amount.

C++
double get() const;
Collapse Expand Returns

The benefit amount.

Collapse Expand Group

BenefitAmount Methods

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, BenefitAmount Methods


round Method

round Method
BenefitAmount Methods

Rounds a PIA or MFB to the appropriate multiple of $0.10.

Collapse Expand Description

There are two versions of the round function. The version with only a year argument calls the static version with two arguments, passing it the stored benefit amount.

Collapse Expand Overload List
Name | Description
BenefitAmount::round (double, int) | Rounds a specified PIA or MFB to the appropriate multiple of $0.10.
BenefitAmount::round (int) | Rounds the stored PIA or MFB to the appropriate multiple of $0.10.
Collapse Expand Group

BenefitAmount Methods

Collapse Expand Links
BenefitAmount Methods


BenefitAmount::round Method (double, int)

BenefitAmount::round Method (double, int)
BenefitAmount Class BenefitAmount Members round Method

Rounds a specified PIA or MFB to the appropriate multiple of $0.10.

C++
static double round(
    double theAmount,
    int year
);
Collapse Expand Parameters
Parameters | Description
double theAmount | Amount to be rounded.
int year | Year of benefit increase, or year prior to year of wage-indexed formula.
Collapse Expand Returns

The rounded amount.

Collapse Expand Remarks

Round a cola calculation up for June 1981 and earlier colas, down for June 1982 and later colas. Round an aime pia calculation up for 1982 and earlier eligibility, down for 1983 and later eligibility.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ROUND if year is less than 1937 (only in debug mode).
Collapse Expand Group

round Method

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, round Method


BenefitAmount::round Method (int)

BenefitAmount::round Method (int)
BenefitAmount Class BenefitAmount Members round Method

Rounds the stored PIA or MFB to the appropriate multiple of $0.10.

C++
void round(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year of benefit increase, or year prior to year of wage-indexed formula.
Collapse Expand Remarks

Uses the stored amount to call the static version with 2 arguments. Round a cola calculation up for June 1981 and earlier colas, down for June 1982 and later colas. Round an aime pia calculation up for 1982 and earlier eligibility, down for 1983 and later eligibility.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ROUND if year is less than 1937 (only in debug mode).
Collapse Expand Group

round Method

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, round Method


round1 Method

round1 Method
BenefitAmount Methods

Rounds a specified PIA or MFB down to a whole dollar for June 1982 and later.

Collapse Expand Description

There are two versions of the round1 function. The version with only a year argument calls the static version with two arguments, passing it the stored benefit amount.

Collapse Expand Overload List
Name | Description
BenefitAmount::round1 (const DateMoyr&) | Rounds the stored PIA or MFB down to a whole dollar for June 1982 and later.
BenefitAmount::round1 (double, const DateMoyr&) | Rounds a specified PIA or MFB down to a whole dollar for June 1982 and later.
Collapse Expand Group

BenefitAmount Methods

Collapse Expand Links
BenefitAmount Methods


BenefitAmount::round1 Method (const DateMoyr&)

BenefitAmount::round1 Method (const DateMoyr&)
BenefitAmount Class BenefitAmount Members round1 Method

Rounds the stored PIA or MFB down to a whole dollar for June 1982 and later.

C++
void round1(
    const DateMoyr& benDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& benDate | The date of benefit.
Collapse Expand Remarks

Uses the stored amount to call the static version with 2 arguments.

Collapse Expand Group

round1 Method

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, round1 Method


BenefitAmount::round1 Method (double, const DateMoyr&)

BenefitAmount::round1 Method (double, const DateMoyr&)
BenefitAmount Class BenefitAmount Members round1 Method

Rounds a specified PIA or MFB down to a whole dollar for June 1982 and later.

C++
static double round1(
    double theAmount,
    const DateMoyr& benDate
);
Collapse Expand Parameters
Parameters | Description
double theAmount | Amount to be rounded.
const DateMoyr& benDate | The date of benefit.
Collapse Expand Returns

The rounded amount.

Collapse Expand Group

round1 Method

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, round1 Method


round5 Method

round5 Method
BenefitAmount Methods

Rounds a benefit down to $5 multiple.

Collapse Expand Description

There are two versions of the round5 function. The version with only a year argument calls the static version with two arguments, passing it the stored benefit amount.

Collapse Expand Overload List
Name | Description
BenefitAmount::round5 (double, int) | Rounds specified benefit down to $5 multiple.
BenefitAmount::round5 (int) | Rounds stored benefit down to $5 multiple.
Collapse Expand Group

BenefitAmount Methods

Collapse Expand Links
BenefitAmount Methods


BenefitAmount::round5 Method (double, int)

BenefitAmount::round5 Method (double, int)
BenefitAmount Class BenefitAmount Members round5 Method

Rounds specified benefit down to $5 multiple.

C++
static int round5(
    double theAmount,
    int year
);
Collapse Expand Parameters
Parameters | Description
double theAmount | Amount to be rounded.
int year | Year of benefit.
Collapse Expand Returns

The rounded benefit.

Collapse Expand Remarks

Use this function for Social Security Statements before 2000. For years 2000 and later, the rounding should be down to $1 multiple.

Collapse Expand Group

round5 Method

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, round5 Method


BenefitAmount::round5 Method (int)

BenefitAmount::round5 Method (int)
BenefitAmount Class BenefitAmount Members round5 Method

Rounds stored benefit down to $5 multiple.

C++
int round5(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of benefit.
theAmount | Amount to be rounded.
Collapse Expand Returns

The rounded benefit.

Collapse Expand Remarks

The version with 1 argument uses the stored amount to call the static version with 2 arguments. Use this function for Social Security Statements before 2000. For years 2000 and later, the rounding should be down to $1 multiple.

Collapse Expand Group

round5 Method

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, round5 Method


BenefitAmount::set Method

BenefitAmount::set Method
BenefitAmount Class BenefitAmount Members BenefitAmount Methods

Sets the benefit amount.

C++
void set(
    double newAmount
);
Collapse Expand Parameters
Parameters | Description
double newAmount | New benefit amount.
Collapse Expand Group

BenefitAmount Methods

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, BenefitAmount Methods


BenefitAmount::toString Method

BenefitAmount::toString Method
BenefitAmount Class BenefitAmount Members BenefitAmount Methods

Returns benefit amount as a string with 2 decimal places.

C++
std::string toString() const;
Collapse Expand Returns

Benefit amount as a string with 2 decimal places.

Collapse Expand Group

BenefitAmount Methods

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, BenefitAmount Methods


unApplyCola Method

unApplyCola Method
BenefitAmount Methods

Removes cola percent from a quantity.

Collapse Expand Description

There are two versions of the unApplyCola function. The version with two arguments calls the static version with three arguments, passing it the stored benefit amount.

Collapse Expand Overload List
Name | Description
BenefitAmount::unApplyCola (double, double, int) | Removes cola percent from specified quantity.
BenefitAmount::unApplyCola (double, int) | Removes cola percent from stored quantity.
Collapse Expand Group

BenefitAmount Methods

Collapse Expand Links
BenefitAmount Methods


BenefitAmount::unApplyCola Method (double, double, int)

BenefitAmount::unApplyCola Method (double, double, int)
BenefitAmount Class BenefitAmount Members unApplyCola Method

Removes cola percent from specified quantity.

C++
static double unApplyCola(
    double theAmount,
    double percent,
    int year
);
Collapse Expand Parameters
Parameters | Description
double theAmount | Amount to decrease.
double percent | Percentage decrease.
int year | Year of decrease.
Collapse Expand Returns

The decreased amount.

Collapse Expand Group

unApplyCola Method

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, unApplyCola Method


BenefitAmount::unApplyCola Method (double, int)

BenefitAmount::unApplyCola Method (double, int)
BenefitAmount Class BenefitAmount Members unApplyCola Method

Removes cola percent from stored quantity.

C++
void unApplyCola(
    double percent,
    int year
);
Collapse Expand Parameters
Parameters | Description
double percent | Percentage decrease.
int year | Year of decrease.
Collapse Expand Remarks

Uses the stored amount to call the static version with 3 arguments.

Collapse Expand Group

unApplyCola Method

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, unApplyCola Method


unround Method

unround Method
BenefitAmount Methods

Unrounds a PIA or MFB to the appropriate multiple of $0.10.

Collapse Expand Description

There are two versions of the unround function. The version with only a year argument calls the static version with two arguments, passing it the stored benefit amount.

Collapse Expand Overload List
Name | Description
BenefitAmount::unround (double, int) | Unrounds a specified PIA or MFB to the appropriate multiple of $0.10.
BenefitAmount::unround (int) | Unrounds the stored PIA or MFB to the appropriate multiple of $0.10.
Collapse Expand Group

BenefitAmount Methods

Collapse Expand Links
BenefitAmount Methods


BenefitAmount::unround Method (double, int)

BenefitAmount::unround Method (double, int)
BenefitAmount Class BenefitAmount Members unround Method

Unrounds a specified PIA or MFB to the appropriate multiple of $0.10.

C++
static double unround(
    double theAmount,
    int year
);
Collapse Expand Parameters
Parameters | Description
double theAmount | Amount to be unrounded.
int year | Year of benefit increase, or year prior to year of wage-indexed formula.
Collapse Expand Returns

The unrounded amount.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ROUND if year is less than 1937 (only in debug mode).
Collapse Expand Group

unround Method

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, unround Method


BenefitAmount::unround Method (int)

BenefitAmount::unround Method (int)
BenefitAmount Class BenefitAmount Members unround Method

Unrounds the stored PIA or MFB to the appropriate multiple of $0.10.

C++
void unround(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year of benefit increase, or year prior to year of wage-indexed formula.
Collapse Expand Remarks

Uses the stored amount to call the static version with 2 arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ROUND if year is less than 1937 (only in debug mode).
Collapse Expand Group

unround Method

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, unround Method


BenefitAmount Operators

BenefitAmount Operators
BenefitAmount Class Legend

The operators of the BenefitAmount class are listed here.

Collapse Expand Class

BenefitAmount Class

Collapse Expand Public Operators
Name | Description
< | Compares benefit with benefit from another instance.
Collapse Expand Links
BenefitAmount Class, Legend


BenefitAmount::< Operator

BenefitAmount::< Operator
BenefitAmount Class BenefitAmount Members BenefitAmount Operators

Compares benefit with benefit from another instance.

C++
bool operator <(
    const BenefitAmount& bentemp
) const;
Collapse Expand Parameters
Parameters | Description
const BenefitAmount& bentemp | Benefit to compare to.
Collapse Expand Returns

True if this benefit is less than argument.

Collapse Expand Group

BenefitAmount Operators

Collapse Expand Links
BenefitAmount Class, BenefitAmount Members, BenefitAmount Operators


BenefitAmountArray Class

BenefitAmountArray Class
BenefitAmountArray Constructor BenefitAmountArray Methods BenefitAmountArray Operators BenefitAmountArray Members BenefitAmountArray.h Classes

Manages an array of BenefitAmount's.

Collapse Expand Class Hierarchy
  BenefitAmountArray
C++
class BenefitAmountArray;
Collapse Expand File

File: BenefitAmountArray.h

Module: PiaData Library

Collapse Expand Remarks

Manages an array of BenefitAmount's.

Collapse Expand Group

Classes

Collapse Expand Links
BenefitAmountArray Constructor, BenefitAmountArray Methods, BenefitAmountArray Operators, BenefitAmountArray Members, BenefitAmountArray.h, Classes


BenefitAmountArray Members

BenefitAmountArray Members
BenefitAmountArray Class Legend Public Methods

The following tables list the members exposed by BenefitAmountArray.

Collapse Expand Class

BenefitAmountArray Class

Collapse Expand Public Methods
Name | Description
BenefitAmountArray | Initializes a BenefitAmountArray, with or without a specified ending year.
deleteContents | Sets all values to zero.
getLastYear | Returns the last year of data.
initialize | Initializes last year.
setDirty | Sets indicator for non-zero values.
~BenefitAmountArray | Deletes allocated memory.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
BenefitAmountArray Class, Legend, Public Methods


BenefitAmountArray Constructor

BenefitAmountArray Constructor
BenefitAmountArray Class

Initializes a BenefitAmountArray, with or without a specified ending year.

Collapse Expand Description

There are two versions of the BenefitAmountArray constructor. If the last year is specified, the data array is allocated to cover the range of years from 1937 to the specified year. Otherwise the data array is left with size 0; it should be changed later to a valid year via the initialize function.

Collapse Expand Overload List
Name | Description
BenefitAmountArray::BenefitAmountArray () | Initializes the last year to 0 and the data array to zero size.
BenefitAmountArray::BenefitAmountArray (int) | Initializes the last year to the specified value.
Collapse Expand Class

BenefitAmountArray Class

Collapse Expand Links
BenefitAmountArray Class


BenefitAmountArray::BenefitAmountArray Constructor ()

BenefitAmountArray::BenefitAmountArray Constructor ()
BenefitAmountArray Class BenefitAmountArray Members BenefitAmountArray Constructor

Initializes the last year to 0 and the data array to zero size.

C++
BenefitAmountArray();
Collapse Expand Remarks

The first year is set to 1937, but the last year must be set via the initialize function before this instance can be used.

Collapse Expand Group

BenefitAmountArray Constructor

Collapse Expand Links
BenefitAmountArray Class, BenefitAmountArray Members, BenefitAmountArray Constructor


BenefitAmountArray::BenefitAmountArray Constructor (int)

BenefitAmountArray::BenefitAmountArray Constructor (int)
BenefitAmountArray Class BenefitAmountArray Members BenefitAmountArray Constructor

Initializes the last year to the specified value.

C++
explicit BenefitAmountArray(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | New last year.
Collapse Expand Remarks

Resizes the data array to cover the span of years from 1937 to the specified year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BENARRAY1 (in debug version) if year is out of range.
Collapse Expand Group

BenefitAmountArray Constructor

Collapse Expand Links
BenefitAmountArray Class, BenefitAmountArray Members, BenefitAmountArray Constructor


BenefitAmountArray::~BenefitAmountArray Destructor

BenefitAmountArray::~BenefitAmountArray Destructor
BenefitAmountArray Class BenefitAmountArray Members BenefitAmountArray Class

Deletes allocated memory.

C++
~BenefitAmountArray();
Collapse Expand Class

BenefitAmountArray Class

Collapse Expand Links
BenefitAmountArray Class, BenefitAmountArray Members, BenefitAmountArray Class


BenefitAmountArray Methods

BenefitAmountArray Methods
BenefitAmountArray Class Legend Public Methods

The methods of the BenefitAmountArray class are listed here.

Collapse Expand Class

BenefitAmountArray Class

Collapse Expand Public Methods
Name | Description
deleteContents | Sets all values to zero.
getLastYear | Returns the last year of data.
initialize | Initializes last year.
setDirty | Sets indicator for non-zero values.
Collapse Expand Links
BenefitAmountArray Class, Legend, Public Methods


BenefitAmountArray::deleteContents Method

BenefitAmountArray::deleteContents Method
BenefitAmountArray Class BenefitAmountArray Members BenefitAmountArray Methods

Sets all values to zero.

C++
void deleteContents();
Collapse Expand Group

BenefitAmountArray Methods

Collapse Expand Links
BenefitAmountArray Class, BenefitAmountArray Members, BenefitAmountArray Methods


BenefitAmountArray::getLastYear Method

BenefitAmountArray::getLastYear Method
BenefitAmountArray Class BenefitAmountArray Members BenefitAmountArray Methods

Returns the last year of data.

C++
int getLastYear() const;
Collapse Expand Returns

The last year of data.

Collapse Expand Group

BenefitAmountArray Methods

Collapse Expand Links
BenefitAmountArray Class, BenefitAmountArray Members, BenefitAmountArray Methods


BenefitAmountArray::initialize Method

BenefitAmountArray::initialize Method
BenefitAmountArray Class BenefitAmountArray Members BenefitAmountArray Methods

Initializes last year.

C++
void initialize(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | New last year.
Collapse Expand Remarks

Resizes the data array to cover the span of years from 1937 to the specified year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BENARRAY1 (in debug version) if year is out of range.
Collapse Expand Group

BenefitAmountArray Methods

Collapse Expand Links
BenefitAmountArray Class, BenefitAmountArray Members, BenefitAmountArray Methods


BenefitAmountArray::setDirty Method

BenefitAmountArray::setDirty Method
BenefitAmountArray Class BenefitAmountArray Members BenefitAmountArray Methods

Sets indicator for non-zero values.

C++
void setDirty();
Collapse Expand Group

BenefitAmountArray Methods

Collapse Expand Links
BenefitAmountArray Class, BenefitAmountArray Members, BenefitAmountArray Methods


BenefitAmountArray Operators

BenefitAmountArray Operators
BenefitAmountArray Class Legend

The operators of the BenefitAmountArray class are listed here.

Collapse Expand Class

BenefitAmountArray Class

Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
BenefitAmountArray Class, Legend


[] Operator

[] Operator
BenefitAmountArray Operators

Functions to access an element of the array.

Collapse Expand Description

There are two versions of the [] operator. They differ only in that one is const and the other is not, so that they can be used in both const and non-const settings.

Collapse Expand Overload List
Name | Description
BenefitAmountArray::[] (int) | Returns the benefit amount (non-const).
BenefitAmountArray::[] (int) | Returns the benefit amount (const).
Collapse Expand Group

BenefitAmountArray Operators

Collapse Expand Links
BenefitAmountArray Operators


BenefitAmountArray::[] Operator (int)

BenefitAmountArray::[] Operator (int)
BenefitAmountArray Class BenefitAmountArray Members [] Operator

Returns the benefit amount (non-const).

C++
BenefitAmount& operator [](
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which benefit amount is desired.
Collapse Expand Returns

The benefit amount for the specified year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BENARRAY2 if year is out of range (in debug version only).
Collapse Expand Group

[] Operator

Collapse Expand Links
BenefitAmountArray Class, BenefitAmountArray Members, [] Operator


BenefitAmountArray::[] Operator (int)

BenefitAmountArray::[] Operator (int)
BenefitAmountArray Class BenefitAmountArray Members [] Operator

Returns the benefit amount (const).

C++
const BenefitAmount operator [](
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which benefit amount is desired.
Collapse Expand Returns

The benefit amount for the specified year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BENARRAY2 if year is out of range (in debug version only).
Collapse Expand Group

[] Operator

Collapse Expand Links
BenefitAmountArray Class, BenefitAmountArray Members, [] Operator


Bic Class

Bic Class
Bic Constructor Bic Methods Bic Operators Bic Members bic.h Classes

Represents one 2-character bic (Beneficiary Identification code) code.

Collapse Expand Class Hierarchy
  Bic
C++
class Bic;
Collapse Expand File

File: bic.h

Module: PiaData Library

Collapse Expand Remarks

The major bic code has the following possible values:

A | primary (old-age or disability).
B | wife or husband (young or aged).
C | child (minor, student, or disabled).
D | aged widow(er).
E | mother or father.
F | parent.
T | transitionally insured.
U | transitionally uninsured.
W | disabled widow(er).

The minor bic code has the following possible values:

If majorBic is B, then

blank | aged wife or husband.
2 | young wife or husband.
6 | divorced aged wife or husband.

If majorBic is D, then

blank | aged widow(er).
6 | surviving divorced wife or husband.

If majorBic is W, then

blank | disabled widow(er).
6 | surviving disabled divorced wife or husband.

An instance of this class is used in Secondary.

Collapse Expand Group

Classes

Collapse Expand Links
Bic Constructor, Bic Methods, Bic Operators, Bic Members, bic.h, Classes


Bic Members

Bic Members
Bic Class Legend Public Methods

The following tables list the members exposed by Bic.

Collapse Expand Class

Bic Class

Collapse Expand Public Methods
Name | Description
Bic | Initializes a Bic, either with defaults or with specified characters.
eligibleForMax | Returns true if this benefit is affected by family maximum.
getLifeAuxType | Returns description of type of life auxiliary.
getMajorBic | Returns the major bic code.
getMinorBic | Returns the minor bic code.
getSurvivorType | Returns description of type of survivor.
isAuxiliary | Returns true if auxiliary beneficiary (major bic is B, C, D, E, F, or W).
isDisabledWidow | Returns true if disabled widow(er), false otherwise.
isReducible | Returns true if benefit is reducible for age.
isWidow | Returns true if widow(er) (aged or disabled), false otherwise.
isYoungSpouse | Returns true if young spouse.
isYoungSurvivor | Returns true if young survivor (child or mother/father), false otherwise.
set | Sets the bic codes.
setMajorBic | Sets the major bic code.
setMinorBic | Sets the minor bic code.
survivorCheck | Checks for valid survivor bic.
toString | Returns the bic code as a string.
Collapse Expand Public Operators
Name | Description
== | Compares to another Bic.
Collapse Expand Links
Bic Class, Legend, Public Methods


Bic Constructor

Bic Constructor
Bic Class

Initializes a Bic, either with defaults or with specified characters.

Collapse Expand Description

There are three versions of the Bic constructor. The default constructor initializes the major and minor Bic codes to blanks. Alternatively, the two codes can be initialized from the first two characters of a string, or from two characters.

Collapse Expand Overload List
Name | Description
Bic::Bic () | Initializes codes to blanks.
Bic::Bic (char, char) | Initializes codes from two characters.
Bic::Bic (const std::string&) | Initializes codes from the first two characters of a string.
Collapse Expand Class

Bic Class

Collapse Expand Links
Bic Class


Bic::Bic Constructor ()

Bic::Bic Constructor ()
Bic Class Bic Members Bic Constructor

Initializes codes to blanks.

C++
Bic();
Collapse Expand Group

Bic Constructor

Collapse Expand Links
Bic Class, Bic Members, Bic Constructor


Bic::Bic Constructor (char, char)

Bic::Bic Constructor (char, char)
Bic Class Bic Members Bic Constructor

Initializes codes from two characters.

C++
Bic(
    char newMajorBic,
    char newMinorBic
);
Collapse Expand Parameters
Parameters | Description
char newMajorBic | New major bic code.
char newMinorBic | New minor bic code.
Collapse Expand Group

Bic Constructor

Collapse Expand Links
Bic Class, Bic Members, Bic Constructor


Bic::Bic Constructor (const std::string&)

Bic::Bic Constructor (const std::string&)
Bic Class Bic Members Bic Constructor

Initializes codes from the first two characters of a string.

C++
Bic(
    const std::string& newCode
);
Collapse Expand Parameters
Parameters | Description
const std::string& newCode | New bic codes as a string.
Collapse Expand Group

Bic Constructor

Collapse Expand Links
Bic Class, Bic Members, Bic Constructor


Bic Methods

Bic Methods
Bic Class Legend Public Methods

The methods of the Bic class are listed here.

Collapse Expand Class

Bic Class

Collapse Expand Public Methods
Name | Description
eligibleForMax | Returns true if this benefit is affected by family maximum.
getLifeAuxType | Returns description of type of life auxiliary.
getMajorBic | Returns the major bic code.
getMinorBic | Returns the minor bic code.
getSurvivorType | Returns description of type of survivor.
isAuxiliary | Returns true if auxiliary beneficiary (major bic is B, C, D, E, F, or W).
isDisabledWidow | Returns true if disabled widow(er), false otherwise.
isReducible | Returns true if benefit is reducible for age.
isWidow | Returns true if widow(er) (aged or disabled), false otherwise.
isYoungSpouse | Returns true if young spouse.
isYoungSurvivor | Returns true if young survivor (child or mother/father), false otherwise.
set | Sets the bic codes.
setMajorBic | Sets the major bic code.
setMinorBic | Sets the minor bic code.
survivorCheck | Checks for valid survivor bic.
toString | Returns the bic code as a string.
Collapse Expand Links
Bic Class, Legend, Public Methods


Bic::eligibleForMax Method

Bic::eligibleForMax Method
Bic Class Bic Members Bic Methods

Returns true if this benefit is affected by family maximum.

C++
bool eligibleForMax() const;
Collapse Expand Returns

True if this benefit is affected by family maximum.

Collapse Expand Remarks

Divorced spouses are not affected by family maximum.

Collapse Expand Group

Bic Methods

Collapse Expand Links
Bic Class, Bic Members, Bic Methods


Bic::getLifeAuxType Method

Bic::getLifeAuxType Method
Bic Class Bic Members Bic Methods

Returns description of type of life auxiliary.

C++
std::string getLifeAuxType() const;
Collapse Expand Returns

Description of type of life auxiliary (empty string if bic is not a life auxiliary).

Collapse Expand Group

Bic Methods

Collapse Expand Links
Bic Class, Bic Members, Bic Methods


Bic::getMajorBic Method

Bic::getMajorBic Method
Bic Class Bic Members Bic Methods

Returns the major bic code.

C++
char getMajorBic() const;
Collapse Expand Returns

The major bic code.

Collapse Expand Group

Bic Methods

Collapse Expand Links
Bic Class, Bic Members, Bic Methods


Bic::getMinorBic Method

Bic::getMinorBic Method
Bic Class Bic Members Bic Methods

Returns the minor bic code.

C++
char getMinorBic() const;
Collapse Expand Returns

The minor bic code.

Collapse Expand Group

Bic Methods

Collapse Expand Links
Bic Class, Bic Members, Bic Methods


Bic::getSurvivorType Method

Bic::getSurvivorType Method
Bic Class Bic Members Bic Methods

Returns description of type of survivor.

C++
std::string getSurvivorType() const;
Collapse Expand Returns

Description of type of survivor (empty string if bic is not a survivor).

Collapse Expand Group

Bic Methods

Collapse Expand Links
Bic Class, Bic Members, Bic Methods


Bic::isAuxiliary Method

Bic::isAuxiliary Method
Bic Class Bic Members Bic Methods

Returns true if auxiliary beneficiary (major bic is B, C, D, E, F, or W).

C++
bool isAuxiliary() const;
Collapse Expand Returns

True if auxiliary beneficiary (major bic is B, C, D, E, F, or W).

Collapse Expand Group

Bic Methods

Collapse Expand Links
Bic Class, Bic Members, Bic Methods


Bic::isDisabledWidow Method

Bic::isDisabledWidow Method
Bic Class Bic Members Bic Methods

Returns true if disabled widow(er), false otherwise.

C++
bool isDisabledWidow() const;
Collapse Expand Returns

True if disabled widow(er), false otherwise.

Collapse Expand Group

Bic Methods

Collapse Expand Links
Bic Class, Bic Members, Bic Methods


Bic::isReducible Method

Bic::isReducible Method
Bic Class Bic Members Bic Methods

Returns true if benefit is reducible for age.

C++
bool isReducible() const;
Collapse Expand Returns

True if benefit is reducible for age.

Collapse Expand Remarks

Children's, young spouse's, and parent's benefits are not reducible for age.

Collapse Expand Group

Bic Methods

Collapse Expand Links
Bic Class, Bic Members, Bic Methods


Bic::isWidow Method

Bic::isWidow Method
Bic Class Bic Members Bic Methods

Returns true if widow(er) (aged or disabled), false otherwise.

C++
bool isWidow() const;
Collapse Expand Returns

True if widow(er) (aged or disabled), false otherwise.

Collapse Expand Group

Bic Methods

Collapse Expand Links
Bic Class, Bic Members, Bic Methods


Bic::isYoungSpouse Method

Bic::isYoungSpouse Method
Bic Class Bic Members Bic Methods

Returns true if young spouse.

C++
bool isYoungSpouse() const;
Collapse Expand Returns

True if young spouse.

Collapse Expand Group

Bic Methods

Collapse Expand Links
Bic Class, Bic Members, Bic Methods


Bic::isYoungSurvivor Method

Bic::isYoungSurvivor Method
Bic Class Bic Members Bic Methods

Returns true if young survivor (child or mother/father), false otherwise.

C++
bool isYoungSurvivor() const;
Collapse Expand Returns

True if young survivor (child or mother/father), false otherwise.

Collapse Expand Group

Bic Methods

Collapse Expand Links
Bic Class, Bic Members, Bic Methods


Bic::set Method

Bic::set Method
Bic Class Bic Members Bic Methods

Sets the bic codes.

C++
void set(
    const std::string& newCode
);
Collapse Expand Parameters
Parameters | Description
const std::string& newCode | New bic codes as a string.
Collapse Expand Group

Bic Methods

Collapse Expand Links
Bic Class, Bic Members, Bic Methods


Bic::setMajorBic Method

Bic::setMajorBic Method
Bic Class Bic Members Bic Methods

Sets the major bic code.

C++
void setMajorBic(
    char newMajorBic
);
Collapse Expand Parameters
Parameters | Description
char newMajorBic | New major bic code.
Collapse Expand Group

Bic Methods

Collapse Expand Links
Bic Class, Bic Members, Bic Methods


Bic::setMinorBic Method

Bic::setMinorBic Method
Bic Class Bic Members Bic Methods

Sets the minor bic code.

C++
void setMinorBic(
    char newMinorBic
);
Collapse Expand Parameters
Parameters | Description
char newMinorBic | New minor bic code.
Collapse Expand Group

Bic Methods

Collapse Expand Links
Bic Class, Bic Members, Bic Methods


Bic::survivorCheck Method

Bic::survivorCheck Method
Bic Class Bic Members Bic Methods

Checks for valid survivor bic.

C++
static void survivorCheck(
    char newMajorBic
);
Collapse Expand Parameters
Parameters | Description
char newMajorBic | The major bic to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_JSURV if bic is not a valid survivor bic.
Collapse Expand Group

Bic Methods

Collapse Expand Links
Bic Class, Bic Members, Bic Methods


Bic::toString Method

Bic::toString Method
Bic Class Bic Members Bic Methods

Returns the bic code as a string.

C++
std::string toString() const;
Collapse Expand Returns

The bic code as a string.

Collapse Expand Group

Bic Methods

Collapse Expand Links
Bic Class, Bic Members, Bic Methods


Bic Operators

Bic Operators
Bic Class Legend

The operators of the Bic class are listed here.

Collapse Expand Class

Bic Class

Collapse Expand Public Operators
Name | Description
== | Compares to another Bic.
Collapse Expand Links
Bic Class, Legend


Bic::== Operator

Bic::== Operator
Bic Class Bic Members Bic Operators

Compares to another Bic.

C++
bool operator ==(
    const Bic& bictemp
) const;
Collapse Expand Parameters
Parameters | Description
const Bic& bictemp | The Bic to compare to.
Collapse Expand Returns

True if major and minor codes agree, false otherwise.

Collapse Expand Group

Bic Operators

Collapse Expand Links
Bic Class, Bic Members, Bic Operators


Biproj Class

Biproj Class
Biproj Data Members Biproj Methods Biproj Members biproj.h Classes

Abstract parent of classes that manage the file of projected benefit increases.

Collapse Expand Class Hierarchy
  Biproj
C++
class Biproj;
Collapse Expand File

File: biproj.h

Module: PiaData Library

Collapse Expand Remarks

One of its subclasses should be instantiated: BiprojFile if it is to be gotten from disk, BiprojNonFile otherwise.

Collapse Expand See Also

BiprojFile, BiprojNonFile

Collapse Expand Group

Classes

Collapse Expand Links
Biproj Data Members, Biproj Methods, Biproj Members, biproj.h, Classes


Biproj Members

Biproj Members
Biproj Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by Biproj.

Collapse Expand Class

Biproj Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
beninc | Titles of projected benefit increase assumptions, other than the four TR assumptions.
biprojTitle | Title of projected benefit increases.
Collapse Expand Public Data Members
Name | Description
theData | Array of projected benefit increases.
Collapse Expand Public Methods
Name | Description
Biproj | Initializes projected benefit increase info.
cpiincCheck | Checks a benefit increase.
getFirstYear | Returns first year of data.
getTitle | Returns title of assumptions.
read | Read benefit increases.
setCpiinc | Sets one benefit increase.
setData | Sets benefit increases for one alternative.
setFirstYear | Sets first year of data.
setTitle | Sets the title for one alternative.
write | Save benefit increases.
~Biproj | Destructor.
Collapse Expand Links
Biproj Class, Legend, Protected Data Members, Public Data Members, Public Methods


Biproj::Biproj Constructor

Biproj::Biproj Constructor
Biproj Class Biproj Members Biproj Class

Initializes projected benefit increase info.

C++
Biproj(
    int newIstart,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
int newIstart | Starting year of benefit increases.
int newMaxyear | Maximum projected year.
Collapse Expand Remarks

Resizes the data array to cover the specified span of years.

Collapse Expand Class

Biproj Class

Collapse Expand Links
Biproj Class, Biproj Members, Biproj Class


Biproj::~Biproj Destructor

Biproj::~Biproj Destructor
Biproj Class Biproj Members Biproj Class

Destructor.

C++
virtual ~Biproj();
Collapse Expand Class

Biproj Class

Collapse Expand Links
Biproj Class, Biproj Members, Biproj Class


Biproj Data Members

Biproj Data Members
Biproj Class Legend Protected Data Members Public Data Members

The data members of the Biproj class are listed here.

Collapse Expand Class

Biproj Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
beninc | Titles of projected benefit increase assumptions, other than the four TR assumptions.
biprojTitle | Title of projected benefit increases.
Collapse Expand Public Data Members
Name | Description
theData | Array of projected benefit increases.
Collapse Expand Links
Biproj Class, Legend, Protected Data Members, Public Data Members


Biproj::beninc Data Member

Biproj::beninc Data Member
Biproj Class Biproj Members Biproj Data Members

Titles of projected benefit increase assumptions, other than the four TR assumptions.

C++
std::string beninc[3];
Collapse Expand Group

Biproj Data Members

Collapse Expand Links
Biproj Class, Biproj Members, Biproj Data Members


Biproj::biprojTitle Data Member

Biproj::biprojTitle Data Member
Biproj Class Biproj Members Biproj Data Members

Title of projected benefit increases.

C++
std::string biprojTitle;
Collapse Expand Group

Biproj Data Members

Collapse Expand Links
Biproj Class, Biproj Members, Biproj Data Members


Biproj::theData Data Member

Biproj::theData Data Member
Biproj Class Biproj Members Biproj Data Members

Array of projected benefit increases.

C++
DoubleAnnual theData;
Collapse Expand Group

Biproj Data Members

Collapse Expand Links
Biproj Class, Biproj Members, Biproj Data Members


Biproj Methods

Biproj Methods
Biproj Class Legend Public Methods

The methods of the Biproj class are listed here.

Collapse Expand Class

Biproj Class

Collapse Expand Public Methods
Name | Description
cpiincCheck | Checks a benefit increase.
getFirstYear | Returns first year of data.
getTitle | Returns title of assumptions.
read | Read benefit increases.
setCpiinc | Sets one benefit increase.
setData | Sets benefit increases for one alternative.
setFirstYear | Sets first year of data.
setTitle | Sets the title for one alternative.
write | Save benefit increases.
Collapse Expand Links
Biproj Class, Legend, Public Methods


Biproj::cpiincCheck Method

Biproj::cpiincCheck Method
Biproj Class Biproj Members Biproj Methods

Checks a benefit increase.

C++
static void cpiincCheck(
    double cpiinct
);
Collapse Expand Parameters
Parameters | Description
double cpiinct | Value to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_CPIINC1 if benefit increase is out of range.
Collapse Expand Group

Biproj Methods

Collapse Expand Links
Biproj Class, Biproj Members, Biproj Methods


Biproj::getFirstYear Method

Biproj::getFirstYear Method
Biproj Class Biproj Members Biproj Methods

Returns first year of data.

C++
int getFirstYear() const;
Collapse Expand Returns

First year of data.

Collapse Expand Group

Biproj Methods

Collapse Expand Links
Biproj Class, Biproj Members, Biproj Methods


Biproj::getTitle Method

Biproj::getTitle Method
Biproj Class Biproj Members Biproj Methods

Returns title of assumptions.

C++
const std::string& getTitle() const;
Collapse Expand Returns

Title of assumptions.

Collapse Expand Group

Biproj Methods

Collapse Expand Links
Biproj Class, Biproj Members, Biproj Methods


Biproj::read Method

Biproj::read Method
Biproj Class Biproj Members Biproj Methods

Read benefit increases.

C++
virtual void read(
    int
) = 0;
Collapse Expand Group

Biproj Methods

Collapse Expand Links
Biproj Class, Biproj Members, Biproj Methods


Biproj::setCpiinc Method

Biproj::setCpiinc Method
Biproj Class Biproj Members Biproj Methods

Sets one benefit increase.

C++
void setCpiinc(
    int year,
    double newCpiinc
);
Collapse Expand Parameters
Parameters | Description
int year | Year of benefit increase to set.
double newCpiinc | Value to use.
Collapse Expand Group

Biproj Methods

Collapse Expand Links
Biproj Class, Biproj Members, Biproj Methods


setData Method

setData Method
Biproj Methods

Sets benefit increases for one alternative.

Collapse Expand Description

There are two versions of the setData method; however, both are placeholder functions for child classes.

Collapse Expand Overload List
Name | Description
Biproj::setData (int) | Set benefit increases for one alternative.
Biproj::setData (int, const DoubleAnnual&) | Set benefit increases for one alternative.
Collapse Expand Group

Biproj Methods

Collapse Expand Links
Biproj Methods


Biproj::setData Method (int)

Biproj::setData Method (int)
Biproj Class Biproj Members setData Method

Set benefit increases for one alternative.

C++
virtual void setData(
    int
) = 0;
Collapse Expand Group

setData Method

Collapse Expand Links
Biproj Class, Biproj Members, setData Method


Biproj::setData Method (int, const DoubleAnnual&)

Biproj::setData Method (int, const DoubleAnnual&)
Biproj Class Biproj Members setData Method

Set benefit increases for one alternative.

C++
virtual void setData(
    int,
    const DoubleAnnual&
) = 0;
Collapse Expand Group

setData Method

Collapse Expand Links
Biproj Class, Biproj Members, setData Method


Biproj::setFirstYear Method

Biproj::setFirstYear Method
Biproj Class Biproj Members Biproj Methods

Sets first year of data.

C++
void setFirstYear(
    int newFirstYear
);
Collapse Expand Parameters
Parameters | Description
int newFirstYear | New first year of data.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if year is out of range (only in debug mode).
Collapse Expand Group

Biproj Methods

Collapse Expand Links
Biproj Class, Biproj Members, Biproj Methods


setTitle Method

setTitle Method
Biproj Methods

Sets the title for one alternative.

Collapse Expand Description

There are two versions of the setTitle method; however, both are placeholder functions for child classes.

Collapse Expand Overload List
Name | Description
Biproj::setTitle (int) | Sets title for one alternative.
Biproj::setTitle (int, const std::string&) | Sets title for one alternative.
Collapse Expand Group

Biproj Methods

Collapse Expand Links
Biproj Methods


Biproj::setTitle Method (int)

Biproj::setTitle Method (int)
Biproj Class Biproj Members setTitle Method

Sets title for one alternative.

C++
virtual void setTitle(
    int
) = 0;
Collapse Expand Group

setTitle Method

Collapse Expand Links
Biproj Class, Biproj Members, setTitle Method


Biproj::setTitle Method (int, const std::string&)

Biproj::setTitle Method (int, const std::string&)
Biproj Class Biproj Members setTitle Method

Sets title for one alternative.

C++
virtual void setTitle(
    int,
    const std::string&
) = 0;
Collapse Expand Group

setTitle Method

Collapse Expand Links
Biproj Class, Biproj Members, setTitle Method


Biproj::write Method

Biproj::write Method
Biproj Class Biproj Members Biproj Methods

Save benefit increases.

C++
virtual void write(
    int
) = 0;
Collapse Expand Group

Biproj Methods

Collapse Expand Links
Biproj Class, Biproj Members, Biproj Methods


BiprojFile Class

BiprojFile Class
BiprojFile Methods BiprojFile Members BiprojFile.h Classes

Manages the file of projected benefit increases stored on disk.

Collapse Expand Class Hierarchy
  BiprojFileBiprojFile
C++
class BiprojFile : public Biproj;
Collapse Expand File

File: BiprojFile.h

Module: PiaData Library

Collapse Expand Remarks

See BiprojNonFile for a version of this class that stores the benefit increases internally.

Collapse Expand See Also

BiprojNonFile

Collapse Expand Group

Classes

Collapse Expand Links
BiprojFile Methods, BiprojFile Members, BiprojFile.h, Classes


BiprojFile Members

BiprojFile Members
BiprojFile Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by BiprojFile.

Collapse Expand Class

BiprojFile Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
beninc | Titles of projected benefit increase assumptions, other than the four TR assumptions.
biprojTitle | Title of projected benefit increases.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
setBiFile | Forms a file name for projected benefit increase file.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
theData | Array of projected benefit increases.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
BiprojFile | Initializes projected benefit increase info.
cpiincCheck | Checks a benefit increase.
getFirstYear | Returns first year of data.
getTitle | Returns title of assumptions.
read | Reads projected benefit increases.
setCpiinc | Sets one benefit increase.
setData | Sets benefit increases for one alternative.
setData | Sets the benefit increases for one alternative.
setFirstYear | Sets first year of data.
setTitle | Sets the title for one alternative.
setTitle | Sets the title for one alternative.
write | Saves projected benefit increases.
Collapse Expand Links
BiprojFile Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


BiprojFile::BiprojFile Constructor

BiprojFile::BiprojFile Constructor
BiprojFile Class BiprojFile Members BiprojFile Class

Initializes projected benefit increase info.

C++
BiprojFile(
    int newIstart,
    int newMaxyear,
    const std::string& newDirectory
);
Collapse Expand Parameters
Parameters | Description
int newIstart | Starting year of benefit increases.
int newMaxyear | Maximum projected year.
const std::string& newDirectory | Directory with benefit increase file.
Collapse Expand Class

BiprojFile Class

Collapse Expand Links
BiprojFile Class, BiprojFile Members, BiprojFile Class


BiprojFile Methods

BiprojFile Methods
BiprojFile Class Legend Protected Methods Public Methods

The methods of the BiprojFile class are listed here.

Collapse Expand Class

BiprojFile Class

Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
setBiFile | Forms a file name for projected benefit increase file.
Collapse Expand Public Methods
Name | Description
read | Reads projected benefit increases.
setData | Sets the benefit increases for one alternative.
setTitle | Sets the title for one alternative.
write | Saves projected benefit increases.
Collapse Expand Links
BiprojFile Class, Legend, Protected Methods, Public Methods


BiprojFile::read Method

BiprojFile::read Method
BiprojFile Class BiprojFile Members BiprojFile Methods

Reads projected benefit increases.

C++
void read(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-4).
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_CPIINC4 if unable to open input file. PiaException of type PIA_IDS_CPIINC3 if unable to read all required data.
Collapse Expand Group

BiprojFile Methods

Collapse Expand Links
BiprojFile Class, BiprojFile Members, BiprojFile Methods


BiprojFile::setBiFile Method

BiprojFile::setBiFile Method
BiprojFile Class BiprojFile Members BiprojFile Methods

Forms a file name for projected benefit increase file.

C++
void setBiFile(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-4).
Collapse Expand Group

BiprojFile Methods

Collapse Expand Links
BiprojFile Class, BiprojFile Members, BiprojFile Methods


setData Method

setData Method
BiprojFile Methods

Sets the benefit increases for one alternative.

Collapse Expand Description

There are two versions of the setData method; however, both are dummy (unused) functions.

Collapse Expand Overload List
Name | Description
BiprojFile::setData (int) | Dummy function.
BiprojFile::setData (int, const DoubleAnnual&) | Dummy function.
Collapse Expand Group

BiprojFile Methods

Collapse Expand Links
BiprojFile Methods


BiprojFile::setData Method (int)

BiprojFile::setData Method (int)
BiprojFile Class BiprojFile Members setData Method

Dummy function.

C++
void setData(
    int
);
Collapse Expand Group

setData Method

Collapse Expand Links
BiprojFile Class, BiprojFile Members, setData Method


BiprojFile::setData Method (int, const DoubleAnnual&)

BiprojFile::setData Method (int, const DoubleAnnual&)
BiprojFile Class BiprojFile Members setData Method

Dummy function.

C++
void setData(
    int,
    const DoubleAnnual&
);
Collapse Expand Group

setData Method

Collapse Expand Links
BiprojFile Class, BiprojFile Members, setData Method


setTitle Method

setTitle Method
BiprojFile Methods

Sets the title for one alternative.

Collapse Expand Description

There are two versions of the setTitle method. However, the second argument in one version (providing a new title) is ignored, so that both functions do the same thing.

Collapse Expand Overload List
Name | Description
BiprojFile::setTitle (int) | Sets title of assumptions if not gotten from disk.
BiprojFile::setTitle (int, const std::string&) | Sets title of assumptions as gotten from disk.
Collapse Expand Group

BiprojFile Methods

Collapse Expand Links
BiprojFile Methods


BiprojFile::setTitle Method (int)

BiprojFile::setTitle Method (int)
BiprojFile Class BiprojFile Members setTitle Method

Sets title of assumptions if not gotten from disk.

C++
void setTitle(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Which set of assumptions.
Collapse Expand Group

setTitle Method

Collapse Expand Links
BiprojFile Class, BiprojFile Members, setTitle Method


BiprojFile::setTitle Method (int, const std::string&)

BiprojFile::setTitle Method (int, const std::string&)
BiprojFile Class BiprojFile Members setTitle Method

Sets title of assumptions as gotten from disk.

C++
void setTitle(
    int altNum,
    const std::string&
);
Collapse Expand Parameters
Parameters | Description
int altNum | Which set of assumptions.
Collapse Expand Group

setTitle Method

Collapse Expand Links
BiprojFile Class, BiprojFile Members, setTitle Method


BiprojFile::write Method

BiprojFile::write Method
BiprojFile Class BiprojFile Members BiprojFile Methods

Saves projected benefit increases.

C++
void write(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-4).
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_CPIINC2 if unable to open output file.
Collapse Expand Group

BiprojFile Methods

Collapse Expand Links
BiprojFile Class, BiprojFile Members, BiprojFile Methods


BiprojNonFile Class

BiprojNonFile Class
BiprojNonFile Enumerations BiprojNonFile Methods BiprojNonFile Members BiprojNonFile.h Classes

Manages the file of projected benefit increases stored in arrays.

Collapse Expand Class Hierarchy
  BiprojNonFileBiprojNonFile
C++
class BiprojNonFile : public Biproj;
Collapse Expand File

File: BiprojNonFile.h

Module: PiaData Library

Collapse Expand Remarks

See BiprojFile for a version of this class that stores the benefit increases on disk.

Collapse Expand See Also

BiprojFile

Collapse Expand Group

Classes

Collapse Expand Links
BiprojNonFile Enumerations, BiprojNonFile Methods, BiprojNonFile Members, BiprojNonFile.h, Classes


BiprojNonFile Members

BiprojNonFile Members
Enumerations BiprojNonFile Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by BiprojNonFile.

Collapse Expand Enumerations
Name | Description
DimLimits | Dimension limits.
Collapse Expand Class

BiprojNonFile Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
beninc | Titles of projected benefit increase assumptions, other than the four TR assumptions.
biprojTitle | Title of projected benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
theData | Array of projected benefit increases.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
BiprojNonFile | Initializes projected benefit increase info for latest Trustees Report.
cpiincCheck | Checks a benefit increase.
getFirstYear | Returns first year of data.
getTitle | Returns title of assumptions.
read | Restore values to original values.
setCpiinc | Sets one benefit increase.
setData | Sets benefit increases for one alternative.
setData | Sets the benefit increases for one alternative.
setFirstYear | Sets first year of data.
setTitle | Sets the title for one alternative.
setTitle | Sets the title for one alternative.
write | Dummy function.
~BiprojNonFile | Destructor.
Collapse Expand Links
Enumerations, BiprojNonFile Class, Legend, Protected Data Members, Public Data Members, Public Methods


BiprojNonFile::BiprojNonFile Constructor

BiprojNonFile::BiprojNonFile Constructor
BiprojNonFile Class BiprojNonFile Members BiprojNonFile Class

Initializes projected benefit increase info for latest Trustees Report.

C++
BiprojNonFile(
    int newIstart,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
int newIstart | Starting year of benefit increases.
int newMaxyear | Maximum projected year.
Collapse Expand Remarks

Creates the arrays of Trustees Report benefit increases.

Collapse Expand Class

BiprojNonFile Class

Collapse Expand Links
BiprojNonFile Class, BiprojNonFile Members, BiprojNonFile Class


BiprojNonFile::~BiprojNonFile Destructor

BiprojNonFile::~BiprojNonFile Destructor
BiprojNonFile Class BiprojNonFile Members BiprojNonFile Class

Destructor.

C++
~BiprojNonFile();
Collapse Expand Remarks

Deletes the arrays of Trustees Report benefit increases.

Collapse Expand Class

BiprojNonFile Class

Collapse Expand Links
BiprojNonFile Class, BiprojNonFile Members, BiprojNonFile Class


BiprojNonFile Enumerations

BiprojNonFile Enumerations
Enumerations BiprojNonFile Class Legend

The enumerations of the BiprojNonFile class are listed here.

Collapse Expand Enumerations
Name | Description
DimLimits | Dimension limits.
Collapse Expand Class

BiprojNonFile Class

Collapse Expand Links
Enumerations, BiprojNonFile Class, Legend


BiprojNonFile::DimLimits Enumeration

BiprojNonFile::DimLimits Enumeration
BiprojNonFile.h BiprojNonFile Enumerations

Dimension limits.

C++
enum DimLimits {
  NUMASSUMSETS = 4,
  NUMPROJYEARS = 15
};
Collapse Expand File

File: BiprojNonFile.h

Module: PiaData Library

Collapse Expand Members
Members | Description
NUMASSUMSETS = 4 | Number of sets of assumptions (4, for 1, 2, 3, and 2b).
NUMPROJYEARS = 15 | Number of annual benefit increases. This should not normally be changed because it is the number of blanks on a form in the detailed calculator.
Collapse Expand Group

BiprojNonFile Enumerations

Collapse Expand Links
BiprojNonFile.h, BiprojNonFile Enumerations


BiprojNonFile Methods

BiprojNonFile Methods
BiprojNonFile Class Legend Public Methods

The methods of the BiprojNonFile class are listed here.

Collapse Expand Class

BiprojNonFile Class

Collapse Expand Public Methods
Name | Description
read | Restore values to original values.
setData | Sets the benefit increases for one alternative.
setTitle | Sets the title for one alternative.
write | Dummy function.
Collapse Expand Links
BiprojNonFile Class, Legend, Public Methods


BiprojNonFile::read Method

BiprojNonFile::read Method
BiprojNonFile Class BiprojNonFile Members BiprojNonFile Methods

Restore values to original values.

C++
void read(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-4).
Collapse Expand Group

BiprojNonFile Methods

Collapse Expand Links
BiprojNonFile Class, BiprojNonFile Members, BiprojNonFile Methods


setData Method

setData Method
BiprojNonFile Methods

Sets the benefit increases for one alternative.

Collapse Expand Description

There are two versions of the setData method. The data to be used can be passed as an argument; if it is not, the stored data is used.

Collapse Expand Overload List
Name | Description
BiprojNonFile::setData (int) | Sets data for one alternative.
BiprojNonFile::setData (int, const DoubleAnnual&) | Sets data for one alternative.
Collapse Expand Group

BiprojNonFile Methods

Collapse Expand Links
BiprojNonFile Methods


BiprojNonFile::setData Method (int)

BiprojNonFile::setData Method (int)
BiprojNonFile Class BiprojNonFile Members setData Method

Sets data for one alternative.

C++
void setData(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-7).
Collapse Expand Remarks

This version has one argument uses the data stored for the specified alternative.

Collapse Expand Group

setData Method

Collapse Expand Links
BiprojNonFile Class, BiprojNonFile Members, setData Method


BiprojNonFile::setData Method (int, const DoubleAnnual&)

BiprojNonFile::setData Method (int, const DoubleAnnual&)
BiprojNonFile Class BiprojNonFile Members setData Method

Sets data for one alternative.

C++
void setData(
    int altNum,
    const DoubleAnnual& newData
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-7).
const DoubleAnnual& newData | Data to use.
Collapse Expand Remarks

This version has two arguments stores the data for the specified alternative, then sets the current data to that data.

Collapse Expand Group

setData Method

Collapse Expand Links
BiprojNonFile Class, BiprojNonFile Members, setData Method


setTitle Method

setTitle Method
BiprojNonFile Methods

Sets the title for one alternative.

Collapse Expand Description

There are two versions of the setTitle method. The title to be used can be passed as an argument; if it is not, the stored title is used.

Collapse Expand Overload List
Name | Description
BiprojNonFile::setTitle (int) | Sets the current title.
BiprojNonFile::setTitle (int, const std::string&) | Sets the current title.
Collapse Expand Group

BiprojNonFile Methods

Collapse Expand Links
BiprojNonFile Methods


BiprojNonFile::setTitle Method (int)

BiprojNonFile::setTitle Method (int)
BiprojNonFile Class BiprojNonFile Members setTitle Method

Sets the current title.

C++
void setTitle(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-7).
Collapse Expand Remarks

This version has one argument uses the title stored for the specified alternative.

Collapse Expand Group

setTitle Method

Collapse Expand Links
BiprojNonFile Class, BiprojNonFile Members, setTitle Method


BiprojNonFile::setTitle Method (int, const std::string&)

BiprojNonFile::setTitle Method (int, const std::string&)
BiprojNonFile Class BiprojNonFile Members setTitle Method

Sets the current title.

C++
void setTitle(
    int altNum,
    const std::string& newTitle
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-7).
const std::string& newTitle | Title to use.
Collapse Expand Remarks

This version has two arguments stores the title for the specified alternative, then sets the current title to that title.

Collapse Expand Group

setTitle Method

Collapse Expand Links
BiprojNonFile Class, BiprojNonFile Members, setTitle Method


BiprojNonFile::write Method

BiprojNonFile::write Method
BiprojNonFile Class BiprojNonFile Members BiprojNonFile Methods

Dummy function.

C++
void write(
    int
);
Collapse Expand Group

BiprojNonFile Methods

Collapse Expand Links
BiprojNonFile Class, BiprojNonFile Members, BiprojNonFile Methods


BpMfbOut Class

BpMfbOut Class
BpMfbOut Constructor BpMfbOut Methods BpMfbOut Members bpmfbout.h Classes

Manages the array of mfb formula bend points.

Collapse Expand Class Hierarchy
  BpMfbOut
C++
class BpMfbOut;
Collapse Expand File

File: bpmfbout.h

Module: PiaData Library

Collapse Expand Remarks

This class is used to store all the bend points for all years, so they do not have to be recalculated for every benefit calculation.

Collapse Expand Group

Classes

Collapse Expand Links
BpMfbOut Constructor, BpMfbOut Methods, BpMfbOut Members, bpmfbout.h, Classes


BpMfbOut Members

BpMfbOut Members
BpMfbOut Class Legend Public Methods

The following tables list the members exposed by BpMfbOut.

Collapse Expand Class

BpMfbOut Class

Collapse Expand Public Methods
Name | Description
BpMfbOut | Initializes a BpMfbOut, with or without a specified first year.
getBpmfb1 | Returns first bend point for specified year.
getBpmfb2 | Returns second bend point for specified year.
getBpmfb3 | Returns third bend point for specified year.
setData | Sets data for one or all years.
Collapse Expand Links
BpMfbOut Class, Legend, Public Methods


BpMfbOut Constructor

BpMfbOut Constructor
BpMfbOut Class

Initializes a BpMfbOut, with or without a specified first year.

Collapse Expand Description

There are two versions of the BpMfbOut constructor. They both specify the last year of projection; if the first year is not specified, it is set to 1937.

Collapse Expand Overload List
Name | Description
BpMfbOut::BpMfbOut (int) | Initializes arrays with a starting year of 1979.
BpMfbOut::BpMfbOut (int, int) | Initializes arrays with a specified starting year.
Collapse Expand Class

BpMfbOut Class

Collapse Expand Links
BpMfbOut Class


BpMfbOut::BpMfbOut Constructor (int)

BpMfbOut::BpMfbOut Constructor (int)
BpMfbOut Class BpMfbOut Members BpMfbOut Constructor

Initializes arrays with a starting year of 1979.

C++
BpMfbOut(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Maximum year of projection.
Collapse Expand Group

BpMfbOut Constructor

Collapse Expand Links
BpMfbOut Class, BpMfbOut Members, BpMfbOut Constructor


BpMfbOut::BpMfbOut Constructor (int, int)

BpMfbOut::BpMfbOut Constructor (int, int)
BpMfbOut Class BpMfbOut Members BpMfbOut Constructor

Initializes arrays with a specified starting year.

C++
BpMfbOut(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | Starting year of array.
int newLastYear | Maximum year of projection.
Collapse Expand Group

BpMfbOut Constructor

Collapse Expand Links
BpMfbOut Class, BpMfbOut Members, BpMfbOut Constructor


BpMfbOut Methods

BpMfbOut Methods
BpMfbOut Class Legend Public Methods

The methods of the BpMfbOut class are listed here.

Collapse Expand Class

BpMfbOut Class

Collapse Expand Public Methods
Name | Description
getBpmfb1 | Returns first bend point for specified year.
getBpmfb2 | Returns second bend point for specified year.
getBpmfb3 | Returns third bend point for specified year.
setData | Sets data for one or all years.
Collapse Expand Links
BpMfbOut Class, Legend, Public Methods


BpMfbOut::getBpmfb1 Method

BpMfbOut::getBpmfb1 Method
BpMfbOut Class BpMfbOut Members BpMfbOut Methods

Returns first bend point for specified year.

C++
double getBpmfb1(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which first bend point is desired.
Collapse Expand Returns

First bend point for specified year.

Collapse Expand Group

BpMfbOut Methods

Collapse Expand Links
BpMfbOut Class, BpMfbOut Members, BpMfbOut Methods


BpMfbOut::getBpmfb2 Method

BpMfbOut::getBpmfb2 Method
BpMfbOut Class BpMfbOut Members BpMfbOut Methods

Returns second bend point for specified year.

C++
double getBpmfb2(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which second bend point is desired.
Collapse Expand Returns

Second bend point for specified year.

Collapse Expand Group

BpMfbOut Methods

Collapse Expand Links
BpMfbOut Class, BpMfbOut Members, BpMfbOut Methods


BpMfbOut::getBpmfb3 Method

BpMfbOut::getBpmfb3 Method
BpMfbOut Class BpMfbOut Members BpMfbOut Methods

Returns third bend point for specified year.

C++
double getBpmfb3(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which third bend point is desired.
Collapse Expand Returns

Third bend point for specified year.

Collapse Expand Group

BpMfbOut Methods

Collapse Expand Links
BpMfbOut Class, BpMfbOut Members, BpMfbOut Methods


setData Method

setData Method
BpMfbOut Methods

Sets data for one or all years.

Collapse Expand Description

There are two versions of the setData function. Values can be set for one year or a range of years. If values are set for a range of years, an average wage series is provided to perform the projection.

Collapse Expand Overload List
Name | Description
BpMfbOut::setData (const AverageWage&, int) | Sets data for all years beginning with the firstYear argument, using the specified average wages for projection.
BpMfbOut::setData (int, double, double, double) | Sets data for one year using three specified bend point values.
Collapse Expand Group

BpMfbOut Methods

Collapse Expand Links
BpMfbOut Methods


BpMfbOut::setData Method (const AverageWage&, int)

BpMfbOut::setData Method (const AverageWage&, int)
BpMfbOut Class BpMfbOut Members setData Method

Sets data for all years beginning with the firstYear argument, using the specified average wages for projection.

C++
void setData(
    const AverageWage& averageWage,
    int firstYear = 1979
);
Collapse Expand Parameters
Parameters | Description
const AverageWage& averageWage | Average wage series used to project bend points, starting in specified year.
int firstYear = 1979 | Starting year of projection.
Collapse Expand Group

setData Method

Collapse Expand Links
BpMfbOut Class, BpMfbOut Members, setData Method


BpMfbOut::setData Method (int, double, double, double)

BpMfbOut::setData Method (int, double, double, double)
BpMfbOut Class BpMfbOut Members setData Method

Sets data for one year using three specified bend point values.

C++
void setData(
    int year,
    double bp1,
    double bp2,
    double bp3
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which data is set.
double bp1 | Value of first bend point.
double bp2 | Value of second bend point.
double bp3 | Value of third bend point.
Collapse Expand Group

setData Method

Collapse Expand Links
BpMfbOut Class, BpMfbOut Members, setData Method


BpPiaOut Class

BpPiaOut Class
BpPiaOut Constructor BpPiaOut Methods BpPiaOut Members bppiaout.h Classes

Manages the array of pia formula bend points.

Collapse Expand Class Hierarchy
  BpPiaOut
C++
class BpPiaOut;
Collapse Expand File

File: bppiaout.h

Module: PiaData Library

Collapse Expand Remarks

This class is used to store all the bend points for all years, so they do not have to be recalculated for every benefit calculation.

Collapse Expand Group

Classes

Collapse Expand Links
BpPiaOut Constructor, BpPiaOut Methods, BpPiaOut Members, bppiaout.h, Classes


BpPiaOut Members

BpPiaOut Members
BpPiaOut Class Legend Public Methods

The following tables list the members exposed by BpPiaOut.

Collapse Expand Class

BpPiaOut Class

Collapse Expand Public Methods
Name | Description
BpPiaOut | Initializes a BpPiaOut with or without a first year.
getBppia | Returns bend point for specified year.
getNumBend | Returns number of bend points.
set1979Data | Sets data for all years based on the wage-indexed 1979 formula starting in the year of the firstYear argument, using the specified average wages for projection.
setIndexedData | Sets data for all years beginning with the firstYear argument, based on the bendpoints specified in the baseYear argument, and using the specified average wages for projection.
setSingleYearData | Sets data for one year using specified bendpoint values.
Collapse Expand Links
BpPiaOut Class, Legend, Public Methods


BpPiaOut Constructor

BpPiaOut Constructor
BpPiaOut Class

Initializes a BpPiaOut with or without a first year.

Collapse Expand Description

There are two versions of the BpPiaOut constructor. They both specify the last year of projection; if the first year is not specified, it is set to 1937.

Collapse Expand Overload List
Name | Description
BpPiaOut::BpPiaOut (int) | Initializes arrays with a starting year of 1979.
BpPiaOut::BpPiaOut (int, int) | Initializes arrays with a specified starting year.
Collapse Expand Class

BpPiaOut Class

Collapse Expand Links
BpPiaOut Class


BpPiaOut::BpPiaOut Constructor (int)

BpPiaOut::BpPiaOut Constructor (int)
BpPiaOut Class BpPiaOut Members BpPiaOut Constructor

Initializes arrays with a starting year of 1979.

C++
BpPiaOut(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Maximum year of projection.
Collapse Expand Group

BpPiaOut Constructor

Collapse Expand Links
BpPiaOut Class, BpPiaOut Members, BpPiaOut Constructor


BpPiaOut::BpPiaOut Constructor (int, int)

BpPiaOut::BpPiaOut Constructor (int, int)
BpPiaOut Class BpPiaOut Members BpPiaOut Constructor

Initializes arrays with a specified starting year.

C++
BpPiaOut(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | Starting year of array.
int newLastYear | Maximum year of projection.
Collapse Expand Group

BpPiaOut Constructor

Collapse Expand Links
BpPiaOut Class, BpPiaOut Members, BpPiaOut Constructor


BpPiaOut Methods

BpPiaOut Methods
BpPiaOut Class Legend Public Methods

The methods of the BpPiaOut class are listed here.

Collapse Expand Class

BpPiaOut Class

Collapse Expand Public Methods
Name | Description
getBppia | Returns bend point for specified year.
getNumBend | Returns number of bend points.
set1979Data | Sets data for all years based on the wage-indexed 1979 formula starting in the year of the firstYear argument, using the specified average wages for projection.
setIndexedData | Sets data for all years beginning with the firstYear argument, based on the bendpoints specified in the baseYear argument, and using the specified average wages for projection.
setSingleYearData | Sets data for one year using specified bendpoint values.
Collapse Expand Links
BpPiaOut Class, Legend, Public Methods


BpPiaOut::getBppia Method

BpPiaOut::getBppia Method
BpPiaOut Class BpPiaOut Members BpPiaOut Methods

Returns bend point for specified year.

C++
double getBppia(
    int year,
    int index
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which bend point is desired.
int index | Index of bend point desired.
Collapse Expand Returns

Bend point number index for specified year.

Collapse Expand Group

BpPiaOut Methods

Collapse Expand Links
BpPiaOut Class, BpPiaOut Members, BpPiaOut Methods


BpPiaOut::getNumBend Method

BpPiaOut::getNumBend Method
BpPiaOut Class BpPiaOut Members BpPiaOut Methods

Returns number of bend points.

C++
int getNumBend(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of bendpoint formula.
Collapse Expand Returns

Number of bend points.

Collapse Expand Group

BpPiaOut Methods

Collapse Expand Links
BpPiaOut Class, BpPiaOut Members, BpPiaOut Methods


BpPiaOut::set1979Data Method

BpPiaOut::set1979Data Method
BpPiaOut Class BpPiaOut Members BpPiaOut Methods

Sets data for all years based on the wage-indexed 1979 formula starting in the year of the firstYear argument, using the specified average wages for projection.

C++
void set1979Data(
    const AverageWage& averageWage,
    int firstYear = 1979
);
Collapse Expand Parameters
Parameters | Description
const AverageWage& averageWage | The average wage series.
int firstYear = 1979 | The first year to project.
Collapse Expand Group

BpPiaOut Methods

Collapse Expand Links
BpPiaOut Class, BpPiaOut Members, BpPiaOut Methods


BpPiaOut::setIndexedData Method

BpPiaOut::setIndexedData Method
BpPiaOut Class BpPiaOut Members BpPiaOut Methods

Sets data for all years beginning with the firstYear argument, based on the bendpoints specified in the baseYear argument, and using the specified average wages for projection.

C++
void setIndexedData(
    const AverageWage& averageWage,
    int firstYear,
    int baseYear,
    int numBp = 2
);
Collapse Expand Parameters
Parameters | Description
const AverageWage& averageWage | The average wage series.
int firstYear | The first year to project.
int baseYear | The year of bend points to project from.
int numBp = 2 | The number of bend points in the formula.
Collapse Expand Group

BpPiaOut Methods

Collapse Expand Links
BpPiaOut Class, BpPiaOut Members, BpPiaOut Methods


BpPiaOut::setSingleYearData Method

BpPiaOut::setSingleYearData Method
BpPiaOut Class BpPiaOut Members BpPiaOut Methods

Sets data for one year using specified bendpoint values.

C++
void setSingleYearData(
    int year,
    int numBp,
    double bp[]
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which data is set.
int numBp | Number of bendpoints in the formula.
double bp[] | Array of values of bendpoints.
Collapse Expand Group

BpPiaOut Methods

Collapse Expand Links
BpPiaOut Class, BpPiaOut Members, BpPiaOut Methods


Catchup Class

Catchup Class
Catchup Constructor Catchup Data Members Catchup Methods Catchup Members cachup.h Classes

Manages the catch-up benefit increases required to calculate a Social Security benefit.

Collapse Expand Class Hierarchy
  Catchup
C++
class Catchup;
Collapse Expand File

File: cachup.h

Module: PiaData Library

Collapse Expand Remarks

There have not been any catch-up benefit increases to date; any catch-up increases used would be projected ones.

Collapse Expand Group

Classes

Collapse Expand Links
Catchup Constructor, Catchup Data Members, Catchup Methods, Catchup Members, cachup.h, Classes


Catchup Members

Catchup Members
Catchup Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by Catchup.

Collapse Expand Class

Catchup Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
catchup | Catch-up benefit increases for 10 years of eligibility.
Collapse Expand Public Data Members
Name | Description
NUM_CATCHUP_ELIG_YEARS | The number of years of eligibility considered (10).
Collapse Expand Public Methods
Name | Description
Catchup | Initializes a Catchup, with or without a specified starting year.
check | Checks a catch-up benefit increase.
deleteContents | Zeroes out catch-up benefit increases.
exist | Checks for existence of catch-up benefit increase.
get | Returns one catch-up increase.
getCatchupIncreases | Returns a CatchupIncreases array.
getCstart | Gets first year of catch-up increases.
parseString | Parses all catch-up increases for one year of eligibility from a string.
set | Sets one catch-up increase.
setCstart | Sets first year of catch-up increases.
~Catchup | Destroys catch-up benefit increases.
Collapse Expand Links
Catchup Class, Legend, Protected Data Members, Public Data Members, Public Methods


Catchup Constructor

Catchup Constructor
Catchup Class

Initializes a Catchup, with or without a specified starting year.

Collapse Expand Description

There are two versions of the Catchup constructor. If there is no argument, the starting year of catch-up benefit increases is made equal to zero; otherwise, it is made equal to the specified value.

Collapse Expand Overload List
Name | Description
Catchup::Catchup () | Initializes catch-up benefit increase data with starting year 0.
Catchup::Catchup (int) | Initializes catch-up benefit increase data with specified starting year.
Collapse Expand Class

Catchup Class

Collapse Expand Links
Catchup Class


Catchup::Catchup Constructor ()

Catchup::Catchup Constructor ()
Catchup Class Catchup Members Catchup Constructor

Initializes catch-up benefit increase data with starting year 0.

C++
Catchup();
Collapse Expand Group

Catchup Constructor

Collapse Expand Links
Catchup Class, Catchup Members, Catchup Constructor


Catchup::Catchup Constructor (int)

Catchup::Catchup Constructor (int)
Catchup Class Catchup Members Catchup Constructor

Initializes catch-up benefit increase data with specified starting year.

C++
explicit Catchup(
    int newCstart
);
Collapse Expand Parameters
Parameters | Description
int newCstart | Starting year of catch-up benefit increases.
Collapse Expand Group

Catchup Constructor

Collapse Expand Links
Catchup Class, Catchup Members, Catchup Constructor


Catchup::~Catchup Destructor

Catchup::~Catchup Destructor
Catchup Class Catchup Members Catchup Class

Destroys catch-up benefit increases.

C++
~Catchup();
Collapse Expand Class

Catchup Class

Collapse Expand Links
Catchup Class, Catchup Members, Catchup Class


Catchup Data Members

Catchup Data Members
Catchup Class Legend Protected Data Members Public Data Members

The data members of the Catchup class are listed here.

Collapse Expand Class

Catchup Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
catchup | Catch-up benefit increases for 10 years of eligibility.
Collapse Expand Public Data Members
Name | Description
NUM_CATCHUP_ELIG_YEARS | The number of years of eligibility considered (10).
Collapse Expand Links
Catchup Class, Legend, Protected Data Members, Public Data Members


Catchup::NUM_CATCHUP_ELIG_YEARS Data Member

Catchup::NUM_CATCHUP_ELIG_YEARS Data Member
Catchup Class Catchup Members Catchup Data Members

The number of years of eligibility considered (10).

C++
const int NUM_CATCHUP_ELIG_YEARS = 10;
Collapse Expand Group

Catchup Data Members

Collapse Expand Links
Catchup Class, Catchup Members, Catchup Data Members


Catchup::catchup Data Member

Catchup::catchup Data Member
Catchup Class Catchup Members Catchup Data Members

Catch-up benefit increases for 10 years of eligibility.

C++
CatchupIncreases catchup[NUM_CATCHUP_ELIG_YEARS];
Collapse Expand Remarks

Array index is year of eligibility, measured from the starting year (0 to 9). For a given array index, calendar year of increase in catchup goes from the starting year plus 2 to the starting year plus 9.

Collapse Expand Group

Catchup Data Members

Collapse Expand Links
Catchup Class, Catchup Members, Catchup Data Members


Catchup Methods

Catchup Methods
Catchup Class Legend Public Methods

The methods of the Catchup class are listed here.

Collapse Expand Class

Catchup Class

Collapse Expand Public Methods
Name | Description
check | Checks a catch-up benefit increase.
deleteContents | Zeroes out catch-up benefit increases.
exist | Checks for existence of catch-up benefit increase.
get | Returns one catch-up increase.
getCatchupIncreases | Returns a CatchupIncreases array.
getCstart | Gets first year of catch-up increases.
parseString | Parses all catch-up increases for one year of eligibility from a string.
set | Sets one catch-up increase.
setCstart | Sets first year of catch-up increases.
Collapse Expand Links
Catchup Class, Legend, Public Methods


Catchup::check Method

Catchup::check Method
Catchup Class Catchup Members Catchup Methods

Checks a catch-up benefit increase.

C++
static void check(
    double newCatchup
);
Collapse Expand Parameters
Parameters | Description
double newCatchup | Value to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_CACHUP1 if catch-up benefit increase is out of range.
Collapse Expand Group

Catchup Methods

Collapse Expand Links
Catchup Class, Catchup Members, Catchup Methods


Catchup::deleteContents Method

Catchup::deleteContents Method
Catchup Class Catchup Members Catchup Methods

Zeroes out catch-up benefit increases.

C++
void deleteContents();
Collapse Expand Group

Catchup Methods

Collapse Expand Links
Catchup Class, Catchup Members, Catchup Methods


Catchup::exist Method

Catchup::exist Method
Catchup Class Catchup Members Catchup Methods

Checks for existence of catch-up benefit increase.

C++
bool exist(
    int eligYear,
    int calYear
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility for catch-up benefit increases.
int calYear | Calendar year of catch-up benefit increase.
Collapse Expand Returns

False if there is no catch-up increase, true otherwise.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_CACHUP4 if either argument year is out of range (only in debug mode).
Collapse Expand Group

Catchup Methods

Collapse Expand Links
Catchup Class, Catchup Members, Catchup Methods


Catchup::get Method

Catchup::get Method
Catchup Class Catchup Members Catchup Methods

Returns one catch-up increase.

C++
double get(
    int eligYear,
    int calYear
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
int calYear | Calendary year of increase.
Collapse Expand Returns

One catch-up increase.

Collapse Expand Group

Catchup Methods

Collapse Expand Links
Catchup Class, Catchup Members, Catchup Methods


Catchup::getCatchupIncreases Method

Catchup::getCatchupIncreases Method
Catchup Class Catchup Members Catchup Methods

Returns a CatchupIncreases array.

C++
const CatchupIncreases& getCatchupIncreases(
    int index
) const;
Collapse Expand Parameters
Parameters | Description
int index | Index of desired array (0-9).
Collapse Expand Returns

A CatchupIncreases array.

Collapse Expand Group

Catchup Methods

Collapse Expand Links
Catchup Class, Catchup Members, Catchup Methods


Catchup::getCstart Method

Catchup::getCstart Method
Catchup Class Catchup Members Catchup Methods

Gets first year of catch-up increases.

C++
int getCstart() const;
Collapse Expand Returns

First year of catch-up increases.

Collapse Expand Group

Catchup Methods

Collapse Expand Links
Catchup Class, Catchup Members, Catchup Methods


Catchup::parseString Method

Catchup::parseString Method
Catchup Class Catchup Members Catchup Methods

Parses all catch-up increases for one year of eligibility from a string.

C++
void parseString(
    int index,
    std::string inputLine
);
Collapse Expand Parameters
Parameters | Description
int index | Index of year of eligibility to parse (0-9).
std::string inputLine | Line to parse.
Collapse Expand Group

Catchup Methods

Collapse Expand Links
Catchup Class, Catchup Members, Catchup Methods


Catchup::set Method

Catchup::set Method
Catchup Class Catchup Members Catchup Methods

Sets one catch-up increase.

C++
void set(
    int eligYear,
    int calYear,
    double newCatchup
);
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
int calYear | Calendar year of increase.
double newCatchup | New value for catch-up increase.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_CACHUP4 if either argument year is out of range (only in debug mode).
Collapse Expand Group

Catchup Methods

Collapse Expand Links
Catchup Class, Catchup Members, Catchup Methods


Catchup::setCstart Method

Catchup::setCstart Method
Catchup Class Catchup Members Catchup Methods

Sets first year of catch-up increases.

C++
void setCstart(
    int newCstart
);
Collapse Expand Parameters
Parameters | Description
int newCstart | New first year of catch-up increases.
Collapse Expand Group

Catchup Methods

Collapse Expand Links
Catchup Class, Catchup Members, Catchup Methods


CatchupDoc Class

CatchupDoc Class
CatchupDoc Constructor CatchupDoc Data Members CatchupDoc Methods CatchupDoc Members cachupf.h Classes

Abstract parent of classes that manage a file of catch-up benefit increases.

Collapse Expand Class Hierarchy
  CatchupDoc
C++
class CatchupDoc;
Collapse Expand File

File: cachupf.h

Module: PiaData Library

Collapse Expand Remarks

To implement this class, use CatchupFile or CatchupNonFile.

Collapse Expand See Also

CatchupFile, CatchupNonFile

Collapse Expand Group

Classes

Collapse Expand Links
CatchupDoc Constructor, CatchupDoc Data Members, CatchupDoc Methods, CatchupDoc Members, cachupf.h, Classes


CatchupDoc Members

CatchupDoc Members
CatchupDoc Class Legend Public Data Members Public Methods

The following tables list the members exposed by CatchupDoc.

Collapse Expand Class

CatchupDoc Class

Collapse Expand Public Data Members
Name | Description
allownonzero | True to allow nonzero catch-up increases.
catchup | Catch-up benefit increases.
Collapse Expand Public Methods
Name | Description
CatchupDoc | Initializes a CatchupDoc, with or without a specified starting year.
exist | Checks for existence of catch-up increase.
get | Returns one catch-up increase.
read | Reads catch-up increases.
setData | Sets catch-up increases for one alternative.
write | Writes catch-up increases.
~CatchupDoc | Destroys catch-up benefit increase file.
Collapse Expand Links
CatchupDoc Class, Legend, Public Data Members, Public Methods


CatchupDoc Constructor

CatchupDoc Constructor
CatchupDoc Class

Initializes a CatchupDoc, with or without a specified starting year.

Collapse Expand Description

There are two versions of the CatchupDoc constructor. If the starting year is not specified, it is set to zero.

Collapse Expand Overload List
Name | Description
CatchupDoc::CatchupDoc () | Initializes catch-up benefit increase file with starting year 0.
CatchupDoc::CatchupDoc (int) | Initializes catch-up benefit increase file with specified starting year.
Collapse Expand Class

CatchupDoc Class

Collapse Expand Links
CatchupDoc Class


CatchupDoc::CatchupDoc Constructor ()

CatchupDoc::CatchupDoc Constructor ()
CatchupDoc Class CatchupDoc Members CatchupDoc Constructor

Initializes catch-up benefit increase file with starting year 0.

C++
CatchupDoc();
Collapse Expand Group

CatchupDoc Constructor

Collapse Expand Links
CatchupDoc Class, CatchupDoc Members, CatchupDoc Constructor


CatchupDoc::CatchupDoc Constructor (int)

CatchupDoc::CatchupDoc Constructor (int)
CatchupDoc Class CatchupDoc Members CatchupDoc Constructor

Initializes catch-up benefit increase file with specified starting year.

C++
explicit CatchupDoc(
    int newCstart
);
Collapse Expand Parameters
Parameters | Description
int newCstart | Starting year of catch-up benefit increases.
Collapse Expand Group

CatchupDoc Constructor

Collapse Expand Links
CatchupDoc Class, CatchupDoc Members, CatchupDoc Constructor


CatchupDoc::~CatchupDoc Destructor

CatchupDoc::~CatchupDoc Destructor
CatchupDoc Class CatchupDoc Members CatchupDoc Class

Destroys catch-up benefit increase file.

C++
virtual ~CatchupDoc();
Collapse Expand Class

CatchupDoc Class

Collapse Expand Links
CatchupDoc Class, CatchupDoc Members, CatchupDoc Class


CatchupDoc Data Members

CatchupDoc Data Members
CatchupDoc Class Legend Public Data Members

The data members of the CatchupDoc class are listed here.

Collapse Expand Class

CatchupDoc Class

Collapse Expand Public Data Members
Name | Description
allownonzero | True to allow nonzero catch-up increases.
catchup | Catch-up benefit increases.
Collapse Expand Links
CatchupDoc Class, Legend, Public Data Members


CatchupDoc::allownonzero Data Member

CatchupDoc::allownonzero Data Member
CatchupDoc Class CatchupDoc Members CatchupDoc Data Members

True to allow nonzero catch-up increases.

C++
bool allownonzero[4];
Collapse Expand Group

CatchupDoc Data Members

Collapse Expand Links
CatchupDoc Class, CatchupDoc Members, CatchupDoc Data Members


CatchupDoc::catchup Data Member

CatchupDoc::catchup Data Member
CatchupDoc Class CatchupDoc Members CatchupDoc Data Members

Catch-up benefit increases.

C++
Catchup catchup;
Collapse Expand Group

CatchupDoc Data Members

Collapse Expand Links
CatchupDoc Class, CatchupDoc Members, CatchupDoc Data Members


CatchupDoc Methods

CatchupDoc Methods
CatchupDoc Class Legend Public Methods

The methods of the CatchupDoc class are listed here.

Collapse Expand Class

CatchupDoc Class

Collapse Expand Public Methods
Name | Description
exist | Checks for existence of catch-up increase.
get | Returns one catch-up increase.
read | Reads catch-up increases.
setData | Sets catch-up increases for one alternative.
write | Writes catch-up increases.
Collapse Expand Links
CatchupDoc Class, Legend, Public Methods


CatchupDoc::exist Method

CatchupDoc::exist Method
CatchupDoc Class CatchupDoc Members CatchupDoc Methods

Checks for existence of catch-up increase.

C++
bool exist(
    int eligYear,
    int calYear
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
int calYear | Calendar year of increase.
Collapse Expand Returns

True if specified catch-up increase exists, false otherwise.

Collapse Expand Group

CatchupDoc Methods

Collapse Expand Links
CatchupDoc Class, CatchupDoc Members, CatchupDoc Methods


CatchupDoc::get Method

CatchupDoc::get Method
CatchupDoc Class CatchupDoc Members CatchupDoc Methods

Returns one catch-up increase.

C++
double get(
    int eligYear,
    int calYear
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
int calYear | Calendar year of increase.
Collapse Expand Returns

One catch-up increase.

Collapse Expand Group

CatchupDoc Methods

Collapse Expand Links
CatchupDoc Class, CatchupDoc Members, CatchupDoc Methods


CatchupDoc::read Method

CatchupDoc::read Method
CatchupDoc Class CatchupDoc Members CatchupDoc Methods

Reads catch-up increases.

C++
virtual void read(
    int
) = 0;
Collapse Expand Group

CatchupDoc Methods

Collapse Expand Links
CatchupDoc Class, CatchupDoc Members, CatchupDoc Methods


setData Method

setData Method
CatchupDoc Methods

Sets catch-up increases for one alternative.

Collapse Expand Description

There are two versions of this function, with or without a specified Catchup.

Collapse Expand Overload List
Name | Description
CatchupDoc::setData (int) | Sets catch-up increases for one alternative.
CatchupDoc::setData (int, const Catchup&) | Sets catch-up increases for one alternative.
Collapse Expand Group

CatchupDoc Methods

Collapse Expand Links
CatchupDoc Methods


CatchupDoc::setData Method (int)

CatchupDoc::setData Method (int)
CatchupDoc Class CatchupDoc Members setData Method

Sets catch-up increases for one alternative.

C++
virtual void setData(
    int
) = 0;
Collapse Expand Group

setData Method

Collapse Expand Links
CatchupDoc Class, CatchupDoc Members, setData Method


CatchupDoc::setData Method (int, const Catchup&)

CatchupDoc::setData Method (int, const Catchup&)
CatchupDoc Class CatchupDoc Members setData Method

Sets catch-up increases for one alternative.

C++
virtual void setData(
    int,
    const Catchup&
) = 0;
Collapse Expand Group

setData Method

Collapse Expand Links
CatchupDoc Class, CatchupDoc Members, setData Method


CatchupDoc::write Method

CatchupDoc::write Method
CatchupDoc Class CatchupDoc Members CatchupDoc Methods

Writes catch-up increases.

C++
virtual void write(
    int
) = 0;
Collapse Expand Group

CatchupDoc Methods

Collapse Expand Links
CatchupDoc Class, CatchupDoc Members, CatchupDoc Methods


CatchupFile Class

CatchupFile Class
CatchupFile Data Members CatchupFile Methods CatchupFile Members CatchupFile.h Classes

Manages a file of catch-up benefit increases stored on disk.

Collapse Expand Class Hierarchy
  CatchupFileCatchupFile
C++
class CatchupFile : public CatchupDoc;
Collapse Expand File

File: CatchupFile.h

Module: PiaData Library

Collapse Expand Remarks

See CatchupNonFile for a version of this class that stores the catch-up benefit increases internally.

Collapse Expand See Also

CatchupNonFile

Collapse Expand Group

Classes

Collapse Expand Links
CatchupFile Data Members, CatchupFile Methods, CatchupFile Members, CatchupFile.h, Classes


CatchupFile Members

CatchupFile Members
CatchupFile Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by CatchupFile.

Collapse Expand Class

CatchupFile Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
pathname | File information.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
setCuFile | Forms a file name for projected catch-up benefit increase file.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
allownonzero | True to allow nonzero catch-up increases.
catchup | Catch-up benefit increases.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
CatchupDoc | Initializes a CatchupDoc, with or without a specified starting year.
CatchupFile | Initializes catch-up benefit increase file.
exist | Checks for existence of catch-up increase.
get | Returns one catch-up increase.
read | Reads all catch-up increases.
setData | Sets catch-up increases for one alternative.
setData | Deletes current catch-up increases if other than TR assumption.
write | Writes all catch-up increases.
~CatchupFile | Destroys catch-up benefit increase file.
Collapse Expand Links
CatchupFile Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


CatchupFile::CatchupFile Constructor

CatchupFile::CatchupFile Constructor
CatchupFile Class CatchupFile Members CatchupFile Class

Initializes catch-up benefit increase file.

C++
CatchupFile(
    int newCstart,
    const std::string& newDirectory
);
Collapse Expand Parameters
Parameters | Description
int newCstart | Starting year of catch-up benefit increases.
const std::string& newDirectory | Directory with catch-up benefit increases file.
Collapse Expand Class

CatchupFile Class

Collapse Expand Links
CatchupFile Class, CatchupFile Members, CatchupFile Class


CatchupFile::~CatchupFile Destructor

CatchupFile::~CatchupFile Destructor
CatchupFile Class CatchupFile Members CatchupFile Class

Destroys catch-up benefit increase file.

C++
~CatchupFile();
Collapse Expand Class

CatchupFile Class

Collapse Expand Links
CatchupFile Class, CatchupFile Members, CatchupFile Class


CatchupFile Data Members

CatchupFile Data Members
CatchupFile Class Legend Protected Data Members

The data members of the CatchupFile class are listed here.

Collapse Expand Class

CatchupFile Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
pathname | File information.
Collapse Expand Links
CatchupFile Class, Legend, Protected Data Members


CatchupFile::pathname Data Member

CatchupFile::pathname Data Member
CatchupFile Class CatchupFile Members CatchupFile Data Members

File information.

C++
std::string pathname;
Collapse Expand Group

CatchupFile Data Members

Collapse Expand Links
CatchupFile Class, CatchupFile Members, CatchupFile Data Members


CatchupFile Methods

CatchupFile Methods
CatchupFile Class Legend Protected Methods Public Methods

The methods of the CatchupFile class are listed here.

Collapse Expand Class

CatchupFile Class

Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
setCuFile | Forms a file name for projected catch-up benefit increase file.
Collapse Expand Public Methods
Name | Description
read | Reads all catch-up increases.
setData | Deletes current catch-up increases if other than TR assumption.
write | Writes all catch-up increases.
Collapse Expand Links
CatchupFile Class, Legend, Protected Methods, Public Methods


CatchupFile::read Method

CatchupFile::read Method
CatchupFile Class CatchupFile Members CatchupFile Methods

Reads all catch-up increases.

C++
void read(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-4).
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_CACHUP2 if unable to open input file.
Collapse Expand Group

CatchupFile Methods

Collapse Expand Links
CatchupFile Class, CatchupFile Members, CatchupFile Methods


CatchupFile::setCuFile Method

CatchupFile::setCuFile Method
CatchupFile Class CatchupFile Members CatchupFile Methods

Forms a file name for projected catch-up benefit increase file.

C++
void setCuFile(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-7).
Collapse Expand Group

CatchupFile Methods

Collapse Expand Links
CatchupFile Class, CatchupFile Members, CatchupFile Methods


setData Method

setData Method
CatchupFile Methods

Deletes current catch-up increases if other than TR assumption.

Collapse Expand Description

There are two versions of the setData method, but they do the same thing. (They may differ in other children of CatchupDoc.)

Collapse Expand Overload List
Name | Description
CatchupFile::setData (int) | Deletes current catch-up increases if other than TR assumption.
CatchupFile::setData (int, const Catchup&) | Deletes current catch-up increases if other than TR assumption.
Collapse Expand Group

CatchupFile Methods

Collapse Expand Links
CatchupFile Methods


CatchupFile::setData Method (int)

CatchupFile::setData Method (int)
CatchupFile Class CatchupFile Members setData Method

Deletes current catch-up increases if other than TR assumption.

C++
void setData(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-7).
Collapse Expand Group

setData Method

Collapse Expand Links
CatchupFile Class, CatchupFile Members, setData Method


CatchupFile::setData Method (int, const Catchup&)

CatchupFile::setData Method (int, const Catchup&)
CatchupFile Class CatchupFile Members setData Method

Deletes current catch-up increases if other than TR assumption.

C++
void setData(
    int altNum,
    const Catchup&
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-7).
Collapse Expand Group

setData Method

Collapse Expand Links
CatchupFile Class, CatchupFile Members, setData Method


CatchupFile::write Method

CatchupFile::write Method
CatchupFile Class CatchupFile Members CatchupFile Methods

Writes all catch-up increases.

C++
void write(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-4).
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_CACHUP3 if unable to open output file.
Collapse Expand Group

CatchupFile Methods

Collapse Expand Links
CatchupFile Class, CatchupFile Members, CatchupFile Methods


CatchupIncreases Class

CatchupIncreases Class
CatchupIncreases Data Members CatchupIncreases Methods CatchupIncreases Members cachup.h Classes

Manages the catch-up benefit increases for one year of eligibility.

Collapse Expand Class Hierarchy
  CatchupIncreases
C++
class CatchupIncreases;
Collapse Expand File

File: cachup.h

Module: PiaData Library

Collapse Expand Remarks

There have not been any catch-up benefit increases to date; any catch-up increases used would be projected ones.

Collapse Expand Group

Classes

Collapse Expand Links
CatchupIncreases Data Members, CatchupIncreases Methods, CatchupIncreases Members, cachup.h, Classes


CatchupIncreases Members

CatchupIncreases Members
CatchupIncreases Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by CatchupIncreases.

Collapse Expand Class

CatchupIncreases Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Catch-up benefit increases for 8 calendar years.
Collapse Expand Public Data Members
Name | Description
NUM_CATCHUP_INCREASES | The number of catch-up increases for one year of eligibility (8).
Collapse Expand Public Methods
Name | Description
CatchupIncreases | Initializes catch-up benefit increase data.
get | Returns one catch-up increase.
parseString | Parses catch-up increases for one year of eligibility from a string.
set | Sets one catch-up increase.
toString | Returns catch-up increases for one year of eligibility as a string.
~CatchupIncreases | Destroys catch-up benefit increase data.
Collapse Expand Links
CatchupIncreases Class, Legend, Protected Data Members, Public Data Members, Public Methods


CatchupIncreases::CatchupIncreases Constructor

CatchupIncreases::CatchupIncreases Constructor
CatchupIncreases Class CatchupIncreases Members CatchupIncreases Class

Initializes catch-up benefit increase data.

C++
CatchupIncreases();
Collapse Expand Class

CatchupIncreases Class

Collapse Expand Links
CatchupIncreases Class, CatchupIncreases Members, CatchupIncreases Class


CatchupIncreases::~CatchupIncreases Destructor

CatchupIncreases::~CatchupIncreases Destructor
CatchupIncreases Class CatchupIncreases Members CatchupIncreases Class

Destroys catch-up benefit increase data.

C++
~CatchupIncreases();
Collapse Expand Class

CatchupIncreases Class

Collapse Expand Links
CatchupIncreases Class, CatchupIncreases Members, CatchupIncreases Class


CatchupIncreases Data Members

CatchupIncreases Data Members
CatchupIncreases Class Legend Protected Data Members Public Data Members

The data members of the CatchupIncreases class are listed here.

Collapse Expand Class

CatchupIncreases Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Catch-up benefit increases for 8 calendar years.
Collapse Expand Public Data Members
Name | Description
NUM_CATCHUP_INCREASES | The number of catch-up increases for one year of eligibility (8).
Collapse Expand Links
CatchupIncreases Class, Legend, Protected Data Members, Public Data Members


CatchupIncreases::NUM_CATCHUP_INCREASES Data Member

CatchupIncreases::NUM_CATCHUP_INCREASES Data Member
CatchupIncreases Class CatchupIncreases Members CatchupIncreases Data Members

The number of catch-up increases for one year of eligibility (8).

C++
const int NUM_CATCHUP_INCREASES = 8;
Collapse Expand Group

CatchupIncreases Data Members

Collapse Expand Links
CatchupIncreases Class, CatchupIncreases Members, CatchupIncreases Data Members


CatchupIncreases::theData Data Member

CatchupIncreases::theData Data Member
CatchupIncreases Class CatchupIncreases Members CatchupIncreases Data Members

Catch-up benefit increases for 8 calendar years.

C++
double theData[NUM_CATCHUP_INCREASES];
Collapse Expand Group

CatchupIncreases Data Members

Collapse Expand Links
CatchupIncreases Class, CatchupIncreases Members, CatchupIncreases Data Members


CatchupIncreases Methods

CatchupIncreases Methods
CatchupIncreases Class Legend Public Methods

The methods of the CatchupIncreases class are listed here.

Collapse Expand Class

CatchupIncreases Class

Collapse Expand Public Methods
Name | Description
get | Returns one catch-up increase.
parseString | Parses catch-up increases for one year of eligibility from a string.
set | Sets one catch-up increase.
toString | Returns catch-up increases for one year of eligibility as a string.
Collapse Expand Links
CatchupIncreases Class, Legend, Public Methods


CatchupIncreases::get Method

CatchupIncreases::get Method
CatchupIncreases Class CatchupIncreases Members CatchupIncreases Methods

Returns one catch-up increase.

C++
double get(
    int yearIndex
) const;
Collapse Expand Parameters
Parameters | Description
int yearIndex | Index of calendary year of increase.
Collapse Expand Returns

One catch-up increase.

Collapse Expand Group

CatchupIncreases Methods

Collapse Expand Links
CatchupIncreases Class, CatchupIncreases Members, CatchupIncreases Methods


CatchupIncreases::parseString Method

CatchupIncreases::parseString Method
CatchupIncreases Class CatchupIncreases Members CatchupIncreases Methods

Parses catch-up increases for one year of eligibility from a string.

C++
void parseString(
    std::string str
);
Collapse Expand Parameters
Parameters | Description
std::string str | String to parse.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_READERR if unable to parse all required data.
Collapse Expand Group

CatchupIncreases Methods

Collapse Expand Links
CatchupIncreases Class, CatchupIncreases Members, CatchupIncreases Methods


CatchupIncreases::set Method

CatchupIncreases::set Method
CatchupIncreases Class CatchupIncreases Members CatchupIncreases Methods

Sets one catch-up increase.

C++
void set(
    int yearIndex,
    double newCatchup
);
Collapse Expand Parameters
Parameters | Description
int yearIndex | Index of calendar year of increase.
double newCatchup | New value of catch-up increase.
Collapse Expand Group

CatchupIncreases Methods

Collapse Expand Links
CatchupIncreases Class, CatchupIncreases Members, CatchupIncreases Methods


CatchupIncreases::toString Method

CatchupIncreases::toString Method
CatchupIncreases Class CatchupIncreases Members CatchupIncreases Methods

Returns catch-up increases for one year of eligibility as a string.

C++
std::string toString() const;
Collapse Expand Returns

Catch-up increases for one year of eligibility as a string.

Collapse Expand Group

CatchupIncreases Methods

Collapse Expand Links
CatchupIncreases Class, CatchupIncreases Members, CatchupIncreases Methods


CatchupNonFile Class

CatchupNonFile Class
CatchupNonFile Methods CatchupNonFile Members CatchupNonFile.h Classes

Manages a file of catch-up benefit increases stored in arrays.

Collapse Expand Class Hierarchy
  CatchupNonFileCatchupNonFile
C++
class CatchupNonFile : public CatchupDoc;
Collapse Expand File

File: CatchupNonFile.h

Module: PiaData Library

Collapse Expand Remarks

See CatchupFile for a version of this class that stores the catch-up benefit increases on disk.

Collapse Expand See Also

CatchupFile

Collapse Expand Group

Classes

Collapse Expand Links
CatchupNonFile Methods, CatchupNonFile Members, CatchupNonFile.h, Classes


CatchupNonFile Members

CatchupNonFile Members
CatchupNonFile Class Legend Public Data Members Public Methods

The following tables list the members exposed by CatchupNonFile.

Collapse Expand Class

CatchupNonFile Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
allownonzero | True to allow nonzero catch-up increases.
catchup | Catch-up benefit increases.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
CatchupDoc | Initializes a CatchupDoc, with or without a specified starting year.
CatchupNonFile | Initializes catch-up benefit increases.
exist | Checks for existence of catch-up increase.
get | Returns one catch-up increase.
read | Read stored values from memory.
setData | Sets catch-up increases for one alternative.
setData | Sets catch-up benefit increases.
write | Dummy function.
~CatchupNonFile | Destructor.
Collapse Expand Links
CatchupNonFile Class, Legend, Public Data Members, Public Methods


CatchupNonFile::CatchupNonFile Constructor

CatchupNonFile::CatchupNonFile Constructor
CatchupNonFile Class CatchupNonFile Members CatchupNonFile Class

Initializes catch-up benefit increases.

C++
CatchupNonFile(
    int newCstart
);
Collapse Expand Parameters
Parameters | Description
int newCstart | Starting year of catch-up benefit increases.
Collapse Expand Class

CatchupNonFile Class

Collapse Expand Links
CatchupNonFile Class, CatchupNonFile Members, CatchupNonFile Class


CatchupNonFile::~CatchupNonFile Destructor

CatchupNonFile::~CatchupNonFile Destructor
CatchupNonFile Class CatchupNonFile Members CatchupNonFile Class

Destructor.

C++
~CatchupNonFile();
Collapse Expand Class

CatchupNonFile Class

Collapse Expand Links
CatchupNonFile Class, CatchupNonFile Members, CatchupNonFile Class


CatchupNonFile Methods

CatchupNonFile Methods
CatchupNonFile Class Legend Public Methods

The methods of the CatchupNonFile class are listed here.

Collapse Expand Class

CatchupNonFile Class

Collapse Expand Public Methods
Name | Description
read | Read stored values from memory.
setData | Sets catch-up benefit increases.
write | Dummy function.
Collapse Expand Links
CatchupNonFile Class, Legend, Public Methods


CatchupNonFile::read Method

CatchupNonFile::read Method
CatchupNonFile Class CatchupNonFile Members CatchupNonFile Methods

Read stored values from memory.

C++
void read(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-4).
Collapse Expand Group

CatchupNonFile Methods

Collapse Expand Links
CatchupNonFile Class, CatchupNonFile Members, CatchupNonFile Methods


setData Method

setData Method
CatchupNonFile Methods

Sets catch-up benefit increases.

Collapse Expand Description

There are two versions of this function. The one with a Catchup argument sets the current data to that data. The one without a Catchup argument uses data stored for the specified alternative.

Collapse Expand Overload List
Name | Description
CatchupNonFile::setData (int) | Sets catch-up increases with specified alternative, using the data stored for the specified alternative.
CatchupNonFile::setData (int, const Catchup&) | Sets catch-up increases, storing the data for the specified alternative from the Catchup, then setting the current data to that data.
Collapse Expand Group

CatchupNonFile Methods

Collapse Expand Links
CatchupNonFile Methods


CatchupNonFile::setData Method (int)

CatchupNonFile::setData Method (int)
CatchupNonFile Class CatchupNonFile Members setData Method

Sets catch-up increases with specified alternative, using the data stored for the specified alternative.

C++
void setData(
    int altNum
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-7).
Collapse Expand Group

setData Method

Collapse Expand Links
CatchupNonFile Class, CatchupNonFile Members, setData Method


CatchupNonFile::setData Method (int, const Catchup&)

CatchupNonFile::setData Method (int, const Catchup&)
CatchupNonFile Class CatchupNonFile Members setData Method

Sets catch-up increases, storing the data for the specified alternative from the Catchup, then setting the current data to that data.

C++
void setData(
    int altNum,
    const Catchup& newCatchup
);
Collapse Expand Parameters
Parameters | Description
int altNum | Desired alternative number (1-7).
const Catchup& newCatchup | New catch-up benefit increases.
Collapse Expand Group

setData Method

Collapse Expand Links
CatchupNonFile Class, CatchupNonFile Members, setData Method


CatchupNonFile::write Method

CatchupNonFile::write Method
CatchupNonFile Class CatchupNonFile Members CatchupNonFile Methods

Dummy function.

C++
void write(
    int
);
Collapse Expand Group

CatchupNonFile Methods

Collapse Expand Links
CatchupNonFile Class, CatchupNonFile Members, CatchupNonFile Methods


ChildCareCalc Class

ChildCareCalc Class
ChildCareCalc Methods ChildCareCalc Members ChildCareCalc.h Classes

Manages the functions required for calculation of a wage indexed Social Security benefit using childcare dropout years.

Collapse Expand Class Hierarchy
  ChildCareCalcChildCareCalcChildCareCalc
C++
class ChildCareCalc : public WageIndGeneral;
Collapse Expand File

File: ChildCareCalc.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaCalPL.

Collapse Expand Group

Classes

Collapse Expand Links
ChildCareCalc Methods, ChildCareCalc Members, ChildCareCalc.h, Classes


ChildCareCalc Members

ChildCareCalc Members
Enumerations ChildCareCalc Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by ChildCareCalc.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

ChildCareCalc Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
windfallInd | Windfall indicator.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
yearsTotal | Number of years of coverage for windfall elimination.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
ChildCareCalc | Initializes a ChildCareCalc instance.
aimepiaCal | Calculates an AIME PIA under the 1977 law.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
bendPointCal | Projects bend points.
calculate | Computes wage indexed PIA with childcare dropout years.
childCareDropMaxCal | Returns maximum number of childcare dropout years.
childCareDropoutCal | Adjust for childcare dropout years.
deconvertAme | Deconverts AIME from raw PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAdjustedN | Returns number of computation years adjusted for childcare dropout years.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getChildCareDrop | Returns number of usable childcare dropout years.
getChildCareDropMax | Returns maximum number of childcare dropout years.
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIndexYearAvgWage | Returns average wage in indexing year.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
realWageGainAdj | Applies real-wage-gain adjustment.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionAime | Calculates portion of aime in each section of pia formula.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setWindfall | Sets windfall indicator in wage-indexed method.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
~ChildCareCalc | Destructor.
Collapse Expand Links
Enumerations, ChildCareCalc Class, Legend, Protected Data Members, Public Data Members, Public Methods


ChildCareCalc::ChildCareCalc Constructor

ChildCareCalc::ChildCareCalc Constructor
ChildCareCalc Class ChildCareCalc Members ChildCareCalc Class

Initializes a ChildCareCalc instance.

C++
ChildCareCalc(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
Collapse Expand Class

ChildCareCalc Class

Collapse Expand Links
ChildCareCalc Class, ChildCareCalc Members, ChildCareCalc Class


ChildCareCalc::~ChildCareCalc Destructor

ChildCareCalc::~ChildCareCalc Destructor
ChildCareCalc Class ChildCareCalc Members ChildCareCalc Class

Destructor.

C++
virtual ~ChildCareCalc();
Collapse Expand Class

ChildCareCalc Class

Collapse Expand Links
ChildCareCalc Class, ChildCareCalc Members, ChildCareCalc Class


ChildCareCalc Methods

ChildCareCalc Methods
ChildCareCalc Class Legend Public Methods

The methods of the ChildCareCalc class are listed here.

Collapse Expand Class

ChildCareCalc Class

Collapse Expand Public Methods
Name | Description
calculate | Computes wage indexed PIA with childcare dropout years.
childCareDropMaxCal | Returns maximum number of childcare dropout years.
childCareDropoutCal | Adjust for childcare dropout years.
getAdjustedN | Returns number of computation years adjusted for childcare dropout years.
getChildCareDrop | Returns number of usable childcare dropout years.
getChildCareDropMax | Returns maximum number of childcare dropout years.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
Collapse Expand Links
ChildCareCalc Class, Legend, Public Methods


ChildCareCalc::calculate Method

ChildCareCalc::calculate Method
ChildCareCalc Class ChildCareCalc Members ChildCareCalc Methods

Computes wage indexed PIA with childcare dropout years.

C++
void calculate();
Collapse Expand Group

ChildCareCalc Methods

Collapse Expand Links
ChildCareCalc Class, ChildCareCalc Members, ChildCareCalc Methods


ChildCareCalc::childCareDropMaxCal Method

ChildCareCalc::childCareDropMaxCal Method
ChildCareCalc Class ChildCareCalc Members ChildCareCalc Methods

Returns maximum number of childcare dropout years.

C++
virtual int childCareDropMaxCal() const;
Collapse Expand Returns

Maximum number of childcare dropout years.

Collapse Expand Remarks

Assumes that there is a specified maximum for combined regular and childcare dropout years, and that number of regular dropout years has already been calculated.

Collapse Expand Group

ChildCareCalc Methods

Collapse Expand Links
ChildCareCalc Class, ChildCareCalc Members, ChildCareCalc Methods


ChildCareCalc::childCareDropoutCal Method

ChildCareCalc::childCareDropoutCal Method
ChildCareCalc Class ChildCareCalc Members ChildCareCalc Methods

Adjust for childcare dropout years.

C++
void childCareDropoutCal();
Collapse Expand Group

ChildCareCalc Methods

Collapse Expand Links
ChildCareCalc Class, ChildCareCalc Members, ChildCareCalc Methods


ChildCareCalc::getAdjustedN Method

ChildCareCalc::getAdjustedN Method
ChildCareCalc Class ChildCareCalc Members ChildCareCalc Methods

Returns number of computation years adjusted for childcare dropout years.

C++
int getAdjustedN() const;
Collapse Expand Returns

Number of computation years adjusted for childcare dropout years.

Collapse Expand Group

ChildCareCalc Methods

Collapse Expand Links
ChildCareCalc Class, ChildCareCalc Members, ChildCareCalc Methods


ChildCareCalc::getChildCareDrop Method

ChildCareCalc::getChildCareDrop Method
ChildCareCalc Class ChildCareCalc Members ChildCareCalc Methods

Returns number of usable childcare dropout years.

C++
int getChildCareDrop() const;
Collapse Expand Returns

Number of usable childcare dropout years.

Collapse Expand Group

ChildCareCalc Methods

Collapse Expand Links
ChildCareCalc Class, ChildCareCalc Members, ChildCareCalc Methods


ChildCareCalc::getChildCareDropMax Method

ChildCareCalc::getChildCareDropMax Method
ChildCareCalc Class ChildCareCalc Members ChildCareCalc Methods

Returns maximum number of childcare dropout years.

C++
int getChildCareDropMax() const;
Collapse Expand Returns

Maximum number of childcare dropout years.

Collapse Expand Group

ChildCareCalc Methods

Collapse Expand Links
ChildCareCalc Class, ChildCareCalc Members, ChildCareCalc Methods


ChildCareCalc::initialize Method

ChildCareCalc::initialize Method
ChildCareCalc Class ChildCareCalc Members ChildCareCalc Methods

Initializes computed values to zero.

C++
void initialize();
Collapse Expand Group

ChildCareCalc Methods

Collapse Expand Links
ChildCareCalc Class, ChildCareCalc Members, ChildCareCalc Methods


isApplicable Method

isApplicable Method
ChildCareCalc Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of this function. The version with no arguments uses stored data, passing it to the static version with three arguments.

Collapse Expand Overload List
Name | Description
ChildCareCalc::isApplicable () | Determines applicability of method using stored data.
ChildCareCalc::isApplicable (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type) | Determines applicability of method using passed data.
Collapse Expand Group

ChildCareCalc Methods

Collapse Expand Links
ChildCareCalc Methods


ChildCareCalc::isApplicable Method ()

ChildCareCalc::isApplicable Method ()
ChildCareCalc Class ChildCareCalc Members isApplicable Method

Determines applicability of method using stored data.

C++
bool isApplicable();
Collapse Expand Returns

True if this method is applicable, false otherwise.

Collapse Expand Remarks

The version with no arguments calls the static version with 3 arguments.

This method is applicable if worker is eligible after 1978, it is not a totalization benefit, and it is an old-age case with prior disability entitlement in June 1980 or later that lasted to age 61, or a disability case with entitlement in June 1980 or later.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
ChildCareCalc Class, ChildCareCalc Members, isApplicable Method


ChildCareCalc::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type)

ChildCareCalc::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type)
ChildCareCalc Class ChildCareCalc Members isApplicable Method

Determines applicability of method using passed data.

C++
static bool isApplicable(
    const WorkerDataGeneral& workerData,
    const PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker data.
const PiaData& piaData | Pia calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
Collapse Expand Returns

True if this method is applicable, false otherwise.

Collapse Expand Remarks

This method is applicable if worker is eligible after 1978, it is not a totalization benefit, and it is an old-age case with prior disability entitlement in June 1980 or later that lasted to age 61, or a disability case with entitlement in June 1980 or later.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
ChildCareCalc Class, ChildCareCalc Members, isApplicable Method


ChildCareCalcLC Class

ChildCareCalcLC Class
ChildCareCalcLC Data Members ChildCareCalcLC Methods ChildCareCalcLC Members ChildCareCalcLC.h Classes

Manages the functions required for calculation of a wage indexed Social Security benefit using childcare dropout years, with law changes.

Collapse Expand Class Hierarchy
  ChildCareCalcLCChildCareCalcLCChildCareCalcLCChildCareCalcLC
C++
class ChildCareCalcLC : public ChildCareCalc;
Collapse Expand File

File: ChildCareCalcLC.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaCalLC.

Collapse Expand Group

Classes

Collapse Expand Links
ChildCareCalcLC Data Members, ChildCareCalcLC Methods, ChildCareCalcLC Members, ChildCareCalcLC.h, Classes


ChildCareCalcLC Members

ChildCareCalcLC Members
Enumerations ChildCareCalcLC Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by ChildCareCalcLC.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

ChildCareCalcLC Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
lawChange | Law change parameters.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
windfallInd | Windfall indicator.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
yearsTotal | Number of years of coverage for windfall elimination.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
ChildCareCalcLC | Initializes a ChildCareCalcLC instance.
aimepiaCal | Calculates an AIME PIA under the 1977 law.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
bendPointCal | Projects bend points.
calculate | Computes wage indexed PIA with childcare dropout years.
calculate | Calculates pia and mfb for this method.
childCareDropMaxCal | Returns maximum number of childcare dropout years.
childCareDropoutCal | Adjust for childcare dropout years.
deconvertAme | Deconverts AIME from raw PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAdjustedN | Returns number of computation years adjusted for childcare dropout years.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getChildCareDrop | Returns number of usable childcare dropout years.
getChildCareDropMax | Returns maximum number of childcare dropout years.
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIndexYearAvgWage | Returns average wage in indexing year.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
realWageGainAdj | Applies real-wage-gain adjustment.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionAime | Calculates portion of aime in each section of pia formula.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setWindfall | Sets windfall indicator in wage-indexed method.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
~ChildCareCalcLC | Destructor.
Collapse Expand Links
Enumerations, ChildCareCalcLC Class, Legend, Protected Data Members, Public Data Members, Public Methods


ChildCareCalcLC::ChildCareCalcLC Constructor

ChildCareCalcLC::ChildCareCalcLC Constructor
ChildCareCalcLC Class ChildCareCalcLC Members ChildCareCalcLC Class

Initializes a ChildCareCalcLC instance.

C++
ChildCareCalcLC(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear,
    const LawChangeArray& newLawChange
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
const LawChangeArray& newLawChange | Law change parameters.
Collapse Expand Class

ChildCareCalcLC Class

Collapse Expand Links
ChildCareCalcLC Class, ChildCareCalcLC Members, ChildCareCalcLC Class


ChildCareCalcLC::~ChildCareCalcLC Destructor

ChildCareCalcLC::~ChildCareCalcLC Destructor
ChildCareCalcLC Class ChildCareCalcLC Members ChildCareCalcLC Class

Destructor.

C++
virtual ~ChildCareCalcLC();
Collapse Expand Class

ChildCareCalcLC Class

Collapse Expand Links
ChildCareCalcLC Class, ChildCareCalcLC Members, ChildCareCalcLC Class


ChildCareCalcLC Data Members

ChildCareCalcLC Data Members
ChildCareCalcLC Class Legend Protected Data Members

The data members of the ChildCareCalcLC class are listed here.

Collapse Expand Class

ChildCareCalcLC Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
lawChange | Law change parameters.
Collapse Expand Links
ChildCareCalcLC Class, Legend, Protected Data Members


ChildCareCalcLC::lawChange Data Member

ChildCareCalcLC::lawChange Data Member
ChildCareCalcLC Class ChildCareCalcLC Members ChildCareCalcLC Data Members

Law change parameters.

C++
const LawChangeArray& lawChange;
Collapse Expand Group

ChildCareCalcLC Data Members

Collapse Expand Links
ChildCareCalcLC Class, ChildCareCalcLC Members, ChildCareCalcLC Data Members


ChildCareCalcLC Methods

ChildCareCalcLC Methods
ChildCareCalcLC Class Legend Public Methods

The methods of the ChildCareCalcLC class are listed here.

Collapse Expand Class

ChildCareCalcLC Class

Collapse Expand Public Methods
Name | Description
childCareDropMaxCal | Returns maximum number of childcare dropout years.
isApplicable | Determines applicability of method.
Collapse Expand Links
ChildCareCalcLC Class, Legend, Public Methods


ChildCareCalcLC::childCareDropMaxCal Method

ChildCareCalcLC::childCareDropMaxCal Method
ChildCareCalcLC Class ChildCareCalcLC Members ChildCareCalcLC Methods

Returns maximum number of childcare dropout years.

C++
int childCareDropMaxCal() const;
Collapse Expand Returns

Maximum number of childcare dropout years.

Collapse Expand Group

ChildCareCalcLC Methods

Collapse Expand Links
ChildCareCalcLC Class, ChildCareCalcLC Members, ChildCareCalcLC Methods


isApplicable Method

isApplicable Method
ChildCareCalcLC Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of this function. The version with no arguments uses stored data, passing it to the static version with four arguments.

Collapse Expand Overload List
Name | Description
ChildCareCalcLC::isApplicable () | Determines applicability of method, using stored data.
ChildCareCalcLC::isApplicable (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type, const LawChangeArray&) | Determines applicability of method, using passed data.
Collapse Expand Group

ChildCareCalcLC Methods

Collapse Expand Links
ChildCareCalcLC Methods


ChildCareCalcLC::isApplicable Method ()

ChildCareCalcLC::isApplicable Method ()
ChildCareCalcLC Class ChildCareCalcLC Members isApplicable Method

Determines applicability of method, using stored data.

C++
bool isApplicable();
Collapse Expand Returns

True if this method is applicable, false otherwise.

Collapse Expand Remarks

The version with no arguments calls the static version with 5 arguments.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
ChildCareCalcLC Class, ChildCareCalcLC Members, isApplicable Method


ChildCareCalcLC::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type, const LawChangeArray&)

ChildCareCalcLC::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type, const LawChangeArray&)
ChildCareCalcLC Class ChildCareCalcLC Members isApplicable Method

Determines applicability of method, using passed data.

C++
static bool isApplicable(
    const WorkerDataGeneral& workerData,
    const PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi,
    const LawChangeArray& lawChange
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker data.
const PiaData& piaData | Pia calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
const LawChangeArray& lawChange | Law change parameters.
Collapse Expand Returns

True if this method is applicable, false otherwise.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
ChildCareCalcLC Class, ChildCareCalcLC Members, isApplicable Method


CompPeriod Class

CompPeriod Class
CompPeriod Methods CompPeriod Members comppd.h Classes

Manages the number of elapsed years, dropout years, and computation years.

Collapse Expand Class Hierarchy
  CompPeriod
C++
class CompPeriod;
Collapse Expand File

File: comppd.h

Module: PiaData Library

Collapse Expand Remarks

Two instances of this class are used in PiaData.

Collapse Expand Group

Classes

Collapse Expand Links
CompPeriod Methods, CompPeriod Members, comppd.h, Classes


CompPeriod Members

CompPeriod Members
CompPeriod Class Legend Public Methods

The following tables list the members exposed by CompPeriod.

Collapse Expand Class

CompPeriod Class

Collapse Expand Public Methods
Name | Description
CompPeriod | Creates a CompPeriod with a given base year.
deleteContents | Zeroes all variables.
getBaseYear | Returns base year (1936 or 1950).
getDiYears | Returns number of years wholly or partially within a period of disability, within the elapsed years.
getN | Returns number of computation years.
getNDrop | Returns number of dropout years.
getNElapsed | Returns number of elapsed years.
setDiYears | Sets number of years wholly or partially within a period of disability, within the elapsed years.
setN | Sets number of computation years.
setNDrop | Sets number of dropout years.
setNElapsed | Sets number of elapsed years.
Collapse Expand Links
CompPeriod Class, Legend, Public Methods


CompPeriod::CompPeriod Constructor

CompPeriod::CompPeriod Constructor
CompPeriod Class CompPeriod Members CompPeriod Class

Creates a CompPeriod with a given base year.

C++
CompPeriod(
    int newBaseYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | Base year to use (1936 or 1950).
Collapse Expand Class

CompPeriod Class

Collapse Expand Links
CompPeriod Class, CompPeriod Members, CompPeriod Class


CompPeriod Methods

CompPeriod Methods
CompPeriod Class Legend Public Methods

The methods of the CompPeriod class are listed here.

Collapse Expand Class

CompPeriod Class

Collapse Expand Public Methods
Name | Description
deleteContents | Zeroes all variables.
getBaseYear | Returns base year (1936 or 1950).
getDiYears | Returns number of years wholly or partially within a period of disability, within the elapsed years.
getN | Returns number of computation years.
getNDrop | Returns number of dropout years.
getNElapsed | Returns number of elapsed years.
setDiYears | Sets number of years wholly or partially within a period of disability, within the elapsed years.
setN | Sets number of computation years.
setNDrop | Sets number of dropout years.
setNElapsed | Sets number of elapsed years.
Collapse Expand Links
CompPeriod Class, Legend, Public Methods


CompPeriod::deleteContents Method

CompPeriod::deleteContents Method
CompPeriod Class CompPeriod Members CompPeriod Methods

Zeroes all variables.

C++
void deleteContents();
Collapse Expand Group

CompPeriod Methods

Collapse Expand Links
CompPeriod Class, CompPeriod Members, CompPeriod Methods


CompPeriod::getBaseYear Method

CompPeriod::getBaseYear Method
CompPeriod Class CompPeriod Members CompPeriod Methods

Returns base year (1936 or 1950).

C++
int getBaseYear() const;
Collapse Expand Returns

Base year (1936 or 1950).

Collapse Expand Group

CompPeriod Methods

Collapse Expand Links
CompPeriod Class, CompPeriod Members, CompPeriod Methods


CompPeriod::getDiYears Method

CompPeriod::getDiYears Method
CompPeriod Class CompPeriod Members CompPeriod Methods

Returns number of years wholly or partially within a period of disability, within the elapsed years.

C++
int getDiYears() const;
Collapse Expand Returns

Number of years wholly or partially within a period of disability, within the elapsed years.

Collapse Expand Group

CompPeriod Methods

Collapse Expand Links
CompPeriod Class, CompPeriod Members, CompPeriod Methods


CompPeriod::getN Method

CompPeriod::getN Method
CompPeriod Class CompPeriod Members CompPeriod Methods

Returns number of computation years.

C++
int getN() const;
Collapse Expand Returns

Number of computation years.

Collapse Expand Group

CompPeriod Methods

Collapse Expand Links
CompPeriod Class, CompPeriod Members, CompPeriod Methods


CompPeriod::getNDrop Method

CompPeriod::getNDrop Method
CompPeriod Class CompPeriod Members CompPeriod Methods

Returns number of dropout years.

C++
int getNDrop() const;
Collapse Expand Returns

Number of dropout years.

Collapse Expand Group

CompPeriod Methods

Collapse Expand Links
CompPeriod Class, CompPeriod Members, CompPeriod Methods


CompPeriod::getNElapsed Method

CompPeriod::getNElapsed Method
CompPeriod Class CompPeriod Members CompPeriod Methods

Returns number of elapsed years.

C++
int getNElapsed() const;
Collapse Expand Returns

Number of elapsed years.

Collapse Expand Group

CompPeriod Methods

Collapse Expand Links
CompPeriod Class, CompPeriod Members, CompPeriod Methods


CompPeriod::setDiYears Method

CompPeriod::setDiYears Method
CompPeriod Class CompPeriod Members CompPeriod Methods

Sets number of years wholly or partially within a period of disability, within the elapsed years.

C++
void setDiYears(
    int newDiYears
);
Collapse Expand Parameters
Parameters | Description
int newDiYears | New number of disability years.
Collapse Expand Group

CompPeriod Methods

Collapse Expand Links
CompPeriod Class, CompPeriod Members, CompPeriod Methods


CompPeriod::setN Method

CompPeriod::setN Method
CompPeriod Class CompPeriod Members CompPeriod Methods

Sets number of computation years.

C++
void setN(
    int newN
);
Collapse Expand Parameters
Parameters | Description
int newN | New number of computation years.
Collapse Expand Group

CompPeriod Methods

Collapse Expand Links
CompPeriod Class, CompPeriod Members, CompPeriod Methods


CompPeriod::setNDrop Method

CompPeriod::setNDrop Method
CompPeriod Class CompPeriod Members CompPeriod Methods

Sets number of dropout years.

C++
void setNDrop(
    int newNDrop
);
Collapse Expand Parameters
Parameters | Description
int newNDrop | New number of dropout years.
Collapse Expand Group

CompPeriod Methods

Collapse Expand Links
CompPeriod Class, CompPeriod Members, CompPeriod Methods


CompPeriod::setNElapsed Method

CompPeriod::setNElapsed Method
CompPeriod Class CompPeriod Members CompPeriod Methods

Sets number of elapsed years.

C++
void setNElapsed(
    int newNElapsed
);
Collapse Expand Parameters
Parameters | Description
int newNElapsed | New number of elapsed years.
Collapse Expand Group

CompPeriod Methods

Collapse Expand Links
CompPeriod Class, CompPeriod Members, CompPeriod Methods


Config Class

Config Class
Config Methods Config Members config.h Classes

Parent of classes that manage the configuration information used by the PIA calculation program.

Collapse Expand Class Hierarchy
  Config
C++
class Config;
Collapse Expand File

File: config.h

Module: PiaData Library

Collapse Expand Remarks

This class is abstract; use ConfigFile or ConfigNonFile.

Collapse Expand See Also

ConfigFile, ConfigNonFile

Collapse Expand Group

Classes

Collapse Expand Links
Config Methods, Config Members, config.h, Classes


Config Members

Config Members
Config Class Legend Public Methods

The following tables list the members exposed by Config.

Collapse Expand Class

Config Class

Collapse Expand Public Methods
Name | Description
Config | Initializes configuration.
getLeftMargin | Returns left margin in inches.
getLongOutput | Returns long output indicator.
getPrinterPoints | Returns printer font point size.
getScreenPoints | Returns screen font point size.
getTopMargin | Returns top margin in inches.
read | Reads this structure.
setLeftMargin | Sets left margin in inches.
setLongOutput | Sets long output indicator.
setPrinterPoints | Sets printer font point size.
setScreenPoints | Sets screen font point size.
setTopMargin | Sets top margin in inches.
write | Writes this structure.
~Config | Destroys configuration.
Collapse Expand Links
Config Class, Legend, Public Methods


Config::Config Constructor

Config::Config Constructor
Config Class Config Members Config Class

Initializes configuration.

C++
Config();
Collapse Expand Class

Config Class

Collapse Expand Links
Config Class, Config Members, Config Class


Config::~Config Destructor

Config::~Config Destructor
Config Class Config Members Config Class

Destroys configuration.

C++
virtual ~Config();
Collapse Expand Class

Config Class

Collapse Expand Links
Config Class, Config Members, Config Class


Config Methods

Config Methods
Config Class Legend Public Methods

The methods of the Config class are listed here.

Collapse Expand Class

Config Class

Collapse Expand Public Methods
Name | Description
getLeftMargin | Returns left margin in inches.
getLongOutput | Returns long output indicator.
getPrinterPoints | Returns printer font point size.
getScreenPoints | Returns screen font point size.
getTopMargin | Returns top margin in inches.
read | Reads this structure.
setLeftMargin | Sets left margin in inches.
setLongOutput | Sets long output indicator.
setPrinterPoints | Sets printer font point size.
setScreenPoints | Sets screen font point size.
setTopMargin | Sets top margin in inches.
write | Writes this structure.
Collapse Expand Links
Config Class, Legend, Public Methods


Config::getLeftMargin Method

Config::getLeftMargin Method
Config Class Config Members Config Methods

Returns left margin in inches.

C++
float getLeftMargin() const;
Collapse Expand Returns

Left margin in inches.

Collapse Expand Group

Config Methods

Collapse Expand Links
Config Class, Config Members, Config Methods


Config::getLongOutput Method

Config::getLongOutput Method
Config Class Config Members Config Methods

Returns long output indicator.

C++
bool getLongOutput() const;
Collapse Expand Returns

Long output indicator.

True | long output.
False | short output.

///

Collapse Expand Group

Config Methods

Collapse Expand Links
Config Class, Config Members, Config Methods


Config::getPrinterPoints Method

Config::getPrinterPoints Method
Config Class Config Members Config Methods

Returns printer font point size.

C++
int getPrinterPoints() const;
Collapse Expand Returns

Printer font point size.

Collapse Expand Group

Config Methods

Collapse Expand Links
Config Class, Config Members, Config Methods


Config::getScreenPoints Method

Config::getScreenPoints Method
Config Class Config Members Config Methods

Returns screen font point size.

C++
int getScreenPoints() const;
Collapse Expand Returns

Screen font point size.

Collapse Expand Group

Config Methods

Collapse Expand Links
Config Class, Config Members, Config Methods


Config::getTopMargin Method

Config::getTopMargin Method
Config Class Config Members Config Methods

Returns top margin in inches.

C++
float getTopMargin() const;
Collapse Expand Returns

Top margin in inches.

Collapse Expand Group

Config Methods

Collapse Expand Links
Config Class, Config Members, Config Methods


Config::read Method

Config::read Method
Config Class Config Members Config Methods

Reads this structure.

C++
virtual void read() = 0;
Collapse Expand Group

Config Methods

Collapse Expand Links
Config Class, Config Members, Config Methods


Config::setLeftMargin Method

Config::setLeftMargin Method
Config Class Config Members Config Methods

Sets left margin in inches.

C++
void setLeftMargin(
    float newLeftMargin
);
Collapse Expand Parameters
Parameters | Description
float newLeftMargin | New left margin in inches.
Collapse Expand Group

Config Methods

Collapse Expand Links
Config Class, Config Members, Config Methods


Config::setLongOutput Method

Config::setLongOutput Method
Config Class Config Members Config Methods

Sets long output indicator.

C++
void setLongOutput(
    bool newLongOutput
);
Collapse Expand Parameters
Parameters | Description
bool newLongOutput | New long output indicator.
Collapse Expand Group

Config Methods

Collapse Expand Links
Config Class, Config Members, Config Methods


Config::setPrinterPoints Method

Config::setPrinterPoints Method
Config Class Config Members Config Methods

Sets printer font point size.

C++
void setPrinterPoints(
    int newPrinterPoints
);
Collapse Expand Parameters
Parameters | Description
int newPrinterPoints | New printer font point size.
Collapse Expand Group

Config Methods

Collapse Expand Links
Config Class, Config Members, Config Methods


Config::setScreenPoints Method

Config::setScreenPoints Method
Config Class Config Members Config Methods

Sets screen font point size.

C++
void setScreenPoints(
    int newScreenPoints
);
Collapse Expand Parameters
Parameters | Description
int newScreenPoints | New screen font point size.
Collapse Expand Group

Config Methods

Collapse Expand Links
Config Class, Config Members, Config Methods


Config::setTopMargin Method

Config::setTopMargin Method
Config Class Config Members Config Methods

Sets top margin in inches.

C++
void setTopMargin(
    float newTopMargin
);
Collapse Expand Parameters
Parameters | Description
float newTopMargin | New top margin in inches.
Collapse Expand Group

Config Methods

Collapse Expand Links
Config Class, Config Members, Config Methods


Config::write Method

Config::write Method
Config Class Config Members Config Methods

Writes this structure.

C++
virtual void write() = 0;
Collapse Expand Group

Config Methods

Collapse Expand Links
Config Class, Config Members, Config Methods


ConfigFile Class

ConfigFile Class
ConfigFile Methods ConfigFile Members ConfigFile.h Classes

Manages the configuration information used by the PIA calculation program, stored in a file.

Collapse Expand Class Hierarchy
  ConfigFileConfigFile
C++
class ConfigFile : public Config;
Collapse Expand File

File: ConfigFile.h

Module: PiaData Library

Collapse Expand Remarks

See ConfigNonFile for a version of this class that stores the configuration information internally.

Collapse Expand See Also

ConfigNonFile

Collapse Expand Group

Classes

Collapse Expand Links
ConfigFile Methods, ConfigFile Members, ConfigFile.h, Classes


ConfigFile Members

ConfigFile Members
ConfigFile Class Legend Public Methods

The following tables list the members exposed by ConfigFile.

Collapse Expand Class

ConfigFile Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
ConfigFile | Initializes configuration.
getLeftMargin | Returns left margin in inches.
getLongOutput | Returns long output indicator.
getPrinterPoints | Returns printer font point size.
getScreenPoints | Returns screen font point size.
getTopMargin | Returns top margin in inches.
read | Reads the configuration from disk.
setLeftMargin | Sets left margin in inches.
setLongOutput | Sets long output indicator.
setPrinterPoints | Sets printer font point size.
setScreenPoints | Sets screen font point size.
setTopMargin | Sets top margin in inches.
write | Saves the configuration to disk.
~ConfigFile | Destroys configuration.
Collapse Expand Links
ConfigFile Class, Legend, Public Methods


ConfigFile::ConfigFile Constructor

ConfigFile::ConfigFile Constructor
ConfigFile Class ConfigFile Members ConfigFile Class

Initializes configuration.

C++
ConfigFile(
    const std::string& newDirectory
);
Collapse Expand Parameters
Parameters | Description
const std::string& newDirectory | New directory to use.
Collapse Expand Class

ConfigFile Class

Collapse Expand Links
ConfigFile Class, ConfigFile Members, ConfigFile Class


ConfigFile::~ConfigFile Destructor

ConfigFile::~ConfigFile Destructor
ConfigFile Class ConfigFile Members ConfigFile Class

Destroys configuration.

C++
~ConfigFile();
Collapse Expand Class

ConfigFile Class

Collapse Expand Links
ConfigFile Class, ConfigFile Members, ConfigFile Class


ConfigFile Methods

ConfigFile Methods
ConfigFile Class Legend Public Methods

The methods of the ConfigFile class are listed here.

Collapse Expand Class

ConfigFile Class

Collapse Expand Public Methods
Name | Description
read | Reads the configuration from disk.
write | Saves the configuration to disk.
Collapse Expand Links
ConfigFile Class, Legend, Public Methods


ConfigFile::read Method

ConfigFile::read Method
ConfigFile Class ConfigFile Members ConfigFile Methods

Reads the configuration from disk.

C++
void read();
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_CONFIG1 if unable to open input file; of type PIA_IDS_CONFIG6 if unable to read all required data.
Collapse Expand Group

ConfigFile Methods

Collapse Expand Links
ConfigFile Class, ConfigFile Members, ConfigFile Methods


ConfigFile::write Method

ConfigFile::write Method
ConfigFile Class ConfigFile Members ConfigFile Methods

Saves the configuration to disk.

C++
void write();
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_CONFIG5 if unable to open output file.
Collapse Expand Group

ConfigFile Methods

Collapse Expand Links
ConfigFile Class, ConfigFile Members, ConfigFile Methods


ConfigNonFile Class

ConfigNonFile Class
ConfigNonFile Methods ConfigNonFile Members ConfigNonFile.h Classes

Manages the configuration information used by the PIA calculation program, stored with the code.

Collapse Expand Class Hierarchy
  ConfigNonFileConfigNonFile
C++
class ConfigNonFile : public Config;
Collapse Expand File

File: ConfigNonFile.h

Module: PiaData Library

Collapse Expand Remarks

See ConfigFile for a version of this class that stores the configuration information on disk.

Collapse Expand See Also

ConfigFile

Collapse Expand Group

Classes

Collapse Expand Links
ConfigNonFile Methods, ConfigNonFile Members, ConfigNonFile.h, Classes


ConfigNonFile Members

ConfigNonFile Members
ConfigNonFile Class Legend Public Methods

The following tables list the members exposed by ConfigNonFile.

Collapse Expand Class

ConfigNonFile Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
ConfigNonFile | Initializes configuration.
getLeftMargin | Returns left margin in inches.
getLongOutput | Returns long output indicator.
getPrinterPoints | Returns printer font point size.
getScreenPoints | Returns screen font point size.
getTopMargin | Returns top margin in inches.
read | Reads the configuration (dummy function).
setLeftMargin | Sets left margin in inches.
setLongOutput | Sets long output indicator.
setPrinterPoints | Sets printer font point size.
setScreenPoints | Sets screen font point size.
setTopMargin | Sets top margin in inches.
write | Saves the configuration (dummy function).
~ConfigNonFile | Destroys configuration.
Collapse Expand Links
ConfigNonFile Class, Legend, Public Methods


ConfigNonFile::ConfigNonFile Constructor

ConfigNonFile::ConfigNonFile Constructor
ConfigNonFile Class ConfigNonFile Members ConfigNonFile Class

Initializes configuration.

C++
ConfigNonFile();
Collapse Expand Class

ConfigNonFile Class

Collapse Expand Links
ConfigNonFile Class, ConfigNonFile Members, ConfigNonFile Class


ConfigNonFile::~ConfigNonFile Destructor

ConfigNonFile::~ConfigNonFile Destructor
ConfigNonFile Class ConfigNonFile Members ConfigNonFile Class

Destroys configuration.

C++
~ConfigNonFile();
Collapse Expand Class

ConfigNonFile Class

Collapse Expand Links
ConfigNonFile Class, ConfigNonFile Members, ConfigNonFile Class


ConfigNonFile Methods

ConfigNonFile Methods
ConfigNonFile Class Legend Public Methods

The methods of the ConfigNonFile class are listed here.

Collapse Expand Class

ConfigNonFile Class

Collapse Expand Public Methods
Name | Description
read | Reads the configuration (dummy function).
write | Saves the configuration (dummy function).
Collapse Expand Links
ConfigNonFile Class, Legend, Public Methods


ConfigNonFile::read Method

ConfigNonFile::read Method
ConfigNonFile Class ConfigNonFile Members ConfigNonFile Methods

Reads the configuration (dummy function).

C++
void read();
Collapse Expand Group

ConfigNonFile Methods

Collapse Expand Links
ConfigNonFile Class, ConfigNonFile Members, ConfigNonFile Methods


ConfigNonFile::write Method

ConfigNonFile::write Method
ConfigNonFile Class ConfigNonFile Members ConfigNonFile Methods

Saves the configuration (dummy function).

C++
void write();
Collapse Expand Group

ConfigNonFile Methods

Collapse Expand Links
ConfigNonFile Class, ConfigNonFile Members, ConfigNonFile Methods


DibGuar Class

DibGuar Class
DibGuar Enumerations DibGuar Methods DibGuar Members DibGuar.h Classes

Manages the functions required for calculation of a disability guarantee Social Security benefit.

Collapse Expand Class Hierarchy
  DibGuarDibGuar
C++
class DibGuar : public PiaMethod;
Collapse Expand File

File: DibGuar.h

Module: PiaData Library

Collapse Expand Remarks

This method is used when a person has recovered from one period of disability and is claiming a subsequent benefit (old-age, disability, or death). An instance of this class is created in PiaCalPL.

Collapse Expand Group

Classes

Collapse Expand Links
DibGuar Enumerations, DibGuar Methods, DibGuar Members, DibGuar.h, Classes


DibGuar Members

DibGuar Members
Enumerations DibGuar Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by DibGuar.

Collapse Expand Enumerations
Name | Description
ConvertedMfbType | The type of mfb at cessation, after conversion.
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

DibGuar Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
cessationMfbCal | Calculates the applicable mfb at cessation date.
convertedMfbTypeCal | Returns the type of mfb at cessation, after conversion.
dateCpiCal | Returns the date as of which the initial pia is calculated.
entDeathDateCal | Returns date of entitlement in a life case, or date of death in a survivor case.
yearCpi1Cal | Returns first year that benefit increases are applied.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
DibGuar | Initializes a disability guarantee pia method.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Computes disability guarantee PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCessationMfbConv | Returns the mfb based on the deconverted pia brought up to the cessation date.
getCessationMfbOrig | Returns the original mfb at the cessation date.
getColasApply | Returns true if colas apply from cessation date of prior disability to new entitlement date.
getConvertedMfbType | Returns the type of converted mfb.
getCpiYear | Returns year that benefit increases were applied.
getDiMaxApplies | Returns true if the mfb from the prior disability was determined using the Disability Maximum method.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getRawMfb | Returns the mfb based on the deconverted pia at eligibility date.
getRawPia | Returns the pia deconverted from cessation date to eligibility date.
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~DibGuar | Destructor.
Collapse Expand Links
Enumerations, DibGuar Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


DibGuar::DibGuar Constructor

DibGuar::DibGuar Constructor
DibGuar Class DibGuar Members DibGuar Class

Initializes a disability guarantee pia method.

C++
DibGuar(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
Collapse Expand Remarks

Initializes all amounts to zero, then calls PiaMethod::initialize.

Collapse Expand Class

DibGuar Class

Collapse Expand Links
DibGuar Class, DibGuar Members, DibGuar Class


DibGuar::~DibGuar Destructor

DibGuar::~DibGuar Destructor
DibGuar Class DibGuar Members DibGuar Class

Destructor.

C++
virtual ~DibGuar();
Collapse Expand Class

DibGuar Class

Collapse Expand Links
DibGuar Class, DibGuar Members, DibGuar Class


DibGuar Enumerations

DibGuar Enumerations
Enumerations DibGuar Class Legend

The enumerations of the DibGuar class are listed here.

Collapse Expand Enumerations
Name | Description
ConvertedMfbType | The type of mfb at cessation, after conversion.
Collapse Expand Class

DibGuar Class

Collapse Expand Links
Enumerations, DibGuar Class, Legend


DibGuar::ConvertedMfbType Enumeration

DibGuar::ConvertedMfbType Enumeration
DibGuar.h DibGuar Enumerations

The type of mfb at cessation, after conversion.

C++
enum ConvertedMfbType {
  POST1995_NOCHANGE = 0,
  POST1995_DECONVERTED,
  PRE1996_PRE1979_LAST12,
  PRE1996_POST1978_LAST12,
  PRE1996_NOTLAST12
};
Collapse Expand File

File: DibGuar.h

Module: PiaData Library

Collapse Expand Members
Members | Description
POST1995_NOCHANGE = 0 | Subsequent entitlement in January 1996 or later, new benefit is DI, or the Disability Maximum does not apply (no conversion required).
POST1995_DECONVERTED | Subsequent entitlement in January 1996 or later, new benefit is OASI, and Disability Maximum applies (requires deconversion to prior eligibility year).
PRE1996_PRE1979_LAST12 | Subsequent entitlement before January 1996, prior DIB continued in the 12 months preceding the new entitlement, prior DIB eligibility was before 1979.
PRE1996_POST1978_LAST12 | Subsequent entitlement before January 1996, prior DIB continued in the 12 months preceding the new entitlement, prior DIB eligibility was after 1978.
PRE1996_NOTLAST12 | Subsequent entitlement before January 1996, prior DIB did not continue in the 12 months preceding the new entitlement.
Collapse Expand Remarks

The type of mfb first depends on the date of entitlement to the subsequent benefit. If it is January 1996 or later, then the type is ConvertedMfbType::POST1995_NOCHANGE if the new benefit is a disability benefit, or if the Disability Maximum does not apply. The type is ConvertedMfbType::POST1995_DECONVERTED if it is an old-age or survivor benefit and the Disability Maximum applies.

If the date of entitlement to the subsequent benefit is before January 1996, then the type depends on if the prior DIB entitlement continued in the 12 months preceding the new entitlement. If so, the type is ConvertedMfbType::PRE1996_PRE1979_LAST12 if eligibility to the prior DIB benefit was before 1979, or ConvertedMfbType::PRE1996_POST1978_LAST12 if eligibility to the prior DIB benefit was after 1978. Otherwise, the type is ConvertedMfbType::PRE1996_NOTLAST12.

Collapse Expand Group

DibGuar Enumerations

Collapse Expand Links
DibGuar.h, DibGuar Enumerations


DibGuar Methods

DibGuar Methods
DibGuar Class Legend Protected Methods Public Methods

The methods of the DibGuar class are listed here.

Collapse Expand Class

DibGuar Class

Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
cessationMfbCal | Calculates the applicable mfb at cessation date.
convertedMfbTypeCal | Returns the type of mfb at cessation, after conversion.
dateCpiCal | Returns the date as of which the initial pia is calculated.
entDeathDateCal | Returns date of entitlement in a life case, or date of death in a survivor case.
yearCpi1Cal | Returns first year that benefit increases are applied.
Collapse Expand Public Methods
Name | Description
calculate | Computes disability guarantee PIA.
getCessationMfbConv | Returns the mfb based on the deconverted pia brought up to the cessation date.
getCessationMfbOrig | Returns the original mfb at the cessation date.
getColasApply | Returns true if colas apply from cessation date of prior disability to new entitlement date.
getConvertedMfbType | Returns the type of converted mfb.
getDiMaxApplies | Returns true if the mfb from the prior disability was determined using the Disability Maximum method.
getRawMfb | Returns the mfb based on the deconverted pia at eligibility date.
getRawPia | Returns the pia deconverted from cessation date to eligibility date.
isApplicable | Determines applicability of method.
Collapse Expand Links
DibGuar Class, Legend, Protected Methods, Public Methods


DibGuar::calculate Method

DibGuar::calculate Method
DibGuar Class DibGuar Members DibGuar Methods

Computes disability guarantee PIA.

C++
void calculate();
Collapse Expand Remarks

Gets the pia at cessation from the prior disability period. For old-age or survivor, that is the most recent period. For disability, that is the prior period of disability.

Apply colas from the prior cessation date to the new entitlement date only if the cessation was within 12 months of the new entitlement.

Collapse Expand Group

DibGuar Methods

Collapse Expand Links
DibGuar Class, DibGuar Members, DibGuar Methods


DibGuar::cessationMfbCal Method

DibGuar::cessationMfbCal Method
DibGuar Class DibGuar Members DibGuar Methods

Calculates the applicable mfb at cessation date.

C++
double cessationMfbCal(
    const DisabPeriod& disabPeriod
);
Collapse Expand Parameters
Parameters | Description
const DisabPeriod& disabPeriod | The period of disability being considered.
Collapse Expand Returns

The applicable mfb at cessation date.

Collapse Expand Remarks

For a disability benefit, or any benefit prior to January 1996, the mfb is simply the one at the date of cessation of the prior disability benefit. For old-age or survivors in 1996 or later, if the prior mfb was based on the Disability Maximum, the pia at cessation must be deconverted back to eligibility, then that is used to compute a raw mfb, and that is converted forward to the cessation date.

Also sets rawPia and rawMfb, if the deconversion is necessary.

Collapse Expand Group

DibGuar Methods

Collapse Expand Links
DibGuar Class, DibGuar Members, DibGuar Methods


DibGuar::convertedMfbTypeCal Method

DibGuar::convertedMfbTypeCal Method
DibGuar Class DibGuar Members DibGuar Methods

Returns the type of mfb at cessation, after conversion.

C++
ConvertedMfbType convertedMfbTypeCal() const;
Collapse Expand Returns

The type of mfb at cessation, after conversion.

Collapse Expand Remarks

The type of mfb first depends on the date of entitlement to the subsequent benefit. If it is January 1996 or later, then the type is POST1995_NOCHANGE if the new benefit is a disability benefit, or if the Disability Maximum does not apply. The type is POST1995_DECONVERTED if it is an old-age or survivor benefit and the Disability Maximum applies.

If the date of entitlement to the subsequent benefit is before January 1996, then the type depends on if the prior DIB entitlement continued in the 12 months preceding the new entitlement. If so, the type is PRE1996_PRE1979_LAST12 if eligibility to the prior DIB benefit was before 1979, or PRE1996_POST1978_LAST12 if eligibility to the prior DIB benefit was after 1978. Otherwise, the type is PRE1996_NOTLAST12.

Collapse Expand Group

DibGuar Methods

Collapse Expand Links
DibGuar Class, DibGuar Members, DibGuar Methods


DibGuar::dateCpiCal Method

DibGuar::dateCpiCal Method
DibGuar Class DibGuar Members DibGuar Methods

Returns the date as of which the initial pia is calculated.

C++
DateMoyr dateCpiCal() const;
Collapse Expand Returns

The date as of which the initial pia is calculated.

Collapse Expand Remarks

Cpi increases are applied after this date.

Collapse Expand Group

DibGuar Methods

Collapse Expand Links
DibGuar Class, DibGuar Members, DibGuar Methods


DibGuar::entDeathDateCal Method

DibGuar::entDeathDateCal Method
DibGuar Class DibGuar Members DibGuar Methods

Returns date of entitlement in a life case, or date of death in a survivor case.

C++
DateMoyr entDeathDateCal() const;
Collapse Expand Returns

The date of entitlement in a life case, or date of death in a survivor case.

Collapse Expand Group

DibGuar Methods

Collapse Expand Links
DibGuar Class, DibGuar Members, DibGuar Methods


DibGuar::getCessationMfbConv Method

DibGuar::getCessationMfbConv Method
DibGuar Class DibGuar Members DibGuar Methods

Returns the mfb based on the deconverted pia brought up to the cessation date.

C++
double getCessationMfbConv() const;
Collapse Expand Returns

The mfb based on the deconverted pia brought up to the cessation date.

Collapse Expand Group

DibGuar Methods

Collapse Expand Links
DibGuar Class, DibGuar Members, DibGuar Methods


DibGuar::getCessationMfbOrig Method

DibGuar::getCessationMfbOrig Method
DibGuar Class DibGuar Members DibGuar Methods

Returns the original mfb at the cessation date.

C++
double getCessationMfbOrig() const;
Collapse Expand Returns

The original mfb at the cessation date.

Collapse Expand Remarks

This could be based on the Disability Maximum, and so may need to be converted (see getCessationMfbConv).

Collapse Expand Group

DibGuar Methods

Collapse Expand Links
DibGuar Class, DibGuar Members, DibGuar Methods


DibGuar::getColasApply Method

DibGuar::getColasApply Method
DibGuar Class DibGuar Members DibGuar Methods

Returns true if colas apply from cessation date of prior disability to new entitlement date.

C++
bool getColasApply() const;
Collapse Expand Returns

True if colas apply from cessation date of prior disability to new entitlement date.

Collapse Expand Group

DibGuar Methods

Collapse Expand Links
DibGuar Class, DibGuar Members, DibGuar Methods


DibGuar::getConvertedMfbType Method

DibGuar::getConvertedMfbType Method
DibGuar Class DibGuar Members DibGuar Methods

Returns the type of converted mfb.

C++
ConvertedMfbType getConvertedMfbType() const;
Collapse Expand Returns

The type of converted mfb.

Collapse Expand Group

DibGuar Methods

Collapse Expand Links
DibGuar Class, DibGuar Members, DibGuar Methods


DibGuar::getDiMaxApplies Method

DibGuar::getDiMaxApplies Method
DibGuar Class DibGuar Members DibGuar Methods

Returns true if the mfb from the prior disability was determined using the Disability Maximum method.

C++
bool getDiMaxApplies() const;
Collapse Expand Returns

True if the mfb from the prior disability was determined using the Disability Maximum method.

Collapse Expand Group

DibGuar Methods

Collapse Expand Links
DibGuar Class, DibGuar Members, DibGuar Methods


DibGuar::getRawMfb Method

DibGuar::getRawMfb Method
DibGuar Class DibGuar Members DibGuar Methods

Returns the mfb based on the deconverted pia at eligibility date.

C++
double getRawMfb() const;
Collapse Expand Returns

The mfb based on the deconverted pia at eligibility date.

Collapse Expand Group

DibGuar Methods

Collapse Expand Links
DibGuar Class, DibGuar Members, DibGuar Methods


DibGuar::getRawPia Method

DibGuar::getRawPia Method
DibGuar Class DibGuar Members DibGuar Methods

Returns the pia deconverted from cessation date to eligibility date.

C++
double getRawPia() const;
Collapse Expand Returns

The pia deconverted from cessation date to eligibility date.

Collapse Expand Group

DibGuar Methods

Collapse Expand Links
DibGuar Class, DibGuar Members, DibGuar Methods


isApplicable Method

isApplicable Method
DibGuar Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of this function. The version with no arguments uses stored data, passing it to the static version with three arguments.

Collapse Expand Overload List
Name | Description
DibGuar::isApplicable () | Determines applicability of method using stored values.
DibGuar::isApplicable (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type) | Determines applicability of method using passed values.
Collapse Expand Group

DibGuar Methods

Collapse Expand Links
DibGuar Methods


DibGuar::isApplicable Method ()

DibGuar::isApplicable Method ()
DibGuar Class DibGuar Members isApplicable Method

Determines applicability of method using stored values.

C++
bool isApplicable();
Collapse Expand Returns

True if method is applicable, false otherwise.

Collapse Expand Remarks

Returns true if eligibility is after 1978, and this is a disability case with more than 1 period of disability, or if this is an old-age or survivor case with any period of disability.

This version with no arguments calls the static version with 3 arguments.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
DibGuar Class, DibGuar Members, isApplicable Method


DibGuar::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type)

DibGuar::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type)
DibGuar Class DibGuar Members isApplicable Method

Determines applicability of method using passed values.

C++
static bool isApplicable(
    const WorkerDataGeneral& workerData,
    const PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker data.
const PiaData& piaData | Pia calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
Collapse Expand Returns

True if method is applicable, false otherwise.

Collapse Expand Remarks

Returns true if eligibility is after 1978, and this is a disability case with more than 1 period of disability, or if this is an old-age or survivor case with any period of disability.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
DibGuar Class, DibGuar Members, isApplicable Method


DibGuar::yearCpi1Cal Method

DibGuar::yearCpi1Cal Method
DibGuar Class DibGuar Members DibGuar Methods

Returns first year that benefit increases are applied.

C++
int yearCpi1Cal() const;
Collapse Expand Returns

First year that benefit increases are applied.

Collapse Expand Remarks

This should be called after colasApply has been calculated. If colasApply is true, returns year of prior disability cessation. Otherwise returns year of entitlement in life case, year of death in survivor case.

Collapse Expand Group

DibGuar Methods

Collapse Expand Links
DibGuar Class, DibGuar Members, DibGuar Methods


DibGuarLC Class

DibGuarLC Class
DibGuarLC Methods DibGuarLC Members DibGuarLC.h Classes

Manages the functions required for calculation of a disability guarantee Social Security benefit with law changes.

Collapse Expand Class Hierarchy
  DibGuarLCDibGuarLCDibGuarLC
C++
class DibGuarLC : public DibGuar;
Collapse Expand File

File: DibGuarLC.h

Module: PiaData Library

Collapse Expand Remarks

This method is used when a person has recovered from one period of disability and is claiming a subsequent benefit (old-age, disability, or death). An instance of this class is created in PiaCalLC.

Collapse Expand Group

Classes

Collapse Expand Links
DibGuarLC Methods, DibGuarLC Members, DibGuarLC.h, Classes


DibGuarLC Members

DibGuarLC Members
Enumerations DibGuarLC Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by DibGuarLC.

Collapse Expand Enumerations
Name | Description
ConvertedMfbType | The type of mfb at cessation, after conversion.
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

DibGuarLC Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
cessationMfbCal | Calculates the applicable mfb at cessation date.
convertedMfbTypeCal | Returns the type of mfb at cessation, after conversion.
dateCpiCal | Returns the date as of which the initial pia is calculated.
entDeathDateCal | Returns date of entitlement in a life case, or date of death in a survivor case.
yearCpi1Cal | Returns first year that benefit increases are applied.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
DibGuarLC | Initializes a DibGuarLC instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Computes disability guarantee PIA.
calculate | Calculates pia and mfb for this method.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCessationMfbConv | Returns the mfb based on the deconverted pia brought up to the cessation date.
getCessationMfbOrig | Returns the original mfb at the cessation date.
getColasApply | Returns true if colas apply from cessation date of prior disability to new entitlement date.
getConvertedMfbType | Returns the type of converted mfb.
getCpiYear | Returns year that benefit increases were applied.
getDiMaxApplies | Returns true if the mfb from the prior disability was determined using the Disability Maximum method.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getRawMfb | Returns the mfb based on the deconverted pia at eligibility date.
getRawPia | Returns the pia deconverted from cessation date to eligibility date.
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~DibGuarLC | Destructor.
Collapse Expand Links
Enumerations, DibGuarLC Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


DibGuarLC::DibGuarLC Constructor

DibGuarLC::DibGuarLC Constructor
DibGuarLC Class DibGuarLC Members DibGuarLC Class

Initializes a DibGuarLC instance.

C++
DibGuarLC(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear,
    const LawChangeArray& newLawChange
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker basic data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
const LawChangeArray& newLawChange | Law change parameters.
Collapse Expand Class

DibGuarLC Class

Collapse Expand Links
DibGuarLC Class, DibGuarLC Members, DibGuarLC Class


DibGuarLC::~DibGuarLC Destructor

DibGuarLC::~DibGuarLC Destructor
DibGuarLC Class DibGuarLC Members DibGuarLC Class

Destructor.

C++
virtual ~DibGuarLC();
Collapse Expand Class

DibGuarLC Class

Collapse Expand Links
DibGuarLC Class, DibGuarLC Members, DibGuarLC Class


DibGuarLC Methods

DibGuarLC Methods
DibGuarLC Class Legend Public Methods

The methods of the DibGuarLC class are listed here.

Collapse Expand Class

DibGuarLC Class

Collapse Expand Public Methods
Name | Description
isApplicable | Determines applicability of method.
Collapse Expand Links
DibGuarLC Class, Legend, Public Methods


isApplicable Method

isApplicable Method
DibGuarLC Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of this function. The version with no arguments uses stored data, passing it to the static version with five arguments.

Collapse Expand Overload List
Name | Description
DibGuarLC::isApplicable () | Determines applicability of method using stored data.
DibGuarLC::isApplicable (const DateMoyr&, const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type, const LawChangeArray&) | Determines applicability of method using passed data.
Collapse Expand Group

DibGuarLC Methods

Collapse Expand Links
DibGuarLC Methods


DibGuarLC::isApplicable Method ()

DibGuarLC::isApplicable Method ()
DibGuarLC Class DibGuarLC Members isApplicable Method

Determines applicability of method using stored data.

C++
bool isApplicable();
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

The version with no arguments calls the static version with 5 arguments.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
DibGuarLC Class, DibGuarLC Members, isApplicable Method


DibGuarLC::isApplicable Method (const DateMoyr&, const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type, const LawChangeArray&)

DibGuarLC::isApplicable Method (const DateMoyr&, const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type, const LawChangeArray&)
DibGuarLC Class DibGuarLC Members isApplicable Method

Determines applicability of method using passed data.

C++
static bool isApplicable(
    const DateMoyr& entDate,
    const WorkerDataGeneral& workerData,
    const PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi,
    const LawChangeArray& lawChange
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | The date of entitlement.
const WorkerDataGeneral& workerData | Worker basic data.
const PiaData& piaData | Pia calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
const LawChangeArray& lawChange | Law change parameters.
Collapse Expand Returns

True if method is applicable.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
DibGuarLC Class, DibGuarLC Members, isApplicable Method


DisabPeriod Class

DisabPeriod Class
DisabPeriod Methods DisabPeriod Friends DisabPeriod Members DisabPeriod.h Classes

Manages a period of disability.

Collapse Expand Class Hierarchy
  DisabPeriod
C++
class DisabPeriod;
Collapse Expand File

File: DisabPeriod.h

Module: PiaData Library

Collapse Expand Remarks

It has slots for the date of onset, first month of the waiting period, date of entitlement, date of cessation, and PIA and MFB as of the month before cessation. (The month of cessation is the month after the last month for which benefits were received.) If the disability is still open, as in a disability case, the date of cessation, and PIA and MFB just before cessation, are zero.

An array of two periods of disability are created in WorkerDataGeneral. The one at index 0 is the most recent, while the one at index 1 is the next most recent. The values in those structures are ignored if the indicator for the number of periods of disability is zero. In a disability case, the most recent period of disability is the current one.

Collapse Expand Group

Classes

Collapse Expand Links
DisabPeriod Methods, DisabPeriod Friends, DisabPeriod Members, DisabPeriod.h, Classes


DisabPeriod Members

DisabPeriod Members
DisabPeriod Class Legend Public Friends Public Methods

The following tables list the members exposed by DisabPeriod.

Collapse Expand Class

DisabPeriod Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Name | Description
DisabPeriod | Constructor.
cessationDateCheck | Checks a date of disability cessation.
deleteCessationDate | Deletes the cessation date.
deleteContents | Sets all variables to default values.
deleteEntDate | Deletes the entitlement date.
deleteOnsetDate | Deletes the onset date.
deleteWaitperDate | Deletes the first month of the waiting period.
entDateCheck | Checks a date of entitlement.
getCessationDate | Returns date of disability cessation.
getCessationMfb | Returns the mfb in the month before cessation.
getCessationPia | Returns the pia in the month before cessation.
getEntDate | Returns date of entitlement to disability.
getOnsetDate | Returns date of disability onset.
getWaitperDate | Returns first month of waiting period.
onsetDateCheck | Checks a date of disability onset.
parseString | Parses a string into a DisabPeriod.
setCessationDate | Sets the cessation date.
setCessationMfb | Sets the mfb at cessation.
setCessationPia | Sets the pia at cessation.
setEntDate | Sets the entitlement date.
setOnsetDate | Sets the onset date.
setWaitperDate | Sets the first month of the waiting period.
toString | Returns the period of disability as a string.
waitperDateCal | Calculates first month of waiting period.
waitperDateCheck | Checks a first month of waiting period for general reasonableness.
Collapse Expand Links
DisabPeriod Class, Legend, Public Friends, Public Methods


DisabPeriod::DisabPeriod Constructor

DisabPeriod::DisabPeriod Constructor
DisabPeriod Class DisabPeriod Members DisabPeriod Class

Constructor.

C++
DisabPeriod();
Collapse Expand Remarks

Initializes onsetDate to not_a_date_time and all other fields to 0.

Collapse Expand Class

DisabPeriod Class

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Class


DisabPeriod Methods

DisabPeriod Methods
DisabPeriod Class Legend Public Methods

The methods of the DisabPeriod class are listed here.

Collapse Expand Class

DisabPeriod Class

Collapse Expand Public Methods
Name | Description
cessationDateCheck | Checks a date of disability cessation.
deleteCessationDate | Deletes the cessation date.
deleteContents | Sets all variables to default values.
deleteEntDate | Deletes the entitlement date.
deleteOnsetDate | Deletes the onset date.
deleteWaitperDate | Deletes the first month of the waiting period.
entDateCheck | Checks a date of entitlement.
getCessationDate | Returns date of disability cessation.
getCessationMfb | Returns the mfb in the month before cessation.
getCessationPia | Returns the pia in the month before cessation.
getEntDate | Returns date of entitlement to disability.
getOnsetDate | Returns date of disability onset.
getWaitperDate | Returns first month of waiting period.
onsetDateCheck | Checks a date of disability onset.
parseString | Parses a string into a DisabPeriod.
setCessationDate | Sets the cessation date.
setCessationMfb | Sets the mfb at cessation.
setCessationPia | Sets the pia at cessation.
setEntDate | Sets the entitlement date.
setOnsetDate | Sets the onset date.
setWaitperDate | Sets the first month of the waiting period.
toString | Returns the period of disability as a string.
waitperDateCal | Calculates first month of waiting period.
waitperDateCheck | Checks a first month of waiting period for general reasonableness.
Collapse Expand Links
DisabPeriod Class, Legend, Public Methods


DisabPeriod::cessationDateCheck Method

DisabPeriod::cessationDateCheck Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Checks a date of disability cessation.

C++
static void cessationDateCheck(
    const DateMoyr& dateMoyr
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The date to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DICESS1 if month of cessation is out of range; of type PIA_IDS_DICESS2 if year of cessation is before 1937; of type PIA_IDS_DICESS3 if year of cessation is after maximum allowed.
Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::deleteCessationDate Method

DisabPeriod::deleteCessationDate Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Deletes the cessation date.

C++
void deleteCessationDate();
Collapse Expand Remarks

Also deletes the pia and mfb at cessation.

Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::deleteContents Method

DisabPeriod::deleteContents Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Sets all variables to default values.

C++
void deleteContents();
Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::deleteEntDate Method

DisabPeriod::deleteEntDate Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Deletes the entitlement date.

C++
void deleteEntDate();
Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::deleteOnsetDate Method

DisabPeriod::deleteOnsetDate Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Deletes the onset date.

C++
void deleteOnsetDate();
Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::deleteWaitperDate Method

DisabPeriod::deleteWaitperDate Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Deletes the first month of the waiting period.

C++
void deleteWaitperDate();
Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::entDateCheck Method

DisabPeriod::entDateCheck Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Checks a date of entitlement.

C++
static void entDateCheck(
    const DateMoyr& dateMoyr
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The date to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PRRENT1 if bad month; of type PIA_IDS_PRRENT2 if year is before 1940; of type PIA_IDS_PRRENT3 if year is after maximum allowed.
Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::getCessationDate Method

DisabPeriod::getCessationDate Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Returns date of disability cessation.

C++
const DateMoyr& getCessationDate() const;
Collapse Expand Returns

The date of disability cessation.

Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::getCessationMfb Method

DisabPeriod::getCessationMfb Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Returns the mfb in the month before cessation.

C++
float getCessationMfb() const;
Collapse Expand Returns

The mfb at cessation.

Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::getCessationPia Method

DisabPeriod::getCessationPia Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Returns the pia in the month before cessation.

C++
float getCessationPia() const;
Collapse Expand Returns

The pia at cessation.

Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::getEntDate Method

DisabPeriod::getEntDate Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Returns date of entitlement to disability.

C++
const DateMoyr& getEntDate() const;
Collapse Expand Returns

The date of entitlement to disability.

Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::getOnsetDate Method

DisabPeriod::getOnsetDate Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Returns date of disability onset.

C++
const boost::gregorian::date& getOnsetDate() const;
Collapse Expand Returns

The date of disability onset.

Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::getWaitperDate Method

DisabPeriod::getWaitperDate Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Returns first month of waiting period.

C++
const DateMoyr& getWaitperDate() const;
Collapse Expand Returns

First month of waiting period.

Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::onsetDateCheck Method

DisabPeriod::onsetDateCheck Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Checks a date of disability onset.

C++
static void onsetDateCheck(
    const boost::gregorian::date& dateModyyr
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& dateModyyr | The date to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ONSET1 if month of onset is out of range; of type PIA_IDS_ONSET2 if day of onset is out of range; of type PIA_IDS_ONSET3 if year of onset is before 1937; of type PIA_IDS_ONSET4 if year of onset is after maximum allowed.
Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::parseString Method

DisabPeriod::parseString Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Parses a string into a DisabPeriod.

C++
void parseString(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | The line to parse.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_READERR if string is not in the correct format.
Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::setCessationDate Method

DisabPeriod::setCessationDate Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Sets the cessation date.

C++
void setCessationDate(
    const DateMoyr& dateMoyr
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The new cessation date.
Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::setCessationMfb Method

DisabPeriod::setCessationMfb Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Sets the mfb at cessation.

C++
void setCessationMfb(
    float newMfb
);
Collapse Expand Parameters
Parameters | Description
float newMfb | The new mfb at cessation.
Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::setCessationPia Method

DisabPeriod::setCessationPia Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Sets the pia at cessation.

C++
void setCessationPia(
    float newPia
);
Collapse Expand Parameters
Parameters | Description
float newPia | The new pia at cessation.
Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::setEntDate Method

DisabPeriod::setEntDate Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Sets the entitlement date.

C++
void setEntDate(
    const DateMoyr& dateMoyr
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The new entitlement date.
Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::setOnsetDate Method

DisabPeriod::setOnsetDate Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Sets the onset date.

C++
void setOnsetDate(
    const boost::gregorian::date& dateModyyr
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& dateModyyr | The new onset date.
Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::setWaitperDate Method

DisabPeriod::setWaitperDate Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Sets the first month of the waiting period.

C++
void setWaitperDate(
    const DateMoyr& dateMoyr
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The new first month of the waiting period.
Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


toString Method

toString Method
DisabPeriod Methods

Returns the period of disability as a string.

Collapse Expand Description

There are two versions of the toString method. If a format argument is used, it specifies how many fields are put into the string; otherwise all four fields are put into the string.

Collapse Expand Overload List
Name | Description
DisabPeriod::toString () | Returns the period of disability as a string, using default format.
DisabPeriod::toString (const std::string&) | Returns the period of disability as a string, using specified format.
Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Methods


DisabPeriod::toString Method ()

DisabPeriod::toString Method ()
DisabPeriod Class DisabPeriod Members toString Method

Returns the period of disability as a string, using default format.

C++
std::string toString() const;
Collapse Expand Returns

The period of disability as a string.

Collapse Expand Remarks

The onset date is formatted as "modyyear", followed by the entitlement date, the first month of the waiting period, and the cessation date, in that order, formatted as "moyear", with a leading 0 on each if necessary.

Collapse Expand Group

toString Method

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, toString Method


DisabPeriod::toString Method (const std::string&)

DisabPeriod::toString Method (const std::string&)
DisabPeriod Class DisabPeriod Members toString Method

Returns the period of disability as a string, using specified format.

C++
std::string toString(
    const std::string& format
) const;
Collapse Expand Parameters
Parameters | Description
const std::string& format | Format to use.
Collapse Expand Returns

The period of disability as a string.

Collapse Expand Remarks

The format has the following meanings:

"c" | show only the onset date, the entitlement date, and the first month of the waiting period.
other | show all four dates.
Collapse Expand Group

toString Method

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, toString Method


DisabPeriod::waitperDateCal Method

DisabPeriod::waitperDateCal Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Calculates first month of waiting period.

C++
DateMoyr waitperDateCal() const;
Collapse Expand Returns

First month of waiting period, given the date of onset.

Collapse Expand Remarks

Returns the first month after onset. If onset is on the first of the month, returns the date of onset (converted to month/year format). Otherwise, returns the month after the date of onset.

Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod::waitperDateCheck Method

DisabPeriod::waitperDateCheck Method
DisabPeriod Class DisabPeriod Members DisabPeriod Methods

Checks a first month of waiting period for general reasonableness.

C++
static void waitperDateCheck(
    const DateMoyr& dateMoyr
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The date to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_WAITPD1 if bad month; of type PIA_IDS_WAITPD2 if year is before 1940; of type PIA_IDS_WAITPD3 if year is after maximum allowed.
Collapse Expand Group

DisabPeriod Methods

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Methods


DisabPeriod Friends

DisabPeriod Friends
DisabPeriod Class Public Friends

The friends of the DisabPeriod class are listed here.

Collapse Expand Class

DisabPeriod Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Links
DisabPeriod Class, Public Friends


friend class boost::serialization::access Friend

friend class boost::serialization::access Friend
DisabPeriod Class DisabPeriod Members DisabPeriod Friends

Friend class to allow serialization.

C++
friend class boost::serialization::access;
Collapse Expand Group

DisabPeriod Friends

Collapse Expand Links
DisabPeriod Class, DisabPeriod Members, DisabPeriod Friends


DisInsCode Class

DisInsCode Class
DisInsCode Constructor DisInsCode Enumerations DisInsCode Methods DisInsCode Operators DisInsCode Members dinscode.h Classes

Represents one disability insured status code.

Collapse Expand Class Hierarchy
  DisInsCode
C++
class DisInsCode;
Collapse Expand File

File: dinscode.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is used in PiaData. An array of instances is used in DisInsCodeArray.

Collapse Expand Group

Classes

Collapse Expand Links
DisInsCode Constructor, DisInsCode Enumerations, DisInsCode Methods, DisInsCode Operators, DisInsCode Members, dinscode.h, Classes


DisInsCode Members

DisInsCode Members
Enumerations DisInsCode Class Legend Public Methods

The following tables list the members exposed by DisInsCode.

Collapse Expand Enumerations
Name | Description
DisInsCodeType | Disability insured status code types.
Collapse Expand Class

DisInsCode Class

Collapse Expand Public Methods
Name | Description
ChartoCode | Converts a character to a DisInsCode::DisInsCodeType.
DisInsCode | Initializes a DisInsCode, with or without a specified insured status.
get | Returns the disability insured status code.
isDiBenie | Returns disability benefit receipt status.
isDisabilityInsured | Returns disability insured status.
set | Sets the disability insured status code.
toChar | Returns a disability insured status code as a character.
Collapse Expand Public Operators
Name | Description
== | Returns true if the DisInsCode::DisInsCodeType's are equal.
Collapse Expand Links
Enumerations, DisInsCode Class, Legend, Public Methods


DisInsCode Constructor

DisInsCode Constructor
DisInsCode Class

Initializes a DisInsCode, with or without a specified insured status.

Collapse Expand Description

There are two versions of the DisInsCode constructor. If the value of the DisInsCodeType is not specified, it is set to DisInsCodeType::NOQCS.

Collapse Expand Overload List
Name | Description
DisInsCode::DisInsCode () | Initializes data to DisInsCode::DisInsCodeType::NOQCS.
DisInsCode::DisInsCode (DisInsCodeType) | Initializes data to a new code.
Collapse Expand Class

DisInsCode Class

Collapse Expand Links
DisInsCode Class


DisInsCode::DisInsCode Constructor ()

DisInsCode::DisInsCode Constructor ()
DisInsCode Class DisInsCode Members DisInsCode Constructor

Initializes data to DisInsCode::DisInsCodeType::NOQCS.

C++
DisInsCode();
Collapse Expand Group

DisInsCode Constructor

Collapse Expand Links
DisInsCode Class, DisInsCode Members, DisInsCode Constructor


DisInsCode::DisInsCode Constructor (DisInsCodeType)

DisInsCode::DisInsCode Constructor (DisInsCodeType)
DisInsCode Class DisInsCode Members DisInsCode Constructor

Initializes data to a new code.

C++
DisInsCode(
    DisInsCodeType newCode
);
Collapse Expand Parameters
Parameters | Description
DisInsCodeType newCode | New code to use.
Collapse Expand Group

DisInsCode Constructor

Collapse Expand Links
DisInsCode Class, DisInsCode Members, DisInsCode Constructor


DisInsCode Enumerations

DisInsCode Enumerations
Enumerations DisInsCode Class Legend

The enumerations of the DisInsCode class are listed here.

Collapse Expand Enumerations
Name | Description
DisInsCodeType | Disability insured status code types.
Collapse Expand Class

DisInsCode Class

Collapse Expand Links
Enumerations, DisInsCode Class, Legend


DisInsCode::DisInsCodeType Enumeration

DisInsCode::DisInsCodeType Enumeration
dinscode.h DisInsCode Enumerations

Disability insured status code types.

C++
enum DisInsCodeType {
  NOQCS,
  FULLAND2040,
  FULLANDSPECIAL,
  FULLANDDIB,
  FULLANDBLIND,
  NOTFULLNOT2040,
  NOTFULLHAS2040,
  FULLNOT2040,
  PRIMARYDEATH,
  NONPRIMARYDEATH,
  TOTALIZED
};
Collapse Expand File

File: dinscode.h

Module: PiaData Library

Collapse Expand Members
Members | Description
NOQCS | 0 - active (no QC's to date).
FULLAND2040 | 1 - disability insured (fully insured and meets 20/40).
FULLANDSPECIAL | 2 - disability insured (fully insured and meets special test).
FULLANDDIB | 3 - disability insured (current DI beneficiary).
FULLANDBLIND | 4 - disability insured (based on blindness).
NOTFULLNOT2040 | 5 - not fully insured or 20/40 (but some QC's to date).
NOTFULLHAS2040 | 6 - not fully insured, but meets 20/40.
FULLNOT2040 | 7 - fully insured, but does not meet 20/40 or special test.
PRIMARYDEATH | 8 - death (was a primary beneficiary).
NONPRIMARYDEATH | 9 - death (was never a primary beneficiary).
TOTALIZED | T - insured for totalization benefits.
Collapse Expand Remarks

Most of these codes come from the CWHS. The last one is added for use in OACT programs.

Collapse Expand Group

DisInsCode Enumerations

Collapse Expand Links
dinscode.h, DisInsCode Enumerations


DisInsCode Methods

DisInsCode Methods
DisInsCode Class Legend Public Methods

The methods of the DisInsCode class are listed here.

Collapse Expand Class

DisInsCode Class

Collapse Expand Public Methods
Name | Description
ChartoCode | Converts a character to a DisInsCode::DisInsCodeType.
get | Returns the disability insured status code.
isDiBenie | Returns disability benefit receipt status.
isDisabilityInsured | Returns disability insured status.
set | Sets the disability insured status code.
toChar | Returns a disability insured status code as a character.
Collapse Expand Links
DisInsCode Class, Legend, Public Methods


DisInsCode::ChartoCode Method

DisInsCode::ChartoCode Method
DisInsCode Class DisInsCode Members DisInsCode Methods

Converts a character to a DisInsCode::DisInsCodeType.

C++
static DisInsCodeType ChartoCode(
    char dinscodechar
);
Collapse Expand Parameters
Parameters | Description
char dinscodechar | The character to convert.
Collapse Expand Returns

The converted DisInsCode::DisInsCodeType.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if the specified character is not one of the allowed ones (0 through 9, and T).
Collapse Expand Group

DisInsCode Methods

Collapse Expand Links
DisInsCode Class, DisInsCode Members, DisInsCode Methods


DisInsCode::get Method

DisInsCode::get Method
DisInsCode Class DisInsCode Members DisInsCode Methods

Returns the disability insured status code.

C++
DisInsCodeType get() const;
Collapse Expand Returns

The disability insured status code.

Collapse Expand Group

DisInsCode Methods

Collapse Expand Links
DisInsCode Class, DisInsCode Members, DisInsCode Methods


DisInsCode::isDiBenie Method

DisInsCode::isDiBenie Method
DisInsCode Class DisInsCode Members DisInsCode Methods

Returns disability benefit receipt status.

C++
bool isDiBenie() const;
Collapse Expand Returns

True if receiving disability benefit, false otherwise.

Collapse Expand Group

DisInsCode Methods

Collapse Expand Links
DisInsCode Class, DisInsCode Members, DisInsCode Methods


DisInsCode::isDisabilityInsured Method

DisInsCode::isDisabilityInsured Method
DisInsCode Class DisInsCode Members DisInsCode Methods

Returns disability insured status.

C++
bool isDisabilityInsured() const;
Collapse Expand Returns

True if disability insured, false otherwise.

Collapse Expand Group

DisInsCode Methods

Collapse Expand Links
DisInsCode Class, DisInsCode Members, DisInsCode Methods


DisInsCode::set Method

DisInsCode::set Method
DisInsCode Class DisInsCode Members DisInsCode Methods

Sets the disability insured status code.

C++
void set(
    DisInsCodeType newCode
);
Collapse Expand Parameters
Parameters | Description
DisInsCodeType newCode | New code to use.
Collapse Expand Group

DisInsCode Methods

Collapse Expand Links
DisInsCode Class, DisInsCode Members, DisInsCode Methods


toChar Method

toChar Method
DisInsCode Methods

Returns a disability insured status code as a character.

Collapse Expand Description

There are two versions of the toChar function. The one with no argument passes the stored disability insured status code as an argument to the static version with 1 argument.

Collapse Expand Overload List
Name | Description
DisInsCode::toChar (DisInsCodeType) | Returns the passed disability insured status code as a character.
DisInsCode::toChar () | Returns the stored disability insured status code as a character.
Collapse Expand Group

DisInsCode Methods

Collapse Expand Links
DisInsCode Methods


DisInsCode::toChar Method ()

DisInsCode::toChar Method ()
DisInsCode Class DisInsCode Members toChar Method

Returns the stored disability insured status code as a character.

C++
char toChar() const;
Collapse Expand Returns

The disability insured status code as a character.

Collapse Expand Remarks

Calls the static version of this function using the stored code.

Collapse Expand Group

toChar Method

Collapse Expand Links
DisInsCode Class, DisInsCode Members, toChar Method


DisInsCode::toChar Method (DisInsCodeType)

DisInsCode::toChar Method (DisInsCodeType)
DisInsCode Class DisInsCode Members toChar Method

Returns the passed disability insured status code as a character.

C++
static char toChar(
    DisInsCodeType newCode
);
Collapse Expand Parameters
Parameters | Description
DisInsCodeType newCode | The code to convert to a character.
Collapse Expand Returns

The disability insured status code as a character.

Collapse Expand Group

toChar Method

Collapse Expand Links
DisInsCode Class, DisInsCode Members, toChar Method


DisInsCode Operators

DisInsCode Operators
DisInsCode Class Legend

The operators of the DisInsCode class are listed here.

Collapse Expand Class

DisInsCode Class

Collapse Expand Public Operators
Name | Description
== | Returns true if the DisInsCode::DisInsCodeType's are equal.
Collapse Expand Links
DisInsCode Class, Legend


DisInsCode::== Operator

DisInsCode::== Operator
DisInsCode Class DisInsCode Members DisInsCode Operators

Returns true if the DisInsCode::DisInsCodeType's are equal.

C++
bool operator ==(
    const DisInsCode& newCode
) const;
Collapse Expand Parameters
Parameters | Description
const DisInsCode& newCode | The disability insured status code to compare against.
Collapse Expand Returns

True if the DisInsCode::DisInsCodeType's are equal.

Collapse Expand Group

DisInsCode Operators

Collapse Expand Links
DisInsCode Class, DisInsCode Members, DisInsCode Operators


DisInsCodeArray Class

DisInsCodeArray Class
DisInsCodeArray Methods DisInsCodeArray Operators DisInsCodeArray Members DisInsCodeArray.h Classes

Manages an array of annual DisInsCode's.

Collapse Expand Class Hierarchy
  DisInsCodeArray
C++
class DisInsCodeArray;
Collapse Expand File

File: DisInsCodeArray.h

Module: PiaData Library

Collapse Expand Remarks

Manages an array of annual DisInsCode's.

Collapse Expand Group

Classes

Collapse Expand Links
DisInsCodeArray Methods, DisInsCodeArray Operators, DisInsCodeArray Members, DisInsCodeArray.h, Classes


DisInsCodeArray Members

DisInsCodeArray Members
DisInsCodeArray Class Legend Public Methods

The following tables list the members exposed by DisInsCodeArray.

Collapse Expand Class

DisInsCodeArray Class

Collapse Expand Public Methods
Name | Description
DisInsCodeArray | Initializes the first and last years.
assign | Sets values for a range of years.
deleteContents | Zeroes out all data values.
getFirstYear | Returns the first year of data.
getLastYear | Returns the last year of data.
isNonzero | Returns true if any insured status code is other than DisInsCode::DisInsCodeType::NOQCS.
setFirstYear | Sets the first year of data.
setLastYear | Sets the last year of data.
toString | Returns data for one disability insured status code array as a string.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
DisInsCodeArray Class, Legend, Public Methods


DisInsCodeArray::DisInsCodeArray Constructor

DisInsCodeArray::DisInsCodeArray Constructor
DisInsCodeArray Class DisInsCodeArray Members DisInsCodeArray Class

Initializes the first and last years.

C++
DisInsCodeArray(
    int newFirstYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newFirstYear | New first year of data.
int newLastYear | New last year of data.
Collapse Expand Remarks

Resizes the data array to cover the specified span of years.

Collapse Expand Class

DisInsCodeArray Class

Collapse Expand Links
DisInsCodeArray Class, DisInsCodeArray Members, DisInsCodeArray Class


DisInsCodeArray Methods

DisInsCodeArray Methods
DisInsCodeArray Class Legend Public Methods

The methods of the DisInsCodeArray class are listed here.

Collapse Expand Class

DisInsCodeArray Class

Collapse Expand Public Methods
Name | Description
assign | Sets values for a range of years.
deleteContents | Zeroes out all data values.
getFirstYear | Returns the first year of data.
getLastYear | Returns the last year of data.
isNonzero | Returns true if any insured status code is other than DisInsCode::DisInsCodeType::NOQCS.
setFirstYear | Sets the first year of data.
setLastYear | Sets the last year of data.
toString | Returns data for one disability insured status code array as a string.
Collapse Expand Links
DisInsCodeArray Class, Legend, Public Methods


assign Method

assign Method
DisInsCodeArray Methods

Sets values for a range of years.

Collapse Expand Description

There are two versions of the assign function. The version with a DisInsCode argument sets all values for the specified range of years to the specified value. The version with a DisInsCodeArray argument copies values for corresponding years from the argument.

Collapse Expand Overload List
Name | Description
DisInsCodeArray::assign (const DisInsCode&, int, int) | Sets the data for specified years to one specified value.
DisInsCodeArray::assign (const DisInsCodeArray&, int, int) | Sets the data for specified years by copying from the newDataArray.
Collapse Expand Group

DisInsCodeArray Methods

Collapse Expand Links
DisInsCodeArray Methods


DisInsCodeArray::assign Method (const DisInsCode&, int, int)

DisInsCodeArray::assign Method (const DisInsCode&, int, int)
DisInsCodeArray Class DisInsCodeArray Members assign Method

Sets the data for specified years to one specified value.

C++
void assign(
    const DisInsCode& newData,
    int firstDataYear,
    int lastDataYear
);
Collapse Expand Parameters
Parameters | Description
const DisInsCode& newData | New value of data to be used for all specified years.
int firstDataYear | First year of data to set.
int lastDataYear | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
DisInsCodeArray Class, DisInsCodeArray Members, assign Method


DisInsCodeArray::assign Method (const DisInsCodeArray&, int, int)

DisInsCodeArray::assign Method (const DisInsCodeArray&, int, int)
DisInsCodeArray Class DisInsCodeArray Members assign Method

Sets the data for specified years by copying from the newDataArray.

C++
void assign(
    const DisInsCodeArray& newDataArray,
    int firstDataYear,
    int lastDataYear
);
Collapse Expand Parameters
Parameters | Description
const DisInsCodeArray& newDataArray | Array of new values of data.
int firstDataYear | First year of data to set.
int lastDataYear | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
DisInsCodeArray Class, DisInsCodeArray Members, assign Method


DisInsCodeArray::deleteContents Method

DisInsCodeArray::deleteContents Method
DisInsCodeArray Class DisInsCodeArray Members DisInsCodeArray Methods

Zeroes out all data values.

C++
void deleteContents();
Collapse Expand Group

DisInsCodeArray Methods

Collapse Expand Links
DisInsCodeArray Class, DisInsCodeArray Members, DisInsCodeArray Methods


DisInsCodeArray::getFirstYear Method

DisInsCodeArray::getFirstYear Method
DisInsCodeArray Class DisInsCodeArray Members DisInsCodeArray Methods

Returns the first year of data.

C++
int getFirstYear() const;
Collapse Expand Returns

The first year of data.

Collapse Expand Group

DisInsCodeArray Methods

Collapse Expand Links
DisInsCodeArray Class, DisInsCodeArray Members, DisInsCodeArray Methods


DisInsCodeArray::getLastYear Method

DisInsCodeArray::getLastYear Method
DisInsCodeArray Class DisInsCodeArray Members DisInsCodeArray Methods

Returns the last year of data.

C++
int getLastYear() const;
Collapse Expand Returns

The last year of data.

Collapse Expand Group

DisInsCodeArray Methods

Collapse Expand Links
DisInsCodeArray Class, DisInsCodeArray Members, DisInsCodeArray Methods


DisInsCodeArray::isNonzero Method

DisInsCodeArray::isNonzero Method
DisInsCodeArray Class DisInsCodeArray Members DisInsCodeArray Methods

Returns true if any insured status code is other than DisInsCode::DisInsCodeType::NOQCS.

C++
bool isNonzero() const;
Collapse Expand Returns

True if any insured status code is other than DisInsCode::DisInsCodeType::NOQCS.

Collapse Expand Group

DisInsCodeArray Methods

Collapse Expand Links
DisInsCodeArray Class, DisInsCodeArray Members, DisInsCodeArray Methods


DisInsCodeArray::setFirstYear Method

DisInsCodeArray::setFirstYear Method
DisInsCodeArray Class DisInsCodeArray Members DisInsCodeArray Methods

Sets the first year of data.

C++
void setFirstYear(
    int newFirstYear
);
Collapse Expand Parameters
Parameters | Description
int newFirstYear | New first year of data.
Collapse Expand Group

DisInsCodeArray Methods

Collapse Expand Links
DisInsCodeArray Class, DisInsCodeArray Members, DisInsCodeArray Methods


DisInsCodeArray::setLastYear Method

DisInsCodeArray::setLastYear Method
DisInsCodeArray Class DisInsCodeArray Members DisInsCodeArray Methods

Sets the last year of data.

C++
void setLastYear(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | New last year of data.
Collapse Expand Group

DisInsCodeArray Methods

Collapse Expand Links
DisInsCodeArray Class, DisInsCodeArray Members, DisInsCodeArray Methods


DisInsCodeArray::toString Method

DisInsCodeArray::toString Method
DisInsCodeArray Class DisInsCodeArray Members DisInsCodeArray Methods

Returns data for one disability insured status code array as a string.

C++
std::string toString() const;
Collapse Expand Returns

Data for one disability insured status code array as a string.

Collapse Expand Group

DisInsCodeArray Methods

Collapse Expand Links
DisInsCodeArray Class, DisInsCodeArray Members, DisInsCodeArray Methods


DisInsCodeArray Operators

DisInsCodeArray Operators
DisInsCodeArray Class Legend

The operators of the DisInsCodeArray class are listed here.

Collapse Expand Class

DisInsCodeArray Class

Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
DisInsCodeArray Class, Legend


[] Operator

[] Operator
DisInsCodeArray Operators

Functions to access an element of the array.

Collapse Expand Description

There are two versions of the [] operator. They differ only in that one is const and the other is not, so that they can be used in both const and non-const settings.

Collapse Expand Overload List
Name | Description
DisInsCodeArray::[] (int) | Returns the disability insured status code at end of year, non-const version.
DisInsCodeArray::[] (int) | Returns the disability insured status code at end of year, const version.
Collapse Expand Group

DisInsCodeArray Operators

Collapse Expand Links
DisInsCodeArray Operators


DisInsCodeArray::[] Operator (int)

DisInsCodeArray::[] Operator (int)
DisInsCodeArray Class DisInsCodeArray Members [] Operator

Returns the disability insured status code at end of year, non-const version.

C++
DisInsCode& operator [](
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which disability insured status code is desired.
Collapse Expand Returns

The disability insured status code at end of year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if year is out of range (only in debug mode).
Collapse Expand Group

[] Operator

Collapse Expand Links
DisInsCodeArray Class, DisInsCodeArray Members, [] Operator


DisInsCodeArray::[] Operator (int)

DisInsCodeArray::[] Operator (int)
DisInsCodeArray Class DisInsCodeArray Members [] Operator

Returns the disability insured status code at end of year, const version.

C++
const DisInsCode operator [](
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which disability insured status code is desired.
Collapse Expand Returns

The disability insured status code at end of year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if year is out of range (only in debug mode).
Collapse Expand Group

[] Operator

Collapse Expand Links
DisInsCodeArray Class, DisInsCodeArray Members, [] Operator


EarnProject Class

EarnProject Class
EarnProject Enumerations EarnProject Data Members EarnProject Methods EarnProject Members EarnProject.h Classes

Manages an array of earnings, with forward and backward projections and specified levels of earnings.

Collapse Expand Class Hierarchy
  EarnProject
C++
class EarnProject;
Collapse Expand File

File: EarnProject.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is used in the Anypia program.

Collapse Expand Group

Classes

Collapse Expand Links
EarnProject Enumerations, EarnProject Data Members, EarnProject Methods, EarnProject Members, EarnProject.h, Classes


EarnProject Members

EarnProject Members
Enumerations EarnProject Class Legend Public Data Members Public Methods

The following tables list the members exposed by EarnProject.

Collapse Expand Enumerations
Name | Description
earn_proj_type | Type of earnings projection.
earn_type | Type of earnings.
Collapse Expand Class

EarnProject Class

Collapse Expand Public Data Members
Name | Description
PERC_HIGH | Highest acceptable projection percentage.
PERC_LOW | Lowest acceptable projection percentage.
earnpebs | Worker earnings, 1937 to maxyear, as read in.
Collapse Expand Public Methods
Name | Description
EarnProject | Initializes this structure.
anyEntered | Returns true if any earnings are entered.
deleteContents | Initializes all variables to default values.
earnpebsCheck | Checks earnings.
earntypeCheck | Checks type of earnings.
getEarntype | Returns array of indicators for type of earnings.
getFirstYear | Returns first year of earnings.
getLastYear | Returns last year of earnings.
getPercback | Returns percentage used in backwards projection.
getPercfwrd | Returns percentage used in forwards projection.
getProjback | Returns backward projection indicator.
getProjfwrd | Returns forward projection indicator.
ibegin2Check | Checks for first year of earnings in bounds.
ibeginCheck | Checks for first year of earnings within bounds, using passed values, with a backward projection.
iendCheck | Checks for last year of earnings within bounds.
need_aw | Returns true if earnings are projected in last two years of historical period.
percbackCheck | Checks backward projection percentage.
percfwrdCheck | Checks forward projection percentage.
projbackCheck1 | Checks backward projection indicator in general case.
projbackCheck2 | Checks backward projection indicator in backward projection case.
project | Projects OASDI-covered earnings for the specified worker.
projfwrdCheck1 | Checks forward projection indicator in general case.
projfwrdCheck2 | Checks forward projection indicator in forward projection case.
setEarnpebs | Sets earnings for specified year.
setEarntype | Sets type of earnings for specified year.
setFirstYear | Sets first year of specified earnings (earnings could be projected backward before this year).
setLastYear | Sets last year of specified earnings (earnings could be projected forward after this year).
setPebsData | Sets some Statement data.
setPebsEarn | Sets last year of Statement earnings when computation year changes, or after a Statement calculation has been done.
setPercback | Sets backward projection percentage.
setPercfwrd | Sets percentage in forward projection.
setProjback | Sets backward projection indicator.
setProjfwrd | Sets forward projection indicator.
toString | Returns description of type of earnings.
yearsCheck | Checks for first and last year of earnings within bounds.
zeroEarn | Zeroes out earnings before firstYear and after lastYear.
~EarnProject | Destroys this structure.
Collapse Expand Links
Enumerations, EarnProject Class, Legend, Public Data Members, Public Methods


EarnProject::EarnProject Constructor

EarnProject::EarnProject Constructor
EarnProject Class EarnProject Members EarnProject Class

Initializes this structure.

C++
explicit EarnProject(
    int newMaxYear
);
Collapse Expand Parameters
Parameters | Description
int newMaxYear | Maximum projected year. Arrays start in 1937.
Collapse Expand Class

EarnProject Class

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Class


EarnProject::~EarnProject Destructor

EarnProject::~EarnProject Destructor
EarnProject Class EarnProject Members EarnProject Class

Destroys this structure.

C++
virtual ~EarnProject();
Collapse Expand Class

EarnProject Class

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Class


EarnProject Enumerations

EarnProject Enumerations
Enumerations EarnProject Class Legend

The enumerations of the EarnProject class are listed here.

Collapse Expand Enumerations
Name | Description
earn_proj_type | Type of earnings projection.
earn_type | Type of earnings.
Collapse Expand Class

EarnProject Class

Collapse Expand Links
Enumerations, EarnProject Class, Legend


EarnProject::earn_proj_type Enumeration

EarnProject::earn_proj_type Enumeration
EarnProject.h EarnProject Enumerations

Type of earnings projection.

C++
enum earn_proj_type {
  NO_PROJ,
  AVGWAGE_PROJ,
  CONSTANT_PROJ
};
Collapse Expand File

File: EarnProject.h

Module: PiaData Library

Collapse Expand Members
Members | Description
NO_PROJ | No projection.
AVGWAGE_PROJ | Projection related to average wage increase.
CONSTANT_PROJ | Projection by a constant percentage.
Collapse Expand Remarks

There are two instances of this enum in this class, one for a backward projection and one for a forward projection.

Collapse Expand Group

EarnProject Enumerations

Collapse Expand Links
EarnProject.h, EarnProject Enumerations


EarnProject::earn_type Enumeration

EarnProject::earn_type Enumeration
EarnProject.h EarnProject Enumerations

Type of earnings.

C++
enum earn_type {
  ENTERED,
  MAXIMUM,
  HIGH,
  AVERAGE,
  LOW,
  OLDLAW_MAXIMUM,
  CHILDCARE_YEAR,
  NUM_TYPES
};
Collapse Expand File

File: EarnProject.h

Module: PiaData Library

Collapse Expand Members
Members | Description
ENTERED | Entered earnings.
MAXIMUM | Maximum earnings.
HIGH | High earnings.
AVERAGE | Average earnings.
LOW | Low earnings.
OLDLAW_MAXIMUM | Old-law maximum.
CHILDCARE_YEAR | Childcare year.
NUM_TYPES | Number of earnings types.
Collapse Expand Group

EarnProject Enumerations

Collapse Expand Links
EarnProject.h, EarnProject Enumerations


EarnProject Data Members

EarnProject Data Members
EarnProject Class Legend Public Data Members

The data members of the EarnProject class are listed here.

Collapse Expand Class

EarnProject Class

Collapse Expand Public Data Members
Name | Description
PERC_HIGH | Highest acceptable projection percentage.
PERC_LOW | Lowest acceptable projection percentage.
earnpebs | Worker earnings, 1937 to maxyear, as read in.
Collapse Expand Links
EarnProject Class, Legend, Public Data Members


EarnProject::PERC_HIGH Data Member

EarnProject::PERC_HIGH Data Member
EarnProject Class EarnProject Members EarnProject Data Members

Highest acceptable projection percentage.

C++
const double PERC_HIGH;
Collapse Expand Group

EarnProject Data Members

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Data Members


EarnProject::PERC_LOW Data Member

EarnProject::PERC_LOW Data Member
EarnProject Class EarnProject Members EarnProject Data Members

Lowest acceptable projection percentage.

C++
const double PERC_LOW;
Collapse Expand Group

EarnProject Data Members

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Data Members


EarnProject::earnpebs Data Member

EarnProject::earnpebs Data Member
EarnProject Class EarnProject Members EarnProject Data Members

Worker earnings, 1937 to maxyear, as read in.

C++
AverageWage earnpebs;
Collapse Expand Group

EarnProject Data Members

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Data Members


EarnProject Methods

EarnProject Methods
EarnProject Class Legend Public Methods

The methods of the EarnProject class are listed here.

Collapse Expand Class

EarnProject Class

Collapse Expand Public Methods
Name | Description
anyEntered | Returns true if any earnings are entered.
deleteContents | Initializes all variables to default values.
earnpebsCheck | Checks earnings.
earntypeCheck | Checks type of earnings.
getEarntype | Returns array of indicators for type of earnings.
getFirstYear | Returns first year of earnings.
getLastYear | Returns last year of earnings.
getPercback | Returns percentage used in backwards projection.
getPercfwrd | Returns percentage used in forwards projection.
getProjback | Returns backward projection indicator.
getProjfwrd | Returns forward projection indicator.
ibegin2Check | Checks for first year of earnings in bounds.
ibeginCheck | Checks for first year of earnings within bounds, using passed values, with a backward projection.
iendCheck | Checks for last year of earnings within bounds.
need_aw | Returns true if earnings are projected in last two years of historical period.
percbackCheck | Checks backward projection percentage.
percfwrdCheck | Checks forward projection percentage.
projbackCheck1 | Checks backward projection indicator in general case.
projbackCheck2 | Checks backward projection indicator in backward projection case.
project | Projects OASDI-covered earnings for the specified worker.
projfwrdCheck1 | Checks forward projection indicator in general case.
projfwrdCheck2 | Checks forward projection indicator in forward projection case.
setEarnpebs | Sets earnings for specified year.
setEarntype | Sets type of earnings for specified year.
setFirstYear | Sets first year of specified earnings (earnings could be projected backward before this year).
setLastYear | Sets last year of specified earnings (earnings could be projected forward after this year).
setPebsData | Sets some Statement data.
setPebsEarn | Sets last year of Statement earnings when computation year changes, or after a Statement calculation has been done.
setPercback | Sets backward projection percentage.
setPercfwrd | Sets percentage in forward projection.
setProjback | Sets backward projection indicator.
setProjfwrd | Sets forward projection indicator.
toString | Returns description of type of earnings.
yearsCheck | Checks for first and last year of earnings within bounds.
zeroEarn | Zeroes out earnings before firstYear and after lastYear.
Collapse Expand Links
EarnProject Class, Legend, Public Methods


EarnProject::anyEntered Method

EarnProject::anyEntered Method
EarnProject Class EarnProject Members EarnProject Methods

Returns true if any earnings are entered.

C++
bool anyEntered() const;
Collapse Expand Returns

True if any earnings are entered.

Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::deleteContents Method

EarnProject::deleteContents Method
EarnProject Class EarnProject Members EarnProject Methods

Initializes all variables to default values.

C++
virtual void deleteContents();
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::earnpebsCheck Method

EarnProject::earnpebsCheck Method
EarnProject Class EarnProject Members EarnProject Methods

Checks earnings.

C++
static void earnpebsCheck(
    double earnpebst
);
Collapse Expand Parameters
Parameters | Description
double earnpebst | The earnings to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_EARNPEBS if earnings are out of range.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::earntypeCheck Method

EarnProject::earntypeCheck Method
EarnProject Class EarnProject Members EarnProject Methods

Checks type of earnings.

C++
static void earntypeCheck(
    int earntypet
);
Collapse Expand Parameters
Parameters | Description
int earntypet | Type of earnings to check. The possible values are in earn_type.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_EARNTYPE if type of earnings is out of range.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::getEarntype Method

EarnProject::getEarntype Method
EarnProject Class EarnProject Members EarnProject Methods

Returns array of indicators for type of earnings.

C++
const IntAnnual& getEarntype() const;
Collapse Expand Returns

Array of indicators for type of earnings. The possible values for the entries are in earn_type.

Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::getFirstYear Method

EarnProject::getFirstYear Method
EarnProject Class EarnProject Members EarnProject Methods

Returns first year of earnings.

C++
int getFirstYear() const;
Collapse Expand Returns

First year of earnings.

Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::getLastYear Method

EarnProject::getLastYear Method
EarnProject Class EarnProject Members EarnProject Methods

Returns last year of earnings.

C++
int getLastYear() const;
Collapse Expand Returns

Last year of earnings.

Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::getPercback Method

EarnProject::getPercback Method
EarnProject Class EarnProject Members EarnProject Methods

Returns percentage used in backwards projection.

C++
double getPercback() const;
Collapse Expand Returns

Percentage used in backwards projection.

Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::getPercfwrd Method

EarnProject::getPercfwrd Method
EarnProject Class EarnProject Members EarnProject Methods

Returns percentage used in forwards projection.

C++
double getPercfwrd() const;
Collapse Expand Returns

Percentage used in forwards projection.

Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::getProjback Method

EarnProject::getProjback Method
EarnProject Class EarnProject Members EarnProject Methods

Returns backward projection indicator.

C++
earn_proj_type getProjback() const;
Collapse Expand Returns

Backward projection indicator.

Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::getProjfwrd Method

EarnProject::getProjfwrd Method
EarnProject Class EarnProject Members EarnProject Methods

Returns forward projection indicator.

C++
earn_proj_type getProjfwrd() const;
Collapse Expand Returns

Forward projection indicator.

Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::ibegin2Check Method

EarnProject::ibegin2Check Method
EarnProject Class EarnProject Members EarnProject Methods

Checks for first year of earnings in bounds.

C++
static void ibegin2Check(
    int ibegint
);
Collapse Expand Parameters
Parameters | Description
int ibegint | Year to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BEGIN3 if first year of earnings is before 1937; of type PIA_IDS_BEGIN5 if first year of earnings is after maximum year allowed.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::ibeginCheck Method

EarnProject::ibeginCheck Method
EarnProject Class EarnProject Members EarnProject Methods

Checks for first year of earnings within bounds, using passed values, with a backward projection.

C++
static void ibeginCheck(
    int ibegint,
    int ibegin1t
);
Collapse Expand Parameters
Parameters | Description
int ibegint | First year of earnings in backward projection period.
int ibegin1t | Last year of earnings in backward projection period.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BEGIN2 if last year of earnings is before first year of earnings in backward projection period.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::iendCheck Method

EarnProject::iendCheck Method
EarnProject Class EarnProject Members EarnProject Methods

Checks for last year of earnings within bounds.

C++
static void iendCheck(
    int iendt
);
Collapse Expand Parameters
Parameters | Description
int iendt | Last year of earnings.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_END1 if last year of earnings is before 1937; of type PIA_IDS_END2 if last year of earnings is after maximum year allowed.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::need_aw Method

EarnProject::need_aw Method
EarnProject Class EarnProject Members EarnProject Methods

Returns true if earnings are projected in last two years of historical period.

C++
bool need_aw(
    int year,
    int iendt
) const;
Collapse Expand Parameters
Parameters | Description
int year | First year of projection period.
int iendt | Last year of projected earnings.
Collapse Expand Returns

True if earnings are projected in last two years of historical period.

Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::percbackCheck Method

EarnProject::percbackCheck Method
EarnProject Class EarnProject Members EarnProject Methods

Checks backward projection percentage.

C++
static void percbackCheck(
    double percbackt
);
Collapse Expand Parameters
Parameters | Description
double percbackt | Percentage to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PERCBACK if backward projection percentage is out of range.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::percfwrdCheck Method

EarnProject::percfwrdCheck Method
EarnProject Class EarnProject Members EarnProject Methods

Checks forward projection percentage.

C++
static void percfwrdCheck(
    double percfwrdt
);
Collapse Expand Parameters
Parameters | Description
double percfwrdt | Percentage to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PERCFWRD if backward projection percentage is out of range.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::projbackCheck1 Method

EarnProject::projbackCheck1 Method
EarnProject Class EarnProject Members EarnProject Methods

Checks backward projection indicator in general case.

C++
static void projbackCheck1(
    int projbackt
);
Collapse Expand Parameters
Parameters | Description
int projbackt | Projection indicator to check. The possible values are in earn_proj_type.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PROJBACK1 if backward projection indicator is not in the earn_proj_type range.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::projbackCheck2 Method

EarnProject::projbackCheck2 Method
EarnProject Class EarnProject Members EarnProject Methods

Checks backward projection indicator in backward projection case.

C++
static void projbackCheck2(
    int projbackt
);
Collapse Expand Parameters
Parameters | Description
int projbackt | Projection indicator to check. The possible values are in earn_proj_type.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PROJBACK2 if backward projection indicator is not an earn_proj_type other than earn_proj_type::NO_PROJ.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::project Method

EarnProject::project Method
EarnProject Class EarnProject Members EarnProject Methods

Projects OASDI-covered earnings for the specified worker.

C++
bool project(
    WorkerDataGeneral& workerData,
    const Awinc& fqinc
) const;
Collapse Expand Parameters
Parameters | Description
WorkerDataGeneral& workerData | Worker basic data.
const Awinc& fqinc | Average wage increases.
Collapse Expand Returns

True if any earnings go over the maximum allowed, false otherwise.

Collapse Expand Remarks

First sets all the earnings in the WorkerDataGeneral for the period within the non-projected period. Then projects backwards, if the trigger is not earn_proj_type::NO_PROJ. The projection goes backwards from the beginning of the non-projected period, using annual factors that depend on the type of projection. Then projects forwards, in a similar fashion.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_EARNPROJ if projection year is out of range (only in debug mode).
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::projfwrdCheck1 Method

EarnProject::projfwrdCheck1 Method
EarnProject Class EarnProject Members EarnProject Methods

Checks forward projection indicator in general case.

C++
static void projfwrdCheck1(
    int projfwrdt
);
Collapse Expand Parameters
Parameters | Description
int projfwrdt | Projection indicator to check. The possible values are in earn_proj_type.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PROJFWRD1 if forward projection indicator is not in the earn_proj_type range.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::projfwrdCheck2 Method

EarnProject::projfwrdCheck2 Method
EarnProject Class EarnProject Members EarnProject Methods

Checks forward projection indicator in forward projection case.

C++
static void projfwrdCheck2(
    int projfwrdt
);
Collapse Expand Parameters
Parameters | Description
int projfwrdt | Projection indicator to check. The possible values are in earn_proj_type.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PROJFWRD2 if forward projection indicator is not an earn_proj_type other than earn_proj_type::NO_PROJ.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::setEarnpebs Method

EarnProject::setEarnpebs Method
EarnProject Class EarnProject Members EarnProject Methods

Sets earnings for specified year.

C++
void setEarnpebs(
    int year,
    double newEarnpebs
);
Collapse Expand Parameters
Parameters | Description
int year | Year of earnings.
double newEarnpebs | Amount of earnings.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::setEarntype Method

EarnProject::setEarntype Method
EarnProject Class EarnProject Members EarnProject Methods

Sets type of earnings for specified year.

C++
void setEarntype(
    int year,
    int newEarntype
);
Collapse Expand Parameters
Parameters | Description
int year | Year of earnings.
int newEarntype | Type of earnings. The possible values are in earn_type.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_EARNTYPEYR if year is out of range (only in debug mode); of type PIA_IDS_EARNTYPE if type of earnings is out of range (only in debug mode).
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::setFirstYear Method

EarnProject::setFirstYear Method
EarnProject Class EarnProject Members EarnProject Methods

Sets first year of specified earnings (earnings could be projected backward before this year).

C++
void setFirstYear(
    int newFirstYear
);
Collapse Expand Parameters
Parameters | Description
int newFirstYear | New first year of earnings before projection.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::setLastYear Method

EarnProject::setLastYear Method
EarnProject Class EarnProject Members EarnProject Methods

Sets last year of specified earnings (earnings could be projected forward after this year).

C++
void setLastYear(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | New last year of earnings before projection.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::setPebsData Method

EarnProject::setPebsData Method
EarnProject Class EarnProject Members EarnProject Methods

Sets some Statement data.

C++
void setPebsData(
    int year,
    int ibegint
);
Collapse Expand Parameters
Parameters | Description
int year | First year of projection period (used to set last year of earnings).
int ibegint | First year of earnings.
Collapse Expand Remarks

There is no backward projection for a Statement. There is a forward projection, at the average wage rate.

Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::setPebsEarn Method

EarnProject::setPebsEarn Method
EarnProject Class EarnProject Members EarnProject Methods

Sets last year of Statement earnings when computation year changes, or after a Statement calculation has been done.

C++
void setPebsEarn(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | First year of projection period.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::setPercback Method

EarnProject::setPercback Method
EarnProject Class EarnProject Members EarnProject Methods

Sets backward projection percentage.

C++
void setPercback(
    double newPercback
);
Collapse Expand Parameters
Parameters | Description
double newPercback | New backward projection percentage.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::setPercfwrd Method

EarnProject::setPercfwrd Method
EarnProject Class EarnProject Members EarnProject Methods

Sets percentage in forward projection.

C++
void setPercfwrd(
    double newPercfwrd
);
Collapse Expand Parameters
Parameters | Description
double newPercfwrd | New forward projection percentage.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::setProjback Method

EarnProject::setProjback Method
EarnProject Class EarnProject Members EarnProject Methods

Sets backward projection indicator.

C++
void setProjback(
    int newProjback
);
Collapse Expand Parameters
Parameters | Description
int newProjback | New backward projection indicator. The possible values are in earn_proj_type.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::setProjfwrd Method

EarnProject::setProjfwrd Method
EarnProject Class EarnProject Members EarnProject Methods

Sets forward projection indicator.

C++
void setProjfwrd(
    int newProjfwrd
);
Collapse Expand Parameters
Parameters | Description
int newProjfwrd | New forward projection indicator. The possible values are in earn_proj_type.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


EarnProject::toString Method

EarnProject::toString Method
EarnProject Class EarnProject Members EarnProject Methods

Returns description of type of earnings.

C++
std::string toString(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which type of earnings is desired.
Collapse Expand Returns

Description of type of earnings.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_EARNMAL if year is before 1937 (only in debug mode).
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


yearsCheck Method

yearsCheck Method
EarnProject Methods

Checks for first and last year of earnings within bounds.

Collapse Expand Description

There are two versions of this function, to check just the first and last years, or to check both periods specified by years.

Collapse Expand Overload List
Name | Description
EarnProject::yearsCheck (int, int) | Checks for first and last year of earnings within bounds.
EarnProject::yearsCheck (int, int, int, int) | Checks for first and last year of earnings within bounds.
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Methods


EarnProject::yearsCheck Method (int, int)

EarnProject::yearsCheck Method (int, int)
EarnProject Class EarnProject Members yearsCheck Method

Checks for first and last year of earnings within bounds.

C++
void yearsCheck(
    int ibegint,
    int iendt
) const;
Collapse Expand Parameters
Parameters | Description
int ibegint | First year of earnings in backward projection period.
int iendt | Last year of earnings in forward projection period.
Collapse Expand Remarks

Calls the static version with 4 arguments, adding firstYear and lastYear as arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_END1 if first year of earnings in forward projection period is before last year of earnings in backward projection period; of type PIA_IDS_END3 if first year of earnings in forward projection period is after last year of earnings in forward projection period; of type PIA_IDS_END4 if the total number of years of earnings is greater than the maximum allowed (MAXYRS); of type PIA_IDS_END1 if last year of earnings is before 1937; of type PIA_IDS_END2 if last year of earnings is after maximum year allowed.
Collapse Expand Group

yearsCheck Method

Collapse Expand Links
EarnProject Class, EarnProject Members, yearsCheck Method


EarnProject::yearsCheck Method (int, int, int, int)

EarnProject::yearsCheck Method (int, int, int, int)
EarnProject Class EarnProject Members yearsCheck Method

Checks for first and last year of earnings within bounds.

C++
static void yearsCheck(
    int ibegint,
    int ibegin1t,
    int iendt,
    int iend1t
);
Collapse Expand Parameters
Parameters | Description
int ibegint | First year of earnings in backward projection period.
int ibegin1t | Last year of earnings in backward projection period.
int iendt | Last year of earnings in forward projection period.
int iend1t | First year of earnings in forward projection period.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_END1 if first year of earnings in forward projection period is before last year of earnings in backward projection period; of type PIA_IDS_END3 if first year of earnings in forward projection period is after last year of earnings in forward projection period; of type PIA_IDS_END4 if the total number of years of earnings is greater than the maximum allowed (MAXYRS); of type PIA_IDS_END1 if last year of earnings is before 1937; of type PIA_IDS_END2 if last year of earnings is after maximum year allowed.
Collapse Expand Group

yearsCheck Method

Collapse Expand Links
EarnProject Class, EarnProject Members, yearsCheck Method


EarnProject::zeroEarn Method

EarnProject::zeroEarn Method
EarnProject Class EarnProject Members EarnProject Methods

Zeroes out earnings before firstYear and after lastYear.

C++
void zeroEarn();
Collapse Expand Group

EarnProject Methods

Collapse Expand Links
EarnProject Class, EarnProject Members, EarnProject Methods


FieldOfficeInfo Class

FieldOfficeInfo Class
FieldOfficeInfo Data Members FieldOfficeInfo Methods FieldOfficeInfo Members foinfo.h Classes

Parent of classes that manage the name and address of the field office.

Collapse Expand Class Hierarchy
  FieldOfficeInfo
C++
class FieldOfficeInfo;
Collapse Expand File

File: foinfo.h

Module: PiaData Library

Collapse Expand Remarks

This class is abstract; use FieldOfficeInfoFile or FieldOfficeInfoNonFile.

Collapse Expand See Also

FieldOfficeInfoFile, FieldOfficeInfoNonFile

Collapse Expand Group

Classes

Collapse Expand Links
FieldOfficeInfo Data Members, FieldOfficeInfo Methods, FieldOfficeInfo Members, foinfo.h, Classes


FieldOfficeInfo Members

FieldOfficeInfo Members
FieldOfficeInfo Class Legend Public Data Members Public Methods

The following tables list the members exposed by FieldOfficeInfo.

Collapse Expand Class

FieldOfficeInfo Class

Collapse Expand Public Data Members
Name | Description
numLines | Number of address lines (4).
Collapse Expand Public Methods
Name | Description
FieldOfficeInfo | Initializes field office info.
getAddress | Returns one line of field office address.
getFieldOfficeName | Returns field office manager's name.
getFieldOfficeTitle | Returns field office manager's title.
read | Read field office info.
setAddress | Sets one line of field office address.
setData | Sets field office info.
setFieldOfficeName | Sets field office manager's name.
setFieldOfficeTitle | Sets field office manager's title.
write | Write field office info.
~FieldOfficeInfo | Destroys field office information.
Collapse Expand Links
FieldOfficeInfo Class, Legend, Public Data Members, Public Methods


FieldOfficeInfo::FieldOfficeInfo Constructor

FieldOfficeInfo::FieldOfficeInfo Constructor
FieldOfficeInfo Class FieldOfficeInfo Members FieldOfficeInfo Class

Initializes field office info.

C++
FieldOfficeInfo();
Collapse Expand Class

FieldOfficeInfo Class

Collapse Expand Links
FieldOfficeInfo Class, FieldOfficeInfo Members, FieldOfficeInfo Class


FieldOfficeInfo::~FieldOfficeInfo Destructor

FieldOfficeInfo::~FieldOfficeInfo Destructor
FieldOfficeInfo Class FieldOfficeInfo Members FieldOfficeInfo Class

Destroys field office information.

C++
virtual ~FieldOfficeInfo();
Collapse Expand Class

FieldOfficeInfo Class

Collapse Expand Links
FieldOfficeInfo Class, FieldOfficeInfo Members, FieldOfficeInfo Class


FieldOfficeInfo Data Members

FieldOfficeInfo Data Members
FieldOfficeInfo Class Legend Public Data Members

The data members of the FieldOfficeInfo class are listed here.

Collapse Expand Class

FieldOfficeInfo Class

Collapse Expand Public Data Members
Name | Description
numLines | Number of address lines (4).
Collapse Expand Links
FieldOfficeInfo Class, Legend, Public Data Members


FieldOfficeInfo::numLines Data Member

FieldOfficeInfo::numLines Data Member
FieldOfficeInfo Class FieldOfficeInfo Members FieldOfficeInfo Data Members

Number of address lines (4).

C++
const int numLines = 4;
Collapse Expand Group

FieldOfficeInfo Data Members

Collapse Expand Links
FieldOfficeInfo Class, FieldOfficeInfo Members, FieldOfficeInfo Data Members


FieldOfficeInfo Methods

FieldOfficeInfo Methods
FieldOfficeInfo Class Legend Public Methods

The methods of the FieldOfficeInfo class are listed here.

Collapse Expand Class

FieldOfficeInfo Class

Collapse Expand Public Methods
Name | Description
getAddress | Returns one line of field office address.
getFieldOfficeName | Returns field office manager's name.
getFieldOfficeTitle | Returns field office manager's title.
read | Read field office info.
setAddress | Sets one line of field office address.
setData | Sets field office info.
setFieldOfficeName | Sets field office manager's name.
setFieldOfficeTitle | Sets field office manager's title.
write | Write field office info.
Collapse Expand Links
FieldOfficeInfo Class, Legend, Public Methods


FieldOfficeInfo::getAddress Method

FieldOfficeInfo::getAddress Method
FieldOfficeInfo Class FieldOfficeInfo Members FieldOfficeInfo Methods

Returns one line of field office address.

C++
const std::string& getAddress(
    int line
) const;
Collapse Expand Parameters
Parameters | Description
int line | Desired line (0 to 3).
Collapse Expand Returns

One line of field office address.

Collapse Expand Group

FieldOfficeInfo Methods

Collapse Expand Links
FieldOfficeInfo Class, FieldOfficeInfo Members, FieldOfficeInfo Methods


FieldOfficeInfo::getFieldOfficeName Method

FieldOfficeInfo::getFieldOfficeName Method
FieldOfficeInfo Class FieldOfficeInfo Members FieldOfficeInfo Methods

Returns field office manager's name.

C++
const std::string& getFieldOfficeName() const;
Collapse Expand Returns

Field office manager's name.

Collapse Expand Group

FieldOfficeInfo Methods

Collapse Expand Links
FieldOfficeInfo Class, FieldOfficeInfo Members, FieldOfficeInfo Methods


FieldOfficeInfo::getFieldOfficeTitle Method

FieldOfficeInfo::getFieldOfficeTitle Method
FieldOfficeInfo Class FieldOfficeInfo Members FieldOfficeInfo Methods

Returns field office manager's title.

C++
const std::string& getFieldOfficeTitle() const;
Collapse Expand Returns

Field office manager's title.

Collapse Expand Group

FieldOfficeInfo Methods

Collapse Expand Links
FieldOfficeInfo Class, FieldOfficeInfo Members, FieldOfficeInfo Methods


FieldOfficeInfo::read Method

FieldOfficeInfo::read Method
FieldOfficeInfo Class FieldOfficeInfo Members FieldOfficeInfo Methods

Read field office info.

C++
virtual void read() = 0;
Collapse Expand Group

FieldOfficeInfo Methods

Collapse Expand Links
FieldOfficeInfo Class, FieldOfficeInfo Members, FieldOfficeInfo Methods


FieldOfficeInfo::setAddress Method

FieldOfficeInfo::setAddress Method
FieldOfficeInfo Class FieldOfficeInfo Members FieldOfficeInfo Methods

Sets one line of field office address.

C++
void setAddress(
    int line,
    const std::string& newAddress
);
Collapse Expand Parameters
Parameters | Description
int line | Desired line (0 to 3).
const std::string& newAddress | New address line.
Collapse Expand Group

FieldOfficeInfo Methods

Collapse Expand Links
FieldOfficeInfo Class, FieldOfficeInfo Members, FieldOfficeInfo Methods


FieldOfficeInfo::setData Method

FieldOfficeInfo::setData Method
FieldOfficeInfo Class FieldOfficeInfo Members FieldOfficeInfo Methods

Sets field office info.

C++
virtual void setData() = 0;
Collapse Expand Group

FieldOfficeInfo Methods

Collapse Expand Links
FieldOfficeInfo Class, FieldOfficeInfo Members, FieldOfficeInfo Methods


FieldOfficeInfo::setFieldOfficeName Method

FieldOfficeInfo::setFieldOfficeName Method
FieldOfficeInfo Class FieldOfficeInfo Members FieldOfficeInfo Methods

Sets field office manager's name.

C++
void setFieldOfficeName(
    const std::string& newName
);
Collapse Expand Parameters
Parameters | Description
const std::string& newName | New name.
Collapse Expand Group

FieldOfficeInfo Methods

Collapse Expand Links
FieldOfficeInfo Class, FieldOfficeInfo Members, FieldOfficeInfo Methods


FieldOfficeInfo::setFieldOfficeTitle Method

FieldOfficeInfo::setFieldOfficeTitle Method
FieldOfficeInfo Class FieldOfficeInfo Members FieldOfficeInfo Methods

Sets field office manager's title.

C++
void setFieldOfficeTitle(
    const std::string& newTitle
);
Collapse Expand Parameters
Parameters | Description
const std::string& newTitle | New title.
Collapse Expand Group

FieldOfficeInfo Methods

Collapse Expand Links
FieldOfficeInfo Class, FieldOfficeInfo Members, FieldOfficeInfo Methods


FieldOfficeInfo::write Method

FieldOfficeInfo::write Method
FieldOfficeInfo Class FieldOfficeInfo Members FieldOfficeInfo Methods

Write field office info.

C++
virtual void write() = 0;
Collapse Expand Group

FieldOfficeInfo Methods

Collapse Expand Links
FieldOfficeInfo Class, FieldOfficeInfo Members, FieldOfficeInfo Methods


FieldOfficeInfoFile Class

FieldOfficeInfoFile Class
FieldOfficeInfoFile Methods FieldOfficeInfoFile Members FieldOfficeInfoFile.h Classes

Reads and writes field office information from and to a file.

Collapse Expand Class Hierarchy
  FieldOfficeInfoFileFieldOfficeInfoFile
C++
class FieldOfficeInfoFile : public FieldOfficeInfo;
Collapse Expand File

File: FieldOfficeInfoFile.h

Module: PiaData Library

Collapse Expand Remarks

See FieldOfficeInfoNonFile for a version of this class that stores the field office information internally.

Collapse Expand See Also

FieldOfficeInfoNonFile

Collapse Expand Group

Classes

Collapse Expand Links
FieldOfficeInfoFile Methods, FieldOfficeInfoFile Members, FieldOfficeInfoFile.h, Classes


FieldOfficeInfoFile Members

FieldOfficeInfoFile Members
FieldOfficeInfoFile Class Legend Public Data Members Public Methods

The following tables list the members exposed by FieldOfficeInfoFile.

Collapse Expand Class

FieldOfficeInfoFile Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
numLines | Number of address lines (4).
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
FieldOfficeInfoFile | Initializes field office info.
getAddress | Returns one line of field office address.
getFieldOfficeName | Returns field office manager's name.
getFieldOfficeTitle | Returns field office manager's title.
read | Reads field office information from disk.
setAddress | Sets one line of field office address.
setData | Dummy function for file version.
setFieldOfficeName | Sets field office manager's name.
setFieldOfficeTitle | Sets field office manager's title.
write | Saves field office information to disk.
~FieldOfficeInfoFile | Destroys field office info.
Collapse Expand Links
FieldOfficeInfoFile Class, Legend, Public Data Members, Public Methods


FieldOfficeInfoFile::FieldOfficeInfoFile Constructor

FieldOfficeInfoFile::FieldOfficeInfoFile Constructor
FieldOfficeInfoFile Class FieldOfficeInfoFile Members FieldOfficeInfoFile Class

Initializes field office info.

C++
FieldOfficeInfoFile(
    const std::string& newDirectory
);
Collapse Expand Parameters
Parameters | Description
const std::string& newDirectory | Directory with field office file.
Collapse Expand Class

FieldOfficeInfoFile Class

Collapse Expand Links
FieldOfficeInfoFile Class, FieldOfficeInfoFile Members, FieldOfficeInfoFile Class


FieldOfficeInfoFile::~FieldOfficeInfoFile Destructor

FieldOfficeInfoFile::~FieldOfficeInfoFile Destructor
FieldOfficeInfoFile Class FieldOfficeInfoFile Members FieldOfficeInfoFile Class

Destroys field office info.

C++
~FieldOfficeInfoFile();
Collapse Expand Class

FieldOfficeInfoFile Class

Collapse Expand Links
FieldOfficeInfoFile Class, FieldOfficeInfoFile Members, FieldOfficeInfoFile Class


FieldOfficeInfoFile Methods

FieldOfficeInfoFile Methods
FieldOfficeInfoFile Class Legend Public Methods

The methods of the FieldOfficeInfoFile class are listed here.

Collapse Expand Class

FieldOfficeInfoFile Class

Collapse Expand Public Methods
Name | Description
read | Reads field office information from disk.
setData | Dummy function for file version.
write | Saves field office information to disk.
Collapse Expand Links
FieldOfficeInfoFile Class, Legend, Public Methods


FieldOfficeInfoFile::read Method

FieldOfficeInfoFile::read Method
FieldOfficeInfoFile Class FieldOfficeInfoFile Members FieldOfficeInfoFile Methods

Reads field office information from disk.

C++
void read();
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FOINFO1 if unable to open input file; of type PIA_IDS_FOINFO2 if unable to read all required data.
Collapse Expand Group

FieldOfficeInfoFile Methods

Collapse Expand Links
FieldOfficeInfoFile Class, FieldOfficeInfoFile Members, FieldOfficeInfoFile Methods


FieldOfficeInfoFile::setData Method

FieldOfficeInfoFile::setData Method
FieldOfficeInfoFile Class FieldOfficeInfoFile Members FieldOfficeInfoFile Methods

Dummy function for file version.

C++
void setData();
Collapse Expand Group

FieldOfficeInfoFile Methods

Collapse Expand Links
FieldOfficeInfoFile Class, FieldOfficeInfoFile Members, FieldOfficeInfoFile Methods


FieldOfficeInfoFile::write Method

FieldOfficeInfoFile::write Method
FieldOfficeInfoFile Class FieldOfficeInfoFile Members FieldOfficeInfoFile Methods

Saves field office information to disk.

C++
void write();
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FOINFO3 if unable to open output file.
Collapse Expand Group

FieldOfficeInfoFile Methods

Collapse Expand Links
FieldOfficeInfoFile Class, FieldOfficeInfoFile Members, FieldOfficeInfoFile Methods


FieldOfficeInfoNonFile Class

FieldOfficeInfoNonFile Class
FieldOfficeInfoNonFile Methods FieldOfficeInfoNonFile Members FieldOfficeInfoNonFile.h Classes

Manages field office information not stored in a file (but its data may be saved in an .ini file).

Collapse Expand Class Hierarchy
  FieldOfficeInfoNonFileFieldOfficeInfoNonFile
C++
class FieldOfficeInfoNonFile : public FieldOfficeInfo;
Collapse Expand File

File: FieldOfficeInfoNonFile.h

Module: PiaData Library

Collapse Expand Remarks

See FieldOfficeInfoFile for a version of this class that stores the field office information internally.

Collapse Expand See Also

FieldOfficeInfoFile

Collapse Expand Group

Classes

Collapse Expand Links
FieldOfficeInfoNonFile Methods, FieldOfficeInfoNonFile Members, FieldOfficeInfoNonFile.h, Classes


FieldOfficeInfoNonFile Members

FieldOfficeInfoNonFile Members
FieldOfficeInfoNonFile Class Legend Public Data Members Public Methods

The following tables list the members exposed by FieldOfficeInfoNonFile.

Collapse Expand Class

FieldOfficeInfoNonFile Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
numLines | Number of address lines (4).
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
FieldOfficeInfoNonFile | Initializes field office info.
getAddress | Returns one line of field office address.
getFieldOfficeName | Returns field office manager's name.
getFieldOfficeTitle | Returns field office manager's title.
read | Reads field office information (dummy function).
setAddress | Sets one line of field office address.
setData | Initializes name and address.
setFieldOfficeName | Sets field office manager's name.
setFieldOfficeTitle | Sets field office manager's title.
write | Saves field office information (dummy function).
~FieldOfficeInfoNonFile | Destroys field office info.
Collapse Expand Links
FieldOfficeInfoNonFile Class, Legend, Public Data Members, Public Methods


FieldOfficeInfoNonFile::FieldOfficeInfoNonFile Constructor

FieldOfficeInfoNonFile::FieldOfficeInfoNonFile Constructor
FieldOfficeInfoNonFile Class FieldOfficeInfoNonFile Members FieldOfficeInfoNonFile Class

Initializes field office info.

C++
FieldOfficeInfoNonFile();
Collapse Expand Class

FieldOfficeInfoNonFile Class

Collapse Expand Links
FieldOfficeInfoNonFile Class, FieldOfficeInfoNonFile Members, FieldOfficeInfoNonFile Class


FieldOfficeInfoNonFile::~FieldOfficeInfoNonFile Destructor

FieldOfficeInfoNonFile::~FieldOfficeInfoNonFile Destructor
FieldOfficeInfoNonFile Class FieldOfficeInfoNonFile Members FieldOfficeInfoNonFile Class

Destroys field office info.

C++
~FieldOfficeInfoNonFile();
Collapse Expand Class

FieldOfficeInfoNonFile Class

Collapse Expand Links
FieldOfficeInfoNonFile Class, FieldOfficeInfoNonFile Members, FieldOfficeInfoNonFile Class


FieldOfficeInfoNonFile Methods

FieldOfficeInfoNonFile Methods
FieldOfficeInfoNonFile Class Legend Public Methods

The methods of the FieldOfficeInfoNonFile class are listed here.

Collapse Expand Class

FieldOfficeInfoNonFile Class

Collapse Expand Public Methods
Name | Description
read | Reads field office information (dummy function).
setData | Initializes name and address.
write | Saves field office information (dummy function).
Collapse Expand Links
FieldOfficeInfoNonFile Class, Legend, Public Methods


FieldOfficeInfoNonFile::read Method

FieldOfficeInfoNonFile::read Method
FieldOfficeInfoNonFile Class FieldOfficeInfoNonFile Members FieldOfficeInfoNonFile Methods

Reads field office information (dummy function).

C++
void read();
Collapse Expand Group

FieldOfficeInfoNonFile Methods

Collapse Expand Links
FieldOfficeInfoNonFile Class, FieldOfficeInfoNonFile Members, FieldOfficeInfoNonFile Methods


FieldOfficeInfoNonFile::setData Method

FieldOfficeInfoNonFile::setData Method
FieldOfficeInfoNonFile Class FieldOfficeInfoNonFile Members FieldOfficeInfoNonFile Methods

Initializes name and address.

C++
void setData();
Collapse Expand Group

FieldOfficeInfoNonFile Methods

Collapse Expand Links
FieldOfficeInfoNonFile Class, FieldOfficeInfoNonFile Members, FieldOfficeInfoNonFile Methods


FieldOfficeInfoNonFile::write Method

FieldOfficeInfoNonFile::write Method
FieldOfficeInfoNonFile Class FieldOfficeInfoNonFile Members FieldOfficeInfoNonFile Methods

Saves field office information (dummy function).

C++
void write();
Collapse Expand Group

FieldOfficeInfoNonFile Methods

Collapse Expand Links
FieldOfficeInfoNonFile Class, FieldOfficeInfoNonFile Members, FieldOfficeInfoNonFile Methods


FreezeYears Class

FreezeYears Class
FreezeYears Methods FreezeYears Members frzyrs.h Classes

Manages the years in a freeze period. The years may be wholly or partially within a freeze period.

Collapse Expand Class Hierarchy
  FreezeYears
C++
class FreezeYears;
Collapse Expand File

File: frzyrs.h

Module: PiaData Library

Collapse Expand Remarks

Two instances of this class are used in PiaData.

Collapse Expand Group

Classes

Collapse Expand Links
FreezeYears Methods, FreezeYears Members, frzyrs.h, Classes


FreezeYears Members

FreezeYears Members
FreezeYears Class Legend Public Methods

The following tables list the members exposed by FreezeYears.

Collapse Expand Class

FreezeYears Class

Collapse Expand Public Methods
Name | Description
FreezeYears | Creates a FreezeYears.
deleteContents | Zeroes all variables.
getYear1 | Returns first year in latest period of disability.
getYear2 | Returns last year in latest period of disability.
getYear3 | Returns first year in prior period of disability.
getYear4 | Returns last year in prior period of disability.
hasYears1 | Returns true if any years in latest freeze period.
hasYears2 | Returns true if any years in prior freeze period.
isFreezeYear | Returns true if year is wholly within a period of disability, false otherwise.
setYear1 | Sets first year in latest period of disability.
setYear2 | Sets last year in latest period of disability.
setYear3 | Sets first year in prior period of disability.
setYear4 | Sets last year in prior period of disability.
Collapse Expand Links
FreezeYears Class, Legend, Public Methods


FreezeYears::FreezeYears Constructor

FreezeYears::FreezeYears Constructor
FreezeYears Class FreezeYears Members FreezeYears Class

Creates a FreezeYears.

C++
FreezeYears();
Collapse Expand Remarks

All years are initialized to 0.

Collapse Expand Class

FreezeYears Class

Collapse Expand Links
FreezeYears Class, FreezeYears Members, FreezeYears Class


FreezeYears Methods

FreezeYears Methods
FreezeYears Class Legend Public Methods

The methods of the FreezeYears class are listed here.

Collapse Expand Class

FreezeYears Class

Collapse Expand Public Methods
Name | Description
deleteContents | Zeroes all variables.
getYear1 | Returns first year in latest period of disability.
getYear2 | Returns last year in latest period of disability.
getYear3 | Returns first year in prior period of disability.
getYear4 | Returns last year in prior period of disability.
hasYears1 | Returns true if any years in latest freeze period.
hasYears2 | Returns true if any years in prior freeze period.
isFreezeYear | Returns true if year is wholly within a period of disability, false otherwise.
setYear1 | Sets first year in latest period of disability.
setYear2 | Sets last year in latest period of disability.
setYear3 | Sets first year in prior period of disability.
setYear4 | Sets last year in prior period of disability.
Collapse Expand Links
FreezeYears Class, Legend, Public Methods


FreezeYears::deleteContents Method

FreezeYears::deleteContents Method
FreezeYears Class FreezeYears Members FreezeYears Methods

Zeroes all variables.

C++
void deleteContents();
Collapse Expand Group

FreezeYears Methods

Collapse Expand Links
FreezeYears Class, FreezeYears Members, FreezeYears Methods


FreezeYears::getYear1 Method

FreezeYears::getYear1 Method
FreezeYears Class FreezeYears Members FreezeYears Methods

Returns first year in latest period of disability.

C++
int getYear1() const;
Collapse Expand Returns

First year in latest period of disability.

Collapse Expand Group

FreezeYears Methods

Collapse Expand Links
FreezeYears Class, FreezeYears Members, FreezeYears Methods


FreezeYears::getYear2 Method

FreezeYears::getYear2 Method
FreezeYears Class FreezeYears Members FreezeYears Methods

Returns last year in latest period of disability.

C++
int getYear2() const;
Collapse Expand Returns

Last year in latest period of disability.

Collapse Expand Group

FreezeYears Methods

Collapse Expand Links
FreezeYears Class, FreezeYears Members, FreezeYears Methods


FreezeYears::getYear3 Method

FreezeYears::getYear3 Method
FreezeYears Class FreezeYears Members FreezeYears Methods

Returns first year in prior period of disability.

C++
int getYear3() const;
Collapse Expand Returns

First year in prior period of disability.

Collapse Expand Group

FreezeYears Methods

Collapse Expand Links
FreezeYears Class, FreezeYears Members, FreezeYears Methods


FreezeYears::getYear4 Method

FreezeYears::getYear4 Method
FreezeYears Class FreezeYears Members FreezeYears Methods

Returns last year in prior period of disability.

C++
int getYear4() const;
Collapse Expand Returns

Last year in prior period of disability.

Collapse Expand Group

FreezeYears Methods

Collapse Expand Links
FreezeYears Class, FreezeYears Members, FreezeYears Methods


FreezeYears::hasYears1 Method

FreezeYears::hasYears1 Method
FreezeYears Class FreezeYears Members FreezeYears Methods

Returns true if any years in latest freeze period.

C++
bool hasYears1() const;
Collapse Expand Returns

True if any years in latest freeze period.

Collapse Expand Group

FreezeYears Methods

Collapse Expand Links
FreezeYears Class, FreezeYears Members, FreezeYears Methods


FreezeYears::hasYears2 Method

FreezeYears::hasYears2 Method
FreezeYears Class FreezeYears Members FreezeYears Methods

Returns true if any years in prior freeze period.

C++
bool hasYears2() const;
Collapse Expand Returns

True if any years in prior freeze period.

Collapse Expand Group

FreezeYears Methods

Collapse Expand Links
FreezeYears Class, FreezeYears Members, FreezeYears Methods


FreezeYears::isFreezeYear Method

FreezeYears::isFreezeYear Method
FreezeYears Class FreezeYears Members FreezeYears Methods

Returns true if year is wholly within a period of disability, false otherwise.

C++
bool isFreezeYear(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year considered.
Collapse Expand Returns

True if year is wholly within a period of disability, false otherwise.

Collapse Expand Group

FreezeYears Methods

Collapse Expand Links
FreezeYears Class, FreezeYears Members, FreezeYears Methods


FreezeYears::setYear1 Method

FreezeYears::setYear1 Method
FreezeYears Class FreezeYears Members FreezeYears Methods

Sets first year in latest period of disability.

C++
void setYear1(
    int newYear1
);
Collapse Expand Parameters
Parameters | Description
int newYear1 | New first year in latest period.
Collapse Expand Group

FreezeYears Methods

Collapse Expand Links
FreezeYears Class, FreezeYears Members, FreezeYears Methods


FreezeYears::setYear2 Method

FreezeYears::setYear2 Method
FreezeYears Class FreezeYears Members FreezeYears Methods

Sets last year in latest period of disability.

C++
void setYear2(
    int newYear2
);
Collapse Expand Parameters
Parameters | Description
int newYear2 | New last year in latest period.
Collapse Expand Group

FreezeYears Methods

Collapse Expand Links
FreezeYears Class, FreezeYears Members, FreezeYears Methods


FreezeYears::setYear3 Method

FreezeYears::setYear3 Method
FreezeYears Class FreezeYears Members FreezeYears Methods

Sets first year in prior period of disability.

C++
void setYear3(
    int newYear3
);
Collapse Expand Parameters
Parameters | Description
int newYear3 | New first year in prior period.
Collapse Expand Group

FreezeYears Methods

Collapse Expand Links
FreezeYears Class, FreezeYears Members, FreezeYears Methods


FreezeYears::setYear4 Method

FreezeYears::setYear4 Method
FreezeYears Class FreezeYears Members FreezeYears Methods

Sets last year in prior period of disability.

C++
void setYear4(
    int newYear4
);
Collapse Expand Parameters
Parameters | Description
int newYear4 | New last year in prior period.
Collapse Expand Group

FreezeYears Methods

Collapse Expand Links
FreezeYears Class, FreezeYears Members, FreezeYears Methods


FrozMin Class

FrozMin Class
FrozMin Methods FrozMin Members FrozMin.h Classes

Manages the functions required for calculation of a frozen minimum Social Security benefit.

Collapse Expand Class Hierarchy
  FrozMinFrozMin
C++
class FrozMin : public PiaMethod;
Collapse Expand File

File: FrozMin.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaCalPL and PiaCalLC.

Collapse Expand Group

Classes

Collapse Expand Links
FrozMin Methods, FrozMin Members, FrozMin.h, Classes


FrozMin Members

FrozMin Members
Enumerations FrozMin Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by FrozMin.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

FrozMin Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
FrozMin | Initializes a frozen minimum method.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Computes frozen minimum PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setFrozMin | Sets amounts for frozen minimum before benefit increases.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~FrozMin | Destructor.
Collapse Expand Links
Enumerations, FrozMin Class, Legend, Protected Data Members, Public Data Members, Public Methods


FrozMin::FrozMin Constructor

FrozMin::FrozMin Constructor
FrozMin Class FrozMin Members FrozMin Class

Initializes a frozen minimum method.

C++
FrozMin(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
Collapse Expand Remarks

Calls PiaMethod::initialize.

Collapse Expand Class

FrozMin Class

Collapse Expand Links
FrozMin Class, FrozMin Members, FrozMin Class


FrozMin::~FrozMin Destructor

FrozMin::~FrozMin Destructor
FrozMin Class FrozMin Members FrozMin Class

Destructor.

C++
virtual ~FrozMin();
Collapse Expand Class

FrozMin Class

Collapse Expand Links
FrozMin Class, FrozMin Members, FrozMin Class


FrozMin Methods

FrozMin Methods
FrozMin Class Legend Public Methods

The methods of the FrozMin class are listed here.

Collapse Expand Class

FrozMin Class

Collapse Expand Public Methods
Name | Description
calculate | Computes frozen minimum PIA.
isApplicable | Determines applicability of method.
setFrozMin | Sets amounts for frozen minimum before benefit increases.
Collapse Expand Links
FrozMin Class, Legend, Public Methods


FrozMin::calculate Method

FrozMin::calculate Method
FrozMin Class FrozMin Members FrozMin Methods

Computes frozen minimum PIA.

C++
void calculate();
Collapse Expand Group

FrozMin Methods

Collapse Expand Links
FrozMin Class, FrozMin Members, FrozMin Methods


isApplicable Method

isApplicable Method
FrozMin Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of this function. The version with no arguments uses stored data, passing it to the static version with two arguments.

Collapse Expand Overload List
Name | Description
FrozMin::isApplicable () | Determines applicability of method using stored values.
FrozMin::isApplicable (const WorkerDataGeneral&, const PiaData&) | Determines applicability of method using passed values.
Collapse Expand Group

FrozMin Methods

Collapse Expand Links
FrozMin Methods


FrozMin::isApplicable Method ()

FrozMin::isApplicable Method ()
FrozMin Class FrozMin Members isApplicable Method

Determines applicability of method using stored values.

C++
bool isApplicable();
Collapse Expand Returns

True if method is applicable, false otherwise.

Collapse Expand Remarks

This version with no arguments calls the static version with 2 arguments. The year of eligibility must be between 1979 and 1981, inclusive, and it must not be a totalization benefit.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
FrozMin Class, FrozMin Members, isApplicable Method


FrozMin::isApplicable Method (const WorkerDataGeneral&, const PiaData&)

FrozMin::isApplicable Method (const WorkerDataGeneral&, const PiaData&)
FrozMin Class FrozMin Members isApplicable Method

Determines applicability of method using passed values.

C++
static bool isApplicable(
    const WorkerDataGeneral& workerData,
    const PiaData& piaData
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker data.
const PiaData& piaData | Pia calculation data.
Collapse Expand Returns

True if method is applicable, false otherwise.

Collapse Expand Remarks

The year of eligibility must be between 1979 and 1981, inclusive, and it must not be a totalization benefit.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
FrozMin Class, FrozMin Members, isApplicable Method


FrozMin::setFrozMin Method

FrozMin::setFrozMin Method
FrozMin Class FrozMin Members FrozMin Methods

Sets amounts for frozen minimum before benefit increases.

C++
void setFrozMin();
Collapse Expand Group

FrozMin Methods

Collapse Expand Links
FrozMin Class, FrozMin Members, FrozMin Methods


InsCode Class

InsCode Class
InsCode Constructor InsCode Enumerations InsCode Methods InsCode Operators InsCode Members inscode.h Classes

Represents one insured status code.

Collapse Expand Class Hierarchy
  InsCode
C++
class InsCode;
Collapse Expand File

File: inscode.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is used in PiaData. An array of instances is used in InsCodeArray.

Collapse Expand Group

Classes

Collapse Expand Links
InsCode Constructor, InsCode Enumerations, InsCode Methods, InsCode Operators, InsCode Members, inscode.h, Classes


InsCode Members

InsCode Members
Enumerations InsCode Class Legend Public Methods

The following tables list the members exposed by InsCode.

Collapse Expand Enumerations
Name | Description
InsCodeType | Insured status code types.
Collapse Expand Class

InsCode Class

Collapse Expand Public Methods
Name | Description
ChartoCode | Converts a character to an InsCode::InsCodeType.
InsCode | Initializes an InsCode, with or without a specified insured status.
get | Returns the insured status code.
isCurrentlyInsured | Returns the currently insured status.
isFullyInsured | Returns the fully insured status.
isFullyOrCurrentlyInsured | Returns the fully or currently insured status.
isFullyOrTotalInsured | Returns the fully or totalization insured status.
isPermanentlyInsured | Returns permanently insured status.
set | Sets the insured status code.
toChar | Returns an insured status code as a character.
Collapse Expand Public Operators
Name | Description
== | Returns true if the InsCode::InsCodeType's are equal.
Collapse Expand Links
Enumerations, InsCode Class, Legend, Public Methods


InsCode Constructor

InsCode Constructor
InsCode Class

Initializes an InsCode, with or without a specified insured status.

Collapse Expand Description

There are two versions of the InsCode constructor. If the value of the InsCodeType is not specified, it is set to InsCodeType::NOQCS.

Collapse Expand Overload List
Name | Description
InsCode::InsCode () | Initializes data to InsCode::InsCodeType::NOQCS.
InsCode::InsCode (InsCodeType) | Initializes data to new code.
Collapse Expand Class

InsCode Class

Collapse Expand Links
InsCode Class


InsCode::InsCode Constructor ()

InsCode::InsCode Constructor ()
InsCode Class InsCode Members InsCode Constructor

Initializes data to InsCode::InsCodeType::NOQCS.

C++
InsCode();
Collapse Expand Group

InsCode Constructor

Collapse Expand Links
InsCode Class, InsCode Members, InsCode Constructor


InsCode::InsCode Constructor (InsCodeType)

InsCode::InsCode Constructor (InsCodeType)
InsCode Class InsCode Members InsCode Constructor

Initializes data to new code.

C++
InsCode(
    InsCodeType newCode
);
Collapse Expand Parameters
Parameters | Description
InsCodeType newCode | Insured status code to use.
Collapse Expand Group

InsCode Constructor

Collapse Expand Links
InsCode Class, InsCode Members, InsCode Constructor


InsCode Enumerations

InsCode Enumerations
Enumerations InsCode Class Legend

The enumerations of the InsCode class are listed here.

Collapse Expand Enumerations
Name | Description
InsCodeType | Insured status code types.
Collapse Expand Class

InsCode Class

Collapse Expand Links
Enumerations, InsCode Class, Legend


InsCode::InsCodeType Enumeration

InsCode::InsCodeType Enumeration
inscode.h InsCode Enumerations

Insured status code types.

C++
enum InsCodeType {
  NOQCS,
  FULLANDCURRENT,
  CURRENTNOTFULL,
  FULLNOTCURRENT,
  UNINSURED,
  PERMANDCURRENT,
  PERMNOTCURRENT,
  PRIMARYDEATH,
  TRANSITIONAL,
  NONPRIMARYDEATH,
  DEEMED,
  TOTALIZED
};
Collapse Expand File

File: inscode.h

Module: PiaData Library

Collapse Expand Members
Members | Description
NOQCS | 0 - active (no QC's to date).
FULLANDCURRENT | 1 - fully and currently insured.
CURRENTNOTFULL | 2 - currently but not fully insured.
FULLNOTCURRENT | 3 - fully but not currently insured.
UNINSURED | 4 - uninsured (but some QC's to date).
PERMANDCURRENT | 5 - permanently and currently insured.
PERMNOTCURRENT | 6 - permanently but not currently insured.
PRIMARYDEATH | 7 - primary-entitled death.
TRANSITIONAL | 8 - transitionally insured.
NONPRIMARYDEATH | 9 - non-primary-entitled death.
DEEMED | D - deemed fully insured (1983 amendments).
TOTALIZED | T - insured for totalization benefits.
Collapse Expand Remarks

Most of these codes come from the CWHS. The last two are added for use in OACT programs.

Collapse Expand Group

InsCode Enumerations

Collapse Expand Links
inscode.h, InsCode Enumerations


InsCode Methods

InsCode Methods
InsCode Class Legend Public Methods

The methods of the InsCode class are listed here.

Collapse Expand Class

InsCode Class

Collapse Expand Public Methods
Name | Description
ChartoCode | Converts a character to an InsCode::InsCodeType.
get | Returns the insured status code.
isCurrentlyInsured | Returns the currently insured status.
isFullyInsured | Returns the fully insured status.
isFullyOrCurrentlyInsured | Returns the fully or currently insured status.
isFullyOrTotalInsured | Returns the fully or totalization insured status.
isPermanentlyInsured | Returns permanently insured status.
set | Sets the insured status code.
toChar | Returns an insured status code as a character.
Collapse Expand Links
InsCode Class, Legend, Public Methods


InsCode::ChartoCode Method

InsCode::ChartoCode Method
InsCode Class InsCode Members InsCode Methods

Converts a character to an InsCode::InsCodeType.

C++
static InsCodeType ChartoCode(
    char inscodechar
);
Collapse Expand Parameters
Parameters | Description
char inscodechar | The character to convert.
Collapse Expand Returns

The converted InsCode::InsCodeType.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if the specified character is not one of the allowed ones (0 through 9, D, and T).
Collapse Expand Group

InsCode Methods

Collapse Expand Links
InsCode Class, InsCode Members, InsCode Methods


InsCode::get Method

InsCode::get Method
InsCode Class InsCode Members InsCode Methods

Returns the insured status code.

C++
InsCodeType get() const;
Collapse Expand Returns

The insured status code.

Collapse Expand Group

InsCode Methods

Collapse Expand Links
InsCode Class, InsCode Members, InsCode Methods


InsCode::isCurrentlyInsured Method

InsCode::isCurrentlyInsured Method
InsCode Class InsCode Members InsCode Methods

Returns the currently insured status.

C++
bool isCurrentlyInsured() const;
Collapse Expand Returns

True if currently insured, false otherwise.

Collapse Expand Group

InsCode Methods

Collapse Expand Links
InsCode Class, InsCode Members, InsCode Methods


InsCode::isFullyInsured Method

InsCode::isFullyInsured Method
InsCode Class InsCode Members InsCode Methods

Returns the fully insured status.

C++
bool isFullyInsured() const;
Collapse Expand Returns

True if fully insured, false otherwise.

Collapse Expand Group

InsCode Methods

Collapse Expand Links
InsCode Class, InsCode Members, InsCode Methods


InsCode::isFullyOrCurrentlyInsured Method

InsCode::isFullyOrCurrentlyInsured Method
InsCode Class InsCode Members InsCode Methods

Returns the fully or currently insured status.

C++
bool isFullyOrCurrentlyInsured() const;
Collapse Expand Returns

True if currently insured or fully insured, false otherwise.

Collapse Expand Group

InsCode Methods

Collapse Expand Links
InsCode Class, InsCode Members, InsCode Methods


InsCode::isFullyOrTotalInsured Method

InsCode::isFullyOrTotalInsured Method
InsCode Class InsCode Members InsCode Methods

Returns the fully or totalization insured status.

C++
bool isFullyOrTotalInsured() const;
Collapse Expand Returns

True if fully insured or insured for totalization benefits, false otherwise.

Collapse Expand Group

InsCode Methods

Collapse Expand Links
InsCode Class, InsCode Members, InsCode Methods


InsCode::isPermanentlyInsured Method

InsCode::isPermanentlyInsured Method
InsCode Class InsCode Members InsCode Methods

Returns permanently insured status.

C++
bool isPermanentlyInsured() const;
Collapse Expand Returns

True if permanently insured, false otherwise.

Collapse Expand Group

InsCode Methods

Collapse Expand Links
InsCode Class, InsCode Members, InsCode Methods


InsCode::set Method

InsCode::set Method
InsCode Class InsCode Members InsCode Methods

Sets the insured status code.

C++
void set(
    InsCodeType newCode
);
Collapse Expand Parameters
Parameters | Description
InsCodeType newCode | New insured status code.
Collapse Expand Group

InsCode Methods

Collapse Expand Links
InsCode Class, InsCode Members, InsCode Methods


toChar Method

toChar Method
InsCode Methods

Returns an insured status code as a character.

Collapse Expand Description

There are two versions of the toChar function. The one with no argument passes the stored disability insured status code as an argument to the static version with 1 argument.

Collapse Expand Overload List
Name | Description
InsCode::toChar (InsCodeType) | Returns the passed insured status code as a character.
InsCode::toChar () | Returns the stored insured status code as a character.
Collapse Expand Group

InsCode Methods

Collapse Expand Links
InsCode Methods


InsCode::toChar Method ()

InsCode::toChar Method ()
InsCode Class InsCode Members toChar Method

Returns the stored insured status code as a character.

C++
char toChar() const;
Collapse Expand Returns

The insured status code as a character.

Collapse Expand Remarks

This version calls the static version of this function using the stored code.

Collapse Expand Group

toChar Method

Collapse Expand Links
InsCode Class, InsCode Members, toChar Method


InsCode::toChar Method (InsCodeType)

InsCode::toChar Method (InsCodeType)
InsCode Class InsCode Members toChar Method

Returns the passed insured status code as a character.

C++
static char toChar(
    InsCodeType newCode
);
Collapse Expand Parameters
Parameters | Description
InsCodeType newCode | The code to convert to a character.
Collapse Expand Returns

The insured status code as a character.

Collapse Expand Group

toChar Method

Collapse Expand Links
InsCode Class, InsCode Members, toChar Method


InsCode Operators

InsCode Operators
InsCode Class Legend

The operators of the InsCode class are listed here.

Collapse Expand Class

InsCode Class

Collapse Expand Public Operators
Name | Description
== | Returns true if the InsCode::InsCodeType's are equal.
Collapse Expand Links
InsCode Class, Legend


InsCode::== Operator

InsCode::== Operator
InsCode Class InsCode Members InsCode Operators

Returns true if the InsCode::InsCodeType's are equal.

C++
bool operator ==(
    const InsCode& newCode
) const;
Collapse Expand Parameters
Parameters | Description
const InsCode& newCode | The insured status code to compare against.
Collapse Expand Returns

True if the InsCode::InsCodeType's are equal.

Collapse Expand Group

InsCode Operators

Collapse Expand Links
InsCode Class, InsCode Members, InsCode Operators


InsCodeArray Class

InsCodeArray Class
InsCodeArray Methods InsCodeArray Operators InsCodeArray Members InsCodeArray.h Classes

Manages an array of annual insured status codes.

Collapse Expand Class Hierarchy
  InsCodeArray
C++
class InsCodeArray;
Collapse Expand File

File: InsCodeArray.h

Module: PiaData Library

Collapse Expand Remarks

Manages an array of annual insured status codes.

Collapse Expand Group

Classes

Collapse Expand Links
InsCodeArray Methods, InsCodeArray Operators, InsCodeArray Members, InsCodeArray.h, Classes


InsCodeArray Members

InsCodeArray Members
InsCodeArray Class Legend Public Methods

The following tables list the members exposed by InsCodeArray.

Collapse Expand Class

InsCodeArray Class

Collapse Expand Public Methods
Name | Description
InsCodeArray | Initializes the first and last years.
assign | Sets values for a range of years.
deleteContents | Zeroes out all data values.
getFirstYear | Returns the first year of data.
getLastYear | Returns the last year of data.
isNonzero | Returns true if any insured status code is other than InsCode::InsCodeType::NOQCS.
setFirstYear | Sets the first year of data.
setLastYear | Sets the last year of data.
toString | Returns data for one insured status code array as a string.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
InsCodeArray Class, Legend, Public Methods


InsCodeArray::InsCodeArray Constructor

InsCodeArray::InsCodeArray Constructor
InsCodeArray Class InsCodeArray Members InsCodeArray Class

Initializes the first and last years.

C++
InsCodeArray(
    int newFirstYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newFirstYear | New first year of data.
int newLastYear | New last year of data.
Collapse Expand Remarks

Resizes the data array to cover the specified span of years.

Collapse Expand Class

InsCodeArray Class

Collapse Expand Links
InsCodeArray Class, InsCodeArray Members, InsCodeArray Class


InsCodeArray Methods

InsCodeArray Methods
InsCodeArray Class Legend Public Methods

The methods of the InsCodeArray class are listed here.

Collapse Expand Class

InsCodeArray Class

Collapse Expand Public Methods
Name | Description
assign | Sets values for a range of years.
deleteContents | Zeroes out all data values.
getFirstYear | Returns the first year of data.
getLastYear | Returns the last year of data.
isNonzero | Returns true if any insured status code is other than InsCode::InsCodeType::NOQCS.
setFirstYear | Sets the first year of data.
setLastYear | Sets the last year of data.
toString | Returns data for one insured status code array as a string.
Collapse Expand Links
InsCodeArray Class, Legend, Public Methods


assign Method

assign Method
InsCodeArray Methods

Sets values for a range of years.

Collapse Expand Description

There are two versions of the assign function. The version with an InsCode argument sets all values for the specified range of years to the specified value. The version with an InscodeArray argument copies values for corresponding years from the argument.

Collapse Expand Overload List
Name | Description
InsCodeArray::assign (const InsCode&, int, int) | Sets the data for specified years to one specified value.
InsCodeArray::assign (const InsCodeArray&, int, int) | Sets the data for each year from the values in the argument array.
Collapse Expand Group

InsCodeArray Methods

Collapse Expand Links
InsCodeArray Methods


InsCodeArray::assign Method (const InsCode&, int, int)

InsCodeArray::assign Method (const InsCode&, int, int)
InsCodeArray Class InsCodeArray Members assign Method

Sets the data for specified years to one specified value.

C++
void assign(
    const InsCode& newData,
    int firstDataYear,
    int lastDataYear
);
Collapse Expand Parameters
Parameters | Description
const InsCode& newData | New value of data to be used for all specified years.
int firstDataYear | First year of data to set.
int lastDataYear | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
InsCodeArray Class, InsCodeArray Members, assign Method


InsCodeArray::assign Method (const InsCodeArray&, int, int)

InsCodeArray::assign Method (const InsCodeArray&, int, int)
InsCodeArray Class InsCodeArray Members assign Method

Sets the data for each year from the values in the argument array.

C++
void assign(
    const InsCodeArray& newDataArray,
    int firstDataYear,
    int lastDataYear
);
Collapse Expand Parameters
Parameters | Description
const InsCodeArray& newDataArray | Array of new values of data.
int firstDataYear | First year of data to set.
int lastDataYear | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
InsCodeArray Class, InsCodeArray Members, assign Method


InsCodeArray::deleteContents Method

InsCodeArray::deleteContents Method
InsCodeArray Class InsCodeArray Members InsCodeArray Methods

Zeroes out all data values.

C++
void deleteContents();
Collapse Expand Group

InsCodeArray Methods

Collapse Expand Links
InsCodeArray Class, InsCodeArray Members, InsCodeArray Methods


InsCodeArray::getFirstYear Method

InsCodeArray::getFirstYear Method
InsCodeArray Class InsCodeArray Members InsCodeArray Methods

Returns the first year of data.

C++
int getFirstYear() const;
Collapse Expand Returns

The first year of data.

Collapse Expand Group

InsCodeArray Methods

Collapse Expand Links
InsCodeArray Class, InsCodeArray Members, InsCodeArray Methods


InsCodeArray::getLastYear Method

InsCodeArray::getLastYear Method
InsCodeArray Class InsCodeArray Members InsCodeArray Methods

Returns the last year of data.

C++
int getLastYear() const;
Collapse Expand Returns

The last year of data.

Collapse Expand Group

InsCodeArray Methods

Collapse Expand Links
InsCodeArray Class, InsCodeArray Members, InsCodeArray Methods


InsCodeArray::isNonzero Method

InsCodeArray::isNonzero Method
InsCodeArray Class InsCodeArray Members InsCodeArray Methods

Returns true if any insured status code is other than InsCode::InsCodeType::NOQCS.

C++
bool isNonzero() const;
Collapse Expand Returns

True if any insured status code is other than InsCode::InsCodeType::NOQCS.

Collapse Expand Group

InsCodeArray Methods

Collapse Expand Links
InsCodeArray Class, InsCodeArray Members, InsCodeArray Methods


InsCodeArray::setFirstYear Method

InsCodeArray::setFirstYear Method
InsCodeArray Class InsCodeArray Members InsCodeArray Methods

Sets the first year of data.

C++
void setFirstYear(
    int newFirstYear
);
Collapse Expand Parameters
Parameters | Description
int newFirstYear | New first year of data.
Collapse Expand Group

InsCodeArray Methods

Collapse Expand Links
InsCodeArray Class, InsCodeArray Members, InsCodeArray Methods


InsCodeArray::setLastYear Method

InsCodeArray::setLastYear Method
InsCodeArray Class InsCodeArray Members InsCodeArray Methods

Sets the last year of data.

C++
void setLastYear(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | New last year of data.
Collapse Expand Group

InsCodeArray Methods

Collapse Expand Links
InsCodeArray Class, InsCodeArray Members, InsCodeArray Methods


InsCodeArray::toString Method

InsCodeArray::toString Method
InsCodeArray Class InsCodeArray Members InsCodeArray Methods

Returns data for one insured status code array as a string.

C++
std::string toString() const;
Collapse Expand Returns

Data for one insured status code array as a string.

Collapse Expand Group

InsCodeArray Methods

Collapse Expand Links
InsCodeArray Class, InsCodeArray Members, InsCodeArray Methods


InsCodeArray Operators

InsCodeArray Operators
InsCodeArray Class Legend

The operators of the InsCodeArray class are listed here.

Collapse Expand Class

InsCodeArray Class

Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
InsCodeArray Class, Legend


[] Operator

[] Operator
InsCodeArray Operators

Functions to access an element of the array.

Collapse Expand Description

There are two versions of the [] operator. They differ only in that one is const and the other is not, so that they can be used in both const and non-const settings.

Collapse Expand Overload List
Name | Description
InsCodeArray::[] (int) | Returns the insured status code at end of year, non-const version.
InsCodeArray::[] (int) | Returns the insured status code at end of year, const version.
Collapse Expand Group

InsCodeArray Operators

Collapse Expand Links
InsCodeArray Operators


InsCodeArray::[] Operator (int)

InsCodeArray::[] Operator (int)
InsCodeArray Class InsCodeArray Members [] Operator

Returns the insured status code at end of year, non-const version.

C++
InsCode& operator [](
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which insured status code is desired.
Collapse Expand Returns

The insured status code at end of year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if year is out of range (only in debug mode).
Collapse Expand Group

[] Operator

Collapse Expand Links
InsCodeArray Class, InsCodeArray Members, [] Operator


InsCodeArray::[] Operator (int)

InsCodeArray::[] Operator (int)
InsCodeArray Class InsCodeArray Members [] Operator

Returns the insured status code at end of year, const version.

C++
const InsCode operator [](
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which insured status code is desired.
Collapse Expand Returns

The insured status code at end of year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if year is out of range (only in debug mode).
Collapse Expand Group

[] Operator

Collapse Expand Links
InsCodeArray Class, InsCodeArray Members, [] Operator


LawChange Class

LawChange Class
LawChange Constructor LawChange Enumerations LawChange Methods LawChange Members LawChange.h Classes

The basic class that manages all of the extra data and functions required for one change in law concerning benefit calculations.

Collapse Expand Class Hierarchy
  LawChange
C++
class LawChange;
Collapse Expand File

File: LawChange.h

Module: PiaData Library

Collapse Expand Remarks

This class has enough data for simple law-changes. If a particular law-change requires additional data, it should subclass from this class and add the additional data.

Collapse Expand Group

Classes

Collapse Expand Links
LawChange Constructor, LawChange Enumerations, LawChange Methods, LawChange Members, LawChange.h, Classes


LawChange Members

LawChange Members
Enumerations LawChange Class Legend Public Methods

The following tables list the members exposed by LawChange.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChange Class

Collapse Expand Public Methods
Name | Description
LawChange | Initializes a LawChange, with or without a title.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years.
writeFirstLine | Writes a line with first and last years.
~LawChange | Destructor.
Collapse Expand Links
Enumerations, LawChange Class, Legend, Public Methods


LawChange Constructor

LawChange Constructor
LawChange Class

Initializes a LawChange, with or without a title.

Collapse Expand Description

There are two versions of the LawChange constructor. If the title is not provided, it is set to an empty string.

Collapse Expand Overload List
Name | Description
LawChange::LawChange () | Constructor with an empty string as title.
LawChange::LawChange (const std::string&) | Constructor with title.
Collapse Expand Class

LawChange Class

Collapse Expand Links
LawChange Class


LawChange::LawChange Constructor ()

LawChange::LawChange Constructor ()
LawChange Class LawChange Members LawChange Constructor

Constructor with an empty string as title.

C++
LawChange();
Collapse Expand Group

LawChange Constructor

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Constructor


LawChange::LawChange Constructor (const std::string&)

LawChange::LawChange Constructor (const std::string&)
LawChange Class LawChange Members LawChange Constructor

Constructor with title.

C++
LawChange(
    const std::string& newTitle
);
Collapse Expand Parameters
Parameters | Description
const std::string& newTitle | Title of this law-change.
Collapse Expand Group

LawChange Constructor

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Constructor


LawChange::~LawChange Destructor

LawChange::~LawChange Destructor
LawChange Class LawChange Members LawChange Class

Destructor.

C++
virtual ~LawChange();
Collapse Expand Class

LawChange Class

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Class


LawChange Enumerations

LawChange Enumerations
Enumerations LawChange Class Legend

The enumerations of the LawChange class are listed here.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChange Class

Collapse Expand Links
Enumerations, LawChange Class, Legend


LawChange::lawChangeType Enumeration

LawChange::lawChangeType Enumeration
LawChange.h LawChange Enumerations

Short names of changes in law.

C++
enum lawChangeType {
  PRE1977LAW,
  BPFRACWAGE,
  BPCPI,
  EARNINDCPI,
  NEWFORMULA,
  BPSPECRATE,
  BPMINCONST,
  AGE65COMP,
  DECLINEPERC,
  NOCPIELIG,
  NOREINDWID,
  WINDFALL,
  NEWSPECMIN,
  NOOLDSTART,
  DIDROP5,
  TRANSGUAR1,
  MARRLENGTH,
  TRANSGUAR3,
  ALLEARN,
  DROPOUTCHG,
  RETTESTCHG,
  SANFORD1,
  NOPIATABLE,
  NOTRANSGUAR,
  TAXRATECHG,
  SANFORD2,
  NRACHANGE,
  CHILDCARECREDIT,
  RETROWAGEIND,
  TRANSGUAR4,
  WIFEFACTOR,
  WIDFACTOR,
  TAXBENCHG,
  PSAACCT,
  WAGEBASECHG,
  STATELOCAL,
  FEDERAL,
  CHILDCAREDROPOUT,
  COLACHANGE,
  NODIBGUAR,
  MAXLCH
};
Collapse Expand File

File: LawChange.h

Module: PiaData Library

Collapse Expand Members
Members | Description
PRE1977LAW | Pre-1977 law benefits.
BPFRACWAGE | Bend points increasing at fraction of wage rate.
BPCPI | Bend points increasing at CPI rate.
EARNINDCPI | Worker's earnings are indexed to CPI rate.
NEWFORMULA | New benefit formula.
BPSPECRATE | Bend points increasing at specified rates.
BPMINCONST | Bend points increasing at wage rate minus a constant.
AGE65COMP | Change to age-65 computation point.
DECLINEPERC | Declining benefit formula percents.
NOCPIELIG | No benefit increase in year of eligibility.
NOREINDWID | No re-indexed widow guarantee.
WINDFALL | No windfall elimination provision.
NEWSPECMIN | New special minimum (years and/or amount).
NOOLDSTART | No old-start method.
DIDROP5 | 5-year DI dropout.
TRANSGUAR1 | Use earnings after age 62 for transitional guarantee.
MARRLENGTH | Number of years married for divorced spouse benefit.
TRANSGUAR3 | Use average of type-16 and aime for transitional guar.
ALLEARN | Use all earnings in AIME computation.
DROPOUTCHG | Reduce number of dropout years.
RETTESTCHG | Retirement test ad hoc change.
SANFORD1 | Original Sanford proposal (3% to retirement).
NOPIATABLE | No PIA table method.
NOTRANSGUAR | No transitional guarantee method.
TAXRATECHG | Tax rate change.
SANFORD2 | Second Sanford notch prop (3.25% to age 62; red yrs).
NRACHANGE | Change full retirement age.
CHILDCARECREDIT | Child care credit years.
RETROWAGEIND | Retroactive wage indexing.
TRANSGUAR4 | Corman-Myers COLA limitation (notch proposal).
WIFEFACTOR | Reduce aged wife factor to .33.
WIDFACTOR | Modify the aged widow(er) benefit calculation.
TAXBENCHG | Change in tax on benefits provision.
PSAACCT | Add PSA accounts.
WAGEBASECHG | Ad hoc wage base change.
STATELOCAL | Cover State and local employees.
FEDERAL | Cover Federal employees.
CHILDCAREDROPOUT | Child care dropout years.
COLACHANGE | Change in the COLA increase.
NODIBGUAR | No DIB guarantee.
MAXLCH | Number of different law changes.
Collapse Expand Group

LawChange Enumerations

Collapse Expand Links
LawChange.h, LawChange Enumerations


LawChange Methods

LawChange Methods
LawChange Class Legend Public Methods

The methods of the LawChange class are listed here.

Collapse Expand Class

LawChange Class

Collapse Expand Public Methods
Name | Description
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
LawChange Class, Legend, Public Methods


LawChange::bendPointCheck Method

LawChange::bendPointCheck Method
LawChange Class LawChange Members LawChange Methods

Checks range of a bendpoint value.

C++
static void bendPointCheck(
    double bendPoint
);
Collapse Expand Parameters
Parameters | Description
double bendPoint | Value to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_LAWCHG4 if bend point is out of range.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::bpincCheck Method

LawChange::bpincCheck Method
LawChange Class LawChange Members LawChange Methods

Checks range of a bend point increase percentage.

C++
static void bpincCheck(
    double bpinc
);
Collapse Expand Parameters
Parameters | Description
double bpinc | Value to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_LAWCHG3 if bend point increase percentage is out of range.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::constantPercCheck Method

LawChange::constantPercCheck Method
LawChange Class LawChange Members LawChange Methods

Checks range of a constant decline percentage.

C++
static void constantPercCheck(
    double constantPerc
);
Collapse Expand Parameters
Parameters | Description
double constantPerc | Value to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_LAWCHG5 if constant decline percentage is out of range.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::getEndYear Method

LawChange::getEndYear Method
LawChange Class LawChange Members LawChange Methods

Returns ending year for this law-change.

C++
int getEndYear() const;
Collapse Expand Returns

Ending year for this law-change.

Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::getEndYearLC Method

LawChange::getEndYearLC Method
LawChange Class LawChange Members LawChange Methods

Returns latest possible ending year for a law-change.

C++
static int getEndYearLC();
Collapse Expand Returns

Latest possible starting year for a law-change.

Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::getFirstLine Method

LawChange::getFirstLine Method
LawChange Class LawChange Members LawChange Methods

Reads a line and parses first and last years and type of phase-in.

C++
std::vector< std::string > getFirstLine(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Returns

Vector of words contained in the line. The first 3 words are the first and last years and the type of phase-in.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_LAWCHG6 if unable to parse input line.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::getInd Method

LawChange::getInd Method
LawChange Class LawChange Members LawChange Methods

Returns indicator for this law-change.

C++
int getInd() const;
Collapse Expand Returns

Indicator for this law-change.

Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::getPhaseType Method

LawChange::getPhaseType Method
LawChange Class LawChange Members LawChange Methods

Returns indicator for type of phase-in.

C++
int getPhaseType() const;
Collapse Expand Returns

Indicator for type of phase-in.

0 | phased in by year of eligiblity,
1 | effective immediately.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::getStartYear Method

LawChange::getStartYear Method
LawChange Class LawChange Members LawChange Methods

Returns starting year for this law-change.

C++
int getStartYear() const;
Collapse Expand Returns

Starting year for this law-change.

Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::getStartYearLC Method

LawChange::getStartYearLC Method
LawChange Class LawChange Members LawChange Methods

Returns earliest possible ending year for a law-change.

C++
static int getStartYearLC();
Collapse Expand Returns

Earliest possible starting year for a law-change.

Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::getTitle Method

LawChange::getTitle Method
LawChange Class LawChange Members LawChange Methods

Returns title of this law change.

C++
std::string getTitle() const;
Collapse Expand Returns

Title of this law change.

Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::isEffective Method

LawChange::isEffective Method
LawChange Class LawChange Members LawChange Methods

Returns true if this law change is in effect.

C++
bool isEffective(
    int eligYear,
    int benYear
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
int benYear | Year of benefit.
Collapse Expand Returns

True if this law change is in effect.

Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::percCheck Method

LawChange::percCheck Method
LawChange Class LawChange Members LawChange Methods

Checks range of a benefit formula percentage.

C++
static void percCheck(
    double perc
);
Collapse Expand Parameters
Parameters | Description
double perc | Value to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_LAWCHG3 if benefit formula percentage is out of range.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::prepareStrings Method

LawChange::prepareStrings Method
LawChange Class LawChange Members LawChange Methods

Prepares output strings for this change from present law.

C++
virtual void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::proportionBendPointsCheck Method

LawChange::proportionBendPointsCheck Method
LawChange Class LawChange Members LawChange Methods

Checks range of a wage increase proportion.

C++
static void proportionBendPointsCheck(
    double proportionBendPoints
);
Collapse Expand Parameters
Parameters | Description
double proportionBendPoints | Value to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_LAWCHG2 if wage increase proportion is out of range.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::read Method

LawChange::read Method
LawChange Class LawChange Members LawChange Methods

Reads all the lines required for this law-change.

C++
virtual void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::setEndYear Method

LawChange::setEndYear Method
LawChange Class LawChange Members LawChange Methods

Sets ending year for this law-change.

C++
void setEndYear(
    int newEndYear
);
Collapse Expand Parameters
Parameters | Description
int newEndYear | New ending year for this law-change.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::setEndYearLC Method

LawChange::setEndYearLC Method
LawChange Class LawChange Members LawChange Methods

Sets latest possible ending year for a law-change.

C++
static void setEndYearLC(
    int newEndYearLC
);
Collapse Expand Parameters
Parameters | Description
int newEndYearLC | Latest possible starting year for a law-change.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::setInd Method

LawChange::setInd Method
LawChange Class LawChange Members LawChange Methods

Sets change indicator for this law-change.

C++
void setInd(
    int newInd
);
Collapse Expand Parameters
Parameters | Description
int newInd | New change indicator for this law-change.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::setPhaseType Method

LawChange::setPhaseType Method
LawChange Class LawChange Members LawChange Methods

Sets indicator for type of phase-in.

C++
void setPhaseType(
    int newPhaseType
);
Collapse Expand Parameters
Parameters | Description
int newPhaseType | New indicator for type of phase-in.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::setStartYear Method

LawChange::setStartYear Method
LawChange Class LawChange Members LawChange Methods

Sets starting year for this law-change.

C++
void setStartYear(
    int newStartYear
);
Collapse Expand Parameters
Parameters | Description
int newStartYear | New starting year for this law-change.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::setStartYearLC Method

LawChange::setStartYearLC Method
LawChange Class LawChange Members LawChange Methods

Sets earliest possible starting year for a law-change.

C++
static void setStartYearLC(
    int newStartYearLC
);
Collapse Expand Parameters
Parameters | Description
int newStartYearLC | Earliest possible starting year for a law-change.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::startCheck Method

LawChange::startCheck Method
LawChange Class LawChange Members LawChange Methods

Checks range of a law-change starting year.

C++
static void startCheck(
    int start
);
Collapse Expand Parameters
Parameters | Description
int start | Starting year to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_LAWCHG1 if starting year is out of range.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::write Method

LawChange::write Method
LawChange Class LawChange Members LawChange Methods

Writes a line with first and last years.

C++
virtual void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChange::writeFirstLine Method

LawChange::writeFirstLine Method
LawChange Class LawChange Members LawChange Methods

Writes a line with first and last years.

C++
void writeFirstLine(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChange Methods

Collapse Expand Links
LawChange Class, LawChange Members, LawChange Methods


LawChangeAGE65COMP Class

LawChangeAGE65COMP Class
LawChangeAGE65COMP Methods LawChangeAGE65COMP Members LawChangeAGE65COMP.h Classes

Parameters for a proposal to increase the number of elapsed years in a pia calculation.

Collapse Expand Class Hierarchy
  LawChangeAGE65COMPLawChangeAGE65COMP
C++
class LawChangeAGE65COMP : public LawChange;
Collapse Expand File

File: LawChangeAGE65COMP.h

Module: PiaData Library

Collapse Expand Remarks

There is one additional data field compared to the base class.

If the indicator is greater than zero, its value of n is the number of years of increase in the elapsed years, so that the computation period is measured to age 62 + n. The change is phased in over a period of years according to the step size. (The computation increases by 1 year every step years.)

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeAGE65COMP Methods, LawChangeAGE65COMP Members, LawChangeAGE65COMP.h, Classes


LawChangeAGE65COMP Members

LawChangeAGE65COMP Members
Enumerations LawChangeAGE65COMP Class Legend Public Methods

The following tables list the members exposed by LawChangeAGE65COMP.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeAGE65COMP Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeAGE65COMP | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getStep | Returns step size when increasing computation period.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
setStep | Sets step size when increasing computation period.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeAGE65COMP Class, Legend, Public Methods


LawChangeAGE65COMP::LawChangeAGE65COMP Constructor

LawChangeAGE65COMP::LawChangeAGE65COMP Constructor
LawChangeAGE65COMP Class LawChangeAGE65COMP Members LawChangeAGE65COMP Class

Constructor.

C++
LawChangeAGE65COMP();
Collapse Expand Class

LawChangeAGE65COMP Class

Collapse Expand Links
LawChangeAGE65COMP Class, LawChangeAGE65COMP Members, LawChangeAGE65COMP Class


LawChangeAGE65COMP Methods

LawChangeAGE65COMP Methods
LawChangeAGE65COMP Class Legend Public Methods

The methods of the LawChangeAGE65COMP class are listed here.

Collapse Expand Class

LawChangeAGE65COMP Class

Collapse Expand Public Methods
Name | Description
getStep | Returns step size when increasing computation period.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setStep | Sets step size when increasing computation period.
write | Writes a line with first and last years, and percentage.
Collapse Expand Links
LawChangeAGE65COMP Class, Legend, Public Methods


LawChangeAGE65COMP::getStep Method

LawChangeAGE65COMP::getStep Method
LawChangeAGE65COMP Class LawChangeAGE65COMP Members LawChangeAGE65COMP Methods

Returns step size when increasing computation period.

C++
int getStep() const;
Collapse Expand Returns

Step size when increasing computation period.

Collapse Expand Group

LawChangeAGE65COMP Methods

Collapse Expand Links
LawChangeAGE65COMP Class, LawChangeAGE65COMP Members, LawChangeAGE65COMP Methods


LawChangeAGE65COMP::prepareStrings Method

LawChangeAGE65COMP::prepareStrings Method
LawChangeAGE65COMP Class LawChangeAGE65COMP Members LawChangeAGE65COMP Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeAGE65COMP Methods

Collapse Expand Links
LawChangeAGE65COMP Class, LawChangeAGE65COMP Members, LawChangeAGE65COMP Methods


LawChangeAGE65COMP::read Method

LawChangeAGE65COMP::read Method
LawChangeAGE65COMP Class LawChangeAGE65COMP Members LawChangeAGE65COMP Methods

Reads all the lines required for this law-change.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Group

LawChangeAGE65COMP Methods

Collapse Expand Links
LawChangeAGE65COMP Class, LawChangeAGE65COMP Members, LawChangeAGE65COMP Methods


LawChangeAGE65COMP::setStep Method

LawChangeAGE65COMP::setStep Method
LawChangeAGE65COMP Class LawChangeAGE65COMP Members LawChangeAGE65COMP Methods

Sets step size when increasing computation period.

C++
void setStep(
    int newStep
);
Collapse Expand Parameters
Parameters | Description
int newStep | New step size when increasing computation period.
Collapse Expand Group

LawChangeAGE65COMP Methods

Collapse Expand Links
LawChangeAGE65COMP Class, LawChangeAGE65COMP Members, LawChangeAGE65COMP Methods


LawChangeAGE65COMP::write Method

LawChangeAGE65COMP::write Method
LawChangeAGE65COMP Class LawChangeAGE65COMP Members LawChangeAGE65COMP Methods

Writes a line with first and last years, and percentage.

C++
void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChangeAGE65COMP Methods

Collapse Expand Links
LawChangeAGE65COMP Class, LawChangeAGE65COMP Members, LawChangeAGE65COMP Methods


LawChangeALLEARN Class

LawChangeALLEARN Class
LawChangeALLEARN Methods LawChangeALLEARN Members LawChangeALLEARN.h Classes

Parameters for a proposal to use all years of earnings in an AIME calculation.

Collapse Expand Class Hierarchy
  LawChangeALLEARNLawChangeALLEARN
C++
class LawChangeALLEARN : public LawChange;
Collapse Expand File

File: LawChangeALLEARN.h

Module: PiaData Library

Collapse Expand Remarks

There are two additional data fields compared to the base class.

If the indicator is 1, we use all earnings in the numerator of the AIME calculation. If the indicator is 2, we use all earnings in the numerator after a "phase-in" period. The number of years of earnings used increases by 1 every step years, until we use all earnings in the specified year.

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeALLEARN Methods, LawChangeALLEARN Members, LawChangeALLEARN.h, Classes


LawChangeALLEARN Members

LawChangeALLEARN Members
Enumerations LawChangeALLEARN Class Legend Public Methods

The following tables list the members exposed by LawChangeALLEARN.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeALLEARN Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeALLEARN | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getStep | Returns step size when increasing number of earnings years.
getTitle | Returns title of this law change.
getYear | Returns starting year when increasing number of earnings years.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
setStep | Sets step size when increasing number of earnings years.
setYear | Sets starting year when increasing number of earnings years.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and step size.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeALLEARN Class, Legend, Public Methods


LawChangeALLEARN::LawChangeALLEARN Constructor

LawChangeALLEARN::LawChangeALLEARN Constructor
LawChangeALLEARN Class LawChangeALLEARN Members LawChangeALLEARN Class

Constructor.

C++
LawChangeALLEARN();
Collapse Expand Class

LawChangeALLEARN Class

Collapse Expand Links
LawChangeALLEARN Class, LawChangeALLEARN Members, LawChangeALLEARN Class


LawChangeALLEARN Methods

LawChangeALLEARN Methods
LawChangeALLEARN Class Legend Public Methods

The methods of the LawChangeALLEARN class are listed here.

Collapse Expand Class

LawChangeALLEARN Class

Collapse Expand Public Methods
Name | Description
getStep | Returns step size when increasing number of earnings years.
getYear | Returns starting year when increasing number of earnings years.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setStep | Sets step size when increasing number of earnings years.
setYear | Sets starting year when increasing number of earnings years.
write | Writes a line with first and last years, and step size.
Collapse Expand Links
LawChangeALLEARN Class, Legend, Public Methods


LawChangeALLEARN::getStep Method

LawChangeALLEARN::getStep Method
LawChangeALLEARN Class LawChangeALLEARN Members LawChangeALLEARN Methods

Returns step size when increasing number of earnings years.

C++
int getStep() const;
Collapse Expand Returns

Step size when increasing number of earnings years.

Collapse Expand Group

LawChangeALLEARN Methods

Collapse Expand Links
LawChangeALLEARN Class, LawChangeALLEARN Members, LawChangeALLEARN Methods


LawChangeALLEARN::getYear Method

LawChangeALLEARN::getYear Method
LawChangeALLEARN Class LawChangeALLEARN Members LawChangeALLEARN Methods

Returns starting year when increasing number of earnings years.

C++
int getYear() const;
Collapse Expand Returns

Starting year when increasing number of earnings years.

Collapse Expand Group

LawChangeALLEARN Methods

Collapse Expand Links
LawChangeALLEARN Class, LawChangeALLEARN Members, LawChangeALLEARN Methods


LawChangeALLEARN::prepareStrings Method

LawChangeALLEARN::prepareStrings Method
LawChangeALLEARN Class LawChangeALLEARN Members LawChangeALLEARN Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeALLEARN Methods

Collapse Expand Links
LawChangeALLEARN Class, LawChangeALLEARN Members, LawChangeALLEARN Methods


LawChangeALLEARN::read Method

LawChangeALLEARN::read Method
LawChangeALLEARN Class LawChangeALLEARN Members LawChangeALLEARN Methods

Reads all the lines required for this law-change.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Group

LawChangeALLEARN Methods

Collapse Expand Links
LawChangeALLEARN Class, LawChangeALLEARN Members, LawChangeALLEARN Methods


LawChangeALLEARN::setStep Method

LawChangeALLEARN::setStep Method
LawChangeALLEARN Class LawChangeALLEARN Members LawChangeALLEARN Methods

Sets step size when increasing number of earnings years.

C++
void setStep(
    int newStep
);
Collapse Expand Parameters
Parameters | Description
int newStep | New step size when increasing number of earnings years.
Collapse Expand Group

LawChangeALLEARN Methods

Collapse Expand Links
LawChangeALLEARN Class, LawChangeALLEARN Members, LawChangeALLEARN Methods


LawChangeALLEARN::setYear Method

LawChangeALLEARN::setYear Method
LawChangeALLEARN Class LawChangeALLEARN Members LawChangeALLEARN Methods

Sets starting year when increasing number of earnings years.

C++
void setYear(
    int newYear
);
Collapse Expand Parameters
Parameters | Description
int newYear | New starting year when increasing number of earnings years.
Collapse Expand Group

LawChangeALLEARN Methods

Collapse Expand Links
LawChangeALLEARN Class, LawChangeALLEARN Members, LawChangeALLEARN Methods


LawChangeALLEARN::write Method

LawChangeALLEARN::write Method
LawChangeALLEARN Class LawChangeALLEARN Members LawChangeALLEARN Methods

Writes a line with first and last years, and step size.

C++
void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChangeALLEARN Methods

Collapse Expand Links
LawChangeALLEARN Class, LawChangeALLEARN Members, LawChangeALLEARN Methods


LawChangeArray Class

LawChangeArray Class
LawChangeArray Data Members LawChangeArray Methods LawChangeArray Members LawChangeArray.h Classes

Manages an array of LawChange's.

Collapse Expand Class Hierarchy
  LawChangeArrayLawChangeArrayLawChangeArray
C++
class LawChangeArray : public Document;
Collapse Expand File

File: LawChangeArray.h

Module: PiaData Library

Collapse Expand Remarks

Manages an array of LawChange's.

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeArray Data Members, LawChangeArray Methods, LawChangeArray Members, LawChangeArray.h, Classes


LawChangeArray Members

LawChangeArray Members
LawChangeArray Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by LawChangeArray.

Collapse Expand Class

LawChangeArray Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
pathname | Pathname of this file.
Collapse Expand Public Data Members
Name | Description
lawChange | Pointers to the law changes.
lawChangeAGE65COMP | Pointer to LawChangeAGE65COMP.
lawChangeALLEARN | Pointer to LawChangeALLEARN.
lawChangeBPFRACWAGE | Pointer to LawChangeBPFRACWAGE.
lawChangeBPMINCONST | Pointer to LawChangeBPMINCONST.
lawChangeBPSPECRATE | Pointer to LawChangeBPSPECRATE.
lawChangeCHILDCARECREDIT | Pointer to LawChangeCHILDCARECREDIT.
lawChangeCHILDCAREDROPOUT | Pointer to LawChangeCHILDCAREDROPOUT.
lawChangeCOLACHANGE | Pointer to LawChangeCOLACHANGE.
lawChangeDECLINEPERC | Pointer to LawChangeDECLINEPERC.
lawChangeDROPOUTCHG | Pointer to LawChangeDROPOUTCHG.
lawChangeMARRLENGTH | Pointer to LawChangeMARRLENGTH.
lawChangeNEWFORMULA | Pointer to LawChangeNEWFORMULA.
lawChangeNEWSPECMIN | Pointer to LawChangeNEWSPECMIN.
lawChangeNRACHANGE | Pointer to LawChangeNRACHANGE.
lawChangePSAACCT | Pointer to LawChangePSAACCT.
lawChangeTAXBENCHG | Pointer to LawChangeTAXBENCHG.
lawChangeTAXRATECHG | Pointer to LawChangeTAXRATECHG.
lawChangeWAGEBASECHG | Pointer to LawChangeWAGEBASECHG.
lawChangeWIDFACTOR | Pointer to LawChangeWIDFACTOR.
lawChangeWIFEFACTOR | Pointer to LawChangeWIFEFACTOR.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
LawChangeArray | Initializes law-change array.
errormesg | Returns message when error reading from file.
getCorename | Returns the core file name, before modifiers or extensions.
getIndTotal | Returns total of law-change indicators (is greater than 0 if any law changes).
getModifier | Returns the modifier on the file name.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
indTotalCal | Calculates total changes in law.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
readmesg | Returns message when reading from file.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
writemesg | Returns message when writing to file.
~LawChangeArray | Destructor.
Collapse Expand Links
LawChangeArray Class, Legend, Protected Data Members, Public Data Members, Public Methods


LawChangeArray::LawChangeArray Constructor

LawChangeArray::LawChangeArray Constructor
LawChangeArray Class LawChangeArray Members LawChangeArray Class

Initializes law-change array.

C++
LawChangeArray(
    int startt,
    int newMaxyear,
    const std::string& newDirectory
);
Collapse Expand Parameters
Parameters | Description
int startt | Earliest starting year for changes.
int newMaxyear | Maximum projected year.
const std::string& newDirectory | Directory with law-change indicators.
Collapse Expand Remarks

Creates all of the LawChange's.

Collapse Expand Class

LawChangeArray Class

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Class


LawChangeArray::~LawChangeArray Destructor

LawChangeArray::~LawChangeArray Destructor
LawChangeArray Class LawChangeArray Members LawChangeArray Class

Destructor.

C++
~LawChangeArray();
Collapse Expand Remarks

Deletes all of the LawChange's.

Collapse Expand Class

LawChangeArray Class

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Class


LawChangeArray Data Members

LawChangeArray Data Members
LawChangeArray Class Legend Public Data Members

The data members of the LawChangeArray class are listed here.

Collapse Expand Class

LawChangeArray Class

Collapse Expand Public Data Members
Name | Description
lawChange | Pointers to the law changes.
lawChangeAGE65COMP | Pointer to LawChangeAGE65COMP.
lawChangeALLEARN | Pointer to LawChangeALLEARN.
lawChangeBPFRACWAGE | Pointer to LawChangeBPFRACWAGE.
lawChangeBPMINCONST | Pointer to LawChangeBPMINCONST.
lawChangeBPSPECRATE | Pointer to LawChangeBPSPECRATE.
lawChangeCHILDCARECREDIT | Pointer to LawChangeCHILDCARECREDIT.
lawChangeCHILDCAREDROPOUT | Pointer to LawChangeCHILDCAREDROPOUT.
lawChangeCOLACHANGE | Pointer to LawChangeCOLACHANGE.
lawChangeDECLINEPERC | Pointer to LawChangeDECLINEPERC.
lawChangeDROPOUTCHG | Pointer to LawChangeDROPOUTCHG.
lawChangeMARRLENGTH | Pointer to LawChangeMARRLENGTH.
lawChangeNEWFORMULA | Pointer to LawChangeNEWFORMULA.
lawChangeNEWSPECMIN | Pointer to LawChangeNEWSPECMIN.
lawChangeNRACHANGE | Pointer to LawChangeNRACHANGE.
lawChangePSAACCT | Pointer to LawChangePSAACCT.
lawChangeTAXBENCHG | Pointer to LawChangeTAXBENCHG.
lawChangeTAXRATECHG | Pointer to LawChangeTAXRATECHG.
lawChangeWAGEBASECHG | Pointer to LawChangeWAGEBASECHG.
lawChangeWIDFACTOR | Pointer to LawChangeWIDFACTOR.
lawChangeWIFEFACTOR | Pointer to LawChangeWIFEFACTOR.
Collapse Expand Links
LawChangeArray Class, Legend, Public Data Members


LawChangeArray::lawChange Data Member

LawChangeArray::lawChange Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointers to the law changes.

C++
std::vector<LawChange *> lawChange;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeAGE65COMP Data Member

LawChangeArray::lawChangeAGE65COMP Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeAGE65COMP.

C++
LawChangeAGE65COMP * lawChangeAGE65COMP;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeALLEARN Data Member

LawChangeArray::lawChangeALLEARN Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeALLEARN.

C++
LawChangeALLEARN * lawChangeALLEARN;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeBPFRACWAGE Data Member

LawChangeArray::lawChangeBPFRACWAGE Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeBPFRACWAGE.

C++
LawChangeBPFRACWAGE * lawChangeBPFRACWAGE;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeBPMINCONST Data Member

LawChangeArray::lawChangeBPMINCONST Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeBPMINCONST.

C++
LawChangeBPMINCONST * lawChangeBPMINCONST;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeBPSPECRATE Data Member

LawChangeArray::lawChangeBPSPECRATE Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeBPSPECRATE.

C++
LawChangeBPSPECRATE * lawChangeBPSPECRATE;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeCHILDCARECREDIT Data Member

LawChangeArray::lawChangeCHILDCARECREDIT Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeCHILDCARECREDIT.

C++
LawChangeCHILDCARECREDIT * lawChangeCHILDCARECREDIT;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeCHILDCAREDROPOUT Data Member

LawChangeArray::lawChangeCHILDCAREDROPOUT Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeCHILDCAREDROPOUT.

C++
LawChangeCHILDCAREDROPOUT * lawChangeCHILDCAREDROPOUT;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeCOLACHANGE Data Member

LawChangeArray::lawChangeCOLACHANGE Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeCOLACHANGE.

C++
LawChangeCOLACHANGE * lawChangeCOLACHANGE;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeDECLINEPERC Data Member

LawChangeArray::lawChangeDECLINEPERC Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeDECLINEPERC.

C++
LawChangeDECLINEPERC * lawChangeDECLINEPERC;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeDROPOUTCHG Data Member

LawChangeArray::lawChangeDROPOUTCHG Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeDROPOUTCHG.

C++
LawChangeDROPOUTCHG * lawChangeDROPOUTCHG;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeMARRLENGTH Data Member

LawChangeArray::lawChangeMARRLENGTH Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeMARRLENGTH.

C++
LawChangeMARRLENGTH * lawChangeMARRLENGTH;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeNEWFORMULA Data Member

LawChangeArray::lawChangeNEWFORMULA Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeNEWFORMULA.

C++
LawChangeNEWFORMULA * lawChangeNEWFORMULA;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeNEWSPECMIN Data Member

LawChangeArray::lawChangeNEWSPECMIN Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeNEWSPECMIN.

C++
LawChangeNEWSPECMIN * lawChangeNEWSPECMIN;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeNRACHANGE Data Member

LawChangeArray::lawChangeNRACHANGE Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeNRACHANGE.

C++
LawChangeNRACHANGE * lawChangeNRACHANGE;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangePSAACCT Data Member

LawChangeArray::lawChangePSAACCT Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangePSAACCT.

C++
LawChangePSAACCT * lawChangePSAACCT;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeTAXBENCHG Data Member

LawChangeArray::lawChangeTAXBENCHG Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeTAXBENCHG.

C++
LawChangeTAXBENCHG * lawChangeTAXBENCHG;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeTAXRATECHG Data Member

LawChangeArray::lawChangeTAXRATECHG Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeTAXRATECHG.

C++
LawChangeTAXRATECHG * lawChangeTAXRATECHG;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeWAGEBASECHG Data Member

LawChangeArray::lawChangeWAGEBASECHG Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeWAGEBASECHG.

C++
LawChangeWAGEBASECHG * lawChangeWAGEBASECHG;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeWIDFACTOR Data Member

LawChangeArray::lawChangeWIDFACTOR Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeWIDFACTOR.

C++
LawChangeWIDFACTOR * lawChangeWIDFACTOR;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray::lawChangeWIFEFACTOR Data Member

LawChangeArray::lawChangeWIFEFACTOR Data Member
LawChangeArray Class LawChangeArray Members LawChangeArray Data Members

Pointer to LawChangeWIFEFACTOR.

C++
LawChangeWIFEFACTOR * lawChangeWIFEFACTOR;
Collapse Expand Group

LawChangeArray Data Members

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Data Members


LawChangeArray Methods

LawChangeArray Methods
LawChangeArray Class Legend Public Methods

The methods of the LawChangeArray class are listed here.

Collapse Expand Class

LawChangeArray Class

Collapse Expand Public Methods
Name | Description
getIndTotal | Returns total of law-change indicators (is greater than 0 if any law changes).
indTotalCal | Calculates total changes in law.
Collapse Expand Links
LawChangeArray Class, Legend, Public Methods


LawChangeArray::getIndTotal Method

LawChangeArray::getIndTotal Method
LawChangeArray Class LawChangeArray Members LawChangeArray Methods

Returns total of law-change indicators (is greater than 0 if any law changes).

C++
int getIndTotal() const;
Collapse Expand Returns

Total of law-change indicators (is greater than 0 if any law changes).

Collapse Expand Group

LawChangeArray Methods

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Methods


LawChangeArray::indTotalCal Method

LawChangeArray::indTotalCal Method
LawChangeArray Class LawChangeArray Members LawChangeArray Methods

Calculates total changes in law.

C++
void indTotalCal();
Collapse Expand Group

LawChangeArray Methods

Collapse Expand Links
LawChangeArray Class, LawChangeArray Members, LawChangeArray Methods


LawChangeBPFRACWAGE Class

LawChangeBPFRACWAGE Class
LawChangeBPFRACWAGE Methods LawChangeBPFRACWAGE Members LawChangeBPFRACWAGE.h Classes

Parameters for a proposal to increase the bend points in the benefit formula by a fraction of average wage growth.

Collapse Expand Class Hierarchy
  LawChangeBPFRACWAGELawChangeBPFRACWAGE
C++
class LawChangeBPFRACWAGE : public LawChange;
Collapse Expand File

File: LawChangeBPFRACWAGE.h

Module: PiaData Library

Collapse Expand Remarks

There is one additional data field compared to the base class.

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeBPFRACWAGE Methods, LawChangeBPFRACWAGE Members, LawChangeBPFRACWAGE.h, Classes


LawChangeBPFRACWAGE Members

LawChangeBPFRACWAGE Members
Enumerations LawChangeBPFRACWAGE Class Legend Public Methods

The following tables list the members exposed by LawChangeBPFRACWAGE.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeBPFRACWAGE Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeBPFRACWAGE | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getProportionBendPoints | Returns proportion of wage increase applied to bend points.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setProportionBendPoints | Sets proportion of wage increase applied to bend points.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeBPFRACWAGE Class, Legend, Public Methods


LawChangeBPFRACWAGE::LawChangeBPFRACWAGE Constructor

LawChangeBPFRACWAGE::LawChangeBPFRACWAGE Constructor
LawChangeBPFRACWAGE Class LawChangeBPFRACWAGE Members LawChangeBPFRACWAGE Class

Constructor.

C++
LawChangeBPFRACWAGE();
Collapse Expand Class

LawChangeBPFRACWAGE Class

Collapse Expand Links
LawChangeBPFRACWAGE Class, LawChangeBPFRACWAGE Members, LawChangeBPFRACWAGE Class


LawChangeBPFRACWAGE Methods

LawChangeBPFRACWAGE Methods
LawChangeBPFRACWAGE Class Legend Public Methods

The methods of the LawChangeBPFRACWAGE class are listed here.

Collapse Expand Class

LawChangeBPFRACWAGE Class

Collapse Expand Public Methods
Name | Description
getProportionBendPoints | Returns proportion of wage increase applied to bend points.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setProportionBendPoints | Sets proportion of wage increase applied to bend points.
write | Writes a line with first and last years, and percentage.
Collapse Expand Links
LawChangeBPFRACWAGE Class, Legend, Public Methods


LawChangeBPFRACWAGE::getProportionBendPoints Method

LawChangeBPFRACWAGE::getProportionBendPoints Method
LawChangeBPFRACWAGE Class LawChangeBPFRACWAGE Members LawChangeBPFRACWAGE Methods

Returns proportion of wage increase applied to bend points.

C++
double getProportionBendPoints() const;
Collapse Expand Returns

Proportion of wage increase applied to bend points.

Collapse Expand Group

LawChangeBPFRACWAGE Methods

Collapse Expand Links
LawChangeBPFRACWAGE Class, LawChangeBPFRACWAGE Members, LawChangeBPFRACWAGE Methods


LawChangeBPFRACWAGE::prepareStrings Method

LawChangeBPFRACWAGE::prepareStrings Method
LawChangeBPFRACWAGE Class LawChangeBPFRACWAGE Members LawChangeBPFRACWAGE Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeBPFRACWAGE Methods

Collapse Expand Links
LawChangeBPFRACWAGE Class, LawChangeBPFRACWAGE Members, LawChangeBPFRACWAGE Methods


LawChangeBPFRACWAGE::read Method

LawChangeBPFRACWAGE::read Method
LawChangeBPFRACWAGE Class LawChangeBPFRACWAGE Members LawChangeBPFRACWAGE Methods

Reads all the lines required for this law-change.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Group

LawChangeBPFRACWAGE Methods

Collapse Expand Links
LawChangeBPFRACWAGE Class, LawChangeBPFRACWAGE Members, LawChangeBPFRACWAGE Methods


LawChangeBPFRACWAGE::setProportionBendPoints Method

LawChangeBPFRACWAGE::setProportionBendPoints Method
LawChangeBPFRACWAGE Class LawChangeBPFRACWAGE Members LawChangeBPFRACWAGE Methods

Sets proportion of wage increase applied to bend points.

C++
void setProportionBendPoints(
    double proportion
);
Collapse Expand Parameters
Parameters | Description
double proportion | New proportion of wage increase applied to bend points.
Collapse Expand Group

LawChangeBPFRACWAGE Methods

Collapse Expand Links
LawChangeBPFRACWAGE Class, LawChangeBPFRACWAGE Members, LawChangeBPFRACWAGE Methods


LawChangeBPFRACWAGE::write Method

LawChangeBPFRACWAGE::write Method
LawChangeBPFRACWAGE Class LawChangeBPFRACWAGE Members LawChangeBPFRACWAGE Methods

Writes a line with first and last years, and percentage.

C++
void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChangeBPFRACWAGE Methods

Collapse Expand Links
LawChangeBPFRACWAGE Class, LawChangeBPFRACWAGE Members, LawChangeBPFRACWAGE Methods


LawChangeBPMINCONST Class

LawChangeBPMINCONST Class
LawChangeBPMINCONST Methods LawChangeBPMINCONST Members LawChangeBPMINCONST.h Classes

Parameters for a proposal to increase the bend points in the benefit formula by the growth in wages minus a specified rate.

Collapse Expand Class Hierarchy
  LawChangeBPMINCONSTLawChangeBPMINCONST
C++
class LawChangeBPMINCONST : public LawChange;
Collapse Expand File

File: LawChangeBPMINCONST.h

Module: PiaData Library

Collapse Expand Remarks

There is one additional data field compared to the base class, to hold the constant percentage subtracted from bend point increase.

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeBPMINCONST Methods, LawChangeBPMINCONST Members, LawChangeBPMINCONST.h, Classes


LawChangeBPMINCONST Members

LawChangeBPMINCONST Members
Enumerations LawChangeBPMINCONST Class Legend Public Methods

The following tables list the members exposed by LawChangeBPMINCONST.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeBPMINCONST Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeBPMINCONST | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getConstantPerc | Returns constant percentage subtracted from bend point increase.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setConstantPerc | Sets constant percentage subtracted from bend point increase.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeBPMINCONST Class, Legend, Public Methods


LawChangeBPMINCONST::LawChangeBPMINCONST Constructor

LawChangeBPMINCONST::LawChangeBPMINCONST Constructor
LawChangeBPMINCONST Class LawChangeBPMINCONST Members LawChangeBPMINCONST Class

Constructor.

C++
LawChangeBPMINCONST();
Collapse Expand Class

LawChangeBPMINCONST Class

Collapse Expand Links
LawChangeBPMINCONST Class, LawChangeBPMINCONST Members, LawChangeBPMINCONST Class


LawChangeBPMINCONST Methods

LawChangeBPMINCONST Methods
LawChangeBPMINCONST Class Legend Public Methods

The methods of the LawChangeBPMINCONST class are listed here.

Collapse Expand Class

LawChangeBPMINCONST Class

Collapse Expand Public Methods
Name | Description
getConstantPerc | Returns constant percentage subtracted from bend point increase.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setConstantPerc | Sets constant percentage subtracted from bend point increase.
write | Writes a line with first and last years, and percentage.
Collapse Expand Links
LawChangeBPMINCONST Class, Legend, Public Methods


LawChangeBPMINCONST::getConstantPerc Method

LawChangeBPMINCONST::getConstantPerc Method
LawChangeBPMINCONST Class LawChangeBPMINCONST Members LawChangeBPMINCONST Methods

Returns constant percentage subtracted from bend point increase.

C++
double getConstantPerc() const;
Collapse Expand Returns

Constant percentage subtracted from bend point increase.

Collapse Expand Group

LawChangeBPMINCONST Methods

Collapse Expand Links
LawChangeBPMINCONST Class, LawChangeBPMINCONST Members, LawChangeBPMINCONST Methods


LawChangeBPMINCONST::prepareStrings Method

LawChangeBPMINCONST::prepareStrings Method
LawChangeBPMINCONST Class LawChangeBPMINCONST Members LawChangeBPMINCONST Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeBPMINCONST Methods

Collapse Expand Links
LawChangeBPMINCONST Class, LawChangeBPMINCONST Members, LawChangeBPMINCONST Methods


LawChangeBPMINCONST::read Method

LawChangeBPMINCONST::read Method
LawChangeBPMINCONST Class LawChangeBPMINCONST Members LawChangeBPMINCONST Methods

Reads all the lines required for this law-change.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Group

LawChangeBPMINCONST Methods

Collapse Expand Links
LawChangeBPMINCONST Class, LawChangeBPMINCONST Members, LawChangeBPMINCONST Methods


LawChangeBPMINCONST::setConstantPerc Method

LawChangeBPMINCONST::setConstantPerc Method
LawChangeBPMINCONST Class LawChangeBPMINCONST Members LawChangeBPMINCONST Methods

Sets constant percentage subtracted from bend point increase.

C++
void setConstantPerc(
    double newConstantPerc
);
Collapse Expand Parameters
Parameters | Description
double newConstantPerc | New constant percentage subtracted from bend point increase.
Collapse Expand Group

LawChangeBPMINCONST Methods

Collapse Expand Links
LawChangeBPMINCONST Class, LawChangeBPMINCONST Members, LawChangeBPMINCONST Methods


LawChangeBPMINCONST::write Method

LawChangeBPMINCONST::write Method
LawChangeBPMINCONST Class LawChangeBPMINCONST Members LawChangeBPMINCONST Methods

Writes a line with first and last years, and percentage.

C++
void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChangeBPMINCONST Methods

Collapse Expand Links
LawChangeBPMINCONST Class, LawChangeBPMINCONST Members, LawChangeBPMINCONST Methods


LawChangeBPSPECRATE Class

LawChangeBPSPECRATE Class
LawChangeBPSPECRATE Methods LawChangeBPSPECRATE Members LawChangeBPSPECRATE.h Classes

Parameters for a proposal to increase the bend points in the benefit formula by a specified growth rate.

Collapse Expand Class Hierarchy
  LawChangeBPSPECRATELawChangeBPSPECRATE
C++
class LawChangeBPSPECRATE : public LawChange;
Collapse Expand File

File: LawChangeBPSPECRATE.h

Module: PiaData Library

Collapse Expand Remarks

There is one additional data field compared to the base class, to hold the vector of bend point increase percentages for the PIA formula.

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeBPSPECRATE Methods, LawChangeBPSPECRATE Members, LawChangeBPSPECRATE.h, Classes


LawChangeBPSPECRATE Members

LawChangeBPSPECRATE Members
Enumerations LawChangeBPSPECRATE Class Legend Public Methods

The following tables list the members exposed by LawChangeBPSPECRATE.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeBPSPECRATE Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeBPSPECRATE | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getBendPiaInc | Returns bend point increase percentage for specified year.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setBendPiaInc | Sets bend point increase percentage for specified year.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeBPSPECRATE Class, Legend, Public Methods


LawChangeBPSPECRATE::LawChangeBPSPECRATE Constructor

LawChangeBPSPECRATE::LawChangeBPSPECRATE Constructor
LawChangeBPSPECRATE Class LawChangeBPSPECRATE Members LawChangeBPSPECRATE Class

Constructor.

C++
LawChangeBPSPECRATE();
Collapse Expand Class

LawChangeBPSPECRATE Class

Collapse Expand Links
LawChangeBPSPECRATE Class, LawChangeBPSPECRATE Members, LawChangeBPSPECRATE Class


LawChangeBPSPECRATE Methods

LawChangeBPSPECRATE Methods
LawChangeBPSPECRATE Class Legend Public Methods

The methods of the LawChangeBPSPECRATE class are listed here.

Collapse Expand Class

LawChangeBPSPECRATE Class

Collapse Expand Public Methods
Name | Description
getBendPiaInc | Returns bend point increase percentage for specified year.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setBendPiaInc | Sets bend point increase percentage for specified year.
write | Writes a line with first and last years, and percentage.
Collapse Expand Links
LawChangeBPSPECRATE Class, Legend, Public Methods


LawChangeBPSPECRATE::getBendPiaInc Method

LawChangeBPSPECRATE::getBendPiaInc Method
LawChangeBPSPECRATE Class LawChangeBPSPECRATE Members LawChangeBPSPECRATE Methods

Returns bend point increase percentage for specified year.

C++
double getBendPiaInc(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which bend point increase percentage is desired.
Collapse Expand Returns

Bend point increase percentage for specified year.

Collapse Expand Group

LawChangeBPSPECRATE Methods

Collapse Expand Links
LawChangeBPSPECRATE Class, LawChangeBPSPECRATE Members, LawChangeBPSPECRATE Methods


LawChangeBPSPECRATE::prepareStrings Method

LawChangeBPSPECRATE::prepareStrings Method
LawChangeBPSPECRATE Class LawChangeBPSPECRATE Members LawChangeBPSPECRATE Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeBPSPECRATE Methods

Collapse Expand Links
LawChangeBPSPECRATE Class, LawChangeBPSPECRATE Members, LawChangeBPSPECRATE Methods


LawChangeBPSPECRATE::read Method

LawChangeBPSPECRATE::read Method
LawChangeBPSPECRATE Class LawChangeBPSPECRATE Members LawChangeBPSPECRATE Methods

Reads all the lines required for this law-change.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_LAWCHG6 if there are not enough entries on the first line for first year, last year, phase-in type, and a bend point increase factor for each year.
Collapse Expand Group

LawChangeBPSPECRATE Methods

Collapse Expand Links
LawChangeBPSPECRATE Class, LawChangeBPSPECRATE Members, LawChangeBPSPECRATE Methods


LawChangeBPSPECRATE::setBendPiaInc Method

LawChangeBPSPECRATE::setBendPiaInc Method
LawChangeBPSPECRATE Class LawChangeBPSPECRATE Members LawChangeBPSPECRATE Methods

Sets bend point increase percentage for specified year.

C++
void setBendPiaInc(
    int year,
    double newData
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which bend point increase percentage is set.
double newData | New bend point increase percentage.
Collapse Expand Group

LawChangeBPSPECRATE Methods

Collapse Expand Links
LawChangeBPSPECRATE Class, LawChangeBPSPECRATE Members, LawChangeBPSPECRATE Methods


LawChangeBPSPECRATE::write Method

LawChangeBPSPECRATE::write Method
LawChangeBPSPECRATE Class LawChangeBPSPECRATE Members LawChangeBPSPECRATE Methods

Writes a line with first and last years, and percentage.

C++
void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChangeBPSPECRATE Methods

Collapse Expand Links
LawChangeBPSPECRATE Class, LawChangeBPSPECRATE Members, LawChangeBPSPECRATE Methods


LawChangeCHILDCARECREDIT Class

LawChangeCHILDCARECREDIT Class
LawChangeCHILDCARECREDIT Methods LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT.h Classes

Parameters for a proposal to provide child care credits.

Collapse Expand Class Hierarchy
  LawChangeCHILDCARECREDITLawChangeCHILDCARECREDIT
C++
class LawChangeCHILDCARECREDIT : public LawChange;
Collapse Expand File

File: LawChangeCHILDCARECREDIT.h

Module: PiaData Library

Collapse Expand Remarks

There are 2 types of child care credit proposals handled by this class. The first type provides an earnings credit for anybody that has an eligible child in care. To be eligible, the child must be under a specified age (see getMaxAge). The amount of the credit is equal to a specified percentage (see getFqRatio) of the wage base in the year of the credit. The number of years that the person is eligible for the credit is specifed (see getMaxYears), and the creditable years are determined such that the person's PIA will be maximized (i.e., not just taking the first years in which the person is elgible for the credit.) Although the proposal starts in a specified year, the historical earnings (before that start year) used for the person's PIA calculation may or may not have credits applied. This is specified by getChildCareYearsBeforeEffYear.

The second type of child care credit proposal handled by this class also provides earnings credits to those who have an eligible child in care. But these credits are based on the person earnings history up to the point of the potential credit. The person uses the his/her top years of earnings. The number of these years is specified (see getNumTopEarnYears). After finding this group of top years of earnings, some extreme years (the years with the highest and lowest of earnings) are dropped out of this group. The number of extreme years is specified (see getNumDropExtremeEarnYears). For example, dropping 2 extreme years means to drop the 2 highest and 2 lowest years of earnings. The remaining years of earnings in the selected group are averaged together and a specified percentage of that average (see getAvgEarnPct) is used as the credit amount. The other parameters are the same as the first version of the child care credit proposal, except that getFqRatio is not used.

One additional note is that for both versions of the proposal, the credit given is not added on to any earnings that the person already has in that year. It is the total amount of earnings the person is credited in that year. For example, if a person has $10,000 of earnings in the year, and the credit amount is calculated to be $15,000, then the new amount of earnings for that person in that year is $15,000 (i.e., $5,000 on top of his/her regular earnings for that year).

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeCHILDCARECREDIT Methods, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT.h, Classes


LawChangeCHILDCARECREDIT Members

LawChangeCHILDCARECREDIT Members
Enumerations LawChangeCHILDCARECREDIT Class Legend Public Methods

The following tables list the members exposed by LawChangeCHILDCARECREDIT.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeCHILDCARECREDIT Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeCHILDCARECREDIT | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getAvgEarnPct | Returns the percentage to be multiplied by the person's average earnings to calculate the credit amount.
getChildCareYearsBeforeEffYear | Returns true if the person can be credited for child care years before the first effective year of the proposal, false otherwise.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getFqRatio | Returns ratio of average earnings credited for a child care year.
getInd | Returns indicator for this law-change.
getMaxAge | Returns maximum age of child to get credited for a child care year.
getMaxYears | Returns maximum number of child care years.
getNumDropExtremeEarnYears | Returns the number of years of highest earnings to drop out of the calculation of the credit amount.
getNumTopEarnYears | Returns the number of highest earnings years to look at for the calculation of the credit amount.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setAvgEarnPct | Sets the percentage to be multiplied by the person's average earnings to calculate the credit amount.
setChildCareYearsBeforeEffYear | Sets if the person can be credited for child care years before the first effective year of the proposal.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setFqRatio | Sets ratio of average earnings credited for a child care year.
setInd | Sets change indicator for this law-change.
setMaxAge | Sets maximum age of child to get credit for a child care year.
setMaxYears | Sets maximum number of child care years.
setNumDropExtremeEarnYears | Sets the number of years of highest earnings to drop out of the calculation of the credit amount.
setNumTopEarnYears | Sets the number of highest earnings years to look at for the calculation of the credit amount.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeCHILDCARECREDIT Class, Legend, Public Methods


LawChangeCHILDCARECREDIT::LawChangeCHILDCARECREDIT Constructor

LawChangeCHILDCARECREDIT::LawChangeCHILDCARECREDIT Constructor
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Class

Constructor.

C++
LawChangeCHILDCARECREDIT();
Collapse Expand Class

LawChangeCHILDCARECREDIT Class

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Class


LawChangeCHILDCARECREDIT Methods

LawChangeCHILDCARECREDIT Methods
LawChangeCHILDCARECREDIT Class Legend Public Methods

The methods of the LawChangeCHILDCARECREDIT class are listed here.

Collapse Expand Class

LawChangeCHILDCARECREDIT Class

Collapse Expand Public Methods
Name | Description
getAvgEarnPct | Returns the percentage to be multiplied by the person's average earnings to calculate the credit amount.
getChildCareYearsBeforeEffYear | Returns true if the person can be credited for child care years before the first effective year of the proposal, false otherwise.
getFqRatio | Returns ratio of average earnings credited for a child care year.
getMaxAge | Returns maximum age of child to get credited for a child care year.
getMaxYears | Returns maximum number of child care years.
getNumDropExtremeEarnYears | Returns the number of years of highest earnings to drop out of the calculation of the credit amount.
getNumTopEarnYears | Returns the number of highest earnings years to look at for the calculation of the credit amount.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setAvgEarnPct | Sets the percentage to be multiplied by the person's average earnings to calculate the credit amount.
setChildCareYearsBeforeEffYear | Sets if the person can be credited for child care years before the first effective year of the proposal.
setFqRatio | Sets ratio of average earnings credited for a child care year.
setMaxAge | Sets maximum age of child to get credit for a child care year.
setMaxYears | Sets maximum number of child care years.
setNumDropExtremeEarnYears | Sets the number of years of highest earnings to drop out of the calculation of the credit amount.
setNumTopEarnYears | Sets the number of highest earnings years to look at for the calculation of the credit amount.
write | Writes a line with first and last years, and percentage.
Collapse Expand Links
LawChangeCHILDCARECREDIT Class, Legend, Public Methods


LawChangeCHILDCARECREDIT::getAvgEarnPct Method

LawChangeCHILDCARECREDIT::getAvgEarnPct Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Returns the percentage to be multiplied by the person's average earnings to calculate the credit amount.

C++
double getAvgEarnPct() const;
Collapse Expand Returns

The percentage to be multiplied by the person's average earnings to calculate the credit amount.

Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCARECREDIT::getChildCareYearsBeforeEffYear Method

LawChangeCHILDCARECREDIT::getChildCareYearsBeforeEffYear Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Returns true if the person can be credited for child care years before the first effective year of the proposal, false otherwise.

C++
bool getChildCareYearsBeforeEffYear() const;
Collapse Expand Returns

True if the person can be credited for child care years before the first effective year of the proposal, false otherwise.

Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCARECREDIT::getFqRatio Method

LawChangeCHILDCARECREDIT::getFqRatio Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Returns ratio of average earnings credited for a child care year.

C++
double getFqRatio() const;
Collapse Expand Returns

Ratio of average earnings credited for a child care year.

Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCARECREDIT::getMaxAge Method

LawChangeCHILDCARECREDIT::getMaxAge Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Returns maximum age of child to get credited for a child care year.

C++
int getMaxAge() const;
Collapse Expand Returns

Maximum age of child to get credited for a child care year.

Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCARECREDIT::getMaxYears Method

LawChangeCHILDCARECREDIT::getMaxYears Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Returns maximum number of child care years.

C++
int getMaxYears() const;
Collapse Expand Returns

Maximum number of child care years.

Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCARECREDIT::getNumDropExtremeEarnYears Method

LawChangeCHILDCARECREDIT::getNumDropExtremeEarnYears Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Returns the number of years of highest earnings to drop out of the calculation of the credit amount.

C++
int getNumDropExtremeEarnYears() const;
Collapse Expand Returns

The number of years of highest earnings to drop out of the calculation of the credit amount.

Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCARECREDIT::getNumTopEarnYears Method

LawChangeCHILDCARECREDIT::getNumTopEarnYears Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Returns the number of highest earnings years to look at for the calculation of the credit amount.

C++
int getNumTopEarnYears() const;
Collapse Expand Returns

The number of highest earnings years to look at for the calculation of the credit amount.

Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCARECREDIT::prepareStrings Method

LawChangeCHILDCARECREDIT::prepareStrings Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCARECREDIT::read Method

LawChangeCHILDCARECREDIT::read Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Reads all the lines required for this law-change.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Remarks

There are 2 types of child care credit proposals. The first is based on a set percentage of the current year's wage base. And the second is based on the person's earnings history.

Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCARECREDIT::setAvgEarnPct Method

LawChangeCHILDCARECREDIT::setAvgEarnPct Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Sets the percentage to be multiplied by the person's average earnings to calculate the credit amount.

C++
void setAvgEarnPct(
    double newAvgEarnPct
);
Collapse Expand Parameters
Parameters | Description
double newAvgEarnPct | The percentage to be used.
Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCARECREDIT::setChildCareYearsBeforeEffYear Method

LawChangeCHILDCARECREDIT::setChildCareYearsBeforeEffYear Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Sets if the person can be credited for child care years before the first effective year of the proposal.

C++
void setChildCareYearsBeforeEffYear(
    int newChildCareYearsBeforeEffYear
);
Collapse Expand Parameters
Parameters | Description
int newChildCareYearsBeforeEffYear | 1 if the person can be credited for child care years before the first effective year of the proposal; 0 otherwise.
Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCARECREDIT::setFqRatio Method

LawChangeCHILDCARECREDIT::setFqRatio Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Sets ratio of average earnings credited for a child care year.

C++
void setFqRatio(
    double newFqRatio
);
Collapse Expand Parameters
Parameters | Description
double newFqRatio | New ratio of average earnings credited for a child care year.
Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCARECREDIT::setMaxAge Method

LawChangeCHILDCARECREDIT::setMaxAge Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Sets maximum age of child to get credit for a child care year.

C++
void setMaxAge(
    int newMaxAge
);
Collapse Expand Parameters
Parameters | Description
int newMaxAge | New maximum age of child.
Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCARECREDIT::setMaxYears Method

LawChangeCHILDCARECREDIT::setMaxYears Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Sets maximum number of child care years.

C++
void setMaxYears(
    int newMaxYears
);
Collapse Expand Parameters
Parameters | Description
int newMaxYears | New maximum number of child care years.
Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCARECREDIT::setNumDropExtremeEarnYears Method

LawChangeCHILDCARECREDIT::setNumDropExtremeEarnYears Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Sets the number of years of highest earnings to drop out of the calculation of the credit amount.

C++
void setNumDropExtremeEarnYears(
    int newNumDropExtremeEarnYears
);
Collapse Expand Parameters
Parameters | Description
int newNumDropExtremeEarnYears | Number of years.
Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCARECREDIT::setNumTopEarnYears Method

LawChangeCHILDCARECREDIT::setNumTopEarnYears Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Sets the number of highest earnings years to look at for the calculation of the credit amount.

C++
void setNumTopEarnYears(
    int newNumTopEarnYears
);
Collapse Expand Parameters
Parameters | Description
int newNumTopEarnYears | Number of years.
Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCARECREDIT::write Method

LawChangeCHILDCARECREDIT::write Method
LawChangeCHILDCARECREDIT Class LawChangeCHILDCARECREDIT Members LawChangeCHILDCARECREDIT Methods

Writes a line with first and last years, and percentage.

C++
void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChangeCHILDCARECREDIT Methods

Collapse Expand Links
LawChangeCHILDCARECREDIT Class, LawChangeCHILDCARECREDIT Members, LawChangeCHILDCARECREDIT Methods


LawChangeCHILDCAREDROPOUT Class

LawChangeCHILDCAREDROPOUT Class
LawChangeCHILDCAREDROPOUT Methods LawChangeCHILDCAREDROPOUT Members LawChangeCHILDCAREDROPOUT.h Classes

Parameters for a proposal to provide child care dropout years.

Collapse Expand Class Hierarchy
  LawChangeCHILDCAREDROPOUTLawChangeCHILDCAREDROPOUT
C++
class LawChangeCHILDCAREDROPOUT : public LawChange;
Collapse Expand File

File: LawChangeCHILDCAREDROPOUT.h

Module: PiaData Library

Collapse Expand Remarks

There are three additional data fields compared to the base class.

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeCHILDCAREDROPOUT Methods, LawChangeCHILDCAREDROPOUT Members, LawChangeCHILDCAREDROPOUT.h, Classes


LawChangeCHILDCAREDROPOUT Members

LawChangeCHILDCAREDROPOUT Members
Enumerations LawChangeCHILDCAREDROPOUT Class Legend Public Methods

The following tables list the members exposed by LawChangeCHILDCAREDROPOUT.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeCHILDCAREDROPOUT Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeCHILDCAREDROPOUT | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getFqRatio | Returns ratio of average earnings limit for a child care dropout year.
getInd | Returns indicator for this law-change.
getMaxAge | Returns maximum age of child to get a child care dropout year.
getMaxYears | Returns maximum number of child care dropout years.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setFqRatio | Sets ratio of average earnings limit for a child care dropout year.
setInd | Sets change indicator for this law-change.
setMaxAge | Sets maximum age of child to get a child care dropout year.
setMaxYears | Sets maximum number of child care dropout years.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeCHILDCAREDROPOUT Class, Legend, Public Methods


LawChangeCHILDCAREDROPOUT::LawChangeCHILDCAREDROPOUT Constructor

LawChangeCHILDCAREDROPOUT::LawChangeCHILDCAREDROPOUT Constructor
LawChangeCHILDCAREDROPOUT Class LawChangeCHILDCAREDROPOUT Members LawChangeCHILDCAREDROPOUT Class

Constructor.

C++
LawChangeCHILDCAREDROPOUT();
Collapse Expand Class

LawChangeCHILDCAREDROPOUT Class

Collapse Expand Links
LawChangeCHILDCAREDROPOUT Class, LawChangeCHILDCAREDROPOUT Members, LawChangeCHILDCAREDROPOUT Class


LawChangeCHILDCAREDROPOUT Methods

LawChangeCHILDCAREDROPOUT Methods
LawChangeCHILDCAREDROPOUT Class Legend Public Methods

The methods of the LawChangeCHILDCAREDROPOUT class are listed here.

Collapse Expand Class

LawChangeCHILDCAREDROPOUT Class

Collapse Expand Public Methods
Name | Description
getFqRatio | Returns ratio of average earnings limit for a child care dropout year.
getMaxAge | Returns maximum age of child to get a child care dropout year.
getMaxYears | Returns maximum number of child care dropout years.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setFqRatio | Sets ratio of average earnings limit for a child care dropout year.
setMaxAge | Sets maximum age of child to get a child care dropout year.
setMaxYears | Sets maximum number of child care dropout years.
write | Writes a line with first and last years, and percentage.
Collapse Expand Links
LawChangeCHILDCAREDROPOUT Class, Legend, Public Methods


LawChangeCHILDCAREDROPOUT::getFqRatio Method

LawChangeCHILDCAREDROPOUT::getFqRatio Method
LawChangeCHILDCAREDROPOUT Class LawChangeCHILDCAREDROPOUT Members LawChangeCHILDCAREDROPOUT Methods

Returns ratio of average earnings limit for a child care dropout year.

C++
double getFqRatio() const;
Collapse Expand Returns

Ratio of average earnings limit for a child care dropout year.

Collapse Expand Group

LawChangeCHILDCAREDROPOUT Methods

Collapse Expand Links
LawChangeCHILDCAREDROPOUT Class, LawChangeCHILDCAREDROPOUT Members, LawChangeCHILDCAREDROPOUT Methods


LawChangeCHILDCAREDROPOUT::getMaxAge Method

LawChangeCHILDCAREDROPOUT::getMaxAge Method
LawChangeCHILDCAREDROPOUT Class LawChangeCHILDCAREDROPOUT Members LawChangeCHILDCAREDROPOUT Methods

Returns maximum age of child to get a child care dropout year.

C++
int getMaxAge() const;
Collapse Expand Returns

Maximum age of child to get a child care dropout year.

Collapse Expand Group

LawChangeCHILDCAREDROPOUT Methods

Collapse Expand Links
LawChangeCHILDCAREDROPOUT Class, LawChangeCHILDCAREDROPOUT Members, LawChangeCHILDCAREDROPOUT Methods


LawChangeCHILDCAREDROPOUT::getMaxYears Method

LawChangeCHILDCAREDROPOUT::getMaxYears Method
LawChangeCHILDCAREDROPOUT Class LawChangeCHILDCAREDROPOUT Members LawChangeCHILDCAREDROPOUT Methods

Returns maximum number of child care dropout years.

C++
int getMaxYears() const;
Collapse Expand Returns

Maximum number of child care dropout years.

Collapse Expand Group

LawChangeCHILDCAREDROPOUT Methods

Collapse Expand Links
LawChangeCHILDCAREDROPOUT Class, LawChangeCHILDCAREDROPOUT Members, LawChangeCHILDCAREDROPOUT Methods


LawChangeCHILDCAREDROPOUT::prepareStrings Method

LawChangeCHILDCAREDROPOUT::prepareStrings Method
LawChangeCHILDCAREDROPOUT Class LawChangeCHILDCAREDROPOUT Members LawChangeCHILDCAREDROPOUT Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeCHILDCAREDROPOUT Methods

Collapse Expand Links
LawChangeCHILDCAREDROPOUT Class, LawChangeCHILDCAREDROPOUT Members, LawChangeCHILDCAREDROPOUT Methods


LawChangeCHILDCAREDROPOUT::read Method

LawChangeCHILDCAREDROPOUT::read Method
LawChangeCHILDCAREDROPOUT Class LawChangeCHILDCAREDROPOUT Members LawChangeCHILDCAREDROPOUT Methods

Reads all the lines required for this law-change.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Group

LawChangeCHILDCAREDROPOUT Methods

Collapse Expand Links
LawChangeCHILDCAREDROPOUT Class, LawChangeCHILDCAREDROPOUT Members, LawChangeCHILDCAREDROPOUT Methods


LawChangeCHILDCAREDROPOUT::setFqRatio Method

LawChangeCHILDCAREDROPOUT::setFqRatio Method
LawChangeCHILDCAREDROPOUT Class LawChangeCHILDCAREDROPOUT Members LawChangeCHILDCAREDROPOUT Methods

Sets ratio of average earnings limit for a child care dropout year.

C++
void setFqRatio(
    double newFqRatio
);
Collapse Expand Parameters
Parameters | Description
double newFqRatio | New ratio of average earnings limit for a child care dropout year.
Collapse Expand Group

LawChangeCHILDCAREDROPOUT Methods

Collapse Expand Links
LawChangeCHILDCAREDROPOUT Class, LawChangeCHILDCAREDROPOUT Members, LawChangeCHILDCAREDROPOUT Methods


LawChangeCHILDCAREDROPOUT::setMaxAge Method

LawChangeCHILDCAREDROPOUT::setMaxAge Method
LawChangeCHILDCAREDROPOUT Class LawChangeCHILDCAREDROPOUT Members LawChangeCHILDCAREDROPOUT Methods

Sets maximum age of child to get a child care dropout year.

C++
void setMaxAge(
    int newMaxAge
);
Collapse Expand Parameters
Parameters | Description
int newMaxAge | New maximum age of child.
Collapse Expand Group

LawChangeCHILDCAREDROPOUT Methods

Collapse Expand Links
LawChangeCHILDCAREDROPOUT Class, LawChangeCHILDCAREDROPOUT Members, LawChangeCHILDCAREDROPOUT Methods


LawChangeCHILDCAREDROPOUT::setMaxYears Method

LawChangeCHILDCAREDROPOUT::setMaxYears Method
LawChangeCHILDCAREDROPOUT Class LawChangeCHILDCAREDROPOUT Members LawChangeCHILDCAREDROPOUT Methods

Sets maximum number of child care dropout years.

C++
void setMaxYears(
    int newMaxYears
);
Collapse Expand Parameters
Parameters | Description
int newMaxYears | New maximum number of child care dropout years.
Collapse Expand Group

LawChangeCHILDCAREDROPOUT Methods

Collapse Expand Links
LawChangeCHILDCAREDROPOUT Class, LawChangeCHILDCAREDROPOUT Members, LawChangeCHILDCAREDROPOUT Methods


LawChangeCHILDCAREDROPOUT::write Method

LawChangeCHILDCAREDROPOUT::write Method
LawChangeCHILDCAREDROPOUT Class LawChangeCHILDCAREDROPOUT Members LawChangeCHILDCAREDROPOUT Methods

Writes a line with first and last years, and percentage.

C++
void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChangeCHILDCAREDROPOUT Methods

Collapse Expand Links
LawChangeCHILDCAREDROPOUT Class, LawChangeCHILDCAREDROPOUT Members, LawChangeCHILDCAREDROPOUT Methods


LawChangeCOLACHANGE Class

LawChangeCOLACHANGE Class
LawChangeCOLACHANGE Methods LawChangeCOLACHANGE Members LawChangeCOLACHANGE.h Classes

Parameters for a proposal to change the cost-of-living benefit increases.

Collapse Expand Class Hierarchy
  LawChangeCOLACHANGELawChangeCOLACHANGE
C++
class LawChangeCOLACHANGE : public LawChange;
Collapse Expand File

File: LawChangeCOLACHANGE.h

Module: PiaData Library

Collapse Expand Remarks

Normally the cost-of-living benefit increase equals the inflation rate. This class allows two types of changes to the COLA.

If the indicator is set to 1, it adjusts the cola up or down by a specified percentage (see getColaAdj).

If the indicator is set to 2, it limits the dollar increase in pia resulting from applying the cola to an amount determined by finding a specified percentile in the pia distribution (see getPiaPercentile).

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeCOLACHANGE Methods, LawChangeCOLACHANGE Members, LawChangeCOLACHANGE.h, Classes


LawChangeCOLACHANGE Members

LawChangeCOLACHANGE Members
Enumerations LawChangeCOLACHANGE Class Legend Public Methods

The following tables list the members exposed by LawChangeCOLACHANGE.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeCOLACHANGE Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeCOLACHANGE | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getColaAdj | Returns the amount of adjustment to COLA.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getPiaPercentile | Returns the PIA percentile to use when indicator == 2.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads the one line required for this law-change.
setColaAdj | Sets the amount of adjustment to COLA.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setPiaPercentile | Sets the PIA percentile to use when indicator == 2.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with this law-change.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeCOLACHANGE Class, Legend, Public Methods


LawChangeCOLACHANGE::LawChangeCOLACHANGE Constructor

LawChangeCOLACHANGE::LawChangeCOLACHANGE Constructor
LawChangeCOLACHANGE Class LawChangeCOLACHANGE Members LawChangeCOLACHANGE Class

Constructor.

C++
LawChangeCOLACHANGE();
Collapse Expand Remarks

It sets the amount by which to adjust the COLA and the PIA percentile to use when indicator == 2 to zero.

Collapse Expand Class

LawChangeCOLACHANGE Class

Collapse Expand Links
LawChangeCOLACHANGE Class, LawChangeCOLACHANGE Members, LawChangeCOLACHANGE Class


LawChangeCOLACHANGE Methods

LawChangeCOLACHANGE Methods
LawChangeCOLACHANGE Class Legend Public Methods

The methods of the LawChangeCOLACHANGE class are listed here.

Collapse Expand Class

LawChangeCOLACHANGE Class

Collapse Expand Public Methods
Name | Description
getColaAdj | Returns the amount of adjustment to COLA.
getPiaPercentile | Returns the PIA percentile to use when indicator == 2.
prepareStrings | Prepares output strings for this change from present law.
read | Reads the one line required for this law-change.
setColaAdj | Sets the amount of adjustment to COLA.
setPiaPercentile | Sets the PIA percentile to use when indicator == 2.
write | Writes a line with this law-change.
Collapse Expand Links
LawChangeCOLACHANGE Class, Legend, Public Methods


LawChangeCOLACHANGE::getColaAdj Method

LawChangeCOLACHANGE::getColaAdj Method
LawChangeCOLACHANGE Class LawChangeCOLACHANGE Members LawChangeCOLACHANGE Methods

Returns the amount of adjustment to COLA.

C++
double getColaAdj() const;
Collapse Expand Returns

The amount of adjustment to COLA.

Collapse Expand Group

LawChangeCOLACHANGE Methods

Collapse Expand Links
LawChangeCOLACHANGE Class, LawChangeCOLACHANGE Members, LawChangeCOLACHANGE Methods


LawChangeCOLACHANGE::getPiaPercentile Method

LawChangeCOLACHANGE::getPiaPercentile Method
LawChangeCOLACHANGE Class LawChangeCOLACHANGE Members LawChangeCOLACHANGE Methods

Returns the PIA percentile to use when indicator == 2.

C++
int getPiaPercentile() const;
Collapse Expand Returns

The PIA percentile to use when COLACHANGE == 2.

Collapse Expand Group

LawChangeCOLACHANGE Methods

Collapse Expand Links
LawChangeCOLACHANGE Class, LawChangeCOLACHANGE Members, LawChangeCOLACHANGE Methods


LawChangeCOLACHANGE::prepareStrings Method

LawChangeCOLACHANGE::prepareStrings Method
LawChangeCOLACHANGE Class LawChangeCOLACHANGE Members LawChangeCOLACHANGE Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeCOLACHANGE Methods

Collapse Expand Links
LawChangeCOLACHANGE Class, LawChangeCOLACHANGE Members, LawChangeCOLACHANGE Methods


LawChangeCOLACHANGE::read Method

LawChangeCOLACHANGE::read Method
LawChangeCOLACHANGE Class LawChangeCOLACHANGE Members LawChangeCOLACHANGE Methods

Reads the one line required for this law-change.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Remarks

It reads the first and last years, and either the percentage increase or decrease in COLA (for type 1), or the pia percentile (for type 2).

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_LAWCHG6 if there are not enough entries on the first line for first year, last year, phase-in type, and a percentage increase or decrease in COLA (for type 1), or the pia percentile (for type 2).
Collapse Expand Group

LawChangeCOLACHANGE Methods

Collapse Expand Links
LawChangeCOLACHANGE Class, LawChangeCOLACHANGE Members, LawChangeCOLACHANGE Methods


LawChangeCOLACHANGE::setColaAdj Method

LawChangeCOLACHANGE::setColaAdj Method
LawChangeCOLACHANGE Class LawChangeCOLACHANGE Members LawChangeCOLACHANGE Methods

Sets the amount of adjustment to COLA.

C++
void setColaAdj(
    double newColaAdj
);
Collapse Expand Parameters
Parameters | Description
double newColaAdj | Amount by which to adjust the COLA (negative number means a smaller COLA, positive number means a bigger COLA).
Collapse Expand Group

LawChangeCOLACHANGE Methods

Collapse Expand Links
LawChangeCOLACHANGE Class, LawChangeCOLACHANGE Members, LawChangeCOLACHANGE Methods


LawChangeCOLACHANGE::setPiaPercentile Method

LawChangeCOLACHANGE::setPiaPercentile Method
LawChangeCOLACHANGE Class LawChangeCOLACHANGE Members LawChangeCOLACHANGE Methods

Sets the PIA percentile to use when indicator == 2.

C++
void setPiaPercentile(
    int newPiaPercentile
);
Collapse Expand Parameters
Parameters | Description
int newPiaPercentile | The PIA percentile to use.
Collapse Expand Group

LawChangeCOLACHANGE Methods

Collapse Expand Links
LawChangeCOLACHANGE Class, LawChangeCOLACHANGE Members, LawChangeCOLACHANGE Methods


LawChangeCOLACHANGE::write Method

LawChangeCOLACHANGE::write Method
LawChangeCOLACHANGE Class LawChangeCOLACHANGE Members LawChangeCOLACHANGE Methods

Writes a line with this law-change.

C++
void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Remarks

The line has the first and last years, and either the percentage increase or decrease in COLA (for type 1), or the pia percentile (for type 2).

Collapse Expand Group

LawChangeCOLACHANGE Methods

Collapse Expand Links
LawChangeCOLACHANGE Class, LawChangeCOLACHANGE Members, LawChangeCOLACHANGE Methods


LawChangeDECLINEPERC Class

LawChangeDECLINEPERC Class
LawChangeDECLINEPERC Enumerations LawChangeDECLINEPERC Methods LawChangeDECLINEPERC Members LawChangeDECLINEPERC.h Classes

Parameters for a proposal to decrease the benefit formula percentages by a constant rate.

Collapse Expand Class Hierarchy
  LawChangeDECLINEPERCLawChangeDECLINEPERC
C++
class LawChangeDECLINEPERC : public LawChange;
Collapse Expand File

File: LawChangeDECLINEPERC.h

Module: PiaData Library

Collapse Expand Remarks

If the indicator is greater than zero, it indicates the number of intervals of declining benefit formula percents. There are three additional data fields compared to the base class, for the initial period of decline. If there are multiple intervals of decline, there are four additional data fields for each interval. The rates of decline can vary for each benefit formula percentage within each interval, and between intervals.

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeDECLINEPERC Enumerations, LawChangeDECLINEPERC Methods, LawChangeDECLINEPERC Members, LawChangeDECLINEPERC.h, Classes


LawChangeDECLINEPERC Members

LawChangeDECLINEPERC Members
Enumerations LawChangeDECLINEPERC Class Legend Public Methods

The following tables list the members exposed by LawChangeDECLINEPERC.

Collapse Expand Enumerations
Name | Description
DimLimits | Array sizes.
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeDECLINEPERC Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeDECLINEPERC | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getAltPercPia | Returns specified benefit formula percentage for specified year.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFactor | Returns percentage decline in specified benefit formula percent for specified year.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
getYear | Returns year that declining benefit formula percentage is effective.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
percPiaCal | Sets pia formula percentages.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setFactor | Sets percentage decline in benefit formula percent.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
setYear | Sets year that declining benefit formula percentage is effective.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.
~LawChangeDECLINEPERC | Destructor.
Collapse Expand Links
Enumerations, LawChangeDECLINEPERC Class, Legend, Public Methods


LawChangeDECLINEPERC::LawChangeDECLINEPERC Constructor

LawChangeDECLINEPERC::LawChangeDECLINEPERC Constructor
LawChangeDECLINEPERC Class LawChangeDECLINEPERC Members LawChangeDECLINEPERC Class

Constructor.

C++
LawChangeDECLINEPERC();
Collapse Expand Remarks

Allocates memory for the benefit formula percentages.

Collapse Expand Class

LawChangeDECLINEPERC Class

Collapse Expand Links
LawChangeDECLINEPERC Class, LawChangeDECLINEPERC Members, LawChangeDECLINEPERC Class


LawChangeDECLINEPERC::~LawChangeDECLINEPERC Destructor

LawChangeDECLINEPERC::~LawChangeDECLINEPERC Destructor
LawChangeDECLINEPERC Class LawChangeDECLINEPERC Members LawChangeDECLINEPERC Class

Destructor.

C++
~LawChangeDECLINEPERC();
Collapse Expand Remarks

Releases memory.

Collapse Expand Class

LawChangeDECLINEPERC Class

Collapse Expand Links
LawChangeDECLINEPERC Class, LawChangeDECLINEPERC Members, LawChangeDECLINEPERC Class


LawChangeDECLINEPERC Enumerations

LawChangeDECLINEPERC Enumerations
Enumerations LawChangeDECLINEPERC Class Legend

The enumerations of the LawChangeDECLINEPERC class are listed here.

Collapse Expand Enumerations
Name | Description
DimLimits | Array sizes.
Collapse Expand Class

LawChangeDECLINEPERC Class

Collapse Expand Links
Enumerations, LawChangeDECLINEPERC Class, Legend


LawChangeDECLINEPERC::DimLimits Enumeration

LawChangeDECLINEPERC::DimLimits Enumeration
LawChangeDECLINEPERC.h LawChangeDECLINEPERC Enumerations

Array sizes.

C++
enum DimLimits {
  MAXDECLINEPERC = 5
};
Collapse Expand File

File: LawChangeDECLINEPERC.h

Module: PiaData Library

Collapse Expand Members
Members | Description
MAXDECLINEPERC = 5 | Maximum number of declining formula percentage intervals.
Collapse Expand Group

LawChangeDECLINEPERC Enumerations

Collapse Expand Links
LawChangeDECLINEPERC.h, LawChangeDECLINEPERC Enumerations


LawChangeDECLINEPERC Methods

LawChangeDECLINEPERC Methods
LawChangeDECLINEPERC Class Legend Public Methods

The methods of the LawChangeDECLINEPERC class are listed here.

Collapse Expand Class

LawChangeDECLINEPERC Class

Collapse Expand Public Methods
Name | Description
getAltPercPia | Returns specified benefit formula percentage for specified year.
getFactor | Returns percentage decline in specified benefit formula percent for specified year.
getYear | Returns year that declining benefit formula percentage is effective.
percPiaCal | Sets pia formula percentages.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setFactor | Sets percentage decline in benefit formula percent.
setYear | Sets year that declining benefit formula percentage is effective.
write | Writes a line with first and last years, and percentage.
Collapse Expand Links
LawChangeDECLINEPERC Class, Legend, Public Methods


LawChangeDECLINEPERC::getAltPercPia Method

LawChangeDECLINEPERC::getAltPercPia Method
LawChangeDECLINEPERC Class LawChangeDECLINEPERC Members LawChangeDECLINEPERC Methods

Returns specified benefit formula percentage for specified year.

C++
double getAltPercPia(
    int year,
    int percNum
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of desired benefit formula percentage.
int percNum | Percentage number (0, 1, or 2 for 3-part formula; 0, 1, 2, or 3 for 4-part formula).
Collapse Expand Returns

Benefit formula percentage for specified year.

Collapse Expand Group

LawChangeDECLINEPERC Methods

Collapse Expand Links
LawChangeDECLINEPERC Class, LawChangeDECLINEPERC Members, LawChangeDECLINEPERC Methods


LawChangeDECLINEPERC::getFactor Method

LawChangeDECLINEPERC::getFactor Method
LawChangeDECLINEPERC Class LawChangeDECLINEPERC Members LawChangeDECLINEPERC Methods

Returns percentage decline in specified benefit formula percent for specified year.

C++
double getFactor(
    int yearNum,
    int percNum
) const;
Collapse Expand Parameters
Parameters | Description
int yearNum | Number of declining percentage interval (0 to DimLimits::MAXDECLINEPERC - 1).
int percNum | Percentage number (0, 1, or 2 for 3-part formula).
Collapse Expand Returns

Percentage decline in benefit formula percent.

Collapse Expand Group

LawChangeDECLINEPERC Methods

Collapse Expand Links
LawChangeDECLINEPERC Class, LawChangeDECLINEPERC Members, LawChangeDECLINEPERC Methods


LawChangeDECLINEPERC::getYear Method

LawChangeDECLINEPERC::getYear Method
LawChangeDECLINEPERC Class LawChangeDECLINEPERC Members LawChangeDECLINEPERC Methods

Returns year that declining benefit formula percentage is effective.

C++
int getYear(
    int yearNum
) const;
Collapse Expand Parameters
Parameters | Description
int yearNum | Number of declining benefit formula percentage interval (0 to DimLimits::MAXDECLINEPERC - 1).
Collapse Expand Returns

Year that declining benefit formula percentage is effective.

Collapse Expand Group

LawChangeDECLINEPERC Methods

Collapse Expand Links
LawChangeDECLINEPERC Class, LawChangeDECLINEPERC Members, LawChangeDECLINEPERC Methods


LawChangeDECLINEPERC::percPiaCal Method

LawChangeDECLINEPERC::percPiaCal Method
LawChangeDECLINEPERC Class LawChangeDECLINEPERC Members LawChangeDECLINEPERC Methods

Sets pia formula percentages.

C++
void percPiaCal();
Collapse Expand Remarks

Initializes the pia formula percentages in the year prior to the effective year with the present-law percentages, then applies the rate of decline for each percentage for each year in the future.

Collapse Expand Group

LawChangeDECLINEPERC Methods

Collapse Expand Links
LawChangeDECLINEPERC Class, LawChangeDECLINEPERC Members, LawChangeDECLINEPERC Methods


LawChangeDECLINEPERC::prepareStrings Method

LawChangeDECLINEPERC::prepareStrings Method
LawChangeDECLINEPERC Class LawChangeDECLINEPERC Members LawChangeDECLINEPERC Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeDECLINEPERC Methods

Collapse Expand Links
LawChangeDECLINEPERC Class, LawChangeDECLINEPERC Members, LawChangeDECLINEPERC Methods


LawChangeDECLINEPERC::read Method

LawChangeDECLINEPERC::read Method
LawChangeDECLINEPERC Class LawChangeDECLINEPERC Members LawChangeDECLINEPERC Methods

Reads all the lines required for this law-change.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_LAWCHG6 if there are not 6 entries on the first line (for first year, last year, phase-in type, and 3 factors). If the law-change indicator is greater than 1, same type of exception if there are not 4 entries on each succeeding line (for year and 3 factors).
Collapse Expand Group

LawChangeDECLINEPERC Methods

Collapse Expand Links
LawChangeDECLINEPERC Class, LawChangeDECLINEPERC Members, LawChangeDECLINEPERC Methods


LawChangeDECLINEPERC::setFactor Method

LawChangeDECLINEPERC::setFactor Method
LawChangeDECLINEPERC Class LawChangeDECLINEPERC Members LawChangeDECLINEPERC Methods

Sets percentage decline in benefit formula percent.

C++
void setFactor(
    int yearNum,
    int percNum,
    double newFactor
);
Collapse Expand Parameters
Parameters | Description
int yearNum | Number of declining percentage interval (0 to DimLimits::MAXDECLINEPERC - 1).
int percNum | Percentage number (0, 1, or 2 for 3-part formula).
double newFactor | New percentage decline.
Collapse Expand Group

LawChangeDECLINEPERC Methods

Collapse Expand Links
LawChangeDECLINEPERC Class, LawChangeDECLINEPERC Members, LawChangeDECLINEPERC Methods


LawChangeDECLINEPERC::setYear Method

LawChangeDECLINEPERC::setYear Method
LawChangeDECLINEPERC Class LawChangeDECLINEPERC Members LawChangeDECLINEPERC Methods

Sets year that declining benefit formula percentage is effective.

C++
void setYear(
    int yearNum,
    int year
);
Collapse Expand Parameters
Parameters | Description
int yearNum | Number of declining benefit formula percentage interval (0 to DimLimits::MAXDECLINEPERC - 1).
int year | New year of declining benefit formula percentage.
Collapse Expand Group

LawChangeDECLINEPERC Methods

Collapse Expand Links
LawChangeDECLINEPERC Class, LawChangeDECLINEPERC Members, LawChangeDECLINEPERC Methods


LawChangeDECLINEPERC::write Method

LawChangeDECLINEPERC::write Method
LawChangeDECLINEPERC Class LawChangeDECLINEPERC Members LawChangeDECLINEPERC Methods

Writes a line with first and last years, and percentage.

C++
void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChangeDECLINEPERC Methods

Collapse Expand Links
LawChangeDECLINEPERC Class, LawChangeDECLINEPERC Members, LawChangeDECLINEPERC Methods


LawChangeDROPOUTCHG Class

LawChangeDROPOUTCHG Class
LawChangeDROPOUTCHG Methods LawChangeDROPOUTCHG Members LawChangeDROPOUTCHG.h Classes

Parameters for a proposal to reduce the number of dropout years in a pia calculation.

Collapse Expand Class Hierarchy
  LawChangeDROPOUTCHGLawChangeDROPOUTCHG
C++
class LawChangeDROPOUTCHG : public LawChange;
Collapse Expand File

File: LawChangeDROPOUTCHG.h

Module: PiaData Library

Collapse Expand Remarks

There is one additional data field compared to the base class.

If the indicator is greater than zero, it indicates the number of years by which drop out years are to be decreased, phased in over period of years. The number of drop out years decreases by 1 every step years.

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeDROPOUTCHG Methods, LawChangeDROPOUTCHG Members, LawChangeDROPOUTCHG.h, Classes


LawChangeDROPOUTCHG Members

LawChangeDROPOUTCHG Members
Enumerations LawChangeDROPOUTCHG Class Legend Public Methods

The following tables list the members exposed by LawChangeDROPOUTCHG.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeDROPOUTCHG Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeDROPOUTCHG | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getStep | Returns step size when reducing number of dropout years.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
setStep | Sets step size when reducing number of dropout years.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and step size.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeDROPOUTCHG Class, Legend, Public Methods


LawChangeDROPOUTCHG::LawChangeDROPOUTCHG Constructor

LawChangeDROPOUTCHG::LawChangeDROPOUTCHG Constructor
LawChangeDROPOUTCHG Class LawChangeDROPOUTCHG Members LawChangeDROPOUTCHG Class

Constructor.

C++
LawChangeDROPOUTCHG();
Collapse Expand Class

LawChangeDROPOUTCHG Class

Collapse Expand Links
LawChangeDROPOUTCHG Class, LawChangeDROPOUTCHG Members, LawChangeDROPOUTCHG Class


LawChangeDROPOUTCHG Methods

LawChangeDROPOUTCHG Methods
LawChangeDROPOUTCHG Class Legend Public Methods

The methods of the LawChangeDROPOUTCHG class are listed here.

Collapse Expand Class

LawChangeDROPOUTCHG Class

Collapse Expand Public Methods
Name | Description
getStep | Returns step size when reducing number of dropout years.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setStep | Sets step size when reducing number of dropout years.
write | Writes a line with first and last years, and step size.
Collapse Expand Links
LawChangeDROPOUTCHG Class, Legend, Public Methods


LawChangeDROPOUTCHG::getStep Method

LawChangeDROPOUTCHG::getStep Method
LawChangeDROPOUTCHG Class LawChangeDROPOUTCHG Members LawChangeDROPOUTCHG Methods

Returns step size when reducing number of dropout years.

C++
int getStep() const;
Collapse Expand Returns

Step size when reducing number of dropout years.

Collapse Expand Group

LawChangeDROPOUTCHG Methods

Collapse Expand Links
LawChangeDROPOUTCHG Class, LawChangeDROPOUTCHG Members, LawChangeDROPOUTCHG Methods


LawChangeDROPOUTCHG::prepareStrings Method

LawChangeDROPOUTCHG::prepareStrings Method
LawChangeDROPOUTCHG Class LawChangeDROPOUTCHG Members LawChangeDROPOUTCHG Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeDROPOUTCHG Methods

Collapse Expand Links
LawChangeDROPOUTCHG Class, LawChangeDROPOUTCHG Members, LawChangeDROPOUTCHG Methods


LawChangeDROPOUTCHG::read Method

LawChangeDROPOUTCHG::read Method
LawChangeDROPOUTCHG Class LawChangeDROPOUTCHG Members LawChangeDROPOUTCHG Methods

Reads all the lines required for this law-change.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Group

LawChangeDROPOUTCHG Methods

Collapse Expand Links
LawChangeDROPOUTCHG Class, LawChangeDROPOUTCHG Members, LawChangeDROPOUTCHG Methods


LawChangeDROPOUTCHG::setStep Method

LawChangeDROPOUTCHG::setStep Method
LawChangeDROPOUTCHG Class LawChangeDROPOUTCHG Members LawChangeDROPOUTCHG Methods

Sets step size when reducing number of dropout years.

C++
void setStep(
    int newStep
);
Collapse Expand Parameters
Parameters | Description
int newStep | New step size when reducing number of dropout years.
Collapse Expand Group

LawChangeDROPOUTCHG Methods

Collapse Expand Links
LawChangeDROPOUTCHG Class, LawChangeDROPOUTCHG Members, LawChangeDROPOUTCHG Methods


LawChangeDROPOUTCHG::write Method

LawChangeDROPOUTCHG::write Method
LawChangeDROPOUTCHG Class LawChangeDROPOUTCHG Members LawChangeDROPOUTCHG Methods

Writes a line with first and last years, and step size.

C++
void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChangeDROPOUTCHG Methods

Collapse Expand Links
LawChangeDROPOUTCHG Class, LawChangeDROPOUTCHG Members, LawChangeDROPOUTCHG Methods


LawChangeMARRLENGTH Class

LawChangeMARRLENGTH Class
LawChangeMARRLENGTH Methods LawChangeMARRLENGTH Members LawChangeMARRLENGTH.h Classes

Parameters for a proposal to change the length of marriage requirement for divorced spouse benefits.

Collapse Expand Class Hierarchy
  LawChangeMARRLENGTHLawChangeMARRLENGTH
C++
class LawChangeMARRLENGTH : public LawChange;
Collapse Expand File

File: LawChangeMARRLENGTH.h

Module: PiaData Library

Collapse Expand Remarks

There is one additional data field compared to the base class.

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeMARRLENGTH Methods, LawChangeMARRLENGTH Members, LawChangeMARRLENGTH.h, Classes


LawChangeMARRLENGTH Members

LawChangeMARRLENGTH Members
Enumerations LawChangeMARRLENGTH Class Legend Public Methods

The following tables list the members exposed by LawChangeMARRLENGTH.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeMARRLENGTH Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeMARRLENGTH | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getMarrLengthForDivBen | Returns the number of years of marriage needed for a divorced spouse benefit.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setMarrLengthForDivBen | Sets the number of years of marriage needed for a divorced spouse benefit.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and step size.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeMARRLENGTH Class, Legend, Public Methods


LawChangeMARRLENGTH::LawChangeMARRLENGTH Constructor

LawChangeMARRLENGTH::LawChangeMARRLENGTH Constructor
LawChangeMARRLENGTH Class LawChangeMARRLENGTH Members LawChangeMARRLENGTH Class

Constructor.

C++
LawChangeMARRLENGTH();
Collapse Expand Class

LawChangeMARRLENGTH Class

Collapse Expand Links
LawChangeMARRLENGTH Class, LawChangeMARRLENGTH Members, LawChangeMARRLENGTH Class


LawChangeMARRLENGTH Methods

LawChangeMARRLENGTH Methods
LawChangeMARRLENGTH Class Legend Public Methods

The methods of the LawChangeMARRLENGTH class are listed here.

Collapse Expand Class

LawChangeMARRLENGTH Class

Collapse Expand Public Methods
Name | Description
getMarrLengthForDivBen | Returns the number of years of marriage needed for a divorced spouse benefit.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setMarrLengthForDivBen | Sets the number of years of marriage needed for a divorced spouse benefit.
write | Writes a line with first and last years, and step size.
Collapse Expand Links
LawChangeMARRLENGTH Class, Legend, Public Methods


LawChangeMARRLENGTH::getMarrLengthForDivBen Method

LawChangeMARRLENGTH::getMarrLengthForDivBen Method
LawChangeMARRLENGTH Class LawChangeMARRLENGTH Members LawChangeMARRLENGTH Methods

Returns the number of years of marriage needed for a divorced spouse benefit.

C++
int getMarrLengthForDivBen() const;
Collapse Expand Returns

The number of years of marriage needed for a divorced spouse benefit.

Collapse Expand Group

LawChangeMARRLENGTH Methods

Collapse Expand Links
LawChangeMARRLENGTH Class, LawChangeMARRLENGTH Members, LawChangeMARRLENGTH Methods


LawChangeMARRLENGTH::prepareStrings Method

LawChangeMARRLENGTH::prepareStrings Method
LawChangeMARRLENGTH Class LawChangeMARRLENGTH Members LawChangeMARRLENGTH Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeMARRLENGTH Methods

Collapse Expand Links
LawChangeMARRLENGTH Class, LawChangeMARRLENGTH Members, LawChangeMARRLENGTH Methods


LawChangeMARRLENGTH::read Method

LawChangeMARRLENGTH::read Method
LawChangeMARRLENGTH Class LawChangeMARRLENGTH Members LawChangeMARRLENGTH Methods

Reads all the lines required for this law-change.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Group

LawChangeMARRLENGTH Methods

Collapse Expand Links
LawChangeMARRLENGTH Class, LawChangeMARRLENGTH Members, LawChangeMARRLENGTH Methods


LawChangeMARRLENGTH::setMarrLengthForDivBen Method

LawChangeMARRLENGTH::setMarrLengthForDivBen Method
LawChangeMARRLENGTH Class LawChangeMARRLENGTH Members LawChangeMARRLENGTH Methods

Sets the number of years of marriage needed for a divorced spouse benefit.

C++
void setMarrLengthForDivBen(
    int newMarrLength
);
Collapse Expand Parameters
Parameters | Description
int newMarrLength | New number of years of marriage.
Collapse Expand Group

LawChangeMARRLENGTH Methods

Collapse Expand Links
LawChangeMARRLENGTH Class, LawChangeMARRLENGTH Members, LawChangeMARRLENGTH Methods


LawChangeMARRLENGTH::write Method

LawChangeMARRLENGTH::write Method
LawChangeMARRLENGTH Class LawChangeMARRLENGTH Members LawChangeMARRLENGTH Methods

Writes a line with first and last years, and step size.

C++
void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChangeMARRLENGTH Methods

Collapse Expand Links
LawChangeMARRLENGTH Class, LawChangeMARRLENGTH Members, LawChangeMARRLENGTH Methods


LawChangeNEWFORMULA Class

LawChangeNEWFORMULA Class
LawChangeNEWFORMULA Methods LawChangeNEWFORMULA Members LawChangeNEWFORMULA.h Classes

Parameters for a proposal to change the pia formula bend points and/or percentages.

Collapse Expand Class Hierarchy
  LawChangeNEWFORMULALawChangeNEWFORMULA
C++
class LawChangeNEWFORMULA : public LawChange;
Collapse Expand File

File: LawChangeNEWFORMULA.h

Module: PiaData Library

Collapse Expand Remarks

There are two additional data fields compared to the base class.

Currently only an indicator of 1 is allowed. Then a new benefit formula of up to 5 percentages and 4 bend points is used for each year in the specified period. The number of bendpoints in the new formula is specified on the first line of additional information, then each year's formula is on each line after that. For years after the last specified formula, the bendpoints are indexed from the last values using the AWI and the percentages are held constant at the last specified values.

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeNEWFORMULA Methods, LawChangeNEWFORMULA Members, LawChangeNEWFORMULA.h, Classes


LawChangeNEWFORMULA Members

LawChangeNEWFORMULA Members
Enumerations LawChangeNEWFORMULA Class Legend Public Methods

The following tables list the members exposed by LawChangeNEWFORMULA.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeNEWFORMULA Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeNEWFORMULA | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getAltBendPia | Returns specified alternate bend point for specified year.
getAltPercPia | Returns specified benefit formula percentage for specified year.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getNumBp | Returns number of bendpoints in the alternate formula.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setAltBendPia | Sets specified alternate bend point for specified year.
setAltPercPia | Sets specified alternate benefit formula percentage for specified year.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setNumBp | Sets number of bendpoints in the alternate formulas.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.
~LawChangeNEWFORMULA | Destructor.
Collapse Expand Links
Enumerations, LawChangeNEWFORMULA Class, Legend, Public Methods


LawChangeNEWFORMULA::LawChangeNEWFORMULA Constructor

LawChangeNEWFORMULA::LawChangeNEWFORMULA Constructor
LawChangeNEWFORMULA Class LawChangeNEWFORMULA Members LawChangeNEWFORMULA Class

Constructor.

C++
LawChangeNEWFORMULA();
Collapse Expand Remarks

Allocates memory for each element of the bend point and percentage arrays.

Collapse Expand Class

LawChangeNEWFORMULA Class

Collapse Expand Links
LawChangeNEWFORMULA Class, LawChangeNEWFORMULA Members, LawChangeNEWFORMULA Class


LawChangeNEWFORMULA::~LawChangeNEWFORMULA Destructor

LawChangeNEWFORMULA::~LawChangeNEWFORMULA Destructor
LawChangeNEWFORMULA Class LawChangeNEWFORMULA Members LawChangeNEWFORMULA Class

Destructor.

C++
~LawChangeNEWFORMULA();
Collapse Expand Remarks

Deletes allocated memory.

Collapse Expand Class

LawChangeNEWFORMULA Class

Collapse Expand Links
LawChangeNEWFORMULA Class, LawChangeNEWFORMULA Members, LawChangeNEWFORMULA Class


LawChangeNEWFORMULA Methods

LawChangeNEWFORMULA Methods
LawChangeNEWFORMULA Class Legend Public Methods

The methods of the LawChangeNEWFORMULA class are listed here.

Collapse Expand Class

LawChangeNEWFORMULA Class

Collapse Expand Public Methods
Name | Description
getAltBendPia | Returns specified alternate bend point for specified year.
getAltPercPia | Returns specified benefit formula percentage for specified year.
getNumBp | Returns number of bendpoints in the alternate formula.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setAltBendPia | Sets specified alternate bend point for specified year.
setAltPercPia | Sets specified alternate benefit formula percentage for specified year.
setNumBp | Sets number of bendpoints in the alternate formulas.
write | Writes a line with first and last years, and percentage.
Collapse Expand Links
LawChangeNEWFORMULA Class, Legend, Public Methods


LawChangeNEWFORMULA::getAltBendPia Method

LawChangeNEWFORMULA::getAltBendPia Method
LawChangeNEWFORMULA Class LawChangeNEWFORMULA Members LawChangeNEWFORMULA Methods

Returns specified alternate bend point for specified year.

C++
double getAltBendPia(
    int year,
    int bendNum
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which bend point is desired.
int bendNum | Bend point number (1 to n-1 for n-part formula).
Collapse Expand Returns

Specified alternate bend point for specified year.

Collapse Expand Group

LawChangeNEWFORMULA Methods

Collapse Expand Links
LawChangeNEWFORMULA Class, LawChangeNEWFORMULA Members, LawChangeNEWFORMULA Methods


LawChangeNEWFORMULA::getAltPercPia Method

LawChangeNEWFORMULA::getAltPercPia Method
LawChangeNEWFORMULA Class LawChangeNEWFORMULA Members LawChangeNEWFORMULA Methods

Returns specified benefit formula percentage for specified year.

C++
double getAltPercPia(
    int year,
    int percNum
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of desired benefit formula percentage.
int percNum | Percentage number (0 to n-1 for n-part formula).
Collapse Expand Returns

Specified benefit formula percentage for specified year.

Collapse Expand Group

LawChangeNEWFORMULA Methods

Collapse Expand Links
LawChangeNEWFORMULA Class, LawChangeNEWFORMULA Members, LawChangeNEWFORMULA Methods


LawChangeNEWFORMULA::getNumBp Method

LawChangeNEWFORMULA::getNumBp Method
LawChangeNEWFORMULA Class LawChangeNEWFORMULA Members LawChangeNEWFORMULA Methods

Returns number of bendpoints in the alternate formula.

C++
int getNumBp() const;
Collapse Expand Returns

Number of bendpoints in the alternate formula.

Collapse Expand Group

LawChangeNEWFORMULA Methods

Collapse Expand Links
LawChangeNEWFORMULA Class, LawChangeNEWFORMULA Members, LawChangeNEWFORMULA Methods


LawChangeNEWFORMULA::prepareStrings Method

LawChangeNEWFORMULA::prepareStrings Method
LawChangeNEWFORMULA Class LawChangeNEWFORMULA Members LawChangeNEWFORMULA Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeNEWFORMULA Methods

Collapse Expand Links
LawChangeNEWFORMULA Class, LawChangeNEWFORMULA Members, LawChangeNEWFORMULA Methods


LawChangeNEWFORMULA::read Method

LawChangeNEWFORMULA::read Method
LawChangeNEWFORMULA Class LawChangeNEWFORMULA Members LawChangeNEWFORMULA Methods

Reads all the lines required for this law-change.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_LAWCHG6 if there are not enough lines of data.
Collapse Expand Group

LawChangeNEWFORMULA Methods

Collapse Expand Links
LawChangeNEWFORMULA Class, LawChangeNEWFORMULA Members, LawChangeNEWFORMULA Methods


LawChangeNEWFORMULA::setAltBendPia Method

LawChangeNEWFORMULA::setAltBendPia Method
LawChangeNEWFORMULA Class LawChangeNEWFORMULA Members LawChangeNEWFORMULA Methods

Sets specified alternate bend point for specified year.

C++
void setAltBendPia(
    int year,
    int bendNum,
    double newAltBendPia
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which alternate bend point is being set.
int bendNum | Bend point number (1 to n-1 for n-part formula).
double newAltBendPia | New alternate bend point.
Collapse Expand Group

LawChangeNEWFORMULA Methods

Collapse Expand Links
LawChangeNEWFORMULA Class, LawChangeNEWFORMULA Members, LawChangeNEWFORMULA Methods


LawChangeNEWFORMULA::setAltPercPia Method

LawChangeNEWFORMULA::setAltPercPia Method
LawChangeNEWFORMULA Class LawChangeNEWFORMULA Members LawChangeNEWFORMULA Methods

Sets specified alternate benefit formula percentage for specified year.

C++
void setAltPercPia(
    int year,
    int percNum,
    double newPerc
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which percentage is set.
int percNum | Percentage number (0, to n-1 for n-part formula).
double newPerc | New alternate percentage.
Collapse Expand Group

LawChangeNEWFORMULA Methods

Collapse Expand Links
LawChangeNEWFORMULA Class, LawChangeNEWFORMULA Members, LawChangeNEWFORMULA Methods


LawChangeNEWFORMULA::setNumBp Method

LawChangeNEWFORMULA::setNumBp Method
LawChangeNEWFORMULA Class LawChangeNEWFORMULA Members LawChangeNEWFORMULA Methods

Sets number of bendpoints in the alternate formulas.

C++
void setNumBp(
    int newNumBp
);
Collapse Expand Parameters
Parameters | Description
int newNumBp | Number of bendpoints in the alternate formulas.
Collapse Expand Group

LawChangeNEWFORMULA Methods

Collapse Expand Links
LawChangeNEWFORMULA Class, LawChangeNEWFORMULA Members, LawChangeNEWFORMULA Methods


LawChangeNEWFORMULA::write Method

LawChangeNEWFORMULA::write Method
LawChangeNEWFORMULA Class LawChangeNEWFORMULA Members LawChangeNEWFORMULA Methods

Writes a line with first and last years, and percentage.

C++
void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChangeNEWFORMULA Methods

Collapse Expand Links
LawChangeNEWFORMULA Class, LawChangeNEWFORMULA Members, LawChangeNEWFORMULA Methods


LawChangeNEWSPECMIN Class

LawChangeNEWSPECMIN Class
LawChangeNEWSPECMIN Methods LawChangeNEWSPECMIN Members LawChangeNEWSPECMIN.h Classes

Parameters for a proposal to change the special minimum pia calculation.

Collapse Expand Class Hierarchy
  LawChangeNEWSPECMINLawChangeNEWSPECMIN
C++
class LawChangeNEWSPECMIN : public LawChange;
Collapse Expand File

File: LawChangeNEWSPECMIN.h

Module: PiaData Library

Collapse Expand Remarks

There are three additional data field compared to the base class, for changes to the dollar amount (see getAmount), the percentage of the old-law wage base required for a year of coverage (see getPercent), and the maximum number of years considered (see getYears).

If the indicator is greater than zero, it has the following meanings:

1 | new dollar amount.
2 | new maximum years of coverage.
3 | new dollar amount and maximum years of coverage.
4 | new year of coverage percent.
5 | new year of coverage percent and dollar amount.
6 | new year of coverage percent and maximum years of coverage.
7 | new year of coverage percent, dollar amount, and maximum years of coverage.
Collapse Expand Group

Classes

Collapse Expand Links
LawChangeNEWSPECMIN Methods, LawChangeNEWSPECMIN Members, LawChangeNEWSPECMIN.h, Classes


LawChangeNEWSPECMIN Members

LawChangeNEWSPECMIN Members
Enumerations LawChangeNEWSPECMIN Class Legend Public Methods

The following tables list the members exposed by LawChangeNEWSPECMIN.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeNEWSPECMIN Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeNEWSPECMIN | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getAmount | Returns alternative special minimum dollar amount.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPercent | Returns alternate special minimum percentage of wage base required for quarter of coverage.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
getYears | Returns alternative maximum number of years of coverage considered in special minimum calculation (30 in PL).
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setAmount | Sets alternative special minimum dollar amount.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPercent | Sets alternate special minimum percentage of wage base required for quarter of coverage.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
setYears | Sets alternative maximum number of years of coverage considered in special minimum calculation (30 in PL).
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and step size.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeNEWSPECMIN Class, Legend, Public Methods


LawChangeNEWSPECMIN::LawChangeNEWSPECMIN Constructor

LawChangeNEWSPECMIN::LawChangeNEWSPECMIN Constructor
LawChangeNEWSPECMIN Class LawChangeNEWSPECMIN Members LawChangeNEWSPECMIN Class

Constructor.

C++
LawChangeNEWSPECMIN();
Collapse Expand Remarks

Initializes all numbers to zero.

Collapse Expand Class

LawChangeNEWSPECMIN Class

Collapse Expand Links
LawChangeNEWSPECMIN Class, LawChangeNEWSPECMIN Members, LawChangeNEWSPECMIN Class


LawChangeNEWSPECMIN Methods

LawChangeNEWSPECMIN Methods
LawChangeNEWSPECMIN Class Legend Public Methods

The methods of the LawChangeNEWSPECMIN class are listed here.

Collapse Expand Class

LawChangeNEWSPECMIN Class

Collapse Expand Public Methods
Name | Description
getAmount | Returns alternative special minimum dollar amount.
getPercent | Returns alternate special minimum percentage of wage base required for quarter of coverage.
getYears | Returns alternative maximum number of years of coverage considered in special minimum calculation (30 in PL).
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setAmount | Sets alternative special minimum dollar amount.
setPercent | Sets alternate special minimum percentage of wage base required for quarter of coverage.
setYears | Sets alternative maximum number of years of coverage considered in special minimum calculation (30 in PL).
write | Writes a line with first and last years, and step size.
Collapse Expand Links
LawChangeNEWSPECMIN Class, Legend, Public Methods


LawChangeNEWSPECMIN::getAmount Method

LawChangeNEWSPECMIN::getAmount Method
LawChangeNEWSPECMIN Class LawChangeNEWSPECMIN Members LawChangeNEWSPECMIN Methods

Returns alternative special minimum dollar amount.

C++
double getAmount() const;
Collapse Expand Returns

Alternative special minimum dollar amount.

Collapse Expand Group

LawChangeNEWSPECMIN Methods

Collapse Expand Links
LawChangeNEWSPECMIN Class, LawChangeNEWSPECMIN Members, LawChangeNEWSPECMIN Methods


LawChangeNEWSPECMIN::getPercent Method

LawChangeNEWSPECMIN::getPercent Method
LawChangeNEWSPECMIN Class LawChangeNEWSPECMIN Members LawChangeNEWSPECMIN Methods

Returns alternate special minimum percentage of wage base required for quarter of coverage.

C++
double getPercent() const;
Collapse Expand Returns

Alternate special minimum percentage of wage base required for quarter of coverage.

Collapse Expand Group

LawChangeNEWSPECMIN Methods

Collapse Expand Links
LawChangeNEWSPECMIN Class, LawChangeNEWSPECMIN Members, LawChangeNEWSPECMIN Methods


LawChangeNEWSPECMIN::getYears Method

LawChangeNEWSPECMIN::getYears Method
LawChangeNEWSPECMIN Class LawChangeNEWSPECMIN Members LawChangeNEWSPECMIN Methods

Returns alternative maximum number of years of coverage considered in special minimum calculation (30 in PL).

C++
int getYears() const;
Collapse Expand Returns

Alternative maximum number of years of coverage considered in special minimum calculation (30 in PL).

Collapse Expand Group

LawChangeNEWSPECMIN Methods

Collapse Expand Links
LawChangeNEWSPECMIN Class, LawChangeNEWSPECMIN Members, LawChangeNEWSPECMIN Methods


LawChangeNEWSPECMIN::prepareStrings Method

LawChangeNEWSPECMIN::prepareStrings Method
LawChangeNEWSPECMIN Class LawChangeNEWSPECMIN Members LawChangeNEWSPECMIN Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeNEWSPECMIN Methods

Collapse Expand Links
LawChangeNEWSPECMIN Class, LawChangeNEWSPECMIN Members, LawChangeNEWSPECMIN Methods


LawChangeNEWSPECMIN::read Method

LawChangeNEWSPECMIN::read Method
LawChangeNEWSPECMIN Class LawChangeNEWSPECMIN Members LawChangeNEWSPECMIN Methods

Reads all the lines required for this law-change.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Group

LawChangeNEWSPECMIN Methods

Collapse Expand Links
LawChangeNEWSPECMIN Class, LawChangeNEWSPECMIN Members, LawChangeNEWSPECMIN Methods


LawChangeNEWSPECMIN::setAmount Method

LawChangeNEWSPECMIN::setAmount Method
LawChangeNEWSPECMIN Class LawChangeNEWSPECMIN Members LawChangeNEWSPECMIN Methods

Sets alternative special minimum dollar amount.

C++
void setAmount(
    double newAmount
);
Collapse Expand Parameters
Parameters | Description
double newAmount | New alternative special minimum dollar amount.
Collapse Expand Group

LawChangeNEWSPECMIN Methods

Collapse Expand Links
LawChangeNEWSPECMIN Class, LawChangeNEWSPECMIN Members, LawChangeNEWSPECMIN Methods


LawChangeNEWSPECMIN::setPercent Method

LawChangeNEWSPECMIN::setPercent Method
LawChangeNEWSPECMIN Class LawChangeNEWSPECMIN Members LawChangeNEWSPECMIN Methods

Sets alternate special minimum percentage of wage base required for quarter of coverage.

C++
void setPercent(
    double newPercent
);
Collapse Expand Parameters
Parameters | Description
double newPercent | New alternative special minimum percentage of wage base.
Collapse Expand Group

LawChangeNEWSPECMIN Methods

Collapse Expand Links
LawChangeNEWSPECMIN Class, LawChangeNEWSPECMIN Members, LawChangeNEWSPECMIN Methods


LawChangeNEWSPECMIN::setYears Method

LawChangeNEWSPECMIN::setYears Method
LawChangeNEWSPECMIN Class LawChangeNEWSPECMIN Members LawChangeNEWSPECMIN Methods

Sets alternative maximum number of years of coverage considered in special minimum calculation (30 in PL).

C++
void setYears(
    int newYears
);
Collapse Expand Parameters
Parameters | Description
int newYears | New alternative special minimum maximum years of coverage.
Collapse Expand Group

LawChangeNEWSPECMIN Methods

Collapse Expand Links
LawChangeNEWSPECMIN Class, LawChangeNEWSPECMIN Members, LawChangeNEWSPECMIN Methods


LawChangeNEWSPECMIN::write Method

LawChangeNEWSPECMIN::write Method
LawChangeNEWSPECMIN Class LawChangeNEWSPECMIN Members LawChangeNEWSPECMIN Methods

Writes a line with first and last years, and step size.

C++
void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChangeNEWSPECMIN Methods

Collapse Expand Links
LawChangeNEWSPECMIN Class, LawChangeNEWSPECMIN Members, LawChangeNEWSPECMIN Methods


LawChangeNRACHANGE Class

LawChangeNRACHANGE Class
LawChangeNRACHANGE Data Members LawChangeNRACHANGE Methods LawChangeNRACHANGE Members LawChangeNRACHANGE.h Classes

Parameters for a proposal to change the full retirement age.

Collapse Expand Class Hierarchy
  LawChangeNRACHANGELawChangeNRACHANGE
C++
class LawChangeNRACHANGE : public LawChange;
Collapse Expand File

File: LawChangeNRACHANGE.h

Module: PiaData Library

Collapse Expand Remarks

If the indicator is greater than zero, it means the following:

1 | keep retirement age at 65 (eliminate the present-law increase to 67).
2 | eliminate plateau between 66 and 67, then remain at 67.
3 | eliminate plateau between 66 and 67, then index to life expectancy (increase by 1 month every 2 years).

The actuarial reduction for years 6 and 7 is 3/8 percent per month. Beyond that, it is 1/3 percent per month.

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeNRACHANGE Data Members, LawChangeNRACHANGE Methods, LawChangeNRACHANGE Members, LawChangeNRACHANGE.h, Classes


LawChangeNRACHANGE Members

LawChangeNRACHANGE Members
Enumerations LawChangeNRACHANGE Class Legend Public Data Members Public Methods

The following tables list the members exposed by LawChangeNRACHANGE.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeNRACHANGE Class

Collapse Expand Public Data Members
Name | Description
ageArChange | The age at which the actuarial reduction factor changes.
arMonthlyFactor67_69 | Monthly actuarial reduction factor between ages 67 and 69.
arMonthlyFactor69Plus | Monthly actuarial reduction factor over age 69.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeNRACHANGE | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeNRACHANGE Class, Legend, Public Data Members, Public Methods


LawChangeNRACHANGE::LawChangeNRACHANGE Constructor

LawChangeNRACHANGE::LawChangeNRACHANGE Constructor
LawChangeNRACHANGE Class LawChangeNRACHANGE Members LawChangeNRACHANGE Class

Constructor.

C++
LawChangeNRACHANGE();
Collapse Expand Class

LawChangeNRACHANGE Class

Collapse Expand Links
LawChangeNRACHANGE Class, LawChangeNRACHANGE Members, LawChangeNRACHANGE Class


LawChangeNRACHANGE Data Members

LawChangeNRACHANGE Data Members
LawChangeNRACHANGE Class Legend Public Data Members

The data members of the LawChangeNRACHANGE class are listed here.

Collapse Expand Class

LawChangeNRACHANGE Class

Collapse Expand Public Data Members
Name | Description
ageArChange | The age at which the actuarial reduction factor changes.
arMonthlyFactor67_69 | Monthly actuarial reduction factor between ages 67 and 69.
arMonthlyFactor69Plus | Monthly actuarial reduction factor over age 69.
Collapse Expand Links
LawChangeNRACHANGE Class, Legend, Public Data Members


LawChangeNRACHANGE::ageArChange Data Member

LawChangeNRACHANGE::ageArChange Data Member
LawChangeNRACHANGE Class LawChangeNRACHANGE Members LawChangeNRACHANGE Data Members

The age at which the actuarial reduction factor changes.

C++
const Age ageArChange;
Collapse Expand Group

LawChangeNRACHANGE Data Members

Collapse Expand Links
LawChangeNRACHANGE Class, LawChangeNRACHANGE Members, LawChangeNRACHANGE Data Members


LawChangeNRACHANGE::arMonthlyFactor67_69 Data Member

LawChangeNRACHANGE::arMonthlyFactor67_69 Data Member
LawChangeNRACHANGE Class LawChangeNRACHANGE Members LawChangeNRACHANGE Data Members

Monthly actuarial reduction factor between ages 67 and 69.

C++
const double arMonthlyFactor67_69;
Collapse Expand Group

LawChangeNRACHANGE Data Members

Collapse Expand Links
LawChangeNRACHANGE Class, LawChangeNRACHANGE Members, LawChangeNRACHANGE Data Members


LawChangeNRACHANGE::arMonthlyFactor69Plus Data Member

LawChangeNRACHANGE::arMonthlyFactor69Plus Data Member
LawChangeNRACHANGE Class LawChangeNRACHANGE Members LawChangeNRACHANGE Data Members

Monthly actuarial reduction factor over age 69.

C++
const double arMonthlyFactor69Plus;
Collapse Expand Group

LawChangeNRACHANGE Data Members

Collapse Expand Links
LawChangeNRACHANGE Class, LawChangeNRACHANGE Members, LawChangeNRACHANGE Data Members


LawChangeNRACHANGE Methods

LawChangeNRACHANGE Methods
LawChangeNRACHANGE Class Legend Public Methods

The methods of the LawChangeNRACHANGE class are listed here.

Collapse Expand Class

LawChangeNRACHANGE Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares output strings for this change from present law.
Collapse Expand Links
LawChangeNRACHANGE Class, Legend, Public Methods


LawChangeNRACHANGE::prepareStrings Method

LawChangeNRACHANGE::prepareStrings Method
LawChangeNRACHANGE Class LawChangeNRACHANGE Members LawChangeNRACHANGE Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeNRACHANGE Methods

Collapse Expand Links
LawChangeNRACHANGE Class, LawChangeNRACHANGE Members, LawChangeNRACHANGE Methods


LawChangeOut Class

LawChangeOut Class
LawChangeOut Data Members LawChangeOut Methods LawChangeOut Members LawChangeOut.h Classes

Manages the output file of law change descriptions.

Collapse Expand Class Hierarchy
  LawChangeOutLawChangeOut
C++
class LawChangeOut : public PageOut;
Collapse Expand File

File: LawChangeOut.h

Module: PiaData Library

Collapse Expand Remarks

The law changes are contained in a LawChangeArray.

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeOut Data Members, LawChangeOut Methods, LawChangeOut Members, LawChangeOut.h, Classes


LawChangeOut Members

LawChangeOut Members
LawChangeOut Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by LawChangeOut.

Collapse Expand Class

LawChangeOut Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
lawChange | Law change data.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChangeOut | Initializes data for output.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareStrings | Prepares output strings for changes from present law.
print | Writes the output strings to the specified device.
~LawChangeOut | Releases memory.
Collapse Expand Links
LawChangeOut Class, Legend, Protected Data Members, Public Data Members, Public Methods


LawChangeOut::LawChangeOut Constructor

LawChangeOut::LawChangeOut Constructor
LawChangeOut Class LawChangeOut Members LawChangeOut Class

Initializes data for output.

C++
LawChangeOut(
    const LawChangeArray& newLawChange
);
Collapse Expand Parameters
Parameters | Description
const LawChangeArray& newLawChange | Law change data.
Collapse Expand Class

LawChangeOut Class

Collapse Expand Links
LawChangeOut Class, LawChangeOut Members, LawChangeOut Class


LawChangeOut::~LawChangeOut Destructor

LawChangeOut::~LawChangeOut Destructor
LawChangeOut Class LawChangeOut Members LawChangeOut Class

Releases memory.

C++
~LawChangeOut();
Collapse Expand Class

LawChangeOut Class

Collapse Expand Links
LawChangeOut Class, LawChangeOut Members, LawChangeOut Class


LawChangeOut Data Members

LawChangeOut Data Members
LawChangeOut Class Legend Public Data Members

The data members of the LawChangeOut class are listed here.

Collapse Expand Class

LawChangeOut Class

Collapse Expand Public Data Members
Name | Description
lawChange | Law change data.
Collapse Expand Links
LawChangeOut Class, Legend, Public Data Members


LawChangeOut::lawChange Data Member

LawChangeOut::lawChange Data Member
LawChangeOut Class LawChangeOut Members LawChangeOut Data Members

Law change data.

C++
const LawChangeArray& lawChange;
Collapse Expand Group

LawChangeOut Data Members

Collapse Expand Links
LawChangeOut Class, LawChangeOut Members, LawChangeOut Data Members


LawChangeOut Methods

LawChangeOut Methods
LawChangeOut Class Legend Public Methods

The methods of the LawChangeOut class are listed here.

Collapse Expand Class

LawChangeOut Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares output strings for changes from present law.
Collapse Expand Links
LawChangeOut Class, Legend, Public Methods


LawChangeOut::prepareStrings Method

LawChangeOut::prepareStrings Method
LawChangeOut Class LawChangeOut Members LawChangeOut Methods

Prepares output strings for changes from present law.

C++
void prepareStrings();
Collapse Expand Remarks

Calls LawChange::prepareStrings for each change in law.

Collapse Expand Group

LawChangeOut Methods

Collapse Expand Links
LawChangeOut Class, LawChangeOut Members, LawChangeOut Methods


LawChangePSAACCT Class

LawChangePSAACCT Class
LawChangePSAACCT Enumerations LawChangePSAACCT Methods LawChangePSAACCT Members LawChangePSAACCT.h Classes

Parameters for a proposal to introduce individual accounts.

Collapse Expand Class Hierarchy
  LawChangePSAACCTLawChangePSAACCT
C++
class LawChangePSAACCT : public LawChange;
Collapse Expand File

File: LawChangePSAACCT.h

Module: PiaData Library

Collapse Expand Remarks

There are many additional data fields compared to the base class. If the indicator is set (greater than 0), then there are individual accounts with contributions of a certain percent of covered wages, where the indicator equals the number of different contribution rates over time.

Collapse Expand Group

Classes

Collapse Expand Links
LawChangePSAACCT Enumerations, LawChangePSAACCT Methods, LawChangePSAACCT Members, LawChangePSAACCT.h, Classes


LawChangePSAACCT Members

LawChangePSAACCT Members
Enumerations LawChangePSAACCT Class Legend Public Methods

The following tables list the members exposed by LawChangePSAACCT.

Collapse Expand Enumerations
Name | Description
DimLimits | Array sizes.
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangePSAACCT Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangePSAACCT | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getAdminFee | Returns the administrative fee for the specified investment.
getAnnIntRate | Returns the interst rate for the PSA annuities.
getAnnuityOffset | Returns true if the PSA annuity offsets the regular OASDI benefits, false otherwise.
getAnnuityToDib | Returns true if a person converts his PSA into an annuity upon beginning DI benefits.
getAnnuityType | Returns the type of annuity (0 for always straight life, 1 for joint and 2/3 survivor if married).
getBuysAnnuity | Returns true if the PSA is used to buy an annuity, false if it is just diminished by the amount of the annuity payments as the payments are made.
getContribBps | Returns the percent of the wage base to be used as a bend point for the contribution rate to the PSA.
getContribDist | Returns the type of distribution to use for PSA contributions.
getContribRates | Returns specified PSA contribution rate.
getContribStartAge | Returns the starting age for PSA contributions.
getContribYears | Returns PSA contribution year index.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getInvestMean | Returns mean to be used for the return rate on stocks.
getInvestPerc | Returns proportion of PSA contributions going to specified investment.
getInvestStdDev | Returns standard deviation to be used for the return rate on specified investment.
getLumpSumAtFra | Returns true if the entire PSA is paid as a lump sum to a person who attains FRA and is not eligible for an annuity, false otherwise.
getLumpSumPerc | Returns the percent of the PSA that is paid out as a lump sum upon conversion to annuity.
getMngmtFee | Returns the management fee for the specified investment.
getNumContribBps | Returns the number of bend point in the contribution rate for the PSA's.
getPercToSpouse | Returns percentage of contribution going to spouse, if any.
getPhaseType | Returns indicator for type of phase-in.
getRebalanceAccounts | Returns true if the PSA investment accounts need to be re-balanced each year, false otherwise.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTaxAnnuityInd | Returns the indicator on how PSA annuities are taxed.
getTitle | Returns title of this law change.
getToSpouseOnDeathInd | Returns the indicator regarding the transfer of the PSA to a spouse upon death of the person.
getUnisexInd | Returns the unisex indicator.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setAdminFee | Sets the administrative fee for the specified investment.
setAnnIntRate | Sets the interest rate for the PSA annuities.
setAnnuityOffset | Sets the indicator for offsetting OASDI benefits with the PSA annuity.
setAnnuityToDib | Sets the indicator for whether or not a person starts getting an annuity from his PSA upon beginning DI benefits.
setAnnuityType | Sets the type of annuity (0 for always straight life, 1 for joint and 2/3 survivor if married).
setBuysAnnuity | Sets the indicator for how the PSA is treated when the person starts getting an annuity payment.
setContribBps | Sets the percent of the wage base used a s a bend point for the contribution rate into the PSA's.
setContribDist | Sets the type of distribution to use for PSA contributions.
setContribRates | Sets psa contribution rate.
setContribStartAge | Sets the starting age for PSA contributions.
setContribYears | Sets PSA contribution year index.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setInvestMean | Sets mean to be used for the return of specified investment.
setInvestPerc | Sets proportion of psa contributions going to specified investment.
setInvestStdDev | Sets standard deviation to be used for the return rate on specified investment.
setLumpSumAtFra | Sets the indicator for whether or not a person receives the entire PSA as a lump sum if they attain FRA and are not eligible for an annuity.
setLumpSumPerc | Sets the new percent of the PSA that is paid out as a lump sum upon conversion to annuity.
setMngmtFee | Sets the management fee for the specified investment.
setNumContribBps | Sets the number of bend point in the contribution rate into the PSA's.
setPercToSpouse | Sets percentage of contribution going to spouse, if any.
setPhaseType | Sets indicator for type of phase-in.
setRebalanceAccounts | Sets the rebalanceAccounts indicator.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
setTaxAnnuityInd | Sets the indicator on how PSA annuities are taxed.
setToSpouseOnDeathInd | Sets the indicator regarding the transfer of the PSA to a spouse upon death of the person.
setUnisexInd | Sets unisex indicator.
startCheck | Checks range of a law-change starting year.
write | Writes all the lines required for this law-change.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangePSAACCT Class, Legend, Public Methods


LawChangePSAACCT::LawChangePSAACCT Constructor

LawChangePSAACCT::LawChangePSAACCT Constructor
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Class

Constructor.

C++
LawChangePSAACCT();
Collapse Expand Class

LawChangePSAACCT Class

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Class


LawChangePSAACCT Enumerations

LawChangePSAACCT Enumerations
Enumerations LawChangePSAACCT Class Legend

The enumerations of the LawChangePSAACCT class are listed here.

Collapse Expand Enumerations
Name | Description
DimLimits | Array sizes.
Collapse Expand Class

LawChangePSAACCT Class

Collapse Expand Links
Enumerations, LawChangePSAACCT Class, Legend


LawChangePSAACCT::DimLimits Enumeration

LawChangePSAACCT::DimLimits Enumeration
LawChangePSAACCT.h LawChangePSAACCT Enumerations

Array sizes.

C++
enum DimLimits {
  MAXCONTRIBRATEYEARS = 100
};
Collapse Expand File

File: LawChangePSAACCT.h

Module: PiaData Library

Collapse Expand Members
Members | Description
MAXCONTRIBRATEYEARS = 100 | Maximum number of PSA contribution rates.
Collapse Expand Group

LawChangePSAACCT Enumerations

Collapse Expand Links
LawChangePSAACCT.h, LawChangePSAACCT Enumerations


LawChangePSAACCT Methods

LawChangePSAACCT Methods
LawChangePSAACCT Class Legend Public Methods

The methods of the LawChangePSAACCT class are listed here.

Collapse Expand Class

LawChangePSAACCT Class

Collapse Expand Public Methods
Name | Description
getAdminFee | Returns the administrative fee for the specified investment.
getAnnIntRate | Returns the interst rate for the PSA annuities.
getAnnuityOffset | Returns true if the PSA annuity offsets the regular OASDI benefits, false otherwise.
getAnnuityToDib | Returns true if a person converts his PSA into an annuity upon beginning DI benefits.
getAnnuityType | Returns the type of annuity (0 for always straight life, 1 for joint and 2/3 survivor if married).
getBuysAnnuity | Returns true if the PSA is used to buy an annuity, false if it is just diminished by the amount of the annuity payments as the payments are made.
getContribBps | Returns the percent of the wage base to be used as a bend point for the contribution rate to the PSA.
getContribDist | Returns the type of distribution to use for PSA contributions.
getContribRates | Returns specified PSA contribution rate.
getContribStartAge | Returns the starting age for PSA contributions.
getContribYears | Returns PSA contribution year index.
getInvestMean | Returns mean to be used for the return rate on stocks.
getInvestPerc | Returns proportion of PSA contributions going to specified investment.
getInvestStdDev | Returns standard deviation to be used for the return rate on specified investment.
getLumpSumAtFra | Returns true if the entire PSA is paid as a lump sum to a person who attains FRA and is not eligible for an annuity, false otherwise.
getLumpSumPerc | Returns the percent of the PSA that is paid out as a lump sum upon conversion to annuity.
getMngmtFee | Returns the management fee for the specified investment.
getNumContribBps | Returns the number of bend point in the contribution rate for the PSA's.
getPercToSpouse | Returns percentage of contribution going to spouse, if any.
getRebalanceAccounts | Returns true if the PSA investment accounts need to be re-balanced each year, false otherwise.
getTaxAnnuityInd | Returns the indicator on how PSA annuities are taxed.
getToSpouseOnDeathInd | Returns the indicator regarding the transfer of the PSA to a spouse upon death of the person.
getUnisexInd | Returns the unisex indicator.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setAdminFee | Sets the administrative fee for the specified investment.
setAnnIntRate | Sets the interest rate for the PSA annuities.
setAnnuityOffset | Sets the indicator for offsetting OASDI benefits with the PSA annuity.
setAnnuityToDib | Sets the indicator for whether or not a person starts getting an annuity from his PSA upon beginning DI benefits.
setAnnuityType | Sets the type of annuity (0 for always straight life, 1 for joint and 2/3 survivor if married).
setBuysAnnuity | Sets the indicator for how the PSA is treated when the person starts getting an annuity payment.
setContribBps | Sets the percent of the wage base used a s a bend point for the contribution rate into the PSA's.
setContribDist | Sets the type of distribution to use for PSA contributions.
setContribRates | Sets psa contribution rate.
setContribStartAge | Sets the starting age for PSA contributions.
setContribYears | Sets PSA contribution year index.
setInvestMean | Sets mean to be used for the return of specified investment.
setInvestPerc | Sets proportion of psa contributions going to specified investment.
setInvestStdDev | Sets standard deviation to be used for the return rate on specified investment.
setLumpSumAtFra | Sets the indicator for whether or not a person receives the entire PSA as a lump sum if they attain FRA and are not eligible for an annuity.
setLumpSumPerc | Sets the new percent of the PSA that is paid out as a lump sum upon conversion to annuity.
setMngmtFee | Sets the management fee for the specified investment.
setNumContribBps | Sets the number of bend point in the contribution rate into the PSA's.
setPercToSpouse | Sets percentage of contribution going to spouse, if any.
setRebalanceAccounts | Sets the rebalanceAccounts indicator.
setTaxAnnuityInd | Sets the indicator on how PSA annuities are taxed.
setToSpouseOnDeathInd | Sets the indicator regarding the transfer of the PSA to a spouse upon death of the person.
setUnisexInd | Sets unisex indicator.
write | Writes all the lines required for this law-change.
Collapse Expand Links
LawChangePSAACCT Class, Legend, Public Methods


LawChangePSAACCT::getAdminFee Method

LawChangePSAACCT::getAdminFee Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns the administrative fee for the specified investment.

C++
double getAdminFee(
    Psa::InvestmentType type
) const;
Collapse Expand Parameters
Parameters | Description
Psa::InvestmentType type | Type of investment.
Collapse Expand Returns

The administrative fee for the specified investment.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getAnnIntRate Method

LawChangePSAACCT::getAnnIntRate Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns the interst rate for the PSA annuities.

C++
double getAnnIntRate() const;
Collapse Expand Returns

The interest rate for the PSA annuities.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getAnnuityOffset Method

LawChangePSAACCT::getAnnuityOffset Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns true if the PSA annuity offsets the regular OASDI benefits, false otherwise.

C++
bool getAnnuityOffset() const;
Collapse Expand Returns

True if the PSA annuity offsets the regular OASDI benefits, false otherwise.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getAnnuityToDib Method

LawChangePSAACCT::getAnnuityToDib Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns true if a person converts his PSA into an annuity upon beginning DI benefits.

C++
bool getAnnuityToDib() const;
Collapse Expand Returns

True if a person converts his PSA into an annuity upon beginning DI benefits.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getAnnuityType Method

LawChangePSAACCT::getAnnuityType Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns the type of annuity (0 for always straight life, 1 for joint and 2/3 survivor if married).

C++
Psa::AnnuityType getAnnuityType() const;
Collapse Expand Returns

The annuity type.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getBuysAnnuity Method

LawChangePSAACCT::getBuysAnnuity Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns true if the PSA is used to buy an annuity, false if it is just diminished by the amount of the annuity payments as the payments are made.

C++
bool getBuysAnnuity() const;
Collapse Expand Returns

True if the PSA is used to buy an annuity, false if it is just diminished by the amount of the annuity payments as the payments are made.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getContribBps Method

LawChangePSAACCT::getContribBps Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns the percent of the wage base to be used as a bend point for the contribution rate to the PSA.

C++
double getContribBps(
    int yearNum,
    int bpNum
) const;
Collapse Expand Parameters
Parameters | Description
int yearNum | Year number.
int bpNum | Bend point number.
Collapse Expand Returns

The percent of the wage base to be used as a bend point for the contribution rate to the PSA.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getContribDist Method

LawChangePSAACCT::getContribDist Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns the type of distribution to use for PSA contributions.

C++
int getContribDist() const;
Collapse Expand Returns

The type of distribution to use for PSA contributions.

0 | Use built-in split that varies by age.
1 | Constant (user-specified) split.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getContribRates Method

LawChangePSAACCT::getContribRates Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns specified PSA contribution rate.

C++
double getContribRates(
    int yearNum,
    int rateNum
) const;
Collapse Expand Parameters
Parameters | Description
int yearNum | Year number.
int rateNum | Rate number.
Collapse Expand Returns

Specified PSA contribution rate.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getContribStartAge Method

LawChangePSAACCT::getContribStartAge Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns the starting age for PSA contributions.

C++
int getContribStartAge() const;
Collapse Expand Returns

The starting age for PSA contributions.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getContribYears Method

LawChangePSAACCT::getContribYears Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns PSA contribution year index.

C++
int getContribYears(
    int yearNum
) const;
Collapse Expand Parameters
Parameters | Description
int yearNum | Year number.
Collapse Expand Returns

PSA contribution year index.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getInvestMean Method

LawChangePSAACCT::getInvestMean Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns mean to be used for the return rate on stocks.

C++
double getInvestMean(
    Psa::InvestmentType type
) const;
Collapse Expand Parameters
Parameters | Description
Psa::InvestmentType type | Type of investment.
Collapse Expand Returns

Mean to be used for the return rate on stocks.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getInvestPerc Method

LawChangePSAACCT::getInvestPerc Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns proportion of PSA contributions going to specified investment.

C++
double getInvestPerc(
    Psa::InvestmentType type
) const;
Collapse Expand Parameters
Parameters | Description
Psa::InvestmentType type | Type of investment.
Collapse Expand Returns

Proportion of PSA contributions going to specified investment.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getInvestStdDev Method

LawChangePSAACCT::getInvestStdDev Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns standard deviation to be used for the return rate on specified investment.

C++
double getInvestStdDev(
    Psa::InvestmentType type
) const;
Collapse Expand Parameters
Parameters | Description
Psa::InvestmentType type | Type of investment.
Collapse Expand Returns

Standard deviation to be used for the return rate on specified investment.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getLumpSumAtFra Method

LawChangePSAACCT::getLumpSumAtFra Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns true if the entire PSA is paid as a lump sum to a person who attains FRA and is not eligible for an annuity, false otherwise.

C++
bool getLumpSumAtFra() const;
Collapse Expand Returns

True if the entire PSA is paid as a lump sum to a person who attains FRA and is not eligible for an annuity, false otherwise.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getLumpSumPerc Method

LawChangePSAACCT::getLumpSumPerc Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns the percent of the PSA that is paid out as a lump sum upon conversion to annuity.

C++
double getLumpSumPerc() const;
Collapse Expand Returns

The percent of the PSA that is paid out as a lump sum upon conversion to annuity.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getMngmtFee Method

LawChangePSAACCT::getMngmtFee Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns the management fee for the specified investment.

C++
double getMngmtFee(
    Psa::InvestmentType type
) const;
Collapse Expand Parameters
Parameters | Description
Psa::InvestmentType type | Type of investment.
Collapse Expand Returns

The management fee for the specified investment.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getNumContribBps Method

LawChangePSAACCT::getNumContribBps Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns the number of bend point in the contribution rate for the PSA's.

C++
int getNumContribBps() const;
Collapse Expand Returns

The number of bend point in the contribution rate for the PSA's.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getPercToSpouse Method

LawChangePSAACCT::getPercToSpouse Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns percentage of contribution going to spouse, if any.

C++
double getPercToSpouse() const;
Collapse Expand Returns

Percentage of contribution going to spouse, if any.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getRebalanceAccounts Method

LawChangePSAACCT::getRebalanceAccounts Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns true if the PSA investment accounts need to be re-balanced each year, false otherwise.

C++
bool getRebalanceAccounts() const;
Collapse Expand Returns

True if the PSA investment accounts need to be re-balanced each year, false otherwise.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getTaxAnnuityInd Method

LawChangePSAACCT::getTaxAnnuityInd Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns the indicator on how PSA annuities are taxed.

C++
int getTaxAnnuityInd() const;
Collapse Expand Returns

The indicator on how PSA annuities are taxed.

0 | Not taxed at all.
1 | Taxed like Social Security benefits.
2 | Taxed like regular income.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getToSpouseOnDeathInd Method

LawChangePSAACCT::getToSpouseOnDeathInd Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns the indicator regarding the transfer of the PSA to a spouse upon death of the person.

C++
int getToSpouseOnDeathInd() const;
Collapse Expand Returns

The indicator regarding the transfer of the PSA to a spouse upon death of the person.

0 | No transfer.
1 | Transfer to current (at time of death) spouse, if any.
2 | Transfer to most recent spouse (current or divorced).
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::getUnisexInd Method

LawChangePSAACCT::getUnisexInd Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Returns the unisex indicator.

C++
Psa::UnisexType getUnisexInd() const;
Collapse Expand Returns

The unisex indicaor.

Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::prepareStrings Method

LawChangePSAACCT::prepareStrings Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::read Method

LawChangePSAACCT::read Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Reads all the lines required for this law-change.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setAdminFee Method

LawChangePSAACCT::setAdminFee Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets the administrative fee for the specified investment.

C++
void setAdminFee(
    Psa::InvestmentType type,
    double newFee
);
Collapse Expand Parameters
Parameters | Description
Psa::InvestmentType type | Type of investment.
double newFee | New administrative fee.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setAnnIntRate Method

LawChangePSAACCT::setAnnIntRate Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets the interest rate for the PSA annuities.

C++
void setAnnIntRate(
    double newIntRate
);
Collapse Expand Parameters
Parameters | Description
double newIntRate | The new interest rate to use for the PSA annuities.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setAnnuityOffset Method

LawChangePSAACCT::setAnnuityOffset Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets the indicator for offsetting OASDI benefits with the PSA annuity.

C++
void setAnnuityOffset(
    int newOffset
);
Collapse Expand Parameters
Parameters | Description
int newOffset | The new indicator.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setAnnuityToDib Method

LawChangePSAACCT::setAnnuityToDib Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets the indicator for whether or not a person starts getting an annuity from his PSA upon beginning DI benefits.

C++
void setAnnuityToDib(
    int newAnnuityToDib
);
Collapse Expand Parameters
Parameters | Description
int newAnnuityToDib | New indicator as to whether or not a person converts his PSA into an annuity upon getting DI benefits.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setAnnuityType Method

LawChangePSAACCT::setAnnuityType Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets the type of annuity (0 for always straight life, 1 for joint and 2/3 survivor if married).

C++
void setAnnuityType(
    Psa::AnnuityType newAnnuityType
);
Collapse Expand Parameters
Parameters | Description
Psa::AnnuityType newAnnuityType | New type of annuity.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setBuysAnnuity Method

LawChangePSAACCT::setBuysAnnuity Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets the indicator for how the PSA is treated when the person starts getting an annuity payment.

C++
void setBuysAnnuity(
    int newBuysAnnuity
);
Collapse Expand Parameters
Parameters | Description
int newBuysAnnuity | Indicator how to treat the PSA once the annuity starts.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setContribBps Method

LawChangePSAACCT::setContribBps Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets the percent of the wage base used a s a bend point for the contribution rate into the PSA's.

C++
void setContribBps(
    int yearNum,
    int bpNum,
    double newBp
);
Collapse Expand Parameters
Parameters | Description
int yearNum | Year number.
int bpNum | Bend point number.
double newBp | New bend point.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setContribDist Method

LawChangePSAACCT::setContribDist Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets the type of distribution to use for PSA contributions.

C++
void setContribDist(
    int newContribDist
);
Collapse Expand Parameters
Parameters | Description
int newContribDist | The new type of distribution to use.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setContribRates Method

LawChangePSAACCT::setContribRates Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets psa contribution rate.

C++
void setContribRates(
    int yearNum,
    int rateNum,
    double newContribRate
);
Collapse Expand Parameters
Parameters | Description
int yearNum | Year number.
int rateNum | Rate number.
double newContribRate | New PSA contribution rate.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setContribStartAge Method

LawChangePSAACCT::setContribStartAge Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets the starting age for PSA contributions.

C++
void setContribStartAge(
    int newStartAge
);
Collapse Expand Parameters
Parameters | Description
int newStartAge | New starting age for PSA contributions.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setContribYears Method

LawChangePSAACCT::setContribYears Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets PSA contribution year index.

C++
void setContribYears(
    int yearNum,
    int newYear
);
Collapse Expand Parameters
Parameters | Description
int yearNum | Year number.
int newYear | New PSA contribution year index.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setInvestMean Method

LawChangePSAACCT::setInvestMean Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets mean to be used for the return of specified investment.

C++
void setInvestMean(
    Psa::InvestmentType theType,
    double newMean
);
Collapse Expand Parameters
Parameters | Description
Psa::InvestmentType theType | Type of investment.
double newMean | New mean.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setInvestPerc Method

LawChangePSAACCT::setInvestPerc Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets proportion of psa contributions going to specified investment.

C++
void setInvestPerc(
    Psa::InvestmentType theType,
    double newInvestPerc
);
Collapse Expand Parameters
Parameters | Description
Psa::InvestmentType theType | Type of investment.
double newInvestPerc | New proportion of PSA contributions going to specified investment.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setInvestStdDev Method

LawChangePSAACCT::setInvestStdDev Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets standard deviation to be used for the return rate on specified investment.

C++
void setInvestStdDev(
    Psa::InvestmentType theType,
    double newStdDev
);
Collapse Expand Parameters
Parameters | Description
Psa::InvestmentType theType | Type of investment.
double newStdDev | New standard deviation.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setLumpSumAtFra Method

LawChangePSAACCT::setLumpSumAtFra Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets the indicator for whether or not a person receives the entire PSA as a lump sum if they attain FRA and are not eligible for an annuity.

C++
void setLumpSumAtFra(
    int newLumpSumAtFra
);
Collapse Expand Parameters
Parameters | Description
int newLumpSumAtFra | New indicator for receiving the entire PSA as a lump sum.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setLumpSumPerc Method

LawChangePSAACCT::setLumpSumPerc Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets the new percent of the PSA that is paid out as a lump sum upon conversion to annuity.

C++
void setLumpSumPerc(
    double newLumpSumPerc
);
Collapse Expand Parameters
Parameters | Description
double newLumpSumPerc | New percent of the PSA that is paid out as a lump sum.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setMngmtFee Method

LawChangePSAACCT::setMngmtFee Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets the management fee for the specified investment.

C++
void setMngmtFee(
    Psa::InvestmentType type,
    double newFee
);
Collapse Expand Parameters
Parameters | Description
Psa::InvestmentType type | Type of investment.
double newFee | New management fee.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setNumContribBps Method

LawChangePSAACCT::setNumContribBps Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets the number of bend point in the contribution rate into the PSA's.

C++
void setNumContribBps(
    int newNumBps
);
Collapse Expand Parameters
Parameters | Description
int newNumBps | new number of bend points.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setPercToSpouse Method

LawChangePSAACCT::setPercToSpouse Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets percentage of contribution going to spouse, if any.

C++
void setPercToSpouse(
    double newPercToSpouse
);
Collapse Expand Parameters
Parameters | Description
double newPercToSpouse | New percentage going to spouse.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setRebalanceAccounts Method

LawChangePSAACCT::setRebalanceAccounts Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets the rebalanceAccounts indicator.

C++
void setRebalanceAccounts(
    int newRebalanceAccounts
);
Collapse Expand Parameters
Parameters | Description
int newRebalanceAccounts | New rebalanceAccounts.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setTaxAnnuityInd Method

LawChangePSAACCT::setTaxAnnuityInd Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets the indicator on how PSA annuities are taxed.

C++
void setTaxAnnuityInd(
    int newInd
);
Collapse Expand Parameters
Parameters | Description
int newInd | New indicator on how PSA annuities are taxed.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setToSpouseOnDeathInd Method

LawChangePSAACCT::setToSpouseOnDeathInd Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets the indicator regarding the transfer of the PSA to a spouse upon death of the person.

C++
void setToSpouseOnDeathInd(
    int newToSpouseOnDeathInd
);
Collapse Expand Parameters
Parameters | Description
int newToSpouseOnDeathInd | New indicator regarding the transfer of the PSA to a spouse upon the person's death. 0 - No transfer. 1 - Transfer to current (at time of death) spouse, if any. 2 - Transfer to most recent spouse (current or divorced).
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::setUnisexInd Method

LawChangePSAACCT::setUnisexInd Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Sets unisex indicator.

C++
void setUnisexInd(
    Psa::UnisexType newUnisexInd
);
Collapse Expand Parameters
Parameters | Description
Psa::UnisexType newUnisexInd | New indicator for unisex annuity factors.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangePSAACCT::write Method

LawChangePSAACCT::write Method
LawChangePSAACCT Class LawChangePSAACCT Members LawChangePSAACCT Methods

Writes all the lines required for this law-change.

C++
void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChangePSAACCT Methods

Collapse Expand Links
LawChangePSAACCT Class, LawChangePSAACCT Members, LawChangePSAACCT Methods


LawChangeRead Class

LawChangeRead Class
LawChangeRead Methods LawChangeRead Members LawChangeRead.h Classes

Reads law changes stored in a file.

Collapse Expand Class Hierarchy
  LawChangeRead
C++
class LawChangeRead;
Collapse Expand File

File: LawChangeRead.h

Module: PiaData Library

Collapse Expand Remarks

Reads a LawChangeArray stored in a file.

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeRead Methods, LawChangeRead Members, LawChangeRead.h, Classes


LawChangeRead Members

LawChangeRead Members
LawChangeRead Class Legend Public Methods

The following tables list the members exposed by LawChangeRead.

Collapse Expand Class

LawChangeRead Class

Collapse Expand Public Methods
Name | Description
LawChangeRead | Initializes law-change reference.
read | Reads indicators for change from present law.
Collapse Expand Links
LawChangeRead Class, Legend, Public Methods


LawChangeRead::LawChangeRead Constructor

LawChangeRead::LawChangeRead Constructor
LawChangeRead Class LawChangeRead Members LawChangeRead Class

Initializes law-change reference.

C++
LawChangeRead(
    LawChangeArray& newLawChange
);
Collapse Expand Parameters
Parameters | Description
LawChangeArray& newLawChange | Law-change indicators.
Collapse Expand Class

LawChangeRead Class

Collapse Expand Links
LawChangeRead Class, LawChangeRead Members, LawChangeRead Class


LawChangeRead Methods

LawChangeRead Methods
LawChangeRead Class Legend Public Methods

The methods of the LawChangeRead class are listed here.

Collapse Expand Class

LawChangeRead Class

Collapse Expand Public Methods
Name | Description
read | Reads indicators for change from present law.
Collapse Expand Links
LawChangeRead Class, Legend, Public Methods


read Method

read Method
LawChangeRead Methods

Reads indicators for change from present law.

Collapse Expand Description

There are two versions of the read function. The one with no arguments opens an input stream and passes it to the version with a stream argument.

Collapse Expand Overload List
Name | Description
LawChangeRead::read () | Reads indicators for change from present law.
LawChangeRead::read (std::istream&) | Reads indicators for change from present law from an open stream.
Collapse Expand Group

LawChangeRead Methods

Collapse Expand Links
LawChangeRead Methods


LawChangeRead::read Method ()

LawChangeRead::read Method ()
LawChangeRead Class LawChangeRead Members read Method

Reads indicators for change from present law.

C++
void read();
Collapse Expand Remarks

Opens an input file and passes it to the version with a stream argument.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_LAWCHG7 if unable to open input file; of type PIA_IDS_LAWCHG6 if unable to parse input line.
Collapse Expand Group

read Method

Collapse Expand Links
LawChangeRead Class, LawChangeRead Members, read Method


LawChangeRead::read Method (std::istream&)

LawChangeRead::read Method (std::istream&)
LawChangeRead Class LawChangeRead Members read Method

Reads indicators for change from present law from an open stream.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_LAWCHG6 if unable to parse input line.
Collapse Expand Group

read Method

Collapse Expand Links
LawChangeRead Class, LawChangeRead Members, read Method


LawChangeTAXBENCHG Class

LawChangeTAXBENCHG Class
LawChangeTAXBENCHG Methods LawChangeTAXBENCHG Members LawChangeTAXBENCHG.h Classes

Parameters for a proposal to change the taxation of benefits.

Collapse Expand Class Hierarchy
  LawChangeTAXBENCHGLawChangeTAXBENCHG
C++
class LawChangeTAXBENCHG : public LawChange;
Collapse Expand File

File: LawChangeTAXBENCHG.h

Module: PiaData Library

Collapse Expand Remarks

If the indicator is greater than zero, it means the following:

1 | phase thresholds down to zero over 10 years (Ball proposal).
2 | tax 100 percent of benefits, but allow a deduction for OASDI contributions similar to that for private pensions.
3 | combination of 1 and 2.
Collapse Expand Group

Classes

Collapse Expand Links
LawChangeTAXBENCHG Methods, LawChangeTAXBENCHG Members, LawChangeTAXBENCHG.h, Classes


LawChangeTAXBENCHG Members

LawChangeTAXBENCHG Members
Enumerations LawChangeTAXBENCHG Class Legend Public Methods

The following tables list the members exposed by LawChangeTAXBENCHG.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeTAXBENCHG Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeTAXBENCHG | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeTAXBENCHG Class, Legend, Public Methods


LawChangeTAXBENCHG::LawChangeTAXBENCHG Constructor

LawChangeTAXBENCHG::LawChangeTAXBENCHG Constructor
LawChangeTAXBENCHG Class LawChangeTAXBENCHG Members LawChangeTAXBENCHG Class

Constructor.

C++
LawChangeTAXBENCHG();
Collapse Expand Class

LawChangeTAXBENCHG Class

Collapse Expand Links
LawChangeTAXBENCHG Class, LawChangeTAXBENCHG Members, LawChangeTAXBENCHG Class


LawChangeTAXBENCHG Methods

LawChangeTAXBENCHG Methods
LawChangeTAXBENCHG Class Legend Public Methods

The methods of the LawChangeTAXBENCHG class are listed here.

Collapse Expand Class

LawChangeTAXBENCHG Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares output strings for this change from present law.
Collapse Expand Links
LawChangeTAXBENCHG Class, Legend, Public Methods


LawChangeTAXBENCHG::prepareStrings Method

LawChangeTAXBENCHG::prepareStrings Method
LawChangeTAXBENCHG Class LawChangeTAXBENCHG Members LawChangeTAXBENCHG Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeTAXBENCHG Methods

Collapse Expand Links
LawChangeTAXBENCHG Class, LawChangeTAXBENCHG Members, LawChangeTAXBENCHG Methods


LawChangeTAXRATECHG Class

LawChangeTAXRATECHG Class
LawChangeTAXRATECHG Enumerations LawChangeTAXRATECHG Methods LawChangeTAXRATECHG Members LawChangeTAXRATECHG.h Classes

Parameters for a proposal to change the OASDI tax rates.

Collapse Expand Class Hierarchy
  LawChangeTAXRATECHGLawChangeTAXRATECHG
C++
class LawChangeTAXRATECHG : public LawChange;
Collapse Expand File

File: LawChangeTAXRATECHG.h

Module: PiaData Library

Collapse Expand Remarks

There are five additional data fields compared to the base class. The indicator can have the following values:

1 | the changed tax rates continue to have the self-employed rate equal to twice the employee rate.
2 | the changed tax rates include specified self-employed rates.
Collapse Expand Group

Classes

Collapse Expand Links
LawChangeTAXRATECHG Enumerations, LawChangeTAXRATECHG Methods, LawChangeTAXRATECHG Members, LawChangeTAXRATECHG.h, Classes


LawChangeTAXRATECHG Members

LawChangeTAXRATECHG Members
Enumerations LawChangeTAXRATECHG Class Legend Public Methods

The following tables list the members exposed by LawChangeTAXRATECHG.

Collapse Expand Enumerations
Name | Description
DimLimits | Array sizes.
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeTAXRATECHG Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeTAXRATECHG | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getNumTaxrates | Returns number of tax rates available.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTaxrate | Returns tax rate.
getTitle | Returns title of this law change.
getYearTaxrate | Returns year that changed tax rate is effective.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setNumTaxrates | Sets number of tax rates available.
setPhaseType | Sets indicator for type of phase-in.
setSelfEmpTaxrate | Set self-employed rates equal to twice ee-er rates.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
setTaxrate | Sets tax rate.
setYearTaxrate | Sets year that changed tax rate is effective.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and step size.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeTAXRATECHG Class, Legend, Public Methods


LawChangeTAXRATECHG::LawChangeTAXRATECHG Constructor

LawChangeTAXRATECHG::LawChangeTAXRATECHG Constructor
LawChangeTAXRATECHG Class LawChangeTAXRATECHG Members LawChangeTAXRATECHG Class

Constructor.

C++
LawChangeTAXRATECHG();
Collapse Expand Class

LawChangeTAXRATECHG Class

Collapse Expand Links
LawChangeTAXRATECHG Class, LawChangeTAXRATECHG Members, LawChangeTAXRATECHG Class


LawChangeTAXRATECHG Enumerations

LawChangeTAXRATECHG Enumerations
Enumerations LawChangeTAXRATECHG Class Legend

The enumerations of the LawChangeTAXRATECHG class are listed here.

Collapse Expand Enumerations
Name | Description
DimLimits | Array sizes.
Collapse Expand Class

LawChangeTAXRATECHG Class

Collapse Expand Links
Enumerations, LawChangeTAXRATECHG Class, Legend


LawChangeTAXRATECHG::DimLimits Enumeration

LawChangeTAXRATECHG::DimLimits Enumeration
LawChangeTAXRATECHG.h LawChangeTAXRATECHG Enumerations

Array sizes.

C++
enum DimLimits {
  MAXTAXRATES = 10
};
Collapse Expand File

File: LawChangeTAXRATECHG.h

Module: PiaData Library

Collapse Expand Members
Members | Description
MAXTAXRATES = 10 | Maximum number of new tax rate intervals.
Collapse Expand Group

LawChangeTAXRATECHG Enumerations

Collapse Expand Links
LawChangeTAXRATECHG.h, LawChangeTAXRATECHG Enumerations


LawChangeTAXRATECHG Methods

LawChangeTAXRATECHG Methods
LawChangeTAXRATECHG Class Legend Public Methods

The methods of the LawChangeTAXRATECHG class are listed here.

Collapse Expand Class

LawChangeTAXRATECHG Class

Collapse Expand Public Methods
Name | Description
getNumTaxrates | Returns number of tax rates available.
getTaxrate | Returns tax rate.
getYearTaxrate | Returns year that changed tax rate is effective.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setNumTaxrates | Sets number of tax rates available.
setSelfEmpTaxrate | Set self-employed rates equal to twice ee-er rates.
setTaxrate | Sets tax rate.
setYearTaxrate | Sets year that changed tax rate is effective.
write | Writes a line with first and last years, and step size.
Collapse Expand Links
LawChangeTAXRATECHG Class, Legend, Public Methods


LawChangeTAXRATECHG::getNumTaxrates Method

LawChangeTAXRATECHG::getNumTaxrates Method
LawChangeTAXRATECHG Class LawChangeTAXRATECHG Members LawChangeTAXRATECHG Methods

Returns number of tax rates available.

C++
int getNumTaxrates() const;
Collapse Expand Returns

Number of tax rates available.

Collapse Expand Group

LawChangeTAXRATECHG Methods

Collapse Expand Links
LawChangeTAXRATECHG Class, LawChangeTAXRATECHG Members, LawChangeTAXRATECHG Methods


LawChangeTAXRATECHG::getTaxrate Method

LawChangeTAXRATECHG::getTaxrate Method
LawChangeTAXRATECHG Class LawChangeTAXRATECHG Members LawChangeTAXRATECHG Methods

Returns tax rate.

C++
double getTaxrate(
    int yearNum,
    TaxRates::taxrateType eeer,
    TaxRates::trustfundType trustfund
) const;
Collapse Expand Parameters
Parameters | Description
int yearNum | Number of tax rate interval (0 to numTaxrates - 1).
TaxRates::taxrateType eeer | Type of tax rate.
TaxRates::trustfundType trustfund | Type of taxes. 0: OASI, 1: DI, 2: HI.
Collapse Expand Returns

Tax rate for specified parameters.

Collapse Expand Group

LawChangeTAXRATECHG Methods

Collapse Expand Links
LawChangeTAXRATECHG Class, LawChangeTAXRATECHG Members, LawChangeTAXRATECHG Methods


LawChangeTAXRATECHG::getYearTaxrate Method

LawChangeTAXRATECHG::getYearTaxrate Method
LawChangeTAXRATECHG Class LawChangeTAXRATECHG Members LawChangeTAXRATECHG Methods

Returns year that changed tax rate is effective.

C++
int getYearTaxrate(
    int yearNum
) const;
Collapse Expand Parameters
Parameters | Description
int yearNum | Number of tax rate interval (0 to getNumTaxrates - 1).
Collapse Expand Returns

Year that changed tax rate is effective.

Collapse Expand Group

LawChangeTAXRATECHG Methods

Collapse Expand Links
LawChangeTAXRATECHG Class, LawChangeTAXRATECHG Members, LawChangeTAXRATECHG Methods


LawChangeTAXRATECHG::prepareStrings Method

LawChangeTAXRATECHG::prepareStrings Method
LawChangeTAXRATECHG Class LawChangeTAXRATECHG Members LawChangeTAXRATECHG Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeTAXRATECHG Methods

Collapse Expand Links
LawChangeTAXRATECHG Class, LawChangeTAXRATECHG Members, LawChangeTAXRATECHG Methods


LawChangeTAXRATECHG::read Method

LawChangeTAXRATECHG::read Method
LawChangeTAXRATECHG Class LawChangeTAXRATECHG Members LawChangeTAXRATECHG Methods

Reads all the lines required for this law-change.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Group

LawChangeTAXRATECHG Methods

Collapse Expand Links
LawChangeTAXRATECHG Class, LawChangeTAXRATECHG Members, LawChangeTAXRATECHG Methods


LawChangeTAXRATECHG::setNumTaxrates Method

LawChangeTAXRATECHG::setNumTaxrates Method
LawChangeTAXRATECHG Class LawChangeTAXRATECHG Members LawChangeTAXRATECHG Methods

Sets number of tax rates available.

C++
void setNumTaxrates(
    int numRates
);
Collapse Expand Parameters
Parameters | Description
int numRates | New number of tax rates.
Collapse Expand Group

LawChangeTAXRATECHG Methods

Collapse Expand Links
LawChangeTAXRATECHG Class, LawChangeTAXRATECHG Members, LawChangeTAXRATECHG Methods


LawChangeTAXRATECHG::setSelfEmpTaxrate Method

LawChangeTAXRATECHG::setSelfEmpTaxrate Method
LawChangeTAXRATECHG Class LawChangeTAXRATECHG Members LawChangeTAXRATECHG Methods

Set self-employed rates equal to twice ee-er rates.

C++
void setSelfEmpTaxrate(
    int yearNum
);
Collapse Expand Parameters
Parameters | Description
int yearNum | Number of tax rate interval (0 to numTaxrates - 1).
Collapse Expand Group

LawChangeTAXRATECHG Methods

Collapse Expand Links
LawChangeTAXRATECHG Class, LawChangeTAXRATECHG Members, LawChangeTAXRATECHG Methods


LawChangeTAXRATECHG::setTaxrate Method

LawChangeTAXRATECHG::setTaxrate Method
LawChangeTAXRATECHG Class LawChangeTAXRATECHG Members LawChangeTAXRATECHG Methods

Sets tax rate.

C++
void setTaxrate(
    int yearNum,
    TaxRates::taxrateType eeer,
    TaxRates::trustfundType trustfund,
    double newRate
);
Collapse Expand Parameters
Parameters | Description
int yearNum | Number of tax rate interval (0 to numTaxrates - 1).
TaxRates::taxrateType eeer | Type of tax rate.
TaxRates::trustfundType trustfund | Type of taxes. 0: OASI, 1: DI, 2: HI.
double newRate | New tax rate.
Collapse Expand Group

LawChangeTAXRATECHG Methods

Collapse Expand Links
LawChangeTAXRATECHG Class, LawChangeTAXRATECHG Members, LawChangeTAXRATECHG Methods


LawChangeTAXRATECHG::setYearTaxrate Method

LawChangeTAXRATECHG::setYearTaxrate Method
LawChangeTAXRATECHG Class LawChangeTAXRATECHG Members LawChangeTAXRATECHG Methods

Sets year that changed tax rate is effective.

C++
void setYearTaxrate(
    int yearNum,
    int year
);
Collapse Expand Parameters
Parameters | Description
int yearNum | Number of tax rate interval (0 to getNumTaxrates - 1).
int year | New year of changed tax rate.
Collapse Expand Group

LawChangeTAXRATECHG Methods

Collapse Expand Links
LawChangeTAXRATECHG Class, LawChangeTAXRATECHG Members, LawChangeTAXRATECHG Methods


LawChangeTAXRATECHG::write Method

LawChangeTAXRATECHG::write Method
LawChangeTAXRATECHG Class LawChangeTAXRATECHG Members LawChangeTAXRATECHG Methods

Writes a line with first and last years, and step size.

C++
void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChangeTAXRATECHG Methods

Collapse Expand Links
LawChangeTAXRATECHG Class, LawChangeTAXRATECHG Members, LawChangeTAXRATECHG Methods


LawChangeWAGEBASECHG Class

LawChangeWAGEBASECHG Class
LawChangeWAGEBASECHG Methods LawChangeWAGEBASECHG Members LawChangeWAGEBASECHG.h Classes

Parameters for a proposal to change the OASDI and/or old-law wage bases.

Collapse Expand Class Hierarchy
  LawChangeWAGEBASECHGLawChangeWAGEBASECHG
C++
class LawChangeWAGEBASECHG : public LawChange;
Collapse Expand File

File: LawChangeWAGEBASECHG.h

Module: PiaData Library

Collapse Expand Remarks

There are two additional data fields compared to the base class.

If the indicator is greater than zero, it has the following meanings:

1 = ad hoc OASDI wage bases.
2 = ad hoc old-law wage bases.
3 = ad hoc OASDI and old-law wage bases.
Collapse Expand Group

Classes

Collapse Expand Links
LawChangeWAGEBASECHG Methods, LawChangeWAGEBASECHG Members, LawChangeWAGEBASECHG.h, Classes


LawChangeWAGEBASECHG Members

LawChangeWAGEBASECHG Members
Enumerations LawChangeWAGEBASECHG Class Legend Public Methods

The following tables list the members exposed by LawChangeWAGEBASECHG.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeWAGEBASECHG Class

Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeWAGEBASECHG | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getBase77 | Returns ad hoc 1977-law wage base for specified year.
getBaseOasdi | Returns ad hoc OASDI wage base for specified year.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setBase77 | Sets ad hoc 1977-law wage base.
setBaseOasdi | Sets ad hoc OASDI wage base.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeWAGEBASECHG Class, Legend, Public Methods


LawChangeWAGEBASECHG::LawChangeWAGEBASECHG Constructor

LawChangeWAGEBASECHG::LawChangeWAGEBASECHG Constructor
LawChangeWAGEBASECHG Class LawChangeWAGEBASECHG Members LawChangeWAGEBASECHG Class

Constructor.

C++
LawChangeWAGEBASECHG();
Collapse Expand Class

LawChangeWAGEBASECHG Class

Collapse Expand Links
LawChangeWAGEBASECHG Class, LawChangeWAGEBASECHG Members, LawChangeWAGEBASECHG Class


LawChangeWAGEBASECHG Methods

LawChangeWAGEBASECHG Methods
LawChangeWAGEBASECHG Class Legend Public Methods

The methods of the LawChangeWAGEBASECHG class are listed here.

Collapse Expand Class

LawChangeWAGEBASECHG Class

Collapse Expand Public Methods
Name | Description
getBase77 | Returns ad hoc 1977-law wage base for specified year.
getBaseOasdi | Returns ad hoc OASDI wage base for specified year.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setBase77 | Sets ad hoc 1977-law wage base.
setBaseOasdi | Sets ad hoc OASDI wage base.
write | Writes a line with first and last years, and percentage.
Collapse Expand Links
LawChangeWAGEBASECHG Class, Legend, Public Methods


LawChangeWAGEBASECHG::getBase77 Method

LawChangeWAGEBASECHG::getBase77 Method
LawChangeWAGEBASECHG Class LawChangeWAGEBASECHG Members LawChangeWAGEBASECHG Methods

Returns ad hoc 1977-law wage base for specified year.

C++
double getBase77(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of wage base.
Collapse Expand Returns

Ad hoc 1977-law wage base for specified year.

Collapse Expand Group

LawChangeWAGEBASECHG Methods

Collapse Expand Links
LawChangeWAGEBASECHG Class, LawChangeWAGEBASECHG Members, LawChangeWAGEBASECHG Methods


LawChangeWAGEBASECHG::getBaseOasdi Method

LawChangeWAGEBASECHG::getBaseOasdi Method
LawChangeWAGEBASECHG Class LawChangeWAGEBASECHG Members LawChangeWAGEBASECHG Methods

Returns ad hoc OASDI wage base for specified year.

C++
double getBaseOasdi(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of wage base.
Collapse Expand Returns

Ad hoc wage base for specified year.

Collapse Expand Group

LawChangeWAGEBASECHG Methods

Collapse Expand Links
LawChangeWAGEBASECHG Class, LawChangeWAGEBASECHG Members, LawChangeWAGEBASECHG Methods


LawChangeWAGEBASECHG::prepareStrings Method

LawChangeWAGEBASECHG::prepareStrings Method
LawChangeWAGEBASECHG Class LawChangeWAGEBASECHG Members LawChangeWAGEBASECHG Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeWAGEBASECHG Methods

Collapse Expand Links
LawChangeWAGEBASECHG Class, LawChangeWAGEBASECHG Members, LawChangeWAGEBASECHG Methods


LawChangeWAGEBASECHG::read Method

LawChangeWAGEBASECHG::read Method
LawChangeWAGEBASECHG Class LawChangeWAGEBASECHG Members LawChangeWAGEBASECHG Methods

Reads all the lines required for this law-change.

C++
void read(
    std::istream& infile
);
Collapse Expand Parameters
Parameters | Description
std::istream& infile | Open input stream.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_LAWCHG6 if there are not enough lines of data.
Collapse Expand Group

LawChangeWAGEBASECHG Methods

Collapse Expand Links
LawChangeWAGEBASECHG Class, LawChangeWAGEBASECHG Members, LawChangeWAGEBASECHG Methods


LawChangeWAGEBASECHG::setBase77 Method

LawChangeWAGEBASECHG::setBase77 Method
LawChangeWAGEBASECHG Class LawChangeWAGEBASECHG Members LawChangeWAGEBASECHG Methods

Sets ad hoc 1977-law wage base.

C++
void setBase77(
    int year,
    double newBase77
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which to set base.
double newBase77 | New value of base.
Collapse Expand Group

LawChangeWAGEBASECHG Methods

Collapse Expand Links
LawChangeWAGEBASECHG Class, LawChangeWAGEBASECHG Members, LawChangeWAGEBASECHG Methods


LawChangeWAGEBASECHG::setBaseOasdi Method

LawChangeWAGEBASECHG::setBaseOasdi Method
LawChangeWAGEBASECHG Class LawChangeWAGEBASECHG Members LawChangeWAGEBASECHG Methods

Sets ad hoc OASDI wage base.

C++
void setBaseOasdi(
    int year,
    double newBaseOasdi
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which to set base.
double newBaseOasdi | New value of base.
Collapse Expand Group

LawChangeWAGEBASECHG Methods

Collapse Expand Links
LawChangeWAGEBASECHG Class, LawChangeWAGEBASECHG Members, LawChangeWAGEBASECHG Methods


LawChangeWAGEBASECHG::write Method

LawChangeWAGEBASECHG::write Method
LawChangeWAGEBASECHG Class LawChangeWAGEBASECHG Members LawChangeWAGEBASECHG Methods

Writes a line with first and last years, and percentage.

C++
void write(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

LawChangeWAGEBASECHG Methods

Collapse Expand Links
LawChangeWAGEBASECHG Class, LawChangeWAGEBASECHG Members, LawChangeWAGEBASECHG Methods


LawChangeWIDFACTOR Class

LawChangeWIDFACTOR Class
LawChangeWIDFACTOR Data Members LawChangeWIDFACTOR Methods LawChangeWIDFACTOR Members LawChangeWIDFACTOR.h Classes

Parameters for a proposal to change the factor for an aged widow(er) benefit.

Collapse Expand Class Hierarchy
  LawChangeWIDFACTORLawChangeWIDFACTOR
C++
class LawChangeWIDFACTOR : public LawChange;
Collapse Expand File

File: LawChangeWIDFACTOR.h

Module: PiaData Library

Collapse Expand Remarks

There are no additional data fields compared to the base class.

If the indicator is greater than zero, it means that the present-law factor for an aged widow(er) of 100 percent is increased to 112.5 percent, in one of the following ways:

1 | effective immediately.
2 | phased in over 40 years.
Collapse Expand Group

Classes

Collapse Expand Links
LawChangeWIDFACTOR Data Members, LawChangeWIDFACTOR Methods, LawChangeWIDFACTOR Members, LawChangeWIDFACTOR.h, Classes


LawChangeWIDFACTOR Members

LawChangeWIDFACTOR Members
Enumerations LawChangeWIDFACTOR Class Legend Public Data Members Public Methods

The following tables list the members exposed by LawChangeWIDFACTOR.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeWIDFACTOR Class

Collapse Expand Public Data Members
Name | Description
newAgedWidFactor | The ultimate changed factor for an aged widow(er) benefit (1.125).
numYears | The number of years over which the factor for an aged widow(er) benefit is phased in (40).
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeWIDFACTOR | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeWIDFACTOR Class, Legend, Public Data Members, Public Methods


LawChangeWIDFACTOR::LawChangeWIDFACTOR Constructor

LawChangeWIDFACTOR::LawChangeWIDFACTOR Constructor
LawChangeWIDFACTOR Class LawChangeWIDFACTOR Members LawChangeWIDFACTOR Class

Constructor.

C++
LawChangeWIDFACTOR();
Collapse Expand Class

LawChangeWIDFACTOR Class

Collapse Expand Links
LawChangeWIDFACTOR Class, LawChangeWIDFACTOR Members, LawChangeWIDFACTOR Class


LawChangeWIDFACTOR Data Members

LawChangeWIDFACTOR Data Members
LawChangeWIDFACTOR Class Legend Public Data Members

The data members of the LawChangeWIDFACTOR class are listed here.

Collapse Expand Class

LawChangeWIDFACTOR Class

Collapse Expand Public Data Members
Name | Description
newAgedWidFactor | The ultimate changed factor for an aged widow(er) benefit (1.125).
numYears | The number of years over which the factor for an aged widow(er) benefit is phased in (40).
Collapse Expand Links
LawChangeWIDFACTOR Class, Legend, Public Data Members


LawChangeWIDFACTOR::newAgedWidFactor Data Member

LawChangeWIDFACTOR::newAgedWidFactor Data Member
LawChangeWIDFACTOR Class LawChangeWIDFACTOR Members LawChangeWIDFACTOR Data Members

The ultimate changed factor for an aged widow(er) benefit (1.125).

C++
const double newAgedWidFactor;
Collapse Expand Group

LawChangeWIDFACTOR Data Members

Collapse Expand Links
LawChangeWIDFACTOR Class, LawChangeWIDFACTOR Members, LawChangeWIDFACTOR Data Members


LawChangeWIDFACTOR::numYears Data Member

LawChangeWIDFACTOR::numYears Data Member
LawChangeWIDFACTOR Class LawChangeWIDFACTOR Members LawChangeWIDFACTOR Data Members

The number of years over which the factor for an aged widow(er) benefit is phased in (40).

C++
const int numYears;
Collapse Expand Group

LawChangeWIDFACTOR Data Members

Collapse Expand Links
LawChangeWIDFACTOR Class, LawChangeWIDFACTOR Members, LawChangeWIDFACTOR Data Members


LawChangeWIDFACTOR Methods

LawChangeWIDFACTOR Methods
LawChangeWIDFACTOR Class Legend Public Methods

The methods of the LawChangeWIDFACTOR class are listed here.

Collapse Expand Class

LawChangeWIDFACTOR Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares output strings for this change from present law.
Collapse Expand Links
LawChangeWIDFACTOR Class, Legend, Public Methods


LawChangeWIDFACTOR::prepareStrings Method

LawChangeWIDFACTOR::prepareStrings Method
LawChangeWIDFACTOR Class LawChangeWIDFACTOR Members LawChangeWIDFACTOR Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeWIDFACTOR Methods

Collapse Expand Links
LawChangeWIDFACTOR Class, LawChangeWIDFACTOR Members, LawChangeWIDFACTOR Methods


LawChangeWIFEFACTOR Class

LawChangeWIFEFACTOR Class
LawChangeWIFEFACTOR Data Members LawChangeWIFEFACTOR Methods LawChangeWIFEFACTOR Members LawChangeWIFEFACTOR.h Classes

Parameters for a proposal to change the factor for an aged spouse benefit.

Collapse Expand Class Hierarchy
  LawChangeWIFEFACTORLawChangeWIFEFACTOR
C++
class LawChangeWIFEFACTOR : public LawChange;
Collapse Expand File

File: LawChangeWIFEFACTOR.h

Module: PiaData Library

Collapse Expand Remarks

There are no additional data fields compared to the base class.

If the indicator is greater than zero, it means that the present-law factor for an aged spouse of 50 percent is reduced to 33 percent, in one of the following ways:

1 | effective immediately.
2 | phased in over 17 years at 1 percent per year.
Collapse Expand Group

Classes

Collapse Expand Links
LawChangeWIFEFACTOR Data Members, LawChangeWIFEFACTOR Methods, LawChangeWIFEFACTOR Members, LawChangeWIFEFACTOR.h, Classes


LawChangeWIFEFACTOR Members

LawChangeWIFEFACTOR Members
Enumerations LawChangeWIFEFACTOR Class Legend Public Data Members Public Methods

The following tables list the members exposed by LawChangeWIFEFACTOR.

Collapse Expand Enumerations
Name | Description
lawChangeType | Short names of changes in law.
Collapse Expand Class

LawChangeWIFEFACTOR Class

Collapse Expand Public Data Members
Name | Description
amtPerYear | The annual amount of reduction in the factor for an aged spouse benefit (0.01).
newSpouseFactor | The ultimate changed factor for an aged spouse benefit (0.33).
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeWIFEFACTOR | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years.
writeFirstLine | Writes a line with first and last years.
Collapse Expand Links
Enumerations, LawChangeWIFEFACTOR Class, Legend, Public Data Members, Public Methods


LawChangeWIFEFACTOR::LawChangeWIFEFACTOR Constructor

LawChangeWIFEFACTOR::LawChangeWIFEFACTOR Constructor
LawChangeWIFEFACTOR Class LawChangeWIFEFACTOR Members LawChangeWIFEFACTOR Class

Constructor.

C++
LawChangeWIFEFACTOR();
Collapse Expand Class

LawChangeWIFEFACTOR Class

Collapse Expand Links
LawChangeWIFEFACTOR Class, LawChangeWIFEFACTOR Members, LawChangeWIFEFACTOR Class


LawChangeWIFEFACTOR Data Members

LawChangeWIFEFACTOR Data Members
LawChangeWIFEFACTOR Class Legend Public Data Members

The data members of the LawChangeWIFEFACTOR class are listed here.

Collapse Expand Class

LawChangeWIFEFACTOR Class

Collapse Expand Public Data Members
Name | Description
amtPerYear | The annual amount of reduction in the factor for an aged spouse benefit (0.01).
newSpouseFactor | The ultimate changed factor for an aged spouse benefit (0.33).
Collapse Expand Links
LawChangeWIFEFACTOR Class, Legend, Public Data Members


LawChangeWIFEFACTOR::amtPerYear Data Member

LawChangeWIFEFACTOR::amtPerYear Data Member
LawChangeWIFEFACTOR Class LawChangeWIFEFACTOR Members LawChangeWIFEFACTOR Data Members

The annual amount of reduction in the factor for an aged spouse benefit (0.01).

C++
const double amtPerYear;
Collapse Expand Group

LawChangeWIFEFACTOR Data Members

Collapse Expand Links
LawChangeWIFEFACTOR Class, LawChangeWIFEFACTOR Members, LawChangeWIFEFACTOR Data Members


LawChangeWIFEFACTOR::newSpouseFactor Data Member

LawChangeWIFEFACTOR::newSpouseFactor Data Member
LawChangeWIFEFACTOR Class LawChangeWIFEFACTOR Members LawChangeWIFEFACTOR Data Members

The ultimate changed factor for an aged spouse benefit (0.33).

C++
const double newSpouseFactor;
Collapse Expand Group

LawChangeWIFEFACTOR Data Members

Collapse Expand Links
LawChangeWIFEFACTOR Class, LawChangeWIFEFACTOR Members, LawChangeWIFEFACTOR Data Members


LawChangeWIFEFACTOR Methods

LawChangeWIFEFACTOR Methods
LawChangeWIFEFACTOR Class Legend Public Methods

The methods of the LawChangeWIFEFACTOR class are listed here.

Collapse Expand Class

LawChangeWIFEFACTOR Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares output strings for this change from present law.
Collapse Expand Links
LawChangeWIFEFACTOR Class, Legend, Public Methods


LawChangeWIFEFACTOR::prepareStrings Method

LawChangeWIFEFACTOR::prepareStrings Method
LawChangeWIFEFACTOR Class LawChangeWIFEFACTOR Members LawChangeWIFEFACTOR Methods

Prepares output strings for this change from present law.

C++
void prepareStrings(
    std::vector< std::string >& outputString
);
Collapse Expand Parameters
Parameters | Description
std::vector< std::string >& outputString | Table of output strings.
Collapse Expand Group

LawChangeWIFEFACTOR Methods

Collapse Expand Links
LawChangeWIFEFACTOR Class, LawChangeWIFEFACTOR Members, LawChangeWIFEFACTOR Methods


LawChangeWrite Class

LawChangeWrite Class
LawChangeWrite Methods LawChangeWrite Members LawChangeWrite.h Classes

Writes a set of law changes to a file.

Collapse Expand Class Hierarchy
  LawChangeWrite
C++
class LawChangeWrite;
Collapse Expand File

File: LawChangeWrite.h

Module: PiaData Library

Collapse Expand Remarks

Writes a LawChangeArray to a file.

Collapse Expand Group

Classes

Collapse Expand Links
LawChangeWrite Methods, LawChangeWrite Members, LawChangeWrite.h, Classes


LawChangeWrite Members

LawChangeWrite Members
LawChangeWrite Class Legend Public Methods

The following tables list the members exposed by LawChangeWrite.

Collapse Expand Class

LawChangeWrite Class

Collapse Expand Public Methods
Name | Description
LawChangeWrite | Initializes references to data.
write | Writes indicators for change from present law.
Collapse Expand Links
LawChangeWrite Class, Legend, Public Methods


LawChangeWrite::LawChangeWrite Constructor

LawChangeWrite::LawChangeWrite Constructor
LawChangeWrite Class LawChangeWrite Members LawChangeWrite Class

Initializes references to data.

C++
LawChangeWrite(
    LawChangeArray& newLawChange
);
Collapse Expand Parameters
Parameters | Description
LawChangeArray& newLawChange | Law-change indicators to print out.
Collapse Expand Class

LawChangeWrite Class

Collapse Expand Links
LawChangeWrite Class, LawChangeWrite Members, LawChangeWrite Class


LawChangeWrite Methods

LawChangeWrite Methods
LawChangeWrite Class Legend Public Methods

The methods of the LawChangeWrite class are listed here.

Collapse Expand Class

LawChangeWrite Class

Collapse Expand Public Methods
Name | Description
write | Writes indicators for change from present law.
Collapse Expand Links
LawChangeWrite Class, Legend, Public Methods


write Method

write Method
LawChangeWrite Methods

Writes indicators for change from present law.

Collapse Expand Description

There are two versions of the write function. The one with no arguments opens an output stream and passes it to the version with a stream argument.

Collapse Expand Overload List
Name | Description
LawChangeWrite::write () | Writes indicators for change from present law.
LawChangeWrite::write (std::ostream&) | Writes indicators for change from present law to an open stream.
Collapse Expand Group

LawChangeWrite Methods

Collapse Expand Links
LawChangeWrite Methods


LawChangeWrite::write Method ()

LawChangeWrite::write Method ()
LawChangeWrite Class LawChangeWrite Members write Method

Writes indicators for change from present law.

C++
void write();
Collapse Expand Parameters
Parameters | Description
out | Open output stream.
Collapse Expand Remarks

Opens an output file and passes it to the version with a stream argument.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_LAWCHG8 if unable to open output file.
Collapse Expand Group

write Method

Collapse Expand Links
LawChangeWrite Class, LawChangeWrite Members, write Method


LawChangeWrite::write Method (std::ostream&)

LawChangeWrite::write Method (std::ostream&)
LawChangeWrite Class LawChangeWrite Members write Method

Writes indicators for change from present law to an open stream.

C++
void write(
    std::ostream& out
);
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Open output stream.
Collapse Expand Group

write Method

Collapse Expand Links
LawChangeWrite Class, LawChangeWrite Members, write Method


MilServDates Class

MilServDates Class
MilServDates Data Members MilServDates Methods MilServDates Friends MilServDates Members msdates.h Classes

Manages one period of military service dates.

Collapse Expand Class Hierarchy
  MilServDates
C++
class MilServDates;
Collapse Expand File

File: msdates.h

Module: PiaData Library

Collapse Expand Remarks

An array of these is stored in MilServDatesVec.

Collapse Expand Group

Classes

Collapse Expand Links
MilServDates Data Members, MilServDates Methods, MilServDates Friends, MilServDates Members, msdates.h, Classes


MilServDates Members

MilServDates Members
MilServDates Class Legend Public Data Members Public Friends Public Methods

The following tables list the members exposed by MilServDates.

Collapse Expand Class

MilServDates Class

Collapse Expand Public Data Members
Name | Description
amtPerMonth37_56 | Amount of credit per month for pre-1951 military service wage credits.
amtPerQtr57_77 | Amount of credit per quarter for military service wage credits from 1957 through 1977.
amtPerYear78_01 | Amount of credit per year for military service wage credits from 1978 through 2001.
dec1950 | Last possible date of pre-1951 military service wage credits.
endDate | Ending date of military service.
firstMilServDate | First possible date of military service wage credits.
lastMilServDate | Last possible date of military service wage credits.
startDate | Starting date of military service.
Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Name | Description
MilServDates | Creates this record with zero or blank entries.
check | Checks a military service record for consistent dates.
deleteContents | Zeroes out dates of military service.
endDateCheck | Checks an ending date for validity.
getCount1 | Returns this record number.
getCount2 | Returns the number of records in this set.
getDatesString | Returns a string with the two dates, without spaces.
getEarn | Returns wage credits for one year in a one-line record.
getEarn3750 | Returns pre-1951 wage credits in a one-line record.
getQc3750 | Returns pre-1951 quarters of coverage in a one-line record.
getQcov | Returns quarters of coverage for one year in a one-line record.
getType | Returns the type of record.
parseDates | Parses a line of data into two dates.
parseLine | Parses a line of data into a record, including the record number, the total record count, and the record type.
setCount1 | Sets this record number.
setCount2 | Sets the number of records in this set.
setType | Sets the type of record.
startDateCheck | Checks a starting date for validity.
toString | Returns a string with the military service info.
~MilServDates | Destroys this instance.
Collapse Expand Links
MilServDates Class, Legend, Public Data Members, Public Friends, Public Methods


MilServDates::MilServDates Constructor

MilServDates::MilServDates Constructor
MilServDates Class MilServDates Members MilServDates Class

Creates this record with zero or blank entries.

C++
MilServDates();
Collapse Expand Class

MilServDates Class

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Class


MilServDates::~MilServDates Destructor

MilServDates::~MilServDates Destructor
MilServDates Class MilServDates Members MilServDates Class

Destroys this instance.

C++
~MilServDates();
Collapse Expand Class

MilServDates Class

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Class


MilServDates Data Members

MilServDates Data Members
MilServDates Class Legend Public Data Members

The data members of the MilServDates class are listed here.

Collapse Expand Class

MilServDates Class

Collapse Expand Public Data Members
Name | Description
amtPerMonth37_56 | Amount of credit per month for pre-1951 military service wage credits.
amtPerQtr57_77 | Amount of credit per quarter for military service wage credits from 1957 through 1977.
amtPerYear78_01 | Amount of credit per year for military service wage credits from 1978 through 2001.
dec1950 | Last possible date of pre-1951 military service wage credits.
endDate | Ending date of military service.
firstMilServDate | First possible date of military service wage credits.
lastMilServDate | Last possible date of military service wage credits.
startDate | Starting date of military service.
Collapse Expand Links
MilServDates Class, Legend, Public Data Members


MilServDates::amtPerMonth37_56 Data Member

MilServDates::amtPerMonth37_56 Data Member
MilServDates Class MilServDates Members MilServDates Data Members

Amount of credit per month for pre-1951 military service wage credits.

C++
const double amtPerMonth37_56;
Collapse Expand Group

MilServDates Data Members

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Data Members


MilServDates::amtPerQtr57_77 Data Member

MilServDates::amtPerQtr57_77 Data Member
MilServDates Class MilServDates Members MilServDates Data Members

Amount of credit per quarter for military service wage credits from 1957 through 1977.

C++
const double amtPerQtr57_77;
Collapse Expand Group

MilServDates Data Members

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Data Members


MilServDates::amtPerYear78_01 Data Member

MilServDates::amtPerYear78_01 Data Member
MilServDates Class MilServDates Members MilServDates Data Members

Amount of credit per year for military service wage credits from 1978 through 2001.

C++
const double amtPerYear78_01;
Collapse Expand Group

MilServDates Data Members

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Data Members


MilServDates::dec1950 Data Member

MilServDates::dec1950 Data Member
MilServDates Class MilServDates Members MilServDates Data Members

Last possible date of pre-1951 military service wage credits.

C++
const DateMoyr dec1950;
Collapse Expand Group

MilServDates Data Members

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Data Members


MilServDates::endDate Data Member

MilServDates::endDate Data Member
MilServDates Class MilServDates Members MilServDates Data Members

Ending date of military service.

C++
DateMoyr endDate;
Collapse Expand Group

MilServDates Data Members

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Data Members


MilServDates::firstMilServDate Data Member

MilServDates::firstMilServDate Data Member
MilServDates Class MilServDates Members MilServDates Data Members

First possible date of military service wage credits.

C++
const DateMoyr firstMilServDate;
Collapse Expand Group

MilServDates Data Members

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Data Members


MilServDates::lastMilServDate Data Member

MilServDates::lastMilServDate Data Member
MilServDates Class MilServDates Members MilServDates Data Members

Last possible date of military service wage credits.

C++
const DateMoyr lastMilServDate;
Collapse Expand Group

MilServDates Data Members

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Data Members


MilServDates::startDate Data Member

MilServDates::startDate Data Member
MilServDates Class MilServDates Members MilServDates Data Members

Starting date of military service.

C++
DateMoyr startDate;
Collapse Expand Group

MilServDates Data Members

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Data Members


MilServDates Methods

MilServDates Methods
MilServDates Class Legend Public Methods

The methods of the MilServDates class are listed here.

Collapse Expand Class

MilServDates Class

Collapse Expand Public Methods
Name | Description
check | Checks a military service record for consistent dates.
deleteContents | Zeroes out dates of military service.
endDateCheck | Checks an ending date for validity.
getCount1 | Returns this record number.
getCount2 | Returns the number of records in this set.
getDatesString | Returns a string with the two dates, without spaces.
getEarn | Returns wage credits for one year in a one-line record.
getEarn3750 | Returns pre-1951 wage credits in a one-line record.
getQc3750 | Returns pre-1951 quarters of coverage in a one-line record.
getQcov | Returns quarters of coverage for one year in a one-line record.
getType | Returns the type of record.
parseDates | Parses a line of data into two dates.
parseLine | Parses a line of data into a record, including the record number, the total record count, and the record type.
setCount1 | Sets this record number.
setCount2 | Sets the number of records in this set.
setType | Sets the type of record.
startDateCheck | Checks a starting date for validity.
toString | Returns a string with the military service info.
Collapse Expand Links
MilServDates Class, Legend, Public Methods


MilServDates::check Method

MilServDates::check Method
MilServDates Class MilServDates Members MilServDates Methods

Checks a military service record for consistent dates.

C++
void check() const;
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_MILSERV1 if starting date is after ending date.
Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Methods


MilServDates::deleteContents Method

MilServDates::deleteContents Method
MilServDates Class MilServDates Members MilServDates Methods

Zeroes out dates of military service.

C++
void deleteContents();
Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Methods


endDateCheck Method

endDateCheck Method
MilServDates Methods

Checks an ending date for validity.

Collapse Expand Description

There are two versions of the endDateCheck function. The version with no arguments calls the version with 1 argument, passing the stored ending date.

Collapse Expand Overload List
Name | Description
MilServDates::endDateCheck () | Checks an ending date for validity.
MilServDates::endDateCheck (const DateMoyr&) | Checks a specified ending date for validity.
Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Methods


MilServDates::endDateCheck Method ()

MilServDates::endDateCheck Method ()
MilServDates Class MilServDates Members endDateCheck Method

Checks an ending date for validity.

C++
void endDateCheck() const;
Collapse Expand Remarks

Passes the stored value to the static version with 1 argument.

Collapse Expand Group

endDateCheck Method

Collapse Expand Links
MilServDates Class, MilServDates Members, endDateCheck Method


MilServDates::endDateCheck Method (const DateMoyr&)

MilServDates::endDateCheck Method (const DateMoyr&)
MilServDates Class MilServDates Members endDateCheck Method

Checks a specified ending date for validity.

C++
static void endDateCheck(
    const DateMoyr& date
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& date | The ending date.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_MILSERV5 if month or year is out of range.
Collapse Expand Group

endDateCheck Method

Collapse Expand Links
MilServDates Class, MilServDates Members, endDateCheck Method


MilServDates::getCount1 Method

MilServDates::getCount1 Method
MilServDates Class MilServDates Members MilServDates Methods

Returns this record number.

C++
int getCount1() const;
Collapse Expand Returns

This record number.

Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Methods


MilServDates::getCount2 Method

MilServDates::getCount2 Method
MilServDates Class MilServDates Members MilServDates Methods

Returns the number of records in this set.

C++
int getCount2() const;
Collapse Expand Returns

The number of records in this set.

Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Methods


MilServDates::getDatesString Method

MilServDates::getDatesString Method
MilServDates Class MilServDates Members MilServDates Methods

Returns a string with the two dates, without spaces.

C++
std::string getDatesString() const;
Collapse Expand Returns

A string with the two dates, without spaces.

Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Methods


MilServDates::getEarn Method

MilServDates::getEarn Method
MilServDates Class MilServDates Members MilServDates Methods

Returns wage credits for one year in a one-line record.

C++
double getEarn(
    unsigned year
) const;
Collapse Expand Parameters
Parameters | Description
unsigned year | Year for which wage credits are desired.
Collapse Expand Returns

Wage credits for one year in a one-line record.

Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Methods


MilServDates::getEarn3750 Method

MilServDates::getEarn3750 Method
MilServDates Class MilServDates Members MilServDates Methods

Returns pre-1951 wage credits in a one-line record.

C++
double getEarn3750() const;
Collapse Expand Returns

Pre-1951 wage credits in a one-line record.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_MILSERV7 if years are out of range (only in debug mode).
Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Methods


MilServDates::getQc3750 Method

MilServDates::getQc3750 Method
MilServDates Class MilServDates Members MilServDates Methods

Returns pre-1951 quarters of coverage in a one-line record.

C++
int getQc3750() const;
Collapse Expand Returns

Pre-1951 quarters of coverage in a one-line record.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_MILSERV6 if years are out of range (only in debug mode).
Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Methods


MilServDates::getQcov Method

MilServDates::getQcov Method
MilServDates Class MilServDates Members MilServDates Methods

Returns quarters of coverage for one year in a one-line record.

C++
int getQcov(
    unsigned year
) const;
Collapse Expand Parameters
Parameters | Description
unsigned year | Year for which quarters are desired.
Collapse Expand Returns

Quarters of coverage for one year in a one-line record.

Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Methods


MilServDates::getType Method

MilServDates::getType Method
MilServDates Class MilServDates Members MilServDates Methods

Returns the type of record.

C++
char getType() const;
Collapse Expand Returns

The type of record:

F | found in folder.
N | not proven.
P | proven.
Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Methods


MilServDates::parseDates Method

MilServDates::parseDates Method
MilServDates Class MilServDates Members MilServDates Methods

Parses a line of data into two dates.

C++
void parseDates(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Methods


MilServDates::parseLine Method

MilServDates::parseLine Method
MilServDates Class MilServDates Members MilServDates Methods

Parses a line of data into a record, including the record number, the total record count, and the record type.

C++
void parseLine(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Methods


MilServDates::setCount1 Method

MilServDates::setCount1 Method
MilServDates Class MilServDates Members MilServDates Methods

Sets this record number.

C++
void setCount1(
    int newCount1
);
Collapse Expand Parameters
Parameters | Description
int newCount1 | New record number.
Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Methods


MilServDates::setCount2 Method

MilServDates::setCount2 Method
MilServDates Class MilServDates Members MilServDates Methods

Sets the number of records in this set.

C++
void setCount2(
    int newCount2
);
Collapse Expand Parameters
Parameters | Description
int newCount2 | New number of records in this set.
Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Methods


MilServDates::setType Method

MilServDates::setType Method
MilServDates Class MilServDates Members MilServDates Methods

Sets the type of record.

C++
void setType(
    char newType
);
Collapse Expand Parameters
Parameters | Description
char newType | New type of record.
Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Methods


startDateCheck Method

startDateCheck Method
MilServDates Methods

Checks a starting date for validity.

Collapse Expand Description

There are two versions of the startDateCheck function. The version with no arguments calls the version with 1 argument, passing the stored starting date.

Collapse Expand Overload List
Name | Description
MilServDates::startDateCheck () | Checks a starting date for validity.
MilServDates::startDateCheck (const DateMoyr&) | Checks a specified starting date for validity.
Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Methods


MilServDates::startDateCheck Method ()

MilServDates::startDateCheck Method ()
MilServDates Class MilServDates Members startDateCheck Method

Checks a starting date for validity.

C++
void startDateCheck() const;
Collapse Expand Remarks

Passes the stored value to the static version with 1 argument.

Collapse Expand Group

startDateCheck Method

Collapse Expand Links
MilServDates Class, MilServDates Members, startDateCheck Method


MilServDates::startDateCheck Method (const DateMoyr&)

MilServDates::startDateCheck Method (const DateMoyr&)
MilServDates Class MilServDates Members startDateCheck Method

Checks a specified starting date for validity.

C++
static void startDateCheck(
    const DateMoyr& date
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& date | The starting date.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_MILSERV4 if month or year is out of range.
Collapse Expand Group

startDateCheck Method

Collapse Expand Links
MilServDates Class, MilServDates Members, startDateCheck Method


toString Method

toString Method
MilServDates Methods

Returns a string with the military service info.

Collapse Expand Description

There are two versions of this function. The one without an argument returns a string without any extra spaces. The one with a format string allows a choice of format, including one with extra spaces as required to produce a fixed-length string.

Collapse Expand Overload List
Name | Description
MilServDates::toString () | Returns a string with the military service info.
MilServDates::toString (const std::string&) | Returns a string with the military service info, with spaces appropriate for a print output.
Collapse Expand Group

MilServDates Methods

Collapse Expand Links
MilServDates Methods


MilServDates::toString Method ()

MilServDates::toString Method ()
MilServDates Class MilServDates Members toString Method

Returns a string with the military service info.

C++
std::string toString() const;
Collapse Expand Returns

A string A string with the military service info.

Collapse Expand Group

toString Method

Collapse Expand Links
MilServDates Class, MilServDates Members, toString Method


MilServDates::toString Method (const std::string&)

MilServDates::toString Method (const std::string&)
MilServDates Class MilServDates Members toString Method

Returns a string with the military service info, with spaces appropriate for a print output.

C++
std::string toString(
    const std::string& format
) const;
Collapse Expand Parameters
Parameters | Description
const std::string& format | Format to use.
Collapse Expand Returns

A string with the military service info.

Collapse Expand Remarks

If the format string begins with "f", create a fixed-width string; otherwise create a string with no extra spaces.

Collapse Expand Group

toString Method

Collapse Expand Links
MilServDates Class, MilServDates Members, toString Method


MilServDates Friends

MilServDates Friends
MilServDates Class Public Friends

The friends of the MilServDates class are listed here.

Collapse Expand Class

MilServDates Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Links
MilServDates Class, Public Friends


friend class boost::serialization::access Friend

friend class boost::serialization::access Friend
MilServDates Class MilServDates Members MilServDates Friends

Friend class to allow serialization.

C++
friend class boost::serialization::access;
Collapse Expand Group

MilServDates Friends

Collapse Expand Links
MilServDates Class, MilServDates Members, MilServDates Friends


MilServDatesVec Class

MilServDatesVec Class
MilServDatesVec Data Members MilServDatesVec Methods MilServDatesVec Friends MilServDatesVec Members MilServDatesVec.h Classes

Manages all the military service dates records for one ssn.

Collapse Expand Class Hierarchy
  MilServDatesVec
C++
class MilServDatesVec;
Collapse Expand File

File: MilServDatesVec.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in WorkerData.

Collapse Expand Group

Classes

Collapse Expand Links
MilServDatesVec Data Members, MilServDatesVec Methods, MilServDatesVec Friends, MilServDatesVec Members, MilServDatesVec.h, Classes


MilServDatesVec Members

MilServDatesVec Members
MilServDatesVec Class Legend Public Data Members Public Friends Public Methods

The following tables list the members exposed by MilServDatesVec.

Collapse Expand Class

MilServDatesVec Class

Collapse Expand Public Data Members
Name | Description
MAX_MILSERVDATES | The number of MilServDates records allowed.
msdates | An array of MilServDates records.
Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Name | Description
MilServDatesVec | Creates an array with a zero record count.
check | Checks a multiline record.
deleteContents | Zeroes out dates of military service.
getEarn | Returns wage credits for one year in a multiline record.
getEarn3750 | Returns pre-1951 wage credits in a multiline record.
getFirstYear | Returns first year with any military service, 0 if none.
getLastYear | Returns last year with any military service, 0 if none.
getMSCount | Returns the number of records being used.
getQc3750 | Returns pre-1951 quarters of coverage in a multiline record.
getQcov | Returns quarters of coverage for one year in a multiline record.
msCountCheck | Checks the number of military service periods.
setMSCount | Sets the number of military service records.
~MilServDatesVec | Destroys this instance.
Collapse Expand Links
MilServDatesVec Class, Legend, Public Data Members, Public Friends, Public Methods


MilServDatesVec::MilServDatesVec Constructor

MilServDatesVec::MilServDatesVec Constructor
MilServDatesVec Class MilServDatesVec Members MilServDatesVec Class

Creates an array with a zero record count.

C++
MilServDatesVec();
Collapse Expand Class

MilServDatesVec Class

Collapse Expand Links
MilServDatesVec Class, MilServDatesVec Members, MilServDatesVec Class


MilServDatesVec::~MilServDatesVec Destructor

MilServDatesVec::~MilServDatesVec Destructor
MilServDatesVec Class MilServDatesVec Members MilServDatesVec Class

Destroys this instance.

C++
~MilServDatesVec();
Collapse Expand Class

MilServDatesVec Class

Collapse Expand Links
MilServDatesVec Class, MilServDatesVec Members, MilServDatesVec Class


MilServDatesVec Data Members

MilServDatesVec Data Members
MilServDatesVec Class Legend Public Data Members

The data members of the MilServDatesVec class are listed here.

Collapse Expand Class

MilServDatesVec Class

Collapse Expand Public Data Members
Name | Description
MAX_MILSERVDATES | The number of MilServDates records allowed.
msdates | An array of MilServDates records.
Collapse Expand Links
MilServDatesVec Class, Legend, Public Data Members


MilServDatesVec::MAX_MILSERVDATES Data Member

MilServDatesVec::MAX_MILSERVDATES Data Member
MilServDatesVec Class MilServDatesVec Members MilServDatesVec Data Members

The number of MilServDates records allowed.

C++
const unsigned MAX_MILSERVDATES = 15;
Collapse Expand Group

MilServDatesVec Data Members

Collapse Expand Links
MilServDatesVec Class, MilServDatesVec Members, MilServDatesVec Data Members


MilServDatesVec::msdates Data Member

MilServDatesVec::msdates Data Member
MilServDatesVec Class MilServDatesVec Members MilServDatesVec Data Members

An array of MilServDates records.

C++
MilServDates msdates[MAX_MILSERVDATES];
Collapse Expand Remarks

There can be up to MAX_MILSERVDATES records.

Collapse Expand Group

MilServDatesVec Data Members

Collapse Expand Links
MilServDatesVec Class, MilServDatesVec Members, MilServDatesVec Data Members


MilServDatesVec Methods

MilServDatesVec Methods
MilServDatesVec Class Legend Public Methods

The methods of the MilServDatesVec class are listed here.

Collapse Expand Class

MilServDatesVec Class

Collapse Expand Public Methods
Name | Description
check | Checks a multiline record.
deleteContents | Zeroes out dates of military service.
getEarn | Returns wage credits for one year in a multiline record.
getEarn3750 | Returns pre-1951 wage credits in a multiline record.
getFirstYear | Returns first year with any military service, 0 if none.
getLastYear | Returns last year with any military service, 0 if none.
getMSCount | Returns the number of records being used.
getQc3750 | Returns pre-1951 quarters of coverage in a multiline record.
getQcov | Returns quarters of coverage for one year in a multiline record.
msCountCheck | Checks the number of military service periods.
setMSCount | Sets the number of military service records.
Collapse Expand Links
MilServDatesVec Class, Legend, Public Methods


MilServDatesVec::check Method

MilServDatesVec::check Method
MilServDatesVec Class MilServDatesVec Members MilServDatesVec Methods

Checks a multiline record.

C++
void check() const;
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_MILSERV1 if starting date is after ending date in any MilServDates.
Collapse Expand Group

MilServDatesVec Methods

Collapse Expand Links
MilServDatesVec Class, MilServDatesVec Members, MilServDatesVec Methods


MilServDatesVec::deleteContents Method

MilServDatesVec::deleteContents Method
MilServDatesVec Class MilServDatesVec Members MilServDatesVec Methods

Zeroes out dates of military service.

C++
void deleteContents();
Collapse Expand Group

MilServDatesVec Methods

Collapse Expand Links
MilServDatesVec Class, MilServDatesVec Members, MilServDatesVec Methods


MilServDatesVec::getEarn Method

MilServDatesVec::getEarn Method
MilServDatesVec Class MilServDatesVec Members MilServDatesVec Methods

Returns wage credits for one year in a multiline record.

C++
double getEarn(
    unsigned year
) const;
Collapse Expand Parameters
Parameters | Description
unsigned year | Year for which wage credits are desired.
Collapse Expand Returns

Wage credits for one year in a multiline record.

Collapse Expand Group

MilServDatesVec Methods

Collapse Expand Links
MilServDatesVec Class, MilServDatesVec Members, MilServDatesVec Methods


MilServDatesVec::getEarn3750 Method

MilServDatesVec::getEarn3750 Method
MilServDatesVec Class MilServDatesVec Members MilServDatesVec Methods

Returns pre-1951 wage credits in a multiline record.

C++
double getEarn3750() const;
Collapse Expand Returns

Pre-1951 wage credits in a multiline record.

Collapse Expand Group

MilServDatesVec Methods

Collapse Expand Links
MilServDatesVec Class, MilServDatesVec Members, MilServDatesVec Methods


MilServDatesVec::getFirstYear Method

MilServDatesVec::getFirstYear Method
MilServDatesVec Class MilServDatesVec Members MilServDatesVec Methods

Returns first year with any military service, 0 if none.

C++
int getFirstYear() const;
Collapse Expand Returns

First year with any military service, 0 if none.

Collapse Expand Group

MilServDatesVec Methods

Collapse Expand Links
MilServDatesVec Class, MilServDatesVec Members, MilServDatesVec Methods


MilServDatesVec::getLastYear Method

MilServDatesVec::getLastYear Method
MilServDatesVec Class MilServDatesVec Members MilServDatesVec Methods

Returns last year with any military service, 0 if none.

C++
int getLastYear() const;
Collapse Expand Returns

Last year with any military service, 0 if none.

Collapse Expand Group

MilServDatesVec Methods

Collapse Expand Links
MilServDatesVec Class, MilServDatesVec Members, MilServDatesVec Methods


MilServDatesVec::getMSCount Method

MilServDatesVec::getMSCount Method
MilServDatesVec Class MilServDatesVec Members MilServDatesVec Methods

Returns the number of records being used.

C++
unsigned getMSCount() const;
Collapse Expand Returns

The number of records being used.

Collapse Expand Group

MilServDatesVec Methods

Collapse Expand Links
MilServDatesVec Class, MilServDatesVec Members, MilServDatesVec Methods


MilServDatesVec::getQc3750 Method

MilServDatesVec::getQc3750 Method
MilServDatesVec Class MilServDatesVec Members MilServDatesVec Methods

Returns pre-1951 quarters of coverage in a multiline record.

C++
unsigned getQc3750() const;
Collapse Expand Returns

Pre-1951 quarters of coverage in a multiline record.

Collapse Expand Group

MilServDatesVec Methods

Collapse Expand Links
MilServDatesVec Class, MilServDatesVec Members, MilServDatesVec Methods


MilServDatesVec::getQcov Method

MilServDatesVec::getQcov Method
MilServDatesVec Class MilServDatesVec Members MilServDatesVec Methods

Returns quarters of coverage for one year in a multiline record.

C++
unsigned getQcov(
    unsigned year
) const;
Collapse Expand Parameters
Parameters | Description
unsigned year | Year for which quarters are desired.
Collapse Expand Returns

Quarters of coverage for one year in a multiline record.

Collapse Expand Group

MilServDatesVec Methods

Collapse Expand Links
MilServDatesVec Class, MilServDatesVec Members, MilServDatesVec Methods


MilServDatesVec::msCountCheck Method

MilServDatesVec::msCountCheck Method
MilServDatesVec Class MilServDatesVec Members MilServDatesVec Methods

Checks the number of military service periods.

C++
static void msCountCheck(
    unsigned newMSCount
);
Collapse Expand Parameters
Parameters | Description
unsigned newMSCount | Number of military service periods.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_MILSERV2 if number of military service periods is out of range.
Collapse Expand Group

MilServDatesVec Methods

Collapse Expand Links
MilServDatesVec Class, MilServDatesVec Members, MilServDatesVec Methods


MilServDatesVec::setMSCount Method

MilServDatesVec::setMSCount Method
MilServDatesVec Class MilServDatesVec Members MilServDatesVec Methods

Sets the number of military service records.

C++
void setMSCount(
    unsigned newMSCount
);
Collapse Expand Parameters
Parameters | Description
unsigned newMSCount | New number of military service records.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_MILSERV2 if number of military service periods is out of range.
Collapse Expand Group

MilServDatesVec Methods

Collapse Expand Links
MilServDatesVec Class, MilServDatesVec Members, MilServDatesVec Methods


MilServDatesVec Friends

MilServDatesVec Friends
MilServDatesVec Class Public Friends

The friends of the MilServDatesVec class are listed here.

Collapse Expand Class

MilServDatesVec Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Links
MilServDatesVec Class, Public Friends


friend class boost::serialization::access Friend

friend class boost::serialization::access Friend
MilServDatesVec Class MilServDatesVec Members MilServDatesVec Friends

Friend class to allow serialization.

C++
friend class boost::serialization::access;
Collapse Expand Group

MilServDatesVec Friends

Collapse Expand Links
MilServDatesVec Class, MilServDatesVec Members, MilServDatesVec Friends


OldPia Class

OldPia Class
OldPia Data Members OldPia Methods OldPia Members OldPia.h Classes

Parent of all methods using pia tables in the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  OldPiaOldPia
C++
class OldPia : public PiaMethod;
Collapse Expand File

File: OldPia.h

Module: PiaData Library

Collapse Expand Remarks

Child classes are OldStart, PiaTable, and SpecMin.

Collapse Expand See Also

OldStart, PiaTable, SpecMin

Collapse Expand Group

Classes

Collapse Expand Links
OldPia Data Members, OldPia Methods, OldPia Members, OldPia.h, Classes


OldPia Members

OldPia Members
Enumerations OldPia Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by OldPia.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

OldPia Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
iamemax | Maximum ame in pia interval.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
OldPia | Initializes this instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Calculates pia and mfb for this method.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Returns true if this method is applicable.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~OldPia | Destructor.
Collapse Expand Links
Enumerations, OldPia Class, Legend, Protected Data Members, Public Data Members, Public Methods


OldPia::OldPia Constructor

OldPia::OldPia Constructor
OldPia Class OldPia Members OldPia Class

Initializes this instance.

C++
OldPia(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear,
    const std::string& newTitle,
    pia_type newMethod
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
const std::string& newTitle | Title of this method.
pia_type newMethod | Number of this method.
Collapse Expand Class

OldPia Class

Collapse Expand Links
OldPia Class, OldPia Members, OldPia Class


OldPia::~OldPia Destructor

OldPia::~OldPia Destructor
OldPia Class OldPia Members OldPia Class

Destructor.

C++
virtual ~OldPia();
Collapse Expand Class

OldPia Class

Collapse Expand Links
OldPia Class, OldPia Members, OldPia Class


OldPia Data Members

OldPia Data Members
OldPia Class Legend Protected Data Members

The data members of the OldPia class are listed here.

Collapse Expand Class

OldPia Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
iamemax | Maximum ame in pia interval.
Collapse Expand Links
OldPia Class, Legend, Protected Data Members


OldPia::iamemax Data Member

OldPia::iamemax Data Member
OldPia Class OldPia Members OldPia Data Members

Maximum ame in pia interval.

C++
int iamemax;
Collapse Expand Group

OldPia Data Members

Collapse Expand Links
OldPia Class, OldPia Members, OldPia Data Members


OldPia Methods

OldPia Methods
OldPia Class Legend Public Methods

The methods of the OldPia class are listed here.

Collapse Expand Class

OldPia Class

Collapse Expand Public Methods
Name | Description
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
Collapse Expand Links
OldPia Class, Legend, Public Methods


OldPia::cpiBase Method

OldPia::cpiBase Method
OldPia Class OldPia Members OldPia Methods

Applies CPI and wage base increases to 1973 Act PIA Table.

C++
table_type cpiBase(
    const DateMoyr& benefitDate,
    bool freeze,
    double amesub,
    bool saveInfo
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& benefitDate | The date for which PIA table is desired.
bool freeze | True for transitional guarantee or 1977 old-start calculation with 1979 or later eligibility, false otherwise.
double amesub | AME in this function.
bool saveInfo | True to save PIA and MFB when doing CPI adjustments.
Collapse Expand Returns

Number of correct PIA table.

Collapse Expand Group

OldPia Methods

Collapse Expand Links
OldPia Class, OldPia Members, OldPia Methods


OldPia::mfbOldCal Method

OldPia::mfbOldCal Method
OldPia Class OldPia Members OldPia Methods

Finds AME from PIA in PIA table.

C++
double mfbOldCal(
    bool belowMin
);
Collapse Expand Parameters
Parameters | Description
bool belowMin | False to not adjust for PIA below minimum, true to adjust.
Collapse Expand Returns

AME corresponding to the PIA.

Collapse Expand Group

OldPia Methods

Collapse Expand Links
OldPia Class, OldPia Members, OldPia Methods


OldPia::oldPiaCal Method

OldPia::oldPiaCal Method
OldPia Class OldPia Members OldPia Methods

Selects correct PIA table.

C++
table_type oldPiaCal();
Collapse Expand Returns

Number of correct PIA table.

Collapse Expand Group

OldPia Methods

Collapse Expand Links
OldPia Class, OldPia Members, OldPia Methods


OldPia::pl1952 Method

OldPia::pl1952 Method
OldPia Class OldPia Members OldPia Methods

Calculates PIAs under 1952 Act.

C++
table_type pl1952(
    int amesub
);
Collapse Expand Parameters
Parameters | Description
int amesub | AME in this function.
Collapse Expand Returns

Number of correct PIA table.

Collapse Expand Group

OldPia Methods

Collapse Expand Links
OldPia Class, OldPia Members, OldPia Methods


OldPia::pl1954 Method

OldPia::pl1954 Method
OldPia Class OldPia Members OldPia Methods

Calculates PIAs under 1954 Act.

C++
table_type pl1954(
    int amesub
);
Collapse Expand Parameters
Parameters | Description
int amesub | AME in this function.
Collapse Expand Returns

Number of correct PIA table.

Collapse Expand Group

OldPia Methods

Collapse Expand Links
OldPia Class, OldPia Members, OldPia Methods


OldPia::pl1958 Method

OldPia::pl1958 Method
OldPia Class OldPia Members OldPia Methods

Calculates PIAs under 1958 Act.

C++
table_type pl1958(
    int amesub
);
Collapse Expand Parameters
Parameters | Description
int amesub | AME in this function.
Collapse Expand Returns

Number of correct PIA table.

Collapse Expand Group

OldPia Methods

Collapse Expand Links
OldPia Class, OldPia Members, OldPia Methods


OldPia::pl1965 Method

OldPia::pl1965 Method
OldPia Class OldPia Members OldPia Methods

Calculates PIAs under 1965 Act.

C++
table_type pl1965(
    int amesub
);
Collapse Expand Parameters
Parameters | Description
int amesub | AME in this function.
Collapse Expand Returns

Number of correct PIA table.

Collapse Expand Group

OldPia Methods

Collapse Expand Links
OldPia Class, OldPia Members, OldPia Methods


OldPia::pl1967 Method

OldPia::pl1967 Method
OldPia Class OldPia Members OldPia Methods

Calculates PIAs under 1967 Act.

C++
table_type pl1967(
    int amesub
);
Collapse Expand Parameters
Parameters | Description
int amesub | AME in this function.
Collapse Expand Returns

Number of correct PIA table.

Collapse Expand Group

OldPia Methods

Collapse Expand Links
OldPia Class, OldPia Members, OldPia Methods


OldPia::pl1969 Method

OldPia::pl1969 Method
OldPia Class OldPia Members OldPia Methods

Calculates PIAs under 1969 Act.

C++
table_type pl1969(
    int amesub
);
Collapse Expand Parameters
Parameters | Description
int amesub | AME in this function.
Collapse Expand Returns

Number of correct PIA table.

Collapse Expand Group

OldPia Methods

Collapse Expand Links
OldPia Class, OldPia Members, OldPia Methods


OldPia::pl1971 Method

OldPia::pl1971 Method
OldPia Class OldPia Members OldPia Methods

Calculates PIAs under 1971 Act.

C++
table_type pl1971(
    int amesub
);
Collapse Expand Parameters
Parameters | Description
int amesub | AME in this function.
Collapse Expand Returns

Number of correct PIA table.

Collapse Expand Group

OldPia Methods

Collapse Expand Links
OldPia Class, OldPia Members, OldPia Methods


OldPia::pl1972 Method

OldPia::pl1972 Method
OldPia Class OldPia Members OldPia Methods

Calculates PIAs under 1972 Act, effective Sept 1972.

C++
table_type pl1972(
    int amesub
);
Collapse Expand Parameters
Parameters | Description
int amesub | AME in this function.
Collapse Expand Returns

Number of correct PIA table.

Collapse Expand Group

OldPia Methods

Collapse Expand Links
OldPia Class, OldPia Members, OldPia Methods


OldPia::pl1973 Method

OldPia::pl1973 Method
OldPia Class OldPia Members OldPia Methods

Calculates PIAs under 1973 Act.

C++
void pl1973(
    int amesub
);
Collapse Expand Parameters
Parameters | Description
int amesub | AME in this function.
Collapse Expand Group

OldPia Methods

Collapse Expand Links
OldPia Class, OldPia Members, OldPia Methods


OldPia::pl1973ext Method

OldPia::pl1973ext Method
OldPia Class OldPia Members OldPia Methods

Calculates PIAs under 1973 Act, extension to table.

C++
void pl1973ext(
    int amesub
);
Collapse Expand Parameters
Parameters | Description
int amesub | AME in this function.
Collapse Expand Group

OldPia Methods

Collapse Expand Links
OldPia Class, OldPia Members, OldPia Methods


OldStart Class

OldStart Class
OldStart Enumerations OldStart Data Members OldStart Methods OldStart Members OldStart.h Classes

Manages the functions required for calculation of an old start Social Security benefit.

Collapse Expand Class Hierarchy
  OldStartOldStartOldStart
C++
class OldStart : public OldPia;
Collapse Expand File

File: OldStart.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaCalPL.

Collapse Expand Group

Classes

Collapse Expand Links
OldStart Enumerations, OldStart Data Members, OldStart Methods, OldStart Members, OldStart.h, Classes


OldStart Members

OldStart Members
Enumerations OldStart Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by OldStart.

Collapse Expand Enumerations
Name | Description
OldStartType | Old-start PIA calculation methods.
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

OldStart Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
entDate | The date of entitlement.
iamemax | Maximum ame in pia interval.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
INC_PER_YEAR | Factor for amount of increment per year (0.01).
bendMfb | Bend points for MFB formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
percMfb | Wage-indexed MFB formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
portionAme | Portion of AME in each interval of PIB formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
OldStart | Initializes an OldStart instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Computes old start PIA.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeOs | Returns old-start AME.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getDivisorOs | Returns divisor for old-start pre-1951 earnings.
getIncyrs | Returns number of old-start increment years.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getMethodOs | Returns old-start calculation method number.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getPib | Returns old-start PIB before incrementing.
getPibInc | Returns old-start PIB after incrementing.
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
imputeEarnings | Imputes yearly earnings prior to 1951.
incrementCal | Calculates number of increment years for old-start.
incrementOldCal | Calculates number of increment years for old old-start.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isOs1977_90 | Returns true if the old-start method is 1977 or 1990.
isPebsAssumptions | Returns old Statement assumptions indicator.
methodOsCal | Determines correct old-start method.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
oldStart39Cal | Calculates 1939 old-start PIA and MFB.
oldStart50Cal | Calculates 1950 old-start PIA and MFB.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeOs | Sets old-start AME.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setDivisorOs | Sets divisor for old-start pre-1951 earnings.
setIncyrs | Sets number of old-start increment years.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setMethodOs | Sets old-start calculation method number.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPib | Sets old-start PIB before incrementing.
setPibInc | Sets old-start PIB with increment years.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~OldStart | Destructor.
Collapse Expand Links
Enumerations, OldStart Class, Legend, Protected Data Members, Public Data Members, Public Methods


OldStart::OldStart Constructor

OldStart::OldStart Constructor
OldStart Class OldStart Members OldStart Class

Initializes an OldStart instance.

C++
OldStart(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear,
    const DateMoyr& newEntDate
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
const DateMoyr& newEntDate | The date of entitlement.
Collapse Expand Class

OldStart Class

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Class


OldStart::~OldStart Destructor

OldStart::~OldStart Destructor
OldStart Class OldStart Members OldStart Class

Destructor.

C++
virtual ~OldStart();
Collapse Expand Class

OldStart Class

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Class


OldStart Enumerations

OldStart Enumerations
Enumerations OldStart Class Legend

The enumerations of the OldStart class are listed here.

Collapse Expand Enumerations
Name | Description
OldStartType | Old-start PIA calculation methods.
Collapse Expand Class

OldStart Class

Collapse Expand Links
Enumerations, OldStart Class, Legend


OldStart::OldStartType Enumeration

OldStart::OldStartType Enumeration
OldStart.h OldStart Enumerations

Old-start PIA calculation methods.

C++
enum OldStartType {
  OS1939 = 0,
  OS1950,
  OS1958,
  OS1965,
  OS1967,
  OS1977_78,
  OS1977_79,
  OS1990,
  NUM_OLD_START_TYPES
};
Collapse Expand File

File: OldStart.h

Module: PiaData Library

Collapse Expand Members
Members | Description
OS1939 = 0 | 1939 Amendments.
OS1950 | 1950 old-start.
OS1958 | 1950 old-start with 1958 conversion table.
OS1965 | 1965 old-start.
OS1967 | 1967 old-start.
OS1977_78 | 1977 old-start with Jan 1978 old-law PIA table.
OS1977_79 | 1977 old-start with Dec 1978 frozen PIA table.
OS1990 | 1990 old-start.
NUM_OLD_START_TYPES | Number of old-start PIA methods (8).
Collapse Expand Group

OldStart Enumerations

Collapse Expand Links
OldStart.h, OldStart Enumerations


OldStart Data Members

OldStart Data Members
OldStart Class Legend Protected Data Members Public Data Members

The data members of the OldStart class are listed here.

Collapse Expand Class

OldStart Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
entDate | The date of entitlement.
Collapse Expand Public Data Members
Name | Description
INC_PER_YEAR | Factor for amount of increment per year (0.01).
bendMfb | Bend points for MFB formula.
percMfb | Wage-indexed MFB formula percentages.
portionAme | Portion of AME in each interval of PIB formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
Collapse Expand Links
OldStart Class, Legend, Protected Data Members, Public Data Members


OldStart::INC_PER_YEAR Data Member

OldStart::INC_PER_YEAR Data Member
OldStart Class OldStart Members OldStart Data Members

Factor for amount of increment per year (0.01).

C++
const double INC_PER_YEAR;
Collapse Expand Group

OldStart Data Members

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Data Members


OldStart::bendMfb Data Member

OldStart::bendMfb Data Member
OldStart Class OldStart Members OldStart Data Members

Bend points for MFB formula.

C++
BendMfb bendMfb;
Collapse Expand Group

OldStart Data Members

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Data Members


OldStart::entDate Data Member

OldStart::entDate Data Member
OldStart Class OldStart Members OldStart Data Members

The date of entitlement.

C++
const DateMoyr entDate;
Collapse Expand Group

OldStart Data Members

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Data Members


OldStart::percMfb Data Member

OldStart::percMfb Data Member
OldStart Class OldStart Members OldStart Data Members

Wage-indexed MFB formula percentages.

C++
PercMfb percMfb;
Collapse Expand Group

OldStart Data Members

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Data Members


OldStart::portionAme Data Member

OldStart::portionAme Data Member
OldStart Class OldStart Members OldStart Data Members

Portion of AME in each interval of PIB formula.

C++
double portionAme[2];
Collapse Expand Group

OldStart Data Members

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Data Members


OldStart::portionPiaElig Data Member

OldStart::portionPiaElig Data Member
OldStart Class OldStart Members OldStart Data Members

Portion of AIME PIA in each interval of MFB formula.

C++
double portionPiaElig[4];
Collapse Expand Group

OldStart Data Members

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Data Members


OldStart Methods

OldStart Methods
OldStart Class Legend Public Methods

The methods of the OldStart class are listed here.

Collapse Expand Class

OldStart Class

Collapse Expand Public Methods
Name | Description
calculate | Computes old start PIA.
getAmeOs | Returns old-start AME.
getDivisorOs | Returns divisor for old-start pre-1951 earnings.
getIncyrs | Returns number of old-start increment years.
getMethodOs | Returns old-start calculation method number.
getPib | Returns old-start PIB before incrementing.
getPibInc | Returns old-start PIB after incrementing.
imputeEarnings | Imputes yearly earnings prior to 1951.
incrementCal | Calculates number of increment years for old-start.
incrementOldCal | Calculates number of increment years for old old-start.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isOs1977_90 | Returns true if the old-start method is 1977 or 1990.
methodOsCal | Determines correct old-start method.
oldStart39Cal | Calculates 1939 old-start PIA and MFB.
oldStart50Cal | Calculates 1950 old-start PIA and MFB.
setAmeOs | Sets old-start AME.
setDivisorOs | Sets divisor for old-start pre-1951 earnings.
setIncyrs | Sets number of old-start increment years.
setMethodOs | Sets old-start calculation method number.
setPib | Sets old-start PIB before incrementing.
setPibInc | Sets old-start PIB with increment years.
Collapse Expand Links
OldStart Class, Legend, Public Methods


OldStart::calculate Method

OldStart::calculate Method
OldStart Class OldStart Members OldStart Methods

Computes old start PIA.

C++
void calculate();
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_OLDSTART1 if date of entitlement is out of range (only in debug mode); of type PIA_IDS_OLDSTART2 if old start method number is out of range (only in debug mode).
Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::getAmeOs Method

OldStart::getAmeOs Method
OldStart Class OldStart Members OldStart Methods

Returns old-start AME.

C++
int getAmeOs() const;
Collapse Expand Returns

Old-start AME.

Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::getDivisorOs Method

OldStart::getDivisorOs Method
OldStart Class OldStart Members OldStart Methods

Returns divisor for old-start pre-1951 earnings.

C++
int getDivisorOs() const;
Collapse Expand Returns

Divisor for old-start pre-1951 earnings.

Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::getIncyrs Method

OldStart::getIncyrs Method
OldStart Class OldStart Members OldStart Methods

Returns number of old-start increment years.

C++
int getIncyrs() const;
Collapse Expand Returns

Number of old-start increment years.

Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::getMethodOs Method

OldStart::getMethodOs Method
OldStart Class OldStart Members OldStart Methods

Returns old-start calculation method number.

C++
OldStartType getMethodOs() const;
Collapse Expand Returns

Old-start calculation method number.

Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::getPib Method

OldStart::getPib Method
OldStart Class OldStart Members OldStart Methods

Returns old-start PIB before incrementing.

C++
double getPib() const;
Collapse Expand Returns

Old-start PIB before incrementing.

Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::getPibInc Method

OldStart::getPibInc Method
OldStart Class OldStart Members OldStart Methods

Returns old-start PIB after incrementing.

C++
double getPibInc() const;
Collapse Expand Returns

Old-start PIB after incrementing.

Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::imputeEarnings Method

OldStart::imputeEarnings Method
OldStart Class OldStart Members OldStart Methods

Imputes yearly earnings prior to 1951.

C++
void imputeEarnings();
Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::incrementCal Method

OldStart::incrementCal Method
OldStart Class OldStart Members OldStart Methods

Calculates number of increment years for old-start.

C++
int incrementCal() const;
Collapse Expand Returns

Number of increment years.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_OLDSTART2 if old start method number is out of range.
Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::incrementOldCal Method

OldStart::incrementOldCal Method
OldStart Class OldStart Members OldStart Methods

Calculates number of increment years for old old-start.

C++
int incrementOldCal() const;
Collapse Expand Returns

Number of increment years.

Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::initialize Method

OldStart::initialize Method
OldStart Class OldStart Members OldStart Methods

Initializes computed values to zero.

C++
void initialize();
Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


isApplicable Method

isApplicable Method
OldStart Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of this function. The version with no arguments uses stored data, passing it to the static version with one argument.

Collapse Expand Overload List
Name | Description
OldStart::isApplicable () | Determines applicability of method using stored data.
OldStart::isApplicable (const PiaData&) | Determines applicability of method using passed data.
Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Methods


OldStart::isApplicable Method ()

OldStart::isApplicable Method ()
OldStart Class OldStart Members isApplicable Method

Determines applicability of method using stored data.

C++
bool isApplicable();
Collapse Expand Returns

True if method is applicable, false otherwise.

Collapse Expand Remarks

The version with no arguments calls the static version with 1 argument.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
OldStart Class, OldStart Members, isApplicable Method


OldStart::isApplicable Method (const PiaData&)

OldStart::isApplicable Method (const PiaData&)
OldStart Class OldStart Members isApplicable Method

Determines applicability of method using passed data.

C++
static bool isApplicable(
    const PiaData& piaData
);
Collapse Expand Parameters
Parameters | Description
const PiaData& piaData | Pia calculation data.
Collapse Expand Returns

True if method is applicable, false otherwise.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
OldStart Class, OldStart Members, isApplicable Method


OldStart::isOs1977_90 Method

OldStart::isOs1977_90 Method
OldStart Class OldStart Members OldStart Methods

Returns true if the old-start method is 1977 or 1990.

C++
bool isOs1977_90() const;
Collapse Expand Returns

True if the old-start method is 1977 or 1990.

Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::methodOsCal Method

OldStart::methodOsCal Method
OldStart Class OldStart Members OldStart Methods

Determines correct old-start method.

C++
OldStartType methodOsCal();
Collapse Expand Returns

Correct old-start method number.

Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::oldStart39Cal Method

OldStart::oldStart39Cal Method
OldStart Class OldStart Members OldStart Methods

Calculates 1939 old-start PIA and MFB.

C++
void oldStart39Cal();
Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::oldStart50Cal Method

OldStart::oldStart50Cal Method
OldStart Class OldStart Members OldStart Methods

Calculates 1950 old-start PIA and MFB.

C++
void oldStart50Cal();
Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::setAmeOs Method

OldStart::setAmeOs Method
OldStart Class OldStart Members OldStart Methods

Sets old-start AME.

C++
void setAmeOs(
    int newAmeOs
);
Collapse Expand Parameters
Parameters | Description
int newAmeOs | New old-start AME.
Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::setDivisorOs Method

OldStart::setDivisorOs Method
OldStart Class OldStart Members OldStart Methods

Sets divisor for old-start pre-1951 earnings.

C++
void setDivisorOs(
    int newDivisorOs
);
Collapse Expand Parameters
Parameters | Description
int newDivisorOs | New divisor for old-start pre-1951 earnings.
Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::setIncyrs Method

OldStart::setIncyrs Method
OldStart Class OldStart Members OldStart Methods

Sets number of old-start increment years.

C++
void setIncyrs(
    int newIncyrs
);
Collapse Expand Parameters
Parameters | Description
int newIncyrs | New number of old-start increment years.
Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::setMethodOs Method

OldStart::setMethodOs Method
OldStart Class OldStart Members OldStart Methods

Sets old-start calculation method number.

C++
void setMethodOs(
    OldStartType newMethodOs
);
Collapse Expand Parameters
Parameters | Description
OldStartType newMethodOs | New old-start calculation method number.
Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::setPib Method

OldStart::setPib Method
OldStart Class OldStart Members OldStart Methods

Sets old-start PIB before incrementing.

C++
void setPib(
    double newPib
);
Collapse Expand Parameters
Parameters | Description
double newPib | New PIB before incrementing.
Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStart::setPibInc Method

OldStart::setPibInc Method
OldStart Class OldStart Members OldStart Methods

Sets old-start PIB with increment years.

C++
void setPibInc();
Collapse Expand Group

OldStart Methods

Collapse Expand Links
OldStart Class, OldStart Members, OldStart Methods


OldStartLC Class

OldStartLC Class
OldStartLC Data Members OldStartLC Methods OldStartLC Members OldStartLC.h Classes

Manages the functions required for calculation of an old start Social Security benefit with law changes.

Collapse Expand Class Hierarchy
  OldStartLCOldStartLCOldStartLCOldStartLC
C++
class OldStartLC : public OldStart;
Collapse Expand File

File: OldStartLC.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaCalLC.

Collapse Expand Group

Classes

Collapse Expand Links
OldStartLC Data Members, OldStartLC Methods, OldStartLC Members, OldStartLC.h, Classes


OldStartLC Members

OldStartLC Members
Enumerations OldStartLC Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by OldStartLC.

Collapse Expand Enumerations
Name | Description
OldStartType | Old-start PIA calculation methods.
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

OldStartLC Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
entDate | The date of entitlement.
iamemax | Maximum ame in pia interval.
lawChange | Law change parameters.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
INC_PER_YEAR | Factor for amount of increment per year (0.01).
bendMfb | Bend points for MFB formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
percMfb | Wage-indexed MFB formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
portionAme | Portion of AME in each interval of PIB formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
OldStartLC | Initializes an old start instance with law changes.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Computes old start PIA.
calculate | Calculates pia and mfb for this method.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeOs | Returns old-start AME.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getDivisorOs | Returns divisor for old-start pre-1951 earnings.
getIncyrs | Returns number of old-start increment years.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getMethodOs | Returns old-start calculation method number.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getPib | Returns old-start PIB before incrementing.
getPibInc | Returns old-start PIB after incrementing.
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
imputeEarnings | Imputes yearly earnings prior to 1951.
incrementCal | Calculates number of increment years for old-start.
incrementOldCal | Calculates number of increment years for old old-start.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isApplicable | Determines applicability of method.
isOs1977_90 | Returns true if the old-start method is 1977 or 1990.
isPebsAssumptions | Returns old Statement assumptions indicator.
methodOsCal | Determines correct old-start method.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
oldStart39Cal | Calculates 1939 old-start PIA and MFB.
oldStart50Cal | Calculates 1950 old-start PIA and MFB.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeOs | Sets old-start AME.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setDivisorOs | Sets divisor for old-start pre-1951 earnings.
setIncyrs | Sets number of old-start increment years.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setMethodOs | Sets old-start calculation method number.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPib | Sets old-start PIB before incrementing.
setPibInc | Sets old-start PIB with increment years.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~OldStartLC | Destructor.
Collapse Expand Links
Enumerations, OldStartLC Class, Legend, Protected Data Members, Public Data Members, Public Methods


OldStartLC::OldStartLC Constructor

OldStartLC::OldStartLC Constructor
OldStartLC Class OldStartLC Members OldStartLC Class

Initializes an old start instance with law changes.

C++
OldStartLC(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear,
    const DateMoyr& newEntDate,
    const LawChangeArray& newLawChange
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum projection year.
const DateMoyr& newEntDate | The date of entitlement.
const LawChangeArray& newLawChange | Law-change parameters.
Collapse Expand Class

OldStartLC Class

Collapse Expand Links
OldStartLC Class, OldStartLC Members, OldStartLC Class


OldStartLC::~OldStartLC Destructor

OldStartLC::~OldStartLC Destructor
OldStartLC Class OldStartLC Members OldStartLC Class

Destructor.

C++
virtual ~OldStartLC();
Collapse Expand Class

OldStartLC Class

Collapse Expand Links
OldStartLC Class, OldStartLC Members, OldStartLC Class


OldStartLC Data Members

OldStartLC Data Members
OldStartLC Class Legend Protected Data Members

The data members of the OldStartLC class are listed here.

Collapse Expand Class

OldStartLC Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
lawChange | Law change parameters.
Collapse Expand Links
OldStartLC Class, Legend, Protected Data Members


OldStartLC::lawChange Data Member

OldStartLC::lawChange Data Member
OldStartLC Class OldStartLC Members OldStartLC Data Members

Law change parameters.

C++
const LawChangeArray& lawChange;
Collapse Expand Group

OldStartLC Data Members

Collapse Expand Links
OldStartLC Class, OldStartLC Members, OldStartLC Data Members


OldStartLC Methods

OldStartLC Methods
OldStartLC Class Legend Public Methods

The methods of the OldStartLC class are listed here.

Collapse Expand Class

OldStartLC Class

Collapse Expand Public Methods
Name | Description
isApplicable | Determines applicability of method.
Collapse Expand Links
OldStartLC Class, Legend, Public Methods


isApplicable Method

isApplicable Method
OldStartLC Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of this function. The version with no arguments uses stored data, passing it to the static version with three arguments.

Collapse Expand Overload List
Name | Description
OldStartLC::isApplicable () | Determines applicability of method using stored data.
OldStartLC::isApplicable (const DateMoyr&, const DateMoyr&, const PiaData&, const LawChangeArray&) | Determines applicability of method using passed data.
Collapse Expand Group

OldStartLC Methods

Collapse Expand Links
OldStartLC Methods


OldStartLC::isApplicable Method ()

OldStartLC::isApplicable Method ()
OldStartLC Class OldStartLC Members isApplicable Method

Determines applicability of method using stored data.

C++
bool isApplicable();
Collapse Expand Returns

True if method is applicable, false otherwise.

Collapse Expand Remarks

This version, with no arguments, calls the static version with 4 arguments.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
OldStartLC Class, OldStartLC Members, isApplicable Method


OldStartLC::isApplicable Method (const DateMoyr&, const DateMoyr&, const PiaData&, const LawChangeArray&)

OldStartLC::isApplicable Method (const DateMoyr&, const DateMoyr&, const PiaData&, const LawChangeArray&)
OldStartLC Class OldStartLC Members isApplicable Method

Determines applicability of method using passed data.

C++
static bool isApplicable(
    const DateMoyr& entDate,
    const DateMoyr& benefitDate,
    const PiaData& piaData,
    const LawChangeArray& lawChange
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | The date of entitlement.
const DateMoyr& benefitDate | The date of benefit.
const PiaData& piaData | Benefit calculation data.
const LawChangeArray& lawChange | Law change parameters.
Collapse Expand Returns

True if method is applicable, false otherwise.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
OldStartLC Class, OldStartLC Members, isApplicable Method


Pebs Class

Pebs Class
Pebs Enumerations Pebs Data Members Pebs Methods Pebs Members pebs.h Classes

Manages most of the data required to prepare and print out the results of a Statement calculation.

Collapse Expand Class Hierarchy
  Pebs
C++
class Pebs;
Collapse Expand File

File: pebs.h

Module: PiaData Library

Collapse Expand Remarks

Manages most of the data required to prepare and print out the results of a Statement calculation.

Collapse Expand Group

Classes

Collapse Expand Links
Pebs Enumerations, Pebs Data Members, Pebs Methods, Pebs Members, pebs.h, Classes


Pebs Members

Pebs Members
Enumerations Pebs Class Legend Public Data Members Public Methods

The following tables list the members exposed by Pebs.

Collapse Expand Enumerations
Name | Description
pebes_type | Type of Statement calculation.
Collapse Expand Class

Pebs Class

Collapse Expand Public Data Members
Name | Description
age70 | Age 70 and 0 months.
ageNow | Current age.
agePlan1 | Age of planned early retirement, after adjusting for current age and earliest possible age (62).
fullRetAge | Age for worker's full retirement.
oab1 | Age for full retirement calculation (could be between full retirement and 70).
oab2 | Age for late retirement calculation (could be 70 or later).
Collapse Expand Public Methods
Name | Description
Pebs | Initializes Pebs instance.
agePlanCheck | Checks planned age of retirement in Statement case.
deleteContents | Initializes all variables to default values.
getAgePlan | Returns planned age of retirement.
getAgePlan2 | Returns planned retirement age.
getBenefitPebs | Returns benefit actually payable in Statement calculation.
getMfbPebs | Returns maximum family benefit in Statement calculation.
getMonthnow | Returns month of processing.
getPebsDib | Returns number of dib computations to do.
getPebsOab | Returns number of oab computations to do.
getPiaPebs | Returns PIA in Statement calculation.
getQcDisReq | Returns quarters of coverage required for disability insured status for Statement calculation.
getQcDisTotal | Returns quarters of coverage earned for disability insured status for Statement calculation.
getQcDisYears | Returns number of years over which quarters of coverage must be earned for disability insured status for Statement calculation.
getQcReq | Returns required quarters of coverage in Statement calculation.
getQcTotal | Returns quarters of coverage earned through current year.
monthnowCheck | Checks for correct month of Statement processing.
setAgePlan | Sets planned age of retirement in Statement case.
setAgePlan2 | Sets planned retirement age.
setBenefitPebs | Sets benefit actually payable in Statement calculation.
setMfbPebs | Sets maximum family benefit in Statement calculation.
setMonthnow | Sets month of Statement processing.
setPebsDib | Sets number of dib computations to do.
setPebsOab | Sets number of oab computations to do.
setPiaPebs | Sets PIA in Statement calculation.
setQcDisReq | Sets number of DI quarters of coverage required.
setQcDisTotal | Sets number of DI quarters of coverage earned.
setQcDisYears | Sets number of years allowed to earn DI quarters of coverage.
setQcReq | Sets required quarters of coverage in Statement calculation.
setQcTotal | Sets number of quarters of coverage earned through current year.
Collapse Expand Links
Enumerations, Pebs Class, Legend, Public Data Members, Public Methods


Pebs::Pebs Constructor

Pebs::Pebs Constructor
Pebs Class Pebs Members Pebs Class

Initializes Pebs instance.

C++
Pebs();
Collapse Expand Remarks

Initializes size of arrays to Pebs::pebes_type::MAXPEBS and zeroes out all data.

Collapse Expand Class

Pebs Class

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Class


Pebs Enumerations

Pebs Enumerations
Enumerations Pebs Class Legend

The enumerations of the Pebs class are listed here.

Collapse Expand Enumerations
Name | Description
pebes_type | Type of Statement calculation.
Collapse Expand Class

Pebs Class

Collapse Expand Links
Enumerations, Pebs Class, Legend


Pebs::pebes_type Enumeration

Pebs::pebes_type Enumeration
pebs.h Pebs Enumerations

Type of Statement calculation.

C++
enum pebes_type {
  PEBS_OAB_DELAYED,
  PEBS_OAB_FULL,
  PEBS_OAB_EARLY,
  PEBS_SURV,
  PEBS_DISAB,
  MAXPEBS
};
Collapse Expand File

File: pebs.h

Module: PiaData Library

Collapse Expand Members
Members | Description
PEBS_OAB_DELAYED | Delayed retirement.
PEBS_OAB_FULL | Full retirement age.
PEBS_OAB_EARLY | Early retirement.
PEBS_SURV | Survivor benefit.
PEBS_DISAB | Disability benefit.
MAXPEBS | Number of Statement calculations.
Collapse Expand Group

Pebs Enumerations

Collapse Expand Links
pebs.h, Pebs Enumerations


Pebs Data Members

Pebs Data Members
Pebs Class Legend Public Data Members

The data members of the Pebs class are listed here.

Collapse Expand Class

Pebs Class

Collapse Expand Public Data Members
Name | Description
age70 | Age 70 and 0 months.
ageNow | Current age.
agePlan1 | Age of planned early retirement, after adjusting for current age and earliest possible age (62).
fullRetAge | Age for worker's full retirement.
oab1 | Age for full retirement calculation (could be between full retirement and 70).
oab2 | Age for late retirement calculation (could be 70 or later).
Collapse Expand Links
Pebs Class, Legend, Public Data Members


Pebs::age70 Data Member

Pebs::age70 Data Member
Pebs Class Pebs Members Pebs Data Members

Age 70 and 0 months.

C++
const Age age70;
Collapse Expand Group

Pebs Data Members

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Data Members


Pebs::ageNow Data Member

Pebs::ageNow Data Member
Pebs Class Pebs Members Pebs Data Members

Current age.

C++
Age ageNow;
Collapse Expand Group

Pebs Data Members

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Data Members


Pebs::agePlan1 Data Member

Pebs::agePlan1 Data Member
Pebs Class Pebs Members Pebs Data Members

Age of planned early retirement, after adjusting for current age and earliest possible age (62).

C++
Age agePlan1;
Collapse Expand Group

Pebs Data Members

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Data Members


Pebs::fullRetAge Data Member

Pebs::fullRetAge Data Member
Pebs Class Pebs Members Pebs Data Members

Age for worker's full retirement.

C++
Age fullRetAge;
Collapse Expand Group

Pebs Data Members

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Data Members


Pebs::oab1 Data Member

Pebs::oab1 Data Member
Pebs Class Pebs Members Pebs Data Members

Age for full retirement calculation (could be between full retirement and 70).

C++
Age oab1;
Collapse Expand Group

Pebs Data Members

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Data Members


Pebs::oab2 Data Member

Pebs::oab2 Data Member
Pebs Class Pebs Members Pebs Data Members

Age for late retirement calculation (could be 70 or later).

C++
Age oab2;
Collapse Expand Group

Pebs Data Members

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Data Members


Pebs Methods

Pebs Methods
Pebs Class Legend Public Methods

The methods of the Pebs class are listed here.

Collapse Expand Class

Pebs Class

Collapse Expand Public Methods
Name | Description
agePlanCheck | Checks planned age of retirement in Statement case.
deleteContents | Initializes all variables to default values.
getAgePlan | Returns planned age of retirement.
getAgePlan2 | Returns planned retirement age.
getBenefitPebs | Returns benefit actually payable in Statement calculation.
getMfbPebs | Returns maximum family benefit in Statement calculation.
getMonthnow | Returns month of processing.
getPebsDib | Returns number of dib computations to do.
getPebsOab | Returns number of oab computations to do.
getPiaPebs | Returns PIA in Statement calculation.
getQcDisReq | Returns quarters of coverage required for disability insured status for Statement calculation.
getQcDisTotal | Returns quarters of coverage earned for disability insured status for Statement calculation.
getQcDisYears | Returns number of years over which quarters of coverage must be earned for disability insured status for Statement calculation.
getQcReq | Returns required quarters of coverage in Statement calculation.
getQcTotal | Returns quarters of coverage earned through current year.
monthnowCheck | Checks for correct month of Statement processing.
setAgePlan | Sets planned age of retirement in Statement case.
setAgePlan2 | Sets planned retirement age.
setBenefitPebs | Sets benefit actually payable in Statement calculation.
setMfbPebs | Sets maximum family benefit in Statement calculation.
setMonthnow | Sets month of Statement processing.
setPebsDib | Sets number of dib computations to do.
setPebsOab | Sets number of oab computations to do.
setPiaPebs | Sets PIA in Statement calculation.
setQcDisReq | Sets number of DI quarters of coverage required.
setQcDisTotal | Sets number of DI quarters of coverage earned.
setQcDisYears | Sets number of years allowed to earn DI quarters of coverage.
setQcReq | Sets required quarters of coverage in Statement calculation.
setQcTotal | Sets number of quarters of coverage earned through current year.
Collapse Expand Links
Pebs Class, Legend, Public Methods


Pebs::agePlanCheck Method

Pebs::agePlanCheck Method
Pebs Class Pebs Members Pebs Methods

Checks planned age of retirement in Statement case.

C++
static void agePlanCheck(
    int agePlant
);
Collapse Expand Parameters
Parameters | Description
int agePlant | The age to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_AGEPLAN if planned age of retirement is out of range.
Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::deleteContents Method

Pebs::deleteContents Method
Pebs Class Pebs Members Pebs Methods

Initializes all variables to default values.

C++
void deleteContents();
Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::getAgePlan Method

Pebs::getAgePlan Method
Pebs Class Pebs Members Pebs Methods

Returns planned age of retirement.

C++
int getAgePlan() const;
Collapse Expand Returns

Planned age of retirement.

Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::getAgePlan2 Method

Pebs::getAgePlan2 Method
Pebs Class Pebs Members Pebs Methods

Returns planned retirement age.

C++
int getAgePlan2() const;
Collapse Expand Returns

Planned retirement age.

Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::getBenefitPebs Method

Pebs::getBenefitPebs Method
Pebs Class Pebs Members Pebs Methods

Returns benefit actually payable in Statement calculation.

C++
int getBenefitPebs(
    pebes_type type
) const;
Collapse Expand Parameters
Parameters | Description
pebes_type type | Type of calculation (0-4).
Collapse Expand Returns

Benefit actually payable in Statement calculation.

Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::getMfbPebs Method

Pebs::getMfbPebs Method
Pebs Class Pebs Members Pebs Methods

Returns maximum family benefit in Statement calculation.

C++
int getMfbPebs(
    pebes_type type
) const;
Collapse Expand Parameters
Parameters | Description
pebes_type type | Type of calculation (0-4).
Collapse Expand Returns

Maximum family benefit in Statement calculation.

Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::getMonthnow Method

Pebs::getMonthnow Method
Pebs Class Pebs Members Pebs Methods

Returns month of processing.

C++
int getMonthnow() const;
Collapse Expand Returns

Month of processing.

Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::getPebsDib Method

Pebs::getPebsDib Method
Pebs Class Pebs Members Pebs Methods

Returns number of dib computations to do.

C++
int getPebsDib() const;
Collapse Expand Returns

Number of dib computations to do.

Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::getPebsOab Method

Pebs::getPebsOab Method
Pebs Class Pebs Members Pebs Methods

Returns number of oab computations to do.

C++
int getPebsOab() const;
Collapse Expand Returns

Number of oab computations to do.

Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::getPiaPebs Method

Pebs::getPiaPebs Method
Pebs Class Pebs Members Pebs Methods

Returns PIA in Statement calculation.

C++
int getPiaPebs(
    pebes_type type
) const;
Collapse Expand Parameters
Parameters | Description
pebes_type type | Type of calculation (0-4).
Collapse Expand Returns

PIA in Statement calculation.

Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::getQcDisReq Method

Pebs::getQcDisReq Method
Pebs Class Pebs Members Pebs Methods

Returns quarters of coverage required for disability insured status for Statement calculation.

C++
int getQcDisReq() const;
Collapse Expand Returns

Quarters of coverage required for disability insured status for Statement calculation.

Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::getQcDisTotal Method

Pebs::getQcDisTotal Method
Pebs Class Pebs Members Pebs Methods

Returns quarters of coverage earned for disability insured status for Statement calculation.

C++
int getQcDisTotal() const;
Collapse Expand Returns

Quarters of coverage earned for disability insured status for Statement calculation.

Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::getQcDisYears Method

Pebs::getQcDisYears Method
Pebs Class Pebs Members Pebs Methods

Returns number of years over which quarters of coverage must be earned for disability insured status for Statement calculation.

C++
int getQcDisYears() const;
Collapse Expand Returns

Number of years over which quarters of coverage must be earned for disability insured status for Statement calculation.

Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::getQcReq Method

Pebs::getQcReq Method
Pebs Class Pebs Members Pebs Methods

Returns required quarters of coverage in Statement calculation.

C++
int getQcReq(
    pebes_type type
) const;
Collapse Expand Parameters
Parameters | Description
pebes_type type | Type of calculation (0-4).
Collapse Expand Returns

Required quarters of coverage in Statement calculation.

Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::getQcTotal Method

Pebs::getQcTotal Method
Pebs Class Pebs Members Pebs Methods

Returns quarters of coverage earned through current year.

C++
int getQcTotal() const;
Collapse Expand Returns

Quarters of coverage earned through current year.

Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


monthnowCheck Method

monthnowCheck Method
Pebs Methods

Checks for correct month of Statement processing.

Collapse Expand Description

There are two versions of the monthnowCheck function. The version with no arguments checks the stored month of processing. The version with one argument checks the value of that argument.

Collapse Expand Overload List
Name | Description
Pebs::monthnowCheck () | Checks for correct month of Statement processing, using the stored month of processing.
Pebs::monthnowCheck (int) | Checks for correct month of Statement processing, using a specified month of processing.
Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Methods


Pebs::monthnowCheck Method ()

Pebs::monthnowCheck Method ()
Pebs Class Pebs Members monthnowCheck Method

Checks for correct month of Statement processing, using the stored month of processing.

C++
void monthnowCheck() const;
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PEBESMONTH if month is out of range.
Collapse Expand Group

monthnowCheck Method

Collapse Expand Links
Pebs Class, Pebs Members, monthnowCheck Method


Pebs::monthnowCheck Method (int)

Pebs::monthnowCheck Method (int)
Pebs Class Pebs Members monthnowCheck Method

Checks for correct month of Statement processing, using a specified month of processing.

C++
static void monthnowCheck(
    int monthnowt
);
Collapse Expand Parameters
Parameters | Description
int monthnowt | Month to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PEBESMONTH if month is out of range.
Collapse Expand Group

monthnowCheck Method

Collapse Expand Links
Pebs Class, Pebs Members, monthnowCheck Method


Pebs::setAgePlan Method

Pebs::setAgePlan Method
Pebs Class Pebs Members Pebs Methods

Sets planned age of retirement in Statement case.

C++
void setAgePlan(
    int newAgePlan
);
Collapse Expand Parameters
Parameters | Description
int newAgePlan | New planned age of retirement.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_AGEPLAN if planned age of retirement is out of range (debug mode only).
Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::setAgePlan2 Method

Pebs::setAgePlan2 Method
Pebs Class Pebs Members Pebs Methods

Sets planned retirement age.

C++
void setAgePlan2(
    int newAgePlan2
);
Collapse Expand Parameters
Parameters | Description
int newAgePlan2 | New planned retirement age.
Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::setBenefitPebs Method

Pebs::setBenefitPebs Method
Pebs Class Pebs Members Pebs Methods

Sets benefit actually payable in Statement calculation.

C++
void setBenefitPebs(
    pebes_type type,
    int newBenefit
);
Collapse Expand Parameters
Parameters | Description
pebes_type type | Type of calculation (0-4).
int newBenefit | New benefit.
Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::setMfbPebs Method

Pebs::setMfbPebs Method
Pebs Class Pebs Members Pebs Methods

Sets maximum family benefit in Statement calculation.

C++
void setMfbPebs(
    pebes_type type,
    int newMfb
);
Collapse Expand Parameters
Parameters | Description
pebes_type type | Type of calculation (0-4).
int newMfb | New maximum family benefit.
Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


setMonthnow Method

setMonthnow Method
Pebs Methods

Sets month of Statement processing.

Collapse Expand Description

There are two versions of the setMonthnow function. The month of Statement processing can be set to a specified month. If the month is not specified, it is set to the current month.

Collapse Expand Overload List
Name | Description
Pebs::setMonthnow () | Sets month of Statement processing with the current month.
Pebs::setMonthnow (int) | Sets month of Statement processing with a specified month.
Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Methods


Pebs::setMonthnow Method ()

Pebs::setMonthnow Method ()
Pebs Class Pebs Members setMonthnow Method

Sets month of Statement processing with the current month.

C++
void setMonthnow();
Collapse Expand Group

setMonthnow Method

Collapse Expand Links
Pebs Class, Pebs Members, setMonthnow Method


Pebs::setMonthnow Method (int)

Pebs::setMonthnow Method (int)
Pebs Class Pebs Members setMonthnow Method

Sets month of Statement processing with a specified month.

C++
void setMonthnow(
    int newMonthnow
);
Collapse Expand Parameters
Parameters | Description
int newMonthnow | New month of processing.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PEBESMONTH if month is out of range (only in debug mode).
Collapse Expand Group

setMonthnow Method

Collapse Expand Links
Pebs Class, Pebs Members, setMonthnow Method


Pebs::setPebsDib Method

Pebs::setPebsDib Method
Pebs Class Pebs Members Pebs Methods

Sets number of dib computations to do.

C++
void setPebsDib(
    int newPebsDib
);
Collapse Expand Parameters
Parameters | Description
int newPebsDib | New number of dib computations.
Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::setPebsOab Method

Pebs::setPebsOab Method
Pebs Class Pebs Members Pebs Methods

Sets number of oab computations to do.

C++
void setPebsOab(
    int newPebsOab
);
Collapse Expand Parameters
Parameters | Description
int newPebsOab | New number of oab computations.
Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::setPiaPebs Method

Pebs::setPiaPebs Method
Pebs Class Pebs Members Pebs Methods

Sets PIA in Statement calculation.

C++
void setPiaPebs(
    pebes_type type,
    int newPia
);
Collapse Expand Parameters
Parameters | Description
pebes_type type | Type of calculation (0-4).
int newPia | New PIA.
Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::setQcDisReq Method

Pebs::setQcDisReq Method
Pebs Class Pebs Members Pebs Methods

Sets number of DI quarters of coverage required.

C++
void setQcDisReq(
    int newQcDisReq
);
Collapse Expand Parameters
Parameters | Description
int newQcDisReq | New value for number of DI quarters of coverage required.
Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::setQcDisTotal Method

Pebs::setQcDisTotal Method
Pebs Class Pebs Members Pebs Methods

Sets number of DI quarters of coverage earned.

C++
void setQcDisTotal(
    int newQcDisTotal
);
Collapse Expand Parameters
Parameters | Description
int newQcDisTotal | New value for number of DI quarters of coverage earned.
Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::setQcDisYears Method

Pebs::setQcDisYears Method
Pebs Class Pebs Members Pebs Methods

Sets number of years allowed to earn DI quarters of coverage.

C++
void setQcDisYears(
    int newQcDisYears
);
Collapse Expand Parameters
Parameters | Description
int newQcDisYears | New value for years allowed to earn DI quarters of coverage.
Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::setQcReq Method

Pebs::setQcReq Method
Pebs Class Pebs Members Pebs Methods

Sets required quarters of coverage in Statement calculation.

C++
void setQcReq(
    pebes_type type,
    int newQcReq
);
Collapse Expand Parameters
Parameters | Description
pebes_type type | Type of calculation (0-4).
int newQcReq | New required quarters of coverage.
Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


Pebs::setQcTotal Method

Pebs::setQcTotal Method
Pebs Class Pebs Members Pebs Methods

Sets number of quarters of coverage earned through current year.

C++
void setQcTotal(
    int newQcTotal
);
Collapse Expand Parameters
Parameters | Description
int newQcTotal | New number of quarters of coverage.
Collapse Expand Group

Pebs Methods

Collapse Expand Links
Pebs Class, Pebs Members, Pebs Methods


PercMfb Class

PercMfb Class
PercMfb Data Members PercMfb Methods PercMfb Operators PercMfb Nested Types PercMfb Members percmfb.h Classes

Manages the array of percentages used in the MFB formula.

Collapse Expand Class Hierarchy
  PercMfb
C++
class PercMfb;
Collapse Expand File

File: percmfb.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is a member of most PiaMethod classes.

Collapse Expand Group

Classes

Collapse Expand Links
PercMfb Data Members, PercMfb Methods, PercMfb Operators, PercMfb Nested Types, PercMfb Members, percmfb.h, Classes


PercMfb Members

PercMfb Members
PercMfb Class Legend Public Data Members Public Methods Public Nested Types

The following tables list the members exposed by PercMfb.

Collapse Expand Class

PercMfb Class

Collapse Expand Public Data Members
Name | Description
PERC | Four percentages.
Collapse Expand Public Methods
Name | Description
PercMfb | Initializes size of array and all values.
as_array | Returns percentages as a simple array.
begin | This is the overview for the begin method overload.
end | This is the overview for the end method overload.
max_size | Returns maximum number of percentages.
reset | Resets percentages to original values.
size | Returns number of percentages.
~PercMfb | Destroys percentages array.
Collapse Expand Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of size in this array.
value_type | The type of data in this array.
Collapse Expand Public Operators
Name | Description
[] | This is the overview for the [] operator overload.
Collapse Expand Links
PercMfb Class, Legend, Public Data Members, Public Methods, Public Nested Types


PercMfb::PercMfb Constructor

PercMfb::PercMfb Constructor
PercMfb Class PercMfb Members PercMfb Class

Initializes size of array and all values.

C++
PercMfb();
Collapse Expand Remarks

It does that by calling the reset function.

Collapse Expand Class

PercMfb Class

Collapse Expand Links
PercMfb Class, PercMfb Members, PercMfb Class


PercMfb::~PercMfb Destructor

PercMfb::~PercMfb Destructor
PercMfb Class PercMfb Members PercMfb Class

Destroys percentages array.

C++
~PercMfb();
Collapse Expand Class

PercMfb Class

Collapse Expand Links
PercMfb Class, PercMfb Members, PercMfb Class


PercMfb Data Members

PercMfb Data Members
PercMfb Class Legend Public Data Members

The data members of the PercMfb class are listed here.

Collapse Expand Class

PercMfb Class

Collapse Expand Public Data Members
Name | Description
PERC | Four percentages.
Collapse Expand Links
PercMfb Class, Legend, Public Data Members


PercMfb::PERC Data Member

PercMfb::PERC Data Member
PercMfb Class PercMfb Members PercMfb Data Members

Four percentages.

C++
const double PERC[MAXPERC];
Collapse Expand Group

PercMfb Data Members

Collapse Expand Links
PercMfb Class, PercMfb Members, PercMfb Data Members


PercMfb Methods

PercMfb Methods
PercMfb Class Legend Public Methods

The methods of the PercMfb class are listed here.

Collapse Expand Class

PercMfb Class

Collapse Expand Public Methods
Name | Description
as_array | Returns percentages as a simple array.
begin | This is the overview for the begin method overload.
end | This is the overview for the end method overload.
max_size | Returns maximum number of percentages.
reset | Resets percentages to original values.
size | Returns number of percentages.
Collapse Expand Links
PercMfb Class, Legend, Public Methods


PercMfb::as_array Method

PercMfb::as_array Method
PercMfb Class PercMfb Members PercMfb Methods

Returns percentages as a simple array.

C++
double* as_array();
Collapse Expand Returns

Percentages as a simple array.

Collapse Expand Group

PercMfb Methods

Collapse Expand Links
PercMfb Class, PercMfb Members, PercMfb Methods


begin Method

begin Method
PercMfb Methods

This is the overview for the begin method overload.

Collapse Expand Overload List
Name | Description
PercMfb::begin () | Returns beginning of array, non-const version.
PercMfb::begin () | Returns beginning of array, const version.
Collapse Expand Group

PercMfb Methods

Collapse Expand Links
PercMfb Methods


PercMfb::begin Method ()

PercMfb::begin Method ()
PercMfb Class PercMfb Members begin Method

Returns beginning of array, non-const version.

C++
iterator begin();
Collapse Expand Returns

Beginning of array.

Collapse Expand Group

begin Method

Collapse Expand Links
PercMfb Class, PercMfb Members, begin Method


PercMfb::begin Method ()

PercMfb::begin Method ()
PercMfb Class PercMfb Members begin Method

Returns beginning of array, const version.

C++
const_iterator begin() const;
Collapse Expand Returns

Beginning of array.

Collapse Expand Group

begin Method

Collapse Expand Links
PercMfb Class, PercMfb Members, begin Method


end Method

end Method
PercMfb Methods

This is the overview for the end method overload.

Collapse Expand Overload List
Name | Description
PercMfb::end () | Returns one past end of array, non-const version.
PercMfb::end () | Returns one past end of array, const version.
Collapse Expand Group

PercMfb Methods

Collapse Expand Links
PercMfb Methods


PercMfb::end Method ()

PercMfb::end Method ()
PercMfb Class PercMfb Members end Method

Returns one past end of array, non-const version.

C++
iterator end();
Collapse Expand Returns

One past end of array.

Collapse Expand Group

end Method

Collapse Expand Links
PercMfb Class, PercMfb Members, end Method


PercMfb::end Method ()

PercMfb::end Method ()
PercMfb Class PercMfb Members end Method

Returns one past end of array, const version.

C++
const_iterator end() const;
Collapse Expand Returns

One past end of array.

Collapse Expand Group

end Method

Collapse Expand Links
PercMfb Class, PercMfb Members, end Method


PercMfb::max_size Method

PercMfb::max_size Method
PercMfb Class PercMfb Members PercMfb Methods

Returns maximum number of percentages.

C++
size_type max_size() const;
Collapse Expand Returns

Number of percentages.

Collapse Expand Group

PercMfb Methods

Collapse Expand Links
PercMfb Class, PercMfb Members, PercMfb Methods


PercMfb::reset Method

PercMfb::reset Method
PercMfb Class PercMfb Members PercMfb Methods

Resets percentages to original values.

C++
void reset();
Collapse Expand Group

PercMfb Methods

Collapse Expand Links
PercMfb Class, PercMfb Members, PercMfb Methods


PercMfb::size Method

PercMfb::size Method
PercMfb Class PercMfb Members PercMfb Methods

Returns number of percentages.

C++
size_type size() const;
Collapse Expand Returns

Number of percentages.

Collapse Expand Group

PercMfb Methods

Collapse Expand Links
PercMfb Class, PercMfb Members, PercMfb Methods


PercMfb Operators

PercMfb Operators
PercMfb Class Legend

The operators of the PercMfb class are listed here.

Collapse Expand Class

PercMfb Class

Collapse Expand Public Operators
Name | Description
[] | This is the overview for the [] operator overload.
Collapse Expand Links
PercMfb Class, Legend


[] Operator

[] Operator
PercMfb Operators

This is the overview for the [] operator overload.

Collapse Expand Overload List
Name | Description
PercMfb::[] (std::size_t) | Returns an mfb formula percentage, non-const version.
PercMfb::[] (std::size_t) | Returns an mfb formula percentage, const version.
Collapse Expand Group

PercMfb Operators

Collapse Expand Links
PercMfb Operators


PercMfb::[] Operator (std::size_t)

PercMfb::[] Operator (std::size_t)
PercMfb Class PercMfb Members [] Operator

Returns an mfb formula percentage, non-const version.

C++
reference operator [](
    std::size_t index
);
Collapse Expand Parameters
Parameters | Description
std::size_t index | Index of percentage desired (0-3).
Collapse Expand Returns

An mfb formula percentage.

Collapse Expand Group

[] Operator

Collapse Expand Links
PercMfb Class, PercMfb Members, [] Operator


PercMfb::[] Operator (std::size_t)

PercMfb::[] Operator (std::size_t)
PercMfb Class PercMfb Members [] Operator

Returns an mfb formula percentage, const version.

C++
const_reference operator [](
    std::size_t index
) const;
Collapse Expand Parameters
Parameters | Description
std::size_t index | Index of percentage desired (0-3).
Collapse Expand Returns

An mfb formula percentage.

Collapse Expand Group

[] Operator

Collapse Expand Links
PercMfb Class, PercMfb Members, [] Operator


PercMfb Nested Types

PercMfb Nested Types
PercMfb Class Public Nested Types

The nested types of the PercMfb class are listed here.

Collapse Expand Class

PercMfb Class

Collapse Expand Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of size in this array.
value_type | The type of data in this array.
Collapse Expand Links
PercMfb Class, Public Nested Types


PercMfb::const_iterator Nested Type

PercMfb::const_iterator Nested Type
PercMfb Class PercMfb Members PercMfb Nested Types

A const iterator for this array.

C++
typedef const double* const_iterator;
Collapse Expand Group

PercMfb Nested Types

Collapse Expand Links
PercMfb Class, PercMfb Members, PercMfb Nested Types


PercMfb::const_reference Nested Type

PercMfb::const_reference Nested Type
PercMfb Class PercMfb Members PercMfb Nested Types

A const reference for this array.

C++
typedef const double& const_reference;
Collapse Expand Group

PercMfb Nested Types

Collapse Expand Links
PercMfb Class, PercMfb Members, PercMfb Nested Types


PercMfb::difference_type Nested Type

PercMfb::difference_type Nested Type
PercMfb Class PercMfb Members PercMfb Nested Types

The type of difference in this array.

C++
typedef std::ptrdiff_t difference_type;
Collapse Expand Group

PercMfb Nested Types

Collapse Expand Links
PercMfb Class, PercMfb Members, PercMfb Nested Types


PercMfb::iterator Nested Type

PercMfb::iterator Nested Type
PercMfb Class PercMfb Members PercMfb Nested Types

An iterator for this array.

C++
typedef double* iterator;
Collapse Expand Group

PercMfb Nested Types

Collapse Expand Links
PercMfb Class, PercMfb Members, PercMfb Nested Types


PercMfb::reference Nested Type

PercMfb::reference Nested Type
PercMfb Class PercMfb Members PercMfb Nested Types

A reference for this array.

C++
typedef double& reference;
Collapse Expand Group

PercMfb Nested Types

Collapse Expand Links
PercMfb Class, PercMfb Members, PercMfb Nested Types


PercMfb::size_type Nested Type

PercMfb::size_type Nested Type
PercMfb Class PercMfb Members PercMfb Nested Types

The type of size in this array.

C++
typedef std::size_t size_type;
Collapse Expand Group

PercMfb Nested Types

Collapse Expand Links
PercMfb Class, PercMfb Members, PercMfb Nested Types


PercMfb::value_type Nested Type

PercMfb::value_type Nested Type
PercMfb Class PercMfb Members PercMfb Nested Types

The type of data in this array.

C++
typedef double value_type;
Collapse Expand Group

PercMfb Nested Types

Collapse Expand Links
PercMfb Class, PercMfb Members, PercMfb Nested Types


PercPia Class

PercPia Class
PercPia Data Members PercPia Methods PercPia Operators PercPia Nested Types PercPia Members percpia.h Classes

Manages the array of percentages used in the PIA formula.

Collapse Expand Class Hierarchy
  PercPia
C++
class PercPia;
Collapse Expand File

File: percpia.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is a member of the WageIndGeneral class.

Collapse Expand Group

Classes

Collapse Expand Links
PercPia Data Members, PercPia Methods, PercPia Operators, PercPia Nested Types, PercPia Members, percpia.h, Classes


PercPia Members

PercPia Members
PercPia Class Legend Public Data Members Public Methods Public Nested Types

The following tables list the members exposed by PercPia.

Collapse Expand Class

PercPia Class

Collapse Expand Public Data Members
Name | Description
PERC | The three percentages for the regular benefit formula.
WINDFALL_PERC | The first percentage under the windfall elimination provision.
WINDFALL_YEARS | Number of years of coverage that negates the windfall elimination provision.
Collapse Expand Public Methods
Name | Description
PercPia | Initializes size of array and all values.
as_array | Returns percentages as a simple array.
begin | This is the overview for the begin method overload.
end | This is the overview for the end method overload.
getNumPerc | Returns the number of percentages.
max_size | Returns maximum number of percentages.
reset | Resets percentages to original 1977 amendments values.
setNumPerc | Sets number of percentages.
setWindfallPerc | Sets first PIA formula percentage for windfall elimination provision.
size | Returns number of percentages.
~PercPia | Destroys percentages array
Collapse Expand Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of size in this array.
value_type | The type of data in this array.
Collapse Expand Public Operators
Name | Description
[] | This is the overview for the [] operator overload.
Collapse Expand Links
PercPia Class, Legend, Public Data Members, Public Methods, Public Nested Types


PercPia::PercPia Constructor

PercPia::PercPia Constructor
PercPia Class PercPia Members PercPia Class

Initializes size of array and all values.

C++
PercPia();
Collapse Expand Remarks

It does that by calling the reset function.

Collapse Expand Class

PercPia Class

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Class


PercPia::~PercPia Destructor

PercPia::~PercPia Destructor
PercPia Class PercPia Members PercPia Class

Destroys percentages array

C++
~PercPia();
Collapse Expand Class

PercPia Class

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Class


PercPia Data Members

PercPia Data Members
PercPia Class Legend Public Data Members

The data members of the PercPia class are listed here.

Collapse Expand Class

PercPia Class

Collapse Expand Public Data Members
Name | Description
PERC | The three percentages for the regular benefit formula.
WINDFALL_PERC | The first percentage under the windfall elimination provision.
WINDFALL_YEARS | Number of years of coverage that negates the windfall elimination provision.
Collapse Expand Links
PercPia Class, Legend, Public Data Members


PercPia::PERC Data Member

PercPia::PERC Data Member
PercPia Class PercPia Members PercPia Data Members

The three percentages for the regular benefit formula.

C++
const double PERC[BASEPERC];
Collapse Expand Group

PercPia Data Members

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Data Members


PercPia::WINDFALL_PERC Data Member

PercPia::WINDFALL_PERC Data Member
PercPia Class PercPia Members PercPia Data Members

The first percentage under the windfall elimination provision.

C++
const double WINDFALL_PERC;
Collapse Expand Group

PercPia Data Members

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Data Members


PercPia::WINDFALL_YEARS Data Member

PercPia::WINDFALL_YEARS Data Member
PercPia Class PercPia Members PercPia Data Members

Number of years of coverage that negates the windfall elimination provision.

C++
const int WINDFALL_YEARS = 30;
Collapse Expand Group

PercPia Data Members

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Data Members


PercPia Methods

PercPia Methods
PercPia Class Legend Public Methods

The methods of the PercPia class are listed here.

Collapse Expand Class

PercPia Class

Collapse Expand Public Methods
Name | Description
as_array | Returns percentages as a simple array.
begin | This is the overview for the begin method overload.
end | This is the overview for the end method overload.
getNumPerc | Returns the number of percentages.
max_size | Returns maximum number of percentages.
reset | Resets percentages to original 1977 amendments values.
setNumPerc | Sets number of percentages.
setWindfallPerc | Sets first PIA formula percentage for windfall elimination provision.
size | Returns number of percentages.
Collapse Expand Links
PercPia Class, Legend, Public Methods


PercPia::as_array Method

PercPia::as_array Method
PercPia Class PercPia Members PercPia Methods

Returns percentages as a simple array.

C++
double* as_array();
Collapse Expand Returns

Percentages as a simple array.

Collapse Expand Group

PercPia Methods

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Methods


begin Method

begin Method
PercPia Methods

This is the overview for the begin method overload.

Collapse Expand Overload List
Name | Description
PercPia::begin () | Returns beginning of array, non-const version.
PercPia::begin () | Returns beginning of array, const version.
Collapse Expand Group

PercPia Methods

Collapse Expand Links
PercPia Methods


PercPia::begin Method ()

PercPia::begin Method ()
PercPia Class PercPia Members begin Method

Returns beginning of array, non-const version.

C++
iterator begin();
Collapse Expand Returns

Beginning of array.

Collapse Expand Group

begin Method

Collapse Expand Links
PercPia Class, PercPia Members, begin Method


PercPia::begin Method ()

PercPia::begin Method ()
PercPia Class PercPia Members begin Method

Returns beginning of array, const version.

C++
const_iterator begin() const;
Collapse Expand Returns

Beginning of array.

Collapse Expand Group

begin Method

Collapse Expand Links
PercPia Class, PercPia Members, begin Method


end Method

end Method
PercPia Methods

This is the overview for the end method overload.

Collapse Expand Overload List
Name | Description
PercPia::end () | Returns one past end of array, non-const version.
PercPia::end () | Returns one past end of array, const version.
Collapse Expand Group

PercPia Methods

Collapse Expand Links
PercPia Methods


PercPia::end Method ()

PercPia::end Method ()
PercPia Class PercPia Members end Method

Returns one past end of array, non-const version.

C++
iterator end();
Collapse Expand Returns

One past end of array.

Collapse Expand Group

end Method

Collapse Expand Links
PercPia Class, PercPia Members, end Method


PercPia::end Method ()

PercPia::end Method ()
PercPia Class PercPia Members end Method

Returns one past end of array, const version.

C++
const_iterator end() const;
Collapse Expand Returns

One past end of array.

Collapse Expand Group

end Method

Collapse Expand Links
PercPia Class, PercPia Members, end Method


PercPia::getNumPerc Method

PercPia::getNumPerc Method
PercPia Class PercPia Members PercPia Methods

Returns the number of percentages.

C++
size_type getNumPerc() const;
Collapse Expand Returns

Number of percentages.

Collapse Expand Group

PercPia Methods

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Methods


PercPia::max_size Method

PercPia::max_size Method
PercPia Class PercPia Members PercPia Methods

Returns maximum number of percentages.

C++
size_type max_size() const;
Collapse Expand Returns

Number of percentages.

Collapse Expand Group

PercPia Methods

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Methods


PercPia::reset Method

PercPia::reset Method
PercPia Class PercPia Members PercPia Methods

Resets percentages to original 1977 amendments values.

C++
void reset();
Collapse Expand Group

PercPia Methods

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Methods


PercPia::setNumPerc Method

PercPia::setNumPerc Method
PercPia Class PercPia Members PercPia Methods

Sets number of percentages.

C++
void setNumPerc(
    int newNumPerc
);
Collapse Expand Parameters
Parameters | Description
int newNumPerc | New number of percentages in formula.
Collapse Expand Remarks

Zeroes out all values in formula, so these have to be set after calling.

Collapse Expand Group

PercPia Methods

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Methods


PercPia::setWindfallPerc Method

PercPia::setWindfallPerc Method
PercPia Class PercPia Members PercPia Methods

Sets first PIA formula percentage for windfall elimination provision.

C++
void setWindfallPerc(
    int eligYear,
    int benefitDate,
    int specMinTot
);
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
int benefitDate | Year of benefit.
int specMinTot | Years of coverage.
Collapse Expand Group

PercPia Methods

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Methods


PercPia::size Method

PercPia::size Method
PercPia Class PercPia Members PercPia Methods

Returns number of percentages.

C++
size_type size() const;
Collapse Expand Returns

Number of percentages.

Collapse Expand Group

PercPia Methods

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Methods


PercPia Operators

PercPia Operators
PercPia Class Legend

The operators of the PercPia class are listed here.

Collapse Expand Class

PercPia Class

Collapse Expand Public Operators
Name | Description
[] | This is the overview for the [] operator overload.
Collapse Expand Links
PercPia Class, Legend


[] Operator

[] Operator
PercPia Operators

This is the overview for the [] operator overload.

Collapse Expand Overload List
Name | Description
PercPia::[] (std::size_t) | Returns a pia formula percentage, non-const version.
PercPia::[] (std::size_t) | Returns a pia formula percentage, const version.
Collapse Expand Group

PercPia Operators

Collapse Expand Links
PercPia Operators


PercPia::[] Operator (std::size_t)

PercPia::[] Operator (std::size_t)
PercPia Class PercPia Members [] Operator

Returns a pia formula percentage, non-const version.

C++
reference operator [](
    std::size_t index
);
Collapse Expand Parameters
Parameters | Description
std::size_t index | Index of percentage desired (0-2).
Collapse Expand Returns

A pia formula percentage.

Collapse Expand Group

[] Operator

Collapse Expand Links
PercPia Class, PercPia Members, [] Operator


PercPia::[] Operator (std::size_t)

PercPia::[] Operator (std::size_t)
PercPia Class PercPia Members [] Operator

Returns a pia formula percentage, const version.

C++
const_reference operator [](
    std::size_t index
) const;
Collapse Expand Parameters
Parameters | Description
std::size_t index | Index of percentage desired (0-2).
Collapse Expand Returns

A pia formula percentage.

Collapse Expand Group

[] Operator

Collapse Expand Links
PercPia Class, PercPia Members, [] Operator


PercPia Nested Types

PercPia Nested Types
PercPia Class Public Nested Types

The nested types of the PercPia class are listed here.

Collapse Expand Class

PercPia Class

Collapse Expand Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of size in this array.
value_type | The type of data in this array.
Collapse Expand Links
PercPia Class, Public Nested Types


PercPia::const_iterator Nested Type

PercPia::const_iterator Nested Type
PercPia Class PercPia Members PercPia Nested Types

A const iterator for this array.

C++
typedef const double* const_iterator;
Collapse Expand Group

PercPia Nested Types

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Nested Types


PercPia::const_reference Nested Type

PercPia::const_reference Nested Type
PercPia Class PercPia Members PercPia Nested Types

A const reference for this array.

C++
typedef const double& const_reference;
Collapse Expand Group

PercPia Nested Types

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Nested Types


PercPia::difference_type Nested Type

PercPia::difference_type Nested Type
PercPia Class PercPia Members PercPia Nested Types

The type of difference in this array.

C++
typedef std::ptrdiff_t difference_type;
Collapse Expand Group

PercPia Nested Types

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Nested Types


PercPia::iterator Nested Type

PercPia::iterator Nested Type
PercPia Class PercPia Members PercPia Nested Types

An iterator for this array.

C++
typedef double* iterator;
Collapse Expand Group

PercPia Nested Types

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Nested Types


PercPia::reference Nested Type

PercPia::reference Nested Type
PercPia Class PercPia Members PercPia Nested Types

A reference for this array.

C++
typedef double& reference;
Collapse Expand Group

PercPia Nested Types

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Nested Types


PercPia::size_type Nested Type

PercPia::size_type Nested Type
PercPia Class PercPia Members PercPia Nested Types

The type of size in this array.

C++
typedef std::size_t size_type;
Collapse Expand Group

PercPia Nested Types

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Nested Types


PercPia::value_type Nested Type

PercPia::value_type Nested Type
PercPia Class PercPia Members PercPia Nested Types

The type of data in this array.

C++
typedef double value_type;
Collapse Expand Group

PercPia Nested Types

Collapse Expand Links
PercPia Class, PercPia Members, PercPia Nested Types


PercPiaOut Class

PercPiaOut Class
PercPiaOut Constructor PercPiaOut Methods PercPiaOut Members PercPiaOut.h Classes

Manages the array of pia formula percentages, projected for all years.

Collapse Expand Class Hierarchy
  PercPiaOut
C++
class PercPiaOut;
Collapse Expand File

File: PercPiaOut.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is used in PiaParams.

Collapse Expand Group

Classes

Collapse Expand Links
PercPiaOut Constructor, PercPiaOut Methods, PercPiaOut Members, PercPiaOut.h, Classes


PercPiaOut Members

PercPiaOut Members
PercPiaOut Class Legend Public Methods

The following tables list the members exposed by PercPiaOut.

Collapse Expand Class

PercPiaOut Class

Collapse Expand Public Methods
Name | Description
PercPiaOut | Initializes a PercPiaOut, with or without a specified first year.
getNumPercs | Returns number of percentages in the PIA formula for a year.
getPercPia | Returns an indexed percentage for specified year.
setData | Sets data for one year.
Collapse Expand Links
PercPiaOut Class, Legend, Public Methods


PercPiaOut Constructor

PercPiaOut Constructor
PercPiaOut Class

Initializes a PercPiaOut, with or without a specified first year.

Collapse Expand Description

There are two versions of the PercPiaOut constructor. If the first year is not specified, it is set to 1979.

Collapse Expand Overload List
Name | Description
PercPiaOut::PercPiaOut (int) | Initializes arrays starting in 1979.
PercPiaOut::PercPiaOut (int, int) | Initializes arrays with specified start year.
Collapse Expand Class

PercPiaOut Class

Collapse Expand Links
PercPiaOut Class


PercPiaOut::PercPiaOut Constructor (int)

PercPiaOut::PercPiaOut Constructor (int)
PercPiaOut Class PercPiaOut Members PercPiaOut Constructor

Initializes arrays starting in 1979.

C++
PercPiaOut(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Maximum year of projection.
Collapse Expand Group

PercPiaOut Constructor

Collapse Expand Links
PercPiaOut Class, PercPiaOut Members, PercPiaOut Constructor


PercPiaOut::PercPiaOut Constructor (int, int)

PercPiaOut::PercPiaOut Constructor (int, int)
PercPiaOut Class PercPiaOut Members PercPiaOut Constructor

Initializes arrays with specified start year.

C++
PercPiaOut(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | Starting year of array.
int newLastYear | Maximum year of projection.
Collapse Expand Group

PercPiaOut Constructor

Collapse Expand Links
PercPiaOut Class, PercPiaOut Members, PercPiaOut Constructor


PercPiaOut Methods

PercPiaOut Methods
PercPiaOut Class Legend Public Methods

The methods of the PercPiaOut class are listed here.

Collapse Expand Class

PercPiaOut Class

Collapse Expand Public Methods
Name | Description
getNumPercs | Returns number of percentages in the PIA formula for a year.
getPercPia | Returns an indexed percentage for specified year.
setData | Sets data for one year.
Collapse Expand Links
PercPiaOut Class, Legend, Public Methods


PercPiaOut::getNumPercs Method

PercPiaOut::getNumPercs Method
PercPiaOut Class PercPiaOut Members PercPiaOut Methods

Returns number of percentages in the PIA formula for a year.

C++
int getNumPercs(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of formula.
Collapse Expand Returns

Number of percentages in PIA formula for a year.

Collapse Expand Group

PercPiaOut Methods

Collapse Expand Links
PercPiaOut Class, PercPiaOut Members, PercPiaOut Methods


PercPiaOut::getPercPia Method

PercPiaOut::getPercPia Method
PercPiaOut Class PercPiaOut Members PercPiaOut Methods

Returns an indexed percentage for specified year.

C++
double getPercPia(
    int year,
    int index
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which first percentage is desired.
int index | Index of desired percentage.
Collapse Expand Returns

Indexed percentage for specified year.

Collapse Expand Group

PercPiaOut Methods

Collapse Expand Links
PercPiaOut Class, PercPiaOut Members, PercPiaOut Methods


PercPiaOut::setData Method

PercPiaOut::setData Method
PercPiaOut Class PercPiaOut Members PercPiaOut Methods

Sets data for one year.

C++
void setData(
    int year,
    int numPerc,
    double perc[]
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which data is set.
int numPerc | Number of percentages in the formula.
double perc[] | Array of percentages.
Collapse Expand Group

PercPiaOut Methods

Collapse Expand Links
PercPiaOut Class, PercPiaOut Members, PercPiaOut Methods


PiaCal Class

PiaCal Class
PiaCal Data Members PiaCal Methods PiaCal Members piacal.h Classes

Parent of all classes that manage the functions required for calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  PiaCal
C++
class PiaCal;
Collapse Expand File

File: piacal.h

Module: PiaData Library

Collapse Expand Remarks

This class is abstract; child classes are PiaCalAny, PiaCalLC, and PiaCalPL.

Collapse Expand See Also

PiaCalAny, PiaCalLC, PiaCalPL

Collapse Expand Group

Classes

Collapse Expand Links
PiaCal Data Members, PiaCal Methods, PiaCal Members, piacal.h, Classes


PiaCal Members

PiaCal Members
PiaCal Class Legend Public Data Members Public Methods

The following tables list the members exposed by PiaCal.

Collapse Expand Class

PiaCal Class

Collapse Expand Public Data Members
Name | Description
childCareCalc | Pointer to child care calculation.
dibGuar | Pointer to disability guarantee.
frozMin | Pointer to frozen minimum method.
highPiaMethod | Pointer to method with high pia.
oldStart | Pointer to old-start method.
piaData | Worker's pia calculation data.
piaMethod | Pia calculation methods that apply to all benies in the family.
piaParams | Pia calculation parameters.
piaTable | Pointer to pia table method.
specMin | Pointer to special minimum method.
transGuar | Pointer to transitional guarantee.
wageInd | Pointer to wage-indexed method.
wageIndNonFreeze | Pointer to wage-indexed non-freeze method.
widowMethod | Pia calculation methods that apply only to widow(er)s.
workerData | Worker's personal data.
Collapse Expand Public Methods
Name | Description
PiaCal | Initializes this instance.
ageEntCheck | Checks date of entitlement for a primary benie.
applyLifeMfb | Applies maximum family benefit to family's benefits in a life case.
applyMfb | Applies maximum family benefit to each family benefit, after ratio has been determined.
applySurvivorMfb | Applies maximum family benefit to family's benefits in a survivor case.
ardriAuxCal | Calculates the benefit factor and number of months of early or delayed retirement for a dependent or survivor.
ardriCal | Calculates the number of months of early or delayed retirement for a primary benie.
calculate2 | Calculates PIA and benefit.
dataCheck | Checks primary data for validity and does some preliminary calculations.
dataCheckAux | Checks auxiliary data for validity and does some preliminary calculations.
deadIns | Returns the insured status code for a deceased worker.
deemedInsCal | Checks for deemed insured status, assuming eligible for deemed insured status provision to apply.
didropCal | Calculates number of years to drop out of elapsed period due to disability.
didropNonFreezeCal | Calculates number of years to drop out of elapsed period for fully insured status due to disability in a non-freeze computation.
disInsCal | Calculates the disability insured status code for one year.
disInsNonFreezeCal | Calculates the disability insured status code for non-freeze for one year.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
eligYearCal | Computes year of eligibility.
eligYearCal1 | Computes date of eligibility before considering disability.
eligYearCal2 | Computes year of eligibility after considering disability.
eligYearCal3 | Computes year of eligibility for non-freeze computations.
eligYearWidowCal | Returns eligibility year for widow(er).
fins1Cal | Calculates and returns the insured status code for one date.
fins2Cal | Calculates and returns the OACT insured status code for one date.
finsNonFreeze1Cal | Calculates and returns the insured status code for non-freeze for one date.
finsNonFreeze2Cal | Calculates and returns the OACT insured status code for non-freeze for one date.
fullInsDateCal | Calculates the date fully insured status was first attained (at full retirement age or later).
getIoasdi | Returns type of benefit.
getPubpenEnable | Returns true if ok to enable noncovered pension entry box.
insCal | Calculates the insured status code for one date.
insNonFreezeCal | This is the overview for the insNonFreezeCal method overload.
isPebsAssumptions | Returns Statement assumptions indicator.
monthsArAgedSpouseCal | Calculates full benefit factor and number of months of actuarial reduction for aged wife or husband and sets reduction factor.
monthsArCal | Calculates number of months of actuarial reduction for OAB and sets reduction factor.
monthsArDICal | Calculates number of months of actuarial reduction for DIB and sets reduction factor.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er) and sets reduction factor.
monthsArWidCal | Calculates full benefit factor and number of months of actuarial reduction for aged widow(er) and sets reduction factor.
monthsDriCal | Calculates number of months of delayed retirement credit for OAB and sets increment factor.
monthsYngLifeCal | Calculates number of months of actuarial reduction for young auxiliary and sets benefit factor.
monthsYngSurvCal | Calculates number of months of actuarial reduction for young survivor and sets benefit factor.
nCal | Determine number of computation years and dropout years.
nDropCal | Determine number of dropout years, before considering 1-for-5 dropout.
nDropNonFreezeCal | Determine number of dropout years, before considering 1-for-5 dropout.
nNonFreezeCal | Determine number of computation years and dropout years.
nelapsed2Cal | Returns ending elapsed year for a beneficiary case.
nelapsed2NonFreezeCal | Returns ending elapsed year for a non-freeze case.
nelapsedCal | Determine number of elapsed years.
nelapsedNonFreezeCal | This is the overview for the nelapsedNonFreezeCal method overload.
piaCal | Calculates PIA and MFB, not including re-indexed widow(er).
piaCal1 | Figures high pia and mfb.
piaCal2 | Figures benefit for primary.
piaCal3 | Figures benefits for auxiliaries.
qc3750simpCal | Calculates simplified quarters of coverage, 1937-50.
qcCal | Calculates annual quarters of coverage and insured status.
qcCurrentCal | Calculates quarters of coverage earned for currently insured status.
qcCurrentNonFreezeCal | Calculates quarters of coverage earned for currently insured status for non-freeze.
qcReqCal | Calculates required quarters of coverage for fully insured status at end of year.
qcReqNonFreezeCal | Calculates required quarters of coverage for fully insured status for non-freeze at end of year.
qcReqPermCal | Calculates required quarters of coverage for permanently insured status.
qcReqPermNonFreezeCal | Calculates required quarters of coverage for permanently insured status for non-freeze.
reindWidCal | Calculates PIA for one re-indexed widow(er).
reindWidCalAll | Calculates PIA for all re-indexed widow(er)s.
relEarnPositionCal | Calculates relative earnings position.
releaseMemory | Releases memory.
resetAmend90 | Resets indicator for earnings used after 1991.
setAmend90 | Sets indicator for entitlement after 1990 amendments.
setArfApp | Sets indicator for delayed retirement credit in special minimum case.
setEligYearWidow | Sets eligibility year for widow.
setHighMfb | Sets applicable mfb.
setHighPia | Sets applicable pia.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPifc | Sets applicable pifc.
setSupportPia | Sets support pia, if applicable pia is special minimum and there is delayed retirement credit involved.
widowCheck | Checks disabled widow's date of disability.
~PiaCal | Destructor.
Collapse Expand Links
PiaCal Class, Legend, Public Data Members, Public Methods


PiaCal::PiaCal Constructor

PiaCal::PiaCal Constructor
PiaCal Class PiaCal Members PiaCal Class

Initializes this instance.

C++
PiaCal(
    WorkerDataGeneral& newWorkerData,
    PiaData& newPiaData,
    const PiaParams& newPiaParams
);
Collapse Expand Parameters
Parameters | Description
WorkerDataGeneral& newWorkerData | Worker's basic data.
PiaData& newPiaData | Worker's pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
Collapse Expand Class

PiaCal Class

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Class


PiaCal::~PiaCal Destructor

PiaCal::~PiaCal Destructor
PiaCal Class PiaCal Members PiaCal Class

Destructor.

C++
virtual ~PiaCal();
Collapse Expand Class

PiaCal Class

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Class


PiaCal Data Members

PiaCal Data Members
PiaCal Class Legend Public Data Members

The data members of the PiaCal class are listed here.

Collapse Expand Class

PiaCal Class

Collapse Expand Public Data Members
Name | Description
childCareCalc | Pointer to child care calculation.
dibGuar | Pointer to disability guarantee.
frozMin | Pointer to frozen minimum method.
highPiaMethod | Pointer to method with high pia.
oldStart | Pointer to old-start method.
piaData | Worker's pia calculation data.
piaMethod | Pia calculation methods that apply to all benies in the family.
piaParams | Pia calculation parameters.
piaTable | Pointer to pia table method.
specMin | Pointer to special minimum method.
transGuar | Pointer to transitional guarantee.
wageInd | Pointer to wage-indexed method.
wageIndNonFreeze | Pointer to wage-indexed non-freeze method.
widowMethod | Pia calculation methods that apply only to widow(er)s.
workerData | Worker's personal data.
Collapse Expand Links
PiaCal Class, Legend, Public Data Members


PiaCal::childCareCalc Data Member

PiaCal::childCareCalc Data Member
PiaCal Class PiaCal Members PiaCal Data Members

Pointer to child care calculation.

C++
ChildCareCalc* childCareCalc;
Collapse Expand Group

PiaCal Data Members

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Data Members


PiaCal::dibGuar Data Member

PiaCal::dibGuar Data Member
PiaCal Class PiaCal Members PiaCal Data Members

Pointer to disability guarantee.

C++
DibGuar* dibGuar;
Collapse Expand Group

PiaCal Data Members

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Data Members


PiaCal::frozMin Data Member

PiaCal::frozMin Data Member
PiaCal Class PiaCal Members PiaCal Data Members

Pointer to frozen minimum method.

C++
FrozMin* frozMin;
Collapse Expand Group

PiaCal Data Members

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Data Members


PiaCal::highPiaMethod Data Member

PiaCal::highPiaMethod Data Member
PiaCal Class PiaCal Members PiaCal Data Members

Pointer to method with high pia.

C++
PiaMethod* highPiaMethod;
Collapse Expand Group

PiaCal Data Members

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Data Members


PiaCal::oldStart Data Member

PiaCal::oldStart Data Member
PiaCal Class PiaCal Members PiaCal Data Members

Pointer to old-start method.

C++
OldStart* oldStart;
Collapse Expand Group

PiaCal Data Members

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Data Members


PiaCal::piaData Data Member

PiaCal::piaData Data Member
PiaCal Class PiaCal Members PiaCal Data Members

Worker's pia calculation data.

C++
PiaData& piaData;
Collapse Expand Group

PiaCal Data Members

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Data Members


PiaCal::piaMethod Data Member

PiaCal::piaMethod Data Member
PiaCal Class PiaCal Members PiaCal Data Members

Pia calculation methods that apply to all benies in the family.

C++
std::vector<PiaMethod *> piaMethod;
Collapse Expand Group

PiaCal Data Members

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Data Members


PiaCal::piaParams Data Member

PiaCal::piaParams Data Member
PiaCal Class PiaCal Members PiaCal Data Members

Pia calculation parameters.

C++
const PiaParams& piaParams;
Collapse Expand Group

PiaCal Data Members

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Data Members


PiaCal::piaTable Data Member

PiaCal::piaTable Data Member
PiaCal Class PiaCal Members PiaCal Data Members

Pointer to pia table method.

C++
PiaTable* piaTable;
Collapse Expand Group

PiaCal Data Members

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Data Members


PiaCal::specMin Data Member

PiaCal::specMin Data Member
PiaCal Class PiaCal Members PiaCal Data Members

Pointer to special minimum method.

C++
SpecMin* specMin;
Collapse Expand Group

PiaCal Data Members

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Data Members


PiaCal::transGuar Data Member

PiaCal::transGuar Data Member
PiaCal Class PiaCal Members PiaCal Data Members

Pointer to transitional guarantee.

C++
TransGuar* transGuar;
Collapse Expand Group

PiaCal Data Members

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Data Members


PiaCal::wageInd Data Member

PiaCal::wageInd Data Member
PiaCal Class PiaCal Members PiaCal Data Members

Pointer to wage-indexed method.

C++
WageInd* wageInd;
Collapse Expand Group

PiaCal Data Members

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Data Members


PiaCal::wageIndNonFreeze Data Member

PiaCal::wageIndNonFreeze Data Member
PiaCal Class PiaCal Members PiaCal Data Members

Pointer to wage-indexed non-freeze method.

C++
WageIndNonFreeze* wageIndNonFreeze;
Collapse Expand Group

PiaCal Data Members

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Data Members


PiaCal::widowMethod Data Member

PiaCal::widowMethod Data Member
PiaCal Class PiaCal Members PiaCal Data Members

Pia calculation methods that apply only to widow(er)s.

C++
std::vector<ReindWid *> widowMethod;
Collapse Expand Group

PiaCal Data Members

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Data Members


PiaCal::workerData Data Member

PiaCal::workerData Data Member
PiaCal Class PiaCal Members PiaCal Data Members

Worker's personal data.

C++
WorkerDataGeneral& workerData;
Collapse Expand Group

PiaCal Data Members

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Data Members


PiaCal Methods

PiaCal Methods
PiaCal Class Legend Public Methods

The methods of the PiaCal class are listed here.

Collapse Expand Class

PiaCal Class

Collapse Expand Public Methods
Name | Description
ageEntCheck | Checks date of entitlement for a primary benie.
applyLifeMfb | Applies maximum family benefit to family's benefits in a life case.
applyMfb | Applies maximum family benefit to each family benefit, after ratio has been determined.
applySurvivorMfb | Applies maximum family benefit to family's benefits in a survivor case.
ardriAuxCal | Calculates the benefit factor and number of months of early or delayed retirement for a dependent or survivor.
ardriCal | Calculates the number of months of early or delayed retirement for a primary benie.
calculate2 | Calculates PIA and benefit.
dataCheck | Checks primary data for validity and does some preliminary calculations.
dataCheckAux | Checks auxiliary data for validity and does some preliminary calculations.
deadIns | Returns the insured status code for a deceased worker.
deemedInsCal | Checks for deemed insured status, assuming eligible for deemed insured status provision to apply.
didropCal | Calculates number of years to drop out of elapsed period due to disability.
didropNonFreezeCal | Calculates number of years to drop out of elapsed period for fully insured status due to disability in a non-freeze computation.
disInsCal | Calculates the disability insured status code for one year.
disInsNonFreezeCal | Calculates the disability insured status code for non-freeze for one year.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
eligYearCal | Computes year of eligibility.
eligYearCal1 | Computes date of eligibility before considering disability.
eligYearCal2 | Computes year of eligibility after considering disability.
eligYearCal3 | Computes year of eligibility for non-freeze computations.
eligYearWidowCal | Returns eligibility year for widow(er).
fins1Cal | Calculates and returns the insured status code for one date.
fins2Cal | Calculates and returns the OACT insured status code for one date.
finsNonFreeze1Cal | Calculates and returns the insured status code for non-freeze for one date.
finsNonFreeze2Cal | Calculates and returns the OACT insured status code for non-freeze for one date.
fullInsDateCal | Calculates the date fully insured status was first attained (at full retirement age or later).
getIoasdi | Returns type of benefit.
getPubpenEnable | Returns true if ok to enable noncovered pension entry box.
insCal | Calculates the insured status code for one date.
insNonFreezeCal | This is the overview for the insNonFreezeCal method overload.
isPebsAssumptions | Returns Statement assumptions indicator.
monthsArAgedSpouseCal | Calculates full benefit factor and number of months of actuarial reduction for aged wife or husband and sets reduction factor.
monthsArCal | Calculates number of months of actuarial reduction for OAB and sets reduction factor.
monthsArDICal | Calculates number of months of actuarial reduction for DIB and sets reduction factor.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er) and sets reduction factor.
monthsArWidCal | Calculates full benefit factor and number of months of actuarial reduction for aged widow(er) and sets reduction factor.
monthsDriCal | Calculates number of months of delayed retirement credit for OAB and sets increment factor.
monthsYngLifeCal | Calculates number of months of actuarial reduction for young auxiliary and sets benefit factor.
monthsYngSurvCal | Calculates number of months of actuarial reduction for young survivor and sets benefit factor.
nCal | Determine number of computation years and dropout years.
nDropCal | Determine number of dropout years, before considering 1-for-5 dropout.
nDropNonFreezeCal | Determine number of dropout years, before considering 1-for-5 dropout.
nNonFreezeCal | Determine number of computation years and dropout years.
nelapsed2Cal | Returns ending elapsed year for a beneficiary case.
nelapsed2NonFreezeCal | Returns ending elapsed year for a non-freeze case.
nelapsedCal | Determine number of elapsed years.
nelapsedNonFreezeCal | This is the overview for the nelapsedNonFreezeCal method overload.
piaCal | Calculates PIA and MFB, not including re-indexed widow(er).
piaCal1 | Figures high pia and mfb.
piaCal2 | Figures benefit for primary.
piaCal3 | Figures benefits for auxiliaries.
qc3750simpCal | Calculates simplified quarters of coverage, 1937-50.
qcCal | Calculates annual quarters of coverage and insured status.
qcCurrentCal | Calculates quarters of coverage earned for currently insured status.
qcCurrentNonFreezeCal | Calculates quarters of coverage earned for currently insured status for non-freeze.
qcReqCal | Calculates required quarters of coverage for fully insured status at end of year.
qcReqNonFreezeCal | Calculates required quarters of coverage for fully insured status for non-freeze at end of year.
qcReqPermCal | Calculates required quarters of coverage for permanently insured status.
qcReqPermNonFreezeCal | Calculates required quarters of coverage for permanently insured status for non-freeze.
reindWidCal | Calculates PIA for one re-indexed widow(er).
reindWidCalAll | Calculates PIA for all re-indexed widow(er)s.
relEarnPositionCal | Calculates relative earnings position.
releaseMemory | Releases memory.
resetAmend90 | Resets indicator for earnings used after 1991.
setAmend90 | Sets indicator for entitlement after 1990 amendments.
setArfApp | Sets indicator for delayed retirement credit in special minimum case.
setEligYearWidow | Sets eligibility year for widow.
setHighMfb | Sets applicable mfb.
setHighPia | Sets applicable pia.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPifc | Sets applicable pifc.
setSupportPia | Sets support pia, if applicable pia is special minimum and there is delayed retirement credit involved.
widowCheck | Checks disabled widow's date of disability.
Collapse Expand Links
PiaCal Class, Legend, Public Methods


PiaCal::ageEntCheck Method

PiaCal::ageEntCheck Method
PiaCal Class PiaCal Members PiaCal Methods

Checks date of entitlement for a primary benie.

C++
void ageEntCheck() const;
Collapse Expand Remarks

Assumes type of benefit is WorkerDataGeneral::ben_type::OLD_AGE or WorkerDataGeneral::ben_type::DISABILITY.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ARDRI1 if age is out of range; of type PIA_IDS_ARDRI2 if age is before early retirement age for OAB; of type PIA_IDS_ARDRI7 if DIB entitlement before 1957; of type PIA_IDS_ARDRI8 if age under 50 for DIB before 1960; of type PIA_IDS_ARDRI9 if age over full retirement age for DIB.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


applyLifeMfb Method

applyLifeMfb Method
PiaCal Methods

Applies maximum family benefit to family's benefits in a life case.

Collapse Expand Description

There are two versions of the applyLifeMfb method. The version with 3 arguments calls the static version with 6 arguments, passing saved values for the other arguments.

Collapse Expand Overload List
Name | Description
PiaCal::applyLifeMfb (SecondaryArray&, int, int) | Applies maximum family benefit (already calculated) to family's benefits in a life case.
PiaCal::applyLifeMfb (SecondaryArray&, int, int, double, double, double) | Applies maximum family benefit to family's benefits in a life case.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Methods


PiaCal::applyLifeMfb Method (SecondaryArray&, int, int)

PiaCal::applyLifeMfb Method (SecondaryArray&, int, int)
PiaCal Class PiaCal Members applyLifeMfb Method

Applies maximum family benefit (already calculated) to family's benefits in a life case.

C++
void applyLifeMfb(
    SecondaryArray& secondaryArray,
    int famSize,
    int year
) const;
Collapse Expand Parameters
Parameters | Description
SecondaryArray& secondaryArray | Benefits for all family members.
int famSize | Number of family members.
int year | Year of rounding.
Collapse Expand Remarks

Calls the static version with 6 arguments, passing saved values for the other arguments. The worker's pia is subtracted from the mfb before applying the mfb to the auxiliaries' total benefits.

Collapse Expand Group

applyLifeMfb Method

Collapse Expand Links
PiaCal Class, PiaCal Members, applyLifeMfb Method


PiaCal::applyLifeMfb Method (SecondaryArray&, int, int, double, double, double)

PiaCal::applyLifeMfb Method (SecondaryArray&, int, int, double, double, double)
PiaCal Class PiaCal Members applyLifeMfb Method

Applies maximum family benefit to family's benefits in a life case.

C++
static void applyLifeMfb(
    SecondaryArray& secondaryArray,
    int famSize,
    int year,
    double mfb,
    double pia,
    double totalBenefit
);
Collapse Expand Parameters
Parameters | Description
SecondaryArray& secondaryArray | Benefits for all family members.
int famSize | Number of family members.
int year | Year of rounding.
double mfb | Maximum family benefit.
double pia | Primary insurance amount.
double totalBenefit | Total family benefit before applying maximum.
Collapse Expand Remarks

The worker's pia is subtracted from the mfb before applying the mfb to the auxiliaries' total benefits.

Collapse Expand Group

applyLifeMfb Method

Collapse Expand Links
PiaCal Class, PiaCal Members, applyLifeMfb Method


PiaCal::applyMfb Method

PiaCal::applyMfb Method
PiaCal Class PiaCal Members PiaCal Methods

Applies maximum family benefit to each family benefit, after ratio has been determined.

C++
static void applyMfb(
    SecondaryArray& secondaryArray,
    int famSize,
    double ratio,
    int year
);
Collapse Expand Parameters
Parameters | Description
SecondaryArray& secondaryArray | Benefits for all family members.
int famSize | Number of family members.
double ratio | Ratio to be applied to each family benefit.
int year | Year of rounding.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


applySurvivorMfb Method

applySurvivorMfb Method
PiaCal Methods

Applies maximum family benefit to family's benefits in a survivor case.

Collapse Expand Description

There are two versions of the applySurvivorMfbmethod. The version with 3 arguments calls the static version with 5 arguments, passing saved values for the other arguments.

Collapse Expand Overload List
Name | Description
PiaCal::applySurvivorMfb (SecondaryArray&, int, int) | Applies maximum family benefit (already calculated) to family's benefits in a survivor case.
PiaCal::applySurvivorMfb (SecondaryArray&, int, int, double, double) | Applies maximum family benefit to family's benefits in a survivor case.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Methods


PiaCal::applySurvivorMfb Method (SecondaryArray&, int, int)

PiaCal::applySurvivorMfb Method (SecondaryArray&, int, int)
PiaCal Class PiaCal Members applySurvivorMfb Method

Applies maximum family benefit (already calculated) to family's benefits in a survivor case.

C++
void applySurvivorMfb(
    SecondaryArray& secondaryArray,
    int famSize,
    int year
) const;
Collapse Expand Parameters
Parameters | Description
SecondaryArray& secondaryArray | Benefits for all family members.
int famSize | Number of family members.
int year | Year of rounding.
Collapse Expand Remarks

Calls the static version with 5 arguments, passing saved values for the other arguments.

Collapse Expand Group

applySurvivorMfb Method

Collapse Expand Links
PiaCal Class, PiaCal Members, applySurvivorMfb Method


PiaCal::applySurvivorMfb Method (SecondaryArray&, int, int, double, double)

PiaCal::applySurvivorMfb Method (SecondaryArray&, int, int, double, double)
PiaCal Class PiaCal Members applySurvivorMfb Method

Applies maximum family benefit to family's benefits in a survivor case.

C++
static void applySurvivorMfb(
    SecondaryArray& secondaryArray,
    int famSize,
    int year,
    double mfb,
    double totalBenefit
);
Collapse Expand Parameters
Parameters | Description
SecondaryArray& secondaryArray | Benefits for all family members.
int famSize | Number of family members.
int year | Year of rounding.
double mfb | Maximum family benefit.
double totalBenefit | Total family benefit before applying maximum.
Collapse Expand Group

applySurvivorMfb Method

Collapse Expand Links
PiaCal Class, PiaCal Members, applySurvivorMfb Method


PiaCal::ardriAuxCal Method

PiaCal::ardriAuxCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates the benefit factor and number of months of early or delayed retirement for a dependent or survivor.

C++
void ardriAuxCal(
    WorkerDataGeneral * widowData,
    PiaData * widowPiaData,
    Secondary * secondaryData,
    const DateMoyr& entDate
) const;
Collapse Expand Parameters
Parameters | Description
WorkerDataGeneral * widowData | Family member's basic information.
PiaData * widowPiaData | Family member's primary benefit data.
Secondary * secondaryData | Family member's secondary benefit data.
const DateMoyr& entDate | Entitlement date.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ARDRI10 if aged wife age is before early retirement age; of type PIA_IDS_JSURV if invalid bic; of type PIA_IDS_ARDRI4 if disabled widow(er) age is before earliest possible age; of type PIA_IDS_ARDRI5 if disabled widow(er) entitlement is before benefit date; of type PIA_IDS_ARDRI6 if aged widow(er) age is before earliest possible age.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::ardriCal Method

PiaCal::ardriCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates the number of months of early or delayed retirement for a primary benie.

C++
void ardriCal() const;
Collapse Expand Remarks

If old-age, it calls monthsArCal or monthsDriCal, if entitlement is before or after full retirement age, respectively. If disability, it calls monthsArDICal.

Assumes type of benefit is WorkerDataGeneral::ben_type::OLD_AGE or WorkerDataGeneral::ben_type::DISABILITY.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::calculate2 Method

PiaCal::calculate2 Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates PIA and benefit.

C++
virtual void calculate2(
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | The date of entitlement.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCTOT0 if no quarters of coverage in a totalization case.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::dataCheck Method

PiaCal::dataCheck Method
PiaCal Class PiaCal Members PiaCal Methods

Checks primary data for validity and does some preliminary calculations.

C++
virtual void dataCheck(
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | Entitlement date.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of many different types if any data is out of range.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::dataCheckAux Method

PiaCal::dataCheckAux Method
PiaCal Class PiaCal Members PiaCal Methods

Checks auxiliary data for validity and does some preliminary calculations.

C++
void dataCheckAux(
    WorkerDataArray& widowDataArray,
    PiaDataArray& widowArray,
    SecondaryArray& secondaryArray
);
Collapse Expand Parameters
Parameters | Description
WorkerDataArray& widowDataArray | Basic information for all family members.
PiaDataArray& widowArray | Calculated data for all family members.
SecondaryArray& secondaryArray | Benefits for all family members.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BENDATE6 if secondary entitlement after benefit date.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::deadIns Method

PiaCal::deadIns Method
PiaCal Class PiaCal Members PiaCal Methods

Returns the insured status code for a deceased worker.

C++
static InsCode::InsCodeType deadIns(
    int iswasPrimary
);
Collapse Expand Parameters
Parameters | Description
int iswasPrimary | Worker's primary beneficiary status.
Collapse Expand Returns

The insured status code for a deceased worker.

Collapse Expand Remarks

Note that this is a static function.

The iswasPrimary argument has the following possible values:

0 | never a primary beneficiary.
1 | is a primary beneficiary.
2 | is a deceased primary beneficiary.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::deemedInsCal Method

PiaCal::deemedInsCal Method
PiaCal Class PiaCal Members PiaCal Methods

Checks for deemed insured status, assuming eligible for deemed insured status provision to apply.

C++
static bool deemedInsCal(
    PiaData& piaData,
    const QtrYear& qtrYear
);
Collapse Expand Parameters
Parameters | Description
PiaData& piaData | Worker's calculated data.
const QtrYear& qtrYear | Quarter and year for which insured status code is required.
Collapse Expand Returns

True if deemed insured, false otherwise.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::didropCal Method

PiaCal::didropCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates number of years to drop out of elapsed period due to disability.

C++
static int didropCal(
    const WorkerDataGeneral& workerData,
    int elapsed1,
    int elapsed2,
    FreezeYears& frzyrst
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
int elapsed1 | First year of elapsed period.
int elapsed2 | Last year of elapsed period.
FreezeYears& frzyrst | Freeze years information.
Collapse Expand Returns

Number of years to drop out of elapsed period due to disability.

Collapse Expand Remarks

Note that this is a static function.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::didropNonFreezeCal Method

PiaCal::didropNonFreezeCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates number of years to drop out of elapsed period for fully insured status due to disability in a non-freeze computation.

C++
static int didropNonFreezeCal(
    const WorkerDataGeneral& workerData,
    int elapsed1,
    int elapsed2
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
int elapsed1 | First year of elapsed period.
int elapsed2 | Last year of elapsed period.
Collapse Expand Returns

Number of years to drop out of elapsed period for fully insured status due to disability in a non-freeze computation.

Collapse Expand Remarks

Note that this is a static function. Also note that this should only be used for computing fully insured status in a non-freeze computation.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::disInsCal Method

PiaCal::disInsCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates the disability insured status code for one year.

C++
static DisInsCode::DisInsCodeType disInsCal(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    const DateMoyr& dateMoyr,
    int iswasPrimary
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
PiaData& piaData | Benefit calculation data.
const DateMoyr& dateMoyr | The date for which insured status code is required.
int iswasPrimary | Worker's primary beneficiary status.
Collapse Expand Returns

The disability insured status code.

Collapse Expand Remarks

Note that this is a static function.

The iswasPrimary argument has the following possible values:

0 | never a primary beneficiary.
1 | is a primary beneficiary.
2 | is a deceased primary beneficiary.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::disInsNonFreezeCal Method

PiaCal::disInsNonFreezeCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates the disability insured status code for non-freeze for one year.

C++
static DisInsCode::DisInsCodeType disInsNonFreezeCal(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    const DateMoyr& dateMoyr,
    int iswasPrimary
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
PiaData& piaData | Benefit calculation data.
const DateMoyr& dateMoyr | The date for which insured status code is required.
int iswasPrimary | Worker's primary beneficiary status.
Collapse Expand Returns

The disability insured status code.

Collapse Expand Remarks

Note that this is a static function.

The iswasPrimary argument has the following possible values:

0 | never a primary beneficiary.
1 | is a primary beneficiary.
2 | is a deceased primary beneficiary.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::earnProjection Method

PiaCal::earnProjection Method
PiaCal Class PiaCal Members PiaCal Methods

Projects earnings and fills in earnings to be used in calculations.

C++
virtual void earnProjection() const;
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::eligYearCal Method

PiaCal::eligYearCal Method
PiaCal Class PiaCal Members PiaCal Methods

Computes year of eligibility.

C++
static void eligYearCal(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
PiaData& piaData | Benefit calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::eligYearCal1 Method

PiaCal::eligYearCal1 Method
PiaCal Class PiaCal Members PiaCal Methods

Computes date of eligibility before considering disability.

C++
static DateMoyr eligYearCal1(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi,
    int jind7
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
PiaData& piaData | Benefit calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
int jind7 | 0 for present law, 1-3 for change to age-65 comp point.
Collapse Expand Returns

The date of eligibility before considering disability.

Collapse Expand Remarks

Note that this is a static function.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::eligYearCal2 Method

PiaCal::eligYearCal2 Method
PiaCal Class PiaCal Members PiaCal Methods

Computes year of eligibility after considering disability.

C++
static int eligYearCal2(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi,
    int eligYear
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
PiaData& piaData | Benefit calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit (old-age, survivor, or disability).
int eligYear | Year of attainment of age 62, for old-age and disability, or year of death, for survivor.
Collapse Expand Returns

Year of eligibility after considering disability.

Collapse Expand Remarks

Note that this is a static function.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::eligYearCal3 Method

PiaCal::eligYearCal3 Method
PiaCal Class PiaCal Members PiaCal Methods

Computes year of eligibility for non-freeze computations.

C++
static int eligYearCal3(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi,
    int eligYear
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
PiaData& piaData | Benefit calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit (old-age, survivor, or disability).
int eligYear | Year of attainment of age 62, for old-age and disability, or year of death, for survivor.
Collapse Expand Returns

Year of eligibility for non-freeze computations.

Collapse Expand Remarks

Note that this is a static function.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::eligYearWidowCal Method

PiaCal::eligYearWidowCal Method
PiaCal Class PiaCal Members PiaCal Methods

Returns eligibility year for widow(er).

C++
static int eligYearWidowCal(
    char majorBic,
    int byear,
    boost::gregorian::date onsetDate
);
Collapse Expand Parameters
Parameters | Description
char majorBic | Type of widow(er).
int byear | Adjusted year of birth of widow.
boost::gregorian::date onsetDate | The date of onset of disability (unused if not disabled widow(er)).
Collapse Expand Returns

Eligibility year for widow(er).

Collapse Expand Remarks

The type of widow(er) is as follows:

W | disabled widow(er).
D | aged widow(er).
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if the onset date is not a date in a disabled widow(er) case.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::fins1Cal Method

PiaCal::fins1Cal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates and returns the insured status code for one date.

C++
static InsCode::InsCodeType fins1Cal(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    const QtrYear& qtrYear,
    int iswasPrimary
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
PiaData& piaData | Benefit calculation data.
const QtrYear& qtrYear | Quarter and year of desired insured status.
int iswasPrimary | Worker's primary beneficiary status.
Collapse Expand Returns

The insured status code for one date.

Collapse Expand Remarks

Requires that total and required quarters of coverage have been calculated, and that worker is alive. Note that this is a static function.

The iswasPrimary argument has the following possible values:

0 | never a primary beneficiary.
1 | is a primary beneficiary.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::fins2Cal Method

PiaCal::fins2Cal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates and returns the OACT insured status code for one date.

C++
static char fins2Cal(
    const WorkerDataGeneral& workerData,
    const PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
const PiaData& piaData | Benefit calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
Collapse Expand Returns

The OACT insured status code, as follows:

1 | Fully insured in nontotalization case.
2 | Not fully insured, but currently insured, survivor.
3 | Totalization case with more than 5 qc's, but not fully insured.
4 | Not fully insured nontotalization case other than survivor.
5 | Not fully or currently insured survivor.
6 | Totalization case with less than 6 qc's.
7 | Fully insured totalization case.
Collapse Expand Remarks

Requires that CWHS insured status code has been calculated. Note that this is a static function.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::finsNonFreeze1Cal Method

PiaCal::finsNonFreeze1Cal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates and returns the insured status code for non-freeze for one date.

C++
static InsCode::InsCodeType finsNonFreeze1Cal(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    const QtrYear& qtrYear,
    int iswasPrimary
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
PiaData& piaData | Benefit calculation data.
const QtrYear& qtrYear | Quarter and year of desired insured status.
int iswasPrimary | Worker's primary beneficiary status.
Collapse Expand Returns

The insured status code for one date.

Collapse Expand Remarks

Requires that total and required quarters of coverage have been calculated, and that worker is alive. Note that this is a static function.

The iswasPrimary argument has the following possible values:

0 | never a primary beneficiary.
1 | is a primary beneficiary.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::finsNonFreeze2Cal Method

PiaCal::finsNonFreeze2Cal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates and returns the OACT insured status code for non-freeze for one date.

C++
static char finsNonFreeze2Cal(
    const WorkerDataGeneral& workerData,
    const PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
const PiaData& piaData | Benefit calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
Collapse Expand Returns

The OACT insured status code, as follows:

1 | Fully insured in nontotalization case.
2 | Not fully insured, but currently insured, survivor.
3 | Totalization case with more than 5 qc's, but not fully insured.
4 | Not fully insured nontotalization case other than survivor.
5 | Not fully or currently insured survivor.
6 | Totalization case with less than 6 qc's.
7 | Fully insured totalization case.
Collapse Expand Remarks

Requires that CWHS insured status code has been calculated. Note that this is a static function.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::fullInsDateCal Method

PiaCal::fullInsDateCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates the date fully insured status was first attained (at full retirement age or later).

C++
DateMoyr fullInsDateCal() const;
Collapse Expand Returns

The date fully insured status was first attained (at full retirement age or later).

Collapse Expand Remarks

First checks for fully insured status as of full retirement age. If uninsured at that time, checks every future quarter through the quarter of the benefit date. For this purpose, being insured for totalization benefits is considered to be fully insured.

Requires adjusted date of birth, quarters of coverage filled in from 1937 to date, total quarters of coverage from 1937 to 1950, dates of disability onset and cessation.

This is called from monthsDriCal.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::getIoasdi Method

PiaCal::getIoasdi Method
PiaCal Class PiaCal Members PiaCal Methods

Returns type of benefit.

C++
WorkerDataGeneral::ben_type getIoasdi() const;
Collapse Expand Returns

Type of benefit.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::getPubpenEnable Method

PiaCal::getPubpenEnable Method
PiaCal Class PiaCal Members PiaCal Methods

Returns true if ok to enable noncovered pension entry box.

C++
static bool getPubpenEnable(
    const WorkerDataGeneral& workerData
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
Collapse Expand Returns

True if ok to enable noncovered pension entry box.

Collapse Expand Remarks

Note that this is a static function.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


insCal Method

insCal Method
PiaCal Methods

Calculates the insured status code for one date.

Collapse Expand Description

There are two versions of the insCal function. The one with two arguments calls the static version with 5 arguments.

Collapse Expand Overload List
Name | Description
PiaCal::insCal (const WorkerDataGeneral&, PiaData&, WorkerDataGeneral::ben_type, const QtrYear&, int) | Calculates the insured status code for one date.
PiaCal::insCal (const boost::gregorian::date&, int) | Calculates the insured status code for one date.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Methods


PiaCal::insCal Method (const WorkerDataGeneral&, PiaData&, WorkerDataGeneral::ben_type, const QtrYear&, int)

PiaCal::insCal Method (const WorkerDataGeneral&, PiaData&, WorkerDataGeneral::ben_type, const QtrYear&, int)
PiaCal Class PiaCal Members insCal Method

Calculates the insured status code for one date.

C++
static InsCode::InsCodeType insCal(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi,
    const QtrYear& qtrYear,
    int isWasPrimary
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
PiaData& piaData | Benefit calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
const QtrYear& qtrYear | The date for which insured status code is required.
int isWasPrimary | Worker's primary beneficiary status.
Collapse Expand Returns

The insured status code for one date.

Collapse Expand Remarks

Requires adjusted date of birth, quarters of coverage filled in from 1937 to date, total quarters of coverage for 1937 to 1950, dates of disability onset and cessation.

The isWasPrimary argument has the following possible values:

0 | never a primary beneficiary.
1 | is a primary beneficiary.
2 | is a deceased primary beneficiary.
Collapse Expand Group

insCal Method

Collapse Expand Links
PiaCal Class, PiaCal Members, insCal Method


PiaCal::insCal Method (const boost::gregorian::date&, int)

PiaCal::insCal Method (const boost::gregorian::date&, int)
PiaCal Class PiaCal Members insCal Method

Calculates the insured status code for one date.

C++
InsCode::InsCodeType insCal(
    const boost::gregorian::date& dateModyyr,
    int isWasPrimary
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& dateModyyr | The date for which insured status code is required.
int isWasPrimary | Worker's primary beneficiary status.
Collapse Expand Returns

The insured status code for one date.

Collapse Expand Remarks

Requires adjusted date of birth, quarters of coverage filled in from 1937 to date, total quarters of coverage for 1937 to 1950, dates of disability onset and cessation. This version calls the static version with 5 arguments.

The isWasPrimary argument has the following possible values:

0 | never a primary beneficiary.
1 | is a primary beneficiary.
2 | is a deceased primary beneficiary.
Collapse Expand Group

insCal Method

Collapse Expand Links
PiaCal Class, PiaCal Members, insCal Method


insNonFreezeCal Method

insNonFreezeCal Method
PiaCal Methods

This is the overview for the insNonFreezeCal method overload.

Collapse Expand Overload List
Name | Description
PiaCal::insNonFreezeCal (const WorkerDataGeneral&, PiaData&, WorkerDataGeneral::ben_type, const QtrYear&, int) | Calculates the insured non-freeze status code for one date.
PiaCal::insNonFreezeCal (const boost::gregorian::date&, int) | Calculates the insured non-freeze status code for one date.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Methods


PiaCal::insNonFreezeCal Method (const WorkerDataGeneral&, PiaData&, WorkerDataGeneral::ben_type, const QtrYear&, int)

PiaCal::insNonFreezeCal Method (const WorkerDataGeneral&, PiaData&, WorkerDataGeneral::ben_type, const QtrYear&, int)
PiaCal Class PiaCal Members insNonFreezeCal Method

Calculates the insured non-freeze status code for one date.

C++
static InsCode::InsCodeType insNonFreezeCal(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi,
    const QtrYear& qtrYear,
    int isWasPrimary
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
PiaData& piaData | Benefit calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
const QtrYear& qtrYear | The date for which insured non-freeze status code is required.
int isWasPrimary | Worker's primary beneficiary status.
Collapse Expand Returns

The insured non-freeze status code for one date.

Collapse Expand Remarks

Requires adjusted date of birth, quarters of coverage filled in from 1937 to date, total quarters of coverage for 1937 to 1950, dates of disability onset and cessation.

The isWasPrimary argument has the following possible values:

0 | never a primary beneficiary.
1 | is a primary beneficiary.
2 | is a deceased primary beneficiary.
Collapse Expand Group

insNonFreezeCal Method

Collapse Expand Links
PiaCal Class, PiaCal Members, insNonFreezeCal Method


PiaCal::insNonFreezeCal Method (const boost::gregorian::date&, int)

PiaCal::insNonFreezeCal Method (const boost::gregorian::date&, int)
PiaCal Class PiaCal Members insNonFreezeCal Method

Calculates the insured non-freeze status code for one date.

C++
InsCode::InsCodeType insNonFreezeCal(
    const boost::gregorian::date& dateModyyr,
    int isWasPrimary
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& dateModyyr | The date for which non-freeze insured status code is required.
int isWasPrimary | Worker's primary beneficiary status.
Collapse Expand Returns

The insured non-freeze status code for one date.

Collapse Expand Remarks

Requires adjusted date of birth, quarters of coverage filled in from 1937 to date, total quarters of coverage for 1937 to 1950, dates of disability onset and cessation. This version calls the static version with 5 arguments.

The isWasPrimary argument has the following possible values:

0 | never a primary beneficiary.
1 | is a primary beneficiary.
2 | is a deceased primary beneficiary.
Collapse Expand Group

insNonFreezeCal Method

Collapse Expand Links
PiaCal Class, PiaCal Members, insNonFreezeCal Method


PiaCal::isPebsAssumptions Method

PiaCal::isPebsAssumptions Method
PiaCal Class PiaCal Members PiaCal Methods

Returns Statement assumptions indicator.

C++
bool isPebsAssumptions() const;
Collapse Expand Returns

True if old Statement assumptions (with 1-percent real wage gain).

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::monthsArAgedSpouseCal Method

PiaCal::monthsArAgedSpouseCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates full benefit factor and number of months of actuarial reduction for aged wife or husband and sets reduction factor.

C++
void monthsArAgedSpouseCal(
    PiaData * widowData,
    Secondary * secondaryData
) const;
Collapse Expand Parameters
Parameters | Description
PiaData * widowData | Family member's information.
Secondary * secondaryData | Family member's secondary benefit.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::monthsArCal Method

PiaCal::monthsArCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates number of months of actuarial reduction for OAB and sets reduction factor.

C++
void monthsArCal() const;
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::monthsArDICal Method

PiaCal::monthsArDICal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates number of months of actuarial reduction for DIB and sets reduction factor.

C++
void monthsArDICal() const;
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::monthsArDisWidCal Method

PiaCal::monthsArDisWidCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates number of months of actuarial reduction for disabled widow(er) and sets reduction factor.

C++
void monthsArDisWidCal(
    PiaData * widowData,
    Secondary * secondaryData,
    const DateMoyr& entDate
) const;
Collapse Expand Parameters
Parameters | Description
PiaData * widowData | Family member's information.
Secondary * secondaryData | Family member's secondary benefit.
const DateMoyr& entDate | The date of entitlement.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::monthsArWidCal Method

PiaCal::monthsArWidCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates full benefit factor and number of months of actuarial reduction for aged widow(er) and sets reduction factor.

C++
void monthsArWidCal(
    PiaData * widowData,
    Secondary * secondaryData
) const;
Collapse Expand Parameters
Parameters | Description
PiaData * widowData | Family member's information.
Secondary * secondaryData | Family member's secondary benefit.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::monthsDriCal Method

PiaCal::monthsDriCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates number of months of delayed retirement credit for OAB and sets increment factor.

C++
void monthsDriCal() const;
Collapse Expand Remarks

First finds the date first fully insured by calling fullInsDateCal, since delayed retirement credits are only available if fully insured. Then it calls the static PiaParams::monthsDriCal to get the number of months. It uses that number to calculate the total amount of delayed retirement credit by calling the static PiaParams::factorDriCal.

This is called from ardriCal.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::monthsYngLifeCal Method

PiaCal::monthsYngLifeCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates number of months of actuarial reduction for young auxiliary and sets benefit factor.

C++
void monthsYngLifeCal(
    Secondary * secondaryData
) const;
Collapse Expand Parameters
Parameters | Description
Secondary * secondaryData | Family member's secondary benefit.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::monthsYngSurvCal Method

PiaCal::monthsYngSurvCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates number of months of actuarial reduction for young survivor and sets benefit factor.

C++
void monthsYngSurvCal(
    Secondary * secondaryData
) const;
Collapse Expand Parameters
Parameters | Description
Secondary * secondaryData | Family member's secondary benefit.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::nCal Method

PiaCal::nCal Method
PiaCal Class PiaCal Members PiaCal Methods

Determine number of computation years and dropout years.

C++
virtual void nCal(
    CompPeriod& compPeriod,
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
CompPeriod& compPeriod | Computation period to use (new or old).
const DateMoyr& entDate | Entitlement date.
Collapse Expand Remarks

Assumes elapsed years have already been computed.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::nDropCal Method

PiaCal::nDropCal Method
PiaCal Class PiaCal Members PiaCal Methods

Determine number of dropout years, before considering 1-for-5 dropout.

C++
int nDropCal(
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | Entitlement date.
Collapse Expand Returns

Number of dropout years.

Collapse Expand Remarks

Assumes elapsed years have already been computed.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::nDropNonFreezeCal Method

PiaCal::nDropNonFreezeCal Method
PiaCal Class PiaCal Members PiaCal Methods

Determine number of dropout years, before considering 1-for-5 dropout.

C++
int nDropNonFreezeCal(
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | Entitlement date.
Collapse Expand Returns

Number of dropout years.

Collapse Expand Remarks

Assumes elapsed years have already been computed.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::nNonFreezeCal Method

PiaCal::nNonFreezeCal Method
PiaCal Class PiaCal Members PiaCal Methods

Determine number of computation years and dropout years.

C++
virtual void nNonFreezeCal(
    CompPeriod& compPeriod,
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
CompPeriod& compPeriod | Computation period to use (new or old).
const DateMoyr& entDate | Entitlement date.
Collapse Expand Remarks

Assumes elapsed years have already been computed.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::nelapsed2Cal Method

PiaCal::nelapsed2Cal Method
PiaCal Class PiaCal Members PiaCal Methods

Returns ending elapsed year for a beneficiary case.

C++
virtual int nelapsed2Cal(
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | Entitlement date.
Collapse Expand Returns

Ending elapsed year for a beneficiary case.

Collapse Expand Remarks

Assumes eligibility year has already been calculated.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::nelapsed2NonFreezeCal Method

PiaCal::nelapsed2NonFreezeCal Method
PiaCal Class PiaCal Members PiaCal Methods

Returns ending elapsed year for a non-freeze case.

C++
virtual int nelapsed2NonFreezeCal(
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | Entitlement date.
Collapse Expand Returns

Ending elapsed year for a non-freeze case.

Collapse Expand Remarks

Assumes eligibility year has already been calculated.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


nelapsedCal Method

nelapsedCal Method
PiaCal Methods

Determine number of elapsed years.

Collapse Expand Description

There are two versions of the nelapsedCal function. The one with an entitlement date argument calculates the ending elapsed year, then calls the version with an ending elapsed year argument.

Collapse Expand Overload List
Name | Description
PiaCal::nelapsedCal (CompPeriod&, const DateMoyr&) | Determine number of elapsed years.
PiaCal::nelapsedCal (CompPeriod&, int) | Determine number of elapsed years.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Methods


PiaCal::nelapsedCal Method (CompPeriod&, const DateMoyr&)

PiaCal::nelapsedCal Method (CompPeriod&, const DateMoyr&)
PiaCal Class PiaCal Members nelapsedCal Method

Determine number of elapsed years.

C++
void nelapsedCal(
    CompPeriod& compPeriod,
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
CompPeriod& compPeriod | Computation period to use (new or old).
const DateMoyr& entDate | Entitlement date.
Collapse Expand Remarks

Calculates the ending elapsed year, then calls the version with an ending elapsed year argument.

Collapse Expand Group

nelapsedCal Method

Collapse Expand Links
PiaCal Class, PiaCal Members, nelapsedCal Method


PiaCal::nelapsedCal Method (CompPeriod&, int)

PiaCal::nelapsedCal Method (CompPeriod&, int)
PiaCal Class PiaCal Members nelapsedCal Method

Determine number of elapsed years.

C++
void nelapsedCal(
    CompPeriod& compPeriod,
    int elapsed2
);
Collapse Expand Parameters
Parameters | Description
CompPeriod& compPeriod | Computation period to use (new or old).
int elapsed2 | Ending elapsed year.
Collapse Expand Group

nelapsedCal Method

Collapse Expand Links
PiaCal Class, PiaCal Members, nelapsedCal Method


nelapsedNonFreezeCal Method

nelapsedNonFreezeCal Method
PiaCal Methods

This is the overview for the nelapsedNonFreezeCal method overload.

Collapse Expand Overload List
Name | Description
PiaCal::nelapsedNonFreezeCal (CompPeriod&, const DateMoyr&) | Determine number of elapsed years for a non-freeze case.
PiaCal::nelapsedNonFreezeCal (CompPeriod&, int) | Determine number of elapsed years.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Methods


PiaCal::nelapsedNonFreezeCal Method (CompPeriod&, const DateMoyr&)

PiaCal::nelapsedNonFreezeCal Method (CompPeriod&, const DateMoyr&)
PiaCal Class PiaCal Members nelapsedNonFreezeCal Method

Determine number of elapsed years for a non-freeze case.

C++
void nelapsedNonFreezeCal(
    CompPeriod& compPeriod,
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
CompPeriod& compPeriod | Computation period to use (new or old).
const DateMoyr& entDate | Entitlement date.
Collapse Expand Remarks

Calculates the ending elapsed year, then calls the version with an ending elapsed year argument.

Collapse Expand Group

nelapsedNonFreezeCal Method

Collapse Expand Links
PiaCal Class, PiaCal Members, nelapsedNonFreezeCal Method


PiaCal::nelapsedNonFreezeCal Method (CompPeriod&, int)

PiaCal::nelapsedNonFreezeCal Method (CompPeriod&, int)
PiaCal Class PiaCal Members nelapsedNonFreezeCal Method

Determine number of elapsed years.

C++
void nelapsedNonFreezeCal(
    CompPeriod& compPeriod,
    int elapsed2
);
Collapse Expand Parameters
Parameters | Description
CompPeriod& compPeriod | Computation period to use (new or old).
int elapsed2 | Ending elapsed year.
Collapse Expand Group

nelapsedNonFreezeCal Method

Collapse Expand Links
PiaCal Class, PiaCal Members, nelapsedNonFreezeCal Method


PiaCal::piaCal Method

PiaCal::piaCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates PIA and MFB, not including re-indexed widow(er).

C++
virtual void piaCal(
    const DateMoyr&
) = 0;
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::piaCal1 Method

PiaCal::piaCal1 Method
PiaCal Class PiaCal Members PiaCal Methods

Figures high pia and mfb.

C++
void piaCal1();
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::piaCal2 Method

PiaCal::piaCal2 Method
PiaCal Class PiaCal Members PiaCal Methods

Figures benefit for primary.

C++
void piaCal2();
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::piaCal3 Method

PiaCal::piaCal3 Method
PiaCal Class PiaCal Members PiaCal Methods

Figures benefits for auxiliaries.

C++
void piaCal3(
    PiaDataArray& widowArray,
    SecondaryArray& secondaryArray
);
Collapse Expand Parameters
Parameters | Description
PiaDataArray& widowArray | Widow and other family members' calculation data.
SecondaryArray& secondaryArray | Array of Secondary benefit data.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::qc3750simpCal Method

PiaCal::qc3750simpCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates simplified quarters of coverage, 1937-50.

C++
static int qc3750simpCal(
    double earn3750
);
Collapse Expand Parameters
Parameters | Description
double earn3750 | Total earnings in the period 1937-50.
Collapse Expand Returns

Simplified quarters of coverage, 1937-50.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::qcCal Method

PiaCal::qcCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates annual quarters of coverage and insured status.

C++
void qcCal();
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::qcCurrentCal Method

PiaCal::qcCurrentCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates quarters of coverage earned for currently insured status.

C++
static int qcCurrentCal(
    const PiaData& piaData,
    const QtrYear& qtrYear
);
Collapse Expand Parameters
Parameters | Description
const PiaData& piaData | Benefit calculation data.
const QtrYear& qtrYear | Calendar quarter and year through which qc's are required.
Collapse Expand Returns

Quarters of coverage earned for currently insured status.

Collapse Expand Remarks

Note that this is a static function.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::qcCurrentNonFreezeCal Method

PiaCal::qcCurrentNonFreezeCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates quarters of coverage earned for currently insured status for non-freeze.

C++
static int qcCurrentNonFreezeCal(
    const PiaData& piaData,
    const QtrYear& qtrYear
);
Collapse Expand Parameters
Parameters | Description
const PiaData& piaData | Benefit calculation data.
const QtrYear& qtrYear | Calendar quarter and year through which qc's are required.
Collapse Expand Returns

Quarters of coverage earned for currently insured status for non-freeze.

Collapse Expand Remarks

Note that this is a static function.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::qcReqCal Method

PiaCal::qcReqCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates required quarters of coverage for fully insured status at end of year.

C++
static int qcReqCal(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi,
    int year
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
PiaData& piaData | Benefit calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
int year | Year for which number is required.
Collapse Expand Returns

Required quarters of coverage for fully insured status at end of year.

Collapse Expand Remarks

Note that this is a static function.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::qcReqNonFreezeCal Method

PiaCal::qcReqNonFreezeCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates required quarters of coverage for fully insured status for non-freeze at end of year.

C++
static int qcReqNonFreezeCal(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi,
    int year
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
PiaData& piaData | Benefit calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
int year | Year for which number is required.
Collapse Expand Returns

Required quarters of coverage for fully insured status for non-freeze at end of year.

Collapse Expand Remarks

Note that this is a static function.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::qcReqPermCal Method

PiaCal::qcReqPermCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates required quarters of coverage for permanently insured status.

C++
static int qcReqPermCal(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
PiaData& piaData | Benefit calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
Collapse Expand Returns

Required quarters of coverage for permanently insured status.

Collapse Expand Remarks

Note that this is a static function.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::qcReqPermNonFreezeCal Method

PiaCal::qcReqPermNonFreezeCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates required quarters of coverage for permanently insured status for non-freeze.

C++
static int qcReqPermNonFreezeCal(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker's basic data.
PiaData& piaData | Benefit calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
Collapse Expand Returns

Required quarters of coverage for permanently insured status for non-freeze.

Collapse Expand Remarks

Note that this is a static function.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::reindWidCal Method

PiaCal::reindWidCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates PIA for one re-indexed widow(er).

C++
virtual void reindWidCal(
    const WorkerDataGeneral&,
    const PiaData&,
    Secondary&
) = 0;
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::reindWidCalAll Method

PiaCal::reindWidCalAll Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates PIA for all re-indexed widow(er)s.

C++
void reindWidCalAll(
    const WorkerDataArray& widowDataArray,
    PiaDataArray& widowArray,
    SecondaryArray& secondaryArray
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataArray& widowDataArray | Basic information for all family members.
PiaDataArray& widowArray | Calculated information for all family members.
SecondaryArray& secondaryArray | Benefits for all family members.
Collapse Expand Remarks

This should be called immediately after piaCal in survivor cases. (It doesn't hurt to call it in other than survivor cases, but it will simply return without doing anything.)

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::relEarnPositionCal Method

PiaCal::relEarnPositionCal Method
PiaCal Class PiaCal Members PiaCal Methods

Calculates relative earnings position.

C++
double relEarnPositionCal();
Collapse Expand Returns

Relative earnings position.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_RELERNPOS if first year of earnings is out of range (only in debug mode).
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::releaseMemory Method

PiaCal::releaseMemory Method
PiaCal Class PiaCal Members PiaCal Methods

Releases memory.

C++
void releaseMemory();
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::resetAmend90 Method

PiaCal::resetAmend90 Method
PiaCal Class PiaCal Members PiaCal Methods

Resets indicator for earnings used after 1991.

C++
void resetAmend90();
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::setAmend90 Method

PiaCal::setAmend90 Method
PiaCal Class PiaCal Members PiaCal Methods

Sets indicator for entitlement after 1990 amendments.

C++
void setAmend90(
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | Entitlement date.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::setArfApp Method

PiaCal::setArfApp Method
PiaCal Class PiaCal Members PiaCal Methods

Sets indicator for delayed retirement credit in special minimum case.

C++
void setArfApp();
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::setEligYearWidow Method

PiaCal::setEligYearWidow Method
PiaCal Class PiaCal Members PiaCal Methods

Sets eligibility year for widow.

C++
void setEligYearWidow(
    WorkerDataArray& widowDataArray,
    PiaDataArray& widowArray,
    SecondaryArray& secondaryArray
) const;
Collapse Expand Parameters
Parameters | Description
WorkerDataArray& widowDataArray | Basic information for all family members.
PiaDataArray& widowArray | Calculated data for all family members.
SecondaryArray& secondaryArray | Benefits for all family members.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::setHighMfb Method

PiaCal::setHighMfb Method
PiaCal Class PiaCal Members PiaCal Methods

Sets applicable mfb.

C++
void setHighMfb();
Collapse Expand Remarks

This should be called after the high pia is set. The mfb is based on the same type as the high pia, except when the high pia is based on the re-indexed widow(er) method. In that case, the high mfb is gotten from the wage-indexed method.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::setHighPia Method

PiaCal::setHighPia Method
PiaCal Class PiaCal Members PiaCal Methods

Sets applicable pia.

C++
void setHighPia();
Collapse Expand Remarks

This should be called after all the pia's have been calculated. It also sets the indicator for type of pia.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::setIoasdi Method

PiaCal::setIoasdi Method
PiaCal Class PiaCal Members PiaCal Methods

Sets the type of benefit.

C++
void setIoasdi(
    WorkerDataGeneral::ben_type ioasdit
);
Collapse Expand Parameters
Parameters | Description
WorkerDataGeneral::ben_type ioasdit | New type of benefit.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::setPebsAssumptions Method

PiaCal::setPebsAssumptions Method
PiaCal Class PiaCal Members PiaCal Methods

Sets Statement assumptions indicator.

C++
void setPebsAssumptions(
    bool newPebsAssumptions
);
Collapse Expand Parameters
Parameters | Description
bool newPebsAssumptions | True if old Statement assumptions (with 1-percent real wage gain).
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::setPifc Method

PiaCal::setPifc Method
PiaCal Class PiaCal Members PiaCal Methods

Sets applicable pifc.

C++
void setPifc();
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


PiaCal::setSupportPia Method

PiaCal::setSupportPia Method
PiaCal Class PiaCal Members PiaCal Methods

Sets support pia, if applicable pia is special minimum and there is delayed retirement credit involved.

C++
void setSupportPia();
Collapse Expand Remarks

Delayed retirement credit cannot be applied to a special minimum pia, but it can be applied to the support pia (the next-highest pia) when calculating the old-age benefit or widow(er) benefit.

Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Class, PiaCal Members, PiaCal Methods


widowCheck Method

widowCheck Method
PiaCal Methods

Checks disabled widow's date of disability.

Collapse Expand Description

There are two versions of the widowCheck function. The version with 2 arguments calls the version with 3 arguments.

Collapse Expand Overload List
Name | Description
PiaCal::widowCheck (WorkerDataGeneral&, Secondary&) | Checks disabled widow's date of disability.
PiaCal::widowCheck (const boost::gregorian::date&, const boost::gregorian::date&, const DateMoyr&) | Checks disabled widow's date of disability.
Collapse Expand Group

PiaCal Methods

Collapse Expand Links
PiaCal Methods


PiaCal::widowCheck Method (WorkerDataGeneral&, Secondary&)

PiaCal::widowCheck Method (WorkerDataGeneral&, Secondary&)
PiaCal Class PiaCal Members widowCheck Method

Checks disabled widow's date of disability.

C++
static void widowCheck(
    WorkerDataGeneral& widowData,
    Secondary& secondaryData
);
Collapse Expand Parameters
Parameters | Description
WorkerDataGeneral& widowData | Family member's information.
Secondary& secondaryData | Family member's benefit.
Collapse Expand Remarks

Calls the static version with 3 arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_JONSET5 if disability is before birth; of type PIA_IDS_JONSET6 if disability is after entitlement.
Collapse Expand Group

widowCheck Method

Collapse Expand Links
PiaCal Class, PiaCal Members, widowCheck Method


PiaCal::widowCheck Method (const boost::gregorian::date&, const boost::gregorian::date&, const DateMoyr&)

PiaCal::widowCheck Method (const boost::gregorian::date&, const boost::gregorian::date&, const DateMoyr&)
PiaCal Class PiaCal Members widowCheck Method

Checks disabled widow's date of disability.

C++
static void widowCheck(
    const boost::gregorian::date& jonsett,
    const boost::gregorian::date& jbirtht,
    const DateMoyr& ientt
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& jonsett | The date of disability onset.
const boost::gregorian::date& jbirtht | The date of birth.
const DateMoyr& ientt | The date of entitlement.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_JONSET5 if disability is before birth; of type PIA_IDS_JONSET6 if disability is after entitlement.
Collapse Expand Group

widowCheck Method

Collapse Expand Links
PiaCal Class, PiaCal Members, widowCheck Method


PiaCalAny Class

PiaCalAny Class
PiaCalAny Data Members PiaCalAny Methods PiaCalAny Members PiaCalAny.h Classes

Manages the additional functions required for calculation of a Social Security benefit in the Anypia program.

Collapse Expand Class Hierarchy
  PiaCalAnyPiaCalAnyPiaCalAny
C++
class PiaCalAny : public PiaCalLC;
Collapse Expand File

File: PiaCalAny.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in the Anypia program.

Collapse Expand Group

Classes

Collapse Expand Links
PiaCalAny Data Members, PiaCalAny Methods, PiaCalAny Members, PiaCalAny.h, Classes


PiaCalAny Members

PiaCalAny Members
PiaCalAny Class Legend Public Data Members Public Methods

The following tables list the members exposed by PiaCalAny.

Collapse Expand Class

PiaCalAny Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
childCareCalc | Pointer to child care calculation.
dibGuar | Pointer to disability guarantee.
earnProject | Projected earnings.
frozMin | Pointer to frozen minimum method.
highPiaMethod | Pointer to method with high pia.
oldStart | Pointer to old-start method.
piaData | Worker's pia calculation data.
piaMethod | Pia calculation methods that apply to all benies in the family.
piaParams | Pia calculation parameters.
piaTable | Pointer to pia table method.
secondaryArray | Array of Secondary benefits.
specMin | Pointer to special minimum method.
transGuar | Pointer to transitional guarantee.
userAssumptions | User-specified assumptions.
wageInd | Pointer to wage-indexed method.
wageIndNonFreeze | Pointer to wage-indexed non-freeze method.
widowArray | Widow and other family member calculation data.
widowDataArray | Widow and other family member calculation data.
widowMethod | Pia calculation methods that apply only to widow(er)s.
workerData | Worker's personal data.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PiaCalAny | Initializes a PiaCalAny instance.
ageEntCheck | Checks date of entitlement for a primary benie.
applyLifeMfb | Applies maximum family benefit to family's benefits in a life case.
applyMfb | Applies maximum family benefit to each family benefit, after ratio has been determined.
applySurvivorMfb | Applies maximum family benefit to family's benefits in a survivor case.
ardriAuxCal | Calculates the benefit factor and number of months of early or delayed retirement for a dependent or survivor.
ardriCal | Calculates the number of months of early or delayed retirement for a primary benie.
calculate1 | Calculates preparatory variables.
calculate2 | Calculates PIA and benefit.
childCareCreditCal | Sets best child care years to use, using passed arguments rather than member variables.
childCareEarningsCal | Adds childcare credits into regular OASDI earnings, using passed arguments rather than member variables.
childCareMaxCreditCal | Calculates the maximum child care credit.
childCareQcCal | Adjusts QCs for child care credits, using passed arguments rather than member variables.
dataCheck | Checks primary data for validity and does some preliminary calculations.
dataCheckAux | Checks auxiliary data for validity and does some preliminary calculations.
deadIns | Returns the insured status code for a deceased worker.
deemedInsCal | Checks for deemed insured status, assuming eligible for deemed insured status provision to apply.
didropCal | Calculates number of years to drop out of elapsed period due to disability.
didropNonFreezeCal | Calculates number of years to drop out of elapsed period for fully insured status due to disability in a non-freeze computation.
disInsCal | Calculates the disability insured status code for one year.
disInsNonFreezeCal | Calculates the disability insured status code for non-freeze for one year.
earnProSteady | Projects steady earnings.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
earnProjectionStatic | Projects earnings and fills in earnings to be used in calculations, using passed arguments rather than member variables.
eligYearCal | Computes year of eligibility.
eligYearCal1 | Computes date of eligibility before considering disability.
eligYearCal2 | Computes year of eligibility after considering disability.
eligYearCal3 | Computes year of eligibility for non-freeze computations.
eligYearWidowCal | Returns eligibility year for widow(er).
fins1Cal | Calculates and returns the insured status code for one date.
fins2Cal | Calculates and returns the OACT insured status code for one date.
finsNonFreeze1Cal | Calculates and returns the insured status code for non-freeze for one date.
finsNonFreeze2Cal | Calculates and returns the OACT insured status code for non-freeze for one date.
fullInsDateCal | Calculates the date fully insured status was first attained (at full retirement age or later).
getIoasdi | Returns type of benefit.
getPubpenEnable | Returns true if ok to enable noncovered pension entry box.
insCal | Calculates the insured status code for one date.
insNonFreezeCal | This is the overview for the insNonFreezeCal method overload.
isPebsAssumptions | Returns Statement assumptions indicator.
monthsArAgedSpouseCal | Calculates full benefit factor and number of months of actuarial reduction for aged wife or husband and sets reduction factor.
monthsArCal | Calculates number of months of actuarial reduction for OAB and sets reduction factor.
monthsArDICal | Calculates number of months of actuarial reduction for DIB and sets reduction factor.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er) and sets reduction factor.
monthsArWidCal | Calculates full benefit factor and number of months of actuarial reduction for aged widow(er) and sets reduction factor.
monthsDriCal | Calculates number of months of delayed retirement credit for OAB and sets increment factor.
monthsYngLifeCal | Calculates number of months of actuarial reduction for young auxiliary and sets benefit factor.
monthsYngSurvCal | Calculates number of months of actuarial reduction for young survivor and sets benefit factor.
nCal | Determine number of computation years and dropout years.
nCal | Determine number of computation years and dropout years.
nDropCal | Determine number of dropout years, before considering 1-for-5 dropout.
nDropNonFreezeCal | Determine number of dropout years, before considering 1-for-5 dropout.
nNonFreezeCal | Determine number of computation years and dropout years.
nelapsed2Cal | Returns ending elapsed year for a beneficiary case.
nelapsed2Cal | Returns ending elapsed year for a beneficiary case.
nelapsed2NonFreezeCal | Returns ending elapsed year for a non-freeze case.
nelapsed2NonFreezeCal | Returns ending elapsed year for a beneficiary case.
nelapsedCal | Determine number of elapsed years.
nelapsedNonFreezeCal | This is the overview for the nelapsedNonFreezeCal method overload.
pebsOabCal | Calculates number of old-age calculations to do.
pebsSetup | Sets information for Statement case.
piaCal | Calculates PIA and MFB, not including re-indexed widow(er).
piaCal | Calculates PIA and MFB, not including re-indexed widow(er).
piaCal1 | Figures high pia and mfb.
piaCal2 | Figures benefit for primary.
piaCal3 | Figures benefits for auxiliaries.
qc3750simpCal | Calculates simplified quarters of coverage, 1937-50.
qcCal | Calculates annual quarters of coverage and insured status.
qcCurrentCal | Calculates quarters of coverage earned for currently insured status.
qcCurrentNonFreezeCal | Calculates quarters of coverage earned for currently insured status for non-freeze.
qcReqCal | Calculates required quarters of coverage for fully insured status at end of year.
qcReqNonFreezeCal | Calculates required quarters of coverage for fully insured status for non-freeze at end of year.
qcReqPermCal | Calculates required quarters of coverage for permanently insured status.
qcReqPermNonFreezeCal | Calculates required quarters of coverage for permanently insured status for non-freeze.
reindWidCal | Calculates PIA for one re-indexed widow(er).
reindWidCal | Calculates PIA for one re-indexed widow(er).
reindWidCalAll | Calculates PIA for all re-indexed widow(er)s.
relEarnPositionCal | Calculates relative earnings position.
releaseMemory | Releases memory.
resetAmend90 | Resets indicator for earnings used after 1991.
setAmend90 | Sets indicator for entitlement after 1990 amendments.
setArfApp | Sets indicator for delayed retirement credit in special minimum case.
setEligYearWidow | Sets eligibility year for widow.
setHighMfb | Sets applicable mfb.
setHighPia | Sets applicable pia.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPifc | Sets applicable pifc.
setSupportPia | Sets support pia, if applicable pia is special minimum and there is delayed retirement credit involved.
widowCheck | Checks disabled widow's date of disability.
~PiaCalAny | Destructor.
Collapse Expand Links
PiaCalAny Class, Legend, Public Data Members, Public Methods


PiaCalAny::PiaCalAny Constructor

PiaCalAny::PiaCalAny Constructor
PiaCalAny Class PiaCalAny Members PiaCalAny Class

Initializes a PiaCalAny instance.

C++
PiaCalAny(
    WorkerDataGeneral& newWorkerData,
    PiaData& newPiaData,
    WorkerDataArray& newWidowDataArray,
    PiaDataArray& newWidowArray,
    PiaParamsAny& newPiaParamsAny,
    UserAssumptions& newUserAssumptions,
    SecondaryArray& newSecondary,
    const LawChangeArray& newLawChange,
    Pebs& newPebs,
    EarnProject& newEarnProject
);
Collapse Expand Parameters
Parameters | Description
WorkerDataGeneral& newWorkerData | Worker's basic data.
PiaData& newPiaData | Worker's calculation data.
WorkerDataArray& newWidowDataArray | Widow and other family members' basic data.
PiaDataArray& newWidowArray | Widow and other family members' calculation data.
PiaParamsAny& newPiaParamsAny | Pia calculation parameters.
UserAssumptions& newUserAssumptions | User-specified assumptions.
SecondaryArray& newSecondary | Array of Secondary benefits.
const LawChangeArray& newLawChange | Law change parameters.
Pebs& newPebs | Statement information.
EarnProject& newEarnProject | Projected earnings information.
Collapse Expand Class

PiaCalAny Class

Collapse Expand Links
PiaCalAny Class, PiaCalAny Members, PiaCalAny Class


PiaCalAny::~PiaCalAny Destructor

PiaCalAny::~PiaCalAny Destructor
PiaCalAny Class PiaCalAny Members PiaCalAny Class

Destructor.

C++
~PiaCalAny();
Collapse Expand Class

PiaCalAny Class

Collapse Expand Links
PiaCalAny Class, PiaCalAny Members, PiaCalAny Class


PiaCalAny Data Members

PiaCalAny Data Members
PiaCalAny Class Legend Public Data Members

The data members of the PiaCalAny class are listed here.

Collapse Expand Class

PiaCalAny Class

Collapse Expand Public Data Members
Name | Description
earnProject | Projected earnings.
secondaryArray | Array of Secondary benefits.
userAssumptions | User-specified assumptions.
widowArray | Widow and other family member calculation data.
widowDataArray | Widow and other family member calculation data.
Collapse Expand Links
PiaCalAny Class, Legend, Public Data Members


PiaCalAny::earnProject Data Member

PiaCalAny::earnProject Data Member
PiaCalAny Class PiaCalAny Members PiaCalAny Data Members

Projected earnings.

C++
EarnProject& earnProject;
Collapse Expand Group

PiaCalAny Data Members

Collapse Expand Links
PiaCalAny Class, PiaCalAny Members, PiaCalAny Data Members


PiaCalAny::secondaryArray Data Member

PiaCalAny::secondaryArray Data Member
PiaCalAny Class PiaCalAny Members PiaCalAny Data Members

Array of Secondary benefits.

C++
SecondaryArray& secondaryArray;
Collapse Expand Group

PiaCalAny Data Members

Collapse Expand Links
PiaCalAny Class, PiaCalAny Members, PiaCalAny Data Members


PiaCalAny::userAssumptions Data Member

PiaCalAny::userAssumptions Data Member
PiaCalAny Class PiaCalAny Members PiaCalAny Data Members

User-specified assumptions.

C++
UserAssumptions& userAssumptions;
Collapse Expand Group

PiaCalAny Data Members

Collapse Expand Links
PiaCalAny Class, PiaCalAny Members, PiaCalAny Data Members


PiaCalAny::widowArray Data Member

PiaCalAny::widowArray Data Member
PiaCalAny Class PiaCalAny Members PiaCalAny Data Members

Widow and other family member calculation data.

C++
PiaDataArray& widowArray;
Collapse Expand Group

PiaCalAny Data Members

Collapse Expand Links
PiaCalAny Class, PiaCalAny Members, PiaCalAny Data Members


PiaCalAny::widowDataArray Data Member

PiaCalAny::widowDataArray Data Member
PiaCalAny Class PiaCalAny Members PiaCalAny Data Members

Widow and other family member calculation data.

C++
WorkerDataArray& widowDataArray;
Collapse Expand Group

PiaCalAny Data Members

Collapse Expand Links
PiaCalAny Class, PiaCalAny Members, PiaCalAny Data Members


PiaCalAny Methods

PiaCalAny Methods
PiaCalAny Class Legend Public Methods

The methods of the PiaCalAny class are listed here.

Collapse Expand Class

PiaCalAny Class

Collapse Expand Public Methods
Name | Description
calculate1 | Calculates preparatory variables.
calculate2 | Calculates PIA and benefit.
dataCheck | Checks primary data for validity and does some preliminary calculations.
earnProSteady | Projects steady earnings.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
pebsOabCal | Calculates number of old-age calculations to do.
pebsSetup | Sets information for Statement case.
Collapse Expand Links
PiaCalAny Class, Legend, Public Methods


PiaCalAny::calculate1 Method

PiaCalAny::calculate1 Method
PiaCalAny Class PiaCalAny Members PiaCalAny Methods

Calculates preparatory variables.

C++
void calculate1(
    Assumptions& assumptions
);
Collapse Expand Parameters
Parameters | Description
Assumptions& assumptions | Stored benefit increase and average wage assumptions.
Collapse Expand Group

PiaCalAny Methods

Collapse Expand Links
PiaCalAny Class, PiaCalAny Members, PiaCalAny Methods


PiaCalAny::calculate2 Method

PiaCalAny::calculate2 Method
PiaCalAny Class PiaCalAny Members PiaCalAny Methods

Calculates PIA and benefit.

C++
void calculate2(
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | The date of entitlement.
Collapse Expand Group

PiaCalAny Methods

Collapse Expand Links
PiaCalAny Class, PiaCalAny Members, PiaCalAny Methods


PiaCalAny::dataCheck Method

PiaCalAny::dataCheck Method
PiaCalAny Class PiaCalAny Members PiaCalAny Methods

Checks primary data for validity and does some preliminary calculations.

C++
void dataCheck(
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | Entitlement date.
Collapse Expand Group

PiaCalAny Methods

Collapse Expand Links
PiaCalAny Class, PiaCalAny Members, PiaCalAny Methods


PiaCalAny::earnProSteady Method

PiaCalAny::earnProSteady Method
PiaCalAny Class PiaCalAny Members PiaCalAny Methods

Projects steady earnings.

C++
void earnProSteady();
Collapse Expand Group

PiaCalAny Methods

Collapse Expand Links
PiaCalAny Class, PiaCalAny Members, PiaCalAny Methods


PiaCalAny::earnProjection Method

PiaCalAny::earnProjection Method
PiaCalAny Class PiaCalAny Members PiaCalAny Methods

Projects earnings and fills in earnings to be used in calculations.

C++
void earnProjection() const;
Collapse Expand Group

PiaCalAny Methods

Collapse Expand Links
PiaCalAny Class, PiaCalAny Members, PiaCalAny Methods


PiaCalAny::pebsOabCal Method

PiaCalAny::pebsOabCal Method
PiaCalAny Class PiaCalAny Members PiaCalAny Methods

Calculates number of old-age calculations to do.

C++
void pebsOabCal();
Collapse Expand Group

PiaCalAny Methods

Collapse Expand Links
PiaCalAny Class, PiaCalAny Members, PiaCalAny Methods


PiaCalAny::pebsSetup Method

PiaCalAny::pebsSetup Method
PiaCalAny Class PiaCalAny Members PiaCalAny Methods

Sets information for Statement case.

C++
void pebsSetup(
    Pebs::pebes_type type,
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
Pebs::pebes_type type | Statement case number.
const DateMoyr& entDate | Entitlement date.
Collapse Expand Group

PiaCalAny Methods

Collapse Expand Links
PiaCalAny Class, PiaCalAny Members, PiaCalAny Methods


PiaCalLC Class

PiaCalLC Class
PiaCalLC Methods PiaCalLC Members PiaCalLC.h Classes

Manages all of the law-change functions required for calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  PiaCalLCPiaCalLC
C++
class PiaCalLC : public PiaCal;
Collapse Expand File

File: PiaCalLC.h

Module: PiaData Library

Collapse Expand Remarks

Manages all of the law-change functions required for calculation of a Social Security benefit.

Collapse Expand Group

Classes

Collapse Expand Links
PiaCalLC Methods, PiaCalLC Members, PiaCalLC.h, Classes


PiaCalLC Members

PiaCalLC Members
PiaCalLC Class Legend Public Data Members Public Methods

The following tables list the members exposed by PiaCalLC.

Collapse Expand Class

PiaCalLC Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
childCareCalc | Pointer to child care calculation.
dibGuar | Pointer to disability guarantee.
frozMin | Pointer to frozen minimum method.
highPiaMethod | Pointer to method with high pia.
oldStart | Pointer to old-start method.
piaData | Worker's pia calculation data.
piaMethod | Pia calculation methods that apply to all benies in the family.
piaParams | Pia calculation parameters.
piaTable | Pointer to pia table method.
specMin | Pointer to special minimum method.
transGuar | Pointer to transitional guarantee.
wageInd | Pointer to wage-indexed method.
wageIndNonFreeze | Pointer to wage-indexed non-freeze method.
widowMethod | Pia calculation methods that apply only to widow(er)s.
workerData | Worker's personal data.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PiaCalLC | Initializes a PiaCalLC instance.
ageEntCheck | Checks date of entitlement for a primary benie.
applyLifeMfb | Applies maximum family benefit to family's benefits in a life case.
applyMfb | Applies maximum family benefit to each family benefit, after ratio has been determined.
applySurvivorMfb | Applies maximum family benefit to family's benefits in a survivor case.
ardriAuxCal | Calculates the benefit factor and number of months of early or delayed retirement for a dependent or survivor.
ardriCal | Calculates the number of months of early or delayed retirement for a primary benie.
calculate2 | Calculates PIA and benefit.
childCareCreditCal | Sets best child care years to use, using passed arguments rather than member variables.
childCareEarningsCal | Adds childcare credits into regular OASDI earnings, using passed arguments rather than member variables.
childCareMaxCreditCal | Calculates the maximum child care credit.
childCareQcCal | Adjusts QCs for child care credits, using passed arguments rather than member variables.
dataCheck | Checks primary data for validity and does some preliminary calculations.
dataCheckAux | Checks auxiliary data for validity and does some preliminary calculations.
deadIns | Returns the insured status code for a deceased worker.
deemedInsCal | Checks for deemed insured status, assuming eligible for deemed insured status provision to apply.
didropCal | Calculates number of years to drop out of elapsed period due to disability.
didropNonFreezeCal | Calculates number of years to drop out of elapsed period for fully insured status due to disability in a non-freeze computation.
disInsCal | Calculates the disability insured status code for one year.
disInsNonFreezeCal | Calculates the disability insured status code for non-freeze for one year.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
earnProjectionStatic | Projects earnings and fills in earnings to be used in calculations, using passed arguments rather than member variables.
eligYearCal | Computes year of eligibility.
eligYearCal1 | Computes date of eligibility before considering disability.
eligYearCal2 | Computes year of eligibility after considering disability.
eligYearCal3 | Computes year of eligibility for non-freeze computations.
eligYearWidowCal | Returns eligibility year for widow(er).
fins1Cal | Calculates and returns the insured status code for one date.
fins2Cal | Calculates and returns the OACT insured status code for one date.
finsNonFreeze1Cal | Calculates and returns the insured status code for non-freeze for one date.
finsNonFreeze2Cal | Calculates and returns the OACT insured status code for non-freeze for one date.
fullInsDateCal | Calculates the date fully insured status was first attained (at full retirement age or later).
getIoasdi | Returns type of benefit.
getPubpenEnable | Returns true if ok to enable noncovered pension entry box.
insCal | Calculates the insured status code for one date.
insNonFreezeCal | This is the overview for the insNonFreezeCal method overload.
isPebsAssumptions | Returns Statement assumptions indicator.
monthsArAgedSpouseCal | Calculates full benefit factor and number of months of actuarial reduction for aged wife or husband and sets reduction factor.
monthsArCal | Calculates number of months of actuarial reduction for OAB and sets reduction factor.
monthsArDICal | Calculates number of months of actuarial reduction for DIB and sets reduction factor.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er) and sets reduction factor.
monthsArWidCal | Calculates full benefit factor and number of months of actuarial reduction for aged widow(er) and sets reduction factor.
monthsDriCal | Calculates number of months of delayed retirement credit for OAB and sets increment factor.
monthsYngLifeCal | Calculates number of months of actuarial reduction for young auxiliary and sets benefit factor.
monthsYngSurvCal | Calculates number of months of actuarial reduction for young survivor and sets benefit factor.
nCal | Determine number of computation years and dropout years.
nDropCal | Determine number of dropout years, before considering 1-for-5 dropout.
nDropNonFreezeCal | Determine number of dropout years, before considering 1-for-5 dropout.
nNonFreezeCal | Determine number of computation years and dropout years.
nelapsed2Cal | Returns ending elapsed year for a beneficiary case.
nelapsed2NonFreezeCal | Returns ending elapsed year for a beneficiary case.
nelapsedCal | Determine number of elapsed years.
nelapsedNonFreezeCal | This is the overview for the nelapsedNonFreezeCal method overload.
piaCal | Calculates PIA and MFB, not including re-indexed widow(er).
piaCal1 | Figures high pia and mfb.
piaCal2 | Figures benefit for primary.
piaCal3 | Figures benefits for auxiliaries.
qc3750simpCal | Calculates simplified quarters of coverage, 1937-50.
qcCal | Calculates annual quarters of coverage and insured status.
qcCurrentCal | Calculates quarters of coverage earned for currently insured status.
qcCurrentNonFreezeCal | Calculates quarters of coverage earned for currently insured status for non-freeze.
qcReqCal | Calculates required quarters of coverage for fully insured status at end of year.
qcReqNonFreezeCal | Calculates required quarters of coverage for fully insured status for non-freeze at end of year.
qcReqPermCal | Calculates required quarters of coverage for permanently insured status.
qcReqPermNonFreezeCal | Calculates required quarters of coverage for permanently insured status for non-freeze.
reindWidCal | Calculates PIA for one re-indexed widow(er).
reindWidCalAll | Calculates PIA for all re-indexed widow(er)s.
relEarnPositionCal | Calculates relative earnings position.
releaseMemory | Releases memory.
resetAmend90 | Resets indicator for earnings used after 1991.
setAmend90 | Sets indicator for entitlement after 1990 amendments.
setArfApp | Sets indicator for delayed retirement credit in special minimum case.
setEligYearWidow | Sets eligibility year for widow.
setHighMfb | Sets applicable mfb.
setHighPia | Sets applicable pia.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPifc | Sets applicable pifc.
setSupportPia | Sets support pia, if applicable pia is special minimum and there is delayed retirement credit involved.
widowCheck | Checks disabled widow's date of disability.
~PiaCalLC | Destructor.
Collapse Expand Links
PiaCalLC Class, Legend, Public Data Members, Public Methods


PiaCalLC::PiaCalLC Constructor

PiaCalLC::PiaCalLC Constructor
PiaCalLC Class PiaCalLC Members PiaCalLC Class

Initializes a PiaCalLC instance.

C++
PiaCalLC(
    WorkerDataGeneral& newWorkerData,
    PiaData& newPiaData,
    const PiaParams& newPiaParams,
    const LawChangeArray& newLawChange
);
Collapse Expand Parameters
Parameters | Description
WorkerDataGeneral& newWorkerData | Worker's basic data.
PiaData& newPiaData | Worker's calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
const LawChangeArray& newLawChange | Law change parameters.
Collapse Expand Class

PiaCalLC Class

Collapse Expand Links
PiaCalLC Class, PiaCalLC Members, PiaCalLC Class


PiaCalLC::~PiaCalLC Destructor

PiaCalLC::~PiaCalLC Destructor
PiaCalLC Class PiaCalLC Members PiaCalLC Class

Destructor.

C++
~PiaCalLC();
Collapse Expand Remarks

Calls releaseMemory.

Collapse Expand Class

PiaCalLC Class

Collapse Expand Links
PiaCalLC Class, PiaCalLC Members, PiaCalLC Class


PiaCalLC Methods

PiaCalLC Methods
PiaCalLC Class Legend Public Methods

The methods of the PiaCalLC class are listed here.

Collapse Expand Class

PiaCalLC Class

Collapse Expand Public Methods
Name | Description
calculate2 | Calculates PIA and benefit.
childCareCreditCal | Sets best child care years to use, using passed arguments rather than member variables.
childCareEarningsCal | Adds childcare credits into regular OASDI earnings, using passed arguments rather than member variables.
childCareMaxCreditCal | Calculates the maximum child care credit.
childCareQcCal | Adjusts QCs for child care credits, using passed arguments rather than member variables.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
earnProjectionStatic | Projects earnings and fills in earnings to be used in calculations, using passed arguments rather than member variables.
nCal | Determine number of computation years and dropout years.
nelapsed2Cal | Returns ending elapsed year for a beneficiary case.
nelapsed2NonFreezeCal | Returns ending elapsed year for a beneficiary case.
piaCal | Calculates PIA and MFB, not including re-indexed widow(er).
reindWidCal | Calculates PIA for one re-indexed widow(er).
Collapse Expand Links
PiaCalLC Class, Legend, Public Methods


PiaCalLC::calculate2 Method

PiaCalLC::calculate2 Method
PiaCalLC Class PiaCalLC Members PiaCalLC Methods

Calculates PIA and benefit.

C++
void calculate2(
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | The date of entitlement.
Collapse Expand Group

PiaCalLC Methods

Collapse Expand Links
PiaCalLC Class, PiaCalLC Members, PiaCalLC Methods


PiaCalLC::childCareCreditCal Method

PiaCalLC::childCareCreditCal Method
PiaCalLC Class PiaCalLC Members PiaCalLC Methods

Sets best child care years to use, using passed arguments rather than member variables.

C++
static void childCareCreditCal(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    const PiaParams& piaParams,
    const LawChangeArray& lawChange
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
PiaData& piaData | Benefit calculation data.
const PiaParams& piaParams | Benefit calculation parameters.
const LawChangeArray& lawChange | Law-change parameters.
Collapse Expand Remarks

Note that this function is static.

Collapse Expand Group

PiaCalLC Methods

Collapse Expand Links
PiaCalLC Class, PiaCalLC Members, PiaCalLC Methods


PiaCalLC::childCareEarningsCal Method

PiaCalLC::childCareEarningsCal Method
PiaCalLC Class PiaCalLC Members PiaCalLC Methods

Adds childcare credits into regular OASDI earnings, using passed arguments rather than member variables.

C++
static void childCareEarningsCal(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    const LawChangeArray& lawChange
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
PiaData& piaData | Benefit calculation data.
const LawChangeArray& lawChange | Law-change parameters.
Collapse Expand Remarks

Note that this function is static.

Collapse Expand Group

PiaCalLC Methods

Collapse Expand Links
PiaCalLC Class, PiaCalLC Members, PiaCalLC Methods


PiaCalLC::childCareMaxCreditCal Method

PiaCalLC::childCareMaxCreditCal Method
PiaCalLC Class PiaCalLC Members PiaCalLC Methods

Calculates the maximum child care credit.

C++
static double childCareMaxCreditCal(
    const WorkerDataGeneral& workerData,
    const DoubleAnnual& earnOasdi,
    const AverageWage& awi,
    const LawChangeCHILDCARECREDIT& lawChange,
    int year
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
const DoubleAnnual& earnOasdi | OASDI covered earnings.
const AverageWage& awi | Average wage indexing array.
const LawChangeCHILDCARECREDIT& lawChange | Law-change parameters for CHILDCARECREDIT.
int year | The year being considered.
Collapse Expand Returns

The maximum child care credit.

Collapse Expand Remarks

Note that this function is static.

Collapse Expand Group

PiaCalLC Methods

Collapse Expand Links
PiaCalLC Class, PiaCalLC Members, PiaCalLC Methods


PiaCalLC::childCareQcCal Method

PiaCalLC::childCareQcCal Method
PiaCalLC Class PiaCalLC Members PiaCalLC Methods

Adjusts QCs for child care credits, using passed arguments rather than member variables.

C++
static void childCareQcCal(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    const PiaParams& piaParams,
    const LawChangeArray& lawChange
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
PiaData& piaData | Benefit calculation data.
const PiaParams& piaParams | Benefit calculation parameters.
const LawChangeArray& lawChange | Law-change parameters.
Collapse Expand Remarks

Note that this function is static.

Collapse Expand Group

PiaCalLC Methods

Collapse Expand Links
PiaCalLC Class, PiaCalLC Members, PiaCalLC Methods


PiaCalLC::earnProjection Method

PiaCalLC::earnProjection Method
PiaCalLC Class PiaCalLC Members PiaCalLC Methods

Projects earnings and fills in earnings to be used in calculations.

C++
void earnProjection() const;
Collapse Expand Group

PiaCalLC Methods

Collapse Expand Links
PiaCalLC Class, PiaCalLC Members, PiaCalLC Methods


PiaCalLC::earnProjectionStatic Method

PiaCalLC::earnProjectionStatic Method
PiaCalLC Class PiaCalLC Members PiaCalLC Methods

Projects earnings and fills in earnings to be used in calculations, using passed arguments rather than member variables.

C++
static void earnProjectionStatic(
    const WorkerDataGeneral& workerData,
    PiaData& piaData,
    const PiaParams& piaParams,
    const LawChangeArray& lawChange
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
PiaData& piaData | Benefit calculation data.
const PiaParams& piaParams | Benefit calculation parameters.
const LawChangeArray& lawChange | Law-change parameters.
Collapse Expand Remarks

Note that this function is static.

Collapse Expand Group

PiaCalLC Methods

Collapse Expand Links
PiaCalLC Class, PiaCalLC Members, PiaCalLC Methods


PiaCalLC::nCal Method

PiaCalLC::nCal Method
PiaCalLC Class PiaCalLC Members PiaCalLC Methods

Determine number of computation years and dropout years.

C++
void nCal(
    CompPeriod& compPeriod,
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
CompPeriod& compPeriod | Computation period to use (new or old).
const DateMoyr& entDate | Entitlement date.
Collapse Expand Group

PiaCalLC Methods

Collapse Expand Links
PiaCalLC Class, PiaCalLC Members, PiaCalLC Methods


PiaCalLC::nelapsed2Cal Method

PiaCalLC::nelapsed2Cal Method
PiaCalLC Class PiaCalLC Members PiaCalLC Methods

Returns ending elapsed year for a beneficiary case.

C++
int nelapsed2Cal(
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | The date of entitlement.
Collapse Expand Returns

Ending elapsed year for a beneficiary case.

Collapse Expand Group

PiaCalLC Methods

Collapse Expand Links
PiaCalLC Class, PiaCalLC Members, PiaCalLC Methods


PiaCalLC::nelapsed2NonFreezeCal Method

PiaCalLC::nelapsed2NonFreezeCal Method
PiaCalLC Class PiaCalLC Members PiaCalLC Methods

Returns ending elapsed year for a beneficiary case.

C++
int nelapsed2NonFreezeCal(
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | The date of entitlement.
Collapse Expand Returns

Ending elapsed year for a beneficiary case.

Collapse Expand Group

PiaCalLC Methods

Collapse Expand Links
PiaCalLC Class, PiaCalLC Members, PiaCalLC Methods


PiaCalLC::piaCal Method

PiaCalLC::piaCal Method
PiaCalLC Class PiaCalLC Members PiaCalLC Methods

Calculates PIA and MFB, not including re-indexed widow(er).

C++
void piaCal(
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | The date of entitlement.
Collapse Expand Group

PiaCalLC Methods

Collapse Expand Links
PiaCalLC Class, PiaCalLC Members, PiaCalLC Methods


PiaCalLC::reindWidCal Method

PiaCalLC::reindWidCal Method
PiaCalLC Class PiaCalLC Members PiaCalLC Methods

Calculates PIA for one re-indexed widow(er).

C++
void reindWidCal(
    const WorkerDataGeneral& widowData,
    const PiaData& widowPiaData,
    Secondary& secondary
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& widowData | Widow(er) basic data.
const PiaData& widowPiaData | Calculation information for widow(er).
Secondary& secondary | Benefits for widow(er).
Collapse Expand Group

PiaCalLC Methods

Collapse Expand Links
PiaCalLC Class, PiaCalLC Members, PiaCalLC Methods


PiaCalPL Class

PiaCalPL Class
PiaCalPL Methods PiaCalPL Members PiaCalPL.h Classes

Manages all of the present law functions required for calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  PiaCalPLPiaCalPL
C++
class PiaCalPL : public PiaCal;
Collapse Expand File

File: PiaCalPL.h

Module: PiaData Library

Collapse Expand Remarks

Manages all of the present law functions required for calculation of a Social Security benefit.

Collapse Expand Group

Classes

Collapse Expand Links
PiaCalPL Methods, PiaCalPL Members, PiaCalPL.h, Classes


PiaCalPL Members

PiaCalPL Members
PiaCalPL Class Legend Public Data Members Public Methods

The following tables list the members exposed by PiaCalPL.

Collapse Expand Class

PiaCalPL Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
childCareCalc | Pointer to child care calculation.
dibGuar | Pointer to disability guarantee.
frozMin | Pointer to frozen minimum method.
highPiaMethod | Pointer to method with high pia.
oldStart | Pointer to old-start method.
piaData | Worker's pia calculation data.
piaMethod | Pia calculation methods that apply to all benies in the family.
piaParams | Pia calculation parameters.
piaTable | Pointer to pia table method.
specMin | Pointer to special minimum method.
transGuar | Pointer to transitional guarantee.
wageInd | Pointer to wage-indexed method.
wageIndNonFreeze | Pointer to wage-indexed non-freeze method.
widowMethod | Pia calculation methods that apply only to widow(er)s.
workerData | Worker's personal data.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PiaCalPL | Initializes this instance.
ageEntCheck | Checks date of entitlement for a primary benie.
applyLifeMfb | Applies maximum family benefit to family's benefits in a life case.
applyMfb | Applies maximum family benefit to each family benefit, after ratio has been determined.
applySurvivorMfb | Applies maximum family benefit to family's benefits in a survivor case.
ardriAuxCal | Calculates the benefit factor and number of months of early or delayed retirement for a dependent or survivor.
ardriCal | Calculates the number of months of early or delayed retirement for a primary benie.
calculate2 | Calculates PIA and benefit.
dataCheck | Checks primary data for validity and does some preliminary calculations.
dataCheckAux | Checks auxiliary data for validity and does some preliminary calculations.
deadIns | Returns the insured status code for a deceased worker.
deemedInsCal | Checks for deemed insured status, assuming eligible for deemed insured status provision to apply.
didropCal | Calculates number of years to drop out of elapsed period due to disability.
didropNonFreezeCal | Calculates number of years to drop out of elapsed period for fully insured status due to disability in a non-freeze computation.
disInsCal | Calculates the disability insured status code for one year.
disInsNonFreezeCal | Calculates the disability insured status code for non-freeze for one year.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
eligYearCal | Computes year of eligibility.
eligYearCal1 | Computes date of eligibility before considering disability.
eligYearCal2 | Computes year of eligibility after considering disability.
eligYearCal3 | Computes year of eligibility for non-freeze computations.
eligYearWidowCal | Returns eligibility year for widow(er).
fins1Cal | Calculates and returns the insured status code for one date.
fins2Cal | Calculates and returns the OACT insured status code for one date.
finsNonFreeze1Cal | Calculates and returns the insured status code for non-freeze for one date.
finsNonFreeze2Cal | Calculates and returns the OACT insured status code for non-freeze for one date.
fullInsDateCal | Calculates the date fully insured status was first attained (at full retirement age or later).
getIoasdi | Returns type of benefit.
getPubpenEnable | Returns true if ok to enable noncovered pension entry box.
insCal | Calculates the insured status code for one date.
insNonFreezeCal | This is the overview for the insNonFreezeCal method overload.
isPebsAssumptions | Returns Statement assumptions indicator.
monthsArAgedSpouseCal | Calculates full benefit factor and number of months of actuarial reduction for aged wife or husband and sets reduction factor.
monthsArCal | Calculates number of months of actuarial reduction for OAB and sets reduction factor.
monthsArDICal | Calculates number of months of actuarial reduction for DIB and sets reduction factor.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er) and sets reduction factor.
monthsArWidCal | Calculates full benefit factor and number of months of actuarial reduction for aged widow(er) and sets reduction factor.
monthsDriCal | Calculates number of months of delayed retirement credit for OAB and sets increment factor.
monthsYngLifeCal | Calculates number of months of actuarial reduction for young auxiliary and sets benefit factor.
monthsYngSurvCal | Calculates number of months of actuarial reduction for young survivor and sets benefit factor.
nCal | Determine number of computation years and dropout years.
nDropCal | Determine number of dropout years, before considering 1-for-5 dropout.
nDropNonFreezeCal | Determine number of dropout years, before considering 1-for-5 dropout.
nNonFreezeCal | Determine number of computation years and dropout years.
nelapsed2Cal | Returns ending elapsed year for a beneficiary case.
nelapsed2NonFreezeCal | Returns ending elapsed year for a non-freeze case.
nelapsedCal | Determine number of elapsed years.
nelapsedNonFreezeCal | This is the overview for the nelapsedNonFreezeCal method overload.
piaCal | Calculates PIA and MFB, not including re-indexed widow(er).
piaCal1 | Figures high pia and mfb.
piaCal2 | Figures benefit for primary.
piaCal3 | Figures benefits for auxiliaries.
qc3750simpCal | Calculates simplified quarters of coverage, 1937-50.
qcCal | Calculates annual quarters of coverage and insured status.
qcCurrentCal | Calculates quarters of coverage earned for currently insured status.
qcCurrentNonFreezeCal | Calculates quarters of coverage earned for currently insured status for non-freeze.
qcReqCal | Calculates required quarters of coverage for fully insured status at end of year.
qcReqNonFreezeCal | Calculates required quarters of coverage for fully insured status for non-freeze at end of year.
qcReqPermCal | Calculates required quarters of coverage for permanently insured status.
qcReqPermNonFreezeCal | Calculates required quarters of coverage for permanently insured status for non-freeze.
reindWidCal | Calculates PIA for one re-indexed widow(er).
reindWidCalAll | Calculates PIA for all re-indexed widow(er)s.
relEarnPositionCal | Calculates relative earnings position.
releaseMemory | Releases memory.
resetAmend90 | Resets indicator for earnings used after 1991.
setAmend90 | Sets indicator for entitlement after 1990 amendments.
setArfApp | Sets indicator for delayed retirement credit in special minimum case.
setEligYearWidow | Sets eligibility year for widow.
setHighMfb | Sets applicable mfb.
setHighPia | Sets applicable pia.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPifc | Sets applicable pifc.
setSupportPia | Sets support pia, if applicable pia is special minimum and there is delayed retirement credit involved.
widowCheck | Checks disabled widow's date of disability.
~PiaCalPL | Destructor.
Collapse Expand Links
PiaCalPL Class, Legend, Public Data Members, Public Methods


PiaCalPL::PiaCalPL Constructor

PiaCalPL::PiaCalPL Constructor
PiaCalPL Class PiaCalPL Members PiaCalPL Class

Initializes this instance.

C++
PiaCalPL(
    WorkerDataGeneral& newWorkerData,
    PiaData& newPiaData,
    const PiaParams& newPiaParams
);
Collapse Expand Parameters
Parameters | Description
WorkerDataGeneral& newWorkerData | Worker's basic data.
PiaData& newPiaData | Worker's calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
Collapse Expand Class

PiaCalPL Class

Collapse Expand Links
PiaCalPL Class, PiaCalPL Members, PiaCalPL Class


PiaCalPL::~PiaCalPL Destructor

PiaCalPL::~PiaCalPL Destructor
PiaCalPL Class PiaCalPL Members PiaCalPL Class

Destructor.

C++
~PiaCalPL();
Collapse Expand Remarks

Calls releaseMemory.

Collapse Expand Class

PiaCalPL Class

Collapse Expand Links
PiaCalPL Class, PiaCalPL Members, PiaCalPL Class


PiaCalPL Methods

PiaCalPL Methods
PiaCalPL Class Legend Public Methods

The methods of the PiaCalPL class are listed here.

Collapse Expand Class

PiaCalPL Class

Collapse Expand Public Methods
Name | Description
calculate2 | Calculates PIA and benefit.
piaCal | Calculates PIA and MFB, not including re-indexed widow(er).
reindWidCal | Calculates PIA for one re-indexed widow(er).
Collapse Expand Links
PiaCalPL Class, Legend, Public Methods


PiaCalPL::calculate2 Method

PiaCalPL::calculate2 Method
PiaCalPL Class PiaCalPL Members PiaCalPL Methods

Calculates PIA and benefit.

C++
void calculate2(
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | The date of entitlement.
Collapse Expand Group

PiaCalPL Methods

Collapse Expand Links
PiaCalPL Class, PiaCalPL Members, PiaCalPL Methods


PiaCalPL::piaCal Method

PiaCalPL::piaCal Method
PiaCalPL Class PiaCalPL Members PiaCalPL Methods

Calculates PIA and MFB, not including re-indexed widow(er).

C++
void piaCal(
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDate | The date of entitlement.
Collapse Expand Group

PiaCalPL Methods

Collapse Expand Links
PiaCalPL Class, PiaCalPL Members, PiaCalPL Methods


PiaCalPL::reindWidCal Method

PiaCalPL::reindWidCal Method
PiaCalPL Class PiaCalPL Members PiaCalPL Methods

Calculates PIA for one re-indexed widow(er).

C++
void reindWidCal(
    const WorkerDataGeneral& widowData,
    const PiaData& widowPiaData,
    Secondary& secondary
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& widowData | Widow basic data.
const PiaData& widowPiaData | Computed information for widow.
Secondary& secondary | Benefits for widow.
Collapse Expand Group

PiaCalPL Methods

Collapse Expand Links
PiaCalPL Class, PiaCalPL Members, PiaCalPL Methods


PiaData Class

PiaData Class
PiaData Enumerations PiaData Data Members PiaData Methods PiaData Operators PiaData Members piadata.h Classes

Manages all of the worker-specific amounts calculated in preparation for and during the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  PiaData
C++
class PiaData;
Collapse Expand File

File: piadata.h

Module: PiaData Library

Collapse Expand Remarks

Manages all of the worker-specific amounts calculated in preparation for and during the calculation of a Social Security benefit.

Collapse Expand Group

Classes

Collapse Expand Links
PiaData Enumerations, PiaData Data Members, PiaData Methods, PiaData Operators, PiaData Members, piadata.h, Classes


PiaData Members

PiaData Members
Enumerations PiaData Class Legend Public Data Members Public Methods

The following tables list the members exposed by PiaData.

Collapse Expand Enumerations
Name | Description
arf_app_type | Special minimum-drc indicator.
earn_total_type | Types of earnings (without or with totalization).
Collapse Expand Class

PiaData Class

Collapse Expand Public Data Members
Name | Description
ageBen | Age at benefit date of worker.
ageEnt | Age at entitlement of worker.
childCareMaxCredit | The maximum amount of credit for each child care year, and the year in which it should be credited.
childCareOrder | Indicators for use of child care credits.
compPeriodNew | Computation period for new-start calculations.
compPeriodNewNonFreeze | Computation period for non-freeze new-start calculations.
compPeriodOld | Computation period for old-start calculation.
disInsCode | Disability insured status code.
disInsNonFreezeCode | Disability insured status code for non-freeze.
earlyRetAge | Earliest possible retirement age.
earnHi | Worker HI earnings, 1937 to maxyear.
earnHiLimited | Worker HI earnings limited to wage base, 1937 to maxyear.
earnMilServ | Military service wage credits, 1951 to date.
earnOasdi | Worker OASDI earnings, 1937 to maxyear, including railroad and military service.
earnOasdiLimited | Worker OASDI earnings limited to wage base, 1937 to maxyear, including railroad and military service.
earnTotalized | Worker OASDI earnings attributed for totalization, 1937 to maxyear.
earnTotalizedLimited | Worker OASDI earnings attributed for totalization, limited to wage base, 1937 to maxyear.
finsCode | Fully insured status code.
finsNonFreezeCode | Fully insured non-freeze status code.
freezeYears | Years wholly within a freeze period.
fullRetAge | Full retirement age.
highMfb | Highest applicable MFB.
highPia | Highest applicable PIA.
partialFreezeYears | Years partially within a freeze period.
qcov | Quarters of coverage, including railroad and military service.
qcovMilServ | Military service quarters of coverage, 1937 to 1956.
relEarnPosition | Annual relative earnings position, 1937 to maxyear.
roundedBenefit | Benefit actually payable, after dollar rounding.
supportPia | Support PIA when highest PIA is special minimum and delayed retirement credits are involved.
unroundedBenefit | Benefit actually payable, before dollar rounding.
Collapse Expand Public Methods
Name | Description
PiaData | Initializes arrays.
deleteContents | Initializes variables to default values.
earn50Cal | Calculates first year of earnings after 1950, with or without totalization.
earnHiCal | Calculates HI earnings by adding OASDI earnings and excess HI earnings.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
earnTotal50Cal0 | Calculates sum of regular pre-1951 earnings.
earnTotal50Cal1 | Calculates sum of pre-1951 totalization earnings.
earnYearCal | Determines last year of allowable earnings.
freezeYearsCal | Determines freeze period.
getAmend90 | Returns indicator for entitlement after 1990 amendments.
getArf | Returns actuarial reduction factor or delayed retirement credit.
getArfApp | Returns special minimum-delayed retirement credit indicator.
getBirthDateMinus1 | Returns day before worker's birth.
getChildCareMaxCredit | Returns maximum child care credit amount for a specified year.
getChildCareYearsTotal | Returns total number of child care years.
getDeemedQcReq | Returns number of quarters required for deemed fully insured status.
getEarn3750ms | Returns military service earnings, 1937-50.
getEarn50 | Returns first year of earnings after 1950.
getEarnTotal50 | Returns total earnings prior to 1951.
getEarnYear | Returns last year of earnings considered.
getEligDate | Returns worker's month and year of eligibility before considering prior disability onset.
getEligYear | Returns worker's year of eligibility after considering prior disability onset.
getEligYearNonFreeze | Returns worker's year of eligibility for non-freeze computations.
getFinsCode2 | Returns fully insured code as used in oact printouts.
getFinsNonFreezeCode2 | Returns fully insured non-freeze code as used in oact printouts.
getFirstQcYear | Returns first year with a quarter of coverage; 1937 if any QC's before 1951, 1936 if no QC's.
getFullInsDate | Returns date fully insured status is attained.
getFullRetDate | Returns date full retirement age is attained.
getIappn | Returns number of applicable pia calculation method.
getIapps | Returns support PIA method number.
getIbeginAll | Returns first year of earnings after considering railroad and military service.
getIbeginTotal | Returns first year of attributed earnings in totalization case.
getIendAll | Returns last year of earnings after considering railroad and military service.
getIendTotal | Returns last year of attributed earnings in totalization case.
getLastQcYear | Returns last year with a quarter of coverage, but at least 1950.
getMonthsArdri | Returns number of months of increment or reduction.
getOverMax | Returns indicator for earnings over maximum.
getPifc | Returns code for type of pia.
getPubpenApp | Returns applicable noncovered pension.
getQc3750ms | Returns military service quarters of coverage, 1937-50.
getQc3750simp | Returns simplified quarters of coverage, 1937-50.
getQcCurrent | Returns number of quarters earned in prior 3 years.
getQcCurrentNonFreeze | Returns number of quarters earned in prior 3 years for non-freeze.
getQcDisDate1 | Returns beginning quarter and year of period of required quarters of coverage for disability insured status.
getQcDisDate2 | Returns ending quarter and year of period of required quarters of coverage for disability insured status.
getQcDisDate3 | Returns beginning quarter and year of period of required quarters of coverage for disability insured status, for period after disability cessation.
getQcDisDate4 | Returns ending quarter and year of period of required quarters of coverage for disability insured status, for period after disability cessation.
getQcDisDate5 | Returns beginning quarter and year of period of required quarters of coverage for disability insured status, for period before prior disability.
getQcDisDate6 | Returns ending quarter and year of period of required quarters of coverage for disability insured status, for period before prior disability.
getQcDisDateNonFreeze1 | Returns beginning quarter and year of period of required quarters of coverage for disability insured status for non-freeze.
getQcDisDateNonFreeze2 | Returns ending quarter and year of period of required quarters of coverage for disability insured status for non-freeze.
getQcDisQtr | Returns number of quarters over which quarters of coverage must be earned for disability insured status.
getQcDisQtr2 | Returns number of quarters over which quarters of coverage must be earned for disability insured status, based on elapsed quarters after disability cessation.
getQcDisQtrNonFreeze | Returns number of quarters over which quarters of coverage must be earned for disability insured status for non-freeze.
getQcDisReq | Returns number of quarters required for disability insured status.
getQcDisReqNonFreeze | Returns number of quarters required for disability insured status for non-freeze.
getQcDisYears | Returns number of years over which quarters of coverage must be earned for disability insured status.
getQcDisYearsNonFreeze | Returns number of years over which quarters of coverage must be earned for disability insured status for non-freeze.
getQcReq | Returns number of quarters required for fully insured status.
getQcReqNonFreeze | Returns number of quarters required for fully insured non-freeze status.
getQcReqPerm | Returns number of quarters required for permanently insured status.
getQcReqPermNonFreeze | Returns number of quarters required for permanently insured non-freeze status.
getQcTotal | Returns total number of quarters earned for fully insured status.
getQcTotal50 | Returns total number of quarters earned from 1937 to 1950.
getQcTotal51 | Returns total number of quarters earned after 1950.
getQcTotal51NonFreeze | Returns total number of quarters earned after 1950 for non-freeze.
getQcTotalDis | Returns total number of quarters earned for disability insured status.
getQcTotalDisNonFreeze | Returns total number of quarters earned for disability insured status for non-freeze.
getQcTotalNonFreeze | Returns total number of quarters earned for fully insured non-freeze status.
getQcTotalRel | Returns total number of quarters earned for totalization benefit computation.
getRelEarnPositionAverage | Returns average relative earnings position.
initialize | Initializes computed values to zero.
qcCal | Calculates annual quarters of coverage.
qcDiSpec | Sets first quarter and year of disability insured period for special insured status (called only if calculated first quarter and year are in quarter of age 21 or earlier).
qcDiSpecNonFreeze | Sets first quarter and year of disability insured period for special insured status (called only if calculated first quarter and year are in quarter of age 21 or earlier).
qcDisCal | Calculates earned quarters of coverage in disability insured period.
qcDisNonFreezeCal | Calculates earned quarters of coverage in disability insured period for non-freeze.
qcDisReq2Cal | Determines number of required quarters of coverage for DI insured status, based on elapsed quarters after disability cessation.
qcDisReqCal | Determines number of required quarters of coverage for DI insured status.
qcDisReqNonFreezeCal | Determines number of required quarters of coverage for DI insured status for non-freeze.
qcTotalCal | Calculates total quarters of coverage. Assumes annual quarters of coverage are already known, either from 1951 or from 1978.
qcTotalNonFreezeCal | Calculates total quarters of coverage for non-freeze. Assumes annual quarters of coverage are already known, either from 1951 or from 1978, and that qcs prior to 1951 have already been computed as well by PiaData::qcTotalCal.
setAmend90 | Sets indicator for entitlement after 1990 amendments.
setArf | Sets actuarial reduction factor or delayed retirement credit.
setArfApp | Sets special minimum-delayed retirement credit indicator.
setBirthDateMinus1 | Sets day before worker's birth.
setChildCareYearsTotal | Sets total number of child care years.
setDeemedQcReq | Sets number of quarters of coverage required for deemed insured status.
setDoEarlyQcs | Sets indicator for calculation of quarters of coverage for early years.
setEarn3750ms | Sets military service earnings, 1937-50.
setEligDate | Sets month and year of eligibility before considering disability.
setEligYear | Sets eligibility year after considering prior disability onset.
setEligYearNonFreeze | Sets eligibility year for non-freeze computations.
setFinsCode2 | Sets fully insured status code as used in oact printouts.
setFinsNonFreezeCode2 | Sets fully insured non-freeze status code as used in oact printouts.
setFullInsDate | Sets date fully insured status is attained.
setFullRetDate | Sets date of attainment of normal retirement age, but no earlier than January 1937.
setIappn | Sets number of applicable pia calculation method.
setIapps | Sets support pia method number.
setIbeginTotal | Sets first year of attributed earnings in totalization case.
setIendTotal | Sets last year of attributed earnings in totalization case.
setMonthsArdri | Sets number of months of increment or reduction.
setOverMax | Sets indicator for earnings over maximum.
setPifc | Sets code for type of pia.
setQc3 | Sets some quarter of coverage amounts.
setQc3750ms | Sets military service quarters of coverage, 1937-50.
setQc3750simp | Sets simplified quarters of coverage, 1937-50.
setQcCurrent | Sets quarters of coverage earned in prior 3 years.
setQcCurrentNonFreeze | Sets quarters of coverage earned in prior 3 years for non-freeze.
setQcReq | Sets number of quarters required for fully insured status.
setQcReqNonFreeze | Sets number of quarters required for fully insured non-freeze status.
setQcReqPerm | Sets number of quarters required for permanently insured status.
setQcReqPermNonFreeze | Sets number of quarters required for permanently insured non-freeze status.
setQcTotal | Sets total quarters of coverage.
setQcTotal50 | Sets quarters of coverage prior to 1951.
setQcTotalNonFreeze | Sets total quarters of coverage for non-freeze.
setQcTotalRel | Sets total quarters of coverage earned for a totalization benefit computation.
setRelEarnPositionAverage | Sets average relative earnings position.
updateMilServ | Updates military service earnings and quarters of coverage.
~PiaData | Destroys arrays.
Collapse Expand Public Operators
Name | Description
= | Sets this instance equal to another instance.
Collapse Expand Links
Enumerations, PiaData Class, Legend, Public Data Members, Public Methods


PiaData::PiaData Constructor

PiaData::PiaData Constructor
PiaData Class PiaData Members PiaData Class

Initializes arrays.

C++
PiaData();
Collapse Expand Class

PiaData Class

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Class


PiaData::~PiaData Destructor

PiaData::~PiaData Destructor
PiaData Class PiaData Members PiaData Class

Destroys arrays.

C++
~PiaData();
Collapse Expand Class

PiaData Class

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Class


PiaData Enumerations

PiaData Enumerations
Enumerations PiaData Class Legend

The enumerations of the PiaData class are listed here.

Collapse Expand Enumerations
Name | Description
arf_app_type | Special minimum-drc indicator.
earn_total_type | Types of earnings (without or with totalization).
Collapse Expand Class

PiaData Class

Collapse Expand Links
Enumerations, PiaData Class, Legend


PiaData::arf_app_type Enumeration

PiaData::arf_app_type Enumeration
piadata.h PiaData Enumerations

Special minimum-drc indicator.

C++
enum arf_app_type {
  NO_SPEC_MIN_DRC,
  SPEC_MIN_BEN,
  SUPPORT_BEN
};
Collapse Expand File

File: piadata.h

Module: PiaData Library

Collapse Expand Members
Members | Description
NO_SPEC_MIN_DRC | No special minimum, or no delayed retirement credits.
SPEC_MIN_BEN | Highest PIA is special minimum, delayed retirement credits are involved, and benefit equals special minimum PIA.
SUPPORT_BEN | Highest PIA is special minimum, delayed retirement credits are involved, and benefit equals support PIA increased by increment factor.
Collapse Expand Group

PiaData Enumerations

Collapse Expand Links
piadata.h, PiaData Enumerations


PiaData::earn_total_type Enumeration

PiaData::earn_total_type Enumeration
piadata.h PiaData Enumerations

Types of earnings (without or with totalization).

C++
enum earn_total_type {
  EARN_NO_TOTALIZATION,
  EARN_WITH_TOTALIZATION,
  NUM_EARN_TOTALIZATION
};
Collapse Expand File

File: piadata.h

Module: PiaData Library

Collapse Expand Members
Members | Description
EARN_NO_TOTALIZATION | Without considering totalization.
EARN_WITH_TOTALIZATION | After considering attributed earnings for totalization.
NUM_EARN_TOTALIZATION | Number of types of earnings (without or with totalization).
Collapse Expand Group

PiaData Enumerations

Collapse Expand Links
piadata.h, PiaData Enumerations


PiaData Data Members

PiaData Data Members
PiaData Class Legend Public Data Members

The data members of the PiaData class are listed here.

Collapse Expand Class

PiaData Class

Collapse Expand Public Data Members
Name | Description
ageBen | Age at benefit date of worker.
ageEnt | Age at entitlement of worker.
childCareMaxCredit | The maximum amount of credit for each child care year, and the year in which it should be credited.
childCareOrder | Indicators for use of child care credits.
compPeriodNew | Computation period for new-start calculations.
compPeriodNewNonFreeze | Computation period for non-freeze new-start calculations.
compPeriodOld | Computation period for old-start calculation.
disInsCode | Disability insured status code.
disInsNonFreezeCode | Disability insured status code for non-freeze.
earlyRetAge | Earliest possible retirement age.
earnHi | Worker HI earnings, 1937 to maxyear.
earnHiLimited | Worker HI earnings limited to wage base, 1937 to maxyear.
earnMilServ | Military service wage credits, 1951 to date.
earnOasdi | Worker OASDI earnings, 1937 to maxyear, including railroad and military service.
earnOasdiLimited | Worker OASDI earnings limited to wage base, 1937 to maxyear, including railroad and military service.
earnTotalized | Worker OASDI earnings attributed for totalization, 1937 to maxyear.
earnTotalizedLimited | Worker OASDI earnings attributed for totalization, limited to wage base, 1937 to maxyear.
finsCode | Fully insured status code.
finsNonFreezeCode | Fully insured non-freeze status code.
freezeYears | Years wholly within a freeze period.
fullRetAge | Full retirement age.
highMfb | Highest applicable MFB.
highPia | Highest applicable PIA.
partialFreezeYears | Years partially within a freeze period.
qcov | Quarters of coverage, including railroad and military service.
qcovMilServ | Military service quarters of coverage, 1937 to 1956.
relEarnPosition | Annual relative earnings position, 1937 to maxyear.
roundedBenefit | Benefit actually payable, after dollar rounding.
supportPia | Support PIA when highest PIA is special minimum and delayed retirement credits are involved.
unroundedBenefit | Benefit actually payable, before dollar rounding.
Collapse Expand Links
PiaData Class, Legend, Public Data Members


PiaData::ageBen Data Member

PiaData::ageBen Data Member
PiaData Class PiaData Members PiaData Data Members

Age at benefit date of worker.

C++
Age ageBen;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::ageEnt Data Member

PiaData::ageEnt Data Member
PiaData Class PiaData Members PiaData Data Members

Age at entitlement of worker.

C++
Age ageEnt;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::childCareMaxCredit Data Member

PiaData::childCareMaxCredit Data Member
PiaData Class PiaData Members PiaData Data Members

The maximum amount of credit for each child care year, and the year in which it should be credited.

C++
std::vector< std::pair<double, int> > childCareMaxCredit;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::childCareOrder Data Member

PiaData::childCareOrder Data Member
PiaData Class PiaData Members PiaData Data Members

Indicators for use of child care credits.

C++
BitAnnual childCareOrder;
Collapse Expand Remarks

True (1) if using child care credit that year, false (0) otherwise.

Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::compPeriodNew Data Member

PiaData::compPeriodNew Data Member
PiaData Class PiaData Members PiaData Data Members

Computation period for new-start calculations.

C++
CompPeriod compPeriodNew;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::compPeriodNewNonFreeze Data Member

PiaData::compPeriodNewNonFreeze Data Member
PiaData Class PiaData Members PiaData Data Members

Computation period for non-freeze new-start calculations.

C++
CompPeriod compPeriodNewNonFreeze;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::compPeriodOld Data Member

PiaData::compPeriodOld Data Member
PiaData Class PiaData Members PiaData Data Members

Computation period for old-start calculation.

C++
CompPeriod compPeriodOld;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::disInsCode Data Member

PiaData::disInsCode Data Member
PiaData Class PiaData Members PiaData Data Members

Disability insured status code.

C++
DisInsCode disInsCode;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::disInsNonFreezeCode Data Member

PiaData::disInsNonFreezeCode Data Member
PiaData Class PiaData Members PiaData Data Members

Disability insured status code for non-freeze.

C++
DisInsCode disInsNonFreezeCode;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::earlyRetAge Data Member

PiaData::earlyRetAge Data Member
PiaData Class PiaData Members PiaData Data Members

Earliest possible retirement age.

C++
Age earlyRetAge;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::earnHi Data Member

PiaData::earnHi Data Member
PiaData Class PiaData Members PiaData Data Members

Worker HI earnings, 1937 to maxyear.

C++
AverageWage earnHi;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::earnHiLimited Data Member

PiaData::earnHiLimited Data Member
PiaData Class PiaData Members PiaData Data Members

Worker HI earnings limited to wage base, 1937 to maxyear.

C++
AverageWage earnHiLimited;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::earnMilServ Data Member

PiaData::earnMilServ Data Member
PiaData Class PiaData Members PiaData Data Members

Military service wage credits, 1951 to date.

C++
DoubleAnnual earnMilServ;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::earnOasdi Data Member

PiaData::earnOasdi Data Member
PiaData Class PiaData Members PiaData Data Members

Worker OASDI earnings, 1937 to maxyear, including railroad and military service.

C++
AverageWage earnOasdi;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::earnOasdiLimited Data Member

PiaData::earnOasdiLimited Data Member
PiaData Class PiaData Members PiaData Data Members

Worker OASDI earnings limited to wage base, 1937 to maxyear, including railroad and military service.

C++
AverageWage earnOasdiLimited;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::earnTotalized Data Member

PiaData::earnTotalized Data Member
PiaData Class PiaData Members PiaData Data Members

Worker OASDI earnings attributed for totalization, 1937 to maxyear.

C++
AverageWage earnTotalized;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::earnTotalizedLimited Data Member

PiaData::earnTotalizedLimited Data Member
PiaData Class PiaData Members PiaData Data Members

Worker OASDI earnings attributed for totalization, limited to wage base, 1937 to maxyear.

C++
AverageWage earnTotalizedLimited;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::finsCode Data Member

PiaData::finsCode Data Member
PiaData Class PiaData Members PiaData Data Members

Fully insured status code.

C++
InsCode finsCode;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::finsNonFreezeCode Data Member

PiaData::finsNonFreezeCode Data Member
PiaData Class PiaData Members PiaData Data Members

Fully insured non-freeze status code.

C++
InsCode finsNonFreezeCode;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::freezeYears Data Member

PiaData::freezeYears Data Member
PiaData Class PiaData Members PiaData Data Members

Years wholly within a freeze period.

C++
FreezeYears freezeYears;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::fullRetAge Data Member

PiaData::fullRetAge Data Member
PiaData Class PiaData Members PiaData Data Members

Full retirement age.

C++
Age fullRetAge;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::highMfb Data Member

PiaData::highMfb Data Member
PiaData Class PiaData Members PiaData Data Members

Highest applicable MFB.

C++
BenefitAmount highMfb;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::highPia Data Member

PiaData::highPia Data Member
PiaData Class PiaData Members PiaData Data Members

Highest applicable PIA.

C++
BenefitAmount highPia;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::partialFreezeYears Data Member

PiaData::partialFreezeYears Data Member
PiaData Class PiaData Members PiaData Data Members

Years partially within a freeze period.

C++
FreezeYears partialFreezeYears;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::qcov Data Member

PiaData::qcov Data Member
PiaData Class PiaData Members PiaData Data Members

Quarters of coverage, including railroad and military service.

C++
QcArray qcov;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::qcovMilServ Data Member

PiaData::qcovMilServ Data Member
PiaData Class PiaData Members PiaData Data Members

Military service quarters of coverage, 1937 to 1956.

C++
QcArray qcovMilServ;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::relEarnPosition Data Member

PiaData::relEarnPosition Data Member
PiaData Class PiaData Members PiaData Data Members

Annual relative earnings position, 1937 to maxyear.

C++
DoubleAnnual relEarnPosition;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::roundedBenefit Data Member

PiaData::roundedBenefit Data Member
PiaData Class PiaData Members PiaData Data Members

Benefit actually payable, after dollar rounding.

C++
BenefitAmount roundedBenefit;
Collapse Expand Remarks

See unroundedBenefit for the benefit before dollar rounding.

Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::supportPia Data Member

PiaData::supportPia Data Member
PiaData Class PiaData Members PiaData Data Members

Support PIA when highest PIA is special minimum and delayed retirement credits are involved.

C++
BenefitAmount supportPia;
Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData::unroundedBenefit Data Member

PiaData::unroundedBenefit Data Member
PiaData Class PiaData Members PiaData Data Members

Benefit actually payable, before dollar rounding.

C++
BenefitAmount unroundedBenefit;
Collapse Expand Remarks

See PiaData::roundedBenefit for the benefit after dollar rounding.

Collapse Expand Group

PiaData Data Members

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Data Members


PiaData Methods

PiaData Methods
PiaData Class Legend Public Methods

The methods of the PiaData class are listed here.

Collapse Expand Class

PiaData Class

Collapse Expand Public Methods
Name | Description
deleteContents | Initializes variables to default values.
earn50Cal | Calculates first year of earnings after 1950, with or without totalization.
earnHiCal | Calculates HI earnings by adding OASDI earnings and excess HI earnings.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
earnTotal50Cal0 | Calculates sum of regular pre-1951 earnings.
earnTotal50Cal1 | Calculates sum of pre-1951 totalization earnings.
earnYearCal | Determines last year of allowable earnings.
freezeYearsCal | Determines freeze period.
getAmend90 | Returns indicator for entitlement after 1990 amendments.
getArf | Returns actuarial reduction factor or delayed retirement credit.
getArfApp | Returns special minimum-delayed retirement credit indicator.
getBirthDateMinus1 | Returns day before worker's birth.
getChildCareMaxCredit | Returns maximum child care credit amount for a specified year.
getChildCareYearsTotal | Returns total number of child care years.
getDeemedQcReq | Returns number of quarters required for deemed fully insured status.
getEarn3750ms | Returns military service earnings, 1937-50.
getEarn50 | Returns first year of earnings after 1950.
getEarnTotal50 | Returns total earnings prior to 1951.
getEarnYear | Returns last year of earnings considered.
getEligDate | Returns worker's month and year of eligibility before considering prior disability onset.
getEligYear | Returns worker's year of eligibility after considering prior disability onset.
getEligYearNonFreeze | Returns worker's year of eligibility for non-freeze computations.
getFinsCode2 | Returns fully insured code as used in oact printouts.
getFinsNonFreezeCode2 | Returns fully insured non-freeze code as used in oact printouts.
getFirstQcYear | Returns first year with a quarter of coverage; 1937 if any QC's before 1951, 1936 if no QC's.
getFullInsDate | Returns date fully insured status is attained.
getFullRetDate | Returns date full retirement age is attained.
getIappn | Returns number of applicable pia calculation method.
getIapps | Returns support PIA method number.
getIbeginAll | Returns first year of earnings after considering railroad and military service.
getIbeginTotal | Returns first year of attributed earnings in totalization case.
getIendAll | Returns last year of earnings after considering railroad and military service.
getIendTotal | Returns last year of attributed earnings in totalization case.
getLastQcYear | Returns last year with a quarter of coverage, but at least 1950.
getMonthsArdri | Returns number of months of increment or reduction.
getOverMax | Returns indicator for earnings over maximum.
getPifc | Returns code for type of pia.
getPubpenApp | Returns applicable noncovered pension.
getQc3750ms | Returns military service quarters of coverage, 1937-50.
getQc3750simp | Returns simplified quarters of coverage, 1937-50.
getQcCurrent | Returns number of quarters earned in prior 3 years.
getQcCurrentNonFreeze | Returns number of quarters earned in prior 3 years for non-freeze.
getQcDisDate1 | Returns beginning quarter and year of period of required quarters of coverage for disability insured status.
getQcDisDate2 | Returns ending quarter and year of period of required quarters of coverage for disability insured status.
getQcDisDate3 | Returns beginning quarter and year of period of required quarters of coverage for disability insured status, for period after disability cessation.
getQcDisDate4 | Returns ending quarter and year of period of required quarters of coverage for disability insured status, for period after disability cessation.
getQcDisDate5 | Returns beginning quarter and year of period of required quarters of coverage for disability insured status, for period before prior disability.
getQcDisDate6 | Returns ending quarter and year of period of required quarters of coverage for disability insured status, for period before prior disability.
getQcDisDateNonFreeze1 | Returns beginning quarter and year of period of required quarters of coverage for disability insured status for non-freeze.
getQcDisDateNonFreeze2 | Returns ending quarter and year of period of required quarters of coverage for disability insured status for non-freeze.
getQcDisQtr | Returns number of quarters over which quarters of coverage must be earned for disability insured status.
getQcDisQtr2 | Returns number of quarters over which quarters of coverage must be earned for disability insured status, based on elapsed quarters after disability cessation.
getQcDisQtrNonFreeze | Returns number of quarters over which quarters of coverage must be earned for disability insured status for non-freeze.
getQcDisReq | Returns number of quarters required for disability insured status.
getQcDisReqNonFreeze | Returns number of quarters required for disability insured status for non-freeze.
getQcDisYears | Returns number of years over which quarters of coverage must be earned for disability insured status.
getQcDisYearsNonFreeze | Returns number of years over which quarters of coverage must be earned for disability insured status for non-freeze.
getQcReq | Returns number of quarters required for fully insured status.
getQcReqNonFreeze | Returns number of quarters required for fully insured non-freeze status.
getQcReqPerm | Returns number of quarters required for permanently insured status.
getQcReqPermNonFreeze | Returns number of quarters required for permanently insured non-freeze status.
getQcTotal | Returns total number of quarters earned for fully insured status.
getQcTotal50 | Returns total number of quarters earned from 1937 to 1950.
getQcTotal51 | Returns total number of quarters earned after 1950.
getQcTotal51NonFreeze | Returns total number of quarters earned after 1950 for non-freeze.
getQcTotalDis | Returns total number of quarters earned for disability insured status.
getQcTotalDisNonFreeze | Returns total number of quarters earned for disability insured status for non-freeze.
getQcTotalNonFreeze | Returns total number of quarters earned for fully insured non-freeze status.
getQcTotalRel | Returns total number of quarters earned for totalization benefit computation.
getRelEarnPositionAverage | Returns average relative earnings position.
initialize | Initializes computed values to zero.
qcCal | Calculates annual quarters of coverage.
qcDiSpec | Sets first quarter and year of disability insured period for special insured status (called only if calculated first quarter and year are in quarter of age 21 or earlier).
qcDiSpecNonFreeze | Sets first quarter and year of disability insured period for special insured status (called only if calculated first quarter and year are in quarter of age 21 or earlier).
qcDisCal | Calculates earned quarters of coverage in disability insured period.
qcDisNonFreezeCal | Calculates earned quarters of coverage in disability insured period for non-freeze.
qcDisReq2Cal | Determines number of required quarters of coverage for DI insured status, based on elapsed quarters after disability cessation.
qcDisReqCal | Determines number of required quarters of coverage for DI insured status.
qcDisReqNonFreezeCal | Determines number of required quarters of coverage for DI insured status for non-freeze.
qcTotalCal | Calculates total quarters of coverage. Assumes annual quarters of coverage are already known, either from 1951 or from 1978.
qcTotalNonFreezeCal | Calculates total quarters of coverage for non-freeze. Assumes annual quarters of coverage are already known, either from 1951 or from 1978, and that qcs prior to 1951 have already been computed as well by PiaData::qcTotalCal.
setAmend90 | Sets indicator for entitlement after 1990 amendments.
setArf | Sets actuarial reduction factor or delayed retirement credit.
setArfApp | Sets special minimum-delayed retirement credit indicator.
setBirthDateMinus1 | Sets day before worker's birth.
setChildCareYearsTotal | Sets total number of child care years.
setDeemedQcReq | Sets number of quarters of coverage required for deemed insured status.
setDoEarlyQcs | Sets indicator for calculation of quarters of coverage for early years.
setEarn3750ms | Sets military service earnings, 1937-50.
setEligDate | Sets month and year of eligibility before considering disability.
setEligYear | Sets eligibility year after considering prior disability onset.
setEligYearNonFreeze | Sets eligibility year for non-freeze computations.
setFinsCode2 | Sets fully insured status code as used in oact printouts.
setFinsNonFreezeCode2 | Sets fully insured non-freeze status code as used in oact printouts.
setFullInsDate | Sets date fully insured status is attained.
setFullRetDate | Sets date of attainment of normal retirement age, but no earlier than January 1937.
setIappn | Sets number of applicable pia calculation method.
setIapps | Sets support pia method number.
setIbeginTotal | Sets first year of attributed earnings in totalization case.
setIendTotal | Sets last year of attributed earnings in totalization case.
setMonthsArdri | Sets number of months of increment or reduction.
setOverMax | Sets indicator for earnings over maximum.
setPifc | Sets code for type of pia.
setQc3 | Sets some quarter of coverage amounts.
setQc3750ms | Sets military service quarters of coverage, 1937-50.
setQc3750simp | Sets simplified quarters of coverage, 1937-50.
setQcCurrent | Sets quarters of coverage earned in prior 3 years.
setQcCurrentNonFreeze | Sets quarters of coverage earned in prior 3 years for non-freeze.
setQcReq | Sets number of quarters required for fully insured status.
setQcReqNonFreeze | Sets number of quarters required for fully insured non-freeze status.
setQcReqPerm | Sets number of quarters required for permanently insured status.
setQcReqPermNonFreeze | Sets number of quarters required for permanently insured non-freeze status.
setQcTotal | Sets total quarters of coverage.
setQcTotal50 | Sets quarters of coverage prior to 1951.
setQcTotalNonFreeze | Sets total quarters of coverage for non-freeze.
setQcTotalRel | Sets total quarters of coverage earned for a totalization benefit computation.
setRelEarnPositionAverage | Sets average relative earnings position.
updateMilServ | Updates military service earnings and quarters of coverage.
Collapse Expand Links
PiaData Class, Legend, Public Methods


PiaData::deleteContents Method

PiaData::deleteContents Method
PiaData Class PiaData Members PiaData Methods

Initializes variables to default values.

C++
void deleteContents();
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::earn50Cal Method

PiaData::earn50Cal Method
PiaData Class PiaData Members PiaData Methods

Calculates first year of earnings after 1950, with or without totalization.

C++
void earn50Cal(
    const WorkerDataGeneral& workerData
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::earnHiCal Method

PiaData::earnHiCal Method
PiaData Class PiaData Members PiaData Methods

Calculates HI earnings by adding OASDI earnings and excess HI earnings.

C++
void earnHiCal(
    const WorkerDataGeneral& workerData
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
Collapse Expand Remarks

This is called in PiaCal::earnProjection.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::earnProjection Method

PiaData::earnProjection Method
PiaData Class PiaData Members PiaData Methods

Projects earnings and fills in earnings to be used in calculations.

C++
void earnProjection(
    const WorkerDataGeneral& workerData
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::earnTotal50Cal0 Method

PiaData::earnTotal50Cal0 Method
PiaData Class PiaData Members PiaData Methods

Calculates sum of regular pre-1951 earnings.

C++
void earnTotal50Cal0();
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if first year of all earnings is out of range (only in debug mode).
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::earnTotal50Cal1 Method

PiaData::earnTotal50Cal1 Method
PiaData Class PiaData Members PiaData Methods

Calculates sum of pre-1951 totalization earnings.

C++
void earnTotal50Cal1();
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if first year of totalization earnings is out of range (only in debug mode).
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::earnYearCal Method

PiaData::earnYearCal Method
PiaData Class PiaData Members PiaData Methods

Determines last year of allowable earnings.

C++
void earnYearCal(
    const WorkerDataGeneral& workerData,
    WorkerDataGeneral::ben_type ioasdi
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
Collapse Expand Remarks

In survivor case, use earnings through year of death; otherwise stop in year before year of benefit

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::freezeYearsCal Method

PiaData::freezeYearsCal Method
PiaData Class PiaData Members PiaData Methods

Determines freeze period.

C++
void freezeYearsCal(
    const WorkerDataGeneral& workerData,
    WorkerDataGeneral::ben_type ioasdi,
    const Age& fullRetAgeDI
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
const Age& fullRetAgeDI | Full retirement age for benefit calculation purposes.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getAmend90 Method

PiaData::getAmend90 Method
PiaData Class PiaData Members PiaData Methods

Returns indicator for entitlement after 1990 amendments.

C++
bool getAmend90() const;
Collapse Expand Returns

Indicator for entitlement after 1990 amendments.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getArf Method

PiaData::getArf Method
PiaData Class PiaData Members PiaData Methods

Returns actuarial reduction factor or delayed retirement credit.

C++
double getArf() const;
Collapse Expand Returns

Actuarial reduction factor or delayed retirement credit.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getArfApp Method

PiaData::getArfApp Method
PiaData Class PiaData Members PiaData Methods

Returns special minimum-delayed retirement credit indicator.

C++
arf_app_type getArfApp() const;
Collapse Expand Returns

Special minimum-delayed retirement credit indicator.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getBirthDateMinus1 Method

PiaData::getBirthDateMinus1 Method
PiaData Class PiaData Members PiaData Methods

Returns day before worker's birth.

C++
const boost::gregorian::date& getBirthDateMinus1() const;
Collapse Expand Returns

Day before worker's birth.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getChildCareMaxCredit Method

PiaData::getChildCareMaxCredit Method
PiaData Class PiaData Members PiaData Methods

Returns maximum child care credit amount for a specified year.

C++
double getChildCareMaxCredit(
    int yearOfCredit
) const;
Collapse Expand Parameters
Parameters | Description
int yearOfCredit | Year of the credit
Collapse Expand Returns

Maximum child care credit amount for a specified year.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getChildCareYearsTotal Method

PiaData::getChildCareYearsTotal Method
PiaData Class PiaData Members PiaData Methods

Returns total number of child care years.

C++
int getChildCareYearsTotal() const;
Collapse Expand Returns

Total number of child care years.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getDeemedQcReq Method

PiaData::getDeemedQcReq Method
PiaData Class PiaData Members PiaData Methods

Returns number of quarters required for deemed fully insured status.

C++
int getDeemedQcReq() const;
Collapse Expand Returns

Number of quarters required for deemed fully insured status.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getEarn3750ms Method

PiaData::getEarn3750ms Method
PiaData Class PiaData Members PiaData Methods

Returns military service earnings, 1937-50.

C++
double getEarn3750ms() const;
Collapse Expand Returns

Military service earnings, 1937-50.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getEarn50 Method

PiaData::getEarn50 Method
PiaData Class PiaData Members PiaData Methods

Returns first year of earnings after 1950.

C++
int getEarn50(
    earn_total_type type
) const;
Collapse Expand Parameters
Parameters | Description
earn_total_type type | Type of earnings.
Collapse Expand Returns

First year of earnings after 1950.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getEarnTotal50 Method

PiaData::getEarnTotal50 Method
PiaData Class PiaData Members PiaData Methods

Returns total earnings prior to 1951.

C++
double getEarnTotal50(
    earn_total_type type
) const;
Collapse Expand Parameters
Parameters | Description
earn_total_type type | Type of earnings.
Collapse Expand Returns

Total earnings prior to 1951.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getEarnYear Method

PiaData::getEarnYear Method
PiaData Class PiaData Members PiaData Methods

Returns last year of earnings considered.

C++
int getEarnYear() const;
Collapse Expand Returns

Last year of earnings considered.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getEligDate Method

PiaData::getEligDate Method
PiaData Class PiaData Members PiaData Methods

Returns worker's month and year of eligibility before considering prior disability onset.

C++
const DateMoyr& getEligDate() const;
Collapse Expand Returns

Worker's month and year of eligibility before considering prior disability onset.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getEligYear Method

PiaData::getEligYear Method
PiaData Class PiaData Members PiaData Methods

Returns worker's year of eligibility after considering prior disability onset.

C++
int getEligYear() const;
Collapse Expand Returns

Worker's year of eligibility after considering prior disability onset.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getEligYearNonFreeze Method

PiaData::getEligYearNonFreeze Method
PiaData Class PiaData Members PiaData Methods

Returns worker's year of eligibility for non-freeze computations.

C++
int getEligYearNonFreeze() const;
Collapse Expand Returns

Worker's year of eligibility for non-freeze computations.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getFinsCode2 Method

PiaData::getFinsCode2 Method
PiaData Class PiaData Members PiaData Methods

Returns fully insured code as used in oact printouts.

C++
char getFinsCode2() const;
Collapse Expand Returns

Fully insured code as used in oact printouts.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getFinsNonFreezeCode2 Method

PiaData::getFinsNonFreezeCode2 Method
PiaData Class PiaData Members PiaData Methods

Returns fully insured non-freeze code as used in oact printouts.

C++
char getFinsNonFreezeCode2() const;
Collapse Expand Returns

Fully insured non-freeze code as used in oact printouts.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getFirstQcYear Method

PiaData::getFirstQcYear Method
PiaData Class PiaData Members PiaData Methods

Returns first year with a quarter of coverage; 1937 if any QC's before 1951, 1936 if no QC's.

C++
int getFirstQcYear(
    const WorkerDataGeneral& workerData
) const;
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
Collapse Expand Returns

First year with a quarter of coverage; 1937 if any QC's before 1951, 1936 if no QC's.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getFullInsDate Method

PiaData::getFullInsDate Method
PiaData Class PiaData Members PiaData Methods

Returns date fully insured status is attained.

C++
const DateMoyr& getFullInsDate() const;
Collapse Expand Returns

The date fully insured status is attained.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getFullRetDate Method

PiaData::getFullRetDate Method
PiaData Class PiaData Members PiaData Methods

Returns date full retirement age is attained.

C++
const DateMoyr& getFullRetDate() const;
Collapse Expand Returns

The date full retirement age is attained.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getIappn Method

PiaData::getIappn Method
PiaData Class PiaData Members PiaData Methods

Returns number of applicable pia calculation method.

C++
int getIappn() const;
Collapse Expand Returns

Number of applicable pia calculation method.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getIapps Method

PiaData::getIapps Method
PiaData Class PiaData Members PiaData Methods

Returns support PIA method number.

C++
int getIapps() const;
Collapse Expand Returns

Support PIA method number.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getIbeginAll Method

PiaData::getIbeginAll Method
PiaData Class PiaData Members PiaData Methods

Returns first year of earnings after considering railroad and military service.

C++
int getIbeginAll() const;
Collapse Expand Returns

First year of earnings after considering railroad and military service.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getIbeginTotal Method

PiaData::getIbeginTotal Method
PiaData Class PiaData Members PiaData Methods

Returns first year of attributed earnings in totalization case.

C++
int getIbeginTotal() const;
Collapse Expand Returns

First year of attributed earnings in totalization case.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getIendAll Method

PiaData::getIendAll Method
PiaData Class PiaData Members PiaData Methods

Returns last year of earnings after considering railroad and military service.

C++
int getIendAll() const;
Collapse Expand Returns

Last year of earnings after considering railroad and military service.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getIendTotal Method

PiaData::getIendTotal Method
PiaData Class PiaData Members PiaData Methods

Returns last year of attributed earnings in totalization case.

C++
int getIendTotal() const;
Collapse Expand Returns

Last year of attributed earnings in totalization case.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getLastQcYear Method

PiaData::getLastQcYear Method
PiaData Class PiaData Members PiaData Methods

Returns last year with a quarter of coverage, but at least 1950.

C++
int getLastQcYear(
    const WorkerDataGeneral& workerData
) const;
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
Collapse Expand Returns

Last year with a quarter of coverage, but at least 1950.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getMonthsArdri Method

PiaData::getMonthsArdri Method
PiaData Class PiaData Members PiaData Methods

Returns number of months of increment or reduction.

C++
int getMonthsArdri() const;
Collapse Expand Returns

Number of months of increment or reduction.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getOverMax Method

PiaData::getOverMax Method
PiaData Class PiaData Members PiaData Methods

Returns indicator for earnings over maximum.

C++
bool getOverMax() const;
Collapse Expand Returns

True if any earnings over maximum, false otherwise.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getPifc Method

PiaData::getPifc Method
PiaData Class PiaData Members PiaData Methods

Returns code for type of pia.

C++
char getPifc() const;
Collapse Expand Returns

Code for type of pia.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getPubpenApp Method

PiaData::getPubpenApp Method
PiaData Class PiaData Members PiaData Methods

Returns applicable noncovered pension.

C++
float getPubpenApp(
    const WorkerDataGeneral& workerData
) const;
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
Collapse Expand Returns

Applicable noncovered pension.

Collapse Expand Remarks

As of January 1995, the rules for determining the noncovered pension amount changed, so someone with a noncovered pension before 1995 could have a different noncovered pension as of January 1995. This function uses the benefit date to determine the correct noncovered pension.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQc3750ms Method

PiaData::getQc3750ms Method
PiaData Class PiaData Members PiaData Methods

Returns military service quarters of coverage, 1937-50.

C++
int getQc3750ms() const;
Collapse Expand Returns

Military service quarters of coverage, 1937-50.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQc3750simp Method

PiaData::getQc3750simp Method
PiaData Class PiaData Members PiaData Methods

Returns simplified quarters of coverage, 1937-50.

C++
int getQc3750simp() const;
Collapse Expand Returns

Simplified quarters of coverage, 1937-50.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcCurrent Method

PiaData::getQcCurrent Method
PiaData Class PiaData Members PiaData Methods

Returns number of quarters earned in prior 3 years.

C++
int getQcCurrent() const;
Collapse Expand Returns

Number of quarters earned in prior 3 years.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcCurrentNonFreeze Method

PiaData::getQcCurrentNonFreeze Method
PiaData Class PiaData Members PiaData Methods

Returns number of quarters earned in prior 3 years for non-freeze.

C++
int getQcCurrentNonFreeze() const;
Collapse Expand Returns

Number of quarters earned in prior 3 years for non-freeze.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcDisDate1 Method

PiaData::getQcDisDate1 Method
PiaData Class PiaData Members PiaData Methods

Returns beginning quarter and year of period of required quarters of coverage for disability insured status.

C++
const QtrYear& getQcDisDate1() const;
Collapse Expand Returns

Beginning quarter and year of period of required quarters of coverage for disability insured status.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcDisDate2 Method

PiaData::getQcDisDate2 Method
PiaData Class PiaData Members PiaData Methods

Returns ending quarter and year of period of required quarters of coverage for disability insured status.

C++
const QtrYear& getQcDisDate2() const;
Collapse Expand Returns

Ending quarter and year of period of required quarters of coverage for disability insured status.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcDisDate3 Method

PiaData::getQcDisDate3 Method
PiaData Class PiaData Members PiaData Methods

Returns beginning quarter and year of period of required quarters of coverage for disability insured status, for period after disability cessation.

C++
const QtrYear& getQcDisDate3() const;
Collapse Expand Returns

Beginning quarter and year of period of required quarters of coverage for disability insured status, for period after disability cessation.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcDisDate4 Method

PiaData::getQcDisDate4 Method
PiaData Class PiaData Members PiaData Methods

Returns ending quarter and year of period of required quarters of coverage for disability insured status, for period after disability cessation.

C++
const QtrYear& getQcDisDate4() const;
Collapse Expand Returns

Ending quarter and year of period of required quarters of coverage for disability insured status, for period after disability cessation.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcDisDate5 Method

PiaData::getQcDisDate5 Method
PiaData Class PiaData Members PiaData Methods

Returns beginning quarter and year of period of required quarters of coverage for disability insured status, for period before prior disability.

C++
const QtrYear& getQcDisDate5() const;
Collapse Expand Returns

Beginning quarter and year of period of required quarters of coverage for disability insured status, for period before prior disability.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcDisDate6 Method

PiaData::getQcDisDate6 Method
PiaData Class PiaData Members PiaData Methods

Returns ending quarter and year of period of required quarters of coverage for disability insured status, for period before prior disability.

C++
const QtrYear& getQcDisDate6() const;
Collapse Expand Returns

Ending quarter and year of period of required quarters of coverage for disability insured status, for period before prior disability.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcDisDateNonFreeze1 Method

PiaData::getQcDisDateNonFreeze1 Method
PiaData Class PiaData Members PiaData Methods

Returns beginning quarter and year of period of required quarters of coverage for disability insured status for non-freeze.

C++
const QtrYear& getQcDisDateNonFreeze1() const;
Collapse Expand Returns

Beginning quarter and year of period of required quarters of coverage for disability insured status for non-freeze.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcDisDateNonFreeze2 Method

PiaData::getQcDisDateNonFreeze2 Method
PiaData Class PiaData Members PiaData Methods

Returns ending quarter and year of period of required quarters of coverage for disability insured status for non-freeze.

C++
const QtrYear& getQcDisDateNonFreeze2() const;
Collapse Expand Returns

Ending quarter and year of period of required quarters of coverage for disability insured status for non-freeze.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcDisQtr Method

PiaData::getQcDisQtr Method
PiaData Class PiaData Members PiaData Methods

Returns number of quarters over which quarters of coverage must be earned for disability insured status.

C++
int getQcDisQtr() const;
Collapse Expand Returns

Number of quarters over which quarters of coverage must be earned for disability insured status.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcDisQtr2 Method

PiaData::getQcDisQtr2 Method
PiaData Class PiaData Members PiaData Methods

Returns number of quarters over which quarters of coverage must be earned for disability insured status, based on elapsed quarters after disability cessation.

C++
int getQcDisQtr2() const;
Collapse Expand Returns

Number of quarters over which quarters of coverage must be earned for disability insured status, based on elapsed quarters after disability cessation.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcDisQtrNonFreeze Method

PiaData::getQcDisQtrNonFreeze Method
PiaData Class PiaData Members PiaData Methods

Returns number of quarters over which quarters of coverage must be earned for disability insured status for non-freeze.

C++
int getQcDisQtrNonFreeze() const;
Collapse Expand Returns

Number of quarters over which quarters of coverage must be earned for disability insured status for non-freeze.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcDisReq Method

PiaData::getQcDisReq Method
PiaData Class PiaData Members PiaData Methods

Returns number of quarters required for disability insured status.

C++
int getQcDisReq() const;
Collapse Expand Returns

Number of quarters required for disability insured status.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcDisReqNonFreeze Method

PiaData::getQcDisReqNonFreeze Method
PiaData Class PiaData Members PiaData Methods

Returns number of quarters required for disability insured status for non-freeze.

C++
int getQcDisReqNonFreeze() const;
Collapse Expand Returns

Number of quarters required for disability insured status for non-freeze.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcDisYears Method

PiaData::getQcDisYears Method
PiaData Class PiaData Members PiaData Methods

Returns number of years over which quarters of coverage must be earned for disability insured status.

C++
int getQcDisYears() const;
Collapse Expand Returns

Number of years over which quarters of coverage must be earned for disability insured status.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcDisYearsNonFreeze Method

PiaData::getQcDisYearsNonFreeze Method
PiaData Class PiaData Members PiaData Methods

Returns number of years over which quarters of coverage must be earned for disability insured status for non-freeze.

C++
int getQcDisYearsNonFreeze() const;
Collapse Expand Returns

Number of years over which quarters of coverage must be earned for disability insured status for non-freeze.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcReq Method

PiaData::getQcReq Method
PiaData Class PiaData Members PiaData Methods

Returns number of quarters required for fully insured status.

C++
int getQcReq() const;
Collapse Expand Returns

Number of quarters required for fully insured status.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcReqNonFreeze Method

PiaData::getQcReqNonFreeze Method
PiaData Class PiaData Members PiaData Methods

Returns number of quarters required for fully insured non-freeze status.

C++
int getQcReqNonFreeze() const;
Collapse Expand Returns

Number of quarters required for fully insured non-freeze status.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcReqPerm Method

PiaData::getQcReqPerm Method
PiaData Class PiaData Members PiaData Methods

Returns number of quarters required for permanently insured status.

C++
int getQcReqPerm() const;
Collapse Expand Returns

Number of quarters required for permanently insured status.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcReqPermNonFreeze Method

PiaData::getQcReqPermNonFreeze Method
PiaData Class PiaData Members PiaData Methods

Returns number of quarters required for permanently insured non-freeze status.

C++
int getQcReqPermNonFreeze() const;
Collapse Expand Returns

Number of quarters required for permanently insured non-freeze status.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcTotal Method

PiaData::getQcTotal Method
PiaData Class PiaData Members PiaData Methods

Returns total number of quarters earned for fully insured status.

C++
int getQcTotal() const;
Collapse Expand Returns

Total number of quarters earned for fully insured status.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcTotal50 Method

PiaData::getQcTotal50 Method
PiaData Class PiaData Members PiaData Methods

Returns total number of quarters earned from 1937 to 1950.

C++
int getQcTotal50() const;
Collapse Expand Returns

Total number of quarters earned from 1937 to 1950.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcTotal51 Method

PiaData::getQcTotal51 Method
PiaData Class PiaData Members PiaData Methods

Returns total number of quarters earned after 1950.

C++
int getQcTotal51() const;
Collapse Expand Returns

Total number of quarters earned after 1950.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcTotal51NonFreeze Method

PiaData::getQcTotal51NonFreeze Method
PiaData Class PiaData Members PiaData Methods

Returns total number of quarters earned after 1950 for non-freeze.

C++
int getQcTotal51NonFreeze() const;
Collapse Expand Returns

Total number of quarters earned after 1950 for non-freeze.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcTotalDis Method

PiaData::getQcTotalDis Method
PiaData Class PiaData Members PiaData Methods

Returns total number of quarters earned for disability insured status.

C++
int getQcTotalDis() const;
Collapse Expand Returns

Total number of quarters earned for disability insured status.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcTotalDisNonFreeze Method

PiaData::getQcTotalDisNonFreeze Method
PiaData Class PiaData Members PiaData Methods

Returns total number of quarters earned for disability insured status for non-freeze.

C++
int getQcTotalDisNonFreeze() const;
Collapse Expand Returns

Total number of quarters earned for disability insured status for non-freeze.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcTotalNonFreeze Method

PiaData::getQcTotalNonFreeze Method
PiaData Class PiaData Members PiaData Methods

Returns total number of quarters earned for fully insured non-freeze status.

C++
int getQcTotalNonFreeze() const;
Collapse Expand Returns

Total number of quarters earned for fully insured non-freeze status.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getQcTotalRel Method

PiaData::getQcTotalRel Method
PiaData Class PiaData Members PiaData Methods

Returns total number of quarters earned for totalization benefit computation.

C++
int getQcTotalRel() const;
Collapse Expand Returns

Total number of quarters earned for disability insured status.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::getRelEarnPositionAverage Method

PiaData::getRelEarnPositionAverage Method
PiaData Class PiaData Members PiaData Methods

Returns average relative earnings position.

C++
double getRelEarnPositionAverage() const;
Collapse Expand Returns

Average relative earnings position.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::initialize Method

PiaData::initialize Method
PiaData Class PiaData Members PiaData Methods

Initializes computed values to zero.

C++
void initialize();
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::qcCal Method

PiaData::qcCal Method
PiaData Class PiaData Members PiaData Methods

Calculates annual quarters of coverage.

C++
void qcCal(
    WorkerDataGeneral& workerData,
    const Qcamt& qcamt
);
Collapse Expand Parameters
Parameters | Description
WorkerDataGeneral& workerData | Basic worker data.
const Qcamt& qcamt | Amount required for quarter of coverage.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCCAL if amount required for quarter of coverage is not initialized (only in debug mode); if years of earnings extend beyond years of amount required for quarter of coverage (only in debug mode).
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::qcDiSpec Method

PiaData::qcDiSpec Method
PiaData Class PiaData Members PiaData Methods

Sets first quarter and year of disability insured period for special insured status (called only if calculated first quarter and year are in quarter of age 21 or earlier).

C++
void qcDiSpec(
    int qcdiqtrt,
    int period
);
Collapse Expand Parameters
Parameters | Description
int qcdiqtrt | Number of elapsed quarters accounted for before considering special insured status.
int period | Period to consider (0 for prior to most recent disability, 1 for prior to next most recent disability).
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::qcDiSpecNonFreeze Method

PiaData::qcDiSpecNonFreeze Method
PiaData Class PiaData Members PiaData Methods

Sets first quarter and year of disability insured period for special insured status (called only if calculated first quarter and year are in quarter of age 21 or earlier).

C++
void qcDiSpecNonFreeze(
    int qcdiqtrt,
    int period
);
Collapse Expand Parameters
Parameters | Description
int qcdiqtrt | Number of elapsed quarters accounted for before considering special insured status.
int period | Period to consider (0 for prior to most recent disability, 1 for prior to next most recent disability).
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::qcDisCal Method

PiaData::qcDisCal Method
PiaData Class PiaData Members PiaData Methods

Calculates earned quarters of coverage in disability insured period.

C++
void qcDisCal(
    const WorkerDataGeneral& workerData
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
Collapse Expand Remarks

Assumes starting and ending dates have already been set, by calling PiaData::qcDisReqCal.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCDISCAL if any starting or ending dates are out of range (only in debug mode).
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::qcDisNonFreezeCal Method

PiaData::qcDisNonFreezeCal Method
PiaData Class PiaData Members PiaData Methods

Calculates earned quarters of coverage in disability insured period for non-freeze.

C++
void qcDisNonFreezeCal(
    const WorkerDataGeneral& workerData
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
Collapse Expand Remarks

Assumes starting and ending dates have already been set, by calling PiaData::qcDisReqNonFreezeCal.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCDISCAL if any starting or ending dates are out of range (only in debug mode).
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::qcDisReq2Cal Method

PiaData::qcDisReq2Cal Method
PiaData Class PiaData Members PiaData Methods

Determines number of required quarters of coverage for DI insured status, based on elapsed quarters after disability cessation.

C++
void qcDisReq2Cal(
    const WorkerDataGeneral& workerData,
    const DateMoyr& date
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
const DateMoyr& date | The date for which required quarters of coverage are desired.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::qcDisReqCal Method

PiaData::qcDisReqCal Method
PiaData Class PiaData Members PiaData Methods

Determines number of required quarters of coverage for DI insured status.

C++
void qcDisReqCal(
    const WorkerDataGeneral& workerData,
    const DateMoyr& date,
    int trial,
    bool dospecial,
    bool dofreeze
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
const DateMoyr& date | The date for which required quarters of coverage are desired.
int trial | Number of quarters to go beyond onset quarter.
bool dospecial | Indicator for special insured status calculation. If false, do not do special insured status calculation. If true, do special insured status calculation.
bool dofreeze | Indicator for assuming period between onset and waiting period in a prior period of disability is a freeze period. If false, do not assume it is a freeze period (excluded period starts with waiting period). If true, assume it is a freeze period (excluded period starts with onset).
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DISREQCAL1 if year in most recent freeze period is out of range (only in debug mode); of type PIA_IDS_DISREQCAL2 if year in next most recent freeze period is out of range (only in debug mode).
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::qcDisReqNonFreezeCal Method

PiaData::qcDisReqNonFreezeCal Method
PiaData Class PiaData Members PiaData Methods

Determines number of required quarters of coverage for DI insured status for non-freeze.

C++
void qcDisReqNonFreezeCal(
    const WorkerDataGeneral& workerData,
    const DateMoyr& date,
    int trial,
    bool dospecial,
    bool dofreeze
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
const DateMoyr& date | The date for which required quarters of coverage are desired.
int trial | Number of quarters to go beyond onset quarter.
bool dospecial | Indicator for special insured status calculation. If false, do not do special insured status calculation. If true, do special insured status calculation.
bool dofreeze | Indicator for assuming period between onset and waiting period in a prior period of disability is a freeze period. If false, do not assume it is a freeze period (excluded period starts with waiting period). If true, assume it is a freeze period (excluded period starts with onset).
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DISREQCAL1 if year in most recent freeze period is out of range (only in debug mode); of type PIA_IDS_DISREQCAL2 if year in next most recent freeze period is out of range (only in debug mode).
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::qcTotalCal Method

PiaData::qcTotalCal Method
PiaData Class PiaData Members PiaData Methods

Calculates total quarters of coverage. Assumes annual quarters of coverage are already known, either from 1951 or from 1978.

C++
void qcTotalCal(
    const WorkerDataGeneral& workerData,
    const QtrYear& qtrYear
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
const QtrYear& qtrYear | Calendar quarter and year through which qc's are calculated.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::qcTotalNonFreezeCal Method

PiaData::qcTotalNonFreezeCal Method
PiaData Class PiaData Members PiaData Methods

Calculates total quarters of coverage for non-freeze. Assumes annual quarters of coverage are already known, either from 1951 or from 1978, and that qcs prior to 1951 have already been computed as well by PiaData::qcTotalCal.

C++
void qcTotalNonFreezeCal(
    const WorkerDataGeneral& workerData,
    const QtrYear& qtrYear
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
const QtrYear& qtrYear | Calendar quarter and year through which qc's are calculated.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setAmend90 Method

PiaData::setAmend90 Method
PiaData Class PiaData Members PiaData Methods

Sets indicator for entitlement after 1990 amendments.

C++
void setAmend90(
    bool newAmend90
);
Collapse Expand Parameters
Parameters | Description
bool newAmend90 | New indicator.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setArf Method

PiaData::setArf Method
PiaData Class PiaData Members PiaData Methods

Sets actuarial reduction factor or delayed retirement credit.

C++
void setArf(
    double newArf
);
Collapse Expand Parameters
Parameters | Description
double newArf | New actuarial reduction factor or delayed retirement credit.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setArfApp Method

PiaData::setArfApp Method
PiaData Class PiaData Members PiaData Methods

Sets special minimum-delayed retirement credit indicator.

C++
void setArfApp(
    arf_app_type newArfApp
);
Collapse Expand Parameters
Parameters | Description
arf_app_type newArfApp | New indicator.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setBirthDateMinus1 Method

PiaData::setBirthDateMinus1 Method
PiaData Class PiaData Members PiaData Methods

Sets day before worker's birth.

C++
void setBirthDateMinus1(
    const boost::gregorian::date& birthDate
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& birthDate | Worker's date of birth.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setChildCareYearsTotal Method

PiaData::setChildCareYearsTotal Method
PiaData Class PiaData Members PiaData Methods

Sets total number of child care years.

C++
void setChildCareYearsTotal(
    int totalYears
);
Collapse Expand Parameters
Parameters | Description
int totalYears | New total number of child care years.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setDeemedQcReq Method

PiaData::setDeemedQcReq Method
PiaData Class PiaData Members PiaData Methods

Sets number of quarters of coverage required for deemed insured status.

C++
void setDeemedQcReq(
    int newDeemedQcReq
);
Collapse Expand Parameters
Parameters | Description
int newDeemedQcReq | New required quarters for deemed insured status.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setDoEarlyQcs Method

PiaData::setDoEarlyQcs Method
PiaData Class PiaData Members PiaData Methods

Sets indicator for calculation of quarters of coverage for early years.

C++
void setDoEarlyQcs(
    bool newDoEarlyQcs
);
Collapse Expand Parameters
Parameters | Description
bool newDoEarlyQcs | New indicator. true - Calculate total by adding earnings qcs, railroad qcs, and military service qcs (as in Anypia). false - Use annual totals as read in (as for microsimulation data).
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setEarn3750ms Method

PiaData::setEarn3750ms Method
PiaData Class PiaData Members PiaData Methods

Sets military service earnings, 1937-50.

C++
void setEarn3750ms(
    double newEarn3750ms
);
Collapse Expand Parameters
Parameters | Description
double newEarn3750ms | New value of military service earnings, 1937-50.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setEligDate Method

PiaData::setEligDate Method
PiaData Class PiaData Members PiaData Methods

Sets month and year of eligibility before considering disability.

C++
void setEligDate(
    const DateMoyr& newEligDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& newEligDate | New date of eligibility.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setEligYear Method

PiaData::setEligYear Method
PiaData Class PiaData Members PiaData Methods

Sets eligibility year after considering prior disability onset.

C++
void setEligYear(
    int newEligYear
);
Collapse Expand Parameters
Parameters | Description
int newEligYear | New eligibility year.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setEligYearNonFreeze Method

PiaData::setEligYearNonFreeze Method
PiaData Class PiaData Members PiaData Methods

Sets eligibility year for non-freeze computations.

C++
void setEligYearNonFreeze(
    int newEligYear
);
Collapse Expand Parameters
Parameters | Description
int newEligYear | New eligibility year.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setFinsCode2 Method

PiaData::setFinsCode2 Method
PiaData Class PiaData Members PiaData Methods

Sets fully insured status code as used in oact printouts.

C++
void setFinsCode2(
    char newFinsCode2
);
Collapse Expand Parameters
Parameters | Description
char newFinsCode2 | New insured status code.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setFinsNonFreezeCode2 Method

PiaData::setFinsNonFreezeCode2 Method
PiaData Class PiaData Members PiaData Methods

Sets fully insured non-freeze status code as used in oact printouts.

C++
void setFinsNonFreezeCode2(
    char newFinsNonFreezeCode2
);
Collapse Expand Parameters
Parameters | Description
char newFinsNonFreezeCode2 | New insured non-freeze status code.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setFullInsDate Method

PiaData::setFullInsDate Method
PiaData Class PiaData Members PiaData Methods

Sets date fully insured status is attained.

C++
void setFullInsDate(
    const DateMoyr& newFullInsDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& newFullInsDate | New date fully insured status is attained.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setFullRetDate Method

PiaData::setFullRetDate Method
PiaData Class PiaData Members PiaData Methods

Sets date of attainment of normal retirement age, but no earlier than January 1937.

C++
void setFullRetDate();
Collapse Expand Remarks

Assumes that day before birth and full retirement age have already been calculated.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setIappn Method

PiaData::setIappn Method
PiaData Class PiaData Members PiaData Methods

Sets number of applicable pia calculation method.

C++
void setIappn(
    int newIappn
);
Collapse Expand Parameters
Parameters | Description
int newIappn | New number of applicable pia method.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setIapps Method

PiaData::setIapps Method
PiaData Class PiaData Members PiaData Methods

Sets support pia method number.

C++
void setIapps(
    int newIapps
);
Collapse Expand Parameters
Parameters | Description
int newIapps | New support pia method number.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setIbeginTotal Method

PiaData::setIbeginTotal Method
PiaData Class PiaData Members PiaData Methods

Sets first year of attributed earnings in totalization case.

C++
void setIbeginTotal(
    const WorkerDataGeneral& workerData
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setIendTotal Method

PiaData::setIendTotal Method
PiaData Class PiaData Members PiaData Methods

Sets last year of attributed earnings in totalization case.

C++
void setIendTotal(
    const WorkerDataGeneral& workerData
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
Collapse Expand Remarks

This is set to the last year of earnings for the record, or the last year actually used in the current computation, whichever is earlier.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setMonthsArdri Method

PiaData::setMonthsArdri Method
PiaData Class PiaData Members PiaData Methods

Sets number of months of increment or reduction.

C++
void setMonthsArdri(
    int newMonthsArdri
);
Collapse Expand Parameters
Parameters | Description
int newMonthsArdri | New number of months.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setOverMax Method

PiaData::setOverMax Method
PiaData Class PiaData Members PiaData Methods

Sets indicator for earnings over maximum.

C++
void setOverMax(
    bool newOverMax
);
Collapse Expand Parameters
Parameters | Description
bool newOverMax | New indicator.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setPifc Method

PiaData::setPifc Method
PiaData Class PiaData Members PiaData Methods

Sets code for type of pia.

C++
void setPifc(
    char newPifc
);
Collapse Expand Parameters
Parameters | Description
char newPifc | New pia factor code.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setQc3 Method

PiaData::setQc3 Method
PiaData Class PiaData Members PiaData Methods

Sets some quarter of coverage amounts.

C++
void setQc3(
    WorkerDataGeneral& workerData
);
Collapse Expand Parameters
Parameters | Description
WorkerDataGeneral& workerData | Basic worker data.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setQc3750ms Method

PiaData::setQc3750ms Method
PiaData Class PiaData Members PiaData Methods

Sets military service quarters of coverage, 1937-50.

C++
void setQc3750ms(
    int newQc3750ms
);
Collapse Expand Parameters
Parameters | Description
int newQc3750ms | New value of military service qcs, 1937-50.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setQc3750simp Method

PiaData::setQc3750simp Method
PiaData Class PiaData Members PiaData Methods

Sets simplified quarters of coverage, 1937-50.

C++
void setQc3750simp(
    int newQc3750simp
);
Collapse Expand Parameters
Parameters | Description
int newQc3750simp | New value of simplified qcs, 1937-50.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setQcCurrent Method

PiaData::setQcCurrent Method
PiaData Class PiaData Members PiaData Methods

Sets quarters of coverage earned in prior 3 years.

C++
void setQcCurrent(
    int newQcCurrent
);
Collapse Expand Parameters
Parameters | Description
int newQcCurrent | New quarters of coverage earned in prior 3 years.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setQcCurrentNonFreeze Method

PiaData::setQcCurrentNonFreeze Method
PiaData Class PiaData Members PiaData Methods

Sets quarters of coverage earned in prior 3 years for non-freeze.

C++
void setQcCurrentNonFreeze(
    int newQcCurrentNonFreeze
);
Collapse Expand Parameters
Parameters | Description
int newQcCurrentNonFreeze | New quarters of coverage earned in prior 3 years for non-freeze.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setQcReq Method

PiaData::setQcReq Method
PiaData Class PiaData Members PiaData Methods

Sets number of quarters required for fully insured status.

C++
void setQcReq(
    int newQcReq
);
Collapse Expand Parameters
Parameters | Description
int newQcReq | New required number of quarters.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setQcReqNonFreeze Method

PiaData::setQcReqNonFreeze Method
PiaData Class PiaData Members PiaData Methods

Sets number of quarters required for fully insured non-freeze status.

C++
void setQcReqNonFreeze(
    int newQcReqNonFreeze
);
Collapse Expand Parameters
Parameters | Description
int newQcReqNonFreeze | New required number of quarters.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setQcReqPerm Method

PiaData::setQcReqPerm Method
PiaData Class PiaData Members PiaData Methods

Sets number of quarters required for permanently insured status.

C++
void setQcReqPerm(
    int newQcReqPerm
);
Collapse Expand Parameters
Parameters | Description
int newQcReqPerm | New required number of quarters.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setQcReqPermNonFreeze Method

PiaData::setQcReqPermNonFreeze Method
PiaData Class PiaData Members PiaData Methods

Sets number of quarters required for permanently insured non-freeze status.

C++
void setQcReqPermNonFreeze(
    int newQcReqPermNonFreeze
);
Collapse Expand Parameters
Parameters | Description
int newQcReqPermNonFreeze | New required number of quarters.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setQcTotal Method

PiaData::setQcTotal Method
PiaData Class PiaData Members PiaData Methods

Sets total quarters of coverage.

C++
void setQcTotal(
    int newQcTotal
);
Collapse Expand Parameters
Parameters | Description
int newQcTotal | New total quarters of coverage.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setQcTotal50 Method

PiaData::setQcTotal50 Method
PiaData Class PiaData Members PiaData Methods

Sets quarters of coverage prior to 1951.

C++
void setQcTotal50(
    int newQcTotal50
);
Collapse Expand Parameters
Parameters | Description
int newQcTotal50 | New quarters of coverage prior to 1951.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setQcTotalNonFreeze Method

PiaData::setQcTotalNonFreeze Method
PiaData Class PiaData Members PiaData Methods

Sets total quarters of coverage for non-freeze.

C++
void setQcTotalNonFreeze(
    int newQcTotalNonFreeze
);
Collapse Expand Parameters
Parameters | Description
int newQcTotalNonFreeze | New total quarters of coverage for non-freeze.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setQcTotalRel Method

PiaData::setQcTotalRel Method
PiaData Class PiaData Members PiaData Methods

Sets total quarters of coverage earned for a totalization benefit computation.

C++
void setQcTotalRel(
    int newQcTotalRel
);
Collapse Expand Parameters
Parameters | Description
int newQcTotalRel | New total quarters of coverage earned for a totalization benefit computation.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::setRelEarnPositionAverage Method

PiaData::setRelEarnPositionAverage Method
PiaData Class PiaData Members PiaData Methods

Sets average relative earnings position.

C++
void setRelEarnPositionAverage(
    double newRelEarnPosition
);
Collapse Expand Parameters
Parameters | Description
double newRelEarnPosition | New average relative earnings position.
Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData::updateMilServ Method

PiaData::updateMilServ Method
PiaData Class PiaData Members PiaData Methods

Updates military service earnings and quarters of coverage.

C++
void updateMilServ(
    const WorkerDataGeneral& workerData
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
Collapse Expand Remarks

This is called in earnProjection.

Collapse Expand Group

PiaData Methods

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Methods


PiaData Operators

PiaData Operators
PiaData Class Legend

The operators of the PiaData class are listed here.

Collapse Expand Class

PiaData Class

Collapse Expand Public Operators
Name | Description
= | Sets this instance equal to another instance.
Collapse Expand Links
PiaData Class, Legend


PiaData::= Operator

PiaData::= Operator
PiaData Class PiaData Members PiaData Operators

Sets this instance equal to another instance.

C++
PiaData& operator =(
    const PiaData& newData
);
Collapse Expand Parameters
Parameters | Description
const PiaData& newData | The instance to copy from.
Collapse Expand Returns

A reference to this instance.

Collapse Expand Group

PiaData Operators

Collapse Expand Links
PiaData Class, PiaData Members, PiaData Operators


PiaDataArray Class

PiaDataArray Class
PiaDataArray Enumerations PiaDataArray Data Members PiaDataArray Methods PiaDataArray Members PiadataArray.h Classes

Manages an array of PiaData's, representing one family.

Collapse Expand Class Hierarchy
  PiaDataArray
C++
class PiaDataArray;
Collapse Expand File

File: PiadataArray.h

Module: PiaData Library

Collapse Expand Remarks

Manages an array of PiaData's, representing one family.

Collapse Expand Group

Classes

Collapse Expand Links
PiaDataArray Enumerations, PiaDataArray Data Members, PiaDataArray Methods, PiaDataArray Members, PiadataArray.h, Classes


PiaDataArray Members

PiaDataArray Members
Enumerations PiaDataArray Class Legend Public Data Members Public Methods

The following tables list the members exposed by PiaDataArray.

Collapse Expand Enumerations
Name | Description
DimLimits | Constant for dimensioning.
Collapse Expand Class

PiaDataArray Class

Collapse Expand Public Data Members
Name | Description
piaData | Array of worker's pia data.
Collapse Expand Public Methods
Name | Description
PiaDataArray | Initializes arrays used in PiadataArray.
deleteContents | Resets all values to zero.
famSizeCheck | Checks if family size is ok.
getFamSize | Returns family size (not including worker).
setFamSize | Sets family size (not including worker).
~PiaDataArray | Releases memory.
Collapse Expand Links
Enumerations, PiaDataArray Class, Legend, Public Data Members, Public Methods


PiaDataArray::PiaDataArray Constructor

PiaDataArray::PiaDataArray Constructor
PiaDataArray Class PiaDataArray Members PiaDataArray Class

Initializes arrays used in PiadataArray.

C++
PiaDataArray();
Collapse Expand Remarks

Allocates memory for the PiaData's.

Collapse Expand Class

PiaDataArray Class

Collapse Expand Links
PiaDataArray Class, PiaDataArray Members, PiaDataArray Class


PiaDataArray::~PiaDataArray Destructor

PiaDataArray::~PiaDataArray Destructor
PiaDataArray Class PiaDataArray Members PiaDataArray Class

Releases memory.

C++
~PiaDataArray();
Collapse Expand Remarks

Deletes memory for the PiaData's.

Collapse Expand Class

PiaDataArray Class

Collapse Expand Links
PiaDataArray Class, PiaDataArray Members, PiaDataArray Class


PiaDataArray Enumerations

PiaDataArray Enumerations
Enumerations PiaDataArray Class Legend

The enumerations of the PiaDataArray class are listed here.

Collapse Expand Enumerations
Name | Description
DimLimits | Constant for dimensioning.
Collapse Expand Class

PiaDataArray Class

Collapse Expand Links
Enumerations, PiaDataArray Class, Legend


PiaDataArray::DimLimits Enumeration

PiaDataArray::DimLimits Enumeration
PiadataArray.h PiaDataArray Enumerations

Constant for dimensioning.

C++
enum DimLimits {
  MAXFAMSIZE = 15
};
Collapse Expand File

File: PiadataArray.h

Module: PiaData Library

Collapse Expand Members
Members | Description
MAXFAMSIZE = 15 | Maximum family size.
Collapse Expand Group

PiaDataArray Enumerations

Collapse Expand Links
PiadataArray.h, PiaDataArray Enumerations


PiaDataArray Data Members

PiaDataArray Data Members
PiaDataArray Class Legend Public Data Members

The data members of the PiaDataArray class are listed here.

Collapse Expand Class

PiaDataArray Class

Collapse Expand Public Data Members
Name | Description
piaData | Array of worker's pia data.
Collapse Expand Links
PiaDataArray Class, Legend, Public Data Members


PiaDataArray::piaData Data Member

PiaDataArray::piaData Data Member
PiaDataArray Class PiaDataArray Members PiaDataArray Data Members

Array of worker's pia data.

C++
PiaData* piaData[MAXFAMSIZE];
Collapse Expand Group

PiaDataArray Data Members

Collapse Expand Links
PiaDataArray Class, PiaDataArray Members, PiaDataArray Data Members


PiaDataArray Methods

PiaDataArray Methods
PiaDataArray Class Legend Public Methods

The methods of the PiaDataArray class are listed here.

Collapse Expand Class

PiaDataArray Class

Collapse Expand Public Methods
Name | Description
deleteContents | Resets all values to zero.
famSizeCheck | Checks if family size is ok.
getFamSize | Returns family size (not including worker).
setFamSize | Sets family size (not including worker).
Collapse Expand Links
PiaDataArray Class, Legend, Public Methods


PiaDataArray::deleteContents Method

PiaDataArray::deleteContents Method
PiaDataArray Class PiaDataArray Members PiaDataArray Methods

Resets all values to zero.

C++
void deleteContents();
Collapse Expand Remarks

Calls PiaData::deleteContents for each item in the array.

Collapse Expand Group

PiaDataArray Methods

Collapse Expand Links
PiaDataArray Class, PiaDataArray Members, PiaDataArray Methods


PiaDataArray::famSizeCheck Method

PiaDataArray::famSizeCheck Method
PiaDataArray Class PiaDataArray Members PiaDataArray Methods

Checks if family size is ok.

C++
static void famSizeCheck(
    int newFamSize
);
Collapse Expand Parameters
Parameters | Description
int newFamSize | Family size to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FAMSIZE if family size is out of bounds.
Collapse Expand Group

PiaDataArray Methods

Collapse Expand Links
PiaDataArray Class, PiaDataArray Members, PiaDataArray Methods


PiaDataArray::getFamSize Method

PiaDataArray::getFamSize Method
PiaDataArray Class PiaDataArray Members PiaDataArray Methods

Returns family size (not including worker).

C++
int getFamSize() const;
Collapse Expand Returns

Family size (not including worker).

Collapse Expand Group

PiaDataArray Methods

Collapse Expand Links
PiaDataArray Class, PiaDataArray Members, PiaDataArray Methods


PiaDataArray::setFamSize Method

PiaDataArray::setFamSize Method
PiaDataArray Class PiaDataArray Members PiaDataArray Methods

Sets family size (not including worker).

C++
void setFamSize(
    int newFamSize
);
Collapse Expand Parameters
Parameters | Description
int newFamSize | Family size to use.
Collapse Expand Group

PiaDataArray Methods

Collapse Expand Links
PiaDataArray Class, PiaDataArray Members, PiaDataArray Methods


PiaMethod Class

PiaMethod Class
PiaMethod Enumerations PiaMethod Data Members PiaMethod Methods PiaMethod Members PiaMethod.h Classes

Parent of the various methods required for calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  PiaMethod
C++
class PiaMethod;
Collapse Expand File

File: PiaMethod.h

Module: PiaData Library

Collapse Expand Remarks

Child classes are DibGuar, FrozMin, OldPia, and WageIndGeneral, and their children.

Collapse Expand See Also

DibGuar, FrozMin, OldPia, WageIndGeneral

Collapse Expand Group

Classes

Collapse Expand Links
PiaMethod Enumerations, PiaMethod Data Members, PiaMethod Methods, PiaMethod Members, PiaMethod.h, Classes


PiaMethod Members

PiaMethod Members
Enumerations PiaMethod Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PiaMethod.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

PiaMethod Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
Collapse Expand Public Data Members
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
Collapse Expand Public Methods
Name | Description
PiaMethod | Initializes this instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Calculates pia and mfb for this method.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Returns true if this method is applicable.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~PiaMethod | Destructor.
Collapse Expand Links
Enumerations, PiaMethod Class, Legend, Protected Data Members, Public Data Members, Public Methods


PiaMethod::PiaMethod Constructor

PiaMethod::PiaMethod Constructor
PiaMethod Class PiaMethod Members PiaMethod Class

Initializes this instance.

C++
PiaMethod(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear,
    const std::string& newTitle,
    pia_type newMethod
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
const std::string& newTitle | Title of this method.
pia_type newMethod | Number of this method.
Collapse Expand Class

PiaMethod Class

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Class


PiaMethod::~PiaMethod Destructor

PiaMethod::~PiaMethod Destructor
PiaMethod Class PiaMethod Members PiaMethod Class

Destructor.

C++
virtual ~PiaMethod();
Collapse Expand Class

PiaMethod Class

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Class


PiaMethod Enumerations

PiaMethod Enumerations
Enumerations PiaMethod Class Legend

The enumerations of the PiaMethod class are listed here.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

PiaMethod Class

Collapse Expand Links
Enumerations, PiaMethod Class, Legend


PiaMethod::WindfallElimType Enumeration

PiaMethod::WindfallElimType Enumeration
PiaMethod.h PiaMethod Enumerations

Type of windfall elimination (WEP).

C++
enum WindfallElimType {
  NOWINDFALLELIM,
  HAS30YEARS,
  ONEHALFPENSION,
  REDUCEDPERC
};
Collapse Expand File

File: PiaMethod.h

Module: PiaData Library

Collapse Expand Members
Members | Description
NOWINDFALLELIM | WEP not applicable (no noncovered pension, or eligible before 1986).
HAS30YEARS | WEP applicable, but have 30 years of coverage.
ONEHALFPENSION | PIA reduced by one-half of noncovered pension.
REDUCEDPERC | First benefit formula factor reduced.
Collapse Expand Group

PiaMethod Enumerations

Collapse Expand Links
PiaMethod.h, PiaMethod Enumerations


PiaMethod::app_type Enumeration

PiaMethod::app_type Enumeration
PiaMethod.h PiaMethod Enumerations

Type of method applicability.

C++
enum app_type {
  NOT_APPLICABLE,
  APPLICABLE,
  HIGH_PIA,
  SUPPORT_PIA
};
Collapse Expand File

File: PiaMethod.h

Module: PiaData Library

Collapse Expand Members
Members | Description
NOT_APPLICABLE | Method not applicable.
APPLICABLE | Method is applicable, but is not the highest or the support PIA.
HIGH_PIA | Method has highest PIA.
SUPPORT_PIA | Method has support PIA.
Collapse Expand Group

PiaMethod Enumerations

Collapse Expand Links
PiaMethod.h, PiaMethod Enumerations


PiaMethod::cpi_year_type Enumeration

PiaMethod::cpi_year_type Enumeration
PiaMethod.h PiaMethod Enumerations

Years of benefit increases applied.

C++
enum cpi_year_type {
  FIRST_YEAR,
  YEAR_ELIG,
  YEAR_ENT,
  YEAR_BEN,
  YEAR_TABLE,
  MAXIYCPI
};
Collapse Expand File

File: PiaMethod.h

Module: PiaData Library

Collapse Expand Members
Members | Description
FIRST_YEAR | First year.
YEAR_ELIG | First year starting with year of eligibility.
YEAR_ENT | Last year ending with year of entitlement.
YEAR_BEN | Last year ending with year of benefit.
YEAR_TABLE | Last year for table changes.
MAXIYCPI | Number of start and end years of CPI increases.
Collapse Expand Group

PiaMethod Enumerations

Collapse Expand Links
PiaMethod.h, PiaMethod Enumerations


PiaMethod::dis_mfb_cap_type Enumeration

PiaMethod::dis_mfb_cap_type Enumeration
PiaMethod.h PiaMethod Enumerations

Disability MFB cap indicator.

C++
enum dis_mfb_cap_type {
  NO_CAP,
  PIA_1_5,
  AIME_85,
  PIA_1_0
};
Collapse Expand File

File: PiaMethod.h

Module: PiaData Library

Collapse Expand Members
Members | Description
NO_CAP | No disability MFB cap applies.
PIA_1_5 | 1.5 * PIA.
AIME_85 | 0.85 * AIME.
PIA_1_0 | 1.0 * PIA.
Collapse Expand Group

PiaMethod Enumerations

Collapse Expand Links
PiaMethod.h, PiaMethod Enumerations


PiaMethod::pia_type Enumeration

PiaMethod::pia_type Enumeration
PiaMethod.h PiaMethod Enumerations

Type of calculation method.

C++
enum pia_type {
  OLD_START,
  PIA_TABLE,
  WAGE_IND,
  TRANS_GUAR,
  SPEC_MIN,
  REIND_WID,
  FROZ_MIN,
  CHILD_CARE,
  DIB_GUAR,
  WAGE_IND_NON_FREEZE,
  NO_PIA_TYPE
};
Collapse Expand File

File: PiaMethod.h

Module: PiaData Library

Collapse Expand Members
Members | Description
OLD_START | Old-start method.
PIA_TABLE | Pia table method.
WAGE_IND | Wage-indexed method.
TRANS_GUAR | Transitional guarantee method.
SPEC_MIN | Special minimum method.
REIND_WID | Re-indexed widow(er) method.
FROZ_MIN | Frozen minimum method.
CHILD_CARE | Child care dropout years method.
DIB_GUAR | Disability pia guarantee method.
WAGE_IND_NON_FREEZE | Wage-indexed non-freeze method.
NO_PIA_TYPE | No method.
Collapse Expand Group

PiaMethod Enumerations

Collapse Expand Links
PiaMethod.h, PiaMethod Enumerations


PiaMethod::table_type Enumeration

PiaMethod::table_type Enumeration
PiaMethod.h PiaMethod Enumerations

Old-law PIA table indicator.

C++
enum table_type {
  NO_TABLE = -1,
  PL_1952 = 0,
  PL_1954,
  PL_1958,
  PL_1965,
  PL_1967,
  PL_1969,
  PL_1971,
  PL_1972,
  PL_1973,
  PL_1977,
  NUM_TABLES
};
Collapse Expand File

File: PiaMethod.h

Module: PiaData Library

Collapse Expand Members
Members | Description
NO_TABLE = -1 | PIA table does not apply.
PL_1952 = 0 | 1952 Act.
PL_1954 | 1954 Act.
PL_1958 | 1958 Act.
PL_1965 | 1965 Act.
PL_1967 | 1967 Act.
PL_1969 | 1969 Act.
PL_1971 | 1971 Act.
PL_1972 | 1972 Act.
PL_1973 | 1973 Act.
PL_1977 | 1977 Act.
NUM_TABLES | Number of PIA tables.
Collapse Expand Group

PiaMethod Enumerations

Collapse Expand Links
PiaMethod.h, PiaMethod Enumerations


PiaMethod Data Members

PiaMethod Data Members
PiaMethod Class Legend Protected Data Members Public Data Members

The data members of the PiaMethod class are listed here.

Collapse Expand Class

PiaMethod Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
Collapse Expand Public Data Members
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
Collapse Expand Links
PiaMethod Class, Legend, Protected Data Members, Public Data Members


PiaMethod::earnIndexed Data Member

PiaMethod::earnIndexed Data Member
PiaMethod Class PiaMethod Members PiaMethod Data Members

The worker's earnings after indexing.

C++
DoubleAnnual earnIndexed;
Collapse Expand Group

PiaMethod Data Members

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Data Members


PiaMethod::earnMultiplied Data Member

PiaMethod::earnMultiplied Data Member
PiaMethod Class PiaMethod Members PiaMethod Data Members

The worker's earnings multiplied by average wages of base year.

C++
DoubleAnnual earnMultiplied;
Collapse Expand Group

PiaMethod Data Members

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Data Members


PiaMethod::iorder Data Member

PiaMethod::iorder Data Member
PiaMethod Class PiaMethod Members PiaMethod Data Members

Indicators for use of earnings.

C++
IntAnnual iorder;
Collapse Expand Remarks

The value for each year has the following meaning:

1 | earnings are among highest n.
0 | otherwise.
Collapse Expand Group

PiaMethod Data Members

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Data Members


PiaMethod::mfbElig Data Member

PiaMethod::mfbElig Data Member
PiaMethod Class PiaMethod Members PiaMethod Data Members

MFB at eligibility and succeeding MFB's.

C++
DoubleAnnual mfbElig;
Collapse Expand Group

PiaMethod Data Members

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Data Members


PiaMethod::mfbEnt Data Member

PiaMethod::mfbEnt Data Member
PiaMethod Class PiaMethod Members PiaMethod Data Members

MFB at entitlement.

C++
BenefitAmount mfbEnt;
Collapse Expand Group

PiaMethod Data Members

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Data Members


PiaMethod::mfbsub Data Member

PiaMethod::mfbsub Data Member
PiaMethod Class PiaMethod Members PiaMethod Data Members

Temporary mfb.

C++
double mfbsub;
Collapse Expand Group

PiaMethod Data Members

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Data Members


PiaMethod::piaData Data Member

PiaMethod::piaData Data Member
PiaMethod Class PiaMethod Members PiaMethod Data Members

Pointer to pia calculation data.

C++
const PiaData& piaData;
Collapse Expand Group

PiaMethod Data Members

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Data Members


PiaMethod::piaElig Data Member

PiaMethod::piaElig Data Member
PiaMethod Class PiaMethod Members PiaMethod Data Members

PIA at eligibility and succeeding PIA's.

C++
DoubleAnnual piaElig;
Collapse Expand Group

PiaMethod Data Members

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Data Members


PiaMethod::piaEnt Data Member

PiaMethod::piaEnt Data Member
PiaMethod Class PiaMethod Members PiaMethod Data Members

PIA at entitlement.

C++
BenefitAmount piaEnt;
Collapse Expand Group

PiaMethod Data Members

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Data Members


PiaMethod::piaParams Data Member

PiaMethod::piaParams Data Member
PiaMethod Class PiaMethod Members PiaMethod Data Members

Pointer to pia calculation parameters.

C++
const PiaParams& piaParams;
Collapse Expand Group

PiaMethod Data Members

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Data Members


PiaMethod::piasub Data Member

PiaMethod::piasub Data Member
PiaMethod Class PiaMethod Members PiaMethod Data Members

Temporary pia.

C++
double piasub;
Collapse Expand Group

PiaMethod Data Members

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Data Members


PiaMethod::workerData Data Member

PiaMethod::workerData Data Member
PiaMethod Class PiaMethod Members PiaMethod Data Members

Pointer to worker data.

C++
const WorkerDataGeneral& workerData;
Collapse Expand Group

PiaMethod Data Members

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Data Members


PiaMethod::yearCpi Data Member

PiaMethod::yearCpi Data Member
PiaMethod Class PiaMethod Members PiaMethod Data Members

Years of benefit increases applied.

C++
int yearCpi[MAXIYCPI];
Collapse Expand Group

PiaMethod Data Members

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Data Members


PiaMethod Methods

PiaMethod Methods
PiaMethod Class Legend Public Methods

The methods of the PiaMethod class are listed here.

Collapse Expand Class

PiaMethod Class

Collapse Expand Public Methods
Name | Description
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Calculates pia and mfb for this method.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Returns true if this method is applicable.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
Collapse Expand Links
PiaMethod Class, Legend, Public Methods


PiaMethod::applyColas Method

PiaMethod::applyColas Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Applies benefit increases to 1977 Amendments PIA or MFB.

C++
double applyColas(
    DoubleAnnual& pia77,
    int year1,
    const DateMoyr& dateMoyr2
) const;
Collapse Expand Parameters
Parameters | Description
DoubleAnnual& pia77 | PIA or MFB to be increased.
int year1 | First year of benefit increases.
const DateMoyr& dateMoyr2 | The date up to which to apply benefit increases.
Collapse Expand Returns

PIA or MFB increased by benefit increases.

Collapse Expand Remarks

Calls applyColas, with a fourth argument equal to the second argument.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::applyColasElig Method

PiaMethod::applyColasElig Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Applies benefit increases to 1977 Amendments PIA or MFB.

C++
double applyColasElig(
    DoubleAnnual& pia77,
    int year1,
    const DateMoyr& dateMoyr2,
    int catchupYear
) const;
Collapse Expand Parameters
Parameters | Description
DoubleAnnual& pia77 | PIA or MFB to be increased.
int year1 | First year of benefit increases.
const DateMoyr& dateMoyr2 | The date up to which to apply benefit increases.
int catchupYear | Year of eligibility for catch-up benefit increases.
Collapse Expand Returns

PIA or MFB increased by benefit increases.

Collapse Expand Remarks

The first benefit increase applied is for year year1; it is applied to pia77 at index (year1 - 1). The values are calculated and saved in pia77 sequentially.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::calculate Method

PiaMethod::calculate Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Calculates pia and mfb for this method.

C++
virtual void calculate() = 0;
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::diMax Method

PiaMethod::diMax Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Applies DI maximum provision, including COLAs to date of benefit.

C++
double diMax(
    double amedimax,
    double piamax
);
Collapse Expand Parameters
Parameters | Description
double amedimax | Ame for DI maximum calculation.
double piamax | Pia at date of benefit.
Collapse Expand Returns

MFB from DI maximum provision, including COLAs to date of benefit.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::diMaxNonFreeze Method

PiaMethod::diMaxNonFreeze Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Applies DI maximum provision for non-freeze, including COLAs to date of benefit.

C++
double diMaxNonFreeze(
    double amedimax,
    double piamax
);
Collapse Expand Parameters
Parameters | Description
double amedimax | Ame for DI maximum calculation.
double piamax | Pia at date of benefit.
Collapse Expand Returns

MFB from DI maximum provision for non-freeze, including COLAs to date of benefit.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::dimaxElig Method

PiaMethod::dimaxElig Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Applies DI maximum provision as of year of eligibility.

C++
static double dimaxElig(
    double amedimax,
    double piaelig,
    int year,
    double& capt,
    dis_mfb_cap_type& icapt
);
Collapse Expand Parameters
Parameters | Description
double amedimax | Aime for DI maximum calculation.
double piaelig | Pia as of year of eligibility.
int year | Year prior to year of eligibility.
double& capt | Percentage used in calculation (1.5, 0.85, or 1.0).
dis_mfb_cap_type& icapt | Type of calculation (returned).
Collapse Expand Returns

MFB at eligibility.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::getAme Method

PiaMethod::getAme Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns ame or aime.

C++
double getAme() const;
Collapse Expand Returns

Ame or aime.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::getAmeTotal Method

PiaMethod::getAmeTotal Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns average (indexed) monthly earnings before application of totalization provision, if applicable.

C++
double getAmeTotal() const;
Collapse Expand Returns

Average (indexed) monthly earnings before application of totalization provision, if applicable.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::getApplicable Method

PiaMethod::getApplicable Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns indicator for use of pia calculation method.

C++
app_type getApplicable() const;
Collapse Expand Returns

Indicator for use of pia calculation method.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::getCap Method

PiaMethod::getCap Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns percentage cap for MFB (for DI cases).

C++
double getCap() const;
Collapse Expand Returns

Percentage cap for MFB (for DI cases).

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::getCpiYear Method

PiaMethod::getCpiYear Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns year that benefit increases were applied.

C++
int getCpiYear(
    cpi_year_type index
) const;
Collapse Expand Parameters
Parameters | Description
cpi_year_type index | The type of year that benefit increases were applied for.
Collapse Expand Returns

Year that benefit increases were applied.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::getIndCap Method

PiaMethod::getIndCap Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns disability MFB cap indicator.

C++
dis_mfb_cap_type getIndCap() const;
Collapse Expand Returns

Disability MFB cap indicator.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::getIoasdi Method

PiaMethod::getIoasdi Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns type of benefit.

C++
WorkerDataGeneral::ben_type getIoasdi() const;
Collapse Expand Returns

Type of benefit.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::getMethod Method

PiaMethod::getMethod Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns the calculation method.

C++
pia_type getMethod() const;
Collapse Expand Returns

The calculation method.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::getPiaEligTotal Method

PiaMethod::getPiaEligTotal Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).

C++
BenefitAmount getPiaEligTotal() const;
Collapse Expand Returns

PIA at eligibility before application of totalization provision, if applicable (0 otherwise).

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::getPiaTotal Method

PiaMethod::getPiaTotal Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns PIA before application of totalization provision, if applicable (0 otherwise).

C++
BenefitAmount getPiaTotal() const;
Collapse Expand Returns

PIA before application of totalization provision, if applicable (0 otherwise).

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::getPiaWindfall Method

PiaMethod::getPiaWindfall Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).

C++
BenefitAmount getPiaWindfall() const;
Collapse Expand Returns

PIA at eligibility before application of windfall provision, if applicable (0 otherwise).

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::getTableNum Method

PiaMethod::getTableNum Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns number of applicable PIA table.

C++
table_type getTableNum() const;
Collapse Expand Returns

Number of applicable PIA table.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::getTitle Method

PiaMethod::getTitle Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns title of this method.

C++
const std::string& getTitle() const;
Collapse Expand Returns

Title of this method.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::getWindfall Method

PiaMethod::getWindfall Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns windfall indicator.

C++
virtual PiaMethod::WindfallElimType getWindfall() const;
Collapse Expand Returns

WindfallElimType::NOWINDFALLELIM. This could be overridden in a child class.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::getYearsTotal Method

PiaMethod::getYearsTotal Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns number of years of coverage for windfall elimination provision.

C++
virtual int getYearsTotal() const;
Collapse Expand Returns

0. This could be overridden in a child class.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::getftearn Method

PiaMethod::getftearn Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns sum of high n years of earnings.

C++
double getftearn() const;
Collapse Expand Returns

Sum of high n years of earnings.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::initialize Method

PiaMethod::initialize Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Initializes computed values to zero.

C++
virtual void initialize();
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::isApplicable Method

PiaMethod::isApplicable Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns true if this method is applicable.

C++
virtual bool isApplicable() = 0;
Collapse Expand Returns

True if this method is applicable.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::isPebsAssumptions Method

PiaMethod::isPebsAssumptions Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Returns old Statement assumptions indicator.

C++
bool isPebsAssumptions() const;
Collapse Expand Returns

True if old Statement assumptions (with 1-percent real wage gain).

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::mfbCal Method

PiaMethod::mfbCal Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Calculates an MFB at eligibility under the 1977 law.

C++
double mfbCal(
    const double portionPiaElig[],
    const PercMfb& percMfbTemp,
    int year
);
Collapse Expand Parameters
Parameters | Description
const double portionPiaElig[] | Portion of mfb in each formula interval.
const PercMfb& percMfbTemp | The four mfb formula percentages.
int year | Year to use for rounding.
Collapse Expand Returns

MFB at eligibility.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::orderEarnings Method

PiaMethod::orderEarnings Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Orders earnings and sets indicator for the highest years.

C++
void orderEarnings(
    int first,
    int last,
    int number
);
Collapse Expand Parameters
Parameters | Description
int first | First year of earnings.
int last | Last year of earnings.
int number | Number of years to be selected.
Collapse Expand Remarks

The number of years selected could be less than the desired number, if there are not that many years of earnings.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::prorate Method

PiaMethod::prorate Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Calculates pro rata totalization benefit.

C++
void prorate();
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::setAme Method

PiaMethod::setAme Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Sets ame or aime.

C++
void setAme(
    double newAme
);
Collapse Expand Parameters
Parameters | Description
double newAme | New ame.
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::setAmeTotal Method

PiaMethod::setAmeTotal Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Saves aime before application of totalization provision.

C++
void setAmeTotal();
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::setApplicable Method

PiaMethod::setApplicable Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Sets indicator for use of pia calculation method.

C++
void setApplicable(
    app_type newIapp
);
Collapse Expand Parameters
Parameters | Description
app_type newIapp | Indicator for use of method.
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::setCap Method

PiaMethod::setCap Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Sets percentage cap for MFB (for DI cases).

C++
void setCap(
    double newCap
);
Collapse Expand Parameters
Parameters | Description
double newCap | New cap.
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::setDirty Method

PiaMethod::setDirty Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Sets indicator for non-zero values.

C++
void setDirty();
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::setIndCap Method

PiaMethod::setIndCap Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Sets disability MFB cap indicator.

C++
void setIndCap(
    dis_mfb_cap_type newIndCap
);
Collapse Expand Parameters
Parameters | Description
dis_mfb_cap_type newIndCap | New disability MFB cap indicator.
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::setIoasdi Method

PiaMethod::setIoasdi Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Sets the type of benefit.

C++
void setIoasdi(
    WorkerDataGeneral::ben_type ioasdit
);
Collapse Expand Parameters
Parameters | Description
WorkerDataGeneral::ben_type ioasdit | New type of benefit.
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::setPebsAssumptions Method

PiaMethod::setPebsAssumptions Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Sets Statement assumptions indicator.

C++
void setPebsAssumptions(
    bool newPebsAssumptions
);
Collapse Expand Parameters
Parameters | Description
bool newPebsAssumptions | True if old Statement assumptions (with 1-percent real wage gain).
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::setPiaEligTotal Method

PiaMethod::setPiaEligTotal Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Saves pia at eligibility before application of totalization provision.

C++
void setPiaEligTotal();
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::setPiaTotal Method

PiaMethod::setPiaTotal Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Saves pia before application of totalization provision.

C++
void setPiaTotal();
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::setPiaWindfall Method

PiaMethod::setPiaWindfall Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Saves pia before application of windfall elimination provision.

C++
void setPiaWindfall();
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::setPortionPiaElig Method

PiaMethod::setPortionPiaElig Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Calculates portion of pia at eligibility in each section of mfb formula.

C++
static void setPortionPiaElig(
    double piasub,
    double piapart[],
    const BendMfb& bendMfbTemp
);
Collapse Expand Parameters
Parameters | Description
double piasub | Pia to portion.
double piapart[] | Parts of the pia.
const BendMfb& bendMfbTemp | Bend points to use.
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::setTableNum Method

PiaMethod::setTableNum Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Sets number of applicable PIA table.

C++
void setTableNum(
    table_type newTableNum
);
Collapse Expand Parameters
Parameters | Description
table_type newTableNum | Number of applicable PIA table.
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::setYearCpi Method

PiaMethod::setYearCpi Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Sets years of benefit increases.

C++
void setYearCpi();
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::setftearn Method

PiaMethod::setftearn Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Sets sum of high n years of earnings,

C++
void setftearn(
    double newftearn
);
Collapse Expand Parameters
Parameters | Description
double newftearn | New sum of high n years of earnings.
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


specMinYearsCal Method

specMinYearsCal Method
PiaMethod Methods

Calculates number of years of coverage.

Collapse Expand Description

There are two versions of the specMinYearsCal function. The one with an IntAnnual argument saves indicators for which years are years of coverage in that argument.

Collapse Expand Overload List
Name | Description
PiaMethod::specMinYearsCal (double, const DoubleAnnual&, int, const DoubleAnnual&) | Calculates number of years of coverage, using passed argument for amounts required for coverage.
PiaMethod::specMinYearsCal (double, const DoubleAnnual&, int, const DoubleAnnual&, IntAnnual&) | Calculates number of years of coverage, using passed argument for amounts required for coverage.
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Methods


PiaMethod::specMinYearsCal Method (double, const DoubleAnnual&, int, const DoubleAnnual&)

PiaMethod::specMinYearsCal Method (double, const DoubleAnnual&, int, const DoubleAnnual&)
PiaMethod Class PiaMethod Members specMinYearsCal Method

Calculates number of years of coverage, using passed argument for amounts required for coverage.

C++
static int specMinYearsCal(
    double pre1951,
    const DoubleAnnual& earnings,
    int year,
    const DoubleAnnual& yocAmount
);
Collapse Expand Parameters
Parameters | Description
double pre1951 | Pre-1951 earnings.
const DoubleAnnual& earnings | Annual earnings, starting in 1951.
int year | Last year of earnings considered.
const DoubleAnnual& yocAmount | Amount required for year of coverage.
Collapse Expand Returns

Number of years of coverage.

Collapse Expand Remarks

This version does not save indicators for years used.

Collapse Expand Group

specMinYearsCal Method

Collapse Expand Links
PiaMethod Class, PiaMethod Members, specMinYearsCal Method


PiaMethod::specMinYearsCal Method (double, const DoubleAnnual&, int, const DoubleAnnual&, IntAnnual&)

PiaMethod::specMinYearsCal Method (double, const DoubleAnnual&, int, const DoubleAnnual&, IntAnnual&)
PiaMethod Class PiaMethod Members specMinYearsCal Method

Calculates number of years of coverage, using passed argument for amounts required for coverage.

C++
static int specMinYearsCal(
    double pre1951,
    const DoubleAnnual& earnings,
    int year,
    const DoubleAnnual& yocAmount,
    IntAnnual& iordert
);
Collapse Expand Parameters
Parameters | Description
double pre1951 | Pre-1951 earnings.
const DoubleAnnual& earnings | Annual earnings, starting in 1951.
int year | Last year of earnings considered.
const DoubleAnnual& yocAmount | Amount required for year of coverage.
IntAnnual& iordert | 1 if year of coverage, 0 otherwise, for years after 1950; total pre-1951 years of coverage for 1950.
Collapse Expand Returns

Number of years of coverage.

Collapse Expand Remarks

This version saves indicators for years used in the iordert argument.

Collapse Expand Group

specMinYearsCal Method

Collapse Expand Links
PiaMethod Class, PiaMethod Members, specMinYearsCal Method


PiaMethod::specMinYearsTotalCal Method

PiaMethod::specMinYearsTotalCal Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Calculates number of years of coverage for special minimum or windfall elimination provision.

C++
int specMinYearsTotalCal();
Collapse Expand Returns

Number of years of coverage.

Collapse Expand Remarks

Calculates number of years of coverage for special minimum if method is PiaMethod::pia_type::SPEC_MIN; otherwise calculates number of years of coverage for windfall elimination provision. Calls specMinYearsCal to do the calculation.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::totalEarnCal Method

PiaMethod::totalEarnCal Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Computes total earnings and AME or AIME.

C++
void totalEarnCal(
    int first,
    int last,
    int number
);
Collapse Expand Parameters
Parameters | Description
int first | First year of earnings.
int last | Last year of earnings.
int number | Number of years to be selected.
Collapse Expand Remarks

Highest earning years must already be selected. If there are not enough selected years, years of zero earnings will be added.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_METHOD if there is an inconsistency in the number of years desired and the ordered earnings (only in debug mode).
Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaMethod::wep_app Method

PiaMethod::wep_app Method
PiaMethod Class PiaMethod Members PiaMethod Methods

Determines if windfall elimination provision applies.

C++
bool wep_app() const;
Collapse Expand Returns

True if windfall elimination provision applies, false otherwise.

Collapse Expand Remarks

The windfall elimination provision applies to old-age and disability benefits, not survivor benefits. It also applies only if the year of eligibility is 1986 or later, and if there is a noncovered pension with an entitlement date after 1985.

Collapse Expand Group

PiaMethod Methods

Collapse Expand Links
PiaMethod Class, PiaMethod Members, PiaMethod Methods


PiaParams Class

PiaParams Class
PiaParams Constructor PiaParams Enumerations PiaParams Data Members PiaParams Methods PiaParams Members piaparms.h Classes

Abstract parent of classes to manage the Social Security parameters required to calculate a Social Security benefit.

Collapse Expand Class Hierarchy
  PiaParams
C++
class PiaParams;
Collapse Expand File

File: piaparms.h

Module: PiaData Library

Collapse Expand Remarks

You should instantiate a sub-class, or a sub-sub-class. PiaParamsLC is used in the microsimulation work; PiaParamsAny is used in the Anypia program; PiaParamsPL is also available.

Collapse Expand See Also

PiaParamsLC, PiaParamsAny, PiaParamsPL

Collapse Expand Group

Classes

Collapse Expand Links
PiaParams Constructor, PiaParams Enumerations, PiaParams Data Members, PiaParams Methods, PiaParams Members, piaparms.h, Classes


PiaParams Members

PiaParams Members
Enumerations PiaParams Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PiaParams.

Collapse Expand Enumerations
Name | Description
SPECMINPERCTYPE | The year range for the special minimum percentage.
Collapse Expand Class

PiaParams Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
baseHi | HI wage bases.
bendOS | Bend points for old-start PIB formula.
catchup | Catch-up benefit increases.
cpiinc | Array of benefit increases.
fq | Array of annual average earnings.
fqinc | Array of percentage increases in annual average earnings.
istart | Current year (year after last known benefit increase).
maxyear | Maximum year allowed.
monthBeninc | Array of month of benefit increase.
noChange | Array of indicators for no change allowed.
percOS | Old-start PIB formula percentages.
percSpecMin | Percentage of old-law wage base required for year of coverage.
recalcInd | Indicator for which year(s) the PIA should be recalculated due to a newly effective law change.
specMinMfb | Special minimum mfbs.
specMinMfb2001 | Special minimum mfbs for August-November 2001.
specMinPerc | Percentage of old-law wage base required for year of coverage for special minimum.
specMinPia | Special minimum pias.
specMinPia2001 | Special minimum pias for August-November 2001.
titleAw | Title of average wage assumptions.
titleBi | Title of benefit increase assumptions.
yocAmountSpecMin | Amount required for year of coverage for special minimum.
yocAmountWindfall | Amount required for year of coverage for windfall elimination provision.
Collapse Expand Public Data Members
Name | Description
YEAR1999 | Year of extra 0.1 percent benefit increase.
age16 | Age 16.
age18 | Age 18.
age19 | Age 19.
age199 | Age 199 (impossible age).
age22 | Age 22.
age50 | Age 50.
age60 | Age 60.
age62 | Age 62.
age621 | Age 62 and 1 month.
age65 | Age 65.
age65_10 | Age 65 and 10 months.
age65_2 | Age 65 and 2 months.
age65_4 | Age 65 and 4 months.
age65_6 | Age 65 and 6 months.
age65_8 | Age 65 and 8 months.
age66 | Age 66.
age66_10 | Age 66 and 10 months.
age66_2 | Age 66 and 2 months.
age66_4 | Age 66 and 4 months.
age66_6 | Age 66 and 6 months.
age66_8 | Age 66 and 8 months.
age67 | Age 67.
age70 | Age 70.
age72 | Age 72.
age75 | Age 75.
amend01 | The date of special 0.1 percent benefit increase.
amend118_273 | The date of WEP no longer being used for benefit computations.
amend50 | The date of 1950 amendments.
amend52 | The date of 1952 amendments.
amend54 | The date of 1954 amendments.
amend56 | The date of 1956 amendments.
amend561 | First birth date for which age 62 is effective for females.
amend562 | Second birth date for which age 62 is effective for females.
amend58 | The date of 1958 amendments.
amend61 | The date of 1961 amendments.
amend611 | First birth date for which age 62 is effective for males.
amend612 | Second birth date for which age 62 is effective for males.
amend651 | The date of 1965 amendments for benefit increase.
amend652 | The date of 1965 amendments for change to age 60.
amend653 | The date of 1965 amendments for old start.
amend671 | The date of 1967 amendments for old start.
amend672 | The date of 1967 amendments for benefit increase.
amend69 | The date of 1969 amendments.
amend70 | The date of 1970 amendments.
amend721 | The date of 1972 amendments for benefit increase.
amend722 | The date of 1972 amendments for special minimum.
amend741 | The date of 1974 amendments for partial increase.
amend742 | The date of 1974 amendments for full increase.
amend771 | The date of 1977 amendments for frozen pia table.
amend772 | The date of 1977 amendments for start of wage indexing.
amend80 | The date of 1980 amendments.
amend811 | The date of birth for age 62 and 1 month in 1981 amendments.
amend812 | The date of 1981 amendments (month, day, and year).
amend813 | The date of 1981 amendments (month and year).
amend82 | The date of 1982 amendments.
amend83 | The date of 1983 amendments.
amend88 | The date of 1988 amendments.
amend90 | The date of 1990 amendments.
amtperincyr | Amount per old start increment year.
arFactorWid285 | Total actuarial reduction factor for aged widow(er)s.
arMonthlyFactor65_67 | Monthly actuarial reduction factor between ages 65 and 67.
arMonthlyFactorOab62_65 | Monthly actuarial reduction factor between ages 62 and 65.
arMonthlyFactorSpouse62_65 | Monthly actuarial reduction factor for aged spouses between ages 62 and 65.
beninc74 | Temporary benefit increase, March-May 1974.
bpMfbOut | Table of mfb formula bend points.
bpPiaOut | Table of pia formula bend points.
factor150 | Factor for calculating mfbs.
factor175 | Factor for calculating mfbs.
factor50 | Factor for calculating life benefits.
factor75 | Factor for calculating survivor benefits.
factor825 | Factor for calculating widow(er) benefits.
maxMonthsAr62_65 | Maximum number of months of actuarial reduction between ages 62 and 65.
maxMonthsAr62_67 | Maximum number of months of actuarial reduction between ages 62 and 67.
maxMonthsAr65_67 | Maximum number of months of actuarial reduction between ages 65 and 67.
percPiaOut | Table of pia formula percentages.
qcamt | Array of amounts required for quarter of coverage.
qtr184 | Starting point of deemed insured.
year37qtr1 | First quarter for which a quarter of coverage could be earned.
Collapse Expand Public Methods
Name | Description
PiaParams | Initializes a PiaParams, with or without a first year of projection.
applyCola | Returns benefit amount increased by cola.
applyCola99 | Returns benefit amount increased by special 1999 cola (includes extra 0.1 percent increase).
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb99 | Returns maximum family benefit amount increased by special 1999 cola (includes extra 0.1 percent increase), with check that result is at least 150 percent of pia.
benincCatchUp | Applies catch-up benefit increases.
birthDateFRA | Returns the earliest birthdate for someone to be over NRA at the end of a year.
childAgeForMFCal | Returns oldest age of child for which parent can get young wife/husband or mother/father benefits.
deconvertPia | Deconverts PIA back to year of eligibility.
deemedQcReqCal | Returns number of quarters of coverage required for deemed insured status.
doRecalc | Returns true if should recalculate PIAs this year because of a newly effective law change, else false.
earlyAgeDisWidCal | Returns earliest possible disabled widow(er)'s retirement age.
earlyAgeOabCal | Returns earliest possible retirement age for oab or aged spouse.
earlyAgeOabCalPL | Returns earliest possible retirement age for old-age benie or aged spouse, based on present law.
earlyAgeWidCal | Returns earliest possible aged widow(er)'s retirement age.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCalPL | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow(er) benefit before age reduction.
factorAgedWidCalPL | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Returns reduction factor for wife/husband.
factorArAgedSpouseCalPL | Calculates reduction factor for wife/husband. Assumes a maximum of 60 months of reduction.
factorArCal | Returns reduction factor for OAB.
factorArCalPL | Calculates reduction factor for OAB or DIB.
factorArDisWidCal | Calculates reduction factor for disabled widow(er).
factorArWidCal | Calculates reduction factor for aged widow(er).
factorDisWidCal | Returns factor for disabled widow(er) benefit before age reduction.
factorDisWidCalPL | Returns factor for disabled widow/widower benefit before age reduction.
factorDriCal | Calculates delayed retirement increment factor for OAB.
factorYngLifeCal | Calculates reduction factor for young life benie.
factorYngSurvCal | Calculates reduction factor for young survivor.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDIPL | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalPL | Returns full retirement age based on present law.
getAverageWage | Returns title of average wage assumptions.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBaseHi | Returns one HI wage base.
getBaseHiArray | Returns the array of HI wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBendOS | Returns a bend point for old-start PIB formula.
getBenefitInc | Returns title of benefit increase assumptions.
getCatchup | Returns catch-up benefit increases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmountPL | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getCpiinc | Returns one benefit increase.
getCpiincArray | Returns the array of benefit increases.
getFq | Returns one average wage for indexing.
getFqArray | Returns array of average wages for indexing.
getFqBppia | Returns series used for indexing pia formula bend points.
getFqIndex | Returns series used for indexing an earnings record.
getFqinc | Returns one increase in average wage for indexing.
getFqincArray | Returns array of increases in average wage for indexing.
getIstart | Returns current year.
getMarrLengthForDivBen | Returns the number of years of marraige needed to be eligible for a divroced spouse benefit.
getMarrLengthForDivBenPL | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year.
getMaxChildcareAgePL | Returns maximum age of child for childcare dropout year.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYearsPL | Returns maximum number of childcare dropout years.
getMaxyear | Returns maximum possible year.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB.
getMonthBeninc | Returns one month of benefit increase.
getMonthBenincArray | Returns array of months of benefit increase.
getPercOS | Returns old-start PIB formula percentage.
getPercSpecMin | Returns percent of old-law base required for year of coverage.
getPercSpecMinArray | Returns array of percents of old-law base required for year of coverage.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinPerc | Returns percentage of old-law base required for year of coverage.
getSpecMinPia | Returns special minimum pia as of a specified month.
getYocAmountSpecMin | Returns amount required for year of coverage for special minimum.
getYocAmountSpecMinArray | Returns array of amounts required for year of coverage for special minimum.
getYocAmountWindfallArray | Returns array of amounts required for year of coverage for windfall elimination.
initdata | Initializes some data.
isApplicableCola99 | Checks for applicability of special 1999 increase (with extra 0.1 percent).
lastAmw | Finds last AMW in old-law table.
lumpSum | Returns amount of lump sum benefit.
maxChildAge | Returns maximum child beneficiary age.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAgePL | Returns maximum DI beneficiary age at end of year, based on present law.
monthsArAgedSpouseCal | Calculates number of months of actuarial reduction for aged wife/husband.
monthsArCal | Calculates number of months of actuarial reduction for OAB.
monthsArDICal | Calculates number of months of reduction for disabled worker.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er).
monthsArWidCal | Calculates number of months of actuarial reduction for aged widow(er).
monthsDriCal | Calculates number of months of delayed retirement credit for OAB.
needColaCap | Returns true if a cola cap is required.
percPiaCal | Sets benefit formula percents.
projectCpiinc | Projects amounts dependent on benefit increases.
projectFq | Projects amounts dependent on the average annual wage.
projectPerc | Projects benefit formula percentages.
projectSpecMin | Projects special minimum amounts.
qcCal | Returns number of quarters of coverage for one year, applying annual test.
resizeSpecMin | Resizes special minimum arrays.
retCredit | Returns amount of monthly delayed retirement credit.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCalPL | Returns widow(er) benefit reduced for RIB-LIM.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setData | Sets data from historical average wages and benefit increase file.
setHistFqinc | Sets historical average wage increases.
setIstart | Sets the first projected year, including for members.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
setNoChange | Sets indicators for no change allowed.
specMinAmountCal | Sets amount per year of coverage in special minimum.
specMinAmountCalPL | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYearsPL | Returns maximum number of usable years for special minimum.
unApplyCola | Returns benefit amount decreased by cola.
unApplyCola99 | Returns benefit amount decreased by special 1999 cola (includes extra 0.1 percent decrease.)
unbiCatchUp | Divides out catch-up benefit increases.
updateBases | Updates wage bases.
updateCpiinc | Updates benefit increases.
updateFq | Updates average wages, using specified amounts.
updateFqinc | Updates increases in average wages, using specified percentages.
updateYocAmountSpecMin | Updates amounts required for special minimum year of coverage.
~PiaParams | Destroys arrays.
Collapse Expand Links
Enumerations, PiaParams Class, Legend, Protected Data Members, Public Data Members, Public Methods


PiaParams Constructor

PiaParams Constructor
PiaParams Class

Initializes a PiaParams, with or without a first year of projection.

Collapse Expand Description

There are two versions of the PiaParams constructor. If the first year of projection is not provided, it is set to BaseYearNonFile::YEAR.

Collapse Expand Overload List
Name | Description
PiaParams::PiaParams (int) | Constructor sets the starting year as BaseYearNonFile::YEAR.
PiaParams::PiaParams (int, int) | Constructor sets the starting year of projection.
Collapse Expand Class

PiaParams Class

Collapse Expand Links
PiaParams Class


PiaParams::PiaParams Constructor (int)

PiaParams::PiaParams Constructor (int)
PiaParams Class PiaParams Members PiaParams Constructor

Constructor sets the starting year as BaseYearNonFile::YEAR.

C++
explicit PiaParams(
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
int newMaxyear | Maximum projected year.
Collapse Expand Remarks

Initialize arrays and sets the starting year of projection.

Collapse Expand Group

PiaParams Constructor

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Constructor


PiaParams::PiaParams Constructor (int, int)

PiaParams::PiaParams Constructor (int, int)
PiaParams Class PiaParams Members PiaParams Constructor

Constructor sets the starting year of projection.

C++
PiaParams(
    int newIstart,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
int newIstart | Year after last known benefit increase.
int newMaxyear | Maximum projected year.
Collapse Expand Remarks

Initialize arrays and sets the starting year of projection.

Collapse Expand Group

PiaParams Constructor

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Constructor


PiaParams::~PiaParams Destructor

PiaParams::~PiaParams Destructor
PiaParams Class PiaParams Members PiaParams Class

Destroys arrays.

C++
virtual ~PiaParams();
Collapse Expand Class

PiaParams Class

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Class


PiaParams Enumerations

PiaParams Enumerations
Enumerations PiaParams Class Legend

The enumerations of the PiaParams class are listed here.

Collapse Expand Enumerations
Name | Description
SPECMINPERCTYPE | The year range for the special minimum percentage.
Collapse Expand Class

PiaParams Class

Collapse Expand Links
Enumerations, PiaParams Class, Legend


PiaParams::SPECMINPERCTYPE Enumeration

PiaParams::SPECMINPERCTYPE Enumeration
piaparms.h PiaParams Enumerations

The year range for the special minimum percentage.

C++
enum SPECMINPERCTYPE {
  PRE1991 = 0,
  POST1990,
  NUMSPECMINPERCTYPES
};
Collapse Expand File

File: piaparms.h

Module: PiaData Library

Collapse Expand Members
Members | Description
PRE1991 = 0 | Special minimum before 1991.
POST1990 | Special minimum after 1990.
NUMSPECMINPERCTYPES | Number of year ranges for the spec min percentage.
Collapse Expand Group

PiaParams Enumerations

Collapse Expand Links
piaparms.h, PiaParams Enumerations


PiaParams Data Members

PiaParams Data Members
PiaParams Class Legend Protected Data Members Public Data Members

The data members of the PiaParams class are listed here.

Collapse Expand Class

PiaParams Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
baseHi | HI wage bases.
bendOS | Bend points for old-start PIB formula.
catchup | Catch-up benefit increases.
cpiinc | Array of benefit increases.
fq | Array of annual average earnings.
fqinc | Array of percentage increases in annual average earnings.
istart | Current year (year after last known benefit increase).
maxyear | Maximum year allowed.
monthBeninc | Array of month of benefit increase.
noChange | Array of indicators for no change allowed.
percOS | Old-start PIB formula percentages.
percSpecMin | Percentage of old-law wage base required for year of coverage.
recalcInd | Indicator for which year(s) the PIA should be recalculated due to a newly effective law change.
specMinMfb | Special minimum mfbs.
specMinMfb2001 | Special minimum mfbs for August-November 2001.
specMinPerc | Percentage of old-law wage base required for year of coverage for special minimum.
specMinPia | Special minimum pias.
specMinPia2001 | Special minimum pias for August-November 2001.
titleAw | Title of average wage assumptions.
titleBi | Title of benefit increase assumptions.
yocAmountSpecMin | Amount required for year of coverage for special minimum.
yocAmountWindfall | Amount required for year of coverage for windfall elimination provision.
Collapse Expand Public Data Members
Name | Description
YEAR1999 | Year of extra 0.1 percent benefit increase.
age16 | Age 16.
age18 | Age 18.
age19 | Age 19.
age199 | Age 199 (impossible age).
age22 | Age 22.
age50 | Age 50.
age60 | Age 60.
age62 | Age 62.
age621 | Age 62 and 1 month.
age65 | Age 65.
age65_10 | Age 65 and 10 months.
age65_2 | Age 65 and 2 months.
age65_4 | Age 65 and 4 months.
age65_6 | Age 65 and 6 months.
age65_8 | Age 65 and 8 months.
age66 | Age 66.
age66_10 | Age 66 and 10 months.
age66_2 | Age 66 and 2 months.
age66_4 | Age 66 and 4 months.
age66_6 | Age 66 and 6 months.
age66_8 | Age 66 and 8 months.
age67 | Age 67.
age70 | Age 70.
age72 | Age 72.
age75 | Age 75.
amend01 | The date of special 0.1 percent benefit increase.
amend118_273 | The date of WEP no longer being used for benefit computations.
amend50 | The date of 1950 amendments.
amend52 | The date of 1952 amendments.
amend54 | The date of 1954 amendments.
amend56 | The date of 1956 amendments.
amend561 | First birth date for which age 62 is effective for females.
amend562 | Second birth date for which age 62 is effective for females.
amend58 | The date of 1958 amendments.
amend61 | The date of 1961 amendments.
amend611 | First birth date for which age 62 is effective for males.
amend612 | Second birth date for which age 62 is effective for males.
amend651 | The date of 1965 amendments for benefit increase.
amend652 | The date of 1965 amendments for change to age 60.
amend653 | The date of 1965 amendments for old start.
amend671 | The date of 1967 amendments for old start.
amend672 | The date of 1967 amendments for benefit increase.
amend69 | The date of 1969 amendments.
amend70 | The date of 1970 amendments.
amend721 | The date of 1972 amendments for benefit increase.
amend722 | The date of 1972 amendments for special minimum.
amend741 | The date of 1974 amendments for partial increase.
amend742 | The date of 1974 amendments for full increase.
amend771 | The date of 1977 amendments for frozen pia table.
amend772 | The date of 1977 amendments for start of wage indexing.
amend80 | The date of 1980 amendments.
amend811 | The date of birth for age 62 and 1 month in 1981 amendments.
amend812 | The date of 1981 amendments (month, day, and year).
amend813 | The date of 1981 amendments (month and year).
amend82 | The date of 1982 amendments.
amend83 | The date of 1983 amendments.
amend88 | The date of 1988 amendments.
amend90 | The date of 1990 amendments.
amtperincyr | Amount per old start increment year.
arFactorWid285 | Total actuarial reduction factor for aged widow(er)s.
arMonthlyFactor65_67 | Monthly actuarial reduction factor between ages 65 and 67.
arMonthlyFactorOab62_65 | Monthly actuarial reduction factor between ages 62 and 65.
arMonthlyFactorSpouse62_65 | Monthly actuarial reduction factor for aged spouses between ages 62 and 65.
beninc74 | Temporary benefit increase, March-May 1974.
bpMfbOut | Table of mfb formula bend points.
bpPiaOut | Table of pia formula bend points.
factor150 | Factor for calculating mfbs.
factor175 | Factor for calculating mfbs.
factor50 | Factor for calculating life benefits.
factor75 | Factor for calculating survivor benefits.
factor825 | Factor for calculating widow(er) benefits.
maxMonthsAr62_65 | Maximum number of months of actuarial reduction between ages 62 and 65.
maxMonthsAr62_67 | Maximum number of months of actuarial reduction between ages 62 and 67.
maxMonthsAr65_67 | Maximum number of months of actuarial reduction between ages 65 and 67.
percPiaOut | Table of pia formula percentages.
qcamt | Array of amounts required for quarter of coverage.
qtr184 | Starting point of deemed insured.
year37qtr1 | First quarter for which a quarter of coverage could be earned.
Collapse Expand Links
PiaParams Class, Legend, Protected Data Members, Public Data Members


PiaParams::YEAR1999 Data Member

PiaParams::YEAR1999 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Year of extra 0.1 percent benefit increase.

C++
const int YEAR1999 = 1999;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age16 Data Member

PiaParams::age16 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 16.

C++
const Age age16;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age18 Data Member

PiaParams::age18 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 18.

C++
const Age age18;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age19 Data Member

PiaParams::age19 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 19.

C++
const Age age19;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age199 Data Member

PiaParams::age199 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 199 (impossible age).

C++
const Age age199;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age22 Data Member

PiaParams::age22 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 22.

C++
const Age age22;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age50 Data Member

PiaParams::age50 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 50.

C++
const Age age50;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age60 Data Member

PiaParams::age60 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 60.

C++
const Age age60;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age62 Data Member

PiaParams::age62 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 62.

C++
const Age age62;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age621 Data Member

PiaParams::age621 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 62 and 1 month.

C++
const Age age621;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age65 Data Member

PiaParams::age65 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 65.

C++
const Age age65;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age65_10 Data Member

PiaParams::age65_10 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 65 and 10 months.

C++
const Age age65_10;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age65_2 Data Member

PiaParams::age65_2 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 65 and 2 months.

C++
const Age age65_2;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age65_4 Data Member

PiaParams::age65_4 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 65 and 4 months.

C++
const Age age65_4;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age65_6 Data Member

PiaParams::age65_6 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 65 and 6 months.

C++
const Age age65_6;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age65_8 Data Member

PiaParams::age65_8 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 65 and 8 months.

C++
const Age age65_8;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age66 Data Member

PiaParams::age66 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 66.

C++
const Age age66;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age66_10 Data Member

PiaParams::age66_10 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 66 and 10 months.

C++
const Age age66_10;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age66_2 Data Member

PiaParams::age66_2 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 66 and 2 months.

C++
const Age age66_2;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age66_4 Data Member

PiaParams::age66_4 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 66 and 4 months.

C++
const Age age66_4;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age66_6 Data Member

PiaParams::age66_6 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 66 and 6 months.

C++
const Age age66_6;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age66_8 Data Member

PiaParams::age66_8 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 66 and 8 months.

C++
const Age age66_8;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age67 Data Member

PiaParams::age67 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 67.

C++
const Age age67;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age70 Data Member

PiaParams::age70 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 70.

C++
const Age age70;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age72 Data Member

PiaParams::age72 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 72.

C++
const Age age72;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::age75 Data Member

PiaParams::age75 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Age 75.

C++
const Age age75;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend01 Data Member

PiaParams::amend01 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of special 0.1 percent benefit increase.

C++
const DateMoyr amend01;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend118_273 Data Member

PiaParams::amend118_273 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of WEP no longer being used for benefit computations.

C++
const DateMoyr amend118_273;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend50 Data Member

PiaParams::amend50 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1950 amendments.

C++
const DateMoyr amend50;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend52 Data Member

PiaParams::amend52 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1952 amendments.

C++
const DateMoyr amend52;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend54 Data Member

PiaParams::amend54 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1954 amendments.

C++
const DateMoyr amend54;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend56 Data Member

PiaParams::amend56 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1956 amendments.

C++
const DateMoyr amend56;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend561 Data Member

PiaParams::amend561 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

First birth date for which age 62 is effective for females.

C++
const boost::gregorian::date amend561;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend562 Data Member

PiaParams::amend562 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Second birth date for which age 62 is effective for females.

C++
const boost::gregorian::date amend562;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend58 Data Member

PiaParams::amend58 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1958 amendments.

C++
const DateMoyr amend58;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend61 Data Member

PiaParams::amend61 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1961 amendments.

C++
const DateMoyr amend61;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend611 Data Member

PiaParams::amend611 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

First birth date for which age 62 is effective for males.

C++
const boost::gregorian::date amend611;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend612 Data Member

PiaParams::amend612 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Second birth date for which age 62 is effective for males.

C++
const boost::gregorian::date amend612;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend651 Data Member

PiaParams::amend651 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1965 amendments for benefit increase.

C++
const DateMoyr amend651;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend652 Data Member

PiaParams::amend652 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1965 amendments for change to age 60.

C++
const DateMoyr amend652;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend653 Data Member

PiaParams::amend653 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1965 amendments for old start.

C++
const DateMoyr amend653;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend671 Data Member

PiaParams::amend671 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1967 amendments for old start.

C++
const DateMoyr amend671;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend672 Data Member

PiaParams::amend672 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1967 amendments for benefit increase.

C++
const DateMoyr amend672;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend69 Data Member

PiaParams::amend69 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1969 amendments.

C++
const DateMoyr amend69;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend70 Data Member

PiaParams::amend70 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1970 amendments.

C++
const DateMoyr amend70;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend721 Data Member

PiaParams::amend721 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1972 amendments for benefit increase.

C++
const DateMoyr amend721;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend722 Data Member

PiaParams::amend722 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1972 amendments for special minimum.

C++
const DateMoyr amend722;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend741 Data Member

PiaParams::amend741 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1974 amendments for partial increase.

C++
const DateMoyr amend741;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend742 Data Member

PiaParams::amend742 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1974 amendments for full increase.

C++
const DateMoyr amend742;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend771 Data Member

PiaParams::amend771 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1977 amendments for frozen pia table.

C++
const DateMoyr amend771;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend772 Data Member

PiaParams::amend772 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1977 amendments for start of wage indexing.

C++
const DateMoyr amend772;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend80 Data Member

PiaParams::amend80 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1980 amendments.

C++
const DateMoyr amend80;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend811 Data Member

PiaParams::amend811 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of birth for age 62 and 1 month in 1981 amendments.

C++
const boost::gregorian::date amend811;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend812 Data Member

PiaParams::amend812 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1981 amendments (month, day, and year).

C++
const boost::gregorian::date amend812;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend813 Data Member

PiaParams::amend813 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1981 amendments (month and year).

C++
const DateMoyr amend813;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend82 Data Member

PiaParams::amend82 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1982 amendments.

C++
const DateMoyr amend82;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend83 Data Member

PiaParams::amend83 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1983 amendments.

C++
const DateMoyr amend83;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend88 Data Member

PiaParams::amend88 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1988 amendments.

C++
const DateMoyr amend88;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amend90 Data Member

PiaParams::amend90 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

The date of 1990 amendments.

C++
const DateMoyr amend90;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::amtperincyr Data Member

PiaParams::amtperincyr Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Amount per old start increment year.

C++
const double amtperincyr;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::arFactorWid285 Data Member

PiaParams::arFactorWid285 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Total actuarial reduction factor for aged widow(er)s.

C++
const double arFactorWid285;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::arMonthlyFactor65_67 Data Member

PiaParams::arMonthlyFactor65_67 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Monthly actuarial reduction factor between ages 65 and 67.

C++
const double arMonthlyFactor65_67;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::arMonthlyFactorOab62_65 Data Member

PiaParams::arMonthlyFactorOab62_65 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Monthly actuarial reduction factor between ages 62 and 65.

C++
const double arMonthlyFactorOab62_65;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::arMonthlyFactorSpouse62_65 Data Member

PiaParams::arMonthlyFactorSpouse62_65 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Monthly actuarial reduction factor for aged spouses between ages 62 and 65.

C++
const double arMonthlyFactorSpouse62_65;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::baseHi Data Member

PiaParams::baseHi Data Member
PiaParams Class PiaParams Members PiaParams Data Members

HI wage bases.

C++
WageBaseHI baseHi;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::bendOS Data Member

PiaParams::bendOS Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Bend points for old-start PIB formula.

C++
const int bendOS[3];
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::beninc74 Data Member

PiaParams::beninc74 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Temporary benefit increase, March-May 1974.

C++
const double beninc74;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::bpMfbOut Data Member

PiaParams::bpMfbOut Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Table of mfb formula bend points.

C++
BpMfbOut bpMfbOut;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::bpPiaOut Data Member

PiaParams::bpPiaOut Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Table of pia formula bend points.

C++
BpPiaOut bpPiaOut;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::catchup Data Member

PiaParams::catchup Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Catch-up benefit increases.

C++
Catchup catchup;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::cpiinc Data Member

PiaParams::cpiinc Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Array of benefit increases.

C++
DoubleAnnual cpiinc;
Collapse Expand Remarks

The years go from 1951 to maxyear.

Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::factor150 Data Member

PiaParams::factor150 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Factor for calculating mfbs.

C++
const double factor150;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::factor175 Data Member

PiaParams::factor175 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Factor for calculating mfbs.

C++
const double factor175;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::factor50 Data Member

PiaParams::factor50 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Factor for calculating life benefits.

C++
const double factor50;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::factor75 Data Member

PiaParams::factor75 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Factor for calculating survivor benefits.

C++
const double factor75;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::factor825 Data Member

PiaParams::factor825 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Factor for calculating widow(er) benefits.

C++
const double factor825;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::fq Data Member

PiaParams::fq Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Array of annual average earnings.

C++
AverageWage fq;
Collapse Expand Remarks

The years go from 1937 to maxyear.

Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::fqinc Data Member

PiaParams::fqinc Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Array of percentage increases in annual average earnings.

C++
Awinc fqinc;
Collapse Expand Remarks

The years go from 1937 to maxyear.

Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::istart Data Member

PiaParams::istart Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Current year (year after last known benefit increase).

C++
int istart;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::maxMonthsAr62_65 Data Member

PiaParams::maxMonthsAr62_65 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Maximum number of months of actuarial reduction between ages 62 and 65.

C++
const int maxMonthsAr62_65;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::maxMonthsAr62_67 Data Member

PiaParams::maxMonthsAr62_67 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Maximum number of months of actuarial reduction between ages 62 and 67.

C++
const int maxMonthsAr62_67;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::maxMonthsAr65_67 Data Member

PiaParams::maxMonthsAr65_67 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Maximum number of months of actuarial reduction between ages 65 and 67.

C++
const int maxMonthsAr65_67;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::maxyear Data Member

PiaParams::maxyear Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Maximum year allowed.

C++
int maxyear;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::monthBeninc Data Member

PiaParams::monthBeninc Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Array of month of benefit increase.

C++
IntAnnual monthBeninc;
Collapse Expand Remarks

The years go from 1951 to maxyear.

Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::noChange Data Member

PiaParams::noChange Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Array of indicators for no change allowed.

C++
IntAnnual noChange;
Collapse Expand Remarks

The years go from 1937 to maxyear.

Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::percOS Data Member

PiaParams::percOS Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Old-start PIB formula percentages.

C++
const double percOS[2];
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::percPiaOut Data Member

PiaParams::percPiaOut Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Table of pia formula percentages.

C++
PercPiaOut percPiaOut;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::percSpecMin Data Member

PiaParams::percSpecMin Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Percentage of old-law wage base required for year of coverage.

C++
DoubleAnnual percSpecMin;
Collapse Expand Remarks

The years go from 1937 to maxyear.

Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::qcamt Data Member

PiaParams::qcamt Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Array of amounts required for quarter of coverage.

C++
Qcamt qcamt;
Collapse Expand Remarks

The years go from 1937 to maxyear.

Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::qtr184 Data Member

PiaParams::qtr184 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Starting point of deemed insured.

C++
const QtrYear qtr184;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::recalcInd Data Member

PiaParams::recalcInd Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Indicator for which year(s) the PIA should be recalculated due to a newly effective law change.

C++
BitAnnual recalcInd;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::specMinMfb Data Member

PiaParams::specMinMfb Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Special minimum mfbs.

C++
std::vector< DoubleAnnual* > specMinMfb;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::specMinMfb2001 Data Member

PiaParams::specMinMfb2001 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Special minimum mfbs for August-November 2001.

C++
std::vector< double > specMinMfb2001;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::specMinPerc Data Member

PiaParams::specMinPerc Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Percentage of old-law wage base required for year of coverage for special minimum.

C++
const double specMinPerc[NUMSPECMINPERCTYPES];
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::specMinPia Data Member

PiaParams::specMinPia Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Special minimum pias.

C++
std::vector< DoubleAnnual* > specMinPia;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::specMinPia2001 Data Member

PiaParams::specMinPia2001 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Special minimum pias for August-November 2001.

C++
std::vector< double > specMinPia2001;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::titleAw Data Member

PiaParams::titleAw Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Title of average wage assumptions.

C++
std::string titleAw;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::titleBi Data Member

PiaParams::titleBi Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Title of benefit increase assumptions.

C++
std::string titleBi;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::year37qtr1 Data Member

PiaParams::year37qtr1 Data Member
PiaParams Class PiaParams Members PiaParams Data Members

First quarter for which a quarter of coverage could be earned.

C++
const QtrYear year37qtr1;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::yocAmountSpecMin Data Member

PiaParams::yocAmountSpecMin Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Amount required for year of coverage for special minimum.

C++
DoubleAnnual yocAmountSpecMin;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams::yocAmountWindfall Data Member

PiaParams::yocAmountWindfall Data Member
PiaParams Class PiaParams Members PiaParams Data Members

Amount required for year of coverage for windfall elimination provision.

C++
DoubleAnnual yocAmountWindfall;
Collapse Expand Group

PiaParams Data Members

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Data Members


PiaParams Methods

PiaParams Methods
PiaParams Class Legend Public Methods

The methods of the PiaParams class are listed here.

Collapse Expand Class

PiaParams Class

Collapse Expand Public Methods
Name | Description
applyCola | Returns benefit amount increased by cola.
applyCola99 | Returns benefit amount increased by special 1999 cola (includes extra 0.1 percent increase).
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb99 | Returns maximum family benefit amount increased by special 1999 cola (includes extra 0.1 percent increase), with check that result is at least 150 percent of pia.
benincCatchUp | Applies catch-up benefit increases.
birthDateFRA | Returns the earliest birthdate for someone to be over NRA at the end of a year.
childAgeForMFCal | Returns oldest age of child for which parent can get young wife/husband or mother/father benefits.
deconvertPia | Deconverts PIA back to year of eligibility.
deemedQcReqCal | Returns number of quarters of coverage required for deemed insured status.
doRecalc | Returns true if should recalculate PIAs this year because of a newly effective law change, else false.
earlyAgeDisWidCal | Returns earliest possible disabled widow(er)'s retirement age.
earlyAgeOabCal | Returns earliest possible retirement age for oab or aged spouse.
earlyAgeOabCalPL | Returns earliest possible retirement age for old-age benie or aged spouse, based on present law.
earlyAgeWidCal | Returns earliest possible aged widow(er)'s retirement age.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCalPL | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow(er) benefit before age reduction.
factorAgedWidCalPL | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Returns reduction factor for wife/husband.
factorArAgedSpouseCalPL | Calculates reduction factor for wife/husband. Assumes a maximum of 60 months of reduction.
factorArCal | Returns reduction factor for OAB.
factorArCalPL | Calculates reduction factor for OAB or DIB.
factorArDisWidCal | Calculates reduction factor for disabled widow(er).
factorArWidCal | Calculates reduction factor for aged widow(er).
factorDisWidCal | Returns factor for disabled widow(er) benefit before age reduction.
factorDisWidCalPL | Returns factor for disabled widow/widower benefit before age reduction.
factorDriCal | Calculates delayed retirement increment factor for OAB.
factorYngLifeCal | Calculates reduction factor for young life benie.
factorYngSurvCal | Calculates reduction factor for young survivor.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDIPL | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalPL | Returns full retirement age based on present law.
getAverageWage | Returns title of average wage assumptions.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBaseHi | Returns one HI wage base.
getBaseHiArray | Returns the array of HI wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBendOS | Returns a bend point for old-start PIB formula.
getBenefitInc | Returns title of benefit increase assumptions.
getCatchup | Returns catch-up benefit increases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmountPL | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getCpiinc | Returns one benefit increase.
getCpiincArray | Returns the array of benefit increases.
getFq | Returns one average wage for indexing.
getFqArray | Returns array of average wages for indexing.
getFqBppia | Returns series used for indexing pia formula bend points.
getFqIndex | Returns series used for indexing an earnings record.
getFqinc | Returns one increase in average wage for indexing.
getFqincArray | Returns array of increases in average wage for indexing.
getIstart | Returns current year.
getMarrLengthForDivBen | Returns the number of years of marraige needed to be eligible for a divroced spouse benefit.
getMarrLengthForDivBenPL | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year.
getMaxChildcareAgePL | Returns maximum age of child for childcare dropout year.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYearsPL | Returns maximum number of childcare dropout years.
getMaxyear | Returns maximum possible year.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB.
getMonthBeninc | Returns one month of benefit increase.
getMonthBenincArray | Returns array of months of benefit increase.
getPercOS | Returns old-start PIB formula percentage.
getPercSpecMin | Returns percent of old-law base required for year of coverage.
getPercSpecMinArray | Returns array of percents of old-law base required for year of coverage.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinPerc | Returns percentage of old-law base required for year of coverage.
getSpecMinPia | Returns special minimum pia as of a specified month.
getYocAmountSpecMin | Returns amount required for year of coverage for special minimum.
getYocAmountSpecMinArray | Returns array of amounts required for year of coverage for special minimum.
getYocAmountWindfallArray | Returns array of amounts required for year of coverage for windfall elimination.
initdata | Initializes some data.
isApplicableCola99 | Checks for applicability of special 1999 increase (with extra 0.1 percent).
lastAmw | Finds last AMW in old-law table.
lumpSum | Returns amount of lump sum benefit.
maxChildAge | Returns maximum child beneficiary age.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAgePL | Returns maximum DI beneficiary age at end of year, based on present law.
monthsArAgedSpouseCal | Calculates number of months of actuarial reduction for aged wife/husband.
monthsArCal | Calculates number of months of actuarial reduction for OAB.
monthsArDICal | Calculates number of months of reduction for disabled worker.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er).
monthsArWidCal | Calculates number of months of actuarial reduction for aged widow(er).
monthsDriCal | Calculates number of months of delayed retirement credit for OAB.
needColaCap | Returns true if a cola cap is required.
percPiaCal | Sets benefit formula percents.
projectCpiinc | Projects amounts dependent on benefit increases.
projectFq | Projects amounts dependent on the average annual wage.
projectPerc | Projects benefit formula percentages.
projectSpecMin | Projects special minimum amounts.
qcCal | Returns number of quarters of coverage for one year, applying annual test.
resizeSpecMin | Resizes special minimum arrays.
retCredit | Returns amount of monthly delayed retirement credit.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCalPL | Returns widow(er) benefit reduced for RIB-LIM.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setData | Sets data from historical average wages and benefit increase file.
setHistFqinc | Sets historical average wage increases.
setIstart | Sets the first projected year, including for members.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
setNoChange | Sets indicators for no change allowed.
specMinAmountCal | Sets amount per year of coverage in special minimum.
specMinAmountCalPL | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYearsPL | Returns maximum number of usable years for special minimum.
unApplyCola | Returns benefit amount decreased by cola.
unApplyCola99 | Returns benefit amount decreased by special 1999 cola (includes extra 0.1 percent decrease.)
unbiCatchUp | Divides out catch-up benefit increases.
updateBases | Updates wage bases.
updateCpiinc | Updates benefit increases.
updateFq | Updates average wages, using specified amounts.
updateFqinc | Updates increases in average wages, using specified percentages.
updateYocAmountSpecMin | Updates amounts required for special minimum year of coverage.
Collapse Expand Links
PiaParams Class, Legend, Public Methods


applyCola Method

applyCola Method
PiaParams Methods

Returns benefit amount increased by cola.

Collapse Expand Description

There are two versions of the applyCola function. The one with a year of eligibility argument considers catch-up benefit increases; the other does not.

Collapse Expand Overload List
Name | Description
PiaParams::applyCola (double, int) | Returns benefit amount increased by cola.
PiaParams::applyCola (double, int, int) | Returns benefit amount increased by cola.
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Methods


PiaParams::applyCola Method (double, int)

PiaParams::applyCola Method (double, int)
PiaParams Class PiaParams Members applyCola Method

Returns benefit amount increased by cola.

C++
virtual double applyCola(
    double pia,
    int year
) const;
Collapse Expand Parameters
Parameters | Description
double pia | Amount to be increased.
int year | Year of increase.
Collapse Expand Returns

Benefit amount increased by cola, without considering any catch-up benefit increases.

Collapse Expand Remarks

This version does not consider any catch-up benefit increases.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_APPCOLA1 if year is out of range (debug mode only).
Collapse Expand Group

applyCola Method

Collapse Expand Links
PiaParams Class, PiaParams Members, applyCola Method


PiaParams::applyCola Method (double, int, int)

PiaParams::applyCola Method (double, int, int)
PiaParams Class PiaParams Members applyCola Method

Returns benefit amount increased by cola.

C++
virtual double applyCola(
    double pia,
    int year,
    int eligYear
) const;
Collapse Expand Parameters
Parameters | Description
double pia | Amount to be increased.
int year | Year of increase.
int eligYear | Year of eligibility for catch-up benefit increases.
Collapse Expand Returns

Benefit amount increased by cola, considering any catch-up benefit increases.

Collapse Expand Remarks

This version considers any catch-up benefit increases.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_APPCOLA1 if year is out of range (debug mode only).
Collapse Expand Group

applyCola Method

Collapse Expand Links
PiaParams Class, PiaParams Members, applyCola Method


PiaParams::applyCola99 Method

PiaParams::applyCola99 Method
PiaParams Class PiaParams Members PiaParams Methods

Returns benefit amount increased by special 1999 cola (includes extra 0.1 percent increase).

C++
double applyCola99(
    double pia
) const;
Collapse Expand Parameters
Parameters | Description
double pia | Amount to be increased.
Collapse Expand Returns

Benefit amount increased by special 1999 cola (includes extra 0.1 percent increase).

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


applyColaMfb Method

applyColaMfb Method
PiaParams Methods

Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.

Collapse Expand Description

There are two versions of the applyColaMfb function. The one with a year of eligibility argument considers catch-up benefit increases; the other does not.

Collapse Expand Overload List
Name | Description
PiaParams::applyColaMfb (double, int, double) | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
PiaParams::applyColaMfb (double, int, int, double) | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Methods


PiaParams::applyColaMfb Method (double, int, double)

PiaParams::applyColaMfb Method (double, int, double)
PiaParams Class PiaParams Members applyColaMfb Method

Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.

C++
virtual double applyColaMfb(
    double mfb,
    int year,
    double pia
) const;
Collapse Expand Parameters
Parameters | Description
double mfb | Amount to be increased.
int year | Year of increase.
double pia | Pia to check against.
Collapse Expand Returns

Maximum family benefit amount increased by cola.

Collapse Expand Remarks

This version does not consider any catch-up benefit increases.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_APPCOLA3 if year is out of range (debug mode only).
Collapse Expand Group

applyColaMfb Method

Collapse Expand Links
PiaParams Class, PiaParams Members, applyColaMfb Method


PiaParams::applyColaMfb Method (double, int, int, double)

PiaParams::applyColaMfb Method (double, int, int, double)
PiaParams Class PiaParams Members applyColaMfb Method

Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.

C++
virtual double applyColaMfb(
    double mfb,
    int year,
    int eligYear,
    double pia
) const;
Collapse Expand Parameters
Parameters | Description
double mfb | Amount to be increased.
int year | Year of increase.
int eligYear | Year of eligibility for catch-up benefit increases.
double pia | Pia to check against.
Collapse Expand Returns

Maximum family benefit amount increased by cola.

Collapse Expand Remarks

This version considers any catch-up benefit increases.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_APPCOLA3 if year is out of range (debug mode only).
Collapse Expand Group

applyColaMfb Method

Collapse Expand Links
PiaParams Class, PiaParams Members, applyColaMfb Method


PiaParams::applyColaMfb99 Method

PiaParams::applyColaMfb99 Method
PiaParams Class PiaParams Members PiaParams Methods

Returns maximum family benefit amount increased by special 1999 cola (includes extra 0.1 percent increase), with check that result is at least 150 percent of pia.

C++
double applyColaMfb99(
    double mfb,
    double pia
) const;
Collapse Expand Parameters
Parameters | Description
double mfb | Amount to be increased.
double pia | Pia to check against.
Collapse Expand Returns

Maximum family benefit amount increased by cola.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::benincCatchUp Method

PiaParams::benincCatchUp Method
PiaParams Class PiaParams Members PiaParams Methods

Applies catch-up benefit increases.

C++
double benincCatchUp(
    double bcatch,
    int year,
    int eligYear
) const;
Collapse Expand Parameters
Parameters | Description
double bcatch | Amount to be increased.
int year | Year of catch-up benefit increase.
int eligYear | Year of eligibility for catch-up benefit increases.
Collapse Expand Returns

Increased benefit amount.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BICCHP if either year is out of range (debug mode only).
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::birthDateFRA Method

PiaParams::birthDateFRA Method
PiaParams Class PiaParams Members PiaParams Methods

Returns the earliest birthdate for someone to be over NRA at the end of a year.

C++
static boost::gregorian::date birthDateFRA(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year to compute a birthdate for.
Collapse Expand Returns

The earliest birthdate for someone to be over NRA at the end of a year.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::childAgeForMFCal Method

PiaParams::childAgeForMFCal Method
PiaParams Class PiaParams Members PiaParams Methods

Returns oldest age of child for which parent can get young wife/husband or mother/father benefits.

C++
static Age childAgeForMFCal(
    const DateMoyr& benefitDate,
    bool isDisabled
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& benefitDate | Benefit date.
bool isDisabled | True if child is disabled, false otherwise.
Collapse Expand Returns

Infinite age (199) if isDisabled is true. Otherwise, returns 18 if benefitDate is before the 1981 amendments, 16 if at that date or later.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::deconvertPia Method

PiaParams::deconvertPia Method
PiaParams Class PiaParams Members PiaParams Methods

Deconverts PIA back to year of eligibility.

C++
double deconvertPia(
    int eligYear,
    int number,
    double pia77,
    const DateMoyr& benDate
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
int number | Number of years for which benefit increases are applied.
double pia77 | PIA or MFB to be increased.
const DateMoyr& benDate | The date of benefit.
Collapse Expand Returns

Deconverted PIA.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::deemedQcReqCal Method

PiaParams::deemedQcReqCal Method
PiaParams Class PiaParams Members PiaParams Methods

Returns number of quarters of coverage required for deemed insured status.

C++
static int deemedQcReqCal(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Adjusted year of birth.
Collapse Expand Returns

Number of quarters of coverage required for deemed insured status. Returns -1 if ineligible because of age (born January 2, 1929 or later).

Collapse Expand Remarks

Note that this is a static function.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::doRecalc Method

PiaParams::doRecalc Method
PiaParams Class PiaParams Members PiaParams Methods

Returns true if should recalculate PIAs this year because of a newly effective law change, else false.

C++
bool doRecalc(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year to check if a recalc is needed.
Collapse Expand Returns

True if should recalculate PIAs this year because of a newly effective law change, else false.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::earlyAgeDisWidCal Method

PiaParams::earlyAgeDisWidCal Method
PiaParams Class PiaParams Members PiaParams Methods

Returns earliest possible disabled widow(er)'s retirement age.

C++
static Age earlyAgeDisWidCal(
    const DateMoyr& benefitDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& benefitDate | Benefit date.
Collapse Expand Returns

Earliest possible disabled widow(er)'s retirement age.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::earlyAgeOabCal Method

PiaParams::earlyAgeOabCal Method
PiaParams Class PiaParams Members PiaParams Methods

Returns earliest possible retirement age for oab or aged spouse.

C++
virtual Age earlyAgeOabCal(
    Sex::sex_type,
    const boost::gregorian::date&
) const = 0;
Collapse Expand Returns

Earliest possible retirement age for oab or aged spouse.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::earlyAgeOabCalPL Method

PiaParams::earlyAgeOabCalPL Method
PiaParams Class PiaParams Members PiaParams Methods

Returns earliest possible retirement age for old-age benie or aged spouse, based on present law.

C++
static Age earlyAgeOabCalPL(
    Sex::sex_type sex,
    const boost::gregorian::date& kbirth
);
Collapse Expand Parameters
Parameters | Description
Sex::sex_type sex | The sex of number holder (Sex::sex_type::MALE for male, Sex::sex_type::FEMALE for female).
const boost::gregorian::date& kbirth | The date of birth, adjusted to previous day.
Collapse Expand Returns

Earliest possible retirement age for old-age benie or aged spouse, based on present law.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::earlyAgeWidCal Method

PiaParams::earlyAgeWidCal Method
PiaParams Class PiaParams Members PiaParams Methods

Returns earliest possible aged widow(er)'s retirement age.

C++
static Age earlyAgeWidCal(
    const DateMoyr& benefitDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& benefitDate | Benefit date.
Collapse Expand Returns

Earliest possible aged widow(er)'s retirement age.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::factorAgedSpouseCal Method

PiaParams::factorAgedSpouseCal Method
PiaParams Class PiaParams Members PiaParams Methods

Returns factor for wife/husband benefit before age reduction.

C++
virtual double factorAgedSpouseCal(
    int,
    int
) const = 0;
Collapse Expand Returns

Factor for wife/husband benefit before age reduction.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::factorAgedSpouseCalPL Method

PiaParams::factorAgedSpouseCalPL Method
PiaParams Class PiaParams Members PiaParams Methods

Returns factor for wife/husband benefit before age reduction.

C++
static double factorAgedSpouseCalPL();
Collapse Expand Returns

0.5 for present law.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::factorAgedWidCal Method

PiaParams::factorAgedWidCal Method
PiaParams Class PiaParams Members PiaParams Methods

Returns factor for widow(er) benefit before age reduction.

C++
virtual double factorAgedWidCal(
    int,
    const Age&,
    int,
    const DateMoyr&
) const = 0;
Collapse Expand Returns

Factor for widow(er) benefit before age reduction.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::factorAgedWidCalPL Method

PiaParams::factorAgedWidCalPL Method
PiaParams Class PiaParams Members PiaParams Methods

Returns factor for widow/widower benefit before age reduction.

C++
static double factorAgedWidCalPL(
    int monthsArdri,
    const Age& age,
    const DateMoyr& benefitDate
);
Collapse Expand Parameters
Parameters | Description
int monthsArdri | Months of reduction.
const Age& age | The age of widow/widower.
const DateMoyr& benefitDate | The date of benefit.
Collapse Expand Returns

Factor for widow/widower benefit before age reduction.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::factorArAgedSpouseCal Method

PiaParams::factorArAgedSpouseCal Method
PiaParams Class PiaParams Members PiaParams Methods

Returns reduction factor for wife/husband.

C++
virtual double factorArAgedSpouseCal(
    int
) const = 0;
Collapse Expand Returns

Reduction factor for wife/husband.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::factorArAgedSpouseCalPL Method

PiaParams::factorArAgedSpouseCalPL Method
PiaParams Class PiaParams Members PiaParams Methods

Calculates reduction factor for wife/husband. Assumes a maximum of 60 months of reduction.

C++
static double factorArAgedSpouseCalPL(
    int monthsArdri
);
Collapse Expand Parameters
Parameters | Description
int monthsArdri | Number of months of reduction.
Collapse Expand Returns

Reduction factor for wife/husband.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::factorArCal Method

PiaParams::factorArCal Method
PiaParams Class PiaParams Members PiaParams Methods

Returns reduction factor for OAB.

C++
virtual double factorArCal(
    int
) const = 0;
Collapse Expand Returns

Reduction factor for OAB.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::factorArCalPL Method

PiaParams::factorArCalPL Method
PiaParams Class PiaParams Members PiaParams Methods

Calculates reduction factor for OAB or DIB.

C++
static double factorArCalPL(
    int monthsArdri
);
Collapse Expand Parameters
Parameters | Description
int monthsArdri | Number of months of reduction.
Collapse Expand Returns

Reduction factor for OAB or DIB.

Collapse Expand Remarks

The reduction is 5/9 of 1 percent for each of the first 36 months of reduction, and 5/12 of 1 percent for each additional month. Assumes a maximum of 60 months of reduction.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::factorArDisWidCal Method

PiaParams::factorArDisWidCal Method
PiaParams Class PiaParams Members PiaParams Methods

Calculates reduction factor for disabled widow(er).

C++
static double factorArDisWidCal(
    int monthsArdri,
    const DateMoyr& entDate
);
Collapse Expand Parameters
Parameters | Description
int monthsArdri | Number of months of reduction. This includes months to full retirement age. These are ignored starting in 1984, when all disabled widow(er)s get 71.5 percent of PIA. But before 1984, we must use the number of months prior to age 60 to calculate the correct reduction. So we subtract 60 (the number of months from 60 to 65) from monthsArdri before calculating the reduction factor.
const DateMoyr& entDate | The date of entitlement.
Collapse Expand Returns

Reduction factor for disabled widow(er).

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::factorArWidCal Method

PiaParams::factorArWidCal Method
PiaParams Class PiaParams Members PiaParams Methods

Calculates reduction factor for aged widow(er).

C++
virtual double factorArWidCal(
    int monthsArdri,
    const Age& age,
    const DateMoyr& benefitDate,
    const Age& fullRetAge
) const;
Collapse Expand Parameters
Parameters | Description
int monthsArdri | Number of months of reduction.
const Age& age | The age for which reduction is being calculated.
const DateMoyr& benefitDate | The date of benefit.
const Age& fullRetAge | Full retirement age of widow(er).
Collapse Expand Returns

Reduction factor for aged widow(er).

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::factorDisWidCal Method

PiaParams::factorDisWidCal Method
PiaParams Class PiaParams Members PiaParams Methods

Returns factor for disabled widow(er) benefit before age reduction.

C++
virtual double factorDisWidCal(
    int,
    const DateMoyr&
) const = 0;
Collapse Expand Returns

Factor for disabled widow(er) benefit before age reduction.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::factorDisWidCalPL Method

PiaParams::factorDisWidCalPL Method
PiaParams Class PiaParams Members PiaParams Methods

Returns factor for disabled widow/widower benefit before age reduction.

C++
static double factorDisWidCalPL(
    const DateMoyr& benefitDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& benefitDate | The date of benefit.
Collapse Expand Returns

Factor for disabled widow/widower benefit before age reduction.

Collapse Expand Remarks

For benefits prior to 1973, returns 0.825. For 1973 and later, returns 1.0, even though all disabled widow/widower benefits are 71.5 percent of PIA. We must do it this way because the unreduced benefit is used when applying the maximum family benefit. After the MFB, we reduce the benefit for age (0.715 factor).

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::factorDriCal Method

PiaParams::factorDriCal Method
PiaParams Class PiaParams Members PiaParams Methods

Calculates delayed retirement increment factor for OAB.

C++
static double factorDriCal(
    int monthsArdri,
    int eligYear
);
Collapse Expand Parameters
Parameters | Description
int monthsArdri | Number of months of increment.
int eligYear | Year of eligibility.
Collapse Expand Returns

Delayed retirement increment factor for OAB.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::factorYngLifeCal Method

PiaParams::factorYngLifeCal Method
PiaParams Class PiaParams Members PiaParams Methods

Calculates reduction factor for young life benie.

C++
virtual double factorYngLifeCal() const;
Collapse Expand Returns

0.50 for present law.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::factorYngSurvCal Method

PiaParams::factorYngSurvCal Method
PiaParams Class PiaParams Members PiaParams Methods

Calculates reduction factor for young survivor.

C++
virtual double factorYngSurvCal() const;
Collapse Expand Returns

0.75 for present law.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::fullRetAgeCal Method

PiaParams::fullRetAgeCal Method
PiaParams Class PiaParams Members PiaParams Methods

Returns full retirement age.

C++
virtual Age fullRetAgeCal(
    int
) const = 0;
Collapse Expand Returns

Full retirement age.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::fullRetAgeCalDI Method

PiaParams::fullRetAgeCalDI Method
PiaParams Class PiaParams Members PiaParams Methods

Returns full retirement age for benefit calculations involving disability freeze.

C++
virtual Age fullRetAgeCalDI(
    int,
    int
) const = 0;
Collapse Expand Returns

Full retirement age for benefit calculations involving disability freeze.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::fullRetAgeCalDIPL Method

PiaParams::fullRetAgeCalDIPL Method
PiaParams Class PiaParams Members PiaParams Methods

Returns full retirement age for benefit calculations involving disability freeze.

C++
static Age fullRetAgeCalDIPL(
    int eligYear,
    int currentYear
);
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility (year of attainment of age 62 for oab or wife/husband, year of attainment of age 60 for widow(er)).
int currentYear | Current year.
Collapse Expand Returns

Full retirement age for benefit calculations involving disability freeze. In this class, it is based on present law, but a subclass could change it.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::fullRetAgeCalPL Method

PiaParams::fullRetAgeCalPL Method
PiaParams Class PiaParams Members PiaParams Methods

Returns full retirement age based on present law.

C++
static Age fullRetAgeCalPL(
    int eligYear
);
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility (year of attainment of age 62 for oab or wife/husband, year of attainment of age 60 for widow(er)).
Collapse Expand Returns

Full retirement age based on present law.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getAverageWage Method

PiaParams::getAverageWage Method
PiaParams Class PiaParams Members PiaParams Methods

Returns title of average wage assumptions.

C++
const std::string& getAverageWage() const;
Collapse Expand Returns

Title of average wage assumptions.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getBase77 Method

PiaParams::getBase77 Method
PiaParams Class PiaParams Members PiaParams Methods

Returns one old-law wage base.

C++
virtual double getBase77(
    int
) const = 0;
Collapse Expand Returns

One old-law wage base.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getBase77Array Method

PiaParams::getBase77Array Method
PiaParams Class PiaParams Members PiaParams Methods

Returns the array of old-law wage bases.

C++
virtual const WageBaseOldLaw& getBase77Array() const = 0;
Collapse Expand Returns

The array of old-law wage bases.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getBaseHi Method

PiaParams::getBaseHi Method
PiaParams Class PiaParams Members PiaParams Methods

Returns one HI wage base.

C++
double getBaseHi(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which base is desired.
Collapse Expand Returns

One HI wage base.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getBaseHiArray Method

PiaParams::getBaseHiArray Method
PiaParams Class PiaParams Members PiaParams Methods

Returns the array of HI wage bases.

C++
const WageBaseHI& getBaseHiArray() const;
Collapse Expand Returns

The array of HI wage bases.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getBaseOasdi Method

PiaParams::getBaseOasdi Method
PiaParams Class PiaParams Members PiaParams Methods

Returns one OASDI wage base.

C++
virtual double getBaseOasdi(
    int
) const = 0;
Collapse Expand Returns

One OASDI wage base.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getBaseOasdiArray Method

PiaParams::getBaseOasdiArray Method
PiaParams Class PiaParams Members PiaParams Methods

Returns the array of OASDI wage bases.

C++
virtual const WageBase& getBaseOasdiArray() const = 0;
Collapse Expand Returns

The array of OASDI wage bases.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getBendOS Method

PiaParams::getBendOS Method
PiaParams Class PiaParams Members PiaParams Methods

Returns a bend point for old-start PIB formula.

C++
static int getBendOS(
    int number
);
Collapse Expand Parameters
Parameters | Description
int number | Number of bend point (0-2).
Collapse Expand Returns

A bend point for old-start PIB formula.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getBenefitInc Method

PiaParams::getBenefitInc Method
PiaParams Class PiaParams Members PiaParams Methods

Returns title of benefit increase assumptions.

C++
const std::string& getBenefitInc() const;
Collapse Expand Returns

Title of benefit increase assumptions.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getCatchup Method

PiaParams::getCatchup Method
PiaParams Class PiaParams Members PiaParams Methods

Returns catch-up benefit increases.

C++
const Catchup& getCatchup() const;
Collapse Expand Returns

Catch-up benefit increases.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getChildcareDropoutAmount Method

PiaParams::getChildcareDropoutAmount Method
PiaParams Class PiaParams Members PiaParams Methods

Returns maximum amount of earnings in a childcare dropout year.

C++
virtual double getChildcareDropoutAmount(
    int,
    int
) const = 0;
Collapse Expand Returns

Maximum amount of earnings in a childcare dropout year.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getChildcareDropoutAmountPL Method

PiaParams::getChildcareDropoutAmountPL Method
PiaParams Class PiaParams Members PiaParams Methods

Returns maximum amount of earnings in a childcare dropout year.

C++
static double getChildcareDropoutAmountPL();
Collapse Expand Returns

0 for present law.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getColaCap Method

PiaParams::getColaCap Method
PiaParams Class PiaParams Members PiaParams Methods

Returns the amount of the cap on the COLA for the given year.

C++
virtual double getColaCap(
    int
) const = 0;
Collapse Expand Returns

The amount of the cap on the COLA for the given year.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getCpiinc Method

PiaParams::getCpiinc Method
PiaParams Class PiaParams Members PiaParams Methods

Returns one benefit increase.

C++
virtual double getCpiinc(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which benefit increase is desired.
Collapse Expand Returns

One benefit increase.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getCpiincArray Method

PiaParams::getCpiincArray Method
PiaParams Class PiaParams Members PiaParams Methods

Returns the array of benefit increases.

C++
virtual const DoubleAnnual& getCpiincArray() const;
Collapse Expand Returns

The array of benefit increases.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getFq Method

PiaParams::getFq Method
PiaParams Class PiaParams Members PiaParams Methods

Returns one average wage for indexing.

C++
double getFq(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which base is desired.
Collapse Expand Returns

One average wage for indexing.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getFqArray Method

PiaParams::getFqArray Method
PiaParams Class PiaParams Members PiaParams Methods

Returns array of average wages for indexing.

C++
const AverageWage& getFqArray() const;
Collapse Expand Returns

Array of average wages for indexing.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getFqBppia Method

PiaParams::getFqBppia Method
PiaParams Class PiaParams Members PiaParams Methods

Returns series used for indexing pia formula bend points.

C++
virtual const AverageWage& getFqBppia() const = 0;
Collapse Expand Returns

Series used for indexing pia formula bend points.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getFqIndex Method

PiaParams::getFqIndex Method
PiaParams Class PiaParams Members PiaParams Methods

Returns series used for indexing an earnings record.

C++
virtual const AverageWage& getFqIndex() const = 0;
Collapse Expand Returns

Series used for indexing an earnings record.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getFqinc Method

PiaParams::getFqinc Method
PiaParams Class PiaParams Members PiaParams Methods

Returns one increase in average wage for indexing.

C++
double getFqinc(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which average wage increase is desired.
Collapse Expand Returns

Increase in average wage for indexing.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getFqincArray Method

PiaParams::getFqincArray Method
PiaParams Class PiaParams Members PiaParams Methods

Returns array of increases in average wage for indexing.

C++
const Awinc& getFqincArray() const;
Collapse Expand Returns

Array of increases in average wage for indexing.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getIstart Method

PiaParams::getIstart Method
PiaParams Class PiaParams Members PiaParams Methods

Returns current year.

C++
int getIstart() const;
Collapse Expand Returns

Current year.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getMarrLengthForDivBen Method

PiaParams::getMarrLengthForDivBen Method
PiaParams Class PiaParams Members PiaParams Methods

Returns the number of years of marraige needed to be eligible for a divroced spouse benefit.

C++
virtual int getMarrLengthForDivBen(
    const DateMoyr&
) const = 0;
Collapse Expand Returns

Number of years of marriage needed to be eligible for a divorced spouse benefit.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getMarrLengthForDivBenPL Method

PiaParams::getMarrLengthForDivBenPL Method
PiaParams Class PiaParams Members PiaParams Methods

Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.

C++
static int getMarrLengthForDivBenPL(
    const DateMoyr& dateMoyr
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The date (year and month) when checking if eligible for a divorced spouse benefit.
Collapse Expand Returns

The number of years of marriage needed to be eligible for a divorced spouse benefit.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getMaxChildcareAge Method

PiaParams::getMaxChildcareAge Method
PiaParams Class PiaParams Members PiaParams Methods

Returns maximum age of child for childcare dropout year.

C++
virtual int getMaxChildcareAge() const = 0;
Collapse Expand Returns

Maximum age of child for childcare dropout year.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getMaxChildcareAgePL Method

PiaParams::getMaxChildcareAgePL Method
PiaParams Class PiaParams Members PiaParams Methods

Returns maximum age of child for childcare dropout year.

C++
static int getMaxChildcareAgePL();
Collapse Expand Returns

3 for present law.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getMaxChildcareDropoutYears Method

PiaParams::getMaxChildcareDropoutYears Method
PiaParams Class PiaParams Members PiaParams Methods

Returns maximum number of childcare dropout years.

C++
virtual int getMaxChildcareDropoutYears(
    int,
    int
) const = 0;
Collapse Expand Returns

Maximum number of childcare dropout years.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getMaxChildcareDropoutYearsPL Method

PiaParams::getMaxChildcareDropoutYearsPL Method
PiaParams Class PiaParams Members PiaParams Methods

Returns maximum number of childcare dropout years.

C++
static int getMaxChildcareDropoutYearsPL();
Collapse Expand Returns

3 for present law.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getMaxyear Method

PiaParams::getMaxyear Method
PiaParams Class PiaParams Members PiaParams Methods

Returns maximum possible year.

C++
int getMaxyear() const;
Collapse Expand Returns

Maximum possible year.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getMfbColaCap Method

PiaParams::getMfbColaCap Method
PiaParams Class PiaParams Members PiaParams Methods

Returns the amount of the cap on the COLA for the MFB.

C++
virtual double getMfbColaCap(
    int
) const = 0;
Collapse Expand Returns

The amount of the cap on the COLA for the MFB.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getMonthBeninc Method

PiaParams::getMonthBeninc Method
PiaParams Class PiaParams Members PiaParams Methods

Returns one month of benefit increase.

C++
int getMonthBeninc(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of desired month of benefit increase.
Collapse Expand Returns

Month of benefit increase for specified year.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getMonthBenincArray Method

PiaParams::getMonthBenincArray Method
PiaParams Class PiaParams Members PiaParams Methods

Returns array of months of benefit increase.

C++
const IntAnnual& getMonthBenincArray() const;
Collapse Expand Returns

Array of months of benefit increase.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getPercOS Method

PiaParams::getPercOS Method
PiaParams Class PiaParams Members PiaParams Methods

Returns old-start PIB formula percentage.

C++
static double getPercOS(
    int number
);
Collapse Expand Parameters
Parameters | Description
int number | Number of percentage (0-1).
Collapse Expand Returns

Old-start PIB formula percentage.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getPercSpecMin Method

PiaParams::getPercSpecMin Method
PiaParams Class PiaParams Members PiaParams Methods

Returns percent of old-law base required for year of coverage.

C++
double getPercSpecMin(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | The year for which the percent is required.
Collapse Expand Returns

Percent of old-law base required for year of coverage.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getPercSpecMinArray Method

PiaParams::getPercSpecMinArray Method
PiaParams Class PiaParams Members PiaParams Methods

Returns array of percents of old-law base required for year of coverage.

C++
const DoubleAnnual& getPercSpecMinArray() const;
Collapse Expand Returns

Array of percents of old-law base required for year of coverage.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getSpecMinMfb Method

PiaParams::getSpecMinMfb Method
PiaParams Class PiaParams Members PiaParams Methods

Returns special minimum mfb as of a specified month.

C++
virtual double getSpecMinMfb(
    const DateMoyr& dateMoyr,
    int yoc
) const;
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | Month and year for which mfb is desired (January 1979 or later).
int yoc | Years of coverage in excess of 10 (1-20).
Collapse Expand Returns

Special minimum mfb.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getSpecMinPerc Method

PiaParams::getSpecMinPerc Method
PiaParams Class PiaParams Members PiaParams Methods

Returns percentage of old-law base required for year of coverage.

C++
static double getSpecMinPerc(
    SPECMINPERCTYPE number
);
Collapse Expand Parameters
Parameters | Description
SPECMINPERCTYPE number | Type of year of coverage.
Collapse Expand Returns

Percentage of old-law base required for year of coverage.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getSpecMinPia Method

PiaParams::getSpecMinPia Method
PiaParams Class PiaParams Members PiaParams Methods

Returns special minimum pia as of a specified month.

C++
virtual double getSpecMinPia(
    const DateMoyr& dateMoyr,
    int yoc
) const;
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | Month and year for which pia is desired (January 1979 or later).
int yoc | Years of coverage in excess of 10 (1-20).
Collapse Expand Returns

Special minimum pia.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getYocAmountSpecMin Method

PiaParams::getYocAmountSpecMin Method
PiaParams Class PiaParams Members PiaParams Methods

Returns amount required for year of coverage for special minimum.

C++
double getYocAmountSpecMin(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which amount is required.
Collapse Expand Returns

Amount required for year of coverage for special minimum.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getYocAmountSpecMinArray Method

PiaParams::getYocAmountSpecMinArray Method
PiaParams Class PiaParams Members PiaParams Methods

Returns array of amounts required for year of coverage for special minimum.

C++
const DoubleAnnual& getYocAmountSpecMinArray() const;
Collapse Expand Returns

Array of amounts required for year of coverage for special minimum.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::getYocAmountWindfallArray Method

PiaParams::getYocAmountWindfallArray Method
PiaParams Class PiaParams Members PiaParams Methods

Returns array of amounts required for year of coverage for windfall elimination.

C++
const DoubleAnnual& getYocAmountWindfallArray() const;
Collapse Expand Returns

Array of amounts required for year of coverage for windfall elimination.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::initdata Method

PiaParams::initdata Method
PiaParams Class PiaParams Members PiaParams Methods

Initializes some data.

C++
virtual void initdata();
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::isApplicableCola99 Method

PiaParams::isApplicableCola99 Method
PiaParams Class PiaParams Members PiaParams Methods

Checks for applicability of special 1999 increase (with extra 0.1 percent).

C++
bool isApplicableCola99(
    int year,
    const DateMoyr& dateMoyr
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of benefit increase.
const DateMoyr& dateMoyr | The date up to which to apply benefit increases.
Collapse Expand Returns

True if special 1999 increase should be used.

Collapse Expand Remarks

The year of benefit increase must be 1999, 2001 must be a historical year, and the benefit is for August 2001 or later.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::lastAmw Method

PiaParams::lastAmw Method
PiaParams Class PiaParams Members PiaParams Methods

Finds last AMW in old-law table.

C++
long lastAmw(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which last AMW is desired.
Collapse Expand Returns

Last AMW in old-law table.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::lumpSum Method

PiaParams::lumpSum Method
PiaParams Class PiaParams Members PiaParams Methods

Returns amount of lump sum benefit.

C++
static double lumpSum();
Collapse Expand Returns

Simply $255.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::maxChildAge Method

PiaParams::maxChildAge Method
PiaParams Class PiaParams Members PiaParams Methods

Returns maximum child beneficiary age.

C++
static Age maxChildAge(
    const DateMoyr& benefitDate,
    bool isDisabled,
    bool isStudent
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& benefitDate | The date of benefit.
bool isDisabled | True if child is disabled, false otherwise.
bool isStudent | True if student, false otherwise.
Collapse Expand Returns

Maximum child beneficiary age.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::maxDibAge Method

PiaParams::maxDibAge Method
PiaParams Class PiaParams Members PiaParams Methods

Returns maximum DI beneficiary age at end of year.

C++
virtual Age maxDibAge(
    int
) const = 0;
Collapse Expand Returns

Maximum DI beneficiary age at end of year.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::maxDibAgePL Method

PiaParams::maxDibAgePL Method
PiaParams Class PiaParams Members PiaParams Methods

Returns maximum DI beneficiary age at end of year, based on present law.

C++
static Age maxDibAgePL(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year of benefit.
Collapse Expand Returns

Maximum DI beneficiary age at end of year, based on present law.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::monthsArAgedSpouseCal Method

PiaParams::monthsArAgedSpouseCal Method
PiaParams Class PiaParams Members PiaParams Methods

Calculates number of months of actuarial reduction for aged wife/husband.

C++
static int monthsArAgedSpouseCal(
    const Age& age,
    const DateMoyr& benefitDate,
    const Age& fullRetAge
);
Collapse Expand Parameters
Parameters | Description
const Age& age | The age for which reduction is being calculated.
const DateMoyr& benefitDate | The date of benefit.
const Age& fullRetAge | Full retirement age of wife/husband.
Collapse Expand Returns

Number of months of actuarial reduction for aged wife/husband. Returns 0 if entitlement is at or after full retirement age.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::monthsArCal Method

PiaParams::monthsArCal Method
PiaParams Class PiaParams Members PiaParams Methods

Calculates number of months of actuarial reduction for OAB.

C++
static int monthsArCal(
    const Age& age,
    const Age& fullRetAge
);
Collapse Expand Parameters
Parameters | Description
const Age& age | The age for which reduction is being calculated.
const Age& fullRetAge | Full retirement age.
Collapse Expand Returns

Number of months of actuarial reduction for OAB.

Collapse Expand Remarks

Assumes age is no more than the full retirement age. Returns the number of months between those two ages.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::monthsArDICal Method

PiaParams::monthsArDICal Method
PiaParams Class PiaParams Members PiaParams Methods

Calculates number of months of reduction for disabled worker.

C++
static int monthsArDICal(
    const DateMoyr& oabEntDate,
    const DateMoyr& oabCessDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& oabEntDate | The date of entitlement to an old-age benefit prior to the disabled worker benefit. Should be the default DateMoyr (0 month and 0 year) if none.
const DateMoyr& oabCessDate | The date of cessation of an old-age benefit prior to the disabled worker benefit. Should be the default DateMoyr (0 month and 0 year) if none.
Collapse Expand Returns

The number of months from oabEntDate to oabCessDate.

Collapse Expand Remarks

Disabled workers do not have any reduction unless they received an old-age benefit prior to their disability benefit.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::monthsArDisWidCal Method

PiaParams::monthsArDisWidCal Method
PiaParams Class PiaParams Members PiaParams Methods

Calculates number of months of actuarial reduction for disabled widow(er).

C++
static int monthsArDisWidCal(
    const Age& age,
    const DateMoyr& benefitDate,
    const Age& fullRetAge
);
Collapse Expand Parameters
Parameters | Description
const Age& age | The age for which reduction is being calculated.
const DateMoyr& benefitDate | The date of benefit.
const Age& fullRetAge | Full retirement age of widow(er).
Collapse Expand Returns

Number of months of actuarial reduction for disabled widow(er).

Collapse Expand Remarks

Before 1984, includes all months from entitlement date to age 65. Starting in 1984, includes months only from age 60 to full retirement age.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::monthsArWidCal Method

PiaParams::monthsArWidCal Method
PiaParams Class PiaParams Members PiaParams Methods

Calculates number of months of actuarial reduction for aged widow(er).

C++
static int monthsArWidCal(
    const Age& age,
    const DateMoyr& benefitDate,
    const Age& fullRetAge
);
Collapse Expand Parameters
Parameters | Description
const Age& age | The age for which reduction is being calculated.
const DateMoyr& benefitDate | The date of benefit.
const Age& fullRetAge | Full retirement age of widow(er).
Collapse Expand Returns

Mumber of months of actuarial reduction for aged widow(er). Returns 0 if entitlement is at or after full retirement age.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::monthsDriCal Method

PiaParams::monthsDriCal Method
PiaParams Class PiaParams Members PiaParams Methods

Calculates number of months of delayed retirement credit for OAB.

C++
static int monthsDriCal(
    const DateMoyr& fullRetDate,
    int eligYear,
    const boost::gregorian::date& dobadj,
    const DateMoyr& entDate,
    const DateMoyr& benefitDate,
    const DateMoyr& fullInsDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& fullRetDate | The date of attainment of full retirement age.
int eligYear | Year of eligibility.
const boost::gregorian::date& dobadj | Adjusted date of birth.
const DateMoyr& entDate | The date of entitlement.
const DateMoyr& benefitDate | The date of benefit.
const DateMoyr& fullInsDate | The date fully insured status is attained.
Collapse Expand Returns

Number of months of delayed retirement credit for OAB.

Collapse Expand Remarks

Delayed retirement credit can be earned for months beginning in January 1971, but only if the worker has attained full retirement age and is fully insured. Credits stop at age 72 or 70.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


needColaCap Method

needColaCap Method
PiaParams Methods

Returns true if a cola cap is required.

Collapse Expand Description

There are two versions of the needColaCap function. The one with a year argument checks to see if a cola cap is required for that specified year; the one with no arguments checks to see if a cola cap is required at any time.

Collapse Expand Overload List
Name | Description
PiaParams::needColaCap () | Returns true if a cola cap is required at any time.
PiaParams::needColaCap (int) | Returns true if a cola cap is required for a specified year.
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Methods


PiaParams::needColaCap Method ()

PiaParams::needColaCap Method ()
PiaParams Class PiaParams Members needColaCap Method

Returns true if a cola cap is required at any time.

C++
virtual bool needColaCap() const = 0;
Collapse Expand Returns

True if a cola cap is required.

Collapse Expand Group

needColaCap Method

Collapse Expand Links
PiaParams Class, PiaParams Members, needColaCap Method


PiaParams::needColaCap Method (int)

PiaParams::needColaCap Method (int)
PiaParams Class PiaParams Members needColaCap Method

Returns true if a cola cap is required for a specified year.

C++
virtual bool needColaCap(
    int year
) const = 0;
Collapse Expand Parameters
Parameters | Description
int year | Year being capped.
Collapse Expand Returns

True if a cola cap is required.

Collapse Expand Group

needColaCap Method

Collapse Expand Links
PiaParams Class, PiaParams Members, needColaCap Method


PiaParams::percPiaCal Method

PiaParams::percPiaCal Method
PiaParams Class PiaParams Members PiaParams Methods

Sets benefit formula percents.

C++
void percPiaCal(
    int eligYear,
    PercPia& percPia
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
PercPia& percPia | Benefit formula percents.
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::projectCpiinc Method

PiaParams::projectCpiinc Method
PiaParams Class PiaParams Members PiaParams Methods

Projects amounts dependent on benefit increases.

C++
virtual void projectCpiinc() = 0;
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::projectFq Method

PiaParams::projectFq Method
PiaParams Class PiaParams Members PiaParams Methods

Projects amounts dependent on the average annual wage.

C++
virtual void projectFq();
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::projectPerc Method

PiaParams::projectPerc Method
PiaParams Class PiaParams Members PiaParams Methods

Projects benefit formula percentages.

C++
virtual void projectPerc();
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::projectSpecMin Method

PiaParams::projectSpecMin Method
PiaParams Class PiaParams Members PiaParams Methods

Projects special minimum amounts.

C++
virtual void projectSpecMin(
    int baseYear,
    int lastYear
);
Collapse Expand Parameters
Parameters | Description
int baseYear | First year of special minimum amounts (1979 for present law).
int lastYear | Last year of projection.
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::qcCal Method

PiaParams::qcCal Method
PiaParams Class PiaParams Members PiaParams Methods

Returns number of quarters of coverage for one year, applying annual test.

C++
int qcCal(
    double earnings,
    int year
) const;
Collapse Expand Parameters
Parameters | Description
double earnings | Annual earnings.
int year | Year of earnings.
Collapse Expand Returns

Number of quarters of coverage for one year.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::resizeSpecMin Method

PiaParams::resizeSpecMin Method
PiaParams Class PiaParams Members PiaParams Methods

Resizes special minimum arrays.

C++
virtual void resizeSpecMin();
Collapse Expand Remarks

This is called in PiaParamsPL::projectCpiinc.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::retCredit Method

PiaParams::retCredit Method
PiaParams Class PiaParams Members PiaParams Methods

Returns amount of monthly delayed retirement credit.

C++
static double retCredit(
    int eligYear
);
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
Collapse Expand Returns

Amount of monthly delayed retirement credit.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::ribLimCal Method

PiaParams::ribLimCal Method
PiaParams Class PiaParams Members PiaParams Methods

Returns widow(er) benefit reduced for RIB-LIM.

C++
virtual double ribLimCal(
    double,
    double,
    double,
    const DateMoyr&
) const = 0;
Collapse Expand Returns

Reduced widow(er) benefit.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::ribLimCalPL Method

PiaParams::ribLimCalPL Method
PiaParams Class PiaParams Members PiaParams Methods

Returns widow(er) benefit reduced for RIB-LIM.

C++
static double ribLimCalPL(
    double widowBen,
    double oabPia,
    double oabBen,
    const DateMoyr& benefitDate
);
Collapse Expand Parameters
Parameters | Description
double widowBen | Widow(er) benefit reduced for widow(er)'s age, but not for RIB-LIM.
double oabPia | PIA upon which widow(er) benefit is based. Note that this is not a re-indexed widow(er) PIA, since the OAB must have survived to age 62.
double oabBen | Benefit that deceased OAB was receiving, increased by colas up to benefitDate (with rounding applied).
const DateMoyr& benefitDate | The date of benefit.
Collapse Expand Returns

Reduced widow(er) benefit (with rounding applied).

Collapse Expand Remarks

This should only be called in cases where the deceased worker was an OAB before death. Note that this is a static function.

Before 1973, the widow(er) benefit was 82.5 percent of PIA. Starting in 1973, there was an age-related factor applied to the PIA, resulting in benefits that could be more or less than 82.5 percent of PIA. As part of that change, widow(er) benefits were limited to what the deceased worker was receiving as an OAB. If he/she was not receiving an OAB, there was no limit. He/she could have been receiving a benefit as low as 80 percent of PIA. But if he/she was receiving less than 82.5 percent of PIA, the widow(er) can still get 82.5 percent of PIA, so as not to get less than she/he could have gotten before the law changed.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::setColaCap Method

PiaParams::setColaCap Method
PiaParams Class PiaParams Members PiaParams Methods

Sets the amount of the cap on the COLA for the given year.

C++
virtual void setColaCap(
    double,
    int
) = 0;
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::setData Method

PiaParams::setData Method
PiaParams Class PiaParams Members PiaParams Methods

Sets data from historical average wages and benefit increase file.

C++
virtual void setData(
    AwbiData& awbiData
);
Collapse Expand Parameters
Parameters | Description
AwbiData& awbiData | Structure with historical average wages and benefit increases.
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::setHistFqinc Method

PiaParams::setHistFqinc Method
PiaParams Class PiaParams Members PiaParams Methods

Sets historical average wage increases.

C++
void setHistFqinc();
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::setIstart Method

PiaParams::setIstart Method
PiaParams Class PiaParams Members PiaParams Methods

Sets the first projected year, including for members.

C++
void setIstart(
    int newIstart
);
Collapse Expand Parameters
Parameters | Description
int newIstart | New first projected year.
Collapse Expand Remarks

The first projected year is set in the constructor, but may be reset by this function. This is only necessary if the user wants to change the base year for computations, which is rare (such as when a pension actuary wants to get a benefit with the law as it stood at a prior date).

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::setMfbColaCap Method

PiaParams::setMfbColaCap Method
PiaParams Class PiaParams Members PiaParams Methods

Sets the amount of the cap on the COLA for the MFB for the given year.

C++
virtual void setMfbColaCap(
    double,
    int
) = 0;
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::setNoChange Method

PiaParams::setNoChange Method
PiaParams Class PiaParams Members PiaParams Methods

Sets indicators for no change allowed.

C++
void setNoChange(
    int firstYear
);
Collapse Expand Parameters
Parameters | Description
int firstYear | First year change is allowed.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_SETNOCH if year is out of range (debug mode only).
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::specMinAmountCal Method

PiaParams::specMinAmountCal Method
PiaParams Class PiaParams Members PiaParams Methods

Sets amount per year of coverage in special minimum.

C++
virtual double specMinAmountCal(
    const DateMoyr&
) const = 0;
Collapse Expand Returns

Amount per year of coverage in special minimum.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::specMinAmountCalPL Method

PiaParams::specMinAmountCalPL Method
PiaParams Class PiaParams Members PiaParams Methods

Returns amount per year of coverage in special minimum.

C++
static double specMinAmountCalPL(
    const DateMoyr& date
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& date | The date of desired amount.
Collapse Expand Returns

Amount per year of coverage in special minimum.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


specMinMaxYears Method

specMinMaxYears Method
PiaParams Methods

Returns maximum number of usable years for special minimum.

Collapse Expand Description

There are two versions of the specMinMaxYears function. The one with two arguments returns the maximum number of usable years for special minimum for a specified year of eligibility and year of benefit. The one with no arguments returns the maximum number of usable years for any year of eligibility and year of benefit.

Collapse Expand Overload List
Name | Description
PiaParams::specMinMaxYears () | Returns maximum number of usable years for special minimum that could ever be for any year of eligibility and year of benefit.
PiaParams::specMinMaxYears (int, int) | Returns maximum number of usable years for special minimum for a specified year of eligibility and year of benefit.
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Methods


PiaParams::specMinMaxYears Method ()

PiaParams::specMinMaxYears Method ()
PiaParams Class PiaParams Members specMinMaxYears Method

Returns maximum number of usable years for special minimum that could ever be for any year of eligibility and year of benefit.

C++
virtual int specMinMaxYears() const = 0;
Collapse Expand Returns

Maximum number of usable years for special minimum.

Collapse Expand Group

specMinMaxYears Method

Collapse Expand Links
PiaParams Class, PiaParams Members, specMinMaxYears Method


PiaParams::specMinMaxYears Method (int, int)

PiaParams::specMinMaxYears Method (int, int)
PiaParams Class PiaParams Members specMinMaxYears Method

Returns maximum number of usable years for special minimum for a specified year of eligibility and year of benefit.

C++
virtual int specMinMaxYears(
    int,
    int
) const = 0;
Collapse Expand Returns

Maximum number of usable years for special minimum.

Collapse Expand Group

specMinMaxYears Method

Collapse Expand Links
PiaParams Class, PiaParams Members, specMinMaxYears Method


PiaParams::specMinMaxYearsPL Method

PiaParams::specMinMaxYearsPL Method
PiaParams Class PiaParams Members PiaParams Methods

Returns maximum number of usable years for special minimum.

C++
static int specMinMaxYearsPL();
Collapse Expand Returns

20 for present law.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


unApplyCola Method

unApplyCola Method
PiaParams Methods

Returns benefit amount decreased by cola.

Collapse Expand Description

There are two versions of the unApplyCola function. The one with a year of eligibility argument considers catch-up benefit increases; the other does not.

Collapse Expand Overload List
Name | Description
PiaParams::unApplyCola (double, int) | Returns benefit amount decreased by cola.
PiaParams::unApplyCola (double, int, int) | Returns benefit amount decreased by cola.
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Methods


PiaParams::unApplyCola Method (double, int)

PiaParams::unApplyCola Method (double, int)
PiaParams Class PiaParams Members unApplyCola Method

Returns benefit amount decreased by cola.

C++
double unApplyCola(
    double pia,
    int year
) const;
Collapse Expand Parameters
Parameters | Description
double pia | Amount to be decreased.
int year | Year of decrease.
Collapse Expand Returns

Benefit amount decreased by cola.

Collapse Expand Remarks

This version does not consider any catch-up benefit decreases.

Collapse Expand Group

unApplyCola Method

Collapse Expand Links
PiaParams Class, PiaParams Members, unApplyCola Method


PiaParams::unApplyCola Method (double, int, int)

PiaParams::unApplyCola Method (double, int, int)
PiaParams Class PiaParams Members unApplyCola Method

Returns benefit amount decreased by cola.

C++
double unApplyCola(
    double pia,
    int year,
    int eligYear
) const;
Collapse Expand Parameters
Parameters | Description
double pia | Amount to be decreased.
int year | Year of decrease.
int eligYear | Year of eligibility for catch-up benefit decreases.
Collapse Expand Returns

Benefit amount decreased by cola.

Collapse Expand Remarks

This version considers catch-up benefit decreases.

Collapse Expand Group

unApplyCola Method

Collapse Expand Links
PiaParams Class, PiaParams Members, unApplyCola Method


PiaParams::unApplyCola99 Method

PiaParams::unApplyCola99 Method
PiaParams Class PiaParams Members PiaParams Methods

Returns benefit amount decreased by special 1999 cola (includes extra 0.1 percent decrease.)

C++
double unApplyCola99(
    double pia
) const;
Collapse Expand Parameters
Parameters | Description
double pia | Amount to be decreased.
Collapse Expand Returns

Benefit amount decreased by special 1999 cola (includes extra 0.1 percent decrease.)

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::unbiCatchUp Method

PiaParams::unbiCatchUp Method
PiaParams Class PiaParams Members PiaParams Methods

Divides out catch-up benefit increases.

C++
double unbiCatchUp(
    int year,
    double bcatch,
    int eligYear
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of catch-up benefit increase.
double bcatch | Amount to be unincreased.
int eligYear | Year of eligibility.
Collapse Expand Returns

Amount with catch-up benefit increase removed.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_UNBICCHP if either year is out of range (debug mode only).
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


updateBases Method

updateBases Method
PiaParams Methods

Updates wage bases.

Collapse Expand Description

There are two versions of the updateBases function. The one with five arguments updates wage bases for user entries and/or for average wage changes. The one with no arguments updates only for average wage changes.

Collapse Expand Overload List
Name | Description
PiaParams::updateBases () | Updates wage bases for average wage changes.
PiaParams::updateBases (const DoubleAnnual&, const DoubleAnnual&, BaseChangeType::change_type, int, int) | Updates wage bases for user entries and/or for average wage changes.
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Methods


PiaParams::updateBases Method ()

PiaParams::updateBases Method ()
PiaParams Class PiaParams Members updateBases Method

Updates wage bases for average wage changes.

C++
virtual void updateBases() = 0;
Collapse Expand Group

updateBases Method

Collapse Expand Links
PiaParams Class, PiaParams Members, updateBases Method


PiaParams::updateBases Method (const DoubleAnnual&, const DoubleAnnual&, BaseChangeType::change_type, int, int)

PiaParams::updateBases Method (const DoubleAnnual&, const DoubleAnnual&, BaseChangeType::change_type, int, int)
PiaParams Class PiaParams Members updateBases Method

Updates wage bases for user entries and/or for average wage changes.

C++
virtual void updateBases(
    const DoubleAnnual&,
    const DoubleAnnual&,
    BaseChangeType::change_type,
    int,
    int
) = 0;
Collapse Expand Group

updateBases Method

Collapse Expand Links
PiaParams Class, PiaParams Members, updateBases Method


updateCpiinc Method

updateCpiinc Method
PiaParams Methods

Updates benefit increases.

Collapse Expand Description

There are two versions of the updateCpiinc function. The one with a Catchup argument updates catch-up benefit increases; the other one does not.

Collapse Expand Overload List
Name | Description
PiaParams::updateCpiinc (const DoubleAnnual&, const Catchup&, const std::string&, int, int) | Updates benefit increases.
PiaParams::updateCpiinc (const DoubleAnnual&, const std::string&, int, int) | Updates benefit increases.
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Methods


PiaParams::updateCpiinc Method (const DoubleAnnual&, const Catchup&, const std::string&, int, int)

PiaParams::updateCpiinc Method (const DoubleAnnual&, const Catchup&, const std::string&, int, int)
PiaParams Class PiaParams Members updateCpiinc Method

Updates benefit increases.

C++
void updateCpiinc(
    const DoubleAnnual& userBiproj,
    const Catchup& userCatchup,
    const std::string& userTitle,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& userBiproj | User-entered benefit increases.
const Catchup& userCatchup | User-entered catch-up benefit increases.
const std::string& userTitle | User-entered title of benefit increases.
int firstYeart | First year of user-specified benefit increases.
int lastYeart | Last year of user-specified benefit increases.
Collapse Expand Remarks

This version updates with catch-up increases.

Collapse Expand Group

updateCpiinc Method

Collapse Expand Links
PiaParams Class, PiaParams Members, updateCpiinc Method


PiaParams::updateCpiinc Method (const DoubleAnnual&, const std::string&, int, int)

PiaParams::updateCpiinc Method (const DoubleAnnual&, const std::string&, int, int)
PiaParams Class PiaParams Members updateCpiinc Method

Updates benefit increases.

C++
void updateCpiinc(
    const DoubleAnnual& userBiproj,
    const std::string& userTitle,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& userBiproj | User-entered benefit increases.
const std::string& userTitle | User-entered title of benefit increases.
int firstYeart | First year of user-specified benefit increases.
int lastYeart | Last year of user-specified benefit increases.
Collapse Expand Remarks

This version updates benefit increases without catch-up increases.

Collapse Expand Group

updateCpiinc Method

Collapse Expand Links
PiaParams Class, PiaParams Members, updateCpiinc Method


PiaParams::updateFq Method

PiaParams::updateFq Method
PiaParams Class PiaParams Members PiaParams Methods

Updates average wages, using specified amounts.

C++
void updateFq(
    const DoubleAnnual& userfq,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& userfq | Specified average wages.
int firstYeart | First year of specified average wages.
int lastYeart | Last year of specified average wages.
Collapse Expand Remarks

After filling in the average wages, it projects the percentage increases in average wages in fqinc. Then it calls projectFq to project the amounts dependent on average wages.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_UPDATEFQ if average wage is zero (only in debug mode).
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::updateFqinc Method

PiaParams::updateFqinc Method
PiaParams Class PiaParams Members PiaParams Methods

Updates increases in average wages, using specified percentages.

C++
void updateFqinc(
    const DoubleAnnual& userFqinc,
    const std::string& userTitle,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& userFqinc | Specified average wage percentage increases.
const std::string& userTitle | Specified title of assumptions.
int firstYeart | First year of specified increases.
int lastYeart | Last year of specified increases.
Collapse Expand Remarks

After filling in the percentage increases in average wages, it projects the amount of average wages. Then it calls projectFq to project the amounts dependent on average wages.

Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParams::updateYocAmountSpecMin Method

PiaParams::updateYocAmountSpecMin Method
PiaParams Class PiaParams Members PiaParams Methods

Updates amounts required for special minimum year of coverage.

C++
void updateYocAmountSpecMin();
Collapse Expand Group

PiaParams Methods

Collapse Expand Links
PiaParams Class, PiaParams Members, PiaParams Methods


PiaParamsAny Class

PiaParamsAny Class
PiaParamsAny Methods PiaParamsAny Members piaparmsAny.h Classes

Manages the additional Social Security parameters required to calculate Social Security benefits in the Anypia program.

Collapse Expand Class Hierarchy
  PiaParamsAnyPiaParamsAnyPiaParamsAny
C++
class PiaParamsAny : public PiaParamsLC;
Collapse Expand File

File: piaparmsAny.h

Module: PiaData Library

Collapse Expand Remarks

Manages the additional Social Security parameters required to calculate Social Security benefits in the Anypia program.

Collapse Expand Group

Classes

Collapse Expand Links
PiaParamsAny Methods, PiaParamsAny Members, piaparmsAny.h, Classes


PiaParamsAny Members

PiaParamsAny Members
Enumerations PiaParamsAny Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by PiaParamsAny.

Collapse Expand Enumerations
Name | Description
SPECMINPERCTYPE | The year range for the special minimum percentage.
Collapse Expand Class

PiaParamsAny Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
baseHi | HI wage bases.
bendOS | Bend points for old-start PIB formula.
catchup | Catch-up benefit increases.
cpiinc | Array of benefit increases.
fq | Array of annual average earnings.
fqinc | Array of percentage increases in annual average earnings.
istart | Current year (year after last known benefit increase).
maxyear | Maximum year allowed.
monthBeninc | Array of month of benefit increase.
noChange | Array of indicators for no change allowed.
percOS | Old-start PIB formula percentages.
percSpecMin | Percentage of old-law wage base required for year of coverage.
recalcInd | Indicator for which year(s) the PIA should be recalculated due to a newly effective law change.
specMinMfb | Special minimum mfbs.
specMinMfb2001 | Special minimum mfbs for August-November 2001.
specMinPerc | Percentage of old-law wage base required for year of coverage for special minimum.
specMinPia | Special minimum pias.
specMinPia2001 | Special minimum pias for August-November 2001.
titleAw | Title of average wage assumptions.
titleBi | Title of benefit increase assumptions.
yocAmountSpecMin | Amount required for year of coverage for special minimum.
yocAmountWindfall | Amount required for year of coverage for windfall elimination provision.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
setAltCpiinc | Sets benefit increases when changed from present law.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setFqBppia | Sets series of average wages or other series used for indexing pia formula bend points.
setFqIndex | Calculate series of average wages or other series used for indexing an earnings record.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
YEAR1999 | Year of extra 0.1 percent benefit increase.
age16 | Age 16.
age18 | Age 18.
age19 | Age 19.
age199 | Age 199 (impossible age).
age22 | Age 22.
age50 | Age 50.
age60 | Age 60.
age62 | Age 62.
age621 | Age 62 and 1 month.
age65 | Age 65.
age65_10 | Age 65 and 10 months.
age65_2 | Age 65 and 2 months.
age65_4 | Age 65 and 4 months.
age65_6 | Age 65 and 6 months.
age65_8 | Age 65 and 8 months.
age66 | Age 66.
age66_10 | Age 66 and 10 months.
age66_2 | Age 66 and 2 months.
age66_4 | Age 66 and 4 months.
age66_6 | Age 66 and 6 months.
age66_8 | Age 66 and 8 months.
age67 | Age 67.
age70 | Age 70.
age72 | Age 72.
age75 | Age 75.
amend01 | The date of special 0.1 percent benefit increase.
amend118_273 | The date of WEP no longer being used for benefit computations.
amend50 | The date of 1950 amendments.
amend52 | The date of 1952 amendments.
amend54 | The date of 1954 amendments.
amend56 | The date of 1956 amendments.
amend561 | First birth date for which age 62 is effective for females.
amend562 | Second birth date for which age 62 is effective for females.
amend58 | The date of 1958 amendments.
amend61 | The date of 1961 amendments.
amend611 | First birth date for which age 62 is effective for males.
amend612 | Second birth date for which age 62 is effective for males.
amend651 | The date of 1965 amendments for benefit increase.
amend652 | The date of 1965 amendments for change to age 60.
amend653 | The date of 1965 amendments for old start.
amend671 | The date of 1967 amendments for old start.
amend672 | The date of 1967 amendments for benefit increase.
amend69 | The date of 1969 amendments.
amend70 | The date of 1970 amendments.
amend721 | The date of 1972 amendments for benefit increase.
amend722 | The date of 1972 amendments for special minimum.
amend741 | The date of 1974 amendments for partial increase.
amend742 | The date of 1974 amendments for full increase.
amend771 | The date of 1977 amendments for frozen pia table.
amend772 | The date of 1977 amendments for start of wage indexing.
amend80 | The date of 1980 amendments.
amend811 | The date of birth for age 62 and 1 month in 1981 amendments.
amend812 | The date of 1981 amendments (month, day, and year).
amend813 | The date of 1981 amendments (month and year).
amend82 | The date of 1982 amendments.
amend83 | The date of 1983 amendments.
amend88 | The date of 1988 amendments.
amend90 | The date of 1990 amendments.
amtperincyr | Amount per old start increment year.
arFactorWid285 | Total actuarial reduction factor for aged widow(er)s.
arMonthlyFactor65_67 | Monthly actuarial reduction factor between ages 65 and 67.
arMonthlyFactorOab62_65 | Monthly actuarial reduction factor between ages 62 and 65.
arMonthlyFactorSpouse62_65 | Monthly actuarial reduction factor for aged spouses between ages 62 and 65.
beninc74 | Temporary benefit increase, March-May 1974.
bpMfbOut | Table of mfb formula bend points.
bpPiaOut | Table of pia formula bend points.
factor150 | Factor for calculating mfbs.
factor175 | Factor for calculating mfbs.
factor50 | Factor for calculating life benefits.
factor75 | Factor for calculating survivor benefits.
factor825 | Factor for calculating widow(er) benefits.
maxMonthsAr62_65 | Maximum number of months of actuarial reduction between ages 62 and 65.
maxMonthsAr62_67 | Maximum number of months of actuarial reduction between ages 62 and 67.
maxMonthsAr65_67 | Maximum number of months of actuarial reduction between ages 65 and 67.
percPiaOut | Table of pia formula percentages.
qcamt | Array of amounts required for quarter of coverage.
qtr184 | Starting point of deemed insured.
year37qtr1 | First quarter for which a quarter of coverage could be earned.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PiaParams | Initializes a PiaParams, with or without a first year of projection.
PiaParamsAny | Initializes arrays.
PiaParamsLC | Initializes a PiaParamsLC, with or without a first year of projection.
applyCola | Returns benefit amount increased by cola.
applyCola | Returns benefit amount increased by cola.
applyCola99 | Returns benefit amount increased by special 1999 cola (includes extra 0.1 percent increase).
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb99 | Returns maximum family benefit amount increased by special 1999 cola (includes extra 0.1 percent increase), with check that result is at least 150 percent of pia.
benincCatchUp | Applies catch-up benefit increases.
birthDateFRA | Returns the earliest birthdate for someone to be over NRA at the end of a year.
childAgeForMFCal | Returns oldest age of child for which parent can get young wife/husband or mother/father benefits.
deconvertPia | Deconverts PIA back to year of eligibility.
deemedQcReqCal | Returns number of quarters of coverage required for deemed insured status.
doRecalc | Returns true if should recalculate PIAs this year because of a newly effective law change, else false.
earlyAgeDisWidCal | Returns earliest possible disabled widow(er)'s retirement age.
earlyAgeOabCal | Returns earliest possible retirement age for oab or aged spouse.
earlyAgeOabCal | Returns earliest possible retirement age for old-age benie or aged spouse.
earlyAgeOabCalPL | Returns earliest possible retirement age for old-age benie or aged spouse, based on present law.
earlyAgeWidCal | Returns earliest possible aged widow(er)'s retirement age.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCalPL | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow(er) benefit before age reduction.
factorAgedWidCal | Returns factor for widow/widower benefit before age reduction.
factorAgedWidCalPL | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Returns reduction factor for wife/husband.
factorArAgedSpouseCal | Calculates reduction factor for wife/husband.
factorArAgedSpouseCalPL | Calculates reduction factor for wife/husband. Assumes a maximum of 60 months of reduction.
factorArCal | Returns reduction factor for OAB.
factorArCal | Calculates reduction factor for OAB.
factorArCalPL | Calculates reduction factor for OAB or DIB.
factorArDisWidCal | Calculates reduction factor for disabled widow(er).
factorArWidCal | Calculates reduction factor for aged widow(er).
factorDisWidCal | Returns factor for disabled widow(er) benefit before age reduction.
factorDisWidCal | Returns factor for disabled widow/widower benefit before age reduction.
factorDisWidCalPL | Returns factor for disabled widow/widower benefit before age reduction.
factorDriCal | Calculates delayed retirement increment factor for OAB.
factorYngLifeCal | Calculates reduction factor for young life benie.
factorYngSurvCal | Calculates reduction factor for young survivor.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDIPL | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalPL | Returns full retirement age based on present law.
getAverageWage | Returns title of average wage assumptions.
getBase77 | Returns one old-law wage base.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBase77Array | Returns the array of old-law wage bases.
getBaseHi | Returns one HI wage base.
getBaseHiArray | Returns the array of HI wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBendOS | Returns a bend point for old-start PIB formula.
getBenefitInc | Returns title of benefit increase assumptions.
getCatchup | Returns catch-up benefit increases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmountPL | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getCpiinc | Returns one benefit increase.
getCpiinc | Returns one benefit increase.
getCpiincArray | Returns the array of benefit increases.
getCpiincArray | Returns the benefit increases.
getFq | Returns one average wage for indexing.
getFqArray | Returns array of average wages for indexing.
getFqBppia | Returns series used for indexing pia formula bend points.
getFqBppia | Returns series of average wages or other series used for indexing pia formula bend points.
getFqIndex | Returns series used for indexing an earnings record.
getFqIndex | Returns series of average wages or other series used for indexing an earnings record.
getFqinc | Returns one increase in average wage for indexing.
getFqincArray | Returns array of increases in average wage for indexing.
getIstart | Returns current year.
getMarrLengthForDivBen | Returns the number of years of marraige needed to be eligible for a divroced spouse benefit.
getMarrLengthForDivBen | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMarrLengthForDivBenPL | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year or childcare credit.
getMaxChildcareAgePL | Returns maximum age of child for childcare dropout year.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYearsPL | Returns maximum number of childcare dropout years.
getMaxyear | Returns maximum possible year.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB for the given year.
getMonthBeninc | Returns one month of benefit increase.
getMonthBenincArray | Returns array of months of benefit increase.
getPercOS | Returns old-start PIB formula percentage.
getPercSpecMin | Returns percent of old-law base required for year of coverage.
getPercSpecMinArray | Returns array of percents of old-law base required for year of coverage.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinPerc | Returns percentage of old-law base required for year of coverage.
getSpecMinPia | Returns special minimum pia as of a specified month.
getSpecMinPia | Returns special minimum pia as of a specified month.
getWageHigh | Returns high earnings for one year.
getWageHighArray | Returns array of high earnings.
getWageMin | Returns low earnings for one year.
getWageMinArray | Returns array of low earnings.
getYocAmountSpecMin | Returns amount required for year of coverage for special minimum.
getYocAmountSpecMinArray | Returns array of amounts required for year of coverage for special minimum.
getYocAmountWindfallArray | Returns array of amounts required for year of coverage for windfall elimination.
highProj | Projects high earnings.
initdata | Initializes some data.
initdata | Initializes some data.
isApplicableCola99 | Checks for applicability of special 1999 increase (with extra 0.1 percent).
lastAmw | Finds last AMW in old-law table.
lumpSum | Returns amount of lump sum benefit.
maxChildAge | Returns maximum child beneficiary age.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAgePL | Returns maximum DI beneficiary age at end of year, based on present law.
minProj | Projects low earnings.
monthsArAgedSpouseCal | Calculates number of months of actuarial reduction for aged wife/husband.
monthsArCal | Calculates number of months of actuarial reduction for OAB.
monthsArDICal | Calculates number of months of reduction for disabled worker.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er).
monthsArWidCal | Calculates number of months of actuarial reduction for aged widow(er).
monthsDriCal | Calculates number of months of delayed retirement credit for OAB.
needColaCap | Returns true if a cola cap is required.
needColaCap | Returns true if a cola cap is required.
percPiaCal | Sets benefit formula percents.
projectCpiinc | Projects amounts dependent on benefit increases.
projectCpiinc | Projects amounts dependent on benefit increases.
projectFq | Projects average annual wage and amounts dependent on it.
projectPerc | Projects benefit formula percentages.
projectPerc | Projects benefit formula percentages.
projectSpecMin | Projects special minimum amounts.
projectSpecMin | Projects special minimum amounts.
qcCal | Returns number of quarters of coverage for one year, applying annual test.
resizeSpecMin | Resizes special minimum arrays.
resizeSpecMin | Resizes special minimum arrays.
retCredit | Returns amount of monthly delayed retirement credit.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCalPL | Returns widow(er) benefit reduced for RIB-LIM.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setData | Sets data from historical average wages and benefit increase file.
setData | Sets data from historical average wages and benefit increase file.
setHistFqinc | Sets historical average wage increases.
setIstart | Sets the first projected year, including for members.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
setNoChange | Sets indicators for no change allowed.
specMinAmountCal | Sets amount per year of coverage in special minimum.
specMinAmountCal | Returns amount per year of coverage in special minimum.
specMinAmountCalPL | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYearsPL | Returns maximum number of usable years for special minimum.
unApplyCola | Returns benefit amount decreased by cola.
unApplyCola99 | Returns benefit amount decreased by special 1999 cola (includes extra 0.1 percent decrease.)
unbiCatchUp | Divides out catch-up benefit increases.
updateBases | Updates wage bases.
updateBases | Updates wage bases.
updateCpiinc | Updates benefit increases.
updateFq | Updates average wages, using specified amounts.
updateFqinc | Updates increases in average wages, using specified percentages.
updateYocAmountSpecMin | Updates amounts required for special minimum year of coverage.
~PiaParamsAny | Destroys arrays.
Collapse Expand Links
Enumerations, PiaParamsAny Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


PiaParamsAny::PiaParamsAny Constructor

PiaParamsAny::PiaParamsAny Constructor
PiaParamsAny Class PiaParamsAny Members PiaParamsAny Class

Initializes arrays.

C++
PiaParamsAny(
    int newIstart,
    int newMaxyear,
    AwbiData& awbiData,
    const LawChangeArray& newLawChange
);
Collapse Expand Parameters
Parameters | Description
int newIstart | Year after last known benefit increase.
int newMaxyear | Maximum projected year.
AwbiData& awbiData | Structure with historical amounts.
const LawChangeArray& newLawChange | Law change parameters.
Collapse Expand Class

PiaParamsAny Class

Collapse Expand Links
PiaParamsAny Class, PiaParamsAny Members, PiaParamsAny Class


PiaParamsAny::~PiaParamsAny Destructor

PiaParamsAny::~PiaParamsAny Destructor
PiaParamsAny Class PiaParamsAny Members PiaParamsAny Class

Destroys arrays.

C++
virtual ~PiaParamsAny();
Collapse Expand Class

PiaParamsAny Class

Collapse Expand Links
PiaParamsAny Class, PiaParamsAny Members, PiaParamsAny Class


PiaParamsAny Methods

PiaParamsAny Methods
PiaParamsAny Class Legend Public Methods

The methods of the PiaParamsAny class are listed here.

Collapse Expand Class

PiaParamsAny Class

Collapse Expand Public Methods
Name | Description
getWageHigh | Returns high earnings for one year.
getWageHighArray | Returns array of high earnings.
getWageMin | Returns low earnings for one year.
getWageMinArray | Returns array of low earnings.
highProj | Projects high earnings.
minProj | Projects low earnings.
projectFq | Projects average annual wage and amounts dependent on it.
Collapse Expand Links
PiaParamsAny Class, Legend, Public Methods


PiaParamsAny::getWageHigh Method

PiaParamsAny::getWageHigh Method
PiaParamsAny Class PiaParamsAny Members PiaParamsAny Methods

Returns high earnings for one year.

C++
double getWageHigh(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which high earnings are desired.
Collapse Expand Returns

High earnings for specified year.

Collapse Expand Group

PiaParamsAny Methods

Collapse Expand Links
PiaParamsAny Class, PiaParamsAny Members, PiaParamsAny Methods


PiaParamsAny::getWageHighArray Method

PiaParamsAny::getWageHighArray Method
PiaParamsAny Class PiaParamsAny Members PiaParamsAny Methods

Returns array of high earnings.

C++
const DoubleAnnual& getWageHighArray() const;
Collapse Expand Returns

Array of high earnings.

Collapse Expand Group

PiaParamsAny Methods

Collapse Expand Links
PiaParamsAny Class, PiaParamsAny Members, PiaParamsAny Methods


PiaParamsAny::getWageMin Method

PiaParamsAny::getWageMin Method
PiaParamsAny Class PiaParamsAny Members PiaParamsAny Methods

Returns low earnings for one year.

C++
double getWageMin(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which low earnings are desired.
Collapse Expand Returns

Low earnings for specified year.

Collapse Expand Group

PiaParamsAny Methods

Collapse Expand Links
PiaParamsAny Class, PiaParamsAny Members, PiaParamsAny Methods


PiaParamsAny::getWageMinArray Method

PiaParamsAny::getWageMinArray Method
PiaParamsAny Class PiaParamsAny Members PiaParamsAny Methods

Returns array of low earnings.

C++
const DoubleAnnual& getWageMinArray() const;
Collapse Expand Returns

Array of low earnings.

Collapse Expand Group

PiaParamsAny Methods

Collapse Expand Links
PiaParamsAny Class, PiaParamsAny Members, PiaParamsAny Methods


PiaParamsAny::highProj Method

PiaParamsAny::highProj Method
PiaParamsAny Class PiaParamsAny Members PiaParamsAny Methods

Projects high earnings.

C++
void highProj();
Collapse Expand Group

PiaParamsAny Methods

Collapse Expand Links
PiaParamsAny Class, PiaParamsAny Members, PiaParamsAny Methods


PiaParamsAny::minProj Method

PiaParamsAny::minProj Method
PiaParamsAny Class PiaParamsAny Members PiaParamsAny Methods

Projects low earnings.

C++
void minProj();
Collapse Expand Group

PiaParamsAny Methods

Collapse Expand Links
PiaParamsAny Class, PiaParamsAny Members, PiaParamsAny Methods


PiaParamsAny::projectFq Method

PiaParamsAny::projectFq Method
PiaParamsAny Class PiaParamsAny Members PiaParamsAny Methods

Projects average annual wage and amounts dependent on it.

C++
void projectFq();
Collapse Expand Group

PiaParamsAny Methods

Collapse Expand Links
PiaParamsAny Class, PiaParamsAny Members, PiaParamsAny Methods


PiaParamsLC Class

PiaParamsLC Class
PiaParamsLC Constructor PiaParamsLC Methods PiaParamsLC Members piaparmsLC.h Classes

Manages the changed law Social Security parameters required to calculate Social Security benefits.

Collapse Expand Class Hierarchy
  PiaParamsLCPiaParamsLC
C++
class PiaParamsLC : public PiaParams;
Collapse Expand File

File: piaparmsLC.h

Module: PiaData Library

Collapse Expand Remarks

Manages the changed law Social Security parameters required to calculate Social Security benefits.

Collapse Expand Group

Classes

Collapse Expand Links
PiaParamsLC Constructor, PiaParamsLC Methods, PiaParamsLC Members, piaparmsLC.h, Classes


PiaParamsLC Members

PiaParamsLC Members
Enumerations PiaParamsLC Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by PiaParamsLC.

Collapse Expand Enumerations
Name | Description
SPECMINPERCTYPE | The year range for the special minimum percentage.
Collapse Expand Class

PiaParamsLC Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
baseHi | HI wage bases.
bendOS | Bend points for old-start PIB formula.
catchup | Catch-up benefit increases.
cpiinc | Array of benefit increases.
fq | Array of annual average earnings.
fqinc | Array of percentage increases in annual average earnings.
istart | Current year (year after last known benefit increase).
maxyear | Maximum year allowed.
monthBeninc | Array of month of benefit increase.
noChange | Array of indicators for no change allowed.
percOS | Old-start PIB formula percentages.
percSpecMin | Percentage of old-law wage base required for year of coverage.
recalcInd | Indicator for which year(s) the PIA should be recalculated due to a newly effective law change.
specMinMfb | Special minimum mfbs.
specMinMfb2001 | Special minimum mfbs for August-November 2001.
specMinPerc | Percentage of old-law wage base required for year of coverage for special minimum.
specMinPia | Special minimum pias.
specMinPia2001 | Special minimum pias for August-November 2001.
titleAw | Title of average wage assumptions.
titleBi | Title of benefit increase assumptions.
yocAmountSpecMin | Amount required for year of coverage for special minimum.
yocAmountWindfall | Amount required for year of coverage for windfall elimination provision.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
setAltCpiinc | Sets benefit increases when changed from present law.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setFqBppia | Sets series of average wages or other series used for indexing pia formula bend points.
setFqIndex | Calculate series of average wages or other series used for indexing an earnings record.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
YEAR1999 | Year of extra 0.1 percent benefit increase.
age16 | Age 16.
age18 | Age 18.
age19 | Age 19.
age199 | Age 199 (impossible age).
age22 | Age 22.
age50 | Age 50.
age60 | Age 60.
age62 | Age 62.
age621 | Age 62 and 1 month.
age65 | Age 65.
age65_10 | Age 65 and 10 months.
age65_2 | Age 65 and 2 months.
age65_4 | Age 65 and 4 months.
age65_6 | Age 65 and 6 months.
age65_8 | Age 65 and 8 months.
age66 | Age 66.
age66_10 | Age 66 and 10 months.
age66_2 | Age 66 and 2 months.
age66_4 | Age 66 and 4 months.
age66_6 | Age 66 and 6 months.
age66_8 | Age 66 and 8 months.
age67 | Age 67.
age70 | Age 70.
age72 | Age 72.
age75 | Age 75.
amend01 | The date of special 0.1 percent benefit increase.
amend118_273 | The date of WEP no longer being used for benefit computations.
amend50 | The date of 1950 amendments.
amend52 | The date of 1952 amendments.
amend54 | The date of 1954 amendments.
amend56 | The date of 1956 amendments.
amend561 | First birth date for which age 62 is effective for females.
amend562 | Second birth date for which age 62 is effective for females.
amend58 | The date of 1958 amendments.
amend61 | The date of 1961 amendments.
amend611 | First birth date for which age 62 is effective for males.
amend612 | Second birth date for which age 62 is effective for males.
amend651 | The date of 1965 amendments for benefit increase.
amend652 | The date of 1965 amendments for change to age 60.
amend653 | The date of 1965 amendments for old start.
amend671 | The date of 1967 amendments for old start.
amend672 | The date of 1967 amendments for benefit increase.
amend69 | The date of 1969 amendments.
amend70 | The date of 1970 amendments.
amend721 | The date of 1972 amendments for benefit increase.
amend722 | The date of 1972 amendments for special minimum.
amend741 | The date of 1974 amendments for partial increase.
amend742 | The date of 1974 amendments for full increase.
amend771 | The date of 1977 amendments for frozen pia table.
amend772 | The date of 1977 amendments for start of wage indexing.
amend80 | The date of 1980 amendments.
amend811 | The date of birth for age 62 and 1 month in 1981 amendments.
amend812 | The date of 1981 amendments (month, day, and year).
amend813 | The date of 1981 amendments (month and year).
amend82 | The date of 1982 amendments.
amend83 | The date of 1983 amendments.
amend88 | The date of 1988 amendments.
amend90 | The date of 1990 amendments.
amtperincyr | Amount per old start increment year.
arFactorWid285 | Total actuarial reduction factor for aged widow(er)s.
arMonthlyFactor65_67 | Monthly actuarial reduction factor between ages 65 and 67.
arMonthlyFactorOab62_65 | Monthly actuarial reduction factor between ages 62 and 65.
arMonthlyFactorSpouse62_65 | Monthly actuarial reduction factor for aged spouses between ages 62 and 65.
beninc74 | Temporary benefit increase, March-May 1974.
bpMfbOut | Table of mfb formula bend points.
bpPiaOut | Table of pia formula bend points.
factor150 | Factor for calculating mfbs.
factor175 | Factor for calculating mfbs.
factor50 | Factor for calculating life benefits.
factor75 | Factor for calculating survivor benefits.
factor825 | Factor for calculating widow(er) benefits.
maxMonthsAr62_65 | Maximum number of months of actuarial reduction between ages 62 and 65.
maxMonthsAr62_67 | Maximum number of months of actuarial reduction between ages 62 and 67.
maxMonthsAr65_67 | Maximum number of months of actuarial reduction between ages 65 and 67.
percPiaOut | Table of pia formula percentages.
qcamt | Array of amounts required for quarter of coverage.
qtr184 | Starting point of deemed insured.
year37qtr1 | First quarter for which a quarter of coverage could be earned.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PiaParams | Initializes a PiaParams, with or without a first year of projection.
PiaParamsLC | Initializes a PiaParamsLC, with or without a first year of projection.
applyCola | Returns benefit amount increased by cola.
applyCola | Returns benefit amount increased by cola.
applyCola99 | Returns benefit amount increased by special 1999 cola (includes extra 0.1 percent increase).
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb99 | Returns maximum family benefit amount increased by special 1999 cola (includes extra 0.1 percent increase), with check that result is at least 150 percent of pia.
benincCatchUp | Applies catch-up benefit increases.
birthDateFRA | Returns the earliest birthdate for someone to be over NRA at the end of a year.
childAgeForMFCal | Returns oldest age of child for which parent can get young wife/husband or mother/father benefits.
deconvertPia | Deconverts PIA back to year of eligibility.
deemedQcReqCal | Returns number of quarters of coverage required for deemed insured status.
doRecalc | Returns true if should recalculate PIAs this year because of a newly effective law change, else false.
earlyAgeDisWidCal | Returns earliest possible disabled widow(er)'s retirement age.
earlyAgeOabCal | Returns earliest possible retirement age for old-age benie or aged spouse.
earlyAgeOabCalPL | Returns earliest possible retirement age for old-age benie or aged spouse, based on present law.
earlyAgeWidCal | Returns earliest possible aged widow(er)'s retirement age.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCalPL | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow/widower benefit before age reduction.
factorAgedWidCalPL | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Calculates reduction factor for wife/husband.
factorArAgedSpouseCalPL | Calculates reduction factor for wife/husband. Assumes a maximum of 60 months of reduction.
factorArCal | Calculates reduction factor for OAB.
factorArCalPL | Calculates reduction factor for OAB or DIB.
factorArDisWidCal | Calculates reduction factor for disabled widow(er).
factorArWidCal | Calculates reduction factor for aged widow(er).
factorDisWidCal | Returns factor for disabled widow/widower benefit before age reduction.
factorDisWidCalPL | Returns factor for disabled widow/widower benefit before age reduction.
factorDriCal | Calculates delayed retirement increment factor for OAB.
factorYngLifeCal | Calculates reduction factor for young life benie.
factorYngSurvCal | Calculates reduction factor for young survivor.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDIPL | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalPL | Returns full retirement age based on present law.
getAverageWage | Returns title of average wage assumptions.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBaseHi | Returns one HI wage base.
getBaseHiArray | Returns the array of HI wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBendOS | Returns a bend point for old-start PIB formula.
getBenefitInc | Returns title of benefit increase assumptions.
getCatchup | Returns catch-up benefit increases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmountPL | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getCpiinc | Returns one benefit increase.
getCpiincArray | Returns the benefit increases.
getFq | Returns one average wage for indexing.
getFqArray | Returns array of average wages for indexing.
getFqBppia | Returns series of average wages or other series used for indexing pia formula bend points.
getFqIndex | Returns series of average wages or other series used for indexing an earnings record.
getFqinc | Returns one increase in average wage for indexing.
getFqincArray | Returns array of increases in average wage for indexing.
getIstart | Returns current year.
getMarrLengthForDivBen | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMarrLengthForDivBenPL | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year or childcare credit.
getMaxChildcareAgePL | Returns maximum age of child for childcare dropout year.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYearsPL | Returns maximum number of childcare dropout years.
getMaxyear | Returns maximum possible year.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB for the given year.
getMonthBeninc | Returns one month of benefit increase.
getMonthBenincArray | Returns array of months of benefit increase.
getPercOS | Returns old-start PIB formula percentage.
getPercSpecMin | Returns percent of old-law base required for year of coverage.
getPercSpecMinArray | Returns array of percents of old-law base required for year of coverage.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinPerc | Returns percentage of old-law base required for year of coverage.
getSpecMinPia | Returns special minimum pia as of a specified month.
getYocAmountSpecMin | Returns amount required for year of coverage for special minimum.
getYocAmountSpecMinArray | Returns array of amounts required for year of coverage for special minimum.
getYocAmountWindfallArray | Returns array of amounts required for year of coverage for windfall elimination.
initdata | Initializes some data.
isApplicableCola99 | Checks for applicability of special 1999 increase (with extra 0.1 percent).
lastAmw | Finds last AMW in old-law table.
lumpSum | Returns amount of lump sum benefit.
maxChildAge | Returns maximum child beneficiary age.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAgePL | Returns maximum DI beneficiary age at end of year, based on present law.
monthsArAgedSpouseCal | Calculates number of months of actuarial reduction for aged wife/husband.
monthsArCal | Calculates number of months of actuarial reduction for OAB.
monthsArDICal | Calculates number of months of reduction for disabled worker.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er).
monthsArWidCal | Calculates number of months of actuarial reduction for aged widow(er).
monthsDriCal | Calculates number of months of delayed retirement credit for OAB.
needColaCap | Returns true if a cola cap is required.
needColaCap | Returns true if a cola cap is required.
percPiaCal | Sets benefit formula percents.
projectCpiinc | Projects amounts dependent on benefit increases.
projectFq | Projects average annual wage and amounts dependent on it.
projectPerc | Projects benefit formula percentages.
projectSpecMin | Projects special minimum amounts.
qcCal | Returns number of quarters of coverage for one year, applying annual test.
resizeSpecMin | Resizes special minimum arrays.
retCredit | Returns amount of monthly delayed retirement credit.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCalPL | Returns widow(er) benefit reduced for RIB-LIM.
setData | Sets data from historical average wages and benefit increase file.
setHistFqinc | Sets historical average wage increases.
setIstart | Sets the first projected year, including for members.
setNoChange | Sets indicators for no change allowed.
specMinAmountCal | Returns amount per year of coverage in special minimum.
specMinAmountCalPL | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYearsPL | Returns maximum number of usable years for special minimum.
unApplyCola | Returns benefit amount decreased by cola.
unApplyCola99 | Returns benefit amount decreased by special 1999 cola (includes extra 0.1 percent decrease.)
unbiCatchUp | Divides out catch-up benefit increases.
updateBases | Updates wage bases.
updateBases | Updates wage bases.
updateCpiinc | Updates benefit increases.
updateFq | Updates average wages, using specified amounts.
updateFqinc | Updates increases in average wages, using specified percentages.
updateYocAmountSpecMin | Updates amounts required for special minimum year of coverage.
~PiaParamsLC | Destroys arrays.
Collapse Expand Links
Enumerations, PiaParamsLC Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


PiaParamsLC Constructor

PiaParamsLC Constructor
PiaParamsLC Class

Initializes a PiaParamsLC, with or without a first year of projection.

Collapse Expand Description

There are two versions of the PiaParamsLC constructor. If the first year of projection is not provided, it is set to BaseYearNonFile::YEAR.

Collapse Expand Overload List
Name | Description
PiaParamsLC::PiaParamsLC (int, const LawChangeArray&) | Initializes arrays without a specified starting year.
PiaParamsLC::PiaParamsLC (int, int, AwbiData&, const LawChangeArray&) | Initializes arrays with a specified starting year.
Collapse Expand Class

PiaParamsLC Class

Collapse Expand Links
PiaParamsLC Class


PiaParamsLC::PiaParamsLC Constructor (int, const LawChangeArray&)

PiaParamsLC::PiaParamsLC Constructor (int, const LawChangeArray&)
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Constructor

Initializes arrays without a specified starting year.

C++
PiaParamsLC(
    int newMaxyear,
    const LawChangeArray& newLawChange
);
Collapse Expand Parameters
Parameters | Description
int newMaxyear | Maximum projected year.
const LawChangeArray& newLawChange | Law change parameters.
Collapse Expand Remarks

This version without a specified starting year uses BaseYearNonFile::YEAR, and constructs an AwbiDataNonFile using that year.

Collapse Expand Group

PiaParamsLC Constructor

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Constructor


PiaParamsLC::PiaParamsLC Constructor (int, int, AwbiData&, const LawChangeArray&)

PiaParamsLC::PiaParamsLC Constructor (int, int, AwbiData&, const LawChangeArray&)
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Constructor

Initializes arrays with a specified starting year.

C++
PiaParamsLC(
    int newIstart,
    int newMaxyear,
    AwbiData& awbiData,
    const LawChangeArray& newLawChange
);
Collapse Expand Parameters
Parameters | Description
int newIstart | Year after last known benefit increase.
int newMaxyear | Maximum projected year.
AwbiData& awbiData | Structure with historical amounts.
const LawChangeArray& newLawChange | Law change parameters.
Collapse Expand Group

PiaParamsLC Constructor

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Constructor


PiaParamsLC::~PiaParamsLC Destructor

PiaParamsLC::~PiaParamsLC Destructor
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Class

Destroys arrays.

C++
virtual ~PiaParamsLC();
Collapse Expand Class

PiaParamsLC Class

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Class


PiaParamsLC Methods

PiaParamsLC Methods
PiaParamsLC Class Legend Protected Methods Public Methods

The methods of the PiaParamsLC class are listed here.

Collapse Expand Class

PiaParamsLC Class

Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
setAltCpiinc | Sets benefit increases when changed from present law.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setFqBppia | Sets series of average wages or other series used for indexing pia formula bend points.
setFqIndex | Calculate series of average wages or other series used for indexing an earnings record.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
Collapse Expand Public Methods
Name | Description
applyCola | Returns benefit amount increased by cola.
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
earlyAgeOabCal | Returns earliest possible retirement age for old-age benie or aged spouse.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Calculates reduction factor for wife/husband.
factorArCal | Calculates reduction factor for OAB.
factorDisWidCal | Returns factor for disabled widow/widower benefit before age reduction.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getCpiinc | Returns one benefit increase.
getCpiincArray | Returns the benefit increases.
getFqBppia | Returns series of average wages or other series used for indexing pia formula bend points.
getFqIndex | Returns series of average wages or other series used for indexing an earnings record.
getMarrLengthForDivBen | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year or childcare credit.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB for the given year.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinPia | Returns special minimum pia as of a specified month.
initdata | Initializes some data.
maxDibAge | Returns maximum DI beneficiary age at end of year.
needColaCap | Returns true if a cola cap is required.
projectCpiinc | Projects amounts dependent on benefit increases.
projectFq | Projects average annual wage and amounts dependent on it.
projectPerc | Projects benefit formula percentages.
projectSpecMin | Projects special minimum amounts.
resizeSpecMin | Resizes special minimum arrays.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
setData | Sets data from historical average wages and benefit increase file.
specMinAmountCal | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
updateBases | Updates wage bases.
Collapse Expand Links
PiaParamsLC Class, Legend, Protected Methods, Public Methods


applyCola Method

applyCola Method
PiaParamsLC Methods

Returns benefit amount increased by cola.

Collapse Expand Description

There are two versions of the applyCola function. The one with a year of eligibility argument considers catch-up benefit increases; the other does not.

Collapse Expand Overload List
Name | Description
PiaParamsLC::applyCola (double, int) | Returns benefit amount increased by cola.
PiaParamsLC::applyCola (double, int, int) | Returns benefit amount increased by cola.
Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Methods


PiaParamsLC::applyCola Method (double, int)

PiaParamsLC::applyCola Method (double, int)
PiaParamsLC Class PiaParamsLC Members applyCola Method

Returns benefit amount increased by cola.

C++
double applyCola(
    double pia,
    int year
) const;
Collapse Expand Parameters
Parameters | Description
double pia | Amount to be increased.
int year | Year of increase.
Collapse Expand Returns

Benefit amount increased by cola, without considering any catch-up benefit increases.

Collapse Expand Remarks

This version does not consider any catch-up benefit increases.

Collapse Expand Group

applyCola Method

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, applyCola Method


PiaParamsLC::applyCola Method (double, int, int)

PiaParamsLC::applyCola Method (double, int, int)
PiaParamsLC Class PiaParamsLC Members applyCola Method

Returns benefit amount increased by cola.

C++
double applyCola(
    double pia,
    int year,
    int eligYear
) const;
Collapse Expand Parameters
Parameters | Description
double pia | Amount to be increased.
int year | Year of increase.
int eligYear | Year of eligibility for catch-up benefit increases.
Collapse Expand Returns

Benefit amount increased by cola, considering any catch-up benefit increases.

Collapse Expand Remarks

This version considers any catch-up benefit increases.

Collapse Expand Group

applyCola Method

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, applyCola Method


applyColaMfb Method

applyColaMfb Method
PiaParamsLC Methods

Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.

Collapse Expand Description

There are two versions of the applyColaMfb function. The one with a year of eligibility argument considers catch-up benefit increases; the other does not.

Collapse Expand Overload List
Name | Description
PiaParamsLC::applyColaMfb (double, int, double) | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
PiaParamsLC::applyColaMfb (double, int, int, double) | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Methods


PiaParamsLC::applyColaMfb Method (double, int, double)

PiaParamsLC::applyColaMfb Method (double, int, double)
PiaParamsLC Class PiaParamsLC Members applyColaMfb Method

Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.

C++
double applyColaMfb(
    double mfb,
    int year,
    double pia
) const;
Collapse Expand Parameters
Parameters | Description
double mfb | Amount to be increased.
int year | Year of increase.
double pia | Pia to check against.
Collapse Expand Returns

Increased maximum family benefit amount.

Collapse Expand Remarks

This version does not consider any catch-up benefit increases.

Collapse Expand Group

applyColaMfb Method

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, applyColaMfb Method


PiaParamsLC::applyColaMfb Method (double, int, int, double)

PiaParamsLC::applyColaMfb Method (double, int, int, double)
PiaParamsLC Class PiaParamsLC Members applyColaMfb Method

Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.

C++
double applyColaMfb(
    double mfb,
    int year,
    int eligYear,
    double pia
) const;
Collapse Expand Parameters
Parameters | Description
double mfb | Amount to be increased.
int year | Year of increase.
int eligYear | Year of eligibility for catch-up benefit increases.
double pia | Pia to check against.
Collapse Expand Returns

Increased maximum family benefit amount.

Collapse Expand Remarks

This version considers any catch-up benefit increases.

Collapse Expand Group

applyColaMfb Method

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, applyColaMfb Method


PiaParamsLC::earlyAgeOabCal Method

PiaParamsLC::earlyAgeOabCal Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns earliest possible retirement age for old-age benie or aged spouse.

C++
Age earlyAgeOabCal(
    Sex::sex_type sex,
    const boost::gregorian::date& kbirth
) const;
Collapse Expand Parameters
Parameters | Description
Sex::sex_type sex | The sex of number holder.
const boost::gregorian::date& kbirth | The date of birth, adjusted to previous day.
Collapse Expand Returns

Earliest possible retirement age for old-age benie or aged spouse, based on changed law.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::factorAgedSpouseCal Method

PiaParamsLC::factorAgedSpouseCal Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns factor for wife/husband benefit before age reduction.

C++
double factorAgedSpouseCal(
    int eligYear,
    int benYear
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Spouse's year of eligibility.
int benYear | Year of benefit.
Collapse Expand Returns

Factor for wife/husband benefit before age reduction.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::factorAgedWidCal Method

PiaParamsLC::factorAgedWidCal Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns factor for widow/widower benefit before age reduction.

C++
double factorAgedWidCal(
    int monthsArdri,
    const Age& age,
    int eligYear,
    const DateMoyr& benefitDate
) const;
Collapse Expand Parameters
Parameters | Description
int monthsArdri | Months of reduction.
const Age& age | The age of widow/widower.
int eligYear | Year of eligibility.
const DateMoyr& benefitDate | The date of benefit.
Collapse Expand Returns

Factor for widow/widower benefit before age reduction. This could be an increased factor (up to 112.5 percent), if LawChange::lawChangeType::WIDFACTOR is effective.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::factorArAgedSpouseCal Method

PiaParamsLC::factorArAgedSpouseCal Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Calculates reduction factor for wife/husband.

C++
double factorArAgedSpouseCal(
    int monthsArdri
) const;
Collapse Expand Parameters
Parameters | Description
int monthsArdri | Number of months of reduction.
Collapse Expand Returns

Reduction factor for wife/husband, based on changed law.

Collapse Expand Remarks

If there are fewer months of reduction than are already accounted for under present law, or if there is no change in full retirement age, then it simply returns PiaParams::factorArAgedSpouseCalPL.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::factorArCal Method

PiaParamsLC::factorArCal Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Calculates reduction factor for OAB.

C++
double factorArCal(
    int monthsArdri
) const;
Collapse Expand Parameters
Parameters | Description
int monthsArdri | Number of months of reduction.
Collapse Expand Returns

Reduction factor for OAB.

Collapse Expand Remarks

If there are fewer months of reduction than are already accounted for under present law, or if there is no change in full retirement age, then it simply returns PiaParams::factorArCalPL.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::factorDisWidCal Method

PiaParamsLC::factorDisWidCal Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns factor for disabled widow/widower benefit before age reduction.

C++
double factorDisWidCal(
    int eligYear,
    const DateMoyr& benefitDate
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
const DateMoyr& benefitDate | The date of benefit.
Collapse Expand Returns

Factor for disabled widow/widower benefit before age reduction.

Collapse Expand Remarks

Returns PiaParams::factorDisWidCalPL. There are no law changes built in for disabled widow/widower benefits yet, so the year of eligibility is currently unused.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::fullRetAgeCal Method

PiaParamsLC::fullRetAgeCal Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns full retirement age.

C++
Age fullRetAgeCal(
    int eligYear
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility (age 62 for oab or wife/husband, 60 for widow(er)).
Collapse Expand Returns

Full retirement age.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::fullRetAgeCalDI Method

PiaParamsLC::fullRetAgeCalDI Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns full retirement age for benefit calculations involving disability freeze.

C++
Age fullRetAgeCalDI(
    int eligYear,
    int currentYear
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility (age 62 for oab or wife/husband, 60 for widow(er)).
int currentYear | Current year.
Collapse Expand Returns

Full retirement age for benefit calculations involving disability freeze.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::getBase77 Method

PiaParamsLC::getBase77 Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns one old-law wage base.

C++
double getBase77(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which base is desired.
Collapse Expand Returns

One old-law wage base.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::getBase77Array Method

PiaParamsLC::getBase77Array Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns the array of old-law wage bases.

C++
const WageBaseOldLaw& getBase77Array() const;
Collapse Expand Returns

The array of old-law wage bases.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::getBaseOasdi Method

PiaParamsLC::getBaseOasdi Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns one OASDI wage base.

C++
double getBaseOasdi(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which base is desired.
Collapse Expand Returns

One OASDI wage base.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::getBaseOasdiArray Method

PiaParamsLC::getBaseOasdiArray Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns the array of OASDI wage bases.

C++
const WageBase& getBaseOasdiArray() const;
Collapse Expand Returns

The array of OASDI wage bases.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::getChildcareDropoutAmount Method

PiaParamsLC::getChildcareDropoutAmount Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns maximum amount of earnings in a childcare dropout year.

C++
double getChildcareDropoutAmount(
    int eligYear,
    int benYear
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
int benYear | Year for which amount is desired.
Collapse Expand Returns

Maximum amount of earnings in a childcare dropout year.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::getColaCap Method

PiaParamsLC::getColaCap Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns the amount of the cap on the COLA for the given year.

C++
double getColaCap(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year being capped.
Collapse Expand Returns

The amount of the cap on the COLA for the given year (returns maximum float if no cap).

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::getCpiinc Method

PiaParamsLC::getCpiinc Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns one benefit increase.

C++
double getCpiinc(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | The year for which a benefit increase is desired.
Collapse Expand Returns

One benefit increase.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::getCpiincArray Method

PiaParamsLC::getCpiincArray Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns the benefit increases.

C++
const DoubleAnnual& getCpiincArray() const;
Collapse Expand Returns

The benefit increases.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::getFqBppia Method

PiaParamsLC::getFqBppia Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns series of average wages or other series used for indexing pia formula bend points.

C++
const AverageWage& getFqBppia() const;
Collapse Expand Returns

Series of average wages or other series used for indexing pia formula bend points.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::getFqIndex Method

PiaParamsLC::getFqIndex Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns series of average wages or other series used for indexing an earnings record.

C++
const AverageWage& getFqIndex() const;
Collapse Expand Returns

Series of average wages or other series used for indexing an earnings record.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::getMarrLengthForDivBen Method

PiaParamsLC::getMarrLengthForDivBen Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.

C++
int getMarrLengthForDivBen(
    const DateMoyr& dateMoyr
) const;
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The date (year and month) when checking if eligible for divorced spouse benefit.
Collapse Expand Returns

Number of years of marriage needed to be eligible for a divorced spouse benefit.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::getMaxChildcareAge Method

PiaParamsLC::getMaxChildcareAge Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns maximum age of child for childcare dropout year or childcare credit.

C++
int getMaxChildcareAge() const;
Collapse Expand Returns

Maximum age of child for childcare dropout year.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::getMaxChildcareDropoutYears Method

PiaParamsLC::getMaxChildcareDropoutYears Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns maximum number of childcare dropout years.

C++
int getMaxChildcareDropoutYears(
    int eligYear,
    int benYear
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
int benYear | Year for which number is desired.
Collapse Expand Returns

Maximum number of childcare dropout years, based on changed law.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::getMfbColaCap Method

PiaParamsLC::getMfbColaCap Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns the amount of the cap on the COLA for the MFB for the given year.

C++
double getMfbColaCap(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year being capped.
Collapse Expand Returns

The amount of the cap on the COLA for the MFB for the given year (returns maximum float if no cap).

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::getSpecMinMfb Method

PiaParamsLC::getSpecMinMfb Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns special minimum mfb as of a specified month.

C++
double getSpecMinMfb(
    const DateMoyr& dateMoyr,
    int yoc
) const;
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | Month and year for which mfb is desired (January 1979 or later).
int yoc | Years of coverage in excess of 10 (1 to 20).
Collapse Expand Returns

Special minimum mfb, based on changed law.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::getSpecMinPia Method

PiaParamsLC::getSpecMinPia Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns special minimum pia as of a specified month.

C++
double getSpecMinPia(
    const DateMoyr& dateMoyr,
    int yoc
) const;
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | Month and year for which pia is desired (January 1979 or later).
int yoc | Years of coverage in excess of 10 (1-20).
Collapse Expand Returns

Special minimum pia, based on changed law.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::initdata Method

PiaParamsLC::initdata Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Initializes some data.

C++
void initdata();
Collapse Expand Remarks

For various types of law changes that are being phased in immediately (i.e. LawChange::getPhaseType == 1), then need to do a recalculation for benefits the first year it is effective. In those cases, we set the indicator for a recalculation in that year.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::maxDibAge Method

PiaParamsLC::maxDibAge Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns maximum DI beneficiary age at end of year.

C++
Age maxDibAge(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of benefit.
Collapse Expand Returns

Maximum DI beneficiary age at end of year.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


needColaCap Method

needColaCap Method
PiaParamsLC Methods

Returns true if a cola cap is required.

Collapse Expand Description

There are two versions of the needColaCap function. The one with a year argument checks to see if a cola cap is required for that specified year; the one with no arguments checks to see if a cola cap is required at any time.

Collapse Expand Overload List
Name | Description
PiaParamsLC::needColaCap () | Returns true if a cola cap is required at any time.
PiaParamsLC::needColaCap (int) | Returns true if a cola cap is required for a specified year.
Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Methods


PiaParamsLC::needColaCap Method ()

PiaParamsLC::needColaCap Method ()
PiaParamsLC Class PiaParamsLC Members needColaCap Method

Returns true if a cola cap is required at any time.

C++
bool needColaCap() const;
Collapse Expand Returns

True if a cola cap is required, based on changed law.

Collapse Expand Remarks

Looks at LawChange::lawChangeType::COLACHANGE.

Collapse Expand Group

needColaCap Method

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, needColaCap Method


PiaParamsLC::needColaCap Method (int)

PiaParamsLC::needColaCap Method (int)
PiaParamsLC Class PiaParamsLC Members needColaCap Method

Returns true if a cola cap is required for a specified year.

C++
bool needColaCap(
    int
) const;
Collapse Expand Parameters
Parameters | Description
year | Year being capped.
Collapse Expand Returns

True if a cola cap is required, based on changed law.

Collapse Expand Remarks

Looks at LawChange::lawChangeType::COLACHANGE.

Collapse Expand Group

needColaCap Method

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, needColaCap Method


PiaParamsLC::projectCpiinc Method

PiaParamsLC::projectCpiinc Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Projects amounts dependent on benefit increases.

C++
void projectCpiinc();
Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::projectFq Method

PiaParamsLC::projectFq Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Projects average annual wage and amounts dependent on it.

C++
void projectFq();
Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::projectPerc Method

PiaParamsLC::projectPerc Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Projects benefit formula percentages.

C++
void projectPerc();
Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::projectSpecMin Method

PiaParamsLC::projectSpecMin Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Projects special minimum amounts.

C++
void projectSpecMin(
    int baseYear,
    int lastYear
);
Collapse Expand Parameters
Parameters | Description
int baseYear | First year of special minimum amounts (1979 for present law).
int lastYear | Last year of projection.
Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::resizeSpecMin Method

PiaParamsLC::resizeSpecMin Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Resizes special minimum arrays.

C++
void resizeSpecMin();
Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::ribLimCal Method

PiaParamsLC::ribLimCal Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns widow(er) benefit reduced for RIB-LIM.

C++
double ribLimCal(
    double widowBen,
    double oabPia,
    double oabBen,
    const DateMoyr& benefitDate
) const;
Collapse Expand Parameters
Parameters | Description
double widowBen | Widow(er) benefit reduced for widow(er)'s age, but not for RIB-LIM.
double oabPia | PIA upon which widow(er) benefit is based. Note that this is not a re-indexed widow(er) PIA, since the OAB must have survived to age 62.
double oabBen | Benefit that deceased OAB was receiving.
const DateMoyr& benefitDate | The date of benefit.
Collapse Expand Returns

Reduced widow(er) benefit.

Collapse Expand Remarks

This should only be called in cases where the deceased worker was an OAB before death.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::setAltCpiinc Method

PiaParamsLC::setAltCpiinc Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Sets benefit increases when changed from present law.

C++
void setAltCpiinc();
Collapse Expand Remarks

This is called in the constructor (see PiaParamsLC::PiaParamsLC) and in projectCpiinc.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::setColaCap Method

PiaParamsLC::setColaCap Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Sets the amount of the cap on the COLA for the given year.

C++
void setColaCap(
    double cap,
    int year
);
Collapse Expand Parameters
Parameters | Description
double cap | Amount of cap for pia.
int year | Year being capped.
Collapse Expand Remarks

Sets the cap in the stored arrays of cola caps for pias and mfbs.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::setData Method

PiaParamsLC::setData Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Sets data from historical average wages and benefit increase file.

C++
void setData(
    AwbiData& awbiData
);
Collapse Expand Parameters
Parameters | Description
AwbiData& awbiData | Structure with historical average wages and benefit increases.
Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::setFqBppia Method

PiaParamsLC::setFqBppia Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Sets series of average wages or other series used for indexing pia formula bend points.

C++
void setFqBppia();
Collapse Expand Remarks

This is called in the constructor (see PiaParamsLC::PiaParamsLC).

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::setFqIndex Method

PiaParamsLC::setFqIndex Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Calculate series of average wages or other series used for indexing an earnings record.

C++
void setFqIndex();
Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::setMfbColaCap Method

PiaParamsLC::setMfbColaCap Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Sets the amount of the cap on the COLA for the MFB for the given year.

C++
void setMfbColaCap(
    double cap,
    int year
);
Collapse Expand Parameters
Parameters | Description
double cap | Amount of cap.
int year | Year being capped.
Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


PiaParamsLC::specMinAmountCal Method

PiaParamsLC::specMinAmountCal Method
PiaParamsLC Class PiaParamsLC Members PiaParamsLC Methods

Returns amount per year of coverage in special minimum.

C++
double specMinAmountCal(
    const DateMoyr& date
) const;
Collapse Expand Parameters
Parameters | Description
const DateMoyr& date | The date of desired amount.
Collapse Expand Returns

Amount per year of coverage in special minimum.

Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, PiaParamsLC Methods


specMinMaxYears Method

specMinMaxYears Method
PiaParamsLC Methods

Returns maximum number of usable years for special minimum.

Collapse Expand Description

There are two versions of the specMinMaxYears function. The one with two arguments returns the maximum number of usable years for special minimum for a specified year of eligibility and year of benefit. The one with no arguments returns the maximum number of usable years for any year of eligibility and year of benefit.

Collapse Expand Overload List
Name | Description
PiaParamsLC::specMinMaxYears () | Returns maximum number of usable years for special minimum that could ever be for any year of eligibility and year of benefit.
PiaParamsLC::specMinMaxYears (int, int) | Returns maximum number of usable years for special minimum for a specified year of eligibility and year of benefit.
Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Methods


PiaParamsLC::specMinMaxYears Method ()

PiaParamsLC::specMinMaxYears Method ()
PiaParamsLC Class PiaParamsLC Members specMinMaxYears Method

Returns maximum number of usable years for special minimum that could ever be for any year of eligibility and year of benefit.

C++
int specMinMaxYears() const;
Collapse Expand Returns

Maximum number of usable years for special minimum.

Collapse Expand Group

specMinMaxYears Method

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, specMinMaxYears Method


PiaParamsLC::specMinMaxYears Method (int, int)

PiaParamsLC::specMinMaxYears Method (int, int)
PiaParamsLC Class PiaParamsLC Members specMinMaxYears Method

Returns maximum number of usable years for special minimum for a specified year of eligibility and year of benefit.

C++
int specMinMaxYears(
    int eligYear,
    int benYear
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility for which maximum number of years is desired.
int benYear | Year of benefit for which maximum number of years is desired.
Collapse Expand Returns

Maximum number of usable years for special minimum.

Collapse Expand Group

specMinMaxYears Method

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, specMinMaxYears Method


updateBases Method

updateBases Method
PiaParamsLC Methods

Updates wage bases.

Collapse Expand Description

There are two versions of the updateBases function. The one with five arguments updates wage bases for user entries and/or for average wage changes. The one with no arguments updates only for average wage changes.

Collapse Expand Overload List
Name | Description
PiaParamsLC::updateBases () | Updates wage bases.
PiaParamsLC::updateBases (const DoubleAnnual&, const DoubleAnnual&, BaseChangeType::change_type, int, int) | Updates wage bases.
Collapse Expand Group

PiaParamsLC Methods

Collapse Expand Links
PiaParamsLC Methods


PiaParamsLC::updateBases Method ()

PiaParamsLC::updateBases Method ()
PiaParamsLC Class PiaParamsLC Members updateBases Method

Updates wage bases.

C++
void updateBases();
Collapse Expand Remarks

This version of the function (with no arguments) handles wage base changes as provided in the stored LawChangeWAGEBASECHG.

Collapse Expand Group

updateBases Method

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, updateBases Method


PiaParamsLC::updateBases Method (const DoubleAnnual&, const DoubleAnnual&, BaseChangeType::change_type, int, int)

PiaParamsLC::updateBases Method (const DoubleAnnual&, const DoubleAnnual&, BaseChangeType::change_type, int, int)
PiaParamsLC Class PiaParamsLC Members updateBases Method

Updates wage bases.

C++
void updateBases(
    const DoubleAnnual& userbase,
    const DoubleAnnual& userbase77,
    BaseChangeType::change_type ibasch,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& userbase | User-entered bases.
const DoubleAnnual& userbase77 | User-entered old-law bases.
BaseChangeType::change_type ibasch | Indicator for base changes.
int firstYeart | First year to update.
int lastYeart | Last year to update.
Collapse Expand Remarks

This version of the function (with specified arguments) handles ad hoc wage bases as provided in the arguments.

Collapse Expand Group

updateBases Method

Collapse Expand Links
PiaParamsLC Class, PiaParamsLC Members, updateBases Method


PiaParamsLCTR Class

PiaParamsLCTR Class
PiaParamsLCTR Members PiaParamsLCTR.h Classes

Manages the changed law Social Security parameters, already projected based on a Trustees Report assumption.

Collapse Expand Class Hierarchy
  PiaParamsLCTRPiaParamsLCTRPiaParamsLCTR
C++
class PiaParamsLCTR : public PiaParamsLC;
Collapse Expand File

File: PiaParamsLCTR.h

Module: PiaData Library

Collapse Expand Remarks

Often the user knows that only one version of PiaParams will be used. This subclass of PiaParams has a specified Trustees Report assumption, so no additional work is necessary to begin using it.

Collapse Expand Group

Classes

Collapse Expand Links
PiaParamsLCTR Members, PiaParamsLCTR.h, Classes


PiaParamsLCTR Members

PiaParamsLCTR Members
Enumerations PiaParamsLCTR Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by PiaParamsLCTR.

Collapse Expand Enumerations
Name | Description
SPECMINPERCTYPE | The year range for the special minimum percentage.
Collapse Expand Class

PiaParamsLCTR Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
baseHi | HI wage bases.
bendOS | Bend points for old-start PIB formula.
catchup | Catch-up benefit increases.
cpiinc | Array of benefit increases.
fq | Array of annual average earnings.
fqinc | Array of percentage increases in annual average earnings.
istart | Current year (year after last known benefit increase).
maxyear | Maximum year allowed.
monthBeninc | Array of month of benefit increase.
noChange | Array of indicators for no change allowed.
percOS | Old-start PIB formula percentages.
percSpecMin | Percentage of old-law wage base required for year of coverage.
recalcInd | Indicator for which year(s) the PIA should be recalculated due to a newly effective law change.
specMinMfb | Special minimum mfbs.
specMinMfb2001 | Special minimum mfbs for August-November 2001.
specMinPerc | Percentage of old-law wage base required for year of coverage for special minimum.
specMinPia | Special minimum pias.
specMinPia2001 | Special minimum pias for August-November 2001.
titleAw | Title of average wage assumptions.
titleBi | Title of benefit increase assumptions.
yocAmountSpecMin | Amount required for year of coverage for special minimum.
yocAmountWindfall | Amount required for year of coverage for windfall elimination provision.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
setAltCpiinc | Sets benefit increases when changed from present law.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setFqBppia | Sets series of average wages or other series used for indexing pia formula bend points.
setFqIndex | Calculate series of average wages or other series used for indexing an earnings record.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
YEAR1999 | Year of extra 0.1 percent benefit increase.
age16 | Age 16.
age18 | Age 18.
age19 | Age 19.
age199 | Age 199 (impossible age).
age22 | Age 22.
age50 | Age 50.
age60 | Age 60.
age62 | Age 62.
age621 | Age 62 and 1 month.
age65 | Age 65.
age65_10 | Age 65 and 10 months.
age65_2 | Age 65 and 2 months.
age65_4 | Age 65 and 4 months.
age65_6 | Age 65 and 6 months.
age65_8 | Age 65 and 8 months.
age66 | Age 66.
age66_10 | Age 66 and 10 months.
age66_2 | Age 66 and 2 months.
age66_4 | Age 66 and 4 months.
age66_6 | Age 66 and 6 months.
age66_8 | Age 66 and 8 months.
age67 | Age 67.
age70 | Age 70.
age72 | Age 72.
age75 | Age 75.
amend01 | The date of special 0.1 percent benefit increase.
amend118_273 | The date of WEP no longer being used for benefit computations.
amend50 | The date of 1950 amendments.
amend52 | The date of 1952 amendments.
amend54 | The date of 1954 amendments.
amend56 | The date of 1956 amendments.
amend561 | First birth date for which age 62 is effective for females.
amend562 | Second birth date for which age 62 is effective for females.
amend58 | The date of 1958 amendments.
amend61 | The date of 1961 amendments.
amend611 | First birth date for which age 62 is effective for males.
amend612 | Second birth date for which age 62 is effective for males.
amend651 | The date of 1965 amendments for benefit increase.
amend652 | The date of 1965 amendments for change to age 60.
amend653 | The date of 1965 amendments for old start.
amend671 | The date of 1967 amendments for old start.
amend672 | The date of 1967 amendments for benefit increase.
amend69 | The date of 1969 amendments.
amend70 | The date of 1970 amendments.
amend721 | The date of 1972 amendments for benefit increase.
amend722 | The date of 1972 amendments for special minimum.
amend741 | The date of 1974 amendments for partial increase.
amend742 | The date of 1974 amendments for full increase.
amend771 | The date of 1977 amendments for frozen pia table.
amend772 | The date of 1977 amendments for start of wage indexing.
amend80 | The date of 1980 amendments.
amend811 | The date of birth for age 62 and 1 month in 1981 amendments.
amend812 | The date of 1981 amendments (month, day, and year).
amend813 | The date of 1981 amendments (month and year).
amend82 | The date of 1982 amendments.
amend83 | The date of 1983 amendments.
amend88 | The date of 1988 amendments.
amend90 | The date of 1990 amendments.
amtperincyr | Amount per old start increment year.
arFactorWid285 | Total actuarial reduction factor for aged widow(er)s.
arMonthlyFactor65_67 | Monthly actuarial reduction factor between ages 65 and 67.
arMonthlyFactorOab62_65 | Monthly actuarial reduction factor between ages 62 and 65.
arMonthlyFactorSpouse62_65 | Monthly actuarial reduction factor for aged spouses between ages 62 and 65.
beninc74 | Temporary benefit increase, March-May 1974.
bpMfbOut | Table of mfb formula bend points.
bpPiaOut | Table of pia formula bend points.
factor150 | Factor for calculating mfbs.
factor175 | Factor for calculating mfbs.
factor50 | Factor for calculating life benefits.
factor75 | Factor for calculating survivor benefits.
factor825 | Factor for calculating widow(er) benefits.
maxMonthsAr62_65 | Maximum number of months of actuarial reduction between ages 62 and 65.
maxMonthsAr62_67 | Maximum number of months of actuarial reduction between ages 62 and 67.
maxMonthsAr65_67 | Maximum number of months of actuarial reduction between ages 65 and 67.
percPiaOut | Table of pia formula percentages.
qcamt | Array of amounts required for quarter of coverage.
qtr184 | Starting point of deemed insured.
year37qtr1 | First quarter for which a quarter of coverage could be earned.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PiaParams | Initializes a PiaParams, with or without a first year of projection.
PiaParamsLC | Initializes a PiaParamsLC, with or without a first year of projection.
PiaParamsLCTR | Constructor.
applyCola | Returns benefit amount increased by cola.
applyCola | Returns benefit amount increased by cola.
applyCola99 | Returns benefit amount increased by special 1999 cola (includes extra 0.1 percent increase).
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb99 | Returns maximum family benefit amount increased by special 1999 cola (includes extra 0.1 percent increase), with check that result is at least 150 percent of pia.
benincCatchUp | Applies catch-up benefit increases.
birthDateFRA | Returns the earliest birthdate for someone to be over NRA at the end of a year.
childAgeForMFCal | Returns oldest age of child for which parent can get young wife/husband or mother/father benefits.
deconvertPia | Deconverts PIA back to year of eligibility.
deemedQcReqCal | Returns number of quarters of coverage required for deemed insured status.
doRecalc | Returns true if should recalculate PIAs this year because of a newly effective law change, else false.
earlyAgeDisWidCal | Returns earliest possible disabled widow(er)'s retirement age.
earlyAgeOabCal | Returns earliest possible retirement age for oab or aged spouse.
earlyAgeOabCal | Returns earliest possible retirement age for old-age benie or aged spouse.
earlyAgeOabCalPL | Returns earliest possible retirement age for old-age benie or aged spouse, based on present law.
earlyAgeWidCal | Returns earliest possible aged widow(er)'s retirement age.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCalPL | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow(er) benefit before age reduction.
factorAgedWidCal | Returns factor for widow/widower benefit before age reduction.
factorAgedWidCalPL | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Returns reduction factor for wife/husband.
factorArAgedSpouseCal | Calculates reduction factor for wife/husband.
factorArAgedSpouseCalPL | Calculates reduction factor for wife/husband. Assumes a maximum of 60 months of reduction.
factorArCal | Returns reduction factor for OAB.
factorArCal | Calculates reduction factor for OAB.
factorArCalPL | Calculates reduction factor for OAB or DIB.
factorArDisWidCal | Calculates reduction factor for disabled widow(er).
factorArWidCal | Calculates reduction factor for aged widow(er).
factorDisWidCal | Returns factor for disabled widow(er) benefit before age reduction.
factorDisWidCal | Returns factor for disabled widow/widower benefit before age reduction.
factorDisWidCalPL | Returns factor for disabled widow/widower benefit before age reduction.
factorDriCal | Calculates delayed retirement increment factor for OAB.
factorYngLifeCal | Calculates reduction factor for young life benie.
factorYngSurvCal | Calculates reduction factor for young survivor.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDIPL | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalPL | Returns full retirement age based on present law.
getAverageWage | Returns title of average wage assumptions.
getBase77 | Returns one old-law wage base.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBase77Array | Returns the array of old-law wage bases.
getBaseHi | Returns one HI wage base.
getBaseHiArray | Returns the array of HI wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBendOS | Returns a bend point for old-start PIB formula.
getBenefitInc | Returns title of benefit increase assumptions.
getCatchup | Returns catch-up benefit increases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmountPL | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getCpiinc | Returns one benefit increase.
getCpiinc | Returns one benefit increase.
getCpiincArray | Returns the array of benefit increases.
getCpiincArray | Returns the benefit increases.
getFq | Returns one average wage for indexing.
getFqArray | Returns array of average wages for indexing.
getFqBppia | Returns series used for indexing pia formula bend points.
getFqBppia | Returns series of average wages or other series used for indexing pia formula bend points.
getFqIndex | Returns series used for indexing an earnings record.
getFqIndex | Returns series of average wages or other series used for indexing an earnings record.
getFqinc | Returns one increase in average wage for indexing.
getFqincArray | Returns array of increases in average wage for indexing.
getIstart | Returns current year.
getMarrLengthForDivBen | Returns the number of years of marraige needed to be eligible for a divroced spouse benefit.
getMarrLengthForDivBen | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMarrLengthForDivBenPL | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year or childcare credit.
getMaxChildcareAgePL | Returns maximum age of child for childcare dropout year.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYearsPL | Returns maximum number of childcare dropout years.
getMaxyear | Returns maximum possible year.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB for the given year.
getMonthBeninc | Returns one month of benefit increase.
getMonthBenincArray | Returns array of months of benefit increase.
getPercOS | Returns old-start PIB formula percentage.
getPercSpecMin | Returns percent of old-law base required for year of coverage.
getPercSpecMinArray | Returns array of percents of old-law base required for year of coverage.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinPerc | Returns percentage of old-law base required for year of coverage.
getSpecMinPia | Returns special minimum pia as of a specified month.
getSpecMinPia | Returns special minimum pia as of a specified month.
getYocAmountSpecMin | Returns amount required for year of coverage for special minimum.
getYocAmountSpecMinArray | Returns array of amounts required for year of coverage for special minimum.
getYocAmountWindfallArray | Returns array of amounts required for year of coverage for windfall elimination.
initdata | Initializes some data.
initdata | Initializes some data.
isApplicableCola99 | Checks for applicability of special 1999 increase (with extra 0.1 percent).
lastAmw | Finds last AMW in old-law table.
lumpSum | Returns amount of lump sum benefit.
maxChildAge | Returns maximum child beneficiary age.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAgePL | Returns maximum DI beneficiary age at end of year, based on present law.
monthsArAgedSpouseCal | Calculates number of months of actuarial reduction for aged wife/husband.
monthsArCal | Calculates number of months of actuarial reduction for OAB.
monthsArDICal | Calculates number of months of reduction for disabled worker.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er).
monthsArWidCal | Calculates number of months of actuarial reduction for aged widow(er).
monthsDriCal | Calculates number of months of delayed retirement credit for OAB.
needColaCap | Returns true if a cola cap is required.
needColaCap | Returns true if a cola cap is required.
percPiaCal | Sets benefit formula percents.
projectCpiinc | Projects amounts dependent on benefit increases.
projectCpiinc | Projects amounts dependent on benefit increases.
projectFq | Projects amounts dependent on the average annual wage.
projectFq | Projects average annual wage and amounts dependent on it.
projectPerc | Projects benefit formula percentages.
projectPerc | Projects benefit formula percentages.
projectSpecMin | Projects special minimum amounts.
projectSpecMin | Projects special minimum amounts.
qcCal | Returns number of quarters of coverage for one year, applying annual test.
resizeSpecMin | Resizes special minimum arrays.
resizeSpecMin | Resizes special minimum arrays.
retCredit | Returns amount of monthly delayed retirement credit.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCalPL | Returns widow(er) benefit reduced for RIB-LIM.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setData | Sets data from historical average wages and benefit increase file.
setData | Sets data from historical average wages and benefit increase file.
setHistFqinc | Sets historical average wage increases.
setIstart | Sets the first projected year, including for members.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
setNoChange | Sets indicators for no change allowed.
specMinAmountCal | Sets amount per year of coverage in special minimum.
specMinAmountCal | Returns amount per year of coverage in special minimum.
specMinAmountCalPL | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYearsPL | Returns maximum number of usable years for special minimum.
unApplyCola | Returns benefit amount decreased by cola.
unApplyCola99 | Returns benefit amount decreased by special 1999 cola (includes extra 0.1 percent decrease.)
unbiCatchUp | Divides out catch-up benefit increases.
updateBases | Updates wage bases.
updateBases | Updates wage bases.
updateCpiinc | Updates benefit increases.
updateFq | Updates average wages, using specified amounts.
updateFqinc | Updates increases in average wages, using specified percentages.
updateYocAmountSpecMin | Updates amounts required for special minimum year of coverage.
~PiaParamsLCTR | Destructor.
Collapse Expand Links
Enumerations, PiaParamsLCTR Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


PiaParamsLCTR::PiaParamsLCTR Constructor

PiaParamsLCTR::PiaParamsLCTR Constructor
PiaParamsLCTR Class PiaParamsLCTR Members PiaParamsLCTR Class

Constructor.

C++
PiaParamsLCTR(
    int newMaxyear,
    AssumptionType::assum_type altNum,
    const LawChangeArray& newLawChange
);
Collapse Expand Parameters
Parameters | Description
int newMaxyear | Maximum projected year.
AssumptionType::assum_type altNum | The Trustees Report alternative.
const LawChangeArray& newLawChange | Law change parameters.
Collapse Expand Class

PiaParamsLCTR Class

Collapse Expand Links
PiaParamsLCTR Class, PiaParamsLCTR Members, PiaParamsLCTR Class


PiaParamsLCTR::~PiaParamsLCTR Destructor

PiaParamsLCTR::~PiaParamsLCTR Destructor
PiaParamsLCTR Class PiaParamsLCTR Members PiaParamsLCTR Class

Destructor.

C++
virtual ~PiaParamsLCTR();
Collapse Expand Class

PiaParamsLCTR Class

Collapse Expand Links
PiaParamsLCTR Class, PiaParamsLCTR Members, PiaParamsLCTR Class


PiaParamsPL Class

PiaParamsPL Class
PiaParamsPL Constructor PiaParamsPL Methods PiaParamsPL Members piaparmsPL.h Classes

Manages the present law Social Security parameters required to calculate Social Security benefits.

Collapse Expand Class Hierarchy
  PiaParamsPLPiaParamsPL
C++
class PiaParamsPL : public PiaParams;
Collapse Expand File

File: piaparmsPL.h

Module: PiaData Library

Collapse Expand Remarks

Manages the present law Social Security parameters required to calculate Social Security benefits.

Collapse Expand Group

Classes

Collapse Expand Links
PiaParamsPL Constructor, PiaParamsPL Methods, PiaParamsPL Members, piaparmsPL.h, Classes


PiaParamsPL Members

PiaParamsPL Members
Enumerations PiaParamsPL Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PiaParamsPL.

Collapse Expand Enumerations
Name | Description
SPECMINPERCTYPE | The year range for the special minimum percentage.
Collapse Expand Class

PiaParamsPL Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
baseHi | HI wage bases.
bendOS | Bend points for old-start PIB formula.
catchup | Catch-up benefit increases.
cpiinc | Array of benefit increases.
fq | Array of annual average earnings.
fqinc | Array of percentage increases in annual average earnings.
istart | Current year (year after last known benefit increase).
maxyear | Maximum year allowed.
monthBeninc | Array of month of benefit increase.
noChange | Array of indicators for no change allowed.
percOS | Old-start PIB formula percentages.
percSpecMin | Percentage of old-law wage base required for year of coverage.
recalcInd | Indicator for which year(s) the PIA should be recalculated due to a newly effective law change.
specMinMfb | Special minimum mfbs.
specMinMfb2001 | Special minimum mfbs for August-November 2001.
specMinPerc | Percentage of old-law wage base required for year of coverage for special minimum.
specMinPia | Special minimum pias.
specMinPia2001 | Special minimum pias for August-November 2001.
titleAw | Title of average wage assumptions.
titleBi | Title of benefit increase assumptions.
yocAmountSpecMin | Amount required for year of coverage for special minimum.
yocAmountWindfall | Amount required for year of coverage for windfall elimination provision.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
YEAR1999 | Year of extra 0.1 percent benefit increase.
age16 | Age 16.
age18 | Age 18.
age19 | Age 19.
age199 | Age 199 (impossible age).
age22 | Age 22.
age50 | Age 50.
age60 | Age 60.
age62 | Age 62.
age621 | Age 62 and 1 month.
age65 | Age 65.
age65_10 | Age 65 and 10 months.
age65_2 | Age 65 and 2 months.
age65_4 | Age 65 and 4 months.
age65_6 | Age 65 and 6 months.
age65_8 | Age 65 and 8 months.
age66 | Age 66.
age66_10 | Age 66 and 10 months.
age66_2 | Age 66 and 2 months.
age66_4 | Age 66 and 4 months.
age66_6 | Age 66 and 6 months.
age66_8 | Age 66 and 8 months.
age67 | Age 67.
age70 | Age 70.
age72 | Age 72.
age75 | Age 75.
amend01 | The date of special 0.1 percent benefit increase.
amend118_273 | The date of WEP no longer being used for benefit computations.
amend50 | The date of 1950 amendments.
amend52 | The date of 1952 amendments.
amend54 | The date of 1954 amendments.
amend56 | The date of 1956 amendments.
amend561 | First birth date for which age 62 is effective for females.
amend562 | Second birth date for which age 62 is effective for females.
amend58 | The date of 1958 amendments.
amend61 | The date of 1961 amendments.
amend611 | First birth date for which age 62 is effective for males.
amend612 | Second birth date for which age 62 is effective for males.
amend651 | The date of 1965 amendments for benefit increase.
amend652 | The date of 1965 amendments for change to age 60.
amend653 | The date of 1965 amendments for old start.
amend671 | The date of 1967 amendments for old start.
amend672 | The date of 1967 amendments for benefit increase.
amend69 | The date of 1969 amendments.
amend70 | The date of 1970 amendments.
amend721 | The date of 1972 amendments for benefit increase.
amend722 | The date of 1972 amendments for special minimum.
amend741 | The date of 1974 amendments for partial increase.
amend742 | The date of 1974 amendments for full increase.
amend771 | The date of 1977 amendments for frozen pia table.
amend772 | The date of 1977 amendments for start of wage indexing.
amend80 | The date of 1980 amendments.
amend811 | The date of birth for age 62 and 1 month in 1981 amendments.
amend812 | The date of 1981 amendments (month, day, and year).
amend813 | The date of 1981 amendments (month and year).
amend82 | The date of 1982 amendments.
amend83 | The date of 1983 amendments.
amend88 | The date of 1988 amendments.
amend90 | The date of 1990 amendments.
amtperincyr | Amount per old start increment year.
arFactorWid285 | Total actuarial reduction factor for aged widow(er)s.
arMonthlyFactor65_67 | Monthly actuarial reduction factor between ages 65 and 67.
arMonthlyFactorOab62_65 | Monthly actuarial reduction factor between ages 62 and 65.
arMonthlyFactorSpouse62_65 | Monthly actuarial reduction factor for aged spouses between ages 62 and 65.
beninc74 | Temporary benefit increase, March-May 1974.
bpMfbOut | Table of mfb formula bend points.
bpPiaOut | Table of pia formula bend points.
factor150 | Factor for calculating mfbs.
factor175 | Factor for calculating mfbs.
factor50 | Factor for calculating life benefits.
factor75 | Factor for calculating survivor benefits.
factor825 | Factor for calculating widow(er) benefits.
maxMonthsAr62_65 | Maximum number of months of actuarial reduction between ages 62 and 65.
maxMonthsAr62_67 | Maximum number of months of actuarial reduction between ages 62 and 67.
maxMonthsAr65_67 | Maximum number of months of actuarial reduction between ages 65 and 67.
percPiaOut | Table of pia formula percentages.
qcamt | Array of amounts required for quarter of coverage.
qtr184 | Starting point of deemed insured.
year37qtr1 | First quarter for which a quarter of coverage could be earned.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PiaParams | Initializes a PiaParams, with or without a first year of projection.
PiaParamsPL | Initializes a PiaParamsPL, with or without a first year of projection.
applyCola | Returns benefit amount increased by cola.
applyCola99 | Returns benefit amount increased by special 1999 cola (includes extra 0.1 percent increase).
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb99 | Returns maximum family benefit amount increased by special 1999 cola (includes extra 0.1 percent increase), with check that result is at least 150 percent of pia.
benincCatchUp | Applies catch-up benefit increases.
birthDateFRA | Returns the earliest birthdate for someone to be over NRA at the end of a year.
childAgeForMFCal | Returns oldest age of child for which parent can get young wife/husband or mother/father benefits.
deconvertPia | Deconverts PIA back to year of eligibility.
deemedQcReqCal | Returns number of quarters of coverage required for deemed insured status.
doRecalc | Returns true if should recalculate PIAs this year because of a newly effective law change, else false.
earlyAgeDisWidCal | Returns earliest possible disabled widow(er)'s retirement age.
earlyAgeOabCal | Sets earliest possible retirement age for old-age benie or aged spouse.
earlyAgeOabCalPL | Returns earliest possible retirement age for old-age benie or aged spouse, based on present law.
earlyAgeWidCal | Returns earliest possible aged widow(er)'s retirement age.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCalPL | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow/widower benefit before age reduction.
factorAgedWidCalPL | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Returns reduction factor for wife/husband.
factorArAgedSpouseCalPL | Calculates reduction factor for wife/husband. Assumes a maximum of 60 months of reduction.
factorArCal | Calculates reduction factor for OAB.
factorArCalPL | Calculates reduction factor for OAB or DIB.
factorArDisWidCal | Calculates reduction factor for disabled widow(er).
factorArWidCal | Calculates reduction factor for aged widow(er).
factorDisWidCal | Returns factor for disabled widow/widower benefit before age reduction.
factorDisWidCalPL | Returns factor for disabled widow/widower benefit before age reduction.
factorDriCal | Calculates delayed retirement increment factor for OAB.
factorYngLifeCal | Calculates reduction factor for young life benie.
factorYngSurvCal | Calculates reduction factor for young survivor.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDIPL | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalPL | Returns full retirement age based on present law.
getAverageWage | Returns title of average wage assumptions.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBaseHi | Returns one HI wage base.
getBaseHiArray | Returns the array of HI wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBendOS | Returns a bend point for old-start PIB formula.
getBenefitInc | Returns title of benefit increase assumptions.
getCatchup | Returns catch-up benefit increases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmountPL | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getCpiinc | Returns one benefit increase.
getCpiincArray | Returns the array of benefit increases.
getFq | Returns one average wage for indexing.
getFqArray | Returns array of average wages for indexing.
getFqBppia | Returns series of average wages used for indexing pia formula bend points.
getFqIndex | Returns series of average wages used for indexing an earnings record.
getFqinc | Returns one increase in average wage for indexing.
getFqincArray | Returns array of increases in average wage for indexing.
getIstart | Returns current year.
getMarrLengthForDivBen | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMarrLengthForDivBenPL | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year.
getMaxChildcareAgePL | Returns maximum age of child for childcare dropout year.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYearsPL | Returns maximum number of childcare dropout years.
getMaxyear | Returns maximum possible year.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB for the given year.
getMonthBeninc | Returns one month of benefit increase.
getMonthBenincArray | Returns array of months of benefit increase.
getPercOS | Returns old-start PIB formula percentage.
getPercSpecMin | Returns percent of old-law base required for year of coverage.
getPercSpecMinArray | Returns array of percents of old-law base required for year of coverage.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinPerc | Returns percentage of old-law base required for year of coverage.
getSpecMinPia | Returns special minimum pia as of a specified month.
getYocAmountSpecMin | Returns amount required for year of coverage for special minimum.
getYocAmountSpecMinArray | Returns array of amounts required for year of coverage for special minimum.
getYocAmountWindfallArray | Returns array of amounts required for year of coverage for windfall elimination.
initdata | Initializes some data.
isApplicableCola99 | Checks for applicability of special 1999 increase (with extra 0.1 percent).
lastAmw | Finds last AMW in old-law table.
lumpSum | Returns amount of lump sum benefit.
maxChildAge | Returns maximum child beneficiary age.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAgePL | Returns maximum DI beneficiary age at end of year, based on present law.
monthsArAgedSpouseCal | Calculates number of months of actuarial reduction for aged wife/husband.
monthsArCal | Calculates number of months of actuarial reduction for OAB.
monthsArDICal | Calculates number of months of reduction for disabled worker.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er).
monthsArWidCal | Calculates number of months of actuarial reduction for aged widow(er).
monthsDriCal | Calculates number of months of delayed retirement credit for OAB.
needColaCap | Returns true if a cola cap is required.
needColaCap | Returns true if a cola cap is required.
percPiaCal | Sets benefit formula percents.
projectCpiinc | Projects amounts dependent on benefit increases.
projectFq | Projects amounts dependent on the average annual wage.
projectPerc | Projects benefit formula percentages.
projectSpecMin | Projects special minimum amounts.
qcCal | Returns number of quarters of coverage for one year, applying annual test.
resizeSpecMin | Resizes special minimum arrays.
retCredit | Returns amount of monthly delayed retirement credit.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCalPL | Returns widow(er) benefit reduced for RIB-LIM.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setData | Sets data from historical average wages and benefit increase file.
setHistFqinc | Sets historical average wage increases.
setIstart | Sets the first projected year, including for members.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
setNoChange | Sets indicators for no change allowed.
specMinAmountCal | Returns amount per year of coverage in special minimum.
specMinAmountCalPL | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYearsPL | Returns maximum number of usable years for special minimum.
unApplyCola | Returns benefit amount decreased by cola.
unApplyCola99 | Returns benefit amount decreased by special 1999 cola (includes extra 0.1 percent decrease.)
unbiCatchUp | Divides out catch-up benefit increases.
updateBases | Updates wage bases.
updateBases | Updates wage bases.
updateCpiinc | Updates benefit increases.
updateFq | Updates average wages, using specified amounts.
updateFqinc | Updates increases in average wages, using specified percentages.
updateYocAmountSpecMin | Updates amounts required for special minimum year of coverage.
~PiaParamsPL | Destroys arrays.
Collapse Expand Links
Enumerations, PiaParamsPL Class, Legend, Protected Data Members, Public Data Members, Public Methods


PiaParamsPL Constructor

PiaParamsPL Constructor
PiaParamsPL Class

Initializes a PiaParamsPL, with or without a first year of projection.

Collapse Expand Description

There are two versions of the PiaParamsPL constructor. If the first year of projection is not provided, it is set to BaseYearNonFile::YEAR.

Collapse Expand Overload List
Name | Description
PiaParamsPL::PiaParamsPL (int) | Initializes arrays without a specified starting year.
PiaParamsPL::PiaParamsPL (int, int, AwbiData&) | Initializes arrays with a specified starting year.
Collapse Expand Class

PiaParamsPL Class

Collapse Expand Links
PiaParamsPL Class


PiaParamsPL::PiaParamsPL Constructor (int)

PiaParamsPL::PiaParamsPL Constructor (int)
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Constructor

Initializes arrays without a specified starting year.

C++
explicit PiaParamsPL(
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
int newMaxyear | Maximum projected year.
Collapse Expand Remarks

This version without a specified starting year uses BaseYearNonFile::YEAR, and constructs an AwbiDataNonFile using that year.

Collapse Expand Group

PiaParamsPL Constructor

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Constructor


PiaParamsPL::PiaParamsPL Constructor (int, int, AwbiData&)

PiaParamsPL::PiaParamsPL Constructor (int, int, AwbiData&)
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Constructor

Initializes arrays with a specified starting year.

C++
PiaParamsPL(
    int newIstart,
    int newMaxyear,
    AwbiData& awbiData
);
Collapse Expand Parameters
Parameters | Description
int newIstart | Year after last known benefit increase.
int newMaxyear | Maximum projected year.
AwbiData& awbiData | Structure with historical amounts.
Collapse Expand Group

PiaParamsPL Constructor

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Constructor


PiaParamsPL::~PiaParamsPL Destructor

PiaParamsPL::~PiaParamsPL Destructor
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Class

Destroys arrays.

C++
~PiaParamsPL();
Collapse Expand Class

PiaParamsPL Class

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Class


PiaParamsPL Methods

PiaParamsPL Methods
PiaParamsPL Class Legend Public Methods

The methods of the PiaParamsPL class are listed here.

Collapse Expand Class

PiaParamsPL Class

Collapse Expand Public Methods
Name | Description
earlyAgeOabCal | Sets earliest possible retirement age for old-age benie or aged spouse.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Returns reduction factor for wife/husband.
factorArCal | Calculates reduction factor for OAB.
factorDisWidCal | Returns factor for disabled widow/widower benefit before age reduction.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getFqBppia | Returns series of average wages used for indexing pia formula bend points.
getFqIndex | Returns series of average wages used for indexing an earnings record.
getMarrLengthForDivBen | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB for the given year.
maxDibAge | Returns maximum DI beneficiary age at end of year.
needColaCap | Returns true if a cola cap is required.
projectCpiinc | Projects amounts dependent on benefit increases.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setData | Sets data from historical average wages and benefit increase file.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
specMinAmountCal | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
updateBases | Updates wage bases.
Collapse Expand Links
PiaParamsPL Class, Legend, Public Methods


PiaParamsPL::earlyAgeOabCal Method

PiaParamsPL::earlyAgeOabCal Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Sets earliest possible retirement age for old-age benie or aged spouse.

C++
Age earlyAgeOabCal(
    Sex::sex_type sex,
    const boost::gregorian::date& kbirth
) const;
Collapse Expand Parameters
Parameters | Description
Sex::sex_type sex | The sex of number holder (Sex::sex_type::MALE for male, Sex::sex_type::FEMALE for female).
const boost::gregorian::date& kbirth | The date of birth, adjusted to previous day.
Collapse Expand Returns

Earliest possible retirement age, based on present law.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::factorAgedSpouseCal Method

PiaParamsPL::factorAgedSpouseCal Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns factor for wife/husband benefit before age reduction.

C++
double factorAgedSpouseCal(
    int,
    int
) const;
Collapse Expand Returns

Factor for wife/husband benefit before age reduction.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::factorAgedWidCal Method

PiaParamsPL::factorAgedWidCal Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns factor for widow/widower benefit before age reduction.

C++
double factorAgedWidCal(
    int monthsArdri,
    const Age& age,
    int,
    const DateMoyr& benefitDate
) const;
Collapse Expand Parameters
Parameters | Description
int monthsArdri | Months of reduction.
const Age& age | The age of widow/widower.
const DateMoyr& benefitDate | The date of benefit.
Collapse Expand Returns

Factor for widow/widower benefit before age reduction.

Collapse Expand Remarks

Returns factorAgedWidCalPL.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::factorArAgedSpouseCal Method

PiaParamsPL::factorArAgedSpouseCal Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns reduction factor for wife/husband.

C++
double factorArAgedSpouseCal(
    int monthsArdri
) const;
Collapse Expand Parameters
Parameters | Description
int monthsArdri | Number of months of reduction.
Collapse Expand Returns

Reduction factor for wife/husband.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::factorArCal Method

PiaParamsPL::factorArCal Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Calculates reduction factor for OAB.

C++
double factorArCal(
    int monthsArdri
) const;
Collapse Expand Parameters
Parameters | Description
int monthsArdri | Number of months of reduction.
Collapse Expand Returns

Reduction factor for OAB.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::factorDisWidCal Method

PiaParamsPL::factorDisWidCal Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns factor for disabled widow/widower benefit before age reduction.

C++
double factorDisWidCal(
    int,
    const DateMoyr& benefitDate
) const;
Collapse Expand Parameters
Parameters | Description
const DateMoyr& benefitDate | The date of benefit.
Collapse Expand Returns

Factor for disabled widow/widower benefit before age reduction.

Collapse Expand Remarks

Returns factorDisWidCalPL.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::fullRetAgeCal Method

PiaParamsPL::fullRetAgeCal Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns full retirement age.

C++
Age fullRetAgeCal(
    int eligYear
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility (age 62 for oab or wife/husband, 60 for widow(er)).
Collapse Expand Returns

Full retirement age based on present law.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::fullRetAgeCalDI Method

PiaParamsPL::fullRetAgeCalDI Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns full retirement age for benefit calculations involving disability freeze.

C++
Age fullRetAgeCalDI(
    int eligYear,
    int currentYear
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility (age 62 for oab or wife/husband, 60 for widow(er)).
int currentYear | Current year.
Collapse Expand Returns

Full retirement age for benefit calculations involving disability freeze.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::getBase77 Method

PiaParamsPL::getBase77 Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns one old-law wage base.

C++
double getBase77(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which base is desired.
Collapse Expand Returns

One old-law wage base.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::getBase77Array Method

PiaParamsPL::getBase77Array Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns the array of old-law wage bases.

C++
const WageBaseOldLaw& getBase77Array() const;
Collapse Expand Returns

The array of old-law wage bases.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::getBaseOasdi Method

PiaParamsPL::getBaseOasdi Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns one OASDI wage base.

C++
double getBaseOasdi(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which base is desired.
Collapse Expand Returns

One OASDI wage base.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::getBaseOasdiArray Method

PiaParamsPL::getBaseOasdiArray Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns the array of OASDI wage bases.

C++
const WageBase& getBaseOasdiArray() const;
Collapse Expand Returns

The array of OASDI wage bases.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::getChildcareDropoutAmount Method

PiaParamsPL::getChildcareDropoutAmount Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns maximum amount of earnings in a childcare dropout year.

C++
double getChildcareDropoutAmount(
    int,
    int
) const;
Collapse Expand Returns

0 for present law.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::getColaCap Method

PiaParamsPL::getColaCap Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns the amount of the cap on the COLA for the given year.

C++
double getColaCap(
    int
) const;
Collapse Expand Returns

Maximum float value.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::getFqBppia Method

PiaParamsPL::getFqBppia Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns series of average wages used for indexing pia formula bend points.

C++
const AverageWage& getFqBppia() const;
Collapse Expand Returns

Series of average wages used for indexing pia formula bend points.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::getFqIndex Method

PiaParamsPL::getFqIndex Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns series of average wages used for indexing an earnings record.

C++
const AverageWage& getFqIndex() const;
Collapse Expand Returns

Series of average wages used for indexing an earnings record.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::getMarrLengthForDivBen Method

PiaParamsPL::getMarrLengthForDivBen Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.

C++
int getMarrLengthForDivBen(
    const DateMoyr& dateMoyr
) const;
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The date (year and month) when checking if eligible for divorced spouse benefit.
Collapse Expand Returns

Number of years of marriage needed to be eligible for a divorced spouse benefit.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::getMaxChildcareAge Method

PiaParamsPL::getMaxChildcareAge Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns maximum age of child for childcare dropout year.

C++
int getMaxChildcareAge() const;
Collapse Expand Returns

3.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::getMaxChildcareDropoutYears Method

PiaParamsPL::getMaxChildcareDropoutYears Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns maximum number of childcare dropout years.

C++
int getMaxChildcareDropoutYears(
    int,
    int
) const;
Collapse Expand Returns

3 for present law.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::getMfbColaCap Method

PiaParamsPL::getMfbColaCap Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns the amount of the cap on the COLA for the MFB for the given year.

C++
double getMfbColaCap(
    int
) const;
Collapse Expand Returns

Maximum float value.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::maxDibAge Method

PiaParamsPL::maxDibAge Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns maximum DI beneficiary age at end of year.

C++
Age maxDibAge(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of benefit.
Collapse Expand Returns

Maximum DI beneficiary age at end of year, based on present law.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


needColaCap Method

needColaCap Method
PiaParamsPL Methods

Returns true if a cola cap is required.

Collapse Expand Description

There are two versions of the needColaCap function. The one with a year argument checks to see if a cola cap is required for that specified year; the one with no arguments checks to see if a cola cap is required at any time.

Collapse Expand Overload List
Name | Description
PiaParamsPL::needColaCap () | Returns true if a cola cap is required at any time.
PiaParamsPL::needColaCap (int) | Returns true if a cola cap is required for a specified year.
Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Methods


PiaParamsPL::needColaCap Method ()

PiaParamsPL::needColaCap Method ()
PiaParamsPL Class PiaParamsPL Members needColaCap Method

Returns true if a cola cap is required at any time.

C++
bool needColaCap() const;
Collapse Expand Returns

Always returns false.

Collapse Expand Group

needColaCap Method

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, needColaCap Method


PiaParamsPL::needColaCap Method (int)

PiaParamsPL::needColaCap Method (int)
PiaParamsPL Class PiaParamsPL Members needColaCap Method

Returns true if a cola cap is required for a specified year.

C++
bool needColaCap(
    int
) const;
Collapse Expand Returns

Always returns false.

Collapse Expand Group

needColaCap Method

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, needColaCap Method


PiaParamsPL::projectCpiinc Method

PiaParamsPL::projectCpiinc Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Projects amounts dependent on benefit increases.

C++
void projectCpiinc();
Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::ribLimCal Method

PiaParamsPL::ribLimCal Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns widow(er) benefit reduced for RIB-LIM.

C++
double ribLimCal(
    double widowBen,
    double oabPia,
    double oabBen,
    const DateMoyr& benefitDate
) const;
Collapse Expand Parameters
Parameters | Description
double widowBen | Widow(er) benefit reduced for widow(er)'s age, but not for RIB-LIM.
double oabPia | PIA upon which widow(er) benefit is based. Note that this is not a re-indexed widow(er) PIA, since the OAB must have survived to age 62.
double oabBen | Benefit that deceased OAB was receiving.
const DateMoyr& benefitDate | The date of benefit.
Collapse Expand Returns

Reduced widow(er) benefit.

Collapse Expand Remarks

This should only be called in cases where the deceased worker was an OAB before death.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::setColaCap Method

PiaParamsPL::setColaCap Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Sets the amount of the cap on the COLA for the given year.

C++
void setColaCap(
    double,
    int
);
Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::setData Method

PiaParamsPL::setData Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Sets data from historical average wages and benefit increase file.

C++
void setData(
    AwbiData& awbiData
);
Collapse Expand Parameters
Parameters | Description
AwbiData& awbiData | Structure with historical average wages and benefit increases.
Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::setMfbColaCap Method

PiaParamsPL::setMfbColaCap Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Sets the amount of the cap on the COLA for the MFB for the given year.

C++
void setMfbColaCap(
    double,
    int
);
Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


PiaParamsPL::specMinAmountCal Method

PiaParamsPL::specMinAmountCal Method
PiaParamsPL Class PiaParamsPL Members PiaParamsPL Methods

Returns amount per year of coverage in special minimum.

C++
double specMinAmountCal(
    const DateMoyr& date
) const;
Collapse Expand Parameters
Parameters | Description
const DateMoyr& date | The date of desired amount.
Collapse Expand Returns

Amount per year of coverage in special minimum.

Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, PiaParamsPL Methods


specMinMaxYears Method

specMinMaxYears Method
PiaParamsPL Methods

Returns maximum number of usable years for special minimum.

Collapse Expand Description

There are two versions of the specMinMaxYears function. The one with two arguments returns the maximum number of usable years for special minimum for a specified year of eligibility and year of benefit. The one with no arguments returns the maximum number of usable years for any year of eligibility and year of benefit.

Collapse Expand Overload List
Name | Description
PiaParamsPL::specMinMaxYears () | Returns maximum number of usable years for special minimum.
PiaParamsPL::specMinMaxYears (int, int) | Returns maximum number of usable years for special minimum for a specified year of eligibility and year of benefit.
Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Methods


PiaParamsPL::specMinMaxYears Method ()

PiaParamsPL::specMinMaxYears Method ()
PiaParamsPL Class PiaParamsPL Members specMinMaxYears Method

Returns maximum number of usable years for special minimum.

C++
int specMinMaxYears() const;
Collapse Expand Returns

Maximum number of usable years for special minimum.

Collapse Expand Remarks

This version (with no arguments) returns the maximum number that could ever be for any year of eligibility and year of benefit.

Collapse Expand Group

specMinMaxYears Method

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, specMinMaxYears Method


PiaParamsPL::specMinMaxYears Method (int, int)

PiaParamsPL::specMinMaxYears Method (int, int)
PiaParamsPL Class PiaParamsPL Members specMinMaxYears Method

Returns maximum number of usable years for special minimum for a specified year of eligibility and year of benefit.

C++
int specMinMaxYears(
    int,
    int
) const;
Collapse Expand Returns

Maximum number of usable years for special minimum.

Collapse Expand Group

specMinMaxYears Method

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, specMinMaxYears Method


updateBases Method

updateBases Method
PiaParamsPL Methods

Updates wage bases.

Collapse Expand Description

There are two versions of the updateBases function. The one with five arguments updates wage bases for user entries and/or for average wage changes. The one with no arguments updates only for average wage changes.

Collapse Expand Overload List
Name | Description
PiaParamsPL::updateBases () | Updates wage bases for average wage changes.
PiaParamsPL::updateBases (const DoubleAnnual&, const DoubleAnnual&, BaseChangeType::change_type, int, int) |
Collapse Expand Group

PiaParamsPL Methods

Collapse Expand Links
PiaParamsPL Methods


PiaParamsPL::updateBases Method ()

PiaParamsPL::updateBases Method ()
PiaParamsPL Class PiaParamsPL Members updateBases Method

Updates wage bases for average wage changes.

C++
void updateBases();
Collapse Expand Group

updateBases Method

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, updateBases Method


PiaParamsPL::updateBases Method (const DoubleAnnual&, const DoubleAnnual&, BaseChangeType::change_type, int, int)

PiaParamsPL::updateBases Method (const DoubleAnnual&, const DoubleAnnual&, BaseChangeType::change_type, int, int)
PiaParamsPL Class PiaParamsPL Members updateBases Method
C++
void updateBases(
    const DoubleAnnual& userbase,
    const DoubleAnnual& userbase77,
    BaseChangeType::change_type ibasch,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& userbase | User-entered bases.
const DoubleAnnual& userbase77 | User-entered old-law bases.
BaseChangeType::change_type ibasch | Indicator for base changes.
int firstYeart | First year to update.
int lastYeart | Last year to update.
Collapse Expand Group

updateBases Method

Collapse Expand Links
PiaParamsPL Class, PiaParamsPL Members, updateBases Method


PiaParamsTR Class

PiaParamsTR Class
PiaParamsTR Data Members PiaParamsTR Methods PiaParamsTR Members PiaParamsTR.h Classes

Manages the present law Social Security parameters required to calculate Social Security benefits, with projected values set to Trustees Report assumptions.

Collapse Expand Class Hierarchy
  PiaParamsTRPiaParamsTRPiaParamsTR
C++
class PiaParamsTR : public PiaParamsPL;
Collapse Expand File

File: PiaParamsTR.h

Module: PiaData Library

Collapse Expand Remarks

Manages the present law Social Security parameters required to calculate Social Security benefits, with projected values set to Trustees Report assumptions.

Collapse Expand Group

Classes

Collapse Expand Links
PiaParamsTR Data Members, PiaParamsTR Methods, PiaParamsTR Members, PiaParamsTR.h, Classes


PiaParamsTR Members

PiaParamsTR Members
Enumerations PiaParamsTR Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PiaParamsTR.

Collapse Expand Enumerations
Name | Description
SPECMINPERCTYPE | The year range for the special minimum percentage.
Collapse Expand Class

PiaParamsTR Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
altNum | Trustees Report alternative (AssumptionType::assum_type::ALTERN_I, AssumptionType::assum_type::ALTERN_IIB, AssumptionType::assum_type::ALTERN_III, or AssumptionType::assum_type::ALTERN_IIA).
baseHi | HI wage bases.
bendOS | Bend points for old-start PIB formula.
catchup | Catch-up benefit increases.
cpiinc | Array of benefit increases.
fq | Array of annual average earnings.
fqinc | Array of percentage increases in annual average earnings.
istart | Current year (year after last known benefit increase).
maxyear | Maximum year allowed.
monthBeninc | Array of month of benefit increase.
noChange | Array of indicators for no change allowed.
percOS | Old-start PIB formula percentages.
percSpecMin | Percentage of old-law wage base required for year of coverage.
recalcInd | Indicator for which year(s) the PIA should be recalculated due to a newly effective law change.
specMinMfb | Special minimum mfbs.
specMinMfb2001 | Special minimum mfbs for August-November 2001.
specMinPerc | Percentage of old-law wage base required for year of coverage for special minimum.
specMinPia | Special minimum pias.
specMinPia2001 | Special minimum pias for August-November 2001.
titleAw | Title of average wage assumptions.
titleBi | Title of benefit increase assumptions.
yocAmountSpecMin | Amount required for year of coverage for special minimum.
yocAmountWindfall | Amount required for year of coverage for windfall elimination provision.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
YEAR1999 | Year of extra 0.1 percent benefit increase.
age16 | Age 16.
age18 | Age 18.
age19 | Age 19.
age199 | Age 199 (impossible age).
age22 | Age 22.
age50 | Age 50.
age60 | Age 60.
age62 | Age 62.
age621 | Age 62 and 1 month.
age65 | Age 65.
age65_10 | Age 65 and 10 months.
age65_2 | Age 65 and 2 months.
age65_4 | Age 65 and 4 months.
age65_6 | Age 65 and 6 months.
age65_8 | Age 65 and 8 months.
age66 | Age 66.
age66_10 | Age 66 and 10 months.
age66_2 | Age 66 and 2 months.
age66_4 | Age 66 and 4 months.
age66_6 | Age 66 and 6 months.
age66_8 | Age 66 and 8 months.
age67 | Age 67.
age70 | Age 70.
age72 | Age 72.
age75 | Age 75.
amend01 | The date of special 0.1 percent benefit increase.
amend118_273 | The date of WEP no longer being used for benefit computations.
amend50 | The date of 1950 amendments.
amend52 | The date of 1952 amendments.
amend54 | The date of 1954 amendments.
amend56 | The date of 1956 amendments.
amend561 | First birth date for which age 62 is effective for females.
amend562 | Second birth date for which age 62 is effective for females.
amend58 | The date of 1958 amendments.
amend61 | The date of 1961 amendments.
amend611 | First birth date for which age 62 is effective for males.
amend612 | Second birth date for which age 62 is effective for males.
amend651 | The date of 1965 amendments for benefit increase.
amend652 | The date of 1965 amendments for change to age 60.
amend653 | The date of 1965 amendments for old start.
amend671 | The date of 1967 amendments for old start.
amend672 | The date of 1967 amendments for benefit increase.
amend69 | The date of 1969 amendments.
amend70 | The date of 1970 amendments.
amend721 | The date of 1972 amendments for benefit increase.
amend722 | The date of 1972 amendments for special minimum.
amend741 | The date of 1974 amendments for partial increase.
amend742 | The date of 1974 amendments for full increase.
amend771 | The date of 1977 amendments for frozen pia table.
amend772 | The date of 1977 amendments for start of wage indexing.
amend80 | The date of 1980 amendments.
amend811 | The date of birth for age 62 and 1 month in 1981 amendments.
amend812 | The date of 1981 amendments (month, day, and year).
amend813 | The date of 1981 amendments (month and year).
amend82 | The date of 1982 amendments.
amend83 | The date of 1983 amendments.
amend88 | The date of 1988 amendments.
amend90 | The date of 1990 amendments.
amtperincyr | Amount per old start increment year.
arFactorWid285 | Total actuarial reduction factor for aged widow(er)s.
arMonthlyFactor65_67 | Monthly actuarial reduction factor between ages 65 and 67.
arMonthlyFactorOab62_65 | Monthly actuarial reduction factor between ages 62 and 65.
arMonthlyFactorSpouse62_65 | Monthly actuarial reduction factor for aged spouses between ages 62 and 65.
beninc74 | Temporary benefit increase, March-May 1974.
bpMfbOut | Table of mfb formula bend points.
bpPiaOut | Table of pia formula bend points.
factor150 | Factor for calculating mfbs.
factor175 | Factor for calculating mfbs.
factor50 | Factor for calculating life benefits.
factor75 | Factor for calculating survivor benefits.
factor825 | Factor for calculating widow(er) benefits.
maxMonthsAr62_65 | Maximum number of months of actuarial reduction between ages 62 and 65.
maxMonthsAr62_67 | Maximum number of months of actuarial reduction between ages 62 and 67.
maxMonthsAr65_67 | Maximum number of months of actuarial reduction between ages 65 and 67.
percPiaOut | Table of pia formula percentages.
qcamt | Array of amounts required for quarter of coverage.
qtr184 | Starting point of deemed insured.
year37qtr1 | First quarter for which a quarter of coverage could be earned.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PiaParams | Initializes a PiaParams, with or without a first year of projection.
PiaParamsPL | Initializes a PiaParamsPL, with or without a first year of projection.
PiaParamsTR | Constructor.
applyCola | Returns benefit amount increased by cola.
applyCola99 | Returns benefit amount increased by special 1999 cola (includes extra 0.1 percent increase).
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb99 | Returns maximum family benefit amount increased by special 1999 cola (includes extra 0.1 percent increase), with check that result is at least 150 percent of pia.
benincCatchUp | Applies catch-up benefit increases.
birthDateFRA | Returns the earliest birthdate for someone to be over NRA at the end of a year.
childAgeForMFCal | Returns oldest age of child for which parent can get young wife/husband or mother/father benefits.
deconvertPia | Deconverts PIA back to year of eligibility.
deemedQcReqCal | Returns number of quarters of coverage required for deemed insured status.
doRecalc | Returns true if should recalculate PIAs this year because of a newly effective law change, else false.
earlyAgeDisWidCal | Returns earliest possible disabled widow(er)'s retirement age.
earlyAgeOabCal | Returns earliest possible retirement age for oab or aged spouse.
earlyAgeOabCal | Sets earliest possible retirement age for old-age benie or aged spouse.
earlyAgeOabCalPL | Returns earliest possible retirement age for old-age benie or aged spouse, based on present law.
earlyAgeWidCal | Returns earliest possible aged widow(er)'s retirement age.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCalPL | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow(er) benefit before age reduction.
factorAgedWidCal | Returns factor for widow/widower benefit before age reduction.
factorAgedWidCalPL | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Returns reduction factor for wife/husband.
factorArAgedSpouseCal | Returns reduction factor for wife/husband.
factorArAgedSpouseCalPL | Calculates reduction factor for wife/husband. Assumes a maximum of 60 months of reduction.
factorArCal | Returns reduction factor for OAB.
factorArCal | Calculates reduction factor for OAB.
factorArCalPL | Calculates reduction factor for OAB or DIB.
factorArDisWidCal | Calculates reduction factor for disabled widow(er).
factorArWidCal | Calculates reduction factor for aged widow(er).
factorDisWidCal | Returns factor for disabled widow(er) benefit before age reduction.
factorDisWidCal | Returns factor for disabled widow/widower benefit before age reduction.
factorDisWidCalPL | Returns factor for disabled widow/widower benefit before age reduction.
factorDriCal | Calculates delayed retirement increment factor for OAB.
factorYngLifeCal | Calculates reduction factor for young life benie.
factorYngSurvCal | Calculates reduction factor for young survivor.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDIPL | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalPL | Returns full retirement age based on present law.
getAltNum | Returns the Trustees Report assumption.
getAverageWage | Returns title of average wage assumptions.
getBase77 | Returns one old-law wage base.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBase77Array | Returns the array of old-law wage bases.
getBaseHi | Returns one HI wage base.
getBaseHiArray | Returns the array of HI wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBendOS | Returns a bend point for old-start PIB formula.
getBenefitInc | Returns title of benefit increase assumptions.
getCatchup | Returns catch-up benefit increases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmountPL | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getCpiinc | Returns one benefit increase.
getCpiincArray | Returns the array of benefit increases.
getFq | Returns one average wage for indexing.
getFqArray | Returns array of average wages for indexing.
getFqBppia | Returns series used for indexing pia formula bend points.
getFqBppia | Returns series of average wages used for indexing pia formula bend points.
getFqIndex | Returns series used for indexing an earnings record.
getFqIndex | Returns series of average wages used for indexing an earnings record.
getFqinc | Returns one increase in average wage for indexing.
getFqincArray | Returns array of increases in average wage for indexing.
getIstart | Returns current year.
getMarrLengthForDivBen | Returns the number of years of marraige needed to be eligible for a divroced spouse benefit.
getMarrLengthForDivBen | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMarrLengthForDivBenPL | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year.
getMaxChildcareAgePL | Returns maximum age of child for childcare dropout year.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYearsPL | Returns maximum number of childcare dropout years.
getMaxyear | Returns maximum possible year.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB for the given year.
getMonthBeninc | Returns one month of benefit increase.
getMonthBenincArray | Returns array of months of benefit increase.
getPercOS | Returns old-start PIB formula percentage.
getPercSpecMin | Returns percent of old-law base required for year of coverage.
getPercSpecMinArray | Returns array of percents of old-law base required for year of coverage.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinPerc | Returns percentage of old-law base required for year of coverage.
getSpecMinPia | Returns special minimum pia as of a specified month.
getYocAmountSpecMin | Returns amount required for year of coverage for special minimum.
getYocAmountSpecMinArray | Returns array of amounts required for year of coverage for special minimum.
getYocAmountWindfallArray | Returns array of amounts required for year of coverage for windfall elimination.
initdata | Initializes some data.
isApplicableCola99 | Checks for applicability of special 1999 increase (with extra 0.1 percent).
lastAmw | Finds last AMW in old-law table.
lumpSum | Returns amount of lump sum benefit.
maxChildAge | Returns maximum child beneficiary age.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAgePL | Returns maximum DI beneficiary age at end of year, based on present law.
monthsArAgedSpouseCal | Calculates number of months of actuarial reduction for aged wife/husband.
monthsArCal | Calculates number of months of actuarial reduction for OAB.
monthsArDICal | Calculates number of months of reduction for disabled worker.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er).
monthsArWidCal | Calculates number of months of actuarial reduction for aged widow(er).
monthsDriCal | Calculates number of months of delayed retirement credit for OAB.
needColaCap | Returns true if a cola cap is required.
needColaCap | Returns true if a cola cap is required.
percPiaCal | Sets benefit formula percents.
projectCpiinc | Projects amounts dependent on benefit increases.
projectCpiinc | Projects amounts dependent on benefit increases.
projectFq | Projects amounts dependent on the average annual wage.
projectPerc | Projects benefit formula percentages.
projectSpecMin | Projects special minimum amounts.
qcCal | Returns number of quarters of coverage for one year, applying annual test.
resizeSpecMin | Resizes special minimum arrays.
retCredit | Returns amount of monthly delayed retirement credit.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCalPL | Returns widow(er) benefit reduced for RIB-LIM.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setData | Sets data from historical average wages and benefit increase file.
setData | Sets data from historical average wages and benefit increase file.
setHistFqinc | Sets historical average wage increases.
setIstart | Sets the first projected year, including for members.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
setNoChange | Sets indicators for no change allowed.
specMinAmountCal | Sets amount per year of coverage in special minimum.
specMinAmountCal | Returns amount per year of coverage in special minimum.
specMinAmountCalPL | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYearsPL | Returns maximum number of usable years for special minimum.
unApplyCola | Returns benefit amount decreased by cola.
unApplyCola99 | Returns benefit amount decreased by special 1999 cola (includes extra 0.1 percent decrease.)
unbiCatchUp | Divides out catch-up benefit increases.
updateBases | Updates wage bases.
updateBases | Updates wage bases.
updateCpiinc | Updates benefit increases.
updateFq | Updates average wages, using specified amounts.
updateFqinc | Updates increases in average wages, using specified percentages.
updateYocAmountSpecMin | Updates amounts required for special minimum year of coverage.
~PiaParamsTR | Destructor.
Collapse Expand Links
Enumerations, PiaParamsTR Class, Legend, Protected Data Members, Public Data Members, Public Methods


PiaParamsTR::PiaParamsTR Constructor

PiaParamsTR::PiaParamsTR Constructor
PiaParamsTR Class PiaParamsTR Members PiaParamsTR Class

Constructor.

C++
PiaParamsTR(
    int newMaxyear,
    AssumptionType::assum_type newAltNum
);
Collapse Expand Parameters
Parameters | Description
int newMaxyear | Maximum projected year.
AssumptionType::assum_type newAltNum | The Trustees Report alternative.
Collapse Expand Class

PiaParamsTR Class

Collapse Expand Links
PiaParamsTR Class, PiaParamsTR Members, PiaParamsTR Class


PiaParamsTR::~PiaParamsTR Destructor

PiaParamsTR::~PiaParamsTR Destructor
PiaParamsTR Class PiaParamsTR Members PiaParamsTR Class

Destructor.

C++
~PiaParamsTR();
Collapse Expand Class

PiaParamsTR Class

Collapse Expand Links
PiaParamsTR Class, PiaParamsTR Members, PiaParamsTR Class


PiaParamsTR Data Members

PiaParamsTR Data Members
PiaParamsTR Class Legend Protected Data Members

The data members of the PiaParamsTR class are listed here.

Collapse Expand Class

PiaParamsTR Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
altNum | Trustees Report alternative (AssumptionType::assum_type::ALTERN_I, AssumptionType::assum_type::ALTERN_IIB, AssumptionType::assum_type::ALTERN_III, or AssumptionType::assum_type::ALTERN_IIA).
Collapse Expand Links
PiaParamsTR Class, Legend, Protected Data Members


PiaParamsTR::altNum Data Member

PiaParamsTR::altNum Data Member
PiaParamsTR Class PiaParamsTR Members PiaParamsTR Data Members

Trustees Report alternative (AssumptionType::assum_type::ALTERN_I, AssumptionType::assum_type::ALTERN_IIB, AssumptionType::assum_type::ALTERN_III, or AssumptionType::assum_type::ALTERN_IIA).

C++
const AssumptionType::assum_type altNum;
Collapse Expand Group

PiaParamsTR Data Members

Collapse Expand Links
PiaParamsTR Class, PiaParamsTR Members, PiaParamsTR Data Members


PiaParamsTR Methods

PiaParamsTR Methods
PiaParamsTR Class Legend Public Methods

The methods of the PiaParamsTR class are listed here.

Collapse Expand Class

PiaParamsTR Class

Collapse Expand Public Methods
Name | Description
getAltNum | Returns the Trustees Report assumption.
Collapse Expand Links
PiaParamsTR Class, Legend, Public Methods


PiaParamsTR::getAltNum Method

PiaParamsTR::getAltNum Method
PiaParamsTR Class PiaParamsTR Members PiaParamsTR Methods

Returns the Trustees Report assumption.

C++
AssumptionType::assum_type getAltNum() const;
Collapse Expand Returns

The Trustees Report assumption.

Collapse Expand Group

PiaParamsTR Methods

Collapse Expand Links
PiaParamsTR Class, PiaParamsTR Members, PiaParamsTR Methods


PiaRead Class

PiaRead Class
PiaRead Data Members PiaRead Methods PiaRead Members piaread.h Classes

Reads the basic data required to calculate a Social Security benefit.

Collapse Expand Class Hierarchy
  PiaRead
C++
class PiaRead;
Collapse Expand File

File: piaread.h

Module: PiaData Library

Collapse Expand Remarks

This version is used in programs such as microsimulations, which do not use Social Security Statements or factors to project earnings. For programs that do use those things, such as Anypia, use the subclass PiaReadAny.

Collapse Expand See Also

PiaReadAny

Collapse Expand Group

Classes

Collapse Expand Links
PiaRead Data Members, PiaRead Methods, PiaRead Members, piaread.h, Classes


PiaRead Members

PiaRead Members
PiaRead Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PiaRead.

Collapse Expand Class

PiaRead Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
secondaryArray | Array of Secondary benefit information.
userAssumptions | User-specified assumptions.
widowArray | Widow and other family member calculation data.
widowDataArray | Widow and other family member basic data.
workerData | Worker data.
Collapse Expand Public Data Members
Name | Description
inputLine | Input line.
lineType | Type of input line.
unusedLine | True if a line has been gotten from the file but not used.
Collapse Expand Public Methods
Name | Description
PiaRead | Initializes references to data.
getEarnWidth | Returns width of earnings or base field.
getWidth | Returns width of field for line number in file.
parseAssump | Parses assumption indicators.
parseAw | Parses projected average wage increases.
parseBack | Parses backward projection amounts.
parseBases | Parses up to 20 OASDI wage bases.
parseBases77 | Parses up to 20 old-law wage bases.
parseBendate | Parses date of benefit.
parseBi | Parses up to 20 projected benefit increases.
parseBlind | Parses blind indicator.
parseCatchup | Parses 8 catch-up benefit increases.
parseChildCareYears | Parses annual child care years.
parseDeath | Parses date of death.
parseDeemed | Parses deemed insured indicator.
parseDisab1 | Parses disability information for most recent period.
parseDisab2 | Parses disability information for second most recent period.
parseEarnHi | Parses up to 10 years of Medicare earnings.
parseEarnOasdi | Parses OASDI-covered earnings for up to 10 years.
parseEarnType | Parses type of earnings vector.
parseFamilyMember | Parses family member's information.
parseFwrd | Parses forward projection amounts.
parseMsdates | Parses military service dates.
parseNhaddr | Parses worker's address.
parseNhname | Parses worker's name.
parseOabent | Parses oab entitlement prior to most recent disability.
parsePebes | Parses Social Security Statement information.
parsePubpen | Parses noncovered pension.
parsePubpenReservist | Parses noncovered pension after military reservist pension removal.
parseQc1 | Parses summary quarters of coverage.
parseQc2 | Parses annual quarters of coverage.
parseSsn | Parses Social Security number, sex, and date of birth.
parseTaxType | Parses type of taxes.
parseTitleaw | Parses title of projected average wage increases.
parseTitlebi | Parses title of projected benefit increases.
parseTob | Parses type of benefit and date of entitlement.
parseTotalize | Parses totalization indicator.
parseYears | Parses years of earnings.
read | Reads case from file.
setEarnProjectYears | Sets the years in the EarnProject class.
setEarnWidth | Sets width of earnings or base field.
setPebsData | Sets data for Social Security Statement.
setWidth | Sets width of field for line number in file,
Collapse Expand Links
PiaRead Class, Legend, Protected Data Members, Public Data Members, Public Methods


PiaRead::PiaRead Constructor

PiaRead::PiaRead Constructor
PiaRead Class PiaRead Members PiaRead Class

Initializes references to data.

C++
PiaRead(
    WorkerData& newWorkerData,
    WorkerDataArray& newWidowDataArray,
    PiaDataArray& newWidowArray,
    UserAssumptions& newUserAssumptions,
    SecondaryArray& newSecondaryArray
);
Collapse Expand Parameters
Parameters | Description
WorkerData& newWorkerData | Worker's calculation data.
WorkerDataArray& newWidowDataArray | Widow and other family members' basic data.
PiaDataArray& newWidowArray | Widow and other family members' calculation data.
UserAssumptions& newUserAssumptions | User-specified assumptions.
SecondaryArray& newSecondaryArray | Array of Secondary benefit information.
Collapse Expand Class

PiaRead Class

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Class


PiaRead Data Members

PiaRead Data Members
PiaRead Class Legend Protected Data Members Public Data Members

The data members of the PiaRead class are listed here.

Collapse Expand Class

PiaRead Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
secondaryArray | Array of Secondary benefit information.
userAssumptions | User-specified assumptions.
widowArray | Widow and other family member calculation data.
widowDataArray | Widow and other family member basic data.
workerData | Worker data.
Collapse Expand Public Data Members
Name | Description
inputLine | Input line.
lineType | Type of input line.
unusedLine | True if a line has been gotten from the file but not used.
Collapse Expand Links
PiaRead Class, Legend, Protected Data Members, Public Data Members


PiaRead::inputLine Data Member

PiaRead::inputLine Data Member
PiaRead Class PiaRead Members PiaRead Data Members

Input line.

C++
std::string inputLine;
Collapse Expand Group

PiaRead Data Members

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Data Members


PiaRead::lineType Data Member

PiaRead::lineType Data Member
PiaRead Class PiaRead Members PiaRead Data Members

Type of input line.

C++
int lineType;
Collapse Expand Group

PiaRead Data Members

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Data Members


PiaRead::secondaryArray Data Member

PiaRead::secondaryArray Data Member
PiaRead Class PiaRead Members PiaRead Data Members

Array of Secondary benefit information.

C++
SecondaryArray& secondaryArray;
Collapse Expand Group

PiaRead Data Members

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Data Members


PiaRead::unusedLine Data Member

PiaRead::unusedLine Data Member
PiaRead Class PiaRead Members PiaRead Data Members

True if a line has been gotten from the file but not used.

C++
bool unusedLine;
Collapse Expand Group

PiaRead Data Members

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Data Members


PiaRead::userAssumptions Data Member

PiaRead::userAssumptions Data Member
PiaRead Class PiaRead Members PiaRead Data Members

User-specified assumptions.

C++
UserAssumptions& userAssumptions;
Collapse Expand Group

PiaRead Data Members

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Data Members


PiaRead::widowArray Data Member

PiaRead::widowArray Data Member
PiaRead Class PiaRead Members PiaRead Data Members

Widow and other family member calculation data.

C++
PiaDataArray& widowArray;
Collapse Expand Group

PiaRead Data Members

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Data Members


PiaRead::widowDataArray Data Member

PiaRead::widowDataArray Data Member
PiaRead Class PiaRead Members PiaRead Data Members

Widow and other family member basic data.

C++
WorkerDataArray& widowDataArray;
Collapse Expand Group

PiaRead Data Members

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Data Members


PiaRead::workerData Data Member

PiaRead::workerData Data Member
PiaRead Class PiaRead Members PiaRead Data Members

Worker data.

C++
WorkerData& workerData;
Collapse Expand Group

PiaRead Data Members

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Data Members


PiaRead Methods

PiaRead Methods
PiaRead Class Legend Public Methods

The methods of the PiaRead class are listed here.

Collapse Expand Class

PiaRead Class

Collapse Expand Public Methods
Name | Description
getEarnWidth | Returns width of earnings or base field.
getWidth | Returns width of field for line number in file.
parseAssump | Parses assumption indicators.
parseAw | Parses projected average wage increases.
parseBack | Parses backward projection amounts.
parseBases | Parses up to 20 OASDI wage bases.
parseBases77 | Parses up to 20 old-law wage bases.
parseBendate | Parses date of benefit.
parseBi | Parses up to 20 projected benefit increases.
parseBlind | Parses blind indicator.
parseCatchup | Parses 8 catch-up benefit increases.
parseChildCareYears | Parses annual child care years.
parseDeath | Parses date of death.
parseDeemed | Parses deemed insured indicator.
parseDisab1 | Parses disability information for most recent period.
parseDisab2 | Parses disability information for second most recent period.
parseEarnHi | Parses up to 10 years of Medicare earnings.
parseEarnOasdi | Parses OASDI-covered earnings for up to 10 years.
parseEarnType | Parses type of earnings vector.
parseFamilyMember | Parses family member's information.
parseFwrd | Parses forward projection amounts.
parseMsdates | Parses military service dates.
parseNhaddr | Parses worker's address.
parseNhname | Parses worker's name.
parseOabent | Parses oab entitlement prior to most recent disability.
parsePebes | Parses Social Security Statement information.
parsePubpen | Parses noncovered pension.
parsePubpenReservist | Parses noncovered pension after military reservist pension removal.
parseQc1 | Parses summary quarters of coverage.
parseQc2 | Parses annual quarters of coverage.
parseSsn | Parses Social Security number, sex, and date of birth.
parseTaxType | Parses type of taxes.
parseTitleaw | Parses title of projected average wage increases.
parseTitlebi | Parses title of projected benefit increases.
parseTob | Parses type of benefit and date of entitlement.
parseTotalize | Parses totalization indicator.
parseYears | Parses years of earnings.
read | Reads case from file.
setEarnProjectYears | Sets the years in the EarnProject class.
setEarnWidth | Sets width of earnings or base field.
setPebsData | Sets data for Social Security Statement.
setWidth | Sets width of field for line number in file,
Collapse Expand Links
PiaRead Class, Legend, Public Methods


PiaRead::getEarnWidth Method

PiaRead::getEarnWidth Method
PiaRead Class PiaRead Members PiaRead Methods

Returns width of earnings or base field.

C++
int getEarnWidth() const;
Collapse Expand Returns

Width of earnings or base field.

Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::getWidth Method

PiaRead::getWidth Method
PiaRead Class PiaRead Members PiaRead Methods

Returns width of field for line number in file.

C++
int getWidth() const;
Collapse Expand Returns

Width of field for line number in file.

Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseAssump Method

PiaRead::parseAssump Method
PiaRead Class PiaRead Members PiaRead Methods

Parses assumption indicators.

C++
void parseAssump(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseAw Method

PiaRead::parseAw Method
PiaRead Class PiaRead Members PiaRead Methods

Parses projected average wage increases.

C++
void parseAw(
    int lineNumber,
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
int lineNumber | Number of increase line (0-3).
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseBack Method

PiaRead::parseBack Method
PiaRead Class PiaRead Members PiaRead Methods

Parses backward projection amounts.

C++
virtual void parseBack(
    const std::string&
);
Collapse Expand Remarks

This version does nothing.

Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseBases Method

PiaRead::parseBases Method
PiaRead Class PiaRead Members PiaRead Methods

Parses up to 20 OASDI wage bases.

C++
void parseBases(
    int lineNumber,
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
int lineNumber | Number of earnings line (0-3).
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseBases77 Method

PiaRead::parseBases77 Method
PiaRead Class PiaRead Members PiaRead Methods

Parses up to 20 old-law wage bases.

C++
void parseBases77(
    int lineNumber,
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
int lineNumber | Number of earnings line (0-3).
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseBendate Method

PiaRead::parseBendate Method
PiaRead Class PiaRead Members PiaRead Methods

Parses date of benefit.

C++
void parseBendate(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseBi Method

PiaRead::parseBi Method
PiaRead Class PiaRead Members PiaRead Methods

Parses up to 20 projected benefit increases.

C++
void parseBi(
    int lineNumber,
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
int lineNumber | Number of increase line (0-3)
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseBlind Method

PiaRead::parseBlind Method
PiaRead Class PiaRead Members PiaRead Methods

Parses blind indicator.

C++
void parseBlind(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseCatchup Method

PiaRead::parseCatchup Method
PiaRead Class PiaRead Members PiaRead Methods

Parses 8 catch-up benefit increases.

C++
void parseCatchup(
    int lineNumber,
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
int lineNumber | Line number of increases (0-9).
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseChildCareYears Method

PiaRead::parseChildCareYears Method
PiaRead Class PiaRead Members PiaRead Methods

Parses annual child care years.

C++
void parseChildCareYears(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseDeath Method

PiaRead::parseDeath Method
PiaRead Class PiaRead Members PiaRead Methods

Parses date of death.

C++
void parseDeath(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseDeemed Method

PiaRead::parseDeemed Method
PiaRead Class PiaRead Members PiaRead Methods

Parses deemed insured indicator.

C++
void parseDeemed(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseDisab1 Method

PiaRead::parseDisab1 Method
PiaRead Class PiaRead Members PiaRead Methods

Parses disability information for most recent period.

C++
void parseDisab1(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseDisab2 Method

PiaRead::parseDisab2 Method
PiaRead Class PiaRead Members PiaRead Methods

Parses disability information for second most recent period.

C++
void parseDisab2(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseEarnHi Method

PiaRead::parseEarnHi Method
PiaRead Class PiaRead Members PiaRead Methods

Parses up to 10 years of Medicare earnings.

C++
void parseEarnHi(
    int lineNumber,
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
int lineNumber | Number of earnings line (0-7).
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseEarnOasdi Method

PiaRead::parseEarnOasdi Method
PiaRead Class PiaRead Members PiaRead Methods

Parses OASDI-covered earnings for up to 10 years.

C++
virtual void parseEarnOasdi(
    int lineNumber,
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
int lineNumber | Number of earnings line (0-7).
const std::string& line | Line to parse.
Collapse Expand Remarks

This version does not have any projection.

Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseEarnType Method

PiaRead::parseEarnType Method
PiaRead Class PiaRead Members PiaRead Methods

Parses type of earnings vector.

C++
virtual void parseEarnType(
    const std::string&
);
Collapse Expand Remarks

This version does nothing.

Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseFamilyMember Method

PiaRead::parseFamilyMember Method
PiaRead Class PiaRead Members PiaRead Methods

Parses family member's information.

C++
void parseFamilyMember(
    int lineNumber,
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
int lineNumber | Family member number (0 to 14).
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseFwrd Method

PiaRead::parseFwrd Method
PiaRead Class PiaRead Members PiaRead Methods

Parses forward projection amounts.

C++
virtual void parseFwrd(
    const std::string&
);
Collapse Expand Remarks

This version does nothing.

Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseMsdates Method

PiaRead::parseMsdates Method
PiaRead Class PiaRead Members PiaRead Methods

Parses military service dates.

C++
void parseMsdates(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseNhaddr Method

PiaRead::parseNhaddr Method
PiaRead Class PiaRead Members PiaRead Methods

Parses worker's address.

C++
void parseNhaddr(
    int lineNumber,
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
int lineNumber | Address line number (0-2).
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseNhname Method

PiaRead::parseNhname Method
PiaRead Class PiaRead Members PiaRead Methods

Parses worker's name.

C++
void parseNhname(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseOabent Method

PiaRead::parseOabent Method
PiaRead Class PiaRead Members PiaRead Methods

Parses oab entitlement prior to most recent disability.

C++
void parseOabent(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parsePebes Method

PiaRead::parsePebes Method
PiaRead Class PiaRead Members PiaRead Methods

Parses Social Security Statement information.

C++
virtual void parsePebes(
    const std::string&
);
Collapse Expand Parameters
Parameters | Description
line | Line to parse.
Collapse Expand Remarks

This version does nothing.

Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parsePubpen Method

PiaRead::parsePubpen Method
PiaRead Class PiaRead Members PiaRead Methods

Parses noncovered pension.

C++
void parsePubpen(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parsePubpenReservist Method

PiaRead::parsePubpenReservist Method
PiaRead Class PiaRead Members PiaRead Methods

Parses noncovered pension after military reservist pension removal.

C++
void parsePubpenReservist(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseQc1 Method

PiaRead::parseQc1 Method
PiaRead Class PiaRead Members PiaRead Methods

Parses summary quarters of coverage.

C++
void parseQc1(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseQc2 Method

PiaRead::parseQc2 Method
PiaRead Class PiaRead Members PiaRead Methods

Parses annual quarters of coverage.

C++
void parseQc2(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseSsn Method

PiaRead::parseSsn Method
PiaRead Class PiaRead Members PiaRead Methods

Parses Social Security number, sex, and date of birth.

C++
void parseSsn(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseTaxType Method

PiaRead::parseTaxType Method
PiaRead Class PiaRead Members PiaRead Methods

Parses type of taxes.

C++
void parseTaxType(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseTitleaw Method

PiaRead::parseTitleaw Method
PiaRead Class PiaRead Members PiaRead Methods

Parses title of projected average wage increases.

C++
void parseTitleaw(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseTitlebi Method

PiaRead::parseTitlebi Method
PiaRead Class PiaRead Members PiaRead Methods

Parses title of projected benefit increases.

C++
void parseTitlebi(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseTob Method

PiaRead::parseTob Method
PiaRead Class PiaRead Members PiaRead Methods

Parses type of benefit and date of entitlement.

C++
void parseTob(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Remarks

The date of entitlement is ignored in a survivor case. The date of benefit is set equal to date of entitlement. This will be overwritten if there is a line 4.

Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseTotalize Method

PiaRead::parseTotalize Method
PiaRead Class PiaRead Members PiaRead Methods

Parses totalization indicator.

C++
void parseTotalize(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::parseYears Method

PiaRead::parseYears Method
PiaRead Class PiaRead Members PiaRead Methods

Parses years of earnings.

C++
void parseYears(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::read Method

PiaRead::read Method
PiaRead Class PiaRead Members PiaRead Methods

Reads case from file.

C++
unsigned int read(
    std::istream& in
);
Collapse Expand Parameters
Parameters | Description
std::istream& in | Input stream.
Collapse Expand Returns

Returns one of the following possible values:

  • 0: successful read, with another record following.
  • PIA_IDS_READEOF successful read, with end of file following.
  • PIA_IDS_READMORE successful read, with additional data following (for subclass).
  • Other positive value: unsuccessful read.
Collapse Expand Remarks

Call WorkerDataGeneral::deleteContents for the worker and each family member before this function if reading more than one case.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_READERR if error reading file.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::setEarnProjectYears Method

PiaRead::setEarnProjectYears Method
PiaRead Class PiaRead Members PiaRead Methods

Sets the years in the EarnProject class.

C++
virtual void setEarnProjectYears(
    int,
    int
);
Collapse Expand Remarks

This version does nothing.

Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::setEarnWidth Method

PiaRead::setEarnWidth Method
PiaRead Class PiaRead Members PiaRead Methods

Sets width of earnings or base field.

C++
void setEarnWidth(
    int newWidth
);
Collapse Expand Parameters
Parameters | Description
int newWidth | New width of earnings or base field.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::setPebsData Method

PiaRead::setPebsData Method
PiaRead Class PiaRead Members PiaRead Methods

Sets data for Social Security Statement.

C++
virtual void setPebsData();
Collapse Expand Remarks

Calls WorkerDataGeneral::setPebsData.

Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaRead::setWidth Method

PiaRead::setWidth Method
PiaRead Class PiaRead Members PiaRead Methods

Sets width of field for line number in file,

C++
void setWidth(
    int newWidth
);
Collapse Expand Parameters
Parameters | Description
int newWidth | New width of field for line number.
Collapse Expand Group

PiaRead Methods

Collapse Expand Links
PiaRead Class, PiaRead Members, PiaRead Methods


PiaReadAny Class

PiaReadAny Class
PiaReadAny Methods PiaReadAny Members piareadAny.h Classes

Reads the data required to calculate a Social Security benefit for the Anypia program.

Collapse Expand Class Hierarchy
  PiaReadAnyPiaReadAny
C++
class PiaReadAny : public PiaRead;
Collapse Expand File

File: piareadAny.h

Module: PiaData Library

Collapse Expand Remarks

This version adds data required for Social Security Statements and factors to project earnings.

Collapse Expand Group

Classes

Collapse Expand Links
PiaReadAny Methods, PiaReadAny Members, piareadAny.h, Classes


PiaReadAny Members

PiaReadAny Members
PiaReadAny Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PiaReadAny.

Collapse Expand Class

PiaReadAny Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
secondaryArray | Array of Secondary benefit information.
userAssumptions | User-specified assumptions.
widowArray | Widow and other family member calculation data.
widowDataArray | Widow and other family member basic data.
workerData | Worker data.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
inputLine | Input line.
lineType | Type of input line.
unusedLine | True if a line has been gotten from the file but not used.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PiaReadAny | Initializes references to data.
getEarnWidth | Returns width of earnings or base field.
getWidth | Returns width of field for line number in file.
parseAssump | Parses assumption indicators.
parseAw | Parses projected average wage increases.
parseBack | Parses backward projection amounts.
parseBases | Parses up to 20 OASDI wage bases.
parseBases77 | Parses up to 20 old-law wage bases.
parseBendate | Parses date of benefit.
parseBi | Parses up to 20 projected benefit increases.
parseBlind | Parses blind indicator.
parseCatchup | Parses 8 catch-up benefit increases.
parseChildCareYears | Parses annual child care years.
parseDeath | Parses date of death.
parseDeemed | Parses deemed insured indicator.
parseDisab1 | Parses disability information for most recent period.
parseDisab2 | Parses disability information for second most recent period.
parseEarnHi | Parses up to 10 years of Medicare earnings.
parseEarnOasdi | Parses OASDI-covered earnings for up to 10 years.
parseEarnType | Parses type of earnings vector.
parseFamilyMember | Parses family member's information.
parseFwrd | Parses forward projection amounts.
parseMsdates | Parses military service dates.
parseNhaddr | Parses worker's address.
parseNhname | Parses worker's name.
parseOabent | Parses oab entitlement prior to most recent disability.
parsePebes | Parses Social Security Statement information.
parsePubpen | Parses noncovered pension.
parsePubpenReservist | Parses noncovered pension after military reservist pension removal.
parseQc1 | Parses summary quarters of coverage.
parseQc2 | Parses annual quarters of coverage.
parseSsn | Parses Social Security number, sex, and date of birth.
parseTaxType | Parses type of taxes.
parseTitleaw | Parses title of projected average wage increases.
parseTitlebi | Parses title of projected benefit increases.
parseTob | Parses type of benefit and date of entitlement.
parseTotalize | Parses totalization indicator.
parseYears | Parses years of earnings.
read | Reads case from file.
setEarnProjectYears | Sets the years in the EarnProject class.
setEarnWidth | Sets width of earnings or base field.
setPebsData | Sets data for Social Security Statement.
setWidth | Sets width of field for line number in file,
Collapse Expand Links
PiaReadAny Class, Legend, Protected Data Members, Public Data Members, Public Methods


PiaReadAny::PiaReadAny Constructor

PiaReadAny::PiaReadAny Constructor
PiaReadAny Class PiaReadAny Members PiaReadAny Class

Initializes references to data.

C++
PiaReadAny(
    WorkerData& newWorkerData,
    WorkerDataArray& newWidowDataArray,
    PiaDataArray& newWidowArray,
    UserAssumptions& newUserAssumptions,
    SecondaryArray& newSecondaryArray,
    EarnProject& newEarnProject,
    Pebs& newPebs
);
Collapse Expand Parameters
Parameters | Description
WorkerData& newWorkerData | Worker's calculation data.
WorkerDataArray& newWidowDataArray | Widow and other family members' basic data.
PiaDataArray& newWidowArray | Widow and other family members' calculation data.
UserAssumptions& newUserAssumptions | User-specified assumptions.
SecondaryArray& newSecondaryArray | Array of Secondary benefit information.
EarnProject& newEarnProject | Projected earnings.
Pebs& newPebs | Statement information.
Collapse Expand Class

PiaReadAny Class

Collapse Expand Links
PiaReadAny Class, PiaReadAny Members, PiaReadAny Class


PiaReadAny Methods

PiaReadAny Methods
PiaReadAny Class Legend Public Methods

The methods of the PiaReadAny class are listed here.

Collapse Expand Class

PiaReadAny Class

Collapse Expand Public Methods
Name | Description
parseBack | Parses backward projection amounts.
parseEarnOasdi | Parses OASDI-covered earnings for up to 10 years.
parseEarnType | Parses type of earnings vector.
parseFwrd | Parses forward projection amounts.
parsePebes | Parses Social Security Statement information.
setEarnProjectYears | Sets the years in the EarnProject class.
setPebsData | Sets data for Social Security Statement.
Collapse Expand Links
PiaReadAny Class, Legend, Public Methods


PiaReadAny::parseBack Method

PiaReadAny::parseBack Method
PiaReadAny Class PiaReadAny Members PiaReadAny Methods

Parses backward projection amounts.

C++
void parseBack(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Remarks

Parses the projection type, the percentage factor, and the beginning year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_READERR if unable to parse the line successfully.
Collapse Expand Group

PiaReadAny Methods

Collapse Expand Links
PiaReadAny Class, PiaReadAny Members, PiaReadAny Methods


PiaReadAny::parseEarnOasdi Method

PiaReadAny::parseEarnOasdi Method
PiaReadAny Class PiaReadAny Members PiaReadAny Methods

Parses OASDI-covered earnings for up to 10 years.

C++
void parseEarnOasdi(
    int lineNumber,
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
int lineNumber | Number of earnings line (0-7).
const std::string& line | Line to parse.
Collapse Expand Remarks

Includes projected earnings.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_READERR if unable to parse the line successfully.
Collapse Expand Group

PiaReadAny Methods

Collapse Expand Links
PiaReadAny Class, PiaReadAny Members, PiaReadAny Methods


PiaReadAny::parseEarnType Method

PiaReadAny::parseEarnType Method
PiaReadAny Class PiaReadAny Members PiaReadAny Methods

Parses type of earnings vector.

C++
void parseEarnType(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Remarks

Parses the first and last years, and the earnings type for each year in that span.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_READERR if unable to parse the line successfully.
Collapse Expand Group

PiaReadAny Methods

Collapse Expand Links
PiaReadAny Class, PiaReadAny Members, PiaReadAny Methods


PiaReadAny::parseFwrd Method

PiaReadAny::parseFwrd Method
PiaReadAny Class PiaReadAny Members PiaReadAny Methods

Parses forward projection amounts.

C++
void parseFwrd(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Remarks

Parses the projection type, the percentage factor, and the ending year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_READERR if unable to parse the line successfully.
Collapse Expand Group

PiaReadAny Methods

Collapse Expand Links
PiaReadAny Class, PiaReadAny Members, PiaReadAny Methods


PiaReadAny::parsePebes Method

PiaReadAny::parsePebes Method
PiaReadAny Class PiaReadAny Members PiaReadAny Methods

Parses Social Security Statement information.

C++
void parsePebes(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Remarks

Parses the month of the statement and the planned age of retirement.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_READERR if unable to parse the line successfully.
Collapse Expand Group

PiaReadAny Methods

Collapse Expand Links
PiaReadAny Class, PiaReadAny Members, PiaReadAny Methods


PiaReadAny::setEarnProjectYears Method

PiaReadAny::setEarnProjectYears Method
PiaReadAny Class PiaReadAny Members PiaReadAny Methods

Sets the years in the EarnProject class.

C++
void setEarnProjectYears(
    int year1,
    int year2
);
Collapse Expand Parameters
Parameters | Description
int year1 | The first year of earnings.
int year2 | The last year of earnings.
Collapse Expand Remarks

Sets the first and last years, then checks them by calling EarnProject::yearsCheck.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_END1 if first year of earnings in forward projection period is before last year of earnings in backward projection period; of type PIA_IDS_END3 if first year of earnings in forward projection period is after last year of earnings in forward projection period; of type PIA_IDS_END4 if the total number of years of earnings is greater than the maximum allowed (MAXYRS); of type PIA_IDS_END1 if last year of earnings is before 1937; of type PIA_IDS_END2 if last year of earnings is after maximum year allowed.
Collapse Expand Group

PiaReadAny Methods

Collapse Expand Links
PiaReadAny Class, PiaReadAny Members, PiaReadAny Methods


PiaReadAny::setPebsData Method

PiaReadAny::setPebsData Method
PiaReadAny Class PiaReadAny Members PiaReadAny Methods

Sets data for Social Security Statement.

C++
void setPebsData();
Collapse Expand Remarks

Calls EarnProject::setPebsData, then PiaRead::setPebsData.

Collapse Expand Group

PiaReadAny Methods

Collapse Expand Links
PiaReadAny Class, PiaReadAny Members, PiaReadAny Methods


PiaTable Class

PiaTable Class
PiaTable Methods PiaTable Members PiaTable.h Classes

Manages the functions required for calculation of a Pia Table Social Security benefit.

Collapse Expand Class Hierarchy
  PiaTablePiaTablePiaTable
C++
class PiaTable : public OldPia;
Collapse Expand File

File: PiaTable.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaCalPL.

Collapse Expand Group

Classes

Collapse Expand Links
PiaTable Methods, PiaTable Members, PiaTable.h, Classes


PiaTable Members

PiaTable Members
Enumerations PiaTable Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PiaTable.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

PiaTable Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
iamemax | Maximum ame in pia interval.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PiaTable | Initializes this instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Computes Pia Table PIA.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~PiaTable | Destructor.
Collapse Expand Links
Enumerations, PiaTable Class, Legend, Protected Data Members, Public Data Members, Public Methods


PiaTable::PiaTable Constructor

PiaTable::PiaTable Constructor
PiaTable Class PiaTable Members PiaTable Class

Initializes this instance.

C++
PiaTable(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker basic data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
Collapse Expand Remarks

Calls initialize.

Collapse Expand Class

PiaTable Class

Collapse Expand Links
PiaTable Class, PiaTable Members, PiaTable Class


PiaTable::~PiaTable Destructor

PiaTable::~PiaTable Destructor
PiaTable Class PiaTable Members PiaTable Class

Destructor.

C++
virtual ~PiaTable();
Collapse Expand Class

PiaTable Class

Collapse Expand Links
PiaTable Class, PiaTable Members, PiaTable Class


PiaTable Methods

PiaTable Methods
PiaTable Class Legend Public Methods

The methods of the PiaTable class are listed here.

Collapse Expand Class

PiaTable Class

Collapse Expand Public Methods
Name | Description
calculate | Computes Pia Table PIA.
isApplicable | Determines applicability of method.
Collapse Expand Links
PiaTable Class, Legend, Public Methods


PiaTable::calculate Method

PiaTable::calculate Method
PiaTable Class PiaTable Members PiaTable Methods

Computes Pia Table PIA.

C++
void calculate();
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PIATABLE1 if year of entitlement is out of range (only in debug mode); of type PIA_IDS_PIATABLE2 if year of benefit is out of range (only in debug mode).
Collapse Expand Group

PiaTable Methods

Collapse Expand Links
PiaTable Class, PiaTable Members, PiaTable Methods


isApplicable Method

isApplicable Method
PiaTable Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of this function. The version with no arguments uses stored data, passing it to the static version with three arguments.

Collapse Expand Overload List
Name | Description
PiaTable::isApplicable () | Determines applicability of method, using stored values.
PiaTable::isApplicable (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type) | Determines applicability of method, using passed values.
Collapse Expand Group

PiaTable Methods

Collapse Expand Links
PiaTable Methods


PiaTable::isApplicable Method ()

PiaTable::isApplicable Method ()
PiaTable Class PiaTable Members isApplicable Method

Determines applicability of method, using stored values.

C++
bool isApplicable();
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

This version calls the static version with 3 arguments.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
PiaTable Class, PiaTable Members, isApplicable Method


PiaTable::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type)

PiaTable::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type)
PiaTable Class PiaTable Members isApplicable Method

Determines applicability of method, using passed values.

C++
static bool isApplicable(
    const WorkerDataGeneral& workerData,
    const PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker basic data.
const PiaData& piaData | Pia calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
Collapse Expand Returns

True if method is applicable.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
PiaTable Class, PiaTable Members, isApplicable Method


PiaTableLC Class

PiaTableLC Class
PiaTableLC Methods PiaTableLC Members PiaTableLC.h Classes

Manages the functions required for calculation of a Pia Table Social Security benefit, including changes from present law.

Collapse Expand Class Hierarchy
  PiaTableLCPiaTableLCPiaTableLCPiaTableLC
C++
class PiaTableLC : public PiaTable;
Collapse Expand File

File: PiaTableLC.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaCalLC.

Collapse Expand Group

Classes

Collapse Expand Links
PiaTableLC Methods, PiaTableLC Members, PiaTableLC.h, Classes


PiaTableLC Members

PiaTableLC Members
Enumerations PiaTableLC Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PiaTableLC.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

PiaTableLC Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
iamemax | Maximum ame in pia interval.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PiaTableLC | Initializes a PiaTableLC instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Calculates pia and mfb for this method.
calculate | Computes Pia Table PIA.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~PiaTableLC | Destructor.
Collapse Expand Links
Enumerations, PiaTableLC Class, Legend, Protected Data Members, Public Data Members, Public Methods


PiaTableLC::PiaTableLC Constructor

PiaTableLC::PiaTableLC Constructor
PiaTableLC Class PiaTableLC Members PiaTableLC Class

Initializes a PiaTableLC instance.

C++
PiaTableLC(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear,
    const LawChangeArray& newLawChange,
    const DateMoyr& entitDate
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker basic data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
const LawChangeArray& newLawChange | Law change parameters.
const DateMoyr& entitDate | Entitlement date of benefit.
Collapse Expand Class

PiaTableLC Class

Collapse Expand Links
PiaTableLC Class, PiaTableLC Members, PiaTableLC Class


PiaTableLC::~PiaTableLC Destructor

PiaTableLC::~PiaTableLC Destructor
PiaTableLC Class PiaTableLC Members PiaTableLC Class

Destructor.

C++
virtual ~PiaTableLC();
Collapse Expand Class

PiaTableLC Class

Collapse Expand Links
PiaTableLC Class, PiaTableLC Members, PiaTableLC Class


PiaTableLC Methods

PiaTableLC Methods
PiaTableLC Class Legend Public Methods

The methods of the PiaTableLC class are listed here.

Collapse Expand Class

PiaTableLC Class

Collapse Expand Public Methods
Name | Description
isApplicable | Determines applicability of method.
Collapse Expand Links
PiaTableLC Class, Legend, Public Methods


isApplicable Method

isApplicable Method
PiaTableLC Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of this function. The version with no arguments uses stored data, passing it to the static version with five arguments.

Collapse Expand Overload List
Name | Description
PiaTableLC::isApplicable () | Determines applicability of method with no arguments.
PiaTableLC::isApplicable (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type, const LawChangeArray&, const DateMoyr&) | Determines applicability of method with 5 arguments.
Collapse Expand Group

PiaTableLC Methods

Collapse Expand Links
PiaTableLC Methods


PiaTableLC::isApplicable Method ()

PiaTableLC::isApplicable Method ()
PiaTableLC Class PiaTableLC Members isApplicable Method

Determines applicability of method with no arguments.

C++
bool isApplicable();
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

This version with no arguments calls the static version with 5 arguments.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
PiaTableLC Class, PiaTableLC Members, isApplicable Method


PiaTableLC::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type, const LawChangeArray&, const DateMoyr&)

PiaTableLC::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type, const LawChangeArray&, const DateMoyr&)
PiaTableLC Class PiaTableLC Members isApplicable Method

Determines applicability of method with 5 arguments.

C++
static bool isApplicable(
    const WorkerDataGeneral& workerData,
    const PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi,
    const LawChangeArray& lawChange,
    const DateMoyr& entitDate
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker basic data.
const PiaData& piaData | Pia calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
const LawChangeArray& lawChange | Law change parameters.
const DateMoyr& entitDate | Entitlement date.
Collapse Expand Returns

True if method is applicable.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
PiaTableLC Class, PiaTableLC Members, isApplicable Method


PiaWrite Class

PiaWrite Class
PiaWrite Data Members PiaWrite Methods PiaWrite Members piawrite.h Classes

Writes out the basic data required to calculate a Social Security benefit.

Collapse Expand Class Hierarchy
  PiaWrite
C++
class PiaWrite;
Collapse Expand File

File: piawrite.h

Module: PiaData Library

Collapse Expand Remarks

This version is used in programs such as microsimulations, which do not use Social Security Statements or factors to project earnings. For programs that do use those things, such as Anypia, use the subclass PiaWriteAny.

Collapse Expand See Also

PiaWriteAny

Collapse Expand Group

Classes

Collapse Expand Links
PiaWrite Data Members, PiaWrite Methods, PiaWrite Members, piawrite.h, Classes


PiaWrite Members

PiaWrite Members
PiaWrite Class Legend Protected Data Members Public Methods

The following tables list the members exposed by PiaWrite.

Collapse Expand Class

PiaWrite Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
secondaryArray | Array of Secondary benefit information.
userAssumptions | User-specified assumptions.
widowArray | Widow and other family member calculation data.
widowDataArray | Widow and other family member basic data.
workerData | Worker data.
Collapse Expand Public Methods
Name | Description
PiaWrite | Initializes references to data.
getEarnWidth | Returns width of earnings or base field.
getNumDecimals | Returns number of decimal places for earnings or base.
getWidth | Returns width of field for line number in file.
setEarnWidth | Sets width of earnings or base field.
setNumDecimals | Sets number of decimal places for earnings or base.
setWidth | Sets width of field for line number in file.
write | Saves a case to disk.
writeAssump | Writes assumption indicators.
writeAw | Writes average wage increase assumptions.
writeBack | Writes backward projection amounts.
writeBases | Writes wage base assumptions.
writeBenDate | Writes date of benefit.
writeBi | Writes benefit increase assumptions.
writeBlind | Writes blind indicator.
writeChildCareYears | Writes annual child care years.
writeDeath | Writes date of death.
writeDeemed | Writes deemed insured indicator.
writeDisab1 | Writes disability information for most recent period.
writeDisab2 | Writes disability information for second most recent period.
writeEarnHi | Writes Medicare earnings.
writeEarnOasdi | Writes OASDI-covered earnings for all years, using unprojected earnings array.
writeEarnType | Writes type of earnings for all years.
writeFamilyMember | Writes information for one family member.
writeFamilyMembers | Writes information for all family members.
writeFwrd | Writes forward projection amounts.
writeMsdates | Writes military service dates.
writeNhaddr | Writes address of worker.
writeNhname | Writes name of worker.
writeOabEnt | Writes oab entitlement prior to most recent dib.
writePebes | Writes pebes information.
writePubpen | Writes noncovered pension.
writePubpenReservist | Writes noncovered pension after military reservist pension removal.
writeQc1 | Writes summary quarters of coverage.
writeQc2 | Writes annual quarters of coverage.
writeRailRoad | Writes railroad earnings and qcs.
writeSsn | Writes Social Security number, sex, and date of birth.
writeTaxType | Writes type of taxes for all years.
writeTob | Writes type of benefit and date of entitlement.
writeTotalize | Writes totalization indicator.
writeYears | Writes years of earnings.
Collapse Expand Links
PiaWrite Class, Legend, Protected Data Members, Public Methods


PiaWrite::PiaWrite Constructor

PiaWrite::PiaWrite Constructor
PiaWrite Class PiaWrite Members PiaWrite Class

Initializes references to data.

C++
PiaWrite(
    const WorkerData& newWorkerData,
    const WorkerDataArray& newWidowDataArray,
    const PiaDataArray& newWidowArray,
    const UserAssumptions& newUserAssumptions,
    const SecondaryArray& newSecondaryArray
);
Collapse Expand Parameters
Parameters | Description
const WorkerData& newWorkerData | Worker's calculation data.
const WorkerDataArray& newWidowDataArray | Widow and other family members' basic data.
const PiaDataArray& newWidowArray | Widow and other family members' calculation data.
const UserAssumptions& newUserAssumptions | User-specified assumptions.
const SecondaryArray& newSecondaryArray | Array of Secondary benefit information.
Collapse Expand Class

PiaWrite Class

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Class


PiaWrite Data Members

PiaWrite Data Members
PiaWrite Class Legend Protected Data Members

The data members of the PiaWrite class are listed here.

Collapse Expand Class

PiaWrite Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
secondaryArray | Array of Secondary benefit information.
userAssumptions | User-specified assumptions.
widowArray | Widow and other family member calculation data.
widowDataArray | Widow and other family member basic data.
workerData | Worker data.
Collapse Expand Links
PiaWrite Class, Legend, Protected Data Members


PiaWrite::secondaryArray Data Member

PiaWrite::secondaryArray Data Member
PiaWrite Class PiaWrite Members PiaWrite Data Members

Array of Secondary benefit information.

C++
const SecondaryArray& secondaryArray;
Collapse Expand Group

PiaWrite Data Members

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Data Members


PiaWrite::userAssumptions Data Member

PiaWrite::userAssumptions Data Member
PiaWrite Class PiaWrite Members PiaWrite Data Members

User-specified assumptions.

C++
const UserAssumptions& userAssumptions;
Collapse Expand Group

PiaWrite Data Members

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Data Members


PiaWrite::widowArray Data Member

PiaWrite::widowArray Data Member
PiaWrite Class PiaWrite Members PiaWrite Data Members

Widow and other family member calculation data.

C++
const PiaDataArray& widowArray;
Collapse Expand Group

PiaWrite Data Members

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Data Members


PiaWrite::widowDataArray Data Member

PiaWrite::widowDataArray Data Member
PiaWrite Class PiaWrite Members PiaWrite Data Members

Widow and other family member basic data.

C++
const WorkerDataArray& widowDataArray;
Collapse Expand Group

PiaWrite Data Members

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Data Members


PiaWrite::workerData Data Member

PiaWrite::workerData Data Member
PiaWrite Class PiaWrite Members PiaWrite Data Members

Worker data.

C++
const WorkerData& workerData;
Collapse Expand Group

PiaWrite Data Members

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Data Members


PiaWrite Methods

PiaWrite Methods
PiaWrite Class Legend Public Methods

The methods of the PiaWrite class are listed here.

Collapse Expand Class

PiaWrite Class

Collapse Expand Public Methods
Name | Description
getEarnWidth | Returns width of earnings or base field.
getNumDecimals | Returns number of decimal places for earnings or base.
getWidth | Returns width of field for line number in file.
setEarnWidth | Sets width of earnings or base field.
setNumDecimals | Sets number of decimal places for earnings or base.
setWidth | Sets width of field for line number in file.
write | Saves a case to disk.
writeAssump | Writes assumption indicators.
writeAw | Writes average wage increase assumptions.
writeBack | Writes backward projection amounts.
writeBases | Writes wage base assumptions.
writeBenDate | Writes date of benefit.
writeBi | Writes benefit increase assumptions.
writeBlind | Writes blind indicator.
writeChildCareYears | Writes annual child care years.
writeDeath | Writes date of death.
writeDeemed | Writes deemed insured indicator.
writeDisab1 | Writes disability information for most recent period.
writeDisab2 | Writes disability information for second most recent period.
writeEarnHi | Writes Medicare earnings.
writeEarnOasdi | Writes OASDI-covered earnings for all years, using unprojected earnings array.
writeEarnType | Writes type of earnings for all years.
writeFamilyMember | Writes information for one family member.
writeFamilyMembers | Writes information for all family members.
writeFwrd | Writes forward projection amounts.
writeMsdates | Writes military service dates.
writeNhaddr | Writes address of worker.
writeNhname | Writes name of worker.
writeOabEnt | Writes oab entitlement prior to most recent dib.
writePebes | Writes pebes information.
writePubpen | Writes noncovered pension.
writePubpenReservist | Writes noncovered pension after military reservist pension removal.
writeQc1 | Writes summary quarters of coverage.
writeQc2 | Writes annual quarters of coverage.
writeRailRoad | Writes railroad earnings and qcs.
writeSsn | Writes Social Security number, sex, and date of birth.
writeTaxType | Writes type of taxes for all years.
writeTob | Writes type of benefit and date of entitlement.
writeTotalize | Writes totalization indicator.
writeYears | Writes years of earnings.
Collapse Expand Links
PiaWrite Class, Legend, Public Methods


PiaWrite::getEarnWidth Method

PiaWrite::getEarnWidth Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Returns width of earnings or base field.

C++
int getEarnWidth() const;
Collapse Expand Returns

Width of earnings or base field.

Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::getNumDecimals Method

PiaWrite::getNumDecimals Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Returns number of decimal places for earnings or base.

C++
int getNumDecimals() const;
Collapse Expand Returns

Number of decimal places for earnings or base.

Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::getWidth Method

PiaWrite::getWidth Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Returns width of field for line number in file.

C++
int getWidth() const;
Collapse Expand Returns

Width of field for line number in file.

Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::setEarnWidth Method

PiaWrite::setEarnWidth Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Sets width of earnings or base field.

C++
void setEarnWidth(
    int newWidth
);
Collapse Expand Parameters
Parameters | Description
int newWidth | New width of earnings or base field.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::setNumDecimals Method

PiaWrite::setNumDecimals Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Sets number of decimal places for earnings or base.

C++
void setNumDecimals(
    int newNumDecimals
);
Collapse Expand Parameters
Parameters | Description
int newNumDecimals | New number of decimals.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::setWidth Method

PiaWrite::setWidth Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Sets width of field for line number in file.

C++
void setWidth(
    int newWidth
);
Collapse Expand Parameters
Parameters | Description
int newWidth | New width of column for line number.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::write Method

PiaWrite::write Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Saves a case to disk.

C++
void write(
    std::ostream& out
);
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeAssump Method

PiaWrite::writeAssump Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes assumption indicators.

C++
virtual void writeAssump(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Remarks

Assumption indicators are written only if this is a case that needs assumptions (a benefit in the future).

Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeAw Method

PiaWrite::writeAw Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes average wage increase assumptions.

C++
void writeAw(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Remarks

Average wage increase assumptions are written if they are not one of the stored sets of assumptions.

Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeBack Method

PiaWrite::writeBack Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes backward projection amounts.

C++
virtual void writeBack(
    std::ostream&
) const;
Collapse Expand Remarks

This version does nothing.

Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeBases Method

PiaWrite::writeBases Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes wage base assumptions.

C++
void writeBases(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Remarks

Projected wage bases are written if they are ad hoc.

Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeBenDate Method

PiaWrite::writeBenDate Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes date of benefit.

C++
void writeBenDate(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Remarks

Only written if this is a recalculation, or a survivor benefit.

Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeBi Method

PiaWrite::writeBi Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes benefit increase assumptions.

C++
void writeBi(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Remarks

Benefit increase assumptions are written if they are not one of the stored sets of assumptions.

Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeBlind Method

PiaWrite::writeBlind Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes blind indicator.

C++
void writeBlind(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeChildCareYears Method

PiaWrite::writeChildCareYears Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes annual child care years.

C++
void writeChildCareYears(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeDeath Method

PiaWrite::writeDeath Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes date of death.

C++
void writeDeath(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeDeemed Method

PiaWrite::writeDeemed Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes deemed insured indicator.

C++
void writeDeemed(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeDisab1 Method

PiaWrite::writeDisab1 Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes disability information for most recent period.

C++
void writeDisab1(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Remarks

Does not print anything unless there is a period of disability. Does not print the date of cessation for a current period of disability (the type of benefit is WorkerDataGeneral::ben_type::DISABILITY).

Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeDisab2 Method

PiaWrite::writeDisab2 Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes disability information for second most recent period.

C++
void writeDisab2(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeEarnHi Method

PiaWrite::writeEarnHi Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes Medicare earnings.

C++
void writeEarnHi(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeEarnOasdi Method

PiaWrite::writeEarnOasdi Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes OASDI-covered earnings for all years, using unprojected earnings array.

C++
virtual void writeEarnOasdi(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_WRITEEARN if first year of earnings is out of range (only in debug mode).
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeEarnType Method

PiaWrite::writeEarnType Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes type of earnings for all years.

C++
virtual void writeEarnType(
    std::ostream&
) const;
Collapse Expand Remarks

This version does nothing.

Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeFamilyMember Method

PiaWrite::writeFamilyMember Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes information for one family member.

C++
void writeFamilyMember(
    std::ostream& out,
    int i
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
int i | Number of family member (0 to 14).
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeFamilyMembers Method

PiaWrite::writeFamilyMembers Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes information for all family members.

C++
void writeFamilyMembers(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeFwrd Method

PiaWrite::writeFwrd Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes forward projection amounts.

C++
virtual void writeFwrd(
    std::ostream&
) const;
Collapse Expand Remarks

This version does nothing.

Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeMsdates Method

PiaWrite::writeMsdates Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes military service dates.

C++
void writeMsdates(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeNhaddr Method

PiaWrite::writeNhaddr Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes address of worker.

C++
void writeNhaddr(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeNhname Method

PiaWrite::writeNhname Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes name of worker.

C++
void writeNhname(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeOabEnt Method

PiaWrite::writeOabEnt Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes oab entitlement prior to most recent dib.

C++
void writeOabEnt(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writePebes Method

PiaWrite::writePebes Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes pebes information.

C++
virtual void writePebes(
    std::ostream&
) const;
Collapse Expand Remarks

This version does nothing.

Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writePubpen Method

PiaWrite::writePubpen Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes noncovered pension.

C++
void writePubpen(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Remarks

Writes the non-covered pension amount if it is greater than zero. Also writes the pension start date if it exists.

Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writePubpenReservist Method

PiaWrite::writePubpenReservist Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes noncovered pension after military reservist pension removal.

C++
void writePubpenReservist(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeQc1 Method

PiaWrite::writeQc1 Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes summary quarters of coverage.

C++
void writeQc1(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeQc2 Method

PiaWrite::writeQc2 Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes annual quarters of coverage.

C++
void writeQc2(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeRailRoad Method

PiaWrite::writeRailRoad Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes railroad earnings and qcs.

C++
void writeRailRoad(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeSsn Method

PiaWrite::writeSsn Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes Social Security number, sex, and date of birth.

C++
void writeSsn(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeTaxType Method

PiaWrite::writeTaxType Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes type of taxes for all years.

C++
void writeTaxType(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeTob Method

PiaWrite::writeTob Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes type of benefit and date of entitlement.

C++
void writeTob(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Remarks

Only written if there is a benefit.

Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeTotalize Method

PiaWrite::writeTotalize Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes totalization indicator.

C++
void writeTotalize(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWrite::writeYears Method

PiaWrite::writeYears Method
PiaWrite Class PiaWrite Members PiaWrite Methods

Writes years of earnings.

C++
void writeYears(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWrite Methods

Collapse Expand Links
PiaWrite Class, PiaWrite Members, PiaWrite Methods


PiaWriteAny Class

PiaWriteAny Class
PiaWriteAny Methods PiaWriteAny Members piawriteAny.h Classes

Writes out the data required to calculate a Social Security benefit for the Anypia program.

Collapse Expand Class Hierarchy
  PiaWriteAnyPiaWriteAny
C++
class PiaWriteAny : public PiaWrite;
Collapse Expand File

File: piawriteAny.h

Module: PiaData Library

Collapse Expand Remarks

This version adds data required for Social Security Statements and factors to project earnings.

Collapse Expand Group

Classes

Collapse Expand Links
PiaWriteAny Methods, PiaWriteAny Members, piawriteAny.h, Classes


PiaWriteAny Members

PiaWriteAny Members
PiaWriteAny Class Legend Protected Data Members Public Methods

The following tables list the members exposed by PiaWriteAny.

Collapse Expand Class

PiaWriteAny Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
secondaryArray | Array of Secondary benefit information.
userAssumptions | User-specified assumptions.
widowArray | Widow and other family member calculation data.
widowDataArray | Widow and other family member basic data.
workerData | Worker data.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PiaWriteAny | Initializes references to data.
getEarnWidth | Returns width of earnings or base field.
getNumDecimals | Returns number of decimal places for earnings or base.
getWidth | Returns width of field for line number in file.
setEarnWidth | Sets width of earnings or base field.
setNumDecimals | Sets number of decimal places for earnings or base.
setWidth | Sets width of field for line number in file.
write | Saves a case to disk.
writeAssump | Writes assumption indicators.
writeAw | Writes average wage increase assumptions.
writeBack | Writes backward projection amounts.
writeBases | Writes wage base assumptions.
writeBenDate | Writes date of benefit.
writeBi | Writes benefit increase assumptions.
writeBlind | Writes blind indicator.
writeChildCareYears | Writes annual child care years.
writeDeath | Writes date of death.
writeDeemed | Writes deemed insured indicator.
writeDisab1 | Writes disability information for most recent period.
writeDisab2 | Writes disability information for second most recent period.
writeEarnHi | Writes Medicare earnings.
writeEarnOasdi | Writes earnings for all years, using projected earnings array.
writeEarnType | Writes type of earnings for all years.
writeFamilyMember | Writes information for one family member.
writeFamilyMembers | Writes information for all family members.
writeFwrd | Writes forward projection amounts.
writeMsdates | Writes military service dates.
writeNhaddr | Writes address of worker.
writeNhname | Writes name of worker.
writeOabEnt | Writes oab entitlement prior to most recent dib.
writePebes | Writes pebes information.
writePubpen | Writes noncovered pension.
writePubpenReservist | Writes noncovered pension after military reservist pension removal.
writeQc1 | Writes summary quarters of coverage.
writeQc2 | Writes annual quarters of coverage.
writeRailRoad | Writes railroad earnings and qcs.
writeSsn | Writes Social Security number, sex, and date of birth.
writeTaxType | Writes type of taxes for all years.
writeTob | Writes type of benefit and date of entitlement.
writeTotalize | Writes totalization indicator.
writeYears | Writes years of earnings.
Collapse Expand Links
PiaWriteAny Class, Legend, Protected Data Members, Public Methods


PiaWriteAny::PiaWriteAny Constructor

PiaWriteAny::PiaWriteAny Constructor
PiaWriteAny Class PiaWriteAny Members PiaWriteAny Class

Initializes references to data.

C++
PiaWriteAny(
    const WorkerData& newWorkerData,
    const WorkerDataArray& newWidowDataArray,
    const PiaDataArray& newWidowArray,
    const UserAssumptions& newUserAssumptions,
    const SecondaryArray& newSecondaryArray,
    const EarnProject& newEarnProject,
    const Pebs& newPebs
);
Collapse Expand Parameters
Parameters | Description
const WorkerData& newWorkerData | Worker's calculation data.
const WorkerDataArray& newWidowDataArray | Widow(er) and other family members' basic data.
const PiaDataArray& newWidowArray | Widow(er) and other family members' calculation data.
const UserAssumptions& newUserAssumptions | User-specified assumptions.
const SecondaryArray& newSecondaryArray | Array of Secondary benefit information.
const EarnProject& newEarnProject | Projected earnings.
const Pebs& newPebs | Statement information.
Collapse Expand Class

PiaWriteAny Class

Collapse Expand Links
PiaWriteAny Class, PiaWriteAny Members, PiaWriteAny Class


PiaWriteAny Methods

PiaWriteAny Methods
PiaWriteAny Class Legend Public Methods

The methods of the PiaWriteAny class are listed here.

Collapse Expand Class

PiaWriteAny Class

Collapse Expand Public Methods
Name | Description
writeAssump | Writes assumption indicators.
writeBack | Writes backward projection amounts.
writeEarnOasdi | Writes earnings for all years, using projected earnings array.
writeEarnType | Writes type of earnings for all years.
writeFwrd | Writes forward projection amounts.
writePebes | Writes pebes information.
Collapse Expand Links
PiaWriteAny Class, Legend, Public Methods


PiaWriteAny::writeAssump Method

PiaWriteAny::writeAssump Method
PiaWriteAny Class PiaWriteAny Members PiaWriteAny Methods

Writes assumption indicators.

C++
void writeAssump(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWriteAny Methods

Collapse Expand Links
PiaWriteAny Class, PiaWriteAny Members, PiaWriteAny Methods


PiaWriteAny::writeBack Method

PiaWriteAny::writeBack Method
PiaWriteAny Class PiaWriteAny Members PiaWriteAny Methods

Writes backward projection amounts.

C++
void writeBack(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWriteAny Methods

Collapse Expand Links
PiaWriteAny Class, PiaWriteAny Members, PiaWriteAny Methods


PiaWriteAny::writeEarnOasdi Method

PiaWriteAny::writeEarnOasdi Method
PiaWriteAny Class PiaWriteAny Members PiaWriteAny Methods

Writes earnings for all years, using projected earnings array.

C++
void writeEarnOasdi(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_WRITEEARN if first year of earnings is out of range (only in debug mode).
Collapse Expand Group

PiaWriteAny Methods

Collapse Expand Links
PiaWriteAny Class, PiaWriteAny Members, PiaWriteAny Methods


PiaWriteAny::writeEarnType Method

PiaWriteAny::writeEarnType Method
PiaWriteAny Class PiaWriteAny Members PiaWriteAny Methods

Writes type of earnings for all years.

C++
void writeEarnType(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_EARNTYPE1 if year of projection is out of range (only in debug mode).
Collapse Expand Group

PiaWriteAny Methods

Collapse Expand Links
PiaWriteAny Class, PiaWriteAny Members, PiaWriteAny Methods


PiaWriteAny::writeFwrd Method

PiaWriteAny::writeFwrd Method
PiaWriteAny Class PiaWriteAny Members PiaWriteAny Methods

Writes forward projection amounts.

C++
void writeFwrd(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWriteAny Methods

Collapse Expand Links
PiaWriteAny Class, PiaWriteAny Members, PiaWriteAny Methods


PiaWriteAny::writePebes Method

PiaWriteAny::writePebes Method
PiaWriteAny Class PiaWriteAny Members PiaWriteAny Methods

Writes pebes information.

C++
void writePebes(
    std::ostream& out
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
Collapse Expand Group

PiaWriteAny Methods

Collapse Expand Links
PiaWriteAny Class, PiaWriteAny Members, PiaWriteAny Methods


Pib50Mfb Class

Pib50Mfb Class
Pib50Mfb Methods Pib50Mfb Members pibtable.h Classes

Manages the 1950 pib-mfb conversion figures.

Collapse Expand Class Hierarchy
  Pib50Mfb
C++
class Pib50Mfb;
Collapse Expand File

File: pibtable.h

Module: PiaData Library

Collapse Expand Remarks

This class is used in OldStart::oldStart50Cal.

Collapse Expand Group

Classes

Collapse Expand Links
Pib50Mfb Methods, Pib50Mfb Members, pibtable.h, Classes


Pib50Mfb Members

Pib50Mfb Members
Pib50Mfb Class Legend Public Methods

The following tables list the members exposed by Pib50Mfb.

Collapse Expand Class

Pib50Mfb Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1950 conversion table mfb.
Collapse Expand Links
Pib50Mfb Class, Legend, Public Methods


Pib50Mfb Methods

Pib50Mfb Methods
Pib50Mfb Class Legend Public Methods

The methods of the Pib50Mfb class are listed here.

Collapse Expand Class

Pib50Mfb Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1950 conversion table mfb.
Collapse Expand Links
Pib50Mfb Class, Legend, Public Methods


Pib50Mfb::getAt Method

Pib50Mfb::getAt Method
Pib50Mfb Class Pib50Mfb Members Pib50Mfb Methods

Returns 1950 conversion table mfb.

C++
static double getAt(
    int index
);
Collapse Expand Parameters
Parameters | Description
int index | Number of mfb desired.
Collapse Expand Returns

1950 conversion table mfb.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PIB50MFB if index is out of range (only in debug mode).
Collapse Expand Group

Pib50Mfb Methods

Collapse Expand Links
Pib50Mfb Class, Pib50Mfb Members, Pib50Mfb Methods


Pib50Pib Class

Pib50Pib Class
Pib50Pib Methods Pib50Pib Members pibtable.h Classes

Manages the 1950 pib-pia conversion figures.

Collapse Expand Class Hierarchy
  Pib50Pib
C++
class Pib50Pib;
Collapse Expand File

File: pibtable.h

Module: PiaData Library

Collapse Expand Remarks

This class is used in OldStart::oldStart50Cal.

Collapse Expand Group

Classes

Collapse Expand Links
Pib50Pib Methods, Pib50Pib Members, pibtable.h, Classes


Pib50Pib Members

Pib50Pib Members
Pib50Pib Class Legend Public Methods

The following tables list the members exposed by Pib50Pib.

Collapse Expand Class

Pib50Pib Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1950 conversion table pib.
Collapse Expand Links
Pib50Pib Class, Legend, Public Methods


Pib50Pib Methods

Pib50Pib Methods
Pib50Pib Class Legend Public Methods

The methods of the Pib50Pib class are listed here.

Collapse Expand Class

Pib50Pib Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1950 conversion table pib.
Collapse Expand Links
Pib50Pib Class, Legend, Public Methods


Pib50Pib::getAt Method

Pib50Pib::getAt Method
Pib50Pib Class Pib50Pib Members Pib50Pib Methods

Returns 1950 conversion table pib.

C++
static double getAt(
    int index
);
Collapse Expand Parameters
Parameters | Description
int index | Number of pib desired.
Collapse Expand Returns

1950 conversion table pib.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PIB50PIB if index is out of range (only in debug mode).
Collapse Expand Group

Pib50Pib Methods

Collapse Expand Links
Pib50Pib Class, Pib50Pib Members, Pib50Pib Methods


Pib52Ame Class

Pib52Ame Class
Pib52Ame Methods Pib52Ame Members pibtable.h Classes

Manages the 1952 pib-ame conversion figures.

Collapse Expand Class Hierarchy
  Pib52Ame
C++
class Pib52Ame;
Collapse Expand File

File: pibtable.h

Module: PiaData Library

Collapse Expand Remarks

This class is used in OldStart::oldStart50Cal.

Collapse Expand Group

Classes

Collapse Expand Links
Pib52Ame Methods, Pib52Ame Members, pibtable.h, Classes


Pib52Ame Members

Pib52Ame Members
Pib52Ame Class Legend Public Methods

The following tables list the members exposed by Pib52Ame.

Collapse Expand Class

Pib52Ame Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1952 conversion table mfb.
Collapse Expand Links
Pib52Ame Class, Legend, Public Methods


Pib52Ame Methods

Pib52Ame Methods
Pib52Ame Class Legend Public Methods

The methods of the Pib52Ame class are listed here.

Collapse Expand Class

Pib52Ame Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1952 conversion table mfb.
Collapse Expand Links
Pib52Ame Class, Legend, Public Methods


Pib52Ame::getAt Method

Pib52Ame::getAt Method
Pib52Ame Class Pib52Ame Members Pib52Ame Methods

Returns 1952 conversion table mfb.

C++
static double getAt(
    int index
);
Collapse Expand Parameters
Parameters | Description
int index | Number of mfb desired.
Collapse Expand Returns

1952 conversion table mfb.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PIB52MFB if index is out of range (only in debug mode).
Collapse Expand Group

Pib52Ame Methods

Collapse Expand Links
Pib52Ame Class, Pib52Ame Members, Pib52Ame Methods


Pib52Mfb Class

Pib52Mfb Class
Pib52Mfb Methods Pib52Mfb Members pibtable.h Classes

Manages the 1952 pib-mfb conversion figures.

Collapse Expand Class Hierarchy
  Pib52Mfb
C++
class Pib52Mfb;
Collapse Expand File

File: pibtable.h

Module: PiaData Library

Collapse Expand Remarks

This class is used in OldStart::oldStart50Cal.

Collapse Expand Group

Classes

Collapse Expand Links
Pib52Mfb Methods, Pib52Mfb Members, pibtable.h, Classes


Pib52Mfb Members

Pib52Mfb Members
Pib52Mfb Class Legend Public Methods

The following tables list the members exposed by Pib52Mfb.

Collapse Expand Class

Pib52Mfb Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1952 conversion table mfb.
Collapse Expand Links
Pib52Mfb Class, Legend, Public Methods


Pib52Mfb Methods

Pib52Mfb Methods
Pib52Mfb Class Legend Public Methods

The methods of the Pib52Mfb class are listed here.

Collapse Expand Class

Pib52Mfb Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1952 conversion table mfb.
Collapse Expand Links
Pib52Mfb Class, Legend, Public Methods


Pib52Mfb::getAt Method

Pib52Mfb::getAt Method
Pib52Mfb Class Pib52Mfb Members Pib52Mfb Methods

Returns 1952 conversion table mfb.

C++
static double getAt(
    int index
);
Collapse Expand Parameters
Parameters | Description
int index | Number of mfb desired.
Collapse Expand Returns

1952 conversion table mfb.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PIB52MFB if index is out of range (only in debug mode).
Collapse Expand Group

Pib52Mfb Methods

Collapse Expand Links
Pib52Mfb Class, Pib52Mfb Members, Pib52Mfb Methods


Pib54Ame Class

Pib54Ame Class
Pib54Ame Methods Pib54Ame Members pibtable.h Classes

Manages the 1954 pib-ame conversion figures.

Collapse Expand Class Hierarchy
  Pib54Ame
C++
class Pib54Ame;
Collapse Expand File

File: pibtable.h

Module: PiaData Library

Collapse Expand Remarks

This class is used in OldStart::oldStart50Cal.

Collapse Expand Group

Classes

Collapse Expand Links
Pib54Ame Methods, Pib54Ame Members, pibtable.h, Classes


Pib54Ame Members

Pib54Ame Members
Pib54Ame Class Legend Public Methods

The following tables list the members exposed by Pib54Ame.

Collapse Expand Class

Pib54Ame Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1954 conversion table ame.
Collapse Expand Links
Pib54Ame Class, Legend, Public Methods


Pib54Ame Methods

Pib54Ame Methods
Pib54Ame Class Legend Public Methods

The methods of the Pib54Ame class are listed here.

Collapse Expand Class

Pib54Ame Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1954 conversion table ame.
Collapse Expand Links
Pib54Ame Class, Legend, Public Methods


Pib54Ame::getAt Method

Pib54Ame::getAt Method
Pib54Ame Class Pib54Ame Members Pib54Ame Methods

Returns 1954 conversion table ame.

C++
static double getAt(
    int index
);
Collapse Expand Parameters
Parameters | Description
int index | Number of pia desired.
Collapse Expand Returns

1954 conversion table ame.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PIB54PIA if index is out of range (only in debug mode).
Collapse Expand Group

Pib54Ame Methods

Collapse Expand Links
Pib54Ame Class, Pib54Ame Members, Pib54Ame Methods


Pib54Mfb Class

Pib54Mfb Class
Pib54Mfb Methods Pib54Mfb Members pibtable.h Classes

Manages the 1954 pib-mfb conversion figures.

Collapse Expand Class Hierarchy
  Pib54Mfb
C++
class Pib54Mfb;
Collapse Expand File

File: pibtable.h

Module: PiaData Library

Collapse Expand Remarks

This class is used in OldStart::oldStart50Cal.

Collapse Expand Group

Classes

Collapse Expand Links
Pib54Mfb Methods, Pib54Mfb Members, pibtable.h, Classes


Pib54Mfb Members

Pib54Mfb Members
Pib54Mfb Class Legend Public Methods

The following tables list the members exposed by Pib54Mfb.

Collapse Expand Class

Pib54Mfb Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1954 conversion table mfb.
Collapse Expand Links
Pib54Mfb Class, Legend, Public Methods


Pib54Mfb Methods

Pib54Mfb Methods
Pib54Mfb Class Legend Public Methods

The methods of the Pib54Mfb class are listed here.

Collapse Expand Class

Pib54Mfb Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1954 conversion table mfb.
Collapse Expand Links
Pib54Mfb Class, Legend, Public Methods


Pib54Mfb::getAt Method

Pib54Mfb::getAt Method
Pib54Mfb Class Pib54Mfb Members Pib54Mfb Methods

Returns 1954 conversion table mfb.

C++
static double getAt(
    int index
);
Collapse Expand Parameters
Parameters | Description
int index | Number of mfb desired.
Collapse Expand Returns

1954 conversion table mfb.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PIB54MFB if index is out of range (only in debug mode).
Collapse Expand Group

Pib54Mfb Methods

Collapse Expand Links
Pib54Mfb Class, Pib54Mfb Members, Pib54Mfb Methods


Pib54Pia Class

Pib54Pia Class
Pib54Pia Methods Pib54Pia Members pibtable.h Classes

Manages the 1954 pib-pia conversion figures.

Collapse Expand Class Hierarchy
  Pib54Pia
C++
class Pib54Pia;
Collapse Expand File

File: pibtable.h

Module: PiaData Library

Collapse Expand Remarks

This class is used in OldStart::oldStart50Cal.

Collapse Expand Group

Classes

Collapse Expand Links
Pib54Pia Methods, Pib54Pia Members, pibtable.h, Classes


Pib54Pia Members

Pib54Pia Members
Pib54Pia Class Legend Public Methods

The following tables list the members exposed by Pib54Pia.

Collapse Expand Class

Pib54Pia Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1954 conversion table pia.
Collapse Expand Links
Pib54Pia Class, Legend, Public Methods


Pib54Pia Methods

Pib54Pia Methods
Pib54Pia Class Legend Public Methods

The methods of the Pib54Pia class are listed here.

Collapse Expand Class

Pib54Pia Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1954 conversion table pia.
Collapse Expand Links
Pib54Pia Class, Legend, Public Methods


Pib54Pia::getAt Method

Pib54Pia::getAt Method
Pib54Pia Class Pib54Pia Members Pib54Pia Methods

Returns 1954 conversion table pia.

C++
static double getAt(
    int index
);
Collapse Expand Parameters
Parameters | Description
int index | Number of pia desired.
Collapse Expand Returns

1954 conversion table pia.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PIB54PIA if index is out of range (only in debug mode).
Collapse Expand Group

Pib54Pia Methods

Collapse Expand Links
Pib54Pia Class, Pib54Pia Members, Pib54Pia Methods


Pib58Ame Class

Pib58Ame Class
Pib58Ame Methods Pib58Ame Members pibtable.h Classes

Manages the 1958 pib-ame conversion figures.

Collapse Expand Class Hierarchy
  Pib58Ame
C++
class Pib58Ame;
Collapse Expand File

File: pibtable.h

Module: PiaData Library

Collapse Expand Remarks

This class is used in OldStart::calculate.

Collapse Expand Group

Classes

Collapse Expand Links
Pib58Ame Methods, Pib58Ame Members, pibtable.h, Classes


Pib58Ame Members

Pib58Ame Members
Pib58Ame Class Legend Public Methods

The following tables list the members exposed by Pib58Ame.

Collapse Expand Class

Pib58Ame Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1958 conversion table ame.
Collapse Expand Links
Pib58Ame Class, Legend, Public Methods


Pib58Ame Methods

Pib58Ame Methods
Pib58Ame Class Legend Public Methods

The methods of the Pib58Ame class are listed here.

Collapse Expand Class

Pib58Ame Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1958 conversion table ame.
Collapse Expand Links
Pib58Ame Class, Legend, Public Methods


Pib58Ame::getAt Method

Pib58Ame::getAt Method
Pib58Ame Class Pib58Ame Members Pib58Ame Methods

Returns 1958 conversion table ame.

C++
static double getAt(
    int index
);
Collapse Expand Parameters
Parameters | Description
int index | Number of ame desired.
Collapse Expand Returns

1958 conversion table ame.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PIB58AME if index is out of range (only in debug mode).
Collapse Expand Group

Pib58Ame Methods

Collapse Expand Links
Pib58Ame Class, Pib58Ame Members, Pib58Ame Methods


Pib58Pib Class

Pib58Pib Class
Pib58Pib Methods Pib58Pib Members pibtable.h Classes

Manages the 1958 pib-pia conversion figures.

Collapse Expand Class Hierarchy
  Pib58Pib
C++
class Pib58Pib;
Collapse Expand File

File: pibtable.h

Module: PiaData Library

Collapse Expand Remarks

This class is used in OldStart::calculate.

Collapse Expand Group

Classes

Collapse Expand Links
Pib58Pib Methods, Pib58Pib Members, pibtable.h, Classes


Pib58Pib Members

Pib58Pib Members
Pib58Pib Class Legend Public Methods

The following tables list the members exposed by Pib58Pib.

Collapse Expand Class

Pib58Pib Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1958 conversion table pib.
Collapse Expand Links
Pib58Pib Class, Legend, Public Methods


Pib58Pib Methods

Pib58Pib Methods
Pib58Pib Class Legend Public Methods

The methods of the Pib58Pib class are listed here.

Collapse Expand Class

Pib58Pib Class

Collapse Expand Public Methods
Name | Description
getAt | Returns 1958 conversion table pib.
Collapse Expand Links
Pib58Pib Class, Legend, Public Methods


Pib58Pib::getAt Method

Pib58Pib::getAt Method
Pib58Pib Class Pib58Pib Members Pib58Pib Methods

Returns 1958 conversion table pib.

C++
static double getAt(
    int index
);
Collapse Expand Parameters
Parameters | Description
int index | Number of pib desired.
Collapse Expand Returns

1958 conversion table pib.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PIB58PIB if index is out of range (only in debug mode).
Collapse Expand Group

Pib58Pib Methods

Collapse Expand Links
Pib58Pib Class, Pib58Pib Members, Pib58Pib Methods


Pifc Class

Pifc Class
Pifc Methods Pifc Members Pifc.h Classes

Represents a pia factor code (type of Social Security pia).

Collapse Expand Class Hierarchy
  Pifc
C++
class Pifc;
Collapse Expand File

File: Pifc.h

Module: PiaData Library

Collapse Expand Remarks

Represents a pia factor code (type of Social Security pia).It has the following possible values:

A | Transitional uninsured or insured PIA (unused).
B | AMW PIA.
C | Special minimum PIA.
E | AMW survivor PIA greater than life PIA (unused).
F | Special minimum survivor PIA greater than life PIA (unused).
G | AMW survivor PIA equal to life PIA (unused).
H | Special minimum survivor PIA equal to life PIA (unused).
K | Totalized (prorated) PIA.
L | AIME PIA.
M | Frozen minimum PIA.
N | New-start guarantee PIA.
O | Old-start guarantee PIA.
S | DIB guarantee PIA.
V | Modified old start windfall PIA.
W | Widow(er)'s reindexed PIA (used only in OACT code).
Y | Child care dropout years method (used only in OACT code).
Z | Northern Mariana Islands computation (unused).
5 | Modified new start windfall PIA.
7 | 1990 new start (unused).
8 | 1990 old start.
Collapse Expand Group

Classes

Collapse Expand Links
Pifc Methods, Pifc Members, Pifc.h, Classes


Pifc Members

Pifc Members
Pifc Class Legend Public Methods

The following tables list the members exposed by Pifc.

Collapse Expand Class

Pifc Class

Collapse Expand Public Methods
Name | Description
Pifc | Initializes pia factor code.
get | Returns the pifc code.
isColable | Returns true if able to apply cola to this benefit.
isNewMfb | Returns true if wage-indexed mfb applies to this benefit.
pifcCal | Calculates applicable pifc.
set | Sets the pifc code.
Collapse Expand Links
Pifc Class, Legend, Public Methods


Pifc::Pifc Constructor

Pifc::Pifc Constructor
Pifc Class Pifc Members Pifc Class

Initializes pia factor code.

C++
Pifc(
    char newCode = ' '
);
Collapse Expand Parameters
Parameters | Description
char newCode = ' ' | New pia factor code to use. If omitted, uses a blank character.
Collapse Expand Class

Pifc Class

Collapse Expand Links
Pifc Class, Pifc Members, Pifc Class


Pifc Methods

Pifc Methods
Pifc Class Legend Public Methods

The methods of the Pifc class are listed here.

Collapse Expand Class

Pifc Class

Collapse Expand Public Methods
Name | Description
get | Returns the pifc code.
isColable | Returns true if able to apply cola to this benefit.
isNewMfb | Returns true if wage-indexed mfb applies to this benefit.
pifcCal | Calculates applicable pifc.
set | Sets the pifc code.
Collapse Expand Links
Pifc Class, Legend, Public Methods


Pifc::get Method

Pifc::get Method
Pifc Class Pifc Members Pifc Methods

Returns the pifc code.

C++
char get() const;
Collapse Expand Returns

The pifc code.

Collapse Expand Group

Pifc Methods

Collapse Expand Links
Pifc Class, Pifc Members, Pifc Methods


Pifc::isColable Method

Pifc::isColable Method
Pifc Class Pifc Members Pifc Methods

Returns true if able to apply cola to this benefit.

C++
bool isColable() const;
Collapse Expand Returns

True if able to apply cola to this benefit.

Collapse Expand Remarks

Code must not be special minimum or frozen minimum pia.

Collapse Expand Group

Pifc Methods

Collapse Expand Links
Pifc Class, Pifc Members, Pifc Methods


Pifc::isNewMfb Method

Pifc::isNewMfb Method
Pifc Class Pifc Members Pifc Methods

Returns true if wage-indexed mfb applies to this benefit.

C++
bool isNewMfb() const;
Collapse Expand Returns

True if wage-indexed mfb applies to this benefit.

Collapse Expand Group

Pifc Methods

Collapse Expand Links
Pifc Class, Pifc Members, Pifc Methods


Pifc::pifcCal Method

Pifc::pifcCal Method
Pifc Class Pifc Members Pifc Methods

Calculates applicable pifc.

C++
static char pifcCal(
    int appnum,
    PiaMethod::WindfallElimType indwind,
    OldStart::OldStartType methodOS,
    bool bamend90,
    bool btotalize
);
Collapse Expand Parameters
Parameters | Description
int appnum | Number of applicable pia method (see PiaMethod::pia_type).
PiaMethod::WindfallElimType indwind | Indicator for windfall elimination provision.
OldStart::OldStartType methodOS | Old-start PIA calculation method (unused if no old start involved).
bool bamend90 | True if entitlement after 1990 amendments, or if earnings in 1992 or later were used to increase the new-start PIA.
bool btotalize | True if totalization applies.
Collapse Expand Returns

Applicable pifc.

Collapse Expand Remarks

Note that this is a static function.

Collapse Expand Group

Pifc Methods

Collapse Expand Links
Pifc Class, Pifc Members, Pifc Methods


Pifc::set Method

Pifc::set Method
Pifc Class Pifc Members Pifc Methods

Sets the pifc code.

C++
void set(
    char newCode
);
Collapse Expand Parameters
Parameters | Description
char newCode | New pifc code.
Collapse Expand Group

Pifc Methods

Collapse Expand Links
Pifc Class, Pifc Members, Pifc Methods


PortionAime Class

PortionAime Class
PortionAime Methods PortionAime Operators PortionAime Nested Types PortionAime Members PortionAime.h Classes

Manages the array of portions of AIME in the PIA formula.

Collapse Expand Class Hierarchy
  PortionAime
C++
class PortionAime;
Collapse Expand File

File: PortionAime.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is used in WageIndGeneral. There is an array with up to 5 slots for portions of AIME.

Collapse Expand Group

Classes

Collapse Expand Links
PortionAime Methods, PortionAime Operators, PortionAime Nested Types, PortionAime Members, PortionAime.h, Classes


PortionAime Members

PortionAime Members
PortionAime Class Legend Public Methods Public Nested Types

The following tables list the members exposed by PortionAime.

Collapse Expand Class

PortionAime Class

Collapse Expand Public Methods
Name | Description
PortionAime | Constructor.
as_array | Returns AIME portions as a simple array.
begin | This is the overview for the begin method overload.
deleteContents | Zeroes out all values.
end | This is the overview for the end method overload.
getNumPart | Returns the number of AIME portions.
max_size | Returns maximum number of AIME portions.
setNumPart | Sets number of AIME portions.
size | Returns number of AIME portions.
~PortionAime | Destroys bend point array.
Collapse Expand Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of size in this array.
value_type | The type of data in this array.
Collapse Expand Public Operators
Name | Description
[] | This is the overview for the [] operator overload.
Collapse Expand Links
PortionAime Class, Legend, Public Methods, Public Nested Types


PortionAime::PortionAime Constructor

PortionAime::PortionAime Constructor
PortionAime Class PortionAime Members PortionAime Class

Constructor.

C++
PortionAime(
    int newNumPart
);
Collapse Expand Parameters
Parameters | Description
int newNumPart | Number of AIME portions in formula.
Collapse Expand Class

PortionAime Class

Collapse Expand Links
PortionAime Class, PortionAime Members, PortionAime Class


PortionAime::~PortionAime Destructor

PortionAime::~PortionAime Destructor
PortionAime Class PortionAime Members PortionAime Class

Destroys bend point array.

C++
~PortionAime();
Collapse Expand Class

PortionAime Class

Collapse Expand Links
PortionAime Class, PortionAime Members, PortionAime Class


PortionAime Methods

PortionAime Methods
PortionAime Class Legend Public Methods

The methods of the PortionAime class are listed here.

Collapse Expand Class

PortionAime Class

Collapse Expand Public Methods
Name | Description
as_array | Returns AIME portions as a simple array.
begin | This is the overview for the begin method overload.
deleteContents | Zeroes out all values.
end | This is the overview for the end method overload.
getNumPart | Returns the number of AIME portions.
max_size | Returns maximum number of AIME portions.
setNumPart | Sets number of AIME portions.
size | Returns number of AIME portions.
Collapse Expand Links
PortionAime Class, Legend, Public Methods


PortionAime::as_array Method

PortionAime::as_array Method
PortionAime Class PortionAime Members PortionAime Methods

Returns AIME portions as a simple array.

C++
double* as_array();
Collapse Expand Returns

AIME portions as a simple array.

Collapse Expand Group

PortionAime Methods

Collapse Expand Links
PortionAime Class, PortionAime Members, PortionAime Methods


begin Method

begin Method
PortionAime Methods

This is the overview for the begin method overload.

Collapse Expand Overload List
Name | Description
PortionAime::begin () | Returns beginning of array, non-const version.
PortionAime::begin () | Returns beginning of array, non-const version.
Collapse Expand Group

PortionAime Methods

Collapse Expand Links
PortionAime Methods


PortionAime::begin Method ()

PortionAime::begin Method ()
PortionAime Class PortionAime Members begin Method

Returns beginning of array, non-const version.

C++
iterator begin();
Collapse Expand Returns

Beginning of array.

Collapse Expand Group

begin Method

Collapse Expand Links
PortionAime Class, PortionAime Members, begin Method


PortionAime::begin Method ()

PortionAime::begin Method ()
PortionAime Class PortionAime Members begin Method

Returns beginning of array, non-const version.

C++
const_iterator begin() const;
Collapse Expand Returns

Beginning of array.

Collapse Expand Group

begin Method

Collapse Expand Links
PortionAime Class, PortionAime Members, begin Method


PortionAime::deleteContents Method

PortionAime::deleteContents Method
PortionAime Class PortionAime Members PortionAime Methods

Zeroes out all values.

C++
void deleteContents();
Collapse Expand Group

PortionAime Methods

Collapse Expand Links
PortionAime Class, PortionAime Members, PortionAime Methods


end Method

end Method
PortionAime Methods

This is the overview for the end method overload.

Collapse Expand Overload List
Name | Description
PortionAime::end () | Returns one past end of array, non-const version.
PortionAime::end () | Returns one past end of array, const version.
Collapse Expand Group

PortionAime Methods

Collapse Expand Links
PortionAime Methods


PortionAime::end Method ()

PortionAime::end Method ()
PortionAime Class PortionAime Members end Method

Returns one past end of array, non-const version.

C++
iterator end();
Collapse Expand Returns

One past end of array.

Collapse Expand Group

end Method

Collapse Expand Links
PortionAime Class, PortionAime Members, end Method


PortionAime::end Method ()

PortionAime::end Method ()
PortionAime Class PortionAime Members end Method

Returns one past end of array, const version.

C++
const_iterator end() const;
Collapse Expand Returns

One past end of array.

Collapse Expand Group

end Method

Collapse Expand Links
PortionAime Class, PortionAime Members, end Method


PortionAime::getNumPart Method

PortionAime::getNumPart Method
PortionAime Class PortionAime Members PortionAime Methods

Returns the number of AIME portions.

C++
size_type getNumPart() const;
Collapse Expand Returns

Number of AIME portions.

Collapse Expand Group

PortionAime Methods

Collapse Expand Links
PortionAime Class, PortionAime Members, PortionAime Methods


PortionAime::max_size Method

PortionAime::max_size Method
PortionAime Class PortionAime Members PortionAime Methods

Returns maximum number of AIME portions.

C++
size_type max_size() const;
Collapse Expand Returns

Number of AIME portions.

Collapse Expand Group

PortionAime Methods

Collapse Expand Links
PortionAime Class, PortionAime Members, PortionAime Methods


PortionAime::setNumPart Method

PortionAime::setNumPart Method
PortionAime Class PortionAime Members PortionAime Methods

Sets number of AIME portions.

C++
void setNumPart(
    int newNumPart
);
Collapse Expand Parameters
Parameters | Description
int newNumPart | Number of AIME portions in formula.
Collapse Expand Group

PortionAime Methods

Collapse Expand Links
PortionAime Class, PortionAime Members, PortionAime Methods


PortionAime::size Method

PortionAime::size Method
PortionAime Class PortionAime Members PortionAime Methods

Returns number of AIME portions.

C++
size_type size() const;
Collapse Expand Returns

Number of AIME portions.

Collapse Expand Group

PortionAime Methods

Collapse Expand Links
PortionAime Class, PortionAime Members, PortionAime Methods


PortionAime Operators

PortionAime Operators
PortionAime Class Legend

The operators of the PortionAime class are listed here.

Collapse Expand Class

PortionAime Class

Collapse Expand Public Operators
Name | Description
[] | This is the overview for the [] operator overload.
Collapse Expand Links
PortionAime Class, Legend


[] Operator

[] Operator
PortionAime Operators

This is the overview for the [] operator overload.

Collapse Expand Overload List
Name | Description
PortionAime::[] (std::size_t) | Returns a pia formula AIME portion, non-const version.
PortionAime::[] (std::size_t) | Returns a pia formula AIME portion, const version.
Collapse Expand Group

PortionAime Operators

Collapse Expand Links
PortionAime Operators


PortionAime::[] Operator (std::size_t)

PortionAime::[] Operator (std::size_t)
PortionAime Class PortionAime Members [] Operator

Returns a pia formula AIME portion, non-const version.

C++
reference operator [](
    std::size_t index
);
Collapse Expand Parameters
Parameters | Description
std::size_t index | Index of AIME portion desired.
Collapse Expand Returns

A pia formula AIME portion.

Collapse Expand Group

[] Operator

Collapse Expand Links
PortionAime Class, PortionAime Members, [] Operator


PortionAime::[] Operator (std::size_t)

PortionAime::[] Operator (std::size_t)
PortionAime Class PortionAime Members [] Operator

Returns a pia formula AIME portion, const version.

C++
const_reference operator [](
    std::size_t index
) const;
Collapse Expand Parameters
Parameters | Description
std::size_t index | Index of AIME portion desired.
Collapse Expand Returns

A pia formula AIME portion.

Collapse Expand Group

[] Operator

Collapse Expand Links
PortionAime Class, PortionAime Members, [] Operator


PortionAime Nested Types

PortionAime Nested Types
PortionAime Class Public Nested Types

The nested types of the PortionAime class are listed here.

Collapse Expand Class

PortionAime Class

Collapse Expand Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of size in this array.
value_type | The type of data in this array.
Collapse Expand Links
PortionAime Class, Public Nested Types


PortionAime::const_iterator Nested Type

PortionAime::const_iterator Nested Type
PortionAime Class PortionAime Members PortionAime Nested Types

A const iterator for this array.

C++
typedef const double* const_iterator;
Collapse Expand Group

PortionAime Nested Types

Collapse Expand Links
PortionAime Class, PortionAime Members, PortionAime Nested Types


PortionAime::const_reference Nested Type

PortionAime::const_reference Nested Type
PortionAime Class PortionAime Members PortionAime Nested Types

A const reference for this array.

C++
typedef const double& const_reference;
Collapse Expand Group

PortionAime Nested Types

Collapse Expand Links
PortionAime Class, PortionAime Members, PortionAime Nested Types


PortionAime::difference_type Nested Type

PortionAime::difference_type Nested Type
PortionAime Class PortionAime Members PortionAime Nested Types

The type of difference in this array.

C++
typedef ptrdiff_t difference_type;
Collapse Expand Group

PortionAime Nested Types

Collapse Expand Links
PortionAime Class, PortionAime Members, PortionAime Nested Types


PortionAime::iterator Nested Type

PortionAime::iterator Nested Type
PortionAime Class PortionAime Members PortionAime Nested Types

An iterator for this array.

C++
typedef double* iterator;
Collapse Expand Group

PortionAime Nested Types

Collapse Expand Links
PortionAime Class, PortionAime Members, PortionAime Nested Types


PortionAime::reference Nested Type

PortionAime::reference Nested Type
PortionAime Class PortionAime Members PortionAime Nested Types

A reference for this array.

C++
typedef double& reference;
Collapse Expand Group

PortionAime Nested Types

Collapse Expand Links
PortionAime Class, PortionAime Members, PortionAime Nested Types


PortionAime::size_type Nested Type

PortionAime::size_type Nested Type
PortionAime Class PortionAime Members PortionAime Nested Types

The type of size in this array.

C++
typedef std::size_t size_type;
Collapse Expand Group

PortionAime Nested Types

Collapse Expand Links
PortionAime Class, PortionAime Members, PortionAime Nested Types


PortionAime::value_type Nested Type

PortionAime::value_type Nested Type
PortionAime Class PortionAime Members PortionAime Nested Types

The type of data in this array.

C++
typedef double value_type;
Collapse Expand Group

PortionAime Nested Types

Collapse Expand Links
PortionAime Class, PortionAime Members, PortionAime Nested Types


PresValFacs Class

PresValFacs Class
PresValFacs Methods PresValFacs Members PresValFacs.h Classes

Manages an array of present value factors.

Collapse Expand Class Hierarchy
  PresValFacsPresValFacs
C++
class PresValFacs : public DoubleAnnual;
Collapse Expand File

File: PresValFacs.h

Module: PiaData Library

Collapse Expand Remarks

The factors are used to discount money from December 31 of a year back to January 1 of the base year (or, equivalently, back to December 31 of the year prior to the base year).

Collapse Expand Group

Classes

Collapse Expand Links
PresValFacs Methods, PresValFacs Members, PresValFacs.h, Classes


PresValFacs Members

PresValFacs Members
PresValFacs Class Legend Public Data Members Public Friends Public Methods

The following tables list the members exposed by PresValFacs.

Collapse Expand Class

PresValFacs Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PresValFacs | Constructor.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects present value factors for the given interest rates.
~PresValFacs | Destroys present value factors array.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
PresValFacs Class, Legend, Public Data Members, Public Friends, Public Methods


PresValFacs::PresValFacs Constructor

PresValFacs::PresValFacs Constructor
PresValFacs Class PresValFacs Members PresValFacs Class

Constructor.

C++
PresValFacs(
    const DoubleAnnual& intRates
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& intRates | Array of interest rates.
Collapse Expand Remarks

Calculates the present value factors based on the interest rates passed in.

Collapse Expand Class

PresValFacs Class

Collapse Expand Links
PresValFacs Class, PresValFacs Members, PresValFacs Class


PresValFacs::~PresValFacs Destructor

PresValFacs::~PresValFacs Destructor
PresValFacs Class PresValFacs Members PresValFacs Class

Destroys present value factors array.

C++
~PresValFacs();
Collapse Expand Class

PresValFacs Class

Collapse Expand Links
PresValFacs Class, PresValFacs Members, PresValFacs Class


PresValFacs Methods

PresValFacs Methods
PresValFacs Class Legend Public Methods

The methods of the PresValFacs class are listed here.

Collapse Expand Class

PresValFacs Class

Collapse Expand Public Methods
Name | Description
project | Projects present value factors for the given interest rates.
Collapse Expand Links
PresValFacs Class, Legend, Public Methods


PresValFacs::project Method

PresValFacs::project Method
PresValFacs Class PresValFacs Members PresValFacs Methods

Projects present value factors for the given interest rates.

C++
void project(
    const DoubleAnnual& intRates
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& intRates | An array of interest rates.
Collapse Expand Group

PresValFacs Methods

Collapse Expand Links
PresValFacs Class, PresValFacs Members, PresValFacs Methods


Psa Class

Psa Class
Psa Enumerations Psa Data Members Psa Methods Psa Members Psa.h Classes

Manages the (theoretical) PSA accounts.

Collapse Expand Class Hierarchy
  Psa
C++
class Psa;
Collapse Expand File

File: Psa.h

Module: PiaData Library

Collapse Expand Remarks

Manages the (theoretical) PSA accounts.

Collapse Expand Group

Classes

Collapse Expand Links
Psa Enumerations, Psa Data Members, Psa Methods, Psa Members, Psa.h, Classes


Psa Members

Psa Members
Enumerations Psa Class Legend Protected Methods Public Data Members Public Methods

The following tables list the members exposed by Psa.

Collapse Expand Enumerations
Name | Description
AnnuityType | Type of annuity.
DimLimits | Constants for dimensioning.
InvestmentType | Types of investments.
PsaSexType | The sex types for PSA annuities.
UnisexType | Codes for using unisex annuity factors.
Collapse Expand Class

Psa Class

Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
getAgeIndex | Returns an age converted to an age index.
getLimitedYear | Returns a year converted to a limited year.
getSexType | Returns the sex code to use for annuities for a specified person.
interpolateFactors | Interpolates the JS annuity factors since the input file only has data for every 10th year.
Collapse Expand Public Data Members
Name | Description
contribAge | The age splits for contribution rates, when using rates based on age.
contribPerc | Contribution rates when using rates based on age, as opposed to using the same set rates for everybody.
Collapse Expand Public Methods
Name | Description
Psa | Constructor.
annuityCal | Calculate an initial psa (monthly) annuity.
annuityRevCal | Calculate the ammount that a person would get if he sold back the specified (monthly) annuity.
contribCal | Calculates contribution to psa for one year, first limiting the earnings to the maximum taxable for the year of contribution.
getAdminFee | Returns the annual administrative fee.
getContribRate | Returns one psa contribution rate for a specified year.
getInvestPerc | Returns percentage of contributions that go into the investment.
getMean | Returns the mean of the normal distribution for bonds.
getMngmtFee | Returns the annual management fee.
getPercToSpouse | Returns percentage of contribution going to spouse, if any.
getStdDev | Returns standard deviation of the normal distribution for specified type.
setParameters | Sets psa parameters from the lawchange file.
~Psa | Destructor.
Collapse Expand Links
Enumerations, Psa Class, Legend, Protected Methods, Public Data Members, Public Methods


Psa::Psa Constructor

Psa::Psa Constructor
Psa Class Psa Members Psa Class

Constructor.

C++
Psa(
    const LawChangeArray& newLawChange,
    const PiaParams& newPiaParams,
    int newAlt
);
Collapse Expand Parameters
Parameters | Description
const LawChangeArray& newLawChange | Law change data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newAlt | Trustees Report alternative (1, 2, or 3).
Collapse Expand Remarks

Creates the annuity factor and contribution rate arrays.

Collapse Expand Class

Psa Class

Collapse Expand Links
Psa Class, Psa Members, Psa Class


Psa::~Psa Destructor

Psa::~Psa Destructor
Psa Class Psa Members Psa Class

Destructor.

C++
~Psa();
Collapse Expand Remarks

Deletes the annuity factor and contribution rate arrays.

Collapse Expand Class

Psa Class

Collapse Expand Links
Psa Class, Psa Members, Psa Class


Psa Enumerations

Psa Enumerations
Enumerations Psa Class Legend

The enumerations of the Psa class are listed here.

Collapse Expand Enumerations
Name | Description
AnnuityType | Type of annuity.
DimLimits | Constants for dimensioning.
InvestmentType | Types of investments.
PsaSexType | The sex types for PSA annuities.
UnisexType | Codes for using unisex annuity factors.
Collapse Expand Class

Psa Class

Collapse Expand Links
Enumerations, Psa Class, Legend


Psa::AnnuityType Enumeration

Psa::AnnuityType Enumeration
Psa.h Psa Enumerations

Type of annuity.

C++
enum AnnuityType {
  ANNUITY_SL,
  ANNUITY_JS
};
Collapse Expand File

File: Psa.h

Module: PiaData Library

Collapse Expand Members
Members | Description
ANNUITY_SL | Always straight life.
ANNUITY_JS | Using joint and 2/3 survivor for married people.
Collapse Expand Group

Psa Enumerations

Collapse Expand Links
Psa.h, Psa Enumerations


Psa::DimLimits Enumeration

Psa::DimLimits Enumeration
Psa.h Psa Enumerations

Constants for dimensioning.

C++
enum DimLimits {
  MAXCONTRIBRATES = 3,
  MAXCONTRIBAGES = 3,
  FIRST_AGE = 16,
  NUM_ANNUITY_AGES = 60
};
Collapse Expand File

File: Psa.h

Module: PiaData Library

Collapse Expand Members
Members | Description
MAXCONTRIBRATES = 3 | The maximum number of bend points allowed in the contribution rate.
MAXCONTRIBAGES = 3 | The maximum number of bend points allowed in the contribution rate, when they vary by age.
FIRST_AGE = 16 | The lowest age considered for annuities.
NUM_ANNUITY_AGES = 60 | The number of ages for which annuities can start (16 to 75).
Collapse Expand Group

Psa Enumerations

Collapse Expand Links
Psa.h, Psa Enumerations


Psa::InvestmentType Enumeration

Psa::InvestmentType Enumeration
Psa.h Psa Enumerations

Types of investments.

C++
enum InvestmentType {
  BONDS,
  STOCKS,
  NUM_INVESTMENTS
};
Collapse Expand File

File: Psa.h

Module: PiaData Library

Collapse Expand Members
Members | Description
BONDS | Bonds.
STOCKS | Stocks.
NUM_INVESTMENTS | Number of types of investments.
Collapse Expand Remarks

If any more investment types are added, the initialization of Psa::contribPerc in Psa.cpp must be updated!

Collapse Expand Group

Psa Enumerations

Collapse Expand Links
Psa.h, Psa Enumerations


Psa::PsaSexType Enumeration

Psa::PsaSexType Enumeration
Psa.h Psa Enumerations

The sex types for PSA annuities.

C++
enum PsaSexType {
  PSA_MALE,
  PSA_FEMALE,
  PSA_UNISEX,
  PSA_NUM_SEX
};
Collapse Expand File

File: Psa.h

Module: PiaData Library

Collapse Expand Members
Members | Description
PSA_MALE | Male.
PSA_FEMALE | Female.
PSA_UNISEX | Unisex.
PSA_NUM_SEX | Number of sex types considered.
Collapse Expand Group

Psa Enumerations

Collapse Expand Links
Psa.h, Psa Enumerations


Psa::UnisexType Enumeration

Psa::UnisexType Enumeration
Psa.h Psa Enumerations

Codes for using unisex annuity factors.

C++
enum UnisexType {
  UNISEX_SL_AND_JS,
  UNISEX_SL_NOT_JS,
  UNISEX_JS_NOT_SL,
  NO_UNISEX
};
Collapse Expand File

File: Psa.h

Module: PiaData Library

Collapse Expand Members
Members | Description
UNISEX_SL_AND_JS | Unisex for SL and JS annuities.
UNISEX_SL_NOT_JS | Unisex for SL annuitites, sex-specific for JS annuities.
UNISEX_JS_NOT_SL | SL annuitites are sex-specific, unisex for JS annuities.
NO_UNISEX | SL and JS annuitites are sex-specific.
Collapse Expand Group

Psa Enumerations

Collapse Expand Links
Psa.h, Psa Enumerations


Psa Data Members

Psa Data Members
Psa Class Legend Public Data Members

The data members of the Psa class are listed here.

Collapse Expand Class

Psa Class

Collapse Expand Public Data Members
Name | Description
contribAge | The age splits for contribution rates, when using rates based on age.
contribPerc | Contribution rates when using rates based on age, as opposed to using the same set rates for everybody.
Collapse Expand Links
Psa Class, Legend, Public Data Members


Psa::contribAge Data Member

Psa::contribAge Data Member
Psa Class Psa Members Psa Data Members

The age splits for contribution rates, when using rates based on age.

C++
const int contribAge[MAXCONTRIBAGES];
Collapse Expand Group

Psa Data Members

Collapse Expand Links
Psa Class, Psa Members, Psa Data Members


Psa::contribPerc Data Member

Psa::contribPerc Data Member
Psa Class Psa Members Psa Data Members

Contribution rates when using rates based on age, as opposed to using the same set rates for everybody.

C++
const double contribPerc[NUM_INVESTMENTS][MAXCONTRIBAGES + 1];
Collapse Expand Group

Psa Data Members

Collapse Expand Links
Psa Class, Psa Members, Psa Data Members


Psa Methods

Psa Methods
Psa Class Legend Protected Methods Public Methods

The methods of the Psa class are listed here.

Collapse Expand Class

Psa Class

Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
getAgeIndex | Returns an age converted to an age index.
getLimitedYear | Returns a year converted to a limited year.
getSexType | Returns the sex code to use for annuities for a specified person.
interpolateFactors | Interpolates the JS annuity factors since the input file only has data for every 10th year.
Collapse Expand Public Methods
Name | Description
annuityCal | Calculate an initial psa (monthly) annuity.
annuityRevCal | Calculate the ammount that a person would get if he sold back the specified (monthly) annuity.
contribCal | Calculates contribution to psa for one year, first limiting the earnings to the maximum taxable for the year of contribution.
getAdminFee | Returns the annual administrative fee.
getContribRate | Returns one psa contribution rate for a specified year.
getInvestPerc | Returns percentage of contributions that go into the investment.
getMean | Returns the mean of the normal distribution for bonds.
getMngmtFee | Returns the annual management fee.
getPercToSpouse | Returns percentage of contribution going to spouse, if any.
getStdDev | Returns standard deviation of the normal distribution for specified type.
setParameters | Sets psa parameters from the lawchange file.
Collapse Expand Links
Psa Class, Legend, Protected Methods, Public Methods


Psa::annuityCal Method

Psa::annuityCal Method
Psa Class Psa Members Psa Methods

Calculate an initial psa (monthly) annuity.

C++
double annuityCal(
    double amount,
    int year,
    Sex::sex_type sex,
    int workerAge,
    int spouseAge
) const;
Collapse Expand Parameters
Parameters | Description
double amount | Amount in psa account.
int year | Year for which annuity is being calculated.
Sex::sex_type sex | The sex of the person.
int workerAge | The age in years of the person getting the annuity.
int spouseAge | The age in years of the person's spouse (0 if not married).
Collapse Expand Returns

Initial psa (monthly) annuity.

Collapse Expand Group

Psa Methods

Collapse Expand Links
Psa Class, Psa Members, Psa Methods


Psa::annuityRevCal Method

Psa::annuityRevCal Method
Psa Class Psa Members Psa Methods

Calculate the ammount that a person would get if he sold back the specified (monthly) annuity.

C++
double annuityRevCal(
    double annuity,
    int year,
    Sex::sex_type sex,
    int workerAge,
    int spouseAge
) const;
Collapse Expand Parameters
Parameters | Description
double annuity | Amount of the (monthly) annuity.
int year | Year for which annuity is being evaluated.
Sex::sex_type sex | The sex of the person.
int workerAge | The age in years of the person getting the annuity.
int spouseAge | The age in years of the person's spouse (0 if not married).
Collapse Expand Returns

Amount that the person's annuity is worth.

Collapse Expand Group

Psa Methods

Collapse Expand Links
Psa Class, Psa Members, Psa Methods


Psa::contribCal Method

Psa::contribCal Method
Psa Class Psa Members Psa Methods

Calculates contribution to psa for one year, first limiting the earnings to the maximum taxable for the year of contribution.

C++
double contribCal(
    int eligYear,
    int benYear,
    double earnings
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
int benYear | Year of contribution.
double earnings | The earnings on which contribution is made.
Collapse Expand Returns

Contribution to psa for one year.

Collapse Expand Group

Psa Methods

Collapse Expand Links
Psa Class, Psa Members, Psa Methods


Psa::getAdminFee Method

Psa::getAdminFee Method
Psa Class Psa Members Psa Methods

Returns the annual administrative fee.

C++
double getAdminFee(
    InvestmentType type
) const;
Collapse Expand Parameters
Parameters | Description
InvestmentType type | Type of investment.
Collapse Expand Returns

The annual administrative fee.

Collapse Expand Group

Psa Methods

Collapse Expand Links
Psa Class, Psa Members, Psa Methods


Psa::getAgeIndex Method

Psa::getAgeIndex Method
Psa Class Psa Members Psa Methods

Returns an age converted to an age index.

C++
static int getAgeIndex(
    int theAge
);
Collapse Expand Parameters
Parameters | Description
int theAge | The age to convert to an age index.
Collapse Expand Returns

An age converted to an age index.

Collapse Expand Remarks

The age index is 0 for age 16, 1 for age 17, ..., 59 for ages 75 and above.

Collapse Expand Group

Psa Methods

Collapse Expand Links
Psa Class, Psa Members, Psa Methods


Psa::getContribRate Method

Psa::getContribRate Method
Psa Class Psa Members Psa Methods

Returns one psa contribution rate for a specified year.

C++
double getContribRate(
    int benYear,
    int bpNum
) const;
Collapse Expand Parameters
Parameters | Description
int benYear | The year.
int bpNum | Contribution rate bend point number.
Collapse Expand Returns

One psa contribution rate for a specified year.

Collapse Expand Group

Psa Methods

Collapse Expand Links
Psa Class, Psa Members, Psa Methods


Psa::getInvestPerc Method

Psa::getInvestPerc Method
Psa Class Psa Members Psa Methods

Returns percentage of contributions that go into the investment.

C++
double getInvestPerc(
    InvestmentType type,
    int age,
    int eligYear,
    int benYear
) const;
Collapse Expand Parameters
Parameters | Description
InvestmentType type | Type of investment.
int age | The age of the contributor in years.
int eligYear | Year of eligibility.
int benYear | Year of contribution.
Collapse Expand Returns

Percentage of contributions that go into the investment.

Collapse Expand Group

Psa Methods

Collapse Expand Links
Psa Class, Psa Members, Psa Methods


Psa::getLimitedYear Method

Psa::getLimitedYear Method
Psa Class Psa Members Psa Methods

Returns a year converted to a limited year.

C++
int getLimitedYear(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | The year for which a limited year is desired.
Collapse Expand Returns

A year converted to a limited year.

Collapse Expand Remarks

The limited year is a minimum of current Trustees Report year and a maximum of LASTYEARLR.

Collapse Expand Group

Psa Methods

Collapse Expand Links
Psa Class, Psa Members, Psa Methods


Psa::getMean Method

Psa::getMean Method
Psa Class Psa Members Psa Methods

Returns the mean of the normal distribution for bonds.

C++
double getMean(
    InvestmentType type
) const;
Collapse Expand Parameters
Parameters | Description
InvestmentType type | Type of investment.
Collapse Expand Returns

The mean of the normal distribution for bonds.

Collapse Expand Group

Psa Methods

Collapse Expand Links
Psa Class, Psa Members, Psa Methods


Psa::getMngmtFee Method

Psa::getMngmtFee Method
Psa Class Psa Members Psa Methods

Returns the annual management fee.

C++
double getMngmtFee(
    InvestmentType type
) const;
Collapse Expand Parameters
Parameters | Description
InvestmentType type | Type of investment.
Collapse Expand Returns

The annual management fee.

Collapse Expand Group

Psa Methods

Collapse Expand Links
Psa Class, Psa Members, Psa Methods


Psa::getPercToSpouse Method

Psa::getPercToSpouse Method
Psa Class Psa Members Psa Methods

Returns percentage of contribution going to spouse, if any.

C++
double getPercToSpouse() const;
Collapse Expand Returns

Percentage of contribution going to spouse, if any.

Collapse Expand Group

Psa Methods

Collapse Expand Links
Psa Class, Psa Members, Psa Methods


Psa::getSexType Method

Psa::getSexType Method
Psa Class Psa Members Psa Methods

Returns the sex code to use for annuities for a specified person.

C++
PsaSexType getSexType(
    Sex::sex_type sex,
    bool isSLorUnmarried
) const;
Collapse Expand Parameters
Parameters | Description
Sex::sex_type sex | The sex of the person.
bool isSLorUnmarried | True if an SL annuity or if person is unmarried, false otherwise.
Collapse Expand Returns

The sex code to use for annuities for a specified person.

Collapse Expand Group

Psa Methods

Collapse Expand Links
Psa Class, Psa Members, Psa Methods


Psa::getStdDev Method

Psa::getStdDev Method
Psa Class Psa Members Psa Methods

Returns standard deviation of the normal distribution for specified type.

C++
double getStdDev(
    InvestmentType type
) const;
Collapse Expand Parameters
Parameters | Description
InvestmentType type | Type of investment.
Collapse Expand Returns

Standard deviation of the normal distribution for specified type.

Collapse Expand Group

Psa Methods

Collapse Expand Links
Psa Class, Psa Members, Psa Methods


Psa::interpolateFactors Method

Psa::interpolateFactors Method
Psa Class Psa Members Psa Methods

Interpolates the JS annuity factors since the input file only has data for every 10th year.

C++
void interpolateFactors(
    int year1,
    int year2,
    PsaSexType sex
);
Collapse Expand Parameters
Parameters | Description
int year1 | Earlier year with data.
int year2 | Latter year with data.
PsaSexType sex | The sex of the person with the annuity.
Collapse Expand Remarks

The years in between year1 and year2 are the ones with missing data that needs to be filled in by this function.

Collapse Expand Group

Psa Methods

Collapse Expand Links
Psa Class, Psa Members, Psa Methods


Psa::setParameters Method

Psa::setParameters Method
Psa Class Psa Members Psa Methods

Sets psa parameters from the lawchange file.

C++
void setParameters(
    int newAlt
);
Collapse Expand Parameters
Parameters | Description
int newAlt | Trustees Report alternative (1, 2, or 3).
Collapse Expand Group

Psa Methods

Collapse Expand Links
Psa Class, Psa Members, Psa Methods


Qc Class

Qc Class
Qc Data Members Qc Methods Qc Members qc.h Classes

Handles calculations with quarters of coverage for one year.

Collapse Expand Class Hierarchy
  Qc
C++
class Qc;
Collapse Expand File

File: qc.h

Module: PiaData Library

Collapse Expand Remarks

The number of quarters of coverage for one year must not exceed 4. This class has two static functions to handle qc calculations.

Collapse Expand Group

Classes

Collapse Expand Links
Qc Data Members, Qc Methods, Qc Members, qc.h, Classes


Qc Members

Qc Members
Qc Class Legend Public Data Members Public Methods

The following tables list the members exposed by Qc.

Collapse Expand Class

Qc Class

Collapse Expand Public Data Members
Name | Description
MAXQCSINYEAR | The maximum number of qcs in one year (4).
Collapse Expand Public Methods
Name | Description
check | Checks annual quarters of coverage for one year.
qcCal | Returns number of quarters of coverage for one year, applying annual test.
Collapse Expand Links
Qc Class, Legend, Public Data Members, Public Methods


Qc Data Members

Qc Data Members
Qc Class Legend Public Data Members

The data members of the Qc class are listed here.

Collapse Expand Class

Qc Class

Collapse Expand Public Data Members
Name | Description
MAXQCSINYEAR | The maximum number of qcs in one year (4).
Collapse Expand Links
Qc Class, Legend, Public Data Members


Qc::MAXQCSINYEAR Data Member

Qc::MAXQCSINYEAR Data Member
Qc Class Qc Members Qc Data Members

The maximum number of qcs in one year (4).

C++
const unsigned int MAXQCSINYEAR = 4u;
Collapse Expand Group

Qc Data Members

Collapse Expand Links
Qc Class, Qc Members, Qc Data Members


Qc Methods

Qc Methods
Qc Class Legend Public Methods

The methods of the Qc class are listed here.

Collapse Expand Class

Qc Class

Collapse Expand Public Methods
Name | Description
check | Checks annual quarters of coverage for one year.
qcCal | Returns number of quarters of coverage for one year, applying annual test.
Collapse Expand Links
Qc Class, Legend, Public Methods


Qc::check Method

Qc::check Method
Qc Class Qc Members Qc Methods

Checks annual quarters of coverage for one year.

C++
static void check(
    unsigned newNumber
);
Collapse Expand Parameters
Parameters | Description
unsigned newNumber | Value to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCANN if number of quarters of coverage is greater than Qc::MAXQCSINYEAR.
Collapse Expand Group

Qc Methods

Collapse Expand Links
Qc Class, Qc Members, Qc Methods


Qc::qcCal Method

Qc::qcCal Method
Qc Class Qc Members Qc Methods

Returns number of quarters of coverage for one year, applying annual test.

C++
static unsigned qcCal(
    double earnings,
    double qcAmount
);
Collapse Expand Parameters
Parameters | Description
double earnings | The earnings in the year.
double qcAmount | Amount required for one quarter of coverage.
Collapse Expand Returns

Number of quarters of coverage for one year. The number cannot exceed Qc::MAXQCSINYEAR.

Collapse Expand Group

Qc Methods

Collapse Expand Links
Qc Class, Qc Members, Qc Methods


Qcamt Class

Qcamt Class
Qcamt Constructor Qcamt Data Members Qcamt Methods Qcamt Members qcamt.h Classes

Manages an array of quarter of coverage amounts.

Collapse Expand Class Hierarchy
  QcamtQcamt
C++
class Qcamt : public DoubleAnnual;
Collapse Expand File

File: qcamt.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaParams.

Collapse Expand Group

Classes

Collapse Expand Links
Qcamt Constructor, Qcamt Data Members, Qcamt Methods, Qcamt Members, qcamt.h, Classes


Qcamt Members

Qcamt Members
Qcamt Class Legend Public Data Members Public Friends Public Methods

The following tables list the members exposed by Qcamt.

Collapse Expand Class

Qcamt Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
AUTO_YEAR | The year when automatic increases started for the quarter of coverage amount.
baseYear | Base year of data.
qcamt1977 | The quarter of coverage amount prior to 1978.
qcamt1978 | The quarter of coverage amount in 1978.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
Qcamt | Initializes a Qcamt, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects quarter of coverage amounts.
~Qcamt | Destructor.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
Qcamt Class, Legend, Public Data Members, Public Friends, Public Methods


Qcamt Constructor

Qcamt Constructor
Qcamt Class

Initializes a Qcamt, with or without a specified first year.

Collapse Expand Description

There are two versions of the Qcamt constructor. The last year of data is specified in both. But if the first year is not specified, it is assumed to be 1937.

Collapse Expand Overload List
Name | Description
Qcamt::Qcamt (int) | Initializes with base year 1937.
Qcamt::Qcamt (int, int) | Initializes with the data starting in a specified year.
Collapse Expand Class

Qcamt Class

Collapse Expand Links
Qcamt Class


Qcamt::Qcamt Constructor (int)

Qcamt::Qcamt Constructor (int)
Qcamt Class Qcamt Members Qcamt Constructor

Initializes with base year 1937.

C++
Qcamt(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | New last year of data.
Collapse Expand Group

Qcamt Constructor

Collapse Expand Links
Qcamt Class, Qcamt Members, Qcamt Constructor


Qcamt::Qcamt Constructor (int, int)

Qcamt::Qcamt Constructor (int, int)
Qcamt Class Qcamt Members Qcamt Constructor

Initializes with the data starting in a specified year.

C++
Qcamt(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | New base year of data.
int newLastYear | New last year of data.
Collapse Expand Group

Qcamt Constructor

Collapse Expand Links
Qcamt Class, Qcamt Members, Qcamt Constructor


Qcamt::~Qcamt Destructor

Qcamt::~Qcamt Destructor
Qcamt Class Qcamt Members Qcamt Class

Destructor.

C++
~Qcamt();
Collapse Expand Class

Qcamt Class

Collapse Expand Links
Qcamt Class, Qcamt Members, Qcamt Class


Qcamt Data Members

Qcamt Data Members
Qcamt Class Legend Public Data Members

The data members of the Qcamt class are listed here.

Collapse Expand Class

Qcamt Class

Collapse Expand Public Data Members
Name | Description
AUTO_YEAR | The year when automatic increases started for the quarter of coverage amount.
qcamt1977 | The quarter of coverage amount prior to 1978.
qcamt1978 | The quarter of coverage amount in 1978.
Collapse Expand Links
Qcamt Class, Legend, Public Data Members


Qcamt::AUTO_YEAR Data Member

Qcamt::AUTO_YEAR Data Member
Qcamt Class Qcamt Members Qcamt Data Members

The year when automatic increases started for the quarter of coverage amount.

C++
const int AUTO_YEAR = 1978;
Collapse Expand Group

Qcamt Data Members

Collapse Expand Links
Qcamt Class, Qcamt Members, Qcamt Data Members


Qcamt::qcamt1977 Data Member

Qcamt::qcamt1977 Data Member
Qcamt Class Qcamt Members Qcamt Data Members

The quarter of coverage amount prior to 1978.

C++
const double qcamt1977;
Collapse Expand Group

Qcamt Data Members

Collapse Expand Links
Qcamt Class, Qcamt Members, Qcamt Data Members


Qcamt::qcamt1978 Data Member

Qcamt::qcamt1978 Data Member
Qcamt Class Qcamt Members Qcamt Data Members

The quarter of coverage amount in 1978.

C++
const double qcamt1978;
Collapse Expand Group

Qcamt Data Members

Collapse Expand Links
Qcamt Class, Qcamt Members, Qcamt Data Members


Qcamt Methods

Qcamt Methods
Qcamt Class Legend Public Methods

The methods of the Qcamt class are listed here.

Collapse Expand Class

Qcamt Class

Collapse Expand Public Methods
Name | Description
project | Projects quarter of coverage amounts.
Collapse Expand Links
Qcamt Class, Legend, Public Methods


Qcamt::project Method

Qcamt::project Method
Qcamt Class Qcamt Members Qcamt Methods

Projects quarter of coverage amounts.

C++
void project(
    const DoubleAnnual& averageWages,
    int firstYeart
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& averageWages | Average wages to use in projection.
int firstYeart | First year of projection.
Collapse Expand Remarks

Projects beginning maximum of specified year or 1978, and continues to last year of data.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCAMT if average wages have not been set (only in debug mode).
Collapse Expand Group

Qcamt Methods

Collapse Expand Links
Qcamt Class, Qcamt Members, Qcamt Methods


QcArray Class

QcArray Class
QcArray Constructor QcArray Methods QcArray Friends QcArray Members QcArray.h Classes

Manages an array of annual quarters of coverage.

Collapse Expand Class Hierarchy
  QcArray
C++
class QcArray;
Collapse Expand File

File: QcArray.h

Module: PiaData Library

Collapse Expand Remarks

The quarters of coverage are stored in QcPacked structures to save space.

Collapse Expand See Also

QcPacked

Collapse Expand Group

Classes

Collapse Expand Links
QcArray Constructor, QcArray Methods, QcArray Friends, QcArray Members, QcArray.h, Classes


QcArray Members

QcArray Members
QcArray Class Legend Public Friends Public Methods

The following tables list the members exposed by QcArray.

Collapse Expand Class

QcArray Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Name | Description
QcArray | Initializes a QcArray, either with specified years or from another QcArray.
accumulate | Sums quarters of coverage over a period of years or quarters.
assign | Sets values for a specified range of years.
deleteContents | Sets values to zero.
get | Returns the number of quarters of coverage for one year.
getLastYear | Returns the last year of data.
set | Sets the number of quarters of coverage for one year.
toString | Converts a quarters of coverage array to a string.
~QcArray | Deletes allocated memory.
Collapse Expand Links
QcArray Class, Legend, Public Friends, Public Methods


QcArray Constructor

QcArray Constructor
QcArray Class

Initializes a QcArray, either with specified years or from another QcArray.

Collapse Expand Description

There are two versions of the QcArray constructor. The one with two year arguments initializes the specified first and last years, resizes the data array, and sets all data values to zero. The one with a QcArray argument copies the first and last years, and all data values, from the argument.

Collapse Expand Overload List
Name | Description
QcArray::QcArray (const QcArray&) | Copy constructor.
QcArray::QcArray (int, int) | Constructor.
Collapse Expand Class

QcArray Class

Collapse Expand Links
QcArray Class


QcArray::QcArray Constructor (const QcArray&)

QcArray::QcArray Constructor (const QcArray&)
QcArray Class QcArray Members QcArray Constructor

Copy constructor.

C++
QcArray(
    const QcArray& qcArray
);
Collapse Expand Parameters
Parameters | Description
const QcArray& qcArray | The QcArray to copy from.
Collapse Expand Remarks

Copies all values from the argument to this instance.

Collapse Expand Group

QcArray Constructor

Collapse Expand Links
QcArray Class, QcArray Members, QcArray Constructor


QcArray::QcArray Constructor (int, int)

QcArray::QcArray Constructor (int, int)
QcArray Class QcArray Members QcArray Constructor

Constructor.

C++
QcArray(
    int firstyr,
    int lastyr
);
Collapse Expand Parameters
Parameters | Description
int firstyr | New first year of data.
int lastyr | New last year of data.
Collapse Expand Remarks

Initializes the specified first and last years, resizes the data array, and sets all data values to zero.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCARRAY1 if first year is out of range (only in debug mode).
Collapse Expand Group

QcArray Constructor

Collapse Expand Links
QcArray Class, QcArray Members, QcArray Constructor


QcArray::~QcArray Destructor

QcArray::~QcArray Destructor
QcArray Class QcArray Members QcArray Class

Deletes allocated memory.

C++
~QcArray();
Collapse Expand Class

QcArray Class

Collapse Expand Links
QcArray Class, QcArray Members, QcArray Class


QcArray Methods

QcArray Methods
QcArray Class Legend Public Methods

The methods of the QcArray class are listed here.

Collapse Expand Class

QcArray Class

Collapse Expand Public Methods
Name | Description
accumulate | Sums quarters of coverage over a period of years or quarters.
assign | Sets values for a specified range of years.
deleteContents | Sets values to zero.
get | Returns the number of quarters of coverage for one year.
getLastYear | Returns the last year of data.
set | Sets the number of quarters of coverage for one year.
toString | Converts a quarters of coverage array to a string.
Collapse Expand Links
QcArray Class, Legend, Public Methods


accumulate Method

accumulate Method
QcArray Methods

Sums quarters of coverage over a period of years or quarters.

Collapse Expand Description

There are two versions of this function. The quarters of coverage can be summed over a period of years, or over a period of quarters.

Collapse Expand Overload List
Name | Description
QcArray::accumulate (const QtrYear&, const QtrYear&, unsigned) | Sums quarters of coverage over a period of years or quarters.
QcArray::accumulate (int, int, unsigned) | Sums quarters of coverage over a period of years or quarters.
Collapse Expand Group

QcArray Methods

Collapse Expand Links
QcArray Methods


QcArray::accumulate Method (const QtrYear&, const QtrYear&, unsigned)

QcArray::accumulate Method (const QtrYear&, const QtrYear&, unsigned)
QcArray Class QcArray Members accumulate Method

Sums quarters of coverage over a period of years or quarters.

C++
unsigned accumulate(
    const QtrYear& qtrYear1,
    const QtrYear& qtrYear2,
    unsigned startValue
) const;
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear1 | First quarter and year to sum.
const QtrYear& qtrYear2 | Last quarter and year to sum.
unsigned startValue | Starting value.
Collapse Expand Returns

Sum of quarters of coverage.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCARRAY3 if years are out of range (only in debug mode); of type PIA_IDS_QCARRAY4 if quarters are out of range (only in debug mode).
Collapse Expand Group

accumulate Method

Collapse Expand Links
QcArray Class, QcArray Members, accumulate Method


QcArray::accumulate Method (int, int, unsigned)

QcArray::accumulate Method (int, int, unsigned)
QcArray Class QcArray Members accumulate Method

Sums quarters of coverage over a period of years or quarters.

C++
unsigned accumulate(
    int firstyr,
    int lastyr,
    unsigned startValue
) const;
Collapse Expand Parameters
Parameters | Description
int firstyr | First year to sum.
int lastyr | Last year to sum.
unsigned startValue | Starting value.
Collapse Expand Returns

Sum of quarters of coverage.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCARRAY3 if years are out of range (only in debug mode); of type PIA_IDS_QCARRAY4 if quarters are out of range (only in debug mode).
Collapse Expand Group

accumulate Method

Collapse Expand Links
QcArray Class, QcArray Members, accumulate Method


assign Method

assign Method
QcArray Methods

Sets values for a specified range of years.

Collapse Expand Description

There are two versions of this function. The values to be assigned are taken from another QcArray, or are one specified value.

Collapse Expand Overload List
Name | Description
QcArray::assign (const QcArray &, int, int) | Sets values for the specified years from another QcArray.
QcArray::assign (unsigned, int, int) | Sets values for the specified years to one specified value.
Collapse Expand Group

QcArray Methods

Collapse Expand Links
QcArray Methods


QcArray::assign Method (const QcArray &, int, int)

QcArray::assign Method (const QcArray &, int, int)
QcArray Class QcArray Members assign Method

Sets values for the specified years from another QcArray.

C++
void assign(
    const QcArray & qcArray,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const QcArray & qcArray | The QcArray from which numbers of quarters of coverage are gotten.
int firstYeart | First year for which to set QCs.
int lastYeart | Last year for which to set QCs.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCARRAY1 if year is out of range (only in debug mode).
Collapse Expand Group

assign Method

Collapse Expand Links
QcArray Class, QcArray Members, assign Method


QcArray::assign Method (unsigned, int, int)

QcArray::assign Method (unsigned, int, int)
QcArray Class QcArray Members assign Method

Sets values for the specified years to one specified value.

C++
void assign(
    unsigned value,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
unsigned value | Amount to use in each year.
int firstYeart | First year for which to set QCs.
int lastYeart | Last year for which to set QCs.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCARRAY1 if year is out of range (only in debug mode).
Collapse Expand Group

assign Method

Collapse Expand Links
QcArray Class, QcArray Members, assign Method


deleteContents Method

deleteContents Method
QcArray Methods

Sets values to zero.

Collapse Expand Description

There are two versions of this function. The version with no arguments sets all values to zero. The version with two year arguments sets all values in that range to zero.

Collapse Expand Overload List
Name | Description
QcArray::deleteContents () | Sets values to zero.
QcArray::deleteContents (int, int) | Zeroes out all data.
Collapse Expand Group

QcArray Methods

Collapse Expand Links
QcArray Methods


QcArray::deleteContents Method ()

QcArray::deleteContents Method ()
QcArray Class QcArray Members deleteContents Method

Sets values to zero.

C++
void deleteContents();
Collapse Expand Remarks

The version with no arguments sets all values to zero. The version with 2 arguments sets values to zero in the specified range.

Collapse Expand Group

deleteContents Method

Collapse Expand Links
QcArray Class, QcArray Members, deleteContents Method


QcArray::deleteContents Method (int, int)

QcArray::deleteContents Method (int, int)
QcArray Class QcArray Members deleteContents Method

Zeroes out all data.

C++
void deleteContents(
    int firstyr,
    int lastyr
);
Collapse Expand Parameters
Parameters | Description
int firstyr | First year to zero.
int lastyr | Last year to zero.
Collapse Expand Group

deleteContents Method

Collapse Expand Links
QcArray Class, QcArray Members, deleteContents Method


QcArray::get Method

QcArray::get Method
QcArray Class QcArray Members QcArray Methods

Returns the number of quarters of coverage for one year.

C++
unsigned get(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which number of quarters of coverage is desired.
Collapse Expand Returns

The number of quarters of coverage for one year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCARRAY1 if year is out of range (only in debug mode).
Collapse Expand Group

QcArray Methods

Collapse Expand Links
QcArray Class, QcArray Members, QcArray Methods


QcArray::getLastYear Method

QcArray::getLastYear Method
QcArray Class QcArray Members QcArray Methods

Returns the last year of data.

C++
int getLastYear() const;
Collapse Expand Returns

The last year of data.

Collapse Expand Group

QcArray Methods

Collapse Expand Links
QcArray Class, QcArray Members, QcArray Methods


QcArray::set Method

QcArray::set Method
QcArray Class QcArray Members QcArray Methods

Sets the number of quarters of coverage for one year.

C++
void set(
    int year,
    unsigned value
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which number of quarters of coverage is set.
unsigned value | Number of quarters of coverage for this year.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCARRAY1 if year is out of range (only in debug mode).
Collapse Expand Group

QcArray Methods

Collapse Expand Links
QcArray Class, QcArray Members, QcArray Methods


QcArray::toString Method

QcArray::toString Method
QcArray Class QcArray Members QcArray Methods

Converts a quarters of coverage array to a string.

C++
std::string toString(
    int firstyr,
    int lastyr
) const;
Collapse Expand Parameters
Parameters | Description
int firstyr | First year to write.
int lastyr | Last year to write.
Collapse Expand Returns

A quarters of coverage array as a string.

Collapse Expand Group

QcArray Methods

Collapse Expand Links
QcArray Class, QcArray Members, QcArray Methods


QcArray Friends

QcArray Friends
QcArray Class Public Friends

The friends of the QcArray class are listed here.

Collapse Expand Class

QcArray Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Links
QcArray Class, Public Friends


friend class boost::serialization::access Friend

friend class boost::serialization::access Friend
QcArray Class QcArray Members QcArray Friends

Friend class to allow serialization.

C++
friend class boost::serialization::access;
Collapse Expand Group

QcArray Friends

Collapse Expand Links
QcArray Class, QcArray Members, QcArray Friends


QcPacked Class

QcPacked Class
QcPacked Data Members QcPacked Methods QcPacked Friends QcPacked Members QcPacked.h Classes

Holds 8 annual quarters of coverage amounts in one word (4 bytes). Each value is in 4 bits, and can take values from 0 to 4.

Collapse Expand Class Hierarchy
  QcPacked
C++
class QcPacked;
Collapse Expand File

File: QcPacked.h

Module: PiaData Library

Collapse Expand Remarks

This class is used in QcArray to save space.

Collapse Expand See Also

QcArray

Collapse Expand Group

Classes

Collapse Expand Links
QcPacked Data Members, QcPacked Methods, QcPacked Friends, QcPacked Members, QcPacked.h, Classes


QcPacked Members

QcPacked Members
QcPacked Class Legend Public Data Members Public Friends Public Methods

The following tables list the members exposed by QcPacked.

Collapse Expand Class

QcPacked Class

Collapse Expand Public Data Members
Name | Description
NUM_QCS | Number of elements in this class.
Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Name | Description
QcPacked | Initialize all values to 0.
get | Return a quarter of coverage amount.
set | Set a quarter of coverage amount.
Collapse Expand Links
QcPacked Class, Legend, Public Data Members, Public Friends, Public Methods


QcPacked::QcPacked Constructor

QcPacked::QcPacked Constructor
QcPacked Class QcPacked Members QcPacked Class

Initialize all values to 0.

C++
QcPacked();
Collapse Expand Class

QcPacked Class

Collapse Expand Links
QcPacked Class, QcPacked Members, QcPacked Class


QcPacked Data Members

QcPacked Data Members
QcPacked Class Legend Public Data Members

The data members of the QcPacked class are listed here.

Collapse Expand Class

QcPacked Class

Collapse Expand Public Data Members
Name | Description
NUM_QCS | Number of elements in this class.
Collapse Expand Links
QcPacked Class, Legend, Public Data Members


QcPacked::NUM_QCS Data Member

QcPacked::NUM_QCS Data Member
QcPacked Class QcPacked Members QcPacked Data Members

Number of elements in this class.

C++
const unsigned NUM_QCS = 8;
Collapse Expand Group

QcPacked Data Members

Collapse Expand Links
QcPacked Class, QcPacked Members, QcPacked Data Members


QcPacked Methods

QcPacked Methods
QcPacked Class Legend Public Methods

The methods of the QcPacked class are listed here.

Collapse Expand Class

QcPacked Class

Collapse Expand Public Methods
Name | Description
get | Return a quarter of coverage amount.
set | Set a quarter of coverage amount.
Collapse Expand Links
QcPacked Class, Legend, Public Methods


QcPacked::get Method

QcPacked::get Method
QcPacked Class QcPacked Members QcPacked Methods

Return a quarter of coverage amount.

C++
unsigned get(
    int index
) const;
Collapse Expand Parameters
Parameters | Description
int index | Index of quarter of coverage amount (0 to QcPacked::NUM_QCS - 1).
Collapse Expand Returns

A quarter of coverage amount.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCPACKED1 if index is out of range (only in debug mode).
Collapse Expand Group

QcPacked Methods

Collapse Expand Links
QcPacked Class, QcPacked Members, QcPacked Methods


QcPacked::set Method

QcPacked::set Method
QcPacked Class QcPacked Members QcPacked Methods

Set a quarter of coverage amount.

C++
void set(
    int index,
    unsigned value
);
Collapse Expand Parameters
Parameters | Description
int index | Index of quarter of coverage amount (0 to QcPacked::NUM_QCS - 1).
unsigned value | New value to use.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCPACKED2 if index is out of range (only in debug mode).
Collapse Expand Group

QcPacked Methods

Collapse Expand Links
QcPacked Class, QcPacked Members, QcPacked Methods


QcPacked Friends

QcPacked Friends
QcPacked Class Public Friends

The friends of the QcPacked class are listed here.

Collapse Expand Class

QcPacked Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Links
QcPacked Class, Public Friends


friend class boost::serialization::access Friend

friend class boost::serialization::access Friend
QcPacked Class QcPacked Members QcPacked Friends

Friend class to allow serialization.

C++
friend class boost::serialization::access;
Collapse Expand Group

QcPacked Friends

Collapse Expand Links
QcPacked Class, QcPacked Members, QcPacked Friends


RailRoadData Class

RailRoadData Class
RailRoadData Data Members RailRoadData Methods RailRoadData Operators RailRoadData Friends RailRoadData Members railroad.h Classes

Manages the railroad data for one worker.

Collapse Expand Class Hierarchy
  RailRoadData
C++
class RailRoadData;
Collapse Expand File

File: railroad.h

Module: PiaData Library

Collapse Expand Remarks

Each record contains railroad quarters of coverage for 1937-50 (total) and for each year from 1951 to 1977. It also contains railroad earnings for 1937-50 (total) and for each year from 1951 to the last year.

Collapse Expand Group

Classes

Collapse Expand Links
RailRoadData Data Members, RailRoadData Methods, RailRoadData Operators, RailRoadData Friends, RailRoadData Members, railroad.h, Classes


RailRoadData Members

RailRoadData Members
RailRoadData Class Legend Public Data Members Public Friends Public Methods

The following tables list the members exposed by RailRoadData.

Collapse Expand Class

RailRoadData Class

Collapse Expand Public Data Members
Name | Description
earningsArray | Annual railroad earnings, starting in 1951.
qcArray | Annual railroad quarters of coverage, from 1951 to 1977.
Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Name | Description
RailRoadData | Initializes last year of railroad data.
deleteContents | Zeroes out all railroad data.
get3750String | Returns string of pre-1951 QCs and earnings.
getDecadeEarningsString | Returns string of decade of earnings.
getDecades | Returns number of decades of post-1950 earnings.
getEarn3750 | Returns total earnings 1937 to 1950.
getFirstYear | Returns first year of earnings.
getLastYear | Returns last year of earnings.
getQc3750 | Returns total quarters of coverage 1937 to 1950.
getQcString | Returns string of qcs.
getYearsString | Returns string of first and last years of earnings.
isNonzero | Returns true if there are any railroad earnings.
parse3750 | Parses line of pre-1951 QCs and earnings.
parseEarnings | Parses one line of earnings.
parseQcs | Parses line of qcs.
parseYears | Parses line of first and last years.
railroadYearCheck | Checks the year of railroad earnings.
setEarn3750 | Sets total earnings 1937 to 1950.
setFirstYear | Sets first year of earnings.
setLastYear | Sets last year of earnings.
setQc3750 | Sets total quarters of coverage 1937 to 1950.
~RailRoadData | Destroys railroad data.
Collapse Expand Public Operators
Name | Description
= | Sets this instance equal to another instance.
Collapse Expand Links
RailRoadData Class, Legend, Public Data Members, Public Friends, Public Methods


RailRoadData::RailRoadData Constructor

RailRoadData::RailRoadData Constructor
RailRoadData Class RailRoadData Members RailRoadData Class

Initializes last year of railroad data.

C++
explicit RailRoadData(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | New last year of data.
Collapse Expand Remarks

First year is always 1937, for simplicity.

Collapse Expand Class

RailRoadData Class

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Class


RailRoadData::~RailRoadData Destructor

RailRoadData::~RailRoadData Destructor
RailRoadData Class RailRoadData Members RailRoadData Class

Destroys railroad data.

C++
~RailRoadData();
Collapse Expand Class

RailRoadData Class

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Class


RailRoadData Data Members

RailRoadData Data Members
RailRoadData Class Legend Public Data Members

The data members of the RailRoadData class are listed here.

Collapse Expand Class

RailRoadData Class

Collapse Expand Public Data Members
Name | Description
earningsArray | Annual railroad earnings, starting in 1951.
qcArray | Annual railroad quarters of coverage, from 1951 to 1977.
Collapse Expand Links
RailRoadData Class, Legend, Public Data Members


RailRoadData::earningsArray Data Member

RailRoadData::earningsArray Data Member
RailRoadData Class RailRoadData Members RailRoadData Data Members

Annual railroad earnings, starting in 1951.

C++
DoubleAnnual earningsArray;
Collapse Expand Group

RailRoadData Data Members

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Data Members


RailRoadData::qcArray Data Member

RailRoadData::qcArray Data Member
RailRoadData Class RailRoadData Members RailRoadData Data Members

Annual railroad quarters of coverage, from 1951 to 1977.

C++
QcArray qcArray;
Collapse Expand Group

RailRoadData Data Members

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Data Members


RailRoadData Methods

RailRoadData Methods
RailRoadData Class Legend Public Methods

The methods of the RailRoadData class are listed here.

Collapse Expand Class

RailRoadData Class

Collapse Expand Public Methods
Name | Description
deleteContents | Zeroes out all railroad data.
get3750String | Returns string of pre-1951 QCs and earnings.
getDecadeEarningsString | Returns string of decade of earnings.
getDecades | Returns number of decades of post-1950 earnings.
getEarn3750 | Returns total earnings 1937 to 1950.
getFirstYear | Returns first year of earnings.
getLastYear | Returns last year of earnings.
getQc3750 | Returns total quarters of coverage 1937 to 1950.
getQcString | Returns string of qcs.
getYearsString | Returns string of first and last years of earnings.
isNonzero | Returns true if there are any railroad earnings.
parse3750 | Parses line of pre-1951 QCs and earnings.
parseEarnings | Parses one line of earnings.
parseQcs | Parses line of qcs.
parseYears | Parses line of first and last years.
railroadYearCheck | Checks the year of railroad earnings.
setEarn3750 | Sets total earnings 1937 to 1950.
setFirstYear | Sets first year of earnings.
setLastYear | Sets last year of earnings.
setQc3750 | Sets total quarters of coverage 1937 to 1950.
Collapse Expand Links
RailRoadData Class, Legend, Public Methods


RailRoadData::deleteContents Method

RailRoadData::deleteContents Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Zeroes out all railroad data.

C++
void deleteContents();
Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::get3750String Method

RailRoadData::get3750String Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Returns string of pre-1951 QCs and earnings.

C++
std::string get3750String(
    int width,
    int decimals
) const;
Collapse Expand Parameters
Parameters | Description
int width | Width of each earnings field.
int decimals | Number of decimals in each earnings field.
Collapse Expand Returns

String of pre-1951 QCs and earnings.

Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::getDecadeEarningsString Method

RailRoadData::getDecadeEarningsString Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Returns string of decade of earnings.

C++
std::string getDecadeEarningsString(
    int decade,
    int width,
    int decimals
) const;
Collapse Expand Parameters
Parameters | Description
int decade | Decade to use. 0: first 10 years. 1: second 10 years. etc. up to eighth 10 years.
int width | Width of each earnings field.
int decimals | Number of decimals in each earnings field.
Collapse Expand Returns

String of decade of earnings.

Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::getDecades Method

RailRoadData::getDecades Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Returns number of decades of post-1950 earnings.

C++
int getDecades() const;
Collapse Expand Returns

Number of decades of post-1950 earnings.

Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::getEarn3750 Method

RailRoadData::getEarn3750 Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Returns total earnings 1937 to 1950.

C++
double getEarn3750() const;
Collapse Expand Returns

Total earnings 1937 to 1950.

Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::getFirstYear Method

RailRoadData::getFirstYear Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Returns first year of earnings.

C++
int getFirstYear() const;
Collapse Expand Returns

First year of earnings.

Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::getLastYear Method

RailRoadData::getLastYear Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Returns last year of earnings.

C++
int getLastYear() const;
Collapse Expand Returns

Last year of earnings.

Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::getQc3750 Method

RailRoadData::getQc3750 Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Returns total quarters of coverage 1937 to 1950.

C++
int getQc3750() const;
Collapse Expand Returns

Total quarters of coverage 1937 to 1950.

Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::getQcString Method

RailRoadData::getQcString Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Returns string of qcs.

C++
std::string getQcString() const;
Collapse Expand Returns

String of qcs.

Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::getYearsString Method

RailRoadData::getYearsString Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Returns string of first and last years of earnings.

C++
std::string getYearsString() const;
Collapse Expand Returns

String of first and last years of earnings.

Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::isNonzero Method

RailRoadData::isNonzero Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Returns true if there are any railroad earnings.

C++
bool isNonzero() const;
Collapse Expand Returns

True if there are any railroad earnings.

Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::parse3750 Method

RailRoadData::parse3750 Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Parses line of pre-1951 QCs and earnings.

C++
void parse3750(
    const std::string& line,
    int width
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
int width | Width of each earnings field.
Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::parseEarnings Method

RailRoadData::parseEarnings Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Parses one line of earnings.

C++
void parseEarnings(
    int decade,
    const std::string& line,
    int width
);
Collapse Expand Parameters
Parameters | Description
int decade | Decade to use.
const std::string& line | Line to parse.
int width | Width of each earnings field.
Collapse Expand Remarks

The decade indicator can be one of the following:

0 | first 10 years.
1 | second 10 years.
etc. | up to eighth 10 years.
Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::parseQcs Method

RailRoadData::parseQcs Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Parses line of qcs.

C++
void parseQcs(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::parseYears Method

RailRoadData::parseYears Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Parses line of first and last years.

C++
void parseYears(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::railroadYearCheck Method

RailRoadData::railroadYearCheck Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Checks the year of railroad earnings.

C++
static void railroadYearCheck(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year of railroad earnings to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | If year of railroad earnings is out of range.
Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::setEarn3750 Method

RailRoadData::setEarn3750 Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Sets total earnings 1937 to 1950.

C++
void setEarn3750(
    double newEarn3750
);
Collapse Expand Parameters
Parameters | Description
double newEarn3750 | New total earnings.
Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::setFirstYear Method

RailRoadData::setFirstYear Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Sets first year of earnings.

C++
void setFirstYear(
    int newFirstYear
);
Collapse Expand Parameters
Parameters | Description
int newFirstYear | New first year of earnings.
Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::setLastYear Method

RailRoadData::setLastYear Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Sets last year of earnings.

C++
void setLastYear(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | New last year of earnings.
Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData::setQc3750 Method

RailRoadData::setQc3750 Method
RailRoadData Class RailRoadData Members RailRoadData Methods

Sets total quarters of coverage 1937 to 1950.

C++
void setQc3750(
    int newQc3750
);
Collapse Expand Parameters
Parameters | Description
int newQc3750 | New total quarters of coverage.
Collapse Expand Group

RailRoadData Methods

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Methods


RailRoadData Operators

RailRoadData Operators
RailRoadData Class Legend

The operators of the RailRoadData class are listed here.

Collapse Expand Class

RailRoadData Class

Collapse Expand Public Operators
Name | Description
= | Sets this instance equal to another instance.
Collapse Expand Links
RailRoadData Class, Legend


RailRoadData::= Operator

RailRoadData::= Operator
RailRoadData Class RailRoadData Members RailRoadData Operators

Sets this instance equal to another instance.

C++
RailRoadData& operator =(
    const RailRoadData& newData
);
Collapse Expand Parameters
Parameters | Description
const RailRoadData& newData | The instance to copy from.
Collapse Expand Returns

A reference to this instance.

Collapse Expand Group

RailRoadData Operators

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Operators


RailRoadData Friends

RailRoadData Friends
RailRoadData Class Public Friends

The friends of the RailRoadData class are listed here.

Collapse Expand Class

RailRoadData Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Links
RailRoadData Class, Public Friends


friend class boost::serialization::access Friend

friend class boost::serialization::access Friend
RailRoadData Class RailRoadData Members RailRoadData Friends

Friend class to allow serialization.

C++
friend class boost::serialization::access;
Collapse Expand Group

RailRoadData Friends

Collapse Expand Links
RailRoadData Class, RailRoadData Members, RailRoadData Friends


ReindWid Class

ReindWid Class
ReindWid Data Members ReindWid Methods ReindWid Members ReindWid.h Classes

Manages the functions required for calculation of a reindexed widow(er) Social Security benefit.

Collapse Expand Class Hierarchy
  ReindWidReindWidReindWid
C++
class ReindWid : public WageIndGeneral;
Collapse Expand File

File: ReindWid.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaCalPL.

Collapse Expand Group

Classes

Collapse Expand Links
ReindWid Data Members, ReindWid Methods, ReindWid Members, ReindWid.h, Classes


ReindWid Members

ReindWid Members
Enumerations ReindWid Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by ReindWid.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

ReindWid Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
widowPiaData | Widow calculation data.
windfallInd | Windfall indicator.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
yearsTotal | Number of years of coverage for windfall elimination.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
secondary | Secondary benefit data.
widowData | Widow basic data.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
ReindWid | Initializes this instance.
aimepiaCal | Calculates an AIME PIA under the 1977 law.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
bendPointCal | Projects bend points.
calculate | Computes reindexed widow PIA.
deconvertAme | Deconverts AIME from raw PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getEligYear | Returns eligibility year for reindexed widow(er) calculation.
getIndCap | Returns disability MFB cap indicator.
getIndexYearAvgWage | Returns average wage in indexing year.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
realWageGainAdj | Applies real-wage-gain adjustment.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setEligYear | Sets year of eligibility in reindexed widow guarantee method.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionAime | Calculates portion of aime in each section of pia formula.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setWindfall | Sets windfall indicator in wage-indexed method.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
~ReindWid | Destructor.
Collapse Expand Links
Enumerations, ReindWid Class, Legend, Protected Data Members, Public Data Members, Public Methods


ReindWid::ReindWid Constructor

ReindWid::ReindWid Constructor
ReindWid Class ReindWid Members ReindWid Class

Initializes this instance.

C++
ReindWid(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear,
    const PiaData& newWidowPiaData,
    const WorkerDataGeneral& newWidowData,
    Secondary& newSecondary
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker basic data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
const PiaData& newWidowPiaData | Widow calculation data.
const WorkerDataGeneral& newWidowData | Widow basic data.
Secondary& newSecondary | Secondary benefit data.
Collapse Expand Class

ReindWid Class

Collapse Expand Links
ReindWid Class, ReindWid Members, ReindWid Class


ReindWid::~ReindWid Destructor

ReindWid::~ReindWid Destructor
ReindWid Class ReindWid Members ReindWid Class

Destructor.

C++
virtual ~ReindWid();
Collapse Expand Class

ReindWid Class

Collapse Expand Links
ReindWid Class, ReindWid Members, ReindWid Class


ReindWid Data Members

ReindWid Data Members
ReindWid Class Legend Protected Data Members Public Data Members

The data members of the ReindWid class are listed here.

Collapse Expand Class

ReindWid Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
widowPiaData | Widow calculation data.
Collapse Expand Public Data Members
Name | Description
secondary | Secondary benefit data.
widowData | Widow basic data.
Collapse Expand Links
ReindWid Class, Legend, Protected Data Members, Public Data Members


ReindWid::secondary Data Member

ReindWid::secondary Data Member
ReindWid Class ReindWid Members ReindWid Data Members

Secondary benefit data.

C++
Secondary& secondary;
Collapse Expand Group

ReindWid Data Members

Collapse Expand Links
ReindWid Class, ReindWid Members, ReindWid Data Members


ReindWid::widowData Data Member

ReindWid::widowData Data Member
ReindWid Class ReindWid Members ReindWid Data Members

Widow basic data.

C++
const WorkerDataGeneral& widowData;
Collapse Expand Remarks

This is not used by this class, but it is handy to have when doing output.

Collapse Expand Group

ReindWid Data Members

Collapse Expand Links
ReindWid Class, ReindWid Members, ReindWid Data Members


ReindWid::widowPiaData Data Member

ReindWid::widowPiaData Data Member
ReindWid Class ReindWid Members ReindWid Data Members

Widow calculation data.

C++
const PiaData& widowPiaData;
Collapse Expand Group

ReindWid Data Members

Collapse Expand Links
ReindWid Class, ReindWid Members, ReindWid Data Members


ReindWid Methods

ReindWid Methods
ReindWid Class Legend Public Methods

The methods of the ReindWid class are listed here.

Collapse Expand Class

ReindWid Class

Collapse Expand Public Methods
Name | Description
calculate | Computes reindexed widow PIA.
getEligYear | Returns eligibility year for reindexed widow(er) calculation.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
setEligYear | Sets year of eligibility in reindexed widow guarantee method.
Collapse Expand Links
ReindWid Class, Legend, Public Methods


ReindWid::calculate Method

ReindWid::calculate Method
ReindWid Class ReindWid Members ReindWid Methods

Computes reindexed widow PIA.

C++
void calculate();
Collapse Expand Group

ReindWid Methods

Collapse Expand Links
ReindWid Class, ReindWid Members, ReindWid Methods


ReindWid::getEligYear Method

ReindWid::getEligYear Method
ReindWid Class ReindWid Members ReindWid Methods

Returns eligibility year for reindexed widow(er) calculation.

C++
int getEligYear() const;
Collapse Expand Returns

Eligibility year for reindexed widow(er) calculation.

Collapse Expand Group

ReindWid Methods

Collapse Expand Links
ReindWid Class, ReindWid Members, ReindWid Methods


ReindWid::initialize Method

ReindWid::initialize Method
ReindWid Class ReindWid Members ReindWid Methods

Initializes computed values to zero.

C++
void initialize();
Collapse Expand Group

ReindWid Methods

Collapse Expand Links
ReindWid Class, ReindWid Members, ReindWid Methods


isApplicable Method

isApplicable Method
ReindWid Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of this function. The version with no arguments uses stored data, passing it to the static version with four arguments.

Collapse Expand Overload List
Name | Description
ReindWid::isApplicable () | Determines applicability of method, using stored valules.
ReindWid::isApplicable (const WorkerDataGeneral&, const PiaData&, int, const Secondary&) | Determines applicability of method, using passed values.
Collapse Expand Group

ReindWid Methods

Collapse Expand Links
ReindWid Methods


ReindWid::isApplicable Method ()

ReindWid::isApplicable Method ()
ReindWid Class ReindWid Members isApplicable Method

Determines applicability of method, using stored valules.

C++
bool isApplicable();
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

This version calls the static version with 4 arguments.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
ReindWid Class, ReindWid Members, isApplicable Method


ReindWid::isApplicable Method (const WorkerDataGeneral&, const PiaData&, int, const Secondary&)

ReindWid::isApplicable Method (const WorkerDataGeneral&, const PiaData&, int, const Secondary&)
ReindWid Class ReindWid Members isApplicable Method

Determines applicability of method, using passed values.

C++
static bool isApplicable(
    const WorkerDataGeneral& workerData,
    const PiaData& piaData,
    int widowEligYear,
    const Secondary& secondary
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker basic data.
const PiaData& piaData | Pia calculation data.
int widowEligYear | Widow(er)'s year of eligibility.
const Secondary& secondary | Widow(er)'s benefit information.
Collapse Expand Returns

True if method is applicable.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
ReindWid Class, ReindWid Members, isApplicable Method


ReindWid::setEligYear Method

ReindWid::setEligYear Method
ReindWid Class ReindWid Members ReindWid Methods

Sets year of eligibility in reindexed widow guarantee method.

C++
void setEligYear();
Collapse Expand Group

ReindWid Methods

Collapse Expand Links
ReindWid Class, ReindWid Members, ReindWid Methods


ReindWidLC Class

ReindWidLC Class
ReindWidLC Methods ReindWidLC Members ReindWidLC.h Classes

Manages the functions required for calculation of a reindexed widow(er) Social Security benefit with law changes.

Collapse Expand Class Hierarchy
  ReindWidLCReindWidLCReindWidLCReindWidLC
C++
class ReindWidLC : public ReindWid;
Collapse Expand File

File: ReindWidLC.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaCalLC.

Collapse Expand Group

Classes

Collapse Expand Links
ReindWidLC Methods, ReindWidLC Members, ReindWidLC.h, Classes


ReindWidLC Members

ReindWidLC Members
Enumerations ReindWidLC Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by ReindWidLC.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

ReindWidLC Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
widowPiaData | Widow calculation data.
windfallInd | Windfall indicator.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
yearsTotal | Number of years of coverage for windfall elimination.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
secondary | Secondary benefit data.
widowData | Widow basic data.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
ReindWidLC | Initializes this instance.
aimepiaCal | Calculates an AIME PIA under the 1977 law.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
bendPointCal | Projects bend points.
calculate | Calculates pia and mfb for this method.
calculate | Computes reindexed widow PIA.
deconvertAme | Deconverts AIME from raw PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getEligYear | Returns eligibility year for reindexed widow(er) calculation.
getIndCap | Returns disability MFB cap indicator.
getIndexYearAvgWage | Returns average wage in indexing year.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
realWageGainAdj | Applies real-wage-gain adjustment.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setEligYear | Sets year of eligibility in reindexed widow guarantee method.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionAime | Calculates portion of aime in each section of pia formula.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setWindfall | Sets windfall indicator in wage-indexed method.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
~ReindWidLC | Destructor.
Collapse Expand Links
Enumerations, ReindWidLC Class, Legend, Protected Data Members, Public Data Members, Public Methods


ReindWidLC::ReindWidLC Constructor

ReindWidLC::ReindWidLC Constructor
ReindWidLC Class ReindWidLC Members ReindWidLC Class

Initializes this instance.

C++
ReindWidLC(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear,
    const PiaData& newWidowPiaData,
    const WorkerDataGeneral& newWidowData,
    Secondary& newSecondary,
    const LawChangeArray& newLawChange
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker basic data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
const PiaData& newWidowPiaData | Widow calculation data.
const WorkerDataGeneral& newWidowData | Widow basic data.
Secondary& newSecondary | Secondary benefit data.
const LawChangeArray& newLawChange | Law change parameters.
Collapse Expand Class

ReindWidLC Class

Collapse Expand Links
ReindWidLC Class, ReindWidLC Members, ReindWidLC Class


ReindWidLC::~ReindWidLC Destructor

ReindWidLC::~ReindWidLC Destructor
ReindWidLC Class ReindWidLC Members ReindWidLC Class

Destructor.

C++
virtual ~ReindWidLC();
Collapse Expand Class

ReindWidLC Class

Collapse Expand Links
ReindWidLC Class, ReindWidLC Members, ReindWidLC Class


ReindWidLC Methods

ReindWidLC Methods
ReindWidLC Class Legend Public Methods

The methods of the ReindWidLC class are listed here.

Collapse Expand Class

ReindWidLC Class

Collapse Expand Public Methods
Name | Description
isApplicable | Determines applicability of method.
Collapse Expand Links
ReindWidLC Class, Legend, Public Methods


isApplicable Method

isApplicable Method
ReindWidLC Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of this function. The version with no arguments uses stored data, passing it to the static version with five arguments.

Collapse Expand Overload List
Name | Description
ReindWidLC::isApplicable () | Determines applicability of method, using stored values.
ReindWidLC::isApplicable (const WorkerDataGeneral&, const PiaData&, int, const Secondary&, const LawChangeArray&) | Determines applicability of method, using passed values.
Collapse Expand Group

ReindWidLC Methods

Collapse Expand Links
ReindWidLC Methods


ReindWidLC::isApplicable Method ()

ReindWidLC::isApplicable Method ()
ReindWidLC Class ReindWidLC Members isApplicable Method

Determines applicability of method, using stored values.

C++
bool isApplicable();
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

This version calls the static version with 5 arguments.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
ReindWidLC Class, ReindWidLC Members, isApplicable Method


ReindWidLC::isApplicable Method (const WorkerDataGeneral&, const PiaData&, int, const Secondary&, const LawChangeArray&)

ReindWidLC::isApplicable Method (const WorkerDataGeneral&, const PiaData&, int, const Secondary&, const LawChangeArray&)
ReindWidLC Class ReindWidLC Members isApplicable Method

Determines applicability of method, using passed values.

C++
static bool isApplicable(
    const WorkerDataGeneral& workerData,
    const PiaData& piaData,
    int widowEligYear,
    const Secondary& secondary,
    const LawChangeArray& lawChange
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker basic data.
const PiaData& piaData | Pia calculation data.
int widowEligYear | Widow(er)'s year of eligibility.
const Secondary& secondary | Widow(er)'s benefit information.
const LawChangeArray& lawChange | Law change parameters.
Collapse Expand Returns

True if method is applicable.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
ReindWidLC Class, ReindWidLC Members, isApplicable Method


RetireTest Class

RetireTest Class
RetireTest Constructor RetireTest Data Members RetireTest Methods RetireTest Members RetireTest.h Classes

Contains all of the retirement test exempt amounts and functions to use them.

Collapse Expand Class Hierarchy
  RetireTest
C++
class RetireTest;
Collapse Expand File

File: RetireTest.h

Module: PiaData Library

Collapse Expand Remarks

Contains all of the retirement test exempt amounts and functions to use them.

Collapse Expand Group

Classes

Collapse Expand Links
RetireTest Constructor, RetireTest Data Members, RetireTest Methods, RetireTest Members, RetireTest.h, Classes


RetireTest Members

RetireTest Members
RetireTest Class Legend Public Data Members Public Methods

The following tables list the members exposed by RetireTest.

Collapse Expand Class

RetireTest Class

Collapse Expand Public Data Members
Name | Description
rtea62 | Annual amounts under full retirement age.
rtea62m | Monthly amounts under full retirement age.
rtea65 | Annual amounts over full retirement age.
rtea65m | Monthly amounts over full retirement age.
rteaHigh | Annual amounts at second tier (effective 1961-1972).
Collapse Expand Public Methods
Name | Description
RetireTest | Initializes a RetireTest, with or without a first year of data.
earningsTestCal | Returns how many months of person's benefit will be withheld according to the retirement test.
project | Projects all retirement test exempt amounts.
Collapse Expand Links
RetireTest Class, Legend, Public Data Members, Public Methods


RetireTest Constructor

RetireTest Constructor
RetireTest Class

Initializes a RetireTest, with or without a first year of data.

Collapse Expand Description

There are two versions of the RetireTest constructor. If the first year of data is not provided, it is set to 1937.

Collapse Expand Overload List
Name | Description
RetireTest::RetireTest (const PiaParams&, int) | Constructor with last year specified.
RetireTest::RetireTest (const PiaParams&, int, int) | Constructor with first and last years specified.
Collapse Expand Class

RetireTest Class

Collapse Expand Links
RetireTest Class


RetireTest::RetireTest Constructor (const PiaParams&, int)

RetireTest::RetireTest Constructor (const PiaParams&, int)
RetireTest Class RetireTest Members RetireTest Constructor

Constructor with last year specified.

C++
RetireTest(
    const PiaParams& newPiaParams,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
const PiaParams& newPiaParams | Pia calculation parameters.
int newLastYear | Last year allowed.
Collapse Expand Remarks

Calls the constructors for RetireTest::rtea62m, RetireTest::rtea62, RetireTest::rtea65m, and RetireTest::rtea65 with the specified last year and an implied first year of 1937, and the default constructor for RetireTest::rteaHigh.

Collapse Expand Group

RetireTest Constructor

Collapse Expand Links
RetireTest Class, RetireTest Members, RetireTest Constructor


RetireTest::RetireTest Constructor (const PiaParams&, int, int)

RetireTest::RetireTest Constructor (const PiaParams&, int, int)
RetireTest Class RetireTest Members RetireTest Constructor

Constructor with first and last years specified.

C++
RetireTest(
    const PiaParams& newPiaParams,
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
const PiaParams& newPiaParams | Pia calculation parameters.
int newBaseYear | First year allowed.
int newLastYear | Last year allowed.
Collapse Expand Remarks

Calls the constructors for RetireTest::rtea62m, RetireTest::rtea62, RetireTest::rtea65m, and RetireTest::rtea65 with the specified first and last years, and the default constructor for RetireTest::rteaHigh.

Collapse Expand Group

RetireTest Constructor

Collapse Expand Links
RetireTest Class, RetireTest Members, RetireTest Constructor


RetireTest Data Members

RetireTest Data Members
RetireTest Class Legend Public Data Members

The data members of the RetireTest class are listed here.

Collapse Expand Class

RetireTest Class

Collapse Expand Public Data Members
Name | Description
rtea62 | Annual amounts under full retirement age.
rtea62m | Monthly amounts under full retirement age.
rtea65 | Annual amounts over full retirement age.
rtea65m | Monthly amounts over full retirement age.
rteaHigh | Annual amounts at second tier (effective 1961-1972).
Collapse Expand Links
RetireTest Class, Legend, Public Data Members


RetireTest::rtea62 Data Member

RetireTest::rtea62 Data Member
RetireTest Class RetireTest Members RetireTest Data Members

Annual amounts under full retirement age.

C++
Rtea62 rtea62;
Collapse Expand Group

RetireTest Data Members

Collapse Expand Links
RetireTest Class, RetireTest Members, RetireTest Data Members


RetireTest::rtea62m Data Member

RetireTest::rtea62m Data Member
RetireTest Class RetireTest Members RetireTest Data Members

Monthly amounts under full retirement age.

C++
Rtea62m rtea62m;
Collapse Expand Group

RetireTest Data Members

Collapse Expand Links
RetireTest Class, RetireTest Members, RetireTest Data Members


RetireTest::rtea65 Data Member

RetireTest::rtea65 Data Member
RetireTest Class RetireTest Members RetireTest Data Members

Annual amounts over full retirement age.

C++
Rtea65 rtea65;
Collapse Expand Group

RetireTest Data Members

Collapse Expand Links
RetireTest Class, RetireTest Members, RetireTest Data Members


RetireTest::rtea65m Data Member

RetireTest::rtea65m Data Member
RetireTest Class RetireTest Members RetireTest Data Members

Monthly amounts over full retirement age.

C++
Rtea65m rtea65m;
Collapse Expand Group

RetireTest Data Members

Collapse Expand Links
RetireTest Class, RetireTest Members, RetireTest Data Members


RetireTest::rteaHigh Data Member

RetireTest::rteaHigh Data Member
RetireTest Class RetireTest Members RetireTest Data Members

Annual amounts at second tier (effective 1961-1972).

C++
RteaHigh rteaHigh;
Collapse Expand Group

RetireTest Data Members

Collapse Expand Links
RetireTest Class, RetireTest Members, RetireTest Data Members


RetireTest Methods

RetireTest Methods
RetireTest Class Legend Public Methods

The methods of the RetireTest class are listed here.

Collapse Expand Class

RetireTest Class

Collapse Expand Public Methods
Name | Description
earningsTestCal | Returns how many months of person's benefit will be withheld according to the retirement test.
project | Projects all retirement test exempt amounts.
Collapse Expand Links
RetireTest Class, Legend, Public Methods


RetireTest::earningsTestCal Method

RetireTest::earningsTestCal Method
RetireTest Class RetireTest Members RetireTest Methods

Returns how many months of person's benefit will be withheld according to the retirement test.

C++
double earningsTestCal(
    const Age& age,
    double earnings,
    int year,
    double benefit
) const;
Collapse Expand Parameters
Parameters | Description
const Age& age | The age at end of year.
double earnings | The earnings in year.
int year | Year being considered.
double benefit | Monthly benefit before reduction.
Collapse Expand Returns

How many months of person's benefit will be withheld according to the retirement test.

Collapse Expand Remarks

Some benies (i.e. disabled workers and disabled widow(er)s) are not affected by the retirement test and should not have this function called for them.

Collapse Expand Group

RetireTest Methods

Collapse Expand Links
RetireTest Class, RetireTest Members, RetireTest Methods


RetireTest::project Method

RetireTest::project Method
RetireTest Class RetireTest Members RetireTest Methods

Projects all retirement test exempt amounts.

C++
void project(
    int firstYear
);
Collapse Expand Parameters
Parameters | Description
int firstYear | First year of projection.
Collapse Expand Group

RetireTest Methods

Collapse Expand Links
RetireTest Class, RetireTest Members, RetireTest Methods


Rtea62 Class

Rtea62 Class
Rtea62 Constructor Rtea62 Members rtgenrl.h Classes

Manages the annual retirement test exempt amount projections under full retirement age.

Collapse Expand Class Hierarchy
  Rtea62Rtea62Rtea62
C++
class Rtea62 : public RtGeneral;
Collapse Expand File

File: rtgenrl.h

Module: PiaData Library

Collapse Expand Remarks

The monthly retirement test exempt amount projections under full retirement age are managed by Rtea62m.

Collapse Expand See Also

Rtea62m

Collapse Expand Group

Classes

Collapse Expand Links
Rtea62 Constructor, Rtea62 Members, rtgenrl.h, Classes


Rtea62 Members

Rtea62 Members
Rtea62 Class Legend Public Data Members Public Friends Public Methods

The following tables list the members exposed by Rtea62.

Collapse Expand Class

Rtea62 Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
RtGeneral | Initializes an RtGeneral, with or without a specified first year.
Rtea62 | Initializes an Rtea62, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly retirement test exempt amounts to annual amounts.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
getMaxAgePL | Returns maximum age for which earnings test applies.
project1 | Calculates a monthly retirement test exempt amount using a base amount and a ratio of average wages.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
Rtea62 Class, Legend, Public Data Members, Public Friends, Public Methods


Rtea62 Constructor

Rtea62 Constructor
Rtea62 Class

Initializes an Rtea62, with or without a specified first year.

Collapse Expand Description

There are two versions of the Rtea62 constructor. The last year of data is specified in both. But if the first year is not specified, it is assumed to be 1937.

Collapse Expand Overload List
Name | Description
Rtea62::Rtea62 (int) | Initializes first year of data to 1937.
Rtea62::Rtea62 (int, int) | Initializes first year of data to specified value.
Collapse Expand Class

Rtea62 Class

Collapse Expand Links
Rtea62 Class


Rtea62::Rtea62 Constructor (int)

Rtea62::Rtea62 Constructor (int)
Rtea62 Class Rtea62 Members Rtea62 Constructor

Initializes first year of data to 1937.

C++
Rtea62(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Last year of projection.
Collapse Expand Group

Rtea62 Constructor

Collapse Expand Links
Rtea62 Class, Rtea62 Members, Rtea62 Constructor


Rtea62::Rtea62 Constructor (int, int)

Rtea62::Rtea62 Constructor (int, int)
Rtea62 Class Rtea62 Members Rtea62 Constructor

Initializes first year of data to specified value.

C++
Rtea62(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | First year of data.
int newLastYear | Last year of projection.
Collapse Expand Group

Rtea62 Constructor

Collapse Expand Links
Rtea62 Class, Rtea62 Members, Rtea62 Constructor


Rtea62m Class

Rtea62m Class
Rtea62m Constructor Rtea62m Methods Rtea62m Members rtgenrl.h Classes

Manages the monthly retirement test exempt amount projections under full retirement age.

Collapse Expand Class Hierarchy
  Rtea62mRtea62mRtea62m
C++
class Rtea62m : public RtGeneral;
Collapse Expand File

File: rtgenrl.h

Module: PiaData Library

Collapse Expand Remarks

The annual retirement test exempt amount projections under full retirement age are managed by Rtea62.

Collapse Expand See Also

Rtea62

Collapse Expand Group

Classes

Collapse Expand Links
Rtea62m Constructor, Rtea62m Methods, Rtea62m Members, rtgenrl.h, Classes


Rtea62m Members

Rtea62m Members
Rtea62m Class Legend Public Data Members Public Friends Public Methods

The following tables list the members exposed by Rtea62m.

Collapse Expand Class

Rtea62m Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
RtGeneral | Initializes an RtGeneral, with or without a specified first year.
Rtea62m | Initializes an Rtea62m, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly retirement test exempt amounts to annual amounts.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getFraction | Returns x in 1-for-x rule for earnings offset.
getHistAmount | Returns historical monthly exempt amount for specified year.
getLastYear | Returns last year of data.
getMaxAgePL | Returns maximum age for which earnings test applies.
initialize | Initializes historical data.
project | Projects retirement test exempt amounts for ages under full retirement age.
project1 | Calculates a monthly retirement test exempt amount using a base amount and a ratio of average wages.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
Rtea62m Class, Legend, Public Data Members, Public Friends, Public Methods


Rtea62m Constructor

Rtea62m Constructor
Rtea62m Class

Initializes an Rtea62m, with or without a specified first year.

Collapse Expand Description

There are two versions of the Rtea62m constructor. The last year of data is specified in both. But if the first year is not specified, it is assumed to be 1937.

Collapse Expand Overload List
Name | Description
Rtea62m::Rtea62m (int) | Initializes historical values for monthly test under full retirement age, with first year as 1937.
Rtea62m::Rtea62m (int, int) | Initializes historical values for monthly test under full retirement age, with first year as specified.
Collapse Expand Class

Rtea62m Class

Collapse Expand Links
Rtea62m Class


Rtea62m::Rtea62m Constructor (int)

Rtea62m::Rtea62m Constructor (int)
Rtea62m Class Rtea62m Members Rtea62m Constructor

Initializes historical values for monthly test under full retirement age, with first year as 1937.

C++
Rtea62m(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Last year of projection.
Collapse Expand Remarks

Calls initialize.

Collapse Expand Group

Rtea62m Constructor

Collapse Expand Links
Rtea62m Class, Rtea62m Members, Rtea62m Constructor


Rtea62m::Rtea62m Constructor (int, int)

Rtea62m::Rtea62m Constructor (int, int)
Rtea62m Class Rtea62m Members Rtea62m Constructor

Initializes historical values for monthly test under full retirement age, with first year as specified.

C++
Rtea62m(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | First year of data.
int newLastYear | Last year of projection.
Collapse Expand Remarks

Calls initialize.

Collapse Expand Group

Rtea62m Constructor

Collapse Expand Links
Rtea62m Class, Rtea62m Members, Rtea62m Constructor


Rtea62m Methods

Rtea62m Methods
Rtea62m Class Legend Public Methods

The methods of the Rtea62m class are listed here.

Collapse Expand Class

Rtea62m Class

Collapse Expand Public Methods
Name | Description
getFraction | Returns x in 1-for-x rule for earnings offset.
getHistAmount | Returns historical monthly exempt amount for specified year.
initialize | Initializes historical data.
project | Projects retirement test exempt amounts for ages under full retirement age.
Collapse Expand Links
Rtea62m Class, Legend, Public Methods


Rtea62m::getFraction Method

Rtea62m::getFraction Method
Rtea62m Class Rtea62m Members Rtea62m Methods

Returns x in 1-for-x rule for earnings offset.

C++
static int getFraction(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which fraction is desired.
Collapse Expand Returns

x in 1-for-x rule for earnings offset.

Collapse Expand Group

Rtea62m Methods

Collapse Expand Links
Rtea62m Class, Rtea62m Members, Rtea62m Methods


Rtea62m::getHistAmount Method

Rtea62m::getHistAmount Method
Rtea62m Class Rtea62m Members Rtea62m Methods

Returns historical monthly exempt amount for specified year.

C++
static double getHistAmount(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which exempt amount is desired.
Collapse Expand Returns

Exempt amount for specified year.

Collapse Expand Group

Rtea62m Methods

Collapse Expand Links
Rtea62m Class, Rtea62m Members, Rtea62m Methods


Rtea62m::initialize Method

Rtea62m::initialize Method
Rtea62m Class Rtea62m Members Rtea62m Methods

Initializes historical data.

C++
void initialize();
Collapse Expand Group

Rtea62m Methods

Collapse Expand Links
Rtea62m Class, Rtea62m Members, Rtea62m Methods


Rtea62m::project Method

Rtea62m::project Method
Rtea62m Class Rtea62m Members Rtea62m Methods

Projects retirement test exempt amounts for ages under full retirement age.

C++
void project(
    int firstYear,
    const DoubleAnnual& averageWages,
    const DoubleAnnual& cpi
);
Collapse Expand Parameters
Parameters | Description
int firstYear | First year of projection.
const DoubleAnnual& averageWages | Average wage series.
const DoubleAnnual& cpi | Benefit increase series.
Collapse Expand Group

Rtea62m Methods

Collapse Expand Links
Rtea62m Class, Rtea62m Members, Rtea62m Methods


Rtea65 Class

Rtea65 Class
Rtea65 Constructor Rtea65 Members rtgenrl.h Classes

Manages the annual retirement test exempt amount projections over full retirement age.

Collapse Expand Class Hierarchy
  Rtea65Rtea65Rtea65
C++
class Rtea65 : public RtGeneral;
Collapse Expand File

File: rtgenrl.h

Module: PiaData Library

Collapse Expand Remarks

The monthly retirement test exempt amount projections over full retirement age are managed by Rtea65m.

Collapse Expand See Also

Rtea65m

Collapse Expand Group

Classes

Collapse Expand Links
Rtea65 Constructor, Rtea65 Members, rtgenrl.h, Classes


Rtea65 Members

Rtea65 Members
Rtea65 Class Legend Public Data Members Public Friends Public Methods

The following tables list the members exposed by Rtea65.

Collapse Expand Class

Rtea65 Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
RtGeneral | Initializes an RtGeneral, with or without a specified first year.
Rtea65 | Initializes an Rtea65, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly retirement test exempt amounts to annual amounts.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
getMaxAgePL | Returns maximum age for which earnings test applies.
project1 | Calculates a monthly retirement test exempt amount using a base amount and a ratio of average wages.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
Rtea65 Class, Legend, Public Data Members, Public Friends, Public Methods


Rtea65 Constructor

Rtea65 Constructor
Rtea65 Class

Initializes an Rtea65, with or without a specified first year.

Collapse Expand Description

There are two versions of the Rtea65 constructor. The last year of data is specified in both. But if the first year is not specified, it is assumed to be 1937.

Collapse Expand Overload List
Name | Description
Rtea65::Rtea65 (int) | Initializes first year of data to 1937.
Rtea65::Rtea65 (int, int) | Initializes first year of data to specified value.
Collapse Expand Class

Rtea65 Class

Collapse Expand Links
Rtea65 Class


Rtea65::Rtea65 Constructor (int)

Rtea65::Rtea65 Constructor (int)
Rtea65 Class Rtea65 Members Rtea65 Constructor

Initializes first year of data to 1937.

C++
Rtea65(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Last year of projection.
Collapse Expand Group

Rtea65 Constructor

Collapse Expand Links
Rtea65 Class, Rtea65 Members, Rtea65 Constructor


Rtea65::Rtea65 Constructor (int, int)

Rtea65::Rtea65 Constructor (int, int)
Rtea65 Class Rtea65 Members Rtea65 Constructor

Initializes first year of data to specified value.

C++
Rtea65(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | First year of data.
int newLastYear | Last year of projection.
Collapse Expand Group

Rtea65 Constructor

Collapse Expand Links
Rtea65 Class, Rtea65 Members, Rtea65 Constructor


Rtea65m Class

Rtea65m Class
Rtea65m Constructor Rtea65m Methods Rtea65m Members rtgenrl.h Classes

Manages the monthly retirement test exempt amount projections over full retirement age.

Collapse Expand Class Hierarchy
  Rtea65mRtea65mRtea65m
C++
class Rtea65m : public RtGeneral;
Collapse Expand File

File: rtgenrl.h

Module: PiaData Library

Collapse Expand Remarks

The annual retirement test exempt amount projections over full retirement age are managed by Rtea65.

Collapse Expand See Also

Rtea65

Collapse Expand Group

Classes

Collapse Expand Links
Rtea65m Constructor, Rtea65m Methods, Rtea65m Members, rtgenrl.h, Classes


Rtea65m Members

Rtea65m Members
Rtea65m Class Legend Public Data Members Public Friends Public Methods

The following tables list the members exposed by Rtea65m.

Collapse Expand Class

Rtea65m Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
RtGeneral | Initializes an RtGeneral, with or without a specified first year.
Rtea65m | Initializes an Rtea65m, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly retirement test exempt amounts to annual amounts.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getFraction | Returns x in 1-for-x rule for earnings offset.
getHistAmount | Returns historical monthly exempt amount for specified year.
getLastYear | Returns last year of data.
getMaxAgePL | Returns maximum age for which earnings test applies.
initialize | Initializes historical data.
project | Projects retirement test exempt amounts for ages 65-69.
project1 | Calculates a monthly retirement test exempt amount using a base amount and a ratio of average wages.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
Rtea65m Class, Legend, Public Data Members, Public Friends, Public Methods


Rtea65m Constructor

Rtea65m Constructor
Rtea65m Class

Initializes an Rtea65m, with or without a specified first year.

Collapse Expand Description

There are two versions of the Rtea65m constructor. The last year of data is specified in both. But if the first year is not specified, it is assumed to be 1937.

Collapse Expand Overload List
Name | Description
Rtea65m::Rtea65m (int) | Initializes historical values for monthly test over full retirement age, with first year as 1937.
Rtea65m::Rtea65m (int, int) | Initializes historical values for monthly test over full retirement age, with first year as specified.
Collapse Expand Class

Rtea65m Class

Collapse Expand Links
Rtea65m Class


Rtea65m::Rtea65m Constructor (int)

Rtea65m::Rtea65m Constructor (int)
Rtea65m Class Rtea65m Members Rtea65m Constructor

Initializes historical values for monthly test over full retirement age, with first year as 1937.

C++
Rtea65m(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Last year of projection.
Collapse Expand Remarks

Calls initialize.

Collapse Expand Group

Rtea65m Constructor

Collapse Expand Links
Rtea65m Class, Rtea65m Members, Rtea65m Constructor


Rtea65m::Rtea65m Constructor (int, int)

Rtea65m::Rtea65m Constructor (int, int)
Rtea65m Class Rtea65m Members Rtea65m Constructor

Initializes historical values for monthly test over full retirement age, with first year as specified.

C++
Rtea65m(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | First year of data.
int newLastYear | Last year of projection.
Collapse Expand Remarks

Calls initialize.

Collapse Expand Group

Rtea65m Constructor

Collapse Expand Links
Rtea65m Class, Rtea65m Members, Rtea65m Constructor


Rtea65m Methods

Rtea65m Methods
Rtea65m Class Legend Public Methods

The methods of the Rtea65m class are listed here.

Collapse Expand Class

Rtea65m Class

Collapse Expand Public Methods
Name | Description
getFraction | Returns x in 1-for-x rule for earnings offset.
getHistAmount | Returns historical monthly exempt amount for specified year.
initialize | Initializes historical data.
project | Projects retirement test exempt amounts for ages 65-69.
Collapse Expand Links
Rtea65m Class, Legend, Public Methods


Rtea65m::getFraction Method

Rtea65m::getFraction Method
Rtea65m Class Rtea65m Members Rtea65m Methods

Returns x in 1-for-x rule for earnings offset.

C++
static int getFraction(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which fraction is desired.
Collapse Expand Returns

x in 1-for-x rule for earnings offset.

Collapse Expand Group

Rtea65m Methods

Collapse Expand Links
Rtea65m Class, Rtea65m Members, Rtea65m Methods


Rtea65m::getHistAmount Method

Rtea65m::getHistAmount Method
Rtea65m Class Rtea65m Members Rtea65m Methods

Returns historical monthly exempt amount for specified year.

C++
static double getHistAmount(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which exempt amount is desired.
Collapse Expand Returns

Exempt amount for specified year.

Collapse Expand Group

Rtea65m Methods

Collapse Expand Links
Rtea65m Class, Rtea65m Members, Rtea65m Methods


Rtea65m::initialize Method

Rtea65m::initialize Method
Rtea65m Class Rtea65m Members Rtea65m Methods

Initializes historical data.

C++
void initialize();
Collapse Expand Group

Rtea65m Methods

Collapse Expand Links
Rtea65m Class, Rtea65m Members, Rtea65m Methods


Rtea65m::project Method

Rtea65m::project Method
Rtea65m Class Rtea65m Members Rtea65m Methods

Projects retirement test exempt amounts for ages 65-69.

C++
void project(
    int firstYear,
    const DoubleAnnual& averageWages,
    const DoubleAnnual& cpi
);
Collapse Expand Parameters
Parameters | Description
int firstYear | First year of projection.
const DoubleAnnual& averageWages | Average wage series.
const DoubleAnnual& cpi | Benefit increase series.
Collapse Expand Group

Rtea65m Methods

Collapse Expand Links
Rtea65m Class, Rtea65m Members, Rtea65m Methods


RteaHigh Class

RteaHigh Class
RteaHigh Methods RteaHigh Members rtgenrl.h Classes

Manages the upper annual retirement test exempt amounts when there were two tiers.

Collapse Expand Class Hierarchy
  RteaHighRteaHighRteaHigh
C++
class RteaHigh : public RtGeneral;
Collapse Expand File

File: rtgenrl.h

Module: PiaData Library

Collapse Expand Remarks

There were two tiers from 1961 to 1972.

Collapse Expand Group

Classes

Collapse Expand Links
RteaHigh Methods, RteaHigh Members, rtgenrl.h, Classes


RteaHigh Members

RteaHigh Members
RteaHigh Class Legend Public Data Members Public Friends Public Methods

The following tables list the members exposed by RteaHigh.

Collapse Expand Class

RteaHigh Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
RtGeneral | Initializes an RtGeneral, with or without a specified first year.
RteaHigh | Initializes historical values for annual test at second tier.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly retirement test exempt amounts to annual amounts.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getFraction | Returns x in 1-for-x rule for earnings offset.
getLastYear | Returns last year of data.
getMaxAgePL | Returns maximum age for which earnings test applies.
initialize | Initializes historical data.
project1 | Calculates a monthly retirement test exempt amount using a base amount and a ratio of average wages.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
RteaHigh Class, Legend, Public Data Members, Public Friends, Public Methods


RteaHigh::RteaHigh Constructor

RteaHigh::RteaHigh Constructor
RteaHigh Class RteaHigh Members RteaHigh Class

Initializes historical values for annual test at second tier.

C++
RteaHigh();
Collapse Expand Remarks

Calls initialize.

First and last years are 1961 and 1972.

Collapse Expand Class

RteaHigh Class

Collapse Expand Links
RteaHigh Class, RteaHigh Members, RteaHigh Class


RteaHigh Methods

RteaHigh Methods
RteaHigh Class Legend Public Methods

The methods of the RteaHigh class are listed here.

Collapse Expand Class

RteaHigh Class

Collapse Expand Public Methods
Name | Description
getFraction | Returns x in 1-for-x rule for earnings offset.
initialize | Initializes historical data.
Collapse Expand Links
RteaHigh Class, Legend, Public Methods


RteaHigh::getFraction Method

RteaHigh::getFraction Method
RteaHigh Class RteaHigh Members RteaHigh Methods

Returns x in 1-for-x rule for earnings offset.

C++
static int getFraction();
Collapse Expand Returns

Always returns 1.

Collapse Expand Group

RteaHigh Methods

Collapse Expand Links
RteaHigh Class, RteaHigh Members, RteaHigh Methods


RteaHigh::initialize Method

RteaHigh::initialize Method
RteaHigh Class RteaHigh Members RteaHigh Methods

Initializes historical data.

C++
void initialize();
Collapse Expand Group

RteaHigh Methods

Collapse Expand Links
RteaHigh Class, RteaHigh Members, RteaHigh Methods


RtGeneral Class

RtGeneral Class
RtGeneral Constructor RtGeneral Methods RtGeneral Members rtgenrl.h Classes

Parent of classes to manage the retirement test exempt amount projections.

Collapse Expand Class Hierarchy
  RtGeneralRtGeneral
C++
class RtGeneral : public DoubleAnnual;
Collapse Expand File

File: rtgenrl.h

Module: PiaData Library

Collapse Expand Remarks

Child classes are Rtea62, Rtea62m, Rtea65, Rtea65m, and RteaHigh.

Collapse Expand See Also

Rtea62, Rtea62m, Rtea65, Rtea65m, RteaHigh

Collapse Expand Group

Classes

Collapse Expand Links
RtGeneral Constructor, RtGeneral Methods, RtGeneral Members, rtgenrl.h, Classes


RtGeneral Members

RtGeneral Members
RtGeneral Class Legend Public Data Members Public Friends Public Methods

The following tables list the members exposed by RtGeneral.

Collapse Expand Class

RtGeneral Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
RtGeneral | Initializes an RtGeneral, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly retirement test exempt amounts to annual amounts.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
getMaxAgePL | Returns maximum age for which earnings test applies.
project1 | Calculates a monthly retirement test exempt amount using a base amount and a ratio of average wages.
~RtGeneral | Destructor.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
RtGeneral Class, Legend, Public Data Members, Public Friends, Public Methods


RtGeneral Constructor

RtGeneral Constructor
RtGeneral Class

Initializes an RtGeneral, with or without a specified first year.

Collapse Expand Description

There are two versions of the RtGeneral constructor. The last year of data is specified in both. But if the first year is not specified, it is assumed to be 1937.

Collapse Expand Overload List
Name | Description
RtGeneral::RtGeneral (int) | Initializes arrays starting in 1937.
RtGeneral::RtGeneral (int, int) | Initializes arrays starting in specified year.
Collapse Expand Class

RtGeneral Class

Collapse Expand Links
RtGeneral Class


RtGeneral::RtGeneral Constructor (int)

RtGeneral::RtGeneral Constructor (int)
RtGeneral Class RtGeneral Members RtGeneral Constructor

Initializes arrays starting in 1937.

C++
RtGeneral(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Last year of projection.
Collapse Expand Group

RtGeneral Constructor

Collapse Expand Links
RtGeneral Class, RtGeneral Members, RtGeneral Constructor


RtGeneral::RtGeneral Constructor (int, int)

RtGeneral::RtGeneral Constructor (int, int)
RtGeneral Class RtGeneral Members RtGeneral Constructor

Initializes arrays starting in specified year.

C++
RtGeneral(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | First year of data.
int newLastYear | Last year of projection.
Collapse Expand Group

RtGeneral Constructor

Collapse Expand Links
RtGeneral Class, RtGeneral Members, RtGeneral Constructor


RtGeneral::~RtGeneral Destructor

RtGeneral::~RtGeneral Destructor
RtGeneral Class RtGeneral Members RtGeneral Class

Destructor.

C++
virtual ~RtGeneral();
Collapse Expand Class

RtGeneral Class

Collapse Expand Links
RtGeneral Class, RtGeneral Members, RtGeneral Class


RtGeneral Methods

RtGeneral Methods
RtGeneral Class Legend Public Methods

The methods of the RtGeneral class are listed here.

Collapse Expand Class

RtGeneral Class

Collapse Expand Public Methods
Name | Description
convertMonthToAnnual | Converts monthly retirement test exempt amounts to annual amounts.
getMaxAgePL | Returns maximum age for which earnings test applies.
project1 | Calculates a monthly retirement test exempt amount using a base amount and a ratio of average wages.
Collapse Expand Links
RtGeneral Class, Legend, Public Methods


RtGeneral::convertMonthToAnnual Method

RtGeneral::convertMonthToAnnual Method
RtGeneral Class RtGeneral Members RtGeneral Methods

Converts monthly retirement test exempt amounts to annual amounts.

C++
void convertMonthToAnnual(
    const RtGeneral& rteam
);
Collapse Expand Parameters
Parameters | Description
const RtGeneral& rteam | Monthly retirement test exempt amounts.
Collapse Expand Group

RtGeneral Methods

Collapse Expand Links
RtGeneral Class, RtGeneral Members, RtGeneral Methods


RtGeneral::getMaxAgePL Method

RtGeneral::getMaxAgePL Method
RtGeneral Class RtGeneral Members RtGeneral Methods

Returns maximum age for which earnings test applies.

C++
static Age getMaxAgePL(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which age is desired.
Collapse Expand Returns

Maximum age for which earnings test applies.

Collapse Expand Group

RtGeneral Methods

Collapse Expand Links
RtGeneral Class, RtGeneral Members, RtGeneral Methods


RtGeneral::project1 Method

RtGeneral::project1 Method
RtGeneral Class RtGeneral Members RtGeneral Methods

Calculates a monthly retirement test exempt amount using a base amount and a ratio of average wages.

C++
static double project1(
    double baseAmount,
    double numerator,
    double denominator,
    double previous
);
Collapse Expand Parameters
Parameters | Description
double baseAmount | Value of exempt amount in base year.
double numerator | Numerator used in projection.
double denominator | Denominator used in projection.
double previous | Value of exempt amount in previous year.
Collapse Expand Returns

The new monthly retirement test exempt amount.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_RTGENRL if denominator is out of range (only in debug mode).
Collapse Expand Group

RtGeneral Methods

Collapse Expand Links
RtGeneral Class, RtGeneral Members, RtGeneral Methods


ScaledEarnFactors Class

ScaledEarnFactors Class
ScaledEarnFactors Enumerations ScaledEarnFactors Methods ScaledEarnFactors Members ScaledEarnFactors.h Classes

Manages scaled earner amounts.

Collapse Expand Class Hierarchy
  ScaledEarnFactors
C++
class ScaledEarnFactors;
Collapse Expand File

File: ScaledEarnFactors.h

Module: PiaData Library

Collapse Expand Remarks

The factors are gotten from an open file via the read function. They begin at a first age and go through a last age, as specified in the constructor. There are three levels of scaled earnings: high, average, and low.

Collapse Expand Group

Classes

Collapse Expand Links
ScaledEarnFactors Enumerations, ScaledEarnFactors Methods, ScaledEarnFactors Members, ScaledEarnFactors.h, Classes


ScaledEarnFactors Members

ScaledEarnFactors Members
Enumerations ScaledEarnFactors Class Legend Public Methods

The following tables list the members exposed by ScaledEarnFactors.

Collapse Expand Enumerations
Name | Description
scaleType | The enumerated scaled earnings type indicator.
Collapse Expand Class

ScaledEarnFactors Class

Collapse Expand Public Methods
Name | Description
ScaledEarnFactors | Initializes scaled earnings factors.
getAverageEarnFactor | Returns average earner factor for an age.
getDecimals | Returns number of decimal places in output.
getFirstAge | Returns first age.
getHighEarnFactor | Returns high earner factor for an age.
getLastAge | Returns last age.
getLowEarnFactor | Returns low earner factor for an age.
getScaledEarnFactor | Returns a scaled earner factor for an age.
getVeryLowEarnFactor | Returns very low earner factor for an age.
getWidth | Returns width of output.
read | Reads scaled earnings factors from file.
setAverageEarnings | Sets earnings in an EarnProject to average earnings between two ages.
setDecimals | Sets number of decimals in output field.
setHighEarnings | Sets earnings in an EarnProject to high earnings between two ages.
setLowEarnings | Sets earnings in an EarnProject to low earnings between two ages.
setScaledEarnings | Sets earnings in an EarnProject to a particular type of scaled earnings between two ages.
setVeryLowEarnings | Sets earnings in an EarnProject to very low earnings between two ages.
setWidth | Sets width of output field.
write | Writes scaled earnings factors to file.
~ScaledEarnFactors | Destructor.
Collapse Expand Links
Enumerations, ScaledEarnFactors Class, Legend, Public Methods


ScaledEarnFactors::ScaledEarnFactors Constructor

ScaledEarnFactors::ScaledEarnFactors Constructor
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Class

Initializes scaled earnings factors.

C++
ScaledEarnFactors(
    int newFirstAge,
    int newLastAge
);
Collapse Expand Parameters
Parameters | Description
int newFirstAge | First age of data.
int newLastAge | Last age of data.
Collapse Expand Remarks

Resizes the internal arrays to newLastAge - newFirstAge + 1.

Collapse Expand Class

ScaledEarnFactors Class

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Class


ScaledEarnFactors::~ScaledEarnFactors Destructor

ScaledEarnFactors::~ScaledEarnFactors Destructor
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Class

Destructor.

C++
~ScaledEarnFactors();
Collapse Expand Class

ScaledEarnFactors Class

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Class


ScaledEarnFactors Enumerations

ScaledEarnFactors Enumerations
Enumerations ScaledEarnFactors Class Legend

The enumerations of the ScaledEarnFactors class are listed here.

Collapse Expand Enumerations
Name | Description
scaleType | The enumerated scaled earnings type indicator.
Collapse Expand Class

ScaledEarnFactors Class

Collapse Expand Links
Enumerations, ScaledEarnFactors Class, Legend


ScaledEarnFactors::scaleType Enumeration

ScaledEarnFactors::scaleType Enumeration
ScaledEarnFactors.h ScaledEarnFactors Enumerations

The enumerated scaled earnings type indicator.

C++
enum scaleType {
  SCALEVERYLOW,
  SCALELOW,
  SCALEAVERAGE,
  SCALEHIGH
};
Collapse Expand File

File: ScaledEarnFactors.h

Module: PiaData Library

Collapse Expand Members
Members | Description
SCALEVERYLOW | Very low scaled earnings. (Career average at about 25% of the AWI.)
SCALELOW | Low scaled earnings. (Career average at about 40% of the AWI.)
SCALEAVERAGE | Average scaled earnings. (Career average at about 100% of the AWI.)
SCALEHIGH | High scaled earnings. (Career average at about 160% of the AWI.)
Collapse Expand Group

ScaledEarnFactors Enumerations

Collapse Expand Links
ScaledEarnFactors.h, ScaledEarnFactors Enumerations


ScaledEarnFactors Methods

ScaledEarnFactors Methods
ScaledEarnFactors Class Legend Public Methods

The methods of the ScaledEarnFactors class are listed here.

Collapse Expand Class

ScaledEarnFactors Class

Collapse Expand Public Methods
Name | Description
getAverageEarnFactor | Returns average earner factor for an age.
getDecimals | Returns number of decimal places in output.
getFirstAge | Returns first age.
getHighEarnFactor | Returns high earner factor for an age.
getLastAge | Returns last age.
getLowEarnFactor | Returns low earner factor for an age.
getScaledEarnFactor | Returns a scaled earner factor for an age.
getVeryLowEarnFactor | Returns very low earner factor for an age.
getWidth | Returns width of output.
read | Reads scaled earnings factors from file.
setAverageEarnings | Sets earnings in an EarnProject to average earnings between two ages.
setDecimals | Sets number of decimals in output field.
setHighEarnings | Sets earnings in an EarnProject to high earnings between two ages.
setLowEarnings | Sets earnings in an EarnProject to low earnings between two ages.
setScaledEarnings | Sets earnings in an EarnProject to a particular type of scaled earnings between two ages.
setVeryLowEarnings | Sets earnings in an EarnProject to very low earnings between two ages.
setWidth | Sets width of output field.
write | Writes scaled earnings factors to file.
Collapse Expand Links
ScaledEarnFactors Class, Legend, Public Methods


ScaledEarnFactors::getAverageEarnFactor Method

ScaledEarnFactors::getAverageEarnFactor Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Returns average earner factor for an age.

C++
double getAverageEarnFactor(
    int theAge
) const;
Collapse Expand Parameters
Parameters | Description
int theAge | The age for which factor is desired.
Collapse Expand Returns

Average earner factor for an age.

Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::getDecimals Method

ScaledEarnFactors::getDecimals Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Returns number of decimal places in output.

C++
int getDecimals() const;
Collapse Expand Returns

Number of decimal places in output.

Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::getFirstAge Method

ScaledEarnFactors::getFirstAge Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Returns first age.

C++
int getFirstAge() const;
Collapse Expand Returns

First age.

Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::getHighEarnFactor Method

ScaledEarnFactors::getHighEarnFactor Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Returns high earner factor for an age.

C++
double getHighEarnFactor(
    int theAge
) const;
Collapse Expand Parameters
Parameters | Description
int theAge | The age for which factor is desired.
Collapse Expand Returns

High earner factor for an age.

Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::getLastAge Method

ScaledEarnFactors::getLastAge Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Returns last age.

C++
int getLastAge() const;
Collapse Expand Returns

Last age.

Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::getLowEarnFactor Method

ScaledEarnFactors::getLowEarnFactor Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Returns low earner factor for an age.

C++
double getLowEarnFactor(
    int theAge
) const;
Collapse Expand Parameters
Parameters | Description
int theAge | The age for which factor is desired.
Collapse Expand Returns

Low earner factor for an age.

Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::getScaledEarnFactor Method

ScaledEarnFactors::getScaledEarnFactor Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Returns a scaled earner factor for an age.

C++
double getScaledEarnFactor(
    int theAge,
    scaleType earnType
) const;
Collapse Expand Parameters
Parameters | Description
int theAge | The age for which factor is desired.
scaleType earnType | The type of scaled earnings which is desired.
Collapse Expand Returns

Scaled earner factor for an age.

Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::getVeryLowEarnFactor Method

ScaledEarnFactors::getVeryLowEarnFactor Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Returns very low earner factor for an age.

C++
double getVeryLowEarnFactor(
    int theAge
) const;
Collapse Expand Parameters
Parameters | Description
int theAge | The age for which factor is desired.
Collapse Expand Returns

Very low earner factor for an age.

Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::getWidth Method

ScaledEarnFactors::getWidth Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Returns width of output.

C++
int getWidth() const;
Collapse Expand Returns

Width of output.

Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::read Method

ScaledEarnFactors::read Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Reads scaled earnings factors from file.

C++
void read(
    std::istream& in,
    int ageStart,
    int ageEnd,
    bool desc
);
Collapse Expand Parameters
Parameters | Description
std::istream& in | Input file. (It must already be open.)
int ageStart | The age to begin reading from file.
int ageEnd | The age to end reading from file.
bool desc | Boolean for skipping the first line in the file.
Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::setAverageEarnings Method

ScaledEarnFactors::setAverageEarnings Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Sets earnings in an EarnProject to average earnings between two ages.

C++
void setAverageEarnings(
    EarnProject& earnProject,
    const AverageWage& averageWage,
    int birthYear,
    int ageStart,
    int ageEnd
);
Collapse Expand Parameters
Parameters | Description
EarnProject& earnProject | Place to set earnings.
const AverageWage& averageWage | The average wage index.
int birthYear | Worker's year of birth.
int ageStart | First year of average earnings.
int ageEnd | Last year of average earnings.
Collapse Expand Remarks

For each year, sets earnings equal to averageFactors times the average wage.

Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::setDecimals Method

ScaledEarnFactors::setDecimals Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Sets number of decimals in output field.

C++
void setDecimals(
    int newDecimals
);
Collapse Expand Parameters
Parameters | Description
int newDecimals | New number of decimals in output.
Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::setHighEarnings Method

ScaledEarnFactors::setHighEarnings Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Sets earnings in an EarnProject to high earnings between two ages.

C++
void setHighEarnings(
    EarnProject& earnProject,
    const AverageWage& averageWage,
    int birthYear,
    int ageStart,
    int ageEnd
);
Collapse Expand Parameters
Parameters | Description
EarnProject& earnProject | Place to set earnings.
const AverageWage& averageWage | The average wage index.
int birthYear | Worker's year of birth.
int ageStart | First year of high earnings.
int ageEnd | Last year of high earnings.
Collapse Expand Remarks

For each year, sets earnings equal to highFactors times the average wage.

Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::setLowEarnings Method

ScaledEarnFactors::setLowEarnings Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Sets earnings in an EarnProject to low earnings between two ages.

C++
void setLowEarnings(
    EarnProject& earnProject,
    const AverageWage& averageWage,
    int birthYear,
    int ageStart,
    int ageEnd
);
Collapse Expand Parameters
Parameters | Description
EarnProject& earnProject | Place to set earnings.
const AverageWage& averageWage | The average wage index.
int birthYear | Worker's year of birth.
int ageStart | First year of low earnings.
int ageEnd | Last year of low earnings.
Collapse Expand Remarks

For each year, sets earnings equal to lowFactors times the average wage.

Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::setScaledEarnings Method

ScaledEarnFactors::setScaledEarnings Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Sets earnings in an EarnProject to a particular type of scaled earnings between two ages.

C++
void setScaledEarnings(
    EarnProject& earnProject,
    const AverageWage& averageWage,
    int birthYear,
    int ageStart,
    int ageEnd,
    scaleType earnType
);
Collapse Expand Parameters
Parameters | Description
EarnProject& earnProject | Place to set earnings.
const AverageWage& averageWage | The average wage index.
int birthYear | Worker's year of birth.
int ageStart | First year of low earnings.
int ageEnd | Last year of low earnings.
scaleType earnType | Type of scaled earnings.
Collapse Expand Remarks

For each year, sets earnings equal to a scaled factor times the average wage.

Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::setVeryLowEarnings Method

ScaledEarnFactors::setVeryLowEarnings Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Sets earnings in an EarnProject to very low earnings between two ages.

C++
void setVeryLowEarnings(
    EarnProject& earnProject,
    const AverageWage& averageWage,
    int birthYear,
    int ageStart,
    int ageEnd
);
Collapse Expand Parameters
Parameters | Description
EarnProject& earnProject | Place to set earnings.
const AverageWage& averageWage | The average wage index.
int birthYear | Worker's year of birth.
int ageStart | First year of low earnings.
int ageEnd | Last year of low earnings.
Collapse Expand Remarks

For each year, sets earnings equal to veryLowFactors times the average wage.

Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::setWidth Method

ScaledEarnFactors::setWidth Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Sets width of output field.

C++
void setWidth(
    int newWidth
);
Collapse Expand Parameters
Parameters | Description
int newWidth | New width of output field.
Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


ScaledEarnFactors::write Method

ScaledEarnFactors::write Method
ScaledEarnFactors Class ScaledEarnFactors Members ScaledEarnFactors Methods

Writes scaled earnings factors to file.

C++
void write(
    std::ostream& out,
    int ageStart,
    int ageEnd
);
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output file. (It must already be open.)
int ageStart | The age to begin writing to file.
int ageEnd | The age to end writing to file.
Collapse Expand Group

ScaledEarnFactors Methods

Collapse Expand Links
ScaledEarnFactors Class, ScaledEarnFactors Members, ScaledEarnFactors Methods


Secondary Class

Secondary Class
Secondary Data Members Secondary Methods Secondary Members Secondary.h Classes

Contains the information about a secondary benefit.

Collapse Expand Class Hierarchy
  Secondary
C++
class Secondary;
Collapse Expand File

File: Secondary.h

Module: PiaData Library

Collapse Expand Remarks

This is used as a vector element in SecondaryArray.

Collapse Expand See Also

SecondaryArray

Collapse Expand Group

Classes

Collapse Expand Links
Secondary Data Members, Secondary Methods, Secondary Members, Secondary.h, Classes


Secondary Members

Secondary Members
Secondary Class Legend Public Data Members Public Methods

The following tables list the members exposed by Secondary.

Collapse Expand Class

Secondary Class

Collapse Expand Public Data Members
Name | Description
bic | Type of beneficiary code.
entDate | The date of entitlement.
pifc | Type of pia calculation method.
Collapse Expand Public Methods
Name | Description
Secondary | Initializes codes to blank or zero.
check | Checks data for validity.
deleteContents | Sets codes to blank or zero.
eligibleForMax | Returns true if this benefit is affected by family maximum.
getArf | Returns reduction or increment factor.
getBenefit | Returns benefit after reduction for family maximum but before actuarial reduction.
getBenefitFactor | Returns benefit factor.
getFullBenefit | Returns full-rate benefit (before actuarial reduction or reduction for family maximum).
getMonthsArdri | Returns months of actuarial reduction or increment.
getReducedBenefit | Returns benefit after actuarial reduction and reduction for family maximum.
getRoundedBenefit | Returns benefit after all reductions and rounding.
isWidow | Returns true if widow (aged or disabled); false otherwise.
setArf | Sets reduction or increment factor.
setBenefit | Sets benefit after reduction for family maximum but before actuarial reduction.
setBenefitFactor | Sets benefit factor.
setFullBenefit | Sets full-rate benefit (before actuarial reduction or reduction for family maximum).
setMonthsArdri | Sets months of actuarial reduction or increment.
setReducedBenefit | Sets benefit after actuarial reduction and reduction for family maximum.
setRoundedBenefit | Sets benefit after all reductions and rounding.
Collapse Expand Links
Secondary Class, Legend, Public Data Members, Public Methods


Secondary::Secondary Constructor

Secondary::Secondary Constructor
Secondary Class Secondary Members Secondary Class

Initializes codes to blank or zero.

C++
Secondary();
Collapse Expand Class

Secondary Class

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Class


Secondary Data Members

Secondary Data Members
Secondary Class Legend Public Data Members

The data members of the Secondary class are listed here.

Collapse Expand Class

Secondary Class

Collapse Expand Public Data Members
Name | Description
bic | Type of beneficiary code.
entDate | The date of entitlement.
pifc | Type of pia calculation method.
Collapse Expand Links
Secondary Class, Legend, Public Data Members


Secondary::bic Data Member

Secondary::bic Data Member
Secondary Class Secondary Members Secondary Data Members

Type of beneficiary code.

C++
Bic bic;
Collapse Expand Group

Secondary Data Members

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Data Members


Secondary::entDate Data Member

Secondary::entDate Data Member
Secondary Class Secondary Members Secondary Data Members

The date of entitlement.

C++
DateMoyr entDate;
Collapse Expand Group

Secondary Data Members

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Data Members


Secondary::pifc Data Member

Secondary::pifc Data Member
Secondary Class Secondary Members Secondary Data Members

Type of pia calculation method.

C++
Pifc pifc;
Collapse Expand Group

Secondary Data Members

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Data Members


Secondary Methods

Secondary Methods
Secondary Class Legend Public Methods

The methods of the Secondary class are listed here.

Collapse Expand Class

Secondary Class

Collapse Expand Public Methods
Name | Description
check | Checks data for validity.
deleteContents | Sets codes to blank or zero.
eligibleForMax | Returns true if this benefit is affected by family maximum.
getArf | Returns reduction or increment factor.
getBenefit | Returns benefit after reduction for family maximum but before actuarial reduction.
getBenefitFactor | Returns benefit factor.
getFullBenefit | Returns full-rate benefit (before actuarial reduction or reduction for family maximum).
getMonthsArdri | Returns months of actuarial reduction or increment.
getReducedBenefit | Returns benefit after actuarial reduction and reduction for family maximum.
getRoundedBenefit | Returns benefit after all reductions and rounding.
isWidow | Returns true if widow (aged or disabled); false otherwise.
setArf | Sets reduction or increment factor.
setBenefit | Sets benefit after reduction for family maximum but before actuarial reduction.
setBenefitFactor | Sets benefit factor.
setFullBenefit | Sets full-rate benefit (before actuarial reduction or reduction for family maximum).
setMonthsArdri | Sets months of actuarial reduction or increment.
setReducedBenefit | Sets benefit after actuarial reduction and reduction for family maximum.
setRoundedBenefit | Sets benefit after all reductions and rounding.
Collapse Expand Links
Secondary Class, Legend, Public Methods


Secondary::check Method

Secondary::check Method
Secondary Class Secondary Members Secondary Methods

Checks data for validity.

C++
void check();
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_SECONDARY if type of beneficiary is not set.
Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::deleteContents Method

Secondary::deleteContents Method
Secondary Class Secondary Members Secondary Methods

Sets codes to blank or zero.

C++
void deleteContents();
Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::eligibleForMax Method

Secondary::eligibleForMax Method
Secondary Class Secondary Members Secondary Methods

Returns true if this benefit is affected by family maximum.

C++
bool eligibleForMax() const;
Collapse Expand Returns

True if this benefit is affected by family maximum.

Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::getArf Method

Secondary::getArf Method
Secondary Class Secondary Members Secondary Methods

Returns reduction or increment factor.

C++
double getArf() const;
Collapse Expand Returns

Reduction or increment factor.

Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::getBenefit Method

Secondary::getBenefit Method
Secondary Class Secondary Members Secondary Methods

Returns benefit after reduction for family maximum but before actuarial reduction.

C++
double getBenefit() const;
Collapse Expand Returns

Benefit after reduction for family maximum but before actuarial reduction.

Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::getBenefitFactor Method

Secondary::getBenefitFactor Method
Secondary Class Secondary Members Secondary Methods

Returns benefit factor.

C++
double getBenefitFactor() const;
Collapse Expand Returns

Benefit factor.

Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::getFullBenefit Method

Secondary::getFullBenefit Method
Secondary Class Secondary Members Secondary Methods

Returns full-rate benefit (before actuarial reduction or reduction for family maximum).

C++
double getFullBenefit() const;
Collapse Expand Returns

Full-rate benefit (before actuarial reduction or reduction for family maximum).

Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::getMonthsArdri Method

Secondary::getMonthsArdri Method
Secondary Class Secondary Members Secondary Methods

Returns months of actuarial reduction or increment.

C++
int getMonthsArdri() const;
Collapse Expand Returns

Months of actuarial reduction or increment.

Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::getReducedBenefit Method

Secondary::getReducedBenefit Method
Secondary Class Secondary Members Secondary Methods

Returns benefit after actuarial reduction and reduction for family maximum.

C++
double getReducedBenefit() const;
Collapse Expand Returns

Benefit after actuarial reduction and reduction for family maximum.

Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::getRoundedBenefit Method

Secondary::getRoundedBenefit Method
Secondary Class Secondary Members Secondary Methods

Returns benefit after all reductions and rounding.

C++
double getRoundedBenefit() const;
Collapse Expand Returns

Benefit after all reductions and rounding.

Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::isWidow Method

Secondary::isWidow Method
Secondary Class Secondary Members Secondary Methods

Returns true if widow (aged or disabled); false otherwise.

C++
bool isWidow() const;
Collapse Expand Returns

True if widow (aged or disabled); false otherwise.

Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::setArf Method

Secondary::setArf Method
Secondary Class Secondary Members Secondary Methods

Sets reduction or increment factor.

C++
void setArf(
    double newArf
);
Collapse Expand Parameters
Parameters | Description
double newArf | New reduction or increment factor.
Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::setBenefit Method

Secondary::setBenefit Method
Secondary Class Secondary Members Secondary Methods

Sets benefit after reduction for family maximum but before actuarial reduction.

C++
void setBenefit(
    double newBenefit
);
Collapse Expand Parameters
Parameters | Description
double newBenefit | New benefit.
Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::setBenefitFactor Method

Secondary::setBenefitFactor Method
Secondary Class Secondary Members Secondary Methods

Sets benefit factor.

C++
void setBenefitFactor(
    double newBenefitFactor
);
Collapse Expand Parameters
Parameters | Description
double newBenefitFactor | New benefit factor.
Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::setFullBenefit Method

Secondary::setFullBenefit Method
Secondary Class Secondary Members Secondary Methods

Sets full-rate benefit (before actuarial reduction or reduction for family maximum).

C++
void setFullBenefit(
    double newFullBenefit
);
Collapse Expand Parameters
Parameters | Description
double newFullBenefit | New full benefit.
Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::setMonthsArdri Method

Secondary::setMonthsArdri Method
Secondary Class Secondary Members Secondary Methods

Sets months of actuarial reduction or increment.

C++
void setMonthsArdri(
    int newMonthsArdri
);
Collapse Expand Parameters
Parameters | Description
int newMonthsArdri | New months of actuarial reduction or increment.
Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::setReducedBenefit Method

Secondary::setReducedBenefit Method
Secondary Class Secondary Members Secondary Methods

Sets benefit after actuarial reduction and reduction for family maximum.

C++
void setReducedBenefit(
    double newReducedBenefit
);
Collapse Expand Parameters
Parameters | Description
double newReducedBenefit | New reduced benefit.
Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


Secondary::setRoundedBenefit Method

Secondary::setRoundedBenefit Method
Secondary Class Secondary Members Secondary Methods

Sets benefit after all reductions and rounding.

C++
void setRoundedBenefit(
    double newRoundedBenefit
);
Collapse Expand Parameters
Parameters | Description
double newRoundedBenefit | New rounded benefit.
Collapse Expand Group

Secondary Methods

Collapse Expand Links
Secondary Class, Secondary Members, Secondary Methods


SecondaryArray Class

SecondaryArray Class
SecondaryArray Data Members SecondaryArray Methods SecondaryArray Members SecondaryArray.h Classes

Manages an array of Secondary's.

Collapse Expand Class Hierarchy
  SecondaryArray
C++
class SecondaryArray;
Collapse Expand File

File: SecondaryArray.h

Module: PiaData Library

Collapse Expand Remarks

This represents all the auxiliary benefits in a family. This is used in various functions in PiaCal.

Collapse Expand See Also

Secondary, PiaCal

Collapse Expand Group

Classes

Collapse Expand Links
SecondaryArray Data Members, SecondaryArray Methods, SecondaryArray Members, SecondaryArray.h, Classes


SecondaryArray Members

SecondaryArray Members
SecondaryArray Class Legend Public Data Members Public Methods

The following tables list the members exposed by SecondaryArray.

Collapse Expand Class

SecondaryArray Class

Collapse Expand Public Data Members
Name | Description
secondary | Array of secondary data.
Collapse Expand Public Methods
Name | Description
SecondaryArray | Initializes arrays.
deleteContents | Resets all values to zero.
getTotalFullBenefit | Returns total family benefit before reduction for age or family maximum.
getTotalFullBenefitMax | Returns total family benefit before reduction for age or family maximum, excluding beneficiaries who are not affected by the maximum.
~SecondaryArray | Releases memory.
Collapse Expand Links
SecondaryArray Class, Legend, Public Data Members, Public Methods


SecondaryArray::SecondaryArray Constructor

SecondaryArray::SecondaryArray Constructor
SecondaryArray Class SecondaryArray Members SecondaryArray Class

Initializes arrays.

C++
SecondaryArray();
Collapse Expand Remarks

Creates PiaDataArray::DimLimits::MAXFAMSIZE new Secondary's and pushes them onto the vector.

Collapse Expand Class

SecondaryArray Class

Collapse Expand Links
SecondaryArray Class, SecondaryArray Members, SecondaryArray Class


SecondaryArray::~SecondaryArray Destructor

SecondaryArray::~SecondaryArray Destructor
SecondaryArray Class SecondaryArray Members SecondaryArray Class

Releases memory.

C++
~SecondaryArray();
Collapse Expand Class

SecondaryArray Class

Collapse Expand Links
SecondaryArray Class, SecondaryArray Members, SecondaryArray Class


SecondaryArray Data Members

SecondaryArray Data Members
SecondaryArray Class Legend Public Data Members

The data members of the SecondaryArray class are listed here.

Collapse Expand Class

SecondaryArray Class

Collapse Expand Public Data Members
Name | Description
secondary | Array of secondary data.
Collapse Expand Links
SecondaryArray Class, Legend, Public Data Members


SecondaryArray::secondary Data Member

SecondaryArray::secondary Data Member
SecondaryArray Class SecondaryArray Members SecondaryArray Data Members

Array of secondary data.

C++
std::vector< Secondary * > secondary;
Collapse Expand Group

SecondaryArray Data Members

Collapse Expand Links
SecondaryArray Class, SecondaryArray Members, SecondaryArray Data Members


SecondaryArray Methods

SecondaryArray Methods
SecondaryArray Class Legend Public Methods

The methods of the SecondaryArray class are listed here.

Collapse Expand Class

SecondaryArray Class

Collapse Expand Public Methods
Name | Description
deleteContents | Resets all values to zero.
getTotalFullBenefit | Returns total family benefit before reduction for age or family maximum.
getTotalFullBenefitMax | Returns total family benefit before reduction for age or family maximum, excluding beneficiaries who are not affected by the maximum.
Collapse Expand Links
SecondaryArray Class, Legend, Public Methods


SecondaryArray::deleteContents Method

SecondaryArray::deleteContents Method
SecondaryArray Class SecondaryArray Members SecondaryArray Methods

Resets all values to zero.

C++
void deleteContents();
Collapse Expand Remarks

For each vector element, calls Secondary::deleteContents.

Collapse Expand Group

SecondaryArray Methods

Collapse Expand Links
SecondaryArray Class, SecondaryArray Members, SecondaryArray Methods


SecondaryArray::getTotalFullBenefit Method

SecondaryArray::getTotalFullBenefit Method
SecondaryArray Class SecondaryArray Members SecondaryArray Methods

Returns total family benefit before reduction for age or family maximum.

C++
double getTotalFullBenefit() const;
Collapse Expand Returns

Total family benefit before reduction for age or family maximum.

Collapse Expand Group

SecondaryArray Methods

Collapse Expand Links
SecondaryArray Class, SecondaryArray Members, SecondaryArray Methods


SecondaryArray::getTotalFullBenefitMax Method

SecondaryArray::getTotalFullBenefitMax Method
SecondaryArray Class SecondaryArray Members SecondaryArray Methods

Returns total family benefit before reduction for age or family maximum, excluding beneficiaries who are not affected by the maximum.

C++
double getTotalFullBenefitMax() const;
Collapse Expand Returns

Total family benefit before reduction for age or family maximum, excluding beneficiaries who are not affected by the maximum.

Collapse Expand Remarks

This is what is compared to the mfb to see if a reduction is required.

Collapse Expand Group

SecondaryArray Methods

Collapse Expand Links
SecondaryArray Class, SecondaryArray Members, SecondaryArray Methods


Sga Class

Sga Class
Sga Data Members Sga Methods Sga Members Sga.h Classes

Contains all of the SGA amounts and functions to use them.

Collapse Expand Class Hierarchy
  Sga
C++
class Sga;
Collapse Expand File

File: Sga.h

Module: PiaData Library

Collapse Expand Remarks

Contains all of the SGA amounts and functions to use them. Note that any users of this class should make sure to call the project function because the constructor only initializes the historical data.

Collapse Expand Group

Classes

Collapse Expand Links
Sga Data Members, Sga Methods, Sga Members, Sga.h, Classes


Sga Members

Sga Members
Sga Class Legend Public Data Members Public Methods

The following tables list the members exposed by Sga.

Collapse Expand Class

Sga Class

Collapse Expand Public Data Members
Name | Description
sgaBlindA | SGA annual amounts for the blind.
sgaBlindM | SGA monthly (December) amounts for the blind.
sgaMaxA | SGA annual maximum amounts for the non-blind.
sgaMaxM | SGA monthly (December) maximum amounts for the non-blind.
sgaMinA | SGA annual minimum amounts for the non-blind.
sgaMinM | SGA monthly (December) minimum amounts for the non-blind.
Collapse Expand Public Methods
Name | Description
Sga | Constructor.
project | Projects all SGA amounts.
Collapse Expand Links
Sga Class, Legend, Public Data Members, Public Methods


Sga::Sga Constructor

Sga::Sga Constructor
Sga Class Sga Members Sga Class

Constructor.

C++
Sga(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Last year allowed.
Collapse Expand Class

Sga Class

Collapse Expand Links
Sga Class, Sga Members, Sga Class


Sga Data Members

Sga Data Members
Sga Class Legend Public Data Members

The data members of the Sga class are listed here.

Collapse Expand Class

Sga Class

Collapse Expand Public Data Members
Name | Description
sgaBlindA | SGA annual amounts for the blind.
sgaBlindM | SGA monthly (December) amounts for the blind.
sgaMaxA | SGA annual maximum amounts for the non-blind.
sgaMaxM | SGA monthly (December) maximum amounts for the non-blind.
sgaMinA | SGA annual minimum amounts for the non-blind.
sgaMinM | SGA monthly (December) minimum amounts for the non-blind.
Collapse Expand Links
Sga Class, Legend, Public Data Members


Sga::sgaBlindA Data Member

Sga::sgaBlindA Data Member
Sga Class Sga Members Sga Data Members

SGA annual amounts for the blind.

C++
SgaBlindA sgaBlindA;
Collapse Expand Group

Sga Data Members

Collapse Expand Links
Sga Class, Sga Members, Sga Data Members


Sga::sgaBlindM Data Member

Sga::sgaBlindM Data Member
Sga Class Sga Members Sga Data Members

SGA monthly (December) amounts for the blind.

C++
SgaBlindM sgaBlindM;
Collapse Expand Group

Sga Data Members

Collapse Expand Links
Sga Class, Sga Members, Sga Data Members


Sga::sgaMaxA Data Member

Sga::sgaMaxA Data Member
Sga Class Sga Members Sga Data Members

SGA annual maximum amounts for the non-blind.

C++
SgaMaxA sgaMaxA;
Collapse Expand Group

Sga Data Members

Collapse Expand Links
Sga Class, Sga Members, Sga Data Members


Sga::sgaMaxM Data Member

Sga::sgaMaxM Data Member
Sga Class Sga Members Sga Data Members

SGA monthly (December) maximum amounts for the non-blind.

C++
SgaMaxM sgaMaxM;
Collapse Expand Group

Sga Data Members

Collapse Expand Links
Sga Class, Sga Members, Sga Data Members


Sga::sgaMinA Data Member

Sga::sgaMinA Data Member
Sga Class Sga Members Sga Data Members

SGA annual minimum amounts for the non-blind.

C++
SgaMinA sgaMinA;
Collapse Expand Group

Sga Data Members

Collapse Expand Links
Sga Class, Sga Members, Sga Data Members


Sga::sgaMinM Data Member

Sga::sgaMinM Data Member
Sga Class Sga Members Sga Data Members

SGA monthly (December) minimum amounts for the non-blind.

C++
SgaMinM sgaMinM;
Collapse Expand Group

Sga Data Members

Collapse Expand Links
Sga Class, Sga Members, Sga Data Members


Sga Methods

Sga Methods
Sga Class Legend Public Methods

The methods of the Sga class are listed here.

Collapse Expand Class

Sga Class

Collapse Expand Public Methods
Name | Description
project | Projects all SGA amounts.
Collapse Expand Links
Sga Class, Legend, Public Methods


Sga::project Method

Sga::project Method
Sga Class Sga Members Sga Methods

Projects all SGA amounts.

C++
void project(
    const DoubleAnnual& averageWages
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& averageWages | Average wages to use for projection.
Collapse Expand Group

Sga Methods

Collapse Expand Links
Sga Class, Sga Members, Sga Methods


SgaBlindA Class

SgaBlindA Class
SgaBlindA Methods SgaBlindA Members SgaDerived.h Classes

Manages the annual SGA amounts (historical and projected) for blind beneficiaries.

Collapse Expand Class Hierarchy
  SgaBlindASgaBlindASgaBlindA
C++
class SgaBlindA : public SgaGeneral;
Collapse Expand File

File: SgaDerived.h

Module: PiaData Library

Collapse Expand Remarks

There is no need to update the data in this class with each new TR. See notes in SgaGeneral as to when an update may be neccessary (and how to do it).

The monthly SGA amounts for blind beneficiaries are in SgaBlindM.

Collapse Expand See Also

SgaBlindM

Collapse Expand Group

Classes

Collapse Expand Links
SgaBlindA Methods, SgaBlindA Members, SgaDerived.h, Classes


SgaBlindA Members

SgaBlindA Members
SgaBlindA Class Legend Protected Data Members Protected Methods Public Data Members Public Friends Public Methods

The following tables list the members exposed by SgaBlindA.

Collapse Expand Class

SgaBlindA Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
FIRST_PROJ_YEAR | First year of projection (2001).
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
project1 | Calculates a monthly SGA amount using a base amount and a ratio of average wages.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
SgaBlindA | Constructor.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly SGA amounts to annual amounts, starting with the first projected year.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects SGA amounts.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
SgaBlindA Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Friends, Public Methods


SgaBlindA::SgaBlindA Constructor

SgaBlindA::SgaBlindA Constructor
SgaBlindA Class SgaBlindA Members SgaBlindA Class

Constructor.

C++
SgaBlindA(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | New last year.
Collapse Expand Remarks

Initializes data. Set all years up to (but not including) SgaGeneral::FIRST_PROJ_YEAR.

Collapse Expand Class

SgaBlindA Class

Collapse Expand Links
SgaBlindA Class, SgaBlindA Members, SgaBlindA Class


SgaBlindA Methods

SgaBlindA Methods
SgaBlindA Class Legend Public Methods

The methods of the SgaBlindA class are listed here.

Collapse Expand Class

SgaBlindA Class

Collapse Expand Public Methods
Name | Description
project | Projects SGA amounts.
Collapse Expand Links
SgaBlindA Class, Legend, Public Methods


SgaBlindA::project Method

SgaBlindA::project Method
SgaBlindA Class SgaBlindA Members SgaBlindA Methods

Projects SGA amounts.

C++
void project(
    const DoubleAnnual&
);
Collapse Expand Remarks

Should not be used because projections are for monthly amount, but this class deals with annual amounts.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_SGAPROJ (always).
Collapse Expand Group

SgaBlindA Methods

Collapse Expand Links
SgaBlindA Class, SgaBlindA Members, SgaBlindA Methods


SgaBlindM Class

SgaBlindM Class
SgaBlindM Members SgaDerived.h Classes

Manages the monthly SGA amounts (historical and projected) for blind beneficiaries (as of December).

Collapse Expand Class Hierarchy
  SgaBlindMSgaBlindMSgaBlindM
C++
class SgaBlindM : public SgaGeneral;
Collapse Expand File

File: SgaDerived.h

Module: PiaData Library

Collapse Expand Remarks

There is no need to update the data in this class with each new TR. See notes in SgaGeneral as to when an update may be neccessary (and how to do it).

The annual SGA amounts for blind beneficiaries are in SgaBlindA.

Collapse Expand See Also

SgaBlindA

Collapse Expand Group

Classes

Collapse Expand Links
SgaBlindM Members, SgaDerived.h, Classes


SgaBlindM Members

SgaBlindM Members
SgaBlindM Class Legend Protected Data Members Protected Methods Public Data Members Public Friends Public Methods

The following tables list the members exposed by SgaBlindM.

Collapse Expand Class

SgaBlindM Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
FIRST_PROJ_YEAR | First year of projection (2001).
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
project1 | Calculates a monthly SGA amount using a base amount and a ratio of average wages.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
SgaBlindM | Constructor. Initializes data.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly SGA amounts to annual amounts, starting with the first projected year.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects the SGA monthly amounts.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
SgaBlindM Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Friends, Public Methods


SgaBlindM::SgaBlindM Constructor

SgaBlindM::SgaBlindM Constructor
SgaBlindM Class SgaBlindM Members SgaBlindM Class

Constructor. Initializes data.

C++
SgaBlindM(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | New last year.
Collapse Expand Remarks

Set all years up to (but not including) SgaGeneral::FIRST_PROJ_YEAR.

Collapse Expand Class

SgaBlindM Class

Collapse Expand Links
SgaBlindM Class, SgaBlindM Members, SgaBlindM Class


SgaGeneral Class

SgaGeneral Class
SgaGeneral Data Members SgaGeneral Methods SgaGeneral Members SgaGeneral.h Classes

Parent of classes to manage the SGA (Substantial Gainful Activity) amounts (historical and projected).

Collapse Expand Class Hierarchy
  SgaGeneralSgaGeneral
C++
class SgaGeneral : public DoubleAnnual;
Collapse Expand File

File: SgaGeneral.h

Module: PiaData Library

Collapse Expand Remarks

Any users of this class should make sure to call the project function (for monthly projections) because the constructor only initializes the historical data.

The only thing here that might ever need to be updated is FIRST_PROJ_YEAR. This does not need to be updated for every TR. For example, in the 2005 TR, the FIRST_PROJ_YEAR could still be 2001, even thought 2001 is really an historical year. This is because the only information the projection needs is the updated Average Wage Series (which does get updated every year). Once the average wages are updated, the projections will work automatically.

So the only reason to change the FIRST_PROJ_YEAR would be if there was some change in the law that would not let the projections kick off from 2000 amounts. In such a case, make sure to:

1) Set FIRST_PROJ_YEAR correctly (in this file).

2) Go to the function SgaMinM::project in the file SgaDerived.cpp, and update the hard-coded number that over-writes the data value in year FIRST_PROJ_YEAR - 1. This number should match the max value for the corresponding year.

3) In the file SgaDerived.cpp, update all the calls to construct an SgaGeneral with the proper base years passed in (if they have changed).

4) In the file SgaDerived.cpp, update all the constructors which initialize data. They should make sure to initialize the data for all years up to (but not including) FIRST_PROJ_YEAR - 1.

Child classes are SgaBlindA, SgaBlindM, SgaMinA, SgaMinM, SgaMaxA, and SgaMaxM.

Collapse Expand See Also

SgaBlindA, SgaBlindM, SgaMinA, SgaMinM, SgaMaxA, SgaMaxM

Collapse Expand Group

Classes

Collapse Expand Links
SgaGeneral Data Members, SgaGeneral Methods, SgaGeneral Members, SgaGeneral.h, Classes


SgaGeneral Members

SgaGeneral Members
SgaGeneral Class Legend Protected Data Members Protected Methods Public Data Members Public Friends Public Methods

The following tables list the members exposed by SgaGeneral.

Collapse Expand Class

SgaGeneral Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
FIRST_PROJ_YEAR | First year of projection (2001).
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
project1 | Calculates a monthly SGA amount using a base amount and a ratio of average wages.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
SgaGeneral | Constructor.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly SGA amounts to annual amounts, starting with the first projected year.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects the SGA monthly amounts.
~SgaGeneral | Destructor.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
SgaGeneral Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Friends, Public Methods


SgaGeneral::SgaGeneral Constructor

SgaGeneral::SgaGeneral Constructor
SgaGeneral Class SgaGeneral Members SgaGeneral Class

Constructor.

C++
SgaGeneral(
    int newLastYear,
    int newBaseSgaYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | New last year.
int newBaseSgaYear | New year for base SGA amount for projections.
Collapse Expand Remarks

The SGA amounts start in 1961 and go through newLastYear.

Collapse Expand Class

SgaGeneral Class

Collapse Expand Links
SgaGeneral Class, SgaGeneral Members, SgaGeneral Class


SgaGeneral::~SgaGeneral Destructor

SgaGeneral::~SgaGeneral Destructor
SgaGeneral Class SgaGeneral Members SgaGeneral Class

Destructor.

C++
virtual ~SgaGeneral();
Collapse Expand Class

SgaGeneral Class

Collapse Expand Links
SgaGeneral Class, SgaGeneral Members, SgaGeneral Class


SgaGeneral Data Members

SgaGeneral Data Members
SgaGeneral Class Legend Protected Data Members

The data members of the SgaGeneral class are listed here.

Collapse Expand Class

SgaGeneral Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
FIRST_PROJ_YEAR | First year of projection (2001).
Collapse Expand Links
SgaGeneral Class, Legend, Protected Data Members


SgaGeneral::FIRST_PROJ_YEAR Data Member

SgaGeneral::FIRST_PROJ_YEAR Data Member
SgaGeneral Class SgaGeneral Members SgaGeneral Data Members

First year of projection (2001).

C++
const int FIRST_PROJ_YEAR = 2001;
Collapse Expand Group

SgaGeneral Data Members

Collapse Expand Links
SgaGeneral Class, SgaGeneral Members, SgaGeneral Data Members


SgaGeneral Methods

SgaGeneral Methods
SgaGeneral Class Legend Protected Methods Public Methods

The methods of the SgaGeneral class are listed here.

Collapse Expand Class

SgaGeneral Class

Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
project1 | Calculates a monthly SGA amount using a base amount and a ratio of average wages.
Collapse Expand Public Methods
Name | Description
convertMonthToAnnual | Converts monthly SGA amounts to annual amounts, starting with the first projected year.
project | Projects the SGA monthly amounts.
Collapse Expand Links
SgaGeneral Class, Legend, Protected Methods, Public Methods


SgaGeneral::convertMonthToAnnual Method

SgaGeneral::convertMonthToAnnual Method
SgaGeneral Class SgaGeneral Members SgaGeneral Methods

Converts monthly SGA amounts to annual amounts, starting with the first projected year.

C++
void convertMonthToAnnual(
    const SgaGeneral& sgaM
);
Collapse Expand Parameters
Parameters | Description
const SgaGeneral& sgaM | Monthly SGA amounts.
Collapse Expand Remarks

Historical amounts are initialized in the constructor of any derived class (because, for some years, the annual amount is not simply 12 times the monthly amount).

Collapse Expand Group

SgaGeneral Methods

Collapse Expand Links
SgaGeneral Class, SgaGeneral Members, SgaGeneral Methods


SgaGeneral::project Method

SgaGeneral::project Method
SgaGeneral Class SgaGeneral Members SgaGeneral Methods

Projects the SGA monthly amounts.

C++
virtual void project(
    const DoubleAnnual& averageWages
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& averageWages | Average wages to use for projection.
Collapse Expand Group

SgaGeneral Methods

Collapse Expand Links
SgaGeneral Class, SgaGeneral Members, SgaGeneral Methods


SgaGeneral::project1 Method

SgaGeneral::project1 Method
SgaGeneral Class SgaGeneral Members SgaGeneral Methods

Calculates a monthly SGA amount using a base amount and a ratio of average wages.

C++
static double project1(
    double baseAmount,
    double numerator,
    double denominator,
    double previous
);
Collapse Expand Parameters
Parameters | Description
double baseAmount | Value of SGA amount in base year.
double numerator | Numerator used in projection.
double denominator | Denominator used in projection.
double previous | Value of SGA amount in previous year.
Collapse Expand Returns

Increased monthly SGA amount.

Collapse Expand Group

SgaGeneral Methods

Collapse Expand Links
SgaGeneral Class, SgaGeneral Members, SgaGeneral Methods


SgaMaxA Class

SgaMaxA Class
SgaMaxA Methods SgaMaxA Members SgaDerived.h Classes

Manages the annual SGA maximum amounts(historical and projected) for non-blind beneficiaries.

Collapse Expand Class Hierarchy
  SgaMaxASgaMaxASgaMaxA
C++
class SgaMaxA : public SgaGeneral;
Collapse Expand File

File: SgaDerived.h

Module: PiaData Library

Collapse Expand Remarks

There is no need to update the data in this class with each new TR. See notes in SgaGeneral as to when an update may be neccessary (and how to do it).

The monthly SGA maximum amounts are in SgaMaxM.

Collapse Expand See Also

SgaMaxM

Collapse Expand Group

Classes

Collapse Expand Links
SgaMaxA Methods, SgaMaxA Members, SgaDerived.h, Classes


SgaMaxA Members

SgaMaxA Members
SgaMaxA Class Legend Protected Data Members Protected Methods Public Data Members Public Friends Public Methods

The following tables list the members exposed by SgaMaxA.

Collapse Expand Class

SgaMaxA Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
FIRST_PROJ_YEAR | First year of projection (2001).
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
project1 | Calculates a monthly SGA amount using a base amount and a ratio of average wages.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
SgaMaxA | Constructor. Initializes data.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly SGA amounts to annual amounts, starting with the first projected year.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects SGA amounts.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
SgaMaxA Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Friends, Public Methods


SgaMaxA::SgaMaxA Constructor

SgaMaxA::SgaMaxA Constructor
SgaMaxA Class SgaMaxA Members SgaMaxA Class

Constructor. Initializes data.

C++
SgaMaxA(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | New last year.
Collapse Expand Remarks

Set all years up to (but not including) SgaGeneral::FIRST_PROJ_YEAR.

Collapse Expand Class

SgaMaxA Class

Collapse Expand Links
SgaMaxA Class, SgaMaxA Members, SgaMaxA Class


SgaMaxA Methods

SgaMaxA Methods
SgaMaxA Class Legend Public Methods

The methods of the SgaMaxA class are listed here.

Collapse Expand Class

SgaMaxA Class

Collapse Expand Public Methods
Name | Description
project | Projects SGA amounts.
Collapse Expand Links
SgaMaxA Class, Legend, Public Methods


SgaMaxA::project Method

SgaMaxA::project Method
SgaMaxA Class SgaMaxA Members SgaMaxA Methods

Projects SGA amounts.

C++
void project(
    const DoubleAnnual&
);
Collapse Expand Remarks

Should not be used because projections are for monthly amount, but this class deals with annual amounts.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_SGAPROJ (always).
Collapse Expand Group

SgaMaxA Methods

Collapse Expand Links
SgaMaxA Class, SgaMaxA Members, SgaMaxA Methods


SgaMaxM Class

SgaMaxM Class
SgaMaxM Members SgaDerived.h Classes

Manages the monthly SGA maximum amounts (historical and projected) for non-blind beneficiaries (as of December).

Collapse Expand Class Hierarchy
  SgaMaxMSgaMaxMSgaMaxM
C++
class SgaMaxM : public SgaGeneral;
Collapse Expand File

File: SgaDerived.h

Module: PiaData Library

Collapse Expand Remarks

There is no need to update the data in this class with each new TR. See notes in SgaGeneral as to when an update may be neccessary (and how to do it).

The annual SGA maximum amounts are in SgaMaxA.

Collapse Expand See Also

SgaMaxA

Collapse Expand Group

Classes

Collapse Expand Links
SgaMaxM Members, SgaDerived.h, Classes


SgaMaxM Members

SgaMaxM Members
SgaMaxM Class Legend Protected Data Members Protected Methods Public Data Members Public Friends Public Methods

The following tables list the members exposed by SgaMaxM.

Collapse Expand Class

SgaMaxM Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
FIRST_PROJ_YEAR | First year of projection (2001).
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
project1 | Calculates a monthly SGA amount using a base amount and a ratio of average wages.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
SgaMaxM | Constructor. Initializes data.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly SGA amounts to annual amounts, starting with the first projected year.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects the SGA monthly amounts.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
SgaMaxM Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Friends, Public Methods


SgaMaxM::SgaMaxM Constructor

SgaMaxM::SgaMaxM Constructor
SgaMaxM Class SgaMaxM Members SgaMaxM Class

Constructor. Initializes data.

C++
SgaMaxM(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | New last year.
Collapse Expand Remarks

Set all years up to (but not including) SgaGeneral::FIRST_PROJ_YEAR.

Collapse Expand Class

SgaMaxM Class

Collapse Expand Links
SgaMaxM Class, SgaMaxM Members, SgaMaxM Class


SgaMinA Class

SgaMinA Class
SgaMinA Methods SgaMinA Members SgaDerived.h Classes

Manages the annual SGA minimum amounts (historical and projected) for non-blind beneficiaries.

Collapse Expand Class Hierarchy
  SgaMinASgaMinASgaMinA
C++
class SgaMinA : public SgaGeneral;
Collapse Expand File

File: SgaDerived.h

Module: PiaData Library

Collapse Expand Remarks

There is no need to update the data in this class with each new TR. See notes in SgaGeneral as to when an update may be neccessary (and how to do it).

The monthly SGA minimum amounts are in SgaMinM.

Collapse Expand See Also

SgaMinM

Collapse Expand Group

Classes

Collapse Expand Links
SgaMinA Methods, SgaMinA Members, SgaDerived.h, Classes


SgaMinA Members

SgaMinA Members
SgaMinA Class Legend Protected Data Members Protected Methods Public Data Members Public Friends Public Methods

The following tables list the members exposed by SgaMinA.

Collapse Expand Class

SgaMinA Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
FIRST_PROJ_YEAR | First year of projection (2001).
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
project1 | Calculates a monthly SGA amount using a base amount and a ratio of average wages.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
SgaMinA | Constructor. Initializes data.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly SGA amounts to annual amounts, starting with the first projected year.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects SGA amounts.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
SgaMinA Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Friends, Public Methods


SgaMinA::SgaMinA Constructor

SgaMinA::SgaMinA Constructor
SgaMinA Class SgaMinA Members SgaMinA Class

Constructor. Initializes data.

C++
SgaMinA(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | New last year.
Collapse Expand Remarks

Set all years up to (but not including) SgaGeneral::FIRST_PROJ_YEAR.

Collapse Expand Class

SgaMinA Class

Collapse Expand Links
SgaMinA Class, SgaMinA Members, SgaMinA Class


SgaMinA Methods

SgaMinA Methods
SgaMinA Class Legend Public Methods

The methods of the SgaMinA class are listed here.

Collapse Expand Class

SgaMinA Class

Collapse Expand Public Methods
Name | Description
project | Projects SGA amounts.
Collapse Expand Links
SgaMinA Class, Legend, Public Methods


SgaMinA::project Method

SgaMinA::project Method
SgaMinA Class SgaMinA Members SgaMinA Methods

Projects SGA amounts.

C++
void project(
    const DoubleAnnual&
);
Collapse Expand Remarks

Should not be used because projections are for monthly amount, but this class deals with annual amounts.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_SGAPROJ (always).
Collapse Expand Group

SgaMinA Methods

Collapse Expand Links
SgaMinA Class, SgaMinA Members, SgaMinA Methods


SgaMinM Class

SgaMinM Class
SgaMinM Methods SgaMinM Members SgaDerived.h Classes

Manages the monthly SGA minimum amounts (historical and projected) for non-blind beneficiaries (as of December).

Collapse Expand Class Hierarchy
  SgaMinMSgaMinMSgaMinM
C++
class SgaMinM : public SgaGeneral;
Collapse Expand File

File: SgaDerived.h

Module: PiaData Library

Collapse Expand Remarks

There is no need to update the data in this class with each new TR. See notes in SgaGeneral as to when an update may be neccessary (and how to do it).

The annual SGA minimum amounts are in SgaMinA.

Collapse Expand See Also

SgaMinA

Collapse Expand Group

Classes

Collapse Expand Links
SgaMinM Methods, SgaMinM Members, SgaDerived.h, Classes


SgaMinM Members

SgaMinM Members
SgaMinM Class Legend Protected Data Members Protected Methods Public Data Members Public Friends Public Methods

The following tables list the members exposed by SgaMinM.

Collapse Expand Class

SgaMinM Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
FIRST_PROJ_YEAR | First year of projection (2001).
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
project1 | Calculates a monthly SGA amount using a base amount and a ratio of average wages.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
SgaMinM | Constructor. Initializes data.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly SGA amounts to annual amounts, starting with the first projected year.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects SGA amounts.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
SgaMinM Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Friends, Public Methods


SgaMinM::SgaMinM Constructor

SgaMinM::SgaMinM Constructor
SgaMinM Class SgaMinM Members SgaMinM Class

Constructor. Initializes data.

C++
SgaMinM(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | New last year.
Collapse Expand Remarks

Set all years up to (but not including) SgaGeneral::FIRST_PROJ_YEAR.

Collapse Expand Class

SgaMinM Class

Collapse Expand Links
SgaMinM Class, SgaMinM Members, SgaMinM Class


SgaMinM Methods

SgaMinM Methods
SgaMinM Class Legend Public Methods

The methods of the SgaMinM class are listed here.

Collapse Expand Class

SgaMinM Class

Collapse Expand Public Methods
Name | Description
project | Projects SGA amounts.
Collapse Expand Links
SgaMinM Class, Legend, Public Methods


SgaMinM::project Method

SgaMinM::project Method
SgaMinM Class SgaMinM Members SgaMinM Methods

Projects SGA amounts.

C++
void project(
    const DoubleAnnual& averageWages
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& averageWages | Average wages to use for projection.
Collapse Expand Remarks

Starting in SgaGeneral::FIRST_PROJ_YEAR, there is no more min amount in use. So we'll set the min to be the same as the max for the projections. In order to duplicate the max projected values, we need to temporarily set the SgaGeneral::FIRST_PROJ_YEAR - 1 min amount to be the same as the max amount for that year and then start the projection. Afterwards we're done with the projection, reset it to its real value.

Collapse Expand Group

SgaMinM Methods

Collapse Expand Links
SgaMinM Class, SgaMinM Members, SgaMinM Methods


SpecMin Class

SpecMin Class
SpecMin Methods SpecMin Members SpecMin.h Classes

Manages the functions required for calculation of a special minimum Social Security benefit.

Collapse Expand Class Hierarchy
  SpecMinSpecMinSpecMin
C++
class SpecMin : public OldPia;
Collapse Expand File

File: SpecMin.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaCalPL.

Collapse Expand See Also

PiaCalPL

Collapse Expand Group

Classes

Collapse Expand Links
SpecMin Methods, SpecMin Members, SpecMin.h, Classes


SpecMin Members

SpecMin Members
Enumerations SpecMin Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by SpecMin.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

SpecMin Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
iamemax | Maximum ame in pia interval.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
SpecMin | Initializes this instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Computes special minimum PIA.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getSpecMinAmount | Returns special minimum dollar amount per year of coverage.
getSpecMinYearsExcess | Returns number of years of coverage in special minimum in excess of 10, up to 30.
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setSpecMinAmount | Sets special minimum dollar amount per year of coverage.
setSpecMinYearsExcess | Sets number of years of coverage in special minimum in excess of 10, up to 30.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsExcessCal | Limits usable years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~SpecMin | Destructor.
Collapse Expand Links
Enumerations, SpecMin Class, Legend, Protected Data Members, Public Data Members, Public Methods


SpecMin::SpecMin Constructor

SpecMin::SpecMin Constructor
SpecMin Class SpecMin Members SpecMin Class

Initializes this instance.

C++
SpecMin(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker basic data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
Collapse Expand Remarks

Initializes the member variables to 0, then calls initialize.

Collapse Expand Class

SpecMin Class

Collapse Expand Links
SpecMin Class, SpecMin Members, SpecMin Class


SpecMin::~SpecMin Destructor

SpecMin::~SpecMin Destructor
SpecMin Class SpecMin Members SpecMin Class

Destructor.

C++
virtual ~SpecMin();
Collapse Expand Class

SpecMin Class

Collapse Expand Links
SpecMin Class, SpecMin Members, SpecMin Class


SpecMin Methods

SpecMin Methods
SpecMin Class Legend Public Methods

The methods of the SpecMin class are listed here.

Collapse Expand Class

SpecMin Class

Collapse Expand Public Methods
Name | Description
calculate | Computes special minimum PIA.
getSpecMinAmount | Returns special minimum dollar amount per year of coverage.
getSpecMinYearsExcess | Returns number of years of coverage in special minimum in excess of 10, up to 30.
getYearsTotal | Returns number of years of coverage.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
setSpecMinAmount | Sets special minimum dollar amount per year of coverage.
setSpecMinYearsExcess | Sets number of years of coverage in special minimum in excess of 10, up to 30.
specMinYearsExcessCal | Limits usable years of coverage.
Collapse Expand Links
SpecMin Class, Legend, Public Methods


SpecMin::calculate Method

SpecMin::calculate Method
SpecMin Class SpecMin Members SpecMin Methods

Computes special minimum PIA.

C++
void calculate();
Collapse Expand Remarks

Finds years of coverage by calling PiaMethod::specMinYearsTotalCal. Finds the amount per year of coverage by calling PiaParams::specMinAmountCal. Limits the usable years of coverage by calling specMinYearsExcessCal.

Collapse Expand Group

SpecMin Methods

Collapse Expand Links
SpecMin Class, SpecMin Members, SpecMin Methods


SpecMin::getSpecMinAmount Method

SpecMin::getSpecMinAmount Method
SpecMin Class SpecMin Members SpecMin Methods

Returns special minimum dollar amount per year of coverage.

C++
double getSpecMinAmount() const;
Collapse Expand Returns

Special minimum dollar amount per year of coverage.

Collapse Expand Group

SpecMin Methods

Collapse Expand Links
SpecMin Class, SpecMin Members, SpecMin Methods


SpecMin::getSpecMinYearsExcess Method

SpecMin::getSpecMinYearsExcess Method
SpecMin Class SpecMin Members SpecMin Methods

Returns number of years of coverage in special minimum in excess of 10, up to 30.

C++
int getSpecMinYearsExcess() const;
Collapse Expand Returns

Number of years of coverage in special minimum in excess of 10, up to 30.

Collapse Expand Group

SpecMin Methods

Collapse Expand Links
SpecMin Class, SpecMin Members, SpecMin Methods


SpecMin::getYearsTotal Method

SpecMin::getYearsTotal Method
SpecMin Class SpecMin Members SpecMin Methods

Returns number of years of coverage.

C++
int getYearsTotal() const;
Collapse Expand Returns

Number of years of coverage.

Collapse Expand Group

SpecMin Methods

Collapse Expand Links
SpecMin Class, SpecMin Members, SpecMin Methods


SpecMin::initialize Method

SpecMin::initialize Method
SpecMin Class SpecMin Members SpecMin Methods

Initializes computed values to zero.

C++
void initialize();
Collapse Expand Group

SpecMin Methods

Collapse Expand Links
SpecMin Class, SpecMin Members, SpecMin Methods


isApplicable Method

isApplicable Method
SpecMin Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of the isApplicable function. The one with no arguments uses stored values to determine the method applicability; the static version with 1 argument uses passed values to determine the method applicability.

Collapse Expand Overload List
Name | Description
SpecMin::isApplicable () | Determines applicability of method, using stored values.
SpecMin::isApplicable (const WorkerDataGeneral&) | Determines applicability of method, using passed values.
Collapse Expand Group

SpecMin Methods

Collapse Expand Links
SpecMin Methods


SpecMin::isApplicable Method ()

SpecMin::isApplicable Method ()
SpecMin Class SpecMin Members isApplicable Method

Determines applicability of method, using stored values.

C++
bool isApplicable();
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

To be applicable, the benefit date must be at least PiaParams::amend722 (January 1973), and it cannot be a totalization benefit.

This version calls the static version with 1 argument.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
SpecMin Class, SpecMin Members, isApplicable Method


SpecMin::isApplicable Method (const WorkerDataGeneral&)

SpecMin::isApplicable Method (const WorkerDataGeneral&)
SpecMin Class SpecMin Members isApplicable Method

Determines applicability of method, using passed values.

C++
static bool isApplicable(
    const WorkerDataGeneral& workerData
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker basic data.
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

To be applicable, the benefit date must be at least PiaParams::amend722 (January 1973), and it cannot be a totalization benefit.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
SpecMin Class, SpecMin Members, isApplicable Method


SpecMin::setSpecMinAmount Method

SpecMin::setSpecMinAmount Method
SpecMin Class SpecMin Members SpecMin Methods

Sets special minimum dollar amount per year of coverage.

C++
void setSpecMinAmount(
    double newAmount
);
Collapse Expand Parameters
Parameters | Description
double newAmount | New dollar amount per year of coverage.
Collapse Expand Group

SpecMin Methods

Collapse Expand Links
SpecMin Class, SpecMin Members, SpecMin Methods


SpecMin::setSpecMinYearsExcess Method

SpecMin::setSpecMinYearsExcess Method
SpecMin Class SpecMin Members SpecMin Methods

Sets number of years of coverage in special minimum in excess of 10, up to 30.

C++
void setSpecMinYearsExcess(
    int newYears
);
Collapse Expand Parameters
Parameters | Description
int newYears | New number of years of coverage.
Collapse Expand Group

SpecMin Methods

Collapse Expand Links
SpecMin Class, SpecMin Members, SpecMin Methods


SpecMin::specMinYearsExcessCal Method

SpecMin::specMinYearsExcessCal Method
SpecMin Class SpecMin Members SpecMin Methods

Limits usable years of coverage.

C++
virtual int specMinYearsExcessCal() const;
Collapse Expand Returns

Usable years of coverage (in excess of 10, up to 20).

Collapse Expand Group

SpecMin Methods

Collapse Expand Links
SpecMin Class, SpecMin Members, SpecMin Methods


SpecMinLC Class

SpecMinLC Class
SpecMinLC Methods SpecMinLC Members SpecMinLC.h Classes

Manages the functions required for calculation of a special minimum Social Security benefit, including changes from present law.

Collapse Expand Class Hierarchy
  SpecMinLCSpecMinLCSpecMinLCSpecMinLC
C++
class SpecMinLC : public SpecMin;
Collapse Expand File

File: SpecMinLC.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaCalLC.

Collapse Expand See Also

PiaCalLC

Collapse Expand Group

Classes

Collapse Expand Links
SpecMinLC Methods, SpecMinLC Members, SpecMinLC.h, Classes


SpecMinLC Members

SpecMinLC Members
Enumerations SpecMinLC Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by SpecMinLC.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

SpecMinLC Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
iamemax | Maximum ame in pia interval.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
SpecMinLC | Initializes all fields.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Calculates pia and mfb for this method.
calculate | Computes special minimum PIA.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getSpecMinAmount | Returns special minimum dollar amount per year of coverage.
getSpecMinYearsExcess | Returns number of years of coverage in special minimum in excess of 10, up to 30.
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getYearsTotal | Returns number of years of coverage.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setSpecMinAmount | Sets special minimum dollar amount per year of coverage.
setSpecMinYearsExcess | Sets number of years of coverage in special minimum in excess of 10, up to 30.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsExcessCal | Limits usable years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~SpecMinLC | Destructor.
Collapse Expand Links
Enumerations, SpecMinLC Class, Legend, Protected Data Members, Public Data Members, Public Methods


SpecMinLC::SpecMinLC Constructor

SpecMinLC::SpecMinLC Constructor
SpecMinLC Class SpecMinLC Members SpecMinLC Class

Initializes all fields.

C++
SpecMinLC(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear,
    const LawChangeArray& newLawChange
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker basic data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
const LawChangeArray& newLawChange | Law-change parameters.
Collapse Expand Class

SpecMinLC Class

Collapse Expand Links
SpecMinLC Class, SpecMinLC Members, SpecMinLC Class


SpecMinLC::~SpecMinLC Destructor

SpecMinLC::~SpecMinLC Destructor
SpecMinLC Class SpecMinLC Members SpecMinLC Class

Destructor.

C++
~SpecMinLC();
Collapse Expand Class

SpecMinLC Class

Collapse Expand Links
SpecMinLC Class, SpecMinLC Members, SpecMinLC Class


SpecMinLC Methods

SpecMinLC Methods
SpecMinLC Class Legend Public Methods

The methods of the SpecMinLC class are listed here.

Collapse Expand Class

SpecMinLC Class

Collapse Expand Public Methods
Name | Description
isApplicable | Determines applicability of method.
specMinYearsExcessCal | Limits usable years of coverage.
Collapse Expand Links
SpecMinLC Class, Legend, Public Methods


isApplicable Method

isApplicable Method
SpecMinLC Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of this function. The version with no arguments uses stored data, passing it to the static version with two arguments.

Collapse Expand Overload List
Name | Description
SpecMinLC::isApplicable () | Determines applicability of method using stored data.
SpecMinLC::isApplicable (const WorkerDataGeneral&, const LawChangeArray&) | Determines applicability of method using passed data.
Collapse Expand Group

SpecMinLC Methods

Collapse Expand Links
SpecMinLC Methods


SpecMinLC::isApplicable Method ()

SpecMinLC::isApplicable Method ()
SpecMinLC Class SpecMinLC Members isApplicable Method

Determines applicability of method using stored data.

C++
bool isApplicable();
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

This version calls the static version with 2 arguments.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
SpecMinLC Class, SpecMinLC Members, isApplicable Method


SpecMinLC::isApplicable Method (const WorkerDataGeneral&, const LawChangeArray&)

SpecMinLC::isApplicable Method (const WorkerDataGeneral&, const LawChangeArray&)
SpecMinLC Class SpecMinLC Members isApplicable Method

Determines applicability of method using passed data.

C++
static bool isApplicable(
    const WorkerDataGeneral& workerData,
    const LawChangeArray&
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker basic data.
LawChangeArray | Law Change parameters.
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

This version simply returns the applicability determined under present law.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
SpecMinLC Class, SpecMinLC Members, isApplicable Method


SpecMinLC::specMinYearsExcessCal Method

SpecMinLC::specMinYearsExcessCal Method
SpecMinLC Class SpecMinLC Members SpecMinLC Methods

Limits usable years of coverage.

C++
int specMinYearsExcessCal() const;
Collapse Expand Returns

Usable years of coverage (in excess of 10, up to 20, or however changed by law change).

Collapse Expand Group

SpecMinLC Methods

Collapse Expand Links
SpecMinLC Class, SpecMinLC Members, SpecMinLC Methods


TaxBenefits Class

TaxBenefits Class
TaxBenefits Data Members TaxBenefits Methods TaxBenefits Members TaxBenefits.h Classes

Contains the functions required to calculate the tax on a Social Security benefit.

Collapse Expand Class Hierarchy
  TaxBenefits
C++
class TaxBenefits;
Collapse Expand File

File: TaxBenefits.h

Module: PiaData Library

Collapse Expand Remarks

Contains the functions required to calculate the tax on a Social Security benefit.

Collapse Expand Group

Classes

Collapse Expand Links
TaxBenefits Data Members, TaxBenefits Methods, TaxBenefits Members, TaxBenefits.h, Classes


TaxBenefits Members

TaxBenefits Members
TaxBenefits Class Legend Public Data Members Public Methods

The following tables list the members exposed by TaxBenefits.

Collapse Expand Class

TaxBenefits Class

Collapse Expand Public Data Members
Name | Description
HiYear | The year that the OASDHI tax became effective.
MARRIEDOASDHITAX | OASDHI tax for married taxpayers in first tier.
MARRIEDOASDHITHRESHOLD | OASDHI threshold for married taxpayers.
MARRIEDOASDITHRESHOLD | OASDI threshold for married taxpayers.
OasdhiRate | The OASDHI tax rate.
OasdiRate | The OASDI tax rate.
SINGLEOASDHITAX | OASDHI tax for single taxpayers in first tier.
SINGLEOASDHITHRESHOLD | OASDHI threshold for single taxpayers.
SINGLEOASDITHRESHOLD | OASDI threshold for single taxpayers.
START_YEAR | Starting year of tax on Social Security benefits.
Collapse Expand Public Methods
Name | Description
TaxBenefits | Initializes an instance.
deductionsCal | Returns the amount of deductions allowed under the Ball taxation plan.
getProportion | Returns proportion of benefits that are taxable for OASDI.
getThreshold | Returns appropriate OASDI threshold.
taxOasdhi | Returns taxable benefits for OASDHI trust funds.
taxOasdi | Returns taxable benefits for OASDI trust funds.
~TaxBenefits | Destructor.
Collapse Expand Links
TaxBenefits Class, Legend, Public Data Members, Public Methods


TaxBenefits::TaxBenefits Constructor

TaxBenefits::TaxBenefits Constructor
TaxBenefits Class TaxBenefits Members TaxBenefits Class

Initializes an instance.

C++
TaxBenefits();
Collapse Expand Class

TaxBenefits Class

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Class


TaxBenefits::~TaxBenefits Destructor

TaxBenefits::~TaxBenefits Destructor
TaxBenefits Class TaxBenefits Members TaxBenefits Class

Destructor.

C++
virtual ~TaxBenefits();
Collapse Expand Class

TaxBenefits Class

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Class


TaxBenefits Data Members

TaxBenefits Data Members
TaxBenefits Class Legend Public Data Members

The data members of the TaxBenefits class are listed here.

Collapse Expand Class

TaxBenefits Class

Collapse Expand Public Data Members
Name | Description
HiYear | The year that the OASDHI tax became effective.
MARRIEDOASDHITAX | OASDHI tax for married taxpayers in first tier.
MARRIEDOASDHITHRESHOLD | OASDHI threshold for married taxpayers.
MARRIEDOASDITHRESHOLD | OASDI threshold for married taxpayers.
OasdhiRate | The OASDHI tax rate.
OasdiRate | The OASDI tax rate.
SINGLEOASDHITAX | OASDHI tax for single taxpayers in first tier.
SINGLEOASDHITHRESHOLD | OASDHI threshold for single taxpayers.
SINGLEOASDITHRESHOLD | OASDI threshold for single taxpayers.
START_YEAR | Starting year of tax on Social Security benefits.
Collapse Expand Links
TaxBenefits Class, Legend, Public Data Members


TaxBenefits::HiYear Data Member

TaxBenefits::HiYear Data Member
TaxBenefits Class TaxBenefits Members TaxBenefits Data Members

The year that the OASDHI tax became effective.

C++
const int HiYear = 1994;
Collapse Expand Group

TaxBenefits Data Members

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Data Members


TaxBenefits::MARRIEDOASDHITAX Data Member

TaxBenefits::MARRIEDOASDHITAX Data Member
TaxBenefits Class TaxBenefits Members TaxBenefits Data Members

OASDHI tax for married taxpayers in first tier.

C++
const double MARRIEDOASDHITAX;
Collapse Expand Group

TaxBenefits Data Members

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Data Members


TaxBenefits::MARRIEDOASDHITHRESHOLD Data Member

TaxBenefits::MARRIEDOASDHITHRESHOLD Data Member
TaxBenefits Class TaxBenefits Members TaxBenefits Data Members

OASDHI threshold for married taxpayers.

C++
const double MARRIEDOASDHITHRESHOLD;
Collapse Expand Group

TaxBenefits Data Members

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Data Members


TaxBenefits::MARRIEDOASDITHRESHOLD Data Member

TaxBenefits::MARRIEDOASDITHRESHOLD Data Member
TaxBenefits Class TaxBenefits Members TaxBenefits Data Members

OASDI threshold for married taxpayers.

C++
const double MARRIEDOASDITHRESHOLD;
Collapse Expand Group

TaxBenefits Data Members

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Data Members


TaxBenefits::OasdhiRate Data Member

TaxBenefits::OasdhiRate Data Member
TaxBenefits Class TaxBenefits Members TaxBenefits Data Members

The OASDHI tax rate.

C++
const double OasdhiRate;
Collapse Expand Group

TaxBenefits Data Members

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Data Members


TaxBenefits::OasdiRate Data Member

TaxBenefits::OasdiRate Data Member
TaxBenefits Class TaxBenefits Members TaxBenefits Data Members

The OASDI tax rate.

C++
const double OasdiRate;
Collapse Expand Group

TaxBenefits Data Members

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Data Members


TaxBenefits::SINGLEOASDHITAX Data Member

TaxBenefits::SINGLEOASDHITAX Data Member
TaxBenefits Class TaxBenefits Members TaxBenefits Data Members

OASDHI tax for single taxpayers in first tier.

C++
const double SINGLEOASDHITAX;
Collapse Expand Group

TaxBenefits Data Members

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Data Members


TaxBenefits::SINGLEOASDHITHRESHOLD Data Member

TaxBenefits::SINGLEOASDHITHRESHOLD Data Member
TaxBenefits Class TaxBenefits Members TaxBenefits Data Members

OASDHI threshold for single taxpayers.

C++
const double SINGLEOASDHITHRESHOLD;
Collapse Expand Group

TaxBenefits Data Members

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Data Members


TaxBenefits::SINGLEOASDITHRESHOLD Data Member

TaxBenefits::SINGLEOASDITHRESHOLD Data Member
TaxBenefits Class TaxBenefits Members TaxBenefits Data Members

OASDI threshold for single taxpayers.

C++
const double SINGLEOASDITHRESHOLD;
Collapse Expand Group

TaxBenefits Data Members

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Data Members


TaxBenefits::START_YEAR Data Member

TaxBenefits::START_YEAR Data Member
TaxBenefits Class TaxBenefits Members TaxBenefits Data Members

Starting year of tax on Social Security benefits.

C++
const int START_YEAR = 1984;
Collapse Expand Group

TaxBenefits Data Members

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Data Members


TaxBenefits Methods

TaxBenefits Methods
TaxBenefits Class Legend Public Methods

The methods of the TaxBenefits class are listed here.

Collapse Expand Class

TaxBenefits Class

Collapse Expand Public Methods
Name | Description
deductionsCal | Returns the amount of deductions allowed under the Ball taxation plan.
getProportion | Returns proportion of benefits that are taxable for OASDI.
getThreshold | Returns appropriate OASDI threshold.
taxOasdhi | Returns taxable benefits for OASDHI trust funds.
taxOasdi | Returns taxable benefits for OASDI trust funds.
Collapse Expand Links
TaxBenefits Class, Legend, Public Methods


TaxBenefits::deductionsCal Method

TaxBenefits::deductionsCal Method
TaxBenefits Class TaxBenefits Members TaxBenefits Methods

Returns the amount of deductions allowed under the Ball taxation plan.

C++
virtual double deductionsCal(
    unsigned,
    double,
    double,
    int
) const;
Collapse Expand Returns

Zero for present law.

Collapse Expand Group

TaxBenefits Methods

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Methods


TaxBenefits::getProportion Method

TaxBenefits::getProportion Method
TaxBenefits Class TaxBenefits Members TaxBenefits Methods

Returns proportion of benefits that are taxable for OASDI.

C++
virtual double getProportion(
    int
) const;
Collapse Expand Returns

0.5 for present law.

Collapse Expand Group

TaxBenefits Methods

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Methods


TaxBenefits::getThreshold Method

TaxBenefits::getThreshold Method
TaxBenefits Class TaxBenefits Members TaxBenefits Methods

Returns appropriate OASDI threshold.

C++
virtual double getThreshold(
    bool married,
    int
) const;
Collapse Expand Parameters
Parameters | Description
bool married | True if married filing jointly.
Collapse Expand Returns

Appropriate OASDI threshold.

Collapse Expand Group

TaxBenefits Methods

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Methods


TaxBenefits::taxOasdhi Method

TaxBenefits::taxOasdhi Method
TaxBenefits Class TaxBenefits Members TaxBenefits Methods

Returns taxable benefits for OASDHI trust funds.

C++
virtual double taxOasdhi(
    int year,
    double magi,
    double benefits,
    bool married
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which benefits are being taxed.
double magi | Modified adjusted gross income (excluding benefits).
double benefits | Social Security benefits (including spouse's benefits, if married, reduced by deduction for contributions).
bool married | True if married filing jointly.
Collapse Expand Returns

Taxable benefits for OASDHI trust funds.

Collapse Expand Group

TaxBenefits Methods

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Methods


TaxBenefits::taxOasdi Method

TaxBenefits::taxOasdi Method
TaxBenefits Class TaxBenefits Members TaxBenefits Methods

Returns taxable benefits for OASDI trust funds.

C++
double taxOasdi(
    int year,
    double magi,
    double benefits,
    bool married
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which benefits are being taxed.
double magi | Modified adjusted gross income (excluding benefits).
double benefits | Social Security benefits (including spouse's benefits, if married). Should be reduced by deduction for contributions, if applicable.
bool married | True if married filing jointly.
Collapse Expand Returns

Taxable benefits for OASDI trust funds.

Collapse Expand Group

TaxBenefits Methods

Collapse Expand Links
TaxBenefits Class, TaxBenefits Members, TaxBenefits Methods


TaxBenefitsLC Class

TaxBenefitsLC Class
TaxBenefitsLC Methods TaxBenefitsLC Members TaxBenefitsLC.h Classes

Contains the functions required to calculate the tax on a Social Security benefit with law changes.

Collapse Expand Class Hierarchy
  TaxBenefitsLCTaxBenefitsLC
C++
class TaxBenefitsLC : public TaxBenefits;
Collapse Expand File

File: TaxBenefitsLC.h

Module: PiaData Library

Collapse Expand Remarks

Contains the functions required to calculate the tax on a Social Security benefit with law changes.

Collapse Expand Group

Classes

Collapse Expand Links
TaxBenefitsLC Methods, TaxBenefitsLC Members, TaxBenefitsLC.h, Classes


TaxBenefitsLC Members

TaxBenefitsLC Members
TaxBenefitsLC Class Legend Public Data Members Public Methods

The following tables list the members exposed by TaxBenefitsLC.

Collapse Expand Class

TaxBenefitsLC Class

Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
HiYear | The year that the OASDHI tax became effective.
MARRIEDOASDHITAX | OASDHI tax for married taxpayers in first tier.
MARRIEDOASDHITHRESHOLD | OASDHI threshold for married taxpayers.
MARRIEDOASDITHRESHOLD | OASDI threshold for married taxpayers.
OasdhiRate | The OASDHI tax rate.
OasdiRate | The OASDI tax rate.
SINGLEOASDHITAX | OASDHI tax for single taxpayers in first tier.
SINGLEOASDHITHRESHOLD | OASDHI threshold for single taxpayers.
SINGLEOASDITHRESHOLD | OASDI threshold for single taxpayers.
START_YEAR | Starting year of tax on Social Security benefits.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
TaxBenefitsLC | Initializes an instance.
deductionsCal | Returns the amount of deductions allowed under the Ball taxation plan.
getProportion | Returns proportion of benefits that are taxable for OASDI.
getThreshold | Returns appropriate threshold.
paymentsCal | Returns number of payments over which contributions are spread for Ball taxation plan.
taxOasdhi | Returns taxable benefits for OASDHI trust funds (same as taxable for OASDI for proposal to tax as for private pension plans).
taxOasdi | Returns taxable benefits for OASDI trust funds.
thresholdsCal | Fills in declining threshold amounts.
~TaxBenefitsLC | Destructor.
Collapse Expand Links
TaxBenefitsLC Class, Legend, Public Data Members, Public Methods


TaxBenefitsLC::TaxBenefitsLC Constructor

TaxBenefitsLC::TaxBenefitsLC Constructor
TaxBenefitsLC Class TaxBenefitsLC Members TaxBenefitsLC Class

Initializes an instance.

C++
TaxBenefitsLC(
    const LawChangeArray& newLawChange
);
Collapse Expand Parameters
Parameters | Description
const LawChangeArray& newLawChange | Law change data.
Collapse Expand Class

TaxBenefitsLC Class

Collapse Expand Links
TaxBenefitsLC Class, TaxBenefitsLC Members, TaxBenefitsLC Class


TaxBenefitsLC::~TaxBenefitsLC Destructor

TaxBenefitsLC::~TaxBenefitsLC Destructor
TaxBenefitsLC Class TaxBenefitsLC Members TaxBenefitsLC Class

Destructor.

C++
~TaxBenefitsLC();
Collapse Expand Class

TaxBenefitsLC Class

Collapse Expand Links
TaxBenefitsLC Class, TaxBenefitsLC Members, TaxBenefitsLC Class


TaxBenefitsLC Methods

TaxBenefitsLC Methods
TaxBenefitsLC Class Legend Public Methods

The methods of the TaxBenefitsLC class are listed here.

Collapse Expand Class

TaxBenefitsLC Class

Collapse Expand Public Methods
Name | Description
deductionsCal | Returns the amount of deductions allowed under the Ball taxation plan.
getProportion | Returns proportion of benefits that are taxable for OASDI.
getThreshold | Returns appropriate threshold.
paymentsCal | Returns number of payments over which contributions are spread for Ball taxation plan.
taxOasdhi | Returns taxable benefits for OASDHI trust funds (same as taxable for OASDI for proposal to tax as for private pension plans).
thresholdsCal | Fills in declining threshold amounts.
Collapse Expand Links
TaxBenefitsLC Class, Legend, Public Methods


TaxBenefitsLC::deductionsCal Method

TaxBenefitsLC::deductionsCal Method
TaxBenefitsLC Class TaxBenefitsLC Members TaxBenefitsLC Methods

Returns the amount of deductions allowed under the Ball taxation plan.

C++
double deductionsCal(
    unsigned startAge,
    double aggContribs,
    double taxRecovered,
    int year
) const;
Collapse Expand Parameters
Parameters | Description
unsigned startAge | Starting age of deductions.
double aggContribs | Aggregate contribution (no interest) over person's lifetime into OASDI trust funds through taxes.
double taxRecovered | Tax recovered through deductions.
int year | Year for which benefits are being taxed.
Collapse Expand Returns

Amount of deductions allowed under the Ball taxation plan.

Collapse Expand Group

TaxBenefitsLC Methods

Collapse Expand Links
TaxBenefitsLC Class, TaxBenefitsLC Members, TaxBenefitsLC Methods


TaxBenefitsLC::getProportion Method

TaxBenefitsLC::getProportion Method
TaxBenefitsLC Class TaxBenefitsLC Members TaxBenefitsLC Methods

Returns proportion of benefits that are taxable for OASDI.

C++
virtual double getProportion(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which benefits are being taxed.
Collapse Expand Returns

Proportion of benefits that are taxable for OASDI.

Collapse Expand Group

TaxBenefitsLC Methods

Collapse Expand Links
TaxBenefitsLC Class, TaxBenefitsLC Members, TaxBenefitsLC Methods


TaxBenefitsLC::getThreshold Method

TaxBenefitsLC::getThreshold Method
TaxBenefitsLC Class TaxBenefitsLC Members TaxBenefitsLC Methods

Returns appropriate threshold.

C++
double getThreshold(
    bool married,
    int year
) const;
Collapse Expand Parameters
Parameters | Description
bool married | True if married filing jointly.
int year | Year for which benefits are being taxed.
Collapse Expand Returns

Appropriate threshold.

Collapse Expand Group

TaxBenefitsLC Methods

Collapse Expand Links
TaxBenefitsLC Class, TaxBenefitsLC Members, TaxBenefitsLC Methods


TaxBenefitsLC::paymentsCal Method

TaxBenefitsLC::paymentsCal Method
TaxBenefitsLC Class TaxBenefitsLC Members TaxBenefitsLC Methods

Returns number of payments over which contributions are spread for Ball taxation plan.

C++
static int paymentsCal(
    unsigned age
);
Collapse Expand Parameters
Parameters | Description
unsigned age | The age of taxpayer.
Collapse Expand Returns

Number of payments over which contributions are spread for Ball taxation plan.

Collapse Expand Group

TaxBenefitsLC Methods

Collapse Expand Links
TaxBenefitsLC Class, TaxBenefitsLC Members, TaxBenefitsLC Methods


TaxBenefitsLC::taxOasdhi Method

TaxBenefitsLC::taxOasdhi Method
TaxBenefitsLC Class TaxBenefitsLC Members TaxBenefitsLC Methods

Returns taxable benefits for OASDHI trust funds (same as taxable for OASDI for proposal to tax as for private pension plans).

C++
double taxOasdhi(
    int year,
    double magi,
    double benefits,
    bool married
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which benefits are being taxed.
double magi | Modified adjusted gross income (excluding benefits).
double benefits | Social Security benefits (including spouse's benefits, if married, reduced by deduction for contributions).
bool married | True if married filing jointly.
Collapse Expand Returns

Taxable benefits for OASDHI trust funds.

Collapse Expand Group

TaxBenefitsLC Methods

Collapse Expand Links
TaxBenefitsLC Class, TaxBenefitsLC Members, TaxBenefitsLC Methods


TaxBenefitsLC::thresholdsCal Method

TaxBenefitsLC::thresholdsCal Method
TaxBenefitsLC Class TaxBenefitsLC Members TaxBenefitsLC Methods

Fills in declining threshold amounts.

C++
void thresholdsCal();
Collapse Expand Group

TaxBenefitsLC Methods

Collapse Expand Links
TaxBenefitsLC Class, TaxBenefitsLC Members, TaxBenefitsLC Methods


TaxData Class

TaxData Class
TaxData Enumerations TaxData Data Members TaxData Methods TaxData Members TaxData.h Classes

Manages the Social Security payroll and self-employed taxes paid by a worker.

Collapse Expand Class Hierarchy
  TaxData
C++
class TaxData;
Collapse Expand File

File: TaxData.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is used in the Anypia program.

Collapse Expand Group

Classes

Collapse Expand Links
TaxData Enumerations, TaxData Data Members, TaxData Methods, TaxData Members, TaxData.h, Classes


TaxData Members

TaxData Members
Enumerations TaxData Class Legend Public Data Members Public Methods

The following tables list the members exposed by TaxData.

Collapse Expand Enumerations
Name | Description
YEAR_GROUP | Dimension limits.
Collapse Expand Class

TaxData Class

Collapse Expand Public Data Members
Name | Description
taxesDi | DI taxes paid by year.
taxesHi | HI taxes paid by year.
taxesOasdhi | OASDHI taxes paid by year.
taxesOasdi | OASDI taxes paid by year.
taxesOasi | OASI taxes paid by year.
Collapse Expand Public Methods
Name | Description
TaxData | Initializes arrays.
getTaxesTotal | Returns total taxes paid for a trust fund type and a period of years.
oasdhiTaxCal | Calculates OASDI and OASDHI taxes paid over a lifetime.
totalTaxCal | Calculates total taxes paid over a lifetime.
~TaxData | Destroys this instance.
Collapse Expand Links
Enumerations, TaxData Class, Legend, Public Data Members, Public Methods


TaxData::TaxData Constructor

TaxData::TaxData Constructor
TaxData Class TaxData Members TaxData Class

Initializes arrays.

C++
TaxData(
    int lastYear
);
Collapse Expand Parameters
Parameters | Description
int lastYear | Maximum projected year.
Collapse Expand Class

TaxData Class

Collapse Expand Links
TaxData Class, TaxData Members, TaxData Class


TaxData::~TaxData Destructor

TaxData::~TaxData Destructor
TaxData Class TaxData Members TaxData Class

Destroys this instance.

C++
~TaxData();
Collapse Expand Class

TaxData Class

Collapse Expand Links
TaxData Class, TaxData Members, TaxData Class


TaxData Enumerations

TaxData Enumerations
Enumerations TaxData Class Legend

The enumerations of the TaxData class are listed here.

Collapse Expand Enumerations
Name | Description
YEAR_GROUP | Dimension limits.
Collapse Expand Class

TaxData Class

Collapse Expand Links
Enumerations, TaxData Class, Legend


TaxData::YEAR_GROUP Enumeration

TaxData::YEAR_GROUP Enumeration
TaxData.h TaxData Enumerations

Dimension limits.

C++
enum YEAR_GROUP {
  YEARS1937_50 = 0,
  YEARS1937PLUS,
  NUMYEARPERIODS
};
Collapse Expand File

File: TaxData.h

Module: PiaData Library

Collapse Expand Members
Members | Description
YEARS1937_50 = 0 | Years 1937 to 1950.
YEARS1937PLUS | All years starting with 1937.
NUMYEARPERIODS | Number of year periods.
Collapse Expand Group

TaxData Enumerations

Collapse Expand Links
TaxData.h, TaxData Enumerations


TaxData Data Members

TaxData Data Members
TaxData Class Legend Public Data Members

The data members of the TaxData class are listed here.

Collapse Expand Class

TaxData Class

Collapse Expand Public Data Members
Name | Description
taxesDi | DI taxes paid by year.
taxesHi | HI taxes paid by year.
taxesOasdhi | OASDHI taxes paid by year.
taxesOasdi | OASDI taxes paid by year.
taxesOasi | OASI taxes paid by year.
Collapse Expand Links
TaxData Class, Legend, Public Data Members


TaxData::taxesDi Data Member

TaxData::taxesDi Data Member
TaxData Class TaxData Members TaxData Data Members

DI taxes paid by year.

C++
DoubleAnnual taxesDi;
Collapse Expand Group

TaxData Data Members

Collapse Expand Links
TaxData Class, TaxData Members, TaxData Data Members


TaxData::taxesHi Data Member

TaxData::taxesHi Data Member
TaxData Class TaxData Members TaxData Data Members

HI taxes paid by year.

C++
DoubleAnnual taxesHi;
Collapse Expand Group

TaxData Data Members

Collapse Expand Links
TaxData Class, TaxData Members, TaxData Data Members


TaxData::taxesOasdhi Data Member

TaxData::taxesOasdhi Data Member
TaxData Class TaxData Members TaxData Data Members

OASDHI taxes paid by year.

C++
DoubleAnnual taxesOasdhi;
Collapse Expand Group

TaxData Data Members

Collapse Expand Links
TaxData Class, TaxData Members, TaxData Data Members


TaxData::taxesOasdi Data Member

TaxData::taxesOasdi Data Member
TaxData Class TaxData Members TaxData Data Members

OASDI taxes paid by year.

C++
DoubleAnnual taxesOasdi;
Collapse Expand Group

TaxData Data Members

Collapse Expand Links
TaxData Class, TaxData Members, TaxData Data Members


TaxData::taxesOasi Data Member

TaxData::taxesOasi Data Member
TaxData Class TaxData Members TaxData Data Members

OASI taxes paid by year.

C++
DoubleAnnual taxesOasi;
Collapse Expand Group

TaxData Data Members

Collapse Expand Links
TaxData Class, TaxData Members, TaxData Data Members


TaxData Methods

TaxData Methods
TaxData Class Legend Public Methods

The methods of the TaxData class are listed here.

Collapse Expand Class

TaxData Class

Collapse Expand Public Methods
Name | Description
getTaxesTotal | Returns total taxes paid for a trust fund type and a period of years.
oasdhiTaxCal | Calculates OASDI and OASDHI taxes paid over a lifetime.
totalTaxCal | Calculates total taxes paid over a lifetime.
Collapse Expand Links
TaxData Class, Legend, Public Methods


TaxData::getTaxesTotal Method

TaxData::getTaxesTotal Method
TaxData Class TaxData Members TaxData Methods

Returns total taxes paid for a trust fund type and a period of years.

C++
double getTaxesTotal(
    TaxRates::trustfundType trustfund,
    YEAR_GROUP yearGroup
) const;
Collapse Expand Parameters
Parameters | Description
TaxRates::trustfundType trustfund | Type of taxes.
YEAR_GROUP yearGroup | Group of years to use (years 1937 to 1950 or all years starting with 1937).
Collapse Expand Returns

Total taxes paid for a trust fund type and a period of years.

Collapse Expand Group

TaxData Methods

Collapse Expand Links
TaxData Class, TaxData Members, TaxData Methods


TaxData::oasdhiTaxCal Method

TaxData::oasdhiTaxCal Method
TaxData Class TaxData Members TaxData Methods

Calculates OASDI and OASDHI taxes paid over a lifetime.

C++
void oasdhiTaxCal();
Collapse Expand Remarks

Calculates OASDI and OASDHI taxes paid over a lifetime. Assumes that OASI, DI, and HI taxes have already been calculated.

Collapse Expand Group

TaxData Methods

Collapse Expand Links
TaxData Class, TaxData Members, TaxData Methods


TaxData::totalTaxCal Method

TaxData::totalTaxCal Method
TaxData Class TaxData Members TaxData Methods

Calculates total taxes paid over a lifetime.

C++
void totalTaxCal();
Collapse Expand Remarks

Calculates total taxes paid over a lifetime. Assumes that OASDI and OASDHI taxes have already been calculated via a call to TaxData::oasdhiTaxCal.

Collapse Expand Group

TaxData Methods

Collapse Expand Links
TaxData Class, TaxData Members, TaxData Methods


TaxRates Class

TaxRates Class
TaxRates Enumerations TaxRates Data Members TaxRates Methods TaxRates Members TaxRates.h Classes

Abstract parent of classes that manage the Social Security payroll and self-employed tax rates.

Collapse Expand Class Hierarchy
  TaxRates
C++
class TaxRates;
Collapse Expand File

File: TaxRates.h

Module: PiaData Library

Collapse Expand Remarks

The child classes are TaxRatesLC and TaxRatesPL.

Collapse Expand See Also

TaxRatesLC, TaxRatesPL

Collapse Expand Group

Classes

Collapse Expand Links
TaxRates Enumerations, TaxRates Data Members, TaxRates Methods, TaxRates Members, TaxRates.h, Classes


TaxRates Members

TaxRates Members
Enumerations TaxRates Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by TaxRates.

Collapse Expand Enumerations
Name | Description
taxrateType | Type of tax rate (employee or self-employed).
trustfundType | Trust fund indicator.
Collapse Expand Class

TaxRates Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
maxyear | Maximum year allowed.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
setCredits | Sets tax credits for one year for employee or employer for all trust funds.
setGrossRates | Sets gross tax rates for all years for employee and employer, for all trust funds.
setNetRates | Sets net tax rates for one year for employee or employer for all trust funds.
Collapse Expand Public Data Members
Name | Description
LAST_TAX_RATE_YEAR | Last year that tax rates change.
NUMTAXRATES | Number of years of historical tax rates.
Collapse Expand Public Methods
Name | Description
TaxRates | Initializes arrays.
getTaxRatesGross | Returns an array of gross tax rates.
getTaxRatesNet | Returns an array of tax rates, net of any tax credit.
initialize | Initializes all tax rates.
setHistCredits | Sets historical tax credits.
setHistRates | Sets historical tax rates.
taxCalAllYears | Calculates taxes paid over a lifetime, net of any tax credit.
taxCalOneYearGross | Returns taxes paid for one year for one trust fund, including any tax credit.
taxCalOneYearNet | Returns taxes paid for one year for one trust fund, net of any tax credit.
~TaxRates | Destroys this instance.
Collapse Expand Links
Enumerations, TaxRates Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


TaxRates::TaxRates Constructor

TaxRates::TaxRates Constructor
TaxRates Class TaxRates Members TaxRates Class

Initializes arrays.

C++
TaxRates(
    int lastYear
);
Collapse Expand Parameters
Parameters | Description
int lastYear | Maximum projected year.
Collapse Expand Class

TaxRates Class

Collapse Expand Links
TaxRates Class, TaxRates Members, TaxRates Class


TaxRates::~TaxRates Destructor

TaxRates::~TaxRates Destructor
TaxRates Class TaxRates Members TaxRates Class

Destroys this instance.

C++
virtual ~TaxRates();
Collapse Expand Remarks

Deletes memory for tax rate and credit arrays.

Collapse Expand Class

TaxRates Class

Collapse Expand Links
TaxRates Class, TaxRates Members, TaxRates Class


TaxRates Enumerations

TaxRates Enumerations
Enumerations TaxRates Class Legend

The enumerations of the TaxRates class are listed here.

Collapse Expand Enumerations
Name | Description
taxrateType | Type of tax rate (employee or self-employed).
trustfundType | Trust fund indicator.
Collapse Expand Class

TaxRates Class

Collapse Expand Links
Enumerations, TaxRates Class, Legend


TaxRates::taxrateType Enumeration

TaxRates::taxrateType Enumeration
TaxRates.h TaxRates Enumerations

Type of tax rate (employee or self-employed).

C++
enum taxrateType {
  EMPLOYEERATE,
  SELFEMPRATE,
  NUMTAXRATETYPES
};
Collapse Expand File

File: TaxRates.h

Module: PiaData Library

Collapse Expand Members
Members | Description
EMPLOYEERATE | Employee rate.
SELFEMPRATE | Self-employed rate.
NUMTAXRATETYPES | Number of tax rate types.
Collapse Expand Group

TaxRates Enumerations

Collapse Expand Links
TaxRates.h, TaxRates Enumerations


TaxRates::trustfundType Enumeration

TaxRates::trustfundType Enumeration
TaxRates.h TaxRates Enumerations

Trust fund indicator.

C++
enum trustfundType {
  OASITF,
  DITF,
  OASDITF,
  HITF,
  OASDHITF,
  NUMTRUSTFUNDTYPES
};
Collapse Expand File

File: TaxRates.h

Module: PiaData Library

Collapse Expand Members
Members | Description
OASITF | Oasi trust fund.
DITF | Di trust fund.
OASDITF | Oasdi trust fund.
HITF | Hi trust fund.
OASDHITF | Oasdhi trust fund.
NUMTRUSTFUNDTYPES | Number of trust fund types.
Collapse Expand Group

TaxRates Enumerations

Collapse Expand Links
TaxRates.h, TaxRates Enumerations


TaxRates Data Members

TaxRates Data Members
TaxRates Class Legend Protected Data Members Public Data Members

The data members of the TaxRates class are listed here.

Collapse Expand Class

TaxRates Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
maxyear | Maximum year allowed.
Collapse Expand Public Data Members
Name | Description
LAST_TAX_RATE_YEAR | Last year that tax rates change.
NUMTAXRATES | Number of years of historical tax rates.
Collapse Expand Links
TaxRates Class, Legend, Protected Data Members, Public Data Members


TaxRates::LAST_TAX_RATE_YEAR Data Member

TaxRates::LAST_TAX_RATE_YEAR Data Member
TaxRates Class TaxRates Members TaxRates Data Members

Last year that tax rates change.

C++
const int LAST_TAX_RATE_YEAR = 2019;
Collapse Expand Group

TaxRates Data Members

Collapse Expand Links
TaxRates Class, TaxRates Members, TaxRates Data Members


TaxRates::NUMTAXRATES Data Member

TaxRates::NUMTAXRATES Data Member
TaxRates Class TaxRates Members TaxRates Data Members

Number of years of historical tax rates.

C++
const int NUMTAXRATES = LAST_TAX_RATE_YEAR - YEAR37 + 1;
Collapse Expand Group

TaxRates Data Members

Collapse Expand Links
TaxRates Class, TaxRates Members, TaxRates Data Members


TaxRates::maxyear Data Member

TaxRates::maxyear Data Member
TaxRates Class TaxRates Members TaxRates Data Members

Maximum year allowed.

C++
int maxyear;
Collapse Expand Group

TaxRates Data Members

Collapse Expand Links
TaxRates Class, TaxRates Members, TaxRates Data Members


TaxRates Methods

TaxRates Methods
TaxRates Class Legend Protected Methods Public Methods

The methods of the TaxRates class are listed here.

Collapse Expand Class

TaxRates Class

Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
setCredits | Sets tax credits for one year for employee or employer for all trust funds.
setGrossRates | Sets gross tax rates for all years for employee and employer, for all trust funds.
setNetRates | Sets net tax rates for one year for employee or employer for all trust funds.
Collapse Expand Public Methods
Name | Description
getTaxRatesGross | Returns an array of gross tax rates.
getTaxRatesNet | Returns an array of tax rates, net of any tax credit.
initialize | Initializes all tax rates.
setHistCredits | Sets historical tax credits.
setHistRates | Sets historical tax rates.
taxCalAllYears | Calculates taxes paid over a lifetime, net of any tax credit.
taxCalOneYearGross | Returns taxes paid for one year for one trust fund, including any tax credit.
taxCalOneYearNet | Returns taxes paid for one year for one trust fund, net of any tax credit.
Collapse Expand Links
TaxRates Class, Legend, Protected Methods, Public Methods


TaxRates::getTaxRatesGross Method

TaxRates::getTaxRatesGross Method
TaxRates Class TaxRates Members TaxRates Methods

Returns an array of gross tax rates.

C++
const DoubleAnnual& getTaxRatesGross(
    taxrateType empeeEmper,
    trustfundType trustfund
) const;
Collapse Expand Parameters
Parameters | Description
taxrateType empeeEmper | Specifies the FICA or SECA rate.
trustfundType trustfund | Type of taxes.
Collapse Expand Returns

An array of gross tax rates.

Collapse Expand Group

TaxRates Methods

Collapse Expand Links
TaxRates Class, TaxRates Members, TaxRates Methods


TaxRates::getTaxRatesNet Method

TaxRates::getTaxRatesNet Method
TaxRates Class TaxRates Members TaxRates Methods

Returns an array of tax rates, net of any tax credit.

C++
const DoubleAnnual& getTaxRatesNet(
    taxrateType empeeEmper,
    trustfundType trustfund
) const;
Collapse Expand Parameters
Parameters | Description
taxrateType empeeEmper | Specifies the FICA or SECA rate.
trustfundType trustfund | Type of taxes.
Collapse Expand Returns

An array of net tax rates.

Collapse Expand Group

TaxRates Methods

Collapse Expand Links
TaxRates Class, TaxRates Members, TaxRates Methods


TaxRates::initialize Method

TaxRates::initialize Method
TaxRates Class TaxRates Members TaxRates Methods

Initializes all tax rates.

C++
virtual void initialize() = 0;
Collapse Expand Group

TaxRates Methods

Collapse Expand Links
TaxRates Class, TaxRates Members, TaxRates Methods


TaxRates::setCredits Method

TaxRates::setCredits Method
TaxRates Class TaxRates Members TaxRates Methods

Sets tax credits for one year for employee or employer for all trust funds.

C++
void setCredits(
    int year,
    taxrateType taxType,
    double oasiCredit,
    double diCredit,
    double hiCredit
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which credits are being set.
taxrateType taxType | Tax type.
double oasiCredit | OASI tax rate.
double diCredit | DI tax rate.
double hiCredit | HI tax rate.
Collapse Expand Remarks

This is called from setHistCredits and TaxRatesLC::initialize

Collapse Expand Group

TaxRates Methods

Collapse Expand Links
TaxRates Class, TaxRates Members, TaxRates Methods


TaxRates::setGrossRates Method

TaxRates::setGrossRates Method
TaxRates Class TaxRates Members TaxRates Methods

Sets gross tax rates for all years for employee and employer, for all trust funds.

C++
void setGrossRates();
Collapse Expand Parameters
Parameters | Description
year | Year for which rates are being set.
taxType | Tax type. 0: employee, 1: employer.
oasiRate | OASI tax rate.
diRate | DI tax rate.
hiRate | HI tax rate.
Collapse Expand Group

TaxRates Methods

Collapse Expand Links
TaxRates Class, TaxRates Members, TaxRates Methods


TaxRates::setHistCredits Method

TaxRates::setHistCredits Method
TaxRates Class TaxRates Members TaxRates Methods

Sets historical tax credits.

C++
void setHistCredits(
    int lastYear
);
Collapse Expand Parameters
Parameters | Description
int lastYear | Last year in historical period (could be last projected year in present law case).
Collapse Expand Remarks

This is called from TaxRatesLC::initialize and TaxRatesPL::initialize.

Collapse Expand Group

TaxRates Methods

Collapse Expand Links
TaxRates Class, TaxRates Members, TaxRates Methods


TaxRates::setHistRates Method

TaxRates::setHistRates Method
TaxRates Class TaxRates Members TaxRates Methods

Sets historical tax rates.

C++
void setHistRates(
    int lastYear
);
Collapse Expand Parameters
Parameters | Description
int lastYear | Last year in historical period (could be last projected year in present law case).
Collapse Expand Remarks

This is called from TaxRatesLC::initialize and TaxRatesPL::initialize.

Collapse Expand Group

TaxRates Methods

Collapse Expand Links
TaxRates Class, TaxRates Members, TaxRates Methods


TaxRates::setNetRates Method

TaxRates::setNetRates Method
TaxRates Class TaxRates Members TaxRates Methods

Sets net tax rates for one year for employee or employer for all trust funds.

C++
void setNetRates(
    int year,
    taxrateType taxType,
    double oasiRate,
    double diRate,
    double hiRate
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which rates are being set.
taxrateType taxType | Tax type. 0: employee, 1: employer.
double oasiRate | OASI tax rate.
double diRate | DI tax rate.
double hiRate | HI tax rate.
Collapse Expand Group

TaxRates Methods

Collapse Expand Links
TaxRates Class, TaxRates Members, TaxRates Methods


TaxRates::taxCalAllYears Method

TaxRates::taxCalAllYears Method
TaxRates Class TaxRates Members TaxRates Methods

Calculates taxes paid over a lifetime, net of any tax credit.

C++
void taxCalAllYears(
    const DoubleAnnual& earnOasdi,
    const BitAnnual& taxType,
    DoubleAnnual& taxes,
    trustfundType fundType
) const;
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& earnOasdi | Array of earnings limited to wage base.
const BitAnnual& taxType | Array of tax types. Each entry is true for employee or false for employer.
DoubleAnnual& taxes | Array to hold calculated taxes.
trustfundType fundType | Trust fund type (0: oasi, 1: di, 2: oasdi, 3: hi, 4: oasdi).
Collapse Expand Group

TaxRates Methods

Collapse Expand Links
TaxRates Class, TaxRates Members, TaxRates Methods


TaxRates::taxCalOneYearGross Method

TaxRates::taxCalOneYearGross Method
TaxRates Class TaxRates Members TaxRates Methods

Returns taxes paid for one year for one trust fund, including any tax credit.

C++
double taxCalOneYearGross(
    int year,
    double earnings,
    taxrateType taxType,
    trustfundType fundType
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of earnings.
double earnings | The earnings limited to wage base.
taxrateType taxType | Tax type.
trustfundType fundType | Trust fund type.
Collapse Expand Returns

Taxes paid for one year for one trust fund.

Collapse Expand Group

TaxRates Methods

Collapse Expand Links
TaxRates Class, TaxRates Members, TaxRates Methods


TaxRates::taxCalOneYearNet Method

TaxRates::taxCalOneYearNet Method
TaxRates Class TaxRates Members TaxRates Methods

Returns taxes paid for one year for one trust fund, net of any tax credit.

C++
double taxCalOneYearNet(
    int year,
    double earnings,
    taxrateType taxType,
    trustfundType fundType
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of earnings.
double earnings | The earnings limited to wage base.
taxrateType taxType | Tax type.
trustfundType fundType | Trust fund type.
Collapse Expand Returns

Taxes paid for one year for one trust fund.

Collapse Expand Group

TaxRates Methods

Collapse Expand Links
TaxRates Class, TaxRates Members, TaxRates Methods


TaxRatesLC Class

TaxRatesLC Class
TaxRatesLC Data Members TaxRatesLC Methods TaxRatesLC Members TaxRatesLC.h Classes

Manages the Social Security payroll and self-employed tax rates, with changes from present law.

Collapse Expand Class Hierarchy
  TaxRatesLCTaxRatesLC
C++
class TaxRatesLC : public TaxRates;
Collapse Expand File

File: TaxRatesLC.h

Module: PiaData Library

Collapse Expand Remarks

Manages the Social Security payroll and self-employed tax rates, with changes from present law.

Collapse Expand Group

Classes

Collapse Expand Links
TaxRatesLC Data Members, TaxRatesLC Methods, TaxRatesLC Members, TaxRatesLC.h, Classes


TaxRatesLC Members

TaxRatesLC Members
Enumerations TaxRatesLC Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by TaxRatesLC.

Collapse Expand Enumerations
Name | Description
taxrateType | Type of tax rate (employee or self-employed).
trustfundType | Trust fund indicator.
Collapse Expand Class

TaxRatesLC Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
lawChange | Law change data.
maxyear | Maximum year allowed.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
setCredits | Sets tax credits for one year for employee or employer for all trust funds.
setGrossRates | Sets gross tax rates for all years for employee and employer, for all trust funds.
setNetRates | Sets net tax rates for one year for employee or employer for all trust funds.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
LAST_TAX_RATE_YEAR | Last year that tax rates change.
NUMTAXRATES | Number of years of historical tax rates.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
TaxRatesLC | Initializes arrays.
getTaxRatesGross | Returns an array of gross tax rates.
getTaxRatesNet | Returns an array of tax rates, net of any tax credit.
initialize | Sets all tax rates, using historical rates unless overridden by rates in law change data.
setHistCredits | Sets historical tax credits.
setHistRates | Sets historical tax rates.
taxCalAllYears | Calculates taxes paid over a lifetime, net of any tax credit.
taxCalOneYearGross | Returns taxes paid for one year for one trust fund, including any tax credit.
taxCalOneYearNet | Returns taxes paid for one year for one trust fund, net of any tax credit.
~TaxRatesLC | Destroys this instance.
Collapse Expand Links
Enumerations, TaxRatesLC Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


TaxRatesLC::TaxRatesLC Constructor

TaxRatesLC::TaxRatesLC Constructor
TaxRatesLC Class TaxRatesLC Members TaxRatesLC Class

Initializes arrays.

C++
TaxRatesLC(
    int lastYear,
    const LawChangeArray& newLawChange
);
Collapse Expand Parameters
Parameters | Description
int lastYear | Maximum projected year.
const LawChangeArray& newLawChange | Law change data.
Collapse Expand Remarks

Calls initialize.

Collapse Expand Class

TaxRatesLC Class

Collapse Expand Links
TaxRatesLC Class, TaxRatesLC Members, TaxRatesLC Class


TaxRatesLC::~TaxRatesLC Destructor

TaxRatesLC::~TaxRatesLC Destructor
TaxRatesLC Class TaxRatesLC Members TaxRatesLC Class

Destroys this instance.

C++
~TaxRatesLC();
Collapse Expand Class

TaxRatesLC Class

Collapse Expand Links
TaxRatesLC Class, TaxRatesLC Members, TaxRatesLC Class


TaxRatesLC Data Members

TaxRatesLC Data Members
TaxRatesLC Class Legend Protected Data Members

The data members of the TaxRatesLC class are listed here.

Collapse Expand Class

TaxRatesLC Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
lawChange | Law change data.
Collapse Expand Links
TaxRatesLC Class, Legend, Protected Data Members


TaxRatesLC::lawChange Data Member

TaxRatesLC::lawChange Data Member
TaxRatesLC Class TaxRatesLC Members TaxRatesLC Data Members

Law change data.

C++
const LawChangeArray& lawChange;
Collapse Expand Group

TaxRatesLC Data Members

Collapse Expand Links
TaxRatesLC Class, TaxRatesLC Members, TaxRatesLC Data Members


TaxRatesLC Methods

TaxRatesLC Methods
TaxRatesLC Class Legend Public Methods

The methods of the TaxRatesLC class are listed here.

Collapse Expand Class

TaxRatesLC Class

Collapse Expand Public Methods
Name | Description
initialize | Sets all tax rates, using historical rates unless overridden by rates in law change data.
Collapse Expand Links
TaxRatesLC Class, Legend, Public Methods


TaxRatesLC::initialize Method

TaxRatesLC::initialize Method
TaxRatesLC Class TaxRatesLC Members TaxRatesLC Methods

Sets all tax rates, using historical rates unless overridden by rates in law change data.

C++
void initialize();
Collapse Expand Remarks

Whether or not tax rates are changed, the tax credits are not currently allowed to be specified for future years; therefore, calls TaxRates::setHistCredits, specifying that all years are being set. Finally calls TaxRates::setGrossRates.

Collapse Expand Group

TaxRatesLC Methods

Collapse Expand Links
TaxRatesLC Class, TaxRatesLC Members, TaxRatesLC Methods


TaxRatesPL Class

TaxRatesPL Class
TaxRatesPL Methods TaxRatesPL Members TaxRatesPL.h Classes

Manages the present law Social Security payroll and self-employed tax rates.

Collapse Expand Class Hierarchy
  TaxRatesPLTaxRatesPL
C++
class TaxRatesPL : public TaxRates;
Collapse Expand File

File: TaxRatesPL.h

Module: PiaData Library

Collapse Expand Remarks

Manages the present law Social Security payroll and self-employed tax rates.

Collapse Expand Group

Classes

Collapse Expand Links
TaxRatesPL Methods, TaxRatesPL Members, TaxRatesPL.h, Classes


TaxRatesPL Members

TaxRatesPL Members
Enumerations TaxRatesPL Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by TaxRatesPL.

Collapse Expand Enumerations
Name | Description
taxrateType | Type of tax rate (employee or self-employed).
trustfundType | Trust fund indicator.
Collapse Expand Class

TaxRatesPL Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
maxyear | Maximum year allowed.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
setCredits | Sets tax credits for one year for employee or employer for all trust funds.
setGrossRates | Sets gross tax rates for all years for employee and employer, for all trust funds.
setNetRates | Sets net tax rates for one year for employee or employer for all trust funds.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
LAST_TAX_RATE_YEAR | Last year that tax rates change.
NUMTAXRATES | Number of years of historical tax rates.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
TaxRatesPL | Initializes arrays.
getTaxRatesGross | Returns an array of gross tax rates.
getTaxRatesNet | Returns an array of tax rates, net of any tax credit.
initialize | Sets all tax rates and credits to stored values.
setHistCredits | Sets historical tax credits.
setHistRates | Sets historical tax rates.
taxCalAllYears | Calculates taxes paid over a lifetime, net of any tax credit.
taxCalOneYearGross | Returns taxes paid for one year for one trust fund, including any tax credit.
taxCalOneYearNet | Returns taxes paid for one year for one trust fund, net of any tax credit.
~TaxRatesPL | Destroys this instance.
Collapse Expand Links
Enumerations, TaxRatesPL Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


TaxRatesPL::TaxRatesPL Constructor

TaxRatesPL::TaxRatesPL Constructor
TaxRatesPL Class TaxRatesPL Members TaxRatesPL Class

Initializes arrays.

C++
TaxRatesPL(
    int lastYear
);
Collapse Expand Parameters
Parameters | Description
int lastYear | Maximum projected year.
Collapse Expand Remarks

Calls initialize.

Collapse Expand Class

TaxRatesPL Class

Collapse Expand Links
TaxRatesPL Class, TaxRatesPL Members, TaxRatesPL Class


TaxRatesPL::~TaxRatesPL Destructor

TaxRatesPL::~TaxRatesPL Destructor
TaxRatesPL Class TaxRatesPL Members TaxRatesPL Class

Destroys this instance.

C++
~TaxRatesPL();
Collapse Expand Class

TaxRatesPL Class

Collapse Expand Links
TaxRatesPL Class, TaxRatesPL Members, TaxRatesPL Class


TaxRatesPL Methods

TaxRatesPL Methods
TaxRatesPL Class Legend Public Methods

The methods of the TaxRatesPL class are listed here.

Collapse Expand Class

TaxRatesPL Class

Collapse Expand Public Methods
Name | Description
initialize | Sets all tax rates and credits to stored values.
Collapse Expand Links
TaxRatesPL Class, Legend, Public Methods


TaxRatesPL::initialize Method

TaxRatesPL::initialize Method
TaxRatesPL Class TaxRatesPL Members TaxRatesPL Methods

Sets all tax rates and credits to stored values.

C++
void initialize();
Collapse Expand Remarks

Calls TaxRates::setHistRates and TaxRates::setHistCredits, specifying that all years are being set. Finally calls TaxRates::setGrossRates.

Collapse Expand Group

TaxRatesPL Methods

Collapse Expand Links
TaxRatesPL Class, TaxRatesPL Members, TaxRatesPL Methods


TransGuar Class

TransGuar Class
TransGuar Data Members TransGuar Methods TransGuar Members TransGuar.h Classes

Manages the functions required for calculation of a transitional guarantee Social Security benefit.

Collapse Expand Class Hierarchy
  TransGuarTransGuarTransGuar
C++
class TransGuar : public OldPia;
Collapse Expand File

File: TransGuar.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaCalPL.

Collapse Expand See Also

PiaCalPL

Collapse Expand Group

Classes

Collapse Expand Links
TransGuar Data Members, TransGuar Methods, TransGuar Members, TransGuar.h, Classes


TransGuar Members

TransGuar Members
Enumerations TransGuar Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by TransGuar.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

TransGuar Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
iamemax | Maximum ame in pia interval.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
percMfb | Wage-indexed MFB formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
TransGuar | Initializes a TransGuar instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Computes transitional guarantee PIA.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~TransGuar | Destructor.
Collapse Expand Links
Enumerations, TransGuar Class, Legend, Protected Data Members, Public Data Members, Public Methods


TransGuar::TransGuar Constructor

TransGuar::TransGuar Constructor
TransGuar Class TransGuar Members TransGuar Class

Initializes a TransGuar instance.

C++
TransGuar(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker basic data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
Collapse Expand Class

TransGuar Class

Collapse Expand Links
TransGuar Class, TransGuar Members, TransGuar Class


TransGuar::~TransGuar Destructor

TransGuar::~TransGuar Destructor
TransGuar Class TransGuar Members TransGuar Class

Destructor.

C++
virtual ~TransGuar();
Collapse Expand Class

TransGuar Class

Collapse Expand Links
TransGuar Class, TransGuar Members, TransGuar Class


TransGuar Data Members

TransGuar Data Members
TransGuar Class Legend Public Data Members

The data members of the TransGuar class are listed here.

Collapse Expand Class

TransGuar Class

Collapse Expand Public Data Members
Name | Description
bendMfb | Bend points for MFB formula.
percMfb | Wage-indexed MFB formula percentages.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
Collapse Expand Links
TransGuar Class, Legend, Public Data Members


TransGuar::bendMfb Data Member

TransGuar::bendMfb Data Member
TransGuar Class TransGuar Members TransGuar Data Members

Bend points for MFB formula.

C++
BendMfb bendMfb;
Collapse Expand Group

TransGuar Data Members

Collapse Expand Links
TransGuar Class, TransGuar Members, TransGuar Data Members


TransGuar::percMfb Data Member

TransGuar::percMfb Data Member
TransGuar Class TransGuar Members TransGuar Data Members

Wage-indexed MFB formula percentages.

C++
PercMfb percMfb;
Collapse Expand Group

TransGuar Data Members

Collapse Expand Links
TransGuar Class, TransGuar Members, TransGuar Data Members


TransGuar::portionPiaElig Data Member

TransGuar::portionPiaElig Data Member
TransGuar Class TransGuar Members TransGuar Data Members

Portion of AIME PIA in each interval of MFB formula.

C++
double portionPiaElig[4];
Collapse Expand Group

TransGuar Data Members

Collapse Expand Links
TransGuar Class, TransGuar Members, TransGuar Data Members


TransGuar Methods

TransGuar Methods
TransGuar Class Legend Public Methods

The methods of the TransGuar class are listed here.

Collapse Expand Class

TransGuar Class

Collapse Expand Public Methods
Name | Description
calculate | Computes transitional guarantee PIA.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
Collapse Expand Links
TransGuar Class, Legend, Public Methods


TransGuar::calculate Method

TransGuar::calculate Method
TransGuar Class TransGuar Members TransGuar Methods

Computes transitional guarantee PIA.

C++
void calculate();
Collapse Expand Group

TransGuar Methods

Collapse Expand Links
TransGuar Class, TransGuar Members, TransGuar Methods


TransGuar::initialize Method

TransGuar::initialize Method
TransGuar Class TransGuar Members TransGuar Methods

Initializes computed values to zero.

C++
void initialize();
Collapse Expand Group

TransGuar Methods

Collapse Expand Links
TransGuar Class, TransGuar Members, TransGuar Methods


isApplicable Method

isApplicable Method
TransGuar Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of this function. The version with no arguments uses stored data, passing it to the static version with three arguments.

Collapse Expand Overload List
Name | Description
TransGuar::isApplicable () | Determines applicability of method using stored values.
TransGuar::isApplicable (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type) | Determines applicability of method using passed values.
Collapse Expand Group

TransGuar Methods

Collapse Expand Links
TransGuar Methods


TransGuar::isApplicable Method ()

TransGuar::isApplicable Method ()
TransGuar Class TransGuar Members isApplicable Method

Determines applicability of method using stored values.

C++
bool isApplicable();
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

This version calls the static version, passing the stored values.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
TransGuar Class, TransGuar Members, isApplicable Method


TransGuar::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type)

TransGuar::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type)
TransGuar Class TransGuar Members isApplicable Method

Determines applicability of method using passed values.

C++
static bool isApplicable(
    const WorkerDataGeneral& workerData,
    const PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker basic data.
const PiaData& piaData | Pia calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

The year of attainment of age 62 must be between 1979 and 1983, inclusive. The benefit must be old-age, or survivor if death occurred before the month of attainment of age 62. It must not be a totalized benefit, and there must be some earnings before 1979.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
TransGuar Class, TransGuar Members, isApplicable Method


TransGuarLC Class

TransGuarLC Class
TransGuarLC Methods TransGuarLC Members TransGuarLC.h Classes

Manages the functions required for calculation of a transitional guarantee Social Security benefit, with changes from present law.

Collapse Expand Class Hierarchy
  TransGuarLCTransGuarLCTransGuarLCTransGuarLC
C++
class TransGuarLC : public TransGuar;
Collapse Expand File

File: TransGuarLC.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaCalLC.

Collapse Expand Group

Classes

Collapse Expand Links
TransGuarLC Methods, TransGuarLC Members, TransGuarLC.h, Classes


TransGuarLC Members

TransGuarLC Members
Enumerations TransGuarLC Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by TransGuarLC.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

TransGuarLC Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
iamemax | Maximum ame in pia interval.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
percMfb | Wage-indexed MFB formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
TransGuarLC | Initializes a TransGuarLC instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Calculates pia and mfb for this method.
calculate | Computes transitional guarantee PIA.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~TransGuarLC | Destructor.
Collapse Expand Links
Enumerations, TransGuarLC Class, Legend, Protected Data Members, Public Data Members, Public Methods


TransGuarLC::TransGuarLC Constructor

TransGuarLC::TransGuarLC Constructor
TransGuarLC Class TransGuarLC Members TransGuarLC Class

Initializes a TransGuarLC instance.

C++
TransGuarLC(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear,
    const LawChangeArray& newLawChange
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker basic data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
const LawChangeArray& newLawChange | Law-change parameters.
Collapse Expand Class

TransGuarLC Class

Collapse Expand Links
TransGuarLC Class, TransGuarLC Members, TransGuarLC Class


TransGuarLC::~TransGuarLC Destructor

TransGuarLC::~TransGuarLC Destructor
TransGuarLC Class TransGuarLC Members TransGuarLC Class

Destructor.

C++
~TransGuarLC();
Collapse Expand Class

TransGuarLC Class

Collapse Expand Links
TransGuarLC Class, TransGuarLC Members, TransGuarLC Class


TransGuarLC Methods

TransGuarLC Methods
TransGuarLC Class Legend Public Methods

The methods of the TransGuarLC class are listed here.

Collapse Expand Class

TransGuarLC Class

Collapse Expand Public Methods
Name | Description
isApplicable | Determines applicability of method.
Collapse Expand Links
TransGuarLC Class, Legend, Public Methods


isApplicable Method

isApplicable Method
TransGuarLC Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of this function. The version with no arguments uses stored data, passing it to the static version with four arguments.

Collapse Expand Overload List
Name | Description
TransGuarLC::isApplicable () | Determines applicability of method using stored values.
TransGuarLC::isApplicable (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type, const LawChangeArray&) | Determines applicability of method using passed values.
Collapse Expand Group

TransGuarLC Methods

Collapse Expand Links
TransGuarLC Methods


TransGuarLC::isApplicable Method ()

TransGuarLC::isApplicable Method ()
TransGuarLC Class TransGuarLC Members isApplicable Method

Determines applicability of method using stored values.

C++
bool isApplicable();
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

Thia version calls the static version with 4 arguments, passing the stored values as arguments.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
TransGuarLC Class, TransGuarLC Members, isApplicable Method


TransGuarLC::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type, const LawChangeArray&)

TransGuarLC::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type, const LawChangeArray&)
TransGuarLC Class TransGuarLC Members isApplicable Method

Determines applicability of method using passed values.

C++
static bool isApplicable(
    const WorkerDataGeneral& workerData,
    const PiaData& piaData,
    WorkerDataGeneral::ben_type ioasdi,
    const LawChangeArray& lawChange
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker basic data.
const PiaData& piaData | Pia calculation data.
WorkerDataGeneral::ben_type ioasdi | Type of benefit.
const LawChangeArray& lawChange | Law-change parameters.
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

The year of attainment of age 62 must be between 1979 and the last year specified in the law change, inclusive. The benefit must be old-age, or survivor if death occurred before the month of attainment of age 62. It must not be a totalized benefit, and there must be some earnings before 1979.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
TransGuarLC Class, TransGuarLC Members, isApplicable Method


UserAssumptions Class

UserAssumptions Class
UserAssumptions Data Members UserAssumptions Methods UserAssumptions Members UserAssumptions.h Classes

Manages all the assumptions about future average wage increases, wage bases, benefit increases, and catch-up benefit increases that a user might specify.

Collapse Expand Class Hierarchy
  UserAssumptions
C++
class UserAssumptions;
Collapse Expand File

File: UserAssumptions.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is used in the Anypia program.

Collapse Expand Group

Classes

Collapse Expand Links
UserAssumptions Data Members, UserAssumptions Methods, UserAssumptions Members, UserAssumptions.h, Classes


UserAssumptions Members

UserAssumptions Members
UserAssumptions Class Legend Public Data Members Public Methods

The following tables list the members exposed by UserAssumptions.

Collapse Expand Class

UserAssumptions Class

Collapse Expand Public Data Members
Name | Description
awincproj | Projected increases in annual average earnings.
base77 | Old-law wage bases (ignoring 1979-81 ad hoc increases), 1937 to maxyear, as read in.
baseOasdi | Wage base under present law, 1937 to maxyear, as read in.
biproj | Projected benefit increases.
catchup | Catch-up benefit increases.
titleAw | Title of user's average wages.
titleBi | Title of user's benefit increases
Collapse Expand Public Methods
Name | Description
UserAssumptions | Initializes user-specified assumptions.
anscchCheck | Checks catch-up increase indicator.
deleteContents | Initializes all variables.
getAnscch | Returns catch-up benefit increase indicator.
getIaltaw | Returns average wage increase assumption.
getIaltbi | Returns benefit increase assumption.
getIbasch | Returns wage base projection indicator.
getIstart | Returns current year (year after last known benefit increase).
getJaltaw | Returns last average wage increase assumption read in.
getJaltbi | Returns last benefit increase assumption read in.
getJbasch | Returns last wage base projection indicator read in.
istartCheck | Checks current year.
pebsasmCheck | Checks for valid assumption for Statement.
resetTriggers | Resets assumptions triggers.
setAnscch | Sets catch-up increase indicator.
setIaltaw | Sets average wage increase indicator.
setIaltbi | Sets benefit increase indicator.
setIbasch | Sets wage base indicator.
setIstart | Sets current year.
setJaltaw | Sets the previous average wage increase assumption.
setJaltbi | Sets the previous benefit increase assumption.
setJbasch | Sets the previous wage base assumption.
setLastYear | Sets last year of data arrays. Should be called when benefit date is set in WorkerData.
setTitleAw | Sets average wage change assumption title.
setTitleBi | Sets benefit increase assumption title.
zeroJalt | Initializes previous assumptions indicators.
Collapse Expand Links
UserAssumptions Class, Legend, Public Data Members, Public Methods


UserAssumptions::UserAssumptions Constructor

UserAssumptions::UserAssumptions Constructor
UserAssumptions Class UserAssumptions Members UserAssumptions Class

Initializes user-specified assumptions.

C++
UserAssumptions(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Maximum projected year.
Collapse Expand Class

UserAssumptions Class

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Class


UserAssumptions Data Members

UserAssumptions Data Members
UserAssumptions Class Legend Public Data Members

The data members of the UserAssumptions class are listed here.

Collapse Expand Class

UserAssumptions Class

Collapse Expand Public Data Members
Name | Description
awincproj | Projected increases in annual average earnings.
base77 | Old-law wage bases (ignoring 1979-81 ad hoc increases), 1937 to maxyear, as read in.
baseOasdi | Wage base under present law, 1937 to maxyear, as read in.
biproj | Projected benefit increases.
catchup | Catch-up benefit increases.
titleAw | Title of user's average wages.
titleBi | Title of user's benefit increases
Collapse Expand Links
UserAssumptions Class, Legend, Public Data Members


UserAssumptions::awincproj Data Member

UserAssumptions::awincproj Data Member
UserAssumptions Class UserAssumptions Members UserAssumptions Data Members

Projected increases in annual average earnings.

C++
DoubleAnnual awincproj;
Collapse Expand Group

UserAssumptions Data Members

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Data Members


UserAssumptions::base77 Data Member

UserAssumptions::base77 Data Member
UserAssumptions Class UserAssumptions Members UserAssumptions Data Members

Old-law wage bases (ignoring 1979-81 ad hoc increases), 1937 to maxyear, as read in.

C++
DoubleAnnual base77;
Collapse Expand Group

UserAssumptions Data Members

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Data Members


UserAssumptions::baseOasdi Data Member

UserAssumptions::baseOasdi Data Member
UserAssumptions Class UserAssumptions Members UserAssumptions Data Members

Wage base under present law, 1937 to maxyear, as read in.

C++
DoubleAnnual baseOasdi;
Collapse Expand Group

UserAssumptions Data Members

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Data Members


UserAssumptions::biproj Data Member

UserAssumptions::biproj Data Member
UserAssumptions Class UserAssumptions Members UserAssumptions Data Members

Projected benefit increases.

C++
DoubleAnnual biproj;
Collapse Expand Group

UserAssumptions Data Members

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Data Members


UserAssumptions::catchup Data Member

UserAssumptions::catchup Data Member
UserAssumptions Class UserAssumptions Members UserAssumptions Data Members

Catch-up benefit increases.

C++
Catchup catchup;
Collapse Expand Group

UserAssumptions Data Members

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Data Members


UserAssumptions::titleAw Data Member

UserAssumptions::titleAw Data Member
UserAssumptions Class UserAssumptions Members UserAssumptions Data Members

Title of user's average wages.

C++
std::string titleAw;
Collapse Expand Group

UserAssumptions Data Members

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Data Members


UserAssumptions::titleBi Data Member

UserAssumptions::titleBi Data Member
UserAssumptions Class UserAssumptions Members UserAssumptions Data Members

Title of user's benefit increases

C++
std::string titleBi;
Collapse Expand Group

UserAssumptions Data Members

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Data Members


UserAssumptions Methods

UserAssumptions Methods
UserAssumptions Class Legend Public Methods

The methods of the UserAssumptions class are listed here.

Collapse Expand Class

UserAssumptions Class

Collapse Expand Public Methods
Name | Description
anscchCheck | Checks catch-up increase indicator.
deleteContents | Initializes all variables.
getAnscch | Returns catch-up benefit increase indicator.
getIaltaw | Returns average wage increase assumption.
getIaltbi | Returns benefit increase assumption.
getIbasch | Returns wage base projection indicator.
getIstart | Returns current year (year after last known benefit increase).
getJaltaw | Returns last average wage increase assumption read in.
getJaltbi | Returns last benefit increase assumption read in.
getJbasch | Returns last wage base projection indicator read in.
istartCheck | Checks current year.
pebsasmCheck | Checks for valid assumption for Statement.
resetTriggers | Resets assumptions triggers.
setAnscch | Sets catch-up increase indicator.
setIaltaw | Sets average wage increase indicator.
setIaltbi | Sets benefit increase indicator.
setIbasch | Sets wage base indicator.
setIstart | Sets current year.
setJaltaw | Sets the previous average wage increase assumption.
setJaltbi | Sets the previous benefit increase assumption.
setJbasch | Sets the previous wage base assumption.
setLastYear | Sets last year of data arrays. Should be called when benefit date is set in WorkerData.
setTitleAw | Sets average wage change assumption title.
setTitleBi | Sets benefit increase assumption title.
zeroJalt | Initializes previous assumptions indicators.
Collapse Expand Links
UserAssumptions Class, Legend, Public Methods


UserAssumptions::anscchCheck Method

UserAssumptions::anscchCheck Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Checks catch-up increase indicator.

C++
static void anscchCheck(
    char ansccht
);
Collapse Expand Parameters
Parameters | Description
char ansccht | Value to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ANSCCH if catch-up increase indicator is out of range.
Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::deleteContents Method

UserAssumptions::deleteContents Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Initializes all variables.

C++
void deleteContents();
Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::getAnscch Method

UserAssumptions::getAnscch Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Returns catch-up benefit increase indicator.

C++
char getAnscch() const;
Collapse Expand Returns

Catch-up benefit increase indicator.

Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::getIaltaw Method

UserAssumptions::getIaltaw Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Returns average wage increase assumption.

C++
AssumptionType::assum_type getIaltaw() const;
Collapse Expand Returns

Average wage increase assumption.

Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::getIaltbi Method

UserAssumptions::getIaltbi Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Returns benefit increase assumption.

C++
AssumptionType::assum_type getIaltbi() const;
Collapse Expand Returns

Benefit increase assumption.

Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::getIbasch Method

UserAssumptions::getIbasch Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Returns wage base projection indicator.

C++
BaseChangeType::change_type getIbasch() const;
Collapse Expand Returns

Wage base projection indicator.

Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::getIstart Method

UserAssumptions::getIstart Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Returns current year (year after last known benefit increase).

C++
static int getIstart();
Collapse Expand Returns

Current year (year after last known benefit increase).

Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::getJaltaw Method

UserAssumptions::getJaltaw Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Returns last average wage increase assumption read in.

C++
AssumptionType::assum_type getJaltaw() const;
Collapse Expand Returns

Last average wage increase assumption read in.

Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::getJaltbi Method

UserAssumptions::getJaltbi Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Returns last benefit increase assumption read in.

C++
AssumptionType::assum_type getJaltbi() const;
Collapse Expand Returns

Last benefit increase assumption read in.

Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::getJbasch Method

UserAssumptions::getJbasch Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Returns last wage base projection indicator read in.

C++
BaseChangeType::change_type getJbasch() const;
Collapse Expand Returns

Last wage base projection indicator read in.

Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::istartCheck Method

UserAssumptions::istartCheck Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Checks current year.

C++
static void istartCheck(
    int istartt
);
Collapse Expand Parameters
Parameters | Description
int istartt | Value to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_START1 if starting year is before 1979; of type PIA_IDS_START2 if starting year is after maximum year allowed.
Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::pebsasmCheck Method

UserAssumptions::pebsasmCheck Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Checks for valid assumption for Statement.

C++
void pebsasmCheck() const;
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PEBSASM if benefit increase indicator or average wage increase indicator is out of range in Statement case.
Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::resetTriggers Method

UserAssumptions::resetTriggers Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Resets assumptions triggers.

C++
void resetTriggers();
Collapse Expand Remarks

Should be called after updating assumptions for user-specified assumptions.

Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::setAnscch Method

UserAssumptions::setAnscch Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Sets catch-up increase indicator.

C++
void setAnscch(
    char ansccht
);
Collapse Expand Parameters
Parameters | Description
char ansccht | Value to use.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ANSCCH if catch-up increase indicator is out of range.
Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::setIaltaw Method

UserAssumptions::setIaltaw Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Sets average wage increase indicator.

C++
void setIaltaw(
    int ialtawt
);
Collapse Expand Parameters
Parameters | Description
int ialtawt | Value to use.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_IALTAW1 if average wage increase indicator is out of range in general case.
Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::setIaltbi Method

UserAssumptions::setIaltbi Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Sets benefit increase indicator.

C++
void setIaltbi(
    int ialtbit
);
Collapse Expand Parameters
Parameters | Description
int ialtbit | Value to use.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_IALTBI1 if benefit increase indicator is out of range in general case.
Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::setIbasch Method

UserAssumptions::setIbasch Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Sets wage base indicator.

C++
void setIbasch(
    int ibascht
);
Collapse Expand Parameters
Parameters | Description
int ibascht | Value to use.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BASECH if wage base indicator is not BaseChangeType::change_type::AUTOMATIC or BaseChangeType::change_type::ADHOC.
Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::setIstart Method

UserAssumptions::setIstart Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Sets current year.

C++
void setIstart(
    int istartt
);
Collapse Expand Parameters
Parameters | Description
int istartt | Value to use.
Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::setJaltaw Method

UserAssumptions::setJaltaw Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Sets the previous average wage increase assumption.

C++
void setJaltaw(
    AssumptionType::assum_type jaltawt
);
Collapse Expand Parameters
Parameters | Description
AssumptionType::assum_type jaltawt | New value of previous average wage increase assumption.
Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::setJaltbi Method

UserAssumptions::setJaltbi Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Sets the previous benefit increase assumption.

C++
void setJaltbi(
    AssumptionType::assum_type jaltbit
);
Collapse Expand Parameters
Parameters | Description
AssumptionType::assum_type jaltbit | New value of previous benefit increase assumption.
Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::setJbasch Method

UserAssumptions::setJbasch Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Sets the previous wage base assumption.

C++
void setJbasch(
    BaseChangeType::change_type jbascht
);
Collapse Expand Parameters
Parameters | Description
BaseChangeType::change_type jbascht | New value of previous wage base assumption.
Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::setLastYear Method

UserAssumptions::setLastYear Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Sets last year of data arrays. Should be called when benefit date is set in WorkerData.

C++
void setLastYear(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year to use.
Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::setTitleAw Method

UserAssumptions::setTitleAw Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Sets average wage change assumption title.

C++
void setTitleAw(
    const std::string& newTitleAw
);
Collapse Expand Parameters
Parameters | Description
const std::string& newTitleAw | New title to use.
Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::setTitleBi Method

UserAssumptions::setTitleBi Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Sets benefit increase assumption title.

C++
void setTitleBi(
    const std::string& newTitleBi
);
Collapse Expand Parameters
Parameters | Description
const std::string& newTitleBi | New title to use.
Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


UserAssumptions::zeroJalt Method

UserAssumptions::zeroJalt Method
UserAssumptions Class UserAssumptions Members UserAssumptions Methods

Initializes previous assumptions indicators.

C++
void zeroJalt();
Collapse Expand Group

UserAssumptions Methods

Collapse Expand Links
UserAssumptions Class, UserAssumptions Members, UserAssumptions Methods


WageBase Class

WageBase Class
WageBase Constructor WageBase Members WageBase.h Classes

Manages the OASDI wage base projections.

Collapse Expand Class Hierarchy
  WageBaseWageBaseWageBase
C++
class WageBase : public WageBaseGeneral;
Collapse Expand File

File: WageBase.h

Module: PiaData Library

Collapse Expand Remarks

Manages the OASDI wage base projections.

Collapse Expand Group

Classes

Collapse Expand Links
WageBase Constructor, WageBase Members, WageBase.h, Classes


WageBase Members

WageBase Members
WageBase Class Legend Protected Data Members Public Data Members Public Friends Public Methods

The following tables list the members exposed by WageBase.

Collapse Expand Class

WageBase Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
defcomp | Increase in average wage due to deferred comp in 1990.
wageBaseInd | Type of wage base.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
WageBase | Initializes a WageBase, with or without a specified first year.
WageBaseGeneral | Initializes a WageBaseGeneral, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
check | Checks a wage base.
earnLimit | Limits earnings to wage base.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects wage bases.
projectLC | Projects wage bases after a period of ad hoc wage bases.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
WageBase Class, Legend, Protected Data Members, Public Data Members, Public Friends, Public Methods


WageBase Constructor

WageBase Constructor
WageBase Class

Initializes a WageBase, with or without a specified first year.

Collapse Expand Description

There are two versions of the WageBase constructor. The last year of data is specified in both. But if the first year is not specified, it is assumed to be 1937.

Collapse Expand Overload List
Name | Description
WageBase::WageBase (int) | Initializes type of projection to present law, first year is 1937.
WageBase::WageBase (int, int) | Initializes type of projection to present law, first year is specified.
Collapse Expand Class

WageBase Class

Collapse Expand Links
WageBase Class


WageBase::WageBase Constructor (int)

WageBase::WageBase Constructor (int)
WageBase Class WageBase Members WageBase Constructor

Initializes type of projection to present law, first year is 1937.

C++
WageBase(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Last year of projection.
Collapse Expand Group

WageBase Constructor

Collapse Expand Links
WageBase Class, WageBase Members, WageBase Constructor


WageBase::WageBase Constructor (int, int)

WageBase::WageBase Constructor (int, int)
WageBase Class WageBase Members WageBase Constructor

Initializes type of projection to present law, first year is specified.

C++
WageBase(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | First year of data.
int newLastYear | Last year of projection.
Collapse Expand Group

WageBase Constructor

Collapse Expand Links
WageBase Class, WageBase Members, WageBase Constructor


WageBaseGeneral Class

WageBaseGeneral Class
WageBaseGeneral Constructor WageBaseGeneral Data Members WageBaseGeneral Methods WageBaseGeneral Members wbgenrl.h Classes

Ancestor of the classes that manage the wage base projections.

Collapse Expand Class Hierarchy
  WageBaseGeneralWageBaseGeneral
C++
class WageBaseGeneral : public DoubleAnnual;
Collapse Expand File

File: wbgenrl.h

Module: PiaData Library

Collapse Expand Remarks

Child classes are WageBase, WageBaseHI, and WageBaseOldLaw.

Collapse Expand See Also

WageBase, WageBaseHI, WageBaseOldLaw

Collapse Expand Group

Classes

Collapse Expand Links
WageBaseGeneral Constructor, WageBaseGeneral Data Members, WageBaseGeneral Methods, WageBaseGeneral Members, wbgenrl.h, Classes


WageBaseGeneral Members

WageBaseGeneral Members
WageBaseGeneral Class Legend Protected Data Members Public Data Members Public Friends Public Methods

The following tables list the members exposed by WageBaseGeneral.

Collapse Expand Class

WageBaseGeneral Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
defcomp | Increase in average wage due to deferred comp in 1990.
wageBaseInd | Type of wage base.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
WageBaseGeneral | Initializes a WageBaseGeneral, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
check | Checks a wage base.
earnLimit | Limits earnings to wage base.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects wage bases.
projectLC | Projects wage bases after a period of ad hoc wage bases.
~WageBaseGeneral | Destructor.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
WageBaseGeneral Class, Legend, Protected Data Members, Public Data Members, Public Friends, Public Methods


WageBaseGeneral Constructor

WageBaseGeneral Constructor
WageBaseGeneral Class

Initializes a WageBaseGeneral, with or without a specified first year.

Collapse Expand Description

There are two versions of the WageBaseGeneral constructor. The last year of data is specified in both. But if the first year is not specified, it is assumed to be 1937.

Collapse Expand Overload List
Name | Description
WageBaseGeneral::WageBaseGeneral (int, int) | The data array starts in 1937 and goes to the specified last year.
WageBaseGeneral::WageBaseGeneral (int, int, int) | The data array starts and ends in the specified years.
Collapse Expand Class

WageBaseGeneral Class

Collapse Expand Links
WageBaseGeneral Class


WageBaseGeneral::WageBaseGeneral Constructor (int, int)

WageBaseGeneral::WageBaseGeneral Constructor (int, int)
WageBaseGeneral Class WageBaseGeneral Members WageBaseGeneral Constructor

The data array starts in 1937 and goes to the specified last year.

C++
WageBaseGeneral(
    int newWageBaseInd,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newWageBaseInd | Type of wage base.
int newLastYear | Last year of projection.
Collapse Expand Remarks

The type of wage base has the following meanings:

0 | present law OASDI.
1 | prior law (ignore 1990-92 ad hoc increases).
2 | old law (ignore 1979-81 ad hoc increases).
3 | HI.
Collapse Expand Group

WageBaseGeneral Constructor

Collapse Expand Links
WageBaseGeneral Class, WageBaseGeneral Members, WageBaseGeneral Constructor


WageBaseGeneral::WageBaseGeneral Constructor (int, int, int)

WageBaseGeneral::WageBaseGeneral Constructor (int, int, int)
WageBaseGeneral Class WageBaseGeneral Members WageBaseGeneral Constructor

The data array starts and ends in the specified years.

C++
WageBaseGeneral(
    int newWageBaseInd,
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newWageBaseInd | Type of wage base.
int newBaseYear | First year of data.
int newLastYear | Last year of projection.
Collapse Expand Remarks

The type of wage base has the following meanings:

0 | present law OASDI.
1 | prior law (ignore 1990-92 ad hoc increases).
2 | old law (ignore 1979-81 ad hoc increases).
3 | HI.
Collapse Expand Group

WageBaseGeneral Constructor

Collapse Expand Links
WageBaseGeneral Class, WageBaseGeneral Members, WageBaseGeneral Constructor


WageBaseGeneral::~WageBaseGeneral Destructor

WageBaseGeneral::~WageBaseGeneral Destructor
WageBaseGeneral Class WageBaseGeneral Members WageBaseGeneral Class

Destructor.

C++
virtual ~WageBaseGeneral();
Collapse Expand Class

WageBaseGeneral Class

Collapse Expand Links
WageBaseGeneral Class, WageBaseGeneral Members, WageBaseGeneral Class


WageBaseGeneral Data Members

WageBaseGeneral Data Members
WageBaseGeneral Class Legend Protected Data Members

The data members of the WageBaseGeneral class are listed here.

Collapse Expand Class

WageBaseGeneral Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
defcomp | Increase in average wage due to deferred comp in 1990.
wageBaseInd | Type of wage base.
Collapse Expand Links
WageBaseGeneral Class, Legend, Protected Data Members


WageBaseGeneral::defcomp Data Member

WageBaseGeneral::defcomp Data Member
WageBaseGeneral Class WageBaseGeneral Members WageBaseGeneral Data Members

Increase in average wage due to deferred comp in 1990.

C++
const double defcomp;
Collapse Expand Group

WageBaseGeneral Data Members

Collapse Expand Links
WageBaseGeneral Class, WageBaseGeneral Members, WageBaseGeneral Data Members


WageBaseGeneral::wageBaseInd Data Member

WageBaseGeneral::wageBaseInd Data Member
WageBaseGeneral Class WageBaseGeneral Members WageBaseGeneral Data Members

Type of wage base.

C++
int wageBaseInd;
Collapse Expand Remarks

It has the following possible values:

0 | present law OASDI.
1 | prior law (ignore 1990-92 ad hoc increases).
2 | old law (ignore 1979-81 ad hoc increases).
3 | HI.
Collapse Expand Group

WageBaseGeneral Data Members

Collapse Expand Links
WageBaseGeneral Class, WageBaseGeneral Members, WageBaseGeneral Data Members


WageBaseGeneral Methods

WageBaseGeneral Methods
WageBaseGeneral Class Legend Public Methods

The methods of the WageBaseGeneral class are listed here.

Collapse Expand Class

WageBaseGeneral Class

Collapse Expand Public Methods
Name | Description
check | Checks a wage base.
earnLimit | Limits earnings to wage base.
project | Projects wage bases.
projectLC | Projects wage bases after a period of ad hoc wage bases.
Collapse Expand Links
WageBaseGeneral Class, Legend, Public Methods


WageBaseGeneral::check Method

WageBaseGeneral::check Method
WageBaseGeneral Class WageBaseGeneral Members WageBaseGeneral Methods

Checks a wage base.

C++
static void check(
    double baset
);
Collapse Expand Parameters
Parameters | Description
double baset | Value to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BASE2 if wage base is out of range.
Collapse Expand Group

WageBaseGeneral Methods

Collapse Expand Links
WageBaseGeneral Class, WageBaseGeneral Members, WageBaseGeneral Methods


WageBaseGeneral::earnLimit Method

WageBaseGeneral::earnLimit Method
WageBaseGeneral Class WageBaseGeneral Members WageBaseGeneral Methods

Limits earnings to wage base.

C++
void earnLimit(
    DoubleAnnual& earnings1,
    const DoubleAnnual& earnings2
) const;
Collapse Expand Parameters
Parameters | Description
DoubleAnnual& earnings1 | Array of limited earnings.
const DoubleAnnual& earnings2 | Array of unlimited earnings.
Collapse Expand Group

WageBaseGeneral Methods

Collapse Expand Links
WageBaseGeneral Class, WageBaseGeneral Members, WageBaseGeneral Methods


WageBaseGeneral::project Method

WageBaseGeneral::project Method
WageBaseGeneral Class WageBaseGeneral Members WageBaseGeneral Methods

Projects wage bases.

C++
virtual void project(
    const DoubleAnnual& averageWages,
    const DoubleAnnual& cpi,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& averageWages | Average wages for wage base projection.
const DoubleAnnual& cpi | Benefit increases.
int firstYeart | First year of projection.
int lastYeart | Last year of projection.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BASE1 if first year is out of range (only in debug mode).
Collapse Expand Group

WageBaseGeneral Methods

Collapse Expand Links
WageBaseGeneral Class, WageBaseGeneral Members, WageBaseGeneral Methods


WageBaseGeneral::projectLC Method

WageBaseGeneral::projectLC Method
WageBaseGeneral Class WageBaseGeneral Members WageBaseGeneral Methods

Projects wage bases after a period of ad hoc wage bases.

C++
void projectLC(
    const DoubleAnnual& averageWages,
    const DoubleAnnual& cpi,
    int lastYearLC
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& averageWages | Average wages for wage base projection.
const DoubleAnnual& cpi | Benefit increases.
int lastYearLC | Last year of ad hoc wage bases.
Collapse Expand Group

WageBaseGeneral Methods

Collapse Expand Links
WageBaseGeneral Class, WageBaseGeneral Members, WageBaseGeneral Methods


WageBaseHI Class

WageBaseHI Class
WageBaseHI Constructor WageBaseHI Members WageBase.h Classes

Manages the HI wage base projections.

Collapse Expand Class Hierarchy
  WageBaseHIWageBaseHIWageBaseHI
C++
class WageBaseHI : public WageBaseGeneral;
Collapse Expand File

File: WageBase.h

Module: PiaData Library

Collapse Expand Remarks

Manages the HI wage base projections.

Collapse Expand Group

Classes

Collapse Expand Links
WageBaseHI Constructor, WageBaseHI Members, WageBase.h, Classes


WageBaseHI Members

WageBaseHI Members
WageBaseHI Class Legend Protected Data Members Public Data Members Public Friends Public Methods

The following tables list the members exposed by WageBaseHI.

Collapse Expand Class

WageBaseHI Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
defcomp | Increase in average wage due to deferred comp in 1990.
wageBaseInd | Type of wage base.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
WageBaseGeneral | Initializes a WageBaseGeneral, with or without a specified first year.
WageBaseHI | Initializes a WageBaseHI, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
check | Checks a wage base.
earnLimit | Limits earnings to wage base.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects wage bases.
projectLC | Projects wage bases after a period of ad hoc wage bases.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
WageBaseHI Class, Legend, Protected Data Members, Public Data Members, Public Friends, Public Methods


WageBaseHI Constructor

WageBaseHI Constructor
WageBaseHI Class

Initializes a WageBaseHI, with or without a specified first year.

Collapse Expand Description

There are two versions of the WageBaseHI constructor. The last year of data is specified in both. But if the first year is not specified, it is assumed to be 1937.

Collapse Expand Overload List
Name | Description
WageBaseHI::WageBaseHI (int) | Initializes type of projection to HI, first year is 1937.
WageBaseHI::WageBaseHI (int, int) | Initializes type of projection to HI, first year is specified.
Collapse Expand Class

WageBaseHI Class

Collapse Expand Links
WageBaseHI Class


WageBaseHI::WageBaseHI Constructor (int)

WageBaseHI::WageBaseHI Constructor (int)
WageBaseHI Class WageBaseHI Members WageBaseHI Constructor

Initializes type of projection to HI, first year is 1937.

C++
WageBaseHI(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Last year of projection.
Collapse Expand Group

WageBaseHI Constructor

Collapse Expand Links
WageBaseHI Class, WageBaseHI Members, WageBaseHI Constructor


WageBaseHI::WageBaseHI Constructor (int, int)

WageBaseHI::WageBaseHI Constructor (int, int)
WageBaseHI Class WageBaseHI Members WageBaseHI Constructor

Initializes type of projection to HI, first year is specified.

C++
WageBaseHI(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | First year of data.
int newLastYear | Last year of projection.
Collapse Expand Group

WageBaseHI Constructor

Collapse Expand Links
WageBaseHI Class, WageBaseHI Members, WageBaseHI Constructor


WageBaseLC Class

WageBaseLC Class
WageBaseLC Constructor WageBaseLC Methods WageBaseLC Members wbgenrlLC.h Classes

Manages the OASDI wage base projection with law changes.

Collapse Expand Class Hierarchy
  WageBaseLCWageBaseLCWageBaseLCWageBaseLC
C++
class WageBaseLC : public WageBase;
Collapse Expand File

File: wbgenrlLC.h

Module: PiaData Library

Collapse Expand Remarks

Manages the OASDI wage base projection with law changes.

Collapse Expand Group

Classes

Collapse Expand Links
WageBaseLC Constructor, WageBaseLC Methods, WageBaseLC Members, wbgenrlLC.h, Classes


WageBaseLC Members

WageBaseLC Members
WageBaseLC Class Legend Protected Data Members Public Data Members Public Friends Public Methods

The following tables list the members exposed by WageBaseLC.

Collapse Expand Class

WageBaseLC Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
defcomp | Increase in average wage due to deferred comp in 1990.
wageBaseInd | Type of wage base.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
WageBase | Initializes a WageBase, with or without a specified first year.
WageBaseGeneral | Initializes a WageBaseGeneral, with or without a specified first year.
WageBaseLC | Initializes a WageBaseLC, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
check | Checks a wage base.
earnLimit | Limits earnings to wage base.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects oasdi wage bases with law changes.
projectLC | Projects wage bases after a period of ad hoc wage bases.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
WageBaseLC Class, Legend, Protected Data Members, Public Data Members, Public Friends, Public Methods


WageBaseLC Constructor

WageBaseLC Constructor
WageBaseLC Class

Initializes a WageBaseLC, with or without a specified first year.

Collapse Expand Description

There are two versions of the WageBaseLC constructor. The last year of data is specified in both. But if the first year is not specified, it is assumed to be 1937.

Collapse Expand Overload List
Name | Description
WageBaseLC::WageBaseLC (const LawChangeArray&, int) | Initializes type of projection to present law, with the data array starting in 1937.
WageBaseLC::WageBaseLC (const LawChangeArray&, int, int) | Initializes type of projection to present law, with the data array starting in the specified year.
Collapse Expand Class

WageBaseLC Class

Collapse Expand Links
WageBaseLC Class


WageBaseLC::WageBaseLC Constructor (const LawChangeArray&, int)

WageBaseLC::WageBaseLC Constructor (const LawChangeArray&, int)
WageBaseLC Class WageBaseLC Members WageBaseLC Constructor

Initializes type of projection to present law, with the data array starting in 1937.

C++
WageBaseLC(
    const LawChangeArray& newLawChange,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
const LawChangeArray& newLawChange | Law change parameters.
int newLastYear | Last year of projection.
Collapse Expand Group

WageBaseLC Constructor

Collapse Expand Links
WageBaseLC Class, WageBaseLC Members, WageBaseLC Constructor


WageBaseLC::WageBaseLC Constructor (const LawChangeArray&, int, int)

WageBaseLC::WageBaseLC Constructor (const LawChangeArray&, int, int)
WageBaseLC Class WageBaseLC Members WageBaseLC Constructor

Initializes type of projection to present law, with the data array starting in the specified year.

C++
WageBaseLC(
    const LawChangeArray& newLawChange,
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
const LawChangeArray& newLawChange | Law change parameters.
int newBaseYear | First year of data.
int newLastYear | Last year of projection.
Collapse Expand Group

WageBaseLC Constructor

Collapse Expand Links
WageBaseLC Class, WageBaseLC Members, WageBaseLC Constructor


WageBaseLC Methods

WageBaseLC Methods
WageBaseLC Class Legend Public Methods

The methods of the WageBaseLC class are listed here.

Collapse Expand Class

WageBaseLC Class

Collapse Expand Public Methods
Name | Description
project | Projects oasdi wage bases with law changes.
Collapse Expand Links
WageBaseLC Class, Legend, Public Methods


WageBaseLC::project Method

WageBaseLC::project Method
WageBaseLC Class WageBaseLC Members WageBaseLC Methods

Projects oasdi wage bases with law changes.

C++
void project(
    const DoubleAnnual& averageWages,
    const DoubleAnnual& cpi,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& averageWages | Average wages for wage base projection.
const DoubleAnnual& cpi | Benefit increases.
int firstYeart | First year of projection.
int lastYeart | Last year of projection.
Collapse Expand Group

WageBaseLC Methods

Collapse Expand Links
WageBaseLC Class, WageBaseLC Members, WageBaseLC Methods


WageBaseOldLaw Class

WageBaseOldLaw Class
WageBaseOldLaw Constructor WageBaseOldLaw Members WageBase.h Classes

Manages the old-law OASDI wage base projections.

Collapse Expand Class Hierarchy
  WageBaseOldLawWageBaseOldLawWageBaseOldLaw
C++
class WageBaseOldLaw : public WageBaseGeneral;
Collapse Expand File

File: WageBase.h

Module: PiaData Library

Collapse Expand Remarks

Manages the old-law OASDI wage base projections.

Collapse Expand Group

Classes

Collapse Expand Links
WageBaseOldLaw Constructor, WageBaseOldLaw Members, WageBase.h, Classes


WageBaseOldLaw Members

WageBaseOldLaw Members
WageBaseOldLaw Class Legend Protected Data Members Public Data Members Public Friends Public Methods

The following tables list the members exposed by WageBaseOldLaw.

Collapse Expand Class

WageBaseOldLaw Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
defcomp | Increase in average wage due to deferred comp in 1990.
wageBaseInd | Type of wage base.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
WageBaseGeneral | Initializes a WageBaseGeneral, with or without a specified first year.
WageBaseOldLaw | Initializes a WageBaseOldLaw, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
check | Checks a wage base.
earnLimit | Limits earnings to wage base.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects wage bases.
projectLC | Projects wage bases after a period of ad hoc wage bases.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
WageBaseOldLaw Class, Legend, Protected Data Members, Public Data Members, Public Friends, Public Methods


WageBaseOldLaw Constructor

WageBaseOldLaw Constructor
WageBaseOldLaw Class

Initializes a WageBaseOldLaw, with or without a specified first year.

Collapse Expand Description

There are two versions of the WageBaseOldLaw constructor. The last year of data is specified in both. But if the first year is not specified, it is assumed to be 1937.

Collapse Expand Overload List
Name | Description
WageBaseOldLaw::WageBaseOldLaw (int) | Initializes type of projection to old law, first year is 1937.
WageBaseOldLaw::WageBaseOldLaw (int, int) | Initializes type of projection to old law, first year is specified.
Collapse Expand Class

WageBaseOldLaw Class

Collapse Expand Links
WageBaseOldLaw Class


WageBaseOldLaw::WageBaseOldLaw Constructor (int)

WageBaseOldLaw::WageBaseOldLaw Constructor (int)
WageBaseOldLaw Class WageBaseOldLaw Members WageBaseOldLaw Constructor

Initializes type of projection to old law, first year is 1937.

C++
WageBaseOldLaw(
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newLastYear | Last year of projection.
Collapse Expand Group

WageBaseOldLaw Constructor

Collapse Expand Links
WageBaseOldLaw Class, WageBaseOldLaw Members, WageBaseOldLaw Constructor


WageBaseOldLaw::WageBaseOldLaw Constructor (int, int)

WageBaseOldLaw::WageBaseOldLaw Constructor (int, int)
WageBaseOldLaw Class WageBaseOldLaw Members WageBaseOldLaw Constructor

Initializes type of projection to old law, first year is specified.

C++
WageBaseOldLaw(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | First year of data.
int newLastYear | Last year of projection.
Collapse Expand Group

WageBaseOldLaw Constructor

Collapse Expand Links
WageBaseOldLaw Class, WageBaseOldLaw Members, WageBaseOldLaw Constructor


WageBaseOldLawLC Class

WageBaseOldLawLC Class
WageBaseOldLawLC Constructor WageBaseOldLawLC Methods WageBaseOldLawLC Members wbgenrlLC.h Classes

Manages the old-law OASDI wage base projection with law changes.

Collapse Expand Class Hierarchy
  WageBaseOldLawLCWageBaseOldLawLCWageBaseOldLawLCWageBaseOldLawLC
C++
class WageBaseOldLawLC : public WageBaseOldLaw;
Collapse Expand File

File: wbgenrlLC.h

Module: PiaData Library

Collapse Expand Remarks

Manages the old-law OASDI wage base projection with law changes.

Collapse Expand Group

Classes

Collapse Expand Links
WageBaseOldLawLC Constructor, WageBaseOldLawLC Methods, WageBaseOldLawLC Members, wbgenrlLC.h, Classes


WageBaseOldLawLC Members

WageBaseOldLawLC Members
WageBaseOldLawLC Class Legend Protected Data Members Public Data Members Public Friends Public Methods

The following tables list the members exposed by WageBaseOldLawLC.

Collapse Expand Class

WageBaseOldLawLC Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
defcomp | Increase in average wage due to deferred comp in 1990.
wageBaseInd | Type of wage base.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
WageBaseGeneral | Initializes a WageBaseGeneral, with or without a specified first year.
WageBaseOldLaw | Initializes a WageBaseOldLaw, with or without a specified first year.
WageBaseOldLawLC | Initializes a WageBaseOldLawLC, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
check | Checks a wage base.
earnLimit | Limits earnings to wage base.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects 1977 law wage bases with law changes.
projectLC | Projects wage bases after a period of ad hoc wage bases.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
WageBaseOldLawLC Class, Legend, Protected Data Members, Public Data Members, Public Friends, Public Methods


WageBaseOldLawLC Constructor

WageBaseOldLawLC Constructor
WageBaseOldLawLC Class

Initializes a WageBaseOldLawLC, with or without a specified first year.

Collapse Expand Description

There are two versions of the WageBaseOldLawLC constructor. The last year of data is specified in both. But if the first year is not specified, it is assumed to be 1937.

Collapse Expand Overload List
Name | Description
WageBaseOldLawLC::WageBaseOldLawLC (const LawChangeArray&, int) | Initializes type of projection to old law, with the data array starting in 1937.
WageBaseOldLawLC::WageBaseOldLawLC (const LawChangeArray&, int, int) | Initializes type of projection to old law, with the data array starting in the specified year.
Collapse Expand Class

WageBaseOldLawLC Class

Collapse Expand Links
WageBaseOldLawLC Class


WageBaseOldLawLC::WageBaseOldLawLC Constructor (const LawChangeArray&, int)

WageBaseOldLawLC::WageBaseOldLawLC Constructor (const LawChangeArray&, int)
WageBaseOldLawLC Class WageBaseOldLawLC Members WageBaseOldLawLC Constructor

Initializes type of projection to old law, with the data array starting in 1937.

C++
WageBaseOldLawLC(
    const LawChangeArray& newLawChange,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
const LawChangeArray& newLawChange | Law change parameters.
int newLastYear | Last year of projection.
Collapse Expand Group

WageBaseOldLawLC Constructor

Collapse Expand Links
WageBaseOldLawLC Class, WageBaseOldLawLC Members, WageBaseOldLawLC Constructor


WageBaseOldLawLC::WageBaseOldLawLC Constructor (const LawChangeArray&, int, int)

WageBaseOldLawLC::WageBaseOldLawLC Constructor (const LawChangeArray&, int, int)
WageBaseOldLawLC Class WageBaseOldLawLC Members WageBaseOldLawLC Constructor

Initializes type of projection to old law, with the data array starting in the specified year.

C++
WageBaseOldLawLC(
    const LawChangeArray& newLawChange,
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
const LawChangeArray& newLawChange | Law change parameters.
int newBaseYear | First year of data.
int newLastYear | Last year of projection.
Collapse Expand Group

WageBaseOldLawLC Constructor

Collapse Expand Links
WageBaseOldLawLC Class, WageBaseOldLawLC Members, WageBaseOldLawLC Constructor


WageBaseOldLawLC Methods

WageBaseOldLawLC Methods
WageBaseOldLawLC Class Legend Public Methods

The methods of the WageBaseOldLawLC class are listed here.

Collapse Expand Class

WageBaseOldLawLC Class

Collapse Expand Public Methods
Name | Description
project | Projects 1977 law wage bases with law changes.
Collapse Expand Links
WageBaseOldLawLC Class, Legend, Public Methods


WageBaseOldLawLC::project Method

WageBaseOldLawLC::project Method
WageBaseOldLawLC Class WageBaseOldLawLC Members WageBaseOldLawLC Methods

Projects 1977 law wage bases with law changes.

C++
void project(
    const DoubleAnnual& averageWages,
    const DoubleAnnual& cpi,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& averageWages | Average wages for wage base projection.
const DoubleAnnual& cpi | Benefit increases.
int firstYeart | First year of projection.
int lastYeart | Last year of projection.
Collapse Expand Group

WageBaseOldLawLC Methods

Collapse Expand Links
WageBaseOldLawLC Class, WageBaseOldLawLC Members, WageBaseOldLawLC Methods


WageInd Class

WageInd Class
WageInd Methods WageInd Members WageInd.h Classes

Manages the functions required for calculation of a wage indexed Social Security benefit.

Collapse Expand Class Hierarchy
  WageIndWageIndWageInd
C++
class WageInd : public WageIndGeneral;
Collapse Expand File

File: WageInd.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaCalPL.

Collapse Expand See Also

PiaCalPL

Collapse Expand Group

Classes

Collapse Expand Links
WageInd Methods, WageInd Members, WageInd.h, Classes


WageInd Members

WageInd Members
Enumerations WageInd Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by WageInd.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

WageInd Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
windfallInd | Windfall indicator.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
yearsTotal | Number of years of coverage for windfall elimination.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
WageInd | Initializes a WageInd instance.
aimepiaCal | Calculates an AIME PIA under the 1977 law.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
bendPointCal | Projects bend points.
calculate | Computes wage indexed PIA.
deconvertAme | Deconverts AIME from raw PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIndexYearAvgWage | Returns average wage in indexing year.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
realWageGainAdj | Applies real-wage-gain adjustment.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionAime | Calculates portion of aime in each section of pia formula.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setWindfall | Sets windfall indicator in wage-indexed method.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
~WageInd | Destructor.
Collapse Expand Links
Enumerations, WageInd Class, Legend, Protected Data Members, Public Data Members, Public Methods


WageInd::WageInd Constructor

WageInd::WageInd Constructor
WageInd Class WageInd Members WageInd Class

Initializes a WageInd instance.

C++
WageInd(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker basic data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
Collapse Expand Class

WageInd Class

Collapse Expand Links
WageInd Class, WageInd Members, WageInd Class


WageInd::~WageInd Destructor

WageInd::~WageInd Destructor
WageInd Class WageInd Members WageInd Class

Destructor.

C++
virtual ~WageInd();
Collapse Expand Class

WageInd Class

Collapse Expand Links
WageInd Class, WageInd Members, WageInd Class


WageInd Methods

WageInd Methods
WageInd Class Legend Public Methods

The methods of the WageInd class are listed here.

Collapse Expand Class

WageInd Class

Collapse Expand Public Methods
Name | Description
calculate | Computes wage indexed PIA.
isApplicable | Determines applicability of method.
Collapse Expand Links
WageInd Class, Legend, Public Methods


WageInd::calculate Method

WageInd::calculate Method
WageInd Class WageInd Members WageInd Methods

Computes wage indexed PIA.

C++
void calculate();
Collapse Expand Group

WageInd Methods

Collapse Expand Links
WageInd Class, WageInd Members, WageInd Methods


isApplicable Method

isApplicable Method
WageInd Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of this function. The version with no arguments uses stored data, passing it to the static version with two arguments.

Collapse Expand Overload List
Name | Description
WageInd::isApplicable () | Determines applicability of method using stored values.
WageInd::isApplicable (const WorkerDataGeneral&, const PiaData&) | Determines applicability of method using passed values.
Collapse Expand Group

WageInd Methods

Collapse Expand Links
WageInd Methods


WageInd::isApplicable Method ()

WageInd::isApplicable Method ()
WageInd Class WageInd Members isApplicable Method

Determines applicability of method using stored values.

C++
bool isApplicable();
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

This version calls the static version with 2 arguments.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
WageInd Class, WageInd Members, isApplicable Method


WageInd::isApplicable Method (const WorkerDataGeneral&, const PiaData&)

WageInd::isApplicable Method (const WorkerDataGeneral&, const PiaData&)
WageInd Class WageInd Members isApplicable Method

Determines applicability of method using passed values.

C++
static bool isApplicable(
    const WorkerDataGeneral& workerData,
    const PiaData& piaData
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker basic data.
const PiaData& piaData | Pia calculation data.
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

The wage-indexed method is applicable if the eligibility year is greater than 1978 and there are some earnings after 1950. Note that in a totalization case we use the artificially calculated earnings, which are always present after 1950.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
WageInd Class, WageInd Members, isApplicable Method


WageIndGeneral Class

WageIndGeneral Class
WageIndGeneral Data Members WageIndGeneral Methods WageIndGeneral Members WageIndGeneral.h Classes

Parent of all classes that manage the functions required for calculation of a wage indexed Social Security benefit.

Collapse Expand Class Hierarchy
  WageIndGeneralWageIndGeneral
C++
class WageIndGeneral : public PiaMethod;
Collapse Expand File

File: WageIndGeneral.h

Module: PiaData Library

Collapse Expand Remarks

Child classes are WageInd and ChildCareCalc.

Collapse Expand See Also

WageInd, ChildCareCalc

Collapse Expand Group

Classes

Collapse Expand Links
WageIndGeneral Data Members, WageIndGeneral Methods, WageIndGeneral Members, WageIndGeneral.h, Classes


WageIndGeneral Members

WageIndGeneral Members
Enumerations WageIndGeneral Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by WageIndGeneral.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

WageIndGeneral Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
windfallInd | Windfall indicator.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
yearsTotal | Number of years of coverage for windfall elimination.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
WageIndGeneral | Initializes this instance.
aimepiaCal | Calculates an AIME PIA under the 1977 law.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
bendPointCal | Projects bend points.
calculate | Calculates pia and mfb for this method.
deconvertAme | Deconverts AIME from raw PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIndexYearAvgWage | Returns average wage in indexing year.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
isApplicable | Returns true if this method is applicable.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
realWageGainAdj | Applies real-wage-gain adjustment.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionAime | Calculates portion of aime in each section of pia formula.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setWindfall | Sets windfall indicator in wage-indexed method.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
~WageIndGeneral | Destructor.
Collapse Expand Links
Enumerations, WageIndGeneral Class, Legend, Protected Data Members, Public Data Members, Public Methods


WageIndGeneral::WageIndGeneral Constructor

WageIndGeneral::WageIndGeneral Constructor
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Class

Initializes this instance.

C++
WageIndGeneral(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear,
    const std::string& newTitle,
    pia_type newMethod
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
const std::string& newTitle | Title of this method.
pia_type newMethod | Number of this method.
Collapse Expand Class

WageIndGeneral Class

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Class


WageIndGeneral::~WageIndGeneral Destructor

WageIndGeneral::~WageIndGeneral Destructor
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Class

Destructor.

C++
virtual ~WageIndGeneral();
Collapse Expand Class

WageIndGeneral Class

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Class


WageIndGeneral Data Members

WageIndGeneral Data Members
WageIndGeneral Class Legend Protected Data Members Public Data Members

The data members of the WageIndGeneral class are listed here.

Collapse Expand Class

WageIndGeneral Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
windfallInd | Windfall indicator.
yearsTotal | Number of years of coverage for windfall elimination.
Collapse Expand Public Data Members
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
Collapse Expand Links
WageIndGeneral Class, Legend, Protected Data Members, Public Data Members


WageIndGeneral::bendMfb Data Member

WageIndGeneral::bendMfb Data Member
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Data Members

Bend points for MFB formula.

C++
BendMfb bendMfb;
Collapse Expand Group

WageIndGeneral Data Members

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Data Members


WageIndGeneral::bendPia Data Member

WageIndGeneral::bendPia Data Member
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Data Members

Bend points for PIA formula.

C++
BendPia bendPia;
Collapse Expand Group

WageIndGeneral Data Members

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Data Members


WageIndGeneral::indexYearAvgWage Data Member

WageIndGeneral::indexYearAvgWage Data Member
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Data Members

Average wage in indexing year.

C++
double indexYearAvgWage;
Collapse Expand Group

WageIndGeneral Data Members

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Data Members


WageIndGeneral::mfbRealWageGain Data Member

WageIndGeneral::mfbRealWageGain Data Member
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Data Members

MFB at entitlement before real-wage-gain adjustment.

C++
BenefitAmount mfbRealWageGain;
Collapse Expand Group

WageIndGeneral Data Members

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Data Members


WageIndGeneral::percMfb Data Member

WageIndGeneral::percMfb Data Member
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Data Members

Wage-indexed MFB formula percentages.

C++
PercMfb percMfb;
Collapse Expand Group

WageIndGeneral Data Members

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Data Members


WageIndGeneral::percPia Data Member

WageIndGeneral::percPia Data Member
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Data Members

Wage-indexed PIA formula percentages.

C++
PercPia percPia;
Collapse Expand Group

WageIndGeneral Data Members

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Data Members


WageIndGeneral::percWind Data Member

WageIndGeneral::percWind Data Member
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Data Members

Windfall PIA formula percentages.

C++
PercPia percWind;
Collapse Expand Group

WageIndGeneral Data Members

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Data Members


WageIndGeneral::piaRealWageGain Data Member

WageIndGeneral::piaRealWageGain Data Member
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Data Members

PIA at entitlement before real-wage-gain adjustment.

C++
BenefitAmount piaRealWageGain;
Collapse Expand Group

WageIndGeneral Data Members

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Data Members


WageIndGeneral::portionAime Data Member

WageIndGeneral::portionAime Data Member
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Data Members

Portion of AIME in each interval of PIA formula.

C++
PortionAime portionAime;
Collapse Expand Group

WageIndGeneral Data Members

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Data Members


WageIndGeneral::portionPiaElig Data Member

WageIndGeneral::portionPiaElig Data Member
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Data Members

Portion of AIME PIA in each interval of MFB formula.

C++
double portionPiaElig[4];
Collapse Expand Group

WageIndGeneral Data Members

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Data Members


WageIndGeneral::windfallInd Data Member

WageIndGeneral::windfallInd Data Member
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Data Members

Windfall indicator.

C++
WindfallElimType windfallInd;
Collapse Expand Group

WageIndGeneral Data Members

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Data Members


WageIndGeneral::yearsTotal Data Member

WageIndGeneral::yearsTotal Data Member
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Data Members

Number of years of coverage for windfall elimination.

C++
int yearsTotal;
Collapse Expand Group

WageIndGeneral Data Members

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Data Members


WageIndGeneral Methods

WageIndGeneral Methods
WageIndGeneral Class Legend Public Methods

The methods of the WageIndGeneral class are listed here.

Collapse Expand Class

WageIndGeneral Class

Collapse Expand Public Methods
Name | Description
aimepiaCal | Calculates an AIME PIA under the 1977 law.
bendPointCal | Projects bend points.
deconvertAme | Deconverts AIME from raw PIA.
getIndexYearAvgWage | Returns average wage in indexing year.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
realWageGainAdj | Applies real-wage-gain adjustment.
setPortionAime | Calculates portion of aime in each section of pia formula.
setWindfall | Sets windfall indicator in wage-indexed method.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
Collapse Expand Links
WageIndGeneral Class, Legend, Public Methods


WageIndGeneral::aimepiaCal Method

WageIndGeneral::aimepiaCal Method
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Methods

Calculates an AIME PIA under the 1977 law.

C++
double aimepiaCal(
    const PortionAime& portionAime,
    const PercPia& percPiaTemp,
    int year
);
Collapse Expand Parameters
Parameters | Description
const PortionAime& portionAime | Portion of AIME in each benefit formula interval.
const PercPia& percPiaTemp | 3 benefit formula percentages.
int year | Year to use for rounding.
Collapse Expand Returns

The PIA.

Collapse Expand Group

WageIndGeneral Methods

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Methods


WageIndGeneral::bendPointCal Method

WageIndGeneral::bendPointCal Method
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Methods

Projects bend points.

C++
void bendPointCal(
    int eligYear,
    BendPia& bendPiaTemp
) const;
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
BendPia& bendPiaTemp | Benefit formula bend points.
Collapse Expand Remarks

In this version, that means retrieving the bend points from PiaParams::bpPiaOut, where they were projected and stored earlier.

Collapse Expand Group

WageIndGeneral Methods

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Methods


WageIndGeneral::deconvertAme Method

WageIndGeneral::deconvertAme Method
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Methods

Deconverts AIME from raw PIA.

C++
double deconvertAme(
    const BendPia& bendPiaTemp,
    const PercPia& percPiaTemp
) const;
Collapse Expand Parameters
Parameters | Description
const BendPia& bendPiaTemp | Benefit formula bend points (starting with 0).
const PercPia& percPiaTemp | Benefit formula percentages.
Collapse Expand Returns

Deconverted AIME.

Collapse Expand Group

WageIndGeneral Methods

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Methods


WageIndGeneral::getIndexYearAvgWage Method

WageIndGeneral::getIndexYearAvgWage Method
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Methods

Returns average wage in indexing year.

C++
double getIndexYearAvgWage() const;
Collapse Expand Returns

Average wage in indexing year.

Collapse Expand Group

WageIndGeneral Methods

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Methods


WageIndGeneral::getWindfall Method

WageIndGeneral::getWindfall Method
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Methods

Returns windfall indicator in wage-indexed method.

C++
PiaMethod::WindfallElimType getWindfall() const;
Collapse Expand Returns

Windfall indicator in wage-indexed method.

Collapse Expand Group

WageIndGeneral Methods

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Methods


WageIndGeneral::getYearsTotal Method

WageIndGeneral::getYearsTotal Method
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Methods

Returns number of years of coverage for windfall elimination provision.

C++
int getYearsTotal() const;
Collapse Expand Returns

Number of years of coverage for windfall elimination provision.

Collapse Expand Group

WageIndGeneral Methods

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Methods


WageIndGeneral::indexEarnings Method

WageIndGeneral::indexEarnings Method
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Methods

Indexes earnings, using specified average wage series.

C++
void indexEarnings(
    int year1,
    int year2,
    int year3,
    const DoubleAnnual& earnings,
    DoubleAnnual& earnMultiplied,
    DoubleAnnual& earnIndexed,
    const DoubleAnnual& avgWage
);
Collapse Expand Parameters
Parameters | Description
int year1 | First year of earnings.
int year2 | Base year for indexing.
int year3 | Last year of earnings.
const DoubleAnnual& earnings | Unindexed earnings (input).
DoubleAnnual& earnMultiplied | The earnings multiplied by average earnings (output).
DoubleAnnual& earnIndexed | Indexed earnings (output).
const DoubleAnnual& avgWage | Average wage indexing series.
Collapse Expand Group

WageIndGeneral Methods

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Methods


WageIndGeneral::initialize Method

WageIndGeneral::initialize Method
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Methods

Initializes computed values to zero.

C++
void initialize();
Collapse Expand Group

WageIndGeneral Methods

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Methods


WageIndGeneral::realWageGainAdj Method

WageIndGeneral::realWageGainAdj Method
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Methods

Applies real-wage-gain adjustment.

C++
void realWageGainAdj(
    int eligYear
);
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
Collapse Expand Group

WageIndGeneral Methods

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Methods


WageIndGeneral::setPortionAime Method

WageIndGeneral::setPortionAime Method
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Methods

Calculates portion of aime in each section of pia formula.

C++
static void setPortionAime(
    double amesub,
    PortionAime& aimePart,
    const BendPia& bendPiaTemp
);
Collapse Expand Parameters
Parameters | Description
double amesub | Aime to portion.
PortionAime& aimePart | Parts of the aime.
const BendPia& bendPiaTemp | Bend points to use.
Collapse Expand Group

WageIndGeneral Methods

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Methods


WageIndGeneral::setWindfall Method

WageIndGeneral::setWindfall Method
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Methods

Sets windfall indicator in wage-indexed method.

C++
void setWindfall(
    WindfallElimType newWindfall
);
Collapse Expand Parameters
Parameters | Description
WindfallElimType newWindfall | New windfall indicator.
Collapse Expand Group

WageIndGeneral Methods

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Methods


WageIndGeneral::windfallCal Method

WageIndGeneral::windfallCal Method
WageIndGeneral Class WageIndGeneral Members WageIndGeneral Methods

Applies windfall elimination provision for wage-indexed calculation.

C++
void windfallCal();
Collapse Expand Group

WageIndGeneral Methods

Collapse Expand Links
WageIndGeneral Class, WageIndGeneral Members, WageIndGeneral Methods


WageIndLC Class

WageIndLC Class
WageIndLC Methods WageIndLC Members WageIndLC.h Classes

Manages the functions required for calculation of a wage indexed Social Security benefit, with changes from present law.

Collapse Expand Class Hierarchy
  WageIndLCWageIndLCWageIndLCWageIndLC
C++
class WageIndLC : public WageInd;
Collapse Expand File

File: WageIndLC.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaCalLC.

Collapse Expand See Also

PiaCalLC

Collapse Expand Group

Classes

Collapse Expand Links
WageIndLC Methods, WageIndLC Members, WageIndLC.h, Classes


WageIndLC Members

WageIndLC Members
Enumerations WageIndLC Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by WageIndLC.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

WageIndLC Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
windfallInd | Windfall indicator.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
yearsTotal | Number of years of coverage for windfall elimination.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
WageIndLC | Initializes a WageIndLC instance.
aimepiaCal | Calculates an AIME PIA under the 1977 law.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
bendPointCal | Projects bend points.
calculate | Calculates pia and mfb for this method.
calculate | Computes wage indexed PIA.
deconvertAme | Deconverts AIME from raw PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIndexYearAvgWage | Returns average wage in indexing year.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
realWageGainAdj | Applies real-wage-gain adjustment.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionAime | Calculates portion of aime in each section of pia formula.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setWindfall | Sets windfall indicator in wage-indexed method.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
~WageIndLC | Destructor.
Collapse Expand Links
Enumerations, WageIndLC Class, Legend, Protected Data Members, Public Data Members, Public Methods


WageIndLC::WageIndLC Constructor

WageIndLC::WageIndLC Constructor
WageIndLC Class WageIndLC Members WageIndLC Class

Initializes a WageIndLC instance.

C++
WageIndLC(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear,
    const LawChangeArray& newLawChange,
    const DateMoyr& entitDate
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker basic data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
const LawChangeArray& newLawChange | Law-change parameters.
const DateMoyr& entitDate | Entitlement date.
Collapse Expand Class

WageIndLC Class

Collapse Expand Links
WageIndLC Class, WageIndLC Members, WageIndLC Class


WageIndLC::~WageIndLC Destructor

WageIndLC::~WageIndLC Destructor
WageIndLC Class WageIndLC Members WageIndLC Class

Destructor.

C++
~WageIndLC();
Collapse Expand Class

WageIndLC Class

Collapse Expand Links
WageIndLC Class, WageIndLC Members, WageIndLC Class


WageIndLC Methods

WageIndLC Methods
WageIndLC Class Legend Public Methods

The methods of the WageIndLC class are listed here.

Collapse Expand Class

WageIndLC Class

Collapse Expand Public Methods
Name | Description
isApplicable | Determines applicability of method.
Collapse Expand Links
WageIndLC Class, Legend, Public Methods


isApplicable Method

isApplicable Method
WageIndLC Methods

Determines applicability of method.

Collapse Expand Description

There are two versions of this function. The version with no arguments uses stored data, passing it to the static version with four arguments.

Collapse Expand Overload List
Name | Description
WageIndLC::isApplicable () | Determines applicability of method using stored values.
WageIndLC::isApplicable (const WorkerDataGeneral&, const PiaData&, const LawChangeArray&, const DateMoyr&) | Determines applicability of method using passed values.
Collapse Expand Group

WageIndLC Methods

Collapse Expand Links
WageIndLC Methods


WageIndLC::isApplicable Method ()

WageIndLC::isApplicable Method ()
WageIndLC Class WageIndLC Members isApplicable Method

Determines applicability of method using stored values.

C++
bool isApplicable();
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

This version calls the static version with 4 arguments, passing the stored values.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
WageIndLC Class, WageIndLC Members, isApplicable Method


WageIndLC::isApplicable Method (const WorkerDataGeneral&, const PiaData&, const LawChangeArray&, const DateMoyr&)

WageIndLC::isApplicable Method (const WorkerDataGeneral&, const PiaData&, const LawChangeArray&, const DateMoyr&)
WageIndLC Class WageIndLC Members isApplicable Method

Determines applicability of method using passed values.

C++
static bool isApplicable(
    const WorkerDataGeneral& workerData,
    const PiaData& piaData,
    const LawChangeArray& lawChange,
    const DateMoyr& entitDate
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker basic data.
const PiaData& piaData | Pia calculation data.
const LawChangeArray& lawChange | Law-change parameters.
const DateMoyr& entitDate | Entitlement date.
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

Returns WageInd::isApplicable, unless a law change has eliminated this method.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
WageIndLC Class, WageIndLC Members, isApplicable Method


WageIndNonFreeze Class

WageIndNonFreeze Class
WageIndNonFreeze Methods WageIndNonFreeze Members WageIndNonFreeze.h Classes

Manages the functions required for calculation of a wage indexed non-freeze Social Security benefit.

Collapse Expand Class Hierarchy
  WageIndNonFreezeWageIndNonFreezeWageIndNonFreeze
C++
class WageIndNonFreeze : public WageIndGeneral;
Collapse Expand File

File: WageIndNonFreeze.h

Module: PiaData Library

Collapse Expand Remarks

An instance of this class is created in PiaCalPL.

Collapse Expand See Also

PiaCalPL

Collapse Expand Group

Classes

Collapse Expand Links
WageIndNonFreeze Methods, WageIndNonFreeze Members, WageIndNonFreeze.h, Classes


WageIndNonFreeze Members

WageIndNonFreeze Members
Enumerations WageIndNonFreeze Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by WageIndNonFreeze.

Collapse Expand Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.
Collapse Expand Class

WageIndNonFreeze Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
windfallInd | Windfall indicator.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
yearsTotal | Number of years of coverage for windfall elimination.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
WageIndNonFreeze | Initializes a WageIndNonFreeze instance.
aimepiaCal | Calculates an AIME PIA under the 1977 law.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
bendPointCal | Projects bend points.
calculate | Computes wage indexed PIA.
deconvertAme | Deconverts AIME from raw PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIndexYearAvgWage | Returns average wage in indexing year.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
isApplicable | This is the overview for the isApplicable method overload.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
realWageGainAdj | Applies real-wage-gain adjustment.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionAime | Calculates portion of aime in each section of pia formula.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setWindfall | Sets windfall indicator in wage-indexed method.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
~WageIndNonFreeze | Destructor.
Collapse Expand Links
Enumerations, WageIndNonFreeze Class, Legend, Protected Data Members, Public Data Members, Public Methods


WageIndNonFreeze::WageIndNonFreeze Constructor

WageIndNonFreeze::WageIndNonFreeze Constructor
WageIndNonFreeze Class WageIndNonFreeze Members WageIndNonFreeze Class

Initializes a WageIndNonFreeze instance.

C++
WageIndNonFreeze(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker basic data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
int newMaxyear | Maximum year of projection.
Collapse Expand Class

WageIndNonFreeze Class

Collapse Expand Links
WageIndNonFreeze Class, WageIndNonFreeze Members, WageIndNonFreeze Class


WageIndNonFreeze::~WageIndNonFreeze Destructor

WageIndNonFreeze::~WageIndNonFreeze Destructor
WageIndNonFreeze Class WageIndNonFreeze Members WageIndNonFreeze Class

Destructor.

C++
virtual ~WageIndNonFreeze();
Collapse Expand Class

WageIndNonFreeze Class

Collapse Expand Links
WageIndNonFreeze Class, WageIndNonFreeze Members, WageIndNonFreeze Class


WageIndNonFreeze Methods

WageIndNonFreeze Methods
WageIndNonFreeze Class Legend Public Methods

The methods of the WageIndNonFreeze class are listed here.

Collapse Expand Class

WageIndNonFreeze Class

Collapse Expand Public Methods
Name | Description
calculate | Computes wage indexed PIA.
indexEarnings | Indexes earnings, using specified average wage series.
isApplicable | This is the overview for the isApplicable method overload.
Collapse Expand Links
WageIndNonFreeze Class, Legend, Public Methods


WageIndNonFreeze::calculate Method

WageIndNonFreeze::calculate Method
WageIndNonFreeze Class WageIndNonFreeze Members WageIndNonFreeze Methods

Computes wage indexed PIA.

C++
void calculate();
Collapse Expand Group

WageIndNonFreeze Methods

Collapse Expand Links
WageIndNonFreeze Class, WageIndNonFreeze Members, WageIndNonFreeze Methods


WageIndNonFreeze::indexEarnings Method

WageIndNonFreeze::indexEarnings Method
WageIndNonFreeze Class WageIndNonFreeze Members WageIndNonFreeze Methods

Indexes earnings, using specified average wage series.

C++
void indexEarnings(
    int year1,
    int year2,
    int year3,
    const DoubleAnnual& earnings,
    DoubleAnnual& earnMultiplied,
    DoubleAnnual& earnIndexed,
    const DoubleAnnual& avgWage
);
Collapse Expand Parameters
Parameters | Description
int year1 | First year of earnings.
int year2 | Base year for indexing.
int year3 | Last year of earnings.
const DoubleAnnual& earnings | Unindexed earnings (input).
DoubleAnnual& earnMultiplied | The earnings multiplied by average earnings (output).
DoubleAnnual& earnIndexed | Indexed earnings (output).
const DoubleAnnual& avgWage | Average wage indexing series.
Collapse Expand Group

WageIndNonFreeze Methods

Collapse Expand Links
WageIndNonFreeze Class, WageIndNonFreeze Members, WageIndNonFreeze Methods


isApplicable Method

isApplicable Method
WageIndNonFreeze Methods

This is the overview for the isApplicable method overload.

Collapse Expand Overload List
Name | Description
WageIndNonFreeze::isApplicable () | Determines applicability of method using stored values.
WageIndNonFreeze::isApplicable (const WorkerDataGeneral&, const PiaData&) | Determines applicability of method using passed values.
Collapse Expand Group

WageIndNonFreeze Methods

Collapse Expand Links
WageIndNonFreeze Methods


WageIndNonFreeze::isApplicable Method ()

WageIndNonFreeze::isApplicable Method ()
WageIndNonFreeze Class WageIndNonFreeze Members isApplicable Method

Determines applicability of method using stored values.

C++
bool isApplicable();
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

This version calls the static version with 2 arguments.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
WageIndNonFreeze Class, WageIndNonFreeze Members, isApplicable Method


WageIndNonFreeze::isApplicable Method (const WorkerDataGeneral&, const PiaData&)

WageIndNonFreeze::isApplicable Method (const WorkerDataGeneral&, const PiaData&)
WageIndNonFreeze Class WageIndNonFreeze Members isApplicable Method

Determines applicability of method using passed values.

C++
static bool isApplicable(
    const WorkerDataGeneral& workerData,
    const PiaData& piaData
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker basic data.
const PiaData& piaData | Pia calculation data.
Collapse Expand Returns

True if method is applicable.

Collapse Expand Remarks

The wage-indexed method is applicable if the eligibility year is greater than 1978 and there are some earnings after 1950. Note that in a totalization case we use the artificially calculated earnings, which are always present after 1950.

Collapse Expand Group

isApplicable Method

Collapse Expand Links
WageIndNonFreeze Class, WageIndNonFreeze Members, isApplicable Method


WorkerData Class

WorkerData Class
WorkerData Enumerations WorkerData Data Members WorkerData Methods WorkerData Friends WorkerData Members wrkrdata.h Classes

Manages the basic data required to calculate a Social Security benefit.

Collapse Expand Class Hierarchy
  WorkerDataWorkerData
C++
class WorkerData : public WorkerDataGeneral;
Collapse Expand File

File: wrkrdata.h

Module: PiaData Library

Collapse Expand Remarks

It includes extra fields for more detailed calculations and fuller output, compared to the parent class WorkerDataGeneral. In particular, it allows for periods of military service (which could generate wage credits) via MilServDatesVec, railroad earnings via RailRoadData, and a noncovered pension (which could trigger the Windfall Elimination Provision).

Collapse Expand See Also

MilServDatesVec, RailRoadData

Collapse Expand Group

Classes

Collapse Expand Links
WorkerData Enumerations, WorkerData Data Members, WorkerData Methods, WorkerData Friends, WorkerData Members, wrkrdata.h, Classes


WorkerData Members

WorkerData Members
Enumerations WorkerData Class Legend Protected Data Members Public Data Members Public Friends Public Methods

The following tables list the members exposed by WorkerData.

Collapse Expand Enumerations
Name | Description
BitsetMembers | Members of the bitset.
DimLimits | Dimension limits.
DimLimits | Dimension limits.
ben_type | Type of benefit calculation.
Collapse Expand Class

WorkerData Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
earnHi | Worker additional Medicare earnings, 1937 to last year considered.
earnOasdi | Worker earnings, 1937 to last year considered, after any projection of earnings.
maxyear | Maximum year of projection is LASTYEARLR, unless changed.
qclumpyear | Quarters of coverage are summed before 1978, unless changed.
taxType | Type of taxes paid. See TaxRates::taxrateType for the meaning of each bit.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
childCareYears | Child care years, 1937 to WorkerDataGeneral::maxyear.
disabPeriod | Two periods of disability.
milServDatesVec | Military service dates.
qc | Quarters of coverage, 1937 to WorkerDataGeneral::maxyear.
railRoadData | Railroad quarters of coverage and earnings.
ssn | Social security number of wage earner.
Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
WorkerData | Initializes all values.
WorkerDataGeneral | Initializes a WorkerDataGeneral, either with default values or from another WorkerDataGeneral.
anySelfEmp | Returns true if any self-employed taxes.
benefitDate1Check | Checks that date of benefit is in range.
benefitDate2Check | Checks that date of benefit is at or after entitlement.
birth1Check | Checks date of birth in a Statement case.
birth2Check | Checks date of birth in a non-Statement case.
cessation1Check | Checks date of prior disability cessation against date of prior onset.
cessation1OnsetCheck | Checks date of prior disability cessation against date of prior onset.
cessationCheck | Checks date of disability cessation, using stored values.
cessationCheck2 | Checks date of disability cessation, using passed values.
deathCheck | Checks that date of death is after birth.
deathCheck1 | Checks date of death (checks in survivor case for death in 1937 or later).
deathCheck2 | Checks date of death for basic correctness.
deathCheck3 | Checks that date of death is before entitlement, using passed values.
deleteContents | Initializes all variables to default values.
deleteDeathDate | Deletes date of death.
deleteEntDate | Deletes date of entitlement.
deleteOabCessDate | Clears date of OAB cessation prior to most recent DIB.
deleteOabEntDate | Clears date of OAB entitlement prior to most recent DIB entitlement.
deletePubpenDate | Clears date of noncovered pension entitlement.
dis1Check | Checks date of prior disability onset.
disBirthEntCheck | Checks date of disability onset against dates of birth, entitlement, and benefit.
disCheck | Checks date of disability onset.
disDeathCheck | Checks date of disability onset against date of death.
earningsCheck | Checks for no earnings of any type.
entCheck | Checks that current date of entitlement is within bounds.
firstEarnHiYear | Returns first year of Medicare earnings, if any.
getBenefitDate | Returns date of benefit.
getBirthDate | Returns date of birth of worker.
getBlindind | Returns the blind indicator.
getDeathDate | Returns date of death.
getDeceasedOAB | Returns the deceased OAB indicator.
getDeemedind | Returns the deemed insured indicator.
getEarliestEntDate | Returns earliest entitlement date on this record.
getEarnEnable | Returns true if ok to enable earnings entry dialog box.
getEarnHi | Returns Medicare earnings for specified year.
getEarnHiOnly | Returns Medicare earnings for specified year if there are no OASDI earnings; otherwise return zero.
getEarnMS | Returns military service earnings for specified year.
getEarnMS3750 | Returns total military service earnings, 1937-50.
getEarnOasdhi | Returns OASDI plus Medicare earnings for specified year.
getEarnOasdi | Returns OASDI-covered earnings for the specified year.
getEarnRR | Returns railroad earnings for specified year.
getEarnRR3750 | Returns total railroad earnings, 1937-50.
getEntDate | Returns date of entitlement.
getFirstYearEarn | Returns first year of OASDI earnings (0 if none).
getFirstYearEarnHi | Returns first year of HI earnings (0 if none).
getFirstYearMS | Returns first year of military service (0 if none).
getFirstYearRR | Returns first year of railroad (0 if none).
getIbegin | Returns first year of earnings after any projection.
getIdNumber | Returns Social Security number as a number.
getIdString | Returns Social Security number as a string.
getIend | Returns last year of earnings after any projection.
getIndearn | Returns earnings indicator.
getIndms | Returns military service indicator.
getIndrr | Returns railroad indicator.
getJoasdi | Returns type of benefit calculation, including possibly Statement.
getLastYearEarn | Returns last year of OASDI earnings (0 if none).
getLastYearEarnHi | Returns last year of HI earnings (0 if none).
getLastYearMS | Returns last year of military service (0 if none).
getLastYearRR | Returns last year of military service (0 if none).
getMaxyear | Returns maximum year allowed.
getMqge | Returns Medicare-qualified government employment indicator.
getNhaddr | Returns one line of number holder's address.
getNhname | Returns number holder's name.
getOabCessDate | Returns date of cessation of oab entitlement prior to most recent DIB entitlement.
getOabEntDate | Returns date of entitlement to oab prior to most recent DIB entitlement.
getPubpen | Returns monthly noncovered pension.
getPubpenDate | Returns monthly noncovered pension.
getPubpenReservist | Returns monthly noncovered pension after December 1994, after removing reservist pension.
getQcLumpYear | Returns last year of period for which quarters of coverage are entered as a lump sum.
getQcovMS | Returns military service quarters of coverage for specified year.
getQcovMS3750 | Returns total military service quarters of coverage, 1937-50.
getQcovRR | Returns railroad quarters of coverage for specified year.
getQcovRR3750 | Returns total railroad quarters of coverage, 1937-50.
getQcovRR5177 | Returns total railroad quarters of coverage, 1951-77.
getQctot51td | Returns quarters of coverage from 1951 to 1977.
getQctottd | Returns quarters of coverage from 1937 to 1977.
getRecalc | Returns recalculation code.
getReservist | Returns reservist indicator.
getSex | Returns the sex of the worker.
getTaxType | Returns type of taxes for specified year.
getTaxTypeArray | Returns array of type of taxes.
getTotalize | Returns totalization indicator.
getValdi | Returns number of periods of disability.
hasQcsByYear | Returns indicator for QCs prior to 1978 by single year.
ibegin1Check | Checks first year of earnings in a Statement case.
ibegin2Check | Checks first year of earnings in a non-Statement case.
ibeginCheck | Checks for first year of earnings within bounds.
iendCheck | Checks last year of earnings.
isFemale | Return true if person is Sex::sex_type::FEMALE, false otherwise.
isMale | Return true if person is Sex::sex_type::MALE, false otherwise.
isPrimary | Returns primary beneficiary code.
isalive | Returns true if alive at end of year, false otherwise.
isdead | Returns true if dead at end of specified date.
joasdiCheck | Checks type of benefit.
lastQcyr | Returns last year of annual QCs.
needDiCess | Returns true if date of cessation to disability is needed.
needQcsByYear | Returns true if quarters of coverage by year from regular earnings are needed, false otherwise.
need_aw | Returns true if average wage increase assumptions are needed.
need_bases | Returns true if wage base assumptions are needed.
need_bi | Returns true if benefit increase assumptions are needed.
priorent1Check | Checks date of second prior entitlement to disability.
priorentCheck | Checks date of prior entitlement to disability.
pubpenCheck | Checks public pension amount.
pubpenDateCheck | Checks public pension entitlement date.
pubpenDateCheck2 | Checks the date of noncovered pension entitlement for consistency with date of birth and date of death.
qc51tdCheck | Checks summary quarters of coverage, 1951 to 1977.
qcCheck | Checks for correct numbers of QC's.
qctdCheck | Checks summary quarters of coverage, 1937 to 1977.
qctdCheck2 | Checks quarters of coverage to 1977 for consistency, assuming both qcs for 1937-1977 and qcs for 1951-1977 have been set to reasonable values.
setBenefitDate | Sets date of benefit.
setBirthDate | Sets date of birth.
setBlindind | Sets blind indicator.
setCessationDate | Sets date of disability cessation.
setCessationMfb | Sets mfb at disability cessation.
setCessationPia | Sets pia at disability cessation.
setDeathDate | Sets date of death.
setDeceasedOAB | Sets deceased OAB indicator.
setDeemedind | Sets deemed insured indicator.
setEarnHi | Sets Medicare earnings for the specified year.
setEarnOasdi | Sets OASDI-covered earnings.
setEntDate | Sets date of entitlement.
setIbegin | Sets first year of earnings, including any projected earnings. Also sets first year of HI earnings (ignored if indicator for HI earnings is not set before attempting to use HI earnings).
setIend | Sets last year of earnings, including any projected earnings.
setIndearn | Sets earnings indicator.
setIndrr | Sets railroad indicator.
setJoasdi | Sets type of benefit.
setMaxyear | Sets maximum year allowed.
setMqge | Sets mqge indicator.
setNhaddr | Sets one line of address.
setNhname | Sets number holder's name.
setOabCessDate | Sets date of cessation of oab prior to most recent dib.
setOabEntDate | Sets date of oab entitlement prior to most recent dib.
setOnsetDate | Sets date of disability onset.
setPebsData | Initializes some Statement data (no disability and no date of death).
setPebsEarn | Sets last year of Statement earnings when computation year changes, or after a Statement calculation has been done.
setPriorentDate | Sets date of entitlement to disability.
setPriorentDateCheck | Sets date of prior entitlement to disability.
setPubpen | Sets amount of monthly noncovered pension.
setPubpenDate | Sets date of noncovered pension entitlement.
setPubpenReservist | Sets amount of monthly noncovered pension after December 1994, after removing military reservist pension.
setQc51td | Sets summary quarters of coverage, 1951 to 1977.
setQcLumpYear | Sets last year of period for which quarters of coverage are entered as a lump sum.
setQcsByYear | Sets indicator for QCs by year prior to 1978.
setQctd | Sets summary quarters of coverage, 1937 to 1977.
setRecalc | Sets recalculation indicator.
setReservist | Sets reservist indicator.
setSex | Sets the sex of the worker.
setTaxType | Sets type of taxes for the specified year.
setTotalize | Sets totalization indicator.
setValdi | Sets number of periods of disability.
setWaitperDate | Sets first month of waiting period.
taxTypeCheck | Checks type of taxes.
valdi1Check | Checks number of periods of disability in nondisability case.
valdi2Check | Checks number of periods of disability in disability case.
valdiCheck | Checks number of periods of disability, using stored value.
waitpd1Check | Checks first month of prior waiting period.
waitpdCheck | Checks first month of waiting period.
zeroEarn | Zeroes out earnings and quarters of coverage before first year and after last year of specified earnings.
zeroEarnHi | Zeroes out HI earnings before first year and after last year of specified earnings.
zeroEarnOasdi | Zeroes out OASDI earnings before first year and after last year of specified earnings.
zeroOasdi | Zeroes out the type of benefit.
~WorkerData | Destroys this structure.
Collapse Expand Links
Enumerations, WorkerData Class, Legend, Protected Data Members, Public Data Members, Public Friends, Public Methods


WorkerData::WorkerData Constructor

WorkerData::WorkerData Constructor
WorkerData Class WorkerData Members WorkerData Class

Initializes all values.

C++
WorkerData();
Collapse Expand Remarks

Should call WorkerDataGeneral::setMaxyear before constructing any WorkerData.

Collapse Expand Class

WorkerData Class

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Class


WorkerData::~WorkerData Destructor

WorkerData::~WorkerData Destructor
WorkerData Class WorkerData Members WorkerData Class

Destroys this structure.

C++
~WorkerData();
Collapse Expand Class

WorkerData Class

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Class


WorkerData Enumerations

WorkerData Enumerations
Enumerations WorkerData Class Legend

The enumerations of the WorkerData class are listed here.

Collapse Expand Enumerations
Name | Description
DimLimits | Dimension limits.
Collapse Expand Class

WorkerData Class

Collapse Expand Links
Enumerations, WorkerData Class, Legend


WorkerData::DimLimits Enumeration

WorkerData::DimLimits Enumeration
wrkrdata.h WorkerData Enumerations

Dimension limits.

C++
enum DimLimits {
  NUM_ADDRESS_LINES = 3
};
Collapse Expand File

File: wrkrdata.h

Module: PiaData Library

Collapse Expand Members
Members | Description
NUM_ADDRESS_LINES = 3 | Number of address lines.
Collapse Expand Group

WorkerData Enumerations

Collapse Expand Links
wrkrdata.h, WorkerData Enumerations


WorkerData Data Members

WorkerData Data Members
WorkerData Class Legend Protected Data Members Public Data Members

The data members of the WorkerData class are listed here.

Collapse Expand Class

WorkerData Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
earnHi | Worker additional Medicare earnings, 1937 to last year considered.
earnOasdi | Worker earnings, 1937 to last year considered, after any projection of earnings.
taxType | Type of taxes paid. See TaxRates::taxrateType for the meaning of each bit.
Collapse Expand Public Data Members
Name | Description
milServDatesVec | Military service dates.
railRoadData | Railroad quarters of coverage and earnings.
ssn | Social security number of wage earner.
Collapse Expand Links
WorkerData Class, Legend, Protected Data Members, Public Data Members


WorkerData::earnHi Data Member

WorkerData::earnHi Data Member
WorkerData Class WorkerData Members WorkerData Data Members

Worker additional Medicare earnings, 1937 to last year considered.

C++
AverageWage earnHi;
Collapse Expand Group

WorkerData Data Members

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Data Members


WorkerData::earnOasdi Data Member

WorkerData::earnOasdi Data Member
WorkerData Class WorkerData Members WorkerData Data Members

Worker earnings, 1937 to last year considered, after any projection of earnings.

C++
AverageWage earnOasdi;
Collapse Expand Group

WorkerData Data Members

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Data Members


WorkerData::milServDatesVec Data Member

WorkerData::milServDatesVec Data Member
WorkerData Class WorkerData Members WorkerData Data Members

Military service dates.

C++
MilServDatesVec milServDatesVec;
Collapse Expand Group

WorkerData Data Members

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Data Members


WorkerData::railRoadData Data Member

WorkerData::railRoadData Data Member
WorkerData Class WorkerData Members WorkerData Data Members

Railroad quarters of coverage and earnings.

C++
RailRoadData railRoadData;
Collapse Expand Group

WorkerData Data Members

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Data Members


WorkerData::ssn Data Member

WorkerData::ssn Data Member
WorkerData Class WorkerData Members WorkerData Data Members

Social security number of wage earner.

C++
Ssn ssn;
Collapse Expand Group

WorkerData Data Members

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Data Members


WorkerData::taxType Data Member

WorkerData::taxType Data Member
WorkerData Class WorkerData Members WorkerData Data Members

Type of taxes paid.

See TaxRates::taxrateType for the meaning of each bit.

C++
BitAnnual taxType;
Collapse Expand Group

WorkerData Data Members

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Data Members


WorkerData Methods

WorkerData Methods
WorkerData Class Legend Public Methods

The methods of the WorkerData class are listed here.

Collapse Expand Class

WorkerData Class

Collapse Expand Public Methods
Name | Description
anySelfEmp | Returns true if any self-employed taxes.
deleteContents | Initializes all variables to default values.
deleteOabCessDate | Clears date of OAB cessation prior to most recent DIB.
deleteOabEntDate | Clears date of OAB entitlement prior to most recent DIB entitlement.
deletePubpenDate | Clears date of noncovered pension entitlement.
getEarnHi | Returns Medicare earnings for specified year.
getEarnHiOnly | Returns Medicare earnings for specified year if there are no OASDI earnings; otherwise return zero.
getEarnMS | Returns military service earnings for specified year.
getEarnMS3750 | Returns total military service earnings, 1937-50.
getEarnOasdhi | Returns OASDI plus Medicare earnings for specified year.
getEarnOasdi | Returns OASDI-covered earnings for the specified year.
getEarnRR | Returns railroad earnings for specified year.
getEarnRR3750 | Returns total railroad earnings, 1937-50.
getFirstYearEarn | Returns first year of OASDI earnings (0 if none).
getFirstYearEarnHi | Returns first year of HI earnings (0 if none).
getFirstYearMS | Returns first year of military service (0 if none).
getFirstYearRR | Returns first year of railroad (0 if none).
getIdNumber | Returns Social Security number as a number.
getIdString | Returns Social Security number as a string.
getIndms | Returns military service indicator.
getLastYearEarn | Returns last year of OASDI earnings (0 if none).
getLastYearEarnHi | Returns last year of HI earnings (0 if none).
getLastYearMS | Returns last year of military service (0 if none).
getLastYearRR | Returns last year of military service (0 if none).
getNhaddr | Returns one line of number holder's address.
getNhname | Returns number holder's name.
getOabCessDate | Returns date of cessation of oab entitlement prior to most recent DIB entitlement.
getOabEntDate | Returns date of entitlement to oab prior to most recent DIB entitlement.
getPubpen | Returns monthly noncovered pension.
getPubpenDate | Returns monthly noncovered pension.
getPubpenReservist | Returns monthly noncovered pension after December 1994, after removing reservist pension.
getQcovMS | Returns military service quarters of coverage for specified year.
getQcovMS3750 | Returns total military service quarters of coverage, 1937-50.
getQcovRR | Returns railroad quarters of coverage for specified year.
getQcovRR3750 | Returns total railroad quarters of coverage, 1937-50.
getQcovRR5177 | Returns total railroad quarters of coverage, 1951-77.
getTaxType | Returns type of taxes for specified year.
getTaxTypeArray | Returns array of type of taxes.
pubpenDateCheck2 | Checks the date of noncovered pension entitlement for consistency with date of birth and date of death.
setEarnHi | Sets Medicare earnings for the specified year.
setEarnOasdi | Sets OASDI-covered earnings.
setNhaddr | Sets one line of address.
setNhname | Sets number holder's name.
setOabCessDate | Sets date of cessation of oab prior to most recent dib.
setOabEntDate | Sets date of oab entitlement prior to most recent dib.
setPubpen | Sets amount of monthly noncovered pension.
setPubpenDate | Sets date of noncovered pension entitlement.
setPubpenReservist | Sets amount of monthly noncovered pension after December 1994, after removing military reservist pension.
setTaxType | Sets type of taxes for the specified year.
zeroEarn | Zeroes out earnings and quarters of coverage before first year and after last year of specified earnings.
zeroEarnHi | Zeroes out HI earnings before first year and after last year of specified earnings.
zeroEarnOasdi | Zeroes out OASDI earnings before first year and after last year of specified earnings.
Collapse Expand Links
WorkerData Class, Legend, Public Methods


WorkerData::anySelfEmp Method

WorkerData::anySelfEmp Method
WorkerData Class WorkerData Members WorkerData Methods

Returns true if any self-employed taxes.

C++
bool anySelfEmp() const;
Collapse Expand Returns

True if any self-employed taxes.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::deleteContents Method

WorkerData::deleteContents Method
WorkerData Class WorkerData Members WorkerData Methods

Initializes all variables to default values.

C++
void deleteContents();
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::deleteOabCessDate Method

WorkerData::deleteOabCessDate Method
WorkerData Class WorkerData Members WorkerData Methods

Clears date of OAB cessation prior to most recent DIB.

C++
void deleteOabCessDate();
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::deleteOabEntDate Method

WorkerData::deleteOabEntDate Method
WorkerData Class WorkerData Members WorkerData Methods

Clears date of OAB entitlement prior to most recent DIB entitlement.

C++
void deleteOabEntDate();
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::deletePubpenDate Method

WorkerData::deletePubpenDate Method
WorkerData Class WorkerData Members WorkerData Methods

Clears date of noncovered pension entitlement.

C++
void deletePubpenDate();
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getEarnHi Method

WorkerData::getEarnHi Method
WorkerData Class WorkerData Members WorkerData Methods

Returns Medicare earnings for specified year.

C++
double getEarnHi(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of earnings.
Collapse Expand Returns

Medicare earnings for specified year.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getEarnHiOnly Method

WorkerData::getEarnHiOnly Method
WorkerData Class WorkerData Members WorkerData Methods

Returns Medicare earnings for specified year if there are no OASDI earnings; otherwise return zero.

C++
double getEarnHiOnly(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of earnings.
Collapse Expand Returns

Medicare earnings for specified year if there are no OASDI earnings; otherwise return zero.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getEarnMS Method

WorkerData::getEarnMS Method
WorkerData Class WorkerData Members WorkerData Methods

Returns military service earnings for specified year.

C++
double getEarnMS(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which earnings are desired.
Collapse Expand Returns

Military service earnings for specified year.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getEarnMS3750 Method

WorkerData::getEarnMS3750 Method
WorkerData Class WorkerData Members WorkerData Methods

Returns total military service earnings, 1937-50.

C++
double getEarnMS3750() const;
Collapse Expand Returns

Total military service earnings, 1937-50.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getEarnOasdhi Method

WorkerData::getEarnOasdhi Method
WorkerData Class WorkerData Members WorkerData Methods

Returns OASDI plus Medicare earnings for specified year.

C++
double getEarnOasdhi(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of earnings.
Collapse Expand Returns

OASDI plus Medicare earnings for specified year.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getEarnOasdi Method

WorkerData::getEarnOasdi Method
WorkerData Class WorkerData Members WorkerData Methods

Returns OASDI-covered earnings for the specified year.

C++
double getEarnOasdi(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which earnings are desired.
Collapse Expand Returns

OASDI-covered earnings for the specified year.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getEarnRR Method

WorkerData::getEarnRR Method
WorkerData Class WorkerData Members WorkerData Methods

Returns railroad earnings for specified year.

C++
double getEarnRR(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which earnings are desired.
Collapse Expand Returns

Railroad earnings for specified year.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getEarnRR3750 Method

WorkerData::getEarnRR3750 Method
WorkerData Class WorkerData Members WorkerData Methods

Returns total railroad earnings, 1937-50.

C++
double getEarnRR3750() const;
Collapse Expand Returns

Total railroad earnings, 1937-50.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getFirstYearEarn Method

WorkerData::getFirstYearEarn Method
WorkerData Class WorkerData Members WorkerData Methods

Returns first year of OASDI earnings (0 if none).

C++
int getFirstYearEarn() const;
Collapse Expand Returns

First year of OASDI earnings (0 if none).

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getFirstYearEarnHi Method

WorkerData::getFirstYearEarnHi Method
WorkerData Class WorkerData Members WorkerData Methods

Returns first year of HI earnings (0 if none).

C++
int getFirstYearEarnHi() const;
Collapse Expand Returns

First year of HI earnings (0 if none).

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getFirstYearMS Method

WorkerData::getFirstYearMS Method
WorkerData Class WorkerData Members WorkerData Methods

Returns first year of military service (0 if none).

C++
int getFirstYearMS() const;
Collapse Expand Returns

First year of military service (0 if none).

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getFirstYearRR Method

WorkerData::getFirstYearRR Method
WorkerData Class WorkerData Members WorkerData Methods

Returns first year of railroad (0 if none).

C++
int getFirstYearRR() const;
Collapse Expand Returns

First year of railroad (0 if none).

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getIdNumber Method

WorkerData::getIdNumber Method
WorkerData Class WorkerData Members WorkerData Methods

Returns Social Security number as a number.

C++
unsigned long getIdNumber() const;
Collapse Expand Returns

Social Security number as a number.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getIdString Method

WorkerData::getIdString Method
WorkerData Class WorkerData Members WorkerData Methods

Returns Social Security number as a string.

C++
std::string getIdString() const;
Collapse Expand Returns

Social Security number as a string.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getIndms Method

WorkerData::getIndms Method
WorkerData Class WorkerData Members WorkerData Methods

Returns military service indicator.

C++
bool getIndms() const;
Collapse Expand Returns

True if any military service, false otherwise.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getLastYearEarn Method

WorkerData::getLastYearEarn Method
WorkerData Class WorkerData Members WorkerData Methods

Returns last year of OASDI earnings (0 if none).

C++
int getLastYearEarn() const;
Collapse Expand Returns

Last year of OASDI earnings (0 if none).

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getLastYearEarnHi Method

WorkerData::getLastYearEarnHi Method
WorkerData Class WorkerData Members WorkerData Methods

Returns last year of HI earnings (0 if none).

C++
int getLastYearEarnHi() const;
Collapse Expand Returns

Last year of HI earnings (0 if none).

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getLastYearMS Method

WorkerData::getLastYearMS Method
WorkerData Class WorkerData Members WorkerData Methods

Returns last year of military service (0 if none).

C++
int getLastYearMS() const;
Collapse Expand Returns

Last year of military service (0 if none).

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getLastYearRR Method

WorkerData::getLastYearRR Method
WorkerData Class WorkerData Members WorkerData Methods

Returns last year of military service (0 if none).

C++
int getLastYearRR() const;
Collapse Expand Returns

Last year of military service (0 if none).

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getNhaddr Method

WorkerData::getNhaddr Method
WorkerData Class WorkerData Members WorkerData Methods

Returns one line of number holder's address.

C++
std::string getNhaddr(
    int line
) const;
Collapse Expand Parameters
Parameters | Description
int line | Desired line number (0-2).
Collapse Expand Returns

One line of number holder's address.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getNhname Method

WorkerData::getNhname Method
WorkerData Class WorkerData Members WorkerData Methods

Returns number holder's name.

C++
std::string getNhname() const;
Collapse Expand Returns

Number holder's name.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getOabCessDate Method

WorkerData::getOabCessDate Method
WorkerData Class WorkerData Members WorkerData Methods

Returns date of cessation of oab entitlement prior to most recent DIB entitlement.

C++
DateMoyr getOabCessDate() const;
Collapse Expand Returns

The date of cessation of oab entitlement prior to most recent DIB entitlement.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getOabEntDate Method

WorkerData::getOabEntDate Method
WorkerData Class WorkerData Members WorkerData Methods

Returns date of entitlement to oab prior to most recent DIB entitlement.

C++
DateMoyr getOabEntDate() const;
Collapse Expand Returns

The date of entitlement to oab prior to most recent DIB entitlement.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getPubpen Method

WorkerData::getPubpen Method
WorkerData Class WorkerData Members WorkerData Methods

Returns monthly noncovered pension.

C++
float getPubpen() const;
Collapse Expand Returns

Monthly noncovered pension.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getPubpenDate Method

WorkerData::getPubpenDate Method
WorkerData Class WorkerData Members WorkerData Methods

Returns monthly noncovered pension.

C++
DateMoyr getPubpenDate() const;
Collapse Expand Returns

Monthly noncovered pension.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getPubpenReservist Method

WorkerData::getPubpenReservist Method
WorkerData Class WorkerData Members WorkerData Methods

Returns monthly noncovered pension after December 1994, after removing reservist pension.

C++
float getPubpenReservist() const;
Collapse Expand Returns

Monthly noncovered pension after December 1994, after removing reservist pension.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getQcovMS Method

WorkerData::getQcovMS Method
WorkerData Class WorkerData Members WorkerData Methods

Returns military service quarters of coverage for specified year.

C++
unsigned getQcovMS(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which quarters are desired.
Collapse Expand Returns

Military service quarters of coverage for specified year.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getQcovMS3750 Method

WorkerData::getQcovMS3750 Method
WorkerData Class WorkerData Members WorkerData Methods

Returns total military service quarters of coverage, 1937-50.

C++
unsigned getQcovMS3750() const;
Collapse Expand Returns

Total military service quarters of coverage, 1937-50.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getQcovRR Method

WorkerData::getQcovRR Method
WorkerData Class WorkerData Members WorkerData Methods

Returns railroad quarters of coverage for specified year.

C++
unsigned getQcovRR(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which quarters are desired.
Collapse Expand Returns

Railroad quarters of coverage for specified year.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getQcovRR3750 Method

WorkerData::getQcovRR3750 Method
WorkerData Class WorkerData Members WorkerData Methods

Returns total railroad quarters of coverage, 1937-50.

C++
unsigned getQcovRR3750() const;
Collapse Expand Returns

Total railroad quarters of coverage, 1937-50.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getQcovRR5177 Method

WorkerData::getQcovRR5177 Method
WorkerData Class WorkerData Members WorkerData Methods

Returns total railroad quarters of coverage, 1951-77.

C++
unsigned getQcovRR5177() const;
Collapse Expand Returns

Total railroad quarters of coverage, 1951-77.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getTaxType Method

WorkerData::getTaxType Method
WorkerData Class WorkerData Members WorkerData Methods

Returns type of taxes for specified year.

C++
bool getTaxType(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year of taxes.
Collapse Expand Returns

Type of taxes for specified year.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::getTaxTypeArray Method

WorkerData::getTaxTypeArray Method
WorkerData Class WorkerData Members WorkerData Methods

Returns array of type of taxes.

C++
const BitAnnual& getTaxTypeArray() const;
Collapse Expand Returns

Array of type of taxes.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::pubpenDateCheck2 Method

WorkerData::pubpenDateCheck2 Method
WorkerData Class WorkerData Members WorkerData Methods

Checks the date of noncovered pension entitlement for consistency with date of birth and date of death.

C++
void pubpenDateCheck2() const;
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_NONPENDATE1 or PIA_IDS_NONPENDATE2 if public pension entitlement date is out of range (before date of birth or after date of death).
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::setEarnHi Method

WorkerData::setEarnHi Method
WorkerData Class WorkerData Members WorkerData Methods

Sets Medicare earnings for the specified year.

C++
void setEarnHi(
    int year,
    double newEarnHi
);
Collapse Expand Parameters
Parameters | Description
int year | Year of earnings.
double newEarnHi | Amount of earnings.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_EARNHI if earnings are out of range (only in debug mode).
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::setEarnOasdi Method

WorkerData::setEarnOasdi Method
WorkerData Class WorkerData Members WorkerData Methods

Sets OASDI-covered earnings.

C++
void setEarnOasdi(
    int year,
    double newEarn
);
Collapse Expand Parameters
Parameters | Description
int year | Year of earnings.
double newEarn | Amount of earnings.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_EARNPEBS if earnings are out of range (only in debug mode).
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::setNhaddr Method

WorkerData::setNhaddr Method
WorkerData Class WorkerData Members WorkerData Methods

Sets one line of address.

C++
void setNhaddr(
    int line,
    const std::string& newNhaddr
);
Collapse Expand Parameters
Parameters | Description
int line | Line of address to set (0-2).
const std::string& newNhaddr | New address to use.
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::setNhname Method

WorkerData::setNhname Method
WorkerData Class WorkerData Members WorkerData Methods

Sets number holder's name.

C++
void setNhname(
    const std::string& newNhname
);
Collapse Expand Parameters
Parameters | Description
const std::string& newNhname | New name to use.
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::setOabCessDate Method

WorkerData::setOabCessDate Method
WorkerData Class WorkerData Members WorkerData Methods

Sets date of cessation of oab prior to most recent dib.

C++
void setOabCessDate(
    const DateMoyr& datetemp
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& datetemp | The date to use.
Collapse Expand Remarks

Sets date of cessation of oab to specified date, if there is at least one period of disability. Otherwise the oab cessation date is zeroed out (the argument date is ignored).

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DICESS1 if month of cessation is out of range; of type PIA_IDS_DICESS2 if year of cessation is before 1937; of type PIA_IDS_DICESS3 if year of cessation is after maximum allowed. (All only in debug mode, and only if there is at least one period of disability.
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::setOabEntDate Method

WorkerData::setOabEntDate Method
WorkerData Class WorkerData Members WorkerData Methods

Sets date of oab entitlement prior to most recent dib.

C++
void setOabEntDate(
    const DateMoyr& datetemp
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& datetemp | The date to use.
Collapse Expand Remarks

Sets date of entitlement of oab to specified date, if there is at least one period of disability. Otherwise the oab entitlement date is zeroed out (the argument date is ignored).

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DICESS1 if month of entitlement is out of range; of type PIA_IDS_DICESS2 if year of entitlement is before 1937; of type PIA_IDS_DICESS3 if year of entitlement is after maximum allowed. (All only in debug mode, and only if there is at least one period of disability.
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::setPubpen Method

WorkerData::setPubpen Method
WorkerData Class WorkerData Members WorkerData Methods

Sets amount of monthly noncovered pension.

C++
void setPubpen(
    float newPubpen
);
Collapse Expand Parameters
Parameters | Description
float newPubpen | New amount of monthly noncovered pension.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PUBPEN if pension is out of range (only in debug mode).
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::setPubpenDate Method

WorkerData::setPubpenDate Method
WorkerData Class WorkerData Members WorkerData Methods

Sets date of noncovered pension entitlement.

C++
void setPubpenDate(
    const DateMoyr& newPubpenDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& newPubpenDate | New date of noncovered pension entitlement.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_NONPENDATE1 or PIA_IDS_NONPENDATE2 if public pension entitlement date is out of range (before date of birth or after date of death).
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::setPubpenReservist Method

WorkerData::setPubpenReservist Method
WorkerData Class WorkerData Members WorkerData Methods

Sets amount of monthly noncovered pension after December 1994, after removing military reservist pension.

C++
void setPubpenReservist(
    float newPubpen
);
Collapse Expand Parameters
Parameters | Description
float newPubpen | New amount of noncovered pension after December 1994.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PUBPEN if pension is out of range (only in debug mode).
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::setTaxType Method

WorkerData::setTaxType Method
WorkerData Class WorkerData Members WorkerData Methods

Sets type of taxes for the specified year.

C++
void setTaxType(
    int year,
    int newTaxType
);
Collapse Expand Parameters
Parameters | Description
int year | Year of taxes.
int newTaxType | Type of taxes.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_TAXTYPEYR if year is out of range (only in debug mode).
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::zeroEarn Method

WorkerData::zeroEarn Method
WorkerData Class WorkerData Members WorkerData Methods

Zeroes out earnings and quarters of coverage before first year and after last year of specified earnings.

C++
void zeroEarn(
    int ibegint,
    int iendt
);
Collapse Expand Parameters
Parameters | Description
int ibegint | First year of specified earnings.
int iendt | Last year of specified earnings.
Collapse Expand Remarks

Call WorkerDataGeneral::zeroEarn to zero out quarters of coverage, then zeroEarnOasdi and zeroEarnHi to zero out the earnings.

Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::zeroEarnHi Method

WorkerData::zeroEarnHi Method
WorkerData Class WorkerData Members WorkerData Methods

Zeroes out HI earnings before first year and after last year of specified earnings.

C++
void zeroEarnHi(
    int ibegint,
    int iendt
);
Collapse Expand Parameters
Parameters | Description
int ibegint | First year of specified earnings.
int iendt | Last year of specified earnings.
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData::zeroEarnOasdi Method

WorkerData::zeroEarnOasdi Method
WorkerData Class WorkerData Members WorkerData Methods

Zeroes out OASDI earnings before first year and after last year of specified earnings.

C++
void zeroEarnOasdi(
    int ibegint,
    int iendt
);
Collapse Expand Parameters
Parameters | Description
int ibegint | First year of specified earnings.
int iendt | Last year of specified earnings.
Collapse Expand Group

WorkerData Methods

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Methods


WorkerData Friends

WorkerData Friends
WorkerData Class Public Friends

The friends of the WorkerData class are listed here.

Collapse Expand Class

WorkerData Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Links
WorkerData Class, Public Friends


friend class boost::serialization::access Friend

friend class boost::serialization::access Friend
WorkerData Class WorkerData Members WorkerData Friends

Friend class to allow serialization.

C++
friend class boost::serialization::access;
Collapse Expand Group

WorkerData Friends

Collapse Expand Links
WorkerData Class, WorkerData Members, WorkerData Friends


WorkerDataArray Class

WorkerDataArray Class
WorkerDataArray Enumerations WorkerDataArray Data Members WorkerDataArray Methods WorkerDataArray Members WorkerDataArray.h Classes

Manages an array of WorkerData's, representing one family.

Collapse Expand Class Hierarchy
  WorkerDataArray
C++
class WorkerDataArray;
Collapse Expand File

File: WorkerDataArray.h

Module: PiaData Library

Collapse Expand Remarks

Manages an array of WorkerData's, representing one family.

Collapse Expand Group

Classes

Collapse Expand Links
WorkerDataArray Enumerations, WorkerDataArray Data Members, WorkerDataArray Methods, WorkerDataArray Members, WorkerDataArray.h, Classes


WorkerDataArray Members

WorkerDataArray Members
Enumerations WorkerDataArray Class Legend Public Data Members Public Methods

The following tables list the members exposed by WorkerDataArray.

Collapse Expand Enumerations
Name | Description
DimLimits | Constant for dimensioning.
Collapse Expand Class

WorkerDataArray Class

Collapse Expand Public Data Members
Name | Description
workerData | Array of worker's pia data.
Collapse Expand Public Methods
Name | Description
WorkerDataArray | Initializes arrays used in WorkerDataArray.
deleteContents | Resets all values to zero.
famSizeCheck | Checks if family size is ok.
getFamSize | Returns family size (not including worker).
setFamSize | Sets family size (not including worker).
~WorkerDataArray | Releases memory.
Collapse Expand Links
Enumerations, WorkerDataArray Class, Legend, Public Data Members, Public Methods


WorkerDataArray::WorkerDataArray Constructor

WorkerDataArray::WorkerDataArray Constructor
WorkerDataArray Class WorkerDataArray Members WorkerDataArray Class

Initializes arrays used in WorkerDataArray.

C++
WorkerDataArray();
Collapse Expand Remarks

Allocates memory for the WorkerData's.

Collapse Expand Class

WorkerDataArray Class

Collapse Expand Links
WorkerDataArray Class, WorkerDataArray Members, WorkerDataArray Class


WorkerDataArray::~WorkerDataArray Destructor

WorkerDataArray::~WorkerDataArray Destructor
WorkerDataArray Class WorkerDataArray Members WorkerDataArray Class

Releases memory.

C++
~WorkerDataArray();
Collapse Expand Remarks

Deletes memory for the WorkerData's.

Collapse Expand Class

WorkerDataArray Class

Collapse Expand Links
WorkerDataArray Class, WorkerDataArray Members, WorkerDataArray Class


WorkerDataArray Enumerations

WorkerDataArray Enumerations
Enumerations WorkerDataArray Class Legend

The enumerations of the WorkerDataArray class are listed here.

Collapse Expand Enumerations
Name | Description
DimLimits | Constant for dimensioning.
Collapse Expand Class

WorkerDataArray Class

Collapse Expand Links
Enumerations, WorkerDataArray Class, Legend


WorkerDataArray::DimLimits Enumeration

WorkerDataArray::DimLimits Enumeration
WorkerDataArray.h WorkerDataArray Enumerations

Constant for dimensioning.

C++
enum DimLimits {
  MAXFAMSIZE = 15
};
Collapse Expand File

File: WorkerDataArray.h

Module: PiaData Library

Collapse Expand Members
Members | Description
MAXFAMSIZE = 15 | Maximum family size.
Collapse Expand Group

WorkerDataArray Enumerations

Collapse Expand Links
WorkerDataArray.h, WorkerDataArray Enumerations


WorkerDataArray Data Members

WorkerDataArray Data Members
WorkerDataArray Class Legend Public Data Members

The data members of the WorkerDataArray class are listed here.

Collapse Expand Class

WorkerDataArray Class

Collapse Expand Public Data Members
Name | Description
workerData | Array of worker's pia data.
Collapse Expand Links
WorkerDataArray Class, Legend, Public Data Members


WorkerDataArray::workerData Data Member

WorkerDataArray::workerData Data Member
WorkerDataArray Class WorkerDataArray Members WorkerDataArray Data Members

Array of worker's pia data.

C++
WorkerData * workerData[MAXFAMSIZE];
Collapse Expand Group

WorkerDataArray Data Members

Collapse Expand Links
WorkerDataArray Class, WorkerDataArray Members, WorkerDataArray Data Members


WorkerDataArray Methods

WorkerDataArray Methods
WorkerDataArray Class Legend Public Methods

The methods of the WorkerDataArray class are listed here.

Collapse Expand Class

WorkerDataArray Class

Collapse Expand Public Methods
Name | Description
deleteContents | Resets all values to zero.
famSizeCheck | Checks if family size is ok.
getFamSize | Returns family size (not including worker).
setFamSize | Sets family size (not including worker).
Collapse Expand Links
WorkerDataArray Class, Legend, Public Methods


WorkerDataArray::deleteContents Method

WorkerDataArray::deleteContents Method
WorkerDataArray Class WorkerDataArray Members WorkerDataArray Methods

Resets all values to zero.

C++
void deleteContents();
Collapse Expand Remarks

Calls WorkerData::deleteContents for each item in the array.

Collapse Expand Group

WorkerDataArray Methods

Collapse Expand Links
WorkerDataArray Class, WorkerDataArray Members, WorkerDataArray Methods


WorkerDataArray::famSizeCheck Method

WorkerDataArray::famSizeCheck Method
WorkerDataArray Class WorkerDataArray Members WorkerDataArray Methods

Checks if family size is ok.

C++
static void famSizeCheck(
    int newFamSize
);
Collapse Expand Parameters
Parameters | Description
int newFamSize | Family size to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FAMSIZE if out of bounds.
Collapse Expand Group

WorkerDataArray Methods

Collapse Expand Links
WorkerDataArray Class, WorkerDataArray Members, WorkerDataArray Methods


WorkerDataArray::getFamSize Method

WorkerDataArray::getFamSize Method
WorkerDataArray Class WorkerDataArray Members WorkerDataArray Methods

Returns family size (not including worker).

C++
int getFamSize() const;
Collapse Expand Returns

Family size (not including worker).

Collapse Expand Group

WorkerDataArray Methods

Collapse Expand Links
WorkerDataArray Class, WorkerDataArray Members, WorkerDataArray Methods


WorkerDataArray::setFamSize Method

WorkerDataArray::setFamSize Method
WorkerDataArray Class WorkerDataArray Members WorkerDataArray Methods

Sets family size (not including worker).

C++
void setFamSize(
    int newFamSize
);
Collapse Expand Parameters
Parameters | Description
int newFamSize | Family size to use.
Collapse Expand Group

WorkerDataArray Methods

Collapse Expand Links
WorkerDataArray Class, WorkerDataArray Members, WorkerDataArray Methods


WorkerDataGeneral Class

WorkerDataGeneral Class
WorkerDataGeneral Constructor WorkerDataGeneral Enumerations WorkerDataGeneral Data Members WorkerDataGeneral Methods WorkerDataGeneral Friends WorkerDataGeneral Members WorkerDataGeneral.h Classes

The abstract parent of all classes that manage the basic data required to calculate a Social Security benefit.

Collapse Expand Class Hierarchy
  WorkerDataGeneral
C++
class WorkerDataGeneral;
Collapse Expand File

File: WorkerDataGeneral.h

Module: PiaData Library

Collapse Expand Remarks

The child class in this library is WorkerData.

Collapse Expand See Also

WorkerData

Collapse Expand Group

Classes

Collapse Expand Links
WorkerDataGeneral Constructor, WorkerDataGeneral Enumerations, WorkerDataGeneral Data Members, WorkerDataGeneral Methods, WorkerDataGeneral Friends, WorkerDataGeneral Members, WorkerDataGeneral.h, Classes


WorkerDataGeneral Members

WorkerDataGeneral Members
Enumerations WorkerDataGeneral Class Legend Protected Data Members Public Data Members Public Friends Public Methods

The following tables list the members exposed by WorkerDataGeneral.

Collapse Expand Enumerations
Name | Description
BitsetMembers | Members of the bitset.
DimLimits | Dimension limits.
ben_type | Type of benefit calculation.
Collapse Expand Class

WorkerDataGeneral Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
maxyear | Maximum year of projection is LASTYEARLR, unless changed.
qclumpyear | Quarters of coverage are summed before 1978, unless changed.
Collapse Expand Public Data Members
Name | Description
childCareYears | Child care years, 1937 to WorkerDataGeneral::maxyear.
disabPeriod | Two periods of disability.
qc | Quarters of coverage, 1937 to WorkerDataGeneral::maxyear.
Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Name | Description
WorkerDataGeneral | Initializes a WorkerDataGeneral, either with default values or from another WorkerDataGeneral.
anySelfEmp | Returns true if any self-employed taxes.
benefitDate1Check | Checks that date of benefit is in range.
benefitDate2Check | Checks that date of benefit is at or after entitlement.
birth1Check | Checks date of birth in a Statement case.
birth2Check | Checks date of birth in a non-Statement case.
cessation1Check | Checks date of prior disability cessation against date of prior onset.
cessation1OnsetCheck | Checks date of prior disability cessation against date of prior onset.
cessationCheck | Checks date of disability cessation, using stored values.
cessationCheck2 | Checks date of disability cessation, using passed values.
deathCheck | Checks that date of death is after birth.
deathCheck1 | Checks date of death (checks in survivor case for death in 1937 or later).
deathCheck2 | Checks date of death for basic correctness.
deathCheck3 | Checks that date of death is before entitlement, using passed values.
deleteContents | Initializes all variables to default values.
deleteDeathDate | Deletes date of death.
deleteEntDate | Deletes date of entitlement.
dis1Check | Checks date of prior disability onset.
disBirthEntCheck | Checks date of disability onset against dates of birth, entitlement, and benefit.
disCheck | Checks date of disability onset.
disDeathCheck | Checks date of disability onset against date of death.
earningsCheck | Checks for no earnings of any type.
entCheck | Checks that current date of entitlement is within bounds.
firstEarnHiYear | Returns first year of Medicare earnings, if any.
getBenefitDate | Returns date of benefit.
getBirthDate | Returns date of birth of worker.
getBlindind | Returns the blind indicator.
getDeathDate | Returns date of death.
getDeceasedOAB | Returns the deceased OAB indicator.
getDeemedind | Returns the deemed insured indicator.
getEarliestEntDate | Returns earliest entitlement date on this record.
getEarnEnable | Returns true if ok to enable earnings entry dialog box.
getEarnHi | Returns Medicare earnings for specified year.
getEarnHiOnly | Returns Medicare earnings for specified year if there are no OASDI earnings; otherwise return zero.
getEarnMS | Returns military service earnings for specified year.
getEarnMS3750 | Returns total military service earnings, 1937-50.
getEarnOasdhi | Returns OASDI plus Medicare earnings for specified year.
getEarnOasdi | Returns OASDI-covered earnings for the specified year.
getEarnRR | Returns railroad earnings for specified year.
getEarnRR3750 | Returns total railroad earnings, 1937-50.
getEntDate | Returns date of entitlement.
getFirstYearMS | Returns first year of military service (0 if none).
getFirstYearRR | Returns first year of railroad (0 if none).
getIbegin | Returns first year of earnings after any projection.
getIdNumber | Returns Social Security number as a number.
getIdString | Returns Social Security number as a string.
getIend | Returns last year of earnings after any projection.
getIndearn | Returns earnings indicator.
getIndms | Returns military service indicator.
getIndrr | Returns railroad indicator.
getJoasdi | Returns type of benefit calculation, including possibly Statement.
getLastYearMS | Returns last year of military service (0 if none).
getLastYearRR | Returns last year of military service (0 if none).
getMaxyear | Returns maximum year allowed.
getMqge | Returns Medicare-qualified government employment indicator.
getNhaddr | Returns one line of number holder's address.
getNhname | Returns number holder's name.
getOabCessDate | Returns date of cessation of oab entitlement prior to most recent DIB entitlement.
getOabEntDate | Returns date of entitlement to oab prior to most recent DIB entitlement.
getPubpen | Returns monthly noncovered pension.
getPubpenDate | Returns date of entitlement for noncovered pension.
getPubpenReservist | Returns monthly noncovered pension after December 1994, after removing reservist pension.
getQcLumpYear | Returns last year of period for which quarters of coverage are entered as a lump sum.
getQcovMS | Returns military service quarters of coverage for specified year.
getQcovMS3750 | Returns total military service quarters of coverage, 1937-50.
getQcovRR | Returns railroad quarters of coverage for specified year.
getQcovRR3750 | Returns total railroad quarters of coverage, 1937-50.
getQcovRR5177 | Returns total railroad quarters of coverage, 1951-77.
getQctot51td | Returns quarters of coverage from 1951 to 1977.
getQctottd | Returns quarters of coverage from 1937 to 1977.
getRecalc | Returns recalculation code.
getReservist | Returns reservist indicator.
getSex | Returns the sex of the worker.
getTaxType | Returns type of taxes for specified year.
getTotalize | Returns totalization indicator.
getValdi | Returns number of periods of disability.
hasQcsByYear | Returns indicator for QCs prior to 1978 by single year.
ibegin1Check | Checks first year of earnings in a Statement case.
ibegin2Check | Checks first year of earnings in a non-Statement case.
ibeginCheck | Checks for first year of earnings within bounds.
iendCheck | Checks last year of earnings.
isFemale | Return true if person is Sex::sex_type::FEMALE, false otherwise.
isMale | Return true if person is Sex::sex_type::MALE, false otherwise.
isPrimary | Returns primary beneficiary code.
isalive | Returns true if alive at end of year, false otherwise.
isdead | Returns true if dead at end of specified date.
joasdiCheck | Checks type of benefit.
lastQcyr | Returns last year of annual QCs.
needDiCess | Returns true if date of cessation to disability is needed.
needQcsByYear | Returns true if quarters of coverage by year from regular earnings are needed, false otherwise.
need_aw | Returns true if average wage increase assumptions are needed.
need_bases | Returns true if wage base assumptions are needed.
need_bi | Returns true if benefit increase assumptions are needed.
priorent1Check | Checks date of second prior entitlement to disability.
priorentCheck | Checks date of prior entitlement to disability.
pubpenCheck | Checks public pension amount.
pubpenDateCheck | Checks public pension entitlement date.
qc51tdCheck | Checks summary quarters of coverage, 1951 to 1977.
qcCheck | Checks for correct numbers of QC's.
qctdCheck | Checks summary quarters of coverage, 1937 to 1977.
qctdCheck2 | Checks quarters of coverage to 1977 for consistency, assuming both qcs for 1937-1977 and qcs for 1951-1977 have been set to reasonable values.
setBenefitDate | Sets date of benefit.
setBirthDate | Sets date of birth.
setBlindind | Sets blind indicator.
setCessationDate | Sets date of disability cessation.
setCessationMfb | Sets mfb at disability cessation.
setCessationPia | Sets pia at disability cessation.
setDeathDate | Sets date of death.
setDeceasedOAB | Sets deceased OAB indicator.
setDeemedind | Sets deemed insured indicator.
setEarnHi | Sets Medicare earnings for the specified year.
setEarnOasdi | Sets OASDI-covered earnings.
setEntDate | Sets date of entitlement.
setIbegin | Sets first year of earnings, including any projected earnings. Also sets first year of HI earnings (ignored if indicator for HI earnings is not set before attempting to use HI earnings).
setIend | Sets last year of earnings, including any projected earnings.
setIndearn | Sets earnings indicator.
setIndrr | Sets railroad indicator.
setJoasdi | Sets type of benefit.
setMaxyear | Sets maximum year allowed.
setMqge | Sets mqge indicator.
setNhaddr | Sets one line of address.
setNhname | Sets number holder's name.
setOabCessDate | Sets date of cessation of oab prior to most recent dib.
setOabEntDate | Sets date of oab entitlement prior to most recent dib.
setOnsetDate | Sets date of disability onset.
setPebsData | Initializes some Statement data (no disability and no date of death).
setPebsEarn | Sets last year of Statement earnings when computation year changes, or after a Statement calculation has been done.
setPriorentDate | Sets date of entitlement to disability.
setPriorentDateCheck | Sets date of prior entitlement to disability.
setPubpen | Sets amount of monthly noncovered pension.
setPubpenDate | Sets date of monthly noncovered pension entitlement.
setPubpenReservist | Sets amount of monthly noncovered pension after December 1994, after removing military reservist pension.
setQc51td | Sets summary quarters of coverage, 1951 to 1977.
setQcLumpYear | Sets last year of period for which quarters of coverage are entered as a lump sum.
setQcsByYear | Sets indicator for QCs by year prior to 1978.
setQctd | Sets summary quarters of coverage, 1937 to 1977.
setRecalc | Sets recalculation indicator.
setReservist | Sets reservist indicator.
setSex | Sets the sex of the worker.
setTaxType | Sets type of taxes for the specified year.
setTotalize | Sets totalization indicator.
setValdi | Sets number of periods of disability.
setWaitperDate | Sets first month of waiting period.
taxTypeCheck | Checks type of taxes.
valdi1Check | Checks number of periods of disability in nondisability case.
valdi2Check | Checks number of periods of disability in disability case.
valdiCheck | Checks number of periods of disability, using stored value.
waitpd1Check | Checks first month of prior waiting period.
waitpdCheck | Checks first month of waiting period.
zeroEarn | Zeroes out earnings and quarters of coverage before first year and after last year of specified earnings.
zeroEarnHi | Zeroes out HI earnings before first year and after last year of specified earnings.
zeroEarnOasdi | Zeroes out OASDI earnings before first year and after last year of specified earnings.
zeroOasdi | Zeroes out the type of benefit.
~WorkerDataGeneral | Destroys this structure.
Collapse Expand Links
Enumerations, WorkerDataGeneral Class, Legend, Protected Data Members, Public Data Members, Public Friends, Public Methods


WorkerDataGeneral Constructor

WorkerDataGeneral Constructor
WorkerDataGeneral Class

Initializes a WorkerDataGeneral, either with default values or from another WorkerDataGeneral.

Collapse Expand Description

There are two versions of the WorkerDataGeneral constructor. The one without any arguments initializes all the data fields to default values. The one with another WorkerDataGeneral argument copies the values from that argument to this instance.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::WorkerDataGeneral () | Initializes a WorkerDataGeneral structure with default values.
WorkerDataGeneral::WorkerDataGeneral (const WorkerDataGeneral&) | Initializes a WorkerDataGeneral structure by copying all the data in the argument to this instance.
Collapse Expand Class

WorkerDataGeneral Class

Collapse Expand Links
WorkerDataGeneral Class


WorkerDataGeneral::WorkerDataGeneral Constructor ()

WorkerDataGeneral::WorkerDataGeneral Constructor ()
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Constructor

Initializes a WorkerDataGeneral structure with default values.

C++
WorkerDataGeneral();
Collapse Expand Remarks

Should call WorkerDataGeneral::setMaxyear before constructing any WorkerDataGeneral.

Collapse Expand Group

WorkerDataGeneral Constructor

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Constructor


WorkerDataGeneral::WorkerDataGeneral Constructor (const WorkerDataGeneral&)

WorkerDataGeneral::WorkerDataGeneral Constructor (const WorkerDataGeneral&)
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Constructor

Initializes a WorkerDataGeneral structure by copying all the data in the argument to this instance.

C++
WorkerDataGeneral(
    const WorkerDataGeneral& workerData
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | The structure to copy from.
Collapse Expand Remarks

Should call WorkerDataGeneral::setMaxyear before constructing any WorkerDataGeneral.

Collapse Expand Group

WorkerDataGeneral Constructor

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Constructor


WorkerDataGeneral::~WorkerDataGeneral Destructor

WorkerDataGeneral::~WorkerDataGeneral Destructor
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Class

Destroys this structure.

C++
virtual ~WorkerDataGeneral();
Collapse Expand Class

WorkerDataGeneral Class

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Class


WorkerDataGeneral Enumerations

WorkerDataGeneral Enumerations
Enumerations WorkerDataGeneral Class Legend

The enumerations of the WorkerDataGeneral class are listed here.

Collapse Expand Enumerations
Name | Description
BitsetMembers | Members of the bitset.
DimLimits | Dimension limits.
ben_type | Type of benefit calculation.
Collapse Expand Class

WorkerDataGeneral Class

Collapse Expand Links
Enumerations, WorkerDataGeneral Class, Legend


WorkerDataGeneral::BitsetMembers Enumeration

WorkerDataGeneral::BitsetMembers Enumeration
WorkerDataGeneral.h WorkerDataGeneral Enumerations

Members of the bitset.

C++
enum BitsetMembers {
  SEX_BIT = 0,
  RECALC_BIT,
  TOTALIZE_BIT,
  DEEMED_BIT,
  BLIND_BIT,
  MQGE_BIT,
  RESERVIST_BIT,
  INDEARN_BIT,
  INDRR_BIT,
  QCSBYYEAR_BIT,
  DEADOAB_BIT
};
Collapse Expand File

File: WorkerDataGeneral.h

Module: PiaData Library

Collapse Expand Members
Members | Description
SEX_BIT = 0 | The sex of worker (see Sex::sex_type).
RECALC_BIT | Recalculation code.
TOTALIZE_BIT | Totalization code.
DEEMED_BIT | Indicator for deemed insured status possible.
BLIND_BIT | Indicator for disability insured status allowed based on fully insured status only because of blindness.
MQGE_BIT | Medicare earnings code.
RESERVIST_BIT | Indicator for military reservist pension.
INDEARN_BIT | Indicator for regular earnings available.
INDRR_BIT | Indicator for railroad qcs and earnings available.
QCSBYYEAR_BIT | Indicator for QCs by single year prior to 1978.
DEADOAB_BIT | Indicator for deceased OAB in survivor case.
Collapse Expand Group

WorkerDataGeneral Enumerations

Collapse Expand Links
WorkerDataGeneral.h, WorkerDataGeneral Enumerations


WorkerDataGeneral::DimLimits Enumeration

WorkerDataGeneral::DimLimits Enumeration
WorkerDataGeneral.h WorkerDataGeneral Enumerations

Dimension limits.

C++
enum DimLimits {
  NUM_DISAB_PERIODS = 2
};
Collapse Expand File

File: WorkerDataGeneral.h

Module: PiaData Library

Collapse Expand Members
Members | Description
NUM_DISAB_PERIODS = 2 | Number of periods of disability.
Collapse Expand Group

WorkerDataGeneral Enumerations

Collapse Expand Links
WorkerDataGeneral.h, WorkerDataGeneral Enumerations


WorkerDataGeneral::ben_type Enumeration

WorkerDataGeneral::ben_type Enumeration
WorkerDataGeneral.h WorkerDataGeneral Enumerations

Type of benefit calculation.

C++
enum ben_type {
  NO_BEN,
  OLD_AGE,
  SURVIVOR,
  DISABILITY,
  PEBS_CALC
};
Collapse Expand File

File: WorkerDataGeneral.h

Module: PiaData Library

Collapse Expand Members
Members | Description
NO_BEN | No benefit calculation.
OLD_AGE | Old-age benefit calculation.
SURVIVOR | Survivor benefit calculation.
DISABILITY | Disability benefit calculation.
PEBS_CALC | Statement benefit calculation.
Collapse Expand Group

WorkerDataGeneral Enumerations

Collapse Expand Links
WorkerDataGeneral.h, WorkerDataGeneral Enumerations


WorkerDataGeneral Data Members

WorkerDataGeneral Data Members
WorkerDataGeneral Class Legend Protected Data Members Public Data Members

The data members of the WorkerDataGeneral class are listed here.

Collapse Expand Class

WorkerDataGeneral Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
maxyear | Maximum year of projection is LASTYEARLR, unless changed.
qclumpyear | Quarters of coverage are summed before 1978, unless changed.
Collapse Expand Public Data Members
Name | Description
childCareYears | Child care years, 1937 to WorkerDataGeneral::maxyear.
disabPeriod | Two periods of disability.
qc | Quarters of coverage, 1937 to WorkerDataGeneral::maxyear.
Collapse Expand Links
WorkerDataGeneral Class, Legend, Protected Data Members, Public Data Members


WorkerDataGeneral::childCareYears Data Member

WorkerDataGeneral::childCareYears Data Member
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Data Members

Child care years, 1937 to WorkerDataGeneral::maxyear.

C++
BitAnnual childCareYears;
Collapse Expand Group

WorkerDataGeneral Data Members

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Data Members


WorkerDataGeneral::disabPeriod Data Member

WorkerDataGeneral::disabPeriod Data Member
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Data Members

Two periods of disability.

C++
DisabPeriod disabPeriod[NUM_DISAB_PERIODS];
Collapse Expand Group

WorkerDataGeneral Data Members

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Data Members


WorkerDataGeneral::maxyear Data Member

WorkerDataGeneral::maxyear Data Member
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Data Members
C++
int maxyear;
Collapse Expand Description

Maximum year of projection is LASTYEARLR, unless changed.

Collapse Expand Group

WorkerDataGeneral Data Members

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Data Members


WorkerDataGeneral::qc Data Member

WorkerDataGeneral::qc Data Member
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Data Members

Quarters of coverage, 1937 to WorkerDataGeneral::maxyear.

C++
QcArray qc;
Collapse Expand Group

WorkerDataGeneral Data Members

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Data Members


WorkerDataGeneral::qclumpyear Data Member

WorkerDataGeneral::qclumpyear Data Member
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Data Members
C++
int qclumpyear;
Collapse Expand Description

Quarters of coverage are summed before 1978, unless changed.

Collapse Expand Group

WorkerDataGeneral Data Members

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Data Members


WorkerDataGeneral Methods

WorkerDataGeneral Methods
WorkerDataGeneral Class Legend Public Methods

The methods of the WorkerDataGeneral class are listed here.

Collapse Expand Class

WorkerDataGeneral Class

Collapse Expand Public Methods
Name | Description
anySelfEmp | Returns true if any self-employed taxes.
benefitDate1Check | Checks that date of benefit is in range.
benefitDate2Check | Checks that date of benefit is at or after entitlement.
birth1Check | Checks date of birth in a Statement case.
birth2Check | Checks date of birth in a non-Statement case.
cessation1Check | Checks date of prior disability cessation against date of prior onset.
cessation1OnsetCheck | Checks date of prior disability cessation against date of prior onset.
cessationCheck | Checks date of disability cessation, using stored values.
cessationCheck2 | Checks date of disability cessation, using passed values.
deathCheck | Checks that date of death is after birth.
deathCheck1 | Checks date of death (checks in survivor case for death in 1937 or later).
deathCheck2 | Checks date of death for basic correctness.
deathCheck3 | Checks that date of death is before entitlement, using passed values.
deleteContents | Initializes all variables to default values.
deleteDeathDate | Deletes date of death.
deleteEntDate | Deletes date of entitlement.
dis1Check | Checks date of prior disability onset.
disBirthEntCheck | Checks date of disability onset against dates of birth, entitlement, and benefit.
disCheck | Checks date of disability onset.
disDeathCheck | Checks date of disability onset against date of death.
earningsCheck | Checks for no earnings of any type.
entCheck | Checks that current date of entitlement is within bounds.
firstEarnHiYear | Returns first year of Medicare earnings, if any.
getBenefitDate | Returns date of benefit.
getBirthDate | Returns date of birth of worker.
getBlindind | Returns the blind indicator.
getDeathDate | Returns date of death.
getDeceasedOAB | Returns the deceased OAB indicator.
getDeemedind | Returns the deemed insured indicator.
getEarliestEntDate | Returns earliest entitlement date on this record.
getEarnEnable | Returns true if ok to enable earnings entry dialog box.
getEarnHi | Returns Medicare earnings for specified year.
getEarnHiOnly | Returns Medicare earnings for specified year if there are no OASDI earnings; otherwise return zero.
getEarnMS | Returns military service earnings for specified year.
getEarnMS3750 | Returns total military service earnings, 1937-50.
getEarnOasdhi | Returns OASDI plus Medicare earnings for specified year.
getEarnOasdi | Returns OASDI-covered earnings for the specified year.
getEarnRR | Returns railroad earnings for specified year.
getEarnRR3750 | Returns total railroad earnings, 1937-50.
getEntDate | Returns date of entitlement.
getFirstYearMS | Returns first year of military service (0 if none).
getFirstYearRR | Returns first year of railroad (0 if none).
getIbegin | Returns first year of earnings after any projection.
getIdNumber | Returns Social Security number as a number.
getIdString | Returns Social Security number as a string.
getIend | Returns last year of earnings after any projection.
getIndearn | Returns earnings indicator.
getIndms | Returns military service indicator.
getIndrr | Returns railroad indicator.
getJoasdi | Returns type of benefit calculation, including possibly Statement.
getLastYearMS | Returns last year of military service (0 if none).
getLastYearRR | Returns last year of military service (0 if none).
getMaxyear | Returns maximum year allowed.
getMqge | Returns Medicare-qualified government employment indicator.
getNhaddr | Returns one line of number holder's address.
getNhname | Returns number holder's name.
getOabCessDate | Returns date of cessation of oab entitlement prior to most recent DIB entitlement.
getOabEntDate | Returns date of entitlement to oab prior to most recent DIB entitlement.
getPubpen | Returns monthly noncovered pension.
getPubpenDate | Returns date of entitlement for noncovered pension.
getPubpenReservist | Returns monthly noncovered pension after December 1994, after removing reservist pension.
getQcLumpYear | Returns last year of period for which quarters of coverage are entered as a lump sum.
getQcovMS | Returns military service quarters of coverage for specified year.
getQcovMS3750 | Returns total military service quarters of coverage, 1937-50.
getQcovRR | Returns railroad quarters of coverage for specified year.
getQcovRR3750 | Returns total railroad quarters of coverage, 1937-50.
getQcovRR5177 | Returns total railroad quarters of coverage, 1951-77.
getQctot51td | Returns quarters of coverage from 1951 to 1977.
getQctottd | Returns quarters of coverage from 1937 to 1977.
getRecalc | Returns recalculation code.
getReservist | Returns reservist indicator.
getSex | Returns the sex of the worker.
getTaxType | Returns type of taxes for specified year.
getTotalize | Returns totalization indicator.
getValdi | Returns number of periods of disability.
hasQcsByYear | Returns indicator for QCs prior to 1978 by single year.
ibegin1Check | Checks first year of earnings in a Statement case.
ibegin2Check | Checks first year of earnings in a non-Statement case.
ibeginCheck | Checks for first year of earnings within bounds.
iendCheck | Checks last year of earnings.
isFemale | Return true if person is Sex::sex_type::FEMALE, false otherwise.
isMale | Return true if person is Sex::sex_type::MALE, false otherwise.
isPrimary | Returns primary beneficiary code.
isalive | Returns true if alive at end of year, false otherwise.
isdead | Returns true if dead at end of specified date.
joasdiCheck | Checks type of benefit.
lastQcyr | Returns last year of annual QCs.
needDiCess | Returns true if date of cessation to disability is needed.
needQcsByYear | Returns true if quarters of coverage by year from regular earnings are needed, false otherwise.
need_aw | Returns true if average wage increase assumptions are needed.
need_bases | Returns true if wage base assumptions are needed.
need_bi | Returns true if benefit increase assumptions are needed.
priorent1Check | Checks date of second prior entitlement to disability.
priorentCheck | Checks date of prior entitlement to disability.
pubpenCheck | Checks public pension amount.
pubpenDateCheck | Checks public pension entitlement date.
qc51tdCheck | Checks summary quarters of coverage, 1951 to 1977.
qcCheck | Checks for correct numbers of QC's.
qctdCheck | Checks summary quarters of coverage, 1937 to 1977.
qctdCheck2 | Checks quarters of coverage to 1977 for consistency, assuming both qcs for 1937-1977 and qcs for 1951-1977 have been set to reasonable values.
setBenefitDate | Sets date of benefit.
setBirthDate | Sets date of birth.
setBlindind | Sets blind indicator.
setCessationDate | Sets date of disability cessation.
setCessationMfb | Sets mfb at disability cessation.
setCessationPia | Sets pia at disability cessation.
setDeathDate | Sets date of death.
setDeceasedOAB | Sets deceased OAB indicator.
setDeemedind | Sets deemed insured indicator.
setEarnHi | Sets Medicare earnings for the specified year.
setEarnOasdi | Sets OASDI-covered earnings.
setEntDate | Sets date of entitlement.
setIbegin | Sets first year of earnings, including any projected earnings. Also sets first year of HI earnings (ignored if indicator for HI earnings is not set before attempting to use HI earnings).
setIend | Sets last year of earnings, including any projected earnings.
setIndearn | Sets earnings indicator.
setIndrr | Sets railroad indicator.
setJoasdi | Sets type of benefit.
setMaxyear | Sets maximum year allowed.
setMqge | Sets mqge indicator.
setNhaddr | Sets one line of address.
setNhname | Sets number holder's name.
setOabCessDate | Sets date of cessation of oab prior to most recent dib.
setOabEntDate | Sets date of oab entitlement prior to most recent dib.
setOnsetDate | Sets date of disability onset.
setPebsData | Initializes some Statement data (no disability and no date of death).
setPebsEarn | Sets last year of Statement earnings when computation year changes, or after a Statement calculation has been done.
setPriorentDate | Sets date of entitlement to disability.
setPriorentDateCheck | Sets date of prior entitlement to disability.
setPubpen | Sets amount of monthly noncovered pension.
setPubpenDate | Sets date of monthly noncovered pension entitlement.
setPubpenReservist | Sets amount of monthly noncovered pension after December 1994, after removing military reservist pension.
setQc51td | Sets summary quarters of coverage, 1951 to 1977.
setQcLumpYear | Sets last year of period for which quarters of coverage are entered as a lump sum.
setQcsByYear | Sets indicator for QCs by year prior to 1978.
setQctd | Sets summary quarters of coverage, 1937 to 1977.
setRecalc | Sets recalculation indicator.
setReservist | Sets reservist indicator.
setSex | Sets the sex of the worker.
setTaxType | Sets type of taxes for the specified year.
setTotalize | Sets totalization indicator.
setValdi | Sets number of periods of disability.
setWaitperDate | Sets first month of waiting period.
taxTypeCheck | Checks type of taxes.
valdi1Check | Checks number of periods of disability in nondisability case.
valdi2Check | Checks number of periods of disability in disability case.
valdiCheck | Checks number of periods of disability, using stored value.
waitpd1Check | Checks first month of prior waiting period.
waitpdCheck | Checks first month of waiting period.
zeroEarn | Zeroes out earnings and quarters of coverage before first year and after last year of specified earnings.
zeroEarnHi | Zeroes out HI earnings before first year and after last year of specified earnings.
zeroEarnOasdi | Zeroes out OASDI earnings before first year and after last year of specified earnings.
zeroOasdi | Zeroes out the type of benefit.
Collapse Expand Links
WorkerDataGeneral Class, Legend, Public Methods


WorkerDataGeneral::anySelfEmp Method

WorkerDataGeneral::anySelfEmp Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns true if any self-employed taxes.

C++
virtual bool anySelfEmp() const = 0;
Collapse Expand Returns

True if any self-employed taxes.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


benefitDate1Check Method

benefitDate1Check Method
WorkerDataGeneral Methods

Checks that date of benefit is in range.

Collapse Expand Description

There are two versions of the benefitDate1Check function. The version with no arguments calls the version with one argument, passing the stored benefit date.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::benefitDate1Check () | Checks that date of benefit is in range, using stored value.
WorkerDataGeneral::benefitDate1Check (const DateMoyr&) | Checks that date of benefit is in range, using passed value.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::benefitDate1Check Method ()

WorkerDataGeneral::benefitDate1Check Method ()
WorkerDataGeneral Class WorkerDataGeneral Members benefitDate1Check Method

Checks that date of benefit is in range, using stored value.

C++
void benefitDate1Check() const;
Collapse Expand Remarks

This version passes the stored benefit date to the static version with one argument.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BENDATE2 if month is out of range. PiaException of type PIA_IDS_BENDATE3 if year is before 1940. PiaException of type PIA_IDS_BENDATE4 if year is after maximum allowed.
Collapse Expand Group

benefitDate1Check Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, benefitDate1Check Method


WorkerDataGeneral::benefitDate1Check Method (const DateMoyr&)

WorkerDataGeneral::benefitDate1Check Method (const DateMoyr&)
WorkerDataGeneral Class WorkerDataGeneral Members benefitDate1Check Method

Checks that date of benefit is in range, using passed value.

C++
static void benefitDate1Check(
    const DateMoyr& datetemp
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& datetemp | The date to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BENDATE2 if month is out of range. PiaException of type PIA_IDS_BENDATE3 if year is before 1940. PiaException of type PIA_IDS_BENDATE4 if year is after maximum allowed.
Collapse Expand Group

benefitDate1Check Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, benefitDate1Check Method


benefitDate2Check Method

benefitDate2Check Method
WorkerDataGeneral Methods

Checks that date of benefit is at or after entitlement.

Collapse Expand Description

There are two versions of the benefitDate2Check function. The version with no arguments calls the version with two arguments, passing the stored entitlement date and benefit date.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::benefitDate2Check () | Checks that date of benefit is at or after entitlement, using stored values.
WorkerDataGeneral::benefitDate2Check (const DateMoyr&, const DateMoyr&) | Checks that date of benefit is at or after entitlement, using passed values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::benefitDate2Check Method ()

WorkerDataGeneral::benefitDate2Check Method ()
WorkerDataGeneral Class WorkerDataGeneral Members benefitDate2Check Method

Checks that date of benefit is at or after entitlement, using stored values.

C++
void benefitDate2Check() const;
Collapse Expand Remarks

This version passes the stored values to the static version with 2 arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BENDATE1 if benefit date is before entitlement date.
Collapse Expand Group

benefitDate2Check Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, benefitDate2Check Method


WorkerDataGeneral::benefitDate2Check Method (const DateMoyr&, const DateMoyr&)

WorkerDataGeneral::benefitDate2Check Method (const DateMoyr&, const DateMoyr&)
WorkerDataGeneral Class WorkerDataGeneral Members benefitDate2Check Method

Checks that date of benefit is at or after entitlement, using passed values.

C++
static void benefitDate2Check(
    const DateMoyr& entDatet,
    const DateMoyr& benefitDatet
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& entDatet | The date of entitlement.
const DateMoyr& benefitDatet | The date of benefit.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BENDATE1 if benefit date is before entitlement date.
Collapse Expand Group

benefitDate2Check Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, benefitDate2Check Method


birth1Check Method

birth1Check Method
WorkerDataGeneral Methods

Checks date of birth in a Statement case.

Collapse Expand Description

There are two versions of the birth1Check function. The version with one argument calls the version with two arguments, passing the stored birth date.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::birth1Check (const boost::gregorian::date&, int) | Checks date of birth in a Statement case, using passed values.
WorkerDataGeneral::birth1Check (int) | Checks date of birth in a Statement case, using stored values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::birth1Check Method (const boost::gregorian::date&, int)

WorkerDataGeneral::birth1Check Method (const boost::gregorian::date&, int)
WorkerDataGeneral Class WorkerDataGeneral Members birth1Check Method

Checks date of birth in a Statement case, using passed values.

C++
static void birth1Check(
    const boost::gregorian::date& datetemp,
    int istartt
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& datetemp | The date to check.
int istartt | Starting year of projections.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BIRTH3 if month of birth is out of range; of type PIA_IDS_BIRTH4 if day of birth is out of range; of type PIA_IDS_BIRTH2 if year of birth is before 1800; of type PIA_IDS_BIRTH1 if year of birth is in current year or later.
Collapse Expand Group

birth1Check Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, birth1Check Method


WorkerDataGeneral::birth1Check Method (int)

WorkerDataGeneral::birth1Check Method (int)
WorkerDataGeneral Class WorkerDataGeneral Members birth1Check Method

Checks date of birth in a Statement case, using stored values.

C++
void birth1Check(
    int istartt
) const;
Collapse Expand Parameters
Parameters | Description
int istartt | Starting year of projections.
Collapse Expand Remarks

This version passes stored values to the static version with 2 arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BIRTH3 if month of birth is out of range; of type PIA_IDS_BIRTH4 if day of birth is out of range; of type PIA_IDS_BIRTH2 if year of birth is before 1800; of type PIA_IDS_BIRTH1 if year of birth is in current year or later.
Collapse Expand Group

birth1Check Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, birth1Check Method


birth2Check Method

birth2Check Method
WorkerDataGeneral Methods

Checks date of birth in a non-Statement case.

Collapse Expand Description

There are two versions of the birth2Check function. The version with no arguments calls the version with one argument, passing the stored birth date.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::birth2Check () | Checks date of birth in a non-Statement case, using stored values.
WorkerDataGeneral::birth2Check (const boost::gregorian::date&) | Checks date of birth in a non-Statement case, using passed values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::birth2Check Method ()

WorkerDataGeneral::birth2Check Method ()
WorkerDataGeneral Class WorkerDataGeneral Members birth2Check Method

Checks date of birth in a non-Statement case, using stored values.

C++
void birth2Check() const;
Collapse Expand Remarks

This version passes stored values to the static version with 1 argument.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BIRTH3 if month of birth is out of range; of type PIA_IDS_BIRTH4 if day of birth is out of range; of type PIA_IDS_BIRTH2 if year of birth is before 1800; of type PIA_IDS_BIRTH5 if year of birth is after maximum allowed.
Collapse Expand Group

birth2Check Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, birth2Check Method


WorkerDataGeneral::birth2Check Method (const boost::gregorian::date&)

WorkerDataGeneral::birth2Check Method (const boost::gregorian::date&)
WorkerDataGeneral Class WorkerDataGeneral Members birth2Check Method

Checks date of birth in a non-Statement case, using passed values.

C++
static void birth2Check(
    const boost::gregorian::date& datetemp
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& datetemp | The date to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BIRTH3 if month of birth is out of range; of type PIA_IDS_BIRTH4 if day of birth is out of range; of type PIA_IDS_BIRTH2 if year of birth is before 1800; of type PIA_IDS_BIRTH5 if year of birth is after maximum allowed.
Collapse Expand Group

birth2Check Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, birth2Check Method


cessation1Check Method

cessation1Check Method
WorkerDataGeneral Methods

Checks date of prior disability cessation against date of prior onset.

Collapse Expand Description

There are two versions of the cessation1Check function. The version with no arguments calls the version with three arguments, passing the stored cessation, onset, and entitlement dates.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::cessation1Check () | Checks date of prior disability cessation against date of prior onset, using stored values.
WorkerDataGeneral::cessation1Check (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&) | Checks date of prior disability cessation against date of prior onset, using passed values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::cessation1Check Method ()

WorkerDataGeneral::cessation1Check Method ()
WorkerDataGeneral Class WorkerDataGeneral Members cessation1Check Method

Checks date of prior disability cessation against date of prior onset, using stored values.

C++
void cessation1Check() const;
Collapse Expand Remarks

This version passes stored values to the static version with 3 arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DICESS4 if disability cessation before onset. PiaException of type PIA_IDS_DICESS5 if prior disability cessation after second entitlement.
Collapse Expand Group

cessation1Check Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, cessation1Check Method


WorkerDataGeneral::cessation1Check Method (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&)

WorkerDataGeneral::cessation1Check Method (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&)
WorkerDataGeneral Class WorkerDataGeneral Members cessation1Check Method

Checks date of prior disability cessation against date of prior onset, using passed values.

C++
static void cessation1Check(
    const DateMoyr& cessation1Datet,
    const boost::gregorian::date& onset1Datet,
    const DateMoyr& entDatet
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& cessation1Datet | The date of prior disability cessation.
const boost::gregorian::date& onset1Datet | The date of prior disability onset.
const DateMoyr& entDatet | The date of current entitlement.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DICESS4 if disability cessation before onset. PiaException of type PIA_IDS_DICESS5 if prior disability cessation after second entitlement.
Collapse Expand Group

cessation1Check Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, cessation1Check Method


WorkerDataGeneral::cessation1OnsetCheck Method

WorkerDataGeneral::cessation1OnsetCheck Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks date of prior disability cessation against date of prior onset.

C++
static void cessation1OnsetCheck(
    const DateMoyr& cessation1Datet,
    const boost::gregorian::date& onset1Datet
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& cessation1Datet | The date of prior disability cessation.
const boost::gregorian::date& onset1Datet | The date of prior disability onset.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DICESS4 if disability cessation before onset.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::cessationCheck Method

WorkerDataGeneral::cessationCheck Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks date of disability cessation, using stored values.

C++
void cessationCheck() const;
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DICESS4 if cesation is before onset; of type PIA_IDS_DICESS6 if entitlement is before cessation; of type PIA_IDS_DICESS7 if cessation is after death in a survivor case.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::cessationCheck2 Method

WorkerDataGeneral::cessationCheck2 Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks date of disability cessation, using passed values.

C++
static void cessationCheck2(
    const DateMoyr& cessationDatet,
    const boost::gregorian::date& onsetDatet,
    const boost::gregorian::date& deathDatet,
    const DateMoyr& entDatet,
    ben_type ioasdi
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& cessationDatet | The date of disability cessation.
const boost::gregorian::date& onsetDatet | The date of disability onset.
const boost::gregorian::date& deathDatet | The date of death.
const DateMoyr& entDatet | The date of entitlement.
ben_type ioasdi | Type of benefit.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DICESS4 if cesation is before onset. PiaException of type PIA_IDS_DICESS6 if entitlement is before cessation. PiaException of type PIA_IDS_DICESS7 if cessation is after death in a survivor case.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


deathCheck Method

deathCheck Method
WorkerDataGeneral Methods

Checks that date of death is after birth.

Collapse Expand Description

There are two versions of the deathCheck function. The version with no arguments calls the version with two arguments, passing the stored death and birth dates.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::deathCheck () | Checks that date of death is after birth, using stored values.
WorkerDataGeneral::deathCheck (const boost::gregorian::date&, const boost::gregorian::date&) | Checks that date of death is after birth, using passed values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::deathCheck Method ()

WorkerDataGeneral::deathCheck Method ()
WorkerDataGeneral Class WorkerDataGeneral Members deathCheck Method

Checks that date of death is after birth, using stored values.

C++
void deathCheck() const;
Collapse Expand Remarks

This version passes stored values to the static version with 2 arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DEATH5 if death of worker is before birth.
Collapse Expand Group

deathCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, deathCheck Method


WorkerDataGeneral::deathCheck Method (const boost::gregorian::date&, const boost::gregorian::date&)

WorkerDataGeneral::deathCheck Method (const boost::gregorian::date&, const boost::gregorian::date&)
WorkerDataGeneral Class WorkerDataGeneral Members deathCheck Method

Checks that date of death is after birth, using passed values.

C++
static void deathCheck(
    const boost::gregorian::date& deathDatet,
    const boost::gregorian::date& birthDatet
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& deathDatet | The date of death.
const boost::gregorian::date& birthDatet | The date of birth.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DEATH5 if death of worker is before birth.
Collapse Expand Group

deathCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, deathCheck Method


WorkerDataGeneral::deathCheck1 Method

WorkerDataGeneral::deathCheck1 Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks date of death (checks in survivor case for death in 1937 or later).

C++
static void deathCheck1(
    const boost::gregorian::date& dateTemp,
    ben_type ioasdi
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& dateTemp | The date to check.
ben_type ioasdi | Type of benefit.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DEATH3 if death before 1937 in a survivor case.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::deathCheck2 Method

WorkerDataGeneral::deathCheck2 Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks date of death for basic correctness.

C++
static void deathCheck2(
    const boost::gregorian::date& datetemp
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& datetemp | The date to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DEATH1 if month of death is out of range. PiaException of type PIA_IDS_DEATH2 if year of death is after maximum allowed.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::deathCheck3 Method

WorkerDataGeneral::deathCheck3 Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks that date of death is before entitlement, using passed values.

C++
static void deathCheck3(
    const boost::gregorian::date& deathDatet,
    const DateMoyr& entDatet
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& deathDatet | The date of death.
const DateMoyr& entDatet | The date of survivor's entitlement.
Collapse Expand Remarks

Assumes that this is a survivor case. Should be called for each survivor's date of entitlement.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DEATH4 if entitlement of survivor is before death of worker.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::deleteContents Method

WorkerDataGeneral::deleteContents Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Initializes all variables to default values.

C++
virtual void deleteContents();
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::deleteDeathDate Method

WorkerDataGeneral::deleteDeathDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Deletes date of death.

C++
void deleteDeathDate();
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::deleteEntDate Method

WorkerDataGeneral::deleteEntDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Deletes date of entitlement.

C++
void deleteEntDate();
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


dis1Check Method

dis1Check Method
WorkerDataGeneral Methods

Checks date of prior disability onset.

Collapse Expand Description

There are two versions of the dis1Check function. The version with no arguments calls the version with four arguments, passing the stored disability information and birth date.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::dis1Check () | Checks date of prior disability onset, using stored values.
WorkerDataGeneral::dis1Check (const boost::gregorian::date&, const boost::gregorian::date&, int, const boost::gregorian::date&) | Checks date of prior disability onset, using passed values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::dis1Check Method ()

WorkerDataGeneral::dis1Check Method ()
WorkerDataGeneral Class WorkerDataGeneral Members dis1Check Method

Checks date of prior disability onset, using stored values.

C++
void dis1Check() const;
Collapse Expand Remarks

This version passes stored values to the static version with 4 arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ONSET5 if disability is before birth; of type PIA_IDS_ONSET8 if prior disability is after current disability.
Collapse Expand Group

dis1Check Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, dis1Check Method


WorkerDataGeneral::dis1Check Method (const boost::gregorian::date&, const boost::gregorian::date&, int, const boost::gregorian::date&)

WorkerDataGeneral::dis1Check Method (const boost::gregorian::date&, const boost::gregorian::date&, int, const boost::gregorian::date&)
WorkerDataGeneral Class WorkerDataGeneral Members dis1Check Method

Checks date of prior disability onset, using passed values.

C++
static void dis1Check(
    const boost::gregorian::date& onset1Datet,
    const boost::gregorian::date& onsetDatet,
    int valdit,
    const boost::gregorian::date& birthDatet
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& onset1Datet | The date of prior disability onset.
const boost::gregorian::date& onsetDatet | The date of most recent disability onset.
int valdit | Number of periods of disability.
const boost::gregorian::date& birthDatet | The date of birth.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ONSET5 if disability is before birth; of type PIA_IDS_ONSET8 if prior disability is after current disability.
Collapse Expand Group

dis1Check Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, dis1Check Method


WorkerDataGeneral::disBirthEntCheck Method

WorkerDataGeneral::disBirthEntCheck Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks date of disability onset against dates of birth, entitlement, and benefit.

C++
static void disBirthEntCheck(
    const boost::gregorian::date& onsetDatet,
    const boost::gregorian::date& birthDatet,
    ben_type ioasdi,
    const DateMoyr& entDatet,
    const DateMoyr& benDatet
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& onsetDatet | The date of onset.
const boost::gregorian::date& birthDatet | The date of birth.
ben_type ioasdi | Type of benefit.
const DateMoyr& entDatet | The date of entitlement.
const DateMoyr& benDatet | The date of benefit.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ONSET5 if disability is before birth. PiaException of type PIA_IDS_ONSET6 if disability is after entitlement.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


disCheck Method

disCheck Method
WorkerDataGeneral Methods

Checks date of disability onset.

Collapse Expand Description

There are two versions of the disCheck function. The version with no arguments calls the version with seven arguments, passing the stored disability information and birth and death dates.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::disCheck () | Checks date of disability onset, using stored values.
WorkerDataGeneral::disCheck (const boost::gregorian::date&, const boost::gregorian::date&, int, const boost::gregorian::date&, ben_type, const DateMoyr&, const DateMoyr&) | Checks date of disability onset, using passed values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::disCheck Method ()

WorkerDataGeneral::disCheck Method ()
WorkerDataGeneral Class WorkerDataGeneral Members disCheck Method

Checks date of disability onset, using stored values.

C++
void disCheck() const;
Collapse Expand Remarks

This version passes stored values to the static version with 7 arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ONSET5 if disability is before birth; of type PIA_IDS_ONSET6 if disability is after entitlement in a life case or after benefit date in a survivor case; of type PIA_IDS_ONSET7 if death of worker is before onset in a survivor case.
Collapse Expand Group

disCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, disCheck Method


WorkerDataGeneral::disCheck Method (const boost::gregorian::date&, const boost::gregorian::date&, int, const boost::gregorian::date&, ben_type, const DateMoyr&, const DateMoyr&)

WorkerDataGeneral::disCheck Method (const boost::gregorian::date&, const boost::gregorian::date&, int, const boost::gregorian::date&, ben_type, const DateMoyr&, const DateMoyr&)
WorkerDataGeneral Class WorkerDataGeneral Members disCheck Method

Checks date of disability onset, using passed values.

C++
static void disCheck(
    const boost::gregorian::date& onsetDatet,
    const boost::gregorian::date& deathDatet,
    int valdit,
    const boost::gregorian::date& birthDatet,
    ben_type ioasdi,
    const DateMoyr& entDatet,
    const DateMoyr& benDatet
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& onsetDatet | The date of onset.
const boost::gregorian::date& deathDatet | The date of death.
int valdit | Number of periods of disability.
const boost::gregorian::date& birthDatet | The date of birth.
ben_type ioasdi | Type of benefit.
const DateMoyr& entDatet | The date of entitlement.
const DateMoyr& benDatet | The date of benefit.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ONSET5 if disability is before birth; of type PIA_IDS_ONSET6 if disability is after entitlement in a life case or after benefit date in a survivor case; of type PIA_IDS_ONSET7 if death of worker is before onset in a survivor case.
Collapse Expand Group

disCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, disCheck Method


WorkerDataGeneral::disDeathCheck Method

WorkerDataGeneral::disDeathCheck Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks date of disability onset against date of death.

C++
static void disDeathCheck(
    const boost::gregorian::date& onsetDatet,
    const boost::gregorian::date& deathDatet,
    ben_type ioasdi
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& onsetDatet | The date of onset.
const boost::gregorian::date& deathDatet | The date of death.
ben_type ioasdi | The type of benefit.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ONSET7 if death before onset in a survivor case.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


earningsCheck Method

earningsCheck Method
WorkerDataGeneral Methods

Checks for no earnings of any type.

Collapse Expand Description

There are two versions of the earningsCheck function. The version with no arguments calls the version with three arguments, passing the stored earnings information.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::earningsCheck (bool, bool, bool) | Checks for no earnings of any type, using passed values.
WorkerDataGeneral::earningsCheck () | Checks for no earnings of any type, using stored values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::earningsCheck Method ()

WorkerDataGeneral::earningsCheck Method ()
WorkerDataGeneral Class WorkerDataGeneral Members earningsCheck Method

Checks for no earnings of any type, using stored values.

C++
void earningsCheck() const;
Collapse Expand Remarks

This version passes stored valuesto the static version with 3 arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BEGIN6 if there are no regular, railroad, or military service earnings.
Collapse Expand Group

earningsCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, earningsCheck Method


WorkerDataGeneral::earningsCheck Method (bool, bool, bool)

WorkerDataGeneral::earningsCheck Method (bool, bool, bool)
WorkerDataGeneral Class WorkerDataGeneral Members earningsCheck Method

Checks for no earnings of any type, using passed values.

C++
static void earningsCheck(
    bool indEarn,
    bool indRailroad,
    bool indMS
);
Collapse Expand Parameters
Parameters | Description
bool indEarn | True if there are any regular OASDI earnings.
bool indRailroad | True if there are any railroad earnings.
bool indMS | True if there are any military service wage credits.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BEGIN6 if there are no regular, railroad, or military service earnings.
Collapse Expand Group

earningsCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, earningsCheck Method


entCheck Method

entCheck Method
WorkerDataGeneral Methods

Checks that current date of entitlement is within bounds.

Collapse Expand Description

There are two versions of the entCheck function. The version with no arguments calls the version with one argument, passing the stored entitlement date.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::entCheck () | Checks that current date of entitlement is within bounds, using stored values.
WorkerDataGeneral::entCheck (const DateMoyr&) | Checks that current date of entitlement is within bounds, using passed values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::entCheck Method ()

WorkerDataGeneral::entCheck Method ()
WorkerDataGeneral Class WorkerDataGeneral Members entCheck Method

Checks that current date of entitlement is within bounds, using stored values.

C++
void entCheck() const;
Collapse Expand Remarks

This version passes stored values to the static version with 1 argument.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ENT1 if month of entitlement is out of range; of type PIA_IDS_ENT2 if year of entitlement is before 1940; of type PIA_IDS_ENT3 if year of entitlement is after maximum allowed.
Collapse Expand Group

entCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, entCheck Method


WorkerDataGeneral::entCheck Method (const DateMoyr&)

WorkerDataGeneral::entCheck Method (const DateMoyr&)
WorkerDataGeneral Class WorkerDataGeneral Members entCheck Method

Checks that current date of entitlement is within bounds, using passed values.

C++
static void entCheck(
    const DateMoyr& datetemp
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& datetemp | The date to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_ENT1 if month of entitlement is out of range; of type PIA_IDS_ENT2 if year of entitlement is before 1940; of type PIA_IDS_ENT3 if year of entitlement is after maximum allowed.
Collapse Expand Group

entCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, entCheck Method


WorkerDataGeneral::firstEarnHiYear Method

WorkerDataGeneral::firstEarnHiYear Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns first year of Medicare earnings, if any.

C++
int firstEarnHiYear() const;
Collapse Expand Returns

First year of Medicare earnings, if any.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getBenefitDate Method

WorkerDataGeneral::getBenefitDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns date of benefit.

C++
const DateMoyr& getBenefitDate() const;
Collapse Expand Returns

The date of benefit.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getBirthDate Method

WorkerDataGeneral::getBirthDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns date of birth of worker.

C++
const boost::gregorian::date& getBirthDate() const;
Collapse Expand Returns

The date of birth of worker.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getBlindind Method

WorkerDataGeneral::getBlindind Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns the blind indicator.

C++
bool getBlindind() const;
Collapse Expand Returns

True if blind, false otherwise.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getDeathDate Method

WorkerDataGeneral::getDeathDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns date of death.

C++
const boost::gregorian::date& getDeathDate() const;
Collapse Expand Returns

The date of death.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getDeceasedOAB Method

WorkerDataGeneral::getDeceasedOAB Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns the deceased OAB indicator.

C++
bool getDeceasedOAB() const;
Collapse Expand Returns

True if the deceased worker was an OAB before death.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getDeemedind Method

WorkerDataGeneral::getDeemedind Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns the deemed insured indicator.

C++
bool getDeemedind() const;
Collapse Expand Returns

True if the deemed insured status provision applies, false otherwise.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getEarliestEntDate Method

WorkerDataGeneral::getEarliestEntDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns earliest entitlement date on this record.

C++
const DateMoyr& getEarliestEntDate() const;
Collapse Expand Returns

Earliest entitlement date on this record.

Collapse Expand Remarks

If there are multiple periods of disability, take the first disability entitlement date. Otherwise, for old-age or survivor with a prior disability, use the prior disability entitlement. Finally, for disability entitlement with only one period of disability, or old-age or survivor with no disability, use current entitlement.

Note that for a survivor with no prior disability, this returns a date of zero. This function should probably not be used in that case.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getEarnEnable Method

WorkerDataGeneral::getEarnEnable Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns true if ok to enable earnings entry dialog box.

C++
bool getEarnEnable() const;
Collapse Expand Returns

True if ok to enable earnings entry dialog box.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getEarnHi Method

WorkerDataGeneral::getEarnHi Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns Medicare earnings for specified year.

C++
virtual double getEarnHi(
    int
) const = 0;
Collapse Expand Returns

Medicare earnings for specified year.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getEarnHiOnly Method

WorkerDataGeneral::getEarnHiOnly Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns Medicare earnings for specified year if there are no OASDI earnings; otherwise return zero.

C++
virtual double getEarnHiOnly(
    int
) const = 0;
Collapse Expand Returns

Medicare earnings for specified year if there are no OASDI earnings; otherwise return zero.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getEarnMS Method

WorkerDataGeneral::getEarnMS Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns military service earnings for specified year.

C++
virtual double getEarnMS(
    int
) const = 0;
Collapse Expand Returns

Military service earnings for specified year.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getEarnMS3750 Method

WorkerDataGeneral::getEarnMS3750 Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns total military service earnings, 1937-50.

C++
virtual double getEarnMS3750() const = 0;
Collapse Expand Returns

Total military service earnings, 1937-50.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getEarnOasdhi Method

WorkerDataGeneral::getEarnOasdhi Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns OASDI plus Medicare earnings for specified year.

C++
virtual double getEarnOasdhi(
    int
) const = 0;
Collapse Expand Returns

OASDI plus Medicare earnings for specified year.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getEarnOasdi Method

WorkerDataGeneral::getEarnOasdi Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns OASDI-covered earnings for the specified year.

C++
virtual double getEarnOasdi(
    int
) const = 0;
Collapse Expand Returns

OASDI-covered earnings for the specified year.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getEarnRR Method

WorkerDataGeneral::getEarnRR Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns railroad earnings for specified year.

C++
virtual double getEarnRR(
    int
) const = 0;
Collapse Expand Returns

Railroad earnings for specified year.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getEarnRR3750 Method

WorkerDataGeneral::getEarnRR3750 Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns total railroad earnings, 1937-50.

C++
virtual double getEarnRR3750() const = 0;
Collapse Expand Returns

Total railroad earnings, 1937-50.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getEntDate Method

WorkerDataGeneral::getEntDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns date of entitlement.

C++
const DateMoyr& getEntDate() const;
Collapse Expand Returns

The date of entitlement.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getFirstYearMS Method

WorkerDataGeneral::getFirstYearMS Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns first year of military service (0 if none).

C++
virtual int getFirstYearMS() const = 0;
Collapse Expand Returns

First year of military service (0 if none).

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getFirstYearRR Method

WorkerDataGeneral::getFirstYearRR Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns first year of railroad (0 if none).

C++
virtual int getFirstYearRR() const = 0;
Collapse Expand Returns

First year of railroad (0 if none).

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getIbegin Method

WorkerDataGeneral::getIbegin Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns first year of earnings after any projection.

C++
int getIbegin() const;
Collapse Expand Returns

First year of earnings after any projection.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getIdNumber Method

WorkerDataGeneral::getIdNumber Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns Social Security number as a number.

C++
virtual unsigned long getIdNumber() const = 0;
Collapse Expand Returns

Social Security number as a number.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getIdString Method

WorkerDataGeneral::getIdString Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns Social Security number as a string.

C++
virtual std::string getIdString() const = 0;
Collapse Expand Returns

Social Security number as a string.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getIend Method

WorkerDataGeneral::getIend Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns last year of earnings after any projection.

C++
int getIend() const;
Collapse Expand Returns

Last year of earnings after any projection.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getIndearn Method

WorkerDataGeneral::getIndearn Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns earnings indicator.

C++
bool getIndearn() const;
Collapse Expand Returns

False if no regular earnings, true if some regular earnings.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getIndms Method

WorkerDataGeneral::getIndms Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns military service indicator.

C++
virtual bool getIndms() const = 0;
Collapse Expand Returns

True if any military service, false otherwise.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getIndrr Method

WorkerDataGeneral::getIndrr Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns railroad indicator.

C++
bool getIndrr() const;
Collapse Expand Returns

False if no railroad earnings, true if some railroad earnings.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getJoasdi Method

WorkerDataGeneral::getJoasdi Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns type of benefit calculation, including possibly Statement.

C++
WorkerDataGeneral::ben_type getJoasdi() const;
Collapse Expand Returns

Type of benefit calculation.

NO_BEN | No benefit calculation.
OLD_AGE | Old-age benefit calculation.
SURVIVOR | Survivor benefit calculation.
DISABILITY | Disability benefit calculation.
PEBS_CALC | Statement benefit calculation.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getLastYearMS Method

WorkerDataGeneral::getLastYearMS Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns last year of military service (0 if none).

C++
virtual int getLastYearMS() const = 0;
Collapse Expand Returns

Last year of military service (0 if none).

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getLastYearRR Method

WorkerDataGeneral::getLastYearRR Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns last year of military service (0 if none).

C++
virtual int getLastYearRR() const = 0;
Collapse Expand Returns

Last year of military service (0 if none).

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getMaxyear Method

WorkerDataGeneral::getMaxyear Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns maximum year allowed.

C++
static int getMaxyear();
Collapse Expand Returns

Maximum year allowed (default LASTYEARLR).

Collapse Expand Remarks

Note that this is a static function.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getMqge Method

WorkerDataGeneral::getMqge Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns Medicare-qualified government employment indicator.

C++
bool getMqge() const;
Collapse Expand Returns

True if any Medicare-qualified government employment.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getNhaddr Method

WorkerDataGeneral::getNhaddr Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns one line of number holder's address.

C++
virtual std::string getNhaddr(
    int
) const = 0;
Collapse Expand Returns

One line of number holder's address.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getNhname Method

WorkerDataGeneral::getNhname Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns number holder's name.

C++
virtual std::string getNhname() const = 0;
Collapse Expand Returns

Number holder's name.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getOabCessDate Method

WorkerDataGeneral::getOabCessDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns date of cessation of oab entitlement prior to most recent DIB entitlement.

C++
virtual DateMoyr getOabCessDate() const = 0;
Collapse Expand Returns

The date of cessation of oab entitlement prior to most recent DIB entitlement.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getOabEntDate Method

WorkerDataGeneral::getOabEntDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns date of entitlement to oab prior to most recent DIB entitlement.

C++
virtual DateMoyr getOabEntDate() const = 0;
Collapse Expand Returns

The date of entitlement to oab prior to most recent DIB entitlement.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getPubpen Method

WorkerDataGeneral::getPubpen Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns monthly noncovered pension.

C++
virtual float getPubpen() const = 0;
Collapse Expand Returns

Monthly noncovered pension.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getPubpenDate Method

WorkerDataGeneral::getPubpenDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns date of entitlement for noncovered pension.

C++
virtual DateMoyr getPubpenDate() const = 0;
Collapse Expand Returns

The date of noncovered pension entitlement.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getPubpenReservist Method

WorkerDataGeneral::getPubpenReservist Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns monthly noncovered pension after December 1994, after removing reservist pension.

C++
virtual float getPubpenReservist() const = 0;
Collapse Expand Returns

Monthly noncovered pension after December 1994, after removing reservist pension.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getQcLumpYear Method

WorkerDataGeneral::getQcLumpYear Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns last year of period for which quarters of coverage are entered as a lump sum.

C++
static int getQcLumpYear();
Collapse Expand Returns

Last year of period for which quarters of coverage are entered as a lump sum (default 1977).

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getQcovMS Method

WorkerDataGeneral::getQcovMS Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns military service quarters of coverage for specified year.

C++
virtual unsigned getQcovMS(
    int
) const = 0;
Collapse Expand Returns

Military service quarters of coverage for specified year.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getQcovMS3750 Method

WorkerDataGeneral::getQcovMS3750 Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns total military service quarters of coverage, 1937-50.

C++
virtual unsigned getQcovMS3750() const = 0;
Collapse Expand Returns

Total military service quarters of coverage, 1937-50.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getQcovRR Method

WorkerDataGeneral::getQcovRR Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns railroad quarters of coverage for specified year.

C++
virtual unsigned getQcovRR(
    int
) const = 0;
Collapse Expand Returns

Railroad quarters of coverage for specified year.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getQcovRR3750 Method

WorkerDataGeneral::getQcovRR3750 Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns total railroad quarters of coverage, 1937-50.

C++
virtual unsigned getQcovRR3750() const = 0;
Collapse Expand Returns

Total railroad quarters of coverage, 1937-50.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getQcovRR5177 Method

WorkerDataGeneral::getQcovRR5177 Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns total railroad quarters of coverage, 1951-77.

C++
virtual unsigned getQcovRR5177() const = 0;
Collapse Expand Returns

Total railroad quarters of coverage, 1951-77.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getQctot51td Method

WorkerDataGeneral::getQctot51td Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns quarters of coverage from 1951 to 1977.

C++
int getQctot51td() const;
Collapse Expand Returns

Quarters of coverage from 1951 to 1977.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getQctottd Method

WorkerDataGeneral::getQctottd Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns quarters of coverage from 1937 to 1977.

C++
int getQctottd() const;
Collapse Expand Returns

Quarters of coverage from 1937 to 1977.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getRecalc Method

WorkerDataGeneral::getRecalc Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns recalculation code.

C++
bool getRecalc() const;
Collapse Expand Returns

True if benefit is being recalculated after initial entitlement, false otherwise.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getReservist Method

WorkerDataGeneral::getReservist Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns reservist indicator.

C++
bool getReservist() const;
Collapse Expand Returns

False if no reservist, true if pubpen is based at least partially on reservist pension.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getSex Method

WorkerDataGeneral::getSex Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns the sex of the worker.

C++
Sex::sex_type getSex() const;
Collapse Expand Returns

MALE (0) if male, FEMALE (1) if female.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getTaxType Method

WorkerDataGeneral::getTaxType Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns type of taxes for specified year.

C++
virtual bool getTaxType(
    int
) const = 0;
Collapse Expand Returns

Type of taxes for specified year.

Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getTotalize Method

WorkerDataGeneral::getTotalize Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns totalization indicator.

C++
bool getTotalize() const;
Collapse Expand Returns

False if no totalization, true if totalization applies.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::getValdi Method

WorkerDataGeneral::getValdi Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns number of periods of disability.

C++
int getValdi() const;
Collapse Expand Returns

Could have 0, 1, or 2 periods of disability.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::hasQcsByYear Method

WorkerDataGeneral::hasQcsByYear Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns indicator for QCs prior to 1978 by single year.

C++
bool hasQcsByYear() const;
Collapse Expand Returns

True if has QCs prior to 1978 by single year, false otherwise.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::ibegin1Check Method

WorkerDataGeneral::ibegin1Check Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks first year of earnings in a Statement case.

C++
static void ibegin1Check(
    int ibegint,
    int istartt
);
Collapse Expand Parameters
Parameters | Description
int ibegint | Year to check.
int istartt | Starting year of projections.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BEGIN3 if first year of earnings is before 1937. PiaException of type PIA_IDS_BEGIN4 if first year of earnings is in starting year of projections or later.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::ibegin2Check Method

WorkerDataGeneral::ibegin2Check Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks first year of earnings in a non-Statement case.

C++
static void ibegin2Check(
    int ibegint
);
Collapse Expand Parameters
Parameters | Description
int ibegint | Year to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BEGIN3 if first year of earnings is before 1937. PiaException of type PIA_IDS_BEGIN5 if first year of earnings is after maximum year allowed.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


ibeginCheck Method

ibeginCheck Method
WorkerDataGeneral Methods

Checks for first year of earnings within bounds.

Collapse Expand Description

There are two versions of the ibeginCheck function. The version with no arguments calls the version with two arguments, passing the stored year of birth and first year of earnings.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::ibeginCheck () | Checks for first year of earnings within bounds, using stored values.
WorkerDataGeneral::ibeginCheck (int, int) | Checks for first year of earnings within bounds, using passed values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::ibeginCheck Method ()

WorkerDataGeneral::ibeginCheck Method ()
WorkerDataGeneral Class WorkerDataGeneral Members ibeginCheck Method

Checks for first year of earnings within bounds, using stored values.

C++
void ibeginCheck() const;
Collapse Expand Remarks

This version passes stored values to the static version with 2 arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BEGIN1 if first year of earnings is out of range.
Collapse Expand Group

ibeginCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, ibeginCheck Method


WorkerDataGeneral::ibeginCheck Method (int, int)

WorkerDataGeneral::ibeginCheck Method (int, int)
WorkerDataGeneral Class WorkerDataGeneral Members ibeginCheck Method

Checks for first year of earnings within bounds, using passed values.

C++
static void ibeginCheck(
    int ibegint,
    int ibirtht
);
Collapse Expand Parameters
Parameters | Description
int ibegint | First year of earnings.
int ibirtht | Year of birth.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BEGIN1 if first year of earnings is out of range.
Collapse Expand Group

ibeginCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, ibeginCheck Method


WorkerDataGeneral::iendCheck Method

WorkerDataGeneral::iendCheck Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks last year of earnings.

C++
static void iendCheck(
    int iendt
);
Collapse Expand Parameters
Parameters | Description
int iendt | Year to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_END1 if last year of earnings is before 1937. PiaException of type PIA_IDS_END2 if last year of earnings is after maximum year allowed.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::isFemale Method

WorkerDataGeneral::isFemale Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Return true if person is Sex::sex_type::FEMALE, false otherwise.

C++
bool isFemale() const;
Collapse Expand Returns

True if person is Sex::sex_type::FEMALE, false otherwise.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::isMale Method

WorkerDataGeneral::isMale Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Return true if person is Sex::sex_type::MALE, false otherwise.

C++
bool isMale() const;
Collapse Expand Returns

True if person is Sex::sex_type::MALE, false otherwise.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::isPrimary Method

WorkerDataGeneral::isPrimary Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns primary beneficiary code.

C++
int isPrimary(
    ben_type ioasdi
) const;
Collapse Expand Parameters
Parameters | Description
ben_type ioasdi | Type of benefit.
Collapse Expand Returns

Primary beneficiary code.

0 | was never a primary beneficiary.
1 | is a primary beneficiary.
2 | is a deceased primary beneficiary.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::isalive Method

WorkerDataGeneral::isalive Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns true if alive at end of year, false otherwise.

C++
bool isalive(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year being checked.
Collapse Expand Returns

True if alive at end of year, false otherwise.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


isdead Method

isdead Method
WorkerDataGeneral Methods

Returns true if dead at end of specified date.

Collapse Expand Description

There are two versions of the isdead function. The version with an integer argument checks for death by the end of that year; the version with a DateMoyr argument checks for death by the end of that month.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::isdead (const DateMoyr&) | Returns true if dead at end of month, false otherwise.
WorkerDataGeneral::isdead (int) | Returns true if dead at end of year, false otherwise.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::isdead Method (const DateMoyr&)

WorkerDataGeneral::isdead Method (const DateMoyr&)
WorkerDataGeneral Class WorkerDataGeneral Members isdead Method

Returns true if dead at end of month, false otherwise.

C++
bool isdead(
    const DateMoyr& date
) const;
Collapse Expand Parameters
Parameters | Description
const DateMoyr& date | Month and year being checked.
Collapse Expand Returns

True if dead at end of month, false otherwise.

Collapse Expand Group

isdead Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, isdead Method


WorkerDataGeneral::isdead Method (int)

WorkerDataGeneral::isdead Method (int)
WorkerDataGeneral Class WorkerDataGeneral Members isdead Method

Returns true if dead at end of year, false otherwise.

C++
bool isdead(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year being checked.
Collapse Expand Returns

True if dead at end of year, false otherwise.

Collapse Expand Group

isdead Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, isdead Method


joasdiCheck Method

joasdiCheck Method
WorkerDataGeneral Methods

Checks type of benefit.

Collapse Expand Description

There are two versions of the joasdiCheck function. The version with no arguments calls the version with one argument, passing the stored type of benefit.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::joasdiCheck () | Checks type of benefit, using stored values.
WorkerDataGeneral::joasdiCheck (int) | Checks type of benefit, using passed values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::joasdiCheck Method ()

WorkerDataGeneral::joasdiCheck Method ()
WorkerDataGeneral Class WorkerDataGeneral Members joasdiCheck Method

Checks type of benefit, using stored values.

C++
void joasdiCheck() const;
Collapse Expand Remarks

This version passes stored values to the static version with 1 argument.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_JOASDI if type of benefit is out of range.
Collapse Expand Group

joasdiCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, joasdiCheck Method


WorkerDataGeneral::joasdiCheck Method (int)

WorkerDataGeneral::joasdiCheck Method (int)
WorkerDataGeneral Class WorkerDataGeneral Members joasdiCheck Method

Checks type of benefit, using passed values.

C++
static void joasdiCheck(
    int joasdit
);
Collapse Expand Parameters
Parameters | Description
int joasdit | Type of benefit to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_JOASDI if type of benefit is out of range.
Collapse Expand Group

joasdiCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, joasdiCheck Method


WorkerDataGeneral::lastQcyr Method

WorkerDataGeneral::lastQcyr Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns last year of annual QCs.

C++
int lastQcyr() const;
Collapse Expand Returns

Last year of annual QCs (lesser of last year of earnings and 1977).

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


needDiCess Method

needDiCess Method
WorkerDataGeneral Methods

Returns true if date of cessation to disability is needed.

Collapse Expand Description

There are two versions of the needDiCess function. The version with no arguments calls the version with two arguments, passing the stored disability and benefit information.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::needDiCess () | Returns true if date of cessation to disability is needed, using stored values.
WorkerDataGeneral::needDiCess (int, ben_type) | Returns true if date of cessation to disability is needed, using passed values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::needDiCess Method ()

WorkerDataGeneral::needDiCess Method ()
WorkerDataGeneral Class WorkerDataGeneral Members needDiCess Method

Returns true if date of cessation to disability is needed, using stored values.

C++
bool needDiCess() const;
Collapse Expand Returns

True if date of cessation to disability is needed.

Collapse Expand Remarks

This version passes stored values to the static version with 2 arguments.

Collapse Expand Group

needDiCess Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, needDiCess Method


WorkerDataGeneral::needDiCess Method (int, ben_type)

WorkerDataGeneral::needDiCess Method (int, ben_type)
WorkerDataGeneral Class WorkerDataGeneral Members needDiCess Method

Returns true if date of cessation to disability is needed, using passed values.

C++
static bool needDiCess(
    int valdit,
    ben_type ioasdi
);
Collapse Expand Parameters
Parameters | Description
int valdit | Number of periods of disability.
ben_type ioasdi | Type of benefit.
Collapse Expand Returns

True if date of cessation to disability is needed.

Collapse Expand Group

needDiCess Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, needDiCess Method


WorkerDataGeneral::needQcsByYear Method

WorkerDataGeneral::needQcsByYear Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns true if quarters of coverage by year from regular earnings are needed, false otherwise.

C++
bool needQcsByYear() const;
Collapse Expand Returns

True if quarters of coverage by year from regular earnings are needed, false otherwise.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCLUMPYEAR if qclumpyear is out of range (only in debug mode).
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::need_aw Method

WorkerDataGeneral::need_aw Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns true if average wage increase assumptions are needed.

C++
bool need_aw(
    int year,
    bool lastTwoYears
) const;
Collapse Expand Parameters
Parameters | Description
int year | First year of projection period.
bool lastTwoYears | True if need to look at last 2 years of historical period.
Collapse Expand Returns

True if average wage increase assumptions are needed.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::need_bases Method

WorkerDataGeneral::need_bases Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns true if wage base assumptions are needed.

C++
bool need_bases(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | First year of projection period.
Collapse Expand Returns

True if wage base assumptions are needed.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_NEEDBASES if year is out of range (only in debug mode).
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::need_bi Method

WorkerDataGeneral::need_bi Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Returns true if benefit increase assumptions are needed.

C++
bool need_bi(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | First year of projection period.
Collapse Expand Returns

True if benefit increase assumptions are needed.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


priorent1Check Method

priorent1Check Method
WorkerDataGeneral Methods

Checks date of second prior entitlement to disability.

Collapse Expand Description

There are two versions of the priorent1Check function. The version with no arguments calls the version with three arguments, passing the stored disability information.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::priorent1Check () | Checks date of second prior entitlement to disability, using stored values.
WorkerDataGeneral::priorent1Check (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&) | Checks date of second prior entitlement to disability, using passed values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::priorent1Check Method ()

WorkerDataGeneral::priorent1Check Method ()
WorkerDataGeneral Class WorkerDataGeneral Members priorent1Check Method

Checks date of second prior entitlement to disability, using stored values.

C++
void priorent1Check() const;
Collapse Expand Remarks

This version passes stored valuesto the static version with 3 arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PRRENT1 if month of prior entitlement is out of range; of type PIA_IDS_PRRENT2 if year of prior entitlement is before 1940; of type PIA_IDS_PRRENT3 if year of prior entitlement is after maximum allowed; of type PIA_IDS_PRRENT4 if prior entitlement is not before current entitlement; of type PIA_IDS_PRRENT5 if prior entitlement to disability is before disability onset.
Collapse Expand Group

priorent1Check Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, priorent1Check Method


WorkerDataGeneral::priorent1Check Method (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&)

WorkerDataGeneral::priorent1Check Method (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&)
WorkerDataGeneral Class WorkerDataGeneral Members priorent1Check Method

Checks date of second prior entitlement to disability, using passed values.

C++
static void priorent1Check(
    const DateMoyr& priorent1t,
    const boost::gregorian::date& ionsett,
    const DateMoyr& priorentt
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& priorent1t | The date of second prior entitlement.
const boost::gregorian::date& ionsett | The date of current disability onset.
const DateMoyr& priorentt | The date of prior entitlement.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PRRENT1 if month of prior entitlement is out of range; of type PIA_IDS_PRRENT2 if year of prior entitlement is before 1940; of type PIA_IDS_PRRENT3 if year of prior entitlement is after maximum allowed; of type PIA_IDS_PRRENT4 if prior entitlement is not before current entitlement; of type PIA_IDS_PRRENT5 if prior entitlement to disability is before disability onset.
Collapse Expand Group

priorent1Check Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, priorent1Check Method


priorentCheck Method

priorentCheck Method
WorkerDataGeneral Methods

Checks date of prior entitlement to disability.

Collapse Expand Description

There are two versions of the priorentCheck function. The version with no arguments calls the version with four arguments, passing the stored disability information.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::priorentCheck () | Checks date of prior entitlement to disability, using stored values.
WorkerDataGeneral::priorentCheck (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&, ben_type) | Checks date of prior entitlement to disability, using passed values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::priorentCheck Method ()

WorkerDataGeneral::priorentCheck Method ()
WorkerDataGeneral Class WorkerDataGeneral Members priorentCheck Method

Checks date of prior entitlement to disability, using stored values.

C++
void priorentCheck() const;
Collapse Expand Remarks

This version passes stored values to the static version with 4 arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PRRENT1 if month of prior entitlement is out of range; of type PIA_IDS_PRRENT2 if year of prior entitlement is before 1940; of type PIA_IDS_PRRENT3 if year of prior entitlement is after maximum allowed; of type PIA_IDS_PRRENT4 if prior entitlement is not before current entitlement in an old-age case (prior entitlement should equal current entitlement in a disability case, and there is no date of entitlement for the worker in a survivor case); of type PIA_IDS_PRRENT5 if prior entitlement to disability is before disability onset.
Collapse Expand Group

priorentCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, priorentCheck Method


WorkerDataGeneral::priorentCheck Method (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&, ben_type)

WorkerDataGeneral::priorentCheck Method (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&, ben_type)
WorkerDataGeneral Class WorkerDataGeneral Members priorentCheck Method

Checks date of prior entitlement to disability, using passed values.

C++
static void priorentCheck(
    const DateMoyr& priorentDatet,
    const boost::gregorian::date& onsetDatet,
    const DateMoyr& entDatet,
    ben_type ioasdit
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& priorentDatet | The date of prior entitlement.
const boost::gregorian::date& onsetDatet | The date of current disability onset.
const DateMoyr& entDatet | The date of current entitlement.
ben_type ioasdit | The type of benefit.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PRRENT1 if month of prior entitlement is out of range; of type PIA_IDS_PRRENT2 if year of prior entitlement is before 1940; of type PIA_IDS_PRRENT3 if year of prior entitlement is after maximum allowed; of type PIA_IDS_PRRENT4 if prior entitlement is not before current entitlement in an old-age case (prior entitlement should equal current entitlement in a disability case, and there is no date of entitlement for the worker in a survivor case); of type PIA_IDS_PRRENT5 if prior entitlement to disability is before disability onset.
Collapse Expand Group

priorentCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, priorentCheck Method


WorkerDataGeneral::pubpenCheck Method

WorkerDataGeneral::pubpenCheck Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks public pension amount.

C++
static void pubpenCheck(
    float pubpent
);
Collapse Expand Parameters
Parameters | Description
float pubpent | Pension to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PUBPEN if public pension amount is out of range.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::pubpenDateCheck Method

WorkerDataGeneral::pubpenDateCheck Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks public pension entitlement date.

C++
static void pubpenDateCheck(
    const DateMoyr& pubpenDatet,
    const boost::gregorian::date& birthDatet,
    const boost::gregorian::date& deathDatet
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& pubpenDatet | Pension to check.
const boost::gregorian::date& birthDatet | Birth date.
const boost::gregorian::date& deathDatet | Death date (could be not_a_date).
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_NONPENDATE1 or PIA_IDS_NONPENDATE2 if public pension entitlement date is out of range (before date of birth or after date of death).
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::qc51tdCheck Method

WorkerDataGeneral::qc51tdCheck Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks summary quarters of coverage, 1951 to 1977.

C++
static void qc51tdCheck(
    int qct
);
Collapse Expand Parameters
Parameters | Description
int qct | Quarters of coverage to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QC51TD if number of quarters of coverage, 1951-77, is out of range.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


qcCheck Method

qcCheck Method
WorkerDataGeneral Methods

Checks for correct numbers of QC's.

Collapse Expand Description

There are two versions of the qcCheck function. The version with no arguments calls the version with two arguments, passing the stored quarter of coverage information.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::qcCheck () | Checks for correct numbers of QC's, using stored values.
WorkerDataGeneral::qcCheck (int, int) | Checks for correct numbers of QC's, using passed values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::qcCheck Method ()

WorkerDataGeneral::qcCheck Method ()
WorkerDataGeneral Class WorkerDataGeneral Members qcCheck Method

Checks for correct numbers of QC's, using stored values.

C++
void qcCheck() const;
Collapse Expand Remarks

This version passes stored valuesto the static version with 2 arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QC if number of quarters of coverage, 1951-77, is greater than number of quarters of coverage, 1937-77.
Collapse Expand Group

qcCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, qcCheck Method


WorkerDataGeneral::qcCheck Method (int, int)

WorkerDataGeneral::qcCheck Method (int, int)
WorkerDataGeneral Class WorkerDataGeneral Members qcCheck Method

Checks for correct numbers of QC's, using passed values.

C++
static void qcCheck(
    int qctottdt,
    int qctot51tdt
);
Collapse Expand Parameters
Parameters | Description
int qctottdt | QCs from 1937 to 1977.
int qctot51tdt | QCs from 1951 to 1977.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QC if number of quarters of coverage, 1951-77, is greater than number of quarters of coverage, 1937-77.
Collapse Expand Group

qcCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, qcCheck Method


WorkerDataGeneral::qctdCheck Method

WorkerDataGeneral::qctdCheck Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks summary quarters of coverage, 1937 to 1977.

C++
static void qctdCheck(
    int qct
);
Collapse Expand Parameters
Parameters | Description
int qct | Quarters of coverage to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QCTD if number of quarters of coverage, 1937-77, is out of range.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::qctdCheck2 Method

WorkerDataGeneral::qctdCheck2 Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks quarters of coverage to 1977 for consistency, assuming both qcs for 1937-1977 and qcs for 1951-1977 have been set to reasonable values.

C++
void qctdCheck2();
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QC51TD if number of quarters of coverage, 1951-77, is out of range.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


setBenefitDate Method

setBenefitDate Method
WorkerDataGeneral Methods

Sets date of benefit.

Collapse Expand Description

There are two versions of the setBenefitDate function. The version with no arguments sets the benefit date to the date of entitlement, while the version with a date argument sets the benefit date to that date.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::setBenefitDate () | Sets date of benefit to the date of initial entitlement.
WorkerDataGeneral::setBenefitDate (const DateMoyr&) | Sets date of benefit to the specified value.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::setBenefitDate Method ()

WorkerDataGeneral::setBenefitDate Method ()
WorkerDataGeneral Class WorkerDataGeneral Members setBenefitDate Method

Sets date of benefit to the date of initial entitlement.

C++
void setBenefitDate();
Collapse Expand Remarks

This version should be used if the recalculation indicator has not been set and this is not a survivor benefit.

Collapse Expand Group

setBenefitDate Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, setBenefitDate Method


WorkerDataGeneral::setBenefitDate Method (const DateMoyr&)

WorkerDataGeneral::setBenefitDate Method (const DateMoyr&)
WorkerDataGeneral Class WorkerDataGeneral Members setBenefitDate Method

Sets date of benefit to the specified value.

C++
void setBenefitDate(
    const DateMoyr& newBenefitDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& newBenefitDate | The date to use.
Collapse Expand Remarks

The specified date is used to set the date of benefit, if the recalculation indicator has been set or this is a survivor benefit. Otherwise, the benefit date is set to the date of initial entitlement, by calling the version of this function with no arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BENDATE2 if month is out of range. PiaException of type PIA_IDS_BENDATE3 if year is before 1940. PiaException of type PIA_IDS_BENDATE4 if year is after maximum allowed. All are in debug mode only.
Collapse Expand Group

setBenefitDate Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, setBenefitDate Method


WorkerDataGeneral::setBirthDate Method

WorkerDataGeneral::setBirthDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets date of birth.

C++
void setBirthDate(
    const boost::gregorian::date& newBirthDate
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& newBirthDate | The date to use.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setBlindind Method

WorkerDataGeneral::setBlindind Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets blind indicator.

C++
void setBlindind(
    bool newBlindind
);
Collapse Expand Parameters
Parameters | Description
bool newBlindind | New blind indicator.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setCessationDate Method

WorkerDataGeneral::setCessationDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets date of disability cessation.

C++
void setCessationDate(
    unsigned index,
    const DateMoyr& dateMoyr
);
Collapse Expand Parameters
Parameters | Description
unsigned index | Which disability period to use (0 for most recent, 1 for next most recent).
const DateMoyr& dateMoyr | The date to use.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setCessationMfb Method

WorkerDataGeneral::setCessationMfb Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets mfb at disability cessation.

C++
void setCessationMfb(
    unsigned index,
    float newMfb
);
Collapse Expand Parameters
Parameters | Description
unsigned index | Which disability period to use (0 for most recent, 1 for next most recent).
float newMfb | The mfb to use.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setCessationPia Method

WorkerDataGeneral::setCessationPia Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets pia at disability cessation.

C++
void setCessationPia(
    unsigned index,
    float newPia
);
Collapse Expand Parameters
Parameters | Description
unsigned index | Which disability period to use (0 for most recent, 1 for next most recent).
float newPia | The pia to use.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setDeathDate Method

WorkerDataGeneral::setDeathDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets date of death.

C++
void setDeathDate(
    const boost::gregorian::date& newDeathDate
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& newDeathDate | The date to use.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setDeceasedOAB Method

WorkerDataGeneral::setDeceasedOAB Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets deceased OAB indicator.

C++
void setDeceasedOAB(
    bool newDeceasedOAB
);
Collapse Expand Parameters
Parameters | Description
bool newDeceasedOAB | New deceased OAB indicator.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setDeemedind Method

WorkerDataGeneral::setDeemedind Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets deemed insured indicator.

C++
void setDeemedind(
    bool newDeemedind
);
Collapse Expand Parameters
Parameters | Description
bool newDeemedind | New deemed insured indicator.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setEarnHi Method

WorkerDataGeneral::setEarnHi Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets Medicare earnings for the specified year.

C++
virtual void setEarnHi(
    int,
    double
) = 0;
Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setEarnOasdi Method

WorkerDataGeneral::setEarnOasdi Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets OASDI-covered earnings.

C++
virtual void setEarnOasdi(
    int,
    double
) = 0;
Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setEntDate Method

WorkerDataGeneral::setEntDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets date of entitlement.

C++
void setEntDate(
    const DateMoyr& newEntDate
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& newEntDate | The date to use.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setIbegin Method

WorkerDataGeneral::setIbegin Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets first year of earnings, including any projected earnings. Also sets first year of HI earnings (ignored if indicator for HI earnings is not set before attempting to use HI earnings).

C++
void setIbegin(
    int newIbegin
);
Collapse Expand Parameters
Parameters | Description
int newIbegin | New first year of earnings.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setIend Method

WorkerDataGeneral::setIend Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets last year of earnings, including any projected earnings.

C++
void setIend(
    int newIend
);
Collapse Expand Parameters
Parameters | Description
int newIend | New last year of earnings.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setIndearn Method

WorkerDataGeneral::setIndearn Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets earnings indicator.

C++
void setIndearn(
    bool newIndearn
);
Collapse Expand Parameters
Parameters | Description
bool newIndearn | New earnings indicator.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setIndrr Method

WorkerDataGeneral::setIndrr Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets railroad indicator.

C++
void setIndrr(
    bool newIndrr
);
Collapse Expand Parameters
Parameters | Description
bool newIndrr | New railroad indicator.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setJoasdi Method

WorkerDataGeneral::setJoasdi Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets type of benefit.

C++
void setJoasdi(
    int newJoasdi
);
Collapse Expand Parameters
Parameters | Description
int newJoasdi | New type of benefit.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_JOASDI if type of benefit is out of range (debug mode only).
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setMaxyear Method

WorkerDataGeneral::setMaxyear Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets maximum year allowed.

C++
static void setMaxyear(
    int newMaxyear
);
Collapse Expand Parameters
Parameters | Description
int newMaxyear | New maximum year allowed.
Collapse Expand Remarks

Note that this is a static function.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setMqge Method

WorkerDataGeneral::setMqge Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets mqge indicator.

C++
void setMqge(
    bool newMqge
);
Collapse Expand Parameters
Parameters | Description
bool newMqge | New mqge indicator.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setNhaddr Method

WorkerDataGeneral::setNhaddr Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets one line of address.

C++
virtual void setNhaddr(
    int,
    const std::string&
) = 0;
Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setNhname Method

WorkerDataGeneral::setNhname Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets number holder's name.

C++
virtual void setNhname(
    const std::string&
) = 0;
Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setOabCessDate Method

WorkerDataGeneral::setOabCessDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets date of cessation of oab prior to most recent dib.

C++
virtual void setOabCessDate(
    const DateMoyr&
) = 0;
Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setOabEntDate Method

WorkerDataGeneral::setOabEntDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets date of oab entitlement prior to most recent dib.

C++
virtual void setOabEntDate(
    const DateMoyr&
) = 0;
Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setOnsetDate Method

WorkerDataGeneral::setOnsetDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets date of disability onset.

C++
void setOnsetDate(
    unsigned index,
    const boost::gregorian::date& dateModyyr
);
Collapse Expand Parameters
Parameters | Description
unsigned index | Which disability period to use (0 for most recent, 1 for next most recent).
const boost::gregorian::date& dateModyyr | The date to use.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setPebsData Method

WorkerDataGeneral::setPebsData Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Initializes some Statement data (no disability and no date of death).

C++
void setPebsData();
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setPebsEarn Method

WorkerDataGeneral::setPebsEarn Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets last year of Statement earnings when computation year changes, or after a Statement calculation has been done.

C++
void setPebsEarn(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | First year of projection period.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setPriorentDate Method

WorkerDataGeneral::setPriorentDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets date of entitlement to disability.

C++
void setPriorentDate(
    unsigned index,
    const DateMoyr& dateMoyr
);
Collapse Expand Parameters
Parameters | Description
unsigned index | Which disability period to use (0 for most recent, 1 for next most recent).
const DateMoyr& dateMoyr | The date to use.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setPriorentDateCheck Method

WorkerDataGeneral::setPriorentDateCheck Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets date of prior entitlement to disability.

C++
void setPriorentDateCheck(
    unsigned index,
    const DateMoyr& dateMoyr
);
Collapse Expand Parameters
Parameters | Description
unsigned index | Which disability period to use (0 for most recent, 1 for next most recent).
const DateMoyr& dateMoyr | The date to check and use.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setPubpen Method

WorkerDataGeneral::setPubpen Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets amount of monthly noncovered pension.

C++
virtual void setPubpen(
    float
) = 0;
Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setPubpenDate Method

WorkerDataGeneral::setPubpenDate Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets date of monthly noncovered pension entitlement.

C++
virtual void setPubpenDate(
    const DateMoyr&
) = 0;
Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setPubpenReservist Method

WorkerDataGeneral::setPubpenReservist Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets amount of monthly noncovered pension after December 1994, after removing military reservist pension.

C++
virtual void setPubpenReservist(
    float
) = 0;
Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setQc51td Method

WorkerDataGeneral::setQc51td Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets summary quarters of coverage, 1951 to 1977.

C++
void setQc51td(
    int qct
);
Collapse Expand Parameters
Parameters | Description
int qct | New summary quarters of coverage.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QC51TD if number of quarters of coverage, 1951-77, is out of range (debug mode only).
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setQcLumpYear Method

WorkerDataGeneral::setQcLumpYear Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets last year of period for which quarters of coverage are entered as a lump sum.

C++
static void setQcLumpYear(
    int newQcLumpYear
);
Collapse Expand Parameters
Parameters | Description
int newQcLumpYear | New last year of period for which quarters of coverage are entered as a lump sum.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setQcsByYear Method

WorkerDataGeneral::setQcsByYear Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets indicator for QCs by year prior to 1978.

C++
void setQcsByYear(
    bool newQcsByYear
);
Collapse Expand Parameters
Parameters | Description
bool newQcsByYear | Indicator for QCs by year prior to 1978.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setQctd Method

WorkerDataGeneral::setQctd Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets summary quarters of coverage, 1937 to 1977.

C++
void setQctd(
    int qct
);
Collapse Expand Parameters
Parameters | Description
int qct | New summary quarters of coverage.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setRecalc Method

WorkerDataGeneral::setRecalc Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets recalculation indicator.

C++
void setRecalc(
    bool newRecalc
);
Collapse Expand Parameters
Parameters | Description
bool newRecalc | New recalculation indicator.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setReservist Method

WorkerDataGeneral::setReservist Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets reservist indicator.

C++
void setReservist(
    bool newReservist
);
Collapse Expand Parameters
Parameters | Description
bool newReservist | New reservist indicator.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setSex Method

WorkerDataGeneral::setSex Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets the sex of the worker.

C++
void setSex(
    Sex::sex_type newSex
);
Collapse Expand Parameters
Parameters | Description
Sex::sex_type newSex | New sex indicator.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_SEX if sex is not MALE or FEMALE (only in debug mode).
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setTaxType Method

WorkerDataGeneral::setTaxType Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets type of taxes for the specified year.

C++
virtual void setTaxType(
    int,
    int
) = 0;
Collapse Expand Remarks

Needs to be implemented by a child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setTotalize Method

WorkerDataGeneral::setTotalize Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets totalization indicator.

C++
void setTotalize(
    bool newTotalize
);
Collapse Expand Parameters
Parameters | Description
bool newTotalize | New totalization indicator.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::setValdi Method

WorkerDataGeneral::setValdi Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Sets number of periods of disability.

C++
void setValdi(
    int newValdi
);
Collapse Expand Parameters
Parameters | Description
int newValdi | New number of periods of disability.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


setWaitperDate Method

setWaitperDate Method
WorkerDataGeneral Methods

Sets first month of waiting period.

Collapse Expand Description

There are two versions of the setWaitperDate function. The version with one argument sets the first month of the waiting period to the first month after onset. The version with two arguments sets the first month of the waiting period to that date.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::setWaitperDate (unsigned) | Sets first month of waiting period to the first month after onset.
WorkerDataGeneral::setWaitperDate (unsigned, const DateMoyr&) | Sets first month of waiting period to the specified date.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::setWaitperDate Method (unsigned)

WorkerDataGeneral::setWaitperDate Method (unsigned)
WorkerDataGeneral Class WorkerDataGeneral Members setWaitperDate Method

Sets first month of waiting period to the first month after onset.

C++
void setWaitperDate(
    unsigned index
);
Collapse Expand Parameters
Parameters | Description
unsigned index | Which disability period to use (0 for most recent, 1 for next most recent).
Collapse Expand Remarks

This version sets the first month of the waiting period to the first month after onset. It does that by calling DisabPeriod::waitperDateCal and passing the resulting date as an argument to the version of this function with two arguments.

Collapse Expand Group

setWaitperDate Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, setWaitperDate Method


WorkerDataGeneral::setWaitperDate Method (unsigned, const DateMoyr&)

WorkerDataGeneral::setWaitperDate Method (unsigned, const DateMoyr&)
WorkerDataGeneral Class WorkerDataGeneral Members setWaitperDate Method

Sets first month of waiting period to the specified date.

C++
void setWaitperDate(
    unsigned index,
    const DateMoyr& dateMoyr
);
Collapse Expand Parameters
Parameters | Description
unsigned index | Which disability period to use (0 for most recent, 1 for next most recent).
const DateMoyr& dateMoyr | The date to use.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_WAITPD1 if bad month; of type PIA_IDS_WAITPD2 if year is before 1940; of type PIA_IDS_WAITPD3 if year is after maximum allowed. (All only in debug mode.)
Collapse Expand Group

setWaitperDate Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, setWaitperDate Method


WorkerDataGeneral::taxTypeCheck Method

WorkerDataGeneral::taxTypeCheck Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks type of taxes.

C++
static void taxTypeCheck(
    int taxTypet
);
Collapse Expand Parameters
Parameters | Description
int taxTypet | Type of taxes to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_TAXTYPE if type of taxes is not 0 or 1.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::valdi1Check Method

WorkerDataGeneral::valdi1Check Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks number of periods of disability in nondisability case.

C++
static void valdi1Check(
    int valdit
);
Collapse Expand Parameters
Parameters | Description
int valdit | Number of periods to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_VALDI1 if number of periods of disability is not 0, 1, or 2.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::valdi2Check Method

WorkerDataGeneral::valdi2Check Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks number of periods of disability in disability case.

C++
static void valdi2Check(
    int valdit
);
Collapse Expand Parameters
Parameters | Description
int valdit | Number of periods of disability to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_VALDI2 if number of periods of disability is not 1 or 2.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::valdiCheck Method

WorkerDataGeneral::valdiCheck Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Checks number of periods of disability, using stored value.

C++
void valdiCheck() const;
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_VALDI1 if number of periods of disability is not 0, 1, or 2 in a nondisability case; of type PIA_IDS_VALDI2 if number of periods of disability is not 1 or 2 in a disability case.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


waitpd1Check Method

waitpd1Check Method
WorkerDataGeneral Methods

Checks first month of prior waiting period.

Collapse Expand Description

There are two versions of the waitpd1Check function. The version with no arguments calls the version with three arguments, passing the stored disability information.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::waitpd1Check () | Checks first month of prior waiting period, using stored values.
WorkerDataGeneral::waitpd1Check (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&) | Checks first month of prior waiting period, using passed values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::waitpd1Check Method ()

WorkerDataGeneral::waitpd1Check Method ()
WorkerDataGeneral Class WorkerDataGeneral Members waitpd1Check Method

Checks first month of prior waiting period, using stored values.

C++
void waitpd1Check() const;
Collapse Expand Remarks

This version passes stored values to the static version with 3 arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_WAITPD4 if waiting period starts before onset; of type PIA_IDS_WAITPD6 if cessation is before waiting period.
Collapse Expand Group

waitpd1Check Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, waitpd1Check Method


WorkerDataGeneral::waitpd1Check Method (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&)

WorkerDataGeneral::waitpd1Check Method (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&)
WorkerDataGeneral Class WorkerDataGeneral Members waitpd1Check Method

Checks first month of prior waiting period, using passed values.

C++
static void waitpd1Check(
    const DateMoyr& waitper1Datet,
    const boost::gregorian::date& onset1Datet,
    const DateMoyr& cessation1Datet
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& waitper1Datet | First month of prior waiting period.
const boost::gregorian::date& onset1Datet | The date of prior onset.
const DateMoyr& cessation1Datet | The date of prior cessation.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_WAITPD4 if waiting period starts before onset; of type PIA_IDS_WAITPD6 if cessation is before waiting period.
Collapse Expand Group

waitpd1Check Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, waitpd1Check Method


waitpdCheck Method

waitpdCheck Method
WorkerDataGeneral Methods

Checks first month of waiting period.

Collapse Expand Description

There are two versions of the waitpdCheck function. The version with no arguments calls the version with three arguments, passing the stored disability information.

Collapse Expand Overload List
Name | Description
WorkerDataGeneral::waitpdCheck () | Checks first month of waiting period, using stored values.
WorkerDataGeneral::waitpdCheck (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&) | Checks first month of waiting period, using passed values.
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Methods


WorkerDataGeneral::waitpdCheck Method ()

WorkerDataGeneral::waitpdCheck Method ()
WorkerDataGeneral Class WorkerDataGeneral Members waitpdCheck Method

Checks first month of waiting period, using stored values.

C++
void waitpdCheck() const;
Collapse Expand Remarks

This version passes stored valuesto the static version with 3 arguments.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_WAITPD1 if first month of waiting period is out of range; of type PIA_IDS_WAITPD2 if year of first month of waiting period is before 1940; of type PIA_IDS_WAITPD3 if year of first month of waiting period is after maximum allowed; of type PIA_IDS_WAITPD4 if waiting period starts before onset; of type PIA_IDS_WAITPD5 if entitlement is before waiting period.
Collapse Expand Group

waitpdCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, waitpdCheck Method


WorkerDataGeneral::waitpdCheck Method (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&)

WorkerDataGeneral::waitpdCheck Method (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&)
WorkerDataGeneral Class WorkerDataGeneral Members waitpdCheck Method

Checks first month of waiting period, using passed values.

C++
static void waitpdCheck(
    const DateMoyr& waitperDatet,
    const boost::gregorian::date& onsetDatet,
    const DateMoyr& entDatet
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& waitperDatet | First month of waiting period.
const boost::gregorian::date& onsetDatet | The date of onset.
const DateMoyr& entDatet | The date of entitlement.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_WAITPD1 if first month of waiting period is out of range; of type PIA_IDS_WAITPD2 if year of first month of waiting period is before 1940; of type PIA_IDS_WAITPD3 if year of first month of waiting period is after maximum allowed; of type PIA_IDS_WAITPD4 if waiting period starts before onset; of type PIA_IDS_WAITPD5 if entitlement is before waiting period.
Collapse Expand Group

waitpdCheck Method

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, waitpdCheck Method


WorkerDataGeneral::zeroEarn Method

WorkerDataGeneral::zeroEarn Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Zeroes out earnings and quarters of coverage before first year and after last year of specified earnings.

C++
virtual void zeroEarn(
    int ibegint,
    int iendt
);
Collapse Expand Parameters
Parameters | Description
int ibegint | First year of specified earnings.
int iendt | Last year of specified earnings.
Collapse Expand Remarks

This version zeroes out quarters of coverage, but not earnings. A child class should implement this function, calling this version and then zeroing out earnings in the child class.

Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::zeroEarnHi Method

WorkerDataGeneral::zeroEarnHi Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Zeroes out HI earnings before first year and after last year of specified earnings.

C++
virtual void zeroEarnHi(
    int,
    int
);
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::zeroEarnOasdi Method

WorkerDataGeneral::zeroEarnOasdi Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Zeroes out OASDI earnings before first year and after last year of specified earnings.

C++
virtual void zeroEarnOasdi(
    int,
    int
);
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral::zeroOasdi Method

WorkerDataGeneral::zeroOasdi Method
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Methods

Zeroes out the type of benefit.

C++
void zeroOasdi();
Collapse Expand Group

WorkerDataGeneral Methods

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Methods


WorkerDataGeneral Friends

WorkerDataGeneral Friends
WorkerDataGeneral Class Public Friends

The friends of the WorkerDataGeneral class are listed here.

Collapse Expand Class

WorkerDataGeneral Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Links
WorkerDataGeneral Class, Public Friends


friend class boost::serialization::access Friend

friend class boost::serialization::access Friend
WorkerDataGeneral Class WorkerDataGeneral Members WorkerDataGeneral Friends

Friend class to allow serialization.

C++
friend class boost::serialization::access;
Collapse Expand Group

WorkerDataGeneral Friends

Collapse Expand Links
WorkerDataGeneral Class, WorkerDataGeneral Members, WorkerDataGeneral Friends


Functions

Functions
Functions Legend PiaData Library

The following table lists functions in this documentation.

Collapse Expand Functions
Name | Description
isDebugPid | Returns true if argument person id is the debug pid.
Collapse Expand Module

PiaData Library

Collapse Expand Links
Functions, Legend, PiaData Library


isDebugPid Function

isDebugPid Function
DebugCase.h Functions
C++
bool isDebugPid(
    unsigned long pid
);
Collapse Expand File

File: DebugCase.h

Module: PiaData Library

Collapse Expand Parameters
Parameters | Description
unsigned long pid | Requested person id.
Collapse Expand Returns

True if argument person id is the debug pid.

Collapse Expand Description

Returns true if argument person id is the debug pid.

Collapse Expand Group

Functions

Collapse Expand Links
DebugCase.h, Functions


Variables

Variables
PiaData Library Variables

The following table lists variables in this documentation.

Collapse Expand Module

PiaData Library

Collapse Expand Variables
Name | Description
BASEYR | Base year for trust fund projection arrays on January 1 basis.
BASEYR1 | Base year for trust fund projection arrays on during-year basis.
DEBUGPID | Value of 999999 is reserved. It means print out for all pid's.
LASTYEARLR | Last year of long-range projection arrays.
LASTYRSR | Last year of short-range projection arrays.
MAXEARN | Maximum annual earnings allowed.
MAXYRS | Maximum number of years of earnings for one individual.
MAXYRSR | Number of years of data in trust fund projections, January 1 basis.
MAXYRSR1 | Number of years of data in trust fund projections, during-year basis.
ORSYR | Base year for ORS trust fund projection data.
YEAR2075 | Last possible year of projection.
YEAR2080 | Last possible year of projection.
YEAR2085 | Last possible year of projection.
YEAR2090 | Last possible year of projection.
YEAR2095 | Last possible year of projection.
YEAR2100 | Last possible year of projection.
YEAR2105 | Last possible year of projection.
YEAR2200 | Last possible year for dates.
YEAR36 | Year before first year of Social Security.
YEAR37 | Base year for many data arrays.
YEAR50 | Year before first year of major revisions to Social Security.
YEAR51 | First year of major revisions to Social Security.
YEAR69 | First year of many OACT projection arrays.
YEAR70 | First year of many OACT projection arrays.
YEAR74 | First year of many OACT projection arrays.
YEAR75 | First year of many OACT projection arrays.
YEAR79 | First year of bend points.
Collapse Expand Links
PiaData Library, Variables


BASEYR Variable

BASEYR Variable
oactcnst.h Variables

Base year for trust fund projection arrays on January 1 basis.

C++
const int BASEYR = 1974;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


BASEYR1 Variable

BASEYR1 Variable
oactcnst.h Variables

Base year for trust fund projection arrays on during-year basis.

C++
const int BASEYR1 = 1975;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


DEBUGPID Variable

DEBUGPID Variable
DebugCase.cpp Variables
C++
const unsigned long DEBUGPID = 1;
Collapse Expand File

File: DebugCase.cpp

Module: PiaData Library

Collapse Expand Description

Value of 999999 is reserved. It means print out for all pid's.

Collapse Expand Group

Variables

Collapse Expand Links
DebugCase.cpp, Variables


LASTYEARLR Variable

LASTYEARLR Variable
oactcnst.h Variables

Last year of long-range projection arrays.

C++
const int LASTYEARLR = 2105;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


LASTYRSR Variable

LASTYRSR Variable
oactcnst.h Variables

Last year of short-range projection arrays.

C++
const int LASTYRSR = BASEYR + MAXYRSR1;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


MAXEARN Variable

MAXEARN Variable
oactcnst.h Variables

Maximum annual earnings allowed.

C++
const double MAXEARN = 9999999.99;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


MAXYRS Variable

MAXYRS Variable
oactcnst.h Variables

Maximum number of years of earnings for one individual.

C++
const int MAXYRS = 80;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


MAXYRSR Variable

MAXYRSR Variable
oactcnst.h Variables

Number of years of data in trust fund projections, January 1 basis.

C++
const int MAXYRSR = 67;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Remarks

When using 67, data runs from January 1, 1975 through January 1, 2041.

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


MAXYRSR1 Variable

MAXYRSR1 Variable
oactcnst.h Variables

Number of years of data in trust fund projections, during-year basis.

C++
const int MAXYRSR1 = 66;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Remarks

When using 66, data runs from 1975 through 2040.

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


ORSYR Variable

ORSYR Variable
oactcnst.h Variables

Base year for ORS trust fund projection data.

C++
const int ORSYR = 1981;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR2075 Variable

YEAR2075 Variable
oactcnst.h Variables

Last possible year of projection.

C++
const int YEAR2075 = 2075;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR2080 Variable

YEAR2080 Variable
oactcnst.h Variables

Last possible year of projection.

C++
const int YEAR2080 = 2080;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR2085 Variable

YEAR2085 Variable
oactcnst.h Variables

Last possible year of projection.

C++
const int YEAR2085 = 2085;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR2090 Variable

YEAR2090 Variable
oactcnst.h Variables

Last possible year of projection.

C++
const int YEAR2090 = 2090;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR2095 Variable

YEAR2095 Variable
oactcnst.h Variables

Last possible year of projection.

C++
const int YEAR2095 = 2095;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR2100 Variable

YEAR2100 Variable
oactcnst.h Variables

Last possible year of projection.

C++
const int YEAR2100 = 2100;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR2105 Variable

YEAR2105 Variable
oactcnst.h Variables

Last possible year of projection.

C++
const int YEAR2105 = 2105;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR2200 Variable

YEAR2200 Variable
oactcnst.h Variables

Last possible year for dates.

C++
const int YEAR2200 = 2200;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR36 Variable

YEAR36 Variable
oactcnst.h Variables

Year before first year of Social Security.

C++
const int YEAR36 = 1936;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR37 Variable

YEAR37 Variable
oactcnst.h Variables

Base year for many data arrays.

C++
const int YEAR37 = 1937;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR50 Variable

YEAR50 Variable
oactcnst.h Variables

Year before first year of major revisions to Social Security.

C++
const int YEAR50 = 1950;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR51 Variable

YEAR51 Variable
oactcnst.h Variables

First year of major revisions to Social Security.

C++
const int YEAR51 = 1951;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR69 Variable

YEAR69 Variable
oactcnst.h Variables

First year of many OACT projection arrays.

C++
const int YEAR69 = 1969;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR70 Variable

YEAR70 Variable
oactcnst.h Variables

First year of many OACT projection arrays.

C++
const int YEAR70 = 1970;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR74 Variable

YEAR74 Variable
oactcnst.h Variables

First year of many OACT projection arrays.

C++
const int YEAR74 = 1974;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR75 Variable

YEAR75 Variable
oactcnst.h Variables

First year of many OACT projection arrays.

C++
const int YEAR75 = 1975;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


YEAR79 Variable

YEAR79 Variable
oactcnst.h Variables

First year of bend points.

C++
const int YEAR79 = 1979;
Collapse Expand File

File: oactcnst.h

Module: PiaData Library

Collapse Expand Group

Variables

Collapse Expand Links
oactcnst.h, Variables


Files

Files
Files PiaData Library

The following table lists files in this documentation.

Collapse Expand Files
Name | Description
Assumptions.cpp | Functions for the Assumptions class - parent of classes that manage the average wage and benefit increase assumptions.
Assumptions.h | Declarations for the Assumptions class - parent of classes that manage the average wage and benefit increase assumptions.
AssumptionsFile.cpp | Functions for the AssumptionsFile class that reads the average wage and benefit increase parameters from disk storage.
AssumptionsFile.h | Declarations for the AssumptionsFile class that reads the average wage and benefit increase parameters from disk storage.
AssumptionsNonFile.cpp | Functions for the AssumptionsNonFile class that contains the average wage and benefit increase parameters (it does not read from disk).
AssumptionsNonFile.h | Declarations for the AssumptionsNonFile class that contains the average wage and benefit increase parameters (it does not read from disk).
AssumptionType.cpp | Functions of the AssumptionType class containing the assumption types allowed in the piadata library.
AssumptionType.h | Declaration of the AssumptionType class containing the assumption types allowed in the piadata library.
avgwg.cpp | Functions needed for AverageWage class to manage array of average wages.
avgwg.h | Declarations needed for AverageWage class to manage array of average wages.
awbidat.cpp | Functions of the AwbiData class to manage historical Social Security parameters.
awbidat.h | Declaration of the AwbiData class to manage historical Social Security parameters.
AwbiDataFile.h | Declaration of the AwbiDataFile class to manage historical Social Security parameters stored in a file.
AwbiDataNonFile.h | Declaration of the AwbiDataNonFile class to manage historical Social Security parameters stored with the code.
awbidtfl.cpp | Functions of the AwbiDataFile class to manage historical Social Security parameters stored in a file.
awbidtnf.cpp | Functions of the AwbiDataNonFile class to manage historical Social Security parameters stored with the code.
awinc.cpp | Functions for the Awinc class to manage a vector of average wage increases.
awinc.h | Declarations for the Awinc class to manage a vector of average wage increases.
AwincDoc.cpp | Functions for the AwincDoc class to manage average wage increases.
AwincDoc.h | Declarations for the AwincDoc class to manage average wage increases.
AwincFile.h | Declarations needed for AwincFile class to manage average wage increases stored on disk.
awincfl.cpp | Functions needed for AwincFile class to manage average wage increases stored on disk.
awincnf.cpp | Functions for the AwincNonFile class to manage average wage increases stored in static arrays.
AwincNonFile.h | Declarations for the AwincNonFile class to manage average wage increases stored in static arrays.
BaseChangeType.cpp | Functions of the BaseChangeType class with the wage base change types allowed in the piadata library.
BaseChangeType.h | Declaration of the BaseChangeType class with the wage base change types allowed in the piadata library.
baseyear.cpp | Functions for the BaseYear class - parent of classes that manage the computation year for a pia program.
baseyear.h | Declarations for the BaseYear class - parent of classes that manage the computation year for a pia program.
BaseYearFile.h | Declarations for the BaseYearFile class to manage the computation year on disk.
BaseYearNonFile.h | Declarations for the BaseYearNonFile class to manage the computation year stored internally.
baseyrfl.cpp | Functions for the BaseYearFile class to manage the computation year on disk.
baseyrnf.cpp | Functions for the BaseYearNonFile class to manage the computation year stored internally.
BendPoints.h | Includes for the class that handles PIA and MFB formula bend points.
BenefitAmount.cpp | Functions for the BenefitAmount class to handle Social Security benefit amount.
BenefitAmount.h | Declarations for the BenefitAmount class to handle Social Security benefit amount.
BenefitAmountArray.cpp | Functions for the BenefitAmountArray class of an array of Social Security benefit amounts.
BenefitAmountArray.h | Declarations for the BenefitAmountArray class of an array of Social Security benefit amounts.
Bic.cpp | Functions for the Bic class to manage bic (Beneficiary Identification code) code.
bic.h | Declarations for the Bic class to manage bic (Beneficiary Identification code) code.
biproj.cpp | Functions for the Biproj class to manage projected benefit increases.
biproj.h | Declarations for the Biproj class to manage projected benefit increases.
BiprojFile.h | Declarations for the BiprojFile class to manage projected benefit increases stored on disk.
biprojfl.cpp | Declarations for the BiprojFile class to manage projected benefit increases stored on disk.
biprojnf.cpp | Functions for the BiprojNonFile class to manage projected benefit increases stored in arrays.
BiprojNonFile.h | Declarations for the BiprojNonFile class to manage projected benefit increases stored in arrays.
bpmfbout.cpp | Functions for the BpMfbOut class to manage array of mfb formula bend points.
bpmfbout.h | Declarations for the BpMfbOut class to manage array of mfb formula bend points.
bppiaout.cpp | Functions for the BpPiaOut class to manage array of pia formula bend points.
bppiaout.h | Declarations for the BpPiaOut class to manage array of pia formula bend points.
cachpdoc.cpp | Functions for the CatchupDoc class to manage a set of catch-up benefit increases.
cachup.cpp | Functions for the CatchupIncreases and Catchup classes to manage catch-up benefit increases.
cachup.h | Declarations for the CatchupIncreases and Catchup classes to manage catch-up benefit increases.
cachupf.h | Declarations for the CatchupDoc class to manage a set of catch-up benefit increases.
cachupfl.cpp | Functions for the CatchupFile class to manage file of catch-up benefit increases.
cachupnf.cpp | Functions for the CatchupNonFile class to manage a set of catch-up benefit increases stored in arrays.
CatchupFile.h | Declarations for the CatchupFile class to manage file of catch-up benefit increases.
CatchupNonFile.h | Declarations for the CatchupNonFile class to manage a set of catch-up benefit increases stored in arrays.
ChildCareCalc.cpp | Functions for the ChildCareCalc class to manage childcare dropout year pia calculations.
ChildCareCalc.h | Declarations for the ChildCareCalc class to manage childcare dropout year pia calculations.
ChildCareCalcLC.cpp | Functions for the ChildCareCalcLC class to manage childcare dropout year pia calculations, with law changes.
ChildCareCalcLC.h | Declarations for the ChildCareCalcLC class to manage childcare dropout year pia calculations, with law changes.
comppd.h | Declarations for the CompPeriod class to manage computation period variables.
CompPeriod.cpp | Functions for the CompPeriod class to manage computation period variables.
config.cpp | Functions for the Config class to manage configuration information used by the PIA calculation program.
config.h | Declarations for the Config class to manage configuration information used by the PIA calculation program.
configFile.cpp | Functions for the ConfigFile class to manage configuration information used by the PIA calculation program stored on disk.
ConfigFile.h | Declarations for the ConfigFile class to manage configuration information used by the PIA calculation program stored on disk.
configNonFile.cpp | Functions for the ConfigNonFile class to manage configuration information used by the PIA calculation program stored internally.
ConfigNonFile.h | Declarations for the ConfigNonFile class to manage configuration information used by the PIA calculation program stored internally.
DebugCase.cpp |
DebugCase.h |
DibGuar.cpp | Functions for the DibGuar class to manage disability guarantee pia calculations.
DibGuar.h | Declarations for the DibGuar class to manage disability guarantee pia calculations.
DibGuarLC.cpp | Functions for the DibGuarLC class to manage disability guarantee pia calculations with law changes.
DibGuarLC.h | Declarations for the DibGuarLC class to manage disability guarantee pia calculations with law changes.
dinscode.cpp | Functions for the DisInsCode class representing a disability insured status code.
dinscode.h | Declarations for the DisInsCode class representing a disability insured status code.
DisabPeriod.cpp | Functions for the DisabPeriod class to manage a period of disability.
DisabPeriod.h | Declarations for the DisabPeriod class to manage a period of disability.
DisInsCodeArray.cpp | Functions for the DisInsCodeArray class to manage an array of disability insured status codes.
DisInsCodeArray.h | Declarations for the DisInsCodeArray class to manage an array of disability insured status codes.
EarnProject.cpp | Functions for the EarnProject class to handle an array of earnings, with forward and backward projections and specified levels of earnings.
EarnProject.h | Declarations for the EarnProject class to handle an array of earnings, with forward and backward projections and specified levels of earnings.
FieldOfficeInfoFile.h | Declarations for the FieldOfficeInfoFile class to manage field office information stored on disk.
FieldOfficeInfoNonFile.h | Declarations for the FieldOfficeInfoNonFile class to manage field office information stored in memory.
foinfo.cpp | Functions for the FieldOfficeInfo class to manage field office information.
foinfo.h | Declarations for the FieldOfficeInfo class to manage field office information.
foinfofl.cpp | Functions for the FieldOfficeInfoFile class to manage field office information stored on disk.
foinfonf.cpp | Functions for the FieldOfficeInfoNonFile class to manage field office information stored in memory.
FrozMin.cpp | Functions for the FrozMin class to manage frozen minimum pia calculations.
FrozMin.h | Declarations for the FrozMin class to manage frozen minimum pia calculations.
frzyrs.cpp | Functions for the FreezeYears class to manage freeze period variables.
frzyrs.h | Declarations for the FreezeYears class to manage freeze period variables.
inscode.cpp | Functions for the InsCode class to manage an insured status code.
inscode.h | Declarations for the InsCode class to manage an insured status code.
InsCodeArray.cpp | Functions for the InsCodeArray class to manage an array of insured status codes.
InsCodeArray.h | Declarations for the InsCodeArray class to manage an array of insured status codes.
LawChange.cpp | Functions for the LawChange class to manage law-change parameters.
LawChange.h | Declarations for the LawChange class to manage law-change parameters.
LawChangeAGE65COMP.cpp | Functions for the LawChangeAGE65COMP class to manage parameters for a proposal to increase the number of elapsed years in a pia calculation.
LawChangeAGE65COMP.h | Declarations for the LawChangeAGE65COMP class to manage parameters for a proposal to increase the number of elapsed years in a pia calculation.
LawChangeALLEARN.cpp | Functions for the LawChangeALLEARN class to manage parameters for a proposal to use all years of earnings in an AIME calculation.
LawChangeALLEARN.h | Declarations for the LawChangeALLEARN class to manage parameters for a proposal to use all years of earnings in an AIME calculation.
LawChangeArray.cpp | Functions for the LawChangeArray class to manage an array of LawChange parameters.
LawChangeArray.h | Declarations for the LawChangeArray class to manage an array of LawChange parameters.
LawChangeBPFRACWAGE.cpp | Functions for the LawChangeBPFRACWAGE class to manage parameters for a proposal to increase the bend points in the benefit formula by a fraction of average wage growth.
LawChangeBPFRACWAGE.h | Declarations for the LawChangeBPFRACWAGE class to manage parameters for a proposal to increase the bend points in the benefit formula by a fraction of average wage growth.
LawChangeBPMINCONST.cpp | Functions for the LawChangeBPMINCONST class to manage parameters for a proposal to increase the bend points in the benefit formula by the growth in wages minus a specified rate.
LawChangeBPMINCONST.h | Declarations for the LawChangeBPMINCONST class to manage parameters for a proposal to increase the bend points in the benefit formula by the growth in wages minus a specified rate.
LawChangeBPSPECRATE.cpp | Functions for the LawChangeBPSPECRATE class to manage parameters for a proposal to increase the bend points in the benefit formula by a specified growth rate.
LawChangeBPSPECRATE.h | Declarations for the LawChangeBPSPECRATE class to manage parameters for a proposal to increase the bend points in the benefit formula by a specified growth rate.
LawChangeCHILDCARECREDIT.cpp | Functions for the LawChangeCHILDCARECREDIT class to manage parameters for a proposal to provide child care credits.
LawChangeCHILDCARECREDIT.h | Declarations for the LawChangeCHILDCARECREDIT class to manage parameters for a proposal to provide child care credits.
LawChangeCHILDCAREDROPOUT.cpp | Functions for the LawChangeCHILDCAREDROPOUT class to manage parameters for a proposal to provide child care dropout years.
LawChangeCHILDCAREDROPOUT.h | Declarations for the LawChangeCHILDCAREDROPOUT class to manage parameters for a proposal to provide child care dropout years.
LawChangeCOLACHANGE.cpp | Functions for the LawChangeCOLACHANGE class to manage parameters for a proposal to change the cost-of-living benefit increases.
LawChangeCOLACHANGE.h | Declarations for the LawChangeCOLACHANGE class to manage parameters for a proposal to change the cost-of-living benefit increases.
LawChangeDECLINEPERC.cpp | Functions for the LawChangeDECLINEPERC class to manage parameters for a proposal to decrease the benefit formula percentages by various rates.
LawChangeDECLINEPERC.h | Declarations for the LawChangeDECLINEPERC class to manage parameters for a proposal to decrease the benefit formula percentages by various rates.
LawChangeDROPOUTCHG.cpp | Functions for the LawChangeDROPOUTCHG class to manage parameters for a proposal to reduce the number of dropout years in a pia calculation.
LawChangeDROPOUTCHG.h | Declarations for the LawChangeDROPOUTCHG class to manage parameters for a proposal to reduce the number of dropout years in a pia calculation.
LawChangeMARRLENGTH.cpp | Functions for the LawChangeMARRLENGTH class to manage parameters for a proposal to change the length of marriage requirement for divorced spouse benefits.
LawChangeMARRLENGTH.h | Declarations for the LawChangeMARRLENGTH class to manage parameters for a proposal to change the length of marriage requirement for divorced spouse benefits.
LawChangeNEWFORMULA.cpp | Functions for the LawChangeNEWFORMULA class to manage parameters for a proposal to change the pia formula bend points and/or percentages.
LawChangeNEWFORMULA.h | Declarations for the LawChangeNEWFORMULA class to manage parameters for a proposal to change the pia formula bend points and/or percentages.
LawChangeNEWSPECMIN.cpp | Functions for the LawChangeNEWSPECMIN class to manage parameters for a proposal to change the special minimum pia calculation.
LawChangeNEWSPECMIN.h | Declarations for the LawChangeNEWSPECMIN class to manage parameters for a proposal to change the special minimum pia calculation.
LawChangeNRACHANGE.cpp | Functions for the LawChangeNRACHANGE class to manage parameters for a proposal to change the full retirement age.
LawChangeNRACHANGE.h | Declarations for the LawChangeNRACHANGE class to manage parameters for a proposal to change the full retirement age.
LawChangeOut.cpp | Functions for the LawChangeOut class to manage the output file of law change descriptions.
LawChangeOut.h | Declarations for the LawChangeOut class to manage the output file of law change descriptions.
LawChangePSAACCT.cpp | Functions for the LawChangePSAACCT class to manage parameters for a proposal to introduce individual accounts.
LawChangePSAACCT.h | Declarations for the LawChangePSAACCT class to manage parameters for a proposal to introduce individual accounts.
LawChangeRead.cpp | Functions for the LawChangeRead class to read law changes from a file.
LawChangeRead.h | Declarations for the LawChangeRead class to read law changes from a file.
LawChangeTAXBENCHG.cpp | Functions for the LawChangeTAXBENCHG class to manage parameters for a proposal to change the taxation of benefits.
LawChangeTAXBENCHG.h | Declarations for the LawChangeTAXBENCHG class to manage parameters for a proposal to change the taxation of benefits.
LawChangeTAXRATECHG.cpp | Functions for the LawChangeTAXRATECHG class to manage parameters for a proposal to change the OASDHI tax rates.
LawChangeTAXRATECHG.h | Declarations for the LawChangeTAXRATECHG class to manage parameters for a proposal to change the OASDHI tax rates.
LawChangeWAGEBASECHG.cpp | Functions for the LawChangeWAGEBASECHG class to manage parameters for a proposal to change the OASDI and/or old-law wage bases.
LawChangeWAGEBASECHG.h | Declarations for the LawChangeWAGEBASECHG class to manage parameters for a proposal to change the OASDI and/or old-law wage bases.
LawChangeWIDFACTOR.cpp | Functions for the LawChangeWIDFACTOR class to manage parameters for a proposal to change the factor for an aged widow(er) benefit.
LawChangeWIDFACTOR.h | Declarations for the LawChangeWIDFACTOR class to manage parameters for a proposal to change the factor for an aged widow(er) benefit.
LawChangeWIFEFACTOR.cpp | Functions for the LawChangeWIFEFACTOR class to manage parameters for a proposal to change the factor for an aged spouse benefit.
LawChangeWIFEFACTOR.h | Declarations for the LawChangeWIFEFACTOR class to manage parameters for a proposal to change the factor for an aged spouse benefit.
LawChangeWrite.cpp | Functions for the LawChangeWrite class to write law changes to a file.
LawChangeWrite.h | Declarations for the LawChangeWrite class to write law changes to a file.
MilServDatesVec.h | Declarations for the MilServDatesVec class to manage an array of military service dates records.
msdates.cpp | Functions for the MilServDates class to manage one military service dates record.
msdates.h | Declarations for the MilServDates class to manage one military service dates record.
msdatesvec.cpp | Functions for the MilServDatesVec class to manage an array of military service dates records.
oactcnst.h | Constants used in the various Oact C++ programs and utilities.
oldpia.cpp | Functions for the OldPia class - parent of all methods using pia tables in the calculation of a Social Security benefit.
OldPia.h | Declarations for the OldPia class - parent of all methods using pia tables in the calculation of a Social Security benefit.
oldstart.cpp | Functions for the OldStart class to manage old-start pia calculations.
OldStart.h | Declarations for the OldStart class to manage old-start pia calculations.
OldStartLC.cpp | Functions for the OldStartLC class to manage old-start pia calculations, with changes from present law.
OldStartLC.h | Declarations for the OldStartLC class to manage old-start pia calculations, with changes from present law.
pebs.cpp | Functions for the Pebs class to handle Social Security Statement data.
pebs.h | Declarations for the Pebs class to handle Social Security Statement data.
percmfb.cpp | Functions to handle MFB formula percentages.
percmfb.h | Declarations needed for class to manage array of MFB formula percentages.
percpia.cpp | Functions to handle PIA formula percentages.
percpia.h | Declarations needed for class to manage array of PIA formula percentages.
PercPiaOut.cpp | Functions for the PercPiaOut class to manage array of pia formula percentages.
PercPiaOut.h | Declarations for the PercPiaOut class to manage array of pia formula percentages.
piacal.cpp | Functions for the PiaCal class - parent of all classes that manage the calculation of a Social Security benefit.
piacal.h | Declarations for the PiaCal class - parent of all classes that manage the calculation of a Social Security benefit.
piacalany.cpp | Functions for the PiaCalAny class to manage pia calculation functions used in Anypia.
PiaCalAny.h | Declarations for the PiaCalAny class to manage pia calculation functions used in Anypia.
piacallc.cpp | Functions for the PiaCalLC class to manage law-change pia calculation functions.
PiaCalLC.h | Declarations for the PiaCalLC class to manage law-change pia calculation functions.
PiaCalPL.cpp | Functions for the PiaCalPL class to manage present law pia calculation functions.
PiaCalPL.h | Declarations for the PiaCalPL class to manage present law pia calculation functions.
piadata.cpp | Functions for the PiaData class to set up data to calculate and print out a PIA.
piadata.h | Declarations for the PiaData class to set up data to calculate and print out a PIA.
PiadataArray.cpp | Functions for the PiaDataArray class to manage an array of PiaData's, representing one family.
PiadataArray.h | Declarations for the PiaDataArray class to manage an array of PiaData's, representing one family.
PiaMethod.cpp | Functions for the PiaMethod class - parent of the various methods required for calculation of a Social Security benefit.
PiaMethod.h | Declarations for the PiaMethod class - parent of the various methods required for calculation of a Social Security benefit.
PiaParamsLCTR.cpp | Functions for the PiaParamsLCTR class to manage the changed law Social Security parameters, already projected based on a Trustees Report assumption.
PiaParamsLCTR.h | Declarations for the PiaParamsLCTR class to manage the changed law Social Security parameters, already projected based on a Trustees Report assumption.
PiaParamsTR.cpp | Functions for the PiaParamsTR class of pia calculation parameters using present law only, with projected values set to Trustees Report assumptions.
PiaParamsTR.h | Declarations for the PiaParamsTR class of pia calculation parameters using present law only, with projected values set to Trustees Report assumptions.
piaparms.cpp | Functions for the PiaParams class - parent of classes to manage the Social Security parameters required to calculate a Social Security benefit.
piaparms.h | Declarations for the PiaParams class - parent of classes to manage the Social Security parameters required to calculate a Social Security benefit.
piaparmsAny.cpp | Functions for the PiaParamsAny class to manage the Social Security parameters required to calculate Social Security benefits in the Anypia program.
piaparmsAny.h | Declarations for the PiaParamsAny class to manage the Social Security parameters required to calculate Social Security benefits in the Anypia program.
piaparmsLC.cpp | Functions for the PiaParamsLC class to handle changed law PIA parameters.
piaparmsLC.h | Declarations for the PiaParamsLC class to handle changed law PIA parameters.
piaparmsPL.cpp | Functions for the PiaParamsPL class of pia calculation parameters using present law only.
piaparmsPL.h | Declarations for the PiaParamsPL class of pia calculation parameters using present law only.
piaread.cpp | Functions for the PiaRead class to read a file of worker data from disk.
piaread.h | Declarations for the PiaRead class to read a file of worker data from disk.
piareadAny.cpp | Functions for the PiaReadAny class to read worker data for Anypia.
piareadAny.h | Declarations for the PiaReadAny class to read worker data for Anypia.
PiaTable.cpp | Functions for the PiaTable class to manage Pia Table pia calculations.
PiaTable.h | Declarations for the PiaTable class to manage Pia Table pia calculations.
PiaTableLC.cpp | Functions for the PiaTableLC class to manage Pia Table pia calculations, with changes from present law.
PiaTableLC.h | Declarations for the PiaTableLC class to manage Pia Table pia calculations, with changes from present law.
piawrite.cpp | Functions for the PiaWrite class to write out worker data.
piawrite.h | Declarations for the PiaWrite class to write out worker data.
piawriteAny.cpp | Functions for the PiaWriteAny class to write out worker data for Anypia program.
piawriteAny.h | Declarations for the PiaWriteAny class to write out worker data for Anypia program.
pib50mfb.cpp | Functions for the Pib50Mfb class to handle 1950 pib-mfb conversion table.
pib50pib.cpp | Functions for the Pib50Pib class to handle 1950 pib-pia conversion table.
pib52ame.cpp | Functions for the class to handle 1952 pib-ame conversion table.
bendmfb.cpp | Functions to handle MFB formula bend points.
pib52mfb.cpp | Functions for the class to handle 1952 pib-mfb conversion table.
bendpia.cpp | Functions for the BendPia class to handle PIA formula bend points.
pib54ame.cpp | Functions for the class to handle 1954 pib-ame conversion table.
pib54mfb.cpp | Functions for the class to handle 1954 pib-mfb conversion table.
pib54pia.cpp | Functions for the class to handle 1954 pib-pia conversion table.
pib58ame.cpp | Functions for the class to handle 1958 pib-ame conversion table.
pib58pib.cpp | Functions for the class to handle 1958 pib-pia conversion table.
pibtable.h | Declarations for the Pib50Mfb, Pib50Pib, Pib52Ame, Pib52Mfb, Pib54Ame, Pib54Mfb, Pib54Pia, Pib58Ame, and Pib58Pib classes to manage pib-pia conversion tables.
Pifc.cpp | Functions for the Pifc class representing a type of Social Security pia.
Pifc.h | Declarations for the Pifc class representing a type of Social Security pia.
PresValFacs.cpp | Functions for the PresValFacs class to handle present value factors.
PresValFacs.h | Declarations for the PresValFacs class to handle present value factors.
Psa.cpp | Functions for Psa class to manage PSA accounts.
Psa.h | Declarations for Psa class to manage PSA accounts.
qc.cpp | Functions for the Qc class to manage one annual quarters of coverage number.
qc.h | Declarations for the Qc class to manage one annual quarters of coverage number.
qcamt.cpp | Functions for the Qcamt class to manage array of amounts required for quarter of coverage.
qcamt.h | Declarations for the Qcamt class to manage array of amounts required for quarter of coverage.
QcArray.cpp | Functions for the QcArray class to handle an array of annual number of quarters of coverage.
QcArray.h | Declarations for the QcArray class to handle an array of annual number of quarters of coverage.
QcPacked.cpp | Functions for the QcPacked class to hold 8 quarters of coverage amounts in one word.
QcPacked.h | Declaration of the QcPacked class to hold 8 quarters of coverage amounts in one word.
railroad.cpp | Functions for the RailRoadData class to manage edited railroad record.
railroad.h | Declarations for the RailRoadData class to manage edited railroad record.
ReindWid.cpp | Functions for the ReindWid class to manage reindexed widow(er) pia calculations.
ReindWid.h | Declarations for the ReindWid class to manage reindexed widow(er) pia calculations.
ReindWidLC.cpp | Functions for the ReindWidLC class to manage reindexed widow(er) pia calculation with law changes.
ReindWidLC.h | Declarations for the ReindWidLC class to manage reindexed widow(er) pia calculation with law changes.
RetireTest.cpp | Functions for the RetireTest class to manage retirement test calculations.
RetireTest.h | Declarations for the RetireTest class to manage retirement test calculations.
rtgenrl.cpp | Functions for the RtGeneral class - parent of classes to manage one retirement test projection.
rtgenrl.h | Declarations for the RtGeneral class - parent of classes to manage one retirement test projection.
ScaledEarnFactors.cpp | Functions for the ScaledEarnFactors class of scaled earnings factors.
ScaledEarnFactors.h | Declarations for the ScaledEarnFactors class of scaled earnings factors.
Secondary.cpp | Functions for the Secondary class containing the information about a secondary benefit.
Secondary.h | Declarations for the Secondary class containing the information about a secondary benefit.
SecondaryArray.cpp | Functions for the SecondaryArray class to manage a vector of secondary benefit data.
SecondaryArray.h | Declarations for the SecondaryArray class to manage a vector of secondary benefit data.
Sga.cpp | Functions for the Sga class to manage SGA amounts.
Sga.h | Declarations for the Sga class to manage SGA amounts.
SgaDerived.cpp | Functions for the SgaBlindA, SgaBlindM, SgaMinA, SgaMinM, SgaMaxA, and SgaMaxM classes (derived classes of the SgaGeneral class).
SgaDerived.h | Declarations for the SgaBlindA, SgaBlindM, SgaMinA, SgaMinM, SgaMaxA, and SgaMaxM classes (derived classes of the SgaGeneral class).
SgaGeneral.cpp | Functions for the SgaGeneral class - parent of classes to handle historical and projected SGA (Substantial Gainful Activity) amounts, stored in arrays.
SgaGeneral.h | Declarations for the SgaGeneral class - parent of classes to handle historical and projected SGA (Substantial Gainful Activity) amounts, stored in arrays.
SpecMin.cpp | Functions for the SpecMin class to manage special minimum pia calculations.
SpecMin.h | Declarations for the SpecMin class to manage special minimum pia calculations.
SpecMinLC.cpp | Functions for the SpecMinLC class to manage special minimum pia calculations, including changes from present law.
SpecMinLC.h | Declarations for the SpecMinLC class to manage special minimum pia calculations, including changes from present law.
TaxBenefits.cpp | Functions for the TaxBenefits class to manage tax on benefits functions.
TaxBenefits.h | Declarations for the TaxBenefits class to manage tax on benefits functions.
TaxBenefitsLC.cpp | Functions for the TaxBenefitsLC class to manage tax on benefits functions with law changes.
TaxBenefitsLC.h | Declarations for the TaxBenefitsLC class to manage tax on benefits functions with law changes.
TaxData.cpp | Functions for the TaxData class to manage taxes paid by a worker.
TaxData.h | Declarations for the TaxData class to manage taxes paid by a worker.
TaxRates.cpp | Functions for the TaxRates class - parent of classes to manage OASDHI tax rates.
TaxRates.h | Declarations for the TaxRates class - parent of classes to manage OASDHI tax rates.
TaxRatesLC.cpp | Functions for the TaxRatesLC class to manage the Social Security payroll and self-employed tax rates, with changes from present law.
TaxRatesLC.h | Declarations for the TaxRatesLC class to manage the Social Security payroll and self-employed tax rates, with changes from present law.
TaxRatesPL.cpp | Functions for the TaxRatesPL class to manage the Social Security payroll and self-employed tax rates.
TaxRatesPL.h | Declarations for the TaxRatesPL class to manage the Social Security payroll and self-employed tax rates.
TransGuar.cpp | Functions for the TransGuar class to manage transitional guarantee pia calculations.
TransGuar.h | Declarations for the TransGuar class to manage transitional guarantee pia calculations.
TransGuarLC.cpp | Functions for the TransGuarLC class to manage transitional guarantee pia calculations, with changes from present law.
TransGuarLC.h | Declarations for the TransGuarLC class to manage transitional guarantee pia calculations, with changes from present law.
UserAssumptions.cpp | Functions for the UserAssumptions class to manage user-specified assumptions.
UserAssumptions.h | Declarations for the UserAssumptions class to manage user-specified assumptions.
WageBase.cpp | Functions for the WageBase, WageBaseHI, and WageBaseOldLaw classes to manage wage base projections.
WageBase.h | Declarations for the WageBase, WageBaseHI, and WageBaseOldLaw classes to manage wage base projections.
WageInd.cpp | Functions for the WageInd class to calculate a wage-indexed PIA.
WageInd.h | Declarations for the WageInd class to manage wage-indexed pia calculation functions.
WageIndGeneral.cpp | Functions for the WageIndGeneral class - parent of classes to manage wage-indexed pia calculations.
WageIndGeneral.h | Declarations for the WageIndGeneral class - parent of classes to manage wage-indexed pia calculations.
WageIndLC.cpp | Functions for the WageIndLC class to manage wage-indexed pia calculation, with law change parameters.
WageIndLC.h | Declarations for the WageIndLC class to manage wage-indexed pia calculation, with law change parameters.
WageIndNonFreeze.cpp | Functions for the WageIndNonFreeze class to calculate a wage-indexed non-freeze PIA.
WageIndNonFreeze.h | Declarations for the WageIndNonFreeze class to manage wage-indexed non-freeze pia calculation functions.
wbgenrl.cpp | Functions for the WageBaseGeneral class - parent of classes that manage wage base projections.
wbgenrl.h | Declarations for the WageBaseGeneral class - parent of classes that manage wage base projections.
wbgenrlLC.cpp | Functions for the WageBaseLC and WageBaseOldLawLC classes to manage wage base projections with law changes.
wbgenrlLC.h | Declarations for the WageBaseLC and WageBaseOldLawLC classes to manage wage base projections with law changes.
WorkerDataArray.cpp | Functions for the WorkerDataArray class to manage array of WorkerData's.
WorkerDataArray.h | Declarations for the WorkerDataArray class to manage array of WorkerData's.
WorkerDataGeneral.cpp | Functions for the WorkerDataGeneral class - parent of classes to manage worker data.
WorkerDataGeneral.h | Declarations for the WorkerDataGeneral class - parent of classes to manage worker data.
wrkrdata.cpp | Functions for the WorkerData class to manage worker data.
wrkrdata.h | Declarations for the WorkerData class to manage worker data.
bendmfb.h | Declarations needed for class to manage array of MFB formula bend points.
bendpia.h | Declarations for the BendPia class to manage array of PIA formula bend points.
PortionAime.cpp | Functions to handle PIA formula AIME portions.
PortionAime.h | Declarations needed for class to manage array of portions of AIME in the PIA formula.
Collapse Expand Module

PiaData Library

Collapse Expand Links
Files, PiaData Library


Assumptions.cpp

Assumptions.cpp
Files

Functions for the Assumptions class - parent of classes that manage the average wage and benefit increase assumptions.

Collapse Expand Group

Files

Collapse Expand Links
Files


Assumptions.h

Assumptions.h
Classes Files Legend

Declarations for the Assumptions class - parent of classes that manage the average wage and benefit increase assumptions.

Collapse Expand Classes
Name | Description
Assumptions | Parent of classes that manage the average wage and benefit increase assumptions.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


AssumptionsFile.cpp

AssumptionsFile.cpp
Files

Functions for the AssumptionsFile class that reads the average wage and benefit increase parameters from disk storage.

Collapse Expand Group

Files

Collapse Expand Links
Files


AssumptionsFile.h

AssumptionsFile.h
Classes Files Legend

Declarations for the AssumptionsFile class that reads the average wage and benefit increase parameters from disk storage.

Collapse Expand Classes
Name | Description
AssumptionsFile | Reads the average wage and benefit increase parameters from disk storage.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


AssumptionsNonFile.cpp

AssumptionsNonFile.cpp
Files

Functions for the AssumptionsNonFile class that contains the average wage and benefit increase parameters (it does not read from disk).

Collapse Expand Group

Files

Collapse Expand Links
Files


AssumptionsNonFile.h

AssumptionsNonFile.h
Classes Files Legend

Declarations for the AssumptionsNonFile class that contains the average wage and benefit increase parameters (it does not read from disk).

Collapse Expand Classes
Name | Description
AssumptionsNonFile | Contains the average wage and benefit increase assumptions (it does not read from disk).
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


AssumptionType.cpp

AssumptionType.cpp
Files

Functions of the AssumptionType class containing the assumption types allowed in the piadata library.

Collapse Expand Group

Files

Collapse Expand Links
Files


AssumptionType.h

AssumptionType.h
Classes Files Legend

Declaration of the AssumptionType class containing the assumption types allowed in the piadata library.

Collapse Expand Classes
Name | Description
AssumptionType | The assumption types (about future average wage and benefit increases) allowed in the piadata library.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


avgwg.cpp

avgwg.cpp
Files

Functions needed for AverageWage class to manage array of average wages.

Collapse Expand Group

Files

Collapse Expand Links
Files


avgwg.h

avgwg.h
Classes Files Legend

Declarations needed for AverageWage class to manage array of average wages.

Collapse Expand Classes
Name | Description
AverageWage | Manages an array of average wage indexing amounts, or any other earnings series.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


awbidat.cpp

awbidat.cpp
Files

Functions of the AwbiData class to manage historical Social Security parameters.

Collapse Expand Group

Files

Collapse Expand Links
Files


awbidat.h

awbidat.h
Classes Files Legend

Declaration of the AwbiData class to manage historical Social Security parameters.

Collapse Expand Classes
Name | Description
AwbiData | Manages the historical Social Security parameters.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


AwbiDataFile.h

AwbiDataFile.h
Classes Files Legend

Declaration of the AwbiDataFile class to manage historical Social Security parameters stored in a file.

Collapse Expand Classes
Name | Description
AwbiDataFile | Manages the historical Social Security parameters stored in a file.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


AwbiDataNonFile.h

AwbiDataNonFile.h
Classes Files Legend

Declaration of the AwbiDataNonFile class to manage historical Social Security parameters stored with the code.

Collapse Expand Classes
Name | Description
AwbiDataNonFile | Manages the historical Social Security parameters stored in arrays in the code.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


awbidtfl.cpp

awbidtfl.cpp
Files

Functions of the AwbiDataFile class to manage historical Social Security parameters stored in a file.

Collapse Expand Group

Files

Collapse Expand Links
Files


awbidtnf.cpp

awbidtnf.cpp
Files

Functions of the AwbiDataNonFile class to manage historical Social Security parameters stored with the code.

Collapse Expand Group

Files

Collapse Expand Links
Files


awinc.cpp

awinc.cpp
Files

Functions for the Awinc class to manage a vector of average wage increases.

Collapse Expand Group

Files

Collapse Expand Links
Files


awinc.h

awinc.h
Classes Files Legend

Declarations for the Awinc class to manage a vector of average wage increases.

Collapse Expand Classes
Name | Description
Awinc | Manages a vector of projected average wage increases.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


AwincDoc.cpp

AwincDoc.cpp
Files

Functions for the AwincDoc class to manage average wage increases.

Collapse Expand Group

Files

Collapse Expand Links
Files


AwincDoc.h

AwincDoc.h
Classes Files Legend

Declarations for the AwincDoc class to manage average wage increases.

Collapse Expand Classes
Name | Description
AwincDoc | Abstract parent of classes that manage the file of projected average wage increases.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


AwincFile.h

AwincFile.h
Classes Files Legend

Declarations needed for AwincFile class to manage average wage increases stored on disk.

Collapse Expand Classes
Name | Description
AwincFile | Manages the file of projected average wage increases stored on disk.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


awincfl.cpp

awincfl.cpp
Files

Functions needed for AwincFile class to manage average wage increases stored on disk.

Collapse Expand Group

Files

Collapse Expand Links
Files


awincnf.cpp

awincnf.cpp
Files

Functions for the AwincNonFile class to manage average wage increases stored in static arrays.

Collapse Expand Group

Files

Collapse Expand Links
Files


AwincNonFile.h

AwincNonFile.h
Classes Files Legend

Declarations for the AwincNonFile class to manage average wage increases stored in static arrays.

Collapse Expand Classes
Name | Description
AwincNonFile | Manages the file of projected average wage increases stored in static arrays.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


BaseChangeType.cpp

BaseChangeType.cpp
Files

Functions of the BaseChangeType class with the wage base change types allowed in the piadata library.

Collapse Expand Group

Files

Collapse Expand Links
Files


BaseChangeType.h

BaseChangeType.h
Classes Files Legend

Declaration of the BaseChangeType class with the wage base change types allowed in the piadata library.

Collapse Expand Classes
Name | Description
BaseChangeType | The wage base change types allowed in the piadata library.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


baseyear.cpp

baseyear.cpp
Files

Functions for the BaseYear class - parent of classes that manage the computation year for a pia program.

Collapse Expand Group

Files

Collapse Expand Links
Files


baseyear.h

baseyear.h
Classes Files Legend

Declarations for the BaseYear class - parent of classes that manage the computation year for a pia program.

Collapse Expand Classes
Name | Description
BaseYear | Parent of classes that manage the computation year for a pia program.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


BaseYearFile.h

BaseYearFile.h
Classes Files Legend

Declarations for the BaseYearFile class to manage the computation year on disk.

Collapse Expand Classes
Name | Description
BaseYearFile | Manages the computation year for a pia program where it is gotten from disk.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


BaseYearNonFile.h

BaseYearNonFile.h
Classes Files Legend

Declarations for the BaseYearNonFile class to manage the computation year stored internally.

Collapse Expand Classes
Name | Description
BaseYearNonFile | Manages the computation year for a pia program where it is stored with the code.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


baseyrfl.cpp

baseyrfl.cpp
Files

Functions for the BaseYearFile class to manage the computation year on disk.

Collapse Expand Group

Files

Collapse Expand Links
Files


baseyrnf.cpp

baseyrnf.cpp
Files

Functions for the BaseYearNonFile class to manage the computation year stored internally.

Collapse Expand Group

Files

Collapse Expand Links
Files


BendPoints.h

BendPoints.h
Files

Includes for the class that handles PIA and MFB formula bend points.

Collapse Expand Group

Files

Collapse Expand Links
Files


BenefitAmount.cpp

BenefitAmount.cpp
Files

Functions for the BenefitAmount class to handle Social Security benefit amount.

Collapse Expand Group

Files

Collapse Expand Links
Files


BenefitAmount.h

BenefitAmount.h
Classes Files Legend

Declarations for the BenefitAmount class to handle Social Security benefit amount.

Collapse Expand Classes
Name | Description
BenefitAmount | Represents a benefit amount for one year.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


BenefitAmountArray.cpp

BenefitAmountArray.cpp
Files

Functions for the BenefitAmountArray class of an array of Social Security benefit amounts.

Collapse Expand Group

Files

Collapse Expand Links
Files


BenefitAmountArray.h

BenefitAmountArray.h
Classes Files Legend

Declarations for the BenefitAmountArray class of an array of Social Security benefit amounts.

Collapse Expand Classes
Name | Description
BenefitAmountArray | Manages an array of BenefitAmount's.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


Bic.cpp

Bic.cpp
Files

Functions for the Bic class to manage bic (Beneficiary Identification code) code.

Collapse Expand Group

Files

Collapse Expand Links
Files


bic.h

bic.h
Classes Files Legend

Declarations for the Bic class to manage bic (Beneficiary Identification code) code.

Collapse Expand Classes
Name | Description
Bic | Represents one 2-character bic (Beneficiary Identification code) code.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


biproj.cpp

biproj.cpp
Files

Functions for the Biproj class to manage projected benefit increases.

Collapse Expand Group

Files

Collapse Expand Links
Files


biproj.h

biproj.h
Classes Files Legend

Declarations for the Biproj class to manage projected benefit increases.

Collapse Expand Classes
Name | Description
Biproj | Abstract parent of classes that manage the file of projected benefit increases.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


BiprojFile.h

BiprojFile.h
Classes Files Legend

Declarations for the BiprojFile class to manage projected benefit increases stored on disk.

Collapse Expand Classes
Name | Description
BiprojFile | Manages the file of projected benefit increases stored on disk.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


biprojfl.cpp

biprojfl.cpp
Files

Declarations for the BiprojFile class to manage projected benefit increases stored on disk.

Collapse Expand Group

Files

Collapse Expand Links
Files


biprojnf.cpp

biprojnf.cpp
Files

Functions for the BiprojNonFile class to manage projected benefit increases stored in arrays.

Collapse Expand Group

Files

Collapse Expand Links
Files


BiprojNonFile.h

BiprojNonFile.h
Classes Files Legend

Declarations for the BiprojNonFile class to manage projected benefit increases stored in arrays.

Collapse Expand Classes
Name | Description
BiprojNonFile | Manages the file of projected benefit increases stored in arrays.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


bpmfbout.cpp

bpmfbout.cpp
Files

Functions for the BpMfbOut class to manage array of mfb formula bend points.

Collapse Expand Group

Files

Collapse Expand Links
Files


bpmfbout.h

bpmfbout.h
Classes Files Legend

Declarations for the BpMfbOut class to manage array of mfb formula bend points.

Collapse Expand Classes
Name | Description
BpMfbOut | Manages the array of mfb formula bend points.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


bppiaout.cpp

bppiaout.cpp
Files

Functions for the BpPiaOut class to manage array of pia formula bend points.

Collapse Expand Group

Files

Collapse Expand Links
Files


bppiaout.h

bppiaout.h
Classes Files Legend

Declarations for the BpPiaOut class to manage array of pia formula bend points.

Collapse Expand Classes
Name | Description
BpPiaOut | Manages the array of pia formula bend points.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


cachpdoc.cpp

cachpdoc.cpp
Files

Functions for the CatchupDoc class to manage a set of catch-up benefit increases.

Collapse Expand Group

Files

Collapse Expand Links
Files


cachup.cpp

cachup.cpp
Files

Functions for the CatchupIncreases and Catchup classes to manage catch-up benefit increases.

Collapse Expand Group

Files

Collapse Expand Links
Files


cachup.h

cachup.h
Classes Files Legend

Declarations for the CatchupIncreases and Catchup classes to manage catch-up benefit increases.

Collapse Expand Classes
Name | Description
Catchup | Manages the catch-up benefit increases required to calculate a Social Security benefit.
CatchupIncreases | Manages the catch-up benefit increases for one year of eligibility.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


cachupf.h

cachupf.h
Classes Files Legend

Declarations for the CatchupDoc class to manage a set of catch-up benefit increases.

Collapse Expand Classes
Name | Description
CatchupDoc | Abstract parent of classes that manage a file of catch-up benefit increases.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


cachupfl.cpp

cachupfl.cpp
Files

Functions for the CatchupFile class to manage file of catch-up benefit increases.

Collapse Expand Group

Files

Collapse Expand Links
Files


cachupnf.cpp

cachupnf.cpp
Files

Functions for the CatchupNonFile class to manage a set of catch-up benefit increases stored in arrays.

Collapse Expand Group

Files

Collapse Expand Links
Files


CatchupFile.h

CatchupFile.h
Classes Files Legend

Declarations for the CatchupFile class to manage file of catch-up benefit increases.

Collapse Expand Classes
Name | Description
CatchupFile | Manages a file of catch-up benefit increases stored on disk.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


CatchupNonFile.h

CatchupNonFile.h
Classes Files Legend

Declarations for the CatchupNonFile class to manage a set of catch-up benefit increases stored in arrays.

Collapse Expand Classes
Name | Description
CatchupNonFile | Manages a file of catch-up benefit increases stored in arrays.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


ChildCareCalc.cpp

ChildCareCalc.cpp
Files

Functions for the ChildCareCalc class to manage childcare dropout year pia calculations.

Collapse Expand Group

Files

Collapse Expand Links
Files


ChildCareCalc.h

ChildCareCalc.h
Classes Files Legend

Declarations for the ChildCareCalc class to manage childcare dropout year pia calculations.

Collapse Expand Classes
Name | Description
ChildCareCalc | Manages the functions required for calculation of a wage indexed Social Security benefit using childcare dropout years.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


ChildCareCalcLC.cpp

ChildCareCalcLC.cpp
Files

Functions for the ChildCareCalcLC class to manage childcare dropout year pia calculations, with law changes.

Collapse Expand Group

Files

Collapse Expand Links
Files


ChildCareCalcLC.h

ChildCareCalcLC.h
Classes Files Legend

Declarations for the ChildCareCalcLC class to manage childcare dropout year pia calculations, with law changes.

Collapse Expand Classes
Name | Description
ChildCareCalcLC | Manages the functions required for calculation of a wage indexed Social Security benefit using childcare dropout years, with law changes.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


comppd.h

comppd.h
Classes Files Legend

Declarations for the CompPeriod class to manage computation period variables.

Collapse Expand Classes
Name | Description
CompPeriod | Manages the number of elapsed years, dropout years, and computation years.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


CompPeriod.cpp

CompPeriod.cpp
Files

Functions for the CompPeriod class to manage computation period variables.

Collapse Expand Group

Files

Collapse Expand Links
Files


config.cpp

config.cpp
Files

Functions for the Config class to manage configuration information used by the PIA calculation program.

Collapse Expand Group

Files

Collapse Expand Links
Files


config.h

config.h
Classes Files Legend

Declarations for the Config class to manage configuration information used by the PIA calculation program.

Collapse Expand Classes
Name | Description
Config | Parent of classes that manage the configuration information used by the PIA calculation program.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


configFile.cpp

configFile.cpp
Files

Functions for the ConfigFile class to manage configuration information used by the PIA calculation program stored on disk.

Collapse Expand Group

Files

Collapse Expand Links
Files


ConfigFile.h

ConfigFile.h
Classes Files Legend

Declarations for the ConfigFile class to manage configuration information used by the PIA calculation program stored on disk.

Collapse Expand Classes
Name | Description
ConfigFile | Manages the configuration information used by the PIA calculation program, stored in a file.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


configNonFile.cpp

configNonFile.cpp
Files

Functions for the ConfigNonFile class to manage configuration information used by the PIA calculation program stored internally.

Collapse Expand Group

Files

Collapse Expand Links
Files


ConfigNonFile.h

ConfigNonFile.h
Classes Files Legend

Declarations for the ConfigNonFile class to manage configuration information used by the PIA calculation program stored internally.

Collapse Expand Classes
Name | Description
ConfigNonFile | Manages the configuration information used by the PIA calculation program, stored with the code.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


DebugCase.cpp

DebugCase.cpp
Files Variables
Collapse Expand Group

Files

Collapse Expand Variables
Name | Description
DEBUGPID | Value of 999999 is reserved. It means print out for all pid's.
Collapse Expand Links
Files, Variables


DebugCase.h

DebugCase.h
Functions Files Legend
Collapse Expand Functions
Name | Description
isDebugPid | Returns true if argument person id is the debug pid.
Collapse Expand Group

Files

Collapse Expand Links
Functions, Files, Legend


DibGuar.cpp

DibGuar.cpp
Files

Functions for the DibGuar class to manage disability guarantee pia calculations.

Collapse Expand Group

Files

Collapse Expand Links
Files


DibGuar.h

DibGuar.h
Classes Files Legend

Declarations for the DibGuar class to manage disability guarantee pia calculations.

Collapse Expand Classes
Name | Description
DibGuar | Manages the functions required for calculation of a disability guarantee Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


DibGuarLC.cpp

DibGuarLC.cpp
Files

Functions for the DibGuarLC class to manage disability guarantee pia calculations with law changes.

Collapse Expand Group

Files

Collapse Expand Links
Files


DibGuarLC.h

DibGuarLC.h
Classes Files Legend

Declarations for the DibGuarLC class to manage disability guarantee pia calculations with law changes.

Collapse Expand Classes
Name | Description
DibGuarLC | Manages the functions required for calculation of a disability guarantee Social Security benefit with law changes.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


dinscode.cpp

dinscode.cpp
Files

Functions for the DisInsCode class representing a disability insured status code.

Collapse Expand Group

Files

Collapse Expand Links
Files


dinscode.h

dinscode.h
Classes Files Legend

Declarations for the DisInsCode class representing a disability insured status code.

Collapse Expand Classes
Name | Description
DisInsCode | Represents one disability insured status code.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


DisabPeriod.cpp

DisabPeriod.cpp
Files

Functions for the DisabPeriod class to manage a period of disability.

Collapse Expand Group

Files

Collapse Expand Links
Files


DisabPeriod.h

DisabPeriod.h
Classes Files Legend

Declarations for the DisabPeriod class to manage a period of disability.

Collapse Expand Classes
Name | Description
DisabPeriod | Manages a period of disability.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


DisInsCodeArray.cpp

DisInsCodeArray.cpp
Files

Functions for the DisInsCodeArray class to manage an array of disability insured status codes.

Collapse Expand Group

Files

Collapse Expand Links
Files


DisInsCodeArray.h

DisInsCodeArray.h
Classes Files Legend

Declarations for the DisInsCodeArray class to manage an array of disability insured status codes.

Collapse Expand Classes
Name | Description
DisInsCodeArray | Manages an array of annual DisInsCode's.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


EarnProject.cpp

EarnProject.cpp
Files

Functions for the EarnProject class to handle an array of earnings, with forward and backward projections and specified levels of earnings.

Collapse Expand Group

Files

Collapse Expand Links
Files


EarnProject.h

EarnProject.h
Classes Files Legend

Declarations for the EarnProject class to handle an array of earnings, with forward and backward projections and specified levels of earnings.

Collapse Expand Classes
Name | Description
EarnProject | Manages an array of earnings, with forward and backward projections and specified levels of earnings.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


FieldOfficeInfoFile.h

FieldOfficeInfoFile.h
Classes Files Legend

Declarations for the FieldOfficeInfoFile class to manage field office information stored on disk.

Collapse Expand Classes
Name | Description
FieldOfficeInfoFile | Reads and writes field office information from and to a file.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


FieldOfficeInfoNonFile.h

FieldOfficeInfoNonFile.h
Classes Files Legend

Declarations for the FieldOfficeInfoNonFile class to manage field office information stored in memory.

Collapse Expand Classes
Name | Description
FieldOfficeInfoNonFile | Manages field office information not stored in a file (but its data may be saved in an .ini file).
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


foinfo.cpp

foinfo.cpp
Files

Functions for the FieldOfficeInfo class to manage field office information.

Collapse Expand Group

Files

Collapse Expand Links
Files


foinfo.h

foinfo.h
Classes Files Legend

Declarations for the FieldOfficeInfo class to manage field office information.

Collapse Expand Classes
Name | Description
FieldOfficeInfo | Parent of classes that manage the name and address of the field office.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


foinfofl.cpp

foinfofl.cpp
Files

Functions for the FieldOfficeInfoFile class to manage field office information stored on disk.

Collapse Expand Group

Files

Collapse Expand Links
Files


foinfonf.cpp

foinfonf.cpp
Files

Functions for the FieldOfficeInfoNonFile class to manage field office information stored in memory.

Collapse Expand Group

Files

Collapse Expand Links
Files


FrozMin.cpp

FrozMin.cpp
Files

Functions for the FrozMin class to manage frozen minimum pia calculations.

Collapse Expand Group

Files

Collapse Expand Links
Files


FrozMin.h

FrozMin.h
Classes Files Legend

Declarations for the FrozMin class to manage frozen minimum pia calculations.

Collapse Expand Classes
Name | Description
FrozMin | Manages the functions required for calculation of a frozen minimum Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


frzyrs.cpp

frzyrs.cpp
Files

Functions for the FreezeYears class to manage freeze period variables.

Collapse Expand Group

Files

Collapse Expand Links
Files


frzyrs.h

frzyrs.h
Classes Files Legend

Declarations for the FreezeYears class to manage freeze period variables.

Collapse Expand Classes
Name | Description
FreezeYears | Manages the years in a freeze period. The years may be wholly or partially within a freeze period.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


inscode.cpp

inscode.cpp
Files

Functions for the InsCode class to manage an insured status code.

Collapse Expand Group

Files

Collapse Expand Links
Files


inscode.h

inscode.h
Classes Files Legend

Declarations for the InsCode class to manage an insured status code.

Collapse Expand Classes
Name | Description
InsCode | Represents one insured status code.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


InsCodeArray.cpp

InsCodeArray.cpp
Files

Functions for the InsCodeArray class to manage an array of insured status codes.

Collapse Expand Group

Files

Collapse Expand Links
Files


InsCodeArray.h

InsCodeArray.h
Classes Files Legend

Declarations for the InsCodeArray class to manage an array of insured status codes.

Collapse Expand Classes
Name | Description
InsCodeArray | Manages an array of annual insured status codes.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChange.cpp

LawChange.cpp
Files

Functions for the LawChange class to manage law-change parameters.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChange.h

LawChange.h
Classes Files Legend

Declarations for the LawChange class to manage law-change parameters.

Collapse Expand Classes
Name | Description
LawChange | The basic class that manages all of the extra data and functions required for one change in law concerning benefit calculations.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeAGE65COMP.cpp

LawChangeAGE65COMP.cpp
Files

Functions for the LawChangeAGE65COMP class to manage parameters for a proposal to increase the number of elapsed years in a pia calculation.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeAGE65COMP.h

LawChangeAGE65COMP.h
Classes Files Legend

Declarations for the LawChangeAGE65COMP class to manage parameters for a proposal to increase the number of elapsed years in a pia calculation.

Collapse Expand Classes
Name | Description
LawChangeAGE65COMP | Parameters for a proposal to increase the number of elapsed years in a pia calculation.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeALLEARN.cpp

LawChangeALLEARN.cpp
Files

Functions for the LawChangeALLEARN class to manage parameters for a proposal to use all years of earnings in an AIME calculation.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeALLEARN.h

LawChangeALLEARN.h
Classes Files Legend

Declarations for the LawChangeALLEARN class to manage parameters for a proposal to use all years of earnings in an AIME calculation.

Collapse Expand Classes
Name | Description
LawChangeALLEARN | Parameters for a proposal to use all years of earnings in an AIME calculation.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeArray.cpp

LawChangeArray.cpp
Files

Functions for the LawChangeArray class to manage an array of LawChange parameters.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeArray.h

LawChangeArray.h
Classes Files Legend

Declarations for the LawChangeArray class to manage an array of LawChange parameters.

Collapse Expand Classes
Name | Description
LawChangeArray | Manages an array of LawChange's.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeBPFRACWAGE.cpp

LawChangeBPFRACWAGE.cpp
Files

Functions for the LawChangeBPFRACWAGE class to manage parameters for a proposal to increase the bend points in the benefit formula by a fraction of average wage growth.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeBPFRACWAGE.h

LawChangeBPFRACWAGE.h
Classes Files Legend

Declarations for the LawChangeBPFRACWAGE class to manage parameters for a proposal to increase the bend points in the benefit formula by a fraction of average wage growth.

Collapse Expand Classes
Name | Description
LawChangeBPFRACWAGE | Parameters for a proposal to increase the bend points in the benefit formula by a fraction of average wage growth.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeBPMINCONST.cpp

LawChangeBPMINCONST.cpp
Files

Functions for the LawChangeBPMINCONST class to manage parameters for a proposal to increase the bend points in the benefit formula by the growth in wages minus a specified rate.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeBPMINCONST.h

LawChangeBPMINCONST.h
Classes Files Legend

Declarations for the LawChangeBPMINCONST class to manage parameters for a proposal to increase the bend points in the benefit formula by the growth in wages minus a specified rate.

Collapse Expand Classes
Name | Description
LawChangeBPMINCONST | Parameters for a proposal to increase the bend points in the benefit formula by the growth in wages minus a specified rate.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeBPSPECRATE.cpp

LawChangeBPSPECRATE.cpp
Files

Functions for the LawChangeBPSPECRATE class to manage parameters for a proposal to increase the bend points in the benefit formula by a specified growth rate.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeBPSPECRATE.h

LawChangeBPSPECRATE.h
Classes Files Legend

Declarations for the LawChangeBPSPECRATE class to manage parameters for a proposal to increase the bend points in the benefit formula by a specified growth rate.

Collapse Expand Classes
Name | Description
LawChangeBPSPECRATE | Parameters for a proposal to increase the bend points in the benefit formula by a specified growth rate.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeCHILDCARECREDIT.cpp

LawChangeCHILDCARECREDIT.cpp
Files

Functions for the LawChangeCHILDCARECREDIT class to manage parameters for a proposal to provide child care credits.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeCHILDCARECREDIT.h

LawChangeCHILDCARECREDIT.h
Classes Files Legend

Declarations for the LawChangeCHILDCARECREDIT class to manage parameters for a proposal to provide child care credits.

Collapse Expand Classes
Name | Description
LawChangeCHILDCARECREDIT | Parameters for a proposal to provide child care credits.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeCHILDCAREDROPOUT.cpp

LawChangeCHILDCAREDROPOUT.cpp
Files

Functions for the LawChangeCHILDCAREDROPOUT class to manage parameters for a proposal to provide child care dropout years.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeCHILDCAREDROPOUT.h

LawChangeCHILDCAREDROPOUT.h
Classes Files Legend

Declarations for the LawChangeCHILDCAREDROPOUT class to manage parameters for a proposal to provide child care dropout years.

Collapse Expand Classes
Name | Description
LawChangeCHILDCAREDROPOUT | Parameters for a proposal to provide child care dropout years.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeCOLACHANGE.cpp

LawChangeCOLACHANGE.cpp
Files

Functions for the LawChangeCOLACHANGE class to manage parameters for a proposal to change the cost-of-living benefit increases.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeCOLACHANGE.h

LawChangeCOLACHANGE.h
Classes Files Legend

Declarations for the LawChangeCOLACHANGE class to manage parameters for a proposal to change the cost-of-living benefit increases.

Collapse Expand Classes
Name | Description
LawChangeCOLACHANGE | Parameters for a proposal to change the cost-of-living benefit increases.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeDECLINEPERC.cpp

LawChangeDECLINEPERC.cpp
Files

Functions for the LawChangeDECLINEPERC class to manage parameters for a proposal to decrease the benefit formula percentages by various rates.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeDECLINEPERC.h

LawChangeDECLINEPERC.h
Classes Files Legend

Declarations for the LawChangeDECLINEPERC class to manage parameters for a proposal to decrease the benefit formula percentages by various rates.

Collapse Expand Classes
Name | Description
LawChangeDECLINEPERC | Parameters for a proposal to decrease the benefit formula percentages by a constant rate.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeDROPOUTCHG.cpp

LawChangeDROPOUTCHG.cpp
Files

Functions for the LawChangeDROPOUTCHG class to manage parameters for a proposal to reduce the number of dropout years in a pia calculation.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeDROPOUTCHG.h

LawChangeDROPOUTCHG.h
Classes Files Legend

Declarations for the LawChangeDROPOUTCHG class to manage parameters for a proposal to reduce the number of dropout years in a pia calculation.

Collapse Expand Classes
Name | Description
LawChangeDROPOUTCHG | Parameters for a proposal to reduce the number of dropout years in a pia calculation.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeMARRLENGTH.cpp

LawChangeMARRLENGTH.cpp
Files

Functions for the LawChangeMARRLENGTH class to manage parameters for a proposal to change the length of marriage requirement for divorced spouse benefits.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeMARRLENGTH.h

LawChangeMARRLENGTH.h
Classes Files Legend

Declarations for the LawChangeMARRLENGTH class to manage parameters for a proposal to change the length of marriage requirement for divorced spouse benefits.

Collapse Expand Classes
Name | Description
LawChangeMARRLENGTH | Parameters for a proposal to change the length of marriage requirement for divorced spouse benefits.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeNEWFORMULA.cpp

LawChangeNEWFORMULA.cpp
Files

Functions for the LawChangeNEWFORMULA class to manage parameters for a proposal to change the pia formula bend points and/or percentages.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeNEWFORMULA.h

LawChangeNEWFORMULA.h
Classes Files Legend

Declarations for the LawChangeNEWFORMULA class to manage parameters for a proposal to change the pia formula bend points and/or percentages.

Collapse Expand Classes
Name | Description
LawChangeNEWFORMULA | Parameters for a proposal to change the pia formula bend points and/or percentages.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeNEWSPECMIN.cpp

LawChangeNEWSPECMIN.cpp
Files

Functions for the LawChangeNEWSPECMIN class to manage parameters for a proposal to change the special minimum pia calculation.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeNEWSPECMIN.h

LawChangeNEWSPECMIN.h
Classes Files Legend

Declarations for the LawChangeNEWSPECMIN class to manage parameters for a proposal to change the special minimum pia calculation.

Collapse Expand Classes
Name | Description
LawChangeNEWSPECMIN | Parameters for a proposal to change the special minimum pia calculation.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeNRACHANGE.cpp

LawChangeNRACHANGE.cpp
Files

Functions for the LawChangeNRACHANGE class to manage parameters for a proposal to change the full retirement age.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeNRACHANGE.h

LawChangeNRACHANGE.h
Classes Files Legend

Declarations for the LawChangeNRACHANGE class to manage parameters for a proposal to change the full retirement age.

Collapse Expand Classes
Name | Description
LawChangeNRACHANGE | Parameters for a proposal to change the full retirement age.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeOut.cpp

LawChangeOut.cpp
Files

Functions for the LawChangeOut class to manage the output file of law change descriptions.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeOut.h

LawChangeOut.h
Classes Files Legend

Declarations for the LawChangeOut class to manage the output file of law change descriptions.

Collapse Expand Classes
Name | Description
LawChangeOut | Manages the output file of law change descriptions.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangePSAACCT.cpp

LawChangePSAACCT.cpp
Files

Functions for the LawChangePSAACCT class to manage parameters for a proposal to introduce individual accounts.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangePSAACCT.h

LawChangePSAACCT.h
Classes Files Legend

Declarations for the LawChangePSAACCT class to manage parameters for a proposal to introduce individual accounts.

Collapse Expand Classes
Name | Description
LawChangePSAACCT | Parameters for a proposal to introduce individual accounts.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeRead.cpp

LawChangeRead.cpp
Files

Functions for the LawChangeRead class to read law changes from a file.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeRead.h

LawChangeRead.h
Classes Files Legend

Declarations for the LawChangeRead class to read law changes from a file.

Collapse Expand Classes
Name | Description
LawChangeRead | Reads law changes stored in a file.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeTAXBENCHG.cpp

LawChangeTAXBENCHG.cpp
Files

Functions for the LawChangeTAXBENCHG class to manage parameters for a proposal to change the taxation of benefits.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeTAXBENCHG.h

LawChangeTAXBENCHG.h
Classes Files Legend

Declarations for the LawChangeTAXBENCHG class to manage parameters for a proposal to change the taxation of benefits.

Collapse Expand Classes
Name | Description
LawChangeTAXBENCHG | Parameters for a proposal to change the taxation of benefits.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeTAXRATECHG.cpp

LawChangeTAXRATECHG.cpp
Files

Functions for the LawChangeTAXRATECHG class to manage parameters for a proposal to change the OASDHI tax rates.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeTAXRATECHG.h

LawChangeTAXRATECHG.h
Classes Files Legend

Declarations for the LawChangeTAXRATECHG class to manage parameters for a proposal to change the OASDHI tax rates.

Collapse Expand Classes
Name | Description
LawChangeTAXRATECHG | Parameters for a proposal to change the OASDI tax rates.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeWAGEBASECHG.cpp

LawChangeWAGEBASECHG.cpp
Files

Functions for the LawChangeWAGEBASECHG class to manage parameters for a proposal to change the OASDI and/or old-law wage bases.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeWAGEBASECHG.h

LawChangeWAGEBASECHG.h
Classes Files Legend

Declarations for the LawChangeWAGEBASECHG class to manage parameters for a proposal to change the OASDI and/or old-law wage bases.

Collapse Expand Classes
Name | Description
LawChangeWAGEBASECHG | Parameters for a proposal to change the OASDI and/or old-law wage bases.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeWIDFACTOR.cpp

LawChangeWIDFACTOR.cpp
Files

Functions for the LawChangeWIDFACTOR class to manage parameters for a proposal to change the factor for an aged widow(er) benefit.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeWIDFACTOR.h

LawChangeWIDFACTOR.h
Classes Files Legend

Declarations for the LawChangeWIDFACTOR class to manage parameters for a proposal to change the factor for an aged widow(er) benefit.

Collapse Expand Classes
Name | Description
LawChangeWIDFACTOR | Parameters for a proposal to change the factor for an aged widow(er) benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeWIFEFACTOR.cpp

LawChangeWIFEFACTOR.cpp
Files

Functions for the LawChangeWIFEFACTOR class to manage parameters for a proposal to change the factor for an aged spouse benefit.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeWIFEFACTOR.h

LawChangeWIFEFACTOR.h
Classes Files Legend

Declarations for the LawChangeWIFEFACTOR class to manage parameters for a proposal to change the factor for an aged spouse benefit.

Collapse Expand Classes
Name | Description
LawChangeWIFEFACTOR | Parameters for a proposal to change the factor for an aged spouse benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


LawChangeWrite.cpp

LawChangeWrite.cpp
Files

Functions for the LawChangeWrite class to write law changes to a file.

Collapse Expand Group

Files

Collapse Expand Links
Files


LawChangeWrite.h

LawChangeWrite.h
Classes Files Legend

Declarations for the LawChangeWrite class to write law changes to a file.

Collapse Expand Classes
Name | Description
LawChangeWrite | Writes a set of law changes to a file.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


MilServDatesVec.h

MilServDatesVec.h
Classes Files Legend

Declarations for the MilServDatesVec class to manage an array of military service dates records.

Collapse Expand Classes
Name | Description
MilServDatesVec | Manages all the military service dates records for one ssn.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


msdates.cpp

msdates.cpp
Files

Functions for the MilServDates class to manage one military service dates record.

Collapse Expand Group

Files

Collapse Expand Links
Files


msdates.h

msdates.h
Classes Files Legend

Declarations for the MilServDates class to manage one military service dates record.

Collapse Expand Classes
Name | Description
MilServDates | Manages one period of military service dates.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


msdatesvec.cpp

msdatesvec.cpp
Files

Functions for the MilServDatesVec class to manage an array of military service dates records.

Collapse Expand Group

Files

Collapse Expand Links
Files


oactcnst.h

oactcnst.h
Files Variables

Constants used in the various Oact C++ programs and utilities.

Collapse Expand Group

Files

Collapse Expand Variables
Name | Description
BASEYR | Base year for trust fund projection arrays on January 1 basis.
BASEYR1 | Base year for trust fund projection arrays on during-year basis.
LASTYEARLR | Last year of long-range projection arrays.
LASTYRSR | Last year of short-range projection arrays.
MAXEARN | Maximum annual earnings allowed.
MAXYRS | Maximum number of years of earnings for one individual.
MAXYRSR | Number of years of data in trust fund projections, January 1 basis.
MAXYRSR1 | Number of years of data in trust fund projections, during-year basis.
ORSYR | Base year for ORS trust fund projection data.
YEAR2075 | Last possible year of projection.
YEAR2080 | Last possible year of projection.
YEAR2085 | Last possible year of projection.
YEAR2090 | Last possible year of projection.
YEAR2095 | Last possible year of projection.
YEAR2100 | Last possible year of projection.
YEAR2105 | Last possible year of projection.
YEAR2200 | Last possible year for dates.
YEAR36 | Year before first year of Social Security.
YEAR37 | Base year for many data arrays.
YEAR50 | Year before first year of major revisions to Social Security.
YEAR51 | First year of major revisions to Social Security.
YEAR69 | First year of many OACT projection arrays.
YEAR70 | First year of many OACT projection arrays.
YEAR74 | First year of many OACT projection arrays.
YEAR75 | First year of many OACT projection arrays.
YEAR79 | First year of bend points.
Collapse Expand Links
Files, Variables


oldpia.cpp

oldpia.cpp
Files

Functions for the OldPia class - parent of all methods using pia tables in the calculation of a Social Security benefit.

Collapse Expand Group

Files

Collapse Expand Links
Files


OldPia.h

OldPia.h
Classes Files Legend

Declarations for the OldPia class - parent of all methods using pia tables in the calculation of a Social Security benefit.

Collapse Expand Classes
Name | Description
OldPia | Parent of all methods using pia tables in the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


oldstart.cpp

oldstart.cpp
Files

Functions for the OldStart class to manage old-start pia calculations.

Collapse Expand Group

Files

Collapse Expand Links
Files


OldStart.h

OldStart.h
Classes Files Legend

Declarations for the OldStart class to manage old-start pia calculations.

Collapse Expand Classes
Name | Description
OldStart | Manages the functions required for calculation of an old start Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


OldStartLC.cpp

OldStartLC.cpp
Files

Functions for the OldStartLC class to manage old-start pia calculations, with changes from present law.

Collapse Expand Group

Files

Collapse Expand Links
Files


OldStartLC.h

OldStartLC.h
Classes Files Legend

Declarations for the OldStartLC class to manage old-start pia calculations, with changes from present law.

Collapse Expand Classes
Name | Description
OldStartLC | Manages the functions required for calculation of an old start Social Security benefit with law changes.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


pebs.cpp

pebs.cpp
Files

Functions for the Pebs class to handle Social Security Statement data.

Collapse Expand Group

Files

Collapse Expand Links
Files


pebs.h

pebs.h
Classes Files Legend

Declarations for the Pebs class to handle Social Security Statement data.

Collapse Expand Classes
Name | Description
Pebs | Manages most of the data required to prepare and print out the results of a Statement calculation.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


percmfb.cpp

percmfb.cpp
Files

Functions to handle MFB formula percentages.

Collapse Expand Group

Files

Collapse Expand Links
Files


percmfb.h

percmfb.h
Classes Files Legend

Declarations needed for class to manage array of MFB formula percentages.

Collapse Expand Classes
Name | Description
PercMfb | Manages the array of percentages used in the MFB formula.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


percpia.cpp

percpia.cpp
Files

Functions to handle PIA formula percentages.

Collapse Expand Group

Files

Collapse Expand Links
Files


percpia.h

percpia.h
Classes Files Legend

Declarations needed for class to manage array of PIA formula percentages.

Collapse Expand Classes
Name | Description
PercPia | Manages the array of percentages used in the PIA formula.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PercPiaOut.cpp

PercPiaOut.cpp
Files

Functions for the PercPiaOut class to manage array of pia formula percentages.

Collapse Expand Group

Files

Collapse Expand Links
Files


PercPiaOut.h

PercPiaOut.h
Classes Files Legend

Declarations for the PercPiaOut class to manage array of pia formula percentages.

Collapse Expand Classes
Name | Description
PercPiaOut | Manages the array of pia formula percentages, projected for all years.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


piacal.cpp

piacal.cpp
Files

Functions for the PiaCal class - parent of all classes that manage the calculation of a Social Security benefit.

Collapse Expand Group

Files

Collapse Expand Links
Files


piacal.h

piacal.h
Classes Files Legend

Declarations for the PiaCal class - parent of all classes that manage the calculation of a Social Security benefit.

Collapse Expand Classes
Name | Description
PiaCal | Parent of all classes that manage the functions required for calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


piacalany.cpp

piacalany.cpp
Files

Functions for the PiaCalAny class to manage pia calculation functions used in Anypia.

Collapse Expand Group

Files

Collapse Expand Links
Files


PiaCalAny.h

PiaCalAny.h
Classes Files Legend

Declarations for the PiaCalAny class to manage pia calculation functions used in Anypia.

Collapse Expand Classes
Name | Description
PiaCalAny | Manages the additional functions required for calculation of a Social Security benefit in the Anypia program.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


piacallc.cpp

piacallc.cpp
Files

Functions for the PiaCalLC class to manage law-change pia calculation functions.

Collapse Expand Group

Files

Collapse Expand Links
Files


PiaCalLC.h

PiaCalLC.h
Classes Files Legend

Declarations for the PiaCalLC class to manage law-change pia calculation functions.

Collapse Expand Classes
Name | Description
PiaCalLC | Manages all of the law-change functions required for calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PiaCalPL.cpp

PiaCalPL.cpp
Files

Functions for the PiaCalPL class to manage present law pia calculation functions.

Collapse Expand Group

Files

Collapse Expand Links
Files


PiaCalPL.h

PiaCalPL.h
Classes Files Legend

Declarations for the PiaCalPL class to manage present law pia calculation functions.

Collapse Expand Classes
Name | Description
PiaCalPL | Manages all of the present law functions required for calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


piadata.cpp

piadata.cpp
Files

Functions for the PiaData class to set up data to calculate and print out a PIA.

Collapse Expand Group

Files

Collapse Expand Links
Files


piadata.h

piadata.h
Classes Files Legend

Declarations for the PiaData class to set up data to calculate and print out a PIA.

Collapse Expand Classes
Name | Description
PiaData | Manages all of the worker-specific amounts calculated in preparation for and during the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PiadataArray.cpp

PiadataArray.cpp
Files

Functions for the PiaDataArray class to manage an array of PiaData's, representing one family.

Collapse Expand Group

Files

Collapse Expand Links
Files


PiadataArray.h

PiadataArray.h
Classes Files Legend

Declarations for the PiaDataArray class to manage an array of PiaData's, representing one family.

Collapse Expand Classes
Name | Description
PiaDataArray | Manages an array of PiaData's, representing one family.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PiaMethod.cpp

PiaMethod.cpp
Files

Functions for the PiaMethod class - parent of the various methods required for calculation of a Social Security benefit.

Collapse Expand Group

Files

Collapse Expand Links
Files


PiaMethod.h

PiaMethod.h
Classes Files Legend

Declarations for the PiaMethod class - parent of the various methods required for calculation of a Social Security benefit.

Collapse Expand Classes
Name | Description
PiaMethod | Parent of the various methods required for calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PiaParamsLCTR.cpp

PiaParamsLCTR.cpp
Files

Functions for the PiaParamsLCTR class to manage the changed law Social Security parameters, already projected based on a Trustees Report assumption.

Collapse Expand Group

Files

Collapse Expand Links
Files


PiaParamsLCTR.h

PiaParamsLCTR.h
Classes Files Legend

Declarations for the PiaParamsLCTR class to manage the changed law Social Security parameters, already projected based on a Trustees Report assumption.

Collapse Expand Classes
Name | Description
PiaParamsLCTR | Manages the changed law Social Security parameters, already projected based on a Trustees Report assumption.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PiaParamsTR.cpp

PiaParamsTR.cpp
Files

Functions for the PiaParamsTR class of pia calculation parameters using present law only, with projected values set to Trustees Report assumptions.

Collapse Expand Group

Files

Collapse Expand Links
Files


PiaParamsTR.h

PiaParamsTR.h
Classes Files Legend

Declarations for the PiaParamsTR class of pia calculation parameters using present law only, with projected values set to Trustees Report assumptions.

Collapse Expand Classes
Name | Description
PiaParamsTR | Manages the present law Social Security parameters required to calculate Social Security benefits, with projected values set to Trustees Report assumptions.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


piaparms.cpp

piaparms.cpp
Files

Functions for the PiaParams class - parent of classes to manage the Social Security parameters required to calculate a Social Security benefit.

Collapse Expand Group

Files

Collapse Expand Links
Files


piaparms.h

piaparms.h
Classes Files Legend

Declarations for the PiaParams class - parent of classes to manage the Social Security parameters required to calculate a Social Security benefit.

Collapse Expand Classes
Name | Description
PiaParams | Abstract parent of classes to manage the Social Security parameters required to calculate a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


piaparmsAny.cpp

piaparmsAny.cpp
Files

Functions for the PiaParamsAny class to manage the Social Security parameters required to calculate Social Security benefits in the Anypia program.

Collapse Expand Group

Files

Collapse Expand Links
Files


piaparmsAny.h

piaparmsAny.h
Classes Files Legend

Declarations for the PiaParamsAny class to manage the Social Security parameters required to calculate Social Security benefits in the Anypia program.

Collapse Expand Classes
Name | Description
PiaParamsAny | Manages the additional Social Security parameters required to calculate Social Security benefits in the Anypia program.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


piaparmsLC.cpp

piaparmsLC.cpp
Files

Functions for the PiaParamsLC class to handle changed law PIA parameters.

Collapse Expand Group

Files

Collapse Expand Links
Files


piaparmsLC.h

piaparmsLC.h
Classes Files Legend

Declarations for the PiaParamsLC class to handle changed law PIA parameters.

Collapse Expand Classes
Name | Description
PiaParamsLC | Manages the changed law Social Security parameters required to calculate Social Security benefits.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


piaparmsPL.cpp

piaparmsPL.cpp
Files

Functions for the PiaParamsPL class of pia calculation parameters using present law only.

Collapse Expand Group

Files

Collapse Expand Links
Files


piaparmsPL.h

piaparmsPL.h
Classes Files Legend

Declarations for the PiaParamsPL class of pia calculation parameters using present law only.

Collapse Expand Classes
Name | Description
PiaParamsPL | Manages the present law Social Security parameters required to calculate Social Security benefits.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


piaread.cpp

piaread.cpp
Files

Functions for the PiaRead class to read a file of worker data from disk.

Collapse Expand Group

Files

Collapse Expand Links
Files


piaread.h

piaread.h
Classes Files Legend

Declarations for the PiaRead class to read a file of worker data from disk.

Collapse Expand Classes
Name | Description
PiaRead | Reads the basic data required to calculate a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


piareadAny.cpp

piareadAny.cpp
Files

Functions for the PiaReadAny class to read worker data for Anypia.

Collapse Expand Group

Files

Collapse Expand Links
Files


piareadAny.h

piareadAny.h
Classes Files Legend

Declarations for the PiaReadAny class to read worker data for Anypia.

Collapse Expand Classes
Name | Description
PiaReadAny | Reads the data required to calculate a Social Security benefit for the Anypia program.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PiaTable.cpp

PiaTable.cpp
Files

Functions for the PiaTable class to manage Pia Table pia calculations.

Collapse Expand Group

Files

Collapse Expand Links
Files


PiaTable.h

PiaTable.h
Classes Files Legend

Declarations for the PiaTable class to manage Pia Table pia calculations.

Collapse Expand Classes
Name | Description
PiaTable | Manages the functions required for calculation of a Pia Table Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PiaTableLC.cpp

PiaTableLC.cpp
Files

Functions for the PiaTableLC class to manage Pia Table pia calculations, with changes from present law.

Collapse Expand Group

Files

Collapse Expand Links
Files


PiaTableLC.h

PiaTableLC.h
Classes Files Legend

Declarations for the PiaTableLC class to manage Pia Table pia calculations, with changes from present law.

Collapse Expand Classes
Name | Description
PiaTableLC | Manages the functions required for calculation of a Pia Table Social Security benefit, including changes from present law.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


piawrite.cpp

piawrite.cpp
Files

Functions for the PiaWrite class to write out worker data.

Collapse Expand Group

Files

Collapse Expand Links
Files


piawrite.h

piawrite.h
Classes Files Legend

Declarations for the PiaWrite class to write out worker data.

Collapse Expand Classes
Name | Description
PiaWrite | Writes out the basic data required to calculate a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


piawriteAny.cpp

piawriteAny.cpp
Files

Functions for the PiaWriteAny class to write out worker data for Anypia program.

Collapse Expand Group

Files

Collapse Expand Links
Files


piawriteAny.h

piawriteAny.h
Classes Files Legend

Declarations for the PiaWriteAny class to write out worker data for Anypia program.

Collapse Expand Classes
Name | Description
PiaWriteAny | Writes out the data required to calculate a Social Security benefit for the Anypia program.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


pib50mfb.cpp

pib50mfb.cpp
Files

Functions for the Pib50Mfb class to handle 1950 pib-mfb conversion table.

Collapse Expand Group

Files

Collapse Expand Links
Files


pib50pib.cpp

pib50pib.cpp
Files

Functions for the Pib50Pib class to handle 1950 pib-pia conversion table.

Collapse Expand Group

Files

Collapse Expand Links
Files


pib52ame.cpp

pib52ame.cpp
Files

Functions for the class to handle 1952 pib-ame conversion table.

Collapse Expand Group

Files

Collapse Expand Links
Files


bendmfb.cpp

bendmfb.cpp
Files

Functions to handle MFB formula bend points.

Collapse Expand Group

Files

Collapse Expand Links
Files


pib52mfb.cpp

pib52mfb.cpp
Files

Functions for the class to handle 1952 pib-mfb conversion table.

Collapse Expand Group

Files

Collapse Expand Links
Files


bendpia.cpp

bendpia.cpp
Files

Functions for the BendPia class to handle PIA formula bend points.

Collapse Expand Group

Files

Collapse Expand Links
Files


pib54ame.cpp

pib54ame.cpp
Files

Functions for the class to handle 1954 pib-ame conversion table.

Collapse Expand Group

Files

Collapse Expand Links
Files


pib54mfb.cpp

pib54mfb.cpp
Files

Functions for the class to handle 1954 pib-mfb conversion table.

Collapse Expand Group

Files

Collapse Expand Links
Files


pib54pia.cpp

pib54pia.cpp
Files

Functions for the class to handle 1954 pib-pia conversion table.

Collapse Expand Group

Files

Collapse Expand Links
Files


pib58ame.cpp

pib58ame.cpp
Files

Functions for the class to handle 1958 pib-ame conversion table.

Collapse Expand Group

Files

Collapse Expand Links
Files


pib58pib.cpp

pib58pib.cpp
Files

Functions for the class to handle 1958 pib-pia conversion table.

Collapse Expand Group

Files

Collapse Expand Links
Files


pibtable.h

pibtable.h
Classes Files Legend

Declarations for the Pib50Mfb, Pib50Pib, Pib52Ame, Pib52Mfb, Pib54Ame, Pib54Mfb, Pib54Pia, Pib58Ame, and Pib58Pib classes to manage pib-pia conversion tables.

Collapse Expand Classes
Name | Description
Pib50Mfb | Manages the 1950 pib-mfb conversion figures.
Pib50Pib | Manages the 1950 pib-pia conversion figures.
Pib52Ame | Manages the 1952 pib-ame conversion figures.
Pib52Mfb | Manages the 1952 pib-mfb conversion figures.
Pib54Ame | Manages the 1954 pib-ame conversion figures.
Pib54Mfb | Manages the 1954 pib-mfb conversion figures.
Pib54Pia | Manages the 1954 pib-pia conversion figures.
Pib58Ame | Manages the 1958 pib-ame conversion figures.
Pib58Pib | Manages the 1958 pib-pia conversion figures.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


Pifc.cpp

Pifc.cpp
Files

Functions for the Pifc class representing a type of Social Security pia.

Collapse Expand Group

Files

Collapse Expand Links
Files


Pifc.h

Pifc.h
Classes Files Legend

Declarations for the Pifc class representing a type of Social Security pia.

Collapse Expand Classes
Name | Description
Pifc | Represents a pia factor code (type of Social Security pia).
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PresValFacs.cpp

PresValFacs.cpp
Files

Functions for the PresValFacs class to handle present value factors.

Collapse Expand Group

Files

Collapse Expand Links
Files


PresValFacs.h

PresValFacs.h
Classes Files Legend

Declarations for the PresValFacs class to handle present value factors.

Collapse Expand Classes
Name | Description
PresValFacs | Manages an array of present value factors.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


Psa.cpp

Psa.cpp
Files

Functions for Psa class to manage PSA accounts.

Collapse Expand Group

Files

Collapse Expand Links
Files


Psa.h

Psa.h
Classes Files Legend

Declarations for Psa class to manage PSA accounts.

Collapse Expand Classes
Name | Description
Psa | Manages the (theoretical) PSA accounts.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


qc.cpp

qc.cpp
Files

Functions for the Qc class to manage one annual quarters of coverage number.

Collapse Expand Group

Files

Collapse Expand Links
Files


qc.h

qc.h
Classes Files Legend

Declarations for the Qc class to manage one annual quarters of coverage number.

Collapse Expand Classes
Name | Description
Qc | Handles calculations with quarters of coverage for one year.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


qcamt.cpp

qcamt.cpp
Files

Functions for the Qcamt class to manage array of amounts required for quarter of coverage.

Collapse Expand Group

Files

Collapse Expand Links
Files


qcamt.h

qcamt.h
Classes Files Legend

Declarations for the Qcamt class to manage array of amounts required for quarter of coverage.

Collapse Expand Classes
Name | Description
Qcamt | Manages an array of quarter of coverage amounts.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


QcArray.cpp

QcArray.cpp
Files

Functions for the QcArray class to handle an array of annual number of quarters of coverage.

Collapse Expand Group

Files

Collapse Expand Links
Files


QcArray.h

QcArray.h
Classes Files Legend

Declarations for the QcArray class to handle an array of annual number of quarters of coverage.

Collapse Expand Classes
Name | Description
QcArray | Manages an array of annual quarters of coverage.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


QcPacked.cpp

QcPacked.cpp
Files

Functions for the QcPacked class to hold 8 quarters of coverage amounts in one word.

Collapse Expand Group

Files

Collapse Expand Links
Files


QcPacked.h

QcPacked.h
Classes Files Legend

Declaration of the QcPacked class to hold 8 quarters of coverage amounts in one word.

Collapse Expand Classes
Name | Description
QcPacked | Holds 8 annual quarters of coverage amounts in one word (4 bytes). Each value is in 4 bits, and can take values from 0 to 4.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


railroad.cpp

railroad.cpp
Files

Functions for the RailRoadData class to manage edited railroad record.

Collapse Expand Group

Files

Collapse Expand Links
Files


railroad.h

railroad.h
Classes Files Legend

Declarations for the RailRoadData class to manage edited railroad record.

Collapse Expand Classes
Name | Description
RailRoadData | Manages the railroad data for one worker.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


ReindWid.cpp

ReindWid.cpp
Files

Functions for the ReindWid class to manage reindexed widow(er) pia calculations.

Collapse Expand Group

Files

Collapse Expand Links
Files


ReindWid.h

ReindWid.h
Classes Files Legend

Declarations for the ReindWid class to manage reindexed widow(er) pia calculations.

Collapse Expand Classes
Name | Description
ReindWid | Manages the functions required for calculation of a reindexed widow(er) Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


ReindWidLC.cpp

ReindWidLC.cpp
Files

Functions for the ReindWidLC class to manage reindexed widow(er) pia calculation with law changes.

Collapse Expand Group

Files

Collapse Expand Links
Files


ReindWidLC.h

ReindWidLC.h
Classes Files Legend

Declarations for the ReindWidLC class to manage reindexed widow(er) pia calculation with law changes.

Collapse Expand Classes
Name | Description
ReindWidLC | Manages the functions required for calculation of a reindexed widow(er) Social Security benefit with law changes.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


RetireTest.cpp

RetireTest.cpp
Files

Functions for the RetireTest class to manage retirement test calculations.

Collapse Expand Group

Files

Collapse Expand Links
Files


RetireTest.h

RetireTest.h
Classes Files Legend

Declarations for the RetireTest class to manage retirement test calculations.

Collapse Expand Classes
Name | Description
RetireTest | Contains all of the retirement test exempt amounts and functions to use them.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


rtgenrl.cpp

rtgenrl.cpp
Files

Functions for the RtGeneral class - parent of classes to manage one retirement test projection.

Collapse Expand Group

Files

Collapse Expand Links
Files


rtgenrl.h

rtgenrl.h
Classes Files Legend

Declarations for the RtGeneral class - parent of classes to manage one retirement test projection.

Collapse Expand Classes
Name | Description
RtGeneral | Parent of classes to manage the retirement test exempt amount projections.
Rtea62 | Manages the annual retirement test exempt amount projections under full retirement age.
Rtea62m | Manages the monthly retirement test exempt amount projections under full retirement age.
Rtea65 | Manages the annual retirement test exempt amount projections over full retirement age.
Rtea65m | Manages the monthly retirement test exempt amount projections over full retirement age.
RteaHigh | Manages the upper annual retirement test exempt amounts when there were two tiers.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


ScaledEarnFactors.cpp

ScaledEarnFactors.cpp
Files

Functions for the ScaledEarnFactors class of scaled earnings factors.

Collapse Expand Group

Files

Collapse Expand Links
Files


ScaledEarnFactors.h

ScaledEarnFactors.h
Classes Files Legend

Declarations for the ScaledEarnFactors class of scaled earnings factors.

Collapse Expand Classes
Name | Description
ScaledEarnFactors | Manages scaled earner amounts.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


Secondary.cpp

Secondary.cpp
Files

Functions for the Secondary class containing the information about a secondary benefit.

Collapse Expand Group

Files

Collapse Expand Links
Files


Secondary.h

Secondary.h
Classes Files Legend

Declarations for the Secondary class containing the information about a secondary benefit.

Collapse Expand Classes
Name | Description
Secondary | Contains the information about a secondary benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


SecondaryArray.cpp

SecondaryArray.cpp
Files

Functions for the SecondaryArray class to manage a vector of secondary benefit data.

Collapse Expand Group

Files

Collapse Expand Links
Files


SecondaryArray.h

SecondaryArray.h
Classes Files Legend

Declarations for the SecondaryArray class to manage a vector of secondary benefit data.

Collapse Expand Classes
Name | Description
SecondaryArray | Manages an array of Secondary's.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


Sga.cpp

Sga.cpp
Files

Functions for the Sga class to manage SGA amounts.

Collapse Expand Group

Files

Collapse Expand Links
Files


Sga.h

Sga.h
Classes Files Legend

Declarations for the Sga class to manage SGA amounts.

Collapse Expand Classes
Name | Description
Sga | Contains all of the SGA amounts and functions to use them.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


SgaDerived.cpp

SgaDerived.cpp
Files

Functions for the SgaBlindA, SgaBlindM, SgaMinA, SgaMinM, SgaMaxA, and SgaMaxM classes (derived classes of the SgaGeneral class).

Collapse Expand Group

Files

Collapse Expand Links
Files


SgaDerived.h

SgaDerived.h
Classes Files Legend

Declarations for the SgaBlindA, SgaBlindM, SgaMinA, SgaMinM, SgaMaxA, and SgaMaxM classes (derived classes of the SgaGeneral class).

Collapse Expand Classes
Name | Description
SgaBlindA | Manages the annual SGA amounts (historical and projected) for blind beneficiaries.
SgaBlindM | Manages the monthly SGA amounts (historical and projected) for blind beneficiaries (as of December).
SgaMaxA | Manages the annual SGA maximum amounts(historical and projected) for non-blind beneficiaries.
SgaMaxM | Manages the monthly SGA maximum amounts (historical and projected) for non-blind beneficiaries (as of December).
SgaMinA | Manages the annual SGA minimum amounts (historical and projected) for non-blind beneficiaries.
SgaMinM | Manages the monthly SGA minimum amounts (historical and projected) for non-blind beneficiaries (as of December).
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


SgaGeneral.cpp

SgaGeneral.cpp
Files

Functions for the SgaGeneral class - parent of classes to handle historical and projected SGA (Substantial Gainful Activity) amounts, stored in arrays.

Collapse Expand Group

Files

Collapse Expand Links
Files


SgaGeneral.h

SgaGeneral.h
Classes Files Legend

Declarations for the SgaGeneral class - parent of classes to handle historical and projected SGA (Substantial Gainful Activity) amounts, stored in arrays.

Collapse Expand Classes
Name | Description
SgaGeneral | Parent of classes to manage the SGA (Substantial Gainful Activity) amounts (historical and projected).
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


SpecMin.cpp

SpecMin.cpp
Files

Functions for the SpecMin class to manage special minimum pia calculations.

Collapse Expand Group

Files

Collapse Expand Links
Files


SpecMin.h

SpecMin.h
Classes Files Legend

Declarations for the SpecMin class to manage special minimum pia calculations.

Collapse Expand Classes
Name | Description
SpecMin | Manages the functions required for calculation of a special minimum Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


SpecMinLC.cpp

SpecMinLC.cpp
Files

Functions for the SpecMinLC class to manage special minimum pia calculations, including changes from present law.

Collapse Expand Group

Files

Collapse Expand Links
Files


SpecMinLC.h

SpecMinLC.h
Classes Files Legend

Declarations for the SpecMinLC class to manage special minimum pia calculations, including changes from present law.

Collapse Expand Classes
Name | Description
SpecMinLC | Manages the functions required for calculation of a special minimum Social Security benefit, including changes from present law.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


TaxBenefits.cpp

TaxBenefits.cpp
Files

Functions for the TaxBenefits class to manage tax on benefits functions.

Collapse Expand Group

Files

Collapse Expand Links
Files


TaxBenefits.h

TaxBenefits.h
Classes Files Legend

Declarations for the TaxBenefits class to manage tax on benefits functions.

Collapse Expand Classes
Name | Description
TaxBenefits | Contains the functions required to calculate the tax on a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


TaxBenefitsLC.cpp

TaxBenefitsLC.cpp
Files

Functions for the TaxBenefitsLC class to manage tax on benefits functions with law changes.

Collapse Expand Group

Files

Collapse Expand Links
Files


TaxBenefitsLC.h

TaxBenefitsLC.h
Classes Files Legend

Declarations for the TaxBenefitsLC class to manage tax on benefits functions with law changes.

Collapse Expand Classes
Name | Description
TaxBenefitsLC | Contains the functions required to calculate the tax on a Social Security benefit with law changes.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


TaxData.cpp

TaxData.cpp
Files

Functions for the TaxData class to manage taxes paid by a worker.

Collapse Expand Group

Files

Collapse Expand Links
Files


TaxData.h

TaxData.h
Classes Files Legend

Declarations for the TaxData class to manage taxes paid by a worker.

Collapse Expand Classes
Name | Description
TaxData | Manages the Social Security payroll and self-employed taxes paid by a worker.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


TaxRates.cpp

TaxRates.cpp
Files

Functions for the TaxRates class - parent of classes to manage OASDHI tax rates.

Collapse Expand Group

Files

Collapse Expand Links
Files


TaxRates.h

TaxRates.h
Classes Files Legend

Declarations for the TaxRates class - parent of classes to manage OASDHI tax rates.

Collapse Expand Classes
Name | Description
TaxRates | Abstract parent of classes that manage the Social Security payroll and self-employed tax rates.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


TaxRatesLC.cpp

TaxRatesLC.cpp
Files

Functions for the TaxRatesLC class to manage the Social Security payroll and self-employed tax rates, with changes from present law.

Collapse Expand Group

Files

Collapse Expand Links
Files


TaxRatesLC.h

TaxRatesLC.h
Classes Files Legend

Declarations for the TaxRatesLC class to manage the Social Security payroll and self-employed tax rates, with changes from present law.

Collapse Expand Classes
Name | Description
TaxRatesLC | Manages the Social Security payroll and self-employed tax rates, with changes from present law.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


TaxRatesPL.cpp

TaxRatesPL.cpp
Files

Functions for the TaxRatesPL class to manage the Social Security payroll and self-employed tax rates.

Collapse Expand Group

Files

Collapse Expand Links
Files


TaxRatesPL.h

TaxRatesPL.h
Classes Files Legend

Declarations for the TaxRatesPL class to manage the Social Security payroll and self-employed tax rates.

Collapse Expand Classes
Name | Description
TaxRatesPL | Manages the present law Social Security payroll and self-employed tax rates.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


TransGuar.cpp

TransGuar.cpp
Files

Functions for the TransGuar class to manage transitional guarantee pia calculations.

Collapse Expand Group

Files

Collapse Expand Links
Files


TransGuar.h

TransGuar.h
Classes Files Legend

Declarations for the TransGuar class to manage transitional guarantee pia calculations.

Collapse Expand Classes
Name | Description
TransGuar | Manages the functions required for calculation of a transitional guarantee Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


TransGuarLC.cpp

TransGuarLC.cpp
Files

Functions for the TransGuarLC class to manage transitional guarantee pia calculations, with changes from present law.

Collapse Expand Group

Files

Collapse Expand Links
Files


TransGuarLC.h

TransGuarLC.h
Classes Files Legend

Declarations for the TransGuarLC class to manage transitional guarantee pia calculations, with changes from present law.

Collapse Expand Classes
Name | Description
TransGuarLC | Manages the functions required for calculation of a transitional guarantee Social Security benefit, with changes from present law.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


UserAssumptions.cpp

UserAssumptions.cpp
Files

Functions for the UserAssumptions class to manage user-specified assumptions.

Collapse Expand Group

Files

Collapse Expand Links
Files


UserAssumptions.h

UserAssumptions.h
Classes Files Legend

Declarations for the UserAssumptions class to manage user-specified assumptions.

Collapse Expand Classes
Name | Description
UserAssumptions | Manages all the assumptions about future average wage increases, wage bases, benefit increases, and catch-up benefit increases that a user might specify.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


WageBase.cpp

WageBase.cpp
Files

Functions for the WageBase, WageBaseHI, and WageBaseOldLaw classes to manage wage base projections.

Collapse Expand Group

Files

Collapse Expand Links
Files


WageBase.h

WageBase.h
Classes Files Legend

Declarations for the WageBase, WageBaseHI, and WageBaseOldLaw classes to manage wage base projections.

Collapse Expand Classes
Name | Description
WageBase | Manages the OASDI wage base projections.
WageBaseHI | Manages the HI wage base projections.
WageBaseOldLaw | Manages the old-law OASDI wage base projections.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


WageInd.cpp

WageInd.cpp
Files

Functions for the WageInd class to calculate a wage-indexed PIA.

Collapse Expand Group

Files

Collapse Expand Links
Files


WageInd.h

WageInd.h
Classes Files Legend

Declarations for the WageInd class to manage wage-indexed pia calculation functions.

Collapse Expand Classes
Name | Description
WageInd | Manages the functions required for calculation of a wage indexed Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


WageIndGeneral.cpp

WageIndGeneral.cpp
Files

Functions for the WageIndGeneral class - parent of classes to manage wage-indexed pia calculations.

Collapse Expand Group

Files

Collapse Expand Links
Files


WageIndGeneral.h

WageIndGeneral.h
Classes Files Legend

Declarations for the WageIndGeneral class - parent of classes to manage wage-indexed pia calculations.

Collapse Expand Classes
Name | Description
WageIndGeneral | Parent of all classes that manage the functions required for calculation of a wage indexed Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


WageIndLC.cpp

WageIndLC.cpp
Files

Functions for the WageIndLC class to manage wage-indexed pia calculation, with law change parameters.

Collapse Expand Group

Files

Collapse Expand Links
Files


WageIndLC.h

WageIndLC.h
Classes Files Legend

Declarations for the WageIndLC class to manage wage-indexed pia calculation, with law change parameters.

Collapse Expand Classes
Name | Description
WageIndLC | Manages the functions required for calculation of a wage indexed Social Security benefit, with changes from present law.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


WageIndNonFreeze.cpp

WageIndNonFreeze.cpp
Files

Functions for the WageIndNonFreeze class to calculate a wage-indexed non-freeze PIA.

Collapse Expand Group

Files

Collapse Expand Links
Files


WageIndNonFreeze.h

WageIndNonFreeze.h
Classes Files Legend

Declarations for the WageIndNonFreeze class to manage wage-indexed non-freeze pia calculation functions.

Collapse Expand Classes
Name | Description
WageIndNonFreeze | Manages the functions required for calculation of a wage indexed non-freeze Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


wbgenrl.cpp

wbgenrl.cpp
Files

Functions for the WageBaseGeneral class - parent of classes that manage wage base projections.

Collapse Expand Group

Files

Collapse Expand Links
Files


wbgenrl.h

wbgenrl.h
Classes Files Legend

Declarations for the WageBaseGeneral class - parent of classes that manage wage base projections.

Collapse Expand Classes
Name | Description
WageBaseGeneral | Ancestor of the classes that manage the wage base projections.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


wbgenrlLC.cpp

wbgenrlLC.cpp
Files

Functions for the WageBaseLC and WageBaseOldLawLC classes to manage wage base projections with law changes.

Collapse Expand Group

Files

Collapse Expand Links
Files


wbgenrlLC.h

wbgenrlLC.h
Classes Files Legend

Declarations for the WageBaseLC and WageBaseOldLawLC classes to manage wage base projections with law changes.

Collapse Expand Classes
Name | Description
WageBaseLC | Manages the OASDI wage base projection with law changes.
WageBaseOldLawLC | Manages the old-law OASDI wage base projection with law changes.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


WorkerDataArray.cpp

WorkerDataArray.cpp
Files

Functions for the WorkerDataArray class to manage array of WorkerData's.

Collapse Expand Group

Files

Collapse Expand Links
Files


WorkerDataArray.h

WorkerDataArray.h
Classes Files Legend

Declarations for the WorkerDataArray class to manage array of WorkerData's.

Collapse Expand Classes
Name | Description
WorkerDataArray | Manages an array of WorkerData's, representing one family.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


WorkerDataGeneral.cpp

WorkerDataGeneral.cpp
Files

Functions for the WorkerDataGeneral class - parent of classes to manage worker data.

Collapse Expand Group

Files

Collapse Expand Links
Files


WorkerDataGeneral.h

WorkerDataGeneral.h
Classes Files Legend

Declarations for the WorkerDataGeneral class - parent of classes to manage worker data.

Collapse Expand Classes
Name | Description
WorkerDataGeneral | The abstract parent of all classes that manage the basic data required to calculate a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


wrkrdata.cpp

wrkrdata.cpp
Files

Functions for the WorkerData class to manage worker data.

Collapse Expand Group

Files

Collapse Expand Links
Files


wrkrdata.h

wrkrdata.h
Classes Files Legend

Declarations for the WorkerData class to manage worker data.

Collapse Expand Classes
Name | Description
WorkerData | Manages the basic data required to calculate a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


bendmfb.h

bendmfb.h
Classes Files Legend

Declarations needed for class to manage array of MFB formula bend points.

Collapse Expand Classes
Name | Description
BendMfb | Manages the array of bend points used in the MFB formula.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


bendpia.h

bendpia.h
Classes Files Legend

Declarations for the BendPia class to manage array of PIA formula bend points.

Collapse Expand Classes
Name | Description
BendPia | Manages the array of bend points used in the PIA formula.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PortionAime.cpp

PortionAime.cpp
Files

Functions to handle PIA formula AIME portions.

Collapse Expand Group

Files

Collapse Expand Links
Files


PortionAime.h

PortionAime.h
Classes Files Legend

Declarations needed for class to manage array of portions of AIME in the PIA formula.

Collapse Expand Classes
Name | Description
PortionAime | Manages the array of portions of AIME in the PIA formula.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


Misc Library

Misc Library
Legend Topics

The misc library part of the oactobjs library.

Collapse Expand Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Macros | The following table lists macros in this documentation.
Files | The following table lists files in this documentation.
Collapse Expand Classes
Name | Description
Age | Manages a year and month age stored as integers.
AnnualArrays | Functions using annual arrays.
BitAnnual | Manages an array of annual bits.
Date | Static variables and functions for classes that hold dates.
DateFormatter | Manages static functions to format and parse dates.
DateMoyr | Manages a month and year stored as unsigned integers.
Document | Manages a generic document.
DoubleAnnual | Manages an array of annual doubles.
DoubleAnnualRead | Reads a DoubleAnnual.
DoubleAnnualWrite | Writes a DoubleAnnual.
DoubleMonth | Manages an array of monthly doubles.
DoubleQuarter | Manages an array of quarterly doubles.
FloatAnnual | Manages an array of annual floats.
FloatMonth | Manages an array of monthly floats.
FloatQuarter | Manages an array of quarterly floats.
Genfile | Manages a generic file.
IntAnnual | Manages an array of annual integers.
Out132 | An Outfile tailored for 132-column output.
Out80 | An Outfile tailored for 80-column output.
OutDC80 | Handles output to a Windows window.
OutFile132 | Manages the print output functions, when printing to a file formatted for 132 columns.
OutFile80 | Manages the print output functions, when printing to a file formatted for 80 columns.
OutFileHTML | Manages the print output functions, when printing to an HTML file.
Outfile | Abstract parent of classes to manage an output file in runstreams with multiple programs.
PageCounters | Manages a vector of page counters.
PageOut | Abstract parent of classes to manage a page of printed output.
Path | Provides operations on string instances that contain file or directory path information.
PiaException | Manages an exception in the piadata library.
PunctFacet | Numeric punctuation facet with 3 digits per thousands separator.
QtrYear | Manages a year and quarter stored as unsigned integers.
Sex | Indicator for sex type.
Ssn | Manages a Social Security number string, and the 3 parts of an ssn separately as strings.
TextWriterTraceListener | An output-stream-based class that listens for Trace output.
Trace | Controls the logfiles used to trace execution of code.
TraceListener | The parent of classes that listen for Trace output.
Collapse Expand Files
Name | Description
AnnualArrays.cpp | Functions for the AnnualArrays class of static functions using annual arrays.
AnnualArrays.h | Declarations for the AnnualArrays class of static functions using annual arrays.
BitAnnual.cpp | Functions for the BitAnnual class to manage an array of annual bits.
BitAnnual.h | Declarations for the BitAnnual class to manage an array of annual bits.
BitAnnualBase.cpp | Functions for the BitAnnual class to manage an array of annual bits for Windows.
BitAnnualBase.h | Declarations for the BitAnnual class to manage an array of annual bits for Windows.
BitAnnualInlines.h | Inline functions for the BitAnnual class to manage an array of annual bits for Windows.
CommaBase.h | Definitions used by the pcomma function on a Windows machine.
DateFormatter.cpp | Functions for the DateFormatter class to format and parse dates.
DateFormatter.h | Declarations for the DateFormatter class to format and parse dates.
DoubleAnnualRW.cpp | Functions for the DoubleAnnualRead and DoubleAnnualWrite classes to read or write an array of annual doubles.
DoubleAnnualRW.h | Declarations for the DoubleAnnualRead and DoubleAnnualWrite classes to read or write an array of annual doubles.
FormatString.cpp | Functions to mimic AfxFormatString using Standard C++ Library strings.
FormatString.h | Declarations of functions to mimic AfxFormatString using Standard C++ Library strings.
NumPunct.cpp | Data for the PunctFacet structure to handle numeric punctuation.
NumPunct.h | Declarations for the PunctFacet structure to handle numeric punctuation.
OutDC.cpp | Functions needed for the OutDC80 class to write to a device context (DC).
OutDC.h | Declarations needed for the OutDC80 class to write to a device context (DC).
OutFile132.cpp | Functions for the OutFile132 class to manage print output to a file with 132-column lines.
OutFile132.h | Declarations for the OutFile132 class to manage print output to a file with 132-column lines.
OutFile80.cpp | Functions needed for the OutFile80 class to manage print output to a file with 80-column lines.
OutFile80.h | Declarations for the OutFile80 class to manage print output to a file with 80-column lines.
OutfileHTML.cpp | Functions for the OutFileHTML class to manage print output to an html file.
OutfileHTML.h | Declarations for the OutFileHTML class to manage print output to an html file.
PageOut.cpp | Functions for the PageOut class - parent of classes to manage a page of printed output.
PageOut.h | Declarations for the PageOut class - parent of classes to manage a page of printed output.
Path.cpp | Functions for the Path class that provides operations on string instances that contain file or directory path information.
Path.h | Declarations for the Path class that provides operations on string instances that contain file or directory path information.
PiaException.cpp | Functions for the PiaException class to manage an exception in the piadata library.
PiaException.h | Declarations for the PiaException class to manage an exception in the piadata library.
Resource.h | String IDS used in oactobjs library.
Sex.cpp | Functions for the Sex class holding a sex indicator.
Sex.h | Declarations needed for the Sex class holding a sex indicator.
StringParser.cpp | Function definitions to parse a string.
StringParser.h | Declarations of functions to parse a string.
TextWriterTraceListener.cpp | Functions for the TextWriterTraceListener class that listens for Trace output and writes to an ostream.
TextWriterTraceListener.h | Declarations for the TextWriterTraceListener class that listens for Trace output and writes to an ostream.
Trace.cpp | Functions for the Trace class to trace execution of code.
Trace.h | Declarations for the Trace class to trace execution of code.
TraceListener.cpp | Functions for the TraceListener class - parent of classes that listen for Trace output.
TraceListener.h | Declarations for the TraceListener class - parent of classes that listen for Trace output.
age.cpp | Functions for Age class to manage age in years and months.
age.h | Declarations for Age class to manage age in years and months.
comma.cpp | Functions that return strings with (or without) embedded commas in any type of number (floating or integral).
comma.h | Declarations of functions that return strings with (or without) embedded commas in any type of number (floating or integral).
date.cpp | Functions for the static Date class to manage date and time.
date.h | Declarations for the static Date class to manage date and time.
datemoyr.cpp | Functions needed for the DateMoyr class to handle date as month and year.
datemoyr.h | Declarations needed for DateMoyr class to manage date as month and year.
dbleann.cpp | Functions needed for DoubleAnnual class to manage an array of annual doubles.
dbleann.h | Declarations needed for DoubleAnnual class to manage an array of annual doubles.
dblemth.cpp | Functions for the DoubleMonth class to manage an array of monthly doubles.
dblemth.h | Declarations for the DoubleMonth class to manage an array of monthly doubles.
dbleqtr.cpp | Functions for the DoubleQuarter class to manage an array of quarterly doubles.
dbleqtr.h | Declarations for the DoubleQuarter class to manage an array of quarterly doubles.
document.cpp | Functions for the Document class to manage a generic document.
document.h | Declarations for the Document class to manage a generic document.
floatann.cpp | Functions for the FloatAnnual class to manage an array of annual floats.
floatann.h | Declarations for the FloatAnnual class to manage an array of annual floats.
floatmth.cpp | Functions for the FloatMonth class to manage an array of monthly floats.
floatmth.h | Declarations for the FloatMonth class to manage an array of monthly floats.
floatqtr.cpp | Functions for the FloatQuarter class to manage an array of quarterly floats.
floatqtr.h | Declarations for the FloatQuarter class to manage an array of quarterly floats.
genfile.cpp | Functions for the Genfile class to manage a general file.
genfile.h | Declarations for the Genfile class to manage a general file.
intann.cpp | Functions for the IntAnnual class to manage an array of annual integers.
intann.h | Declarations for the IntAnnual class to manage an array of annual integers.
outfile.cpp | Functions for the Outfile, Out132, and Out80 classes - parents of classes to manage output file with page counters.
outfile.h | Declarations for the Outfile, Out132, and Out80 classes - parents of classes to manage output file with page counters.
page.cpp | Functions for the PageCounters class to manage page counters.
page.h | Declarations for the PageCounters class to manage page counters.
qtryear.cpp | Functions for the QtrYear class to handle a year and quarter.
qtryear.h | Declarations for the QtrYear class to handle a year and quarter.
ssn.cpp | Functions for the Ssn class to manage a Social Security number.
ssn.h | Declarations for the Ssn class to manage a Social Security number.
Collapse Expand Functions
Name | Description
AfxFormatString1 | Loads the specified string resource and substitutes for the characters "%1" the string referenced by filler.
AfxFormatString2 | Loads the specified string resource and substitutes for the characters "%1"and "%2" the strings referenced by filler1 and filler2.
parseString | Parses a string into its delimited parts, using a space separator.
parseString | Parses a string into its delimited parts with a specified delimiter.
pblank | Inserts blanks or zeroes on the left of a formatted string representing a number.
pcomma | Inserts commas into a formatted string representing a number.
Collapse Expand Macros
Name | Description
ENDS | No special character for end of ostringstream.
FREEZE | No special function to freeze the string.
OSTREAM | Use ostringstream for formatting output.
PIA_IDS_2YEARS | (Currently unused.)
PIA_IDS_ACTQCOUT | String ID for printing actual quarters of coverage.
PIA_IDS_AGEMONTH | Type of PiaException thrown if number of months in an Age is greater than 11.
PIA_IDS_AGEPLAN | Type of PiaException thrown if planned age of retirement is out of range.
PIA_IDS_AIMEOUT | String ID for printing AIME.
PIA_IDS_AMEOUT | String ID for printing AMW.
PIA_IDS_ANDLATER | (Currently unused.)
PIA_IDS_ANSCCH | Type of PiaException thrown if catch-up increase indicator is out of range.
PIA_IDS_APPCOLA1 | Type of PiaException thrown if year is out of range in PiaParams::applyCola without catch-up.
PIA_IDS_APPCOLA2 | Type of PiaException thrown if year is out of range in PiaParams::applyCola with catch-up.
PIA_IDS_APPCOLA3 | Type of PiaException thrown if year is out of range in PiaParams::applyColaMfb without catch-up.
PIA_IDS_APPCOLA4 | Type of PiaException thrown if year is out of range in PiaParams::applyColaMfb with catch-up.
PIA_IDS_ARDRI1 | Type of PiaException thrown if age is out of range in PiaCal::ardriCal.
PIA_IDS_ARDRI10 | Type of PiaException thrown if aged wife age is before early retirement age in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI2 | Type of PiaException thrown if age is before early retirement age for OAB in PiaCal::ardriCal.
PIA_IDS_ARDRI3 | (Currently unused.)
PIA_IDS_ARDRI4 | Type of PiaException thrown if disabled widow(er) age is before earliest possible age in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI5 | Type of PiaException thrown if disabled widow(er) entitlement is before benefit date in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI6 | Type of PiaException thrown if aged widow(er) age is before earliest possible age in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI7 | Type of PiaException thrown if DIB entitlement before 1957 in PiaCal::ardriCal.
PIA_IDS_ARDRI8 | Type of PiaException thrown if age under 50 for DIB before 1960 in PiaCal::ardriCal.
PIA_IDS_ARDRI9 | Type of PiaException thrown if age over full retirement age for DIB in PiaCal::ardriCal.
PIA_IDS_ARFFOUT | String ID for printing actuarial reduction factor.
PIA_IDS_ARFMOUT | String ID for printing months of actuarial reduction.
PIA_IDS_ATODOUBLE | (Currently unused).
PIA_IDS_ATOFLOAT | (Currently unused).
PIA_IDS_ATOINT | (Currently unused).
PIA_IDS_ATOLONG | (Currently unused).
PIA_IDS_AVERAGETEXT | (Currently unused.)
PIA_IDS_AVGWG | Type of PiaException thrown if year is out of range in an AverageWage function.
PIA_IDS_AVGWGTTL | (Currently unused.)
PIA_IDS_AWASSUM | (Currently unused.)
PIA_IDS_AWBI1 | Type of PiaException thrown if unable to open input file in AwbiDataFile::read.
PIA_IDS_AWBI2 | Type of PiaException thrown if unable to open output file in AwbiDataFile::write.
PIA_IDS_AWBI3 | Type of PiaException thrown if unable to read all required data in AwbiDataFile::read.
PIA_IDS_AWBIDAT1 | Type of PiaException thrown if last year of historical data is too large in AwbiDataNonFile::setData.
PIA_IDS_AWOUT | String ID for printing average wage assumptions.
PIA_IDS_BASE1 | Type of PiaException thrown if first year is out of range in WageBaseGeneral::project.
PIA_IDS_BASE2 | Type of PiaException thrown if wage base is out of range.
PIA_IDS_BASECH | Type of PiaException thrown if wage base indicator is not 1 or 2.
PIA_IDS_BASEYR1 | Type of PiaException thrown if base year is out of range (1979-2020).
PIA_IDS_BASEYR2 | Type of PiaException thrown if unable to open output file in BaseYearFile::write.
PIA_IDS_BASEYR3 | Type of PiaException thrown if unable to read base year in BaseYearFile::read.
PIA_IDS_BASEYR4 | Type of PiaException thrown if unable to open input file in BaseYearFile::read.
PIA_IDS_BEGIN1 | Type of PiaException thrown if first year of earnings is out of range.
PIA_IDS_BEGIN2 | Type of PiaException thrown if last year of earnings is before first year of earnings in backward projection period.
PIA_IDS_BEGIN3 | Type of PiaException thrown if first year of earnings is before 1937.
PIA_IDS_BEGIN4 | Type of PiaException thrown if first year of earnings is in starting year of projections or later, in a Statement case.
PIA_IDS_BEGIN5 | Type of PiaException thrown if first year of earnings is after maximum year allowed, in a non-Statement case.
PIA_IDS_BEGIN6 | Type of PiaException thrown if there are no regular, railroad, or military earnings.
PIA_IDS_BEN1OUT | String ID for printing benefit before rounding.
PIA_IDS_BEN2OUT | String ID for printing benefit after rounding.
PIA_IDS_BENARRAY1 | Type of PiaException thrown if year is out of range in BenefitAmountArray functions.
PIA_IDS_BENARRAY2 | Type of PiaException thrown if year is out of range in BenefitAmountArray::[].
PIA_IDS_BENDATE1 | Type of PiaException thrown if benefit date is before entitlement date.
PIA_IDS_BENDATE2 | Type of PiaException thrown if month of benefit is out of range.
PIA_IDS_BENDATE3 | Type of PiaException thrown if year of benefit is before 1940.
PIA_IDS_BENDATE4 | Type of PiaException thrown if year of benefit is after maximum allowed.
PIA_IDS_BENDATE5 | (Currently unused.)
PIA_IDS_BENDATE6 | Type of PiaException thrown if secondary entitlement after benefit date.
PIA_IDS_BENFOUT | String ID for printing secondary benefit factor.
PIA_IDS_BIASSUM | (Currently unused.)
PIA_IDS_BICCHP | Type of PiaException thrown if year is out of range in Catchup functions.
PIA_IDS_BIOUT | String ID for printing benefit increase assumptions.
PIA_IDS_BIPROJTTL | (Currently unused.)
PIA_IDS_BIRTH1 | Type of PiaException thrown if year of birth is in current year or later (in Statement case).
PIA_IDS_BIRTH2 | Type of PiaException thrown if year of birth is before 1800.
PIA_IDS_BIRTH3 | Type of PiaException thrown if month of birth is out of range.
PIA_IDS_BIRTH4 | Type of PiaException thrown if day of birth is out of range.
PIA_IDS_BIRTH5 | Type of PiaException thrown if year of birth is after maximum allowed.
PIA_IDS_BIRTH6 | (Currently unused.)
PIA_IDS_BITANN1 | Type of PiaException thrown if year is out of range in BitAnnual functions.
PIA_IDS_CACHUP1 | Type of PiaException thrown if catch-up benefit increase is out of range.
PIA_IDS_CACHUP2 | Type of PiaException thrown if unable to open input file in CatchupFile::read.
PIA_IDS_CACHUP3 | Type of PiaException thrown if unable to open output file in CatchupFile::write.
PIA_IDS_CACHUP4 | Type of PiaException thrown if year is out of range in a Catchup function.
PIA_IDS_CESS2OUT | String ID for printing second prior date of cessation.
PIA_IDS_COMMA | Type of PiaException thrown if number of decimals is nonzero for other than a float type in pout.
PIA_IDS_CONFIG1 | Type of PiaException thrown if unable to open input file in ConfigFile::read.
PIA_IDS_CONFIG5 | Type of PiaException thrown if unable to open output file in ConfigFile::write.
PIA_IDS_CONFIG6 | Type of PiaException thrown if unable to read all required data in ConfigFile::read.
PIA_IDS_CPIINC1 | Type of PiaException thrown if benefit increase is out of range.
PIA_IDS_CPIINC2 | Type of PiaException thrown if unable to open output file in BiprojFile::write.
PIA_IDS_CPIINC3 | Type of PiaException thrown if unable to read all required data in BiprojFile::read.
PIA_IDS_CPIINC4 | Type of PiaException thrown if unable to open input file in BiprojFile::read.
PIA_IDS_CUPROJTTL | (Currently unused.)
PIA_IDS_CURINSOUT | String ID for printing currently insured status in survivor case.
PIA_IDS_DATEDAY | Type of PiaException thrown if day in a date is out of range.
PIA_IDS_DATEDIFF | Type of PiaException thrown if unable to difference two dates.
PIA_IDS_DATEMONTH | Type of PiaException thrown if month in a date is out of range.
PIA_IDS_DATEREAD | Type of PiaException thrown if unable to parse string into a date.
PIA_IDS_DATEYEAR | Type of PiaException thrown if year in a date is out of range.
PIA_IDS_DBLEANN1 | (Currently unused).
PIA_IDS_DBLEANN2 | Type of PiaException thrown if unable to read specified years in DoubleAnnualRead::read.
PIA_IDS_DEATH1 | Type of PiaException thrown if month of death is out of range.
PIA_IDS_DEATH2 | Type of PiaException thrown if year of death is after maximum allowed.
PIA_IDS_DEATH3 | Type of PiaException thrown if death before 1937 in a survivor case.
PIA_IDS_DEATH4 | Type of PiaException thrown if entitlement of survivor is before death of worker.
PIA_IDS_DEATH5 | Type of PiaException thrown if death of worker is before birth.
PIA_IDS_DEATH6 | (Currently unused.)
PIA_IDS_DEATHOUT | String ID for printing date of death.
PIA_IDS_DIBENTOUT | String ID for printing DIB date of entitlement.
PIA_IDS_DICESS1 | Type of PiaException thrown if month of cessation is out of range.
PIA_IDS_DICESS2 | Type of PiaException thrown if year of cessation is before 1937.
PIA_IDS_DICESS3 | Type of PiaException thrown if year of cessation is after maximum allowed.
PIA_IDS_DICESS4 | Type of PiaException thrown if disability cessation before onset.
PIA_IDS_DICESS5 | Type of PiaException thrown if prior disability cessation after second entitlement.
PIA_IDS_DICESS6 | Type of PiaException thrown if entitlement is before cessation.
PIA_IDS_DICESS7 | Type of PiaException thrown if cessation is after death in a survivor case.
PIA_IDS_DICESS8 | (Currently unused.)
PIA_IDS_DINS1OUT | String ID for printing first part of disability insured status.
PIA_IDS_DINS2OUT | String ID for printing second part of disability insured status.
PIA_IDS_DINS3OUT | String ID for printing third part of disability insured status.
PIA_IDS_DISREQCAL1 | Type of PiaException thrown if year in most recent freeze period is out of range in PiaData::qcDisReqCal.
PIA_IDS_DISREQCAL2 | Type of PiaException thrown if year in next most recent freeze period is out of range in PiaData::qcDisReqCal.
PIA_IDS_DOBOUT | String ID for printing date of birth.
PIA_IDS_DOBWIDOUT | String ID for printing date of birth of widow(er).
PIA_IDS_DRCFOUT | String ID for printing delayed retirement credit factor.
PIA_IDS_DRCMOUT | String ID for printing months of delayed retirement credit.
PIA_IDS_EARNHI | Type of PiaException thrown if Medicare earnings are out of range.
PIA_IDS_EARNMAL | Type of PiaException thrown if year is before 1937 in EarnProject::toString.
PIA_IDS_EARNPEBS | Type of PiaException thrown if OASDI earnings are out of range.
PIA_IDS_EARNPROJ | Type of PiaException thrown if projection year is out of range in EarnProject::project.
PIA_IDS_EARNTYPE | Type of PiaException thrown if type of earnings is out of range.
PIA_IDS_EARNTYPE1 | Type of PiaException thrown if projection year is out of range in PiaWrite::writeEarnType.
PIA_IDS_EARNTYPEYR | Type of PiaException thrown if year is out of range in EarnProject::setEarntype.
PIA_IDS_ELAPSOUT | String ID for printing elapsed years.
PIA_IDS_END1 | Type of PiaException thrown if last year of earnings is before 1937.
PIA_IDS_END2 | Type of PiaException thrown if last year of earnings is after maximum year allowed.
PIA_IDS_END3 | Type of PiaException thrown if first year of earnings in forward projection period is after last year of earnings in forward projection period.
PIA_IDS_END4 | Type of PiaException thrown if the total number of years of earnings is greater than the maximum allowed (MAXYRS).
PIA_IDS_ENT1 | Type of PiaException thrown if month of entitlement is out of range.
PIA_IDS_ENT2 | Type of PiaException thrown if year of entitlement is before 1940.
PIA_IDS_ENT3 | Type of PiaException thrown if year of entitlement is after maximum allowed.
PIA_IDS_ENT4 | (Currently unused.)
PIA_IDS_ERNLIMOUT | String ID for printing earnings over maximum allowed.
PIA_IDS_FAMSIZE | Type of PiaException thrown if family size is out of bounds.
PIA_IDS_FLOATANN1 | (Currently unused).
PIA_IDS_FLOATANN2 | (Currently unused).
PIA_IDS_FLOATMTH1 | Type of PiaException thrown if years are out of range in a FloatMonth function.
PIA_IDS_FLOATMTH2 | Type of PiaException thrown if unable to read specified years in FloatMonth::read.
PIA_IDS_FLOATMTH3 | Type of PiaException thrown if quarter is out of range in a FloatMonth function.
PIA_IDS_FLOATQTR1 | Type of PiaException thrown if years are out of range in a FloatQuarter function.
PIA_IDS_FLOATQTR2 | Type of PiaException thrown if unable to read specified years in FloatQuarter::read.
PIA_IDS_FLOATQTR3 | Type of PiaException thrown if quarter is out of range in a FloatQuarter function.
PIA_IDS_FLOATQTR4 | Type of PiaException thrown if data value is zero in a FloatQuarter divide function.
PIA_IDS_FMSTRING | Type of PiaException thrown if error in FrozMinPage::prepareStrings.
PIA_IDS_FOINFO1 | Type of PiaException thrown if unable to open input file in FieldOfficeInfoFile::read.
PIA_IDS_FOINFO2 | Type of PiaException thrown if unable to read all required data in FieldOfficeInfoFile::read.
PIA_IDS_FOINFO3 | Type of PiaException thrown if unable to open output file in FieldOfficeInfoFile::write.
PIA_IDS_FQINC1 | Type of PiaException thrown if average wage increase is out of range.
PIA_IDS_FQINC2 | Type of PiaException thrown if unable to open output file in AwincFile::write.
PIA_IDS_FQINC3 | Type of PiaException thrown if unable to read all required data in AwincFile::read.
PIA_IDS_FQINC4 | Type of PiaException thrown if unable to open input file in AwincFile::read.
PIA_IDS_FULLBEN | String ID for printing full secondary benefit.
PIA_IDS_GENFILE1 | Type of PiaException thrown if unable to open a Genfile for output.
PIA_IDS_GENFILE2 | Type of PiaException thrown if unable to open a Genfile for appended output.
PIA_IDS_GENFILE3 | Type of PiaException thrown if unable to open a Genfile for input.
PIA_IDS_HIGHTEXT | (Currently unused.)
PIA_IDS_HISTAMTTL | (Currently unused.)
PIA_IDS_HISTAMTUPDATE | (Currently unused.)
PIA_IDS_IALTAW1 | Type of PiaException thrown if average wage increase indicator is out of range in general case.
PIA_IDS_IALTAW2 | Type of PiaException thrown if average wage increase indicator is out of range in Statement case.
PIA_IDS_IALTBI1 | Type of PiaException thrown if benefit increase indicator is out of range in general case.
PIA_IDS_IALTBI2 | Type of PiaException thrown if benefit increase indicator is out of range in Statement case.
PIA_IDS_INSTATOUT | String ID for printing insured status.
PIA_IDS_INSUREOUT | String ID for printing fully insured for totalization benefits.
PIA_IDS_INTANN1 | (Currently unused).
PIA_IDS_INTANN2 | (Currently unused).
PIA_IDS_JBIRTH1 | (Currently unused.)
PIA_IDS_JBIRTH2 | (Currently unused.)
PIA_IDS_JBIRTH3 | (Currently unused.)
PIA_IDS_JBIRTH4 | (Currently unused.)
PIA_IDS_JBIRTH5 | (Currently unused.)
PIA_IDS_JOASDI | Type of PiaException thrown if type of benefit is out of range.
PIA_IDS_JONSET1 | (Currently unused.)
PIA_IDS_JONSET2 | (Currently unused.)
PIA_IDS_JONSET3 | (Currently unused.)
PIA_IDS_JONSET4 | (Currently unused.)
PIA_IDS_JONSET5 | Type of PiaException thrown if widow's disability is before birth.
PIA_IDS_JONSET6 | Type of PiaException thrown if widow's disability is after entitlement.
PIA_IDS_JONSET7 | (Currently unused.)
PIA_IDS_JSURV | Type of PiaException thrown if bic is not a valid life or survivor bic.
PIA_IDS_JSURVOUT | String ID for printing type of survivor.
PIA_IDS_LAWCHG1 | Type of PiaException thrown if starting year of law changes is out of range.
PIA_IDS_LAWCHG2 | Type of PiaException thrown if law change wage increase proportion is out of range.
PIA_IDS_LAWCHG3 | Type of PiaException thrown if law change benefit formula percentage is out of range.
PIA_IDS_LAWCHG4 | Type of PiaException thrown if law change bend point is out of range.
PIA_IDS_LAWCHG5 | Type of PiaException thrown if law change constant decline percentage is out of range.
PIA_IDS_LAWCHG6 | Type of PiaException thrown if unable to parse input line in LawChangeRead::read.
PIA_IDS_LAWCHG7 | Type of PiaException thrown if unable to open input file in LawChangeRead::read.
PIA_IDS_LAWCHG8 | Type of PiaException thrown if unable to open output file in LawChangeWrite::write.
PIA_IDS_LAWCHG9 | Type of PiaException thrown if type of law change is out of range.
PIA_IDS_LOWTEXT | (Currently unused.)
PIA_IDS_MAXIMUMTEXT | (Currently unused.)
PIA_IDS_METHOD | Type of PiaException thrown if years are inconsistent in PiaMethod::totalEarnCal.
PIA_IDS_MFBBEN | String ID for printing maximum family benefit.
PIA_IDS_MFBLOUT | String ID for printing MFB at eligibility.
PIA_IDS_MFBOUT | String ID for printing MFB.
PIA_IDS_MILSERV1 | Type of PiaException thrown if military service starting date is after ending date.
PIA_IDS_MILSERV2 | Type of PiaException thrown if number of military service periods is out of range in general case.
PIA_IDS_MILSERV3 | Type of PiaException thrown if number of military service periods is out of range in military service case.
PIA_IDS_MILSERV4 | Type of PiaException thrown if military service starting date is out of range.
PIA_IDS_MILSERV5 | Type of PiaException thrown if military service ending date is out of range.
PIA_IDS_MILSERV6 | Type of PiaException thrown if years are out of range in MilServDates::getQc3750.
PIA_IDS_MILSERV7 | Type of PiaException thrown if years are out of range in MilServDates::getEarn3750.
PIA_IDS_MODTC | Type of PiaException thrown if moddata is in error.
PIA_IDS_MONTHTEXT | (Currently unused).
PIA_IDS_NAMEOUT | String ID for printing worker's name.
PIA_IDS_NDISINOUT | String ID for printing not disability insured.
PIA_IDS_NEEDAW | (Currently unused).
PIA_IDS_NEEDBASES | Type of PiaException thrown if year is out of range in WorkerDataGeneral::need_bases.
PIA_IDS_NEEDBI | (Currently unused).
PIA_IDS_NINSTOUT | String ID for printing not insured in survivor case.
PIA_IDS_NINSUROUT | String ID for printing not fully insured.
PIA_IDS_NONPENDATE1 | Type of PiaException thrown if noncovered pension entitlement date is before birth.
PIA_IDS_NONPENDATE2 | Type of PiaException thrown if noncovered pension entitlement date is after death.
PIA_IDS_NONPENDATE3 | Type of PiaException thrown if noncovered pension entitlement date entry is invalid.
PIA_IDS_NONPENDATEOUT | String ID for printing noncovered pension entitlement date.
PIA_IDS_NONPENOUT | String ID for printing noncovered pension.
PIA_IDS_NRA1OUT | String ID for printing early retirement age.
PIA_IDS_NRAOUT | String ID for printing full retirement age.
PIA_IDS_NRAWIDOUT | String ID for printing widow(er)'s full retirement age.
PIA_IDS_NRAWIFEOUT | String ID for printing full retirement age of aged wife/husband.
PIA_IDS_NTOTALOUT | String ID for printing not insured for totalization benefits.
PIA_IDS_OABBENOUT | String ID for printing OAB date of benefit.
PIA_IDS_OABENTOUT | String ID for printing OAB date of entitlement.
PIA_IDS_OLDSTART1 | Type of PiaException thrown if date of entitlement is out of range in OldStart::calculate.
PIA_IDS_OLDSTART2 | Type of PiaException thrown if old start method number is out of range.
PIA_IDS_ONEPAGE | Type of PiaException thrown if error in OnePage::prepareStrings.
PIA_IDS_ONSET1 | Type of PiaException thrown if month of onset is out of range.
PIA_IDS_ONSET10 | (Currently unused.)
PIA_IDS_ONSET11 | Type of PiaException thrown if disability onset is after full retirement age.
PIA_IDS_ONSET2 | Type of PiaException thrown if day of onset is out of range.
PIA_IDS_ONSET2OUT | String ID for printing second prior date of onset.
PIA_IDS_ONSET3 | Type of PiaException thrown if year of onset is before 1937.
PIA_IDS_ONSET4 | Type of PiaException thrown if year of onset is after maximum allowed.
PIA_IDS_ONSET5 | Type of PiaException thrown if disability is before birth.
PIA_IDS_ONSET6 | Type of PiaException thrown if disability is after entitlement.
PIA_IDS_ONSET7 | Type of PiaException thrown if death of worker is before disability onset in a survivor case.
PIA_IDS_ONSET8 | Type of PiaException thrown if prior disability is after current disability.
PIA_IDS_ONSET9 | (Currently unused.)
PIA_IDS_ONSETOUT | String ID for printing date of onset.
PIA_IDS_OPENERR | (Currently unused.)
PIA_IDS_OSRANGE1 | (Currently unused.)
PIA_IDS_OSRANGE2 | (Currently unused.)
PIA_IDS_OSSTRING | Type of PiaException thrown if error in OldStart1Page::prepareStrings.
PIA_IDS_OUTFILE | (Currently unused.)
PIA_IDS_PEBESMONTH | Type of PiaException thrown if month of Statement processing is out of range.
PIA_IDS_PEBSASM | Type of PiaException thrown if benefit increase indicator or average wage increase indicator is out of range in Statement case.
PIA_IDS_PERCBACK | Type of PiaException thrown if backward projection percentage is out of range.
PIA_IDS_PERCFWRD | Type of PiaException thrown if forward projection percentage is out of range.
PIA_IDS_PIACALPLRGE | (Currently unused.)
PIA_IDS_PIACALRANGE | (Currently unused.)
PIA_IDS_PIALOUT | String ID for printing PIA at eligibility.
PIA_IDS_PIAOUT | String ID for printing PIA.
PIA_IDS_PIATABLE1 | Type of PiaException thrown if year of entitlement is out of range in PiaTable::calculate.
PIA_IDS_PIATABLE2 | Type of PiaException thrown if year of benefit is out of range in PiaTable::calculate.
PIA_IDS_PIB50MFB | Type of PiaException thrown if index is out of range in Pib50Mfb::getAt.
PIA_IDS_PIB50PIB | Type of PiaException thrown if index is out of range in Pib50Pib::getAt.
PIA_IDS_PIB52MFB | Type of PiaException thrown if index is out of range in Pib52Mfb::getAt.
PIA_IDS_PIB54MFB | Type of PiaException thrown if index is out of range in Pib54Mfb::getAt.
PIA_IDS_PIB54PIA | Type of PiaException thrown if index is out of range in Pib54Pia::getAt.
PIA_IDS_PIB58AME | Type of PiaException thrown if index is out of range in Pib58Ame::getAt.
PIA_IDS_PIB58PIB | Type of PiaException thrown if index is out of range in Pib58Pib::getAt.
PIA_IDS_PIBTABLE1 | (Currently unused.)
PIA_IDS_PIBTABLE2 | (Currently unused.)
PIA_IDS_PONSETOUT | String ID for printing second prior date of onset in nondisability case.
PIA_IDS_PRCESSOUT | String ID for printing prior date of cessation.
PIA_IDS_PRENTOUT | String ID for printing date of prior entitlement in nondisability case.
PIA_IDS_PRIOROUT | String ID for printing prior date of entitlement in disability case.
PIA_IDS_PROBASOUT | String ID for printing projected wage base type.
PIA_IDS_PROJBACK1 | Type of PiaException thrown if backward projection indicator is out of range in general case (0-2).
PIA_IDS_PROJBACK2 | Type of PiaException thrown if backward projection indicator is out of range in backward projection case (1-2).
PIA_IDS_PROJFWRD1 | Type of PiaException thrown if forward projection indicator is out of range in general case (0-2).
PIA_IDS_PROJFWRD2 | Type of PiaException thrown if forward projection indicator is out of range in forward projection case (1-2).
PIA_IDS_PRRENT1 | Type of PiaException thrown if month of prior entitlement is out of range.
PIA_IDS_PRRENT2 | Type of PiaException thrown if year of prior entitlement is before 1940.
PIA_IDS_PRRENT3 | Type of PiaException thrown if year of prior entitlement is after maximum allowed.
PIA_IDS_PRRENT4 | Type of PiaException thrown if prior entitlement is not before current entitlement.
PIA_IDS_PRRENT5 | Type of PiaException thrown if prior entitlement to disability is before disability onset.
PIA_IDS_PRRENT6 | (Currently unused.)
PIA_IDS_PRRENT7 | Type of PiaException thrown if prior entitlement to disability is after full retirement age.
PIA_IDS_PTSTRING | Type of PiaException thrown if error in PiaTable1Page::prepareStrings.
PIA_IDS_PUBPEN | Type of PiaException thrown if public pension amount is out of range.
PIA_IDS_QC | Type of PiaException thrown if number of quarters of coverage, 1951-77, is greater than number of quarters of coverage, 1937-77.
PIA_IDS_QC51TD | Type of PiaException thrown if number of quarters of coverage, 1951-77, is out of range.
PIA_IDS_QCAMT | Type of PiaException thrown if average wages have not been set in Qcamt::project.
PIA_IDS_QCANN | Type of PiaException thrown if number of annual quarters of coverage is out of range.
PIA_IDS_QCARRAY1 | Type of PiaException thrown if year is out of range in QcArray functions.
PIA_IDS_QCARRAY2 | (Currently unused).
PIA_IDS_QCARRAY3 | Type of PiaException thrown if years are out of range in QcArray::accumulate.
PIA_IDS_QCARRAY4 | Type of PiaException thrown if quarters are out of range in QcArray::accumulate.
PIA_IDS_QCCAL | Type of PiaException thrown if quarter of coverage amount has not been set in PiaData::qcCal.
PIA_IDS_QCDISCAL | Type of PiaException thrown if any starting or ending dates are out of range in PiaData::qcDisCal.
PIA_IDS_QCLUMPYEAR | Type of PiaException thrown if qclumpyear is out of range.
PIA_IDS_QCPACKED1 | Type of PiaException thrown if index is out of range in QcPacked::get.
PIA_IDS_QCPACKED2 | Type of PiaException thrown if index is out of range in QcPacked::set.
PIA_IDS_QCTD | Type of PiaException thrown if number of quarters of coverage, 1937-77, is out of range.
PIA_IDS_QCTOT0 | Type of PiaException thrown if no quarters of coverage in a totalization case.
PIA_IDS_QTRYRQTR | Type of PiaException thrown if number of quarters in a QtrYear is greater than 3.
PIA_IDS_QTRYRYR | Type of PiaException thrown if year in a QtrYear is greater than LASTYEARLR.
PIA_IDS_READEOF | Return value from PiaRead::read if successful read, with end of file following.
PIA_IDS_READERR | Type of PiaException thrown if unable to read a pia file.
PIA_IDS_READMORE | Return value from PiaRead::read if successful read, with additional data following.
PIA_IDS_RELERNOUT | String ID for printing relative earnings level.
PIA_IDS_RELERNPOS | Type of PiaException thrown if first year is out of range in PiaCal::relEarnPositionCal.
PIA_IDS_REQQCOUT | String ID for printing required quarters of coverage.
PIA_IDS_REVIEWBI | (Currently unused.)
PIA_IDS_ROUND | Type of PiaException thrown if year is before 1937 in BenefitAmount functions.
PIA_IDS_RTGENRL | Type of PiaException thrown if denominator is out of range in RtGeneral::project1.
PIA_IDS_RWSTRING | Type of PiaException thrown if error in ReindWid1Page::prepareStrings.
PIA_IDS_SECONDARY | Type of PiaException thrown if type of bic is not set in Secondary::check.
PIA_IDS_SETNOCH | Type of PiaException thrown if year is out of range in PiaParams::setNoChange.
PIA_IDS_SEX | Type of PiaException thrown if sex is not Sex::sex_type::MALE or Sex::sex_type::FEMALE.
PIA_IDS_SEXOUT | String ID for printing sex of worker.
PIA_IDS_SGAPROJ | Type of PiaException thrown if annual Sga project function is called.
PIA_IDS_SMSTRING | Type of PiaException thrown if error in SpecMin1Page::prepareStrings.
PIA_IDS_SPPIA1OUT | String ID for printing special minimum PIA, support PIA unused.
PIA_IDS_SPPIA2OUT | String ID for printing special minimum PIA, support PIA used.
PIA_IDS_SPYRS2OUT | String ID for printing total special minimum years of coverage.
PIA_IDS_SPYRSOUT | String ID for printing total special minimum years of coverage.
PIA_IDS_SSN1 | Type of PiaException thrown if number of characters in a string used to construct an Ssn is less than 9.
PIA_IDS_SSNOUT | String ID for printing worker's Social Security number.
PIA_IDS_START1 | Type of PiaException thrown if starting year of assumptions is before 1979.
PIA_IDS_START2 | Type of PiaException thrown if starting year of assumptions is after maximum year allowed.
PIA_IDS_SUPPIAOUT | String ID for printing support PIA.
PIA_IDS_SURVBENOUT | String ID for printing secondary date of benefit.
PIA_IDS_SURVENTOUT | String ID for printing secondary date of entitlement.
PIA_IDS_TAXTYPE | Type of PiaException thrown if type of taxes is out of range.
PIA_IDS_TAXTYPEYR | Type of PiaException thrown if year is out of range in WorkerData::setTaxType.
PIA_IDS_TGSTRING | Type of PiaException thrown if error in TransGuar1Page::prepareStrings.
PIA_IDS_TITLEPRO1 | (Currently unused.)
PIA_IDS_TITLEPRO2 | (Currently unused.)
PIA_IDS_TITLEPRO3 | (Currently unused.)
PIA_IDS_TITLEPRO4 | (Currently unused).
PIA_IDS_TWOPAGE1 | Type of PiaException thrown if error in InsuredPage::prepareStrings.
PIA_IDS_TWOPAGE2 | Type of PiaException thrown if error in EarningsPage::prepareStrings.
PIA_IDS_TWOPAGE3 | Type of PiaException thrown if error in Summary1Page::prepareStrings.
PIA_IDS_TWOPAGE4 | Type of PiaException thrown if error in Summary2Page::prepareStrings.
PIA_IDS_TWOPAGE5 | Type of PiaException thrown if error in Summary3Page::prepareStrings.
PIA_IDS_TXSTRING | Type of PiaException thrown if error in TaxesPage::prepareStrings.
PIA_IDS_UNBICCHP | Type of PiaException thrown if either year is out of range in PiaParams::unbiCatchUp.
PIA_IDS_UNEARNOUT | String ID for printing unused earnings message.
PIA_IDS_UPDATEAW | (Currently unused.)
PIA_IDS_UPDATEBI | (Currently unused.)
PIA_IDS_UPDATEFQ | Type of PiaException thrown if average wage is zero in PiaParams::updateFq.
PIA_IDS_UPDATEWB | (Currently unused.)
PIA_IDS_UPDATEWBOLD | (Currently unused.)
PIA_IDS_VALDI1 | Type of PiaException thrown if number of periods of disability is not 0, 1, or 2 in a nondisability case.
PIA_IDS_VALDI2 | Type of PiaException thrown if number of periods of disability is not 1 or 2 in a disability case.
PIA_IDS_WAGEBASE | (Currently unused.)
PIA_IDS_WAITPD1 | Type of PiaException thrown if first month of waiting period is out of range.
PIA_IDS_WAITPD2 | Type of PiaException thrown if year of first month of waiting period is before 1940.
PIA_IDS_WAITPD3 | Type of PiaException thrown if year of first month of waiting period is after maximum allowed.
PIA_IDS_WAITPD4 | Type of PiaException thrown if waiting period starts before onset.
PIA_IDS_WAITPD5 | Type of PiaException thrown if entitlement is before waiting period.
PIA_IDS_WAITPD6 | Type of PiaException thrown if cessation is before waiting period.
PIA_IDS_WAITPD7 | (Currently unused.)
PIA_IDS_WIDDIBOUT | String ID for printing date of onset of widow(er).
PIA_IDS_WISTRING | Type of PiaException thrown if error in WageInd1Page::prepareStrings.
PIA_IDS_WRITEEARN | Type of PiaException thrown if first year of earnings is out of range in PiaWrite::writeEarnOasdi or PiaWriteAny::writeEarnOasdi.
PIA_IDS_YEAR | (Currently unused.)
_AFXDLL | Use the AFXDLL library, which contains MFC in a DLL.
Collapse Expand Types
Name | Description
BitAnnualData | Bit array used in BitAnnual (a std::bitset).
Collapse Expand Variables
Name | Description
MAX_BITSET_SIZE | Size to use for bit array in BitAnnual (from 1937 to 2200).
Collapse Expand Links
Legend, Topics


Classes

Classes
Classes Legend Misc Library Structures

The following table lists classes in this documentation.

Collapse Expand Classes
Name | Description
Age | Manages a year and month age stored as integers.
AnnualArrays | Functions using annual arrays.
BitAnnual | Manages an array of annual bits.
Date | Static variables and functions for classes that hold dates.
DateFormatter | Manages static functions to format and parse dates.
DateMoyr | Manages a month and year stored as unsigned integers.
Document | Manages a generic document.
DoubleAnnual | Manages an array of annual doubles.
DoubleAnnualRead | Reads a DoubleAnnual.
DoubleAnnualWrite | Writes a DoubleAnnual.
DoubleMonth | Manages an array of monthly doubles.
DoubleQuarter | Manages an array of quarterly doubles.
FloatAnnual | Manages an array of annual floats.
FloatMonth | Manages an array of monthly floats.
FloatQuarter | Manages an array of quarterly floats.
Genfile | Manages a generic file.
IntAnnual | Manages an array of annual integers.
Out132 | An Outfile tailored for 132-column output.
Out80 | An Outfile tailored for 80-column output.
OutDC80 | Handles output to a Windows window.
OutFile132 | Manages the print output functions, when printing to a file formatted for 132 columns.
OutFile80 | Manages the print output functions, when printing to a file formatted for 80 columns.
OutFileHTML | Manages the print output functions, when printing to an HTML file.
Outfile | Abstract parent of classes to manage an output file in runstreams with multiple programs.
PageCounters | Manages a vector of page counters.
PageOut | Abstract parent of classes to manage a page of printed output.
Path | Provides operations on string instances that contain file or directory path information.
PiaException | Manages an exception in the piadata library.
QtrYear | Manages a year and quarter stored as unsigned integers.
Sex | Indicator for sex type.
Ssn | Manages a Social Security number string, and the 3 parts of an ssn separately as strings.
TextWriterTraceListener | An output-stream-based class that listens for Trace output.
Trace | Controls the logfiles used to trace execution of code.
TraceListener | The parent of classes that listen for Trace output.
Collapse Expand Module

Misc Library

Collapse Expand Structures
Name | Description
PunctFacet | Numeric punctuation facet with 3 digits per thousands separator.
Collapse Expand Links
Classes, Legend, Misc Library, Structures


Age Class

Age Class
Age Constructor Age Methods Age Operators Age Friends Age Members age.h Classes

Manages a year and month age stored as integers.

Collapse Expand Class Hierarchy
  Age
C++
class Age;
Collapse Expand File

File: age.h

Module: Misc Library

Collapse Expand Remarks

The year and month are stored as 16-bit unsigned shorts to save space.

Collapse Expand Group

Classes

Collapse Expand Links
Age Constructor, Age Methods, Age Operators, Age Friends, Age Members, age.h, Classes


Age Members

Age Members
Age Class Legend Public Friends Public Methods

The following tables list the members exposed by Age.

Collapse Expand Class

Age Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Name | Description
Age | Initializes an Age, either as default or from an existing Age instance or integers.
deleteContents | Zeroes years and months.
getMonths | Returns months of age.
getYears | Returns years of age.
monthsCheck | Checks for months in bounds.
toMonths | Returns the age converted to months.
toString | Returns string with age as years and months.
~Age | Destructor.
Collapse Expand Public Operators
Name | Description
- | Calculates a number of months by subtracting argument age from this one.
< | Compares (years,months) ages.
= | Copies from another Age.
== | Compares (years,months) ages for equality.
Collapse Expand Links
Age Class, Legend, Public Friends, Public Methods


Age Constructor

Age Constructor
Age Class

Initializes an Age, either as default or from an existing Age instance or integers.

Collapse Expand Description

There are four constructors for the Age class. The years and months of age can be set to default values (0), values from an existing Age instance, values from an array of integers, or values from two separate integers.

Collapse Expand Overload List
Name | Description
Age::Age () | Initializes age years and months to zero.
Age::Age (const Age&) | Copies age from another Age.
Age::Age (unsigned) | Initializes age years and months from data in an array.
Age::Age (unsigned, unsigned) | Initializes age years and months from two integers.
Collapse Expand Class

Age Class

Collapse Expand Links
Age Class


Age::Age Constructor ()

Age::Age Constructor ()
Age Class Age Members Age Constructor

Initializes age years and months to zero.

C++
Age();
Collapse Expand Remarks

All versions of the constructor initialize the years and months of age.

Collapse Expand Group

Age Constructor

Collapse Expand Links
Age Class, Age Members, Age Constructor


Age::Age Constructor (const Age&)

Age::Age Constructor (const Age&)
Age Class Age Members Age Constructor

Copies age from another Age.

C++
Age(
    const Age& newAge
);
Collapse Expand Parameters
Parameters | Description
const Age& newAge | The age to copy from.
Collapse Expand Group

Age Constructor

Collapse Expand Links
Age Class, Age Members, Age Constructor


Age::Age Constructor (unsigned)

Age::Age Constructor (unsigned)
Age Class Age Members Age Constructor

Initializes age years and months from data in an array.

C++
Age(
    unsigned newYrMo[2]
);
Collapse Expand Parameters
Parameters | Description
unsigned newYrMo[2] | The years and months in an array.
Collapse Expand Group

Age Constructor

Collapse Expand Links
Age Class, Age Members, Age Constructor


Age::Age Constructor (unsigned, unsigned)

Age::Age Constructor (unsigned, unsigned)
Age Class Age Members Age Constructor

Initializes age years and months from two integers.

C++
Age(
    unsigned newYears,
    unsigned newMonths
);
Collapse Expand Parameters
Parameters | Description
unsigned newYears | The years of age.
unsigned newMonths | The months of age.
Collapse Expand Group

Age Constructor

Collapse Expand Links
Age Class, Age Members, Age Constructor


Age::~Age Destructor

Age::~Age Destructor
Age Class Age Members Age Class

Destructor.

C++
~Age();
Collapse Expand Remarks

Does nothing.

Collapse Expand Class

Age Class

Collapse Expand Links
Age Class, Age Members, Age Class


Age Methods

Age Methods
Age Class Legend Public Methods

The methods of the Age class are listed here.

Collapse Expand Class

Age Class

Collapse Expand Public Methods
Name | Description
deleteContents | Zeroes years and months.
getMonths | Returns months of age.
getYears | Returns years of age.
monthsCheck | Checks for months in bounds.
toMonths | Returns the age converted to months.
toString | Returns string with age as years and months.
Collapse Expand Links
Age Class, Legend, Public Methods


Age::deleteContents Method

Age::deleteContents Method
Age Class Age Members Age Methods

Zeroes years and months.

C++
void deleteContents();
Collapse Expand Group

Age Methods

Collapse Expand Links
Age Class, Age Members, Age Methods


Age::getMonths Method

Age::getMonths Method
Age Class Age Members Age Methods

Returns months of age.

C++
unsigned getMonths() const;
Collapse Expand Returns

Number of months of age (0-11).

Collapse Expand Group

Age Methods

Collapse Expand Links
Age Class, Age Members, Age Methods


Age::getYears Method

Age::getYears Method
Age Class Age Members Age Methods

Returns years of age.

C++
unsigned getYears() const;
Collapse Expand Returns

Number of years of age.

Collapse Expand Group

Age Methods

Collapse Expand Links
Age Class, Age Members, Age Methods


Age::monthsCheck Method

Age::monthsCheck Method
Age Class Age Members Age Methods

Checks for months in bounds.

C++
void monthsCheck() const;
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_AGEMONTH if months is greater than 11.
Collapse Expand Group

Age Methods

Collapse Expand Links
Age Class, Age Members, Age Methods


Age::toMonths Method

Age::toMonths Method
Age Class Age Members Age Methods

Returns the age converted to months.

C++
int toMonths() const;
Collapse Expand Returns

The age converted to months.

Collapse Expand Group

Age Methods

Collapse Expand Links
Age Class, Age Members, Age Methods


toString Method

toString Method
Age Methods

Returns string with age as years and months.

Collapse Expand Description

There are two versions of this function. The one without an argument returns a string without any extra spaces. The one with a format string allows a choice of format, including one with extra spaces as required to produce a fixed-length string.

Collapse Expand Overload List
Name | Description
Age::toString () | Returns string with age as years and months.
Age::toString (const std::string&) | Returns formatted string with age as years and months, suitable for a fixed-width record.
Collapse Expand Group

Age Methods

Collapse Expand Links
Age Methods


Age::toString Method ()

Age::toString Method ()
Age Class Age Members toString Method

Returns string with age as years and months.

C++
std::string toString() const;
Collapse Expand Returns

A string such as "65 and 6 months".

Collapse Expand Group

toString Method

Collapse Expand Links
Age Class, Age Members, toString Method


Age::toString Method (const std::string&)

Age::toString Method (const std::string&)
Age Class Age Members toString Method

Returns formatted string with age as years and months, suitable for a fixed-width record.

C++
std::string toString(
    const std::string& format
) const;
Collapse Expand Parameters
Parameters | Description
const std::string& format | Format to use.
Collapse Expand Returns

A seventeen character string such as " 65 and 6 months".

Collapse Expand Remarks

If the format string begins with "f", create a fixed-width string; otherwise create a string with no extra spaces.

Collapse Expand Group

toString Method

Collapse Expand Links
Age Class, Age Members, toString Method


Age Operators

Age Operators
Age Class Legend

The operators of the Age class are listed here.

Collapse Expand Class

Age Class

Collapse Expand Public Operators
Name | Description
- | Calculates a number of months by subtracting argument age from this one.
< | Compares (years,months) ages.
= | Copies from another Age.
== | Compares (years,months) ages for equality.
Collapse Expand Links
Age Class, Legend


Age::- Operator

Age::- Operator
Age Class Age Members Age Operators

Calculates a number of months by subtracting argument age from this one.

C++
int operator -(
    const Age& newAge
) const;
Collapse Expand Parameters
Parameters | Description
const Age& newAge | The age to subtract from this one.
Collapse Expand Returns

The calculated number of months.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if argument is greater than this instance.
Collapse Expand Group

Age Operators

Collapse Expand Links
Age Class, Age Members, Age Operators


Age::< Operator

Age::< Operator
Age Class Age Members Age Operators

Compares (years,months) ages.

C++
bool operator <(
    const Age& newAge
) const;
Collapse Expand Parameters
Parameters | Description
const Age& newAge | The age to compare this one to.
Collapse Expand Returns

True if this age is less than argument, false otherwise.

Collapse Expand Group

Age Operators

Collapse Expand Links
Age Class, Age Members, Age Operators


Age::= Operator

Age::= Operator
Age Class Age Members Age Operators

Copies from another Age.

C++
Age& operator =(
    const Age& newAge
);
Collapse Expand Parameters
Parameters | Description
const Age& newAge | The Age to copy from.
Collapse Expand Returns

A reference to this Age.

Collapse Expand Group

Age Operators

Collapse Expand Links
Age Class, Age Members, Age Operators


Age::== Operator

Age::== Operator
Age Class Age Members Age Operators

Compares (years,months) ages for equality.

C++
bool operator ==(
    const Age& newAge
) const;
Collapse Expand Parameters
Parameters | Description
const Age& newAge | The age to compare this one to.
Collapse Expand Returns

True if years and months agree, false otherwise.

Collapse Expand Group

Age Operators

Collapse Expand Links
Age Class, Age Members, Age Operators


Age Friends

Age Friends
Age Class Public Friends

The friends of the Age class are listed here.

Collapse Expand Class

Age Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Links
Age Class, Public Friends


friend class boost::serialization::access Friend

friend class boost::serialization::access Friend
Age Class Age Members Age Friends

Friend class to allow serialization.

C++
friend class boost::serialization::access;
Collapse Expand Group

Age Friends

Collapse Expand Links
Age Class, Age Members, Age Friends


AnnualArrays Class

AnnualArrays Class
AnnualArrays Methods AnnualArrays Members AnnualArrays.h Classes

Functions using annual arrays.

Collapse Expand Class Hierarchy
  AnnualArrays
C++
class AnnualArrays;
Collapse Expand File

File: AnnualArrays.h

Module: Misc Library

Collapse Expand Remarks

These are used in the inttab library.

Collapse Expand Group

Classes

Collapse Expand Links
AnnualArrays Methods, AnnualArrays Members, AnnualArrays.h, Classes


AnnualArrays Members

AnnualArrays Members
AnnualArrays Class Legend Public Methods

The following tables list the members exposed by AnnualArrays.

Collapse Expand Class

AnnualArrays Class

Collapse Expand Public Methods
Name | Description
add | Adds the second DoubleAnnual to the first DoubleAnnual.
convert | Returns the DoubleAnnual converted from an IntAnnual.
divide | Divides the first DoubleAnnual by the second DoubleAnnual.
multiply | Multiplies a DoubleAnnual by a specified quantity.
subtract | Subtracts the second DoubleAnnual from the first DoubleAnnual.
Collapse Expand Links
AnnualArrays Class, Legend, Public Methods


AnnualArrays Methods

AnnualArrays Methods
AnnualArrays Class Legend Public Methods

The methods of the AnnualArrays class are listed here.

Collapse Expand Class

AnnualArrays Class

Collapse Expand Public Methods
Name | Description
add | Adds the second DoubleAnnual to the first DoubleAnnual.
convert | Returns the DoubleAnnual converted from an IntAnnual.
divide | Divides the first DoubleAnnual by the second DoubleAnnual.
multiply | Multiplies a DoubleAnnual by a specified quantity.
subtract | Subtracts the second DoubleAnnual from the first DoubleAnnual.
Collapse Expand Links
AnnualArrays Class, Legend, Public Methods


AnnualArrays::add Method

AnnualArrays::add Method
AnnualArrays Class AnnualArrays Members AnnualArrays Methods

Adds the second DoubleAnnual to the first DoubleAnnual.

C++
static void add(
    DoubleAnnual& data1,
    const DoubleAnnual& data2,
    int firstYear,
    int lastYear
);
Collapse Expand Parameters
Parameters | Description
DoubleAnnual& data1 | Array of doubles to be added to.
const DoubleAnnual& data2 | Array of doubles to add to data1.
int firstYear | First year to add.
int lastYear | Last year to add.
Collapse Expand Group

AnnualArrays Methods

Collapse Expand Links
AnnualArrays Class, AnnualArrays Members, AnnualArrays Methods


AnnualArrays::convert Method

AnnualArrays::convert Method
AnnualArrays Class AnnualArrays Members AnnualArrays Methods

Returns the DoubleAnnual converted from an IntAnnual.

C++
static DoubleAnnual convert(
    const IntAnnual& intAnnual
);
Collapse Expand Parameters
Parameters | Description
const IntAnnual& intAnnual | Array of integers to convert.
Collapse Expand Returns

The DoubleAnnual converted from an IntAnnual.

Collapse Expand Group

AnnualArrays Methods

Collapse Expand Links
AnnualArrays Class, AnnualArrays Members, AnnualArrays Methods


AnnualArrays::divide Method

AnnualArrays::divide Method
AnnualArrays Class AnnualArrays Members AnnualArrays Methods

Divides the first DoubleAnnual by the second DoubleAnnual.

C++
static void divide(
    DoubleAnnual& data1,
    const DoubleAnnual& data2,
    int firstYear,
    int lastYear
);
Collapse Expand Parameters
Parameters | Description
DoubleAnnual& data1 | Array of doubles to be divided.
const DoubleAnnual& data2 | Array of doubles to divide by.
int firstYear | First year to divide.
int lastYear | Last year to divide.
Collapse Expand Group

AnnualArrays Methods

Collapse Expand Links
AnnualArrays Class, AnnualArrays Members, AnnualArrays Methods


multiply Method

multiply Method
AnnualArrays Methods

Multiplies a DoubleAnnual by a specified quantity.

Collapse Expand Description

There are two versions of this function. The DoubleAnnual can be multiplied by a scalar or another DoubleAnnual.

Collapse Expand Overload List
Name | Description
AnnualArrays::multiply (DoubleAnnual&, const DoubleAnnual&, int, int) | Multiplies the second DoubleAnnual into the first DoubleAnnual.
AnnualArrays::multiply (DoubleAnnual&, double, int, int) | Multiplies the DoubleAnnual by a scalar.
Collapse Expand Group

AnnualArrays Methods

Collapse Expand Links
AnnualArrays Methods


AnnualArrays::multiply Method (DoubleAnnual&, const DoubleAnnual&, int, int)

AnnualArrays::multiply Method (DoubleAnnual&, const DoubleAnnual&, int, int)
AnnualArrays Class AnnualArrays Members multiply Method

Multiplies the second DoubleAnnual into the first DoubleAnnual.

C++
static void multiply(
    DoubleAnnual& data1,
    const DoubleAnnual& data2,
    int firstYear,
    int lastYear
);
Collapse Expand Parameters
Parameters | Description
DoubleAnnual& data1 | Array of doubles to be multiplied into.
const DoubleAnnual& data2 | Array of doubles to multiply into data1.
int firstYear | First year of data to multiply.
int lastYear | Last year of data to multiply.
Collapse Expand Group

multiply Method

Collapse Expand Links
AnnualArrays Class, AnnualArrays Members, multiply Method


AnnualArrays::multiply Method (DoubleAnnual&, double, int, int)

AnnualArrays::multiply Method (DoubleAnnual&, double, int, int)
AnnualArrays Class AnnualArrays Members multiply Method

Multiplies the DoubleAnnual by a scalar.

C++
static void multiply(
    DoubleAnnual& data1,
    double factor,
    int firstYear,
    int lastYear
);
Collapse Expand Parameters
Parameters | Description
DoubleAnnual& data1 | Array of doubles to be multiplied into.
double factor | The scalar multiplier. It is applied to all specified years of data.
int firstYear | First year of data to multiply.
int lastYear | Last year of data to multiply.
Collapse Expand Group

multiply Method

Collapse Expand Links
AnnualArrays Class, AnnualArrays Members, multiply Method


AnnualArrays::subtract Method

AnnualArrays::subtract Method
AnnualArrays Class AnnualArrays Members AnnualArrays Methods

Subtracts the second DoubleAnnual from the first DoubleAnnual.

C++
static void subtract(
    DoubleAnnual& data1,
    const DoubleAnnual& data2,
    int firstYear,
    int lastYear
);
Collapse Expand Parameters
Parameters | Description
DoubleAnnual& data1 | Array of doubles to be subtracted from.
const DoubleAnnual& data2 | Array of doubles to subtract from data1.
int firstYear | First year to subtract.
int lastYear | Last year to subtract.
Collapse Expand Group

AnnualArrays Methods

Collapse Expand Links
AnnualArrays Class, AnnualArrays Members, AnnualArrays Methods


BitAnnual Class

BitAnnual Class
BitAnnual Constructor BitAnnual Data Members BitAnnual Methods BitAnnual Friends BitAnnual Members BitAnnual.h Classes

Manages an array of annual bits.

Collapse Expand Class Hierarchy
  BitAnnual
C++
class BitAnnual;
Collapse Expand File

File: BitAnnual.h

Module: Misc Library

Collapse Expand Remarks

When adding functions to this class, or changing the implementation of existing functions, be careful not to use square brackets ( [] ) to access theData unless you're really sure of what you are doing. This is because there are different implementations of this class depending on whether you are using NT or Linux. Instead, use the setBit and getBit functions.

Collapse Expand Group

Classes

Collapse Expand Links
BitAnnual Constructor, BitAnnual Data Members, BitAnnual Methods, BitAnnual Friends, BitAnnual Members, BitAnnual.h, Classes


BitAnnual Members

BitAnnual Members
BitAnnual Class Legend Protected Data Members Public Friends Public Methods

The following tables list the members exposed by BitAnnual.

Collapse Expand Class

BitAnnual Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
lastYear | Last year of data.
theData | Bit array.
Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Allows serialization of this class.
Collapse Expand Public Methods
Name | Description
BitAnnual | Initializes a BitAnnual, either with specified years or with data from another BitAnnual.
any | Returns true if at least one bit is set, false otherwise.
assign | Sets data from another BitAnnual for specified years.
deleteContents | Zeroes out all data values.
getBaseYear | Returns base year.
getBit | Returns one constant value of data.
getLastYear | Returns last year.
setBit | Sets one value of data.
~BitAnnual | Deletes allocated memory.
Collapse Expand Links
BitAnnual Class, Legend, Protected Data Members, Public Friends, Public Methods


BitAnnual Constructor

BitAnnual Constructor
BitAnnual Class

Initializes a BitAnnual, either with specified years or with data from another BitAnnual.

Collapse Expand Description

There are two constructors for the BitAnnual class. The first and last years can be set via arguments, in which case all data values are set to false. Or the first and last years can be set from another BitAnnual, in which case all data values are set from that same BitAnnual.

Collapse Expand Overload List
Name | Description
BitAnnual::BitAnnual (const BitAnnual&) | Copies all values from the BitAnnual argument to this instance.
BitAnnual::BitAnnual (int, int) | Initializes the first and last years and sets all data values to false.
Collapse Expand Class

BitAnnual Class

Collapse Expand Links
BitAnnual Class


BitAnnual::BitAnnual Constructor (const BitAnnual&)

BitAnnual::BitAnnual Constructor (const BitAnnual&)
BitAnnual Class BitAnnual Members BitAnnual Constructor

Copies all values from the BitAnnual argument to this instance.

C++
BitAnnual(
    const BitAnnual& bitAnnual
);
Collapse Expand Parameters
Parameters | Description
const BitAnnual& bitAnnual | The BitAnnual to copy from.
Collapse Expand Remarks

On the linux system, data is a vector of BitPacked's -- so the constructor needs to know how many to create. On other systems (which conform to the standard and have a std::bitset class built in), data is a std::bitset and doesn't need parameters because the default constructor initializes all of the bits to zero.

Collapse Expand Group

BitAnnual Constructor

Collapse Expand Links
BitAnnual Class, BitAnnual Members, BitAnnual Constructor


BitAnnual::BitAnnual Constructor (int, int)

BitAnnual::BitAnnual Constructor (int, int)
BitAnnual Class BitAnnual Members BitAnnual Constructor

Initializes the first and last years and sets all data values to false.

C++
BitAnnual(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | New base year.
int newLastYear | New last year.
Collapse Expand Remarks

On the linux system, data is a vector of BitPacked's -- so the constructor needs to know how many to create. On other systems (which conform to the standard and have a std::bitset class built in), data is a std::bitset and doesn't need parameters because the default constructor initializes all of the bits to zero.

Collapse Expand Group

BitAnnual Constructor

Collapse Expand Links
BitAnnual Class, BitAnnual Members, BitAnnual Constructor


BitAnnual::~BitAnnual Destructor

BitAnnual::~BitAnnual Destructor
BitAnnual Class BitAnnual Members BitAnnual Class

Deletes allocated memory.

C++
virtual ~BitAnnual();
Collapse Expand Class

BitAnnual Class

Collapse Expand Links
BitAnnual Class, BitAnnual Members, BitAnnual Class


BitAnnual Data Members

BitAnnual Data Members
BitAnnual Class Legend Protected Data Members

The data members of the BitAnnual class are listed here.

Collapse Expand Class

BitAnnual Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
lastYear | Last year of data.
theData | Bit array.
Collapse Expand Links
BitAnnual Class, Legend, Protected Data Members


BitAnnual::baseYear Data Member

BitAnnual::baseYear Data Member
BitAnnual Class BitAnnual Members BitAnnual Data Members

Base year of data.

C++
int baseYear;
Collapse Expand Group

BitAnnual Data Members

Collapse Expand Links
BitAnnual Class, BitAnnual Members, BitAnnual Data Members


BitAnnual::lastYear Data Member

BitAnnual::lastYear Data Member
BitAnnual Class BitAnnual Members BitAnnual Data Members

Last year of data.

C++
int lastYear;
Collapse Expand Group

BitAnnual Data Members

Collapse Expand Links
BitAnnual Class, BitAnnual Members, BitAnnual Data Members


BitAnnual::theData Data Member

BitAnnual::theData Data Member
BitAnnual Class BitAnnual Members BitAnnual Data Members

Bit array.

C++
BitAnnualData theData;
Collapse Expand Group

BitAnnual Data Members

Collapse Expand Links
BitAnnual Class, BitAnnual Members, BitAnnual Data Members


BitAnnual Methods

BitAnnual Methods
BitAnnual Class Legend Public Methods

The methods of the BitAnnual class are listed here.

Collapse Expand Class

BitAnnual Class

Collapse Expand Public Methods
Name | Description
any | Returns true if at least one bit is set, false otherwise.
assign | Sets data from another BitAnnual for specified years.
deleteContents | Zeroes out all data values.
getBaseYear | Returns base year.
getBit | Returns one constant value of data.
getLastYear | Returns last year.
setBit | Sets one value of data.
Collapse Expand Links
BitAnnual Class, Legend, Public Methods


BitAnnual::any Method

BitAnnual::any Method
BitAnnual Class BitAnnual Members BitAnnual Methods

Returns true if at least one bit is set, false otherwise.

C++
bool any() const;
Collapse Expand Returns

True if at least one bit is set, false otherwise.

Collapse Expand Group

BitAnnual Methods

Collapse Expand Links
BitAnnual Class, BitAnnual Members, BitAnnual Methods


BitAnnual::assign Method

BitAnnual::assign Method
BitAnnual Class BitAnnual Members BitAnnual Methods

Sets data from another BitAnnual for specified years.

C++
void assign(
    const BitAnnual& bitAnnual,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const BitAnnual& bitAnnual | Array of new values of data.
int firstYeart | First year of data to set.
int lastYeart | Last year of data to set.
Collapse Expand Group

BitAnnual Methods

Collapse Expand Links
BitAnnual Class, BitAnnual Members, BitAnnual Methods


BitAnnual::deleteContents Method

BitAnnual::deleteContents Method
BitAnnual Class BitAnnual Members BitAnnual Methods

Zeroes out all data values.

C++
void deleteContents();
Collapse Expand Group

BitAnnual Methods

Collapse Expand Links
BitAnnual Class, BitAnnual Members, BitAnnual Methods


BitAnnual::getBaseYear Method

BitAnnual::getBaseYear Method
BitAnnual Class BitAnnual Members BitAnnual Methods

Returns base year.

C++
int getBaseYear() const;
Collapse Expand Returns

Base year.

Collapse Expand Group

BitAnnual Methods

Collapse Expand Links
BitAnnual Class, BitAnnual Members, BitAnnual Methods


BitAnnual::getBit Method

BitAnnual::getBit Method
BitAnnual Class BitAnnual Members BitAnnual Methods

Returns one constant value of data.

C++
bool getBit(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which data is desired.
Collapse Expand Returns

One constant value of data.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BITANN1 if year is out of range (only in debug mode).
Collapse Expand Group

BitAnnual Methods

Collapse Expand Links
BitAnnual Class, BitAnnual Members, BitAnnual Methods


BitAnnual::getLastYear Method

BitAnnual::getLastYear Method
BitAnnual Class BitAnnual Members BitAnnual Methods

Returns last year.

C++
int getLastYear() const;
Collapse Expand Returns

Last year.

Collapse Expand Group

BitAnnual Methods

Collapse Expand Links
BitAnnual Class, BitAnnual Members, BitAnnual Methods


BitAnnual::setBit Method

BitAnnual::setBit Method
BitAnnual Class BitAnnual Members BitAnnual Methods

Sets one value of data.

C++
void setBit(
    int year,
    int bit
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which data is to be set.
int bit | Value to set (0 for false, anything else for true).
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_BITANN1 if year is out of range (only in debug mode).
Collapse Expand Group

BitAnnual Methods

Collapse Expand Links
BitAnnual Class, BitAnnual Members, BitAnnual Methods


BitAnnual Friends

BitAnnual Friends
BitAnnual Class Public Friends

The friends of the BitAnnual class are listed here.

Collapse Expand Class

BitAnnual Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Allows serialization of this class.
Collapse Expand Links
BitAnnual Class, Public Friends


friend class boost::serialization::access Friend

friend class boost::serialization::access Friend
BitAnnual Class BitAnnual Members BitAnnual Friends

Allows serialization of this class.

C++
friend class boost::serialization::access;
Collapse Expand Group

BitAnnual Friends

Collapse Expand Links
BitAnnual Class, BitAnnual Members, BitAnnual Friends


Date Class

Date Class
Date Data Members Date Methods Date Members date.h Classes

Static variables and functions for classes that hold dates.

Collapse Expand Class Hierarchy
  Date
C++
class Date;
Collapse Expand File

File: date.h

Module: Misc Library

Collapse Expand Remarks

Static variables and functions for classes that hold dates as month, day, and year (boost::gregorian::date).

Collapse Expand Group

Classes

Collapse Expand Links
Date Data Members, Date Methods, Date Members, date.h, Classes


Date Members

Date Members
Date Class Legend Public Data Members Public Methods

The following tables list the members exposed by Date.

Collapse Expand Class

Date Class

Collapse Expand Public Data Members
Name | Description
highyear | Highest year that is acceptable (2200).
lowyear | Lowest year that is acceptable (1800).
Collapse Expand Public Methods
Name | Description
addYears | Adds years to the specified date.
monthCheck | Checks for month in bounds.
yearCheck | Checks for year in bounds.
Collapse Expand Links
Date Class, Legend, Public Data Members, Public Methods


Date Data Members

Date Data Members
Date Class Legend Public Data Members

The data members of the Date class are listed here.

Collapse Expand Class

Date Class

Collapse Expand Public Data Members
Name | Description
highyear | Highest year that is acceptable (2200).
lowyear | Lowest year that is acceptable (1800).
Collapse Expand Links
Date Class, Legend, Public Data Members


Date::highyear Data Member

Date::highyear Data Member
Date Class Date Members Date Data Members

Highest year that is acceptable (2200).

C++
unsigned highyear;
Collapse Expand Group

Date Data Members

Collapse Expand Links
Date Class, Date Members, Date Data Members


Date::lowyear Data Member

Date::lowyear Data Member
Date Class Date Members Date Data Members

Lowest year that is acceptable (1800).

C++
unsigned lowyear;
Collapse Expand Group

Date Data Members

Collapse Expand Links
Date Class, Date Members, Date Data Members


Date Methods

Date Methods
Date Class Legend Public Methods

The methods of the Date class are listed here.

Collapse Expand Class

Date Class

Collapse Expand Public Methods
Name | Description
addYears | Adds years to the specified date.
monthCheck | Checks for month in bounds.
yearCheck | Checks for year in bounds.
Collapse Expand Links
Date Class, Legend, Public Methods


Date::addYears Method

Date::addYears Method
Date Class Date Members Date Methods

Adds years to the specified date.

C++
static boost::gregorian::date addYears(
    boost::gregorian::date theDate,
    int years
);
Collapse Expand Parameters
Parameters | Description
boost::gregorian::date theDate | The date to add to.
int years | The number of years to add.
Collapse Expand Returns

The incremented date.

Collapse Expand Remarks

The years could be negative. A day of February 29 is changed to February 28 to be sure there is no leap-year problem.

Collapse Expand Group

Date Methods

Collapse Expand Links
Date Class, Date Members, Date Methods


Date::monthCheck Method

Date::monthCheck Method
Date Class Date Members Date Methods

Checks for month in bounds.

C++
static void monthCheck(
    unsigned month
);
Collapse Expand Parameters
Parameters | Description
unsigned month | Month to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DATEMONTH if bad month.
Collapse Expand Group

Date Methods

Collapse Expand Links
Date Class, Date Members, Date Methods


Date::yearCheck Method

Date::yearCheck Method
Date Class Date Members Date Methods

Checks for year in bounds.

C++
static void yearCheck(
    unsigned year
);
Collapse Expand Parameters
Parameters | Description
unsigned year | Year to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DATEYEAR if bad year.
Collapse Expand Group

Date Methods

Collapse Expand Links
Date Class, Date Members, Date Methods


DateFormatter Class

DateFormatter Class
DateFormatter Methods DateFormatter Members DateFormatter.h Classes

Manages static functions to format and parse dates.

Collapse Expand Class Hierarchy
  DateFormatter
C++
class DateFormatter;
Collapse Expand File

File: DateFormatter.h

Module: Misc Library

Collapse Expand Remarks

The dates can be of type boost::gregorian::date for month, day, and year, or DateMoyr for month and year.

Collapse Expand See Also

DateMoyr

Collapse Expand Group

Classes

Collapse Expand Links
DateFormatter Methods, DateFormatter Members, DateFormatter.h, Classes


DateFormatter Members

DateFormatter Members
DateFormatter Class Legend Public Methods

The following tables list the members exposed by DateFormatter.

Collapse Expand Class

DateFormatter Class

Collapse Expand Public Methods
Name | Description
date_from_undelimited_us_string | Parses a date from an undelimited date string where the order is month (2 digits), day (2 digits), and year (4 digits).
month_year_from_undelimited_us_string | Parses a month and year date from an undelimited date string where the order is month (2 digits) and year (4 digits).
toString | Returns a string with a formatted date.
Collapse Expand Links
DateFormatter Class, Legend, Public Methods


DateFormatter Methods

DateFormatter Methods
DateFormatter Class Legend Public Methods

The methods of the DateFormatter class are listed here.

Collapse Expand Class

DateFormatter Class

Collapse Expand Public Methods
Name | Description
date_from_undelimited_us_string | Parses a date from an undelimited date string where the order is month (2 digits), day (2 digits), and year (4 digits).
month_year_from_undelimited_us_string | Parses a month and year date from an undelimited date string where the order is month (2 digits) and year (4 digits).
toString | Returns a string with a formatted date.
Collapse Expand Links
DateFormatter Class, Legend, Public Methods


DateFormatter::date_from_undelimited_us_string Method

DateFormatter::date_from_undelimited_us_string Method
DateFormatter Class DateFormatter Members DateFormatter Methods

Parses a date from an undelimited date string where the order is month (2 digits), day (2 digits), and year (4 digits).

C++
static boost::gregorian::date date_from_undelimited_us_string(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Returns

The date parsed from the date string.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DATEDAY if bad day; of type PIA_IDS_DATEMONTH if bad month; of type PIA_IDS_DATEYEAR if bad year; of type PIA_IDS_READERR if fewer than 8 characters.
Collapse Expand Group

DateFormatter Methods

Collapse Expand Links
DateFormatter Class, DateFormatter Members, DateFormatter Methods


DateFormatter::month_year_from_undelimited_us_string Method

DateFormatter::month_year_from_undelimited_us_string Method
DateFormatter Class DateFormatter Members DateFormatter Methods

Parses a month and year date from an undelimited date string where the order is month (2 digits) and year (4 digits).

C++
static DateMoyr month_year_from_undelimited_us_string(
    const std::string& line
);
Collapse Expand Parameters
Parameters | Description
const std::string& line | Line to parse.
Collapse Expand Returns

The month and year date parsed from the date string.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DATEMONTH if bad month; of type PIA_IDS_DATEYEAR if bad year; of type PIA_IDS_READERR if fewer than 6 characters.
Collapse Expand Group

DateFormatter Methods

Collapse Expand Links
DateFormatter Class, DateFormatter Members, DateFormatter Methods


toString Method

toString Method
DateFormatter Methods

Returns a string with a formatted date.

Collapse Expand Description

There are four static variations of the toString function. The first argument can be a DateMoyr (a date with a month and year) or a boost::gregorian::date (a date with a month, day, and year). Each of those functions can have a second argument specifying the format to use. If the second argument is not present, the default format is used.

Collapse Expand Overload List
Name | Description
DateFormatter::toString (const DateMoyr&) | Returns string with formatted date using format "month year".
DateFormatter::toString (const DateMoyr&, const std::string&) | Returns string with formatted date using specified format.
DateFormatter::toString (const boost::gregorian::date&) | Returns string with formatted date using format "month day, year".
DateFormatter::toString (const boost::gregorian::date&, const std::string&) | Returns string with formatted date using specified format.
Collapse Expand Group

DateFormatter Methods

Collapse Expand Links
DateFormatter Methods


DateFormatter::toString Method (const DateMoyr&)

DateFormatter::toString Method (const DateMoyr&)
DateFormatter Class DateFormatter Members toString Method

Returns string with formatted date using format "month year".

C++
static std::string toString(
    const DateMoyr& dateMoyr
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The month and year date to format.
Collapse Expand Returns

A string with date using format "month year".

Collapse Expand Group

toString Method

Collapse Expand Links
DateFormatter Class, DateFormatter Members, toString Method


DateFormatter::toString Method (const DateMoyr&, const std::string&)

DateFormatter::toString Method (const DateMoyr&, const std::string&)
DateFormatter Class DateFormatter Members toString Method

Returns string with formatted date using specified format.

C++
static std::string toString(
    const DateMoyr& dateMoyr,
    const std::string& formatMoyr
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The month and year date to format.
const std::string& formatMoyr | Format to use for month and year dates. Use "s" to format as "mo/year", with leading 0 if necessary. Use "n" to format as "moyear", with leading 0 if necessary. Any other format will result in a format of "month year".
Collapse Expand Returns

A string with date using specified format.

Collapse Expand Group

toString Method

Collapse Expand Links
DateFormatter Class, DateFormatter Members, toString Method


DateFormatter::toString Method (const boost::gregorian::date&)

DateFormatter::toString Method (const boost::gregorian::date&)
DateFormatter Class DateFormatter Members toString Method

Returns string with formatted date using format "month day, year".

C++
static std::string toString(
    const boost::gregorian::date& dateModyyr
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& dateModyyr | The month, day, and year date to format.
Collapse Expand Returns

A string with date using format "month day, year".

Collapse Expand Group

toString Method

Collapse Expand Links
DateFormatter Class, DateFormatter Members, toString Method


DateFormatter::toString Method (const boost::gregorian::date&, const std::string&)

DateFormatter::toString Method (const boost::gregorian::date&, const std::string&)
DateFormatter Class DateFormatter Members toString Method

Returns string with formatted date using specified format.

C++
static std::string toString(
    const boost::gregorian::date& dateModyyr,
    const std::string& formatModyyr
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& dateModyyr | The month, day, and year date to format.
const std::string& formatModyyr | Format to use for month, day, and year dates. Use "s" to format as "mo/dy/year", with leading 0's if necessary. Use "n" to format as "modyyear", with leading 0's if necessary. Any other format will result in a format of "month day, year".
Collapse Expand Returns

A string with date using specified format.

Collapse Expand Group

toString Method

Collapse Expand Links
DateFormatter Class, DateFormatter Members, toString Method


DateMoyr Class

DateMoyr Class
DateMoyr Constructor DateMoyr Methods DateMoyr Operators DateMoyr Friends DateMoyr Members datemoyr.h Classes

Manages a month and year stored as unsigned integers.

Collapse Expand Class Hierarchy
  DateMoyr
C++
class DateMoyr;
Collapse Expand File

File: datemoyr.h

Module: Misc Library

Collapse Expand Remarks

The two data fields are stored as unsigned shorts to save space. The month is 1 to 12, while the year is 1 to 65000. If the date is uninitialized (tested by DateMoyr::isNotADate, the month and year are both zero.

Collapse Expand Group

Classes

Collapse Expand Links
DateMoyr Constructor, DateMoyr Methods, DateMoyr Operators, DateMoyr Friends, DateMoyr Members, datemoyr.h, Classes


DateMoyr Members

DateMoyr Members
DateMoyr Class Legend Public Friends Public Methods

The following tables list the members exposed by DateMoyr.

Collapse Expand Class

DateMoyr Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Name | Description
DateMoyr | Initializes a DateMoyr from a variety of dates or a string.
check | Checks for valid month and year.
deleteContents | Zeroes month and year.
getMonth | Returns month of year.
getMonthBefore | Returns the date that is the month before this date.
getMonths | Returns number of months from this date to given date.
getYear | Returns the year.
index | Returns index of the month and year, based on January 1971 being 0.
isNotADate | Returns true if the default values of 0 for the year and month are present, which shows that it has never been set.
monthCheck | Checks for month in bounds.
~DateMoyr | Destroys date.
Collapse Expand Public Operators
Name | Description
+ | Calculates a date by adding an Age.
- | Calculates an Age by subtracting argument date from this one.
< | Compares this date to another one.
= | Sets the month and year from a date.
== | Compares this date to another one.
Collapse Expand Links
DateMoyr Class, Legend, Public Friends, Public Methods


DateMoyr Constructor

DateMoyr Constructor
DateMoyr Class

Initializes a DateMoyr from a variety of dates or a string.

Collapse Expand Description

There are five constructors for the DateMoyr class. The month and year of the date can be set to default values, values from an existing boost::gregorian::date (a date with month, day, and year) or DateMoyr, values parsed from a string, or values from two separate integers.

Collapse Expand Overload List
Name | Description
DateMoyr::DateMoyr () | Initializes the month and year to zero.
DateMoyr::DateMoyr (const DateMoyr&) | Initializes the month and year from another DateMoyr.
DateMoyr::DateMoyr (const boost::gregorian::date&) | Initializes the month and year from a boost::gregorian::date.
DateMoyr::DateMoyr (const std::string&) | Initializes the month and year by parsing a date string (as mo/year).
DateMoyr::DateMoyr (unsigned, unsigned) | Initializes the month and year from specified values.
Collapse Expand Class

DateMoyr Class

Collapse Expand Links
DateMoyr Class


DateMoyr::DateMoyr Constructor ()

DateMoyr::DateMoyr Constructor ()
DateMoyr Class DateMoyr Members DateMoyr Constructor

Initializes the month and year to zero.

C++
DateMoyr();
Collapse Expand Group

DateMoyr Constructor

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Constructor


DateMoyr::DateMoyr Constructor (const DateMoyr&)

DateMoyr::DateMoyr Constructor (const DateMoyr&)
DateMoyr Class DateMoyr Members DateMoyr Constructor

Initializes the month and year from another DateMoyr.

C++
DateMoyr(
    const DateMoyr& dateMoyr
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The date to copy from (month and year).
Collapse Expand Group

DateMoyr Constructor

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Constructor


DateMoyr::DateMoyr Constructor (const boost::gregorian::date&)

DateMoyr::DateMoyr Constructor (const boost::gregorian::date&)
DateMoyr Class DateMoyr Members DateMoyr Constructor

Initializes the month and year from a boost::gregorian::date.

C++
DateMoyr(
    const boost::gregorian::date& dateModyyr
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& dateModyyr | The date to copy from (month, day, and year).
Collapse Expand Group

DateMoyr Constructor

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Constructor


DateMoyr::DateMoyr Constructor (const std::string&)

DateMoyr::DateMoyr Constructor (const std::string&)
DateMoyr Class DateMoyr Members DateMoyr Constructor

Initializes the month and year by parsing a date string (as mo/year).

C++
DateMoyr(
    const std::string& dateTemp
);
Collapse Expand Parameters
Parameters | Description
const std::string& dateTemp | The date string to parse (as mo/year).
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DATEREAD if unable to set month and year, or if they have invalid values.
Collapse Expand Group

DateMoyr Constructor

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Constructor


DateMoyr::DateMoyr Constructor (unsigned, unsigned)

DateMoyr::DateMoyr Constructor (unsigned, unsigned)
DateMoyr Class DateMoyr Members DateMoyr Constructor

Initializes the month and year from specified values.

C++
DateMoyr(
    unsigned newMonth,
    unsigned newYear
);
Collapse Expand Parameters
Parameters | Description
unsigned newMonth | New month of year (1-12).
unsigned newYear | New year.
Collapse Expand Group

DateMoyr Constructor

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Constructor


DateMoyr::~DateMoyr Destructor

DateMoyr::~DateMoyr Destructor
DateMoyr Class DateMoyr Members DateMoyr Class

Destroys date.

C++
~DateMoyr();
Collapse Expand Class

DateMoyr Class

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Class


DateMoyr Methods

DateMoyr Methods
DateMoyr Class Legend Public Methods

The methods of the DateMoyr class are listed here.

Collapse Expand Class

DateMoyr Class

Collapse Expand Public Methods
Name | Description
check | Checks for valid month and year.
deleteContents | Zeroes month and year.
getMonth | Returns month of year.
getMonthBefore | Returns the date that is the month before this date.
getMonths | Returns number of months from this date to given date.
getYear | Returns the year.
index | Returns index of the month and year, based on January 1971 being 0.
isNotADate | Returns true if the default values of 0 for the year and month are present, which shows that it has never been set.
monthCheck | Checks for month in bounds.
Collapse Expand Links
DateMoyr Class, Legend, Public Methods


DateMoyr::check Method

DateMoyr::check Method
DateMoyr Class DateMoyr Members DateMoyr Methods

Checks for valid month and year.

C++
void check() const;
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DATEMONTH or PIA_IDS_DATEYEAR if bad month or year.
Collapse Expand Group

DateMoyr Methods

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Methods


DateMoyr::deleteContents Method

DateMoyr::deleteContents Method
DateMoyr Class DateMoyr Members DateMoyr Methods

Zeroes month and year.

C++
void deleteContents();
Collapse Expand Group

DateMoyr Methods

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Methods


DateMoyr::getMonth Method

DateMoyr::getMonth Method
DateMoyr Class DateMoyr Members DateMoyr Methods

Returns month of year.

C++
unsigned short getMonth() const;
Collapse Expand Returns

Month of year (1-12).

Collapse Expand Group

DateMoyr Methods

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Methods


DateMoyr::getMonthBefore Method

DateMoyr::getMonthBefore Method
DateMoyr Class DateMoyr Members DateMoyr Methods

Returns the date that is the month before this date.

C++
DateMoyr getMonthBefore() const;
Collapse Expand Returns

The month and year that is the month before this date.

Collapse Expand Group

DateMoyr Methods

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Methods


DateMoyr::getMonths Method

DateMoyr::getMonths Method
DateMoyr Class DateMoyr Members DateMoyr Methods

Returns number of months from this date to given date.

C++
int getMonths(
    const DateMoyr& dateMoyr
) const;
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | Given date.
Collapse Expand Returns

Number of months from this date to given date. Result is negative if argument date is before this date.

Collapse Expand Group

DateMoyr Methods

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Methods


DateMoyr::getYear Method

DateMoyr::getYear Method
DateMoyr Class DateMoyr Members DateMoyr Methods

Returns the year.

C++
unsigned getYear() const;
Collapse Expand Returns

The year.

Collapse Expand Group

DateMoyr Methods

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Methods


DateMoyr::index Method

DateMoyr::index Method
DateMoyr Class DateMoyr Members DateMoyr Methods

Returns index of the month and year, based on January 1971 being 0.

C++
int index() const;
Collapse Expand Returns

Index of the month and year, based on January 1971 being 0.

Collapse Expand Group

DateMoyr Methods

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Methods


DateMoyr::isNotADate Method

DateMoyr::isNotADate Method
DateMoyr Class DateMoyr Members DateMoyr Methods

Returns true if the default values of 0 for the year and month are present, which shows that it has never been set.

C++
bool isNotADate() const;
Collapse Expand Returns

A bool that says whether the default (invalid) values are present.

Collapse Expand Group

DateMoyr Methods

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Methods


DateMoyr::monthCheck Method

DateMoyr::monthCheck Method
DateMoyr Class DateMoyr Members DateMoyr Methods

Checks for month in bounds.

C++
void monthCheck() const;
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DATEMONTH if month is out of range.
Collapse Expand Group

DateMoyr Methods

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Methods


DateMoyr Operators

DateMoyr Operators
DateMoyr Class Legend

The operators of the DateMoyr class are listed here.

Collapse Expand Class

DateMoyr Class

Collapse Expand Public Operators
Name | Description
+ | Calculates a date by adding an Age.
- | Calculates an Age by subtracting argument date from this one.
< | Compares this date to another one.
= | Sets the month and year from a date.
== | Compares this date to another one.
Collapse Expand Links
DateMoyr Class, Legend


DateMoyr::+ Operator

DateMoyr::+ Operator
DateMoyr Class DateMoyr Members DateMoyr Operators

Calculates a date by adding an Age.

C++
DateMoyr operator +(
    const Age& age
) const;
Collapse Expand Parameters
Parameters | Description
const Age& age | The Age to add to this date.
Collapse Expand Returns

The instance date plus the argument age.

Collapse Expand Group

DateMoyr Operators

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Operators


DateMoyr::- Operator

DateMoyr::- Operator
DateMoyr Class DateMoyr Members DateMoyr Operators

Calculates an Age by subtracting argument date from this one.

C++
Age operator -(
    const DateMoyr& dateMoyr
) const;
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The date to subtract from this instance.
Collapse Expand Returns

The calculated Age.

Collapse Expand Remarks

This would typically be used when this instance is the date of entitlement to a benefit and the argument is the date of birth.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if argument is greater than this instance.
Collapse Expand Group

DateMoyr Operators

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Operators


DateMoyr::< Operator

DateMoyr::< Operator
DateMoyr Class DateMoyr Members DateMoyr Operators

Compares this date to another one.

C++
bool operator <(
    const DateMoyr& dateMoyr
) const;
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The date to compare to.
Collapse Expand Returns

True if this date is before argument date.

Collapse Expand Group

DateMoyr Operators

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Operators


= Operator

= Operator
DateMoyr Operators

Sets the month and year from a date.

Collapse Expand Description

There are two versions of operator= method. The month and year in the current instance of DateMoyr can be set from existing values in a boost::gregorian::date (month, day, and year) or another DateMoyr.

Collapse Expand Overload List
Name | Description
DateMoyr::= (const DateMoyr&) | Sets month and year from another DateMoyr.
DateMoyr::= (const boost::gregorian::date&) | Sets month and year from a boost::gregorian::date (month, day, and year).
Collapse Expand Group

DateMoyr Operators

Collapse Expand Links
DateMoyr Operators


DateMoyr::= Operator (const DateMoyr&)

DateMoyr::= Operator (const DateMoyr&)
DateMoyr Class DateMoyr Members = Operator

Sets month and year from another DateMoyr.

C++
DateMoyr& operator =(
    const DateMoyr& dateMoyr
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The date to copy from (month and year).
Collapse Expand Returns

A reference to this instance.

Collapse Expand Group

= Operator

Collapse Expand Links
DateMoyr Class, DateMoyr Members, = Operator


DateMoyr::= Operator (const boost::gregorian::date&)

DateMoyr::= Operator (const boost::gregorian::date&)
DateMoyr Class DateMoyr Members = Operator

Sets month and year from a boost::gregorian::date (month, day, and year).

C++
DateMoyr& operator =(
    const boost::gregorian::date& dateModyyr
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& dateModyyr | The date to copy from (month, day, and year). Ignores the day.
Collapse Expand Returns

A reference to this instance.

Collapse Expand Remarks

This version ignores the day.

Collapse Expand Group

= Operator

Collapse Expand Links
DateMoyr Class, DateMoyr Members, = Operator


DateMoyr::== Operator

DateMoyr::== Operator
DateMoyr Class DateMoyr Members DateMoyr Operators

Compares this date to another one.

C++
bool operator ==(
    const DateMoyr& dateMoyr
) const;
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The date to compare to.
Collapse Expand Returns

True if this date equals argument date.

Collapse Expand Group

DateMoyr Operators

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Operators


DateMoyr Friends

DateMoyr Friends
DateMoyr Class Public Friends

The friends of the DateMoyr class are listed here.

Collapse Expand Class

DateMoyr Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Links
DateMoyr Class, Public Friends


friend class boost::serialization::access Friend

friend class boost::serialization::access Friend
DateMoyr Class DateMoyr Members DateMoyr Friends

Friend class to allow serialization.

C++
friend class boost::serialization::access;
Collapse Expand Group

DateMoyr Friends

Collapse Expand Links
DateMoyr Class, DateMoyr Members, DateMoyr Friends


Document Class

Document Class
Document Constructor Document Methods Document Members document.h Classes

Manages a generic document.

Collapse Expand Class Hierarchy
  DocumentDocument
C++
class Document : public Genfile;
Collapse Expand File

File: document.h

Module: Misc Library

Collapse Expand Remarks

This class is meant to be a parent of a user's document.

Collapse Expand Group

Classes

Collapse Expand Links
Document Constructor, Document Methods, Document Members, document.h, Classes


Document Members

Document Members
Document Class Legend Protected Data Members Public Methods

The following tables list the members exposed by Document.

Collapse Expand Class

Document Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
pathname | Pathname of this file.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
errormesg | Returns message when error reading from file.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
readmesg | Returns message when reading from file.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
writemesg | Returns message when writing to file.
~Document | Destroys document.
Collapse Expand Links
Document Class, Legend, Protected Data Members, Public Methods


Document Constructor

Document Constructor
Document Class

Initializes a Document, either with default values or with specified parent directory and core file name.

Collapse Expand Description

There are two constructors for the Document class. The parent directory and core file name can be set to default values (an empty string), or they can be set to specified values. In both cases, the title is set to an empty string.

Collapse Expand Overload List
Name | Description
Document::Document () | Initializes the parent directory, core file name, and title to "".
Document::Document (const std::string&, const std::string&) | Initializes the parent directory and core file name to the specified arguments, and the title to "".
Collapse Expand Class

Document Class

Collapse Expand Links
Document Class


Document::Document Constructor ()

Document::Document Constructor ()
Document Class Document Members Document Constructor

Initializes the parent directory, core file name, and title to "".

C++
Document();
Collapse Expand Group

Document Constructor

Collapse Expand Links
Document Class, Document Members, Document Constructor


Document::Document Constructor (const std::string&, const std::string&)

Document::Document Constructor (const std::string&, const std::string&)
Document Class Document Members Document Constructor

Initializes the parent directory and core file name to the specified arguments, and the title to "".

C++
Document(
    const std::string& newCorename,
    const std::string& newDirectory
);
Collapse Expand Parameters
Parameters | Description
const std::string& newCorename | New core file name, before modifiers or extensions.
const std::string& newDirectory | New directory holding this document.
Collapse Expand Group

Document Constructor

Collapse Expand Links
Document Class, Document Members, Document Constructor


Document::~Document Destructor

Document::~Document Destructor
Document Class Document Members Document Class

Destroys document.

C++
virtual ~Document();
Collapse Expand Class

Document Class

Collapse Expand Links
Document Class, Document Members, Document Class


Document Methods

Document Methods
Document Class Legend Public Methods

The methods of the Document class are listed here.

Collapse Expand Class

Document Class

Collapse Expand Public Methods
Name | Description
errormesg | Returns message when error reading from file.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPathname | Returns full path name.
getTitle | Returns title of this document.
readmesg | Returns message when reading from file.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
writemesg | Returns message when writing to file.
Collapse Expand Links
Document Class, Legend, Public Methods


Document::errormesg Method

Document::errormesg Method
Document Class Document Members Document Methods

Returns message when error reading from file.

C++
std::string errormesg();
Collapse Expand Returns

Message when error reading from file.

Collapse Expand Group

Document Methods

Collapse Expand Links
Document Class, Document Members, Document Methods


Document::getCorename Method

Document::getCorename Method
Document Class Document Members Document Methods

Returns the core file name, before modifiers or extensions.

C++
std::string getCorename() const;
Collapse Expand Returns

The core file name, before modifiers or extensions.

Collapse Expand Group

Document Methods

Collapse Expand Links
Document Class, Document Members, Document Methods


Document::getModifier Method

Document::getModifier Method
Document Class Document Members Document Methods

Returns the modifier on the file name.

C++
std::string getModifier() const;
Collapse Expand Returns

The modifier on the file name.

Collapse Expand Group

Document Methods

Collapse Expand Links
Document Class, Document Members, Document Methods


Document::getPathname Method

Document::getPathname Method
Document Class Document Members Document Methods

Returns full path name.

C++
std::string getPathname() const;
Collapse Expand Returns

Full path name.

Collapse Expand Group

Document Methods

Collapse Expand Links
Document Class, Document Members, Document Methods


Document::getTitle Method

Document::getTitle Method
Document Class Document Members Document Methods

Returns title of this document.

C++
const std::string& getTitle() const;
Collapse Expand Returns

Title of this document.

Collapse Expand Group

Document Methods

Collapse Expand Links
Document Class, Document Members, Document Methods


Document::readmesg Method

Document::readmesg Method
Document Class Document Members Document Methods

Returns message when reading from file.

C++
std::string readmesg();
Collapse Expand Returns

Message when reading from file.

Collapse Expand Group

Document Methods

Collapse Expand Links
Document Class, Document Members, Document Methods


Document::setCorename Method

Document::setCorename Method
Document Class Document Members Document Methods

Sets the core part of the file name, before modifiers or extensions.

C++
void setCorename(
    const std::string& newCorename
);
Collapse Expand Parameters
Parameters | Description
const std::string& newCorename | The new core name.
Collapse Expand Remarks

Also sets the path name to the core name.

Collapse Expand Group

Document Methods

Collapse Expand Links
Document Class, Document Members, Document Methods


Document::setExtension Method

Document::setExtension Method
Document Class Document Members Document Methods

Sets the extension on the file name.

C++
void setExtension(
    const std::string& newExtension
);
Collapse Expand Parameters
Parameters | Description
const std::string& newExtension | The new file extension.
Collapse Expand Group

Document Methods

Collapse Expand Links
Document Class, Document Members, Document Methods


Document::setModifier Method

Document::setModifier Method
Document Class Document Members Document Methods

Sets the modifier on the file name.

C++
void setModifier(
    const std::string& newModifier
);
Collapse Expand Parameters
Parameters | Description
const std::string& newModifier | The new file modifier.
Collapse Expand Group

Document Methods

Collapse Expand Links
Document Class, Document Members, Document Methods


Document::setPath Method

Document::setPath Method
Document Class Document Members Document Methods

Sets the path and modifier on the file name.

C++
void setPath(
    const std::string& newPath
);
Collapse Expand Parameters
Parameters | Description
const std::string& newPath | The new path.
Collapse Expand Group

Document Methods

Collapse Expand Links
Document Class, Document Members, Document Methods


Document::setPathAndModifier Method

Document::setPathAndModifier Method
Document Class Document Members Document Methods

Sets the path and modifier on the file name.

C++
void setPathAndModifier(
    const std::string& newPath,
    const std::string& newModifier
);
Collapse Expand Parameters
Parameters | Description
const std::string& newPath | The new path.
const std::string& newModifier | The new file modifier.
Collapse Expand Group

Document Methods

Collapse Expand Links
Document Class, Document Members, Document Methods


Document::setPathname Method

Document::setPathname Method
Document Class Document Members Document Methods

Sets full path name.

C++
void setPathname(
    const std::string& newPathname
);
Collapse Expand Parameters
Parameters | Description
const std::string& newPathname | New full path name.
Collapse Expand Group

Document Methods

Collapse Expand Links
Document Class, Document Members, Document Methods


Document::setTitle Method

Document::setTitle Method
Document Class Document Members Document Methods

Sets title of this document.

C++
void setTitle(
    const std::string& newTitle
);
Collapse Expand Parameters
Parameters | Description
const std::string& newTitle | New title of this document.
Collapse Expand Group

Document Methods

Collapse Expand Links
Document Class, Document Members, Document Methods


Document::writemesg Method

Document::writemesg Method
Document Class Document Members Document Methods

Returns message when writing to file.

C++
std::string writemesg();
Collapse Expand Returns

Message when writing to file.

Collapse Expand Group

Document Methods

Collapse Expand Links
Document Class, Document Members, Document Methods


DoubleAnnual Class

DoubleAnnual Class
DoubleAnnual Data Members DoubleAnnual Methods DoubleAnnual Operators DoubleAnnual Friends DoubleAnnual Members dbleann.h Classes

Manages an array of annual doubles.

Collapse Expand Class Hierarchy
  DoubleAnnual
C++
class DoubleAnnual;
Collapse Expand File

File: dbleann.h

Module: Misc Library

Collapse Expand Remarks

See FloatAnnual and IntAnnual for similar classes that manage arrays of annual floats and integers.

Collapse Expand Group

Classes

Collapse Expand Links
DoubleAnnual Data Members, DoubleAnnual Methods, DoubleAnnual Operators, DoubleAnnual Friends, DoubleAnnual Members, dbleann.h, Classes


DoubleAnnual Members

DoubleAnnual Members
DoubleAnnual Class Legend Public Data Members Public Friends Public Methods

The following tables list the members exposed by DoubleAnnual.

Collapse Expand Class

DoubleAnnual Class

Collapse Expand Public Data Members
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Name | Description
DoubleAnnual | Constructor.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
~DoubleAnnual | Destructor.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
DoubleAnnual Class, Legend, Public Data Members, Public Friends, Public Methods


DoubleAnnual::DoubleAnnual Constructor

DoubleAnnual::DoubleAnnual Constructor
DoubleAnnual Class DoubleAnnual Members DoubleAnnual Class

Constructor.

C++
DoubleAnnual(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | New base year.
int newLastYear | New last year.
Collapse Expand Remarks

Sets the base year of data, and initializes the size of the data vector to the span of years.

Collapse Expand Class

DoubleAnnual Class

Collapse Expand Links
DoubleAnnual Class, DoubleAnnual Members, DoubleAnnual Class


DoubleAnnual::~DoubleAnnual Destructor

DoubleAnnual::~DoubleAnnual Destructor
DoubleAnnual Class DoubleAnnual Members DoubleAnnual Class

Destructor.

C++
virtual ~DoubleAnnual();
Collapse Expand Class

DoubleAnnual Class

Collapse Expand Links
DoubleAnnual Class, DoubleAnnual Members, DoubleAnnual Class


DoubleAnnual Data Members

DoubleAnnual Data Members
DoubleAnnual Class Legend Public Data Members

The data members of the DoubleAnnual class are listed here.

Collapse Expand Class

DoubleAnnual Class

Collapse Expand Public Data Members
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.
Collapse Expand Links
DoubleAnnual Class, Legend, Public Data Members


DoubleAnnual::baseYear Data Member

DoubleAnnual::baseYear Data Member
DoubleAnnual Class DoubleAnnual Members DoubleAnnual Data Members

Base year of data.

C++
const int baseYear;
Collapse Expand Group

DoubleAnnual Data Members

Collapse Expand Links
DoubleAnnual Class, DoubleAnnual Members, DoubleAnnual Data Members


DoubleAnnual::theData Data Member

DoubleAnnual::theData Data Member
DoubleAnnual Class DoubleAnnual Members DoubleAnnual Data Members

Vector of doubles.

C++
std::vector< double > theData;
Collapse Expand Group

DoubleAnnual Data Members

Collapse Expand Links
DoubleAnnual Class, DoubleAnnual Members, DoubleAnnual Data Members


DoubleAnnual Methods

DoubleAnnual Methods
DoubleAnnual Class Legend Public Methods

The methods of the DoubleAnnual class are listed here.

Collapse Expand Class

DoubleAnnual Class

Collapse Expand Public Methods
Name | Description
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
Collapse Expand Links
DoubleAnnual Class, Legend, Public Methods


DoubleAnnual::accumulate Method

DoubleAnnual::accumulate Method
DoubleAnnual Class DoubleAnnual Members DoubleAnnual Methods

Accumulates data over a range of years.

C++
double accumulate(
    int year1,
    int year2,
    double startValue
) const;
Collapse Expand Parameters
Parameters | Description
int year1 | Year with which to start accumulating (inclusive).
int year2 | Year with which to end accumulating (inclusive).
double startValue | Starting value.
Collapse Expand Returns

Total of data in the vector over the specified range.

Collapse Expand Remarks

Does not check to be sure range of years is within allowable range, unless in debug mode.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DBLEANN1 if years are out of range, if in debug mode.
Collapse Expand Group

DoubleAnnual Methods

Collapse Expand Links
DoubleAnnual Class, DoubleAnnual Members, DoubleAnnual Methods


assign Method

assign Method
DoubleAnnual Methods

Functions to assign data for a range of years.

Collapse Expand Description

There are two versions of the assign method. In both versions, the range of years is specified by two arguments. The other argument, supplying the data to be copied, can be a constant double or another DoubleAnnual.

Collapse Expand Overload List
Name | Description
DoubleAnnual::assign (const DoubleAnnual&, int, int) | Sets data for specified years from another DoubleAnnual.
DoubleAnnual::assign (double, int, int) | Sets data for specified years from one value that is constant for all years.
Collapse Expand Group

DoubleAnnual Methods

Collapse Expand Links
DoubleAnnual Methods


DoubleAnnual::assign Method (const DoubleAnnual&, int, int)

DoubleAnnual::assign Method (const DoubleAnnual&, int, int)
DoubleAnnual Class DoubleAnnual Members assign Method

Sets data for specified years from another DoubleAnnual.

C++
void assign(
    const DoubleAnnual& doubleAnnual,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& doubleAnnual | Array of new values of data.
int firstYeart | First year of data to set.
int lastYeart | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
DoubleAnnual Class, DoubleAnnual Members, assign Method


DoubleAnnual::assign Method (double, int, int)

DoubleAnnual::assign Method (double, int, int)
DoubleAnnual Class DoubleAnnual Members assign Method

Sets data for specified years from one value that is constant for all years.

C++
void assign(
    double newData,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
double newData | New value of data to be used for all specified years.
int firstYeart | First year of data to set.
int lastYeart | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
DoubleAnnual Class, DoubleAnnual Members, assign Method


DoubleAnnual::fill Method

DoubleAnnual::fill Method
DoubleAnnual Class DoubleAnnual Members DoubleAnnual Methods

Fills all data slots with the given value.

C++
void fill(
    double value
);
Collapse Expand Parameters
Parameters | Description
double value | The value to fill the data slots with.
Collapse Expand Group

DoubleAnnual Methods

Collapse Expand Links
DoubleAnnual Class, DoubleAnnual Members, DoubleAnnual Methods


DoubleAnnual::getBaseYear Method

DoubleAnnual::getBaseYear Method
DoubleAnnual Class DoubleAnnual Members DoubleAnnual Methods

Returns base year of data.

C++
int getBaseYear() const;
Collapse Expand Returns

Base year of data.

Collapse Expand Group

DoubleAnnual Methods

Collapse Expand Links
DoubleAnnual Class, DoubleAnnual Members, DoubleAnnual Methods


DoubleAnnual::getLastYear Method

DoubleAnnual::getLastYear Method
DoubleAnnual Class DoubleAnnual Members DoubleAnnual Methods

Returns last year of data.

C++
int getLastYear() const;
Collapse Expand Returns

Last year of data.

Collapse Expand Remarks

This is the base year plus the size of the data array, minus 1. Note that this is less than the base year if the size is zero.

Collapse Expand Group

DoubleAnnual Methods

Collapse Expand Links
DoubleAnnual Class, DoubleAnnual Members, DoubleAnnual Methods


DoubleAnnual Operators

DoubleAnnual Operators
DoubleAnnual Class Legend

The operators of the DoubleAnnual class are listed here.

Collapse Expand Class

DoubleAnnual Class

Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
DoubleAnnual Class, Legend


[] Operator

[] Operator
DoubleAnnual Operators

Functions to access an element of the array.

Collapse Expand Description

There are two versions of the [] operator. They differ only in that one is const and the other is not, so that they can be used in both const and non-const settings.

Collapse Expand Overload List
Name | Description
DoubleAnnual::[] (int) | Returns one value of data, not const.
DoubleAnnual::[] (int) | Returns one value of data, const.
Collapse Expand Group

DoubleAnnual Operators

Collapse Expand Links
DoubleAnnual Operators


DoubleAnnual::[] Operator (int)

DoubleAnnual::[] Operator (int)
DoubleAnnual Class DoubleAnnual Members [] Operator

Returns one value of data, not const.

C++
double& operator [](
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which data is desired.
Collapse Expand Returns

One value of data for the specified year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DBLEANN1 if year is out of range (only in debug mode).
Collapse Expand Group

[] Operator

Collapse Expand Links
DoubleAnnual Class, DoubleAnnual Members, [] Operator


DoubleAnnual::[] Operator (int)

DoubleAnnual::[] Operator (int)
DoubleAnnual Class DoubleAnnual Members [] Operator

Returns one value of data, const.

C++
const double operator [](
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which data is desired.
Collapse Expand Returns

One value of data for the specified year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DBLEANN1 if year is out of range (only in debug mode).
Collapse Expand Group

[] Operator

Collapse Expand Links
DoubleAnnual Class, DoubleAnnual Members, [] Operator


DoubleAnnual Friends

DoubleAnnual Friends
DoubleAnnual Class Public Friends

The friends of the DoubleAnnual class are listed here.

Collapse Expand Class

DoubleAnnual Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Links
DoubleAnnual Class, Public Friends


friend class boost::serialization::access Friend

friend class boost::serialization::access Friend
DoubleAnnual Class DoubleAnnual Members DoubleAnnual Friends

Friend class to allow serialization.

C++
friend class boost::serialization::access;
Collapse Expand Group

DoubleAnnual Friends

Collapse Expand Links
DoubleAnnual Class, DoubleAnnual Members, DoubleAnnual Friends


DoubleAnnualRead Class

DoubleAnnualRead Class
DoubleAnnualRead Methods DoubleAnnualRead Members DoubleAnnualRW.h Classes

Reads a DoubleAnnual.

Collapse Expand Class Hierarchy
  DoubleAnnualRead
C++
class DoubleAnnualRead;
Collapse Expand File

File: DoubleAnnualRW.h

Module: Misc Library

Collapse Expand Remarks

If necessary, we could create FloatAnnualRead and IntAnnualRead for similar classes that get FloatAnnual's and IntAnnual's.

Collapse Expand See Also

FloatAnnual, IntAnnual

Collapse Expand Group

Classes

Collapse Expand Links
DoubleAnnualRead Methods, DoubleAnnualRead Members, DoubleAnnualRW.h, Classes


DoubleAnnualRead Members

DoubleAnnualRead Members
DoubleAnnualRead Class Legend Public Methods

The following tables list the members exposed by DoubleAnnualRead.

Collapse Expand Class

DoubleAnnualRead Class

Collapse Expand Public Methods
Name | Description
DoubleAnnualRead | Constructor.
read | Reads array from an open stream.
Collapse Expand Links
DoubleAnnualRead Class, Legend, Public Methods


DoubleAnnualRead::DoubleAnnualRead Constructor

DoubleAnnualRead::DoubleAnnualRead Constructor
DoubleAnnualRead Class DoubleAnnualRead Members DoubleAnnualRead Class

Constructor.

C++
DoubleAnnualRead(
    DoubleAnnual& newData
);
Collapse Expand Parameters
Parameters | Description
DoubleAnnual& newData | Vector of doubles to get.
Collapse Expand Class

DoubleAnnualRead Class

Collapse Expand Links
DoubleAnnualRead Class, DoubleAnnualRead Members, DoubleAnnualRead Class


DoubleAnnualRead Methods

DoubleAnnualRead Methods
DoubleAnnualRead Class Legend Public Methods

The methods of the DoubleAnnualRead class are listed here.

Collapse Expand Class

DoubleAnnualRead Class

Collapse Expand Public Methods
Name | Description
read | Reads array from an open stream.
Collapse Expand Links
DoubleAnnualRead Class, Legend, Public Methods


DoubleAnnualRead::read Method

DoubleAnnualRead::read Method
DoubleAnnualRead Class DoubleAnnualRead Members DoubleAnnualRead Methods

Reads array from an open stream.

C++
void read(
    std::istream& in,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
std::istream& in | Input stream.
int firstYeart | First year to read.
int lastYeart | Last year to read.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_DBLEANN2 if unable to read specified fields.
Collapse Expand Group

DoubleAnnualRead Methods

Collapse Expand Links
DoubleAnnualRead Class, DoubleAnnualRead Members, DoubleAnnualRead Methods


DoubleAnnualWrite Class

DoubleAnnualWrite Class
DoubleAnnualWrite Methods DoubleAnnualWrite Members DoubleAnnualRW.h Classes

Writes a DoubleAnnual.

Collapse Expand Class Hierarchy
  DoubleAnnualWrite
C++
class DoubleAnnualWrite;
Collapse Expand File

File: DoubleAnnualRW.h

Module: Misc Library

Collapse Expand Remarks

If necessary, we could create FloatAnnualWrite and IntAnnualWrite for similar classes that output FloatAnnual's and IntAnnual's.

Collapse Expand See Also

FloatAnnual, IntAnnual

Collapse Expand Group

Classes

Collapse Expand Links
DoubleAnnualWrite Methods, DoubleAnnualWrite Members, DoubleAnnualRW.h, Classes


DoubleAnnualWrite Members

DoubleAnnualWrite Members
DoubleAnnualWrite Class Legend Public Methods

The following tables list the members exposed by DoubleAnnualWrite.

Collapse Expand Class

DoubleAnnualWrite Class

Collapse Expand Public Methods
Name | Description
DoubleAnnualWrite | Constructor.
getLineWidth | Returns output line width.
getPrecision | Returns precision of output field.
getWidth | Returns width of output field.
write | Writes array to an open stream.
Collapse Expand Links
DoubleAnnualWrite Class, Legend, Public Methods


DoubleAnnualWrite::DoubleAnnualWrite Constructor

DoubleAnnualWrite::DoubleAnnualWrite Constructor
DoubleAnnualWrite Class DoubleAnnualWrite Members DoubleAnnualWrite Class

Constructor.

C++
DoubleAnnualWrite(
    const DoubleAnnual& newData,
    int newWidth,
    int newPrecision,
    int newLineWidth
);
Collapse Expand Parameters
Parameters | Description
const DoubleAnnual& newData | Vector of doubles to output.
int newWidth | Width of field when writing to an output file.
int newPrecision | Number of decimal places when writing to an output file.
int newLineWidth | Width of output line when writing to an output file.
Collapse Expand Class

DoubleAnnualWrite Class

Collapse Expand Links
DoubleAnnualWrite Class, DoubleAnnualWrite Members, DoubleAnnualWrite Class


DoubleAnnualWrite Methods

DoubleAnnualWrite Methods
DoubleAnnualWrite Class Legend Public Methods

The methods of the DoubleAnnualWrite class are listed here.

Collapse Expand Class

DoubleAnnualWrite Class

Collapse Expand Public Methods
Name | Description
getLineWidth | Returns output line width.
getPrecision | Returns precision of output field.
getWidth | Returns width of output field.
write | Writes array to an open stream.
Collapse Expand Links
DoubleAnnualWrite Class, Legend, Public Methods


DoubleAnnualWrite::getLineWidth Method

DoubleAnnualWrite::getLineWidth Method
DoubleAnnualWrite Class DoubleAnnualWrite Members DoubleAnnualWrite Methods

Returns output line width.

C++
int getLineWidth() const;
Collapse Expand Returns

Output line width.

Collapse Expand Group

DoubleAnnualWrite Methods

Collapse Expand Links
DoubleAnnualWrite Class, DoubleAnnualWrite Members, DoubleAnnualWrite Methods


DoubleAnnualWrite::getPrecision Method

DoubleAnnualWrite::getPrecision Method
DoubleAnnualWrite Class DoubleAnnualWrite Members DoubleAnnualWrite Methods

Returns precision of output field.

C++
int getPrecision() const;
Collapse Expand Returns

Precision of output field.

Collapse Expand Group

DoubleAnnualWrite Methods

Collapse Expand Links
DoubleAnnualWrite Class, DoubleAnnualWrite Members, DoubleAnnualWrite Methods


DoubleAnnualWrite::getWidth Method

DoubleAnnualWrite::getWidth Method
DoubleAnnualWrite Class DoubleAnnualWrite Members DoubleAnnualWrite Methods

Returns width of output field.

C++
int getWidth() const;
Collapse Expand Returns

Width of output field.

Collapse Expand Group

DoubleAnnualWrite Methods

Collapse Expand Links
DoubleAnnualWrite Class, DoubleAnnualWrite Members, DoubleAnnualWrite Methods


DoubleAnnualWrite::write Method

DoubleAnnualWrite::write Method
DoubleAnnualWrite Class DoubleAnnualWrite Members DoubleAnnualWrite Methods

Writes array to an open stream.

C++
void write(
    std::ostream& out,
    int firstYeart,
    int lastYeart
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
int firstYeart | First year to write.
int lastYeart | Last year to write.
Collapse Expand Group

DoubleAnnualWrite Methods

Collapse Expand Links
DoubleAnnualWrite Class, DoubleAnnualWrite Members, DoubleAnnualWrite Methods


DoubleMonth Class

DoubleMonth Class
DoubleMonth Data Members DoubleMonth Methods DoubleMonth Members dblemth.h Classes

Manages an array of monthly doubles.

Collapse Expand Class Hierarchy
  DoubleMonth
C++
class DoubleMonth;
Collapse Expand File

File: dblemth.h

Module: Misc Library

Collapse Expand Remarks

Manages an array of monthly doubles.

Collapse Expand Group

Classes

Collapse Expand Links
DoubleMonth Data Members, DoubleMonth Methods, DoubleMonth Members, dblemth.h, Classes


DoubleMonth Members

DoubleMonth Members
DoubleMonth Class Legend Protected Data Members Public Methods

The following tables list the members exposed by DoubleMonth.

Collapse Expand Class

DoubleMonth Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Double array.
Collapse Expand Public Methods
Name | Description
DoubleMonth | Initializes the baseYear and lastYear and the data array.
annAvgCal | Calculates annual average of the 12 monthly figures.
assign | Sets data for specified years.
getAt | Returns one value of data.
getBaseYear | Returns base year.
getLastYear | Returns last year.
getLineWidth | Returns line width for output.
getPrecision | Returns precision for output.
getWidth | Returns field width for output.
nmonCal | Finds number of months of (nonzero) data in a given year.
qtrAvgCal | Calculates quarterly average of the 3 monthly figures.
read | Reads array from an open stream.
setAt | Sets one value of data.
setLineWidth | Initializes line width for output.
setPrecision | Initializes precision for output.
setWidth | Initializes field width for output.
write | Writes array to an open stream.
~DoubleMonth | Destructor.
Collapse Expand Links
DoubleMonth Class, Legend, Protected Data Members, Public Methods


DoubleMonth::DoubleMonth Constructor

DoubleMonth::DoubleMonth Constructor
DoubleMonth Class DoubleMonth Members DoubleMonth Class

Initializes the baseYear and lastYear and the data array.

C++
DoubleMonth(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | New base year.
int newLastYear | New last year.
Collapse Expand Class

DoubleMonth Class

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Class


DoubleMonth::~DoubleMonth Destructor

DoubleMonth::~DoubleMonth Destructor
DoubleMonth Class DoubleMonth Members DoubleMonth Class

Destructor.

C++
~DoubleMonth();
Collapse Expand Remarks

Does nothing.

Collapse Expand Class

DoubleMonth Class

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Class


DoubleMonth Data Members

DoubleMonth Data Members
DoubleMonth Class Legend Protected Data Members

The data members of the DoubleMonth class are listed here.

Collapse Expand Class

DoubleMonth Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Double array.
Collapse Expand Links
DoubleMonth Class, Legend, Protected Data Members


DoubleMonth::theData Data Member

DoubleMonth::theData Data Member
DoubleMonth Class DoubleMonth Members DoubleMonth Data Members

Double array.

C++
std::vector< double > theData;
Collapse Expand Group

DoubleMonth Data Members

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Data Members


DoubleMonth Methods

DoubleMonth Methods
DoubleMonth Class Legend Public Methods

The methods of the DoubleMonth class are listed here.

Collapse Expand Class

DoubleMonth Class

Collapse Expand Public Methods
Name | Description
annAvgCal | Calculates annual average of the 12 monthly figures.
assign | Sets data for specified years.
getAt | Returns one value of data.
getBaseYear | Returns base year.
getLastYear | Returns last year.
getLineWidth | Returns line width for output.
getPrecision | Returns precision for output.
getWidth | Returns field width for output.
nmonCal | Finds number of months of (nonzero) data in a given year.
qtrAvgCal | Calculates quarterly average of the 3 monthly figures.
read | Reads array from an open stream.
setAt | Sets one value of data.
setLineWidth | Initializes line width for output.
setPrecision | Initializes precision for output.
setWidth | Initializes field width for output.
write | Writes array to an open stream.
Collapse Expand Links
DoubleMonth Class, Legend, Public Methods


DoubleMonth::annAvgCal Method

DoubleMonth::annAvgCal Method
DoubleMonth Class DoubleMonth Members DoubleMonth Methods

Calculates annual average of the 12 monthly figures.

C++
double annAvgCal(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which average is desired.
Collapse Expand Returns

Annual average of the 12 monthly figures.

Collapse Expand Group

DoubleMonth Methods

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Methods


assign Method

assign Method
DoubleMonth Methods

Sets data for specified years.

Collapse Expand Description

There are two versions of this function. The data can be set from a given constant, or from another DoubleMonth.

Collapse Expand Overload List
Name | Description
DoubleMonth::assign (const DoubleMonth&, int, int) | Sets data for specified years from another DoubleMonth.
DoubleMonth::assign (double, int, int) | Sets data for specified years to a given constant.
Collapse Expand Group

DoubleMonth Methods

Collapse Expand Links
DoubleMonth Methods


DoubleMonth::assign Method (const DoubleMonth&, int, int)

DoubleMonth::assign Method (const DoubleMonth&, int, int)
DoubleMonth Class DoubleMonth Members assign Method

Sets data for specified years from another DoubleMonth.

C++
void assign(
    const DoubleMonth& newData,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const DoubleMonth& newData | Array of new values of data.
int firstYeart | First year of data to set.
int lastYeart | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, assign Method


DoubleMonth::assign Method (double, int, int)

DoubleMonth::assign Method (double, int, int)
DoubleMonth Class DoubleMonth Members assign Method

Sets data for specified years to a given constant.

C++
void assign(
    double newDouble,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
double newDouble | New value of data to be used for all years.
int firstYeart | First year of data to set.
int lastYeart | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, assign Method


DoubleMonth::getAt Method

DoubleMonth::getAt Method
DoubleMonth Class DoubleMonth Members DoubleMonth Methods

Returns one value of data.

C++
double getAt(
    const DateMoyr& dateMoyr
) const;
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | Year and month (0-11) for which data is desired.
Collapse Expand Returns

One value of data for the specified year and month.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATMTH1 if year is out of range (only in debug mode).
Collapse Expand Group

DoubleMonth Methods

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Methods


DoubleMonth::getBaseYear Method

DoubleMonth::getBaseYear Method
DoubleMonth Class DoubleMonth Members DoubleMonth Methods

Returns base year.

C++
int getBaseYear() const;
Collapse Expand Returns

Base year.

Collapse Expand Group

DoubleMonth Methods

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Methods


DoubleMonth::getLastYear Method

DoubleMonth::getLastYear Method
DoubleMonth Class DoubleMonth Members DoubleMonth Methods

Returns last year.

C++
int getLastYear() const;
Collapse Expand Returns

Last year.

Collapse Expand Group

DoubleMonth Methods

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Methods


DoubleMonth::getLineWidth Method

DoubleMonth::getLineWidth Method
DoubleMonth Class DoubleMonth Members DoubleMonth Methods

Returns line width for output.

C++
int getLineWidth() const;
Collapse Expand Returns

Line width for output.

Collapse Expand Group

DoubleMonth Methods

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Methods


DoubleMonth::getPrecision Method

DoubleMonth::getPrecision Method
DoubleMonth Class DoubleMonth Members DoubleMonth Methods

Returns precision for output.

C++
int getPrecision() const;
Collapse Expand Returns

Precision for output.

Collapse Expand Group

DoubleMonth Methods

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Methods


DoubleMonth::getWidth Method

DoubleMonth::getWidth Method
DoubleMonth Class DoubleMonth Members DoubleMonth Methods

Returns field width for output.

C++
int getWidth() const;
Collapse Expand Returns

Field width for output.

Collapse Expand Group

DoubleMonth Methods

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Methods


DoubleMonth::nmonCal Method

DoubleMonth::nmonCal Method
DoubleMonth Class DoubleMonth Members DoubleMonth Methods

Finds number of months of (nonzero) data in a given year.

C++
int nmonCal(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year to test.
Collapse Expand Returns

Number of months of (nonzero) data in a given year.

Collapse Expand Group

DoubleMonth Methods

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Methods


DoubleMonth::qtrAvgCal Method

DoubleMonth::qtrAvgCal Method
DoubleMonth Class DoubleMonth Members DoubleMonth Methods

Calculates quarterly average of the 3 monthly figures.

C++
double qtrAvgCal(
    const QtrYear& qtrYear
) const;
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | Year and quarter (0-3) for which average is desired.
Collapse Expand Returns

Quarterly average of the 3 monthly figures.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATMTH3 if quarter is out of range (only in debug mode).
Collapse Expand Group

DoubleMonth Methods

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Methods


DoubleMonth::read Method

DoubleMonth::read Method
DoubleMonth Class DoubleMonth Members DoubleMonth Methods

Reads array from an open stream.

C++
void read(
    std::istream& in,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
std::istream& in | Input stream.
int firstYeart | First year of data to read.
int lastYeart | Last year of data to read.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATMTH2 if unable to read data for all specified years.
Collapse Expand Group

DoubleMonth Methods

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Methods


DoubleMonth::setAt Method

DoubleMonth::setAt Method
DoubleMonth Class DoubleMonth Members DoubleMonth Methods

Sets one value of data.

C++
void setAt(
    const DateMoyr& dateMoyr,
    double newData
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | Year and month (0-11) for which data is to be set.
double newData | New value of data.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATMTH1 if year in the date is out of range (only in debug mode).
Collapse Expand Group

DoubleMonth Methods

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Methods


DoubleMonth::setLineWidth Method

DoubleMonth::setLineWidth Method
DoubleMonth Class DoubleMonth Members DoubleMonth Methods

Initializes line width for output.

C++
void setLineWidth(
    int newLineWidth
);
Collapse Expand Parameters
Parameters | Description
int newLineWidth | New line width for output.
Collapse Expand Group

DoubleMonth Methods

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Methods


DoubleMonth::setPrecision Method

DoubleMonth::setPrecision Method
DoubleMonth Class DoubleMonth Members DoubleMonth Methods

Initializes precision for output.

C++
void setPrecision(
    int newPrecision
);
Collapse Expand Parameters
Parameters | Description
int newPrecision | New value of precision for output.
Collapse Expand Group

DoubleMonth Methods

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Methods


DoubleMonth::setWidth Method

DoubleMonth::setWidth Method
DoubleMonth Class DoubleMonth Members DoubleMonth Methods

Initializes field width for output.

C++
void setWidth(
    int newWidth
);
Collapse Expand Parameters
Parameters | Description
int newWidth | New value of field width for output.
Collapse Expand Group

DoubleMonth Methods

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Methods


DoubleMonth::write Method

DoubleMonth::write Method
DoubleMonth Class DoubleMonth Members DoubleMonth Methods

Writes array to an open stream.

C++
void write(
    std::ostream& out,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
int firstYeart | First year of data to write.
int lastYeart | Last year of data to write.
Collapse Expand Group

DoubleMonth Methods

Collapse Expand Links
DoubleMonth Class, DoubleMonth Members, DoubleMonth Methods


DoubleQuarter Class

DoubleQuarter Class
DoubleQuarter Data Members DoubleQuarter Methods DoubleQuarter Members dbleqtr.h Classes

Manages an array of quarterly doubles.

Collapse Expand Class Hierarchy
  DoubleQuarter
C++
class DoubleQuarter;
Collapse Expand File

File: dbleqtr.h

Module: Misc Library

Collapse Expand Remarks

Manages an array of quarterly doubles.

Collapse Expand Group

Classes

Collapse Expand Links
DoubleQuarter Data Members, DoubleQuarter Methods, DoubleQuarter Members, dbleqtr.h, Classes


DoubleQuarter Members

DoubleQuarter Members
DoubleQuarter Class Legend Protected Data Members Public Methods

The following tables list the members exposed by DoubleQuarter.

Collapse Expand Class

DoubleQuarter Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Double data.
Collapse Expand Public Methods
Name | Description
DoubleQuarter | Initializes size, base year, and last year.
anninc | Calculates annual percentage increase.
anninc3 | Calculates 3-year percentage increase at annual rate.
assign | Sets data for a range of years.
average | Calculates annual average.
getAfter | Gets one value of data after specified quarter.
getAt | Gets one value of data.
getBaseYear | Returns base year.
getBefore | Gets one value of data before specified quarter.
getLastYear | Returns last year.
getLineWidth | Returns output line width.
getWidth | Returns field width on output.
multiply | Multiplies data by another DoubleQuarter.
read | Reads array from an open stream.
setAt | Sets one value of data.
setLineWidth | Initializes output line width.
setPrecision | Initializes precision on output.
setWidth | Initializes field width.
write | Writes array to an open stream.
~DoubleQuarter | Destructor.
Collapse Expand Links
DoubleQuarter Class, Legend, Protected Data Members, Public Methods


DoubleQuarter::DoubleQuarter Constructor

DoubleQuarter::DoubleQuarter Constructor
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Class

Initializes size, base year, and last year.

C++
DoubleQuarter(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | New base year.
int newLastYear | New last year.
Collapse Expand Class

DoubleQuarter Class

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Class


DoubleQuarter::~DoubleQuarter Destructor

DoubleQuarter::~DoubleQuarter Destructor
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Class

Destructor.

C++
~DoubleQuarter();
Collapse Expand Remarks

Does nothing.

Collapse Expand Class

DoubleQuarter Class

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Class


DoubleQuarter Data Members

DoubleQuarter Data Members
DoubleQuarter Class Legend Protected Data Members

The data members of the DoubleQuarter class are listed here.

Collapse Expand Class

DoubleQuarter Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Double data.
Collapse Expand Links
DoubleQuarter Class, Legend, Protected Data Members


DoubleQuarter::theData Data Member

DoubleQuarter::theData Data Member
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Data Members

Double data.

C++
std::vector< double > theData;
Collapse Expand Group

DoubleQuarter Data Members

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Data Members


DoubleQuarter Methods

DoubleQuarter Methods
DoubleQuarter Class Legend Public Methods

The methods of the DoubleQuarter class are listed here.

Collapse Expand Class

DoubleQuarter Class

Collapse Expand Public Methods
Name | Description
anninc | Calculates annual percentage increase.
anninc3 | Calculates 3-year percentage increase at annual rate.
assign | Sets data for a range of years.
average | Calculates annual average.
getAfter | Gets one value of data after specified quarter.
getAt | Gets one value of data.
getBaseYear | Returns base year.
getBefore | Gets one value of data before specified quarter.
getLastYear | Returns last year.
getLineWidth | Returns output line width.
getWidth | Returns field width on output.
multiply | Multiplies data by another DoubleQuarter.
read | Reads array from an open stream.
setAt | Sets one value of data.
setLineWidth | Initializes output line width.
setPrecision | Initializes precision on output.
setWidth | Initializes field width.
write | Writes array to an open stream.
Collapse Expand Links
DoubleQuarter Class, Legend, Public Methods


DoubleQuarter::anninc Method

DoubleQuarter::anninc Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Calculates annual percentage increase.

C++
double anninc(
    const QtrYear& qtrYear
) const;
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | Year and quarter (0-3) for which percentage increase is desired.
Collapse Expand Returns

Annual percentage increase.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATQTR1 if year is out of range, or of type PIA_IDS_FLOATQTR3 if quarter is out of range, or of type PIA_IDS_FLOATQTR4 if value is zero in prior year (only in debug mode).
Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


DoubleQuarter::anninc3 Method

DoubleQuarter::anninc3 Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Calculates 3-year percentage increase at annual rate.

C++
double anninc3(
    const QtrYear& qtrYear
) const;
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | Year and quarter (0-3) for which percentage increase is desired.
Collapse Expand Returns

3-year percentage increase at annual rate.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATQTR1 if year is out of range, or of type PIA_IDS_FLOATQTR3 if quarter is out of range, or of type PIA_IDS_FLOATQTR4 if value is zero in third prior year (only in debug mode).
Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


assign Method

assign Method
DoubleQuarter Methods

Sets data for a range of years.

Collapse Expand Description

There are three versions of this function. The data can be assigned from a constant, from a DoubleMonth, or from another DoubleQuarter.

Collapse Expand Overload List
Name | Description
DoubleQuarter::assign (const DoubleMonth&, const QtrYear&, const QtrYear&) | Initializes data for specified dates from a DoubleMonth.
DoubleQuarter::assign (const DoubleQuarter&, int, int) | Initializes data for specified years from another DoubleQuarter.
DoubleQuarter::assign (double, int, int) | Initializes data for specified years from a constant.
Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Methods


DoubleQuarter::assign Method (const DoubleMonth&, const QtrYear&, const QtrYear&)

DoubleQuarter::assign Method (const DoubleMonth&, const QtrYear&, const QtrYear&)
DoubleQuarter Class DoubleQuarter Members assign Method

Initializes data for specified dates from a DoubleMonth.

C++
void assign(
    const DoubleMonth& doubleMonth,
    const QtrYear& firstQtrYear,
    const QtrYear& lastQtrYear
);
Collapse Expand Parameters
Parameters | Description
const DoubleMonth& doubleMonth | Array of monthly values. The three values in each quarter are averaged.
const QtrYear& firstQtrYear | First year and quarter of data to set.
const QtrYear& lastQtrYear | Last year and quarter of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, assign Method


DoubleQuarter::assign Method (const DoubleQuarter&, int, int)

DoubleQuarter::assign Method (const DoubleQuarter&, int, int)
DoubleQuarter Class DoubleQuarter Members assign Method

Initializes data for specified years from another DoubleQuarter.

C++
void assign(
    const DoubleQuarter& doubleQuarter,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const DoubleQuarter& doubleQuarter | Array of new quarterly values of data.
int firstYeart | First year of data to set.
int lastYeart | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, assign Method


DoubleQuarter::assign Method (double, int, int)

DoubleQuarter::assign Method (double, int, int)
DoubleQuarter Class DoubleQuarter Members assign Method

Initializes data for specified years from a constant.

C++
void assign(
    double newData,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
double newData | New value of data to be used for all years.
int firstYeart | First year of data to set.
int lastYeart | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, assign Method


DoubleQuarter::average Method

DoubleQuarter::average Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Calculates annual average.

C++
double average(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which average is desired.
Collapse Expand Returns

Annual average.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATQTR1 if year is out of range (only in debug mode).
Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


DoubleQuarter::getAfter Method

DoubleQuarter::getAfter Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Gets one value of data after specified quarter.

C++
double getAfter(
    const QtrYear& qtrYear
) const;
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | Year and quarter (0-3) after which data is desired.
Collapse Expand Returns

One value of data after specified quarter.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATQTR1 if year is out of range, or of type PIA_IDS_FLOATQTR3 if quarter is out of range (only in debug mode).
Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


DoubleQuarter::getAt Method

DoubleQuarter::getAt Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Gets one value of data.

C++
double getAt(
    const QtrYear& qtrYear
) const;
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | Year and quarter (0-3) for which data is desired.
Collapse Expand Returns

One value of data for the specified year and quarter.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATQTR1 if year is out of range (only in debug mode).
Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


DoubleQuarter::getBaseYear Method

DoubleQuarter::getBaseYear Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Returns base year.

C++
int getBaseYear() const;
Collapse Expand Returns

Base year.

Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


DoubleQuarter::getBefore Method

DoubleQuarter::getBefore Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Gets one value of data before specified quarter.

C++
double getBefore(
    const QtrYear& qtrYear
) const;
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | Year and quarter (0-3) before which data is desired.
Collapse Expand Returns

One value of data before specified quarter.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATQTR1 if year is out of range, or of type PIA_IDS_FLOATQTR3 if quarter is out of range (only in debug mode).
Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


DoubleQuarter::getLastYear Method

DoubleQuarter::getLastYear Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Returns last year.

C++
int getLastYear() const;
Collapse Expand Returns

Last year.

Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


DoubleQuarter::getLineWidth Method

DoubleQuarter::getLineWidth Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Returns output line width.

C++
int getLineWidth() const;
Collapse Expand Returns

Output line width.

Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


DoubleQuarter::getWidth Method

DoubleQuarter::getWidth Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Returns field width on output.

C++
int getWidth() const;
Collapse Expand Returns

Field width on output.

Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


DoubleQuarter::multiply Method

DoubleQuarter::multiply Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Multiplies data by another DoubleQuarter.

C++
void multiply(
    const DoubleQuarter& doubleQuarter,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const DoubleQuarter& doubleQuarter | Array of multipliers.
int firstYeart | First year of data to multiply.
int lastYeart | Last year of data to multiply.
Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


DoubleQuarter::read Method

DoubleQuarter::read Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Reads array from an open stream.

C++
void read(
    std::istream& in,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
std::istream& in | Input stream.
int firstYeart | First year of data to read.
int lastYeart | Last year of data to read.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATQTR2 if unable to read data for all specified years.
Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


DoubleQuarter::setAt Method

DoubleQuarter::setAt Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Sets one value of data.

C++
void setAt(
    const QtrYear& qtrYear,
    double newData
);
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | Year and quarter (0-3) for which data is desired.
double newData | New value of data.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATQTR1 if year is out of range (only in debug mode).
Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


DoubleQuarter::setLineWidth Method

DoubleQuarter::setLineWidth Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Initializes output line width.

C++
void setLineWidth(
    int newLineWidth
);
Collapse Expand Parameters
Parameters | Description
int newLineWidth | New output line width.
Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


DoubleQuarter::setPrecision Method

DoubleQuarter::setPrecision Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Initializes precision on output.

C++
void setPrecision(
    int newPrecision
);
Collapse Expand Parameters
Parameters | Description
int newPrecision | New value of precision on output.
Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


DoubleQuarter::setWidth Method

DoubleQuarter::setWidth Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Initializes field width.

C++
void setWidth(
    int newWidth
);
Collapse Expand Parameters
Parameters | Description
int newWidth | New value of field width.
Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


DoubleQuarter::write Method

DoubleQuarter::write Method
DoubleQuarter Class DoubleQuarter Members DoubleQuarter Methods

Writes array to an open stream.

C++
void write(
    std::ostream& out,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
int firstYeart | First year of data to write.
int lastYeart | Last year of data to write.
Collapse Expand Group

DoubleQuarter Methods

Collapse Expand Links
DoubleQuarter Class, DoubleQuarter Members, DoubleQuarter Methods


FloatAnnual Class

FloatAnnual Class
FloatAnnual Data Members FloatAnnual Methods FloatAnnual Operators FloatAnnual Friends FloatAnnual Members floatann.h Classes

Manages an array of annual floats.

Collapse Expand Class Hierarchy
  FloatAnnual
C++
class FloatAnnual;
Collapse Expand File

File: floatann.h

Module: Misc Library

Collapse Expand Remarks

See DoubleAnnual and IntAnnual for similar classes that manage arrays of annual doubles and integers.

Collapse Expand See Also

DoubleAnnual, IntAnnual

Collapse Expand Group

Classes

Collapse Expand Links
FloatAnnual Data Members, FloatAnnual Methods, FloatAnnual Operators, FloatAnnual Friends, FloatAnnual Members, floatann.h, Classes


FloatAnnual Members

FloatAnnual Members
FloatAnnual Class Legend Public Data Members Public Friends Public Methods

The following tables list the members exposed by FloatAnnual.

Collapse Expand Class

FloatAnnual Class

Collapse Expand Public Data Members
Name | Description
baseYear | Base year of data.
theData | Vector of floats.
Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Name | Description
FloatAnnual | Constructor.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
~FloatAnnual | Destructor.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
FloatAnnual Class, Legend, Public Data Members, Public Friends, Public Methods


FloatAnnual::FloatAnnual Constructor

FloatAnnual::FloatAnnual Constructor
FloatAnnual Class FloatAnnual Members FloatAnnual Class

Constructor.

C++
FloatAnnual(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | New base year.
int newLastYear | New last year.
Collapse Expand Remarks

Sets the base year of data, and initializes the size of the data vector to the span of years.

Collapse Expand Class

FloatAnnual Class

Collapse Expand Links
FloatAnnual Class, FloatAnnual Members, FloatAnnual Class


FloatAnnual::~FloatAnnual Destructor

FloatAnnual::~FloatAnnual Destructor
FloatAnnual Class FloatAnnual Members FloatAnnual Class

Destructor.

C++
virtual ~FloatAnnual();
Collapse Expand Class

FloatAnnual Class

Collapse Expand Links
FloatAnnual Class, FloatAnnual Members, FloatAnnual Class


FloatAnnual Data Members

FloatAnnual Data Members
FloatAnnual Class Legend Public Data Members

The data members of the FloatAnnual class are listed here.

Collapse Expand Class

FloatAnnual Class

Collapse Expand Public Data Members
Name | Description
baseYear | Base year of data.
theData | Vector of floats.
Collapse Expand Links
FloatAnnual Class, Legend, Public Data Members


FloatAnnual::baseYear Data Member

FloatAnnual::baseYear Data Member
FloatAnnual Class FloatAnnual Members FloatAnnual Data Members

Base year of data.

C++
const int baseYear;
Collapse Expand Group

FloatAnnual Data Members

Collapse Expand Links
FloatAnnual Class, FloatAnnual Members, FloatAnnual Data Members


FloatAnnual::theData Data Member

FloatAnnual::theData Data Member
FloatAnnual Class FloatAnnual Members FloatAnnual Data Members

Vector of floats.

C++
std::vector< float > theData;
Collapse Expand Group

FloatAnnual Data Members

Collapse Expand Links
FloatAnnual Class, FloatAnnual Members, FloatAnnual Data Members


FloatAnnual Methods

FloatAnnual Methods
FloatAnnual Class Legend Public Methods

The methods of the FloatAnnual class are listed here.

Collapse Expand Class

FloatAnnual Class

Collapse Expand Public Methods
Name | Description
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
Collapse Expand Links
FloatAnnual Class, Legend, Public Methods


FloatAnnual::accumulate Method

FloatAnnual::accumulate Method
FloatAnnual Class FloatAnnual Members FloatAnnual Methods

Accumulates data over a range of years.

C++
float accumulate(
    int year1,
    int year2,
    float startValue
) const;
Collapse Expand Parameters
Parameters | Description
int year1 | Year with which to start accumulating (inclusive).
int year2 | Year with which to end accumulating (inclusive).
float startValue | Starting value.
Collapse Expand Returns

Total of data in the vector over the specified range.

Collapse Expand Remarks

Does not check to be sure range of years is within allowable range, unless in debug mode.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATANN1 if years are out of range (only in debug mode).
Collapse Expand Group

FloatAnnual Methods

Collapse Expand Links
FloatAnnual Class, FloatAnnual Members, FloatAnnual Methods


assign Method

assign Method
FloatAnnual Methods

Functions to assign data for a range of years.

Collapse Expand Description

There are two versions of the assign method. In both versions, the range of years is specified by two arguments. The other argument, supplying the data to be copied, can be a constant float or another FloatAnnual.

Collapse Expand Overload List
Name | Description
FloatAnnual::assign (const FloatAnnual&, int, int) | Sets data for specified years from another FloatAnnual.
FloatAnnual::assign (float, int, int) | Sets data for specified years from one value that is constant for all years.
Collapse Expand Group

FloatAnnual Methods

Collapse Expand Links
FloatAnnual Methods


FloatAnnual::assign Method (const FloatAnnual&, int, int)

FloatAnnual::assign Method (const FloatAnnual&, int, int)
FloatAnnual Class FloatAnnual Members assign Method

Sets data for specified years from another FloatAnnual.

C++
void assign(
    const FloatAnnual& floatAnnual,
    int firstYear,
    int lastYear
);
Collapse Expand Parameters
Parameters | Description
const FloatAnnual& floatAnnual | Array of new values of data.
int firstYear | First year of data to set.
int lastYear | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
FloatAnnual Class, FloatAnnual Members, assign Method


FloatAnnual::assign Method (float, int, int)

FloatAnnual::assign Method (float, int, int)
FloatAnnual Class FloatAnnual Members assign Method

Sets data for specified years from one value that is constant for all years.

C++
void assign(
    float newData,
    int firstYear,
    int lastYear
);
Collapse Expand Parameters
Parameters | Description
float newData | New value of data to be used for all specified years.
int firstYear | First year of data to set.
int lastYear | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
FloatAnnual Class, FloatAnnual Members, assign Method


FloatAnnual::fill Method

FloatAnnual::fill Method
FloatAnnual Class FloatAnnual Members FloatAnnual Methods

Fills all data slots with the given value.

C++
void fill(
    float value
);
Collapse Expand Parameters
Parameters | Description
float value | The value to fill the data slots with.
Collapse Expand Group

FloatAnnual Methods

Collapse Expand Links
FloatAnnual Class, FloatAnnual Members, FloatAnnual Methods


FloatAnnual::getBaseYear Method

FloatAnnual::getBaseYear Method
FloatAnnual Class FloatAnnual Members FloatAnnual Methods

Returns base year of data.

C++
int getBaseYear() const;
Collapse Expand Returns

Base year of data.

Collapse Expand Group

FloatAnnual Methods

Collapse Expand Links
FloatAnnual Class, FloatAnnual Members, FloatAnnual Methods


FloatAnnual::getLastYear Method

FloatAnnual::getLastYear Method
FloatAnnual Class FloatAnnual Members FloatAnnual Methods

Returns last year of data.

C++
int getLastYear() const;
Collapse Expand Returns

Last year of data.

Collapse Expand Remarks

This is the base year plus the size of the data array, minus 1. Note that this is less than the base year if the size is zero.

Collapse Expand Group

FloatAnnual Methods

Collapse Expand Links
FloatAnnual Class, FloatAnnual Members, FloatAnnual Methods


FloatAnnual Operators

FloatAnnual Operators
FloatAnnual Class Legend

The operators of the FloatAnnual class are listed here.

Collapse Expand Class

FloatAnnual Class

Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
FloatAnnual Class, Legend


[] Operator

[] Operator
FloatAnnual Operators

Functions to access an element of the array.

Collapse Expand Description

There are two versions of the [] operator. They differ only in that one is const and the other is not, so that they can be used in both const and non-const settings.

Collapse Expand Overload List
Name | Description
FloatAnnual::[] (int) | Returns one value of data, non const.
FloatAnnual::[] (int) | Returns one value of data, const.
Collapse Expand Group

FloatAnnual Operators

Collapse Expand Links
FloatAnnual Operators


FloatAnnual::[] Operator (int)

FloatAnnual::[] Operator (int)
FloatAnnual Class FloatAnnual Members [] Operator

Returns one value of data, non const.

C++
float& operator [](
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which data is desired.
Collapse Expand Returns

One value of data for the specified year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATANN1 if year is out of range. (only in debug mode)
Collapse Expand Group

[] Operator

Collapse Expand Links
FloatAnnual Class, FloatAnnual Members, [] Operator


FloatAnnual::[] Operator (int)

FloatAnnual::[] Operator (int)
FloatAnnual Class FloatAnnual Members [] Operator

Returns one value of data, const.

C++
const float operator [](
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which data is desired.
Collapse Expand Returns

One value of data for the specified year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATANN1 if year is out of range. (only in debug mode)
Collapse Expand Group

[] Operator

Collapse Expand Links
FloatAnnual Class, FloatAnnual Members, [] Operator


FloatAnnual Friends

FloatAnnual Friends
FloatAnnual Class Public Friends

The friends of the FloatAnnual class are listed here.

Collapse Expand Class

FloatAnnual Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Links
FloatAnnual Class, Public Friends


friend class boost::serialization::access Friend

friend class boost::serialization::access Friend
FloatAnnual Class FloatAnnual Members FloatAnnual Friends

Friend class to allow serialization.

C++
friend class boost::serialization::access;
Collapse Expand Group

FloatAnnual Friends

Collapse Expand Links
FloatAnnual Class, FloatAnnual Members, FloatAnnual Friends


FloatMonth Class

FloatMonth Class
FloatMonth Data Members FloatMonth Methods FloatMonth Members floatmth.h Classes

Manages an array of monthly floats.

Collapse Expand Class Hierarchy
  FloatMonth
C++
class FloatMonth;
Collapse Expand File

File: floatmth.h

Module: Misc Library

Collapse Expand Remarks

Manages an array of monthly floats.

Collapse Expand Group

Classes

Collapse Expand Links
FloatMonth Data Members, FloatMonth Methods, FloatMonth Members, floatmth.h, Classes


FloatMonth Members

FloatMonth Members
FloatMonth Class Legend Protected Data Members Public Methods

The following tables list the members exposed by FloatMonth.

Collapse Expand Class

FloatMonth Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Float array.
Collapse Expand Public Methods
Name | Description
FloatMonth | Initializes the base year and last year to the specified values.
annAvgCal | Calculates annual average of the 12 monthly figures.
assign | Sets data for specified years.
getAt | Returns one value of data.
getBaseYear | Returns base year.
getLastYear | Returns last year.
getLineWidth | Returns line width for output.
getPrecision | Returns precision for output.
getWidth | Returns field width for output.
nmonCal | Finds number of months of (nonzero) data in a given year.
qtrAvgCal | Calculates quarterly average of the 3 monthly figures.
read | Reads array from an open stream.
setAt | Sets one value of data.
setLineWidth | Initializes line width for output.
setPrecision | Initializes precision for output.
setWidth | Initializes field width for output.
write | Writes array to an open stream.
~FloatMonth | Destructor.
Collapse Expand Links
FloatMonth Class, Legend, Protected Data Members, Public Methods


FloatMonth::FloatMonth Constructor

FloatMonth::FloatMonth Constructor
FloatMonth Class FloatMonth Members FloatMonth Class

Initializes the base year and last year to the specified values.

C++
FloatMonth(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | New base year.
int newLastYear | New last year.
Collapse Expand Class

FloatMonth Class

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Class


FloatMonth::~FloatMonth Destructor

FloatMonth::~FloatMonth Destructor
FloatMonth Class FloatMonth Members FloatMonth Class

Destructor.

C++
~FloatMonth();
Collapse Expand Remarks

Does nothing.

Collapse Expand Class

FloatMonth Class

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Class


FloatMonth Data Members

FloatMonth Data Members
FloatMonth Class Legend Protected Data Members

The data members of the FloatMonth class are listed here.

Collapse Expand Class

FloatMonth Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Float array.
Collapse Expand Links
FloatMonth Class, Legend, Protected Data Members


FloatMonth::theData Data Member

FloatMonth::theData Data Member
FloatMonth Class FloatMonth Members FloatMonth Data Members

Float array.

C++
std::vector< float > theData;
Collapse Expand Group

FloatMonth Data Members

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Data Members


FloatMonth Methods

FloatMonth Methods
FloatMonth Class Legend Public Methods

The methods of the FloatMonth class are listed here.

Collapse Expand Class

FloatMonth Class

Collapse Expand Public Methods
Name | Description
annAvgCal | Calculates annual average of the 12 monthly figures.
assign | Sets data for specified years.
getAt | Returns one value of data.
getBaseYear | Returns base year.
getLastYear | Returns last year.
getLineWidth | Returns line width for output.
getPrecision | Returns precision for output.
getWidth | Returns field width for output.
nmonCal | Finds number of months of (nonzero) data in a given year.
qtrAvgCal | Calculates quarterly average of the 3 monthly figures.
read | Reads array from an open stream.
setAt | Sets one value of data.
setLineWidth | Initializes line width for output.
setPrecision | Initializes precision for output.
setWidth | Initializes field width for output.
write | Writes array to an open stream.
Collapse Expand Links
FloatMonth Class, Legend, Public Methods


FloatMonth::annAvgCal Method

FloatMonth::annAvgCal Method
FloatMonth Class FloatMonth Members FloatMonth Methods

Calculates annual average of the 12 monthly figures.

C++
float annAvgCal(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which average is desired.
Collapse Expand Returns

Annual average of the 12 monthly figures.

Collapse Expand Group

FloatMonth Methods

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Methods


assign Method

assign Method
FloatMonth Methods

Sets data for specified years.

Collapse Expand Description

There are two versions of this function. The data can be set from a given constant, or from another FloatMonth.

Collapse Expand Overload List
Name | Description
FloatMonth::assign (const FloatMonth&, int, int) | Sets data for specified years.
FloatMonth::assign (float, int, int) | Sets data for specified years.
Collapse Expand Group

FloatMonth Methods

Collapse Expand Links
FloatMonth Methods


FloatMonth::assign Method (const FloatMonth&, int, int)

FloatMonth::assign Method (const FloatMonth&, int, int)
FloatMonth Class FloatMonth Members assign Method

Sets data for specified years.

C++
void assign(
    const FloatMonth& newData,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const FloatMonth& newData | Array of new values of data.
int firstYeart | First year of data to set.
int lastYeart | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
FloatMonth Class, FloatMonth Members, assign Method


FloatMonth::assign Method (float, int, int)

FloatMonth::assign Method (float, int, int)
FloatMonth Class FloatMonth Members assign Method

Sets data for specified years.

C++
void assign(
    float newFloat,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
float newFloat | New value of data to be used for all years.
int firstYeart | First year of data to set.
int lastYeart | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
FloatMonth Class, FloatMonth Members, assign Method


FloatMonth::getAt Method

FloatMonth::getAt Method
FloatMonth Class FloatMonth Members FloatMonth Methods

Returns one value of data.

C++
float getAt(
    const DateMoyr& dateMoyr
) const;
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | Year and month (0-11) for which data is desired.
Collapse Expand Returns

One value of data for the specified year and month.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATMTH1 if year is out of range (only in debug mode).
Collapse Expand Group

FloatMonth Methods

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Methods


FloatMonth::getBaseYear Method

FloatMonth::getBaseYear Method
FloatMonth Class FloatMonth Members FloatMonth Methods

Returns base year.

C++
int getBaseYear() const;
Collapse Expand Returns

Base year.

Collapse Expand Group

FloatMonth Methods

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Methods


FloatMonth::getLastYear Method

FloatMonth::getLastYear Method
FloatMonth Class FloatMonth Members FloatMonth Methods

Returns last year.

C++
int getLastYear() const;
Collapse Expand Returns

Last year.

Collapse Expand Group

FloatMonth Methods

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Methods


FloatMonth::getLineWidth Method

FloatMonth::getLineWidth Method
FloatMonth Class FloatMonth Members FloatMonth Methods

Returns line width for output.

C++
int getLineWidth() const;
Collapse Expand Returns

Line width for output.

Collapse Expand Group

FloatMonth Methods

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Methods


FloatMonth::getPrecision Method

FloatMonth::getPrecision Method
FloatMonth Class FloatMonth Members FloatMonth Methods

Returns precision for output.

C++
int getPrecision() const;
Collapse Expand Returns

Precision for output.

Collapse Expand Group

FloatMonth Methods

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Methods


FloatMonth::getWidth Method

FloatMonth::getWidth Method
FloatMonth Class FloatMonth Members FloatMonth Methods

Returns field width for output.

C++
int getWidth() const;
Collapse Expand Returns

Field width for output.

Collapse Expand Group

FloatMonth Methods

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Methods


FloatMonth::nmonCal Method

FloatMonth::nmonCal Method
FloatMonth Class FloatMonth Members FloatMonth Methods

Finds number of months of (nonzero) data in a given year.

C++
int nmonCal(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year to test.
Collapse Expand Returns

Number of months of (nonzero) data in a given year.

Collapse Expand Group

FloatMonth Methods

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Methods


FloatMonth::qtrAvgCal Method

FloatMonth::qtrAvgCal Method
FloatMonth Class FloatMonth Members FloatMonth Methods

Calculates quarterly average of the 3 monthly figures.

C++
float qtrAvgCal(
    const QtrYear& qtrYear
) const;
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | Year and quarter (0-3) for which average is desired.
Collapse Expand Returns

Quarterly average of the 3 monthly figures.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATMTH3 if quarter is out of range (only in debug mode).
Collapse Expand Group

FloatMonth Methods

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Methods


FloatMonth::read Method

FloatMonth::read Method
FloatMonth Class FloatMonth Members FloatMonth Methods

Reads array from an open stream.

C++
void read(
    std::istream& in,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
std::istream& in | Input stream.
int firstYeart | First year of data to read.
int lastYeart | Last year of data to read.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATMTH2 if unable to read data for all specified years.
Collapse Expand Group

FloatMonth Methods

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Methods


FloatMonth::setAt Method

FloatMonth::setAt Method
FloatMonth Class FloatMonth Members FloatMonth Methods

Sets one value of data.

C++
void setAt(
    const DateMoyr& dateMoyr,
    float newData
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | Year and month (0-11) for which data is to be set.
float newData | New value of data.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATMTH1 if year is out of range (only in debug mode).
Collapse Expand Group

FloatMonth Methods

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Methods


FloatMonth::setLineWidth Method

FloatMonth::setLineWidth Method
FloatMonth Class FloatMonth Members FloatMonth Methods

Initializes line width for output.

C++
void setLineWidth(
    int newLineWidth
);
Collapse Expand Parameters
Parameters | Description
int newLineWidth | New line width for output.
Collapse Expand Group

FloatMonth Methods

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Methods


FloatMonth::setPrecision Method

FloatMonth::setPrecision Method
FloatMonth Class FloatMonth Members FloatMonth Methods

Initializes precision for output.

C++
void setPrecision(
    int newPrecision
);
Collapse Expand Parameters
Parameters | Description
int newPrecision | New value of precision for output.
Collapse Expand Group

FloatMonth Methods

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Methods


FloatMonth::setWidth Method

FloatMonth::setWidth Method
FloatMonth Class FloatMonth Members FloatMonth Methods

Initializes field width for output.

C++
void setWidth(
    int newWidth
);
Collapse Expand Parameters
Parameters | Description
int newWidth | New value of field width for output.
Collapse Expand Group

FloatMonth Methods

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Methods


FloatMonth::write Method

FloatMonth::write Method
FloatMonth Class FloatMonth Members FloatMonth Methods

Writes array to an open stream.

C++
void write(
    std::ostream& out,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
int firstYeart | First year of data to write.
int lastYeart | Last year of data to write.
Collapse Expand Group

FloatMonth Methods

Collapse Expand Links
FloatMonth Class, FloatMonth Members, FloatMonth Methods


FloatQuarter Class

FloatQuarter Class
FloatQuarter Data Members FloatQuarter Methods FloatQuarter Members floatqtr.h Classes

Manages an array of quarterly floats.

Collapse Expand Class Hierarchy
  FloatQuarter
C++
class FloatQuarter;
Collapse Expand File

File: floatqtr.h

Module: Misc Library

Collapse Expand Remarks

Manages an array of quarterly floats.

Collapse Expand Group

Classes

Collapse Expand Links
FloatQuarter Data Members, FloatQuarter Methods, FloatQuarter Members, floatqtr.h, Classes


FloatQuarter Members

FloatQuarter Members
FloatQuarter Class Legend Protected Data Members Public Methods

The following tables list the members exposed by FloatQuarter.

Collapse Expand Class

FloatQuarter Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Float data.
Collapse Expand Public Methods
Name | Description
FloatQuarter | Initializes the base year and last year to the specified values.
anninc | Calculates annual percentage increase.
anninc3 | Calculates 3-year percentage increase at annual rate.
assign | Sets data for a range of years.
average | Calculates annual average.
getAfter | Gets one value of data after specified quarter.
getAt | Gets one value of data.
getBaseYear | Returns base year.
getBefore | Gets one value of data before specified quarter.
getLastYear | Returns last year.
getLineWidth | Returns output line width.
getWidth | Returns field width on output.
multiply | Multiplies data by another FloatQuarter.
read | Reads array from an open stream.
setAt | Sets one value of data.
setLineWidth | Initializes output line width.
setPrecision | Initializes precision on output.
setWidth | Initializes field width.
write | Writes array to an open stream.
Collapse Expand Links
FloatQuarter Class, Legend, Protected Data Members, Public Methods


FloatQuarter::FloatQuarter Constructor

FloatQuarter::FloatQuarter Constructor
FloatQuarter Class FloatQuarter Members FloatQuarter Class

Initializes the base year and last year to the specified values.

C++
FloatQuarter(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | New base year.
int newLastYear | New last year.
Collapse Expand Class

FloatQuarter Class

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Class


FloatQuarter Data Members

FloatQuarter Data Members
FloatQuarter Class Legend Protected Data Members

The data members of the FloatQuarter class are listed here.

Collapse Expand Class

FloatQuarter Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Float data.
Collapse Expand Links
FloatQuarter Class, Legend, Protected Data Members


FloatQuarter::theData Data Member

FloatQuarter::theData Data Member
FloatQuarter Class FloatQuarter Members FloatQuarter Data Members

Float data.

C++
std::vector< float > theData;
Collapse Expand Group

FloatQuarter Data Members

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Data Members


FloatQuarter Methods

FloatQuarter Methods
FloatQuarter Class Legend Public Methods

The methods of the FloatQuarter class are listed here.

Collapse Expand Class

FloatQuarter Class

Collapse Expand Public Methods
Name | Description
anninc | Calculates annual percentage increase.
anninc3 | Calculates 3-year percentage increase at annual rate.
assign | Sets data for a range of years.
average | Calculates annual average.
getAfter | Gets one value of data after specified quarter.
getAt | Gets one value of data.
getBaseYear | Returns base year.
getBefore | Gets one value of data before specified quarter.
getLastYear | Returns last year.
getLineWidth | Returns output line width.
getWidth | Returns field width on output.
multiply | Multiplies data by another FloatQuarter.
read | Reads array from an open stream.
setAt | Sets one value of data.
setLineWidth | Initializes output line width.
setPrecision | Initializes precision on output.
setWidth | Initializes field width.
write | Writes array to an open stream.
Collapse Expand Links
FloatQuarter Class, Legend, Public Methods


FloatQuarter::anninc Method

FloatQuarter::anninc Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Calculates annual percentage increase.

C++
float anninc(
    const QtrYear& qtrYear
) const;
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | Year and quarter (0-3) for which percentage increase is desired.
Collapse Expand Returns

Annual percentage increase.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATQTR1 if year is out of range, or of type PIA_IDS_FLOATQTR3 if quarter is out of range, or of type PIA_IDS_FLOATQTR4 if value is zero in prior year (only in debug mode).
Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


FloatQuarter::anninc3 Method

FloatQuarter::anninc3 Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Calculates 3-year percentage increase at annual rate.

C++
float anninc3(
    const QtrYear& qtrYear
) const;
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | Year and quarter (0-3) for which percentage increase is desired.
Collapse Expand Returns

3-year percentage increase at annual rate.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATQTR1 if year is out of range, or of type PIA_IDS_FLOATQTR3 if quarter is out of range, or of type PIA_IDS_FLOATQTR4 if value is zero in third prior year (only in debug mode).
Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


assign Method

assign Method
FloatQuarter Methods

Sets data for a range of years.

Collapse Expand Description

There are three versions of this function. The data can be assigned from a constant, from a FloatMonth, or from another FloatQuarter.

Collapse Expand Overload List
Name | Description
FloatQuarter::assign (const FloatMonth&, const QtrYear&, const QtrYear&) | Sets data for specified years.
FloatQuarter::assign (const FloatQuarter&, int, int) | Sets data for specified years.
FloatQuarter::assign (float, int, int) | Sets data for specified years.
Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Methods


FloatQuarter::assign Method (const FloatMonth&, const QtrYear&, const QtrYear&)

FloatQuarter::assign Method (const FloatMonth&, const QtrYear&, const QtrYear&)
FloatQuarter Class FloatQuarter Members assign Method

Sets data for specified years.

C++
void assign(
    const FloatMonth& floatMonth,
    const QtrYear& firstQtrYear,
    const QtrYear& lastQtrYear
);
Collapse Expand Parameters
Parameters | Description
const FloatMonth& floatMonth | Array of monthly values. The three values in each quarter are averaged.
const QtrYear& firstQtrYear | First year and quarter of data to set.
const QtrYear& lastQtrYear | Last year and quarter of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, assign Method


FloatQuarter::assign Method (const FloatQuarter&, int, int)

FloatQuarter::assign Method (const FloatQuarter&, int, int)
FloatQuarter Class FloatQuarter Members assign Method

Sets data for specified years.

C++
void assign(
    const FloatQuarter& floatQuarter,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const FloatQuarter& floatQuarter | Array of new quarterly values of data.
int firstYeart | First year of data to set.
int lastYeart | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, assign Method


FloatQuarter::assign Method (float, int, int)

FloatQuarter::assign Method (float, int, int)
FloatQuarter Class FloatQuarter Members assign Method

Sets data for specified years.

C++
void assign(
    float newData,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
float newData | New value of data to be used for all years.
int firstYeart | First year of data to set.
int lastYeart | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, assign Method


FloatQuarter::average Method

FloatQuarter::average Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Calculates annual average.

C++
float average(
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which average is desired.
Collapse Expand Returns

Annual average.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATQTR1 if year is out of range (only in debug mode).
Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


FloatQuarter::getAfter Method

FloatQuarter::getAfter Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Gets one value of data after specified quarter.

C++
float getAfter(
    const QtrYear& qtrYear
) const;
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | Year and quarter (0-3) after which data is desired.
Collapse Expand Returns

One value of data after specified quarter.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATQTR1 if year is out of range, or of type PIA_IDS_FLOATQTR3 if quarter is out of range (only in debug mode).
Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


FloatQuarter::getAt Method

FloatQuarter::getAt Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Gets one value of data.

C++
float getAt(
    const QtrYear& qtrYear
) const;
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | Year and quarter (0-3) for which data is desired.
Collapse Expand Returns

One value of data for the specified year and quarter.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATQTR1 if year is out of range (only in debug mode).
Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


FloatQuarter::getBaseYear Method

FloatQuarter::getBaseYear Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Returns base year.

C++
int getBaseYear() const;
Collapse Expand Returns

Base year.

Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


FloatQuarter::getBefore Method

FloatQuarter::getBefore Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Gets one value of data before specified quarter.

C++
float getBefore(
    const QtrYear& qtrYear
) const;
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | Year and quarter (0-3) before which data is desired.
Collapse Expand Returns

One value of data before specified quarter.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATQTR1 if year is out of range, or of type PIA_IDS_FLOATQTR3 if quarter is out of range (only in debug mode).
Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


FloatQuarter::getLastYear Method

FloatQuarter::getLastYear Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Returns last year.

C++
int getLastYear() const;
Collapse Expand Returns

Last year.

Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


FloatQuarter::getLineWidth Method

FloatQuarter::getLineWidth Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Returns output line width.

C++
int getLineWidth() const;
Collapse Expand Returns

Output line width.

Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


FloatQuarter::getWidth Method

FloatQuarter::getWidth Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Returns field width on output.

C++
int getWidth() const;
Collapse Expand Returns

Field width on output.

Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


FloatQuarter::multiply Method

FloatQuarter::multiply Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Multiplies data by another FloatQuarter.

C++
void multiply(
    const FloatQuarter& floatQuarter,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
const FloatQuarter& floatQuarter | Array of multipliers.
int firstYeart | First year of data to multiply.
int lastYeart | Last year of data to multiply.
Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


FloatQuarter::read Method

FloatQuarter::read Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Reads array from an open stream.

C++
void read(
    std::istream& in,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
std::istream& in | Input stream.
int firstYeart | First year of data to read.
int lastYeart | Last year of data to read.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATQTR2 if unable to read data for all specified years.
Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


FloatQuarter::setAt Method

FloatQuarter::setAt Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Sets one value of data.

C++
void setAt(
    const QtrYear& qtrYear,
    float newData
);
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | Year and quarter (0-3) for which data is desired.
float newData | New value of data.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_FLOATQTR1 if year is out of range (only in debug mode).
Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


FloatQuarter::setLineWidth Method

FloatQuarter::setLineWidth Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Initializes output line width.

C++
void setLineWidth(
    int newLineWidth
);
Collapse Expand Parameters
Parameters | Description
int newLineWidth | New output line width.
Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


FloatQuarter::setPrecision Method

FloatQuarter::setPrecision Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Initializes precision on output.

C++
void setPrecision(
    int newPrecision
);
Collapse Expand Parameters
Parameters | Description
int newPrecision | New value of precision on output.
Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


FloatQuarter::setWidth Method

FloatQuarter::setWidth Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Initializes field width.

C++
void setWidth(
    int newWidth
);
Collapse Expand Parameters
Parameters | Description
int newWidth | New value of field width.
Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


FloatQuarter::write Method

FloatQuarter::write Method
FloatQuarter Class FloatQuarter Members FloatQuarter Methods

Writes array to an open stream.

C++
void write(
    std::ostream& out,
    int firstYeart,
    int lastYeart
);
Collapse Expand Parameters
Parameters | Description
std::ostream& out | Output stream.
int firstYeart | First year of data to write.
int lastYeart | Last year of data to write.
Collapse Expand Group

FloatQuarter Methods

Collapse Expand Links
FloatQuarter Class, FloatQuarter Members, FloatQuarter Methods


Genfile Class

Genfile Class
Genfile Constructor Genfile Data Members Genfile Methods Genfile Members genfile.h Classes

Manages a generic file.

Collapse Expand Class Hierarchy
  Genfile
C++
class Genfile;
Collapse Expand File

File: genfile.h

Module: Misc Library

Collapse Expand Remarks

This class is meant to be a parent of other classes of files.

Collapse Expand Group

Classes

Collapse Expand Links
Genfile Constructor, Genfile Data Members, Genfile Methods, Genfile Members, genfile.h, Classes


Genfile Members

Genfile Members
Genfile Class Legend Protected Data Members Public Methods

The following tables list the members exposed by Genfile.

Collapse Expand Class

Genfile Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
pathname | Pathname of this file.
Collapse Expand Public Methods
Name | Description
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
getmesg | Returns current status or warning message.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
setmesg | Sets current status or warning message.
~Genfile | Destroys this instance.
Collapse Expand Links
Genfile Class, Legend, Protected Data Members, Public Methods


Genfile Constructor

Genfile Constructor
Genfile Class

Initializes a Genfile, either with default values or with a specified parent directory.

Collapse Expand Description

There are two versions of the Genfile constructor. The version with an argument specifies the parent directory. The default version sets the parent directory to the empty string.

Collapse Expand Overload List
Name | Description
Genfile::Genfile () | Initializes the parent directory to "".
Genfile::Genfile (const std::string&) | Sets the parent directory to the specified directory or path name.
Collapse Expand Class

Genfile Class

Collapse Expand Links
Genfile Class


Genfile::Genfile Constructor ()

Genfile::Genfile Constructor ()
Genfile Class Genfile Members Genfile Constructor

Initializes the parent directory to "".

C++
Genfile();
Collapse Expand Group

Genfile Constructor

Collapse Expand Links
Genfile Class, Genfile Members, Genfile Constructor


Genfile::Genfile Constructor (const std::string&)

Genfile::Genfile Constructor (const std::string&)
Genfile Class Genfile Members Genfile Constructor

Sets the parent directory to the specified directory or path name.

C++
explicit Genfile(
    const std::string& newDirectory
);
Collapse Expand Parameters
Parameters | Description
const std::string& newDirectory | New parent directory or full path name.
Collapse Expand Group

Genfile Constructor

Collapse Expand Links
Genfile Class, Genfile Members, Genfile Constructor


Genfile::~Genfile Destructor

Genfile::~Genfile Destructor
Genfile Class Genfile Members Genfile Class

Destroys this instance.

C++
virtual ~Genfile();
Collapse Expand Class

Genfile Class

Collapse Expand Links
Genfile Class, Genfile Members, Genfile Class


Genfile Data Members

Genfile Data Members
Genfile Class Legend Protected Data Members

The data members of the Genfile class are listed here.

Collapse Expand Class

Genfile Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
pathname | Pathname of this file.
Collapse Expand Links
Genfile Class, Legend, Protected Data Members


Genfile::pathname Data Member

Genfile::pathname Data Member
Genfile Class Genfile Members Genfile Data Members

Pathname of this file.

C++
std::string pathname;
Collapse Expand Group

Genfile Data Members

Collapse Expand Links
Genfile Class, Genfile Members, Genfile Data Members


Genfile Methods

Genfile Methods
Genfile Class Legend Public Methods

The methods of the Genfile class are listed here.

Collapse Expand Class

Genfile Class

Collapse Expand Public Methods
Name | Description
getmesg | Returns current status or warning message.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
setmesg | Sets current status or warning message.
Collapse Expand Links
Genfile Class, Legend, Public Methods


Genfile::getmesg Method

Genfile::getmesg Method
Genfile Class Genfile Members Genfile Methods

Returns current status or warning message.

C++
const std::string& getmesg() const;
Collapse Expand Returns

Current status or warning message.

Collapse Expand Group

Genfile Methods

Collapse Expand Links
Genfile Class, Genfile Members, Genfile Methods


Genfile::openapp Method

Genfile::openapp Method
Genfile Class Genfile Members Genfile Methods

Opens a file for appended output with fixed fields for floats.

C++
void openapp(
    std::ofstream& out
);
Collapse Expand Parameters
Parameters | Description
std::ofstream& out | Output stream.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_GENFILE2 if unable to open file.
Collapse Expand Group

Genfile Methods

Collapse Expand Links
Genfile Class, Genfile Members, Genfile Methods


Genfile::openin Method

Genfile::openin Method
Genfile Class Genfile Members Genfile Methods

Opens a file for input.

C++
void openin(
    std::ifstream& in
);
Collapse Expand Parameters
Parameters | Description
std::ifstream& in | Input stream.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_GENFILE3 if unable to open file.
Collapse Expand Group

Genfile Methods

Collapse Expand Links
Genfile Class, Genfile Members, Genfile Methods


Genfile::openout Method

Genfile::openout Method
Genfile Class Genfile Members Genfile Methods

Opens a file for output with fixed fields for floats.

C++
void openout(
    std::ofstream& out
);
Collapse Expand Parameters
Parameters | Description
std::ofstream& out | Output stream.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_GENFILE1 if unable to open file.
Collapse Expand Group

Genfile Methods

Collapse Expand Links
Genfile Class, Genfile Members, Genfile Methods


Genfile::setmesg Method

Genfile::setmesg Method
Genfile Class Genfile Members Genfile Methods

Sets current status or warning message.

C++
void setmesg(
    const std::string& newMesg
);
Collapse Expand Parameters
Parameters | Description
const std::string& newMesg | New message.
Collapse Expand Group

Genfile Methods

Collapse Expand Links
Genfile Class, Genfile Members, Genfile Methods


IntAnnual Class

IntAnnual Class
IntAnnual Data Members IntAnnual Methods IntAnnual Operators IntAnnual Members intann.h Classes

Manages an array of annual integers.

Collapse Expand Class Hierarchy
  IntAnnual
C++
class IntAnnual;
Collapse Expand File

File: intann.h

Module: Misc Library

Collapse Expand Remarks

See DoubleAnnual and FloatAnnual for similar classes that manage arrays of annual doubles and floats.

Collapse Expand See Also

DoubleAnnual, FloatAnnual

Collapse Expand Group

Classes

Collapse Expand Links
IntAnnual Data Members, IntAnnual Methods, IntAnnual Operators, IntAnnual Members, intann.h, Classes


IntAnnual Members

IntAnnual Members
IntAnnual Class Legend Public Data Members Public Methods

The following tables list the members exposed by IntAnnual.

Collapse Expand Class

IntAnnual Class

Collapse Expand Public Data Members
Name | Description
baseYear | Base year of data.
theData | Integer array.
Collapse Expand Public Methods
Name | Description
IntAnnual | Constructor.
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
~IntAnnual | Destructor.
Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
IntAnnual Class, Legend, Public Data Members, Public Methods


IntAnnual::IntAnnual Constructor

IntAnnual::IntAnnual Constructor
IntAnnual Class IntAnnual Members IntAnnual Class

Constructor.

C++
IntAnnual(
    int newBaseYear,
    int newLastYear
);
Collapse Expand Parameters
Parameters | Description
int newBaseYear | New base year.
int newLastYear | New last year.
Collapse Expand Remarks

Sets the base year of data, and initializes the size of the data vector to the span of years.

Collapse Expand Class

IntAnnual Class

Collapse Expand Links
IntAnnual Class, IntAnnual Members, IntAnnual Class


IntAnnual::~IntAnnual Destructor

IntAnnual::~IntAnnual Destructor
IntAnnual Class IntAnnual Members IntAnnual Class

Destructor.

C++
~IntAnnual();
Collapse Expand Class

IntAnnual Class

Collapse Expand Links
IntAnnual Class, IntAnnual Members, IntAnnual Class


IntAnnual Data Members

IntAnnual Data Members
IntAnnual Class Legend Public Data Members

The data members of the IntAnnual class are listed here.

Collapse Expand Class

IntAnnual Class

Collapse Expand Public Data Members
Name | Description
baseYear | Base year of data.
theData | Integer array.
Collapse Expand Links
IntAnnual Class, Legend, Public Data Members


IntAnnual::baseYear Data Member

IntAnnual::baseYear Data Member
IntAnnual Class IntAnnual Members IntAnnual Data Members

Base year of data.

C++
const int baseYear;
Collapse Expand Group

IntAnnual Data Members

Collapse Expand Links
IntAnnual Class, IntAnnual Members, IntAnnual Data Members


IntAnnual::theData Data Member

IntAnnual::theData Data Member
IntAnnual Class IntAnnual Members IntAnnual Data Members

Integer array.

C++
std::vector< int > theData;
Collapse Expand Group

IntAnnual Data Members

Collapse Expand Links
IntAnnual Class, IntAnnual Members, IntAnnual Data Members


IntAnnual Methods

IntAnnual Methods
IntAnnual Class Legend Public Methods

The methods of the IntAnnual class are listed here.

Collapse Expand Class

IntAnnual Class

Collapse Expand Public Methods
Name | Description
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
Collapse Expand Links
IntAnnual Class, Legend, Public Methods


assign Method

assign Method
IntAnnual Methods

Functions to assign data for a range of years.

Collapse Expand Description

There are two versions of the assign method. In both versions, the range of years is specified by two arguments. The other argument, supplying the data to be copied, can be a constant integer or another IntAnnual.

Collapse Expand Overload List
Name | Description
IntAnnual::assign (const IntAnnual&, int, int) | Sets data for specified years from another IntAnnual.
IntAnnual::assign (int, int, int) | Sets data for specified years from one value that is constant for all years.
Collapse Expand Group

IntAnnual Methods

Collapse Expand Links
IntAnnual Methods


IntAnnual::assign Method (const IntAnnual&, int, int)

IntAnnual::assign Method (const IntAnnual&, int, int)
IntAnnual Class IntAnnual Members assign Method

Sets data for specified years from another IntAnnual.

C++
void assign(
    const IntAnnual& intAnnual,
    int firstYear,
    int lastYear
);
Collapse Expand Parameters
Parameters | Description
const IntAnnual& intAnnual | Array of new values of data.
int firstYear | First year of data to set.
int lastYear | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
IntAnnual Class, IntAnnual Members, assign Method


IntAnnual::assign Method (int, int, int)

IntAnnual::assign Method (int, int, int)
IntAnnual Class IntAnnual Members assign Method

Sets data for specified years from one value that is constant for all years.

C++
void assign(
    int newData,
    int firstYear,
    int lastYear
);
Collapse Expand Parameters
Parameters | Description
int newData | New value of data to be used for all specified years.
int firstYear | First year of data to set.
int lastYear | Last year of data to set.
Collapse Expand Group

assign Method

Collapse Expand Links
IntAnnual Class, IntAnnual Members, assign Method


IntAnnual::fill Method

IntAnnual::fill Method
IntAnnual Class IntAnnual Members IntAnnual Methods

Fills all data slots with the given value.

C++
void fill(
    int value
);
Collapse Expand Parameters
Parameters | Description
int value | The value to fill the data slots with.
Collapse Expand Group

IntAnnual Methods

Collapse Expand Links
IntAnnual Class, IntAnnual Members, IntAnnual Methods


IntAnnual::getBaseYear Method

IntAnnual::getBaseYear Method
IntAnnual Class IntAnnual Members IntAnnual Methods

Returns base year of data.

C++
int getBaseYear() const;
Collapse Expand Returns

Base year of data.

Collapse Expand Group

IntAnnual Methods

Collapse Expand Links
IntAnnual Class, IntAnnual Members, IntAnnual Methods


IntAnnual::getLastYear Method

IntAnnual::getLastYear Method
IntAnnual Class IntAnnual Members IntAnnual Methods

Returns last year of data.

C++
int getLastYear() const;
Collapse Expand Returns

Last year of data.

Collapse Expand Remarks

This is the base year plus the size of the data array, minus 1. Note that this is less than the base year if the size is zero.

Collapse Expand Group

IntAnnual Methods

Collapse Expand Links
IntAnnual Class, IntAnnual Members, IntAnnual Methods


IntAnnual Operators

IntAnnual Operators
IntAnnual Class Legend

The operators of the IntAnnual class are listed here.

Collapse Expand Class

IntAnnual Class

Collapse Expand Public Operators
Name | Description
[] | Functions to access an element of the array.
Collapse Expand Links
IntAnnual Class, Legend


[] Operator

[] Operator
IntAnnual Operators

Functions to access an element of the array.

Collapse Expand Description

There are two versions of the [] operator. They differ only in that one is const and the other is not, so that they can be used in both const and non-const settings.

Collapse Expand Overload List
Name | Description
IntAnnual::[] (int) | Returns one value of data, non const version.
IntAnnual::[] (int) | Returns one value of data, const version.
Collapse Expand Group

IntAnnual Operators

Collapse Expand Links
IntAnnual Operators


IntAnnual::[] Operator (int)

IntAnnual::[] Operator (int)
IntAnnual Class IntAnnual Members [] Operator

Returns one value of data, non const version.

C++
int& operator [](
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Year for which data is desired.
Collapse Expand Returns

One value of data for specified year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_INTANN1 if year is out of range (only in debug mode).
Collapse Expand Group

[] Operator

Collapse Expand Links
IntAnnual Class, IntAnnual Members, [] Operator


IntAnnual::[] Operator (int)

IntAnnual::[] Operator (int)
IntAnnual Class IntAnnual Members [] Operator

Returns one value of data, const version.

C++
const int operator [](
    int year
) const;
Collapse Expand Parameters
Parameters | Description
int year | Year for which data is desired.
Collapse Expand Returns

One value of data for specified year.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_INTANN1 if year is out of range (only in debug mode).
Collapse Expand Group

[] Operator

Collapse Expand Links
IntAnnual Class, IntAnnual Members, [] Operator


Out132 Class

Out132 Class
Out132 Methods Out132 Members outfile.h Classes

An Outfile tailored for 132-column output.

Collapse Expand Class Hierarchy
  Out132Out132Out132Out132
C++
class Out132 : public Outfile;
Collapse Expand File

File: outfile.h

Module: Misc Library

Collapse Expand Remarks

This is an abstract class; one of its subclasses (OutFile132) should be instantiated.

Collapse Expand See Also

OutFile132

Collapse Expand Group

Classes

Collapse Expand Links
Out132 Methods, Out132 Members, outfile.h, Classes


Out132 Members

Out132 Members
Out132 Class Legend Protected Data Members Public Methods

The following tables list the members exposed by Out132.

Collapse Expand Class

Out132 Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
PAGE_TITLE_LINES | Number of title lines.
dateModyyr | The current date as month, day, and year.
outstrm | Output stream.
pageNum | Page number.
pathname | Pathname of this file.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
Out132 | Initializes output file core name and extension.
Outfile | Initializes an Outfile, where the parent directory is either specified or default.
advanceLine | Move to next line.
closeout | Closes output file.
errormesg | Returns message when error reading from file.
footer | Does nothing.
formfeed | Move to next page.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPageNum | Returns page number.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
gettitle | Returns one page title line.
header | Does nothing.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
openout | Opens output file.
pgtitle | Writes date, time, 2-line title, and page to 132-column print file.
prepareStrings | Prepares the two-line title strings for output.
printLine | Prints a line of output with a carriage return.
printLinena | Prints a line of output without a carriage return.
readmesg | Returns message when reading from file.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPageNum | Sets page number.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
settitle | Sets one page title line.
writemesg | Returns message when writing to file.
Collapse Expand Links
Out132 Class, Legend, Protected Data Members, Public Methods


Out132::Out132 Constructor

Out132::Out132 Constructor
Out132 Class Out132 Members Out132 Class

Initializes output file core name and extension.

C++
Out132(
    const std::string& newCorename,
    const std::string& newExtension
);
Collapse Expand Parameters
Parameters | Description
const std::string& newCorename | New core file name.
const std::string& newExtension | New extension on the file name.
Collapse Expand Class

Out132 Class

Collapse Expand Links
Out132 Class, Out132 Members, Out132 Class


Out132 Methods

Out132 Methods
Out132 Class Legend Public Methods

The methods of the Out132 class are listed here.

Collapse Expand Class

Out132 Class

Collapse Expand Public Methods
Name | Description
footer | Does nothing.
header | Does nothing.
pgtitle | Writes date, time, 2-line title, and page to 132-column print file.
prepareStrings | Prepares the two-line title strings for output.
Collapse Expand Links
Out132 Class, Legend, Public Methods


Out132::footer Method

Out132::footer Method
Out132 Class Out132 Members Out132 Methods

Does nothing.

C++
void footer();
Collapse Expand Group

Out132 Methods

Collapse Expand Links
Out132 Class, Out132 Members, Out132 Methods


Out132::header Method

Out132::header Method
Out132 Class Out132 Members Out132 Methods

Does nothing.

C++
void header(
    const std::string&
);
Collapse Expand Group

Out132 Methods

Collapse Expand Links
Out132 Class, Out132 Members, Out132 Methods


Out132::pgtitle Method

Out132::pgtitle Method
Out132 Class Out132 Members Out132 Methods

Writes date, time, 2-line title, and page to 132-column print file.

C++
void pgtitle();
Collapse Expand Remarks

Prints the two-line title, along with the date, time, and page counter. Then prints two blank lines.

Collapse Expand Group

Out132 Methods

Collapse Expand Links
Out132 Class, Out132 Members, Out132 Methods


Out132::prepareStrings Method

Out132::prepareStrings Method
Out132 Class Out132 Members Out132 Methods

Prepares the two-line title strings for output.

C++
static void prepareStrings(
    std::string* stringTable,
    int* count,
    int* pageNum,
    const std::string* newPageTitle
);
Collapse Expand Parameters
Parameters | Description
std::string* stringTable | String table to put results into.
int* count | Output count of number of lines prepared.
int* pageNum | Page counter.
const std::string* newPageTitle | Title array (length 2).
Collapse Expand Remarks

Puts the specified titles in the next two strings in the specified string table, along with the date, time, and page counter. Then adds two blank lines to the string table.

Collapse Expand Group

Out132 Methods

Collapse Expand Links
Out132 Class, Out132 Members, Out132 Methods


Out80 Class

Out80 Class
Out80 Methods Out80 Members outfile.h Classes

An Outfile tailored for 80-column output.

Collapse Expand Class Hierarchy
  Out80Out80Out80Out80
C++
class Out80 : public Outfile;
Collapse Expand File

File: outfile.h

Module: Misc Library

Collapse Expand Remarks

This is an abstract class; one of its subclasses (OutFile80 or OutDC80) should be instantiated.

Collapse Expand See Also

OutFile80, OutDC80

Collapse Expand Group

Classes

Collapse Expand Links
Out80 Methods, Out80 Members, outfile.h, Classes


Out80 Members

Out80 Members
Out80 Class Legend Protected Data Members Public Methods

The following tables list the members exposed by Out80.

Collapse Expand Class

Out80 Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
PAGE_TITLE_LINES | Number of title lines.
dateModyyr | The current date as month, day, and year.
outstrm | Output stream.
pageNum | Page number.
pathname | Pathname of this file.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
Out80 | Initializes output file core name and extension.
Outfile | Initializes an Outfile, where the parent directory is either specified or default.
advanceLine | Move to next line.
closeout | Closes output file.
errormesg | Returns message when error reading from file.
footer | Does nothing.
formfeed | Move to next page.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPageNum | Returns page number.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
gettitle | Returns one page title line.
header | Does nothing.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
openout | Opens output file.
pgtitle | Writes date, time, 1-line title, and page to 80-column print file.
prepareStrings | Prepares the two-line title strings for output.
printLine | Prints a line of output with a carriage return.
printLinena | Prints a line of output without a carriage return.
readmesg | Returns message when reading from file.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPageNum | Sets page number.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
settitle | Sets one page title line.
writemesg | Returns message when writing to file.
Collapse Expand Links
Out80 Class, Legend, Protected Data Members, Public Methods


Out80::Out80 Constructor

Out80::Out80 Constructor
Out80 Class Out80 Members Out80 Class

Initializes output file core name and extension.

C++
Out80(
    const std::string& newCorename,
    const std::string& newExtension
);
Collapse Expand Parameters
Parameters | Description
const std::string& newCorename | New core file name.
const std::string& newExtension | New extension on the file name.
Collapse Expand Class

Out80 Class

Collapse Expand Links
Out80 Class, Out80 Members, Out80 Class


Out80 Methods

Out80 Methods
Out80 Class Legend Public Methods

The methods of the Out80 class are listed here.

Collapse Expand Class

Out80 Class

Collapse Expand Public Methods
Name | Description
footer | Does nothing.
header | Does nothing.
pgtitle | Writes date, time, 1-line title, and page to 80-column print file.
prepareStrings | Prepares the two-line title strings for output.
Collapse Expand Links
Out80 Class, Legend, Public Methods


Out80::footer Method

Out80::footer Method
Out80 Class Out80 Members Out80 Methods

Does nothing.

C++
void footer();
Collapse Expand Group

Out80 Methods

Collapse Expand Links
Out80 Class, Out80 Members, Out80 Methods


Out80::header Method

Out80::header Method
Out80 Class Out80 Members Out80 Methods

Does nothing.

C++
void header(
    const std::string&
);
Collapse Expand Group

Out80 Methods

Collapse Expand Links
Out80 Class, Out80 Members, Out80 Methods


Out80::pgtitle Method

Out80::pgtitle Method
Out80 Class Out80 Members Out80 Methods

Writes date, time, 1-line title, and page to 80-column print file.

C++
void pgtitle();
Collapse Expand Group

Out80 Methods

Collapse Expand Links
Out80 Class, Out80 Members, Out80 Methods


Out80::prepareStrings Method

Out80::prepareStrings Method
Out80 Class Out80 Members Out80 Methods

Prepares the two-line title strings for output.

C++
static void prepareStrings(
    std::string* stringTable,
    int* count,
    int* pageNum,
    const std::string* newPageTitle
);
Collapse Expand Parameters
Parameters | Description
std::string* stringTable | String table to put results into.
int* count | Output count of number of lines prepared.
int* pageNum | Page counter.
const std::string* newPageTitle | Title array (length 2).
Collapse Expand Remarks

Puts the specified titles in the next two strings in the specified string table, along with the date, time, and page counter. Then adds two blank lines to the string table.

Collapse Expand Group

Out80 Methods

Collapse Expand Links
Out80 Class, Out80 Members, Out80 Methods


OutDC80 Class

OutDC80 Class
OutDC80 Methods OutDC80 Members OutDC.h Classes

Handles output to a Windows window.

Collapse Expand Class Hierarchy
  OutDC80OutDC80OutDC80OutDC80OutDC80
C++
class OutDC80 : public Out80;
Collapse Expand File

File: OutDC.h

Module: Misc Library

Collapse Expand Remarks

Handles output to a Windows window.

Collapse Expand Group

Classes

Collapse Expand Links
OutDC80 Methods, OutDC80 Members, OutDC.h, Classes


OutDC80 Members

OutDC80 Members
OutDC80 Class Legend Protected Data Members Public Methods

The following tables list the members exposed by OutDC80.

Collapse Expand Class

OutDC80 Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
PAGE_TITLE_LINES | Number of title lines.
dateModyyr | The current date as month, day, and year.
outstrm | Output stream.
pageNum | Page number.
pathname | Pathname of this file.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
OutDC80 | Initializes a new OutDC.
Outfile | Initializes an Outfile, where the parent directory is either specified or default.
advanceLine | Advances one line.
closeout | Closes output file.
errormesg | Returns message when error reading from file.
footer | Does nothing.
footer | Writes a footer to a print file.
formfeed | Dummy function.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPageNum | Returns page number.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
gettitle | Returns one page title line.
header | Does nothing.
header | Writes a heading line to a print file.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
openout | Opens output file.
pgtitle | Writes date, time, 1-line title, and page to 80-column print file.
pgtitle | Writes date, time, title, and page to print file.
prepareStrings | Prepares the two-line title strings for output.
printLine | Prints one line of text with a carriage return.
printLine | Prints a line of output with a carriage return.
printLinena | Prints one line of text without a carriage return.
printLinena | Prints a line of output without a carriage return.
readmesg | Returns message when reading from file.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setDC | Sets device context to use.
setExtension | Sets the extension on the file name.
setHeight | Sets height of one line.
setModifier | Sets the modifier on the file name.
setPageNum | Sets page number.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
settitle | Sets one page title line.
setx | Sets horizontal margin.
sety | Sets vertical margin.
writemesg | Returns message when writing to file.
Collapse Expand Links
OutDC80 Class, Legend, Protected Data Members, Public Methods


OutDC80::OutDC80 Constructor

OutDC80::OutDC80 Constructor
OutDC80 Class OutDC80 Members OutDC80 Class

Initializes a new OutDC.

C++
OutDC80();
Collapse Expand Class

OutDC80 Class

Collapse Expand Links
OutDC80 Class, OutDC80 Members, OutDC80 Class


OutDC80 Methods

OutDC80 Methods
OutDC80 Class Legend Public Methods

The methods of the OutDC80 class are listed here.

Collapse Expand Class

OutDC80 Class

Collapse Expand Public Methods
Name | Description
advanceLine | Advances one line.
formfeed | Dummy function.
printLine | Prints one line of text with a carriage return.
printLinena | Prints one line of text without a carriage return.
setDC | Sets device context to use.
setHeight | Sets height of one line.
setx | Sets horizontal margin.
sety | Sets vertical margin.
Collapse Expand Links
OutDC80 Class, Legend, Public Methods


OutDC80::advanceLine Method

OutDC80::advanceLine Method
OutDC80 Class OutDC80 Members OutDC80 Methods

Advances one line.

C++
void advanceLine();
Collapse Expand Group

OutDC80 Methods

Collapse Expand Links
OutDC80 Class, OutDC80 Members, OutDC80 Methods


OutDC80::formfeed Method

OutDC80::formfeed Method
OutDC80 Class OutDC80 Members OutDC80 Methods

Dummy function.

C++
void formfeed();
Collapse Expand Group

OutDC80 Methods

Collapse Expand Links
OutDC80 Class, OutDC80 Members, OutDC80 Methods


printLine Method

printLine Method
OutDC80 Methods

Prints one line of text with a carriage return.

Collapse Expand Description

There are two versions of this function, printing either a C-style string or a C++ style string.

Collapse Expand Overload List
Name | Description
OutDC80::printLine (const char*) | Prints one line of text with a newline.
OutDC80::printLine (const std::string&) | Prints one line of text with a newline.
Collapse Expand Group

OutDC80 Methods

Collapse Expand Links
OutDC80 Methods


OutDC80::printLine Method (const char*)

OutDC80::printLine Method (const char*)
OutDC80 Class OutDC80 Members printLine Method

Prints one line of text with a newline.

C++
void printLine(
    const char* temp
);
Collapse Expand Parameters
Parameters | Description
const char* temp | Line of text to print.
Collapse Expand Group

printLine Method

Collapse Expand Links
OutDC80 Class, OutDC80 Members, printLine Method


OutDC80::printLine Method (const std::string&)

OutDC80::printLine Method (const std::string&)
OutDC80 Class OutDC80 Members printLine Method

Prints one line of text with a newline.

C++
void printLine(
    const std::string& str
);
Collapse Expand Parameters
Parameters | Description
const std::string& str | Line of text to print.
Collapse Expand Group

printLine Method

Collapse Expand Links
OutDC80 Class, OutDC80 Members, printLine Method


printLinena Method

printLinena Method
OutDC80 Methods

Prints one line of text without a carriage return.

Collapse Expand Description

There are two versions of this function, printing either a C-style string or a C++ style string.

Collapse Expand Overload List
Name | Description
OutDC80::printLinena (const char*) | Prints one line of text without newline.
OutDC80::printLinena (const std::string&) | Prints one line of text without newline.
Collapse Expand Group

OutDC80 Methods

Collapse Expand Links
OutDC80 Methods


OutDC80::printLinena Method (const char*)

OutDC80::printLinena Method (const char*)
OutDC80 Class OutDC80 Members printLinena Method

Prints one line of text without newline.

C++
void printLinena(
    const char* temp
);
Collapse Expand Parameters
Parameters | Description
const char* temp | Line of text to print.
Collapse Expand Group

printLinena Method

Collapse Expand Links
OutDC80 Class, OutDC80 Members, printLinena Method


OutDC80::printLinena Method (const std::string&)

OutDC80::printLinena Method (const std::string&)
OutDC80 Class OutDC80 Members printLinena Method

Prints one line of text without newline.

C++
void printLinena(
    const std::string& str
);
Collapse Expand Parameters
Parameters | Description
const std::string& str | Line of text to print.
Collapse Expand Group

printLinena Method

Collapse Expand Links
OutDC80 Class, OutDC80 Members, printLinena Method


OutDC80::setDC Method

OutDC80::setDC Method
OutDC80 Class OutDC80 Members OutDC80 Methods

Sets device context to use.

C++
void setDC(
    CDC* newDC
);
Collapse Expand Parameters
Parameters | Description
CDC* newDC | New device context to use.
Collapse Expand Group

OutDC80 Methods

Collapse Expand Links
OutDC80 Class, OutDC80 Members, OutDC80 Methods


OutDC80::setHeight Method

OutDC80::setHeight Method
OutDC80 Class OutDC80 Members OutDC80 Methods

Sets height of one line.

C++
void setHeight(
    int newht
);
Collapse Expand Parameters
Parameters | Description
int newht | New height of one line.
Collapse Expand Group

OutDC80 Methods

Collapse Expand Links
OutDC80 Class, OutDC80 Members, OutDC80 Methods


OutDC80::setx Method

OutDC80::setx Method
OutDC80 Class OutDC80 Members OutDC80 Methods

Sets horizontal margin.

C++
void setx(
    int newx
);
Collapse Expand Parameters
Parameters | Description
int newx | New horizontal margin.
Collapse Expand Group

OutDC80 Methods

Collapse Expand Links
OutDC80 Class, OutDC80 Members, OutDC80 Methods


OutDC80::sety Method

OutDC80::sety Method
OutDC80 Class OutDC80 Members OutDC80 Methods

Sets vertical margin.

C++
void sety(
    int newy
);
Collapse Expand Parameters
Parameters | Description
int newy | New vertical margin.
Collapse Expand Group

OutDC80 Methods

Collapse Expand Links
OutDC80 Class, OutDC80 Members, OutDC80 Methods


OutFile132 Class

OutFile132 Class
OutFile132 Constructor OutFile132 Methods OutFile132 Members OutFile132.h Classes

Manages the print output functions, when printing to a file formatted for 132 columns.

Collapse Expand Class Hierarchy
  OutFile132OutFile132OutFile132OutFile132OutFile132
C++
class OutFile132 : public Out132;
Collapse Expand File

File: OutFile132.h

Module: Misc Library

Collapse Expand Remarks

Manages the print output functions, when printing to a file formatted for 132 columns.

Collapse Expand Group

Classes

Collapse Expand Links
OutFile132 Constructor, OutFile132 Methods, OutFile132 Members, OutFile132.h, Classes


OutFile132 Members

OutFile132 Members
OutFile132 Class Legend Protected Data Members Public Methods

The following tables list the members exposed by OutFile132.

Collapse Expand Class

OutFile132 Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
PAGE_TITLE_LINES | Number of title lines.
dateModyyr | The current date as month, day, and year.
outstrm | Output stream.
pageNum | Page number.
pathname | Pathname of this file.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
OutFile132 | Initializes an OutFile132.
Outfile | Initializes an Outfile, where the parent directory is either specified or default.
advanceLine | Advances one line.
closeout | Closes output file.
errormesg | Returns message when error reading from file.
footer | Does nothing.
footer | Writes a footer to a print file.
formfeed | Advances to next page.
getColString | Returns left-hand margin string.
getCols | Returns number of columns to space over on left side.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPageNum | Returns page number.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
gettitle | Returns one page title line.
header | Does nothing.
header | Writes a heading line to a print file.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
openout | Opens output file.
pgtitle | Writes date, time, 2-line title, and page to 132-column print file.
pgtitle | Writes date, time, title, and page to print file.
prepareStrings | Prepares the two-line title strings for output.
printLine | Prints a line of output with a carriage return.
printLine | Prints a line of output with a carriage return.
printLinena | Prints a line of output without a carriage return.
printLinena | Prints a line of output without a carriage return.
readmesg | Returns message when reading from file.
setCols | Sets number of columns on left-hand margin.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPageNum | Sets page number.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
settitle | Sets one page title line.
writemesg | Returns message when writing to file.
~OutFile132 | Destructor.
Collapse Expand Links
OutFile132 Class, Legend, Protected Data Members, Public Methods


OutFile132 Constructor

OutFile132 Constructor
OutFile132 Class

Initializes an OutFile132.

Collapse Expand Description

There are two versions of the OutFile132 constructor. Both take a core file name, but one also takes a file name extension. If not provided, the file name extension is ".out".

Collapse Expand Overload List
Name | Description
OutFile132::OutFile132 (const std::string&) | Initializes the core file name, using an extension of ".out".
OutFile132::OutFile132 (const std::string&, const std::string&) | Initializes the core file name and extension.
Collapse Expand Class

OutFile132 Class

Collapse Expand Links
OutFile132 Class


OutFile132::OutFile132 Constructor (const std::string&)

OutFile132::OutFile132 Constructor (const std::string&)
OutFile132 Class OutFile132 Members OutFile132 Constructor

Initializes the core file name, using an extension of ".out".

C++
OutFile132(
    const std::string& newCorename = std::string("")
);
Collapse Expand Parameters
Parameters | Description
const std::string& newCorename = std::string("") | New core file name.
Collapse Expand Group

OutFile132 Constructor

Collapse Expand Links
OutFile132 Class, OutFile132 Members, OutFile132 Constructor


OutFile132::OutFile132 Constructor (const std::string&, const std::string&)

OutFile132::OutFile132 Constructor (const std::string&, const std::string&)
OutFile132 Class OutFile132 Members OutFile132 Constructor

Initializes the core file name and extension.

C++
OutFile132(
    const std::string& newCorename,
    const std::string& newExtension
);
Collapse Expand Parameters
Parameters | Description
const std::string& newCorename | New core file name.
const std::string& newExtension | New extension on the file name.
Collapse Expand Group

OutFile132 Constructor

Collapse Expand Links
OutFile132 Class, OutFile132 Members, OutFile132 Constructor


OutFile132::~OutFile132 Destructor

OutFile132::~OutFile132 Destructor
OutFile132 Class OutFile132 Members OutFile132 Class

Destructor.

C++
~OutFile132();
Collapse Expand Class

OutFile132 Class

Collapse Expand Links
OutFile132 Class, OutFile132 Members, OutFile132 Class


OutFile132 Methods

OutFile132 Methods
OutFile132 Class Legend Public Methods

The methods of the OutFile132 class are listed here.

Collapse Expand Class

OutFile132 Class

Collapse Expand Public Methods
Name | Description
advanceLine | Advances one line.
formfeed | Advances to next page.
getColString | Returns left-hand margin string.
getCols | Returns number of columns to space over on left side.
printLine | Prints a line of output with a carriage return.
printLinena | Prints a line of output without a carriage return.
setCols | Sets number of columns on left-hand margin.
Collapse Expand Links
OutFile132 Class, Legend, Public Methods


OutFile132::advanceLine Method

OutFile132::advanceLine Method
OutFile132 Class OutFile132 Members OutFile132 Methods

Advances one line.

C++
void advanceLine();
Collapse Expand Group

OutFile132 Methods

Collapse Expand Links
OutFile132 Class, OutFile132 Members, OutFile132 Methods


OutFile132::formfeed Method

OutFile132::formfeed Method
OutFile132 Class OutFile132 Members OutFile132 Methods

Advances to next page.

C++
void formfeed();
Collapse Expand Group

OutFile132 Methods

Collapse Expand Links
OutFile132 Class, OutFile132 Members, OutFile132 Methods


OutFile132::getColString Method

OutFile132::getColString Method
OutFile132 Class OutFile132 Members OutFile132 Methods

Returns left-hand margin string.

C++
const char * getColString() const;
Collapse Expand Returns

Left-hand margin string.

Collapse Expand Group

OutFile132 Methods

Collapse Expand Links
OutFile132 Class, OutFile132 Members, OutFile132 Methods


OutFile132::getCols Method

OutFile132::getCols Method
OutFile132 Class OutFile132 Members OutFile132 Methods

Returns number of columns to space over on left side.

C++
int getCols() const;
Collapse Expand Returns

Number of columns to space over on left side.

Collapse Expand Group

OutFile132 Methods

Collapse Expand Links
OutFile132 Class, OutFile132 Members, OutFile132 Methods


printLine Method

printLine Method
OutFile132 Methods

Prints a line of output with a carriage return.

Collapse Expand Description

There are two versions of this function, where the argument can be a C-style string or a C++ style string.

Collapse Expand Overload List
Name | Description
OutFile132::printLine (const char*) | Prints one line with a carriage return.
OutFile132::printLine (const std::string&) | Prints one line with a carriage return.
Collapse Expand Group

OutFile132 Methods

Collapse Expand Links
OutFile132 Methods


OutFile132::printLine Method (const char*)

OutFile132::printLine Method (const char*)
OutFile132 Class OutFile132 Members printLine Method

Prints one line with a carriage return.

C++
void printLine(
    const char* str
);
Collapse Expand Parameters
Parameters | Description
const char* str | String to print.
Collapse Expand Group

printLine Method

Collapse Expand Links
OutFile132 Class, OutFile132 Members, printLine Method


OutFile132::printLine Method (const std::string&)

OutFile132::printLine Method (const std::string&)
OutFile132 Class OutFile132 Members printLine Method

Prints one line with a carriage return.

C++
void printLine(
    const std::string& str
);
Collapse Expand Parameters
Parameters | Description
const std::string& str | String to print.
Collapse Expand Group

printLine Method

Collapse Expand Links
OutFile132 Class, OutFile132 Members, printLine Method


printLinena Method

printLinena Method
OutFile132 Methods

Prints a line of output without a carriage return.

Collapse Expand Description

There are two versions of this function, where the argument can be a C-style string or a C++ style string.

Collapse Expand Overload List
Name | Description
OutFile132::printLinena (const char*) | Print a line of output with no carriage return.
OutFile132::printLinena (const std::string&) | Print a line of output with no carriage return.
Collapse Expand Group

OutFile132 Methods

Collapse Expand Links
OutFile132 Methods


OutFile132::printLinena Method (const char*)

OutFile132::printLinena Method (const char*)
OutFile132 Class OutFile132 Members printLinena Method

Print a line of output with no carriage return.

C++
void printLinena(
    const char* str
);
Collapse Expand Parameters
Parameters | Description
const char* str | String to print.
Collapse Expand Group

printLinena Method

Collapse Expand Links
OutFile132 Class, OutFile132 Members, printLinena Method


OutFile132::printLinena Method (const std::string&)

OutFile132::printLinena Method (const std::string&)
OutFile132 Class OutFile132 Members printLinena Method

Print a line of output with no carriage return.

C++
void printLinena(
    const std::string& str
);
Collapse Expand Parameters
Parameters | Description
const std::string& str | String to print.
Collapse Expand Group

printLinena Method

Collapse Expand Links
OutFile132 Class, OutFile132 Members, printLinena Method


OutFile132::setCols Method

OutFile132::setCols Method
OutFile132 Class OutFile132 Members OutFile132 Methods

Sets number of columns on left-hand margin.

C++
void setCols(
    int newCols
);
Collapse Expand Parameters
Parameters | Description
int newCols | New number of columns.
Collapse Expand Group

OutFile132 Methods

Collapse Expand Links
OutFile132 Class, OutFile132 Members, OutFile132 Methods


OutFile80 Class

OutFile80 Class
OutFile80 Constructor OutFile80 Methods OutFile80 Members OutFile80.h Classes

Manages the print output functions, when printing to a file formatted for 80 columns.

Collapse Expand Class Hierarchy
  OutFile80OutFile80OutFile80OutFile80OutFile80
C++
class OutFile80 : public Out80;
Collapse Expand File

File: OutFile80.h

Module: Misc Library

Collapse Expand Remarks

Manages the print output functions, when printing to a file formatted for 80 columns.

Collapse Expand Group

Classes

Collapse Expand Links
OutFile80 Constructor, OutFile80 Methods, OutFile80 Members, OutFile80.h, Classes


OutFile80 Members

OutFile80 Members
OutFile80 Class Legend Protected Data Members Public Methods

The following tables list the members exposed by OutFile80.

Collapse Expand Class

OutFile80 Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
PAGE_TITLE_LINES | Number of title lines.
dateModyyr | The current date as month, day, and year.
outstrm | Output stream.
pageNum | Page number.
pathname | Pathname of this file.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
OutFile80 | Initializes an OutFile80.
Outfile | Initializes an Outfile, where the parent directory is either specified or default.
advanceLine | Advances one line.
closeout | Closes output file.
errormesg | Returns message when error reading from file.
footer | Does nothing.
footer | Writes a footer to a print file.
formfeed | Advances to next page.
getColString | Returns left-hand margin string.
getCols | Returns number of columns to space over on left side.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPageNum | Returns page number.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
gettitle | Returns one page title line.
header | Does nothing.
header | Writes a heading line to a print file.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
openout | Opens output file.
pgtitle | Writes date, time, 1-line title, and page to 80-column print file.
pgtitle | Writes date, time, title, and page to print file.
prepareStrings | Prepares the two-line title strings for output.
printLine | Prints a line of output with a carriage return.
printLine | Prints a line of output with a carriage return.
printLinena | Prints a line of output without a carriage return.
printLinena | Prints a line of output without a carriage return.
readmesg | Returns message when reading from file.
setCols | Sets number of columns on left-hand margin.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPageNum | Sets page number.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
settitle | Sets one page title line.
writemesg | Returns message when writing to file.
~OutFile80 | Destructor.
Collapse Expand Links
OutFile80 Class, Legend, Protected Data Members, Public Methods


OutFile80 Constructor

OutFile80 Constructor
OutFile80 Class

Initializes an OutFile80.

Collapse Expand Description

There are two versions of the OutFile80 constructor. Both take a core file name, but one also takes a file name extension. If not provided, the file name extension is ".out".

Collapse Expand Overload List
Name | Description
OutFile80::OutFile80 (const std::string&) | Initializes the core file name, using an extension of ".out".
OutFile80::OutFile80 (const std::string&, const std::string&) | Initializes the core file name and extension.
Collapse Expand Class

OutFile80 Class

Collapse Expand Links
OutFile80 Class


OutFile80::OutFile80 Constructor (const std::string&)

OutFile80::OutFile80 Constructor (const std::string&)
OutFile80 Class OutFile80 Members OutFile80 Constructor

Initializes the core file name, using an extension of ".out".

C++
OutFile80(
    const std::string& newCorename = std::string("")
);
Collapse Expand Parameters
Parameters | Description
const std::string& newCorename = std::string("") | New core file name.
Collapse Expand Group

OutFile80 Constructor

Collapse Expand Links
OutFile80 Class, OutFile80 Members, OutFile80 Constructor


OutFile80::OutFile80 Constructor (const std::string&, const std::string&)

OutFile80::OutFile80 Constructor (const std::string&, const std::string&)
OutFile80 Class OutFile80 Members OutFile80 Constructor

Initializes the core file name and extension.

C++
OutFile80(
    const std::string& newCorename,
    const std::string& newExtension
);
Collapse Expand Parameters
Parameters | Description
const std::string& newCorename | New core file name.
const std::string& newExtension | New extension on the file name.
Collapse Expand Group

OutFile80 Constructor

Collapse Expand Links
OutFile80 Class, OutFile80 Members, OutFile80 Constructor


OutFile80::~OutFile80 Destructor

OutFile80::~OutFile80 Destructor
OutFile80 Class OutFile80 Members OutFile80 Class

Destructor.

C++
~OutFile80();
Collapse Expand Class

OutFile80 Class

Collapse Expand Links
OutFile80 Class, OutFile80 Members, OutFile80 Class


OutFile80 Methods

OutFile80 Methods
OutFile80 Class Legend Public Methods

The methods of the OutFile80 class are listed here.

Collapse Expand Class

OutFile80 Class

Collapse Expand Public Methods
Name | Description
advanceLine | Advances one line.
formfeed | Advances to next page.
getColString | Returns left-hand margin string.
getCols | Returns number of columns to space over on left side.
printLine | Prints a line of output with a carriage return.
printLinena | Prints a line of output without a carriage return.
setCols | Sets number of columns on left-hand margin.
Collapse Expand Links
OutFile80 Class, Legend, Public Methods


OutFile80::advanceLine Method

OutFile80::advanceLine Method
OutFile80 Class OutFile80 Members OutFile80 Methods

Advances one line.

C++
void advanceLine();
Collapse Expand Group

OutFile80 Methods

Collapse Expand Links
OutFile80 Class, OutFile80 Members, OutFile80 Methods


OutFile80::formfeed Method

OutFile80::formfeed Method
OutFile80 Class OutFile80 Members OutFile80 Methods

Advances to next page.

C++
void formfeed();
Collapse Expand Group

OutFile80 Methods

Collapse Expand Links
OutFile80 Class, OutFile80 Members, OutFile80 Methods


OutFile80::getColString Method

OutFile80::getColString Method
OutFile80 Class OutFile80 Members OutFile80 Methods

Returns left-hand margin string.

C++
const char * getColString() const;
Collapse Expand Returns

Left-hand margin string.

Collapse Expand Group

OutFile80 Methods

Collapse Expand Links
OutFile80 Class, OutFile80 Members, OutFile80 Methods


OutFile80::getCols Method

OutFile80::getCols Method
OutFile80 Class OutFile80 Members OutFile80 Methods

Returns number of columns to space over on left side.

C++
int getCols() const;
Collapse Expand Returns

Number of columns to space over on left side.

Collapse Expand Group

OutFile80 Methods

Collapse Expand Links
OutFile80 Class, OutFile80 Members, OutFile80 Methods


printLine Method

printLine Method
OutFile80 Methods

Prints a line of output with a carriage return.

Collapse Expand Description

There are two versions of this function, where the argument can be a C-style string or a C++ style string.

Collapse Expand Overload List
Name | Description
OutFile80::printLine (const char*) | Prints one line with a carriage return.
OutFile80::printLine (const std::string&) | Prints one line with a carriage return.
Collapse Expand Group

OutFile80 Methods

Collapse Expand Links
OutFile80 Methods


OutFile80::printLine Method (const char*)

OutFile80::printLine Method (const char*)
OutFile80 Class OutFile80 Members printLine Method

Prints one line with a carriage return.

C++
void printLine(
    const char* str
);
Collapse Expand Parameters
Parameters | Description
const char* str | String to print.
Collapse Expand Group

printLine Method

Collapse Expand Links
OutFile80 Class, OutFile80 Members, printLine Method


OutFile80::printLine Method (const std::string&)

OutFile80::printLine Method (const std::string&)
OutFile80 Class OutFile80 Members printLine Method

Prints one line with a carriage return.

C++
void printLine(
    const std::string& str
);
Collapse Expand Parameters
Parameters | Description
const std::string& str | String to print.
Collapse Expand Group

printLine Method

Collapse Expand Links
OutFile80 Class, OutFile80 Members, printLine Method


printLinena Method

printLinena Method
OutFile80 Methods

Prints a line of output without a carriage return.

Collapse Expand Description

There are two versions of this function, where the argument can be a C-style string or a C++ style string.

Collapse Expand Overload List
Name | Description
OutFile80::printLinena (const char*) | Prints one line without a carriage return.
OutFile80::printLinena (const std::string&) | Prints one line without a carriage return.
Collapse Expand Group

OutFile80 Methods

Collapse Expand Links
OutFile80 Methods


OutFile80::printLinena Method (const char*)

OutFile80::printLinena Method (const char*)
OutFile80 Class OutFile80 Members printLinena Method

Prints one line without a carriage return.

C++
void printLinena(
    const char* str
);
Collapse Expand Parameters
Parameters | Description
const char* str | String to print.
Collapse Expand Group

printLinena Method

Collapse Expand Links
OutFile80 Class, OutFile80 Members, printLinena Method


OutFile80::printLinena Method (const std::string&)

OutFile80::printLinena Method (const std::string&)
OutFile80 Class OutFile80 Members printLinena Method

Prints one line without a carriage return.

C++
void printLinena(
    const std::string& str
);
Collapse Expand Parameters
Parameters | Description
const std::string& str | String to print.
Collapse Expand Group

printLinena Method

Collapse Expand Links
OutFile80 Class, OutFile80 Members, printLinena Method


OutFile80::setCols Method

OutFile80::setCols Method
OutFile80 Class OutFile80 Members OutFile80 Methods

Sets number of columns on left-hand margin.

C++
void setCols(
    int newCols
);
Collapse Expand Parameters
Parameters | Description
int newCols | New number of columns.
Collapse Expand Group

OutFile80 Methods

Collapse Expand Links
OutFile80 Class, OutFile80 Members, OutFile80 Methods


OutFileHTML Class

OutFileHTML Class
OutFileHTML Data Members OutFileHTML Methods OutFileHTML Members OutfileHTML.h Classes

Manages the print output functions, when printing to an HTML file.

Collapse Expand Class Hierarchy
  OutFileHTML
C++
class OutFileHTML;
Collapse Expand File

File: OutfileHTML.h

Module: Misc Library

Collapse Expand Remarks

Manages the print output functions, when printing to an HTML file.

Collapse Expand Group

Classes

Collapse Expand Links
OutFileHTML Data Members, OutFileHTML Methods, OutFileHTML Members, OutfileHTML.h, Classes


OutFileHTML Members

OutFileHTML Members
OutFileHTML Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by OutFileHTML.

Collapse Expand Class

OutFileHTML Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
firstPage | Indicator for first page of output.
Collapse Expand Public Data Members
Name | Description
PAGE_TITLE_LINES | Number of title lines.
cssPage | The CSS page.
tagRightChar | Represents the closing angle-bracket of an HTML tag.
Collapse Expand Public Methods
Name | Description
OutFileHTML | Constructor.
closeFile | Close the output file.
doHeader | Writes html header information.
gettitle | Returns one page title line.
openFile | Opens output file.
pgtitle | Writes title to html file.
settitle | Sets one page title line.
write | Prints the specified argument without a carriage return.
writeAttribute | Writes an HTML attribute and its value.
writeBeginGrayRow | Writes gray row starting information.
writeBeginTable | Writes the HTML for the start of a table.
writeBeginTag | Writes the opening tag of the specified HTML element.
writeCellBody | Writes the HTML for the contents of one cell in a table, left-justified.
writeCellBodyColSpan | Writes the html for a string as the contents of one cell in a table, left-justified, spanning columns.
writeCellBodyRight | Writes the HTML for the contents of one cell in a table, right-justified.
writeCellHeading | Writes the HTML for the contents of one heading in a table.
writeCellHeadingColSpan | Writes the HTML for the contents of one heading in a table, spanning columns.
writeCellHeadingRowSpan | Writes the html for the contents of one heading in a table, spanning rows.
writeEndTag | Writes the closing tag of the specified HTML element.
writeFullBeginTag | Writes the opening tag of the specified HTML element.
writeLine | Prints one line with a carriage return.
writeYear | Prints year with left justification in html output file.
~OutFileHTML | Destructor.
Collapse Expand Links
OutFileHTML Class, Legend, Protected Data Members, Public Data Members, Public Methods


OutFileHTML::OutFileHTML Constructor

OutFileHTML::OutFileHTML Constructor
OutFileHTML Class OutFileHTML Members OutFileHTML Class

Constructor.

C++
OutFileHTML(
    const std::string& newCssPage,
    int numTitleLines
);
Collapse Expand Parameters
Parameters | Description
const std::string& newCssPage | The css page to use.
int numTitleLines | Number of title lines at top of page.
Collapse Expand Remarks

Initializes the css page to use, the number of title lines, and the punctuation facet.

Collapse Expand Class

OutFileHTML Class

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Class


OutFileHTML::~OutFileHTML Destructor

OutFileHTML::~OutFileHTML Destructor
OutFileHTML Class OutFileHTML Members OutFileHTML Class

Destructor.

C++
~OutFileHTML();
Collapse Expand Class

OutFileHTML Class

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Class


OutFileHTML Data Members

OutFileHTML Data Members
OutFileHTML Class Legend Protected Data Members Public Data Members

The data members of the OutFileHTML class are listed here.

Collapse Expand Class

OutFileHTML Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
firstPage | Indicator for first page of output.
Collapse Expand Public Data Members
Name | Description
PAGE_TITLE_LINES | Number of title lines.
cssPage | The CSS page.
tagRightChar | Represents the closing angle-bracket of an HTML tag.
Collapse Expand Links
OutFileHTML Class, Legend, Protected Data Members, Public Data Members


OutFileHTML::PAGE_TITLE_LINES Data Member

OutFileHTML::PAGE_TITLE_LINES Data Member
OutFileHTML Class OutFileHTML Members OutFileHTML Data Members

Number of title lines.

C++
int PAGE_TITLE_LINES;
Collapse Expand Group

OutFileHTML Data Members

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Data Members


OutFileHTML::cssPage Data Member

OutFileHTML::cssPage Data Member
OutFileHTML Class OutFileHTML Members OutFileHTML Data Members

The CSS page.

C++
std::string cssPage;
Collapse Expand Group

OutFileHTML Data Members

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Data Members


OutFileHTML::firstPage Data Member

OutFileHTML::firstPage Data Member
OutFileHTML Class OutFileHTML Members OutFileHTML Data Members

Indicator for first page of output.

C++
bool firstPage;
Collapse Expand Group

OutFileHTML Data Members

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Data Members


OutFileHTML::tagRightChar Data Member

OutFileHTML::tagRightChar Data Member
OutFileHTML Class OutFileHTML Members OutFileHTML Data Members

Represents the closing angle-bracket of an HTML tag.

C++
const char tagRightChar;
Collapse Expand Group

OutFileHTML Data Members

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Data Members


OutFileHTML Methods

OutFileHTML Methods
OutFileHTML Class Legend Public Methods

The methods of the OutFileHTML class are listed here.

Collapse Expand Class

OutFileHTML Class

Collapse Expand Public Methods
Name | Description
closeFile | Close the output file.
doHeader | Writes html header information.
gettitle | Returns one page title line.
openFile | Opens output file.
pgtitle | Writes title to html file.
settitle | Sets one page title line.
write | Prints the specified argument without a carriage return.
writeAttribute | Writes an HTML attribute and its value.
writeBeginGrayRow | Writes gray row starting information.
writeBeginTable | Writes the HTML for the start of a table.
writeBeginTag | Writes the opening tag of the specified HTML element.
writeCellBody | Writes the HTML for the contents of one cell in a table, left-justified.
writeCellBodyColSpan | Writes the html for a string as the contents of one cell in a table, left-justified, spanning columns.
writeCellBodyRight | Writes the HTML for the contents of one cell in a table, right-justified.
writeCellHeading | Writes the HTML for the contents of one heading in a table.
writeCellHeadingColSpan | Writes the HTML for the contents of one heading in a table, spanning columns.
writeCellHeadingRowSpan | Writes the html for the contents of one heading in a table, spanning rows.
writeEndTag | Writes the closing tag of the specified HTML element.
writeFullBeginTag | Writes the opening tag of the specified HTML element.
writeLine | Prints one line with a carriage return.
writeYear | Prints year with left justification in html output file.
Collapse Expand Links
OutFileHTML Class, Legend, Public Methods


OutFileHTML::closeFile Method

OutFileHTML::closeFile Method
OutFileHTML Class OutFileHTML Members OutFileHTML Methods

Close the output file.

C++
void closeFile();
Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Methods


OutFileHTML::doHeader Method

OutFileHTML::doHeader Method
OutFileHTML Class OutFileHTML Members OutFileHTML Methods

Writes html header information.

C++
void doHeader(
    const std::string& webTitle
);
Collapse Expand Parameters
Parameters | Description
const std::string& webTitle | The title in the web page title bar.
Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Methods


OutFileHTML::gettitle Method

OutFileHTML::gettitle Method
OutFileHTML Class OutFileHTML Members OutFileHTML Methods

Returns one page title line.

C++
const std::string& gettitle(
    int number
) const;
Collapse Expand Parameters
Parameters | Description
int number | Page title line number (0 or 1).
Collapse Expand Returns

Specified page title line.

Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Methods


OutFileHTML::openFile Method

OutFileHTML::openFile Method
OutFileHTML Class OutFileHTML Members OutFileHTML Methods

Opens output file.

C++
void openFile(
    const std::string& pathname
);
Collapse Expand Parameters
Parameters | Description
const std::string& pathname | The full pathname of the file.
Collapse Expand Description

void RowStub( const std::string& rowstub );

Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Methods


OutFileHTML::pgtitle Method

OutFileHTML::pgtitle Method
OutFileHTML Class OutFileHTML Members OutFileHTML Methods

Writes title to html file.

C++
void pgtitle();
Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Methods


OutFileHTML::settitle Method

OutFileHTML::settitle Method
OutFileHTML Class OutFileHTML Members OutFileHTML Methods

Sets one page title line.

C++
void settitle(
    int number,
    const std::string& newPageTitle
);
Collapse Expand Parameters
Parameters | Description
int number | Page title line number (0 or 1).
const std::string& newPageTitle | New page title line.
Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Methods


write Method

write Method
OutFileHTML Methods

Prints the specified argument without a carriage return.

Collapse Expand Description

There are three versions of this function, to print a character, a C-style string, or a C++ style string, without a carriage return.

Collapse Expand Overload List
Name | Description
OutFileHTML::write (char) | Prints the character without a carriage return.
OutFileHTML::write (const char*) | Prints the C-style string without a carriage return.
OutFileHTML::write (const std::string&) | Prints the string without a carriage return.
Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Methods


OutFileHTML::write Method (char)

OutFileHTML::write Method (char)
OutFileHTML Class OutFileHTML Members write Method

Prints the character without a carriage return.

C++
void write(
    char ch
);
Collapse Expand Parameters
Parameters | Description
char ch | Character to print.
Collapse Expand Group

write Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, write Method


OutFileHTML::write Method (const char*)

OutFileHTML::write Method (const char*)
OutFileHTML Class OutFileHTML Members write Method

Prints the C-style string without a carriage return.

C++
void write(
    const char* str
);
Collapse Expand Parameters
Parameters | Description
const char* str | String to print.
Collapse Expand Group

write Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, write Method


OutFileHTML::write Method (const std::string&)

OutFileHTML::write Method (const std::string&)
OutFileHTML Class OutFileHTML Members write Method

Prints the string without a carriage return.

C++
void write(
    const std::string& str
);
Collapse Expand Parameters
Parameters | Description
const std::string& str | String to print.
Collapse Expand Group

write Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, write Method


writeAttribute Method

writeAttribute Method
OutFileHTML Methods

Writes an HTML attribute and its value.

Collapse Expand Description

There are two versions of this function, where the value written can be an integer or a string.

Collapse Expand Overload List
Name | Description
OutFileHTML::writeAttribute (const std::string&, const std::string&) | Writes an HTML attribute and its string value.
OutFileHTML::writeAttribute (const std::string&, int) | Writes an HTML attribute and its integer value.
Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Methods


OutFileHTML::writeAttribute Method (const std::string&, int)

OutFileHTML::writeAttribute Method (const std::string&, int)
OutFileHTML Class OutFileHTML Members writeAttribute Method

Writes an HTML attribute and its integer value.

C++
void writeAttribute(
    const std::string& style,
    int value
);
Collapse Expand Parameters
Parameters | Description
const std::string& style | The attribute name.
int value | The attribute value as an integer.
Collapse Expand Remarks

They are written as a space, the attribute name, an equals sign, and the attribute value in double quotes.

Collapse Expand Group

writeAttribute Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, writeAttribute Method


OutFileHTML::writeAttribute Method (const std::string&, const std::string&)

OutFileHTML::writeAttribute Method (const std::string&, const std::string&)
OutFileHTML Class OutFileHTML Members writeAttribute Method

Writes an HTML attribute and its string value.

C++
void writeAttribute(
    const std::string& style,
    const std::string& s
);
Collapse Expand Parameters
Parameters | Description
const std::string& style | The attribute name.
const std::string& s | The attribute value as a string.
Collapse Expand Remarks

They are written as a space, the attribute name, an equals sign, and the attribute value in double quotes.

Collapse Expand Group

writeAttribute Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, writeAttribute Method


OutFileHTML::writeBeginGrayRow Method

OutFileHTML::writeBeginGrayRow Method
OutFileHTML Class OutFileHTML Members OutFileHTML Methods

Writes gray row starting information.

C++
void writeBeginGrayRow();
Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Methods


writeBeginTable Method

writeBeginTable Method
OutFileHTML Methods

Writes the HTML for the start of a table.

Collapse Expand Description

There are two versions of this function. The one with one argument specifies the width of the table. The one with three arguments also specifies the caption and title of the table.

Collapse Expand Overload List
Name | Description
OutFileHTML::writeBeginTable (const std::string&) | Writes the html for the start of a table, without a caption.
OutFileHTML::writeBeginTable (const std::string&, const std::string&, const std::string&) | Writes the html for the start of a table, with a caption.
Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Methods


OutFileHTML::writeBeginTable Method (const std::string&)

OutFileHTML::writeBeginTable Method (const std::string&)
OutFileHTML Class OutFileHTML Members writeBeginTable Method

Writes the html for the start of a table, without a caption.

C++
void writeBeginTable(
    const std::string& width
);
Collapse Expand Parameters
Parameters | Description
const std::string& width | Width of table (e.g. "95%").
Collapse Expand Group

writeBeginTable Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, writeBeginTable Method


OutFileHTML::writeBeginTable Method (const std::string&, const std::string&, const std::string&)

OutFileHTML::writeBeginTable Method (const std::string&, const std::string&, const std::string&)
OutFileHTML Class OutFileHTML Members writeBeginTable Method

Writes the html for the start of a table, with a caption.

C++
void writeBeginTable(
    const std::string& width,
    const std::string& captionClass,
    const std::string& theTitle
);
Collapse Expand Parameters
Parameters | Description
const std::string& width | Width of table (e.g. "95%").
const std::string& captionClass | Class of paragraph for table caption.
const std::string& theTitle | Title of table.
Collapse Expand Group

writeBeginTable Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, writeBeginTable Method


OutFileHTML::writeBeginTag Method

OutFileHTML::writeBeginTag Method
OutFileHTML Class OutFileHTML Members OutFileHTML Methods

Writes the opening tag of the specified HTML element.

C++
void writeBeginTag(
    const std::string& s
);
Collapse Expand Parameters
Parameters | Description
const std::string& s | The specified HTML element.
Collapse Expand Remarks

The closing angle-bracket is left off so that attributes may be added.

Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Methods


writeCellBody Method

writeCellBody Method
OutFileHTML Methods

Writes the HTML for the contents of one cell in a table, left-justified.

Collapse Expand Description

There are two versions of this function, to write an integer or a string.

Collapse Expand Overload List
Name | Description
OutFileHTML::writeCellBody (const std::string&) | Writes the html for a string as the contents of one cell in a table, left-justified.
OutFileHTML::writeCellBody (int) | Writes the html for an integer as the contents of one cell in a table, left-justified.
Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Methods


OutFileHTML::writeCellBody Method (int)

OutFileHTML::writeCellBody Method (int)
OutFileHTML Class OutFileHTML Members writeCellBody Method

Writes the html for an integer as the contents of one cell in a table, left-justified.

C++
void writeCellBody(
    int theInt
);
Collapse Expand Parameters
Parameters | Description
int theInt | The integer to be placed in the cell in the table.
Collapse Expand Remarks

There are multiple versions of this function. Each version uses the inserter to put the argument into the output stream, surrounded by the appropriate tags.

Collapse Expand Group

writeCellBody Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, writeCellBody Method


OutFileHTML::writeCellBody Method (const std::string&)

OutFileHTML::writeCellBody Method (const std::string&)
OutFileHTML Class OutFileHTML Members writeCellBody Method

Writes the html for a string as the contents of one cell in a table, left-justified.

C++
void writeCellBody(
    const std::string& contents
);
Collapse Expand Parameters
Parameters | Description
const std::string& contents | The contents of the cell in the table.
Collapse Expand Remarks

There are multiple versions of this function. Each version uses the inserter to put the argument into the output stream, surrounded by the appropriate tags.

Collapse Expand Group

writeCellBody Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, writeCellBody Method


OutFileHTML::writeCellBodyColSpan Method

OutFileHTML::writeCellBodyColSpan Method
OutFileHTML Class OutFileHTML Members OutFileHTML Methods

Writes the html for a string as the contents of one cell in a table, left-justified, spanning columns.

C++
void writeCellBodyColSpan(
    const std::string& contents,
    int spanInt
);
Collapse Expand Parameters
Parameters | Description
const std::string& contents | The contents of the cells in the table.
int spanInt | The number of columns to span, as an integer.
Collapse Expand Remarks

There are multiple versions of this function. Each version uses the inserter to put the argument into the output stream, surrounded by the appropriate tags.

Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Methods


writeCellBodyRight Method

writeCellBodyRight Method
OutFileHTML Methods

Writes the HTML for the contents of one cell in a table, right-justified.

Collapse Expand Description

There are three versions of this function, to write an integer, a double, or a string.

Collapse Expand Overload List
Name | Description
OutFileHTML::writeCellBodyRight (const std::string&) | Writes the html for a string as the contents of one cell in a table, right-justified.
OutFileHTML::writeCellBodyRight (double, int) | Writes the html for a double as the contents of one cell in a table, right-justified.
OutFileHTML::writeCellBodyRight (int) | Writes the html for an integer as the contents of one cell in a table, right-justified.
Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Methods


OutFileHTML::writeCellBodyRight Method (double, int)

OutFileHTML::writeCellBodyRight Method (double, int)
OutFileHTML Class OutFileHTML Members writeCellBodyRight Method

Writes the html for a double as the contents of one cell in a table, right-justified.

C++
void writeCellBodyRight(
    double theDouble,
    int precision
);
Collapse Expand Parameters
Parameters | Description
double theDouble | The double to be placed in the cell in the table.
int precision | Precision to be used when writing the double.
Collapse Expand Remarks

There are multiple versions of this function. Each version uses the inserter to put the argument into the output stream, surrounded by the appropriate tags.

Collapse Expand Group

writeCellBodyRight Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, writeCellBodyRight Method


OutFileHTML::writeCellBodyRight Method (int)

OutFileHTML::writeCellBodyRight Method (int)
OutFileHTML Class OutFileHTML Members writeCellBodyRight Method

Writes the html for an integer as the contents of one cell in a table, right-justified.

C++
void writeCellBodyRight(
    int theInt
);
Collapse Expand Parameters
Parameters | Description
int theInt | The integer to be placed in the cell in the table.
Collapse Expand Remarks

There are multiple versions of this function. Each version uses the inserter to put the argument into the output stream, surrounded by the appropriate tags.

Collapse Expand Group

writeCellBodyRight Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, writeCellBodyRight Method


OutFileHTML::writeCellBodyRight Method (const std::string&)

OutFileHTML::writeCellBodyRight Method (const std::string&)
OutFileHTML Class OutFileHTML Members writeCellBodyRight Method

Writes the html for a string as the contents of one cell in a table, right-justified.

C++
void writeCellBodyRight(
    const std::string& contents
);
Collapse Expand Parameters
Parameters | Description
const std::string& contents | The contents of the cell in the table.
Collapse Expand Remarks

There are multiple versions of this function. Each version uses the inserter to put the argument into the output stream, surrounded by the appropriate tags.

Collapse Expand Group

writeCellBodyRight Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, writeCellBodyRight Method


writeCellHeading Method

writeCellHeading Method
OutFileHTML Methods

Writes the HTML for the contents of one heading in a table.

Collapse Expand Description

There are two versions of this function, to write an integer or a string.

Collapse Expand Overload List
Name | Description
OutFileHTML::writeCellHeading (const std::string&) | Writes the html for a string as the contents of one heading in a table.
OutFileHTML::writeCellHeading (int) | Writes the html for an integer as the contents of one heading in a table.
Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Methods


OutFileHTML::writeCellHeading Method (int)

OutFileHTML::writeCellHeading Method (int)
OutFileHTML Class OutFileHTML Members writeCellHeading Method

Writes the html for an integer as the contents of one heading in a table.

C++
void writeCellHeading(
    int theInt
);
Collapse Expand Parameters
Parameters | Description
int theInt | The integer to use as the heading in the table.
Collapse Expand Remarks

The cell does not span columns or rows.

There are multiple versions of this function. Each version uses the inserter to put the argument into the output stream, surrounded by the appropriate tags.

Collapse Expand Group

writeCellHeading Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, writeCellHeading Method


OutFileHTML::writeCellHeading Method (const std::string&)

OutFileHTML::writeCellHeading Method (const std::string&)
OutFileHTML Class OutFileHTML Members writeCellHeading Method

Writes the html for a string as the contents of one heading in a table.

C++
void writeCellHeading(
    const std::string& heading
);
Collapse Expand Parameters
Parameters | Description
const std::string& heading | The heading in the table.
Collapse Expand Remarks

The cell does not span columns or rows.

There are multiple versions of this function. Each version uses the inserter to put the argument into the output stream, surrounded by the appropriate tags.

Collapse Expand Group

writeCellHeading Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, writeCellHeading Method


writeCellHeadingColSpan Method

writeCellHeadingColSpan Method
OutFileHTML Methods

Writes the HTML for the contents of one heading in a table, spanning columns.

Collapse Expand Description

There are two versions of this function, where the span is specified as an integer or a string.

Collapse Expand Overload List
Name | Description
OutFileHTML::writeCellHeadingColSpan (const std::string&, const std::string&) | Writes the html for the contents of one heading in a table, spanning columns.
OutFileHTML::writeCellHeadingColSpan (const std::string&, int) | Writes the html for the contents of one heading in a table, spanning columns.
Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Methods


OutFileHTML::writeCellHeadingColSpan Method (const std::string&, int)

OutFileHTML::writeCellHeadingColSpan Method (const std::string&, int)
OutFileHTML Class OutFileHTML Members writeCellHeadingColSpan Method

Writes the html for the contents of one heading in a table, spanning columns.

C++
void writeCellHeadingColSpan(
    const std::string& heading,
    int spanInt
);
Collapse Expand Parameters
Parameters | Description
const std::string& heading | The heading in the table.
int spanInt | The number of columns to span, as an integer.
Collapse Expand Group

writeCellHeadingColSpan Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, writeCellHeadingColSpan Method


OutFileHTML::writeCellHeadingColSpan Method (const std::string&, const std::string&)

OutFileHTML::writeCellHeadingColSpan Method (const std::string&, const std::string&)
OutFileHTML Class OutFileHTML Members writeCellHeadingColSpan Method

Writes the html for the contents of one heading in a table, spanning columns.

C++
void writeCellHeadingColSpan(
    const std::string& heading,
    const std::string& spanStr
);
Collapse Expand Parameters
Parameters | Description
const std::string& heading | The heading in the table.
const std::string& spanStr | The number of columns to span, as a string.
Collapse Expand Group

writeCellHeadingColSpan Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, writeCellHeadingColSpan Method


OutFileHTML::writeCellHeadingRowSpan Method

OutFileHTML::writeCellHeadingRowSpan Method
OutFileHTML Class OutFileHTML Members OutFileHTML Methods

Writes the html for the contents of one heading in a table, spanning rows.

C++
void writeCellHeadingRowSpan(
    const std::string& heading,
    const std::string& span
);
Collapse Expand Parameters
Parameters | Description
const std::string& heading | The heading in the table.
const std::string& span | The number of rows to span, as a string.
Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Methods


OutFileHTML::writeEndTag Method

OutFileHTML::writeEndTag Method
OutFileHTML Class OutFileHTML Members OutFileHTML Methods

Writes the closing tag of the specified HTML element.

C++
void writeEndTag(
    const std::string& s
);
Collapse Expand Parameters
Parameters | Description
const std::string& s | The specified HTML element.
Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Methods


OutFileHTML::writeFullBeginTag Method

OutFileHTML::writeFullBeginTag Method
OutFileHTML Class OutFileHTML Members OutFileHTML Methods

Writes the opening tag of the specified HTML element.

C++
void writeFullBeginTag(
    const std::string& s
);
Collapse Expand Parameters
Parameters | Description
const std::string& s | The specified HTML element.
Collapse Expand Remarks

The closing angle-bracket is added.

Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Methods


writeLine Method

writeLine Method
OutFileHTML Methods

Prints one line with a carriage return.

Collapse Expand Description

There are three versions of this function, to print just a newline, a C-style string, or a C++ style string, with a carriage return.

Collapse Expand Overload List
Name | Description
OutFileHTML::writeLine () | Prints a carriage return.
OutFileHTML::writeLine (const char*) | Prints one line with a carriage return.
OutFileHTML::writeLine (const std::string&) | Prints one line with a carriage return.
Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Methods


OutFileHTML::writeLine Method ()

OutFileHTML::writeLine Method ()
OutFileHTML Class OutFileHTML Members writeLine Method

Prints a carriage return.

C++
void writeLine();
Collapse Expand Group

writeLine Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, writeLine Method


OutFileHTML::writeLine Method (const char*)

OutFileHTML::writeLine Method (const char*)
OutFileHTML Class OutFileHTML Members writeLine Method

Prints one line with a carriage return.

C++
void writeLine(
    const char* str
);
Collapse Expand Parameters
Parameters | Description
const char* str | String to print.
Collapse Expand Group

writeLine Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, writeLine Method


OutFileHTML::writeLine Method (const std::string&)

OutFileHTML::writeLine Method (const std::string&)
OutFileHTML Class OutFileHTML Members writeLine Method

Prints one line with a carriage return.

C++
void writeLine(
    const std::string& str
);
Collapse Expand Parameters
Parameters | Description
const std::string& str | String to print.
Collapse Expand Group

writeLine Method

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, writeLine Method


OutFileHTML::writeYear Method

OutFileHTML::writeYear Method
OutFileHTML Class OutFileHTML Members OutFileHTML Methods

Prints year with left justification in html output file.

C++
void writeYear(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | The year to print.
Collapse Expand Remarks

We have a special function to handle a year, because we do not want a comma inserted in it.

Collapse Expand Group

OutFileHTML Methods

Collapse Expand Links
OutFileHTML Class, OutFileHTML Members, OutFileHTML Methods


Outfile Class

Outfile Class
Outfile Constructor Outfile Data Members Outfile Methods Outfile Members outfile.h Classes

Abstract parent of classes to manage an output file in runstreams with multiple programs.

Collapse Expand Class Hierarchy
  OutfileOutfileOutfile
C++
class Outfile : public Document;
Collapse Expand File

File: outfile.h

Module: Misc Library

Collapse Expand Remarks

It also manages a 2-line title and a date and time string for output at the top of each page, along with the page number. It is an abstract class; one of its subclasses (OutFile80, OutDC80, or OutFile132) should be instantiated.

This was formerly used in the ssgiat programs, but they are all now in C#. This also was formerly used in some of the ssgbp and jrunfunds programs, but they have all been changed to use OutFileHTML.

Collapse Expand See Also

OutFile80, OutDC80, OutFile132, OutFileHTML

Collapse Expand Group

Classes

Collapse Expand Links
Outfile Constructor, Outfile Data Members, Outfile Methods, Outfile Members, outfile.h, Classes


Outfile Members

Outfile Members
Outfile Class Legend Protected Data Members Public Methods

The following tables list the members exposed by Outfile.

Collapse Expand Class

Outfile Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
PAGE_TITLE_LINES | Number of title lines.
dateModyyr | The current date as month, day, and year.
outstrm | Output stream.
pageNum | Page number.
pathname | Pathname of this file.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
Outfile | Initializes an Outfile, where the parent directory is either specified or default.
advanceLine | Move to next line.
closeout | Closes output file.
errormesg | Returns message when error reading from file.
footer | Writes a footer to a print file.
formfeed | Move to next page.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPageNum | Returns page number.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
gettitle | Returns one page title line.
header | Writes a heading line to a print file.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens output file.
pgtitle | Writes date, time, title, and page to print file.
printLine | Prints a line of output with a carriage return.
printLinena | Prints a line of output without a carriage return.
readmesg | Returns message when reading from file.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPageNum | Sets page number.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
settitle | Sets one page title line.
writemesg | Returns message when writing to file.
~Outfile | Destroys this instance.
Collapse Expand Links
Outfile Class, Legend, Protected Data Members, Public Methods


Outfile Constructor

Outfile Constructor
Outfile Class

Initializes an Outfile, where the parent directory is either specified or default.

Collapse Expand Description

There are two versions of the Outfile constructor. Both set the output file core name and extension. The one with a third argument also sets the parent directory; otherwise the parent directory is initialized to the current working directory.

Collapse Expand Overload List
Name | Description
Outfile::Outfile (const std::string&, const std::string&) | Initializes output file core name and extension to specified values; parent directory is set to the current working directory.
Outfile::Outfile (const std::string&, const std::string&, const std::string&) | Initializes output file core name, extension, and parent directory to the specified values.
Collapse Expand Class

Outfile Class

Collapse Expand Links
Outfile Class


Outfile::Outfile Constructor (const std::string&, const std::string&)

Outfile::Outfile Constructor (const std::string&, const std::string&)
Outfile Class Outfile Members Outfile Constructor

Initializes output file core name and extension to specified values; parent directory is set to the current working directory.

C++
Outfile(
    const std::string& newCorename,
    const std::string& newExtension
);
Collapse Expand Parameters
Parameters | Description
const std::string& newCorename | New core file name.
const std::string& newExtension | New extension on the file name.
Collapse Expand Group

Outfile Constructor

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Constructor


Outfile::Outfile Constructor (const std::string&, const std::string&, const std::string&)

Outfile::Outfile Constructor (const std::string&, const std::string&, const std::string&)
Outfile Class Outfile Members Outfile Constructor

Initializes output file core name, extension, and parent directory to the specified values.

C++
Outfile(
    const std::string& newDirectory,
    const std::string& newCorename,
    const std::string& newExtension
);
Collapse Expand Parameters
Parameters | Description
const std::string& newDirectory | Name of parent directory.
const std::string& newCorename | New core file name.
const std::string& newExtension | New extension on the file name.
Collapse Expand Group

Outfile Constructor

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Constructor


Outfile::~Outfile Destructor

Outfile::~Outfile Destructor
Outfile Class Outfile Members Outfile Class

Destroys this instance.

C++
virtual ~Outfile();
Collapse Expand Class

Outfile Class

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Class


Outfile Data Members

Outfile Data Members
Outfile Class Legend Protected Data Members

The data members of the Outfile class are listed here.

Collapse Expand Class

Outfile Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
PAGE_TITLE_LINES | Number of title lines.
dateModyyr | The current date as month, day, and year.
outstrm | Output stream.
pageNum | Page number.
Collapse Expand Links
Outfile Class, Legend, Protected Data Members


Outfile::PAGE_TITLE_LINES Data Member

Outfile::PAGE_TITLE_LINES Data Member
Outfile Class Outfile Members Outfile Data Members

Number of title lines.

C++
const int PAGE_TITLE_LINES = 2;
Collapse Expand Group

Outfile Data Members

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Data Members


Outfile::dateModyyr Data Member

Outfile::dateModyyr Data Member
Outfile Class Outfile Members Outfile Data Members

The current date as month, day, and year.

C++
boost::gregorian::date dateModyyr;
Collapse Expand Group

Outfile Data Members

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Data Members


Outfile::outstrm Data Member

Outfile::outstrm Data Member
Outfile Class Outfile Members Outfile Data Members

Output stream.

C++
std::ofstream outstrm;
Collapse Expand Group

Outfile Data Members

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Data Members


Outfile::pageNum Data Member

Outfile::pageNum Data Member
Outfile Class Outfile Members Outfile Data Members

Page number.

C++
int pageNum;
Collapse Expand Group

Outfile Data Members

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Data Members


Outfile Methods

Outfile Methods
Outfile Class Legend Public Methods

The methods of the Outfile class are listed here.

Collapse Expand Class

Outfile Class

Collapse Expand Public Methods
Name | Description
advanceLine | Move to next line.
closeout | Closes output file.
footer | Writes a footer to a print file.
formfeed | Move to next page.
getPageNum | Returns page number.
gettitle | Returns one page title line.
header | Writes a heading line to a print file.
openout | Opens output file.
pgtitle | Writes date, time, title, and page to print file.
printLine | Prints a line of output with a carriage return.
printLinena | Prints a line of output without a carriage return.
setPageNum | Sets page number.
settitle | Sets one page title line.
Collapse Expand Links
Outfile Class, Legend, Public Methods


Outfile::advanceLine Method

Outfile::advanceLine Method
Outfile Class Outfile Members Outfile Methods

Move to next line.

C++
virtual void advanceLine() = 0;
Collapse Expand Group

Outfile Methods

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Methods


Outfile::closeout Method

Outfile::closeout Method
Outfile Class Outfile Members Outfile Methods

Closes output file.

C++
void closeout();
Collapse Expand Group

Outfile Methods

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Methods


Outfile::footer Method

Outfile::footer Method
Outfile Class Outfile Members Outfile Methods

Writes a footer to a print file.

C++
virtual void footer() = 0;
Collapse Expand Group

Outfile Methods

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Methods


Outfile::formfeed Method

Outfile::formfeed Method
Outfile Class Outfile Members Outfile Methods

Move to next page.

C++
virtual void formfeed() = 0;
Collapse Expand Group

Outfile Methods

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Methods


Outfile::getPageNum Method

Outfile::getPageNum Method
Outfile Class Outfile Members Outfile Methods

Returns page number.

C++
int getPageNum() const;
Collapse Expand Returns

Page number.

Collapse Expand Group

Outfile Methods

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Methods


Outfile::gettitle Method

Outfile::gettitle Method
Outfile Class Outfile Members Outfile Methods

Returns one page title line.

C++
const std::string& gettitle(
    int number
) const;
Collapse Expand Parameters
Parameters | Description
int number | Page title line number (0 or 1).
Collapse Expand Returns

Specified page title line.

Collapse Expand Group

Outfile Methods

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Methods


Outfile::header Method

Outfile::header Method
Outfile Class Outfile Members Outfile Methods

Writes a heading line to a print file.

C++
virtual void header(
    const std::string& webTitle
) = 0;
Collapse Expand Parameters
Parameters | Description
const std::string& webTitle | The heading line to print.
Collapse Expand Group

Outfile Methods

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Methods


Outfile::openout Method

Outfile::openout Method
Outfile Class Outfile Members Outfile Methods

Opens output file.

C++
void openout();
Collapse Expand Group

Outfile Methods

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Methods


Outfile::pgtitle Method

Outfile::pgtitle Method
Outfile Class Outfile Members Outfile Methods

Writes date, time, title, and page to print file.

C++
virtual void pgtitle() = 0;
Collapse Expand Group

Outfile Methods

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Methods


printLine Method

printLine Method
Outfile Methods

Prints a line of output with a carriage return.

Collapse Expand Description

There are two versions of this function, where the argument can be a C-style string or a C++ style string.

Collapse Expand Overload List
Name | Description
Outfile::printLine (const char*) | Print a line of output with a carriage return.
Outfile::printLine (const std::string&) | Print a line of output with a carriage return.
Collapse Expand Group

Outfile Methods

Collapse Expand Links
Outfile Methods


Outfile::printLine Method (const char*)

Outfile::printLine Method (const char*)
Outfile Class Outfile Members printLine Method

Print a line of output with a carriage return.

C++
virtual void printLine(
    const char*
) = 0;
Collapse Expand Group

printLine Method

Collapse Expand Links
Outfile Class, Outfile Members, printLine Method


Outfile::printLine Method (const std::string&)

Outfile::printLine Method (const std::string&)
Outfile Class Outfile Members printLine Method

Print a line of output with a carriage return.

C++
virtual void printLine(
    const std::string&
) = 0;
Collapse Expand Group

printLine Method

Collapse Expand Links
Outfile Class, Outfile Members, printLine Method


printLinena Method

printLinena Method
Outfile Methods

Prints a line of output without a carriage return.

Collapse Expand Description

There are two versions of this function, where the argument can be a C-style string or a C++ style string.

Collapse Expand Overload List
Name | Description
Outfile::printLinena (const char*) | Print a line of output with no carriage return.
Outfile::printLinena (const std::string&) | Print a line of output with no carriage return.
Collapse Expand Group

Outfile Methods

Collapse Expand Links
Outfile Methods


Outfile::printLinena Method (const char*)

Outfile::printLinena Method (const char*)
Outfile Class Outfile Members printLinena Method

Print a line of output with no carriage return.

C++
virtual void printLinena(
    const char*
) = 0;
Collapse Expand Group

printLinena Method

Collapse Expand Links
Outfile Class, Outfile Members, printLinena Method


Outfile::printLinena Method (const std::string&)

Outfile::printLinena Method (const std::string&)
Outfile Class Outfile Members printLinena Method

Print a line of output with no carriage return.

C++
virtual void printLinena(
    const std::string&
) = 0;
Collapse Expand Group

printLinena Method

Collapse Expand Links
Outfile Class, Outfile Members, printLinena Method


Outfile::setPageNum Method

Outfile::setPageNum Method
Outfile Class Outfile Members Outfile Methods

Sets page number.

C++
void setPageNum(
    int newPageNum
);
Collapse Expand Parameters
Parameters | Description
int newPageNum | New page number.
Collapse Expand Group

Outfile Methods

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Methods


Outfile::settitle Method

Outfile::settitle Method
Outfile Class Outfile Members Outfile Methods

Sets one page title line.

C++
void settitle(
    int number,
    const std::string& newPageTitle
);
Collapse Expand Parameters
Parameters | Description
int number | Page title line number (0 or 1).
const std::string& newPageTitle | New page title line.
Collapse Expand Group

Outfile Methods

Collapse Expand Links
Outfile Class, Outfile Members, Outfile Methods


PageCounters Class

PageCounters Class
PageCounters Data Members PageCounters Methods PageCounters Members page.h Classes

Manages a vector of page counters.

Collapse Expand Class Hierarchy
  PageCountersPageCountersPageCounters
C++
class PageCounters : public Document;
Collapse Expand File

File: page.h

Module: Misc Library

Collapse Expand Remarks

Manages a vector of page counters for use in runstreams with multiple programs. This were formerly used in the ssgiat, ssgbp, and jrunfunds runstreams, but since they were converted to html output, this class is no longer used.

Collapse Expand Group

Classes

Collapse Expand Links
PageCounters Data Members, PageCounters Methods, PageCounters Members, page.h, Classes


PageCounters Members

PageCounters Members
PageCounters Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PageCounters.

Collapse Expand Class

PageCounters Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
pathname | Pathname of this file.
Collapse Expand Public Data Members
Name | Description
PIA_IDS_PAGE1 | Error code.
PIA_IDS_PAGE2 | Error code.
PIA_IDS_PAGE3 | Error code.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
PageCounters | Initializes page file name and array size.
deleteContents | Zeroes out page counters.
errormesg | Returns message when error reading from file.
get | Returns page counter for one slot.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
read | Reads page counters from a file named "page".
readmesg | Returns message when reading from file.
set | Sets page counter for one slot.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
update | Updates all subsequent page counters and writes them out.
write | Writes page counters out to a file named "page".
writemesg | Returns message when writing to file.
~PageCounters | Destructor.
Collapse Expand Links
PageCounters Class, Legend, Protected Data Members, Public Data Members, Public Methods


PageCounters::PageCounters Constructor

PageCounters::PageCounters Constructor
PageCounters Class PageCounters Members PageCounters Class

Initializes page file name and array size.

C++
explicit PageCounters(
    int maxCounters
);
Collapse Expand Parameters
Parameters | Description
int maxCounters | Maximum number of page counters.
Collapse Expand Class

PageCounters Class

Collapse Expand Links
PageCounters Class, PageCounters Members, PageCounters Class


PageCounters::~PageCounters Destructor

PageCounters::~PageCounters Destructor
PageCounters Class PageCounters Members PageCounters Class

Destructor.

C++
~PageCounters();
Collapse Expand Remarks

Does nothing.

Collapse Expand Class

PageCounters Class

Collapse Expand Links
PageCounters Class, PageCounters Members, PageCounters Class


PageCounters Data Members

PageCounters Data Members
PageCounters Class Legend Public Data Members

The data members of the PageCounters class are listed here.

Collapse Expand Class

PageCounters Class

Collapse Expand Public Data Members
Name | Description
PIA_IDS_PAGE1 | Error code.
PIA_IDS_PAGE2 | Error code.
PIA_IDS_PAGE3 | Error code.
Collapse Expand Links
PageCounters Class, Legend, Public Data Members


PageCounters::PIA_IDS_PAGE1 Data Member

PageCounters::PIA_IDS_PAGE1 Data Member
PageCounters Class PageCounters Members PageCounters Data Members

Error code.

C++
const unsigned int PIA_IDS_PAGE1 = 1;
Collapse Expand Group

PageCounters Data Members

Collapse Expand Links
PageCounters Class, PageCounters Members, PageCounters Data Members


PageCounters::PIA_IDS_PAGE2 Data Member

PageCounters::PIA_IDS_PAGE2 Data Member
PageCounters Class PageCounters Members PageCounters Data Members

Error code.

C++
const unsigned int PIA_IDS_PAGE2 = 2;
Collapse Expand Group

PageCounters Data Members

Collapse Expand Links
PageCounters Class, PageCounters Members, PageCounters Data Members


PageCounters::PIA_IDS_PAGE3 Data Member

PageCounters::PIA_IDS_PAGE3 Data Member
PageCounters Class PageCounters Members PageCounters Data Members

Error code.

C++
const unsigned int PIA_IDS_PAGE3 = 3;
Collapse Expand Group

PageCounters Data Members

Collapse Expand Links
PageCounters Class, PageCounters Members, PageCounters Data Members


PageCounters Methods

PageCounters Methods
PageCounters Class Legend Public Methods

The methods of the PageCounters class are listed here.

Collapse Expand Class

PageCounters Class

Collapse Expand Public Methods
Name | Description
deleteContents | Zeroes out page counters.
get | Returns page counter for one slot.
read | Reads page counters from a file named "page".
set | Sets page counter for one slot.
update | Updates all subsequent page counters and writes them out.
write | Writes page counters out to a file named "page".
Collapse Expand Links
PageCounters Class, Legend, Public Methods


PageCounters::deleteContents Method

PageCounters::deleteContents Method
PageCounters Class PageCounters Members PageCounters Methods

Zeroes out page counters.

C++
void deleteContents();
Collapse Expand Group

PageCounters Methods

Collapse Expand Links
PageCounters Class, PageCounters Members, PageCounters Methods


PageCounters::get Method

PageCounters::get Method
PageCounters Class PageCounters Members PageCounters Methods

Returns page counter for one slot.

C++
int get(
    int slot
) const;
Collapse Expand Parameters
Parameters | Description
int slot | Page counter slot to get.
Collapse Expand Returns

Page counter for one slot.

Collapse Expand Group

PageCounters Methods

Collapse Expand Links
PageCounters Class, PageCounters Members, PageCounters Methods


PageCounters::read Method

PageCounters::read Method
PageCounters Class PageCounters Members PageCounters Methods

Reads page counters from a file named "page".

C++
void read();
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PAGE1 if unable to open input file; of type PIA_IDS_PAGE2 if unable to read all values successfully.
Collapse Expand Group

PageCounters Methods

Collapse Expand Links
PageCounters Class, PageCounters Members, PageCounters Methods


PageCounters::set Method

PageCounters::set Method
PageCounters Class PageCounters Members PageCounters Methods

Sets page counter for one slot.

C++
void set(
    int slot,
    int newPageNum
);
Collapse Expand Parameters
Parameters | Description
int slot | Page counter slot to use.
int newPageNum | New page number.
Collapse Expand Group

PageCounters Methods

Collapse Expand Links
PageCounters Class, PageCounters Members, PageCounters Methods


PageCounters::update Method

PageCounters::update Method
PageCounters Class PageCounters Members PageCounters Methods

Updates all subsequent page counters and writes them out.

C++
void update(
    int slot
);
Collapse Expand Parameters
Parameters | Description
int slot | Slot after which all page counters are updated.
Collapse Expand Group

PageCounters Methods

Collapse Expand Links
PageCounters Class, PageCounters Members, PageCounters Methods


PageCounters::write Method

PageCounters::write Method
PageCounters Class PageCounters Members PageCounters Methods

Writes page counters out to a file named "page".

C++
void write();
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_PAGE3 if unable to open output file.
Collapse Expand Group

PageCounters Methods

Collapse Expand Links
PageCounters Class, PageCounters Members, PageCounters Methods


PageOut Class

PageOut Class
PageOut Data Members PageOut Methods PageOut Members PageOut.h Classes

Abstract parent of classes to manage a page of printed output.

Collapse Expand Class Hierarchy
  PageOut
C++
class PageOut;
Collapse Expand File

File: PageOut.h

Module: Misc Library

Collapse Expand Remarks

This is the parent of each page of printed output in the Anypia program.

Collapse Expand Group

Classes

Collapse Expand Links
PageOut Data Members, PageOut Methods, PageOut Members, PageOut.h, Classes


PageOut Members

PageOut Members
PageOut Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PageOut.

Collapse Expand Class

PageOut Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Public Data Members
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Name | Description
PageOut | Initializes PageOut.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareStrings | Prepares strings for output.
print | Writes the output strings to the specified device.
~PageOut | Destructor.
Collapse Expand Links
PageOut Class, Legend, Protected Data Members, Public Data Members, Public Methods


PageOut::PageOut Constructor

PageOut::PageOut Constructor
PageOut Class PageOut Members PageOut Class

Initializes PageOut.

C++
PageOut();
Collapse Expand Remarks

Reserves MAXLINES entries for outputString. Creates punct and loc and imbues strm with the facet to allow for inserting commas into formatted numbers for output.

Collapse Expand Class

PageOut Class

Collapse Expand Links
PageOut Class, PageOut Members, PageOut Class


PageOut::~PageOut Destructor

PageOut::~PageOut Destructor
PageOut Class PageOut Members PageOut Class

Destructor.

C++
virtual ~PageOut();
Collapse Expand Class

PageOut Class

Collapse Expand Links
PageOut Class, PageOut Members, PageOut Class


PageOut Data Members

PageOut Data Members
PageOut Class Legend Protected Data Members Public Data Members

The data members of the PageOut class are listed here.

Collapse Expand Class

PageOut Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Public Data Members
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Links
PageOut Class, Legend, Protected Data Members, Public Data Members


PageOut::MAXLINES Data Member

PageOut::MAXLINES Data Member
PageOut Class PageOut Members PageOut Data Members

The maximum number of lines on a page.

C++
const int MAXLINES = 100;
Collapse Expand Group

PageOut Data Members

Collapse Expand Links
PageOut Class, PageOut Members, PageOut Data Members


PageOut::loc Data Member

PageOut::loc Data Member
PageOut Class PageOut Members PageOut Data Members

A locale used to imbue PageOut::strm.

C++
const std::locale loc;
Collapse Expand Group

PageOut Data Members

Collapse Expand Links
PageOut Class, PageOut Members, PageOut Data Members


PageOut::outputString Data Member

PageOut::outputString Data Member
PageOut Class PageOut Members PageOut Data Members

Strings for output.

C++
std::vector<std::string> outputString;
Collapse Expand Group

PageOut Data Members

Collapse Expand Links
PageOut Class, PageOut Members, PageOut Data Members


PageOut::punct Data Member

PageOut::punct Data Member
PageOut Class PageOut Members PageOut Data Members

Numeric punctuation facet with 3 digits per thousands separator.

C++
std::numpunct<char> * punct;
Collapse Expand Group

PageOut Data Members

Collapse Expand Links
PageOut Class, PageOut Members, PageOut Data Members


PageOut::strm Data Member

PageOut::strm Data Member
PageOut Class PageOut Members PageOut Data Members

A stream to insert commas in a formatted number.

C++
std::ostringstream strm;
Collapse Expand Group

PageOut Data Members

Collapse Expand Links
PageOut Class, PageOut Members, PageOut Data Members


PageOut Methods

PageOut Methods
PageOut Class Legend Public Methods

The methods of the PageOut class are listed here.

Collapse Expand Class

PageOut Class

Collapse Expand Public Methods
Name | Description
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareStrings | Prepares strings for output.
print | Writes the output strings to the specified device.
Collapse Expand Links
PageOut Class, Legend, Public Methods


PageOut::getCount Method

PageOut::getCount Method
PageOut Class PageOut Members PageOut Methods

Returns number of lines of output.

C++
unsigned getCount() const;
Collapse Expand Returns

Number of lines of output.

Collapse Expand Group

PageOut Methods

Collapse Expand Links
PageOut Class, PageOut Members, PageOut Methods


PageOut::getString Method

PageOut::getString Method
PageOut Class PageOut Members PageOut Methods

Returns one line of output.

C++
std::string getString(
    unsigned index
) const;
Collapse Expand Parameters
Parameters | Description
unsigned index | Index of desired line (0-based).
Collapse Expand Returns

The specified line of output.

Collapse Expand Group

PageOut Methods

Collapse Expand Links
PageOut Class, PageOut Members, PageOut Methods


PageOut::prepareStrings Method

PageOut::prepareStrings Method
PageOut Class PageOut Members PageOut Methods

Prepares strings for output.

C++
virtual void prepareStrings() = 0;
Collapse Expand Group

PageOut Methods

Collapse Expand Links
PageOut Class, PageOut Members, PageOut Methods


print Method

print Method
PageOut Methods

Writes the output strings to the specified device.

Collapse Expand Description

There are two versions of the print method. They write the output strings to either an Outfile (which contains an output stream) or a specified output stream.

Collapse Expand Overload List
Name | Description
PageOut::print (Outfile&) | Prints the output strings to the specified Outfile.
PageOut::print (std::ostream&) | Prints the output strings to the specified stream.
Collapse Expand Group

PageOut Methods

Collapse Expand Links
PageOut Methods


PageOut::print Method (Outfile&)

PageOut::print Method (Outfile&)
PageOut Class PageOut Members print Method

Prints the output strings to the specified Outfile.

C++
void print(
    Outfile& outfile
) const;
Collapse Expand Parameters
Parameters | Description
Outfile& outfile | Output file with page counters.
Collapse Expand Group

print Method

Collapse Expand Links
PageOut Class, PageOut Members, print Method


PageOut::print Method (std::ostream&)

PageOut::print Method (std::ostream&)
PageOut Class PageOut Members print Method

Prints the output strings to the specified stream.

C++
void print(
    std::ostream& ostrm
) const;
Collapse Expand Parameters
Parameters | Description
std::ostream& ostrm | Output stream.
Collapse Expand Group

print Method

Collapse Expand Links
PageOut Class, PageOut Members, print Method


Path Class

Path Class
Path Data Members Path Methods Path Members Path.h Classes

Provides operations on string instances that contain file or directory path information.

Collapse Expand Class Hierarchy
  Path
C++
class Path;
Collapse Expand File

File: Path.h

Module: Misc Library

Collapse Expand Remarks

All members of this class are static and can therefore be called without having an instance of a Path.

Collapse Expand Group

Classes

Collapse Expand Links
Path Data Members, Path Methods, Path Members, Path.h, Classes


Path Members

Path Members
Path Class Legend Public Data Members Public Methods

The following tables list the members exposed by Path.

Collapse Expand Class

Path Class

Collapse Expand Public Data Members
Name | Description
allSeparators | A string with all the possible separator characters.
altDirectorySeparatorChar | The alternate character used to separate directory levels in a path string (forward slash).
directorySeparatorChar | The character used to separate directory levels in a path string (backward slash).
Collapse Expand Public Methods
Name | Description
changeExtension | Changes the extension of a path string.
combine | Combines two path strings.
getDirectoryName | Returns the directory information for the specified path string.
getFileName | Returns the file name information for the specified path string.
getRelativeName | Returns a relative path to the file for the specified path string. This is designed to provide a relative link to a file from an html page.
Collapse Expand Links
Path Class, Legend, Public Data Members, Public Methods


Path Data Members

Path Data Members
Path Class Legend Public Data Members

The data members of the Path class are listed here.

Collapse Expand Class

Path Class

Collapse Expand Public Data Members
Name | Description
allSeparators | A string with all the possible separator characters.
altDirectorySeparatorChar | The alternate character used to separate directory levels in a path string (forward slash).
directorySeparatorChar | The character used to separate directory levels in a path string (backward slash).
Collapse Expand Links
Path Class, Legend, Public Data Members


Path::allSeparators Data Member

Path::allSeparators Data Member
Path Class Path Members Path Data Members

A string with all the possible separator characters.

C++
const std::string allSeparators;
Collapse Expand Group

Path Data Members

Collapse Expand Links
Path Class, Path Members, Path Data Members


Path::altDirectorySeparatorChar Data Member

Path::altDirectorySeparatorChar Data Member
Path Class Path Members Path Data Members

The alternate character used to separate directory levels in a path string (forward slash).

C++
const char altDirectorySeparatorChar = '/';
Collapse Expand Group

Path Data Members

Collapse Expand Links
Path Class, Path Members, Path Data Members


Path::directorySeparatorChar Data Member

Path::directorySeparatorChar Data Member
Path Class Path Members Path Data Members

The character used to separate directory levels in a path string (backward slash).

C++
const char directorySeparatorChar = '\\';
Collapse Expand Group

Path Data Members

Collapse Expand Links
Path Class, Path Members, Path Data Members


Path Methods

Path Methods
Path Class Legend Public Methods

The methods of the Path class are listed here.

Collapse Expand Class

Path Class

Collapse Expand Public Methods
Name | Description
changeExtension | Changes the extension of a path string.
combine | Combines two path strings.
getDirectoryName | Returns the directory information for the specified path string.
getFileName | Returns the file name information for the specified path string.
getRelativeName | Returns a relative path to the file for the specified path string. This is designed to provide a relative link to a file from an html page.
Collapse Expand Links
Path Class, Legend, Public Methods


Path::changeExtension Method

Path::changeExtension Method
Path Class Path Members Path Methods

Changes the extension of a path string.

C++
static std::string changeExtension(
    const std::string& path,
    const std::string& extension
);
Collapse Expand Parameters
Parameters | Description
const std::string& path | The path information to modify.
const std::string& extension | The new extension (with a leading period).
Collapse Expand Returns

The string containing the modified path information.

Collapse Expand Remarks

If the extension argument is empty or consists solely of a period, this function removes any existing extension. Otherwise, if neither path nor extension contains a period, this function adds the period. Then the rest of the extension argument after the period is added.

Collapse Expand Group

Path Methods

Collapse Expand Links
Path Class, Path Members, Path Methods


Path::combine Method

Path::combine Method
Path Class Path Members Path Methods

Combines two path strings.

C++
static std::string combine(
    const std::string& path1,
    const std::string& path2
);
Collapse Expand Parameters
Parameters | Description
const std::string& path1 | The first path.
const std::string& path2 | The second path.
Collapse Expand Returns

A string containing the combined paths.

Collapse Expand Group

Path Methods

Collapse Expand Links
Path Class, Path Members, Path Methods


Path::getDirectoryName Method

Path::getDirectoryName Method
Path Class Path Members Path Methods

Returns the directory information for the specified path string.

C++
static std::string getDirectoryName(
    const std::string& path
);
Collapse Expand Parameters
Parameters | Description
const std::string& path | The path of a file or directory.
Collapse Expand Returns

A string containing directory information for path.

Collapse Expand Group

Path Methods

Collapse Expand Links
Path Class, Path Members, Path Methods


Path::getFileName Method

Path::getFileName Method
Path Class Path Members Path Methods

Returns the file name information for the specified path string.

C++
static std::string getFileName(
    const std::string& path
);
Collapse Expand Parameters
Parameters | Description
const std::string& path | The path of a file or directory.
Collapse Expand Returns

A string containing the file name information for path.

Collapse Expand Group

Path Methods

Collapse Expand Links
Path Class, Path Members, Path Methods


Path::getRelativeName Method

Path::getRelativeName Method
Path Class Path Members Path Methods

Returns a relative path to the file for the specified path string. This is designed to provide a relative link to a file from an html page.

C++
static std::string getRelativeName(
    const std::string& path,
    const int height
);
Collapse Expand Parameters
Parameters | Description
const std::string& path | The path of a file or directory.
const int height | The relative height of the file.
Collapse Expand Returns

A string containing directory information for path.

Collapse Expand Group

Path Methods

Collapse Expand Links
Path Class, Path Members, Path Methods


PiaException Class

PiaException Class
PiaException Constructor PiaException Methods PiaException Members PiaException.h Classes

Manages an exception in the piadata library.

Collapse Expand Class Hierarchy
  PiaException
C++
class PiaException : public std::exception;
Collapse Expand File

File: PiaException.h

Module: Misc Library

Collapse Expand Remarks

The exception could be created with a number, which could be used to look up an associated string in a string table. Alternatively, the exception could be created by a string, in which case the associated number is set to zero.

Collapse Expand Group

Classes

Collapse Expand Links
PiaException Constructor, PiaException Methods, PiaException Members, PiaException.h, Classes


PiaException Members

PiaException Members
PiaException Class Legend Public Methods

The following tables list the members exposed by PiaException.

Collapse Expand Class

PiaException Class

Collapse Expand Public Methods
Name | Description
PiaException | Initializes a PiaException, either from an integer, string, or another PiaException.
getNumber | Returns number of this exception.
what | Returns string with message about this error.
~PiaException | Destructor.
Collapse Expand Links
PiaException Class, Legend, Public Methods


PiaException Constructor

PiaException Constructor
PiaException Class

Initializes a PiaException, either from an integer, string, or another PiaException.

Collapse Expand Description

There are three versions of the PiaException constructor. The number can be specified, in which case the message is initialized with that number as a string. The message can be specified, in which case the number is set to zero. Or the number and message can be copied from another PiaException instance.

Collapse Expand Overload List
Name | Description
PiaException::PiaException (const PiaException&) | Copies a PiaException.
PiaException::PiaException (const std::string&) | Sets the number to 0 and the message to the specified string.
PiaException::PiaException (int) | Sets the number to the specified value and initializes the message to "PiaException: number".
Collapse Expand Class

PiaException Class

Collapse Expand Links
PiaException Class


PiaException::PiaException Constructor (const PiaException&)

PiaException::PiaException Constructor (const PiaException&)
PiaException Class PiaException Members PiaException Constructor

Copies a PiaException.

C++
PiaException(
    const PiaException& piaException
);
Collapse Expand Parameters
Parameters | Description
const PiaException& piaException | The PiaException to copy from.
Collapse Expand Group

PiaException Constructor

Collapse Expand Links
PiaException Class, PiaException Members, PiaException Constructor


PiaException::PiaException Constructor (int)

PiaException::PiaException Constructor (int)
PiaException Class PiaException Members PiaException Constructor

Sets the number to the specified value and initializes the message to "PiaException: number".

C++
PiaException(
    int newNumber
);
Collapse Expand Parameters
Parameters | Description
int newNumber | Number of this exception.
Collapse Expand Group

PiaException Constructor

Collapse Expand Links
PiaException Class, PiaException Members, PiaException Constructor


PiaException::PiaException Constructor (const std::string&)

PiaException::PiaException Constructor (const std::string&)
PiaException Class PiaException Members PiaException Constructor

Sets the number to 0 and the message to the specified string.

C++
PiaException(
    const std::string& newMessage
);
Collapse Expand Parameters
Parameters | Description
const std::string& newMessage | Message of this exception.
Collapse Expand Group

PiaException Constructor

Collapse Expand Links
PiaException Class, PiaException Members, PiaException Constructor


PiaException::~PiaException Destructor

PiaException::~PiaException Destructor
PiaException Class PiaException Members PiaException Class

Destructor.

C++
~PiaException();
Collapse Expand Remarks

Does nothing.

Collapse Expand Class

PiaException Class

Collapse Expand Links
PiaException Class, PiaException Members, PiaException Class


PiaException Methods

PiaException Methods
PiaException Class Legend Public Methods

The methods of the PiaException class are listed here.

Collapse Expand Class

PiaException Class

Collapse Expand Public Methods
Name | Description
getNumber | Returns number of this exception.
what | Returns string with message about this error.
Collapse Expand Links
PiaException Class, Legend, Public Methods


PiaException::getNumber Method

PiaException::getNumber Method
PiaException Class PiaException Members PiaException Methods

Returns number of this exception.

C++
int getNumber() const;
Collapse Expand Returns

Number of this exception.

Collapse Expand Group

PiaException Methods

Collapse Expand Links
PiaException Class, PiaException Members, PiaException Methods


PiaException::what Method

PiaException::what Method
PiaException Class PiaException Members PiaException Methods

Returns string with message about this error.

C++
const char * what() const;
Collapse Expand Returns

String with message about this error.

Collapse Expand Remarks

Note that this overrides a virtual function in the exception class.

Collapse Expand Group

PiaException Methods

Collapse Expand Links
PiaException Class, PiaException Members, PiaException Methods


PunctFacet Structure

PunctFacet Structure
PunctFacet Data Members PunctFacet Methods PunctFacet Members NumPunct.h Classes

Numeric punctuation facet with 3 digits per thousands separator.

C++
struct PunctFacet : public std::numpunct<char> {
  const std::string yearStr[YEAR2200 - YEAR37 + 1];
};
Collapse Expand File

File: NumPunct.h

Module: Misc Library

Collapse Expand Remarks

Numbers are printed with comma separators. Therefore, we store string representations of all the possible years used in our work so they can be printed without comma separators.

An instance of this structure is created in PageOut.

Collapse Expand Group

Classes

Collapse Expand Links
PunctFacet Data Members, PunctFacet Methods, PunctFacet Members, NumPunct.h, Classes


PunctFacet Members

PunctFacet Members
PunctFacet Structure Legend Public Data Members Public Methods

The following tables list the members exposed by PunctFacet.

Collapse Expand Structure

PunctFacet Structure

Collapse Expand Public Data Members
Name | Description
yearStr | String representations of all the years in the output range.
Collapse Expand Public Methods
Name | Description
do_grouping | Returns specification of 3 digits per thousands separator.
getYear | Returns a string representation of the specified year.
Collapse Expand Links
PunctFacet Structure, Legend, Public Data Members, Public Methods


PunctFacet Data Members

PunctFacet Data Members
PunctFacet Structure Legend Public Data Members

The data members of the PunctFacet class are listed here.

Collapse Expand Structure

PunctFacet Structure

Collapse Expand Public Data Members
Name | Description
yearStr | String representations of all the years in the output range.
Collapse Expand Links
PunctFacet Structure, Legend, Public Data Members


PunctFacet::yearStr Data Member

PunctFacet::yearStr Data Member
PunctFacet Structure PunctFacet Members PunctFacet Data Members

String representations of all the years in the output range.

C++
const std::string yearStr[YEAR2200 - YEAR37 + 1];
Collapse Expand Group

PunctFacet Data Members

Collapse Expand Links
PunctFacet Structure, PunctFacet Members, PunctFacet Data Members


PunctFacet Methods

PunctFacet Methods
PunctFacet Structure Legend Public Methods

The methods of the PunctFacet class are listed here.

Collapse Expand Structure

PunctFacet Structure

Collapse Expand Public Methods
Name | Description
do_grouping | Returns specification of 3 digits per thousands separator.
getYear | Returns a string representation of the specified year.
Collapse Expand Links
PunctFacet Structure, Legend, Public Methods


PunctFacet::do_grouping Method

PunctFacet::do_grouping Method
PunctFacet Structure PunctFacet Members PunctFacet Methods

Returns specification of 3 digits per thousands separator.

C++
std::string do_grouping() const;
Collapse Expand Returns

Specification of 3 digits per thousands separator.

Collapse Expand Group

PunctFacet Methods

Collapse Expand Links
PunctFacet Structure, PunctFacet Members, PunctFacet Methods


PunctFacet::getYear Method

PunctFacet::getYear Method
PunctFacet Structure PunctFacet Members PunctFacet Methods

Returns a string representation of the specified year.

C++
static std::string getYear(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | The year to convert to a string.
Collapse Expand Returns

A string representation of the specified year.

Collapse Expand Group

PunctFacet Methods

Collapse Expand Links
PunctFacet Structure, PunctFacet Members, PunctFacet Methods


QtrYear Class

QtrYear Class
QtrYear Constructor QtrYear Methods QtrYear Operators QtrYear Friends QtrYear Members qtryear.h Classes

Manages a year and quarter stored as unsigned integers.

Collapse Expand Class Hierarchy
  QtrYear
C++
class QtrYear;
Collapse Expand File

File: qtryear.h

Module: Misc Library

Collapse Expand Remarks

The quarter and year are stored as unsigned shorts to save space. The quarter is 0 to 3, and the year is 1 to 65000.

Collapse Expand Group

Classes

Collapse Expand Links
QtrYear Constructor, QtrYear Methods, QtrYear Operators, QtrYear Friends, QtrYear Members, qtryear.h, Classes


QtrYear Members

QtrYear Members
QtrYear Class Legend Public Friends Public Methods

The following tables list the members exposed by QtrYear.

Collapse Expand Class

QtrYear Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Name | Description
QtrYear | Initializes a QtrYear, either as a default or from a variety of calendar instances.
add | Adds a quarterly time period to this instance.
check | Checks for valid quarter and year.
deleteContents | Zeroes quarter and year.
diff | Calculates difference of two quarter-year periods as an integer number of quarters.
getQuarter | Returns quarter (0-3).
getYear | Returns year.
qtrCheck | Checks for quarter in bounds.
setQuarter | Sets quarter.
setYear | Sets year.
subtract | Subtracts a quarterly time period from this one.
toDateMoyr | Converts this quarter and year to a month and year.
toString | Returns string representation of quarter and year.
yearCheck | Checks for year in bounds.
~QtrYear | Destructor.
Collapse Expand Public Operators
Name | Description
< | Compares this date to another one.
= | Sets quarter and year from a calendar date.
== | Compares this quarter and year to another one for equality.
Collapse Expand Links
QtrYear Class, Legend, Public Friends, Public Methods


QtrYear Constructor

QtrYear Constructor
QtrYear Class

Initializes a QtrYear, either as a default or from a variety of calendar instances.

Collapse Expand Description

There are five constructors for the QtrYear class. The quarter and year can be set to default values (0), values from a boost::gregorian::date or DateMoyr instance, values from an array of integers, or values from two separate integers.

Collapse Expand Overload List
Name | Description
QtrYear::QtrYear () | Initializes the quarter and year to 0.
QtrYear::QtrYear (const DateMoyr&) | Initializes the quarter and year from a DateMoyr.
QtrYear::QtrYear (const boost::gregorian::date&) | Initializes the quarter and year from a boost::gregorian::date.
QtrYear::QtrYear (unsigned) | Initializes the quarter and year from an array of size 2.
QtrYear::QtrYear (unsigned, unsigned) | Initializes the quarter and year from two specified values.
Collapse Expand Class

QtrYear Class

Collapse Expand Links
QtrYear Class


QtrYear::QtrYear Constructor ()

QtrYear::QtrYear Constructor ()
QtrYear Class QtrYear Members QtrYear Constructor

Initializes the quarter and year to 0.

C++
QtrYear();
Collapse Expand Group

QtrYear Constructor

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Constructor


QtrYear::QtrYear Constructor (const DateMoyr&)

QtrYear::QtrYear Constructor (const DateMoyr&)
QtrYear Class QtrYear Members QtrYear Constructor

Initializes the quarter and year from a DateMoyr.

C++
QtrYear(
    const DateMoyr& dateMoyr
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& dateMoyr | The date to use.
Collapse Expand Remarks

Quarter is set to 0 for months 0-2, 1 for months 3-5, 2 for months 6-8, or 3 for months 9-11.

Collapse Expand Group

QtrYear Constructor

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Constructor


QtrYear::QtrYear Constructor (const boost::gregorian::date&)

QtrYear::QtrYear Constructor (const boost::gregorian::date&)
QtrYear Class QtrYear Members QtrYear Constructor

Initializes the quarter and year from a boost::gregorian::date.

C++
QtrYear(
    const boost::gregorian::date& dateModyyr
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& dateModyyr | The date to use.
Collapse Expand Remarks

Quarter is set to 0 for months 0-2, 1 for months 3-5, 2 for months 6-8, or 3 for months 9-11.

Collapse Expand Group

QtrYear Constructor

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Constructor


QtrYear::QtrYear Constructor (unsigned)

QtrYear::QtrYear Constructor (unsigned)
QtrYear Class QtrYear Members QtrYear Constructor

Initializes the quarter and year from an array of size 2.

C++
QtrYear(
    unsigned newQtrYear[2]
);
Collapse Expand Parameters
Parameters | Description
unsigned newQtrYear[2] | Quarter and year in an array.
Collapse Expand Group

QtrYear Constructor

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Constructor


QtrYear::QtrYear Constructor (unsigned, unsigned)

QtrYear::QtrYear Constructor (unsigned, unsigned)
QtrYear Class QtrYear Members QtrYear Constructor

Initializes the quarter and year from two specified values.

C++
QtrYear(
    unsigned newQuarter,
    unsigned newYear
);
Collapse Expand Parameters
Parameters | Description
unsigned newQuarter | Quarter of year (0-3) to use.
unsigned newYear | Year to use.
Collapse Expand Group

QtrYear Constructor

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Constructor


QtrYear::~QtrYear Destructor

QtrYear::~QtrYear Destructor
QtrYear Class QtrYear Members QtrYear Class

Destructor.

C++
~QtrYear();
Collapse Expand Remarks

Does nothing.

Collapse Expand Class

QtrYear Class

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Class


QtrYear Methods

QtrYear Methods
QtrYear Class Legend Public Methods

The methods of the QtrYear class are listed here.

Collapse Expand Class

QtrYear Class

Collapse Expand Public Methods
Name | Description
add | Adds a quarterly time period to this instance.
check | Checks for valid quarter and year.
deleteContents | Zeroes quarter and year.
diff | Calculates difference of two quarter-year periods as an integer number of quarters.
getQuarter | Returns quarter (0-3).
getYear | Returns year.
qtrCheck | Checks for quarter in bounds.
setQuarter | Sets quarter.
setYear | Sets year.
subtract | Subtracts a quarterly time period from this one.
toDateMoyr | Converts this quarter and year to a month and year.
toString | Returns string representation of quarter and year.
yearCheck | Checks for year in bounds.
Collapse Expand Links
QtrYear Class, Legend, Public Methods


add Method

add Method
QtrYear Methods

Adds a quarterly time period to this instance.

Collapse Expand Description

There are two versions of the add method. The method can add either another QtrYear or a specified number of quarters to this one.

Collapse Expand Overload List
Name | Description
QtrYear::add (const QtrYear&) | Adds a (quarter,year) date to this one.
QtrYear::add (unsigned) | Adds a number of quarters this one.
Collapse Expand Group

QtrYear Methods

Collapse Expand Links
QtrYear Methods


QtrYear::add Method (const QtrYear&)

QtrYear::add Method (const QtrYear&)
QtrYear Class QtrYear Members add Method

Adds a (quarter,year) date to this one.

C++
void add(
    const QtrYear& addQtrYear
);
Collapse Expand Parameters
Parameters | Description
const QtrYear& addQtrYear | The (quarter,year) date to add.
Collapse Expand Group

add Method

Collapse Expand Links
QtrYear Class, QtrYear Members, add Method


QtrYear::add Method (unsigned)

QtrYear::add Method (unsigned)
QtrYear Class QtrYear Members add Method

Adds a number of quarters this one.

C++
void add(
    unsigned addQuarter
);
Collapse Expand Parameters
Parameters | Description
unsigned addQuarter | The number of quarters to add.
Collapse Expand Group

add Method

Collapse Expand Links
QtrYear Class, QtrYear Members, add Method


QtrYear::check Method

QtrYear::check Method
QtrYear Class QtrYear Members QtrYear Methods

Checks for valid quarter and year.

C++
void check() const;
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException if date is not ok.
Collapse Expand Group

QtrYear Methods

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Methods


QtrYear::deleteContents Method

QtrYear::deleteContents Method
QtrYear Class QtrYear Members QtrYear Methods

Zeroes quarter and year.

C++
void deleteContents();
Collapse Expand Group

QtrYear Methods

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Methods


QtrYear::diff Method

QtrYear::diff Method
QtrYear Class QtrYear Members QtrYear Methods

Calculates difference of two quarter-year periods as an integer number of quarters.

C++
static int diff(
    const QtrYear& qtrYear1,
    const QtrYear& qtrYear2
);
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear1 | First period.
const QtrYear& qtrYear2 | Second period.
Collapse Expand Returns

Difference as an integer number of quarters. Result is negative if second period is before first period.

Collapse Expand Group

QtrYear Methods

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Methods


QtrYear::getQuarter Method

QtrYear::getQuarter Method
QtrYear Class QtrYear Members QtrYear Methods

Returns quarter (0-3).

C++
unsigned getQuarter() const;
Collapse Expand Returns

Quarter of year (0-3).

Collapse Expand Group

QtrYear Methods

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Methods


QtrYear::getYear Method

QtrYear::getYear Method
QtrYear Class QtrYear Members QtrYear Methods

Returns year.

C++
unsigned getYear() const;
Collapse Expand Returns

The year.

Collapse Expand Group

QtrYear Methods

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Methods


QtrYear::qtrCheck Method

QtrYear::qtrCheck Method
QtrYear Class QtrYear Members QtrYear Methods

Checks for quarter in bounds.

C++
void qtrCheck() const;
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QTRYRQTR if quarter is greater than 3.
Collapse Expand Group

QtrYear Methods

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Methods


QtrYear::setQuarter Method

QtrYear::setQuarter Method
QtrYear Class QtrYear Members QtrYear Methods

Sets quarter.

C++
void setQuarter(
    unsigned newQuarter
);
Collapse Expand Parameters
Parameters | Description
unsigned newQuarter | New quarter of year (0-3).
Collapse Expand Group

QtrYear Methods

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Methods


QtrYear::setYear Method

QtrYear::setYear Method
QtrYear Class QtrYear Members QtrYear Methods

Sets year.

C++
void setYear(
    unsigned newYear
);
Collapse Expand Parameters
Parameters | Description
unsigned newYear | New year.
Collapse Expand Group

QtrYear Methods

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Methods


subtract Method

subtract Method
QtrYear Methods

Subtracts a quarterly time period from this one.

Collapse Expand Description

There are two versions of the subtract method. The method can subtract either another QtrYear or a specified number of quarters from this one.

Collapse Expand Overload List
Name | Description
QtrYear::subtract (const QtrYear&) | Subtracts a number of (quarter,year) date from this one.
QtrYear::subtract (unsigned) | Subtracts a number of quarters from this one.
Collapse Expand Group

QtrYear Methods

Collapse Expand Links
QtrYear Methods


QtrYear::subtract Method (const QtrYear&)

QtrYear::subtract Method (const QtrYear&)
QtrYear Class QtrYear Members subtract Method

Subtracts a number of (quarter,year) date from this one.

C++
void subtract(
    const QtrYear& subQtrYear
);
Collapse Expand Parameters
Parameters | Description
const QtrYear& subQtrYear | (quarters,year) date to subtract.
Collapse Expand Group

subtract Method

Collapse Expand Links
QtrYear Class, QtrYear Members, subtract Method


QtrYear::subtract Method (unsigned)

QtrYear::subtract Method (unsigned)
QtrYear Class QtrYear Members subtract Method

Subtracts a number of quarters from this one.

C++
void subtract(
    unsigned subQuarter
);
Collapse Expand Parameters
Parameters | Description
unsigned subQuarter | Number of quarters to subtract.
Collapse Expand Group

subtract Method

Collapse Expand Links
QtrYear Class, QtrYear Members, subtract Method


QtrYear::toDateMoyr Method

QtrYear::toDateMoyr Method
QtrYear Class QtrYear Members QtrYear Methods

Converts this quarter and year to a month and year.

C++
DateMoyr toDateMoyr() const;
Collapse Expand Returns

The converted month and year.

Collapse Expand Group

QtrYear Methods

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Methods


QtrYear::toString Method

QtrYear::toString Method
QtrYear Class QtrYear Members QtrYear Methods

Returns string representation of quarter and year.

C++
std::string toString() const;
Collapse Expand Returns

String representation of quarter and year, for example "qtr 3 of 1999".

Collapse Expand Group

QtrYear Methods

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Methods


QtrYear::yearCheck Method

QtrYear::yearCheck Method
QtrYear Class QtrYear Members QtrYear Methods

Checks for year in bounds.

C++
void yearCheck() const;
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_QTRYRYR if year is greater than Date::highyear.
Collapse Expand Group

QtrYear Methods

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Methods


QtrYear Operators

QtrYear Operators
QtrYear Class Legend

The operators of the QtrYear class are listed here.

Collapse Expand Class

QtrYear Class

Collapse Expand Public Operators
Name | Description
< | Compares this date to another one.
= | Sets quarter and year from a calendar date.
== | Compares this quarter and year to another one for equality.
Collapse Expand Links
QtrYear Class, Legend


QtrYear::< Operator

QtrYear::< Operator
QtrYear Class QtrYear Members QtrYear Operators

Compares this date to another one.

C++
bool operator <(
    const QtrYear& qtrYear
) const;
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | The date to compare to.
Collapse Expand Returns

True if this date is before argument, false otherwise.

Collapse Expand Group

QtrYear Operators

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Operators


= Operator

= Operator
QtrYear Operators

Sets quarter and year from a calendar date.

Collapse Expand Description

There are three possible arguments for this operator: a date with month, day, and year, a date with month and year, or another Qtryear.

Collapse Expand Overload List
Name | Description
QtrYear::= (const DateMoyr&) | Sets quarter and year from a date with months and years.
QtrYear::= (const QtrYear&) | Sets quarter and year from a QtrYear.
QtrYear::= (const boost::gregorian::date&) | Sets quarter and year from a date.
Collapse Expand Group

QtrYear Operators

Collapse Expand Links
QtrYear Operators


QtrYear::= Operator (const DateMoyr&)

QtrYear::= Operator (const DateMoyr&)
QtrYear Class QtrYear Members = Operator

Sets quarter and year from a date with months and years.

C++
QtrYear& operator =(
    const DateMoyr& date
);
Collapse Expand Parameters
Parameters | Description
const DateMoyr& date | The date to use.
Collapse Expand Returns

A reference to this instance.

Collapse Expand Group

= Operator

Collapse Expand Links
QtrYear Class, QtrYear Members, = Operator


QtrYear::= Operator (const QtrYear&)

QtrYear::= Operator (const QtrYear&)
QtrYear Class QtrYear Members = Operator

Sets quarter and year from a QtrYear.

C++
QtrYear& operator =(
    const QtrYear& qtrYear
);
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | The other QtrYear to use.
Collapse Expand Returns

A reference to this instance.

Collapse Expand Group

= Operator

Collapse Expand Links
QtrYear Class, QtrYear Members, = Operator


QtrYear::= Operator (const boost::gregorian::date&)

QtrYear::= Operator (const boost::gregorian::date&)
QtrYear Class QtrYear Members = Operator

Sets quarter and year from a date.

C++
QtrYear& operator =(
    const boost::gregorian::date& date
);
Collapse Expand Parameters
Parameters | Description
const boost::gregorian::date& date | The date to use.
Collapse Expand Returns

A reference to this instance.

Collapse Expand Group

= Operator

Collapse Expand Links
QtrYear Class, QtrYear Members, = Operator


QtrYear::== Operator

QtrYear::== Operator
QtrYear Class QtrYear Members QtrYear Operators

Compares this quarter and year to another one for equality.

C++
bool operator ==(
    const QtrYear& qtrYear
) const;
Collapse Expand Parameters
Parameters | Description
const QtrYear& qtrYear | The quarter and year to compare to.
Collapse Expand Returns

True if this quarter and year is equal to argument, false otherwise.

Collapse Expand Group

QtrYear Operators

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Operators


QtrYear Friends

QtrYear Friends
QtrYear Class Public Friends

The friends of the QtrYear class are listed here.

Collapse Expand Class

QtrYear Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Links
QtrYear Class, Public Friends


friend class boost::serialization::access Friend

friend class boost::serialization::access Friend
QtrYear Class QtrYear Members QtrYear Friends

Friend class to allow serialization.

C++
friend class boost::serialization::access;
Collapse Expand Group

QtrYear Friends

Collapse Expand Links
QtrYear Class, QtrYear Members, QtrYear Friends


Sex Class

Sex Class
Sex Constructor Sex Enumerations Sex Methods Sex Operators Sex Members Sex.h Classes

Indicator for sex type.

Collapse Expand Class Hierarchy
  Sex
C++
class Sex;
Collapse Expand File

File: Sex.h

Module: Misc Library

Collapse Expand Remarks

Most functions are inline for efficiency.

Collapse Expand Group

Classes

Collapse Expand Links
Sex Constructor, Sex Enumerations, Sex Methods, Sex Operators, Sex Members, Sex.h, Classes


Sex Members

Sex Members
Enumerations Sex Class Legend Public Methods

The following tables list the members exposed by Sex.

Collapse Expand Enumerations
Name | Description
sex_type | The enumerated sex indicator.
Collapse Expand Class

Sex Class

Collapse Expand Public Methods
Name | Description
Sex | Initializes the Sex, either as a default, or from a Sex instance or a Sex::sex_type.
check | Checks sex.
toString | Returns an output label for the sex of the person.
~Sex | Destructor.
Collapse Expand Public Operators
Name | Description
= | Copies from another Sex.
Collapse Expand Links
Enumerations, Sex Class, Legend, Public Methods


Sex Constructor

Sex Constructor
Sex Class

Initializes the Sex, either as a default, or from a Sex instance or a Sex::sex_type.

Collapse Expand Description

There are three versions of the Sex constructor. The default constructor initializes the sex to Sex::sex_type::MALE. Otherwise the sex is initialized from a Sex instance or a Sex::sex_type.

Collapse Expand Overload List
Name | Description
Sex::Sex () | Sets the sex code to Sex::sex_type::MALE.
Sex::Sex (const Sex&) | Copies the sex code from another Sex.
Sex::Sex (sex_type) | Sets the sex code to a new sex code.
Collapse Expand Class

Sex Class

Collapse Expand Links
Sex Class


Sex::Sex Constructor ()

Sex::Sex Constructor ()
Sex Class Sex Members Sex Constructor

Sets the sex code to Sex::sex_type::MALE.

C++
Sex();
Collapse Expand Group

Sex Constructor

Collapse Expand Links
Sex Class, Sex Members, Sex Constructor


Sex::Sex Constructor (const Sex&)

Sex::Sex Constructor (const Sex&)
Sex Class Sex Members Sex Constructor

Copies the sex code from another Sex.

C++
Sex(
    const Sex& sex
);
Collapse Expand Parameters
Parameters | Description
const Sex& sex | The Sex to copy from.
Collapse Expand Group

Sex Constructor

Collapse Expand Links
Sex Class, Sex Members, Sex Constructor


Sex::Sex Constructor (sex_type)

Sex::Sex Constructor (sex_type)
Sex Class Sex Members Sex Constructor

Sets the sex code to a new sex code.

C++
Sex(
    sex_type newCode
);
Collapse Expand Parameters
Parameters | Description
sex_type newCode | New sex code.
Collapse Expand Group

Sex Constructor

Collapse Expand Links
Sex Class, Sex Members, Sex Constructor


Sex::~Sex Destructor

Sex::~Sex Destructor
Sex Class Sex Members Sex Class

Destructor.

C++
~Sex();
Collapse Expand Remarks

Does nothing.

Collapse Expand Class

Sex Class

Collapse Expand Links
Sex Class, Sex Members, Sex Class


Sex Enumerations

Sex Enumerations
Enumerations Sex Class Legend

The enumerations of the Sex class are listed here.

Collapse Expand Enumerations
Name | Description
sex_type | The enumerated sex indicator.
Collapse Expand Class

Sex Class

Collapse Expand Links
Enumerations, Sex Class, Legend


Sex::sex_type Enumeration

Sex::sex_type Enumeration
Sex.h Sex Enumerations

The enumerated sex indicator.

C++
enum sex_type {
  MALE,
  FEMALE,
  NUM_SEX
};
Collapse Expand File

File: Sex.h

Module: Misc Library

Collapse Expand Members
Members | Description
MALE | Male.
FEMALE | Female.
NUM_SEX | Number of sexes.
Collapse Expand Group

Sex Enumerations

Collapse Expand Links
Sex.h, Sex Enumerations


Sex Methods

Sex Methods
Sex Class Legend Public Methods

The methods of the Sex class are listed here.

Collapse Expand Class

Sex Class

Collapse Expand Public Methods
Name | Description
check | Checks sex.
toString | Returns an output label for the sex of the person.
Collapse Expand Links
Sex Class, Legend, Public Methods


Sex::check Method

Sex::check Method
Sex Class Sex Members Sex Methods

Checks sex.

C++
static void check(
    int newSex
);
Collapse Expand Parameters
Parameters | Description
int newSex | The sex value to check.
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_SEX if the argument is not Sex::sex_type::MALE or Sex::sex_type::FEMALE.
Collapse Expand Group

Sex Methods

Collapse Expand Links
Sex Class, Sex Members, Sex Methods


toString Method

toString Method
Sex Methods

Returns an output label for the sex of the person.

Collapse Expand Description

There are two versions of this function. The one without an argument returns the default label. The one with a format string allows a choice of label format.

Collapse Expand Overload List
Name | Description
Sex::toString () | Returns default output label for sex of worker.
Sex::toString (const std::string&) | Returns specified output label for sex of worker.
Collapse Expand Group

Sex Methods

Collapse Expand Links
Sex Methods


Sex::toString Method ()

Sex::toString Method ()
Sex Class Sex Members toString Method

Returns default output label for sex of worker.

C++
std::string toString() const;
Collapse Expand Returns

Output label for sex of worker.

Collapse Expand Remarks

Returns a lower-case string.

Collapse Expand Group

toString Method

Collapse Expand Links
Sex Class, Sex Members, toString Method


Sex::toString Method (const std::string&)

Sex::toString Method (const std::string&)
Sex Class Sex Members toString Method

Returns specified output label for sex of worker.

C++
std::string toString(
    const std::string& format
) const;
Collapse Expand Parameters
Parameters | Description
const std::string& format | Format to use. If "c", return capitalized string. Otherwise, return lower-case string.
Collapse Expand Returns

Output label for sex of worker.

Collapse Expand Group

toString Method

Collapse Expand Links
Sex Class, Sex Members, toString Method


Sex Operators

Sex Operators
Sex Class Legend

The operators of the Sex class are listed here.

Collapse Expand Class

Sex Class

Collapse Expand Public Operators
Name | Description
= | Copies from another Sex.
Collapse Expand Links
Sex Class, Legend


Sex::= Operator

Sex::= Operator
Sex Class Sex Members Sex Operators

Copies from another Sex.

C++
Sex& operator =(
    const Sex& sex
);
Collapse Expand Parameters
Parameters | Description
const Sex& sex | The Sex to copy from.
Collapse Expand Returns

A reference to this instance.

Collapse Expand Group

Sex Operators

Collapse Expand Links
Sex Class, Sex Members, Sex Operators


Ssn Class

Ssn Class
Ssn Constructor Ssn Methods Ssn Operators Ssn Friends Ssn Members ssn.h Classes

Manages a Social Security number string, and the 3 parts of an ssn separately as strings.

Collapse Expand Class Hierarchy
  Ssn
C++
class Ssn;
Collapse Expand File

File: ssn.h

Module: Misc Library

Collapse Expand Remarks

An instance of this class is a member of WorkerData.

Collapse Expand Group

Classes

Collapse Expand Links
Ssn Constructor, Ssn Methods, Ssn Operators, Ssn Friends, Ssn Members, ssn.h, Classes


Ssn Members

Ssn Members
Ssn Class Legend Public Friends Public Methods

The following tables list the members exposed by Ssn.

Collapse Expand Class

Ssn Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Public Methods
Name | Description
Ssn | Initializes an Ssn, either as a default or as specified.
deleteContents | Zeroes the three parts.
getPart1 | Returns first part of ssn.
getPart2 | Returns second part of ssn.
getPart3 | Returns third part of ssn.
setPart1 | Sets first part of ssn.
setPart2 | Sets second part of ssn.
setPart3 | Sets third part of ssn.
setSsnFull | Sets the full ssn.
toNumber | Returns ssn converted to a number.
toString | Returns the ssn as a string.
update | Updates full ssn from three parts.
~Ssn | Destructor.
Collapse Expand Public Operators
Name | Description
< | Compares to another Ssn.
= | Copies from another Ssn.
== | Compares to another Ssn.
Collapse Expand Links
Ssn Class, Legend, Public Friends, Public Methods


Ssn Constructor

Ssn Constructor
Ssn Class

Initializes an Ssn, either as a default or as specified.

Collapse Expand Description

There are four versions of the Ssn constructor. The default constructor sets all three parts to zero. The ssn can be specified as three parts, or as one string representing the full ssn. Or the ssn can be copied from another Ssn.

Collapse Expand Overload List
Name | Description
Ssn::Ssn () | Creates ssn, initializing all fields with zeroes.
Ssn::Ssn (const Ssn&) | Copies from another Ssn.
Ssn::Ssn (const std::string&) | Creates ssn by using one string without hyphens.
Ssn::Ssn (const std::string&, const std::string&, const std::string&) | Creates ssn by using the three specified parts.
Collapse Expand Class

Ssn Class

Collapse Expand Links
Ssn Class


Ssn::Ssn Constructor ()

Ssn::Ssn Constructor ()
Ssn Class Ssn Members Ssn Constructor

Creates ssn, initializing all fields with zeroes.

C++
Ssn();
Collapse Expand Group

Ssn Constructor

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Constructor


Ssn::Ssn Constructor (const Ssn&)

Ssn::Ssn Constructor (const Ssn&)
Ssn Class Ssn Members Ssn Constructor

Copies from another Ssn.

C++
Ssn(
    const Ssn& ssn
);
Collapse Expand Parameters
Parameters | Description
const Ssn& ssn | The Ssn to copy from.
Collapse Expand Group

Ssn Constructor

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Constructor


Ssn::Ssn Constructor (const std::string&)

Ssn::Ssn Constructor (const std::string&)
Ssn Class Ssn Members Ssn Constructor

Creates ssn by using one string without hyphens.

C++
Ssn(
    const std::string& newSsn
);
Collapse Expand Parameters
Parameters | Description
const std::string& newSsn | String to use for full ssn.
Collapse Expand Group

Ssn Constructor

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Constructor


Ssn::Ssn Constructor (const std::string&, const std::string&, const std::string&)

Ssn::Ssn Constructor (const std::string&, const std::string&, const std::string&)
Ssn Class Ssn Members Ssn Constructor

Creates ssn by using the three specified parts.

C++
Ssn(
    const std::string& newSsnPart1,
    const std::string& newSsnPart2,
    const std::string& newSsnPart3
);
Collapse Expand Parameters
Parameters | Description
const std::string& newSsnPart1 | First part of ssn.
const std::string& newSsnPart2 | Second part of ssn.
const std::string& newSsnPart3 | Third part of ssn.
Collapse Expand Group

Ssn Constructor

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Constructor


Ssn::~Ssn Destructor

Ssn::~Ssn Destructor
Ssn Class Ssn Members Ssn Class

Destructor.

C++
~Ssn();
Collapse Expand Remarks

Does nothing.

Collapse Expand Class

Ssn Class

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Class


Ssn Methods

Ssn Methods
Ssn Class Legend Public Methods

The methods of the Ssn class are listed here.

Collapse Expand Class

Ssn Class

Collapse Expand Public Methods
Name | Description
deleteContents | Zeroes the three parts.
getPart1 | Returns first part of ssn.
getPart2 | Returns second part of ssn.
getPart3 | Returns third part of ssn.
setPart1 | Sets first part of ssn.
setPart2 | Sets second part of ssn.
setPart3 | Sets third part of ssn.
setSsnFull | Sets the full ssn.
toNumber | Returns ssn converted to a number.
toString | Returns the ssn as a string.
update | Updates full ssn from three parts.
Collapse Expand Links
Ssn Class, Legend, Public Methods


Ssn::deleteContents Method

Ssn::deleteContents Method
Ssn Class Ssn Members Ssn Methods

Zeroes the three parts.

C++
void deleteContents();
Collapse Expand Group

Ssn Methods

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Methods


Ssn::getPart1 Method

Ssn::getPart1 Method
Ssn Class Ssn Members Ssn Methods

Returns first part of ssn.

C++
const std::string& getPart1() const;
Collapse Expand Returns

First part of ssn.

Collapse Expand Group

Ssn Methods

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Methods


Ssn::getPart2 Method

Ssn::getPart2 Method
Ssn Class Ssn Members Ssn Methods

Returns second part of ssn.

C++
const std::string& getPart2() const;
Collapse Expand Returns

Second part of ssn.

Collapse Expand Group

Ssn Methods

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Methods


Ssn::getPart3 Method

Ssn::getPart3 Method
Ssn Class Ssn Members Ssn Methods

Returns third part of ssn.

C++
const std::string& getPart3() const;
Collapse Expand Returns

Third part of ssn.

Collapse Expand Group

Ssn Methods

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Methods


Ssn::setPart1 Method

Ssn::setPart1 Method
Ssn Class Ssn Members Ssn Methods

Sets first part of ssn.

C++
void setPart1(
    const std::string& newPart1
);
Collapse Expand Parameters
Parameters | Description
const std::string& newPart1 | New first part of ssn.
Collapse Expand Group

Ssn Methods

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Methods


Ssn::setPart2 Method

Ssn::setPart2 Method
Ssn Class Ssn Members Ssn Methods

Sets second part of ssn.

C++
void setPart2(
    const std::string& newPart2
);
Collapse Expand Parameters
Parameters | Description
const std::string& newPart2 | New second part of ssn.
Collapse Expand Group

Ssn Methods

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Methods


Ssn::setPart3 Method

Ssn::setPart3 Method
Ssn Class Ssn Members Ssn Methods

Sets third part of ssn.

C++
void setPart3(
    const std::string& newPart3
);
Collapse Expand Parameters
Parameters | Description
const std::string& newPart3 | New third part of ssn.
Collapse Expand Group

Ssn Methods

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Methods


setSsnFull Method

setSsnFull Method
Ssn Methods

Sets the full ssn.

Collapse Expand Description

There are two versions of the setSsnFull method. The ssn can be specified as three parts, or as one string representing the full ssn.

Collapse Expand Overload List
Name | Description
Ssn::setSsnFull (const std::string&) | Sets the full ssn by using one string without hyphens.
Ssn::setSsnFull (const std::string&, const std::string&, const std::string&) | Sets the full ssn by using the three specified parts.
Collapse Expand Group

Ssn Methods

Collapse Expand Links
Ssn Methods


Ssn::setSsnFull Method (const std::string&)

Ssn::setSsnFull Method (const std::string&)
Ssn Class Ssn Members setSsnFull Method

Sets the full ssn by using one string without hyphens.

C++
void setSsnFull(
    const std::string& newSsnFull
);
Collapse Expand Parameters
Parameters | Description
const std::string& newSsnFull | String to use for full ssn (without hyphens).
Collapse Expand Remarks

One string is used, the full ssn is set from that, then the three parts are parsed.

Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_SSN1 if there any string-handling problems.
Collapse Expand Group

setSsnFull Method

Collapse Expand Links
Ssn Class, Ssn Members, setSsnFull Method


Ssn::setSsnFull Method (const std::string&, const std::string&, const std::string&)

Ssn::setSsnFull Method (const std::string&, const std::string&, const std::string&)
Ssn Class Ssn Members setSsnFull Method

Sets the full ssn by using the three specified parts.

C++
void setSsnFull(
    const std::string& newSsnPart1,
    const std::string& newSsnPart2,
    const std::string& newSsnPart3
);
Collapse Expand Parameters
Parameters | Description
const std::string& newSsnPart1 | First part of ssn.
const std::string& newSsnPart2 | Second part of ssn.
const std::string& newSsnPart3 | Third part of ssn.
Collapse Expand Remarks

Three strings are used, the three parts are set, then the full ssn is set from the concatenated parts.

Collapse Expand Group

setSsnFull Method

Collapse Expand Links
Ssn Class, Ssn Members, setSsnFull Method


Ssn::toNumber Method

Ssn::toNumber Method
Ssn Class Ssn Members Ssn Methods

Returns ssn converted to a number.

C++
long toNumber() const;
Collapse Expand Returns

The ssn converted to a number. It could be as large as 999999999.

Collapse Expand Group

Ssn Methods

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Methods


toString Method

toString Method
Ssn Methods

Returns the ssn as a string.

Collapse Expand Description

There are two versions of the toString method. The one without an argument returns the ssn as a string with hyphens separating the three parts. The one with a format argument uses that argument to determine the format of the returned ssn string.

Collapse Expand Overload List
Name | Description
Ssn::toString () | Returns formatted ssn with hyphens separating the three parts.
Ssn::toString (const std::string&) | Returns formatted ssn.
Collapse Expand Group

Ssn Methods

Collapse Expand Links
Ssn Methods


Ssn::toString Method ()

Ssn::toString Method ()
Ssn Class Ssn Members toString Method

Returns formatted ssn with hyphens separating the three parts.

C++
std::string toString() const;
Collapse Expand Returns

Formatted ssn.

Collapse Expand Group

toString Method

Collapse Expand Links
Ssn Class, Ssn Members, toString Method


Ssn::toString Method (const std::string&)

Ssn::toString Method (const std::string&)
Ssn Class Ssn Members toString Method

Returns formatted ssn.

C++
std::string toString(
    const std::string& format
) const;
Collapse Expand Parameters
Parameters | Description
const std::string& format | Format to use.
Collapse Expand Returns

Formatted ssn.

Collapse Expand Remarks

If the format string begins with "n", do not use hyphens; otherwise use hyphens separating the three parts.

Collapse Expand Group

toString Method

Collapse Expand Links
Ssn Class, Ssn Members, toString Method


Ssn::update Method

Ssn::update Method
Ssn Class Ssn Members Ssn Methods

Updates full ssn from three parts.

C++
void update();
Collapse Expand Group

Ssn Methods

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Methods


Ssn Operators

Ssn Operators
Ssn Class Legend

The operators of the Ssn class are listed here.

Collapse Expand Class

Ssn Class

Collapse Expand Public Operators
Name | Description
< | Compares to another Ssn.
= | Copies from another Ssn.
== | Compares to another Ssn.
Collapse Expand Links
Ssn Class, Legend


Ssn::< Operator

Ssn::< Operator
Ssn Class Ssn Members Ssn Operators

Compares to another Ssn.

C++
bool operator <(
    const Ssn& ssntemp
) const;
Collapse Expand Parameters
Parameters | Description
const Ssn& ssntemp | Ssn to compare to.
Collapse Expand Returns

True if this Ssn is less than the argument Ssn, false otherwise.

Collapse Expand Group

Ssn Operators

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Operators


Ssn::= Operator

Ssn::= Operator
Ssn Class Ssn Members Ssn Operators

Copies from another Ssn.

C++
Ssn& operator =(
    const Ssn& ssn
);
Collapse Expand Parameters
Parameters | Description
const Ssn& ssn | The Ssn to copy from.
Collapse Expand Returns

A reference to this instance.

Collapse Expand Group

Ssn Operators

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Operators


Ssn::== Operator

Ssn::== Operator
Ssn Class Ssn Members Ssn Operators

Compares to another Ssn.

C++
bool operator ==(
    const Ssn& ssntemp
) const;
Collapse Expand Parameters
Parameters | Description
const Ssn& ssntemp | Ssn to compare to.
Collapse Expand Returns

True if this Ssn is equal to the argument Ssn, false otherwise.

Collapse Expand Group

Ssn Operators

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Operators


Ssn Friends

Ssn Friends
Ssn Class Public Friends

The friends of the Ssn class are listed here.

Collapse Expand Class

Ssn Class

Collapse Expand Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.
Collapse Expand Links
Ssn Class, Public Friends


friend class boost::serialization::access Friend

friend class boost::serialization::access Friend
Ssn Class Ssn Members Ssn Friends

Friend class to allow serialization.

C++
friend class boost::serialization::access;
Collapse Expand Group

Ssn Friends

Collapse Expand Links
Ssn Class, Ssn Members, Ssn Friends


TextWriterTraceListener Class

TextWriterTraceListener Class
TextWriterTraceListener Methods TextWriterTraceListener Members TextWriterTraceListener.h Classes

An output-stream-based class that listens for Trace output.

Collapse Expand Class Hierarchy
  TextWriterTraceListenerTextWriterTraceListener
C++
class TextWriterTraceListener : public TraceListener;
Collapse Expand File

File: TextWriterTraceListener.h

Module: Misc Library

Collapse Expand Remarks

This is a concrete implementation of the TraceListener class, with a private ostream member. It can be used with cout, cerr, or a user-created output stream, which is specified in the constructor.

Collapse Expand See Also

Trace

Collapse Expand Group

Classes

Collapse Expand Links
TextWriterTraceListener Methods, TextWriterTraceListener Members, TextWriterTraceListener.h, Classes


TextWriterTraceListener Members

TextWriterTraceListener Members
TextWriterTraceListener Class Legend Public Methods

The following tables list the members exposed by TextWriterTraceListener.

Collapse Expand Class

TextWriterTraceListener Class

Collapse Expand Public Methods
Name | Description
TextWriterTraceListener | Creates this instance.
close | Closes things.
flush | Flushes the output.
write | Writes a string of characters, without a newline, to the designated output.
write | Writes a string of characters, without a newline, to the designated output.
writeLine | Writes a string of characters, with a newline, to the designated output.
writeLine | Writes a string of characters, with a newline, to the designated output.
~TextWriterTraceListener | Destroys this instance.
Collapse Expand Links
TextWriterTraceListener Class, Legend, Public Methods


TextWriterTraceListener::TextWriterTraceListener Constructor

TextWriterTraceListener::TextWriterTraceListener Constructor
TextWriterTraceListener Class TextWriterTraceListener Members TextWriterTraceListener Class

Creates this instance.

C++
TextWriterTraceListener(
    std::ostream * newStream
);
Collapse Expand Parameters
Parameters | Description
std::ostream * newStream | The output stream to use as the logfile.
Collapse Expand Remarks

Associates the argument with the internal output stream.

Collapse Expand Class

TextWriterTraceListener Class

Collapse Expand Links
TextWriterTraceListener Class, TextWriterTraceListener Members, TextWriterTraceListener Class


TextWriterTraceListener::~TextWriterTraceListener Destructor

TextWriterTraceListener::~TextWriterTraceListener Destructor
TextWriterTraceListener Class TextWriterTraceListener Members TextWriterTraceListener Class

Destroys this instance.

C++
~TextWriterTraceListener();
Collapse Expand Class

TextWriterTraceListener Class

Collapse Expand Links
TextWriterTraceListener Class, TextWriterTraceListener Members, TextWriterTraceListener Class


TextWriterTraceListener Methods

TextWriterTraceListener Methods
TextWriterTraceListener Class Legend Public Methods

The methods of the TextWriterTraceListener class are listed here.

Collapse Expand Class

TextWriterTraceListener Class

Collapse Expand Public Methods
Name | Description
close | Closes things.
flush | Flushes the output.
write | Writes a string of characters, without a newline, to the designated output.
writeLine | Writes a string of characters, with a newline, to the designated output.
Collapse Expand Links
TextWriterTraceListener Class, Legend, Public Methods


TextWriterTraceListener::close Method

TextWriterTraceListener::close Method
TextWriterTraceListener Class TextWriterTraceListener Members TextWriterTraceListener Methods

Closes things.

C++
void close();
Collapse Expand Group

TextWriterTraceListener Methods

Collapse Expand Links
TextWriterTraceListener Class, TextWriterTraceListener Members, TextWriterTraceListener Methods


TextWriterTraceListener::flush Method

TextWriterTraceListener::flush Method
TextWriterTraceListener Class TextWriterTraceListener Members TextWriterTraceListener Methods

Flushes the output.

C++
void flush();
Collapse Expand Group

TextWriterTraceListener Methods

Collapse Expand Links
TextWriterTraceListener Class, TextWriterTraceListener Members, TextWriterTraceListener Methods


write Method

write Method
TextWriterTraceListener Methods

Writes a string of characters, without a newline, to the designated output.

Collapse Expand Description

There are two versions of the write method. They write a C-style string or a C++-style string to the designated output, without a newline.

Collapse Expand Overload List
Name | Description
TextWriterTraceListener::write (const char *) | Write the characters of output, without a newline.
TextWriterTraceListener::write (const std::string&) | Write a string of output, without a newline.
Collapse Expand Group

TextWriterTraceListener Methods

Collapse Expand Links
TextWriterTraceListener Methods


TextWriterTraceListener::write Method (const char *)

TextWriterTraceListener::write Method (const char *)
TextWriterTraceListener Class TextWriterTraceListener Members write Method

Write the characters of output, without a newline.

C++
void write(
    const char * str
);
Collapse Expand Parameters
Parameters | Description
const char * str | The characters to output.
Collapse Expand Group

write Method

Collapse Expand Links
TextWriterTraceListener Class, TextWriterTraceListener Members, write Method


TextWriterTraceListener::write Method (const std::string&)

TextWriterTraceListener::write Method (const std::string&)
TextWriterTraceListener Class TextWriterTraceListener Members write Method

Write a string of output, without a newline.

C++
void write(
    const std::string& str
);
Collapse Expand Parameters
Parameters | Description
const std::string& str | The string to output.
Collapse Expand Group

write Method

Collapse Expand Links
TextWriterTraceListener Class, TextWriterTraceListener Members, write Method


writeLine Method

writeLine Method
TextWriterTraceListener Methods

Writes a string of characters, with a newline, to the designated output.

Collapse Expand Description

There are two versions of the writeline method. They write a C-style string or a C++-style string to the designated output, with a newline.

Collapse Expand Overload List
Name | Description
TextWriterTraceListener::writeLine (const char *) | Write the characters of output, with a newline.
TextWriterTraceListener::writeLine (const std::string&) | Write a string of output, with a newline.
Collapse Expand Group

TextWriterTraceListener Methods

Collapse Expand Links
TextWriterTraceListener Methods


TextWriterTraceListener::writeLine Method (const char *)

TextWriterTraceListener::writeLine Method (const char *)
TextWriterTraceListener Class TextWriterTraceListener Members writeLine Method

Write the characters of output, with a newline.

C++
void writeLine(
    const char * str
);
Collapse Expand Parameters
Parameters | Description
const char * str | The characters to output.
Collapse Expand Group

writeLine Method

Collapse Expand Links
TextWriterTraceListener Class, TextWriterTraceListener Members, writeLine Method


TextWriterTraceListener::writeLine Method (const std::string&)

TextWriterTraceListener::writeLine Method (const std::string&)
TextWriterTraceListener Class TextWriterTraceListener Members writeLine Method

Write a string of output, with a newline.

C++
void writeLine(
    const std::string& str
);
Collapse Expand Parameters
Parameters | Description
const std::string& str | The string to output.
Collapse Expand Group

writeLine Method

Collapse Expand Links
TextWriterTraceListener Class, TextWriterTraceListener Members, writeLine Method


Trace Class

Trace Class
Trace Methods Trace Members Trace.h Classes

Controls the logfiles used to trace execution of code.

Collapse Expand Class Hierarchy
  Trace
C++
class Trace;
Collapse Expand File

File: Trace.h

Module: Misc Library

Collapse Expand Remarks

This class maintains a vector of TraceListener objects. When a Trace function is called, the corresponding function is called for each TraceListener object. Note that all public functions are static, and there is no public constructor. Simply use the static functions directly, without an instance of Trace, i.e. Trace::writeLine("abc").

Collapse Expand Group

Classes

Collapse Expand Links
Trace Methods, Trace Members, Trace.h, Classes


Trace Members

Trace Members
Trace Class Legend Public Methods

The following tables list the members exposed by Trace.

Collapse Expand Class

Trace Class

Collapse Expand Public Methods
Name | Description
close | Close all the TraceListener objects.
flush | Flush all the TraceListener objects.
getListeners | Returns the vector of TraceListener objects.
write | Writes a string of characters, without a newline, to all the TraceListener objects.
writeLine | Writes a string of characters, with a newline, to all the TraceListener objects.
Collapse Expand Links
Trace Class, Legend, Public Methods


Trace Methods

Trace Methods
Trace Class Legend Public Methods

The methods of the Trace class are listed here.

Collapse Expand Class

Trace Class

Collapse Expand Public Methods
Name | Description
close | Close all the TraceListener objects.
flush | Flush all the TraceListener objects.
getListeners | Returns the vector of TraceListener objects.
write | Writes a string of characters, without a newline, to all the TraceListener objects.
writeLine | Writes a string of characters, with a newline, to all the TraceListener objects.
Collapse Expand Links
Trace Class, Legend, Public Methods


Trace::close Method

Trace::close Method
Trace Class Trace Members Trace Methods

Close all the TraceListener objects.

C++
static void close();
Collapse Expand Group

Trace Methods

Collapse Expand Links
Trace Class, Trace Members, Trace Methods


Trace::flush Method

Trace::flush Method
Trace Class Trace Members Trace Methods

Flush all the TraceListener objects.

C++
static void flush();
Collapse Expand Group

Trace Methods

Collapse Expand Links
Trace Class, Trace Members, Trace Methods


Trace::getListeners Method

Trace::getListeners Method
Trace Class Trace Members Trace Methods

Returns the vector of TraceListener objects.

C++
static std::vector< TraceListener* >& getListeners();
Collapse Expand Returns

The vector of TraceListener objects.

Collapse Expand Group

Trace Methods

Collapse Expand Links
Trace Class, Trace Members, Trace Methods


write Method

write Method
Trace Methods

Writes a string of characters, without a newline, to all the TraceListener objects.

Collapse Expand Description

There are two versions of the write method. They write a C-style string or a C++-style string, without a newline, to all the TraceListener objects.

Collapse Expand Overload List
Name | Description
Trace::write (const char *) | Write the characters of output, without a newline, to all the TraceListener objects.
Trace::write (const std::string&) | Write a string of output, without a newline, to all the TraceListener objects.
Collapse Expand Group

Trace Methods

Collapse Expand Links
Trace Methods


Trace::write Method (const char *)

Trace::write Method (const char *)
Trace Class Trace Members write Method

Write the characters of output, without a newline, to all the TraceListener objects.

C++
static void write(
    const char * str
);
Collapse Expand Parameters
Parameters | Description
const char * str | The characters to write.
Collapse Expand Group

write Method

Collapse Expand Links
Trace Class, Trace Members, write Method


Trace::write Method (const std::string&)

Trace::write Method (const std::string&)
Trace Class Trace Members write Method

Write a string of output, without a newline, to all the TraceListener objects.

C++
static void write(
    const std::string& str
);
Collapse Expand Parameters
Parameters | Description
const std::string& str | The string to write.
Collapse Expand Group

write Method

Collapse Expand Links
Trace Class, Trace Members, write Method


writeLine Method

writeLine Method
Trace Methods

Writes a string of characters, with a newline, to all the TraceListener objects.

Collapse Expand Description

There are two versions of the writeLine method. They write a C-style string or a C++-style string, with a newline, to all the TraceListener objects.

Collapse Expand Overload List
Name | Description
Trace::writeLine (const char *) | Write the characters of output, with a newline, to all the TraceListener objects.
Trace::writeLine (const std::string&) | Write a string of output, with a newline, to all the TraceListener objects.
Collapse Expand Group

Trace Methods

Collapse Expand Links
Trace Methods


Trace::writeLine Method (const char *)

Trace::writeLine Method (const char *)
Trace Class Trace Members writeLine Method

Write the characters of output, with a newline, to all the TraceListener objects.

C++
static void writeLine(
    const char * str
);
Collapse Expand Parameters
Parameters | Description
const char * str | The characters to output.
Collapse Expand Group

writeLine Method

Collapse Expand Links
Trace Class, Trace Members, writeLine Method


Trace::writeLine Method (const std::string&)

Trace::writeLine Method (const std::string&)
Trace Class Trace Members writeLine Method

Write a string of output, with a newline, to all the TraceListener objects.

C++
static void writeLine(
    const std::string& str
);
Collapse Expand Parameters
Parameters | Description
const std::string& str | The string to output.
Collapse Expand Group

writeLine Method

Collapse Expand Links
Trace Class, Trace Members, writeLine Method


TraceListener Class

TraceListener Class
TraceListener Methods TraceListener Members TraceListener.h Classes

The parent of classes that listen for Trace output.

Collapse Expand Class Hierarchy
  TraceListener
C++
class TraceListener;
Collapse Expand File

File: TraceListener.h

Module: Misc Library

Collapse Expand Remarks

Child classes are DefaultTraceListener (not yet implemented) and TextWriterTraceListener.

Collapse Expand See Also

TextWriterTraceListener, Trace

Collapse Expand Group

Classes

Collapse Expand Links
TraceListener Methods, TraceListener Members, TraceListener.h, Classes


TraceListener Members

TraceListener Members
TraceListener Class Legend Protected Methods Public Methods

The following tables list the members exposed by TraceListener.

Collapse Expand Class

TraceListener Class

Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
TraceListener | Creates this instance.
Collapse Expand Public Methods
Name | Description
close | Closes this instance.
flush | Flushes the output of this instance.
write | Writes a string of characters, without a newline, to the designated output.
writeLine | Writes a string of characters, with a newline, to the designated output.
~TraceListener | Destroys this instance.
Collapse Expand Links
TraceListener Class, Legend, Protected Methods, Public Methods


TraceListener::TraceListener Constructor

TraceListener::TraceListener Constructor
TraceListener Class TraceListener Members TraceListener Class

Creates this instance.

C++
TraceListener();
Collapse Expand Remarks

The default version does nothing.

Collapse Expand Class

TraceListener Class

Collapse Expand Links
TraceListener Class, TraceListener Members, TraceListener Class


TraceListener::~TraceListener Destructor

TraceListener::~TraceListener Destructor
TraceListener Class TraceListener Members TraceListener Class

Destroys this instance.

C++
virtual ~TraceListener();
Collapse Expand Remarks

The default version does nothing.

Collapse Expand Class

TraceListener Class

Collapse Expand Links
TraceListener Class, TraceListener Members, TraceListener Class


TraceListener Methods

TraceListener Methods
TraceListener Class Legend Public Methods

The methods of the TraceListener class are listed here.

Collapse Expand Class

TraceListener Class

Collapse Expand Public Methods
Name | Description
close | Closes this instance.
flush | Flushes the output of this instance.
write | Writes a string of characters, without a newline, to the designated output.
writeLine | Writes a string of characters, with a newline, to the designated output.
Collapse Expand Links
TraceListener Class, Legend, Public Methods


TraceListener::close Method

TraceListener::close Method
TraceListener Class TraceListener Members TraceListener Methods

Closes this instance.

C++
virtual void close();
Collapse Expand Remarks

The default version does nothing.

Collapse Expand Group

TraceListener Methods

Collapse Expand Links
TraceListener Class, TraceListener Members, TraceListener Methods


TraceListener::flush Method

TraceListener::flush Method
TraceListener Class TraceListener Members TraceListener Methods

Flushes the output of this instance.

C++
virtual void flush();
Collapse Expand Remarks

The default version does nothing.

Collapse Expand Group

TraceListener Methods

Collapse Expand Links
TraceListener Class, TraceListener Members, TraceListener Methods


write Method

write Method
TraceListener Methods

Writes a string of characters, without a newline, to the designated output.

Collapse Expand Description

There are two versions of the write method. They write a C-style string or a C++-style string to the designated output, without a newline.

Collapse Expand Overload List
Name | Description
TraceListener::write (const char *) | Write the characters of output, without a newline.
TraceListener::write (const std::string&) | Write a string of output, without a newline.
Collapse Expand Group

TraceListener Methods

Collapse Expand Links
TraceListener Methods


TraceListener::write Method (const char *)

TraceListener::write Method (const char *)
TraceListener Class TraceListener Members write Method

Write the characters of output, without a newline.

C++
virtual void write(
    const char * str
) = 0;
Collapse Expand Parameters
Parameters | Description
const char * str | The characters to write.
Collapse Expand Group

write Method

Collapse Expand Links
TraceListener Class, TraceListener Members, write Method


TraceListener::write Method (const std::string&)

TraceListener::write Method (const std::string&)
TraceListener Class TraceListener Members write Method

Write a string of output, without a newline.

C++
virtual void write(
    const std::string& str
) = 0;
Collapse Expand Parameters
Parameters | Description
const std::string& str | The string to write.
Collapse Expand Group

write Method

Collapse Expand Links
TraceListener Class, TraceListener Members, write Method


writeLine Method

writeLine Method
TraceListener Methods

Writes a string of characters, with a newline, to the designated output.

Collapse Expand Description

There are two versions of the writeLine method. They write a C-style string or a C++-style string to the designated output, with a newline.

Collapse Expand Overload List
Name | Description
TraceListener::writeLine (const char *) | Write the characters of output, with a newline.
TraceListener::writeLine (const std::string&) | Write a string of output, with a newline.
Collapse Expand Group

TraceListener Methods

Collapse Expand Links
TraceListener Methods


TraceListener::writeLine Method (const char *)

TraceListener::writeLine Method (const char *)
TraceListener Class TraceListener Members writeLine Method

Write the characters of output, with a newline.

C++
virtual void writeLine(
    const char * str
) = 0;
Collapse Expand Parameters
Parameters | Description
const char * str | The characters to output.
Collapse Expand Group

writeLine Method

Collapse Expand Links
TraceListener Class, TraceListener Members, writeLine Method


TraceListener::writeLine Method (const std::string&)

TraceListener::writeLine Method (const std::string&)
TraceListener Class TraceListener Members writeLine Method

Write a string of output, with a newline.

C++
virtual void writeLine(
    const std::string& str
) = 0;
Collapse Expand Parameters
Parameters | Description
const std::string& str | The string to output.
Collapse Expand Group

writeLine Method

Collapse Expand Links
TraceListener Class, TraceListener Members, writeLine Method


Functions

Functions
Functions Legend Misc Library

The following table lists functions in this documentation.

Collapse Expand Functions
Name | Description
AfxFormatString1 | Loads the specified string resource and substitutes for the characters "%1" the string referenced by filler.
AfxFormatString2 | Loads the specified string resource and substitutes for the characters "%1"and "%2" the strings referenced by filler1 and filler2.
parseString | Parses a string into its delimited parts, using a space separator.
parseString | Parses a string into its delimited parts with a specified delimiter.
pblank | Inserts blanks or zeroes on the left of a formatted string representing a number.
pcomma | Inserts commas into a formatted string representing a number.
Collapse Expand Module

Misc Library

Collapse Expand Links
Functions, Legend, Misc Library


AfxFormatString1 Function

AfxFormatString1 Function
FormatString.h Functions

Loads the specified string resource and substitutes for the characters "%1" the string referenced by filler.

C++
void AfxFormatString1(
    std::string& result,
    unsigned int rsc,
    const std::string& filler
);
Collapse Expand File

File: FormatString.h

Module: Misc Library

Collapse Expand Parameters
Parameters | Description
std::string& result | A reference to a string that will contain the resultant string after the substitution is performed.
unsigned int rsc | The resource ID of the template string on which the substitution will be performed
const std::string& filler | A string that will replace the format characters "%1" in the template string
Collapse Expand Group

Functions

Collapse Expand Links
FormatString.h, Functions


AfxFormatString2 Function

AfxFormatString2 Function
FormatString.h Functions

Loads the specified string resource and substitutes for the characters "%1"and "%2" the strings referenced by filler1 and filler2.

C++
void AfxFormatString2(
    std::string& result,
    unsigned int rsc,
    const std::string& filler1,
    const std::string& filler2
);
Collapse Expand File

File: FormatString.h

Module: Misc Library

Collapse Expand Parameters
Parameters | Description
std::string& result | A reference to a string that will contain the resultant string after the substitution is performed.
unsigned int rsc | The resource ID of the template string on which the substitution will be performed
const std::string& filler1 | A string that will replace the format characters "%1" in the template string
const std::string& filler2 | A string that will replace the format characters "%1" in the template string
Collapse Expand Group

Functions

Collapse Expand Links
FormatString.h, Functions


parseString Function

parseString Function
StringParser.h Functions

Parses a string into its delimited parts, using a space separator.

C++
std::vector< std::string > parseString(
    const std::string& str
);
Collapse Expand File

File: StringParser.h

Module: Misc Library

Collapse Expand Parameters
Parameters | Description
const std::string& str | The string to parse.
Collapse Expand Returns

A vector of the strings contained in the input.

Collapse Expand Remarks

This version (with only one argument) uses a space as the delimiter.

Collapse Expand Group

Functions

Collapse Expand Links
StringParser.h, Functions


parseString Function

parseString Function
StringParser.h Functions

Parses a string into its delimited parts with a specified delimiter.

C++
std::vector< std::string > parseString(
    const std::string& str,
    char sep
);
Collapse Expand File

File: StringParser.h

Module: Misc Library

Collapse Expand Parameters
Parameters | Description
const std::string& str | The string to parse.
char sep | The separator character. If omitted, a space is used.
Collapse Expand Returns

A vector of the strings contained in the input.

Collapse Expand Group

Functions

Collapse Expand Links
StringParser.h, Functions


pblank Function

pblank Function
comma.h Functions

Inserts blanks or zeroes on the left of a formatted string representing a number.

C++
void pblank(
    std::string& start,
    int width,
    bool zeroFill
);
Collapse Expand File

File: comma.h

Module: Misc Library

Collapse Expand Parameters
Parameters | Description
std::string& start | String without blanks, to be returned with blanks.
int width | Minimum width of field.
bool zeroFill | True if should zero fill on left.
Collapse Expand Group

Functions

Collapse Expand Links
comma.h, Functions


pcomma Function

pcomma Function
comma.h Functions

Inserts commas into a formatted string representing a number.

C++
void pcomma(
    std::string& start,
    int dec,
    int point,
    int sign
);
Collapse Expand File

File: comma.h

Module: Misc Library

Collapse Expand Parameters
Parameters | Description
std::string& start | String without commas, to be returned with commas.
int dec | Number of decimal places.
int point | Indicator for decimal point.
int sign | Indicator for negative sign.
Collapse Expand Group

Functions

Collapse Expand Links
comma.h, Functions


Types

Types
Misc Library Types

The following table lists types in this documentation.

Collapse Expand Module

Misc Library

Collapse Expand Types
Name | Description
BitAnnualData | Bit array used in BitAnnual (a std::bitset).
Collapse Expand Links
Misc Library, Types


BitAnnualData Type

BitAnnualData Type
BitAnnualBase.h Types

Bit array used in BitAnnual (a std::bitset).

C++
typedef std::bitset< MAX_BITSET_SIZE > BitAnnualData;
Collapse Expand File

File: BitAnnualBase.h

Module: Misc Library

Collapse Expand Group

Types

Collapse Expand Links
BitAnnualBase.h, Types


Variables

Variables
Misc Library Variables

The following table lists variables in this documentation.

Collapse Expand Module

Misc Library

Collapse Expand Variables
Name | Description
MAX_BITSET_SIZE | Size to use for bit array in BitAnnual (from 1937 to 2200).
Collapse Expand Links
Misc Library, Variables


MAX_BITSET_SIZE Variable

MAX_BITSET_SIZE Variable
BitAnnualBase.h Variables

Size to use for bit array in BitAnnual (from 1937 to 2200).

C++
const int MAX_BITSET_SIZE = 264;
Collapse Expand File

File: BitAnnualBase.h

Module: Misc Library

Collapse Expand Group

Variables

Collapse Expand Links
BitAnnualBase.h, Variables


Macros

Macros
Macros Misc Library

The following table lists macros in this documentation.

Collapse Expand Macros
Name | Description
ENDS | No special character for end of ostringstream.
FREEZE | No special function to freeze the string.
OSTREAM | Use ostringstream for formatting output.
PIA_IDS_2YEARS | (Currently unused.)
PIA_IDS_ACTQCOUT | String ID for printing actual quarters of coverage.
PIA_IDS_AGEMONTH | Type of PiaException thrown if number of months in an Age is greater than 11.
PIA_IDS_AGEPLAN | Type of PiaException thrown if planned age of retirement is out of range.
PIA_IDS_AIMEOUT | String ID for printing AIME.
PIA_IDS_AMEOUT | String ID for printing AMW.
PIA_IDS_ANDLATER | (Currently unused.)
PIA_IDS_ANSCCH | Type of PiaException thrown if catch-up increase indicator is out of range.
PIA_IDS_APPCOLA1 | Type of PiaException thrown if year is out of range in PiaParams::applyCola without catch-up.
PIA_IDS_APPCOLA2 | Type of PiaException thrown if year is out of range in PiaParams::applyCola with catch-up.
PIA_IDS_APPCOLA3 | Type of PiaException thrown if year is out of range in PiaParams::applyColaMfb without catch-up.
PIA_IDS_APPCOLA4 | Type of PiaException thrown if year is out of range in PiaParams::applyColaMfb with catch-up.
PIA_IDS_ARDRI1 | Type of PiaException thrown if age is out of range in PiaCal::ardriCal.
PIA_IDS_ARDRI10 | Type of PiaException thrown if aged wife age is before early retirement age in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI2 | Type of PiaException thrown if age is before early retirement age for OAB in PiaCal::ardriCal.
PIA_IDS_ARDRI3 | (Currently unused.)
PIA_IDS_ARDRI4 | Type of PiaException thrown if disabled widow(er) age is before earliest possible age in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI5 | Type of PiaException thrown if disabled widow(er) entitlement is before benefit date in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI6 | Type of PiaException thrown if aged widow(er) age is before earliest possible age in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI7 | Type of PiaException thrown if DIB entitlement before 1957 in PiaCal::ardriCal.
PIA_IDS_ARDRI8 | Type of PiaException thrown if age under 50 for DIB before 1960 in PiaCal::ardriCal.
PIA_IDS_ARDRI9 | Type of PiaException thrown if age over full retirement age for DIB in PiaCal::ardriCal.
PIA_IDS_ARFFOUT | String ID for printing actuarial reduction factor.
PIA_IDS_ARFMOUT | String ID for printing months of actuarial reduction.
PIA_IDS_ATODOUBLE | (Currently unused).
PIA_IDS_ATOFLOAT | (Currently unused).
PIA_IDS_ATOINT | (Currently unused).
PIA_IDS_ATOLONG | (Currently unused).
PIA_IDS_AVERAGETEXT | (Currently unused.)
PIA_IDS_AVGWG | Type of PiaException thrown if year is out of range in an AverageWage function.
PIA_IDS_AVGWGTTL | (Currently unused.)
PIA_IDS_AWASSUM | (Currently unused.)
PIA_IDS_AWBI1 | Type of PiaException thrown if unable to open input file in AwbiDataFile::read.
PIA_IDS_AWBI2 | Type of PiaException thrown if unable to open output file in AwbiDataFile::write.
PIA_IDS_AWBI3 | Type of PiaException thrown if unable to read all required data in AwbiDataFile::read.
PIA_IDS_AWBIDAT1 | Type of PiaException thrown if last year of historical data is too large in AwbiDataNonFile::setData.
PIA_IDS_AWOUT | String ID for printing average wage assumptions.
PIA_IDS_BASE1 | Type of PiaException thrown if first year is out of range in WageBaseGeneral::project.
PIA_IDS_BASE2 | Type of PiaException thrown if wage base is out of range.
PIA_IDS_BASECH | Type of PiaException thrown if wage base indicator is not 1 or 2.
PIA_IDS_BASEYR1 | Type of PiaException thrown if base year is out of range (1979-2020).
PIA_IDS_BASEYR2 | Type of PiaException thrown if unable to open output file in BaseYearFile::write.
PIA_IDS_BASEYR3 | Type of PiaException thrown if unable to read base year in BaseYearFile::read.
PIA_IDS_BASEYR4 | Type of PiaException thrown if unable to open input file in BaseYearFile::read.
PIA_IDS_BEGIN1 | Type of PiaException thrown if first year of earnings is out of range.
PIA_IDS_BEGIN2 | Type of PiaException thrown if last year of earnings is before first year of earnings in backward projection period.
PIA_IDS_BEGIN3 | Type of PiaException thrown if first year of earnings is before 1937.
PIA_IDS_BEGIN4 | Type of PiaException thrown if first year of earnings is in starting year of projections or later, in a Statement case.
PIA_IDS_BEGIN5 | Type of PiaException thrown if first year of earnings is after maximum year allowed, in a non-Statement case.
PIA_IDS_BEGIN6 | Type of PiaException thrown if there are no regular, railroad, or military earnings.
PIA_IDS_BEN1OUT | String ID for printing benefit before rounding.
PIA_IDS_BEN2OUT | String ID for printing benefit after rounding.
PIA_IDS_BENARRAY1 | Type of PiaException thrown if year is out of range in BenefitAmountArray functions.
PIA_IDS_BENARRAY2 | Type of PiaException thrown if year is out of range in BenefitAmountArray::[].
PIA_IDS_BENDATE1 | Type of PiaException thrown if benefit date is before entitlement date.
PIA_IDS_BENDATE2 | Type of PiaException thrown if month of benefit is out of range.
PIA_IDS_BENDATE3 | Type of PiaException thrown if year of benefit is before 1940.
PIA_IDS_BENDATE4 | Type of PiaException thrown if year of benefit is after maximum allowed.
PIA_IDS_BENDATE5 | (Currently unused.)
PIA_IDS_BENDATE6 | Type of PiaException thrown if secondary entitlement after benefit date.
PIA_IDS_BENFOUT | String ID for printing secondary benefit factor.
PIA_IDS_BIASSUM | (Currently unused.)
PIA_IDS_BICCHP | Type of PiaException thrown if year is out of range in Catchup functions.
PIA_IDS_BIOUT | String ID for printing benefit increase assumptions.
PIA_IDS_BIPROJTTL | (Currently unused.)
PIA_IDS_BIRTH1 | Type of PiaException thrown if year of birth is in current year or later (in Statement case).
PIA_IDS_BIRTH2 | Type of PiaException thrown if year of birth is before 1800.
PIA_IDS_BIRTH3 | Type of PiaException thrown if month of birth is out of range.
PIA_IDS_BIRTH4 | Type of PiaException thrown if day of birth is out of range.
PIA_IDS_BIRTH5 | Type of PiaException thrown if year of birth is after maximum allowed.
PIA_IDS_BIRTH6 | (Currently unused.)
PIA_IDS_BITANN1 | Type of PiaException thrown if year is out of range in BitAnnual functions.
PIA_IDS_CACHUP1 | Type of PiaException thrown if catch-up benefit increase is out of range.
PIA_IDS_CACHUP2 | Type of PiaException thrown if unable to open input file in CatchupFile::read.
PIA_IDS_CACHUP3 | Type of PiaException thrown if unable to open output file in CatchupFile::write.
PIA_IDS_CACHUP4 | Type of PiaException thrown if year is out of range in a Catchup function.
PIA_IDS_CESS2OUT | String ID for printing second prior date of cessation.
PIA_IDS_COMMA | Type of PiaException thrown if number of decimals is nonzero for other than a float type in pout.
PIA_IDS_CONFIG1 | Type of PiaException thrown if unable to open input file in ConfigFile::read.
PIA_IDS_CONFIG5 | Type of PiaException thrown if unable to open output file in ConfigFile::write.
PIA_IDS_CONFIG6 | Type of PiaException thrown if unable to read all required data in ConfigFile::read.
PIA_IDS_CPIINC1 | Type of PiaException thrown if benefit increase is out of range.
PIA_IDS_CPIINC2 | Type of PiaException thrown if unable to open output file in BiprojFile::write.
PIA_IDS_CPIINC3 | Type of PiaException thrown if unable to read all required data in BiprojFile::read.
PIA_IDS_CPIINC4 | Type of PiaException thrown if unable to open input file in BiprojFile::read.
PIA_IDS_CUPROJTTL | (Currently unused.)
PIA_IDS_CURINSOUT | String ID for printing currently insured status in survivor case.
PIA_IDS_DATEDAY | Type of PiaException thrown if day in a date is out of range.
PIA_IDS_DATEDIFF | Type of PiaException thrown if unable to difference two dates.
PIA_IDS_DATEMONTH | Type of PiaException thrown if month in a date is out of range.
PIA_IDS_DATEREAD | Type of PiaException thrown if unable to parse string into a date.
PIA_IDS_DATEYEAR | Type of PiaException thrown if year in a date is out of range.
PIA_IDS_DBLEANN1 | (Currently unused).
PIA_IDS_DBLEANN2 | Type of PiaException thrown if unable to read specified years in DoubleAnnualRead::read.
PIA_IDS_DEATH1 | Type of PiaException thrown if month of death is out of range.
PIA_IDS_DEATH2 | Type of PiaException thrown if year of death is after maximum allowed.
PIA_IDS_DEATH3 | Type of PiaException thrown if death before 1937 in a survivor case.
PIA_IDS_DEATH4 | Type of PiaException thrown if entitlement of survivor is before death of worker.
PIA_IDS_DEATH5 | Type of PiaException thrown if death of worker is before birth.
PIA_IDS_DEATH6 | (Currently unused.)
PIA_IDS_DEATHOUT | String ID for printing date of death.
PIA_IDS_DIBENTOUT | String ID for printing DIB date of entitlement.
PIA_IDS_DICESS1 | Type of PiaException thrown if month of cessation is out of range.
PIA_IDS_DICESS2 | Type of PiaException thrown if year of cessation is before 1937.
PIA_IDS_DICESS3 | Type of PiaException thrown if year of cessation is after maximum allowed.
PIA_IDS_DICESS4 | Type of PiaException thrown if disability cessation before onset.
PIA_IDS_DICESS5 | Type of PiaException thrown if prior disability cessation after second entitlement.
PIA_IDS_DICESS6 | Type of PiaException thrown if entitlement is before cessation.
PIA_IDS_DICESS7 | Type of PiaException thrown if cessation is after death in a survivor case.
PIA_IDS_DICESS8 | (Currently unused.)
PIA_IDS_DINS1OUT | String ID for printing first part of disability insured status.
PIA_IDS_DINS2OUT | String ID for printing second part of disability insured status.
PIA_IDS_DINS3OUT | String ID for printing third part of disability insured status.
PIA_IDS_DISREQCAL1 | Type of PiaException thrown if year in most recent freeze period is out of range in PiaData::qcDisReqCal.
PIA_IDS_DISREQCAL2 | Type of PiaException thrown if year in next most recent freeze period is out of range in PiaData::qcDisReqCal.
PIA_IDS_DOBOUT | String ID for printing date of birth.
PIA_IDS_DOBWIDOUT | String ID for printing date of birth of widow(er).
PIA_IDS_DRCFOUT | String ID for printing delayed retirement credit factor.
PIA_IDS_DRCMOUT | String ID for printing months of delayed retirement credit.
PIA_IDS_EARNHI | Type of PiaException thrown if Medicare earnings are out of range.
PIA_IDS_EARNMAL | Type of PiaException thrown if year is before 1937 in EarnProject::toString.
PIA_IDS_EARNPEBS | Type of PiaException thrown if OASDI earnings are out of range.
PIA_IDS_EARNPROJ | Type of PiaException thrown if projection year is out of range in EarnProject::project.
PIA_IDS_EARNTYPE | Type of PiaException thrown if type of earnings is out of range.
PIA_IDS_EARNTYPE1 | Type of PiaException thrown if projection year is out of range in PiaWrite::writeEarnType.
PIA_IDS_EARNTYPEYR | Type of PiaException thrown if year is out of range in EarnProject::setEarntype.
PIA_IDS_ELAPSOUT | String ID for printing elapsed years.
PIA_IDS_END1 | Type of PiaException thrown if last year of earnings is before 1937.
PIA_IDS_END2 | Type of PiaException thrown if last year of earnings is after maximum year allowed.
PIA_IDS_END3 | Type of PiaException thrown if first year of earnings in forward projection period is after last year of earnings in forward projection period.
PIA_IDS_END4 | Type of PiaException thrown if the total number of years of earnings is greater than the maximum allowed (MAXYRS).
PIA_IDS_ENT1 | Type of PiaException thrown if month of entitlement is out of range.
PIA_IDS_ENT2 | Type of PiaException thrown if year of entitlement is before 1940.
PIA_IDS_ENT3 | Type of PiaException thrown if year of entitlement is after maximum allowed.
PIA_IDS_ENT4 | (Currently unused.)
PIA_IDS_ERNLIMOUT | String ID for printing earnings over maximum allowed.
PIA_IDS_FAMSIZE | Type of PiaException thrown if family size is out of bounds.
PIA_IDS_FLOATANN1 | (Currently unused).
PIA_IDS_FLOATANN2 | (Currently unused).
PIA_IDS_FLOATMTH1 | Type of PiaException thrown if years are out of range in a FloatMonth function.
PIA_IDS_FLOATMTH2 | Type of PiaException thrown if unable to read specified years in FloatMonth::read.
PIA_IDS_FLOATMTH3 | Type of PiaException thrown if quarter is out of range in a FloatMonth function.
PIA_IDS_FLOATQTR1 | Type of PiaException thrown if years are out of range in a FloatQuarter function.
PIA_IDS_FLOATQTR2 | Type of PiaException thrown if unable to read specified years in FloatQuarter::read.
PIA_IDS_FLOATQTR3 | Type of PiaException thrown if quarter is out of range in a FloatQuarter function.
PIA_IDS_FLOATQTR4 | Type of PiaException thrown if data value is zero in a FloatQuarter divide function.
PIA_IDS_FMSTRING | Type of PiaException thrown if error in FrozMinPage::prepareStrings.
PIA_IDS_FOINFO1 | Type of PiaException thrown if unable to open input file in FieldOfficeInfoFile::read.
PIA_IDS_FOINFO2 | Type of PiaException thrown if unable to read all required data in FieldOfficeInfoFile::read.
PIA_IDS_FOINFO3 | Type of PiaException thrown if unable to open output file in FieldOfficeInfoFile::write.
PIA_IDS_FQINC1 | Type of PiaException thrown if average wage increase is out of range.
PIA_IDS_FQINC2 | Type of PiaException thrown if unable to open output file in AwincFile::write.
PIA_IDS_FQINC3 | Type of PiaException thrown if unable to read all required data in AwincFile::read.
PIA_IDS_FQINC4 | Type of PiaException thrown if unable to open input file in AwincFile::read.
PIA_IDS_FULLBEN | String ID for printing full secondary benefit.
PIA_IDS_GENFILE1 | Type of PiaException thrown if unable to open a Genfile for output.
PIA_IDS_GENFILE2 | Type of PiaException thrown if unable to open a Genfile for appended output.
PIA_IDS_GENFILE3 | Type of PiaException thrown if unable to open a Genfile for input.
PIA_IDS_HIGHTEXT | (Currently unused.)
PIA_IDS_HISTAMTTL | (Currently unused.)
PIA_IDS_HISTAMTUPDATE | (Currently unused.)
PIA_IDS_IALTAW1 | Type of PiaException thrown if average wage increase indicator is out of range in general case.
PIA_IDS_IALTAW2 | Type of PiaException thrown if average wage increase indicator is out of range in Statement case.
PIA_IDS_IALTBI1 | Type of PiaException thrown if benefit increase indicator is out of range in general case.
PIA_IDS_IALTBI2 | Type of PiaException thrown if benefit increase indicator is out of range in Statement case.
PIA_IDS_INSTATOUT | String ID for printing insured status.
PIA_IDS_INSUREOUT | String ID for printing fully insured for totalization benefits.
PIA_IDS_INTANN1 | (Currently unused).
PIA_IDS_INTANN2 | (Currently unused).
PIA_IDS_JBIRTH1 | (Currently unused.)
PIA_IDS_JBIRTH2 | (Currently unused.)
PIA_IDS_JBIRTH3 | (Currently unused.)
PIA_IDS_JBIRTH4 | (Currently unused.)
PIA_IDS_JBIRTH5 | (Currently unused.)
PIA_IDS_JOASDI | Type of PiaException thrown if type of benefit is out of range.
PIA_IDS_JONSET1 | (Currently unused.)
PIA_IDS_JONSET2 | (Currently unused.)
PIA_IDS_JONSET3 | (Currently unused.)
PIA_IDS_JONSET4 | (Currently unused.)
PIA_IDS_JONSET5 | Type of PiaException thrown if widow's disability is before birth.
PIA_IDS_JONSET6 | Type of PiaException thrown if widow's disability is after entitlement.
PIA_IDS_JONSET7 | (Currently unused.)
PIA_IDS_JSURV | Type of PiaException thrown if bic is not a valid life or survivor bic.
PIA_IDS_JSURVOUT | String ID for printing type of survivor.
PIA_IDS_LAWCHG1 | Type of PiaException thrown if starting year of law changes is out of range.
PIA_IDS_LAWCHG2 | Type of PiaException thrown if law change wage increase proportion is out of range.
PIA_IDS_LAWCHG3 | Type of PiaException thrown if law change benefit formula percentage is out of range.
PIA_IDS_LAWCHG4 | Type of PiaException thrown if law change bend point is out of range.
PIA_IDS_LAWCHG5 | Type of PiaException thrown if law change constant decline percentage is out of range.
PIA_IDS_LAWCHG6 | Type of PiaException thrown if unable to parse input line in LawChangeRead::read.
PIA_IDS_LAWCHG7 | Type of PiaException thrown if unable to open input file in LawChangeRead::read.
PIA_IDS_LAWCHG8 | Type of PiaException thrown if unable to open output file in LawChangeWrite::write.
PIA_IDS_LAWCHG9 | Type of PiaException thrown if type of law change is out of range.
PIA_IDS_LOWTEXT | (Currently unused.)
PIA_IDS_MAXIMUMTEXT | (Currently unused.)
PIA_IDS_METHOD | Type of PiaException thrown if years are inconsistent in PiaMethod::totalEarnCal.
PIA_IDS_MFBBEN | String ID for printing maximum family benefit.
PIA_IDS_MFBLOUT | String ID for printing MFB at eligibility.
PIA_IDS_MFBOUT | String ID for printing MFB.
PIA_IDS_MILSERV1 | Type of PiaException thrown if military service starting date is after ending date.
PIA_IDS_MILSERV2 | Type of PiaException thrown if number of military service periods is out of range in general case.
PIA_IDS_MILSERV3 | Type of PiaException thrown if number of military service periods is out of range in military service case.
PIA_IDS_MILSERV4 | Type of PiaException thrown if military service starting date is out of range.
PIA_IDS_MILSERV5 | Type of PiaException thrown if military service ending date is out of range.
PIA_IDS_MILSERV6 | Type of PiaException thrown if years are out of range in MilServDates::getQc3750.
PIA_IDS_MILSERV7 | Type of PiaException thrown if years are out of range in MilServDates::getEarn3750.
PIA_IDS_MODTC | Type of PiaException thrown if moddata is in error.
PIA_IDS_MONTHTEXT | (Currently unused).
PIA_IDS_NAMEOUT | String ID for printing worker's name.
PIA_IDS_NDISINOUT | String ID for printing not disability insured.
PIA_IDS_NEEDAW | (Currently unused).
PIA_IDS_NEEDBASES | Type of PiaException thrown if year is out of range in WorkerDataGeneral::need_bases.
PIA_IDS_NEEDBI | (Currently unused).
PIA_IDS_NINSTOUT | String ID for printing not insured in survivor case.
PIA_IDS_NINSUROUT | String ID for printing not fully insured.
PIA_IDS_NONPENDATE1 | Type of PiaException thrown if noncovered pension entitlement date is before birth.
PIA_IDS_NONPENDATE2 | Type of PiaException thrown if noncovered pension entitlement date is after death.
PIA_IDS_NONPENDATE3 | Type of PiaException thrown if noncovered pension entitlement date entry is invalid.
PIA_IDS_NONPENDATEOUT | String ID for printing noncovered pension entitlement date.
PIA_IDS_NONPENOUT | String ID for printing noncovered pension.
PIA_IDS_NRA1OUT | String ID for printing early retirement age.
PIA_IDS_NRAOUT | String ID for printing full retirement age.
PIA_IDS_NRAWIDOUT | String ID for printing widow(er)'s full retirement age.
PIA_IDS_NRAWIFEOUT | String ID for printing full retirement age of aged wife/husband.
PIA_IDS_NTOTALOUT | String ID for printing not insured for totalization benefits.
PIA_IDS_OABBENOUT | String ID for printing OAB date of benefit.
PIA_IDS_OABENTOUT | String ID for printing OAB date of entitlement.
PIA_IDS_OLDSTART1 | Type of PiaException thrown if date of entitlement is out of range in OldStart::calculate.
PIA_IDS_OLDSTART2 | Type of PiaException thrown if old start method number is out of range.
PIA_IDS_ONEPAGE | Type of PiaException thrown if error in OnePage::prepareStrings.
PIA_IDS_ONSET1 | Type of PiaException thrown if month of onset is out of range.
PIA_IDS_ONSET10 | (Currently unused.)
PIA_IDS_ONSET11 | Type of PiaException thrown if disability onset is after full retirement age.
PIA_IDS_ONSET2 | Type of PiaException thrown if day of onset is out of range.
PIA_IDS_ONSET2OUT | String ID for printing second prior date of onset.
PIA_IDS_ONSET3 | Type of PiaException thrown if year of onset is before 1937.
PIA_IDS_ONSET4 | Type of PiaException thrown if year of onset is after maximum allowed.
PIA_IDS_ONSET5 | Type of PiaException thrown if disability is before birth.
PIA_IDS_ONSET6 | Type of PiaException thrown if disability is after entitlement.
PIA_IDS_ONSET7 | Type of PiaException thrown if death of worker is before disability onset in a survivor case.
PIA_IDS_ONSET8 | Type of PiaException thrown if prior disability is after current disability.
PIA_IDS_ONSET9 | (Currently unused.)
PIA_IDS_ONSETOUT | String ID for printing date of onset.
PIA_IDS_OPENERR | (Currently unused.)
PIA_IDS_OSRANGE1 | (Currently unused.)
PIA_IDS_OSRANGE2 | (Currently unused.)
PIA_IDS_OSSTRING | Type of PiaException thrown if error in OldStart1Page::prepareStrings.
PIA_IDS_OUTFILE | (Currently unused.)
PIA_IDS_PEBESMONTH | Type of PiaException thrown if month of Statement processing is out of range.
PIA_IDS_PEBSASM | Type of PiaException thrown if benefit increase indicator or average wage increase indicator is out of range in Statement case.
PIA_IDS_PERCBACK | Type of PiaException thrown if backward projection percentage is out of range.
PIA_IDS_PERCFWRD | Type of PiaException thrown if forward projection percentage is out of range.
PIA_IDS_PIACALPLRGE | (Currently unused.)
PIA_IDS_PIACALRANGE | (Currently unused.)
PIA_IDS_PIALOUT | String ID for printing PIA at eligibility.
PIA_IDS_PIAOUT | String ID for printing PIA.
PIA_IDS_PIATABLE1 | Type of PiaException thrown if year of entitlement is out of range in PiaTable::calculate.
PIA_IDS_PIATABLE2 | Type of PiaException thrown if year of benefit is out of range in PiaTable::calculate.
PIA_IDS_PIB50MFB | Type of PiaException thrown if index is out of range in Pib50Mfb::getAt.
PIA_IDS_PIB50PIB | Type of PiaException thrown if index is out of range in Pib50Pib::getAt.
PIA_IDS_PIB52MFB | Type of PiaException thrown if index is out of range in Pib52Mfb::getAt.
PIA_IDS_PIB54MFB | Type of PiaException thrown if index is out of range in Pib54Mfb::getAt.
PIA_IDS_PIB54PIA | Type of PiaException thrown if index is out of range in Pib54Pia::getAt.
PIA_IDS_PIB58AME | Type of PiaException thrown if index is out of range in Pib58Ame::getAt.
PIA_IDS_PIB58PIB | Type of PiaException thrown if index is out of range in Pib58Pib::getAt.
PIA_IDS_PIBTABLE1 | (Currently unused.)
PIA_IDS_PIBTABLE2 | (Currently unused.)
PIA_IDS_PONSETOUT | String ID for printing second prior date of onset in nondisability case.
PIA_IDS_PRCESSOUT | String ID for printing prior date of cessation.
PIA_IDS_PRENTOUT | String ID for printing date of prior entitlement in nondisability case.
PIA_IDS_PRIOROUT | String ID for printing prior date of entitlement in disability case.
PIA_IDS_PROBASOUT | String ID for printing projected wage base type.
PIA_IDS_PROJBACK1 | Type of PiaException thrown if backward projection indicator is out of range in general case (0-2).
PIA_IDS_PROJBACK2 | Type of PiaException thrown if backward projection indicator is out of range in backward projection case (1-2).
PIA_IDS_PROJFWRD1 | Type of PiaException thrown if forward projection indicator is out of range in general case (0-2).
PIA_IDS_PROJFWRD2 | Type of PiaException thrown if forward projection indicator is out of range in forward projection case (1-2).
PIA_IDS_PRRENT1 | Type of PiaException thrown if month of prior entitlement is out of range.
PIA_IDS_PRRENT2 | Type of PiaException thrown if year of prior entitlement is before 1940.
PIA_IDS_PRRENT3 | Type of PiaException thrown if year of prior entitlement is after maximum allowed.
PIA_IDS_PRRENT4 | Type of PiaException thrown if prior entitlement is not before current entitlement.
PIA_IDS_PRRENT5 | Type of PiaException thrown if prior entitlement to disability is before disability onset.
PIA_IDS_PRRENT6 | (Currently unused.)
PIA_IDS_PRRENT7 | Type of PiaException thrown if prior entitlement to disability is after full retirement age.
PIA_IDS_PTSTRING | Type of PiaException thrown if error in PiaTable1Page::prepareStrings.
PIA_IDS_PUBPEN | Type of PiaException thrown if public pension amount is out of range.
PIA_IDS_QC | Type of PiaException thrown if number of quarters of coverage, 1951-77, is greater than number of quarters of coverage, 1937-77.
PIA_IDS_QC51TD | Type of PiaException thrown if number of quarters of coverage, 1951-77, is out of range.
PIA_IDS_QCAMT | Type of PiaException thrown if average wages have not been set in Qcamt::project.
PIA_IDS_QCANN | Type of PiaException thrown if number of annual quarters of coverage is out of range.
PIA_IDS_QCARRAY1 | Type of PiaException thrown if year is out of range in QcArray functions.
PIA_IDS_QCARRAY2 | (Currently unused).
PIA_IDS_QCARRAY3 | Type of PiaException thrown if years are out of range in QcArray::accumulate.
PIA_IDS_QCARRAY4 | Type of PiaException thrown if quarters are out of range in QcArray::accumulate.
PIA_IDS_QCCAL | Type of PiaException thrown if quarter of coverage amount has not been set in PiaData::qcCal.
PIA_IDS_QCDISCAL | Type of PiaException thrown if any starting or ending dates are out of range in PiaData::qcDisCal.
PIA_IDS_QCLUMPYEAR | Type of PiaException thrown if qclumpyear is out of range.
PIA_IDS_QCPACKED1 | Type of PiaException thrown if index is out of range in QcPacked::get.
PIA_IDS_QCPACKED2 | Type of PiaException thrown if index is out of range in QcPacked::set.
PIA_IDS_QCTD | Type of PiaException thrown if number of quarters of coverage, 1937-77, is out of range.
PIA_IDS_QCTOT0 | Type of PiaException thrown if no quarters of coverage in a totalization case.
PIA_IDS_QTRYRQTR | Type of PiaException thrown if number of quarters in a QtrYear is greater than 3.
PIA_IDS_QTRYRYR | Type of PiaException thrown if year in a QtrYear is greater than LASTYEARLR.
PIA_IDS_READEOF | Return value from PiaRead::read if successful read, with end of file following.
PIA_IDS_READERR | Type of PiaException thrown if unable to read a pia file.
PIA_IDS_READMORE | Return value from PiaRead::read if successful read, with additional data following.
PIA_IDS_RELERNOUT | String ID for printing relative earnings level.
PIA_IDS_RELERNPOS | Type of PiaException thrown if first year is out of range in PiaCal::relEarnPositionCal.
PIA_IDS_REQQCOUT | String ID for printing required quarters of coverage.
PIA_IDS_REVIEWBI | (Currently unused.)
PIA_IDS_ROUND | Type of PiaException thrown if year is before 1937 in BenefitAmount functions.
PIA_IDS_RTGENRL | Type of PiaException thrown if denominator is out of range in RtGeneral::project1.
PIA_IDS_RWSTRING | Type of PiaException thrown if error in ReindWid1Page::prepareStrings.
PIA_IDS_SECONDARY | Type of PiaException thrown if type of bic is not set in Secondary::check.
PIA_IDS_SETNOCH | Type of PiaException thrown if year is out of range in PiaParams::setNoChange.
PIA_IDS_SEX | Type of PiaException thrown if sex is not Sex::sex_type::MALE or Sex::sex_type::FEMALE.
PIA_IDS_SEXOUT | String ID for printing sex of worker.
PIA_IDS_SGAPROJ | Type of PiaException thrown if annual Sga project function is called.
PIA_IDS_SMSTRING | Type of PiaException thrown if error in SpecMin1Page::prepareStrings.
PIA_IDS_SPPIA1OUT | String ID for printing special minimum PIA, support PIA unused.
PIA_IDS_SPPIA2OUT | String ID for printing special minimum PIA, support PIA used.
PIA_IDS_SPYRS2OUT | String ID for printing total special minimum years of coverage.
PIA_IDS_SPYRSOUT | String ID for printing total special minimum years of coverage.
PIA_IDS_SSN1 | Type of PiaException thrown if number of characters in a string used to construct an Ssn is less than 9.
PIA_IDS_SSNOUT | String ID for printing worker's Social Security number.
PIA_IDS_START1 | Type of PiaException thrown if starting year of assumptions is before 1979.
PIA_IDS_START2 | Type of PiaException thrown if starting year of assumptions is after maximum year allowed.
PIA_IDS_SUPPIAOUT | String ID for printing support PIA.
PIA_IDS_SURVBENOUT | String ID for printing secondary date of benefit.
PIA_IDS_SURVENTOUT | String ID for printing secondary date of entitlement.
PIA_IDS_TAXTYPE | Type of PiaException thrown if type of taxes is out of range.
PIA_IDS_TAXTYPEYR | Type of PiaException thrown if year is out of range in WorkerData::setTaxType.
PIA_IDS_TGSTRING | Type of PiaException thrown if error in TransGuar1Page::prepareStrings.
PIA_IDS_TITLEPRO1 | (Currently unused.)
PIA_IDS_TITLEPRO2 | (Currently unused.)
PIA_IDS_TITLEPRO3 | (Currently unused.)
PIA_IDS_TITLEPRO4 | (Currently unused).
PIA_IDS_TWOPAGE1 | Type of PiaException thrown if error in InsuredPage::prepareStrings.
PIA_IDS_TWOPAGE2 | Type of PiaException thrown if error in EarningsPage::prepareStrings.
PIA_IDS_TWOPAGE3 | Type of PiaException thrown if error in Summary1Page::prepareStrings.
PIA_IDS_TWOPAGE4 | Type of PiaException thrown if error in Summary2Page::prepareStrings.
PIA_IDS_TWOPAGE5 | Type of PiaException thrown if error in Summary3Page::prepareStrings.
PIA_IDS_TXSTRING | Type of PiaException thrown if error in TaxesPage::prepareStrings.
PIA_IDS_UNBICCHP | Type of PiaException thrown if either year is out of range in PiaParams::unbiCatchUp.
PIA_IDS_UNEARNOUT | String ID for printing unused earnings message.
PIA_IDS_UPDATEAW | (Currently unused.)
PIA_IDS_UPDATEBI | (Currently unused.)
PIA_IDS_UPDATEFQ | Type of PiaException thrown if average wage is zero in PiaParams::updateFq.
PIA_IDS_UPDATEWB | (Currently unused.)
PIA_IDS_UPDATEWBOLD | (Currently unused.)
PIA_IDS_VALDI1 | Type of PiaException thrown if number of periods of disability is not 0, 1, or 2 in a nondisability case.
PIA_IDS_VALDI2 | Type of PiaException thrown if number of periods of disability is not 1 or 2 in a disability case.
PIA_IDS_WAGEBASE | (Currently unused.)
PIA_IDS_WAITPD1 | Type of PiaException thrown if first month of waiting period is out of range.
PIA_IDS_WAITPD2 | Type of PiaException thrown if year of first month of waiting period is before 1940.
PIA_IDS_WAITPD3 | Type of PiaException thrown if year of first month of waiting period is after maximum allowed.
PIA_IDS_WAITPD4 | Type of PiaException thrown if waiting period starts before onset.
PIA_IDS_WAITPD5 | Type of PiaException thrown if entitlement is before waiting period.
PIA_IDS_WAITPD6 | Type of PiaException thrown if cessation is before waiting period.
PIA_IDS_WAITPD7 | (Currently unused.)
PIA_IDS_WIDDIBOUT | String ID for printing date of onset of widow(er).
PIA_IDS_WISTRING | Type of PiaException thrown if error in WageInd1Page::prepareStrings.
PIA_IDS_WRITEEARN | Type of PiaException thrown if first year of earnings is out of range in PiaWrite::writeEarnOasdi or PiaWriteAny::writeEarnOasdi.
PIA_IDS_YEAR | (Currently unused.)
_AFXDLL | Use the AFXDLL library, which contains MFC in a DLL.
Collapse Expand Module

Misc Library

Collapse Expand Links
Macros, Misc Library


ENDS Macro

ENDS Macro
CommaBase.h Macros

No special character for end of ostringstream.

C++
#define ENDS
Collapse Expand File

File: CommaBase.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
CommaBase.h, Macros


FREEZE Macro

FREEZE Macro
CommaBase.h Macros

No special function to freeze the string.

C++
#define FREEZE(strm)
Collapse Expand File

File: CommaBase.h

Module: Misc Library

Collapse Expand Parameters
Parameters | Description
strm | Stream to freeze.
Collapse Expand Group

Macros

Collapse Expand Links
CommaBase.h, Macros


OSTREAM Macro

OSTREAM Macro
CommaBase.h Macros

Use ostringstream for formatting output.

C++
#define OSTREAM std::ostringstream
Collapse Expand File

File: CommaBase.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
CommaBase.h, Macros


PIA_IDS_2YEARS Macro

PIA_IDS_2YEARS Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_2YEARS 61315
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ACTQCOUT Macro

PIA_IDS_ACTQCOUT Macro
Resource.h Macros

String ID for printing actual quarters of coverage.

C++
#define PIA_IDS_ACTQCOUT 61393
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_AGEMONTH Macro

PIA_IDS_AGEMONTH Macro
Resource.h Macros

Type of PiaException thrown if number of months in an Age is greater than 11.

C++
#define PIA_IDS_AGEMONTH 62096
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_AGEPLAN Macro

PIA_IDS_AGEPLAN Macro
Resource.h Macros

Type of PiaException thrown if planned age of retirement is out of range.

C++
#define PIA_IDS_AGEPLAN 61206
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_AIMEOUT Macro

PIA_IDS_AIMEOUT Macro
Resource.h Macros

String ID for printing AIME.

C++
#define PIA_IDS_AIMEOUT 61407
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_AMEOUT Macro

PIA_IDS_AMEOUT Macro
Resource.h Macros

String ID for printing AMW.

C++
#define PIA_IDS_AMEOUT 61406
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ANDLATER Macro

PIA_IDS_ANDLATER Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_ANDLATER 61322
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ANSCCH Macro

PIA_IDS_ANSCCH Macro
Resource.h Macros

Type of PiaException thrown if catch-up increase indicator is out of range.

C++
#define PIA_IDS_ANSCCH 61327
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_APPCOLA1 Macro

PIA_IDS_APPCOLA1 Macro
Resource.h Macros

Type of PiaException thrown if year is out of range in PiaParams::applyCola without catch-up.

C++
#define PIA_IDS_APPCOLA1 62118
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_APPCOLA2 Macro

PIA_IDS_APPCOLA2 Macro
Resource.h Macros

Type of PiaException thrown if year is out of range in PiaParams::applyCola with catch-up.

C++
#define PIA_IDS_APPCOLA2 62119
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_APPCOLA3 Macro

PIA_IDS_APPCOLA3 Macro
Resource.h Macros

Type of PiaException thrown if year is out of range in PiaParams::applyColaMfb without catch-up.

C++
#define PIA_IDS_APPCOLA3 62120
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_APPCOLA4 Macro

PIA_IDS_APPCOLA4 Macro
Resource.h Macros

Type of PiaException thrown if year is out of range in PiaParams::applyColaMfb with catch-up.

C++
#define PIA_IDS_APPCOLA4 62121
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ARDRI1 Macro

PIA_IDS_ARDRI1 Macro
Resource.h Macros

Type of PiaException thrown if age is out of range in PiaCal::ardriCal.

C++
#define PIA_IDS_ARDRI1 61288
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ARDRI10 Macro

PIA_IDS_ARDRI10 Macro
Resource.h Macros

Type of PiaException thrown if aged wife age is before early retirement age in PiaCal::ardriAuxCal.

C++
#define PIA_IDS_ARDRI10 62088
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ARDRI2 Macro

PIA_IDS_ARDRI2 Macro
Resource.h Macros

Type of PiaException thrown if age is before early retirement age for OAB in PiaCal::ardriCal.

C++
#define PIA_IDS_ARDRI2 61289
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ARDRI3 Macro

PIA_IDS_ARDRI3 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_ARDRI3 61290
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ARDRI4 Macro

PIA_IDS_ARDRI4 Macro
Resource.h Macros

Type of PiaException thrown if disabled widow(er) age is before earliest possible age in PiaCal::ardriAuxCal.

C++
#define PIA_IDS_ARDRI4 61291
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ARDRI5 Macro

PIA_IDS_ARDRI5 Macro
Resource.h Macros

Type of PiaException thrown if disabled widow(er) entitlement is before benefit date in PiaCal::ardriAuxCal.

C++
#define PIA_IDS_ARDRI5 61292
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ARDRI6 Macro

PIA_IDS_ARDRI6 Macro
Resource.h Macros

Type of PiaException thrown if aged widow(er) age is before earliest possible age in PiaCal::ardriAuxCal.

C++
#define PIA_IDS_ARDRI6 61293
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ARDRI7 Macro

PIA_IDS_ARDRI7 Macro
Resource.h Macros

Type of PiaException thrown if DIB entitlement before 1957 in PiaCal::ardriCal.

C++
#define PIA_IDS_ARDRI7 61294
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ARDRI8 Macro

PIA_IDS_ARDRI8 Macro
Resource.h Macros

Type of PiaException thrown if age under 50 for DIB before 1960 in PiaCal::ardriCal.

C++
#define PIA_IDS_ARDRI8 61295
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ARDRI9 Macro

PIA_IDS_ARDRI9 Macro
Resource.h Macros

Type of PiaException thrown if age over full retirement age for DIB in PiaCal::ardriCal.

C++
#define PIA_IDS_ARDRI9 61296
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ARFFOUT Macro

PIA_IDS_ARFFOUT Macro
Resource.h Macros

String ID for printing actuarial reduction factor.

C++
#define PIA_IDS_ARFFOUT 61414
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ARFMOUT Macro

PIA_IDS_ARFMOUT Macro
Resource.h Macros

String ID for printing months of actuarial reduction.

C++
#define PIA_IDS_ARFMOUT 61412
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ATODOUBLE Macro

PIA_IDS_ATODOUBLE Macro
Resource.h Macros

(Currently unused).

C++
#define PIA_IDS_ATODOUBLE 62046
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ATOFLOAT Macro

PIA_IDS_ATOFLOAT Macro
Resource.h Macros

(Currently unused).

C++
#define PIA_IDS_ATOFLOAT 62043
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ATOINT Macro

PIA_IDS_ATOINT Macro
Resource.h Macros

(Currently unused).

C++
#define PIA_IDS_ATOINT 62044
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ATOLONG Macro

PIA_IDS_ATOLONG Macro
Resource.h Macros

(Currently unused).

C++
#define PIA_IDS_ATOLONG 62045
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_AVERAGETEXT Macro

PIA_IDS_AVERAGETEXT Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_AVERAGETEXT 61363
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_AVGWG Macro

PIA_IDS_AVGWG Macro
Resource.h Macros

Type of PiaException thrown if year is out of range in an AverageWage function.

C++
#define PIA_IDS_AVGWG 62054
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_AVGWGTTL Macro

PIA_IDS_AVGWGTTL Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_AVGWGTTL 61324
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_AWASSUM Macro

PIA_IDS_AWASSUM Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_AWASSUM 61431
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_AWBI1 Macro

PIA_IDS_AWBI1 Macro
Resource.h Macros

Type of PiaException thrown if unable to open input file in AwbiDataFile::read.

C++
#define PIA_IDS_AWBI1 61298
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_AWBI2 Macro

PIA_IDS_AWBI2 Macro
Resource.h Macros

Type of PiaException thrown if unable to open output file in AwbiDataFile::write.

C++
#define PIA_IDS_AWBI2 61301
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_AWBI3 Macro

PIA_IDS_AWBI3 Macro
Resource.h Macros

Type of PiaException thrown if unable to read all required data in AwbiDataFile::read.

C++
#define PIA_IDS_AWBI3 61299
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_AWBIDAT1 Macro

PIA_IDS_AWBIDAT1 Macro
Resource.h Macros

Type of PiaException thrown if last year of historical data is too large in AwbiDataNonFile::setData.

C++
#define PIA_IDS_AWBIDAT1 62090
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_AWOUT Macro

PIA_IDS_AWOUT Macro
Resource.h Macros

String ID for printing average wage assumptions.

C++
#define PIA_IDS_AWOUT 61386
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BASE1 Macro

PIA_IDS_BASE1 Macro
Resource.h Macros

Type of PiaException thrown if first year is out of range in WageBaseGeneral::project.

C++
#define PIA_IDS_BASE1 62031
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BASE2 Macro

PIA_IDS_BASE2 Macro
Resource.h Macros

Type of PiaException thrown if wage base is out of range.

C++
#define PIA_IDS_BASE2 61329
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BASECH Macro

PIA_IDS_BASECH Macro
Resource.h Macros

Type of PiaException thrown if wage base indicator is not 1 or 2.

C++
#define PIA_IDS_BASECH 61310
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BASEYR1 Macro

PIA_IDS_BASEYR1 Macro
Resource.h Macros

Type of PiaException thrown if base year is out of range (1979-2020).

C++
#define PIA_IDS_BASEYR1 61307
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BASEYR2 Macro

PIA_IDS_BASEYR2 Macro
Resource.h Macros

Type of PiaException thrown if unable to open output file in BaseYearFile::write.

C++
#define PIA_IDS_BASEYR2 61305
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BASEYR3 Macro

PIA_IDS_BASEYR3 Macro
Resource.h Macros

Type of PiaException thrown if unable to read base year in BaseYearFile::read.

C++
#define PIA_IDS_BASEYR3 61304
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BASEYR4 Macro

PIA_IDS_BASEYR4 Macro
Resource.h Macros

Type of PiaException thrown if unable to open input file in BaseYearFile::read.

C++
#define PIA_IDS_BASEYR4 61303
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BEGIN1 Macro

PIA_IDS_BEGIN1 Macro
Resource.h Macros

Type of PiaException thrown if first year of earnings is out of range.

C++
#define PIA_IDS_BEGIN1 61207
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BEGIN2 Macro

PIA_IDS_BEGIN2 Macro
Resource.h Macros

Type of PiaException thrown if last year of earnings is before first year of earnings in backward projection period.

C++
#define PIA_IDS_BEGIN2 61208
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BEGIN3 Macro

PIA_IDS_BEGIN3 Macro
Resource.h Macros

Type of PiaException thrown if first year of earnings is before 1937.

C++
#define PIA_IDS_BEGIN3 61218
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BEGIN4 Macro

PIA_IDS_BEGIN4 Macro
Resource.h Macros

Type of PiaException thrown if first year of earnings is in starting year of projections or later, in a Statement case.

C++
#define PIA_IDS_BEGIN4 61235
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BEGIN5 Macro

PIA_IDS_BEGIN5 Macro
Resource.h Macros

Type of PiaException thrown if first year of earnings is after maximum year allowed, in a non-Statement case.

C++
#define PIA_IDS_BEGIN5 61236
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BEGIN6 Macro

PIA_IDS_BEGIN6 Macro
Resource.h Macros

Type of PiaException thrown if there are no regular, railroad, or military earnings.

C++
#define PIA_IDS_BEGIN6 62116
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BEN1OUT Macro

PIA_IDS_BEN1OUT Macro
Resource.h Macros

String ID for printing benefit before rounding.

C++
#define PIA_IDS_BEN1OUT 61415
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BEN2OUT Macro

PIA_IDS_BEN2OUT Macro
Resource.h Macros

String ID for printing benefit after rounding.

C++
#define PIA_IDS_BEN2OUT 61418
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BENARRAY1 Macro

PIA_IDS_BENARRAY1 Macro
Resource.h Macros

Type of PiaException thrown if year is out of range in BenefitAmountArray functions.

C++
#define PIA_IDS_BENARRAY1 62060
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BENARRAY2 Macro

PIA_IDS_BENARRAY2 Macro
Resource.h Macros

Type of PiaException thrown if year is out of range in BenefitAmountArray::[].

C++
#define PIA_IDS_BENARRAY2 62061
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BENDATE1 Macro

PIA_IDS_BENDATE1 Macro
Resource.h Macros

Type of PiaException thrown if benefit date is before entitlement date.

C++
#define PIA_IDS_BENDATE1 61231
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BENDATE2 Macro

PIA_IDS_BENDATE2 Macro
Resource.h Macros

Type of PiaException thrown if month of benefit is out of range.

C++
#define PIA_IDS_BENDATE2 61232
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BENDATE3 Macro

PIA_IDS_BENDATE3 Macro
Resource.h Macros

Type of PiaException thrown if year of benefit is before 1940.

C++
#define PIA_IDS_BENDATE3 61233
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BENDATE4 Macro

PIA_IDS_BENDATE4 Macro
Resource.h Macros

Type of PiaException thrown if year of benefit is after maximum allowed.

C++
#define PIA_IDS_BENDATE4 61234
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BENDATE5 Macro

PIA_IDS_BENDATE5 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_BENDATE5 61357
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BENDATE6 Macro

PIA_IDS_BENDATE6 Macro
Resource.h Macros

Type of PiaException thrown if secondary entitlement after benefit date.

C++
#define PIA_IDS_BENDATE6 62095
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BENFOUT Macro

PIA_IDS_BENFOUT Macro
Resource.h Macros

String ID for printing secondary benefit factor.

C++
#define PIA_IDS_BENFOUT 61413
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BIASSUM Macro

PIA_IDS_BIASSUM Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_BIASSUM 61430
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BICCHP Macro

PIA_IDS_BICCHP Macro
Resource.h Macros

Type of PiaException thrown if year is out of range in Catchup functions.

C++
#define PIA_IDS_BICCHP 62032
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BIOUT Macro

PIA_IDS_BIOUT Macro
Resource.h Macros

String ID for printing benefit increase assumptions.

C++
#define PIA_IDS_BIOUT 61385
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BIPROJTTL Macro

PIA_IDS_BIPROJTTL Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_BIPROJTTL 61312
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BIRTH1 Macro

PIA_IDS_BIRTH1 Macro
Resource.h Macros

Type of PiaException thrown if year of birth is in current year or later (in Statement case).

C++
#define PIA_IDS_BIRTH1 61213
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BIRTH2 Macro

PIA_IDS_BIRTH2 Macro
Resource.h Macros

Type of PiaException thrown if year of birth is before 1800.

C++
#define PIA_IDS_BIRTH2 61212
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BIRTH3 Macro

PIA_IDS_BIRTH3 Macro
Resource.h Macros

Type of PiaException thrown if month of birth is out of range.

C++
#define PIA_IDS_BIRTH3 61209
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BIRTH4 Macro

PIA_IDS_BIRTH4 Macro
Resource.h Macros

Type of PiaException thrown if day of birth is out of range.

C++
#define PIA_IDS_BIRTH4 61210
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BIRTH5 Macro

PIA_IDS_BIRTH5 Macro
Resource.h Macros

Type of PiaException thrown if year of birth is after maximum allowed.

C++
#define PIA_IDS_BIRTH5 61214
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BIRTH6 Macro

PIA_IDS_BIRTH6 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_BIRTH6 61342
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_BITANN1 Macro

PIA_IDS_BITANN1 Macro
Resource.h Macros

Type of PiaException thrown if year is out of range in BitAnnual functions.

C++
#define PIA_IDS_BITANN1 62112
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_CACHUP1 Macro

PIA_IDS_CACHUP1 Macro
Resource.h Macros

Type of PiaException thrown if catch-up benefit increase is out of range.

C++
#define PIA_IDS_CACHUP1 61321
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_CACHUP2 Macro

PIA_IDS_CACHUP2 Macro
Resource.h Macros

Type of PiaException thrown if unable to open input file in CatchupFile::read.

C++
#define PIA_IDS_CACHUP2 61331
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_CACHUP3 Macro

PIA_IDS_CACHUP3 Macro
Resource.h Macros

Type of PiaException thrown if unable to open output file in CatchupFile::write.

C++
#define PIA_IDS_CACHUP3 61332
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_CACHUP4 Macro

PIA_IDS_CACHUP4 Macro
Resource.h Macros

Type of PiaException thrown if year is out of range in a Catchup function.

C++
#define PIA_IDS_CACHUP4 62052
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_CESS2OUT Macro

PIA_IDS_CESS2OUT Macro
Resource.h Macros

String ID for printing second prior date of cessation.

C++
#define PIA_IDS_CESS2OUT 61401
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_COMMA Macro

PIA_IDS_COMMA Macro
Resource.h Macros

Type of PiaException thrown if number of decimals is nonzero for other than a float type in pout.

C++
#define PIA_IDS_COMMA 62117
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_CONFIG1 Macro

PIA_IDS_CONFIG1 Macro
Resource.h Macros

Type of PiaException thrown if unable to open input file in ConfigFile::read.

C++
#define PIA_IDS_CONFIG1 62077
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_CONFIG5 Macro

PIA_IDS_CONFIG5 Macro
Resource.h Macros

Type of PiaException thrown if unable to open output file in ConfigFile::write.

C++
#define PIA_IDS_CONFIG5 62078
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_CONFIG6 Macro

PIA_IDS_CONFIG6 Macro
Resource.h Macros

Type of PiaException thrown if unable to read all required data in ConfigFile::read.

C++
#define PIA_IDS_CONFIG6 62079
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_CPIINC1 Macro

PIA_IDS_CPIINC1 Macro
Resource.h Macros

Type of PiaException thrown if benefit increase is out of range.

C++
#define PIA_IDS_CPIINC1 61318
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_CPIINC2 Macro

PIA_IDS_CPIINC2 Macro
Resource.h Macros

Type of PiaException thrown if unable to open output file in BiprojFile::write.

C++
#define PIA_IDS_CPIINC2 61316
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_CPIINC3 Macro

PIA_IDS_CPIINC3 Macro
Resource.h Macros

Type of PiaException thrown if unable to read all required data in BiprojFile::read.

C++
#define PIA_IDS_CPIINC3 61314
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_CPIINC4 Macro

PIA_IDS_CPIINC4 Macro
Resource.h Macros

Type of PiaException thrown if unable to open input file in BiprojFile::read.

C++
#define PIA_IDS_CPIINC4 61311
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_CUPROJTTL Macro

PIA_IDS_CUPROJTTL Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_CUPROJTTL 61248
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_CURINSOUT Macro

PIA_IDS_CURINSOUT Macro
Resource.h Macros

String ID for printing currently insured status in survivor case.

C++
#define PIA_IDS_CURINSOUT 62094
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DATEDAY Macro

PIA_IDS_DATEDAY Macro
Resource.h Macros

Type of PiaException thrown if day in a date is out of range.

C++
#define PIA_IDS_DATEDAY 62057
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DATEDIFF Macro

PIA_IDS_DATEDIFF Macro
Resource.h Macros

Type of PiaException thrown if unable to difference two dates.

C++
#define PIA_IDS_DATEDIFF 62059
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DATEMONTH Macro

PIA_IDS_DATEMONTH Macro
Resource.h Macros

Type of PiaException thrown if month in a date is out of range.

C++
#define PIA_IDS_DATEMONTH 62055
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DATEREAD Macro

PIA_IDS_DATEREAD Macro
Resource.h Macros

Type of PiaException thrown if unable to parse string into a date.

C++
#define PIA_IDS_DATEREAD 62058
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DATEYEAR Macro

PIA_IDS_DATEYEAR Macro
Resource.h Macros

Type of PiaException thrown if year in a date is out of range.

C++
#define PIA_IDS_DATEYEAR 62056
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DBLEANN1 Macro

PIA_IDS_DBLEANN1 Macro
Resource.h Macros

(Currently unused).

C++
#define PIA_IDS_DBLEANN1 62016
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DBLEANN2 Macro

PIA_IDS_DBLEANN2 Macro
Resource.h Macros

Type of PiaException thrown if unable to read specified years in DoubleAnnualRead::read.

C++
#define PIA_IDS_DBLEANN2 62017
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DEATH1 Macro

PIA_IDS_DEATH1 Macro
Resource.h Macros

Type of PiaException thrown if month of death is out of range.

C++
#define PIA_IDS_DEATH1 61247
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DEATH2 Macro

PIA_IDS_DEATH2 Macro
Resource.h Macros

Type of PiaException thrown if year of death is after maximum allowed.

C++
#define PIA_IDS_DEATH2 62076
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DEATH3 Macro

PIA_IDS_DEATH3 Macro
Resource.h Macros

Type of PiaException thrown if death before 1937 in a survivor case.

C++
#define PIA_IDS_DEATH3 61254
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DEATH4 Macro

PIA_IDS_DEATH4 Macro
Resource.h Macros

Type of PiaException thrown if entitlement of survivor is before death of worker.

C++
#define PIA_IDS_DEATH4 61252
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DEATH5 Macro

PIA_IDS_DEATH5 Macro
Resource.h Macros

Type of PiaException thrown if death of worker is before birth.

C++
#define PIA_IDS_DEATH5 61253
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DEATH6 Macro

PIA_IDS_DEATH6 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_DEATH6 61345
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DEATHOUT Macro

PIA_IDS_DEATHOUT Macro
Resource.h Macros

String ID for printing date of death.

C++
#define PIA_IDS_DEATHOUT 61374
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DIBENTOUT Macro

PIA_IDS_DIBENTOUT Macro
Resource.h Macros

String ID for printing DIB date of entitlement.

C++
#define PIA_IDS_DIBENTOUT 61382
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DICESS1 Macro

PIA_IDS_DICESS1 Macro
Resource.h Macros

Type of PiaException thrown if month of cessation is out of range.

C++
#define PIA_IDS_DICESS1 61244
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DICESS2 Macro

PIA_IDS_DICESS2 Macro
Resource.h Macros

Type of PiaException thrown if year of cessation is before 1937.

C++
#define PIA_IDS_DICESS2 61245
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DICESS3 Macro

PIA_IDS_DICESS3 Macro
Resource.h Macros

Type of PiaException thrown if year of cessation is after maximum allowed.

C++
#define PIA_IDS_DICESS3 61246
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DICESS4 Macro

PIA_IDS_DICESS4 Macro
Resource.h Macros

Type of PiaException thrown if disability cessation before onset.

C++
#define PIA_IDS_DICESS4 61258
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DICESS5 Macro

PIA_IDS_DICESS5 Macro
Resource.h Macros

Type of PiaException thrown if prior disability cessation after second entitlement.

C++
#define PIA_IDS_DICESS5 61262
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DICESS6 Macro

PIA_IDS_DICESS6 Macro
Resource.h Macros

Type of PiaException thrown if entitlement is before cessation.

C++
#define PIA_IDS_DICESS6 61259
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DICESS7 Macro

PIA_IDS_DICESS7 Macro
Resource.h Macros

Type of PiaException thrown if cessation is after death in a survivor case.

C++
#define PIA_IDS_DICESS7 61260
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DICESS8 Macro

PIA_IDS_DICESS8 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_DICESS8 61344
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DINS1OUT Macro

PIA_IDS_DINS1OUT Macro
Resource.h Macros

String ID for printing first part of disability insured status.

C++
#define PIA_IDS_DINS1OUT 61395
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DINS2OUT Macro

PIA_IDS_DINS2OUT Macro
Resource.h Macros

String ID for printing second part of disability insured status.

C++
#define PIA_IDS_DINS2OUT 61396
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DINS3OUT Macro

PIA_IDS_DINS3OUT Macro
Resource.h Macros

String ID for printing third part of disability insured status.

C++
#define PIA_IDS_DINS3OUT 61397
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DISREQCAL1 Macro

PIA_IDS_DISREQCAL1 Macro
Resource.h Macros

Type of PiaException thrown if year in most recent freeze period is out of range in PiaData::qcDisReqCal.

C++
#define PIA_IDS_DISREQCAL1 62105
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DISREQCAL2 Macro

PIA_IDS_DISREQCAL2 Macro
Resource.h Macros

Type of PiaException thrown if year in next most recent freeze period is out of range in PiaData::qcDisReqCal.

C++
#define PIA_IDS_DISREQCAL2 62106
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DOBOUT Macro

PIA_IDS_DOBOUT Macro
Resource.h Macros

String ID for printing date of birth.

C++
#define PIA_IDS_DOBOUT 61369
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DOBWIDOUT Macro

PIA_IDS_DOBWIDOUT Macro
Resource.h Macros

String ID for printing date of birth of widow(er).

C++
#define PIA_IDS_DOBWIDOUT 61404
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DRCFOUT Macro

PIA_IDS_DRCFOUT Macro
Resource.h Macros

String ID for printing delayed retirement credit factor.

C++
#define PIA_IDS_DRCFOUT 61411
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_DRCMOUT Macro

PIA_IDS_DRCMOUT Macro
Resource.h Macros

String ID for printing months of delayed retirement credit.

C++
#define PIA_IDS_DRCMOUT 61410
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_EARNHI Macro

PIA_IDS_EARNHI Macro
Resource.h Macros

Type of PiaException thrown if Medicare earnings are out of range.

C++
#define PIA_IDS_EARNHI 61328
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_EARNMAL Macro

PIA_IDS_EARNMAL Macro
Resource.h Macros

Type of PiaException thrown if year is before 1937 in EarnProject::toString.

C++
#define PIA_IDS_EARNMAL 62040
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_EARNPEBS Macro

PIA_IDS_EARNPEBS Macro
Resource.h Macros

Type of PiaException thrown if OASDI earnings are out of range.

C++
#define PIA_IDS_EARNPEBS 61326
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_EARNPROJ Macro

PIA_IDS_EARNPROJ Macro
Resource.h Macros

Type of PiaException thrown if projection year is out of range in EarnProject::project.

C++
#define PIA_IDS_EARNPROJ 62108
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_EARNTYPE Macro

PIA_IDS_EARNTYPE Macro
Resource.h Macros

Type of PiaException thrown if type of earnings is out of range.

C++
#define PIA_IDS_EARNTYPE 61325
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_EARNTYPE1 Macro

PIA_IDS_EARNTYPE1 Macro
Resource.h Macros

Type of PiaException thrown if projection year is out of range in PiaWrite::writeEarnType.

C++
#define PIA_IDS_EARNTYPE1 62109
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_EARNTYPEYR Macro

PIA_IDS_EARNTYPEYR Macro
Resource.h Macros

Type of PiaException thrown if year is out of range in EarnProject::setEarntype.

C++
#define PIA_IDS_EARNTYPEYR 62037
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ELAPSOUT Macro

PIA_IDS_ELAPSOUT Macro
Resource.h Macros

String ID for printing elapsed years.

C++
#define PIA_IDS_ELAPSOUT 61398
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_END1 Macro

PIA_IDS_END1 Macro
Resource.h Macros

Type of PiaException thrown if last year of earnings is before 1937.

C++
#define PIA_IDS_END1 61219
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_END2 Macro

PIA_IDS_END2 Macro
Resource.h Macros

Type of PiaException thrown if last year of earnings is after maximum year allowed.

C++
#define PIA_IDS_END2 61237
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_END3 Macro

PIA_IDS_END3 Macro
Resource.h Macros

Type of PiaException thrown if first year of earnings in forward projection period is after last year of earnings in forward projection period.

C++
#define PIA_IDS_END3 61225
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_END4 Macro

PIA_IDS_END4 Macro
Resource.h Macros

Type of PiaException thrown if the total number of years of earnings is greater than the maximum allowed (MAXYRS).

C++
#define PIA_IDS_END4 61223
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ENT1 Macro

PIA_IDS_ENT1 Macro
Resource.h Macros

Type of PiaException thrown if month of entitlement is out of range.

C++
#define PIA_IDS_ENT1 61216
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ENT2 Macro

PIA_IDS_ENT2 Macro
Resource.h Macros

Type of PiaException thrown if year of entitlement is before 1940.

C++
#define PIA_IDS_ENT2 61217
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ENT3 Macro

PIA_IDS_ENT3 Macro
Resource.h Macros

Type of PiaException thrown if year of entitlement is after maximum allowed.

C++
#define PIA_IDS_ENT3 61226
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ENT4 Macro

PIA_IDS_ENT4 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_ENT4 61350
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ERNLIMOUT Macro

PIA_IDS_ERNLIMOUT Macro
Resource.h Macros

String ID for printing earnings over maximum allowed.

C++
#define PIA_IDS_ERNLIMOUT 61423
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FAMSIZE Macro

PIA_IDS_FAMSIZE Macro
Resource.h Macros

Type of PiaException thrown if family size is out of bounds.

C++
#define PIA_IDS_FAMSIZE 62086
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FLOATANN1 Macro

PIA_IDS_FLOATANN1 Macro
Resource.h Macros

(Currently unused).

C++
#define PIA_IDS_FLOATANN1 62014
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FLOATANN2 Macro

PIA_IDS_FLOATANN2 Macro
Resource.h Macros

(Currently unused).

C++
#define PIA_IDS_FLOATANN2 62015
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FLOATMTH1 Macro

PIA_IDS_FLOATMTH1 Macro
Resource.h Macros

Type of PiaException thrown if years are out of range in a FloatMonth function.

C++
#define PIA_IDS_FLOATMTH1 62020
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FLOATMTH2 Macro

PIA_IDS_FLOATMTH2 Macro
Resource.h Macros

Type of PiaException thrown if unable to read specified years in FloatMonth::read.

C++
#define PIA_IDS_FLOATMTH2 62021
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FLOATMTH3 Macro

PIA_IDS_FLOATMTH3 Macro
Resource.h Macros

Type of PiaException thrown if quarter is out of range in a FloatMonth function.

C++
#define PIA_IDS_FLOATMTH3 62097
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FLOATQTR1 Macro

PIA_IDS_FLOATQTR1 Macro
Resource.h Macros

Type of PiaException thrown if years are out of range in a FloatQuarter function.

C++
#define PIA_IDS_FLOATQTR1 62022
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FLOATQTR2 Macro

PIA_IDS_FLOATQTR2 Macro
Resource.h Macros

Type of PiaException thrown if unable to read specified years in FloatQuarter::read.

C++
#define PIA_IDS_FLOATQTR2 62023
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FLOATQTR3 Macro

PIA_IDS_FLOATQTR3 Macro
Resource.h Macros

Type of PiaException thrown if quarter is out of range in a FloatQuarter function.

C++
#define PIA_IDS_FLOATQTR3 62047
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FLOATQTR4 Macro

PIA_IDS_FLOATQTR4 Macro
Resource.h Macros

Type of PiaException thrown if data value is zero in a FloatQuarter divide function.

C++
#define PIA_IDS_FLOATQTR4 62048
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FMSTRING Macro

PIA_IDS_FMSTRING Macro
Resource.h Macros

Type of PiaException thrown if error in FrozMinPage::prepareStrings.

C++
#define PIA_IDS_FMSTRING 62074
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FOINFO1 Macro

PIA_IDS_FOINFO1 Macro
Resource.h Macros

Type of PiaException thrown if unable to open input file in FieldOfficeInfoFile::read.

C++
#define PIA_IDS_FOINFO1 61351
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FOINFO2 Macro

PIA_IDS_FOINFO2 Macro
Resource.h Macros

Type of PiaException thrown if unable to read all required data in FieldOfficeInfoFile::read.

C++
#define PIA_IDS_FOINFO2 61352
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FOINFO3 Macro

PIA_IDS_FOINFO3 Macro
Resource.h Macros

Type of PiaException thrown if unable to open output file in FieldOfficeInfoFile::write.

C++
#define PIA_IDS_FOINFO3 61353
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FQINC1 Macro

PIA_IDS_FQINC1 Macro
Resource.h Macros

Type of PiaException thrown if average wage increase is out of range.

C++
#define PIA_IDS_FQINC1 61306
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FQINC2 Macro

PIA_IDS_FQINC2 Macro
Resource.h Macros

Type of PiaException thrown if unable to open output file in AwincFile::write.

C++
#define PIA_IDS_FQINC2 61302
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FQINC3 Macro

PIA_IDS_FQINC3 Macro
Resource.h Macros

Type of PiaException thrown if unable to read all required data in AwincFile::read.

C++
#define PIA_IDS_FQINC3 61300
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FQINC4 Macro

PIA_IDS_FQINC4 Macro
Resource.h Macros

Type of PiaException thrown if unable to open input file in AwincFile::read.

C++
#define PIA_IDS_FQINC4 61297
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_FULLBEN Macro

PIA_IDS_FULLBEN Macro
Resource.h Macros

String ID for printing full secondary benefit.

C++
#define PIA_IDS_FULLBEN 62085
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_GENFILE1 Macro

PIA_IDS_GENFILE1 Macro
Resource.h Macros

Type of PiaException thrown if unable to open a Genfile for output.

C++
#define PIA_IDS_GENFILE1 62007
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_GENFILE2 Macro

PIA_IDS_GENFILE2 Macro
Resource.h Macros

Type of PiaException thrown if unable to open a Genfile for appended output.

C++
#define PIA_IDS_GENFILE2 62008
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_GENFILE3 Macro

PIA_IDS_GENFILE3 Macro
Resource.h Macros

Type of PiaException thrown if unable to open a Genfile for input.

C++
#define PIA_IDS_GENFILE3 62009
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_HIGHTEXT Macro

PIA_IDS_HIGHTEXT Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_HIGHTEXT 61429
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_HISTAMTTL Macro

PIA_IDS_HISTAMTTL Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_HISTAMTTL 61323
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_HISTAMTUPDATE Macro

PIA_IDS_HISTAMTUPDATE Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_HISTAMTUPDATE 61432
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_IALTAW1 Macro

PIA_IDS_IALTAW1 Macro
Resource.h Macros

Type of PiaException thrown if average wage increase indicator is out of range in general case.

C++
#define PIA_IDS_IALTAW1 61309
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_IALTAW2 Macro

PIA_IDS_IALTAW2 Macro
Resource.h Macros

Type of PiaException thrown if average wage increase indicator is out of range in Statement case.

C++
#define PIA_IDS_IALTAW2 61320
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_IALTBI1 Macro

PIA_IDS_IALTBI1 Macro
Resource.h Macros

Type of PiaException thrown if benefit increase indicator is out of range in general case.

C++
#define PIA_IDS_IALTBI1 61308
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_IALTBI2 Macro

PIA_IDS_IALTBI2 Macro
Resource.h Macros

Type of PiaException thrown if benefit increase indicator is out of range in Statement case.

C++
#define PIA_IDS_IALTBI2 61319
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_INSTATOUT Macro

PIA_IDS_INSTATOUT Macro
Resource.h Macros

String ID for printing insured status.

C++
#define PIA_IDS_INSTATOUT 61394
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_INSUREOUT Macro

PIA_IDS_INSUREOUT Macro
Resource.h Macros

String ID for printing fully insured for totalization benefits.

C++
#define PIA_IDS_INSUREOUT 61420
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_INTANN1 Macro

PIA_IDS_INTANN1 Macro
Resource.h Macros

(Currently unused).

C++
#define PIA_IDS_INTANN1 62018
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_INTANN2 Macro

PIA_IDS_INTANN2 Macro
Resource.h Macros

(Currently unused).

C++
#define PIA_IDS_INTANN2 62019
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_JBIRTH1 Macro

PIA_IDS_JBIRTH1 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_JBIRTH1 61264
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_JBIRTH2 Macro

PIA_IDS_JBIRTH2 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_JBIRTH2 61265
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_JBIRTH3 Macro

PIA_IDS_JBIRTH3 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_JBIRTH3 61274
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_JBIRTH4 Macro

PIA_IDS_JBIRTH4 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_JBIRTH4 61275
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_JBIRTH5 Macro

PIA_IDS_JBIRTH5 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_JBIRTH5 61340
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_JOASDI Macro

PIA_IDS_JOASDI Macro
Resource.h Macros

Type of PiaException thrown if type of benefit is out of range.

C++
#define PIA_IDS_JOASDI 61211
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_JONSET1 Macro

PIA_IDS_JONSET1 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_JONSET1 61266
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_JONSET2 Macro

PIA_IDS_JONSET2 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_JONSET2 61267
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_JONSET3 Macro

PIA_IDS_JONSET3 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_JONSET3 61268
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_JONSET4 Macro

PIA_IDS_JONSET4 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_JONSET4 61269
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_JONSET5 Macro

PIA_IDS_JONSET5 Macro
Resource.h Macros

Type of PiaException thrown if widow's disability is before birth.

C++
#define PIA_IDS_JONSET5 61276
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_JONSET6 Macro

PIA_IDS_JONSET6 Macro
Resource.h Macros

Type of PiaException thrown if widow's disability is after entitlement.

C++
#define PIA_IDS_JONSET6 61273
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_JONSET7 Macro

PIA_IDS_JONSET7 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_JONSET7 61341
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_JSURV Macro

PIA_IDS_JSURV Macro
Resource.h Macros

Type of PiaException thrown if bic is not a valid life or survivor bic.

C++
#define PIA_IDS_JSURV 61263
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_JSURVOUT Macro

PIA_IDS_JSURVOUT Macro
Resource.h Macros

String ID for printing type of survivor.

C++
#define PIA_IDS_JSURVOUT 61377
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_LAWCHG1 Macro

PIA_IDS_LAWCHG1 Macro
Resource.h Macros

Type of PiaException thrown if starting year of law changes is out of range.

C++
#define PIA_IDS_LAWCHG1 61333
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_LAWCHG2 Macro

PIA_IDS_LAWCHG2 Macro
Resource.h Macros

Type of PiaException thrown if law change wage increase proportion is out of range.

C++
#define PIA_IDS_LAWCHG2 61334
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_LAWCHG3 Macro

PIA_IDS_LAWCHG3 Macro
Resource.h Macros

Type of PiaException thrown if law change benefit formula percentage is out of range.

C++
#define PIA_IDS_LAWCHG3 61335
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_LAWCHG4 Macro

PIA_IDS_LAWCHG4 Macro
Resource.h Macros

Type of PiaException thrown if law change bend point is out of range.

C++
#define PIA_IDS_LAWCHG4 61336
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_LAWCHG5 Macro

PIA_IDS_LAWCHG5 Macro
Resource.h Macros

Type of PiaException thrown if law change constant decline percentage is out of range.

C++
#define PIA_IDS_LAWCHG5 61337
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_LAWCHG6 Macro

PIA_IDS_LAWCHG6 Macro
Resource.h Macros

Type of PiaException thrown if unable to parse input line in LawChangeRead::read.

C++
#define PIA_IDS_LAWCHG6 61355
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_LAWCHG7 Macro

PIA_IDS_LAWCHG7 Macro
Resource.h Macros

Type of PiaException thrown if unable to open input file in LawChangeRead::read.

C++
#define PIA_IDS_LAWCHG7 61354
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_LAWCHG8 Macro

PIA_IDS_LAWCHG8 Macro
Resource.h Macros

Type of PiaException thrown if unable to open output file in LawChangeWrite::write.

C++
#define PIA_IDS_LAWCHG8 61356
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_LAWCHG9 Macro

PIA_IDS_LAWCHG9 Macro
Resource.h Macros

Type of PiaException thrown if type of law change is out of range.

C++
#define PIA_IDS_LAWCHG9 62051
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_LOWTEXT Macro

PIA_IDS_LOWTEXT Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_LOWTEXT 61364
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_MAXIMUMTEXT Macro

PIA_IDS_MAXIMUMTEXT Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_MAXIMUMTEXT 61362
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_METHOD Macro

PIA_IDS_METHOD Macro
Resource.h Macros

Type of PiaException thrown if years are inconsistent in PiaMethod::totalEarnCal.

C++
#define PIA_IDS_METHOD 62098
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_MFBBEN Macro

PIA_IDS_MFBBEN Macro
Resource.h Macros

String ID for printing maximum family benefit.

C++
#define PIA_IDS_MFBBEN 62087
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_MFBLOUT Macro

PIA_IDS_MFBLOUT Macro
Resource.h Macros

String ID for printing MFB at eligibility.

C++
#define PIA_IDS_MFBLOUT 61416
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_MFBOUT Macro

PIA_IDS_MFBOUT Macro
Resource.h Macros

String ID for printing MFB.

C++
#define PIA_IDS_MFBOUT 61384
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_MILSERV1 Macro

PIA_IDS_MILSERV1 Macro
Resource.h Macros

Type of PiaException thrown if military service starting date is after ending date.

C++
#define PIA_IDS_MILSERV1 62080
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_MILSERV2 Macro

PIA_IDS_MILSERV2 Macro
Resource.h Macros

Type of PiaException thrown if number of military service periods is out of range in general case.

C++
#define PIA_IDS_MILSERV2 62081
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_MILSERV3 Macro

PIA_IDS_MILSERV3 Macro
Resource.h Macros

Type of PiaException thrown if number of military service periods is out of range in military service case.

C++
#define PIA_IDS_MILSERV3 62082
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_MILSERV4 Macro

PIA_IDS_MILSERV4 Macro
Resource.h Macros

Type of PiaException thrown if military service starting date is out of range.

C++
#define PIA_IDS_MILSERV4 62083
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_MILSERV5 Macro

PIA_IDS_MILSERV5 Macro
Resource.h Macros

Type of PiaException thrown if military service ending date is out of range.

C++
#define PIA_IDS_MILSERV5 62084
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_MILSERV6 Macro

PIA_IDS_MILSERV6 Macro
Resource.h Macros

Type of PiaException thrown if years are out of range in MilServDates::getQc3750.

C++
#define PIA_IDS_MILSERV6 62103
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_MILSERV7 Macro

PIA_IDS_MILSERV7 Macro
Resource.h Macros

Type of PiaException thrown if years are out of range in MilServDates::getEarn3750.

C++
#define PIA_IDS_MILSERV7 62104
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_MODTC Macro

PIA_IDS_MODTC Macro
Resource.h Macros

Type of PiaException thrown if moddata is in error.

C++
#define PIA_IDS_MODTC 62053
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_MONTHTEXT Macro

PIA_IDS_MONTHTEXT Macro
Resource.h Macros

(Currently unused).

C++
#define PIA_IDS_MONTHTEXT 61204
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NAMEOUT Macro

PIA_IDS_NAMEOUT Macro
Resource.h Macros

String ID for printing worker's name.

C++
#define PIA_IDS_NAMEOUT 61387
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NDISINOUT Macro

PIA_IDS_NDISINOUT Macro
Resource.h Macros

String ID for printing not disability insured.

C++
#define PIA_IDS_NDISINOUT 61427
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NEEDAW Macro

PIA_IDS_NEEDAW Macro
Resource.h Macros

(Currently unused).

C++
#define PIA_IDS_NEEDAW 62039
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NEEDBASES Macro

PIA_IDS_NEEDBASES Macro
Resource.h Macros

Type of PiaException thrown if year is out of range in WorkerDataGeneral::need_bases.

C++
#define PIA_IDS_NEEDBASES 62041
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NEEDBI Macro

PIA_IDS_NEEDBI Macro
Resource.h Macros

(Currently unused).

C++
#define PIA_IDS_NEEDBI 62042
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NINSTOUT Macro

PIA_IDS_NINSTOUT Macro
Resource.h Macros

String ID for printing not insured in survivor case.

C++
#define PIA_IDS_NINSTOUT 61424
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NINSUROUT Macro

PIA_IDS_NINSUROUT Macro
Resource.h Macros

String ID for printing not fully insured.

C++
#define PIA_IDS_NINSUROUT 61421
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NONPENDATE1 Macro

PIA_IDS_NONPENDATE1 Macro
Resource.h Macros

Type of PiaException thrown if noncovered pension entitlement date is before birth.

C++
#define PIA_IDS_NONPENDATE1 62123
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NONPENDATE2 Macro

PIA_IDS_NONPENDATE2 Macro
Resource.h Macros

Type of PiaException thrown if noncovered pension entitlement date is after death.

C++
#define PIA_IDS_NONPENDATE2 62124
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NONPENDATE3 Macro

PIA_IDS_NONPENDATE3 Macro
Resource.h Macros

Type of PiaException thrown if noncovered pension entitlement date entry is invalid.

C++
#define PIA_IDS_NONPENDATE3 62125
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NONPENDATEOUT Macro

PIA_IDS_NONPENDATEOUT Macro
Resource.h Macros

String ID for printing noncovered pension entitlement date.

C++
#define PIA_IDS_NONPENDATEOUT 62126
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NONPENOUT Macro

PIA_IDS_NONPENOUT Macro
Resource.h Macros

String ID for printing noncovered pension.

C++
#define PIA_IDS_NONPENOUT 61389
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NRA1OUT Macro

PIA_IDS_NRA1OUT Macro
Resource.h Macros

String ID for printing early retirement age.

C++
#define PIA_IDS_NRA1OUT 61373
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NRAOUT Macro

PIA_IDS_NRAOUT Macro
Resource.h Macros

String ID for printing full retirement age.

C++
#define PIA_IDS_NRAOUT 61372
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NRAWIDOUT Macro

PIA_IDS_NRAWIDOUT Macro
Resource.h Macros

String ID for printing widow(er)'s full retirement age.

C++
#define PIA_IDS_NRAWIDOUT 61378
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NRAWIFEOUT Macro

PIA_IDS_NRAWIFEOUT Macro
Resource.h Macros

String ID for printing full retirement age of aged wife/husband.

C++
#define PIA_IDS_NRAWIFEOUT 62089
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_NTOTALOUT Macro

PIA_IDS_NTOTALOUT Macro
Resource.h Macros

String ID for printing not insured for totalization benefits.

C++
#define PIA_IDS_NTOTALOUT 61419
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_OABBENOUT Macro

PIA_IDS_OABBENOUT Macro
Resource.h Macros

String ID for printing OAB date of benefit.

C++
#define PIA_IDS_OABBENOUT 61371
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_OABENTOUT Macro

PIA_IDS_OABENTOUT Macro
Resource.h Macros

String ID for printing OAB date of entitlement.

C++
#define PIA_IDS_OABENTOUT 61370
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_OLDSTART1 Macro

PIA_IDS_OLDSTART1 Macro
Resource.h Macros

Type of PiaException thrown if date of entitlement is out of range in OldStart::calculate.

C++
#define PIA_IDS_OLDSTART1 62099
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_OLDSTART2 Macro

PIA_IDS_OLDSTART2 Macro
Resource.h Macros

Type of PiaException thrown if old start method number is out of range.

C++
#define PIA_IDS_OLDSTART2 62100
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ONEPAGE Macro

PIA_IDS_ONEPAGE Macro
Resource.h Macros

Type of PiaException thrown if error in OnePage::prepareStrings.

C++
#define PIA_IDS_ONEPAGE 62062
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ONSET1 Macro

PIA_IDS_ONSET1 Macro
Resource.h Macros

Type of PiaException thrown if month of onset is out of range.

C++
#define PIA_IDS_ONSET1 61238
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ONSET10 Macro

PIA_IDS_ONSET10 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_ONSET10 61339
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ONSET11 Macro

PIA_IDS_ONSET11 Macro
Resource.h Macros

Type of PiaException thrown if disability onset is after full retirement age.

C++
#define PIA_IDS_ONSET11 61358
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ONSET2 Macro

PIA_IDS_ONSET2 Macro
Resource.h Macros

Type of PiaException thrown if day of onset is out of range.

C++
#define PIA_IDS_ONSET2 61239
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ONSET2OUT Macro

PIA_IDS_ONSET2OUT Macro
Resource.h Macros

String ID for printing second prior date of onset.

C++
#define PIA_IDS_ONSET2OUT 61400
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ONSET3 Macro

PIA_IDS_ONSET3 Macro
Resource.h Macros

Type of PiaException thrown if year of onset is before 1937.

C++
#define PIA_IDS_ONSET3 61241
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ONSET4 Macro

PIA_IDS_ONSET4 Macro
Resource.h Macros

Type of PiaException thrown if year of onset is after maximum allowed.

C++
#define PIA_IDS_ONSET4 61240
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ONSET5 Macro

PIA_IDS_ONSET5 Macro
Resource.h Macros

Type of PiaException thrown if disability is before birth.

C++
#define PIA_IDS_ONSET5 61256
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ONSET6 Macro

PIA_IDS_ONSET6 Macro
Resource.h Macros

Type of PiaException thrown if disability is after entitlement.

C++
#define PIA_IDS_ONSET6 61255
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ONSET7 Macro

PIA_IDS_ONSET7 Macro
Resource.h Macros

Type of PiaException thrown if death of worker is before disability onset in a survivor case.

C++
#define PIA_IDS_ONSET7 61257
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ONSET8 Macro

PIA_IDS_ONSET8 Macro
Resource.h Macros

Type of PiaException thrown if prior disability is after current disability.

C++
#define PIA_IDS_ONSET8 61261
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ONSET9 Macro

PIA_IDS_ONSET9 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_ONSET9 61338
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ONSETOUT Macro

PIA_IDS_ONSETOUT Macro
Resource.h Macros

String ID for printing date of onset.

C++
#define PIA_IDS_ONSETOUT 61379
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_OPENERR Macro

PIA_IDS_OPENERR Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_OPENERR 61428
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_OSRANGE1 Macro

PIA_IDS_OSRANGE1 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_OSRANGE1 62002
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_OSRANGE2 Macro

PIA_IDS_OSRANGE2 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_OSRANGE2 62003
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_OSSTRING Macro

PIA_IDS_OSSTRING Macro
Resource.h Macros

Type of PiaException thrown if error in OldStart1Page::prepareStrings.

C++
#define PIA_IDS_OSSTRING 62068
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_OUTFILE Macro

PIA_IDS_OUTFILE Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_OUTFILE 61365
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PEBESMONTH Macro

PIA_IDS_PEBESMONTH Macro
Resource.h Macros

Type of PiaException thrown if month of Statement processing is out of range.

C++
#define PIA_IDS_PEBESMONTH 61205
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PEBSASM Macro

PIA_IDS_PEBSASM Macro
Resource.h Macros

Type of PiaException thrown if benefit increase indicator or average wage increase indicator is out of range in Statement case.

C++
#define PIA_IDS_PEBSASM 61282
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PERCBACK Macro

PIA_IDS_PERCBACK Macro
Resource.h Macros

Type of PiaException thrown if backward projection percentage is out of range.

C++
#define PIA_IDS_PERCBACK 61228
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PERCFWRD Macro

PIA_IDS_PERCFWRD Macro
Resource.h Macros

Type of PiaException thrown if forward projection percentage is out of range.

C++
#define PIA_IDS_PERCFWRD 61230
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PIACALPLRGE Macro

PIA_IDS_PIACALPLRGE Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_PIACALPLRGE 62001
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PIACALRANGE Macro

PIA_IDS_PIACALRANGE Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_PIACALRANGE 62000
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PIALOUT Macro

PIA_IDS_PIALOUT Macro
Resource.h Macros

String ID for printing PIA at eligibility.

C++
#define PIA_IDS_PIALOUT 61409
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PIAOUT Macro

PIA_IDS_PIAOUT Macro
Resource.h Macros

String ID for printing PIA.

C++
#define PIA_IDS_PIAOUT 61383
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PIATABLE1 Macro

PIA_IDS_PIATABLE1 Macro
Resource.h Macros

Type of PiaException thrown if year of entitlement is out of range in PiaTable::calculate.

C++
#define PIA_IDS_PIATABLE1 62101
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PIATABLE2 Macro

PIA_IDS_PIATABLE2 Macro
Resource.h Macros

Type of PiaException thrown if year of benefit is out of range in PiaTable::calculate.

C++
#define PIA_IDS_PIATABLE2 62102
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PIB50MFB Macro

PIA_IDS_PIB50MFB Macro
Resource.h Macros

Type of PiaException thrown if index is out of range in Pib50Mfb::getAt.

C++
#define PIA_IDS_PIB50MFB 62024
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PIB50PIB Macro

PIA_IDS_PIB50PIB Macro
Resource.h Macros

Type of PiaException thrown if index is out of range in Pib50Pib::getAt.

C++
#define PIA_IDS_PIB50PIB 62025
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PIB52MFB Macro

PIA_IDS_PIB52MFB Macro
Resource.h Macros

Type of PiaException thrown if index is out of range in Pib52Mfb::getAt.

C++
#define PIA_IDS_PIB52MFB 62026
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PIB54MFB Macro

PIA_IDS_PIB54MFB Macro
Resource.h Macros

Type of PiaException thrown if index is out of range in Pib54Mfb::getAt.

C++
#define PIA_IDS_PIB54MFB 62027
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PIB54PIA Macro

PIA_IDS_PIB54PIA Macro
Resource.h Macros

Type of PiaException thrown if index is out of range in Pib54Pia::getAt.

C++
#define PIA_IDS_PIB54PIA 62028
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PIB58AME Macro

PIA_IDS_PIB58AME Macro
Resource.h Macros

Type of PiaException thrown if index is out of range in Pib58Ame::getAt.

C++
#define PIA_IDS_PIB58AME 62029
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PIB58PIB Macro

PIA_IDS_PIB58PIB Macro
Resource.h Macros

Type of PiaException thrown if index is out of range in Pib58Pib::getAt.

C++
#define PIA_IDS_PIB58PIB 62030
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PIBTABLE1 Macro

PIA_IDS_PIBTABLE1 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_PIBTABLE1 61360
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PIBTABLE2 Macro

PIA_IDS_PIBTABLE2 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_PIBTABLE2 61361
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PONSETOUT Macro

PIA_IDS_PONSETOUT Macro
Resource.h Macros

String ID for printing second prior date of onset in nondisability case.

C++
#define PIA_IDS_PONSETOUT 61403
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PRCESSOUT Macro

PIA_IDS_PRCESSOUT Macro
Resource.h Macros

String ID for printing prior date of cessation.

C++
#define PIA_IDS_PRCESSOUT 61381
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PRENTOUT Macro

PIA_IDS_PRENTOUT Macro
Resource.h Macros

String ID for printing date of prior entitlement in nondisability case.

C++
#define PIA_IDS_PRENTOUT 61399
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PRIOROUT Macro

PIA_IDS_PRIOROUT Macro
Resource.h Macros

String ID for printing prior date of entitlement in disability case.

C++
#define PIA_IDS_PRIOROUT 61380
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PROBASOUT Macro

PIA_IDS_PROBASOUT Macro
Resource.h Macros

String ID for printing projected wage base type.

C++
#define PIA_IDS_PROBASOUT 61391
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PROJBACK1 Macro

PIA_IDS_PROJBACK1 Macro
Resource.h Macros

Type of PiaException thrown if backward projection indicator is out of range in general case (0-2).

C++
#define PIA_IDS_PROJBACK1 61222
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PROJBACK2 Macro

PIA_IDS_PROJBACK2 Macro
Resource.h Macros

Type of PiaException thrown if backward projection indicator is out of range in backward projection case (1-2).

C++
#define PIA_IDS_PROJBACK2 61227
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PROJFWRD1 Macro

PIA_IDS_PROJFWRD1 Macro
Resource.h Macros

Type of PiaException thrown if forward projection indicator is out of range in general case (0-2).

C++
#define PIA_IDS_PROJFWRD1 61224
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PROJFWRD2 Macro

PIA_IDS_PROJFWRD2 Macro
Resource.h Macros

Type of PiaException thrown if forward projection indicator is out of range in forward projection case (1-2).

C++
#define PIA_IDS_PROJFWRD2 61229
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PRRENT1 Macro

PIA_IDS_PRRENT1 Macro
Resource.h Macros

Type of PiaException thrown if month of prior entitlement is out of range.

C++
#define PIA_IDS_PRRENT1 61249
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PRRENT2 Macro

PIA_IDS_PRRENT2 Macro
Resource.h Macros

Type of PiaException thrown if year of prior entitlement is before 1940.

C++
#define PIA_IDS_PRRENT2 61250
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PRRENT3 Macro

PIA_IDS_PRRENT3 Macro
Resource.h Macros

Type of PiaException thrown if year of prior entitlement is after maximum allowed.

C++
#define PIA_IDS_PRRENT3 61251
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PRRENT4 Macro

PIA_IDS_PRRENT4 Macro
Resource.h Macros

Type of PiaException thrown if prior entitlement is not before current entitlement.

C++
#define PIA_IDS_PRRENT4 61280
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PRRENT5 Macro

PIA_IDS_PRRENT5 Macro
Resource.h Macros

Type of PiaException thrown if prior entitlement to disability is before disability onset.

C++
#define PIA_IDS_PRRENT5 61279
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PRRENT6 Macro

PIA_IDS_PRRENT6 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_PRRENT6 61343
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PRRENT7 Macro

PIA_IDS_PRRENT7 Macro
Resource.h Macros

Type of PiaException thrown if prior entitlement to disability is after full retirement age.

C++
#define PIA_IDS_PRRENT7 61359
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PTSTRING Macro

PIA_IDS_PTSTRING Macro
Resource.h Macros

Type of PiaException thrown if error in PiaTable1Page::prepareStrings.

C++
#define PIA_IDS_PTSTRING 62069
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_PUBPEN Macro

PIA_IDS_PUBPEN Macro
Resource.h Macros

Type of PiaException thrown if public pension amount is out of range.

C++
#define PIA_IDS_PUBPEN 61283
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QC Macro

PIA_IDS_QC Macro
Resource.h Macros

Type of PiaException thrown if number of quarters of coverage, 1951-77, is greater than number of quarters of coverage, 1937-77.

C++
#define PIA_IDS_QC 61287
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QC51TD Macro

PIA_IDS_QC51TD Macro
Resource.h Macros

Type of PiaException thrown if number of quarters of coverage, 1951-77, is out of range.

C++
#define PIA_IDS_QC51TD 61285
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QCAMT Macro

PIA_IDS_QCAMT Macro
Resource.h Macros

Type of PiaException thrown if average wages have not been set in Qcamt::project.

C++
#define PIA_IDS_QCAMT 62111
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QCANN Macro

PIA_IDS_QCANN Macro
Resource.h Macros

Type of PiaException thrown if number of annual quarters of coverage is out of range.

C++
#define PIA_IDS_QCANN 61286
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QCARRAY1 Macro

PIA_IDS_QCARRAY1 Macro
Resource.h Macros

Type of PiaException thrown if year is out of range in QcArray functions.

C++
#define PIA_IDS_QCARRAY1 62010
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QCARRAY2 Macro

PIA_IDS_QCARRAY2 Macro
Resource.h Macros

(Currently unused).

C++
#define PIA_IDS_QCARRAY2 62011
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QCARRAY3 Macro

PIA_IDS_QCARRAY3 Macro
Resource.h Macros

Type of PiaException thrown if years are out of range in QcArray::accumulate.

C++
#define PIA_IDS_QCARRAY3 62012
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QCARRAY4 Macro

PIA_IDS_QCARRAY4 Macro
Resource.h Macros

Type of PiaException thrown if quarters are out of range in QcArray::accumulate.

C++
#define PIA_IDS_QCARRAY4 62013
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QCCAL Macro

PIA_IDS_QCCAL Macro
Resource.h Macros

Type of PiaException thrown if quarter of coverage amount has not been set in PiaData::qcCal.

C++
#define PIA_IDS_QCCAL 62107
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QCDISCAL Macro

PIA_IDS_QCDISCAL Macro
Resource.h Macros

Type of PiaException thrown if any starting or ending dates are out of range in PiaData::qcDisCal.

C++
#define PIA_IDS_QCDISCAL 62093
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QCLUMPYEAR Macro

PIA_IDS_QCLUMPYEAR Macro
Resource.h Macros

Type of PiaException thrown if qclumpyear is out of range.

C++
#define PIA_IDS_QCLUMPYEAR 62113
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QCPACKED1 Macro

PIA_IDS_QCPACKED1 Macro
Resource.h Macros

Type of PiaException thrown if index is out of range in QcPacked::get.

C++
#define PIA_IDS_QCPACKED1 62114
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QCPACKED2 Macro

PIA_IDS_QCPACKED2 Macro
Resource.h Macros

Type of PiaException thrown if index is out of range in QcPacked::set.

C++
#define PIA_IDS_QCPACKED2 62115
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QCTD Macro

PIA_IDS_QCTD Macro
Resource.h Macros

Type of PiaException thrown if number of quarters of coverage, 1937-77, is out of range.

C++
#define PIA_IDS_QCTD 61284
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QCTOT0 Macro

PIA_IDS_QCTOT0 Macro
Resource.h Macros

Type of PiaException thrown if no quarters of coverage in a totalization case.

C++
#define PIA_IDS_QCTOT0 61437
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QTRYRQTR Macro

PIA_IDS_QTRYRQTR Macro
Resource.h Macros

Type of PiaException thrown if number of quarters in a QtrYear is greater than 3.

C++
#define PIA_IDS_QTRYRQTR 62005
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_QTRYRYR Macro

PIA_IDS_QTRYRYR Macro
Resource.h Macros

Type of PiaException thrown if year in a QtrYear is greater than LASTYEARLR.

C++
#define PIA_IDS_QTRYRYR 62006
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_READEOF Macro

PIA_IDS_READEOF Macro
Resource.h Macros

Return value from PiaRead::read if successful read, with end of file following.

C++
#define PIA_IDS_READEOF 61366
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_READERR Macro

PIA_IDS_READERR Macro
Resource.h Macros

Type of PiaException thrown if unable to read a pia file.

C++
#define PIA_IDS_READERR 61313
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_READMORE Macro

PIA_IDS_READMORE Macro
Resource.h Macros

Return value from PiaRead::read if successful read, with additional data following.

C++
#define PIA_IDS_READMORE 61367
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_RELERNOUT Macro

PIA_IDS_RELERNOUT Macro
Resource.h Macros

String ID for printing relative earnings level.

C++
#define PIA_IDS_RELERNOUT 61390
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_RELERNPOS Macro

PIA_IDS_RELERNPOS Macro
Resource.h Macros

Type of PiaException thrown if first year is out of range in PiaCal::relEarnPositionCal.

C++
#define PIA_IDS_RELERNPOS 62050
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_REQQCOUT Macro

PIA_IDS_REQQCOUT Macro
Resource.h Macros

String ID for printing required quarters of coverage.

C++
#define PIA_IDS_REQQCOUT 61392
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_REVIEWBI Macro

PIA_IDS_REVIEWBI Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_REVIEWBI 61438
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_ROUND Macro

PIA_IDS_ROUND Macro
Resource.h Macros

Type of PiaException thrown if year is before 1937 in BenefitAmount functions.

C++
#define PIA_IDS_ROUND 62033
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_RTGENRL Macro

PIA_IDS_RTGENRL Macro
Resource.h Macros

Type of PiaException thrown if denominator is out of range in RtGeneral::project1.

C++
#define PIA_IDS_RTGENRL 62004
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_RWSTRING Macro

PIA_IDS_RWSTRING Macro
Resource.h Macros

Type of PiaException thrown if error in ReindWid1Page::prepareStrings.

C++
#define PIA_IDS_RWSTRING 62073
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_SECONDARY Macro

PIA_IDS_SECONDARY Macro
Resource.h Macros

Type of PiaException thrown if type of bic is not set in Secondary::check.

C++
#define PIA_IDS_SECONDARY 62091
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_SETNOCH Macro

PIA_IDS_SETNOCH Macro
Resource.h Macros

Type of PiaException thrown if year is out of range in PiaParams::setNoChange.

C++
#define PIA_IDS_SETNOCH 62034
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_SEX Macro

PIA_IDS_SEX Macro
Resource.h Macros

Type of PiaException thrown if sex is not Sex::sex_type::MALE or Sex::sex_type::FEMALE.

C++
#define PIA_IDS_SEX 61215
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_SEXOUT Macro

PIA_IDS_SEXOUT Macro
Resource.h Macros

String ID for printing sex of worker.

C++
#define PIA_IDS_SEXOUT 61368
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_SGAPROJ Macro

PIA_IDS_SGAPROJ Macro
Resource.h Macros

Type of PiaException thrown if annual Sga project function is called.

C++
#define PIA_IDS_SGAPROJ 62122
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_SMSTRING Macro

PIA_IDS_SMSTRING Macro
Resource.h Macros

Type of PiaException thrown if error in SpecMin1Page::prepareStrings.

C++
#define PIA_IDS_SMSTRING 62072
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_SPPIA1OUT Macro

PIA_IDS_SPPIA1OUT Macro
Resource.h Macros

String ID for printing special minimum PIA, support PIA unused.

C++
#define PIA_IDS_SPPIA1OUT 61425
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_SPPIA2OUT Macro

PIA_IDS_SPPIA2OUT Macro
Resource.h Macros

String ID for printing special minimum PIA, support PIA used.

C++
#define PIA_IDS_SPPIA2OUT 61426
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_SPYRS2OUT Macro

PIA_IDS_SPYRS2OUT Macro
Resource.h Macros

String ID for printing total special minimum years of coverage.

C++
#define PIA_IDS_SPYRS2OUT 61402
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_SPYRSOUT Macro

PIA_IDS_SPYRSOUT Macro
Resource.h Macros

String ID for printing total special minimum years of coverage.

C++
#define PIA_IDS_SPYRSOUT 61408
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_SSN1 Macro

PIA_IDS_SSN1 Macro
Resource.h Macros

Type of PiaException thrown if number of characters in a string used to construct an Ssn is less than 9.

C++
#define PIA_IDS_SSN1 62092
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_SSNOUT Macro

PIA_IDS_SSNOUT Macro
Resource.h Macros

String ID for printing worker's Social Security number.

C++
#define PIA_IDS_SSNOUT 61388
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_START1 Macro

PIA_IDS_START1 Macro
Resource.h Macros

Type of PiaException thrown if starting year of assumptions is before 1979.

C++
#define PIA_IDS_START1 61242
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_START2 Macro

PIA_IDS_START2 Macro
Resource.h Macros

Type of PiaException thrown if starting year of assumptions is after maximum year allowed.

C++
#define PIA_IDS_START2 61243
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_SUPPIAOUT Macro

PIA_IDS_SUPPIAOUT Macro
Resource.h Macros

String ID for printing support PIA.

C++
#define PIA_IDS_SUPPIAOUT 61417
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_SURVBENOUT Macro

PIA_IDS_SURVBENOUT Macro
Resource.h Macros

String ID for printing secondary date of benefit.

C++
#define PIA_IDS_SURVBENOUT 61376
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_SURVENTOUT Macro

PIA_IDS_SURVENTOUT Macro
Resource.h Macros

String ID for printing secondary date of entitlement.

C++
#define PIA_IDS_SURVENTOUT 61375
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_TAXTYPE Macro

PIA_IDS_TAXTYPE Macro
Resource.h Macros

Type of PiaException thrown if type of taxes is out of range.

C++
#define PIA_IDS_TAXTYPE 61330
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_TAXTYPEYR Macro

PIA_IDS_TAXTYPEYR Macro
Resource.h Macros

Type of PiaException thrown if year is out of range in WorkerData::setTaxType.

C++
#define PIA_IDS_TAXTYPEYR 62038
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_TGSTRING Macro

PIA_IDS_TGSTRING Macro
Resource.h Macros

Type of PiaException thrown if error in TransGuar1Page::prepareStrings.

C++
#define PIA_IDS_TGSTRING 62071
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_TITLEPRO1 Macro

PIA_IDS_TITLEPRO1 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_TITLEPRO1 61347
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_TITLEPRO2 Macro

PIA_IDS_TITLEPRO2 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_TITLEPRO2 61348
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_TITLEPRO3 Macro

PIA_IDS_TITLEPRO3 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_TITLEPRO3 61349
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_TITLEPRO4 Macro

PIA_IDS_TITLEPRO4 Macro
Resource.h Macros

(Currently unused).

C++
#define PIA_IDS_TITLEPRO4 62049
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_TWOPAGE1 Macro

PIA_IDS_TWOPAGE1 Macro
Resource.h Macros

Type of PiaException thrown if error in InsuredPage::prepareStrings.

C++
#define PIA_IDS_TWOPAGE1 62063
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_TWOPAGE2 Macro

PIA_IDS_TWOPAGE2 Macro
Resource.h Macros

Type of PiaException thrown if error in EarningsPage::prepareStrings.

C++
#define PIA_IDS_TWOPAGE2 62064
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_TWOPAGE3 Macro

PIA_IDS_TWOPAGE3 Macro
Resource.h Macros

Type of PiaException thrown if error in Summary1Page::prepareStrings.

C++
#define PIA_IDS_TWOPAGE3 62065
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_TWOPAGE4 Macro

PIA_IDS_TWOPAGE4 Macro
Resource.h Macros

Type of PiaException thrown if error in Summary2Page::prepareStrings.

C++
#define PIA_IDS_TWOPAGE4 62066
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_TWOPAGE5 Macro

PIA_IDS_TWOPAGE5 Macro
Resource.h Macros

Type of PiaException thrown if error in Summary3Page::prepareStrings.

C++
#define PIA_IDS_TWOPAGE5 62067
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_TXSTRING Macro

PIA_IDS_TXSTRING Macro
Resource.h Macros

Type of PiaException thrown if error in TaxesPage::prepareStrings.

C++
#define PIA_IDS_TXSTRING 62075
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_UNBICCHP Macro

PIA_IDS_UNBICCHP Macro
Resource.h Macros

Type of PiaException thrown if either year is out of range in PiaParams::unbiCatchUp.

C++
#define PIA_IDS_UNBICCHP 62036
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_UNEARNOUT Macro

PIA_IDS_UNEARNOUT Macro
Resource.h Macros

String ID for printing unused earnings message.

C++
#define PIA_IDS_UNEARNOUT 61422
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_UPDATEAW Macro

PIA_IDS_UPDATEAW Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_UPDATEAW 61434
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_UPDATEBI Macro

PIA_IDS_UPDATEBI Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_UPDATEBI 61433
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_UPDATEFQ Macro

PIA_IDS_UPDATEFQ Macro
Resource.h Macros

Type of PiaException thrown if average wage is zero in PiaParams::updateFq.

C++
#define PIA_IDS_UPDATEFQ 62035
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_UPDATEWB Macro

PIA_IDS_UPDATEWB Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_UPDATEWB 61435
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_UPDATEWBOLD Macro

PIA_IDS_UPDATEWBOLD Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_UPDATEWBOLD 61436
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_VALDI1 Macro

PIA_IDS_VALDI1 Macro
Resource.h Macros

Type of PiaException thrown if number of periods of disability is not 0, 1, or 2 in a nondisability case.

C++
#define PIA_IDS_VALDI1 61220
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_VALDI2 Macro

PIA_IDS_VALDI2 Macro
Resource.h Macros

Type of PiaException thrown if number of periods of disability is not 1 or 2 in a disability case.

C++
#define PIA_IDS_VALDI2 61221
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_WAGEBASE Macro

PIA_IDS_WAGEBASE Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_WAGEBASE 61439
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_WAITPD1 Macro

PIA_IDS_WAITPD1 Macro
Resource.h Macros

Type of PiaException thrown if first month of waiting period is out of range.

C++
#define PIA_IDS_WAITPD1 61270
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_WAITPD2 Macro

PIA_IDS_WAITPD2 Macro
Resource.h Macros

Type of PiaException thrown if year of first month of waiting period is before 1940.

C++
#define PIA_IDS_WAITPD2 61271
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_WAITPD3 Macro

PIA_IDS_WAITPD3 Macro
Resource.h Macros

Type of PiaException thrown if year of first month of waiting period is after maximum allowed.

C++
#define PIA_IDS_WAITPD3 61272
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_WAITPD4 Macro

PIA_IDS_WAITPD4 Macro
Resource.h Macros

Type of PiaException thrown if waiting period starts before onset.

C++
#define PIA_IDS_WAITPD4 61277
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_WAITPD5 Macro

PIA_IDS_WAITPD5 Macro
Resource.h Macros

Type of PiaException thrown if entitlement is before waiting period.

C++
#define PIA_IDS_WAITPD5 61278
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_WAITPD6 Macro

PIA_IDS_WAITPD6 Macro
Resource.h Macros

Type of PiaException thrown if cessation is before waiting period.

C++
#define PIA_IDS_WAITPD6 61281
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_WAITPD7 Macro

PIA_IDS_WAITPD7 Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_WAITPD7 61346
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_WIDDIBOUT Macro

PIA_IDS_WIDDIBOUT Macro
Resource.h Macros

String ID for printing date of onset of widow(er).

C++
#define PIA_IDS_WIDDIBOUT 61405
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_WISTRING Macro

PIA_IDS_WISTRING Macro
Resource.h Macros

Type of PiaException thrown if error in WageInd1Page::prepareStrings.

C++
#define PIA_IDS_WISTRING 62070
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_WRITEEARN Macro

PIA_IDS_WRITEEARN Macro
Resource.h Macros

Type of PiaException thrown if first year of earnings is out of range in PiaWrite::writeEarnOasdi or PiaWriteAny::writeEarnOasdi.

C++
#define PIA_IDS_WRITEEARN 62110
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


PIA_IDS_YEAR Macro

PIA_IDS_YEAR Macro
Resource.h Macros

(Currently unused.)

C++
#define PIA_IDS_YEAR 61317
Collapse Expand File

File: Resource.h

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
Resource.h, Macros


_AFXDLL Macro

_AFXDLL Macro
OutDC.cpp Macros

Use the AFXDLL library, which contains MFC in a DLL.

C++
#define _AFXDLL
Collapse Expand File

File: OutDC.cpp

Module: Misc Library

Collapse Expand Group

Macros

Collapse Expand Links
OutDC.cpp, Macros


Files

Files
Files Misc Library

The following table lists files in this documentation.

Collapse Expand Files
Name | Description
AnnualArrays.cpp | Functions for the AnnualArrays class of static functions using annual arrays.
AnnualArrays.h | Declarations for the AnnualArrays class of static functions using annual arrays.
BitAnnual.cpp | Functions for the BitAnnual class to manage an array of annual bits.
BitAnnual.h | Declarations for the BitAnnual class to manage an array of annual bits.
BitAnnualBase.cpp | Functions for the BitAnnual class to manage an array of annual bits for Windows.
BitAnnualBase.h | Declarations for the BitAnnual class to manage an array of annual bits for Windows.
BitAnnualInlines.h | Inline functions for the BitAnnual class to manage an array of annual bits for Windows.
CommaBase.h | Definitions used by the pcomma function on a Windows machine.
DateFormatter.cpp | Functions for the DateFormatter class to format and parse dates.
DateFormatter.h | Declarations for the DateFormatter class to format and parse dates.
DoubleAnnualRW.cpp | Functions for the DoubleAnnualRead and DoubleAnnualWrite classes to read or write an array of annual doubles.
DoubleAnnualRW.h | Declarations for the DoubleAnnualRead and DoubleAnnualWrite classes to read or write an array of annual doubles.
FormatString.cpp | Functions to mimic AfxFormatString using Standard C++ Library strings.
FormatString.h | Declarations of functions to mimic AfxFormatString using Standard C++ Library strings.
NumPunct.cpp | Data for the PunctFacet structure to handle numeric punctuation.
NumPunct.h | Declarations for the PunctFacet structure to handle numeric punctuation.
OutDC.cpp | Functions needed for the OutDC80 class to write to a device context (DC).
OutDC.h | Declarations needed for the OutDC80 class to write to a device context (DC).
OutFile132.cpp | Functions for the OutFile132 class to manage print output to a file with 132-column lines.
OutFile132.h | Declarations for the OutFile132 class to manage print output to a file with 132-column lines.
OutFile80.cpp | Functions needed for the OutFile80 class to manage print output to a file with 80-column lines.
OutFile80.h | Declarations for the OutFile80 class to manage print output to a file with 80-column lines.
OutfileHTML.cpp | Functions for the OutFileHTML class to manage print output to an html file.
OutfileHTML.h | Declarations for the OutFileHTML class to manage print output to an html file.
PageOut.cpp | Functions for the PageOut class - parent of classes to manage a page of printed output.
PageOut.h | Declarations for the PageOut class - parent of classes to manage a page of printed output.
Path.cpp | Functions for the Path class that provides operations on string instances that contain file or directory path information.
Path.h | Declarations for the Path class that provides operations on string instances that contain file or directory path information.
PiaException.cpp | Functions for the PiaException class to manage an exception in the piadata library.
PiaException.h | Declarations for the PiaException class to manage an exception in the piadata library.
Resource.h | String IDS used in oactobjs library.
Sex.cpp | Functions for the Sex class holding a sex indicator.
Sex.h | Declarations needed for the Sex class holding a sex indicator.
StringParser.cpp | Function definitions to parse a string.
StringParser.h | Declarations of functions to parse a string.
TextWriterTraceListener.cpp | Functions for the TextWriterTraceListener class that listens for Trace output and writes to an ostream.
TextWriterTraceListener.h | Declarations for the TextWriterTraceListener class that listens for Trace output and writes to an ostream.
Trace.cpp | Functions for the Trace class to trace execution of code.
Trace.h | Declarations for the Trace class to trace execution of code.
TraceListener.cpp | Functions for the TraceListener class - parent of classes that listen for Trace output.
TraceListener.h | Declarations for the TraceListener class - parent of classes that listen for Trace output.
age.cpp | Functions for Age class to manage age in years and months.
age.h | Declarations for Age class to manage age in years and months.
comma.cpp | Functions that return strings with (or without) embedded commas in any type of number (floating or integral).
comma.h | Declarations of functions that return strings with (or without) embedded commas in any type of number (floating or integral).
date.cpp | Functions for the static Date class to manage date and time.
date.h | Declarations for the static Date class to manage date and time.
datemoyr.cpp | Functions needed for the DateMoyr class to handle date as month and year.
datemoyr.h | Declarations needed for DateMoyr class to manage date as month and year.
dbleann.cpp | Functions needed for DoubleAnnual class to manage an array of annual doubles.
dbleann.h | Declarations needed for DoubleAnnual class to manage an array of annual doubles.
dblemth.cpp | Functions for the DoubleMonth class to manage an array of monthly doubles.
dblemth.h | Declarations for the DoubleMonth class to manage an array of monthly doubles.
dbleqtr.cpp | Functions for the DoubleQuarter class to manage an array of quarterly doubles.
dbleqtr.h | Declarations for the DoubleQuarter class to manage an array of quarterly doubles.
document.cpp | Functions for the Document class to manage a generic document.
document.h | Declarations for the Document class to manage a generic document.
floatann.cpp | Functions for the FloatAnnual class to manage an array of annual floats.
floatann.h | Declarations for the FloatAnnual class to manage an array of annual floats.
floatmth.cpp | Functions for the FloatMonth class to manage an array of monthly floats.
floatmth.h | Declarations for the FloatMonth class to manage an array of monthly floats.
floatqtr.cpp | Functions for the FloatQuarter class to manage an array of quarterly floats.
floatqtr.h | Declarations for the FloatQuarter class to manage an array of quarterly floats.
genfile.cpp | Functions for the Genfile class to manage a general file.
genfile.h | Declarations for the Genfile class to manage a general file.
intann.cpp | Functions for the IntAnnual class to manage an array of annual integers.
intann.h | Declarations for the IntAnnual class to manage an array of annual integers.
outfile.cpp | Functions for the Outfile, Out132, and Out80 classes - parents of classes to manage output file with page counters.
outfile.h | Declarations for the Outfile, Out132, and Out80 classes - parents of classes to manage output file with page counters.
page.cpp | Functions for the PageCounters class to manage page counters.
page.h | Declarations for the PageCounters class to manage page counters.
qtryear.cpp | Functions for the QtrYear class to handle a year and quarter.
qtryear.h | Declarations for the QtrYear class to handle a year and quarter.
ssn.cpp | Functions for the Ssn class to manage a Social Security number.
ssn.h | Declarations for the Ssn class to manage a Social Security number.
Collapse Expand Module

Misc Library

Collapse Expand Links
Files, Misc Library


AnnualArrays.cpp

AnnualArrays.cpp
Files

Functions for the AnnualArrays class of static functions using annual arrays.

Collapse Expand Group

Files

Collapse Expand Links
Files


AnnualArrays.h

AnnualArrays.h
Classes Files Legend

Declarations for the AnnualArrays class of static functions using annual arrays.

Collapse Expand Classes
Name | Description
AnnualArrays | Functions using annual arrays.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


BitAnnual.cpp

BitAnnual.cpp
Files

Functions for the BitAnnual class to manage an array of annual bits.

Collapse Expand Group

Files

Collapse Expand Links
Files


BitAnnual.h

BitAnnual.h
Classes Files Legend

Declarations for the BitAnnual class to manage an array of annual bits.

Collapse Expand Classes
Name | Description
BitAnnual | Manages an array of annual bits.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


BitAnnualBase.cpp

BitAnnualBase.cpp
Files

Functions for the BitAnnual class to manage an array of annual bits for Windows.

Collapse Expand Group

Files

Collapse Expand Links
Files


BitAnnualBase.h

BitAnnualBase.h
Files Types Variables

Declarations for the BitAnnual class to manage an array of annual bits for Windows.

Collapse Expand Group

Files

Collapse Expand Types
Name | Description
BitAnnualData | Bit array used in BitAnnual (a std::bitset).
Collapse Expand Variables
Name | Description
MAX_BITSET_SIZE | Size to use for bit array in BitAnnual (from 1937 to 2200).
Collapse Expand Links
Files, Types, Variables


BitAnnualInlines.h

BitAnnualInlines.h
Files

Inline functions for the BitAnnual class to manage an array of annual bits for Windows.

Collapse Expand Group

Files

Collapse Expand Links
Files


CommaBase.h

CommaBase.h
Files Macros

Definitions used by the pcomma function on a Windows machine.

Collapse Expand Group

Files

Collapse Expand Macros
Name | Description
ENDS | No special character for end of ostringstream.
FREEZE | No special function to freeze the string.
OSTREAM | Use ostringstream for formatting output.
Collapse Expand Links
Files, Macros


DateFormatter.cpp

DateFormatter.cpp
Files

Functions for the DateFormatter class to format and parse dates.

Collapse Expand Group

Files

Collapse Expand Links
Files


DateFormatter.h

DateFormatter.h
Classes Files Legend

Declarations for the DateFormatter class to format and parse dates.

Collapse Expand Classes
Name | Description
DateFormatter | Manages static functions to format and parse dates.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


DoubleAnnualRW.cpp

DoubleAnnualRW.cpp
Files

Functions for the DoubleAnnualRead and DoubleAnnualWrite classes to read or write an array of annual doubles.

Collapse Expand Group

Files

Collapse Expand Links
Files


DoubleAnnualRW.h

DoubleAnnualRW.h
Classes Files Legend

Declarations for the DoubleAnnualRead and DoubleAnnualWrite classes to read or write an array of annual doubles.

Collapse Expand Classes
Name | Description
DoubleAnnualRead | Reads a DoubleAnnual.
DoubleAnnualWrite | Writes a DoubleAnnual.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


FormatString.cpp

FormatString.cpp
Files

Functions to mimic AfxFormatString using Standard C++ Library strings.

Collapse Expand Group

Files

Collapse Expand Links
Files


FormatString.h

FormatString.h
Functions Files Legend

Declarations of functions to mimic AfxFormatString using Standard C++ Library strings.

Collapse Expand Functions
Name | Description
AfxFormatString1 | Loads the specified string resource and substitutes for the characters "%1" the string referenced by filler.
AfxFormatString2 | Loads the specified string resource and substitutes for the characters "%1"and "%2" the strings referenced by filler1 and filler2.
Collapse Expand Group

Files

Collapse Expand Links
Functions, Files, Legend


NumPunct.cpp

NumPunct.cpp
Files

Data for the PunctFacet structure to handle numeric punctuation.

Collapse Expand Group

Files

Collapse Expand Links
Files


NumPunct.h

NumPunct.h
Files Legend Structures

Declarations for the PunctFacet structure to handle numeric punctuation.

Collapse Expand Group

Files

Collapse Expand Structures
Name | Description
PunctFacet | Numeric punctuation facet with 3 digits per thousands separator.
Collapse Expand Links
Files, Legend, Structures


OutDC.cpp

OutDC.cpp
Files Macros

Functions needed for the OutDC80 class to write to a device context (DC).

Collapse Expand Group

Files

Collapse Expand Macros
Name | Description
_AFXDLL | Use the AFXDLL library, which contains MFC in a DLL.
Collapse Expand Links
Files, Macros


OutDC.h

OutDC.h
Classes Files Legend

Declarations needed for the OutDC80 class to write to a device context (DC).

Collapse Expand Classes
Name | Description
OutDC80 | Handles output to a Windows window.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


OutFile132.cpp

OutFile132.cpp
Files

Functions for the OutFile132 class to manage print output to a file with 132-column lines.

Collapse Expand Group

Files

Collapse Expand Links
Files


OutFile132.h

OutFile132.h
Classes Files Legend

Declarations for the OutFile132 class to manage print output to a file with 132-column lines.

Collapse Expand Classes
Name | Description
OutFile132 | Manages the print output functions, when printing to a file formatted for 132 columns.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


OutFile80.cpp

OutFile80.cpp
Files

Functions needed for the OutFile80 class to manage print output to a file with 80-column lines.

Collapse Expand Group

Files

Collapse Expand Links
Files


OutFile80.h

OutFile80.h
Classes Files Legend

Declarations for the OutFile80 class to manage print output to a file with 80-column lines.

Collapse Expand Classes
Name | Description
OutFile80 | Manages the print output functions, when printing to a file formatted for 80 columns.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


OutfileHTML.cpp

OutfileHTML.cpp
Files

Functions for the OutFileHTML class to manage print output to an html file.

Collapse Expand Group

Files

Collapse Expand Links
Files


OutfileHTML.h

OutfileHTML.h
Classes Files Legend

Declarations for the OutFileHTML class to manage print output to an html file.

Collapse Expand Classes
Name | Description
OutFileHTML | Manages the print output functions, when printing to an HTML file.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PageOut.cpp

PageOut.cpp
Files

Functions for the PageOut class - parent of classes to manage a page of printed output.

Collapse Expand Group

Files

Collapse Expand Links
Files


PageOut.h

PageOut.h
Classes Files Legend

Declarations for the PageOut class - parent of classes to manage a page of printed output.

Collapse Expand Classes
Name | Description
PageOut | Abstract parent of classes to manage a page of printed output.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


Path.cpp

Path.cpp
Files

Functions for the Path class that provides operations on string instances that contain file or directory path information.

Collapse Expand Group

Files

Collapse Expand Links
Files


Path.h

Path.h
Classes Files Legend

Declarations for the Path class that provides operations on string instances that contain file or directory path information.

Collapse Expand Classes
Name | Description
Path | Provides operations on string instances that contain file or directory path information.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PiaException.cpp

PiaException.cpp
Files

Functions for the PiaException class to manage an exception in the piadata library.

Collapse Expand Group

Files

Collapse Expand Links
Files


PiaException.h

PiaException.h
Classes Files Legend

Declarations for the PiaException class to manage an exception in the piadata library.

Collapse Expand Classes
Name | Description
PiaException | Manages an exception in the piadata library.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


Resource.h

Resource.h
Files Macros

String IDS used in oactobjs library.

Collapse Expand Group

Files

Collapse Expand Macros
Name | Description
PIA_IDS_2YEARS | (Currently unused.)
PIA_IDS_ACTQCOUT | String ID for printing actual quarters of coverage.
PIA_IDS_AGEMONTH | Type of PiaException thrown if number of months in an Age is greater than 11.
PIA_IDS_AGEPLAN | Type of PiaException thrown if planned age of retirement is out of range.
PIA_IDS_AIMEOUT | String ID for printing AIME.
PIA_IDS_AMEOUT | String ID for printing AMW.
PIA_IDS_ANDLATER | (Currently unused.)
PIA_IDS_ANSCCH | Type of PiaException thrown if catch-up increase indicator is out of range.
PIA_IDS_APPCOLA1 | Type of PiaException thrown if year is out of range in PiaParams::applyCola without catch-up.
PIA_IDS_APPCOLA2 | Type of PiaException thrown if year is out of range in PiaParams::applyCola with catch-up.
PIA_IDS_APPCOLA3 | Type of PiaException thrown if year is out of range in PiaParams::applyColaMfb without catch-up.
PIA_IDS_APPCOLA4 | Type of PiaException thrown if year is out of range in PiaParams::applyColaMfb with catch-up.
PIA_IDS_ARDRI1 | Type of PiaException thrown if age is out of range in PiaCal::ardriCal.
PIA_IDS_ARDRI10 | Type of PiaException thrown if aged wife age is before early retirement age in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI2 | Type of PiaException thrown if age is before early retirement age for OAB in PiaCal::ardriCal.
PIA_IDS_ARDRI3 | (Currently unused.)
PIA_IDS_ARDRI4 | Type of PiaException thrown if disabled widow(er) age is before earliest possible age in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI5 | Type of PiaException thrown if disabled widow(er) entitlement is before benefit date in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI6 | Type of PiaException thrown if aged widow(er) age is before earliest possible age in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI7 | Type of PiaException thrown if DIB entitlement before 1957 in PiaCal::ardriCal.
PIA_IDS_ARDRI8 | Type of PiaException thrown if age under 50 for DIB before 1960 in PiaCal::ardriCal.
PIA_IDS_ARDRI9 | Type of PiaException thrown if age over full retirement age for DIB in PiaCal::ardriCal.
PIA_IDS_ARFFOUT | String ID for printing actuarial reduction factor.
PIA_IDS_ARFMOUT | String ID for printing months of actuarial reduction.
PIA_IDS_ATODOUBLE | (Currently unused).
PIA_IDS_ATOFLOAT | (Currently unused).
PIA_IDS_ATOINT | (Currently unused).
PIA_IDS_ATOLONG | (Currently unused).
PIA_IDS_AVERAGETEXT | (Currently unused.)
PIA_IDS_AVGWG | Type of PiaException thrown if year is out of range in an AverageWage function.
PIA_IDS_AVGWGTTL | (Currently unused.)
PIA_IDS_AWASSUM | (Currently unused.)
PIA_IDS_AWBI1 | Type of PiaException thrown if unable to open input file in AwbiDataFile::read.
PIA_IDS_AWBI2 | Type of PiaException thrown if unable to open output file in AwbiDataFile::write.
PIA_IDS_AWBI3 | Type of PiaException thrown if unable to read all required data in AwbiDataFile::read.
PIA_IDS_AWBIDAT1 | Type of PiaException thrown if last year of historical data is too large in AwbiDataNonFile::setData.
PIA_IDS_AWOUT | String ID for printing average wage assumptions.
PIA_IDS_BASE1 | Type of PiaException thrown if first year is out of range in WageBaseGeneral::project.
PIA_IDS_BASE2 | Type of PiaException thrown if wage base is out of range.
PIA_IDS_BASECH | Type of PiaException thrown if wage base indicator is not 1 or 2.
PIA_IDS_BASEYR1 | Type of PiaException thrown if base year is out of range (1979-2020).
PIA_IDS_BASEYR2 | Type of PiaException thrown if unable to open output file in BaseYearFile::write.
PIA_IDS_BASEYR3 | Type of PiaException thrown if unable to read base year in BaseYearFile::read.
PIA_IDS_BASEYR4 | Type of PiaException thrown if unable to open input file in BaseYearFile::read.
PIA_IDS_BEGIN1 | Type of PiaException thrown if first year of earnings is out of range.
PIA_IDS_BEGIN2 | Type of PiaException thrown if last year of earnings is before first year of earnings in backward projection period.
PIA_IDS_BEGIN3 | Type of PiaException thrown if first year of earnings is before 1937.
PIA_IDS_BEGIN4 | Type of PiaException thrown if first year of earnings is in starting year of projections or later, in a Statement case.
PIA_IDS_BEGIN5 | Type of PiaException thrown if first year of earnings is after maximum year allowed, in a non-Statement case.
PIA_IDS_BEGIN6 | Type of PiaException thrown if there are no regular, railroad, or military earnings.
PIA_IDS_BEN1OUT | String ID for printing benefit before rounding.
PIA_IDS_BEN2OUT | String ID for printing benefit after rounding.
PIA_IDS_BENARRAY1 | Type of PiaException thrown if year is out of range in BenefitAmountArray functions.
PIA_IDS_BENARRAY2 | Type of PiaException thrown if year is out of range in BenefitAmountArray::[].
PIA_IDS_BENDATE1 | Type of PiaException thrown if benefit date is before entitlement date.
PIA_IDS_BENDATE2 | Type of PiaException thrown if month of benefit is out of range.
PIA_IDS_BENDATE3 | Type of PiaException thrown if year of benefit is before 1940.
PIA_IDS_BENDATE4 | Type of PiaException thrown if year of benefit is after maximum allowed.
PIA_IDS_BENDATE5 | (Currently unused.)
PIA_IDS_BENDATE6 | Type of PiaException thrown if secondary entitlement after benefit date.
PIA_IDS_BENFOUT | String ID for printing secondary benefit factor.
PIA_IDS_BIASSUM | (Currently unused.)
PIA_IDS_BICCHP | Type of PiaException thrown if year is out of range in Catchup functions.
PIA_IDS_BIOUT | String ID for printing benefit increase assumptions.
PIA_IDS_BIPROJTTL | (Currently unused.)
PIA_IDS_BIRTH1 | Type of PiaException thrown if year of birth is in current year or later (in Statement case).
PIA_IDS_BIRTH2 | Type of PiaException thrown if year of birth is before 1800.
PIA_IDS_BIRTH3 | Type of PiaException thrown if month of birth is out of range.
PIA_IDS_BIRTH4 | Type of PiaException thrown if day of birth is out of range.
PIA_IDS_BIRTH5 | Type of PiaException thrown if year of birth is after maximum allowed.
PIA_IDS_BIRTH6 | (Currently unused.)
PIA_IDS_BITANN1 | Type of PiaException thrown if year is out of range in BitAnnual functions.
PIA_IDS_CACHUP1 | Type of PiaException thrown if catch-up benefit increase is out of range.
PIA_IDS_CACHUP2 | Type of PiaException thrown if unable to open input file in CatchupFile::read.
PIA_IDS_CACHUP3 | Type of PiaException thrown if unable to open output file in CatchupFile::write.
PIA_IDS_CACHUP4 | Type of PiaException thrown if year is out of range in a Catchup function.
PIA_IDS_CESS2OUT | String ID for printing second prior date of cessation.
PIA_IDS_COMMA | Type of PiaException thrown if number of decimals is nonzero for other than a float type in pout.
PIA_IDS_CONFIG1 | Type of PiaException thrown if unable to open input file in ConfigFile::read.
PIA_IDS_CONFIG5 | Type of PiaException thrown if unable to open output file in ConfigFile::write.
PIA_IDS_CONFIG6 | Type of PiaException thrown if unable to read all required data in ConfigFile::read.
PIA_IDS_CPIINC1 | Type of PiaException thrown if benefit increase is out of range.
PIA_IDS_CPIINC2 | Type of PiaException thrown if unable to open output file in BiprojFile::write.
PIA_IDS_CPIINC3 | Type of PiaException thrown if unable to read all required data in BiprojFile::read.
PIA_IDS_CPIINC4 | Type of PiaException thrown if unable to open input file in BiprojFile::read.
PIA_IDS_CUPROJTTL | (Currently unused.)
PIA_IDS_CURINSOUT | String ID for printing currently insured status in survivor case.
PIA_IDS_DATEDAY | Type of PiaException thrown if day in a date is out of range.
PIA_IDS_DATEDIFF | Type of PiaException thrown if unable to difference two dates.
PIA_IDS_DATEMONTH | Type of PiaException thrown if month in a date is out of range.
PIA_IDS_DATEREAD | Type of PiaException thrown if unable to parse string into a date.
PIA_IDS_DATEYEAR | Type of PiaException thrown if year in a date is out of range.
PIA_IDS_DBLEANN1 | (Currently unused).
PIA_IDS_DBLEANN2 | Type of PiaException thrown if unable to read specified years in DoubleAnnualRead::read.
PIA_IDS_DEATH1 | Type of PiaException thrown if month of death is out of range.
PIA_IDS_DEATH2 | Type of PiaException thrown if year of death is after maximum allowed.
PIA_IDS_DEATH3 | Type of PiaException thrown if death before 1937 in a survivor case.
PIA_IDS_DEATH4 | Type of PiaException thrown if entitlement of survivor is before death of worker.
PIA_IDS_DEATH5 | Type of PiaException thrown if death of worker is before birth.
PIA_IDS_DEATH6 | (Currently unused.)
PIA_IDS_DEATHOUT | String ID for printing date of death.
PIA_IDS_DIBENTOUT | String ID for printing DIB date of entitlement.
PIA_IDS_DICESS1 | Type of PiaException thrown if month of cessation is out of range.
PIA_IDS_DICESS2 | Type of PiaException thrown if year of cessation is before 1937.
PIA_IDS_DICESS3 | Type of PiaException thrown if year of cessation is after maximum allowed.
PIA_IDS_DICESS4 | Type of PiaException thrown if disability cessation before onset.
PIA_IDS_DICESS5 | Type of PiaException thrown if prior disability cessation after second entitlement.
PIA_IDS_DICESS6 | Type of PiaException thrown if entitlement is before cessation.
PIA_IDS_DICESS7 | Type of PiaException thrown if cessation is after death in a survivor case.
PIA_IDS_DICESS8 | (Currently unused.)
PIA_IDS_DINS1OUT | String ID for printing first part of disability insured status.
PIA_IDS_DINS2OUT | String ID for printing second part of disability insured status.
PIA_IDS_DINS3OUT | String ID for printing third part of disability insured status.
PIA_IDS_DISREQCAL1 | Type of PiaException thrown if year in most recent freeze period is out of range in PiaData::qcDisReqCal.
PIA_IDS_DISREQCAL2 | Type of PiaException thrown if year in next most recent freeze period is out of range in PiaData::qcDisReqCal.
PIA_IDS_DOBOUT | String ID for printing date of birth.
PIA_IDS_DOBWIDOUT | String ID for printing date of birth of widow(er).
PIA_IDS_DRCFOUT | String ID for printing delayed retirement credit factor.
PIA_IDS_DRCMOUT | String ID for printing months of delayed retirement credit.
PIA_IDS_EARNHI | Type of PiaException thrown if Medicare earnings are out of range.
PIA_IDS_EARNMAL | Type of PiaException thrown if year is before 1937 in EarnProject::toString.
PIA_IDS_EARNPEBS | Type of PiaException thrown if OASDI earnings are out of range.
PIA_IDS_EARNPROJ | Type of PiaException thrown if projection year is out of range in EarnProject::project.
PIA_IDS_EARNTYPE | Type of PiaException thrown if type of earnings is out of range.
PIA_IDS_EARNTYPE1 | Type of PiaException thrown if projection year is out of range in PiaWrite::writeEarnType.
PIA_IDS_EARNTYPEYR | Type of PiaException thrown if year is out of range in EarnProject::setEarntype.
PIA_IDS_ELAPSOUT | String ID for printing elapsed years.
PIA_IDS_END1 | Type of PiaException thrown if last year of earnings is before 1937.
PIA_IDS_END2 | Type of PiaException thrown if last year of earnings is after maximum year allowed.
PIA_IDS_END3 | Type of PiaException thrown if first year of earnings in forward projection period is after last year of earnings in forward projection period.
PIA_IDS_END4 | Type of PiaException thrown if the total number of years of earnings is greater than the maximum allowed (MAXYRS).
PIA_IDS_ENT1 | Type of PiaException thrown if month of entitlement is out of range.
PIA_IDS_ENT2 | Type of PiaException thrown if year of entitlement is before 1940.
PIA_IDS_ENT3 | Type of PiaException thrown if year of entitlement is after maximum allowed.
PIA_IDS_ENT4 | (Currently unused.)
PIA_IDS_ERNLIMOUT | String ID for printing earnings over maximum allowed.
PIA_IDS_FAMSIZE | Type of PiaException thrown if family size is out of bounds.
PIA_IDS_FLOATANN1 | (Currently unused).
PIA_IDS_FLOATANN2 | (Currently unused).
PIA_IDS_FLOATMTH1 | Type of PiaException thrown if years are out of range in a FloatMonth function.
PIA_IDS_FLOATMTH2 | Type of PiaException thrown if unable to read specified years in FloatMonth::read.
PIA_IDS_FLOATMTH3 | Type of PiaException thrown if quarter is out of range in a FloatMonth function.
PIA_IDS_FLOATQTR1 | Type of PiaException thrown if years are out of range in a FloatQuarter function.
PIA_IDS_FLOATQTR2 | Type of PiaException thrown if unable to read specified years in FloatQuarter::read.
PIA_IDS_FLOATQTR3 | Type of PiaException thrown if quarter is out of range in a FloatQuarter function.
PIA_IDS_FLOATQTR4 | Type of PiaException thrown if data value is zero in a FloatQuarter divide function.
PIA_IDS_FMSTRING | Type of PiaException thrown if error in FrozMinPage::prepareStrings.
PIA_IDS_FOINFO1 | Type of PiaException thrown if unable to open input file in FieldOfficeInfoFile::read.
PIA_IDS_FOINFO2 | Type of PiaException thrown if unable to read all required data in FieldOfficeInfoFile::read.
PIA_IDS_FOINFO3 | Type of PiaException thrown if unable to open output file in FieldOfficeInfoFile::write.
PIA_IDS_FQINC1 | Type of PiaException thrown if average wage increase is out of range.
PIA_IDS_FQINC2 | Type of PiaException thrown if unable to open output file in AwincFile::write.
PIA_IDS_FQINC3 | Type of PiaException thrown if unable to read all required data in AwincFile::read.
PIA_IDS_FQINC4 | Type of PiaException thrown if unable to open input file in AwincFile::read.
PIA_IDS_FULLBEN | String ID for printing full secondary benefit.
PIA_IDS_GENFILE1 | Type of PiaException thrown if unable to open a Genfile for output.
PIA_IDS_GENFILE2 | Type of PiaException thrown if unable to open a Genfile for appended output.
PIA_IDS_GENFILE3 | Type of PiaException thrown if unable to open a Genfile for input.
PIA_IDS_HIGHTEXT | (Currently unused.)
PIA_IDS_HISTAMTTL | (Currently unused.)
PIA_IDS_HISTAMTUPDATE | (Currently unused.)
PIA_IDS_IALTAW1 | Type of PiaException thrown if average wage increase indicator is out of range in general case.
PIA_IDS_IALTAW2 | Type of PiaException thrown if average wage increase indicator is out of range in Statement case.
PIA_IDS_IALTBI1 | Type of PiaException thrown if benefit increase indicator is out of range in general case.
PIA_IDS_IALTBI2 | Type of PiaException thrown if benefit increase indicator is out of range in Statement case.
PIA_IDS_INSTATOUT | String ID for printing insured status.
PIA_IDS_INSUREOUT | String ID for printing fully insured for totalization benefits.
PIA_IDS_INTANN1 | (Currently unused).
PIA_IDS_INTANN2 | (Currently unused).
PIA_IDS_JBIRTH1 | (Currently unused.)
PIA_IDS_JBIRTH2 | (Currently unused.)
PIA_IDS_JBIRTH3 | (Currently unused.)
PIA_IDS_JBIRTH4 | (Currently unused.)
PIA_IDS_JBIRTH5 | (Currently unused.)
PIA_IDS_JOASDI | Type of PiaException thrown if type of benefit is out of range.
PIA_IDS_JONSET1 | (Currently unused.)
PIA_IDS_JONSET2 | (Currently unused.)
PIA_IDS_JONSET3 | (Currently unused.)
PIA_IDS_JONSET4 | (Currently unused.)
PIA_IDS_JONSET5 | Type of PiaException thrown if widow's disability is before birth.
PIA_IDS_JONSET6 | Type of PiaException thrown if widow's disability is after entitlement.
PIA_IDS_JONSET7 | (Currently unused.)
PIA_IDS_JSURV | Type of PiaException thrown if bic is not a valid life or survivor bic.
PIA_IDS_JSURVOUT | String ID for printing type of survivor.
PIA_IDS_LAWCHG1 | Type of PiaException thrown if starting year of law changes is out of range.
PIA_IDS_LAWCHG2 | Type of PiaException thrown if law change wage increase proportion is out of range.
PIA_IDS_LAWCHG3 | Type of PiaException thrown if law change benefit formula percentage is out of range.
PIA_IDS_LAWCHG4 | Type of PiaException thrown if law change bend point is out of range.
PIA_IDS_LAWCHG5 | Type of PiaException thrown if law change constant decline percentage is out of range.
PIA_IDS_LAWCHG6 | Type of PiaException thrown if unable to parse input line in LawChangeRead::read.
PIA_IDS_LAWCHG7 | Type of PiaException thrown if unable to open input file in LawChangeRead::read.
PIA_IDS_LAWCHG8 | Type of PiaException thrown if unable to open output file in LawChangeWrite::write.
PIA_IDS_LAWCHG9 | Type of PiaException thrown if type of law change is out of range.
PIA_IDS_LOWTEXT | (Currently unused.)
PIA_IDS_MAXIMUMTEXT | (Currently unused.)
PIA_IDS_METHOD | Type of PiaException thrown if years are inconsistent in PiaMethod::totalEarnCal.
PIA_IDS_MFBBEN | String ID for printing maximum family benefit.
PIA_IDS_MFBLOUT | String ID for printing MFB at eligibility.
PIA_IDS_MFBOUT | String ID for printing MFB.
PIA_IDS_MILSERV1 | Type of PiaException thrown if military service starting date is after ending date.
PIA_IDS_MILSERV2 | Type of PiaException thrown if number of military service periods is out of range in general case.
PIA_IDS_MILSERV3 | Type of PiaException thrown if number of military service periods is out of range in military service case.
PIA_IDS_MILSERV4 | Type of PiaException thrown if military service starting date is out of range.
PIA_IDS_MILSERV5 | Type of PiaException thrown if military service ending date is out of range.
PIA_IDS_MILSERV6 | Type of PiaException thrown if years are out of range in MilServDates::getQc3750.
PIA_IDS_MILSERV7 | Type of PiaException thrown if years are out of range in MilServDates::getEarn3750.
PIA_IDS_MODTC | Type of PiaException thrown if moddata is in error.
PIA_IDS_MONTHTEXT | (Currently unused).
PIA_IDS_NAMEOUT | String ID for printing worker's name.
PIA_IDS_NDISINOUT | String ID for printing not disability insured.
PIA_IDS_NEEDAW | (Currently unused).
PIA_IDS_NEEDBASES | Type of PiaException thrown if year is out of range in WorkerDataGeneral::need_bases.
PIA_IDS_NEEDBI | (Currently unused).
PIA_IDS_NINSTOUT | String ID for printing not insured in survivor case.
PIA_IDS_NINSUROUT | String ID for printing not fully insured.
PIA_IDS_NONPENDATE1 | Type of PiaException thrown if noncovered pension entitlement date is before birth.
PIA_IDS_NONPENDATE2 | Type of PiaException thrown if noncovered pension entitlement date is after death.
PIA_IDS_NONPENDATE3 | Type of PiaException thrown if noncovered pension entitlement date entry is invalid.
PIA_IDS_NONPENDATEOUT | String ID for printing noncovered pension entitlement date.
PIA_IDS_NONPENOUT | String ID for printing noncovered pension.
PIA_IDS_NRA1OUT | String ID for printing early retirement age.
PIA_IDS_NRAOUT | String ID for printing full retirement age.
PIA_IDS_NRAWIDOUT | String ID for printing widow(er)'s full retirement age.
PIA_IDS_NRAWIFEOUT | String ID for printing full retirement age of aged wife/husband.
PIA_IDS_NTOTALOUT | String ID for printing not insured for totalization benefits.
PIA_IDS_OABBENOUT | String ID for printing OAB date of benefit.
PIA_IDS_OABENTOUT | String ID for printing OAB date of entitlement.
PIA_IDS_OLDSTART1 | Type of PiaException thrown if date of entitlement is out of range in OldStart::calculate.
PIA_IDS_OLDSTART2 | Type of PiaException thrown if old start method number is out of range.
PIA_IDS_ONEPAGE | Type of PiaException thrown if error in OnePage::prepareStrings.
PIA_IDS_ONSET1 | Type of PiaException thrown if month of onset is out of range.
PIA_IDS_ONSET10 | (Currently unused.)
PIA_IDS_ONSET11 | Type of PiaException thrown if disability onset is after full retirement age.
PIA_IDS_ONSET2 | Type of PiaException thrown if day of onset is out of range.
PIA_IDS_ONSET2OUT | String ID for printing second prior date of onset.
PIA_IDS_ONSET3 | Type of PiaException thrown if year of onset is before 1937.
PIA_IDS_ONSET4 | Type of PiaException thrown if year of onset is after maximum allowed.
PIA_IDS_ONSET5 | Type of PiaException thrown if disability is before birth.
PIA_IDS_ONSET6 | Type of PiaException thrown if disability is after entitlement.
PIA_IDS_ONSET7 | Type of PiaException thrown if death of worker is before disability onset in a survivor case.
PIA_IDS_ONSET8 | Type of PiaException thrown if prior disability is after current disability.
PIA_IDS_ONSET9 | (Currently unused.)
PIA_IDS_ONSETOUT | String ID for printing date of onset.
PIA_IDS_OPENERR | (Currently unused.)
PIA_IDS_OSRANGE1 | (Currently unused.)
PIA_IDS_OSRANGE2 | (Currently unused.)
PIA_IDS_OSSTRING | Type of PiaException thrown if error in OldStart1Page::prepareStrings.
PIA_IDS_OUTFILE | (Currently unused.)
PIA_IDS_PEBESMONTH | Type of PiaException thrown if month of Statement processing is out of range.
PIA_IDS_PEBSASM | Type of PiaException thrown if benefit increase indicator or average wage increase indicator is out of range in Statement case.
PIA_IDS_PERCBACK | Type of PiaException thrown if backward projection percentage is out of range.
PIA_IDS_PERCFWRD | Type of PiaException thrown if forward projection percentage is out of range.
PIA_IDS_PIACALPLRGE | (Currently unused.)
PIA_IDS_PIACALRANGE | (Currently unused.)
PIA_IDS_PIALOUT | String ID for printing PIA at eligibility.
PIA_IDS_PIAOUT | String ID for printing PIA.
PIA_IDS_PIATABLE1 | Type of PiaException thrown if year of entitlement is out of range in PiaTable::calculate.
PIA_IDS_PIATABLE2 | Type of PiaException thrown if year of benefit is out of range in PiaTable::calculate.
PIA_IDS_PIB50MFB | Type of PiaException thrown if index is out of range in Pib50Mfb::getAt.
PIA_IDS_PIB50PIB | Type of PiaException thrown if index is out of range in Pib50Pib::getAt.
PIA_IDS_PIB52MFB | Type of PiaException thrown if index is out of range in Pib52Mfb::getAt.
PIA_IDS_PIB54MFB | Type of PiaException thrown if index is out of range in Pib54Mfb::getAt.
PIA_IDS_PIB54PIA | Type of PiaException thrown if index is out of range in Pib54Pia::getAt.
PIA_IDS_PIB58AME | Type of PiaException thrown if index is out of range in Pib58Ame::getAt.
PIA_IDS_PIB58PIB | Type of PiaException thrown if index is out of range in Pib58Pib::getAt.
PIA_IDS_PIBTABLE1 | (Currently unused.)
PIA_IDS_PIBTABLE2 | (Currently unused.)
PIA_IDS_PONSETOUT | String ID for printing second prior date of onset in nondisability case.
PIA_IDS_PRCESSOUT | String ID for printing prior date of cessation.
PIA_IDS_PRENTOUT | String ID for printing date of prior entitlement in nondisability case.
PIA_IDS_PRIOROUT | String ID for printing prior date of entitlement in disability case.
PIA_IDS_PROBASOUT | String ID for printing projected wage base type.
PIA_IDS_PROJBACK1 | Type of PiaException thrown if backward projection indicator is out of range in general case (0-2).
PIA_IDS_PROJBACK2 | Type of PiaException thrown if backward projection indicator is out of range in backward projection case (1-2).
PIA_IDS_PROJFWRD1 | Type of PiaException thrown if forward projection indicator is out of range in general case (0-2).
PIA_IDS_PROJFWRD2 | Type of PiaException thrown if forward projection indicator is out of range in forward projection case (1-2).
PIA_IDS_PRRENT1 | Type of PiaException thrown if month of prior entitlement is out of range.
PIA_IDS_PRRENT2 | Type of PiaException thrown if year of prior entitlement is before 1940.
PIA_IDS_PRRENT3 | Type of PiaException thrown if year of prior entitlement is after maximum allowed.
PIA_IDS_PRRENT4 | Type of PiaException thrown if prior entitlement is not before current entitlement.
PIA_IDS_PRRENT5 | Type of PiaException thrown if prior entitlement to disability is before disability onset.
PIA_IDS_PRRENT6 | (Currently unused.)
PIA_IDS_PRRENT7 | Type of PiaException thrown if prior entitlement to disability is after full retirement age.
PIA_IDS_PTSTRING | Type of PiaException thrown if error in PiaTable1Page::prepareStrings.
PIA_IDS_PUBPEN | Type of PiaException thrown if public pension amount is out of range.
PIA_IDS_QC | Type of PiaException thrown if number of quarters of coverage, 1951-77, is greater than number of quarters of coverage, 1937-77.
PIA_IDS_QC51TD | Type of PiaException thrown if number of quarters of coverage, 1951-77, is out of range.
PIA_IDS_QCAMT | Type of PiaException thrown if average wages have not been set in Qcamt::project.
PIA_IDS_QCANN | Type of PiaException thrown if number of annual quarters of coverage is out of range.
PIA_IDS_QCARRAY1 | Type of PiaException thrown if year is out of range in QcArray functions.
PIA_IDS_QCARRAY2 | (Currently unused).
PIA_IDS_QCARRAY3 | Type of PiaException thrown if years are out of range in QcArray::accumulate.
PIA_IDS_QCARRAY4 | Type of PiaException thrown if quarters are out of range in QcArray::accumulate.
PIA_IDS_QCCAL | Type of PiaException thrown if quarter of coverage amount has not been set in PiaData::qcCal.
PIA_IDS_QCDISCAL | Type of PiaException thrown if any starting or ending dates are out of range in PiaData::qcDisCal.
PIA_IDS_QCLUMPYEAR | Type of PiaException thrown if qclumpyear is out of range.
PIA_IDS_QCPACKED1 | Type of PiaException thrown if index is out of range in QcPacked::get.
PIA_IDS_QCPACKED2 | Type of PiaException thrown if index is out of range in QcPacked::set.
PIA_IDS_QCTD | Type of PiaException thrown if number of quarters of coverage, 1937-77, is out of range.
PIA_IDS_QCTOT0 | Type of PiaException thrown if no quarters of coverage in a totalization case.
PIA_IDS_QTRYRQTR | Type of PiaException thrown if number of quarters in a QtrYear is greater than 3.
PIA_IDS_QTRYRYR | Type of PiaException thrown if year in a QtrYear is greater than LASTYEARLR.
PIA_IDS_READEOF | Return value from PiaRead::read if successful read, with end of file following.
PIA_IDS_READERR | Type of PiaException thrown if unable to read a pia file.
PIA_IDS_READMORE | Return value from PiaRead::read if successful read, with additional data following.
PIA_IDS_RELERNOUT | String ID for printing relative earnings level.
PIA_IDS_RELERNPOS | Type of PiaException thrown if first year is out of range in PiaCal::relEarnPositionCal.
PIA_IDS_REQQCOUT | String ID for printing required quarters of coverage.
PIA_IDS_REVIEWBI | (Currently unused.)
PIA_IDS_ROUND | Type of PiaException thrown if year is before 1937 in BenefitAmount functions.
PIA_IDS_RTGENRL | Type of PiaException thrown if denominator is out of range in RtGeneral::project1.
PIA_IDS_RWSTRING | Type of PiaException thrown if error in ReindWid1Page::prepareStrings.
PIA_IDS_SECONDARY | Type of PiaException thrown if type of bic is not set in Secondary::check.
PIA_IDS_SETNOCH | Type of PiaException thrown if year is out of range in PiaParams::setNoChange.
PIA_IDS_SEX | Type of PiaException thrown if sex is not Sex::sex_type::MALE or Sex::sex_type::FEMALE.
PIA_IDS_SEXOUT | String ID for printing sex of worker.
PIA_IDS_SGAPROJ | Type of PiaException thrown if annual Sga project function is called.
PIA_IDS_SMSTRING | Type of PiaException thrown if error in SpecMin1Page::prepareStrings.
PIA_IDS_SPPIA1OUT | String ID for printing special minimum PIA, support PIA unused.
PIA_IDS_SPPIA2OUT | String ID for printing special minimum PIA, support PIA used.
PIA_IDS_SPYRS2OUT | String ID for printing total special minimum years of coverage.
PIA_IDS_SPYRSOUT | String ID for printing total special minimum years of coverage.
PIA_IDS_SSN1 | Type of PiaException thrown if number of characters in a string used to construct an Ssn is less than 9.
PIA_IDS_SSNOUT | String ID for printing worker's Social Security number.
PIA_IDS_START1 | Type of PiaException thrown if starting year of assumptions is before 1979.
PIA_IDS_START2 | Type of PiaException thrown if starting year of assumptions is after maximum year allowed.
PIA_IDS_SUPPIAOUT | String ID for printing support PIA.
PIA_IDS_SURVBENOUT | String ID for printing secondary date of benefit.
PIA_IDS_SURVENTOUT | String ID for printing secondary date of entitlement.
PIA_IDS_TAXTYPE | Type of PiaException thrown if type of taxes is out of range.
PIA_IDS_TAXTYPEYR | Type of PiaException thrown if year is out of range in WorkerData::setTaxType.
PIA_IDS_TGSTRING | Type of PiaException thrown if error in TransGuar1Page::prepareStrings.
PIA_IDS_TITLEPRO1 | (Currently unused.)
PIA_IDS_TITLEPRO2 | (Currently unused.)
PIA_IDS_TITLEPRO3 | (Currently unused.)
PIA_IDS_TITLEPRO4 | (Currently unused).
PIA_IDS_TWOPAGE1 | Type of PiaException thrown if error in InsuredPage::prepareStrings.
PIA_IDS_TWOPAGE2 | Type of PiaException thrown if error in EarningsPage::prepareStrings.
PIA_IDS_TWOPAGE3 | Type of PiaException thrown if error in Summary1Page::prepareStrings.
PIA_IDS_TWOPAGE4 | Type of PiaException thrown if error in Summary2Page::prepareStrings.
PIA_IDS_TWOPAGE5 | Type of PiaException thrown if error in Summary3Page::prepareStrings.
PIA_IDS_TXSTRING | Type of PiaException thrown if error in TaxesPage::prepareStrings.
PIA_IDS_UNBICCHP | Type of PiaException thrown if either year is out of range in PiaParams::unbiCatchUp.
PIA_IDS_UNEARNOUT | String ID for printing unused earnings message.
PIA_IDS_UPDATEAW | (Currently unused.)
PIA_IDS_UPDATEBI | (Currently unused.)
PIA_IDS_UPDATEFQ | Type of PiaException thrown if average wage is zero in PiaParams::updateFq.
PIA_IDS_UPDATEWB | (Currently unused.)
PIA_IDS_UPDATEWBOLD | (Currently unused.)
PIA_IDS_VALDI1 | Type of PiaException thrown if number of periods of disability is not 0, 1, or 2 in a nondisability case.
PIA_IDS_VALDI2 | Type of PiaException thrown if number of periods of disability is not 1 or 2 in a disability case.
PIA_IDS_WAGEBASE | (Currently unused.)
PIA_IDS_WAITPD1 | Type of PiaException thrown if first month of waiting period is out of range.
PIA_IDS_WAITPD2 | Type of PiaException thrown if year of first month of waiting period is before 1940.
PIA_IDS_WAITPD3 | Type of PiaException thrown if year of first month of waiting period is after maximum allowed.
PIA_IDS_WAITPD4 | Type of PiaException thrown if waiting period starts before onset.
PIA_IDS_WAITPD5 | Type of PiaException thrown if entitlement is before waiting period.
PIA_IDS_WAITPD6 | Type of PiaException thrown if cessation is before waiting period.
PIA_IDS_WAITPD7 | (Currently unused.)
PIA_IDS_WIDDIBOUT | String ID for printing date of onset of widow(er).
PIA_IDS_WISTRING | Type of PiaException thrown if error in WageInd1Page::prepareStrings.
PIA_IDS_WRITEEARN | Type of PiaException thrown if first year of earnings is out of range in PiaWrite::writeEarnOasdi or PiaWriteAny::writeEarnOasdi.
PIA_IDS_YEAR | (Currently unused.)
Collapse Expand Links
Files, Macros


Sex.cpp

Sex.cpp
Files

Functions for the Sex class holding a sex indicator.

Collapse Expand Group

Files

Collapse Expand Links
Files


Sex.h

Sex.h
Classes Files Legend

Declarations needed for the Sex class holding a sex indicator.

Collapse Expand Classes
Name | Description
Sex | Indicator for sex type.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


StringParser.cpp

StringParser.cpp
Files

Function definitions to parse a string.

Collapse Expand Group

Files

Collapse Expand Links
Files


StringParser.h

StringParser.h
Functions Files Legend

Declarations of functions to parse a string.

Collapse Expand Functions
Name | Description
parseString | Parses a string into its delimited parts, using a space separator.
parseString | Parses a string into its delimited parts with a specified delimiter.
Collapse Expand Group

Files

Collapse Expand Links
Functions, Files, Legend


TextWriterTraceListener.cpp

TextWriterTraceListener.cpp
Files

Functions for the TextWriterTraceListener class that listens for Trace output and writes to an ostream.

Collapse Expand Group

Files

Collapse Expand Links
Files


TextWriterTraceListener.h

TextWriterTraceListener.h
Classes Files Legend

Declarations for the TextWriterTraceListener class that listens for Trace output and writes to an ostream.

Collapse Expand Classes
Name | Description
TextWriterTraceListener | An output-stream-based class that listens for Trace output.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


Trace.cpp

Trace.cpp
Files

Functions for the Trace class to trace execution of code.

Collapse Expand Group

Files

Collapse Expand Links
Files


Trace.h

Trace.h
Classes Files Legend

Declarations for the Trace class to trace execution of code.

Collapse Expand Classes
Name | Description
Trace | Controls the logfiles used to trace execution of code.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


TraceListener.cpp

TraceListener.cpp
Files

Functions for the TraceListener class - parent of classes that listen for Trace output.

Collapse Expand Group

Files

Collapse Expand Links
Files


TraceListener.h

TraceListener.h
Classes Files Legend

Declarations for the TraceListener class - parent of classes that listen for Trace output.

Collapse Expand Classes
Name | Description
TraceListener | The parent of classes that listen for Trace output.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


age.cpp

age.cpp
Files

Functions for Age class to manage age in years and months.

Collapse Expand Group

Files

Collapse Expand Links
Files


age.h

age.h
Classes Files Legend

Declarations for Age class to manage age in years and months.

Collapse Expand Classes
Name | Description
Age | Manages a year and month age stored as integers.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


comma.cpp

comma.cpp
Files

Functions that return strings with (or without) embedded commas in any type of number (floating or integral).

Collapse Expand Group

Files

Collapse Expand Links
Files


comma.h

comma.h
Functions Files Legend

Declarations of functions that return strings with (or without) embedded commas in any type of number (floating or integral).

Collapse Expand Functions
Name | Description
pblank | Inserts blanks or zeroes on the left of a formatted string representing a number.
pcomma | Inserts commas into a formatted string representing a number.
Collapse Expand Group

Files

Collapse Expand Links
Functions, Files, Legend


date.cpp

date.cpp
Files

Functions for the static Date class to manage date and time.

Collapse Expand Group

Files

Collapse Expand Links
Files


date.h

date.h
Classes Files Legend

Declarations for the static Date class to manage date and time.

Collapse Expand Classes
Name | Description
Date | Static variables and functions for classes that hold dates.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


datemoyr.cpp

datemoyr.cpp
Files

Functions needed for the DateMoyr class to handle date as month and year.

Collapse Expand Group

Files

Collapse Expand Links
Files


datemoyr.h

datemoyr.h
Classes Files Legend

Declarations needed for DateMoyr class to manage date as month and year.

Collapse Expand Classes
Name | Description
DateMoyr | Manages a month and year stored as unsigned integers.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


dbleann.cpp

dbleann.cpp
Files

Functions needed for DoubleAnnual class to manage an array of annual doubles.

Collapse Expand Group

Files

Collapse Expand Links
Files


dbleann.h

dbleann.h
Classes Files Legend

Declarations needed for DoubleAnnual class to manage an array of annual doubles.

Collapse Expand Classes
Name | Description
DoubleAnnual | Manages an array of annual doubles.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


dblemth.cpp

dblemth.cpp
Files

Functions for the DoubleMonth class to manage an array of monthly doubles.

Collapse Expand Group

Files

Collapse Expand Links
Files


dblemth.h

dblemth.h
Classes Files Legend

Declarations for the DoubleMonth class to manage an array of monthly doubles.

Collapse Expand Classes
Name | Description
DoubleMonth | Manages an array of monthly doubles.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


dbleqtr.cpp

dbleqtr.cpp
Files

Functions for the DoubleQuarter class to manage an array of quarterly doubles.

Collapse Expand Group

Files

Collapse Expand Links
Files


dbleqtr.h

dbleqtr.h
Classes Files Legend

Declarations for the DoubleQuarter class to manage an array of quarterly doubles.

Collapse Expand Classes
Name | Description
DoubleQuarter | Manages an array of quarterly doubles.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


document.cpp

document.cpp
Files

Functions for the Document class to manage a generic document.

Collapse Expand Group

Files

Collapse Expand Links
Files


document.h

document.h
Classes Files Legend

Declarations for the Document class to manage a generic document.

Collapse Expand Classes
Name | Description
Document | Manages a generic document.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


floatann.cpp

floatann.cpp
Files

Functions for the FloatAnnual class to manage an array of annual floats.

Collapse Expand Group

Files

Collapse Expand Links
Files


floatann.h

floatann.h
Classes Files Legend

Declarations for the FloatAnnual class to manage an array of annual floats.

Collapse Expand Classes
Name | Description
FloatAnnual | Manages an array of annual floats.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


floatmth.cpp

floatmth.cpp
Files

Functions for the FloatMonth class to manage an array of monthly floats.

Collapse Expand Group

Files

Collapse Expand Links
Files


floatmth.h

floatmth.h
Classes Files Legend

Declarations for the FloatMonth class to manage an array of monthly floats.

Collapse Expand Classes
Name | Description
FloatMonth | Manages an array of monthly floats.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


floatqtr.cpp

floatqtr.cpp
Files

Functions for the FloatQuarter class to manage an array of quarterly floats.

Collapse Expand Group

Files

Collapse Expand Links
Files


floatqtr.h

floatqtr.h
Classes Files Legend

Declarations for the FloatQuarter class to manage an array of quarterly floats.

Collapse Expand Classes
Name | Description
FloatQuarter | Manages an array of quarterly floats.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


genfile.cpp

genfile.cpp
Files

Functions for the Genfile class to manage a general file.

Collapse Expand Group

Files

Collapse Expand Links
Files


genfile.h

genfile.h
Classes Files Legend

Declarations for the Genfile class to manage a general file.

Collapse Expand Classes
Name | Description
Genfile | Manages a generic file.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


intann.cpp

intann.cpp
Files

Functions for the IntAnnual class to manage an array of annual integers.

Collapse Expand Group

Files

Collapse Expand Links
Files


intann.h

intann.h
Classes Files Legend

Declarations for the IntAnnual class to manage an array of annual integers.

Collapse Expand Classes
Name | Description
IntAnnual | Manages an array of annual integers.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


outfile.cpp

outfile.cpp
Files

Functions for the Outfile, Out132, and Out80 classes - parents of classes to manage output file with page counters.

Collapse Expand Group

Files

Collapse Expand Links
Files


outfile.h

outfile.h
Classes Files Legend

Declarations for the Outfile, Out132, and Out80 classes - parents of classes to manage output file with page counters.

Collapse Expand Classes
Name | Description
Out132 | An Outfile tailored for 132-column output.
Out80 | An Outfile tailored for 80-column output.
Outfile | Abstract parent of classes to manage an output file in runstreams with multiple programs.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


page.cpp

page.cpp
Files

Functions for the PageCounters class to manage page counters.

Collapse Expand Group

Files

Collapse Expand Links
Files


page.h

page.h
Classes Files Legend

Declarations for the PageCounters class to manage page counters.

Collapse Expand Classes
Name | Description
PageCounters | Manages a vector of page counters.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


qtryear.cpp

qtryear.cpp
Files

Functions for the QtrYear class to handle a year and quarter.

Collapse Expand Group

Files

Collapse Expand Links
Files


qtryear.h

qtryear.h
Classes Files Legend

Declarations for the QtrYear class to handle a year and quarter.

Collapse Expand Classes
Name | Description
QtrYear | Manages a year and quarter stored as unsigned integers.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


ssn.cpp

ssn.cpp
Files

Functions for the Ssn class to manage a Social Security number.

Collapse Expand Group

Files

Collapse Expand Links
Files


ssn.h

ssn.h
Classes Files Legend

Declarations for the Ssn class to manage a Social Security number.

Collapse Expand Classes
Name | Description
Ssn | Manages a Social Security number string, and the 3 parts of an ssn separately as strings.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PiaOut Library

PiaOut Library
Legend Topics

The piaout library part of the oactobjs library.

Collapse Expand Topics
Name | Description
Classes | The following table lists classes in this documentation.
Files | The following table lists files in this documentation.
Collapse Expand Classes
Name | Description
AnypiaOut | Manages all output pages from the Anypia program.
ChildCareCalc1Page | Manages wage indexed earnings from the calculation of a Social Security benefit with child-care dropout years.
ChildCareCalc2Page | Manages wage indexed results with child-care dropout years from the calculation of a Social Security benefit.
DibGuarPage | Manages the disability guarantee results from the calculation of a Social Security benefit.
EarningsPage | Manages printing of earnings used in the calculation of a Social Security benefit.
FamilyPage | Manages the results for the auxiliary beneficiaries from the calculation of a Social Security benefit.
FrozMinPage | Manages the frozen minimum results from the calculation of a Social Security benefit.
InsuredPage | Manages insured status output determined in the calculation of a Social Security benefit.
OldStart1Page | Manages old start earnings output from the calculation of a Social Security benefit.
OldStart2Page | Manages old start results from the calculation of a Social Security benefit.
OnePage | Manages one-page summary of results from the calculation of a Social Security benefit.
PebsCreditInfo | Manages the Social Security Statement credit info page.
PebsEarnings | Manages the Social Security Statement earnings page.
PebsEarningsInfo | Manages the Social Security Statement earnings info page.
PebsLetter | Manages the Social Security Statement letter page.
PebsOasdiEst | Manages the Social Security Statement oasdi estimates page.
PebsOasdiInfo | Manages the Social Security Statement oasdi benefit info page.
PebsOut | Manages the printing of the results of a Social Security Statement calculation.
PebsPageOut | Parent of classes that manage a page of Social Security Statement output.
PebsWorkerEarnings | Manages the Social Security Statement worker info and earnings info page.
PebsWorkerInfo | Manages the Social Security Statement worker info page.
PiaOut | >Manages the printing of the results of a Social Security non-Statement calculation.
PiaPageOut | Parent of classes that manage a page of output from the calculation of a non-Statement Social Security benefit.
PiaTable1Page | Manages the pia table calculation earnings page from the calculation of a Social Security benefit.
PiaTable2Page | Manages the pia table calculation results page from the calculation of a Social Security benefit.
ReindWid1Page | Manages a re-indexed widow earnings page from the calculation of a Social Security benefit.
ReindWid2Page | Manages a re-indexed widow calculation results page from the calculation of a Social Security benefit.
SpecMin1Page | Manages a special minimum earnings page from the calculation of a Social Security benefit.
SpecMin2Page | Manages a special minimum calculation details page from the calculation of a Social Security benefit.
Summary1Page | Manages the top part of the summary of results page from the calculation of a Social Security benefit.
Summary2Page | Manages the middle part of the summary of results page from the calculation of a Social Security benefit.
Summary3Page | Manages the bottom part of the summary of results page from the calculation of a Social Security benefit.
SummaryPage | Manages the summary page of results from the calculation of a Social Security benefit.
TaxesPage | Manages the taxes output page.
TransGuar1Page | Manages the transitional guarantee earnings page from the calculation of a Social Security benefit.
TransGuar2Page | Manages the transitional guarantee results page from the calculation of a Social Security benefit.
WageInd1Page | Manages a wage indexed earnings page from the calculation of a Social Security benefit.
WageInd2Page | Manages a wage indexed results page from the calculation of a Social Security benefit.
WageIndNonFreeze1Page | Manages a wage indexed non-freeze page from the calculation of a Social Security benefit.
WageIndNonFreeze2Page | Manages a wage indexed non-freeze results page from the calculation of a Social Security benefit.
Collapse Expand Files
Name | Description
AnypiaOut.cpp | Functions for the AnypiaOut class to manage all output pages from Anypia.
AnypiaOut.h | Declarations for the AnypiaOut class to manage all output pages from Anypia.
ChildCareCalc1Page.cpp | Functions for the ChildCareCalc1Page class to manage wage indexed earnings with child-care dropout years.
ChildCareCalc1Page.h | Declarations for the ChildCareCalc1Page class to manage wage indexed earnings with child-care dropout years.
ChildCareCalc2Page.cpp | Functions for the ChildCareCalc2Page class to manage wage indexed results with child-care dropout years.
ChildCareCalc2Page.h | Declarations for the ChildCareCalc2Page class to manage wage indexed results with child-care dropout years.
DibGuarPage.cpp | Functions for the DibGuarPage class to manage disability guarantee calculation output.
DibGuarPage.h | Declarations for the DibGuarPage class to manage disability guarantee calculation output.
EarningsPage.cpp | Functions for the EarningsPage class to manage earnings output.
EarningsPage.h | Declarations for the EarningsPage class to manage earnings output.
FamilyPage.cpp | Functions for the FamilyPage class to manage family members' benefits output.
FamilyPage.h | Declarations for the FamilyPage class to manage family members' benefits output.
FrozMinPage.cpp | Functions for the FrozMinPage class to manage frozen minimum calculation output.
FrozMinPage.h | Declarations for the FrozMinPage class to manage frozen minimum calculation output.
InsuredPage.cpp | Functions for the InsuredPage class to manage insured status output.
InsuredPage.h | Declarations for the InsuredPage class to manage insured status output.
OldStart1Page.cpp | Functions for the OldStart1Page class to manage old start calculation earnings output.
OldStart1Page.h | Declarations for the OldStart1Page class to manage old start calculation earnings output.
OldStart2Page.cpp | Functions for the OldStart2Page class to manage old start calculation results.
OldStart2Page.h | Declarations for the OldStart2Page class to manage old start calculation results.
OnePage.cpp | Functions for the OnePage class to manage one-page summary of results.
OnePage.h | Declarations for the OnePage class to manage one-page summary of results.
PebsCreditInfo.cpp | Functions for the PebsCreditInfo class to manage the Social Security Statement credit info page.
PebsCreditInfo.h | Declarations for the PebsCreditInfo class to manage the Social Security Statement credit info page.
PebsEarnings.cpp | Functions for the PebsEarnings class to manage Social Security Statement earnings page.
PebsEarnings.h | Declarations for the PebsEarnings class to manage Social Security Statement earnings page.
PebsEarningsInfo.cpp | Functions for the PebsEarningsInfo class to manage the Social Security Statement earnings info page.
PebsEarningsInfo.h | Declarations for the PebsEarningsInfo class to manage the Social Security Statement earnings info page.
PebsLetter.cpp | Functions for the PebsLetter class to manage the Social Security Statement letter page.
PebsLetter.h | Declarations for the PebsLetter class to manage the Social Security Statement letter page.
PebsOasdiEst.cpp | Functions for the PebsOasdiEst class to manage the Social Security Statement oasdi estimates info page.
PebsOasdiEst.h | Declarations for the PebsOasdiEst class to manage the Social Security Statement oasdi estimates info page.
PebsOasdiInfo.cpp | Functions for the PebsOasdiInfo class to manage the Social Security Statement oasdi benefit info page.
PebsOasdiInfo.h | Declarations for the PebsOasdiInfo class to manage the Social Security Statement oasdi benefit info page.
PebsOut.cpp | Functions for the PebsOut class to print out the Social Security Statement.
PebsOut.h | Declarations for the PebsOut class to print out the Social Security Statement.
PebsPageOut.cpp | Functions for the PebsPageOut class - parent of classes to write out results of Social Security Statement benefit calculation.
PebsPageOut.h | Declarations for the PebsPageOut class - parent of classes to write out results of Social Security Statement benefit calculation.
PebsWorkerEarnings.cpp | Functions for the PebsWorkerEarnings class to manage the Social Security Statement worker info and earnings page.
PebsWorkerEarnings.h | Declarations for the PebsWorkerEarnings class to manage the Social Security Statement worker info and earnings page.
PebsWorkerInfo.cpp | Functions for the PebsWorkerInfo class to manage the Social Security Statement worker info page.
PebsWorkerInfo.h | Declarations for the PebsWorkerInfo class to manage the Social Security Statement worker info page.
PiaOut.cpp | Functions for the PiaOut class to manage output for a non-Statement calculation.
PiaOut.h | Declarations for the PiaOut class to manage output for a non-Statement calculation.
PiaPageOut.cpp | Functions for the PiaPageOut class - parent of classes to write out results of a non-Statement benefit calculation.
PiaPageOut.h | Declarations for the PiaPageOut class - parent of classes to write out results of a non-Statement benefit calculation.
PiaTable1Page.cpp | Functions for the PiaTable1Page class to manage a pia table calculation earnings page.
PiaTable1Page.h | Declarations for the PiaTable1Page class to manage a pia table calculation earnings page.
PiaTable2Page.cpp | Functions for the PiaTable2Page class to manage a pia table calculation results page.
PiaTable2Page.h | Declarations for the PiaTable2Page class to manage a pia table calculation results page.
ReindWid1Page.cpp | Functions for the ReindWid1Page class to manage a re-indexed widow earnings page.
ReindWid1Page.h | Declarations for the ReindWid1Page class to manage a re-indexed widow earnings page.
ReindWid2Page.cpp | Functions for the ReindWid2Page class to manage a re-indexed widow calculation results page.
ReindWid2Page.h | Declarations for the ReindWid2Page class to manage a re-indexed widow calculation results page.
SpecMin1Page.cpp | Functions for the SpecMin1Page class to manage a special minimum calculation earnings page.
SpecMin1Page.h | Declarations for the SpecMin1Page class to manage a special minimum calculation earnings page.
SpecMin2Page.cpp | Functions for the SpecMin2Page class to manage a special minimum calculation results page.
SpecMin2Page.h | Declarations for the SpecMin2Page class to manage a special minimum calculation results page.
Summary1Page.cpp | Functions for the Summary1Page class to manage the top part of a summary of results page.
Summary1Page.h | Declarations for the Summary1Page class to manage the top part of a summary of results page.
Summary2Page.cpp | Functions for the Summary2Page class to manage the middle part of a summary of results page.
Summary2Page.h | Declarations for the Summary2Page class to manage the middle part of a summary of results page.
Summary3Page.cpp | Functions for the Summary3Page class to manage the bottom part of a summary of results page.
Summary3Page.h | Declarations for the Summary3Page class to manage the bottom part of a summary of results page.
SummaryPage.cpp | Functions for the SummaryPage class to manage the summary page of results.
SummaryPage.h | Declarations for the SummaryPage class to manage the summary page of results.
TaxesPage.cpp | Functions for the TaxesPage class to manage the taxes output page.
TaxesPage.h | Declarations for the TaxesPage class to manage the taxes output page.
TransGuar1Page.cpp | Functions for the TransGuar1Page class to manage the transitional guarantee calculation earnings page.
TransGuar1Page.h | Declarations for the TransGuar1Page class to manage the transitional guarantee calculation earnings page.
TransGuar2Page.cpp | Functions for the TransGuar2Page class to manage the transitional guarantee calculation results page.
TransGuar2Page.h | Declarations for the TransGuar2Page class to manage the transitional guarantee calculation results page.
WageInd1Page.cpp | Functions for the WageInd1Page class to manage a wage indexed earnings page.
WageInd1Page.h | Declarations for the WageInd1Page class to manage a wage indexed earnings page.
WageInd2Page.cpp | Functions for the WageInd2Page class to manage a wage indexed reuslts page.
WageInd2Page.h | Declarations for the WageInd2Page class to manage a wage indexed reuslts page.
WageIndNonFreeze1Page.cpp | Functions for the WageIndNonFreeze1Page class to manage a wage indexed earnings page.
WageIndNonFreeze1Page.h | Declarations for the WageIndNonFreeze1Page class to manage a wage indexed earnings page.
WageIndNonFreeze2Page.cpp | Functions for the WageIndNonFreeze2Page class to manage a wage indexed results page.
WageIndNonFreeze2Page.h | Declarations for the WageIndNonFreeze2Page class to manage a wage indexed results page.
Collapse Expand Links
Legend, Topics


Classes

Classes
Classes Legend PiaOut Library

The following table lists classes in this documentation.

Collapse Expand Classes
Name | Description
AnypiaOut | Manages all output pages from the Anypia program.
ChildCareCalc1Page | Manages wage indexed earnings from the calculation of a Social Security benefit with child-care dropout years.
ChildCareCalc2Page | Manages wage indexed results with child-care dropout years from the calculation of a Social Security benefit.
DibGuarPage | Manages the disability guarantee results from the calculation of a Social Security benefit.
EarningsPage | Manages printing of earnings used in the calculation of a Social Security benefit.
FamilyPage | Manages the results for the auxiliary beneficiaries from the calculation of a Social Security benefit.
FrozMinPage | Manages the frozen minimum results from the calculation of a Social Security benefit.
InsuredPage | Manages insured status output determined in the calculation of a Social Security benefit.
OldStart1Page | Manages old start earnings output from the calculation of a Social Security benefit.
OldStart2Page | Manages old start results from the calculation of a Social Security benefit.
OnePage | Manages one-page summary of results from the calculation of a Social Security benefit.
PebsCreditInfo | Manages the Social Security Statement credit info page.
PebsEarnings | Manages the Social Security Statement earnings page.
PebsEarningsInfo | Manages the Social Security Statement earnings info page.
PebsLetter | Manages the Social Security Statement letter page.
PebsOasdiEst | Manages the Social Security Statement oasdi estimates page.
PebsOasdiInfo | Manages the Social Security Statement oasdi benefit info page.
PebsOut | Manages the printing of the results of a Social Security Statement calculation.
PebsPageOut | Parent of classes that manage a page of Social Security Statement output.
PebsWorkerEarnings | Manages the Social Security Statement worker info and earnings info page.
PebsWorkerInfo | Manages the Social Security Statement worker info page.
PiaOut | >Manages the printing of the results of a Social Security non-Statement calculation.
PiaPageOut | Parent of classes that manage a page of output from the calculation of a non-Statement Social Security benefit.
PiaTable1Page | Manages the pia table calculation earnings page from the calculation of a Social Security benefit.
PiaTable2Page | Manages the pia table calculation results page from the calculation of a Social Security benefit.
ReindWid1Page | Manages a re-indexed widow earnings page from the calculation of a Social Security benefit.
ReindWid2Page | Manages a re-indexed widow calculation results page from the calculation of a Social Security benefit.
SpecMin1Page | Manages a special minimum earnings page from the calculation of a Social Security benefit.
SpecMin2Page | Manages a special minimum calculation details page from the calculation of a Social Security benefit.
Summary1Page | Manages the top part of the summary of results page from the calculation of a Social Security benefit.
Summary2Page | Manages the middle part of the summary of results page from the calculation of a Social Security benefit.
Summary3Page | Manages the bottom part of the summary of results page from the calculation of a Social Security benefit.
SummaryPage | Manages the summary page of results from the calculation of a Social Security benefit.
TaxesPage | Manages the taxes output page.
TransGuar1Page | Manages the transitional guarantee earnings page from the calculation of a Social Security benefit.
TransGuar2Page | Manages the transitional guarantee results page from the calculation of a Social Security benefit.
WageInd1Page | Manages a wage indexed earnings page from the calculation of a Social Security benefit.
WageInd2Page | Manages a wage indexed results page from the calculation of a Social Security benefit.
WageIndNonFreeze1Page | Manages a wage indexed non-freeze page from the calculation of a Social Security benefit.
WageIndNonFreeze2Page | Manages a wage indexed non-freeze results page from the calculation of a Social Security benefit.
Collapse Expand Module

PiaOut Library

Collapse Expand Links
Classes, Legend, PiaOut Library


AnypiaOut Class

AnypiaOut Class
AnypiaOut Methods AnypiaOut Members AnypiaOut.h Classes

Manages all output pages from the Anypia program.

Collapse Expand Class Hierarchy
  AnypiaOut
C++
class AnypiaOut;
Collapse Expand File

File: AnypiaOut.h

Module: PiaOut Library

Collapse Expand Remarks

The pages are in two objects: a PiaOut for non-Statement calculations, and a PebsOut for Statement calculations.

An instance of this class is used in the Anypia program.

Collapse Expand See Also

PiaOut, PebsOut

Collapse Expand Group

Classes

Collapse Expand Links
AnypiaOut Methods, AnypiaOut Members, AnypiaOut.h, Classes


AnypiaOut Members

AnypiaOut Members
AnypiaOut Class Legend Public Methods

The following tables list the members exposed by AnypiaOut.

Collapse Expand Class

AnypiaOut Class

Collapse Expand Public Methods
Name | Description
AnypiaOut | Constructor.
fillPageSlots | Fills out page slots.
getPage | Returns one page to print.
getPageCount | Returns number of pages to print.
setPebsOut | Sets pointer to Statement output.
setPiaCal | Sets pointer to pia calculation results.
setPiaData | Sets pointer to pia calculation data.
setPiaOut | Sets pointer to pia calculation output.
setWorkerData | Sets pointer to worker data.
Collapse Expand Links
AnypiaOut Class, Legend, Public Methods


AnypiaOut::AnypiaOut Constructor

AnypiaOut::AnypiaOut Constructor
AnypiaOut Class AnypiaOut Members AnypiaOut Class

Constructor.

C++
AnypiaOut();
Collapse Expand Class

AnypiaOut Class

Collapse Expand Links
AnypiaOut Class, AnypiaOut Members, AnypiaOut Class


AnypiaOut Methods

AnypiaOut Methods
AnypiaOut Class Legend Public Methods

The methods of the AnypiaOut class are listed here.

Collapse Expand Class

AnypiaOut Class

Collapse Expand Public Methods
Name | Description
fillPageSlots | Fills out page slots.
getPage | Returns one page to print.
getPageCount | Returns number of pages to print.
setPebsOut | Sets pointer to Statement output.
setPiaCal | Sets pointer to pia calculation results.
setPiaData | Sets pointer to pia calculation data.
setPiaOut | Sets pointer to pia calculation output.
setWorkerData | Sets pointer to worker data.
Collapse Expand Links
AnypiaOut Class, Legend, Public Methods


AnypiaOut::fillPageSlots Method

AnypiaOut::fillPageSlots Method
AnypiaOut Class AnypiaOut Members AnypiaOut Methods

Fills out page slots.

C++
void fillPageSlots(
    bool valid,
    bool longOutput
);
Collapse Expand Parameters
Parameters | Description
bool valid | True if calculated results are valid.
bool longOutput | True if long output desired.
Collapse Expand Group

AnypiaOut Methods

Collapse Expand Links
AnypiaOut Class, AnypiaOut Members, AnypiaOut Methods


AnypiaOut::getPage Method

AnypiaOut::getPage Method
AnypiaOut Class AnypiaOut Members AnypiaOut Methods

Returns one page to print.

C++
const PageOut* getPage(
    int index
) const;
Collapse Expand Parameters
Parameters | Description
int index | Index of page to print (0-based).
Collapse Expand Returns

One page to print.

Collapse Expand Group

AnypiaOut Methods

Collapse Expand Links
AnypiaOut Class, AnypiaOut Members, AnypiaOut Methods


AnypiaOut::getPageCount Method

AnypiaOut::getPageCount Method
AnypiaOut Class AnypiaOut Members AnypiaOut Methods

Returns number of pages to print.

C++
unsigned getPageCount() const;
Collapse Expand Returns

Number of pages to print.

Collapse Expand Group

AnypiaOut Methods

Collapse Expand Links
AnypiaOut Class, AnypiaOut Members, AnypiaOut Methods


AnypiaOut::setPebsOut Method

AnypiaOut::setPebsOut Method
AnypiaOut Class AnypiaOut Members AnypiaOut Methods

Sets pointer to Statement output.

C++
void setPebsOut(
    const PebsOut* newPebsOut
);
Collapse Expand Parameters
Parameters | Description
const PebsOut* newPebsOut | New Statement output.
Collapse Expand Group

AnypiaOut Methods

Collapse Expand Links
AnypiaOut Class, AnypiaOut Members, AnypiaOut Methods


AnypiaOut::setPiaCal Method

AnypiaOut::setPiaCal Method
AnypiaOut Class AnypiaOut Members AnypiaOut Methods

Sets pointer to pia calculation results.

C++
void setPiaCal(
    const PiaCalAny* newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny* newPiaCal | New pia calculation results.
Collapse Expand Group

AnypiaOut Methods

Collapse Expand Links
AnypiaOut Class, AnypiaOut Members, AnypiaOut Methods


AnypiaOut::setPiaData Method

AnypiaOut::setPiaData Method
AnypiaOut Class AnypiaOut Members AnypiaOut Methods

Sets pointer to pia calculation data.

C++
void setPiaData(
    const PiaData* newPiaData
);
Collapse Expand Parameters
Parameters | Description
const PiaData* newPiaData | New pia calculation data.
Collapse Expand Group

AnypiaOut Methods

Collapse Expand Links
AnypiaOut Class, AnypiaOut Members, AnypiaOut Methods


AnypiaOut::setPiaOut Method

AnypiaOut::setPiaOut Method
AnypiaOut Class AnypiaOut Members AnypiaOut Methods

Sets pointer to pia calculation output.

C++
void setPiaOut(
    const PiaOut* newPiaOut
);
Collapse Expand Parameters
Parameters | Description
const PiaOut* newPiaOut | New pia calculation output.
Collapse Expand Group

AnypiaOut Methods

Collapse Expand Links
AnypiaOut Class, AnypiaOut Members, AnypiaOut Methods


AnypiaOut::setWorkerData Method

AnypiaOut::setWorkerData Method
AnypiaOut Class AnypiaOut Members AnypiaOut Methods

Sets pointer to worker data.

C++
void setWorkerData(
    const WorkerData* newWorkerData
);
Collapse Expand Parameters
Parameters | Description
const WorkerData* newWorkerData | New worker data.
Collapse Expand Group

AnypiaOut Methods

Collapse Expand Links
AnypiaOut Class, AnypiaOut Members, AnypiaOut Methods


ChildCareCalc1Page Class

ChildCareCalc1Page Class
ChildCareCalc1Page Methods ChildCareCalc1Page Members ChildCareCalc1Page.h Classes

Manages wage indexed earnings from the calculation of a Social Security benefit with child-care dropout years.

Collapse Expand Class Hierarchy
  ChildCareCalc1PageChildCareCalc1PageChildCareCalc1Page
C++
class ChildCareCalc1Page : public PiaPageOut;
Collapse Expand File

File: ChildCareCalc1Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with ChildCareCalc2Page.

Collapse Expand See Also

ChildCareCalc2Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
ChildCareCalc1Page Methods, ChildCareCalc1Page Members, ChildCareCalc1Page.h, Classes


ChildCareCalc1Page Members

ChildCareCalc1Page Members
ChildCareCalc1Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by ChildCareCalc1Page.

Collapse Expand Class

ChildCareCalc1Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
ChildCareCalc1Page | Initializes ChildCareCalc1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares wage indexed strings with childcare dropout years for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~ChildCareCalc1Page | Destructor.
Collapse Expand Links
ChildCareCalc1Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


ChildCareCalc1Page::ChildCareCalc1Page Constructor

ChildCareCalc1Page::ChildCareCalc1Page Constructor
ChildCareCalc1Page Class ChildCareCalc1Page Members ChildCareCalc1Page Class

Initializes ChildCareCalc1Page.

C++
ChildCareCalc1Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

ChildCareCalc1Page Class

Collapse Expand Links
ChildCareCalc1Page Class, ChildCareCalc1Page Members, ChildCareCalc1Page Class


ChildCareCalc1Page::~ChildCareCalc1Page Destructor

ChildCareCalc1Page::~ChildCareCalc1Page Destructor
ChildCareCalc1Page Class ChildCareCalc1Page Members ChildCareCalc1Page Class

Destructor.

C++
~ChildCareCalc1Page();
Collapse Expand Class

ChildCareCalc1Page Class

Collapse Expand Links
ChildCareCalc1Page Class, ChildCareCalc1Page Members, ChildCareCalc1Page Class


ChildCareCalc1Page Methods

ChildCareCalc1Page Methods
ChildCareCalc1Page Class Legend Public Methods

The methods of the ChildCareCalc1Page class are listed here.

Collapse Expand Class

ChildCareCalc1Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares wage indexed strings with childcare dropout years for printing.
Collapse Expand Links
ChildCareCalc1Page Class, Legend, Public Methods


ChildCareCalc1Page::prepareStrings Method

ChildCareCalc1Page::prepareStrings Method
ChildCareCalc1Page Class ChildCareCalc1Page Members ChildCareCalc1Page Methods

Prepares wage indexed strings with childcare dropout years for printing.

C++
void prepareStrings();
Collapse Expand Group

ChildCareCalc1Page Methods

Collapse Expand Links
ChildCareCalc1Page Class, ChildCareCalc1Page Members, ChildCareCalc1Page Methods


ChildCareCalc2Page Class

ChildCareCalc2Page Class
ChildCareCalc2Page Data Members ChildCareCalc2Page Methods ChildCareCalc2Page Members ChildCareCalc2Page.h Classes

Manages wage indexed results with child-care dropout years from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  ChildCareCalc2PageChildCareCalc2PageChildCareCalc2Page
C++
class ChildCareCalc2Page : public PiaPageOut;
Collapse Expand File

File: ChildCareCalc2Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with ChildCareCalc1Page.

Collapse Expand See Also

ChildCareCalc1Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
ChildCareCalc2Page Data Members, ChildCareCalc2Page Methods, ChildCareCalc2Page Members, ChildCareCalc2Page.h, Classes


ChildCareCalc2Page Members

ChildCareCalc2Page Members
ChildCareCalc2Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by ChildCareCalc2Page.

Collapse Expand Class

ChildCareCalc2Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
piaCal | Pia calculation detailed data.
piaData | Pia calculation summary data.
piaParams | Pia calculation parameters.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
userAssumptions | User-specified assumptions.
workerData | Worker basic data.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
ChildCareCalc2Page | Initializes ChildCareCalc2Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares wage indexed strings with childcare dropout years for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~ChildCareCalc2Page | Destructor.
Collapse Expand Links
ChildCareCalc2Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


ChildCareCalc2Page::ChildCareCalc2Page Constructor

ChildCareCalc2Page::ChildCareCalc2Page Constructor
ChildCareCalc2Page Class ChildCareCalc2Page Members ChildCareCalc2Page Class

Initializes ChildCareCalc2Page.

C++
ChildCareCalc2Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

ChildCareCalc2Page Class

Collapse Expand Links
ChildCareCalc2Page Class, ChildCareCalc2Page Members, ChildCareCalc2Page Class


ChildCareCalc2Page::~ChildCareCalc2Page Destructor

ChildCareCalc2Page::~ChildCareCalc2Page Destructor
ChildCareCalc2Page Class ChildCareCalc2Page Members ChildCareCalc2Page Class

Destructor.

C++
~ChildCareCalc2Page();
Collapse Expand Class

ChildCareCalc2Page Class

Collapse Expand Links
ChildCareCalc2Page Class, ChildCareCalc2Page Members, ChildCareCalc2Page Class


ChildCareCalc2Page Data Members

ChildCareCalc2Page Data Members
ChildCareCalc2Page Class Legend Protected Data Members

The data members of the ChildCareCalc2Page class are listed here.

Collapse Expand Class

ChildCareCalc2Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
piaCal | Pia calculation detailed data.
piaData | Pia calculation summary data.
piaParams | Pia calculation parameters.
userAssumptions | User-specified assumptions.
workerData | Worker basic data.
Collapse Expand Links
ChildCareCalc2Page Class, Legend, Protected Data Members


ChildCareCalc2Page::piaCal Data Member

ChildCareCalc2Page::piaCal Data Member
ChildCareCalc2Page Class ChildCareCalc2Page Members ChildCareCalc2Page Data Members

Pia calculation detailed data.

C++
const PiaCalAny& piaCal;
Collapse Expand Group

ChildCareCalc2Page Data Members

Collapse Expand Links
ChildCareCalc2Page Class, ChildCareCalc2Page Members, ChildCareCalc2Page Data Members


ChildCareCalc2Page::piaData Data Member

ChildCareCalc2Page::piaData Data Member
ChildCareCalc2Page Class ChildCareCalc2Page Members ChildCareCalc2Page Data Members

Pia calculation summary data.

C++
const PiaData& piaData;
Collapse Expand Group

ChildCareCalc2Page Data Members

Collapse Expand Links
ChildCareCalc2Page Class, ChildCareCalc2Page Members, ChildCareCalc2Page Data Members


ChildCareCalc2Page::piaParams Data Member

ChildCareCalc2Page::piaParams Data Member
ChildCareCalc2Page Class ChildCareCalc2Page Members ChildCareCalc2Page Data Members

Pia calculation parameters.

C++
const PiaParams& piaParams;
Collapse Expand Group

ChildCareCalc2Page Data Members

Collapse Expand Links
ChildCareCalc2Page Class, ChildCareCalc2Page Members, ChildCareCalc2Page Data Members


ChildCareCalc2Page::userAssumptions Data Member

ChildCareCalc2Page::userAssumptions Data Member
ChildCareCalc2Page Class ChildCareCalc2Page Members ChildCareCalc2Page Data Members

User-specified assumptions.

C++
const UserAssumptions& userAssumptions;
Collapse Expand Group

ChildCareCalc2Page Data Members

Collapse Expand Links
ChildCareCalc2Page Class, ChildCareCalc2Page Members, ChildCareCalc2Page Data Members


ChildCareCalc2Page::workerData Data Member

ChildCareCalc2Page::workerData Data Member
ChildCareCalc2Page Class ChildCareCalc2Page Members ChildCareCalc2Page Data Members

Worker basic data.

C++
const WorkerDataGeneral& workerData;
Collapse Expand Group

ChildCareCalc2Page Data Members

Collapse Expand Links
ChildCareCalc2Page Class, ChildCareCalc2Page Members, ChildCareCalc2Page Data Members


ChildCareCalc2Page Methods

ChildCareCalc2Page Methods
ChildCareCalc2Page Class Legend Public Methods

The methods of the ChildCareCalc2Page class are listed here.

Collapse Expand Class

ChildCareCalc2Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares wage indexed strings with childcare dropout years for printing.
Collapse Expand Links
ChildCareCalc2Page Class, Legend, Public Methods


ChildCareCalc2Page::prepareStrings Method

ChildCareCalc2Page::prepareStrings Method
ChildCareCalc2Page Class ChildCareCalc2Page Members ChildCareCalc2Page Methods

Prepares wage indexed strings with childcare dropout years for printing.

C++
void prepareStrings();
Collapse Expand Group

ChildCareCalc2Page Methods

Collapse Expand Links
ChildCareCalc2Page Class, ChildCareCalc2Page Members, ChildCareCalc2Page Methods


DibGuarPage Class

DibGuarPage Class
DibGuarPage Methods DibGuarPage Members DibGuarPage.h Classes

Manages the disability guarantee results from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  DibGuarPageDibGuarPageDibGuarPage
C++
class DibGuarPage : public PiaPageOut;
Collapse Expand File

File: DibGuarPage.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

Collapse Expand See Also

PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
DibGuarPage Methods, DibGuarPage Members, DibGuarPage.h, Classes


DibGuarPage Members

DibGuarPage Members
DibGuarPage Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by DibGuarPage.

Collapse Expand Class

DibGuarPage Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
piamfbDeath | Prepares PIA and MFB at death in a string table.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
DibGuarPage | Initializes DibGuarPage.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares frozen minimum strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~DibGuarPage | Destructor.
Collapse Expand Links
DibGuarPage Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


DibGuarPage::DibGuarPage Constructor

DibGuarPage::DibGuarPage Constructor
DibGuarPage Class DibGuarPage Members DibGuarPage Class

Initializes DibGuarPage.

C++
DibGuarPage(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

DibGuarPage Class

Collapse Expand Links
DibGuarPage Class, DibGuarPage Members, DibGuarPage Class


DibGuarPage::~DibGuarPage Destructor

DibGuarPage::~DibGuarPage Destructor
DibGuarPage Class DibGuarPage Members DibGuarPage Class

Destructor.

C++
~DibGuarPage();
Collapse Expand Class

DibGuarPage Class

Collapse Expand Links
DibGuarPage Class, DibGuarPage Members, DibGuarPage Class


DibGuarPage Methods

DibGuarPage Methods
DibGuarPage Class Legend Protected Methods Public Methods

The methods of the DibGuarPage class are listed here.

Collapse Expand Class

DibGuarPage Class

Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
piamfbDeath | Prepares PIA and MFB at death in a string table.
Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares frozen minimum strings for printing.
Collapse Expand Links
DibGuarPage Class, Legend, Protected Methods, Public Methods


DibGuarPage::piamfbDeath Method

DibGuarPage::piamfbDeath Method
DibGuarPage Class DibGuarPage Members DibGuarPage Methods

Prepares PIA and MFB at death in a string table.

C++
void piamfbDeath(
    const PiaMethod& piaMethod
);
Collapse Expand Parameters
Parameters | Description
const PiaMethod& piaMethod | Pia calculation method.
Collapse Expand Group

DibGuarPage Methods

Collapse Expand Links
DibGuarPage Class, DibGuarPage Members, DibGuarPage Methods


DibGuarPage::prepareStrings Method

DibGuarPage::prepareStrings Method
DibGuarPage Class DibGuarPage Members DibGuarPage Methods

Prepares frozen minimum strings for printing.

C++
void prepareStrings();
Collapse Expand Group

DibGuarPage Methods

Collapse Expand Links
DibGuarPage Class, DibGuarPage Members, DibGuarPage Methods


EarningsPage Class

EarningsPage Class
EarningsPage Methods EarningsPage Members EarningsPage.h Classes

Manages printing of earnings used in the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  EarningsPageEarningsPageEarningsPage
C++
class EarningsPage : public PiaPageOut;
Collapse Expand File

File: EarningsPage.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

Collapse Expand See Also

PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
EarningsPage Methods, EarningsPage Members, EarningsPage.h, Classes


EarningsPage Members

EarningsPage Members
EarningsPage Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by EarningsPage.

Collapse Expand Class

EarningsPage Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
EarningsPage | Initializes EarningsPage.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares earnings strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~EarningsPage | Destructor.
Collapse Expand Links
EarningsPage Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


EarningsPage::EarningsPage Constructor

EarningsPage::EarningsPage Constructor
EarningsPage Class EarningsPage Members EarningsPage Class

Initializes EarningsPage.

C++
EarningsPage(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

EarningsPage Class

Collapse Expand Links
EarningsPage Class, EarningsPage Members, EarningsPage Class


EarningsPage::~EarningsPage Destructor

EarningsPage::~EarningsPage Destructor
EarningsPage Class EarningsPage Members EarningsPage Class

Destructor.

C++
~EarningsPage();
Collapse Expand Class

EarningsPage Class

Collapse Expand Links
EarningsPage Class, EarningsPage Members, EarningsPage Class


EarningsPage Methods

EarningsPage Methods
EarningsPage Class Legend Public Methods

The methods of the EarningsPage class are listed here.

Collapse Expand Class

EarningsPage Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares earnings strings for printing.
Collapse Expand Links
EarningsPage Class, Legend, Public Methods


EarningsPage::prepareStrings Method

EarningsPage::prepareStrings Method
EarningsPage Class EarningsPage Members EarningsPage Methods

Prepares earnings strings for printing.

C++
void prepareStrings();
Collapse Expand Exceptions
Exceptions | Description
PiaException | PiaException of type PIA_IDS_TWOPAGE2 if any exceptions are caught.
Collapse Expand Group

EarningsPage Methods

Collapse Expand Links
EarningsPage Class, EarningsPage Members, EarningsPage Methods


FamilyPage Class

FamilyPage Class
FamilyPage Methods FamilyPage Members FamilyPage.h Classes

Manages the results for the auxiliary beneficiaries from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  FamilyPageFamilyPageFamilyPage
C++
class FamilyPage : public PiaPageOut;
Collapse Expand File

File: FamilyPage.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

Collapse Expand See Also

PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
FamilyPage Methods, FamilyPage Members, FamilyPage.h, Classes


FamilyPage Members

FamilyPage Members
FamilyPage Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by FamilyPage.

Collapse Expand Class

FamilyPage Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
FamilyPage | Initializes FamilyPage.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares strings for family members page.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~FamilyPage | Destructor.
Collapse Expand Links
FamilyPage Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


FamilyPage::FamilyPage Constructor

FamilyPage::FamilyPage Constructor
FamilyPage Class FamilyPage Members FamilyPage Class

Initializes FamilyPage.

C++
FamilyPage(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

FamilyPage Class

Collapse Expand Links
FamilyPage Class, FamilyPage Members, FamilyPage Class


FamilyPage::~FamilyPage Destructor

FamilyPage::~FamilyPage Destructor
FamilyPage Class FamilyPage Members FamilyPage Class

Destructor.

C++
~FamilyPage();
Collapse Expand Class

FamilyPage Class

Collapse Expand Links
FamilyPage Class, FamilyPage Members, FamilyPage Class


FamilyPage Methods

FamilyPage Methods
FamilyPage Class Legend Public Methods

The methods of the FamilyPage class are listed here.

Collapse Expand Class

FamilyPage Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares strings for family members page.
Collapse Expand Links
FamilyPage Class, Legend, Public Methods


FamilyPage::prepareStrings Method

FamilyPage::prepareStrings Method
FamilyPage Class FamilyPage Members FamilyPage Methods

Prepares strings for family members page.

C++
void prepareStrings();
Collapse Expand Group

FamilyPage Methods

Collapse Expand Links
FamilyPage Class, FamilyPage Members, FamilyPage Methods


FrozMinPage Class

FrozMinPage Class
FrozMinPage Methods FrozMinPage Members FrozMinPage.h Classes

Manages the frozen minimum results from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  FrozMinPageFrozMinPageFrozMinPage
C++
class FrozMinPage : public PiaPageOut;
Collapse Expand File

File: FrozMinPage.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

Collapse Expand See Also

PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
FrozMinPage Methods, FrozMinPage Members, FrozMinPage.h, Classes


FrozMinPage Members

FrozMinPage Members
FrozMinPage Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by FrozMinPage.

Collapse Expand Class

FrozMinPage Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
FrozMinPage | Initializes FrozMinPage.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares frozen minimum strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~FrozMinPage | Destructor.
Collapse Expand Links
FrozMinPage Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


FrozMinPage::FrozMinPage Constructor

FrozMinPage::FrozMinPage Constructor
FrozMinPage Class FrozMinPage Members FrozMinPage Class

Initializes FrozMinPage.

C++
FrozMinPage(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

FrozMinPage Class

Collapse Expand Links
FrozMinPage Class, FrozMinPage Members, FrozMinPage Class


FrozMinPage::~FrozMinPage Destructor

FrozMinPage::~FrozMinPage Destructor
FrozMinPage Class FrozMinPage Members FrozMinPage Class

Destructor.

C++
~FrozMinPage();
Collapse Expand Class

FrozMinPage Class

Collapse Expand Links
FrozMinPage Class, FrozMinPage Members, FrozMinPage Class


FrozMinPage Methods

FrozMinPage Methods
FrozMinPage Class Legend Public Methods

The methods of the FrozMinPage class are listed here.

Collapse Expand Class

FrozMinPage Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares frozen minimum strings for printing.
Collapse Expand Links
FrozMinPage Class, Legend, Public Methods


FrozMinPage::prepareStrings Method

FrozMinPage::prepareStrings Method
FrozMinPage Class FrozMinPage Members FrozMinPage Methods

Prepares frozen minimum strings for printing.

C++
void prepareStrings();
Collapse Expand Group

FrozMinPage Methods

Collapse Expand Links
FrozMinPage Class, FrozMinPage Members, FrozMinPage Methods


InsuredPage Class

InsuredPage Class
InsuredPage Methods InsuredPage Members InsuredPage.h Classes

Manages insured status output determined in the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  InsuredPageInsuredPageInsuredPage
C++
class InsuredPage : public PiaPageOut;
Collapse Expand File

File: InsuredPage.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

Collapse Expand See Also

PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
InsuredPage Methods, InsuredPage Members, InsuredPage.h, Classes


InsuredPage Members

InsuredPage Members
InsuredPage Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by InsuredPage.

Collapse Expand Class

InsuredPage Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
InsuredPage | Initializes InsuredPage.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares strings for insured status page.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~InsuredPage | Destructor.
Collapse Expand Links
InsuredPage Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


InsuredPage::InsuredPage Constructor

InsuredPage::InsuredPage Constructor
InsuredPage Class InsuredPage Members InsuredPage Class

Initializes InsuredPage.

C++
InsuredPage(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

InsuredPage Class

Collapse Expand Links
InsuredPage Class, InsuredPage Members, InsuredPage Class


InsuredPage::~InsuredPage Destructor

InsuredPage::~InsuredPage Destructor
InsuredPage Class InsuredPage Members InsuredPage Class

Destructor.

C++
~InsuredPage();
Collapse Expand Class

InsuredPage Class

Collapse Expand Links
InsuredPage Class, InsuredPage Members, InsuredPage Class


InsuredPage Methods

InsuredPage Methods
InsuredPage Class Legend Public Methods

The methods of the InsuredPage class are listed here.

Collapse Expand Class

InsuredPage Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares strings for insured status page.
Collapse Expand Links
InsuredPage Class, Legend, Public Methods


InsuredPage::prepareStrings Method

InsuredPage::prepareStrings Method
InsuredPage Class InsuredPage Members InsuredPage Methods

Prepares strings for insured status page.

C++
void prepareStrings();
Collapse Expand Group

InsuredPage Methods

Collapse Expand Links
InsuredPage Class, InsuredPage Members, InsuredPage Methods


OldStart1Page Class

OldStart1Page Class
OldStart1Page Methods OldStart1Page Members OldStart1Page.h Classes

Manages old start earnings output from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  OldStart1PageOldStart1PageOldStart1Page
C++
class OldStart1Page : public PiaPageOut;
Collapse Expand File

File: OldStart1Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with OldStart2Page.

Collapse Expand See Also

OldStart2Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
OldStart1Page Methods, OldStart1Page Members, OldStart1Page.h, Classes


OldStart1Page Members

OldStart1Page Members
OldStart1Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by OldStart1Page.

Collapse Expand Class

OldStart1Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
OldStart1Page | Initializes OldStart1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares old start strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~OldStart1Page | Destructor.
Collapse Expand Links
OldStart1Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


OldStart1Page::OldStart1Page Constructor

OldStart1Page::OldStart1Page Constructor
OldStart1Page Class OldStart1Page Members OldStart1Page Class

Initializes OldStart1Page.

C++
OldStart1Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

OldStart1Page Class

Collapse Expand Links
OldStart1Page Class, OldStart1Page Members, OldStart1Page Class


OldStart1Page::~OldStart1Page Destructor

OldStart1Page::~OldStart1Page Destructor
OldStart1Page Class OldStart1Page Members OldStart1Page Class

Destructor.

C++
~OldStart1Page();
Collapse Expand Class

OldStart1Page Class

Collapse Expand Links
OldStart1Page Class, OldStart1Page Members, OldStart1Page Class


OldStart1Page Methods

OldStart1Page Methods
OldStart1Page Class Legend Public Methods

The methods of the OldStart1Page class are listed here.

Collapse Expand Class

OldStart1Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares old start strings for printing.
Collapse Expand Links
OldStart1Page Class, Legend, Public Methods


OldStart1Page::prepareStrings Method

OldStart1Page::prepareStrings Method
OldStart1Page Class OldStart1Page Members OldStart1Page Methods

Prepares old start strings for printing.

C++
void prepareStrings();
Collapse Expand Group

OldStart1Page Methods

Collapse Expand Links
OldStart1Page Class, OldStart1Page Members, OldStart1Page Methods


OldStart2Page Class

OldStart2Page Class
OldStart2Page Methods OldStart2Page Members OldStart2Page.h Classes

Manages old start results from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  OldStart2PageOldStart2PageOldStart2Page
C++
class OldStart2Page : public PiaPageOut;
Collapse Expand File

File: OldStart2Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with OldStart1Page.

Collapse Expand See Also

OldStart1Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
OldStart2Page Methods, OldStart2Page Members, OldStart2Page.h, Classes


OldStart2Page Members

OldStart2Page Members
OldStart2Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by OldStart2Page.

Collapse Expand Class

OldStart2Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
OldStart2Page | Initializes OldStart2Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares old start strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~OldStart2Page | Destructor.
Collapse Expand Links
OldStart2Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


OldStart2Page::OldStart2Page Constructor

OldStart2Page::OldStart2Page Constructor
OldStart2Page Class OldStart2Page Members OldStart2Page Class

Initializes OldStart2Page.

C++
OldStart2Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

OldStart2Page Class

Collapse Expand Links
OldStart2Page Class, OldStart2Page Members, OldStart2Page Class


OldStart2Page::~OldStart2Page Destructor

OldStart2Page::~OldStart2Page Destructor
OldStart2Page Class OldStart2Page Members OldStart2Page Class

Destructor.

C++
~OldStart2Page();
Collapse Expand Class

OldStart2Page Class

Collapse Expand Links
OldStart2Page Class, OldStart2Page Members, OldStart2Page Class


OldStart2Page Methods

OldStart2Page Methods
OldStart2Page Class Legend Public Methods

The methods of the OldStart2Page class are listed here.

Collapse Expand Class

OldStart2Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares old start strings for printing.
pubPenOut | Prepares windfall calculation.
Collapse Expand Links
OldStart2Page Class, Legend, Public Methods


OldStart2Page::prepareStrings Method

OldStart2Page::prepareStrings Method
OldStart2Page Class OldStart2Page Members OldStart2Page Methods

Prepares old start strings for printing.

C++
void prepareStrings();
Collapse Expand Group

OldStart2Page Methods

Collapse Expand Links
OldStart2Page Class, OldStart2Page Members, OldStart2Page Methods


OldStart2Page::pubPenOut Method

OldStart2Page::pubPenOut Method
OldStart2Page Class OldStart2Page Members OldStart2Page Methods

Prepares windfall calculation.

C++
void pubPenOut(
    const OldStart& oldStart,
    double pubpen,
    const DateMoyr& pubpenDate
);
Collapse Expand Parameters
Parameters | Description
const OldStart& oldStart | Old-start calculation method.
double pubpen | Amount of public pension.
const DateMoyr& pubpenDate | Starting date of public pension.
Collapse Expand Group

OldStart2Page Methods

Collapse Expand Links
OldStart2Page Class, OldStart2Page Members, OldStart2Page Methods


OnePage Class

OnePage Class
OnePage Methods OnePage Members OnePage.h Classes

Manages one-page summary of results from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  OnePageOnePageOnePage
C++
class OnePage : public PiaPageOut;
Collapse Expand File

File: OnePage.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

Collapse Expand See Also

PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
OnePage Methods, OnePage Members, OnePage.h, Classes


OnePage Members

OnePage Members
OnePage Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by OnePage.

Collapse Expand Class

OnePage Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
OnePage | Initializes OnePage.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares strings for 1-page summary.
print | Writes the output strings to the specified device.
printEarn | Prepares table of earnings.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~OnePage | Destructor.
Collapse Expand Links
OnePage Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


OnePage::OnePage Constructor

OnePage::OnePage Constructor
OnePage Class OnePage Members OnePage Class

Initializes OnePage.

C++
OnePage(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

OnePage Class

Collapse Expand Links
OnePage Class, OnePage Members, OnePage Class


OnePage::~OnePage Destructor

OnePage::~OnePage Destructor
OnePage Class OnePage Members OnePage Class

Destructor.

C++
~OnePage();
Collapse Expand Class

OnePage Class

Collapse Expand Links
OnePage Class, OnePage Members, OnePage Class


OnePage Methods

OnePage Methods
OnePage Class Legend Public Methods

The methods of the OnePage class are listed here.

Collapse Expand Class

OnePage Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares strings for 1-page summary.
printEarn | Prepares table of earnings.
Collapse Expand Links
OnePage Class, Legend, Public Methods


OnePage::prepareStrings Method

OnePage::prepareStrings Method
OnePage Class OnePage Members OnePage Methods

Prepares strings for 1-page summary.

C++
void prepareStrings();
Collapse Expand Group

OnePage Methods

Collapse Expand Links
OnePage Class, OnePage Members, OnePage Methods


OnePage::printEarn Method

OnePage::printEarn Method
OnePage Class OnePage Members OnePage Methods

Prepares table of earnings.

C++
void printEarn(
    int firstyr,
    int lastyr,
    int tier
);
Collapse Expand Parameters
Parameters | Description
int firstyr | First year of earnings.
int lastyr | Last year of earnings
int tier | Tier of table to prepare.
Collapse Expand Remarks

There are two tiers of the table, as follows:

0 | actual earnings.
1 | indexed earnings.
Collapse Expand Group

OnePage Methods

Collapse Expand Links
OnePage Class, OnePage Members, OnePage Methods


PebsCreditInfo Class

PebsCreditInfo Class
PebsCreditInfo Methods PebsCreditInfo Members PebsCreditInfo.h Classes

Manages the Social Security Statement credit info page.

Collapse Expand Class Hierarchy
  PebsCreditInfoPebsCreditInfoPebsCreditInfo
C++
class PebsCreditInfo : public PebsPageOut;
Collapse Expand File

File: PebsCreditInfo.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PebsOut.

Collapse Expand See Also

PebsOut

Collapse Expand Group

Classes

Collapse Expand Links
PebsCreditInfo Methods, PebsCreditInfo Members, PebsCreditInfo.h, Classes


PebsCreditInfo Members

PebsCreditInfo Members
PebsCreditInfo Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PebsCreditInfo.

Collapse Expand Class

PebsCreditInfo Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
equals | String of equals signs.
hyphens | String of hyphens.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PebsCreditInfo | Initializes this instance.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareHeader | Prepares header string for output.
prepareStrings | Prepares general credit and tax information for printing.
print | Writes the output strings to the specified device.
setPageNum | Sets page number.
~PebsCreditInfo | Destructor.
Collapse Expand Links
PebsCreditInfo Class, Legend, Protected Data Members, Public Data Members, Public Methods


PebsCreditInfo::PebsCreditInfo Constructor

PebsCreditInfo::PebsCreditInfo Constructor
PebsCreditInfo Class PebsCreditInfo Members PebsCreditInfo Class

Initializes this instance.

C++
PebsCreditInfo(
    const WorkerData& newWorkerData,
    const PiaParams& newPiaParams
);
Collapse Expand Parameters
Parameters | Description
const WorkerData& newWorkerData | Worker data.
const PiaParams& newPiaParams | Pia calculation parameters.
Collapse Expand Class

PebsCreditInfo Class

Collapse Expand Links
PebsCreditInfo Class, PebsCreditInfo Members, PebsCreditInfo Class


PebsCreditInfo::~PebsCreditInfo Destructor

PebsCreditInfo::~PebsCreditInfo Destructor
PebsCreditInfo Class PebsCreditInfo Members PebsCreditInfo Class

Destructor.

C++
~PebsCreditInfo();
Collapse Expand Class

PebsCreditInfo Class

Collapse Expand Links
PebsCreditInfo Class, PebsCreditInfo Members, PebsCreditInfo Class


PebsCreditInfo Methods

PebsCreditInfo Methods
PebsCreditInfo Class Legend Public Methods

The methods of the PebsCreditInfo class are listed here.

Collapse Expand Class

PebsCreditInfo Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares general credit and tax information for printing.
Collapse Expand Links
PebsCreditInfo Class, Legend, Public Methods


PebsCreditInfo::prepareStrings Method

PebsCreditInfo::prepareStrings Method
PebsCreditInfo Class PebsCreditInfo Members PebsCreditInfo Methods

Prepares general credit and tax information for printing.

C++
void prepareStrings();
Collapse Expand Group

PebsCreditInfo Methods

Collapse Expand Links
PebsCreditInfo Class, PebsCreditInfo Members, PebsCreditInfo Methods


PebsEarnings Class

PebsEarnings Class
PebsEarnings Methods PebsEarnings Members PebsEarnings.h Classes

Manages the Social Security Statement earnings page.

Collapse Expand Class Hierarchy
  PebsEarningsPebsEarningsPebsEarnings
C++
class PebsEarnings : public PebsPageOut;
Collapse Expand File

File: PebsEarnings.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PebsOut.

Collapse Expand See Also

PebsOut

Collapse Expand Group

Classes

Collapse Expand Links
PebsEarnings Methods, PebsEarnings Members, PebsEarnings.h, Classes


PebsEarnings Members

PebsEarnings Members
PebsEarnings Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PebsEarnings.

Collapse Expand Class

PebsEarnings Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
equals | String of equals signs.
hyphens | String of hyphens.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PebsEarnings | Initializes PebsEarnings.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareHeader | Prepares header string for output.
prepareStrings | Prepares page of earnings for printing.
print | Writes the output strings to the specified device.
setPageNum | Sets page number.
~PebsEarnings | Destructor.
Collapse Expand Links
PebsEarnings Class, Legend, Protected Data Members, Public Data Members, Public Methods


PebsEarnings::PebsEarnings Constructor

PebsEarnings::PebsEarnings Constructor
PebsEarnings Class PebsEarnings Members PebsEarnings Class

Initializes PebsEarnings.

C++
PebsEarnings(
    const WorkerData& newWorkerData,
    const PiaData& newPiaData,
    const PiaParams& newPiaParams,
    const TaxData& newTaxData
);
Collapse Expand Parameters
Parameters | Description
const WorkerData& newWorkerData | Worker basic data.
const PiaData& newPiaData | Pia calculation data.
const PiaParams& newPiaParams | Pia calculation parameters.
const TaxData& newTaxData | Taxes paid.
Collapse Expand Class

PebsEarnings Class

Collapse Expand Links
PebsEarnings Class, PebsEarnings Members, PebsEarnings Class


PebsEarnings::~PebsEarnings Destructor

PebsEarnings::~PebsEarnings Destructor
PebsEarnings Class PebsEarnings Members PebsEarnings Class

Destructor.

C++
~PebsEarnings();
Collapse Expand Class

PebsEarnings Class

Collapse Expand Links
PebsEarnings Class, PebsEarnings Members, PebsEarnings Class


PebsEarnings Methods

PebsEarnings Methods
PebsEarnings Class Legend Public Methods

The methods of the PebsEarnings class are listed here.

Collapse Expand Class

PebsEarnings Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares page of earnings for printing.
Collapse Expand Links
PebsEarnings Class, Legend, Public Methods


PebsEarnings::prepareStrings Method

PebsEarnings::prepareStrings Method
PebsEarnings Class PebsEarnings Members PebsEarnings Methods

Prepares page of earnings for printing.

C++
void prepareStrings();
Collapse Expand Group

PebsEarnings Methods

Collapse Expand Links
PebsEarnings Class, PebsEarnings Members, PebsEarnings Methods


PebsEarningsInfo Class

PebsEarningsInfo Class
PebsEarningsInfo Methods PebsEarningsInfo Members PebsEarningsInfo.h Classes

Manages the Social Security Statement earnings info page.

Collapse Expand Class Hierarchy
  PebsEarningsInfoPebsEarningsInfoPebsEarningsInfo
C++
class PebsEarningsInfo : public PebsPageOut;
Collapse Expand File

File: PebsEarningsInfo.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PebsOut.

Collapse Expand See Also

PebsOut

Collapse Expand Group

Classes

Collapse Expand Links
PebsEarningsInfo Methods, PebsEarningsInfo Members, PebsEarningsInfo.h, Classes


PebsEarningsInfo Members

PebsEarningsInfo Members
PebsEarningsInfo Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PebsEarningsInfo.

Collapse Expand Class

PebsEarningsInfo Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
equals | String of equals signs.
hyphens | String of hyphens.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PebsEarningsInfo | Initializes this instance.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareHeader | Prepares header string for output.
prepareStrings | Prepares earnings info for printing.
print | Writes the output strings to the specified device.
setPageNum | Sets page number.
~PebsEarningsInfo | Destructor.
Collapse Expand Links
PebsEarningsInfo Class, Legend, Protected Data Members, Public Data Members, Public Methods


PebsEarningsInfo::PebsEarningsInfo Constructor

PebsEarningsInfo::PebsEarningsInfo Constructor
PebsEarningsInfo Class PebsEarningsInfo Members PebsEarningsInfo Class

Initializes this instance.

C++
PebsEarningsInfo(
    const PiaParams& newPiaParams
);
Collapse Expand Parameters
Parameters | Description
const PiaParams& newPiaParams | Pia calculation parameters.
Collapse Expand Class

PebsEarningsInfo Class

Collapse Expand Links
PebsEarningsInfo Class, PebsEarningsInfo Members, PebsEarningsInfo Class


PebsEarningsInfo::~PebsEarningsInfo Destructor

PebsEarningsInfo::~PebsEarningsInfo Destructor
PebsEarningsInfo Class PebsEarningsInfo Members PebsEarningsInfo Class

Destructor.

C++
~PebsEarningsInfo();
Collapse Expand Class

PebsEarningsInfo Class

Collapse Expand Links
PebsEarningsInfo Class, PebsEarningsInfo Members, PebsEarningsInfo Class


PebsEarningsInfo Methods

PebsEarningsInfo Methods
PebsEarningsInfo Class Legend Public Methods

The methods of the PebsEarningsInfo class are listed here.

Collapse Expand Class

PebsEarningsInfo Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares earnings info for printing.
Collapse Expand Links
PebsEarningsInfo Class, Legend, Public Methods


PebsEarningsInfo::prepareStrings Method

PebsEarningsInfo::prepareStrings Method
PebsEarningsInfo Class PebsEarningsInfo Members PebsEarningsInfo Methods

Prepares earnings info for printing.

C++
void prepareStrings();
Collapse Expand Group

PebsEarningsInfo Methods

Collapse Expand Links
PebsEarningsInfo Class, PebsEarningsInfo Members, PebsEarningsInfo Methods


PebsLetter Class

PebsLetter Class
PebsLetter Methods PebsLetter Members PebsLetter.h Classes

Manages the Social Security Statement letter page.

Collapse Expand Class Hierarchy
  PebsLetterPebsLetterPebsLetter
C++
class PebsLetter : public PebsPageOut;
Collapse Expand File

File: PebsLetter.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PebsOut.

Collapse Expand See Also

PebsOut

Collapse Expand Group

Classes

Collapse Expand Links
PebsLetter Methods, PebsLetter Members, PebsLetter.h, Classes


PebsLetter Members

PebsLetter Members
PebsLetter Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PebsLetter.

Collapse Expand Class

PebsLetter Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
equals | String of equals signs.
hyphens | String of hyphens.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PebsLetter | Initializes this instance.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareHeader | Prepares header string for output.
prepareStrings | Prepares letter for printing.
print | Writes the output strings to the specified device.
setPageNum | Sets page number.
~PebsLetter | Destructor.
Collapse Expand Links
PebsLetter Class, Legend, Protected Data Members, Public Data Members, Public Methods


PebsLetter::PebsLetter Constructor

PebsLetter::PebsLetter Constructor
PebsLetter Class PebsLetter Members PebsLetter Class

Initializes this instance.

C++
PebsLetter(
    const WorkerData& newWorkerData,
    const FieldOfficeInfo& newFieldOfficeInfo
);
Collapse Expand Parameters
Parameters | Description
const WorkerData& newWorkerData | Worker data.
const FieldOfficeInfo& newFieldOfficeInfo | Field office information.
Collapse Expand Class

PebsLetter Class

Collapse Expand Links
PebsLetter Class, PebsLetter Members, PebsLetter Class


PebsLetter::~PebsLetter Destructor

PebsLetter::~PebsLetter Destructor
PebsLetter Class PebsLetter Members PebsLetter Class

Destructor.

C++
~PebsLetter();
Collapse Expand Class

PebsLetter Class

Collapse Expand Links
PebsLetter Class, PebsLetter Members, PebsLetter Class


PebsLetter Methods

PebsLetter Methods
PebsLetter Class Legend Public Methods

The methods of the PebsLetter class are listed here.

Collapse Expand Class

PebsLetter Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares letter for printing.
Collapse Expand Links
PebsLetter Class, Legend, Public Methods


PebsLetter::prepareStrings Method

PebsLetter::prepareStrings Method
PebsLetter Class PebsLetter Members PebsLetter Methods

Prepares letter for printing.

C++
void prepareStrings();
Collapse Expand Group

PebsLetter Methods

Collapse Expand Links
PebsLetter Class, PebsLetter Members, PebsLetter Methods


PebsOasdiEst Class

PebsOasdiEst Class
PebsOasdiEst Methods PebsOasdiEst Members PebsOasdiEst.h Classes

Manages the Social Security Statement oasdi estimates page.

Collapse Expand Class Hierarchy
  PebsOasdiEstPebsOasdiEstPebsOasdiEst
C++
class PebsOasdiEst : public PebsPageOut;
Collapse Expand File

File: PebsOasdiEst.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PebsOut.

Collapse Expand See Also

PebsOut

Collapse Expand Group

Classes

Collapse Expand Links
PebsOasdiEst Methods, PebsOasdiEst Members, PebsOasdiEst.h, Classes


PebsOasdiEst Members

PebsOasdiEst Members
PebsOasdiEst Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PebsOasdiEst.

Collapse Expand Class

PebsOasdiEst Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
equals | String of equals signs.
hyphens | String of hyphens.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PebsOasdiEst | Initializes PebsOasdiEst.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareHeader | Prepares header string for output.
prepareStrings | Prepares OASI estimates for printing.
print | Writes the output strings to the specified device.
setPageNum | Sets page number.
~PebsOasdiEst | Destructor.
Collapse Expand Links
PebsOasdiEst Class, Legend, Protected Data Members, Public Data Members, Public Methods


PebsOasdiEst::PebsOasdiEst Constructor

PebsOasdiEst::PebsOasdiEst Constructor
PebsOasdiEst Class PebsOasdiEst Members PebsOasdiEst Class

Initializes PebsOasdiEst.

C++
PebsOasdiEst(
    const WorkerData& newWorkerData,
    const Pebs& newPebs
);
Collapse Expand Parameters
Parameters | Description
const WorkerData& newWorkerData | Worker data.
const Pebs& newPebs | Social Security Statement information.
Collapse Expand Class

PebsOasdiEst Class

Collapse Expand Links
PebsOasdiEst Class, PebsOasdiEst Members, PebsOasdiEst Class


PebsOasdiEst::~PebsOasdiEst Destructor

PebsOasdiEst::~PebsOasdiEst Destructor
PebsOasdiEst Class PebsOasdiEst Members PebsOasdiEst Class

Destructor.

C++
~PebsOasdiEst();
Collapse Expand Class

PebsOasdiEst Class

Collapse Expand Links
PebsOasdiEst Class, PebsOasdiEst Members, PebsOasdiEst Class


PebsOasdiEst Methods

PebsOasdiEst Methods
PebsOasdiEst Class Legend Public Methods

The methods of the PebsOasdiEst class are listed here.

Collapse Expand Class

PebsOasdiEst Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares OASI estimates for printing.
Collapse Expand Links
PebsOasdiEst Class, Legend, Public Methods


PebsOasdiEst::prepareStrings Method

PebsOasdiEst::prepareStrings Method
PebsOasdiEst Class PebsOasdiEst Members PebsOasdiEst Methods

Prepares OASI estimates for printing.

C++
void prepareStrings();
Collapse Expand Group

PebsOasdiEst Methods

Collapse Expand Links
PebsOasdiEst Class, PebsOasdiEst Members, PebsOasdiEst Methods


PebsOasdiInfo Class

PebsOasdiInfo Class
PebsOasdiInfo Methods PebsOasdiInfo Members PebsOasdiInfo.h Classes

Manages the Social Security Statement oasdi benefit info page.

Collapse Expand Class Hierarchy
  PebsOasdiInfoPebsOasdiInfoPebsOasdiInfo
C++
class PebsOasdiInfo : public PebsPageOut;
Collapse Expand File

File: PebsOasdiInfo.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PebsOut.

Collapse Expand See Also

PebsOut

Collapse Expand Group

Classes

Collapse Expand Links
PebsOasdiInfo Methods, PebsOasdiInfo Members, PebsOasdiInfo.h, Classes


PebsOasdiInfo Members

PebsOasdiInfo Members
PebsOasdiInfo Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PebsOasdiInfo.

Collapse Expand Class

PebsOasdiInfo Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
equals | String of equals signs.
hyphens | String of hyphens.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PebsOasdiInfo | Initializes PebsOasdiInfo.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareHeader | Prepares header string for output.
prepareStrings | Prepares oasdi benefit estimate information.
print | Writes the output strings to the specified device.
setPageNum | Sets page number.
~PebsOasdiInfo | Destructor.
Collapse Expand Links
PebsOasdiInfo Class, Legend, Protected Data Members, Public Data Members, Public Methods


PebsOasdiInfo::PebsOasdiInfo Constructor

PebsOasdiInfo::PebsOasdiInfo Constructor
PebsOasdiInfo Class PebsOasdiInfo Members PebsOasdiInfo Class

Initializes PebsOasdiInfo.

C++
PebsOasdiInfo(
    const WorkerData& newWorkerData
);
Collapse Expand Parameters
Parameters | Description
const WorkerData& newWorkerData | Worker data.
Collapse Expand Class

PebsOasdiInfo Class

Collapse Expand Links
PebsOasdiInfo Class, PebsOasdiInfo Members, PebsOasdiInfo Class


PebsOasdiInfo::~PebsOasdiInfo Destructor

PebsOasdiInfo::~PebsOasdiInfo Destructor
PebsOasdiInfo Class PebsOasdiInfo Members PebsOasdiInfo Class

Destructor.

C++
~PebsOasdiInfo();
Collapse Expand Class

PebsOasdiInfo Class

Collapse Expand Links
PebsOasdiInfo Class, PebsOasdiInfo Members, PebsOasdiInfo Class


PebsOasdiInfo Methods

PebsOasdiInfo Methods
PebsOasdiInfo Class Legend Public Methods

The methods of the PebsOasdiInfo class are listed here.

Collapse Expand Class

PebsOasdiInfo Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares oasdi benefit estimate information.
Collapse Expand Links
PebsOasdiInfo Class, Legend, Public Methods


PebsOasdiInfo::prepareStrings Method

PebsOasdiInfo::prepareStrings Method
PebsOasdiInfo Class PebsOasdiInfo Members PebsOasdiInfo Methods

Prepares oasdi benefit estimate information.

C++
void prepareStrings();
Collapse Expand Group

PebsOasdiInfo Methods

Collapse Expand Links
PebsOasdiInfo Class, PebsOasdiInfo Members, PebsOasdiInfo Methods


PebsOut Class

PebsOut Class
PebsOut Data Members PebsOut Methods PebsOut Members PebsOut.h Classes

Manages the printing of the results of a Social Security Statement calculation.

Collapse Expand Class Hierarchy
  PebsOut
C++
class PebsOut;
Collapse Expand File

File: PebsOut.h

Module: PiaOut Library

Collapse Expand Remarks

It contains an instance of each of the pages of output related to a Social Security Statement. For a similar class that contains an instance of each of the pages of output related to a non-Statement calculation, see PiaOut.

Collapse Expand See Also

PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
PebsOut Data Members, PebsOut Methods, PebsOut Members, PebsOut.h, Classes


PebsOut Members

PebsOut Members
PebsOut Class Legend Public Data Members Public Methods

The following tables list the members exposed by PebsOut.

Collapse Expand Class

PebsOut Class

Collapse Expand Public Data Members
Name | Description
pebsCreditInfo | Credit information.
pebsEarnings | Earnings information.
pebsEarningsInfo | Earnings information.
pebsLetter | Letter transmitting results.
pebsOasdiEst | OASDI estimates.
pebsOasdiInfo | OASDI benefit information.
pebsWorkerEarnings | Worker information and earnings.
pebsWorkerInfo | Worker information.
Collapse Expand Public Methods
Name | Description
PebsOut | Initializes PebsOut instance.
prepareStrings | Prepares strings for printing.
setPageNum | Fills out page numbers.
~PebsOut | Destructor.
Collapse Expand Links
PebsOut Class, Legend, Public Data Members, Public Methods


PebsOut::PebsOut Constructor

PebsOut::PebsOut Constructor
PebsOut Class PebsOut Members PebsOut Class

Initializes PebsOut instance.

C++
PebsOut(
    const WorkerData& newWorkerData,
    const PiaData& newPiaData,
    const FieldOfficeInfo& newFieldOfficeInfo,
    const Pebs& newPebs,
    const PiaParams& newPiaParams,
    const TaxData& newTaxData,
    const EarnProject& newEarnProject
);
Collapse Expand Parameters
Parameters | Description
const WorkerData& newWorkerData | Worker data.
const PiaData& newPiaData | Pia calculation data.
const FieldOfficeInfo& newFieldOfficeInfo | Field office information.
const Pebs& newPebs | Social Security Statement data.
const PiaParams& newPiaParams | Pia calculation parameters.
const TaxData& newTaxData | Taxes paid.
const EarnProject& newEarnProject | Projected earnings information.
Collapse Expand Class

PebsOut Class

Collapse Expand Links
PebsOut Class, PebsOut Members, PebsOut Class


PebsOut::~PebsOut Destructor

PebsOut::~PebsOut Destructor
PebsOut Class PebsOut Members PebsOut Class

Destructor.

C++
~PebsOut();
Collapse Expand Class

PebsOut Class

Collapse Expand Links
PebsOut Class, PebsOut Members, PebsOut Class


PebsOut Data Members

PebsOut Data Members
PebsOut Class Legend Public Data Members

The data members of the PebsOut class are listed here.

Collapse Expand Class

PebsOut Class

Collapse Expand Public Data Members
Name | Description
pebsCreditInfo | Credit information.
pebsEarnings | Earnings information.
pebsEarningsInfo | Earnings information.
pebsLetter | Letter transmitting results.
pebsOasdiEst | OASDI estimates.
pebsOasdiInfo | OASDI benefit information.
pebsWorkerEarnings | Worker information and earnings.
pebsWorkerInfo | Worker information.
Collapse Expand Links
PebsOut Class, Legend, Public Data Members


PebsOut::pebsCreditInfo Data Member

PebsOut::pebsCreditInfo Data Member
PebsOut Class PebsOut Members PebsOut Data Members

Credit information.

C++
PebsCreditInfo pebsCreditInfo;
Collapse Expand Group

PebsOut Data Members

Collapse Expand Links
PebsOut Class, PebsOut Members, PebsOut Data Members


PebsOut::pebsEarnings Data Member

PebsOut::pebsEarnings Data Member
PebsOut Class PebsOut Members PebsOut Data Members

Earnings information.

C++
PebsEarnings pebsEarnings;
Collapse Expand Group

PebsOut Data Members

Collapse Expand Links
PebsOut Class, PebsOut Members, PebsOut Data Members


PebsOut::pebsEarningsInfo Data Member

PebsOut::pebsEarningsInfo Data Member
PebsOut Class PebsOut Members PebsOut Data Members

Earnings information.

C++
PebsEarningsInfo pebsEarningsInfo;
Collapse Expand Group

PebsOut Data Members

Collapse Expand Links
PebsOut Class, PebsOut Members, PebsOut Data Members


PebsOut::pebsLetter Data Member

PebsOut::pebsLetter Data Member
PebsOut Class PebsOut Members PebsOut Data Members

Letter transmitting results.

C++
PebsLetter pebsLetter;
Collapse Expand Group

PebsOut Data Members

Collapse Expand Links
PebsOut Class, PebsOut Members, PebsOut Data Members


PebsOut::pebsOasdiEst Data Member

PebsOut::pebsOasdiEst Data Member
PebsOut Class PebsOut Members PebsOut Data Members

OASDI estimates.

C++
PebsOasdiEst pebsOasdiEst;
Collapse Expand Group

PebsOut Data Members

Collapse Expand Links
PebsOut Class, PebsOut Members, PebsOut Data Members


PebsOut::pebsOasdiInfo Data Member

PebsOut::pebsOasdiInfo Data Member
PebsOut Class PebsOut Members PebsOut Data Members

OASDI benefit information.

C++
PebsOasdiInfo pebsOasdiInfo;
Collapse Expand Group

PebsOut Data Members

Collapse Expand Links
PebsOut Class, PebsOut Members, PebsOut Data Members


PebsOut::pebsWorkerEarnings Data Member

PebsOut::pebsWorkerEarnings Data Member
PebsOut Class PebsOut Members PebsOut Data Members

Worker information and earnings.

C++
PebsWorkerEarnings pebsWorkerEarnings;
Collapse Expand Group

PebsOut Data Members

Collapse Expand Links
PebsOut Class, PebsOut Members, PebsOut Data Members


PebsOut::pebsWorkerInfo Data Member

PebsOut::pebsWorkerInfo Data Member
PebsOut Class PebsOut Members PebsOut Data Members

Worker information.

C++
PebsWorkerInfo pebsWorkerInfo;
Collapse Expand Group

PebsOut Data Members

Collapse Expand Links
PebsOut Class, PebsOut Members, PebsOut Data Members


PebsOut Methods

PebsOut Methods
PebsOut Class Legend Public Methods

The methods of the PebsOut class are listed here.

Collapse Expand Class

PebsOut Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares strings for printing.
setPageNum | Fills out page numbers.
Collapse Expand Links
PebsOut Class, Legend, Public Methods


PebsOut::prepareStrings Method

PebsOut::prepareStrings Method
PebsOut Class PebsOut Members PebsOut Methods

Prepares strings for printing.

C++
void prepareStrings();
Collapse Expand Group

PebsOut Methods

Collapse Expand Links
PebsOut Class, PebsOut Members, PebsOut Methods


PebsOut::setPageNum Method

PebsOut::setPageNum Method
PebsOut Class PebsOut Members PebsOut Methods

Fills out page numbers.

C++
void setPageNum();
Collapse Expand Group

PebsOut Methods

Collapse Expand Links
PebsOut Class, PebsOut Members, PebsOut Methods


PebsPageOut Class

PebsPageOut Class
PebsPageOut Data Members PebsPageOut Methods PebsPageOut Members PebsPageOut.h Classes

Parent of classes that manage a page of Social Security Statement output.

Collapse Expand Class Hierarchy
  PebsPageOutPebsPageOut
C++
class PebsPageOut : public PageOut;
Collapse Expand File

File: PebsPageOut.h

Module: PiaOut Library

Collapse Expand Remarks

Child classes are PebsCreditInfo, PebsEarnings, PebsEarningsInfo, PebsLetter, PebsOasdiEst, PebsOasdiInfo, and PebsWorkerInfo.

For a similar class that is the parent of classes that manage a page of non-Statement output, see PiaPageOut.

Collapse Expand See Also

PebsCreditInfo, PebsEarnings, PebsEarningsInfo, PebsLetter, PebsOasdiEst, PebsOasdiInfo, PebsWorkerInfo, PiaPageOut

Collapse Expand Group

Classes

Collapse Expand Links
PebsPageOut Data Members, PebsPageOut Methods, PebsPageOut Members, PebsPageOut.h, Classes


PebsPageOut Members

PebsPageOut Members
PebsPageOut Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PebsPageOut.

Collapse Expand Class

PebsPageOut Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
equals | String of equals signs.
hyphens | String of hyphens.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PebsPageOut | Initializes this instance.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareHeader | Prepares header string for output.
prepareStrings | Prepares strings for output.
print | Writes the output strings to the specified device.
setPageNum | Sets page number.
~PebsPageOut | Destructor.
Collapse Expand Links
PebsPageOut Class, Legend, Protected Data Members, Public Data Members, Public Methods


PebsPageOut::PebsPageOut Constructor

PebsPageOut::PebsPageOut Constructor
PebsPageOut Class PebsPageOut Members PebsPageOut Class

Initializes this instance.

C++
PebsPageOut();
Collapse Expand Class

PebsPageOut Class

Collapse Expand Links
PebsPageOut Class, PebsPageOut Members, PebsPageOut Class


PebsPageOut::~PebsPageOut Destructor

PebsPageOut::~PebsPageOut Destructor
PebsPageOut Class PebsPageOut Members PebsPageOut Class

Destructor.

C++
~PebsPageOut();
Collapse Expand Class

PebsPageOut Class

Collapse Expand Links
PebsPageOut Class, PebsPageOut Members, PebsPageOut Class


PebsPageOut Data Members

PebsPageOut Data Members
PebsPageOut Class Legend Public Data Members

The data members of the PebsPageOut class are listed here.

Collapse Expand Class

PebsPageOut Class

Collapse Expand Public Data Members
Name | Description
equals | String of equals signs.
hyphens | String of hyphens.
Collapse Expand Links
PebsPageOut Class, Legend, Public Data Members


PebsPageOut::equals Data Member

PebsPageOut::equals Data Member
PebsPageOut Class PebsPageOut Members PebsPageOut Data Members

String of equals signs.

C++
const std::string equals;
Collapse Expand Group

PebsPageOut Data Members

Collapse Expand Links
PebsPageOut Class, PebsPageOut Members, PebsPageOut Data Members


PebsPageOut::hyphens Data Member

PebsPageOut::hyphens Data Member
PebsPageOut Class PebsPageOut Members PebsPageOut Data Members

String of hyphens.

C++
const std::string hyphens;
Collapse Expand Group

PebsPageOut Data Members

Collapse Expand Links
PebsPageOut Class, PebsPageOut Members, PebsPageOut Data Members


PebsPageOut Methods

PebsPageOut Methods
PebsPageOut Class Legend Public Methods

The methods of the PebsPageOut class are listed here.

Collapse Expand Class

PebsPageOut Class

Collapse Expand Public Methods
Name | Description
prepareHeader | Prepares header string for output.
setPageNum | Sets page number.
Collapse Expand Links
PebsPageOut Class, Legend, Public Methods


PebsPageOut::prepareHeader Method

PebsPageOut::prepareHeader Method
PebsPageOut Class PebsPageOut Members PebsPageOut Methods

Prepares header string for output.

C++
void prepareHeader(
    const WorkerData& workerData
);
Collapse Expand Parameters
Parameters | Description
const WorkerData& workerData | Worker data.
Collapse Expand Group

PebsPageOut Methods

Collapse Expand Links
PebsPageOut Class, PebsPageOut Members, PebsPageOut Methods


PebsPageOut::setPageNum Method

PebsPageOut::setPageNum Method
PebsPageOut Class PebsPageOut Members PebsPageOut Methods

Sets page number.

C++
void setPageNum(
    int newPage
);
Collapse Expand Parameters
Parameters | Description
int newPage | New page number.
Collapse Expand Group

PebsPageOut Methods

Collapse Expand Links
PebsPageOut Class, PebsPageOut Members, PebsPageOut Methods


PebsWorkerEarnings Class

PebsWorkerEarnings Class
PebsWorkerEarnings Methods PebsWorkerEarnings Members PebsWorkerEarnings.h Classes

Manages the Social Security Statement worker info and earnings info page.

Collapse Expand Class Hierarchy
  PebsWorkerEarningsPebsWorkerEarnings
C++
class PebsWorkerEarnings : public PageOut;
Collapse Expand File

File: PebsWorkerEarnings.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PebsOut.

Collapse Expand See Also

PebsOut

Collapse Expand Group

Classes

Collapse Expand Links
PebsWorkerEarnings Methods, PebsWorkerEarnings Members, PebsWorkerEarnings.h, Classes


PebsWorkerEarnings Members

PebsWorkerEarnings Members
PebsWorkerEarnings Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PebsWorkerEarnings.

Collapse Expand Class

PebsWorkerEarnings Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PebsWorkerEarnings | Initializes PebsWorkerEarnings.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareStrings | Prepares top part of summary page.
print | Writes the output strings to the specified device.
~PebsWorkerEarnings | Destructor.
Collapse Expand Links
PebsWorkerEarnings Class, Legend, Protected Data Members, Public Data Members, Public Methods


PebsWorkerEarnings::PebsWorkerEarnings Constructor

PebsWorkerEarnings::PebsWorkerEarnings Constructor
PebsWorkerEarnings Class PebsWorkerEarnings Members PebsWorkerEarnings Class

Initializes PebsWorkerEarnings.

C++
PebsWorkerEarnings(
    const PebsWorkerInfo& newPebsWorkerInfo,
    const PebsEarningsInfo& newPebsEarningsInfo
);
Collapse Expand Parameters
Parameters | Description
const PebsWorkerInfo& newPebsWorkerInfo | Worker info.
const PebsEarningsInfo& newPebsEarningsInfo | Worker's earnings.
Collapse Expand Class

PebsWorkerEarnings Class

Collapse Expand Links
PebsWorkerEarnings Class, PebsWorkerEarnings Members, PebsWorkerEarnings Class


PebsWorkerEarnings::~PebsWorkerEarnings Destructor

PebsWorkerEarnings::~PebsWorkerEarnings Destructor
PebsWorkerEarnings Class PebsWorkerEarnings Members PebsWorkerEarnings Class

Destructor.

C++
~PebsWorkerEarnings();
Collapse Expand Class

PebsWorkerEarnings Class

Collapse Expand Links
PebsWorkerEarnings Class, PebsWorkerEarnings Members, PebsWorkerEarnings Class


PebsWorkerEarnings Methods

PebsWorkerEarnings Methods
PebsWorkerEarnings Class Legend Public Methods

The methods of the PebsWorkerEarnings class are listed here.

Collapse Expand Class

PebsWorkerEarnings Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares top part of summary page.
Collapse Expand Links
PebsWorkerEarnings Class, Legend, Public Methods


PebsWorkerEarnings::prepareStrings Method

PebsWorkerEarnings::prepareStrings Method
PebsWorkerEarnings Class PebsWorkerEarnings Members PebsWorkerEarnings Methods

Prepares top part of summary page.

C++
void prepareStrings();
Collapse Expand Group

PebsWorkerEarnings Methods

Collapse Expand Links
PebsWorkerEarnings Class, PebsWorkerEarnings Members, PebsWorkerEarnings Methods


PebsWorkerInfo Class

PebsWorkerInfo Class
PebsWorkerInfo Methods PebsWorkerInfo Members PebsWorkerInfo.h Classes

Manages the Social Security Statement worker info page.

Collapse Expand Class Hierarchy
  PebsWorkerInfoPebsWorkerInfoPebsWorkerInfo
C++
class PebsWorkerInfo : public PebsPageOut;
Collapse Expand File

File: PebsWorkerInfo.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PebsOut.

Collapse Expand See Also

PebsOut

Collapse Expand Group

Classes

Collapse Expand Links
PebsWorkerInfo Methods, PebsWorkerInfo Members, PebsWorkerInfo.h, Classes


PebsWorkerInfo Members

PebsWorkerInfo Members
PebsWorkerInfo Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by PebsWorkerInfo.

Collapse Expand Class

PebsWorkerInfo Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
equals | String of equals signs.
hyphens | String of hyphens.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PebsWorkerInfo | Initializes PebsWorkerInfo.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareHeader | Prepares header string for output.
prepareStrings | Prepares worker information for printing.
print | Writes the output strings to the specified device.
setPageNum | Sets page number.
~PebsWorkerInfo | Destructor.
Collapse Expand Links
PebsWorkerInfo Class, Legend, Protected Data Members, Public Data Members, Public Methods


PebsWorkerInfo::PebsWorkerInfo Constructor

PebsWorkerInfo::PebsWorkerInfo Constructor
PebsWorkerInfo Class PebsWorkerInfo Members PebsWorkerInfo Class

Initializes PebsWorkerInfo.

C++
PebsWorkerInfo(
    const WorkerData& newWorkerData,
    const Pebs& newPebs,
    const PiaParams& newPiaParams,
    const EarnProject& newEarnProject
);
Collapse Expand Parameters
Parameters | Description
const WorkerData& newWorkerData | Basic worker data.
const Pebs& newPebs | Social Security Statement data.
const PiaParams& newPiaParams | Pia calculation parameters.
const EarnProject& newEarnProject | Projected earnings information.
Collapse Expand Class

PebsWorkerInfo Class

Collapse Expand Links
PebsWorkerInfo Class, PebsWorkerInfo Members, PebsWorkerInfo Class


PebsWorkerInfo::~PebsWorkerInfo Destructor

PebsWorkerInfo::~PebsWorkerInfo Destructor
PebsWorkerInfo Class PebsWorkerInfo Members PebsWorkerInfo Class

Destructor.

C++
~PebsWorkerInfo();
Collapse Expand Class

PebsWorkerInfo Class

Collapse Expand Links
PebsWorkerInfo Class, PebsWorkerInfo Members, PebsWorkerInfo Class


PebsWorkerInfo Methods

PebsWorkerInfo Methods
PebsWorkerInfo Class Legend Public Methods

The methods of the PebsWorkerInfo class are listed here.

Collapse Expand Class

PebsWorkerInfo Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares worker information for printing.
Collapse Expand Links
PebsWorkerInfo Class, Legend, Public Methods


PebsWorkerInfo::prepareStrings Method

PebsWorkerInfo::prepareStrings Method
PebsWorkerInfo Class PebsWorkerInfo Members PebsWorkerInfo Methods

Prepares worker information for printing.

C++
void prepareStrings();
Collapse Expand Group

PebsWorkerInfo Methods

Collapse Expand Links
PebsWorkerInfo Class, PebsWorkerInfo Members, PebsWorkerInfo Methods


PiaOut Class

PiaOut Class
PiaOut Data Members PiaOut Methods PiaOut Members PiaOut.h Classes

>Manages the printing of the results of a Social Security non-Statement calculation.

Collapse Expand Class Hierarchy
  PiaOut
C++
class PiaOut;
Collapse Expand File

File: PiaOut.h

Module: PiaOut Library

Collapse Expand Remarks

It contains an instance of each of the pages of output related to a non-Statement calculation. For a similar class that contains an instance of each of the pages of output related to a Statement calculation, see PebsOut.

Collapse Expand See Also

PebsOut

Collapse Expand Group

Classes

Collapse Expand Links
PiaOut Data Members, PiaOut Methods, PiaOut Members, PiaOut.h, Classes


PiaOut Members

PiaOut Members
PiaOut Class Legend Public Data Members Public Methods

The following tables list the members exposed by PiaOut.

Collapse Expand Class

PiaOut Class

Collapse Expand Public Data Members
Name | Description
MAX_REINDWID | Maximum number of re-indexed widow(er)s.
childCareCalc1Page | Wage-indexed earnings with child-care dropout years.
childCareCalc2Page | Wage-indexed calculation with child-care dropout years.
dibGuarPage | Disability guarantee calculation.
earningsPage | Earnings used in calculation.
familyPage | Family members calculation.
frozMinPage | Frozen minimum calculation.
insuredPage | Insured status calculation.
oldStart1Page | Old-start earnings.
oldStart2Page | Old-start calculation.
onePage | One-page output.
piaTable1Page | Pia table earnings.
piaTable2Page | Pia table calculation.
reindWid1Page | Re-indexed widow guarantee earnings.
reindWid2Page | Re-indexed widow guarantee calculation.
specMin1Page | Special minimum earnings.
specMin2Page | Special minimum calculation.
summary1Page | Top part of summary page.
summary2Page | Middle part of summary page.
summary3Page | Bottom part of summary page.
summaryPage | Summary page of results.
taxesPage | Taxes calculation.
transGuar1Page | Transitional guarantee earnings.
transGuar2Page | Transitional guarantee calculation.
wageInd1Page | Wage-indexed earnings.
wageInd2Page | Wage-indexed calculation.
wageIndNonFreeze1Page | Wage-indexed earnings.
wageIndNonFreeze2Page | Wage-indexed calculation.
Collapse Expand Public Methods
Name | Description
PiaOut | Initializes PiaOut.
prepareStrings | Prepares strings for printing.
setPageNum | Fills out page numbers.
~PiaOut | Destructor.
Collapse Expand Links
PiaOut Class, Legend, Public Data Members, Public Methods


PiaOut::PiaOut Constructor

PiaOut::PiaOut Constructor
PiaOut Class PiaOut Members PiaOut Class

Initializes PiaOut.

C++
PiaOut(
    const PiaCalAny& piaCal,
    const TaxData& taxData
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& piaCal | Benefit calculation parameters and results.
const TaxData& taxData | Taxes paid.
Collapse Expand Remarks

Creates the five ReindWid1Page's and ReindWid2Page's.

Collapse Expand Class

PiaOut Class

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Class


PiaOut::~PiaOut Destructor

PiaOut::~PiaOut Destructor
PiaOut Class PiaOut Members PiaOut Class

Destructor.

C++
~PiaOut();
Collapse Expand Remarks

Deletes the five ReindWid1Page's and ReindWid2Page's.

Collapse Expand Class

PiaOut Class

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Class


PiaOut Data Members

PiaOut Data Members
PiaOut Class Legend Public Data Members

The data members of the PiaOut class are listed here.

Collapse Expand Class

PiaOut Class

Collapse Expand Public Data Members
Name | Description
MAX_REINDWID | Maximum number of re-indexed widow(er)s.
childCareCalc1Page | Wage-indexed earnings with child-care dropout years.
childCareCalc2Page | Wage-indexed calculation with child-care dropout years.
dibGuarPage | Disability guarantee calculation.
earningsPage | Earnings used in calculation.
familyPage | Family members calculation.
frozMinPage | Frozen minimum calculation.
insuredPage | Insured status calculation.
oldStart1Page | Old-start earnings.
oldStart2Page | Old-start calculation.
onePage | One-page output.
piaTable1Page | Pia table earnings.
piaTable2Page | Pia table calculation.
reindWid1Page | Re-indexed widow guarantee earnings.
reindWid2Page | Re-indexed widow guarantee calculation.
specMin1Page | Special minimum earnings.
specMin2Page | Special minimum calculation.
summary1Page | Top part of summary page.
summary2Page | Middle part of summary page.
summary3Page | Bottom part of summary page.
summaryPage | Summary page of results.
taxesPage | Taxes calculation.
transGuar1Page | Transitional guarantee earnings.
transGuar2Page | Transitional guarantee calculation.
wageInd1Page | Wage-indexed earnings.
wageInd2Page | Wage-indexed calculation.
wageIndNonFreeze1Page | Wage-indexed earnings.
wageIndNonFreeze2Page | Wage-indexed calculation.
Collapse Expand Links
PiaOut Class, Legend, Public Data Members


PiaOut::MAX_REINDWID Data Member

PiaOut::MAX_REINDWID Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Maximum number of re-indexed widow(er)s.

C++
const int MAX_REINDWID = 5;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::childCareCalc1Page Data Member

PiaOut::childCareCalc1Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Wage-indexed earnings with child-care dropout years.

C++
ChildCareCalc1Page childCareCalc1Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::childCareCalc2Page Data Member

PiaOut::childCareCalc2Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Wage-indexed calculation with child-care dropout years.

C++
ChildCareCalc2Page childCareCalc2Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::dibGuarPage Data Member

PiaOut::dibGuarPage Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Disability guarantee calculation.

C++
DibGuarPage dibGuarPage;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::earningsPage Data Member

PiaOut::earningsPage Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Earnings used in calculation.

C++
EarningsPage earningsPage;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::familyPage Data Member

PiaOut::familyPage Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Family members calculation.

C++
FamilyPage familyPage;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::frozMinPage Data Member

PiaOut::frozMinPage Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Frozen minimum calculation.

C++
FrozMinPage frozMinPage;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::insuredPage Data Member

PiaOut::insuredPage Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Insured status calculation.

C++
InsuredPage insuredPage;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::oldStart1Page Data Member

PiaOut::oldStart1Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Old-start earnings.

C++
OldStart1Page oldStart1Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::oldStart2Page Data Member

PiaOut::oldStart2Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Old-start calculation.

C++
OldStart2Page oldStart2Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::onePage Data Member

PiaOut::onePage Data Member
PiaOut Class PiaOut Members PiaOut Data Members

One-page output.

C++
OnePage onePage;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::piaTable1Page Data Member

PiaOut::piaTable1Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Pia table earnings.

C++
PiaTable1Page piaTable1Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::piaTable2Page Data Member

PiaOut::piaTable2Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Pia table calculation.

C++
PiaTable2Page piaTable2Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::reindWid1Page Data Member

PiaOut::reindWid1Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Re-indexed widow guarantee earnings.

C++
ReindWid1Page* reindWid1Page[MAX_REINDWID];
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::reindWid2Page Data Member

PiaOut::reindWid2Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Re-indexed widow guarantee calculation.

C++
ReindWid2Page* reindWid2Page[MAX_REINDWID];
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::specMin1Page Data Member

PiaOut::specMin1Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Special minimum earnings.

C++
SpecMin1Page specMin1Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::specMin2Page Data Member

PiaOut::specMin2Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Special minimum calculation.

C++
SpecMin2Page specMin2Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::summary1Page Data Member

PiaOut::summary1Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Top part of summary page.

C++
Summary1Page summary1Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::summary2Page Data Member

PiaOut::summary2Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Middle part of summary page.

C++
Summary2Page summary2Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::summary3Page Data Member

PiaOut::summary3Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Bottom part of summary page.

C++
Summary3Page summary3Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::summaryPage Data Member

PiaOut::summaryPage Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Summary page of results.

C++
SummaryPage summaryPage;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::taxesPage Data Member

PiaOut::taxesPage Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Taxes calculation.

C++
TaxesPage taxesPage;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::transGuar1Page Data Member

PiaOut::transGuar1Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Transitional guarantee earnings.

C++
TransGuar1Page transGuar1Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::transGuar2Page Data Member

PiaOut::transGuar2Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Transitional guarantee calculation.

C++
TransGuar2Page transGuar2Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::wageInd1Page Data Member

PiaOut::wageInd1Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Wage-indexed earnings.

C++
WageInd1Page wageInd1Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::wageInd2Page Data Member

PiaOut::wageInd2Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Wage-indexed calculation.

C++
WageInd2Page wageInd2Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::wageIndNonFreeze1Page Data Member

PiaOut::wageIndNonFreeze1Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Wage-indexed earnings.

C++
WageIndNonFreeze1Page wageIndNonFreeze1Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut::wageIndNonFreeze2Page Data Member

PiaOut::wageIndNonFreeze2Page Data Member
PiaOut Class PiaOut Members PiaOut Data Members

Wage-indexed calculation.

C++
WageIndNonFreeze2Page wageIndNonFreeze2Page;
Collapse Expand Group

PiaOut Data Members

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Data Members


PiaOut Methods

PiaOut Methods
PiaOut Class Legend Public Methods

The methods of the PiaOut class are listed here.

Collapse Expand Class

PiaOut Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares strings for printing.
setPageNum | Fills out page numbers.
Collapse Expand Links
PiaOut Class, Legend, Public Methods


PiaOut::prepareStrings Method

PiaOut::prepareStrings Method
PiaOut Class PiaOut Members PiaOut Methods

Prepares strings for printing.

C++
void prepareStrings();
Collapse Expand Remarks

This should be called after setPageNum, so the number of reindexed widow(er) calculations will be set.

Collapse Expand Group

PiaOut Methods

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Methods


PiaOut::setPageNum Method

PiaOut::setPageNum Method
PiaOut Class PiaOut Members PiaOut Methods

Fills out page numbers.

C++
void setPageNum(
    const PiaCalAny& piaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& piaCal | Benefit calculation parameters and results.
Collapse Expand Remarks

This should be called before prepareStrings, to set the number of reindexed widow(er) calculations.

Collapse Expand Group

PiaOut Methods

Collapse Expand Links
PiaOut Class, PiaOut Members, PiaOut Methods


PiaPageOut Class

PiaPageOut Class
PiaPageOut Data Members PiaPageOut Methods PiaPageOut Members PiaPageOut.h Classes

Parent of classes that manage a page of output from the calculation of a non-Statement Social Security benefit.

Collapse Expand Class Hierarchy
  PiaPageOutPiaPageOut
C++
class PiaPageOut : public PageOut;
Collapse Expand File

File: PiaPageOut.h

Module: PiaOut Library

Collapse Expand Remarks

Child classes are ChildCareCalc1Page, ChildCareCalc2Page, DibGuarPage, EarningsPage, FamilyPage, FrozMinPage, InsuredPage, OldStart1Page, OldStart2Page, OnePage, PiaTable1Page, PiaTable2Page, ReindWid1Page, ReindWid2Page, SpecMin1Page, SpecMin2Page, Summary1Page, Summary3Page, TaxesPage, TransGuar1Page, TransGuar2Page, WageInd1Page, and WageInd2Page.

For a similar class that is the parent of classes that manage a page of Statement output, see PebsPageOut.

Collapse Expand See Also

ChildCareCalc1Page, ChildCareCalc2Page, DibGuarPage, EarningsPage, FamilyPage, FrozMinPage, InsuredPage, OldStart1Page, OldStart2Page, OnePage, PiaTable1Page, PiaTable2Page, ReindWid1Page, ReindWid2Page, SpecMin1Page, SpecMin2Page, Summary1Page, Summary3Page, TaxesPage, TransGuar1Page, TransGuar2Page, WageInd1Page, WageInd2Page, PebsPageOut

Collapse Expand Group

Classes

Collapse Expand Links
PiaPageOut Data Members, PiaPageOut Methods, PiaPageOut Members, PiaPageOut.h, Classes


PiaPageOut Members

PiaPageOut Members
PiaPageOut Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by PiaPageOut.

Collapse Expand Class

PiaPageOut Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PiaPageOut | Initializes PiaPageOut.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares strings for output.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~PiaPageOut | Destructor.
Collapse Expand Links
PiaPageOut Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


PiaPageOut::PiaPageOut Constructor

PiaPageOut::PiaPageOut Constructor
PiaPageOut Class PiaPageOut Members PiaPageOut Class

Initializes PiaPageOut.

C++
PiaPageOut();
Collapse Expand Class

PiaPageOut Class

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Class


PiaPageOut::~PiaPageOut Destructor

PiaPageOut::~PiaPageOut Destructor
PiaPageOut Class PiaPageOut Members PiaPageOut Class

Destructor.

C++
virtual ~PiaPageOut();
Collapse Expand Class

PiaPageOut Class

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Class


PiaPageOut Data Members

PiaPageOut Data Members
PiaPageOut Class Legend Protected Data Members

The data members of the PiaPageOut class are listed here.

Collapse Expand Class

PiaPageOut Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
pageTitle | Title at top of page.
Collapse Expand Links
PiaPageOut Class, Legend, Protected Data Members


PiaPageOut::pageTitle Data Member

PiaPageOut::pageTitle Data Member
PiaPageOut Class PiaPageOut Members PiaPageOut Data Members

Title at top of page.

C++
std::string pageTitle[2];
Collapse Expand Group

PiaPageOut Data Members

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Data Members


PiaPageOut Methods

PiaPageOut Methods
PiaPageOut Class Legend Protected Methods Public Methods

The methods of the PiaPageOut class are listed here.

Collapse Expand Class

PiaPageOut Class

Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Methods
Name | Description
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
Collapse Expand Links
PiaPageOut Class, Legend, Protected Methods, Public Methods


PiaPageOut::baseYearOut Method

PiaPageOut::baseYearOut Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares base year in a string table.

C++
void baseYearOut(
    int year
);
Collapse Expand Parameters
Parameters | Description
int year | Base year to put in a string table.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


biOut Method

biOut Method
PiaPageOut Methods

Prints the benefit increases that are applied to a benefit.

Collapse Expand Description

There are two versions of the biOut function. The one with 6 arguments receives the first and last years that should be printed. The one with 5 arguments receives a trigger, which is interpreted to derive the first and last years that should be printed.

Collapse Expand Overload List
Name | Description
PiaPageOut::biOut (const PiaMethod&, const PiaParams&, int, int, int) | Prepares benefit increases used in PIA calculation in a string table.
PiaPageOut::biOut (const PiaMethod&, const PiaParams&, int, int, int, int) | Prepares benefit increases used in PIA calculation in a string table.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Methods


PiaPageOut::biOut Method (const PiaMethod&, const PiaParams&, int, int, int)

PiaPageOut::biOut Method (const PiaMethod&, const PiaParams&, int, int, int)
PiaPageOut Class PiaPageOut Members biOut Method

Prepares benefit increases used in PIA calculation in a string table.

C++
void biOut(
    const PiaMethod& piaMethod,
    const PiaParams& piaParams,
    int eligYear,
    int type,
    int piamfb
);
Collapse Expand Parameters
Parameters | Description
const PiaMethod& piaMethod | Pia calculation method.
const PiaParams& piaParams | Pia calculation parameters.
int eligYear | Year of eligibility for catch-up benefit increases.
int type | Type of writeout.
int piamfb | Indicator for PIA and MFB printout.
Collapse Expand Remarks

This version is passed an int which determines the starting and ending years. The type of writeout is one of the following:

0 | to go from first year to entitlement.
1 | to go from eligibility to entitlement.
2 | to go from entitlement to benefit date.
3 | to go from first year to benefit date.

The indicator for PIA and MFB printout is one of the following:

0 | to not write out PIA or MFB.
1 | for PIA.
2 | for MFB.
3 | for PIA and MFB.
Collapse Expand Group

biOut Method

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, biOut Method


PiaPageOut::biOut Method (const PiaMethod&, const PiaParams&, int, int, int, int)

PiaPageOut::biOut Method (const PiaMethod&, const PiaParams&, int, int, int, int)
PiaPageOut Class PiaPageOut Members biOut Method

Prepares benefit increases used in PIA calculation in a string table.

C++
void biOut(
    const PiaMethod& piaMethod,
    const PiaParams& piaParams,
    int eligYear,
    int firstYear,
    int lastYear,
    int piamfb
);
Collapse Expand Parameters
Parameters | Description
const PiaMethod& piaMethod | Pia calculation method.
const PiaParams& piaParams | Pia calculation parameters.
int eligYear | Year of eligibility for catch-up benefit increases.
int firstYear | First year to write increases.
int lastYear | Last year to write increases.
int piamfb | Indicator for PIA and MFB printout.
Collapse Expand Remarks

This version is passed the starting and ending years. The indicator for PIA and MFB printout is one of the following:

0 | to not write out PIA or MFB.
1 | for PIA.
2 | for MFB.
3 | for PIA and MFB.
Collapse Expand Group

biOut Method

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, biOut Method


PiaPageOut::compYear Method

PiaPageOut::compYear Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares number of computation years in a string table.

C++
void compYear(
    const WorkerDataGeneral& workerData,
    const PiaData& piaData,
    const CompPeriod& compPeriod
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Worker basic data.
const PiaData& piaData | Pia calculation data.
const CompPeriod& compPeriod | Computation period (old or new).
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::disInsOut Method

PiaPageOut::disInsOut Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prints out disability insured message.

C++
void disInsOut(
    const PiaData& piaData
);
Collapse Expand Parameters
Parameters | Description
const PiaData& piaData | Pia calculation data.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::disMfbOut Method

PiaPageOut::disMfbOut Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares MFB cap on DI cases in a string table.

C++
void disMfbOut(
    double capt,
    double amepia,
    double mfbt
);
Collapse Expand Parameters
Parameters | Description
double capt | Percentage cap for DI MFB.
double amepia | Ame or pia.
double mfbt | DI MFB.
Collapse Expand Remarks

This is called from piamfb1, piamfb2, and mfbOut.

Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::endYearCal Method

PiaPageOut::endYearCal Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Calculates the ending year type for printing a range of benefit increases.

C++
static PiaMethod::cpi_year_type endYearCal(
    int type
);
Collapse Expand Parameters
Parameters | Description
int type | Type of writeout.
Collapse Expand Returns

The ending year type.

Collapse Expand Remarks

The type of writeout is one of the following:

0 | to go from first year to entitlement.
1 | to go from eligibility to entitlement.
2 | to go from entitlement to benefit date.
3 | to go from first year to benefit date.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::firstYearCal Method

PiaPageOut::firstYearCal Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Calculates the first year type for printing a range of benefit increases.

C++
static PiaMethod::cpi_year_type firstYearCal(
    int type
);
Collapse Expand Parameters
Parameters | Description
int type | Type of writeout.
Collapse Expand Returns

The ending year type.

Collapse Expand Remarks

The type of writeout is one of the following:

0 | to go from first year to entitlement.
1 | to go from eligibility to entitlement.
2 | to go from entitlement to benefit date.
3 | to go from first year to benefit date.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::mfbBpOut Method

PiaPageOut::mfbBpOut Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares MFB formula bend points in a string table.

C++
void mfbBpOut(
    const BendMfb& bendMfb
);
Collapse Expand Parameters
Parameters | Description
const BendMfb& bendMfb | Mfb formula bend points.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


mfbOut Method

mfbOut Method
PiaPageOut Methods

Prints the calculation of the Maximum Family Benefit.

Collapse Expand Description

There are two versions of the mfbOut function. The one with 4 arguments can handle the DI family maximum; the one with 3 arguments cannot.

Collapse Expand Overload List
Name | Description
PiaPageOut::mfbOut (const PiaMethod&, const double, const PercMfb&) | Prepares MFB calculation in a string table.
PiaPageOut::mfbOut (const PiaMethod&, const double, const PercMfb&, double) | Prepares MFB calculation in a string table.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Methods


PiaPageOut::mfbOut Method (const PiaMethod&, const double, const PercMfb&)

PiaPageOut::mfbOut Method (const PiaMethod&, const double, const PercMfb&)
PiaPageOut Class PiaPageOut Members mfbOut Method

Prepares MFB calculation in a string table.

C++
void mfbOut(
    const PiaMethod& piaMethod,
    const double portionPiaElig[],
    const PercMfb& percMfb
);
Collapse Expand Parameters
Parameters | Description
const PiaMethod& piaMethod | Pia calculation method number.
const double portionPiaElig[] | Portion of pia in each mfb formula interval.
const PercMfb& percMfb | Mfb formula percentages.
Collapse Expand Remarks

This version does not handle the DI family maximum.

Collapse Expand Group

mfbOut Method

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, mfbOut Method


PiaPageOut::mfbOut Method (const PiaMethod&, const double, const PercMfb&, double)

PiaPageOut::mfbOut Method (const PiaMethod&, const double, const PercMfb&, double)
PiaPageOut Class PiaPageOut Members mfbOut Method

Prepares MFB calculation in a string table.

C++
void mfbOut(
    const PiaMethod& piaMethod,
    const double portionPiaElig[],
    const PercMfb& percMfb,
    double aime
);
Collapse Expand Parameters
Parameters | Description
const PiaMethod& piaMethod | Pia calculation method number.
const double portionPiaElig[] | Portion of pia in each mfb formula interval.
const PercMfb& percMfb | Mfb formula percentages.
double aime | Aime used in pia formula.
Collapse Expand Remarks

This version handles the DI family maximum.

Collapse Expand Group

mfbOut Method

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, mfbOut Method


PiaPageOut::newTableOut Method

PiaPageOut::newTableOut Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares table change automatic increases used in PIA calculation in a string table.

C++
void newTableOut(
    const PiaMethod&,
    const PiaParams& piaParams,
    int eligYear,
    int firstYear,
    int lastYear,
    int piamfb
);
Collapse Expand Parameters
Parameters | Description
const PiaParams& piaParams | Pia calculation parameters.
int eligYear | Year of eligibility for catch-up benefit increases.
int firstYear | First year to write.
int lastYear | Last year to write.
int piamfb | Indicator for PIA and MFB printout.
piaMethod | Pia calculation method.
Collapse Expand Remarks

The indicator for PIA and MFB printout is one of the following:

0 | to not write out PIA or MFB.
1 | for PIA.
2 | for MFB.
3 | for PIA and MFB.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::nonIns Method

PiaPageOut::nonIns Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prints out uninsured message.

C++
void nonIns(
    char finsCode,
    const WorkerDataGeneral& workerData,
    const PiaData& piaData
);
Collapse Expand Parameters
Parameters | Description
char finsCode | Insured status code.
const WorkerDataGeneral& workerData | Worker basic data.
const PiaData& piaData | Benefit calculation data.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::nonpenOut Method

PiaPageOut::nonpenOut Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prints out noncovered pension amount and starting date.

C++
void nonpenOut(
    double pubpen,
    const DateMoyr& pubpenDate
);
Collapse Expand Parameters
Parameters | Description
double pubpen | Amount of public pension.
const DateMoyr& pubpenDate | Starting date of public pension.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::osTableOut Method

PiaPageOut::osTableOut Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares applicable old start pia table in a string table.

C++
void osTableOut(
    const PiaMethod& piaMethod
);
Collapse Expand Parameters
Parameters | Description
const PiaMethod& piaMethod | Pia calculation method.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::piaBpOut Method

PiaPageOut::piaBpOut Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares PIA formula bend points in a string table.

C++
void piaBpOut(
    const BendPia& bendPia
);
Collapse Expand Parameters
Parameters | Description
const BendPia& bendPia | Pia formula bend points.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::piaEligOut Method

PiaPageOut::piaEligOut Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares wage-indexed pia at eligibility calculation in a string table.

C++
void piaEligOut(
    const PercPia& percPia,
    const PortionAime& portionAime,
    double piaTemp
);
Collapse Expand Parameters
Parameters | Description
const PercPia& percPia | Pia formula percentages.
const PortionAime& portionAime | Parts of aime in each pia formula interval.
double piaTemp | Pia at eligibility.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::piaEntOut Method

PiaPageOut::piaEntOut Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares PIA at entitlement in a string table.

C++
void piaEntOut(
    double piaentt
);
Collapse Expand Parameters
Parameters | Description
double piaentt | Pia at entitlement.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::piamfb1 Method

PiaPageOut::piamfb1 Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares PIA and MFB at entitlement in a string table.

C++
void piamfb1(
    const PiaMethod& piaMethod
);
Collapse Expand Parameters
Parameters | Description
const PiaMethod& piaMethod | Pia calculation method.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::piamfb2 Method

PiaPageOut::piamfb2 Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares PIA and MFB at benefit date in a string table.

C++
void piamfb2(
    const PiaMethod& piaMethod
);
Collapse Expand Parameters
Parameters | Description
const PiaMethod& piaMethod | Pia calculation method.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::piamfb3 Method

PiaPageOut::piamfb3 Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares PIA and MFB from June 1974 table in a string table.

C++
void piamfb3(
    const PiaMethod& piaMethod
);
Collapse Expand Parameters
Parameters | Description
const PiaMethod& piaMethod | Pia calculation method.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::prepareHeader Method

PiaPageOut::prepareHeader Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares header strings for output.

C++
void prepareHeader();
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::printIndexedEarningsTable Method

PiaPageOut::printIndexedEarningsTable Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Print out indexed earnings table.

C++
void printIndexedEarningsTable(
    const WageIndGeneral& wageInd,
    const PiaData& piaData,
    int eligYear,
    const AverageWage& earnings,
    int firstYear
);
Collapse Expand Parameters
Parameters | Description
const WageIndGeneral& wageInd | Wage-indexed calculation method.
const PiaData& piaData | Pia calculation summary data.
int eligYear | Year of eligibility.
const AverageWage& earnings | Unindexed earnings.
int firstYear | First year of earnings.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::printNameSsn Method

PiaPageOut::printNameSsn Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prints out name and SSN.

C++
void printNameSsn(
    const WorkerDataGeneral& workerData
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& workerData | Basic worker data.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::printRealWageGain Method

PiaPageOut::printRealWageGain Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares real-wage-gain adjustment in a string table.

C++
void printRealWageGain(
    int eligYear,
    int istart,
    const PiaMethod& piaMethod,
    double rwgpia,
    double rwgmfb
);
Collapse Expand Parameters
Parameters | Description
int eligYear | Year of eligibility.
int istart | Current year.
const PiaMethod& piaMethod | Pia calculation method.
double rwgpia | Pia before real-wage-gain adjustment.
double rwgmfb | Mfb before real-wage-gain adjustment.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::pubPenOut Method

PiaPageOut::pubPenOut Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares windfall elimination provision calculation.

C++
void pubPenOut(
    const WageIndGeneral& wageInd,
    double pubpen,
    const DateMoyr& pubpenDate
);
Collapse Expand Parameters
Parameters | Description
const WageIndGeneral& wageInd | Wage-indexed calculation method.
double pubpen | Amount of public pension.
const DateMoyr& pubpenDate | Starting date of public pension.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::rawPiaOut Method

PiaPageOut::rawPiaOut Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares raw pro rata PIA in a string table.

C++
void rawPiaOut(
    double rawpia
);
Collapse Expand Parameters
Parameters | Description
double rawpia | Raw pro rata PIA.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::setPageNum Method

PiaPageOut::setPageNum Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Sets page number.

C++
void setPageNum(
    int newPageNum
);
Collapse Expand Parameters
Parameters | Description
int newPageNum | New page number.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::tableHead1 Method

PiaPageOut::tableHead1 Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares table heading for wage-indexed earnings in a string table.

C++
void tableHead1(
    double avgbsyr
);
Collapse Expand Parameters
Parameters | Description
double avgbsyr | Average wage in base year.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::tableHead2 Method

PiaPageOut::tableHead2 Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares table heading for non-indexed earnings in a string table.

C++
void tableHead2();
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaPageOut::totPiaOut Method

PiaPageOut::totPiaOut Method
PiaPageOut Class PiaPageOut Members PiaPageOut Methods

Prepares totalization PIAs in a string table.

C++
void totPiaOut(
    const PiaMethod& piaMethod,
    int qcTotal,
    int n
);
Collapse Expand Parameters
Parameters | Description
const PiaMethod& piaMethod | Pia calculation method.
int qcTotal | Total number of quarters of coverage.
int n | Number of computation years.
Collapse Expand Group

PiaPageOut Methods

Collapse Expand Links
PiaPageOut Class, PiaPageOut Members, PiaPageOut Methods


PiaTable1Page Class

PiaTable1Page Class
PiaTable1Page Methods PiaTable1Page Members PiaTable1Page.h Classes

Manages the pia table calculation earnings page from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  PiaTable1PagePiaTable1PagePiaTable1Page
C++
class PiaTable1Page : public PiaPageOut;
Collapse Expand File

File: PiaTable1Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with PiaTable2Page.

Collapse Expand See Also

PiaTable2Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
PiaTable1Page Methods, PiaTable1Page Members, PiaTable1Page.h, Classes


PiaTable1Page Members

PiaTable1Page Members
PiaTable1Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by PiaTable1Page.

Collapse Expand Class

PiaTable1Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PiaTable1Page | Initializes PiaTable1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares pia table strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~PiaTable1Page | Destructor.
Collapse Expand Links
PiaTable1Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


PiaTable1Page::PiaTable1Page Constructor

PiaTable1Page::PiaTable1Page Constructor
PiaTable1Page Class PiaTable1Page Members PiaTable1Page Class

Initializes PiaTable1Page.

C++
PiaTable1Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

PiaTable1Page Class

Collapse Expand Links
PiaTable1Page Class, PiaTable1Page Members, PiaTable1Page Class


PiaTable1Page::~PiaTable1Page Destructor

PiaTable1Page::~PiaTable1Page Destructor
PiaTable1Page Class PiaTable1Page Members PiaTable1Page Class

Destructor.

C++
~PiaTable1Page();
Collapse Expand Class

PiaTable1Page Class

Collapse Expand Links
PiaTable1Page Class, PiaTable1Page Members, PiaTable1Page Class


PiaTable1Page Methods

PiaTable1Page Methods
PiaTable1Page Class Legend Public Methods

The methods of the PiaTable1Page class are listed here.

Collapse Expand Class

PiaTable1Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares pia table strings for printing.
Collapse Expand Links
PiaTable1Page Class, Legend, Public Methods


PiaTable1Page::prepareStrings Method

PiaTable1Page::prepareStrings Method
PiaTable1Page Class PiaTable1Page Members PiaTable1Page Methods

Prepares pia table strings for printing.

C++
void prepareStrings();
Collapse Expand Group

PiaTable1Page Methods

Collapse Expand Links
PiaTable1Page Class, PiaTable1Page Members, PiaTable1Page Methods


PiaTable2Page Class

PiaTable2Page Class
PiaTable2Page Methods PiaTable2Page Members PiaTable2Page.h Classes

Manages the pia table calculation results page from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  PiaTable2PagePiaTable2PagePiaTable2Page
C++
class PiaTable2Page : public PiaPageOut;
Collapse Expand File

File: PiaTable2Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with PiaTable1Page.

Collapse Expand See Also

PiaTable1Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
PiaTable2Page Methods, PiaTable2Page Members, PiaTable2Page.h, Classes


PiaTable2Page Members

PiaTable2Page Members
PiaTable2Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by PiaTable2Page.

Collapse Expand Class

PiaTable2Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
PiaTable2Page | Initializes PiaTable2Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares pia table strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~PiaTable2Page | Destructor.
Collapse Expand Links
PiaTable2Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


PiaTable2Page::PiaTable2Page Constructor

PiaTable2Page::PiaTable2Page Constructor
PiaTable2Page Class PiaTable2Page Members PiaTable2Page Class

Initializes PiaTable2Page.

C++
PiaTable2Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

PiaTable2Page Class

Collapse Expand Links
PiaTable2Page Class, PiaTable2Page Members, PiaTable2Page Class


PiaTable2Page::~PiaTable2Page Destructor

PiaTable2Page::~PiaTable2Page Destructor
PiaTable2Page Class PiaTable2Page Members PiaTable2Page Class

Destructor.

C++
~PiaTable2Page();
Collapse Expand Class

PiaTable2Page Class

Collapse Expand Links
PiaTable2Page Class, PiaTable2Page Members, PiaTable2Page Class


PiaTable2Page Methods

PiaTable2Page Methods
PiaTable2Page Class Legend Public Methods

The methods of the PiaTable2Page class are listed here.

Collapse Expand Class

PiaTable2Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares pia table strings for printing.
Collapse Expand Links
PiaTable2Page Class, Legend, Public Methods


PiaTable2Page::prepareStrings Method

PiaTable2Page::prepareStrings Method
PiaTable2Page Class PiaTable2Page Members PiaTable2Page Methods

Prepares pia table strings for printing.

C++
void prepareStrings();
Collapse Expand Group

PiaTable2Page Methods

Collapse Expand Links
PiaTable2Page Class, PiaTable2Page Members, PiaTable2Page Methods


ReindWid1Page Class

ReindWid1Page Class
ReindWid1Page Data Members ReindWid1Page Methods ReindWid1Page Members ReindWid1Page.h Classes

Manages a re-indexed widow earnings page from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  ReindWid1PageReindWid1PageReindWid1Page
C++
class ReindWid1Page : public PiaPageOut;
Collapse Expand File

File: ReindWid1Page.h

Module: PiaOut Library

Collapse Expand Remarks

Five instances of this class are created in PiaOut.

This is used in combination with ReindWid2Page.

Collapse Expand See Also

ReindWid2Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
ReindWid1Page Data Members, ReindWid1Page Methods, ReindWid1Page Members, ReindWid1Page.h, Classes


ReindWid1Page Members

ReindWid1Page Members
ReindWid1Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by ReindWid1Page.

Collapse Expand Class

ReindWid1Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
reindWid | Reindexed widow(er) calculation.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
ReindWid1Page | Initializes ReindWid1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares reindexed widow strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~ReindWid1Page | Destructor.
Collapse Expand Links
ReindWid1Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


ReindWid1Page::ReindWid1Page Constructor

ReindWid1Page::ReindWid1Page Constructor
ReindWid1Page Class ReindWid1Page Members ReindWid1Page Class

Initializes ReindWid1Page.

C++
ReindWid1Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

ReindWid1Page Class

Collapse Expand Links
ReindWid1Page Class, ReindWid1Page Members, ReindWid1Page Class


ReindWid1Page::~ReindWid1Page Destructor

ReindWid1Page::~ReindWid1Page Destructor
ReindWid1Page Class ReindWid1Page Members ReindWid1Page Class

Destructor.

C++
~ReindWid1Page();
Collapse Expand Class

ReindWid1Page Class

Collapse Expand Links
ReindWid1Page Class, ReindWid1Page Members, ReindWid1Page Class


ReindWid1Page Data Members

ReindWid1Page Data Members
ReindWid1Page Class Legend Public Data Members

The data members of the ReindWid1Page class are listed here.

Collapse Expand Class

ReindWid1Page Class

Collapse Expand Public Data Members
Name | Description
reindWid | Reindexed widow(er) calculation.
Collapse Expand Links
ReindWid1Page Class, Legend, Public Data Members


ReindWid1Page::reindWid Data Member

ReindWid1Page::reindWid Data Member
ReindWid1Page Class ReindWid1Page Members ReindWid1Page Data Members

Reindexed widow(er) calculation.

C++
const ReindWid* reindWid;
Collapse Expand Group

ReindWid1Page Data Members

Collapse Expand Links
ReindWid1Page Class, ReindWid1Page Members, ReindWid1Page Data Members


ReindWid1Page Methods

ReindWid1Page Methods
ReindWid1Page Class Legend Public Methods

The methods of the ReindWid1Page class are listed here.

Collapse Expand Class

ReindWid1Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares reindexed widow strings for printing.
Collapse Expand Links
ReindWid1Page Class, Legend, Public Methods


ReindWid1Page::prepareStrings Method

ReindWid1Page::prepareStrings Method
ReindWid1Page Class ReindWid1Page Members ReindWid1Page Methods

Prepares reindexed widow strings for printing.

C++
void prepareStrings();
Collapse Expand Group

ReindWid1Page Methods

Collapse Expand Links
ReindWid1Page Class, ReindWid1Page Members, ReindWid1Page Methods


ReindWid2Page Class

ReindWid2Page Class
ReindWid2Page Data Members ReindWid2Page Methods ReindWid2Page Members ReindWid2Page.h Classes

Manages a re-indexed widow calculation results page from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  ReindWid2PageReindWid2PageReindWid2Page
C++
class ReindWid2Page : public PiaPageOut;
Collapse Expand File

File: ReindWid2Page.h

Module: PiaOut Library

Collapse Expand Remarks

Five instances of this class are created in PiaOut.

This is used in combination with ReindWid1Page.

Collapse Expand See Also

ReindWid1Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
ReindWid2Page Data Members, ReindWid2Page Methods, ReindWid2Page Members, ReindWid2Page.h, Classes


ReindWid2Page Members

ReindWid2Page Members
ReindWid2Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by ReindWid2Page.

Collapse Expand Class

ReindWid2Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
reindWid | Reindexed widow(er) calculation.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
ReindWid2Page | Initializes ReindWid2Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares reindexed widow strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~ReindWid2Page | Destructor.
Collapse Expand Links
ReindWid2Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


ReindWid2Page::ReindWid2Page Constructor

ReindWid2Page::ReindWid2Page Constructor
ReindWid2Page Class ReindWid2Page Members ReindWid2Page Class

Initializes ReindWid2Page.

C++
ReindWid2Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

ReindWid2Page Class

Collapse Expand Links
ReindWid2Page Class, ReindWid2Page Members, ReindWid2Page Class


ReindWid2Page::~ReindWid2Page Destructor

ReindWid2Page::~ReindWid2Page Destructor
ReindWid2Page Class ReindWid2Page Members ReindWid2Page Class

Destructor.

C++
~ReindWid2Page();
Collapse Expand Class

ReindWid2Page Class

Collapse Expand Links
ReindWid2Page Class, ReindWid2Page Members, ReindWid2Page Class


ReindWid2Page Data Members

ReindWid2Page Data Members
ReindWid2Page Class Legend Public Data Members

The data members of the ReindWid2Page class are listed here.

Collapse Expand Class

ReindWid2Page Class

Collapse Expand Public Data Members
Name | Description
reindWid | Reindexed widow(er) calculation.
Collapse Expand Links
ReindWid2Page Class, Legend, Public Data Members


ReindWid2Page::reindWid Data Member

ReindWid2Page::reindWid Data Member
ReindWid2Page Class ReindWid2Page Members ReindWid2Page Data Members

Reindexed widow(er) calculation.

C++
const ReindWid* reindWid;
Collapse Expand Group

ReindWid2Page Data Members

Collapse Expand Links
ReindWid2Page Class, ReindWid2Page Members, ReindWid2Page Data Members


ReindWid2Page Methods

ReindWid2Page Methods
ReindWid2Page Class Legend Public Methods

The methods of the ReindWid2Page class are listed here.

Collapse Expand Class

ReindWid2Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares reindexed widow strings for printing.
Collapse Expand Links
ReindWid2Page Class, Legend, Public Methods


ReindWid2Page::prepareStrings Method

ReindWid2Page::prepareStrings Method
ReindWid2Page Class ReindWid2Page Members ReindWid2Page Methods

Prepares reindexed widow strings for printing.

C++
void prepareStrings();
Collapse Expand Group

ReindWid2Page Methods

Collapse Expand Links
ReindWid2Page Class, ReindWid2Page Members, ReindWid2Page Methods


SpecMin1Page Class

SpecMin1Page Class
SpecMin1Page Methods SpecMin1Page Members SpecMin1Page.h Classes

Manages a special minimum earnings page from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  SpecMin1PageSpecMin1PageSpecMin1Page
C++
class SpecMin1Page : public PiaPageOut;
Collapse Expand File

File: SpecMin1Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with SpecMin2Page.

Collapse Expand See Also

SpecMin2Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
SpecMin1Page Methods, SpecMin1Page Members, SpecMin1Page.h, Classes


SpecMin1Page Members

SpecMin1Page Members
SpecMin1Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by SpecMin1Page.

Collapse Expand Class

SpecMin1Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
SpecMin1Page | Initializes SpecMin1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares special minimum strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~SpecMin1Page | Destructor.
Collapse Expand Links
SpecMin1Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


SpecMin1Page::SpecMin1Page Constructor

SpecMin1Page::SpecMin1Page Constructor
SpecMin1Page Class SpecMin1Page Members SpecMin1Page Class

Initializes SpecMin1Page.

C++
SpecMin1Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

SpecMin1Page Class

Collapse Expand Links
SpecMin1Page Class, SpecMin1Page Members, SpecMin1Page Class


SpecMin1Page::~SpecMin1Page Destructor

SpecMin1Page::~SpecMin1Page Destructor
SpecMin1Page Class SpecMin1Page Members SpecMin1Page Class

Destructor.

C++
~SpecMin1Page();
Collapse Expand Class

SpecMin1Page Class

Collapse Expand Links
SpecMin1Page Class, SpecMin1Page Members, SpecMin1Page Class


SpecMin1Page Methods

SpecMin1Page Methods
SpecMin1Page Class Legend Public Methods

The methods of the SpecMin1Page class are listed here.

Collapse Expand Class

SpecMin1Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares special minimum strings for printing.
Collapse Expand Links
SpecMin1Page Class, Legend, Public Methods


SpecMin1Page::prepareStrings Method

SpecMin1Page::prepareStrings Method
SpecMin1Page Class SpecMin1Page Members SpecMin1Page Methods

Prepares special minimum strings for printing.

C++
void prepareStrings();
Collapse Expand Group

SpecMin1Page Methods

Collapse Expand Links
SpecMin1Page Class, SpecMin1Page Members, SpecMin1Page Methods


SpecMin2Page Class

SpecMin2Page Class
SpecMin2Page Methods SpecMin2Page Members SpecMin2Page.h Classes

Manages a special minimum calculation details page from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  SpecMin2PageSpecMin2PageSpecMin2Page
C++
class SpecMin2Page : public PiaPageOut;
Collapse Expand File

File: SpecMin2Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with SpecMin1Page.

Collapse Expand See Also

SpecMin1Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
SpecMin2Page Methods, SpecMin2Page Members, SpecMin2Page.h, Classes


SpecMin2Page Members

SpecMin2Page Members
SpecMin2Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by SpecMin2Page.

Collapse Expand Class

SpecMin2Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
SpecMin2Page | Initializes this instance.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares special minimum strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~SpecMin2Page | Destructor.
Collapse Expand Links
SpecMin2Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


SpecMin2Page::SpecMin2Page Constructor

SpecMin2Page::SpecMin2Page Constructor
SpecMin2Page Class SpecMin2Page Members SpecMin2Page Class

Initializes this instance.

C++
SpecMin2Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

SpecMin2Page Class

Collapse Expand Links
SpecMin2Page Class, SpecMin2Page Members, SpecMin2Page Class


SpecMin2Page::~SpecMin2Page Destructor

SpecMin2Page::~SpecMin2Page Destructor
SpecMin2Page Class SpecMin2Page Members SpecMin2Page Class

Destructor.

C++
~SpecMin2Page();
Collapse Expand Class

SpecMin2Page Class

Collapse Expand Links
SpecMin2Page Class, SpecMin2Page Members, SpecMin2Page Class


SpecMin2Page Methods

SpecMin2Page Methods
SpecMin2Page Class Legend Public Methods

The methods of the SpecMin2Page class are listed here.

Collapse Expand Class

SpecMin2Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares special minimum strings for printing.
Collapse Expand Links
SpecMin2Page Class, Legend, Public Methods


SpecMin2Page::prepareStrings Method

SpecMin2Page::prepareStrings Method
SpecMin2Page Class SpecMin2Page Members SpecMin2Page Methods

Prepares special minimum strings for printing.

C++
void prepareStrings();
Collapse Expand Group

SpecMin2Page Methods

Collapse Expand Links
SpecMin2Page Class, SpecMin2Page Members, SpecMin2Page Methods


Summary1Page Class

Summary1Page Class
Summary1Page Methods Summary1Page Members Summary1Page.h Classes

Manages the top part of the summary of results page from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  Summary1PageSummary1PageSummary1Page
C++
class Summary1Page : public PiaPageOut;
Collapse Expand File

File: Summary1Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with Summary2Page and Summary3Page.

Collapse Expand See Also

Summary2Page, Summary3Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
Summary1Page Methods, Summary1Page Members, Summary1Page.h, Classes


Summary1Page Members

Summary1Page Members
Summary1Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by Summary1Page.

Collapse Expand Class

Summary1Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
Summary1Page | Initializes Summary1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares top part of summary page.
print | Writes the output strings to the specified device.
printDisInfo | Prints disability information.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~Summary1Page | Destructor.
Collapse Expand Links
Summary1Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


Summary1Page::Summary1Page Constructor

Summary1Page::Summary1Page Constructor
Summary1Page Class Summary1Page Members Summary1Page Class

Initializes Summary1Page.

C++
Summary1Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

Summary1Page Class

Collapse Expand Links
Summary1Page Class, Summary1Page Members, Summary1Page Class


Summary1Page::~Summary1Page Destructor

Summary1Page::~Summary1Page Destructor
Summary1Page Class Summary1Page Members Summary1Page Class

Destructor.

C++
~Summary1Page();
Collapse Expand Class

Summary1Page Class

Collapse Expand Links
Summary1Page Class, Summary1Page Members, Summary1Page Class


Summary1Page Methods

Summary1Page Methods
Summary1Page Class Legend Public Methods

The methods of the Summary1Page class are listed here.

Collapse Expand Class

Summary1Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares top part of summary page.
printDisInfo | Prints disability information.
Collapse Expand Links
Summary1Page Class, Legend, Public Methods


Summary1Page::prepareStrings Method

Summary1Page::prepareStrings Method
Summary1Page Class Summary1Page Members Summary1Page Methods

Prepares top part of summary page.

C++
void prepareStrings();
Collapse Expand Group

Summary1Page Methods

Collapse Expand Links
Summary1Page Class, Summary1Page Members, Summary1Page Methods


Summary1Page::printDisInfo Method

Summary1Page::printDisInfo Method
Summary1Page Class Summary1Page Members Summary1Page Methods

Prints disability information.

C++
void printDisInfo();
Collapse Expand Remarks

Called from prepareStrings only if there is a disability.

Collapse Expand Group

Summary1Page Methods

Collapse Expand Links
Summary1Page Class, Summary1Page Members, Summary1Page Methods


Summary2Page Class

Summary2Page Class
Summary2Page Methods Summary2Page Members Summary2Page.h Classes

Manages the middle part of the summary of results page from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  Summary2PageSummary2Page
C++
class Summary2Page : public PageOut;
Collapse Expand File

File: Summary2Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with Summary1Page and Summary3Page.

Collapse Expand See Also

Summary1Page, Summary3Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
Summary2Page Methods, Summary2Page Members, Summary2Page.h, Classes


Summary2Page Members

Summary2Page Members
Summary2Page Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by Summary2Page.

Collapse Expand Class

Summary2Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
Summary2Page | Initializes Summary2Page.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareStrings | Prepares middle part of summary page.
print | Writes the output strings to the specified device.
~Summary2Page | Destructor.
Collapse Expand Links
Summary2Page Class, Legend, Protected Data Members, Public Data Members, Public Methods


Summary2Page::Summary2Page Constructor

Summary2Page::Summary2Page Constructor
Summary2Page Class Summary2Page Members Summary2Page Class

Initializes Summary2Page.

C++
Summary2Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

Summary2Page Class

Collapse Expand Links
Summary2Page Class, Summary2Page Members, Summary2Page Class


Summary2Page::~Summary2Page Destructor

Summary2Page::~Summary2Page Destructor
Summary2Page Class Summary2Page Members Summary2Page Class

Destructor.

C++
~Summary2Page();
Collapse Expand Class

Summary2Page Class

Collapse Expand Links
Summary2Page Class, Summary2Page Members, Summary2Page Class


Summary2Page Methods

Summary2Page Methods
Summary2Page Class Legend Public Methods

The methods of the Summary2Page class are listed here.

Collapse Expand Class

Summary2Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares middle part of summary page.
Collapse Expand Links
Summary2Page Class, Legend, Public Methods


Summary2Page::prepareStrings Method

Summary2Page::prepareStrings Method
Summary2Page Class Summary2Page Members Summary2Page Methods

Prepares middle part of summary page.

C++
void prepareStrings();
Collapse Expand Group

Summary2Page Methods

Collapse Expand Links
Summary2Page Class, Summary2Page Members, Summary2Page Methods


Summary3Page Class

Summary3Page Class
Summary3Page Methods Summary3Page Members Summary3Page.h Classes

Manages the bottom part of the summary of results page from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  Summary3PageSummary3PageSummary3Page
C++
class Summary3Page : public PiaPageOut;
Collapse Expand File

File: Summary3Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with Summary1Page and Summary2Page.

Collapse Expand See Also

Summary1Page, Summary2Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
Summary3Page Methods, Summary3Page Members, Summary3Page.h, Classes


Summary3Page Members

Summary3Page Members
Summary3Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by Summary3Page.

Collapse Expand Class

Summary3Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
Summary3Page | Initializes Summary3Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
bottom3 | Prints bottom of summary.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
disclaimer | Prints disclaimer.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonInsPara | Prints noninsured paragraph.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares bottom part of summary page.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~Summary3Page | Destructor.
Collapse Expand Links
Summary3Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


Summary3Page::Summary3Page Constructor

Summary3Page::Summary3Page Constructor
Summary3Page Class Summary3Page Members Summary3Page Class

Initializes Summary3Page.

C++
Summary3Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

Summary3Page Class

Collapse Expand Links
Summary3Page Class, Summary3Page Members, Summary3Page Class


Summary3Page::~Summary3Page Destructor

Summary3Page::~Summary3Page Destructor
Summary3Page Class Summary3Page Members Summary3Page Class

Destructor.

C++
~Summary3Page();
Collapse Expand Class

Summary3Page Class

Collapse Expand Links
Summary3Page Class, Summary3Page Members, Summary3Page Class


Summary3Page Methods

Summary3Page Methods
Summary3Page Class Legend Public Methods

The methods of the Summary3Page class are listed here.

Collapse Expand Class

Summary3Page Class

Collapse Expand Public Methods
Name | Description
bottom3 | Prints bottom of summary.
disclaimer | Prints disclaimer.
nonInsPara | Prints noninsured paragraph.
prepareStrings | Prepares bottom part of summary page.
Collapse Expand Links
Summary3Page Class, Legend, Public Methods


Summary3Page::bottom3 Method

Summary3Page::bottom3 Method
Summary3Page Class Summary3Page Members Summary3Page Methods

Prints bottom of summary.

C++
void bottom3(
    bool isPebs
);
Collapse Expand Parameters
Parameters | Description
bool isPebs | True if old PEBES assumptions, false otherwise.
Collapse Expand Group

Summary3Page Methods

Collapse Expand Links
Summary3Page Class, Summary3Page Members, Summary3Page Methods


Summary3Page::disclaimer Method

Summary3Page::disclaimer Method
Summary3Page Class Summary3Page Members Summary3Page Methods

Prints disclaimer.

C++
void disclaimer();
Collapse Expand Remarks

The disclaimer mentions that the benefit is an estimate, and varies slightly depending on the economic assumptions used, if any.

Collapse Expand Group

Summary3Page Methods

Collapse Expand Links
Summary3Page Class, Summary3Page Members, Summary3Page Methods


Summary3Page::nonInsPara Method

Summary3Page::nonInsPara Method
Summary3Page Class Summary3Page Members Summary3Page Methods

Prints noninsured paragraph.

C++
void nonInsPara();
Collapse Expand Group

Summary3Page Methods

Collapse Expand Links
Summary3Page Class, Summary3Page Members, Summary3Page Methods


Summary3Page::prepareStrings Method

Summary3Page::prepareStrings Method
Summary3Page Class Summary3Page Members Summary3Page Methods

Prepares bottom part of summary page.

C++
void prepareStrings();
Collapse Expand Group

Summary3Page Methods

Collapse Expand Links
Summary3Page Class, Summary3Page Members, Summary3Page Methods


SummaryPage Class

SummaryPage Class
SummaryPage Methods SummaryPage Members SummaryPage.h Classes

Manages the summary page of results from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  SummaryPageSummaryPage
C++
class SummaryPage : public PageOut;
Collapse Expand File

File: SummaryPage.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

It contains references to a Summary1Page, Summary2Page, and Summary3Page.

Collapse Expand See Also

Summary1Page, Summary2Page, Summary3Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
SummaryPage Methods, SummaryPage Members, SummaryPage.h, Classes


SummaryPage Members

SummaryPage Members
SummaryPage Class Legend Protected Data Members Public Data Members Public Methods

The following tables list the members exposed by SummaryPage.

Collapse Expand Class

SummaryPage Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
SummaryPage | Initializes SummaryPage.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareStrings | Prepares the three parts of the summary page.
print | Writes the output strings to the specified device.
~SummaryPage | Destructor.
Collapse Expand Links
SummaryPage Class, Legend, Protected Data Members, Public Data Members, Public Methods


SummaryPage::SummaryPage Constructor

SummaryPage::SummaryPage Constructor
SummaryPage Class SummaryPage Members SummaryPage Class

Initializes SummaryPage.

C++
SummaryPage(
    const Summary1Page& newSummary1Page,
    const Summary2Page& newSummary2Page,
    const Summary3Page& newSummary3Page
);
Collapse Expand Parameters
Parameters | Description
const Summary1Page& newSummary1Page | Top part of summary page.
const Summary2Page& newSummary2Page | Middle part of summary page.
const Summary3Page& newSummary3Page | Bottom part of summary page.
Collapse Expand Class

SummaryPage Class

Collapse Expand Links
SummaryPage Class, SummaryPage Members, SummaryPage Class


SummaryPage::~SummaryPage Destructor

SummaryPage::~SummaryPage Destructor
SummaryPage Class SummaryPage Members SummaryPage Class

Destructor.

C++
~SummaryPage();
Collapse Expand Class

SummaryPage Class

Collapse Expand Links
SummaryPage Class, SummaryPage Members, SummaryPage Class


SummaryPage Methods

SummaryPage Methods
SummaryPage Class Legend Public Methods

The methods of the SummaryPage class are listed here.

Collapse Expand Class

SummaryPage Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares the three parts of the summary page.
Collapse Expand Links
SummaryPage Class, Legend, Public Methods


SummaryPage::prepareStrings Method

SummaryPage::prepareStrings Method
SummaryPage Class SummaryPage Members SummaryPage Methods

Prepares the three parts of the summary page.

C++
void prepareStrings();
Collapse Expand Group

SummaryPage Methods

Collapse Expand Links
SummaryPage Class, SummaryPage Members, SummaryPage Methods


TaxesPage Class

TaxesPage Class
TaxesPage Methods TaxesPage Members TaxesPage.h Classes

Manages the taxes output page.

Collapse Expand Class Hierarchy
  TaxesPageTaxesPageTaxesPage
C++
class TaxesPage : public PiaPageOut;
Collapse Expand File

File: TaxesPage.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

Collapse Expand See Also

PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
TaxesPage Methods, TaxesPage Members, TaxesPage.h, Classes


TaxesPage Members

TaxesPage Members
TaxesPage Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by TaxesPage.

Collapse Expand Class

TaxesPage Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
TaxesPage | Initializes TaxesPage.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares taxes strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~TaxesPage | Destructor.
Collapse Expand Links
TaxesPage Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


TaxesPage::TaxesPage Constructor

TaxesPage::TaxesPage Constructor
TaxesPage Class TaxesPage Members TaxesPage Class

Initializes TaxesPage.

C++
TaxesPage(
    const WorkerDataGeneral& newWorkerData,
    const PiaData& newPiaData,
    const TaxData& newTaxData
);
Collapse Expand Parameters
Parameters | Description
const WorkerDataGeneral& newWorkerData | Worker basic data.
const PiaData& newPiaData | Benefit calculation data.
const TaxData& newTaxData | Taxes paid.
Collapse Expand Class

TaxesPage Class

Collapse Expand Links
TaxesPage Class, TaxesPage Members, TaxesPage Class


TaxesPage::~TaxesPage Destructor

TaxesPage::~TaxesPage Destructor
TaxesPage Class TaxesPage Members TaxesPage Class

Destructor.

C++
~TaxesPage();
Collapse Expand Class

TaxesPage Class

Collapse Expand Links
TaxesPage Class, TaxesPage Members, TaxesPage Class


TaxesPage Methods

TaxesPage Methods
TaxesPage Class Legend Public Methods

The methods of the TaxesPage class are listed here.

Collapse Expand Class

TaxesPage Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares taxes strings for printing.
Collapse Expand Links
TaxesPage Class, Legend, Public Methods


TaxesPage::prepareStrings Method

TaxesPage::prepareStrings Method
TaxesPage Class TaxesPage Members TaxesPage Methods

Prepares taxes strings for printing.

C++
void prepareStrings();
Collapse Expand Group

TaxesPage Methods

Collapse Expand Links
TaxesPage Class, TaxesPage Members, TaxesPage Methods


TransGuar1Page Class

TransGuar1Page Class
TransGuar1Page Methods TransGuar1Page Members TransGuar1Page.h Classes

Manages the transitional guarantee earnings page from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  TransGuar1PageTransGuar1PageTransGuar1Page
C++
class TransGuar1Page : public PiaPageOut;
Collapse Expand File

File: TransGuar1Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with TransGuar2Page.

Collapse Expand See Also

TransGuar2Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
TransGuar1Page Methods, TransGuar1Page Members, TransGuar1Page.h, Classes


TransGuar1Page Members

TransGuar1Page Members
TransGuar1Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by TransGuar1Page.

Collapse Expand Class

TransGuar1Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
TransGuar1Page | Initializes TransGuar1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares transitional guarantee strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~TransGuar1Page | Destructor.
Collapse Expand Links
TransGuar1Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


TransGuar1Page::TransGuar1Page Constructor

TransGuar1Page::TransGuar1Page Constructor
TransGuar1Page Class TransGuar1Page Members TransGuar1Page Class

Initializes TransGuar1Page.

C++
TransGuar1Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

TransGuar1Page Class

Collapse Expand Links
TransGuar1Page Class, TransGuar1Page Members, TransGuar1Page Class


TransGuar1Page::~TransGuar1Page Destructor

TransGuar1Page::~TransGuar1Page Destructor
TransGuar1Page Class TransGuar1Page Members TransGuar1Page Class

Destructor.

C++
~TransGuar1Page();
Collapse Expand Class

TransGuar1Page Class

Collapse Expand Links
TransGuar1Page Class, TransGuar1Page Members, TransGuar1Page Class


TransGuar1Page Methods

TransGuar1Page Methods
TransGuar1Page Class Legend Public Methods

The methods of the TransGuar1Page class are listed here.

Collapse Expand Class

TransGuar1Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares transitional guarantee strings for printing.
Collapse Expand Links
TransGuar1Page Class, Legend, Public Methods


TransGuar1Page::prepareStrings Method

TransGuar1Page::prepareStrings Method
TransGuar1Page Class TransGuar1Page Members TransGuar1Page Methods

Prepares transitional guarantee strings for printing.

C++
void prepareStrings();
Collapse Expand Group

TransGuar1Page Methods

Collapse Expand Links
TransGuar1Page Class, TransGuar1Page Members, TransGuar1Page Methods


TransGuar2Page Class

TransGuar2Page Class
TransGuar2Page Methods TransGuar2Page Members TransGuar2Page.h Classes

Manages the transitional guarantee results page from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  TransGuar2PageTransGuar2PageTransGuar2Page
C++
class TransGuar2Page : public PiaPageOut;
Collapse Expand File

File: TransGuar2Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with TransGuar1Page.

Collapse Expand See Also

TransGuar1Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
TransGuar2Page Methods, TransGuar2Page Members, TransGuar2Page.h, Classes


TransGuar2Page Members

TransGuar2Page Members
TransGuar2Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by TransGuar2Page.

Collapse Expand Class

TransGuar2Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
TransGuar2Page | Initializes TransGuar2Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares transitional guarantee strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~TransGuar2Page | Destructor.
Collapse Expand Links
TransGuar2Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


TransGuar2Page::TransGuar2Page Constructor

TransGuar2Page::TransGuar2Page Constructor
TransGuar2Page Class TransGuar2Page Members TransGuar2Page Class

Initializes TransGuar2Page.

C++
TransGuar2Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

TransGuar2Page Class

Collapse Expand Links
TransGuar2Page Class, TransGuar2Page Members, TransGuar2Page Class


TransGuar2Page::~TransGuar2Page Destructor

TransGuar2Page::~TransGuar2Page Destructor
TransGuar2Page Class TransGuar2Page Members TransGuar2Page Class

Destructor.

C++
~TransGuar2Page();
Collapse Expand Class

TransGuar2Page Class

Collapse Expand Links
TransGuar2Page Class, TransGuar2Page Members, TransGuar2Page Class


TransGuar2Page Methods

TransGuar2Page Methods
TransGuar2Page Class Legend Public Methods

The methods of the TransGuar2Page class are listed here.

Collapse Expand Class

TransGuar2Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares transitional guarantee strings for printing.
Collapse Expand Links
TransGuar2Page Class, Legend, Public Methods


TransGuar2Page::prepareStrings Method

TransGuar2Page::prepareStrings Method
TransGuar2Page Class TransGuar2Page Members TransGuar2Page Methods

Prepares transitional guarantee strings for printing.

C++
void prepareStrings();
Collapse Expand Group

TransGuar2Page Methods

Collapse Expand Links
TransGuar2Page Class, TransGuar2Page Members, TransGuar2Page Methods


WageInd1Page Class

WageInd1Page Class
WageInd1Page Methods WageInd1Page Members WageInd1Page.h Classes

Manages a wage indexed earnings page from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  WageInd1PageWageInd1PageWageInd1Page
C++
class WageInd1Page : public PiaPageOut;
Collapse Expand File

File: WageInd1Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with WageInd2Page.

Collapse Expand See Also

WageInd2Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
WageInd1Page Methods, WageInd1Page Members, WageInd1Page.h, Classes


WageInd1Page Members

WageInd1Page Members
WageInd1Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by WageInd1Page.

Collapse Expand Class

WageInd1Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
WageInd1Page | Initializes WageInd1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares wage indexed strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~WageInd1Page | Destructor.
Collapse Expand Links
WageInd1Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


WageInd1Page::WageInd1Page Constructor

WageInd1Page::WageInd1Page Constructor
WageInd1Page Class WageInd1Page Members WageInd1Page Class

Initializes WageInd1Page.

C++
WageInd1Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

WageInd1Page Class

Collapse Expand Links
WageInd1Page Class, WageInd1Page Members, WageInd1Page Class


WageInd1Page::~WageInd1Page Destructor

WageInd1Page::~WageInd1Page Destructor
WageInd1Page Class WageInd1Page Members WageInd1Page Class

Destructor.

C++
~WageInd1Page();
Collapse Expand Class

WageInd1Page Class

Collapse Expand Links
WageInd1Page Class, WageInd1Page Members, WageInd1Page Class


WageInd1Page Methods

WageInd1Page Methods
WageInd1Page Class Legend Public Methods

The methods of the WageInd1Page class are listed here.

Collapse Expand Class

WageInd1Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares wage indexed strings for printing.
Collapse Expand Links
WageInd1Page Class, Legend, Public Methods


WageInd1Page::prepareStrings Method

WageInd1Page::prepareStrings Method
WageInd1Page Class WageInd1Page Members WageInd1Page Methods

Prepares wage indexed strings for printing.

C++
void prepareStrings();
Collapse Expand Group

WageInd1Page Methods

Collapse Expand Links
WageInd1Page Class, WageInd1Page Members, WageInd1Page Methods


WageInd2Page Class

WageInd2Page Class
WageInd2Page Methods WageInd2Page Members WageInd2Page.h Classes

Manages a wage indexed results page from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  WageInd2PageWageInd2PageWageInd2Page
C++
class WageInd2Page : public PiaPageOut;
Collapse Expand File

File: WageInd2Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with WageInd1Page.

Collapse Expand See Also

WageInd1Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
WageInd2Page Methods, WageInd2Page Members, WageInd2Page.h, Classes


WageInd2Page Members

WageInd2Page Members
WageInd2Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by WageInd2Page.

Collapse Expand Class

WageInd2Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
WageInd2Page | Initializes WageInd2Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares wage indexed strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~WageInd2Page | Destructor.
Collapse Expand Links
WageInd2Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


WageInd2Page::WageInd2Page Constructor

WageInd2Page::WageInd2Page Constructor
WageInd2Page Class WageInd2Page Members WageInd2Page Class

Initializes WageInd2Page.

C++
WageInd2Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

WageInd2Page Class

Collapse Expand Links
WageInd2Page Class, WageInd2Page Members, WageInd2Page Class


WageInd2Page::~WageInd2Page Destructor

WageInd2Page::~WageInd2Page Destructor
WageInd2Page Class WageInd2Page Members WageInd2Page Class

Destructor.

C++
~WageInd2Page();
Collapse Expand Class

WageInd2Page Class

Collapse Expand Links
WageInd2Page Class, WageInd2Page Members, WageInd2Page Class


WageInd2Page Methods

WageInd2Page Methods
WageInd2Page Class Legend Public Methods

The methods of the WageInd2Page class are listed here.

Collapse Expand Class

WageInd2Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares wage indexed strings for printing.
Collapse Expand Links
WageInd2Page Class, Legend, Public Methods


WageInd2Page::prepareStrings Method

WageInd2Page::prepareStrings Method
WageInd2Page Class WageInd2Page Members WageInd2Page Methods

Prepares wage indexed strings for printing.

C++
void prepareStrings();
Collapse Expand Group

WageInd2Page Methods

Collapse Expand Links
WageInd2Page Class, WageInd2Page Members, WageInd2Page Methods


WageIndNonFreeze1Page Class

WageIndNonFreeze1Page Class
WageIndNonFreeze1Page Methods WageIndNonFreeze1Page Members WageIndNonFreeze1Page.h Classes

Manages a wage indexed non-freeze page from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  WageIndNonFreeze1PageWageIndNonFreeze1PageWageIndNonFreeze1Page
C++
class WageIndNonFreeze1Page : public PiaPageOut;
Collapse Expand File

File: WageIndNonFreeze1Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with WageIndNonFreeze2Page.

Collapse Expand See Also

WageIndNonFreeze2Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
WageIndNonFreeze1Page Methods, WageIndNonFreeze1Page Members, WageIndNonFreeze1Page.h, Classes


WageIndNonFreeze1Page Members

WageIndNonFreeze1Page Members
WageIndNonFreeze1Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by WageIndNonFreeze1Page.

Collapse Expand Class

WageIndNonFreeze1Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
WageIndNonFreeze1Page | Initializes WageIndNonFreeze1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares wage indexed strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~WageIndNonFreeze1Page | Destructor.
Collapse Expand Links
WageIndNonFreeze1Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


WageIndNonFreeze1Page::WageIndNonFreeze1Page Constructor

WageIndNonFreeze1Page::WageIndNonFreeze1Page Constructor
WageIndNonFreeze1Page Class WageIndNonFreeze1Page Members WageIndNonFreeze1Page Class

Initializes WageIndNonFreeze1Page.

C++
WageIndNonFreeze1Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

WageIndNonFreeze1Page Class

Collapse Expand Links
WageIndNonFreeze1Page Class, WageIndNonFreeze1Page Members, WageIndNonFreeze1Page Class


WageIndNonFreeze1Page::~WageIndNonFreeze1Page Destructor

WageIndNonFreeze1Page::~WageIndNonFreeze1Page Destructor
WageIndNonFreeze1Page Class WageIndNonFreeze1Page Members WageIndNonFreeze1Page Class

Destructor.

C++
~WageIndNonFreeze1Page();
Collapse Expand Class

WageIndNonFreeze1Page Class

Collapse Expand Links
WageIndNonFreeze1Page Class, WageIndNonFreeze1Page Members, WageIndNonFreeze1Page Class


WageIndNonFreeze1Page Methods

WageIndNonFreeze1Page Methods
WageIndNonFreeze1Page Class Legend Public Methods

The methods of the WageIndNonFreeze1Page class are listed here.

Collapse Expand Class

WageIndNonFreeze1Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares wage indexed strings for printing.
Collapse Expand Links
WageIndNonFreeze1Page Class, Legend, Public Methods


WageIndNonFreeze1Page::prepareStrings Method

WageIndNonFreeze1Page::prepareStrings Method
WageIndNonFreeze1Page Class WageIndNonFreeze1Page Members WageIndNonFreeze1Page Methods

Prepares wage indexed strings for printing.

C++
void prepareStrings();
Collapse Expand Group

WageIndNonFreeze1Page Methods

Collapse Expand Links
WageIndNonFreeze1Page Class, WageIndNonFreeze1Page Members, WageIndNonFreeze1Page Methods


WageIndNonFreeze2Page Class

WageIndNonFreeze2Page Class
WageIndNonFreeze2Page Methods WageIndNonFreeze2Page Members WageIndNonFreeze2Page.h Classes

Manages a wage indexed non-freeze results page from the calculation of a Social Security benefit.

Collapse Expand Class Hierarchy
  WageIndNonFreeze2PageWageIndNonFreeze2PageWageIndNonFreeze2Page
C++
class WageIndNonFreeze2Page : public PiaPageOut;
Collapse Expand File

File: WageIndNonFreeze2Page.h

Module: PiaOut Library

Collapse Expand Remarks

An instance of this class is created in PiaOut.

This is used in combination with WageIndNonFreeze1Page.

Collapse Expand See Also

WageIndNonFreeze1Page, PiaOut

Collapse Expand Group

Classes

Collapse Expand Links
WageIndNonFreeze2Page Methods, WageIndNonFreeze2Page Members, WageIndNonFreeze2Page.h, Classes


WageIndNonFreeze2Page Members

WageIndNonFreeze2Page Members
WageIndNonFreeze2Page Class Legend Protected Data Members Protected Methods Public Data Members Public Methods

The following tables list the members exposed by WageIndNonFreeze2Page.

Collapse Expand Class

WageIndNonFreeze2Page Class

Collapse Expand Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
Collapse Expand Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
Collapse Expand Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
Collapse Expand Public Methods
Show:
No members matching the current filter
Name | Description
WageIndNonFreeze2Page | Initializes WageIndNonFreeze2Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares wage indexed strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~WageIndNonFreeze2Page | Destructor.
Collapse Expand Links
WageIndNonFreeze2Page Class, Legend, Protected Data Members, Protected Methods, Public Data Members, Public Methods


WageIndNonFreeze2Page::WageIndNonFreeze2Page Constructor

WageIndNonFreeze2Page::WageIndNonFreeze2Page Constructor
WageIndNonFreeze2Page Class WageIndNonFreeze2Page Members WageIndNonFreeze2Page Class

Initializes WageIndNonFreeze2Page.

C++
WageIndNonFreeze2Page(
    const PiaCalAny& newPiaCal
);
Collapse Expand Parameters
Parameters | Description
const PiaCalAny& newPiaCal | Benefit calculation parameters and results.
Collapse Expand Class

WageIndNonFreeze2Page Class

Collapse Expand Links
WageIndNonFreeze2Page Class, WageIndNonFreeze2Page Members, WageIndNonFreeze2Page Class


WageIndNonFreeze2Page::~WageIndNonFreeze2Page Destructor

WageIndNonFreeze2Page::~WageIndNonFreeze2Page Destructor
WageIndNonFreeze2Page Class WageIndNonFreeze2Page Members WageIndNonFreeze2Page Class

Destructor.

C++
~WageIndNonFreeze2Page();
Collapse Expand Class

WageIndNonFreeze2Page Class

Collapse Expand Links
WageIndNonFreeze2Page Class, WageIndNonFreeze2Page Members, WageIndNonFreeze2Page Class


WageIndNonFreeze2Page Methods

WageIndNonFreeze2Page Methods
WageIndNonFreeze2Page Class Legend Public Methods

The methods of the WageIndNonFreeze2Page class are listed here.

Collapse Expand Class

WageIndNonFreeze2Page Class

Collapse Expand Public Methods
Name | Description
prepareStrings | Prepares wage indexed strings for printing.
Collapse Expand Links
WageIndNonFreeze2Page Class, Legend, Public Methods


WageIndNonFreeze2Page::prepareStrings Method

WageIndNonFreeze2Page::prepareStrings Method
WageIndNonFreeze2Page Class WageIndNonFreeze2Page Members WageIndNonFreeze2Page Methods

Prepares wage indexed strings for printing.

C++
void prepareStrings();
Collapse Expand Group

WageIndNonFreeze2Page Methods

Collapse Expand Links
WageIndNonFreeze2Page Class, WageIndNonFreeze2Page Members, WageIndNonFreeze2Page Methods


Files

Files
Files PiaOut Library

The following table lists files in this documentation.

Collapse Expand Files
Name | Description
AnypiaOut.cpp | Functions for the AnypiaOut class to manage all output pages from Anypia.
AnypiaOut.h | Declarations for the AnypiaOut class to manage all output pages from Anypia.
ChildCareCalc1Page.cpp | Functions for the ChildCareCalc1Page class to manage wage indexed earnings with child-care dropout years.
ChildCareCalc1Page.h | Declarations for the ChildCareCalc1Page class to manage wage indexed earnings with child-care dropout years.
ChildCareCalc2Page.cpp | Functions for the ChildCareCalc2Page class to manage wage indexed results with child-care dropout years.
ChildCareCalc2Page.h | Declarations for the ChildCareCalc2Page class to manage wage indexed results with child-care dropout years.
DibGuarPage.cpp | Functions for the DibGuarPage class to manage disability guarantee calculation output.
DibGuarPage.h | Declarations for the DibGuarPage class to manage disability guarantee calculation output.
EarningsPage.cpp | Functions for the EarningsPage class to manage earnings output.
EarningsPage.h | Declarations for the EarningsPage class to manage earnings output.
FamilyPage.cpp | Functions for the FamilyPage class to manage family members' benefits output.
FamilyPage.h | Declarations for the FamilyPage class to manage family members' benefits output.
FrozMinPage.cpp | Functions for the FrozMinPage class to manage frozen minimum calculation output.
FrozMinPage.h | Declarations for the FrozMinPage class to manage frozen minimum calculation output.
InsuredPage.cpp | Functions for the InsuredPage class to manage insured status output.
InsuredPage.h | Declarations for the InsuredPage class to manage insured status output.
OldStart1Page.cpp | Functions for the OldStart1Page class to manage old start calculation earnings output.
OldStart1Page.h | Declarations for the OldStart1Page class to manage old start calculation earnings output.
OldStart2Page.cpp | Functions for the OldStart2Page class to manage old start calculation results.
OldStart2Page.h | Declarations for the OldStart2Page class to manage old start calculation results.
OnePage.cpp | Functions for the OnePage class to manage one-page summary of results.
OnePage.h | Declarations for the OnePage class to manage one-page summary of results.
PebsCreditInfo.cpp | Functions for the PebsCreditInfo class to manage the Social Security Statement credit info page.
PebsCreditInfo.h | Declarations for the PebsCreditInfo class to manage the Social Security Statement credit info page.
PebsEarnings.cpp | Functions for the PebsEarnings class to manage Social Security Statement earnings page.
PebsEarnings.h | Declarations for the PebsEarnings class to manage Social Security Statement earnings page.
PebsEarningsInfo.cpp | Functions for the PebsEarningsInfo class to manage the Social Security Statement earnings info page.
PebsEarningsInfo.h | Declarations for the PebsEarningsInfo class to manage the Social Security Statement earnings info page.
PebsLetter.cpp | Functions for the PebsLetter class to manage the Social Security Statement letter page.
PebsLetter.h | Declarations for the PebsLetter class to manage the Social Security Statement letter page.
PebsOasdiEst.cpp | Functions for the PebsOasdiEst class to manage the Social Security Statement oasdi estimates info page.
PebsOasdiEst.h | Declarations for the PebsOasdiEst class to manage the Social Security Statement oasdi estimates info page.
PebsOasdiInfo.cpp | Functions for the PebsOasdiInfo class to manage the Social Security Statement oasdi benefit info page.
PebsOasdiInfo.h | Declarations for the PebsOasdiInfo class to manage the Social Security Statement oasdi benefit info page.
PebsOut.cpp | Functions for the PebsOut class to print out the Social Security Statement.
PebsOut.h | Declarations for the PebsOut class to print out the Social Security Statement.
PebsPageOut.cpp | Functions for the PebsPageOut class - parent of classes to write out results of Social Security Statement benefit calculation.
PebsPageOut.h | Declarations for the PebsPageOut class - parent of classes to write out results of Social Security Statement benefit calculation.
PebsWorkerEarnings.cpp | Functions for the PebsWorkerEarnings class to manage the Social Security Statement worker info and earnings page.
PebsWorkerEarnings.h | Declarations for the PebsWorkerEarnings class to manage the Social Security Statement worker info and earnings page.
PebsWorkerInfo.cpp | Functions for the PebsWorkerInfo class to manage the Social Security Statement worker info page.
PebsWorkerInfo.h | Declarations for the PebsWorkerInfo class to manage the Social Security Statement worker info page.
PiaOut.cpp | Functions for the PiaOut class to manage output for a non-Statement calculation.
PiaOut.h | Declarations for the PiaOut class to manage output for a non-Statement calculation.
PiaPageOut.cpp | Functions for the PiaPageOut class - parent of classes to write out results of a non-Statement benefit calculation.
PiaPageOut.h | Declarations for the PiaPageOut class - parent of classes to write out results of a non-Statement benefit calculation.
PiaTable1Page.cpp | Functions for the PiaTable1Page class to manage a pia table calculation earnings page.
PiaTable1Page.h | Declarations for the PiaTable1Page class to manage a pia table calculation earnings page.
PiaTable2Page.cpp | Functions for the PiaTable2Page class to manage a pia table calculation results page.
PiaTable2Page.h | Declarations for the PiaTable2Page class to manage a pia table calculation results page.
ReindWid1Page.cpp | Functions for the ReindWid1Page class to manage a re-indexed widow earnings page.
ReindWid1Page.h | Declarations for the ReindWid1Page class to manage a re-indexed widow earnings page.
ReindWid2Page.cpp | Functions for the ReindWid2Page class to manage a re-indexed widow calculation results page.
ReindWid2Page.h | Declarations for the ReindWid2Page class to manage a re-indexed widow calculation results page.
SpecMin1Page.cpp | Functions for the SpecMin1Page class to manage a special minimum calculation earnings page.
SpecMin1Page.h | Declarations for the SpecMin1Page class to manage a special minimum calculation earnings page.
SpecMin2Page.cpp | Functions for the SpecMin2Page class to manage a special minimum calculation results page.
SpecMin2Page.h | Declarations for the SpecMin2Page class to manage a special minimum calculation results page.
Summary1Page.cpp | Functions for the Summary1Page class to manage the top part of a summary of results page.
Summary1Page.h | Declarations for the Summary1Page class to manage the top part of a summary of results page.
Summary2Page.cpp | Functions for the Summary2Page class to manage the middle part of a summary of results page.
Summary2Page.h | Declarations for the Summary2Page class to manage the middle part of a summary of results page.
Summary3Page.cpp | Functions for the Summary3Page class to manage the bottom part of a summary of results page.
Summary3Page.h | Declarations for the Summary3Page class to manage the bottom part of a summary of results page.
SummaryPage.cpp | Functions for the SummaryPage class to manage the summary page of results.
SummaryPage.h | Declarations for the SummaryPage class to manage the summary page of results.
TaxesPage.cpp | Functions for the TaxesPage class to manage the taxes output page.
TaxesPage.h | Declarations for the TaxesPage class to manage the taxes output page.
TransGuar1Page.cpp | Functions for the TransGuar1Page class to manage the transitional guarantee calculation earnings page.
TransGuar1Page.h | Declarations for the TransGuar1Page class to manage the transitional guarantee calculation earnings page.
TransGuar2Page.cpp | Functions for the TransGuar2Page class to manage the transitional guarantee calculation results page.
TransGuar2Page.h | Declarations for the TransGuar2Page class to manage the transitional guarantee calculation results page.
WageInd1Page.cpp | Functions for the WageInd1Page class to manage a wage indexed earnings page.
WageInd1Page.h | Declarations for the WageInd1Page class to manage a wage indexed earnings page.
WageInd2Page.cpp | Functions for the WageInd2Page class to manage a wage indexed reuslts page.
WageInd2Page.h | Declarations for the WageInd2Page class to manage a wage indexed reuslts page.
WageIndNonFreeze1Page.cpp | Functions for the WageIndNonFreeze1Page class to manage a wage indexed earnings page.
WageIndNonFreeze1Page.h | Declarations for the WageIndNonFreeze1Page class to manage a wage indexed earnings page.
WageIndNonFreeze2Page.cpp | Functions for the WageIndNonFreeze2Page class to manage a wage indexed results page.
WageIndNonFreeze2Page.h | Declarations for the WageIndNonFreeze2Page class to manage a wage indexed results page.
Collapse Expand Module

PiaOut Library

Collapse Expand Links
Files, PiaOut Library


AnypiaOut.cpp

AnypiaOut.cpp
Files

Functions for the AnypiaOut class to manage all output pages from Anypia.

Collapse Expand Group

Files

Collapse Expand Links
Files


AnypiaOut.h

AnypiaOut.h
Classes Files Legend

Declarations for the AnypiaOut class to manage all output pages from Anypia.

Collapse Expand Classes
Name | Description
AnypiaOut | Manages all output pages from the Anypia program.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


ChildCareCalc1Page.cpp

ChildCareCalc1Page.cpp
Files

Functions for the ChildCareCalc1Page class to manage wage indexed earnings with child-care dropout years.

Collapse Expand Group

Files

Collapse Expand Links
Files


ChildCareCalc1Page.h

ChildCareCalc1Page.h
Classes Files Legend

Declarations for the ChildCareCalc1Page class to manage wage indexed earnings with child-care dropout years.

Collapse Expand Classes
Name | Description
ChildCareCalc1Page | Manages wage indexed earnings from the calculation of a Social Security benefit with child-care dropout years.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


ChildCareCalc2Page.cpp

ChildCareCalc2Page.cpp
Files

Functions for the ChildCareCalc2Page class to manage wage indexed results with child-care dropout years.

Collapse Expand Group

Files

Collapse Expand Links
Files


ChildCareCalc2Page.h

ChildCareCalc2Page.h
Classes Files Legend

Declarations for the ChildCareCalc2Page class to manage wage indexed results with child-care dropout years.

Collapse Expand Classes
Name | Description
ChildCareCalc2Page | Manages wage indexed results with child-care dropout years from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


DibGuarPage.cpp

DibGuarPage.cpp
Files

Functions for the DibGuarPage class to manage disability guarantee calculation output.

Collapse Expand Group

Files

Collapse Expand Links
Files


DibGuarPage.h

DibGuarPage.h
Classes Files Legend

Declarations for the DibGuarPage class to manage disability guarantee calculation output.

Collapse Expand Classes
Name | Description
DibGuarPage | Manages the disability guarantee results from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


EarningsPage.cpp

EarningsPage.cpp
Files

Functions for the EarningsPage class to manage earnings output.

Collapse Expand Group

Files

Collapse Expand Links
Files


EarningsPage.h

EarningsPage.h
Classes Files Legend

Declarations for the EarningsPage class to manage earnings output.

Collapse Expand Classes
Name | Description
EarningsPage | Manages printing of earnings used in the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


FamilyPage.cpp

FamilyPage.cpp
Files

Functions for the FamilyPage class to manage family members' benefits output.

Collapse Expand Group

Files

Collapse Expand Links
Files


FamilyPage.h

FamilyPage.h
Classes Files Legend

Declarations for the FamilyPage class to manage family members' benefits output.

Collapse Expand Classes
Name | Description
FamilyPage | Manages the results for the auxiliary beneficiaries from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


FrozMinPage.cpp

FrozMinPage.cpp
Files

Functions for the FrozMinPage class to manage frozen minimum calculation output.

Collapse Expand Group

Files

Collapse Expand Links
Files


FrozMinPage.h

FrozMinPage.h
Classes Files Legend

Declarations for the FrozMinPage class to manage frozen minimum calculation output.

Collapse Expand Classes
Name | Description
FrozMinPage | Manages the frozen minimum results from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


InsuredPage.cpp

InsuredPage.cpp
Files

Functions for the InsuredPage class to manage insured status output.

Collapse Expand Group

Files

Collapse Expand Links
Files


InsuredPage.h

InsuredPage.h
Classes Files Legend

Declarations for the InsuredPage class to manage insured status output.

Collapse Expand Classes
Name | Description
InsuredPage | Manages insured status output determined in the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


OldStart1Page.cpp

OldStart1Page.cpp
Files

Functions for the OldStart1Page class to manage old start calculation earnings output.

Collapse Expand Group

Files

Collapse Expand Links
Files


OldStart1Page.h

OldStart1Page.h
Classes Files Legend

Declarations for the OldStart1Page class to manage old start calculation earnings output.

Collapse Expand Classes
Name | Description
OldStart1Page | Manages old start earnings output from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


OldStart2Page.cpp

OldStart2Page.cpp
Files

Functions for the OldStart2Page class to manage old start calculation results.

Collapse Expand Group

Files

Collapse Expand Links
Files


OldStart2Page.h

OldStart2Page.h
Classes Files Legend

Declarations for the OldStart2Page class to manage old start calculation results.

Collapse Expand Classes
Name | Description
OldStart2Page | Manages old start results from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


OnePage.cpp

OnePage.cpp
Files

Functions for the OnePage class to manage one-page summary of results.

Collapse Expand Group

Files

Collapse Expand Links
Files


OnePage.h

OnePage.h
Classes Files Legend

Declarations for the OnePage class to manage one-page summary of results.

Collapse Expand Classes
Name | Description
OnePage | Manages one-page summary of results from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PebsCreditInfo.cpp

PebsCreditInfo.cpp
Files

Functions for the PebsCreditInfo class to manage the Social Security Statement credit info page.

Collapse Expand Group

Files

Collapse Expand Links
Files


PebsCreditInfo.h

PebsCreditInfo.h
Classes Files Legend

Declarations for the PebsCreditInfo class to manage the Social Security Statement credit info page.

Collapse Expand Classes
Name | Description
PebsCreditInfo | Manages the Social Security Statement credit info page.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PebsEarnings.cpp

PebsEarnings.cpp
Files

Functions for the PebsEarnings class to manage Social Security Statement earnings page.

Collapse Expand Group

Files

Collapse Expand Links
Files


PebsEarnings.h

PebsEarnings.h
Classes Files Legend

Declarations for the PebsEarnings class to manage Social Security Statement earnings page.

Collapse Expand Classes
Name | Description
PebsEarnings | Manages the Social Security Statement earnings page.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PebsEarningsInfo.cpp

PebsEarningsInfo.cpp
Files

Functions for the PebsEarningsInfo class to manage the Social Security Statement earnings info page.

Collapse Expand Group

Files

Collapse Expand Links
Files


PebsEarningsInfo.h

PebsEarningsInfo.h
Classes Files Legend

Declarations for the PebsEarningsInfo class to manage the Social Security Statement earnings info page.

Collapse Expand Classes
Name | Description
PebsEarningsInfo | Manages the Social Security Statement earnings info page.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PebsLetter.cpp

PebsLetter.cpp
Files

Functions for the PebsLetter class to manage the Social Security Statement letter page.

Collapse Expand Group

Files

Collapse Expand Links
Files


PebsLetter.h

PebsLetter.h
Classes Files Legend

Declarations for the PebsLetter class to manage the Social Security Statement letter page.

Collapse Expand Classes
Name | Description
PebsLetter | Manages the Social Security Statement letter page.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PebsOasdiEst.cpp

PebsOasdiEst.cpp
Files

Functions for the PebsOasdiEst class to manage the Social Security Statement oasdi estimates info page.

Collapse Expand Group

Files

Collapse Expand Links
Files


PebsOasdiEst.h

PebsOasdiEst.h
Classes Files Legend

Declarations for the PebsOasdiEst class to manage the Social Security Statement oasdi estimates info page.

Collapse Expand Classes
Name | Description
PebsOasdiEst | Manages the Social Security Statement oasdi estimates page.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PebsOasdiInfo.cpp

PebsOasdiInfo.cpp
Files

Functions for the PebsOasdiInfo class to manage the Social Security Statement oasdi benefit info page.

Collapse Expand Group

Files

Collapse Expand Links
Files


PebsOasdiInfo.h

PebsOasdiInfo.h
Classes Files Legend

Declarations for the PebsOasdiInfo class to manage the Social Security Statement oasdi benefit info page.

Collapse Expand Classes
Name | Description
PebsOasdiInfo | Manages the Social Security Statement oasdi benefit info page.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PebsOut.cpp

PebsOut.cpp
Files

Functions for the PebsOut class to print out the Social Security Statement.

Collapse Expand Group

Files

Collapse Expand Links
Files


PebsOut.h

PebsOut.h
Classes Files Legend

Declarations for the PebsOut class to print out the Social Security Statement.

Collapse Expand Classes
Name | Description
PebsOut | Manages the printing of the results of a Social Security Statement calculation.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PebsPageOut.cpp

PebsPageOut.cpp
Files

Functions for the PebsPageOut class - parent of classes to write out results of Social Security Statement benefit calculation.

Collapse Expand Group

Files

Collapse Expand Links
Files


PebsPageOut.h

PebsPageOut.h
Classes Files Legend

Declarations for the PebsPageOut class - parent of classes to write out results of Social Security Statement benefit calculation.

Collapse Expand Classes
Name | Description
PebsPageOut | Parent of classes that manage a page of Social Security Statement output.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PebsWorkerEarnings.cpp

PebsWorkerEarnings.cpp
Files

Functions for the PebsWorkerEarnings class to manage the Social Security Statement worker info and earnings page.

Collapse Expand Group

Files

Collapse Expand Links
Files


PebsWorkerEarnings.h

PebsWorkerEarnings.h
Classes Files Legend

Declarations for the PebsWorkerEarnings class to manage the Social Security Statement worker info and earnings page.

Collapse Expand Classes
Name | Description
PebsWorkerEarnings | Manages the Social Security Statement worker info and earnings info page.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PebsWorkerInfo.cpp

PebsWorkerInfo.cpp
Files

Functions for the PebsWorkerInfo class to manage the Social Security Statement worker info page.

Collapse Expand Group

Files

Collapse Expand Links
Files


PebsWorkerInfo.h

PebsWorkerInfo.h
Classes Files Legend

Declarations for the PebsWorkerInfo class to manage the Social Security Statement worker info page.

Collapse Expand Classes
Name | Description
PebsWorkerInfo | Manages the Social Security Statement worker info page.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PiaOut.cpp

PiaOut.cpp
Files

Functions for the PiaOut class to manage output for a non-Statement calculation.

Collapse Expand Group

Files

Collapse Expand Links
Files


PiaOut.h

PiaOut.h
Classes Files Legend

Declarations for the PiaOut class to manage output for a non-Statement calculation.

Collapse Expand Classes
Name | Description
PiaOut | >Manages the printing of the results of a Social Security non-Statement calculation.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PiaPageOut.cpp

PiaPageOut.cpp
Files

Functions for the PiaPageOut class - parent of classes to write out results of a non-Statement benefit calculation.

Collapse Expand Group

Files

Collapse Expand Links
Files


PiaPageOut.h

PiaPageOut.h
Classes Files Legend

Declarations for the PiaPageOut class - parent of classes to write out results of a non-Statement benefit calculation.

Collapse Expand Classes
Name | Description
PiaPageOut | Parent of classes that manage a page of output from the calculation of a non-Statement Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PiaTable1Page.cpp

PiaTable1Page.cpp
Files

Functions for the PiaTable1Page class to manage a pia table calculation earnings page.

Collapse Expand Group

Files

Collapse Expand Links
Files


PiaTable1Page.h

PiaTable1Page.h
Classes Files Legend

Declarations for the PiaTable1Page class to manage a pia table calculation earnings page.

Collapse Expand Classes
Name | Description
PiaTable1Page | Manages the pia table calculation earnings page from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


PiaTable2Page.cpp

PiaTable2Page.cpp
Files

Functions for the PiaTable2Page class to manage a pia table calculation results page.

Collapse Expand Group

Files

Collapse Expand Links
Files


PiaTable2Page.h

PiaTable2Page.h
Classes Files Legend

Declarations for the PiaTable2Page class to manage a pia table calculation results page.

Collapse Expand Classes
Name | Description
PiaTable2Page | Manages the pia table calculation results page from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


ReindWid1Page.cpp

ReindWid1Page.cpp
Files

Functions for the ReindWid1Page class to manage a re-indexed widow earnings page.

Collapse Expand Group

Files

Collapse Expand Links
Files


ReindWid1Page.h

ReindWid1Page.h
Classes Files Legend

Declarations for the ReindWid1Page class to manage a re-indexed widow earnings page.

Collapse Expand Classes
Name | Description
ReindWid1Page | Manages a re-indexed widow earnings page from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


ReindWid2Page.cpp

ReindWid2Page.cpp
Files

Functions for the ReindWid2Page class to manage a re-indexed widow calculation results page.

Collapse Expand Group

Files

Collapse Expand Links
Files


ReindWid2Page.h

ReindWid2Page.h
Classes Files Legend

Declarations for the ReindWid2Page class to manage a re-indexed widow calculation results page.

Collapse Expand Classes
Name | Description
ReindWid2Page | Manages a re-indexed widow calculation results page from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


SpecMin1Page.cpp

SpecMin1Page.cpp
Files

Functions for the SpecMin1Page class to manage a special minimum calculation earnings page.

Collapse Expand Group

Files

Collapse Expand Links
Files


SpecMin1Page.h

SpecMin1Page.h
Classes Files Legend

Declarations for the SpecMin1Page class to manage a special minimum calculation earnings page.

Collapse Expand Classes
Name | Description
SpecMin1Page | Manages a special minimum earnings page from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


SpecMin2Page.cpp

SpecMin2Page.cpp
Files

Functions for the SpecMin2Page class to manage a special minimum calculation results page.

Collapse Expand Group

Files

Collapse Expand Links
Files


SpecMin2Page.h

SpecMin2Page.h
Classes Files Legend

Declarations for the SpecMin2Page class to manage a special minimum calculation results page.

Collapse Expand Classes
Name | Description
SpecMin2Page | Manages a special minimum calculation details page from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


Summary1Page.cpp

Summary1Page.cpp
Files

Functions for the Summary1Page class to manage the top part of a summary of results page.

Collapse Expand Group

Files

Collapse Expand Links
Files


Summary1Page.h

Summary1Page.h
Classes Files Legend

Declarations for the Summary1Page class to manage the top part of a summary of results page.

Collapse Expand Classes
Name | Description
Summary1Page | Manages the top part of the summary of results page from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


Summary2Page.cpp

Summary2Page.cpp
Files

Functions for the Summary2Page class to manage the middle part of a summary of results page.

Collapse Expand Group

Files

Collapse Expand Links
Files


Summary2Page.h

Summary2Page.h
Classes Files Legend

Declarations for the Summary2Page class to manage the middle part of a summary of results page.

Collapse Expand Classes
Name | Description
Summary2Page | Manages the middle part of the summary of results page from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


Summary3Page.cpp

Summary3Page.cpp
Files

Functions for the Summary3Page class to manage the bottom part of a summary of results page.

Collapse Expand Group

Files

Collapse Expand Links
Files


Summary3Page.h

Summary3Page.h
Classes Files Legend

Declarations for the Summary3Page class to manage the bottom part of a summary of results page.

Collapse Expand Classes
Name | Description
Summary3Page | Manages the bottom part of the summary of results page from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


SummaryPage.cpp

SummaryPage.cpp
Files

Functions for the SummaryPage class to manage the summary page of results.

Collapse Expand Group

Files

Collapse Expand Links
Files


SummaryPage.h

SummaryPage.h
Classes Files Legend

Declarations for the SummaryPage class to manage the summary page of results.

Collapse Expand Classes
Name | Description
SummaryPage | Manages the summary page of results from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


TaxesPage.cpp

TaxesPage.cpp
Files

Functions for the TaxesPage class to manage the taxes output page.

Collapse Expand Group

Files

Collapse Expand Links
Files


TaxesPage.h

TaxesPage.h
Classes Files Legend

Declarations for the TaxesPage class to manage the taxes output page.

Collapse Expand Classes
Name | Description
TaxesPage | Manages the taxes output page.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


TransGuar1Page.cpp

TransGuar1Page.cpp
Files

Functions for the TransGuar1Page class to manage the transitional guarantee calculation earnings page.

Collapse Expand Group

Files

Collapse Expand Links
Files


TransGuar1Page.h

TransGuar1Page.h
Classes Files Legend

Declarations for the TransGuar1Page class to manage the transitional guarantee calculation earnings page.

Collapse Expand Classes
Name | Description
TransGuar1Page | Manages the transitional guarantee earnings page from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


TransGuar2Page.cpp

TransGuar2Page.cpp
Files

Functions for the TransGuar2Page class to manage the transitional guarantee calculation results page.

Collapse Expand Group

Files

Collapse Expand Links
Files


TransGuar2Page.h

TransGuar2Page.h
Classes Files Legend

Declarations for the TransGuar2Page class to manage the transitional guarantee calculation results page.

Collapse Expand Classes
Name | Description
TransGuar2Page | Manages the transitional guarantee results page from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


WageInd1Page.cpp

WageInd1Page.cpp
Files

Functions for the WageInd1Page class to manage a wage indexed earnings page.

Collapse Expand Group

Files

Collapse Expand Links
Files


WageInd1Page.h

WageInd1Page.h
Classes Files Legend

Declarations for the WageInd1Page class to manage a wage indexed earnings page.

Collapse Expand Classes
Name | Description
WageInd1Page | Manages a wage indexed earnings page from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


WageInd2Page.cpp

WageInd2Page.cpp
Files

Functions for the WageInd2Page class to manage a wage indexed reuslts page.

Collapse Expand Group

Files

Collapse Expand Links
Files


WageInd2Page.h

WageInd2Page.h
Classes Files Legend

Declarations for the WageInd2Page class to manage a wage indexed reuslts page.

Collapse Expand Classes
Name | Description
WageInd2Page | Manages a wage indexed results page from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


WageIndNonFreeze1Page.cpp

WageIndNonFreeze1Page.cpp
Files

Functions for the WageIndNonFreeze1Page class to manage a wage indexed earnings page.

Collapse Expand Group

Files

Collapse Expand Links
Files


WageIndNonFreeze1Page.h

WageIndNonFreeze1Page.h
Classes Files Legend

Declarations for the WageIndNonFreeze1Page class to manage a wage indexed earnings page.

Collapse Expand Classes
Name | Description
WageIndNonFreeze1Page | Manages a wage indexed non-freeze page from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


WageIndNonFreeze2Page.cpp

WageIndNonFreeze2Page.cpp
Files

Functions for the WageIndNonFreeze2Page class to manage a wage indexed results page.

Collapse Expand Group

Files

Collapse Expand Links
Files


WageIndNonFreeze2Page.h

WageIndNonFreeze2Page.h
Classes Files Legend

Declarations for the WageIndNonFreeze2Page class to manage a wage indexed results page.

Collapse Expand Classes
Name | Description
WageIndNonFreeze2Page | Manages a wage indexed non-freeze results page from the calculation of a Social Security benefit.
Collapse Expand Group

Files

Collapse Expand Links
Classes, Files, Legend


Classes

Classes
Classes Legend
Classes
Name | Description
Age | Manages a year and month age stored as integers.
AnnualArrays | Functions using annual arrays.
BitAnnual | Manages an array of annual bits.
Date | Static variables and functions for classes that hold dates.
DateFormatter | Manages static functions to format and parse dates.
DateMoyr | Manages a month and year stored as unsigned integers.
Document | Manages a generic document.
DoubleAnnual | Manages an array of annual doubles.
DoubleAnnualRead | Reads a DoubleAnnual.
DoubleAnnualWrite | Writes a DoubleAnnual.
DoubleMonth | Manages an array of monthly doubles.
DoubleQuarter | Manages an array of quarterly doubles.
FloatAnnual | Manages an array of annual floats.
FloatMonth | Manages an array of monthly floats.
FloatQuarter | Manages an array of quarterly floats.
Genfile | Manages a generic file.
IntAnnual | Manages an array of annual integers.
Out132 | An Outfile tailored for 132-column output.
Out80 | An Outfile tailored for 80-column output.
OutDC80 | Handles output to a Windows window.
OutFile132 | Manages the print output functions, when printing to a file formatted for 132 columns.
OutFile80 | Manages the print output functions, when printing to a file formatted for 80 columns.
OutFileHTML | Manages the print output functions, when printing to an HTML file.
Outfile | Abstract parent of classes to manage an output file in runstreams with multiple programs.
PageCounters | Manages a vector of page counters.
PageOut | Abstract parent of classes to manage a page of printed output.
Path | Provides operations on string instances that contain file or directory path information.
PiaException | Manages an exception in the piadata library.
QtrYear | Manages a year and quarter stored as unsigned integers.
Sex | Indicator for sex type.
Ssn | Manages a Social Security number string, and the 3 parts of an ssn separately as strings.
TextWriterTraceListener | An output-stream-based class that listens for Trace output.
Trace | Controls the logfiles used to trace execution of code.
TraceListener | The parent of classes that listen for Trace output.


Classes

Legend
Legend
Class


Legend

Legend
Classes
Legend
Class
Structure


Classes Structures

Classes Structures
Classes Legend
Structures
Name | Description
PunctFacet | Numeric punctuation facet with 3 digits per thousands separator.


Structures

Legend
Legend
Structure


Classes

Classes
Classes Legend
Classes
Name | Description
Assumptions | Parent of classes that manage the average wage and benefit increase assumptions.
AssumptionsFile | Reads the average wage and benefit increase parameters from disk storage.
AssumptionsNonFile | Contains the average wage and benefit increase assumptions (it does not read from disk).
AssumptionType | The assumption types (about future average wage and benefit increases) allowed in the piadata library.
AverageWage | Manages an array of average wage indexing amounts, or any other earnings series.
AwbiData | Manages the historical Social Security parameters.
AwbiDataFile | Manages the historical Social Security parameters stored in a file.
AwbiDataNonFile | Manages the historical Social Security parameters stored in arrays in the code.
Awinc | Manages a vector of projected average wage increases.
AwincDoc | Abstract parent of classes that manage the file of projected average wage increases.
AwincFile | Manages the file of projected average wage increases stored on disk.
AwincNonFile | Manages the file of projected average wage increases stored in static arrays.
BaseChangeType | The wage base change types allowed in the piadata library.
BaseYear | Parent of classes that manage the computation year for a pia program.
BaseYearFile | Manages the computation year for a pia program where it is gotten from disk.
BaseYearNonFile | Manages the computation year for a pia program where it is stored with the code.
BendPia | Manages the array of bend points used in the PIA formula.
BendMfb | Manages the array of bend points used in the MFB formula.
BenefitAmount | Represents a benefit amount for one year.
BenefitAmountArray | Manages an array of BenefitAmount's.
Bic | Represents one 2-character bic (Beneficiary Identification code) code.
Biproj | Abstract parent of classes that manage the file of projected benefit increases.
BiprojFile | Manages the file of projected benefit increases stored on disk.
BiprojNonFile | Manages the file of projected benefit increases stored in arrays.
BpMfbOut | Manages the array of mfb formula bend points.
BpPiaOut | Manages the array of pia formula bend points.
Catchup | Manages the catch-up benefit increases required to calculate a Social Security benefit.
CatchupDoc | Abstract parent of classes that manage a file of catch-up benefit increases.
CatchupFile | Manages a file of catch-up benefit increases stored on disk.
CatchupIncreases | Manages the catch-up benefit increases for one year of eligibility.
CatchupNonFile | Manages a file of catch-up benefit increases stored in arrays.
ChildCareCalc | Manages the functions required for calculation of a wage indexed Social Security benefit using childcare dropout years.
ChildCareCalcLC | Manages the functions required for calculation of a wage indexed Social Security benefit using childcare dropout years, with law changes.
CompPeriod | Manages the number of elapsed years, dropout years, and computation years.
Config | Parent of classes that manage the configuration information used by the PIA calculation program.
ConfigFile | Manages the configuration information used by the PIA calculation program, stored in a file.
ConfigNonFile | Manages the configuration information used by the PIA calculation program, stored with the code.
DibGuar | Manages the functions required for calculation of a disability guarantee Social Security benefit.
DibGuarLC | Manages the functions required for calculation of a disability guarantee Social Security benefit with law changes.
DisabPeriod | Manages a period of disability.
DisInsCode | Represents one disability insured status code.
DisInsCodeArray | Manages an array of annual DisInsCode's.
EarnProject | Manages an array of earnings, with forward and backward projections and specified levels of earnings.
FieldOfficeInfo | Parent of classes that manage the name and address of the field office.
FieldOfficeInfoFile | Reads and writes field office information from and to a file.
FieldOfficeInfoNonFile | Manages field office information not stored in a file (but its data may be saved in an .ini file).
FreezeYears | Manages the years in a freeze period. The years may be wholly or partially within a freeze period.
FrozMin | Manages the functions required for calculation of a frozen minimum Social Security benefit.
InsCode | Represents one insured status code.
InsCodeArray | Manages an array of annual insured status codes.
LawChange | The basic class that manages all of the extra data and functions required for one change in law concerning benefit calculations.
LawChangeAGE65COMP | Parameters for a proposal to increase the number of elapsed years in a pia calculation.
LawChangeALLEARN | Parameters for a proposal to use all years of earnings in an AIME calculation.
LawChangeArray | Manages an array of LawChange's.
LawChangeBPFRACWAGE | Parameters for a proposal to increase the bend points in the benefit formula by a fraction of average wage growth.
LawChangeBPMINCONST | Parameters for a proposal to increase the bend points in the benefit formula by the growth in wages minus a specified rate.
LawChangeBPSPECRATE | Parameters for a proposal to increase the bend points in the benefit formula by a specified growth rate.
LawChangeCHILDCARECREDIT | Parameters for a proposal to provide child care credits.
LawChangeCHILDCAREDROPOUT | Parameters for a proposal to provide child care dropout years.
LawChangeCOLACHANGE | Parameters for a proposal to change the cost-of-living benefit increases.
LawChangeDECLINEPERC | Parameters for a proposal to decrease the benefit formula percentages by a constant rate.
LawChangeDROPOUTCHG | Parameters for a proposal to reduce the number of dropout years in a pia calculation.
LawChangeMARRLENGTH | Parameters for a proposal to change the length of marriage requirement for divorced spouse benefits.
LawChangeNEWFORMULA | Parameters for a proposal to change the pia formula bend points and/or percentages.
LawChangeNEWSPECMIN | Parameters for a proposal to change the special minimum pia calculation.
LawChangeNRACHANGE | Parameters for a proposal to change the full retirement age.
LawChangeOut | Manages the output file of law change descriptions.
LawChangePSAACCT | Parameters for a proposal to introduce individual accounts.
LawChangeRead | Reads law changes stored in a file.
LawChangeTAXBENCHG | Parameters for a proposal to change the taxation of benefits.
LawChangeTAXRATECHG | Parameters for a proposal to change the OASDI tax rates.
LawChangeWAGEBASECHG | Parameters for a proposal to change the OASDI and/or old-law wage bases.
LawChangeWIDFACTOR | Parameters for a proposal to change the factor for an aged widow(er) benefit.
LawChangeWIFEFACTOR | Parameters for a proposal to change the factor for an aged spouse benefit.
LawChangeWrite | Writes a set of law changes to a file.
MilServDates | Manages one period of military service dates.
MilServDatesVec | Manages all the military service dates records for one ssn.
OldPia | Parent of all methods using pia tables in the calculation of a Social Security benefit.
OldStart | Manages the functions required for calculation of an old start Social Security benefit.
OldStartLC | Manages the functions required for calculation of an old start Social Security benefit with law changes.
Pebs | Manages most of the data required to prepare and print out the results of a Statement calculation.
PercMfb | Manages the array of percentages used in the MFB formula.
PercPia | Manages the array of percentages used in the PIA formula.
PercPiaOut | Manages the array of pia formula percentages, projected for all years.
PiaCal | Parent of all classes that manage the functions required for calculation of a Social Security benefit.
PiaCalAny | Manages the additional functions required for calculation of a Social Security benefit in the Anypia program.
PiaCalLC | Manages all of the law-change functions required for calculation of a Social Security benefit.
PiaCalPL | Manages all of the present law functions required for calculation of a Social Security benefit.
PiaData | Manages all of the worker-specific amounts calculated in preparation for and during the calculation of a Social Security benefit.
PiaDataArray | Manages an array of PiaData's, representing one family.
PiaMethod | Parent of the various methods required for calculation of a Social Security benefit.
PiaParams | Abstract parent of classes to manage the Social Security parameters required to calculate a Social Security benefit.
PiaParamsAny | Manages the additional Social Security parameters required to calculate Social Security benefits in the Anypia program.
PiaParamsLC | Manages the changed law Social Security parameters required to calculate Social Security benefits.
PiaParamsLCTR | Manages the changed law Social Security parameters, already projected based on a Trustees Report assumption.
PiaParamsPL | Manages the present law Social Security parameters required to calculate Social Security benefits.
PiaParamsTR | Manages the present law Social Security parameters required to calculate Social Security benefits, with projected values set to Trustees Report assumptions.
PiaRead | Reads the basic data required to calculate a Social Security benefit.
PiaReadAny | Reads the data required to calculate a Social Security benefit for the Anypia program.
PiaTable | Manages the functions required for calculation of a Pia Table Social Security benefit.
PiaTableLC | Manages the functions required for calculation of a Pia Table Social Security benefit, including changes from present law.
PiaWrite | Writes out the basic data required to calculate a Social Security benefit.
PiaWriteAny | Writes out the data required to calculate a Social Security benefit for the Anypia program.
Pib50Mfb | Manages the 1950 pib-mfb conversion figures.
Pib50Pib | Manages the 1950 pib-pia conversion figures.
Pib52Ame | Manages the 1952 pib-ame conversion figures.
Pib52Mfb | Manages the 1952 pib-mfb conversion figures.
Pib54Ame | Manages the 1954 pib-ame conversion figures.
Pib54Mfb | Manages the 1954 pib-mfb conversion figures.
Pib54Pia | Manages the 1954 pib-pia conversion figures.
Pib58Ame | Manages the 1958 pib-ame conversion figures.
Pib58Pib | Manages the 1958 pib-pia conversion figures.
Pifc | Represents a pia factor code (type of Social Security pia).
PortionAime | Manages the array of portions of AIME in the PIA formula.
PresValFacs | Manages an array of present value factors.
Psa | Manages the (theoretical) PSA accounts.
Qc | Handles calculations with quarters of coverage for one year.
Qcamt | Manages an array of quarter of coverage amounts.
QcArray | Manages an array of annual quarters of coverage.
QcPacked | Holds 8 annual quarters of coverage amounts in one word (4 bytes). Each value is in 4 bits, and can take values from 0 to 4.
RailRoadData | Manages the railroad data for one worker.
ReindWid | Manages the functions required for calculation of a reindexed widow(er) Social Security benefit.
ReindWidLC | Manages the functions required for calculation of a reindexed widow(er) Social Security benefit with law changes.
RetireTest | Contains all of the retirement test exempt amounts and functions to use them.
Rtea62 | Manages the annual retirement test exempt amount projections under full retirement age.
Rtea62m | Manages the monthly retirement test exempt amount projections under full retirement age.
Rtea65 | Manages the annual retirement test exempt amount projections over full retirement age.
Rtea65m | Manages the monthly retirement test exempt amount projections over full retirement age.
RteaHigh | Manages the upper annual retirement test exempt amounts when there were two tiers.
RtGeneral | Parent of classes to manage the retirement test exempt amount projections.
ScaledEarnFactors | Manages scaled earner amounts.
Secondary | Contains the information about a secondary benefit.
SecondaryArray | Manages an array of Secondary's.
Sga | Contains all of the SGA amounts and functions to use them.
SgaBlindA | Manages the annual SGA amounts (historical and projected) for blind beneficiaries.
SgaBlindM | Manages the monthly SGA amounts (historical and projected) for blind beneficiaries (as of December).
SgaGeneral | Parent of classes to manage the SGA (Substantial Gainful Activity) amounts (historical and projected).
SgaMaxA | Manages the annual SGA maximum amounts(historical and projected) for non-blind beneficiaries.
SgaMaxM | Manages the monthly SGA maximum amounts (historical and projected) for non-blind beneficiaries (as of December).
SgaMinA | Manages the annual SGA minimum amounts (historical and projected) for non-blind beneficiaries.
SgaMinM | Manages the monthly SGA minimum amounts (historical and projected) for non-blind beneficiaries (as of December).
SpecMin | Manages the functions required for calculation of a special minimum Social Security benefit.
SpecMinLC | Manages the functions required for calculation of a special minimum Social Security benefit, including changes from present law.
TaxBenefits | Contains the functions required to calculate the tax on a Social Security benefit.
TaxBenefitsLC | Contains the functions required to calculate the tax on a Social Security benefit with law changes.
TaxData | Manages the Social Security payroll and self-employed taxes paid by a worker.
TaxRates | Abstract parent of classes that manage the Social Security payroll and self-employed tax rates.
TaxRatesLC | Manages the Social Security payroll and self-employed tax rates, with changes from present law.
TaxRatesPL | Manages the present law Social Security payroll and self-employed tax rates.
TransGuar | Manages the functions required for calculation of a transitional guarantee Social Security benefit.
TransGuarLC | Manages the functions required for calculation of a transitional guarantee Social Security benefit, with changes from present law.
UserAssumptions | Manages all the assumptions about future average wage increases, wage bases, benefit increases, and catch-up benefit increases that a user might specify.
WageBase | Manages the OASDI wage base projections.
WageBaseGeneral | Ancestor of the classes that manage the wage base projections.
WageBaseHI | Manages the HI wage base projections.
WageBaseLC | Manages the OASDI wage base projection with law changes.
WageBaseOldLaw | Manages the old-law OASDI wage base projections.
WageBaseOldLawLC | Manages the old-law OASDI wage base projection with law changes.
WageInd | Manages the functions required for calculation of a wage indexed Social Security benefit.
WageIndGeneral | Parent of all classes that manage the functions required for calculation of a wage indexed Social Security benefit.
WageIndLC | Manages the functions required for calculation of a wage indexed Social Security benefit, with changes from present law.
WageIndNonFreeze | Manages the functions required for calculation of a wage indexed non-freeze Social Security benefit.
WorkerData | Manages the basic data required to calculate a Social Security benefit.
WorkerDataArray | Manages an array of WorkerData's, representing one family.
WorkerDataGeneral | The abstract parent of all classes that manage the basic data required to calculate a Social Security benefit.


Legend

Legend
Classes
Legend
Class


Classes

Classes
Classes Legend
Classes
Name | Description
AnypiaOut | Manages all output pages from the Anypia program.
ChildCareCalc1Page | Manages wage indexed earnings from the calculation of a Social Security benefit with child-care dropout years.
ChildCareCalc2Page | Manages wage indexed results with child-care dropout years from the calculation of a Social Security benefit.
DibGuarPage | Manages the disability guarantee results from the calculation of a Social Security benefit.
EarningsPage | Manages printing of earnings used in the calculation of a Social Security benefit.
FamilyPage | Manages the results for the auxiliary beneficiaries from the calculation of a Social Security benefit.
FrozMinPage | Manages the frozen minimum results from the calculation of a Social Security benefit.
InsuredPage | Manages insured status output determined in the calculation of a Social Security benefit.
OldStart1Page | Manages old start earnings output from the calculation of a Social Security benefit.
OldStart2Page | Manages old start results from the calculation of a Social Security benefit.
OnePage | Manages one-page summary of results from the calculation of a Social Security benefit.
PebsCreditInfo | Manages the Social Security Statement credit info page.
PebsEarnings | Manages the Social Security Statement earnings page.
PebsEarningsInfo | Manages the Social Security Statement earnings info page.
PebsLetter | Manages the Social Security Statement letter page.
PebsOasdiEst | Manages the Social Security Statement oasdi estimates page.
PebsOasdiInfo | Manages the Social Security Statement oasdi benefit info page.
PebsOut | Manages the printing of the results of a Social Security Statement calculation.
PebsPageOut | Parent of classes that manage a page of Social Security Statement output.
PebsWorkerEarnings | Manages the Social Security Statement worker info and earnings info page.
PebsWorkerInfo | Manages the Social Security Statement worker info page.
PiaOut | >Manages the printing of the results of a Social Security non-Statement calculation.
PiaPageOut | Parent of classes that manage a page of output from the calculation of a non-Statement Social Security benefit.
PiaTable1Page | Manages the pia table calculation earnings page from the calculation of a Social Security benefit.
PiaTable2Page | Manages the pia table calculation results page from the calculation of a Social Security benefit.
ReindWid1Page | Manages a re-indexed widow earnings page from the calculation of a Social Security benefit.
ReindWid2Page | Manages a re-indexed widow calculation results page from the calculation of a Social Security benefit.
SpecMin1Page | Manages a special minimum earnings page from the calculation of a Social Security benefit.
SpecMin2Page | Manages a special minimum calculation details page from the calculation of a Social Security benefit.
Summary1Page | Manages the top part of the summary of results page from the calculation of a Social Security benefit.
Summary2Page | Manages the middle part of the summary of results page from the calculation of a Social Security benefit.
Summary3Page | Manages the bottom part of the summary of results page from the calculation of a Social Security benefit.
SummaryPage | Manages the summary page of results from the calculation of a Social Security benefit.
TaxesPage | Manages the taxes output page.
TransGuar1Page | Manages the transitional guarantee earnings page from the calculation of a Social Security benefit.
TransGuar2Page | Manages the transitional guarantee results page from the calculation of a Social Security benefit.
WageInd1Page | Manages a wage indexed earnings page from the calculation of a Social Security benefit.
WageInd2Page | Manages a wage indexed results page from the calculation of a Social Security benefit.
WageIndNonFreeze1Page | Manages a wage indexed non-freeze page from the calculation of a Social Security benefit.
WageIndNonFreeze2Page | Manages a wage indexed non-freeze results page from the calculation of a Social Security benefit.


Files

Files
Files
Files
Name | Description
AnnualArrays.cpp | Functions for the AnnualArrays class of static functions using annual arrays.
AnnualArrays.h | Declarations for the AnnualArrays class of static functions using annual arrays.
BitAnnual.cpp | Functions for the BitAnnual class to manage an array of annual bits.
BitAnnual.h | Declarations for the BitAnnual class to manage an array of annual bits.
BitAnnualBase.cpp | Functions for the BitAnnual class to manage an array of annual bits for Windows.
BitAnnualBase.h | Declarations for the BitAnnual class to manage an array of annual bits for Windows.
BitAnnualInlines.h | Inline functions for the BitAnnual class to manage an array of annual bits for Windows.
CommaBase.h | Definitions used by the pcomma function on a Windows machine.
DateFormatter.cpp | Functions for the DateFormatter class to format and parse dates.
DateFormatter.h | Declarations for the DateFormatter class to format and parse dates.
DoubleAnnualRW.cpp | Functions for the DoubleAnnualRead and DoubleAnnualWrite classes to read or write an array of annual doubles.
DoubleAnnualRW.h | Declarations for the DoubleAnnualRead and DoubleAnnualWrite classes to read or write an array of annual doubles.
FormatString.cpp | Functions to mimic AfxFormatString using Standard C++ Library strings.
FormatString.h | Declarations of functions to mimic AfxFormatString using Standard C++ Library strings.
NumPunct.cpp | Data for the PunctFacet structure to handle numeric punctuation.
NumPunct.h | Declarations for the PunctFacet structure to handle numeric punctuation.
OutDC.cpp | Functions needed for the OutDC80 class to write to a device context (DC).
OutDC.h | Declarations needed for the OutDC80 class to write to a device context (DC).
OutFile132.cpp | Functions for the OutFile132 class to manage print output to a file with 132-column lines.
OutFile132.h | Declarations for the OutFile132 class to manage print output to a file with 132-column lines.
OutFile80.cpp | Functions needed for the OutFile80 class to manage print output to a file with 80-column lines.
OutFile80.h | Declarations for the OutFile80 class to manage print output to a file with 80-column lines.
OutfileHTML.cpp | Functions for the OutFileHTML class to manage print output to an html file.
OutfileHTML.h | Declarations for the OutFileHTML class to manage print output to an html file.
PageOut.cpp | Functions for the PageOut class - parent of classes to manage a page of printed output.
PageOut.h | Declarations for the PageOut class - parent of classes to manage a page of printed output.
Path.cpp | Functions for the Path class that provides operations on string instances that contain file or directory path information.
Path.h | Declarations for the Path class that provides operations on string instances that contain file or directory path information.
PiaException.cpp | Functions for the PiaException class to manage an exception in the piadata library.
PiaException.h | Declarations for the PiaException class to manage an exception in the piadata library.
Resource.h | String IDS used in oactobjs library.
Sex.cpp | Functions for the Sex class holding a sex indicator.
Sex.h | Declarations needed for the Sex class holding a sex indicator.
StringParser.cpp | Function definitions to parse a string.
StringParser.h | Declarations of functions to parse a string.
TextWriterTraceListener.cpp | Functions for the TextWriterTraceListener class that listens for Trace output and writes to an ostream.
TextWriterTraceListener.h | Declarations for the TextWriterTraceListener class that listens for Trace output and writes to an ostream.
Trace.cpp | Functions for the Trace class to trace execution of code.
Trace.h | Declarations for the Trace class to trace execution of code.
TraceListener.cpp | Functions for the TraceListener class - parent of classes that listen for Trace output.
TraceListener.h | Declarations for the TraceListener class - parent of classes that listen for Trace output.
age.cpp | Functions for Age class to manage age in years and months.
age.h | Declarations for Age class to manage age in years and months.
comma.cpp | Functions that return strings with (or without) embedded commas in any type of number (floating or integral).
comma.h | Declarations of functions that return strings with (or without) embedded commas in any type of number (floating or integral).
date.cpp | Functions for the static Date class to manage date and time.
date.h | Declarations for the static Date class to manage date and time.
datemoyr.cpp | Functions needed for the DateMoyr class to handle date as month and year.
datemoyr.h | Declarations needed for DateMoyr class to manage date as month and year.
dbleann.cpp | Functions needed for DoubleAnnual class to manage an array of annual doubles.
dbleann.h | Declarations needed for DoubleAnnual class to manage an array of annual doubles.
dblemth.cpp | Functions for the DoubleMonth class to manage an array of monthly doubles.
dblemth.h | Declarations for the DoubleMonth class to manage an array of monthly doubles.
dbleqtr.cpp | Functions for the DoubleQuarter class to manage an array of quarterly doubles.
dbleqtr.h | Declarations for the DoubleQuarter class to manage an array of quarterly doubles.
document.cpp | Functions for the Document class to manage a generic document.
document.h | Declarations for the Document class to manage a generic document.
floatann.cpp | Functions for the FloatAnnual class to manage an array of annual floats.
floatann.h | Declarations for the FloatAnnual class to manage an array of annual floats.
floatmth.cpp | Functions for the FloatMonth class to manage an array of monthly floats.
floatmth.h | Declarations for the FloatMonth class to manage an array of monthly floats.
floatqtr.cpp | Functions for the FloatQuarter class to manage an array of quarterly floats.
floatqtr.h | Declarations for the FloatQuarter class to manage an array of quarterly floats.
genfile.cpp | Functions for the Genfile class to manage a general file.
genfile.h | Declarations for the Genfile class to manage a general file.
intann.cpp | Functions for the IntAnnual class to manage an array of annual integers.
intann.h | Declarations for the IntAnnual class to manage an array of annual integers.
outfile.cpp | Functions for the Outfile, Out132, and Out80 classes - parents of classes to manage output file with page counters.
outfile.h | Declarations for the Outfile, Out132, and Out80 classes - parents of classes to manage output file with page counters.
page.cpp | Functions for the PageCounters class to manage page counters.
page.h | Declarations for the PageCounters class to manage page counters.
qtryear.cpp | Functions for the QtrYear class to handle a year and quarter.
qtryear.h | Declarations for the QtrYear class to handle a year and quarter.
ssn.cpp | Functions for the Ssn class to manage a Social Security number.
ssn.h | Declarations for the Ssn class to manage a Social Security number.


Files

Files
Files
Files
Name | Description
Assumptions.cpp | Functions for the Assumptions class - parent of classes that manage the average wage and benefit increase assumptions.
Assumptions.h | Declarations for the Assumptions class - parent of classes that manage the average wage and benefit increase assumptions.
AssumptionsFile.cpp | Functions for the AssumptionsFile class that reads the average wage and benefit increase parameters from disk storage.
AssumptionsFile.h | Declarations for the AssumptionsFile class that reads the average wage and benefit increase parameters from disk storage.
AssumptionsNonFile.cpp | Functions for the AssumptionsNonFile class that contains the average wage and benefit increase parameters (it does not read from disk).
AssumptionsNonFile.h | Declarations for the AssumptionsNonFile class that contains the average wage and benefit increase parameters (it does not read from disk).
AssumptionType.cpp | Functions of the AssumptionType class containing the assumption types allowed in the piadata library.
AssumptionType.h | Declaration of the AssumptionType class containing the assumption types allowed in the piadata library.
avgwg.cpp | Functions needed for AverageWage class to manage array of average wages.
avgwg.h | Declarations needed for AverageWage class to manage array of average wages.
awbidat.cpp | Functions of the AwbiData class to manage historical Social Security parameters.
awbidat.h | Declaration of the AwbiData class to manage historical Social Security parameters.
AwbiDataFile.h | Declaration of the AwbiDataFile class to manage historical Social Security parameters stored in a file.
AwbiDataNonFile.h | Declaration of the AwbiDataNonFile class to manage historical Social Security parameters stored with the code.
awbidtfl.cpp | Functions of the AwbiDataFile class to manage historical Social Security parameters stored in a file.
awbidtnf.cpp | Functions of the AwbiDataNonFile class to manage historical Social Security parameters stored with the code.
awinc.cpp | Functions for the Awinc class to manage a vector of average wage increases.
awinc.h | Declarations for the Awinc class to manage a vector of average wage increases.
AwincDoc.cpp | Functions for the AwincDoc class to manage average wage increases.
AwincDoc.h | Declarations for the AwincDoc class to manage average wage increases.
AwincFile.h | Declarations needed for AwincFile class to manage average wage increases stored on disk.
awincfl.cpp | Functions needed for AwincFile class to manage average wage increases stored on disk.
awincnf.cpp | Functions for the AwincNonFile class to manage average wage increases stored in static arrays.
AwincNonFile.h | Declarations for the AwincNonFile class to manage average wage increases stored in static arrays.
BaseChangeType.cpp | Functions of the BaseChangeType class with the wage base change types allowed in the piadata library.
BaseChangeType.h | Declaration of the BaseChangeType class with the wage base change types allowed in the piadata library.
baseyear.cpp | Functions for the BaseYear class - parent of classes that manage the computation year for a pia program.
baseyear.h | Declarations for the BaseYear class - parent of classes that manage the computation year for a pia program.
BaseYearFile.h | Declarations for the BaseYearFile class to manage the computation year on disk.
BaseYearNonFile.h | Declarations for the BaseYearNonFile class to manage the computation year stored internally.
baseyrfl.cpp | Functions for the BaseYearFile class to manage the computation year on disk.
baseyrnf.cpp | Functions for the BaseYearNonFile class to manage the computation year stored internally.
BendPoints.h | Includes for the class that handles PIA and MFB formula bend points.
BenefitAmount.cpp | Functions for the BenefitAmount class to handle Social Security benefit amount.
BenefitAmount.h | Declarations for the BenefitAmount class to handle Social Security benefit amount.
BenefitAmountArray.cpp | Functions for the BenefitAmountArray class of an array of Social Security benefit amounts.
BenefitAmountArray.h | Declarations for the BenefitAmountArray class of an array of Social Security benefit amounts.
Bic.cpp | Functions for the Bic class to manage bic (Beneficiary Identification code) code.
bic.h | Declarations for the Bic class to manage bic (Beneficiary Identification code) code.
biproj.cpp | Functions for the Biproj class to manage projected benefit increases.
biproj.h | Declarations for the Biproj class to manage projected benefit increases.
BiprojFile.h | Declarations for the BiprojFile class to manage projected benefit increases stored on disk.
biprojfl.cpp | Declarations for the BiprojFile class to manage projected benefit increases stored on disk.
biprojnf.cpp | Functions for the BiprojNonFile class to manage projected benefit increases stored in arrays.
BiprojNonFile.h | Declarations for the BiprojNonFile class to manage projected benefit increases stored in arrays.
bpmfbout.cpp | Functions for the BpMfbOut class to manage array of mfb formula bend points.
bpmfbout.h | Declarations for the BpMfbOut class to manage array of mfb formula bend points.
bppiaout.cpp | Functions for the BpPiaOut class to manage array of pia formula bend points.
bppiaout.h | Declarations for the BpPiaOut class to manage array of pia formula bend points.
cachpdoc.cpp | Functions for the CatchupDoc class to manage a set of catch-up benefit increases.
cachup.cpp | Functions for the CatchupIncreases and Catchup classes to manage catch-up benefit increases.
cachup.h | Declarations for the CatchupIncreases and Catchup classes to manage catch-up benefit increases.
cachupf.h | Declarations for the CatchupDoc class to manage a set of catch-up benefit increases.
cachupfl.cpp | Functions for the CatchupFile class to manage file of catch-up benefit increases.
cachupnf.cpp | Functions for the CatchupNonFile class to manage a set of catch-up benefit increases stored in arrays.
CatchupFile.h | Declarations for the CatchupFile class to manage file of catch-up benefit increases.
CatchupNonFile.h | Declarations for the CatchupNonFile class to manage a set of catch-up benefit increases stored in arrays.
ChildCareCalc.cpp | Functions for the ChildCareCalc class to manage childcare dropout year pia calculations.
ChildCareCalc.h | Declarations for the ChildCareCalc class to manage childcare dropout year pia calculations.
ChildCareCalcLC.cpp | Functions for the ChildCareCalcLC class to manage childcare dropout year pia calculations, with law changes.
ChildCareCalcLC.h | Declarations for the ChildCareCalcLC class to manage childcare dropout year pia calculations, with law changes.
comppd.h | Declarations for the CompPeriod class to manage computation period variables.
CompPeriod.cpp | Functions for the CompPeriod class to manage computation period variables.
config.cpp | Functions for the Config class to manage configuration information used by the PIA calculation program.
config.h | Declarations for the Config class to manage configuration information used by the PIA calculation program.
configFile.cpp | Functions for the ConfigFile class to manage configuration information used by the PIA calculation program stored on disk.
ConfigFile.h | Declarations for the ConfigFile class to manage configuration information used by the PIA calculation program stored on disk.
configNonFile.cpp | Functions for the ConfigNonFile class to manage configuration information used by the PIA calculation program stored internally.
ConfigNonFile.h | Declarations for the ConfigNonFile class to manage configuration information used by the PIA calculation program stored internally.
DebugCase.cpp |
DebugCase.h |
DibGuar.cpp | Functions for the DibGuar class to manage disability guarantee pia calculations.
DibGuar.h | Declarations for the DibGuar class to manage disability guarantee pia calculations.
DibGuarLC.cpp | Functions for the DibGuarLC class to manage disability guarantee pia calculations with law changes.
DibGuarLC.h | Declarations for the DibGuarLC class to manage disability guarantee pia calculations with law changes.
dinscode.cpp | Functions for the DisInsCode class representing a disability insured status code.
dinscode.h | Declarations for the DisInsCode class representing a disability insured status code.
DisabPeriod.cpp | Functions for the DisabPeriod class to manage a period of disability.
DisabPeriod.h | Declarations for the DisabPeriod class to manage a period of disability.
DisInsCodeArray.cpp | Functions for the DisInsCodeArray class to manage an array of disability insured status codes.
DisInsCodeArray.h | Declarations for the DisInsCodeArray class to manage an array of disability insured status codes.
EarnProject.cpp | Functions for the EarnProject class to handle an array of earnings, with forward and backward projections and specified levels of earnings.
EarnProject.h | Declarations for the EarnProject class to handle an array of earnings, with forward and backward projections and specified levels of earnings.
FieldOfficeInfoFile.h | Declarations for the FieldOfficeInfoFile class to manage field office information stored on disk.
FieldOfficeInfoNonFile.h | Declarations for the FieldOfficeInfoNonFile class to manage field office information stored in memory.
foinfo.cpp | Functions for the FieldOfficeInfo class to manage field office information.
foinfo.h | Declarations for the FieldOfficeInfo class to manage field office information.
foinfofl.cpp | Functions for the FieldOfficeInfoFile class to manage field office information stored on disk.
foinfonf.cpp | Functions for the FieldOfficeInfoNonFile class to manage field office information stored in memory.
FrozMin.cpp | Functions for the FrozMin class to manage frozen minimum pia calculations.
FrozMin.h | Declarations for the FrozMin class to manage frozen minimum pia calculations.
frzyrs.cpp | Functions for the FreezeYears class to manage freeze period variables.
frzyrs.h | Declarations for the FreezeYears class to manage freeze period variables.
inscode.cpp | Functions for the InsCode class to manage an insured status code.
inscode.h | Declarations for the InsCode class to manage an insured status code.
InsCodeArray.cpp | Functions for the InsCodeArray class to manage an array of insured status codes.
InsCodeArray.h | Declarations for the InsCodeArray class to manage an array of insured status codes.
LawChange.cpp | Functions for the LawChange class to manage law-change parameters.
LawChange.h | Declarations for the LawChange class to manage law-change parameters.
LawChangeAGE65COMP.cpp | Functions for the LawChangeAGE65COMP class to manage parameters for a proposal to increase the number of elapsed years in a pia calculation.
LawChangeAGE65COMP.h | Declarations for the LawChangeAGE65COMP class to manage parameters for a proposal to increase the number of elapsed years in a pia calculation.
LawChangeALLEARN.cpp | Functions for the LawChangeALLEARN class to manage parameters for a proposal to use all years of earnings in an AIME calculation.
LawChangeALLEARN.h | Declarations for the LawChangeALLEARN class to manage parameters for a proposal to use all years of earnings in an AIME calculation.
LawChangeArray.cpp | Functions for the LawChangeArray class to manage an array of LawChange parameters.
LawChangeArray.h | Declarations for the LawChangeArray class to manage an array of LawChange parameters.
LawChangeBPFRACWAGE.cpp | Functions for the LawChangeBPFRACWAGE class to manage parameters for a proposal to increase the bend points in the benefit formula by a fraction of average wage growth.
LawChangeBPFRACWAGE.h | Declarations for the LawChangeBPFRACWAGE class to manage parameters for a proposal to increase the bend points in the benefit formula by a fraction of average wage growth.
LawChangeBPMINCONST.cpp | Functions for the LawChangeBPMINCONST class to manage parameters for a proposal to increase the bend points in the benefit formula by the growth in wages minus a specified rate.
LawChangeBPMINCONST.h | Declarations for the LawChangeBPMINCONST class to manage parameters for a proposal to increase the bend points in the benefit formula by the growth in wages minus a specified rate.
LawChangeBPSPECRATE.cpp | Functions for the LawChangeBPSPECRATE class to manage parameters for a proposal to increase the bend points in the benefit formula by a specified growth rate.
LawChangeBPSPECRATE.h | Declarations for the LawChangeBPSPECRATE class to manage parameters for a proposal to increase the bend points in the benefit formula by a specified growth rate.
LawChangeCHILDCARECREDIT.cpp | Functions for the LawChangeCHILDCARECREDIT class to manage parameters for a proposal to provide child care credits.
LawChangeCHILDCARECREDIT.h | Declarations for the LawChangeCHILDCARECREDIT class to manage parameters for a proposal to provide child care credits.
LawChangeCHILDCAREDROPOUT.cpp | Functions for the LawChangeCHILDCAREDROPOUT class to manage parameters for a proposal to provide child care dropout years.
LawChangeCHILDCAREDROPOUT.h | Declarations for the LawChangeCHILDCAREDROPOUT class to manage parameters for a proposal to provide child care dropout years.
LawChangeCOLACHANGE.cpp | Functions for the LawChangeCOLACHANGE class to manage parameters for a proposal to change the cost-of-living benefit increases.
LawChangeCOLACHANGE.h | Declarations for the LawChangeCOLACHANGE class to manage parameters for a proposal to change the cost-of-living benefit increases.
LawChangeDECLINEPERC.cpp | Functions for the LawChangeDECLINEPERC class to manage parameters for a proposal to decrease the benefit formula percentages by various rates.
LawChangeDECLINEPERC.h | Declarations for the LawChangeDECLINEPERC class to manage parameters for a proposal to decrease the benefit formula percentages by various rates.
LawChangeDROPOUTCHG.cpp | Functions for the LawChangeDROPOUTCHG class to manage parameters for a proposal to reduce the number of dropout years in a pia calculation.
LawChangeDROPOUTCHG.h | Declarations for the LawChangeDROPOUTCHG class to manage parameters for a proposal to reduce the number of dropout years in a pia calculation.
LawChangeMARRLENGTH.cpp | Functions for the LawChangeMARRLENGTH class to manage parameters for a proposal to change the length of marriage requirement for divorced spouse benefits.
LawChangeMARRLENGTH.h | Declarations for the LawChangeMARRLENGTH class to manage parameters for a proposal to change the length of marriage requirement for divorced spouse benefits.
LawChangeNEWFORMULA.cpp | Functions for the LawChangeNEWFORMULA class to manage parameters for a proposal to change the pia formula bend points and/or percentages.
LawChangeNEWFORMULA.h | Declarations for the LawChangeNEWFORMULA class to manage parameters for a proposal to change the pia formula bend points and/or percentages.
LawChangeNEWSPECMIN.cpp | Functions for the LawChangeNEWSPECMIN class to manage parameters for a proposal to change the special minimum pia calculation.
LawChangeNEWSPECMIN.h | Declarations for the LawChangeNEWSPECMIN class to manage parameters for a proposal to change the special minimum pia calculation.
LawChangeNRACHANGE.cpp | Functions for the LawChangeNRACHANGE class to manage parameters for a proposal to change the full retirement age.
LawChangeNRACHANGE.h | Declarations for the LawChangeNRACHANGE class to manage parameters for a proposal to change the full retirement age.
LawChangeOut.cpp | Functions for the LawChangeOut class to manage the output file of law change descriptions.
LawChangeOut.h | Declarations for the LawChangeOut class to manage the output file of law change descriptions.
LawChangePSAACCT.cpp | Functions for the LawChangePSAACCT class to manage parameters for a proposal to introduce individual accounts.
LawChangePSAACCT.h | Declarations for the LawChangePSAACCT class to manage parameters for a proposal to introduce individual accounts.
LawChangeRead.cpp | Functions for the LawChangeRead class to read law changes from a file.
LawChangeRead.h | Declarations for the LawChangeRead class to read law changes from a file.
LawChangeTAXBENCHG.cpp | Functions for the LawChangeTAXBENCHG class to manage parameters for a proposal to change the taxation of benefits.
LawChangeTAXBENCHG.h | Declarations for the LawChangeTAXBENCHG class to manage parameters for a proposal to change the taxation of benefits.
LawChangeTAXRATECHG.cpp | Functions for the LawChangeTAXRATECHG class to manage parameters for a proposal to change the OASDHI tax rates.
LawChangeTAXRATECHG.h | Declarations for the LawChangeTAXRATECHG class to manage parameters for a proposal to change the OASDHI tax rates.
LawChangeWAGEBASECHG.cpp | Functions for the LawChangeWAGEBASECHG class to manage parameters for a proposal to change the OASDI and/or old-law wage bases.
LawChangeWAGEBASECHG.h | Declarations for the LawChangeWAGEBASECHG class to manage parameters for a proposal to change the OASDI and/or old-law wage bases.
LawChangeWIDFACTOR.cpp | Functions for the LawChangeWIDFACTOR class to manage parameters for a proposal to change the factor for an aged widow(er) benefit.
LawChangeWIDFACTOR.h | Declarations for the LawChangeWIDFACTOR class to manage parameters for a proposal to change the factor for an aged widow(er) benefit.
LawChangeWIFEFACTOR.cpp | Functions for the LawChangeWIFEFACTOR class to manage parameters for a proposal to change the factor for an aged spouse benefit.
LawChangeWIFEFACTOR.h | Declarations for the LawChangeWIFEFACTOR class to manage parameters for a proposal to change the factor for an aged spouse benefit.
LawChangeWrite.cpp | Functions for the LawChangeWrite class to write law changes to a file.
LawChangeWrite.h | Declarations for the LawChangeWrite class to write law changes to a file.
MilServDatesVec.h | Declarations for the MilServDatesVec class to manage an array of military service dates records.
msdates.cpp | Functions for the MilServDates class to manage one military service dates record.
msdates.h | Declarations for the MilServDates class to manage one military service dates record.
msdatesvec.cpp | Functions for the MilServDatesVec class to manage an array of military service dates records.
oactcnst.h | Constants used in the various Oact C++ programs and utilities.
oldpia.cpp | Functions for the OldPia class - parent of all methods using pia tables in the calculation of a Social Security benefit.
OldPia.h | Declarations for the OldPia class - parent of all methods using pia tables in the calculation of a Social Security benefit.
oldstart.cpp | Functions for the OldStart class to manage old-start pia calculations.
OldStart.h | Declarations for the OldStart class to manage old-start pia calculations.
OldStartLC.cpp | Functions for the OldStartLC class to manage old-start pia calculations, with changes from present law.
OldStartLC.h | Declarations for the OldStartLC class to manage old-start pia calculations, with changes from present law.
pebs.cpp | Functions for the Pebs class to handle Social Security Statement data.
pebs.h | Declarations for the Pebs class to handle Social Security Statement data.
percmfb.cpp | Functions to handle MFB formula percentages.
percmfb.h | Declarations needed for class to manage array of MFB formula percentages.
percpia.cpp | Functions to handle PIA formula percentages.
percpia.h | Declarations needed for class to manage array of PIA formula percentages.
PercPiaOut.cpp | Functions for the PercPiaOut class to manage array of pia formula percentages.
PercPiaOut.h | Declarations for the PercPiaOut class to manage array of pia formula percentages.
piacal.cpp | Functions for the PiaCal class - parent of all classes that manage the calculation of a Social Security benefit.
piacal.h | Declarations for the PiaCal class - parent of all classes that manage the calculation of a Social Security benefit.
piacalany.cpp | Functions for the PiaCalAny class to manage pia calculation functions used in Anypia.
PiaCalAny.h | Declarations for the PiaCalAny class to manage pia calculation functions used in Anypia.
piacallc.cpp | Functions for the PiaCalLC class to manage law-change pia calculation functions.
PiaCalLC.h | Declarations for the PiaCalLC class to manage law-change pia calculation functions.
PiaCalPL.cpp | Functions for the PiaCalPL class to manage present law pia calculation functions.
PiaCalPL.h | Declarations for the PiaCalPL class to manage present law pia calculation functions.
piadata.cpp | Functions for the PiaData class to set up data to calculate and print out a PIA.
piadata.h | Declarations for the PiaData class to set up data to calculate and print out a PIA.
PiadataArray.cpp | Functions for the PiaDataArray class to manage an array of PiaData's, representing one family.
PiadataArray.h | Declarations for the PiaDataArray class to manage an array of PiaData's, representing one family.
PiaMethod.cpp | Functions for the PiaMethod class - parent of the various methods required for calculation of a Social Security benefit.
PiaMethod.h | Declarations for the PiaMethod class - parent of the various methods required for calculation of a Social Security benefit.
PiaParamsLCTR.cpp | Functions for the PiaParamsLCTR class to manage the changed law Social Security parameters, already projected based on a Trustees Report assumption.
PiaParamsLCTR.h | Declarations for the PiaParamsLCTR class to manage the changed law Social Security parameters, already projected based on a Trustees Report assumption.
PiaParamsTR.cpp | Functions for the PiaParamsTR class of pia calculation parameters using present law only, with projected values set to Trustees Report assumptions.
PiaParamsTR.h | Declarations for the PiaParamsTR class of pia calculation parameters using present law only, with projected values set to Trustees Report assumptions.
piaparms.cpp | Functions for the PiaParams class - parent of classes to manage the Social Security parameters required to calculate a Social Security benefit.
piaparms.h | Declarations for the PiaParams class - parent of classes to manage the Social Security parameters required to calculate a Social Security benefit.
piaparmsAny.cpp | Functions for the PiaParamsAny class to manage the Social Security parameters required to calculate Social Security benefits in the Anypia program.
piaparmsAny.h | Declarations for the PiaParamsAny class to manage the Social Security parameters required to calculate Social Security benefits in the Anypia program.
piaparmsLC.cpp | Functions for the PiaParamsLC class to handle changed law PIA parameters.
piaparmsLC.h | Declarations for the PiaParamsLC class to handle changed law PIA parameters.
piaparmsPL.cpp | Functions for the PiaParamsPL class of pia calculation parameters using present law only.
piaparmsPL.h | Declarations for the PiaParamsPL class of pia calculation parameters using present law only.
piaread.cpp | Functions for the PiaRead class to read a file of worker data from disk.
piaread.h | Declarations for the PiaRead class to read a file of worker data from disk.
piareadAny.cpp | Functions for the PiaReadAny class to read worker data for Anypia.
piareadAny.h | Declarations for the PiaReadAny class to read worker data for Anypia.
PiaTable.cpp | Functions for the PiaTable class to manage Pia Table pia calculations.
PiaTable.h | Declarations for the PiaTable class to manage Pia Table pia calculations.
PiaTableLC.cpp | Functions for the PiaTableLC class to manage Pia Table pia calculations, with changes from present law.
PiaTableLC.h | Declarations for the PiaTableLC class to manage Pia Table pia calculations, with changes from present law.
piawrite.cpp | Functions for the PiaWrite class to write out worker data.
piawrite.h | Declarations for the PiaWrite class to write out worker data.
piawriteAny.cpp | Functions for the PiaWriteAny class to write out worker data for Anypia program.
piawriteAny.h | Declarations for the PiaWriteAny class to write out worker data for Anypia program.
pib50mfb.cpp | Functions for the Pib50Mfb class to handle 1950 pib-mfb conversion table.
pib50pib.cpp | Functions for the Pib50Pib class to handle 1950 pib-pia conversion table.
pib52ame.cpp | Functions for the class to handle 1952 pib-ame conversion table.
bendmfb.cpp | Functions to handle MFB formula bend points.
pib52mfb.cpp | Functions for the class to handle 1952 pib-mfb conversion table.
bendpia.cpp | Functions for the BendPia class to handle PIA formula bend points.
pib54ame.cpp | Functions for the class to handle 1954 pib-ame conversion table.
pib54mfb.cpp | Functions for the class to handle 1954 pib-mfb conversion table.
pib54pia.cpp | Functions for the class to handle 1954 pib-pia conversion table.
pib58ame.cpp | Functions for the class to handle 1958 pib-ame conversion table.
pib58pib.cpp | Functions for the class to handle 1958 pib-pia conversion table.
pibtable.h | Declarations for the Pib50Mfb, Pib50Pib, Pib52Ame, Pib52Mfb, Pib54Ame, Pib54Mfb, Pib54Pia, Pib58Ame, and Pib58Pib classes to manage pib-pia conversion tables.
Pifc.cpp | Functions for the Pifc class representing a type of Social Security pia.
Pifc.h | Declarations for the Pifc class representing a type of Social Security pia.
PresValFacs.cpp | Functions for the PresValFacs class to handle present value factors.
PresValFacs.h | Declarations for the PresValFacs class to handle present value factors.
Psa.cpp | Functions for Psa class to manage PSA accounts.
Psa.h | Declarations for Psa class to manage PSA accounts.
qc.cpp | Functions for the Qc class to manage one annual quarters of coverage number.
qc.h | Declarations for the Qc class to manage one annual quarters of coverage number.
qcamt.cpp | Functions for the Qcamt class to manage array of amounts required for quarter of coverage.
qcamt.h | Declarations for the Qcamt class to manage array of amounts required for quarter of coverage.
QcArray.cpp | Functions for the QcArray class to handle an array of annual number of quarters of coverage.
QcArray.h | Declarations for the QcArray class to handle an array of annual number of quarters of coverage.
QcPacked.cpp | Functions for the QcPacked class to hold 8 quarters of coverage amounts in one word.
QcPacked.h | Declaration of the QcPacked class to hold 8 quarters of coverage amounts in one word.
railroad.cpp | Functions for the RailRoadData class to manage edited railroad record.
railroad.h | Declarations for the RailRoadData class to manage edited railroad record.
ReindWid.cpp | Functions for the ReindWid class to manage reindexed widow(er) pia calculations.
ReindWid.h | Declarations for the ReindWid class to manage reindexed widow(er) pia calculations.
ReindWidLC.cpp | Functions for the ReindWidLC class to manage reindexed widow(er) pia calculation with law changes.
ReindWidLC.h | Declarations for the ReindWidLC class to manage reindexed widow(er) pia calculation with law changes.
RetireTest.cpp | Functions for the RetireTest class to manage retirement test calculations.
RetireTest.h | Declarations for the RetireTest class to manage retirement test calculations.
rtgenrl.cpp | Functions for the RtGeneral class - parent of classes to manage one retirement test projection.
rtgenrl.h | Declarations for the RtGeneral class - parent of classes to manage one retirement test projection.
ScaledEarnFactors.cpp | Functions for the ScaledEarnFactors class of scaled earnings factors.
ScaledEarnFactors.h | Declarations for the ScaledEarnFactors class of scaled earnings factors.
Secondary.cpp | Functions for the Secondary class containing the information about a secondary benefit.
Secondary.h | Declarations for the Secondary class containing the information about a secondary benefit.
SecondaryArray.cpp | Functions for the SecondaryArray class to manage a vector of secondary benefit data.
SecondaryArray.h | Declarations for the SecondaryArray class to manage a vector of secondary benefit data.
Sga.cpp | Functions for the Sga class to manage SGA amounts.
Sga.h | Declarations for the Sga class to manage SGA amounts.
SgaDerived.cpp | Functions for the SgaBlindA, SgaBlindM, SgaMinA, SgaMinM, SgaMaxA, and SgaMaxM classes (derived classes of the SgaGeneral class).
SgaDerived.h | Declarations for the SgaBlindA, SgaBlindM, SgaMinA, SgaMinM, SgaMaxA, and SgaMaxM classes (derived classes of the SgaGeneral class).
SgaGeneral.cpp | Functions for the SgaGeneral class - parent of classes to handle historical and projected SGA (Substantial Gainful Activity) amounts, stored in arrays.
SgaGeneral.h | Declarations for the SgaGeneral class - parent of classes to handle historical and projected SGA (Substantial Gainful Activity) amounts, stored in arrays.
SpecMin.cpp | Functions for the SpecMin class to manage special minimum pia calculations.
SpecMin.h | Declarations for the SpecMin class to manage special minimum pia calculations.
SpecMinLC.cpp | Functions for the SpecMinLC class to manage special minimum pia calculations, including changes from present law.
SpecMinLC.h | Declarations for the SpecMinLC class to manage special minimum pia calculations, including changes from present law.
TaxBenefits.cpp | Functions for the TaxBenefits class to manage tax on benefits functions.
TaxBenefits.h | Declarations for the TaxBenefits class to manage tax on benefits functions.
TaxBenefitsLC.cpp | Functions for the TaxBenefitsLC class to manage tax on benefits functions with law changes.
TaxBenefitsLC.h | Declarations for the TaxBenefitsLC class to manage tax on benefits functions with law changes.
TaxData.cpp | Functions for the TaxData class to manage taxes paid by a worker.
TaxData.h | Declarations for the TaxData class to manage taxes paid by a worker.
TaxRates.cpp | Functions for the TaxRates class - parent of classes to manage OASDHI tax rates.
TaxRates.h | Declarations for the TaxRates class - parent of classes to manage OASDHI tax rates.
TaxRatesLC.cpp | Functions for the TaxRatesLC class to manage the Social Security payroll and self-employed tax rates, with changes from present law.
TaxRatesLC.h | Declarations for the TaxRatesLC class to manage the Social Security payroll and self-employed tax rates, with changes from present law.
TaxRatesPL.cpp | Functions for the TaxRatesPL class to manage the Social Security payroll and self-employed tax rates.
TaxRatesPL.h | Declarations for the TaxRatesPL class to manage the Social Security payroll and self-employed tax rates.
TransGuar.cpp | Functions for the TransGuar class to manage transitional guarantee pia calculations.
TransGuar.h | Declarations for the TransGuar class to manage transitional guarantee pia calculations.
TransGuarLC.cpp | Functions for the TransGuarLC class to manage transitional guarantee pia calculations, with changes from present law.
TransGuarLC.h | Declarations for the TransGuarLC class to manage transitional guarantee pia calculations, with changes from present law.
UserAssumptions.cpp | Functions for the UserAssumptions class to manage user-specified assumptions.
UserAssumptions.h | Declarations for the UserAssumptions class to manage user-specified assumptions.
WageBase.cpp | Functions for the WageBase, WageBaseHI, and WageBaseOldLaw classes to manage wage base projections.
WageBase.h | Declarations for the WageBase, WageBaseHI, and WageBaseOldLaw classes to manage wage base projections.
WageInd.cpp | Functions for the WageInd class to calculate a wage-indexed PIA.
WageInd.h | Declarations for the WageInd class to manage wage-indexed pia calculation functions.
WageIndGeneral.cpp | Functions for the WageIndGeneral class - parent of classes to manage wage-indexed pia calculations.
WageIndGeneral.h | Declarations for the WageIndGeneral class - parent of classes to manage wage-indexed pia calculations.
WageIndLC.cpp | Functions for the WageIndLC class to manage wage-indexed pia calculation, with law change parameters.
WageIndLC.h | Declarations for the WageIndLC class to manage wage-indexed pia calculation, with law change parameters.
WageIndNonFreeze.cpp | Functions for the WageIndNonFreeze class to calculate a wage-indexed non-freeze PIA.
WageIndNonFreeze.h | Declarations for the WageIndNonFreeze class to manage wage-indexed non-freeze pia calculation functions.
wbgenrl.cpp | Functions for the WageBaseGeneral class - parent of classes that manage wage base projections.
wbgenrl.h | Declarations for the WageBaseGeneral class - parent of classes that manage wage base projections.
wbgenrlLC.cpp | Functions for the WageBaseLC and WageBaseOldLawLC classes to manage wage base projections with law changes.
wbgenrlLC.h | Declarations for the WageBaseLC and WageBaseOldLawLC classes to manage wage base projections with law changes.
WorkerDataArray.cpp | Functions for the WorkerDataArray class to manage array of WorkerData's.
WorkerDataArray.h | Declarations for the WorkerDataArray class to manage array of WorkerData's.
WorkerDataGeneral.cpp | Functions for the WorkerDataGeneral class - parent of classes to manage worker data.
WorkerDataGeneral.h | Declarations for the WorkerDataGeneral class - parent of classes to manage worker data.
wrkrdata.cpp | Functions for the WorkerData class to manage worker data.
wrkrdata.h | Declarations for the WorkerData class to manage worker data.
bendmfb.h | Declarations needed for class to manage array of MFB formula bend points.
bendpia.h | Declarations for the BendPia class to manage array of PIA formula bend points.
PortionAime.cpp | Functions to handle PIA formula AIME portions.
PortionAime.h | Declarations needed for class to manage array of portions of AIME in the PIA formula.


Files

Files
Files
Files
Name | Description
AnypiaOut.cpp | Functions for the AnypiaOut class to manage all output pages from Anypia.
AnypiaOut.h | Declarations for the AnypiaOut class to manage all output pages from Anypia.
ChildCareCalc1Page.cpp | Functions for the ChildCareCalc1Page class to manage wage indexed earnings with child-care dropout years.
ChildCareCalc1Page.h | Declarations for the ChildCareCalc1Page class to manage wage indexed earnings with child-care dropout years.
ChildCareCalc2Page.cpp | Functions for the ChildCareCalc2Page class to manage wage indexed results with child-care dropout years.
ChildCareCalc2Page.h | Declarations for the ChildCareCalc2Page class to manage wage indexed results with child-care dropout years.
DibGuarPage.cpp | Functions for the DibGuarPage class to manage disability guarantee calculation output.
DibGuarPage.h | Declarations for the DibGuarPage class to manage disability guarantee calculation output.
EarningsPage.cpp | Functions for the EarningsPage class to manage earnings output.
EarningsPage.h | Declarations for the EarningsPage class to manage earnings output.
FamilyPage.cpp | Functions for the FamilyPage class to manage family members' benefits output.
FamilyPage.h | Declarations for the FamilyPage class to manage family members' benefits output.
FrozMinPage.cpp | Functions for the FrozMinPage class to manage frozen minimum calculation output.
FrozMinPage.h | Declarations for the FrozMinPage class to manage frozen minimum calculation output.
InsuredPage.cpp | Functions for the InsuredPage class to manage insured status output.
InsuredPage.h | Declarations for the InsuredPage class to manage insured status output.
OldStart1Page.cpp | Functions for the OldStart1Page class to manage old start calculation earnings output.
OldStart1Page.h | Declarations for the OldStart1Page class to manage old start calculation earnings output.
OldStart2Page.cpp | Functions for the OldStart2Page class to manage old start calculation results.
OldStart2Page.h | Declarations for the OldStart2Page class to manage old start calculation results.
OnePage.cpp | Functions for the OnePage class to manage one-page summary of results.
OnePage.h | Declarations for the OnePage class to manage one-page summary of results.
PebsCreditInfo.cpp | Functions for the PebsCreditInfo class to manage the Social Security Statement credit info page.
PebsCreditInfo.h | Declarations for the PebsCreditInfo class to manage the Social Security Statement credit info page.
PebsEarnings.cpp | Functions for the PebsEarnings class to manage Social Security Statement earnings page.
PebsEarnings.h | Declarations for the PebsEarnings class to manage Social Security Statement earnings page.
PebsEarningsInfo.cpp | Functions for the PebsEarningsInfo class to manage the Social Security Statement earnings info page.
PebsEarningsInfo.h | Declarations for the PebsEarningsInfo class to manage the Social Security Statement earnings info page.
PebsLetter.cpp | Functions for the PebsLetter class to manage the Social Security Statement letter page.
PebsLetter.h | Declarations for the PebsLetter class to manage the Social Security Statement letter page.
PebsOasdiEst.cpp | Functions for the PebsOasdiEst class to manage the Social Security Statement oasdi estimates info page.
PebsOasdiEst.h | Declarations for the PebsOasdiEst class to manage the Social Security Statement oasdi estimates info page.
PebsOasdiInfo.cpp | Functions for the PebsOasdiInfo class to manage the Social Security Statement oasdi benefit info page.
PebsOasdiInfo.h | Declarations for the PebsOasdiInfo class to manage the Social Security Statement oasdi benefit info page.
PebsOut.cpp | Functions for the PebsOut class to print out the Social Security Statement.
PebsOut.h | Declarations for the PebsOut class to print out the Social Security Statement.
PebsPageOut.cpp | Functions for the PebsPageOut class - parent of classes to write out results of Social Security Statement benefit calculation.
PebsPageOut.h | Declarations for the PebsPageOut class - parent of classes to write out results of Social Security Statement benefit calculation.
PebsWorkerEarnings.cpp | Functions for the PebsWorkerEarnings class to manage the Social Security Statement worker info and earnings page.
PebsWorkerEarnings.h | Declarations for the PebsWorkerEarnings class to manage the Social Security Statement worker info and earnings page.
PebsWorkerInfo.cpp | Functions for the PebsWorkerInfo class to manage the Social Security Statement worker info page.
PebsWorkerInfo.h | Declarations for the PebsWorkerInfo class to manage the Social Security Statement worker info page.
PiaOut.cpp | Functions for the PiaOut class to manage output for a non-Statement calculation.
PiaOut.h | Declarations for the PiaOut class to manage output for a non-Statement calculation.
PiaPageOut.cpp | Functions for the PiaPageOut class - parent of classes to write out results of a non-Statement benefit calculation.
PiaPageOut.h | Declarations for the PiaPageOut class - parent of classes to write out results of a non-Statement benefit calculation.
PiaTable1Page.cpp | Functions for the PiaTable1Page class to manage a pia table calculation earnings page.
PiaTable1Page.h | Declarations for the PiaTable1Page class to manage a pia table calculation earnings page.
PiaTable2Page.cpp | Functions for the PiaTable2Page class to manage a pia table calculation results page.
PiaTable2Page.h | Declarations for the PiaTable2Page class to manage a pia table calculation results page.
ReindWid1Page.cpp | Functions for the ReindWid1Page class to manage a re-indexed widow earnings page.
ReindWid1Page.h | Declarations for the ReindWid1Page class to manage a re-indexed widow earnings page.
ReindWid2Page.cpp | Functions for the ReindWid2Page class to manage a re-indexed widow calculation results page.
ReindWid2Page.h | Declarations for the ReindWid2Page class to manage a re-indexed widow calculation results page.
SpecMin1Page.cpp | Functions for the SpecMin1Page class to manage a special minimum calculation earnings page.
SpecMin1Page.h | Declarations for the SpecMin1Page class to manage a special minimum calculation earnings page.
SpecMin2Page.cpp | Functions for the SpecMin2Page class to manage a special minimum calculation results page.
SpecMin2Page.h | Declarations for the SpecMin2Page class to manage a special minimum calculation results page.
Summary1Page.cpp | Functions for the Summary1Page class to manage the top part of a summary of results page.
Summary1Page.h | Declarations for the Summary1Page class to manage the top part of a summary of results page.
Summary2Page.cpp | Functions for the Summary2Page class to manage the middle part of a summary of results page.
Summary2Page.h | Declarations for the Summary2Page class to manage the middle part of a summary of results page.
Summary3Page.cpp | Functions for the Summary3Page class to manage the bottom part of a summary of results page.
Summary3Page.h | Declarations for the Summary3Page class to manage the bottom part of a summary of results page.
SummaryPage.cpp | Functions for the SummaryPage class to manage the summary page of results.
SummaryPage.h | Declarations for the SummaryPage class to manage the summary page of results.
TaxesPage.cpp | Functions for the TaxesPage class to manage the taxes output page.
TaxesPage.h | Declarations for the TaxesPage class to manage the taxes output page.
TransGuar1Page.cpp | Functions for the TransGuar1Page class to manage the transitional guarantee calculation earnings page.
TransGuar1Page.h | Declarations for the TransGuar1Page class to manage the transitional guarantee calculation earnings page.
TransGuar2Page.cpp | Functions for the TransGuar2Page class to manage the transitional guarantee calculation results page.
TransGuar2Page.h | Declarations for the TransGuar2Page class to manage the transitional guarantee calculation results page.
WageInd1Page.cpp | Functions for the WageInd1Page class to manage a wage indexed earnings page.
WageInd1Page.h | Declarations for the WageInd1Page class to manage a wage indexed earnings page.
WageInd2Page.cpp | Functions for the WageInd2Page class to manage a wage indexed reuslts page.
WageInd2Page.h | Declarations for the WageInd2Page class to manage a wage indexed reuslts page.
WageIndNonFreeze1Page.cpp | Functions for the WageIndNonFreeze1Page class to manage a wage indexed earnings page.
WageIndNonFreeze1Page.h | Declarations for the WageIndNonFreeze1Page class to manage a wage indexed earnings page.
WageIndNonFreeze2Page.cpp | Functions for the WageIndNonFreeze2Page class to manage a wage indexed results page.
WageIndNonFreeze2Page.h | Declarations for the WageIndNonFreeze2Page class to manage a wage indexed results page.


Functions

Functions
Functions Legend
Functions
Name | Description
AfxFormatString1 | Loads the specified string resource and substitutes for the characters "%1" the string referenced by filler.
AfxFormatString2 | Loads the specified string resource and substitutes for the characters "%1"and "%2" the strings referenced by filler1 and filler2.
parseString | Parses a string into its delimited parts, using a space separator.
parseString | Parses a string into its delimited parts with a specified delimiter.
pblank | Inserts blanks or zeroes on the left of a formatted string representing a number.
pcomma | Inserts commas into a formatted string representing a number.


Functions

Legend
Legend
Method


Legend

Legend
Functions
Legend
Method


Functions

Functions
Functions Legend
Functions
Name | Description
isDebugPid | Returns true if argument person id is the debug pid.


Macros

Macros
Macros
Macros
Name | Description
ENDS | No special character for end of ostringstream.
FREEZE | No special function to freeze the string.
OSTREAM | Use ostringstream for formatting output.
PIA_IDS_2YEARS | (Currently unused.)
PIA_IDS_ACTQCOUT | String ID for printing actual quarters of coverage.
PIA_IDS_AGEMONTH | Type of PiaException thrown if number of months in an Age is greater than 11.
PIA_IDS_AGEPLAN | Type of PiaException thrown if planned age of retirement is out of range.
PIA_IDS_AIMEOUT | String ID for printing AIME.
PIA_IDS_AMEOUT | String ID for printing AMW.
PIA_IDS_ANDLATER | (Currently unused.)
PIA_IDS_ANSCCH | Type of PiaException thrown if catch-up increase indicator is out of range.
PIA_IDS_APPCOLA1 | Type of PiaException thrown if year is out of range in PiaParams::applyCola without catch-up.
PIA_IDS_APPCOLA2 | Type of PiaException thrown if year is out of range in PiaParams::applyCola with catch-up.
PIA_IDS_APPCOLA3 | Type of PiaException thrown if year is out of range in PiaParams::applyColaMfb without catch-up.
PIA_IDS_APPCOLA4 | Type of PiaException thrown if year is out of range in PiaParams::applyColaMfb with catch-up.
PIA_IDS_ARDRI1 | Type of PiaException thrown if age is out of range in PiaCal::ardriCal.
PIA_IDS_ARDRI10 | Type of PiaException thrown if aged wife age is before early retirement age in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI2 | Type of PiaException thrown if age is before early retirement age for OAB in PiaCal::ardriCal.
PIA_IDS_ARDRI3 | (Currently unused.)
PIA_IDS_ARDRI4 | Type of PiaException thrown if disabled widow(er) age is before earliest possible age in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI5 | Type of PiaException thrown if disabled widow(er) entitlement is before benefit date in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI6 | Type of PiaException thrown if aged widow(er) age is before earliest possible age in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI7 | Type of PiaException thrown if DIB entitlement before 1957 in PiaCal::ardriCal.
PIA_IDS_ARDRI8 | Type of PiaException thrown if age under 50 for DIB before 1960 in PiaCal::ardriCal.
PIA_IDS_ARDRI9 | Type of PiaException thrown if age over full retirement age for DIB in PiaCal::ardriCal.
PIA_IDS_ARFFOUT | String ID for printing actuarial reduction factor.
PIA_IDS_ARFMOUT | String ID for printing months of actuarial reduction.
PIA_IDS_ATODOUBLE | (Currently unused).
PIA_IDS_ATOFLOAT | (Currently unused).
PIA_IDS_ATOINT | (Currently unused).
PIA_IDS_ATOLONG | (Currently unused).
PIA_IDS_AVERAGETEXT | (Currently unused.)
PIA_IDS_AVGWG | Type of PiaException thrown if year is out of range in an AverageWage function.
PIA_IDS_AVGWGTTL | (Currently unused.)
PIA_IDS_AWASSUM | (Currently unused.)
PIA_IDS_AWBI1 | Type of PiaException thrown if unable to open input file in AwbiDataFile::read.
PIA_IDS_AWBI2 | Type of PiaException thrown if unable to open output file in AwbiDataFile::write.
PIA_IDS_AWBI3 | Type of PiaException thrown if unable to read all required data in AwbiDataFile::read.
PIA_IDS_AWBIDAT1 | Type of PiaException thrown if last year of historical data is too large in AwbiDataNonFile::setData.
PIA_IDS_AWOUT | String ID for printing average wage assumptions.
PIA_IDS_BASE1 | Type of PiaException thrown if first year is out of range in WageBaseGeneral::project.
PIA_IDS_BASE2 | Type of PiaException thrown if wage base is out of range.
PIA_IDS_BASECH | Type of PiaException thrown if wage base indicator is not 1 or 2.
PIA_IDS_BASEYR1 | Type of PiaException thrown if base year is out of range (1979-2020).
PIA_IDS_BASEYR2 | Type of PiaException thrown if unable to open output file in BaseYearFile::write.
PIA_IDS_BASEYR3 | Type of PiaException thrown if unable to read base year in BaseYearFile::read.
PIA_IDS_BASEYR4 | Type of PiaException thrown if unable to open input file in BaseYearFile::read.
PIA_IDS_BEGIN1 | Type of PiaException thrown if first year of earnings is out of range.
PIA_IDS_BEGIN2 | Type of PiaException thrown if last year of earnings is before first year of earnings in backward projection period.
PIA_IDS_BEGIN3 | Type of PiaException thrown if first year of earnings is before 1937.
PIA_IDS_BEGIN4 | Type of PiaException thrown if first year of earnings is in starting year of projections or later, in a Statement case.
PIA_IDS_BEGIN5 | Type of PiaException thrown if first year of earnings is after maximum year allowed, in a non-Statement case.
PIA_IDS_BEGIN6 | Type of PiaException thrown if there are no regular, railroad, or military earnings.
PIA_IDS_BEN1OUT | String ID for printing benefit before rounding.
PIA_IDS_BEN2OUT | String ID for printing benefit after rounding.
PIA_IDS_BENARRAY1 | Type of PiaException thrown if year is out of range in BenefitAmountArray functions.
PIA_IDS_BENARRAY2 | Type of PiaException thrown if year is out of range in BenefitAmountArray::[].
PIA_IDS_BENDATE1 | Type of PiaException thrown if benefit date is before entitlement date.
PIA_IDS_BENDATE2 | Type of PiaException thrown if month of benefit is out of range.
PIA_IDS_BENDATE3 | Type of PiaException thrown if year of benefit is before 1940.
PIA_IDS_BENDATE4 | Type of PiaException thrown if year of benefit is after maximum allowed.
PIA_IDS_BENDATE5 | (Currently unused.)
PIA_IDS_BENDATE6 | Type of PiaException thrown if secondary entitlement after benefit date.
PIA_IDS_BENFOUT | String ID for printing secondary benefit factor.
PIA_IDS_BIASSUM | (Currently unused.)
PIA_IDS_BICCHP | Type of PiaException thrown if year is out of range in Catchup functions.
PIA_IDS_BIOUT | String ID for printing benefit increase assumptions.
PIA_IDS_BIPROJTTL | (Currently unused.)
PIA_IDS_BIRTH1 | Type of PiaException thrown if year of birth is in current year or later (in Statement case).
PIA_IDS_BIRTH2 | Type of PiaException thrown if year of birth is before 1800.
PIA_IDS_BIRTH3 | Type of PiaException thrown if month of birth is out of range.
PIA_IDS_BIRTH4 | Type of PiaException thrown if day of birth is out of range.
PIA_IDS_BIRTH5 | Type of PiaException thrown if year of birth is after maximum allowed.
PIA_IDS_BIRTH6 | (Currently unused.)
PIA_IDS_BITANN1 | Type of PiaException thrown if year is out of range in BitAnnual functions.
PIA_IDS_CACHUP1 | Type of PiaException thrown if catch-up benefit increase is out of range.
PIA_IDS_CACHUP2 | Type of PiaException thrown if unable to open input file in CatchupFile::read.
PIA_IDS_CACHUP3 | Type of PiaException thrown if unable to open output file in CatchupFile::write.
PIA_IDS_CACHUP4 | Type of PiaException thrown if year is out of range in a Catchup function.
PIA_IDS_CESS2OUT | String ID for printing second prior date of cessation.
PIA_IDS_COMMA | Type of PiaException thrown if number of decimals is nonzero for other than a float type in pout.
PIA_IDS_CONFIG1 | Type of PiaException thrown if unable to open input file in ConfigFile::read.
PIA_IDS_CONFIG5 | Type of PiaException thrown if unable to open output file in ConfigFile::write.
PIA_IDS_CONFIG6 | Type of PiaException thrown if unable to read all required data in ConfigFile::read.
PIA_IDS_CPIINC1 | Type of PiaException thrown if benefit increase is out of range.
PIA_IDS_CPIINC2 | Type of PiaException thrown if unable to open output file in BiprojFile::write.
PIA_IDS_CPIINC3 | Type of PiaException thrown if unable to read all required data in BiprojFile::read.
PIA_IDS_CPIINC4 | Type of PiaException thrown if unable to open input file in BiprojFile::read.
PIA_IDS_CUPROJTTL | (Currently unused.)
PIA_IDS_CURINSOUT | String ID for printing currently insured status in survivor case.
PIA_IDS_DATEDAY | Type of PiaException thrown if day in a date is out of range.
PIA_IDS_DATEDIFF | Type of PiaException thrown if unable to difference two dates.
PIA_IDS_DATEMONTH | Type of PiaException thrown if month in a date is out of range.
PIA_IDS_DATEREAD | Type of PiaException thrown if unable to parse string into a date.
PIA_IDS_DATEYEAR | Type of PiaException thrown if year in a date is out of range.
PIA_IDS_DBLEANN1 | (Currently unused).
PIA_IDS_DBLEANN2 | Type of PiaException thrown if unable to read specified years in DoubleAnnualRead::read.
PIA_IDS_DEATH1 | Type of PiaException thrown if month of death is out of range.
PIA_IDS_DEATH2 | Type of PiaException thrown if year of death is after maximum allowed.
PIA_IDS_DEATH3 | Type of PiaException thrown if death before 1937 in a survivor case.
PIA_IDS_DEATH4 | Type of PiaException thrown if entitlement of survivor is before death of worker.
PIA_IDS_DEATH5 | Type of PiaException thrown if death of worker is before birth.
PIA_IDS_DEATH6 | (Currently unused.)
PIA_IDS_DEATHOUT | String ID for printing date of death.
PIA_IDS_DIBENTOUT | String ID for printing DIB date of entitlement.
PIA_IDS_DICESS1 | Type of PiaException thrown if month of cessation is out of range.
PIA_IDS_DICESS2 | Type of PiaException thrown if year of cessation is before 1937.
PIA_IDS_DICESS3 | Type of PiaException thrown if year of cessation is after maximum allowed.
PIA_IDS_DICESS4 | Type of PiaException thrown if disability cessation before onset.
PIA_IDS_DICESS5 | Type of PiaException thrown if prior disability cessation after second entitlement.
PIA_IDS_DICESS6 | Type of PiaException thrown if entitlement is before cessation.
PIA_IDS_DICESS7 | Type of PiaException thrown if cessation is after death in a survivor case.
PIA_IDS_DICESS8 | (Currently unused.)
PIA_IDS_DINS1OUT | String ID for printing first part of disability insured status.
PIA_IDS_DINS2OUT | String ID for printing second part of disability insured status.
PIA_IDS_DINS3OUT | String ID for printing third part of disability insured status.
PIA_IDS_DISREQCAL1 | Type of PiaException thrown if year in most recent freeze period is out of range in PiaData::qcDisReqCal.
PIA_IDS_DISREQCAL2 | Type of PiaException thrown if year in next most recent freeze period is out of range in PiaData::qcDisReqCal.
PIA_IDS_DOBOUT | String ID for printing date of birth.
PIA_IDS_DOBWIDOUT | String ID for printing date of birth of widow(er).
PIA_IDS_DRCFOUT | String ID for printing delayed retirement credit factor.
PIA_IDS_DRCMOUT | String ID for printing months of delayed retirement credit.
PIA_IDS_EARNHI | Type of PiaException thrown if Medicare earnings are out of range.
PIA_IDS_EARNMAL | Type of PiaException thrown if year is before 1937 in EarnProject::toString.
PIA_IDS_EARNPEBS | Type of PiaException thrown if OASDI earnings are out of range.
PIA_IDS_EARNPROJ | Type of PiaException thrown if projection year is out of range in EarnProject::project.
PIA_IDS_EARNTYPE | Type of PiaException thrown if type of earnings is out of range.
PIA_IDS_EARNTYPE1 | Type of PiaException thrown if projection year is out of range in PiaWrite::writeEarnType.
PIA_IDS_EARNTYPEYR | Type of PiaException thrown if year is out of range in EarnProject::setEarntype.
PIA_IDS_ELAPSOUT | String ID for printing elapsed years.
PIA_IDS_END1 | Type of PiaException thrown if last year of earnings is before 1937.
PIA_IDS_END2 | Type of PiaException thrown if last year of earnings is after maximum year allowed.
PIA_IDS_END3 | Type of PiaException thrown if first year of earnings in forward projection period is after last year of earnings in forward projection period.
PIA_IDS_END4 | Type of PiaException thrown if the total number of years of earnings is greater than the maximum allowed (MAXYRS).
PIA_IDS_ENT1 | Type of PiaException thrown if month of entitlement is out of range.
PIA_IDS_ENT2 | Type of PiaException thrown if year of entitlement is before 1940.
PIA_IDS_ENT3 | Type of PiaException thrown if year of entitlement is after maximum allowed.
PIA_IDS_ENT4 | (Currently unused.)
PIA_IDS_ERNLIMOUT | String ID for printing earnings over maximum allowed.
PIA_IDS_FAMSIZE | Type of PiaException thrown if family size is out of bounds.
PIA_IDS_FLOATANN1 | (Currently unused).
PIA_IDS_FLOATANN2 | (Currently unused).
PIA_IDS_FLOATMTH1 | Type of PiaException thrown if years are out of range in a FloatMonth function.
PIA_IDS_FLOATMTH2 | Type of PiaException thrown if unable to read specified years in FloatMonth::read.
PIA_IDS_FLOATMTH3 | Type of PiaException thrown if quarter is out of range in a FloatMonth function.
PIA_IDS_FLOATQTR1 | Type of PiaException thrown if years are out of range in a FloatQuarter function.
PIA_IDS_FLOATQTR2 | Type of PiaException thrown if unable to read specified years in FloatQuarter::read.
PIA_IDS_FLOATQTR3 | Type of PiaException thrown if quarter is out of range in a FloatQuarter function.
PIA_IDS_FLOATQTR4 | Type of PiaException thrown if data value is zero in a FloatQuarter divide function.
PIA_IDS_FMSTRING | Type of PiaException thrown if error in FrozMinPage::prepareStrings.
PIA_IDS_FOINFO1 | Type of PiaException thrown if unable to open input file in FieldOfficeInfoFile::read.
PIA_IDS_FOINFO2 | Type of PiaException thrown if unable to read all required data in FieldOfficeInfoFile::read.
PIA_IDS_FOINFO3 | Type of PiaException thrown if unable to open output file in FieldOfficeInfoFile::write.
PIA_IDS_FQINC1 | Type of PiaException thrown if average wage increase is out of range.
PIA_IDS_FQINC2 | Type of PiaException thrown if unable to open output file in AwincFile::write.
PIA_IDS_FQINC3 | Type of PiaException thrown if unable to read all required data in AwincFile::read.
PIA_IDS_FQINC4 | Type of PiaException thrown if unable to open input file in AwincFile::read.
PIA_IDS_FULLBEN | String ID for printing full secondary benefit.
PIA_IDS_GENFILE1 | Type of PiaException thrown if unable to open a Genfile for output.
PIA_IDS_GENFILE2 | Type of PiaException thrown if unable to open a Genfile for appended output.
PIA_IDS_GENFILE3 | Type of PiaException thrown if unable to open a Genfile for input.
PIA_IDS_HIGHTEXT | (Currently unused.)
PIA_IDS_HISTAMTTL | (Currently unused.)
PIA_IDS_HISTAMTUPDATE | (Currently unused.)
PIA_IDS_IALTAW1 | Type of PiaException thrown if average wage increase indicator is out of range in general case.
PIA_IDS_IALTAW2 | Type of PiaException thrown if average wage increase indicator is out of range in Statement case.
PIA_IDS_IALTBI1 | Type of PiaException thrown if benefit increase indicator is out of range in general case.
PIA_IDS_IALTBI2 | Type of PiaException thrown if benefit increase indicator is out of range in Statement case.
PIA_IDS_INSTATOUT | String ID for printing insured status.
PIA_IDS_INSUREOUT | String ID for printing fully insured for totalization benefits.
PIA_IDS_INTANN1 | (Currently unused).
PIA_IDS_INTANN2 | (Currently unused).
PIA_IDS_JBIRTH1 | (Currently unused.)
PIA_IDS_JBIRTH2 | (Currently unused.)
PIA_IDS_JBIRTH3 | (Currently unused.)
PIA_IDS_JBIRTH4 | (Currently unused.)
PIA_IDS_JBIRTH5 | (Currently unused.)
PIA_IDS_JOASDI | Type of PiaException thrown if type of benefit is out of range.
PIA_IDS_JONSET1 | (Currently unused.)
PIA_IDS_JONSET2 | (Currently unused.)
PIA_IDS_JONSET3 | (Currently unused.)
PIA_IDS_JONSET4 | (Currently unused.)
PIA_IDS_JONSET5 | Type of PiaException thrown if widow's disability is before birth.
PIA_IDS_JONSET6 | Type of PiaException thrown if widow's disability is after entitlement.
PIA_IDS_JONSET7 | (Currently unused.)
PIA_IDS_JSURV | Type of PiaException thrown if bic is not a valid life or survivor bic.
PIA_IDS_JSURVOUT | String ID for printing type of survivor.
PIA_IDS_LAWCHG1 | Type of PiaException thrown if starting year of law changes is out of range.
PIA_IDS_LAWCHG2 | Type of PiaException thrown if law change wage increase proportion is out of range.
PIA_IDS_LAWCHG3 | Type of PiaException thrown if law change benefit formula percentage is out of range.
PIA_IDS_LAWCHG4 | Type of PiaException thrown if law change bend point is out of range.
PIA_IDS_LAWCHG5 | Type of PiaException thrown if law change constant decline percentage is out of range.
PIA_IDS_LAWCHG6 | Type of PiaException thrown if unable to parse input line in LawChangeRead::read.
PIA_IDS_LAWCHG7 | Type of PiaException thrown if unable to open input file in LawChangeRead::read.
PIA_IDS_LAWCHG8 | Type of PiaException thrown if unable to open output file in LawChangeWrite::write.
PIA_IDS_LAWCHG9 | Type of PiaException thrown if type of law change is out of range.
PIA_IDS_LOWTEXT | (Currently unused.)
PIA_IDS_MAXIMUMTEXT | (Currently unused.)
PIA_IDS_METHOD | Type of PiaException thrown if years are inconsistent in PiaMethod::totalEarnCal.
PIA_IDS_MFBBEN | String ID for printing maximum family benefit.
PIA_IDS_MFBLOUT | String ID for printing MFB at eligibility.
PIA_IDS_MFBOUT | String ID for printing MFB.
PIA_IDS_MILSERV1 | Type of PiaException thrown if military service starting date is after ending date.
PIA_IDS_MILSERV2 | Type of PiaException thrown if number of military service periods is out of range in general case.
PIA_IDS_MILSERV3 | Type of PiaException thrown if number of military service periods is out of range in military service case.
PIA_IDS_MILSERV4 | Type of PiaException thrown if military service starting date is out of range.
PIA_IDS_MILSERV5 | Type of PiaException thrown if military service ending date is out of range.
PIA_IDS_MILSERV6 | Type of PiaException thrown if years are out of range in MilServDates::getQc3750.
PIA_IDS_MILSERV7 | Type of PiaException thrown if years are out of range in MilServDates::getEarn3750.
PIA_IDS_MODTC | Type of PiaException thrown if moddata is in error.
PIA_IDS_MONTHTEXT | (Currently unused).
PIA_IDS_NAMEOUT | String ID for printing worker's name.
PIA_IDS_NDISINOUT | String ID for printing not disability insured.
PIA_IDS_NEEDAW | (Currently unused).
PIA_IDS_NEEDBASES | Type of PiaException thrown if year is out of range in WorkerDataGeneral::need_bases.
PIA_IDS_NEEDBI | (Currently unused).
PIA_IDS_NINSTOUT | String ID for printing not insured in survivor case.
PIA_IDS_NINSUROUT | String ID for printing not fully insured.
PIA_IDS_NONPENDATE1 | Type of PiaException thrown if noncovered pension entitlement date is before birth.
PIA_IDS_NONPENDATE2 | Type of PiaException thrown if noncovered pension entitlement date is after death.
PIA_IDS_NONPENDATE3 | Type of PiaException thrown if noncovered pension entitlement date entry is invalid.
PIA_IDS_NONPENDATEOUT | String ID for printing noncovered pension entitlement date.
PIA_IDS_NONPENOUT | String ID for printing noncovered pension.
PIA_IDS_NRA1OUT | String ID for printing early retirement age.
PIA_IDS_NRAOUT | String ID for printing full retirement age.
PIA_IDS_NRAWIDOUT | String ID for printing widow(er)'s full retirement age.
PIA_IDS_NRAWIFEOUT | String ID for printing full retirement age of aged wife/husband.
PIA_IDS_NTOTALOUT | String ID for printing not insured for totalization benefits.
PIA_IDS_OABBENOUT | String ID for printing OAB date of benefit.
PIA_IDS_OABENTOUT | String ID for printing OAB date of entitlement.
PIA_IDS_OLDSTART1 | Type of PiaException thrown if date of entitlement is out of range in OldStart::calculate.
PIA_IDS_OLDSTART2 | Type of PiaException thrown if old start method number is out of range.
PIA_IDS_ONEPAGE | Type of PiaException thrown if error in OnePage::prepareStrings.
PIA_IDS_ONSET1 | Type of PiaException thrown if month of onset is out of range.
PIA_IDS_ONSET10 | (Currently unused.)
PIA_IDS_ONSET11 | Type of PiaException thrown if disability onset is after full retirement age.
PIA_IDS_ONSET2 | Type of PiaException thrown if day of onset is out of range.
PIA_IDS_ONSET2OUT | String ID for printing second prior date of onset.
PIA_IDS_ONSET3 | Type of PiaException thrown if year of onset is before 1937.
PIA_IDS_ONSET4 | Type of PiaException thrown if year of onset is after maximum allowed.
PIA_IDS_ONSET5 | Type of PiaException thrown if disability is before birth.
PIA_IDS_ONSET6 | Type of PiaException thrown if disability is after entitlement.
PIA_IDS_ONSET7 | Type of PiaException thrown if death of worker is before disability onset in a survivor case.
PIA_IDS_ONSET8 | Type of PiaException thrown if prior disability is after current disability.
PIA_IDS_ONSET9 | (Currently unused.)
PIA_IDS_ONSETOUT | String ID for printing date of onset.
PIA_IDS_OPENERR | (Currently unused.)
PIA_IDS_OSRANGE1 | (Currently unused.)
PIA_IDS_OSRANGE2 | (Currently unused.)
PIA_IDS_OSSTRING | Type of PiaException thrown if error in OldStart1Page::prepareStrings.
PIA_IDS_OUTFILE | (Currently unused.)
PIA_IDS_PEBESMONTH | Type of PiaException thrown if month of Statement processing is out of range.
PIA_IDS_PEBSASM | Type of PiaException thrown if benefit increase indicator or average wage increase indicator is out of range in Statement case.
PIA_IDS_PERCBACK | Type of PiaException thrown if backward projection percentage is out of range.
PIA_IDS_PERCFWRD | Type of PiaException thrown if forward projection percentage is out of range.
PIA_IDS_PIACALPLRGE | (Currently unused.)
PIA_IDS_PIACALRANGE | (Currently unused.)
PIA_IDS_PIALOUT | String ID for printing PIA at eligibility.
PIA_IDS_PIAOUT | String ID for printing PIA.
PIA_IDS_PIATABLE1 | Type of PiaException thrown if year of entitlement is out of range in PiaTable::calculate.
PIA_IDS_PIATABLE2 | Type of PiaException thrown if year of benefit is out of range in PiaTable::calculate.
PIA_IDS_PIB50MFB | Type of PiaException thrown if index is out of range in Pib50Mfb::getAt.
PIA_IDS_PIB50PIB | Type of PiaException thrown if index is out of range in Pib50Pib::getAt.
PIA_IDS_PIB52MFB | Type of PiaException thrown if index is out of range in Pib52Mfb::getAt.
PIA_IDS_PIB54MFB | Type of PiaException thrown if index is out of range in Pib54Mfb::getAt.
PIA_IDS_PIB54PIA | Type of PiaException thrown if index is out of range in Pib54Pia::getAt.
PIA_IDS_PIB58AME | Type of PiaException thrown if index is out of range in Pib58Ame::getAt.
PIA_IDS_PIB58PIB | Type of PiaException thrown if index is out of range in Pib58Pib::getAt.
PIA_IDS_PIBTABLE1 | (Currently unused.)
PIA_IDS_PIBTABLE2 | (Currently unused.)
PIA_IDS_PONSETOUT | String ID for printing second prior date of onset in nondisability case.
PIA_IDS_PRCESSOUT | String ID for printing prior date of cessation.
PIA_IDS_PRENTOUT | String ID for printing date of prior entitlement in nondisability case.
PIA_IDS_PRIOROUT | String ID for printing prior date of entitlement in disability case.
PIA_IDS_PROBASOUT | String ID for printing projected wage base type.
PIA_IDS_PROJBACK1 | Type of PiaException thrown if backward projection indicator is out of range in general case (0-2).
PIA_IDS_PROJBACK2 | Type of PiaException thrown if backward projection indicator is out of range in backward projection case (1-2).
PIA_IDS_PROJFWRD1 | Type of PiaException thrown if forward projection indicator is out of range in general case (0-2).
PIA_IDS_PROJFWRD2 | Type of PiaException thrown if forward projection indicator is out of range in forward projection case (1-2).
PIA_IDS_PRRENT1 | Type of PiaException thrown if month of prior entitlement is out of range.
PIA_IDS_PRRENT2 | Type of PiaException thrown if year of prior entitlement is before 1940.
PIA_IDS_PRRENT3 | Type of PiaException thrown if year of prior entitlement is after maximum allowed.
PIA_IDS_PRRENT4 | Type of PiaException thrown if prior entitlement is not before current entitlement.
PIA_IDS_PRRENT5 | Type of PiaException thrown if prior entitlement to disability is before disability onset.
PIA_IDS_PRRENT6 | (Currently unused.)
PIA_IDS_PRRENT7 | Type of PiaException thrown if prior entitlement to disability is after full retirement age.
PIA_IDS_PTSTRING | Type of PiaException thrown if error in PiaTable1Page::prepareStrings.
PIA_IDS_PUBPEN | Type of PiaException thrown if public pension amount is out of range.
PIA_IDS_QC | Type of PiaException thrown if number of quarters of coverage, 1951-77, is greater than number of quarters of coverage, 1937-77.
PIA_IDS_QC51TD | Type of PiaException thrown if number of quarters of coverage, 1951-77, is out of range.
PIA_IDS_QCAMT | Type of PiaException thrown if average wages have not been set in Qcamt::project.
PIA_IDS_QCANN | Type of PiaException thrown if number of annual quarters of coverage is out of range.
PIA_IDS_QCARRAY1 | Type of PiaException thrown if year is out of range in QcArray functions.
PIA_IDS_QCARRAY2 | (Currently unused).
PIA_IDS_QCARRAY3 | Type of PiaException thrown if years are out of range in QcArray::accumulate.
PIA_IDS_QCARRAY4 | Type of PiaException thrown if quarters are out of range in QcArray::accumulate.
PIA_IDS_QCCAL | Type of PiaException thrown if quarter of coverage amount has not been set in PiaData::qcCal.
PIA_IDS_QCDISCAL | Type of PiaException thrown if any starting or ending dates are out of range in PiaData::qcDisCal.
PIA_IDS_QCLUMPYEAR | Type of PiaException thrown if qclumpyear is out of range.
PIA_IDS_QCPACKED1 | Type of PiaException thrown if index is out of range in QcPacked::get.
PIA_IDS_QCPACKED2 | Type of PiaException thrown if index is out of range in QcPacked::set.
PIA_IDS_QCTD | Type of PiaException thrown if number of quarters of coverage, 1937-77, is out of range.
PIA_IDS_QCTOT0 | Type of PiaException thrown if no quarters of coverage in a totalization case.
PIA_IDS_QTRYRQTR | Type of PiaException thrown if number of quarters in a QtrYear is greater than 3.
PIA_IDS_QTRYRYR | Type of PiaException thrown if year in a QtrYear is greater than LASTYEARLR.
PIA_IDS_READEOF | Return value from PiaRead::read if successful read, with end of file following.
PIA_IDS_READERR | Type of PiaException thrown if unable to read a pia file.
PIA_IDS_READMORE | Return value from PiaRead::read if successful read, with additional data following.
PIA_IDS_RELERNOUT | String ID for printing relative earnings level.
PIA_IDS_RELERNPOS | Type of PiaException thrown if first year is out of range in PiaCal::relEarnPositionCal.
PIA_IDS_REQQCOUT | String ID for printing required quarters of coverage.
PIA_IDS_REVIEWBI | (Currently unused.)
PIA_IDS_ROUND | Type of PiaException thrown if year is before 1937 in BenefitAmount functions.
PIA_IDS_RTGENRL | Type of PiaException thrown if denominator is out of range in RtGeneral::project1.
PIA_IDS_RWSTRING | Type of PiaException thrown if error in ReindWid1Page::prepareStrings.
PIA_IDS_SECONDARY | Type of PiaException thrown if type of bic is not set in Secondary::check.
PIA_IDS_SETNOCH | Type of PiaException thrown if year is out of range in PiaParams::setNoChange.
PIA_IDS_SEX | Type of PiaException thrown if sex is not Sex::sex_type::MALE or Sex::sex_type::FEMALE.
PIA_IDS_SEXOUT | String ID for printing sex of worker.
PIA_IDS_SGAPROJ | Type of PiaException thrown if annual Sga project function is called.
PIA_IDS_SMSTRING | Type of PiaException thrown if error in SpecMin1Page::prepareStrings.
PIA_IDS_SPPIA1OUT | String ID for printing special minimum PIA, support PIA unused.
PIA_IDS_SPPIA2OUT | String ID for printing special minimum PIA, support PIA used.
PIA_IDS_SPYRS2OUT | String ID for printing total special minimum years of coverage.
PIA_IDS_SPYRSOUT | String ID for printing total special minimum years of coverage.
PIA_IDS_SSN1 | Type of PiaException thrown if number of characters in a string used to construct an Ssn is less than 9.
PIA_IDS_SSNOUT | String ID for printing worker's Social Security number.
PIA_IDS_START1 | Type of PiaException thrown if starting year of assumptions is before 1979.
PIA_IDS_START2 | Type of PiaException thrown if starting year of assumptions is after maximum year allowed.
PIA_IDS_SUPPIAOUT | String ID for printing support PIA.
PIA_IDS_SURVBENOUT | String ID for printing secondary date of benefit.
PIA_IDS_SURVENTOUT | String ID for printing secondary date of entitlement.
PIA_IDS_TAXTYPE | Type of PiaException thrown if type of taxes is out of range.
PIA_IDS_TAXTYPEYR | Type of PiaException thrown if year is out of range in WorkerData::setTaxType.
PIA_IDS_TGSTRING | Type of PiaException thrown if error in TransGuar1Page::prepareStrings.
PIA_IDS_TITLEPRO1 | (Currently unused.)
PIA_IDS_TITLEPRO2 | (Currently unused.)
PIA_IDS_TITLEPRO3 | (Currently unused.)
PIA_IDS_TITLEPRO4 | (Currently unused).
PIA_IDS_TWOPAGE1 | Type of PiaException thrown if error in InsuredPage::prepareStrings.
PIA_IDS_TWOPAGE2 | Type of PiaException thrown if error in EarningsPage::prepareStrings.
PIA_IDS_TWOPAGE3 | Type of PiaException thrown if error in Summary1Page::prepareStrings.
PIA_IDS_TWOPAGE4 | Type of PiaException thrown if error in Summary2Page::prepareStrings.
PIA_IDS_TWOPAGE5 | Type of PiaException thrown if error in Summary3Page::prepareStrings.
PIA_IDS_TXSTRING | Type of PiaException thrown if error in TaxesPage::prepareStrings.
PIA_IDS_UNBICCHP | Type of PiaException thrown if either year is out of range in PiaParams::unbiCatchUp.
PIA_IDS_UNEARNOUT | String ID for printing unused earnings message.
PIA_IDS_UPDATEAW | (Currently unused.)
PIA_IDS_UPDATEBI | (Currently unused.)
PIA_IDS_UPDATEFQ | Type of PiaException thrown if average wage is zero in PiaParams::updateFq.
PIA_IDS_UPDATEWB | (Currently unused.)
PIA_IDS_UPDATEWBOLD | (Currently unused.)
PIA_IDS_VALDI1 | Type of PiaException thrown if number of periods of disability is not 0, 1, or 2 in a nondisability case.
PIA_IDS_VALDI2 | Type of PiaException thrown if number of periods of disability is not 1 or 2 in a disability case.
PIA_IDS_WAGEBASE | (Currently unused.)
PIA_IDS_WAITPD1 | Type of PiaException thrown if first month of waiting period is out of range.
PIA_IDS_WAITPD2 | Type of PiaException thrown if year of first month of waiting period is before 1940.
PIA_IDS_WAITPD3 | Type of PiaException thrown if year of first month of waiting period is after maximum allowed.
PIA_IDS_WAITPD4 | Type of PiaException thrown if waiting period starts before onset.
PIA_IDS_WAITPD5 | Type of PiaException thrown if entitlement is before waiting period.
PIA_IDS_WAITPD6 | Type of PiaException thrown if cessation is before waiting period.
PIA_IDS_WAITPD7 | (Currently unused.)
PIA_IDS_WIDDIBOUT | String ID for printing date of onset of widow(er).
PIA_IDS_WISTRING | Type of PiaException thrown if error in WageInd1Page::prepareStrings.
PIA_IDS_WRITEEARN | Type of PiaException thrown if first year of earnings is out of range in PiaWrite::writeEarnOasdi or PiaWriteAny::writeEarnOasdi.
PIA_IDS_YEAR | (Currently unused.)
_AFXDLL | Use the AFXDLL library, which contains MFC in a DLL.


Legend

Legend
Age Members
Legend
Constructor
Operator


Age Members Public Friends

Age Members Public Friends
Age Members
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


Age Members Public Methods

Age Members Public Methods
Age Members Legend
Public Methods
Name | Description
Age | Initializes an Age, either as default or from an existing Age instance or integers.
deleteContents | Zeroes years and months.
getMonths | Returns months of age.
getYears | Returns years of age.
monthsCheck | Checks for months in bounds.
toMonths | Returns the age converted to months.
toString | Returns string with age as years and months.
~Age | Destructor.


Public Methods

Legend
Legend
Constructor


Legend

Legend
AnnualArrays Members
Legend
Method


AnnualArrays Members Public Methods

AnnualArrays Members Public Methods
AnnualArrays Members Legend
Public Methods
Name | Description
add | Adds the second DoubleAnnual to the first DoubleAnnual.
convert | Returns the DoubleAnnual converted from an IntAnnual.
divide | Divides the first DoubleAnnual by the second DoubleAnnual.
multiply | Multiplies a DoubleAnnual by a specified quantity.
subtract | Subtracts the second DoubleAnnual from the first DoubleAnnual.


Public Methods

Legend
Legend
Method


Legend

Legend
AnypiaOut Members
Legend
Constructor


AnypiaOut Members Public Methods

AnypiaOut Members Public Methods
AnypiaOut Members Legend
Public Methods
Name | Description
AnypiaOut | Constructor.
fillPageSlots | Fills out page slots.
getPage | Returns one page to print.
getPageCount | Returns number of pages to print.
setPebsOut | Sets pointer to Statement output.
setPiaCal | Sets pointer to pia calculation results.
setPiaData | Sets pointer to pia calculation data.
setPiaOut | Sets pointer to pia calculation output.
setWorkerData | Sets pointer to worker data.


Legend

Legend
Assumptions Members
Legend
Constructor
abstract
virtual


Assumptions Members Public Methods

Assumptions Members Public Methods
Assumptions Members Legend
Public Methods
Name | Description
Assumptions | Initializes an Assumptions, with or without a specified first year.
averageWageMenu | Set average wage increases from stored values.
benefitIncMenu | Set benefit increases from stored values.
getAverageWage | Returns an average wage increase assumption title.
getAwincProj | Returns projected average wage increases.
getBenefitInc | Returns a benefit increase assumption title.
getBiProj | Returns projected benefit increases.
getCatchupDoc | Returns catch-up benefit increases.
getIstart | Returns current year.
getMaxyear | Returns maximum projected year.
setAwincProjTitle | Set title of projected average wage increases.
setBiProjTitle | Set title of projected benefit increases.
setIstart | Sets the current year, including for the members.
~Assumptions | Destructor.


Public Methods

Legend
Legend
Constructor
abstract
virtual


Legend

Legend
AssumptionsFile Members
Legend
Constructor
Data Member


AssumptionsFile Members Public Data Members

AssumptionsFile Members Public Data Members
AssumptionsFile Members Legend
Public Data Members
Name | Description
awincProj | Projected average wage increases.
biProj | Projected benefit increases.
catchupDoc | Catch-up benefit increases.


Public Data Members

Legend
Legend
Data Member


AssumptionsFile Members Public Methods

AssumptionsFile Members Public Methods
AssumptionsFile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
Assumptions | Initializes an Assumptions, with or without a specified first year.
AssumptionsFile | Initializes arrays.
averageWageMenu | Reads stored average wage increases from disk.
benefitIncMenu | Reads stored benefit increases from disk.
getAverageWage | Returns an average wage increase assumption title.
getAwincProj | Returns projected average wage increases.
getBenefitInc | Returns a benefit increase assumption title.
getBiProj | Returns projected benefit increases.
getCatchupDoc | Returns catch-up benefit increases.
getIstart | Returns current year.
getMaxyear | Returns maximum projected year.
setAwincProjTitle | Set title of projected average wage increases.
setBiProjTitle | Set title of projected benefit increases.
setIstart | Sets the current year, including for the members.
~AssumptionsFile | Destructor.


Legend

Legend
AssumptionsNonFile Members
Legend
Constructor
Data Member


AssumptionsNonFile Members Public Data Members

AssumptionsNonFile Members Public Data Members
AssumptionsNonFile Members Legend
Public Data Members
Name | Description
awincProj | Projected average wage increases.
biProj | Projected benefit increases.
catchupDoc | Catch-up benefit increases.


AssumptionsNonFile Members Public Methods

AssumptionsNonFile Members Public Methods
AssumptionsNonFile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
Assumptions | Initializes an Assumptions, with or without a specified first year.
AssumptionsNonFile | Initializes an AssumptionsNonFile, either with or without a specified first year.
averageWageMenu | Reads stored average wage increases from a static array.
benefitIncMenu | Reads stored benefit increases from a static array.
getAverageWage | Returns an average wage increase assumption title.
getAwincProj | Returns projected average wage increases.
getBenefitInc | Returns a benefit increase assumption title.
getBiProj | Returns projected benefit increases.
getCatchupDoc | Returns catch-up benefit increases.
getIstart | Returns current year.
getMaxyear | Returns maximum projected year.
setAwincProjTitle | Set title of projected average wage increases.
setBiProjTitle | Set title of projected benefit increases.
setIstart | Sets the current year, including for the members.
~AssumptionsNonFile | Destructor.


AssumptionType Members Enumerations

AssumptionType Members Enumerations
AssumptionType Members Legend
Enumerations
Name | Description
assum_type | Type of assumptions.


Enumerations

Legend
Legend
Enumeration


Legend

Legend
AssumptionType Members
Legend
Enumeration
Data Member
Method


AssumptionType Members Public Data Members

AssumptionType Members Public Data Members
AssumptionType Members Legend
Public Data Members
Name | Description
EXPANDED_PEBES | True to use a wider range of possible assumptions for Statement calculations.


AssumptionType Members Public Methods

AssumptionType Members Public Methods
AssumptionType Members Legend
Public Methods
Name | Description
ialtawCheck1 | Checks average wage increase indicator in general case.
ialtawCheck2 | Checks average wage increase indicator in Statement case.
ialtbiCheck1 | Checks benefit increase indicator in general case.
ialtbiCheck2 | Checks benefit increase indicator in Statement case.
isFlatOrPebs | Returns true if argument is a statement-type constant-dollar assumption.
isNotTR | Returns true if argument is not a Trustees Report assumption.
isTR | Returns true if argument is a Trustees Report assumption.


Legend

Legend
AverageWage Members
Legend
Constructor
Operator
Data Member


AverageWage Members Public Data Members

AverageWage Members Public Data Members
AverageWage Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


AverageWage Members Public Friends

AverageWage Members Public Friends
AverageWage Members
Public Friends
Name | Description
class boost::serialization::access | Allows serialization of this class.


AverageWage Members Public Methods

AverageWage Members Public Methods
AverageWage Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
AverageWage | Initializes the first and last years.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
endYear | Returns the last year that data > 4.5, or returns 0.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects average wage amounts.
projectBackward | Projects the earnings amount backward for the specified year.
projectBackwardStatic | Projects an earnings amount back for one year.
projectForward | Projects the earnings amount forward for the specified year.
projectForwardStatic | Projects an earnings amount forward for one year.
round | Rounds an earnings amount to 2 decimal places.
startYear | Returns the first year that data > 4.5, or returns 0.
~AverageWage | Destroys average wage array.


Legend

Legend
AwbiData Members
Legend
Constructor
virtual
abstract
Data Member


AwbiData Members Public Data Members

AwbiData Members Public Data Members
AwbiData Members Legend
Public Data Members
Name | Description
HI_BASE_YEAR | Year when HI wage base first differs from OASDI base.
base77 | Historical old-law wage bases.
baseHi | Historical HI wage bases.
baseOasdi | Historical OASDI wage bases.
cpiinc | Historical benefit increases.
fq | Historical average wages.


AwbiData Members Public Methods

AwbiData Members Public Methods
AwbiData Members Legend
Public Methods
Name | Description
AwbiData | Initializes an AwbiData, with or without specifying the last year of historical wage bases.
getLastYear | Gets last year of historical wage bases.
read | Dummy function (descendant class may use it).
setData | Set data values.
setLastYear | Sets last year of historical wage bases.
write | Dummy function (descendant class may use it).
~AwbiData | Destructor.


Public Methods

Legend
Legend
Constructor
virtual
abstract


Legend

Legend
AwbiDataFile Members
Legend
Constructor
Data Member


AwbiDataFile Members Public Data Members

AwbiDataFile Members Public Data Members
AwbiDataFile Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
HI_BASE_YEAR | Year when HI wage base first differs from OASDI base.
base77 | Historical old-law wage bases.
baseHi | Historical HI wage bases.
baseOasdi | Historical OASDI wage bases.
cpiinc | Historical benefit increases.
fq | Historical average wages.


AwbiDataFile Members Public Methods

AwbiDataFile Members Public Methods
AwbiDataFile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
AwbiData | Initializes an AwbiData, with or without specifying the last year of historical wage bases.
AwbiDataFile | Initializes historical parameters info.
getLastYear | Gets last year of historical wage bases.
read | Reads historical parameters.
setAwbiFile | Forms a file name for historical parameters file.
setData | Dummy function (descendant class may use it).
setLastYear | Sets last year of historical wage bases.
write | Writes historical parameters.


Legend

Legend
AwbiDataNonFile Members
Legend
Constructor
virtual
Data Member


AwbiDataNonFile Members Public Data Members

AwbiDataNonFile Members Public Data Members
AwbiDataNonFile Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
HI_BASE_YEAR | Year when HI wage base first differs from OASDI base.
base77 | Historical old-law wage bases.
baseHi | Historical HI wage bases.
baseOasdi | Historical OASDI wage bases.
cpiinc | Historical benefit increases.
fq | Historical average wages.


AwbiDataNonFile Members Public Methods

AwbiDataNonFile Members Public Methods
AwbiDataNonFile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
AwbiData | Initializes an AwbiData, with or without specifying the last year of historical wage bases.
AwbiDataNonFile | Initializes an AwbiDataNonFile, with or without specifying the last year of historical wage bases.
getBase77Data | Returns a historical old-law wage base.
getBaseHiData | Returns a historical HI wage base.
getBaseOasdiData | Returns a historical OASDI wage base.
getCpiincData | Returns a historical benefit increase.
getFqData | Returns a historical average indexing wage.
getLastYear | Gets last year of historical wage bases.
read | Dummy function (descendant class may use it).
setData | Sets values for historical parameters through the last year of historical wage bases (to avoid reading from disk).
setLastYear | Sets last year of historical wage bases.
write | Dummy function (descendant class may use it).


Public Methods

Legend
Legend
Constructor
virtual


Legend

Legend
Awinc Members
Legend
Constructor
Data Member
Operator


Awinc Members Public Data Members

Awinc Members Public Data Members
Awinc Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


Awinc Members Public Friends

Awinc Members Public Friends
Awinc Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


Awinc Members Public Methods

Awinc Members Public Methods
Awinc Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
Awinc | Initializes an Awinc, with or without specifying the first year of data.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
fqincCheck | Checks an average wage increase.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Calculates average wage increases.


Legend

Legend
AwincDoc Members
Legend
Constructor
abstract
virtual
Data Member
protected


AwincDoc Members Protected Data Members

AwincDoc Members Protected Data Members
AwincDoc Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
avgwage | Titles of projected average wage increase assumptions, other than the four TR assumptions.
awincTitle | Title of projected average wage increases.


Protected Data Members

Legend
Legend
Data Member
protected


AwincDoc Members Public Data Members

AwincDoc Members Public Data Members
AwincDoc Members Legend
Public Data Members
Name | Description
awinc | Array of average wage increases.


AwincDoc Members Public Methods

AwincDoc Members Public Methods
AwincDoc Members Legend
Public Methods
Name | Description
AwincDoc | Initializes projected average wage increase info.
getFirstYear | Returns first year of data.
getTitle | Returns title of assumptions.
read | Read data.
setData | Sets data for one alternative.
setFirstYear | Sets first year of data.
setFqinc | Sets average wage increase for specified year.
setTitle | Sets title for one alternative.
write | Write data.
~AwincDoc | Destructor.


Legend

Legend
AwincFile Members
Legend
Constructor
abstract
protected
Data Member


AwincFile Members Protected Data Members

AwincFile Members Protected Data Members
AwincFile Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
avgwage | Titles of projected average wage increase assumptions, other than the four TR assumptions.
awincTitle | Title of projected average wage increases.


AwincFile Members Protected Methods

AwincFile Members Protected Methods
AwincFile Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
setAwFile | Forms a file name for projected average wage increase file.


Protected Methods

Legend
Legend
Method
protected


AwincFile Members Public Data Members

AwincFile Members Public Data Members
AwincFile Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
awinc | Array of average wage increases.


AwincFile Members Public Methods

AwincFile Members Public Methods
AwincFile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
AwincFile | Initializes projected average wage increase info.
getFirstYear | Returns first year of data.
getTitle | Returns title of assumptions.
read | Reads projected average wage increases.
setData | Sets data for one alternative.
setData | Sets data for one alternative.
setFirstYear | Sets first year of data.
setFqinc | Sets average wage increase for specified year.
setTitle | Sets title for one alternative.
setTitle | Sets title for one alternative.
write | Saves projected average wage increases.


Public Methods

Legend
Legend
Constructor
abstract


AwincNonFile Members Enumerations

AwincNonFile Members Enumerations
AwincNonFile Members Legend
Enumerations
Name | Description
DimLimits | Dimension limits.


Legend

Legend
AwincNonFile Members
Legend
Constructor
abstract
Enumeration
Data Member
protected


AwincNonFile Members Protected Data Members

AwincNonFile Members Protected Data Members
AwincNonFile Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
avgwage | Titles of projected average wage increase assumptions, other than the four TR assumptions.
awincTitle | Title of projected average wage increases.


AwincNonFile Members Public Data Members

AwincNonFile Members Public Data Members
AwincNonFile Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
awinc | Array of average wage increases.


AwincNonFile Members Public Methods

AwincNonFile Members Public Methods
AwincNonFile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
AwincNonFile | Initializes projected average wage increase info with latest Trustees Report assumptions.
getFirstYear | Returns first year of data.
getTitle | Returns title of assumptions.
read | Restore values to original values.
setData | Sets data for one alternative.
setData | Sets data for one alternative.
setFirstYear | Sets first year of data.
setFqinc | Sets average wage increase for specified year.
setTitle | Sets title for one alternative.
setTitle | Sets title for one alternative.
write | Dummy function.
~AwincNonFile | Destructor.


BaseChangeType Members Enumerations

BaseChangeType Members Enumerations
BaseChangeType Members Legend
Enumerations
Name | Description
change_type | Type of wage base changes.


Legend

Legend
BaseChangeType Members
Legend
Enumeration
Method


BaseChangeType Members Public Methods

BaseChangeType Members Public Methods
BaseChangeType Members Legend
Public Methods
Name | Description
check | Checks wage base indicator.
toString | Returns description of wage base projection method.


Legend

Legend
BaseYear Members
Legend
Constructor
abstract
virtual
Data Member
protected


BaseYear Members Protected Data Members

BaseYear Members Protected Data Members
BaseYear Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
theYear | Computation year.


BaseYear Members Public Methods

BaseYear Members Public Methods
BaseYear Members Legend
Public Methods
Name | Description
BaseYear | Initializes base year to zero.
getYear | Returns computation year.
read | Read base year.
setYear | Sets computation year.
write | Save base year.
yearCheck | Checks base year.
~BaseYear | Destroys base year info.


Legend

Legend
BaseYearFile Members
Legend
Constructor
Data Member
protected


BaseYearFile Members Protected Data Members

BaseYearFile Members Protected Data Members
BaseYearFile Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
theYear | Computation year.


BaseYearFile Members Public Methods

BaseYearFile Members Public Methods
BaseYearFile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
BaseYearFile | Initializes base year info.
getYear | Returns computation year.
read | Reads base year from disk.
setYear | Sets computation year.
write | Saves base year to disk.
yearCheck | Checks base year.


Legend

Legend
BaseYearNonFile Members
Legend
Constructor
Data Member
protected


BaseYearNonFile Members Protected Data Members

BaseYearNonFile Members Protected Data Members
BaseYearNonFile Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
theYear | Computation year.


BaseYearNonFile Members Public Data Members

BaseYearNonFile Members Public Data Members
BaseYearNonFile Members Legend
Public Data Members
Name | Description
TR_YEAR | Year of Trustees Report assumptions.
YEAR | Year for which data has been stored.


BaseYearNonFile Members Public Methods

BaseYearNonFile Members Public Methods
BaseYearNonFile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
BaseYearNonFile | Initializes base year.
getYear | Returns computation year.
read | Reads stored base year.
setYear | Sets computation year.
write | Saves base year (dummy function).
yearCheck | Checks base year.


Legend

Legend
BendMfb Members
Legend
Constructor
Data Member
Operator


BendMfb Members Public Data Members

BendMfb Members Public Data Members
BendMfb Members Legend
Public Data Members
Name | Description
BP1979 | Four bend points from 1979.


BendMfb Members Public Methods

BendMfb Members Public Methods
BendMfb Members Legend
Public Methods
Name | Description
BendMfb | Constructor.
as_array | Returns bend points as a simple array.
begin | This is the overview for the begin method overload.
deleteContents | Zeroes out all values.
end | This is the overview for the end method overload.
max_size | Returns maximum number of bend points.
project | Projects bend points, using 1979 bend points as a base.
size | Returns number of bend points.
~BendMfb | Destroys bend point array.


BendMfb Members Public Nested Types

BendMfb Members Public Nested Types
BendMfb Members
Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of number of bend points in this array.
value_type | The type of data in this array.


Legend

Legend
BendPia Members
Legend
Constructor
Data Member
Operator


BendPia Members Public Data Members

BendPia Members Public Data Members
BendPia Members Legend
Public Data Members
Name | Description
BP1979 | Three bend points from 1979.


BendPia Members Public Methods

BendPia Members Public Methods
BendPia Members Legend
Public Methods
Name | Description
BendPia | Constructor.
as_array | Returns bend points as a simple array.
begin | This is the overview for the begin method overload.
deleteContents | Zeroes out all values.
end | This is the overview for the end method overload.
getNumBend | Returns the number of bendpoints.
max_size | Returns maximum number of bend points.
project | Projects bend points, using 1979 bend points as a base.
setNumBend | Sets the number of bendpoints. Sets number of bend points.
size | Returns number of bend points.
~BendPia | Destroys bend point array.


BendPia Members Public Nested Types

BendPia Members Public Nested Types
BendPia Members
Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of size in this array.
value_type | The type of data in this array.


Legend

Legend
BenefitAmount Members
Legend
Constructor
Operator


BenefitAmount Members Public Methods

BenefitAmount Members Public Methods
BenefitAmount Members Legend
Public Methods
Name | Description
BenefitAmount | Initializes amount.
applyCola | Applies cola percent to a benefit.
get | Returns the benefit amount.
round | Rounds a PIA or MFB to the appropriate multiple of $0.10.
round1 | Rounds a specified PIA or MFB down to a whole dollar for June 1982 and later.
round5 | Rounds a benefit down to $5 multiple.
set | Sets the benefit amount.
toString | Returns benefit amount as a string with 2 decimal places.
unApplyCola | Removes cola percent from a quantity.
unround | Unrounds a PIA or MFB to the appropriate multiple of $0.10.


Legend

Legend
BenefitAmountArray Members
Legend
Constructor
Operator


BenefitAmountArray Members Public Methods

BenefitAmountArray Members Public Methods
BenefitAmountArray Members Legend
Public Methods
Name | Description
BenefitAmountArray | Initializes a BenefitAmountArray, with or without a specified ending year.
deleteContents | Sets all values to zero.
getLastYear | Returns the last year of data.
initialize | Initializes last year.
setDirty | Sets indicator for non-zero values.
~BenefitAmountArray | Deletes allocated memory.


Legend

Legend
Bic Members
Legend
Constructor
Operator


Bic Members Public Methods

Bic Members Public Methods
Bic Members Legend
Public Methods
Name | Description
Bic | Initializes a Bic, either with defaults or with specified characters.
eligibleForMax | Returns true if this benefit is affected by family maximum.
getLifeAuxType | Returns description of type of life auxiliary.
getMajorBic | Returns the major bic code.
getMinorBic | Returns the minor bic code.
getSurvivorType | Returns description of type of survivor.
isAuxiliary | Returns true if auxiliary beneficiary (major bic is B, C, D, E, F, or W).
isDisabledWidow | Returns true if disabled widow(er), false otherwise.
isReducible | Returns true if benefit is reducible for age.
isWidow | Returns true if widow(er) (aged or disabled), false otherwise.
isYoungSpouse | Returns true if young spouse.
isYoungSurvivor | Returns true if young survivor (child or mother/father), false otherwise.
set | Sets the bic codes.
setMajorBic | Sets the major bic code.
setMinorBic | Sets the minor bic code.
survivorCheck | Checks for valid survivor bic.
toString | Returns the bic code as a string.


Legend

Legend
Biproj Members
Legend
Constructor
abstract
virtual
Data Member
protected


Biproj Members Protected Data Members

Biproj Members Protected Data Members
Biproj Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
beninc | Titles of projected benefit increase assumptions, other than the four TR assumptions.
biprojTitle | Title of projected benefit increases.


Biproj Members Public Data Members

Biproj Members Public Data Members
Biproj Members Legend
Public Data Members
Name | Description
theData | Array of projected benefit increases.


Biproj Members Public Methods

Biproj Members Public Methods
Biproj Members Legend
Public Methods
Name | Description
Biproj | Initializes projected benefit increase info.
cpiincCheck | Checks a benefit increase.
getFirstYear | Returns first year of data.
getTitle | Returns title of assumptions.
read | Read benefit increases.
setCpiinc | Sets one benefit increase.
setData | Sets benefit increases for one alternative.
setFirstYear | Sets first year of data.
setTitle | Sets the title for one alternative.
write | Save benefit increases.
~Biproj | Destructor.


Legend

Legend
BiprojFile Members
Legend
Constructor
abstract
protected
Data Member


BiprojFile Members Protected Data Members

BiprojFile Members Protected Data Members
BiprojFile Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
beninc | Titles of projected benefit increase assumptions, other than the four TR assumptions.
biprojTitle | Title of projected benefit increases.


BiprojFile Members Protected Methods

BiprojFile Members Protected Methods
BiprojFile Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
setBiFile | Forms a file name for projected benefit increase file.


BiprojFile Members Public Data Members

BiprojFile Members Public Data Members
BiprojFile Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
theData | Array of projected benefit increases.


BiprojFile Members Public Methods

BiprojFile Members Public Methods
BiprojFile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
BiprojFile | Initializes projected benefit increase info.
cpiincCheck | Checks a benefit increase.
getFirstYear | Returns first year of data.
getTitle | Returns title of assumptions.
read | Reads projected benefit increases.
setCpiinc | Sets one benefit increase.
setData | Sets benefit increases for one alternative.
setData | Sets the benefit increases for one alternative.
setFirstYear | Sets first year of data.
setTitle | Sets the title for one alternative.
setTitle | Sets the title for one alternative.
write | Saves projected benefit increases.


BiprojNonFile Members Enumerations

BiprojNonFile Members Enumerations
BiprojNonFile Members Legend
Enumerations
Name | Description
DimLimits | Dimension limits.


Legend

Legend
BiprojNonFile Members
Legend
Constructor
abstract
Enumeration
Data Member
protected


BiprojNonFile Members Protected Data Members

BiprojNonFile Members Protected Data Members
BiprojNonFile Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
beninc | Titles of projected benefit increase assumptions, other than the four TR assumptions.
biprojTitle | Title of projected benefit increases.


BiprojNonFile Members Public Data Members

BiprojNonFile Members Public Data Members
BiprojNonFile Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
theData | Array of projected benefit increases.


BiprojNonFile Members Public Methods

BiprojNonFile Members Public Methods
BiprojNonFile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
BiprojNonFile | Initializes projected benefit increase info for latest Trustees Report.
cpiincCheck | Checks a benefit increase.
getFirstYear | Returns first year of data.
getTitle | Returns title of assumptions.
read | Restore values to original values.
setCpiinc | Sets one benefit increase.
setData | Sets benefit increases for one alternative.
setData | Sets the benefit increases for one alternative.
setFirstYear | Sets first year of data.
setTitle | Sets the title for one alternative.
setTitle | Sets the title for one alternative.
write | Dummy function.
~BiprojNonFile | Destructor.


Legend

Legend
BitAnnual Members
Legend
Constructor
virtual
Data Member
protected


BitAnnual Members Protected Data Members

BitAnnual Members Protected Data Members
BitAnnual Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
lastYear | Last year of data.
theData | Bit array.


BitAnnual Members Public Friends

BitAnnual Members Public Friends
BitAnnual Members
Public Friends
Name | Description
class boost::serialization::access | Allows serialization of this class.


BitAnnual Members Public Methods

BitAnnual Members Public Methods
BitAnnual Members Legend
Public Methods
Name | Description
BitAnnual | Initializes a BitAnnual, either with specified years or with data from another BitAnnual.
any | Returns true if at least one bit is set, false otherwise.
assign | Sets data from another BitAnnual for specified years.
deleteContents | Zeroes out all data values.
getBaseYear | Returns base year.
getBit | Returns one constant value of data.
getLastYear | Returns last year.
setBit | Sets one value of data.
~BitAnnual | Deletes allocated memory.


Legend

Legend
BpMfbOut Members
Legend
Constructor


BpMfbOut Members Public Methods

BpMfbOut Members Public Methods
BpMfbOut Members Legend
Public Methods
Name | Description
BpMfbOut | Initializes a BpMfbOut, with or without a specified first year.
getBpmfb1 | Returns first bend point for specified year.
getBpmfb2 | Returns second bend point for specified year.
getBpmfb3 | Returns third bend point for specified year.
setData | Sets data for one or all years.


Legend

Legend
BpPiaOut Members
Legend
Constructor


BpPiaOut Members Public Methods

BpPiaOut Members Public Methods
BpPiaOut Members Legend
Public Methods
Name | Description
BpPiaOut | Initializes a BpPiaOut with or without a first year.
getBppia | Returns bend point for specified year.
getNumBend | Returns number of bend points.
set1979Data | Sets data for all years based on the wage-indexed 1979 formula starting in the year of the firstYear argument, using the specified average wages for projection.
setIndexedData | Sets data for all years beginning with the firstYear argument, based on the bendpoints specified in the baseYear argument, and using the specified average wages for projection.
setSingleYearData | Sets data for one year using specified bendpoint values.


Legend

Legend
Catchup Members
Legend
Constructor
Data Member
protected


Catchup Members Protected Data Members

Catchup Members Protected Data Members
Catchup Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
catchup | Catch-up benefit increases for 10 years of eligibility.


Catchup Members Public Data Members

Catchup Members Public Data Members
Catchup Members Legend
Public Data Members
Name | Description
NUM_CATCHUP_ELIG_YEARS | The number of years of eligibility considered (10).


Catchup Members Public Methods

Catchup Members Public Methods
Catchup Members Legend
Public Methods
Name | Description
Catchup | Initializes a Catchup, with or without a specified starting year.
check | Checks a catch-up benefit increase.
deleteContents | Zeroes out catch-up benefit increases.
exist | Checks for existence of catch-up benefit increase.
get | Returns one catch-up increase.
getCatchupIncreases | Returns a CatchupIncreases array.
getCstart | Gets first year of catch-up increases.
parseString | Parses all catch-up increases for one year of eligibility from a string.
set | Sets one catch-up increase.
setCstart | Sets first year of catch-up increases.
~Catchup | Destroys catch-up benefit increases.


Legend

Legend
CatchupDoc Members
Legend
Constructor
abstract
virtual
Data Member


CatchupDoc Members Public Data Members

CatchupDoc Members Public Data Members
CatchupDoc Members Legend
Public Data Members
Name | Description
allownonzero | True to allow nonzero catch-up increases.
catchup | Catch-up benefit increases.


CatchupDoc Members Public Methods

CatchupDoc Members Public Methods
CatchupDoc Members Legend
Public Methods
Name | Description
CatchupDoc | Initializes a CatchupDoc, with or without a specified starting year.
exist | Checks for existence of catch-up increase.
get | Returns one catch-up increase.
read | Reads catch-up increases.
setData | Sets catch-up increases for one alternative.
write | Writes catch-up increases.
~CatchupDoc | Destroys catch-up benefit increase file.


Legend

Legend
CatchupFile Members
Legend
Constructor
abstract
Data Member
protected


CatchupFile Members Protected Data Members

CatchupFile Members Protected Data Members
CatchupFile Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
pathname | File information.


CatchupFile Members Protected Methods

CatchupFile Members Protected Methods
CatchupFile Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
setCuFile | Forms a file name for projected catch-up benefit increase file.


CatchupFile Members Public Data Members

CatchupFile Members Public Data Members
CatchupFile Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
allownonzero | True to allow nonzero catch-up increases.
catchup | Catch-up benefit increases.


CatchupFile Members Public Methods

CatchupFile Members Public Methods
CatchupFile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
CatchupDoc | Initializes a CatchupDoc, with or without a specified starting year.
CatchupFile | Initializes catch-up benefit increase file.
exist | Checks for existence of catch-up increase.
get | Returns one catch-up increase.
read | Reads all catch-up increases.
setData | Sets catch-up increases for one alternative.
setData | Deletes current catch-up increases if other than TR assumption.
write | Writes all catch-up increases.
~CatchupFile | Destroys catch-up benefit increase file.


Legend

Legend
CatchupIncreases Members
Legend
Constructor
Data Member
protected


CatchupIncreases Members Protected Data Members

CatchupIncreases Members Protected Data Members
CatchupIncreases Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Catch-up benefit increases for 8 calendar years.


CatchupIncreases Members Public Data Members

CatchupIncreases Members Public Data Members
CatchupIncreases Members Legend
Public Data Members
Name | Description
NUM_CATCHUP_INCREASES | The number of catch-up increases for one year of eligibility (8).


CatchupIncreases Members Public Methods

CatchupIncreases Members Public Methods
CatchupIncreases Members Legend
Public Methods
Name | Description
CatchupIncreases | Initializes catch-up benefit increase data.
get | Returns one catch-up increase.
parseString | Parses catch-up increases for one year of eligibility from a string.
set | Sets one catch-up increase.
toString | Returns catch-up increases for one year of eligibility as a string.
~CatchupIncreases | Destroys catch-up benefit increase data.


Legend

Legend
CatchupNonFile Members
Legend
Constructor
abstract
Data Member


CatchupNonFile Members Public Data Members

CatchupNonFile Members Public Data Members
CatchupNonFile Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
allownonzero | True to allow nonzero catch-up increases.
catchup | Catch-up benefit increases.


CatchupNonFile Members Public Methods

CatchupNonFile Members Public Methods
CatchupNonFile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
CatchupDoc | Initializes a CatchupDoc, with or without a specified starting year.
CatchupNonFile | Initializes catch-up benefit increases.
exist | Checks for existence of catch-up increase.
get | Returns one catch-up increase.
read | Read stored values from memory.
setData | Sets catch-up increases for one alternative.
setData | Sets catch-up benefit increases.
write | Dummy function.
~CatchupNonFile | Destructor.


Legend

Legend
ChildCareCalc1Page Members
Legend
Constructor
Data Member
protected


ChildCareCalc1Page Members Protected Data Members

ChildCareCalc1Page Members Protected Data Members
ChildCareCalc1Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


ChildCareCalc1Page Members Protected Methods

ChildCareCalc1Page Members Protected Methods
ChildCareCalc1Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


ChildCareCalc1Page Members Public Data Members

ChildCareCalc1Page Members Public Data Members
ChildCareCalc1Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


ChildCareCalc1Page Members Public Methods

ChildCareCalc1Page Members Public Methods
ChildCareCalc1Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
ChildCareCalc1Page | Initializes ChildCareCalc1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares wage indexed strings with childcare dropout years for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~ChildCareCalc1Page | Destructor.


Legend

Legend
ChildCareCalc2Page Members
Legend
Constructor
Data Member
protected


ChildCareCalc2Page Members Protected Data Members

ChildCareCalc2Page Members Protected Data Members
ChildCareCalc2Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
piaCal | Pia calculation detailed data.
piaData | Pia calculation summary data.
piaParams | Pia calculation parameters.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.
userAssumptions | User-specified assumptions.
workerData | Worker basic data.


ChildCareCalc2Page Members Protected Methods

ChildCareCalc2Page Members Protected Methods
ChildCareCalc2Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


ChildCareCalc2Page Members Public Data Members

ChildCareCalc2Page Members Public Data Members
ChildCareCalc2Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


ChildCareCalc2Page Members Public Methods

ChildCareCalc2Page Members Public Methods
ChildCareCalc2Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
ChildCareCalc2Page | Initializes ChildCareCalc2Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares wage indexed strings with childcare dropout years for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~ChildCareCalc2Page | Destructor.


ChildCareCalc Members Enumerations

ChildCareCalc Members Enumerations
ChildCareCalc Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
ChildCareCalc Members
Legend
Constructor
virtual
Data Member
protected
Enumeration


ChildCareCalc Members Protected Data Members

ChildCareCalc Members Protected Data Members
ChildCareCalc Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
windfallInd | Windfall indicator.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
yearsTotal | Number of years of coverage for windfall elimination.


ChildCareCalc Members Public Data Members

ChildCareCalc Members Public Data Members
ChildCareCalc Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.


ChildCareCalc Members Public Methods

ChildCareCalc Members Public Methods
ChildCareCalc Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
ChildCareCalc | Initializes a ChildCareCalc instance.
aimepiaCal | Calculates an AIME PIA under the 1977 law.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
bendPointCal | Projects bend points.
calculate | Computes wage indexed PIA with childcare dropout years.
childCareDropMaxCal | Returns maximum number of childcare dropout years.
childCareDropoutCal | Adjust for childcare dropout years.
deconvertAme | Deconverts AIME from raw PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAdjustedN | Returns number of computation years adjusted for childcare dropout years.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getChildCareDrop | Returns number of usable childcare dropout years.
getChildCareDropMax | Returns maximum number of childcare dropout years.
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIndexYearAvgWage | Returns average wage in indexing year.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
realWageGainAdj | Applies real-wage-gain adjustment.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionAime | Calculates portion of aime in each section of pia formula.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setWindfall | Sets windfall indicator in wage-indexed method.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
~ChildCareCalc | Destructor.


ChildCareCalcLC Members Enumerations

ChildCareCalcLC Members Enumerations
ChildCareCalcLC Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
ChildCareCalcLC Members
Legend
Constructor
abstract
virtual
Data Member
protected
Enumeration


ChildCareCalcLC Members Protected Data Members

ChildCareCalcLC Members Protected Data Members
ChildCareCalcLC Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
lawChange | Law change parameters.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
windfallInd | Windfall indicator.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
yearsTotal | Number of years of coverage for windfall elimination.


ChildCareCalcLC Members Public Data Members

ChildCareCalcLC Members Public Data Members
ChildCareCalcLC Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.


ChildCareCalcLC Members Public Methods

ChildCareCalcLC Members Public Methods
ChildCareCalcLC Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
ChildCareCalcLC | Initializes a ChildCareCalcLC instance.
aimepiaCal | Calculates an AIME PIA under the 1977 law.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
bendPointCal | Projects bend points.
calculate | Computes wage indexed PIA with childcare dropout years.
calculate | Calculates pia and mfb for this method.
childCareDropMaxCal | Returns maximum number of childcare dropout years.
childCareDropoutCal | Adjust for childcare dropout years.
deconvertAme | Deconverts AIME from raw PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAdjustedN | Returns number of computation years adjusted for childcare dropout years.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getChildCareDrop | Returns number of usable childcare dropout years.
getChildCareDropMax | Returns maximum number of childcare dropout years.
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIndexYearAvgWage | Returns average wage in indexing year.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
realWageGainAdj | Applies real-wage-gain adjustment.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionAime | Calculates portion of aime in each section of pia formula.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setWindfall | Sets windfall indicator in wage-indexed method.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
~ChildCareCalcLC | Destructor.


Legend

Legend
CompPeriod Members
Legend
Constructor


CompPeriod Members Public Methods

CompPeriod Members Public Methods
CompPeriod Members Legend
Public Methods
Name | Description
CompPeriod | Creates a CompPeriod with a given base year.
deleteContents | Zeroes all variables.
getBaseYear | Returns base year (1936 or 1950).
getDiYears | Returns number of years wholly or partially within a period of disability, within the elapsed years.
getN | Returns number of computation years.
getNDrop | Returns number of dropout years.
getNElapsed | Returns number of elapsed years.
setDiYears | Sets number of years wholly or partially within a period of disability, within the elapsed years.
setN | Sets number of computation years.
setNDrop | Sets number of dropout years.
setNElapsed | Sets number of elapsed years.


Legend

Legend
Config Members
Legend
Constructor
abstract
virtual


Config Members Public Methods

Config Members Public Methods
Config Members Legend
Public Methods
Name | Description
Config | Initializes configuration.
getLeftMargin | Returns left margin in inches.
getLongOutput | Returns long output indicator.
getPrinterPoints | Returns printer font point size.
getScreenPoints | Returns screen font point size.
getTopMargin | Returns top margin in inches.
read | Reads this structure.
setLeftMargin | Sets left margin in inches.
setLongOutput | Sets long output indicator.
setPrinterPoints | Sets printer font point size.
setScreenPoints | Sets screen font point size.
setTopMargin | Sets top margin in inches.
write | Writes this structure.
~Config | Destroys configuration.


Legend

Legend
ConfigFile Members
Legend
Constructor


ConfigFile Members Public Methods

ConfigFile Members Public Methods
ConfigFile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
ConfigFile | Initializes configuration.
getLeftMargin | Returns left margin in inches.
getLongOutput | Returns long output indicator.
getPrinterPoints | Returns printer font point size.
getScreenPoints | Returns screen font point size.
getTopMargin | Returns top margin in inches.
read | Reads the configuration from disk.
setLeftMargin | Sets left margin in inches.
setLongOutput | Sets long output indicator.
setPrinterPoints | Sets printer font point size.
setScreenPoints | Sets screen font point size.
setTopMargin | Sets top margin in inches.
write | Saves the configuration to disk.
~ConfigFile | Destroys configuration.


Legend

Legend
ConfigNonFile Members
Legend
Constructor


ConfigNonFile Members Public Methods

ConfigNonFile Members Public Methods
ConfigNonFile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
ConfigNonFile | Initializes configuration.
getLeftMargin | Returns left margin in inches.
getLongOutput | Returns long output indicator.
getPrinterPoints | Returns printer font point size.
getScreenPoints | Returns screen font point size.
getTopMargin | Returns top margin in inches.
read | Reads the configuration (dummy function).
setLeftMargin | Sets left margin in inches.
setLongOutput | Sets long output indicator.
setPrinterPoints | Sets printer font point size.
setScreenPoints | Sets screen font point size.
setTopMargin | Sets top margin in inches.
write | Saves the configuration (dummy function).
~ConfigNonFile | Destroys configuration.


Legend

Legend
Date Members
Legend
Data Member
Method


Date Members Public Data Members

Date Members Public Data Members
Date Members Legend
Public Data Members
Name | Description
highyear | Highest year that is acceptable (2200).
lowyear | Lowest year that is acceptable (1800).


Date Members Public Methods

Date Members Public Methods
Date Members Legend
Public Methods
Name | Description
addYears | Adds years to the specified date.
monthCheck | Checks for month in bounds.
yearCheck | Checks for year in bounds.


Legend

Legend
DateFormatter Members
Legend
Method


DateFormatter Members Public Methods

DateFormatter Members Public Methods
DateFormatter Members Legend
Public Methods
Name | Description
date_from_undelimited_us_string | Parses a date from an undelimited date string where the order is month (2 digits), day (2 digits), and year (4 digits).
month_year_from_undelimited_us_string | Parses a month and year date from an undelimited date string where the order is month (2 digits) and year (4 digits).
toString | Returns a string with a formatted date.


Legend

Legend
DateMoyr Members
Legend
Constructor
Operator


DateMoyr Members Public Friends

DateMoyr Members Public Friends
DateMoyr Members
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


DateMoyr Members Public Methods

DateMoyr Members Public Methods
DateMoyr Members Legend
Public Methods
Name | Description
DateMoyr | Initializes a DateMoyr from a variety of dates or a string.
check | Checks for valid month and year.
deleteContents | Zeroes month and year.
getMonth | Returns month of year.
getMonthBefore | Returns the date that is the month before this date.
getMonths | Returns number of months from this date to given date.
getYear | Returns the year.
index | Returns index of the month and year, based on January 1971 being 0.
isNotADate | Returns true if the default values of 0 for the year and month are present, which shows that it has never been set.
monthCheck | Checks for month in bounds.
~DateMoyr | Destroys date.


DibGuar Members Enumerations

DibGuar Members Enumerations
DibGuar Members Legend
Enumerations
Name | Description
ConvertedMfbType | The type of mfb at cessation, after conversion.
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
DibGuar Members
Legend
Constructor
virtual
Enumeration
protected
Data Member


DibGuar Members Protected Data Members

DibGuar Members Protected Data Members
DibGuar Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.


DibGuar Members Protected Methods

DibGuar Members Protected Methods
DibGuar Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
cessationMfbCal | Calculates the applicable mfb at cessation date.
convertedMfbTypeCal | Returns the type of mfb at cessation, after conversion.
dateCpiCal | Returns the date as of which the initial pia is calculated.
entDeathDateCal | Returns date of entitlement in a life case, or date of death in a survivor case.
yearCpi1Cal | Returns first year that benefit increases are applied.


DibGuar Members Public Data Members

DibGuar Members Public Data Members
DibGuar Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.


DibGuar Members Public Methods

DibGuar Members Public Methods
DibGuar Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
DibGuar | Initializes a disability guarantee pia method.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Computes disability guarantee PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCessationMfbConv | Returns the mfb based on the deconverted pia brought up to the cessation date.
getCessationMfbOrig | Returns the original mfb at the cessation date.
getColasApply | Returns true if colas apply from cessation date of prior disability to new entitlement date.
getConvertedMfbType | Returns the type of converted mfb.
getCpiYear | Returns year that benefit increases were applied.
getDiMaxApplies | Returns true if the mfb from the prior disability was determined using the Disability Maximum method.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getRawMfb | Returns the mfb based on the deconverted pia at eligibility date.
getRawPia | Returns the pia deconverted from cessation date to eligibility date.
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~DibGuar | Destructor.


DibGuarLC Members Enumerations

DibGuarLC Members Enumerations
DibGuarLC Members Legend
Enumerations
Name | Description
ConvertedMfbType | The type of mfb at cessation, after conversion.
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
DibGuarLC Members
Legend
Constructor
abstract
virtual
Enumeration
protected
Data Member


DibGuarLC Members Protected Data Members

DibGuarLC Members Protected Data Members
DibGuarLC Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.


DibGuarLC Members Protected Methods

DibGuarLC Members Protected Methods
DibGuarLC Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
cessationMfbCal | Calculates the applicable mfb at cessation date.
convertedMfbTypeCal | Returns the type of mfb at cessation, after conversion.
dateCpiCal | Returns the date as of which the initial pia is calculated.
entDeathDateCal | Returns date of entitlement in a life case, or date of death in a survivor case.
yearCpi1Cal | Returns first year that benefit increases are applied.


DibGuarLC Members Public Data Members

DibGuarLC Members Public Data Members
DibGuarLC Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.


DibGuarLC Members Public Methods

DibGuarLC Members Public Methods
DibGuarLC Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
DibGuarLC | Initializes a DibGuarLC instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Computes disability guarantee PIA.
calculate | Calculates pia and mfb for this method.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCessationMfbConv | Returns the mfb based on the deconverted pia brought up to the cessation date.
getCessationMfbOrig | Returns the original mfb at the cessation date.
getColasApply | Returns true if colas apply from cessation date of prior disability to new entitlement date.
getConvertedMfbType | Returns the type of converted mfb.
getCpiYear | Returns year that benefit increases were applied.
getDiMaxApplies | Returns true if the mfb from the prior disability was determined using the Disability Maximum method.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getRawMfb | Returns the mfb based on the deconverted pia at eligibility date.
getRawPia | Returns the pia deconverted from cessation date to eligibility date.
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~DibGuarLC | Destructor.


Legend

Legend
DibGuarPage Members
Legend
Constructor
protected
Data Member


DibGuarPage Members Protected Data Members

DibGuarPage Members Protected Data Members
DibGuarPage Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


DibGuarPage Members Protected Methods

DibGuarPage Members Protected Methods
DibGuarPage Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.
piamfbDeath | Prepares PIA and MFB at death in a string table.


DibGuarPage Members Public Data Members

DibGuarPage Members Public Data Members
DibGuarPage Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


DibGuarPage Members Public Methods

DibGuarPage Members Public Methods
DibGuarPage Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
DibGuarPage | Initializes DibGuarPage.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares frozen minimum strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~DibGuarPage | Destructor.


Legend

Legend
DisabPeriod Members
Legend
Constructor


DisabPeriod Members Public Friends

DisabPeriod Members Public Friends
DisabPeriod Members
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


DisabPeriod Members Public Methods

DisabPeriod Members Public Methods
DisabPeriod Members Legend
Public Methods
Name | Description
DisabPeriod | Constructor.
cessationDateCheck | Checks a date of disability cessation.
deleteCessationDate | Deletes the cessation date.
deleteContents | Sets all variables to default values.
deleteEntDate | Deletes the entitlement date.
deleteOnsetDate | Deletes the onset date.
deleteWaitperDate | Deletes the first month of the waiting period.
entDateCheck | Checks a date of entitlement.
getCessationDate | Returns date of disability cessation.
getCessationMfb | Returns the mfb in the month before cessation.
getCessationPia | Returns the pia in the month before cessation.
getEntDate | Returns date of entitlement to disability.
getOnsetDate | Returns date of disability onset.
getWaitperDate | Returns first month of waiting period.
onsetDateCheck | Checks a date of disability onset.
parseString | Parses a string into a DisabPeriod.
setCessationDate | Sets the cessation date.
setCessationMfb | Sets the mfb at cessation.
setCessationPia | Sets the pia at cessation.
setEntDate | Sets the entitlement date.
setOnsetDate | Sets the onset date.
setWaitperDate | Sets the first month of the waiting period.
toString | Returns the period of disability as a string.
waitperDateCal | Calculates first month of waiting period.
waitperDateCheck | Checks a first month of waiting period for general reasonableness.


DisInsCode Members Enumerations

DisInsCode Members Enumerations
DisInsCode Members Legend
Enumerations
Name | Description
DisInsCodeType | Disability insured status code types.


Legend

Legend
DisInsCode Members
Legend
Method
Enumeration
Operator


DisInsCode Members Public Methods

DisInsCode Members Public Methods
DisInsCode Members Legend
Public Methods
Name | Description
ChartoCode | Converts a character to a DisInsCode::DisInsCodeType.
DisInsCode | Initializes a DisInsCode, with or without a specified insured status.
get | Returns the disability insured status code.
isDiBenie | Returns disability benefit receipt status.
isDisabilityInsured | Returns disability insured status.
set | Sets the disability insured status code.
toChar | Returns a disability insured status code as a character.


Legend

Legend
DisInsCodeArray Members
Legend
Constructor
Operator


DisInsCodeArray Members Public Methods

DisInsCodeArray Members Public Methods
DisInsCodeArray Members Legend
Public Methods
Name | Description
DisInsCodeArray | Initializes the first and last years.
assign | Sets values for a range of years.
deleteContents | Zeroes out all data values.
getFirstYear | Returns the first year of data.
getLastYear | Returns the last year of data.
isNonzero | Returns true if any insured status code is other than DisInsCode::DisInsCodeType::NOQCS.
setFirstYear | Sets the first year of data.
setLastYear | Sets the last year of data.
toString | Returns data for one disability insured status code array as a string.


Legend

Legend
Document Members
Legend
Constructor
virtual
Data Member
protected


Document Members Protected Data Members

Document Members Protected Data Members
Document Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
pathname | Pathname of this file.


Document Members Public Methods

Document Members Public Methods
Document Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
errormesg | Returns message when error reading from file.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
readmesg | Returns message when reading from file.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
writemesg | Returns message when writing to file.
~Document | Destroys document.


Legend

Legend
DoubleAnnual Members
Legend
Constructor
virtual
Data Member
Operator


DoubleAnnual Members Public Data Members

DoubleAnnual Members Public Data Members
DoubleAnnual Members Legend
Public Data Members
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


DoubleAnnual Members Public Friends

DoubleAnnual Members Public Friends
DoubleAnnual Members
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


DoubleAnnual Members Public Methods

DoubleAnnual Members Public Methods
DoubleAnnual Members Legend
Public Methods
Name | Description
DoubleAnnual | Constructor.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
~DoubleAnnual | Destructor.


Legend

Legend
DoubleAnnualRead Members
Legend
Constructor


DoubleAnnualRead Members Public Methods

DoubleAnnualRead Members Public Methods
DoubleAnnualRead Members Legend
Public Methods
Name | Description
DoubleAnnualRead | Constructor.
read | Reads array from an open stream.


Legend

Legend
DoubleAnnualWrite Members
Legend
Constructor


DoubleAnnualWrite Members Public Methods

DoubleAnnualWrite Members Public Methods
DoubleAnnualWrite Members Legend
Public Methods
Name | Description
DoubleAnnualWrite | Constructor.
getLineWidth | Returns output line width.
getPrecision | Returns precision of output field.
getWidth | Returns width of output field.
write | Writes array to an open stream.


Legend

Legend
DoubleMonth Members
Legend
Constructor
Data Member
protected


DoubleMonth Members Protected Data Members

DoubleMonth Members Protected Data Members
DoubleMonth Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Double array.


DoubleMonth Members Public Methods

DoubleMonth Members Public Methods
DoubleMonth Members Legend
Public Methods
Name | Description
DoubleMonth | Initializes the baseYear and lastYear and the data array.
annAvgCal | Calculates annual average of the 12 monthly figures.
assign | Sets data for specified years.
getAt | Returns one value of data.
getBaseYear | Returns base year.
getLastYear | Returns last year.
getLineWidth | Returns line width for output.
getPrecision | Returns precision for output.
getWidth | Returns field width for output.
nmonCal | Finds number of months of (nonzero) data in a given year.
qtrAvgCal | Calculates quarterly average of the 3 monthly figures.
read | Reads array from an open stream.
setAt | Sets one value of data.
setLineWidth | Initializes line width for output.
setPrecision | Initializes precision for output.
setWidth | Initializes field width for output.
write | Writes array to an open stream.
~DoubleMonth | Destructor.


Legend

Legend
DoubleQuarter Members
Legend
Constructor
Data Member
protected


DoubleQuarter Members Protected Data Members

DoubleQuarter Members Protected Data Members
DoubleQuarter Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Double data.


DoubleQuarter Members Public Methods

DoubleQuarter Members Public Methods
DoubleQuarter Members Legend
Public Methods
Name | Description
DoubleQuarter | Initializes size, base year, and last year.
anninc | Calculates annual percentage increase.
anninc3 | Calculates 3-year percentage increase at annual rate.
assign | Sets data for a range of years.
average | Calculates annual average.
getAfter | Gets one value of data after specified quarter.
getAt | Gets one value of data.
getBaseYear | Returns base year.
getBefore | Gets one value of data before specified quarter.
getLastYear | Returns last year.
getLineWidth | Returns output line width.
getWidth | Returns field width on output.
multiply | Multiplies data by another DoubleQuarter.
read | Reads array from an open stream.
setAt | Sets one value of data.
setLineWidth | Initializes output line width.
setPrecision | Initializes precision on output.
setWidth | Initializes field width.
write | Writes array to an open stream.
~DoubleQuarter | Destructor.


Legend

Legend
EarningsPage Members
Legend
Constructor
Data Member
protected


EarningsPage Members Protected Data Members

EarningsPage Members Protected Data Members
EarningsPage Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


EarningsPage Members Protected Methods

EarningsPage Members Protected Methods
EarningsPage Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


EarningsPage Members Public Data Members

EarningsPage Members Public Data Members
EarningsPage Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


EarningsPage Members Public Methods

EarningsPage Members Public Methods
EarningsPage Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
EarningsPage | Initializes EarningsPage.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares earnings strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~EarningsPage | Destructor.


EarnProject Members Enumerations

EarnProject Members Enumerations
EarnProject Members Legend
Enumerations
Name | Description
earn_proj_type | Type of earnings projection.
earn_type | Type of earnings.


Legend

Legend
EarnProject Members
Legend
Constructor
virtual
Enumeration
Data Member


EarnProject Members Public Data Members

EarnProject Members Public Data Members
EarnProject Members Legend
Public Data Members
Name | Description
PERC_HIGH | Highest acceptable projection percentage.
PERC_LOW | Lowest acceptable projection percentage.
earnpebs | Worker earnings, 1937 to maxyear, as read in.


EarnProject Members Public Methods

EarnProject Members Public Methods
EarnProject Members Legend
Public Methods
Name | Description
EarnProject | Initializes this structure.
anyEntered | Returns true if any earnings are entered.
deleteContents | Initializes all variables to default values.
earnpebsCheck | Checks earnings.
earntypeCheck | Checks type of earnings.
getEarntype | Returns array of indicators for type of earnings.
getFirstYear | Returns first year of earnings.
getLastYear | Returns last year of earnings.
getPercback | Returns percentage used in backwards projection.
getPercfwrd | Returns percentage used in forwards projection.
getProjback | Returns backward projection indicator.
getProjfwrd | Returns forward projection indicator.
ibegin2Check | Checks for first year of earnings in bounds.
ibeginCheck | Checks for first year of earnings within bounds, using passed values, with a backward projection.
iendCheck | Checks for last year of earnings within bounds.
need_aw | Returns true if earnings are projected in last two years of historical period.
percbackCheck | Checks backward projection percentage.
percfwrdCheck | Checks forward projection percentage.
projbackCheck1 | Checks backward projection indicator in general case.
projbackCheck2 | Checks backward projection indicator in backward projection case.
project | Projects OASDI-covered earnings for the specified worker.
projfwrdCheck1 | Checks forward projection indicator in general case.
projfwrdCheck2 | Checks forward projection indicator in forward projection case.
setEarnpebs | Sets earnings for specified year.
setEarntype | Sets type of earnings for specified year.
setFirstYear | Sets first year of specified earnings (earnings could be projected backward before this year).
setLastYear | Sets last year of specified earnings (earnings could be projected forward after this year).
setPebsData | Sets some Statement data.
setPebsEarn | Sets last year of Statement earnings when computation year changes, or after a Statement calculation has been done.
setPercback | Sets backward projection percentage.
setPercfwrd | Sets percentage in forward projection.
setProjback | Sets backward projection indicator.
setProjfwrd | Sets forward projection indicator.
toString | Returns description of type of earnings.
yearsCheck | Checks for first and last year of earnings within bounds.
zeroEarn | Zeroes out earnings before firstYear and after lastYear.
~EarnProject | Destroys this structure.


Legend

Legend
FamilyPage Members
Legend
Constructor
Data Member
protected


FamilyPage Members Protected Data Members

FamilyPage Members Protected Data Members
FamilyPage Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


FamilyPage Members Protected Methods

FamilyPage Members Protected Methods
FamilyPage Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


FamilyPage Members Public Data Members

FamilyPage Members Public Data Members
FamilyPage Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


FamilyPage Members Public Methods

FamilyPage Members Public Methods
FamilyPage Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
FamilyPage | Initializes FamilyPage.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares strings for family members page.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~FamilyPage | Destructor.


Legend

Legend
FieldOfficeInfo Members
Legend
Constructor
abstract
virtual
Data Member


FieldOfficeInfo Members Public Data Members

FieldOfficeInfo Members Public Data Members
FieldOfficeInfo Members Legend
Public Data Members
Name | Description
numLines | Number of address lines (4).


FieldOfficeInfo Members Public Methods

FieldOfficeInfo Members Public Methods
FieldOfficeInfo Members Legend
Public Methods
Name | Description
FieldOfficeInfo | Initializes field office info.
getAddress | Returns one line of field office address.
getFieldOfficeName | Returns field office manager's name.
getFieldOfficeTitle | Returns field office manager's title.
read | Read field office info.
setAddress | Sets one line of field office address.
setData | Sets field office info.
setFieldOfficeName | Sets field office manager's name.
setFieldOfficeTitle | Sets field office manager's title.
write | Write field office info.
~FieldOfficeInfo | Destroys field office information.


Legend

Legend
FieldOfficeInfoFile Members
Legend
Constructor
Data Member


FieldOfficeInfoFile Members Public Data Members

FieldOfficeInfoFile Members Public Data Members
FieldOfficeInfoFile Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
numLines | Number of address lines (4).


FieldOfficeInfoFile Members Public Methods

FieldOfficeInfoFile Members Public Methods
FieldOfficeInfoFile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
FieldOfficeInfoFile | Initializes field office info.
getAddress | Returns one line of field office address.
getFieldOfficeName | Returns field office manager's name.
getFieldOfficeTitle | Returns field office manager's title.
read | Reads field office information from disk.
setAddress | Sets one line of field office address.
setData | Dummy function for file version.
setFieldOfficeName | Sets field office manager's name.
setFieldOfficeTitle | Sets field office manager's title.
write | Saves field office information to disk.
~FieldOfficeInfoFile | Destroys field office info.


Legend

Legend
FieldOfficeInfoNonFile Members
Legend
Constructor
Data Member


FieldOfficeInfoNonFile Members Public Data Members

FieldOfficeInfoNonFile Members Public Data Members
FieldOfficeInfoNonFile Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
numLines | Number of address lines (4).


FieldOfficeInfoNonFile Members Public Methods

FieldOfficeInfoNonFile Members Public Methods
FieldOfficeInfoNonFile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
FieldOfficeInfoNonFile | Initializes field office info.
getAddress | Returns one line of field office address.
getFieldOfficeName | Returns field office manager's name.
getFieldOfficeTitle | Returns field office manager's title.
read | Reads field office information (dummy function).
setAddress | Sets one line of field office address.
setData | Initializes name and address.
setFieldOfficeName | Sets field office manager's name.
setFieldOfficeTitle | Sets field office manager's title.
write | Saves field office information (dummy function).
~FieldOfficeInfoNonFile | Destroys field office info.


Legend

Legend
FloatAnnual Members
Legend
Constructor
virtual
Data Member
Operator


FloatAnnual Members Public Data Members

FloatAnnual Members Public Data Members
FloatAnnual Members Legend
Public Data Members
Name | Description
baseYear | Base year of data.
theData | Vector of floats.


FloatAnnual Members Public Friends

FloatAnnual Members Public Friends
FloatAnnual Members
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


FloatAnnual Members Public Methods

FloatAnnual Members Public Methods
FloatAnnual Members Legend
Public Methods
Name | Description
FloatAnnual | Constructor.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
~FloatAnnual | Destructor.


Legend

Legend
FloatMonth Members
Legend
Constructor
Data Member
protected


FloatMonth Members Protected Data Members

FloatMonth Members Protected Data Members
FloatMonth Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Float array.


FloatMonth Members Public Methods

FloatMonth Members Public Methods
FloatMonth Members Legend
Public Methods
Name | Description
FloatMonth | Initializes the base year and last year to the specified values.
annAvgCal | Calculates annual average of the 12 monthly figures.
assign | Sets data for specified years.
getAt | Returns one value of data.
getBaseYear | Returns base year.
getLastYear | Returns last year.
getLineWidth | Returns line width for output.
getPrecision | Returns precision for output.
getWidth | Returns field width for output.
nmonCal | Finds number of months of (nonzero) data in a given year.
qtrAvgCal | Calculates quarterly average of the 3 monthly figures.
read | Reads array from an open stream.
setAt | Sets one value of data.
setLineWidth | Initializes line width for output.
setPrecision | Initializes precision for output.
setWidth | Initializes field width for output.
write | Writes array to an open stream.
~FloatMonth | Destructor.


Legend

Legend
FloatQuarter Members
Legend
Constructor
Data Member
protected


FloatQuarter Members Protected Data Members

FloatQuarter Members Protected Data Members
FloatQuarter Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Float data.


FloatQuarter Members Public Methods

FloatQuarter Members Public Methods
FloatQuarter Members Legend
Public Methods
Name | Description
FloatQuarter | Initializes the base year and last year to the specified values.
anninc | Calculates annual percentage increase.
anninc3 | Calculates 3-year percentage increase at annual rate.
assign | Sets data for a range of years.
average | Calculates annual average.
getAfter | Gets one value of data after specified quarter.
getAt | Gets one value of data.
getBaseYear | Returns base year.
getBefore | Gets one value of data before specified quarter.
getLastYear | Returns last year.
getLineWidth | Returns output line width.
getWidth | Returns field width on output.
multiply | Multiplies data by another FloatQuarter.
read | Reads array from an open stream.
setAt | Sets one value of data.
setLineWidth | Initializes output line width.
setPrecision | Initializes precision on output.
setWidth | Initializes field width.
write | Writes array to an open stream.


Legend

Legend
FreezeYears Members
Legend
Constructor


FreezeYears Members Public Methods

FreezeYears Members Public Methods
FreezeYears Members Legend
Public Methods
Name | Description
FreezeYears | Creates a FreezeYears.
deleteContents | Zeroes all variables.
getYear1 | Returns first year in latest period of disability.
getYear2 | Returns last year in latest period of disability.
getYear3 | Returns first year in prior period of disability.
getYear4 | Returns last year in prior period of disability.
hasYears1 | Returns true if any years in latest freeze period.
hasYears2 | Returns true if any years in prior freeze period.
isFreezeYear | Returns true if year is wholly within a period of disability, false otherwise.
setYear1 | Sets first year in latest period of disability.
setYear2 | Sets last year in latest period of disability.
setYear3 | Sets first year in prior period of disability.
setYear4 | Sets last year in prior period of disability.


FrozMin Members Enumerations

FrozMin Members Enumerations
FrozMin Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
FrozMin Members
Legend
Constructor
virtual
Enumeration
Data Member
protected


FrozMin Members Protected Data Members

FrozMin Members Protected Data Members
FrozMin Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.


FrozMin Members Public Data Members

FrozMin Members Public Data Members
FrozMin Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.


FrozMin Members Public Methods

FrozMin Members Public Methods
FrozMin Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
FrozMin | Initializes a frozen minimum method.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Computes frozen minimum PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setFrozMin | Sets amounts for frozen minimum before benefit increases.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~FrozMin | Destructor.


Legend

Legend
FrozMinPage Members
Legend
Constructor
Data Member
protected


FrozMinPage Members Protected Data Members

FrozMinPage Members Protected Data Members
FrozMinPage Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


FrozMinPage Members Protected Methods

FrozMinPage Members Protected Methods
FrozMinPage Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


FrozMinPage Members Public Data Members

FrozMinPage Members Public Data Members
FrozMinPage Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


FrozMinPage Members Public Methods

FrozMinPage Members Public Methods
FrozMinPage Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
FrozMinPage | Initializes FrozMinPage.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares frozen minimum strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~FrozMinPage | Destructor.


Legend

Legend
Genfile Members
Legend
Constructor
virtual
Data Member
protected


Genfile Members Protected Data Members

Genfile Members Protected Data Members
Genfile Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
pathname | Pathname of this file.


Genfile Members Public Methods

Genfile Members Public Methods
Genfile Members Legend
Public Methods
Name | Description
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
getmesg | Returns current status or warning message.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
setmesg | Sets current status or warning message.
~Genfile | Destroys this instance.


InsCode Members Enumerations

InsCode Members Enumerations
InsCode Members Legend
Enumerations
Name | Description
InsCodeType | Insured status code types.


Legend

Legend
InsCode Members
Legend
Method
Enumeration
Operator


InsCode Members Public Methods

InsCode Members Public Methods
InsCode Members Legend
Public Methods
Name | Description
ChartoCode | Converts a character to an InsCode::InsCodeType.
InsCode | Initializes an InsCode, with or without a specified insured status.
get | Returns the insured status code.
isCurrentlyInsured | Returns the currently insured status.
isFullyInsured | Returns the fully insured status.
isFullyOrCurrentlyInsured | Returns the fully or currently insured status.
isFullyOrTotalInsured | Returns the fully or totalization insured status.
isPermanentlyInsured | Returns permanently insured status.
set | Sets the insured status code.
toChar | Returns an insured status code as a character.


Legend

Legend
InsCodeArray Members
Legend
Constructor
Operator


InsCodeArray Members Public Methods

InsCodeArray Members Public Methods
InsCodeArray Members Legend
Public Methods
Name | Description
InsCodeArray | Initializes the first and last years.
assign | Sets values for a range of years.
deleteContents | Zeroes out all data values.
getFirstYear | Returns the first year of data.
getLastYear | Returns the last year of data.
isNonzero | Returns true if any insured status code is other than InsCode::InsCodeType::NOQCS.
setFirstYear | Sets the first year of data.
setLastYear | Sets the last year of data.
toString | Returns data for one insured status code array as a string.


Legend

Legend
InsuredPage Members
Legend
Constructor
Data Member
protected


InsuredPage Members Protected Data Members

InsuredPage Members Protected Data Members
InsuredPage Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


InsuredPage Members Protected Methods

InsuredPage Members Protected Methods
InsuredPage Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


InsuredPage Members Public Data Members

InsuredPage Members Public Data Members
InsuredPage Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


InsuredPage Members Public Methods

InsuredPage Members Public Methods
InsuredPage Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
InsuredPage | Initializes InsuredPage.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares strings for insured status page.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~InsuredPage | Destructor.


Legend

Legend
IntAnnual Members
Legend
Constructor
Data Member
Operator


IntAnnual Members Public Data Members

IntAnnual Members Public Data Members
IntAnnual Members Legend
Public Data Members
Name | Description
baseYear | Base year of data.
theData | Integer array.


IntAnnual Members Public Methods

IntAnnual Members Public Methods
IntAnnual Members Legend
Public Methods
Name | Description
IntAnnual | Constructor.
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
~IntAnnual | Destructor.


LawChange Members Enumerations

LawChange Members Enumerations
LawChange Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChange Members
Legend
Constructor
virtual
Enumeration


LawChange Members Public Methods

LawChange Members Public Methods
LawChange Members Legend
Public Methods
Name | Description
LawChange | Initializes a LawChange, with or without a title.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years.
writeFirstLine | Writes a line with first and last years.
~LawChange | Destructor.


LawChangeAGE65COMP Members Enumerations

LawChangeAGE65COMP Members Enumerations
LawChangeAGE65COMP Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeAGE65COMP Members
Legend
Constructor
Enumeration


LawChangeAGE65COMP Members Public Methods

LawChangeAGE65COMP Members Public Methods
LawChangeAGE65COMP Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeAGE65COMP | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getStep | Returns step size when increasing computation period.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
setStep | Sets step size when increasing computation period.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.


LawChangeALLEARN Members Enumerations

LawChangeALLEARN Members Enumerations
LawChangeALLEARN Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeALLEARN Members
Legend
Constructor
Enumeration


LawChangeALLEARN Members Public Methods

LawChangeALLEARN Members Public Methods
LawChangeALLEARN Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeALLEARN | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getStep | Returns step size when increasing number of earnings years.
getTitle | Returns title of this law change.
getYear | Returns starting year when increasing number of earnings years.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
setStep | Sets step size when increasing number of earnings years.
setYear | Sets starting year when increasing number of earnings years.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and step size.
writeFirstLine | Writes a line with first and last years.


Legend

Legend
LawChangeArray Members
Legend
Constructor
Data Member
protected


LawChangeArray Members Protected Data Members

LawChangeArray Members Protected Data Members
LawChangeArray Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
pathname | Pathname of this file.


LawChangeArray Members Public Data Members

LawChangeArray Members Public Data Members
LawChangeArray Members Legend
Public Data Members
Name | Description
lawChange | Pointers to the law changes.
lawChangeAGE65COMP | Pointer to LawChangeAGE65COMP.
lawChangeALLEARN | Pointer to LawChangeALLEARN.
lawChangeBPFRACWAGE | Pointer to LawChangeBPFRACWAGE.
lawChangeBPMINCONST | Pointer to LawChangeBPMINCONST.
lawChangeBPSPECRATE | Pointer to LawChangeBPSPECRATE.
lawChangeCHILDCARECREDIT | Pointer to LawChangeCHILDCARECREDIT.
lawChangeCHILDCAREDROPOUT | Pointer to LawChangeCHILDCAREDROPOUT.
lawChangeCOLACHANGE | Pointer to LawChangeCOLACHANGE.
lawChangeDECLINEPERC | Pointer to LawChangeDECLINEPERC.
lawChangeDROPOUTCHG | Pointer to LawChangeDROPOUTCHG.
lawChangeMARRLENGTH | Pointer to LawChangeMARRLENGTH.
lawChangeNEWFORMULA | Pointer to LawChangeNEWFORMULA.
lawChangeNEWSPECMIN | Pointer to LawChangeNEWSPECMIN.
lawChangeNRACHANGE | Pointer to LawChangeNRACHANGE.
lawChangePSAACCT | Pointer to LawChangePSAACCT.
lawChangeTAXBENCHG | Pointer to LawChangeTAXBENCHG.
lawChangeTAXRATECHG | Pointer to LawChangeTAXRATECHG.
lawChangeWAGEBASECHG | Pointer to LawChangeWAGEBASECHG.
lawChangeWIDFACTOR | Pointer to LawChangeWIDFACTOR.
lawChangeWIFEFACTOR | Pointer to LawChangeWIFEFACTOR.


LawChangeArray Members Public Methods

LawChangeArray Members Public Methods
LawChangeArray Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
LawChangeArray | Initializes law-change array.
errormesg | Returns message when error reading from file.
getCorename | Returns the core file name, before modifiers or extensions.
getIndTotal | Returns total of law-change indicators (is greater than 0 if any law changes).
getModifier | Returns the modifier on the file name.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
indTotalCal | Calculates total changes in law.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
readmesg | Returns message when reading from file.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
writemesg | Returns message when writing to file.
~LawChangeArray | Destructor.


LawChangeBPFRACWAGE Members Enumerations

LawChangeBPFRACWAGE Members Enumerations
LawChangeBPFRACWAGE Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeBPFRACWAGE Members
Legend
Constructor
Enumeration


LawChangeBPFRACWAGE Members Public Methods

LawChangeBPFRACWAGE Members Public Methods
LawChangeBPFRACWAGE Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeBPFRACWAGE | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getProportionBendPoints | Returns proportion of wage increase applied to bend points.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setProportionBendPoints | Sets proportion of wage increase applied to bend points.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.


LawChangeBPMINCONST Members Enumerations

LawChangeBPMINCONST Members Enumerations
LawChangeBPMINCONST Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeBPMINCONST Members
Legend
Constructor
Enumeration


LawChangeBPMINCONST Members Public Methods

LawChangeBPMINCONST Members Public Methods
LawChangeBPMINCONST Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeBPMINCONST | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getConstantPerc | Returns constant percentage subtracted from bend point increase.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setConstantPerc | Sets constant percentage subtracted from bend point increase.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.


LawChangeBPSPECRATE Members Enumerations

LawChangeBPSPECRATE Members Enumerations
LawChangeBPSPECRATE Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeBPSPECRATE Members
Legend
Constructor
Enumeration


LawChangeBPSPECRATE Members Public Methods

LawChangeBPSPECRATE Members Public Methods
LawChangeBPSPECRATE Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeBPSPECRATE | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getBendPiaInc | Returns bend point increase percentage for specified year.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setBendPiaInc | Sets bend point increase percentage for specified year.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.


LawChangeCHILDCARECREDIT Members Enumerations

LawChangeCHILDCARECREDIT Members Enumerations
LawChangeCHILDCARECREDIT Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeCHILDCARECREDIT Members
Legend
Constructor
Enumeration


LawChangeCHILDCARECREDIT Members Public Methods

LawChangeCHILDCARECREDIT Members Public Methods
LawChangeCHILDCARECREDIT Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeCHILDCARECREDIT | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getAvgEarnPct | Returns the percentage to be multiplied by the person's average earnings to calculate the credit amount.
getChildCareYearsBeforeEffYear | Returns true if the person can be credited for child care years before the first effective year of the proposal, false otherwise.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getFqRatio | Returns ratio of average earnings credited for a child care year.
getInd | Returns indicator for this law-change.
getMaxAge | Returns maximum age of child to get credited for a child care year.
getMaxYears | Returns maximum number of child care years.
getNumDropExtremeEarnYears | Returns the number of years of highest earnings to drop out of the calculation of the credit amount.
getNumTopEarnYears | Returns the number of highest earnings years to look at for the calculation of the credit amount.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setAvgEarnPct | Sets the percentage to be multiplied by the person's average earnings to calculate the credit amount.
setChildCareYearsBeforeEffYear | Sets if the person can be credited for child care years before the first effective year of the proposal.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setFqRatio | Sets ratio of average earnings credited for a child care year.
setInd | Sets change indicator for this law-change.
setMaxAge | Sets maximum age of child to get credit for a child care year.
setMaxYears | Sets maximum number of child care years.
setNumDropExtremeEarnYears | Sets the number of years of highest earnings to drop out of the calculation of the credit amount.
setNumTopEarnYears | Sets the number of highest earnings years to look at for the calculation of the credit amount.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.


LawChangeCHILDCAREDROPOUT Members Enumerations

LawChangeCHILDCAREDROPOUT Members Enumerations
LawChangeCHILDCAREDROPOUT Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeCHILDCAREDROPOUT Members
Legend
Constructor
Enumeration


LawChangeCHILDCAREDROPOUT Members Public Methods

LawChangeCHILDCAREDROPOUT Members Public Methods
LawChangeCHILDCAREDROPOUT Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeCHILDCAREDROPOUT | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getFqRatio | Returns ratio of average earnings limit for a child care dropout year.
getInd | Returns indicator for this law-change.
getMaxAge | Returns maximum age of child to get a child care dropout year.
getMaxYears | Returns maximum number of child care dropout years.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setFqRatio | Sets ratio of average earnings limit for a child care dropout year.
setInd | Sets change indicator for this law-change.
setMaxAge | Sets maximum age of child to get a child care dropout year.
setMaxYears | Sets maximum number of child care dropout years.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.


LawChangeCOLACHANGE Members Enumerations

LawChangeCOLACHANGE Members Enumerations
LawChangeCOLACHANGE Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeCOLACHANGE Members
Legend
Constructor
Enumeration


LawChangeCOLACHANGE Members Public Methods

LawChangeCOLACHANGE Members Public Methods
LawChangeCOLACHANGE Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeCOLACHANGE | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getColaAdj | Returns the amount of adjustment to COLA.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getPiaPercentile | Returns the PIA percentile to use when indicator == 2.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads the one line required for this law-change.
setColaAdj | Sets the amount of adjustment to COLA.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setPiaPercentile | Sets the PIA percentile to use when indicator == 2.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with this law-change.
writeFirstLine | Writes a line with first and last years.


LawChangeDECLINEPERC Members Enumerations

LawChangeDECLINEPERC Members Enumerations
LawChangeDECLINEPERC Members Legend
Enumerations
Name | Description
DimLimits | Array sizes.
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeDECLINEPERC Members
Legend
Constructor
Enumeration


LawChangeDECLINEPERC Members Public Methods

LawChangeDECLINEPERC Members Public Methods
LawChangeDECLINEPERC Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeDECLINEPERC | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getAltPercPia | Returns specified benefit formula percentage for specified year.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFactor | Returns percentage decline in specified benefit formula percent for specified year.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
getYear | Returns year that declining benefit formula percentage is effective.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
percPiaCal | Sets pia formula percentages.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setFactor | Sets percentage decline in benefit formula percent.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
setYear | Sets year that declining benefit formula percentage is effective.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.
~LawChangeDECLINEPERC | Destructor.


LawChangeDROPOUTCHG Members Enumerations

LawChangeDROPOUTCHG Members Enumerations
LawChangeDROPOUTCHG Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeDROPOUTCHG Members
Legend
Constructor
Enumeration


LawChangeDROPOUTCHG Members Public Methods

LawChangeDROPOUTCHG Members Public Methods
LawChangeDROPOUTCHG Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeDROPOUTCHG | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getStep | Returns step size when reducing number of dropout years.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
setStep | Sets step size when reducing number of dropout years.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and step size.
writeFirstLine | Writes a line with first and last years.


LawChangeMARRLENGTH Members Enumerations

LawChangeMARRLENGTH Members Enumerations
LawChangeMARRLENGTH Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeMARRLENGTH Members
Legend
Constructor
Enumeration


LawChangeMARRLENGTH Members Public Methods

LawChangeMARRLENGTH Members Public Methods
LawChangeMARRLENGTH Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeMARRLENGTH | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getMarrLengthForDivBen | Returns the number of years of marriage needed for a divorced spouse benefit.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setMarrLengthForDivBen | Sets the number of years of marriage needed for a divorced spouse benefit.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and step size.
writeFirstLine | Writes a line with first and last years.


LawChangeNEWFORMULA Members Enumerations

LawChangeNEWFORMULA Members Enumerations
LawChangeNEWFORMULA Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeNEWFORMULA Members
Legend
Constructor
Enumeration


LawChangeNEWFORMULA Members Public Methods

LawChangeNEWFORMULA Members Public Methods
LawChangeNEWFORMULA Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeNEWFORMULA | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getAltBendPia | Returns specified alternate bend point for specified year.
getAltPercPia | Returns specified benefit formula percentage for specified year.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getNumBp | Returns number of bendpoints in the alternate formula.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setAltBendPia | Sets specified alternate bend point for specified year.
setAltPercPia | Sets specified alternate benefit formula percentage for specified year.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setNumBp | Sets number of bendpoints in the alternate formulas.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.
~LawChangeNEWFORMULA | Destructor.


LawChangeNEWSPECMIN Members Enumerations

LawChangeNEWSPECMIN Members Enumerations
LawChangeNEWSPECMIN Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeNEWSPECMIN Members
Legend
Constructor
Enumeration


LawChangeNEWSPECMIN Members Public Methods

LawChangeNEWSPECMIN Members Public Methods
LawChangeNEWSPECMIN Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeNEWSPECMIN | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getAmount | Returns alternative special minimum dollar amount.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPercent | Returns alternate special minimum percentage of wage base required for quarter of coverage.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
getYears | Returns alternative maximum number of years of coverage considered in special minimum calculation (30 in PL).
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setAmount | Sets alternative special minimum dollar amount.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPercent | Sets alternate special minimum percentage of wage base required for quarter of coverage.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
setYears | Sets alternative maximum number of years of coverage considered in special minimum calculation (30 in PL).
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and step size.
writeFirstLine | Writes a line with first and last years.


LawChangeNRACHANGE Members Enumerations

LawChangeNRACHANGE Members Enumerations
LawChangeNRACHANGE Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeNRACHANGE Members
Legend
Constructor
virtual
Data Member
Enumeration


LawChangeNRACHANGE Members Public Data Members

LawChangeNRACHANGE Members Public Data Members
LawChangeNRACHANGE Members Legend
Public Data Members
Name | Description
ageArChange | The age at which the actuarial reduction factor changes.
arMonthlyFactor67_69 | Monthly actuarial reduction factor between ages 67 and 69.
arMonthlyFactor69Plus | Monthly actuarial reduction factor over age 69.


LawChangeNRACHANGE Members Public Methods

LawChangeNRACHANGE Members Public Methods
LawChangeNRACHANGE Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeNRACHANGE | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years.
writeFirstLine | Writes a line with first and last years.


Legend

Legend
LawChangeOut Members
Legend
Constructor
Data Member
protected


LawChangeOut Members Protected Data Members

LawChangeOut Members Protected Data Members
LawChangeOut Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


LawChangeOut Members Public Data Members

LawChangeOut Members Public Data Members
LawChangeOut Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
lawChange | Law change data.


LawChangeOut Members Public Methods

LawChangeOut Members Public Methods
LawChangeOut Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChangeOut | Initializes data for output.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareStrings | Prepares output strings for changes from present law.
print | Writes the output strings to the specified device.
~LawChangeOut | Releases memory.


LawChangePSAACCT Members Enumerations

LawChangePSAACCT Members Enumerations
LawChangePSAACCT Members Legend
Enumerations
Name | Description
DimLimits | Array sizes.
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangePSAACCT Members
Legend
Constructor
Enumeration


LawChangePSAACCT Members Public Methods

LawChangePSAACCT Members Public Methods
LawChangePSAACCT Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangePSAACCT | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getAdminFee | Returns the administrative fee for the specified investment.
getAnnIntRate | Returns the interst rate for the PSA annuities.
getAnnuityOffset | Returns true if the PSA annuity offsets the regular OASDI benefits, false otherwise.
getAnnuityToDib | Returns true if a person converts his PSA into an annuity upon beginning DI benefits.
getAnnuityType | Returns the type of annuity (0 for always straight life, 1 for joint and 2/3 survivor if married).
getBuysAnnuity | Returns true if the PSA is used to buy an annuity, false if it is just diminished by the amount of the annuity payments as the payments are made.
getContribBps | Returns the percent of the wage base to be used as a bend point for the contribution rate to the PSA.
getContribDist | Returns the type of distribution to use for PSA contributions.
getContribRates | Returns specified PSA contribution rate.
getContribStartAge | Returns the starting age for PSA contributions.
getContribYears | Returns PSA contribution year index.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getInvestMean | Returns mean to be used for the return rate on stocks.
getInvestPerc | Returns proportion of PSA contributions going to specified investment.
getInvestStdDev | Returns standard deviation to be used for the return rate on specified investment.
getLumpSumAtFra | Returns true if the entire PSA is paid as a lump sum to a person who attains FRA and is not eligible for an annuity, false otherwise.
getLumpSumPerc | Returns the percent of the PSA that is paid out as a lump sum upon conversion to annuity.
getMngmtFee | Returns the management fee for the specified investment.
getNumContribBps | Returns the number of bend point in the contribution rate for the PSA's.
getPercToSpouse | Returns percentage of contribution going to spouse, if any.
getPhaseType | Returns indicator for type of phase-in.
getRebalanceAccounts | Returns true if the PSA investment accounts need to be re-balanced each year, false otherwise.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTaxAnnuityInd | Returns the indicator on how PSA annuities are taxed.
getTitle | Returns title of this law change.
getToSpouseOnDeathInd | Returns the indicator regarding the transfer of the PSA to a spouse upon death of the person.
getUnisexInd | Returns the unisex indicator.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setAdminFee | Sets the administrative fee for the specified investment.
setAnnIntRate | Sets the interest rate for the PSA annuities.
setAnnuityOffset | Sets the indicator for offsetting OASDI benefits with the PSA annuity.
setAnnuityToDib | Sets the indicator for whether or not a person starts getting an annuity from his PSA upon beginning DI benefits.
setAnnuityType | Sets the type of annuity (0 for always straight life, 1 for joint and 2/3 survivor if married).
setBuysAnnuity | Sets the indicator for how the PSA is treated when the person starts getting an annuity payment.
setContribBps | Sets the percent of the wage base used a s a bend point for the contribution rate into the PSA's.
setContribDist | Sets the type of distribution to use for PSA contributions.
setContribRates | Sets psa contribution rate.
setContribStartAge | Sets the starting age for PSA contributions.
setContribYears | Sets PSA contribution year index.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setInvestMean | Sets mean to be used for the return of specified investment.
setInvestPerc | Sets proportion of psa contributions going to specified investment.
setInvestStdDev | Sets standard deviation to be used for the return rate on specified investment.
setLumpSumAtFra | Sets the indicator for whether or not a person receives the entire PSA as a lump sum if they attain FRA and are not eligible for an annuity.
setLumpSumPerc | Sets the new percent of the PSA that is paid out as a lump sum upon conversion to annuity.
setMngmtFee | Sets the management fee for the specified investment.
setNumContribBps | Sets the number of bend point in the contribution rate into the PSA's.
setPercToSpouse | Sets percentage of contribution going to spouse, if any.
setPhaseType | Sets indicator for type of phase-in.
setRebalanceAccounts | Sets the rebalanceAccounts indicator.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
setTaxAnnuityInd | Sets the indicator on how PSA annuities are taxed.
setToSpouseOnDeathInd | Sets the indicator regarding the transfer of the PSA to a spouse upon death of the person.
setUnisexInd | Sets unisex indicator.
startCheck | Checks range of a law-change starting year.
write | Writes all the lines required for this law-change.
writeFirstLine | Writes a line with first and last years.


Legend

Legend
LawChangeRead Members
Legend
Constructor


LawChangeRead Members Public Methods

LawChangeRead Members Public Methods
LawChangeRead Members Legend
Public Methods
Name | Description
LawChangeRead | Initializes law-change reference.
read | Reads indicators for change from present law.


LawChangeTAXBENCHG Members Enumerations

LawChangeTAXBENCHG Members Enumerations
LawChangeTAXBENCHG Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeTAXBENCHG Members
Legend
Constructor
virtual
Enumeration


LawChangeTAXBENCHG Members Public Methods

LawChangeTAXBENCHG Members Public Methods
LawChangeTAXBENCHG Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeTAXBENCHG | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years.
writeFirstLine | Writes a line with first and last years.


LawChangeTAXRATECHG Members Enumerations

LawChangeTAXRATECHG Members Enumerations
LawChangeTAXRATECHG Members Legend
Enumerations
Name | Description
DimLimits | Array sizes.
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeTAXRATECHG Members
Legend
Constructor
Enumeration


LawChangeTAXRATECHG Members Public Methods

LawChangeTAXRATECHG Members Public Methods
LawChangeTAXRATECHG Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeTAXRATECHG | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getNumTaxrates | Returns number of tax rates available.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTaxrate | Returns tax rate.
getTitle | Returns title of this law change.
getYearTaxrate | Returns year that changed tax rate is effective.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setNumTaxrates | Sets number of tax rates available.
setPhaseType | Sets indicator for type of phase-in.
setSelfEmpTaxrate | Set self-employed rates equal to twice ee-er rates.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
setTaxrate | Sets tax rate.
setYearTaxrate | Sets year that changed tax rate is effective.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and step size.
writeFirstLine | Writes a line with first and last years.


LawChangeWAGEBASECHG Members Enumerations

LawChangeWAGEBASECHG Members Enumerations
LawChangeWAGEBASECHG Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeWAGEBASECHG Members
Legend
Constructor
Enumeration


LawChangeWAGEBASECHG Members Public Methods

LawChangeWAGEBASECHG Members Public Methods
LawChangeWAGEBASECHG Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeWAGEBASECHG | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getBase77 | Returns ad hoc 1977-law wage base for specified year.
getBaseOasdi | Returns ad hoc OASDI wage base for specified year.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setBase77 | Sets ad hoc 1977-law wage base.
setBaseOasdi | Sets ad hoc OASDI wage base.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years, and percentage.
writeFirstLine | Writes a line with first and last years.


LawChangeWIDFACTOR Members Enumerations

LawChangeWIDFACTOR Members Enumerations
LawChangeWIDFACTOR Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeWIDFACTOR Members
Legend
Constructor
virtual
Data Member
Enumeration


LawChangeWIDFACTOR Members Public Data Members

LawChangeWIDFACTOR Members Public Data Members
LawChangeWIDFACTOR Members Legend
Public Data Members
Name | Description
newAgedWidFactor | The ultimate changed factor for an aged widow(er) benefit (1.125).
numYears | The number of years over which the factor for an aged widow(er) benefit is phased in (40).


LawChangeWIDFACTOR Members Public Methods

LawChangeWIDFACTOR Members Public Methods
LawChangeWIDFACTOR Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeWIDFACTOR | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years.
writeFirstLine | Writes a line with first and last years.


LawChangeWIFEFACTOR Members Enumerations

LawChangeWIFEFACTOR Members Enumerations
LawChangeWIFEFACTOR Members Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChangeWIFEFACTOR Members
Legend
Constructor
virtual
Data Member
Enumeration


LawChangeWIFEFACTOR Members Public Data Members

LawChangeWIFEFACTOR Members Public Data Members
LawChangeWIFEFACTOR Members Legend
Public Data Members
Name | Description
amtPerYear | The annual amount of reduction in the factor for an aged spouse benefit (0.01).
newSpouseFactor | The ultimate changed factor for an aged spouse benefit (0.33).


LawChangeWIFEFACTOR Members Public Methods

LawChangeWIFEFACTOR Members Public Methods
LawChangeWIFEFACTOR Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
LawChange | Initializes a LawChange, with or without a title.
LawChangeWIFEFACTOR | Constructor.
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years.
writeFirstLine | Writes a line with first and last years.


Legend

Legend
LawChangeWrite Members
Legend
Constructor


LawChangeWrite Members Public Methods

LawChangeWrite Members Public Methods
LawChangeWrite Members Legend
Public Methods
Name | Description
LawChangeWrite | Initializes references to data.
write | Writes indicators for change from present law.


Legend

Legend
MilServDates Members
Legend
Constructor
Data Member


MilServDates Members Public Data Members

MilServDates Members Public Data Members
MilServDates Members Legend
Public Data Members
Name | Description
amtPerMonth37_56 | Amount of credit per month for pre-1951 military service wage credits.
amtPerQtr57_77 | Amount of credit per quarter for military service wage credits from 1957 through 1977.
amtPerYear78_01 | Amount of credit per year for military service wage credits from 1978 through 2001.
dec1950 | Last possible date of pre-1951 military service wage credits.
endDate | Ending date of military service.
firstMilServDate | First possible date of military service wage credits.
lastMilServDate | Last possible date of military service wage credits.
startDate | Starting date of military service.


MilServDates Members Public Friends

MilServDates Members Public Friends
MilServDates Members
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


MilServDates Members Public Methods

MilServDates Members Public Methods
MilServDates Members Legend
Public Methods
Name | Description
MilServDates | Creates this record with zero or blank entries.
check | Checks a military service record for consistent dates.
deleteContents | Zeroes out dates of military service.
endDateCheck | Checks an ending date for validity.
getCount1 | Returns this record number.
getCount2 | Returns the number of records in this set.
getDatesString | Returns a string with the two dates, without spaces.
getEarn | Returns wage credits for one year in a one-line record.
getEarn3750 | Returns pre-1951 wage credits in a one-line record.
getQc3750 | Returns pre-1951 quarters of coverage in a one-line record.
getQcov | Returns quarters of coverage for one year in a one-line record.
getType | Returns the type of record.
parseDates | Parses a line of data into two dates.
parseLine | Parses a line of data into a record, including the record number, the total record count, and the record type.
setCount1 | Sets this record number.
setCount2 | Sets the number of records in this set.
setType | Sets the type of record.
startDateCheck | Checks a starting date for validity.
toString | Returns a string with the military service info.
~MilServDates | Destroys this instance.


Legend

Legend
MilServDatesVec Members
Legend
Constructor
Data Member


MilServDatesVec Members Public Data Members

MilServDatesVec Members Public Data Members
MilServDatesVec Members Legend
Public Data Members
Name | Description
MAX_MILSERVDATES | The number of MilServDates records allowed.
msdates | An array of MilServDates records.


MilServDatesVec Members Public Friends

MilServDatesVec Members Public Friends
MilServDatesVec Members
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


MilServDatesVec Members Public Methods

MilServDatesVec Members Public Methods
MilServDatesVec Members Legend
Public Methods
Name | Description
MilServDatesVec | Creates an array with a zero record count.
check | Checks a multiline record.
deleteContents | Zeroes out dates of military service.
getEarn | Returns wage credits for one year in a multiline record.
getEarn3750 | Returns pre-1951 wage credits in a multiline record.
getFirstYear | Returns first year with any military service, 0 if none.
getLastYear | Returns last year with any military service, 0 if none.
getMSCount | Returns the number of records being used.
getQc3750 | Returns pre-1951 quarters of coverage in a multiline record.
getQcov | Returns quarters of coverage for one year in a multiline record.
msCountCheck | Checks the number of military service periods.
setMSCount | Sets the number of military service records.
~MilServDatesVec | Destroys this instance.


OldPia Members Enumerations

OldPia Members Enumerations
OldPia Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
OldPia Members
Legend
Constructor
abstract
virtual
Data Member
protected
Enumeration


OldPia Members Protected Data Members

OldPia Members Protected Data Members
OldPia Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
iamemax | Maximum ame in pia interval.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.


OldPia Members Public Data Members

OldPia Members Public Data Members
OldPia Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.


OldPia Members Public Methods

OldPia Members Public Methods
OldPia Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
OldPia | Initializes this instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Calculates pia and mfb for this method.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Returns true if this method is applicable.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~OldPia | Destructor.


Legend

Legend
OldStart1Page Members
Legend
Constructor
Data Member
protected


OldStart1Page Members Protected Data Members

OldStart1Page Members Protected Data Members
OldStart1Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


OldStart1Page Members Protected Methods

OldStart1Page Members Protected Methods
OldStart1Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


OldStart1Page Members Public Data Members

OldStart1Page Members Public Data Members
OldStart1Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


OldStart1Page Members Public Methods

OldStart1Page Members Public Methods
OldStart1Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
OldStart1Page | Initializes OldStart1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares old start strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~OldStart1Page | Destructor.


Legend

Legend
OldStart2Page Members
Legend
Constructor
Data Member
protected


OldStart2Page Members Protected Data Members

OldStart2Page Members Protected Data Members
OldStart2Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


OldStart2Page Members Protected Methods

OldStart2Page Members Protected Methods
OldStart2Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


OldStart2Page Members Public Data Members

OldStart2Page Members Public Data Members
OldStart2Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


OldStart2Page Members Public Methods

OldStart2Page Members Public Methods
OldStart2Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
OldStart2Page | Initializes OldStart2Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares old start strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~OldStart2Page | Destructor.


OldStart Members Enumerations

OldStart Members Enumerations
OldStart Members Legend
Enumerations
Name | Description
OldStartType | Old-start PIA calculation methods.
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
OldStart Members
Legend
Constructor
virtual
Enumeration
Data Member
protected


OldStart Members Protected Data Members

OldStart Members Protected Data Members
OldStart Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
entDate | The date of entitlement.
iamemax | Maximum ame in pia interval.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.


OldStart Members Public Data Members

OldStart Members Public Data Members
OldStart Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
INC_PER_YEAR | Factor for amount of increment per year (0.01).
bendMfb | Bend points for MFB formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
percMfb | Wage-indexed MFB formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
portionAme | Portion of AME in each interval of PIB formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.


OldStart Members Public Methods

OldStart Members Public Methods
OldStart Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
OldStart | Initializes an OldStart instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Computes old start PIA.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeOs | Returns old-start AME.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getDivisorOs | Returns divisor for old-start pre-1951 earnings.
getIncyrs | Returns number of old-start increment years.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getMethodOs | Returns old-start calculation method number.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getPib | Returns old-start PIB before incrementing.
getPibInc | Returns old-start PIB after incrementing.
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
imputeEarnings | Imputes yearly earnings prior to 1951.
incrementCal | Calculates number of increment years for old-start.
incrementOldCal | Calculates number of increment years for old old-start.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isOs1977_90 | Returns true if the old-start method is 1977 or 1990.
isPebsAssumptions | Returns old Statement assumptions indicator.
methodOsCal | Determines correct old-start method.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
oldStart39Cal | Calculates 1939 old-start PIA and MFB.
oldStart50Cal | Calculates 1950 old-start PIA and MFB.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeOs | Sets old-start AME.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setDivisorOs | Sets divisor for old-start pre-1951 earnings.
setIncyrs | Sets number of old-start increment years.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setMethodOs | Sets old-start calculation method number.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPib | Sets old-start PIB before incrementing.
setPibInc | Sets old-start PIB with increment years.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~OldStart | Destructor.


OldStartLC Members Enumerations

OldStartLC Members Enumerations
OldStartLC Members Legend
Enumerations
Name | Description
OldStartType | Old-start PIA calculation methods.
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
OldStartLC Members
Legend
Constructor
abstract
virtual
Data Member
protected
Enumeration


OldStartLC Members Protected Data Members

OldStartLC Members Protected Data Members
OldStartLC Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
entDate | The date of entitlement.
iamemax | Maximum ame in pia interval.
lawChange | Law change parameters.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.


OldStartLC Members Public Data Members

OldStartLC Members Public Data Members
OldStartLC Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
INC_PER_YEAR | Factor for amount of increment per year (0.01).
bendMfb | Bend points for MFB formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
percMfb | Wage-indexed MFB formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
portionAme | Portion of AME in each interval of PIB formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.


OldStartLC Members Public Methods

OldStartLC Members Public Methods
OldStartLC Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
OldStartLC | Initializes an old start instance with law changes.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Computes old start PIA.
calculate | Calculates pia and mfb for this method.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeOs | Returns old-start AME.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getDivisorOs | Returns divisor for old-start pre-1951 earnings.
getIncyrs | Returns number of old-start increment years.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getMethodOs | Returns old-start calculation method number.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getPib | Returns old-start PIB before incrementing.
getPibInc | Returns old-start PIB after incrementing.
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
imputeEarnings | Imputes yearly earnings prior to 1951.
incrementCal | Calculates number of increment years for old-start.
incrementOldCal | Calculates number of increment years for old old-start.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isApplicable | Determines applicability of method.
isOs1977_90 | Returns true if the old-start method is 1977 or 1990.
isPebsAssumptions | Returns old Statement assumptions indicator.
methodOsCal | Determines correct old-start method.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
oldStart39Cal | Calculates 1939 old-start PIA and MFB.
oldStart50Cal | Calculates 1950 old-start PIA and MFB.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeOs | Sets old-start AME.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setDivisorOs | Sets divisor for old-start pre-1951 earnings.
setIncyrs | Sets number of old-start increment years.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setMethodOs | Sets old-start calculation method number.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPib | Sets old-start PIB before incrementing.
setPibInc | Sets old-start PIB with increment years.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~OldStartLC | Destructor.


Legend

Legend
OnePage Members
Legend
Constructor
Data Member
protected


OnePage Members Protected Data Members

OnePage Members Protected Data Members
OnePage Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


OnePage Members Protected Methods

OnePage Members Protected Methods
OnePage Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


OnePage Members Public Data Members

OnePage Members Public Data Members
OnePage Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


OnePage Members Public Methods

OnePage Members Public Methods
OnePage Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
OnePage | Initializes OnePage.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares strings for 1-page summary.
print | Writes the output strings to the specified device.
printEarn | Prepares table of earnings.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~OnePage | Destructor.


Legend

Legend
Out80 Members
Legend
Constructor
abstract
Data Member
protected


Out80 Members Protected Data Members

Out80 Members Protected Data Members
Out80 Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
PAGE_TITLE_LINES | Number of title lines.
dateModyyr | The current date as month, day, and year.
outstrm | Output stream.
pageNum | Page number.
pathname | Pathname of this file.


Out80 Members Public Methods

Out80 Members Public Methods
Out80 Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
Out80 | Initializes output file core name and extension.
Outfile | Initializes an Outfile, where the parent directory is either specified or default.
advanceLine | Move to next line.
closeout | Closes output file.
errormesg | Returns message when error reading from file.
footer | Does nothing.
formfeed | Move to next page.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPageNum | Returns page number.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
gettitle | Returns one page title line.
header | Does nothing.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
openout | Opens output file.
pgtitle | Writes date, time, 1-line title, and page to 80-column print file.
prepareStrings | Prepares the two-line title strings for output.
printLine | Prints a line of output with a carriage return.
printLinena | Prints a line of output without a carriage return.
readmesg | Returns message when reading from file.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPageNum | Sets page number.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
settitle | Sets one page title line.
writemesg | Returns message when writing to file.


Legend

Legend
Out132 Members
Legend
Constructor
abstract
Data Member
protected


Out132 Members Protected Data Members

Out132 Members Protected Data Members
Out132 Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
PAGE_TITLE_LINES | Number of title lines.
dateModyyr | The current date as month, day, and year.
outstrm | Output stream.
pageNum | Page number.
pathname | Pathname of this file.


Out132 Members Public Methods

Out132 Members Public Methods
Out132 Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
Out132 | Initializes output file core name and extension.
Outfile | Initializes an Outfile, where the parent directory is either specified or default.
advanceLine | Move to next line.
closeout | Closes output file.
errormesg | Returns message when error reading from file.
footer | Does nothing.
formfeed | Move to next page.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPageNum | Returns page number.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
gettitle | Returns one page title line.
header | Does nothing.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
openout | Opens output file.
pgtitle | Writes date, time, 2-line title, and page to 132-column print file.
prepareStrings | Prepares the two-line title strings for output.
printLine | Prints a line of output with a carriage return.
printLinena | Prints a line of output without a carriage return.
readmesg | Returns message when reading from file.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPageNum | Sets page number.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
settitle | Sets one page title line.
writemesg | Returns message when writing to file.


Legend

Legend
OutDC80 Members
Legend
Constructor
abstract
Data Member
protected


OutDC80 Members Protected Data Members

OutDC80 Members Protected Data Members
OutDC80 Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
PAGE_TITLE_LINES | Number of title lines.
dateModyyr | The current date as month, day, and year.
outstrm | Output stream.
pageNum | Page number.
pathname | Pathname of this file.


OutDC80 Members Public Methods

OutDC80 Members Public Methods
OutDC80 Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
OutDC80 | Initializes a new OutDC.
Outfile | Initializes an Outfile, where the parent directory is either specified or default.
advanceLine | Advances one line.
closeout | Closes output file.
errormesg | Returns message when error reading from file.
footer | Does nothing.
footer | Writes a footer to a print file.
formfeed | Dummy function.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPageNum | Returns page number.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
gettitle | Returns one page title line.
header | Does nothing.
header | Writes a heading line to a print file.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
openout | Opens output file.
pgtitle | Writes date, time, 1-line title, and page to 80-column print file.
pgtitle | Writes date, time, title, and page to print file.
prepareStrings | Prepares the two-line title strings for output.
printLine | Prints one line of text with a carriage return.
printLine | Prints a line of output with a carriage return.
printLinena | Prints one line of text without a carriage return.
printLinena | Prints a line of output without a carriage return.
readmesg | Returns message when reading from file.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setDC | Sets device context to use.
setExtension | Sets the extension on the file name.
setHeight | Sets height of one line.
setModifier | Sets the modifier on the file name.
setPageNum | Sets page number.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
settitle | Sets one page title line.
setx | Sets horizontal margin.
sety | Sets vertical margin.
writemesg | Returns message when writing to file.


Legend

Legend
OutFile80 Members
Legend
Constructor
abstract
Data Member
protected


OutFile80 Members Protected Data Members

OutFile80 Members Protected Data Members
OutFile80 Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
PAGE_TITLE_LINES | Number of title lines.
dateModyyr | The current date as month, day, and year.
outstrm | Output stream.
pageNum | Page number.
pathname | Pathname of this file.


OutFile80 Members Public Methods

OutFile80 Members Public Methods
OutFile80 Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
OutFile80 | Initializes an OutFile80.
Outfile | Initializes an Outfile, where the parent directory is either specified or default.
advanceLine | Advances one line.
closeout | Closes output file.
errormesg | Returns message when error reading from file.
footer | Does nothing.
footer | Writes a footer to a print file.
formfeed | Advances to next page.
getColString | Returns left-hand margin string.
getCols | Returns number of columns to space over on left side.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPageNum | Returns page number.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
gettitle | Returns one page title line.
header | Does nothing.
header | Writes a heading line to a print file.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
openout | Opens output file.
pgtitle | Writes date, time, 1-line title, and page to 80-column print file.
pgtitle | Writes date, time, title, and page to print file.
prepareStrings | Prepares the two-line title strings for output.
printLine | Prints a line of output with a carriage return.
printLine | Prints a line of output with a carriage return.
printLinena | Prints a line of output without a carriage return.
printLinena | Prints a line of output without a carriage return.
readmesg | Returns message when reading from file.
setCols | Sets number of columns on left-hand margin.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPageNum | Sets page number.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
settitle | Sets one page title line.
writemesg | Returns message when writing to file.
~OutFile80 | Destructor.


Legend

Legend
OutFile132 Members
Legend
Constructor
abstract
Data Member
protected


OutFile132 Members Protected Data Members

OutFile132 Members Protected Data Members
OutFile132 Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
PAGE_TITLE_LINES | Number of title lines.
dateModyyr | The current date as month, day, and year.
outstrm | Output stream.
pageNum | Page number.
pathname | Pathname of this file.


OutFile132 Members Public Methods

OutFile132 Members Public Methods
OutFile132 Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
OutFile132 | Initializes an OutFile132.
Outfile | Initializes an Outfile, where the parent directory is either specified or default.
advanceLine | Advances one line.
closeout | Closes output file.
errormesg | Returns message when error reading from file.
footer | Does nothing.
footer | Writes a footer to a print file.
formfeed | Advances to next page.
getColString | Returns left-hand margin string.
getCols | Returns number of columns to space over on left side.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPageNum | Returns page number.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
gettitle | Returns one page title line.
header | Does nothing.
header | Writes a heading line to a print file.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
openout | Opens output file.
pgtitle | Writes date, time, 2-line title, and page to 132-column print file.
pgtitle | Writes date, time, title, and page to print file.
prepareStrings | Prepares the two-line title strings for output.
printLine | Prints a line of output with a carriage return.
printLine | Prints a line of output with a carriage return.
printLinena | Prints a line of output without a carriage return.
printLinena | Prints a line of output without a carriage return.
readmesg | Returns message when reading from file.
setCols | Sets number of columns on left-hand margin.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPageNum | Sets page number.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
settitle | Sets one page title line.
writemesg | Returns message when writing to file.
~OutFile132 | Destructor.


Legend

Legend
Outfile Members
Legend
Constructor
abstract
virtual
Data Member
protected


Outfile Members Protected Data Members

Outfile Members Protected Data Members
Outfile Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
PAGE_TITLE_LINES | Number of title lines.
dateModyyr | The current date as month, day, and year.
outstrm | Output stream.
pageNum | Page number.
pathname | Pathname of this file.


Outfile Members Public Methods

Outfile Members Public Methods
Outfile Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
Outfile | Initializes an Outfile, where the parent directory is either specified or default.
advanceLine | Move to next line.
closeout | Closes output file.
errormesg | Returns message when error reading from file.
footer | Writes a footer to a print file.
formfeed | Move to next page.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPageNum | Returns page number.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
gettitle | Returns one page title line.
header | Writes a heading line to a print file.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens output file.
pgtitle | Writes date, time, title, and page to print file.
printLine | Prints a line of output with a carriage return.
printLinena | Prints a line of output without a carriage return.
readmesg | Returns message when reading from file.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPageNum | Sets page number.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
settitle | Sets one page title line.
writemesg | Returns message when writing to file.
~Outfile | Destroys this instance.


Legend

Legend
OutFileHTML Members
Legend
Constructor
Data Member
protected


OutFileHTML Members Protected Data Members

OutFileHTML Members Protected Data Members
OutFileHTML Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
firstPage | Indicator for first page of output.


OutFileHTML Members Public Data Members

OutFileHTML Members Public Data Members
OutFileHTML Members Legend
Public Data Members
Name | Description
PAGE_TITLE_LINES | Number of title lines.
cssPage | The CSS page.
tagRightChar | Represents the closing angle-bracket of an HTML tag.


OutFileHTML Members Public Methods

OutFileHTML Members Public Methods
OutFileHTML Members Legend
Public Methods
Name | Description
OutFileHTML | Constructor.
closeFile | Close the output file.
doHeader | Writes html header information.
gettitle | Returns one page title line.
openFile | Opens output file.
pgtitle | Writes title to html file.
settitle | Sets one page title line.
write | Prints the specified argument without a carriage return.
writeAttribute | Writes an HTML attribute and its value.
writeBeginGrayRow | Writes gray row starting information.
writeBeginTable | Writes the HTML for the start of a table.
writeBeginTag | Writes the opening tag of the specified HTML element.
writeCellBody | Writes the HTML for the contents of one cell in a table, left-justified.
writeCellBodyColSpan | Writes the html for a string as the contents of one cell in a table, left-justified, spanning columns.
writeCellBodyRight | Writes the HTML for the contents of one cell in a table, right-justified.
writeCellHeading | Writes the HTML for the contents of one heading in a table.
writeCellHeadingColSpan | Writes the HTML for the contents of one heading in a table, spanning columns.
writeCellHeadingRowSpan | Writes the html for the contents of one heading in a table, spanning rows.
writeEndTag | Writes the closing tag of the specified HTML element.
writeFullBeginTag | Writes the opening tag of the specified HTML element.
writeLine | Prints one line with a carriage return.
writeYear | Prints year with left justification in html output file.
~OutFileHTML | Destructor.


Legend

Legend
PageCounters Members
Legend
Constructor
Data Member
protected


PageCounters Members Protected Data Members

PageCounters Members Protected Data Members
PageCounters Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
pathname | Pathname of this file.


PageCounters Members Public Data Members

PageCounters Members Public Data Members
PageCounters Members Legend
Public Data Members
Name | Description
PIA_IDS_PAGE1 | Error code.
PIA_IDS_PAGE2 | Error code.
PIA_IDS_PAGE3 | Error code.


PageCounters Members Public Methods

PageCounters Members Public Methods
PageCounters Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
Document | Initializes a Document, either with default values or with specified parent directory and core file name.
Genfile | Initializes a Genfile, either with default values or with a specified parent directory.
PageCounters | Initializes page file name and array size.
deleteContents | Zeroes out page counters.
errormesg | Returns message when error reading from file.
get | Returns page counter for one slot.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPathname | Returns full path name.
getTitle | Returns title of this document.
getmesg | Returns current status or warning message.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
read | Reads page counters from a file named "page".
readmesg | Returns message when reading from file.
set | Sets page counter for one slot.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
setmesg | Sets current status or warning message.
update | Updates all subsequent page counters and writes them out.
write | Writes page counters out to a file named "page".
writemesg | Returns message when writing to file.
~PageCounters | Destructor.


Legend

Legend
PageOut Members
Legend
Constructor
abstract
virtual
Data Member
protected


PageOut Members Protected Data Members

PageOut Members Protected Data Members
PageOut Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


PageOut Members Public Data Members

PageOut Members Public Data Members
PageOut Members Legend
Public Data Members
Name | Description
MAXLINES | The maximum number of lines on a page.


PageOut Members Public Methods

PageOut Members Public Methods
PageOut Members Legend
Public Methods
Name | Description
PageOut | Initializes PageOut.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareStrings | Prepares strings for output.
print | Writes the output strings to the specified device.
~PageOut | Destructor.


Legend

Legend
Path Members
Legend
Data Member
Method


Path Members Public Data Members

Path Members Public Data Members
Path Members Legend
Public Data Members
Name | Description
allSeparators | A string with all the possible separator characters.
altDirectorySeparatorChar | The alternate character used to separate directory levels in a path string (forward slash).
directorySeparatorChar | The character used to separate directory levels in a path string (backward slash).


Path Members Public Methods

Path Members Public Methods
Path Members Legend
Public Methods
Name | Description
changeExtension | Changes the extension of a path string.
combine | Combines two path strings.
getDirectoryName | Returns the directory information for the specified path string.
getFileName | Returns the file name information for the specified path string.
getRelativeName | Returns a relative path to the file for the specified path string. This is designed to provide a relative link to a file from an html page.


Pebs Members Enumerations

Pebs Members Enumerations
Pebs Members Legend
Enumerations
Name | Description
pebes_type | Type of Statement calculation.


Legend

Legend
Pebs Members
Legend
Constructor
Enumeration
Data Member


Pebs Members Public Data Members

Pebs Members Public Data Members
Pebs Members Legend
Public Data Members
Name | Description
age70 | Age 70 and 0 months.
ageNow | Current age.
agePlan1 | Age of planned early retirement, after adjusting for current age and earliest possible age (62).
fullRetAge | Age for worker's full retirement.
oab1 | Age for full retirement calculation (could be between full retirement and 70).
oab2 | Age for late retirement calculation (could be 70 or later).


Pebs Members Public Methods

Pebs Members Public Methods
Pebs Members Legend
Public Methods
Name | Description
Pebs | Initializes Pebs instance.
agePlanCheck | Checks planned age of retirement in Statement case.
deleteContents | Initializes all variables to default values.
getAgePlan | Returns planned age of retirement.
getAgePlan2 | Returns planned retirement age.
getBenefitPebs | Returns benefit actually payable in Statement calculation.
getMfbPebs | Returns maximum family benefit in Statement calculation.
getMonthnow | Returns month of processing.
getPebsDib | Returns number of dib computations to do.
getPebsOab | Returns number of oab computations to do.
getPiaPebs | Returns PIA in Statement calculation.
getQcDisReq | Returns quarters of coverage required for disability insured status for Statement calculation.
getQcDisTotal | Returns quarters of coverage earned for disability insured status for Statement calculation.
getQcDisYears | Returns number of years over which quarters of coverage must be earned for disability insured status for Statement calculation.
getQcReq | Returns required quarters of coverage in Statement calculation.
getQcTotal | Returns quarters of coverage earned through current year.
monthnowCheck | Checks for correct month of Statement processing.
setAgePlan | Sets planned age of retirement in Statement case.
setAgePlan2 | Sets planned retirement age.
setBenefitPebs | Sets benefit actually payable in Statement calculation.
setMfbPebs | Sets maximum family benefit in Statement calculation.
setMonthnow | Sets month of Statement processing.
setPebsDib | Sets number of dib computations to do.
setPebsOab | Sets number of oab computations to do.
setPiaPebs | Sets PIA in Statement calculation.
setQcDisReq | Sets number of DI quarters of coverage required.
setQcDisTotal | Sets number of DI quarters of coverage earned.
setQcDisYears | Sets number of years allowed to earn DI quarters of coverage.
setQcReq | Sets required quarters of coverage in Statement calculation.
setQcTotal | Sets number of quarters of coverage earned through current year.


Legend

Legend
PebsCreditInfo Members
Legend
Constructor
Data Member
protected


PebsCreditInfo Members Protected Data Members

PebsCreditInfo Members Protected Data Members
PebsCreditInfo Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


PebsCreditInfo Members Public Data Members

PebsCreditInfo Members Public Data Members
PebsCreditInfo Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
equals | String of equals signs.
hyphens | String of hyphens.


PebsCreditInfo Members Public Methods

PebsCreditInfo Members Public Methods
PebsCreditInfo Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PebsCreditInfo | Initializes this instance.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareHeader | Prepares header string for output.
prepareStrings | Prepares general credit and tax information for printing.
print | Writes the output strings to the specified device.
setPageNum | Sets page number.
~PebsCreditInfo | Destructor.


Legend

Legend
PebsEarnings Members
Legend
Constructor
Data Member
protected


PebsEarnings Members Protected Data Members

PebsEarnings Members Protected Data Members
PebsEarnings Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


PebsEarnings Members Public Data Members

PebsEarnings Members Public Data Members
PebsEarnings Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
equals | String of equals signs.
hyphens | String of hyphens.


PebsEarnings Members Public Methods

PebsEarnings Members Public Methods
PebsEarnings Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PebsEarnings | Initializes PebsEarnings.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareHeader | Prepares header string for output.
prepareStrings | Prepares page of earnings for printing.
print | Writes the output strings to the specified device.
setPageNum | Sets page number.
~PebsEarnings | Destructor.


Legend

Legend
PebsEarningsInfo Members
Legend
Constructor
Data Member
protected


PebsEarningsInfo Members Protected Data Members

PebsEarningsInfo Members Protected Data Members
PebsEarningsInfo Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


PebsEarningsInfo Members Public Data Members

PebsEarningsInfo Members Public Data Members
PebsEarningsInfo Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
equals | String of equals signs.
hyphens | String of hyphens.


PebsEarningsInfo Members Public Methods

PebsEarningsInfo Members Public Methods
PebsEarningsInfo Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PebsEarningsInfo | Initializes this instance.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareHeader | Prepares header string for output.
prepareStrings | Prepares earnings info for printing.
print | Writes the output strings to the specified device.
setPageNum | Sets page number.
~PebsEarningsInfo | Destructor.


Legend

Legend
PebsLetter Members
Legend
Constructor
Data Member
protected


PebsLetter Members Protected Data Members

PebsLetter Members Protected Data Members
PebsLetter Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


PebsLetter Members Public Data Members

PebsLetter Members Public Data Members
PebsLetter Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
equals | String of equals signs.
hyphens | String of hyphens.


PebsLetter Members Public Methods

PebsLetter Members Public Methods
PebsLetter Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PebsLetter | Initializes this instance.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareHeader | Prepares header string for output.
prepareStrings | Prepares letter for printing.
print | Writes the output strings to the specified device.
setPageNum | Sets page number.
~PebsLetter | Destructor.


Legend

Legend
PebsOasdiEst Members
Legend
Constructor
Data Member
protected


PebsOasdiEst Members Protected Data Members

PebsOasdiEst Members Protected Data Members
PebsOasdiEst Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


PebsOasdiEst Members Public Data Members

PebsOasdiEst Members Public Data Members
PebsOasdiEst Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
equals | String of equals signs.
hyphens | String of hyphens.


PebsOasdiEst Members Public Methods

PebsOasdiEst Members Public Methods
PebsOasdiEst Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PebsOasdiEst | Initializes PebsOasdiEst.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareHeader | Prepares header string for output.
prepareStrings | Prepares OASI estimates for printing.
print | Writes the output strings to the specified device.
setPageNum | Sets page number.
~PebsOasdiEst | Destructor.


Legend

Legend
PebsOasdiInfo Members
Legend
Constructor
Data Member
protected


PebsOasdiInfo Members Protected Data Members

PebsOasdiInfo Members Protected Data Members
PebsOasdiInfo Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


PebsOasdiInfo Members Public Data Members

PebsOasdiInfo Members Public Data Members
PebsOasdiInfo Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
equals | String of equals signs.
hyphens | String of hyphens.


PebsOasdiInfo Members Public Methods

PebsOasdiInfo Members Public Methods
PebsOasdiInfo Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PebsOasdiInfo | Initializes PebsOasdiInfo.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareHeader | Prepares header string for output.
prepareStrings | Prepares oasdi benefit estimate information.
print | Writes the output strings to the specified device.
setPageNum | Sets page number.
~PebsOasdiInfo | Destructor.


Legend

Legend
PebsOut Members
Legend
Constructor
Data Member


PebsOut Members Public Data Members

PebsOut Members Public Data Members
PebsOut Members Legend
Public Data Members
Name | Description
pebsCreditInfo | Credit information.
pebsEarnings | Earnings information.
pebsEarningsInfo | Earnings information.
pebsLetter | Letter transmitting results.
pebsOasdiEst | OASDI estimates.
pebsOasdiInfo | OASDI benefit information.
pebsWorkerEarnings | Worker information and earnings.
pebsWorkerInfo | Worker information.


PebsOut Members Public Methods

PebsOut Members Public Methods
PebsOut Members Legend
Public Methods
Name | Description
PebsOut | Initializes PebsOut instance.
prepareStrings | Prepares strings for printing.
setPageNum | Fills out page numbers.
~PebsOut | Destructor.


Legend

Legend
PebsPageOut Members
Legend
Constructor
abstract
Data Member
protected


PebsPageOut Members Protected Data Members

PebsPageOut Members Protected Data Members
PebsPageOut Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


PebsPageOut Members Public Data Members

PebsPageOut Members Public Data Members
PebsPageOut Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
equals | String of equals signs.
hyphens | String of hyphens.


PebsPageOut Members Public Methods

PebsPageOut Members Public Methods
PebsPageOut Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PebsPageOut | Initializes this instance.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareHeader | Prepares header string for output.
prepareStrings | Prepares strings for output.
print | Writes the output strings to the specified device.
setPageNum | Sets page number.
~PebsPageOut | Destructor.


Legend

Legend
PebsWorkerEarnings Members
Legend
Constructor
Data Member
protected


PebsWorkerEarnings Members Protected Data Members

PebsWorkerEarnings Members Protected Data Members
PebsWorkerEarnings Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


PebsWorkerEarnings Members Public Data Members

PebsWorkerEarnings Members Public Data Members
PebsWorkerEarnings Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


PebsWorkerEarnings Members Public Methods

PebsWorkerEarnings Members Public Methods
PebsWorkerEarnings Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PebsWorkerEarnings | Initializes PebsWorkerEarnings.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareStrings | Prepares top part of summary page.
print | Writes the output strings to the specified device.
~PebsWorkerEarnings | Destructor.


Legend

Legend
PebsWorkerInfo Members
Legend
Constructor
Data Member
protected


PebsWorkerInfo Members Protected Data Members

PebsWorkerInfo Members Protected Data Members
PebsWorkerInfo Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


PebsWorkerInfo Members Public Data Members

PebsWorkerInfo Members Public Data Members
PebsWorkerInfo Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
equals | String of equals signs.
hyphens | String of hyphens.


PebsWorkerInfo Members Public Methods

PebsWorkerInfo Members Public Methods
PebsWorkerInfo Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PebsWorkerInfo | Initializes PebsWorkerInfo.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareHeader | Prepares header string for output.
prepareStrings | Prepares worker information for printing.
print | Writes the output strings to the specified device.
setPageNum | Sets page number.
~PebsWorkerInfo | Destructor.


Legend

Legend
PercMfb Members
Legend
Constructor
Data Member
Operator


PercMfb Members Public Data Members

PercMfb Members Public Data Members
PercMfb Members Legend
Public Data Members
Name | Description
PERC | Four percentages.


PercMfb Members Public Methods

PercMfb Members Public Methods
PercMfb Members Legend
Public Methods
Name | Description
PercMfb | Initializes size of array and all values.
as_array | Returns percentages as a simple array.
begin | This is the overview for the begin method overload.
end | This is the overview for the end method overload.
max_size | Returns maximum number of percentages.
reset | Resets percentages to original values.
size | Returns number of percentages.
~PercMfb | Destroys percentages array.


PercMfb Members Public Nested Types

PercMfb Members Public Nested Types
PercMfb Members
Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of size in this array.
value_type | The type of data in this array.


Legend

Legend
PercPia Members
Legend
Constructor
Data Member
Operator


PercPia Members Public Data Members

PercPia Members Public Data Members
PercPia Members Legend
Public Data Members
Name | Description
PERC | The three percentages for the regular benefit formula.
WINDFALL_PERC | The first percentage under the windfall elimination provision.
WINDFALL_YEARS | Number of years of coverage that negates the windfall elimination provision.


PercPia Members Public Methods

PercPia Members Public Methods
PercPia Members Legend
Public Methods
Name | Description
PercPia | Initializes size of array and all values.
as_array | Returns percentages as a simple array.
begin | This is the overview for the begin method overload.
end | This is the overview for the end method overload.
getNumPerc | Returns the number of percentages.
max_size | Returns maximum number of percentages.
reset | Resets percentages to original 1977 amendments values.
setNumPerc | Sets number of percentages.
setWindfallPerc | Sets first PIA formula percentage for windfall elimination provision.
size | Returns number of percentages.
~PercPia | Destroys percentages array


PercPia Members Public Nested Types

PercPia Members Public Nested Types
PercPia Members
Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of size in this array.
value_type | The type of data in this array.


Legend

Legend
PercPiaOut Members
Legend
Constructor


PercPiaOut Members Public Methods

PercPiaOut Members Public Methods
PercPiaOut Members Legend
Public Methods
Name | Description
PercPiaOut | Initializes a PercPiaOut, with or without a specified first year.
getNumPercs | Returns number of percentages in the PIA formula for a year.
getPercPia | Returns an indexed percentage for specified year.
setData | Sets data for one year.


Legend

Legend
PiaCal Members
Legend
Constructor
virtual
abstract
Data Member


PiaCal Members Public Data Members

PiaCal Members Public Data Members
PiaCal Members Legend
Public Data Members
Name | Description
childCareCalc | Pointer to child care calculation.
dibGuar | Pointer to disability guarantee.
frozMin | Pointer to frozen minimum method.
highPiaMethod | Pointer to method with high pia.
oldStart | Pointer to old-start method.
piaData | Worker's pia calculation data.
piaMethod | Pia calculation methods that apply to all benies in the family.
piaParams | Pia calculation parameters.
piaTable | Pointer to pia table method.
specMin | Pointer to special minimum method.
transGuar | Pointer to transitional guarantee.
wageInd | Pointer to wage-indexed method.
wageIndNonFreeze | Pointer to wage-indexed non-freeze method.
widowMethod | Pia calculation methods that apply only to widow(er)s.
workerData | Worker's personal data.


PiaCal Members Public Methods

PiaCal Members Public Methods
PiaCal Members Legend
Public Methods
Name | Description
PiaCal | Initializes this instance.
ageEntCheck | Checks date of entitlement for a primary benie.
applyLifeMfb | Applies maximum family benefit to family's benefits in a life case.
applyMfb | Applies maximum family benefit to each family benefit, after ratio has been determined.
applySurvivorMfb | Applies maximum family benefit to family's benefits in a survivor case.
ardriAuxCal | Calculates the benefit factor and number of months of early or delayed retirement for a dependent or survivor.
ardriCal | Calculates the number of months of early or delayed retirement for a primary benie.
calculate2 | Calculates PIA and benefit.
dataCheck | Checks primary data for validity and does some preliminary calculations.
dataCheckAux | Checks auxiliary data for validity and does some preliminary calculations.
deadIns | Returns the insured status code for a deceased worker.
deemedInsCal | Checks for deemed insured status, assuming eligible for deemed insured status provision to apply.
didropCal | Calculates number of years to drop out of elapsed period due to disability.
didropNonFreezeCal | Calculates number of years to drop out of elapsed period for fully insured status due to disability in a non-freeze computation.
disInsCal | Calculates the disability insured status code for one year.
disInsNonFreezeCal | Calculates the disability insured status code for non-freeze for one year.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
eligYearCal | Computes year of eligibility.
eligYearCal1 | Computes date of eligibility before considering disability.
eligYearCal2 | Computes year of eligibility after considering disability.
eligYearCal3 | Computes year of eligibility for non-freeze computations.
eligYearWidowCal | Returns eligibility year for widow(er).
fins1Cal | Calculates and returns the insured status code for one date.
fins2Cal | Calculates and returns the OACT insured status code for one date.
finsNonFreeze1Cal | Calculates and returns the insured status code for non-freeze for one date.
finsNonFreeze2Cal | Calculates and returns the OACT insured status code for non-freeze for one date.
fullInsDateCal | Calculates the date fully insured status was first attained (at full retirement age or later).
getIoasdi | Returns type of benefit.
getPubpenEnable | Returns true if ok to enable noncovered pension entry box.
insCal | Calculates the insured status code for one date.
insNonFreezeCal | This is the overview for the insNonFreezeCal method overload.
isPebsAssumptions | Returns Statement assumptions indicator.
monthsArAgedSpouseCal | Calculates full benefit factor and number of months of actuarial reduction for aged wife or husband and sets reduction factor.
monthsArCal | Calculates number of months of actuarial reduction for OAB and sets reduction factor.
monthsArDICal | Calculates number of months of actuarial reduction for DIB and sets reduction factor.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er) and sets reduction factor.
monthsArWidCal | Calculates full benefit factor and number of months of actuarial reduction for aged widow(er) and sets reduction factor.
monthsDriCal | Calculates number of months of delayed retirement credit for OAB and sets increment factor.
monthsYngLifeCal | Calculates number of months of actuarial reduction for young auxiliary and sets benefit factor.
monthsYngSurvCal | Calculates number of months of actuarial reduction for young survivor and sets benefit factor.
nCal | Determine number of computation years and dropout years.
nDropCal | Determine number of dropout years, before considering 1-for-5 dropout.
nDropNonFreezeCal | Determine number of dropout years, before considering 1-for-5 dropout.
nNonFreezeCal | Determine number of computation years and dropout years.
nelapsed2Cal | Returns ending elapsed year for a beneficiary case.
nelapsed2NonFreezeCal | Returns ending elapsed year for a non-freeze case.
nelapsedCal | Determine number of elapsed years.
nelapsedNonFreezeCal | This is the overview for the nelapsedNonFreezeCal method overload.
piaCal | Calculates PIA and MFB, not including re-indexed widow(er).
piaCal1 | Figures high pia and mfb.
piaCal2 | Figures benefit for primary.
piaCal3 | Figures benefits for auxiliaries.
qc3750simpCal | Calculates simplified quarters of coverage, 1937-50.
qcCal | Calculates annual quarters of coverage and insured status.
qcCurrentCal | Calculates quarters of coverage earned for currently insured status.
qcCurrentNonFreezeCal | Calculates quarters of coverage earned for currently insured status for non-freeze.
qcReqCal | Calculates required quarters of coverage for fully insured status at end of year.
qcReqNonFreezeCal | Calculates required quarters of coverage for fully insured status for non-freeze at end of year.
qcReqPermCal | Calculates required quarters of coverage for permanently insured status.
qcReqPermNonFreezeCal | Calculates required quarters of coverage for permanently insured status for non-freeze.
reindWidCal | Calculates PIA for one re-indexed widow(er).
reindWidCalAll | Calculates PIA for all re-indexed widow(er)s.
relEarnPositionCal | Calculates relative earnings position.
releaseMemory | Releases memory.
resetAmend90 | Resets indicator for earnings used after 1991.
setAmend90 | Sets indicator for entitlement after 1990 amendments.
setArfApp | Sets indicator for delayed retirement credit in special minimum case.
setEligYearWidow | Sets eligibility year for widow.
setHighMfb | Sets applicable mfb.
setHighPia | Sets applicable pia.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPifc | Sets applicable pifc.
setSupportPia | Sets support pia, if applicable pia is special minimum and there is delayed retirement credit involved.
widowCheck | Checks disabled widow's date of disability.
~PiaCal | Destructor.


Legend

Legend
PiaCalAny Members
Legend
Constructor
virtual
abstract
Data Member


PiaCalAny Members Public Data Members

PiaCalAny Members Public Data Members
PiaCalAny Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
childCareCalc | Pointer to child care calculation.
dibGuar | Pointer to disability guarantee.
earnProject | Projected earnings.
frozMin | Pointer to frozen minimum method.
highPiaMethod | Pointer to method with high pia.
oldStart | Pointer to old-start method.
piaData | Worker's pia calculation data.
piaMethod | Pia calculation methods that apply to all benies in the family.
piaParams | Pia calculation parameters.
piaTable | Pointer to pia table method.
secondaryArray | Array of Secondary benefits.
specMin | Pointer to special minimum method.
transGuar | Pointer to transitional guarantee.
userAssumptions | User-specified assumptions.
wageInd | Pointer to wage-indexed method.
wageIndNonFreeze | Pointer to wage-indexed non-freeze method.
widowArray | Widow and other family member calculation data.
widowDataArray | Widow and other family member calculation data.
widowMethod | Pia calculation methods that apply only to widow(er)s.
workerData | Worker's personal data.


PiaCalAny Members Public Methods

PiaCalAny Members Public Methods
PiaCalAny Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PiaCalAny | Initializes a PiaCalAny instance.
ageEntCheck | Checks date of entitlement for a primary benie.
applyLifeMfb | Applies maximum family benefit to family's benefits in a life case.
applyMfb | Applies maximum family benefit to each family benefit, after ratio has been determined.
applySurvivorMfb | Applies maximum family benefit to family's benefits in a survivor case.
ardriAuxCal | Calculates the benefit factor and number of months of early or delayed retirement for a dependent or survivor.
ardriCal | Calculates the number of months of early or delayed retirement for a primary benie.
calculate1 | Calculates preparatory variables.
calculate2 | Calculates PIA and benefit.
childCareCreditCal | Sets best child care years to use, using passed arguments rather than member variables.
childCareEarningsCal | Adds childcare credits into regular OASDI earnings, using passed arguments rather than member variables.
childCareMaxCreditCal | Calculates the maximum child care credit.
childCareQcCal | Adjusts QCs for child care credits, using passed arguments rather than member variables.
dataCheck | Checks primary data for validity and does some preliminary calculations.
dataCheckAux | Checks auxiliary data for validity and does some preliminary calculations.
deadIns | Returns the insured status code for a deceased worker.
deemedInsCal | Checks for deemed insured status, assuming eligible for deemed insured status provision to apply.
didropCal | Calculates number of years to drop out of elapsed period due to disability.
didropNonFreezeCal | Calculates number of years to drop out of elapsed period for fully insured status due to disability in a non-freeze computation.
disInsCal | Calculates the disability insured status code for one year.
disInsNonFreezeCal | Calculates the disability insured status code for non-freeze for one year.
earnProSteady | Projects steady earnings.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
earnProjectionStatic | Projects earnings and fills in earnings to be used in calculations, using passed arguments rather than member variables.
eligYearCal | Computes year of eligibility.
eligYearCal1 | Computes date of eligibility before considering disability.
eligYearCal2 | Computes year of eligibility after considering disability.
eligYearCal3 | Computes year of eligibility for non-freeze computations.
eligYearWidowCal | Returns eligibility year for widow(er).
fins1Cal | Calculates and returns the insured status code for one date.
fins2Cal | Calculates and returns the OACT insured status code for one date.
finsNonFreeze1Cal | Calculates and returns the insured status code for non-freeze for one date.
finsNonFreeze2Cal | Calculates and returns the OACT insured status code for non-freeze for one date.
fullInsDateCal | Calculates the date fully insured status was first attained (at full retirement age or later).
getIoasdi | Returns type of benefit.
getPubpenEnable | Returns true if ok to enable noncovered pension entry box.
insCal | Calculates the insured status code for one date.
insNonFreezeCal | This is the overview for the insNonFreezeCal method overload.
isPebsAssumptions | Returns Statement assumptions indicator.
monthsArAgedSpouseCal | Calculates full benefit factor and number of months of actuarial reduction for aged wife or husband and sets reduction factor.
monthsArCal | Calculates number of months of actuarial reduction for OAB and sets reduction factor.
monthsArDICal | Calculates number of months of actuarial reduction for DIB and sets reduction factor.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er) and sets reduction factor.
monthsArWidCal | Calculates full benefit factor and number of months of actuarial reduction for aged widow(er) and sets reduction factor.
monthsDriCal | Calculates number of months of delayed retirement credit for OAB and sets increment factor.
monthsYngLifeCal | Calculates number of months of actuarial reduction for young auxiliary and sets benefit factor.
monthsYngSurvCal | Calculates number of months of actuarial reduction for young survivor and sets benefit factor.
nCal | Determine number of computation years and dropout years.
nCal | Determine number of computation years and dropout years.
nDropCal | Determine number of dropout years, before considering 1-for-5 dropout.
nDropNonFreezeCal | Determine number of dropout years, before considering 1-for-5 dropout.
nNonFreezeCal | Determine number of computation years and dropout years.
nelapsed2Cal | Returns ending elapsed year for a beneficiary case.
nelapsed2Cal | Returns ending elapsed year for a beneficiary case.
nelapsed2NonFreezeCal | Returns ending elapsed year for a non-freeze case.
nelapsed2NonFreezeCal | Returns ending elapsed year for a beneficiary case.
nelapsedCal | Determine number of elapsed years.
nelapsedNonFreezeCal | This is the overview for the nelapsedNonFreezeCal method overload.
pebsOabCal | Calculates number of old-age calculations to do.
pebsSetup | Sets information for Statement case.
piaCal | Calculates PIA and MFB, not including re-indexed widow(er).
piaCal | Calculates PIA and MFB, not including re-indexed widow(er).
piaCal1 | Figures high pia and mfb.
piaCal2 | Figures benefit for primary.
piaCal3 | Figures benefits for auxiliaries.
qc3750simpCal | Calculates simplified quarters of coverage, 1937-50.
qcCal | Calculates annual quarters of coverage and insured status.
qcCurrentCal | Calculates quarters of coverage earned for currently insured status.
qcCurrentNonFreezeCal | Calculates quarters of coverage earned for currently insured status for non-freeze.
qcReqCal | Calculates required quarters of coverage for fully insured status at end of year.
qcReqNonFreezeCal | Calculates required quarters of coverage for fully insured status for non-freeze at end of year.
qcReqPermCal | Calculates required quarters of coverage for permanently insured status.
qcReqPermNonFreezeCal | Calculates required quarters of coverage for permanently insured status for non-freeze.
reindWidCal | Calculates PIA for one re-indexed widow(er).
reindWidCal | Calculates PIA for one re-indexed widow(er).
reindWidCalAll | Calculates PIA for all re-indexed widow(er)s.
relEarnPositionCal | Calculates relative earnings position.
releaseMemory | Releases memory.
resetAmend90 | Resets indicator for earnings used after 1991.
setAmend90 | Sets indicator for entitlement after 1990 amendments.
setArfApp | Sets indicator for delayed retirement credit in special minimum case.
setEligYearWidow | Sets eligibility year for widow.
setHighMfb | Sets applicable mfb.
setHighPia | Sets applicable pia.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPifc | Sets applicable pifc.
setSupportPia | Sets support pia, if applicable pia is special minimum and there is delayed retirement credit involved.
widowCheck | Checks disabled widow's date of disability.
~PiaCalAny | Destructor.


Legend

Legend
PiaCalLC Members
Legend
Constructor
virtual
Data Member


PiaCalLC Members Public Data Members

PiaCalLC Members Public Data Members
PiaCalLC Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
childCareCalc | Pointer to child care calculation.
dibGuar | Pointer to disability guarantee.
frozMin | Pointer to frozen minimum method.
highPiaMethod | Pointer to method with high pia.
oldStart | Pointer to old-start method.
piaData | Worker's pia calculation data.
piaMethod | Pia calculation methods that apply to all benies in the family.
piaParams | Pia calculation parameters.
piaTable | Pointer to pia table method.
specMin | Pointer to special minimum method.
transGuar | Pointer to transitional guarantee.
wageInd | Pointer to wage-indexed method.
wageIndNonFreeze | Pointer to wage-indexed non-freeze method.
widowMethod | Pia calculation methods that apply only to widow(er)s.
workerData | Worker's personal data.


PiaCalLC Members Public Methods

PiaCalLC Members Public Methods
PiaCalLC Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PiaCalLC | Initializes a PiaCalLC instance.
ageEntCheck | Checks date of entitlement for a primary benie.
applyLifeMfb | Applies maximum family benefit to family's benefits in a life case.
applyMfb | Applies maximum family benefit to each family benefit, after ratio has been determined.
applySurvivorMfb | Applies maximum family benefit to family's benefits in a survivor case.
ardriAuxCal | Calculates the benefit factor and number of months of early or delayed retirement for a dependent or survivor.
ardriCal | Calculates the number of months of early or delayed retirement for a primary benie.
calculate2 | Calculates PIA and benefit.
childCareCreditCal | Sets best child care years to use, using passed arguments rather than member variables.
childCareEarningsCal | Adds childcare credits into regular OASDI earnings, using passed arguments rather than member variables.
childCareMaxCreditCal | Calculates the maximum child care credit.
childCareQcCal | Adjusts QCs for child care credits, using passed arguments rather than member variables.
dataCheck | Checks primary data for validity and does some preliminary calculations.
dataCheckAux | Checks auxiliary data for validity and does some preliminary calculations.
deadIns | Returns the insured status code for a deceased worker.
deemedInsCal | Checks for deemed insured status, assuming eligible for deemed insured status provision to apply.
didropCal | Calculates number of years to drop out of elapsed period due to disability.
didropNonFreezeCal | Calculates number of years to drop out of elapsed period for fully insured status due to disability in a non-freeze computation.
disInsCal | Calculates the disability insured status code for one year.
disInsNonFreezeCal | Calculates the disability insured status code for non-freeze for one year.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
earnProjectionStatic | Projects earnings and fills in earnings to be used in calculations, using passed arguments rather than member variables.
eligYearCal | Computes year of eligibility.
eligYearCal1 | Computes date of eligibility before considering disability.
eligYearCal2 | Computes year of eligibility after considering disability.
eligYearCal3 | Computes year of eligibility for non-freeze computations.
eligYearWidowCal | Returns eligibility year for widow(er).
fins1Cal | Calculates and returns the insured status code for one date.
fins2Cal | Calculates and returns the OACT insured status code for one date.
finsNonFreeze1Cal | Calculates and returns the insured status code for non-freeze for one date.
finsNonFreeze2Cal | Calculates and returns the OACT insured status code for non-freeze for one date.
fullInsDateCal | Calculates the date fully insured status was first attained (at full retirement age or later).
getIoasdi | Returns type of benefit.
getPubpenEnable | Returns true if ok to enable noncovered pension entry box.
insCal | Calculates the insured status code for one date.
insNonFreezeCal | This is the overview for the insNonFreezeCal method overload.
isPebsAssumptions | Returns Statement assumptions indicator.
monthsArAgedSpouseCal | Calculates full benefit factor and number of months of actuarial reduction for aged wife or husband and sets reduction factor.
monthsArCal | Calculates number of months of actuarial reduction for OAB and sets reduction factor.
monthsArDICal | Calculates number of months of actuarial reduction for DIB and sets reduction factor.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er) and sets reduction factor.
monthsArWidCal | Calculates full benefit factor and number of months of actuarial reduction for aged widow(er) and sets reduction factor.
monthsDriCal | Calculates number of months of delayed retirement credit for OAB and sets increment factor.
monthsYngLifeCal | Calculates number of months of actuarial reduction for young auxiliary and sets benefit factor.
monthsYngSurvCal | Calculates number of months of actuarial reduction for young survivor and sets benefit factor.
nCal | Determine number of computation years and dropout years.
nDropCal | Determine number of dropout years, before considering 1-for-5 dropout.
nDropNonFreezeCal | Determine number of dropout years, before considering 1-for-5 dropout.
nNonFreezeCal | Determine number of computation years and dropout years.
nelapsed2Cal | Returns ending elapsed year for a beneficiary case.
nelapsed2NonFreezeCal | Returns ending elapsed year for a beneficiary case.
nelapsedCal | Determine number of elapsed years.
nelapsedNonFreezeCal | This is the overview for the nelapsedNonFreezeCal method overload.
piaCal | Calculates PIA and MFB, not including re-indexed widow(er).
piaCal1 | Figures high pia and mfb.
piaCal2 | Figures benefit for primary.
piaCal3 | Figures benefits for auxiliaries.
qc3750simpCal | Calculates simplified quarters of coverage, 1937-50.
qcCal | Calculates annual quarters of coverage and insured status.
qcCurrentCal | Calculates quarters of coverage earned for currently insured status.
qcCurrentNonFreezeCal | Calculates quarters of coverage earned for currently insured status for non-freeze.
qcReqCal | Calculates required quarters of coverage for fully insured status at end of year.
qcReqNonFreezeCal | Calculates required quarters of coverage for fully insured status for non-freeze at end of year.
qcReqPermCal | Calculates required quarters of coverage for permanently insured status.
qcReqPermNonFreezeCal | Calculates required quarters of coverage for permanently insured status for non-freeze.
reindWidCal | Calculates PIA for one re-indexed widow(er).
reindWidCalAll | Calculates PIA for all re-indexed widow(er)s.
relEarnPositionCal | Calculates relative earnings position.
releaseMemory | Releases memory.
resetAmend90 | Resets indicator for earnings used after 1991.
setAmend90 | Sets indicator for entitlement after 1990 amendments.
setArfApp | Sets indicator for delayed retirement credit in special minimum case.
setEligYearWidow | Sets eligibility year for widow.
setHighMfb | Sets applicable mfb.
setHighPia | Sets applicable pia.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPifc | Sets applicable pifc.
setSupportPia | Sets support pia, if applicable pia is special minimum and there is delayed retirement credit involved.
widowCheck | Checks disabled widow's date of disability.
~PiaCalLC | Destructor.


Legend

Legend
PiaCalPL Members
Legend
Constructor
virtual
Data Member


PiaCalPL Members Public Data Members

PiaCalPL Members Public Data Members
PiaCalPL Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
childCareCalc | Pointer to child care calculation.
dibGuar | Pointer to disability guarantee.
frozMin | Pointer to frozen minimum method.
highPiaMethod | Pointer to method with high pia.
oldStart | Pointer to old-start method.
piaData | Worker's pia calculation data.
piaMethod | Pia calculation methods that apply to all benies in the family.
piaParams | Pia calculation parameters.
piaTable | Pointer to pia table method.
specMin | Pointer to special minimum method.
transGuar | Pointer to transitional guarantee.
wageInd | Pointer to wage-indexed method.
wageIndNonFreeze | Pointer to wage-indexed non-freeze method.
widowMethod | Pia calculation methods that apply only to widow(er)s.
workerData | Worker's personal data.


PiaCalPL Members Public Methods

PiaCalPL Members Public Methods
PiaCalPL Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PiaCalPL | Initializes this instance.
ageEntCheck | Checks date of entitlement for a primary benie.
applyLifeMfb | Applies maximum family benefit to family's benefits in a life case.
applyMfb | Applies maximum family benefit to each family benefit, after ratio has been determined.
applySurvivorMfb | Applies maximum family benefit to family's benefits in a survivor case.
ardriAuxCal | Calculates the benefit factor and number of months of early or delayed retirement for a dependent or survivor.
ardriCal | Calculates the number of months of early or delayed retirement for a primary benie.
calculate2 | Calculates PIA and benefit.
dataCheck | Checks primary data for validity and does some preliminary calculations.
dataCheckAux | Checks auxiliary data for validity and does some preliminary calculations.
deadIns | Returns the insured status code for a deceased worker.
deemedInsCal | Checks for deemed insured status, assuming eligible for deemed insured status provision to apply.
didropCal | Calculates number of years to drop out of elapsed period due to disability.
didropNonFreezeCal | Calculates number of years to drop out of elapsed period for fully insured status due to disability in a non-freeze computation.
disInsCal | Calculates the disability insured status code for one year.
disInsNonFreezeCal | Calculates the disability insured status code for non-freeze for one year.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
eligYearCal | Computes year of eligibility.
eligYearCal1 | Computes date of eligibility before considering disability.
eligYearCal2 | Computes year of eligibility after considering disability.
eligYearCal3 | Computes year of eligibility for non-freeze computations.
eligYearWidowCal | Returns eligibility year for widow(er).
fins1Cal | Calculates and returns the insured status code for one date.
fins2Cal | Calculates and returns the OACT insured status code for one date.
finsNonFreeze1Cal | Calculates and returns the insured status code for non-freeze for one date.
finsNonFreeze2Cal | Calculates and returns the OACT insured status code for non-freeze for one date.
fullInsDateCal | Calculates the date fully insured status was first attained (at full retirement age or later).
getIoasdi | Returns type of benefit.
getPubpenEnable | Returns true if ok to enable noncovered pension entry box.
insCal | Calculates the insured status code for one date.
insNonFreezeCal | This is the overview for the insNonFreezeCal method overload.
isPebsAssumptions | Returns Statement assumptions indicator.
monthsArAgedSpouseCal | Calculates full benefit factor and number of months of actuarial reduction for aged wife or husband and sets reduction factor.
monthsArCal | Calculates number of months of actuarial reduction for OAB and sets reduction factor.
monthsArDICal | Calculates number of months of actuarial reduction for DIB and sets reduction factor.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er) and sets reduction factor.
monthsArWidCal | Calculates full benefit factor and number of months of actuarial reduction for aged widow(er) and sets reduction factor.
monthsDriCal | Calculates number of months of delayed retirement credit for OAB and sets increment factor.
monthsYngLifeCal | Calculates number of months of actuarial reduction for young auxiliary and sets benefit factor.
monthsYngSurvCal | Calculates number of months of actuarial reduction for young survivor and sets benefit factor.
nCal | Determine number of computation years and dropout years.
nDropCal | Determine number of dropout years, before considering 1-for-5 dropout.
nDropNonFreezeCal | Determine number of dropout years, before considering 1-for-5 dropout.
nNonFreezeCal | Determine number of computation years and dropout years.
nelapsed2Cal | Returns ending elapsed year for a beneficiary case.
nelapsed2NonFreezeCal | Returns ending elapsed year for a non-freeze case.
nelapsedCal | Determine number of elapsed years.
nelapsedNonFreezeCal | This is the overview for the nelapsedNonFreezeCal method overload.
piaCal | Calculates PIA and MFB, not including re-indexed widow(er).
piaCal1 | Figures high pia and mfb.
piaCal2 | Figures benefit for primary.
piaCal3 | Figures benefits for auxiliaries.
qc3750simpCal | Calculates simplified quarters of coverage, 1937-50.
qcCal | Calculates annual quarters of coverage and insured status.
qcCurrentCal | Calculates quarters of coverage earned for currently insured status.
qcCurrentNonFreezeCal | Calculates quarters of coverage earned for currently insured status for non-freeze.
qcReqCal | Calculates required quarters of coverage for fully insured status at end of year.
qcReqNonFreezeCal | Calculates required quarters of coverage for fully insured status for non-freeze at end of year.
qcReqPermCal | Calculates required quarters of coverage for permanently insured status.
qcReqPermNonFreezeCal | Calculates required quarters of coverage for permanently insured status for non-freeze.
reindWidCal | Calculates PIA for one re-indexed widow(er).
reindWidCalAll | Calculates PIA for all re-indexed widow(er)s.
relEarnPositionCal | Calculates relative earnings position.
releaseMemory | Releases memory.
resetAmend90 | Resets indicator for earnings used after 1991.
setAmend90 | Sets indicator for entitlement after 1990 amendments.
setArfApp | Sets indicator for delayed retirement credit in special minimum case.
setEligYearWidow | Sets eligibility year for widow.
setHighMfb | Sets applicable mfb.
setHighPia | Sets applicable pia.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPifc | Sets applicable pifc.
setSupportPia | Sets support pia, if applicable pia is special minimum and there is delayed retirement credit involved.
widowCheck | Checks disabled widow's date of disability.
~PiaCalPL | Destructor.


PiaData Members Enumerations

PiaData Members Enumerations
PiaData Members Legend
Enumerations
Name | Description
arf_app_type | Special minimum-drc indicator.
earn_total_type | Types of earnings (without or with totalization).


Legend

Legend
PiaData Members
Legend
Constructor
Enumeration
Data Member
Operator


PiaData Members Public Data Members

PiaData Members Public Data Members
PiaData Members Legend
Public Data Members
Name | Description
ageBen | Age at benefit date of worker.
ageEnt | Age at entitlement of worker.
childCareMaxCredit | The maximum amount of credit for each child care year, and the year in which it should be credited.
childCareOrder | Indicators for use of child care credits.
compPeriodNew | Computation period for new-start calculations.
compPeriodNewNonFreeze | Computation period for non-freeze new-start calculations.
compPeriodOld | Computation period for old-start calculation.
disInsCode | Disability insured status code.
disInsNonFreezeCode | Disability insured status code for non-freeze.
earlyRetAge | Earliest possible retirement age.
earnHi | Worker HI earnings, 1937 to maxyear.
earnHiLimited | Worker HI earnings limited to wage base, 1937 to maxyear.
earnMilServ | Military service wage credits, 1951 to date.
earnOasdi | Worker OASDI earnings, 1937 to maxyear, including railroad and military service.
earnOasdiLimited | Worker OASDI earnings limited to wage base, 1937 to maxyear, including railroad and military service.
earnTotalized | Worker OASDI earnings attributed for totalization, 1937 to maxyear.
earnTotalizedLimited | Worker OASDI earnings attributed for totalization, limited to wage base, 1937 to maxyear.
finsCode | Fully insured status code.
finsNonFreezeCode | Fully insured non-freeze status code.
freezeYears | Years wholly within a freeze period.
fullRetAge | Full retirement age.
highMfb | Highest applicable MFB.
highPia | Highest applicable PIA.
partialFreezeYears | Years partially within a freeze period.
qcov | Quarters of coverage, including railroad and military service.
qcovMilServ | Military service quarters of coverage, 1937 to 1956.
relEarnPosition | Annual relative earnings position, 1937 to maxyear.
roundedBenefit | Benefit actually payable, after dollar rounding.
supportPia | Support PIA when highest PIA is special minimum and delayed retirement credits are involved.
unroundedBenefit | Benefit actually payable, before dollar rounding.


PiaData Members Public Methods

PiaData Members Public Methods
PiaData Members Legend
Public Methods
Name | Description
PiaData | Initializes arrays.
deleteContents | Initializes variables to default values.
earn50Cal | Calculates first year of earnings after 1950, with or without totalization.
earnHiCal | Calculates HI earnings by adding OASDI earnings and excess HI earnings.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
earnTotal50Cal0 | Calculates sum of regular pre-1951 earnings.
earnTotal50Cal1 | Calculates sum of pre-1951 totalization earnings.
earnYearCal | Determines last year of allowable earnings.
freezeYearsCal | Determines freeze period.
getAmend90 | Returns indicator for entitlement after 1990 amendments.
getArf | Returns actuarial reduction factor or delayed retirement credit.
getArfApp | Returns special minimum-delayed retirement credit indicator.
getBirthDateMinus1 | Returns day before worker's birth.
getChildCareMaxCredit | Returns maximum child care credit amount for a specified year.
getChildCareYearsTotal | Returns total number of child care years.
getDeemedQcReq | Returns number of quarters required for deemed fully insured status.
getEarn3750ms | Returns military service earnings, 1937-50.
getEarn50 | Returns first year of earnings after 1950.
getEarnTotal50 | Returns total earnings prior to 1951.
getEarnYear | Returns last year of earnings considered.
getEligDate | Returns worker's month and year of eligibility before considering prior disability onset.
getEligYear | Returns worker's year of eligibility after considering prior disability onset.
getEligYearNonFreeze | Returns worker's year of eligibility for non-freeze computations.
getFinsCode2 | Returns fully insured code as used in oact printouts.
getFinsNonFreezeCode2 | Returns fully insured non-freeze code as used in oact printouts.
getFirstQcYear | Returns first year with a quarter of coverage; 1937 if any QC's before 1951, 1936 if no QC's.
getFullInsDate | Returns date fully insured status is attained.
getFullRetDate | Returns date full retirement age is attained.
getIappn | Returns number of applicable pia calculation method.
getIapps | Returns support PIA method number.
getIbeginAll | Returns first year of earnings after considering railroad and military service.
getIbeginTotal | Returns first year of attributed earnings in totalization case.
getIendAll | Returns last year of earnings after considering railroad and military service.
getIendTotal | Returns last year of attributed earnings in totalization case.
getLastQcYear | Returns last year with a quarter of coverage, but at least 1950.
getMonthsArdri | Returns number of months of increment or reduction.
getOverMax | Returns indicator for earnings over maximum.
getPifc | Returns code for type of pia.
getPubpenApp | Returns applicable noncovered pension.
getQc3750ms | Returns military service quarters of coverage, 1937-50.
getQc3750simp | Returns simplified quarters of coverage, 1937-50.
getQcCurrent | Returns number of quarters earned in prior 3 years.
getQcCurrentNonFreeze | Returns number of quarters earned in prior 3 years for non-freeze.
getQcDisDate1 | Returns beginning quarter and year of period of required quarters of coverage for disability insured status.
getQcDisDate2 | Returns ending quarter and year of period of required quarters of coverage for disability insured status.
getQcDisDate3 | Returns beginning quarter and year of period of required quarters of coverage for disability insured status, for period after disability cessation.
getQcDisDate4 | Returns ending quarter and year of period of required quarters of coverage for disability insured status, for period after disability cessation.
getQcDisDate5 | Returns beginning quarter and year of period of required quarters of coverage for disability insured status, for period before prior disability.
getQcDisDate6 | Returns ending quarter and year of period of required quarters of coverage for disability insured status, for period before prior disability.
getQcDisDateNonFreeze1 | Returns beginning quarter and year of period of required quarters of coverage for disability insured status for non-freeze.
getQcDisDateNonFreeze2 | Returns ending quarter and year of period of required quarters of coverage for disability insured status for non-freeze.
getQcDisQtr | Returns number of quarters over which quarters of coverage must be earned for disability insured status.
getQcDisQtr2 | Returns number of quarters over which quarters of coverage must be earned for disability insured status, based on elapsed quarters after disability cessation.
getQcDisQtrNonFreeze | Returns number of quarters over which quarters of coverage must be earned for disability insured status for non-freeze.
getQcDisReq | Returns number of quarters required for disability insured status.
getQcDisReqNonFreeze | Returns number of quarters required for disability insured status for non-freeze.
getQcDisYears | Returns number of years over which quarters of coverage must be earned for disability insured status.
getQcDisYearsNonFreeze | Returns number of years over which quarters of coverage must be earned for disability insured status for non-freeze.
getQcReq | Returns number of quarters required for fully insured status.
getQcReqNonFreeze | Returns number of quarters required for fully insured non-freeze status.
getQcReqPerm | Returns number of quarters required for permanently insured status.
getQcReqPermNonFreeze | Returns number of quarters required for permanently insured non-freeze status.
getQcTotal | Returns total number of quarters earned for fully insured status.
getQcTotal50 | Returns total number of quarters earned from 1937 to 1950.
getQcTotal51 | Returns total number of quarters earned after 1950.
getQcTotal51NonFreeze | Returns total number of quarters earned after 1950 for non-freeze.
getQcTotalDis | Returns total number of quarters earned for disability insured status.
getQcTotalDisNonFreeze | Returns total number of quarters earned for disability insured status for non-freeze.
getQcTotalNonFreeze | Returns total number of quarters earned for fully insured non-freeze status.
getQcTotalRel | Returns total number of quarters earned for totalization benefit computation.
getRelEarnPositionAverage | Returns average relative earnings position.
initialize | Initializes computed values to zero.
qcCal | Calculates annual quarters of coverage.
qcDiSpec | Sets first quarter and year of disability insured period for special insured status (called only if calculated first quarter and year are in quarter of age 21 or earlier).
qcDiSpecNonFreeze | Sets first quarter and year of disability insured period for special insured status (called only if calculated first quarter and year are in quarter of age 21 or earlier).
qcDisCal | Calculates earned quarters of coverage in disability insured period.
qcDisNonFreezeCal | Calculates earned quarters of coverage in disability insured period for non-freeze.
qcDisReq2Cal | Determines number of required quarters of coverage for DI insured status, based on elapsed quarters after disability cessation.
qcDisReqCal | Determines number of required quarters of coverage for DI insured status.
qcDisReqNonFreezeCal | Determines number of required quarters of coverage for DI insured status for non-freeze.
qcTotalCal | Calculates total quarters of coverage. Assumes annual quarters of coverage are already known, either from 1951 or from 1978.
qcTotalNonFreezeCal | Calculates total quarters of coverage for non-freeze. Assumes annual quarters of coverage are already known, either from 1951 or from 1978, and that qcs prior to 1951 have already been computed as well by PiaData::qcTotalCal.
setAmend90 | Sets indicator for entitlement after 1990 amendments.
setArf | Sets actuarial reduction factor or delayed retirement credit.
setArfApp | Sets special minimum-delayed retirement credit indicator.
setBirthDateMinus1 | Sets day before worker's birth.
setChildCareYearsTotal | Sets total number of child care years.
setDeemedQcReq | Sets number of quarters of coverage required for deemed insured status.
setDoEarlyQcs | Sets indicator for calculation of quarters of coverage for early years.
setEarn3750ms | Sets military service earnings, 1937-50.
setEligDate | Sets month and year of eligibility before considering disability.
setEligYear | Sets eligibility year after considering prior disability onset.
setEligYearNonFreeze | Sets eligibility year for non-freeze computations.
setFinsCode2 | Sets fully insured status code as used in oact printouts.
setFinsNonFreezeCode2 | Sets fully insured non-freeze status code as used in oact printouts.
setFullInsDate | Sets date fully insured status is attained.
setFullRetDate | Sets date of attainment of normal retirement age, but no earlier than January 1937.
setIappn | Sets number of applicable pia calculation method.
setIapps | Sets support pia method number.
setIbeginTotal | Sets first year of attributed earnings in totalization case.
setIendTotal | Sets last year of attributed earnings in totalization case.
setMonthsArdri | Sets number of months of increment or reduction.
setOverMax | Sets indicator for earnings over maximum.
setPifc | Sets code for type of pia.
setQc3 | Sets some quarter of coverage amounts.
setQc3750ms | Sets military service quarters of coverage, 1937-50.
setQc3750simp | Sets simplified quarters of coverage, 1937-50.
setQcCurrent | Sets quarters of coverage earned in prior 3 years.
setQcCurrentNonFreeze | Sets quarters of coverage earned in prior 3 years for non-freeze.
setQcReq | Sets number of quarters required for fully insured status.
setQcReqNonFreeze | Sets number of quarters required for fully insured non-freeze status.
setQcReqPerm | Sets number of quarters required for permanently insured status.
setQcReqPermNonFreeze | Sets number of quarters required for permanently insured non-freeze status.
setQcTotal | Sets total quarters of coverage.
setQcTotal50 | Sets quarters of coverage prior to 1951.
setQcTotalNonFreeze | Sets total quarters of coverage for non-freeze.
setQcTotalRel | Sets total quarters of coverage earned for a totalization benefit computation.
setRelEarnPositionAverage | Sets average relative earnings position.
updateMilServ | Updates military service earnings and quarters of coverage.
~PiaData | Destroys arrays.


PiaDataArray Members Enumerations

PiaDataArray Members Enumerations
PiaDataArray Members Legend
Enumerations
Name | Description
DimLimits | Constant for dimensioning.


Legend

Legend
PiaDataArray Members
Legend
Constructor
Enumeration
Data Member


PiaDataArray Members Public Data Members

PiaDataArray Members Public Data Members
PiaDataArray Members Legend
Public Data Members
Name | Description
piaData | Array of worker's pia data.


PiaDataArray Members Public Methods

PiaDataArray Members Public Methods
PiaDataArray Members Legend
Public Methods
Name | Description
PiaDataArray | Initializes arrays used in PiadataArray.
deleteContents | Resets all values to zero.
famSizeCheck | Checks if family size is ok.
getFamSize | Returns family size (not including worker).
setFamSize | Sets family size (not including worker).
~PiaDataArray | Releases memory.


Legend

Legend
PiaException Members
Legend
Constructor


PiaException Members Public Methods

PiaException Members Public Methods
PiaException Members Legend
Public Methods
Name | Description
PiaException | Initializes a PiaException, either from an integer, string, or another PiaException.
getNumber | Returns number of this exception.
what | Returns string with message about this error.
~PiaException | Destructor.


PiaMethod Members Enumerations

PiaMethod Members Enumerations
PiaMethod Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
PiaMethod Members
Legend
Constructor
abstract
virtual
Enumeration
Data Member
protected


PiaMethod Members Protected Data Members

PiaMethod Members Protected Data Members
PiaMethod Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.


PiaMethod Members Public Data Members

PiaMethod Members Public Data Members
PiaMethod Members Legend
Public Data Members
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.


PiaMethod Members Public Methods

PiaMethod Members Public Methods
PiaMethod Members Legend
Public Methods
Name | Description
PiaMethod | Initializes this instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Calculates pia and mfb for this method.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Returns true if this method is applicable.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~PiaMethod | Destructor.


Legend

Legend
PiaOut Members
Legend
Constructor
Data Member


PiaOut Members Public Data Members

PiaOut Members Public Data Members
PiaOut Members Legend
Public Data Members
Name | Description
MAX_REINDWID | Maximum number of re-indexed widow(er)s.
childCareCalc1Page | Wage-indexed earnings with child-care dropout years.
childCareCalc2Page | Wage-indexed calculation with child-care dropout years.
dibGuarPage | Disability guarantee calculation.
earningsPage | Earnings used in calculation.
familyPage | Family members calculation.
frozMinPage | Frozen minimum calculation.
insuredPage | Insured status calculation.
oldStart1Page | Old-start earnings.
oldStart2Page | Old-start calculation.
onePage | One-page output.
piaTable1Page | Pia table earnings.
piaTable2Page | Pia table calculation.
reindWid1Page | Re-indexed widow guarantee earnings.
reindWid2Page | Re-indexed widow guarantee calculation.
specMin1Page | Special minimum earnings.
specMin2Page | Special minimum calculation.
summary1Page | Top part of summary page.
summary2Page | Middle part of summary page.
summary3Page | Bottom part of summary page.
summaryPage | Summary page of results.
taxesPage | Taxes calculation.
transGuar1Page | Transitional guarantee earnings.
transGuar2Page | Transitional guarantee calculation.
wageInd1Page | Wage-indexed earnings.
wageInd2Page | Wage-indexed calculation.
wageIndNonFreeze1Page | Wage-indexed earnings.
wageIndNonFreeze2Page | Wage-indexed calculation.


PiaOut Members Public Methods

PiaOut Members Public Methods
PiaOut Members Legend
Public Methods
Name | Description
PiaOut | Initializes PiaOut.
prepareStrings | Prepares strings for printing.
setPageNum | Fills out page numbers.
~PiaOut | Destructor.


Legend

Legend
PiaPageOut Members
Legend
Constructor
abstract
virtual
Data Member
protected


PiaPageOut Members Protected Data Members

PiaPageOut Members Protected Data Members
PiaPageOut Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


PiaPageOut Members Protected Methods

PiaPageOut Members Protected Methods
PiaPageOut Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


PiaPageOut Members Public Data Members

PiaPageOut Members Public Data Members
PiaPageOut Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


PiaPageOut Members Public Methods

PiaPageOut Members Public Methods
PiaPageOut Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PiaPageOut | Initializes PiaPageOut.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares strings for output.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~PiaPageOut | Destructor.


PiaParams Members Enumerations

PiaParams Members Enumerations
PiaParams Members Legend
Enumerations
Name | Description
SPECMINPERCTYPE | The year range for the special minimum percentage.


Legend

Legend
PiaParams Members
Legend
Constructor
virtual
abstract
Enumeration
Data Member
protected


PiaParams Members Protected Data Members

PiaParams Members Protected Data Members
PiaParams Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
baseHi | HI wage bases.
bendOS | Bend points for old-start PIB formula.
catchup | Catch-up benefit increases.
cpiinc | Array of benefit increases.
fq | Array of annual average earnings.
fqinc | Array of percentage increases in annual average earnings.
istart | Current year (year after last known benefit increase).
maxyear | Maximum year allowed.
monthBeninc | Array of month of benefit increase.
noChange | Array of indicators for no change allowed.
percOS | Old-start PIB formula percentages.
percSpecMin | Percentage of old-law wage base required for year of coverage.
recalcInd | Indicator for which year(s) the PIA should be recalculated due to a newly effective law change.
specMinMfb | Special minimum mfbs.
specMinMfb2001 | Special minimum mfbs for August-November 2001.
specMinPerc | Percentage of old-law wage base required for year of coverage for special minimum.
specMinPia | Special minimum pias.
specMinPia2001 | Special minimum pias for August-November 2001.
titleAw | Title of average wage assumptions.
titleBi | Title of benefit increase assumptions.
yocAmountSpecMin | Amount required for year of coverage for special minimum.
yocAmountWindfall | Amount required for year of coverage for windfall elimination provision.


PiaParams Members Public Data Members

PiaParams Members Public Data Members
PiaParams Members Legend
Public Data Members
Name | Description
YEAR1999 | Year of extra 0.1 percent benefit increase.
age16 | Age 16.
age18 | Age 18.
age19 | Age 19.
age199 | Age 199 (impossible age).
age22 | Age 22.
age50 | Age 50.
age60 | Age 60.
age62 | Age 62.
age621 | Age 62 and 1 month.
age65 | Age 65.
age65_10 | Age 65 and 10 months.
age65_2 | Age 65 and 2 months.
age65_4 | Age 65 and 4 months.
age65_6 | Age 65 and 6 months.
age65_8 | Age 65 and 8 months.
age66 | Age 66.
age66_10 | Age 66 and 10 months.
age66_2 | Age 66 and 2 months.
age66_4 | Age 66 and 4 months.
age66_6 | Age 66 and 6 months.
age66_8 | Age 66 and 8 months.
age67 | Age 67.
age70 | Age 70.
age72 | Age 72.
age75 | Age 75.
amend01 | The date of special 0.1 percent benefit increase.
amend118_273 | The date of WEP no longer being used for benefit computations.
amend50 | The date of 1950 amendments.
amend52 | The date of 1952 amendments.
amend54 | The date of 1954 amendments.
amend56 | The date of 1956 amendments.
amend561 | First birth date for which age 62 is effective for females.
amend562 | Second birth date for which age 62 is effective for females.
amend58 | The date of 1958 amendments.
amend61 | The date of 1961 amendments.
amend611 | First birth date for which age 62 is effective for males.
amend612 | Second birth date for which age 62 is effective for males.
amend651 | The date of 1965 amendments for benefit increase.
amend652 | The date of 1965 amendments for change to age 60.
amend653 | The date of 1965 amendments for old start.
amend671 | The date of 1967 amendments for old start.
amend672 | The date of 1967 amendments for benefit increase.
amend69 | The date of 1969 amendments.
amend70 | The date of 1970 amendments.
amend721 | The date of 1972 amendments for benefit increase.
amend722 | The date of 1972 amendments for special minimum.
amend741 | The date of 1974 amendments for partial increase.
amend742 | The date of 1974 amendments for full increase.
amend771 | The date of 1977 amendments for frozen pia table.
amend772 | The date of 1977 amendments for start of wage indexing.
amend80 | The date of 1980 amendments.
amend811 | The date of birth for age 62 and 1 month in 1981 amendments.
amend812 | The date of 1981 amendments (month, day, and year).
amend813 | The date of 1981 amendments (month and year).
amend82 | The date of 1982 amendments.
amend83 | The date of 1983 amendments.
amend88 | The date of 1988 amendments.
amend90 | The date of 1990 amendments.
amtperincyr | Amount per old start increment year.
arFactorWid285 | Total actuarial reduction factor for aged widow(er)s.
arMonthlyFactor65_67 | Monthly actuarial reduction factor between ages 65 and 67.
arMonthlyFactorOab62_65 | Monthly actuarial reduction factor between ages 62 and 65.
arMonthlyFactorSpouse62_65 | Monthly actuarial reduction factor for aged spouses between ages 62 and 65.
beninc74 | Temporary benefit increase, March-May 1974.
bpMfbOut | Table of mfb formula bend points.
bpPiaOut | Table of pia formula bend points.
factor150 | Factor for calculating mfbs.
factor175 | Factor for calculating mfbs.
factor50 | Factor for calculating life benefits.
factor75 | Factor for calculating survivor benefits.
factor825 | Factor for calculating widow(er) benefits.
maxMonthsAr62_65 | Maximum number of months of actuarial reduction between ages 62 and 65.
maxMonthsAr62_67 | Maximum number of months of actuarial reduction between ages 62 and 67.
maxMonthsAr65_67 | Maximum number of months of actuarial reduction between ages 65 and 67.
percPiaOut | Table of pia formula percentages.
qcamt | Array of amounts required for quarter of coverage.
qtr184 | Starting point of deemed insured.
year37qtr1 | First quarter for which a quarter of coverage could be earned.


PiaParams Members Public Methods

PiaParams Members Public Methods
PiaParams Members Legend
Public Methods
Name | Description
PiaParams | Initializes a PiaParams, with or without a first year of projection.
applyCola | Returns benefit amount increased by cola.
applyCola99 | Returns benefit amount increased by special 1999 cola (includes extra 0.1 percent increase).
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb99 | Returns maximum family benefit amount increased by special 1999 cola (includes extra 0.1 percent increase), with check that result is at least 150 percent of pia.
benincCatchUp | Applies catch-up benefit increases.
birthDateFRA | Returns the earliest birthdate for someone to be over NRA at the end of a year.
childAgeForMFCal | Returns oldest age of child for which parent can get young wife/husband or mother/father benefits.
deconvertPia | Deconverts PIA back to year of eligibility.
deemedQcReqCal | Returns number of quarters of coverage required for deemed insured status.
doRecalc | Returns true if should recalculate PIAs this year because of a newly effective law change, else false.
earlyAgeDisWidCal | Returns earliest possible disabled widow(er)'s retirement age.
earlyAgeOabCal | Returns earliest possible retirement age for oab or aged spouse.
earlyAgeOabCalPL | Returns earliest possible retirement age for old-age benie or aged spouse, based on present law.
earlyAgeWidCal | Returns earliest possible aged widow(er)'s retirement age.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCalPL | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow(er) benefit before age reduction.
factorAgedWidCalPL | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Returns reduction factor for wife/husband.
factorArAgedSpouseCalPL | Calculates reduction factor for wife/husband. Assumes a maximum of 60 months of reduction.
factorArCal | Returns reduction factor for OAB.
factorArCalPL | Calculates reduction factor for OAB or DIB.
factorArDisWidCal | Calculates reduction factor for disabled widow(er).
factorArWidCal | Calculates reduction factor for aged widow(er).
factorDisWidCal | Returns factor for disabled widow(er) benefit before age reduction.
factorDisWidCalPL | Returns factor for disabled widow/widower benefit before age reduction.
factorDriCal | Calculates delayed retirement increment factor for OAB.
factorYngLifeCal | Calculates reduction factor for young life benie.
factorYngSurvCal | Calculates reduction factor for young survivor.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDIPL | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalPL | Returns full retirement age based on present law.
getAverageWage | Returns title of average wage assumptions.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBaseHi | Returns one HI wage base.
getBaseHiArray | Returns the array of HI wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBendOS | Returns a bend point for old-start PIB formula.
getBenefitInc | Returns title of benefit increase assumptions.
getCatchup | Returns catch-up benefit increases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmountPL | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getCpiinc | Returns one benefit increase.
getCpiincArray | Returns the array of benefit increases.
getFq | Returns one average wage for indexing.
getFqArray | Returns array of average wages for indexing.
getFqBppia | Returns series used for indexing pia formula bend points.
getFqIndex | Returns series used for indexing an earnings record.
getFqinc | Returns one increase in average wage for indexing.
getFqincArray | Returns array of increases in average wage for indexing.
getIstart | Returns current year.
getMarrLengthForDivBen | Returns the number of years of marraige needed to be eligible for a divroced spouse benefit.
getMarrLengthForDivBenPL | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year.
getMaxChildcareAgePL | Returns maximum age of child for childcare dropout year.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYearsPL | Returns maximum number of childcare dropout years.
getMaxyear | Returns maximum possible year.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB.
getMonthBeninc | Returns one month of benefit increase.
getMonthBenincArray | Returns array of months of benefit increase.
getPercOS | Returns old-start PIB formula percentage.
getPercSpecMin | Returns percent of old-law base required for year of coverage.
getPercSpecMinArray | Returns array of percents of old-law base required for year of coverage.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinPerc | Returns percentage of old-law base required for year of coverage.
getSpecMinPia | Returns special minimum pia as of a specified month.
getYocAmountSpecMin | Returns amount required for year of coverage for special minimum.
getYocAmountSpecMinArray | Returns array of amounts required for year of coverage for special minimum.
getYocAmountWindfallArray | Returns array of amounts required for year of coverage for windfall elimination.
initdata | Initializes some data.
isApplicableCola99 | Checks for applicability of special 1999 increase (with extra 0.1 percent).
lastAmw | Finds last AMW in old-law table.
lumpSum | Returns amount of lump sum benefit.
maxChildAge | Returns maximum child beneficiary age.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAgePL | Returns maximum DI beneficiary age at end of year, based on present law.
monthsArAgedSpouseCal | Calculates number of months of actuarial reduction for aged wife/husband.
monthsArCal | Calculates number of months of actuarial reduction for OAB.
monthsArDICal | Calculates number of months of reduction for disabled worker.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er).
monthsArWidCal | Calculates number of months of actuarial reduction for aged widow(er).
monthsDriCal | Calculates number of months of delayed retirement credit for OAB.
needColaCap | Returns true if a cola cap is required.
percPiaCal | Sets benefit formula percents.
projectCpiinc | Projects amounts dependent on benefit increases.
projectFq | Projects amounts dependent on the average annual wage.
projectPerc | Projects benefit formula percentages.
projectSpecMin | Projects special minimum amounts.
qcCal | Returns number of quarters of coverage for one year, applying annual test.
resizeSpecMin | Resizes special minimum arrays.
retCredit | Returns amount of monthly delayed retirement credit.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCalPL | Returns widow(er) benefit reduced for RIB-LIM.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setData | Sets data from historical average wages and benefit increase file.
setHistFqinc | Sets historical average wage increases.
setIstart | Sets the first projected year, including for members.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
setNoChange | Sets indicators for no change allowed.
specMinAmountCal | Sets amount per year of coverage in special minimum.
specMinAmountCalPL | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYearsPL | Returns maximum number of usable years for special minimum.
unApplyCola | Returns benefit amount decreased by cola.
unApplyCola99 | Returns benefit amount decreased by special 1999 cola (includes extra 0.1 percent decrease.)
unbiCatchUp | Divides out catch-up benefit increases.
updateBases | Updates wage bases.
updateCpiinc | Updates benefit increases.
updateFq | Updates average wages, using specified amounts.
updateFqinc | Updates increases in average wages, using specified percentages.
updateYocAmountSpecMin | Updates amounts required for special minimum year of coverage.
~PiaParams | Destroys arrays.


PiaParamsAny Members Enumerations

PiaParamsAny Members Enumerations
PiaParamsAny Members Legend
Enumerations
Name | Description
SPECMINPERCTYPE | The year range for the special minimum percentage.


Legend

Legend
PiaParamsAny Members
Legend
Constructor
virtual
abstract
protected
Enumeration
Data Member


PiaParamsAny Members Protected Data Members

PiaParamsAny Members Protected Data Members
PiaParamsAny Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
baseHi | HI wage bases.
bendOS | Bend points for old-start PIB formula.
catchup | Catch-up benefit increases.
cpiinc | Array of benefit increases.
fq | Array of annual average earnings.
fqinc | Array of percentage increases in annual average earnings.
istart | Current year (year after last known benefit increase).
maxyear | Maximum year allowed.
monthBeninc | Array of month of benefit increase.
noChange | Array of indicators for no change allowed.
percOS | Old-start PIB formula percentages.
percSpecMin | Percentage of old-law wage base required for year of coverage.
recalcInd | Indicator for which year(s) the PIA should be recalculated due to a newly effective law change.
specMinMfb | Special minimum mfbs.
specMinMfb2001 | Special minimum mfbs for August-November 2001.
specMinPerc | Percentage of old-law wage base required for year of coverage for special minimum.
specMinPia | Special minimum pias.
specMinPia2001 | Special minimum pias for August-November 2001.
titleAw | Title of average wage assumptions.
titleBi | Title of benefit increase assumptions.
yocAmountSpecMin | Amount required for year of coverage for special minimum.
yocAmountWindfall | Amount required for year of coverage for windfall elimination provision.


PiaParamsAny Members Protected Methods

PiaParamsAny Members Protected Methods
PiaParamsAny Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
setAltCpiinc | Sets benefit increases when changed from present law.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setFqBppia | Sets series of average wages or other series used for indexing pia formula bend points.
setFqIndex | Calculate series of average wages or other series used for indexing an earnings record.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.


PiaParamsAny Members Public Data Members

PiaParamsAny Members Public Data Members
PiaParamsAny Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
YEAR1999 | Year of extra 0.1 percent benefit increase.
age16 | Age 16.
age18 | Age 18.
age19 | Age 19.
age199 | Age 199 (impossible age).
age22 | Age 22.
age50 | Age 50.
age60 | Age 60.
age62 | Age 62.
age621 | Age 62 and 1 month.
age65 | Age 65.
age65_10 | Age 65 and 10 months.
age65_2 | Age 65 and 2 months.
age65_4 | Age 65 and 4 months.
age65_6 | Age 65 and 6 months.
age65_8 | Age 65 and 8 months.
age66 | Age 66.
age66_10 | Age 66 and 10 months.
age66_2 | Age 66 and 2 months.
age66_4 | Age 66 and 4 months.
age66_6 | Age 66 and 6 months.
age66_8 | Age 66 and 8 months.
age67 | Age 67.
age70 | Age 70.
age72 | Age 72.
age75 | Age 75.
amend01 | The date of special 0.1 percent benefit increase.
amend118_273 | The date of WEP no longer being used for benefit computations.
amend50 | The date of 1950 amendments.
amend52 | The date of 1952 amendments.
amend54 | The date of 1954 amendments.
amend56 | The date of 1956 amendments.
amend561 | First birth date for which age 62 is effective for females.
amend562 | Second birth date for which age 62 is effective for females.
amend58 | The date of 1958 amendments.
amend61 | The date of 1961 amendments.
amend611 | First birth date for which age 62 is effective for males.
amend612 | Second birth date for which age 62 is effective for males.
amend651 | The date of 1965 amendments for benefit increase.
amend652 | The date of 1965 amendments for change to age 60.
amend653 | The date of 1965 amendments for old start.
amend671 | The date of 1967 amendments for old start.
amend672 | The date of 1967 amendments for benefit increase.
amend69 | The date of 1969 amendments.
amend70 | The date of 1970 amendments.
amend721 | The date of 1972 amendments for benefit increase.
amend722 | The date of 1972 amendments for special minimum.
amend741 | The date of 1974 amendments for partial increase.
amend742 | The date of 1974 amendments for full increase.
amend771 | The date of 1977 amendments for frozen pia table.
amend772 | The date of 1977 amendments for start of wage indexing.
amend80 | The date of 1980 amendments.
amend811 | The date of birth for age 62 and 1 month in 1981 amendments.
amend812 | The date of 1981 amendments (month, day, and year).
amend813 | The date of 1981 amendments (month and year).
amend82 | The date of 1982 amendments.
amend83 | The date of 1983 amendments.
amend88 | The date of 1988 amendments.
amend90 | The date of 1990 amendments.
amtperincyr | Amount per old start increment year.
arFactorWid285 | Total actuarial reduction factor for aged widow(er)s.
arMonthlyFactor65_67 | Monthly actuarial reduction factor between ages 65 and 67.
arMonthlyFactorOab62_65 | Monthly actuarial reduction factor between ages 62 and 65.
arMonthlyFactorSpouse62_65 | Monthly actuarial reduction factor for aged spouses between ages 62 and 65.
beninc74 | Temporary benefit increase, March-May 1974.
bpMfbOut | Table of mfb formula bend points.
bpPiaOut | Table of pia formula bend points.
factor150 | Factor for calculating mfbs.
factor175 | Factor for calculating mfbs.
factor50 | Factor for calculating life benefits.
factor75 | Factor for calculating survivor benefits.
factor825 | Factor for calculating widow(er) benefits.
maxMonthsAr62_65 | Maximum number of months of actuarial reduction between ages 62 and 65.
maxMonthsAr62_67 | Maximum number of months of actuarial reduction between ages 62 and 67.
maxMonthsAr65_67 | Maximum number of months of actuarial reduction between ages 65 and 67.
percPiaOut | Table of pia formula percentages.
qcamt | Array of amounts required for quarter of coverage.
qtr184 | Starting point of deemed insured.
year37qtr1 | First quarter for which a quarter of coverage could be earned.


PiaParamsAny Members Public Methods

PiaParamsAny Members Public Methods
PiaParamsAny Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PiaParams | Initializes a PiaParams, with or without a first year of projection.
PiaParamsAny | Initializes arrays.
PiaParamsLC | Initializes a PiaParamsLC, with or without a first year of projection.
applyCola | Returns benefit amount increased by cola.
applyCola | Returns benefit amount increased by cola.
applyCola99 | Returns benefit amount increased by special 1999 cola (includes extra 0.1 percent increase).
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb99 | Returns maximum family benefit amount increased by special 1999 cola (includes extra 0.1 percent increase), with check that result is at least 150 percent of pia.
benincCatchUp | Applies catch-up benefit increases.
birthDateFRA | Returns the earliest birthdate for someone to be over NRA at the end of a year.
childAgeForMFCal | Returns oldest age of child for which parent can get young wife/husband or mother/father benefits.
deconvertPia | Deconverts PIA back to year of eligibility.
deemedQcReqCal | Returns number of quarters of coverage required for deemed insured status.
doRecalc | Returns true if should recalculate PIAs this year because of a newly effective law change, else false.
earlyAgeDisWidCal | Returns earliest possible disabled widow(er)'s retirement age.
earlyAgeOabCal | Returns earliest possible retirement age for oab or aged spouse.
earlyAgeOabCal | Returns earliest possible retirement age for old-age benie or aged spouse.
earlyAgeOabCalPL | Returns earliest possible retirement age for old-age benie or aged spouse, based on present law.
earlyAgeWidCal | Returns earliest possible aged widow(er)'s retirement age.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCalPL | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow(er) benefit before age reduction.
factorAgedWidCal | Returns factor for widow/widower benefit before age reduction.
factorAgedWidCalPL | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Returns reduction factor for wife/husband.
factorArAgedSpouseCal | Calculates reduction factor for wife/husband.
factorArAgedSpouseCalPL | Calculates reduction factor for wife/husband. Assumes a maximum of 60 months of reduction.
factorArCal | Returns reduction factor for OAB.
factorArCal | Calculates reduction factor for OAB.
factorArCalPL | Calculates reduction factor for OAB or DIB.
factorArDisWidCal | Calculates reduction factor for disabled widow(er).
factorArWidCal | Calculates reduction factor for aged widow(er).
factorDisWidCal | Returns factor for disabled widow(er) benefit before age reduction.
factorDisWidCal | Returns factor for disabled widow/widower benefit before age reduction.
factorDisWidCalPL | Returns factor for disabled widow/widower benefit before age reduction.
factorDriCal | Calculates delayed retirement increment factor for OAB.
factorYngLifeCal | Calculates reduction factor for young life benie.
factorYngSurvCal | Calculates reduction factor for young survivor.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDIPL | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalPL | Returns full retirement age based on present law.
getAverageWage | Returns title of average wage assumptions.
getBase77 | Returns one old-law wage base.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBase77Array | Returns the array of old-law wage bases.
getBaseHi | Returns one HI wage base.
getBaseHiArray | Returns the array of HI wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBendOS | Returns a bend point for old-start PIB formula.
getBenefitInc | Returns title of benefit increase assumptions.
getCatchup | Returns catch-up benefit increases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmountPL | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getCpiinc | Returns one benefit increase.
getCpiinc | Returns one benefit increase.
getCpiincArray | Returns the array of benefit increases.
getCpiincArray | Returns the benefit increases.
getFq | Returns one average wage for indexing.
getFqArray | Returns array of average wages for indexing.
getFqBppia | Returns series used for indexing pia formula bend points.
getFqBppia | Returns series of average wages or other series used for indexing pia formula bend points.
getFqIndex | Returns series used for indexing an earnings record.
getFqIndex | Returns series of average wages or other series used for indexing an earnings record.
getFqinc | Returns one increase in average wage for indexing.
getFqincArray | Returns array of increases in average wage for indexing.
getIstart | Returns current year.
getMarrLengthForDivBen | Returns the number of years of marraige needed to be eligible for a divroced spouse benefit.
getMarrLengthForDivBen | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMarrLengthForDivBenPL | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year or childcare credit.
getMaxChildcareAgePL | Returns maximum age of child for childcare dropout year.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYearsPL | Returns maximum number of childcare dropout years.
getMaxyear | Returns maximum possible year.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB for the given year.
getMonthBeninc | Returns one month of benefit increase.
getMonthBenincArray | Returns array of months of benefit increase.
getPercOS | Returns old-start PIB formula percentage.
getPercSpecMin | Returns percent of old-law base required for year of coverage.
getPercSpecMinArray | Returns array of percents of old-law base required for year of coverage.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinPerc | Returns percentage of old-law base required for year of coverage.
getSpecMinPia | Returns special minimum pia as of a specified month.
getSpecMinPia | Returns special minimum pia as of a specified month.
getWageHigh | Returns high earnings for one year.
getWageHighArray | Returns array of high earnings.
getWageMin | Returns low earnings for one year.
getWageMinArray | Returns array of low earnings.
getYocAmountSpecMin | Returns amount required for year of coverage for special minimum.
getYocAmountSpecMinArray | Returns array of amounts required for year of coverage for special minimum.
getYocAmountWindfallArray | Returns array of amounts required for year of coverage for windfall elimination.
highProj | Projects high earnings.
initdata | Initializes some data.
initdata | Initializes some data.
isApplicableCola99 | Checks for applicability of special 1999 increase (with extra 0.1 percent).
lastAmw | Finds last AMW in old-law table.
lumpSum | Returns amount of lump sum benefit.
maxChildAge | Returns maximum child beneficiary age.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAgePL | Returns maximum DI beneficiary age at end of year, based on present law.
minProj | Projects low earnings.
monthsArAgedSpouseCal | Calculates number of months of actuarial reduction for aged wife/husband.
monthsArCal | Calculates number of months of actuarial reduction for OAB.
monthsArDICal | Calculates number of months of reduction for disabled worker.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er).
monthsArWidCal | Calculates number of months of actuarial reduction for aged widow(er).
monthsDriCal | Calculates number of months of delayed retirement credit for OAB.
needColaCap | Returns true if a cola cap is required.
needColaCap | Returns true if a cola cap is required.
percPiaCal | Sets benefit formula percents.
projectCpiinc | Projects amounts dependent on benefit increases.
projectCpiinc | Projects amounts dependent on benefit increases.
projectFq | Projects average annual wage and amounts dependent on it.
projectPerc | Projects benefit formula percentages.
projectPerc | Projects benefit formula percentages.
projectSpecMin | Projects special minimum amounts.
projectSpecMin | Projects special minimum amounts.
qcCal | Returns number of quarters of coverage for one year, applying annual test.
resizeSpecMin | Resizes special minimum arrays.
resizeSpecMin | Resizes special minimum arrays.
retCredit | Returns amount of monthly delayed retirement credit.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCalPL | Returns widow(er) benefit reduced for RIB-LIM.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setData | Sets data from historical average wages and benefit increase file.
setData | Sets data from historical average wages and benefit increase file.
setHistFqinc | Sets historical average wage increases.
setIstart | Sets the first projected year, including for members.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
setNoChange | Sets indicators for no change allowed.
specMinAmountCal | Sets amount per year of coverage in special minimum.
specMinAmountCal | Returns amount per year of coverage in special minimum.
specMinAmountCalPL | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYearsPL | Returns maximum number of usable years for special minimum.
unApplyCola | Returns benefit amount decreased by cola.
unApplyCola99 | Returns benefit amount decreased by special 1999 cola (includes extra 0.1 percent decrease.)
unbiCatchUp | Divides out catch-up benefit increases.
updateBases | Updates wage bases.
updateBases | Updates wage bases.
updateCpiinc | Updates benefit increases.
updateFq | Updates average wages, using specified amounts.
updateFqinc | Updates increases in average wages, using specified percentages.
updateYocAmountSpecMin | Updates amounts required for special minimum year of coverage.
~PiaParamsAny | Destroys arrays.


PiaParamsLC Members Enumerations

PiaParamsLC Members Enumerations
PiaParamsLC Members Legend
Enumerations
Name | Description
SPECMINPERCTYPE | The year range for the special minimum percentage.


Legend

Legend
PiaParamsLC Members
Legend
Constructor
virtual
abstract
protected
Enumeration
Data Member


PiaParamsLC Members Protected Data Members

PiaParamsLC Members Protected Data Members
PiaParamsLC Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
baseHi | HI wage bases.
bendOS | Bend points for old-start PIB formula.
catchup | Catch-up benefit increases.
cpiinc | Array of benefit increases.
fq | Array of annual average earnings.
fqinc | Array of percentage increases in annual average earnings.
istart | Current year (year after last known benefit increase).
maxyear | Maximum year allowed.
monthBeninc | Array of month of benefit increase.
noChange | Array of indicators for no change allowed.
percOS | Old-start PIB formula percentages.
percSpecMin | Percentage of old-law wage base required for year of coverage.
recalcInd | Indicator for which year(s) the PIA should be recalculated due to a newly effective law change.
specMinMfb | Special minimum mfbs.
specMinMfb2001 | Special minimum mfbs for August-November 2001.
specMinPerc | Percentage of old-law wage base required for year of coverage for special minimum.
specMinPia | Special minimum pias.
specMinPia2001 | Special minimum pias for August-November 2001.
titleAw | Title of average wage assumptions.
titleBi | Title of benefit increase assumptions.
yocAmountSpecMin | Amount required for year of coverage for special minimum.
yocAmountWindfall | Amount required for year of coverage for windfall elimination provision.


PiaParamsLC Members Protected Methods

PiaParamsLC Members Protected Methods
PiaParamsLC Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
setAltCpiinc | Sets benefit increases when changed from present law.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setFqBppia | Sets series of average wages or other series used for indexing pia formula bend points.
setFqIndex | Calculate series of average wages or other series used for indexing an earnings record.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.


PiaParamsLC Members Public Data Members

PiaParamsLC Members Public Data Members
PiaParamsLC Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
YEAR1999 | Year of extra 0.1 percent benefit increase.
age16 | Age 16.
age18 | Age 18.
age19 | Age 19.
age199 | Age 199 (impossible age).
age22 | Age 22.
age50 | Age 50.
age60 | Age 60.
age62 | Age 62.
age621 | Age 62 and 1 month.
age65 | Age 65.
age65_10 | Age 65 and 10 months.
age65_2 | Age 65 and 2 months.
age65_4 | Age 65 and 4 months.
age65_6 | Age 65 and 6 months.
age65_8 | Age 65 and 8 months.
age66 | Age 66.
age66_10 | Age 66 and 10 months.
age66_2 | Age 66 and 2 months.
age66_4 | Age 66 and 4 months.
age66_6 | Age 66 and 6 months.
age66_8 | Age 66 and 8 months.
age67 | Age 67.
age70 | Age 70.
age72 | Age 72.
age75 | Age 75.
amend01 | The date of special 0.1 percent benefit increase.
amend118_273 | The date of WEP no longer being used for benefit computations.
amend50 | The date of 1950 amendments.
amend52 | The date of 1952 amendments.
amend54 | The date of 1954 amendments.
amend56 | The date of 1956 amendments.
amend561 | First birth date for which age 62 is effective for females.
amend562 | Second birth date for which age 62 is effective for females.
amend58 | The date of 1958 amendments.
amend61 | The date of 1961 amendments.
amend611 | First birth date for which age 62 is effective for males.
amend612 | Second birth date for which age 62 is effective for males.
amend651 | The date of 1965 amendments for benefit increase.
amend652 | The date of 1965 amendments for change to age 60.
amend653 | The date of 1965 amendments for old start.
amend671 | The date of 1967 amendments for old start.
amend672 | The date of 1967 amendments for benefit increase.
amend69 | The date of 1969 amendments.
amend70 | The date of 1970 amendments.
amend721 | The date of 1972 amendments for benefit increase.
amend722 | The date of 1972 amendments for special minimum.
amend741 | The date of 1974 amendments for partial increase.
amend742 | The date of 1974 amendments for full increase.
amend771 | The date of 1977 amendments for frozen pia table.
amend772 | The date of 1977 amendments for start of wage indexing.
amend80 | The date of 1980 amendments.
amend811 | The date of birth for age 62 and 1 month in 1981 amendments.
amend812 | The date of 1981 amendments (month, day, and year).
amend813 | The date of 1981 amendments (month and year).
amend82 | The date of 1982 amendments.
amend83 | The date of 1983 amendments.
amend88 | The date of 1988 amendments.
amend90 | The date of 1990 amendments.
amtperincyr | Amount per old start increment year.
arFactorWid285 | Total actuarial reduction factor for aged widow(er)s.
arMonthlyFactor65_67 | Monthly actuarial reduction factor between ages 65 and 67.
arMonthlyFactorOab62_65 | Monthly actuarial reduction factor between ages 62 and 65.
arMonthlyFactorSpouse62_65 | Monthly actuarial reduction factor for aged spouses between ages 62 and 65.
beninc74 | Temporary benefit increase, March-May 1974.
bpMfbOut | Table of mfb formula bend points.
bpPiaOut | Table of pia formula bend points.
factor150 | Factor for calculating mfbs.
factor175 | Factor for calculating mfbs.
factor50 | Factor for calculating life benefits.
factor75 | Factor for calculating survivor benefits.
factor825 | Factor for calculating widow(er) benefits.
maxMonthsAr62_65 | Maximum number of months of actuarial reduction between ages 62 and 65.
maxMonthsAr62_67 | Maximum number of months of actuarial reduction between ages 62 and 67.
maxMonthsAr65_67 | Maximum number of months of actuarial reduction between ages 65 and 67.
percPiaOut | Table of pia formula percentages.
qcamt | Array of amounts required for quarter of coverage.
qtr184 | Starting point of deemed insured.
year37qtr1 | First quarter for which a quarter of coverage could be earned.


PiaParamsLC Members Public Methods

PiaParamsLC Members Public Methods
PiaParamsLC Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PiaParams | Initializes a PiaParams, with or without a first year of projection.
PiaParamsLC | Initializes a PiaParamsLC, with or without a first year of projection.
applyCola | Returns benefit amount increased by cola.
applyCola | Returns benefit amount increased by cola.
applyCola99 | Returns benefit amount increased by special 1999 cola (includes extra 0.1 percent increase).
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb99 | Returns maximum family benefit amount increased by special 1999 cola (includes extra 0.1 percent increase), with check that result is at least 150 percent of pia.
benincCatchUp | Applies catch-up benefit increases.
birthDateFRA | Returns the earliest birthdate for someone to be over NRA at the end of a year.
childAgeForMFCal | Returns oldest age of child for which parent can get young wife/husband or mother/father benefits.
deconvertPia | Deconverts PIA back to year of eligibility.
deemedQcReqCal | Returns number of quarters of coverage required for deemed insured status.
doRecalc | Returns true if should recalculate PIAs this year because of a newly effective law change, else false.
earlyAgeDisWidCal | Returns earliest possible disabled widow(er)'s retirement age.
earlyAgeOabCal | Returns earliest possible retirement age for old-age benie or aged spouse.
earlyAgeOabCalPL | Returns earliest possible retirement age for old-age benie or aged spouse, based on present law.
earlyAgeWidCal | Returns earliest possible aged widow(er)'s retirement age.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCalPL | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow/widower benefit before age reduction.
factorAgedWidCalPL | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Calculates reduction factor for wife/husband.
factorArAgedSpouseCalPL | Calculates reduction factor for wife/husband. Assumes a maximum of 60 months of reduction.
factorArCal | Calculates reduction factor for OAB.
factorArCalPL | Calculates reduction factor for OAB or DIB.
factorArDisWidCal | Calculates reduction factor for disabled widow(er).
factorArWidCal | Calculates reduction factor for aged widow(er).
factorDisWidCal | Returns factor for disabled widow/widower benefit before age reduction.
factorDisWidCalPL | Returns factor for disabled widow/widower benefit before age reduction.
factorDriCal | Calculates delayed retirement increment factor for OAB.
factorYngLifeCal | Calculates reduction factor for young life benie.
factorYngSurvCal | Calculates reduction factor for young survivor.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDIPL | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalPL | Returns full retirement age based on present law.
getAverageWage | Returns title of average wage assumptions.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBaseHi | Returns one HI wage base.
getBaseHiArray | Returns the array of HI wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBendOS | Returns a bend point for old-start PIB formula.
getBenefitInc | Returns title of benefit increase assumptions.
getCatchup | Returns catch-up benefit increases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmountPL | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getCpiinc | Returns one benefit increase.
getCpiincArray | Returns the benefit increases.
getFq | Returns one average wage for indexing.
getFqArray | Returns array of average wages for indexing.
getFqBppia | Returns series of average wages or other series used for indexing pia formula bend points.
getFqIndex | Returns series of average wages or other series used for indexing an earnings record.
getFqinc | Returns one increase in average wage for indexing.
getFqincArray | Returns array of increases in average wage for indexing.
getIstart | Returns current year.
getMarrLengthForDivBen | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMarrLengthForDivBenPL | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year or childcare credit.
getMaxChildcareAgePL | Returns maximum age of child for childcare dropout year.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYearsPL | Returns maximum number of childcare dropout years.
getMaxyear | Returns maximum possible year.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB for the given year.
getMonthBeninc | Returns one month of benefit increase.
getMonthBenincArray | Returns array of months of benefit increase.
getPercOS | Returns old-start PIB formula percentage.
getPercSpecMin | Returns percent of old-law base required for year of coverage.
getPercSpecMinArray | Returns array of percents of old-law base required for year of coverage.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinPerc | Returns percentage of old-law base required for year of coverage.
getSpecMinPia | Returns special minimum pia as of a specified month.
getYocAmountSpecMin | Returns amount required for year of coverage for special minimum.
getYocAmountSpecMinArray | Returns array of amounts required for year of coverage for special minimum.
getYocAmountWindfallArray | Returns array of amounts required for year of coverage for windfall elimination.
initdata | Initializes some data.
isApplicableCola99 | Checks for applicability of special 1999 increase (with extra 0.1 percent).
lastAmw | Finds last AMW in old-law table.
lumpSum | Returns amount of lump sum benefit.
maxChildAge | Returns maximum child beneficiary age.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAgePL | Returns maximum DI beneficiary age at end of year, based on present law.
monthsArAgedSpouseCal | Calculates number of months of actuarial reduction for aged wife/husband.
monthsArCal | Calculates number of months of actuarial reduction for OAB.
monthsArDICal | Calculates number of months of reduction for disabled worker.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er).
monthsArWidCal | Calculates number of months of actuarial reduction for aged widow(er).
monthsDriCal | Calculates number of months of delayed retirement credit for OAB.
needColaCap | Returns true if a cola cap is required.
needColaCap | Returns true if a cola cap is required.
percPiaCal | Sets benefit formula percents.
projectCpiinc | Projects amounts dependent on benefit increases.
projectFq | Projects average annual wage and amounts dependent on it.
projectPerc | Projects benefit formula percentages.
projectSpecMin | Projects special minimum amounts.
qcCal | Returns number of quarters of coverage for one year, applying annual test.
resizeSpecMin | Resizes special minimum arrays.
retCredit | Returns amount of monthly delayed retirement credit.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCalPL | Returns widow(er) benefit reduced for RIB-LIM.
setData | Sets data from historical average wages and benefit increase file.
setHistFqinc | Sets historical average wage increases.
setIstart | Sets the first projected year, including for members.
setNoChange | Sets indicators for no change allowed.
specMinAmountCal | Returns amount per year of coverage in special minimum.
specMinAmountCalPL | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYearsPL | Returns maximum number of usable years for special minimum.
unApplyCola | Returns benefit amount decreased by cola.
unApplyCola99 | Returns benefit amount decreased by special 1999 cola (includes extra 0.1 percent decrease.)
unbiCatchUp | Divides out catch-up benefit increases.
updateBases | Updates wage bases.
updateBases | Updates wage bases.
updateCpiinc | Updates benefit increases.
updateFq | Updates average wages, using specified amounts.
updateFqinc | Updates increases in average wages, using specified percentages.
updateYocAmountSpecMin | Updates amounts required for special minimum year of coverage.
~PiaParamsLC | Destroys arrays.


PiaParamsLCTR Members Enumerations

PiaParamsLCTR Members Enumerations
PiaParamsLCTR Members Legend
Enumerations
Name | Description
SPECMINPERCTYPE | The year range for the special minimum percentage.


Legend

Legend
PiaParamsLCTR Members
Legend
Constructor
virtual
abstract
protected
Enumeration
Data Member


PiaParamsLCTR Members Protected Data Members

PiaParamsLCTR Members Protected Data Members
PiaParamsLCTR Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
baseHi | HI wage bases.
bendOS | Bend points for old-start PIB formula.
catchup | Catch-up benefit increases.
cpiinc | Array of benefit increases.
fq | Array of annual average earnings.
fqinc | Array of percentage increases in annual average earnings.
istart | Current year (year after last known benefit increase).
maxyear | Maximum year allowed.
monthBeninc | Array of month of benefit increase.
noChange | Array of indicators for no change allowed.
percOS | Old-start PIB formula percentages.
percSpecMin | Percentage of old-law wage base required for year of coverage.
recalcInd | Indicator for which year(s) the PIA should be recalculated due to a newly effective law change.
specMinMfb | Special minimum mfbs.
specMinMfb2001 | Special minimum mfbs for August-November 2001.
specMinPerc | Percentage of old-law wage base required for year of coverage for special minimum.
specMinPia | Special minimum pias.
specMinPia2001 | Special minimum pias for August-November 2001.
titleAw | Title of average wage assumptions.
titleBi | Title of benefit increase assumptions.
yocAmountSpecMin | Amount required for year of coverage for special minimum.
yocAmountWindfall | Amount required for year of coverage for windfall elimination provision.


PiaParamsLCTR Members Protected Methods

PiaParamsLCTR Members Protected Methods
PiaParamsLCTR Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
setAltCpiinc | Sets benefit increases when changed from present law.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setFqBppia | Sets series of average wages or other series used for indexing pia formula bend points.
setFqIndex | Calculate series of average wages or other series used for indexing an earnings record.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.


PiaParamsLCTR Members Public Data Members

PiaParamsLCTR Members Public Data Members
PiaParamsLCTR Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
YEAR1999 | Year of extra 0.1 percent benefit increase.
age16 | Age 16.
age18 | Age 18.
age19 | Age 19.
age199 | Age 199 (impossible age).
age22 | Age 22.
age50 | Age 50.
age60 | Age 60.
age62 | Age 62.
age621 | Age 62 and 1 month.
age65 | Age 65.
age65_10 | Age 65 and 10 months.
age65_2 | Age 65 and 2 months.
age65_4 | Age 65 and 4 months.
age65_6 | Age 65 and 6 months.
age65_8 | Age 65 and 8 months.
age66 | Age 66.
age66_10 | Age 66 and 10 months.
age66_2 | Age 66 and 2 months.
age66_4 | Age 66 and 4 months.
age66_6 | Age 66 and 6 months.
age66_8 | Age 66 and 8 months.
age67 | Age 67.
age70 | Age 70.
age72 | Age 72.
age75 | Age 75.
amend01 | The date of special 0.1 percent benefit increase.
amend118_273 | The date of WEP no longer being used for benefit computations.
amend50 | The date of 1950 amendments.
amend52 | The date of 1952 amendments.
amend54 | The date of 1954 amendments.
amend56 | The date of 1956 amendments.
amend561 | First birth date for which age 62 is effective for females.
amend562 | Second birth date for which age 62 is effective for females.
amend58 | The date of 1958 amendments.
amend61 | The date of 1961 amendments.
amend611 | First birth date for which age 62 is effective for males.
amend612 | Second birth date for which age 62 is effective for males.
amend651 | The date of 1965 amendments for benefit increase.
amend652 | The date of 1965 amendments for change to age 60.
amend653 | The date of 1965 amendments for old start.
amend671 | The date of 1967 amendments for old start.
amend672 | The date of 1967 amendments for benefit increase.
amend69 | The date of 1969 amendments.
amend70 | The date of 1970 amendments.
amend721 | The date of 1972 amendments for benefit increase.
amend722 | The date of 1972 amendments for special minimum.
amend741 | The date of 1974 amendments for partial increase.
amend742 | The date of 1974 amendments for full increase.
amend771 | The date of 1977 amendments for frozen pia table.
amend772 | The date of 1977 amendments for start of wage indexing.
amend80 | The date of 1980 amendments.
amend811 | The date of birth for age 62 and 1 month in 1981 amendments.
amend812 | The date of 1981 amendments (month, day, and year).
amend813 | The date of 1981 amendments (month and year).
amend82 | The date of 1982 amendments.
amend83 | The date of 1983 amendments.
amend88 | The date of 1988 amendments.
amend90 | The date of 1990 amendments.
amtperincyr | Amount per old start increment year.
arFactorWid285 | Total actuarial reduction factor for aged widow(er)s.
arMonthlyFactor65_67 | Monthly actuarial reduction factor between ages 65 and 67.
arMonthlyFactorOab62_65 | Monthly actuarial reduction factor between ages 62 and 65.
arMonthlyFactorSpouse62_65 | Monthly actuarial reduction factor for aged spouses between ages 62 and 65.
beninc74 | Temporary benefit increase, March-May 1974.
bpMfbOut | Table of mfb formula bend points.
bpPiaOut | Table of pia formula bend points.
factor150 | Factor for calculating mfbs.
factor175 | Factor for calculating mfbs.
factor50 | Factor for calculating life benefits.
factor75 | Factor for calculating survivor benefits.
factor825 | Factor for calculating widow(er) benefits.
maxMonthsAr62_65 | Maximum number of months of actuarial reduction between ages 62 and 65.
maxMonthsAr62_67 | Maximum number of months of actuarial reduction between ages 62 and 67.
maxMonthsAr65_67 | Maximum number of months of actuarial reduction between ages 65 and 67.
percPiaOut | Table of pia formula percentages.
qcamt | Array of amounts required for quarter of coverage.
qtr184 | Starting point of deemed insured.
year37qtr1 | First quarter for which a quarter of coverage could be earned.


PiaParamsLCTR Members Public Methods

PiaParamsLCTR Members Public Methods
PiaParamsLCTR Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PiaParams | Initializes a PiaParams, with or without a first year of projection.
PiaParamsLC | Initializes a PiaParamsLC, with or without a first year of projection.
PiaParamsLCTR | Constructor.
applyCola | Returns benefit amount increased by cola.
applyCola | Returns benefit amount increased by cola.
applyCola99 | Returns benefit amount increased by special 1999 cola (includes extra 0.1 percent increase).
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb99 | Returns maximum family benefit amount increased by special 1999 cola (includes extra 0.1 percent increase), with check that result is at least 150 percent of pia.
benincCatchUp | Applies catch-up benefit increases.
birthDateFRA | Returns the earliest birthdate for someone to be over NRA at the end of a year.
childAgeForMFCal | Returns oldest age of child for which parent can get young wife/husband or mother/father benefits.
deconvertPia | Deconverts PIA back to year of eligibility.
deemedQcReqCal | Returns number of quarters of coverage required for deemed insured status.
doRecalc | Returns true if should recalculate PIAs this year because of a newly effective law change, else false.
earlyAgeDisWidCal | Returns earliest possible disabled widow(er)'s retirement age.
earlyAgeOabCal | Returns earliest possible retirement age for oab or aged spouse.
earlyAgeOabCal | Returns earliest possible retirement age for old-age benie or aged spouse.
earlyAgeOabCalPL | Returns earliest possible retirement age for old-age benie or aged spouse, based on present law.
earlyAgeWidCal | Returns earliest possible aged widow(er)'s retirement age.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCalPL | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow(er) benefit before age reduction.
factorAgedWidCal | Returns factor for widow/widower benefit before age reduction.
factorAgedWidCalPL | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Returns reduction factor for wife/husband.
factorArAgedSpouseCal | Calculates reduction factor for wife/husband.
factorArAgedSpouseCalPL | Calculates reduction factor for wife/husband. Assumes a maximum of 60 months of reduction.
factorArCal | Returns reduction factor for OAB.
factorArCal | Calculates reduction factor for OAB.
factorArCalPL | Calculates reduction factor for OAB or DIB.
factorArDisWidCal | Calculates reduction factor for disabled widow(er).
factorArWidCal | Calculates reduction factor for aged widow(er).
factorDisWidCal | Returns factor for disabled widow(er) benefit before age reduction.
factorDisWidCal | Returns factor for disabled widow/widower benefit before age reduction.
factorDisWidCalPL | Returns factor for disabled widow/widower benefit before age reduction.
factorDriCal | Calculates delayed retirement increment factor for OAB.
factorYngLifeCal | Calculates reduction factor for young life benie.
factorYngSurvCal | Calculates reduction factor for young survivor.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDIPL | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalPL | Returns full retirement age based on present law.
getAverageWage | Returns title of average wage assumptions.
getBase77 | Returns one old-law wage base.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBase77Array | Returns the array of old-law wage bases.
getBaseHi | Returns one HI wage base.
getBaseHiArray | Returns the array of HI wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBendOS | Returns a bend point for old-start PIB formula.
getBenefitInc | Returns title of benefit increase assumptions.
getCatchup | Returns catch-up benefit increases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmountPL | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getCpiinc | Returns one benefit increase.
getCpiinc | Returns one benefit increase.
getCpiincArray | Returns the array of benefit increases.
getCpiincArray | Returns the benefit increases.
getFq | Returns one average wage for indexing.
getFqArray | Returns array of average wages for indexing.
getFqBppia | Returns series used for indexing pia formula bend points.
getFqBppia | Returns series of average wages or other series used for indexing pia formula bend points.
getFqIndex | Returns series used for indexing an earnings record.
getFqIndex | Returns series of average wages or other series used for indexing an earnings record.
getFqinc | Returns one increase in average wage for indexing.
getFqincArray | Returns array of increases in average wage for indexing.
getIstart | Returns current year.
getMarrLengthForDivBen | Returns the number of years of marraige needed to be eligible for a divroced spouse benefit.
getMarrLengthForDivBen | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMarrLengthForDivBenPL | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year or childcare credit.
getMaxChildcareAgePL | Returns maximum age of child for childcare dropout year.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYearsPL | Returns maximum number of childcare dropout years.
getMaxyear | Returns maximum possible year.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB for the given year.
getMonthBeninc | Returns one month of benefit increase.
getMonthBenincArray | Returns array of months of benefit increase.
getPercOS | Returns old-start PIB formula percentage.
getPercSpecMin | Returns percent of old-law base required for year of coverage.
getPercSpecMinArray | Returns array of percents of old-law base required for year of coverage.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinPerc | Returns percentage of old-law base required for year of coverage.
getSpecMinPia | Returns special minimum pia as of a specified month.
getSpecMinPia | Returns special minimum pia as of a specified month.
getYocAmountSpecMin | Returns amount required for year of coverage for special minimum.
getYocAmountSpecMinArray | Returns array of amounts required for year of coverage for special minimum.
getYocAmountWindfallArray | Returns array of amounts required for year of coverage for windfall elimination.
initdata | Initializes some data.
initdata | Initializes some data.
isApplicableCola99 | Checks for applicability of special 1999 increase (with extra 0.1 percent).
lastAmw | Finds last AMW in old-law table.
lumpSum | Returns amount of lump sum benefit.
maxChildAge | Returns maximum child beneficiary age.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAgePL | Returns maximum DI beneficiary age at end of year, based on present law.
monthsArAgedSpouseCal | Calculates number of months of actuarial reduction for aged wife/husband.
monthsArCal | Calculates number of months of actuarial reduction for OAB.
monthsArDICal | Calculates number of months of reduction for disabled worker.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er).
monthsArWidCal | Calculates number of months of actuarial reduction for aged widow(er).
monthsDriCal | Calculates number of months of delayed retirement credit for OAB.
needColaCap | Returns true if a cola cap is required.
needColaCap | Returns true if a cola cap is required.
percPiaCal | Sets benefit formula percents.
projectCpiinc | Projects amounts dependent on benefit increases.
projectCpiinc | Projects amounts dependent on benefit increases.
projectFq | Projects amounts dependent on the average annual wage.
projectFq | Projects average annual wage and amounts dependent on it.
projectPerc | Projects benefit formula percentages.
projectPerc | Projects benefit formula percentages.
projectSpecMin | Projects special minimum amounts.
projectSpecMin | Projects special minimum amounts.
qcCal | Returns number of quarters of coverage for one year, applying annual test.
resizeSpecMin | Resizes special minimum arrays.
resizeSpecMin | Resizes special minimum arrays.
retCredit | Returns amount of monthly delayed retirement credit.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCalPL | Returns widow(er) benefit reduced for RIB-LIM.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setData | Sets data from historical average wages and benefit increase file.
setData | Sets data from historical average wages and benefit increase file.
setHistFqinc | Sets historical average wage increases.
setIstart | Sets the first projected year, including for members.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
setNoChange | Sets indicators for no change allowed.
specMinAmountCal | Sets amount per year of coverage in special minimum.
specMinAmountCal | Returns amount per year of coverage in special minimum.
specMinAmountCalPL | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYearsPL | Returns maximum number of usable years for special minimum.
unApplyCola | Returns benefit amount decreased by cola.
unApplyCola99 | Returns benefit amount decreased by special 1999 cola (includes extra 0.1 percent decrease.)
unbiCatchUp | Divides out catch-up benefit increases.
updateBases | Updates wage bases.
updateBases | Updates wage bases.
updateCpiinc | Updates benefit increases.
updateFq | Updates average wages, using specified amounts.
updateFqinc | Updates increases in average wages, using specified percentages.
updateYocAmountSpecMin | Updates amounts required for special minimum year of coverage.
~PiaParamsLCTR | Destructor.


PiaParamsPL Members Enumerations

PiaParamsPL Members Enumerations
PiaParamsPL Members Legend
Enumerations
Name | Description
SPECMINPERCTYPE | The year range for the special minimum percentage.


Legend

Legend
PiaParamsPL Members
Legend
Constructor
virtual
abstract
Enumeration
Data Member
protected


PiaParamsPL Members Protected Data Members

PiaParamsPL Members Protected Data Members
PiaParamsPL Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
baseHi | HI wage bases.
bendOS | Bend points for old-start PIB formula.
catchup | Catch-up benefit increases.
cpiinc | Array of benefit increases.
fq | Array of annual average earnings.
fqinc | Array of percentage increases in annual average earnings.
istart | Current year (year after last known benefit increase).
maxyear | Maximum year allowed.
monthBeninc | Array of month of benefit increase.
noChange | Array of indicators for no change allowed.
percOS | Old-start PIB formula percentages.
percSpecMin | Percentage of old-law wage base required for year of coverage.
recalcInd | Indicator for which year(s) the PIA should be recalculated due to a newly effective law change.
specMinMfb | Special minimum mfbs.
specMinMfb2001 | Special minimum mfbs for August-November 2001.
specMinPerc | Percentage of old-law wage base required for year of coverage for special minimum.
specMinPia | Special minimum pias.
specMinPia2001 | Special minimum pias for August-November 2001.
titleAw | Title of average wage assumptions.
titleBi | Title of benefit increase assumptions.
yocAmountSpecMin | Amount required for year of coverage for special minimum.
yocAmountWindfall | Amount required for year of coverage for windfall elimination provision.


PiaParamsPL Members Public Data Members

PiaParamsPL Members Public Data Members
PiaParamsPL Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
YEAR1999 | Year of extra 0.1 percent benefit increase.
age16 | Age 16.
age18 | Age 18.
age19 | Age 19.
age199 | Age 199 (impossible age).
age22 | Age 22.
age50 | Age 50.
age60 | Age 60.
age62 | Age 62.
age621 | Age 62 and 1 month.
age65 | Age 65.
age65_10 | Age 65 and 10 months.
age65_2 | Age 65 and 2 months.
age65_4 | Age 65 and 4 months.
age65_6 | Age 65 and 6 months.
age65_8 | Age 65 and 8 months.
age66 | Age 66.
age66_10 | Age 66 and 10 months.
age66_2 | Age 66 and 2 months.
age66_4 | Age 66 and 4 months.
age66_6 | Age 66 and 6 months.
age66_8 | Age 66 and 8 months.
age67 | Age 67.
age70 | Age 70.
age72 | Age 72.
age75 | Age 75.
amend01 | The date of special 0.1 percent benefit increase.
amend118_273 | The date of WEP no longer being used for benefit computations.
amend50 | The date of 1950 amendments.
amend52 | The date of 1952 amendments.
amend54 | The date of 1954 amendments.
amend56 | The date of 1956 amendments.
amend561 | First birth date for which age 62 is effective for females.
amend562 | Second birth date for which age 62 is effective for females.
amend58 | The date of 1958 amendments.
amend61 | The date of 1961 amendments.
amend611 | First birth date for which age 62 is effective for males.
amend612 | Second birth date for which age 62 is effective for males.
amend651 | The date of 1965 amendments for benefit increase.
amend652 | The date of 1965 amendments for change to age 60.
amend653 | The date of 1965 amendments for old start.
amend671 | The date of 1967 amendments for old start.
amend672 | The date of 1967 amendments for benefit increase.
amend69 | The date of 1969 amendments.
amend70 | The date of 1970 amendments.
amend721 | The date of 1972 amendments for benefit increase.
amend722 | The date of 1972 amendments for special minimum.
amend741 | The date of 1974 amendments for partial increase.
amend742 | The date of 1974 amendments for full increase.
amend771 | The date of 1977 amendments for frozen pia table.
amend772 | The date of 1977 amendments for start of wage indexing.
amend80 | The date of 1980 amendments.
amend811 | The date of birth for age 62 and 1 month in 1981 amendments.
amend812 | The date of 1981 amendments (month, day, and year).
amend813 | The date of 1981 amendments (month and year).
amend82 | The date of 1982 amendments.
amend83 | The date of 1983 amendments.
amend88 | The date of 1988 amendments.
amend90 | The date of 1990 amendments.
amtperincyr | Amount per old start increment year.
arFactorWid285 | Total actuarial reduction factor for aged widow(er)s.
arMonthlyFactor65_67 | Monthly actuarial reduction factor between ages 65 and 67.
arMonthlyFactorOab62_65 | Monthly actuarial reduction factor between ages 62 and 65.
arMonthlyFactorSpouse62_65 | Monthly actuarial reduction factor for aged spouses between ages 62 and 65.
beninc74 | Temporary benefit increase, March-May 1974.
bpMfbOut | Table of mfb formula bend points.
bpPiaOut | Table of pia formula bend points.
factor150 | Factor for calculating mfbs.
factor175 | Factor for calculating mfbs.
factor50 | Factor for calculating life benefits.
factor75 | Factor for calculating survivor benefits.
factor825 | Factor for calculating widow(er) benefits.
maxMonthsAr62_65 | Maximum number of months of actuarial reduction between ages 62 and 65.
maxMonthsAr62_67 | Maximum number of months of actuarial reduction between ages 62 and 67.
maxMonthsAr65_67 | Maximum number of months of actuarial reduction between ages 65 and 67.
percPiaOut | Table of pia formula percentages.
qcamt | Array of amounts required for quarter of coverage.
qtr184 | Starting point of deemed insured.
year37qtr1 | First quarter for which a quarter of coverage could be earned.


PiaParamsPL Members Public Methods

PiaParamsPL Members Public Methods
PiaParamsPL Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PiaParams | Initializes a PiaParams, with or without a first year of projection.
PiaParamsPL | Initializes a PiaParamsPL, with or without a first year of projection.
applyCola | Returns benefit amount increased by cola.
applyCola99 | Returns benefit amount increased by special 1999 cola (includes extra 0.1 percent increase).
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb99 | Returns maximum family benefit amount increased by special 1999 cola (includes extra 0.1 percent increase), with check that result is at least 150 percent of pia.
benincCatchUp | Applies catch-up benefit increases.
birthDateFRA | Returns the earliest birthdate for someone to be over NRA at the end of a year.
childAgeForMFCal | Returns oldest age of child for which parent can get young wife/husband or mother/father benefits.
deconvertPia | Deconverts PIA back to year of eligibility.
deemedQcReqCal | Returns number of quarters of coverage required for deemed insured status.
doRecalc | Returns true if should recalculate PIAs this year because of a newly effective law change, else false.
earlyAgeDisWidCal | Returns earliest possible disabled widow(er)'s retirement age.
earlyAgeOabCal | Sets earliest possible retirement age for old-age benie or aged spouse.
earlyAgeOabCalPL | Returns earliest possible retirement age for old-age benie or aged spouse, based on present law.
earlyAgeWidCal | Returns earliest possible aged widow(er)'s retirement age.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCalPL | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow/widower benefit before age reduction.
factorAgedWidCalPL | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Returns reduction factor for wife/husband.
factorArAgedSpouseCalPL | Calculates reduction factor for wife/husband. Assumes a maximum of 60 months of reduction.
factorArCal | Calculates reduction factor for OAB.
factorArCalPL | Calculates reduction factor for OAB or DIB.
factorArDisWidCal | Calculates reduction factor for disabled widow(er).
factorArWidCal | Calculates reduction factor for aged widow(er).
factorDisWidCal | Returns factor for disabled widow/widower benefit before age reduction.
factorDisWidCalPL | Returns factor for disabled widow/widower benefit before age reduction.
factorDriCal | Calculates delayed retirement increment factor for OAB.
factorYngLifeCal | Calculates reduction factor for young life benie.
factorYngSurvCal | Calculates reduction factor for young survivor.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDIPL | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalPL | Returns full retirement age based on present law.
getAverageWage | Returns title of average wage assumptions.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBaseHi | Returns one HI wage base.
getBaseHiArray | Returns the array of HI wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBendOS | Returns a bend point for old-start PIB formula.
getBenefitInc | Returns title of benefit increase assumptions.
getCatchup | Returns catch-up benefit increases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmountPL | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getCpiinc | Returns one benefit increase.
getCpiincArray | Returns the array of benefit increases.
getFq | Returns one average wage for indexing.
getFqArray | Returns array of average wages for indexing.
getFqBppia | Returns series of average wages used for indexing pia formula bend points.
getFqIndex | Returns series of average wages used for indexing an earnings record.
getFqinc | Returns one increase in average wage for indexing.
getFqincArray | Returns array of increases in average wage for indexing.
getIstart | Returns current year.
getMarrLengthForDivBen | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMarrLengthForDivBenPL | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year.
getMaxChildcareAgePL | Returns maximum age of child for childcare dropout year.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYearsPL | Returns maximum number of childcare dropout years.
getMaxyear | Returns maximum possible year.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB for the given year.
getMonthBeninc | Returns one month of benefit increase.
getMonthBenincArray | Returns array of months of benefit increase.
getPercOS | Returns old-start PIB formula percentage.
getPercSpecMin | Returns percent of old-law base required for year of coverage.
getPercSpecMinArray | Returns array of percents of old-law base required for year of coverage.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinPerc | Returns percentage of old-law base required for year of coverage.
getSpecMinPia | Returns special minimum pia as of a specified month.
getYocAmountSpecMin | Returns amount required for year of coverage for special minimum.
getYocAmountSpecMinArray | Returns array of amounts required for year of coverage for special minimum.
getYocAmountWindfallArray | Returns array of amounts required for year of coverage for windfall elimination.
initdata | Initializes some data.
isApplicableCola99 | Checks for applicability of special 1999 increase (with extra 0.1 percent).
lastAmw | Finds last AMW in old-law table.
lumpSum | Returns amount of lump sum benefit.
maxChildAge | Returns maximum child beneficiary age.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAgePL | Returns maximum DI beneficiary age at end of year, based on present law.
monthsArAgedSpouseCal | Calculates number of months of actuarial reduction for aged wife/husband.
monthsArCal | Calculates number of months of actuarial reduction for OAB.
monthsArDICal | Calculates number of months of reduction for disabled worker.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er).
monthsArWidCal | Calculates number of months of actuarial reduction for aged widow(er).
monthsDriCal | Calculates number of months of delayed retirement credit for OAB.
needColaCap | Returns true if a cola cap is required.
needColaCap | Returns true if a cola cap is required.
percPiaCal | Sets benefit formula percents.
projectCpiinc | Projects amounts dependent on benefit increases.
projectFq | Projects amounts dependent on the average annual wage.
projectPerc | Projects benefit formula percentages.
projectSpecMin | Projects special minimum amounts.
qcCal | Returns number of quarters of coverage for one year, applying annual test.
resizeSpecMin | Resizes special minimum arrays.
retCredit | Returns amount of monthly delayed retirement credit.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCalPL | Returns widow(er) benefit reduced for RIB-LIM.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setData | Sets data from historical average wages and benefit increase file.
setHistFqinc | Sets historical average wage increases.
setIstart | Sets the first projected year, including for members.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
setNoChange | Sets indicators for no change allowed.
specMinAmountCal | Returns amount per year of coverage in special minimum.
specMinAmountCalPL | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYearsPL | Returns maximum number of usable years for special minimum.
unApplyCola | Returns benefit amount decreased by cola.
unApplyCola99 | Returns benefit amount decreased by special 1999 cola (includes extra 0.1 percent decrease.)
unbiCatchUp | Divides out catch-up benefit increases.
updateBases | Updates wage bases.
updateBases | Updates wage bases.
updateCpiinc | Updates benefit increases.
updateFq | Updates average wages, using specified amounts.
updateFqinc | Updates increases in average wages, using specified percentages.
updateYocAmountSpecMin | Updates amounts required for special minimum year of coverage.
~PiaParamsPL | Destroys arrays.


PiaParamsTR Members Enumerations

PiaParamsTR Members Enumerations
PiaParamsTR Members Legend
Enumerations
Name | Description
SPECMINPERCTYPE | The year range for the special minimum percentage.


Legend

Legend
PiaParamsTR Members
Legend
Constructor
virtual
abstract
Data Member
protected
Enumeration


PiaParamsTR Members Protected Data Members

PiaParamsTR Members Protected Data Members
PiaParamsTR Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
altNum | Trustees Report alternative (AssumptionType::assum_type::ALTERN_I, AssumptionType::assum_type::ALTERN_IIB, AssumptionType::assum_type::ALTERN_III, or AssumptionType::assum_type::ALTERN_IIA).
baseHi | HI wage bases.
bendOS | Bend points for old-start PIB formula.
catchup | Catch-up benefit increases.
cpiinc | Array of benefit increases.
fq | Array of annual average earnings.
fqinc | Array of percentage increases in annual average earnings.
istart | Current year (year after last known benefit increase).
maxyear | Maximum year allowed.
monthBeninc | Array of month of benefit increase.
noChange | Array of indicators for no change allowed.
percOS | Old-start PIB formula percentages.
percSpecMin | Percentage of old-law wage base required for year of coverage.
recalcInd | Indicator for which year(s) the PIA should be recalculated due to a newly effective law change.
specMinMfb | Special minimum mfbs.
specMinMfb2001 | Special minimum mfbs for August-November 2001.
specMinPerc | Percentage of old-law wage base required for year of coverage for special minimum.
specMinPia | Special minimum pias.
specMinPia2001 | Special minimum pias for August-November 2001.
titleAw | Title of average wage assumptions.
titleBi | Title of benefit increase assumptions.
yocAmountSpecMin | Amount required for year of coverage for special minimum.
yocAmountWindfall | Amount required for year of coverage for windfall elimination provision.


PiaParamsTR Members Public Data Members

PiaParamsTR Members Public Data Members
PiaParamsTR Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
YEAR1999 | Year of extra 0.1 percent benefit increase.
age16 | Age 16.
age18 | Age 18.
age19 | Age 19.
age199 | Age 199 (impossible age).
age22 | Age 22.
age50 | Age 50.
age60 | Age 60.
age62 | Age 62.
age621 | Age 62 and 1 month.
age65 | Age 65.
age65_10 | Age 65 and 10 months.
age65_2 | Age 65 and 2 months.
age65_4 | Age 65 and 4 months.
age65_6 | Age 65 and 6 months.
age65_8 | Age 65 and 8 months.
age66 | Age 66.
age66_10 | Age 66 and 10 months.
age66_2 | Age 66 and 2 months.
age66_4 | Age 66 and 4 months.
age66_6 | Age 66 and 6 months.
age66_8 | Age 66 and 8 months.
age67 | Age 67.
age70 | Age 70.
age72 | Age 72.
age75 | Age 75.
amend01 | The date of special 0.1 percent benefit increase.
amend118_273 | The date of WEP no longer being used for benefit computations.
amend50 | The date of 1950 amendments.
amend52 | The date of 1952 amendments.
amend54 | The date of 1954 amendments.
amend56 | The date of 1956 amendments.
amend561 | First birth date for which age 62 is effective for females.
amend562 | Second birth date for which age 62 is effective for females.
amend58 | The date of 1958 amendments.
amend61 | The date of 1961 amendments.
amend611 | First birth date for which age 62 is effective for males.
amend612 | Second birth date for which age 62 is effective for males.
amend651 | The date of 1965 amendments for benefit increase.
amend652 | The date of 1965 amendments for change to age 60.
amend653 | The date of 1965 amendments for old start.
amend671 | The date of 1967 amendments for old start.
amend672 | The date of 1967 amendments for benefit increase.
amend69 | The date of 1969 amendments.
amend70 | The date of 1970 amendments.
amend721 | The date of 1972 amendments for benefit increase.
amend722 | The date of 1972 amendments for special minimum.
amend741 | The date of 1974 amendments for partial increase.
amend742 | The date of 1974 amendments for full increase.
amend771 | The date of 1977 amendments for frozen pia table.
amend772 | The date of 1977 amendments for start of wage indexing.
amend80 | The date of 1980 amendments.
amend811 | The date of birth for age 62 and 1 month in 1981 amendments.
amend812 | The date of 1981 amendments (month, day, and year).
amend813 | The date of 1981 amendments (month and year).
amend82 | The date of 1982 amendments.
amend83 | The date of 1983 amendments.
amend88 | The date of 1988 amendments.
amend90 | The date of 1990 amendments.
amtperincyr | Amount per old start increment year.
arFactorWid285 | Total actuarial reduction factor for aged widow(er)s.
arMonthlyFactor65_67 | Monthly actuarial reduction factor between ages 65 and 67.
arMonthlyFactorOab62_65 | Monthly actuarial reduction factor between ages 62 and 65.
arMonthlyFactorSpouse62_65 | Monthly actuarial reduction factor for aged spouses between ages 62 and 65.
beninc74 | Temporary benefit increase, March-May 1974.
bpMfbOut | Table of mfb formula bend points.
bpPiaOut | Table of pia formula bend points.
factor150 | Factor for calculating mfbs.
factor175 | Factor for calculating mfbs.
factor50 | Factor for calculating life benefits.
factor75 | Factor for calculating survivor benefits.
factor825 | Factor for calculating widow(er) benefits.
maxMonthsAr62_65 | Maximum number of months of actuarial reduction between ages 62 and 65.
maxMonthsAr62_67 | Maximum number of months of actuarial reduction between ages 62 and 67.
maxMonthsAr65_67 | Maximum number of months of actuarial reduction between ages 65 and 67.
percPiaOut | Table of pia formula percentages.
qcamt | Array of amounts required for quarter of coverage.
qtr184 | Starting point of deemed insured.
year37qtr1 | First quarter for which a quarter of coverage could be earned.


PiaParamsTR Members Public Methods

PiaParamsTR Members Public Methods
PiaParamsTR Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PiaParams | Initializes a PiaParams, with or without a first year of projection.
PiaParamsPL | Initializes a PiaParamsPL, with or without a first year of projection.
PiaParamsTR | Constructor.
applyCola | Returns benefit amount increased by cola.
applyCola99 | Returns benefit amount increased by special 1999 cola (includes extra 0.1 percent increase).
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb99 | Returns maximum family benefit amount increased by special 1999 cola (includes extra 0.1 percent increase), with check that result is at least 150 percent of pia.
benincCatchUp | Applies catch-up benefit increases.
birthDateFRA | Returns the earliest birthdate for someone to be over NRA at the end of a year.
childAgeForMFCal | Returns oldest age of child for which parent can get young wife/husband or mother/father benefits.
deconvertPia | Deconverts PIA back to year of eligibility.
deemedQcReqCal | Returns number of quarters of coverage required for deemed insured status.
doRecalc | Returns true if should recalculate PIAs this year because of a newly effective law change, else false.
earlyAgeDisWidCal | Returns earliest possible disabled widow(er)'s retirement age.
earlyAgeOabCal | Returns earliest possible retirement age for oab or aged spouse.
earlyAgeOabCal | Sets earliest possible retirement age for old-age benie or aged spouse.
earlyAgeOabCalPL | Returns earliest possible retirement age for old-age benie or aged spouse, based on present law.
earlyAgeWidCal | Returns earliest possible aged widow(er)'s retirement age.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCalPL | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow(er) benefit before age reduction.
factorAgedWidCal | Returns factor for widow/widower benefit before age reduction.
factorAgedWidCalPL | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Returns reduction factor for wife/husband.
factorArAgedSpouseCal | Returns reduction factor for wife/husband.
factorArAgedSpouseCalPL | Calculates reduction factor for wife/husband. Assumes a maximum of 60 months of reduction.
factorArCal | Returns reduction factor for OAB.
factorArCal | Calculates reduction factor for OAB.
factorArCalPL | Calculates reduction factor for OAB or DIB.
factorArDisWidCal | Calculates reduction factor for disabled widow(er).
factorArWidCal | Calculates reduction factor for aged widow(er).
factorDisWidCal | Returns factor for disabled widow(er) benefit before age reduction.
factorDisWidCal | Returns factor for disabled widow/widower benefit before age reduction.
factorDisWidCalPL | Returns factor for disabled widow/widower benefit before age reduction.
factorDriCal | Calculates delayed retirement increment factor for OAB.
factorYngLifeCal | Calculates reduction factor for young life benie.
factorYngSurvCal | Calculates reduction factor for young survivor.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDIPL | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalPL | Returns full retirement age based on present law.
getAltNum | Returns the Trustees Report assumption.
getAverageWage | Returns title of average wage assumptions.
getBase77 | Returns one old-law wage base.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBase77Array | Returns the array of old-law wage bases.
getBaseHi | Returns one HI wage base.
getBaseHiArray | Returns the array of HI wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBendOS | Returns a bend point for old-start PIB formula.
getBenefitInc | Returns title of benefit increase assumptions.
getCatchup | Returns catch-up benefit increases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmountPL | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getCpiinc | Returns one benefit increase.
getCpiincArray | Returns the array of benefit increases.
getFq | Returns one average wage for indexing.
getFqArray | Returns array of average wages for indexing.
getFqBppia | Returns series used for indexing pia formula bend points.
getFqBppia | Returns series of average wages used for indexing pia formula bend points.
getFqIndex | Returns series used for indexing an earnings record.
getFqIndex | Returns series of average wages used for indexing an earnings record.
getFqinc | Returns one increase in average wage for indexing.
getFqincArray | Returns array of increases in average wage for indexing.
getIstart | Returns current year.
getMarrLengthForDivBen | Returns the number of years of marraige needed to be eligible for a divroced spouse benefit.
getMarrLengthForDivBen | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMarrLengthForDivBenPL | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year.
getMaxChildcareAgePL | Returns maximum age of child for childcare dropout year.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYearsPL | Returns maximum number of childcare dropout years.
getMaxyear | Returns maximum possible year.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB for the given year.
getMonthBeninc | Returns one month of benefit increase.
getMonthBenincArray | Returns array of months of benefit increase.
getPercOS | Returns old-start PIB formula percentage.
getPercSpecMin | Returns percent of old-law base required for year of coverage.
getPercSpecMinArray | Returns array of percents of old-law base required for year of coverage.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinPerc | Returns percentage of old-law base required for year of coverage.
getSpecMinPia | Returns special minimum pia as of a specified month.
getYocAmountSpecMin | Returns amount required for year of coverage for special minimum.
getYocAmountSpecMinArray | Returns array of amounts required for year of coverage for special minimum.
getYocAmountWindfallArray | Returns array of amounts required for year of coverage for windfall elimination.
initdata | Initializes some data.
isApplicableCola99 | Checks for applicability of special 1999 increase (with extra 0.1 percent).
lastAmw | Finds last AMW in old-law table.
lumpSum | Returns amount of lump sum benefit.
maxChildAge | Returns maximum child beneficiary age.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAgePL | Returns maximum DI beneficiary age at end of year, based on present law.
monthsArAgedSpouseCal | Calculates number of months of actuarial reduction for aged wife/husband.
monthsArCal | Calculates number of months of actuarial reduction for OAB.
monthsArDICal | Calculates number of months of reduction for disabled worker.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er).
monthsArWidCal | Calculates number of months of actuarial reduction for aged widow(er).
monthsDriCal | Calculates number of months of delayed retirement credit for OAB.
needColaCap | Returns true if a cola cap is required.
needColaCap | Returns true if a cola cap is required.
percPiaCal | Sets benefit formula percents.
projectCpiinc | Projects amounts dependent on benefit increases.
projectCpiinc | Projects amounts dependent on benefit increases.
projectFq | Projects amounts dependent on the average annual wage.
projectPerc | Projects benefit formula percentages.
projectSpecMin | Projects special minimum amounts.
qcCal | Returns number of quarters of coverage for one year, applying annual test.
resizeSpecMin | Resizes special minimum arrays.
retCredit | Returns amount of monthly delayed retirement credit.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCalPL | Returns widow(er) benefit reduced for RIB-LIM.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setData | Sets data from historical average wages and benefit increase file.
setData | Sets data from historical average wages and benefit increase file.
setHistFqinc | Sets historical average wage increases.
setIstart | Sets the first projected year, including for members.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
setNoChange | Sets indicators for no change allowed.
specMinAmountCal | Sets amount per year of coverage in special minimum.
specMinAmountCal | Returns amount per year of coverage in special minimum.
specMinAmountCalPL | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYearsPL | Returns maximum number of usable years for special minimum.
unApplyCola | Returns benefit amount decreased by cola.
unApplyCola99 | Returns benefit amount decreased by special 1999 cola (includes extra 0.1 percent decrease.)
unbiCatchUp | Divides out catch-up benefit increases.
updateBases | Updates wage bases.
updateBases | Updates wage bases.
updateCpiinc | Updates benefit increases.
updateFq | Updates average wages, using specified amounts.
updateFqinc | Updates increases in average wages, using specified percentages.
updateYocAmountSpecMin | Updates amounts required for special minimum year of coverage.
~PiaParamsTR | Destructor.


Legend

Legend
PiaRead Members
Legend
Constructor
virtual
Data Member
protected


PiaRead Members Protected Data Members

PiaRead Members Protected Data Members
PiaRead Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
secondaryArray | Array of Secondary benefit information.
userAssumptions | User-specified assumptions.
widowArray | Widow and other family member calculation data.
widowDataArray | Widow and other family member basic data.
workerData | Worker data.


PiaRead Members Public Data Members

PiaRead Members Public Data Members
PiaRead Members Legend
Public Data Members
Name | Description
inputLine | Input line.
lineType | Type of input line.
unusedLine | True if a line has been gotten from the file but not used.


PiaRead Members Public Methods

PiaRead Members Public Methods
PiaRead Members Legend
Public Methods
Name | Description
PiaRead | Initializes references to data.
getEarnWidth | Returns width of earnings or base field.
getWidth | Returns width of field for line number in file.
parseAssump | Parses assumption indicators.
parseAw | Parses projected average wage increases.
parseBack | Parses backward projection amounts.
parseBases | Parses up to 20 OASDI wage bases.
parseBases77 | Parses up to 20 old-law wage bases.
parseBendate | Parses date of benefit.
parseBi | Parses up to 20 projected benefit increases.
parseBlind | Parses blind indicator.
parseCatchup | Parses 8 catch-up benefit increases.
parseChildCareYears | Parses annual child care years.
parseDeath | Parses date of death.
parseDeemed | Parses deemed insured indicator.
parseDisab1 | Parses disability information for most recent period.
parseDisab2 | Parses disability information for second most recent period.
parseEarnHi | Parses up to 10 years of Medicare earnings.
parseEarnOasdi | Parses OASDI-covered earnings for up to 10 years.
parseEarnType | Parses type of earnings vector.
parseFamilyMember | Parses family member's information.
parseFwrd | Parses forward projection amounts.
parseMsdates | Parses military service dates.
parseNhaddr | Parses worker's address.
parseNhname | Parses worker's name.
parseOabent | Parses oab entitlement prior to most recent disability.
parsePebes | Parses Social Security Statement information.
parsePubpen | Parses noncovered pension.
parsePubpenReservist | Parses noncovered pension after military reservist pension removal.
parseQc1 | Parses summary quarters of coverage.
parseQc2 | Parses annual quarters of coverage.
parseSsn | Parses Social Security number, sex, and date of birth.
parseTaxType | Parses type of taxes.
parseTitleaw | Parses title of projected average wage increases.
parseTitlebi | Parses title of projected benefit increases.
parseTob | Parses type of benefit and date of entitlement.
parseTotalize | Parses totalization indicator.
parseYears | Parses years of earnings.
read | Reads case from file.
setEarnProjectYears | Sets the years in the EarnProject class.
setEarnWidth | Sets width of earnings or base field.
setPebsData | Sets data for Social Security Statement.
setWidth | Sets width of field for line number in file,


Legend

Legend
PiaReadAny Members
Legend
Constructor
Data Member
protected


PiaReadAny Members Protected Data Members

PiaReadAny Members Protected Data Members
PiaReadAny Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
secondaryArray | Array of Secondary benefit information.
userAssumptions | User-specified assumptions.
widowArray | Widow and other family member calculation data.
widowDataArray | Widow and other family member basic data.
workerData | Worker data.


PiaReadAny Members Public Data Members

PiaReadAny Members Public Data Members
PiaReadAny Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
inputLine | Input line.
lineType | Type of input line.
unusedLine | True if a line has been gotten from the file but not used.


PiaReadAny Members Public Methods

PiaReadAny Members Public Methods
PiaReadAny Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PiaReadAny | Initializes references to data.
getEarnWidth | Returns width of earnings or base field.
getWidth | Returns width of field for line number in file.
parseAssump | Parses assumption indicators.
parseAw | Parses projected average wage increases.
parseBack | Parses backward projection amounts.
parseBases | Parses up to 20 OASDI wage bases.
parseBases77 | Parses up to 20 old-law wage bases.
parseBendate | Parses date of benefit.
parseBi | Parses up to 20 projected benefit increases.
parseBlind | Parses blind indicator.
parseCatchup | Parses 8 catch-up benefit increases.
parseChildCareYears | Parses annual child care years.
parseDeath | Parses date of death.
parseDeemed | Parses deemed insured indicator.
parseDisab1 | Parses disability information for most recent period.
parseDisab2 | Parses disability information for second most recent period.
parseEarnHi | Parses up to 10 years of Medicare earnings.
parseEarnOasdi | Parses OASDI-covered earnings for up to 10 years.
parseEarnType | Parses type of earnings vector.
parseFamilyMember | Parses family member's information.
parseFwrd | Parses forward projection amounts.
parseMsdates | Parses military service dates.
parseNhaddr | Parses worker's address.
parseNhname | Parses worker's name.
parseOabent | Parses oab entitlement prior to most recent disability.
parsePebes | Parses Social Security Statement information.
parsePubpen | Parses noncovered pension.
parsePubpenReservist | Parses noncovered pension after military reservist pension removal.
parseQc1 | Parses summary quarters of coverage.
parseQc2 | Parses annual quarters of coverage.
parseSsn | Parses Social Security number, sex, and date of birth.
parseTaxType | Parses type of taxes.
parseTitleaw | Parses title of projected average wage increases.
parseTitlebi | Parses title of projected benefit increases.
parseTob | Parses type of benefit and date of entitlement.
parseTotalize | Parses totalization indicator.
parseYears | Parses years of earnings.
read | Reads case from file.
setEarnProjectYears | Sets the years in the EarnProject class.
setEarnWidth | Sets width of earnings or base field.
setPebsData | Sets data for Social Security Statement.
setWidth | Sets width of field for line number in file,


Legend

Legend
PiaTable1Page Members
Legend
Constructor
Data Member
protected


PiaTable1Page Members Protected Data Members

PiaTable1Page Members Protected Data Members
PiaTable1Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


PiaTable1Page Members Protected Methods

PiaTable1Page Members Protected Methods
PiaTable1Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


PiaTable1Page Members Public Data Members

PiaTable1Page Members Public Data Members
PiaTable1Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


PiaTable1Page Members Public Methods

PiaTable1Page Members Public Methods
PiaTable1Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PiaTable1Page | Initializes PiaTable1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares pia table strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~PiaTable1Page | Destructor.


Legend

Legend
PiaTable2Page Members
Legend
Constructor
Data Member
protected


PiaTable2Page Members Protected Data Members

PiaTable2Page Members Protected Data Members
PiaTable2Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


PiaTable2Page Members Protected Methods

PiaTable2Page Members Protected Methods
PiaTable2Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


PiaTable2Page Members Public Data Members

PiaTable2Page Members Public Data Members
PiaTable2Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


PiaTable2Page Members Public Methods

PiaTable2Page Members Public Methods
PiaTable2Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PiaTable2Page | Initializes PiaTable2Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares pia table strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~PiaTable2Page | Destructor.


PiaTable Members Enumerations

PiaTable Members Enumerations
PiaTable Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
PiaTable Members
Legend
Constructor
virtual
Data Member
protected
Enumeration


PiaTable Members Protected Data Members

PiaTable Members Protected Data Members
PiaTable Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
iamemax | Maximum ame in pia interval.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.


PiaTable Members Public Data Members

PiaTable Members Public Data Members
PiaTable Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.


PiaTable Members Public Methods

PiaTable Members Public Methods
PiaTable Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PiaTable | Initializes this instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Computes Pia Table PIA.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~PiaTable | Destructor.


PiaTableLC Members Enumerations

PiaTableLC Members Enumerations
PiaTableLC Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
PiaTableLC Members
Legend
Constructor
abstract
virtual
Data Member
protected
Enumeration


PiaTableLC Members Protected Data Members

PiaTableLC Members Protected Data Members
PiaTableLC Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
iamemax | Maximum ame in pia interval.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.


PiaTableLC Members Public Data Members

PiaTableLC Members Public Data Members
PiaTableLC Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.


PiaTableLC Members Public Methods

PiaTableLC Members Public Methods
PiaTableLC Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PiaTableLC | Initializes a PiaTableLC instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Calculates pia and mfb for this method.
calculate | Computes Pia Table PIA.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~PiaTableLC | Destructor.


Legend

Legend
PiaWrite Members
Legend
Constructor
virtual
Data Member
protected


PiaWrite Members Protected Data Members

PiaWrite Members Protected Data Members
PiaWrite Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
secondaryArray | Array of Secondary benefit information.
userAssumptions | User-specified assumptions.
widowArray | Widow and other family member calculation data.
widowDataArray | Widow and other family member basic data.
workerData | Worker data.


PiaWrite Members Public Methods

PiaWrite Members Public Methods
PiaWrite Members Legend
Public Methods
Name | Description
PiaWrite | Initializes references to data.
getEarnWidth | Returns width of earnings or base field.
getNumDecimals | Returns number of decimal places for earnings or base.
getWidth | Returns width of field for line number in file.
setEarnWidth | Sets width of earnings or base field.
setNumDecimals | Sets number of decimal places for earnings or base.
setWidth | Sets width of field for line number in file.
write | Saves a case to disk.
writeAssump | Writes assumption indicators.
writeAw | Writes average wage increase assumptions.
writeBack | Writes backward projection amounts.
writeBases | Writes wage base assumptions.
writeBenDate | Writes date of benefit.
writeBi | Writes benefit increase assumptions.
writeBlind | Writes blind indicator.
writeChildCareYears | Writes annual child care years.
writeDeath | Writes date of death.
writeDeemed | Writes deemed insured indicator.
writeDisab1 | Writes disability information for most recent period.
writeDisab2 | Writes disability information for second most recent period.
writeEarnHi | Writes Medicare earnings.
writeEarnOasdi | Writes OASDI-covered earnings for all years, using unprojected earnings array.
writeEarnType | Writes type of earnings for all years.
writeFamilyMember | Writes information for one family member.
writeFamilyMembers | Writes information for all family members.
writeFwrd | Writes forward projection amounts.
writeMsdates | Writes military service dates.
writeNhaddr | Writes address of worker.
writeNhname | Writes name of worker.
writeOabEnt | Writes oab entitlement prior to most recent dib.
writePebes | Writes pebes information.
writePubpen | Writes noncovered pension.
writePubpenReservist | Writes noncovered pension after military reservist pension removal.
writeQc1 | Writes summary quarters of coverage.
writeQc2 | Writes annual quarters of coverage.
writeRailRoad | Writes railroad earnings and qcs.
writeSsn | Writes Social Security number, sex, and date of birth.
writeTaxType | Writes type of taxes for all years.
writeTob | Writes type of benefit and date of entitlement.
writeTotalize | Writes totalization indicator.
writeYears | Writes years of earnings.


Legend

Legend
PiaWriteAny Members
Legend
Constructor
Data Member
protected


PiaWriteAny Members Protected Data Members

PiaWriteAny Members Protected Data Members
PiaWriteAny Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
secondaryArray | Array of Secondary benefit information.
userAssumptions | User-specified assumptions.
widowArray | Widow and other family member calculation data.
widowDataArray | Widow and other family member basic data.
workerData | Worker data.


PiaWriteAny Members Public Methods

PiaWriteAny Members Public Methods
PiaWriteAny Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PiaWriteAny | Initializes references to data.
getEarnWidth | Returns width of earnings or base field.
getNumDecimals | Returns number of decimal places for earnings or base.
getWidth | Returns width of field for line number in file.
setEarnWidth | Sets width of earnings or base field.
setNumDecimals | Sets number of decimal places for earnings or base.
setWidth | Sets width of field for line number in file.
write | Saves a case to disk.
writeAssump | Writes assumption indicators.
writeAw | Writes average wage increase assumptions.
writeBack | Writes backward projection amounts.
writeBases | Writes wage base assumptions.
writeBenDate | Writes date of benefit.
writeBi | Writes benefit increase assumptions.
writeBlind | Writes blind indicator.
writeChildCareYears | Writes annual child care years.
writeDeath | Writes date of death.
writeDeemed | Writes deemed insured indicator.
writeDisab1 | Writes disability information for most recent period.
writeDisab2 | Writes disability information for second most recent period.
writeEarnHi | Writes Medicare earnings.
writeEarnOasdi | Writes earnings for all years, using projected earnings array.
writeEarnType | Writes type of earnings for all years.
writeFamilyMember | Writes information for one family member.
writeFamilyMembers | Writes information for all family members.
writeFwrd | Writes forward projection amounts.
writeMsdates | Writes military service dates.
writeNhaddr | Writes address of worker.
writeNhname | Writes name of worker.
writeOabEnt | Writes oab entitlement prior to most recent dib.
writePebes | Writes pebes information.
writePubpen | Writes noncovered pension.
writePubpenReservist | Writes noncovered pension after military reservist pension removal.
writeQc1 | Writes summary quarters of coverage.
writeQc2 | Writes annual quarters of coverage.
writeRailRoad | Writes railroad earnings and qcs.
writeSsn | Writes Social Security number, sex, and date of birth.
writeTaxType | Writes type of taxes for all years.
writeTob | Writes type of benefit and date of entitlement.
writeTotalize | Writes totalization indicator.
writeYears | Writes years of earnings.


Legend

Legend
Pib50Mfb Members
Legend
Method


Pib50Mfb Members Public Methods

Pib50Mfb Members Public Methods
Pib50Mfb Members Legend
Public Methods
Name | Description
getAt | Returns 1950 conversion table mfb.


Legend

Legend
Pib50Pib Members
Legend
Method


Pib50Pib Members Public Methods

Pib50Pib Members Public Methods
Pib50Pib Members Legend
Public Methods
Name | Description
getAt | Returns 1950 conversion table pib.


Legend

Legend
Pib52Ame Members
Legend
Method


Pib52Ame Members Public Methods

Pib52Ame Members Public Methods
Pib52Ame Members Legend
Public Methods
Name | Description
getAt | Returns 1952 conversion table mfb.


Legend

Legend
Pib52Mfb Members
Legend
Method


Pib52Mfb Members Public Methods

Pib52Mfb Members Public Methods
Pib52Mfb Members Legend
Public Methods
Name | Description
getAt | Returns 1952 conversion table mfb.


Legend

Legend
Pib54Ame Members
Legend
Method


Pib54Ame Members Public Methods

Pib54Ame Members Public Methods
Pib54Ame Members Legend
Public Methods
Name | Description
getAt | Returns 1954 conversion table ame.


Legend

Legend
Pib54Mfb Members
Legend
Method


Pib54Mfb Members Public Methods

Pib54Mfb Members Public Methods
Pib54Mfb Members Legend
Public Methods
Name | Description
getAt | Returns 1954 conversion table mfb.


Legend

Legend
Pib54Pia Members
Legend
Method


Pib54Pia Members Public Methods

Pib54Pia Members Public Methods
Pib54Pia Members Legend
Public Methods
Name | Description
getAt | Returns 1954 conversion table pia.


Legend

Legend
Pib58Ame Members
Legend
Method


Pib58Ame Members Public Methods

Pib58Ame Members Public Methods
Pib58Ame Members Legend
Public Methods
Name | Description
getAt | Returns 1958 conversion table ame.


Legend

Legend
Pib58Pib Members
Legend
Method


Pib58Pib Members Public Methods

Pib58Pib Members Public Methods
Pib58Pib Members Legend
Public Methods
Name | Description
getAt | Returns 1958 conversion table pib.


Legend

Legend
Pifc Members
Legend
Constructor


Pifc Members Public Methods

Pifc Members Public Methods
Pifc Members Legend
Public Methods
Name | Description
Pifc | Initializes pia factor code.
get | Returns the pifc code.
isColable | Returns true if able to apply cola to this benefit.
isNewMfb | Returns true if wage-indexed mfb applies to this benefit.
pifcCal | Calculates applicable pifc.
set | Sets the pifc code.


Legend

Legend
PortionAime Members
Legend
Constructor
Operator


PortionAime Members Public Methods

PortionAime Members Public Methods
PortionAime Members Legend
Public Methods
Name | Description
PortionAime | Constructor.
as_array | Returns AIME portions as a simple array.
begin | This is the overview for the begin method overload.
deleteContents | Zeroes out all values.
end | This is the overview for the end method overload.
getNumPart | Returns the number of AIME portions.
max_size | Returns maximum number of AIME portions.
setNumPart | Sets number of AIME portions.
size | Returns number of AIME portions.
~PortionAime | Destroys bend point array.


PortionAime Members Public Nested Types

PortionAime Members Public Nested Types
PortionAime Members
Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of size in this array.
value_type | The type of data in this array.


Legend

Legend
PresValFacs Members
Legend
Constructor
Data Member
Operator


PresValFacs Members Public Data Members

PresValFacs Members Public Data Members
PresValFacs Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


PresValFacs Members Public Friends

PresValFacs Members Public Friends
PresValFacs Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


PresValFacs Members Public Methods

PresValFacs Members Public Methods
PresValFacs Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
PresValFacs | Constructor.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects present value factors for the given interest rates.
~PresValFacs | Destroys present value factors array.


Psa Members Enumerations

Psa Members Enumerations
Psa Members Legend
Enumerations
Name | Description
AnnuityType | Type of annuity.
DimLimits | Constants for dimensioning.
InvestmentType | Types of investments.
PsaSexType | The sex types for PSA annuities.
UnisexType | Codes for using unisex annuity factors.


Legend

Legend
Psa Members
Legend
Constructor
Enumeration
Data Member
protected


Psa Members Protected Methods

Psa Members Protected Methods
Psa Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
getAgeIndex | Returns an age converted to an age index.
getLimitedYear | Returns a year converted to a limited year.
getSexType | Returns the sex code to use for annuities for a specified person.
interpolateFactors | Interpolates the JS annuity factors since the input file only has data for every 10th year.


Psa Members Public Data Members

Psa Members Public Data Members
Psa Members Legend
Public Data Members
Name | Description
contribAge | The age splits for contribution rates, when using rates based on age.
contribPerc | Contribution rates when using rates based on age, as opposed to using the same set rates for everybody.


Psa Members Public Methods

Psa Members Public Methods
Psa Members Legend
Public Methods
Name | Description
Psa | Constructor.
annuityCal | Calculate an initial psa (monthly) annuity.
annuityRevCal | Calculate the ammount that a person would get if he sold back the specified (monthly) annuity.
contribCal | Calculates contribution to psa for one year, first limiting the earnings to the maximum taxable for the year of contribution.
getAdminFee | Returns the annual administrative fee.
getContribRate | Returns one psa contribution rate for a specified year.
getInvestPerc | Returns percentage of contributions that go into the investment.
getMean | Returns the mean of the normal distribution for bonds.
getMngmtFee | Returns the annual management fee.
getPercToSpouse | Returns percentage of contribution going to spouse, if any.
getStdDev | Returns standard deviation of the normal distribution for specified type.
setParameters | Sets psa parameters from the lawchange file.
~Psa | Destructor.


Legend

Legend
PunctFacet Members
Legend
Data Member
Method


PunctFacet Members Public Data Members

PunctFacet Members Public Data Members
PunctFacet Members Legend
Public Data Members
Name | Description
yearStr | String representations of all the years in the output range.


PunctFacet Members Public Methods

PunctFacet Members Public Methods
PunctFacet Members Legend
Public Methods
Name | Description
do_grouping | Returns specification of 3 digits per thousands separator.
getYear | Returns a string representation of the specified year.


Legend

Legend
Qc Members
Legend
Data Member
Method


Qc Members Public Data Members

Qc Members Public Data Members
Qc Members Legend
Public Data Members
Name | Description
MAXQCSINYEAR | The maximum number of qcs in one year (4).


Qc Members Public Methods

Qc Members Public Methods
Qc Members Legend
Public Methods
Name | Description
check | Checks annual quarters of coverage for one year.
qcCal | Returns number of quarters of coverage for one year, applying annual test.


Legend

Legend
Qcamt Members
Legend
Constructor
Data Member
Operator


Qcamt Members Public Data Members

Qcamt Members Public Data Members
Qcamt Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
AUTO_YEAR | The year when automatic increases started for the quarter of coverage amount.
baseYear | Base year of data.
qcamt1977 | The quarter of coverage amount prior to 1978.
qcamt1978 | The quarter of coverage amount in 1978.
theData | Vector of doubles.


Qcamt Members Public Friends

Qcamt Members Public Friends
Qcamt Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


Qcamt Members Public Methods

Qcamt Members Public Methods
Qcamt Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
Qcamt | Initializes a Qcamt, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects quarter of coverage amounts.
~Qcamt | Destructor.


Legend

Legend
QcArray Members
Legend
Constructor


QcArray Members Public Friends

QcArray Members Public Friends
QcArray Members
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


QcArray Members Public Methods

QcArray Members Public Methods
QcArray Members Legend
Public Methods
Name | Description
QcArray | Initializes a QcArray, either with specified years or from another QcArray.
accumulate | Sums quarters of coverage over a period of years or quarters.
assign | Sets values for a specified range of years.
deleteContents | Sets values to zero.
get | Returns the number of quarters of coverage for one year.
getLastYear | Returns the last year of data.
set | Sets the number of quarters of coverage for one year.
toString | Converts a quarters of coverage array to a string.
~QcArray | Deletes allocated memory.


Legend

Legend
QcPacked Members
Legend
Constructor
Data Member


QcPacked Members Public Data Members

QcPacked Members Public Data Members
QcPacked Members Legend
Public Data Members
Name | Description
NUM_QCS | Number of elements in this class.


QcPacked Members Public Friends

QcPacked Members Public Friends
QcPacked Members
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


QcPacked Members Public Methods

QcPacked Members Public Methods
QcPacked Members Legend
Public Methods
Name | Description
QcPacked | Initialize all values to 0.
get | Return a quarter of coverage amount.
set | Set a quarter of coverage amount.


Legend

Legend
QtrYear Members
Legend
Constructor
Operator


QtrYear Members Public Friends

QtrYear Members Public Friends
QtrYear Members
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


QtrYear Members Public Methods

QtrYear Members Public Methods
QtrYear Members Legend
Public Methods
Name | Description
QtrYear | Initializes a QtrYear, either as a default or from a variety of calendar instances.
add | Adds a quarterly time period to this instance.
check | Checks for valid quarter and year.
deleteContents | Zeroes quarter and year.
diff | Calculates difference of two quarter-year periods as an integer number of quarters.
getQuarter | Returns quarter (0-3).
getYear | Returns year.
qtrCheck | Checks for quarter in bounds.
setQuarter | Sets quarter.
setYear | Sets year.
subtract | Subtracts a quarterly time period from this one.
toDateMoyr | Converts this quarter and year to a month and year.
toString | Returns string representation of quarter and year.
yearCheck | Checks for year in bounds.
~QtrYear | Destructor.


Legend

Legend
RailRoadData Members
Legend
Constructor
Data Member
Operator


RailRoadData Members Public Data Members

RailRoadData Members Public Data Members
RailRoadData Members Legend
Public Data Members
Name | Description
earningsArray | Annual railroad earnings, starting in 1951.
qcArray | Annual railroad quarters of coverage, from 1951 to 1977.


RailRoadData Members Public Friends

RailRoadData Members Public Friends
RailRoadData Members
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


RailRoadData Members Public Methods

RailRoadData Members Public Methods
RailRoadData Members Legend
Public Methods
Name | Description
RailRoadData | Initializes last year of railroad data.
deleteContents | Zeroes out all railroad data.
get3750String | Returns string of pre-1951 QCs and earnings.
getDecadeEarningsString | Returns string of decade of earnings.
getDecades | Returns number of decades of post-1950 earnings.
getEarn3750 | Returns total earnings 1937 to 1950.
getFirstYear | Returns first year of earnings.
getLastYear | Returns last year of earnings.
getQc3750 | Returns total quarters of coverage 1937 to 1950.
getQcString | Returns string of qcs.
getYearsString | Returns string of first and last years of earnings.
isNonzero | Returns true if there are any railroad earnings.
parse3750 | Parses line of pre-1951 QCs and earnings.
parseEarnings | Parses one line of earnings.
parseQcs | Parses line of qcs.
parseYears | Parses line of first and last years.
railroadYearCheck | Checks the year of railroad earnings.
setEarn3750 | Sets total earnings 1937 to 1950.
setFirstYear | Sets first year of earnings.
setLastYear | Sets last year of earnings.
setQc3750 | Sets total quarters of coverage 1937 to 1950.
~RailRoadData | Destroys railroad data.


Legend

Legend
ReindWid1Page Members
Legend
Constructor
Data Member
protected


ReindWid1Page Members Protected Data Members

ReindWid1Page Members Protected Data Members
ReindWid1Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


ReindWid1Page Members Protected Methods

ReindWid1Page Members Protected Methods
ReindWid1Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


ReindWid1Page Members Public Data Members

ReindWid1Page Members Public Data Members
ReindWid1Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
reindWid | Reindexed widow(er) calculation.


ReindWid1Page Members Public Methods

ReindWid1Page Members Public Methods
ReindWid1Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
ReindWid1Page | Initializes ReindWid1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares reindexed widow strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~ReindWid1Page | Destructor.


Legend

Legend
ReindWid2Page Members
Legend
Constructor
Data Member
protected


ReindWid2Page Members Protected Data Members

ReindWid2Page Members Protected Data Members
ReindWid2Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


ReindWid2Page Members Protected Methods

ReindWid2Page Members Protected Methods
ReindWid2Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


ReindWid2Page Members Public Data Members

ReindWid2Page Members Public Data Members
ReindWid2Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.
reindWid | Reindexed widow(er) calculation.


ReindWid2Page Members Public Methods

ReindWid2Page Members Public Methods
ReindWid2Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
ReindWid2Page | Initializes ReindWid2Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares reindexed widow strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~ReindWid2Page | Destructor.


ReindWid Members Enumerations

ReindWid Members Enumerations
ReindWid Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
ReindWid Members
Legend
Constructor
virtual
Data Member
protected
Enumeration


ReindWid Members Protected Data Members

ReindWid Members Protected Data Members
ReindWid Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
widowPiaData | Widow calculation data.
windfallInd | Windfall indicator.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
yearsTotal | Number of years of coverage for windfall elimination.


ReindWid Members Public Data Members

ReindWid Members Public Data Members
ReindWid Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
secondary | Secondary benefit data.
widowData | Widow basic data.


ReindWid Members Public Methods

ReindWid Members Public Methods
ReindWid Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
ReindWid | Initializes this instance.
aimepiaCal | Calculates an AIME PIA under the 1977 law.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
bendPointCal | Projects bend points.
calculate | Computes reindexed widow PIA.
deconvertAme | Deconverts AIME from raw PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getEligYear | Returns eligibility year for reindexed widow(er) calculation.
getIndCap | Returns disability MFB cap indicator.
getIndexYearAvgWage | Returns average wage in indexing year.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
realWageGainAdj | Applies real-wage-gain adjustment.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setEligYear | Sets year of eligibility in reindexed widow guarantee method.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionAime | Calculates portion of aime in each section of pia formula.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setWindfall | Sets windfall indicator in wage-indexed method.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
~ReindWid | Destructor.


ReindWidLC Members Enumerations

ReindWidLC Members Enumerations
ReindWidLC Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
ReindWidLC Members
Legend
Constructor
abstract
virtual
Data Member
protected
Enumeration


ReindWidLC Members Protected Data Members

ReindWidLC Members Protected Data Members
ReindWidLC Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
widowPiaData | Widow calculation data.
windfallInd | Windfall indicator.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
yearsTotal | Number of years of coverage for windfall elimination.


ReindWidLC Members Public Data Members

ReindWidLC Members Public Data Members
ReindWidLC Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.
secondary | Secondary benefit data.
widowData | Widow basic data.


ReindWidLC Members Public Methods

ReindWidLC Members Public Methods
ReindWidLC Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
ReindWidLC | Initializes this instance.
aimepiaCal | Calculates an AIME PIA under the 1977 law.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
bendPointCal | Projects bend points.
calculate | Calculates pia and mfb for this method.
calculate | Computes reindexed widow PIA.
deconvertAme | Deconverts AIME from raw PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getEligYear | Returns eligibility year for reindexed widow(er) calculation.
getIndCap | Returns disability MFB cap indicator.
getIndexYearAvgWage | Returns average wage in indexing year.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
realWageGainAdj | Applies real-wage-gain adjustment.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setEligYear | Sets year of eligibility in reindexed widow guarantee method.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionAime | Calculates portion of aime in each section of pia formula.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setWindfall | Sets windfall indicator in wage-indexed method.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
~ReindWidLC | Destructor.


Legend

Legend
RetireTest Members
Legend
Constructor
Data Member


RetireTest Members Public Data Members

RetireTest Members Public Data Members
RetireTest Members Legend
Public Data Members
Name | Description
rtea62 | Annual amounts under full retirement age.
rtea62m | Monthly amounts under full retirement age.
rtea65 | Annual amounts over full retirement age.
rtea65m | Monthly amounts over full retirement age.
rteaHigh | Annual amounts at second tier (effective 1961-1972).


RetireTest Members Public Methods

RetireTest Members Public Methods
RetireTest Members Legend
Public Methods
Name | Description
RetireTest | Initializes a RetireTest, with or without a first year of data.
earningsTestCal | Returns how many months of person's benefit will be withheld according to the retirement test.
project | Projects all retirement test exempt amounts.


Legend

Legend
Rtea62 Members
Legend
Constructor
Data Member
Operator


Rtea62 Members Public Data Members

Rtea62 Members Public Data Members
Rtea62 Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


Rtea62 Members Public Friends

Rtea62 Members Public Friends
Rtea62 Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


Rtea62 Members Public Methods

Rtea62 Members Public Methods
Rtea62 Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
RtGeneral | Initializes an RtGeneral, with or without a specified first year.
Rtea62 | Initializes an Rtea62, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly retirement test exempt amounts to annual amounts.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
getMaxAgePL | Returns maximum age for which earnings test applies.
project1 | Calculates a monthly retirement test exempt amount using a base amount and a ratio of average wages.


Legend

Legend
Rtea62m Members
Legend
Constructor
Data Member
Operator


Rtea62m Members Public Data Members

Rtea62m Members Public Data Members
Rtea62m Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


Rtea62m Members Public Friends

Rtea62m Members Public Friends
Rtea62m Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


Rtea62m Members Public Methods

Rtea62m Members Public Methods
Rtea62m Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
RtGeneral | Initializes an RtGeneral, with or without a specified first year.
Rtea62m | Initializes an Rtea62m, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly retirement test exempt amounts to annual amounts.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getFraction | Returns x in 1-for-x rule for earnings offset.
getHistAmount | Returns historical monthly exempt amount for specified year.
getLastYear | Returns last year of data.
getMaxAgePL | Returns maximum age for which earnings test applies.
initialize | Initializes historical data.
project | Projects retirement test exempt amounts for ages under full retirement age.
project1 | Calculates a monthly retirement test exempt amount using a base amount and a ratio of average wages.


Legend

Legend
Rtea65 Members
Legend
Constructor
Data Member
Operator


Rtea65 Members Public Data Members

Rtea65 Members Public Data Members
Rtea65 Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


Rtea65 Members Public Friends

Rtea65 Members Public Friends
Rtea65 Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


Rtea65 Members Public Methods

Rtea65 Members Public Methods
Rtea65 Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
RtGeneral | Initializes an RtGeneral, with or without a specified first year.
Rtea65 | Initializes an Rtea65, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly retirement test exempt amounts to annual amounts.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
getMaxAgePL | Returns maximum age for which earnings test applies.
project1 | Calculates a monthly retirement test exempt amount using a base amount and a ratio of average wages.


Legend

Legend
Rtea65m Members
Legend
Constructor
Data Member
Operator


Rtea65m Members Public Data Members

Rtea65m Members Public Data Members
Rtea65m Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


Rtea65m Members Public Friends

Rtea65m Members Public Friends
Rtea65m Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


Rtea65m Members Public Methods

Rtea65m Members Public Methods
Rtea65m Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
RtGeneral | Initializes an RtGeneral, with or without a specified first year.
Rtea65m | Initializes an Rtea65m, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly retirement test exempt amounts to annual amounts.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getFraction | Returns x in 1-for-x rule for earnings offset.
getHistAmount | Returns historical monthly exempt amount for specified year.
getLastYear | Returns last year of data.
getMaxAgePL | Returns maximum age for which earnings test applies.
initialize | Initializes historical data.
project | Projects retirement test exempt amounts for ages 65-69.
project1 | Calculates a monthly retirement test exempt amount using a base amount and a ratio of average wages.


Legend

Legend
RteaHigh Members
Legend
Constructor
Data Member
Operator


RteaHigh Members Public Data Members

RteaHigh Members Public Data Members
RteaHigh Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


RteaHigh Members Public Friends

RteaHigh Members Public Friends
RteaHigh Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


RteaHigh Members Public Methods

RteaHigh Members Public Methods
RteaHigh Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
RtGeneral | Initializes an RtGeneral, with or without a specified first year.
RteaHigh | Initializes historical values for annual test at second tier.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly retirement test exempt amounts to annual amounts.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getFraction | Returns x in 1-for-x rule for earnings offset.
getLastYear | Returns last year of data.
getMaxAgePL | Returns maximum age for which earnings test applies.
initialize | Initializes historical data.
project1 | Calculates a monthly retirement test exempt amount using a base amount and a ratio of average wages.


Legend

Legend
RtGeneral Members
Legend
Constructor
virtual
Data Member
Operator


RtGeneral Members Public Data Members

RtGeneral Members Public Data Members
RtGeneral Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


RtGeneral Members Public Friends

RtGeneral Members Public Friends
RtGeneral Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


RtGeneral Members Public Methods

RtGeneral Members Public Methods
RtGeneral Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
RtGeneral | Initializes an RtGeneral, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly retirement test exempt amounts to annual amounts.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
getMaxAgePL | Returns maximum age for which earnings test applies.
project1 | Calculates a monthly retirement test exempt amount using a base amount and a ratio of average wages.
~RtGeneral | Destructor.


ScaledEarnFactors Members Enumerations

ScaledEarnFactors Members Enumerations
ScaledEarnFactors Members Legend
Enumerations
Name | Description
scaleType | The enumerated scaled earnings type indicator.


Legend

Legend
ScaledEarnFactors Members
Legend
Constructor
Enumeration


ScaledEarnFactors Members Public Methods

ScaledEarnFactors Members Public Methods
ScaledEarnFactors Members Legend
Public Methods
Name | Description
ScaledEarnFactors | Initializes scaled earnings factors.
getAverageEarnFactor | Returns average earner factor for an age.
getDecimals | Returns number of decimal places in output.
getFirstAge | Returns first age.
getHighEarnFactor | Returns high earner factor for an age.
getLastAge | Returns last age.
getLowEarnFactor | Returns low earner factor for an age.
getScaledEarnFactor | Returns a scaled earner factor for an age.
getVeryLowEarnFactor | Returns very low earner factor for an age.
getWidth | Returns width of output.
read | Reads scaled earnings factors from file.
setAverageEarnings | Sets earnings in an EarnProject to average earnings between two ages.
setDecimals | Sets number of decimals in output field.
setHighEarnings | Sets earnings in an EarnProject to high earnings between two ages.
setLowEarnings | Sets earnings in an EarnProject to low earnings between two ages.
setScaledEarnings | Sets earnings in an EarnProject to a particular type of scaled earnings between two ages.
setVeryLowEarnings | Sets earnings in an EarnProject to very low earnings between two ages.
setWidth | Sets width of output field.
write | Writes scaled earnings factors to file.
~ScaledEarnFactors | Destructor.


Legend

Legend
Secondary Members
Legend
Constructor
Data Member


Secondary Members Public Data Members

Secondary Members Public Data Members
Secondary Members Legend
Public Data Members
Name | Description
bic | Type of beneficiary code.
entDate | The date of entitlement.
pifc | Type of pia calculation method.


Secondary Members Public Methods

Secondary Members Public Methods
Secondary Members Legend
Public Methods
Name | Description
Secondary | Initializes codes to blank or zero.
check | Checks data for validity.
deleteContents | Sets codes to blank or zero.
eligibleForMax | Returns true if this benefit is affected by family maximum.
getArf | Returns reduction or increment factor.
getBenefit | Returns benefit after reduction for family maximum but before actuarial reduction.
getBenefitFactor | Returns benefit factor.
getFullBenefit | Returns full-rate benefit (before actuarial reduction or reduction for family maximum).
getMonthsArdri | Returns months of actuarial reduction or increment.
getReducedBenefit | Returns benefit after actuarial reduction and reduction for family maximum.
getRoundedBenefit | Returns benefit after all reductions and rounding.
isWidow | Returns true if widow (aged or disabled); false otherwise.
setArf | Sets reduction or increment factor.
setBenefit | Sets benefit after reduction for family maximum but before actuarial reduction.
setBenefitFactor | Sets benefit factor.
setFullBenefit | Sets full-rate benefit (before actuarial reduction or reduction for family maximum).
setMonthsArdri | Sets months of actuarial reduction or increment.
setReducedBenefit | Sets benefit after actuarial reduction and reduction for family maximum.
setRoundedBenefit | Sets benefit after all reductions and rounding.


Legend

Legend
SecondaryArray Members
Legend
Constructor
Data Member


SecondaryArray Members Public Data Members

SecondaryArray Members Public Data Members
SecondaryArray Members Legend
Public Data Members
Name | Description
secondary | Array of secondary data.


SecondaryArray Members Public Methods

SecondaryArray Members Public Methods
SecondaryArray Members Legend
Public Methods
Name | Description
SecondaryArray | Initializes arrays.
deleteContents | Resets all values to zero.
getTotalFullBenefit | Returns total family benefit before reduction for age or family maximum.
getTotalFullBenefitMax | Returns total family benefit before reduction for age or family maximum, excluding beneficiaries who are not affected by the maximum.
~SecondaryArray | Releases memory.


Sex Members Enumerations

Sex Members Enumerations
Sex Members Legend
Enumerations
Name | Description
sex_type | The enumerated sex indicator.


Legend

Legend
Sex Members
Legend
Constructor
Enumeration
Operator


Sex Members Public Methods

Sex Members Public Methods
Sex Members Legend
Public Methods
Name | Description
Sex | Initializes the Sex, either as a default, or from a Sex instance or a Sex::sex_type.
check | Checks sex.
toString | Returns an output label for the sex of the person.
~Sex | Destructor.


Legend

Legend
Sga Members
Legend
Constructor
Data Member


Sga Members Public Data Members

Sga Members Public Data Members
Sga Members Legend
Public Data Members
Name | Description
sgaBlindA | SGA annual amounts for the blind.
sgaBlindM | SGA monthly (December) amounts for the blind.
sgaMaxA | SGA annual maximum amounts for the non-blind.
sgaMaxM | SGA monthly (December) maximum amounts for the non-blind.
sgaMinA | SGA annual minimum amounts for the non-blind.
sgaMinM | SGA monthly (December) minimum amounts for the non-blind.


Sga Members Public Methods

Sga Members Public Methods
Sga Members Legend
Public Methods
Name | Description
Sga | Constructor.
project | Projects all SGA amounts.


Legend

Legend
SgaBlindA Members
Legend
Constructor
Data Member
protected
Operator


SgaBlindA Members Protected Data Members

SgaBlindA Members Protected Data Members
SgaBlindA Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
FIRST_PROJ_YEAR | First year of projection (2001).


SgaBlindA Members Protected Methods

SgaBlindA Members Protected Methods
SgaBlindA Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
project1 | Calculates a monthly SGA amount using a base amount and a ratio of average wages.


SgaBlindA Members Public Data Members

SgaBlindA Members Public Data Members
SgaBlindA Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


SgaBlindA Members Public Friends

SgaBlindA Members Public Friends
SgaBlindA Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


SgaBlindA Members Public Methods

SgaBlindA Members Public Methods
SgaBlindA Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
SgaBlindA | Constructor.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly SGA amounts to annual amounts, starting with the first projected year.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects SGA amounts.


Legend

Legend
SgaBlindM Members
Legend
Constructor
virtual
Data Member
protected
Operator


SgaBlindM Members Protected Data Members

SgaBlindM Members Protected Data Members
SgaBlindM Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
FIRST_PROJ_YEAR | First year of projection (2001).


SgaBlindM Members Protected Methods

SgaBlindM Members Protected Methods
SgaBlindM Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
project1 | Calculates a monthly SGA amount using a base amount and a ratio of average wages.


SgaBlindM Members Public Data Members

SgaBlindM Members Public Data Members
SgaBlindM Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


SgaBlindM Members Public Friends

SgaBlindM Members Public Friends
SgaBlindM Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


SgaBlindM Members Public Methods

SgaBlindM Members Public Methods
SgaBlindM Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
SgaBlindM | Constructor. Initializes data.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly SGA amounts to annual amounts, starting with the first projected year.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects the SGA monthly amounts.


Legend

Legend
SgaGeneral Members
Legend
Constructor
virtual
Data Member
protected
Operator


SgaGeneral Members Protected Data Members

SgaGeneral Members Protected Data Members
SgaGeneral Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
FIRST_PROJ_YEAR | First year of projection (2001).


SgaGeneral Members Protected Methods

SgaGeneral Members Protected Methods
SgaGeneral Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
project1 | Calculates a monthly SGA amount using a base amount and a ratio of average wages.


SgaGeneral Members Public Data Members

SgaGeneral Members Public Data Members
SgaGeneral Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


SgaGeneral Members Public Friends

SgaGeneral Members Public Friends
SgaGeneral Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


SgaGeneral Members Public Methods

SgaGeneral Members Public Methods
SgaGeneral Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
SgaGeneral | Constructor.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly SGA amounts to annual amounts, starting with the first projected year.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects the SGA monthly amounts.
~SgaGeneral | Destructor.


Legend

Legend
SgaMaxA Members
Legend
Constructor
Data Member
protected
Operator


SgaMaxA Members Protected Data Members

SgaMaxA Members Protected Data Members
SgaMaxA Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
FIRST_PROJ_YEAR | First year of projection (2001).


SgaMaxA Members Protected Methods

SgaMaxA Members Protected Methods
SgaMaxA Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
project1 | Calculates a monthly SGA amount using a base amount and a ratio of average wages.


SgaMaxA Members Public Data Members

SgaMaxA Members Public Data Members
SgaMaxA Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


SgaMaxA Members Public Friends

SgaMaxA Members Public Friends
SgaMaxA Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


SgaMaxA Members Public Methods

SgaMaxA Members Public Methods
SgaMaxA Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
SgaMaxA | Constructor. Initializes data.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly SGA amounts to annual amounts, starting with the first projected year.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects SGA amounts.


Legend

Legend
SgaMaxM Members
Legend
Constructor
virtual
Data Member
protected
Operator


SgaMaxM Members Protected Data Members

SgaMaxM Members Protected Data Members
SgaMaxM Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
FIRST_PROJ_YEAR | First year of projection (2001).


SgaMaxM Members Protected Methods

SgaMaxM Members Protected Methods
SgaMaxM Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
project1 | Calculates a monthly SGA amount using a base amount and a ratio of average wages.


SgaMaxM Members Public Data Members

SgaMaxM Members Public Data Members
SgaMaxM Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


SgaMaxM Members Public Friends

SgaMaxM Members Public Friends
SgaMaxM Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


SgaMaxM Members Public Methods

SgaMaxM Members Public Methods
SgaMaxM Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
SgaMaxM | Constructor. Initializes data.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly SGA amounts to annual amounts, starting with the first projected year.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects the SGA monthly amounts.


Legend

Legend
SgaMinA Members
Legend
Constructor
Data Member
protected
Operator


SgaMinA Members Protected Data Members

SgaMinA Members Protected Data Members
SgaMinA Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
FIRST_PROJ_YEAR | First year of projection (2001).


SgaMinA Members Protected Methods

SgaMinA Members Protected Methods
SgaMinA Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
project1 | Calculates a monthly SGA amount using a base amount and a ratio of average wages.


SgaMinA Members Public Data Members

SgaMinA Members Public Data Members
SgaMinA Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


SgaMinA Members Public Friends

SgaMinA Members Public Friends
SgaMinA Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


SgaMinA Members Public Methods

SgaMinA Members Public Methods
SgaMinA Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
SgaMinA | Constructor. Initializes data.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly SGA amounts to annual amounts, starting with the first projected year.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects SGA amounts.


Legend

Legend
SgaMinM Members
Legend
Constructor
Data Member
protected
Operator


SgaMinM Members Protected Data Members

SgaMinM Members Protected Data Members
SgaMinM Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
FIRST_PROJ_YEAR | First year of projection (2001).


SgaMinM Members Protected Methods

SgaMinM Members Protected Methods
SgaMinM Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
project1 | Calculates a monthly SGA amount using a base amount and a ratio of average wages.


SgaMinM Members Public Data Members

SgaMinM Members Public Data Members
SgaMinM Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


SgaMinM Members Public Friends

SgaMinM Members Public Friends
SgaMinM Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


SgaMinM Members Public Methods

SgaMinM Members Public Methods
SgaMinM Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
SgaMinM | Constructor. Initializes data.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
convertMonthToAnnual | Converts monthly SGA amounts to annual amounts, starting with the first projected year.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects SGA amounts.


Legend

Legend
SpecMin1Page Members
Legend
Constructor
Data Member
protected


SpecMin1Page Members Protected Data Members

SpecMin1Page Members Protected Data Members
SpecMin1Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


SpecMin1Page Members Protected Methods

SpecMin1Page Members Protected Methods
SpecMin1Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


SpecMin1Page Members Public Data Members

SpecMin1Page Members Public Data Members
SpecMin1Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


SpecMin1Page Members Public Methods

SpecMin1Page Members Public Methods
SpecMin1Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
SpecMin1Page | Initializes SpecMin1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares special minimum strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~SpecMin1Page | Destructor.


Legend

Legend
SpecMin2Page Members
Legend
Constructor
Data Member
protected


SpecMin2Page Members Protected Data Members

SpecMin2Page Members Protected Data Members
SpecMin2Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


SpecMin2Page Members Protected Methods

SpecMin2Page Members Protected Methods
SpecMin2Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


SpecMin2Page Members Public Data Members

SpecMin2Page Members Public Data Members
SpecMin2Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


SpecMin2Page Members Public Methods

SpecMin2Page Members Public Methods
SpecMin2Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
SpecMin2Page | Initializes this instance.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares special minimum strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~SpecMin2Page | Destructor.


SpecMin Members Enumerations

SpecMin Members Enumerations
SpecMin Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
SpecMin Members
Legend
Constructor
virtual
Data Member
protected
Enumeration


SpecMin Members Protected Data Members

SpecMin Members Protected Data Members
SpecMin Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
iamemax | Maximum ame in pia interval.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.


SpecMin Members Public Data Members

SpecMin Members Public Data Members
SpecMin Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.


SpecMin Members Public Methods

SpecMin Members Public Methods
SpecMin Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
SpecMin | Initializes this instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Computes special minimum PIA.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getSpecMinAmount | Returns special minimum dollar amount per year of coverage.
getSpecMinYearsExcess | Returns number of years of coverage in special minimum in excess of 10, up to 30.
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setSpecMinAmount | Sets special minimum dollar amount per year of coverage.
setSpecMinYearsExcess | Sets number of years of coverage in special minimum in excess of 10, up to 30.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsExcessCal | Limits usable years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~SpecMin | Destructor.


SpecMinLC Members Enumerations

SpecMinLC Members Enumerations
SpecMinLC Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
SpecMinLC Members
Legend
Constructor
abstract
virtual
Data Member
protected
Enumeration


SpecMinLC Members Protected Data Members

SpecMinLC Members Protected Data Members
SpecMinLC Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
iamemax | Maximum ame in pia interval.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.


SpecMinLC Members Public Data Members

SpecMinLC Members Public Data Members
SpecMinLC Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.


SpecMinLC Members Public Methods

SpecMinLC Members Public Methods
SpecMinLC Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
SpecMinLC | Initializes all fields.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Calculates pia and mfb for this method.
calculate | Computes special minimum PIA.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getSpecMinAmount | Returns special minimum dollar amount per year of coverage.
getSpecMinYearsExcess | Returns number of years of coverage in special minimum in excess of 10, up to 30.
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getYearsTotal | Returns number of years of coverage.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setSpecMinAmount | Sets special minimum dollar amount per year of coverage.
setSpecMinYearsExcess | Sets number of years of coverage in special minimum in excess of 10, up to 30.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsExcessCal | Limits usable years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~SpecMinLC | Destructor.


Legend

Legend
Ssn Members
Legend
Constructor
Operator


Ssn Members Public Friends

Ssn Members Public Friends
Ssn Members
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


Ssn Members Public Methods

Ssn Members Public Methods
Ssn Members Legend
Public Methods
Name | Description
Ssn | Initializes an Ssn, either as a default or as specified.
deleteContents | Zeroes the three parts.
getPart1 | Returns first part of ssn.
getPart2 | Returns second part of ssn.
getPart3 | Returns third part of ssn.
setPart1 | Sets first part of ssn.
setPart2 | Sets second part of ssn.
setPart3 | Sets third part of ssn.
setSsnFull | Sets the full ssn.
toNumber | Returns ssn converted to a number.
toString | Returns the ssn as a string.
update | Updates full ssn from three parts.
~Ssn | Destructor.


Legend

Legend
Summary1Page Members
Legend
Constructor
Data Member
protected


Summary1Page Members Protected Data Members

Summary1Page Members Protected Data Members
Summary1Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


Summary1Page Members Protected Methods

Summary1Page Members Protected Methods
Summary1Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


Summary1Page Members Public Data Members

Summary1Page Members Public Data Members
Summary1Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


Summary1Page Members Public Methods

Summary1Page Members Public Methods
Summary1Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
Summary1Page | Initializes Summary1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares top part of summary page.
print | Writes the output strings to the specified device.
printDisInfo | Prints disability information.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~Summary1Page | Destructor.


Legend

Legend
Summary2Page Members
Legend
Constructor
Data Member
protected


Summary2Page Members Protected Data Members

Summary2Page Members Protected Data Members
Summary2Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


Summary2Page Members Public Data Members

Summary2Page Members Public Data Members
Summary2Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


Summary2Page Members Public Methods

Summary2Page Members Public Methods
Summary2Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
Summary2Page | Initializes Summary2Page.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareStrings | Prepares middle part of summary page.
print | Writes the output strings to the specified device.
~Summary2Page | Destructor.


Legend

Legend
Summary3Page Members
Legend
Constructor
Data Member
protected


Summary3Page Members Protected Data Members

Summary3Page Members Protected Data Members
Summary3Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


Summary3Page Members Protected Methods

Summary3Page Members Protected Methods
Summary3Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


Summary3Page Members Public Data Members

Summary3Page Members Public Data Members
Summary3Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


Summary3Page Members Public Methods

Summary3Page Members Public Methods
Summary3Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
Summary3Page | Initializes Summary3Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
bottom3 | Prints bottom of summary.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
disclaimer | Prints disclaimer.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonInsPara | Prints noninsured paragraph.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares bottom part of summary page.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~Summary3Page | Destructor.


Legend

Legend
SummaryPage Members
Legend
Constructor
Data Member
protected


SummaryPage Members Protected Data Members

SummaryPage Members Protected Data Members
SummaryPage Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


SummaryPage Members Public Data Members

SummaryPage Members Public Data Members
SummaryPage Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


SummaryPage Members Public Methods

SummaryPage Members Public Methods
SummaryPage Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
SummaryPage | Initializes SummaryPage.
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareStrings | Prepares the three parts of the summary page.
print | Writes the output strings to the specified device.
~SummaryPage | Destructor.


Legend

Legend
TaxBenefits Members
Legend
Constructor
virtual
Data Member


TaxBenefits Members Public Data Members

TaxBenefits Members Public Data Members
TaxBenefits Members Legend
Public Data Members
Name | Description
HiYear | The year that the OASDHI tax became effective.
MARRIEDOASDHITAX | OASDHI tax for married taxpayers in first tier.
MARRIEDOASDHITHRESHOLD | OASDHI threshold for married taxpayers.
MARRIEDOASDITHRESHOLD | OASDI threshold for married taxpayers.
OasdhiRate | The OASDHI tax rate.
OasdiRate | The OASDI tax rate.
SINGLEOASDHITAX | OASDHI tax for single taxpayers in first tier.
SINGLEOASDHITHRESHOLD | OASDHI threshold for single taxpayers.
SINGLEOASDITHRESHOLD | OASDI threshold for single taxpayers.
START_YEAR | Starting year of tax on Social Security benefits.


TaxBenefits Members Public Methods

TaxBenefits Members Public Methods
TaxBenefits Members Legend
Public Methods
Name | Description
TaxBenefits | Initializes an instance.
deductionsCal | Returns the amount of deductions allowed under the Ball taxation plan.
getProportion | Returns proportion of benefits that are taxable for OASDI.
getThreshold | Returns appropriate OASDI threshold.
taxOasdhi | Returns taxable benefits for OASDHI trust funds.
taxOasdi | Returns taxable benefits for OASDI trust funds.
~TaxBenefits | Destructor.


Legend

Legend
TaxBenefitsLC Members
Legend
Constructor
virtual
Data Member


TaxBenefitsLC Members Public Data Members

TaxBenefitsLC Members Public Data Members
TaxBenefitsLC Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
HiYear | The year that the OASDHI tax became effective.
MARRIEDOASDHITAX | OASDHI tax for married taxpayers in first tier.
MARRIEDOASDHITHRESHOLD | OASDHI threshold for married taxpayers.
MARRIEDOASDITHRESHOLD | OASDI threshold for married taxpayers.
OasdhiRate | The OASDHI tax rate.
OasdiRate | The OASDI tax rate.
SINGLEOASDHITAX | OASDHI tax for single taxpayers in first tier.
SINGLEOASDHITHRESHOLD | OASDHI threshold for single taxpayers.
SINGLEOASDITHRESHOLD | OASDI threshold for single taxpayers.
START_YEAR | Starting year of tax on Social Security benefits.


TaxBenefitsLC Members Public Methods

TaxBenefitsLC Members Public Methods
TaxBenefitsLC Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
TaxBenefitsLC | Initializes an instance.
deductionsCal | Returns the amount of deductions allowed under the Ball taxation plan.
getProportion | Returns proportion of benefits that are taxable for OASDI.
getThreshold | Returns appropriate threshold.
paymentsCal | Returns number of payments over which contributions are spread for Ball taxation plan.
taxOasdhi | Returns taxable benefits for OASDHI trust funds (same as taxable for OASDI for proposal to tax as for private pension plans).
taxOasdi | Returns taxable benefits for OASDI trust funds.
thresholdsCal | Fills in declining threshold amounts.
~TaxBenefitsLC | Destructor.


TaxData Members Enumerations

TaxData Members Enumerations
TaxData Members Legend
Enumerations
Name | Description
YEAR_GROUP | Dimension limits.


Legend

Legend
TaxData Members
Legend
Constructor
Enumeration
Data Member


TaxData Members Public Data Members

TaxData Members Public Data Members
TaxData Members Legend
Public Data Members
Name | Description
taxesDi | DI taxes paid by year.
taxesHi | HI taxes paid by year.
taxesOasdhi | OASDHI taxes paid by year.
taxesOasdi | OASDI taxes paid by year.
taxesOasi | OASI taxes paid by year.


TaxData Members Public Methods

TaxData Members Public Methods
TaxData Members Legend
Public Methods
Name | Description
TaxData | Initializes arrays.
getTaxesTotal | Returns total taxes paid for a trust fund type and a period of years.
oasdhiTaxCal | Calculates OASDI and OASDHI taxes paid over a lifetime.
totalTaxCal | Calculates total taxes paid over a lifetime.
~TaxData | Destroys this instance.


Legend

Legend
TaxesPage Members
Legend
Constructor
Data Member
protected


TaxesPage Members Protected Data Members

TaxesPage Members Protected Data Members
TaxesPage Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


TaxesPage Members Protected Methods

TaxesPage Members Protected Methods
TaxesPage Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


TaxesPage Members Public Data Members

TaxesPage Members Public Data Members
TaxesPage Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


TaxesPage Members Public Methods

TaxesPage Members Public Methods
TaxesPage Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
TaxesPage | Initializes TaxesPage.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares taxes strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~TaxesPage | Destructor.


TaxRates Members Enumerations

TaxRates Members Enumerations
TaxRates Members Legend
Enumerations
Name | Description
taxrateType | Type of tax rate (employee or self-employed).
trustfundType | Trust fund indicator.


Legend

Legend
TaxRates Members
Legend
Constructor
abstract
virtual
Enumeration
Data Member
protected


TaxRates Members Protected Data Members

TaxRates Members Protected Data Members
TaxRates Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
maxyear | Maximum year allowed.


TaxRates Members Protected Methods

TaxRates Members Protected Methods
TaxRates Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
setCredits | Sets tax credits for one year for employee or employer for all trust funds.
setGrossRates | Sets gross tax rates for all years for employee and employer, for all trust funds.
setNetRates | Sets net tax rates for one year for employee or employer for all trust funds.


TaxRates Members Public Data Members

TaxRates Members Public Data Members
TaxRates Members Legend
Public Data Members
Name | Description
LAST_TAX_RATE_YEAR | Last year that tax rates change.
NUMTAXRATES | Number of years of historical tax rates.


TaxRates Members Public Methods

TaxRates Members Public Methods
TaxRates Members Legend
Public Methods
Name | Description
TaxRates | Initializes arrays.
getTaxRatesGross | Returns an array of gross tax rates.
getTaxRatesNet | Returns an array of tax rates, net of any tax credit.
initialize | Initializes all tax rates.
setHistCredits | Sets historical tax credits.
setHistRates | Sets historical tax rates.
taxCalAllYears | Calculates taxes paid over a lifetime, net of any tax credit.
taxCalOneYearGross | Returns taxes paid for one year for one trust fund, including any tax credit.
taxCalOneYearNet | Returns taxes paid for one year for one trust fund, net of any tax credit.
~TaxRates | Destroys this instance.


TaxRatesLC Members Enumerations

TaxRatesLC Members Enumerations
TaxRatesLC Members Legend
Enumerations
Name | Description
taxrateType | Type of tax rate (employee or self-employed).
trustfundType | Trust fund indicator.


Legend

Legend
TaxRatesLC Members
Legend
Constructor
Data Member
protected
Enumeration


TaxRatesLC Members Protected Data Members

TaxRatesLC Members Protected Data Members
TaxRatesLC Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
lawChange | Law change data.
maxyear | Maximum year allowed.


TaxRatesLC Members Protected Methods

TaxRatesLC Members Protected Methods
TaxRatesLC Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
setCredits | Sets tax credits for one year for employee or employer for all trust funds.
setGrossRates | Sets gross tax rates for all years for employee and employer, for all trust funds.
setNetRates | Sets net tax rates for one year for employee or employer for all trust funds.


TaxRatesLC Members Public Data Members

TaxRatesLC Members Public Data Members
TaxRatesLC Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
LAST_TAX_RATE_YEAR | Last year that tax rates change.
NUMTAXRATES | Number of years of historical tax rates.


TaxRatesLC Members Public Methods

TaxRatesLC Members Public Methods
TaxRatesLC Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
TaxRatesLC | Initializes arrays.
getTaxRatesGross | Returns an array of gross tax rates.
getTaxRatesNet | Returns an array of tax rates, net of any tax credit.
initialize | Sets all tax rates, using historical rates unless overridden by rates in law change data.
setHistCredits | Sets historical tax credits.
setHistRates | Sets historical tax rates.
taxCalAllYears | Calculates taxes paid over a lifetime, net of any tax credit.
taxCalOneYearGross | Returns taxes paid for one year for one trust fund, including any tax credit.
taxCalOneYearNet | Returns taxes paid for one year for one trust fund, net of any tax credit.
~TaxRatesLC | Destroys this instance.


TaxRatesPL Members Enumerations

TaxRatesPL Members Enumerations
TaxRatesPL Members Legend
Enumerations
Name | Description
taxrateType | Type of tax rate (employee or self-employed).
trustfundType | Trust fund indicator.


Legend

Legend
TaxRatesPL Members
Legend
Constructor
Enumeration
Data Member
protected


TaxRatesPL Members Protected Data Members

TaxRatesPL Members Protected Data Members
TaxRatesPL Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
maxyear | Maximum year allowed.


TaxRatesPL Members Protected Methods

TaxRatesPL Members Protected Methods
TaxRatesPL Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
setCredits | Sets tax credits for one year for employee or employer for all trust funds.
setGrossRates | Sets gross tax rates for all years for employee and employer, for all trust funds.
setNetRates | Sets net tax rates for one year for employee or employer for all trust funds.


TaxRatesPL Members Public Data Members

TaxRatesPL Members Public Data Members
TaxRatesPL Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
LAST_TAX_RATE_YEAR | Last year that tax rates change.
NUMTAXRATES | Number of years of historical tax rates.


TaxRatesPL Members Public Methods

TaxRatesPL Members Public Methods
TaxRatesPL Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
TaxRatesPL | Initializes arrays.
getTaxRatesGross | Returns an array of gross tax rates.
getTaxRatesNet | Returns an array of tax rates, net of any tax credit.
initialize | Sets all tax rates and credits to stored values.
setHistCredits | Sets historical tax credits.
setHistRates | Sets historical tax rates.
taxCalAllYears | Calculates taxes paid over a lifetime, net of any tax credit.
taxCalOneYearGross | Returns taxes paid for one year for one trust fund, including any tax credit.
taxCalOneYearNet | Returns taxes paid for one year for one trust fund, net of any tax credit.
~TaxRatesPL | Destroys this instance.


Legend

Legend
TextWriterTraceListener Members
Legend
Constructor
abstract


TextWriterTraceListener Members Public Methods

TextWriterTraceListener Members Public Methods
TextWriterTraceListener Members Legend
Public Methods
Name | Description
TextWriterTraceListener | Creates this instance.
close | Closes things.
flush | Flushes the output.
write | Writes a string of characters, without a newline, to the designated output.
write | Writes a string of characters, without a newline, to the designated output.
writeLine | Writes a string of characters, with a newline, to the designated output.
writeLine | Writes a string of characters, with a newline, to the designated output.
~TextWriterTraceListener | Destroys this instance.


Legend

Legend
Trace Members
Legend
Method


Trace Members Public Methods

Trace Members Public Methods
Trace Members Legend
Public Methods
Name | Description
close | Close all the TraceListener objects.
flush | Flush all the TraceListener objects.
getListeners | Returns the vector of TraceListener objects.
write | Writes a string of characters, without a newline, to all the TraceListener objects.
writeLine | Writes a string of characters, with a newline, to all the TraceListener objects.


Legend

Legend
TraceListener Members
Legend
Constructor
protected
virtual
abstract


TraceListener Members Protected Methods

TraceListener Members Protected Methods
TraceListener Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
TraceListener | Creates this instance.


Protected Methods

Legend
Legend
Constructor
protected


TraceListener Members Public Methods

TraceListener Members Public Methods
TraceListener Members Legend
Public Methods
Name | Description
close | Closes this instance.
flush | Flushes the output of this instance.
write | Writes a string of characters, without a newline, to the designated output.
writeLine | Writes a string of characters, with a newline, to the designated output.
~TraceListener | Destroys this instance.


Public Methods

Legend
Legend
Method
virtual
abstract


Legend

Legend
TransGuar1Page Members
Legend
Constructor
Data Member
protected


TransGuar1Page Members Protected Data Members

TransGuar1Page Members Protected Data Members
TransGuar1Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


TransGuar1Page Members Protected Methods

TransGuar1Page Members Protected Methods
TransGuar1Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


TransGuar1Page Members Public Data Members

TransGuar1Page Members Public Data Members
TransGuar1Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


TransGuar1Page Members Public Methods

TransGuar1Page Members Public Methods
TransGuar1Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
TransGuar1Page | Initializes TransGuar1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares transitional guarantee strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~TransGuar1Page | Destructor.


Legend

Legend
TransGuar2Page Members
Legend
Constructor
Data Member
protected


TransGuar2Page Members Protected Data Members

TransGuar2Page Members Protected Data Members
TransGuar2Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


TransGuar2Page Members Protected Methods

TransGuar2Page Members Protected Methods
TransGuar2Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


TransGuar2Page Members Public Data Members

TransGuar2Page Members Public Data Members
TransGuar2Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


TransGuar2Page Members Public Methods

TransGuar2Page Members Public Methods
TransGuar2Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
TransGuar2Page | Initializes TransGuar2Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares transitional guarantee strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~TransGuar2Page | Destructor.


TransGuar Members Enumerations

TransGuar Members Enumerations
TransGuar Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
TransGuar Members
Legend
Constructor
virtual
Data Member
protected
Enumeration


TransGuar Members Protected Data Members

TransGuar Members Protected Data Members
TransGuar Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
iamemax | Maximum ame in pia interval.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.


TransGuar Members Public Data Members

TransGuar Members Public Data Members
TransGuar Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
percMfb | Wage-indexed MFB formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.


TransGuar Members Public Methods

TransGuar Members Public Methods
TransGuar Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
TransGuar | Initializes a TransGuar instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Computes transitional guarantee PIA.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~TransGuar | Destructor.


TransGuarLC Members Enumerations

TransGuarLC Members Enumerations
TransGuarLC Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
TransGuarLC Members
Legend
Constructor
abstract
virtual
Data Member
protected
Enumeration


TransGuarLC Members Protected Data Members

TransGuarLC Members Protected Data Members
TransGuarLC Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
iamemax | Maximum ame in pia interval.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.


TransGuarLC Members Public Data Members

TransGuarLC Members Public Data Members
TransGuarLC Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
percMfb | Wage-indexed MFB formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.


TransGuarLC Members Public Methods

TransGuarLC Members Public Methods
TransGuarLC Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
TransGuarLC | Initializes a TransGuarLC instance.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Calculates pia and mfb for this method.
calculate | Computes transitional guarantee PIA.
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
orderEarnings | Orders earnings and sets indicator for the highest years.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
~TransGuarLC | Destructor.


Legend

Legend
UserAssumptions Members
Legend
Constructor
Data Member


UserAssumptions Members Public Data Members

UserAssumptions Members Public Data Members
UserAssumptions Members Legend
Public Data Members
Name | Description
awincproj | Projected increases in annual average earnings.
base77 | Old-law wage bases (ignoring 1979-81 ad hoc increases), 1937 to maxyear, as read in.
baseOasdi | Wage base under present law, 1937 to maxyear, as read in.
biproj | Projected benefit increases.
catchup | Catch-up benefit increases.
titleAw | Title of user's average wages.
titleBi | Title of user's benefit increases


UserAssumptions Members Public Methods

UserAssumptions Members Public Methods
UserAssumptions Members Legend
Public Methods
Name | Description
UserAssumptions | Initializes user-specified assumptions.
anscchCheck | Checks catch-up increase indicator.
deleteContents | Initializes all variables.
getAnscch | Returns catch-up benefit increase indicator.
getIaltaw | Returns average wage increase assumption.
getIaltbi | Returns benefit increase assumption.
getIbasch | Returns wage base projection indicator.
getIstart | Returns current year (year after last known benefit increase).
getJaltaw | Returns last average wage increase assumption read in.
getJaltbi | Returns last benefit increase assumption read in.
getJbasch | Returns last wage base projection indicator read in.
istartCheck | Checks current year.
pebsasmCheck | Checks for valid assumption for Statement.
resetTriggers | Resets assumptions triggers.
setAnscch | Sets catch-up increase indicator.
setIaltaw | Sets average wage increase indicator.
setIaltbi | Sets benefit increase indicator.
setIbasch | Sets wage base indicator.
setIstart | Sets current year.
setJaltaw | Sets the previous average wage increase assumption.
setJaltbi | Sets the previous benefit increase assumption.
setJbasch | Sets the previous wage base assumption.
setLastYear | Sets last year of data arrays. Should be called when benefit date is set in WorkerData.
setTitleAw | Sets average wage change assumption title.
setTitleBi | Sets benefit increase assumption title.
zeroJalt | Initializes previous assumptions indicators.


Legend

Legend
WageBase Members
Legend
Constructor
virtual
Data Member
protected
Operator


WageBase Members Protected Data Members

WageBase Members Protected Data Members
WageBase Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
defcomp | Increase in average wage due to deferred comp in 1990.
wageBaseInd | Type of wage base.


WageBase Members Public Data Members

WageBase Members Public Data Members
WageBase Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


WageBase Members Public Friends

WageBase Members Public Friends
WageBase Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


WageBase Members Public Methods

WageBase Members Public Methods
WageBase Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
WageBase | Initializes a WageBase, with or without a specified first year.
WageBaseGeneral | Initializes a WageBaseGeneral, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
check | Checks a wage base.
earnLimit | Limits earnings to wage base.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects wage bases.
projectLC | Projects wage bases after a period of ad hoc wage bases.


Legend

Legend
WageBaseGeneral Members
Legend
Constructor
virtual
Data Member
protected
Operator


WageBaseGeneral Members Protected Data Members

WageBaseGeneral Members Protected Data Members
WageBaseGeneral Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
defcomp | Increase in average wage due to deferred comp in 1990.
wageBaseInd | Type of wage base.


WageBaseGeneral Members Public Data Members

WageBaseGeneral Members Public Data Members
WageBaseGeneral Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


WageBaseGeneral Members Public Friends

WageBaseGeneral Members Public Friends
WageBaseGeneral Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


WageBaseGeneral Members Public Methods

WageBaseGeneral Members Public Methods
WageBaseGeneral Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
WageBaseGeneral | Initializes a WageBaseGeneral, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
check | Checks a wage base.
earnLimit | Limits earnings to wage base.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects wage bases.
projectLC | Projects wage bases after a period of ad hoc wage bases.
~WageBaseGeneral | Destructor.


Legend

Legend
WageBaseHI Members
Legend
Constructor
virtual
Data Member
protected
Operator


WageBaseHI Members Protected Data Members

WageBaseHI Members Protected Data Members
WageBaseHI Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
defcomp | Increase in average wage due to deferred comp in 1990.
wageBaseInd | Type of wage base.


WageBaseHI Members Public Data Members

WageBaseHI Members Public Data Members
WageBaseHI Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


WageBaseHI Members Public Friends

WageBaseHI Members Public Friends
WageBaseHI Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


WageBaseHI Members Public Methods

WageBaseHI Members Public Methods
WageBaseHI Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
WageBaseGeneral | Initializes a WageBaseGeneral, with or without a specified first year.
WageBaseHI | Initializes a WageBaseHI, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
check | Checks a wage base.
earnLimit | Limits earnings to wage base.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects wage bases.
projectLC | Projects wage bases after a period of ad hoc wage bases.


Legend

Legend
WageBaseLC Members
Legend
Constructor
Data Member
protected
Operator


WageBaseLC Members Protected Data Members

WageBaseLC Members Protected Data Members
WageBaseLC Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
defcomp | Increase in average wage due to deferred comp in 1990.
wageBaseInd | Type of wage base.


WageBaseLC Members Public Data Members

WageBaseLC Members Public Data Members
WageBaseLC Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


WageBaseLC Members Public Friends

WageBaseLC Members Public Friends
WageBaseLC Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


WageBaseLC Members Public Methods

WageBaseLC Members Public Methods
WageBaseLC Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
WageBase | Initializes a WageBase, with or without a specified first year.
WageBaseGeneral | Initializes a WageBaseGeneral, with or without a specified first year.
WageBaseLC | Initializes a WageBaseLC, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
check | Checks a wage base.
earnLimit | Limits earnings to wage base.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects oasdi wage bases with law changes.
projectLC | Projects wage bases after a period of ad hoc wage bases.


Legend

Legend
WageBaseOldLaw Members
Legend
Constructor
virtual
Data Member
protected
Operator


WageBaseOldLaw Members Protected Data Members

WageBaseOldLaw Members Protected Data Members
WageBaseOldLaw Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
defcomp | Increase in average wage due to deferred comp in 1990.
wageBaseInd | Type of wage base.


WageBaseOldLaw Members Public Data Members

WageBaseOldLaw Members Public Data Members
WageBaseOldLaw Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


WageBaseOldLaw Members Public Friends

WageBaseOldLaw Members Public Friends
WageBaseOldLaw Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


WageBaseOldLaw Members Public Methods

WageBaseOldLaw Members Public Methods
WageBaseOldLaw Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
WageBaseGeneral | Initializes a WageBaseGeneral, with or without a specified first year.
WageBaseOldLaw | Initializes a WageBaseOldLaw, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
check | Checks a wage base.
earnLimit | Limits earnings to wage base.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects wage bases.
projectLC | Projects wage bases after a period of ad hoc wage bases.


Legend

Legend
WageBaseOldLawLC Members
Legend
Constructor
Data Member
protected
Operator


WageBaseOldLawLC Members Protected Data Members

WageBaseOldLawLC Members Protected Data Members
WageBaseOldLawLC Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
defcomp | Increase in average wage due to deferred comp in 1990.
wageBaseInd | Type of wage base.


WageBaseOldLawLC Members Public Data Members

WageBaseOldLawLC Members Public Data Members
WageBaseOldLawLC Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


WageBaseOldLawLC Members Public Friends

WageBaseOldLawLC Members Public Friends
WageBaseOldLawLC Members
Public Friends
Show:
No members matching the current filter
Name | Description
class boost::serialization::access | Friend class to allow serialization.


WageBaseOldLawLC Members Public Methods

WageBaseOldLawLC Members Public Methods
WageBaseOldLawLC Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
WageBaseGeneral | Initializes a WageBaseGeneral, with or without a specified first year.
WageBaseOldLaw | Initializes a WageBaseOldLaw, with or without a specified first year.
WageBaseOldLawLC | Initializes a WageBaseOldLawLC, with or without a specified first year.
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
check | Checks a wage base.
earnLimit | Limits earnings to wage base.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.
project | Projects 1977 law wage bases with law changes.
projectLC | Projects wage bases after a period of ad hoc wage bases.


Legend

Legend
WageInd1Page Members
Legend
Constructor
Data Member
protected


WageInd1Page Members Protected Data Members

WageInd1Page Members Protected Data Members
WageInd1Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


WageInd1Page Members Protected Methods

WageInd1Page Members Protected Methods
WageInd1Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


WageInd1Page Members Public Data Members

WageInd1Page Members Public Data Members
WageInd1Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


WageInd1Page Members Public Methods

WageInd1Page Members Public Methods
WageInd1Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
WageInd1Page | Initializes WageInd1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares wage indexed strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~WageInd1Page | Destructor.


Legend

Legend
WageInd2Page Members
Legend
Constructor
Data Member
protected


WageInd2Page Members Protected Data Members

WageInd2Page Members Protected Data Members
WageInd2Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


WageInd2Page Members Protected Methods

WageInd2Page Members Protected Methods
WageInd2Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


WageInd2Page Members Public Data Members

WageInd2Page Members Public Data Members
WageInd2Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


WageInd2Page Members Public Methods

WageInd2Page Members Public Methods
WageInd2Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
WageInd2Page | Initializes WageInd2Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares wage indexed strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~WageInd2Page | Destructor.


WageInd Members Enumerations

WageInd Members Enumerations
WageInd Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
WageInd Members
Legend
Constructor
virtual
Data Member
protected
Enumeration


WageInd Members Protected Data Members

WageInd Members Protected Data Members
WageInd Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
windfallInd | Windfall indicator.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
yearsTotal | Number of years of coverage for windfall elimination.


WageInd Members Public Data Members

WageInd Members Public Data Members
WageInd Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.


WageInd Members Public Methods

WageInd Members Public Methods
WageInd Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
WageInd | Initializes a WageInd instance.
aimepiaCal | Calculates an AIME PIA under the 1977 law.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
bendPointCal | Projects bend points.
calculate | Computes wage indexed PIA.
deconvertAme | Deconverts AIME from raw PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIndexYearAvgWage | Returns average wage in indexing year.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
realWageGainAdj | Applies real-wage-gain adjustment.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionAime | Calculates portion of aime in each section of pia formula.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setWindfall | Sets windfall indicator in wage-indexed method.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
~WageInd | Destructor.


WageIndGeneral Members Enumerations

WageIndGeneral Members Enumerations
WageIndGeneral Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
WageIndGeneral Members
Legend
Constructor
abstract
virtual
Data Member
protected
Enumeration


WageIndGeneral Members Protected Data Members

WageIndGeneral Members Protected Data Members
WageIndGeneral Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
windfallInd | Windfall indicator.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
yearsTotal | Number of years of coverage for windfall elimination.


WageIndGeneral Members Public Data Members

WageIndGeneral Members Public Data Members
WageIndGeneral Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.


WageIndGeneral Members Public Methods

WageIndGeneral Members Public Methods
WageIndGeneral Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
WageIndGeneral | Initializes this instance.
aimepiaCal | Calculates an AIME PIA under the 1977 law.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
bendPointCal | Projects bend points.
calculate | Calculates pia and mfb for this method.
deconvertAme | Deconverts AIME from raw PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIndexYearAvgWage | Returns average wage in indexing year.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
isApplicable | Returns true if this method is applicable.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
realWageGainAdj | Applies real-wage-gain adjustment.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionAime | Calculates portion of aime in each section of pia formula.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setWindfall | Sets windfall indicator in wage-indexed method.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
~WageIndGeneral | Destructor.


WageIndLC Members Enumerations

WageIndLC Members Enumerations
WageIndLC Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
WageIndLC Members
Legend
Constructor
abstract
virtual
Data Member
protected
Enumeration


WageIndLC Members Protected Data Members

WageIndLC Members Protected Data Members
WageIndLC Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
windfallInd | Windfall indicator.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
yearsTotal | Number of years of coverage for windfall elimination.


WageIndLC Members Public Data Members

WageIndLC Members Public Data Members
WageIndLC Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.


WageIndLC Members Public Methods

WageIndLC Members Public Methods
WageIndLC Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
WageIndLC | Initializes a WageIndLC instance.
aimepiaCal | Calculates an AIME PIA under the 1977 law.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
bendPointCal | Projects bend points.
calculate | Calculates pia and mfb for this method.
calculate | Computes wage indexed PIA.
deconvertAme | Deconverts AIME from raw PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIndexYearAvgWage | Returns average wage in indexing year.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isApplicable | Determines applicability of method.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
realWageGainAdj | Applies real-wage-gain adjustment.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionAime | Calculates portion of aime in each section of pia formula.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setWindfall | Sets windfall indicator in wage-indexed method.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
~WageIndLC | Destructor.


Legend

Legend
WageIndNonFreeze1Page Members
Legend
Constructor
Data Member
protected


WageIndNonFreeze1Page Members Protected Data Members

WageIndNonFreeze1Page Members Protected Data Members
WageIndNonFreeze1Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


WageIndNonFreeze1Page Members Protected Methods

WageIndNonFreeze1Page Members Protected Methods
WageIndNonFreeze1Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


WageIndNonFreeze1Page Members Public Data Members

WageIndNonFreeze1Page Members Public Data Members
WageIndNonFreeze1Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


WageIndNonFreeze1Page Members Public Methods

WageIndNonFreeze1Page Members Public Methods
WageIndNonFreeze1Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
WageIndNonFreeze1Page | Initializes WageIndNonFreeze1Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares wage indexed strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~WageIndNonFreeze1Page | Destructor.


Legend

Legend
WageIndNonFreeze2Page Members
Legend
Constructor
Data Member
protected


WageIndNonFreeze2Page Members Protected Data Members

WageIndNonFreeze2Page Members Protected Data Members
WageIndNonFreeze2Page Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
pageTitle | Title at top of page.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


WageIndNonFreeze2Page Members Protected Methods

WageIndNonFreeze2Page Members Protected Methods
WageIndNonFreeze2Page Members Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


WageIndNonFreeze2Page Members Public Data Members

WageIndNonFreeze2Page Members Public Data Members
WageIndNonFreeze2Page Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
MAXLINES | The maximum number of lines on a page.


WageIndNonFreeze2Page Members Public Methods

WageIndNonFreeze2Page Members Public Methods
WageIndNonFreeze2Page Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
WageIndNonFreeze2Page | Initializes WageIndNonFreeze2Page.
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
getCount | Returns number of lines of output.
getString | Returns one line of output.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
prepareStrings | Prepares wage indexed strings for printing.
print | Writes the output strings to the specified device.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.
~WageIndNonFreeze2Page | Destructor.


WageIndNonFreeze Members Enumerations

WageIndNonFreeze Members Enumerations
WageIndNonFreeze Members Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
WageIndNonFreeze Members
Legend
Constructor
virtual
Data Member
protected
Enumeration


WageIndNonFreeze Members Protected Data Members

WageIndNonFreeze Members Protected Data Members
WageIndNonFreeze Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
windfallInd | Windfall indicator.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.
yearsTotal | Number of years of coverage for windfall elimination.


WageIndNonFreeze Members Public Data Members

WageIndNonFreeze Members Public Data Members
WageIndNonFreeze Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.


WageIndNonFreeze Members Public Methods

WageIndNonFreeze Members Public Methods
WageIndNonFreeze Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
WageIndNonFreeze | Initializes a WageIndNonFreeze instance.
aimepiaCal | Calculates an AIME PIA under the 1977 law.
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
bendPointCal | Projects bend points.
calculate | Computes wage indexed PIA.
deconvertAme | Deconverts AIME from raw PIA.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIndexYearAvgWage | Returns average wage in indexing year.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
initialize | Initializes computed values to zero.
isApplicable | This is the overview for the isApplicable method overload.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
realWageGainAdj | Applies real-wage-gain adjustment.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionAime | Calculates portion of aime in each section of pia formula.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setWindfall | Sets windfall indicator in wage-indexed method.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.
~WageIndNonFreeze | Destructor.


WorkerData Members Enumerations

WorkerData Members Enumerations
WorkerData Members Legend
Enumerations
Name | Description
BitsetMembers | Members of the bitset.
DimLimits | Dimension limits.
DimLimits | Dimension limits.
ben_type | Type of benefit calculation.


Legend

Legend
WorkerData Members
Legend
Constructor
Enumeration
Data Member
protected


WorkerData Members Protected Data Members

WorkerData Members Protected Data Members
WorkerData Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
earnHi | Worker additional Medicare earnings, 1937 to last year considered.
earnOasdi | Worker earnings, 1937 to last year considered, after any projection of earnings.
maxyear | Maximum year of projection is LASTYEARLR, unless changed.
qclumpyear | Quarters of coverage are summed before 1978, unless changed.
taxType | Type of taxes paid. See TaxRates::taxrateType for the meaning of each bit.


WorkerData Members Public Data Members

WorkerData Members Public Data Members
WorkerData Members Legend
Public Data Members
Show:
No members matching the current filter
Name | Description
childCareYears | Child care years, 1937 to WorkerDataGeneral::maxyear.
disabPeriod | Two periods of disability.
milServDatesVec | Military service dates.
qc | Quarters of coverage, 1937 to WorkerDataGeneral::maxyear.
railRoadData | Railroad quarters of coverage and earnings.
ssn | Social security number of wage earner.


WorkerData Members Public Friends

WorkerData Members Public Friends
WorkerData Members
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


WorkerData Members Public Methods

WorkerData Members Public Methods
WorkerData Members Legend
Public Methods
Show:
No members matching the current filter
Name | Description
WorkerData | Initializes all values.
WorkerDataGeneral | Initializes a WorkerDataGeneral, either with default values or from another WorkerDataGeneral.
anySelfEmp | Returns true if any self-employed taxes.
benefitDate1Check | Checks that date of benefit is in range.
benefitDate2Check | Checks that date of benefit is at or after entitlement.
birth1Check | Checks date of birth in a Statement case.
birth2Check | Checks date of birth in a non-Statement case.
cessation1Check | Checks date of prior disability cessation against date of prior onset.
cessation1OnsetCheck | Checks date of prior disability cessation against date of prior onset.
cessationCheck | Checks date of disability cessation, using stored values.
cessationCheck2 | Checks date of disability cessation, using passed values.
deathCheck | Checks that date of death is after birth.
deathCheck1 | Checks date of death (checks in survivor case for death in 1937 or later).
deathCheck2 | Checks date of death for basic correctness.
deathCheck3 | Checks that date of death is before entitlement, using passed values.
deleteContents | Initializes all variables to default values.
deleteDeathDate | Deletes date of death.
deleteEntDate | Deletes date of entitlement.
deleteOabCessDate | Clears date of OAB cessation prior to most recent DIB.
deleteOabEntDate | Clears date of OAB entitlement prior to most recent DIB entitlement.
deletePubpenDate | Clears date of noncovered pension entitlement.
dis1Check | Checks date of prior disability onset.
disBirthEntCheck | Checks date of disability onset against dates of birth, entitlement, and benefit.
disCheck | Checks date of disability onset.
disDeathCheck | Checks date of disability onset against date of death.
earningsCheck | Checks for no earnings of any type.
entCheck | Checks that current date of entitlement is within bounds.
firstEarnHiYear | Returns first year of Medicare earnings, if any.
getBenefitDate | Returns date of benefit.
getBirthDate | Returns date of birth of worker.
getBlindind | Returns the blind indicator.
getDeathDate | Returns date of death.
getDeceasedOAB | Returns the deceased OAB indicator.
getDeemedind | Returns the deemed insured indicator.
getEarliestEntDate | Returns earliest entitlement date on this record.
getEarnEnable | Returns true if ok to enable earnings entry dialog box.
getEarnHi | Returns Medicare earnings for specified year.
getEarnHiOnly | Returns Medicare earnings for specified year if there are no OASDI earnings; otherwise return zero.
getEarnMS | Returns military service earnings for specified year.
getEarnMS3750 | Returns total military service earnings, 1937-50.
getEarnOasdhi | Returns OASDI plus Medicare earnings for specified year.
getEarnOasdi | Returns OASDI-covered earnings for the specified year.
getEarnRR | Returns railroad earnings for specified year.
getEarnRR3750 | Returns total railroad earnings, 1937-50.
getEntDate | Returns date of entitlement.
getFirstYearEarn | Returns first year of OASDI earnings (0 if none).
getFirstYearEarnHi | Returns first year of HI earnings (0 if none).
getFirstYearMS | Returns first year of military service (0 if none).
getFirstYearRR | Returns first year of railroad (0 if none).
getIbegin | Returns first year of earnings after any projection.
getIdNumber | Returns Social Security number as a number.
getIdString | Returns Social Security number as a string.
getIend | Returns last year of earnings after any projection.
getIndearn | Returns earnings indicator.
getIndms | Returns military service indicator.
getIndrr | Returns railroad indicator.
getJoasdi | Returns type of benefit calculation, including possibly Statement.
getLastYearEarn | Returns last year of OASDI earnings (0 if none).
getLastYearEarnHi | Returns last year of HI earnings (0 if none).
getLastYearMS | Returns last year of military service (0 if none).
getLastYearRR | Returns last year of military service (0 if none).
getMaxyear | Returns maximum year allowed.
getMqge | Returns Medicare-qualified government employment indicator.
getNhaddr | Returns one line of number holder's address.
getNhname | Returns number holder's name.
getOabCessDate | Returns date of cessation of oab entitlement prior to most recent DIB entitlement.
getOabEntDate | Returns date of entitlement to oab prior to most recent DIB entitlement.
getPubpen | Returns monthly noncovered pension.
getPubpenDate | Returns monthly noncovered pension.
getPubpenReservist | Returns monthly noncovered pension after December 1994, after removing reservist pension.
getQcLumpYear | Returns last year of period for which quarters of coverage are entered as a lump sum.
getQcovMS | Returns military service quarters of coverage for specified year.
getQcovMS3750 | Returns total military service quarters of coverage, 1937-50.
getQcovRR | Returns railroad quarters of coverage for specified year.
getQcovRR3750 | Returns total railroad quarters of coverage, 1937-50.
getQcovRR5177 | Returns total railroad quarters of coverage, 1951-77.
getQctot51td | Returns quarters of coverage from 1951 to 1977.
getQctottd | Returns quarters of coverage from 1937 to 1977.
getRecalc | Returns recalculation code.
getReservist | Returns reservist indicator.
getSex | Returns the sex of the worker.
getTaxType | Returns type of taxes for specified year.
getTaxTypeArray | Returns array of type of taxes.
getTotalize | Returns totalization indicator.
getValdi | Returns number of periods of disability.
hasQcsByYear | Returns indicator for QCs prior to 1978 by single year.
ibegin1Check | Checks first year of earnings in a Statement case.
ibegin2Check | Checks first year of earnings in a non-Statement case.
ibeginCheck | Checks for first year of earnings within bounds.
iendCheck | Checks last year of earnings.
isFemale | Return true if person is Sex::sex_type::FEMALE, false otherwise.
isMale | Return true if person is Sex::sex_type::MALE, false otherwise.
isPrimary | Returns primary beneficiary code.
isalive | Returns true if alive at end of year, false otherwise.
isdead | Returns true if dead at end of specified date.
joasdiCheck | Checks type of benefit.
lastQcyr | Returns last year of annual QCs.
needDiCess | Returns true if date of cessation to disability is needed.
needQcsByYear | Returns true if quarters of coverage by year from regular earnings are needed, false otherwise.
need_aw | Returns true if average wage increase assumptions are needed.
need_bases | Returns true if wage base assumptions are needed.
need_bi | Returns true if benefit increase assumptions are needed.
priorent1Check | Checks date of second prior entitlement to disability.
priorentCheck | Checks date of prior entitlement to disability.
pubpenCheck | Checks public pension amount.
pubpenDateCheck | Checks public pension entitlement date.
pubpenDateCheck2 | Checks the date of noncovered pension entitlement for consistency with date of birth and date of death.
qc51tdCheck | Checks summary quarters of coverage, 1951 to 1977.
qcCheck | Checks for correct numbers of QC's.
qctdCheck | Checks summary quarters of coverage, 1937 to 1977.
qctdCheck2 | Checks quarters of coverage to 1977 for consistency, assuming both qcs for 1937-1977 and qcs for 1951-1977 have been set to reasonable values.
setBenefitDate | Sets date of benefit.
setBirthDate | Sets date of birth.
setBlindind | Sets blind indicator.
setCessationDate | Sets date of disability cessation.
setCessationMfb | Sets mfb at disability cessation.
setCessationPia | Sets pia at disability cessation.
setDeathDate | Sets date of death.
setDeceasedOAB | Sets deceased OAB indicator.
setDeemedind | Sets deemed insured indicator.
setEarnHi | Sets Medicare earnings for the specified year.
setEarnOasdi | Sets OASDI-covered earnings.
setEntDate | Sets date of entitlement.
setIbegin | Sets first year of earnings, including any projected earnings. Also sets first year of HI earnings (ignored if indicator for HI earnings is not set before attempting to use HI earnings).
setIend | Sets last year of earnings, including any projected earnings.
setIndearn | Sets earnings indicator.
setIndrr | Sets railroad indicator.
setJoasdi | Sets type of benefit.
setMaxyear | Sets maximum year allowed.
setMqge | Sets mqge indicator.
setNhaddr | Sets one line of address.
setNhname | Sets number holder's name.
setOabCessDate | Sets date of cessation of oab prior to most recent dib.
setOabEntDate | Sets date of oab entitlement prior to most recent dib.
setOnsetDate | Sets date of disability onset.
setPebsData | Initializes some Statement data (no disability and no date of death).
setPebsEarn | Sets last year of Statement earnings when computation year changes, or after a Statement calculation has been done.
setPriorentDate | Sets date of entitlement to disability.
setPriorentDateCheck | Sets date of prior entitlement to disability.
setPubpen | Sets amount of monthly noncovered pension.
setPubpenDate | Sets date of noncovered pension entitlement.
setPubpenReservist | Sets amount of monthly noncovered pension after December 1994, after removing military reservist pension.
setQc51td | Sets summary quarters of coverage, 1951 to 1977.
setQcLumpYear | Sets last year of period for which quarters of coverage are entered as a lump sum.
setQcsByYear | Sets indicator for QCs by year prior to 1978.
setQctd | Sets summary quarters of coverage, 1937 to 1977.
setRecalc | Sets recalculation indicator.
setReservist | Sets reservist indicator.
setSex | Sets the sex of the worker.
setTaxType | Sets type of taxes for the specified year.
setTotalize | Sets totalization indicator.
setValdi | Sets number of periods of disability.
setWaitperDate | Sets first month of waiting period.
taxTypeCheck | Checks type of taxes.
valdi1Check | Checks number of periods of disability in nondisability case.
valdi2Check | Checks number of periods of disability in disability case.
valdiCheck | Checks number of periods of disability, using stored value.
waitpd1Check | Checks first month of prior waiting period.
waitpdCheck | Checks first month of waiting period.
zeroEarn | Zeroes out earnings and quarters of coverage before first year and after last year of specified earnings.
zeroEarnHi | Zeroes out HI earnings before first year and after last year of specified earnings.
zeroEarnOasdi | Zeroes out OASDI earnings before first year and after last year of specified earnings.
zeroOasdi | Zeroes out the type of benefit.
~WorkerData | Destroys this structure.


WorkerDataArray Members Enumerations

WorkerDataArray Members Enumerations
WorkerDataArray Members Legend
Enumerations
Name | Description
DimLimits | Constant for dimensioning.


Legend

Legend
WorkerDataArray Members
Legend
Constructor
Enumeration
Data Member


WorkerDataArray Members Public Data Members

WorkerDataArray Members Public Data Members
WorkerDataArray Members Legend
Public Data Members
Name | Description
workerData | Array of worker's pia data.


WorkerDataArray Members Public Methods

WorkerDataArray Members Public Methods
WorkerDataArray Members Legend
Public Methods
Name | Description
WorkerDataArray | Initializes arrays used in WorkerDataArray.
deleteContents | Resets all values to zero.
famSizeCheck | Checks if family size is ok.
getFamSize | Returns family size (not including worker).
setFamSize | Sets family size (not including worker).
~WorkerDataArray | Releases memory.


WorkerDataGeneral Members Enumerations

WorkerDataGeneral Members Enumerations
WorkerDataGeneral Members Legend
Enumerations
Name | Description
BitsetMembers | Members of the bitset.
DimLimits | Dimension limits.
ben_type | Type of benefit calculation.


Legend

Legend
WorkerDataGeneral Members
Legend
Constructor
abstract
virtual
Enumeration
Data Member
protected


WorkerDataGeneral Members Protected Data Members

WorkerDataGeneral Members Protected Data Members
WorkerDataGeneral Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
maxyear | Maximum year of projection is LASTYEARLR, unless changed.
qclumpyear | Quarters of coverage are summed before 1978, unless changed.


WorkerDataGeneral Members Public Data Members

WorkerDataGeneral Members Public Data Members
WorkerDataGeneral Members Legend
Public Data Members
Name | Description
childCareYears | Child care years, 1937 to WorkerDataGeneral::maxyear.
disabPeriod | Two periods of disability.
qc | Quarters of coverage, 1937 to WorkerDataGeneral::maxyear.


WorkerDataGeneral Members Public Friends

WorkerDataGeneral Members Public Friends
WorkerDataGeneral Members
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


WorkerDataGeneral Members Public Methods

WorkerDataGeneral Members Public Methods
WorkerDataGeneral Members Legend
Public Methods
Name | Description
WorkerDataGeneral | Initializes a WorkerDataGeneral, either with default values or from another WorkerDataGeneral.
anySelfEmp | Returns true if any self-employed taxes.
benefitDate1Check | Checks that date of benefit is in range.
benefitDate2Check | Checks that date of benefit is at or after entitlement.
birth1Check | Checks date of birth in a Statement case.
birth2Check | Checks date of birth in a non-Statement case.
cessation1Check | Checks date of prior disability cessation against date of prior onset.
cessation1OnsetCheck | Checks date of prior disability cessation against date of prior onset.
cessationCheck | Checks date of disability cessation, using stored values.
cessationCheck2 | Checks date of disability cessation, using passed values.
deathCheck | Checks that date of death is after birth.
deathCheck1 | Checks date of death (checks in survivor case for death in 1937 or later).
deathCheck2 | Checks date of death for basic correctness.
deathCheck3 | Checks that date of death is before entitlement, using passed values.
deleteContents | Initializes all variables to default values.
deleteDeathDate | Deletes date of death.
deleteEntDate | Deletes date of entitlement.
dis1Check | Checks date of prior disability onset.
disBirthEntCheck | Checks date of disability onset against dates of birth, entitlement, and benefit.
disCheck | Checks date of disability onset.
disDeathCheck | Checks date of disability onset against date of death.
earningsCheck | Checks for no earnings of any type.
entCheck | Checks that current date of entitlement is within bounds.
firstEarnHiYear | Returns first year of Medicare earnings, if any.
getBenefitDate | Returns date of benefit.
getBirthDate | Returns date of birth of worker.
getBlindind | Returns the blind indicator.
getDeathDate | Returns date of death.
getDeceasedOAB | Returns the deceased OAB indicator.
getDeemedind | Returns the deemed insured indicator.
getEarliestEntDate | Returns earliest entitlement date on this record.
getEarnEnable | Returns true if ok to enable earnings entry dialog box.
getEarnHi | Returns Medicare earnings for specified year.
getEarnHiOnly | Returns Medicare earnings for specified year if there are no OASDI earnings; otherwise return zero.
getEarnMS | Returns military service earnings for specified year.
getEarnMS3750 | Returns total military service earnings, 1937-50.
getEarnOasdhi | Returns OASDI plus Medicare earnings for specified year.
getEarnOasdi | Returns OASDI-covered earnings for the specified year.
getEarnRR | Returns railroad earnings for specified year.
getEarnRR3750 | Returns total railroad earnings, 1937-50.
getEntDate | Returns date of entitlement.
getFirstYearMS | Returns first year of military service (0 if none).
getFirstYearRR | Returns first year of railroad (0 if none).
getIbegin | Returns first year of earnings after any projection.
getIdNumber | Returns Social Security number as a number.
getIdString | Returns Social Security number as a string.
getIend | Returns last year of earnings after any projection.
getIndearn | Returns earnings indicator.
getIndms | Returns military service indicator.
getIndrr | Returns railroad indicator.
getJoasdi | Returns type of benefit calculation, including possibly Statement.
getLastYearMS | Returns last year of military service (0 if none).
getLastYearRR | Returns last year of military service (0 if none).
getMaxyear | Returns maximum year allowed.
getMqge | Returns Medicare-qualified government employment indicator.
getNhaddr | Returns one line of number holder's address.
getNhname | Returns number holder's name.
getOabCessDate | Returns date of cessation of oab entitlement prior to most recent DIB entitlement.
getOabEntDate | Returns date of entitlement to oab prior to most recent DIB entitlement.
getPubpen | Returns monthly noncovered pension.
getPubpenDate | Returns date of entitlement for noncovered pension.
getPubpenReservist | Returns monthly noncovered pension after December 1994, after removing reservist pension.
getQcLumpYear | Returns last year of period for which quarters of coverage are entered as a lump sum.
getQcovMS | Returns military service quarters of coverage for specified year.
getQcovMS3750 | Returns total military service quarters of coverage, 1937-50.
getQcovRR | Returns railroad quarters of coverage for specified year.
getQcovRR3750 | Returns total railroad quarters of coverage, 1937-50.
getQcovRR5177 | Returns total railroad quarters of coverage, 1951-77.
getQctot51td | Returns quarters of coverage from 1951 to 1977.
getQctottd | Returns quarters of coverage from 1937 to 1977.
getRecalc | Returns recalculation code.
getReservist | Returns reservist indicator.
getSex | Returns the sex of the worker.
getTaxType | Returns type of taxes for specified year.
getTotalize | Returns totalization indicator.
getValdi | Returns number of periods of disability.
hasQcsByYear | Returns indicator for QCs prior to 1978 by single year.
ibegin1Check | Checks first year of earnings in a Statement case.
ibegin2Check | Checks first year of earnings in a non-Statement case.
ibeginCheck | Checks for first year of earnings within bounds.
iendCheck | Checks last year of earnings.
isFemale | Return true if person is Sex::sex_type::FEMALE, false otherwise.
isMale | Return true if person is Sex::sex_type::MALE, false otherwise.
isPrimary | Returns primary beneficiary code.
isalive | Returns true if alive at end of year, false otherwise.
isdead | Returns true if dead at end of specified date.
joasdiCheck | Checks type of benefit.
lastQcyr | Returns last year of annual QCs.
needDiCess | Returns true if date of cessation to disability is needed.
needQcsByYear | Returns true if quarters of coverage by year from regular earnings are needed, false otherwise.
need_aw | Returns true if average wage increase assumptions are needed.
need_bases | Returns true if wage base assumptions are needed.
need_bi | Returns true if benefit increase assumptions are needed.
priorent1Check | Checks date of second prior entitlement to disability.
priorentCheck | Checks date of prior entitlement to disability.
pubpenCheck | Checks public pension amount.
pubpenDateCheck | Checks public pension entitlement date.
qc51tdCheck | Checks summary quarters of coverage, 1951 to 1977.
qcCheck | Checks for correct numbers of QC's.
qctdCheck | Checks summary quarters of coverage, 1937 to 1977.
qctdCheck2 | Checks quarters of coverage to 1977 for consistency, assuming both qcs for 1937-1977 and qcs for 1951-1977 have been set to reasonable values.
setBenefitDate | Sets date of benefit.
setBirthDate | Sets date of birth.
setBlindind | Sets blind indicator.
setCessationDate | Sets date of disability cessation.
setCessationMfb | Sets mfb at disability cessation.
setCessationPia | Sets pia at disability cessation.
setDeathDate | Sets date of death.
setDeceasedOAB | Sets deceased OAB indicator.
setDeemedind | Sets deemed insured indicator.
setEarnHi | Sets Medicare earnings for the specified year.
setEarnOasdi | Sets OASDI-covered earnings.
setEntDate | Sets date of entitlement.
setIbegin | Sets first year of earnings, including any projected earnings. Also sets first year of HI earnings (ignored if indicator for HI earnings is not set before attempting to use HI earnings).
setIend | Sets last year of earnings, including any projected earnings.
setIndearn | Sets earnings indicator.
setIndrr | Sets railroad indicator.
setJoasdi | Sets type of benefit.
setMaxyear | Sets maximum year allowed.
setMqge | Sets mqge indicator.
setNhaddr | Sets one line of address.
setNhname | Sets number holder's name.
setOabCessDate | Sets date of cessation of oab prior to most recent dib.
setOabEntDate | Sets date of oab entitlement prior to most recent dib.
setOnsetDate | Sets date of disability onset.
setPebsData | Initializes some Statement data (no disability and no date of death).
setPebsEarn | Sets last year of Statement earnings when computation year changes, or after a Statement calculation has been done.
setPriorentDate | Sets date of entitlement to disability.
setPriorentDateCheck | Sets date of prior entitlement to disability.
setPubpen | Sets amount of monthly noncovered pension.
setPubpenDate | Sets date of monthly noncovered pension entitlement.
setPubpenReservist | Sets amount of monthly noncovered pension after December 1994, after removing military reservist pension.
setQc51td | Sets summary quarters of coverage, 1951 to 1977.
setQcLumpYear | Sets last year of period for which quarters of coverage are entered as a lump sum.
setQcsByYear | Sets indicator for QCs by year prior to 1978.
setQctd | Sets summary quarters of coverage, 1937 to 1977.
setRecalc | Sets recalculation indicator.
setReservist | Sets reservist indicator.
setSex | Sets the sex of the worker.
setTaxType | Sets type of taxes for the specified year.
setTotalize | Sets totalization indicator.
setValdi | Sets number of periods of disability.
setWaitperDate | Sets first month of waiting period.
taxTypeCheck | Checks type of taxes.
valdi1Check | Checks number of periods of disability in nondisability case.
valdi2Check | Checks number of periods of disability in disability case.
valdiCheck | Checks number of periods of disability, using stored value.
waitpd1Check | Checks first month of prior waiting period.
waitpdCheck | Checks first month of waiting period.
zeroEarn | Zeroes out earnings and quarters of coverage before first year and after last year of specified earnings.
zeroEarnHi | Zeroes out HI earnings before first year and after last year of specified earnings.
zeroEarnOasdi | Zeroes out OASDI earnings before first year and after last year of specified earnings.
zeroOasdi | Zeroes out the type of benefit.
~WorkerDataGeneral | Destroys this structure.


Legend

Legend
AssumptionsFile Data Members
Legend
Data Member


AssumptionsFile Data Members Public Data Members

AssumptionsFile Data Members Public Data Members
AssumptionsFile Data Members Legend
Public Data Members
Name | Description
awincProj | Projected average wage increases.
biProj | Projected benefit increases.
catchupDoc | Catch-up benefit increases.


Legend

Legend
AssumptionsNonFile Data Members
Legend
Data Member


AssumptionsNonFile Data Members Public Data Members

AssumptionsNonFile Data Members Public Data Members
AssumptionsNonFile Data Members Legend
Public Data Members
Name | Description
awincProj | Projected average wage increases.
biProj | Projected benefit increases.
catchupDoc | Catch-up benefit increases.


Legend

Legend
AssumptionType Data Members
Legend
Data Member


AssumptionType Data Members Public Data Members

AssumptionType Data Members Public Data Members
AssumptionType Data Members Legend
Public Data Members
Name | Description
EXPANDED_PEBES | True to use a wider range of possible assumptions for Statement calculations.


Legend

Legend
AwbiData Data Members
Legend
Data Member


AwbiData Data Members Public Data Members

AwbiData Data Members Public Data Members
AwbiData Data Members Legend
Public Data Members
Name | Description
HI_BASE_YEAR | Year when HI wage base first differs from OASDI base.
base77 | Historical old-law wage bases.
baseHi | Historical HI wage bases.
baseOasdi | Historical OASDI wage bases.
cpiinc | Historical benefit increases.
fq | Historical average wages.


Legend

Legend
AwincDoc Data Members
Legend
Data Member
protected


AwincDoc Data Members Protected Data Members

AwincDoc Data Members Protected Data Members
AwincDoc Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
avgwage | Titles of projected average wage increase assumptions, other than the four TR assumptions.
awincTitle | Title of projected average wage increases.


AwincDoc Data Members Public Data Members

AwincDoc Data Members Public Data Members
AwincDoc Data Members Legend
Public Data Members
Name | Description
awinc | Array of average wage increases.


Legend

Legend
BaseYear Data Members
Legend
Data Member
protected


BaseYear Data Members Protected Data Members

BaseYear Data Members Protected Data Members
BaseYear Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
theYear | Computation year.


Legend

Legend
BaseYearNonFile Data Members
Legend
Data Member


BaseYearNonFile Data Members Public Data Members

BaseYearNonFile Data Members Public Data Members
BaseYearNonFile Data Members Legend
Public Data Members
Name | Description
TR_YEAR | Year of Trustees Report assumptions.
YEAR | Year for which data has been stored.


Legend

Legend
BendMfb Data Members
Legend
Data Member


BendMfb Data Members Public Data Members

BendMfb Data Members Public Data Members
BendMfb Data Members Legend
Public Data Members
Name | Description
BP1979 | Four bend points from 1979.


Legend

Legend
BendPia Data Members
Legend
Data Member


BendPia Data Members Public Data Members

BendPia Data Members Public Data Members
BendPia Data Members Legend
Public Data Members
Name | Description
BP1979 | Three bend points from 1979.


Legend

Legend
Biproj Data Members
Legend
Data Member
protected


Biproj Data Members Protected Data Members

Biproj Data Members Protected Data Members
Biproj Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
beninc | Titles of projected benefit increase assumptions, other than the four TR assumptions.
biprojTitle | Title of projected benefit increases.


Biproj Data Members Public Data Members

Biproj Data Members Public Data Members
Biproj Data Members Legend
Public Data Members
Name | Description
theData | Array of projected benefit increases.


Legend

Legend
BitAnnual Data Members
Legend
Data Member
protected


BitAnnual Data Members Protected Data Members

BitAnnual Data Members Protected Data Members
BitAnnual Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
baseYear | Base year of data.
lastYear | Last year of data.
theData | Bit array.


Legend

Legend
Catchup Data Members
Legend
Data Member
protected


Catchup Data Members Protected Data Members

Catchup Data Members Protected Data Members
Catchup Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
catchup | Catch-up benefit increases for 10 years of eligibility.


Catchup Data Members Public Data Members

Catchup Data Members Public Data Members
Catchup Data Members Legend
Public Data Members
Name | Description
NUM_CATCHUP_ELIG_YEARS | The number of years of eligibility considered (10).


Legend

Legend
CatchupDoc Data Members
Legend
Data Member


CatchupDoc Data Members Public Data Members

CatchupDoc Data Members Public Data Members
CatchupDoc Data Members Legend
Public Data Members
Name | Description
allownonzero | True to allow nonzero catch-up increases.
catchup | Catch-up benefit increases.


Legend

Legend
CatchupFile Data Members
Legend
Data Member
protected


CatchupFile Data Members Protected Data Members

CatchupFile Data Members Protected Data Members
CatchupFile Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
pathname | File information.


Legend

Legend
CatchupIncreases Data Members
Legend
Data Member
protected


CatchupIncreases Data Members Protected Data Members

CatchupIncreases Data Members Protected Data Members
CatchupIncreases Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Catch-up benefit increases for 8 calendar years.


CatchupIncreases Data Members Public Data Members

CatchupIncreases Data Members Public Data Members
CatchupIncreases Data Members Legend
Public Data Members
Name | Description
NUM_CATCHUP_INCREASES | The number of catch-up increases for one year of eligibility (8).


Legend

Legend
ChildCareCalc2Page Data Members
Legend
Data Member
protected


ChildCareCalc2Page Data Members Protected Data Members

ChildCareCalc2Page Data Members Protected Data Members
ChildCareCalc2Page Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
piaCal | Pia calculation detailed data.
piaData | Pia calculation summary data.
piaParams | Pia calculation parameters.
userAssumptions | User-specified assumptions.
workerData | Worker basic data.


Legend

Legend
ChildCareCalcLC Data Members
Legend
Data Member
protected


ChildCareCalcLC Data Members Protected Data Members

ChildCareCalcLC Data Members Protected Data Members
ChildCareCalcLC Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
lawChange | Law change parameters.


Legend

Legend
Date Data Members
Legend
Data Member


Date Data Members Public Data Members

Date Data Members Public Data Members
Date Data Members Legend
Public Data Members
Name | Description
highyear | Highest year that is acceptable (2200).
lowyear | Lowest year that is acceptable (1800).


Legend

Legend
DoubleAnnual Data Members
Legend
Data Member


DoubleAnnual Data Members Public Data Members

DoubleAnnual Data Members Public Data Members
DoubleAnnual Data Members Legend
Public Data Members
Name | Description
baseYear | Base year of data.
theData | Vector of doubles.


Legend

Legend
DoubleMonth Data Members
Legend
Data Member
protected


DoubleMonth Data Members Protected Data Members

DoubleMonth Data Members Protected Data Members
DoubleMonth Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Double array.


Legend

Legend
DoubleQuarter Data Members
Legend
Data Member
protected


DoubleQuarter Data Members Protected Data Members

DoubleQuarter Data Members Protected Data Members
DoubleQuarter Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Double data.


Legend

Legend
EarnProject Data Members
Legend
Data Member


EarnProject Data Members Public Data Members

EarnProject Data Members Public Data Members
EarnProject Data Members Legend
Public Data Members
Name | Description
PERC_HIGH | Highest acceptable projection percentage.
PERC_LOW | Lowest acceptable projection percentage.
earnpebs | Worker earnings, 1937 to maxyear, as read in.


Legend

Legend
FieldOfficeInfo Data Members
Legend
Data Member


FieldOfficeInfo Data Members Public Data Members

FieldOfficeInfo Data Members Public Data Members
FieldOfficeInfo Data Members Legend
Public Data Members
Name | Description
numLines | Number of address lines (4).


Legend

Legend
FloatAnnual Data Members
Legend
Data Member


FloatAnnual Data Members Public Data Members

FloatAnnual Data Members Public Data Members
FloatAnnual Data Members Legend
Public Data Members
Name | Description
baseYear | Base year of data.
theData | Vector of floats.


Legend

Legend
FloatMonth Data Members
Legend
Data Member
protected


FloatMonth Data Members Protected Data Members

FloatMonth Data Members Protected Data Members
FloatMonth Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Float array.


Legend

Legend
FloatQuarter Data Members
Legend
Data Member
protected


FloatQuarter Data Members Protected Data Members

FloatQuarter Data Members Protected Data Members
FloatQuarter Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
theData | Float data.


Legend

Legend
Genfile Data Members
Legend
Data Member
protected


Genfile Data Members Protected Data Members

Genfile Data Members Protected Data Members
Genfile Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
pathname | Pathname of this file.


Legend

Legend
IntAnnual Data Members
Legend
Data Member


IntAnnual Data Members Public Data Members

IntAnnual Data Members Public Data Members
IntAnnual Data Members Legend
Public Data Members
Name | Description
baseYear | Base year of data.
theData | Integer array.


Legend

Legend
LawChangeArray Data Members
Legend
Data Member


LawChangeArray Data Members Public Data Members

LawChangeArray Data Members Public Data Members
LawChangeArray Data Members Legend
Public Data Members
Name | Description
lawChange | Pointers to the law changes.
lawChangeAGE65COMP | Pointer to LawChangeAGE65COMP.
lawChangeALLEARN | Pointer to LawChangeALLEARN.
lawChangeBPFRACWAGE | Pointer to LawChangeBPFRACWAGE.
lawChangeBPMINCONST | Pointer to LawChangeBPMINCONST.
lawChangeBPSPECRATE | Pointer to LawChangeBPSPECRATE.
lawChangeCHILDCARECREDIT | Pointer to LawChangeCHILDCARECREDIT.
lawChangeCHILDCAREDROPOUT | Pointer to LawChangeCHILDCAREDROPOUT.
lawChangeCOLACHANGE | Pointer to LawChangeCOLACHANGE.
lawChangeDECLINEPERC | Pointer to LawChangeDECLINEPERC.
lawChangeDROPOUTCHG | Pointer to LawChangeDROPOUTCHG.
lawChangeMARRLENGTH | Pointer to LawChangeMARRLENGTH.
lawChangeNEWFORMULA | Pointer to LawChangeNEWFORMULA.
lawChangeNEWSPECMIN | Pointer to LawChangeNEWSPECMIN.
lawChangeNRACHANGE | Pointer to LawChangeNRACHANGE.
lawChangePSAACCT | Pointer to LawChangePSAACCT.
lawChangeTAXBENCHG | Pointer to LawChangeTAXBENCHG.
lawChangeTAXRATECHG | Pointer to LawChangeTAXRATECHG.
lawChangeWAGEBASECHG | Pointer to LawChangeWAGEBASECHG.
lawChangeWIDFACTOR | Pointer to LawChangeWIDFACTOR.
lawChangeWIFEFACTOR | Pointer to LawChangeWIFEFACTOR.


Legend

Legend
LawChangeNRACHANGE Data Members
Legend
Data Member


LawChangeNRACHANGE Data Members Public Data Members

LawChangeNRACHANGE Data Members Public Data Members
LawChangeNRACHANGE Data Members Legend
Public Data Members
Name | Description
ageArChange | The age at which the actuarial reduction factor changes.
arMonthlyFactor67_69 | Monthly actuarial reduction factor between ages 67 and 69.
arMonthlyFactor69Plus | Monthly actuarial reduction factor over age 69.


Legend

Legend
LawChangeOut Data Members
Legend
Data Member


LawChangeOut Data Members Public Data Members

LawChangeOut Data Members Public Data Members
LawChangeOut Data Members Legend
Public Data Members
Name | Description
lawChange | Law change data.


Legend

Legend
LawChangeWIDFACTOR Data Members
Legend
Data Member


LawChangeWIDFACTOR Data Members Public Data Members

LawChangeWIDFACTOR Data Members Public Data Members
LawChangeWIDFACTOR Data Members Legend
Public Data Members
Name | Description
newAgedWidFactor | The ultimate changed factor for an aged widow(er) benefit (1.125).
numYears | The number of years over which the factor for an aged widow(er) benefit is phased in (40).


Legend

Legend
LawChangeWIFEFACTOR Data Members
Legend
Data Member


LawChangeWIFEFACTOR Data Members Public Data Members

LawChangeWIFEFACTOR Data Members Public Data Members
LawChangeWIFEFACTOR Data Members Legend
Public Data Members
Name | Description
amtPerYear | The annual amount of reduction in the factor for an aged spouse benefit (0.01).
newSpouseFactor | The ultimate changed factor for an aged spouse benefit (0.33).


Legend

Legend
MilServDates Data Members
Legend
Data Member


MilServDates Data Members Public Data Members

MilServDates Data Members Public Data Members
MilServDates Data Members Legend
Public Data Members
Name | Description
amtPerMonth37_56 | Amount of credit per month for pre-1951 military service wage credits.
amtPerQtr57_77 | Amount of credit per quarter for military service wage credits from 1957 through 1977.
amtPerYear78_01 | Amount of credit per year for military service wage credits from 1978 through 2001.
dec1950 | Last possible date of pre-1951 military service wage credits.
endDate | Ending date of military service.
firstMilServDate | First possible date of military service wage credits.
lastMilServDate | Last possible date of military service wage credits.
startDate | Starting date of military service.


Legend

Legend
MilServDatesVec Data Members
Legend
Data Member


MilServDatesVec Data Members Public Data Members

MilServDatesVec Data Members Public Data Members
MilServDatesVec Data Members Legend
Public Data Members
Name | Description
MAX_MILSERVDATES | The number of MilServDates records allowed.
msdates | An array of MilServDates records.


Legend

Legend
OldPia Data Members
Legend
Data Member
protected


OldPia Data Members Protected Data Members

OldPia Data Members Protected Data Members
OldPia Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
iamemax | Maximum ame in pia interval.


Legend

Legend
OldStart Data Members
Legend
Data Member
protected


OldStart Data Members Protected Data Members

OldStart Data Members Protected Data Members
OldStart Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
entDate | The date of entitlement.


OldStart Data Members Public Data Members

OldStart Data Members Public Data Members
OldStart Data Members Legend
Public Data Members
Name | Description
INC_PER_YEAR | Factor for amount of increment per year (0.01).
bendMfb | Bend points for MFB formula.
percMfb | Wage-indexed MFB formula percentages.
portionAme | Portion of AME in each interval of PIB formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.


Legend

Legend
OldStartLC Data Members
Legend
Data Member
protected


OldStartLC Data Members Protected Data Members

OldStartLC Data Members Protected Data Members
OldStartLC Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
lawChange | Law change parameters.


Legend

Legend
Outfile Data Members
Legend
Data Member
protected


Outfile Data Members Protected Data Members

Outfile Data Members Protected Data Members
Outfile Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
PAGE_TITLE_LINES | Number of title lines.
dateModyyr | The current date as month, day, and year.
outstrm | Output stream.
pageNum | Page number.


Legend

Legend
OutFileHTML Data Members
Legend
Data Member
protected


OutFileHTML Data Members Protected Data Members

OutFileHTML Data Members Protected Data Members
OutFileHTML Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
firstPage | Indicator for first page of output.


OutFileHTML Data Members Public Data Members

OutFileHTML Data Members Public Data Members
OutFileHTML Data Members Legend
Public Data Members
Name | Description
PAGE_TITLE_LINES | Number of title lines.
cssPage | The CSS page.
tagRightChar | Represents the closing angle-bracket of an HTML tag.


Legend

Legend
PageCounters Data Members
Legend
Data Member


PageCounters Data Members Public Data Members

PageCounters Data Members Public Data Members
PageCounters Data Members Legend
Public Data Members
Name | Description
PIA_IDS_PAGE1 | Error code.
PIA_IDS_PAGE2 | Error code.
PIA_IDS_PAGE3 | Error code.


Legend

Legend
PageOut Data Members
Legend
Data Member
protected


PageOut Data Members Protected Data Members

PageOut Data Members Protected Data Members
PageOut Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
loc | A locale used to imbue PageOut::strm.
outputString | Strings for output.
punct | Numeric punctuation facet with 3 digits per thousands separator.
strm | A stream to insert commas in a formatted number.


PageOut Data Members Public Data Members

PageOut Data Members Public Data Members
PageOut Data Members Legend
Public Data Members
Name | Description
MAXLINES | The maximum number of lines on a page.


Legend

Legend
Path Data Members
Legend
Data Member


Path Data Members Public Data Members

Path Data Members Public Data Members
Path Data Members Legend
Public Data Members
Name | Description
allSeparators | A string with all the possible separator characters.
altDirectorySeparatorChar | The alternate character used to separate directory levels in a path string (forward slash).
directorySeparatorChar | The character used to separate directory levels in a path string (backward slash).


Legend

Legend
Pebs Data Members
Legend
Data Member


Pebs Data Members Public Data Members

Pebs Data Members Public Data Members
Pebs Data Members Legend
Public Data Members
Name | Description
age70 | Age 70 and 0 months.
ageNow | Current age.
agePlan1 | Age of planned early retirement, after adjusting for current age and earliest possible age (62).
fullRetAge | Age for worker's full retirement.
oab1 | Age for full retirement calculation (could be between full retirement and 70).
oab2 | Age for late retirement calculation (could be 70 or later).


Legend

Legend
PebsOut Data Members
Legend
Data Member


PebsOut Data Members Public Data Members

PebsOut Data Members Public Data Members
PebsOut Data Members Legend
Public Data Members
Name | Description
pebsCreditInfo | Credit information.
pebsEarnings | Earnings information.
pebsEarningsInfo | Earnings information.
pebsLetter | Letter transmitting results.
pebsOasdiEst | OASDI estimates.
pebsOasdiInfo | OASDI benefit information.
pebsWorkerEarnings | Worker information and earnings.
pebsWorkerInfo | Worker information.


Legend

Legend
PebsPageOut Data Members
Legend
Data Member


PebsPageOut Data Members Public Data Members

PebsPageOut Data Members Public Data Members
PebsPageOut Data Members Legend
Public Data Members
Name | Description
equals | String of equals signs.
hyphens | String of hyphens.


Legend

Legend
PercMfb Data Members
Legend
Data Member


PercMfb Data Members Public Data Members

PercMfb Data Members Public Data Members
PercMfb Data Members Legend
Public Data Members
Name | Description
PERC | Four percentages.


Legend

Legend
PercPia Data Members
Legend
Data Member


PercPia Data Members Public Data Members

PercPia Data Members Public Data Members
PercPia Data Members Legend
Public Data Members
Name | Description
PERC | The three percentages for the regular benefit formula.
WINDFALL_PERC | The first percentage under the windfall elimination provision.
WINDFALL_YEARS | Number of years of coverage that negates the windfall elimination provision.


Legend

Legend
PiaCal Data Members
Legend
Data Member


PiaCal Data Members Public Data Members

PiaCal Data Members Public Data Members
PiaCal Data Members Legend
Public Data Members
Name | Description
childCareCalc | Pointer to child care calculation.
dibGuar | Pointer to disability guarantee.
frozMin | Pointer to frozen minimum method.
highPiaMethod | Pointer to method with high pia.
oldStart | Pointer to old-start method.
piaData | Worker's pia calculation data.
piaMethod | Pia calculation methods that apply to all benies in the family.
piaParams | Pia calculation parameters.
piaTable | Pointer to pia table method.
specMin | Pointer to special minimum method.
transGuar | Pointer to transitional guarantee.
wageInd | Pointer to wage-indexed method.
wageIndNonFreeze | Pointer to wage-indexed non-freeze method.
widowMethod | Pia calculation methods that apply only to widow(er)s.
workerData | Worker's personal data.


Legend

Legend
PiaCalAny Data Members
Legend
Data Member


PiaCalAny Data Members Public Data Members

PiaCalAny Data Members Public Data Members
PiaCalAny Data Members Legend
Public Data Members
Name | Description
earnProject | Projected earnings.
secondaryArray | Array of Secondary benefits.
userAssumptions | User-specified assumptions.
widowArray | Widow and other family member calculation data.
widowDataArray | Widow and other family member calculation data.


Legend

Legend
PiaData Data Members
Legend
Data Member


PiaData Data Members Public Data Members

PiaData Data Members Public Data Members
PiaData Data Members Legend
Public Data Members
Name | Description
ageBen | Age at benefit date of worker.
ageEnt | Age at entitlement of worker.
childCareMaxCredit | The maximum amount of credit for each child care year, and the year in which it should be credited.
childCareOrder | Indicators for use of child care credits.
compPeriodNew | Computation period for new-start calculations.
compPeriodNewNonFreeze | Computation period for non-freeze new-start calculations.
compPeriodOld | Computation period for old-start calculation.
disInsCode | Disability insured status code.
disInsNonFreezeCode | Disability insured status code for non-freeze.
earlyRetAge | Earliest possible retirement age.
earnHi | Worker HI earnings, 1937 to maxyear.
earnHiLimited | Worker HI earnings limited to wage base, 1937 to maxyear.
earnMilServ | Military service wage credits, 1951 to date.
earnOasdi | Worker OASDI earnings, 1937 to maxyear, including railroad and military service.
earnOasdiLimited | Worker OASDI earnings limited to wage base, 1937 to maxyear, including railroad and military service.
earnTotalized | Worker OASDI earnings attributed for totalization, 1937 to maxyear.
earnTotalizedLimited | Worker OASDI earnings attributed for totalization, limited to wage base, 1937 to maxyear.
finsCode | Fully insured status code.
finsNonFreezeCode | Fully insured non-freeze status code.
freezeYears | Years wholly within a freeze period.
fullRetAge | Full retirement age.
highMfb | Highest applicable MFB.
highPia | Highest applicable PIA.
partialFreezeYears | Years partially within a freeze period.
qcov | Quarters of coverage, including railroad and military service.
qcovMilServ | Military service quarters of coverage, 1937 to 1956.
relEarnPosition | Annual relative earnings position, 1937 to maxyear.
roundedBenefit | Benefit actually payable, after dollar rounding.
supportPia | Support PIA when highest PIA is special minimum and delayed retirement credits are involved.
unroundedBenefit | Benefit actually payable, before dollar rounding.


Legend

Legend
PiaDataArray Data Members
Legend
Data Member


PiaDataArray Data Members Public Data Members

PiaDataArray Data Members Public Data Members
PiaDataArray Data Members Legend
Public Data Members
Name | Description
piaData | Array of worker's pia data.


Legend

Legend
PiaMethod Data Members
Legend
Data Member
protected


PiaMethod Data Members Protected Data Members

PiaMethod Data Members Protected Data Members
PiaMethod Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
mfbsub | Temporary mfb.
piaData | Pointer to pia calculation data.
piaParams | Pointer to pia calculation parameters.
piasub | Temporary pia.
workerData | Pointer to worker data.
yearCpi | Years of benefit increases applied.


PiaMethod Data Members Public Data Members

PiaMethod Data Members Public Data Members
PiaMethod Data Members Legend
Public Data Members
Name | Description
earnIndexed | The worker's earnings after indexing.
earnMultiplied | The worker's earnings multiplied by average wages of base year.
iorder | Indicators for use of earnings.
mfbElig | MFB at eligibility and succeeding MFB's.
mfbEnt | MFB at entitlement.
piaElig | PIA at eligibility and succeeding PIA's.
piaEnt | PIA at entitlement.


Legend

Legend
PiaOut Data Members
Legend
Data Member


PiaOut Data Members Public Data Members

PiaOut Data Members Public Data Members
PiaOut Data Members Legend
Public Data Members
Name | Description
MAX_REINDWID | Maximum number of re-indexed widow(er)s.
childCareCalc1Page | Wage-indexed earnings with child-care dropout years.
childCareCalc2Page | Wage-indexed calculation with child-care dropout years.
dibGuarPage | Disability guarantee calculation.
earningsPage | Earnings used in calculation.
familyPage | Family members calculation.
frozMinPage | Frozen minimum calculation.
insuredPage | Insured status calculation.
oldStart1Page | Old-start earnings.
oldStart2Page | Old-start calculation.
onePage | One-page output.
piaTable1Page | Pia table earnings.
piaTable2Page | Pia table calculation.
reindWid1Page | Re-indexed widow guarantee earnings.
reindWid2Page | Re-indexed widow guarantee calculation.
specMin1Page | Special minimum earnings.
specMin2Page | Special minimum calculation.
summary1Page | Top part of summary page.
summary2Page | Middle part of summary page.
summary3Page | Bottom part of summary page.
summaryPage | Summary page of results.
taxesPage | Taxes calculation.
transGuar1Page | Transitional guarantee earnings.
transGuar2Page | Transitional guarantee calculation.
wageInd1Page | Wage-indexed earnings.
wageInd2Page | Wage-indexed calculation.
wageIndNonFreeze1Page | Wage-indexed earnings.
wageIndNonFreeze2Page | Wage-indexed calculation.


Legend

Legend
PiaPageOut Data Members
Legend
Data Member
protected


PiaPageOut Data Members Protected Data Members

PiaPageOut Data Members Protected Data Members
PiaPageOut Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
pageTitle | Title at top of page.


Legend

Legend
PiaParams Data Members
Legend
Data Member
protected


PiaParams Data Members Protected Data Members

PiaParams Data Members Protected Data Members
PiaParams Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
baseHi | HI wage bases.
bendOS | Bend points for old-start PIB formula.
catchup | Catch-up benefit increases.
cpiinc | Array of benefit increases.
fq | Array of annual average earnings.
fqinc | Array of percentage increases in annual average earnings.
istart | Current year (year after last known benefit increase).
maxyear | Maximum year allowed.
monthBeninc | Array of month of benefit increase.
noChange | Array of indicators for no change allowed.
percOS | Old-start PIB formula percentages.
percSpecMin | Percentage of old-law wage base required for year of coverage.
recalcInd | Indicator for which year(s) the PIA should be recalculated due to a newly effective law change.
specMinMfb | Special minimum mfbs.
specMinMfb2001 | Special minimum mfbs for August-November 2001.
specMinPerc | Percentage of old-law wage base required for year of coverage for special minimum.
specMinPia | Special minimum pias.
specMinPia2001 | Special minimum pias for August-November 2001.
titleAw | Title of average wage assumptions.
titleBi | Title of benefit increase assumptions.
yocAmountSpecMin | Amount required for year of coverage for special minimum.
yocAmountWindfall | Amount required for year of coverage for windfall elimination provision.


PiaParams Data Members Public Data Members

PiaParams Data Members Public Data Members
PiaParams Data Members Legend
Public Data Members
Name | Description
YEAR1999 | Year of extra 0.1 percent benefit increase.
age16 | Age 16.
age18 | Age 18.
age19 | Age 19.
age199 | Age 199 (impossible age).
age22 | Age 22.
age50 | Age 50.
age60 | Age 60.
age62 | Age 62.
age621 | Age 62 and 1 month.
age65 | Age 65.
age65_10 | Age 65 and 10 months.
age65_2 | Age 65 and 2 months.
age65_4 | Age 65 and 4 months.
age65_6 | Age 65 and 6 months.
age65_8 | Age 65 and 8 months.
age66 | Age 66.
age66_10 | Age 66 and 10 months.
age66_2 | Age 66 and 2 months.
age66_4 | Age 66 and 4 months.
age66_6 | Age 66 and 6 months.
age66_8 | Age 66 and 8 months.
age67 | Age 67.
age70 | Age 70.
age72 | Age 72.
age75 | Age 75.
amend01 | The date of special 0.1 percent benefit increase.
amend118_273 | The date of WEP no longer being used for benefit computations.
amend50 | The date of 1950 amendments.
amend52 | The date of 1952 amendments.
amend54 | The date of 1954 amendments.
amend56 | The date of 1956 amendments.
amend561 | First birth date for which age 62 is effective for females.
amend562 | Second birth date for which age 62 is effective for females.
amend58 | The date of 1958 amendments.
amend61 | The date of 1961 amendments.
amend611 | First birth date for which age 62 is effective for males.
amend612 | Second birth date for which age 62 is effective for males.
amend651 | The date of 1965 amendments for benefit increase.
amend652 | The date of 1965 amendments for change to age 60.
amend653 | The date of 1965 amendments for old start.
amend671 | The date of 1967 amendments for old start.
amend672 | The date of 1967 amendments for benefit increase.
amend69 | The date of 1969 amendments.
amend70 | The date of 1970 amendments.
amend721 | The date of 1972 amendments for benefit increase.
amend722 | The date of 1972 amendments for special minimum.
amend741 | The date of 1974 amendments for partial increase.
amend742 | The date of 1974 amendments for full increase.
amend771 | The date of 1977 amendments for frozen pia table.
amend772 | The date of 1977 amendments for start of wage indexing.
amend80 | The date of 1980 amendments.
amend811 | The date of birth for age 62 and 1 month in 1981 amendments.
amend812 | The date of 1981 amendments (month, day, and year).
amend813 | The date of 1981 amendments (month and year).
amend82 | The date of 1982 amendments.
amend83 | The date of 1983 amendments.
amend88 | The date of 1988 amendments.
amend90 | The date of 1990 amendments.
amtperincyr | Amount per old start increment year.
arFactorWid285 | Total actuarial reduction factor for aged widow(er)s.
arMonthlyFactor65_67 | Monthly actuarial reduction factor between ages 65 and 67.
arMonthlyFactorOab62_65 | Monthly actuarial reduction factor between ages 62 and 65.
arMonthlyFactorSpouse62_65 | Monthly actuarial reduction factor for aged spouses between ages 62 and 65.
beninc74 | Temporary benefit increase, March-May 1974.
bpMfbOut | Table of mfb formula bend points.
bpPiaOut | Table of pia formula bend points.
factor150 | Factor for calculating mfbs.
factor175 | Factor for calculating mfbs.
factor50 | Factor for calculating life benefits.
factor75 | Factor for calculating survivor benefits.
factor825 | Factor for calculating widow(er) benefits.
maxMonthsAr62_65 | Maximum number of months of actuarial reduction between ages 62 and 65.
maxMonthsAr62_67 | Maximum number of months of actuarial reduction between ages 62 and 67.
maxMonthsAr65_67 | Maximum number of months of actuarial reduction between ages 65 and 67.
percPiaOut | Table of pia formula percentages.
qcamt | Array of amounts required for quarter of coverage.
qtr184 | Starting point of deemed insured.
year37qtr1 | First quarter for which a quarter of coverage could be earned.


Legend

Legend
PiaParamsTR Data Members
Legend
Data Member
protected


PiaParamsTR Data Members Protected Data Members

PiaParamsTR Data Members Protected Data Members
PiaParamsTR Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
altNum | Trustees Report alternative (AssumptionType::assum_type::ALTERN_I, AssumptionType::assum_type::ALTERN_IIB, AssumptionType::assum_type::ALTERN_III, or AssumptionType::assum_type::ALTERN_IIA).


Legend

Legend
PiaRead Data Members
Legend
Data Member
protected


PiaRead Data Members Protected Data Members

PiaRead Data Members Protected Data Members
PiaRead Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
secondaryArray | Array of Secondary benefit information.
userAssumptions | User-specified assumptions.
widowArray | Widow and other family member calculation data.
widowDataArray | Widow and other family member basic data.
workerData | Worker data.


PiaRead Data Members Public Data Members

PiaRead Data Members Public Data Members
PiaRead Data Members Legend
Public Data Members
Name | Description
inputLine | Input line.
lineType | Type of input line.
unusedLine | True if a line has been gotten from the file but not used.


Legend

Legend
PiaWrite Data Members
Legend
Data Member
protected


PiaWrite Data Members Protected Data Members

PiaWrite Data Members Protected Data Members
PiaWrite Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
secondaryArray | Array of Secondary benefit information.
userAssumptions | User-specified assumptions.
widowArray | Widow and other family member calculation data.
widowDataArray | Widow and other family member basic data.
workerData | Worker data.


Legend

Legend
Psa Data Members
Legend
Data Member


Psa Data Members Public Data Members

Psa Data Members Public Data Members
Psa Data Members Legend
Public Data Members
Name | Description
contribAge | The age splits for contribution rates, when using rates based on age.
contribPerc | Contribution rates when using rates based on age, as opposed to using the same set rates for everybody.


Legend

Legend
PunctFacet Data Members
Legend
Data Member


PunctFacet Data Members Public Data Members

PunctFacet Data Members Public Data Members
PunctFacet Data Members Legend
Public Data Members
Name | Description
yearStr | String representations of all the years in the output range.


Legend

Legend
Qc Data Members
Legend
Data Member


Qc Data Members Public Data Members

Qc Data Members Public Data Members
Qc Data Members Legend
Public Data Members
Name | Description
MAXQCSINYEAR | The maximum number of qcs in one year (4).


Legend

Legend
Qcamt Data Members
Legend
Data Member


Qcamt Data Members Public Data Members

Qcamt Data Members Public Data Members
Qcamt Data Members Legend
Public Data Members
Name | Description
AUTO_YEAR | The year when automatic increases started for the quarter of coverage amount.
qcamt1977 | The quarter of coverage amount prior to 1978.
qcamt1978 | The quarter of coverage amount in 1978.


Legend

Legend
QcPacked Data Members
Legend
Data Member


QcPacked Data Members Public Data Members

QcPacked Data Members Public Data Members
QcPacked Data Members Legend
Public Data Members
Name | Description
NUM_QCS | Number of elements in this class.


Legend

Legend
RailRoadData Data Members
Legend
Data Member


RailRoadData Data Members Public Data Members

RailRoadData Data Members Public Data Members
RailRoadData Data Members Legend
Public Data Members
Name | Description
earningsArray | Annual railroad earnings, starting in 1951.
qcArray | Annual railroad quarters of coverage, from 1951 to 1977.


Legend

Legend
ReindWid1Page Data Members
Legend
Data Member


ReindWid1Page Data Members Public Data Members

ReindWid1Page Data Members Public Data Members
ReindWid1Page Data Members Legend
Public Data Members
Name | Description
reindWid | Reindexed widow(er) calculation.


Legend

Legend
ReindWid2Page Data Members
Legend
Data Member


ReindWid2Page Data Members Public Data Members

ReindWid2Page Data Members Public Data Members
ReindWid2Page Data Members Legend
Public Data Members
Name | Description
reindWid | Reindexed widow(er) calculation.


Legend

Legend
ReindWid Data Members
Legend
Data Member
protected


ReindWid Data Members Protected Data Members

ReindWid Data Members Protected Data Members
ReindWid Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
widowPiaData | Widow calculation data.


ReindWid Data Members Public Data Members

ReindWid Data Members Public Data Members
ReindWid Data Members Legend
Public Data Members
Name | Description
secondary | Secondary benefit data.
widowData | Widow basic data.


Legend

Legend
RetireTest Data Members
Legend
Data Member


RetireTest Data Members Public Data Members

RetireTest Data Members Public Data Members
RetireTest Data Members Legend
Public Data Members
Name | Description
rtea62 | Annual amounts under full retirement age.
rtea62m | Monthly amounts under full retirement age.
rtea65 | Annual amounts over full retirement age.
rtea65m | Monthly amounts over full retirement age.
rteaHigh | Annual amounts at second tier (effective 1961-1972).


Legend

Legend
Secondary Data Members
Legend
Data Member


Secondary Data Members Public Data Members

Secondary Data Members Public Data Members
Secondary Data Members Legend
Public Data Members
Name | Description
bic | Type of beneficiary code.
entDate | The date of entitlement.
pifc | Type of pia calculation method.


Legend

Legend
SecondaryArray Data Members
Legend
Data Member


SecondaryArray Data Members Public Data Members

SecondaryArray Data Members Public Data Members
SecondaryArray Data Members Legend
Public Data Members
Name | Description
secondary | Array of secondary data.


Legend

Legend
Sga Data Members
Legend
Data Member


Sga Data Members Public Data Members

Sga Data Members Public Data Members
Sga Data Members Legend
Public Data Members
Name | Description
sgaBlindA | SGA annual amounts for the blind.
sgaBlindM | SGA monthly (December) amounts for the blind.
sgaMaxA | SGA annual maximum amounts for the non-blind.
sgaMaxM | SGA monthly (December) maximum amounts for the non-blind.
sgaMinA | SGA annual minimum amounts for the non-blind.
sgaMinM | SGA monthly (December) minimum amounts for the non-blind.


Legend

Legend
SgaGeneral Data Members
Legend
Data Member
protected


SgaGeneral Data Members Protected Data Members

SgaGeneral Data Members Protected Data Members
SgaGeneral Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
FIRST_PROJ_YEAR | First year of projection (2001).


Legend

Legend
TaxBenefits Data Members
Legend
Data Member


TaxBenefits Data Members Public Data Members

TaxBenefits Data Members Public Data Members
TaxBenefits Data Members Legend
Public Data Members
Name | Description
HiYear | The year that the OASDHI tax became effective.
MARRIEDOASDHITAX | OASDHI tax for married taxpayers in first tier.
MARRIEDOASDHITHRESHOLD | OASDHI threshold for married taxpayers.
MARRIEDOASDITHRESHOLD | OASDI threshold for married taxpayers.
OasdhiRate | The OASDHI tax rate.
OasdiRate | The OASDI tax rate.
SINGLEOASDHITAX | OASDHI tax for single taxpayers in first tier.
SINGLEOASDHITHRESHOLD | OASDHI threshold for single taxpayers.
SINGLEOASDITHRESHOLD | OASDI threshold for single taxpayers.
START_YEAR | Starting year of tax on Social Security benefits.


Legend

Legend
TaxData Data Members
Legend
Data Member


TaxData Data Members Public Data Members

TaxData Data Members Public Data Members
TaxData Data Members Legend
Public Data Members
Name | Description
taxesDi | DI taxes paid by year.
taxesHi | HI taxes paid by year.
taxesOasdhi | OASDHI taxes paid by year.
taxesOasdi | OASDI taxes paid by year.
taxesOasi | OASI taxes paid by year.


Legend

Legend
TaxRates Data Members
Legend
Data Member
protected


TaxRates Data Members Protected Data Members

TaxRates Data Members Protected Data Members
TaxRates Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
maxyear | Maximum year allowed.


TaxRates Data Members Public Data Members

TaxRates Data Members Public Data Members
TaxRates Data Members Legend
Public Data Members
Name | Description
LAST_TAX_RATE_YEAR | Last year that tax rates change.
NUMTAXRATES | Number of years of historical tax rates.


Legend

Legend
TaxRatesLC Data Members
Legend
Data Member
protected


TaxRatesLC Data Members Protected Data Members

TaxRatesLC Data Members Protected Data Members
TaxRatesLC Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
lawChange | Law change data.


Legend

Legend
TransGuar Data Members
Legend
Data Member


TransGuar Data Members Public Data Members

TransGuar Data Members Public Data Members
TransGuar Data Members Legend
Public Data Members
Name | Description
bendMfb | Bend points for MFB formula.
percMfb | Wage-indexed MFB formula percentages.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.


Legend

Legend
UserAssumptions Data Members
Legend
Data Member


UserAssumptions Data Members Public Data Members

UserAssumptions Data Members Public Data Members
UserAssumptions Data Members Legend
Public Data Members
Name | Description
awincproj | Projected increases in annual average earnings.
base77 | Old-law wage bases (ignoring 1979-81 ad hoc increases), 1937 to maxyear, as read in.
baseOasdi | Wage base under present law, 1937 to maxyear, as read in.
biproj | Projected benefit increases.
catchup | Catch-up benefit increases.
titleAw | Title of user's average wages.
titleBi | Title of user's benefit increases


Legend

Legend
WageBaseGeneral Data Members
Legend
Data Member
protected


WageBaseGeneral Data Members Protected Data Members

WageBaseGeneral Data Members Protected Data Members
WageBaseGeneral Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
defcomp | Increase in average wage due to deferred comp in 1990.
wageBaseInd | Type of wage base.


Legend

Legend
WageIndGeneral Data Members
Legend
Data Member
protected


WageIndGeneral Data Members Protected Data Members

WageIndGeneral Data Members Protected Data Members
WageIndGeneral Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
indexYearAvgWage | Average wage in indexing year.
windfallInd | Windfall indicator.
yearsTotal | Number of years of coverage for windfall elimination.


WageIndGeneral Data Members Public Data Members

WageIndGeneral Data Members Public Data Members
WageIndGeneral Data Members Legend
Public Data Members
Name | Description
bendMfb | Bend points for MFB formula.
bendPia | Bend points for PIA formula.
mfbRealWageGain | MFB at entitlement before real-wage-gain adjustment.
percMfb | Wage-indexed MFB formula percentages.
percPia | Wage-indexed PIA formula percentages.
percWind | Windfall PIA formula percentages.
piaRealWageGain | PIA at entitlement before real-wage-gain adjustment.
portionAime | Portion of AIME in each interval of PIA formula.
portionPiaElig | Portion of AIME PIA in each interval of MFB formula.


Legend

Legend
WorkerData Data Members
Legend
Data Member
protected


WorkerData Data Members Protected Data Members

WorkerData Data Members Protected Data Members
WorkerData Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
earnHi | Worker additional Medicare earnings, 1937 to last year considered.
earnOasdi | Worker earnings, 1937 to last year considered, after any projection of earnings.
taxType | Type of taxes paid. See TaxRates::taxrateType for the meaning of each bit.


WorkerData Data Members Public Data Members

WorkerData Data Members Public Data Members
WorkerData Data Members Legend
Public Data Members
Name | Description
milServDatesVec | Military service dates.
railRoadData | Railroad quarters of coverage and earnings.
ssn | Social security number of wage earner.


Legend

Legend
WorkerDataArray Data Members
Legend
Data Member


WorkerDataArray Data Members Public Data Members

WorkerDataArray Data Members Public Data Members
WorkerDataArray Data Members Legend
Public Data Members
Name | Description
workerData | Array of worker's pia data.


Legend

Legend
WorkerDataGeneral Data Members
Legend
Data Member
protected


WorkerDataGeneral Data Members Protected Data Members

WorkerDataGeneral Data Members Protected Data Members
WorkerDataGeneral Data Members Legend
Protected Data Members
Show:
No members matching the current filter
Name | Description
maxyear | Maximum year of projection is LASTYEARLR, unless changed.
qclumpyear | Quarters of coverage are summed before 1978, unless changed.


WorkerDataGeneral Data Members Public Data Members

WorkerDataGeneral Data Members Public Data Members
WorkerDataGeneral Data Members Legend
Public Data Members
Name | Description
childCareYears | Child care years, 1937 to WorkerDataGeneral::maxyear.
disabPeriod | Two periods of disability.
qc | Quarters of coverage, 1937 to WorkerDataGeneral::maxyear.


AssumptionType Enumerations Enumerations

AssumptionType Enumerations Enumerations
AssumptionType Enumerations Legend
Enumerations
Name | Description
assum_type | Type of assumptions.


Legend

Legend
AssumptionType Enumerations
Legend
Enumeration


AwincNonFile Enumerations Enumerations

AwincNonFile Enumerations Enumerations
AwincNonFile Enumerations Legend
Enumerations
Name | Description
DimLimits | Dimension limits.


Legend

Legend
AwincNonFile Enumerations
Legend
Enumeration


BaseChangeType Enumerations Enumerations

BaseChangeType Enumerations Enumerations
BaseChangeType Enumerations Legend
Enumerations
Name | Description
change_type | Type of wage base changes.


Legend

Legend
BaseChangeType Enumerations
Legend
Enumeration


BiprojNonFile Enumerations Enumerations

BiprojNonFile Enumerations Enumerations
BiprojNonFile Enumerations Legend
Enumerations
Name | Description
DimLimits | Dimension limits.


Legend

Legend
BiprojNonFile Enumerations
Legend
Enumeration


DibGuar Enumerations Enumerations

DibGuar Enumerations Enumerations
DibGuar Enumerations Legend
Enumerations
Name | Description
ConvertedMfbType | The type of mfb at cessation, after conversion.


Legend

Legend
DibGuar Enumerations
Legend
Enumeration


DisInsCode Enumerations Enumerations

DisInsCode Enumerations Enumerations
DisInsCode Enumerations Legend
Enumerations
Name | Description
DisInsCodeType | Disability insured status code types.


Legend

Legend
DisInsCode Enumerations
Legend
Enumeration


EarnProject Enumerations Enumerations

EarnProject Enumerations Enumerations
EarnProject Enumerations Legend
Enumerations
Name | Description
earn_proj_type | Type of earnings projection.
earn_type | Type of earnings.


Legend

Legend
EarnProject Enumerations
Legend
Enumeration


InsCode Enumerations Enumerations

InsCode Enumerations Enumerations
InsCode Enumerations Legend
Enumerations
Name | Description
InsCodeType | Insured status code types.


Legend

Legend
InsCode Enumerations
Legend
Enumeration


LawChange Enumerations Enumerations

LawChange Enumerations Enumerations
LawChange Enumerations Legend
Enumerations
Name | Description
lawChangeType | Short names of changes in law.


Legend

Legend
LawChange Enumerations
Legend
Enumeration


LawChangeDECLINEPERC Enumerations Enumerations

LawChangeDECLINEPERC Enumerations Enumerations
LawChangeDECLINEPERC Enumerations Legend
Enumerations
Name | Description
DimLimits | Array sizes.


Legend

Legend
LawChangeDECLINEPERC Enumerations
Legend
Enumeration


LawChangePSAACCT Enumerations Enumerations

LawChangePSAACCT Enumerations Enumerations
LawChangePSAACCT Enumerations Legend
Enumerations
Name | Description
DimLimits | Array sizes.


Legend

Legend
LawChangePSAACCT Enumerations
Legend
Enumeration


LawChangeTAXRATECHG Enumerations Enumerations

LawChangeTAXRATECHG Enumerations Enumerations
LawChangeTAXRATECHG Enumerations Legend
Enumerations
Name | Description
DimLimits | Array sizes.


Legend

Legend
LawChangeTAXRATECHG Enumerations
Legend
Enumeration


OldStart Enumerations Enumerations

OldStart Enumerations Enumerations
OldStart Enumerations Legend
Enumerations
Name | Description
OldStartType | Old-start PIA calculation methods.


Legend

Legend
OldStart Enumerations
Legend
Enumeration


Pebs Enumerations Enumerations

Pebs Enumerations Enumerations
Pebs Enumerations Legend
Enumerations
Name | Description
pebes_type | Type of Statement calculation.


Legend

Legend
Pebs Enumerations
Legend
Enumeration


PiaData Enumerations Enumerations

PiaData Enumerations Enumerations
PiaData Enumerations Legend
Enumerations
Name | Description
arf_app_type | Special minimum-drc indicator.
earn_total_type | Types of earnings (without or with totalization).


Legend

Legend
PiaData Enumerations
Legend
Enumeration


PiaDataArray Enumerations Enumerations

PiaDataArray Enumerations Enumerations
PiaDataArray Enumerations Legend
Enumerations
Name | Description
DimLimits | Constant for dimensioning.


Legend

Legend
PiaDataArray Enumerations
Legend
Enumeration


PiaMethod Enumerations Enumerations

PiaMethod Enumerations Enumerations
PiaMethod Enumerations Legend
Enumerations
Name | Description
WindfallElimType | Type of windfall elimination (WEP).
app_type | Type of method applicability.
cpi_year_type | Years of benefit increases applied.
dis_mfb_cap_type | Disability MFB cap indicator.
pia_type | Type of calculation method.
table_type | Old-law PIA table indicator.


Legend

Legend
PiaMethod Enumerations
Legend
Enumeration


PiaParams Enumerations Enumerations

PiaParams Enumerations Enumerations
PiaParams Enumerations Legend
Enumerations
Name | Description
SPECMINPERCTYPE | The year range for the special minimum percentage.


Legend

Legend
PiaParams Enumerations
Legend
Enumeration


Psa Enumerations Enumerations

Psa Enumerations Enumerations
Psa Enumerations Legend
Enumerations
Name | Description
AnnuityType | Type of annuity.
DimLimits | Constants for dimensioning.
InvestmentType | Types of investments.
PsaSexType | The sex types for PSA annuities.
UnisexType | Codes for using unisex annuity factors.


Legend

Legend
Psa Enumerations
Legend
Enumeration


ScaledEarnFactors Enumerations Enumerations

ScaledEarnFactors Enumerations Enumerations
ScaledEarnFactors Enumerations Legend
Enumerations
Name | Description
scaleType | The enumerated scaled earnings type indicator.


Legend

Legend
ScaledEarnFactors Enumerations
Legend
Enumeration


Sex Enumerations Enumerations

Sex Enumerations Enumerations
Sex Enumerations Legend
Enumerations
Name | Description
sex_type | The enumerated sex indicator.


Legend

Legend
Sex Enumerations
Legend
Enumeration


TaxData Enumerations Enumerations

TaxData Enumerations Enumerations
TaxData Enumerations Legend
Enumerations
Name | Description
YEAR_GROUP | Dimension limits.


Legend

Legend
TaxData Enumerations
Legend
Enumeration


TaxRates Enumerations Enumerations

TaxRates Enumerations Enumerations
TaxRates Enumerations Legend
Enumerations
Name | Description
taxrateType | Type of tax rate (employee or self-employed).
trustfundType | Trust fund indicator.


Legend

Legend
TaxRates Enumerations
Legend
Enumeration


WorkerData Enumerations Enumerations

WorkerData Enumerations Enumerations
WorkerData Enumerations Legend
Enumerations
Name | Description
DimLimits | Dimension limits.


Legend

Legend
WorkerData Enumerations
Legend
Enumeration


WorkerDataArray Enumerations Enumerations

WorkerDataArray Enumerations Enumerations
WorkerDataArray Enumerations Legend
Enumerations
Name | Description
DimLimits | Constant for dimensioning.


Legend

Legend
WorkerDataArray Enumerations
Legend
Enumeration


WorkerDataGeneral Enumerations Enumerations

WorkerDataGeneral Enumerations Enumerations
WorkerDataGeneral Enumerations Legend
Enumerations
Name | Description
BitsetMembers | Members of the bitset.
DimLimits | Dimension limits.
ben_type | Type of benefit calculation.


Legend

Legend
WorkerDataGeneral Enumerations
Legend
Enumeration


Age Friends Public Friends

Age Friends Public Friends
Age Friends
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


AverageWage Friends Public Friends

AverageWage Friends Public Friends
AverageWage Friends
Public Friends
Name | Description
class boost::serialization::access | Allows serialization of this class.


BitAnnual Friends Public Friends

BitAnnual Friends Public Friends
BitAnnual Friends
Public Friends
Name | Description
class boost::serialization::access | Allows serialization of this class.


DateMoyr Friends Public Friends

DateMoyr Friends Public Friends
DateMoyr Friends
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


DisabPeriod Friends Public Friends

DisabPeriod Friends Public Friends
DisabPeriod Friends
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


DoubleAnnual Friends Public Friends

DoubleAnnual Friends Public Friends
DoubleAnnual Friends
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


FloatAnnual Friends Public Friends

FloatAnnual Friends Public Friends
FloatAnnual Friends
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


MilServDates Friends Public Friends

MilServDates Friends Public Friends
MilServDates Friends
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


MilServDatesVec Friends Public Friends

MilServDatesVec Friends Public Friends
MilServDatesVec Friends
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


QcArray Friends Public Friends

QcArray Friends Public Friends
QcArray Friends
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


QcPacked Friends Public Friends

QcPacked Friends Public Friends
QcPacked Friends
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


QtrYear Friends Public Friends

QtrYear Friends Public Friends
QtrYear Friends
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


RailRoadData Friends Public Friends

RailRoadData Friends Public Friends
RailRoadData Friends
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


Ssn Friends Public Friends

Ssn Friends Public Friends
Ssn Friends
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


WorkerData Friends Public Friends

WorkerData Friends Public Friends
WorkerData Friends
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


WorkerDataGeneral Friends Public Friends

WorkerDataGeneral Friends Public Friends
WorkerDataGeneral Friends
Public Friends
Name | Description
class boost::serialization::access | Friend class to allow serialization.


Legend

Legend
Age Methods
Legend
Method


Age Methods Public Methods

Age Methods Public Methods
Age Methods Legend
Public Methods
Name | Description
deleteContents | Zeroes years and months.
getMonths | Returns months of age.
getYears | Returns years of age.
monthsCheck | Checks for months in bounds.
toMonths | Returns the age converted to months.
toString | Returns string with age as years and months.


Legend

Legend
AnnualArrays Methods
Legend
Method


AnnualArrays Methods Public Methods

AnnualArrays Methods Public Methods
AnnualArrays Methods Legend
Public Methods
Name | Description
add | Adds the second DoubleAnnual to the first DoubleAnnual.
convert | Returns the DoubleAnnual converted from an IntAnnual.
divide | Divides the first DoubleAnnual by the second DoubleAnnual.
multiply | Multiplies a DoubleAnnual by a specified quantity.
subtract | Subtracts the second DoubleAnnual from the first DoubleAnnual.


Legend

Legend
AnypiaOut Methods
Legend
Method


AnypiaOut Methods Public Methods

AnypiaOut Methods Public Methods
AnypiaOut Methods Legend
Public Methods
Name | Description
fillPageSlots | Fills out page slots.
getPage | Returns one page to print.
getPageCount | Returns number of pages to print.
setPebsOut | Sets pointer to Statement output.
setPiaCal | Sets pointer to pia calculation results.
setPiaData | Sets pointer to pia calculation data.
setPiaOut | Sets pointer to pia calculation output.
setWorkerData | Sets pointer to worker data.


Legend

Legend
Assumptions Methods
Legend
Method
abstract
virtual


Assumptions Methods Public Methods

Assumptions Methods Public Methods
Assumptions Methods Legend
Public Methods
Name | Description
averageWageMenu | Set average wage increases from stored values.
benefitIncMenu | Set benefit increases from stored values.
getAverageWage | Returns an average wage increase assumption title.
getAwincProj | Returns projected average wage increases.
getBenefitInc | Returns a benefit increase assumption title.
getBiProj | Returns projected benefit increases.
getCatchupDoc | Returns catch-up benefit increases.
getIstart | Returns current year.
getMaxyear | Returns maximum projected year.
setAwincProjTitle | Set title of projected average wage increases.
setBiProjTitle | Set title of projected benefit increases.
setIstart | Sets the current year, including for the members.


Public Methods

Legend
Legend
Method
abstract
virtual


Legend

Legend
AssumptionsFile Methods
Legend
Method


AssumptionsFile Methods Public Methods

AssumptionsFile Methods Public Methods
AssumptionsFile Methods Legend
Public Methods
Name | Description
averageWageMenu | Reads stored average wage increases from disk.
benefitIncMenu | Reads stored benefit increases from disk.
getAwincProj | Returns projected average wage increases.
getBiProj | Returns projected benefit increases.
getCatchupDoc | Returns catch-up benefit increases.
setAwincProjTitle | Set title of projected average wage increases.
setBiProjTitle | Set title of projected benefit increases.
setIstart | Sets the current year, including for the members.


Legend

Legend
AssumptionsNonFile Methods
Legend
Method


AssumptionsNonFile Methods Public Methods

AssumptionsNonFile Methods Public Methods
AssumptionsNonFile Methods Legend
Public Methods
Name | Description
averageWageMenu | Reads stored average wage increases from a static array.
benefitIncMenu | Reads stored benefit increases from a static array.
getAwincProj | Returns projected average wage increases.
getBiProj | Returns projected benefit increases.
getCatchupDoc | Returns catch-up benefit increases.
setAwincProjTitle | Set title of projected average wage increases.
setBiProjTitle | Set title of projected benefit increases.
setIstart | Sets the current year, including for the members.


Legend

Legend
AssumptionType Methods
Legend
Method


AssumptionType Methods Public Methods

AssumptionType Methods Public Methods
AssumptionType Methods Legend
Public Methods
Name | Description
ialtawCheck1 | Checks average wage increase indicator in general case.
ialtawCheck2 | Checks average wage increase indicator in Statement case.
ialtbiCheck1 | Checks benefit increase indicator in general case.
ialtbiCheck2 | Checks benefit increase indicator in Statement case.
isFlatOrPebs | Returns true if argument is a statement-type constant-dollar assumption.
isNotTR | Returns true if argument is not a Trustees Report assumption.
isTR | Returns true if argument is a Trustees Report assumption.


Legend

Legend
AverageWage Methods
Legend
Method


AverageWage Methods Public Methods

AverageWage Methods Public Methods
AverageWage Methods Legend
Public Methods
Name | Description
endYear | Returns the last year that data > 4.5, or returns 0.
project | Projects average wage amounts.
projectBackward | Projects the earnings amount backward for the specified year.
projectBackwardStatic | Projects an earnings amount back for one year.
projectForward | Projects the earnings amount forward for the specified year.
projectForwardStatic | Projects an earnings amount forward for one year.
round | Rounds an earnings amount to 2 decimal places.
startYear | Returns the first year that data > 4.5, or returns 0.


Legend

Legend
AwbiData Methods
Legend
Method
virtual
abstract


AwbiData Methods Public Methods

AwbiData Methods Public Methods
AwbiData Methods Legend
Public Methods
Name | Description
getLastYear | Gets last year of historical wage bases.
read | Dummy function (descendant class may use it).
setData | Set data values.
setLastYear | Sets last year of historical wage bases.
write | Dummy function (descendant class may use it).


Legend

Legend
AwbiDataFile Methods
Legend
Method


AwbiDataFile Methods Public Methods

AwbiDataFile Methods Public Methods
AwbiDataFile Methods Legend
Public Methods
Name | Description
read | Reads historical parameters.
setAwbiFile | Forms a file name for historical parameters file.
setData | Dummy function (descendant class may use it).
write | Writes historical parameters.


Legend

Legend
AwbiDataNonFile Methods
Legend
Method


AwbiDataNonFile Methods Public Methods

AwbiDataNonFile Methods Public Methods
AwbiDataNonFile Methods Legend
Public Methods
Name | Description
getBase77Data | Returns a historical old-law wage base.
getBaseHiData | Returns a historical HI wage base.
getBaseOasdiData | Returns a historical OASDI wage base.
getCpiincData | Returns a historical benefit increase.
getFqData | Returns a historical average indexing wage.
setData | Sets values for historical parameters through the last year of historical wage bases (to avoid reading from disk).


Legend

Legend
Awinc Methods
Legend
Method


Awinc Methods Public Methods

Awinc Methods Public Methods
Awinc Methods Legend
Public Methods
Name | Description
fqincCheck | Checks an average wage increase.
project | Calculates average wage increases.


Legend

Legend
AwincDoc Methods
Legend
Method
abstract


AwincDoc Methods Public Methods

AwincDoc Methods Public Methods
AwincDoc Methods Legend
Public Methods
Name | Description
getFirstYear | Returns first year of data.
getTitle | Returns title of assumptions.
read | Read data.
setData | Sets data for one alternative.
setFirstYear | Sets first year of data.
setFqinc | Sets average wage increase for specified year.
setTitle | Sets title for one alternative.
write | Write data.


Public Methods

Legend
Legend
Method
abstract


Legend

Legend
AwincFile Methods
Legend
Method
protected


AwincFile Methods Protected Methods

AwincFile Methods Protected Methods
AwincFile Methods Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
setAwFile | Forms a file name for projected average wage increase file.


AwincFile Methods Public Methods

AwincFile Methods Public Methods
AwincFile Methods Legend
Public Methods
Name | Description
read | Reads projected average wage increases.
setData | Sets data for one alternative.
setTitle | Sets title for one alternative.
write | Saves projected average wage increases.


Legend

Legend
AwincNonFile Methods
Legend
Method


AwincNonFile Methods Public Methods

AwincNonFile Methods Public Methods
AwincNonFile Methods Legend
Public Methods
Name | Description
read | Restore values to original values.
setData | Sets data for one alternative.
setTitle | Sets title for one alternative.
write | Dummy function.


Legend

Legend
BaseChangeType Methods
Legend
Method


BaseChangeType Methods Public Methods

BaseChangeType Methods Public Methods
BaseChangeType Methods Legend
Public Methods
Name | Description
check | Checks wage base indicator.
toString | Returns description of wage base projection method.


Legend

Legend
BaseYear Methods
Legend
Method
abstract


BaseYear Methods Public Methods

BaseYear Methods Public Methods
BaseYear Methods Legend
Public Methods
Name | Description
getYear | Returns computation year.
read | Read base year.
setYear | Sets computation year.
write | Save base year.
yearCheck | Checks base year.


Legend

Legend
BaseYearFile Methods
Legend
Method


BaseYearFile Methods Public Methods

BaseYearFile Methods Public Methods
BaseYearFile Methods Legend
Public Methods
Name | Description
read | Reads base year from disk.
write | Saves base year to disk.


Legend

Legend
BaseYearNonFile Methods
Legend
Method


BaseYearNonFile Methods Public Methods

BaseYearNonFile Methods Public Methods
BaseYearNonFile Methods Legend
Public Methods
Name | Description
read | Reads stored base year.
write | Saves base year (dummy function).


Legend

Legend
BendMfb Methods
Legend
Method


BendMfb Methods Public Methods

BendMfb Methods Public Methods
BendMfb Methods Legend
Public Methods
Name | Description
as_array | Returns bend points as a simple array.
begin | This is the overview for the begin method overload.
deleteContents | Zeroes out all values.
end | This is the overview for the end method overload.
max_size | Returns maximum number of bend points.
project | Projects bend points, using 1979 bend points as a base.
size | Returns number of bend points.


Legend

Legend
BendPia Methods
Legend
Method


BendPia Methods Public Methods

BendPia Methods Public Methods
BendPia Methods Legend
Public Methods
Name | Description
as_array | Returns bend points as a simple array.
begin | This is the overview for the begin method overload.
deleteContents | Zeroes out all values.
end | This is the overview for the end method overload.
getNumBend | Returns the number of bendpoints.
max_size | Returns maximum number of bend points.
project | Projects bend points, using 1979 bend points as a base.
setNumBend | Sets the number of bendpoints. Sets number of bend points.
size | Returns number of bend points.


Legend

Legend
BenefitAmount Methods
Legend
Method


BenefitAmount Methods Public Methods

BenefitAmount Methods Public Methods
BenefitAmount Methods Legend
Public Methods
Name | Description
applyCola | Applies cola percent to a benefit.
get | Returns the benefit amount.
round | Rounds a PIA or MFB to the appropriate multiple of $0.10.
round1 | Rounds a specified PIA or MFB down to a whole dollar for June 1982 and later.
round5 | Rounds a benefit down to $5 multiple.
set | Sets the benefit amount.
toString | Returns benefit amount as a string with 2 decimal places.
unApplyCola | Removes cola percent from a quantity.
unround | Unrounds a PIA or MFB to the appropriate multiple of $0.10.


Legend

Legend
BenefitAmountArray Methods
Legend
Method


BenefitAmountArray Methods Public Methods

BenefitAmountArray Methods Public Methods
BenefitAmountArray Methods Legend
Public Methods
Name | Description
deleteContents | Sets all values to zero.
getLastYear | Returns the last year of data.
initialize | Initializes last year.
setDirty | Sets indicator for non-zero values.


Legend

Legend
Bic Methods
Legend
Method


Bic Methods Public Methods

Bic Methods Public Methods
Bic Methods Legend
Public Methods
Name | Description
eligibleForMax | Returns true if this benefit is affected by family maximum.
getLifeAuxType | Returns description of type of life auxiliary.
getMajorBic | Returns the major bic code.
getMinorBic | Returns the minor bic code.
getSurvivorType | Returns description of type of survivor.
isAuxiliary | Returns true if auxiliary beneficiary (major bic is B, C, D, E, F, or W).
isDisabledWidow | Returns true if disabled widow(er), false otherwise.
isReducible | Returns true if benefit is reducible for age.
isWidow | Returns true if widow(er) (aged or disabled), false otherwise.
isYoungSpouse | Returns true if young spouse.
isYoungSurvivor | Returns true if young survivor (child or mother/father), false otherwise.
set | Sets the bic codes.
setMajorBic | Sets the major bic code.
setMinorBic | Sets the minor bic code.
survivorCheck | Checks for valid survivor bic.
toString | Returns the bic code as a string.


Legend

Legend
Biproj Methods
Legend
Method
abstract


Biproj Methods Public Methods

Biproj Methods Public Methods
Biproj Methods Legend
Public Methods
Name | Description
cpiincCheck | Checks a benefit increase.
getFirstYear | Returns first year of data.
getTitle | Returns title of assumptions.
read | Read benefit increases.
setCpiinc | Sets one benefit increase.
setData | Sets benefit increases for one alternative.
setFirstYear | Sets first year of data.
setTitle | Sets the title for one alternative.
write | Save benefit increases.


Legend

Legend
BiprojFile Methods
Legend
Method
protected


BiprojFile Methods Protected Methods

BiprojFile Methods Protected Methods
BiprojFile Methods Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
setBiFile | Forms a file name for projected benefit increase file.


BiprojFile Methods Public Methods

BiprojFile Methods Public Methods
BiprojFile Methods Legend
Public Methods
Name | Description
read | Reads projected benefit increases.
setData | Sets the benefit increases for one alternative.
setTitle | Sets the title for one alternative.
write | Saves projected benefit increases.


Legend

Legend
BiprojNonFile Methods
Legend
Method


BiprojNonFile Methods Public Methods

BiprojNonFile Methods Public Methods
BiprojNonFile Methods Legend
Public Methods
Name | Description
read | Restore values to original values.
setData | Sets the benefit increases for one alternative.
setTitle | Sets the title for one alternative.
write | Dummy function.


Legend

Legend
BitAnnual Methods
Legend
Method


BitAnnual Methods Public Methods

BitAnnual Methods Public Methods
BitAnnual Methods Legend
Public Methods
Name | Description
any | Returns true if at least one bit is set, false otherwise.
assign | Sets data from another BitAnnual for specified years.
deleteContents | Zeroes out all data values.
getBaseYear | Returns base year.
getBit | Returns one constant value of data.
getLastYear | Returns last year.
setBit | Sets one value of data.


Legend

Legend
BpMfbOut Methods
Legend
Method


BpMfbOut Methods Public Methods

BpMfbOut Methods Public Methods
BpMfbOut Methods Legend
Public Methods
Name | Description
getBpmfb1 | Returns first bend point for specified year.
getBpmfb2 | Returns second bend point for specified year.
getBpmfb3 | Returns third bend point for specified year.
setData | Sets data for one or all years.


Legend

Legend
BpPiaOut Methods
Legend
Method


BpPiaOut Methods Public Methods

BpPiaOut Methods Public Methods
BpPiaOut Methods Legend
Public Methods
Name | Description
getBppia | Returns bend point for specified year.
getNumBend | Returns number of bend points.
set1979Data | Sets data for all years based on the wage-indexed 1979 formula starting in the year of the firstYear argument, using the specified average wages for projection.
setIndexedData | Sets data for all years beginning with the firstYear argument, based on the bendpoints specified in the baseYear argument, and using the specified average wages for projection.
setSingleYearData | Sets data for one year using specified bendpoint values.


Legend

Legend
Catchup Methods
Legend
Method


Catchup Methods Public Methods

Catchup Methods Public Methods
Catchup Methods Legend
Public Methods
Name | Description
check | Checks a catch-up benefit increase.
deleteContents | Zeroes out catch-up benefit increases.
exist | Checks for existence of catch-up benefit increase.
get | Returns one catch-up increase.
getCatchupIncreases | Returns a CatchupIncreases array.
getCstart | Gets first year of catch-up increases.
parseString | Parses all catch-up increases for one year of eligibility from a string.
set | Sets one catch-up increase.
setCstart | Sets first year of catch-up increases.


Legend

Legend
CatchupDoc Methods
Legend
Method
abstract


CatchupDoc Methods Public Methods

CatchupDoc Methods Public Methods
CatchupDoc Methods Legend
Public Methods
Name | Description
exist | Checks for existence of catch-up increase.
get | Returns one catch-up increase.
read | Reads catch-up increases.
setData | Sets catch-up increases for one alternative.
write | Writes catch-up increases.


Legend

Legend
CatchupFile Methods
Legend
Method
protected


CatchupFile Methods Protected Methods

CatchupFile Methods Protected Methods
CatchupFile Methods Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
setCuFile | Forms a file name for projected catch-up benefit increase file.


CatchupFile Methods Public Methods

CatchupFile Methods Public Methods
CatchupFile Methods Legend
Public Methods
Name | Description
read | Reads all catch-up increases.
setData | Deletes current catch-up increases if other than TR assumption.
write | Writes all catch-up increases.


Legend

Legend
CatchupIncreases Methods
Legend
Method


CatchupIncreases Methods Public Methods

CatchupIncreases Methods Public Methods
CatchupIncreases Methods Legend
Public Methods
Name | Description
get | Returns one catch-up increase.
parseString | Parses catch-up increases for one year of eligibility from a string.
set | Sets one catch-up increase.
toString | Returns catch-up increases for one year of eligibility as a string.


Legend

Legend
CatchupNonFile Methods
Legend
Method


CatchupNonFile Methods Public Methods

CatchupNonFile Methods Public Methods
CatchupNonFile Methods Legend
Public Methods
Name | Description
read | Read stored values from memory.
setData | Sets catch-up benefit increases.
write | Dummy function.


Legend

Legend
ChildCareCalc1Page Methods
Legend
Method


ChildCareCalc1Page Methods Public Methods

ChildCareCalc1Page Methods Public Methods
ChildCareCalc1Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares wage indexed strings with childcare dropout years for printing.


Legend

Legend
ChildCareCalc2Page Methods
Legend
Method


ChildCareCalc2Page Methods Public Methods

ChildCareCalc2Page Methods Public Methods
ChildCareCalc2Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares wage indexed strings with childcare dropout years for printing.


Legend

Legend
ChildCareCalc Methods
Legend
Method
virtual


ChildCareCalc Methods Public Methods

ChildCareCalc Methods Public Methods
ChildCareCalc Methods Legend
Public Methods
Name | Description
calculate | Computes wage indexed PIA with childcare dropout years.
childCareDropMaxCal | Returns maximum number of childcare dropout years.
childCareDropoutCal | Adjust for childcare dropout years.
getAdjustedN | Returns number of computation years adjusted for childcare dropout years.
getChildCareDrop | Returns number of usable childcare dropout years.
getChildCareDropMax | Returns maximum number of childcare dropout years.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.


Public Methods

Legend
Legend
Method
virtual


Legend

Legend
ChildCareCalcLC Methods
Legend
Method


ChildCareCalcLC Methods Public Methods

ChildCareCalcLC Methods Public Methods
ChildCareCalcLC Methods Legend
Public Methods
Name | Description
childCareDropMaxCal | Returns maximum number of childcare dropout years.
isApplicable | Determines applicability of method.


Legend

Legend
CompPeriod Methods
Legend
Method


CompPeriod Methods Public Methods

CompPeriod Methods Public Methods
CompPeriod Methods Legend
Public Methods
Name | Description
deleteContents | Zeroes all variables.
getBaseYear | Returns base year (1936 or 1950).
getDiYears | Returns number of years wholly or partially within a period of disability, within the elapsed years.
getN | Returns number of computation years.
getNDrop | Returns number of dropout years.
getNElapsed | Returns number of elapsed years.
setDiYears | Sets number of years wholly or partially within a period of disability, within the elapsed years.
setN | Sets number of computation years.
setNDrop | Sets number of dropout years.
setNElapsed | Sets number of elapsed years.


Legend

Legend
Config Methods
Legend
Method
abstract


Config Methods Public Methods

Config Methods Public Methods
Config Methods Legend
Public Methods
Name | Description
getLeftMargin | Returns left margin in inches.
getLongOutput | Returns long output indicator.
getPrinterPoints | Returns printer font point size.
getScreenPoints | Returns screen font point size.
getTopMargin | Returns top margin in inches.
read | Reads this structure.
setLeftMargin | Sets left margin in inches.
setLongOutput | Sets long output indicator.
setPrinterPoints | Sets printer font point size.
setScreenPoints | Sets screen font point size.
setTopMargin | Sets top margin in inches.
write | Writes this structure.


Legend

Legend
ConfigFile Methods
Legend
Method


ConfigFile Methods Public Methods

ConfigFile Methods Public Methods
ConfigFile Methods Legend
Public Methods
Name | Description
read | Reads the configuration from disk.
write | Saves the configuration to disk.


Legend

Legend
ConfigNonFile Methods
Legend
Method


ConfigNonFile Methods Public Methods

ConfigNonFile Methods Public Methods
ConfigNonFile Methods Legend
Public Methods
Name | Description
read | Reads the configuration (dummy function).
write | Saves the configuration (dummy function).


Legend

Legend
Date Methods
Legend
Method


Date Methods Public Methods

Date Methods Public Methods
Date Methods Legend
Public Methods
Name | Description
addYears | Adds years to the specified date.
monthCheck | Checks for month in bounds.
yearCheck | Checks for year in bounds.


Legend

Legend
DateFormatter Methods
Legend
Method


DateFormatter Methods Public Methods

DateFormatter Methods Public Methods
DateFormatter Methods Legend
Public Methods
Name | Description
date_from_undelimited_us_string | Parses a date from an undelimited date string where the order is month (2 digits), day (2 digits), and year (4 digits).
month_year_from_undelimited_us_string | Parses a month and year date from an undelimited date string where the order is month (2 digits) and year (4 digits).
toString | Returns a string with a formatted date.


Legend

Legend
DateMoyr Methods
Legend
Method


DateMoyr Methods Public Methods

DateMoyr Methods Public Methods
DateMoyr Methods Legend
Public Methods
Name | Description
check | Checks for valid month and year.
deleteContents | Zeroes month and year.
getMonth | Returns month of year.
getMonthBefore | Returns the date that is the month before this date.
getMonths | Returns number of months from this date to given date.
getYear | Returns the year.
index | Returns index of the month and year, based on January 1971 being 0.
isNotADate | Returns true if the default values of 0 for the year and month are present, which shows that it has never been set.
monthCheck | Checks for month in bounds.


Legend

Legend
DibGuar Methods
Legend
Method
protected


DibGuar Methods Protected Methods

DibGuar Methods Protected Methods
DibGuar Methods Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
cessationMfbCal | Calculates the applicable mfb at cessation date.
convertedMfbTypeCal | Returns the type of mfb at cessation, after conversion.
dateCpiCal | Returns the date as of which the initial pia is calculated.
entDeathDateCal | Returns date of entitlement in a life case, or date of death in a survivor case.
yearCpi1Cal | Returns first year that benefit increases are applied.


DibGuar Methods Public Methods

DibGuar Methods Public Methods
DibGuar Methods Legend
Public Methods
Name | Description
calculate | Computes disability guarantee PIA.
getCessationMfbConv | Returns the mfb based on the deconverted pia brought up to the cessation date.
getCessationMfbOrig | Returns the original mfb at the cessation date.
getColasApply | Returns true if colas apply from cessation date of prior disability to new entitlement date.
getConvertedMfbType | Returns the type of converted mfb.
getDiMaxApplies | Returns true if the mfb from the prior disability was determined using the Disability Maximum method.
getRawMfb | Returns the mfb based on the deconverted pia at eligibility date.
getRawPia | Returns the pia deconverted from cessation date to eligibility date.
isApplicable | Determines applicability of method.


Legend

Legend
DibGuarLC Methods
Legend
Method


DibGuarLC Methods Public Methods

DibGuarLC Methods Public Methods
DibGuarLC Methods Legend
Public Methods
Name | Description
isApplicable | Determines applicability of method.


Legend

Legend
DibGuarPage Methods
Legend
Method
protected


DibGuarPage Methods Protected Methods

DibGuarPage Methods Protected Methods
DibGuarPage Methods Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
piamfbDeath | Prepares PIA and MFB at death in a string table.


DibGuarPage Methods Public Methods

DibGuarPage Methods Public Methods
DibGuarPage Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares frozen minimum strings for printing.


Legend

Legend
DisabPeriod Methods
Legend
Method


DisabPeriod Methods Public Methods

DisabPeriod Methods Public Methods
DisabPeriod Methods Legend
Public Methods
Name | Description
cessationDateCheck | Checks a date of disability cessation.
deleteCessationDate | Deletes the cessation date.
deleteContents | Sets all variables to default values.
deleteEntDate | Deletes the entitlement date.
deleteOnsetDate | Deletes the onset date.
deleteWaitperDate | Deletes the first month of the waiting period.
entDateCheck | Checks a date of entitlement.
getCessationDate | Returns date of disability cessation.
getCessationMfb | Returns the mfb in the month before cessation.
getCessationPia | Returns the pia in the month before cessation.
getEntDate | Returns date of entitlement to disability.
getOnsetDate | Returns date of disability onset.
getWaitperDate | Returns first month of waiting period.
onsetDateCheck | Checks a date of disability onset.
parseString | Parses a string into a DisabPeriod.
setCessationDate | Sets the cessation date.
setCessationMfb | Sets the mfb at cessation.
setCessationPia | Sets the pia at cessation.
setEntDate | Sets the entitlement date.
setOnsetDate | Sets the onset date.
setWaitperDate | Sets the first month of the waiting period.
toString | Returns the period of disability as a string.
waitperDateCal | Calculates first month of waiting period.
waitperDateCheck | Checks a first month of waiting period for general reasonableness.


Legend

Legend
DisInsCode Methods
Legend
Method


DisInsCode Methods Public Methods

DisInsCode Methods Public Methods
DisInsCode Methods Legend
Public Methods
Name | Description
ChartoCode | Converts a character to a DisInsCode::DisInsCodeType.
get | Returns the disability insured status code.
isDiBenie | Returns disability benefit receipt status.
isDisabilityInsured | Returns disability insured status.
set | Sets the disability insured status code.
toChar | Returns a disability insured status code as a character.


Legend

Legend
DisInsCodeArray Methods
Legend
Method


DisInsCodeArray Methods Public Methods

DisInsCodeArray Methods Public Methods
DisInsCodeArray Methods Legend
Public Methods
Name | Description
assign | Sets values for a range of years.
deleteContents | Zeroes out all data values.
getFirstYear | Returns the first year of data.
getLastYear | Returns the last year of data.
isNonzero | Returns true if any insured status code is other than DisInsCode::DisInsCodeType::NOQCS.
setFirstYear | Sets the first year of data.
setLastYear | Sets the last year of data.
toString | Returns data for one disability insured status code array as a string.


Legend

Legend
Document Methods
Legend
Method


Document Methods Public Methods

Document Methods Public Methods
Document Methods Legend
Public Methods
Name | Description
errormesg | Returns message when error reading from file.
getCorename | Returns the core file name, before modifiers or extensions.
getModifier | Returns the modifier on the file name.
getPathname | Returns full path name.
getTitle | Returns title of this document.
readmesg | Returns message when reading from file.
setCorename | Sets the core part of the file name, before modifiers or extensions.
setExtension | Sets the extension on the file name.
setModifier | Sets the modifier on the file name.
setPath | Sets the path and modifier on the file name.
setPathAndModifier | Sets the path and modifier on the file name.
setPathname | Sets full path name.
setTitle | Sets title of this document.
writemesg | Returns message when writing to file.


Legend

Legend
DoubleAnnual Methods
Legend
Method


DoubleAnnual Methods Public Methods

DoubleAnnual Methods Public Methods
DoubleAnnual Methods Legend
Public Methods
Name | Description
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.


Legend

Legend
DoubleAnnualRead Methods
Legend
Method


DoubleAnnualRead Methods Public Methods

DoubleAnnualRead Methods Public Methods
DoubleAnnualRead Methods Legend
Public Methods
Name | Description
read | Reads array from an open stream.


Legend

Legend
DoubleAnnualWrite Methods
Legend
Method


DoubleAnnualWrite Methods Public Methods

DoubleAnnualWrite Methods Public Methods
DoubleAnnualWrite Methods Legend
Public Methods
Name | Description
getLineWidth | Returns output line width.
getPrecision | Returns precision of output field.
getWidth | Returns width of output field.
write | Writes array to an open stream.


Legend

Legend
DoubleMonth Methods
Legend
Method


DoubleMonth Methods Public Methods

DoubleMonth Methods Public Methods
DoubleMonth Methods Legend
Public Methods
Name | Description
annAvgCal | Calculates annual average of the 12 monthly figures.
assign | Sets data for specified years.
getAt | Returns one value of data.
getBaseYear | Returns base year.
getLastYear | Returns last year.
getLineWidth | Returns line width for output.
getPrecision | Returns precision for output.
getWidth | Returns field width for output.
nmonCal | Finds number of months of (nonzero) data in a given year.
qtrAvgCal | Calculates quarterly average of the 3 monthly figures.
read | Reads array from an open stream.
setAt | Sets one value of data.
setLineWidth | Initializes line width for output.
setPrecision | Initializes precision for output.
setWidth | Initializes field width for output.
write | Writes array to an open stream.


Legend

Legend
DoubleQuarter Methods
Legend
Method


DoubleQuarter Methods Public Methods

DoubleQuarter Methods Public Methods
DoubleQuarter Methods Legend
Public Methods
Name | Description
anninc | Calculates annual percentage increase.
anninc3 | Calculates 3-year percentage increase at annual rate.
assign | Sets data for a range of years.
average | Calculates annual average.
getAfter | Gets one value of data after specified quarter.
getAt | Gets one value of data.
getBaseYear | Returns base year.
getBefore | Gets one value of data before specified quarter.
getLastYear | Returns last year.
getLineWidth | Returns output line width.
getWidth | Returns field width on output.
multiply | Multiplies data by another DoubleQuarter.
read | Reads array from an open stream.
setAt | Sets one value of data.
setLineWidth | Initializes output line width.
setPrecision | Initializes precision on output.
setWidth | Initializes field width.
write | Writes array to an open stream.


Legend

Legend
EarningsPage Methods
Legend
Method


EarningsPage Methods Public Methods

EarningsPage Methods Public Methods
EarningsPage Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares earnings strings for printing.


Legend

Legend
EarnProject Methods
Legend
Method
virtual


EarnProject Methods Public Methods

EarnProject Methods Public Methods
EarnProject Methods Legend
Public Methods
Name | Description
anyEntered | Returns true if any earnings are entered.
deleteContents | Initializes all variables to default values.
earnpebsCheck | Checks earnings.
earntypeCheck | Checks type of earnings.
getEarntype | Returns array of indicators for type of earnings.
getFirstYear | Returns first year of earnings.
getLastYear | Returns last year of earnings.
getPercback | Returns percentage used in backwards projection.
getPercfwrd | Returns percentage used in forwards projection.
getProjback | Returns backward projection indicator.
getProjfwrd | Returns forward projection indicator.
ibegin2Check | Checks for first year of earnings in bounds.
ibeginCheck | Checks for first year of earnings within bounds, using passed values, with a backward projection.
iendCheck | Checks for last year of earnings within bounds.
need_aw | Returns true if earnings are projected in last two years of historical period.
percbackCheck | Checks backward projection percentage.
percfwrdCheck | Checks forward projection percentage.
projbackCheck1 | Checks backward projection indicator in general case.
projbackCheck2 | Checks backward projection indicator in backward projection case.
project | Projects OASDI-covered earnings for the specified worker.
projfwrdCheck1 | Checks forward projection indicator in general case.
projfwrdCheck2 | Checks forward projection indicator in forward projection case.
setEarnpebs | Sets earnings for specified year.
setEarntype | Sets type of earnings for specified year.
setFirstYear | Sets first year of specified earnings (earnings could be projected backward before this year).
setLastYear | Sets last year of specified earnings (earnings could be projected forward after this year).
setPebsData | Sets some Statement data.
setPebsEarn | Sets last year of Statement earnings when computation year changes, or after a Statement calculation has been done.
setPercback | Sets backward projection percentage.
setPercfwrd | Sets percentage in forward projection.
setProjback | Sets backward projection indicator.
setProjfwrd | Sets forward projection indicator.
toString | Returns description of type of earnings.
yearsCheck | Checks for first and last year of earnings within bounds.
zeroEarn | Zeroes out earnings before firstYear and after lastYear.


Legend

Legend
FamilyPage Methods
Legend
Method


FamilyPage Methods Public Methods

FamilyPage Methods Public Methods
FamilyPage Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares strings for family members page.


Legend

Legend
FieldOfficeInfo Methods
Legend
Method
abstract


FieldOfficeInfo Methods Public Methods

FieldOfficeInfo Methods Public Methods
FieldOfficeInfo Methods Legend
Public Methods
Name | Description
getAddress | Returns one line of field office address.
getFieldOfficeName | Returns field office manager's name.
getFieldOfficeTitle | Returns field office manager's title.
read | Read field office info.
setAddress | Sets one line of field office address.
setData | Sets field office info.
setFieldOfficeName | Sets field office manager's name.
setFieldOfficeTitle | Sets field office manager's title.
write | Write field office info.


Legend

Legend
FieldOfficeInfoFile Methods
Legend
Method


FieldOfficeInfoFile Methods Public Methods

FieldOfficeInfoFile Methods Public Methods
FieldOfficeInfoFile Methods Legend
Public Methods
Name | Description
read | Reads field office information from disk.
setData | Dummy function for file version.
write | Saves field office information to disk.


Legend

Legend
FieldOfficeInfoNonFile Methods
Legend
Method


FieldOfficeInfoNonFile Methods Public Methods

FieldOfficeInfoNonFile Methods Public Methods
FieldOfficeInfoNonFile Methods Legend
Public Methods
Name | Description
read | Reads field office information (dummy function).
setData | Initializes name and address.
write | Saves field office information (dummy function).


Legend

Legend
FloatAnnual Methods
Legend
Method


FloatAnnual Methods Public Methods

FloatAnnual Methods Public Methods
FloatAnnual Methods Legend
Public Methods
Name | Description
accumulate | Accumulates data over a range of years.
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.


Legend

Legend
FloatMonth Methods
Legend
Method


FloatMonth Methods Public Methods

FloatMonth Methods Public Methods
FloatMonth Methods Legend
Public Methods
Name | Description
annAvgCal | Calculates annual average of the 12 monthly figures.
assign | Sets data for specified years.
getAt | Returns one value of data.
getBaseYear | Returns base year.
getLastYear | Returns last year.
getLineWidth | Returns line width for output.
getPrecision | Returns precision for output.
getWidth | Returns field width for output.
nmonCal | Finds number of months of (nonzero) data in a given year.
qtrAvgCal | Calculates quarterly average of the 3 monthly figures.
read | Reads array from an open stream.
setAt | Sets one value of data.
setLineWidth | Initializes line width for output.
setPrecision | Initializes precision for output.
setWidth | Initializes field width for output.
write | Writes array to an open stream.


Legend

Legend
FloatQuarter Methods
Legend
Method


FloatQuarter Methods Public Methods

FloatQuarter Methods Public Methods
FloatQuarter Methods Legend
Public Methods
Name | Description
anninc | Calculates annual percentage increase.
anninc3 | Calculates 3-year percentage increase at annual rate.
assign | Sets data for a range of years.
average | Calculates annual average.
getAfter | Gets one value of data after specified quarter.
getAt | Gets one value of data.
getBaseYear | Returns base year.
getBefore | Gets one value of data before specified quarter.
getLastYear | Returns last year.
getLineWidth | Returns output line width.
getWidth | Returns field width on output.
multiply | Multiplies data by another FloatQuarter.
read | Reads array from an open stream.
setAt | Sets one value of data.
setLineWidth | Initializes output line width.
setPrecision | Initializes precision on output.
setWidth | Initializes field width.
write | Writes array to an open stream.


Legend

Legend
FreezeYears Methods
Legend
Method


FreezeYears Methods Public Methods

FreezeYears Methods Public Methods
FreezeYears Methods Legend
Public Methods
Name | Description
deleteContents | Zeroes all variables.
getYear1 | Returns first year in latest period of disability.
getYear2 | Returns last year in latest period of disability.
getYear3 | Returns first year in prior period of disability.
getYear4 | Returns last year in prior period of disability.
hasYears1 | Returns true if any years in latest freeze period.
hasYears2 | Returns true if any years in prior freeze period.
isFreezeYear | Returns true if year is wholly within a period of disability, false otherwise.
setYear1 | Sets first year in latest period of disability.
setYear2 | Sets last year in latest period of disability.
setYear3 | Sets first year in prior period of disability.
setYear4 | Sets last year in prior period of disability.


Legend

Legend
FrozMin Methods
Legend
Method


FrozMin Methods Public Methods

FrozMin Methods Public Methods
FrozMin Methods Legend
Public Methods
Name | Description
calculate | Computes frozen minimum PIA.
isApplicable | Determines applicability of method.
setFrozMin | Sets amounts for frozen minimum before benefit increases.


Legend

Legend
FrozMinPage Methods
Legend
Method


FrozMinPage Methods Public Methods

FrozMinPage Methods Public Methods
FrozMinPage Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares frozen minimum strings for printing.


Legend

Legend
Genfile Methods
Legend
Method


Genfile Methods Public Methods

Genfile Methods Public Methods
Genfile Methods Legend
Public Methods
Name | Description
getmesg | Returns current status or warning message.
openapp | Opens a file for appended output with fixed fields for floats.
openin | Opens a file for input.
openout | Opens a file for output with fixed fields for floats.
setmesg | Sets current status or warning message.


Legend

Legend
InsCode Methods
Legend
Method


InsCode Methods Public Methods

InsCode Methods Public Methods
InsCode Methods Legend
Public Methods
Name | Description
ChartoCode | Converts a character to an InsCode::InsCodeType.
get | Returns the insured status code.
isCurrentlyInsured | Returns the currently insured status.
isFullyInsured | Returns the fully insured status.
isFullyOrCurrentlyInsured | Returns the fully or currently insured status.
isFullyOrTotalInsured | Returns the fully or totalization insured status.
isPermanentlyInsured | Returns permanently insured status.
set | Sets the insured status code.
toChar | Returns an insured status code as a character.


Legend

Legend
InsCodeArray Methods
Legend
Method


InsCodeArray Methods Public Methods

InsCodeArray Methods Public Methods
InsCodeArray Methods Legend
Public Methods
Name | Description
assign | Sets values for a range of years.
deleteContents | Zeroes out all data values.
getFirstYear | Returns the first year of data.
getLastYear | Returns the last year of data.
isNonzero | Returns true if any insured status code is other than InsCode::InsCodeType::NOQCS.
setFirstYear | Sets the first year of data.
setLastYear | Sets the last year of data.
toString | Returns data for one insured status code array as a string.


Legend

Legend
InsuredPage Methods
Legend
Method


InsuredPage Methods Public Methods

InsuredPage Methods Public Methods
InsuredPage Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares strings for insured status page.


Legend

Legend
IntAnnual Methods
Legend
Method


IntAnnual Methods Public Methods

IntAnnual Methods Public Methods
IntAnnual Methods Legend
Public Methods
Name | Description
assign | Functions to assign data for a range of years.
fill | Fills all data slots with the given value.
getBaseYear | Returns base year of data.
getLastYear | Returns last year of data.


Legend

Legend
LawChange Methods
Legend
Method
virtual


LawChange Methods Public Methods

LawChange Methods Public Methods
LawChange Methods Legend
Public Methods
Name | Description
bendPointCheck | Checks range of a bendpoint value.
bpincCheck | Checks range of a bend point increase percentage.
constantPercCheck | Checks range of a constant decline percentage.
getEndYear | Returns ending year for this law-change.
getEndYearLC | Returns latest possible ending year for a law-change.
getFirstLine | Reads a line and parses first and last years and type of phase-in.
getInd | Returns indicator for this law-change.
getPhaseType | Returns indicator for type of phase-in.
getStartYear | Returns starting year for this law-change.
getStartYearLC | Returns earliest possible ending year for a law-change.
getTitle | Returns title of this law change.
isEffective | Returns true if this law change is in effect.
percCheck | Checks range of a benefit formula percentage.
prepareStrings | Prepares output strings for this change from present law.
proportionBendPointsCheck | Checks range of a wage increase proportion.
read | Reads all the lines required for this law-change.
setEndYear | Sets ending year for this law-change.
setEndYearLC | Sets latest possible ending year for a law-change.
setInd | Sets change indicator for this law-change.
setPhaseType | Sets indicator for type of phase-in.
setStartYear | Sets starting year for this law-change.
setStartYearLC | Sets earliest possible starting year for a law-change.
startCheck | Checks range of a law-change starting year.
write | Writes a line with first and last years.
writeFirstLine | Writes a line with first and last years.


Legend

Legend
LawChangeAGE65COMP Methods
Legend
Method


LawChangeAGE65COMP Methods Public Methods

LawChangeAGE65COMP Methods Public Methods
LawChangeAGE65COMP Methods Legend
Public Methods
Name | Description
getStep | Returns step size when increasing computation period.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setStep | Sets step size when increasing computation period.
write | Writes a line with first and last years, and percentage.


Legend

Legend
LawChangeALLEARN Methods
Legend
Method


LawChangeALLEARN Methods Public Methods

LawChangeALLEARN Methods Public Methods
LawChangeALLEARN Methods Legend
Public Methods
Name | Description
getStep | Returns step size when increasing number of earnings years.
getYear | Returns starting year when increasing number of earnings years.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setStep | Sets step size when increasing number of earnings years.
setYear | Sets starting year when increasing number of earnings years.
write | Writes a line with first and last years, and step size.


Legend

Legend
LawChangeArray Methods
Legend
Method


LawChangeArray Methods Public Methods

LawChangeArray Methods Public Methods
LawChangeArray Methods Legend
Public Methods
Name | Description
getIndTotal | Returns total of law-change indicators (is greater than 0 if any law changes).
indTotalCal | Calculates total changes in law.


Legend

Legend
LawChangeBPFRACWAGE Methods
Legend
Method


LawChangeBPFRACWAGE Methods Public Methods

LawChangeBPFRACWAGE Methods Public Methods
LawChangeBPFRACWAGE Methods Legend
Public Methods
Name | Description
getProportionBendPoints | Returns proportion of wage increase applied to bend points.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setProportionBendPoints | Sets proportion of wage increase applied to bend points.
write | Writes a line with first and last years, and percentage.


Legend

Legend
LawChangeBPMINCONST Methods
Legend
Method


LawChangeBPMINCONST Methods Public Methods

LawChangeBPMINCONST Methods Public Methods
LawChangeBPMINCONST Methods Legend
Public Methods
Name | Description
getConstantPerc | Returns constant percentage subtracted from bend point increase.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setConstantPerc | Sets constant percentage subtracted from bend point increase.
write | Writes a line with first and last years, and percentage.


Legend

Legend
LawChangeBPSPECRATE Methods
Legend
Method


LawChangeBPSPECRATE Methods Public Methods

LawChangeBPSPECRATE Methods Public Methods
LawChangeBPSPECRATE Methods Legend
Public Methods
Name | Description
getBendPiaInc | Returns bend point increase percentage for specified year.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setBendPiaInc | Sets bend point increase percentage for specified year.
write | Writes a line with first and last years, and percentage.


Legend

Legend
LawChangeCHILDCARECREDIT Methods
Legend
Method


LawChangeCHILDCARECREDIT Methods Public Methods

LawChangeCHILDCARECREDIT Methods Public Methods
LawChangeCHILDCARECREDIT Methods Legend
Public Methods
Name | Description
getAvgEarnPct | Returns the percentage to be multiplied by the person's average earnings to calculate the credit amount.
getChildCareYearsBeforeEffYear | Returns true if the person can be credited for child care years before the first effective year of the proposal, false otherwise.
getFqRatio | Returns ratio of average earnings credited for a child care year.
getMaxAge | Returns maximum age of child to get credited for a child care year.
getMaxYears | Returns maximum number of child care years.
getNumDropExtremeEarnYears | Returns the number of years of highest earnings to drop out of the calculation of the credit amount.
getNumTopEarnYears | Returns the number of highest earnings years to look at for the calculation of the credit amount.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setAvgEarnPct | Sets the percentage to be multiplied by the person's average earnings to calculate the credit amount.
setChildCareYearsBeforeEffYear | Sets if the person can be credited for child care years before the first effective year of the proposal.
setFqRatio | Sets ratio of average earnings credited for a child care year.
setMaxAge | Sets maximum age of child to get credit for a child care year.
setMaxYears | Sets maximum number of child care years.
setNumDropExtremeEarnYears | Sets the number of years of highest earnings to drop out of the calculation of the credit amount.
setNumTopEarnYears | Sets the number of highest earnings years to look at for the calculation of the credit amount.
write | Writes a line with first and last years, and percentage.


Legend

Legend
LawChangeCHILDCAREDROPOUT Methods
Legend
Method


LawChangeCHILDCAREDROPOUT Methods Public Methods

LawChangeCHILDCAREDROPOUT Methods Public Methods
LawChangeCHILDCAREDROPOUT Methods Legend
Public Methods
Name | Description
getFqRatio | Returns ratio of average earnings limit for a child care dropout year.
getMaxAge | Returns maximum age of child to get a child care dropout year.
getMaxYears | Returns maximum number of child care dropout years.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setFqRatio | Sets ratio of average earnings limit for a child care dropout year.
setMaxAge | Sets maximum age of child to get a child care dropout year.
setMaxYears | Sets maximum number of child care dropout years.
write | Writes a line with first and last years, and percentage.


Legend

Legend
LawChangeCOLACHANGE Methods
Legend
Method


LawChangeCOLACHANGE Methods Public Methods

LawChangeCOLACHANGE Methods Public Methods
LawChangeCOLACHANGE Methods Legend
Public Methods
Name | Description
getColaAdj | Returns the amount of adjustment to COLA.
getPiaPercentile | Returns the PIA percentile to use when indicator == 2.
prepareStrings | Prepares output strings for this change from present law.
read | Reads the one line required for this law-change.
setColaAdj | Sets the amount of adjustment to COLA.
setPiaPercentile | Sets the PIA percentile to use when indicator == 2.
write | Writes a line with this law-change.


Legend

Legend
LawChangeDECLINEPERC Methods
Legend
Method


LawChangeDECLINEPERC Methods Public Methods

LawChangeDECLINEPERC Methods Public Methods
LawChangeDECLINEPERC Methods Legend
Public Methods
Name | Description
getAltPercPia | Returns specified benefit formula percentage for specified year.
getFactor | Returns percentage decline in specified benefit formula percent for specified year.
getYear | Returns year that declining benefit formula percentage is effective.
percPiaCal | Sets pia formula percentages.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setFactor | Sets percentage decline in benefit formula percent.
setYear | Sets year that declining benefit formula percentage is effective.
write | Writes a line with first and last years, and percentage.


Legend

Legend
LawChangeDROPOUTCHG Methods
Legend
Method


LawChangeDROPOUTCHG Methods Public Methods

LawChangeDROPOUTCHG Methods Public Methods
LawChangeDROPOUTCHG Methods Legend
Public Methods
Name | Description
getStep | Returns step size when reducing number of dropout years.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setStep | Sets step size when reducing number of dropout years.
write | Writes a line with first and last years, and step size.


Legend

Legend
LawChangeMARRLENGTH Methods
Legend
Method


LawChangeMARRLENGTH Methods Public Methods

LawChangeMARRLENGTH Methods Public Methods
LawChangeMARRLENGTH Methods Legend
Public Methods
Name | Description
getMarrLengthForDivBen | Returns the number of years of marriage needed for a divorced spouse benefit.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setMarrLengthForDivBen | Sets the number of years of marriage needed for a divorced spouse benefit.
write | Writes a line with first and last years, and step size.


Legend

Legend
LawChangeNEWFORMULA Methods
Legend
Method


LawChangeNEWFORMULA Methods Public Methods

LawChangeNEWFORMULA Methods Public Methods
LawChangeNEWFORMULA Methods Legend
Public Methods
Name | Description
getAltBendPia | Returns specified alternate bend point for specified year.
getAltPercPia | Returns specified benefit formula percentage for specified year.
getNumBp | Returns number of bendpoints in the alternate formula.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setAltBendPia | Sets specified alternate bend point for specified year.
setAltPercPia | Sets specified alternate benefit formula percentage for specified year.
setNumBp | Sets number of bendpoints in the alternate formulas.
write | Writes a line with first and last years, and percentage.


Legend

Legend
LawChangeNEWSPECMIN Methods
Legend
Method


LawChangeNEWSPECMIN Methods Public Methods

LawChangeNEWSPECMIN Methods Public Methods
LawChangeNEWSPECMIN Methods Legend
Public Methods
Name | Description
getAmount | Returns alternative special minimum dollar amount.
getPercent | Returns alternate special minimum percentage of wage base required for quarter of coverage.
getYears | Returns alternative maximum number of years of coverage considered in special minimum calculation (30 in PL).
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setAmount | Sets alternative special minimum dollar amount.
setPercent | Sets alternate special minimum percentage of wage base required for quarter of coverage.
setYears | Sets alternative maximum number of years of coverage considered in special minimum calculation (30 in PL).
write | Writes a line with first and last years, and step size.


Legend

Legend
LawChangeNRACHANGE Methods
Legend
Method


LawChangeNRACHANGE Methods Public Methods

LawChangeNRACHANGE Methods Public Methods
LawChangeNRACHANGE Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares output strings for this change from present law.


Legend

Legend
LawChangeOut Methods
Legend
Method


LawChangeOut Methods Public Methods

LawChangeOut Methods Public Methods
LawChangeOut Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares output strings for changes from present law.


Legend

Legend
LawChangePSAACCT Methods
Legend
Method


LawChangePSAACCT Methods Public Methods

LawChangePSAACCT Methods Public Methods
LawChangePSAACCT Methods Legend
Public Methods
Name | Description
getAdminFee | Returns the administrative fee for the specified investment.
getAnnIntRate | Returns the interst rate for the PSA annuities.
getAnnuityOffset | Returns true if the PSA annuity offsets the regular OASDI benefits, false otherwise.
getAnnuityToDib | Returns true if a person converts his PSA into an annuity upon beginning DI benefits.
getAnnuityType | Returns the type of annuity (0 for always straight life, 1 for joint and 2/3 survivor if married).
getBuysAnnuity | Returns true if the PSA is used to buy an annuity, false if it is just diminished by the amount of the annuity payments as the payments are made.
getContribBps | Returns the percent of the wage base to be used as a bend point for the contribution rate to the PSA.
getContribDist | Returns the type of distribution to use for PSA contributions.
getContribRates | Returns specified PSA contribution rate.
getContribStartAge | Returns the starting age for PSA contributions.
getContribYears | Returns PSA contribution year index.
getInvestMean | Returns mean to be used for the return rate on stocks.
getInvestPerc | Returns proportion of PSA contributions going to specified investment.
getInvestStdDev | Returns standard deviation to be used for the return rate on specified investment.
getLumpSumAtFra | Returns true if the entire PSA is paid as a lump sum to a person who attains FRA and is not eligible for an annuity, false otherwise.
getLumpSumPerc | Returns the percent of the PSA that is paid out as a lump sum upon conversion to annuity.
getMngmtFee | Returns the management fee for the specified investment.
getNumContribBps | Returns the number of bend point in the contribution rate for the PSA's.
getPercToSpouse | Returns percentage of contribution going to spouse, if any.
getRebalanceAccounts | Returns true if the PSA investment accounts need to be re-balanced each year, false otherwise.
getTaxAnnuityInd | Returns the indicator on how PSA annuities are taxed.
getToSpouseOnDeathInd | Returns the indicator regarding the transfer of the PSA to a spouse upon death of the person.
getUnisexInd | Returns the unisex indicator.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setAdminFee | Sets the administrative fee for the specified investment.
setAnnIntRate | Sets the interest rate for the PSA annuities.
setAnnuityOffset | Sets the indicator for offsetting OASDI benefits with the PSA annuity.
setAnnuityToDib | Sets the indicator for whether or not a person starts getting an annuity from his PSA upon beginning DI benefits.
setAnnuityType | Sets the type of annuity (0 for always straight life, 1 for joint and 2/3 survivor if married).
setBuysAnnuity | Sets the indicator for how the PSA is treated when the person starts getting an annuity payment.
setContribBps | Sets the percent of the wage base used a s a bend point for the contribution rate into the PSA's.
setContribDist | Sets the type of distribution to use for PSA contributions.
setContribRates | Sets psa contribution rate.
setContribStartAge | Sets the starting age for PSA contributions.
setContribYears | Sets PSA contribution year index.
setInvestMean | Sets mean to be used for the return of specified investment.
setInvestPerc | Sets proportion of psa contributions going to specified investment.
setInvestStdDev | Sets standard deviation to be used for the return rate on specified investment.
setLumpSumAtFra | Sets the indicator for whether or not a person receives the entire PSA as a lump sum if they attain FRA and are not eligible for an annuity.
setLumpSumPerc | Sets the new percent of the PSA that is paid out as a lump sum upon conversion to annuity.
setMngmtFee | Sets the management fee for the specified investment.
setNumContribBps | Sets the number of bend point in the contribution rate into the PSA's.
setPercToSpouse | Sets percentage of contribution going to spouse, if any.
setRebalanceAccounts | Sets the rebalanceAccounts indicator.
setTaxAnnuityInd | Sets the indicator on how PSA annuities are taxed.
setToSpouseOnDeathInd | Sets the indicator regarding the transfer of the PSA to a spouse upon death of the person.
setUnisexInd | Sets unisex indicator.
write | Writes all the lines required for this law-change.


Legend

Legend
LawChangeRead Methods
Legend
Method


LawChangeRead Methods Public Methods

LawChangeRead Methods Public Methods
LawChangeRead Methods Legend
Public Methods
Name | Description
read | Reads indicators for change from present law.


Legend

Legend
LawChangeTAXBENCHG Methods
Legend
Method


LawChangeTAXBENCHG Methods Public Methods

LawChangeTAXBENCHG Methods Public Methods
LawChangeTAXBENCHG Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares output strings for this change from present law.


Legend

Legend
LawChangeTAXRATECHG Methods
Legend
Method


LawChangeTAXRATECHG Methods Public Methods

LawChangeTAXRATECHG Methods Public Methods
LawChangeTAXRATECHG Methods Legend
Public Methods
Name | Description
getNumTaxrates | Returns number of tax rates available.
getTaxrate | Returns tax rate.
getYearTaxrate | Returns year that changed tax rate is effective.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setNumTaxrates | Sets number of tax rates available.
setSelfEmpTaxrate | Set self-employed rates equal to twice ee-er rates.
setTaxrate | Sets tax rate.
setYearTaxrate | Sets year that changed tax rate is effective.
write | Writes a line with first and last years, and step size.


Legend

Legend
LawChangeWAGEBASECHG Methods
Legend
Method


LawChangeWAGEBASECHG Methods Public Methods

LawChangeWAGEBASECHG Methods Public Methods
LawChangeWAGEBASECHG Methods Legend
Public Methods
Name | Description
getBase77 | Returns ad hoc 1977-law wage base for specified year.
getBaseOasdi | Returns ad hoc OASDI wage base for specified year.
prepareStrings | Prepares output strings for this change from present law.
read | Reads all the lines required for this law-change.
setBase77 | Sets ad hoc 1977-law wage base.
setBaseOasdi | Sets ad hoc OASDI wage base.
write | Writes a line with first and last years, and percentage.


Legend

Legend
LawChangeWIDFACTOR Methods
Legend
Method


LawChangeWIDFACTOR Methods Public Methods

LawChangeWIDFACTOR Methods Public Methods
LawChangeWIDFACTOR Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares output strings for this change from present law.


Legend

Legend
LawChangeWIFEFACTOR Methods
Legend
Method


LawChangeWIFEFACTOR Methods Public Methods

LawChangeWIFEFACTOR Methods Public Methods
LawChangeWIFEFACTOR Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares output strings for this change from present law.


Legend

Legend
LawChangeWrite Methods
Legend
Method


LawChangeWrite Methods Public Methods

LawChangeWrite Methods Public Methods
LawChangeWrite Methods Legend
Public Methods
Name | Description
write | Writes indicators for change from present law.


Legend

Legend
MilServDates Methods
Legend
Method


MilServDates Methods Public Methods

MilServDates Methods Public Methods
MilServDates Methods Legend
Public Methods
Name | Description
check | Checks a military service record for consistent dates.
deleteContents | Zeroes out dates of military service.
endDateCheck | Checks an ending date for validity.
getCount1 | Returns this record number.
getCount2 | Returns the number of records in this set.
getDatesString | Returns a string with the two dates, without spaces.
getEarn | Returns wage credits for one year in a one-line record.
getEarn3750 | Returns pre-1951 wage credits in a one-line record.
getQc3750 | Returns pre-1951 quarters of coverage in a one-line record.
getQcov | Returns quarters of coverage for one year in a one-line record.
getType | Returns the type of record.
parseDates | Parses a line of data into two dates.
parseLine | Parses a line of data into a record, including the record number, the total record count, and the record type.
setCount1 | Sets this record number.
setCount2 | Sets the number of records in this set.
setType | Sets the type of record.
startDateCheck | Checks a starting date for validity.
toString | Returns a string with the military service info.


Legend

Legend
MilServDatesVec Methods
Legend
Method


MilServDatesVec Methods Public Methods

MilServDatesVec Methods Public Methods
MilServDatesVec Methods Legend
Public Methods
Name | Description
check | Checks a multiline record.
deleteContents | Zeroes out dates of military service.
getEarn | Returns wage credits for one year in a multiline record.
getEarn3750 | Returns pre-1951 wage credits in a multiline record.
getFirstYear | Returns first year with any military service, 0 if none.
getLastYear | Returns last year with any military service, 0 if none.
getMSCount | Returns the number of records being used.
getQc3750 | Returns pre-1951 quarters of coverage in a multiline record.
getQcov | Returns quarters of coverage for one year in a multiline record.
msCountCheck | Checks the number of military service periods.
setMSCount | Sets the number of military service records.


Legend

Legend
OldPia Methods
Legend
Method


OldPia Methods Public Methods

OldPia Methods Public Methods
OldPia Methods Legend
Public Methods
Name | Description
cpiBase | Applies CPI and wage base increases to 1973 Act PIA Table.
mfbOldCal | Finds AME from PIA in PIA table.
oldPiaCal | Selects correct PIA table.
pl1952 | Calculates PIAs under 1952 Act.
pl1954 | Calculates PIAs under 1954 Act.
pl1958 | Calculates PIAs under 1958 Act.
pl1965 | Calculates PIAs under 1965 Act.
pl1967 | Calculates PIAs under 1967 Act.
pl1969 | Calculates PIAs under 1969 Act.
pl1971 | Calculates PIAs under 1971 Act.
pl1972 | Calculates PIAs under 1972 Act, effective Sept 1972.
pl1973 | Calculates PIAs under 1973 Act.
pl1973ext | Calculates PIAs under 1973 Act, extension to table.


Legend

Legend
OldStart1Page Methods
Legend
Method


OldStart1Page Methods Public Methods

OldStart1Page Methods Public Methods
OldStart1Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares old start strings for printing.


Legend

Legend
OldStart2Page Methods
Legend
Method


OldStart2Page Methods Public Methods

OldStart2Page Methods Public Methods
OldStart2Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares old start strings for printing.
pubPenOut | Prepares windfall calculation.


Legend

Legend
OldStart Methods
Legend
Method


OldStart Methods Public Methods

OldStart Methods Public Methods
OldStart Methods Legend
Public Methods
Name | Description
calculate | Computes old start PIA.
getAmeOs | Returns old-start AME.
getDivisorOs | Returns divisor for old-start pre-1951 earnings.
getIncyrs | Returns number of old-start increment years.
getMethodOs | Returns old-start calculation method number.
getPib | Returns old-start PIB before incrementing.
getPibInc | Returns old-start PIB after incrementing.
imputeEarnings | Imputes yearly earnings prior to 1951.
incrementCal | Calculates number of increment years for old-start.
incrementOldCal | Calculates number of increment years for old old-start.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
isOs1977_90 | Returns true if the old-start method is 1977 or 1990.
methodOsCal | Determines correct old-start method.
oldStart39Cal | Calculates 1939 old-start PIA and MFB.
oldStart50Cal | Calculates 1950 old-start PIA and MFB.
setAmeOs | Sets old-start AME.
setDivisorOs | Sets divisor for old-start pre-1951 earnings.
setIncyrs | Sets number of old-start increment years.
setMethodOs | Sets old-start calculation method number.
setPib | Sets old-start PIB before incrementing.
setPibInc | Sets old-start PIB with increment years.


Legend

Legend
OldStartLC Methods
Legend
Method


OldStartLC Methods Public Methods

OldStartLC Methods Public Methods
OldStartLC Methods Legend
Public Methods
Name | Description
isApplicable | Determines applicability of method.


Legend

Legend
OnePage Methods
Legend
Method


OnePage Methods Public Methods

OnePage Methods Public Methods
OnePage Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares strings for 1-page summary.
printEarn | Prepares table of earnings.


Legend

Legend
Out80 Methods
Legend
Method


Out80 Methods Public Methods

Out80 Methods Public Methods
Out80 Methods Legend
Public Methods
Name | Description
footer | Does nothing.
header | Does nothing.
pgtitle | Writes date, time, 1-line title, and page to 80-column print file.
prepareStrings | Prepares the two-line title strings for output.


Legend

Legend
Out132 Methods
Legend
Method


Out132 Methods Public Methods

Out132 Methods Public Methods
Out132 Methods Legend
Public Methods
Name | Description
footer | Does nothing.
header | Does nothing.
pgtitle | Writes date, time, 2-line title, and page to 132-column print file.
prepareStrings | Prepares the two-line title strings for output.


Legend

Legend
OutDC80 Methods
Legend
Method


OutDC80 Methods Public Methods

OutDC80 Methods Public Methods
OutDC80 Methods Legend
Public Methods
Name | Description
advanceLine | Advances one line.
formfeed | Dummy function.
printLine | Prints one line of text with a carriage return.
printLinena | Prints one line of text without a carriage return.
setDC | Sets device context to use.
setHeight | Sets height of one line.
setx | Sets horizontal margin.
sety | Sets vertical margin.


Legend

Legend
OutFile80 Methods
Legend
Method


OutFile80 Methods Public Methods

OutFile80 Methods Public Methods
OutFile80 Methods Legend
Public Methods
Name | Description
advanceLine | Advances one line.
formfeed | Advances to next page.
getColString | Returns left-hand margin string.
getCols | Returns number of columns to space over on left side.
printLine | Prints a line of output with a carriage return.
printLinena | Prints a line of output without a carriage return.
setCols | Sets number of columns on left-hand margin.


Legend

Legend
OutFile132 Methods
Legend
Method


OutFile132 Methods Public Methods

OutFile132 Methods Public Methods
OutFile132 Methods Legend
Public Methods
Name | Description
advanceLine | Advances one line.
formfeed | Advances to next page.
getColString | Returns left-hand margin string.
getCols | Returns number of columns to space over on left side.
printLine | Prints a line of output with a carriage return.
printLinena | Prints a line of output without a carriage return.
setCols | Sets number of columns on left-hand margin.


Legend

Legend
Outfile Methods
Legend
Method
abstract


Outfile Methods Public Methods

Outfile Methods Public Methods
Outfile Methods Legend
Public Methods
Name | Description
advanceLine | Move to next line.
closeout | Closes output file.
footer | Writes a footer to a print file.
formfeed | Move to next page.
getPageNum | Returns page number.
gettitle | Returns one page title line.
header | Writes a heading line to a print file.
openout | Opens output file.
pgtitle | Writes date, time, title, and page to print file.
printLine | Prints a line of output with a carriage return.
printLinena | Prints a line of output without a carriage return.
setPageNum | Sets page number.
settitle | Sets one page title line.


Legend

Legend
OutFileHTML Methods
Legend
Method


OutFileHTML Methods Public Methods

OutFileHTML Methods Public Methods
OutFileHTML Methods Legend
Public Methods
Name | Description
closeFile | Close the output file.
doHeader | Writes html header information.
gettitle | Returns one page title line.
openFile | Opens output file.
pgtitle | Writes title to html file.
settitle | Sets one page title line.
write | Prints the specified argument without a carriage return.
writeAttribute | Writes an HTML attribute and its value.
writeBeginGrayRow | Writes gray row starting information.
writeBeginTable | Writes the HTML for the start of a table.
writeBeginTag | Writes the opening tag of the specified HTML element.
writeCellBody | Writes the HTML for the contents of one cell in a table, left-justified.
writeCellBodyColSpan | Writes the html for a string as the contents of one cell in a table, left-justified, spanning columns.
writeCellBodyRight | Writes the HTML for the contents of one cell in a table, right-justified.
writeCellHeading | Writes the HTML for the contents of one heading in a table.
writeCellHeadingColSpan | Writes the HTML for the contents of one heading in a table, spanning columns.
writeCellHeadingRowSpan | Writes the html for the contents of one heading in a table, spanning rows.
writeEndTag | Writes the closing tag of the specified HTML element.
writeFullBeginTag | Writes the opening tag of the specified HTML element.
writeLine | Prints one line with a carriage return.
writeYear | Prints year with left justification in html output file.


Legend

Legend
PageCounters Methods
Legend
Method


PageCounters Methods Public Methods

PageCounters Methods Public Methods
PageCounters Methods Legend
Public Methods
Name | Description
deleteContents | Zeroes out page counters.
get | Returns page counter for one slot.
read | Reads page counters from a file named "page".
set | Sets page counter for one slot.
update | Updates all subsequent page counters and writes them out.
write | Writes page counters out to a file named "page".


Legend

Legend
PageOut Methods
Legend
Method
abstract


PageOut Methods Public Methods

PageOut Methods Public Methods
PageOut Methods Legend
Public Methods
Name | Description
getCount | Returns number of lines of output.
getString | Returns one line of output.
prepareStrings | Prepares strings for output.
print | Writes the output strings to the specified device.


Legend

Legend
Path Methods
Legend
Method


Path Methods Public Methods

Path Methods Public Methods
Path Methods Legend
Public Methods
Name | Description
changeExtension | Changes the extension of a path string.
combine | Combines two path strings.
getDirectoryName | Returns the directory information for the specified path string.
getFileName | Returns the file name information for the specified path string.
getRelativeName | Returns a relative path to the file for the specified path string. This is designed to provide a relative link to a file from an html page.


Legend

Legend
Pebs Methods
Legend
Method


Pebs Methods Public Methods

Pebs Methods Public Methods
Pebs Methods Legend
Public Methods
Name | Description
agePlanCheck | Checks planned age of retirement in Statement case.
deleteContents | Initializes all variables to default values.
getAgePlan | Returns planned age of retirement.
getAgePlan2 | Returns planned retirement age.
getBenefitPebs | Returns benefit actually payable in Statement calculation.
getMfbPebs | Returns maximum family benefit in Statement calculation.
getMonthnow | Returns month of processing.
getPebsDib | Returns number of dib computations to do.
getPebsOab | Returns number of oab computations to do.
getPiaPebs | Returns PIA in Statement calculation.
getQcDisReq | Returns quarters of coverage required for disability insured status for Statement calculation.
getQcDisTotal | Returns quarters of coverage earned for disability insured status for Statement calculation.
getQcDisYears | Returns number of years over which quarters of coverage must be earned for disability insured status for Statement calculation.
getQcReq | Returns required quarters of coverage in Statement calculation.
getQcTotal | Returns quarters of coverage earned through current year.
monthnowCheck | Checks for correct month of Statement processing.
setAgePlan | Sets planned age of retirement in Statement case.
setAgePlan2 | Sets planned retirement age.
setBenefitPebs | Sets benefit actually payable in Statement calculation.
setMfbPebs | Sets maximum family benefit in Statement calculation.
setMonthnow | Sets month of Statement processing.
setPebsDib | Sets number of dib computations to do.
setPebsOab | Sets number of oab computations to do.
setPiaPebs | Sets PIA in Statement calculation.
setQcDisReq | Sets number of DI quarters of coverage required.
setQcDisTotal | Sets number of DI quarters of coverage earned.
setQcDisYears | Sets number of years allowed to earn DI quarters of coverage.
setQcReq | Sets required quarters of coverage in Statement calculation.
setQcTotal | Sets number of quarters of coverage earned through current year.


Legend

Legend
PebsCreditInfo Methods
Legend
Method


PebsCreditInfo Methods Public Methods

PebsCreditInfo Methods Public Methods
PebsCreditInfo Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares general credit and tax information for printing.


Legend

Legend
PebsEarnings Methods
Legend
Method


PebsEarnings Methods Public Methods

PebsEarnings Methods Public Methods
PebsEarnings Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares page of earnings for printing.


Legend

Legend
PebsEarningsInfo Methods
Legend
Method


PebsEarningsInfo Methods Public Methods

PebsEarningsInfo Methods Public Methods
PebsEarningsInfo Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares earnings info for printing.


Legend

Legend
PebsLetter Methods
Legend
Method


PebsLetter Methods Public Methods

PebsLetter Methods Public Methods
PebsLetter Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares letter for printing.


Legend

Legend
PebsOasdiEst Methods
Legend
Method


PebsOasdiEst Methods Public Methods

PebsOasdiEst Methods Public Methods
PebsOasdiEst Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares OASI estimates for printing.


Legend

Legend
PebsOasdiInfo Methods
Legend
Method


PebsOasdiInfo Methods Public Methods

PebsOasdiInfo Methods Public Methods
PebsOasdiInfo Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares oasdi benefit estimate information.


Legend

Legend
PebsOut Methods
Legend
Method


PebsOut Methods Public Methods

PebsOut Methods Public Methods
PebsOut Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares strings for printing.
setPageNum | Fills out page numbers.


Legend

Legend
PebsPageOut Methods
Legend
Method


PebsPageOut Methods Public Methods

PebsPageOut Methods Public Methods
PebsPageOut Methods Legend
Public Methods
Name | Description
prepareHeader | Prepares header string for output.
setPageNum | Sets page number.


Legend

Legend
PebsWorkerEarnings Methods
Legend
Method


PebsWorkerEarnings Methods Public Methods

PebsWorkerEarnings Methods Public Methods
PebsWorkerEarnings Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares top part of summary page.


Legend

Legend
PebsWorkerInfo Methods
Legend
Method


PebsWorkerInfo Methods Public Methods

PebsWorkerInfo Methods Public Methods
PebsWorkerInfo Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares worker information for printing.


Legend

Legend
PercMfb Methods
Legend
Method


PercMfb Methods Public Methods

PercMfb Methods Public Methods
PercMfb Methods Legend
Public Methods
Name | Description
as_array | Returns percentages as a simple array.
begin | This is the overview for the begin method overload.
end | This is the overview for the end method overload.
max_size | Returns maximum number of percentages.
reset | Resets percentages to original values.
size | Returns number of percentages.


Legend

Legend
PercPia Methods
Legend
Method


PercPia Methods Public Methods

PercPia Methods Public Methods
PercPia Methods Legend
Public Methods
Name | Description
as_array | Returns percentages as a simple array.
begin | This is the overview for the begin method overload.
end | This is the overview for the end method overload.
getNumPerc | Returns the number of percentages.
max_size | Returns maximum number of percentages.
reset | Resets percentages to original 1977 amendments values.
setNumPerc | Sets number of percentages.
setWindfallPerc | Sets first PIA formula percentage for windfall elimination provision.
size | Returns number of percentages.


Legend

Legend
PercPiaOut Methods
Legend
Method


PercPiaOut Methods Public Methods

PercPiaOut Methods Public Methods
PercPiaOut Methods Legend
Public Methods
Name | Description
getNumPercs | Returns number of percentages in the PIA formula for a year.
getPercPia | Returns an indexed percentage for specified year.
setData | Sets data for one year.


Legend

Legend
PiaCal Methods
Legend
Method
virtual
abstract


PiaCal Methods Public Methods

PiaCal Methods Public Methods
PiaCal Methods Legend
Public Methods
Name | Description
ageEntCheck | Checks date of entitlement for a primary benie.
applyLifeMfb | Applies maximum family benefit to family's benefits in a life case.
applyMfb | Applies maximum family benefit to each family benefit, after ratio has been determined.
applySurvivorMfb | Applies maximum family benefit to family's benefits in a survivor case.
ardriAuxCal | Calculates the benefit factor and number of months of early or delayed retirement for a dependent or survivor.
ardriCal | Calculates the number of months of early or delayed retirement for a primary benie.
calculate2 | Calculates PIA and benefit.
dataCheck | Checks primary data for validity and does some preliminary calculations.
dataCheckAux | Checks auxiliary data for validity and does some preliminary calculations.
deadIns | Returns the insured status code for a deceased worker.
deemedInsCal | Checks for deemed insured status, assuming eligible for deemed insured status provision to apply.
didropCal | Calculates number of years to drop out of elapsed period due to disability.
didropNonFreezeCal | Calculates number of years to drop out of elapsed period for fully insured status due to disability in a non-freeze computation.
disInsCal | Calculates the disability insured status code for one year.
disInsNonFreezeCal | Calculates the disability insured status code for non-freeze for one year.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
eligYearCal | Computes year of eligibility.
eligYearCal1 | Computes date of eligibility before considering disability.
eligYearCal2 | Computes year of eligibility after considering disability.
eligYearCal3 | Computes year of eligibility for non-freeze computations.
eligYearWidowCal | Returns eligibility year for widow(er).
fins1Cal | Calculates and returns the insured status code for one date.
fins2Cal | Calculates and returns the OACT insured status code for one date.
finsNonFreeze1Cal | Calculates and returns the insured status code for non-freeze for one date.
finsNonFreeze2Cal | Calculates and returns the OACT insured status code for non-freeze for one date.
fullInsDateCal | Calculates the date fully insured status was first attained (at full retirement age or later).
getIoasdi | Returns type of benefit.
getPubpenEnable | Returns true if ok to enable noncovered pension entry box.
insCal | Calculates the insured status code for one date.
insNonFreezeCal | This is the overview for the insNonFreezeCal method overload.
isPebsAssumptions | Returns Statement assumptions indicator.
monthsArAgedSpouseCal | Calculates full benefit factor and number of months of actuarial reduction for aged wife or husband and sets reduction factor.
monthsArCal | Calculates number of months of actuarial reduction for OAB and sets reduction factor.
monthsArDICal | Calculates number of months of actuarial reduction for DIB and sets reduction factor.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er) and sets reduction factor.
monthsArWidCal | Calculates full benefit factor and number of months of actuarial reduction for aged widow(er) and sets reduction factor.
monthsDriCal | Calculates number of months of delayed retirement credit for OAB and sets increment factor.
monthsYngLifeCal | Calculates number of months of actuarial reduction for young auxiliary and sets benefit factor.
monthsYngSurvCal | Calculates number of months of actuarial reduction for young survivor and sets benefit factor.
nCal | Determine number of computation years and dropout years.
nDropCal | Determine number of dropout years, before considering 1-for-5 dropout.
nDropNonFreezeCal | Determine number of dropout years, before considering 1-for-5 dropout.
nNonFreezeCal | Determine number of computation years and dropout years.
nelapsed2Cal | Returns ending elapsed year for a beneficiary case.
nelapsed2NonFreezeCal | Returns ending elapsed year for a non-freeze case.
nelapsedCal | Determine number of elapsed years.
nelapsedNonFreezeCal | This is the overview for the nelapsedNonFreezeCal method overload.
piaCal | Calculates PIA and MFB, not including re-indexed widow(er).
piaCal1 | Figures high pia and mfb.
piaCal2 | Figures benefit for primary.
piaCal3 | Figures benefits for auxiliaries.
qc3750simpCal | Calculates simplified quarters of coverage, 1937-50.
qcCal | Calculates annual quarters of coverage and insured status.
qcCurrentCal | Calculates quarters of coverage earned for currently insured status.
qcCurrentNonFreezeCal | Calculates quarters of coverage earned for currently insured status for non-freeze.
qcReqCal | Calculates required quarters of coverage for fully insured status at end of year.
qcReqNonFreezeCal | Calculates required quarters of coverage for fully insured status for non-freeze at end of year.
qcReqPermCal | Calculates required quarters of coverage for permanently insured status.
qcReqPermNonFreezeCal | Calculates required quarters of coverage for permanently insured status for non-freeze.
reindWidCal | Calculates PIA for one re-indexed widow(er).
reindWidCalAll | Calculates PIA for all re-indexed widow(er)s.
relEarnPositionCal | Calculates relative earnings position.
releaseMemory | Releases memory.
resetAmend90 | Resets indicator for earnings used after 1991.
setAmend90 | Sets indicator for entitlement after 1990 amendments.
setArfApp | Sets indicator for delayed retirement credit in special minimum case.
setEligYearWidow | Sets eligibility year for widow.
setHighMfb | Sets applicable mfb.
setHighPia | Sets applicable pia.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPifc | Sets applicable pifc.
setSupportPia | Sets support pia, if applicable pia is special minimum and there is delayed retirement credit involved.
widowCheck | Checks disabled widow's date of disability.


Legend

Legend
PiaCalAny Methods
Legend
Method


PiaCalAny Methods Public Methods

PiaCalAny Methods Public Methods
PiaCalAny Methods Legend
Public Methods
Name | Description
calculate1 | Calculates preparatory variables.
calculate2 | Calculates PIA and benefit.
dataCheck | Checks primary data for validity and does some preliminary calculations.
earnProSteady | Projects steady earnings.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
pebsOabCal | Calculates number of old-age calculations to do.
pebsSetup | Sets information for Statement case.


Legend

Legend
PiaCalLC Methods
Legend
Method


PiaCalLC Methods Public Methods

PiaCalLC Methods Public Methods
PiaCalLC Methods Legend
Public Methods
Name | Description
calculate2 | Calculates PIA and benefit.
childCareCreditCal | Sets best child care years to use, using passed arguments rather than member variables.
childCareEarningsCal | Adds childcare credits into regular OASDI earnings, using passed arguments rather than member variables.
childCareMaxCreditCal | Calculates the maximum child care credit.
childCareQcCal | Adjusts QCs for child care credits, using passed arguments rather than member variables.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
earnProjectionStatic | Projects earnings and fills in earnings to be used in calculations, using passed arguments rather than member variables.
nCal | Determine number of computation years and dropout years.
nelapsed2Cal | Returns ending elapsed year for a beneficiary case.
nelapsed2NonFreezeCal | Returns ending elapsed year for a beneficiary case.
piaCal | Calculates PIA and MFB, not including re-indexed widow(er).
reindWidCal | Calculates PIA for one re-indexed widow(er).


Legend

Legend
PiaCalPL Methods
Legend
Method


PiaCalPL Methods Public Methods

PiaCalPL Methods Public Methods
PiaCalPL Methods Legend
Public Methods
Name | Description
calculate2 | Calculates PIA and benefit.
piaCal | Calculates PIA and MFB, not including re-indexed widow(er).
reindWidCal | Calculates PIA for one re-indexed widow(er).


Legend

Legend
PiaData Methods
Legend
Method


PiaData Methods Public Methods

PiaData Methods Public Methods
PiaData Methods Legend
Public Methods
Name | Description
deleteContents | Initializes variables to default values.
earn50Cal | Calculates first year of earnings after 1950, with or without totalization.
earnHiCal | Calculates HI earnings by adding OASDI earnings and excess HI earnings.
earnProjection | Projects earnings and fills in earnings to be used in calculations.
earnTotal50Cal0 | Calculates sum of regular pre-1951 earnings.
earnTotal50Cal1 | Calculates sum of pre-1951 totalization earnings.
earnYearCal | Determines last year of allowable earnings.
freezeYearsCal | Determines freeze period.
getAmend90 | Returns indicator for entitlement after 1990 amendments.
getArf | Returns actuarial reduction factor or delayed retirement credit.
getArfApp | Returns special minimum-delayed retirement credit indicator.
getBirthDateMinus1 | Returns day before worker's birth.
getChildCareMaxCredit | Returns maximum child care credit amount for a specified year.
getChildCareYearsTotal | Returns total number of child care years.
getDeemedQcReq | Returns number of quarters required for deemed fully insured status.
getEarn3750ms | Returns military service earnings, 1937-50.
getEarn50 | Returns first year of earnings after 1950.
getEarnTotal50 | Returns total earnings prior to 1951.
getEarnYear | Returns last year of earnings considered.
getEligDate | Returns worker's month and year of eligibility before considering prior disability onset.
getEligYear | Returns worker's year of eligibility after considering prior disability onset.
getEligYearNonFreeze | Returns worker's year of eligibility for non-freeze computations.
getFinsCode2 | Returns fully insured code as used in oact printouts.
getFinsNonFreezeCode2 | Returns fully insured non-freeze code as used in oact printouts.
getFirstQcYear | Returns first year with a quarter of coverage; 1937 if any QC's before 1951, 1936 if no QC's.
getFullInsDate | Returns date fully insured status is attained.
getFullRetDate | Returns date full retirement age is attained.
getIappn | Returns number of applicable pia calculation method.
getIapps | Returns support PIA method number.
getIbeginAll | Returns first year of earnings after considering railroad and military service.
getIbeginTotal | Returns first year of attributed earnings in totalization case.
getIendAll | Returns last year of earnings after considering railroad and military service.
getIendTotal | Returns last year of attributed earnings in totalization case.
getLastQcYear | Returns last year with a quarter of coverage, but at least 1950.
getMonthsArdri | Returns number of months of increment or reduction.
getOverMax | Returns indicator for earnings over maximum.
getPifc | Returns code for type of pia.
getPubpenApp | Returns applicable noncovered pension.
getQc3750ms | Returns military service quarters of coverage, 1937-50.
getQc3750simp | Returns simplified quarters of coverage, 1937-50.
getQcCurrent | Returns number of quarters earned in prior 3 years.
getQcCurrentNonFreeze | Returns number of quarters earned in prior 3 years for non-freeze.
getQcDisDate1 | Returns beginning quarter and year of period of required quarters of coverage for disability insured status.
getQcDisDate2 | Returns ending quarter and year of period of required quarters of coverage for disability insured status.
getQcDisDate3 | Returns beginning quarter and year of period of required quarters of coverage for disability insured status, for period after disability cessation.
getQcDisDate4 | Returns ending quarter and year of period of required quarters of coverage for disability insured status, for period after disability cessation.
getQcDisDate5 | Returns beginning quarter and year of period of required quarters of coverage for disability insured status, for period before prior disability.
getQcDisDate6 | Returns ending quarter and year of period of required quarters of coverage for disability insured status, for period before prior disability.
getQcDisDateNonFreeze1 | Returns beginning quarter and year of period of required quarters of coverage for disability insured status for non-freeze.
getQcDisDateNonFreeze2 | Returns ending quarter and year of period of required quarters of coverage for disability insured status for non-freeze.
getQcDisQtr | Returns number of quarters over which quarters of coverage must be earned for disability insured status.
getQcDisQtr2 | Returns number of quarters over which quarters of coverage must be earned for disability insured status, based on elapsed quarters after disability cessation.
getQcDisQtrNonFreeze | Returns number of quarters over which quarters of coverage must be earned for disability insured status for non-freeze.
getQcDisReq | Returns number of quarters required for disability insured status.
getQcDisReqNonFreeze | Returns number of quarters required for disability insured status for non-freeze.
getQcDisYears | Returns number of years over which quarters of coverage must be earned for disability insured status.
getQcDisYearsNonFreeze | Returns number of years over which quarters of coverage must be earned for disability insured status for non-freeze.
getQcReq | Returns number of quarters required for fully insured status.
getQcReqNonFreeze | Returns number of quarters required for fully insured non-freeze status.
getQcReqPerm | Returns number of quarters required for permanently insured status.
getQcReqPermNonFreeze | Returns number of quarters required for permanently insured non-freeze status.
getQcTotal | Returns total number of quarters earned for fully insured status.
getQcTotal50 | Returns total number of quarters earned from 1937 to 1950.
getQcTotal51 | Returns total number of quarters earned after 1950.
getQcTotal51NonFreeze | Returns total number of quarters earned after 1950 for non-freeze.
getQcTotalDis | Returns total number of quarters earned for disability insured status.
getQcTotalDisNonFreeze | Returns total number of quarters earned for disability insured status for non-freeze.
getQcTotalNonFreeze | Returns total number of quarters earned for fully insured non-freeze status.
getQcTotalRel | Returns total number of quarters earned for totalization benefit computation.
getRelEarnPositionAverage | Returns average relative earnings position.
initialize | Initializes computed values to zero.
qcCal | Calculates annual quarters of coverage.
qcDiSpec | Sets first quarter and year of disability insured period for special insured status (called only if calculated first quarter and year are in quarter of age 21 or earlier).
qcDiSpecNonFreeze | Sets first quarter and year of disability insured period for special insured status (called only if calculated first quarter and year are in quarter of age 21 or earlier).
qcDisCal | Calculates earned quarters of coverage in disability insured period.
qcDisNonFreezeCal | Calculates earned quarters of coverage in disability insured period for non-freeze.
qcDisReq2Cal | Determines number of required quarters of coverage for DI insured status, based on elapsed quarters after disability cessation.
qcDisReqCal | Determines number of required quarters of coverage for DI insured status.
qcDisReqNonFreezeCal | Determines number of required quarters of coverage for DI insured status for non-freeze.
qcTotalCal | Calculates total quarters of coverage. Assumes annual quarters of coverage are already known, either from 1951 or from 1978.
qcTotalNonFreezeCal | Calculates total quarters of coverage for non-freeze. Assumes annual quarters of coverage are already known, either from 1951 or from 1978, and that qcs prior to 1951 have already been computed as well by PiaData::qcTotalCal.
setAmend90 | Sets indicator for entitlement after 1990 amendments.
setArf | Sets actuarial reduction factor or delayed retirement credit.
setArfApp | Sets special minimum-delayed retirement credit indicator.
setBirthDateMinus1 | Sets day before worker's birth.
setChildCareYearsTotal | Sets total number of child care years.
setDeemedQcReq | Sets number of quarters of coverage required for deemed insured status.
setDoEarlyQcs | Sets indicator for calculation of quarters of coverage for early years.
setEarn3750ms | Sets military service earnings, 1937-50.
setEligDate | Sets month and year of eligibility before considering disability.
setEligYear | Sets eligibility year after considering prior disability onset.
setEligYearNonFreeze | Sets eligibility year for non-freeze computations.
setFinsCode2 | Sets fully insured status code as used in oact printouts.
setFinsNonFreezeCode2 | Sets fully insured non-freeze status code as used in oact printouts.
setFullInsDate | Sets date fully insured status is attained.
setFullRetDate | Sets date of attainment of normal retirement age, but no earlier than January 1937.
setIappn | Sets number of applicable pia calculation method.
setIapps | Sets support pia method number.
setIbeginTotal | Sets first year of attributed earnings in totalization case.
setIendTotal | Sets last year of attributed earnings in totalization case.
setMonthsArdri | Sets number of months of increment or reduction.
setOverMax | Sets indicator for earnings over maximum.
setPifc | Sets code for type of pia.
setQc3 | Sets some quarter of coverage amounts.
setQc3750ms | Sets military service quarters of coverage, 1937-50.
setQc3750simp | Sets simplified quarters of coverage, 1937-50.
setQcCurrent | Sets quarters of coverage earned in prior 3 years.
setQcCurrentNonFreeze | Sets quarters of coverage earned in prior 3 years for non-freeze.
setQcReq | Sets number of quarters required for fully insured status.
setQcReqNonFreeze | Sets number of quarters required for fully insured non-freeze status.
setQcReqPerm | Sets number of quarters required for permanently insured status.
setQcReqPermNonFreeze | Sets number of quarters required for permanently insured non-freeze status.
setQcTotal | Sets total quarters of coverage.
setQcTotal50 | Sets quarters of coverage prior to 1951.
setQcTotalNonFreeze | Sets total quarters of coverage for non-freeze.
setQcTotalRel | Sets total quarters of coverage earned for a totalization benefit computation.
setRelEarnPositionAverage | Sets average relative earnings position.
updateMilServ | Updates military service earnings and quarters of coverage.


Legend

Legend
PiaDataArray Methods
Legend
Method


PiaDataArray Methods Public Methods

PiaDataArray Methods Public Methods
PiaDataArray Methods Legend
Public Methods
Name | Description
deleteContents | Resets all values to zero.
famSizeCheck | Checks if family size is ok.
getFamSize | Returns family size (not including worker).
setFamSize | Sets family size (not including worker).


Legend

Legend
PiaException Methods
Legend
Method


PiaException Methods Public Methods

PiaException Methods Public Methods
PiaException Methods Legend
Public Methods
Name | Description
getNumber | Returns number of this exception.
what | Returns string with message about this error.


Legend

Legend
PiaMethod Methods
Legend
Method
abstract
virtual


PiaMethod Methods Public Methods

PiaMethod Methods Public Methods
PiaMethod Methods Legend
Public Methods
Name | Description
applyColas | Applies benefit increases to 1977 Amendments PIA or MFB.
applyColasElig | Applies benefit increases to 1977 Amendments PIA or MFB.
calculate | Calculates pia and mfb for this method.
diMax | Applies DI maximum provision, including COLAs to date of benefit.
diMaxNonFreeze | Applies DI maximum provision for non-freeze, including COLAs to date of benefit.
dimaxElig | Applies DI maximum provision as of year of eligibility.
getAme | Returns ame or aime.
getAmeTotal | Returns average (indexed) monthly earnings before application of totalization provision, if applicable.
getApplicable | Returns indicator for use of pia calculation method.
getCap | Returns percentage cap for MFB (for DI cases).
getCpiYear | Returns year that benefit increases were applied.
getIndCap | Returns disability MFB cap indicator.
getIoasdi | Returns type of benefit.
getMethod | Returns the calculation method.
getPiaEligTotal | Returns PIA at eligibility before application of totalization provision, if applicable (0 otherwise).
getPiaTotal | Returns PIA before application of totalization provision, if applicable (0 otherwise).
getPiaWindfall | Returns PIA at eligibility before application of windfall provision, if applicable (0 otherwise).
getTableNum | Returns number of applicable PIA table.
getTitle | Returns title of this method.
getWindfall | Returns windfall indicator.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
getftearn | Returns sum of high n years of earnings.
initialize | Initializes computed values to zero.
isApplicable | Returns true if this method is applicable.
isPebsAssumptions | Returns old Statement assumptions indicator.
mfbCal | Calculates an MFB at eligibility under the 1977 law.
orderEarnings | Orders earnings and sets indicator for the highest years.
prorate | Calculates pro rata totalization benefit.
setAme | Sets ame or aime.
setAmeTotal | Saves aime before application of totalization provision.
setApplicable | Sets indicator for use of pia calculation method.
setCap | Sets percentage cap for MFB (for DI cases).
setDirty | Sets indicator for non-zero values.
setIndCap | Sets disability MFB cap indicator.
setIoasdi | Sets the type of benefit.
setPebsAssumptions | Sets Statement assumptions indicator.
setPiaEligTotal | Saves pia at eligibility before application of totalization provision.
setPiaTotal | Saves pia before application of totalization provision.
setPiaWindfall | Saves pia before application of windfall elimination provision.
setPortionPiaElig | Calculates portion of pia at eligibility in each section of mfb formula.
setTableNum | Sets number of applicable PIA table.
setYearCpi | Sets years of benefit increases.
setftearn | Sets sum of high n years of earnings,
specMinYearsCal | Calculates number of years of coverage.
specMinYearsTotalCal | Calculates number of years of coverage for special minimum or windfall elimination provision.
totalEarnCal | Computes total earnings and AME or AIME.
wep_app | Determines if windfall elimination provision applies.


Legend

Legend
PiaOut Methods
Legend
Method


PiaOut Methods Public Methods

PiaOut Methods Public Methods
PiaOut Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares strings for printing.
setPageNum | Fills out page numbers.


Legend

Legend
PiaPageOut Methods
Legend
Method
protected


PiaPageOut Methods Protected Methods

PiaPageOut Methods Protected Methods
PiaPageOut Methods Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
endYearCal | Calculates the ending year type for printing a range of benefit increases.
firstYearCal | Calculates the first year type for printing a range of benefit increases.


PiaPageOut Methods Public Methods

PiaPageOut Methods Public Methods
PiaPageOut Methods Legend
Public Methods
Name | Description
baseYearOut | Prepares base year in a string table.
biOut | Prints the benefit increases that are applied to a benefit.
compYear | Prepares number of computation years in a string table.
disInsOut | Prints out disability insured message.
disMfbOut | Prepares MFB cap on DI cases in a string table.
mfbBpOut | Prepares MFB formula bend points in a string table.
mfbOut | Prints the calculation of the Maximum Family Benefit.
newTableOut | Prepares table change automatic increases used in PIA calculation in a string table.
nonIns | Prints out uninsured message.
nonpenOut | Prints out noncovered pension amount and starting date.
osTableOut | Prepares applicable old start pia table in a string table.
piaBpOut | Prepares PIA formula bend points in a string table.
piaEligOut | Prepares wage-indexed pia at eligibility calculation in a string table.
piaEntOut | Prepares PIA at entitlement in a string table.
piamfb1 | Prepares PIA and MFB at entitlement in a string table.
piamfb2 | Prepares PIA and MFB at benefit date in a string table.
piamfb3 | Prepares PIA and MFB from June 1974 table in a string table.
prepareHeader | Prepares header strings for output.
printIndexedEarningsTable | Print out indexed earnings table.
printNameSsn | Prints out name and SSN.
printRealWageGain | Prepares real-wage-gain adjustment in a string table.
pubPenOut | Prepares windfall elimination provision calculation.
rawPiaOut | Prepares raw pro rata PIA in a string table.
setPageNum | Sets page number.
tableHead1 | Prepares table heading for wage-indexed earnings in a string table.
tableHead2 | Prepares table heading for non-indexed earnings in a string table.
totPiaOut | Prepares totalization PIAs in a string table.


Legend

Legend
PiaParams Methods
Legend
Method
virtual
abstract


PiaParams Methods Public Methods

PiaParams Methods Public Methods
PiaParams Methods Legend
Public Methods
Name | Description
applyCola | Returns benefit amount increased by cola.
applyCola99 | Returns benefit amount increased by special 1999 cola (includes extra 0.1 percent increase).
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
applyColaMfb99 | Returns maximum family benefit amount increased by special 1999 cola (includes extra 0.1 percent increase), with check that result is at least 150 percent of pia.
benincCatchUp | Applies catch-up benefit increases.
birthDateFRA | Returns the earliest birthdate for someone to be over NRA at the end of a year.
childAgeForMFCal | Returns oldest age of child for which parent can get young wife/husband or mother/father benefits.
deconvertPia | Deconverts PIA back to year of eligibility.
deemedQcReqCal | Returns number of quarters of coverage required for deemed insured status.
doRecalc | Returns true if should recalculate PIAs this year because of a newly effective law change, else false.
earlyAgeDisWidCal | Returns earliest possible disabled widow(er)'s retirement age.
earlyAgeOabCal | Returns earliest possible retirement age for oab or aged spouse.
earlyAgeOabCalPL | Returns earliest possible retirement age for old-age benie or aged spouse, based on present law.
earlyAgeWidCal | Returns earliest possible aged widow(er)'s retirement age.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedSpouseCalPL | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow(er) benefit before age reduction.
factorAgedWidCalPL | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Returns reduction factor for wife/husband.
factorArAgedSpouseCalPL | Calculates reduction factor for wife/husband. Assumes a maximum of 60 months of reduction.
factorArCal | Returns reduction factor for OAB.
factorArCalPL | Calculates reduction factor for OAB or DIB.
factorArDisWidCal | Calculates reduction factor for disabled widow(er).
factorArWidCal | Calculates reduction factor for aged widow(er).
factorDisWidCal | Returns factor for disabled widow(er) benefit before age reduction.
factorDisWidCalPL | Returns factor for disabled widow/widower benefit before age reduction.
factorDriCal | Calculates delayed retirement increment factor for OAB.
factorYngLifeCal | Calculates reduction factor for young life benie.
factorYngSurvCal | Calculates reduction factor for young survivor.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalDIPL | Returns full retirement age for benefit calculations involving disability freeze.
fullRetAgeCalPL | Returns full retirement age based on present law.
getAverageWage | Returns title of average wage assumptions.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBaseHi | Returns one HI wage base.
getBaseHiArray | Returns the array of HI wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getBendOS | Returns a bend point for old-start PIB formula.
getBenefitInc | Returns title of benefit increase assumptions.
getCatchup | Returns catch-up benefit increases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getChildcareDropoutAmountPL | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getCpiinc | Returns one benefit increase.
getCpiincArray | Returns the array of benefit increases.
getFq | Returns one average wage for indexing.
getFqArray | Returns array of average wages for indexing.
getFqBppia | Returns series used for indexing pia formula bend points.
getFqIndex | Returns series used for indexing an earnings record.
getFqinc | Returns one increase in average wage for indexing.
getFqincArray | Returns array of increases in average wage for indexing.
getIstart | Returns current year.
getMarrLengthForDivBen | Returns the number of years of marraige needed to be eligible for a divroced spouse benefit.
getMarrLengthForDivBenPL | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year.
getMaxChildcareAgePL | Returns maximum age of child for childcare dropout year.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMaxChildcareDropoutYearsPL | Returns maximum number of childcare dropout years.
getMaxyear | Returns maximum possible year.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB.
getMonthBeninc | Returns one month of benefit increase.
getMonthBenincArray | Returns array of months of benefit increase.
getPercOS | Returns old-start PIB formula percentage.
getPercSpecMin | Returns percent of old-law base required for year of coverage.
getPercSpecMinArray | Returns array of percents of old-law base required for year of coverage.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinPerc | Returns percentage of old-law base required for year of coverage.
getSpecMinPia | Returns special minimum pia as of a specified month.
getYocAmountSpecMin | Returns amount required for year of coverage for special minimum.
getYocAmountSpecMinArray | Returns array of amounts required for year of coverage for special minimum.
getYocAmountWindfallArray | Returns array of amounts required for year of coverage for windfall elimination.
initdata | Initializes some data.
isApplicableCola99 | Checks for applicability of special 1999 increase (with extra 0.1 percent).
lastAmw | Finds last AMW in old-law table.
lumpSum | Returns amount of lump sum benefit.
maxChildAge | Returns maximum child beneficiary age.
maxDibAge | Returns maximum DI beneficiary age at end of year.
maxDibAgePL | Returns maximum DI beneficiary age at end of year, based on present law.
monthsArAgedSpouseCal | Calculates number of months of actuarial reduction for aged wife/husband.
monthsArCal | Calculates number of months of actuarial reduction for OAB.
monthsArDICal | Calculates number of months of reduction for disabled worker.
monthsArDisWidCal | Calculates number of months of actuarial reduction for disabled widow(er).
monthsArWidCal | Calculates number of months of actuarial reduction for aged widow(er).
monthsDriCal | Calculates number of months of delayed retirement credit for OAB.
needColaCap | Returns true if a cola cap is required.
percPiaCal | Sets benefit formula percents.
projectCpiinc | Projects amounts dependent on benefit increases.
projectFq | Projects amounts dependent on the average annual wage.
projectPerc | Projects benefit formula percentages.
projectSpecMin | Projects special minimum amounts.
qcCal | Returns number of quarters of coverage for one year, applying annual test.
resizeSpecMin | Resizes special minimum arrays.
retCredit | Returns amount of monthly delayed retirement credit.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
ribLimCalPL | Returns widow(er) benefit reduced for RIB-LIM.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setData | Sets data from historical average wages and benefit increase file.
setHistFqinc | Sets historical average wage increases.
setIstart | Sets the first projected year, including for members.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
setNoChange | Sets indicators for no change allowed.
specMinAmountCal | Sets amount per year of coverage in special minimum.
specMinAmountCalPL | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
specMinMaxYearsPL | Returns maximum number of usable years for special minimum.
unApplyCola | Returns benefit amount decreased by cola.
unApplyCola99 | Returns benefit amount decreased by special 1999 cola (includes extra 0.1 percent decrease.)
unbiCatchUp | Divides out catch-up benefit increases.
updateBases | Updates wage bases.
updateCpiinc | Updates benefit increases.
updateFq | Updates average wages, using specified amounts.
updateFqinc | Updates increases in average wages, using specified percentages.
updateYocAmountSpecMin | Updates amounts required for special minimum year of coverage.


Legend

Legend
PiaParamsAny Methods
Legend
Method


PiaParamsAny Methods Public Methods

PiaParamsAny Methods Public Methods
PiaParamsAny Methods Legend
Public Methods
Name | Description
getWageHigh | Returns high earnings for one year.
getWageHighArray | Returns array of high earnings.
getWageMin | Returns low earnings for one year.
getWageMinArray | Returns array of low earnings.
highProj | Projects high earnings.
minProj | Projects low earnings.
projectFq | Projects average annual wage and amounts dependent on it.


Legend

Legend
PiaParamsLC Methods
Legend
Method
protected


PiaParamsLC Methods Protected Methods

PiaParamsLC Methods Protected Methods
PiaParamsLC Methods Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
setAltCpiinc | Sets benefit increases when changed from present law.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setFqBppia | Sets series of average wages or other series used for indexing pia formula bend points.
setFqIndex | Calculate series of average wages or other series used for indexing an earnings record.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.


PiaParamsLC Methods Public Methods

PiaParamsLC Methods Public Methods
PiaParamsLC Methods Legend
Public Methods
Name | Description
applyCola | Returns benefit amount increased by cola.
applyColaMfb | Returns maximum family benefit amount increased by cola, with check that result is at least 150 percent of pia.
earlyAgeOabCal | Returns earliest possible retirement age for old-age benie or aged spouse.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Calculates reduction factor for wife/husband.
factorArCal | Calculates reduction factor for OAB.
factorDisWidCal | Returns factor for disabled widow/widower benefit before age reduction.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getCpiinc | Returns one benefit increase.
getCpiincArray | Returns the benefit increases.
getFqBppia | Returns series of average wages or other series used for indexing pia formula bend points.
getFqIndex | Returns series of average wages or other series used for indexing an earnings record.
getMarrLengthForDivBen | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year or childcare credit.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB for the given year.
getSpecMinMfb | Returns special minimum mfb as of a specified month.
getSpecMinPia | Returns special minimum pia as of a specified month.
initdata | Initializes some data.
maxDibAge | Returns maximum DI beneficiary age at end of year.
needColaCap | Returns true if a cola cap is required.
projectCpiinc | Projects amounts dependent on benefit increases.
projectFq | Projects average annual wage and amounts dependent on it.
projectPerc | Projects benefit formula percentages.
projectSpecMin | Projects special minimum amounts.
resizeSpecMin | Resizes special minimum arrays.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
setData | Sets data from historical average wages and benefit increase file.
specMinAmountCal | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
updateBases | Updates wage bases.


Legend

Legend
PiaParamsPL Methods
Legend
Method


PiaParamsPL Methods Public Methods

PiaParamsPL Methods Public Methods
PiaParamsPL Methods Legend
Public Methods
Name | Description
earlyAgeOabCal | Sets earliest possible retirement age for old-age benie or aged spouse.
factorAgedSpouseCal | Returns factor for wife/husband benefit before age reduction.
factorAgedWidCal | Returns factor for widow/widower benefit before age reduction.
factorArAgedSpouseCal | Returns reduction factor for wife/husband.
factorArCal | Calculates reduction factor for OAB.
factorDisWidCal | Returns factor for disabled widow/widower benefit before age reduction.
fullRetAgeCal | Returns full retirement age.
fullRetAgeCalDI | Returns full retirement age for benefit calculations involving disability freeze.
getBase77 | Returns one old-law wage base.
getBase77Array | Returns the array of old-law wage bases.
getBaseOasdi | Returns one OASDI wage base.
getBaseOasdiArray | Returns the array of OASDI wage bases.
getChildcareDropoutAmount | Returns maximum amount of earnings in a childcare dropout year.
getColaCap | Returns the amount of the cap on the COLA for the given year.
getFqBppia | Returns series of average wages used for indexing pia formula bend points.
getFqIndex | Returns series of average wages used for indexing an earnings record.
getMarrLengthForDivBen | Returns the number of years of marriage needed to be eligible for a divorced spouse benefit.
getMaxChildcareAge | Returns maximum age of child for childcare dropout year.
getMaxChildcareDropoutYears | Returns maximum number of childcare dropout years.
getMfbColaCap | Returns the amount of the cap on the COLA for the MFB for the given year.
maxDibAge | Returns maximum DI beneficiary age at end of year.
needColaCap | Returns true if a cola cap is required.
projectCpiinc | Projects amounts dependent on benefit increases.
ribLimCal | Returns widow(er) benefit reduced for RIB-LIM.
setColaCap | Sets the amount of the cap on the COLA for the given year.
setData | Sets data from historical average wages and benefit increase file.
setMfbColaCap | Sets the amount of the cap on the COLA for the MFB for the given year.
specMinAmountCal | Returns amount per year of coverage in special minimum.
specMinMaxYears | Returns maximum number of usable years for special minimum.
updateBases | Updates wage bases.


Legend

Legend
PiaParamsTR Methods
Legend
Method


PiaParamsTR Methods Public Methods

PiaParamsTR Methods Public Methods
PiaParamsTR Methods Legend
Public Methods
Name | Description
getAltNum | Returns the Trustees Report assumption.


Legend

Legend
PiaRead Methods
Legend
Method
virtual


PiaRead Methods Public Methods

PiaRead Methods Public Methods
PiaRead Methods Legend
Public Methods
Name | Description
getEarnWidth | Returns width of earnings or base field.
getWidth | Returns width of field for line number in file.
parseAssump | Parses assumption indicators.
parseAw | Parses projected average wage increases.
parseBack | Parses backward projection amounts.
parseBases | Parses up to 20 OASDI wage bases.
parseBases77 | Parses up to 20 old-law wage bases.
parseBendate | Parses date of benefit.
parseBi | Parses up to 20 projected benefit increases.
parseBlind | Parses blind indicator.
parseCatchup | Parses 8 catch-up benefit increases.
parseChildCareYears | Parses annual child care years.
parseDeath | Parses date of death.
parseDeemed | Parses deemed insured indicator.
parseDisab1 | Parses disability information for most recent period.
parseDisab2 | Parses disability information for second most recent period.
parseEarnHi | Parses up to 10 years of Medicare earnings.
parseEarnOasdi | Parses OASDI-covered earnings for up to 10 years.
parseEarnType | Parses type of earnings vector.
parseFamilyMember | Parses family member's information.
parseFwrd | Parses forward projection amounts.
parseMsdates | Parses military service dates.
parseNhaddr | Parses worker's address.
parseNhname | Parses worker's name.
parseOabent | Parses oab entitlement prior to most recent disability.
parsePebes | Parses Social Security Statement information.
parsePubpen | Parses noncovered pension.
parsePubpenReservist | Parses noncovered pension after military reservist pension removal.
parseQc1 | Parses summary quarters of coverage.
parseQc2 | Parses annual quarters of coverage.
parseSsn | Parses Social Security number, sex, and date of birth.
parseTaxType | Parses type of taxes.
parseTitleaw | Parses title of projected average wage increases.
parseTitlebi | Parses title of projected benefit increases.
parseTob | Parses type of benefit and date of entitlement.
parseTotalize | Parses totalization indicator.
parseYears | Parses years of earnings.
read | Reads case from file.
setEarnProjectYears | Sets the years in the EarnProject class.
setEarnWidth | Sets width of earnings or base field.
setPebsData | Sets data for Social Security Statement.
setWidth | Sets width of field for line number in file,


Legend

Legend
PiaReadAny Methods
Legend
Method


PiaReadAny Methods Public Methods

PiaReadAny Methods Public Methods
PiaReadAny Methods Legend
Public Methods
Name | Description
parseBack | Parses backward projection amounts.
parseEarnOasdi | Parses OASDI-covered earnings for up to 10 years.
parseEarnType | Parses type of earnings vector.
parseFwrd | Parses forward projection amounts.
parsePebes | Parses Social Security Statement information.
setEarnProjectYears | Sets the years in the EarnProject class.
setPebsData | Sets data for Social Security Statement.


Legend

Legend
PiaTable1Page Methods
Legend
Method


PiaTable1Page Methods Public Methods

PiaTable1Page Methods Public Methods
PiaTable1Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares pia table strings for printing.


Legend

Legend
PiaTable2Page Methods
Legend
Method


PiaTable2Page Methods Public Methods

PiaTable2Page Methods Public Methods
PiaTable2Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares pia table strings for printing.


Legend

Legend
PiaTable Methods
Legend
Method


PiaTable Methods Public Methods

PiaTable Methods Public Methods
PiaTable Methods Legend
Public Methods
Name | Description
calculate | Computes Pia Table PIA.
isApplicable | Determines applicability of method.


Legend

Legend
PiaTableLC Methods
Legend
Method


PiaTableLC Methods Public Methods

PiaTableLC Methods Public Methods
PiaTableLC Methods Legend
Public Methods
Name | Description
isApplicable | Determines applicability of method.


Legend

Legend
PiaWrite Methods
Legend
Method
virtual


PiaWrite Methods Public Methods

PiaWrite Methods Public Methods
PiaWrite Methods Legend
Public Methods
Name | Description
getEarnWidth | Returns width of earnings or base field.
getNumDecimals | Returns number of decimal places for earnings or base.
getWidth | Returns width of field for line number in file.
setEarnWidth | Sets width of earnings or base field.
setNumDecimals | Sets number of decimal places for earnings or base.
setWidth | Sets width of field for line number in file.
write | Saves a case to disk.
writeAssump | Writes assumption indicators.
writeAw | Writes average wage increase assumptions.
writeBack | Writes backward projection amounts.
writeBases | Writes wage base assumptions.
writeBenDate | Writes date of benefit.
writeBi | Writes benefit increase assumptions.
writeBlind | Writes blind indicator.
writeChildCareYears | Writes annual child care years.
writeDeath | Writes date of death.
writeDeemed | Writes deemed insured indicator.
writeDisab1 | Writes disability information for most recent period.
writeDisab2 | Writes disability information for second most recent period.
writeEarnHi | Writes Medicare earnings.
writeEarnOasdi | Writes OASDI-covered earnings for all years, using unprojected earnings array.
writeEarnType | Writes type of earnings for all years.
writeFamilyMember | Writes information for one family member.
writeFamilyMembers | Writes information for all family members.
writeFwrd | Writes forward projection amounts.
writeMsdates | Writes military service dates.
writeNhaddr | Writes address of worker.
writeNhname | Writes name of worker.
writeOabEnt | Writes oab entitlement prior to most recent dib.
writePebes | Writes pebes information.
writePubpen | Writes noncovered pension.
writePubpenReservist | Writes noncovered pension after military reservist pension removal.
writeQc1 | Writes summary quarters of coverage.
writeQc2 | Writes annual quarters of coverage.
writeRailRoad | Writes railroad earnings and qcs.
writeSsn | Writes Social Security number, sex, and date of birth.
writeTaxType | Writes type of taxes for all years.
writeTob | Writes type of benefit and date of entitlement.
writeTotalize | Writes totalization indicator.
writeYears | Writes years of earnings.


Legend

Legend
PiaWriteAny Methods
Legend
Method


PiaWriteAny Methods Public Methods

PiaWriteAny Methods Public Methods
PiaWriteAny Methods Legend
Public Methods
Name | Description
writeAssump | Writes assumption indicators.
writeBack | Writes backward projection amounts.
writeEarnOasdi | Writes earnings for all years, using projected earnings array.
writeEarnType | Writes type of earnings for all years.
writeFwrd | Writes forward projection amounts.
writePebes | Writes pebes information.


Legend

Legend
Pib50Mfb Methods
Legend
Method


Pib50Mfb Methods Public Methods

Pib50Mfb Methods Public Methods
Pib50Mfb Methods Legend
Public Methods
Name | Description
getAt | Returns 1950 conversion table mfb.


Legend

Legend
Pib50Pib Methods
Legend
Method


Pib50Pib Methods Public Methods

Pib50Pib Methods Public Methods
Pib50Pib Methods Legend
Public Methods
Name | Description
getAt | Returns 1950 conversion table pib.


Legend

Legend
Pib52Ame Methods
Legend
Method


Pib52Ame Methods Public Methods

Pib52Ame Methods Public Methods
Pib52Ame Methods Legend
Public Methods
Name | Description
getAt | Returns 1952 conversion table mfb.


Legend

Legend
Pib52Mfb Methods
Legend
Method


Pib52Mfb Methods Public Methods

Pib52Mfb Methods Public Methods
Pib52Mfb Methods Legend
Public Methods
Name | Description
getAt | Returns 1952 conversion table mfb.


Legend

Legend
Pib54Ame Methods
Legend
Method


Pib54Ame Methods Public Methods

Pib54Ame Methods Public Methods
Pib54Ame Methods Legend
Public Methods
Name | Description
getAt | Returns 1954 conversion table ame.


Legend

Legend
Pib54Mfb Methods
Legend
Method


Pib54Mfb Methods Public Methods

Pib54Mfb Methods Public Methods
Pib54Mfb Methods Legend
Public Methods
Name | Description
getAt | Returns 1954 conversion table mfb.


Legend

Legend
Pib54Pia Methods
Legend
Method


Pib54Pia Methods Public Methods

Pib54Pia Methods Public Methods
Pib54Pia Methods Legend
Public Methods
Name | Description
getAt | Returns 1954 conversion table pia.


Legend

Legend
Pib58Ame Methods
Legend
Method


Pib58Ame Methods Public Methods

Pib58Ame Methods Public Methods
Pib58Ame Methods Legend
Public Methods
Name | Description
getAt | Returns 1958 conversion table ame.


Legend

Legend
Pib58Pib Methods
Legend
Method


Pib58Pib Methods Public Methods

Pib58Pib Methods Public Methods
Pib58Pib Methods Legend
Public Methods
Name | Description
getAt | Returns 1958 conversion table pib.


Legend

Legend
Pifc Methods
Legend
Method


Pifc Methods Public Methods

Pifc Methods Public Methods
Pifc Methods Legend
Public Methods
Name | Description
get | Returns the pifc code.
isColable | Returns true if able to apply cola to this benefit.
isNewMfb | Returns true if wage-indexed mfb applies to this benefit.
pifcCal | Calculates applicable pifc.
set | Sets the pifc code.


Legend

Legend
PortionAime Methods
Legend
Method


PortionAime Methods Public Methods

PortionAime Methods Public Methods
PortionAime Methods Legend
Public Methods
Name | Description
as_array | Returns AIME portions as a simple array.
begin | This is the overview for the begin method overload.
deleteContents | Zeroes out all values.
end | This is the overview for the end method overload.
getNumPart | Returns the number of AIME portions.
max_size | Returns maximum number of AIME portions.
setNumPart | Sets number of AIME portions.
size | Returns number of AIME portions.


Legend

Legend
PresValFacs Methods
Legend
Method


PresValFacs Methods Public Methods

PresValFacs Methods Public Methods
PresValFacs Methods Legend
Public Methods
Name | Description
project | Projects present value factors for the given interest rates.


Legend

Legend
Psa Methods
Legend
Method
protected


Psa Methods Protected Methods

Psa Methods Protected Methods
Psa Methods Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
getAgeIndex | Returns an age converted to an age index.
getLimitedYear | Returns a year converted to a limited year.
getSexType | Returns the sex code to use for annuities for a specified person.
interpolateFactors | Interpolates the JS annuity factors since the input file only has data for every 10th year.


Psa Methods Public Methods

Psa Methods Public Methods
Psa Methods Legend
Public Methods
Name | Description
annuityCal | Calculate an initial psa (monthly) annuity.
annuityRevCal | Calculate the ammount that a person would get if he sold back the specified (monthly) annuity.
contribCal | Calculates contribution to psa for one year, first limiting the earnings to the maximum taxable for the year of contribution.
getAdminFee | Returns the annual administrative fee.
getContribRate | Returns one psa contribution rate for a specified year.
getInvestPerc | Returns percentage of contributions that go into the investment.
getMean | Returns the mean of the normal distribution for bonds.
getMngmtFee | Returns the annual management fee.
getPercToSpouse | Returns percentage of contribution going to spouse, if any.
getStdDev | Returns standard deviation of the normal distribution for specified type.
setParameters | Sets psa parameters from the lawchange file.


Legend

Legend
PunctFacet Methods
Legend
Method


PunctFacet Methods Public Methods

PunctFacet Methods Public Methods
PunctFacet Methods Legend
Public Methods
Name | Description
do_grouping | Returns specification of 3 digits per thousands separator.
getYear | Returns a string representation of the specified year.


Legend

Legend
Qc Methods
Legend
Method


Qc Methods Public Methods

Qc Methods Public Methods
Qc Methods Legend
Public Methods
Name | Description
check | Checks annual quarters of coverage for one year.
qcCal | Returns number of quarters of coverage for one year, applying annual test.


Legend

Legend
Qcamt Methods
Legend
Method


Qcamt Methods Public Methods

Qcamt Methods Public Methods
Qcamt Methods Legend
Public Methods
Name | Description
project | Projects quarter of coverage amounts.


Legend

Legend
QcArray Methods
Legend
Method


QcArray Methods Public Methods

QcArray Methods Public Methods
QcArray Methods Legend
Public Methods
Name | Description
accumulate | Sums quarters of coverage over a period of years or quarters.
assign | Sets values for a specified range of years.
deleteContents | Sets values to zero.
get | Returns the number of quarters of coverage for one year.
getLastYear | Returns the last year of data.
set | Sets the number of quarters of coverage for one year.
toString | Converts a quarters of coverage array to a string.


Legend

Legend
QcPacked Methods
Legend
Method


QcPacked Methods Public Methods

QcPacked Methods Public Methods
QcPacked Methods Legend
Public Methods
Name | Description
get | Return a quarter of coverage amount.
set | Set a quarter of coverage amount.


Legend

Legend
QtrYear Methods
Legend
Method


QtrYear Methods Public Methods

QtrYear Methods Public Methods
QtrYear Methods Legend
Public Methods
Name | Description
add | Adds a quarterly time period to this instance.
check | Checks for valid quarter and year.
deleteContents | Zeroes quarter and year.
diff | Calculates difference of two quarter-year periods as an integer number of quarters.
getQuarter | Returns quarter (0-3).
getYear | Returns year.
qtrCheck | Checks for quarter in bounds.
setQuarter | Sets quarter.
setYear | Sets year.
subtract | Subtracts a quarterly time period from this one.
toDateMoyr | Converts this quarter and year to a month and year.
toString | Returns string representation of quarter and year.
yearCheck | Checks for year in bounds.


Legend

Legend
RailRoadData Methods
Legend
Method


RailRoadData Methods Public Methods

RailRoadData Methods Public Methods
RailRoadData Methods Legend
Public Methods
Name | Description
deleteContents | Zeroes out all railroad data.
get3750String | Returns string of pre-1951 QCs and earnings.
getDecadeEarningsString | Returns string of decade of earnings.
getDecades | Returns number of decades of post-1950 earnings.
getEarn3750 | Returns total earnings 1937 to 1950.
getFirstYear | Returns first year of earnings.
getLastYear | Returns last year of earnings.
getQc3750 | Returns total quarters of coverage 1937 to 1950.
getQcString | Returns string of qcs.
getYearsString | Returns string of first and last years of earnings.
isNonzero | Returns true if there are any railroad earnings.
parse3750 | Parses line of pre-1951 QCs and earnings.
parseEarnings | Parses one line of earnings.
parseQcs | Parses line of qcs.
parseYears | Parses line of first and last years.
railroadYearCheck | Checks the year of railroad earnings.
setEarn3750 | Sets total earnings 1937 to 1950.
setFirstYear | Sets first year of earnings.
setLastYear | Sets last year of earnings.
setQc3750 | Sets total quarters of coverage 1937 to 1950.


Legend

Legend
ReindWid1Page Methods
Legend
Method


ReindWid1Page Methods Public Methods

ReindWid1Page Methods Public Methods
ReindWid1Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares reindexed widow strings for printing.


Legend

Legend
ReindWid2Page Methods
Legend
Method


ReindWid2Page Methods Public Methods

ReindWid2Page Methods Public Methods
ReindWid2Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares reindexed widow strings for printing.


Legend

Legend
ReindWid Methods
Legend
Method


ReindWid Methods Public Methods

ReindWid Methods Public Methods
ReindWid Methods Legend
Public Methods
Name | Description
calculate | Computes reindexed widow PIA.
getEligYear | Returns eligibility year for reindexed widow(er) calculation.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
setEligYear | Sets year of eligibility in reindexed widow guarantee method.


Legend

Legend
ReindWidLC Methods
Legend
Method


ReindWidLC Methods Public Methods

ReindWidLC Methods Public Methods
ReindWidLC Methods Legend
Public Methods
Name | Description
isApplicable | Determines applicability of method.


Legend

Legend
RetireTest Methods
Legend
Method


RetireTest Methods Public Methods

RetireTest Methods Public Methods
RetireTest Methods Legend
Public Methods
Name | Description
earningsTestCal | Returns how many months of person's benefit will be withheld according to the retirement test.
project | Projects all retirement test exempt amounts.


Legend

Legend
Rtea62m Methods
Legend
Method


Rtea62m Methods Public Methods

Rtea62m Methods Public Methods
Rtea62m Methods Legend
Public Methods
Name | Description
getFraction | Returns x in 1-for-x rule for earnings offset.
getHistAmount | Returns historical monthly exempt amount for specified year.
initialize | Initializes historical data.
project | Projects retirement test exempt amounts for ages under full retirement age.


Legend

Legend
Rtea65m Methods
Legend
Method


Rtea65m Methods Public Methods

Rtea65m Methods Public Methods
Rtea65m Methods Legend
Public Methods
Name | Description
getFraction | Returns x in 1-for-x rule for earnings offset.
getHistAmount | Returns historical monthly exempt amount for specified year.
initialize | Initializes historical data.
project | Projects retirement test exempt amounts for ages 65-69.


Legend

Legend
RteaHigh Methods
Legend
Method


RteaHigh Methods Public Methods

RteaHigh Methods Public Methods
RteaHigh Methods Legend
Public Methods
Name | Description
getFraction | Returns x in 1-for-x rule for earnings offset.
initialize | Initializes historical data.


Legend

Legend
RtGeneral Methods
Legend
Method


RtGeneral Methods Public Methods

RtGeneral Methods Public Methods
RtGeneral Methods Legend
Public Methods
Name | Description
convertMonthToAnnual | Converts monthly retirement test exempt amounts to annual amounts.
getMaxAgePL | Returns maximum age for which earnings test applies.
project1 | Calculates a monthly retirement test exempt amount using a base amount and a ratio of average wages.


Legend

Legend
ScaledEarnFactors Methods
Legend
Method


ScaledEarnFactors Methods Public Methods

ScaledEarnFactors Methods Public Methods
ScaledEarnFactors Methods Legend
Public Methods
Name | Description
getAverageEarnFactor | Returns average earner factor for an age.
getDecimals | Returns number of decimal places in output.
getFirstAge | Returns first age.
getHighEarnFactor | Returns high earner factor for an age.
getLastAge | Returns last age.
getLowEarnFactor | Returns low earner factor for an age.
getScaledEarnFactor | Returns a scaled earner factor for an age.
getVeryLowEarnFactor | Returns very low earner factor for an age.
getWidth | Returns width of output.
read | Reads scaled earnings factors from file.
setAverageEarnings | Sets earnings in an EarnProject to average earnings between two ages.
setDecimals | Sets number of decimals in output field.
setHighEarnings | Sets earnings in an EarnProject to high earnings between two ages.
setLowEarnings | Sets earnings in an EarnProject to low earnings between two ages.
setScaledEarnings | Sets earnings in an EarnProject to a particular type of scaled earnings between two ages.
setVeryLowEarnings | Sets earnings in an EarnProject to very low earnings between two ages.
setWidth | Sets width of output field.
write | Writes scaled earnings factors to file.


Legend

Legend
Secondary Methods
Legend
Method


Secondary Methods Public Methods

Secondary Methods Public Methods
Secondary Methods Legend
Public Methods
Name | Description
check | Checks data for validity.
deleteContents | Sets codes to blank or zero.
eligibleForMax | Returns true if this benefit is affected by family maximum.
getArf | Returns reduction or increment factor.
getBenefit | Returns benefit after reduction for family maximum but before actuarial reduction.
getBenefitFactor | Returns benefit factor.
getFullBenefit | Returns full-rate benefit (before actuarial reduction or reduction for family maximum).
getMonthsArdri | Returns months of actuarial reduction or increment.
getReducedBenefit | Returns benefit after actuarial reduction and reduction for family maximum.
getRoundedBenefit | Returns benefit after all reductions and rounding.
isWidow | Returns true if widow (aged or disabled); false otherwise.
setArf | Sets reduction or increment factor.
setBenefit | Sets benefit after reduction for family maximum but before actuarial reduction.
setBenefitFactor | Sets benefit factor.
setFullBenefit | Sets full-rate benefit (before actuarial reduction or reduction for family maximum).
setMonthsArdri | Sets months of actuarial reduction or increment.
setReducedBenefit | Sets benefit after actuarial reduction and reduction for family maximum.
setRoundedBenefit | Sets benefit after all reductions and rounding.


Legend

Legend
SecondaryArray Methods
Legend
Method


SecondaryArray Methods Public Methods

SecondaryArray Methods Public Methods
SecondaryArray Methods Legend
Public Methods
Name | Description
deleteContents | Resets all values to zero.
getTotalFullBenefit | Returns total family benefit before reduction for age or family maximum.
getTotalFullBenefitMax | Returns total family benefit before reduction for age or family maximum, excluding beneficiaries who are not affected by the maximum.


Legend

Legend
Sex Methods
Legend
Method


Sex Methods Public Methods

Sex Methods Public Methods
Sex Methods Legend
Public Methods
Name | Description
check | Checks sex.
toString | Returns an output label for the sex of the person.


Legend

Legend
Sga Methods
Legend
Method


Sga Methods Public Methods

Sga Methods Public Methods
Sga Methods Legend
Public Methods
Name | Description
project | Projects all SGA amounts.


Legend

Legend
SgaBlindA Methods
Legend
Method


SgaBlindA Methods Public Methods

SgaBlindA Methods Public Methods
SgaBlindA Methods Legend
Public Methods
Name | Description
project | Projects SGA amounts.


Legend

Legend
SgaGeneral Methods
Legend
Method
virtual
protected


SgaGeneral Methods Protected Methods

SgaGeneral Methods Protected Methods
SgaGeneral Methods Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
project1 | Calculates a monthly SGA amount using a base amount and a ratio of average wages.


SgaGeneral Methods Public Methods

SgaGeneral Methods Public Methods
SgaGeneral Methods Legend
Public Methods
Name | Description
convertMonthToAnnual | Converts monthly SGA amounts to annual amounts, starting with the first projected year.
project | Projects the SGA monthly amounts.


Legend

Legend
SgaMaxA Methods
Legend
Method


SgaMaxA Methods Public Methods

SgaMaxA Methods Public Methods
SgaMaxA Methods Legend
Public Methods
Name | Description
project | Projects SGA amounts.


Legend

Legend
SgaMinA Methods
Legend
Method


SgaMinA Methods Public Methods

SgaMinA Methods Public Methods
SgaMinA Methods Legend
Public Methods
Name | Description
project | Projects SGA amounts.


Legend

Legend
SgaMinM Methods
Legend
Method


SgaMinM Methods Public Methods

SgaMinM Methods Public Methods
SgaMinM Methods Legend
Public Methods
Name | Description
project | Projects SGA amounts.


Legend

Legend
SpecMin1Page Methods
Legend
Method


SpecMin1Page Methods Public Methods

SpecMin1Page Methods Public Methods
SpecMin1Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares special minimum strings for printing.


Legend

Legend
SpecMin2Page Methods
Legend
Method


SpecMin2Page Methods Public Methods

SpecMin2Page Methods Public Methods
SpecMin2Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares special minimum strings for printing.


Legend

Legend
SpecMin Methods
Legend
Method
virtual


SpecMin Methods Public Methods

SpecMin Methods Public Methods
SpecMin Methods Legend
Public Methods
Name | Description
calculate | Computes special minimum PIA.
getSpecMinAmount | Returns special minimum dollar amount per year of coverage.
getSpecMinYearsExcess | Returns number of years of coverage in special minimum in excess of 10, up to 30.
getYearsTotal | Returns number of years of coverage.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.
setSpecMinAmount | Sets special minimum dollar amount per year of coverage.
setSpecMinYearsExcess | Sets number of years of coverage in special minimum in excess of 10, up to 30.
specMinYearsExcessCal | Limits usable years of coverage.


Legend

Legend
SpecMinLC Methods
Legend
Method


SpecMinLC Methods Public Methods

SpecMinLC Methods Public Methods
SpecMinLC Methods Legend
Public Methods
Name | Description
isApplicable | Determines applicability of method.
specMinYearsExcessCal | Limits usable years of coverage.


Legend

Legend
Ssn Methods
Legend
Method


Ssn Methods Public Methods

Ssn Methods Public Methods
Ssn Methods Legend
Public Methods
Name | Description
deleteContents | Zeroes the three parts.
getPart1 | Returns first part of ssn.
getPart2 | Returns second part of ssn.
getPart3 | Returns third part of ssn.
setPart1 | Sets first part of ssn.
setPart2 | Sets second part of ssn.
setPart3 | Sets third part of ssn.
setSsnFull | Sets the full ssn.
toNumber | Returns ssn converted to a number.
toString | Returns the ssn as a string.
update | Updates full ssn from three parts.


Legend

Legend
Summary1Page Methods
Legend
Method


Summary1Page Methods Public Methods

Summary1Page Methods Public Methods
Summary1Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares top part of summary page.
printDisInfo | Prints disability information.


Legend

Legend
Summary2Page Methods
Legend
Method


Summary2Page Methods Public Methods

Summary2Page Methods Public Methods
Summary2Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares middle part of summary page.


Legend

Legend
Summary3Page Methods
Legend
Method


Summary3Page Methods Public Methods

Summary3Page Methods Public Methods
Summary3Page Methods Legend
Public Methods
Name | Description
bottom3 | Prints bottom of summary.
disclaimer | Prints disclaimer.
nonInsPara | Prints noninsured paragraph.
prepareStrings | Prepares bottom part of summary page.


Legend

Legend
SummaryPage Methods
Legend
Method


SummaryPage Methods Public Methods

SummaryPage Methods Public Methods
SummaryPage Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares the three parts of the summary page.


Legend

Legend
TaxBenefits Methods
Legend
Method
virtual


TaxBenefits Methods Public Methods

TaxBenefits Methods Public Methods
TaxBenefits Methods Legend
Public Methods
Name | Description
deductionsCal | Returns the amount of deductions allowed under the Ball taxation plan.
getProportion | Returns proportion of benefits that are taxable for OASDI.
getThreshold | Returns appropriate OASDI threshold.
taxOasdhi | Returns taxable benefits for OASDHI trust funds.
taxOasdi | Returns taxable benefits for OASDI trust funds.


Legend

Legend
TaxBenefitsLC Methods
Legend
Method
virtual


TaxBenefitsLC Methods Public Methods

TaxBenefitsLC Methods Public Methods
TaxBenefitsLC Methods Legend
Public Methods
Name | Description
deductionsCal | Returns the amount of deductions allowed under the Ball taxation plan.
getProportion | Returns proportion of benefits that are taxable for OASDI.
getThreshold | Returns appropriate threshold.
paymentsCal | Returns number of payments over which contributions are spread for Ball taxation plan.
taxOasdhi | Returns taxable benefits for OASDHI trust funds (same as taxable for OASDI for proposal to tax as for private pension plans).
thresholdsCal | Fills in declining threshold amounts.


Legend

Legend
TaxData Methods
Legend
Method


TaxData Methods Public Methods

TaxData Methods Public Methods
TaxData Methods Legend
Public Methods
Name | Description
getTaxesTotal | Returns total taxes paid for a trust fund type and a period of years.
oasdhiTaxCal | Calculates OASDI and OASDHI taxes paid over a lifetime.
totalTaxCal | Calculates total taxes paid over a lifetime.


Legend

Legend
TaxesPage Methods
Legend
Method


TaxesPage Methods Public Methods

TaxesPage Methods Public Methods
TaxesPage Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares taxes strings for printing.


Legend

Legend
TaxRates Methods
Legend
Method
abstract
protected


TaxRates Methods Protected Methods

TaxRates Methods Protected Methods
TaxRates Methods Legend
Protected Methods
Show:
No members matching the current filter
Name | Description
setCredits | Sets tax credits for one year for employee or employer for all trust funds.
setGrossRates | Sets gross tax rates for all years for employee and employer, for all trust funds.
setNetRates | Sets net tax rates for one year for employee or employer for all trust funds.


TaxRates Methods Public Methods

TaxRates Methods Public Methods
TaxRates Methods Legend
Public Methods
Name | Description
getTaxRatesGross | Returns an array of gross tax rates.
getTaxRatesNet | Returns an array of tax rates, net of any tax credit.
initialize | Initializes all tax rates.
setHistCredits | Sets historical tax credits.
setHistRates | Sets historical tax rates.
taxCalAllYears | Calculates taxes paid over a lifetime, net of any tax credit.
taxCalOneYearGross | Returns taxes paid for one year for one trust fund, including any tax credit.
taxCalOneYearNet | Returns taxes paid for one year for one trust fund, net of any tax credit.


Legend

Legend
TaxRatesLC Methods
Legend
Method


TaxRatesLC Methods Public Methods

TaxRatesLC Methods Public Methods
TaxRatesLC Methods Legend
Public Methods
Name | Description
initialize | Sets all tax rates, using historical rates unless overridden by rates in law change data.


Legend

Legend
TaxRatesPL Methods
Legend
Method


TaxRatesPL Methods Public Methods

TaxRatesPL Methods Public Methods
TaxRatesPL Methods Legend
Public Methods
Name | Description
initialize | Sets all tax rates and credits to stored values.


Legend

Legend
TextWriterTraceListener Methods
Legend
Method


TextWriterTraceListener Methods Public Methods

TextWriterTraceListener Methods Public Methods
TextWriterTraceListener Methods Legend
Public Methods
Name | Description
close | Closes things.
flush | Flushes the output.
write | Writes a string of characters, without a newline, to the designated output.
writeLine | Writes a string of characters, with a newline, to the designated output.


Legend

Legend
Trace Methods
Legend
Method


Trace Methods Public Methods

Trace Methods Public Methods
Trace Methods Legend
Public Methods
Name | Description
close | Close all the TraceListener objects.
flush | Flush all the TraceListener objects.
getListeners | Returns the vector of TraceListener objects.
write | Writes a string of characters, without a newline, to all the TraceListener objects.
writeLine | Writes a string of characters, with a newline, to all the TraceListener objects.


Legend

Legend
TraceListener Methods
Legend
Method
virtual
abstract


TraceListener Methods Public Methods

TraceListener Methods Public Methods
TraceListener Methods Legend
Public Methods
Name | Description
close | Closes this instance.
flush | Flushes the output of this instance.
write | Writes a string of characters, without a newline, to the designated output.
writeLine | Writes a string of characters, with a newline, to the designated output.


Legend

Legend
TransGuar1Page Methods
Legend
Method


TransGuar1Page Methods Public Methods

TransGuar1Page Methods Public Methods
TransGuar1Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares transitional guarantee strings for printing.


Legend

Legend
TransGuar2Page Methods
Legend
Method


TransGuar2Page Methods Public Methods

TransGuar2Page Methods Public Methods
TransGuar2Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares transitional guarantee strings for printing.


Legend

Legend
TransGuar Methods
Legend
Method


TransGuar Methods Public Methods

TransGuar Methods Public Methods
TransGuar Methods Legend
Public Methods
Name | Description
calculate | Computes transitional guarantee PIA.
initialize | Initializes computed values to zero.
isApplicable | Determines applicability of method.


Legend

Legend
TransGuarLC Methods
Legend
Method


TransGuarLC Methods Public Methods

TransGuarLC Methods Public Methods
TransGuarLC Methods Legend
Public Methods
Name | Description
isApplicable | Determines applicability of method.


Legend

Legend
UserAssumptions Methods
Legend
Method


UserAssumptions Methods Public Methods

UserAssumptions Methods Public Methods
UserAssumptions Methods Legend
Public Methods
Name | Description
anscchCheck | Checks catch-up increase indicator.
deleteContents | Initializes all variables.
getAnscch | Returns catch-up benefit increase indicator.
getIaltaw | Returns average wage increase assumption.
getIaltbi | Returns benefit increase assumption.
getIbasch | Returns wage base projection indicator.
getIstart | Returns current year (year after last known benefit increase).
getJaltaw | Returns last average wage increase assumption read in.
getJaltbi | Returns last benefit increase assumption read in.
getJbasch | Returns last wage base projection indicator read in.
istartCheck | Checks current year.
pebsasmCheck | Checks for valid assumption for Statement.
resetTriggers | Resets assumptions triggers.
setAnscch | Sets catch-up increase indicator.
setIaltaw | Sets average wage increase indicator.
setIaltbi | Sets benefit increase indicator.
setIbasch | Sets wage base indicator.
setIstart | Sets current year.
setJaltaw | Sets the previous average wage increase assumption.
setJaltbi | Sets the previous benefit increase assumption.
setJbasch | Sets the previous wage base assumption.
setLastYear | Sets last year of data arrays. Should be called when benefit date is set in WorkerData.
setTitleAw | Sets average wage change assumption title.
setTitleBi | Sets benefit increase assumption title.
zeroJalt | Initializes previous assumptions indicators.


Legend

Legend
WageBaseGeneral Methods
Legend
Method
virtual


WageBaseGeneral Methods Public Methods

WageBaseGeneral Methods Public Methods
WageBaseGeneral Methods Legend
Public Methods
Name | Description
check | Checks a wage base.
earnLimit | Limits earnings to wage base.
project | Projects wage bases.
projectLC | Projects wage bases after a period of ad hoc wage bases.


Legend

Legend
WageBaseLC Methods
Legend
Method


WageBaseLC Methods Public Methods

WageBaseLC Methods Public Methods
WageBaseLC Methods Legend
Public Methods
Name | Description
project | Projects oasdi wage bases with law changes.


Legend

Legend
WageBaseOldLawLC Methods
Legend
Method


WageBaseOldLawLC Methods Public Methods

WageBaseOldLawLC Methods Public Methods
WageBaseOldLawLC Methods Legend
Public Methods
Name | Description
project | Projects 1977 law wage bases with law changes.


Legend

Legend
WageInd1Page Methods
Legend
Method


WageInd1Page Methods Public Methods

WageInd1Page Methods Public Methods
WageInd1Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares wage indexed strings for printing.


Legend

Legend
WageInd2Page Methods
Legend
Method


WageInd2Page Methods Public Methods

WageInd2Page Methods Public Methods
WageInd2Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares wage indexed strings for printing.


Legend

Legend
WageInd Methods
Legend
Method


WageInd Methods Public Methods

WageInd Methods Public Methods
WageInd Methods Legend
Public Methods
Name | Description
calculate | Computes wage indexed PIA.
isApplicable | Determines applicability of method.


Legend

Legend
WageIndGeneral Methods
Legend
Method


WageIndGeneral Methods Public Methods

WageIndGeneral Methods Public Methods
WageIndGeneral Methods Legend
Public Methods
Name | Description
aimepiaCal | Calculates an AIME PIA under the 1977 law.
bendPointCal | Projects bend points.
deconvertAme | Deconverts AIME from raw PIA.
getIndexYearAvgWage | Returns average wage in indexing year.
getWindfall | Returns windfall indicator in wage-indexed method.
getYearsTotal | Returns number of years of coverage for windfall elimination provision.
indexEarnings | Indexes earnings, using specified average wage series.
initialize | Initializes computed values to zero.
realWageGainAdj | Applies real-wage-gain adjustment.
setPortionAime | Calculates portion of aime in each section of pia formula.
setWindfall | Sets windfall indicator in wage-indexed method.
windfallCal | Applies windfall elimination provision for wage-indexed calculation.


Legend

Legend
WageIndLC Methods
Legend
Method


WageIndLC Methods Public Methods

WageIndLC Methods Public Methods
WageIndLC Methods Legend
Public Methods
Name | Description
isApplicable | Determines applicability of method.


Legend

Legend
WageIndNonFreeze1Page Methods
Legend
Method


WageIndNonFreeze1Page Methods Public Methods

WageIndNonFreeze1Page Methods Public Methods
WageIndNonFreeze1Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares wage indexed strings for printing.


Legend

Legend
WageIndNonFreeze2Page Methods
Legend
Method


WageIndNonFreeze2Page Methods Public Methods

WageIndNonFreeze2Page Methods Public Methods
WageIndNonFreeze2Page Methods Legend
Public Methods
Name | Description
prepareStrings | Prepares wage indexed strings for printing.


Legend

Legend
WageIndNonFreeze Methods
Legend
Method


WageIndNonFreeze Methods Public Methods

WageIndNonFreeze Methods Public Methods
WageIndNonFreeze Methods Legend
Public Methods
Name | Description
calculate | Computes wage indexed PIA.
indexEarnings | Indexes earnings, using specified average wage series.
isApplicable | This is the overview for the isApplicable method overload.


Legend

Legend
WorkerData Methods
Legend
Method


WorkerData Methods Public Methods

WorkerData Methods Public Methods
WorkerData Methods Legend
Public Methods
Name | Description
anySelfEmp | Returns true if any self-employed taxes.
deleteContents | Initializes all variables to default values.
deleteOabCessDate | Clears date of OAB cessation prior to most recent DIB.
deleteOabEntDate | Clears date of OAB entitlement prior to most recent DIB entitlement.
deletePubpenDate | Clears date of noncovered pension entitlement.
getEarnHi | Returns Medicare earnings for specified year.
getEarnHiOnly | Returns Medicare earnings for specified year if there are no OASDI earnings; otherwise return zero.
getEarnMS | Returns military service earnings for specified year.
getEarnMS3750 | Returns total military service earnings, 1937-50.
getEarnOasdhi | Returns OASDI plus Medicare earnings for specified year.
getEarnOasdi | Returns OASDI-covered earnings for the specified year.
getEarnRR | Returns railroad earnings for specified year.
getEarnRR3750 | Returns total railroad earnings, 1937-50.
getFirstYearEarn | Returns first year of OASDI earnings (0 if none).
getFirstYearEarnHi | Returns first year of HI earnings (0 if none).
getFirstYearMS | Returns first year of military service (0 if none).
getFirstYearRR | Returns first year of railroad (0 if none).
getIdNumber | Returns Social Security number as a number.
getIdString | Returns Social Security number as a string.
getIndms | Returns military service indicator.
getLastYearEarn | Returns last year of OASDI earnings (0 if none).
getLastYearEarnHi | Returns last year of HI earnings (0 if none).
getLastYearMS | Returns last year of military service (0 if none).
getLastYearRR | Returns last year of military service (0 if none).
getNhaddr | Returns one line of number holder's address.
getNhname | Returns number holder's name.
getOabCessDate | Returns date of cessation of oab entitlement prior to most recent DIB entitlement.
getOabEntDate | Returns date of entitlement to oab prior to most recent DIB entitlement.
getPubpen | Returns monthly noncovered pension.
getPubpenDate | Returns monthly noncovered pension.
getPubpenReservist | Returns monthly noncovered pension after December 1994, after removing reservist pension.
getQcovMS | Returns military service quarters of coverage for specified year.
getQcovMS3750 | Returns total military service quarters of coverage, 1937-50.
getQcovRR | Returns railroad quarters of coverage for specified year.
getQcovRR3750 | Returns total railroad quarters of coverage, 1937-50.
getQcovRR5177 | Returns total railroad quarters of coverage, 1951-77.
getTaxType | Returns type of taxes for specified year.
getTaxTypeArray | Returns array of type of taxes.
pubpenDateCheck2 | Checks the date of noncovered pension entitlement for consistency with date of birth and date of death.
setEarnHi | Sets Medicare earnings for the specified year.
setEarnOasdi | Sets OASDI-covered earnings.
setNhaddr | Sets one line of address.
setNhname | Sets number holder's name.
setOabCessDate | Sets date of cessation of oab prior to most recent dib.
setOabEntDate | Sets date of oab entitlement prior to most recent dib.
setPubpen | Sets amount of monthly noncovered pension.
setPubpenDate | Sets date of noncovered pension entitlement.
setPubpenReservist | Sets amount of monthly noncovered pension after December 1994, after removing military reservist pension.
setTaxType | Sets type of taxes for the specified year.
zeroEarn | Zeroes out earnings and quarters of coverage before first year and after last year of specified earnings.
zeroEarnHi | Zeroes out HI earnings before first year and after last year of specified earnings.
zeroEarnOasdi | Zeroes out OASDI earnings before first year and after last year of specified earnings.


Legend

Legend
WorkerDataArray Methods
Legend
Method


WorkerDataArray Methods Public Methods

WorkerDataArray Methods Public Methods
WorkerDataArray Methods Legend
Public Methods
Name | Description
deleteContents | Resets all values to zero.
famSizeCheck | Checks if family size is ok.
getFamSize | Returns family size (not including worker).
setFamSize | Sets family size (not including worker).


Legend

Legend
WorkerDataGeneral Methods
Legend
Method
abstract
virtual


WorkerDataGeneral Methods Public Methods

WorkerDataGeneral Methods Public Methods
WorkerDataGeneral Methods Legend
Public Methods
Name | Description
anySelfEmp | Returns true if any self-employed taxes.
benefitDate1Check | Checks that date of benefit is in range.
benefitDate2Check | Checks that date of benefit is at or after entitlement.
birth1Check | Checks date of birth in a Statement case.
birth2Check | Checks date of birth in a non-Statement case.
cessation1Check | Checks date of prior disability cessation against date of prior onset.
cessation1OnsetCheck | Checks date of prior disability cessation against date of prior onset.
cessationCheck | Checks date of disability cessation, using stored values.
cessationCheck2 | Checks date of disability cessation, using passed values.
deathCheck | Checks that date of death is after birth.
deathCheck1 | Checks date of death (checks in survivor case for death in 1937 or later).
deathCheck2 | Checks date of death for basic correctness.
deathCheck3 | Checks that date of death is before entitlement, using passed values.
deleteContents | Initializes all variables to default values.
deleteDeathDate | Deletes date of death.
deleteEntDate | Deletes date of entitlement.
dis1Check | Checks date of prior disability onset.
disBirthEntCheck | Checks date of disability onset against dates of birth, entitlement, and benefit.
disCheck | Checks date of disability onset.
disDeathCheck | Checks date of disability onset against date of death.
earningsCheck | Checks for no earnings of any type.
entCheck | Checks that current date of entitlement is within bounds.
firstEarnHiYear | Returns first year of Medicare earnings, if any.
getBenefitDate | Returns date of benefit.
getBirthDate | Returns date of birth of worker.
getBlindind | Returns the blind indicator.
getDeathDate | Returns date of death.
getDeceasedOAB | Returns the deceased OAB indicator.
getDeemedind | Returns the deemed insured indicator.
getEarliestEntDate | Returns earliest entitlement date on this record.
getEarnEnable | Returns true if ok to enable earnings entry dialog box.
getEarnHi | Returns Medicare earnings for specified year.
getEarnHiOnly | Returns Medicare earnings for specified year if there are no OASDI earnings; otherwise return zero.
getEarnMS | Returns military service earnings for specified year.
getEarnMS3750 | Returns total military service earnings, 1937-50.
getEarnOasdhi | Returns OASDI plus Medicare earnings for specified year.
getEarnOasdi | Returns OASDI-covered earnings for the specified year.
getEarnRR | Returns railroad earnings for specified year.
getEarnRR3750 | Returns total railroad earnings, 1937-50.
getEntDate | Returns date of entitlement.
getFirstYearMS | Returns first year of military service (0 if none).
getFirstYearRR | Returns first year of railroad (0 if none).
getIbegin | Returns first year of earnings after any projection.
getIdNumber | Returns Social Security number as a number.
getIdString | Returns Social Security number as a string.
getIend | Returns last year of earnings after any projection.
getIndearn | Returns earnings indicator.
getIndms | Returns military service indicator.
getIndrr | Returns railroad indicator.
getJoasdi | Returns type of benefit calculation, including possibly Statement.
getLastYearMS | Returns last year of military service (0 if none).
getLastYearRR | Returns last year of military service (0 if none).
getMaxyear | Returns maximum year allowed.
getMqge | Returns Medicare-qualified government employment indicator.
getNhaddr | Returns one line of number holder's address.
getNhname | Returns number holder's name.
getOabCessDate | Returns date of cessation of oab entitlement prior to most recent DIB entitlement.
getOabEntDate | Returns date of entitlement to oab prior to most recent DIB entitlement.
getPubpen | Returns monthly noncovered pension.
getPubpenDate | Returns date of entitlement for noncovered pension.
getPubpenReservist | Returns monthly noncovered pension after December 1994, after removing reservist pension.
getQcLumpYear | Returns last year of period for which quarters of coverage are entered as a lump sum.
getQcovMS | Returns military service quarters of coverage for specified year.
getQcovMS3750 | Returns total military service quarters of coverage, 1937-50.
getQcovRR | Returns railroad quarters of coverage for specified year.
getQcovRR3750 | Returns total railroad quarters of coverage, 1937-50.
getQcovRR5177 | Returns total railroad quarters of coverage, 1951-77.
getQctot51td | Returns quarters of coverage from 1951 to 1977.
getQctottd | Returns quarters of coverage from 1937 to 1977.
getRecalc | Returns recalculation code.
getReservist | Returns reservist indicator.
getSex | Returns the sex of the worker.
getTaxType | Returns type of taxes for specified year.
getTotalize | Returns totalization indicator.
getValdi | Returns number of periods of disability.
hasQcsByYear | Returns indicator for QCs prior to 1978 by single year.
ibegin1Check | Checks first year of earnings in a Statement case.
ibegin2Check | Checks first year of earnings in a non-Statement case.
ibeginCheck | Checks for first year of earnings within bounds.
iendCheck | Checks last year of earnings.
isFemale | Return true if person is Sex::sex_type::FEMALE, false otherwise.
isMale | Return true if person is Sex::sex_type::MALE, false otherwise.
isPrimary | Returns primary beneficiary code.
isalive | Returns true if alive at end of year, false otherwise.
isdead | Returns true if dead at end of specified date.
joasdiCheck | Checks type of benefit.
lastQcyr | Returns last year of annual QCs.
needDiCess | Returns true if date of cessation to disability is needed.
needQcsByYear | Returns true if quarters of coverage by year from regular earnings are needed, false otherwise.
need_aw | Returns true if average wage increase assumptions are needed.
need_bases | Returns true if wage base assumptions are needed.
need_bi | Returns true if benefit increase assumptions are needed.
priorent1Check | Checks date of second prior entitlement to disability.
priorentCheck | Checks date of prior entitlement to disability.
pubpenCheck | Checks public pension amount.
pubpenDateCheck | Checks public pension entitlement date.
qc51tdCheck | Checks summary quarters of coverage, 1951 to 1977.
qcCheck | Checks for correct numbers of QC's.
qctdCheck | Checks summary quarters of coverage, 1937 to 1977.
qctdCheck2 | Checks quarters of coverage to 1977 for consistency, assuming both qcs for 1937-1977 and qcs for 1951-1977 have been set to reasonable values.
setBenefitDate | Sets date of benefit.
setBirthDate | Sets date of birth.
setBlindind | Sets blind indicator.
setCessationDate | Sets date of disability cessation.
setCessationMfb | Sets mfb at disability cessation.
setCessationPia | Sets pia at disability cessation.
setDeathDate | Sets date of death.
setDeceasedOAB | Sets deceased OAB indicator.
setDeemedind | Sets deemed insured indicator.
setEarnHi | Sets Medicare earnings for the specified year.
setEarnOasdi | Sets OASDI-covered earnings.
setEntDate | Sets date of entitlement.
setIbegin | Sets first year of earnings, including any projected earnings. Also sets first year of HI earnings (ignored if indicator for HI earnings is not set before attempting to use HI earnings).
setIend | Sets last year of earnings, including any projected earnings.
setIndearn | Sets earnings indicator.
setIndrr | Sets railroad indicator.
setJoasdi | Sets type of benefit.
setMaxyear | Sets maximum year allowed.
setMqge | Sets mqge indicator.
setNhaddr | Sets one line of address.
setNhname | Sets number holder's name.
setOabCessDate | Sets date of cessation of oab prior to most recent dib.
setOabEntDate | Sets date of oab entitlement prior to most recent dib.
setOnsetDate | Sets date of disability onset.
setPebsData | Initializes some Statement data (no disability and no date of death).
setPebsEarn | Sets last year of Statement earnings when computation year changes, or after a Statement calculation has been done.
setPriorentDate | Sets date of entitlement to disability.
setPriorentDateCheck | Sets date of prior entitlement to disability.
setPubpen | Sets amount of monthly noncovered pension.
setPubpenDate | Sets date of monthly noncovered pension entitlement.
setPubpenReservist | Sets amount of monthly noncovered pension after December 1994, after removing military reservist pension.
setQc51td | Sets summary quarters of coverage, 1951 to 1977.
setQcLumpYear | Sets last year of period for which quarters of coverage are entered as a lump sum.
setQcsByYear | Sets indicator for QCs by year prior to 1978.
setQctd | Sets summary quarters of coverage, 1937 to 1977.
setRecalc | Sets recalculation indicator.
setReservist | Sets reservist indicator.
setSex | Sets the sex of the worker.
setTaxType | Sets type of taxes for the specified year.
setTotalize | Sets totalization indicator.
setValdi | Sets number of periods of disability.
setWaitperDate | Sets first month of waiting period.
taxTypeCheck | Checks type of taxes.
valdi1Check | Checks number of periods of disability in nondisability case.
valdi2Check | Checks number of periods of disability in disability case.
valdiCheck | Checks number of periods of disability, using stored value.
waitpd1Check | Checks first month of prior waiting period.
waitpdCheck | Checks first month of waiting period.
zeroEarn | Zeroes out earnings and quarters of coverage before first year and after last year of specified earnings.
zeroEarnHi | Zeroes out HI earnings before first year and after last year of specified earnings.
zeroEarnOasdi | Zeroes out OASDI earnings before first year and after last year of specified earnings.
zeroOasdi | Zeroes out the type of benefit.


BendMfb Nested Types Public Nested Types

BendMfb Nested Types Public Nested Types
BendMfb Nested Types
Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of number of bend points in this array.
value_type | The type of data in this array.


BendPia Nested Types Public Nested Types

BendPia Nested Types Public Nested Types
BendPia Nested Types
Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of size in this array.
value_type | The type of data in this array.


PercMfb Nested Types Public Nested Types

PercMfb Nested Types Public Nested Types
PercMfb Nested Types
Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of size in this array.
value_type | The type of data in this array.


PercPia Nested Types Public Nested Types

PercPia Nested Types Public Nested Types
PercPia Nested Types
Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of size in this array.
value_type | The type of data in this array.


PortionAime Nested Types Public Nested Types

PortionAime Nested Types Public Nested Types
PortionAime Nested Types
Public Nested Types
Name | Description
const_iterator | A const iterator for this array.
const_reference | A const reference for this array.
difference_type | The type of difference in this array.
iterator | An iterator for this array.
reference | A reference for this array.
size_type | The type of size in this array.
value_type | The type of data in this array.


Legend

Legend
Age Operators
Legend
Operator


Legend

Legend
AverageWage Operators
Legend
Operator


Legend

Legend
BendMfb Operators
Legend
Operator


Legend

Legend
BendPia Operators
Legend
Operator


Legend

Legend
BenefitAmount Operators
Legend
Operator


Legend

Legend
BenefitAmountArray Operators
Legend
Operator


Legend

Legend
Bic Operators
Legend
Operator


Legend

Legend
DateMoyr Operators
Legend
Operator


Legend

Legend
DisInsCode Operators
Legend
Operator


Legend

Legend
DisInsCodeArray Operators
Legend
Operator


Legend

Legend
DoubleAnnual Operators
Legend
Operator


Legend

Legend
FloatAnnual Operators
Legend
Operator


Legend

Legend
InsCode Operators
Legend
Operator


Legend

Legend
InsCodeArray Operators
Legend
Operator


Legend

Legend
IntAnnual Operators
Legend
Operator


Legend

Legend
PercMfb Operators
Legend
Operator


Legend

Legend
PercPia Operators
Legend
Operator


Legend

Legend
PiaData Operators
Legend
Operator


Legend

Legend
PortionAime Operators
Legend
Operator


Legend

Legend
QtrYear Operators
Legend
Operator


Legend

Legend
RailRoadData Operators
Legend
Operator


Legend

Legend
Sex Operators
Legend
Operator


Legend

Legend
Ssn Operators
Legend
Operator


Types

Types
Types
Types
Name | Description
BitAnnualData | Bit array used in BitAnnual (a std::bitset).


Variables

Variables
Variables
Variables
Name | Description
MAX_BITSET_SIZE | Size to use for bit array in BitAnnual (from 1937 to 2200).


Variables

Variables
Variables
Variables
Name | Description
BASEYR | Base year for trust fund projection arrays on January 1 basis.
BASEYR1 | Base year for trust fund projection arrays on during-year basis.
DEBUGPID | Value of 999999 is reserved. It means print out for all pid's.
LASTYEARLR | Last year of long-range projection arrays.
LASTYRSR | Last year of short-range projection arrays.
MAXEARN | Maximum annual earnings allowed.
MAXYRS | Maximum number of years of earnings for one individual.
MAXYRSR | Number of years of data in trust fund projections, January 1 basis.
MAXYRSR1 | Number of years of data in trust fund projections, during-year basis.
ORSYR | Base year for ORS trust fund projection data.
YEAR2075 | Last possible year of projection.
YEAR2080 | Last possible year of projection.
YEAR2085 | Last possible year of projection.
YEAR2090 | Last possible year of projection.
YEAR2095 | Last possible year of projection.
YEAR2100 | Last possible year of projection.
YEAR2105 | Last possible year of projection.
YEAR2200 | Last possible year for dates.
YEAR36 | Year before first year of Social Security.
YEAR37 | Base year for many data arrays.
YEAR50 | Year before first year of major revisions to Social Security.
YEAR51 | First year of major revisions to Social Security.
YEAR69 | First year of many OACT projection arrays.
YEAR70 | First year of many OACT projection arrays.
YEAR74 | First year of many OACT projection arrays.
YEAR75 | First year of many OACT projection arrays.
YEAR79 | First year of bend points.


age.h Classes

age.h Classes
age.h Legend
Classes
Name | Description
Age | Manages a year and month age stored as integers.


Legend

Legend
age.h
Legend
Class


AnnualArrays.h Classes

AnnualArrays.h Classes
AnnualArrays.h Legend
Classes
Name | Description
AnnualArrays | Functions using annual arrays.


Legend

Legend
AnnualArrays.h
Legend
Class


AnypiaOut.h Classes

AnypiaOut.h Classes
AnypiaOut.h Legend
Classes
Name | Description
AnypiaOut | Manages all output pages from the Anypia program.


Legend

Legend
AnypiaOut.h
Legend
Class


Assumptions.h Classes

Assumptions.h Classes
Assumptions.h Legend
Classes
Name | Description
Assumptions | Parent of classes that manage the average wage and benefit increase assumptions.


Legend

Legend
Assumptions.h
Legend
Class


AssumptionsFile.h Classes

AssumptionsFile.h Classes
AssumptionsFile.h Legend
Classes
Name | Description
AssumptionsFile | Reads the average wage and benefit increase parameters from disk storage.


Legend

Legend
AssumptionsFile.h
Legend
Class


AssumptionsNonFile.h Classes

AssumptionsNonFile.h Classes
AssumptionsNonFile.h Legend
Classes
Name | Description
AssumptionsNonFile | Contains the average wage and benefit increase assumptions (it does not read from disk).


Legend

Legend
AssumptionsNonFile.h
Legend
Class


AssumptionType.h Classes

AssumptionType.h Classes
AssumptionType.h Legend
Classes
Name | Description
AssumptionType | The assumption types (about future average wage and benefit increases) allowed in the piadata library.


Legend

Legend
AssumptionType.h
Legend
Class


avgwg.h Classes

avgwg.h Classes
avgwg.h Legend
Classes
Name | Description
AverageWage | Manages an array of average wage indexing amounts, or any other earnings series.


Legend

Legend
avgwg.h
Legend
Class


awbidat.h Classes

awbidat.h Classes
awbidat.h Legend
Classes
Name | Description
AwbiData | Manages the historical Social Security parameters.


Legend

Legend
awbidat.h
Legend
Class


AwbiDataFile.h Classes

AwbiDataFile.h Classes
AwbiDataFile.h Legend
Classes
Name | Description
AwbiDataFile | Manages the historical Social Security parameters stored in a file.


Legend

Legend
AwbiDataFile.h
Legend
Class


AwbiDataNonFile.h Classes

AwbiDataNonFile.h Classes
AwbiDataNonFile.h Legend
Classes
Name | Description
AwbiDataNonFile | Manages the historical Social Security parameters stored in arrays in the code.


Legend

Legend
AwbiDataNonFile.h
Legend
Class


awinc.h Classes

awinc.h Classes
awinc.h Legend
Classes
Name | Description
Awinc | Manages a vector of projected average wage increases.


Legend

Legend
awinc.h
Legend
Class


AwincDoc.h Classes

AwincDoc.h Classes
AwincDoc.h Legend
Classes
Name | Description
AwincDoc | Abstract parent of classes that manage the file of projected average wage increases.


Legend

Legend
AwincDoc.h
Legend
Class


AwincFile.h Classes

AwincFile.h Classes
AwincFile.h Legend
Classes
Name | Description
AwincFile | Manages the file of projected average wage increases stored on disk.


Legend

Legend
AwincFile.h
Legend
Class


AwincNonFile.h Classes

AwincNonFile.h Classes
AwincNonFile.h Legend
Classes
Name | Description
AwincNonFile | Manages the file of projected average wage increases stored in static arrays.


Legend

Legend
AwincNonFile.h
Legend
Class


BaseChangeType.h Classes

BaseChangeType.h Classes
BaseChangeType.h Legend
Classes
Name | Description
BaseChangeType | The wage base change types allowed in the piadata library.


Legend

Legend
BaseChangeType.h
Legend
Class


baseyear.h Classes

baseyear.h Classes
baseyear.h Legend
Classes
Name | Description
BaseYear | Parent of classes that manage the computation year for a pia program.


Legend

Legend
baseyear.h
Legend
Class


BaseYearFile.h Classes

BaseYearFile.h Classes
BaseYearFile.h Legend
Classes
Name | Description
BaseYearFile | Manages the computation year for a pia program where it is gotten from disk.


Legend

Legend
BaseYearFile.h
Legend
Class


BaseYearNonFile.h Classes

BaseYearNonFile.h Classes
BaseYearNonFile.h Legend
Classes
Name | Description
BaseYearNonFile | Manages the computation year for a pia program where it is stored with the code.


Legend

Legend
BaseYearNonFile.h
Legend
Class


bendmfb.h Classes

bendmfb.h Classes
bendmfb.h Legend
Classes
Name | Description
BendMfb | Manages the array of bend points used in the MFB formula.


Legend

Legend
bendmfb.h
Legend
Class


bendpia.h Classes

bendpia.h Classes
bendpia.h Legend
Classes
Name | Description
BendPia | Manages the array of bend points used in the PIA formula.


Legend

Legend
bendpia.h
Legend
Class


BenefitAmount.h Classes

BenefitAmount.h Classes
BenefitAmount.h Legend
Classes
Name | Description
BenefitAmount | Represents a benefit amount for one year.


Legend

Legend
BenefitAmount.h
Legend
Class


BenefitAmountArray.h Classes

BenefitAmountArray.h Classes
BenefitAmountArray.h Legend
Classes
Name | Description
BenefitAmountArray | Manages an array of BenefitAmount's.


Legend

Legend
BenefitAmountArray.h
Legend
Class


bic.h Classes

bic.h Classes
bic.h Legend
Classes
Name | Description
Bic | Represents one 2-character bic (Beneficiary Identification code) code.


Legend

Legend
bic.h
Legend
Class


biproj.h Classes

biproj.h Classes
biproj.h Legend
Classes
Name | Description
Biproj | Abstract parent of classes that manage the file of projected benefit increases.


Legend

Legend
biproj.h
Legend
Class


BiprojFile.h Classes

BiprojFile.h Classes
BiprojFile.h Legend
Classes
Name | Description
BiprojFile | Manages the file of projected benefit increases stored on disk.


Legend

Legend
BiprojFile.h
Legend
Class


BiprojNonFile.h Classes

BiprojNonFile.h Classes
BiprojNonFile.h Legend
Classes
Name | Description
BiprojNonFile | Manages the file of projected benefit increases stored in arrays.


Legend

Legend
BiprojNonFile.h
Legend
Class


BitAnnual.h Classes

BitAnnual.h Classes
BitAnnual.h Legend
Classes
Name | Description
BitAnnual | Manages an array of annual bits.


Legend

Legend
BitAnnual.h
Legend
Class


BitAnnualBase.h Types

BitAnnualBase.h Types
BitAnnualBase.h
Types
Name | Description
BitAnnualData | Bit array used in BitAnnual (a std::bitset).


BitAnnualBase.h Variables

BitAnnualBase.h Variables
BitAnnualBase.h
Variables
Name | Description
MAX_BITSET_SIZE | Size to use for bit array in BitAnnual (from 1937 to 2200).


bpmfbout.h Classes

bpmfbout.h Classes
bpmfbout.h Legend
Classes
Name | Description
BpMfbOut | Manages the array of mfb formula bend points.


Legend

Legend
bpmfbout.h
Legend
Class


bppiaout.h Classes

bppiaout.h Classes
bppiaout.h Legend
Classes
Name | Description
BpPiaOut | Manages the array of pia formula bend points.


Legend

Legend
bppiaout.h
Legend
Class


cachup.h Classes

cachup.h Classes
cachup.h Legend
Classes
Name | Description
Catchup | Manages the catch-up benefit increases required to calculate a Social Security benefit.
CatchupIncreases | Manages the catch-up benefit increases for one year of eligibility.


Legend

Legend
cachup.h
Legend
Class


cachupf.h Classes

cachupf.h Classes
cachupf.h Legend
Classes
Name | Description
CatchupDoc | Abstract parent of classes that manage a file of catch-up benefit increases.


Legend

Legend
cachupf.h
Legend
Class


CatchupFile.h Classes

CatchupFile.h Classes
CatchupFile.h Legend
Classes
Name | Description
CatchupFile | Manages a file of catch-up benefit increases stored on disk.


Legend

Legend
CatchupFile.h
Legend
Class


CatchupNonFile.h Classes

CatchupNonFile.h Classes
CatchupNonFile.h Legend
Classes
Name | Description
CatchupNonFile | Manages a file of catch-up benefit increases stored in arrays.


Legend

Legend
CatchupNonFile.h
Legend
Class


ChildCareCalc1Page.h Classes

ChildCareCalc1Page.h Classes
ChildCareCalc1Page.h Legend
Classes
Name | Description
ChildCareCalc1Page | Manages wage indexed earnings from the calculation of a Social Security benefit with child-care dropout years.


Legend

Legend
ChildCareCalc1Page.h
Legend
Class


ChildCareCalc2Page.h Classes

ChildCareCalc2Page.h Classes
ChildCareCalc2Page.h Legend
Classes
Name | Description
ChildCareCalc2Page | Manages wage indexed results with child-care dropout years from the calculation of a Social Security benefit.


Legend

Legend
ChildCareCalc2Page.h
Legend
Class


ChildCareCalc.h Classes

ChildCareCalc.h Classes
ChildCareCalc.h Legend
Classes
Name | Description
ChildCareCalc | Manages the functions required for calculation of a wage indexed Social Security benefit using childcare dropout years.


Legend

Legend
ChildCareCalc.h
Legend
Class


ChildCareCalcLC.h Classes

ChildCareCalcLC.h Classes
ChildCareCalcLC.h Legend
Classes
Name | Description
ChildCareCalcLC | Manages the functions required for calculation of a wage indexed Social Security benefit using childcare dropout years, with law changes.


Legend

Legend
ChildCareCalcLC.h
Legend
Class


comma.h Functions

comma.h Functions
comma.h Legend
Functions
Name | Description
pblank | Inserts blanks or zeroes on the left of a formatted string representing a number.
pcomma | Inserts commas into a formatted string representing a number.


Legend

Legend
comma.h
Legend
Method


CommaBase.h Macros

CommaBase.h Macros
CommaBase.h
Macros
Name | Description
ENDS | No special character for end of ostringstream.
FREEZE | No special function to freeze the string.
OSTREAM | Use ostringstream for formatting output.


comppd.h Classes

comppd.h Classes
comppd.h Legend
Classes
Name | Description
CompPeriod | Manages the number of elapsed years, dropout years, and computation years.


Legend

Legend
comppd.h
Legend
Class


config.h Classes

config.h Classes
config.h Legend
Classes
Name | Description
Config | Parent of classes that manage the configuration information used by the PIA calculation program.


Legend

Legend
config.h
Legend
Class


ConfigFile.h Classes

ConfigFile.h Classes
ConfigFile.h Legend
Classes
Name | Description
ConfigFile | Manages the configuration information used by the PIA calculation program, stored in a file.


Legend

Legend
ConfigFile.h
Legend
Class


ConfigNonFile.h Classes

ConfigNonFile.h Classes
ConfigNonFile.h Legend
Classes
Name | Description
ConfigNonFile | Manages the configuration information used by the PIA calculation program, stored with the code.


Legend

Legend
ConfigNonFile.h
Legend
Class


date.h Classes

date.h Classes
date.h Legend
Classes
Name | Description
Date | Static variables and functions for classes that hold dates.


Legend

Legend
date.h
Legend
Class


DateFormatter.h Classes

DateFormatter.h Classes
DateFormatter.h Legend
Classes
Name | Description
DateFormatter | Manages static functions to format and parse dates.


Legend

Legend
DateFormatter.h
Legend
Class


datemoyr.h Classes

datemoyr.h Classes
datemoyr.h Legend
Classes
Name | Description
DateMoyr | Manages a month and year stored as unsigned integers.


Legend

Legend
datemoyr.h
Legend
Class


dbleann.h Classes

dbleann.h Classes
dbleann.h Legend
Classes
Name | Description
DoubleAnnual | Manages an array of annual doubles.


Legend

Legend
dbleann.h
Legend
Class


dblemth.h Classes

dblemth.h Classes
dblemth.h Legend
Classes
Name | Description
DoubleMonth | Manages an array of monthly doubles.


Legend

Legend
dblemth.h
Legend
Class


dbleqtr.h Classes

dbleqtr.h Classes
dbleqtr.h Legend
Classes
Name | Description
DoubleQuarter | Manages an array of quarterly doubles.


Legend

Legend
dbleqtr.h
Legend
Class


DebugCase.cpp Variables

DebugCase.cpp Variables
DebugCase.cpp
Variables
Name | Description
DEBUGPID | Value of 999999 is reserved. It means print out for all pid's.


DebugCase.h Functions

DebugCase.h Functions
DebugCase.h Legend
Functions
Name | Description
isDebugPid | Returns true if argument person id is the debug pid.


Legend

Legend
DebugCase.h
Legend
Method


DibGuar.h Classes

DibGuar.h Classes
DibGuar.h Legend
Classes
Name | Description
DibGuar | Manages the functions required for calculation of a disability guarantee Social Security benefit.


Legend

Legend
DibGuar.h
Legend
Class


DibGuarLC.h Classes

DibGuarLC.h Classes
DibGuarLC.h Legend
Classes
Name | Description
DibGuarLC | Manages the functions required for calculation of a disability guarantee Social Security benefit with law changes.


Legend

Legend
DibGuarLC.h
Legend
Class


DibGuarPage.h Classes

DibGuarPage.h Classes
DibGuarPage.h Legend
Classes
Name | Description
DibGuarPage | Manages the disability guarantee results from the calculation of a Social Security benefit.


Legend

Legend
DibGuarPage.h
Legend
Class


dinscode.h Classes

dinscode.h Classes
dinscode.h Legend
Classes
Name | Description
DisInsCode | Represents one disability insured status code.


Legend

Legend
dinscode.h
Legend
Class


DisabPeriod.h Classes

DisabPeriod.h Classes
DisabPeriod.h Legend
Classes
Name | Description
DisabPeriod | Manages a period of disability.


Legend

Legend
DisabPeriod.h
Legend
Class


DisInsCodeArray.h Classes

DisInsCodeArray.h Classes
DisInsCodeArray.h Legend
Classes
Name | Description
DisInsCodeArray | Manages an array of annual DisInsCode's.


Legend

Legend
DisInsCodeArray.h
Legend
Class


document.h Classes

document.h Classes
document.h Legend
Classes
Name | Description
Document | Manages a generic document.


Legend

Legend
document.h
Legend
Class


DoubleAnnualRW.h Classes

DoubleAnnualRW.h Classes
DoubleAnnualRW.h Legend
Classes
Name | Description
DoubleAnnualRead | Reads a DoubleAnnual.
DoubleAnnualWrite | Writes a DoubleAnnual.


Legend

Legend
DoubleAnnualRW.h
Legend
Class


EarningsPage.h Classes

EarningsPage.h Classes
EarningsPage.h Legend
Classes
Name | Description
EarningsPage | Manages printing of earnings used in the calculation of a Social Security benefit.


Legend

Legend
EarningsPage.h
Legend
Class


EarnProject.h Classes

EarnProject.h Classes
EarnProject.h Legend
Classes
Name | Description
EarnProject | Manages an array of earnings, with forward and backward projections and specified levels of earnings.


Legend

Legend
EarnProject.h
Legend
Class


FamilyPage.h Classes

FamilyPage.h Classes
FamilyPage.h Legend
Classes
Name | Description
FamilyPage | Manages the results for the auxiliary beneficiaries from the calculation of a Social Security benefit.


Legend

Legend
FamilyPage.h
Legend
Class


FieldOfficeInfoFile.h Classes

FieldOfficeInfoFile.h Classes
FieldOfficeInfoFile.h Legend
Classes
Name | Description
FieldOfficeInfoFile | Reads and writes field office information from and to a file.


Legend

Legend
FieldOfficeInfoFile.h
Legend
Class


FieldOfficeInfoNonFile.h Classes

FieldOfficeInfoNonFile.h Classes
FieldOfficeInfoNonFile.h Legend
Classes
Name | Description
FieldOfficeInfoNonFile | Manages field office information not stored in a file (but its data may be saved in an .ini file).


Legend

Legend
FieldOfficeInfoNonFile.h
Legend
Class


floatann.h Classes

floatann.h Classes
floatann.h Legend
Classes
Name | Description
FloatAnnual | Manages an array of annual floats.


Legend

Legend
floatann.h
Legend
Class


floatmth.h Classes

floatmth.h Classes
floatmth.h Legend
Classes
Name | Description
FloatMonth | Manages an array of monthly floats.


Legend

Legend
floatmth.h
Legend
Class


floatqtr.h Classes

floatqtr.h Classes
floatqtr.h Legend
Classes
Name | Description
FloatQuarter | Manages an array of quarterly floats.


Legend

Legend
floatqtr.h
Legend
Class


foinfo.h Classes

foinfo.h Classes
foinfo.h Legend
Classes
Name | Description
FieldOfficeInfo | Parent of classes that manage the name and address of the field office.


Legend

Legend
foinfo.h
Legend
Class


FormatString.h Functions

FormatString.h Functions
FormatString.h Legend
Functions
Name | Description
AfxFormatString1 | Loads the specified string resource and substitutes for the characters "%1" the string referenced by filler.
AfxFormatString2 | Loads the specified string resource and substitutes for the characters "%1"and "%2" the strings referenced by filler1 and filler2.


Legend

Legend
FormatString.h
Legend
Method


FrozMin.h Classes

FrozMin.h Classes
FrozMin.h Legend
Classes
Name | Description
FrozMin | Manages the functions required for calculation of a frozen minimum Social Security benefit.


Legend

Legend
FrozMin.h
Legend
Class


FrozMinPage.h Classes

FrozMinPage.h Classes
FrozMinPage.h Legend
Classes
Name | Description
FrozMinPage | Manages the frozen minimum results from the calculation of a Social Security benefit.


Legend

Legend
FrozMinPage.h
Legend
Class


frzyrs.h Classes

frzyrs.h Classes
frzyrs.h Legend
Classes
Name | Description
FreezeYears | Manages the years in a freeze period. The years may be wholly or partially within a freeze period.


Legend

Legend
frzyrs.h
Legend
Class


genfile.h Classes

genfile.h Classes
genfile.h Legend
Classes
Name | Description
Genfile | Manages a generic file.


Legend

Legend
genfile.h
Legend
Class


inscode.h Classes

inscode.h Classes
inscode.h Legend
Classes
Name | Description
InsCode | Represents one insured status code.


Legend

Legend
inscode.h
Legend
Class


InsCodeArray.h Classes

InsCodeArray.h Classes
InsCodeArray.h Legend
Classes
Name | Description
InsCodeArray | Manages an array of annual insured status codes.


Legend

Legend
InsCodeArray.h
Legend
Class


InsuredPage.h Classes

InsuredPage.h Classes
InsuredPage.h Legend
Classes
Name | Description
InsuredPage | Manages insured status output determined in the calculation of a Social Security benefit.


Legend

Legend
InsuredPage.h
Legend
Class


intann.h Classes

intann.h Classes
intann.h Legend
Classes
Name | Description
IntAnnual | Manages an array of annual integers.


Legend

Legend
intann.h
Legend
Class


LawChange.h Classes

LawChange.h Classes
LawChange.h Legend
Classes
Name | Description
LawChange | The basic class that manages all of the extra data and functions required for one change in law concerning benefit calculations.


Legend

Legend
LawChange.h
Legend
Class


LawChangeAGE65COMP.h Classes

LawChangeAGE65COMP.h Classes
LawChangeAGE65COMP.h Legend
Classes
Name | Description
LawChangeAGE65COMP | Parameters for a proposal to increase the number of elapsed years in a pia calculation.


Legend

Legend
LawChangeAGE65COMP.h
Legend
Class


LawChangeALLEARN.h Classes

LawChangeALLEARN.h Classes
LawChangeALLEARN.h Legend
Classes
Name | Description
LawChangeALLEARN | Parameters for a proposal to use all years of earnings in an AIME calculation.


Legend

Legend
LawChangeALLEARN.h
Legend
Class


LawChangeArray.h Classes

LawChangeArray.h Classes
LawChangeArray.h Legend
Classes
Name | Description
LawChangeArray | Manages an array of LawChange's.


Legend

Legend
LawChangeArray.h
Legend
Class


LawChangeBPFRACWAGE.h Classes

LawChangeBPFRACWAGE.h Classes
LawChangeBPFRACWAGE.h Legend
Classes
Name | Description
LawChangeBPFRACWAGE | Parameters for a proposal to increase the bend points in the benefit formula by a fraction of average wage growth.


Legend

Legend
LawChangeBPFRACWAGE.h
Legend
Class


LawChangeBPMINCONST.h Classes

LawChangeBPMINCONST.h Classes
LawChangeBPMINCONST.h Legend
Classes
Name | Description
LawChangeBPMINCONST | Parameters for a proposal to increase the bend points in the benefit formula by the growth in wages minus a specified rate.


Legend

Legend
LawChangeBPMINCONST.h
Legend
Class


LawChangeBPSPECRATE.h Classes

LawChangeBPSPECRATE.h Classes
LawChangeBPSPECRATE.h Legend
Classes
Name | Description
LawChangeBPSPECRATE | Parameters for a proposal to increase the bend points in the benefit formula by a specified growth rate.


Legend

Legend
LawChangeBPSPECRATE.h
Legend
Class


LawChangeCHILDCARECREDIT.h Classes

LawChangeCHILDCARECREDIT.h Classes
LawChangeCHILDCARECREDIT.h Legend
Classes
Name | Description
LawChangeCHILDCARECREDIT | Parameters for a proposal to provide child care credits.


Legend

Legend
LawChangeCHILDCARECREDIT.h
Legend
Class


LawChangeCHILDCAREDROPOUT.h Classes

LawChangeCHILDCAREDROPOUT.h Classes
LawChangeCHILDCAREDROPOUT.h Legend
Classes
Name | Description
LawChangeCHILDCAREDROPOUT | Parameters for a proposal to provide child care dropout years.


Legend

Legend
LawChangeCHILDCAREDROPOUT.h
Legend
Class


LawChangeCOLACHANGE.h Classes

LawChangeCOLACHANGE.h Classes
LawChangeCOLACHANGE.h Legend
Classes
Name | Description
LawChangeCOLACHANGE | Parameters for a proposal to change the cost-of-living benefit increases.


Legend

Legend
LawChangeCOLACHANGE.h
Legend
Class


LawChangeDECLINEPERC.h Classes

LawChangeDECLINEPERC.h Classes
LawChangeDECLINEPERC.h Legend
Classes
Name | Description
LawChangeDECLINEPERC | Parameters for a proposal to decrease the benefit formula percentages by a constant rate.


Legend

Legend
LawChangeDECLINEPERC.h
Legend
Class


LawChangeDROPOUTCHG.h Classes

LawChangeDROPOUTCHG.h Classes
LawChangeDROPOUTCHG.h Legend
Classes
Name | Description
LawChangeDROPOUTCHG | Parameters for a proposal to reduce the number of dropout years in a pia calculation.


Legend

Legend
LawChangeDROPOUTCHG.h
Legend
Class


LawChangeMARRLENGTH.h Classes

LawChangeMARRLENGTH.h Classes
LawChangeMARRLENGTH.h Legend
Classes
Name | Description
LawChangeMARRLENGTH | Parameters for a proposal to change the length of marriage requirement for divorced spouse benefits.


Legend

Legend
LawChangeMARRLENGTH.h
Legend
Class


LawChangeNEWFORMULA.h Classes

LawChangeNEWFORMULA.h Classes
LawChangeNEWFORMULA.h Legend
Classes
Name | Description
LawChangeNEWFORMULA | Parameters for a proposal to change the pia formula bend points and/or percentages.


Legend

Legend
LawChangeNEWFORMULA.h
Legend
Class


LawChangeNEWSPECMIN.h Classes

LawChangeNEWSPECMIN.h Classes
LawChangeNEWSPECMIN.h Legend
Classes
Name | Description
LawChangeNEWSPECMIN | Parameters for a proposal to change the special minimum pia calculation.


Legend

Legend
LawChangeNEWSPECMIN.h
Legend
Class


LawChangeNRACHANGE.h Classes

LawChangeNRACHANGE.h Classes
LawChangeNRACHANGE.h Legend
Classes
Name | Description
LawChangeNRACHANGE | Parameters for a proposal to change the full retirement age.


Legend

Legend
LawChangeNRACHANGE.h
Legend
Class


LawChangeOut.h Classes

LawChangeOut.h Classes
LawChangeOut.h Legend
Classes
Name | Description
LawChangeOut | Manages the output file of law change descriptions.


Legend

Legend
LawChangeOut.h
Legend
Class


LawChangePSAACCT.h Classes

LawChangePSAACCT.h Classes
LawChangePSAACCT.h Legend
Classes
Name | Description
LawChangePSAACCT | Parameters for a proposal to introduce individual accounts.


Legend

Legend
LawChangePSAACCT.h
Legend
Class


LawChangeRead.h Classes

LawChangeRead.h Classes
LawChangeRead.h Legend
Classes
Name | Description
LawChangeRead | Reads law changes stored in a file.


Legend

Legend
LawChangeRead.h
Legend
Class


LawChangeTAXBENCHG.h Classes

LawChangeTAXBENCHG.h Classes
LawChangeTAXBENCHG.h Legend
Classes
Name | Description
LawChangeTAXBENCHG | Parameters for a proposal to change the taxation of benefits.


Legend

Legend
LawChangeTAXBENCHG.h
Legend
Class


LawChangeTAXRATECHG.h Classes

LawChangeTAXRATECHG.h Classes
LawChangeTAXRATECHG.h Legend
Classes
Name | Description
LawChangeTAXRATECHG | Parameters for a proposal to change the OASDI tax rates.


Legend

Legend
LawChangeTAXRATECHG.h
Legend
Class


LawChangeWAGEBASECHG.h Classes

LawChangeWAGEBASECHG.h Classes
LawChangeWAGEBASECHG.h Legend
Classes
Name | Description
LawChangeWAGEBASECHG | Parameters for a proposal to change the OASDI and/or old-law wage bases.


Legend

Legend
LawChangeWAGEBASECHG.h
Legend
Class


LawChangeWIDFACTOR.h Classes

LawChangeWIDFACTOR.h Classes
LawChangeWIDFACTOR.h Legend
Classes
Name | Description
LawChangeWIDFACTOR | Parameters for a proposal to change the factor for an aged widow(er) benefit.


Legend

Legend
LawChangeWIDFACTOR.h
Legend
Class


LawChangeWIFEFACTOR.h Classes

LawChangeWIFEFACTOR.h Classes
LawChangeWIFEFACTOR.h Legend
Classes
Name | Description
LawChangeWIFEFACTOR | Parameters for a proposal to change the factor for an aged spouse benefit.


Legend

Legend
LawChangeWIFEFACTOR.h
Legend
Class


LawChangeWrite.h Classes

LawChangeWrite.h Classes
LawChangeWrite.h Legend
Classes
Name | Description
LawChangeWrite | Writes a set of law changes to a file.


Legend

Legend
LawChangeWrite.h
Legend
Class


MilServDatesVec.h Classes

MilServDatesVec.h Classes
MilServDatesVec.h Legend
Classes
Name | Description
MilServDatesVec | Manages all the military service dates records for one ssn.


Legend

Legend
MilServDatesVec.h
Legend
Class


Legend

Legend
Misc Library
Legend
Class
Structure
Method


Topics

Topics
Misc Library
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Types | The following table lists types in this documentation.
Variables | The following table lists variables in this documentation.
Macros | The following table lists macros in this documentation.
Files | The following table lists files in this documentation.


msdates.h Classes

msdates.h Classes
msdates.h Legend
Classes
Name | Description
MilServDates | Manages one period of military service dates.


Legend

Legend
msdates.h
Legend
Class


Legend

Legend
NumPunct.h
Legend
Structure


NumPunct.h Structures

NumPunct.h Structures
NumPunct.h Legend
Structures
Name | Description
PunctFacet | Numeric punctuation facet with 3 digits per thousands separator.


oactcnst.h Variables

oactcnst.h Variables
oactcnst.h
Variables
Name | Description
BASEYR | Base year for trust fund projection arrays on January 1 basis.
BASEYR1 | Base year for trust fund projection arrays on during-year basis.
LASTYEARLR | Last year of long-range projection arrays.
LASTYRSR | Last year of short-range projection arrays.
MAXEARN | Maximum annual earnings allowed.
MAXYRS | Maximum number of years of earnings for one individual.
MAXYRSR | Number of years of data in trust fund projections, January 1 basis.
MAXYRSR1 | Number of years of data in trust fund projections, during-year basis.
ORSYR | Base year for ORS trust fund projection data.
YEAR2075 | Last possible year of projection.
YEAR2080 | Last possible year of projection.
YEAR2085 | Last possible year of projection.
YEAR2090 | Last possible year of projection.
YEAR2095 | Last possible year of projection.
YEAR2100 | Last possible year of projection.
YEAR2105 | Last possible year of projection.
YEAR2200 | Last possible year for dates.
YEAR36 | Year before first year of Social Security.
YEAR37 | Base year for many data arrays.
YEAR50 | Year before first year of major revisions to Social Security.
YEAR51 | First year of major revisions to Social Security.
YEAR69 | First year of many OACT projection arrays.
YEAR70 | First year of many OACT projection arrays.
YEAR74 | First year of many OACT projection arrays.
YEAR75 | First year of many OACT projection arrays.
YEAR79 | First year of bend points.


OldPia.h Classes

OldPia.h Classes
OldPia.h Legend
Classes
Name | Description
OldPia | Parent of all methods using pia tables in the calculation of a Social Security benefit.


Legend

Legend
OldPia.h
Legend
Class


OldStart1Page.h Classes

OldStart1Page.h Classes
OldStart1Page.h Legend
Classes
Name | Description
OldStart1Page | Manages old start earnings output from the calculation of a Social Security benefit.


Legend

Legend
OldStart1Page.h
Legend
Class


OldStart2Page.h Classes

OldStart2Page.h Classes
OldStart2Page.h Legend
Classes
Name | Description
OldStart2Page | Manages old start results from the calculation of a Social Security benefit.


Legend

Legend
OldStart2Page.h
Legend
Class


OldStart.h Classes

OldStart.h Classes
OldStart.h Legend
Classes
Name | Description
OldStart | Manages the functions required for calculation of an old start Social Security benefit.


Legend

Legend
OldStart.h
Legend
Class


OldStartLC.h Classes

OldStartLC.h Classes
OldStartLC.h Legend
Classes
Name | Description
OldStartLC | Manages the functions required for calculation of an old start Social Security benefit with law changes.


Legend

Legend
OldStartLC.h
Legend
Class


OnePage.h Classes

OnePage.h Classes
OnePage.h Legend
Classes
Name | Description
OnePage | Manages one-page summary of results from the calculation of a Social Security benefit.


Legend

Legend
OnePage.h
Legend
Class


OutDC.cpp Macros

OutDC.cpp Macros
OutDC.cpp
Macros
Name | Description
_AFXDLL | Use the AFXDLL library, which contains MFC in a DLL.


OutDC.h Classes

OutDC.h Classes
OutDC.h Legend
Classes
Name | Description
OutDC80 | Handles output to a Windows window.


Legend

Legend
OutDC.h
Legend
Class


OutFile80.h Classes

OutFile80.h Classes
OutFile80.h Legend
Classes
Name | Description
OutFile80 | Manages the print output functions, when printing to a file formatted for 80 columns.


Legend

Legend
OutFile80.h
Legend
Class


OutFile132.h Classes

OutFile132.h Classes
OutFile132.h Legend
Classes
Name | Description
OutFile132 | Manages the print output functions, when printing to a file formatted for 132 columns.


Legend

Legend
OutFile132.h
Legend
Class


outfile.h Classes

outfile.h Classes
outfile.h Legend
Classes
Name | Description
Out132 | An Outfile tailored for 132-column output.
Out80 | An Outfile tailored for 80-column output.
Outfile | Abstract parent of classes to manage an output file in runstreams with multiple programs.


Legend

Legend
outfile.h
Legend
Class


OutfileHTML.h Classes

OutfileHTML.h Classes
OutfileHTML.h Legend
Classes
Name | Description
OutFileHTML | Manages the print output functions, when printing to an HTML file.


Legend

Legend
OutfileHTML.h
Legend
Class


page.h Classes

page.h Classes
page.h Legend
Classes
Name | Description
PageCounters | Manages a vector of page counters.


Legend

Legend
page.h
Legend
Class


PageOut.h Classes

PageOut.h Classes
PageOut.h Legend
Classes
Name | Description
PageOut | Abstract parent of classes to manage a page of printed output.


Legend

Legend
PageOut.h
Legend
Class


Path.h Classes

Path.h Classes
Path.h Legend
Classes
Name | Description
Path | Provides operations on string instances that contain file or directory path information.


Legend

Legend
Path.h
Legend
Class


pebs.h Classes

pebs.h Classes
pebs.h Legend
Classes
Name | Description
Pebs | Manages most of the data required to prepare and print out the results of a Statement calculation.


Legend

Legend
pebs.h
Legend
Class


PebsCreditInfo.h Classes

PebsCreditInfo.h Classes
PebsCreditInfo.h Legend
Classes
Name | Description
PebsCreditInfo | Manages the Social Security Statement credit info page.


Legend

Legend
PebsCreditInfo.h
Legend
Class


PebsEarnings.h Classes

PebsEarnings.h Classes
PebsEarnings.h Legend
Classes
Name | Description
PebsEarnings | Manages the Social Security Statement earnings page.


Legend

Legend
PebsEarnings.h
Legend
Class


PebsEarningsInfo.h Classes

PebsEarningsInfo.h Classes
PebsEarningsInfo.h Legend
Classes
Name | Description
PebsEarningsInfo | Manages the Social Security Statement earnings info page.


Legend

Legend
PebsEarningsInfo.h
Legend
Class


PebsLetter.h Classes

PebsLetter.h Classes
PebsLetter.h Legend
Classes
Name | Description
PebsLetter | Manages the Social Security Statement letter page.


Legend

Legend
PebsLetter.h
Legend
Class


PebsOasdiEst.h Classes

PebsOasdiEst.h Classes
PebsOasdiEst.h Legend
Classes
Name | Description
PebsOasdiEst | Manages the Social Security Statement oasdi estimates page.


Legend

Legend
PebsOasdiEst.h
Legend
Class


PebsOasdiInfo.h Classes

PebsOasdiInfo.h Classes
PebsOasdiInfo.h Legend
Classes
Name | Description
PebsOasdiInfo | Manages the Social Security Statement oasdi benefit info page.


Legend

Legend
PebsOasdiInfo.h
Legend
Class


PebsOut.h Classes

PebsOut.h Classes
PebsOut.h Legend
Classes
Name | Description
PebsOut | Manages the printing of the results of a Social Security Statement calculation.


Legend

Legend
PebsOut.h
Legend
Class


PebsPageOut.h Classes

PebsPageOut.h Classes
PebsPageOut.h Legend
Classes
Name | Description
PebsPageOut | Parent of classes that manage a page of Social Security Statement output.


Legend

Legend
PebsPageOut.h
Legend
Class


PebsWorkerEarnings.h Classes

PebsWorkerEarnings.h Classes
PebsWorkerEarnings.h Legend
Classes
Name | Description
PebsWorkerEarnings | Manages the Social Security Statement worker info and earnings info page.


Legend

Legend
PebsWorkerEarnings.h
Legend
Class


PebsWorkerInfo.h Classes

PebsWorkerInfo.h Classes
PebsWorkerInfo.h Legend
Classes
Name | Description
PebsWorkerInfo | Manages the Social Security Statement worker info page.


Legend

Legend
PebsWorkerInfo.h
Legend
Class


percmfb.h Classes

percmfb.h Classes
percmfb.h Legend
Classes
Name | Description
PercMfb | Manages the array of percentages used in the MFB formula.


Legend

Legend
percmfb.h
Legend
Class


percpia.h Classes

percpia.h Classes
percpia.h Legend
Classes
Name | Description
PercPia | Manages the array of percentages used in the PIA formula.


Legend

Legend
percpia.h
Legend
Class


PercPiaOut.h Classes

PercPiaOut.h Classes
PercPiaOut.h Legend
Classes
Name | Description
PercPiaOut | Manages the array of pia formula percentages, projected for all years.


Legend

Legend
PercPiaOut.h
Legend
Class


piacal.h Classes

piacal.h Classes
piacal.h Legend
Classes
Name | Description
PiaCal | Parent of all classes that manage the functions required for calculation of a Social Security benefit.


Legend

Legend
piacal.h
Legend
Class


PiaCalAny.h Classes

PiaCalAny.h Classes
PiaCalAny.h Legend
Classes
Name | Description
PiaCalAny | Manages the additional functions required for calculation of a Social Security benefit in the Anypia program.


Legend

Legend
PiaCalAny.h
Legend
Class


PiaCalLC.h Classes

PiaCalLC.h Classes
PiaCalLC.h Legend
Classes
Name | Description
PiaCalLC | Manages all of the law-change functions required for calculation of a Social Security benefit.


Legend

Legend
PiaCalLC.h
Legend
Class


PiaCalPL.h Classes

PiaCalPL.h Classes
PiaCalPL.h Legend
Classes
Name | Description
PiaCalPL | Manages all of the present law functions required for calculation of a Social Security benefit.


Legend

Legend
PiaCalPL.h
Legend
Class


piadata.h Classes

piadata.h Classes
piadata.h Legend
Classes
Name | Description
PiaData | Manages all of the worker-specific amounts calculated in preparation for and during the calculation of a Social Security benefit.


Legend

Legend
piadata.h
Legend
Class


Legend

Legend
PiaData Library
Legend
Class
Method


Topics

Topics
PiaData Library
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Functions | The following table lists functions in this documentation.
Variables | The following table lists variables in this documentation.
Files | The following table lists files in this documentation.


PiadataArray.h Classes

PiadataArray.h Classes
PiadataArray.h Legend
Classes
Name | Description
PiaDataArray | Manages an array of PiaData's, representing one family.


Legend

Legend
PiadataArray.h
Legend
Class


PiaException.h Classes

PiaException.h Classes
PiaException.h Legend
Classes
Name | Description
PiaException | Manages an exception in the piadata library.


Legend

Legend
PiaException.h
Legend
Class


PiaMethod.h Classes

PiaMethod.h Classes
PiaMethod.h Legend
Classes
Name | Description
PiaMethod | Parent of the various methods required for calculation of a Social Security benefit.


Legend

Legend
PiaMethod.h
Legend
Class


PiaOut.h Classes

PiaOut.h Classes
PiaOut.h Legend
Classes
Name | Description
PiaOut | >Manages the printing of the results of a Social Security non-Statement calculation.


Legend

Legend
PiaOut.h
Legend
Class


Legend

Legend
PiaOut Library
Legend
Class


Topics

Topics
PiaOut Library
Topics
Name | Description
Classes | The following table lists classes in this documentation.
Files | The following table lists files in this documentation.


PiaPageOut.h Classes

PiaPageOut.h Classes
PiaPageOut.h Legend
Classes
Name | Description
PiaPageOut | Parent of classes that manage a page of output from the calculation of a non-Statement Social Security benefit.


Legend

Legend
PiaPageOut.h
Legend
Class


PiaParamsLCTR.h Classes

PiaParamsLCTR.h Classes
PiaParamsLCTR.h Legend
Classes
Name | Description
PiaParamsLCTR | Manages the changed law Social Security parameters, already projected based on a Trustees Report assumption.


Legend

Legend
PiaParamsLCTR.h
Legend
Class


PiaParamsTR.h Classes

PiaParamsTR.h Classes
PiaParamsTR.h Legend
Classes
Name | Description
PiaParamsTR | Manages the present law Social Security parameters required to calculate Social Security benefits, with projected values set to Trustees Report assumptions.


Legend

Legend
PiaParamsTR.h
Legend
Class


piaparms.h Classes

piaparms.h Classes
piaparms.h Legend
Classes
Name | Description
PiaParams | Abstract parent of classes to manage the Social Security parameters required to calculate a Social Security benefit.


Legend

Legend
piaparms.h
Legend
Class


piaparmsAny.h Classes

piaparmsAny.h Classes
piaparmsAny.h Legend
Classes
Name | Description
PiaParamsAny | Manages the additional Social Security parameters required to calculate Social Security benefits in the Anypia program.


Legend

Legend
piaparmsAny.h
Legend
Class


piaparmsLC.h Classes

piaparmsLC.h Classes
piaparmsLC.h Legend
Classes
Name | Description
PiaParamsLC | Manages the changed law Social Security parameters required to calculate Social Security benefits.


Legend

Legend
piaparmsLC.h
Legend
Class


piaparmsPL.h Classes

piaparmsPL.h Classes
piaparmsPL.h Legend
Classes
Name | Description
PiaParamsPL | Manages the present law Social Security parameters required to calculate Social Security benefits.


Legend

Legend
piaparmsPL.h
Legend
Class


piaread.h Classes

piaread.h Classes
piaread.h Legend
Classes
Name | Description
PiaRead | Reads the basic data required to calculate a Social Security benefit.


Legend

Legend
piaread.h
Legend
Class


piareadAny.h Classes

piareadAny.h Classes
piareadAny.h Legend
Classes
Name | Description
PiaReadAny | Reads the data required to calculate a Social Security benefit for the Anypia program.


Legend

Legend
piareadAny.h
Legend
Class


PiaTable1Page.h Classes

PiaTable1Page.h Classes
PiaTable1Page.h Legend
Classes
Name | Description
PiaTable1Page | Manages the pia table calculation earnings page from the calculation of a Social Security benefit.


Legend

Legend
PiaTable1Page.h
Legend
Class


PiaTable2Page.h Classes

PiaTable2Page.h Classes
PiaTable2Page.h Legend
Classes
Name | Description
PiaTable2Page | Manages the pia table calculation results page from the calculation of a Social Security benefit.


Legend

Legend
PiaTable2Page.h
Legend
Class


PiaTable.h Classes

PiaTable.h Classes
PiaTable.h Legend
Classes
Name | Description
PiaTable | Manages the functions required for calculation of a Pia Table Social Security benefit.


Legend

Legend
PiaTable.h
Legend
Class


PiaTableLC.h Classes

PiaTableLC.h Classes
PiaTableLC.h Legend
Classes
Name | Description
PiaTableLC | Manages the functions required for calculation of a Pia Table Social Security benefit, including changes from present law.


Legend

Legend
PiaTableLC.h
Legend
Class


piawrite.h Classes

piawrite.h Classes
piawrite.h Legend
Classes
Name | Description
PiaWrite | Writes out the basic data required to calculate a Social Security benefit.


Legend

Legend
piawrite.h
Legend
Class


piawriteAny.h Classes

piawriteAny.h Classes
piawriteAny.h Legend
Classes
Name | Description
PiaWriteAny | Writes out the data required to calculate a Social Security benefit for the Anypia program.


Legend

Legend
piawriteAny.h
Legend
Class


pibtable.h Classes

pibtable.h Classes
pibtable.h Legend
Classes
Name | Description
Pib50Mfb | Manages the 1950 pib-mfb conversion figures.
Pib50Pib | Manages the 1950 pib-pia conversion figures.
Pib52Ame | Manages the 1952 pib-ame conversion figures.
Pib52Mfb | Manages the 1952 pib-mfb conversion figures.
Pib54Ame | Manages the 1954 pib-ame conversion figures.
Pib54Mfb | Manages the 1954 pib-mfb conversion figures.
Pib54Pia | Manages the 1954 pib-pia conversion figures.
Pib58Ame | Manages the 1958 pib-ame conversion figures.
Pib58Pib | Manages the 1958 pib-pia conversion figures.


Legend

Legend
pibtable.h
Legend
Class


Pifc.h Classes

Pifc.h Classes
Pifc.h Legend
Classes
Name | Description
Pifc | Represents a pia factor code (type of Social Security pia).


Legend

Legend
Pifc.h
Legend
Class


PortionAime.h Classes

PortionAime.h Classes
PortionAime.h Legend
Classes
Name | Description
PortionAime | Manages the array of portions of AIME in the PIA formula.


Legend

Legend
PortionAime.h
Legend
Class


PresValFacs.h Classes

PresValFacs.h Classes
PresValFacs.h Legend
Classes
Name | Description
PresValFacs | Manages an array of present value factors.


Legend

Legend
PresValFacs.h
Legend
Class


Psa.h Classes

Psa.h Classes
Psa.h Legend
Classes
Name | Description
Psa | Manages the (theoretical) PSA accounts.


Legend

Legend
Psa.h
Legend
Class


qc.h Classes

qc.h Classes
qc.h Legend
Classes
Name | Description
Qc | Handles calculations with quarters of coverage for one year.


Legend

Legend
qc.h
Legend
Class


qcamt.h Classes

qcamt.h Classes
qcamt.h Legend
Classes
Name | Description
Qcamt | Manages an array of quarter of coverage amounts.


Legend

Legend
qcamt.h
Legend
Class


QcArray.h Classes

QcArray.h Classes
QcArray.h Legend
Classes
Name | Description
QcArray | Manages an array of annual quarters of coverage.


Legend

Legend
QcArray.h
Legend
Class


QcPacked.h Classes

QcPacked.h Classes
QcPacked.h Legend
Classes
Name | Description
QcPacked | Holds 8 annual quarters of coverage amounts in one word (4 bytes). Each value is in 4 bits, and can take values from 0 to 4.


Legend

Legend
QcPacked.h
Legend
Class


qtryear.h Classes

qtryear.h Classes
qtryear.h Legend
Classes
Name | Description
QtrYear | Manages a year and quarter stored as unsigned integers.


Legend

Legend
qtryear.h
Legend
Class


railroad.h Classes

railroad.h Classes
railroad.h Legend
Classes
Name | Description
RailRoadData | Manages the railroad data for one worker.


Legend

Legend
railroad.h
Legend
Class


ReindWid1Page.h Classes

ReindWid1Page.h Classes
ReindWid1Page.h Legend
Classes
Name | Description
ReindWid1Page | Manages a re-indexed widow earnings page from the calculation of a Social Security benefit.


Legend

Legend
ReindWid1Page.h
Legend
Class


ReindWid2Page.h Classes

ReindWid2Page.h Classes
ReindWid2Page.h Legend
Classes
Name | Description
ReindWid2Page | Manages a re-indexed widow calculation results page from the calculation of a Social Security benefit.


Legend

Legend
ReindWid2Page.h
Legend
Class


ReindWid.h Classes

ReindWid.h Classes
ReindWid.h Legend
Classes
Name | Description
ReindWid | Manages the functions required for calculation of a reindexed widow(er) Social Security benefit.


Legend

Legend
ReindWid.h
Legend
Class


ReindWidLC.h Classes

ReindWidLC.h Classes
ReindWidLC.h Legend
Classes
Name | Description
ReindWidLC | Manages the functions required for calculation of a reindexed widow(er) Social Security benefit with law changes.


Legend

Legend
ReindWidLC.h
Legend
Class


Resource.h Macros

Resource.h Macros
Resource.h
Macros
Name | Description
PIA_IDS_2YEARS | (Currently unused.)
PIA_IDS_ACTQCOUT | String ID for printing actual quarters of coverage.
PIA_IDS_AGEMONTH | Type of PiaException thrown if number of months in an Age is greater than 11.
PIA_IDS_AGEPLAN | Type of PiaException thrown if planned age of retirement is out of range.
PIA_IDS_AIMEOUT | String ID for printing AIME.
PIA_IDS_AMEOUT | String ID for printing AMW.
PIA_IDS_ANDLATER | (Currently unused.)
PIA_IDS_ANSCCH | Type of PiaException thrown if catch-up increase indicator is out of range.
PIA_IDS_APPCOLA1 | Type of PiaException thrown if year is out of range in PiaParams::applyCola without catch-up.
PIA_IDS_APPCOLA2 | Type of PiaException thrown if year is out of range in PiaParams::applyCola with catch-up.
PIA_IDS_APPCOLA3 | Type of PiaException thrown if year is out of range in PiaParams::applyColaMfb without catch-up.
PIA_IDS_APPCOLA4 | Type of PiaException thrown if year is out of range in PiaParams::applyColaMfb with catch-up.
PIA_IDS_ARDRI1 | Type of PiaException thrown if age is out of range in PiaCal::ardriCal.
PIA_IDS_ARDRI10 | Type of PiaException thrown if aged wife age is before early retirement age in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI2 | Type of PiaException thrown if age is before early retirement age for OAB in PiaCal::ardriCal.
PIA_IDS_ARDRI3 | (Currently unused.)
PIA_IDS_ARDRI4 | Type of PiaException thrown if disabled widow(er) age is before earliest possible age in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI5 | Type of PiaException thrown if disabled widow(er) entitlement is before benefit date in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI6 | Type of PiaException thrown if aged widow(er) age is before earliest possible age in PiaCal::ardriAuxCal.
PIA_IDS_ARDRI7 | Type of PiaException thrown if DIB entitlement before 1957 in PiaCal::ardriCal.
PIA_IDS_ARDRI8 | Type of PiaException thrown if age under 50 for DIB before 1960 in PiaCal::ardriCal.
PIA_IDS_ARDRI9 | Type of PiaException thrown if age over full retirement age for DIB in PiaCal::ardriCal.
PIA_IDS_ARFFOUT | String ID for printing actuarial reduction factor.
PIA_IDS_ARFMOUT | String ID for printing months of actuarial reduction.
PIA_IDS_ATODOUBLE | (Currently unused).
PIA_IDS_ATOFLOAT | (Currently unused).
PIA_IDS_ATOINT | (Currently unused).
PIA_IDS_ATOLONG | (Currently unused).
PIA_IDS_AVERAGETEXT | (Currently unused.)
PIA_IDS_AVGWG | Type of PiaException thrown if year is out of range in an AverageWage function.
PIA_IDS_AVGWGTTL | (Currently unused.)
PIA_IDS_AWASSUM | (Currently unused.)
PIA_IDS_AWBI1 | Type of PiaException thrown if unable to open input file in AwbiDataFile::read.
PIA_IDS_AWBI2 | Type of PiaException thrown if unable to open output file in AwbiDataFile::write.
PIA_IDS_AWBI3 | Type of PiaException thrown if unable to read all required data in AwbiDataFile::read.
PIA_IDS_AWBIDAT1 | Type of PiaException thrown if last year of historical data is too large in AwbiDataNonFile::setData.
PIA_IDS_AWOUT | String ID for printing average wage assumptions.
PIA_IDS_BASE1 | Type of PiaException thrown if first year is out of range in WageBaseGeneral::project.
PIA_IDS_BASE2 | Type of PiaException thrown if wage base is out of range.
PIA_IDS_BASECH | Type of PiaException thrown if wage base indicator is not 1 or 2.
PIA_IDS_BASEYR1 | Type of PiaException thrown if base year is out of range (1979-2020).
PIA_IDS_BASEYR2 | Type of PiaException thrown if unable to open output file in BaseYearFile::write.
PIA_IDS_BASEYR3 | Type of PiaException thrown if unable to read base year in BaseYearFile::read.
PIA_IDS_BASEYR4 | Type of PiaException thrown if unable to open input file in BaseYearFile::read.
PIA_IDS_BEGIN1 | Type of PiaException thrown if first year of earnings is out of range.
PIA_IDS_BEGIN2 | Type of PiaException thrown if last year of earnings is before first year of earnings in backward projection period.
PIA_IDS_BEGIN3 | Type of PiaException thrown if first year of earnings is before 1937.
PIA_IDS_BEGIN4 | Type of PiaException thrown if first year of earnings is in starting year of projections or later, in a Statement case.
PIA_IDS_BEGIN5 | Type of PiaException thrown if first year of earnings is after maximum year allowed, in a non-Statement case.
PIA_IDS_BEGIN6 | Type of PiaException thrown if there are no regular, railroad, or military earnings.
PIA_IDS_BEN1OUT | String ID for printing benefit before rounding.
PIA_IDS_BEN2OUT | String ID for printing benefit after rounding.
PIA_IDS_BENARRAY1 | Type of PiaException thrown if year is out of range in BenefitAmountArray functions.
PIA_IDS_BENARRAY2 | Type of PiaException thrown if year is out of range in BenefitAmountArray::[].
PIA_IDS_BENDATE1 | Type of PiaException thrown if benefit date is before entitlement date.
PIA_IDS_BENDATE2 | Type of PiaException thrown if month of benefit is out of range.
PIA_IDS_BENDATE3 | Type of PiaException thrown if year of benefit is before 1940.
PIA_IDS_BENDATE4 | Type of PiaException thrown if year of benefit is after maximum allowed.
PIA_IDS_BENDATE5 | (Currently unused.)
PIA_IDS_BENDATE6 | Type of PiaException thrown if secondary entitlement after benefit date.
PIA_IDS_BENFOUT | String ID for printing secondary benefit factor.
PIA_IDS_BIASSUM | (Currently unused.)
PIA_IDS_BICCHP | Type of PiaException thrown if year is out of range in Catchup functions.
PIA_IDS_BIOUT | String ID for printing benefit increase assumptions.
PIA_IDS_BIPROJTTL | (Currently unused.)
PIA_IDS_BIRTH1 | Type of PiaException thrown if year of birth is in current year or later (in Statement case).
PIA_IDS_BIRTH2 | Type of PiaException thrown if year of birth is before 1800.
PIA_IDS_BIRTH3 | Type of PiaException thrown if month of birth is out of range.
PIA_IDS_BIRTH4 | Type of PiaException thrown if day of birth is out of range.
PIA_IDS_BIRTH5 | Type of PiaException thrown if year of birth is after maximum allowed.
PIA_IDS_BIRTH6 | (Currently unused.)
PIA_IDS_BITANN1 | Type of PiaException thrown if year is out of range in BitAnnual functions.
PIA_IDS_CACHUP1 | Type of PiaException thrown if catch-up benefit increase is out of range.
PIA_IDS_CACHUP2 | Type of PiaException thrown if unable to open input file in CatchupFile::read.
PIA_IDS_CACHUP3 | Type of PiaException thrown if unable to open output file in CatchupFile::write.
PIA_IDS_CACHUP4 | Type of PiaException thrown if year is out of range in a Catchup function.
PIA_IDS_CESS2OUT | String ID for printing second prior date of cessation.
PIA_IDS_COMMA | Type of PiaException thrown if number of decimals is nonzero for other than a float type in pout.
PIA_IDS_CONFIG1 | Type of PiaException thrown if unable to open input file in ConfigFile::read.
PIA_IDS_CONFIG5 | Type of PiaException thrown if unable to open output file in ConfigFile::write.
PIA_IDS_CONFIG6 | Type of PiaException thrown if unable to read all required data in ConfigFile::read.
PIA_IDS_CPIINC1 | Type of PiaException thrown if benefit increase is out of range.
PIA_IDS_CPIINC2 | Type of PiaException thrown if unable to open output file in BiprojFile::write.
PIA_IDS_CPIINC3 | Type of PiaException thrown if unable to read all required data in BiprojFile::read.
PIA_IDS_CPIINC4 | Type of PiaException thrown if unable to open input file in BiprojFile::read.
PIA_IDS_CUPROJTTL | (Currently unused.)
PIA_IDS_CURINSOUT | String ID for printing currently insured status in survivor case.
PIA_IDS_DATEDAY | Type of PiaException thrown if day in a date is out of range.
PIA_IDS_DATEDIFF | Type of PiaException thrown if unable to difference two dates.
PIA_IDS_DATEMONTH | Type of PiaException thrown if month in a date is out of range.
PIA_IDS_DATEREAD | Type of PiaException thrown if unable to parse string into a date.
PIA_IDS_DATEYEAR | Type of PiaException thrown if year in a date is out of range.
PIA_IDS_DBLEANN1 | (Currently unused).
PIA_IDS_DBLEANN2 | Type of PiaException thrown if unable to read specified years in DoubleAnnualRead::read.
PIA_IDS_DEATH1 | Type of PiaException thrown if month of death is out of range.
PIA_IDS_DEATH2 | Type of PiaException thrown if year of death is after maximum allowed.
PIA_IDS_DEATH3 | Type of PiaException thrown if death before 1937 in a survivor case.
PIA_IDS_DEATH4 | Type of PiaException thrown if entitlement of survivor is before death of worker.
PIA_IDS_DEATH5 | Type of PiaException thrown if death of worker is before birth.
PIA_IDS_DEATH6 | (Currently unused.)
PIA_IDS_DEATHOUT | String ID for printing date of death.
PIA_IDS_DIBENTOUT | String ID for printing DIB date of entitlement.
PIA_IDS_DICESS1 | Type of PiaException thrown if month of cessation is out of range.
PIA_IDS_DICESS2 | Type of PiaException thrown if year of cessation is before 1937.
PIA_IDS_DICESS3 | Type of PiaException thrown if year of cessation is after maximum allowed.
PIA_IDS_DICESS4 | Type of PiaException thrown if disability cessation before onset.
PIA_IDS_DICESS5 | Type of PiaException thrown if prior disability cessation after second entitlement.
PIA_IDS_DICESS6 | Type of PiaException thrown if entitlement is before cessation.
PIA_IDS_DICESS7 | Type of PiaException thrown if cessation is after death in a survivor case.
PIA_IDS_DICESS8 | (Currently unused.)
PIA_IDS_DINS1OUT | String ID for printing first part of disability insured status.
PIA_IDS_DINS2OUT | String ID for printing second part of disability insured status.
PIA_IDS_DINS3OUT | String ID for printing third part of disability insured status.
PIA_IDS_DISREQCAL1 | Type of PiaException thrown if year in most recent freeze period is out of range in PiaData::qcDisReqCal.
PIA_IDS_DISREQCAL2 | Type of PiaException thrown if year in next most recent freeze period is out of range in PiaData::qcDisReqCal.
PIA_IDS_DOBOUT | String ID for printing date of birth.
PIA_IDS_DOBWIDOUT | String ID for printing date of birth of widow(er).
PIA_IDS_DRCFOUT | String ID for printing delayed retirement credit factor.
PIA_IDS_DRCMOUT | String ID for printing months of delayed retirement credit.
PIA_IDS_EARNHI | Type of PiaException thrown if Medicare earnings are out of range.
PIA_IDS_EARNMAL | Type of PiaException thrown if year is before 1937 in EarnProject::toString.
PIA_IDS_EARNPEBS | Type of PiaException thrown if OASDI earnings are out of range.
PIA_IDS_EARNPROJ | Type of PiaException thrown if projection year is out of range in EarnProject::project.
PIA_IDS_EARNTYPE | Type of PiaException thrown if type of earnings is out of range.
PIA_IDS_EARNTYPE1 | Type of PiaException thrown if projection year is out of range in PiaWrite::writeEarnType.
PIA_IDS_EARNTYPEYR | Type of PiaException thrown if year is out of range in EarnProject::setEarntype.
PIA_IDS_ELAPSOUT | String ID for printing elapsed years.
PIA_IDS_END1 | Type of PiaException thrown if last year of earnings is before 1937.
PIA_IDS_END2 | Type of PiaException thrown if last year of earnings is after maximum year allowed.
PIA_IDS_END3 | Type of PiaException thrown if first year of earnings in forward projection period is after last year of earnings in forward projection period.
PIA_IDS_END4 | Type of PiaException thrown if the total number of years of earnings is greater than the maximum allowed (MAXYRS).
PIA_IDS_ENT1 | Type of PiaException thrown if month of entitlement is out of range.
PIA_IDS_ENT2 | Type of PiaException thrown if year of entitlement is before 1940.
PIA_IDS_ENT3 | Type of PiaException thrown if year of entitlement is after maximum allowed.
PIA_IDS_ENT4 | (Currently unused.)
PIA_IDS_ERNLIMOUT | String ID for printing earnings over maximum allowed.
PIA_IDS_FAMSIZE | Type of PiaException thrown if family size is out of bounds.
PIA_IDS_FLOATANN1 | (Currently unused).
PIA_IDS_FLOATANN2 | (Currently unused).
PIA_IDS_FLOATMTH1 | Type of PiaException thrown if years are out of range in a FloatMonth function.
PIA_IDS_FLOATMTH2 | Type of PiaException thrown if unable to read specified years in FloatMonth::read.
PIA_IDS_FLOATMTH3 | Type of PiaException thrown if quarter is out of range in a FloatMonth function.
PIA_IDS_FLOATQTR1 | Type of PiaException thrown if years are out of range in a FloatQuarter function.
PIA_IDS_FLOATQTR2 | Type of PiaException thrown if unable to read specified years in FloatQuarter::read.
PIA_IDS_FLOATQTR3 | Type of PiaException thrown if quarter is out of range in a FloatQuarter function.
PIA_IDS_FLOATQTR4 | Type of PiaException thrown if data value is zero in a FloatQuarter divide function.
PIA_IDS_FMSTRING | Type of PiaException thrown if error in FrozMinPage::prepareStrings.
PIA_IDS_FOINFO1 | Type of PiaException thrown if unable to open input file in FieldOfficeInfoFile::read.
PIA_IDS_FOINFO2 | Type of PiaException thrown if unable to read all required data in FieldOfficeInfoFile::read.
PIA_IDS_FOINFO3 | Type of PiaException thrown if unable to open output file in FieldOfficeInfoFile::write.
PIA_IDS_FQINC1 | Type of PiaException thrown if average wage increase is out of range.
PIA_IDS_FQINC2 | Type of PiaException thrown if unable to open output file in AwincFile::write.
PIA_IDS_FQINC3 | Type of PiaException thrown if unable to read all required data in AwincFile::read.
PIA_IDS_FQINC4 | Type of PiaException thrown if unable to open input file in AwincFile::read.
PIA_IDS_FULLBEN | String ID for printing full secondary benefit.
PIA_IDS_GENFILE1 | Type of PiaException thrown if unable to open a Genfile for output.
PIA_IDS_GENFILE2 | Type of PiaException thrown if unable to open a Genfile for appended output.
PIA_IDS_GENFILE3 | Type of PiaException thrown if unable to open a Genfile for input.
PIA_IDS_HIGHTEXT | (Currently unused.)
PIA_IDS_HISTAMTTL | (Currently unused.)
PIA_IDS_HISTAMTUPDATE | (Currently unused.)
PIA_IDS_IALTAW1 | Type of PiaException thrown if average wage increase indicator is out of range in general case.
PIA_IDS_IALTAW2 | Type of PiaException thrown if average wage increase indicator is out of range in Statement case.
PIA_IDS_IALTBI1 | Type of PiaException thrown if benefit increase indicator is out of range in general case.
PIA_IDS_IALTBI2 | Type of PiaException thrown if benefit increase indicator is out of range in Statement case.
PIA_IDS_INSTATOUT | String ID for printing insured status.
PIA_IDS_INSUREOUT | String ID for printing fully insured for totalization benefits.
PIA_IDS_INTANN1 | (Currently unused).
PIA_IDS_INTANN2 | (Currently unused).
PIA_IDS_JBIRTH1 | (Currently unused.)
PIA_IDS_JBIRTH2 | (Currently unused.)
PIA_IDS_JBIRTH3 | (Currently unused.)
PIA_IDS_JBIRTH4 | (Currently unused.)
PIA_IDS_JBIRTH5 | (Currently unused.)
PIA_IDS_JOASDI | Type of PiaException thrown if type of benefit is out of range.
PIA_IDS_JONSET1 | (Currently unused.)
PIA_IDS_JONSET2 | (Currently unused.)
PIA_IDS_JONSET3 | (Currently unused.)
PIA_IDS_JONSET4 | (Currently unused.)
PIA_IDS_JONSET5 | Type of PiaException thrown if widow's disability is before birth.
PIA_IDS_JONSET6 | Type of PiaException thrown if widow's disability is after entitlement.
PIA_IDS_JONSET7 | (Currently unused.)
PIA_IDS_JSURV | Type of PiaException thrown if bic is not a valid life or survivor bic.
PIA_IDS_JSURVOUT | String ID for printing type of survivor.
PIA_IDS_LAWCHG1 | Type of PiaException thrown if starting year of law changes is out of range.
PIA_IDS_LAWCHG2 | Type of PiaException thrown if law change wage increase proportion is out of range.
PIA_IDS_LAWCHG3 | Type of PiaException thrown if law change benefit formula percentage is out of range.
PIA_IDS_LAWCHG4 | Type of PiaException thrown if law change bend point is out of range.
PIA_IDS_LAWCHG5 | Type of PiaException thrown if law change constant decline percentage is out of range.
PIA_IDS_LAWCHG6 | Type of PiaException thrown if unable to parse input line in LawChangeRead::read.
PIA_IDS_LAWCHG7 | Type of PiaException thrown if unable to open input file in LawChangeRead::read.
PIA_IDS_LAWCHG8 | Type of PiaException thrown if unable to open output file in LawChangeWrite::write.
PIA_IDS_LAWCHG9 | Type of PiaException thrown if type of law change is out of range.
PIA_IDS_LOWTEXT | (Currently unused.)
PIA_IDS_MAXIMUMTEXT | (Currently unused.)
PIA_IDS_METHOD | Type of PiaException thrown if years are inconsistent in PiaMethod::totalEarnCal.
PIA_IDS_MFBBEN | String ID for printing maximum family benefit.
PIA_IDS_MFBLOUT | String ID for printing MFB at eligibility.
PIA_IDS_MFBOUT | String ID for printing MFB.
PIA_IDS_MILSERV1 | Type of PiaException thrown if military service starting date is after ending date.
PIA_IDS_MILSERV2 | Type of PiaException thrown if number of military service periods is out of range in general case.
PIA_IDS_MILSERV3 | Type of PiaException thrown if number of military service periods is out of range in military service case.
PIA_IDS_MILSERV4 | Type of PiaException thrown if military service starting date is out of range.
PIA_IDS_MILSERV5 | Type of PiaException thrown if military service ending date is out of range.
PIA_IDS_MILSERV6 | Type of PiaException thrown if years are out of range in MilServDates::getQc3750.
PIA_IDS_MILSERV7 | Type of PiaException thrown if years are out of range in MilServDates::getEarn3750.
PIA_IDS_MODTC | Type of PiaException thrown if moddata is in error.
PIA_IDS_MONTHTEXT | (Currently unused).
PIA_IDS_NAMEOUT | String ID for printing worker's name.
PIA_IDS_NDISINOUT | String ID for printing not disability insured.
PIA_IDS_NEEDAW | (Currently unused).
PIA_IDS_NEEDBASES | Type of PiaException thrown if year is out of range in WorkerDataGeneral::need_bases.
PIA_IDS_NEEDBI | (Currently unused).
PIA_IDS_NINSTOUT | String ID for printing not insured in survivor case.
PIA_IDS_NINSUROUT | String ID for printing not fully insured.
PIA_IDS_NONPENDATE1 | Type of PiaException thrown if noncovered pension entitlement date is before birth.
PIA_IDS_NONPENDATE2 | Type of PiaException thrown if noncovered pension entitlement date is after death.
PIA_IDS_NONPENDATE3 | Type of PiaException thrown if noncovered pension entitlement date entry is invalid.
PIA_IDS_NONPENDATEOUT | String ID for printing noncovered pension entitlement date.
PIA_IDS_NONPENOUT | String ID for printing noncovered pension.
PIA_IDS_NRA1OUT | String ID for printing early retirement age.
PIA_IDS_NRAOUT | String ID for printing full retirement age.
PIA_IDS_NRAWIDOUT | String ID for printing widow(er)'s full retirement age.
PIA_IDS_NRAWIFEOUT | String ID for printing full retirement age of aged wife/husband.
PIA_IDS_NTOTALOUT | String ID for printing not insured for totalization benefits.
PIA_IDS_OABBENOUT | String ID for printing OAB date of benefit.
PIA_IDS_OABENTOUT | String ID for printing OAB date of entitlement.
PIA_IDS_OLDSTART1 | Type of PiaException thrown if date of entitlement is out of range in OldStart::calculate.
PIA_IDS_OLDSTART2 | Type of PiaException thrown if old start method number is out of range.
PIA_IDS_ONEPAGE | Type of PiaException thrown if error in OnePage::prepareStrings.
PIA_IDS_ONSET1 | Type of PiaException thrown if month of onset is out of range.
PIA_IDS_ONSET10 | (Currently unused.)
PIA_IDS_ONSET11 | Type of PiaException thrown if disability onset is after full retirement age.
PIA_IDS_ONSET2 | Type of PiaException thrown if day of onset is out of range.
PIA_IDS_ONSET2OUT | String ID for printing second prior date of onset.
PIA_IDS_ONSET3 | Type of PiaException thrown if year of onset is before 1937.
PIA_IDS_ONSET4 | Type of PiaException thrown if year of onset is after maximum allowed.
PIA_IDS_ONSET5 | Type of PiaException thrown if disability is before birth.
PIA_IDS_ONSET6 | Type of PiaException thrown if disability is after entitlement.
PIA_IDS_ONSET7 | Type of PiaException thrown if death of worker is before disability onset in a survivor case.
PIA_IDS_ONSET8 | Type of PiaException thrown if prior disability is after current disability.
PIA_IDS_ONSET9 | (Currently unused.)
PIA_IDS_ONSETOUT | String ID for printing date of onset.
PIA_IDS_OPENERR | (Currently unused.)
PIA_IDS_OSRANGE1 | (Currently unused.)
PIA_IDS_OSRANGE2 | (Currently unused.)
PIA_IDS_OSSTRING | Type of PiaException thrown if error in OldStart1Page::prepareStrings.
PIA_IDS_OUTFILE | (Currently unused.)
PIA_IDS_PEBESMONTH | Type of PiaException thrown if month of Statement processing is out of range.
PIA_IDS_PEBSASM | Type of PiaException thrown if benefit increase indicator or average wage increase indicator is out of range in Statement case.
PIA_IDS_PERCBACK | Type of PiaException thrown if backward projection percentage is out of range.
PIA_IDS_PERCFWRD | Type of PiaException thrown if forward projection percentage is out of range.
PIA_IDS_PIACALPLRGE | (Currently unused.)
PIA_IDS_PIACALRANGE | (Currently unused.)
PIA_IDS_PIALOUT | String ID for printing PIA at eligibility.
PIA_IDS_PIAOUT | String ID for printing PIA.
PIA_IDS_PIATABLE1 | Type of PiaException thrown if year of entitlement is out of range in PiaTable::calculate.
PIA_IDS_PIATABLE2 | Type of PiaException thrown if year of benefit is out of range in PiaTable::calculate.
PIA_IDS_PIB50MFB | Type of PiaException thrown if index is out of range in Pib50Mfb::getAt.
PIA_IDS_PIB50PIB | Type of PiaException thrown if index is out of range in Pib50Pib::getAt.
PIA_IDS_PIB52MFB | Type of PiaException thrown if index is out of range in Pib52Mfb::getAt.
PIA_IDS_PIB54MFB | Type of PiaException thrown if index is out of range in Pib54Mfb::getAt.
PIA_IDS_PIB54PIA | Type of PiaException thrown if index is out of range in Pib54Pia::getAt.
PIA_IDS_PIB58AME | Type of PiaException thrown if index is out of range in Pib58Ame::getAt.
PIA_IDS_PIB58PIB | Type of PiaException thrown if index is out of range in Pib58Pib::getAt.
PIA_IDS_PIBTABLE1 | (Currently unused.)
PIA_IDS_PIBTABLE2 | (Currently unused.)
PIA_IDS_PONSETOUT | String ID for printing second prior date of onset in nondisability case.
PIA_IDS_PRCESSOUT | String ID for printing prior date of cessation.
PIA_IDS_PRENTOUT | String ID for printing date of prior entitlement in nondisability case.
PIA_IDS_PRIOROUT | String ID for printing prior date of entitlement in disability case.
PIA_IDS_PROBASOUT | String ID for printing projected wage base type.
PIA_IDS_PROJBACK1 | Type of PiaException thrown if backward projection indicator is out of range in general case (0-2).
PIA_IDS_PROJBACK2 | Type of PiaException thrown if backward projection indicator is out of range in backward projection case (1-2).
PIA_IDS_PROJFWRD1 | Type of PiaException thrown if forward projection indicator is out of range in general case (0-2).
PIA_IDS_PROJFWRD2 | Type of PiaException thrown if forward projection indicator is out of range in forward projection case (1-2).
PIA_IDS_PRRENT1 | Type of PiaException thrown if month of prior entitlement is out of range.
PIA_IDS_PRRENT2 | Type of PiaException thrown if year of prior entitlement is before 1940.
PIA_IDS_PRRENT3 | Type of PiaException thrown if year of prior entitlement is after maximum allowed.
PIA_IDS_PRRENT4 | Type of PiaException thrown if prior entitlement is not before current entitlement.
PIA_IDS_PRRENT5 | Type of PiaException thrown if prior entitlement to disability is before disability onset.
PIA_IDS_PRRENT6 | (Currently unused.)
PIA_IDS_PRRENT7 | Type of PiaException thrown if prior entitlement to disability is after full retirement age.
PIA_IDS_PTSTRING | Type of PiaException thrown if error in PiaTable1Page::prepareStrings.
PIA_IDS_PUBPEN | Type of PiaException thrown if public pension amount is out of range.
PIA_IDS_QC | Type of PiaException thrown if number of quarters of coverage, 1951-77, is greater than number of quarters of coverage, 1937-77.
PIA_IDS_QC51TD | Type of PiaException thrown if number of quarters of coverage, 1951-77, is out of range.
PIA_IDS_QCAMT | Type of PiaException thrown if average wages have not been set in Qcamt::project.
PIA_IDS_QCANN | Type of PiaException thrown if number of annual quarters of coverage is out of range.
PIA_IDS_QCARRAY1 | Type of PiaException thrown if year is out of range in QcArray functions.
PIA_IDS_QCARRAY2 | (Currently unused).
PIA_IDS_QCARRAY3 | Type of PiaException thrown if years are out of range in QcArray::accumulate.
PIA_IDS_QCARRAY4 | Type of PiaException thrown if quarters are out of range in QcArray::accumulate.
PIA_IDS_QCCAL | Type of PiaException thrown if quarter of coverage amount has not been set in PiaData::qcCal.
PIA_IDS_QCDISCAL | Type of PiaException thrown if any starting or ending dates are out of range in PiaData::qcDisCal.
PIA_IDS_QCLUMPYEAR | Type of PiaException thrown if qclumpyear is out of range.
PIA_IDS_QCPACKED1 | Type of PiaException thrown if index is out of range in QcPacked::get.
PIA_IDS_QCPACKED2 | Type of PiaException thrown if index is out of range in QcPacked::set.
PIA_IDS_QCTD | Type of PiaException thrown if number of quarters of coverage, 1937-77, is out of range.
PIA_IDS_QCTOT0 | Type of PiaException thrown if no quarters of coverage in a totalization case.
PIA_IDS_QTRYRQTR | Type of PiaException thrown if number of quarters in a QtrYear is greater than 3.
PIA_IDS_QTRYRYR | Type of PiaException thrown if year in a QtrYear is greater than LASTYEARLR.
PIA_IDS_READEOF | Return value from PiaRead::read if successful read, with end of file following.
PIA_IDS_READERR | Type of PiaException thrown if unable to read a pia file.
PIA_IDS_READMORE | Return value from PiaRead::read if successful read, with additional data following.
PIA_IDS_RELERNOUT | String ID for printing relative earnings level.
PIA_IDS_RELERNPOS | Type of PiaException thrown if first year is out of range in PiaCal::relEarnPositionCal.
PIA_IDS_REQQCOUT | String ID for printing required quarters of coverage.
PIA_IDS_REVIEWBI | (Currently unused.)
PIA_IDS_ROUND | Type of PiaException thrown if year is before 1937 in BenefitAmount functions.
PIA_IDS_RTGENRL | Type of PiaException thrown if denominator is out of range in RtGeneral::project1.
PIA_IDS_RWSTRING | Type of PiaException thrown if error in ReindWid1Page::prepareStrings.
PIA_IDS_SECONDARY | Type of PiaException thrown if type of bic is not set in Secondary::check.
PIA_IDS_SETNOCH | Type of PiaException thrown if year is out of range in PiaParams::setNoChange.
PIA_IDS_SEX | Type of PiaException thrown if sex is not Sex::sex_type::MALE or Sex::sex_type::FEMALE.
PIA_IDS_SEXOUT | String ID for printing sex of worker.
PIA_IDS_SGAPROJ | Type of PiaException thrown if annual Sga project function is called.
PIA_IDS_SMSTRING | Type of PiaException thrown if error in SpecMin1Page::prepareStrings.
PIA_IDS_SPPIA1OUT | String ID for printing special minimum PIA, support PIA unused.
PIA_IDS_SPPIA2OUT | String ID for printing special minimum PIA, support PIA used.
PIA_IDS_SPYRS2OUT | String ID for printing total special minimum years of coverage.
PIA_IDS_SPYRSOUT | String ID for printing total special minimum years of coverage.
PIA_IDS_SSN1 | Type of PiaException thrown if number of characters in a string used to construct an Ssn is less than 9.
PIA_IDS_SSNOUT | String ID for printing worker's Social Security number.
PIA_IDS_START1 | Type of PiaException thrown if starting year of assumptions is before 1979.
PIA_IDS_START2 | Type of PiaException thrown if starting year of assumptions is after maximum year allowed.
PIA_IDS_SUPPIAOUT | String ID for printing support PIA.
PIA_IDS_SURVBENOUT | String ID for printing secondary date of benefit.
PIA_IDS_SURVENTOUT | String ID for printing secondary date of entitlement.
PIA_IDS_TAXTYPE | Type of PiaException thrown if type of taxes is out of range.
PIA_IDS_TAXTYPEYR | Type of PiaException thrown if year is out of range in WorkerData::setTaxType.
PIA_IDS_TGSTRING | Type of PiaException thrown if error in TransGuar1Page::prepareStrings.
PIA_IDS_TITLEPRO1 | (Currently unused.)
PIA_IDS_TITLEPRO2 | (Currently unused.)
PIA_IDS_TITLEPRO3 | (Currently unused.)
PIA_IDS_TITLEPRO4 | (Currently unused).
PIA_IDS_TWOPAGE1 | Type of PiaException thrown if error in InsuredPage::prepareStrings.
PIA_IDS_TWOPAGE2 | Type of PiaException thrown if error in EarningsPage::prepareStrings.
PIA_IDS_TWOPAGE3 | Type of PiaException thrown if error in Summary1Page::prepareStrings.
PIA_IDS_TWOPAGE4 | Type of PiaException thrown if error in Summary2Page::prepareStrings.
PIA_IDS_TWOPAGE5 | Type of PiaException thrown if error in Summary3Page::prepareStrings.
PIA_IDS_TXSTRING | Type of PiaException thrown if error in TaxesPage::prepareStrings.
PIA_IDS_UNBICCHP | Type of PiaException thrown if either year is out of range in PiaParams::unbiCatchUp.
PIA_IDS_UNEARNOUT | String ID for printing unused earnings message.
PIA_IDS_UPDATEAW | (Currently unused.)
PIA_IDS_UPDATEBI | (Currently unused.)
PIA_IDS_UPDATEFQ | Type of PiaException thrown if average wage is zero in PiaParams::updateFq.
PIA_IDS_UPDATEWB | (Currently unused.)
PIA_IDS_UPDATEWBOLD | (Currently unused.)
PIA_IDS_VALDI1 | Type of PiaException thrown if number of periods of disability is not 0, 1, or 2 in a nondisability case.
PIA_IDS_VALDI2 | Type of PiaException thrown if number of periods of disability is not 1 or 2 in a disability case.
PIA_IDS_WAGEBASE | (Currently unused.)
PIA_IDS_WAITPD1 | Type of PiaException thrown if first month of waiting period is out of range.
PIA_IDS_WAITPD2 | Type of PiaException thrown if year of first month of waiting period is before 1940.
PIA_IDS_WAITPD3 | Type of PiaException thrown if year of first month of waiting period is after maximum allowed.
PIA_IDS_WAITPD4 | Type of PiaException thrown if waiting period starts before onset.
PIA_IDS_WAITPD5 | Type of PiaException thrown if entitlement is before waiting period.
PIA_IDS_WAITPD6 | Type of PiaException thrown if cessation is before waiting period.
PIA_IDS_WAITPD7 | (Currently unused.)
PIA_IDS_WIDDIBOUT | String ID for printing date of onset of widow(er).
PIA_IDS_WISTRING | Type of PiaException thrown if error in WageInd1Page::prepareStrings.
PIA_IDS_WRITEEARN | Type of PiaException thrown if first year of earnings is out of range in PiaWrite::writeEarnOasdi or PiaWriteAny::writeEarnOasdi.
PIA_IDS_YEAR | (Currently unused.)


RetireTest.h Classes

RetireTest.h Classes
RetireTest.h Legend
Classes
Name | Description
RetireTest | Contains all of the retirement test exempt amounts and functions to use them.


Legend

Legend
RetireTest.h
Legend
Class


rtgenrl.h Classes

rtgenrl.h Classes
rtgenrl.h Legend
Classes
Name | Description
RtGeneral | Parent of classes to manage the retirement test exempt amount projections.
Rtea62 | Manages the annual retirement test exempt amount projections under full retirement age.
Rtea62m | Manages the monthly retirement test exempt amount projections under full retirement age.
Rtea65 | Manages the annual retirement test exempt amount projections over full retirement age.
Rtea65m | Manages the monthly retirement test exempt amount projections over full retirement age.
RteaHigh | Manages the upper annual retirement test exempt amounts when there were two tiers.


Legend

Legend
rtgenrl.h
Legend
Class


ScaledEarnFactors.h Classes

ScaledEarnFactors.h Classes
ScaledEarnFactors.h Legend
Classes
Name | Description
ScaledEarnFactors | Manages scaled earner amounts.


Legend

Legend
ScaledEarnFactors.h
Legend
Class


Secondary.h Classes

Secondary.h Classes
Secondary.h Legend
Classes
Name | Description
Secondary | Contains the information about a secondary benefit.


Legend

Legend
Secondary.h
Legend
Class


SecondaryArray.h Classes

SecondaryArray.h Classes
SecondaryArray.h Legend
Classes
Name | Description
SecondaryArray | Manages an array of Secondary's.


Legend

Legend
SecondaryArray.h
Legend
Class


Sex.h Classes

Sex.h Classes
Sex.h Legend
Classes
Name | Description
Sex | Indicator for sex type.


Legend

Legend
Sex.h
Legend
Class


Sga.h Classes

Sga.h Classes
Sga.h Legend
Classes
Name | Description
Sga | Contains all of the SGA amounts and functions to use them.


Legend

Legend
Sga.h
Legend
Class


SgaDerived.h Classes

SgaDerived.h Classes
SgaDerived.h Legend
Classes
Name | Description
SgaBlindA | Manages the annual SGA amounts (historical and projected) for blind beneficiaries.
SgaBlindM | Manages the monthly SGA amounts (historical and projected) for blind beneficiaries (as of December).
SgaMaxA | Manages the annual SGA maximum amounts(historical and projected) for non-blind beneficiaries.
SgaMaxM | Manages the monthly SGA maximum amounts (historical and projected) for non-blind beneficiaries (as of December).
SgaMinA | Manages the annual SGA minimum amounts (historical and projected) for non-blind beneficiaries.
SgaMinM | Manages the monthly SGA minimum amounts (historical and projected) for non-blind beneficiaries (as of December).


Legend

Legend
SgaDerived.h
Legend
Class


SgaGeneral.h Classes

SgaGeneral.h Classes
SgaGeneral.h Legend
Classes
Name | Description
SgaGeneral | Parent of classes to manage the SGA (Substantial Gainful Activity) amounts (historical and projected).


Legend

Legend
SgaGeneral.h
Legend
Class


SpecMin1Page.h Classes

SpecMin1Page.h Classes
SpecMin1Page.h Legend
Classes
Name | Description
SpecMin1Page | Manages a special minimum earnings page from the calculation of a Social Security benefit.


Legend

Legend
SpecMin1Page.h
Legend
Class


SpecMin2Page.h Classes

SpecMin2Page.h Classes
SpecMin2Page.h Legend
Classes
Name | Description
SpecMin2Page | Manages a special minimum calculation details page from the calculation of a Social Security benefit.


Legend

Legend
SpecMin2Page.h
Legend
Class


SpecMin.h Classes

SpecMin.h Classes
SpecMin.h Legend
Classes
Name | Description
SpecMin | Manages the functions required for calculation of a special minimum Social Security benefit.


Legend

Legend
SpecMin.h
Legend
Class


SpecMinLC.h Classes

SpecMinLC.h Classes
SpecMinLC.h Legend
Classes
Name | Description
SpecMinLC | Manages the functions required for calculation of a special minimum Social Security benefit, including changes from present law.


Legend

Legend
SpecMinLC.h
Legend
Class


ssn.h Classes

ssn.h Classes
ssn.h Legend
Classes
Name | Description
Ssn | Manages a Social Security number string, and the 3 parts of an ssn separately as strings.


Legend

Legend
ssn.h
Legend
Class


StringParser.h Functions

StringParser.h Functions
StringParser.h Legend
Functions
Name | Description
parseString | Parses a string into its delimited parts, using a space separator.
parseString | Parses a string into its delimited parts with a specified delimiter.


Legend

Legend
StringParser.h
Legend
Method


Summary1Page.h Classes

Summary1Page.h Classes
Summary1Page.h Legend
Classes
Name | Description
Summary1Page | Manages the top part of the summary of results page from the calculation of a Social Security benefit.


Legend

Legend
Summary1Page.h
Legend
Class


Summary2Page.h Classes

Summary2Page.h Classes
Summary2Page.h Legend
Classes
Name | Description
Summary2Page | Manages the middle part of the summary of results page from the calculation of a Social Security benefit.


Legend

Legend
Summary2Page.h
Legend
Class


Summary3Page.h Classes

Summary3Page.h Classes
Summary3Page.h Legend
Classes
Name | Description
Summary3Page | Manages the bottom part of the summary of results page from the calculation of a Social Security benefit.


Legend

Legend
Summary3Page.h
Legend
Class


SummaryPage.h Classes

SummaryPage.h Classes
SummaryPage.h Legend
Classes
Name | Description
SummaryPage | Manages the summary page of results from the calculation of a Social Security benefit.


Legend

Legend
SummaryPage.h
Legend
Class


TaxBenefits.h Classes

TaxBenefits.h Classes
TaxBenefits.h Legend
Classes
Name | Description
TaxBenefits | Contains the functions required to calculate the tax on a Social Security benefit.


Legend

Legend
TaxBenefits.h
Legend
Class


TaxBenefitsLC.h Classes

TaxBenefitsLC.h Classes
TaxBenefitsLC.h Legend
Classes
Name | Description
TaxBenefitsLC | Contains the functions required to calculate the tax on a Social Security benefit with law changes.


Legend

Legend
TaxBenefitsLC.h
Legend
Class


TaxData.h Classes

TaxData.h Classes
TaxData.h Legend
Classes
Name | Description
TaxData | Manages the Social Security payroll and self-employed taxes paid by a worker.


Legend

Legend
TaxData.h
Legend
Class


TaxesPage.h Classes

TaxesPage.h Classes
TaxesPage.h Legend
Classes
Name | Description
TaxesPage | Manages the taxes output page.


Legend

Legend
TaxesPage.h
Legend
Class


TaxRates.h Classes

TaxRates.h Classes
TaxRates.h Legend
Classes
Name | Description
TaxRates | Abstract parent of classes that manage the Social Security payroll and self-employed tax rates.


Legend

Legend
TaxRates.h
Legend
Class


TaxRatesLC.h Classes

TaxRatesLC.h Classes
TaxRatesLC.h Legend
Classes
Name | Description
TaxRatesLC | Manages the Social Security payroll and self-employed tax rates, with changes from present law.


Legend

Legend
TaxRatesLC.h
Legend
Class


TaxRatesPL.h Classes

TaxRatesPL.h Classes
TaxRatesPL.h Legend
Classes
Name | Description
TaxRatesPL | Manages the present law Social Security payroll and self-employed tax rates.


Legend

Legend
TaxRatesPL.h
Legend
Class


TextWriterTraceListener.h Classes

TextWriterTraceListener.h Classes
TextWriterTraceListener.h Legend
Classes
Name | Description
TextWriterTraceListener | An output-stream-based class that listens for Trace output.


Legend

Legend
TextWriterTraceListener.h
Legend
Class


Trace.h Classes

Trace.h Classes
Trace.h Legend
Classes
Name | Description
Trace | Controls the logfiles used to trace execution of code.


Legend

Legend
Trace.h
Legend
Class


TraceListener.h Classes

TraceListener.h Classes
TraceListener.h Legend
Classes
Name | Description
TraceListener | The parent of classes that listen for Trace output.


Legend

Legend
TraceListener.h
Legend
Class


TransGuar1Page.h Classes

TransGuar1Page.h Classes
TransGuar1Page.h Legend
Classes
Name | Description
TransGuar1Page | Manages the transitional guarantee earnings page from the calculation of a Social Security benefit.


Legend

Legend
TransGuar1Page.h
Legend
Class


TransGuar2Page.h Classes

TransGuar2Page.h Classes
TransGuar2Page.h Legend
Classes
Name | Description
TransGuar2Page | Manages the transitional guarantee results page from the calculation of a Social Security benefit.


Legend

Legend
TransGuar2Page.h
Legend
Class


TransGuar.h Classes

TransGuar.h Classes
TransGuar.h Legend
Classes
Name | Description
TransGuar | Manages the functions required for calculation of a transitional guarantee Social Security benefit.


Legend

Legend
TransGuar.h
Legend
Class


TransGuarLC.h Classes

TransGuarLC.h Classes
TransGuarLC.h Legend
Classes
Name | Description
TransGuarLC | Manages the functions required for calculation of a transitional guarantee Social Security benefit, with changes from present law.


Legend

Legend
TransGuarLC.h
Legend
Class


UserAssumptions.h Classes

UserAssumptions.h Classes
UserAssumptions.h Legend
Classes
Name | Description
UserAssumptions | Manages all the assumptions about future average wage increases, wage bases, benefit increases, and catch-up benefit increases that a user might specify.


Legend

Legend
UserAssumptions.h
Legend
Class


WageBase.h Classes

WageBase.h Classes
WageBase.h Legend
Classes
Name | Description
WageBase | Manages the OASDI wage base projections.
WageBaseHI | Manages the HI wage base projections.
WageBaseOldLaw | Manages the old-law OASDI wage base projections.


Legend

Legend
WageBase.h
Legend
Class


WageInd1Page.h Classes

WageInd1Page.h Classes
WageInd1Page.h Legend
Classes
Name | Description
WageInd1Page | Manages a wage indexed earnings page from the calculation of a Social Security benefit.


Legend

Legend
WageInd1Page.h
Legend
Class


WageInd2Page.h Classes

WageInd2Page.h Classes
WageInd2Page.h Legend
Classes
Name | Description
WageInd2Page | Manages a wage indexed results page from the calculation of a Social Security benefit.


Legend

Legend
WageInd2Page.h
Legend
Class


WageInd.h Classes

WageInd.h Classes
WageInd.h Legend
Classes
Name | Description
WageInd | Manages the functions required for calculation of a wage indexed Social Security benefit.


Legend

Legend
WageInd.h
Legend
Class


WageIndGeneral.h Classes

WageIndGeneral.h Classes
WageIndGeneral.h Legend
Classes
Name | Description
WageIndGeneral | Parent of all classes that manage the functions required for calculation of a wage indexed Social Security benefit.


Legend

Legend
WageIndGeneral.h
Legend
Class


WageIndLC.h Classes

WageIndLC.h Classes
WageIndLC.h Legend
Classes
Name | Description
WageIndLC | Manages the functions required for calculation of a wage indexed Social Security benefit, with changes from present law.


Legend

Legend
WageIndLC.h
Legend
Class


WageIndNonFreeze1Page.h Classes

WageIndNonFreeze1Page.h Classes
WageIndNonFreeze1Page.h Legend
Classes
Name | Description
WageIndNonFreeze1Page | Manages a wage indexed non-freeze page from the calculation of a Social Security benefit.


Legend

Legend
WageIndNonFreeze1Page.h
Legend
Class


WageIndNonFreeze2Page.h Classes

WageIndNonFreeze2Page.h Classes
WageIndNonFreeze2Page.h Legend
Classes
Name | Description
WageIndNonFreeze2Page | Manages a wage indexed non-freeze results page from the calculation of a Social Security benefit.


Legend

Legend
WageIndNonFreeze2Page.h
Legend
Class


WageIndNonFreeze.h Classes

WageIndNonFreeze.h Classes
WageIndNonFreeze.h Legend
Classes
Name | Description
WageIndNonFreeze | Manages the functions required for calculation of a wage indexed non-freeze Social Security benefit.


Legend

Legend
WageIndNonFreeze.h
Legend
Class


wbgenrl.h Classes

wbgenrl.h Classes
wbgenrl.h Legend
Classes
Name | Description
WageBaseGeneral | Ancestor of the classes that manage the wage base projections.


Legend

Legend
wbgenrl.h
Legend
Class


wbgenrlLC.h Classes

wbgenrlLC.h Classes
wbgenrlLC.h Legend
Classes
Name | Description
WageBaseLC | Manages the OASDI wage base projection with law changes.
WageBaseOldLawLC | Manages the old-law OASDI wage base projection with law changes.


Legend

Legend
wbgenrlLC.h
Legend
Class


WorkerDataArray.h Classes

WorkerDataArray.h Classes
WorkerDataArray.h Legend
Classes
Name | Description
WorkerDataArray | Manages an array of WorkerData's, representing one family.


Legend

Legend
WorkerDataArray.h
Legend
Class


WorkerDataGeneral.h Classes

WorkerDataGeneral.h Classes
WorkerDataGeneral.h Legend
Classes
Name | Description
WorkerDataGeneral | The abstract parent of all classes that manage the basic data required to calculate a Social Security benefit.


Legend

Legend
WorkerDataGeneral.h
Legend
Class


wrkrdata.h Classes

wrkrdata.h Classes
wrkrdata.h Legend
Classes
Name | Description
WorkerData | Manages the basic data required to calculate a Social Security benefit.


Legend

Legend
wrkrdata.h
Legend
Class


Contents

Contents
Social Security Benefit Calculator
Collapse Expand PiaData Library
Collapse Expand Classes
Collapse Expand Assumptions Class
Assumptions Members
Collapse Expand Assumptions Constructor
Assumptions::Assumptions Constructor (int)
Assumptions::Assumptions Constructor (int, int)
Assumptions::~Assumptions Destructor
Collapse Expand Assumptions Methods
Assumptions::averageWageMenu Method
Assumptions::benefitIncMenu Method
Assumptions::getAverageWage Method
Assumptions::getAwincProj Method
Assumptions::getBenefitInc Method
Assumptions::getBiProj Method
Assumptions::getCatchupDoc Method
Assumptions::getIstart Method
Assumptions::getMaxyear Method
Assumptions::setAwincProjTitle Method
Assumptions::setBiProjTitle Method
Assumptions::setIstart Method
Collapse Expand AssumptionsFile Class
AssumptionsFile Members
AssumptionsFile::AssumptionsFile Constructor
AssumptionsFile::~AssumptionsFile Destructor
Collapse Expand AssumptionsFile Data Members
AssumptionsFile::awincProj Data Member
AssumptionsFile::biProj Data Member
AssumptionsFile::catchupDoc Data Member
Collapse Expand AssumptionsFile Methods
AssumptionsFile::averageWageMenu Method
AssumptionsFile::benefitIncMenu Method
AssumptionsFile::getAwincProj Method
AssumptionsFile::getBiProj Method
AssumptionsFile::getCatchupDoc Method
AssumptionsFile::setAwincProjTitle Method
AssumptionsFile::setBiProjTitle Method
AssumptionsFile::setIstart Method
Collapse Expand AssumptionsNonFile Class
AssumptionsNonFile Members
Collapse Expand AssumptionsNonFile Constructor
AssumptionsNonFile::AssumptionsNonFile Constructor (int)
AssumptionsNonFile::AssumptionsNonFile Constructor (int, int)
AssumptionsNonFile::~AssumptionsNonFile Destructor
Collapse Expand AssumptionsNonFile Data Members
AssumptionsNonFile::awincProj Data Member
AssumptionsNonFile::biProj Data Member
AssumptionsNonFile::catchupDoc Data Member
Collapse Expand AssumptionsNonFile Methods
AssumptionsNonFile::averageWageMenu Method
AssumptionsNonFile::benefitIncMenu Method
AssumptionsNonFile::getAwincProj Method
AssumptionsNonFile::getBiProj Method
AssumptionsNonFile::getCatchupDoc Method
AssumptionsNonFile::setAwincProjTitle Method
AssumptionsNonFile::setBiProjTitle Method
AssumptionsNonFile::setIstart Method
Collapse Expand AssumptionType Class
AssumptionType Members
Collapse Expand AssumptionType Enumerations
AssumptionType::assum_type Enumeration
Collapse Expand AssumptionType Data Members
AssumptionType::EXPANDED_PEBES Data Member
Collapse Expand AssumptionType Methods
AssumptionType::ialtawCheck1 Method
AssumptionType::ialtawCheck2 Method
AssumptionType::ialtbiCheck1 Method
AssumptionType::ialtbiCheck2 Method
AssumptionType::isFlatOrPebs Method
AssumptionType::isNotTR Method
AssumptionType::isTR Method
Collapse Expand AverageWage Class
AverageWage Members
AverageWage::AverageWage Constructor
AverageWage::~AverageWage Destructor
Collapse Expand AverageWage Methods
AverageWage::endYear Method
Collapse Expand project Method
AverageWage::project Method (const Awinc&, int)
AverageWage::project Method (double, int, int)
AverageWage::projectBackward Method
AverageWage::projectBackwardStatic Method
AverageWage::projectForward Method
AverageWage::projectForwardStatic Method
AverageWage::round Method
AverageWage::startYear Method
Collapse Expand AverageWage Operators
AverageWage::= Operator
Collapse Expand AverageWage Friends
friend class boost::serialization::access Friend
Collapse Expand AwbiData Class
AwbiData Members
Collapse Expand AwbiData Constructor
AwbiData::AwbiData Constructor (int)
AwbiData::AwbiData Constructor (int, int)
AwbiData::~AwbiData Destructor
Collapse Expand AwbiData Data Members
AwbiData::HI_BASE_YEAR Data Member
AwbiData::base77 Data Member
AwbiData::baseHi Data Member
AwbiData::baseOasdi Data Member
AwbiData::cpiinc Data Member
AwbiData::fq Data Member
Collapse Expand AwbiData Methods
AwbiData::getLastYear Method
AwbiData::read Method
AwbiData::setData Method
AwbiData::setLastYear Method
AwbiData::write Method
Collapse Expand AwbiDataFile Class
AwbiDataFile Members
AwbiDataFile::AwbiDataFile Constructor
Collapse Expand AwbiDataFile Methods
Collapse Expand read Method
AwbiDataFile::read Method ()
AwbiDataFile::read Method (std::istream&)
AwbiDataFile::setAwbiFile Method
AwbiDataFile::setData Method
Collapse Expand write Method
AwbiDataFile::write Method ()
AwbiDataFile::write Method (std::ostream&)
Collapse Expand AwbiDataNonFile Class
AwbiDataNonFile Members
Collapse Expand AwbiDataNonFile Constructor
AwbiDataNonFile::AwbiDataNonFile Constructor (int)
AwbiDataNonFile::AwbiDataNonFile Constructor (int, int)
Collapse Expand AwbiDataNonFile Methods
AwbiDataNonFile::getBase77Data Method
AwbiDataNonFile::getBaseHiData Method
AwbiDataNonFile::getBaseOasdiData Method
AwbiDataNonFile::getCpiincData Method
AwbiDataNonFile::getFqData Method
AwbiDataNonFile::setData Method
Collapse Expand Awinc Class
Awinc Members
Collapse Expand Awinc Constructor
Awinc::Awinc Constructor (int)
Awinc::Awinc Constructor (int, int)
Collapse Expand Awinc Methods
Awinc::fqincCheck Method
Collapse Expand project Method
Awinc::project Method (const AverageWage&, int, int)
Awinc::project Method (double, int)
Collapse Expand AwincDoc Class
AwincDoc Members
AwincDoc::AwincDoc Constructor
AwincDoc::~AwincDoc Destructor
Collapse Expand AwincDoc Data Members
AwincDoc::avgwage Data Member
AwincDoc::awinc Data Member
AwincDoc::awincTitle Data Member
Collapse Expand AwincDoc Methods
AwincDoc::getFirstYear Method
AwincDoc::getTitle Method
AwincDoc::read Method
Collapse Expand setData Method
AwincDoc::setData Method (int)
AwincDoc::setData Method (int, const DoubleAnnual&)
AwincDoc::setFirstYear Method
AwincDoc::setFqinc Method
Collapse Expand setTitle Method
AwincDoc::setTitle Method (int)
AwincDoc::setTitle Method (int, const std::string&)
AwincDoc::write Method
Collapse Expand AwincFile Class
AwincFile Members
AwincFile::AwincFile Constructor
Collapse Expand AwincFile Methods
AwincFile::read Method
AwincFile::setAwFile Method
Collapse Expand setData Method
AwincFile::setData Method (int)
AwincFile::setData Method (int, const DoubleAnnual&)
Collapse Expand setTitle Method
AwincFile::setTitle Method (int)
AwincFile::setTitle Method (int, const std::string&)
AwincFile::write Method
Collapse Expand AwincNonFile Class
AwincNonFile Members
AwincNonFile::AwincNonFile Constructor
AwincNonFile::~AwincNonFile Destructor
Collapse Expand AwincNonFile Enumerations
AwincNonFile::DimLimits Enumeration
Collapse Expand AwincNonFile Methods
AwincNonFile::read Method
Collapse Expand setData Method
AwincNonFile::setData Method (int)
AwincNonFile::setData Method (int, const DoubleAnnual&)
Collapse Expand setTitle Method
AwincNonFile::setTitle Method (int)
AwincNonFile::setTitle Method (int, const std::string&)
AwincNonFile::write Method
Collapse Expand BaseChangeType Class
BaseChangeType Members
Collapse Expand BaseChangeType Enumerations
BaseChangeType::change_type Enumeration
Collapse Expand BaseChangeType Methods
BaseChangeType::check Method
BaseChangeType::toString Method
Collapse Expand BaseYear Class
BaseYear Members
BaseYear::BaseYear Constructor
BaseYear::~BaseYear Destructor
Collapse Expand BaseYear Data Members
BaseYear::theYear Data Member
Collapse Expand BaseYear Methods
BaseYear::getYear Method
BaseYear::read Method
BaseYear::setYear Method
BaseYear::write Method
BaseYear::yearCheck Method
Collapse Expand BaseYearFile Class
BaseYearFile Members
BaseYearFile::BaseYearFile Constructor
Collapse Expand BaseYearFile Methods
BaseYearFile::read Method
BaseYearFile::write Method
Collapse Expand BaseYearNonFile Class
BaseYearNonFile Members
BaseYearNonFile::BaseYearNonFile Constructor
Collapse Expand BaseYearNonFile Data Members
BaseYearNonFile::TR_YEAR Data Member
BaseYearNonFile::YEAR Data Member
Collapse Expand BaseYearNonFile Methods
BaseYearNonFile::read Method
BaseYearNonFile::write Method
Collapse Expand BendPia Class
BendPia Members
BendPia::BendPia Constructor
BendPia::~BendPia Destructor
Collapse Expand BendPia Data Members
BendPia::BP1979 Data Member
Collapse Expand BendPia Methods
BendPia::as_array Method
Collapse Expand begin Method
BendPia::begin Method ()
BendPia::begin Method ()
BendPia::deleteContents Method
Collapse Expand end Method
BendPia::end Method ()
BendPia::end Method ()
BendPia::getNumBend Method
BendPia::max_size Method
BendPia::project Method
BendPia::setNumBend Method
BendPia::size Method
Collapse Expand BendPia Operators
Collapse Expand [] Operator
BendPia::[] Operator (std::size_t)
BendPia::[] Operator (std::size_t)
Collapse Expand BendPia Nested Types
BendPia::const_iterator Nested Type
BendPia::const_reference Nested Type
BendPia::difference_type Nested Type
BendPia::iterator Nested Type
BendPia::reference Nested Type
BendPia::size_type Nested Type
BendPia::value_type Nested Type
Collapse Expand BendMfb Class
BendMfb Members
BendMfb::BendMfb Constructor
BendMfb::~BendMfb Destructor
Collapse Expand BendMfb Data Members
BendMfb::BP1979 Data Member
Collapse Expand BendMfb Methods
BendMfb::as_array Method
Collapse Expand begin Method
BendMfb::begin Method ()
BendMfb::begin Method ()
BendMfb::deleteContents Method
Collapse Expand end Method
BendMfb::end Method ()
BendMfb::end Method ()
BendMfb::max_size Method
BendMfb::project Method
BendMfb::size Method
Collapse Expand BendMfb Operators
Collapse Expand [] Operator
BendMfb::[] Operator (std::size_t)
BendMfb::[] Operator (std::size_t)
Collapse Expand BendMfb Nested Types
BendMfb::const_iterator Nested Type
BendMfb::const_reference Nested Type
BendMfb::difference_type Nested Type
BendMfb::iterator Nested Type
BendMfb::reference Nested Type
BendMfb::size_type Nested Type
BendMfb::value_type Nested Type
Collapse Expand BenefitAmount Class
BenefitAmount Members
BenefitAmount::BenefitAmount Constructor
Collapse Expand BenefitAmount Methods
Collapse Expand applyCola Method
BenefitAmount::applyCola Method (double, double, int)
BenefitAmount::applyCola Method (double, int)
BenefitAmount::get Method
Collapse Expand round Method
BenefitAmount::round Method (double, int)
BenefitAmount::round Method (int)
Collapse Expand round1 Method
BenefitAmount::round1 Method (const DateMoyr&)
BenefitAmount::round1 Method (double, const DateMoyr&)
Collapse Expand round5 Method
BenefitAmount::round5 Method (double, int)
BenefitAmount::round5 Method (int)
BenefitAmount::set Method
BenefitAmount::toString Method
Collapse Expand unApplyCola Method
BenefitAmount::unApplyCola Method (double, double, int)
BenefitAmount::unApplyCola Method (double, int)
Collapse Expand unround Method
BenefitAmount::unround Method (double, int)
BenefitAmount::unround Method (int)
Collapse Expand BenefitAmount Operators
BenefitAmount::< Operator
Collapse Expand BenefitAmountArray Class
BenefitAmountArray Members
Collapse Expand BenefitAmountArray Constructor
BenefitAmountArray::BenefitAmountArray Constructor ()
BenefitAmountArray::BenefitAmountArray Constructor (int)
BenefitAmountArray::~BenefitAmountArray Destructor
Collapse Expand BenefitAmountArray Methods
BenefitAmountArray::deleteContents Method
BenefitAmountArray::getLastYear Method
BenefitAmountArray::initialize Method
BenefitAmountArray::setDirty Method
Collapse Expand BenefitAmountArray Operators
Collapse Expand [] Operator
BenefitAmountArray::[] Operator (int)
BenefitAmountArray::[] Operator (int)
Collapse Expand Bic Class
Bic Members
Collapse Expand Bic Constructor
Bic::Bic Constructor ()
Bic::Bic Constructor (char, char)
Bic::Bic Constructor (const std::string&)
Collapse Expand Bic Methods
Bic::eligibleForMax Method
Bic::getLifeAuxType Method
Bic::getMajorBic Method
Bic::getMinorBic Method
Bic::getSurvivorType Method
Bic::isAuxiliary Method
Bic::isDisabledWidow Method
Bic::isReducible Method
Bic::isWidow Method
Bic::isYoungSpouse Method
Bic::isYoungSurvivor Method
Bic::set Method
Bic::setMajorBic Method
Bic::setMinorBic Method
Bic::survivorCheck Method
Bic::toString Method
Collapse Expand Bic Operators
Bic::== Operator
Collapse Expand Biproj Class
Biproj Members
Biproj::Biproj Constructor
Biproj::~Biproj Destructor
Collapse Expand Biproj Data Members
Biproj::beninc Data Member
Biproj::biprojTitle Data Member
Biproj::theData Data Member
Collapse Expand Biproj Methods
Biproj::cpiincCheck Method
Biproj::getFirstYear Method
Biproj::getTitle Method
Biproj::read Method
Biproj::setCpiinc Method
Collapse Expand setData Method
Biproj::setData Method (int)
Biproj::setData Method (int, const DoubleAnnual&)
Biproj::setFirstYear Method
Collapse Expand setTitle Method
Biproj::setTitle Method (int)
Biproj::setTitle Method (int, const std::string&)
Biproj::write Method
Collapse Expand BiprojFile Class
BiprojFile Members
BiprojFile::BiprojFile Constructor
Collapse Expand BiprojFile Methods
BiprojFile::read Method
BiprojFile::setBiFile Method
Collapse Expand setData Method
BiprojFile::setData Method (int)
BiprojFile::setData Method (int, const DoubleAnnual&)
Collapse Expand setTitle Method
BiprojFile::setTitle Method (int)
BiprojFile::setTitle Method (int, const std::string&)
BiprojFile::write Method
Collapse Expand BiprojNonFile Class
BiprojNonFile Members
BiprojNonFile::BiprojNonFile Constructor
BiprojNonFile::~BiprojNonFile Destructor
Collapse Expand BiprojNonFile Enumerations
BiprojNonFile::DimLimits Enumeration
Collapse Expand BiprojNonFile Methods
BiprojNonFile::read Method
Collapse Expand setData Method
BiprojNonFile::setData Method (int)
BiprojNonFile::setData Method (int, const DoubleAnnual&)
Collapse Expand setTitle Method
BiprojNonFile::setTitle Method (int)
BiprojNonFile::setTitle Method (int, const std::string&)
BiprojNonFile::write Method
Collapse Expand BpMfbOut Class
BpMfbOut Members
Collapse Expand BpMfbOut Constructor
BpMfbOut::BpMfbOut Constructor (int)
BpMfbOut::BpMfbOut Constructor (int, int)
Collapse Expand BpMfbOut Methods
BpMfbOut::getBpmfb1 Method
BpMfbOut::getBpmfb2 Method
BpMfbOut::getBpmfb3 Method
Collapse Expand setData Method
BpMfbOut::setData Method (const AverageWage&, int)
BpMfbOut::setData Method (int, double, double, double)
Collapse Expand BpPiaOut Class
BpPiaOut Members
Collapse Expand BpPiaOut Constructor
BpPiaOut::BpPiaOut Constructor (int)
BpPiaOut::BpPiaOut Constructor (int, int)
Collapse Expand BpPiaOut Methods
BpPiaOut::getBppia Method
BpPiaOut::getNumBend Method
BpPiaOut::set1979Data Method
BpPiaOut::setIndexedData Method
BpPiaOut::setSingleYearData Method
Collapse Expand Catchup Class
Catchup Members
Collapse Expand Catchup Constructor
Catchup::Catchup Constructor ()
Catchup::Catchup Constructor (int)
Catchup::~Catchup Destructor
Collapse Expand Catchup Data Members
Catchup::NUM_CATCHUP_ELIG_YEARS Data Member
Catchup::catchup Data Member
Collapse Expand Catchup Methods
Catchup::check Method
Catchup::deleteContents Method
Catchup::exist Method
Catchup::get Method
Catchup::getCatchupIncreases Method
Catchup::getCstart Method
Catchup::parseString Method
Catchup::set Method
Catchup::setCstart Method
Collapse Expand CatchupDoc Class
CatchupDoc Members
Collapse Expand CatchupDoc Constructor
CatchupDoc::CatchupDoc Constructor ()
CatchupDoc::CatchupDoc Constructor (int)
CatchupDoc::~CatchupDoc Destructor
Collapse Expand CatchupDoc Data Members
CatchupDoc::allownonzero Data Member
CatchupDoc::catchup Data Member
Collapse Expand CatchupDoc Methods
CatchupDoc::exist Method
CatchupDoc::get Method
CatchupDoc::read Method
Collapse Expand setData Method
CatchupDoc::setData Method (int)
CatchupDoc::setData Method (int, const Catchup&)
CatchupDoc::write Method
Collapse Expand CatchupFile Class
CatchupFile Members
CatchupFile::CatchupFile Constructor
CatchupFile::~CatchupFile Destructor
Collapse Expand CatchupFile Data Members
CatchupFile::pathname Data Member
Collapse Expand CatchupFile Methods
CatchupFile::read Method
CatchupFile::setCuFile Method
Collapse Expand setData Method
CatchupFile::setData Method (int)
CatchupFile::setData Method (int, const Catchup&)
CatchupFile::write Method
Collapse Expand CatchupIncreases Class
CatchupIncreases Members
CatchupIncreases::CatchupIncreases Constructor
CatchupIncreases::~CatchupIncreases Destructor
Collapse Expand CatchupIncreases Data Members
CatchupIncreases::NUM_CATCHUP_INCREASES Data Member
CatchupIncreases::theData Data Member
Collapse Expand CatchupIncreases Methods
CatchupIncreases::get Method
CatchupIncreases::parseString Method
CatchupIncreases::set Method
CatchupIncreases::toString Method
Collapse Expand CatchupNonFile Class
CatchupNonFile Members
CatchupNonFile::CatchupNonFile Constructor
CatchupNonFile::~CatchupNonFile Destructor
Collapse Expand CatchupNonFile Methods
CatchupNonFile::read Method
Collapse Expand setData Method
CatchupNonFile::setData Method (int)
CatchupNonFile::setData Method (int, const Catchup&)
CatchupNonFile::write Method
Collapse Expand ChildCareCalc Class
ChildCareCalc Members
ChildCareCalc::ChildCareCalc Constructor
ChildCareCalc::~ChildCareCalc Destructor
Collapse Expand ChildCareCalc Methods
ChildCareCalc::calculate Method
ChildCareCalc::childCareDropMaxCal Method
ChildCareCalc::childCareDropoutCal Method
ChildCareCalc::getAdjustedN Method
ChildCareCalc::getChildCareDrop Method
ChildCareCalc::getChildCareDropMax Method
ChildCareCalc::initialize Method
Collapse Expand isApplicable Method
ChildCareCalc::isApplicable Method ()
ChildCareCalc::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type)
Collapse Expand ChildCareCalcLC Class
ChildCareCalcLC Members
ChildCareCalcLC::ChildCareCalcLC Constructor
ChildCareCalcLC::~ChildCareCalcLC Destructor
Collapse Expand ChildCareCalcLC Data Members
ChildCareCalcLC::lawChange Data Member
Collapse Expand ChildCareCalcLC Methods
ChildCareCalcLC::childCareDropMaxCal Method
Collapse Expand isApplicable Method
ChildCareCalcLC::isApplicable Method ()
ChildCareCalcLC::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type, const LawChangeArray&)
Collapse Expand CompPeriod Class
CompPeriod Members
CompPeriod::CompPeriod Constructor
Collapse Expand CompPeriod Methods
CompPeriod::deleteContents Method
CompPeriod::getBaseYear Method
CompPeriod::getDiYears Method
CompPeriod::getN Method
CompPeriod::getNDrop Method
CompPeriod::getNElapsed Method
CompPeriod::setDiYears Method
CompPeriod::setN Method
CompPeriod::setNDrop Method
CompPeriod::setNElapsed Method
Collapse Expand Config Class
Config Members
Config::Config Constructor
Config::~Config Destructor
Collapse Expand Config Methods
Config::getLeftMargin Method
Config::getLongOutput Method
Config::getPrinterPoints Method
Config::getScreenPoints Method
Config::getTopMargin Method
Config::read Method
Config::setLeftMargin Method
Config::setLongOutput Method
Config::setPrinterPoints Method
Config::setScreenPoints Method
Config::setTopMargin Method
Config::write Method
Collapse Expand ConfigFile Class
ConfigFile Members
ConfigFile::ConfigFile Constructor
ConfigFile::~ConfigFile Destructor
Collapse Expand ConfigFile Methods
ConfigFile::read Method
ConfigFile::write Method
Collapse Expand ConfigNonFile Class
ConfigNonFile Members
ConfigNonFile::ConfigNonFile Constructor
ConfigNonFile::~ConfigNonFile Destructor
Collapse Expand ConfigNonFile Methods
ConfigNonFile::read Method
ConfigNonFile::write Method
Collapse Expand DibGuar Class
DibGuar Members
DibGuar::DibGuar Constructor
DibGuar::~DibGuar Destructor
Collapse Expand DibGuar Enumerations
DibGuar::ConvertedMfbType Enumeration
Collapse Expand DibGuar Methods
DibGuar::calculate Method
DibGuar::cessationMfbCal Method
DibGuar::convertedMfbTypeCal Method
DibGuar::dateCpiCal Method
DibGuar::entDeathDateCal Method
DibGuar::getCessationMfbConv Method
DibGuar::getCessationMfbOrig Method
DibGuar::getColasApply Method
DibGuar::getConvertedMfbType Method
DibGuar::getDiMaxApplies Method
DibGuar::getRawMfb Method
DibGuar::getRawPia Method
Collapse Expand isApplicable Method
DibGuar::isApplicable Method ()
DibGuar::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type)
DibGuar::yearCpi1Cal Method
Collapse Expand DibGuarLC Class
DibGuarLC Members
DibGuarLC::DibGuarLC Constructor
DibGuarLC::~DibGuarLC Destructor
Collapse Expand DibGuarLC Methods
Collapse Expand isApplicable Method
DibGuarLC::isApplicable Method ()
DibGuarLC::isApplicable Method (const DateMoyr&, const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type, const LawChangeArray&)
Collapse Expand DisabPeriod Class
DisabPeriod Members
DisabPeriod::DisabPeriod Constructor
Collapse Expand DisabPeriod Methods
DisabPeriod::cessationDateCheck Method
DisabPeriod::deleteCessationDate Method
DisabPeriod::deleteContents Method
DisabPeriod::deleteEntDate Method
DisabPeriod::deleteOnsetDate Method
DisabPeriod::deleteWaitperDate Method
DisabPeriod::entDateCheck Method
DisabPeriod::getCessationDate Method
DisabPeriod::getCessationMfb Method
DisabPeriod::getCessationPia Method
DisabPeriod::getEntDate Method
DisabPeriod::getOnsetDate Method
DisabPeriod::getWaitperDate Method
DisabPeriod::onsetDateCheck Method
DisabPeriod::parseString Method
DisabPeriod::setCessationDate Method
DisabPeriod::setCessationMfb Method
DisabPeriod::setCessationPia Method
DisabPeriod::setEntDate Method
DisabPeriod::setOnsetDate Method
DisabPeriod::setWaitperDate Method
Collapse Expand toString Method
DisabPeriod::toString Method ()
DisabPeriod::toString Method (const std::string&)
DisabPeriod::waitperDateCal Method
DisabPeriod::waitperDateCheck Method
Collapse Expand DisabPeriod Friends
friend class boost::serialization::access Friend
Collapse Expand DisInsCode Class
DisInsCode Members
Collapse Expand DisInsCode Constructor
DisInsCode::DisInsCode Constructor ()
DisInsCode::DisInsCode Constructor (DisInsCodeType)
Collapse Expand DisInsCode Enumerations
DisInsCode::DisInsCodeType Enumeration
Collapse Expand DisInsCode Methods
DisInsCode::ChartoCode Method
DisInsCode::get Method
DisInsCode::isDiBenie Method
DisInsCode::isDisabilityInsured Method
DisInsCode::set Method
Collapse Expand toChar Method
DisInsCode::toChar Method ()
DisInsCode::toChar Method (DisInsCodeType)
Collapse Expand DisInsCode Operators
DisInsCode::== Operator
Collapse Expand DisInsCodeArray Class
DisInsCodeArray Members
DisInsCodeArray::DisInsCodeArray Constructor
Collapse Expand DisInsCodeArray Methods
Collapse Expand assign Method
DisInsCodeArray::assign Method (const DisInsCode&, int, int)
DisInsCodeArray::assign Method (const DisInsCodeArray&, int, int)
DisInsCodeArray::deleteContents Method
DisInsCodeArray::getFirstYear Method
DisInsCodeArray::getLastYear Method
DisInsCodeArray::isNonzero Method
DisInsCodeArray::setFirstYear Method
DisInsCodeArray::setLastYear Method
DisInsCodeArray::toString Method
Collapse Expand DisInsCodeArray Operators
Collapse Expand [] Operator
DisInsCodeArray::[] Operator (int)
DisInsCodeArray::[] Operator (int)
Collapse Expand EarnProject Class
EarnProject Members
EarnProject::EarnProject Constructor
EarnProject::~EarnProject Destructor
Collapse Expand EarnProject Enumerations
EarnProject::earn_proj_type Enumeration
EarnProject::earn_type Enumeration
Collapse Expand EarnProject Data Members
EarnProject::PERC_HIGH Data Member
EarnProject::PERC_LOW Data Member
EarnProject::earnpebs Data Member
Collapse Expand EarnProject Methods
EarnProject::anyEntered Method
EarnProject::deleteContents Method
EarnProject::earnpebsCheck Method
EarnProject::earntypeCheck Method
EarnProject::getEarntype Method
EarnProject::getFirstYear Method
EarnProject::getLastYear Method
EarnProject::getPercback Method
EarnProject::getPercfwrd Method
EarnProject::getProjback Method
EarnProject::getProjfwrd Method
EarnProject::ibegin2Check Method
EarnProject::ibeginCheck Method
EarnProject::iendCheck Method
EarnProject::need_aw Method
EarnProject::percbackCheck Method
EarnProject::percfwrdCheck Method
EarnProject::projbackCheck1 Method
EarnProject::projbackCheck2 Method
EarnProject::project Method
EarnProject::projfwrdCheck1 Method
EarnProject::projfwrdCheck2 Method
EarnProject::setEarnpebs Method
EarnProject::setEarntype Method
EarnProject::setFirstYear Method
EarnProject::setLastYear Method
EarnProject::setPebsData Method
EarnProject::setPebsEarn Method
EarnProject::setPercback Method
EarnProject::setPercfwrd Method
EarnProject::setProjback Method
EarnProject::setProjfwrd Method
EarnProject::toString Method
Collapse Expand yearsCheck Method
EarnProject::yearsCheck Method (int, int)
EarnProject::yearsCheck Method (int, int, int, int)
EarnProject::zeroEarn Method
Collapse Expand FieldOfficeInfo Class
FieldOfficeInfo Members
FieldOfficeInfo::FieldOfficeInfo Constructor
FieldOfficeInfo::~FieldOfficeInfo Destructor
Collapse Expand FieldOfficeInfo Data Members
FieldOfficeInfo::numLines Data Member
Collapse Expand FieldOfficeInfo Methods
FieldOfficeInfo::getAddress Method
FieldOfficeInfo::getFieldOfficeName Method
FieldOfficeInfo::getFieldOfficeTitle Method
FieldOfficeInfo::read Method
FieldOfficeInfo::setAddress Method
FieldOfficeInfo::setData Method
FieldOfficeInfo::setFieldOfficeName Method
FieldOfficeInfo::setFieldOfficeTitle Method
FieldOfficeInfo::write Method
Collapse Expand FieldOfficeInfoFile Class
FieldOfficeInfoFile Members
FieldOfficeInfoFile::FieldOfficeInfoFile Constructor
FieldOfficeInfoFile::~FieldOfficeInfoFile Destructor
Collapse Expand FieldOfficeInfoFile Methods
FieldOfficeInfoFile::read Method
FieldOfficeInfoFile::setData Method
FieldOfficeInfoFile::write Method
Collapse Expand FieldOfficeInfoNonFile Class
FieldOfficeInfoNonFile Members
FieldOfficeInfoNonFile::FieldOfficeInfoNonFile Constructor
FieldOfficeInfoNonFile::~FieldOfficeInfoNonFile Destructor
Collapse Expand FieldOfficeInfoNonFile Methods
FieldOfficeInfoNonFile::read Method
FieldOfficeInfoNonFile::setData Method
FieldOfficeInfoNonFile::write Method
Collapse Expand FreezeYears Class
FreezeYears Members
FreezeYears::FreezeYears Constructor
Collapse Expand FreezeYears Methods
FreezeYears::deleteContents Method
FreezeYears::getYear1 Method
FreezeYears::getYear2 Method
FreezeYears::getYear3 Method
FreezeYears::getYear4 Method
FreezeYears::hasYears1 Method
FreezeYears::hasYears2 Method
FreezeYears::isFreezeYear Method
FreezeYears::setYear1 Method
FreezeYears::setYear2 Method
FreezeYears::setYear3 Method
FreezeYears::setYear4 Method
Collapse Expand FrozMin Class
FrozMin Members
FrozMin::FrozMin Constructor
FrozMin::~FrozMin Destructor
Collapse Expand FrozMin Methods
FrozMin::calculate Method
Collapse Expand isApplicable Method
FrozMin::isApplicable Method ()
FrozMin::isApplicable Method (const WorkerDataGeneral&, const PiaData&)
FrozMin::setFrozMin Method
Collapse Expand InsCode Class
InsCode Members
Collapse Expand InsCode Constructor
InsCode::InsCode Constructor ()
InsCode::InsCode Constructor (InsCodeType)
Collapse Expand InsCode Enumerations
InsCode::InsCodeType Enumeration
Collapse Expand InsCode Methods
InsCode::ChartoCode Method
InsCode::get Method
InsCode::isCurrentlyInsured Method
InsCode::isFullyInsured Method
InsCode::isFullyOrCurrentlyInsured Method
InsCode::isFullyOrTotalInsured Method
InsCode::isPermanentlyInsured Method
InsCode::set Method
Collapse Expand toChar Method
InsCode::toChar Method ()
InsCode::toChar Method (InsCodeType)
Collapse Expand InsCode Operators
InsCode::== Operator
Collapse Expand InsCodeArray Class
InsCodeArray Members
InsCodeArray::InsCodeArray Constructor
Collapse Expand InsCodeArray Methods
Collapse Expand assign Method
InsCodeArray::assign Method (const InsCode&, int, int)
InsCodeArray::assign Method (const InsCodeArray&, int, int)
InsCodeArray::deleteContents Method
InsCodeArray::getFirstYear Method
InsCodeArray::getLastYear Method
InsCodeArray::isNonzero Method
InsCodeArray::setFirstYear Method
InsCodeArray::setLastYear Method
InsCodeArray::toString Method
Collapse Expand InsCodeArray Operators
Collapse Expand [] Operator
InsCodeArray::[] Operator (int)
InsCodeArray::[] Operator (int)
Collapse Expand LawChange Class
LawChange Members
Collapse Expand LawChange Constructor
LawChange::LawChange Constructor ()
LawChange::LawChange Constructor (const std::string&)
LawChange::~LawChange Destructor
Collapse Expand LawChange Enumerations
LawChange::lawChangeType Enumeration
Collapse Expand LawChange Methods
LawChange::bendPointCheck Method
LawChange::bpincCheck Method
LawChange::constantPercCheck Method
LawChange::getEndYear Method
LawChange::getEndYearLC Method
LawChange::getFirstLine Method
LawChange::getInd Method
LawChange::getPhaseType Method
LawChange::getStartYear Method
LawChange::getStartYearLC Method
LawChange::getTitle Method
LawChange::isEffective Method
LawChange::percCheck Method
LawChange::prepareStrings Method
LawChange::proportionBendPointsCheck Method
LawChange::read Method
LawChange::setEndYear Method
LawChange::setEndYearLC Method
LawChange::setInd Method
LawChange::setPhaseType Method
LawChange::setStartYear Method
LawChange::setStartYearLC Method
LawChange::startCheck Method
LawChange::write Method
LawChange::writeFirstLine Method
Collapse Expand LawChangeAGE65COMP Class
LawChangeAGE65COMP Members
LawChangeAGE65COMP::LawChangeAGE65COMP Constructor
Collapse Expand LawChangeAGE65COMP Methods
LawChangeAGE65COMP::getStep Method
LawChangeAGE65COMP::prepareStrings Method
LawChangeAGE65COMP::read Method
LawChangeAGE65COMP::setStep Method
LawChangeAGE65COMP::write Method
Collapse Expand LawChangeALLEARN Class
LawChangeALLEARN Members
LawChangeALLEARN::LawChangeALLEARN Constructor
Collapse Expand LawChangeALLEARN Methods
LawChangeALLEARN::getStep Method
LawChangeALLEARN::getYear Method
LawChangeALLEARN::prepareStrings Method
LawChangeALLEARN::read Method
LawChangeALLEARN::setStep Method
LawChangeALLEARN::setYear Method
LawChangeALLEARN::write Method
Collapse Expand LawChangeArray Class
LawChangeArray Members
LawChangeArray::LawChangeArray Constructor
LawChangeArray::~LawChangeArray Destructor
Collapse Expand LawChangeArray Data Members
LawChangeArray::lawChange Data Member
LawChangeArray::lawChangeAGE65COMP Data Member
LawChangeArray::lawChangeALLEARN Data Member
LawChangeArray::lawChangeBPFRACWAGE Data Member
LawChangeArray::lawChangeBPMINCONST Data Member
LawChangeArray::lawChangeBPSPECRATE Data Member
LawChangeArray::lawChangeCHILDCARECREDIT Data Member
LawChangeArray::lawChangeCHILDCAREDROPOUT Data Member
LawChangeArray::lawChangeCOLACHANGE Data Member
LawChangeArray::lawChangeDECLINEPERC Data Member
LawChangeArray::lawChangeDROPOUTCHG Data Member
LawChangeArray::lawChangeMARRLENGTH Data Member
LawChangeArray::lawChangeNEWFORMULA Data Member
LawChangeArray::lawChangeNEWSPECMIN Data Member
LawChangeArray::lawChangeNRACHANGE Data Member
LawChangeArray::lawChangePSAACCT Data Member
LawChangeArray::lawChangeTAXBENCHG Data Member
LawChangeArray::lawChangeTAXRATECHG Data Member
LawChangeArray::lawChangeWAGEBASECHG Data Member
LawChangeArray::lawChangeWIDFACTOR Data Member
LawChangeArray::lawChangeWIFEFACTOR Data Member
Collapse Expand LawChangeArray Methods
LawChangeArray::getIndTotal Method
LawChangeArray::indTotalCal Method
Collapse Expand LawChangeBPFRACWAGE Class
LawChangeBPFRACWAGE Members
LawChangeBPFRACWAGE::LawChangeBPFRACWAGE Constructor
Collapse Expand LawChangeBPFRACWAGE Methods
LawChangeBPFRACWAGE::getProportionBendPoints Method
LawChangeBPFRACWAGE::prepareStrings Method
LawChangeBPFRACWAGE::read Method
LawChangeBPFRACWAGE::setProportionBendPoints Method
LawChangeBPFRACWAGE::write Method
Collapse Expand LawChangeBPMINCONST Class
LawChangeBPMINCONST Members
LawChangeBPMINCONST::LawChangeBPMINCONST Constructor
Collapse Expand LawChangeBPMINCONST Methods
LawChangeBPMINCONST::getConstantPerc Method
LawChangeBPMINCONST::prepareStrings Method
LawChangeBPMINCONST::read Method
LawChangeBPMINCONST::setConstantPerc Method
LawChangeBPMINCONST::write Method
Collapse Expand LawChangeBPSPECRATE Class
LawChangeBPSPECRATE Members
LawChangeBPSPECRATE::LawChangeBPSPECRATE Constructor
Collapse Expand LawChangeBPSPECRATE Methods
LawChangeBPSPECRATE::getBendPiaInc Method
LawChangeBPSPECRATE::prepareStrings Method
LawChangeBPSPECRATE::read Method
LawChangeBPSPECRATE::setBendPiaInc Method
LawChangeBPSPECRATE::write Method
Collapse Expand LawChangeCHILDCARECREDIT Class
LawChangeCHILDCARECREDIT Members
LawChangeCHILDCARECREDIT::LawChangeCHILDCARECREDIT Constructor
Collapse Expand LawChangeCHILDCARECREDIT Methods
LawChangeCHILDCARECREDIT::getAvgEarnPct Method
LawChangeCHILDCARECREDIT::getChildCareYearsBeforeEffYear Method
LawChangeCHILDCARECREDIT::getFqRatio Method
LawChangeCHILDCARECREDIT::getMaxAge Method
LawChangeCHILDCARECREDIT::getMaxYears Method
LawChangeCHILDCARECREDIT::getNumDropExtremeEarnYears Method
LawChangeCHILDCARECREDIT::getNumTopEarnYears Method
LawChangeCHILDCARECREDIT::prepareStrings Method
LawChangeCHILDCARECREDIT::read Method
LawChangeCHILDCARECREDIT::setAvgEarnPct Method
LawChangeCHILDCARECREDIT::setChildCareYearsBeforeEffYear Method
LawChangeCHILDCARECREDIT::setFqRatio Method
LawChangeCHILDCARECREDIT::setMaxAge Method
LawChangeCHILDCARECREDIT::setMaxYears Method
LawChangeCHILDCARECREDIT::setNumDropExtremeEarnYears Method
LawChangeCHILDCARECREDIT::setNumTopEarnYears Method
LawChangeCHILDCARECREDIT::write Method
Collapse Expand LawChangeCHILDCAREDROPOUT Class
LawChangeCHILDCAREDROPOUT Members
LawChangeCHILDCAREDROPOUT::LawChangeCHILDCAREDROPOUT Constructor
Collapse Expand LawChangeCHILDCAREDROPOUT Methods
LawChangeCHILDCAREDROPOUT::getFqRatio Method
LawChangeCHILDCAREDROPOUT::getMaxAge Method
LawChangeCHILDCAREDROPOUT::getMaxYears Method
LawChangeCHILDCAREDROPOUT::prepareStrings Method
LawChangeCHILDCAREDROPOUT::read Method
LawChangeCHILDCAREDROPOUT::setFqRatio Method
LawChangeCHILDCAREDROPOUT::setMaxAge Method
LawChangeCHILDCAREDROPOUT::setMaxYears Method
LawChangeCHILDCAREDROPOUT::write Method
Collapse Expand LawChangeCOLACHANGE Class
LawChangeCOLACHANGE Members
LawChangeCOLACHANGE::LawChangeCOLACHANGE Constructor
Collapse Expand LawChangeCOLACHANGE Methods
LawChangeCOLACHANGE::getColaAdj Method
LawChangeCOLACHANGE::getPiaPercentile Method
LawChangeCOLACHANGE::prepareStrings Method
LawChangeCOLACHANGE::read Method
LawChangeCOLACHANGE::setColaAdj Method
LawChangeCOLACHANGE::setPiaPercentile Method
LawChangeCOLACHANGE::write Method
Collapse Expand LawChangeDECLINEPERC Class
LawChangeDECLINEPERC Members
LawChangeDECLINEPERC::LawChangeDECLINEPERC Constructor
LawChangeDECLINEPERC::~LawChangeDECLINEPERC Destructor
Collapse Expand LawChangeDECLINEPERC Enumerations
LawChangeDECLINEPERC::DimLimits Enumeration
Collapse Expand LawChangeDECLINEPERC Methods
LawChangeDECLINEPERC::getAltPercPia Method
LawChangeDECLINEPERC::getFactor Method
LawChangeDECLINEPERC::getYear Method
LawChangeDECLINEPERC::percPiaCal Method
LawChangeDECLINEPERC::prepareStrings Method
LawChangeDECLINEPERC::read Method
LawChangeDECLINEPERC::setFactor Method
LawChangeDECLINEPERC::setYear Method
LawChangeDECLINEPERC::write Method
Collapse Expand LawChangeDROPOUTCHG Class
LawChangeDROPOUTCHG Members
LawChangeDROPOUTCHG::LawChangeDROPOUTCHG Constructor
Collapse Expand LawChangeDROPOUTCHG Methods
LawChangeDROPOUTCHG::getStep Method
LawChangeDROPOUTCHG::prepareStrings Method
LawChangeDROPOUTCHG::read Method
LawChangeDROPOUTCHG::setStep Method
LawChangeDROPOUTCHG::write Method
Collapse Expand LawChangeMARRLENGTH Class
LawChangeMARRLENGTH Members
LawChangeMARRLENGTH::LawChangeMARRLENGTH Constructor
Collapse Expand LawChangeMARRLENGTH Methods
LawChangeMARRLENGTH::getMarrLengthForDivBen Method
LawChangeMARRLENGTH::prepareStrings Method
LawChangeMARRLENGTH::read Method
LawChangeMARRLENGTH::setMarrLengthForDivBen Method
LawChangeMARRLENGTH::write Method
Collapse Expand LawChangeNEWFORMULA Class
LawChangeNEWFORMULA Members
LawChangeNEWFORMULA::LawChangeNEWFORMULA Constructor
LawChangeNEWFORMULA::~LawChangeNEWFORMULA Destructor
Collapse Expand LawChangeNEWFORMULA Methods
LawChangeNEWFORMULA::getAltBendPia Method
LawChangeNEWFORMULA::getAltPercPia Method
LawChangeNEWFORMULA::getNumBp Method
LawChangeNEWFORMULA::prepareStrings Method
LawChangeNEWFORMULA::read Method
LawChangeNEWFORMULA::setAltBendPia Method
LawChangeNEWFORMULA::setAltPercPia Method
LawChangeNEWFORMULA::setNumBp Method
LawChangeNEWFORMULA::write Method
Collapse Expand LawChangeNEWSPECMIN Class
LawChangeNEWSPECMIN Members
LawChangeNEWSPECMIN::LawChangeNEWSPECMIN Constructor
Collapse Expand LawChangeNEWSPECMIN Methods
LawChangeNEWSPECMIN::getAmount Method
LawChangeNEWSPECMIN::getPercent Method
LawChangeNEWSPECMIN::getYears Method
LawChangeNEWSPECMIN::prepareStrings Method
LawChangeNEWSPECMIN::read Method
LawChangeNEWSPECMIN::setAmount Method
LawChangeNEWSPECMIN::setPercent Method
LawChangeNEWSPECMIN::setYears Method
LawChangeNEWSPECMIN::write Method
Collapse Expand LawChangeNRACHANGE Class
LawChangeNRACHANGE Members
LawChangeNRACHANGE::LawChangeNRACHANGE Constructor
Collapse Expand LawChangeNRACHANGE Data Members
LawChangeNRACHANGE::ageArChange Data Member
LawChangeNRACHANGE::arMonthlyFactor67_69 Data Member
LawChangeNRACHANGE::arMonthlyFactor69Plus Data Member
Collapse Expand LawChangeNRACHANGE Methods
LawChangeNRACHANGE::prepareStrings Method
Collapse Expand LawChangeOut Class
LawChangeOut Members
LawChangeOut::LawChangeOut Constructor
LawChangeOut::~LawChangeOut Destructor
Collapse Expand LawChangeOut Data Members
LawChangeOut::lawChange Data Member
Collapse Expand LawChangeOut Methods
LawChangeOut::prepareStrings Method
Collapse Expand LawChangePSAACCT Class
LawChangePSAACCT Members
LawChangePSAACCT::LawChangePSAACCT Constructor
Collapse Expand LawChangePSAACCT Enumerations
LawChangePSAACCT::DimLimits Enumeration
Collapse Expand LawChangePSAACCT Methods
LawChangePSAACCT::getAdminFee Method
LawChangePSAACCT::getAnnIntRate Method
LawChangePSAACCT::getAnnuityOffset Method
LawChangePSAACCT::getAnnuityToDib Method
LawChangePSAACCT::getAnnuityType Method
LawChangePSAACCT::getBuysAnnuity Method
LawChangePSAACCT::getContribBps Method
LawChangePSAACCT::getContribDist Method
LawChangePSAACCT::getContribRates Method
LawChangePSAACCT::getContribStartAge Method
LawChangePSAACCT::getContribYears Method
LawChangePSAACCT::getInvestMean Method
LawChangePSAACCT::getInvestPerc Method
LawChangePSAACCT::getInvestStdDev Method
LawChangePSAACCT::getLumpSumAtFra Method
LawChangePSAACCT::getLumpSumPerc Method
LawChangePSAACCT::getMngmtFee Method
LawChangePSAACCT::getNumContribBps Method
LawChangePSAACCT::getPercToSpouse Method
LawChangePSAACCT::getRebalanceAccounts Method
LawChangePSAACCT::getTaxAnnuityInd Method
LawChangePSAACCT::getToSpouseOnDeathInd Method
LawChangePSAACCT::getUnisexInd Method
LawChangePSAACCT::prepareStrings Method
LawChangePSAACCT::read Method
LawChangePSAACCT::setAdminFee Method
LawChangePSAACCT::setAnnIntRate Method
LawChangePSAACCT::setAnnuityOffset Method
LawChangePSAACCT::setAnnuityToDib Method
LawChangePSAACCT::setAnnuityType Method
LawChangePSAACCT::setBuysAnnuity Method
LawChangePSAACCT::setContribBps Method
LawChangePSAACCT::setContribDist Method
LawChangePSAACCT::setContribRates Method
LawChangePSAACCT::setContribStartAge Method
LawChangePSAACCT::setContribYears Method
LawChangePSAACCT::setInvestMean Method
LawChangePSAACCT::setInvestPerc Method
LawChangePSAACCT::setInvestStdDev Method
LawChangePSAACCT::setLumpSumAtFra Method
LawChangePSAACCT::setLumpSumPerc Method
LawChangePSAACCT::setMngmtFee Method
LawChangePSAACCT::setNumContribBps Method
LawChangePSAACCT::setPercToSpouse Method
LawChangePSAACCT::setRebalanceAccounts Method
LawChangePSAACCT::setTaxAnnuityInd Method
LawChangePSAACCT::setToSpouseOnDeathInd Method
LawChangePSAACCT::setUnisexInd Method
LawChangePSAACCT::write Method
Collapse Expand LawChangeRead Class
LawChangeRead Members
LawChangeRead::LawChangeRead Constructor
Collapse Expand LawChangeRead Methods
Collapse Expand read Method
LawChangeRead::read Method ()
LawChangeRead::read Method (std::istream&)
Collapse Expand LawChangeTAXBENCHG Class
LawChangeTAXBENCHG Members
LawChangeTAXBENCHG::LawChangeTAXBENCHG Constructor
Collapse Expand LawChangeTAXBENCHG Methods
LawChangeTAXBENCHG::prepareStrings Method
Collapse Expand LawChangeTAXRATECHG Class
LawChangeTAXRATECHG Members
LawChangeTAXRATECHG::LawChangeTAXRATECHG Constructor
Collapse Expand LawChangeTAXRATECHG Enumerations
LawChangeTAXRATECHG::DimLimits Enumeration
Collapse Expand LawChangeTAXRATECHG Methods
LawChangeTAXRATECHG::getNumTaxrates Method
LawChangeTAXRATECHG::getTaxrate Method
LawChangeTAXRATECHG::getYearTaxrate Method
LawChangeTAXRATECHG::prepareStrings Method
LawChangeTAXRATECHG::read Method
LawChangeTAXRATECHG::setNumTaxrates Method
LawChangeTAXRATECHG::setSelfEmpTaxrate Method
LawChangeTAXRATECHG::setTaxrate Method
LawChangeTAXRATECHG::setYearTaxrate Method
LawChangeTAXRATECHG::write Method
Collapse Expand LawChangeWAGEBASECHG Class
LawChangeWAGEBASECHG Members
LawChangeWAGEBASECHG::LawChangeWAGEBASECHG Constructor
Collapse Expand LawChangeWAGEBASECHG Methods
LawChangeWAGEBASECHG::getBase77 Method
LawChangeWAGEBASECHG::getBaseOasdi Method
LawChangeWAGEBASECHG::prepareStrings Method
LawChangeWAGEBASECHG::read Method
LawChangeWAGEBASECHG::setBase77 Method
LawChangeWAGEBASECHG::setBaseOasdi Method
LawChangeWAGEBASECHG::write Method
Collapse Expand LawChangeWIDFACTOR Class
LawChangeWIDFACTOR Members
LawChangeWIDFACTOR::LawChangeWIDFACTOR Constructor
Collapse Expand LawChangeWIDFACTOR Data Members
LawChangeWIDFACTOR::newAgedWidFactor Data Member
LawChangeWIDFACTOR::numYears Data Member
Collapse Expand LawChangeWIDFACTOR Methods
LawChangeWIDFACTOR::prepareStrings Method
Collapse Expand LawChangeWIFEFACTOR Class
LawChangeWIFEFACTOR Members
LawChangeWIFEFACTOR::LawChangeWIFEFACTOR Constructor
Collapse Expand LawChangeWIFEFACTOR Data Members
LawChangeWIFEFACTOR::amtPerYear Data Member
LawChangeWIFEFACTOR::newSpouseFactor Data Member
Collapse Expand LawChangeWIFEFACTOR Methods
LawChangeWIFEFACTOR::prepareStrings Method
Collapse Expand LawChangeWrite Class
LawChangeWrite Members
LawChangeWrite::LawChangeWrite Constructor
Collapse Expand LawChangeWrite Methods
Collapse Expand write Method
LawChangeWrite::write Method ()
LawChangeWrite::write Method (std::ostream&)
Collapse Expand MilServDates Class
MilServDates Members
MilServDates::MilServDates Constructor
MilServDates::~MilServDates Destructor
Collapse Expand MilServDates Data Members
MilServDates::amtPerMonth37_56 Data Member
MilServDates::amtPerQtr57_77 Data Member
MilServDates::amtPerYear78_01 Data Member
MilServDates::dec1950 Data Member
MilServDates::endDate Data Member
MilServDates::firstMilServDate Data Member
MilServDates::lastMilServDate Data Member
MilServDates::startDate Data Member
Collapse Expand MilServDates Methods
MilServDates::check Method
MilServDates::deleteContents Method
Collapse Expand endDateCheck Method
MilServDates::endDateCheck Method ()
MilServDates::endDateCheck Method (const DateMoyr&)
MilServDates::getCount1 Method
MilServDates::getCount2 Method
MilServDates::getDatesString Method
MilServDates::getEarn Method
MilServDates::getEarn3750 Method
MilServDates::getQc3750 Method
MilServDates::getQcov Method
MilServDates::getType Method
MilServDates::parseDates Method
MilServDates::parseLine Method
MilServDates::setCount1 Method
MilServDates::setCount2 Method
MilServDates::setType Method
Collapse Expand startDateCheck Method
MilServDates::startDateCheck Method ()
MilServDates::startDateCheck Method (const DateMoyr&)
Collapse Expand toString Method
MilServDates::toString Method ()
MilServDates::toString Method (const std::string&)
Collapse Expand MilServDates Friends
friend class boost::serialization::access Friend
Collapse Expand MilServDatesVec Class
MilServDatesVec Members
MilServDatesVec::MilServDatesVec Constructor
MilServDatesVec::~MilServDatesVec Destructor
Collapse Expand MilServDatesVec Data Members
MilServDatesVec::MAX_MILSERVDATES Data Member
MilServDatesVec::msdates Data Member
Collapse Expand MilServDatesVec Methods
MilServDatesVec::check Method
MilServDatesVec::deleteContents Method
MilServDatesVec::getEarn Method
MilServDatesVec::getEarn3750 Method
MilServDatesVec::getFirstYear Method
MilServDatesVec::getLastYear Method
MilServDatesVec::getMSCount Method
MilServDatesVec::getQc3750 Method
MilServDatesVec::getQcov Method
MilServDatesVec::msCountCheck Method
MilServDatesVec::setMSCount Method
Collapse Expand MilServDatesVec Friends
friend class boost::serialization::access Friend
Collapse Expand OldPia Class
OldPia Members
OldPia::OldPia Constructor
OldPia::~OldPia Destructor
Collapse Expand OldPia Data Members
OldPia::iamemax Data Member
Collapse Expand OldPia Methods
OldPia::cpiBase Method
OldPia::mfbOldCal Method
OldPia::oldPiaCal Method
OldPia::pl1952 Method
OldPia::pl1954 Method
OldPia::pl1958 Method
OldPia::pl1965 Method
OldPia::pl1967 Method
OldPia::pl1969 Method
OldPia::pl1971 Method
OldPia::pl1972 Method
OldPia::pl1973 Method
OldPia::pl1973ext Method
Collapse Expand OldStart Class
OldStart Members
OldStart::OldStart Constructor
OldStart::~OldStart Destructor
Collapse Expand OldStart Enumerations
OldStart::OldStartType Enumeration
Collapse Expand OldStart Data Members
OldStart::INC_PER_YEAR Data Member
OldStart::bendMfb Data Member
OldStart::entDate Data Member
OldStart::percMfb Data Member
OldStart::portionAme Data Member
OldStart::portionPiaElig Data Member
Collapse Expand OldStart Methods
OldStart::calculate Method
OldStart::getAmeOs Method
OldStart::getDivisorOs Method
OldStart::getIncyrs Method
OldStart::getMethodOs Method
OldStart::getPib Method
OldStart::getPibInc Method
OldStart::imputeEarnings Method
OldStart::incrementCal Method
OldStart::incrementOldCal Method
OldStart::initialize Method
Collapse Expand isApplicable Method
OldStart::isApplicable Method ()
OldStart::isApplicable Method (const PiaData&)
OldStart::isOs1977_90 Method
OldStart::methodOsCal Method
OldStart::oldStart39Cal Method
OldStart::oldStart50Cal Method
OldStart::setAmeOs Method
OldStart::setDivisorOs Method
OldStart::setIncyrs Method
OldStart::setMethodOs Method
OldStart::setPib Method
OldStart::setPibInc Method
Collapse Expand OldStartLC Class
OldStartLC Members
OldStartLC::OldStartLC Constructor
OldStartLC::~OldStartLC Destructor
Collapse Expand OldStartLC Data Members
OldStartLC::lawChange Data Member
Collapse Expand OldStartLC Methods
Collapse Expand isApplicable Method
OldStartLC::isApplicable Method ()
OldStartLC::isApplicable Method (const DateMoyr&, const DateMoyr&, const PiaData&, const LawChangeArray&)
Collapse Expand Pebs Class
Pebs Members
Pebs::Pebs Constructor
Collapse Expand Pebs Enumerations
Pebs::pebes_type Enumeration
Collapse Expand Pebs Data Members
Pebs::age70 Data Member
Pebs::ageNow Data Member
Pebs::agePlan1 Data Member
Pebs::fullRetAge Data Member
Pebs::oab1 Data Member
Pebs::oab2 Data Member
Collapse Expand Pebs Methods
Pebs::agePlanCheck Method
Pebs::deleteContents Method
Pebs::getAgePlan Method
Pebs::getAgePlan2 Method
Pebs::getBenefitPebs Method
Pebs::getMfbPebs Method
Pebs::getMonthnow Method
Pebs::getPebsDib Method
Pebs::getPebsOab Method
Pebs::getPiaPebs Method
Pebs::getQcDisReq Method
Pebs::getQcDisTotal Method
Pebs::getQcDisYears Method
Pebs::getQcReq Method
Pebs::getQcTotal Method
Collapse Expand monthnowCheck Method
Pebs::monthnowCheck Method ()
Pebs::monthnowCheck Method (int)
Pebs::setAgePlan Method
Pebs::setAgePlan2 Method
Pebs::setBenefitPebs Method
Pebs::setMfbPebs Method
Collapse Expand setMonthnow Method
Pebs::setMonthnow Method ()
Pebs::setMonthnow Method (int)
Pebs::setPebsDib Method
Pebs::setPebsOab Method
Pebs::setPiaPebs Method
Pebs::setQcDisReq Method
Pebs::setQcDisTotal Method
Pebs::setQcDisYears Method
Pebs::setQcReq Method
Pebs::setQcTotal Method
Collapse Expand PercMfb Class
PercMfb Members
PercMfb::PercMfb Constructor
PercMfb::~PercMfb Destructor
Collapse Expand PercMfb Data Members
PercMfb::PERC Data Member
Collapse Expand PercMfb Methods
PercMfb::as_array Method
Collapse Expand begin Method
PercMfb::begin Method ()
PercMfb::begin Method ()
Collapse Expand end Method
PercMfb::end Method ()
PercMfb::end Method ()
PercMfb::max_size Method
PercMfb::reset Method
PercMfb::size Method
Collapse Expand PercMfb Operators
Collapse Expand [] Operator
PercMfb::[] Operator (std::size_t)
PercMfb::[] Operator (std::size_t)
Collapse Expand PercMfb Nested Types
PercMfb::const_iterator Nested Type
PercMfb::const_reference Nested Type
PercMfb::difference_type Nested Type
PercMfb::iterator Nested Type
PercMfb::reference Nested Type
PercMfb::size_type Nested Type
PercMfb::value_type Nested Type
Collapse Expand PercPia Class
PercPia Members
PercPia::PercPia Constructor
PercPia::~PercPia Destructor
Collapse Expand PercPia Data Members
PercPia::PERC Data Member
PercPia::WINDFALL_PERC Data Member
PercPia::WINDFALL_YEARS Data Member
Collapse Expand PercPia Methods
PercPia::as_array Method
Collapse Expand begin Method
PercPia::begin Method ()
PercPia::begin Method ()
Collapse Expand end Method
PercPia::end Method ()
PercPia::end Method ()
PercPia::getNumPerc Method
PercPia::max_size Method
PercPia::reset Method
PercPia::setNumPerc Method
PercPia::setWindfallPerc Method
PercPia::size Method
Collapse Expand PercPia Operators
Collapse Expand [] Operator
PercPia::[] Operator (std::size_t)
PercPia::[] Operator (std::size_t)
Collapse Expand PercPia Nested Types
PercPia::const_iterator Nested Type
PercPia::const_reference Nested Type
PercPia::difference_type Nested Type
PercPia::iterator Nested Type
PercPia::reference Nested Type
PercPia::size_type Nested Type
PercPia::value_type Nested Type
Collapse Expand PercPiaOut Class
PercPiaOut Members
Collapse Expand PercPiaOut Constructor
PercPiaOut::PercPiaOut Constructor (int)
PercPiaOut::PercPiaOut Constructor (int, int)
Collapse Expand PercPiaOut Methods
PercPiaOut::getNumPercs Method
PercPiaOut::getPercPia Method
PercPiaOut::setData Method
Collapse Expand PiaCal Class
PiaCal Members
PiaCal::PiaCal Constructor
PiaCal::~PiaCal Destructor
Collapse Expand PiaCal Data Members
PiaCal::childCareCalc Data Member
PiaCal::dibGuar Data Member
PiaCal::frozMin Data Member
PiaCal::highPiaMethod Data Member
PiaCal::oldStart Data Member
PiaCal::piaData Data Member
PiaCal::piaMethod Data Member
PiaCal::piaParams Data Member
PiaCal::piaTable Data Member
PiaCal::specMin Data Member
PiaCal::transGuar Data Member
PiaCal::wageInd Data Member
PiaCal::wageIndNonFreeze Data Member
PiaCal::widowMethod Data Member
PiaCal::workerData Data Member
Collapse Expand PiaCal Methods
PiaCal::ageEntCheck Method
Collapse Expand applyLifeMfb Method
PiaCal::applyLifeMfb Method (SecondaryArray&, int, int)
PiaCal::applyLifeMfb Method (SecondaryArray&, int, int, double, double, double)
PiaCal::applyMfb Method
Collapse Expand applySurvivorMfb Method
PiaCal::applySurvivorMfb Method (SecondaryArray&, int, int)
PiaCal::applySurvivorMfb Method (SecondaryArray&, int, int, double, double)
PiaCal::ardriAuxCal Method
PiaCal::ardriCal Method
PiaCal::calculate2 Method
PiaCal::dataCheck Method
PiaCal::dataCheckAux Method
PiaCal::deadIns Method
PiaCal::deemedInsCal Method
PiaCal::didropCal Method
PiaCal::didropNonFreezeCal Method
PiaCal::disInsCal Method
PiaCal::disInsNonFreezeCal Method
PiaCal::earnProjection Method
PiaCal::eligYearCal Method
PiaCal::eligYearCal1 Method
PiaCal::eligYearCal2 Method
PiaCal::eligYearCal3 Method
PiaCal::eligYearWidowCal Method
PiaCal::fins1Cal Method
PiaCal::fins2Cal Method
PiaCal::finsNonFreeze1Cal Method
PiaCal::finsNonFreeze2Cal Method
PiaCal::fullInsDateCal Method
PiaCal::getIoasdi Method
PiaCal::getPubpenEnable Method
Collapse Expand insCal Method
PiaCal::insCal Method (const WorkerDataGeneral&, PiaData&, WorkerDataGeneral::ben_type, const QtrYear&, int)
PiaCal::insCal Method (const boost::gregorian::date&, int)
Collapse Expand insNonFreezeCal Method
PiaCal::insNonFreezeCal Method (const WorkerDataGeneral&, PiaData&, WorkerDataGeneral::ben_type, const QtrYear&, int)
PiaCal::insNonFreezeCal Method (const boost::gregorian::date&, int)
PiaCal::isPebsAssumptions Method
PiaCal::monthsArAgedSpouseCal Method
PiaCal::monthsArCal Method
PiaCal::monthsArDICal Method
PiaCal::monthsArDisWidCal Method
PiaCal::monthsArWidCal Method
PiaCal::monthsDriCal Method
PiaCal::monthsYngLifeCal Method
PiaCal::monthsYngSurvCal Method
PiaCal::nCal Method
PiaCal::nDropCal Method
PiaCal::nDropNonFreezeCal Method
PiaCal::nNonFreezeCal Method
PiaCal::nelapsed2Cal Method
PiaCal::nelapsed2NonFreezeCal Method
Collapse Expand nelapsedCal Method
PiaCal::nelapsedCal Method (CompPeriod&, const DateMoyr&)
PiaCal::nelapsedCal Method (CompPeriod&, int)
Collapse Expand nelapsedNonFreezeCal Method
PiaCal::nelapsedNonFreezeCal Method (CompPeriod&, const DateMoyr&)
PiaCal::nelapsedNonFreezeCal Method (CompPeriod&, int)
PiaCal::piaCal Method
PiaCal::piaCal1 Method
PiaCal::piaCal2 Method
PiaCal::piaCal3 Method
PiaCal::qc3750simpCal Method
PiaCal::qcCal Method
PiaCal::qcCurrentCal Method
PiaCal::qcCurrentNonFreezeCal Method
PiaCal::qcReqCal Method
PiaCal::qcReqNonFreezeCal Method
PiaCal::qcReqPermCal Method
PiaCal::qcReqPermNonFreezeCal Method
PiaCal::reindWidCal Method
PiaCal::reindWidCalAll Method
PiaCal::relEarnPositionCal Method
PiaCal::releaseMemory Method
PiaCal::resetAmend90 Method
PiaCal::setAmend90 Method
PiaCal::setArfApp Method
PiaCal::setEligYearWidow Method
PiaCal::setHighMfb Method
PiaCal::setHighPia Method
PiaCal::setIoasdi Method
PiaCal::setPebsAssumptions Method
PiaCal::setPifc Method
PiaCal::setSupportPia Method
Collapse Expand widowCheck Method
PiaCal::widowCheck Method (WorkerDataGeneral&, Secondary&)
PiaCal::widowCheck Method (const boost::gregorian::date&, const boost::gregorian::date&, const DateMoyr&)
Collapse Expand PiaCalAny Class
PiaCalAny Members
PiaCalAny::PiaCalAny Constructor
PiaCalAny::~PiaCalAny Destructor
Collapse Expand PiaCalAny Data Members
PiaCalAny::earnProject Data Member
PiaCalAny::secondaryArray Data Member
PiaCalAny::userAssumptions Data Member
PiaCalAny::widowArray Data Member
PiaCalAny::widowDataArray Data Member
Collapse Expand PiaCalAny Methods
PiaCalAny::calculate1 Method
PiaCalAny::calculate2 Method
PiaCalAny::dataCheck Method
PiaCalAny::earnProSteady Method
PiaCalAny::earnProjection Method
PiaCalAny::pebsOabCal Method
PiaCalAny::pebsSetup Method
Collapse Expand PiaCalLC Class
PiaCalLC Members
PiaCalLC::PiaCalLC Constructor
PiaCalLC::~PiaCalLC Destructor
Collapse Expand PiaCalLC Methods
PiaCalLC::calculate2 Method
PiaCalLC::childCareCreditCal Method
PiaCalLC::childCareEarningsCal Method
PiaCalLC::childCareMaxCreditCal Method
PiaCalLC::childCareQcCal Method
PiaCalLC::earnProjection Method
PiaCalLC::earnProjectionStatic Method
PiaCalLC::nCal Method
PiaCalLC::nelapsed2Cal Method
PiaCalLC::nelapsed2NonFreezeCal Method
PiaCalLC::piaCal Method
PiaCalLC::reindWidCal Method
Collapse Expand PiaCalPL Class
PiaCalPL Members
PiaCalPL::PiaCalPL Constructor
PiaCalPL::~PiaCalPL Destructor
Collapse Expand PiaCalPL Methods
PiaCalPL::calculate2 Method
PiaCalPL::piaCal Method
PiaCalPL::reindWidCal Method
Collapse Expand PiaData Class
PiaData Members
PiaData::PiaData Constructor
PiaData::~PiaData Destructor
Collapse Expand PiaData Enumerations
PiaData::arf_app_type Enumeration
PiaData::earn_total_type Enumeration
Collapse Expand PiaData Data Members
PiaData::ageBen Data Member
PiaData::ageEnt Data Member
PiaData::childCareMaxCredit Data Member
PiaData::childCareOrder Data Member
PiaData::compPeriodNew Data Member
PiaData::compPeriodNewNonFreeze Data Member
PiaData::compPeriodOld Data Member
PiaData::disInsCode Data Member
PiaData::disInsNonFreezeCode Data Member
PiaData::earlyRetAge Data Member
PiaData::earnHi Data Member
PiaData::earnHiLimited Data Member
PiaData::earnMilServ Data Member
PiaData::earnOasdi Data Member
PiaData::earnOasdiLimited Data Member
PiaData::earnTotalized Data Member
PiaData::earnTotalizedLimited Data Member
PiaData::finsCode Data Member
PiaData::finsNonFreezeCode Data Member
PiaData::freezeYears Data Member
PiaData::fullRetAge Data Member
PiaData::highMfb Data Member
PiaData::highPia Data Member
PiaData::partialFreezeYears Data Member
PiaData::qcov Data Member
PiaData::qcovMilServ Data Member
PiaData::relEarnPosition Data Member
PiaData::roundedBenefit Data Member
PiaData::supportPia Data Member
PiaData::unroundedBenefit Data Member
Collapse Expand PiaData Methods
PiaData::deleteContents Method
PiaData::earn50Cal Method
PiaData::earnHiCal Method
PiaData::earnProjection Method
PiaData::earnTotal50Cal0 Method
PiaData::earnTotal50Cal1 Method
PiaData::earnYearCal Method
PiaData::freezeYearsCal Method
PiaData::getAmend90 Method
PiaData::getArf Method
PiaData::getArfApp Method
PiaData::getBirthDateMinus1 Method
PiaData::getChildCareMaxCredit Method
PiaData::getChildCareYearsTotal Method
PiaData::getDeemedQcReq Method
PiaData::getEarn3750ms Method
PiaData::getEarn50 Method
PiaData::getEarnTotal50 Method
PiaData::getEarnYear Method
PiaData::getEligDate Method
PiaData::getEligYear Method
PiaData::getEligYearNonFreeze Method
PiaData::getFinsCode2 Method
PiaData::getFinsNonFreezeCode2 Method
PiaData::getFirstQcYear Method
PiaData::getFullInsDate Method
PiaData::getFullRetDate Method
PiaData::getIappn Method
PiaData::getIapps Method
PiaData::getIbeginAll Method
PiaData::getIbeginTotal Method
PiaData::getIendAll Method
PiaData::getIendTotal Method
PiaData::getLastQcYear Method
PiaData::getMonthsArdri Method
PiaData::getOverMax Method
PiaData::getPifc Method
PiaData::getPubpenApp Method
PiaData::getQc3750ms Method
PiaData::getQc3750simp Method
PiaData::getQcCurrent Method
PiaData::getQcCurrentNonFreeze Method
PiaData::getQcDisDate1 Method
PiaData::getQcDisDate2 Method
PiaData::getQcDisDate3 Method
PiaData::getQcDisDate4 Method
PiaData::getQcDisDate5 Method
PiaData::getQcDisDate6 Method
PiaData::getQcDisDateNonFreeze1 Method
PiaData::getQcDisDateNonFreeze2 Method
PiaData::getQcDisQtr Method
PiaData::getQcDisQtr2 Method
PiaData::getQcDisQtrNonFreeze Method
PiaData::getQcDisReq Method
PiaData::getQcDisReqNonFreeze Method
PiaData::getQcDisYears Method
PiaData::getQcDisYearsNonFreeze Method
PiaData::getQcReq Method
PiaData::getQcReqNonFreeze Method
PiaData::getQcReqPerm Method
PiaData::getQcReqPermNonFreeze Method
PiaData::getQcTotal Method
PiaData::getQcTotal50 Method
PiaData::getQcTotal51 Method
PiaData::getQcTotal51NonFreeze Method
PiaData::getQcTotalDis Method
PiaData::getQcTotalDisNonFreeze Method
PiaData::getQcTotalNonFreeze Method
PiaData::getQcTotalRel Method
PiaData::getRelEarnPositionAverage Method
PiaData::initialize Method
PiaData::qcCal Method
PiaData::qcDiSpec Method
PiaData::qcDiSpecNonFreeze Method
PiaData::qcDisCal Method
PiaData::qcDisNonFreezeCal Method
PiaData::qcDisReq2Cal Method
PiaData::qcDisReqCal Method
PiaData::qcDisReqNonFreezeCal Method
PiaData::qcTotalCal Method
PiaData::qcTotalNonFreezeCal Method
PiaData::setAmend90 Method
PiaData::setArf Method
PiaData::setArfApp Method
PiaData::setBirthDateMinus1 Method
PiaData::setChildCareYearsTotal Method
PiaData::setDeemedQcReq Method
PiaData::setDoEarlyQcs Method
PiaData::setEarn3750ms Method
PiaData::setEligDate Method
PiaData::setEligYear Method
PiaData::setEligYearNonFreeze Method
PiaData::setFinsCode2 Method
PiaData::setFinsNonFreezeCode2 Method
PiaData::setFullInsDate Method
PiaData::setFullRetDate Method
PiaData::setIappn Method
PiaData::setIapps Method
PiaData::setIbeginTotal Method
PiaData::setIendTotal Method
PiaData::setMonthsArdri Method
PiaData::setOverMax Method
PiaData::setPifc Method
PiaData::setQc3 Method
PiaData::setQc3750ms Method
PiaData::setQc3750simp Method
PiaData::setQcCurrent Method
PiaData::setQcCurrentNonFreeze Method
PiaData::setQcReq Method
PiaData::setQcReqNonFreeze Method
PiaData::setQcReqPerm Method
PiaData::setQcReqPermNonFreeze Method
PiaData::setQcTotal Method
PiaData::setQcTotal50 Method
PiaData::setQcTotalNonFreeze Method
PiaData::setQcTotalRel Method
PiaData::setRelEarnPositionAverage Method
PiaData::updateMilServ Method
Collapse Expand PiaData Operators
PiaData::= Operator
Collapse Expand PiaDataArray Class
PiaDataArray Members
PiaDataArray::PiaDataArray Constructor
PiaDataArray::~PiaDataArray Destructor
Collapse Expand PiaDataArray Enumerations
PiaDataArray::DimLimits Enumeration
Collapse Expand PiaDataArray Data Members
PiaDataArray::piaData Data Member
Collapse Expand PiaDataArray Methods
PiaDataArray::deleteContents Method
PiaDataArray::famSizeCheck Method
PiaDataArray::getFamSize Method
PiaDataArray::setFamSize Method
Collapse Expand PiaMethod Class
PiaMethod Members
PiaMethod::PiaMethod Constructor
PiaMethod::~PiaMethod Destructor
Collapse Expand PiaMethod Enumerations
PiaMethod::WindfallElimType Enumeration
PiaMethod::app_type Enumeration
PiaMethod::cpi_year_type Enumeration
PiaMethod::dis_mfb_cap_type Enumeration
PiaMethod::pia_type Enumeration
PiaMethod::table_type Enumeration
Collapse Expand PiaMethod Data Members
PiaMethod::earnIndexed Data Member
PiaMethod::earnMultiplied Data Member
PiaMethod::iorder Data Member
PiaMethod::mfbElig Data Member
PiaMethod::mfbEnt Data Member
PiaMethod::mfbsub Data Member
PiaMethod::piaData Data Member
PiaMethod::piaElig Data Member
PiaMethod::piaEnt Data Member
PiaMethod::piaParams Data Member
PiaMethod::piasub Data Member
PiaMethod::workerData Data Member
PiaMethod::yearCpi Data Member
Collapse Expand PiaMethod Methods
PiaMethod::applyColas Method
PiaMethod::applyColasElig Method
PiaMethod::calculate Method
PiaMethod::diMax Method
PiaMethod::diMaxNonFreeze Method
PiaMethod::dimaxElig Method
PiaMethod::getAme Method
PiaMethod::getAmeTotal Method
PiaMethod::getApplicable Method
PiaMethod::getCap Method
PiaMethod::getCpiYear Method
PiaMethod::getIndCap Method
PiaMethod::getIoasdi Method
PiaMethod::getMethod Method
PiaMethod::getPiaEligTotal Method
PiaMethod::getPiaTotal Method
PiaMethod::getPiaWindfall Method
PiaMethod::getTableNum Method
PiaMethod::getTitle Method
PiaMethod::getWindfall Method
PiaMethod::getYearsTotal Method
PiaMethod::getftearn Method
PiaMethod::initialize Method
PiaMethod::isApplicable Method
PiaMethod::isPebsAssumptions Method
PiaMethod::mfbCal Method
PiaMethod::orderEarnings Method
PiaMethod::prorate Method
PiaMethod::setAme Method
PiaMethod::setAmeTotal Method
PiaMethod::setApplicable Method
PiaMethod::setCap Method
PiaMethod::setDirty Method
PiaMethod::setIndCap Method
PiaMethod::setIoasdi Method
PiaMethod::setPebsAssumptions Method
PiaMethod::setPiaEligTotal Method
PiaMethod::setPiaTotal Method
PiaMethod::setPiaWindfall Method
PiaMethod::setPortionPiaElig Method
PiaMethod::setTableNum Method
PiaMethod::setYearCpi Method
PiaMethod::setftearn Method
Collapse Expand specMinYearsCal Method
PiaMethod::specMinYearsCal Method (double, const DoubleAnnual&, int, const DoubleAnnual&)
PiaMethod::specMinYearsCal Method (double, const DoubleAnnual&, int, const DoubleAnnual&, IntAnnual&)
PiaMethod::specMinYearsTotalCal Method
PiaMethod::totalEarnCal Method
PiaMethod::wep_app Method
Collapse Expand PiaParams Class
PiaParams Members
Collapse Expand PiaParams Constructor
PiaParams::PiaParams Constructor (int)
PiaParams::PiaParams Constructor (int, int)
PiaParams::~PiaParams Destructor
Collapse Expand PiaParams Enumerations
PiaParams::SPECMINPERCTYPE Enumeration
Collapse Expand PiaParams Data Members
PiaParams::YEAR1999 Data Member
PiaParams::age16 Data Member
PiaParams::age18 Data Member
PiaParams::age19 Data Member
PiaParams::age199 Data Member
PiaParams::age22 Data Member
PiaParams::age50 Data Member
PiaParams::age60 Data Member
PiaParams::age62 Data Member
PiaParams::age621 Data Member
PiaParams::age65 Data Member
PiaParams::age65_10 Data Member
PiaParams::age65_2 Data Member
PiaParams::age65_4 Data Member
PiaParams::age65_6 Data Member
PiaParams::age65_8 Data Member
PiaParams::age66 Data Member
PiaParams::age66_10 Data Member
PiaParams::age66_2 Data Member
PiaParams::age66_4 Data Member
PiaParams::age66_6 Data Member
PiaParams::age66_8 Data Member
PiaParams::age67 Data Member
PiaParams::age70 Data Member
PiaParams::age72 Data Member
PiaParams::age75 Data Member
PiaParams::amend01 Data Member
PiaParams::amend118_273 Data Member
PiaParams::amend50 Data Member
PiaParams::amend52 Data Member
PiaParams::amend54 Data Member
PiaParams::amend56 Data Member
PiaParams::amend561 Data Member
PiaParams::amend562 Data Member
PiaParams::amend58 Data Member
PiaParams::amend61 Data Member
PiaParams::amend611 Data Member
PiaParams::amend612 Data Member
PiaParams::amend651 Data Member
PiaParams::amend652 Data Member
PiaParams::amend653 Data Member
PiaParams::amend671 Data Member
PiaParams::amend672 Data Member
PiaParams::amend69 Data Member
PiaParams::amend70 Data Member
PiaParams::amend721 Data Member
PiaParams::amend722 Data Member
PiaParams::amend741 Data Member
PiaParams::amend742 Data Member
PiaParams::amend771 Data Member
PiaParams::amend772 Data Member
PiaParams::amend80 Data Member
PiaParams::amend811 Data Member
PiaParams::amend812 Data Member
PiaParams::amend813 Data Member
PiaParams::amend82 Data Member
PiaParams::amend83 Data Member
PiaParams::amend88 Data Member
PiaParams::amend90 Data Member
PiaParams::amtperincyr Data Member
PiaParams::arFactorWid285 Data Member
PiaParams::arMonthlyFactor65_67 Data Member
PiaParams::arMonthlyFactorOab62_65 Data Member
PiaParams::arMonthlyFactorSpouse62_65 Data Member
PiaParams::baseHi Data Member
PiaParams::bendOS Data Member
PiaParams::beninc74 Data Member
PiaParams::bpMfbOut Data Member
PiaParams::bpPiaOut Data Member
PiaParams::catchup Data Member
PiaParams::cpiinc Data Member
PiaParams::factor150 Data Member
PiaParams::factor175 Data Member
PiaParams::factor50 Data Member
PiaParams::factor75 Data Member
PiaParams::factor825 Data Member
PiaParams::fq Data Member
PiaParams::fqinc Data Member
PiaParams::istart Data Member
PiaParams::maxMonthsAr62_65 Data Member
PiaParams::maxMonthsAr62_67 Data Member
PiaParams::maxMonthsAr65_67 Data Member
PiaParams::maxyear Data Member
PiaParams::monthBeninc Data Member
PiaParams::noChange Data Member
PiaParams::percOS Data Member
PiaParams::percPiaOut Data Member
PiaParams::percSpecMin Data Member
PiaParams::qcamt Data Member
PiaParams::qtr184 Data Member
PiaParams::recalcInd Data Member
PiaParams::specMinMfb Data Member
PiaParams::specMinMfb2001 Data Member
PiaParams::specMinPerc Data Member
PiaParams::specMinPia Data Member
PiaParams::specMinPia2001 Data Member
PiaParams::titleAw Data Member
PiaParams::titleBi Data Member
PiaParams::year37qtr1 Data Member
PiaParams::yocAmountSpecMin Data Member
PiaParams::yocAmountWindfall Data Member
Collapse Expand PiaParams Methods
Collapse Expand applyCola Method
PiaParams::applyCola Method (double, int)
PiaParams::applyCola Method (double, int, int)
PiaParams::applyCola99 Method
Collapse Expand applyColaMfb Method
PiaParams::applyColaMfb Method (double, int, double)
PiaParams::applyColaMfb Method (double, int, int, double)
PiaParams::applyColaMfb99 Method
PiaParams::benincCatchUp Method
PiaParams::birthDateFRA Method
PiaParams::childAgeForMFCal Method
PiaParams::deconvertPia Method
PiaParams::deemedQcReqCal Method
PiaParams::doRecalc Method
PiaParams::earlyAgeDisWidCal Method
PiaParams::earlyAgeOabCal Method
PiaParams::earlyAgeOabCalPL Method
PiaParams::earlyAgeWidCal Method
PiaParams::factorAgedSpouseCal Method
PiaParams::factorAgedSpouseCalPL Method
PiaParams::factorAgedWidCal Method
PiaParams::factorAgedWidCalPL Method
PiaParams::factorArAgedSpouseCal Method
PiaParams::factorArAgedSpouseCalPL Method
PiaParams::factorArCal Method
PiaParams::factorArCalPL Method
PiaParams::factorArDisWidCal Method
PiaParams::factorArWidCal Method
PiaParams::factorDisWidCal Method
PiaParams::factorDisWidCalPL Method
PiaParams::factorDriCal Method
PiaParams::factorYngLifeCal Method
PiaParams::factorYngSurvCal Method
PiaParams::fullRetAgeCal Method
PiaParams::fullRetAgeCalDI Method
PiaParams::fullRetAgeCalDIPL Method
PiaParams::fullRetAgeCalPL Method
PiaParams::getAverageWage Method
PiaParams::getBase77 Method
PiaParams::getBase77Array Method
PiaParams::getBaseHi Method
PiaParams::getBaseHiArray Method
PiaParams::getBaseOasdi Method
PiaParams::getBaseOasdiArray Method
PiaParams::getBendOS Method
PiaParams::getBenefitInc Method
PiaParams::getCatchup Method
PiaParams::getChildcareDropoutAmount Method
PiaParams::getChildcareDropoutAmountPL Method
PiaParams::getColaCap Method
PiaParams::getCpiinc Method
PiaParams::getCpiincArray Method
PiaParams::getFq Method
PiaParams::getFqArray Method
PiaParams::getFqBppia Method
PiaParams::getFqIndex Method
PiaParams::getFqinc Method
PiaParams::getFqincArray Method
PiaParams::getIstart Method
PiaParams::getMarrLengthForDivBen Method
PiaParams::getMarrLengthForDivBenPL Method
PiaParams::getMaxChildcareAge Method
PiaParams::getMaxChildcareAgePL Method
PiaParams::getMaxChildcareDropoutYears Method
PiaParams::getMaxChildcareDropoutYearsPL Method
PiaParams::getMaxyear Method
PiaParams::getMfbColaCap Method
PiaParams::getMonthBeninc Method
PiaParams::getMonthBenincArray Method
PiaParams::getPercOS Method
PiaParams::getPercSpecMin Method
PiaParams::getPercSpecMinArray Method
PiaParams::getSpecMinMfb Method
PiaParams::getSpecMinPerc Method
PiaParams::getSpecMinPia Method
PiaParams::getYocAmountSpecMin Method
PiaParams::getYocAmountSpecMinArray Method
PiaParams::getYocAmountWindfallArray Method
PiaParams::initdata Method
PiaParams::isApplicableCola99 Method
PiaParams::lastAmw Method
PiaParams::lumpSum Method
PiaParams::maxChildAge Method
PiaParams::maxDibAge Method
PiaParams::maxDibAgePL Method
PiaParams::monthsArAgedSpouseCal Method
PiaParams::monthsArCal Method
PiaParams::monthsArDICal Method
PiaParams::monthsArDisWidCal Method
PiaParams::monthsArWidCal Method
PiaParams::monthsDriCal Method
Collapse Expand needColaCap Method
PiaParams::needColaCap Method ()
PiaParams::needColaCap Method (int)
PiaParams::percPiaCal Method
PiaParams::projectCpiinc Method
PiaParams::projectFq Method
PiaParams::projectPerc Method
PiaParams::projectSpecMin Method
PiaParams::qcCal Method
PiaParams::resizeSpecMin Method
PiaParams::retCredit Method
PiaParams::ribLimCal Method
PiaParams::ribLimCalPL Method
PiaParams::setColaCap Method
PiaParams::setData Method
PiaParams::setHistFqinc Method
PiaParams::setIstart Method
PiaParams::setMfbColaCap Method
PiaParams::setNoChange Method
PiaParams::specMinAmountCal Method
PiaParams::specMinAmountCalPL Method
Collapse Expand specMinMaxYears Method
PiaParams::specMinMaxYears Method ()
PiaParams::specMinMaxYears Method (int, int)
PiaParams::specMinMaxYearsPL Method
Collapse Expand unApplyCola Method
PiaParams::unApplyCola Method (double, int)
PiaParams::unApplyCola Method (double, int, int)
PiaParams::unApplyCola99 Method
PiaParams::unbiCatchUp Method
Collapse Expand updateBases Method
PiaParams::updateBases Method ()
PiaParams::updateBases Method (const DoubleAnnual&, const DoubleAnnual&, BaseChangeType::change_type, int, int)
Collapse Expand updateCpiinc Method
PiaParams::updateCpiinc Method (const DoubleAnnual&, const Catchup&, const std::string&, int, int)
PiaParams::updateCpiinc Method (const DoubleAnnual&, const std::string&, int, int)
PiaParams::updateFq Method
PiaParams::updateFqinc Method
PiaParams::updateYocAmountSpecMin Method
Collapse Expand PiaParamsAny Class
PiaParamsAny Members
PiaParamsAny::PiaParamsAny Constructor
PiaParamsAny::~PiaParamsAny Destructor
Collapse Expand PiaParamsAny Methods
PiaParamsAny::getWageHigh Method
PiaParamsAny::getWageHighArray Method
PiaParamsAny::getWageMin Method
PiaParamsAny::getWageMinArray Method
PiaParamsAny::highProj Method
PiaParamsAny::minProj Method
PiaParamsAny::projectFq Method
Collapse Expand PiaParamsLC Class
PiaParamsLC Members
Collapse Expand PiaParamsLC Constructor
PiaParamsLC::PiaParamsLC Constructor (int, const LawChangeArray&)
PiaParamsLC::PiaParamsLC Constructor (int, int, AwbiData&, const LawChangeArray&)
PiaParamsLC::~PiaParamsLC Destructor
Collapse Expand PiaParamsLC Methods
Collapse Expand applyCola Method
PiaParamsLC::applyCola Method (double, int)
PiaParamsLC::applyCola Method (double, int, int)
Collapse Expand applyColaMfb Method
PiaParamsLC::applyColaMfb Method (double, int, double)
PiaParamsLC::applyColaMfb Method (double, int, int, double)
PiaParamsLC::earlyAgeOabCal Method
PiaParamsLC::factorAgedSpouseCal Method
PiaParamsLC::factorAgedWidCal Method
PiaParamsLC::factorArAgedSpouseCal Method
PiaParamsLC::factorArCal Method
PiaParamsLC::factorDisWidCal Method
PiaParamsLC::fullRetAgeCal Method
PiaParamsLC::fullRetAgeCalDI Method
PiaParamsLC::getBase77 Method
PiaParamsLC::getBase77Array Method
PiaParamsLC::getBaseOasdi Method
PiaParamsLC::getBaseOasdiArray Method
PiaParamsLC::getChildcareDropoutAmount Method
PiaParamsLC::getColaCap Method
PiaParamsLC::getCpiinc Method
PiaParamsLC::getCpiincArray Method
PiaParamsLC::getFqBppia Method
PiaParamsLC::getFqIndex Method
PiaParamsLC::getMarrLengthForDivBen Method
PiaParamsLC::getMaxChildcareAge Method
PiaParamsLC::getMaxChildcareDropoutYears Method
PiaParamsLC::getMfbColaCap Method
PiaParamsLC::getSpecMinMfb Method
PiaParamsLC::getSpecMinPia Method
PiaParamsLC::initdata Method
PiaParamsLC::maxDibAge Method
Collapse Expand needColaCap Method
PiaParamsLC::needColaCap Method ()
PiaParamsLC::needColaCap Method (int)
PiaParamsLC::projectCpiinc Method
PiaParamsLC::projectFq Method
PiaParamsLC::projectPerc Method
PiaParamsLC::projectSpecMin Method
PiaParamsLC::resizeSpecMin Method
PiaParamsLC::ribLimCal Method
PiaParamsLC::setAltCpiinc Method
PiaParamsLC::setColaCap Method
PiaParamsLC::setData Method
PiaParamsLC::setFqBppia Method
PiaParamsLC::setFqIndex Method
PiaParamsLC::setMfbColaCap Method
PiaParamsLC::specMinAmountCal Method
Collapse Expand specMinMaxYears Method
PiaParamsLC::specMinMaxYears Method ()
PiaParamsLC::specMinMaxYears Method (int, int)
Collapse Expand updateBases Method
PiaParamsLC::updateBases Method ()
PiaParamsLC::updateBases Method (const DoubleAnnual&, const DoubleAnnual&, BaseChangeType::change_type, int, int)
Collapse Expand PiaParamsLCTR Class
PiaParamsLCTR Members
PiaParamsLCTR::PiaParamsLCTR Constructor
PiaParamsLCTR::~PiaParamsLCTR Destructor
Collapse Expand PiaParamsPL Class
PiaParamsPL Members
Collapse Expand PiaParamsPL Constructor
PiaParamsPL::PiaParamsPL Constructor (int)
PiaParamsPL::PiaParamsPL Constructor (int, int, AwbiData&)
PiaParamsPL::~PiaParamsPL Destructor
Collapse Expand PiaParamsPL Methods
PiaParamsPL::earlyAgeOabCal Method
PiaParamsPL::factorAgedSpouseCal Method
PiaParamsPL::factorAgedWidCal Method
PiaParamsPL::factorArAgedSpouseCal Method
PiaParamsPL::factorArCal Method
PiaParamsPL::factorDisWidCal Method
PiaParamsPL::fullRetAgeCal Method
PiaParamsPL::fullRetAgeCalDI Method
PiaParamsPL::getBase77 Method
PiaParamsPL::getBase77Array Method
PiaParamsPL::getBaseOasdi Method
PiaParamsPL::getBaseOasdiArray Method
PiaParamsPL::getChildcareDropoutAmount Method
PiaParamsPL::getColaCap Method
PiaParamsPL::getFqBppia Method
PiaParamsPL::getFqIndex Method
PiaParamsPL::getMarrLengthForDivBen Method
PiaParamsPL::getMaxChildcareAge Method
PiaParamsPL::getMaxChildcareDropoutYears Method
PiaParamsPL::getMfbColaCap Method
PiaParamsPL::maxDibAge Method
Collapse Expand needColaCap Method
PiaParamsPL::needColaCap Method ()
PiaParamsPL::needColaCap Method (int)
PiaParamsPL::projectCpiinc Method
PiaParamsPL::ribLimCal Method
PiaParamsPL::setColaCap Method
PiaParamsPL::setData Method
PiaParamsPL::setMfbColaCap Method
PiaParamsPL::specMinAmountCal Method
Collapse Expand specMinMaxYears Method
PiaParamsPL::specMinMaxYears Method ()
PiaParamsPL::specMinMaxYears Method (int, int)
Collapse Expand updateBases Method
PiaParamsPL::updateBases Method ()
PiaParamsPL::updateBases Method (const DoubleAnnual&, const DoubleAnnual&, BaseChangeType::change_type, int, int)
Collapse Expand PiaParamsTR Class
PiaParamsTR Members
PiaParamsTR::PiaParamsTR Constructor
PiaParamsTR::~PiaParamsTR Destructor
Collapse Expand PiaParamsTR Data Members
PiaParamsTR::altNum Data Member
Collapse Expand PiaParamsTR Methods
PiaParamsTR::getAltNum Method
Collapse Expand PiaRead Class
PiaRead Members
PiaRead::PiaRead Constructor
Collapse Expand PiaRead Data Members
PiaRead::inputLine Data Member
PiaRead::lineType Data Member
PiaRead::secondaryArray Data Member
PiaRead::unusedLine Data Member
PiaRead::userAssumptions Data Member
PiaRead::widowArray Data Member
PiaRead::widowDataArray Data Member
PiaRead::workerData Data Member
Collapse Expand PiaRead Methods
PiaRead::getEarnWidth Method
PiaRead::getWidth Method
PiaRead::parseAssump Method
PiaRead::parseAw Method
PiaRead::parseBack Method
PiaRead::parseBases Method
PiaRead::parseBases77 Method
PiaRead::parseBendate Method
PiaRead::parseBi Method
PiaRead::parseBlind Method
PiaRead::parseCatchup Method
PiaRead::parseChildCareYears Method
PiaRead::parseDeath Method
PiaRead::parseDeemed Method
PiaRead::parseDisab1 Method
PiaRead::parseDisab2 Method
PiaRead::parseEarnHi Method
PiaRead::parseEarnOasdi Method
PiaRead::parseEarnType Method
PiaRead::parseFamilyMember Method
PiaRead::parseFwrd Method
PiaRead::parseMsdates Method
PiaRead::parseNhaddr Method
PiaRead::parseNhname Method
PiaRead::parseOabent Method
PiaRead::parsePebes Method
PiaRead::parsePubpen Method
PiaRead::parsePubpenReservist Method
PiaRead::parseQc1 Method
PiaRead::parseQc2 Method
PiaRead::parseSsn Method
PiaRead::parseTaxType Method
PiaRead::parseTitleaw Method
PiaRead::parseTitlebi Method
PiaRead::parseTob Method
PiaRead::parseTotalize Method
PiaRead::parseYears Method
PiaRead::read Method
PiaRead::setEarnProjectYears Method
PiaRead::setEarnWidth Method
PiaRead::setPebsData Method
PiaRead::setWidth Method
Collapse Expand PiaReadAny Class
PiaReadAny Members
PiaReadAny::PiaReadAny Constructor
Collapse Expand PiaReadAny Methods
PiaReadAny::parseBack Method
PiaReadAny::parseEarnOasdi Method
PiaReadAny::parseEarnType Method
PiaReadAny::parseFwrd Method
PiaReadAny::parsePebes Method
PiaReadAny::setEarnProjectYears Method
PiaReadAny::setPebsData Method
Collapse Expand PiaTable Class
PiaTable Members
PiaTable::PiaTable Constructor
PiaTable::~PiaTable Destructor
Collapse Expand PiaTable Methods
PiaTable::calculate Method
Collapse Expand isApplicable Method
PiaTable::isApplicable Method ()
PiaTable::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type)
Collapse Expand PiaTableLC Class
PiaTableLC Members
PiaTableLC::PiaTableLC Constructor
PiaTableLC::~PiaTableLC Destructor
Collapse Expand PiaTableLC Methods
Collapse Expand isApplicable Method
PiaTableLC::isApplicable Method ()
PiaTableLC::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type, const LawChangeArray&, const DateMoyr&)
Collapse Expand PiaWrite Class
PiaWrite Members
PiaWrite::PiaWrite Constructor
Collapse Expand PiaWrite Data Members
PiaWrite::secondaryArray Data Member
PiaWrite::userAssumptions Data Member
PiaWrite::widowArray Data Member
PiaWrite::widowDataArray Data Member
PiaWrite::workerData Data Member
Collapse Expand PiaWrite Methods
PiaWrite::getEarnWidth Method
PiaWrite::getNumDecimals Method
PiaWrite::getWidth Method
PiaWrite::setEarnWidth Method
PiaWrite::setNumDecimals Method
PiaWrite::setWidth Method
PiaWrite::write Method
PiaWrite::writeAssump Method
PiaWrite::writeAw Method
PiaWrite::writeBack Method
PiaWrite::writeBases Method
PiaWrite::writeBenDate Method
PiaWrite::writeBi Method
PiaWrite::writeBlind Method
PiaWrite::writeChildCareYears Method
PiaWrite::writeDeath Method
PiaWrite::writeDeemed Method
PiaWrite::writeDisab1 Method
PiaWrite::writeDisab2 Method
PiaWrite::writeEarnHi Method
PiaWrite::writeEarnOasdi Method
PiaWrite::writeEarnType Method
PiaWrite::writeFamilyMember Method
PiaWrite::writeFamilyMembers Method
PiaWrite::writeFwrd Method
PiaWrite::writeMsdates Method
PiaWrite::writeNhaddr Method
PiaWrite::writeNhname Method
PiaWrite::writeOabEnt Method
PiaWrite::writePebes Method
PiaWrite::writePubpen Method
PiaWrite::writePubpenReservist Method
PiaWrite::writeQc1 Method
PiaWrite::writeQc2 Method
PiaWrite::writeRailRoad Method
PiaWrite::writeSsn Method
PiaWrite::writeTaxType Method
PiaWrite::writeTob Method
PiaWrite::writeTotalize Method
PiaWrite::writeYears Method
Collapse Expand PiaWriteAny Class
PiaWriteAny Members
PiaWriteAny::PiaWriteAny Constructor
Collapse Expand PiaWriteAny Methods
PiaWriteAny::writeAssump Method
PiaWriteAny::writeBack Method
PiaWriteAny::writeEarnOasdi Method
PiaWriteAny::writeEarnType Method
PiaWriteAny::writeFwrd Method
PiaWriteAny::writePebes Method
Collapse Expand Pib50Mfb Class
Pib50Mfb Members
Collapse Expand Pib50Mfb Methods
Pib50Mfb::getAt Method
Collapse Expand Pib50Pib Class
Pib50Pib Members
Collapse Expand Pib50Pib Methods
Pib50Pib::getAt Method
Collapse Expand Pib52Ame Class
Pib52Ame Members
Collapse Expand Pib52Ame Methods
Pib52Ame::getAt Method
Collapse Expand Pib52Mfb Class
Pib52Mfb Members
Collapse Expand Pib52Mfb Methods
Pib52Mfb::getAt Method
Collapse Expand Pib54Ame Class
Pib54Ame Members
Collapse Expand Pib54Ame Methods
Pib54Ame::getAt Method
Collapse Expand Pib54Mfb Class
Pib54Mfb Members
Collapse Expand Pib54Mfb Methods
Pib54Mfb::getAt Method
Collapse Expand Pib54Pia Class
Pib54Pia Members
Collapse Expand Pib54Pia Methods
Pib54Pia::getAt Method
Collapse Expand Pib58Ame Class
Pib58Ame Members
Collapse Expand Pib58Ame Methods
Pib58Ame::getAt Method
Collapse Expand Pib58Pib Class
Pib58Pib Members
Collapse Expand Pib58Pib Methods
Pib58Pib::getAt Method
Collapse Expand Pifc Class
Pifc Members
Pifc::Pifc Constructor
Collapse Expand Pifc Methods
Pifc::get Method
Pifc::isColable Method
Pifc::isNewMfb Method
Pifc::pifcCal Method
Pifc::set Method
Collapse Expand PortionAime Class
PortionAime Members
PortionAime::PortionAime Constructor
PortionAime::~PortionAime Destructor
Collapse Expand PortionAime Methods
PortionAime::as_array Method
Collapse Expand begin Method
PortionAime::begin Method ()
PortionAime::begin Method ()
PortionAime::deleteContents Method
Collapse Expand end Method
PortionAime::end Method ()
PortionAime::end Method ()
PortionAime::getNumPart Method
PortionAime::max_size Method
PortionAime::setNumPart Method
PortionAime::size Method
Collapse Expand PortionAime Operators
Collapse Expand [] Operator
PortionAime::[] Operator (std::size_t)
PortionAime::[] Operator (std::size_t)
Collapse Expand PortionAime Nested Types
PortionAime::const_iterator Nested Type
PortionAime::const_reference Nested Type
PortionAime::difference_type Nested Type
PortionAime::iterator Nested Type
PortionAime::reference Nested Type
PortionAime::size_type Nested Type
PortionAime::value_type Nested Type
Collapse Expand PresValFacs Class
PresValFacs Members
PresValFacs::PresValFacs Constructor
PresValFacs::~PresValFacs Destructor
Collapse Expand PresValFacs Methods
PresValFacs::project Method
Collapse Expand Psa Class
Psa Members
Psa::Psa Constructor
Psa::~Psa Destructor
Collapse Expand Psa Enumerations
Psa::AnnuityType Enumeration
Psa::DimLimits Enumeration
Psa::InvestmentType Enumeration
Psa::PsaSexType Enumeration
Psa::UnisexType Enumeration
Collapse Expand Psa Data Members
Psa::contribAge Data Member
Psa::contribPerc Data Member
Collapse Expand Psa Methods
Psa::annuityCal Method
Psa::annuityRevCal Method
Psa::contribCal Method
Psa::getAdminFee Method
Psa::getAgeIndex Method
Psa::getContribRate Method
Psa::getInvestPerc Method
Psa::getLimitedYear Method
Psa::getMean Method
Psa::getMngmtFee Method
Psa::getPercToSpouse Method
Psa::getSexType Method
Psa::getStdDev Method
Psa::interpolateFactors Method
Psa::setParameters Method
Collapse Expand Qc Class
Qc Members
Collapse Expand Qc Data Members
Qc::MAXQCSINYEAR Data Member
Collapse Expand Qc Methods
Qc::check Method
Qc::qcCal Method
Collapse Expand Qcamt Class
Qcamt Members
Collapse Expand Qcamt Constructor
Qcamt::Qcamt Constructor (int)
Qcamt::Qcamt Constructor (int, int)
Qcamt::~Qcamt Destructor
Collapse Expand Qcamt Data Members
Qcamt::AUTO_YEAR Data Member
Qcamt::qcamt1977 Data Member
Qcamt::qcamt1978 Data Member
Collapse Expand Qcamt Methods
Qcamt::project Method
Collapse Expand QcArray Class
QcArray Members
Collapse Expand QcArray Constructor
QcArray::QcArray Constructor (const QcArray&)
QcArray::QcArray Constructor (int, int)
QcArray::~QcArray Destructor
Collapse Expand QcArray Methods
Collapse Expand accumulate Method
QcArray::accumulate Method (const QtrYear&, const QtrYear&, unsigned)
QcArray::accumulate Method (int, int, unsigned)
Collapse Expand assign Method
QcArray::assign Method (const QcArray &, int, int)
QcArray::assign Method (unsigned, int, int)
Collapse Expand deleteContents Method
QcArray::deleteContents Method ()
QcArray::deleteContents Method (int, int)
QcArray::get Method
QcArray::getLastYear Method
QcArray::set Method
QcArray::toString Method
Collapse Expand QcArray Friends
friend class boost::serialization::access Friend
Collapse Expand QcPacked Class
QcPacked Members
QcPacked::QcPacked Constructor
Collapse Expand QcPacked Data Members
QcPacked::NUM_QCS Data Member
Collapse Expand QcPacked Methods
QcPacked::get Method
QcPacked::set Method
Collapse Expand QcPacked Friends
friend class boost::serialization::access Friend
Collapse Expand RailRoadData Class
RailRoadData Members
RailRoadData::RailRoadData Constructor
RailRoadData::~RailRoadData Destructor
Collapse Expand RailRoadData Data Members
RailRoadData::earningsArray Data Member
RailRoadData::qcArray Data Member
Collapse Expand RailRoadData Methods
RailRoadData::deleteContents Method
RailRoadData::get3750String Method
RailRoadData::getDecadeEarningsString Method
RailRoadData::getDecades Method
RailRoadData::getEarn3750 Method
RailRoadData::getFirstYear Method
RailRoadData::getLastYear Method
RailRoadData::getQc3750 Method
RailRoadData::getQcString Method
RailRoadData::getYearsString Method
RailRoadData::isNonzero Method
RailRoadData::parse3750 Method
RailRoadData::parseEarnings Method
RailRoadData::parseQcs Method
RailRoadData::parseYears Method
RailRoadData::railroadYearCheck Method
RailRoadData::setEarn3750 Method
RailRoadData::setFirstYear Method
RailRoadData::setLastYear Method
RailRoadData::setQc3750 Method
Collapse Expand RailRoadData Operators
RailRoadData::= Operator
Collapse Expand RailRoadData Friends
friend class boost::serialization::access Friend
Collapse Expand ReindWid Class
ReindWid Members
ReindWid::ReindWid Constructor
ReindWid::~ReindWid Destructor
Collapse Expand ReindWid Data Members
ReindWid::secondary Data Member
ReindWid::widowData Data Member
ReindWid::widowPiaData Data Member
Collapse Expand ReindWid Methods
ReindWid::calculate Method
ReindWid::getEligYear Method
ReindWid::initialize Method
Collapse Expand isApplicable Method
ReindWid::isApplicable Method ()
ReindWid::isApplicable Method (const WorkerDataGeneral&, const PiaData&, int, const Secondary&)
ReindWid::setEligYear Method
Collapse Expand ReindWidLC Class
ReindWidLC Members
ReindWidLC::ReindWidLC Constructor
ReindWidLC::~ReindWidLC Destructor
Collapse Expand ReindWidLC Methods
Collapse Expand isApplicable Method
ReindWidLC::isApplicable Method ()
ReindWidLC::isApplicable Method (const WorkerDataGeneral&, const PiaData&, int, const Secondary&, const LawChangeArray&)
Collapse Expand RetireTest Class
RetireTest Members
Collapse Expand RetireTest Constructor
RetireTest::RetireTest Constructor (const PiaParams&, int)
RetireTest::RetireTest Constructor (const PiaParams&, int, int)
Collapse Expand RetireTest Data Members
RetireTest::rtea62 Data Member
RetireTest::rtea62m Data Member
RetireTest::rtea65 Data Member
RetireTest::rtea65m Data Member
RetireTest::rteaHigh Data Member
Collapse Expand RetireTest Methods
RetireTest::earningsTestCal Method
RetireTest::project Method
Collapse Expand Rtea62 Class
Rtea62 Members
Collapse Expand Rtea62 Constructor
Rtea62::Rtea62 Constructor (int)
Rtea62::Rtea62 Constructor (int, int)
Collapse Expand Rtea62m Class
Rtea62m Members
Collapse Expand Rtea62m Constructor
Rtea62m::Rtea62m Constructor (int)
Rtea62m::Rtea62m Constructor (int, int)
Collapse Expand Rtea62m Methods
Rtea62m::getFraction Method
Rtea62m::getHistAmount Method
Rtea62m::initialize Method
Rtea62m::project Method
Collapse Expand Rtea65 Class
Rtea65 Members
Collapse Expand Rtea65 Constructor
Rtea65::Rtea65 Constructor (int)
Rtea65::Rtea65 Constructor (int, int)
Collapse Expand Rtea65m Class
Rtea65m Members
Collapse Expand Rtea65m Constructor
Rtea65m::Rtea65m Constructor (int)
Rtea65m::Rtea65m Constructor (int, int)
Collapse Expand Rtea65m Methods
Rtea65m::getFraction Method
Rtea65m::getHistAmount Method
Rtea65m::initialize Method
Rtea65m::project Method
Collapse Expand RteaHigh Class
RteaHigh Members
RteaHigh::RteaHigh Constructor
Collapse Expand RteaHigh Methods
RteaHigh::getFraction Method
RteaHigh::initialize Method
Collapse Expand RtGeneral Class
RtGeneral Members
Collapse Expand RtGeneral Constructor
RtGeneral::RtGeneral Constructor (int)
RtGeneral::RtGeneral Constructor (int, int)
RtGeneral::~RtGeneral Destructor
Collapse Expand RtGeneral Methods
RtGeneral::convertMonthToAnnual Method
RtGeneral::getMaxAgePL Method
RtGeneral::project1 Method
Collapse Expand ScaledEarnFactors Class
ScaledEarnFactors Members
ScaledEarnFactors::ScaledEarnFactors Constructor
ScaledEarnFactors::~ScaledEarnFactors Destructor
Collapse Expand ScaledEarnFactors Enumerations
ScaledEarnFactors::scaleType Enumeration
Collapse Expand ScaledEarnFactors Methods
ScaledEarnFactors::getAverageEarnFactor Method
ScaledEarnFactors::getDecimals Method
ScaledEarnFactors::getFirstAge Method
ScaledEarnFactors::getHighEarnFactor Method
ScaledEarnFactors::getLastAge Method
ScaledEarnFactors::getLowEarnFactor Method
ScaledEarnFactors::getScaledEarnFactor Method
ScaledEarnFactors::getVeryLowEarnFactor Method
ScaledEarnFactors::getWidth Method
ScaledEarnFactors::read Method
ScaledEarnFactors::setAverageEarnings Method
ScaledEarnFactors::setDecimals Method
ScaledEarnFactors::setHighEarnings Method
ScaledEarnFactors::setLowEarnings Method
ScaledEarnFactors::setScaledEarnings Method
ScaledEarnFactors::setVeryLowEarnings Method
ScaledEarnFactors::setWidth Method
ScaledEarnFactors::write Method
Collapse Expand Secondary Class
Secondary Members
Secondary::Secondary Constructor
Collapse Expand Secondary Data Members
Secondary::bic Data Member
Secondary::entDate Data Member
Secondary::pifc Data Member
Collapse Expand Secondary Methods
Secondary::check Method
Secondary::deleteContents Method
Secondary::eligibleForMax Method
Secondary::getArf Method
Secondary::getBenefit Method
Secondary::getBenefitFactor Method
Secondary::getFullBenefit Method
Secondary::getMonthsArdri Method
Secondary::getReducedBenefit Method
Secondary::getRoundedBenefit Method
Secondary::isWidow Method
Secondary::setArf Method
Secondary::setBenefit Method
Secondary::setBenefitFactor Method
Secondary::setFullBenefit Method
Secondary::setMonthsArdri Method
Secondary::setReducedBenefit Method
Secondary::setRoundedBenefit Method
Collapse Expand SecondaryArray Class
SecondaryArray Members
SecondaryArray::SecondaryArray Constructor
SecondaryArray::~SecondaryArray Destructor
Collapse Expand SecondaryArray Data Members
SecondaryArray::secondary Data Member
Collapse Expand SecondaryArray Methods
SecondaryArray::deleteContents Method
SecondaryArray::getTotalFullBenefit Method
SecondaryArray::getTotalFullBenefitMax Method
Collapse Expand Sga Class
Sga Members
Sga::Sga Constructor
Collapse Expand Sga Data Members
Sga::sgaBlindA Data Member
Sga::sgaBlindM Data Member
Sga::sgaMaxA Data Member
Sga::sgaMaxM Data Member
Sga::sgaMinA Data Member
Sga::sgaMinM Data Member
Collapse Expand Sga Methods
Sga::project Method
Collapse Expand SgaBlindA Class
SgaBlindA Members
SgaBlindA::SgaBlindA Constructor
Collapse Expand SgaBlindA Methods
SgaBlindA::project Method
Collapse Expand SgaBlindM Class
SgaBlindM Members
SgaBlindM::SgaBlindM Constructor
Collapse Expand SgaGeneral Class
SgaGeneral Members
SgaGeneral::SgaGeneral Constructor
SgaGeneral::~SgaGeneral Destructor
Collapse Expand SgaGeneral Data Members
SgaGeneral::FIRST_PROJ_YEAR Data Member
Collapse Expand SgaGeneral Methods
SgaGeneral::convertMonthToAnnual Method
SgaGeneral::project Method
SgaGeneral::project1 Method
Collapse Expand SgaMaxA Class
SgaMaxA Members
SgaMaxA::SgaMaxA Constructor
Collapse Expand SgaMaxA Methods
SgaMaxA::project Method
Collapse Expand SgaMaxM Class
SgaMaxM Members
SgaMaxM::SgaMaxM Constructor
Collapse Expand SgaMinA Class
SgaMinA Members
SgaMinA::SgaMinA Constructor
Collapse Expand SgaMinA Methods
SgaMinA::project Method
Collapse Expand SgaMinM Class
SgaMinM Members
SgaMinM::SgaMinM Constructor
Collapse Expand SgaMinM Methods
SgaMinM::project Method
Collapse Expand SpecMin Class
SpecMin Members
SpecMin::SpecMin Constructor
SpecMin::~SpecMin Destructor
Collapse Expand SpecMin Methods
SpecMin::calculate Method
SpecMin::getSpecMinAmount Method
SpecMin::getSpecMinYearsExcess Method
SpecMin::getYearsTotal Method
SpecMin::initialize Method
Collapse Expand isApplicable Method
SpecMin::isApplicable Method ()
SpecMin::isApplicable Method (const WorkerDataGeneral&)
SpecMin::setSpecMinAmount Method
SpecMin::setSpecMinYearsExcess Method
SpecMin::specMinYearsExcessCal Method
Collapse Expand SpecMinLC Class
SpecMinLC Members
SpecMinLC::SpecMinLC Constructor
SpecMinLC::~SpecMinLC Destructor
Collapse Expand SpecMinLC Methods
Collapse Expand isApplicable Method
SpecMinLC::isApplicable Method ()
SpecMinLC::isApplicable Method (const WorkerDataGeneral&, const LawChangeArray&)
SpecMinLC::specMinYearsExcessCal Method
Collapse Expand TaxBenefits Class
TaxBenefits Members
TaxBenefits::TaxBenefits Constructor
TaxBenefits::~TaxBenefits Destructor
Collapse Expand TaxBenefits Data Members
TaxBenefits::HiYear Data Member
TaxBenefits::MARRIEDOASDHITAX Data Member
TaxBenefits::MARRIEDOASDHITHRESHOLD Data Member
TaxBenefits::MARRIEDOASDITHRESHOLD Data Member
TaxBenefits::OasdhiRate Data Member
TaxBenefits::OasdiRate Data Member
TaxBenefits::SINGLEOASDHITAX Data Member
TaxBenefits::SINGLEOASDHITHRESHOLD Data Member
TaxBenefits::SINGLEOASDITHRESHOLD Data Member
TaxBenefits::START_YEAR Data Member
Collapse Expand TaxBenefits Methods
TaxBenefits::deductionsCal Method
TaxBenefits::getProportion Method
TaxBenefits::getThreshold Method
TaxBenefits::taxOasdhi Method
TaxBenefits::taxOasdi Method
Collapse Expand TaxBenefitsLC Class
TaxBenefitsLC Members
TaxBenefitsLC::TaxBenefitsLC Constructor
TaxBenefitsLC::~TaxBenefitsLC Destructor
Collapse Expand TaxBenefitsLC Methods
TaxBenefitsLC::deductionsCal Method
TaxBenefitsLC::getProportion Method
TaxBenefitsLC::getThreshold Method
TaxBenefitsLC::paymentsCal Method
TaxBenefitsLC::taxOasdhi Method
TaxBenefitsLC::thresholdsCal Method
Collapse Expand TaxData Class
TaxData Members
TaxData::TaxData Constructor
TaxData::~TaxData Destructor
Collapse Expand TaxData Enumerations
TaxData::YEAR_GROUP Enumeration
Collapse Expand TaxData Data Members
TaxData::taxesDi Data Member
TaxData::taxesHi Data Member
TaxData::taxesOasdhi Data Member
TaxData::taxesOasdi Data Member
TaxData::taxesOasi Data Member
Collapse Expand TaxData Methods
TaxData::getTaxesTotal Method
TaxData::oasdhiTaxCal Method
TaxData::totalTaxCal Method
Collapse Expand TaxRates Class
TaxRates Members
TaxRates::TaxRates Constructor
TaxRates::~TaxRates Destructor
Collapse Expand TaxRates Enumerations
TaxRates::taxrateType Enumeration
TaxRates::trustfundType Enumeration
Collapse Expand TaxRates Data Members
TaxRates::LAST_TAX_RATE_YEAR Data Member
TaxRates::NUMTAXRATES Data Member
TaxRates::maxyear Data Member
Collapse Expand TaxRates Methods
TaxRates::getTaxRatesGross Method
TaxRates::getTaxRatesNet Method
TaxRates::initialize Method
TaxRates::setCredits Method
TaxRates::setGrossRates Method
TaxRates::setHistCredits Method
TaxRates::setHistRates Method
TaxRates::setNetRates Method
TaxRates::taxCalAllYears Method
TaxRates::taxCalOneYearGross Method
TaxRates::taxCalOneYearNet Method
Collapse Expand TaxRatesLC Class
TaxRatesLC Members
TaxRatesLC::TaxRatesLC Constructor
TaxRatesLC::~TaxRatesLC Destructor
Collapse Expand TaxRatesLC Data Members
TaxRatesLC::lawChange Data Member
Collapse Expand TaxRatesLC Methods
TaxRatesLC::initialize Method
Collapse Expand TaxRatesPL Class
TaxRatesPL Members
TaxRatesPL::TaxRatesPL Constructor
TaxRatesPL::~TaxRatesPL Destructor
Collapse Expand TaxRatesPL Methods
TaxRatesPL::initialize Method
Collapse Expand TransGuar Class
TransGuar Members
TransGuar::TransGuar Constructor
TransGuar::~TransGuar Destructor
Collapse Expand TransGuar Data Members
TransGuar::bendMfb Data Member
TransGuar::percMfb Data Member
TransGuar::portionPiaElig Data Member
Collapse Expand TransGuar Methods
TransGuar::calculate Method
TransGuar::initialize Method
Collapse Expand isApplicable Method
TransGuar::isApplicable Method ()
TransGuar::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type)
Collapse Expand TransGuarLC Class
TransGuarLC Members
TransGuarLC::TransGuarLC Constructor
TransGuarLC::~TransGuarLC Destructor
Collapse Expand TransGuarLC Methods
Collapse Expand isApplicable Method
TransGuarLC::isApplicable Method ()
TransGuarLC::isApplicable Method (const WorkerDataGeneral&, const PiaData&, WorkerDataGeneral::ben_type, const LawChangeArray&)
Collapse Expand UserAssumptions Class
UserAssumptions Members
UserAssumptions::UserAssumptions Constructor
Collapse Expand UserAssumptions Data Members
UserAssumptions::awincproj Data Member
UserAssumptions::base77 Data Member
UserAssumptions::baseOasdi Data Member
UserAssumptions::biproj Data Member
UserAssumptions::catchup Data Member
UserAssumptions::titleAw Data Member
UserAssumptions::titleBi Data Member
Collapse Expand UserAssumptions Methods
UserAssumptions::anscchCheck Method
UserAssumptions::deleteContents Method
UserAssumptions::getAnscch Method
UserAssumptions::getIaltaw Method
UserAssumptions::getIaltbi Method
UserAssumptions::getIbasch Method
UserAssumptions::getIstart Method
UserAssumptions::getJaltaw Method
UserAssumptions::getJaltbi Method
UserAssumptions::getJbasch Method
UserAssumptions::istartCheck Method
UserAssumptions::pebsasmCheck Method
UserAssumptions::resetTriggers Method
UserAssumptions::setAnscch Method
UserAssumptions::setIaltaw Method
UserAssumptions::setIaltbi Method
UserAssumptions::setIbasch Method
UserAssumptions::setIstart Method
UserAssumptions::setJaltaw Method
UserAssumptions::setJaltbi Method
UserAssumptions::setJbasch Method
UserAssumptions::setLastYear Method
UserAssumptions::setTitleAw Method
UserAssumptions::setTitleBi Method
UserAssumptions::zeroJalt Method
Collapse Expand WageBase Class
WageBase Members
Collapse Expand WageBase Constructor
WageBase::WageBase Constructor (int)
WageBase::WageBase Constructor (int, int)
Collapse Expand WageBaseGeneral Class
WageBaseGeneral Members
Collapse Expand WageBaseGeneral Constructor
WageBaseGeneral::WageBaseGeneral Constructor (int, int)
WageBaseGeneral::WageBaseGeneral Constructor (int, int, int)
WageBaseGeneral::~WageBaseGeneral Destructor
Collapse Expand WageBaseGeneral Data Members
WageBaseGeneral::defcomp Data Member
WageBaseGeneral::wageBaseInd Data Member
Collapse Expand WageBaseGeneral Methods
WageBaseGeneral::check Method
WageBaseGeneral::earnLimit Method
WageBaseGeneral::project Method
WageBaseGeneral::projectLC Method
Collapse Expand WageBaseHI Class
WageBaseHI Members
Collapse Expand WageBaseHI Constructor
WageBaseHI::WageBaseHI Constructor (int)
WageBaseHI::WageBaseHI Constructor (int, int)
Collapse Expand WageBaseLC Class
WageBaseLC Members
Collapse Expand WageBaseLC Constructor
WageBaseLC::WageBaseLC Constructor (const LawChangeArray&, int)
WageBaseLC::WageBaseLC Constructor (const LawChangeArray&, int, int)
Collapse Expand WageBaseLC Methods
WageBaseLC::project Method
Collapse Expand WageBaseOldLaw Class
WageBaseOldLaw Members
Collapse Expand WageBaseOldLaw Constructor
WageBaseOldLaw::WageBaseOldLaw Constructor (int)
WageBaseOldLaw::WageBaseOldLaw Constructor (int, int)
Collapse Expand WageBaseOldLawLC Class
WageBaseOldLawLC Members
Collapse Expand WageBaseOldLawLC Constructor
WageBaseOldLawLC::WageBaseOldLawLC Constructor (const LawChangeArray&, int)
WageBaseOldLawLC::WageBaseOldLawLC Constructor (const LawChangeArray&, int, int)
Collapse Expand WageBaseOldLawLC Methods
WageBaseOldLawLC::project Method
Collapse Expand WageInd Class
WageInd Members
WageInd::WageInd Constructor
WageInd::~WageInd Destructor
Collapse Expand WageInd Methods
WageInd::calculate Method
Collapse Expand isApplicable Method
WageInd::isApplicable Method ()
WageInd::isApplicable Method (const WorkerDataGeneral&, const PiaData&)
Collapse Expand WageIndGeneral Class
WageIndGeneral Members
WageIndGeneral::WageIndGeneral Constructor
WageIndGeneral::~WageIndGeneral Destructor
Collapse Expand WageIndGeneral Data Members
WageIndGeneral::bendMfb Data Member
WageIndGeneral::bendPia Data Member
WageIndGeneral::indexYearAvgWage Data Member
WageIndGeneral::mfbRealWageGain Data Member
WageIndGeneral::percMfb Data Member
WageIndGeneral::percPia Data Member
WageIndGeneral::percWind Data Member
WageIndGeneral::piaRealWageGain Data Member
WageIndGeneral::portionAime Data Member
WageIndGeneral::portionPiaElig Data Member
WageIndGeneral::windfallInd Data Member
WageIndGeneral::yearsTotal Data Member
Collapse Expand WageIndGeneral Methods
WageIndGeneral::aimepiaCal Method
WageIndGeneral::bendPointCal Method
WageIndGeneral::deconvertAme Method
WageIndGeneral::getIndexYearAvgWage Method
WageIndGeneral::getWindfall Method
WageIndGeneral::getYearsTotal Method
WageIndGeneral::indexEarnings Method
WageIndGeneral::initialize Method
WageIndGeneral::realWageGainAdj Method
WageIndGeneral::setPortionAime Method
WageIndGeneral::setWindfall Method
WageIndGeneral::windfallCal Method
Collapse Expand WageIndLC Class
WageIndLC Members
WageIndLC::WageIndLC Constructor
WageIndLC::~WageIndLC Destructor
Collapse Expand WageIndLC Methods
Collapse Expand isApplicable Method
WageIndLC::isApplicable Method ()
WageIndLC::isApplicable Method (const WorkerDataGeneral&, const PiaData&, const LawChangeArray&, const DateMoyr&)
Collapse Expand WageIndNonFreeze Class
WageIndNonFreeze Members
WageIndNonFreeze::WageIndNonFreeze Constructor
WageIndNonFreeze::~WageIndNonFreeze Destructor
Collapse Expand WageIndNonFreeze Methods
WageIndNonFreeze::calculate Method
WageIndNonFreeze::indexEarnings Method
Collapse Expand isApplicable Method
WageIndNonFreeze::isApplicable Method ()
WageIndNonFreeze::isApplicable Method (const WorkerDataGeneral&, const PiaData&)
Collapse Expand WorkerData Class
WorkerData Members
WorkerData::WorkerData Constructor
WorkerData::~WorkerData Destructor
Collapse Expand WorkerData Enumerations
WorkerData::DimLimits Enumeration
Collapse Expand WorkerData Data Members
WorkerData::earnHi Data Member
WorkerData::earnOasdi Data Member
WorkerData::milServDatesVec Data Member
WorkerData::railRoadData Data Member
WorkerData::ssn Data Member
WorkerData::taxType Data Member
Collapse Expand WorkerData Methods
WorkerData::anySelfEmp Method
WorkerData::deleteContents Method
WorkerData::deleteOabCessDate Method
WorkerData::deleteOabEntDate Method
WorkerData::deletePubpenDate Method
WorkerData::getEarnHi Method
WorkerData::getEarnHiOnly Method
WorkerData::getEarnMS Method
WorkerData::getEarnMS3750 Method
WorkerData::getEarnOasdhi Method
WorkerData::getEarnOasdi Method
WorkerData::getEarnRR Method
WorkerData::getEarnRR3750 Method
WorkerData::getFirstYearEarn Method
WorkerData::getFirstYearEarnHi Method
WorkerData::getFirstYearMS Method
WorkerData::getFirstYearRR Method
WorkerData::getIdNumber Method
WorkerData::getIdString Method
WorkerData::getIndms Method
WorkerData::getLastYearEarn Method
WorkerData::getLastYearEarnHi Method
WorkerData::getLastYearMS Method
WorkerData::getLastYearRR Method
WorkerData::getNhaddr Method
WorkerData::getNhname Method
WorkerData::getOabCessDate Method
WorkerData::getOabEntDate Method
WorkerData::getPubpen Method
WorkerData::getPubpenDate Method
WorkerData::getPubpenReservist Method
WorkerData::getQcovMS Method
WorkerData::getQcovMS3750 Method
WorkerData::getQcovRR Method
WorkerData::getQcovRR3750 Method
WorkerData::getQcovRR5177 Method
WorkerData::getTaxType Method
WorkerData::getTaxTypeArray Method
WorkerData::pubpenDateCheck2 Method
WorkerData::setEarnHi Method
WorkerData::setEarnOasdi Method
WorkerData::setNhaddr Method
WorkerData::setNhname Method
WorkerData::setOabCessDate Method
WorkerData::setOabEntDate Method
WorkerData::setPubpen Method
WorkerData::setPubpenDate Method
WorkerData::setPubpenReservist Method
WorkerData::setTaxType Method
WorkerData::zeroEarn Method
WorkerData::zeroEarnHi Method
WorkerData::zeroEarnOasdi Method
Collapse Expand WorkerData Friends
friend class boost::serialization::access Friend
Collapse Expand WorkerDataArray Class
WorkerDataArray Members
WorkerDataArray::WorkerDataArray Constructor
WorkerDataArray::~WorkerDataArray Destructor
Collapse Expand WorkerDataArray Enumerations
WorkerDataArray::DimLimits Enumeration
Collapse Expand WorkerDataArray Data Members
WorkerDataArray::workerData Data Member
Collapse Expand WorkerDataArray Methods
WorkerDataArray::deleteContents Method
WorkerDataArray::famSizeCheck Method
WorkerDataArray::getFamSize Method
WorkerDataArray::setFamSize Method
Collapse Expand WorkerDataGeneral Class
WorkerDataGeneral Members
Collapse Expand WorkerDataGeneral Constructor
WorkerDataGeneral::WorkerDataGeneral Constructor ()
WorkerDataGeneral::WorkerDataGeneral Constructor (const WorkerDataGeneral&)
WorkerDataGeneral::~WorkerDataGeneral Destructor
Collapse Expand WorkerDataGeneral Enumerations
WorkerDataGeneral::BitsetMembers Enumeration
WorkerDataGeneral::DimLimits Enumeration
WorkerDataGeneral::ben_type Enumeration
Collapse Expand WorkerDataGeneral Data Members
WorkerDataGeneral::childCareYears Data Member
WorkerDataGeneral::disabPeriod Data Member
WorkerDataGeneral::maxyear Data Member
WorkerDataGeneral::qc Data Member
WorkerDataGeneral::qclumpyear Data Member
Collapse Expand WorkerDataGeneral Methods
WorkerDataGeneral::anySelfEmp Method
Collapse Expand benefitDate1Check Method
WorkerDataGeneral::benefitDate1Check Method ()
WorkerDataGeneral::benefitDate1Check Method (const DateMoyr&)
Collapse Expand benefitDate2Check Method
WorkerDataGeneral::benefitDate2Check Method ()
WorkerDataGeneral::benefitDate2Check Method (const DateMoyr&, const DateMoyr&)
Collapse Expand birth1Check Method
WorkerDataGeneral::birth1Check Method (const boost::gregorian::date&, int)
WorkerDataGeneral::birth1Check Method (int)
Collapse Expand birth2Check Method
WorkerDataGeneral::birth2Check Method ()
WorkerDataGeneral::birth2Check Method (const boost::gregorian::date&)
Collapse Expand cessation1Check Method
WorkerDataGeneral::cessation1Check Method ()
WorkerDataGeneral::cessation1Check Method (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&)
WorkerDataGeneral::cessation1OnsetCheck Method
WorkerDataGeneral::cessationCheck Method
WorkerDataGeneral::cessationCheck2 Method
Collapse Expand deathCheck Method
WorkerDataGeneral::deathCheck Method ()
WorkerDataGeneral::deathCheck Method (const boost::gregorian::date&, const boost::gregorian::date&)
WorkerDataGeneral::deathCheck1 Method
WorkerDataGeneral::deathCheck2 Method
WorkerDataGeneral::deathCheck3 Method
WorkerDataGeneral::deleteContents Method
WorkerDataGeneral::deleteDeathDate Method
WorkerDataGeneral::deleteEntDate Method
Collapse Expand dis1Check Method
WorkerDataGeneral::dis1Check Method ()
WorkerDataGeneral::dis1Check Method (const boost::gregorian::date&, const boost::gregorian::date&, int, const boost::gregorian::date&)
WorkerDataGeneral::disBirthEntCheck Method
Collapse Expand disCheck Method
WorkerDataGeneral::disCheck Method ()
WorkerDataGeneral::disCheck Method (const boost::gregorian::date&, const boost::gregorian::date&, int, const boost::gregorian::date&, ben_type, const DateMoyr&, const DateMoyr&)
WorkerDataGeneral::disDeathCheck Method
Collapse Expand earningsCheck Method
WorkerDataGeneral::earningsCheck Method ()
WorkerDataGeneral::earningsCheck Method (bool, bool, bool)
Collapse Expand entCheck Method
WorkerDataGeneral::entCheck Method ()
WorkerDataGeneral::entCheck Method (const DateMoyr&)
WorkerDataGeneral::firstEarnHiYear Method
WorkerDataGeneral::getBenefitDate Method
WorkerDataGeneral::getBirthDate Method
WorkerDataGeneral::getBlindind Method
WorkerDataGeneral::getDeathDate Method
WorkerDataGeneral::getDeceasedOAB Method
WorkerDataGeneral::getDeemedind Method
WorkerDataGeneral::getEarliestEntDate Method
WorkerDataGeneral::getEarnEnable Method
WorkerDataGeneral::getEarnHi Method
WorkerDataGeneral::getEarnHiOnly Method
WorkerDataGeneral::getEarnMS Method
WorkerDataGeneral::getEarnMS3750 Method
WorkerDataGeneral::getEarnOasdhi Method
WorkerDataGeneral::getEarnOasdi Method
WorkerDataGeneral::getEarnRR Method
WorkerDataGeneral::getEarnRR3750 Method
WorkerDataGeneral::getEntDate Method
WorkerDataGeneral::getFirstYearMS Method
WorkerDataGeneral::getFirstYearRR Method
WorkerDataGeneral::getIbegin Method
WorkerDataGeneral::getIdNumber Method
WorkerDataGeneral::getIdString Method
WorkerDataGeneral::getIend Method
WorkerDataGeneral::getIndearn Method
WorkerDataGeneral::getIndms Method
WorkerDataGeneral::getIndrr Method
WorkerDataGeneral::getJoasdi Method
WorkerDataGeneral::getLastYearMS Method
WorkerDataGeneral::getLastYearRR Method
WorkerDataGeneral::getMaxyear Method
WorkerDataGeneral::getMqge Method
WorkerDataGeneral::getNhaddr Method
WorkerDataGeneral::getNhname Method
WorkerDataGeneral::getOabCessDate Method
WorkerDataGeneral::getOabEntDate Method
WorkerDataGeneral::getPubpen Method
WorkerDataGeneral::getPubpenDate Method
WorkerDataGeneral::getPubpenReservist Method
WorkerDataGeneral::getQcLumpYear Method
WorkerDataGeneral::getQcovMS Method
WorkerDataGeneral::getQcovMS3750 Method
WorkerDataGeneral::getQcovRR Method
WorkerDataGeneral::getQcovRR3750 Method
WorkerDataGeneral::getQcovRR5177 Method
WorkerDataGeneral::getQctot51td Method
WorkerDataGeneral::getQctottd Method
WorkerDataGeneral::getRecalc Method
WorkerDataGeneral::getReservist Method
WorkerDataGeneral::getSex Method
WorkerDataGeneral::getTaxType Method
WorkerDataGeneral::getTotalize Method
WorkerDataGeneral::getValdi Method
WorkerDataGeneral::hasQcsByYear Method
WorkerDataGeneral::ibegin1Check Method
WorkerDataGeneral::ibegin2Check Method
Collapse Expand ibeginCheck Method
WorkerDataGeneral::ibeginCheck Method ()
WorkerDataGeneral::ibeginCheck Method (int, int)
WorkerDataGeneral::iendCheck Method
WorkerDataGeneral::isFemale Method
WorkerDataGeneral::isMale Method
WorkerDataGeneral::isPrimary Method
WorkerDataGeneral::isalive Method
Collapse Expand isdead Method
WorkerDataGeneral::isdead Method (const DateMoyr&)
WorkerDataGeneral::isdead Method (int)
Collapse Expand joasdiCheck Method
WorkerDataGeneral::joasdiCheck Method ()
WorkerDataGeneral::joasdiCheck Method (int)
WorkerDataGeneral::lastQcyr Method
Collapse Expand needDiCess Method
WorkerDataGeneral::needDiCess Method ()
WorkerDataGeneral::needDiCess Method (int, ben_type)
WorkerDataGeneral::needQcsByYear Method
WorkerDataGeneral::need_aw Method
WorkerDataGeneral::need_bases Method
WorkerDataGeneral::need_bi Method
Collapse Expand priorent1Check Method
WorkerDataGeneral::priorent1Check Method ()
WorkerDataGeneral::priorent1Check Method (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&)
Collapse Expand priorentCheck Method
WorkerDataGeneral::priorentCheck Method ()
WorkerDataGeneral::priorentCheck Method (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&, ben_type)
WorkerDataGeneral::pubpenCheck Method
WorkerDataGeneral::pubpenDateCheck Method
WorkerDataGeneral::qc51tdCheck Method
Collapse Expand qcCheck Method
WorkerDataGeneral::qcCheck Method ()
WorkerDataGeneral::qcCheck Method (int, int)
WorkerDataGeneral::qctdCheck Method
WorkerDataGeneral::qctdCheck2 Method
Collapse Expand setBenefitDate Method
WorkerDataGeneral::setBenefitDate Method ()
WorkerDataGeneral::setBenefitDate Method (const DateMoyr&)
WorkerDataGeneral::setBirthDate Method
WorkerDataGeneral::setBlindind Method
WorkerDataGeneral::setCessationDate Method
WorkerDataGeneral::setCessationMfb Method
WorkerDataGeneral::setCessationPia Method
WorkerDataGeneral::setDeathDate Method
WorkerDataGeneral::setDeceasedOAB Method
WorkerDataGeneral::setDeemedind Method
WorkerDataGeneral::setEarnHi Method
WorkerDataGeneral::setEarnOasdi Method
WorkerDataGeneral::setEntDate Method
WorkerDataGeneral::setIbegin Method
WorkerDataGeneral::setIend Method
WorkerDataGeneral::setIndearn Method
WorkerDataGeneral::setIndrr Method
WorkerDataGeneral::setJoasdi Method
WorkerDataGeneral::setMaxyear Method
WorkerDataGeneral::setMqge Method
WorkerDataGeneral::setNhaddr Method
WorkerDataGeneral::setNhname Method
WorkerDataGeneral::setOabCessDate Method
WorkerDataGeneral::setOabEntDate Method
WorkerDataGeneral::setOnsetDate Method
WorkerDataGeneral::setPebsData Method
WorkerDataGeneral::setPebsEarn Method
WorkerDataGeneral::setPriorentDate Method
WorkerDataGeneral::setPriorentDateCheck Method
WorkerDataGeneral::setPubpen Method
WorkerDataGeneral::setPubpenDate Method
WorkerDataGeneral::setPubpenReservist Method
WorkerDataGeneral::setQc51td Method
WorkerDataGeneral::setQcLumpYear Method
WorkerDataGeneral::setQcsByYear Method
WorkerDataGeneral::setQctd Method
WorkerDataGeneral::setRecalc Method
WorkerDataGeneral::setReservist Method
WorkerDataGeneral::setSex Method
WorkerDataGeneral::setTaxType Method
WorkerDataGeneral::setTotalize Method
WorkerDataGeneral::setValdi Method
Collapse Expand setWaitperDate Method
WorkerDataGeneral::setWaitperDate Method (unsigned)
WorkerDataGeneral::setWaitperDate Method (unsigned, const DateMoyr&)
WorkerDataGeneral::taxTypeCheck Method
WorkerDataGeneral::valdi1Check Method
WorkerDataGeneral::valdi2Check Method
WorkerDataGeneral::valdiCheck Method
Collapse Expand waitpd1Check Method
WorkerDataGeneral::waitpd1Check Method ()
WorkerDataGeneral::waitpd1Check Method (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&)
Collapse Expand waitpdCheck Method
WorkerDataGeneral::waitpdCheck Method ()
WorkerDataGeneral::waitpdCheck Method (const DateMoyr&, const boost::gregorian::date&, const DateMoyr&)
WorkerDataGeneral::zeroEarn Method
WorkerDataGeneral::zeroEarnHi Method
WorkerDataGeneral::zeroEarnOasdi Method
WorkerDataGeneral::zeroOasdi Method
Collapse Expand WorkerDataGeneral Friends
friend class boost::serialization::access Friend
Collapse Expand Functions
isDebugPid Function
Collapse Expand Variables
BASEYR Variable
BASEYR1 Variable
DEBUGPID Variable
LASTYEARLR Variable
LASTYRSR Variable
MAXEARN Variable
MAXYRS Variable
MAXYRSR Variable
MAXYRSR1 Variable
ORSYR Variable
YEAR2075 Variable
YEAR2080 Variable
YEAR2085 Variable
YEAR2090 Variable
YEAR2095 Variable
YEAR2100 Variable
YEAR2105 Variable
YEAR2200 Variable
YEAR36 Variable
YEAR37 Variable
YEAR50 Variable
YEAR51 Variable
YEAR69 Variable
YEAR70 Variable
YEAR74 Variable
YEAR75 Variable
YEAR79 Variable
Collapse Expand Files
Assumptions.cpp
Assumptions.h
AssumptionsFile.cpp
AssumptionsFile.h
AssumptionsNonFile.cpp
AssumptionsNonFile.h
AssumptionType.cpp
AssumptionType.h
avgwg.cpp
avgwg.h
awbidat.cpp
awbidat.h
AwbiDataFile.h
AwbiDataNonFile.h
awbidtfl.cpp
awbidtnf.cpp
awinc.cpp
awinc.h
AwincDoc.cpp
AwincDoc.h
AwincFile.h
awincfl.cpp
awincnf.cpp
AwincNonFile.h
BaseChangeType.cpp
BaseChangeType.h
baseyear.cpp
baseyear.h
BaseYearFile.h
BaseYearNonFile.h
baseyrfl.cpp
baseyrnf.cpp
BendPoints.h
BenefitAmount.cpp
BenefitAmount.h
BenefitAmountArray.cpp
BenefitAmountArray.h
Bic.cpp
bic.h
biproj.cpp
biproj.h
BiprojFile.h
biprojfl.cpp
biprojnf.cpp
BiprojNonFile.h
bpmfbout.cpp
bpmfbout.h
bppiaout.cpp
bppiaout.h
cachpdoc.cpp
cachup.cpp
cachup.h
cachupf.h
cachupfl.cpp
cachupnf.cpp
CatchupFile.h
CatchupNonFile.h
ChildCareCalc.cpp
ChildCareCalc.h
ChildCareCalcLC.cpp
ChildCareCalcLC.h
comppd.h
CompPeriod.cpp
config.cpp
config.h
configFile.cpp
ConfigFile.h
configNonFile.cpp
ConfigNonFile.h
DebugCase.cpp
DebugCase.h
DibGuar.cpp
DibGuar.h
DibGuarLC.cpp
DibGuarLC.h
dinscode.cpp
dinscode.h
DisabPeriod.cpp
DisabPeriod.h
DisInsCodeArray.cpp
DisInsCodeArray.h
EarnProject.cpp
EarnProject.h
FieldOfficeInfoFile.h
FieldOfficeInfoNonFile.h
foinfo.cpp
foinfo.h
foinfofl.cpp
foinfonf.cpp
FrozMin.cpp
FrozMin.h
frzyrs.cpp
frzyrs.h
inscode.cpp
inscode.h
InsCodeArray.cpp
InsCodeArray.h
LawChange.cpp
LawChange.h
LawChangeAGE65COMP.cpp
LawChangeAGE65COMP.h
LawChangeALLEARN.cpp
LawChangeALLEARN.h
LawChangeArray.cpp
LawChangeArray.h
LawChangeBPFRACWAGE.cpp
LawChangeBPFRACWAGE.h
LawChangeBPMINCONST.cpp
LawChangeBPMINCONST.h
LawChangeBPSPECRATE.cpp
LawChangeBPSPECRATE.h
LawChangeCHILDCARECREDIT.cpp
LawChangeCHILDCARECREDIT.h
LawChangeCHILDCAREDROPOUT.cpp
LawChangeCHILDCAREDROPOUT.h
LawChangeCOLACHANGE.cpp
LawChangeCOLACHANGE.h
LawChangeDECLINEPERC.cpp
LawChangeDECLINEPERC.h
LawChangeDROPOUTCHG.cpp
LawChangeDROPOUTCHG.h
LawChangeMARRLENGTH.cpp
LawChangeMARRLENGTH.h
LawChangeNEWFORMULA.cpp
LawChangeNEWFORMULA.h
LawChangeNEWSPECMIN.cpp
LawChangeNEWSPECMIN.h
LawChangeNRACHANGE.cpp
LawChangeNRACHANGE.h
LawChangeOut.cpp
LawChangeOut.h
LawChangePSAACCT.cpp
LawChangePSAACCT.h
LawChangeRead.cpp
LawChangeRead.h
LawChangeTAXBENCHG.cpp
LawChangeTAXBENCHG.h
LawChangeTAXRATECHG.cpp
LawChangeTAXRATECHG.h
LawChangeWAGEBASECHG.cpp
LawChangeWAGEBASECHG.h
LawChangeWIDFACTOR.cpp
LawChangeWIDFACTOR.h
LawChangeWIFEFACTOR.cpp
LawChangeWIFEFACTOR.h
LawChangeWrite.cpp
LawChangeWrite.h
MilServDatesVec.h
msdates.cpp
msdates.h
msdatesvec.cpp
oactcnst.h
oldpia.cpp
OldPia.h
oldstart.cpp
OldStart.h
OldStartLC.cpp
OldStartLC.h
pebs.cpp
pebs.h
percmfb.cpp
percmfb.h
percpia.cpp
percpia.h
PercPiaOut.cpp
PercPiaOut.h
piacal.cpp
piacal.h
piacalany.cpp
PiaCalAny.h
piacallc.cpp
PiaCalLC.h
PiaCalPL.cpp
PiaCalPL.h
piadata.cpp
piadata.h
PiadataArray.cpp
PiadataArray.h
PiaMethod.cpp
PiaMethod.h
PiaParamsLCTR.cpp
PiaParamsLCTR.h
PiaParamsTR.cpp
PiaParamsTR.h
piaparms.cpp
piaparms.h
piaparmsAny.cpp
piaparmsAny.h
piaparmsLC.cpp
piaparmsLC.h
piaparmsPL.cpp
piaparmsPL.h
piaread.cpp
piaread.h
piareadAny.cpp
piareadAny.h
PiaTable.cpp
PiaTable.h
PiaTableLC.cpp
PiaTableLC.h
piawrite.cpp
piawrite.h
piawriteAny.cpp
piawriteAny.h
pib50mfb.cpp
pib50pib.cpp
pib52ame.cpp
bendmfb.cpp
pib52mfb.cpp
bendpia.cpp
pib54ame.cpp
pib54mfb.cpp
pib54pia.cpp
pib58ame.cpp
pib58pib.cpp
pibtable.h
Pifc.cpp
Pifc.h
PresValFacs.cpp
PresValFacs.h
Psa.cpp
Psa.h
qc.cpp
qc.h
qcamt.cpp
qcamt.h
QcArray.cpp
QcArray.h
QcPacked.cpp
QcPacked.h
railroad.cpp
railroad.h
ReindWid.cpp
ReindWid.h
ReindWidLC.cpp
ReindWidLC.h
RetireTest.cpp
RetireTest.h
rtgenrl.cpp
rtgenrl.h
ScaledEarnFactors.cpp
ScaledEarnFactors.h
Secondary.cpp
Secondary.h
SecondaryArray.cpp
SecondaryArray.h
Sga.cpp
Sga.h
SgaDerived.cpp
SgaDerived.h
SgaGeneral.cpp
SgaGeneral.h
SpecMin.cpp
SpecMin.h
SpecMinLC.cpp
SpecMinLC.h
TaxBenefits.cpp
TaxBenefits.h
TaxBenefitsLC.cpp
TaxBenefitsLC.h
TaxData.cpp
TaxData.h
TaxRates.cpp
TaxRates.h
TaxRatesLC.cpp
TaxRatesLC.h
TaxRatesPL.cpp
TaxRatesPL.h
TransGuar.cpp
TransGuar.h
TransGuarLC.cpp
TransGuarLC.h
UserAssumptions.cpp
UserAssumptions.h
WageBase.cpp
WageBase.h
WageInd.cpp
WageInd.h
WageIndGeneral.cpp
WageIndGeneral.h
WageIndLC.cpp
WageIndLC.h
WageIndNonFreeze.cpp
WageIndNonFreeze.h
wbgenrl.cpp
wbgenrl.h
wbgenrlLC.cpp
wbgenrlLC.h
WorkerDataArray.cpp
WorkerDataArray.h
WorkerDataGeneral.cpp
WorkerDataGeneral.h
wrkrdata.cpp
wrkrdata.h
bendmfb.h
bendpia.h
PortionAime.cpp
PortionAime.h
Collapse Expand Misc Library
Collapse Expand Classes
Collapse Expand Age Class
Age Members
Collapse Expand Age Constructor
Age::Age Constructor ()
Age::Age Constructor (const Age&)
Age::Age Constructor (unsigned)
Age::Age Constructor (unsigned, unsigned)
Age::~Age Destructor
Collapse Expand Age Methods
Age::deleteContents Method
Age::getMonths Method
Age::getYears Method
Age::monthsCheck Method
Age::toMonths Method
Collapse Expand toString Method
Age::toString Method ()
Age::toString Method (const std::string&)
Collapse Expand Age Operators
Age::- Operator
Age::< Operator
Age::= Operator
Age::== Operator
Collapse Expand Age Friends
friend class boost::serialization::access Friend
Collapse Expand AnnualArrays Class
AnnualArrays Members
Collapse Expand AnnualArrays Methods
AnnualArrays::add Method
AnnualArrays::convert Method
AnnualArrays::divide Method
Collapse Expand multiply Method
AnnualArrays::multiply Method (DoubleAnnual&, const DoubleAnnual&, int, int)
AnnualArrays::multiply Method (DoubleAnnual&, double, int, int)
AnnualArrays::subtract Method
Collapse Expand BitAnnual Class
BitAnnual Members
Collapse Expand BitAnnual Constructor
BitAnnual::BitAnnual Constructor (const BitAnnual&)
BitAnnual::BitAnnual Constructor (int, int)
BitAnnual::~BitAnnual Destructor
Collapse Expand BitAnnual Data Members
BitAnnual::baseYear Data Member
BitAnnual::lastYear Data Member
BitAnnual::theData Data Member
Collapse Expand BitAnnual Methods
BitAnnual::any Method
BitAnnual::assign Method
BitAnnual::deleteContents Method
BitAnnual::getBaseYear Method
BitAnnual::getBit Method
BitAnnual::getLastYear Method
BitAnnual::setBit Method
Collapse Expand BitAnnual Friends
friend class boost::serialization::access Friend
Collapse Expand Date Class
Date Members
Collapse Expand Date Data Members
Date::highyear Data Member
Date::lowyear Data Member
Collapse Expand Date Methods
Date::addYears Method
Date::monthCheck Method
Date::yearCheck Method
Collapse Expand DateFormatter Class
DateFormatter Members
Collapse Expand DateFormatter Methods
DateFormatter::date_from_undelimited_us_string Method
DateFormatter::month_year_from_undelimited_us_string Method
Collapse Expand toString Method
DateFormatter::toString Method (const DateMoyr&)
DateFormatter::toString Method (const DateMoyr&, const std::string&)
DateFormatter::toString Method (const boost::gregorian::date&)
DateFormatter::toString Method (const boost::gregorian::date&, const std::string&)
Collapse Expand DateMoyr Class
DateMoyr Members
Collapse Expand DateMoyr Constructor
DateMoyr::DateMoyr Constructor ()
DateMoyr::DateMoyr Constructor (const DateMoyr&)
DateMoyr::DateMoyr Constructor (const boost::gregorian::date&)
DateMoyr::DateMoyr Constructor (const std::string&)
DateMoyr::DateMoyr Constructor (unsigned, unsigned)
DateMoyr::~DateMoyr Destructor
Collapse Expand DateMoyr Methods
DateMoyr::check Method
DateMoyr::deleteContents Method
DateMoyr::getMonth Method
DateMoyr::getMonthBefore Method
DateMoyr::getMonths Method
DateMoyr::getYear Method
DateMoyr::index Method
DateMoyr::isNotADate Method
DateMoyr::monthCheck Method
Collapse Expand DateMoyr Operators
DateMoyr::+ Operator
DateMoyr::- Operator
DateMoyr::< Operator
Collapse Expand = Operator
DateMoyr::= Operator (const DateMoyr&)
DateMoyr::= Operator (const boost::gregorian::date&)
DateMoyr::== Operator
Collapse Expand DateMoyr Friends
friend class boost::serialization::access Friend
Collapse Expand Document Class
Document Members
Collapse Expand Document Constructor
Document::Document Constructor ()
Document::Document Constructor (const std::string&, const std::string&)
Document::~Document Destructor
Collapse Expand Document Methods
Document::errormesg Method
Document::getCorename Method
Document::getModifier Method
Document::getPathname Method
Document::getTitle Method
Document::readmesg Method
Document::setCorename Method
Document::setExtension Method
Document::setModifier Method
Document::setPath Method
Document::setPathAndModifier Method
Document::setPathname Method
Document::setTitle Method
Document::writemesg Method
Collapse Expand DoubleAnnual Class
DoubleAnnual Members
DoubleAnnual::DoubleAnnual Constructor
DoubleAnnual::~DoubleAnnual Destructor
Collapse Expand DoubleAnnual Data Members
DoubleAnnual::baseYear Data Member
DoubleAnnual::theData Data Member
Collapse Expand DoubleAnnual Methods
DoubleAnnual::accumulate Method
Collapse Expand assign Method
DoubleAnnual::assign Method (const DoubleAnnual&, int, int)
DoubleAnnual::assign Method (double, int, int)
DoubleAnnual::fill Method
DoubleAnnual::getBaseYear Method
DoubleAnnual::getLastYear Method
Collapse Expand DoubleAnnual Operators
Collapse Expand [] Operator
DoubleAnnual::[] Operator (int)
DoubleAnnual::[] Operator (int)
Collapse Expand DoubleAnnual Friends
friend class boost::serialization::access Friend
Collapse Expand DoubleAnnualRead Class
DoubleAnnualRead Members
DoubleAnnualRead::DoubleAnnualRead Constructor
Collapse Expand DoubleAnnualRead Methods
DoubleAnnualRead::read Method
Collapse Expand DoubleAnnualWrite Class
DoubleAnnualWrite Members
DoubleAnnualWrite::DoubleAnnualWrite Constructor
Collapse Expand DoubleAnnualWrite Methods
DoubleAnnualWrite::getLineWidth Method
DoubleAnnualWrite::getPrecision Method
DoubleAnnualWrite::getWidth Method
DoubleAnnualWrite::write Method
Collapse Expand DoubleMonth Class
DoubleMonth Members
DoubleMonth::DoubleMonth Constructor
DoubleMonth::~DoubleMonth Destructor
Collapse Expand DoubleMonth Data Members
DoubleMonth::theData Data Member
Collapse Expand DoubleMonth Methods
DoubleMonth::annAvgCal Method
Collapse Expand assign Method
DoubleMonth::assign Method (const DoubleMonth&, int, int)
DoubleMonth::assign Method (double, int, int)
DoubleMonth::getAt Method
DoubleMonth::getBaseYear Method
DoubleMonth::getLastYear Method
DoubleMonth::getLineWidth Method
DoubleMonth::getPrecision Method
DoubleMonth::getWidth Method
DoubleMonth::nmonCal Method
DoubleMonth::qtrAvgCal Method
DoubleMonth::read Method
DoubleMonth::setAt Method
DoubleMonth::setLineWidth Method
DoubleMonth::setPrecision Method
DoubleMonth::setWidth Method
DoubleMonth::write Method
Collapse Expand DoubleQuarter Class
DoubleQuarter Members
DoubleQuarter::DoubleQuarter Constructor
DoubleQuarter::~DoubleQuarter Destructor
Collapse Expand DoubleQuarter Data Members
DoubleQuarter::theData Data Member
Collapse Expand DoubleQuarter Methods
DoubleQuarter::anninc Method
DoubleQuarter::anninc3 Method
Collapse Expand assign Method
DoubleQuarter::assign Method (const DoubleMonth&, const QtrYear&, const QtrYear&)
DoubleQuarter::assign Method (const DoubleQuarter&, int, int)
DoubleQuarter::assign Method (double, int, int)
DoubleQuarter::average Method
DoubleQuarter::getAfter Method
DoubleQuarter::getAt Method
DoubleQuarter::getBaseYear Method
DoubleQuarter::getBefore Method
DoubleQuarter::getLastYear Method
DoubleQuarter::getLineWidth Method
DoubleQuarter::getWidth Method
DoubleQuarter::multiply Method
DoubleQuarter::read Method
DoubleQuarter::setAt Method
DoubleQuarter::setLineWidth Method
DoubleQuarter::setPrecision Method
DoubleQuarter::setWidth Method
DoubleQuarter::write Method
Collapse Expand FloatAnnual Class
FloatAnnual Members
FloatAnnual::FloatAnnual Constructor
FloatAnnual::~FloatAnnual Destructor
Collapse Expand FloatAnnual Data Members
FloatAnnual::baseYear Data Member
FloatAnnual::theData Data Member
Collapse Expand FloatAnnual Methods
FloatAnnual::accumulate Method
Collapse Expand assign Method
FloatAnnual::assign Method (const FloatAnnual&, int, int)
FloatAnnual::assign Method (float, int, int)
FloatAnnual::fill Method
FloatAnnual::getBaseYear Method
FloatAnnual::getLastYear Method
Collapse Expand FloatAnnual Operators
Collapse Expand [] Operator
FloatAnnual::[] Operator (int)
FloatAnnual::[] Operator (int)
Collapse Expand FloatAnnual Friends
friend class boost::serialization::access Friend
Collapse Expand FloatMonth Class
FloatMonth Members
FloatMonth::FloatMonth Constructor
FloatMonth::~FloatMonth Destructor
Collapse Expand FloatMonth Data Members
FloatMonth::theData Data Member
Collapse Expand FloatMonth Methods
FloatMonth::annAvgCal Method
Collapse Expand assign Method
FloatMonth::assign Method (const FloatMonth&, int, int)
FloatMonth::assign Method (float, int, int)
FloatMonth::getAt Method
FloatMonth::getBaseYear Method
FloatMonth::getLastYear Method
FloatMonth::getLineWidth Method
FloatMonth::getPrecision Method
FloatMonth::getWidth Method
FloatMonth::nmonCal Method
FloatMonth::qtrAvgCal Method
FloatMonth::read Method
FloatMonth::setAt Method
FloatMonth::setLineWidth Method
FloatMonth::setPrecision Method
FloatMonth::setWidth Method
FloatMonth::write Method
Collapse Expand FloatQuarter Class
FloatQuarter Members
FloatQuarter::FloatQuarter Constructor
Collapse Expand FloatQuarter Data Members
FloatQuarter::theData Data Member
Collapse Expand FloatQuarter Methods
FloatQuarter::anninc Method
FloatQuarter::anninc3 Method
Collapse Expand assign Method
FloatQuarter::assign Method (const FloatMonth&, const QtrYear&, const QtrYear&)
FloatQuarter::assign Method (const FloatQuarter&, int, int)
FloatQuarter::assign Method (float, int, int)
FloatQuarter::average Method
FloatQuarter::getAfter Method
FloatQuarter::getAt Method
FloatQuarter::getBaseYear Method
FloatQuarter::getBefore Method
FloatQuarter::getLastYear Method
FloatQuarter::getLineWidth Method
FloatQuarter::getWidth Method
FloatQuarter::multiply Method
FloatQuarter::read Method
FloatQuarter::setAt Method
FloatQuarter::setLineWidth Method
FloatQuarter::setPrecision Method
FloatQuarter::setWidth Method
FloatQuarter::write Method
Collapse Expand Genfile Class
Genfile Members
Collapse Expand Genfile Constructor
Genfile::Genfile Constructor ()
Genfile::Genfile Constructor (const std::string&)
Genfile::~Genfile Destructor
Collapse Expand Genfile Data Members
Genfile::pathname Data Member
Collapse Expand Genfile Methods
Genfile::getmesg Method
Genfile::openapp Method
Genfile::openin Method
Genfile::openout Method
Genfile::setmesg Method
Collapse Expand IntAnnual Class
IntAnnual Members
IntAnnual::IntAnnual Constructor
IntAnnual::~IntAnnual Destructor
Collapse Expand IntAnnual Data Members
IntAnnual::baseYear Data Member
IntAnnual::theData Data Member
Collapse Expand IntAnnual Methods
Collapse Expand assign Method
IntAnnual::assign Method (const IntAnnual&, int, int)
IntAnnual::assign Method (int, int, int)
IntAnnual::fill Method
IntAnnual::getBaseYear Method
IntAnnual::getLastYear Method
Collapse Expand IntAnnual Operators
Collapse Expand [] Operator
IntAnnual::[] Operator (int)
IntAnnual::[] Operator (int)
Collapse Expand Out132 Class
Out132 Members
Out132::Out132 Constructor
Collapse Expand Out132 Methods
Out132::footer Method
Out132::header Method
Out132::pgtitle Method
Out132::prepareStrings Method
Collapse Expand Out80 Class
Out80 Members
Out80::Out80 Constructor
Collapse Expand Out80 Methods
Out80::footer Method
Out80::header Method
Out80::pgtitle Method
Out80::prepareStrings Method
Collapse Expand OutDC80 Class
OutDC80 Members
OutDC80::OutDC80 Constructor
Collapse Expand OutDC80 Methods
OutDC80::advanceLine Method
OutDC80::formfeed Method
Collapse Expand printLine Method
OutDC80::printLine Method (const char*)
OutDC80::printLine Method (const std::string&)
Collapse Expand printLinena Method
OutDC80::printLinena Method (const char*)
OutDC80::printLinena Method (const std::string&)
OutDC80::setDC Method
OutDC80::setHeight Method
OutDC80::setx Method
OutDC80::sety Method
Collapse Expand OutFile132 Class
OutFile132 Members
Collapse Expand OutFile132 Constructor
OutFile132::OutFile132 Constructor (const std::string&)
OutFile132::OutFile132 Constructor (const std::string&, const std::string&)
OutFile132::~OutFile132 Destructor
Collapse Expand OutFile132 Methods
OutFile132::advanceLine Method
OutFile132::formfeed Method
OutFile132::getColString Method
OutFile132::getCols Method
Collapse Expand printLine Method
OutFile132::printLine Method (const char*)
OutFile132::printLine Method (const std::string&)
Collapse Expand printLinena Method
OutFile132::printLinena Method (const char*)
OutFile132::printLinena Method (const std::string&)
OutFile132::setCols Method
Collapse Expand OutFile80 Class
OutFile80 Members
Collapse Expand OutFile80 Constructor
OutFile80::OutFile80 Constructor (const std::string&)
OutFile80::OutFile80 Constructor (const std::string&, const std::string&)
OutFile80::~OutFile80 Destructor
Collapse Expand OutFile80 Methods
OutFile80::advanceLine Method
OutFile80::formfeed Method
OutFile80::getColString Method
OutFile80::getCols Method
Collapse Expand printLine Method
OutFile80::printLine Method (const char*)
OutFile80::printLine Method (const std::string&)
Collapse Expand printLinena Method
OutFile80::printLinena Method (const char*)
OutFile80::printLinena Method (const std::string&)
OutFile80::setCols Method
Collapse Expand OutFileHTML Class
OutFileHTML Members
OutFileHTML::OutFileHTML Constructor
OutFileHTML::~OutFileHTML Destructor
Collapse Expand OutFileHTML Data Members
OutFileHTML::PAGE_TITLE_LINES Data Member
OutFileHTML::cssPage Data Member
OutFileHTML::firstPage Data Member
OutFileHTML::tagRightChar Data Member
Collapse Expand OutFileHTML Methods
OutFileHTML::closeFile Method
OutFileHTML::doHeader Method
OutFileHTML::gettitle Method
OutFileHTML::openFile Method
OutFileHTML::pgtitle Method
OutFileHTML::settitle Method
Collapse Expand write Method
OutFileHTML::write Method (char)
OutFileHTML::write Method (const char*)
OutFileHTML::write Method (const std::string&)
Collapse Expand writeAttribute Method
OutFileHTML::writeAttribute Method (const std::string&, int)
OutFileHTML::writeAttribute Method (const std::string&, const std::string&)
OutFileHTML::writeBeginGrayRow Method
Collapse Expand writeBeginTable Method
OutFileHTML::writeBeginTable Method (const std::string&)
OutFileHTML::writeBeginTable Method (const std::string&, const std::string&, const std::string&)
OutFileHTML::writeBeginTag Method
Collapse Expand writeCellBody Method
OutFileHTML::writeCellBody Method (int)
OutFileHTML::writeCellBody Method (const std::string&)
OutFileHTML::writeCellBodyColSpan Method
Collapse Expand writeCellBodyRight Method
OutFileHTML::writeCellBodyRight Method (double, int)
OutFileHTML::writeCellBodyRight Method (int)
OutFileHTML::writeCellBodyRight Method (const std::string&)
Collapse Expand writeCellHeading Method
OutFileHTML::writeCellHeading Method (int)
OutFileHTML::writeCellHeading Method (const std::string&)
Collapse Expand writeCellHeadingColSpan Method
OutFileHTML::writeCellHeadingColSpan Method (const std::string&, int)
OutFileHTML::writeCellHeadingColSpan Method (const std::string&, const std::string&)
OutFileHTML::writeCellHeadingRowSpan Method
OutFileHTML::writeEndTag Method
OutFileHTML::writeFullBeginTag Method
Collapse Expand writeLine Method
OutFileHTML::writeLine Method ()
OutFileHTML::writeLine Method (const char*)
OutFileHTML::writeLine Method (const std::string&)
OutFileHTML::writeYear Method
Collapse Expand Outfile Class
Outfile Members
Collapse Expand Outfile Constructor
Outfile::Outfile Constructor (const std::string&, const std::string&)
Outfile::Outfile Constructor (const std::string&, const std::string&, const std::string&)
Outfile::~Outfile Destructor
Collapse Expand Outfile Data Members
Outfile::PAGE_TITLE_LINES Data Member
Outfile::dateModyyr Data Member
Outfile::outstrm Data Member
Outfile::pageNum Data Member
Collapse Expand Outfile Methods
Outfile::advanceLine Method
Outfile::closeout Method
Outfile::footer Method
Outfile::formfeed Method
Outfile::getPageNum Method
Outfile::gettitle Method
Outfile::header Method
Outfile::openout Method
Outfile::pgtitle Method
Collapse Expand printLine Method
Outfile::printLine Method (const char*)
Outfile::printLine Method (const std::string&)
Collapse Expand printLinena Method
Outfile::printLinena Method (const char*)
Outfile::printLinena Method (const std::string&)
Outfile::setPageNum Method
Outfile::settitle Method
Collapse Expand PageCounters Class
PageCounters Members
PageCounters::PageCounters Constructor
PageCounters::~PageCounters Destructor
Collapse Expand PageCounters Data Members
PageCounters::PIA_IDS_PAGE1 Data Member
PageCounters::PIA_IDS_PAGE2 Data Member
PageCounters::PIA_IDS_PAGE3 Data Member
Collapse Expand PageCounters Methods
PageCounters::deleteContents Method
PageCounters::get Method
PageCounters::read Method
PageCounters::set Method
PageCounters::update Method
PageCounters::write Method
Collapse Expand PageOut Class
PageOut Members
PageOut::PageOut Constructor
PageOut::~PageOut Destructor
Collapse Expand PageOut Data Members
PageOut::MAXLINES Data Member
PageOut::loc Data Member
PageOut::outputString Data Member
PageOut::punct Data Member
PageOut::strm Data Member
Collapse Expand PageOut Methods
PageOut::getCount Method
PageOut::getString Method
PageOut::prepareStrings Method
Collapse Expand print Method
PageOut::print Method (Outfile&)
PageOut::print Method (std::ostream&)
Collapse Expand Path Class
Path Members
Collapse Expand Path Data Members
Path::allSeparators Data Member
Path::altDirectorySeparatorChar Data Member
Path::directorySeparatorChar Data Member
Collapse Expand Path Methods
Path::changeExtension Method
Path::combine Method
Path::getDirectoryName Method
Path::getFileName Method
Path::getRelativeName Method
Collapse Expand PiaException Class
PiaException Members
Collapse Expand PiaException Constructor
PiaException::PiaException Constructor (const PiaException&)
PiaException::PiaException Constructor (int)
PiaException::PiaException Constructor (const std::string&)
PiaException::~PiaException Destructor
Collapse Expand PiaException Methods
PiaException::getNumber Method
PiaException::what Method
Collapse Expand PunctFacet Structure
PunctFacet Members
Collapse Expand PunctFacet Data Members
PunctFacet::yearStr Data Member
Collapse Expand PunctFacet Methods
PunctFacet::do_grouping Method
PunctFacet::getYear Method
Collapse Expand QtrYear Class
QtrYear Members
Collapse Expand QtrYear Constructor
QtrYear::QtrYear Constructor ()
QtrYear::QtrYear Constructor (const DateMoyr&)
QtrYear::QtrYear Constructor (const boost::gregorian::date&)
QtrYear::QtrYear Constructor (unsigned)
QtrYear::QtrYear Constructor (unsigned, unsigned)
QtrYear::~QtrYear Destructor
Collapse Expand QtrYear Methods
Collapse Expand add Method
QtrYear::add Method (const QtrYear&)
QtrYear::add Method (unsigned)
QtrYear::check Method
QtrYear::deleteContents Method
QtrYear::diff Method
QtrYear::getQuarter Method
QtrYear::getYear Method
QtrYear::qtrCheck Method
QtrYear::setQuarter Method
QtrYear::setYear Method
Collapse Expand subtract Method
QtrYear::subtract Method (const QtrYear&)
QtrYear::subtract Method (unsigned)
QtrYear::toDateMoyr Method
QtrYear::toString Method
QtrYear::yearCheck Method
Collapse Expand QtrYear Operators
QtrYear::< Operator
Collapse Expand = Operator
QtrYear::= Operator (const DateMoyr&)
QtrYear::= Operator (const QtrYear&)
QtrYear::= Operator (const boost::gregorian::date&)
QtrYear::== Operator
Collapse Expand QtrYear Friends
friend class boost::serialization::access Friend
Collapse Expand Sex Class
Sex Members
Collapse Expand Sex Constructor
Sex::Sex Constructor ()
Sex::Sex Constructor (const Sex&)
Sex::Sex Constructor (sex_type)
Sex::~Sex Destructor
Collapse Expand Sex Enumerations
Sex::sex_type Enumeration
Collapse Expand Sex Methods
Sex::check Method
Collapse Expand toString Method
Sex::toString Method ()
Sex::toString Method (const std::string&)
Collapse Expand Sex Operators
Sex::= Operator
Collapse Expand Ssn Class
Ssn Members
Collapse Expand Ssn Constructor
Ssn::Ssn Constructor ()
Ssn::Ssn Constructor (const Ssn&)
Ssn::Ssn Constructor (const std::string&)
Ssn::Ssn Constructor (const std::string&, const std::string&, const std::string&)
Ssn::~Ssn Destructor
Collapse Expand Ssn Methods
Ssn::deleteContents Method
Ssn::getPart1 Method
Ssn::getPart2 Method
Ssn::getPart3 Method
Ssn::setPart1 Method
Ssn::setPart2 Method
Ssn::setPart3 Method
Collapse Expand setSsnFull Method
Ssn::setSsnFull Method (const std::string&)
Ssn::setSsnFull Method (const std::string&, const std::string&, const std::string&)
Ssn::toNumber Method
Collapse Expand toString Method
Ssn::toString Method ()
Ssn::toString Method (const std::string&)
Ssn::update Method
Collapse Expand Ssn Operators
Ssn::< Operator
Ssn::= Operator
Ssn::== Operator
Collapse Expand Ssn Friends
friend class boost::serialization::access Friend
Collapse Expand TextWriterTraceListener Class
TextWriterTraceListener Members
TextWriterTraceListener::TextWriterTraceListener Constructor
TextWriterTraceListener::~TextWriterTraceListener Destructor
Collapse Expand TextWriterTraceListener Methods
TextWriterTraceListener::close Method
TextWriterTraceListener::flush Method
Collapse Expand write Method
TextWriterTraceListener::write Method (const char *)
TextWriterTraceListener::write Method (const std::string&)
Collapse Expand writeLine Method
TextWriterTraceListener::writeLine Method (const char *)
TextWriterTraceListener::writeLine Method (const std::string&)
Collapse Expand Trace Class
Trace Members
Collapse Expand Trace Methods
Trace::close Method
Trace::flush Method
Trace::getListeners Method
Collapse Expand write Method
Trace::write Method (const char *)
Trace::write Method (const std::string&)
Collapse Expand writeLine Method
Trace::writeLine Method (const char *)
Trace::writeLine Method (const std::string&)
Collapse Expand TraceListener Class
TraceListener Members
TraceListener::TraceListener Constructor
TraceListener::~TraceListener Destructor
Collapse Expand TraceListener Methods
TraceListener::close Method
TraceListener::flush Method
Collapse Expand write Method
TraceListener::write Method (const char *)
TraceListener::write Method (const std::string&)
Collapse Expand writeLine Method
TraceListener::writeLine Method (const char *)
TraceListener::writeLine Method (const std::string&)
Collapse Expand Functions
AfxFormatString1 Function
AfxFormatString2 Function
parseString Function
parseString Function
pblank Function
pcomma Function
Collapse Expand Types
BitAnnualData Type
Collapse Expand Variables
MAX_BITSET_SIZE Variable
Collapse Expand Macros
ENDS Macro
FREEZE Macro
OSTREAM Macro
PIA_IDS_2YEARS Macro
PIA_IDS_ACTQCOUT Macro
PIA_IDS_AGEMONTH Macro
PIA_IDS_AGEPLAN Macro
PIA_IDS_AIMEOUT Macro
PIA_IDS_AMEOUT Macro
PIA_IDS_ANDLATER Macro
PIA_IDS_ANSCCH Macro
PIA_IDS_APPCOLA1 Macro
PIA_IDS_APPCOLA2 Macro
PIA_IDS_APPCOLA3 Macro
PIA_IDS_APPCOLA4 Macro
PIA_IDS_ARDRI1 Macro
PIA_IDS_ARDRI10 Macro
PIA_IDS_ARDRI2 Macro
PIA_IDS_ARDRI3 Macro
PIA_IDS_ARDRI4 Macro
PIA_IDS_ARDRI5 Macro
PIA_IDS_ARDRI6 Macro
PIA_IDS_ARDRI7 Macro
PIA_IDS_ARDRI8 Macro
PIA_IDS_ARDRI9 Macro
PIA_IDS_ARFFOUT Macro
PIA_IDS_ARFMOUT Macro
PIA_IDS_ATODOUBLE Macro
PIA_IDS_ATOFLOAT Macro
PIA_IDS_ATOINT Macro
PIA_IDS_ATOLONG Macro
PIA_IDS_AVERAGETEXT Macro
PIA_IDS_AVGWG Macro
PIA_IDS_AVGWGTTL Macro
PIA_IDS_AWASSUM Macro
PIA_IDS_AWBI1 Macro
PIA_IDS_AWBI2 Macro
PIA_IDS_AWBI3 Macro
PIA_IDS_AWBIDAT1 Macro
PIA_IDS_AWOUT Macro
PIA_IDS_BASE1 Macro
PIA_IDS_BASE2 Macro
PIA_IDS_BASECH Macro
PIA_IDS_BASEYR1 Macro
PIA_IDS_BASEYR2 Macro
PIA_IDS_BASEYR3 Macro
PIA_IDS_BASEYR4 Macro
PIA_IDS_BEGIN1 Macro
PIA_IDS_BEGIN2 Macro
PIA_IDS_BEGIN3 Macro
PIA_IDS_BEGIN4 Macro
PIA_IDS_BEGIN5 Macro
PIA_IDS_BEGIN6 Macro
PIA_IDS_BEN1OUT Macro
PIA_IDS_BEN2OUT Macro
PIA_IDS_BENARRAY1 Macro
PIA_IDS_BENARRAY2 Macro
PIA_IDS_BENDATE1 Macro
PIA_IDS_BENDATE2 Macro
PIA_IDS_BENDATE3 Macro
PIA_IDS_BENDATE4 Macro
PIA_IDS_BENDATE5 Macro
PIA_IDS_BENDATE6 Macro
PIA_IDS_BENFOUT Macro
PIA_IDS_BIASSUM Macro
PIA_IDS_BICCHP Macro
PIA_IDS_BIOUT Macro
PIA_IDS_BIPROJTTL Macro
PIA_IDS_BIRTH1 Macro
PIA_IDS_BIRTH2 Macro
PIA_IDS_BIRTH3 Macro
PIA_IDS_BIRTH4 Macro
PIA_IDS_BIRTH5 Macro
PIA_IDS_BIRTH6 Macro
PIA_IDS_BITANN1 Macro
PIA_IDS_CACHUP1 Macro
PIA_IDS_CACHUP2 Macro
PIA_IDS_CACHUP3 Macro
PIA_IDS_CACHUP4 Macro
PIA_IDS_CESS2OUT Macro
PIA_IDS_COMMA Macro
PIA_IDS_CONFIG1 Macro
PIA_IDS_CONFIG5 Macro
PIA_IDS_CONFIG6 Macro
PIA_IDS_CPIINC1 Macro
PIA_IDS_CPIINC2 Macro
PIA_IDS_CPIINC3 Macro
PIA_IDS_CPIINC4 Macro
PIA_IDS_CUPROJTTL Macro
PIA_IDS_CURINSOUT Macro
PIA_IDS_DATEDAY Macro
PIA_IDS_DATEDIFF Macro
PIA_IDS_DATEMONTH Macro
PIA_IDS_DATEREAD Macro
PIA_IDS_DATEYEAR Macro
PIA_IDS_DBLEANN1 Macro
PIA_IDS_DBLEANN2 Macro
PIA_IDS_DEATH1 Macro
PIA_IDS_DEATH2 Macro
PIA_IDS_DEATH3 Macro
PIA_IDS_DEATH4 Macro
PIA_IDS_DEATH5 Macro
PIA_IDS_DEATH6 Macro
PIA_IDS_DEATHOUT Macro
PIA_IDS_DIBENTOUT Macro
PIA_IDS_DICESS1 Macro
PIA_IDS_DICESS2 Macro
PIA_IDS_DICESS3 Macro
PIA_IDS_DICESS4 Macro
PIA_IDS_DICESS5 Macro
PIA_IDS_DICESS6 Macro
PIA_IDS_DICESS7 Macro
PIA_IDS_DICESS8 Macro
PIA_IDS_DINS1OUT Macro
PIA_IDS_DINS2OUT Macro
PIA_IDS_DINS3OUT Macro
PIA_IDS_DISREQCAL1 Macro
PIA_IDS_DISREQCAL2 Macro
PIA_IDS_DOBOUT Macro
PIA_IDS_DOBWIDOUT Macro
PIA_IDS_DRCFOUT Macro
PIA_IDS_DRCMOUT Macro
PIA_IDS_EARNHI Macro
PIA_IDS_EARNMAL Macro
PIA_IDS_EARNPEBS Macro
PIA_IDS_EARNPROJ Macro
PIA_IDS_EARNTYPE Macro
PIA_IDS_EARNTYPE1 Macro
PIA_IDS_EARNTYPEYR Macro
PIA_IDS_ELAPSOUT Macro
PIA_IDS_END1 Macro
PIA_IDS_END2 Macro
PIA_IDS_END3 Macro
PIA_IDS_END4 Macro
PIA_IDS_ENT1 Macro
PIA_IDS_ENT2 Macro
PIA_IDS_ENT3 Macro
PIA_IDS_ENT4 Macro
PIA_IDS_ERNLIMOUT Macro
PIA_IDS_FAMSIZE Macro
PIA_IDS_FLOATANN1 Macro
PIA_IDS_FLOATANN2 Macro
PIA_IDS_FLOATMTH1 Macro
PIA_IDS_FLOATMTH2 Macro
PIA_IDS_FLOATMTH3 Macro
PIA_IDS_FLOATQTR1 Macro
PIA_IDS_FLOATQTR2 Macro
PIA_IDS_FLOATQTR3 Macro
PIA_IDS_FLOATQTR4 Macro
PIA_IDS_FMSTRING Macro
PIA_IDS_FOINFO1 Macro
PIA_IDS_FOINFO2 Macro
PIA_IDS_FOINFO3 Macro
PIA_IDS_FQINC1 Macro
PIA_IDS_FQINC2 Macro
PIA_IDS_FQINC3 Macro
PIA_IDS_FQINC4 Macro
PIA_IDS_FULLBEN Macro
PIA_IDS_GENFILE1 Macro
PIA_IDS_GENFILE2 Macro
PIA_IDS_GENFILE3 Macro
PIA_IDS_HIGHTEXT Macro
PIA_IDS_HISTAMTTL Macro
PIA_IDS_HISTAMTUPDATE Macro
PIA_IDS_IALTAW1 Macro
PIA_IDS_IALTAW2 Macro
PIA_IDS_IALTBI1 Macro
PIA_IDS_IALTBI2 Macro
PIA_IDS_INSTATOUT Macro
PIA_IDS_INSUREOUT Macro
PIA_IDS_INTANN1 Macro
PIA_IDS_INTANN2 Macro
PIA_IDS_JBIRTH1 Macro
PIA_IDS_JBIRTH2 Macro
PIA_IDS_JBIRTH3 Macro
PIA_IDS_JBIRTH4 Macro
PIA_IDS_JBIRTH5 Macro
PIA_IDS_JOASDI Macro
PIA_IDS_JONSET1 Macro
PIA_IDS_JONSET2 Macro
PIA_IDS_JONSET3 Macro
PIA_IDS_JONSET4 Macro
PIA_IDS_JONSET5 Macro
PIA_IDS_JONSET6 Macro
PIA_IDS_JONSET7 Macro
PIA_IDS_JSURV Macro
PIA_IDS_JSURVOUT Macro
PIA_IDS_LAWCHG1 Macro
PIA_IDS_LAWCHG2 Macro
PIA_IDS_LAWCHG3 Macro
PIA_IDS_LAWCHG4 Macro
PIA_IDS_LAWCHG5 Macro
PIA_IDS_LAWCHG6 Macro
PIA_IDS_LAWCHG7 Macro
PIA_IDS_LAWCHG8 Macro
PIA_IDS_LAWCHG9 Macro
PIA_IDS_LOWTEXT Macro
PIA_IDS_MAXIMUMTEXT Macro
PIA_IDS_METHOD Macro
PIA_IDS_MFBBEN Macro
PIA_IDS_MFBLOUT Macro
PIA_IDS_MFBOUT Macro
PIA_IDS_MILSERV1 Macro
PIA_IDS_MILSERV2 Macro
PIA_IDS_MILSERV3 Macro
PIA_IDS_MILSERV4 Macro
PIA_IDS_MILSERV5 Macro
PIA_IDS_MILSERV6 Macro
PIA_IDS_MILSERV7 Macro
PIA_IDS_MODTC Macro
PIA_IDS_MONTHTEXT Macro
PIA_IDS_NAMEOUT Macro
PIA_IDS_NDISINOUT Macro
PIA_IDS_NEEDAW Macro
PIA_IDS_NEEDBASES Macro
PIA_IDS_NEEDBI Macro
PIA_IDS_NINSTOUT Macro
PIA_IDS_NINSUROUT Macro
PIA_IDS_NONPENDATE1 Macro
PIA_IDS_NONPENDATE2 Macro
PIA_IDS_NONPENDATE3 Macro
PIA_IDS_NONPENDATEOUT Macro
PIA_IDS_NONPENOUT Macro
PIA_IDS_NRA1OUT Macro
PIA_IDS_NRAOUT Macro
PIA_IDS_NRAWIDOUT Macro
PIA_IDS_NRAWIFEOUT Macro
PIA_IDS_NTOTALOUT Macro
PIA_IDS_OABBENOUT Macro
PIA_IDS_OABENTOUT Macro
PIA_IDS_OLDSTART1 Macro
PIA_IDS_OLDSTART2 Macro
PIA_IDS_ONEPAGE Macro
PIA_IDS_ONSET1 Macro
PIA_IDS_ONSET10 Macro
PIA_IDS_ONSET11 Macro
PIA_IDS_ONSET2 Macro
PIA_IDS_ONSET2OUT Macro
PIA_IDS_ONSET3 Macro
PIA_IDS_ONSET4 Macro
PIA_IDS_ONSET5 Macro
PIA_IDS_ONSET6 Macro
PIA_IDS_ONSET7 Macro
PIA_IDS_ONSET8 Macro
PIA_IDS_ONSET9 Macro
PIA_IDS_ONSETOUT Macro
PIA_IDS_OPENERR Macro
PIA_IDS_OSRANGE1 Macro
PIA_IDS_OSRANGE2 Macro
PIA_IDS_OSSTRING Macro
PIA_IDS_OUTFILE Macro
PIA_IDS_PEBESMONTH Macro
PIA_IDS_PEBSASM Macro
PIA_IDS_PERCBACK Macro
PIA_IDS_PERCFWRD Macro
PIA_IDS_PIACALPLRGE Macro
PIA_IDS_PIACALRANGE Macro
PIA_IDS_PIALOUT Macro
PIA_IDS_PIAOUT Macro
PIA_IDS_PIATABLE1 Macro
PIA_IDS_PIATABLE2 Macro
PIA_IDS_PIB50MFB Macro
PIA_IDS_PIB50PIB Macro
PIA_IDS_PIB52MFB Macro
PIA_IDS_PIB54MFB Macro
PIA_IDS_PIB54PIA Macro
PIA_IDS_PIB58AME Macro
PIA_IDS_PIB58PIB Macro
PIA_IDS_PIBTABLE1 Macro
PIA_IDS_PIBTABLE2 Macro
PIA_IDS_PONSETOUT Macro
PIA_IDS_PRCESSOUT Macro
PIA_IDS_PRENTOUT Macro
PIA_IDS_PRIOROUT Macro
PIA_IDS_PROBASOUT Macro
PIA_IDS_PROJBACK1 Macro
PIA_IDS_PROJBACK2 Macro
PIA_IDS_PROJFWRD1 Macro
PIA_IDS_PROJFWRD2 Macro
PIA_IDS_PRRENT1 Macro
PIA_IDS_PRRENT2 Macro
PIA_IDS_PRRENT3 Macro
PIA_IDS_PRRENT4 Macro
PIA_IDS_PRRENT5 Macro
PIA_IDS_PRRENT6 Macro
PIA_IDS_PRRENT7 Macro
PIA_IDS_PTSTRING Macro
PIA_IDS_PUBPEN Macro
PIA_IDS_QC Macro
PIA_IDS_QC51TD Macro
PIA_IDS_QCAMT Macro
PIA_IDS_QCANN Macro
PIA_IDS_QCARRAY1 Macro
PIA_IDS_QCARRAY2 Macro
PIA_IDS_QCARRAY3 Macro
PIA_IDS_QCARRAY4 Macro
PIA_IDS_QCCAL Macro
PIA_IDS_QCDISCAL Macro
PIA_IDS_QCLUMPYEAR Macro
PIA_IDS_QCPACKED1 Macro
PIA_IDS_QCPACKED2 Macro
PIA_IDS_QCTD Macro
PIA_IDS_QCTOT0 Macro
PIA_IDS_QTRYRQTR Macro
PIA_IDS_QTRYRYR Macro
PIA_IDS_READEOF Macro
PIA_IDS_READERR Macro
PIA_IDS_READMORE Macro
PIA_IDS_RELERNOUT Macro
PIA_IDS_RELERNPOS Macro
PIA_IDS_REQQCOUT Macro
PIA_IDS_REVIEWBI Macro
PIA_IDS_ROUND Macro
PIA_IDS_RTGENRL Macro
PIA_IDS_RWSTRING Macro
PIA_IDS_SECONDARY Macro
PIA_IDS_SETNOCH Macro
PIA_IDS_SEX Macro
PIA_IDS_SEXOUT Macro
PIA_IDS_SGAPROJ Macro
PIA_IDS_SMSTRING Macro
PIA_IDS_SPPIA1OUT Macro
PIA_IDS_SPPIA2OUT Macro
PIA_IDS_SPYRS2OUT Macro
PIA_IDS_SPYRSOUT Macro
PIA_IDS_SSN1 Macro
PIA_IDS_SSNOUT Macro
PIA_IDS_START1 Macro
PIA_IDS_START2 Macro
PIA_IDS_SUPPIAOUT Macro
PIA_IDS_SURVBENOUT Macro
PIA_IDS_SURVENTOUT Macro
PIA_IDS_TAXTYPE Macro
PIA_IDS_TAXTYPEYR Macro
PIA_IDS_TGSTRING Macro
PIA_IDS_TITLEPRO1 Macro
PIA_IDS_TITLEPRO2 Macro
PIA_IDS_TITLEPRO3 Macro
PIA_IDS_TITLEPRO4 Macro
PIA_IDS_TWOPAGE1 Macro
PIA_IDS_TWOPAGE2 Macro
PIA_IDS_TWOPAGE3 Macro
PIA_IDS_TWOPAGE4 Macro
PIA_IDS_TWOPAGE5 Macro
PIA_IDS_TXSTRING Macro
PIA_IDS_UNBICCHP Macro
PIA_IDS_UNEARNOUT Macro
PIA_IDS_UPDATEAW Macro
PIA_IDS_UPDATEBI Macro
PIA_IDS_UPDATEFQ Macro
PIA_IDS_UPDATEWB Macro
PIA_IDS_UPDATEWBOLD Macro
PIA_IDS_VALDI1 Macro
PIA_IDS_VALDI2 Macro
PIA_IDS_WAGEBASE Macro
PIA_IDS_WAITPD1 Macro
PIA_IDS_WAITPD2 Macro
PIA_IDS_WAITPD3 Macro
PIA_IDS_WAITPD4 Macro
PIA_IDS_WAITPD5 Macro
PIA_IDS_WAITPD6 Macro
PIA_IDS_WAITPD7 Macro
PIA_IDS_WIDDIBOUT Macro
PIA_IDS_WISTRING Macro
PIA_IDS_WRITEEARN Macro
PIA_IDS_YEAR Macro
_AFXDLL Macro
Collapse Expand Files
AnnualArrays.cpp
AnnualArrays.h
BitAnnual.cpp
BitAnnual.h
BitAnnualBase.cpp
BitAnnualBase.h
BitAnnualInlines.h
CommaBase.h
DateFormatter.cpp
DateFormatter.h
DoubleAnnualRW.cpp
DoubleAnnualRW.h
FormatString.cpp
FormatString.h
NumPunct.cpp
NumPunct.h
OutDC.cpp
OutDC.h
OutFile132.cpp
OutFile132.h
OutFile80.cpp
OutFile80.h
OutfileHTML.cpp
OutfileHTML.h
PageOut.cpp
PageOut.h
Path.cpp
Path.h
PiaException.cpp
PiaException.h
Resource.h
Sex.cpp
Sex.h
StringParser.cpp
StringParser.h
TextWriterTraceListener.cpp
TextWriterTraceListener.h
Trace.cpp
Trace.h
TraceListener.cpp
TraceListener.h
age.cpp
age.h
comma.cpp
comma.h
date.cpp
date.h
datemoyr.cpp
datemoyr.h
dbleann.cpp
dbleann.h
dblemth.cpp
dblemth.h
dbleqtr.cpp
dbleqtr.h
document.cpp
document.h
floatann.cpp
floatann.h
floatmth.cpp
floatmth.h
floatqtr.cpp
floatqtr.h
genfile.cpp
genfile.h
intann.cpp
intann.h
outfile.cpp
outfile.h
page.cpp
page.h
qtryear.cpp
qtryear.h
ssn.cpp
ssn.h
Collapse Expand PiaOut Library
Collapse Expand Classes
Collapse Expand AnypiaOut Class
AnypiaOut Members
AnypiaOut::AnypiaOut Constructor
Collapse Expand AnypiaOut Methods
AnypiaOut::fillPageSlots Method
AnypiaOut::getPage Method
AnypiaOut::getPageCount Method
AnypiaOut::setPebsOut Method
AnypiaOut::setPiaCal Method
AnypiaOut::setPiaData Method
AnypiaOut::setPiaOut Method
AnypiaOut::setWorkerData Method
Collapse Expand ChildCareCalc1Page Class
ChildCareCalc1Page Members
ChildCareCalc1Page::ChildCareCalc1Page Constructor
ChildCareCalc1Page::~ChildCareCalc1Page Destructor
Collapse Expand ChildCareCalc1Page Methods
ChildCareCalc1Page::prepareStrings Method
Collapse Expand ChildCareCalc2Page Class
ChildCareCalc2Page Members
ChildCareCalc2Page::ChildCareCalc2Page Constructor
ChildCareCalc2Page::~ChildCareCalc2Page Destructor
Collapse Expand ChildCareCalc2Page Data Members
ChildCareCalc2Page::piaCal Data Member
ChildCareCalc2Page::piaData Data Member
ChildCareCalc2Page::piaParams Data Member
ChildCareCalc2Page::userAssumptions Data Member
ChildCareCalc2Page::workerData Data Member
Collapse Expand ChildCareCalc2Page Methods
ChildCareCalc2Page::prepareStrings Method
Collapse Expand DibGuarPage Class
DibGuarPage Members
DibGuarPage::DibGuarPage Constructor
DibGuarPage::~DibGuarPage Destructor
Collapse Expand DibGuarPage Methods
DibGuarPage::piamfbDeath Method
DibGuarPage::prepareStrings Method
Collapse Expand EarningsPage Class
EarningsPage Members
EarningsPage::EarningsPage Constructor
EarningsPage::~EarningsPage Destructor
Collapse Expand EarningsPage Methods
EarningsPage::prepareStrings Method
Collapse Expand FamilyPage Class
FamilyPage Members
FamilyPage::FamilyPage Constructor
FamilyPage::~FamilyPage Destructor
Collapse Expand FamilyPage Methods
FamilyPage::prepareStrings Method
Collapse Expand FrozMinPage Class
FrozMinPage Members
FrozMinPage::FrozMinPage Constructor
FrozMinPage::~FrozMinPage Destructor
Collapse Expand FrozMinPage Methods
FrozMinPage::prepareStrings Method
Collapse Expand InsuredPage Class
InsuredPage Members
InsuredPage::InsuredPage Constructor
InsuredPage::~InsuredPage Destructor
Collapse Expand InsuredPage Methods
InsuredPage::prepareStrings Method
Collapse Expand OldStart1Page Class
OldStart1Page Members
OldStart1Page::OldStart1Page Constructor
OldStart1Page::~OldStart1Page Destructor
Collapse Expand OldStart1Page Methods
OldStart1Page::prepareStrings Method
Collapse Expand OldStart2Page Class
OldStart2Page Members
OldStart2Page::OldStart2Page Constructor
OldStart2Page::~OldStart2Page Destructor
Collapse Expand OldStart2Page Methods
OldStart2Page::prepareStrings Method
OldStart2Page::pubPenOut Method
Collapse Expand OnePage Class
OnePage Members
OnePage::OnePage Constructor
OnePage::~OnePage Destructor
Collapse Expand OnePage Methods
OnePage::prepareStrings Method
OnePage::printEarn Method
Collapse Expand PebsCreditInfo Class
PebsCreditInfo Members
PebsCreditInfo::PebsCreditInfo Constructor
PebsCreditInfo::~PebsCreditInfo Destructor
Collapse Expand PebsCreditInfo Methods
PebsCreditInfo::prepareStrings Method
Collapse Expand PebsEarnings Class
PebsEarnings Members
PebsEarnings::PebsEarnings Constructor
PebsEarnings::~PebsEarnings Destructor
Collapse Expand PebsEarnings Methods
PebsEarnings::prepareStrings Method
Collapse Expand PebsEarningsInfo Class
PebsEarningsInfo Members
PebsEarningsInfo::PebsEarningsInfo Constructor
PebsEarningsInfo::~PebsEarningsInfo Destructor
Collapse Expand PebsEarningsInfo Methods
PebsEarningsInfo::prepareStrings Method
Collapse Expand PebsLetter Class
PebsLetter Members
PebsLetter::PebsLetter Constructor
PebsLetter::~PebsLetter Destructor
Collapse Expand PebsLetter Methods
PebsLetter::prepareStrings Method
Collapse Expand PebsOasdiEst Class
PebsOasdiEst Members
PebsOasdiEst::PebsOasdiEst Constructor
PebsOasdiEst::~PebsOasdiEst Destructor
Collapse Expand PebsOasdiEst Methods
PebsOasdiEst::prepareStrings Method
Collapse Expand PebsOasdiInfo Class
PebsOasdiInfo Members
PebsOasdiInfo::PebsOasdiInfo Constructor
PebsOasdiInfo::~PebsOasdiInfo Destructor
Collapse Expand PebsOasdiInfo Methods
PebsOasdiInfo::prepareStrings Method
Collapse Expand PebsOut Class
PebsOut Members
PebsOut::PebsOut Constructor
PebsOut::~PebsOut Destructor
Collapse Expand PebsOut Data Members
PebsOut::pebsCreditInfo Data Member
PebsOut::pebsEarnings Data Member
PebsOut::pebsEarningsInfo Data Member
PebsOut::pebsLetter Data Member
PebsOut::pebsOasdiEst Data Member
PebsOut::pebsOasdiInfo Data Member
PebsOut::pebsWorkerEarnings Data Member
PebsOut::pebsWorkerInfo Data Member
Collapse Expand PebsOut Methods
PebsOut::prepareStrings Method
PebsOut::setPageNum Method
Collapse Expand PebsPageOut Class
PebsPageOut Members
PebsPageOut::PebsPageOut Constructor
PebsPageOut::~PebsPageOut Destructor
Collapse Expand PebsPageOut Data Members
PebsPageOut::equals Data Member
PebsPageOut::hyphens Data Member
Collapse Expand PebsPageOut Methods
PebsPageOut::prepareHeader Method
PebsPageOut::setPageNum Method
Collapse Expand PebsWorkerEarnings Class
PebsWorkerEarnings Members
PebsWorkerEarnings::PebsWorkerEarnings Constructor
PebsWorkerEarnings::~PebsWorkerEarnings Destructor
Collapse Expand PebsWorkerEarnings Methods
PebsWorkerEarnings::prepareStrings Method
Collapse Expand PebsWorkerInfo Class
PebsWorkerInfo Members
PebsWorkerInfo::PebsWorkerInfo Constructor
PebsWorkerInfo::~PebsWorkerInfo Destructor
Collapse Expand PebsWorkerInfo Methods
PebsWorkerInfo::prepareStrings Method
Collapse Expand PiaOut Class
PiaOut Members
PiaOut::PiaOut Constructor
PiaOut::~PiaOut Destructor
Collapse Expand PiaOut Data Members
PiaOut::MAX_REINDWID Data Member
PiaOut::childCareCalc1Page Data Member
PiaOut::childCareCalc2Page Data Member
PiaOut::dibGuarPage Data Member
PiaOut::earningsPage Data Member
PiaOut::familyPage Data Member
PiaOut::frozMinPage Data Member
PiaOut::insuredPage Data Member
PiaOut::oldStart1Page Data Member
PiaOut::oldStart2Page Data Member
PiaOut::onePage Data Member
PiaOut::piaTable1Page Data Member
PiaOut::piaTable2Page Data Member
PiaOut::reindWid1Page Data Member
PiaOut::reindWid2Page Data Member
PiaOut::specMin1Page Data Member
PiaOut::specMin2Page Data Member
PiaOut::summary1Page Data Member
PiaOut::summary2Page Data Member
PiaOut::summary3Page Data Member
PiaOut::summaryPage Data Member
PiaOut::taxesPage Data Member
PiaOut::transGuar1Page Data Member
PiaOut::transGuar2Page Data Member
PiaOut::wageInd1Page Data Member
PiaOut::wageInd2Page Data Member
PiaOut::wageIndNonFreeze1Page Data Member
PiaOut::wageIndNonFreeze2Page Data Member
Collapse Expand PiaOut Methods
PiaOut::prepareStrings Method
PiaOut::setPageNum Method
Collapse Expand PiaPageOut Class
PiaPageOut Members
PiaPageOut::PiaPageOut Constructor
PiaPageOut::~PiaPageOut Destructor
Collapse Expand PiaPageOut Data Members
PiaPageOut::pageTitle Data Member
Collapse Expand PiaPageOut Methods
PiaPageOut::baseYearOut Method
Collapse Expand biOut Method
PiaPageOut::biOut Method (const PiaMethod&, const PiaParams&, int, int, int)
PiaPageOut::biOut Method (const PiaMethod&, const PiaParams&, int, int, int, int)
PiaPageOut::compYear Method
PiaPageOut::disInsOut Method
PiaPageOut::disMfbOut Method
PiaPageOut::endYearCal Method
PiaPageOut::firstYearCal Method
PiaPageOut::mfbBpOut Method
Collapse Expand mfbOut Method
PiaPageOut::mfbOut Method (const PiaMethod&, const double, const PercMfb&)
PiaPageOut::mfbOut Method (const PiaMethod&, const double, const PercMfb&, double)
PiaPageOut::newTableOut Method
PiaPageOut::nonIns Method
PiaPageOut::nonpenOut Method
PiaPageOut::osTableOut Method
PiaPageOut::piaBpOut Method
PiaPageOut::piaEligOut Method
PiaPageOut::piaEntOut Method
PiaPageOut::piamfb1 Method
PiaPageOut::piamfb2 Method
PiaPageOut::piamfb3 Method
PiaPageOut::prepareHeader Method
PiaPageOut::printIndexedEarningsTable Method
PiaPageOut::printNameSsn Method
PiaPageOut::printRealWageGain Method
PiaPageOut::pubPenOut Method
PiaPageOut::rawPiaOut Method
PiaPageOut::setPageNum Method
PiaPageOut::tableHead1 Method
PiaPageOut::tableHead2 Method
PiaPageOut::totPiaOut Method
Collapse Expand PiaTable1Page Class
PiaTable1Page Members
PiaTable1Page::PiaTable1Page Constructor
PiaTable1Page::~PiaTable1Page Destructor
Collapse Expand PiaTable1Page Methods
PiaTable1Page::prepareStrings Method
Collapse Expand PiaTable2Page Class
PiaTable2Page Members
PiaTable2Page::PiaTable2Page Constructor
PiaTable2Page::~PiaTable2Page Destructor
Collapse Expand PiaTable2Page Methods
PiaTable2Page::prepareStrings Method
Collapse Expand ReindWid1Page Class
ReindWid1Page Members
ReindWid1Page::ReindWid1Page Constructor
ReindWid1Page::~ReindWid1Page Destructor
Collapse Expand ReindWid1Page Data Members
ReindWid1Page::reindWid Data Member
Collapse Expand ReindWid1Page Methods
ReindWid1Page::prepareStrings Method
Collapse Expand ReindWid2Page Class
ReindWid2Page Members
ReindWid2Page::ReindWid2Page Constructor
ReindWid2Page::~ReindWid2Page Destructor
Collapse Expand ReindWid2Page Data Members
ReindWid2Page::reindWid Data Member
Collapse Expand ReindWid2Page Methods
ReindWid2Page::prepareStrings Method
Collapse Expand SpecMin1Page Class
SpecMin1Page Members
SpecMin1Page::SpecMin1Page Constructor
SpecMin1Page::~SpecMin1Page Destructor
Collapse Expand SpecMin1Page Methods
SpecMin1Page::prepareStrings Method
Collapse Expand SpecMin2Page Class
SpecMin2Page Members
SpecMin2Page::SpecMin2Page Constructor
SpecMin2Page::~SpecMin2Page Destructor
Collapse Expand SpecMin2Page Methods
SpecMin2Page::prepareStrings Method
Collapse Expand Summary1Page Class
Summary1Page Members
Summary1Page::Summary1Page Constructor
Summary1Page::~Summary1Page Destructor
Collapse Expand Summary1Page Methods
Summary1Page::prepareStrings Method
Summary1Page::printDisInfo Method
Collapse Expand Summary2Page Class
Summary2Page Members
Summary2Page::Summary2Page Constructor
Summary2Page::~Summary2Page Destructor
Collapse Expand Summary2Page Methods
Summary2Page::prepareStrings Method
Collapse Expand Summary3Page Class
Summary3Page Members
Summary3Page::Summary3Page Constructor
Summary3Page::~Summary3Page Destructor
Collapse Expand Summary3Page Methods
Summary3Page::bottom3 Method
Summary3Page::disclaimer Method
Summary3Page::nonInsPara Method
Summary3Page::prepareStrings Method
Collapse Expand SummaryPage Class
SummaryPage Members
SummaryPage::SummaryPage Constructor
SummaryPage::~SummaryPage Destructor
Collapse Expand SummaryPage Methods
SummaryPage::prepareStrings Method
Collapse Expand TaxesPage Class
TaxesPage Members
TaxesPage::TaxesPage Constructor
TaxesPage::~TaxesPage Destructor
Collapse Expand TaxesPage Methods
TaxesPage::prepareStrings Method
Collapse Expand TransGuar1Page Class
TransGuar1Page Members
TransGuar1Page::TransGuar1Page Constructor
TransGuar1Page::~TransGuar1Page Destructor
Collapse Expand TransGuar1Page Methods
TransGuar1Page::prepareStrings Method
Collapse Expand TransGuar2Page Class
TransGuar2Page Members
TransGuar2Page::TransGuar2Page Constructor
TransGuar2Page::~TransGuar2Page Destructor
Collapse Expand TransGuar2Page Methods
TransGuar2Page::prepareStrings Method
Collapse Expand WageInd1Page Class
WageInd1Page Members
WageInd1Page::WageInd1Page Constructor
WageInd1Page::~WageInd1Page Destructor
Collapse Expand WageInd1Page Methods
WageInd1Page::prepareStrings Method
Collapse Expand WageInd2Page Class
WageInd2Page Members
WageInd2Page::WageInd2Page Constructor
WageInd2Page::~WageInd2Page Destructor
Collapse Expand WageInd2Page Methods
WageInd2Page::prepareStrings Method
Collapse Expand WageIndNonFreeze1Page Class
WageIndNonFreeze1Page Members
WageIndNonFreeze1Page::WageIndNonFreeze1Page Constructor
WageIndNonFreeze1Page::~WageIndNonFreeze1Page Destructor
Collapse Expand WageIndNonFreeze1Page Methods
WageIndNonFreeze1Page::prepareStrings Method
Collapse Expand WageIndNonFreeze2Page Class
WageIndNonFreeze2Page Members
WageIndNonFreeze2Page::WageIndNonFreeze2Page Constructor
WageIndNonFreeze2Page::~WageIndNonFreeze2Page Destructor
Collapse Expand WageIndNonFreeze2Page Methods
WageIndNonFreeze2Page::prepareStrings Method
Collapse Expand Files
AnypiaOut.cpp
AnypiaOut.h
ChildCareCalc1Page.cpp
ChildCareCalc1Page.h
ChildCareCalc2Page.cpp
ChildCareCalc2Page.h
DibGuarPage.cpp
DibGuarPage.h
EarningsPage.cpp
EarningsPage.h
FamilyPage.cpp
FamilyPage.h
FrozMinPage.cpp
FrozMinPage.h
InsuredPage.cpp
InsuredPage.h
OldStart1Page.cpp
OldStart1Page.h
OldStart2Page.cpp
OldStart2Page.h
OnePage.cpp
OnePage.h
PebsCreditInfo.cpp
PebsCreditInfo.h
PebsEarnings.cpp
PebsEarnings.h
PebsEarningsInfo.cpp
PebsEarningsInfo.h
PebsLetter.cpp
PebsLetter.h
PebsOasdiEst.cpp
PebsOasdiEst.h
PebsOasdiInfo.cpp
PebsOasdiInfo.h
PebsOut.cpp
PebsOut.h
PebsPageOut.cpp
PebsPageOut.h
PebsWorkerEarnings.cpp
PebsWorkerEarnings.h
PebsWorkerInfo.cpp
PebsWorkerInfo.h
PiaOut.cpp
PiaOut.h
PiaPageOut.cpp
PiaPageOut.h
PiaTable1Page.cpp
PiaTable1Page.h
PiaTable2Page.cpp
PiaTable2Page.h
ReindWid1Page.cpp
ReindWid1Page.h
ReindWid2Page.cpp
ReindWid2Page.h
SpecMin1Page.cpp
SpecMin1Page.h
SpecMin2Page.cpp
SpecMin2Page.h
Summary1Page.cpp
Summary1Page.h
Summary2Page.cpp
Summary2Page.h
Summary3Page.cpp
Summary3Page.h
SummaryPage.cpp
SummaryPage.h
TaxesPage.cpp
TaxesPage.h
TransGuar1Page.cpp
TransGuar1Page.h
TransGuar2Page.cpp
TransGuar2Page.h
WageInd1Page.cpp
WageInd1Page.h
WageInd2Page.cpp
WageInd2Page.h
WageIndNonFreeze1Page.cpp
WageIndNonFreeze1Page.h
WageIndNonFreeze2Page.cpp
WageIndNonFreeze2Page.h


Index

Index
A | B | C | D | F | G | I | M | O | P | Q | R | S | W
A
ADHOC enumeration member
AGE65COMP enumeration member
AIME_85 enumeration member
ALLEARN enumeration member
ALTERN_I enumeration member
ALTERN_IIA enumeration member
ALTERN_IIB enumeration member
ALTERN_III enumeration member
ANNUITY_JS enumeration member
ANNUITY_SL enumeration member
APPLICABLE enumeration member
AUTOMATIC enumeration member
AVERAGE enumeration member
AVGWAGE_PROJ enumeration member
AfxFormatString1
AfxFormatString1 function
AfxFormatString2
AfxFormatString2 function
Age
Age class
-
<
=
==
Age
Age
Age
Age
Age constructor
Age friends
Age members
Age methods
Age operators
about Age class
class boost::serialization::access
deleteContents
getMonths
getYears
monthsCheck
toMonths
toString
toString
toString method
~Age
Age::-
Age::<
Age::=
Age::==
Age::Age
Age::deleteContents
Age::getMonths
Age::getYears
Age::monthsCheck
Age::toMonths
Age::toString
Age::~Age
AnnualArrays
AnnualArrays class
AnnualArrays members
AnnualArrays methods
about AnnualArrays class
add
convert
divide
multiply
multiply
multiply method
subtract
AnnualArrays.cpp
AnnualArrays.h
AnnualArrays::add
AnnualArrays::convert
AnnualArrays::divide
AnnualArrays::multiply
AnnualArrays::subtract
AnypiaOut
AnypiaOut class
AnypiaOut
AnypiaOut members
AnypiaOut methods
about AnypiaOut class
fillPageSlots
getPage
getPageCount
setPebsOut
setPiaCal
setPiaData
setPiaOut
setWorkerData
AnypiaOut.cpp
AnypiaOut.h
AnypiaOut::AnypiaOut
AnypiaOut::fillPageSlots
AnypiaOut::getPage
AnypiaOut::getPageCount
AnypiaOut::setPebsOut
AnypiaOut::setPiaCal
AnypiaOut::setPiaData
AnypiaOut::setPiaOut
AnypiaOut::setWorkerData
AssumptionType
AssumptionType class
AssumptionType data members
AssumptionType enumerations
AssumptionType members
AssumptionType methods
EXPANDED_PEBES
about AssumptionType class
ialtawCheck1
ialtawCheck2
ialtbiCheck1
ialtbiCheck2
isFlatOrPebs
isNotTR
isTR
AssumptionType.cpp
AssumptionType.h
AssumptionType::EXPANDED_PEBES
AssumptionType::assum_type
AssumptionType::assum_type enumeration
AssumptionType::ialtawCheck1
AssumptionType::ialtawCheck2
AssumptionType::ialtbiCheck1
AssumptionType::ialtbiCheck2
AssumptionType::isFlatOrPebs
AssumptionType::isNotTR
AssumptionType::isTR
Assumptions
Assumptions class
Assumptions
Assumptions
Assumptions constructor
Assumptions members
Assumptions methods
about Assumptions class
averageWageMenu
benefitIncMenu
getAverageWage
getAwincProj
getBenefitInc
getBiProj
getCatchupDoc
getIstart
getMaxyear
setAwincProjTitle
setBiProjTitle
setIstart
~Assumptions
Assumptions.cpp
Assumptions.h
Assumptions::Assumptions
Assumptions::averageWageMenu
Assumptions::benefitIncMenu
Assumptions::getAverageWage
Assumptions::getAwincProj
Assumptions::getBenefitInc
Assumptions::getBiProj
Assumptions::getCatchupDoc
Assumptions::getIstart
Assumptions::getMaxyear
Assumptions::setAwincProjTitle
Assumptions::setBiProjTitle
Assumptions::setIstart
Assumptions::~Assumptions
AssumptionsFile
AssumptionsFile class
AssumptionsFile
AssumptionsFile data members
AssumptionsFile members
AssumptionsFile methods
about AssumptionsFile class
averageWageMenu
awincProj
benefitIncMenu
biProj
catchupDoc
getAwincProj
getBiProj
getCatchupDoc
setAwincProjTitle
setBiProjTitle
setIstart
~AssumptionsFile
AssumptionsFile.cpp
AssumptionsFile.h
AssumptionsFile::AssumptionsFile
AssumptionsFile::averageWageMenu
AssumptionsFile::awincProj
AssumptionsFile::benefitIncMenu
AssumptionsFile::biProj
AssumptionsFile::catchupDoc
AssumptionsFile::getAwincProj
AssumptionsFile::getBiProj
AssumptionsFile::getCatchupDoc
AssumptionsFile::setAwincProjTitle
AssumptionsFile::setBiProjTitle
AssumptionsFile::setIstart
AssumptionsFile::~AssumptionsFile
AssumptionsNonFile
AssumptionsNonFile class
AssumptionsNonFile
AssumptionsNonFile
AssumptionsNonFile constructor
AssumptionsNonFile data members
AssumptionsNonFile members
AssumptionsNonFile methods
about AssumptionsNonFile class
averageWageMenu
awincProj
benefitIncMenu
biProj
catchupDoc
getAwincProj
getBiProj
getCatchupDoc
setAwincProjTitle
setBiProjTitle
setIstart
~AssumptionsNonFile
AssumptionsNonFile.cpp
AssumptionsNonFile.h
AssumptionsNonFile::AssumptionsNonFile
AssumptionsNonFile::averageWageMenu
AssumptionsNonFile::awincProj
AssumptionsNonFile::benefitIncMenu
AssumptionsNonFile::biProj
AssumptionsNonFile::catchupDoc
AssumptionsNonFile::getAwincProj
AssumptionsNonFile::getBiProj
AssumptionsNonFile::getCatchupDoc
AssumptionsNonFile::setAwincProjTitle
AssumptionsNonFile::setBiProjTitle
AssumptionsNonFile::setIstart
AssumptionsNonFile::~AssumptionsNonFile
AverageWage
AverageWage class
=
AverageWage
AverageWage friends
AverageWage members
AverageWage methods
AverageWage operators
about AverageWage class
class boost::serialization::access
endYear
project
project
project method
projectBackward
projectBackwardStatic
projectForward
projectForwardStatic
round
startYear
~AverageWage
AverageWage::=
AverageWage::AverageWage
AverageWage::endYear
AverageWage::project
AverageWage::projectBackward
AverageWage::projectBackwardStatic
AverageWage::projectForward
AverageWage::projectForwardStatic
AverageWage::round
AverageWage::startYear
AverageWage::~AverageWage
AwbiData
AwbiData class
AwbiData
AwbiData
AwbiData constructor
AwbiData data members
AwbiData members
AwbiData methods
HI_BASE_YEAR
about AwbiData class
base77
baseHi
baseOasdi
cpiinc
fq
getLastYear
read
setData
setLastYear
write
~AwbiData
AwbiData::AwbiData
AwbiData::HI_BASE_YEAR
AwbiData::base77
AwbiData::baseHi
AwbiData::baseOasdi
AwbiData::cpiinc
AwbiData::fq
AwbiData::getLastYear
AwbiData::read
AwbiData::setData
AwbiData::setLastYear
AwbiData::write
AwbiData::~AwbiData
AwbiDataFile
AwbiDataFile class
AwbiDataFile
AwbiDataFile members
AwbiDataFile methods
about AwbiDataFile class
read
read
read method
setAwbiFile
setData
write
write
write method
AwbiDataFile.h
AwbiDataFile::AwbiDataFile
AwbiDataFile::read
AwbiDataFile::setAwbiFile
AwbiDataFile::setData
AwbiDataFile::write
AwbiDataNonFile
AwbiDataNonFile class
AwbiDataNonFile
AwbiDataNonFile
AwbiDataNonFile constructor
AwbiDataNonFile members
AwbiDataNonFile methods
about AwbiDataNonFile class
getBase77Data
getBaseHiData
getBaseOasdiData
getCpiincData
getFqData
setData
AwbiDataNonFile.h
AwbiDataNonFile::AwbiDataNonFile
AwbiDataNonFile::getBase77Data
AwbiDataNonFile::getBaseHiData
AwbiDataNonFile::getBaseOasdiData
AwbiDataNonFile::getCpiincData
AwbiDataNonFile::getFqData
AwbiDataNonFile::setData
Awinc
Awinc class
Awinc
Awinc
Awinc constructor
Awinc members
Awinc methods
about Awinc class
fqincCheck
project
project
project method
Awinc::Awinc
Awinc::fqincCheck
Awinc::project
AwincDoc
AwincDoc class
AwincDoc
AwincDoc data members
AwincDoc members
AwincDoc methods
about AwincDoc class
avgwage
awinc
awincTitle
getFirstYear
getTitle
read
setData
setData
setData method
setFirstYear
setFqinc
setTitle
setTitle
setTitle method
write
~AwincDoc
AwincDoc.cpp
AwincDoc.h
AwincDoc::AwincDoc
AwincDoc::avgwage
AwincDoc::awinc
AwincDoc::awincTitle
AwincDoc::getFirstYear
AwincDoc::getTitle
AwincDoc::read
AwincDoc::setData
AwincDoc::setFirstYear
AwincDoc::setFqinc
AwincDoc::setTitle
AwincDoc::write
AwincDoc::~AwincDoc
AwincFile
AwincFile class
AwincFile
AwincFile members
AwincFile methods
about AwincFile class
read
setAwFile
setData
setData
setData method
setTitle
setTitle
setTitle method
write
AwincFile.h
AwincFile::AwincFile
AwincFile::read
AwincFile::setAwFile
AwincFile::setData
AwincFile::setTitle
AwincFile::write
AwincNonFile
AwincNonFile class
AwincNonFile
AwincNonFile enumerations
AwincNonFile members
AwincNonFile methods
about AwincNonFile class
read
setData
setData
setData method
setTitle
setTitle
setTitle method
write
~AwincNonFile
AwincNonFile.h
AwincNonFile::AwincNonFile
AwincNonFile::DimLimits
AwincNonFile::DimLimits enumeration
AwincNonFile::read
AwincNonFile::setData
AwincNonFile::setTitle
AwincNonFile::write
AwincNonFile::~AwincNonFile
BASEYR
BASEYR variable
BASEYR1
BASEYR1 variable
BLIND_BIT enumeration member
BONDS enumeration member
BPCPI enumeration member
BPFRACWAGE enumeration member
BPMINCONST enumeration member
BPSPECRATE enumeration member
BaseChangeType
BaseChangeType class
BaseChangeType enumerations
BaseChangeType members
BaseChangeType methods
about BaseChangeType class
check
toString
BaseChangeType.cpp
BaseChangeType.h
BaseChangeType::change_type
BaseChangeType::change_type enumeration
BaseChangeType::check
BaseChangeType::toString
BaseYear
BaseYear class
BaseYear
BaseYear data members
BaseYear members
BaseYear methods
about BaseYear class
getYear
read
setYear
theYear
write
yearCheck
~BaseYear
BaseYear::BaseYear
BaseYear::getYear
BaseYear::read
BaseYear::setYear
BaseYear::theYear
BaseYear::write
BaseYear::yearCheck
BaseYear::~BaseYear
BaseYearFile
BaseYearFile class
BaseYearFile
BaseYearFile members
BaseYearFile methods
about BaseYearFile class
read
write
BaseYearFile.h
BaseYearFile::BaseYearFile
BaseYearFile::read
BaseYearFile::write
BaseYearNonFile
BaseYearNonFile class
BaseYearNonFile
BaseYearNonFile data members
BaseYearNonFile members
BaseYearNonFile methods
TR_YEAR
YEAR
about BaseYearNonFile class
read
write
BaseYearNonFile.h
BaseYearNonFile::BaseYearNonFile
BaseYearNonFile::TR_YEAR
BaseYearNonFile::YEAR
BaseYearNonFile::read
BaseYearNonFile::write
BendMfb
BendMfb class
BP1979
BendMfb
BendMfb data members
BendMfb members
BendMfb methods
BendMfb nested types
BendMfb operators
[]
[]
[] operator
about BendMfb class
as_array
begin
begin
begin method
const_iterator
const_reference
deleteContents
difference_type
end
end
end method
iterator
max_size
project
reference
size
size_type
value_type
~BendMfb
BendMfb::BP1979
BendMfb::BendMfb
BendMfb::[]
BendMfb::as_array
BendMfb::begin
BendMfb::const_iterator
BendMfb::const_reference
BendMfb::deleteContents
BendMfb::difference_type
BendMfb::end
BendMfb::iterator
BendMfb::max_size
BendMfb::project
BendMfb::reference
BendMfb::size
BendMfb::size_type
BendMfb::value_type
BendMfb::~BendMfb
BendPia
BendPia class
BP1979
BendPia
BendPia data members
BendPia members
BendPia methods
BendPia nested types
BendPia operators
[]
[]
[] operator
about BendPia class
as_array
begin
begin
begin method
const_iterator
const_reference
deleteContents
difference_type
end
end
end method
getNumBend
iterator
max_size
project
reference
setNumBend
size
size_type
value_type
~BendPia
BendPia::BP1979
BendPia::BendPia
BendPia::[]
BendPia::as_array
BendPia::begin
BendPia::const_iterator
BendPia::const_reference
BendPia::deleteContents
BendPia::difference_type
BendPia::end
BendPia::getNumBend
BendPia::iterator
BendPia::max_size
BendPia::project
BendPia::reference
BendPia::setNumBend
BendPia::size
BendPia::size_type
BendPia::value_type
BendPia::~BendPia
BendPoints.h
BenefitAmount
BenefitAmount class
<
BenefitAmount
BenefitAmount members
BenefitAmount methods
BenefitAmount operators
about BenefitAmount class
applyCola
applyCola
applyCola method
get
round
round
round method
round1
round1
round1 method
round5
round5
round5 method
set
toString
unApplyCola
unApplyCola
unApplyCola method
unround
unround
unround method
BenefitAmount.cpp
BenefitAmount.h
BenefitAmount::<
BenefitAmount::BenefitAmount
BenefitAmount::applyCola
BenefitAmount::get
BenefitAmount::round
BenefitAmount::round1
BenefitAmount::round5
BenefitAmount::set
BenefitAmount::toString
BenefitAmount::unApplyCola
BenefitAmount::unround
BenefitAmountArray
BenefitAmountArray class
BenefitAmountArray
BenefitAmountArray
BenefitAmountArray constructor
BenefitAmountArray members
BenefitAmountArray methods
BenefitAmountArray operators
[]
[]
[] operator
about BenefitAmountArray class
deleteContents
getLastYear
initialize
setDirty
~BenefitAmountArray
BenefitAmountArray.cpp
BenefitAmountArray.h
BenefitAmountArray::BenefitAmountArray
BenefitAmountArray::[]
BenefitAmountArray::deleteContents
BenefitAmountArray::getLastYear
BenefitAmountArray::initialize
BenefitAmountArray::setDirty
BenefitAmountArray::~BenefitAmountArray
Bic
Bic class
==
Bic
Bic
Bic
Bic constructor
Bic members
Bic methods
Bic operators
about Bic class
eligibleForMax
getLifeAuxType
getMajorBic
getMinorBic
getSurvivorType
isAuxiliary
isDisabledWidow
isReducible
isWidow
isYoungSpouse
isYoungSurvivor
set
setMajorBic
setMinorBic
survivorCheck
toString
Bic.cpp
Bic::==
Bic::Bic
Bic::eligibleForMax
Bic::getLifeAuxType
Bic::getMajorBic
Bic::getMinorBic
Bic::getSurvivorType
Bic::isAuxiliary
Bic::isDisabledWidow
Bic::isReducible
Bic::isWidow
Bic::isYoungSpouse
Bic::isYoungSurvivor
Bic::set
Bic::setMajorBic
Bic::setMinorBic
Bic::survivorCheck
Bic::toString
Biproj
Biproj class
Biproj
Biproj data members
Biproj members
Biproj methods
about Biproj class
beninc
biprojTitle
cpiincCheck
getFirstYear
getTitle
read
setCpiinc
setData
setData
setData method
setFirstYear
setTitle
setTitle
setTitle method
theData
write
~Biproj
Biproj::Biproj
Biproj::beninc
Biproj::biprojTitle
Biproj::cpiincCheck
Biproj::getFirstYear
Biproj::getTitle
Biproj::read
Biproj::setCpiinc
Biproj::setData
Biproj::setFirstYear
Biproj::setTitle
Biproj::theData
Biproj::write
Biproj::~Biproj
BiprojFile
BiprojFile class
BiprojFile
BiprojFile members
BiprojFile methods
about BiprojFile class
read
setBiFile
setData
setData
setData method
setTitle
setTitle
setTitle method
write
BiprojFile.h
BiprojFile::BiprojFile
BiprojFile::read
BiprojFile::setBiFile
BiprojFile::setData
BiprojFile::setTitle
BiprojFile::write
BiprojNonFile
BiprojNonFile class
BiprojNonFile
BiprojNonFile enumerations
BiprojNonFile members
BiprojNonFile methods
about BiprojNonFile class
read
setData
setData
setData method
setTitle
setTitle
setTitle method
write
~BiprojNonFile
BiprojNonFile.h
BiprojNonFile::BiprojNonFile
BiprojNonFile::DimLimits
BiprojNonFile::DimLimits enumeration
BiprojNonFile::read
BiprojNonFile::setData
BiprojNonFile::setTitle
BiprojNonFile::write
BiprojNonFile::~BiprojNonFile
BitAnnual
BitAnnual class
BitAnnual
BitAnnual
BitAnnual constructor
BitAnnual data members
BitAnnual friends
BitAnnual members
BitAnnual methods
about BitAnnual class
any
assign
baseYear
class boost::serialization::access
deleteContents
getBaseYear
getBit
getLastYear
lastYear
setBit
theData
~BitAnnual
BitAnnual.cpp
BitAnnual.h
BitAnnual::BitAnnual
BitAnnual::any
BitAnnual::assign
BitAnnual::baseYear
BitAnnual::deleteContents
BitAnnual::getBaseYear
BitAnnual::getBit
BitAnnual::getLastYear
BitAnnual::lastYear
BitAnnual::setBit
BitAnnual::theData
BitAnnual::~BitAnnual
BitAnnualBase.cpp
BitAnnualBase.h
BitAnnualData
BitAnnualData type
BitAnnualInlines.h
BpMfbOut
BpMfbOut class
BpMfbOut
BpMfbOut
BpMfbOut constructor
BpMfbOut members
BpMfbOut methods
about BpMfbOut class
getBpmfb1
getBpmfb2
getBpmfb3
setData
setData
setData method
BpMfbOut::BpMfbOut
BpMfbOut::getBpmfb1
BpMfbOut::getBpmfb2
BpMfbOut::getBpmfb3
BpMfbOut::setData
BpPiaOut
BpPiaOut class
BpPiaOut
BpPiaOut
BpPiaOut constructor
BpPiaOut members
BpPiaOut methods
about BpPiaOut class
getBppia
getNumBend
set1979Data
setIndexedData
setSingleYearData
BpPiaOut::BpPiaOut
BpPiaOut::getBppia
BpPiaOut::getNumBend
BpPiaOut::set1979Data
BpPiaOut::setIndexedData
BpPiaOut::setSingleYearData
CHILDCARECREDIT enumeration member
CHILDCAREDROPOUT enumeration member
CHILDCARE_YEAR enumeration member
CHILD_CARE enumeration member
COLACHANGE enumeration member
CONSTANT_PROJ enumeration member
CURRENTNOTFULL enumeration member
Catchup
Catchup class
Catchup
Catchup
Catchup constructor
Catchup data members
Catchup members
Catchup methods
NUM_CATCHUP_ELIG_YEARS
about Catchup class
catchup
check
deleteContents
exist
get
getCatchupIncreases
getCstart
parseString
set
setCstart
~Catchup
Catchup::Catchup
Catchup::NUM_CATCHUP_ELIG_YEARS
Catchup::catchup
Catchup::check
Catchup::deleteContents
Catchup::exist
Catchup::get
Catchup::getCatchupIncreases
Catchup::getCstart
Catchup::parseString
Catchup::set
Catchup::setCstart
Catchup::~Catchup
CatchupDoc
CatchupDoc class
CatchupDoc
CatchupDoc
CatchupDoc constructor
CatchupDoc data members
CatchupDoc members
CatchupDoc methods
about CatchupDoc class
allownonzero
catchup
exist
get
read
setData
setData
setData method
write
~CatchupDoc
CatchupDoc::CatchupDoc
CatchupDoc::allownonzero
CatchupDoc::catchup
CatchupDoc::exist
CatchupDoc::get
CatchupDoc::read
CatchupDoc::setData
CatchupDoc::write
CatchupDoc::~CatchupDoc
CatchupFile
CatchupFile class
CatchupFile
CatchupFile data members
CatchupFile members
CatchupFile methods
about CatchupFile class
pathname
read
setCuFile
setData
setData
setData method
write
~CatchupFile
CatchupFile.h
CatchupFile::CatchupFile
CatchupFile::pathname
CatchupFile::read
CatchupFile::setCuFile
CatchupFile::setData
CatchupFile::write
CatchupFile::~CatchupFile
CatchupIncreases
CatchupIncreases class
CatchupIncreases
CatchupIncreases data members
CatchupIncreases members
CatchupIncreases methods
NUM_CATCHUP_INCREASES
about CatchupIncreases class
get
parseString
set
theData
toString
~CatchupIncreases
CatchupIncreases::CatchupIncreases
CatchupIncreases::NUM_CATCHUP_INCREASES
CatchupIncreases::get
CatchupIncreases::parseString
CatchupIncreases::set
CatchupIncreases::theData
CatchupIncreases::toString
CatchupIncreases::~CatchupIncreases
CatchupNonFile
CatchupNonFile class
CatchupNonFile
CatchupNonFile members
CatchupNonFile methods
about CatchupNonFile class
read
setData
setData
setData method
write
~CatchupNonFile
CatchupNonFile.h
CatchupNonFile::CatchupNonFile
CatchupNonFile::read
CatchupNonFile::setData
CatchupNonFile::write
CatchupNonFile::~CatchupNonFile
ChildCareCalc
ChildCareCalc class
ChildCareCalc
ChildCareCalc members
ChildCareCalc methods
about ChildCareCalc class
calculate
childCareDropMaxCal
childCareDropoutCal
getAdjustedN
getChildCareDrop
getChildCareDropMax
initialize
isApplicable
isApplicable
isApplicable method
~ChildCareCalc
ChildCareCalc.cpp
ChildCareCalc.h
ChildCareCalc1Page
ChildCareCalc1Page class
ChildCareCalc1Page
ChildCareCalc1Page members
ChildCareCalc1Page methods
about ChildCareCalc1Page class
prepareStrings
~ChildCareCalc1Page
ChildCareCalc1Page.cpp
ChildCareCalc1Page.h
ChildCareCalc1Page::ChildCareCalc1Page
ChildCareCalc1Page::prepareStrings
ChildCareCalc1Page::~ChildCareCalc1Page
ChildCareCalc2Page
ChildCareCalc2Page class
ChildCareCalc2Page
ChildCareCalc2Page data members
ChildCareCalc2Page members
ChildCareCalc2Page methods
about ChildCareCalc2Page class
piaCal
piaData
piaParams
prepareStrings
userAssumptions
workerData
~ChildCareCalc2Page
ChildCareCalc2Page.cpp
ChildCareCalc2Page.h
ChildCareCalc2Page::ChildCareCalc2Page
ChildCareCalc2Page::piaCal
ChildCareCalc2Page::piaData
ChildCareCalc2Page::piaParams
ChildCareCalc2Page::prepareStrings
ChildCareCalc2Page::userAssumptions
ChildCareCalc2Page::workerData
ChildCareCalc2Page::~ChildCareCalc2Page
ChildCareCalc::ChildCareCalc
ChildCareCalc::calculate
ChildCareCalc::childCareDropMaxCal
ChildCareCalc::childCareDropoutCal
ChildCareCalc::getAdjustedN
ChildCareCalc::getChildCareDrop
ChildCareCalc::getChildCareDropMax
ChildCareCalc::initialize
ChildCareCalc::isApplicable
ChildCareCalc::~ChildCareCalc
ChildCareCalcLC
ChildCareCalcLC class
ChildCareCalcLC
ChildCareCalcLC data members
ChildCareCalcLC members
ChildCareCalcLC methods
about ChildCareCalcLC class
childCareDropMaxCal
isApplicable
isApplicable
isApplicable method
lawChange
~ChildCareCalcLC
ChildCareCalcLC.cpp
ChildCareCalcLC.h
ChildCareCalcLC::ChildCareCalcLC
ChildCareCalcLC::childCareDropMaxCal
ChildCareCalcLC::isApplicable
ChildCareCalcLC::lawChange
ChildCareCalcLC::~ChildCareCalcLC
CommaBase.h
CompPeriod
CompPeriod class
CompPeriod
CompPeriod members
CompPeriod methods
about CompPeriod class
deleteContents
getBaseYear
getDiYears
getN
getNDrop
getNElapsed
setDiYears
setN
setNDrop
setNElapsed
CompPeriod.cpp
CompPeriod::CompPeriod
CompPeriod::deleteContents
CompPeriod::getBaseYear
CompPeriod::getDiYears
CompPeriod::getN
CompPeriod::getNDrop
CompPeriod::getNElapsed
CompPeriod::setDiYears
CompPeriod::setN
CompPeriod::setNDrop
CompPeriod::setNElapsed
Config
Config class
Config
Config members
Config methods
about Config class
getLeftMargin
getLongOutput
getPrinterPoints
getScreenPoints
getTopMargin
read
setLeftMargin
setLongOutput
setPrinterPoints
setScreenPoints
setTopMargin
write
~Config
Config::Config
Config::getLeftMargin
Config::getLongOutput
Config::getPrinterPoints
Config::getScreenPoints
Config::getTopMargin
Config::read
Config::setLeftMargin
Config::setLongOutput
Config::setPrinterPoints
Config::setScreenPoints
Config::setTopMargin
Config::write
Config::~Config
ConfigFile
ConfigFile class
ConfigFile
ConfigFile members
ConfigFile methods
about ConfigFile class
read
write
~ConfigFile
ConfigFile.h
ConfigFile::ConfigFile
ConfigFile::read
ConfigFile::write
ConfigFile::~ConfigFile
ConfigNonFile
ConfigNonFile class
ConfigNonFile
ConfigNonFile members
ConfigNonFile methods
about ConfigNonFile class
read
write
~ConfigNonFile
ConfigNonFile.h
ConfigNonFile::ConfigNonFile
ConfigNonFile::read
ConfigNonFile::write
ConfigNonFile::~ConfigNonFile
DEADOAB_BIT enumeration member
DEBUGPID
DEBUGPID variable
DECLINEPERC enumeration member
DEEMED enumeration member
DEEMED_BIT enumeration member
DIB_GUAR enumeration member
DIDROP5 enumeration member
DISABILITY enumeration member
DITF enumeration member
DROPOUTCHG enumeration member
Date
Date class
Date data members
Date members
Date methods
about Date class
addYears
highyear
lowyear
monthCheck
yearCheck
Date::addYears
Date::highyear
Date::lowyear
Date::monthCheck
Date::yearCheck
DateFormatter
DateFormatter class
DateFormatter members
DateFormatter methods
about DateFormatter class
date_from_undelimited_us_string
month_year_from_undelimited_us_string
toString
toString
toString
toString
toString method
DateFormatter.cpp
DateFormatter.h
DateFormatter::date_from_undelimited_us_string
DateFormatter::month_year_from_undelimited_us_string
DateFormatter::toString
DateMoyr
DateMoyr class
+
-
<
=
=
= operator
==
DateMoyr
DateMoyr
DateMoyr
DateMoyr
DateMoyr
DateMoyr constructor
DateMoyr friends
DateMoyr members
DateMoyr methods
DateMoyr operators
about DateMoyr class
check
class boost::serialization::access
deleteContents
getMonth
getMonthBefore
getMonths
getYear
index
isNotADate
monthCheck
~DateMoyr
DateMoyr::+
DateMoyr::-
DateMoyr::<
DateMoyr::=
DateMoyr::==
DateMoyr::DateMoyr
DateMoyr::check
DateMoyr::deleteContents
DateMoyr::getMonth
DateMoyr::getMonthBefore
DateMoyr::getMonths
DateMoyr::getYear
DateMoyr::index
DateMoyr::isNotADate
DateMoyr::monthCheck
DateMoyr::~DateMoyr
DebugCase.cpp
DebugCase.h
DibGuar
DibGuar class
DibGuar
DibGuar enumerations
DibGuar members
DibGuar methods
about DibGuar class
calculate
cessationMfbCal
convertedMfbTypeCal
dateCpiCal
entDeathDateCal
getCessationMfbConv
getCessationMfbOrig
getColasApply
getConvertedMfbType
getDiMaxApplies
getRawMfb
getRawPia
isApplicable
isApplicable
isApplicable method
yearCpi1Cal
~DibGuar
DibGuar.cpp
DibGuar.h
DibGuar::ConvertedMfbType
DibGuar::ConvertedMfbType enumeration
DibGuar::DibGuar
DibGuar::calculate
DibGuar::cessationMfbCal
DibGuar::convertedMfbTypeCal
DibGuar::dateCpiCal
DibGuar::entDeathDateCal
DibGuar::getCessationMfbConv
DibGuar::getCessationMfbOrig
DibGuar::getColasApply
DibGuar::getConvertedMfbType
DibGuar::getDiMaxApplies
DibGuar::getRawMfb
DibGuar::getRawPia
DibGuar::isApplicable
DibGuar::yearCpi1Cal
DibGuar::~DibGuar
DibGuarLC
DibGuarLC class
DibGuarLC
DibGuarLC members
DibGuarLC methods
about DibGuarLC class
isApplicable
isApplicable
isApplicable method
~DibGuarLC
DibGuarLC.cpp
DibGuarLC.h
DibGuarLC::DibGuarLC
DibGuarLC::isApplicable
DibGuarLC::~DibGuarLC
DibGuarPage
DibGuarPage class
DibGuarPage
DibGuarPage members
DibGuarPage methods
about DibGuarPage class
piamfbDeath
prepareStrings
~DibGuarPage
DibGuarPage.cpp
DibGuarPage.h
DibGuarPage::DibGuarPage
DibGuarPage::piamfbDeath
DibGuarPage::prepareStrings
DibGuarPage::~DibGuarPage
DisInsCode
DisInsCode class
==
ChartoCode
DisInsCode
DisInsCode
DisInsCode constructor
DisInsCode enumerations
DisInsCode members
DisInsCode methods
DisInsCode operators
about DisInsCode class
get
isDiBenie
isDisabilityInsured
set
toChar
toChar
toChar method
DisInsCode::==
DisInsCode::ChartoCode
DisInsCode::DisInsCode
DisInsCode::DisInsCodeType
DisInsCode::DisInsCodeType enumeration
DisInsCode::get
DisInsCode::isDiBenie
DisInsCode::isDisabilityInsured
DisInsCode::set
DisInsCode::toChar
DisInsCodeArray
DisInsCodeArray class
DisInsCodeArray
DisInsCodeArray members
DisInsCodeArray methods
DisInsCodeArray operators
[]
[]
[] operator
about DisInsCodeArray class
assign
assign
assign method
deleteContents
getFirstYear
getLastYear
isNonzero
setFirstYear
setLastYear
toString
DisInsCodeArray.cpp
DisInsCodeArray.h
DisInsCodeArray::DisInsCodeArray
DisInsCodeArray::[]
DisInsCodeArray::assign
DisInsCodeArray::deleteContents
DisInsCodeArray::getFirstYear
DisInsCodeArray::getLastYear
DisInsCodeArray::isNonzero
DisInsCodeArray::setFirstYear
DisInsCodeArray::setLastYear
DisInsCodeArray::toString
DisabPeriod
DisabPeriod class
DisabPeriod
DisabPeriod friends
DisabPeriod members
DisabPeriod methods
about DisabPeriod class
cessationDateCheck
class boost::serialization::access
deleteCessationDate
deleteContents
deleteEntDate
deleteOnsetDate
deleteWaitperDate
entDateCheck
getCessationDate
getCessationMfb
getCessationPia
getEntDate
getOnsetDate
getWaitperDate
onsetDateCheck
parseString
setCessationDate
setCessationMfb
setCessationPia
setEntDate
setOnsetDate
setWaitperDate
toString
toString
toString method
waitperDateCal
waitperDateCheck
DisabPeriod.cpp
DisabPeriod.h
DisabPeriod::DisabPeriod
DisabPeriod::cessationDateCheck
DisabPeriod::deleteCessationDate
DisabPeriod::deleteContents
DisabPeriod::deleteEntDate
DisabPeriod::deleteOnsetDate
DisabPeriod::deleteWaitperDate
DisabPeriod::entDateCheck
DisabPeriod::getCessationDate
DisabPeriod::getCessationMfb
DisabPeriod::getCessationPia
DisabPeriod::getEntDate
DisabPeriod::getOnsetDate
DisabPeriod::getWaitperDate
DisabPeriod::onsetDateCheck
DisabPeriod::parseString
DisabPeriod::setCessationDate
DisabPeriod::setCessationMfb
DisabPeriod::setCessationPia
DisabPeriod::setEntDate
DisabPeriod::setOnsetDate
DisabPeriod::setWaitperDate
DisabPeriod::toString
DisabPeriod::waitperDateCal
DisabPeriod::waitperDateCheck
Document
Document class
Document
Document
Document constructor
Document members
Document methods
about Document class
errormesg
getCorename
getModifier
getPathname
getTitle
readmesg
setCorename
setExtension
setModifier
setPath
setPathAndModifier
setPathname
setTitle
writemesg
~Document
Document::Document
Document::errormesg
Document::getCorename
Document::getModifier
Document::getPathname
Document::getTitle
Document::readmesg
Document::setCorename
Document::setExtension
Document::setModifier
Document::setPath
Document::setPathAndModifier
Document::setPathname
Document::setTitle
Document::writemesg
Document::~Document
DoubleAnnual
DoubleAnnual class
DoubleAnnual
DoubleAnnual data members
DoubleAnnual friends
DoubleAnnual members
DoubleAnnual methods
DoubleAnnual operators
[]
[]
[] operator
about DoubleAnnual class
accumulate
assign
assign
assign method
baseYear
class boost::serialization::access
fill
getBaseYear
getLastYear
theData
~DoubleAnnual
DoubleAnnual::DoubleAnnual
DoubleAnnual::[]
DoubleAnnual::accumulate
DoubleAnnual::assign
DoubleAnnual::baseYear
DoubleAnnual::fill
DoubleAnnual::getBaseYear
DoubleAnnual::getLastYear
DoubleAnnual::theData
DoubleAnnual::~DoubleAnnual
DoubleAnnualRW.cpp
DoubleAnnualRW.h
DoubleAnnualRead
DoubleAnnualRead class
DoubleAnnualRead
DoubleAnnualRead members
DoubleAnnualRead methods
about DoubleAnnualRead class
read
DoubleAnnualRead::DoubleAnnualRead
DoubleAnnualRead::read
DoubleAnnualWrite
DoubleAnnualWrite class
DoubleAnnualWrite
DoubleAnnualWrite members
DoubleAnnualWrite methods
about DoubleAnnualWrite class
getLineWidth
getPrecision
getWidth
write
DoubleAnnualWrite::DoubleAnnualWrite
DoubleAnnualWrite::getLineWidth
DoubleAnnualWrite::getPrecision
DoubleAnnualWrite::getWidth
DoubleAnnualWrite::write
DoubleMonth
DoubleMonth class
DoubleMonth
DoubleMonth data members
DoubleMonth members
DoubleMonth methods
about DoubleMonth class
annAvgCal
assign
assign
assign method
getAt
getBaseYear
getLastYear
getLineWidth
getPrecision
getWidth
nmonCal
qtrAvgCal
read
setAt
setLineWidth
setPrecision
setWidth
theData
write
~DoubleMonth
DoubleMonth::DoubleMonth
DoubleMonth::annAvgCal
DoubleMonth::assign
DoubleMonth::getAt
DoubleMonth::getBaseYear
DoubleMonth::getLastYear
DoubleMonth::getLineWidth
DoubleMonth::getPrecision
DoubleMonth::getWidth
DoubleMonth::nmonCal
DoubleMonth::qtrAvgCal
DoubleMonth::read
DoubleMonth::setAt
DoubleMonth::setLineWidth
DoubleMonth::setPrecision
DoubleMonth::setWidth
DoubleMonth::theData
DoubleMonth::write
DoubleMonth::~DoubleMonth
DoubleQuarter
DoubleQuarter class
DoubleQuarter
DoubleQuarter data members
DoubleQuarter members
DoubleQuarter methods
about DoubleQuarter class
anninc
anninc3
assign
assign
assign
assign method
average
getAfter
getAt
getBaseYear
getBefore
getLastYear
getLineWidth
getWidth
multiply
read
setAt
setLineWidth
setPrecision
setWidth
theData
write
~DoubleQuarter
DoubleQuarter::DoubleQuarter
DoubleQuarter::anninc
DoubleQuarter::anninc3
DoubleQuarter::assign
DoubleQuarter::average
DoubleQuarter::getAfter
DoubleQuarter::getAt
DoubleQuarter::getBaseYear
DoubleQuarter::getBefore
DoubleQuarter::getLastYear
DoubleQuarter::getLineWidth
DoubleQuarter::getWidth
DoubleQuarter::multiply
DoubleQuarter::read
DoubleQuarter::setAt
DoubleQuarter::setLineWidth
DoubleQuarter::setPrecision
DoubleQuarter::setWidth
DoubleQuarter::theData
DoubleQuarter::write
DoubleQuarter::~DoubleQuarter
EARNINDCPI enumeration member
EARN_NO_TOTALIZATION enumeration member
EARN_WITH_TOTALIZATION enumeration member
EMPLOYEERATE enumeration member
ENDS
ENDS macro
ENTERED enumeration member
EarnProject
EarnProject class
EarnProject
EarnProject data members
EarnProject enumerations
EarnProject members
EarnProject methods
PERC_HIGH
PERC_LOW
about EarnProject class
anyEntered
deleteContents
earnpebs
earnpebsCheck
earntypeCheck
getEarntype
getFirstYear
getLastYear
getPercback
getPercfwrd
getProjback
getProjfwrd
ibegin2Check
ibeginCheck
iendCheck
need_aw
percbackCheck
percfwrdCheck
projbackCheck1
projbackCheck2
project
projfwrdCheck1
projfwrdCheck2
setEarnpebs
setEarntype
setFirstYear
setLastYear
setPebsData
setPebsEarn
setPercback
setPercfwrd
setProjback
setProjfwrd
toString
yearsCheck
yearsCheck
yearsCheck method
zeroEarn
~EarnProject
EarnProject.cpp
EarnProject.h
EarnProject::EarnProject
EarnProject::PERC_HIGH
EarnProject::PERC_LOW
EarnProject::anyEntered
EarnProject::deleteContents
EarnProject::earn_proj_type
EarnProject::earn_proj_type enumeration
EarnProject::earn_type
EarnProject::earn_type enumeration
EarnProject::earnpebs
EarnProject::earnpebsCheck
EarnProject::earntypeCheck
EarnProject::getEarntype
EarnProject::getFirstYear
EarnProject::getLastYear
EarnProject::getPercback
EarnProject::getPercfwrd
EarnProject::getProjback
EarnProject::getProjfwrd
EarnProject::ibegin2Check
EarnProject::ibeginCheck
EarnProject::iendCheck
EarnProject::need_aw
EarnProject::percbackCheck
EarnProject::percfwrdCheck
EarnProject::projbackCheck1
EarnProject::projbackCheck2
EarnProject::project
EarnProject::projfwrdCheck1
EarnProject::projfwrdCheck2
EarnProject::setEarnpebs
EarnProject::setEarntype
EarnProject::setFirstYear
EarnProject::setLastYear
EarnProject::setPebsData
EarnProject::setPebsEarn
EarnProject::setPercback
EarnProject::setPercfwrd
EarnProject::setProjback
EarnProject::setProjfwrd
EarnProject::toString
EarnProject::yearsCheck
EarnProject::zeroEarn
EarnProject::~EarnProject
EarningsPage
EarningsPage class
EarningsPage
EarningsPage members
EarningsPage methods
about EarningsPage class
prepareStrings
~EarningsPage
EarningsPage.cpp
EarningsPage.h
EarningsPage::EarningsPage
EarningsPage::prepareStrings
EarningsPage::~EarningsPage
FEDERAL enumeration member
FEMALE enumeration member
FIRST_AGE enumeration member
FIRST_YEAR enumeration member
FLAT enumeration member
FREEZE
FREEZE macro
FROZ_MIN enumeration member
FULLAND2040 enumeration member
FULLANDBLIND enumeration member
FULLANDCURRENT enumeration member
FULLANDDIB enumeration member
FULLANDSPECIAL enumeration member
FULLNOT2040 enumeration member
FULLNOTCURRENT enumeration member
FamilyPage
FamilyPage class
FamilyPage
FamilyPage members
FamilyPage methods
about FamilyPage class
prepareStrings
~FamilyPage
FamilyPage.cpp
FamilyPage.h
FamilyPage::FamilyPage
FamilyPage::prepareStrings
FamilyPage::~FamilyPage
FieldOfficeInfo
FieldOfficeInfo class
FieldOfficeInfo
FieldOfficeInfo data members
FieldOfficeInfo members
FieldOfficeInfo methods
about FieldOfficeInfo class
getAddress
getFieldOfficeName
getFieldOfficeTitle
numLines
read
setAddress
setData
setFieldOfficeName
setFieldOfficeTitle
write
~FieldOfficeInfo
FieldOfficeInfo::FieldOfficeInfo
FieldOfficeInfo::getAddress
FieldOfficeInfo::getFieldOfficeName
FieldOfficeInfo::getFieldOfficeTitle
FieldOfficeInfo::numLines
FieldOfficeInfo::read
FieldOfficeInfo::setAddress
FieldOfficeInfo::setData
FieldOfficeInfo::setFieldOfficeName
FieldOfficeInfo::setFieldOfficeTitle
FieldOfficeInfo::write
FieldOfficeInfo::~FieldOfficeInfo
FieldOfficeInfoFile
FieldOfficeInfoFile class
FieldOfficeInfoFile
FieldOfficeInfoFile members
FieldOfficeInfoFile methods
about FieldOfficeInfoFile class
read
setData
write
~FieldOfficeInfoFile
FieldOfficeInfoFile.h
FieldOfficeInfoFile::FieldOfficeInfoFile
FieldOfficeInfoFile::read
FieldOfficeInfoFile::setData
FieldOfficeInfoFile::write
FieldOfficeInfoFile::~FieldOfficeInfoFile
FieldOfficeInfoNonFile
FieldOfficeInfoNonFile class
FieldOfficeInfoNonFile
FieldOfficeInfoNonFile members
FieldOfficeInfoNonFile methods
about FieldOfficeInfoNonFile class
read
setData
write
~FieldOfficeInfoNonFile
FieldOfficeInfoNonFile.h
FieldOfficeInfoNonFile::FieldOfficeInfoNonFile
FieldOfficeInfoNonFile::read
FieldOfficeInfoNonFile::setData
FieldOfficeInfoNonFile::write
FieldOfficeInfoNonFile::~FieldOfficeInfoNonFile
FloatAnnual
FloatAnnual class
FloatAnnual
FloatAnnual data members
FloatAnnual friends
FloatAnnual members
FloatAnnual methods
FloatAnnual operators
[]
[]
[] operator
about FloatAnnual class
accumulate
assign
assign
assign method
baseYear
class boost::serialization::access
fill
getBaseYear
getLastYear
theData
~FloatAnnual
FloatAnnual::FloatAnnual
FloatAnnual::[]
FloatAnnual::accumulate
FloatAnnual::assign
FloatAnnual::baseYear
FloatAnnual::fill
FloatAnnual::getBaseYear
FloatAnnual::getLastYear
FloatAnnual::theData
FloatAnnual::~FloatAnnual
FloatMonth
FloatMonth class
FloatMonth
FloatMonth data members
FloatMonth members
FloatMonth methods
about FloatMonth class
annAvgCal
assign
assign
assign method
getAt
getBaseYear
getLastYear
getLineWidth
getPrecision
getWidth
nmonCal
qtrAvgCal
read
setAt
setLineWidth
setPrecision
setWidth
theData
write
~FloatMonth
FloatMonth::FloatMonth
FloatMonth::annAvgCal
FloatMonth::assign
FloatMonth::getAt
FloatMonth::getBaseYear
FloatMonth::getLastYear
FloatMonth::getLineWidth
FloatMonth::getPrecision
FloatMonth::getWidth
FloatMonth::nmonCal
FloatMonth::qtrAvgCal
FloatMonth::read
FloatMonth::setAt
FloatMonth::setLineWidth
FloatMonth::setPrecision
FloatMonth::setWidth
FloatMonth::theData
FloatMonth::write
FloatMonth::~FloatMonth
FloatQuarter
FloatQuarter class
FloatQuarter
FloatQuarter data members
FloatQuarter members
FloatQuarter methods
about FloatQuarter class
anninc
anninc3
assign
assign
assign
assign method
average
getAfter
getAt
getBaseYear
getBefore
getLastYear
getLineWidth
getWidth
multiply
read
setAt
setLineWidth
setPrecision
setWidth
theData
write
FloatQuarter::FloatQuarter
FloatQuarter::anninc
FloatQuarter::anninc3
FloatQuarter::assign
FloatQuarter::average
FloatQuarter::getAfter
FloatQuarter::getAt
FloatQuarter::getBaseYear
FloatQuarter::getBefore
FloatQuarter::getLastYear
FloatQuarter::getLineWidth
FloatQuarter::getWidth
FloatQuarter::multiply
FloatQuarter::read
FloatQuarter::setAt
FloatQuarter::setLineWidth
FloatQuarter::setPrecision
FloatQuarter::setWidth
FloatQuarter::theData
FloatQuarter::write
FormatString.cpp
FormatString.h
FreezeYears
FreezeYears class
FreezeYears
FreezeYears members
FreezeYears methods
about FreezeYears class
deleteContents
getYear1
getYear2
getYear3
getYear4
hasYears1
hasYears2
isFreezeYear
setYear1
setYear2
setYear3
setYear4
FreezeYears::FreezeYears
FreezeYears::deleteContents
FreezeYears::getYear1
FreezeYears::getYear2
FreezeYears::getYear3
FreezeYears::getYear4
FreezeYears::hasYears1
FreezeYears::hasYears2
FreezeYears::isFreezeYear
FreezeYears::setYear1
FreezeYears::setYear2
FreezeYears::setYear3
FreezeYears::setYear4
FrozMin
FrozMin class
FrozMin
FrozMin members
FrozMin methods
about FrozMin class
calculate
isApplicable
isApplicable
isApplicable method
setFrozMin
~FrozMin
FrozMin.cpp
FrozMin.h
FrozMin::FrozMin
FrozMin::calculate
FrozMin::isApplicable
FrozMin::setFrozMin
FrozMin::~FrozMin
FrozMinPage
FrozMinPage class
FrozMinPage
FrozMinPage members
FrozMinPage methods
about FrozMinPage class
prepareStrings
~FrozMinPage
FrozMinPage.cpp
FrozMinPage.h
FrozMinPage::FrozMinPage
FrozMinPage::prepareStrings
FrozMinPage::~FrozMinPage
Genfile
Genfile class
Genfile
Genfile
Genfile constructor
Genfile data members
Genfile members
Genfile methods
about Genfile class
getmesg
openapp
openin
openout
pathname
setmesg
~Genfile
Genfile::Genfile
Genfile::getmesg
Genfile::openapp
Genfile::openin
Genfile::openout
Genfile::pathname
Genfile::setmesg
Genfile::~Genfile
HAS30YEARS enumeration member
HIGH enumeration member
HIGH_PIA enumeration member
HITF enumeration member
INDEARN_BIT enumeration member
INDRR_BIT enumeration member
InsCode
InsCode class
==
ChartoCode
InsCode
InsCode
InsCode constructor
InsCode enumerations
InsCode members
InsCode methods
InsCode operators
about InsCode class
get
isCurrentlyInsured
isFullyInsured
isFullyOrCurrentlyInsured
isFullyOrTotalInsured
isPermanentlyInsured
set
toChar
toChar
toChar method
InsCode::==
InsCode::ChartoCode
InsCode::InsCode
InsCode::InsCodeType
InsCode::InsCodeType enumeration
InsCode::get
InsCode::isCurrentlyInsured
InsCode::isFullyInsured
InsCode::isFullyOrCurrentlyInsured
InsCode::isFullyOrTotalInsured
InsCode::isPermanentlyInsured
InsCode::set
InsCode::toChar
InsCodeArray
InsCodeArray class
InsCodeArray
InsCodeArray members
InsCodeArray methods
InsCodeArray operators
[]
[]
[] operator
about InsCodeArray class
assign
assign
assign method
deleteContents
getFirstYear
getLastYear
isNonzero
setFirstYear
setLastYear
toString
InsCodeArray.cpp
InsCodeArray.h
InsCodeArray::InsCodeArray
InsCodeArray::[]
InsCodeArray::assign
InsCodeArray::deleteContents
InsCodeArray::getFirstYear
InsCodeArray::getLastYear
InsCodeArray::isNonzero
InsCodeArray::setFirstYear
InsCodeArray::setLastYear
InsCodeArray::toString
InsuredPage
InsuredPage class
InsuredPage
InsuredPage members
InsuredPage methods
about InsuredPage class
prepareStrings
~InsuredPage
InsuredPage.cpp
InsuredPage.h
InsuredPage::InsuredPage
InsuredPage::prepareStrings
InsuredPage::~InsuredPage
IntAnnual
IntAnnual class
IntAnnual
IntAnnual data members
IntAnnual members
IntAnnual methods
IntAnnual operators
[]
[]
[] operator
about IntAnnual class
assign
assign
assign method
baseYear
fill
getBaseYear
getLastYear
theData
~IntAnnual
IntAnnual::IntAnnual
IntAnnual::[]
IntAnnual::assign
IntAnnual::baseYear
IntAnnual::fill
IntAnnual::getBaseYear
IntAnnual::getLastYear
IntAnnual::theData
IntAnnual::~IntAnnual
LASTYEARLR
LASTYEARLR variable
LASTYRSR
LASTYRSR variable
LOW enumeration member
LawChange
LawChange class
LawChange
LawChange
LawChange constructor
LawChange enumerations
LawChange members
LawChange methods
about LawChange class
bendPointCheck
bpincCheck
constantPercCheck
getEndYear
getEndYearLC
getFirstLine
getInd
getPhaseType
getStartYear
getStartYearLC
getTitle
isEffective
percCheck
prepareStrings
proportionBendPointsCheck
read
setEndYear
setEndYearLC
setInd
setPhaseType
setStartYear
setStartYearLC
startCheck
write
writeFirstLine
~LawChange
LawChange.cpp
LawChange.h
LawChange::LawChange
LawChange::bendPointCheck
LawChange::bpincCheck
LawChange::constantPercCheck
LawChange::getEndYear
LawChange::getEndYearLC
LawChange::getFirstLine
LawChange::getInd
LawChange::getPhaseType
LawChange::getStartYear
LawChange::getStartYearLC
LawChange::getTitle
LawChange::isEffective
LawChange::lawChangeType
LawChange::lawChangeType enumeration
LawChange::percCheck
LawChange::prepareStrings
LawChange::proportionBendPointsCheck
LawChange::read
LawChange::setEndYear
LawChange::setEndYearLC
LawChange::setInd
LawChange::setPhaseType
LawChange::setStartYear
LawChange::setStartYearLC
LawChange::startCheck
LawChange::write
LawChange::writeFirstLine
LawChange::~LawChange
LawChangeAGE65COMP
LawChangeAGE65COMP class
LawChangeAGE65COMP
LawChangeAGE65COMP members
LawChangeAGE65COMP methods
about LawChangeAGE65COMP class
getStep
prepareStrings
read
setStep
write
LawChangeAGE65COMP.cpp
LawChangeAGE65COMP.h
LawChangeAGE65COMP::LawChangeAGE65COMP
LawChangeAGE65COMP::getStep
LawChangeAGE65COMP::prepareStrings
LawChangeAGE65COMP::read
LawChangeAGE65COMP::setStep
LawChangeAGE65COMP::write
LawChangeALLEARN
LawChangeALLEARN class
LawChangeALLEARN
LawChangeALLEARN members
LawChangeALLEARN methods
about LawChangeALLEARN class
getStep
getYear
prepareStrings
read
setStep
setYear
write
LawChangeALLEARN.cpp
LawChangeALLEARN.h
LawChangeALLEARN::LawChangeALLEARN
LawChangeALLEARN::getStep
LawChangeALLEARN::getYear
LawChangeALLEARN::prepareStrings
LawChangeALLEARN::read
LawChangeALLEARN::setStep
LawChangeALLEARN::setYear
LawChangeALLEARN::write
LawChangeArray
LawChangeArray class
LawChangeArray
LawChangeArray data members
LawChangeArray members
LawChangeArray methods
about LawChangeArray class
getIndTotal
indTotalCal
lawChange
lawChangeAGE65COMP
lawChangeALLEARN
lawChangeBPFRACWAGE
lawChangeBPMINCONST
lawChangeBPSPECRATE
lawChangeCHILDCARECREDIT
lawChangeCHILDCAREDROPOUT
lawChangeCOLACHANGE
lawChangeDECLINEPERC
lawChangeDROPOUTCHG
lawChangeMARRLENGTH
lawChangeNEWFORMULA
lawChangeNEWSPECMIN
lawChangeNRACHANGE
lawChangePSAACCT
lawChangeTAXBENCHG
lawChangeTAXRATECHG
lawChangeWAGEBASECHG
lawChangeWIDFACTOR
lawChangeWIFEFACTOR
~LawChangeArray
LawChangeArray.cpp
LawChangeArray.h
LawChangeArray::LawChangeArray
LawChangeArray::getIndTotal
LawChangeArray::indTotalCal
LawChangeArray::lawChange
LawChangeArray::lawChangeAGE65COMP
LawChangeArray::lawChangeALLEARN
LawChangeArray::lawChangeBPFRACWAGE
LawChangeArray::lawChangeBPMINCONST
LawChangeArray::lawChangeBPSPECRATE
LawChangeArray::lawChangeCHILDCARECREDIT
LawChangeArray::lawChangeCHILDCAREDROPOUT
LawChangeArray::lawChangeCOLACHANGE
LawChangeArray::lawChangeDECLINEPERC
LawChangeArray::lawChangeDROPOUTCHG
LawChangeArray::lawChangeMARRLENGTH
LawChangeArray::lawChangeNEWFORMULA
LawChangeArray::lawChangeNEWSPECMIN
LawChangeArray::lawChangeNRACHANGE
LawChangeArray::lawChangePSAACCT
LawChangeArray::lawChangeTAXBENCHG
LawChangeArray::lawChangeTAXRATECHG
LawChangeArray::lawChangeWAGEBASECHG
LawChangeArray::lawChangeWIDFACTOR
LawChangeArray::lawChangeWIFEFACTOR
LawChangeArray::~LawChangeArray
LawChangeBPFRACWAGE
LawChangeBPFRACWAGE class
LawChangeBPFRACWAGE
LawChangeBPFRACWAGE members
LawChangeBPFRACWAGE methods
about LawChangeBPFRACWAGE class
getProportionBendPoints
prepareStrings
read
setProportionBendPoints
write
LawChangeBPFRACWAGE.cpp
LawChangeBPFRACWAGE.h
LawChangeBPFRACWAGE::LawChangeBPFRACWAGE
LawChangeBPFRACWAGE::getProportionBendPoints
LawChangeBPFRACWAGE::prepareStrings
LawChangeBPFRACWAGE::read
LawChangeBPFRACWAGE::setProportionBendPoints
LawChangeBPFRACWAGE::write
LawChangeBPMINCONST
LawChangeBPMINCONST class
LawChangeBPMINCONST
LawChangeBPMINCONST members
LawChangeBPMINCONST methods
about LawChangeBPMINCONST class
getConstantPerc
prepareStrings
read
setConstantPerc
write
LawChangeBPMINCONST.cpp
LawChangeBPMINCONST.h
LawChangeBPMINCONST::LawChangeBPMINCONST
LawChangeBPMINCONST::getConstantPerc
LawChangeBPMINCONST::prepareStrings
LawChangeBPMINCONST::read
LawChangeBPMINCONST::setConstantPerc
LawChangeBPMINCONST::write
LawChangeBPSPECRATE
LawChangeBPSPECRATE class
LawChangeBPSPECRATE
LawChangeBPSPECRATE members
LawChangeBPSPECRATE methods
about LawChangeBPSPECRATE class
getBendPiaInc
prepareStrings
read
setBendPiaInc
write
LawChangeBPSPECRATE.cpp
LawChangeBPSPECRATE.h
LawChangeBPSPECRATE::LawChangeBPSPECRATE
LawChangeBPSPECRATE::getBendPiaInc
LawChangeBPSPECRATE::prepareStrings
LawChangeBPSPECRATE::read
LawChangeBPSPECRATE::setBendPiaInc
LawChangeBPSPECRATE::write
LawChangeCHILDCARECREDIT
LawChangeCHILDCARECREDIT class
LawChangeCHILDCARECREDIT
LawChangeCHILDCARECREDIT members
LawChangeCHILDCARECREDIT methods
about LawChangeCHILDCARECREDIT class
getAvgEarnPct
getChildCareYearsBeforeEffYear
getFqRatio
getMaxAge
getMaxYears
getNumDropExtremeEarnYears
getNumTopEarnYears
prepareStrings
read
setAvgEarnPct
setChildCareYearsBeforeEffYear
setFqRatio
setMaxAge
setMaxYears
setNumDropExtremeEarnYears
setNumTopEarnYears
write
LawChangeCHILDCARECREDIT.cpp
LawChangeCHILDCARECREDIT.h
LawChangeCHILDCARECREDIT::LawChangeCHILDCARECREDIT
LawChangeCHILDCARECREDIT::getAvgEarnPct
LawChangeCHILDCARECREDIT::getChildCareYearsBeforeEffYear
LawChangeCHILDCARECREDIT::getFqRatio
LawChangeCHILDCARECREDIT::getMaxAge
LawChangeCHILDCARECREDIT::getMaxYears
LawChangeCHILDCARECREDIT::getNumDropExtremeEarnYears
LawChangeCHILDCARECREDIT::getNumTopEarnYears
LawChangeCHILDCARECREDIT::prepareStrings
LawChangeCHILDCARECREDIT::read
LawChangeCHILDCARECREDIT::setAvgEarnPct
LawChangeCHILDCARECREDIT::setChildCareYearsBeforeEffYear
LawChangeCHILDCARECREDIT::setFqRatio
LawChangeCHILDCARECREDIT::setMaxAge
LawChangeCHILDCARECREDIT::setMaxYears
LawChangeCHILDCARECREDIT::setNumDropExtremeEarnYears
LawChangeCHILDCARECREDIT::setNumTopEarnYears
LawChangeCHILDCARECREDIT::write
LawChangeCHILDCAREDROPOUT
LawChangeCHILDCAREDROPOUT class
LawChangeCHILDCAREDROPOUT
LawChangeCHILDCAREDROPOUT members
LawChangeCHILDCAREDROPOUT methods
about LawChangeCHILDCAREDROPOUT class
getFqRatio
getMaxAge
getMaxYears
prepareStrings
read
setFqRatio
setMaxAge
setMaxYears
write
LawChangeCHILDCAREDROPOUT.cpp
LawChangeCHILDCAREDROPOUT.h
LawChangeCHILDCAREDROPOUT::LawChangeCHILDCAREDROPOUT
LawChangeCHILDCAREDROPOUT::getFqRatio
LawChangeCHILDCAREDROPOUT::getMaxAge
LawChangeCHILDCAREDROPOUT::getMaxYears
LawChangeCHILDCAREDROPOUT::prepareStrings
LawChangeCHILDCAREDROPOUT::read
LawChangeCHILDCAREDROPOUT::setFqRatio
LawChangeCHILDCAREDROPOUT::setMaxAge
LawChangeCHILDCAREDROPOUT::setMaxYears
LawChangeCHILDCAREDROPOUT::write
LawChangeCOLACHANGE
LawChangeCOLACHANGE class
LawChangeCOLACHANGE
LawChangeCOLACHANGE members
LawChangeCOLACHANGE methods
about LawChangeCOLACHANGE class
getColaAdj
getPiaPercentile
prepareStrings
read
setColaAdj
setPiaPercentile
write
LawChangeCOLACHANGE.cpp
LawChangeCOLACHANGE.h
LawChangeCOLACHANGE::LawChangeCOLACHANGE
LawChangeCOLACHANGE::getColaAdj
LawChangeCOLACHANGE::getPiaPercentile
LawChangeCOLACHANGE::prepareStrings
LawChangeCOLACHANGE::read
LawChangeCOLACHANGE::setColaAdj
LawChangeCOLACHANGE::setPiaPercentile
LawChangeCOLACHANGE::write
LawChangeDECLINEPERC
LawChangeDECLINEPERC class
LawChangeDECLINEPERC
LawChangeDECLINEPERC enumerations
LawChangeDECLINEPERC members
LawChangeDECLINEPERC methods
about LawChangeDECLINEPERC class
getAltPercPia
getFactor
getYear
percPiaCal
prepareStrings
read
setFactor
setYear
write
~LawChangeDECLINEPERC
LawChangeDECLINEPERC.cpp
LawChangeDECLINEPERC.h
LawChangeDECLINEPERC::DimLimits
LawChangeDECLINEPERC::DimLimits enumeration
LawChangeDECLINEPERC::LawChangeDECLINEPERC
LawChangeDECLINEPERC::getAltPercPia
LawChangeDECLINEPERC::getFactor
LawChangeDECLINEPERC::getYear
LawChangeDECLINEPERC::percPiaCal
LawChangeDECLINEPERC::prepareStrings
LawChangeDECLINEPERC::read
LawChangeDECLINEPERC::setFactor
LawChangeDECLINEPERC::setYear
LawChangeDECLINEPERC::write
LawChangeDECLINEPERC::~LawChangeDECLINEPERC
LawChangeDROPOUTCHG
LawChangeDROPOUTCHG class
LawChangeDROPOUTCHG
LawChangeDROPOUTCHG members
LawChangeDROPOUTCHG methods
about LawChangeDROPOUTCHG class
getStep
prepareStrings
read
setStep
write
LawChangeDROPOUTCHG.cpp
LawChangeDROPOUTCHG.h
LawChangeDROPOUTCHG::LawChangeDROPOUTCHG
LawChangeDROPOUTCHG::getStep
LawChangeDROPOUTCHG::prepareStrings
LawChangeDROPOUTCHG::read
LawChangeDROPOUTCHG::setStep
LawChangeDROPOUTCHG::write
LawChangeMARRLENGTH
LawChangeMARRLENGTH class
LawChangeMARRLENGTH
LawChangeMARRLENGTH members
LawChangeMARRLENGTH methods
about LawChangeMARRLENGTH class
getMarrLengthForDivBen
prepareStrings
read
setMarrLengthForDivBen
write
LawChangeMARRLENGTH.cpp
LawChangeMARRLENGTH.h
LawChangeMARRLENGTH::LawChangeMARRLENGTH
LawChangeMARRLENGTH::getMarrLengthForDivBen
LawChangeMARRLENGTH::prepareStrings
LawChangeMARRLENGTH::read
LawChangeMARRLENGTH::setMarrLengthForDivBen
LawChangeMARRLENGTH::write
LawChangeNEWFORMULA
LawChangeNEWFORMULA class
LawChangeNEWFORMULA
LawChangeNEWFORMULA members
LawChangeNEWFORMULA methods
about LawChangeNEWFORMULA class
getAltBendPia
getAltPercPia
getNumBp
prepareStrings
read
setAltBendPia
setAltPercPia
setNumBp
write
~LawChangeNEWFORMULA
LawChangeNEWFORMULA.cpp
LawChangeNEWFORMULA.h
LawChangeNEWFORMULA::LawChangeNEWFORMULA
LawChangeNEWFORMULA::getAltBendPia
LawChangeNEWFORMULA::getAltPercPia
LawChangeNEWFORMULA::getNumBp
LawChangeNEWFORMULA::prepareStrings
LawChangeNEWFORMULA::read
LawChangeNEWFORMULA::setAltBendPia
LawChangeNEWFORMULA::setAltPercPia
LawChangeNEWFORMULA::setNumBp
LawChangeNEWFORMULA::write
LawChangeNEWFORMULA::~LawChangeNEWFORMULA
LawChangeNEWSPECMIN
LawChangeNEWSPECMIN class
LawChangeNEWSPECMIN
LawChangeNEWSPECMIN members
LawChangeNEWSPECMIN methods
about LawChangeNEWSPECMIN class
getAmount
getPercent
getYears
prepareStrings
read
setAmount
setPercent
setYears
write
LawChangeNEWSPECMIN.cpp
LawChangeNEWSPECMIN.h
LawChangeNEWSPECMIN::LawChangeNEWSPECMIN
LawChangeNEWSPECMIN::getAmount
LawChangeNEWSPECMIN::getPercent
LawChangeNEWSPECMIN::getYears
LawChangeNEWSPECMIN::prepareStrings
LawChangeNEWSPECMIN::read
LawChangeNEWSPECMIN::setAmount
LawChangeNEWSPECMIN::setPercent
LawChangeNEWSPECMIN::setYears
LawChangeNEWSPECMIN::write
LawChangeNRACHANGE
LawChangeNRACHANGE class
LawChangeNRACHANGE
LawChangeNRACHANGE data members
LawChangeNRACHANGE members
LawChangeNRACHANGE methods
about LawChangeNRACHANGE class
ageArChange
arMonthlyFactor67_69
arMonthlyFactor69Plus
prepareStrings
LawChangeNRACHANGE.cpp
LawChangeNRACHANGE.h
LawChangeNRACHANGE::LawChangeNRACHANGE
LawChangeNRACHANGE::ageArChange
LawChangeNRACHANGE::arMonthlyFactor67_69
LawChangeNRACHANGE::arMonthlyFactor69Plus
LawChangeNRACHANGE::prepareStrings
LawChangeOut
LawChangeOut class
LawChangeOut
LawChangeOut data members
LawChangeOut members
LawChangeOut methods
about LawChangeOut class
lawChange
prepareStrings
~LawChangeOut
LawChangeOut.cpp
LawChangeOut.h
LawChangeOut::LawChangeOut
LawChangeOut::lawChange
LawChangeOut::prepareStrings
LawChangeOut::~LawChangeOut
LawChangePSAACCT
LawChangePSAACCT class
LawChangePSAACCT
LawChangePSAACCT enumerations
LawChangePSAACCT members
LawChangePSAACCT methods
about LawChangePSAACCT class
getAdminFee
getAnnIntRate
getAnnuityOffset
getAnnuityToDib
getAnnuityType
getBuysAnnuity
getContribBps
getContribDist
getContribRates
getContribStartAge
getContribYears
getInvestMean
getInvestPerc
getInvestStdDev
getLumpSumAtFra
getLumpSumPerc
getMngmtFee
getNumContribBps
getPercToSpouse
getRebalanceAccounts
getTaxAnnuityInd
getToSpouseOnDeathInd
getUnisexInd
prepareStrings
read
setAdminFee
setAnnIntRate
setAnnuityOffset
setAnnuityToDib
setAnnuityType
setBuysAnnuity
setContribBps
setContribDist
setContribRates
setContribStartAge
setContribYears
setInvestMean
setInvestPerc
setInvestStdDev
setLumpSumAtFra
setLumpSumPerc
setMngmtFee
setNumContribBps
setPercToSpouse
setRebalanceAccounts
setTaxAnnuityInd
setToSpouseOnDeathInd
setUnisexInd
write
LawChangePSAACCT.cpp
LawChangePSAACCT.h
LawChangePSAACCT::DimLimits
LawChangePSAACCT::DimLimits enumeration
LawChangePSAACCT::LawChangePSAACCT
LawChangePSAACCT::getAdminFee
LawChangePSAACCT::getAnnIntRate
LawChangePSAACCT::getAnnuityOffset
LawChangePSAACCT::getAnnuityToDib
LawChangePSAACCT::getAnnuityType
LawChangePSAACCT::getBuysAnnuity
LawChangePSAACCT::getContribBps
LawChangePSAACCT::getContribDist
LawChangePSAACCT::getContribRates
LawChangePSAACCT::getContribStartAge
LawChangePSAACCT::getContribYears
LawChangePSAACCT::getInvestMean
LawChangePSAACCT::getInvestPerc
LawChangePSAACCT::getInvestStdDev
LawChangePSAACCT::getLumpSumAtFra
LawChangePSAACCT::getLumpSumPerc
LawChangePSAACCT::getMngmtFee
LawChangePSAACCT::getNumContribBps
LawChangePSAACCT::getPercToSpouse
LawChangePSAACCT::getRebalanceAccounts
LawChangePSAACCT::getTaxAnnuityInd
LawChangePSAACCT::getToSpouseOnDeathInd
LawChangePSAACCT::getUnisexInd
LawChangePSAACCT::prepareStrings
LawChangePSAACCT::read
LawChangePSAACCT::setAdminFee
LawChangePSAACCT::setAnnIntRate
LawChangePSAACCT::setAnnuityOffset
LawChangePSAACCT::setAnnuityToDib
LawChangePSAACCT::setAnnuityType
LawChangePSAACCT::setBuysAnnuity
LawChangePSAACCT::setContribBps
LawChangePSAACCT::setContribDist
LawChangePSAACCT::setContribRates
LawChangePSAACCT::setContribStartAge
LawChangePSAACCT::setContribYears
LawChangePSAACCT::setInvestMean
LawChangePSAACCT::setInvestPerc
LawChangePSAACCT::setInvestStdDev
LawChangePSAACCT::setLumpSumAtFra
LawChangePSAACCT::setLumpSumPerc
LawChangePSAACCT::setMngmtFee
LawChangePSAACCT::setNumContribBps
LawChangePSAACCT::setPercToSpouse
LawChangePSAACCT::setRebalanceAccounts
LawChangePSAACCT::setTaxAnnuityInd
LawChangePSAACCT::setToSpouseOnDeathInd
LawChangePSAACCT::setUnisexInd
LawChangePSAACCT::write
LawChangeRead
LawChangeRead class
LawChangeRead
LawChangeRead members
LawChangeRead methods
about LawChangeRead class
read
read
read method
LawChangeRead.cpp
LawChangeRead.h
LawChangeRead::LawChangeRead
LawChangeRead::read
LawChangeTAXBENCHG
LawChangeTAXBENCHG class
LawChangeTAXBENCHG
LawChangeTAXBENCHG members
LawChangeTAXBENCHG methods
about LawChangeTAXBENCHG class
prepareStrings
LawChangeTAXBENCHG.cpp
LawChangeTAXBENCHG.h
LawChangeTAXBENCHG::LawChangeTAXBENCHG
LawChangeTAXBENCHG::prepareStrings
LawChangeTAXRATECHG
LawChangeTAXRATECHG class
LawChangeTAXRATECHG
LawChangeTAXRATECHG enumerations
LawChangeTAXRATECHG members
LawChangeTAXRATECHG methods
about LawChangeTAXRATECHG class
getNumTaxrates
getTaxrate
getYearTaxrate
prepareStrings
read
setNumTaxrates
setSelfEmpTaxrate
setTaxrate
setYearTaxrate
write
LawChangeTAXRATECHG.cpp
LawChangeTAXRATECHG.h
LawChangeTAXRATECHG::DimLimits
LawChangeTAXRATECHG::DimLimits enumeration
LawChangeTAXRATECHG::LawChangeTAXRATECHG
LawChangeTAXRATECHG::getNumTaxrates
LawChangeTAXRATECHG::getTaxrate
LawChangeTAXRATECHG::getYearTaxrate
LawChangeTAXRATECHG::prepareStrings
LawChangeTAXRATECHG::read
LawChangeTAXRATECHG::setNumTaxrates
LawChangeTAXRATECHG::setSelfEmpTaxrate
LawChangeTAXRATECHG::setTaxrate
LawChangeTAXRATECHG::setYearTaxrate
LawChangeTAXRATECHG::write
LawChangeWAGEBASECHG
LawChangeWAGEBASECHG class
LawChangeWAGEBASECHG
LawChangeWAGEBASECHG members
LawChangeWAGEBASECHG methods
about LawChangeWAGEBASECHG class
getBase77
getBaseOasdi
prepareStrings
read
setBase77
setBaseOasdi
write
LawChangeWAGEBASECHG.cpp
LawChangeWAGEBASECHG.h
LawChangeWAGEBASECHG::LawChangeWAGEBASECHG
LawChangeWAGEBASECHG::getBase77
LawChangeWAGEBASECHG::getBaseOasdi
LawChangeWAGEBASECHG::prepareStrings
LawChangeWAGEBASECHG::read
LawChangeWAGEBASECHG::setBase77
LawChangeWAGEBASECHG::setBaseOasdi
LawChangeWAGEBASECHG::write
LawChangeWIDFACTOR
LawChangeWIDFACTOR class
LawChangeWIDFACTOR
LawChangeWIDFACTOR data members
LawChangeWIDFACTOR members
LawChangeWIDFACTOR methods
about LawChangeWIDFACTOR class
newAgedWidFactor
numYears
prepareStrings
LawChangeWIDFACTOR.cpp
LawChangeWIDFACTOR.h
LawChangeWIDFACTOR::LawChangeWIDFACTOR
LawChangeWIDFACTOR::newAgedWidFactor
LawChangeWIDFACTOR::numYears
LawChangeWIDFACTOR::prepareStrings
LawChangeWIFEFACTOR
LawChangeWIFEFACTOR class
LawChangeWIFEFACTOR
LawChangeWIFEFACTOR data members
LawChangeWIFEFACTOR members
LawChangeWIFEFACTOR methods
about LawChangeWIFEFACTOR class
amtPerYear
newSpouseFactor
prepareStrings
LawChangeWIFEFACTOR.cpp
LawChangeWIFEFACTOR.h
LawChangeWIFEFACTOR::LawChangeWIFEFACTOR
LawChangeWIFEFACTOR::amtPerYear
LawChangeWIFEFACTOR::newSpouseFactor
LawChangeWIFEFACTOR::prepareStrings
LawChangeWrite
LawChangeWrite class
LawChangeWrite
LawChangeWrite members
LawChangeWrite methods
about LawChangeWrite class
write
write
write method
LawChangeWrite.cpp
LawChangeWrite.h
LawChangeWrite::LawChangeWrite
LawChangeWrite::write
MALE enumeration member
MARRLENGTH enumeration member
MAXCONTRIBAGES enumeration member
MAXCONTRIBRATES enumeration member
MAXCONTRIBRATEYEARS enumeration member
MAXDECLINEPERC enumeration member
MAXEARN
MAXEARN variable
MAXFAMSIZE enumeration member
MAXIMUM enumeration member
MAXIYCPI enumeration member
MAXLCH enumeration member
MAXPEBS enumeration member
MAXTAXRATES enumeration member
MAXYRS
MAXYRS variable
MAXYRSR
MAXYRSR variable
MAXYRSR1
MAXYRSR1 variable
MAX_BITSET_SIZE
MAX_BITSET_SIZE variable
MQGE_BIT enumeration member
MilServDates
MilServDates class
MilServDates
MilServDates data members
MilServDates friends
MilServDates members
MilServDates methods
about MilServDates class
amtPerMonth37_56
amtPerQtr57_77
amtPerYear78_01
check
class boost::serialization::access
dec1950
deleteContents
endDate
endDateCheck
endDateCheck
endDateCheck method
firstMilServDate
getCount1
getCount2
getDatesString
getEarn
getEarn3750
getQc3750
getQcov
getType
lastMilServDate
parseDates
parseLine
setCount1
setCount2
setType
startDate
startDateCheck
startDateCheck
startDateCheck method
toString
toString
toString method
~MilServDates
MilServDates::MilServDates
MilServDates::amtPerMonth37_56
MilServDates::amtPerQtr57_77
MilServDates::amtPerYear78_01
MilServDates::check
MilServDates::dec1950
MilServDates::deleteContents
MilServDates::endDate
MilServDates::endDateCheck
MilServDates::firstMilServDate
MilServDates::getCount1
MilServDates::getCount2
MilServDates::getDatesString
MilServDates::getEarn
MilServDates::getEarn3750
MilServDates::getQc3750
MilServDates::getQcov
MilServDates::getType
MilServDates::lastMilServDate
MilServDates::parseDates
MilServDates::parseLine
MilServDates::setCount1
MilServDates::setCount2
MilServDates::setType
MilServDates::startDate
MilServDates::startDateCheck
MilServDates::toString
MilServDates::~MilServDates
MilServDatesVec
MilServDatesVec class
MAX_MILSERVDATES
MilServDatesVec
MilServDatesVec data members
MilServDatesVec friends
MilServDatesVec members
MilServDatesVec methods
about MilServDatesVec class
check
class boost::serialization::access
deleteContents
getEarn
getEarn3750
getFirstYear
getLastYear
getMSCount
getQc3750
getQcov
msCountCheck
msdates
setMSCount
~MilServDatesVec
MilServDatesVec.h
MilServDatesVec::MAX_MILSERVDATES
MilServDatesVec::MilServDatesVec
MilServDatesVec::check
MilServDatesVec::deleteContents
MilServDatesVec::getEarn
MilServDatesVec::getEarn3750
MilServDatesVec::getFirstYear
MilServDatesVec::getLastYear
MilServDatesVec::getMSCount
MilServDatesVec::getQc3750
MilServDatesVec::getQcov
MilServDatesVec::msCountCheck
MilServDatesVec::msdates
MilServDatesVec::setMSCount
MilServDatesVec::~MilServDatesVec
Misc Library
Classes
Files
Functions
Macros
Types
Variables
NEWFORMULA enumeration member
NEWSPECMIN enumeration member
NOCPIELIG enumeration member
NODIBGUAR enumeration member
NONE enumeration member
NONPRIMARYDEATH enumeration member
NOOLDSTART enumeration member
NOPIATABLE enumeration member
NOQCS enumeration member
NOREINDWID enumeration member
NOTFULLHAS2040 enumeration member
NOTFULLNOT2040 enumeration member
NOTRANSGUAR enumeration member
NOT_APPLICABLE enumeration member
NOWINDFALLELIM enumeration member
NO_BEN enumeration member
NO_CAP enumeration member
NO_PIA_TYPE enumeration member
NO_PROJ enumeration member
NO_SPEC_MIN_DRC enumeration member
NO_TABLE enumeration member
NO_UNISEX enumeration member
NRACHANGE enumeration member
NUMASSUMSETS enumeration member
NUMPROJYEARS enumeration member
NUMSPECMINPERCTYPES enumeration member
NUMTAXRATETYPES enumeration member
NUMTRUSTFUNDTYPES enumeration member
NUMYEARPERIODS enumeration member
NUM_ADDRESS_LINES enumeration member
NUM_ANNUITY_AGES enumeration member
NUM_CHANGE_TYPES enumeration member
NUM_DISAB_PERIODS enumeration member
NUM_EARN_TOTALIZATION enumeration member
NUM_INVESTMENTS enumeration member
NUM_OLD_START_TYPES enumeration member
NUM_SEX enumeration member
NUM_TABLES enumeration member
NUM_TYPES enumeration member
NumPunct.cpp
NumPunct.h
OASDHITF enumeration member
OASDITF enumeration member
OASITF enumeration member
OLDLAW_MAXIMUM enumeration member
OLD_AGE enumeration member
OLD_START enumeration member
ONEHALFPENSION enumeration member
ORSYR
ORSYR variable
OS1939 enumeration member
OS1950 enumeration member
OS1958 enumeration member
OS1965 enumeration member
OS1967 enumeration member
OS1977_78 enumeration member
OS1977_79 enumeration member
OS1990 enumeration member
OSTREAM
OSTREAM macro
OTHER_ASSUM enumeration member
OldPia
OldPia class
OldPia
OldPia data members
OldPia members
OldPia methods
about OldPia class
cpiBase
iamemax
mfbOldCal
oldPiaCal
pl1952
pl1954
pl1958
pl1965
pl1967
pl1969
pl1971
pl1972
pl1973
pl1973ext
~OldPia
OldPia.h
OldPia::OldPia
OldPia::cpiBase
OldPia::iamemax
OldPia::mfbOldCal
OldPia::oldPiaCal
OldPia::pl1952
OldPia::pl1954
OldPia::pl1958
OldPia::pl1965
OldPia::pl1967
OldPia::pl1969
OldPia::pl1971
OldPia::pl1972
OldPia::pl1973
OldPia::pl1973ext
OldPia::~OldPia
OldStart
OldStart class
INC_PER_YEAR
OldStart
OldStart data members
OldStart enumerations
OldStart members
OldStart methods
about OldStart class
bendMfb
calculate
entDate
getAmeOs
getDivisorOs
getIncyrs
getMethodOs
getPib
getPibInc
imputeEarnings
incrementCal
incrementOldCal
initialize
isApplicable
isApplicable
isApplicable method
isOs1977_90
methodOsCal
oldStart39Cal
oldStart50Cal
percMfb
portionAme
portionPiaElig
setAmeOs
setDivisorOs
setIncyrs
setMethodOs
setPib
setPibInc
~OldStart
OldStart.h
OldStart1Page
OldStart1Page class
OldStart1Page
OldStart1Page members
OldStart1Page methods
about OldStart1Page class
prepareStrings
~OldStart1Page
OldStart1Page.cpp
OldStart1Page.h
OldStart1Page::OldStart1Page
OldStart1Page::prepareStrings
OldStart1Page::~OldStart1Page
OldStart2Page
OldStart2Page class
OldStart2Page
OldStart2Page members
OldStart2Page methods
about OldStart2Page class
prepareStrings
pubPenOut
~OldStart2Page
OldStart2Page.cpp
OldStart2Page.h
OldStart2Page::OldStart2Page
OldStart2Page::prepareStrings
OldStart2Page::pubPenOut
OldStart2Page::~OldStart2Page
OldStart::INC_PER_YEAR
OldStart::OldStart
OldStart::OldStartType
OldStart::OldStartType enumeration
OldStart::bendMfb
OldStart::calculate
OldStart::entDate
OldStart::getAmeOs
OldStart::getDivisorOs
OldStart::getIncyrs
OldStart::getMethodOs
OldStart::getPib
OldStart::getPibInc
OldStart::imputeEarnings
OldStart::incrementCal
OldStart::incrementOldCal
OldStart::initialize
OldStart::isApplicable
OldStart::isOs1977_90
OldStart::methodOsCal
OldStart::oldStart39Cal
OldStart::oldStart50Cal
OldStart::percMfb
OldStart::portionAme
OldStart::portionPiaElig
OldStart::setAmeOs
OldStart::setDivisorOs
OldStart::setIncyrs
OldStart::setMethodOs
OldStart::setPib
OldStart::setPibInc
OldStart::~OldStart
OldStartLC
OldStartLC class
OldStartLC
OldStartLC data members
OldStartLC members
OldStartLC methods
about OldStartLC class
isApplicable
isApplicable
isApplicable method
lawChange
~OldStartLC
OldStartLC.cpp
OldStartLC.h
OldStartLC::OldStartLC
OldStartLC::isApplicable
OldStartLC::lawChange
OldStartLC::~OldStartLC
OnePage
OnePage class
OnePage
OnePage members
OnePage methods
about OnePage class
prepareStrings
printEarn
~OnePage
OnePage.cpp
OnePage.h
OnePage::OnePage
OnePage::prepareStrings
OnePage::printEarn
OnePage::~OnePage
Out132
Out132 class
Out132
Out132 members
Out132 methods
about Out132 class
footer
header
pgtitle
prepareStrings
Out132::Out132
Out132::footer
Out132::header
Out132::pgtitle
Out132::prepareStrings
Out80
Out80 class
Out80
Out80 members
Out80 methods
about Out80 class
footer
header
pgtitle
prepareStrings
Out80::Out80
Out80::footer
Out80::header
Out80::pgtitle
Out80::prepareStrings
OutDC.cpp
OutDC.h
OutDC80
OutDC80 class
OutDC80
OutDC80 members
OutDC80 methods
about OutDC80 class
advanceLine
formfeed
printLine
printLine
printLine method
printLinena
printLinena
printLinena method
setDC
setHeight
setx
sety
OutDC80::OutDC80
OutDC80::advanceLine
OutDC80::formfeed
OutDC80::printLine
OutDC80::printLinena
OutDC80::setDC
OutDC80::setHeight
OutDC80::setx
OutDC80::sety
OutFile132
OutFile132 class
OutFile132
OutFile132
OutFile132 constructor
OutFile132 members
OutFile132 methods
about OutFile132 class
advanceLine
formfeed
getColString
getCols
printLine
printLine
printLine method
printLinena
printLinena
printLinena method
setCols
~OutFile132
OutFile132.cpp
OutFile132.h
OutFile132::OutFile132
OutFile132::advanceLine
OutFile132::formfeed
OutFile132::getColString
OutFile132::getCols
OutFile132::printLine
OutFile132::printLinena
OutFile132::setCols
OutFile132::~OutFile132
OutFile80
OutFile80 class
OutFile80
OutFile80
OutFile80 constructor
OutFile80 members
OutFile80 methods
about OutFile80 class
advanceLine
formfeed
getColString
getCols
printLine
printLine
printLine method
printLinena
printLinena
printLinena method
setCols
~OutFile80
OutFile80.cpp
OutFile80.h
OutFile80::OutFile80
OutFile80::advanceLine
OutFile80::formfeed
OutFile80::getColString
OutFile80::getCols
OutFile80::printLine
OutFile80::printLinena
OutFile80::setCols
OutFile80::~OutFile80
OutFileHTML
OutFileHTML class
OutFileHTML
OutFileHTML data members
OutFileHTML members
OutFileHTML methods
PAGE_TITLE_LINES
about OutFileHTML class
closeFile
cssPage
doHeader
firstPage
gettitle
openFile
pgtitle
settitle
tagRightChar
write
write
write
write method
writeAttribute
writeAttribute
writeAttribute method
writeBeginGrayRow
writeBeginTable
writeBeginTable
writeBeginTable method
writeBeginTag
writeCellBody
writeCellBody
writeCellBody method
writeCellBodyColSpan
writeCellBodyRight
writeCellBodyRight
writeCellBodyRight
writeCellBodyRight method
writeCellHeading
writeCellHeading
writeCellHeading method
writeCellHeadingColSpan
writeCellHeadingColSpan
writeCellHeadingColSpan method
writeCellHeadingRowSpan
writeEndTag
writeFullBeginTag
writeLine
writeLine
writeLine
writeLine method
writeYear
~OutFileHTML
OutFileHTML::OutFileHTML
OutFileHTML::PAGE_TITLE_LINES
OutFileHTML::closeFile
OutFileHTML::cssPage
OutFileHTML::doHeader
OutFileHTML::firstPage
OutFileHTML::gettitle
OutFileHTML::openFile
OutFileHTML::pgtitle
OutFileHTML::settitle
OutFileHTML::tagRightChar
OutFileHTML::write
OutFileHTML::writeAttribute
OutFileHTML::writeBeginGrayRow
OutFileHTML::writeBeginTable
OutFileHTML::writeBeginTag
OutFileHTML::writeCellBody
OutFileHTML::writeCellBodyColSpan
OutFileHTML::writeCellBodyRight
OutFileHTML::writeCellHeading
OutFileHTML::writeCellHeadingColSpan
OutFileHTML::writeCellHeadingRowSpan
OutFileHTML::writeEndTag
OutFileHTML::writeFullBeginTag
OutFileHTML::writeLine
OutFileHTML::writeYear
OutFileHTML::~OutFileHTML
Outfile
Outfile class
Outfile
Outfile
Outfile constructor
Outfile data members
Outfile members
Outfile methods
PAGE_TITLE_LINES
about Outfile class
advanceLine
closeout
dateModyyr
footer
formfeed
getPageNum
gettitle
header
openout
outstrm
pageNum
pgtitle
printLine
printLine
printLine method
printLinena
printLinena
printLinena method
setPageNum
settitle
~Outfile
Outfile::Outfile
Outfile::PAGE_TITLE_LINES
Outfile::advanceLine
Outfile::closeout
Outfile::dateModyyr
Outfile::footer
Outfile::formfeed
Outfile::getPageNum
Outfile::gettitle
Outfile::header
Outfile::openout
Outfile::outstrm
Outfile::pageNum
Outfile::pgtitle
Outfile::printLine
Outfile::printLinena
Outfile::setPageNum
Outfile::settitle
Outfile::~Outfile
OutfileHTML.cpp
OutfileHTML.h
PEBS_ASSUM enumeration member
PEBS_CALC enumeration member
PEBS_DISAB enumeration member
PEBS_OAB_DELAYED enumeration member
PEBS_OAB_EARLY enumeration member
PEBS_OAB_FULL enumeration member
PEBS_SURV enumeration member
PERMANDCURRENT enumeration member
PERMNOTCURRENT enumeration member
PIA_1_0 enumeration member
PIA_1_5 enumeration member
PIA_IDS_2YEARS
PIA_IDS_2YEARS macro
PIA_IDS_ACTQCOUT
PIA_IDS_ACTQCOUT macro
PIA_IDS_AGEMONTH
PIA_IDS_AGEMONTH macro
PIA_IDS_AGEPLAN
PIA_IDS_AGEPLAN macro
PIA_IDS_AIMEOUT
PIA_IDS_AIMEOUT macro
PIA_IDS_AMEOUT
PIA_IDS_AMEOUT macro
PIA_IDS_ANDLATER
PIA_IDS_ANDLATER macro
PIA_IDS_ANSCCH
PIA_IDS_ANSCCH macro
PIA_IDS_APPCOLA1
PIA_IDS_APPCOLA1 macro
PIA_IDS_APPCOLA2
PIA_IDS_APPCOLA2 macro
PIA_IDS_APPCOLA3
PIA_IDS_APPCOLA3 macro
PIA_IDS_APPCOLA4
PIA_IDS_APPCOLA4 macro
PIA_IDS_ARDRI1
PIA_IDS_ARDRI1 macro
PIA_IDS_ARDRI10
PIA_IDS_ARDRI10 macro
PIA_IDS_ARDRI2
PIA_IDS_ARDRI2 macro
PIA_IDS_ARDRI3
PIA_IDS_ARDRI3 macro
PIA_IDS_ARDRI4
PIA_IDS_ARDRI4 macro
PIA_IDS_ARDRI5
PIA_IDS_ARDRI5 macro
PIA_IDS_ARDRI6
PIA_IDS_ARDRI6 macro
PIA_IDS_ARDRI7
PIA_IDS_ARDRI7 macro
PIA_IDS_ARDRI8
PIA_IDS_ARDRI8 macro
PIA_IDS_ARDRI9
PIA_IDS_ARDRI9 macro
PIA_IDS_ARFFOUT
PIA_IDS_ARFFOUT macro
PIA_IDS_ARFMOUT
PIA_IDS_ARFMOUT macro
PIA_IDS_ATODOUBLE
PIA_IDS_ATODOUBLE macro
PIA_IDS_ATOFLOAT
PIA_IDS_ATOFLOAT macro
PIA_IDS_ATOINT
PIA_IDS_ATOINT macro
PIA_IDS_ATOLONG
PIA_IDS_ATOLONG macro
PIA_IDS_AVERAGETEXT
PIA_IDS_AVERAGETEXT macro
PIA_IDS_AVGWG
PIA_IDS_AVGWG macro
PIA_IDS_AVGWGTTL
PIA_IDS_AVGWGTTL macro
PIA_IDS_AWASSUM
PIA_IDS_AWASSUM macro
PIA_IDS_AWBI1
PIA_IDS_AWBI1 macro
PIA_IDS_AWBI2
PIA_IDS_AWBI2 macro
PIA_IDS_AWBI3
PIA_IDS_AWBI3 macro
PIA_IDS_AWBIDAT1
PIA_IDS_AWBIDAT1 macro
PIA_IDS_AWOUT
PIA_IDS_AWOUT macro
PIA_IDS_BASE1
PIA_IDS_BASE1 macro
PIA_IDS_BASE2
PIA_IDS_BASE2 macro
PIA_IDS_BASECH
PIA_IDS_BASECH macro
PIA_IDS_BASEYR1
PIA_IDS_BASEYR1 macro
PIA_IDS_BASEYR2
PIA_IDS_BASEYR2 macro
PIA_IDS_BASEYR3
PIA_IDS_BASEYR3 macro
PIA_IDS_BASEYR4
PIA_IDS_BASEYR4 macro
PIA_IDS_BEGIN1
PIA_IDS_BEGIN1 macro
PIA_IDS_BEGIN2
PIA_IDS_BEGIN2 macro
PIA_IDS_BEGIN3
PIA_IDS_BEGIN3 macro
PIA_IDS_BEGIN4
PIA_IDS_BEGIN4 macro
PIA_IDS_BEGIN5
PIA_IDS_BEGIN5 macro
PIA_IDS_BEGIN6
PIA_IDS_BEGIN6 macro
PIA_IDS_BEN1OUT
PIA_IDS_BEN1OUT macro
PIA_IDS_BEN2OUT
PIA_IDS_BEN2OUT macro
PIA_IDS_BENARRAY1
PIA_IDS_BENARRAY1 macro
PIA_IDS_BENARRAY2
PIA_IDS_BENARRAY2 macro
PIA_IDS_BENDATE1
PIA_IDS_BENDATE1 macro
PIA_IDS_BENDATE2
PIA_IDS_BENDATE2 macro
PIA_IDS_BENDATE3
PIA_IDS_BENDATE3 macro
PIA_IDS_BENDATE4
PIA_IDS_BENDATE4 macro
PIA_IDS_BENDATE5
PIA_IDS_BENDATE5 macro
PIA_IDS_BENDATE6
PIA_IDS_BENDATE6 macro
PIA_IDS_BENFOUT
PIA_IDS_BENFOUT macro
PIA_IDS_BIASSUM
PIA_IDS_BIASSUM macro
PIA_IDS_BICCHP
PIA_IDS_BICCHP macro
PIA_IDS_BIOUT
PIA_IDS_BIOUT macro
PIA_IDS_BIPROJTTL
PIA_IDS_BIPROJTTL macro
PIA_IDS_BIRTH1
PIA_IDS_BIRTH1 macro
PIA_IDS_BIRTH2
PIA_IDS_BIRTH2 macro
PIA_IDS_BIRTH3
PIA_IDS_BIRTH3 macro
PIA_IDS_BIRTH4
PIA_IDS_BIRTH4 macro
PIA_IDS_BIRTH5
PIA_IDS_BIRTH5 macro
PIA_IDS_BIRTH6
PIA_IDS_BIRTH6 macro
PIA_IDS_BITANN1
PIA_IDS_BITANN1 macro
PIA_IDS_CACHUP1
PIA_IDS_CACHUP1 macro
PIA_IDS_CACHUP2
PIA_IDS_CACHUP2 macro
PIA_IDS_CACHUP3
PIA_IDS_CACHUP3 macro
PIA_IDS_CACHUP4
PIA_IDS_CACHUP4 macro
PIA_IDS_CESS2OUT
PIA_IDS_CESS2OUT macro
PIA_IDS_COMMA
PIA_IDS_COMMA macro
PIA_IDS_CONFIG1
PIA_IDS_CONFIG1 macro
PIA_IDS_CONFIG5
PIA_IDS_CONFIG5 macro
PIA_IDS_CONFIG6
PIA_IDS_CONFIG6 macro
PIA_IDS_CPIINC1
PIA_IDS_CPIINC1 macro
PIA_IDS_CPIINC2
PIA_IDS_CPIINC2 macro
PIA_IDS_CPIINC3
PIA_IDS_CPIINC3 macro
PIA_IDS_CPIINC4
PIA_IDS_CPIINC4 macro
PIA_IDS_CUPROJTTL
PIA_IDS_CUPROJTTL macro
PIA_IDS_CURINSOUT
PIA_IDS_CURINSOUT macro
PIA_IDS_DATEDAY
PIA_IDS_DATEDAY macro
PIA_IDS_DATEDIFF
PIA_IDS_DATEDIFF macro
PIA_IDS_DATEMONTH
PIA_IDS_DATEMONTH macro
PIA_IDS_DATEREAD
PIA_IDS_DATEREAD macro
PIA_IDS_DATEYEAR
PIA_IDS_DATEYEAR macro
PIA_IDS_DBLEANN1
PIA_IDS_DBLEANN1 macro
PIA_IDS_DBLEANN2
PIA_IDS_DBLEANN2 macro
PIA_IDS_DEATH1
PIA_IDS_DEATH1 macro
PIA_IDS_DEATH2
PIA_IDS_DEATH2 macro
PIA_IDS_DEATH3
PIA_IDS_DEATH3 macro
PIA_IDS_DEATH4
PIA_IDS_DEATH4 macro
PIA_IDS_DEATH5
PIA_IDS_DEATH5 macro
PIA_IDS_DEATH6
PIA_IDS_DEATH6 macro
PIA_IDS_DEATHOUT
PIA_IDS_DEATHOUT macro
PIA_IDS_DIBENTOUT
PIA_IDS_DIBENTOUT macro
PIA_IDS_DICESS1
PIA_IDS_DICESS1 macro
PIA_IDS_DICESS2
PIA_IDS_DICESS2 macro
PIA_IDS_DICESS3
PIA_IDS_DICESS3 macro
PIA_IDS_DICESS4
PIA_IDS_DICESS4 macro
PIA_IDS_DICESS5
PIA_IDS_DICESS5 macro
PIA_IDS_DICESS6
PIA_IDS_DICESS6 macro
PIA_IDS_DICESS7
PIA_IDS_DICESS7 macro
PIA_IDS_DICESS8
PIA_IDS_DICESS8 macro
PIA_IDS_DINS1OUT
PIA_IDS_DINS1OUT macro
PIA_IDS_DINS2OUT
PIA_IDS_DINS2OUT macro
PIA_IDS_DINS3OUT
PIA_IDS_DINS3OUT macro
PIA_IDS_DISREQCAL1
PIA_IDS_DISREQCAL1 macro
PIA_IDS_DISREQCAL2
PIA_IDS_DISREQCAL2 macro
PIA_IDS_DOBOUT
PIA_IDS_DOBOUT macro
PIA_IDS_DOBWIDOUT
PIA_IDS_DOBWIDOUT macro
PIA_IDS_DRCFOUT
PIA_IDS_DRCFOUT macro
PIA_IDS_DRCMOUT
PIA_IDS_DRCMOUT macro
PIA_IDS_EARNHI
PIA_IDS_EARNHI macro
PIA_IDS_EARNMAL
PIA_IDS_EARNMAL macro
PIA_IDS_EARNPEBS
PIA_IDS_EARNPEBS macro
PIA_IDS_EARNPROJ
PIA_IDS_EARNPROJ macro
PIA_IDS_EARNTYPE
PIA_IDS_EARNTYPE macro
PIA_IDS_EARNTYPE1
PIA_IDS_EARNTYPE1 macro
PIA_IDS_EARNTYPEYR
PIA_IDS_EARNTYPEYR macro
PIA_IDS_ELAPSOUT
PIA_IDS_ELAPSOUT macro
PIA_IDS_END1
PIA_IDS_END1 macro
PIA_IDS_END2
PIA_IDS_END2 macro
PIA_IDS_END3
PIA_IDS_END3 macro
PIA_IDS_END4
PIA_IDS_END4 macro
PIA_IDS_ENT1
PIA_IDS_ENT1 macro
PIA_IDS_ENT2
PIA_IDS_ENT2 macro
PIA_IDS_ENT3
PIA_IDS_ENT3 macro
PIA_IDS_ENT4
PIA_IDS_ENT4 macro
PIA_IDS_ERNLIMOUT
PIA_IDS_ERNLIMOUT macro
PIA_IDS_FAMSIZE
PIA_IDS_FAMSIZE macro
PIA_IDS_FLOATANN1
PIA_IDS_FLOATANN1 macro
PIA_IDS_FLOATANN2
PIA_IDS_FLOATANN2 macro
PIA_IDS_FLOATMTH1
PIA_IDS_FLOATMTH1 macro
PIA_IDS_FLOATMTH2
PIA_IDS_FLOATMTH2 macro
PIA_IDS_FLOATMTH3
PIA_IDS_FLOATMTH3 macro
PIA_IDS_FLOATQTR1
PIA_IDS_FLOATQTR1 macro
PIA_IDS_FLOATQTR2
PIA_IDS_FLOATQTR2 macro
PIA_IDS_FLOATQTR3
PIA_IDS_FLOATQTR3 macro
PIA_IDS_FLOATQTR4
PIA_IDS_FLOATQTR4 macro
PIA_IDS_FMSTRING
PIA_IDS_FMSTRING macro
PIA_IDS_FOINFO1
PIA_IDS_FOINFO1 macro
PIA_IDS_FOINFO2
PIA_IDS_FOINFO2 macro
PIA_IDS_FOINFO3
PIA_IDS_FOINFO3 macro
PIA_IDS_FQINC1
PIA_IDS_FQINC1 macro
PIA_IDS_FQINC2
PIA_IDS_FQINC2 macro
PIA_IDS_FQINC3
PIA_IDS_FQINC3 macro
PIA_IDS_FQINC4
PIA_IDS_FQINC4 macro
PIA_IDS_FULLBEN
PIA_IDS_FULLBEN macro
PIA_IDS_GENFILE1
PIA_IDS_GENFILE1 macro
PIA_IDS_GENFILE2
PIA_IDS_GENFILE2 macro
PIA_IDS_GENFILE3
PIA_IDS_GENFILE3 macro
PIA_IDS_HIGHTEXT
PIA_IDS_HIGHTEXT macro
PIA_IDS_HISTAMTTL
PIA_IDS_HISTAMTTL macro
PIA_IDS_HISTAMTUPDATE
PIA_IDS_HISTAMTUPDATE macro
PIA_IDS_IALTAW1
PIA_IDS_IALTAW1 macro
PIA_IDS_IALTAW2
PIA_IDS_IALTAW2 macro
PIA_IDS_IALTBI1
PIA_IDS_IALTBI1 macro
PIA_IDS_IALTBI2
PIA_IDS_IALTBI2 macro
PIA_IDS_INSTATOUT
PIA_IDS_INSTATOUT macro
PIA_IDS_INSUREOUT
PIA_IDS_INSUREOUT macro
PIA_IDS_INTANN1
PIA_IDS_INTANN1 macro
PIA_IDS_INTANN2
PIA_IDS_INTANN2 macro
PIA_IDS_JBIRTH1
PIA_IDS_JBIRTH1 macro
PIA_IDS_JBIRTH2
PIA_IDS_JBIRTH2 macro
PIA_IDS_JBIRTH3
PIA_IDS_JBIRTH3 macro
PIA_IDS_JBIRTH4
PIA_IDS_JBIRTH4 macro
PIA_IDS_JBIRTH5
PIA_IDS_JBIRTH5 macro
PIA_IDS_JOASDI
PIA_IDS_JOASDI macro
PIA_IDS_JONSET1
PIA_IDS_JONSET1 macro
PIA_IDS_JONSET2
PIA_IDS_JONSET2 macro
PIA_IDS_JONSET3
PIA_IDS_JONSET3 macro
PIA_IDS_JONSET4
PIA_IDS_JONSET4 macro
PIA_IDS_JONSET5
PIA_IDS_JONSET5 macro
PIA_IDS_JONSET6
PIA_IDS_JONSET6 macro
PIA_IDS_JONSET7
PIA_IDS_JONSET7 macro
PIA_IDS_JSURV
PIA_IDS_JSURV macro
PIA_IDS_JSURVOUT
PIA_IDS_JSURVOUT macro
PIA_IDS_LAWCHG1
PIA_IDS_LAWCHG1 macro
PIA_IDS_LAWCHG2
PIA_IDS_LAWCHG2 macro
PIA_IDS_LAWCHG3
PIA_IDS_LAWCHG3 macro
PIA_IDS_LAWCHG4
PIA_IDS_LAWCHG4 macro
PIA_IDS_LAWCHG5
PIA_IDS_LAWCHG5 macro
PIA_IDS_LAWCHG6
PIA_IDS_LAWCHG6 macro
PIA_IDS_LAWCHG7
PIA_IDS_LAWCHG7 macro
PIA_IDS_LAWCHG8
PIA_IDS_LAWCHG8 macro
PIA_IDS_LAWCHG9
PIA_IDS_LAWCHG9 macro
PIA_IDS_LOWTEXT
PIA_IDS_LOWTEXT macro
PIA_IDS_MAXIMUMTEXT
PIA_IDS_MAXIMUMTEXT macro
PIA_IDS_METHOD
PIA_IDS_METHOD macro
PIA_IDS_MFBBEN
PIA_IDS_MFBBEN macro
PIA_IDS_MFBLOUT
PIA_IDS_MFBLOUT macro
PIA_IDS_MFBOUT
PIA_IDS_MFBOUT macro
PIA_IDS_MILSERV1
PIA_IDS_MILSERV1 macro
PIA_IDS_MILSERV2
PIA_IDS_MILSERV2 macro
PIA_IDS_MILSERV3
PIA_IDS_MILSERV3 macro
PIA_IDS_MILSERV4
PIA_IDS_MILSERV4 macro
PIA_IDS_MILSERV5
PIA_IDS_MILSERV5 macro
PIA_IDS_MILSERV6
PIA_IDS_MILSERV6 macro
PIA_IDS_MILSERV7
PIA_IDS_MILSERV7 macro
PIA_IDS_MODTC
PIA_IDS_MODTC macro
PIA_IDS_MONTHTEXT
PIA_IDS_MONTHTEXT macro
PIA_IDS_NAMEOUT
PIA_IDS_NAMEOUT macro
PIA_IDS_NDISINOUT
PIA_IDS_NDISINOUT macro
PIA_IDS_NEEDAW
PIA_IDS_NEEDAW macro
PIA_IDS_NEEDBASES
PIA_IDS_NEEDBASES macro
PIA_IDS_NEEDBI
PIA_IDS_NEEDBI macro
PIA_IDS_NINSTOUT
PIA_IDS_NINSTOUT macro
PIA_IDS_NINSUROUT
PIA_IDS_NINSUROUT macro
PIA_IDS_NONPENDATE1
PIA_IDS_NONPENDATE1 macro
PIA_IDS_NONPENDATE2
PIA_IDS_NONPENDATE2 macro
PIA_IDS_NONPENDATE3
PIA_IDS_NONPENDATE3 macro
PIA_IDS_NONPENDATEOUT
PIA_IDS_NONPENDATEOUT macro
PIA_IDS_NONPENOUT
PIA_IDS_NONPENOUT macro
PIA_IDS_NRA1OUT
PIA_IDS_NRA1OUT macro
PIA_IDS_NRAOUT
PIA_IDS_NRAOUT macro
PIA_IDS_NRAWIDOUT
PIA_IDS_NRAWIDOUT macro
PIA_IDS_NRAWIFEOUT
PIA_IDS_NRAWIFEOUT macro
PIA_IDS_NTOTALOUT
PIA_IDS_NTOTALOUT macro
PIA_IDS_OABBENOUT
PIA_IDS_OABBENOUT macro
PIA_IDS_OABENTOUT
PIA_IDS_OABENTOUT macro
PIA_IDS_OLDSTART1
PIA_IDS_OLDSTART1 macro
PIA_IDS_OLDSTART2
PIA_IDS_OLDSTART2 macro
PIA_IDS_ONEPAGE
PIA_IDS_ONEPAGE macro
PIA_IDS_ONSET1
PIA_IDS_ONSET1 macro
PIA_IDS_ONSET10
PIA_IDS_ONSET10 macro
PIA_IDS_ONSET11
PIA_IDS_ONSET11 macro
PIA_IDS_ONSET2
PIA_IDS_ONSET2 macro
PIA_IDS_ONSET2OUT
PIA_IDS_ONSET2OUT macro
PIA_IDS_ONSET3
PIA_IDS_ONSET3 macro
PIA_IDS_ONSET4
PIA_IDS_ONSET4 macro
PIA_IDS_ONSET5
PIA_IDS_ONSET5 macro
PIA_IDS_ONSET6
PIA_IDS_ONSET6 macro
PIA_IDS_ONSET7
PIA_IDS_ONSET7 macro
PIA_IDS_ONSET8
PIA_IDS_ONSET8 macro
PIA_IDS_ONSET9
PIA_IDS_ONSET9 macro
PIA_IDS_ONSETOUT
PIA_IDS_ONSETOUT macro
PIA_IDS_OPENERR
PIA_IDS_OPENERR macro
PIA_IDS_OSRANGE1
PIA_IDS_OSRANGE1 macro
PIA_IDS_OSRANGE2
PIA_IDS_OSRANGE2 macro
PIA_IDS_OSSTRING
PIA_IDS_OSSTRING macro
PIA_IDS_OUTFILE
PIA_IDS_OUTFILE macro
PIA_IDS_PEBESMONTH
PIA_IDS_PEBESMONTH macro
PIA_IDS_PEBSASM
PIA_IDS_PEBSASM macro
PIA_IDS_PERCBACK
PIA_IDS_PERCBACK macro
PIA_IDS_PERCFWRD
PIA_IDS_PERCFWRD macro
PIA_IDS_PIACALPLRGE
PIA_IDS_PIACALPLRGE macro
PIA_IDS_PIACALRANGE
PIA_IDS_PIACALRANGE macro
PIA_IDS_PIALOUT
PIA_IDS_PIALOUT macro
PIA_IDS_PIAOUT
PIA_IDS_PIAOUT macro
PIA_IDS_PIATABLE1
PIA_IDS_PIATABLE1 macro
PIA_IDS_PIATABLE2
PIA_IDS_PIATABLE2 macro
PIA_IDS_PIB50MFB
PIA_IDS_PIB50MFB macro
PIA_IDS_PIB50PIB
PIA_IDS_PIB50PIB macro
PIA_IDS_PIB52MFB
PIA_IDS_PIB52MFB macro
PIA_IDS_PIB54MFB
PIA_IDS_PIB54MFB macro
PIA_IDS_PIB54PIA
PIA_IDS_PIB54PIA macro
PIA_IDS_PIB58AME
PIA_IDS_PIB58AME macro
PIA_IDS_PIB58PIB
PIA_IDS_PIB58PIB macro
PIA_IDS_PIBTABLE1
PIA_IDS_PIBTABLE1 macro
PIA_IDS_PIBTABLE2
PIA_IDS_PIBTABLE2 macro
PIA_IDS_PONSETOUT
PIA_IDS_PONSETOUT macro
PIA_IDS_PRCESSOUT
PIA_IDS_PRCESSOUT macro
PIA_IDS_PRENTOUT
PIA_IDS_PRENTOUT macro
PIA_IDS_PRIOROUT
PIA_IDS_PRIOROUT macro
PIA_IDS_PROBASOUT
PIA_IDS_PROBASOUT macro
PIA_IDS_PROJBACK1
PIA_IDS_PROJBACK1 macro
PIA_IDS_PROJBACK2
PIA_IDS_PROJBACK2 macro
PIA_IDS_PROJFWRD1
PIA_IDS_PROJFWRD1 macro
PIA_IDS_PROJFWRD2
PIA_IDS_PROJFWRD2 macro
PIA_IDS_PRRENT1
PIA_IDS_PRRENT1 macro
PIA_IDS_PRRENT2
PIA_IDS_PRRENT2 macro
PIA_IDS_PRRENT3
PIA_IDS_PRRENT3 macro
PIA_IDS_PRRENT4
PIA_IDS_PRRENT4 macro
PIA_IDS_PRRENT5
PIA_IDS_PRRENT5 macro
PIA_IDS_PRRENT6
PIA_IDS_PRRENT6 macro
PIA_IDS_PRRENT7
PIA_IDS_PRRENT7 macro
PIA_IDS_PTSTRING
PIA_IDS_PTSTRING macro
PIA_IDS_PUBPEN
PIA_IDS_PUBPEN macro
PIA_IDS_QC
PIA_IDS_QC macro
PIA_IDS_QC51TD
PIA_IDS_QC51TD macro
PIA_IDS_QCAMT
PIA_IDS_QCAMT macro
PIA_IDS_QCANN
PIA_IDS_QCANN macro
PIA_IDS_QCARRAY1
PIA_IDS_QCARRAY1 macro
PIA_IDS_QCARRAY2
PIA_IDS_QCARRAY2 macro
PIA_IDS_QCARRAY3
PIA_IDS_QCARRAY3 macro
PIA_IDS_QCARRAY4
PIA_IDS_QCARRAY4 macro
PIA_IDS_QCCAL
PIA_IDS_QCCAL macro
PIA_IDS_QCDISCAL
PIA_IDS_QCDISCAL macro
PIA_IDS_QCLUMPYEAR
PIA_IDS_QCLUMPYEAR macro
PIA_IDS_QCPACKED1
PIA_IDS_QCPACKED1 macro
PIA_IDS_QCPACKED2
PIA_IDS_QCPACKED2 macro
PIA_IDS_QCTD
PIA_IDS_QCTD macro
PIA_IDS_QCTOT0
PIA_IDS_QCTOT0 macro
PIA_IDS_QTRYRQTR
PIA_IDS_QTRYRQTR macro
PIA_IDS_QTRYRYR
PIA_IDS_QTRYRYR macro
PIA_IDS_READEOF
PIA_IDS_READEOF macro
PIA_IDS_READERR
PIA_IDS_READERR macro
PIA_IDS_READMORE
PIA_IDS_READMORE macro
PIA_IDS_RELERNOUT
PIA_IDS_RELERNOUT macro
PIA_IDS_RELERNPOS
PIA_IDS_RELERNPOS macro
PIA_IDS_REQQCOUT
PIA_IDS_REQQCOUT macro
PIA_IDS_REVIEWBI
PIA_IDS_REVIEWBI macro
PIA_IDS_ROUND
PIA_IDS_ROUND macro
PIA_IDS_RTGENRL
PIA_IDS_RTGENRL macro
PIA_IDS_RWSTRING
PIA_IDS_RWSTRING macro
PIA_IDS_SECONDARY
PIA_IDS_SECONDARY macro
PIA_IDS_SETNOCH
PIA_IDS_SETNOCH macro
PIA_IDS_SEX
PIA_IDS_SEX macro
PIA_IDS_SEXOUT
PIA_IDS_SEXOUT macro
PIA_IDS_SGAPROJ
PIA_IDS_SGAPROJ macro
PIA_IDS_SMSTRING
PIA_IDS_SMSTRING macro
PIA_IDS_SPPIA1OUT
PIA_IDS_SPPIA1OUT macro
PIA_IDS_SPPIA2OUT
PIA_IDS_SPPIA2OUT macro
PIA_IDS_SPYRS2OUT
PIA_IDS_SPYRS2OUT macro
PIA_IDS_SPYRSOUT
PIA_IDS_SPYRSOUT macro
PIA_IDS_SSN1
PIA_IDS_SSN1 macro
PIA_IDS_SSNOUT
PIA_IDS_SSNOUT macro
PIA_IDS_START1
PIA_IDS_START1 macro
PIA_IDS_START2
PIA_IDS_START2 macro
PIA_IDS_SUPPIAOUT
PIA_IDS_SUPPIAOUT macro
PIA_IDS_SURVBENOUT
PIA_IDS_SURVBENOUT macro
PIA_IDS_SURVENTOUT
PIA_IDS_SURVENTOUT macro
PIA_IDS_TAXTYPE
PIA_IDS_TAXTYPE macro
PIA_IDS_TAXTYPEYR
PIA_IDS_TAXTYPEYR macro
PIA_IDS_TGSTRING
PIA_IDS_TGSTRING macro
PIA_IDS_TITLEPRO1
PIA_IDS_TITLEPRO1 macro
PIA_IDS_TITLEPRO2
PIA_IDS_TITLEPRO2 macro
PIA_IDS_TITLEPRO3
PIA_IDS_TITLEPRO3 macro
PIA_IDS_TITLEPRO4
PIA_IDS_TITLEPRO4 macro
PIA_IDS_TWOPAGE1
PIA_IDS_TWOPAGE1 macro
PIA_IDS_TWOPAGE2
PIA_IDS_TWOPAGE2 macro
PIA_IDS_TWOPAGE3
PIA_IDS_TWOPAGE3 macro
PIA_IDS_TWOPAGE4
PIA_IDS_TWOPAGE4 macro
PIA_IDS_TWOPAGE5
PIA_IDS_TWOPAGE5 macro
PIA_IDS_TXSTRING
PIA_IDS_TXSTRING macro
PIA_IDS_UNBICCHP
PIA_IDS_UNBICCHP macro
PIA_IDS_UNEARNOUT
PIA_IDS_UNEARNOUT macro
PIA_IDS_UPDATEAW
PIA_IDS_UPDATEAW macro
PIA_IDS_UPDATEBI
PIA_IDS_UPDATEBI macro
PIA_IDS_UPDATEFQ
PIA_IDS_UPDATEFQ macro
PIA_IDS_UPDATEWB
PIA_IDS_UPDATEWB macro
PIA_IDS_UPDATEWBOLD
PIA_IDS_UPDATEWBOLD macro
PIA_IDS_VALDI1
PIA_IDS_VALDI1 macro
PIA_IDS_VALDI2
PIA_IDS_VALDI2 macro
PIA_IDS_WAGEBASE
PIA_IDS_WAGEBASE macro
PIA_IDS_WAITPD1
PIA_IDS_WAITPD1 macro
PIA_IDS_WAITPD2
PIA_IDS_WAITPD2 macro
PIA_IDS_WAITPD3
PIA_IDS_WAITPD3 macro
PIA_IDS_WAITPD4
PIA_IDS_WAITPD4 macro
PIA_IDS_WAITPD5
PIA_IDS_WAITPD5 macro
PIA_IDS_WAITPD6
PIA_IDS_WAITPD6 macro
PIA_IDS_WAITPD7
PIA_IDS_WAITPD7 macro
PIA_IDS_WIDDIBOUT
PIA_IDS_WIDDIBOUT macro
PIA_IDS_WISTRING
PIA_IDS_WISTRING macro
PIA_IDS_WRITEEARN
PIA_IDS_WRITEEARN macro
PIA_IDS_YEAR
PIA_IDS_YEAR macro
PIA_TABLE enumeration member
PL_1952 enumeration member
PL_1954 enumeration member
PL_1958 enumeration member
PL_1965 enumeration member
PL_1967 enumeration member
PL_1969 enumeration member
PL_1971 enumeration member
PL_1972 enumeration member
PL_1973 enumeration member
PL_1977 enumeration member
POST1990 enumeration member
POST1995_DECONVERTED enumeration member
POST1995_NOCHANGE enumeration member
PRE1977LAW enumeration member
PRE1991 enumeration member
PRE1996_NOTLAST12 enumeration member
PRE1996_POST1978_LAST12 enumeration member
PRE1996_PRE1979_LAST12 enumeration member
PRIMARYDEATH enumeration member
PSAACCT enumeration member
PSA_FEMALE enumeration member
PSA_MALE enumeration member
PSA_NUM_SEX enumeration member
PSA_UNISEX enumeration member
PageCounters
PageCounters class
PIA_IDS_PAGE1
PIA_IDS_PAGE2
PIA_IDS_PAGE3
PageCounters
PageCounters data members
PageCounters members
PageCounters methods
about PageCounters class
deleteContents
get
read
set
update
write
~PageCounters
PageCounters::PIA_IDS_PAGE1
PageCounters::PIA_IDS_PAGE2
PageCounters::PIA_IDS_PAGE3
PageCounters::PageCounters
PageCounters::deleteContents
PageCounters::get
PageCounters::read
PageCounters::set
PageCounters::update
PageCounters::write
PageCounters::~PageCounters
PageOut
PageOut class
MAXLINES
PageOut
PageOut data members
PageOut members
PageOut methods
about PageOut class
getCount
getString
loc
outputString
prepareStrings
print
print
print method
punct
strm
~PageOut
PageOut.cpp
PageOut.h
PageOut::MAXLINES
PageOut::PageOut
PageOut::getCount
PageOut::getString
PageOut::loc
PageOut::outputString
PageOut::prepareStrings
PageOut::print
PageOut::punct
PageOut::strm
PageOut::~PageOut
Path
Path class
Path data members
Path members
Path methods
about Path class
allSeparators
altDirectorySeparatorChar
changeExtension
combine
directorySeparatorChar
getDirectoryName
getFileName
getRelativeName
Path.cpp
Path.h
Path::allSeparators
Path::altDirectorySeparatorChar
Path::changeExtension
Path::combine
Path::directorySeparatorChar
Path::getDirectoryName
Path::getFileName
Path::getRelativeName
Pebs
Pebs class
Pebs
Pebs data members
Pebs enumerations
Pebs members
Pebs methods
about Pebs class
age70
ageNow
agePlan1
agePlanCheck
deleteContents
fullRetAge
getAgePlan
getAgePlan2
getBenefitPebs
getMfbPebs
getMonthnow
getPebsDib
getPebsOab
getPiaPebs
getQcDisReq
getQcDisTotal
getQcDisYears
getQcReq
getQcTotal
monthnowCheck
monthnowCheck
monthnowCheck method
oab1
oab2
setAgePlan
setAgePlan2
setBenefitPebs
setMfbPebs
setMonthnow
setMonthnow
setMonthnow method
setPebsDib
setPebsOab
setPiaPebs
setQcDisReq
setQcDisTotal
setQcDisYears
setQcReq
setQcTotal
Pebs::Pebs
Pebs::age70
Pebs::ageNow
Pebs::agePlan1
Pebs::agePlanCheck
Pebs::deleteContents
Pebs::fullRetAge
Pebs::getAgePlan
Pebs::getAgePlan2
Pebs::getBenefitPebs
Pebs::getMfbPebs
Pebs::getMonthnow
Pebs::getPebsDib
Pebs::getPebsOab
Pebs::getPiaPebs
Pebs::getQcDisReq
Pebs::getQcDisTotal
Pebs::getQcDisYears
Pebs::getQcReq
Pebs::getQcTotal
Pebs::monthnowCheck
Pebs::oab1
Pebs::oab2
Pebs::pebes_type
Pebs::pebes_type enumeration
Pebs::setAgePlan
Pebs::setAgePlan2
Pebs::setBenefitPebs
Pebs::setMfbPebs
Pebs::setMonthnow
Pebs::setPebsDib
Pebs::setPebsOab
Pebs::setPiaPebs
Pebs::setQcDisReq
Pebs::setQcDisTotal
Pebs::setQcDisYears
Pebs::setQcReq
Pebs::setQcTotal
PebsCreditInfo
PebsCreditInfo class
PebsCreditInfo
PebsCreditInfo members
PebsCreditInfo methods
about PebsCreditInfo class
prepareStrings
~PebsCreditInfo
PebsCreditInfo.cpp
PebsCreditInfo.h
PebsCreditInfo::PebsCreditInfo
PebsCreditInfo::prepareStrings
PebsCreditInfo::~PebsCreditInfo
PebsEarnings
PebsEarnings class
PebsEarnings
PebsEarnings members
PebsEarnings methods
about PebsEarnings class
prepareStrings
~PebsEarnings
PebsEarnings.cpp
PebsEarnings.h
PebsEarnings::PebsEarnings
PebsEarnings::prepareStrings
PebsEarnings::~PebsEarnings
PebsEarningsInfo
PebsEarningsInfo class
PebsEarningsInfo
PebsEarningsInfo members
PebsEarningsInfo methods
about PebsEarningsInfo class
prepareStrings
~PebsEarningsInfo
PebsEarningsInfo.cpp
PebsEarningsInfo.h
PebsEarningsInfo::PebsEarningsInfo
PebsEarningsInfo::prepareStrings
PebsEarningsInfo::~PebsEarningsInfo
PebsLetter
PebsLetter class
PebsLetter
PebsLetter members
PebsLetter methods
about PebsLetter class
prepareStrings
~PebsLetter
PebsLetter.cpp
PebsLetter.h
PebsLetter::PebsLetter
PebsLetter::prepareStrings
PebsLetter::~PebsLetter
PebsOasdiEst
PebsOasdiEst class
PebsOasdiEst
PebsOasdiEst members
PebsOasdiEst methods
about PebsOasdiEst class
prepareStrings
~PebsOasdiEst
PebsOasdiEst.cpp
PebsOasdiEst.h
PebsOasdiEst::PebsOasdiEst
PebsOasdiEst::prepareStrings
PebsOasdiEst::~PebsOasdiEst
PebsOasdiInfo
PebsOasdiInfo class
PebsOasdiInfo
PebsOasdiInfo members
PebsOasdiInfo methods
about PebsOasdiInfo class
prepareStrings
~PebsOasdiInfo
PebsOasdiInfo.cpp
PebsOasdiInfo.h
PebsOasdiInfo::PebsOasdiInfo
PebsOasdiInfo::prepareStrings
PebsOasdiInfo::~PebsOasdiInfo
PebsOut
PebsOut class
PebsOut
PebsOut data members
PebsOut members
PebsOut methods
about PebsOut class
pebsCreditInfo
pebsEarnings
pebsEarningsInfo
pebsLetter
pebsOasdiEst
pebsOasdiInfo
pebsWorkerEarnings
pebsWorkerInfo
prepareStrings
setPageNum
~PebsOut
PebsOut.cpp
PebsOut.h
PebsOut::PebsOut
PebsOut::pebsCreditInfo
PebsOut::pebsEarnings
PebsOut::pebsEarningsInfo
PebsOut::pebsLetter
PebsOut::pebsOasdiEst
PebsOut::pebsOasdiInfo
PebsOut::pebsWorkerEarnings
PebsOut::pebsWorkerInfo
PebsOut::prepareStrings
PebsOut::setPageNum
PebsOut::~PebsOut
PebsPageOut
PebsPageOut class
PebsPageOut
PebsPageOut data members
PebsPageOut members
PebsPageOut methods
about PebsPageOut class
equals
hyphens
prepareHeader
setPageNum
~PebsPageOut
PebsPageOut.cpp
PebsPageOut.h
PebsPageOut::PebsPageOut
PebsPageOut::equals
PebsPageOut::hyphens
PebsPageOut::prepareHeader
PebsPageOut::setPageNum
PebsPageOut::~PebsPageOut
PebsWorkerEarnings
PebsWorkerEarnings class
PebsWorkerEarnings
PebsWorkerEarnings members
PebsWorkerEarnings methods
about PebsWorkerEarnings class
prepareStrings
~PebsWorkerEarnings
PebsWorkerEarnings.cpp
PebsWorkerEarnings.h
PebsWorkerEarnings::PebsWorkerEarnings
PebsWorkerEarnings::prepareStrings
PebsWorkerEarnings::~PebsWorkerEarnings
PebsWorkerInfo
PebsWorkerInfo class
PebsWorkerInfo
PebsWorkerInfo members
PebsWorkerInfo methods
about PebsWorkerInfo class
prepareStrings
~PebsWorkerInfo
PebsWorkerInfo.cpp
PebsWorkerInfo.h
PebsWorkerInfo::PebsWorkerInfo
PebsWorkerInfo::prepareStrings
PebsWorkerInfo::~PebsWorkerInfo
PercMfb
PercMfb class
PERC
PercMfb
PercMfb data members
PercMfb members
PercMfb methods
PercMfb nested types
PercMfb operators
[]
[]
[] operator
about PercMfb class
as_array
begin
begin
begin method
const_iterator
const_reference
difference_type
end
end
end method
iterator
max_size
reference
reset
size
size_type
value_type
~PercMfb
PercMfb::PERC
PercMfb::PercMfb
PercMfb::[]
PercMfb::as_array
PercMfb::begin
PercMfb::const_iterator
PercMfb::const_reference
PercMfb::difference_type
PercMfb::end
PercMfb::iterator
PercMfb::max_size
PercMfb::reference
PercMfb::reset
PercMfb::size
PercMfb::size_type
PercMfb::value_type
PercMfb::~PercMfb
PercPia
PercPia class
PERC
PercPia
PercPia data members
PercPia members
PercPia methods
PercPia nested types
PercPia operators
WINDFALL_PERC
WINDFALL_YEARS
[]
[]
[] operator
about PercPia class
as_array
begin
begin
begin method
const_iterator
const_reference
difference_type
end
end
end method
getNumPerc
iterator
max_size
reference
reset
setNumPerc
setWindfallPerc
size
size_type
value_type
~PercPia
PercPia::PERC
PercPia::PercPia
PercPia::WINDFALL_PERC
PercPia::WINDFALL_YEARS
PercPia::[]
PercPia::as_array
PercPia::begin
PercPia::const_iterator
PercPia::const_reference
PercPia::difference_type
PercPia::end
PercPia::getNumPerc
PercPia::iterator
PercPia::max_size
PercPia::reference
PercPia::reset
PercPia::setNumPerc
PercPia::setWindfallPerc
PercPia::size
PercPia::size_type
PercPia::value_type
PercPia::~PercPia
PercPiaOut
PercPiaOut class
PercPiaOut
PercPiaOut
PercPiaOut constructor
PercPiaOut members
PercPiaOut methods
about PercPiaOut class
getNumPercs
getPercPia
setData
PercPiaOut.cpp
PercPiaOut.h
PercPiaOut::PercPiaOut
PercPiaOut::getNumPercs
PercPiaOut::getPercPia
PercPiaOut::setData
PiaCal
PiaCal class
PiaCal
PiaCal data members
PiaCal members
PiaCal methods
about PiaCal class
ageEntCheck
applyLifeMfb
applyLifeMfb
applyLifeMfb method
applyMfb
applySurvivorMfb
applySurvivorMfb
applySurvivorMfb method
ardriAuxCal
ardriCal
calculate2
childCareCalc
dataCheck
dataCheckAux
deadIns
deemedInsCal
dibGuar
didropCal
didropNonFreezeCal
disInsCal
disInsNonFreezeCal
earnProjection
eligYearCal
eligYearCal1
eligYearCal2
eligYearCal3
eligYearWidowCal
fins1Cal
fins2Cal
finsNonFreeze1Cal
finsNonFreeze2Cal
frozMin
fullInsDateCal
getIoasdi
getPubpenEnable
highPiaMethod
insCal
insCal
insCal method
insNonFreezeCal
insNonFreezeCal
insNonFreezeCal method
isPebsAssumptions
monthsArAgedSpouseCal
monthsArCal
monthsArDICal
monthsArDisWidCal
monthsArWidCal
monthsDriCal
monthsYngLifeCal
monthsYngSurvCal
nCal
nDropCal
nDropNonFreezeCal
nNonFreezeCal
nelapsed2Cal
nelapsed2NonFreezeCal
nelapsedCal
nelapsedCal
nelapsedCal method
nelapsedNonFreezeCal
nelapsedNonFreezeCal
nelapsedNonFreezeCal method
oldStart
piaCal
piaCal1
piaCal2
piaCal3
piaData
piaMethod
piaParams
piaTable
qc3750simpCal
qcCal
qcCurrentCal
qcCurrentNonFreezeCal
qcReqCal
qcReqNonFreezeCal
qcReqPermCal
qcReqPermNonFreezeCal
reindWidCal
reindWidCalAll
relEarnPositionCal
releaseMemory
resetAmend90
setAmend90
setArfApp
setEligYearWidow
setHighMfb
setHighPia
setIoasdi
setPebsAssumptions
setPifc
setSupportPia
specMin
transGuar
wageInd
wageIndNonFreeze
widowCheck
widowCheck
widowCheck method
widowMethod
workerData
~PiaCal
PiaCal::PiaCal
PiaCal::ageEntCheck
PiaCal::applyLifeMfb
PiaCal::applyMfb
PiaCal::applySurvivorMfb
PiaCal::ardriAuxCal
PiaCal::ardriCal
PiaCal::calculate2
PiaCal::childCareCalc
PiaCal::dataCheck
PiaCal::dataCheckAux
PiaCal::deadIns
PiaCal::deemedInsCal
PiaCal::dibGuar
PiaCal::didropCal
PiaCal::didropNonFreezeCal
PiaCal::disInsCal
PiaCal::disInsNonFreezeCal
PiaCal::earnProjection
PiaCal::eligYearCal
PiaCal::eligYearCal1
PiaCal::eligYearCal2
PiaCal::eligYearCal3
PiaCal::eligYearWidowCal
PiaCal::fins1Cal
PiaCal::fins2Cal
PiaCal::finsNonFreeze1Cal
PiaCal::finsNonFreeze2Cal
PiaCal::frozMin
PiaCal::fullInsDateCal
PiaCal::getIoasdi
PiaCal::getPubpenEnable
PiaCal::highPiaMethod
PiaCal::insCal
PiaCal::insNonFreezeCal
PiaCal::isPebsAssumptions
PiaCal::monthsArAgedSpouseCal
PiaCal::monthsArCal
PiaCal::monthsArDICal
PiaCal::monthsArDisWidCal
PiaCal::monthsArWidCal
PiaCal::monthsDriCal
PiaCal::monthsYngLifeCal
PiaCal::monthsYngSurvCal
PiaCal::nCal
PiaCal::nDropCal
PiaCal::nDropNonFreezeCal
PiaCal::nNonFreezeCal
PiaCal::nelapsed2Cal
PiaCal::nelapsed2NonFreezeCal
PiaCal::nelapsedCal
PiaCal::nelapsedNonFreezeCal
PiaCal::oldStart
PiaCal::piaCal
PiaCal::piaCal1
PiaCal::piaCal2
PiaCal::piaCal3
PiaCal::piaData
PiaCal::piaMethod
PiaCal::piaParams
PiaCal::piaTable
PiaCal::qc3750simpCal
PiaCal::qcCal
PiaCal::qcCurrentCal
PiaCal::qcCurrentNonFreezeCal
PiaCal::qcReqCal
PiaCal::qcReqNonFreezeCal
PiaCal::qcReqPermCal
PiaCal::qcReqPermNonFreezeCal
PiaCal::reindWidCal
PiaCal::reindWidCalAll
PiaCal::relEarnPositionCal
PiaCal::releaseMemory
PiaCal::resetAmend90
PiaCal::setAmend90
PiaCal::setArfApp
PiaCal::setEligYearWidow
PiaCal::setHighMfb
PiaCal::setHighPia
PiaCal::setIoasdi
PiaCal::setPebsAssumptions
PiaCal::setPifc
PiaCal::setSupportPia
PiaCal::specMin
PiaCal::transGuar
PiaCal::wageInd
PiaCal::wageIndNonFreeze
PiaCal::widowCheck
PiaCal::widowMethod
PiaCal::workerData
PiaCal::~PiaCal
PiaCalAny
PiaCalAny class
PiaCalAny
PiaCalAny data members
PiaCalAny members
PiaCalAny methods
about PiaCalAny class
calculate1
calculate2
dataCheck
earnProSteady
earnProject
earnProjection
pebsOabCal
pebsSetup
secondaryArray
userAssumptions
widowArray
widowDataArray
~PiaCalAny
PiaCalAny.h
PiaCalAny::PiaCalAny
PiaCalAny::calculate1
PiaCalAny::calculate2
PiaCalAny::dataCheck
PiaCalAny::earnProSteady
PiaCalAny::earnProject
PiaCalAny::earnProjection
PiaCalAny::pebsOabCal
PiaCalAny::pebsSetup
PiaCalAny::secondaryArray
PiaCalAny::userAssumptions
PiaCalAny::widowArray
PiaCalAny::widowDataArray
PiaCalAny::~PiaCalAny
PiaCalLC
PiaCalLC class
PiaCalLC
PiaCalLC members
PiaCalLC methods
about PiaCalLC class
calculate2
childCareCreditCal
childCareEarningsCal
childCareMaxCreditCal
childCareQcCal
earnProjection
earnProjectionStatic
nCal
nelapsed2Cal
nelapsed2NonFreezeCal
piaCal
reindWidCal
~PiaCalLC
PiaCalLC.h
PiaCalLC::PiaCalLC
PiaCalLC::calculate2
PiaCalLC::childCareCreditCal
PiaCalLC::childCareEarningsCal
PiaCalLC::childCareMaxCreditCal
PiaCalLC::childCareQcCal
PiaCalLC::earnProjection
PiaCalLC::earnProjectionStatic
PiaCalLC::nCal
PiaCalLC::nelapsed2Cal
PiaCalLC::nelapsed2NonFreezeCal
PiaCalLC::piaCal
PiaCalLC::reindWidCal
PiaCalLC::~PiaCalLC
PiaCalPL
PiaCalPL class
PiaCalPL
PiaCalPL members
PiaCalPL methods
about PiaCalPL class
calculate2
piaCal
reindWidCal
~PiaCalPL
PiaCalPL.cpp
PiaCalPL.h
PiaCalPL::PiaCalPL
PiaCalPL::calculate2
PiaCalPL::piaCal
PiaCalPL::reindWidCal
PiaCalPL::~PiaCalPL
PiaData
PiaData Library
Classes
Files
Functions
Variables
PiaData class
=
PiaData
PiaData data members
PiaData enumerations
PiaData members
PiaData methods
PiaData operators
about PiaData class
ageBen
ageEnt
childCareMaxCredit
childCareOrder
compPeriodNew
compPeriodNewNonFreeze
compPeriodOld
deleteContents
disInsCode
disInsNonFreezeCode
earlyRetAge
earn50Cal
earnHi
earnHiCal
earnHiLimited
earnMilServ
earnOasdi
earnOasdiLimited
earnProjection
earnTotal50Cal0
earnTotal50Cal1
earnTotalized
earnTotalizedLimited
earnYearCal
finsCode
finsNonFreezeCode
freezeYears
freezeYearsCal
fullRetAge
getAmend90
getArf
getArfApp
getBirthDateMinus1
getChildCareMaxCredit
getChildCareYearsTotal
getDeemedQcReq
getEarn3750ms
getEarn50
getEarnTotal50
getEarnYear
getEligDate
getEligYear
getEligYearNonFreeze
getFinsCode2
getFinsNonFreezeCode2
getFirstQcYear
getFullInsDate
getFullRetDate
getIappn
getIapps
getIbeginAll
getIbeginTotal
getIendAll
getIendTotal
getLastQcYear
getMonthsArdri
getOverMax
getPifc
getPubpenApp
getQc3750ms
getQc3750simp
getQcCurrent
getQcCurrentNonFreeze
getQcDisDate1
getQcDisDate2
getQcDisDate3
getQcDisDate4
getQcDisDate5
getQcDisDate6
getQcDisDateNonFreeze1
getQcDisDateNonFreeze2
getQcDisQtr
getQcDisQtr2
getQcDisQtrNonFreeze
getQcDisReq
getQcDisReqNonFreeze
getQcDisYears
getQcDisYearsNonFreeze
getQcReq
getQcReqNonFreeze
getQcReqPerm
getQcReqPermNonFreeze
getQcTotal
getQcTotal50
getQcTotal51
getQcTotal51NonFreeze
getQcTotalDis
getQcTotalDisNonFreeze
getQcTotalNonFreeze
getQcTotalRel
getRelEarnPositionAverage
highMfb
highPia
initialize
partialFreezeYears
qcCal
qcDiSpec
qcDiSpecNonFreeze
qcDisCal
qcDisNonFreezeCal
qcDisReq2Cal
qcDisReqCal
qcDisReqNonFreezeCal
qcTotalCal
qcTotalNonFreezeCal
qcov
qcovMilServ
relEarnPosition
roundedBenefit
setAmend90
setArf
setArfApp
setBirthDateMinus1
setChildCareYearsTotal
setDeemedQcReq
setDoEarlyQcs
setEarn3750ms
setEligDate
setEligYear
setEligYearNonFreeze
setFinsCode2
setFinsNonFreezeCode2
setFullInsDate
setFullRetDate
setIappn
setIapps
setIbeginTotal
setIendTotal
setMonthsArdri
setOverMax
setPifc
setQc3
setQc3750ms
setQc3750simp
setQcCurrent
setQcCurrentNonFreeze
setQcReq
setQcReqNonFreeze
setQcReqPerm
setQcReqPermNonFreeze
setQcTotal
setQcTotal50
setQcTotalNonFreeze
setQcTotalRel
setRelEarnPositionAverage
supportPia
unroundedBenefit
updateMilServ
~PiaData
PiaData::=
PiaData::PiaData
PiaData::ageBen
PiaData::ageEnt
PiaData::arf_app_type
PiaData::arf_app_type enumeration
PiaData::childCareMaxCredit
PiaData::childCareOrder
PiaData::compPeriodNew
PiaData::compPeriodNewNonFreeze
PiaData::compPeriodOld
PiaData::deleteContents
PiaData::disInsCode
PiaData::disInsNonFreezeCode
PiaData::earlyRetAge
PiaData::earn50Cal
PiaData::earnHi
PiaData::earnHiCal
PiaData::earnHiLimited
PiaData::earnMilServ
PiaData::earnOasdi
PiaData::earnOasdiLimited
PiaData::earnProjection
PiaData::earnTotal50Cal0
PiaData::earnTotal50Cal1
PiaData::earnTotalized
PiaData::earnTotalizedLimited
PiaData::earnYearCal
PiaData::earn_total_type
PiaData::earn_total_type enumeration
PiaData::finsCode
PiaData::finsNonFreezeCode
PiaData::freezeYears
PiaData::freezeYearsCal
PiaData::fullRetAge
PiaData::getAmend90
PiaData::getArf
PiaData::getArfApp
PiaData::getBirthDateMinus1
PiaData::getChildCareMaxCredit
PiaData::getChildCareYearsTotal
PiaData::getDeemedQcReq
PiaData::getEarn3750ms
PiaData::getEarn50
PiaData::getEarnTotal50
PiaData::getEarnYear
PiaData::getEligDate
PiaData::getEligYear
PiaData::getEligYearNonFreeze
PiaData::getFinsCode2
PiaData::getFinsNonFreezeCode2
PiaData::getFirstQcYear
PiaData::getFullInsDate
PiaData::getFullRetDate
PiaData::getIappn
PiaData::getIapps
PiaData::getIbeginAll
PiaData::getIbeginTotal
PiaData::getIendAll
PiaData::getIendTotal
PiaData::getLastQcYear
PiaData::getMonthsArdri
PiaData::getOverMax
PiaData::getPifc
PiaData::getPubpenApp
PiaData::getQc3750ms
PiaData::getQc3750simp
PiaData::getQcCurrent
PiaData::getQcCurrentNonFreeze
PiaData::getQcDisDate1
PiaData::getQcDisDate2
PiaData::getQcDisDate3
PiaData::getQcDisDate4
PiaData::getQcDisDate5
PiaData::getQcDisDate6
PiaData::getQcDisDateNonFreeze1
PiaData::getQcDisDateNonFreeze2
PiaData::getQcDisQtr
PiaData::getQcDisQtr2
PiaData::getQcDisQtrNonFreeze
PiaData::getQcDisReq
PiaData::getQcDisReqNonFreeze
PiaData::getQcDisYears
PiaData::getQcDisYearsNonFreeze
PiaData::getQcReq
PiaData::getQcReqNonFreeze
PiaData::getQcReqPerm
PiaData::getQcReqPermNonFreeze
PiaData::getQcTotal
PiaData::getQcTotal50
PiaData::getQcTotal51
PiaData::getQcTotal51NonFreeze
PiaData::getQcTotalDis
PiaData::getQcTotalDisNonFreeze
PiaData::getQcTotalNonFreeze
PiaData::getQcTotalRel
PiaData::getRelEarnPositionAverage
PiaData::highMfb
PiaData::highPia
PiaData::initialize
PiaData::partialFreezeYears
PiaData::qcCal
PiaData::qcDiSpec
PiaData::qcDiSpecNonFreeze
PiaData::qcDisCal
PiaData::qcDisNonFreezeCal
PiaData::qcDisReq2Cal
PiaData::qcDisReqCal
PiaData::qcDisReqNonFreezeCal
PiaData::qcTotalCal
PiaData::qcTotalNonFreezeCal
PiaData::qcov
PiaData::qcovMilServ
PiaData::relEarnPosition
PiaData::roundedBenefit
PiaData::setAmend90
PiaData::setArf
PiaData::setArfApp
PiaData::setBirthDateMinus1
PiaData::setChildCareYearsTotal
PiaData::setDeemedQcReq
PiaData::setDoEarlyQcs
PiaData::setEarn3750ms
PiaData::setEligDate
PiaData::setEligYear
PiaData::setEligYearNonFreeze
PiaData::setFinsCode2
PiaData::setFinsNonFreezeCode2
PiaData::setFullInsDate
PiaData::setFullRetDate
PiaData::setIappn
PiaData::setIapps
PiaData::setIbeginTotal
PiaData::setIendTotal
PiaData::setMonthsArdri
PiaData::setOverMax
PiaData::setPifc
PiaData::setQc3
PiaData::setQc3750ms
PiaData::setQc3750simp
PiaData::setQcCurrent
PiaData::setQcCurrentNonFreeze
PiaData::setQcReq
PiaData::setQcReqNonFreeze
PiaData::setQcReqPerm
PiaData::setQcReqPermNonFreeze
PiaData::setQcTotal
PiaData::setQcTotal50
PiaData::setQcTotalNonFreeze
PiaData::setQcTotalRel
PiaData::setRelEarnPositionAverage
PiaData::supportPia
PiaData::unroundedBenefit
PiaData::updateMilServ
PiaData::~PiaData
PiaDataArray
PiaDataArray class
PiaDataArray
PiaDataArray data members
PiaDataArray enumerations
PiaDataArray members
PiaDataArray methods
about PiaDataArray class
deleteContents
famSizeCheck
getFamSize
piaData
setFamSize
~PiaDataArray
PiaDataArray::DimLimits
PiaDataArray::DimLimits enumeration
PiaDataArray::PiaDataArray
PiaDataArray::deleteContents
PiaDataArray::famSizeCheck
PiaDataArray::getFamSize
PiaDataArray::piaData
PiaDataArray::setFamSize
PiaDataArray::~PiaDataArray
PiaException
PiaException class
PiaException
PiaException
PiaException
PiaException constructor
PiaException members
PiaException methods
about PiaException class
getNumber
what
~PiaException
PiaException.cpp
PiaException.h
PiaException::PiaException
PiaException::getNumber
PiaException::what
PiaException::~PiaException
PiaMethod
PiaMethod class
PiaMethod
PiaMethod data members
PiaMethod enumerations
PiaMethod members
PiaMethod methods
about PiaMethod class
applyColas
applyColasElig
calculate
diMax
diMaxNonFreeze
dimaxElig
earnIndexed
earnMultiplied
getAme
getAmeTotal
getApplicable
getCap
getCpiYear
getIndCap
getIoasdi
getMethod
getPiaEligTotal
getPiaTotal
getPiaWindfall
getTableNum
getTitle
getWindfall
getYearsTotal
getftearn
initialize
iorder
isApplicable
isPebsAssumptions
mfbCal
mfbElig
mfbEnt
mfbsub
orderEarnings
piaData
piaElig
piaEnt
piaParams
piasub
prorate
setAme
setAmeTotal
setApplicable
setCap
setDirty
setIndCap
setIoasdi
setPebsAssumptions
setPiaEligTotal
setPiaTotal
setPiaWindfall
setPortionPiaElig
setTableNum
setYearCpi
setftearn
specMinYearsCal
specMinYearsCal
specMinYearsCal method
specMinYearsTotalCal
totalEarnCal
wep_app
workerData
yearCpi
~PiaMethod
PiaMethod.cpp
PiaMethod.h
PiaMethod::PiaMethod
PiaMethod::WindfallElimType
PiaMethod::WindfallElimType enumeration
PiaMethod::app_type
PiaMethod::app_type enumeration
PiaMethod::applyColas
PiaMethod::applyColasElig
PiaMethod::calculate
PiaMethod::cpi_year_type
PiaMethod::cpi_year_type enumeration
PiaMethod::diMax
PiaMethod::diMaxNonFreeze
PiaMethod::dimaxElig
PiaMethod::dis_mfb_cap_type
PiaMethod::dis_mfb_cap_type enumeration
PiaMethod::earnIndexed
PiaMethod::earnMultiplied
PiaMethod::getAme
PiaMethod::getAmeTotal
PiaMethod::getApplicable
PiaMethod::getCap
PiaMethod::getCpiYear
PiaMethod::getIndCap
PiaMethod::getIoasdi
PiaMethod::getMethod
PiaMethod::getPiaEligTotal
PiaMethod::getPiaTotal
PiaMethod::getPiaWindfall
PiaMethod::getTableNum
PiaMethod::getTitle
PiaMethod::getWindfall
PiaMethod::getYearsTotal
PiaMethod::getftearn
PiaMethod::initialize
PiaMethod::iorder
PiaMethod::isApplicable
PiaMethod::isPebsAssumptions
PiaMethod::mfbCal
PiaMethod::mfbElig
PiaMethod::mfbEnt
PiaMethod::mfbsub
PiaMethod::orderEarnings
PiaMethod::piaData
PiaMethod::piaElig
PiaMethod::piaEnt
PiaMethod::piaParams
PiaMethod::pia_type
PiaMethod::pia_type enumeration
PiaMethod::piasub
PiaMethod::prorate
PiaMethod::setAme
PiaMethod::setAmeTotal
PiaMethod::setApplicable
PiaMethod::setCap
PiaMethod::setDirty
PiaMethod::setIndCap
PiaMethod::setIoasdi
PiaMethod::setPebsAssumptions
PiaMethod::setPiaEligTotal
PiaMethod::setPiaTotal
PiaMethod::setPiaWindfall
PiaMethod::setPortionPiaElig
PiaMethod::setTableNum
PiaMethod::setYearCpi
PiaMethod::setftearn
PiaMethod::specMinYearsCal
PiaMethod::specMinYearsTotalCal
PiaMethod::table_type
PiaMethod::table_type enumeration
PiaMethod::totalEarnCal
PiaMethod::wep_app
PiaMethod::workerData
PiaMethod::yearCpi
PiaMethod::~PiaMethod
PiaOut
PiaOut Library
Classes
Files
PiaOut class
MAX_REINDWID
PiaOut
PiaOut data members
PiaOut members
PiaOut methods
about PiaOut class
childCareCalc1Page
childCareCalc2Page
dibGuarPage
earningsPage
familyPage
frozMinPage
insuredPage
oldStart1Page
oldStart2Page
onePage
piaTable1Page
piaTable2Page
prepareStrings
reindWid1Page
reindWid2Page
setPageNum
specMin1Page
specMin2Page
summary1Page
summary2Page
summary3Page
summaryPage
taxesPage
transGuar1Page
transGuar2Page
wageInd1Page
wageInd2Page
wageIndNonFreeze1Page
wageIndNonFreeze2Page
~PiaOut
PiaOut.cpp
PiaOut.h
PiaOut::MAX_REINDWID
PiaOut::PiaOut
PiaOut::childCareCalc1Page
PiaOut::childCareCalc2Page
PiaOut::dibGuarPage
PiaOut::earningsPage
PiaOut::familyPage
PiaOut::frozMinPage
PiaOut::insuredPage
PiaOut::oldStart1Page
PiaOut::oldStart2Page
PiaOut::onePage
PiaOut::piaTable1Page
PiaOut::piaTable2Page
PiaOut::prepareStrings
PiaOut::reindWid1Page
PiaOut::reindWid2Page
PiaOut::setPageNum
PiaOut::specMin1Page
PiaOut::specMin2Page
PiaOut::summary1Page
PiaOut::summary2Page
PiaOut::summary3Page
PiaOut::summaryPage
PiaOut::taxesPage
PiaOut::transGuar1Page
PiaOut::transGuar2Page
PiaOut::wageInd1Page
PiaOut::wageInd2Page
PiaOut::wageIndNonFreeze1Page
PiaOut::wageIndNonFreeze2Page
PiaOut::~PiaOut
PiaPageOut
PiaPageOut class
PiaPageOut
PiaPageOut data members
PiaPageOut members
PiaPageOut methods
about PiaPageOut class
baseYearOut
biOut
biOut
biOut method
compYear
disInsOut
disMfbOut
endYearCal
firstYearCal
mfbBpOut
mfbOut
mfbOut
mfbOut method
newTableOut
nonIns
nonpenOut
osTableOut
pageTitle
piaBpOut
piaEligOut
piaEntOut
piamfb1
piamfb2
piamfb3
prepareHeader
printIndexedEarningsTable
printNameSsn
printRealWageGain
pubPenOut
rawPiaOut
setPageNum
tableHead1
tableHead2
totPiaOut
~PiaPageOut
PiaPageOut.cpp
PiaPageOut.h
PiaPageOut::PiaPageOut
PiaPageOut::baseYearOut
PiaPageOut::biOut
PiaPageOut::compYear
PiaPageOut::disInsOut
PiaPageOut::disMfbOut
PiaPageOut::endYearCal
PiaPageOut::firstYearCal
PiaPageOut::mfbBpOut
PiaPageOut::mfbOut
PiaPageOut::newTableOut
PiaPageOut::nonIns
PiaPageOut::nonpenOut
PiaPageOut::osTableOut
PiaPageOut::pageTitle
PiaPageOut::piaBpOut
PiaPageOut::piaEligOut
PiaPageOut::piaEntOut
PiaPageOut::piamfb1
PiaPageOut::piamfb2
PiaPageOut::piamfb3
PiaPageOut::prepareHeader
PiaPageOut::printIndexedEarningsTable
PiaPageOut::printNameSsn
PiaPageOut::printRealWageGain
PiaPageOut::pubPenOut
PiaPageOut::rawPiaOut
PiaPageOut::setPageNum
PiaPageOut::tableHead1
PiaPageOut::tableHead2
PiaPageOut::totPiaOut
PiaPageOut::~PiaPageOut
PiaParams
PiaParams class
PiaParams
PiaParams
PiaParams constructor
PiaParams data members
PiaParams enumerations
PiaParams members
PiaParams methods
YEAR1999
about PiaParams class
age16
age18
age19
age199
age22
age50
age60
age62
age621
age65
age65_10
age65_2
age65_4
age65_6
age65_8
age66
age66_10
age66_2
age66_4
age66_6
age66_8
age67
age70
age72
age75
amend01
amend118_273
amend50
amend52
amend54
amend56
amend561
amend562
amend58
amend61
amend611
amend612
amend651
amend652
amend653
amend671
amend672
amend69
amend70
amend721
amend722
amend741
amend742
amend771
amend772
amend80
amend811
amend812
amend813
amend82
amend83
amend88
amend90
amtperincyr
applyCola
applyCola
applyCola method
applyCola99
applyColaMfb
applyColaMfb
applyColaMfb method
applyColaMfb99
arFactorWid285
arMonthlyFactor65_67
arMonthlyFactorOab62_65
arMonthlyFactorSpouse62_65
baseHi
bendOS
beninc74
benincCatchUp
birthDateFRA
bpMfbOut
bpPiaOut
catchup
childAgeForMFCal
cpiinc
deconvertPia
deemedQcReqCal
doRecalc
earlyAgeDisWidCal
earlyAgeOabCal
earlyAgeOabCalPL
earlyAgeWidCal
factor150
factor175
factor50
factor75
factor825
factorAgedSpouseCal
factorAgedSpouseCalPL
factorAgedWidCal
factorAgedWidCalPL
factorArAgedSpouseCal
factorArAgedSpouseCalPL
factorArCal
factorArCalPL
factorArDisWidCal
factorArWidCal
factorDisWidCal
factorDisWidCalPL
factorDriCal
factorYngLifeCal
factorYngSurvCal
fq
fqinc
fullRetAgeCal
fullRetAgeCalDI
fullRetAgeCalDIPL
fullRetAgeCalPL
getAverageWage
getBase77
getBase77Array
getBaseHi
getBaseHiArray
getBaseOasdi
getBaseOasdiArray
getBendOS
getBenefitInc
getCatchup
getChildcareDropoutAmount
getChildcareDropoutAmountPL
getColaCap
getCpiinc
getCpiincArray
getFq
getFqArray
getFqBppia
getFqIndex
getFqinc
getFqincArray
getIstart
getMarrLengthForDivBen
getMarrLengthForDivBenPL
getMaxChildcareAge
getMaxChildcareAgePL
getMaxChildcareDropoutYears
getMaxChildcareDropoutYearsPL
getMaxyear
getMfbColaCap
getMonthBeninc
getMonthBenincArray
getPercOS
getPercSpecMin
getPercSpecMinArray
getSpecMinMfb
getSpecMinPerc
getSpecMinPia
getYocAmountSpecMin
getYocAmountSpecMinArray
getYocAmountWindfallArray
initdata
isApplicableCola99
istart
lastAmw
lumpSum
maxChildAge
maxDibAge
maxDibAgePL
maxMonthsAr62_65
maxMonthsAr62_67
maxMonthsAr65_67
maxyear
monthBeninc
monthsArAgedSpouseCal
monthsArCal
monthsArDICal
monthsArDisWidCal
monthsArWidCal
monthsDriCal
needColaCap
needColaCap
needColaCap method
noChange
percOS
percPiaCal
percPiaOut
percSpecMin
projectCpiinc
projectFq
projectPerc
projectSpecMin
qcCal
qcamt
qtr184
recalcInd
resizeSpecMin
retCredit
ribLimCal
ribLimCalPL
setColaCap
setData
setHistFqinc
setIstart
setMfbColaCap
setNoChange
specMinAmountCal
specMinAmountCalPL
specMinMaxYears
specMinMaxYears
specMinMaxYears method
specMinMaxYearsPL
specMinMfb
specMinMfb2001
specMinPerc
specMinPia
specMinPia2001
titleAw
titleBi
unApplyCola
unApplyCola
unApplyCola method
unApplyCola99
unbiCatchUp
updateBases
updateBases
updateBases method
updateCpiinc
updateCpiinc
updateCpiinc method
updateFq
updateFqinc
updateYocAmountSpecMin
year37qtr1
yocAmountSpecMin
yocAmountWindfall
~PiaParams
PiaParams::PiaParams
PiaParams::SPECMINPERCTYPE
PiaParams::SPECMINPERCTYPE enumeration
PiaParams::YEAR1999
PiaParams::age16
PiaParams::age18
PiaParams::age19
PiaParams::age199
PiaParams::age22
PiaParams::age50
PiaParams::age60
PiaParams::age62
PiaParams::age621
PiaParams::age65
PiaParams::age65_10
PiaParams::age65_2
PiaParams::age65_4
PiaParams::age65_6
PiaParams::age65_8
PiaParams::age66
PiaParams::age66_10
PiaParams::age66_2
PiaParams::age66_4
PiaParams::age66_6
PiaParams::age66_8
PiaParams::age67
PiaParams::age70
PiaParams::age72
PiaParams::age75
PiaParams::amend01
PiaParams::amend118_273
PiaParams::amend50
PiaParams::amend52
PiaParams::amend54
PiaParams::amend56
PiaParams::amend561
PiaParams::amend562
PiaParams::amend58
PiaParams::amend61
PiaParams::amend611
PiaParams::amend612
PiaParams::amend651
PiaParams::amend652
PiaParams::amend653
PiaParams::amend671
PiaParams::amend672
PiaParams::amend69
PiaParams::amend70
PiaParams::amend721
PiaParams::amend722
PiaParams::amend741
PiaParams::amend742
PiaParams::amend771
PiaParams::amend772
PiaParams::amend80
PiaParams::amend811
PiaParams::amend812
PiaParams::amend813
PiaParams::amend82
PiaParams::amend83
PiaParams::amend88
PiaParams::amend90
PiaParams::amtperincyr
PiaParams::applyCola
PiaParams::applyCola99
PiaParams::applyColaMfb
PiaParams::applyColaMfb99
PiaParams::arFactorWid285
PiaParams::arMonthlyFactor65_67
PiaParams::arMonthlyFactorOab62_65
PiaParams::arMonthlyFactorSpouse62_65
PiaParams::baseHi
PiaParams::bendOS
PiaParams::beninc74
PiaParams::benincCatchUp
PiaParams::birthDateFRA
PiaParams::bpMfbOut
PiaParams::bpPiaOut
PiaParams::catchup
PiaParams::childAgeForMFCal
PiaParams::cpiinc
PiaParams::deconvertPia
PiaParams::deemedQcReqCal
PiaParams::doRecalc
PiaParams::earlyAgeDisWidCal
PiaParams::earlyAgeOabCal
PiaParams::earlyAgeOabCalPL
PiaParams::earlyAgeWidCal
PiaParams::factor150
PiaParams::factor175
PiaParams::factor50
PiaParams::factor75
PiaParams::factor825
PiaParams::factorAgedSpouseCal
PiaParams::factorAgedSpouseCalPL
PiaParams::factorAgedWidCal
PiaParams::factorAgedWidCalPL
PiaParams::factorArAgedSpouseCal
PiaParams::factorArAgedSpouseCalPL
PiaParams::factorArCal
PiaParams::factorArCalPL
PiaParams::factorArDisWidCal
PiaParams::factorArWidCal
PiaParams::factorDisWidCal
PiaParams::factorDisWidCalPL
PiaParams::factorDriCal
PiaParams::factorYngLifeCal
PiaParams::factorYngSurvCal
PiaParams::fq
PiaParams::fqinc
PiaParams::fullRetAgeCal
PiaParams::fullRetAgeCalDI
PiaParams::fullRetAgeCalDIPL
PiaParams::fullRetAgeCalPL
PiaParams::getAverageWage
PiaParams::getBase77
PiaParams::getBase77Array
PiaParams::getBaseHi
PiaParams::getBaseHiArray
PiaParams::getBaseOasdi
PiaParams::getBaseOasdiArray
PiaParams::getBendOS
PiaParams::getBenefitInc
PiaParams::getCatchup
PiaParams::getChildcareDropoutAmount
PiaParams::getChildcareDropoutAmountPL
PiaParams::getColaCap
PiaParams::getCpiinc
PiaParams::getCpiincArray
PiaParams::getFq
PiaParams::getFqArray
PiaParams::getFqBppia
PiaParams::getFqIndex
PiaParams::getFqinc
PiaParams::getFqincArray
PiaParams::getIstart
PiaParams::getMarrLengthForDivBen
PiaParams::getMarrLengthForDivBenPL
PiaParams::getMaxChildcareAge
PiaParams::getMaxChildcareAgePL
PiaParams::getMaxChildcareDropoutYears
PiaParams::getMaxChildcareDropoutYearsPL
PiaParams::getMaxyear
PiaParams::getMfbColaCap
PiaParams::getMonthBeninc
PiaParams::getMonthBenincArray
PiaParams::getPercOS
PiaParams::getPercSpecMin
PiaParams::getPercSpecMinArray
PiaParams::getSpecMinMfb
PiaParams::getSpecMinPerc
PiaParams::getSpecMinPia
PiaParams::getYocAmountSpecMin
PiaParams::getYocAmountSpecMinArray
PiaParams::getYocAmountWindfallArray
PiaParams::initdata
PiaParams::isApplicableCola99
PiaParams::istart
PiaParams::lastAmw
PiaParams::lumpSum
PiaParams::maxChildAge
PiaParams::maxDibAge
PiaParams::maxDibAgePL
PiaParams::maxMonthsAr62_65
PiaParams::maxMonthsAr62_67
PiaParams::maxMonthsAr65_67
PiaParams::maxyear
PiaParams::monthBeninc
PiaParams::monthsArAgedSpouseCal
PiaParams::monthsArCal
PiaParams::monthsArDICal
PiaParams::monthsArDisWidCal
PiaParams::monthsArWidCal
PiaParams::monthsDriCal
PiaParams::needColaCap
PiaParams::noChange
PiaParams::percOS
PiaParams::percPiaCal
PiaParams::percPiaOut
PiaParams::percSpecMin
PiaParams::projectCpiinc
PiaParams::projectFq
PiaParams::projectPerc
PiaParams::projectSpecMin
PiaParams::qcCal
PiaParams::qcamt
PiaParams::qtr184
PiaParams::recalcInd
PiaParams::resizeSpecMin
PiaParams::retCredit
PiaParams::ribLimCal
PiaParams::ribLimCalPL
PiaParams::setColaCap
PiaParams::setData
PiaParams::setHistFqinc
PiaParams::setIstart
PiaParams::setMfbColaCap
PiaParams::setNoChange
PiaParams::specMinAmountCal
PiaParams::specMinAmountCalPL
PiaParams::specMinMaxYears
PiaParams::specMinMaxYearsPL
PiaParams::specMinMfb
PiaParams::specMinMfb2001
PiaParams::specMinPerc
PiaParams::specMinPia
PiaParams::specMinPia2001
PiaParams::titleAw
PiaParams::titleBi
PiaParams::unApplyCola
PiaParams::unApplyCola99
PiaParams::unbiCatchUp
PiaParams::updateBases
PiaParams::updateCpiinc
PiaParams::updateFq
PiaParams::updateFqinc
PiaParams::updateYocAmountSpecMin
PiaParams::year37qtr1
PiaParams::yocAmountSpecMin
PiaParams::yocAmountWindfall
PiaParams::~PiaParams
PiaParamsAny
PiaParamsAny class
PiaParamsAny
PiaParamsAny members
PiaParamsAny methods
about PiaParamsAny class
getWageHigh
getWageHighArray
getWageMin
getWageMinArray
highProj
minProj
projectFq
~PiaParamsAny
PiaParamsAny::PiaParamsAny
PiaParamsAny::getWageHigh
PiaParamsAny::getWageHighArray
PiaParamsAny::getWageMin
PiaParamsAny::getWageMinArray
PiaParamsAny::highProj
PiaParamsAny::minProj
PiaParamsAny::projectFq
PiaParamsAny::~PiaParamsAny
PiaParamsLC
PiaParamsLC class
PiaParamsLC
PiaParamsLC
PiaParamsLC constructor
PiaParamsLC members
PiaParamsLC methods
about PiaParamsLC class
applyCola
applyCola
applyCola method
applyColaMfb
applyColaMfb
applyColaMfb method
earlyAgeOabCal
factorAgedSpouseCal
factorAgedWidCal
factorArAgedSpouseCal
factorArCal
factorDisWidCal
fullRetAgeCal
fullRetAgeCalDI
getBase77
getBase77Array
getBaseOasdi
getBaseOasdiArray
getChildcareDropoutAmount
getColaCap
getCpiinc
getCpiincArray
getFqBppia
getFqIndex
getMarrLengthForDivBen
getMaxChildcareAge
getMaxChildcareDropoutYears
getMfbColaCap
getSpecMinMfb
getSpecMinPia
initdata
maxDibAge
needColaCap
needColaCap
needColaCap method
projectCpiinc
projectFq
projectPerc
projectSpecMin
resizeSpecMin
ribLimCal
setAltCpiinc
setColaCap
setData
setFqBppia
setFqIndex
setMfbColaCap
specMinAmountCal
specMinMaxYears
specMinMaxYears
specMinMaxYears method
updateBases
updateBases
updateBases method
~PiaParamsLC
PiaParamsLC::PiaParamsLC
PiaParamsLC::applyCola
PiaParamsLC::applyColaMfb
PiaParamsLC::earlyAgeOabCal
PiaParamsLC::factorAgedSpouseCal
PiaParamsLC::factorAgedWidCal
PiaParamsLC::factorArAgedSpouseCal
PiaParamsLC::factorArCal
PiaParamsLC::factorDisWidCal
PiaParamsLC::fullRetAgeCal
PiaParamsLC::fullRetAgeCalDI
PiaParamsLC::getBase77
PiaParamsLC::getBase77Array
PiaParamsLC::getBaseOasdi
PiaParamsLC::getBaseOasdiArray
PiaParamsLC::getChildcareDropoutAmount
PiaParamsLC::getColaCap
PiaParamsLC::getCpiinc
PiaParamsLC::getCpiincArray
PiaParamsLC::getFqBppia
PiaParamsLC::getFqIndex
PiaParamsLC::getMarrLengthForDivBen
PiaParamsLC::getMaxChildcareAge
PiaParamsLC::getMaxChildcareDropoutYears
PiaParamsLC::getMfbColaCap
PiaParamsLC::getSpecMinMfb
PiaParamsLC::getSpecMinPia
PiaParamsLC::initdata
PiaParamsLC::maxDibAge
PiaParamsLC::needColaCap
PiaParamsLC::projectCpiinc
PiaParamsLC::projectFq
PiaParamsLC::projectPerc
PiaParamsLC::projectSpecMin
PiaParamsLC::resizeSpecMin
PiaParamsLC::ribLimCal
PiaParamsLC::setAltCpiinc
PiaParamsLC::setColaCap
PiaParamsLC::setData
PiaParamsLC::setFqBppia
PiaParamsLC::setFqIndex
PiaParamsLC::setMfbColaCap
PiaParamsLC::specMinAmountCal
PiaParamsLC::specMinMaxYears
PiaParamsLC::updateBases
PiaParamsLC::~PiaParamsLC
PiaParamsLCTR
PiaParamsLCTR class
PiaParamsLCTR
PiaParamsLCTR members
about PiaParamsLCTR class
~PiaParamsLCTR
PiaParamsLCTR.cpp
PiaParamsLCTR.h
PiaParamsLCTR::PiaParamsLCTR
PiaParamsLCTR::~PiaParamsLCTR
PiaParamsPL
PiaParamsPL class
PiaParamsPL
PiaParamsPL
PiaParamsPL constructor
PiaParamsPL members
PiaParamsPL methods
about PiaParamsPL class
earlyAgeOabCal
factorAgedSpouseCal
factorAgedWidCal
factorArAgedSpouseCal
factorArCal
factorDisWidCal
fullRetAgeCal
fullRetAgeCalDI
getBase77
getBase77Array
getBaseOasdi
getBaseOasdiArray
getChildcareDropoutAmount
getColaCap
getFqBppia
getFqIndex
getMarrLengthForDivBen
getMaxChildcareAge
getMaxChildcareDropoutYears
getMfbColaCap
maxDibAge
needColaCap
needColaCap
needColaCap method
projectCpiinc
ribLimCal
setColaCap
setData
setMfbColaCap
specMinAmountCal
specMinMaxYears
specMinMaxYears
specMinMaxYears method
updateBases
updateBases
updateBases method
~PiaParamsPL
PiaParamsPL::PiaParamsPL
PiaParamsPL::earlyAgeOabCal
PiaParamsPL::factorAgedSpouseCal
PiaParamsPL::factorAgedWidCal
PiaParamsPL::factorArAgedSpouseCal
PiaParamsPL::factorArCal
PiaParamsPL::factorDisWidCal
PiaParamsPL::fullRetAgeCal
PiaParamsPL::fullRetAgeCalDI
PiaParamsPL::getBase77
PiaParamsPL::getBase77Array
PiaParamsPL::getBaseOasdi
PiaParamsPL::getBaseOasdiArray
PiaParamsPL::getChildcareDropoutAmount
PiaParamsPL::getColaCap
PiaParamsPL::getFqBppia
PiaParamsPL::getFqIndex
PiaParamsPL::getMarrLengthForDivBen
PiaParamsPL::getMaxChildcareAge
PiaParamsPL::getMaxChildcareDropoutYears
PiaParamsPL::getMfbColaCap
PiaParamsPL::maxDibAge
PiaParamsPL::needColaCap
PiaParamsPL::projectCpiinc
PiaParamsPL::ribLimCal
PiaParamsPL::setColaCap
PiaParamsPL::setData
PiaParamsPL::setMfbColaCap
PiaParamsPL::specMinAmountCal
PiaParamsPL::specMinMaxYears
PiaParamsPL::updateBases
PiaParamsPL::~PiaParamsPL
PiaParamsTR
PiaParamsTR class
PiaParamsTR
PiaParamsTR data members
PiaParamsTR members
PiaParamsTR methods
about PiaParamsTR class
altNum
getAltNum
~PiaParamsTR
PiaParamsTR.cpp
PiaParamsTR.h
PiaParamsTR::PiaParamsTR
PiaParamsTR::altNum
PiaParamsTR::getAltNum
PiaParamsTR::~PiaParamsTR
PiaRead
PiaRead class
PiaRead
PiaRead data members
PiaRead members
PiaRead methods
about PiaRead class
getEarnWidth
getWidth
inputLine
lineType
parseAssump
parseAw
parseBack
parseBases
parseBases77
parseBendate
parseBi
parseBlind
parseCatchup
parseChildCareYears
parseDeath
parseDeemed
parseDisab1
parseDisab2
parseEarnHi
parseEarnOasdi
parseEarnType
parseFamilyMember
parseFwrd
parseMsdates
parseNhaddr
parseNhname
parseOabent
parsePebes
parsePubpen
parsePubpenReservist
parseQc1
parseQc2
parseSsn
parseTaxType
parseTitleaw
parseTitlebi
parseTob
parseTotalize
parseYears
read
secondaryArray
setEarnProjectYears
setEarnWidth
setPebsData
setWidth
unusedLine
userAssumptions
widowArray
widowDataArray
workerData
PiaRead::PiaRead
PiaRead::getEarnWidth
PiaRead::getWidth
PiaRead::inputLine
PiaRead::lineType
PiaRead::parseAssump
PiaRead::parseAw
PiaRead::parseBack
PiaRead::parseBases
PiaRead::parseBases77
PiaRead::parseBendate
PiaRead::parseBi
PiaRead::parseBlind
PiaRead::parseCatchup
PiaRead::parseChildCareYears
PiaRead::parseDeath
PiaRead::parseDeemed
PiaRead::parseDisab1
PiaRead::parseDisab2
PiaRead::parseEarnHi
PiaRead::parseEarnOasdi
PiaRead::parseEarnType
PiaRead::parseFamilyMember
PiaRead::parseFwrd
PiaRead::parseMsdates
PiaRead::parseNhaddr
PiaRead::parseNhname
PiaRead::parseOabent
PiaRead::parsePebes
PiaRead::parsePubpen
PiaRead::parsePubpenReservist
PiaRead::parseQc1
PiaRead::parseQc2
PiaRead::parseSsn
PiaRead::parseTaxType
PiaRead::parseTitleaw
PiaRead::parseTitlebi
PiaRead::parseTob
PiaRead::parseTotalize
PiaRead::parseYears
PiaRead::read
PiaRead::secondaryArray
PiaRead::setEarnProjectYears
PiaRead::setEarnWidth
PiaRead::setPebsData
PiaRead::setWidth
PiaRead::unusedLine
PiaRead::userAssumptions
PiaRead::widowArray
PiaRead::widowDataArray
PiaRead::workerData
PiaReadAny
PiaReadAny class
PiaReadAny
PiaReadAny members
PiaReadAny methods
about PiaReadAny class
parseBack
parseEarnOasdi
parseEarnType
parseFwrd
parsePebes
setEarnProjectYears
setPebsData
PiaReadAny::PiaReadAny
PiaReadAny::parseBack
PiaReadAny::parseEarnOasdi
PiaReadAny::parseEarnType
PiaReadAny::parseFwrd
PiaReadAny::parsePebes
PiaReadAny::setEarnProjectYears
PiaReadAny::setPebsData
PiaTable
PiaTable class
PiaTable
PiaTable members
PiaTable methods
about PiaTable class
calculate
isApplicable
isApplicable
isApplicable method
~PiaTable
PiaTable.cpp
PiaTable.h
PiaTable1Page
PiaTable1Page class
PiaTable1Page
PiaTable1Page members
PiaTable1Page methods
about PiaTable1Page class
prepareStrings
~PiaTable1Page
PiaTable1Page.cpp
PiaTable1Page.h
PiaTable1Page::PiaTable1Page
PiaTable1Page::prepareStrings
PiaTable1Page::~PiaTable1Page
PiaTable2Page
PiaTable2Page class
PiaTable2Page
PiaTable2Page members
PiaTable2Page methods
about PiaTable2Page class
prepareStrings
~PiaTable2Page
PiaTable2Page.cpp
PiaTable2Page.h
PiaTable2Page::PiaTable2Page
PiaTable2Page::prepareStrings
PiaTable2Page::~PiaTable2Page
PiaTable::PiaTable
PiaTable::calculate
PiaTable::isApplicable
PiaTable::~PiaTable
PiaTableLC
PiaTableLC class
PiaTableLC
PiaTableLC members
PiaTableLC methods
about PiaTableLC class
isApplicable
isApplicable
isApplicable method
~PiaTableLC
PiaTableLC.cpp
PiaTableLC.h
PiaTableLC::PiaTableLC
PiaTableLC::isApplicable
PiaTableLC::~PiaTableLC
PiaWrite
PiaWrite class
PiaWrite
PiaWrite data members
PiaWrite members
PiaWrite methods
about PiaWrite class
getEarnWidth
getNumDecimals
getWidth
secondaryArray
setEarnWidth
setNumDecimals
setWidth
userAssumptions
widowArray
widowDataArray
workerData
write
writeAssump
writeAw
writeBack
writeBases
writeBenDate
writeBi
writeBlind
writeChildCareYears
writeDeath
writeDeemed
writeDisab1
writeDisab2
writeEarnHi
writeEarnOasdi
writeEarnType
writeFamilyMember
writeFamilyMembers
writeFwrd
writeMsdates
writeNhaddr
writeNhname
writeOabEnt
writePebes
writePubpen
writePubpenReservist
writeQc1
writeQc2
writeRailRoad
writeSsn
writeTaxType
writeTob
writeTotalize
writeYears
PiaWrite::PiaWrite
PiaWrite::getEarnWidth
PiaWrite::getNumDecimals
PiaWrite::getWidth
PiaWrite::secondaryArray
PiaWrite::setEarnWidth
PiaWrite::setNumDecimals
PiaWrite::setWidth
PiaWrite::userAssumptions
PiaWrite::widowArray
PiaWrite::widowDataArray
PiaWrite::workerData
PiaWrite::write
PiaWrite::writeAssump
PiaWrite::writeAw
PiaWrite::writeBack
PiaWrite::writeBases
PiaWrite::writeBenDate
PiaWrite::writeBi
PiaWrite::writeBlind
PiaWrite::writeChildCareYears
PiaWrite::writeDeath
PiaWrite::writeDeemed
PiaWrite::writeDisab1
PiaWrite::writeDisab2
PiaWrite::writeEarnHi
PiaWrite::writeEarnOasdi
PiaWrite::writeEarnType
PiaWrite::writeFamilyMember
PiaWrite::writeFamilyMembers
PiaWrite::writeFwrd
PiaWrite::writeMsdates
PiaWrite::writeNhaddr
PiaWrite::writeNhname
PiaWrite::writeOabEnt
PiaWrite::writePebes
PiaWrite::writePubpen
PiaWrite::writePubpenReservist
PiaWrite::writeQc1
PiaWrite::writeQc2
PiaWrite::writeRailRoad
PiaWrite::writeSsn
PiaWrite::writeTaxType
PiaWrite::writeTob
PiaWrite::writeTotalize
PiaWrite::writeYears
PiaWriteAny
PiaWriteAny class
PiaWriteAny
PiaWriteAny members
PiaWriteAny methods
about PiaWriteAny class
writeAssump
writeBack
writeEarnOasdi
writeEarnType
writeFwrd
writePebes
PiaWriteAny::PiaWriteAny
PiaWriteAny::writeAssump
PiaWriteAny::writeBack
PiaWriteAny::writeEarnOasdi
PiaWriteAny::writeEarnType
PiaWriteAny::writeFwrd
PiaWriteAny::writePebes
PiadataArray.cpp
PiadataArray.h
Pib50Mfb
Pib50Mfb class
Pib50Mfb members
Pib50Mfb methods
about Pib50Mfb class
getAt
Pib50Mfb::getAt
Pib50Pib
Pib50Pib class
Pib50Pib members
Pib50Pib methods
about Pib50Pib class
getAt
Pib50Pib::getAt
Pib52Ame
Pib52Ame class
Pib52Ame members
Pib52Ame methods
about Pib52Ame class
getAt
Pib52Ame::getAt
Pib52Mfb
Pib52Mfb class
Pib52Mfb members
Pib52Mfb methods
about Pib52Mfb class
getAt
Pib52Mfb::getAt
Pib54Ame
Pib54Ame class
Pib54Ame members
Pib54Ame methods
about Pib54Ame class
getAt
Pib54Ame::getAt
Pib54Mfb
Pib54Mfb class
Pib54Mfb members
Pib54Mfb methods
about Pib54Mfb class
getAt
Pib54Mfb::getAt
Pib54Pia
Pib54Pia class
Pib54Pia members
Pib54Pia methods
about Pib54Pia class
getAt
Pib54Pia::getAt
Pib58Ame
Pib58Ame class
Pib58Ame members
Pib58Ame methods
about Pib58Ame class
getAt
Pib58Ame::getAt
Pib58Pib
Pib58Pib class
Pib58Pib members
Pib58Pib methods
about Pib58Pib class
getAt
Pib58Pib::getAt
Pifc
Pifc class
Pifc
Pifc members
Pifc methods
about Pifc class
get
isColable
isNewMfb
pifcCal
set
Pifc.cpp
Pifc.h
Pifc::Pifc
Pifc::get
Pifc::isColable
Pifc::isNewMfb
Pifc::pifcCal
Pifc::set
PortionAime
PortionAime class
PortionAime
PortionAime members
PortionAime methods
PortionAime nested types
PortionAime operators
[]
[]
[] operator
about PortionAime class
as_array
begin
begin
begin method
const_iterator
const_reference
deleteContents
difference_type
end
end
end method
getNumPart
iterator
max_size
reference
setNumPart
size
size_type
value_type
~PortionAime
PortionAime.cpp
PortionAime.h
PortionAime::PortionAime
PortionAime::[]
PortionAime::as_array
PortionAime::begin
PortionAime::const_iterator
PortionAime::const_reference
PortionAime::deleteContents
PortionAime::difference_type
PortionAime::end
PortionAime::getNumPart
PortionAime::iterator
PortionAime::max_size
PortionAime::reference
PortionAime::setNumPart
PortionAime::size
PortionAime::size_type
PortionAime::value_type
PortionAime::~PortionAime
PresValFacs
PresValFacs class
PresValFacs
PresValFacs members
PresValFacs methods
about PresValFacs class
project
~PresValFacs
PresValFacs.cpp
PresValFacs.h
PresValFacs::PresValFacs
PresValFacs::project
PresValFacs::~PresValFacs
Psa
Psa class
Psa
Psa data members
Psa enumerations
Psa members
Psa methods
about Psa class
annuityCal
annuityRevCal
contribAge
contribCal
contribPerc
getAdminFee
getAgeIndex
getContribRate
getInvestPerc
getLimitedYear
getMean
getMngmtFee
getPercToSpouse
getSexType
getStdDev
interpolateFactors
setParameters
~Psa
Psa.cpp
Psa.h
Psa::AnnuityType
Psa::AnnuityType enumeration
Psa::DimLimits
Psa::DimLimits enumeration
Psa::InvestmentType
Psa::InvestmentType enumeration
Psa::Psa
Psa::PsaSexType
Psa::PsaSexType enumeration
Psa::UnisexType
Psa::UnisexType enumeration
Psa::annuityCal
Psa::annuityRevCal
Psa::contribAge
Psa::contribCal
Psa::contribPerc
Psa::getAdminFee
Psa::getAgeIndex
Psa::getContribRate
Psa::getInvestPerc
Psa::getLimitedYear
Psa::getMean
Psa::getMngmtFee
Psa::getPercToSpouse
Psa::getSexType
Psa::getStdDev
Psa::interpolateFactors
Psa::setParameters
Psa::~Psa
PunctFacet
PunctFacet structure
PunctFacet data members
PunctFacet members
PunctFacet methods
about PunctFacet structure
do_grouping
getYear
yearStr
PunctFacet::do_grouping
PunctFacet::getYear
PunctFacet::yearStr
QCSBYYEAR_BIT enumeration member
Qc
Qc class
MAXQCSINYEAR
Qc data members
Qc members
Qc methods
about Qc class
check
qcCal
Qc::MAXQCSINYEAR
Qc::check
Qc::qcCal
QcArray
QcArray class
QcArray
QcArray
QcArray constructor
QcArray friends
QcArray members
QcArray methods
about QcArray class
accumulate
accumulate
accumulate method
assign
assign
assign method
class boost::serialization::access
deleteContents
deleteContents
deleteContents method
get
getLastYear
set
toString
~QcArray
QcArray.cpp
QcArray.h
QcArray::QcArray
QcArray::accumulate
QcArray::assign
QcArray::deleteContents
QcArray::get
QcArray::getLastYear
QcArray::set
QcArray::toString
QcArray::~QcArray
QcPacked
QcPacked class
NUM_QCS
QcPacked
QcPacked data members
QcPacked friends
QcPacked members
QcPacked methods
about QcPacked class
class boost::serialization::access
get
set
QcPacked.cpp
QcPacked.h
QcPacked::NUM_QCS
QcPacked::QcPacked
QcPacked::get
QcPacked::set
Qcamt
Qcamt class
AUTO_YEAR
Qcamt
Qcamt
Qcamt constructor
Qcamt data members
Qcamt members
Qcamt methods
about Qcamt class
project
qcamt1977
qcamt1978
~Qcamt
Qcamt::AUTO_YEAR
Qcamt::Qcamt
Qcamt::project
Qcamt::qcamt1977
Qcamt::qcamt1978
Qcamt::~Qcamt
QtrYear
QtrYear class
<
=
=
=
= operator
==
QtrYear
QtrYear
QtrYear
QtrYear
QtrYear
QtrYear constructor
QtrYear friends
QtrYear members
QtrYear methods
QtrYear operators
about QtrYear class
add
add
add method
check
class boost::serialization::access
deleteContents
diff
getQuarter
getYear
qtrCheck
setQuarter
setYear
subtract
subtract
subtract method
toDateMoyr
toString
yearCheck
~QtrYear
QtrYear::<
QtrYear::=
QtrYear::==
QtrYear::QtrYear
QtrYear::add
QtrYear::check
QtrYear::deleteContents
QtrYear::diff
QtrYear::getQuarter
QtrYear::getYear
QtrYear::qtrCheck
QtrYear::setQuarter
QtrYear::setYear
QtrYear::subtract
QtrYear::toDateMoyr
QtrYear::toString
QtrYear::yearCheck
QtrYear::~QtrYear
RECALC_BIT enumeration member
REDUCEDPERC enumeration member
REIND_WID enumeration member
RESERVIST_BIT enumeration member
RETROWAGEIND enumeration member
RETTESTCHG enumeration member
RailRoadData
RailRoadData class
=
RailRoadData
RailRoadData data members
RailRoadData friends
RailRoadData members
RailRoadData methods
RailRoadData operators
about RailRoadData class
class boost::serialization::access
deleteContents
earningsArray
get3750String
getDecadeEarningsString
getDecades
getEarn3750
getFirstYear
getLastYear
getQc3750
getQcString
getYearsString
isNonzero
parse3750
parseEarnings
parseQcs
parseYears
qcArray
railroadYearCheck
setEarn3750
setFirstYear
setLastYear
setQc3750
~RailRoadData
RailRoadData::=
RailRoadData::RailRoadData
RailRoadData::deleteContents
RailRoadData::earningsArray
RailRoadData::get3750String
RailRoadData::getDecadeEarningsString
RailRoadData::getDecades
RailRoadData::getEarn3750
RailRoadData::getFirstYear
RailRoadData::getLastYear
RailRoadData::getQc3750
RailRoadData::getQcString
RailRoadData::getYearsString
RailRoadData::isNonzero
RailRoadData::parse3750
RailRoadData::parseEarnings
RailRoadData::parseQcs
RailRoadData::parseYears
RailRoadData::qcArray
RailRoadData::railroadYearCheck
RailRoadData::setEarn3750
RailRoadData::setFirstYear
RailRoadData::setLastYear
RailRoadData::setQc3750
RailRoadData::~RailRoadData
ReindWid
ReindWid class
ReindWid
ReindWid data members
ReindWid members
ReindWid methods
about ReindWid class
calculate
getEligYear
initialize
isApplicable
isApplicable
isApplicable method
secondary
setEligYear
widowData
widowPiaData
~ReindWid
ReindWid.cpp
ReindWid.h
ReindWid1Page
ReindWid1Page class
ReindWid1Page
ReindWid1Page data members
ReindWid1Page members
ReindWid1Page methods
about ReindWid1Page class
prepareStrings
reindWid
~ReindWid1Page
ReindWid1Page.cpp
ReindWid1Page.h
ReindWid1Page::ReindWid1Page
ReindWid1Page::prepareStrings
ReindWid1Page::reindWid
ReindWid1Page::~ReindWid1Page
ReindWid2Page
ReindWid2Page class
ReindWid2Page
ReindWid2Page data members
ReindWid2Page members
ReindWid2Page methods
about ReindWid2Page class
prepareStrings
reindWid
~ReindWid2Page
ReindWid2Page.cpp
ReindWid2Page.h
ReindWid2Page::ReindWid2Page
ReindWid2Page::prepareStrings
ReindWid2Page::reindWid
ReindWid2Page::~ReindWid2Page
ReindWid::ReindWid
ReindWid::calculate
ReindWid::getEligYear
ReindWid::initialize
ReindWid::isApplicable
ReindWid::secondary
ReindWid::setEligYear
ReindWid::widowData
ReindWid::widowPiaData
ReindWid::~ReindWid
ReindWidLC
ReindWidLC class
ReindWidLC
ReindWidLC members
ReindWidLC methods
about ReindWidLC class
isApplicable
isApplicable
isApplicable method
~ReindWidLC
ReindWidLC.cpp
ReindWidLC.h
ReindWidLC::ReindWidLC
ReindWidLC::isApplicable
ReindWidLC::~ReindWidLC
Resource.h
RetireTest
RetireTest class
RetireTest
RetireTest
RetireTest constructor
RetireTest data members
RetireTest members
RetireTest methods
about RetireTest class
earningsTestCal
project
rtea62
rtea62m
rtea65
rtea65m
rteaHigh
RetireTest.cpp
RetireTest.h
RetireTest::RetireTest
RetireTest::earningsTestCal
RetireTest::project
RetireTest::rtea62
RetireTest::rtea62m
RetireTest::rtea65
RetireTest::rtea65m
RetireTest::rteaHigh
RtGeneral
RtGeneral class
RtGeneral
RtGeneral
RtGeneral constructor
RtGeneral members
RtGeneral methods
about RtGeneral class
convertMonthToAnnual
getMaxAgePL
project1
~RtGeneral
RtGeneral::RtGeneral
RtGeneral::convertMonthToAnnual
RtGeneral::getMaxAgePL
RtGeneral::project1
RtGeneral::~RtGeneral
Rtea62
Rtea62 class
Rtea62
Rtea62
Rtea62 constructor
Rtea62 members
about Rtea62 class
Rtea62::Rtea62
Rtea62m
Rtea62m class
Rtea62m
Rtea62m
Rtea62m constructor
Rtea62m members
Rtea62m methods
about Rtea62m class
getFraction
getHistAmount
initialize
project
Rtea62m::Rtea62m
Rtea62m::getFraction
Rtea62m::getHistAmount
Rtea62m::initialize
Rtea62m::project
Rtea65
Rtea65 class
Rtea65
Rtea65
Rtea65 constructor
Rtea65 members
about Rtea65 class
Rtea65::Rtea65
Rtea65m
Rtea65m class
Rtea65m
Rtea65m
Rtea65m constructor
Rtea65m members
Rtea65m methods
about Rtea65m class
getFraction
getHistAmount
initialize
project
Rtea65m::Rtea65m
Rtea65m::getFraction
Rtea65m::getHistAmount
Rtea65m::initialize
Rtea65m::project
RteaHigh
RteaHigh class
RteaHigh
RteaHigh members
RteaHigh methods
about RteaHigh class
getFraction
initialize
RteaHigh::RteaHigh
RteaHigh::getFraction
RteaHigh::initialize
SANFORD1 enumeration member
SANFORD2 enumeration member
SCALEAVERAGE enumeration member
SCALEHIGH enumeration member
SCALELOW enumeration member
SCALEVERYLOW enumeration member
SELFEMPRATE enumeration member
SEX_BIT enumeration member
SPEC_MIN enumeration member
SPEC_MIN_BEN enumeration member
STATELOCAL enumeration member
STOCKS enumeration member
SUPPORT_BEN enumeration member
SUPPORT_PIA enumeration member
SURVIVOR enumeration member
ScaledEarnFactors
ScaledEarnFactors class
ScaledEarnFactors
ScaledEarnFactors enumerations
ScaledEarnFactors members
ScaledEarnFactors methods
about ScaledEarnFactors class
getAverageEarnFactor
getDecimals
getFirstAge
getHighEarnFactor
getLastAge
getLowEarnFactor
getScaledEarnFactor
getVeryLowEarnFactor
getWidth
read
setAverageEarnings
setDecimals
setHighEarnings
setLowEarnings
setScaledEarnings
setVeryLowEarnings
setWidth
write
~ScaledEarnFactors
ScaledEarnFactors.cpp
ScaledEarnFactors.h
ScaledEarnFactors::ScaledEarnFactors
ScaledEarnFactors::getAverageEarnFactor
ScaledEarnFactors::getDecimals
ScaledEarnFactors::getFirstAge
ScaledEarnFactors::getHighEarnFactor
ScaledEarnFactors::getLastAge
ScaledEarnFactors::getLowEarnFactor
ScaledEarnFactors::getScaledEarnFactor
ScaledEarnFactors::getVeryLowEarnFactor
ScaledEarnFactors::getWidth
ScaledEarnFactors::read
ScaledEarnFactors::scaleType
ScaledEarnFactors::scaleType enumeration
ScaledEarnFactors::setAverageEarnings
ScaledEarnFactors::setDecimals
ScaledEarnFactors::setHighEarnings
ScaledEarnFactors::setLowEarnings
ScaledEarnFactors::setScaledEarnings
ScaledEarnFactors::setVeryLowEarnings
ScaledEarnFactors::setWidth
ScaledEarnFactors::write
ScaledEarnFactors::~ScaledEarnFactors
Secondary
Secondary class
Secondary
Secondary data members
Secondary members
Secondary methods
about Secondary class
bic
check
deleteContents
eligibleForMax
entDate
getArf
getBenefit
getBenefitFactor
getFullBenefit
getMonthsArdri
getReducedBenefit
getRoundedBenefit
isWidow
pifc
setArf
setBenefit
setBenefitFactor
setFullBenefit
setMonthsArdri
setReducedBenefit
setRoundedBenefit
Secondary.cpp
Secondary.h
Secondary::Secondary
Secondary::bic
Secondary::check
Secondary::deleteContents
Secondary::eligibleForMax
Secondary::entDate
Secondary::getArf
Secondary::getBenefit
Secondary::getBenefitFactor
Secondary::getFullBenefit
Secondary::getMonthsArdri
Secondary::getReducedBenefit
Secondary::getRoundedBenefit
Secondary::isWidow
Secondary::pifc
Secondary::setArf
Secondary::setBenefit
Secondary::setBenefitFactor
Secondary::setFullBenefit
Secondary::setMonthsArdri
Secondary::setReducedBenefit
Secondary::setRoundedBenefit
SecondaryArray
SecondaryArray class
SecondaryArray
SecondaryArray data members
SecondaryArray members
SecondaryArray methods
about SecondaryArray class
deleteContents
getTotalFullBenefit
getTotalFullBenefitMax
secondary
~SecondaryArray
SecondaryArray.cpp
SecondaryArray.h
SecondaryArray::SecondaryArray
SecondaryArray::deleteContents
SecondaryArray::getTotalFullBenefit
SecondaryArray::getTotalFullBenefitMax
SecondaryArray::secondary
SecondaryArray::~SecondaryArray
Sex
Sex class
=
Sex
Sex
Sex
Sex constructor
Sex enumerations
Sex members
Sex methods
Sex operators
about Sex class
check
toString
toString
toString method
~Sex
Sex.cpp
Sex.h
Sex::=
Sex::Sex
Sex::check
Sex::sex_type
Sex::sex_type enumeration
Sex::toString
Sex::~Sex
Sga
Sga class
Sga
Sga data members
Sga members
Sga methods
about Sga class
project
sgaBlindA
sgaBlindM
sgaMaxA
sgaMaxM
sgaMinA
sgaMinM
Sga.cpp
Sga.h
Sga::Sga
Sga::project
Sga::sgaBlindA
Sga::sgaBlindM
Sga::sgaMaxA
Sga::sgaMaxM
Sga::sgaMinA
Sga::sgaMinM
SgaBlindA
SgaBlindA class
SgaBlindA
SgaBlindA members
SgaBlindA methods
about SgaBlindA class
project
SgaBlindA::SgaBlindA
SgaBlindA::project
SgaBlindM
SgaBlindM class
SgaBlindM
SgaBlindM members
about SgaBlindM class
SgaBlindM::SgaBlindM
SgaDerived.cpp
SgaDerived.h
SgaGeneral
SgaGeneral class
FIRST_PROJ_YEAR
SgaGeneral
SgaGeneral data members
SgaGeneral members
SgaGeneral methods
about SgaGeneral class
convertMonthToAnnual
project
project1
~SgaGeneral
SgaGeneral.cpp
SgaGeneral.h
SgaGeneral::FIRST_PROJ_YEAR
SgaGeneral::SgaGeneral
SgaGeneral::convertMonthToAnnual
SgaGeneral::project
SgaGeneral::project1
SgaGeneral::~SgaGeneral
SgaMaxA
SgaMaxA class
SgaMaxA
SgaMaxA members
SgaMaxA methods
about SgaMaxA class
project
SgaMaxA::SgaMaxA
SgaMaxA::project
SgaMaxM
SgaMaxM class
SgaMaxM
SgaMaxM members
about SgaMaxM class
SgaMaxM::SgaMaxM
SgaMinA
SgaMinA class
SgaMinA
SgaMinA members
SgaMinA methods
about SgaMinA class
project
SgaMinA::SgaMinA
SgaMinA::project
SgaMinM
SgaMinM class
SgaMinM
SgaMinM members
SgaMinM methods
about SgaMinM class
project
SgaMinM::SgaMinM
SgaMinM::project
Social Security Benefit Calculator
SpecMin
SpecMin class
SpecMin
SpecMin members
SpecMin methods
about SpecMin class
calculate
getSpecMinAmount
getSpecMinYearsExcess
getYearsTotal
initialize
isApplicable
isApplicable
isApplicable method
setSpecMinAmount
setSpecMinYearsExcess
specMinYearsExcessCal
~SpecMin
SpecMin.cpp
SpecMin.h
SpecMin1Page
SpecMin1Page class
SpecMin1Page
SpecMin1Page members
SpecMin1Page methods
about SpecMin1Page class
prepareStrings
~SpecMin1Page
SpecMin1Page.cpp
SpecMin1Page.h
SpecMin1Page::SpecMin1Page
SpecMin1Page::prepareStrings
SpecMin1Page::~SpecMin1Page
SpecMin2Page
SpecMin2Page class
SpecMin2Page
SpecMin2Page members
SpecMin2Page methods
about SpecMin2Page class
prepareStrings
~SpecMin2Page
SpecMin2Page.cpp
SpecMin2Page.h
SpecMin2Page::SpecMin2Page
SpecMin2Page::prepareStrings
SpecMin2Page::~SpecMin2Page
SpecMin::SpecMin
SpecMin::calculate
SpecMin::getSpecMinAmount
SpecMin::getSpecMinYearsExcess
SpecMin::getYearsTotal
SpecMin::initialize
SpecMin::isApplicable
SpecMin::setSpecMinAmount
SpecMin::setSpecMinYearsExcess
SpecMin::specMinYearsExcessCal
SpecMin::~SpecMin
SpecMinLC
SpecMinLC class
SpecMinLC
SpecMinLC members
SpecMinLC methods
about SpecMinLC class
isApplicable
isApplicable
isApplicable method
specMinYearsExcessCal
~SpecMinLC
SpecMinLC.cpp
SpecMinLC.h
SpecMinLC::SpecMinLC
SpecMinLC::isApplicable
SpecMinLC::specMinYearsExcessCal
SpecMinLC::~SpecMinLC
Ssn
Ssn class
<
=
==
Ssn
Ssn
Ssn
Ssn
Ssn constructor
Ssn friends
Ssn members
Ssn methods
Ssn operators
about Ssn class
class boost::serialization::access
deleteContents
getPart1
getPart2
getPart3
setPart1
setPart2
setPart3
setSsnFull
setSsnFull
setSsnFull method
toNumber
toString
toString
toString method
update
~Ssn
Ssn::<
Ssn::=
Ssn::==
Ssn::Ssn
Ssn::deleteContents
Ssn::getPart1
Ssn::getPart2
Ssn::getPart3
Ssn::setPart1
Ssn::setPart2
Ssn::setPart3
Ssn::setSsnFull
Ssn::toNumber
Ssn::toString
Ssn::update
Ssn::~Ssn
StringParser.cpp
StringParser.h
Summary1Page
Summary1Page class
Summary1Page
Summary1Page members
Summary1Page methods
about Summary1Page class
prepareStrings
printDisInfo
~Summary1Page
Summary1Page.cpp
Summary1Page.h
Summary1Page::Summary1Page
Summary1Page::prepareStrings
Summary1Page::printDisInfo
Summary1Page::~Summary1Page
Summary2Page
Summary2Page class
Summary2Page
Summary2Page members
Summary2Page methods
about Summary2Page class
prepareStrings
~Summary2Page
Summary2Page.cpp
Summary2Page.h
Summary2Page::Summary2Page
Summary2Page::prepareStrings
Summary2Page::~Summary2Page
Summary3Page
Summary3Page class
Summary3Page
Summary3Page members
Summary3Page methods
about Summary3Page class
bottom3
disclaimer
nonInsPara
prepareStrings
~Summary3Page
Summary3Page.cpp
Summary3Page.h
Summary3Page::Summary3Page
Summary3Page::bottom3
Summary3Page::disclaimer
Summary3Page::nonInsPara
Summary3Page::prepareStrings
Summary3Page::~Summary3Page
SummaryPage
SummaryPage class
SummaryPage
SummaryPage members
SummaryPage methods
about SummaryPage class
prepareStrings
~SummaryPage
SummaryPage.cpp
SummaryPage.h
SummaryPage::SummaryPage
SummaryPage::prepareStrings
SummaryPage::~SummaryPage
TAXBENCHG enumeration member
TAXRATECHG enumeration member
TOTALIZED enumeration member
TOTALIZE_BIT enumeration member
TRANSGUAR1 enumeration member
TRANSGUAR3 enumeration member
TRANSGUAR4 enumeration member
TRANSITIONAL enumeration member
TRANS_GUAR enumeration member
TaxBenefits
TaxBenefits class
HiYear
MARRIEDOASDHITAX
MARRIEDOASDHITHRESHOLD
MARRIEDOASDITHRESHOLD
OasdhiRate
OasdiRate
SINGLEOASDHITAX
SINGLEOASDHITHRESHOLD
SINGLEOASDITHRESHOLD
START_YEAR
TaxBenefits
TaxBenefits data members
TaxBenefits members
TaxBenefits methods
about TaxBenefits class
deductionsCal
getProportion
getThreshold
taxOasdhi
taxOasdi
~TaxBenefits
TaxBenefits.cpp
TaxBenefits.h
TaxBenefits::HiYear
TaxBenefits::MARRIEDOASDHITAX
TaxBenefits::MARRIEDOASDHITHRESHOLD
TaxBenefits::MARRIEDOASDITHRESHOLD
TaxBenefits::OasdhiRate
TaxBenefits::OasdiRate
TaxBenefits::SINGLEOASDHITAX
TaxBenefits::SINGLEOASDHITHRESHOLD
TaxBenefits::SINGLEOASDITHRESHOLD
TaxBenefits::START_YEAR
TaxBenefits::TaxBenefits
TaxBenefits::deductionsCal
TaxBenefits::getProportion
TaxBenefits::getThreshold
TaxBenefits::taxOasdhi
TaxBenefits::taxOasdi
TaxBenefits::~TaxBenefits
TaxBenefitsLC
TaxBenefitsLC class
TaxBenefitsLC
TaxBenefitsLC members
TaxBenefitsLC methods
about TaxBenefitsLC class
deductionsCal
getProportion
getThreshold
paymentsCal
taxOasdhi
thresholdsCal
~TaxBenefitsLC
TaxBenefitsLC.cpp
TaxBenefitsLC.h
TaxBenefitsLC::TaxBenefitsLC
TaxBenefitsLC::deductionsCal
TaxBenefitsLC::getProportion
TaxBenefitsLC::getThreshold
TaxBenefitsLC::paymentsCal
TaxBenefitsLC::taxOasdhi
TaxBenefitsLC::thresholdsCal
TaxBenefitsLC::~TaxBenefitsLC
TaxData
TaxData class
TaxData
TaxData data members
TaxData enumerations
TaxData members
TaxData methods
about TaxData class
getTaxesTotal
oasdhiTaxCal
taxesDi
taxesHi
taxesOasdhi
taxesOasdi
taxesOasi
totalTaxCal
~TaxData
TaxData.cpp
TaxData.h
TaxData::TaxData
TaxData::YEAR_GROUP
TaxData::YEAR_GROUP enumeration
TaxData::getTaxesTotal
TaxData::oasdhiTaxCal
TaxData::taxesDi
TaxData::taxesHi
TaxData::taxesOasdhi
TaxData::taxesOasdi
TaxData::taxesOasi
TaxData::totalTaxCal
TaxData::~TaxData
TaxRates
TaxRates class
LAST_TAX_RATE_YEAR
NUMTAXRATES
TaxRates
TaxRates data members
TaxRates enumerations
TaxRates members
TaxRates methods
about TaxRates class
getTaxRatesGross
getTaxRatesNet
initialize
maxyear
setCredits
setGrossRates
setHistCredits
setHistRates
setNetRates
taxCalAllYears
taxCalOneYearGross
taxCalOneYearNet
~TaxRates
TaxRates.cpp
TaxRates.h
TaxRates::LAST_TAX_RATE_YEAR
TaxRates::NUMTAXRATES
TaxRates::TaxRates
TaxRates::getTaxRatesGross
TaxRates::getTaxRatesNet
TaxRates::initialize
TaxRates::maxyear
TaxRates::setCredits
TaxRates::setGrossRates
TaxRates::setHistCredits
TaxRates::setHistRates
TaxRates::setNetRates
TaxRates::taxCalAllYears
TaxRates::taxCalOneYearGross
TaxRates::taxCalOneYearNet
TaxRates::taxrateType
TaxRates::taxrateType enumeration
TaxRates::trustfundType
TaxRates::trustfundType enumeration
TaxRates::~TaxRates
TaxRatesLC
TaxRatesLC class
TaxRatesLC
TaxRatesLC data members
TaxRatesLC members
TaxRatesLC methods
about TaxRatesLC class
initialize
lawChange
~TaxRatesLC
TaxRatesLC.cpp
TaxRatesLC.h
TaxRatesLC::TaxRatesLC
TaxRatesLC::initialize
TaxRatesLC::lawChange
TaxRatesLC::~TaxRatesLC
TaxRatesPL
TaxRatesPL class
TaxRatesPL
TaxRatesPL members
TaxRatesPL methods
about TaxRatesPL class
initialize
~TaxRatesPL
TaxRatesPL.cpp
TaxRatesPL.h
TaxRatesPL::TaxRatesPL
TaxRatesPL::initialize
TaxRatesPL::~TaxRatesPL
TaxesPage
TaxesPage class
TaxesPage
TaxesPage members
TaxesPage methods
about TaxesPage class
prepareStrings
~TaxesPage
TaxesPage.cpp
TaxesPage.h
TaxesPage::TaxesPage
TaxesPage::prepareStrings
TaxesPage::~TaxesPage
TextWriterTraceListener
TextWriterTraceListener class
TextWriterTraceListener
TextWriterTraceListener members
TextWriterTraceListener methods
about TextWriterTraceListener class
close
flush
write
write
write method
writeLine
writeLine
writeLine method
~TextWriterTraceListener
TextWriterTraceListener.cpp
TextWriterTraceListener.h
TextWriterTraceListener::TextWriterTraceListener
TextWriterTraceListener::close
TextWriterTraceListener::flush
TextWriterTraceListener::write
TextWriterTraceListener::writeLine
TextWriterTraceListener::~TextWriterTraceListener
Trace
Trace class
Trace members
Trace methods
about Trace class
close
flush
getListeners
write
write
write method
writeLine
writeLine
writeLine method
Trace.cpp
Trace.h
Trace::close
Trace::flush
Trace::getListeners
Trace::write
Trace::writeLine
TraceListener
TraceListener class
TraceListener
TraceListener members
TraceListener methods
about TraceListener class
close
flush
write
write
write method
writeLine
writeLine
writeLine method
~TraceListener
TraceListener.cpp
TraceListener.h
TraceListener::TraceListener
TraceListener::close
TraceListener::flush
TraceListener::write
TraceListener::writeLine
TraceListener::~TraceListener
TransGuar
TransGuar class
TransGuar
TransGuar data members
TransGuar members
TransGuar methods
about TransGuar class
bendMfb
calculate
initialize
isApplicable
isApplicable
isApplicable method
percMfb
portionPiaElig
~TransGuar
TransGuar.cpp
TransGuar.h
TransGuar1Page
TransGuar1Page class
TransGuar1Page
TransGuar1Page members
TransGuar1Page methods
about TransGuar1Page class
prepareStrings
~TransGuar1Page
TransGuar1Page.cpp
TransGuar1Page.h
TransGuar1Page::TransGuar1Page
TransGuar1Page::prepareStrings
TransGuar1Page::~TransGuar1Page
TransGuar2Page
TransGuar2Page class
TransGuar2Page
TransGuar2Page members
TransGuar2Page methods
about TransGuar2Page class
prepareStrings
~TransGuar2Page
TransGuar2Page.cpp
TransGuar2Page.h
TransGuar2Page::TransGuar2Page
TransGuar2Page::prepareStrings
TransGuar2Page::~TransGuar2Page
TransGuar::TransGuar
TransGuar::bendMfb
TransGuar::calculate
TransGuar::initialize
TransGuar::isApplicable
TransGuar::percMfb
TransGuar::portionPiaElig
TransGuar::~TransGuar
TransGuarLC
TransGuarLC class
TransGuarLC
TransGuarLC members
TransGuarLC methods
about TransGuarLC class
isApplicable
isApplicable
isApplicable method
~TransGuarLC
TransGuarLC.cpp
TransGuarLC.h
TransGuarLC::TransGuarLC
TransGuarLC::isApplicable
TransGuarLC::~TransGuarLC
UNINSURED enumeration member
UNISEX_JS_NOT_SL enumeration member
UNISEX_SL_AND_JS enumeration member
UNISEX_SL_NOT_JS enumeration member
UserAssumptions
UserAssumptions class
UserAssumptions
UserAssumptions data members
UserAssumptions members
UserAssumptions methods
about UserAssumptions class
anscchCheck
awincproj
base77
baseOasdi
biproj
catchup
deleteContents
getAnscch
getIaltaw
getIaltbi
getIbasch
getIstart
getJaltaw
getJaltbi
getJbasch
istartCheck
pebsasmCheck
resetTriggers
setAnscch
setIaltaw
setIaltbi
setIbasch
setIstart
setJaltaw
setJaltbi
setJbasch
setLastYear
setTitleAw
setTitleBi
titleAw
titleBi
zeroJalt
UserAssumptions.cpp
UserAssumptions.h
UserAssumptions::UserAssumptions
UserAssumptions::anscchCheck
UserAssumptions::awincproj
UserAssumptions::base77
UserAssumptions::baseOasdi
UserAssumptions::biproj
UserAssumptions::catchup
UserAssumptions::deleteContents
UserAssumptions::getAnscch
UserAssumptions::getIaltaw
UserAssumptions::getIaltbi
UserAssumptions::getIbasch
UserAssumptions::getIstart
UserAssumptions::getJaltaw
UserAssumptions::getJaltbi
UserAssumptions::getJbasch
UserAssumptions::istartCheck
UserAssumptions::pebsasmCheck
UserAssumptions::resetTriggers
UserAssumptions::setAnscch
UserAssumptions::setIaltaw
UserAssumptions::setIaltbi
UserAssumptions::setIbasch
UserAssumptions::setIstart
UserAssumptions::setJaltaw
UserAssumptions::setJaltbi
UserAssumptions::setJbasch
UserAssumptions::setLastYear
UserAssumptions::setTitleAw
UserAssumptions::setTitleBi
UserAssumptions::titleAw
UserAssumptions::titleBi
UserAssumptions::zeroJalt
WAGEBASECHG enumeration member
WAGE_IND enumeration member
WAGE_IND_NON_FREEZE enumeration member
WIDFACTOR enumeration member
WIFEFACTOR enumeration member
WINDFALL enumeration member
WageBase
WageBase class
WageBase
WageBase
WageBase constructor
WageBase members
about WageBase class
WageBase.cpp
WageBase.h
WageBase::WageBase
WageBaseGeneral
WageBaseGeneral class
WageBaseGeneral
WageBaseGeneral
WageBaseGeneral constructor
WageBaseGeneral data members
WageBaseGeneral members
WageBaseGeneral methods
about WageBaseGeneral class
check
defcomp
earnLimit
project
projectLC
wageBaseInd
~WageBaseGeneral
WageBaseGeneral::WageBaseGeneral
WageBaseGeneral::check
WageBaseGeneral::defcomp
WageBaseGeneral::earnLimit
WageBaseGeneral::project
WageBaseGeneral::projectLC
WageBaseGeneral::wageBaseInd
WageBaseGeneral::~WageBaseGeneral
WageBaseHI
WageBaseHI class
WageBaseHI
WageBaseHI
WageBaseHI constructor
WageBaseHI members
about WageBaseHI class
WageBaseHI::WageBaseHI
WageBaseLC
WageBaseLC class
WageBaseLC
WageBaseLC
WageBaseLC constructor
WageBaseLC members
WageBaseLC methods
about WageBaseLC class
project
WageBaseLC::WageBaseLC
WageBaseLC::project
WageBaseOldLaw
WageBaseOldLaw class
WageBaseOldLaw
WageBaseOldLaw
WageBaseOldLaw constructor
WageBaseOldLaw members
about WageBaseOldLaw class
WageBaseOldLaw::WageBaseOldLaw
WageBaseOldLawLC
WageBaseOldLawLC class
WageBaseOldLawLC
WageBaseOldLawLC
WageBaseOldLawLC constructor
WageBaseOldLawLC members
WageBaseOldLawLC methods
about WageBaseOldLawLC class
project
WageBaseOldLawLC::WageBaseOldLawLC
WageBaseOldLawLC::project
WageInd
WageInd class
WageInd
WageInd members
WageInd methods
about WageInd class
calculate
isApplicable
isApplicable
isApplicable method
~WageInd
WageInd.cpp
WageInd.h
WageInd1Page
WageInd1Page class
WageInd1Page
WageInd1Page members
WageInd1Page methods
about WageInd1Page class
prepareStrings
~WageInd1Page
WageInd1Page.cpp
WageInd1Page.h
WageInd1Page::WageInd1Page
WageInd1Page::prepareStrings
WageInd1Page::~WageInd1Page
WageInd2Page
WageInd2Page class
WageInd2Page
WageInd2Page members
WageInd2Page methods
about WageInd2Page class
prepareStrings
~WageInd2Page
WageInd2Page.cpp
WageInd2Page.h
WageInd2Page::WageInd2Page
WageInd2Page::prepareStrings
WageInd2Page::~WageInd2Page
WageInd::WageInd
WageInd::calculate
WageInd::isApplicable
WageInd::~WageInd
WageIndGeneral
WageIndGeneral class
WageIndGeneral
WageIndGeneral data members
WageIndGeneral members
WageIndGeneral methods
about WageIndGeneral class
aimepiaCal
bendMfb
bendPia
bendPointCal
deconvertAme
getIndexYearAvgWage
getWindfall
getYearsTotal
indexEarnings
indexYearAvgWage
initialize
mfbRealWageGain
percMfb
percPia
percWind
piaRealWageGain
portionAime
portionPiaElig
realWageGainAdj
setPortionAime
setWindfall
windfallCal
windfallInd
yearsTotal
~WageIndGeneral
WageIndGeneral.cpp
WageIndGeneral.h
WageIndGeneral::WageIndGeneral
WageIndGeneral::aimepiaCal
WageIndGeneral::bendMfb
WageIndGeneral::bendPia
WageIndGeneral::bendPointCal
WageIndGeneral::deconvertAme
WageIndGeneral::getIndexYearAvgWage
WageIndGeneral::getWindfall
WageIndGeneral::getYearsTotal
WageIndGeneral::indexEarnings
WageIndGeneral::indexYearAvgWage
WageIndGeneral::initialize
WageIndGeneral::mfbRealWageGain
WageIndGeneral::percMfb
WageIndGeneral::percPia
WageIndGeneral::percWind
WageIndGeneral::piaRealWageGain
WageIndGeneral::portionAime
WageIndGeneral::portionPiaElig
WageIndGeneral::realWageGainAdj
WageIndGeneral::setPortionAime
WageIndGeneral::setWindfall
WageIndGeneral::windfallCal
WageIndGeneral::windfallInd
WageIndGeneral::yearsTotal
WageIndGeneral::~WageIndGeneral
WageIndLC
WageIndLC class
WageIndLC
WageIndLC members
WageIndLC methods
about WageIndLC class
isApplicable
isApplicable
isApplicable method
~WageIndLC
WageIndLC.cpp
WageIndLC.h
WageIndLC::WageIndLC
WageIndLC::isApplicable
WageIndLC::~WageIndLC
WageIndNonFreeze
WageIndNonFreeze class
WageIndNonFreeze
WageIndNonFreeze members
WageIndNonFreeze methods
about WageIndNonFreeze class
calculate
indexEarnings
isApplicable
isApplicable
isApplicable method
~WageIndNonFreeze
WageIndNonFreeze.cpp
WageIndNonFreeze.h
WageIndNonFreeze1Page
WageIndNonFreeze1Page class
WageIndNonFreeze1Page
WageIndNonFreeze1Page members
WageIndNonFreeze1Page methods
about WageIndNonFreeze1Page class
prepareStrings
~WageIndNonFreeze1Page
WageIndNonFreeze1Page.cpp
WageIndNonFreeze1Page.h
WageIndNonFreeze1Page::WageIndNonFreeze1Page
WageIndNonFreeze1Page::prepareStrings
WageIndNonFreeze1Page::~WageIndNonFreeze1Page
WageIndNonFreeze2Page
WageIndNonFreeze2Page class
WageIndNonFreeze2Page
WageIndNonFreeze2Page members
WageIndNonFreeze2Page methods
about WageIndNonFreeze2Page class
prepareStrings
~WageIndNonFreeze2Page
WageIndNonFreeze2Page.cpp
WageIndNonFreeze2Page.h
WageIndNonFreeze2Page::WageIndNonFreeze2Page
WageIndNonFreeze2Page::prepareStrings
WageIndNonFreeze2Page::~WageIndNonFreeze2Page
WageIndNonFreeze::WageIndNonFreeze
WageIndNonFreeze::calculate
WageIndNonFreeze::indexEarnings
WageIndNonFreeze::isApplicable
WageIndNonFreeze::~WageIndNonFreeze
WorkerData
WorkerData class
WorkerData
WorkerData data members
WorkerData enumerations
WorkerData friends
WorkerData members
WorkerData methods
about WorkerData class
anySelfEmp
class boost::serialization::access
deleteContents
deleteOabCessDate
deleteOabEntDate
deletePubpenDate
earnHi
earnOasdi
getEarnHi
getEarnHiOnly
getEarnMS
getEarnMS3750
getEarnOasdhi
getEarnOasdi
getEarnRR
getEarnRR3750
getFirstYearEarn
getFirstYearEarnHi
getFirstYearMS
getFirstYearRR
getIdNumber
getIdString
getIndms
getLastYearEarn
getLastYearEarnHi
getLastYearMS
getLastYearRR
getNhaddr
getNhname
getOabCessDate
getOabEntDate
getPubpen
getPubpenDate
getPubpenReservist
getQcovMS
getQcovMS3750
getQcovRR
getQcovRR3750
getQcovRR5177
getTaxType
getTaxTypeArray
milServDatesVec
pubpenDateCheck2
railRoadData
setEarnHi
setEarnOasdi
setNhaddr
setNhname
setOabCessDate
setOabEntDate
setPubpen
setPubpenDate
setPubpenReservist
setTaxType
ssn
taxType
zeroEarn
zeroEarnHi
zeroEarnOasdi
~WorkerData
WorkerData::DimLimits
WorkerData::DimLimits enumeration
WorkerData::WorkerData
WorkerData::anySelfEmp
WorkerData::deleteContents
WorkerData::deleteOabCessDate
WorkerData::deleteOabEntDate
WorkerData::deletePubpenDate
WorkerData::earnHi
WorkerData::earnOasdi
WorkerData::getEarnHi
WorkerData::getEarnHiOnly
WorkerData::getEarnMS
WorkerData::getEarnMS3750
WorkerData::getEarnOasdhi
WorkerData::getEarnOasdi
WorkerData::getEarnRR
WorkerData::getEarnRR3750
WorkerData::getFirstYearEarn
WorkerData::getFirstYearEarnHi
WorkerData::getFirstYearMS
WorkerData::getFirstYearRR
WorkerData::getIdNumber
WorkerData::getIdString
WorkerData::getIndms
WorkerData::getLastYearEarn
WorkerData::getLastYearEarnHi
WorkerData::getLastYearMS
WorkerData::getLastYearRR
WorkerData::getNhaddr
WorkerData::getNhname
WorkerData::getOabCessDate
WorkerData::getOabEntDate
WorkerData::getPubpen
WorkerData::getPubpenDate
WorkerData::getPubpenReservist
WorkerData::getQcovMS
WorkerData::getQcovMS3750
WorkerData::getQcovRR
WorkerData::getQcovRR3750
WorkerData::getQcovRR5177
WorkerData::getTaxType
WorkerData::getTaxTypeArray
WorkerData::milServDatesVec
WorkerData::pubpenDateCheck2
WorkerData::railRoadData
WorkerData::setEarnHi
WorkerData::setEarnOasdi
WorkerData::setNhaddr
WorkerData::setNhname
WorkerData::setOabCessDate
WorkerData::setOabEntDate
WorkerData::setPubpen
WorkerData::setPubpenDate
WorkerData::setPubpenReservist
WorkerData::setTaxType
WorkerData::ssn
WorkerData::taxType
WorkerData::zeroEarn
WorkerData::zeroEarnHi
WorkerData::zeroEarnOasdi
WorkerData::~WorkerData
WorkerDataArray
WorkerDataArray class
WorkerDataArray
WorkerDataArray data members
WorkerDataArray enumerations
WorkerDataArray members
WorkerDataArray methods
about WorkerDataArray class
deleteContents
famSizeCheck
getFamSize
setFamSize
workerData
~WorkerDataArray
WorkerDataArray.cpp
WorkerDataArray.h
WorkerDataArray::DimLimits
WorkerDataArray::DimLimits enumeration
WorkerDataArray::WorkerDataArray
WorkerDataArray::deleteContents
WorkerDataArray::famSizeCheck
WorkerDataArray::getFamSize
WorkerDataArray::setFamSize
WorkerDataArray::workerData
WorkerDataArray::~WorkerDataArray
WorkerDataGeneral
WorkerDataGeneral class
WorkerDataGeneral
WorkerDataGeneral
WorkerDataGeneral constructor
WorkerDataGeneral data members
WorkerDataGeneral enumerations
WorkerDataGeneral friends
WorkerDataGeneral members
WorkerDataGeneral methods
about WorkerDataGeneral class
anySelfEmp
benefitDate1Check
benefitDate1Check
benefitDate1Check method
benefitDate2Check
benefitDate2Check
benefitDate2Check method
birth1Check
birth1Check
birth1Check method
birth2Check
birth2Check
birth2Check method
cessation1Check
cessation1Check
cessation1Check method
cessation1OnsetCheck
cessationCheck
cessationCheck2
childCareYears
class boost::serialization::access
deathCheck
deathCheck
deathCheck method
deathCheck1
deathCheck2
deathCheck3
deleteContents
deleteDeathDate
deleteEntDate
dis1Check
dis1Check
dis1Check method
disBirthEntCheck
disCheck
disCheck
disCheck method
disDeathCheck
disabPeriod
earningsCheck
earningsCheck
earningsCheck method
entCheck
entCheck
entCheck method
firstEarnHiYear
getBenefitDate
getBirthDate
getBlindind
getDeathDate
getDeceasedOAB
getDeemedind
getEarliestEntDate
getEarnEnable
getEarnHi
getEarnHiOnly
getEarnMS
getEarnMS3750
getEarnOasdhi
getEarnOasdi
getEarnRR
getEarnRR3750
getEntDate
getFirstYearMS
getFirstYearRR
getIbegin
getIdNumber
getIdString
getIend
getIndearn
getIndms
getIndrr
getJoasdi
getLastYearMS
getLastYearRR
getMaxyear
getMqge
getNhaddr
getNhname
getOabCessDate
getOabEntDate
getPubpen
getPubpenDate
getPubpenReservist
getQcLumpYear
getQcovMS
getQcovMS3750
getQcovRR
getQcovRR3750
getQcovRR5177
getQctot51td
getQctottd
getRecalc
getReservist
getSex
getTaxType
getTotalize
getValdi
hasQcsByYear
ibegin1Check
ibegin2Check
ibeginCheck
ibeginCheck
ibeginCheck method
iendCheck
isFemale
isMale
isPrimary
isalive
isdead
isdead
isdead method
joasdiCheck
joasdiCheck
joasdiCheck method
lastQcyr
maxyear
needDiCess
needDiCess
needDiCess method
needQcsByYear
need_aw
need_bases
need_bi
priorent1Check
priorent1Check
priorent1Check method
priorentCheck
priorentCheck
priorentCheck method
pubpenCheck
pubpenDateCheck
qc
qc51tdCheck
qcCheck
qcCheck
qcCheck method
qclumpyear
qctdCheck
qctdCheck2
setBenefitDate
setBenefitDate
setBenefitDate method
setBirthDate
setBlindind
setCessationDate
setCessationMfb
setCessationPia
setDeathDate
setDeceasedOAB
setDeemedind
setEarnHi
setEarnOasdi
setEntDate
setIbegin
setIend
setIndearn
setIndrr
setJoasdi
setMaxyear
setMqge
setNhaddr
setNhname
setOabCessDate
setOabEntDate
setOnsetDate
setPebsData
setPebsEarn
setPriorentDate
setPriorentDateCheck
setPubpen
setPubpenDate
setPubpenReservist
setQc51td
setQcLumpYear
setQcsByYear
setQctd
setRecalc
setReservist
setSex
setTaxType
setTotalize
setValdi
setWaitperDate
setWaitperDate
setWaitperDate method
taxTypeCheck
valdi1Check
valdi2Check
valdiCheck
waitpd1Check
waitpd1Check
waitpd1Check method
waitpdCheck
waitpdCheck
waitpdCheck method
zeroEarn
zeroEarnHi
zeroEarnOasdi
zeroOasdi
~WorkerDataGeneral
WorkerDataGeneral.cpp
WorkerDataGeneral.h
WorkerDataGeneral::BitsetMembers
WorkerDataGeneral::BitsetMembers enumeration
WorkerDataGeneral::DimLimits
WorkerDataGeneral::DimLimits enumeration
WorkerDataGeneral::WorkerDataGeneral
WorkerDataGeneral::anySelfEmp
WorkerDataGeneral::ben_type
WorkerDataGeneral::ben_type enumeration
WorkerDataGeneral::benefitDate1Check
WorkerDataGeneral::benefitDate2Check
WorkerDataGeneral::birth1Check
WorkerDataGeneral::birth2Check
WorkerDataGeneral::cessation1Check
WorkerDataGeneral::cessation1OnsetCheck
WorkerDataGeneral::cessationCheck
WorkerDataGeneral::cessationCheck2
WorkerDataGeneral::childCareYears
WorkerDataGeneral::deathCheck
WorkerDataGeneral::deathCheck1
WorkerDataGeneral::deathCheck2
WorkerDataGeneral::deathCheck3
WorkerDataGeneral::deleteContents
WorkerDataGeneral::deleteDeathDate
WorkerDataGeneral::deleteEntDate
WorkerDataGeneral::dis1Check
WorkerDataGeneral::disBirthEntCheck
WorkerDataGeneral::disCheck
WorkerDataGeneral::disDeathCheck
WorkerDataGeneral::disabPeriod
WorkerDataGeneral::earningsCheck
WorkerDataGeneral::entCheck
WorkerDataGeneral::firstEarnHiYear
WorkerDataGeneral::getBenefitDate
WorkerDataGeneral::getBirthDate
WorkerDataGeneral::getBlindind
WorkerDataGeneral::getDeathDate
WorkerDataGeneral::getDeceasedOAB
WorkerDataGeneral::getDeemedind
WorkerDataGeneral::getEarliestEntDate
WorkerDataGeneral::getEarnEnable
WorkerDataGeneral::getEarnHi
WorkerDataGeneral::getEarnHiOnly
WorkerDataGeneral::getEarnMS
WorkerDataGeneral::getEarnMS3750
WorkerDataGeneral::getEarnOasdhi
WorkerDataGeneral::getEarnOasdi
WorkerDataGeneral::getEarnRR
WorkerDataGeneral::getEarnRR3750
WorkerDataGeneral::getEntDate
WorkerDataGeneral::getFirstYearMS
WorkerDataGeneral::getFirstYearRR
WorkerDataGeneral::getIbegin
WorkerDataGeneral::getIdNumber
WorkerDataGeneral::getIdString
WorkerDataGeneral::getIend
WorkerDataGeneral::getIndearn
WorkerDataGeneral::getIndms
WorkerDataGeneral::getIndrr
WorkerDataGeneral::getJoasdi
WorkerDataGeneral::getLastYearMS
WorkerDataGeneral::getLastYearRR
WorkerDataGeneral::getMaxyear
WorkerDataGeneral::getMqge
WorkerDataGeneral::getNhaddr
WorkerDataGeneral::getNhname
WorkerDataGeneral::getOabCessDate
WorkerDataGeneral::getOabEntDate
WorkerDataGeneral::getPubpen
WorkerDataGeneral::getPubpenDate
WorkerDataGeneral::getPubpenReservist
WorkerDataGeneral::getQcLumpYear
WorkerDataGeneral::getQcovMS
WorkerDataGeneral::getQcovMS3750
WorkerDataGeneral::getQcovRR
WorkerDataGeneral::getQcovRR3750
WorkerDataGeneral::getQcovRR5177
WorkerDataGeneral::getQctot51td
WorkerDataGeneral::getQctottd
WorkerDataGeneral::getRecalc
WorkerDataGeneral::getReservist
WorkerDataGeneral::getSex
WorkerDataGeneral::getTaxType
WorkerDataGeneral::getTotalize
WorkerDataGeneral::getValdi
WorkerDataGeneral::hasQcsByYear
WorkerDataGeneral::ibegin1Check
WorkerDataGeneral::ibegin2Check
WorkerDataGeneral::ibeginCheck
WorkerDataGeneral::iendCheck
WorkerDataGeneral::isFemale
WorkerDataGeneral::isMale
WorkerDataGeneral::isPrimary
WorkerDataGeneral::isalive
WorkerDataGeneral::isdead
WorkerDataGeneral::joasdiCheck
WorkerDataGeneral::lastQcyr
WorkerDataGeneral::maxyear
WorkerDataGeneral::needDiCess
WorkerDataGeneral::needQcsByYear
WorkerDataGeneral::need_aw
WorkerDataGeneral::need_bases
WorkerDataGeneral::need_bi
WorkerDataGeneral::priorent1Check
WorkerDataGeneral::priorentCheck
WorkerDataGeneral::pubpenCheck
WorkerDataGeneral::pubpenDateCheck
WorkerDataGeneral::qc
WorkerDataGeneral::qc51tdCheck
WorkerDataGeneral::qcCheck
WorkerDataGeneral::qclumpyear
WorkerDataGeneral::qctdCheck
WorkerDataGeneral::qctdCheck2
WorkerDataGeneral::setBenefitDate
WorkerDataGeneral::setBirthDate
WorkerDataGeneral::setBlindind
WorkerDataGeneral::setCessationDate
WorkerDataGeneral::setCessationMfb
WorkerDataGeneral::setCessationPia
WorkerDataGeneral::setDeathDate
WorkerDataGeneral::setDeceasedOAB
WorkerDataGeneral::setDeemedind
WorkerDataGeneral::setEarnHi
WorkerDataGeneral::setEarnOasdi
WorkerDataGeneral::setEntDate
WorkerDataGeneral::setIbegin
WorkerDataGeneral::setIend
WorkerDataGeneral::setIndearn
WorkerDataGeneral::setIndrr
WorkerDataGeneral::setJoasdi
WorkerDataGeneral::setMaxyear
WorkerDataGeneral::setMqge
WorkerDataGeneral::setNhaddr
WorkerDataGeneral::setNhname
WorkerDataGeneral::setOabCessDate
WorkerDataGeneral::setOabEntDate
WorkerDataGeneral::setOnsetDate
WorkerDataGeneral::setPebsData
WorkerDataGeneral::setPebsEarn
WorkerDataGeneral::setPriorentDate
WorkerDataGeneral::setPriorentDateCheck
WorkerDataGeneral::setPubpen
WorkerDataGeneral::setPubpenDate
WorkerDataGeneral::setPubpenReservist
WorkerDataGeneral::setQc51td
WorkerDataGeneral::setQcLumpYear
WorkerDataGeneral::setQcsByYear
WorkerDataGeneral::setQctd
WorkerDataGeneral::setRecalc
WorkerDataGeneral::setReservist
WorkerDataGeneral::setSex
WorkerDataGeneral::setTaxType
WorkerDataGeneral::setTotalize
WorkerDataGeneral::setValdi
WorkerDataGeneral::setWaitperDate
WorkerDataGeneral::taxTypeCheck
WorkerDataGeneral::valdi1Check
WorkerDataGeneral::valdi2Check
WorkerDataGeneral::valdiCheck
WorkerDataGeneral::waitpd1Check
WorkerDataGeneral::waitpdCheck
WorkerDataGeneral::zeroEarn
WorkerDataGeneral::zeroEarnHi
WorkerDataGeneral::zeroEarnOasdi
WorkerDataGeneral::zeroOasdi
WorkerDataGeneral::~WorkerDataGeneral
YEAR2075
YEAR2075 variable
YEAR2080
YEAR2080 variable
YEAR2085
YEAR2085 variable
YEAR2090
YEAR2090 variable
YEAR2095
YEAR2095 variable
YEAR2100
YEAR2100 variable
YEAR2105
YEAR2105 variable
YEAR2200
YEAR2200 variable
YEAR36
YEAR36 variable
YEAR37
YEAR37 variable
YEAR50
YEAR50 variable
YEAR51
YEAR51 variable
YEAR69
YEAR69 variable
YEAR70
YEAR70 variable
YEAR74
YEAR74 variable
YEAR75
YEAR75 variable
YEAR79
YEAR79 variable
YEARS1937PLUS enumeration member
YEARS1937_50 enumeration member
YEAR_BEN enumeration member
YEAR_ELIG enumeration member
YEAR_ENT enumeration member
YEAR_TABLE enumeration member
_AFXDLL
_AFXDLL macro
age.cpp
age.h
avgwg.cpp
avgwg.h
awbidat.cpp
awbidat.h
awbidtfl.cpp
awbidtnf.cpp
awinc.cpp
awinc.h
awincfl.cpp
awincnf.cpp
B
baseyear.cpp
baseyear.h
baseyrfl.cpp
baseyrnf.cpp
bendmfb.cpp
bendmfb.h
bendpia.cpp
bendpia.h
bic.h
biproj.cpp
biproj.h
biprojfl.cpp
biprojnf.cpp
bpmfbout.cpp
bpmfbout.h
bppiaout.cpp
bppiaout.h
C
cachpdoc.cpp
cachup.cpp
cachup.h
cachupf.h
cachupfl.cpp
cachupnf.cpp
comma.cpp
comma.h
comppd.h
config.cpp
config.h
configFile.cpp
configNonFile.cpp
D
date.cpp
date.h
datemoyr.cpp
datemoyr.h
dbleann.cpp
dbleann.h
dblemth.cpp
dblemth.h
dbleqtr.cpp
dbleqtr.h
dinscode.cpp
dinscode.h
document.cpp
document.h
F
floatann.cpp
floatann.h
floatmth.cpp
floatmth.h
floatqtr.cpp
floatqtr.h
foinfo.cpp
foinfo.h
foinfofl.cpp
foinfonf.cpp
friend class boost::serialization::access
frzyrs.cpp
frzyrs.h
G
genfile.cpp
genfile.h
I
inscode.cpp
inscode.h
intann.cpp
intann.h
isDebugPid
isDebugPid function
M
msdates.cpp
msdates.h
msdatesvec.cpp
O
oactcnst.h
oldpia.cpp
oldstart.cpp
outfile.cpp
outfile.h
P
page.cpp
page.h
parseString
parseString function
pblank
pblank function
pcomma
pcomma function
pebs.cpp
pebs.h
percmfb.cpp
percmfb.h
percpia.cpp
percpia.h
piacal.cpp
piacal.h
piacalany.cpp
piacallc.cpp
piadata.cpp
piadata.h
piaparms.cpp
piaparms.h
piaparmsAny.cpp
piaparmsAny.h
piaparmsLC.cpp
piaparmsLC.h
piaparmsPL.cpp
piaparmsPL.h
piaread.cpp
piaread.h
piareadAny.cpp
piareadAny.h
piawrite.cpp
piawrite.h
piawriteAny.cpp
piawriteAny.h
pib50mfb.cpp
pib50pib.cpp
pib52ame.cpp
pib52mfb.cpp
pib54ame.cpp
pib54mfb.cpp
pib54pia.cpp
pib58ame.cpp
pib58pib.cpp
pibtable.h
Q
qc.cpp
qc.h
qcamt.cpp
qcamt.h
qtryear.cpp
qtryear.h
R
railroad.cpp
railroad.h
rtgenrl.cpp
rtgenrl.h
S
ssn.cpp
ssn.h
W
wbgenrl.cpp
wbgenrl.h
wbgenrlLC.cpp
wbgenrlLC.h
wrkrdata.cpp
wrkrdata.h


Welcome

Version 1.0